GXSysHelp v.2.5: Introduction

 GXScene v.2.5 for FMX

Introduction

GXScene is an OpenGL based 3D library for Delphi and C++Builder. It provides visual components and objects allowing description and effective rendering of 3D scenes. GXScene is not only an OpenGL wrapper or utility library, but it's grown to become a set of founding classes for a generic 3D engine for the Rapid Application Development. GXScene allows you to design and render 3D scenes quickly and without having to learn the intricacies of OpenGL: if you know how to design a TForm, you'll easily master the basic operation of TGXScene. Make sure to checkout the introduction tutorial included in the help folder. GXScene includes more than many components and a variety of founding classes. The library comes with a comfortable set of demos showcasing the ease of use and demonstrating RAD wasn't done at the expense of CPU horsepower. The GXScene Sound System allows positional 3D audio via low-level APIs like FMOD, BASS, OpenAL and WaveOut. Advanced demos and samples could be found in the project directory GXScene\Examples. Some additional options for compiler are in GLScene.Defines.inc (activated/deactivated, all are inactive by default): The option DEFINE Graphics32_SUPPORT controls support Alex Denissov's Graphics32 library (http://www.graphics32.org), once activated will redirect assignments from TBitmap32 to TGLBitmap32.

GLXS Team

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: All Units

All Units

Name Description
FMxCUDAEditor

The graphics engine GXScene https://github.com/glscene
FMxGuiLayoutEditor

The graphics engine GXScene https://github.com/glscene
FMxInfo

The graphics engine GXScene https://github.com/glscene
FMXLibMaterialPicker

The graphics engine GXScene https://github.com/glscene
FMxMaterialEditor

The graphics engine GXScene https://github.com/glscene
FMxSceneEditor

The graphics engine GXScene https://github.com/glscene
FMxShaderMemo

The graphics engine GXScene https://github.com/glscene
FMxShaderUniformEditor

The graphics engine GXScene https://github.com/glscene
FMxSkinEditor

The graphics engine GXScene https://github.com/glscene
FMxXCollectionEditor

The graphics engine GXScene https://github.com/glscene
Formatx.DDSImage

The graphics engine GXScene https://github.com/glscene
Formatx.HDRImage

The graphics engine GXScene https://github.com/glscene
Formatx.Q3MD3

The graphics engine GXScene https://github.com/glscene
Formatx.TGA

The graphics engine GXScene https://github.com/glscene
FRxColorEditor

The graphics engine GXScene https://github.com/glscene
FRxFaceEditor

The graphics engine GXScene https://github.com/glscene
FRxMaterialPreview

The graphics engine GXScene https://github.com/glscene
FRxTextureEdit

The graphics engine GXScene https://github.com/glscene
GBE.Clouds

GBE.ConeExtend

GBE.CubeExtend

GBE.Cubemap

GBE.CylinderExtend

GBE.Grass

GBE.Heightmap

GBE.Joystick

GBE.omOceanWaves

GBE.PlaneExtend

GBE.PlayerPosition

GBE.SphereExtend

GBE.Terrain

GBE.TimeLine

GBE.Viewport3D

GLScene.AnimationUtils

The graphics engine GLScene https://github.com/glscene
GLScene.GeometryBB

The graphics engine GLScene https://github.com/glscene
GLScene.Keyboard

The graphics engine GLScene https://github.com/glscene
GLScene.Logger

The graphics engine GLScene https://github.com/glscene
GLScene.Manager

The graphics engine GLScene https://github.com/glscene
GLScene.OpenGL4

The graphics engine GXScene https://github.com/glscene
GLScene.OpenGLTokens

The graphics engine GLScene https://github.com/glscene
GLScene.PipelineTransform

The graphics engine GLScene https://github.com/glscene
GLScene.Polynomials

The graphics engine GLScene https://github.com/glscene
GLScene.RandomLib

The graphics engine GLScene https://github.com/glscene
GLScene.RedBlackTree

The graphics engine GXScene https://github.com/glscene
GLScene.RGBE

The graphics engine GLScene https://github.com/glscene
GLScene.Spline

The graphics engine GLScene https://github.com/glscene
GLScene.Strings

The graphics engine GLScene https://github.com/glscene
GLScene.TextureFormat

The graphics engine GLScene https://github.com/glscene
GLScene.Triangulation

The graphics engine GLScene https://github.com/glscene
GLScene.Utils

The graphics engine GLScene https://github.com/glscene
GLScene.VectorGeometry

The graphics engine GLScene https://github.com/glscene
GLScene.VectorTypes

The graphics engine GLScene https://github.com/glscene
GLScene.VectorTypesExt

The graphics engine GLScene https://github.com/glscene
GLScene.XCollection

The graphics engine GLScene https://github.com/glscene
GLScene.XCollectionRegister

The graphics engine GXScene https://github.com/glscene
GXS.AnimatedSprite

The graphics engine GXScene https://github.com/glscene
GXS.ApplicationFileIO

The graphics engine GXScene https://github.com/glscene
GXS.ArchiveManager

The graphics engine GXScene https://github.com/glscene
GXS.AsyncHDS

/ The graphics engine GXScene https://github.com/glscene
GXS.AsyncTimer

The graphics engine GXScene https://github.com/glscene
GXS.Atmosphere

The graphics engine GXScene https://github.com/glscene
GXS.AVIRecorder

The graphics engine GXScene https://github.com/glscene
GXS.BaseMeshSilhouette

The graphics engine GXScene https://github.com/glscene
GXS.Behaviours

The graphics engine GXScene https://github.com/glscene
GXS.BitmapFont

The graphics engine GXScene https://github.com/glscene
GXS.Blur

The graphics engine GXScene https://github.com/glscene
GXS.BSP

The graphics engine GXScene https://github.com/glscene
GXS.BumpmapHDS

The graphics engine GXScene https://github.com/glscene
GXS.BumpMapping

The graphics engine GXScene https://github.com/glscene
GXS.Cadencer

The graphics engine GXScene https://github.com/glscene
GXS.CameraController

The graphics engine GXScene https://github.com/glscene
GXS.Canvas

The graphics engine GXScene https://github.com/glscene
GXS.CelShader

The graphics engine GXScene https://github.com/glscene
GXS.CgBombShader

The graphics engine GLScene https://github.com/glscene
GXS.CgPostTransformationShader

The graphics engine GLScene https://github.com/glscene
GXS.CgRegister

The graphics engine GXScene https://github.com/glscene
GXS.CgShader

The graphics engine GLScene https://github.com/glscene
GXS.Collision

The graphics engine GXScene https://github.com/glscene
GXS.CompositeImage

The graphics engine GXScene https://github.com/glscene
GXS.Console

The graphics engine GXScene https://github.com/glscene
GXS.Context

The graphics engine GXScene https://github.com/glscene
GXS.CUDA.API

The graphics engine GXScene https://github.com/glscene
GXS.CUDA.Compiler

The graphics engine GXScene https://github.com/glscene
GXS.CUDA.Context

The graphics engine GXScene https://github.com/glscene
GXS.CUDA.FFTPlan

The graphics engine GXScene https://github.com/glscene
GXS.CUDA.Graphics

The graphics engine GXScene https://github.com/glscene
GXS.CyborgManager

GXS.DCE

* The graphics engine GXScene https://github.com/glscene
GXS.DCEMisc

* The graphics engine GXScene https://github.com/glscene
GXS.DwsObjects

Base classes and logic for DelphiWebScript enabled objects
GXS.DynamicTexture

* The graphics engine GXScene https://github.com/glscene
GXS.EllipseCollision

The graphics engine GXScene https://github.com/glscene
GXS.EParticleMasksManager

The graphics engine GXScene https://github.com/glscene
GXS.ExplosionFx

The graphics engine GXScene https://github.com/glscene
GXS.Extrusion

The graphics engine GXScene https://github.com/glscene
GXS.FBO

The graphics engine GXScene https://github.com/glscene
GXS.FBORenderer

The graphics engine GXScene https://github.com/glscene
GXS.Feedback

The graphics engine GXScene https://github.com/glscene
GXS.File3DS

The graphics engine GXScene https://github.com/glscene
GXS.File3DSSceneObjects

Graphic Scene Engine, http://glscene.org
GXS.FileASE

The graphics engine GXScene https://github.com/glscene
GXS.FileB3D

The graphics engine GXScene https://github.com/glscene
GXS.FileBMP

The graphics engine GXScene https://github.com/glscene
GXS.FileDAE

Quake2 MD2 vector file format implementation.
GXS.FileDDS

The graphics engine GXScene https://github.com/glscene
GXS.FileDXF

The graphics engine GXScene https://github.com/glscene
GXS.FileGL2

Vector file object loading of Ghoul2 model and animation files.
GXS.FileGLTF

The graphics engine GXScene https://github.com/glscene
GXS.FileGRD

The graphics engine GXScene https://github.com/glscene
GXS.FileGTS

The graphics engine GXScene https://github.com/glscene
GXS.FileHDR

The graphics engine GXScene https://github.com/glscene
GXS.FileJPEG

The graphics engine GXScene https://github.com/glscene
GXS.FileLMTS

The graphics engine GXScene https://github.com/glscene
GXS.FileLWO

The graphics engine GXScene https://github.com/glscene
GXS.FileMD2

The graphics engine GXScene https://github.com/glscene
GXS.FileMD3

The graphics engine GXScene https://github.com/glscene
GXS.FileMD5

The graphics engine GXScene https://github.com/glscene
GXS.FileMDC

The graphics engine GXScene https://github.com/glscene
GXS.FileMP3

The graphics engine GXScene https://github.com/glscene
GXS.FileMS3D

The graphics engine GXScene https://github.com/glscene
GXS.FileNMF

The graphics engine GXScene https://github.com/glscene
GXS.FileNurbs

The graphics engine GXScene https://github.com/glscene
GXS.FileOBJ

The graphics engine GXScene https://github.com/glscene
GXS.FileOCT

The graphics engine GXScene https://github.com/glscene
GXS.FilePGM

Graphic Scene Engine, http://glscene.org
GXS.FilePLY

The graphics engine GXScene https://github.com/glscene
GXS.FilePNG

The graphics engine GXScene https://github.com/glscene
GXS.FileQ3BSP

The graphics engine GXScene https://github.com/glscene
GXS.FileSMD

The graphics engine GXScene https://github.com/glscene
GXS.FileSTL

The graphics engine GXScene https://github.com/glscene
GXS.FileTGA

The graphics engine GXScene https://github.com/glscene
GXS.FileTIN

The graphics engine GXScene https://github.com/glscene
GXS.FileVRML

The graphics engine GXScene https://github.com/glscene
GXS.FileWAV

The graphics engine GXScene https://github.com/glscene
GXS.FileX

The graphics engine GXScene https://github.com/glscene
GXS.FileZLIB

Graphic Scene Engine, http://glscene.org
GXS.FireFX

The graphics engine GXScene https://github.com/glscene
GXS.FMX.Viewer

This unit is part of the GLScene Project, http://glscene.org
GXS.FPSMovement

The graphics engine GXScene https://github.com/glscene
GXS.FullScreenViewer

The graphics engine GXScene https://github.com/glscene
GXS.GameMenu

The graphics engine GXScene https://github.com/glscene
GXS.GeomObjects

The graphics engine GXScene https://github.com/glscene
GXS.Gizmo

The graphics engine GXScene https://github.com/glscene
GXS.GizmoEx

The graphics engine GXScene https://github.com/glscene
GXS.GPURegister

The graphics engine GXScene https://github.com/glscene
GXS.Graph

The graphics engine GXScene https://github.com/glscene
GXS.Graphics

The graphics engine GXScene https://github.com/glscene
GXS.Gui

The graphics engine GXScene https://github.com/glscene
GXS.HeightData

The graphics engine GXScene https://github.com/glscene
GXS.HeightTileFile

The graphics engine GXScene https://github.com/glscene
GXS.HeightTileFileHDS

The graphics engine GXScene https://github.com/glscene
GXS.HiddenLineShader

The graphics engine GXScene https://github.com/glscene
GXS.HUDObjects

The graphics engine GXScene https://github.com/glscene
GXS.ImageUtils

The graphics engine GXScene https://github.com/glscene
GXS.Imposter

The graphics engine GXScene https://github.com/glscene
GXS.InitOpenGL

The graphics engine GXScene https://github.com/glscene
GXS.Isolines

The graphics engine GXScene https://github.com/glscene
GXS.Isosurface

The graphics engine GXScene https://github.com/glscene
GXS.Joystick

The graphics engine GXScene https://github.com/glscene
GXS.LensFlare

The graphics engine GXScene https://github.com/glscene
GXS.LinePFX

The graphics engine GXScene https://github.com/glscene
GXS.Material

The graphics engine GXScene https://github.com/glscene
GXS.MaterialMultiProxy

The graphics engine GXScene https://github.com/glscene
GXS.MaterialScript

The graphics engine GXScene https://github.com/glscene
GXS.Mesh

The graphics engine GXScene https://github.com/glscene
GXS.MeshBuilder

The graphics engine GXScene https://github.com/glscene
GXS.MeshCSG

The graphics engine GXScene https://github.com/glscene
GXS.MeshLines

The graphics engine GXScene https://github.com/glscene
GXS.MeshOptimizer

The graphics engine GXScene https://github.com/glscene
GXS.MeshUtils

The graphics engine GXScene https://github.com/glscene
GXS.Mirror

The graphics engine GXScene https://github.com/glscene
GXS.Movement

The graphics engine GXScene https://github.com/glscene
GXS.MultiMaterialShader

The graphics engine GXScene https://github.com/glscene
GXS.MultiPolygon

The graphics engine GXScene https://github.com/glscene
GXS.MultiProxy

The graphics engine GXScene https://github.com/glscene
GXS.MultisampleImage

The graphics engine GXScene https://github.com/glscene
GXS.Navigator

The graphics engine GXScene https://github.com/glscene
GXS.NGDManager

The graphics engine GXScene https://github.com/glscene
GXS.NGDRagdoll

The graphics engine GXScene https://github.com/glscene
GXS.Nodes

The graphics engine GXScene https://github.com/glscene
GXS.ObjectManager

The graphics engine GXScene https://github.com/glscene
GXS.Objects

The graphics engine GXScene https://github.com/glscene
GXS.Octree

The graphics engine GXScene https://github.com/glscene
GXS.ODEManager

The graphics engine GXScene https://github.com/glscene
GXS.ODERagdoll

The graphics engine GXScene https://github.com/glscene
GXS.ODESkeletonColliders

The graphics engine GXScene https://github.com/glscene
GXS.ODEUtils

The graphics engine GXScene https://github.com/glscene
GXS.OpenGLAdapter

The graphics engine GLScene https://github.com/glscene
GXS.OutlineShader

The graphics engine GXScene https://github.com/glscene
GXS.PAKArchive

The graphics engine GXScene https://github.com/glscene
GXS.ParallelRegister

The graphics engine GXScene https://github.com/glscene
GXS.ParametricSurfaces

The graphics engine GXScene https://github.com/glscene
GXS.ParticleFX

The graphics engine GXScene https://github.com/glscene
GXS.Particles

The graphics engine GXScene https://github.com/glscene
GXS.Perlin

The graphics engine GXScene https://github.com/glscene
GXS.PerlinPFX

The graphics engine GXScene https://github.com/glscene
GXS.PhysFields

The graphics engine GLScene https://github.com/glscene
GXS.PhysForces

The graphics engine GLScene https://github.com/glscene
GXS.Physics.Register

The graphics engine GXScene https://github.com/glscene
GXS.PhysInertias

The graphics engine GLScene https://github.com/glscene
GXS.PhysJoints

The graphics engine GLScene https://github.com/glscene
GXS.PhysManager

The graphics engine GLScene https://github.com/glscene
GXS.PhysX

The graphics engine GXScene https://github.com/glscene
GXS.PictureRegisteredFormats

The graphics engine GXScene https://github.com/glscene
GXS.PolygonTesselation

The graphics engine GXScene https://github.com/glscene
GXS.Portal

The graphics engine GXScene https://github.com/glscene
GXS.ProcTextures

The graphics engine GXScene https://github.com/glscene
GXS.ProjectedTextures

The graphics engine GXScene https://github.com/glscene
GXS.ProxyObjects

The graphics engine GXScene https://github.com/glscene
GXS.Python.Script

The graphics rendering engine GLScene http://glscene.org
GXS.Ragdoll

The graphics engine GXScene https://github.com/glscene
GXS.RandomHDS

The graphics engine GXScene https://github.com/glscene
GXS.RegisterXCollection

Register TXCollection property editor
GXS.RenderContextInfo

The graphics engine GXScene https://github.com/glscene
GXS.ROAMPatch

The graphics engine GXScene https://github.com/glscene
GXS.Scene

The graphics engine GXScene https://github.com/glscene
GXS.SceneRegister

The graphics engine GXScene https://github.com/glscene
GXS.SceneViewer

The graphics engine GXScene https://github.com/glscene
GXS.Screen

The graphics engine GXScene https://github.com/glscene
GXS.ScreenSaver

The graphics engine GXScene https://github.com/glscene
GXS.ScriptBase

The graphics engine GXScene https://github.com/glscene
GXS.Selection

The graphics engine GXScene https://github.com/glscene
GXS.ShadowHDS

The graphics engine GXScene https://github.com/glscene
GXS.ShadowPlane

The graphics engine GXScene https://github.com/glscene
GXS.ShadowVolume

The graphics engine GXScene https://github.com/glscene
GXS.Silhouette

The graphics engine GXScene https://github.com/glscene
GXS.SimpleNavigation

The graphics engine GXScene https://github.com/glscene
GXS.Skydome

The graphics engine GXScene https://github.com/glscene
GXS.SmartObjects

The graphics engine GLScene https://github.com/glscene
GXS.SmoothNavigator

The graphics engine GXScene https://github.com/glscene
GXS.SoundFileObjects

The graphics engine GXScene https://github.com/glscene
GXS.SoundManager

The graphics engine GXScene https://github.com/glscene
GXS.Sounds.BASS

The graphics engine GXScene https://github.com/glscene
GXS.Sounds.FMOD

========================================================================================== FMOD Main header file. Copyright (c), FireLight Technologies Pty, Ltd. 1999-2003. ===========================================================================================

NOTE: For the demos to run you must have either fmod.dll (in Windows) or libfmod-3.75.so (in Linux) installed.

In Winapi.Windows, copy the fmod.dll file found in the api directory to either of the following locations (in order of preference) - your application directory - Windows\System (95/98) or WinNT\System32 (NT/2000/XP)

In Linux, make sure you are signed in as root and copy the libfmod-3.75.so file from the api directory to your /usr/lib/ directory. Then via a command line, navigate to the /usr/lib/ directory and create a symbolic link between libfmod-3.75.so and libfmod.so. This is done with the following command (assuming you are in /usr/lib/)... ln -s libfmod-3.75.so libfmod.so.

============================================================================================
GXS.Sounds.OpenAL

The graphics rendering engine GLScene http://glscene.org
GXS.Sounds.Register

The graphics engine GXScene https://github.com/glscene
GXS.Sounds.WaveOut

Basic sound manager based on WinMM
GXS.SpacePartition

The graphics engine GXScene https://github.com/glscene
GXS.SpaceText

The graphics engine GXScene https://github.com/glscene
GXS.SpatialPartitioning

The graphics engine GXScene https://github.com/glscene
GXS.State

The graphics engine GXScene https://github.com/glscene
GXS.TerrainRenderer

The graphics engine GXScene https://github.com/glscene
GXS.TexLensFlare

The graphics engine GXScene https://github.com/glscene
GXS.Texture

The graphics engine GXScene https://github.com/glscene
GXS.TextureCombiners

The graphics engine GXScene https://github.com/glscene
GXS.TexturedHDS

The graphics engine GXScene https://github.com/glscene
GXS.TextureImageEditors

The graphics engine GXScene https://github.com/glscene
GXS.ThorFX

The graphics engine GXScene https://github.com/glscene
GXS.TilePlane

The graphics engine GXScene https://github.com/glscene
GXS.TimeEventsMgr

The graphics engine GXScene https://github.com/glscene
GXS.Trail

The graphics engine GXScene https://github.com/glscene
GXS.Tree

The graphics engine GXScene https://github.com/glscene
GXS.VectorFileObjects

The graphics engine GXScene https://github.com/glscene
GXS.VerletClothify

The graphics engine GXScene https://github.com/glscene
GXS.VerletTypes

The graphics rendering engine GLScene http://glscene.org
GXS.ViewerOpenGL

The graphics engine GXScene https://github.com/glscene
GXS.WaterPlane

The graphics engine GXScene https://github.com/glscene
GXS.WinContext

The graphics engine GXScene https://github.com/glscene
GXS.Windows

The graphics engine GXScene https://github.com/glscene
GXS.WindowsFont

The graphics engine GXScene https://github.com/glscene
GXS.XOpenGL

The graphics engine GXScene https://github.com/glscene
GXS.zBuffer

The graphics engine GXScene https://github.com/glscene
GXSL.AsmShader

The graphics engine GXScene https://github.com/glscene
GXSL.BumpShaders

The graphics engine GXScene https://github.com/glscene
GXSL.CustomShader

The graphics engine GXScene https://github.com/glscene
GXSL.DiffuseSpecularShader

The graphics engine GXScene https://github.com/glscene
GXSL.LineShaders

The graphics engine GXScene https://github.com/glscene
GXSL.MultiMaterialShader

The graphics engine GXScene https://github.com/glscene
GXSL.Parameter

The graphics engine GXScene https://github.com/glscene
GXSL.PhongShader

The graphics engine GXScene https://github.com/glscene
GXSL.PostEffects

The graphics engine GXScene https://github.com/glscene
GXSL.PostShaders

The graphics engine GXScene https://github.com/glscene
GXSL.ProjectedTextures

The graphics engine GXScene https://github.com/glscene
GXSL.Shader

The graphics engine GXScene https://github.com/glscene
GXSL.ShaderCombiner

The graphics engine GXScene https://github.com/glscene
GXSL.ShaderParameter

The graphics engine GXScene https://github.com/glscene
GXSL.ShapeShaders

The graphics engine GXScene https://github.com/glscene
GXSL.TextureShaders

The graphics engine GXScene https://github.com/glscene
GXSL.UserShader

A shader that passes control of the DoApply and DoUnApply methods through published events. This component is designed to make it a little easier to implement a customized shader. Be sure to keep the shader balanced by returning the OpenGL state to how you found it.
omSailSurface

OpenGXS.InitFMX

The graphics engine GXScene https://github.com/glscene
SDLx.Context

The graphics engine GXScene https://github.com/glscene
SDLx.Window

The graphics engine GXScene https://github.com/glscene
uGBEImageUtils

uGBEOptionsUtils

uGBEPathFinder

uGBESound

uGBEUtils3D

VXS.DWSScene

DelphiWebScript symbol creation for base GLScene classes.

This unit is dependent on DwsClasses and DwsVectorGeometry. These components must be associated with the same compiler for the GLScene classes to inherit from.


GXSysHelp v.2.5: FMxCUDAEditor

Unit FMxCUDAEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.Layouts
  • FMX.ListBox
  • FMX.Objects
  • FMX.StdCtrls
  • FMX.Controls.Presentation
  • GLScene.Strings
  • CUDAx.API
  • CUDAx.FFTPlan
  • CUDAx.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAEditorForm |

Functions and Procedures

function GetCUDAEditorForm: TCUDAEditorForm;
procedure ReleaseCUDAEditorForm;

Variables

CUDAEditorForm: TCUDAEditorForm;

Description

Functions and Procedures

function GetCUDAEditorForm: TCUDAEditorForm;

This item has no description.

procedure ReleaseCUDAEditorForm;

This item has no description.

Variables

CUDAEditorForm: TCUDAEditorForm;

This item has no description.


GXSysHelp v.2.5: FMxCUDAEditor: Class TCUDAEditorForm

Class TCUDAEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxCUDAEditor

Declaration

type TCUDAEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TCUDAEditorForm

Overview

Fields

Public | ToolBar1: TToolBar;
Public | SBOpen: TSpeedButton;
Public | Image1: TImage;
Public | SBSave: TSpeedButton;
Public | Image2: TImage;
Public | SBHelp: TSpeedButton;
Public | Image3: TImage;
Public | ListBox1: TListBox;

Description

Fields

Public ToolBar1: TToolBar;

This item has no description.

Public SBOpen: TSpeedButton;

This item has no description.

Public Image1: TImage;

This item has no description.

Public SBSave: TSpeedButton;

This item has no description.

Public Image2: TImage;

This item has no description.

Public SBHelp: TSpeedButton;

This item has no description.

Public Image3: TImage;

This item has no description.

Public ListBox1: TListBox;


GXSysHelp v.2.5: FMxGuiLayoutEditor

Unit FMxGuiLayoutEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • System.Rtti
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Layouts
  • FMX.ListBox
  • FMX.Grid
  • FMX.Controls.Presentation
  • FMX.Edit
  • FMX.EditBox
  • FMX.SpinBox
  • FMX.Objects
  • GXS.Gui
  • FMX.Grid.Style
  • FMX.ScrollBox

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGUILayoutForm |

Variables

GUILayoutForm: TGUILayoutForm;

Description

Variables

GUILayoutForm: TGUILayoutForm;


GXSysHelp v.2.5: FMxGuiLayoutEditor: Class TGUILayoutForm

Class TGUILayoutForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxGuiLayoutEditor

Declaration

type TGUILayoutForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TGUILayoutForm

Overview

Fields

Public | Panel1: TPanel;
Public | OpenDialog1: TOpenDialog;
Public | SaveDialog1: TSaveDialog;
Public | Panel2: TPanel;
Public | Items_List: TListBox;
Public | Open_Image_Button: TButton;
Public | Open_Button: TButton;
Public | Save_Button: TButton;
Public | Done_Button: TButton;
Public | ButtonZoomIn: TButton;
Public | Add_Button: TButton;
Public | Delete_Button: TButton;
Public | Name_Edit: TEdit;
Public | LabelName: TLabel;
Public | Elements_Grid: TStringGrid;
Public | LabelX: TLabel;
Public | LabelY: TLabel;
Public | LabelHeight: TLabel;
Public | LabelWidth: TLabel;
Public | Left_Edit: TSpinBox;
Public | Top_Edit: TSpinBox;
Public | Width_Edit: TSpinBox;
Public | Height_Edit: TSpinBox;
Public | ScrollBox1: TScrollBox;
Public | PaintBox1: TPaintBox;
Public | Image1: TImage;
Public | Image2: TImage;
Public | X_Label: TLabel;
Public | Y_Label: TLabel;
Public | ImageZoomIn: TImage;
Public | ButtonZoomOut: TButton;
Public | ImageZoomOut: TImage;
Public | ButtonShow: TButton;
Public | ImageShow: TImage;
Public | ImageDone: TImage;
Public | ImageOpen: TImage;
Public | ImageSave: TImage;
Public | ImageLoadSkin: TImage;
Public | ImageAdd: TImage;
Public | ImageDelete: TImage;
Private | Rect_point1: TPoint;
Private | Rect_point2: TPoint;
Private | Sorted_Elements: array[0..9] of TgxGuiElement;

Methods

Private | function GetEnabledSpins: Boolean;
Public | procedure Items_ListClick(Sender: TObject);
Private | procedure DrawCurrentElement;
Private | procedure RefreshComponentBox;
Private | procedure SetEnabledSpins(Value: Boolean);
Private | procedure SyncImages;

Description

Fields

Public Panel1: TPanel;

This item has no description.

Public OpenDialog1: TOpenDialog;

This item has no description.

Public SaveDialog1: TSaveDialog;

This item has no description.

Public Panel2: TPanel;

This item has no description.

Public Items_List: TListBox;

This item has no description.

Public Open_Image_Button: TButton;

This item has no description.

Public Open_Button: TButton;

This item has no description.

Public Save_Button: TButton;

This item has no description.

Public Done_Button: TButton;

This item has no description.

Public ButtonZoomIn: TButton;

This item has no description.

Public Add_Button: TButton;

This item has no description.

Public Delete_Button: TButton;

This item has no description.

Public Name_Edit: TEdit;

This item has no description.

Public LabelName: TLabel;

This item has no description.

Public Elements_Grid: TStringGrid;

This item has no description.

Public LabelX: TLabel;

This item has no description.

Public LabelY: TLabel;

This item has no description.

Public LabelHeight: TLabel;

This item has no description.

Public LabelWidth: TLabel;

This item has no description.

Public Left_Edit: TSpinBox;

This item has no description.

Public Top_Edit: TSpinBox;

This item has no description.

Public Width_Edit: TSpinBox;

This item has no description.

Public Height_Edit: TSpinBox;

This item has no description.

Public ScrollBox1: TScrollBox;

This item has no description.

Public PaintBox1: TPaintBox;

This item has no description.

Public Image1: TImage;

This item has no description.

Public Image2: TImage;

This item has no description.

Public X_Label: TLabel;

This item has no description.

Public Y_Label: TLabel;

This item has no description.

Public ImageZoomIn: TImage;

This item has no description.

Public ButtonZoomOut: TButton;

This item has no description.

Public ImageZoomOut: TImage;

This item has no description.

Public ButtonShow: TButton;

This item has no description.

Public ImageShow: TImage;

This item has no description.

Public ImageDone: TImage;

This item has no description.

Public ImageOpen: TImage;

This item has no description.

Public ImageSave: TImage;

This item has no description.

Public ImageLoadSkin: TImage;

This item has no description.

Public ImageAdd: TImage;

This item has no description.

Public ImageDelete: TImage;

This item has no description.

Private Rect_point1: TPoint;

This item has no description.

Private Rect_point2: TPoint;

This item has no description.

Private Sorted_Elements: array[0..9] of TgxGuiElement;

This item has no description.

Methods

Private function GetEnabledSpins: Boolean;

This item has no description.

Public procedure Items_ListClick(Sender: TObject);

This item has no description.

Private procedure DrawCurrentElement;

This item has no description.

Private procedure RefreshComponentBox;

This item has no description.

Private procedure SetEnabledSpins(Value: Boolean);

This item has no description.

Private procedure SyncImages;


GXSysHelp v.2.5: FMxInfo

Unit FMxInfo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.TabControl
  • FMX.Layouts
  • FMX.ListBox
  • FMX.Memo
  • FMX.ScrollBox
  • FMX.Controls.Presentation
  • FMX.Objects
  • FMX.Memo.Types
  • GLScene.OpenGL4
  • GXS.Scene
  • GXS.Context
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TInfoForm |

Variables

InfoForm: TInfoForm;

Description

Variables

InfoForm: TInfoForm;


GXSysHelp v.2.5: FMxInfo: Class TInfoForm

Class TInfoForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxInfo

Declaration

type TInfoForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TInfoForm

Overview

Fields

Public | TabControl: TTabControl;
Public | TabItemScene: TTabItem;
Public | TabItemInformation: TTabItem;
Public | TabItemExtensions: TTabItem;
Public | TabItemContributors: TTabItem;
Public | TabItemAbout: TTabItem;
Public | ButtonClose: TButton;
Public | ImageControl1: TImageControl;
Public | ScrollBoxInfo: TScrollBox;
Public | LabelCommon: TLabel;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | Label5: TLabel;
Public | Label6: TLabel;
Public | Label7: TLabel;
Public | CopyLabel: TLabel;
Public | AccLabel: TLabel;
Public | StereoLabel: TLabel;
Public | DoubleLabel: TLabel;
Public | VersionLabel: TLabel;
Public | RendererLabel: TLabel;
Public | VendorLabel: TLabel;
Public | LabelDepths: TLabel;
Public | Label9: TLabel;
Public | ColorLabel: TLabel;
Public | Label11: TLabel;
Public | DepthLabel: TLabel;
Public | Label13: TLabel;
Public | StencilLabel: TLabel;
Public | Label15: TLabel;
Public | AccumLabel: TLabel;
Public | Label17: TLabel;
Public | AuxLabel: TLabel;
Public | Label19: TLabel;
Public | SubLabel: TLabel;
Public | Label21: TLabel;
Public | OverlayLabel: TLabel;
Public | ListBoxExtensions: TListBox;
Public | Label23: TLabel;
Public | UnderlayLabel: TLabel;
Public | LabelMaxValues: TLabel;
Public | Label8: TLabel;
Public | ViewLabel: TLabel;
Public | Label26: TLabel;
Public | ModelLabel: TLabel;
Public | Label28: TLabel;
Public | ListLabel: TLabel;
Public | LightLabel: TLabel;
Public | Label31: TLabel;
Public | EvalLabel: TLabel;
Public | Label33: TLabel;
Public | ClipLabel: TLabel;
Public | Label35: TLabel;
Public | Label36: TLabel;
Public | Label37: TLabel;
Public | NameLabel: TLabel;
Public | Label39: TLabel;
Public | PixelLabel: TLabel;
Public | ProjLabel: TLabel;
Public | TexSizeLabel: TLabel;
Public | Label43: TLabel;
Public | TexStackLabel: TLabel;
Public | Label45: TLabel;
Public | TexUnitsLabel: TLabel;
Public | Label47: TLabel;
Public | MemoContributors: TMemo;
Public | MemoAbout: TMemo;
Public | LabelOfficial: TLabel;
Public | WebSiteLbl: TLabel;
Public | LabelDevelopment: TLabel;
Public | DevSiteLbl: TLabel;
Public | Label10: TLabel;
Public | TextInfo: TText;
Public | Label12: TLabel;
Public | Label14: TLabel;

Methods

Public | procedure ButtonCloseClick(Sender: TObject);
Public | procedure FormClose(Sender: TObject; var Action: TCloseAction);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormKeyDown(Sender: TObject; var Key: Word; var KeyChar: Char; Shift: TShiftState);
Public | procedure FormShow(Sender: TObject);
Public | procedure GetInfoFrom(aSceneBuffer: TgxSceneBuffer);
Public | procedure ListBoxExtensionsDblClick(Sender: TObject);
Public | procedure TextInfoClick(Sender: TObject);
Public | procedure WebSiteLblClick(Sender: TObject);

Description

Fields

Public TabControl: TTabControl;

This item has no description.

Public TabItemScene: TTabItem;

This item has no description.

Public TabItemInformation: TTabItem;

This item has no description.

Public TabItemExtensions: TTabItem;

This item has no description.

Public TabItemContributors: TTabItem;

This item has no description.

Public TabItemAbout: TTabItem;

This item has no description.

Public ButtonClose: TButton;

This item has no description.

Public ImageControl1: TImageControl;

This item has no description.

Public ScrollBoxInfo: TScrollBox;

This item has no description.

Public LabelCommon: TLabel;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public Label6: TLabel;

This item has no description.

Public Label7: TLabel;

This item has no description.

Public CopyLabel: TLabel;

This item has no description.

Public AccLabel: TLabel;

This item has no description.

Public StereoLabel: TLabel;

This item has no description.

Public DoubleLabel: TLabel;

This item has no description.

Public VersionLabel: TLabel;

This item has no description.

Public RendererLabel: TLabel;

This item has no description.

Public VendorLabel: TLabel;

This item has no description.

Public LabelDepths: TLabel;

This item has no description.

Public Label9: TLabel;

This item has no description.

Public ColorLabel: TLabel;

This item has no description.

Public Label11: TLabel;

This item has no description.

Public DepthLabel: TLabel;

This item has no description.

Public Label13: TLabel;

This item has no description.

Public StencilLabel: TLabel;

This item has no description.

Public Label15: TLabel;

This item has no description.

Public AccumLabel: TLabel;

This item has no description.

Public Label17: TLabel;

This item has no description.

Public AuxLabel: TLabel;

This item has no description.

Public Label19: TLabel;

This item has no description.

Public SubLabel: TLabel;

This item has no description.

Public Label21: TLabel;

This item has no description.

Public OverlayLabel: TLabel;

This item has no description.

Public ListBoxExtensions: TListBox;

This item has no description.

Public Label23: TLabel;

This item has no description.

Public UnderlayLabel: TLabel;

This item has no description.

Public LabelMaxValues: TLabel;

This item has no description.

Public Label8: TLabel;

This item has no description.

Public ViewLabel: TLabel;

This item has no description.

Public Label26: TLabel;

This item has no description.

Public ModelLabel: TLabel;

This item has no description.

Public Label28: TLabel;

This item has no description.

Public ListLabel: TLabel;

This item has no description.

Public LightLabel: TLabel;

This item has no description.

Public Label31: TLabel;

This item has no description.

Public EvalLabel: TLabel;

This item has no description.

Public Label33: TLabel;

This item has no description.

Public ClipLabel: TLabel;

This item has no description.

Public Label35: TLabel;

This item has no description.

Public Label36: TLabel;

This item has no description.

Public Label37: TLabel;

This item has no description.

Public NameLabel: TLabel;

This item has no description.

Public Label39: TLabel;

This item has no description.

Public PixelLabel: TLabel;

This item has no description.

Public ProjLabel: TLabel;

This item has no description.

Public TexSizeLabel: TLabel;

This item has no description.

Public Label43: TLabel;

This item has no description.

Public TexStackLabel: TLabel;

This item has no description.

Public Label45: TLabel;

This item has no description.

Public TexUnitsLabel: TLabel;

This item has no description.

Public Label47: TLabel;

This item has no description.

Public MemoContributors: TMemo;

This item has no description.

Public MemoAbout: TMemo;

This item has no description.

Public LabelOfficial: TLabel;

This item has no description.

Public WebSiteLbl: TLabel;

This item has no description.

Public LabelDevelopment: TLabel;

This item has no description.

Public DevSiteLbl: TLabel;

This item has no description.

Public Label10: TLabel;

This item has no description.

Public TextInfo: TText;

This item has no description.

Public Label12: TLabel;

This item has no description.

Public Label14: TLabel;

This item has no description.

Methods

Public procedure ButtonCloseClick(Sender: TObject);

This item has no description.

Public procedure FormClose(Sender: TObject; var Action: TCloseAction);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormKeyDown(Sender: TObject; var Key: Word; var KeyChar: Char; Shift: TShiftState);

This item has no description.

Public procedure FormShow(Sender: TObject);

This item has no description.

Public procedure GetInfoFrom(aSceneBuffer: TgxSceneBuffer);

This item has no description.

Public procedure ListBoxExtensionsDblClick(Sender: TObject);

This item has no description.

Public procedure TextInfoClick(Sender: TObject);

This item has no description.

Public procedure WebSiteLblClick(Sender: TObject);


GXSysHelp v.2.5: FMXLibMaterialPicker

Unit FMXLibMaterialPicker

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Layouts
  • FMX.ListBox
  • FMX.Objects
  • FMX.Media
  • FMX.Viewport3D
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • FMX.MaterialSources
  • FMX.Controls.Presentation
  • FRxMaterialPreview
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLibMaterialPicker |

Functions and Procedures

function GLLibMaterialPicker: TLibMaterialPicker;
procedure ReleaseLibMaterialPicker;

Description

Functions and Procedures

function GLLibMaterialPicker: TLibMaterialPicker;

This item has no description.

procedure ReleaseLibMaterialPicker;


GXSysHelp v.2.5: FMXLibMaterialPicker: Class TLibMaterialPicker

Class TLibMaterialPicker

Description
Hierarchy
Fields
Methods
Properties

Unit

FMXLibMaterialPicker

Declaration

type TLibMaterialPicker = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TLibMaterialPicker

Overview

Fields

Public | Label1: TLabel;
Public | Label2: TLabel;
Public | LBMaterials: TListBox;
Public | BBOK: TButton;
Public | ImageOK: TImage;
Public | BBCancel: TButton;
Public | MPPreview: TMaterialPreviewFrame;

Methods

Public | function Execute(var materialName: TgxLibMaterialName; materialLibrary: TgxAbstractMaterialLibrary): Boolean;
Public | procedure CBBackgroundChange(Sender: TObject);
Public | procedure CBObjectChange(Sender: TObject);
Public | procedure LBMaterialsClick(Sender: TObject);
Public | procedure LBMaterialsDblClick(Sender: TObject);

Description

Fields

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public LBMaterials: TListBox;

This item has no description.

Public BBOK: TButton;

This item has no description.

Public ImageOK: TImage;

This item has no description.

Public BBCancel: TButton;

This item has no description.

Public MPPreview: TMaterialPreviewFrame;

This item has no description.

Methods

Public function Execute(var materialName: TgxLibMaterialName; materialLibrary: TgxAbstractMaterialLibrary): Boolean;

This item has no description.

Public procedure CBBackgroundChange(Sender: TObject);

This item has no description.

Public procedure CBObjectChange(Sender: TObject);

This item has no description.

Public procedure LBMaterialsClick(Sender: TObject);

This item has no description.

Public procedure LBMaterialsDblClick(Sender: TObject);


GXSysHelp v.2.5: FMxMaterialEditor

Unit FMxMaterialEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • System.Types
  • System.UITypes
  • System.Variants
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.TabControl
  • FMX.StdCtrls
  • FMX.Objects
  • FMX.ListBox
  • FMX.Controls.Presentation
  • FRxMaterialPreview
  • FRxColorEditor
  • FRxFaceEditor
  • FRxTextureEdit
  • GXS.Texture
  • GXS.Material
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialEditorForm |

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;
procedure ReleaseMaterialEditorForm;

Description

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;

This item has no description.

procedure ReleaseMaterialEditorForm;


GXSysHelp v.2.5: FMxMaterialEditor: Class TMaterialEditorForm

Class TMaterialEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxMaterialEditor

Declaration

type TMaterialEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TMaterialEditorForm

Overview

Fields

Public | TabControl1: TTabControl;
Public | TIFront: TTabItem;
Public | TIBack: TTabItem;
Public | TITexture: TTabItem;
Public | FEFront: TFaceEditorFrame;
Public | FEBack: TFaceEditorFrame;
Public | GroupBox1: TGroupBox;
Public | MPPreview: TMaterialPreviewFrame;
Public | BBOK: TButton;
Public | ImageOK: TImage;
Public | BBCancel: TButton;
Public | ImageCancel: TImage;
Public | RTextureEdit: TTextureEditFrame;
Public | CBBlending: TComboBox;
Public | Label1: TLabel;
Public | Label2: TLabel;
Public | CBPolygonMode: TComboBox;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function Execute(AMaterial: TgxMaterial): Boolean;
Public | procedure OnMaterialChanged(Sender: TObject);

Description

Fields

Public TabControl1: TTabControl;

This item has no description.

Public TIFront: TTabItem;

This item has no description.

Public TIBack: TTabItem;

This item has no description.

Public TITexture: TTabItem;

This item has no description.

Public FEFront: TFaceEditorFrame;

This item has no description.

Public FEBack: TFaceEditorFrame;

This item has no description.

Public GroupBox1: TGroupBox;

This item has no description.

Public MPPreview: TMaterialPreviewFrame;

This item has no description.

Public BBOK: TButton;

This item has no description.

Public ImageOK: TImage;

This item has no description.

Public BBCancel: TButton;

This item has no description.

Public ImageCancel: TImage;

This item has no description.

Public RTextureEdit: TTextureEditFrame;

This item has no description.

Public CBBlending: TComboBox;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public CBPolygonMode: TComboBox;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function Execute(AMaterial: TgxMaterial): Boolean;

This item has no description.

Public procedure OnMaterialChanged(Sender: TObject);


GXSysHelp v.2.5: FMxSceneEditor

Unit FMxSceneEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • System.Actions
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.Menus
  • FMX.ActnList
  • FMX.StdCtrls
  • FMX.Layouts
  • FMX.TreeView
  • FMX.ListView.Types
  • FMX.ListView
  • FMX.Objects
  • FMX.ListView.Appearances
  • FMX.ListView.Adapters.Base
  • FMX.Controls.Presentation
  • FMxInfo
  • GXS.Scene
  • GXS.SceneViewer
  • GXS.SceneRegister
  • GLScene.Strings
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSceneEditorForm |

Functions and Procedures

function SceneEditorForm: TSceneEditorForm;
procedure ReleaseSceneEditorForm;

Description

Functions and Procedures

function SceneEditorForm: TSceneEditorForm;

This item has no description.

procedure ReleaseSceneEditorForm;


GXSysHelp v.2.5: FMxSceneEditor: Class TSceneEditorForm

Class TSceneEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxSceneEditor

Declaration

type TSceneEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TSceneEditorForm

Overview

Fields

Public | ToolBar: TToolBar;
Public | PATree: TPanel;
Public | PAGallery: TPanel;
Public | PAEffects: TPanel;
Public | ActionList: TActionList;
Public | PMToolBar: TPopupMenu;
Public | PopupMenu: TPopupMenu;
Public | SaveDialog: TSaveDialog;
Public | OpenDialog: TOpenDialog;
Public | Tree: TTreeView;
Public | PABehaviours: TPanel;
Public | PMBehavioursToolBar: TPopupMenu;
Public | PMEffectsToolBar: TPopupMenu;
Public | BehavioursPopupMenu: TPopupMenu;
Public | ToolBarBehaviours: TToolBar;
Public | ToolBarEffects: TToolBar;
Public | GalleryListView: TListView;
Public | BehavioursListView: TListView;
Public | EffectsListView: TListView;
Public | ACLoadScene: TAction;
Public | ACSaveScene: TAction;
Public | ACStayOnTop: TAction;
Public | ACAddObject: TAction;
Public | ACAddBehaviour: TAction;
Public | ACAddEffect: TAction;
Public | ACMoveUp: TAction;
Public | ACMoveDown: TAction;
Public | ACExpand: TAction;
Public | ACDeleteObject: TAction;
Public | ACDeleteBehaviour: TAction;
Public | ACCut: TAction;
Public | ACCopy: TAction;
Public | ACPaste: TAction;
Public | ACInfo: TAction;
Public | TBLoadScene: TSpeedButton;
Public | ImLoadScene: TImage;
Public | TBInfo: TSpeedButton;
Public | ImInfo: TImage;
Public | TBPaste: TSpeedButton;
Public | ImPaste: TImage;
Public | TBCopy: TSpeedButton;
Public | ImCopy: TImage;
Public | TBCut: TSpeedButton;
Public | ImCut: TImage;
Public | TBDeleteObject: TSpeedButton;
Public | ImDeleteObject: TImage;
Public | TBExpand: TSpeedButton;
Public | ImExpand: TImage;
Public | TBMoveDown: TSpeedButton;
Public | ImMoveDown: TImage;
Public | TBMoveUp: TSpeedButton;
Public | ImMoveUp: TImage;
Public | TBCharacterPanels: TSpeedButton;
Public | ImCharacterPanels: TImage;
Public | TBGalleryPanel: TSpeedButton;
Public | ImGalleryPanel: TImage;
Public | TBAddObjects: TSpeedButton;
Public | ImAddObjects: TImage;
Public | TBStayOnTop: TSpeedButton;
Public | ImStayOnTop: TImage;
Public | TBSaveScene: TSpeedButton;
Public | ImSaveScene: TImage;
Public | TBSeparator1: TSpeedButton;
Public | TBSeparator2: TSpeedButton;
Public | TBSeparator3: TSpeedButton;
Public | TBSeparator4: TSpeedButton;
Public | ACGallery: TAction;
Public | ImArrowDown: TImage;
Public | ImArrowDownBeh: TImage;
Public | ImArrowDownEff: TImage;
Public | TBAddBehaviours: TSpeedButton;
Public | TBAddEffects: TSpeedButton;
Public | MIAddObject: TMenuItem;
Public | MIAddBehaviour: TMenuItem;
Public | MIAddEffect: TMenuItem;
Public | MICut: TMenuItem;
Public | MICopy: TMenuItem;
Public | MIPaste: TMenuItem;
Public | MIDelObject: TMenuItem;
Public | MIMoveUp: TMenuItem;
Public | MIMoveDown: TMenuItem;
Public | StyleBook: TStyleBook;

Methods

Public | procedure ACInfoExecute(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);

Description

Fields

Public ToolBar: TToolBar;

This item has no description.

Public PATree: TPanel;

This item has no description.

Public PAGallery: TPanel;

This item has no description.

Public PAEffects: TPanel;

This item has no description.

Public ActionList: TActionList;

This item has no description.

Public PMToolBar: TPopupMenu;

This item has no description.

Public PopupMenu: TPopupMenu;

This item has no description.

Public SaveDialog: TSaveDialog;

This item has no description.

Public OpenDialog: TOpenDialog;

This item has no description.

Public Tree: TTreeView;

This item has no description.

Public PABehaviours: TPanel;

This item has no description.

Public PMBehavioursToolBar: TPopupMenu;

This item has no description.

Public PMEffectsToolBar: TPopupMenu;

This item has no description.

Public BehavioursPopupMenu: TPopupMenu;

This item has no description.

Public ToolBarBehaviours: TToolBar;

This item has no description.

Public ToolBarEffects: TToolBar;

This item has no description.

Public GalleryListView: TListView;

This item has no description.

Public BehavioursListView: TListView;

This item has no description.

Public EffectsListView: TListView;

This item has no description.

Public ACLoadScene: TAction;

This item has no description.

Public ACSaveScene: TAction;

This item has no description.

Public ACStayOnTop: TAction;

This item has no description.

Public ACAddObject: TAction;

This item has no description.

Public ACAddBehaviour: TAction;

This item has no description.

Public ACAddEffect: TAction;

This item has no description.

Public ACMoveUp: TAction;

This item has no description.

Public ACMoveDown: TAction;

This item has no description.

Public ACExpand: TAction;

This item has no description.

Public ACDeleteObject: TAction;

This item has no description.

Public ACDeleteBehaviour: TAction;

This item has no description.

Public ACCut: TAction;

This item has no description.

Public ACCopy: TAction;

This item has no description.

Public ACPaste: TAction;

This item has no description.

Public ACInfo: TAction;

This item has no description.

Public TBLoadScene: TSpeedButton;

This item has no description.

Public ImLoadScene: TImage;

This item has no description.

Public TBInfo: TSpeedButton;

This item has no description.

Public ImInfo: TImage;

This item has no description.

Public TBPaste: TSpeedButton;

This item has no description.

Public ImPaste: TImage;

This item has no description.

Public TBCopy: TSpeedButton;

This item has no description.

Public ImCopy: TImage;

This item has no description.

Public TBCut: TSpeedButton;

This item has no description.

Public ImCut: TImage;

This item has no description.

Public TBDeleteObject: TSpeedButton;

This item has no description.

Public ImDeleteObject: TImage;

This item has no description.

Public TBExpand: TSpeedButton;

This item has no description.

Public ImExpand: TImage;

This item has no description.

Public TBMoveDown: TSpeedButton;

This item has no description.

Public ImMoveDown: TImage;

This item has no description.

Public TBMoveUp: TSpeedButton;

This item has no description.

Public ImMoveUp: TImage;

This item has no description.

Public TBCharacterPanels: TSpeedButton;

This item has no description.

Public ImCharacterPanels: TImage;

This item has no description.

Public TBGalleryPanel: TSpeedButton;

This item has no description.

Public ImGalleryPanel: TImage;

This item has no description.

Public TBAddObjects: TSpeedButton;

This item has no description.

Public ImAddObjects: TImage;

This item has no description.

Public TBStayOnTop: TSpeedButton;

This item has no description.

Public ImStayOnTop: TImage;

This item has no description.

Public TBSaveScene: TSpeedButton;

This item has no description.

Public ImSaveScene: TImage;

This item has no description.

Public TBSeparator1: TSpeedButton;

This item has no description.

Public TBSeparator2: TSpeedButton;

This item has no description.

Public TBSeparator3: TSpeedButton;

This item has no description.

Public TBSeparator4: TSpeedButton;

This item has no description.

Public ACGallery: TAction;

This item has no description.

Public ImArrowDown: TImage;

This item has no description.

Public ImArrowDownBeh: TImage;

This item has no description.

Public ImArrowDownEff: TImage;

This item has no description.

Public TBAddBehaviours: TSpeedButton;

This item has no description.

Public TBAddEffects: TSpeedButton;

This item has no description.

Public MIAddObject: TMenuItem;

This item has no description.

Public MIAddBehaviour: TMenuItem;

This item has no description.

Public MIAddEffect: TMenuItem;

This item has no description.

Public MICut: TMenuItem;

This item has no description.

Public MICopy: TMenuItem;

This item has no description.

Public MIPaste: TMenuItem;

This item has no description.

Public MIDelObject: TMenuItem;

This item has no description.

Public MIMoveUp: TMenuItem;

This item has no description.

Public MIMoveDown: TMenuItem;

This item has no description.

Public StyleBook: TStyleBook;

This item has no description.

Methods

Public procedure ACInfoExecute(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);


GXSysHelp v.2.5: FMxShaderMemo

Unit FMxShaderMemo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Win.Registry
  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Objects
  • FMX.Layouts
  • FMX.Menus
  • FMX.Memo
  • FMX.ScrollBox
  • FMX.Controls.Presentation
  • FMX.Memo.Types

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TShaderMemoForm |

Functions and Procedures

function ShaderEditorForm: TShaderMemoForm;
procedure ReleaseShaderEditor;

Description

Functions and Procedures

function ShaderEditorForm: TShaderMemoForm;

This item has no description.

procedure ReleaseShaderEditor;


GXSysHelp v.2.5: FMxShaderMemo: Class TShaderMemoForm

Class TShaderMemoForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxShaderMemo

Declaration

type TShaderMemoForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TShaderMemoForm

Overview

Fields

Public | ToolBar1: TToolBar;
Public | Panel1: TPanel;
Public | ButtonOK: TButton;
Public | ImageOK: TImage;
Public | ButtonCancel: TButton;
Public | ImageCancel: TImage;
Public | CheckButton: TSpeedButton;
Public | CompilatorLog: TMemo;
Public | SBOpen: TSpeedButton;
Public | Image1: TImage;
Public | SBSave: TSpeedButton;
Public | Image2: TImage;
Public | SBHelp: TSpeedButton;
Public | Image3: TImage;
Public | GLSLMemo: TMemo;

Methods

Public procedure FormCreate(Sender: TObject);

Description

Fields

Public ToolBar1: TToolBar;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public ButtonOK: TButton;

This item has no description.

Public ImageOK: TImage;

This item has no description.

Public ButtonCancel: TButton;

This item has no description.

Public ImageCancel: TImage;

This item has no description.

Public CheckButton: TSpeedButton;

This item has no description.

Public CompilatorLog: TMemo;

This item has no description.

Public SBOpen: TSpeedButton;

This item has no description.

Public Image1: TImage;

This item has no description.

Public SBSave: TSpeedButton;

This item has no description.

Public Image2: TImage;

This item has no description.

Public SBHelp: TSpeedButton;

This item has no description.

Public Image3: TImage;

This item has no description.

Public GLSLMemo: TMemo;

This item has no description.

Methods

Public procedure FormCreate(Sender: TObject);


GXSysHelp v.2.5: FMxShaderUniformEditor

Unit FMxShaderUniformEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.Layouts
  • FMX.ListBox
  • FMX.StdCtrls
  • FMX.Controls.Presentation
  • GXSL.Parameter
  • GLScene.TextureFormat
  • GLScene.VectorGeometry
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TShaderUniformEditorForm |

Functions and Procedures

function ShaderUniformEditorForm: TShaderUniformEditorForm;
procedure ReleaseShaderUniformEditor;

Description

Functions and Procedures

function ShaderUniformEditorForm: TShaderUniformEditorForm;

This item has no description.

procedure ReleaseShaderUniformEditor;


GXSysHelp v.2.5: FMxShaderUniformEditor: Class TShaderUniformEditorForm

Class TShaderUniformEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxShaderUniformEditor

Declaration

type TShaderUniformEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TShaderUniformEditorForm

Overview

Fields

Public | Label1: TLabel;
Public | LBUniforms: TListBox;
Public | Label2: TLabel;
Public | AutoSetBox: TComboBox;
Public | SamplerBox: TComboBox;
Public | RedGroup: TGroupBox;
Public | GreenGroup: TGroupBox;
Public | BlueGroup: TGroupBox;
Public | AlphaGroup: TGroupBox;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | TextureBox: TComboBox;
Public | Label5: TLabel;
Public | RadioButton1: TRadioButton;
Public | RadioButton2: TRadioButton;
Public | RadioButton3: TRadioButton;
Public | RadioButton4: TRadioButton;
Public | RadioButton5: TRadioButton;
Public | RadioButton6: TRadioButton;
Public | RadioButton7: TRadioButton;
Public | RadioButton8: TRadioButton;
Public | RadioButton9: TRadioButton;
Public | RadioButton10: TRadioButton;
Public | RadioButton11: TRadioButton;
Public | RadioButton12: TRadioButton;
Public | RadioButton13: TRadioButton;
Public | RadioButton14: TRadioButton;
Public | RadioButton15: TRadioButton;
Public | RadioButton16: TRadioButton;
Public | RadioButton17: TRadioButton;
Public | RadioButton18: TRadioButton;
Public | RadioButton19: TRadioButton;
Public | RadioButton20: TRadioButton;
Public | RadioButton21: TRadioButton;
Public | RadioButton22: TRadioButton;
Public | RadioButton23: TRadioButton;
Public | RadioButton24: TRadioButton;
Private | FUniformList: array of IgxShaderParameter;

Methods

Public | procedure AddSamplerName(const S: string);
Public | procedure AddTextureName(const S: string);
Public | procedure AddUniform(AValue: IgxShaderParameter);
Public | procedure AutoSetBoxChange(Sender: TObject);
Public | procedure Clear;
Public | procedure ColorGroupClick(Sender: TObject);
Public | procedure Execute;
Public | procedure FormDestroy(Sender: TObject);
Public | procedure LBUniformsClick(Sender: TObject);
Public | procedure LBUniformsKeyDown(Sender: TObject; var Key: Word; var KeyChar: Char; Shift: TShiftState);
Public | procedure SamplerBoxChange(Sender: TObject);
Public | procedure TextureBoxChange(Sender: TObject);

Description

Fields

Public Label1: TLabel;

This item has no description.

Public LBUniforms: TListBox;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public AutoSetBox: TComboBox;

This item has no description.

Public SamplerBox: TComboBox;

This item has no description.

Public RedGroup: TGroupBox;

This item has no description.

Public GreenGroup: TGroupBox;

This item has no description.

Public BlueGroup: TGroupBox;

This item has no description.

Public AlphaGroup: TGroupBox;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public TextureBox: TComboBox;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public RadioButton1: TRadioButton;

This item has no description.

Public RadioButton2: TRadioButton;

This item has no description.

Public RadioButton3: TRadioButton;

This item has no description.

Public RadioButton4: TRadioButton;

This item has no description.

Public RadioButton5: TRadioButton;

This item has no description.

Public RadioButton6: TRadioButton;

This item has no description.

Public RadioButton7: TRadioButton;

This item has no description.

Public RadioButton8: TRadioButton;

This item has no description.

Public RadioButton9: TRadioButton;

This item has no description.

Public RadioButton10: TRadioButton;

This item has no description.

Public RadioButton11: TRadioButton;

This item has no description.

Public RadioButton12: TRadioButton;

This item has no description.

Public RadioButton13: TRadioButton;

This item has no description.

Public RadioButton14: TRadioButton;

This item has no description.

Public RadioButton15: TRadioButton;

This item has no description.

Public RadioButton16: TRadioButton;

This item has no description.

Public RadioButton17: TRadioButton;

This item has no description.

Public RadioButton18: TRadioButton;

This item has no description.

Public RadioButton19: TRadioButton;

This item has no description.

Public RadioButton20: TRadioButton;

This item has no description.

Public RadioButton21: TRadioButton;

This item has no description.

Public RadioButton22: TRadioButton;

This item has no description.

Public RadioButton23: TRadioButton;

This item has no description.

Public RadioButton24: TRadioButton;

This item has no description.

Private FUniformList: array of IgxShaderParameter;

This item has no description.

Methods

Public procedure AddSamplerName(const S: string);

This item has no description.

Public procedure AddTextureName(const S: string);

This item has no description.

Public procedure AddUniform(AValue: IgxShaderParameter);

This item has no description.

Public procedure AutoSetBoxChange(Sender: TObject);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ColorGroupClick(Sender: TObject);

This item has no description.

Public procedure Execute;

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure LBUniformsClick(Sender: TObject);

This item has no description.

Public procedure LBUniformsKeyDown(Sender: TObject; var Key: Word; var KeyChar: Char; Shift: TShiftState);

This item has no description.

Public procedure SamplerBoxChange(Sender: TObject);

This item has no description.

Public procedure TextureBoxChange(Sender: TObject);


GXSysHelp v.2.5: FMxSkinEditor

Unit FMxSkinEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Messaging
  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Layouts
  • FMX.ListBox
  • FMX.Objects
  • FMX.Controls.Presentation
  • FMX.Edit
  • FMX.Controls3D
  • GXS.BaseClasses
  • GXS.Gui
  • GXS.Texture
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSkinEditorForm |

Functions and Procedures

function GUIComponentDialog(GuiComponent: TgxGuiElementList): Boolean;

Variables

SkinEditorForm: TSkinEditorForm;

Description

Functions and Procedures

function GUIComponentDialog(GuiComponent: TgxGuiElementList): Boolean;

This item has no description.

Variables

SkinEditorForm: TSkinEditorForm;


GXSysHelp v.2.5: FMxSkinEditor: Class TSkinEditorForm

Class TSkinEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxSkinEditor

Declaration

type TSkinEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TSkinEditorForm

Overview

Fields

Public | PanElements: TPanel;
Public | StatusBar: TStatusBar;
Public | PanBottom: TPanel;
Public | Label1: TLabel;
Public | btnAdd: TButton;
Public | btnDelete: TButton;
Public | LBElements: TListBox;
Public | Label2: TLabel;
Public | ComboBox1: TComboBox;
Public | PanImageProperties: TPanel;
Public | PanZoomImage: TPanel;
Public | SBarHorizontal: TScrollBar;
Public | SBarVertical: TScrollBar;
Public | ImgFull: TImage;
Public | ButtonOK: TButton;
Public | ImageOK: TImage;
Public | ButtonCancel: TButton;
Public | ImageCancel: TImage;
Public | Panel1: TPanel;
Public | ImgPreview: TImage;
Public | Panel2: TPanel;
Public | Label3: TLabel;
Public | CheckBox1: TCheckBox;
Public | Label4: TLabel;
Public | Label5: TLabel;
Public | EditWidth: TEdit;
Public | EditHeight: TEdit;
Public | GLCamera1: TCamera;
Public | GLPanel1: TPanel;
Private | FOriginalWndProc: TWndMethod;
Private | FFocusRect: TRect;
Private | VisibleRect: TRect;
Private | PreviewMousePoint: TPoint;
Private | PreviewWidth: Integer;
Private | PreviewHeight: Integer;
Private | FullMousePoint: TPoint;
Private | MouseDown: Boolean;
Public | TheGuiComponent: TgxGuiElementList;
Public | SelectedElement: TgxGUIElement;
Public | Tex: TgxTexture;
Public | Zoom: Single;
Public | Width: Integer;
Public | Height: Integer;

Methods

Public | function Edit(GuiComponent: TgxGuiElementList): Boolean;
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure Render;
Public | procedure SetMax(Scrollbar: TScrollbar; Val: Integer);
Private | procedure AddElement(Index: Integer);
Private | procedure AlignZoomPanel;
Private | procedure DrawCrossair(Point: TPoint);
Private | procedure DrawImageFocusRect(ARect: TRect);
Private | procedure ImageWndProc(var Message: TMessage);
Private | procedure SetEditState(Parent: TControl; Enabled: Boolean);
Private | procedure UpdateRegionEdits;

Description

Fields

Public PanElements: TPanel;

This item has no description.

Public StatusBar: TStatusBar;

This item has no description.

Public PanBottom: TPanel;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public btnAdd: TButton;

This item has no description.

Public btnDelete: TButton;

This item has no description.

Public LBElements: TListBox;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public ComboBox1: TComboBox;

This item has no description.

Public PanImageProperties: TPanel;

This item has no description.

Public PanZoomImage: TPanel;

This item has no description.

Public SBarHorizontal: TScrollBar;

This item has no description.

Public SBarVertical: TScrollBar;

This item has no description.

Public ImgFull: TImage;

This item has no description.

Public ButtonOK: TButton;

This item has no description.

Public ImageOK: TImage;

This item has no description.

Public ButtonCancel: TButton;

This item has no description.

Public ImageCancel: TImage;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public ImgPreview: TImage;

This item has no description.

Public Panel2: TPanel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public CheckBox1: TCheckBox;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public Label5: TLabel;

This item has no description.

Public EditWidth: TEdit;

This item has no description.

Public EditHeight: TEdit;

This item has no description.

Public GLCamera1: TCamera;

This item has no description.

Public GLPanel1: TPanel;

This item has no description.

Private FOriginalWndProc: TWndMethod;

This item has no description.

Private FFocusRect: TRect;

This item has no description.

Private VisibleRect: TRect;

This item has no description.

Private PreviewMousePoint: TPoint;

This item has no description.

Private PreviewWidth: Integer;

This item has no description.

Private PreviewHeight: Integer;

This item has no description.

Private FullMousePoint: TPoint;

This item has no description.

Private MouseDown: Boolean;

This item has no description.

Public TheGuiComponent: TgxGuiElementList;

This item has no description.

Public SelectedElement: TgxGUIElement;

This item has no description.

Public Tex: TgxTexture;

This item has no description.

Public Zoom: Single;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Methods

Public function Edit(GuiComponent: TgxGuiElementList): Boolean;

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure Render;

This item has no description.

Public procedure SetMax(Scrollbar: TScrollbar; Val: Integer);

This item has no description.

Private procedure AddElement(Index: Integer);

This item has no description.

Private procedure AlignZoomPanel;

This item has no description.

Private procedure DrawCrossair(Point: TPoint);

This item has no description.

Private procedure DrawImageFocusRect(ARect: TRect);

This item has no description.

Private procedure ImageWndProc(var Message: TMessage);

This item has no description.

Private procedure SetEditState(Parent: TControl; Enabled: Boolean);

This item has no description.

Private procedure UpdateRegionEdits;


GXSysHelp v.2.5: FMxXCollectionEditor

Unit FMxXCollectionEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Rtti
  • System.Variants
  • System.Actions
  • System.TypInfo
  • FMX.Types
  • FMX.Controls
  • FMX.Forms
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.ListView.Types
  • FMX.ActnList
  • FMX.Menus
  • FMX.ListView.Appearances
  • FMX.ListView.Adapters.Base
  • FMX.Controls.Presentation
  • FMX.ListView
  • GXS.Scene
  • GLScene.Strings
  • GXS.Behaviours
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IDesigner |
Record TInstProp |
Class TXCollectionEditorForm |

Functions and Procedures

function XCollectionEditorForm: TXCollectionEditorForm;
procedure ReleaseXCollectionEditor;

Types

PInstPropList = ˆTInstPropList;
TInstPropList = array[0..1023] of TInstProp;

Description

Functions and Procedures

function XCollectionEditorForm: TXCollectionEditorForm;

This item has no description.

procedure ReleaseXCollectionEditor;

This item has no description.

Types

PInstPropList = ˆTInstPropList;

This item has no description.

TInstPropList = array[0..1023] of TInstProp;


GXSysHelp v.2.5: FMxXCollectionEditor: Interface IDesigner

Interface IDesigner

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxXCollectionEditor

Declaration

type IDesigner = interface(IInterface)

Description

This item has no description.

Attributes
GUID['{93F3FCBC-968E-45A9-9641-609E8FB3AC60}']

Hierarchy

  • IInterface
  • IDesigner

Overview

Methods

Public function CreateChild(ComponentClass: TComponentClass; Parent: TComponent): TComponent;

Description

Methods

Public function CreateChild(ComponentClass: TComponentClass; Parent: TComponent): TComponent;

in designintf -> (IDesigner200)


GXSysHelp v.2.5: FMxXCollectionEditor: Record TInstProp

Record TInstProp

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxXCollectionEditor

Declaration

type TInstProp = record

Description

This item has no description.

Overview

Fields

Public | Instance: TPersistent;
Public | PropInfo: PPropInfo;

Description

Fields

Public Instance: TPersistent;

This item has no description.

Public PropInfo: PPropInfo;


GXSysHelp v.2.5: FMxXCollectionEditor: Class TXCollectionEditorForm

Class TXCollectionEditorForm

Description
Hierarchy
Fields
Methods
Properties

Unit

FMxXCollectionEditor

Declaration

type TXCollectionEditorForm = class(TForm)

Description

This item has no description.

Hierarchy

  • TForm
  • TXCollectionEditorForm

Overview

Fields

Public | ToolBar1: TToolBar;
Public | TBAdd: TButton;
Public | ListView: TListView;
Public | PMListView: TPopupMenu;
Public | PMToolBar: TPopupMenu;
Public | ActionList: TActionList;
Public | ACRemove: TAction;
Public | ACMoveUp: TAction;
Public | ACMoveDown: TAction;
Public | Button1: TButton;
Public | Button2: TButton;
Public | Button3: TButton;
Private | FXCollection: TXCollection;
Private | FDesigner: IDesigner;
Private | UpdatingListView: Boolean;

Methods

Public | procedure ACMoveDownExecute(Sender: TObject);
Public | procedure ACMoveUpExecute(Sender: TObject);
Public | procedure ACRemoveExecute(Sender: TObject);
Public | procedure FormCreate(Sender: TObject);
Public | procedure FormDestroy(Sender: TObject);
Public | procedure FormHide(Sender: TObject);
Public | procedure ListViewChange(Sender: TObject);
Public | procedure SetXCollection(aXCollection: TXCollection; designer: IDesigner);
Private | procedure OnAddXCollectionItemClick(Sender: TObject);
Private | procedure OnNameChanged(Sender: TObject);
Private | procedure OnXCollectionDestroyed(Sender: TObject);
Private | procedure PrepareListView;
Private | procedure PrepareXCollectionItemPopup(parent: TMenuItem);

Description

Fields

Public ToolBar1: TToolBar;

This item has no description.

Public TBAdd: TButton;

This item has no description.

Public ListView: TListView;

This item has no description.

Public PMListView: TPopupMenu;

This item has no description.

Public PMToolBar: TPopupMenu;

This item has no description.

Public ActionList: TActionList;

This item has no description.

Public ACRemove: TAction;

This item has no description.

Public ACMoveUp: TAction;

This item has no description.

Public ACMoveDown: TAction;

This item has no description.

Public Button1: TButton;

This item has no description.

Public Button2: TButton;

This item has no description.

Public Button3: TButton;

This item has no description.

Private FXCollection: TXCollection;

This item has no description.

Private FDesigner: IDesigner;

ownerComponent : TComponent;

Private UpdatingListView: Boolean;

This item has no description.

Methods

Public procedure ACMoveDownExecute(Sender: TObject);

This item has no description.

Public procedure ACMoveUpExecute(Sender: TObject);

This item has no description.

Public procedure ACRemoveExecute(Sender: TObject);

This item has no description.

Public procedure FormCreate(Sender: TObject);

This item has no description.

Public procedure FormDestroy(Sender: TObject);

This item has no description.

Public procedure FormHide(Sender: TObject);

This item has no description.

Public procedure ListViewChange(Sender: TObject);

This item has no description.

Public procedure SetXCollection(aXCollection: TXCollection; designer: IDesigner);

This item has no description.

Private procedure OnAddXCollectionItemClick(Sender: TObject);

This item has no description.

Private procedure OnNameChanged(Sender: TObject);

This item has no description.

Private procedure OnXCollectionDestroyed(Sender: TObject);

This item has no description.

Private procedure PrepareListView;

This item has no description.

Private procedure PrepareXCollectionItemPopup(parent: TMenuItem);


GXSysHelp v.2.5: Formatx.DDSImage

Unit Formatx.DDSImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Graphics
  • FMX.Types
  • GLScene.VectorGeometry
  • GXS.Graphics
  • GXS.Context
  • GLScene.TextureFormat
  • GXS.FileDDS
  • Formats.DXTC

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDDSImage |
Class EDDSException |


GXSysHelp v.2.5: Formatx.DDSImage: Class TDDSImage

Class TDDSImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formatx.DDSImage

Declaration

type TDDSImage = class(TBitmap)

Description

This item has no description.

Hierarchy

  • TBitmap
  • TDDSImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream);
Public | procedure SaveToStream(stream: TStream);

Description

Methods

Public procedure LoadFromStream(stream: TStream);

This item has no description.

Public procedure SaveToStream(stream: TStream);

override; -> E2170 Cannot override a non-virtual method override;


GXSysHelp v.2.5: Formatx.DDSImage: Class EDDSException

Class EDDSException

Description
Hierarchy
Fields
Methods
Properties

Unit

Formatx.DDSImage

Declaration

type EDDSException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EDDSException


GXSysHelp v.2.5: Formatx.HDRImage

Unit Formatx.HDRImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GXS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class THDRImage |


GXSysHelp v.2.5: Formatx.HDRImage: Class THDRImage

Class THDRImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formatx.HDRImage

Declaration

type THDRImage = class(TBitmap)

Description

This item has no description.

Hierarchy

  • TBitmap
  • THDRImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream);
Public | procedure SaveToStream(stream: TStream);

Description

Methods

Public procedure LoadFromStream(stream: TStream);

TODO : E2170 Cannot override a non-virtual method

Public procedure SaveToStream(stream: TStream);

in VCL override;


GXSysHelp v.2.5: Formatx.Q3MD3

Unit Formatx.Q3MD3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO
  • GXS.VectorFileObjects
  • GXS.Material
  • Formats.MD3

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMD3TagList |

Functions and Procedures

procedure LoadQ3Anims(Animations: TgxActorAnimations; FileName: string; NamePrefix: string); overload;
procedure LoadQ3Anims(Animations: TgxActorAnimations; Strings: TStrings; NamePrefix: string); overload;
procedure LoadQ3Skin(FileName: string; Actor: TgxActor);

Description

Functions and Procedures

procedure LoadQ3Anims(Animations: TgxActorAnimations; FileName: string; NamePrefix: string); overload;

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'

procedure LoadQ3Anims(Animations: TgxActorAnimations; Strings: TStrings; NamePrefix: string); overload;

This item has no description.

procedure LoadQ3Skin(FileName: string; Actor: TgxActor);

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.


GXSysHelp v.2.5: Formatx.Q3MD3: Class TMD3TagList

Class TMD3TagList

Description
Hierarchy
Fields
Methods
Properties

Unit

Formatx.Q3MD3

Declaration

type TMD3TagList = class(TObject)

Description

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.

Hierarchy

  • TObject
  • TMD3TagList

Overview

Fields

Private | FTags: array of TMD3Tag;
Private | FNumTags: Integer;
Private | FNumFrames: Integer;

Methods

Public | function GetTransform(TagName: string; Frame: Integer): TMatrix4f;
Private | function GetTag(index: Integer): TMD3Tag;
Public | procedure LoadFromFile(FileName: String);
Public | procedure LoadFromStream(AStream: TStream);

Properties

Public | property FrameCount: Integer read FNumFrames;
Public | property TagCount: Integer read FNumTags;
Public | property Tags[index: Integer]: TMD3Tag read GetTag;

Description

Fields

Private FTags: array of TMD3Tag;

This item has no description.

Private FNumTags: Integer;

This item has no description.

Private FNumFrames: Integer;

This item has no description.

Methods

Public function GetTransform(TagName: string; Frame: Integer): TMatrix4f;

This item has no description.

Private function GetTag(index: Integer): TMD3Tag;

This item has no description.

Public procedure LoadFromFile(FileName: String);

This item has no description.

Public procedure LoadFromStream(AStream: TStream);

This item has no description.

Properties

Public property FrameCount: Integer read FNumFrames;

This item has no description.

Public property TagCount: Integer read FNumTags;

This item has no description.

Public property Tags[index: Integer]: TMD3Tag read GetTag;


GXSysHelp v.2.5: Formatx.TGA

Unit Formatx.TGA

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.ApplicationFileIO
  • GLScene.Strings
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTGAImage |


GXSysHelp v.2.5: Formatx.TGA: Class TgxTGAImage

Class TgxTGAImage

Description
Hierarchy
Fields
Methods
Properties

Unit

Formatx.TGA

Declaration

type TgxTGAImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxTGAImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GXSysHelp v.2.5: FRxColorEditor

Unit FRxColorEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Graphics
  • FMX.Controls
  • FMX.Forms
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Colors
  • FMX.Edit
  • FMX.Controls.Presentation
  • FMX.Objects
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.Color
  • GXS.Texture

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TColorEditorFrame |


GXSysHelp v.2.5: FRxColorEditor: Class TColorEditorFrame

Class TColorEditorFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

FRxColorEditor

Declaration

type TColorEditorFrame = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TColorEditorFrame

Overview

Fields

Public | Label1: TLabel;
Public | Label2: TLabel;
Public | Label3: TLabel;
Public | Label4: TLabel;
Public | Panel1: TPanel;
Public | ColorEditorPaintBox: TPaintBox;
Public | RedEdit: TEdit;
Public | GreenEdit: TEdit;
Public | BlueEdit: TEdit;
Public | AlphaEdit: TEdit;
Public | PAPreview: TColorPanel;
Private | FOnChange: TNotifyEvent;
Private | Updating: Boolean;
Private | WorkBitmap: TBitmap;
Private | RedValue: Integer;
Private | GreenValue: Integer;
Private | BlueValue: Integer;
Private | AlphaVAlue: Integer;
Private | DraggingValue: (None, Red, Green, Blue, Alpha);

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetColor: THomogeneousFltVector;
Public | procedure AlphaEditChange(Sender: TObject);
Public | procedure BlueEditChange(Sender: TObject);
Public | procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);
Public | procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);
Public | procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);
Public | procedure ColorEditorPaintBoxPaint(Sender: TObject; Canvas: TCanvas);
Public | procedure FrameResize(Sender: TObject);
Public | procedure GreenEditChange(Sender: TObject);
Public | procedure PAPreviewDblClick(Sender: TObject);
Public | procedure RedEditChange(Sender: TObject);
Public | procedure TBEChange(Sender: TObject);
Private | procedure ContentsChanged;
Private | procedure DragColorSliderToPosition(XPos: Integer);
Private | procedure DrawContents;
Private | procedure SetColor(const val: THomogeneousFltVector);

Properties

Public | property Color: THomogeneousFltVector read GetColor write SetColor;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Public Label1: TLabel;

This item has no description.

Public Label2: TLabel;

This item has no description.

Public Label3: TLabel;

This item has no description.

Public Label4: TLabel;

This item has no description.

Public Panel1: TPanel;

This item has no description.

Public ColorEditorPaintBox: TPaintBox;

This item has no description.

Public RedEdit: TEdit;

This item has no description.

Public GreenEdit: TEdit;

This item has no description.

Public BlueEdit: TEdit;

This item has no description.

Public AlphaEdit: TEdit;

This item has no description.

Public PAPreview: TColorPanel;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private Updating: Boolean;

This item has no description.

Private WorkBitmap: TBitmap;

This item has no description.

Private RedValue: Integer;

This item has no description.

Private GreenValue: Integer;

This item has no description.

Private BlueValue: Integer;

This item has no description.

Private AlphaVAlue: Integer;

This item has no description.

Private DraggingValue: (None, Red, Green, Blue, Alpha);

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetColor: THomogeneousFltVector;

This item has no description.

Public procedure AlphaEditChange(Sender: TObject);

This item has no description.

Public procedure BlueEditChange(Sender: TObject);

This item has no description.

Public procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure ColorEditorPaintBoxPaint(Sender: TObject; Canvas: TCanvas);

This item has no description.

Public procedure FrameResize(Sender: TObject);

This item has no description.

Public procedure GreenEditChange(Sender: TObject);

This item has no description.

Public procedure PAPreviewDblClick(Sender: TObject);

This item has no description.

Public procedure RedEditChange(Sender: TObject);

This item has no description.

Public procedure TBEChange(Sender: TObject);

This item has no description.

Private procedure ContentsChanged;

This item has no description.

Private procedure DragColorSliderToPosition(XPos: Integer);

This item has no description.

Private procedure DrawContents;

This item has no description.

Private procedure SetColor(const val: THomogeneousFltVector);

This item has no description.

Properties

Public property Color: THomogeneousFltVector read GetColor write SetColor;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;


GXSysHelp v.2.5: FRxFaceEditor

Unit FRxFaceEditor

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Graphics
  • FMX.Controls
  • FMX.Forms
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.TabControl
  • FMX.Controls.Presentation
  • FMX.Edit
  • FRxColorEditor
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFaceEditorFrame |


GXSysHelp v.2.5: FRxFaceEditor: Class TFaceEditorFrame

Class TFaceEditorFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

FRxFaceEditor

Declaration

type TFaceEditorFrame = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TFaceEditorFrame

Overview

Fields

Public | TabControl: TTabControl;
Public | TIAmbient: TTabItem;
Public | TIDiffuse: TTabItem;
Public | TIEmission: TTabItem;
Public | TISpecular: TTabItem;
Public | CEAmbiant: TColorEditorFrame;
Public | Label1: TLabel;
Public | CEDiffuse: TColorEditorFrame;
Public | CEEmission: TColorEditorFrame;
Public | CESpecular: TColorEditorFrame;
Public | TrackBar: TTrackBar;
Public | Edit: TEdit;
Private | FOnChange: TNotifyEvent;
Private | Updating: Boolean;
Private | FFaceProperties: TgxFaceProperties;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetValue: Single;
Private | function GetValueMax: Single;
Private | function GetValueMin: Single;
Public | procedure EditChange(Sender: TObject);
Public | procedure TrackBarChange(Sender: TObject);
Private | procedure OnColorChange(Sender: TObject);
Private | procedure SetFaceProperties(const val: TgxFaceProperties);
Private | procedure SetValue(const val : Single);
Private | procedure SetValueMax(const val : Single);
Private | procedure SetValueMin(const val : Single);

Properties

Public | property FaceProperties: TgxFaceProperties read FFaceProperties write SetFaceProperties;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Public TabControl: TTabControl;

This item has no description.

Public TIAmbient: TTabItem;

This item has no description.

Public TIDiffuse: TTabItem;

This item has no description.

Public TIEmission: TTabItem;

This item has no description.

Public TISpecular: TTabItem;

This item has no description.

Public CEAmbiant: TColorEditorFrame;

This item has no description.

Public Label1: TLabel;

This item has no description.

Public CEDiffuse: TColorEditorFrame;

This item has no description.

Public CEEmission: TColorEditorFrame;

This item has no description.

Public CESpecular: TColorEditorFrame;

This item has no description.

Public TrackBar: TTrackBar;

This item has no description.

Public Edit: TEdit;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private Updating: Boolean;

This item has no description.

Private FFaceProperties: TgxFaceProperties;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetValue: Single;

This item has no description.

Private function GetValueMax: Single;

This item has no description.

Private function GetValueMin: Single;

This item has no description.

Public procedure EditChange(Sender: TObject);

This item has no description.

Public procedure TrackBarChange(Sender: TObject);

This item has no description.

Private procedure OnColorChange(Sender: TObject);

This item has no description.

Private procedure SetFaceProperties(const val: TgxFaceProperties);

This item has no description.

Private procedure SetValue(const val : Single);

This item has no description.

Private procedure SetValueMax(const val : Single);

This item has no description.

Private procedure SetValueMin(const val : Single);

This item has no description.

Properties

Public property FaceProperties: TgxFaceProperties read FFaceProperties write SetFaceProperties;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;


GXSysHelp v.2.5: FRxMaterialPreview

Unit FRxMaterialPreview

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Variants
  • System.Math.Vectors
  • FMX.Types
  • FMX.Graphics
  • FMX.Controls
  • FMX.Forms
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.Media
  • FMX.Viewport3D
  • FMX.ListBox
  • FMX.Types3D
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.MaterialSources
  • FMX.Layers3D
  • GXS.BaseClasses
  • GXS.Scene
  • GXS.Material
  • GXS.HUDObjects
  • GXS.GeomObjects
  • GXS.Color
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialPreviewFrame |


GXSysHelp v.2.5: FRxMaterialPreview: Class TMaterialPreviewFrame

Class TMaterialPreviewFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

FRxMaterialPreview

Declaration

type TMaterialPreviewFrame = class(TFrame)

Description

GXS.SceneViewer,

Hierarchy

  • TFrame
  • TMaterialPreviewFrame

Overview

Fields

Public | CBObject: TComboBox;
Public | Camera: TCamera;
Public | Cube: TCube;
Public | Sphere: TSphere;
Public | LightSource: TLight;
Public | CBBackground: TComboBox;
Public | BackGroundSprite: TImage3D;
Public | LightMaterialSource: TLightMaterialSource;
Public | Cone: TCone;
Public | Teapot: TModel3D;
Public | World: TDummy;
Public | Light: TDummy;
Public | FireSphere: TSphere;
Public | GLSViewer: TViewport3D;
Private | FLibMaterial: TgxAbstractLibMaterial;
Public | IsMouseUp: Boolean;
Public | Down: TPointF;
Public | GLMaterialLibrary: TgxMaterialLibrary;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | function GetLibMaterial: TgxAbstractLibMaterial;
Private | function GetMaterial: TgxMaterial;
Public | procedure CBBackgroundChange(Sender: TObject);
Public | procedure CBObjectChange(Sender: TObject);
Public | procedure GLSViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);
Public | procedure GLSViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);
Public | procedure GLSViewerMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);
Public | procedure GLSViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; var Handled: Boolean);
Private | procedure SetLibMaterial(const Value: TgxAbstractLibMaterial);
Private | procedure SetMaterial(const Value: TgxMaterial);

Properties

Public | property LibMaterial : TgxAbstractLibMaterial read GetLibMaterial write SetLibMaterial;
Public | property Material : TgxMaterial read GetMaterial write SetMaterial;

Description

Fields

Public CBObject: TComboBox;

This item has no description.

Public Camera: TCamera;

This item has no description.

Public Cube: TCube;

This item has no description.

Public Sphere: TSphere;

This item has no description.

Public LightSource: TLight;

This item has no description.

Public CBBackground: TComboBox;

This item has no description.

Public BackGroundSprite: TImage3D;

This item has no description.

Public LightMaterialSource: TLightMaterialSource;

This item has no description.

Public Cone: TCone;

This item has no description.

Public Teapot: TModel3D;

This item has no description.

Public World: TDummy;

This item has no description.

Public Light: TDummy;

This item has no description.

Public FireSphere: TSphere;

This item has no description.

Public GLSViewer: TViewport3D;

This item has no description.

Private FLibMaterial: TgxAbstractLibMaterial;

This item has no description.

Public IsMouseUp: Boolean;

This item has no description.

Public Down: TPointF;

This item has no description.

Public GLMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private function GetLibMaterial: TgxAbstractLibMaterial;

This item has no description.

Private function GetMaterial: TgxMaterial;

This item has no description.

Public procedure CBBackgroundChange(Sender: TObject);

This item has no description.

Public procedure CBObjectChange(Sender: TObject);

This item has no description.

Public procedure GLSViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure GLSViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure GLSViewerMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Single);

This item has no description.

Public procedure GLSViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; var Handled: Boolean);

This item has no description.

Private procedure SetLibMaterial(const Value: TgxAbstractLibMaterial);

This item has no description.

Private procedure SetMaterial(const Value: TgxMaterial);

This item has no description.

Properties

Public property LibMaterial : TgxAbstractLibMaterial read GetLibMaterial write SetLibMaterial;

This item has no description.

Public property Material : TgxMaterial read GetMaterial write SetMaterial;


GXSysHelp v.2.5: FRxTextureEdit

Unit FRxTextureEdit

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.TypInfo
  • System.Classes
  • System.Variants
  • FMX.Types
  • FMX.Graphics
  • FMX.Controls
  • FMX.Forms
  • FMX.Dialogs
  • FMX.StdCtrls
  • FMX.ListBox
  • FMX.Controls.Presentation
  • GXS.Graphics
  • GLScene.TextureFormat
  • GXS.Texture
  • GXS.TextureImageEditors

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TTextureEditFrame |


GXSysHelp v.2.5: FRxTextureEdit: Class TTextureEditFrame

Class TTextureEditFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

FRxTextureEdit

Declaration

type TTextureEditFrame = class(TFrame)

Description

This item has no description.

Hierarchy

  • TFrame
  • TTextureEditFrame

Overview

Fields

Public | LabelImage: TLabel;
Public | SBEditImage: TSpeedButton;
Public | CBMagFilter: TComboBox;
Public | LabelImageAlpha: TLabel;
Public | LabelTextureWrap: TLabel;
Public | CBMinFilter: TComboBox;
Public | CBTextureMode: TComboBox;
Public | LabelMagFilter: TLabel;
Public | LabelMinFilter: TLabel;
Public | CBTextureWrap: TComboBox;
Public | CBDisabled: TCheckBox;
Public | CBImageClass: TComboBox;
Public | CBImageAlpha: TComboBox;
Public | LabelFilterQuality: TLabel;
Public | CBFilteringQuality: TComboBox;
Public | LabelTextureMode: TLabel;
Private | FTexture: TgxTexture;
Private | FOnChange: TNotifyEvent;
Private | Changeing: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CBDisabledClick(Sender: TObject);
Public | procedure CBFilteringQualityChange(Sender: TObject);
Public | procedure CBImageAlphaChange(Sender: TObject);
Public | procedure CBImageClassChange(Sender: TObject);
Public | procedure CBMagFilterChange(Sender: TObject);
Public | procedure CBMinFilterChange(Sender: TObject);
Public | procedure CBTextureModeChange(Sender: TObject);
Public | procedure CBTextureWrapChange(Sender: TObject);
Public | procedure SBEditImageClick(Sender: TObject);

Properties

Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public | property Texture: TgxTexture read FTexture write SetTexture;

Description

Fields

Public LabelImage: TLabel;

This item has no description.

Public SBEditImage: TSpeedButton;

This item has no description.

Public CBMagFilter: TComboBox;

This item has no description.

Public LabelImageAlpha: TLabel;

This item has no description.

Public LabelTextureWrap: TLabel;

This item has no description.

Public CBMinFilter: TComboBox;

This item has no description.

Public CBTextureMode: TComboBox;

This item has no description.

Public LabelMagFilter: TLabel;

This item has no description.

Public LabelMinFilter: TLabel;

This item has no description.

Public CBTextureWrap: TComboBox;

This item has no description.

Public CBDisabled: TCheckBox;

This item has no description.

Public CBImageClass: TComboBox;

This item has no description.

Public CBImageAlpha: TComboBox;

This item has no description.

Public LabelFilterQuality: TLabel;

This item has no description.

Public CBFilteringQuality: TComboBox;

This item has no description.

Public LabelTextureMode: TLabel;

This item has no description.

Private FTexture: TgxTexture;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private Changeing: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CBDisabledClick(Sender: TObject);

This item has no description.

Public procedure CBFilteringQualityChange(Sender: TObject);

This item has no description.

Public procedure CBImageAlphaChange(Sender: TObject);

This item has no description.

Public procedure CBImageClassChange(Sender: TObject);

This item has no description.

Public procedure CBMagFilterChange(Sender: TObject);

This item has no description.

Public procedure CBMinFilterChange(Sender: TObject);

This item has no description.

Public procedure CBTextureModeChange(Sender: TObject);

This item has no description.

Public procedure CBTextureWrapChange(Sender: TObject);

This item has no description.

Public procedure SBEditImageClick(Sender: TObject);

This item has no description.

Properties

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Public property Texture: TgxTexture read FTexture write SetTexture;


GXSysHelp v.2.5: GBE.Clouds

Unit GBE.Clouds

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Generics.Collections
  • System.Math.Vectors
  • System.Threading
  • FMX.Types
  • FMX.Types3D
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBEClouds |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Clouds: Class TGBEClouds

Class TGBEClouds

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Clouds

Declaration

type TGBEClouds = class(TDummy)

Description

This item has no description.

Hierarchy

  • TDummy
  • TGBEClouds

Overview

Fields

Private | fListClouds: TList<TPlane>;
Private | fNbClouds: integer;
Private | fLimits: integer;
Private | fWindSpeed: single;
Private | fActiveWind: boolean;
Private | fUseTasks: boolean;
Private | fTexturesClouds: TList<TTextureMaterialSource>;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetActiveWind: boolean;
Private | function GetLimits: integer;
Private | function GetNbClouds: integer;
Private | function GetWindSpeed: single;
Public | procedure AddTextureCloud(TextureMaterial: TTextureMaterialSource);
Public | procedure DeleteTexturesClouds;
Public | procedure GenerateClouds;
Public | procedure MoveClouds;
Private | procedure DeplacementNuages;
Private | procedure SetActiveWind(const Value: boolean);
Private | procedure SetLimits(const Value: integer);
Private | procedure SetNbClouds(const Value: integer);
Private | procedure SetWindSpeed(const Value: single);

Properties

Published | property ActiveWind: boolean read GetActiveWind write SetActiveWind;
Published | property Limits: integer read GetLimits write SetLimits;
Published | property NbClouds: integer read GetNbClouds write SetNbClouds;
Published | property UseTasks: boolean read fUseTasks write fUseTasks;
Published | property WindSpeed: single read GetWindSpeed write SetWindSpeed;

Description

Fields

Private fListClouds: TList<TPlane>;

This item has no description.

Private fNbClouds: integer;

This item has no description.

Private fLimits: integer;

This item has no description.

Private fWindSpeed: single;

This item has no description.

Private fActiveWind: boolean;

This item has no description.

Private fUseTasks: boolean;

This item has no description.

Private fTexturesClouds: TList<TTextureMaterialSource>;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetActiveWind: boolean;

This item has no description.

Private function GetLimits: integer;

This item has no description.

Private function GetNbClouds: integer;

This item has no description.

Private function GetWindSpeed: single;

This item has no description.

Public procedure AddTextureCloud(TextureMaterial: TTextureMaterialSource);

This item has no description.

Public procedure DeleteTexturesClouds;

This item has no description.

Public procedure GenerateClouds;

This item has no description.

Public procedure MoveClouds;

This item has no description.

Private procedure DeplacementNuages;

This item has no description.

Private procedure SetActiveWind(const Value: boolean);

This item has no description.

Private procedure SetLimits(const Value: integer);

This item has no description.

Private procedure SetNbClouds(const Value: integer);

This item has no description.

Private procedure SetWindSpeed(const Value: single);

This item has no description.

Properties

Published property ActiveWind: boolean read GetActiveWind write SetActiveWind;

This item has no description.

Published property Limits: integer read GetLimits write SetLimits;

This item has no description.

Published property NbClouds: integer read GetNbClouds write SetNbClouds;

This item has no description.

Published property UseTasks: boolean read fUseTasks write fUseTasks;

This item has no description.

Published property WindSpeed: single read GetWindSpeed write SetWindSpeed;


GXSysHelp v.2.5: GBE.ConeExtend

Unit GBE.ConeExtend

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • System.Math.Vectors
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCustomMeshHelper |
Class TGBEConeExtend |

Functions and Procedures

procedure Register;

Types

TConeForme = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TConeForme = (...);

This item has no description.

Values
  • PyramidTriangle
  • PyramidSquare
  • Tipi
  • Cone


GXSysHelp v.2.5: GBE.ConeExtend: Class TCustomMeshHelper

Class TCustomMeshHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.ConeExtend

Declaration

type TCustomMeshHelper = class(TCustomMesh)

Description

This item has no description.

Hierarchy

  • TCustomMesh
  • TCustomMeshHelper


GXSysHelp v.2.5: GBE.ConeExtend: Class TGBEConeExtend

Class TGBEConeExtend

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.ConeExtend

Declaration

type TGBEConeExtend = class(TCone)

Description

This item has no description.

Hierarchy

  • TCone
  • TGBEConeExtend

Overview

Fields

Private | fForme: TConeForme;
Private | fShowlines: boolean;
Private | fMaterialLignes: TColorMaterialSource;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Render; override;
Private | procedure CreateGBECone(const aData: TMeshData; const aForme: TConeForme = TConeForme.Cone);
Private | procedure SetForme(const Value: TConeForme);

Properties

Published | property Forme: TConeForme read fForme write SetForme;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property ShowLines: boolean read fShowlines write fShowlines;

Description

Fields

Private fForme: TConeForme;

This item has no description.

Private fShowlines: boolean;

This item has no description.

Private fMaterialLignes: TColorMaterialSource;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Render; override;

This item has no description.

Private procedure CreateGBECone(const aData: TMeshData; const aForme: TConeForme = TConeForme.Cone);

This item has no description.

Private procedure SetForme(const Value: TConeForme);

This item has no description.

Properties

Published property Forme: TConeForme read fForme write SetForme;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;


GXSysHelp v.2.5: GBE.CubeExtend

Unit GBE.CubeExtend

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBECubeExtend |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.CubeExtend: Class TGBECubeExtend

Class TGBECubeExtend

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.CubeExtend

Declaration

type TGBECubeExtend = class(TDummy)

Description

This item has no description.

Hierarchy

  • TDummy
  • TGBECubeExtend

Overview

Fields

Private | FMaterialSourceFaceFront: TMaterialSource;
Private | FMaterialSourceFaceRight: TMaterialSource;
Private | FMaterialSourceFaceBack: TMaterialSource;
Private | FMaterialSourceFaceLeft: TMaterialSource;
Private | FMaterialSourceFaceTop: TMaterialSource;
Private | FMaterialSourceFaceBottom: TMaterialSource;
Private | fSubdivisionsWidth: integer;
Private | fSubdivisionsHeight: integer;
Private | fSubdivisionsDepth: integer;
Private | fFaceFront: TPlane;
Private | fFaceRight: TPlane;
Private | fFaceBack: TPlane;
Private | fFaceLeft: TPlane;
Private | fFaceTop: TPlane;
Private | fFaceBottom: TPlane;
Private | fFaceFrontVisible: boolean;
Private | fFaceRightVisible: boolean;
Private | fFaceBackVisible: boolean;
Private | fFaceLeftVisible: boolean;
Private | fFaceTopVisible: boolean;
Private | fFaceBottomVisible: boolean;
Private | fWidth: single;
Private | fDepth: single;
Private | fHeight: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure DrawCube;
Private | procedure SetDepth(const Value: single);
Private | procedure SetFaceBackVisible(const Value: boolean);
Private | procedure SetFaceBottomVisible(const Value: boolean);
Private | procedure SetFaceFrontVisible(const Value: boolean);
Private | procedure SetFaceLeftVisible(const Value: boolean);
Private | procedure SetFaceRightVisible(const Value: boolean);
Private | procedure SetFaceTopVisible(const Value: boolean);
Private | procedure SetHeight(const Value: single);
Private | procedure SetMaterialSourceFaceBack(const Value: TMaterialSource);
Private | procedure SetMaterialSourceFaceBottom(const Value: TMaterialSource);
Private | procedure SetMaterialSourceFaceFront(const Value: TMaterialSource);
Private | procedure SetMaterialSourceFaceLeft(const Value: TMaterialSource);
Private | procedure SetMaterialSourceFaceRight(const Value: TMaterialSource);
Private | procedure SetMaterialSourceFaceTop(const Value: TMaterialSource);
Private | procedure SetSubdivisionsDepth(const Value: integer);
Private | procedure SetSubdivisionsHeight(const Value: integer);
Private | procedure SetSubdivisionsWidth(const Value: integer);
Private | procedure SetWidth(const Value: single);

Properties

Published | property Depth: single read fDepth write SetDepth;
Published | property FaceBackVisible: boolean read fFaceBackVisible write SetFaceBackVisible;
Published | property FaceBottomVisible: boolean read fFaceBottomVisible write SetFaceBottomVisible;
Published | property FaceFrontVisible: boolean read fFaceFrontVisible write SetFaceFrontVisible;
Published | property FaceLeftVisible: boolean read fFaceLeftVisible write SetFaceLeftVisible;
Published | property FaceRightVisible: boolean read fFaceRightVisible write SetFaceRightVisible;
Published | property FaceTopVisible: boolean read fFaceTopVisible write SetFaceTopVisible;
Published | property Height: single read fHeight write SetHeight;
Published | property MaterialSourceFaceBack: TMaterialSource read FMaterialSourceFaceBack write SetMaterialSourceFaceBack;
Published | property MaterialSourceFaceBottom: TMaterialSource read FMaterialSourceFaceBottom write SetMaterialSourceFaceBottom;
Published | property MaterialSourceFaceFront: TMaterialSource read FMaterialSourceFaceFront write SetMaterialSourceFaceFront;
Published | property MaterialSourceFaceLeft: TMaterialSource read FMaterialSourceFaceLeft write SetMaterialSourceFaceLeft;
Published | property MaterialSourceFaceRight: TMaterialSource read FMaterialSourceFaceRight write SetMaterialSourceFaceRight;
Published | property MaterialSourceFaceTop: TMaterialSource read FMaterialSourceFaceTop write SetMaterialSourceFaceTop;
Published | property SubdivisionsDepth: integer read fSubdivisionsDepth write SetSubdivisionsDepth;
Published | property SubdivisionsHeight: integer read fSubdivisionsHeight write SetSubdivisionsHeight;
Published | property SubdivisionsWidth: integer read fSubdivisionsWidth write SetSubdivisionsWidth;
Published | property Width: single read fWidth write SetWidth;

Description

Fields

Private FMaterialSourceFaceFront: TMaterialSource;

This item has no description.

Private FMaterialSourceFaceRight: TMaterialSource;

This item has no description.

Private FMaterialSourceFaceBack: TMaterialSource;

This item has no description.

Private FMaterialSourceFaceLeft: TMaterialSource;

This item has no description.

Private FMaterialSourceFaceTop: TMaterialSource;

This item has no description.

Private FMaterialSourceFaceBottom: TMaterialSource;

This item has no description.

Private fSubdivisionsWidth: integer;

This item has no description.

Private fSubdivisionsHeight: integer;

This item has no description.

Private fSubdivisionsDepth: integer;

This item has no description.

Private fFaceFront: TPlane;

This item has no description.

Private fFaceRight: TPlane;

This item has no description.

Private fFaceBack: TPlane;

This item has no description.

Private fFaceLeft: TPlane;

This item has no description.

Private fFaceTop: TPlane;

This item has no description.

Private fFaceBottom: TPlane;

This item has no description.

Private fFaceFrontVisible: boolean;

This item has no description.

Private fFaceRightVisible: boolean;

This item has no description.

Private fFaceBackVisible: boolean;

This item has no description.

Private fFaceLeftVisible: boolean;

This item has no description.

Private fFaceTopVisible: boolean;

This item has no description.

Private fFaceBottomVisible: boolean;

This item has no description.

Private fWidth: single;

This item has no description.

Private fDepth: single;

This item has no description.

Private fHeight: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure DrawCube;

Drawing

Private procedure SetDepth(const Value: single);

This item has no description.

Private procedure SetFaceBackVisible(const Value: boolean);

This item has no description.

Private procedure SetFaceBottomVisible(const Value: boolean);

This item has no description.

Private procedure SetFaceFrontVisible(const Value: boolean);

Faces

Private procedure SetFaceLeftVisible(const Value: boolean);

This item has no description.

Private procedure SetFaceRightVisible(const Value: boolean);

This item has no description.

Private procedure SetFaceTopVisible(const Value: boolean);

This item has no description.

Private procedure SetHeight(const Value: single);

This item has no description.

Private procedure SetMaterialSourceFaceBack(const Value: TMaterialSource);

This item has no description.

Private procedure SetMaterialSourceFaceBottom(const Value: TMaterialSource);

This item has no description.

Private procedure SetMaterialSourceFaceFront(const Value: TMaterialSource);

Materials

Private procedure SetMaterialSourceFaceLeft(const Value: TMaterialSource);

This item has no description.

Private procedure SetMaterialSourceFaceRight(const Value: TMaterialSource);

This item has no description.

Private procedure SetMaterialSourceFaceTop(const Value: TMaterialSource);

This item has no description.

Private procedure SetSubdivisionsDepth(const Value: integer);

Subdivisions

Private procedure SetSubdivisionsHeight(const Value: integer);

This item has no description.

Private procedure SetSubdivisionsWidth(const Value: integer);

This item has no description.

Private procedure SetWidth(const Value: single);

This item has no description.

Properties

Published property Depth: single read fDepth write SetDepth;

This item has no description.

Published property FaceBackVisible: boolean read fFaceBackVisible write SetFaceBackVisible;

This item has no description.

Published property FaceBottomVisible: boolean read fFaceBottomVisible write SetFaceBottomVisible;

This item has no description.

Published property FaceFrontVisible: boolean read fFaceFrontVisible write SetFaceFrontVisible;

This item has no description.

Published property FaceLeftVisible: boolean read fFaceLeftVisible write SetFaceLeftVisible;

This item has no description.

Published property FaceRightVisible: boolean read fFaceRightVisible write SetFaceRightVisible;

This item has no description.

Published property FaceTopVisible: boolean read fFaceTopVisible write SetFaceTopVisible;

This item has no description.

Published property Height: single read fHeight write SetHeight;

This item has no description.

Published property MaterialSourceFaceBack: TMaterialSource read FMaterialSourceFaceBack write SetMaterialSourceFaceBack;

This item has no description.

Published property MaterialSourceFaceBottom: TMaterialSource read FMaterialSourceFaceBottom write SetMaterialSourceFaceBottom;

This item has no description.

Published property MaterialSourceFaceFront: TMaterialSource read FMaterialSourceFaceFront write SetMaterialSourceFaceFront;

This item has no description.

Published property MaterialSourceFaceLeft: TMaterialSource read FMaterialSourceFaceLeft write SetMaterialSourceFaceLeft;

This item has no description.

Published property MaterialSourceFaceRight: TMaterialSource read FMaterialSourceFaceRight write SetMaterialSourceFaceRight;

This item has no description.

Published property MaterialSourceFaceTop: TMaterialSource read FMaterialSourceFaceTop write SetMaterialSourceFaceTop;

This item has no description.

Published property SubdivisionsDepth: integer read fSubdivisionsDepth write SetSubdivisionsDepth;

This item has no description.

Published property SubdivisionsHeight: integer read fSubdivisionsHeight write SetSubdivisionsHeight;

This item has no description.

Published property SubdivisionsWidth: integer read fSubdivisionsWidth write SetSubdivisionsWidth;

This item has no description.

Published property Width: single read fWidth write SetWidth;


GXSysHelp v.2.5: GBE.Cubemap

Unit GBE.Cubemap

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Types
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Graphics
  • System.UITypes
  • FMX.Materials
  • FMX.types3D
  • FMX.Materialsources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBECubemap |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Cubemap: Class TGBECubemap

Class TGBECubemap

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Cubemap

Declaration

type TGBECubemap = class(TMesh)

Description

This item has no description.

Hierarchy

  • TMesh
  • TGBECubemap

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure GenerateCubemap;

Properties

Published | property HitTest default False;
Published | property Locked default False;
Published | property Visible default True;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure GenerateCubemap;

This item has no description.

Properties

Published property HitTest default False;

This item has no description.

Published property Locked default False;

This item has no description.

Published property Visible default True;


GXSysHelp v.2.5: GBE.CylinderExtend

Unit GBE.CylinderExtend

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • FMX.MaterialSources
  • System.Math.Vectors

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCustomMeshHelper |
Class TGBECylinderExtend |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.CylinderExtend: Class TCustomMeshHelper

Class TCustomMeshHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.CylinderExtend

Declaration

type TCustomMeshHelper = class(TCustomMesh)

Description

This item has no description.

Hierarchy

  • TCustomMesh
  • TCustomMeshHelper


GXSysHelp v.2.5: GBE.CylinderExtend: Class TGBECylinderExtend

Class TGBECylinderExtend

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.CylinderExtend

Declaration

type TGBECylinderExtend = class(TCylinder)

Description

This item has no description.

Hierarchy

  • TCylinder
  • TGBECylinderExtend

Overview

Fields

Private | fDiskTop: TDisk;
Private | fDiskBottom: TDisk;
Private | FMaterialSourceTop: TMaterialSource;
Private | FMaterialSourceBottom: TMaterialSource;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Render; override;
Private | procedure CreateGBECylinder;
Private | procedure SetMaterialSourceBottom(const Value: TMaterialSource);
Private | procedure SetMaterialSourceTop(const Value: TMaterialSource);

Properties

Published | property MaterialSourceBottom: TMaterialSource read FMaterialSourceBottom write SetMaterialSourceBottom;
Published | property MaterialSourceTop: TMaterialSource read FMaterialSourceTop write SetMaterialSourceTop;

Description

Fields

Private fDiskTop: TDisk;

This item has no description.

Private fDiskBottom: TDisk;

This item has no description.

Private FMaterialSourceTop: TMaterialSource;

This item has no description.

Private FMaterialSourceBottom: TMaterialSource;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Render; override;

This item has no description.

Private procedure CreateGBECylinder;

This item has no description.

Private procedure SetMaterialSourceBottom(const Value: TMaterialSource);

This item has no description.

Private procedure SetMaterialSourceTop(const Value: TMaterialSource);

This item has no description.

Properties

Published property MaterialSourceBottom: TMaterialSource read FMaterialSourceBottom write SetMaterialSourceBottom;

This item has no description.

Published property MaterialSourceTop: TMaterialSource read FMaterialSourceTop write SetMaterialSourceTop;


GXSysHelp v.2.5: GBE.Grass

Unit GBE.Grass

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.RTLConsts
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Graphics
  • System.UITypes
  • FMX.Materials
  • FMX.types3D
  • System.Types
  • System.Math.Vectors
  • FMX.Materialsources
  • System.Threading

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBEGrass |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Grass: Class TGBEGrass

Class TGBEGrass

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Grass

Declaration

type TGBEGrass = class(TMesh)

Description

This item has no description.

Hierarchy

  • TMesh
  • TGBEGrass

Overview

Fields

Private | fWind: boolean;
Private | fTemps: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure GenerateGrass;

Properties

Published | property HitTest default False;
Published | property Locked default False;
Published | property Temps: single read fTemps write fTemps;
Published | property Visible default True;
Published | property Wind: boolean read fWind write fWind;
Published | property ZWrite default False;

Description

Fields

Private fWind: boolean;

This item has no description.

Private fTemps: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure GenerateGrass;

This item has no description.

Properties

Published property HitTest default False;

This item has no description.

Published property Locked default False;

This item has no description.

Published property Temps: single read fTemps write fTemps;

This item has no description.

Published property Visible default True;

This item has no description.

Published property Wind: boolean read fWind write fWind;

This item has no description.

Published property ZWrite default False;


GXSysHelp v.2.5: GBE.Heightmap

Unit GBE.Heightmap

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.RTLConsts
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Graphics
  • System.Math.Vectors
  • FMX.types3D
  • System.UITypes
  • System.UIConsts
  • FMX.Effects
  • FMX.MaterialSources
  • System.Types
  • Math
  • uGBEUtils3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBEHeightmap |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Heightmap: Class TGBEHeightmap

Class TGBEHeightmap

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Heightmap

Declaration

type TGBEHeightmap = class(TMesh)

Description

This item has no description.

Hierarchy

  • TMesh
  • TGBEHeightmap

Overview

Fields

Private | fSubdivisionsX: integer;
Private | fSubdivisionsZ: integer;
Private | fFlou: integer;
Private | fHalfSubdivisionsX: integer;
Private | fHalfSubdivisionsZ: integer;
Private | fHeightmap: TBitmap;
Private | fTracerLignes: boolean;
Private | FUseRamp: boolean;
Private | fMaterialLignes: TColorMaterialSource;
Private | fMiseAEchelle: single;
Private | fMaxHauteur: single;
Private | fMinHauteur: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetHeight(P: TPoint3d): single;
Private | function GetFlou: integer;
Private | function GetTracerLignes: boolean;
Public | procedure LoadHeightmapFromFile(FileName: string);
Public | procedure LoadHeightmapFromResource(ResourceName: string);
Public | procedure LoadHeightmapFromStream(Stream: TStream);
Public | procedure RebuildMesh;
Private | procedure GenerateHeightmap(Const aData: TMeshData);
Private | procedure SetFlou(const Value: integer);
Private | procedure SetTracerLignes(const Value: boolean);
Private | procedure SetUseRamp(const Value: boolean);

Properties

Published | property Flou: integer read GetFlou write SetFlou;
Published | property HitTest default False;
Published | property Locked default True;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property MaxHeight: single read fMaxHauteur;
Published | property MinHeight: single read fMinHauteur;
Published | property MiseAEchelle: single read fMiseAEchelle;
Published | property ShowLines: boolean read GetTracerLignes write SetTracerLignes;
Published | property TwoSide default True;
Published | property UseRamp: boolean read FUseRamp write SetUseRamp;
Published | property Visible default True;
Published | property ZWrite default True;

Description

Fields

Private fSubdivisionsX: integer;

This item has no description.

Private fSubdivisionsZ: integer;

This item has no description.

Private fFlou: integer;

This item has no description.

Private fHalfSubdivisionsX: integer;

This item has no description.

Private fHalfSubdivisionsZ: integer;

This item has no description.

Private fHeightmap: TBitmap;

This item has no description.

Private fTracerLignes: boolean;

This item has no description.

Private FUseRamp: boolean;

This item has no description.

Private fMaterialLignes: TColorMaterialSource;

This item has no description.

Private fMiseAEchelle: single;

This item has no description.

Private fMaxHauteur: single;

This item has no description.

Private fMinHauteur: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetHeight(P: TPoint3d): single;

This item has no description.

Private function GetFlou: integer;

This item has no description.

Private function GetTracerLignes: boolean;

This item has no description.

Public procedure LoadHeightmapFromFile(FileName: string);

This item has no description.

Public procedure LoadHeightmapFromResource(ResourceName: string);

This item has no description.

Public procedure LoadHeightmapFromStream(Stream: TStream);

This item has no description.

Public procedure RebuildMesh;

This item has no description.

Private procedure GenerateHeightmap(Const aData: TMeshData);

This item has no description.

Private procedure SetFlou(const Value: integer);

This item has no description.

Private procedure SetTracerLignes(const Value: boolean);

This item has no description.

Private procedure SetUseRamp(const Value: boolean);

This item has no description.

Properties

Published property Flou: integer read GetFlou write SetFlou;

This item has no description.

Published property HitTest default False;

This item has no description.

Published property Locked default True;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property MaxHeight: single read fMaxHauteur;

This item has no description.

Published property MinHeight: single read fMinHauteur;

This item has no description.

Published property MiseAEchelle: single read fMiseAEchelle;

This item has no description.

Published property ShowLines: boolean read GetTracerLignes write SetTracerLignes;

This item has no description.

Published property TwoSide default True;

This item has no description.

Published property UseRamp: boolean read FUseRamp write SetUseRamp;

This item has no description.

Published property Visible default True;

This item has no description.

Published property ZWrite default True;


GXSysHelp v.2.5: GBE.Joystick

Unit GBE.Joystick

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Controls
  • FMX.Layouts
  • GBE.PlayerPosition
  • System.Math.Vectors
  • System.Types
  • FMX.Viewport3D
  • System.UITypes
  • FMX.Dialogs
  • FMX.Objects
  • FMX.Graphics
  • FMX.Ani
  • uGBEUtils3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBEJoystick |

Functions and Procedures

procedure Register;

Types

TGBEJoystickType = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TGBEJoystickType = (...);

This item has no description.

Values
  • jtOrientation
  • jtDeplacement
  • jtOrientationDeplacement


GXSysHelp v.2.5: GBE.Joystick: Class TGBEJoystick

Class TGBEJoystick

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Joystick

Declaration

type TGBEJoystick = class(TLayout)

Description

This item has no description.

Hierarchy

  • TLayout
  • TGBEJoystick

Overview

Fields

Private | fPlayerPosition: TGBEPlayerPosition;
Private | FPosDepartCurseur: TPointF;
Private | fViewport3D: TViewport3D;
Private | fCircle: TCircle;
Private | fCircle2: TCircle;
Private | fSensitivity: Integer;
Private | fShowIntegrateJoystick: Boolean;
Private | useJoystick: Boolean;
Private | fMouseCapture: Boolean;
Private | fPoint: TPoint3D;
Private | fJoystickType: TGBEJoystickType;
Private | Offset: TPointF;
Private | fAcceleration: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function OrientationKeyManagement(rightKey, leftKey, upKey, downKey, goUp, goDown, sideWayRight, sideWayLeft: Boolean; sensibility, speed, maxspeed: Single): Single;
Private | function GetDirection: TPoint3D;
Private | function GetDirectionSidewayLeft: TPoint3D;
Private | function GetDirectionSidewayRight: TPoint3D;
Private | function GetMouseCapture: Boolean;
Public | procedure DoMouseLeave; override;
Public | procedure InitialiserJoystick;
Public | procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;
Public | procedure MouseMove(Shift: TShiftState; X, Y: Single); override;
Public | procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;
Public | procedure Paint; override;
Public | procedure Resize; override;
Private | procedure SetAngleDeVue(const Value: TPointF);
Private | procedure SetJoystickType(const Value: TGBEJoystickType);
Private | procedure SetMouseCapture(const Value: Boolean);
Private | procedure SetShowIntegrateJoystick(const Value: Boolean);

Properties

Published | property Acceleration: Single read fAcceleration write fAcceleration;
Published | property AngleDeVue: TPointF write SetAngleDeVue;
Published | property Deplacement: TPoint3D read fPoint write fPoint;
Published | property Direction: TPoint3D read GetDirection;
Published | property DirectionSidewayLeft: TPoint3D read GetDirectionSidewayLeft;
Published | property DirectionSidewayRight: TPoint3D read GetDirectionSidewayRight;
Published | property HitTest default true;
Published | property JoystickType: TGBEJoystickType read fJoystickType write SetJoystickType;
Published | property MouseCapture: Boolean read GetMouseCapture write SetMouseCapture;
Published | property PlayerPosition: TGBEPlayerPosition read fPlayerPosition write fPlayerPosition;
Published | property Sensitivity: Integer read fSensitivity write fSensitivity;
Published | property ShowIntegrateJoystick: Boolean read fShowIntegrateJoystick write SetShowIntegrateJoystick;
Published | property Viewport3D: TViewport3D read fViewport3D write fViewport3D;

Description

Fields

Private fPlayerPosition: TGBEPlayerPosition;

This item has no description.

Private FPosDepartCurseur: TPointF;

This item has no description.

Private fViewport3D: TViewport3D;

Position of the mouse mark at the start of the mouse movement

Private fCircle: TCircle;

This item has no description.

Private fCircle2: TCircle;

This item has no description.

Private fSensitivity: Integer;

This item has no description.

Private fShowIntegrateJoystick: Boolean;

This item has no description.

Private useJoystick: Boolean;

This item has no description.

Private fMouseCapture: Boolean;

This item has no description.

Private fPoint: TPoint3D;

This item has no description.

Private fJoystickType: TGBEJoystickType;

This item has no description.

Private Offset: TPointF;

This item has no description.

Private fAcceleration: Single;

Offset between click location and joystick circle center

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OrientationKeyManagement(rightKey, leftKey, upKey, downKey, goUp, goDown, sideWayRight, sideWayLeft: Boolean; sensibility, speed, maxspeed: Single): Single;

This item has no description.

Private function GetDirection: TPoint3D;

Changing the viewing angle

Private function GetDirectionSidewayLeft: TPoint3D;

This item has no description.

Private function GetDirectionSidewayRight: TPoint3D;

This item has no description.

Private function GetMouseCapture: Boolean;

This item has no description.

Public procedure DoMouseLeave; override;

This item has no description.

Public procedure InitialiserJoystick;

This item has no description.

Public procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;

This item has no description.

Public procedure MouseMove(Shift: TShiftState; X, Y: Single); override;

This item has no description.

Public procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;

This item has no description.

Public procedure Paint; override;

This item has no description.

Public procedure Resize; override;

This item has no description.

Private procedure SetAngleDeVue(const Value: TPointF);

This item has no description.

Private procedure SetJoystickType(const Value: TGBEJoystickType);

This item has no description.

Private procedure SetMouseCapture(const Value: Boolean);

This item has no description.

Private procedure SetShowIntegrateJoystick(const Value: Boolean);

This item has no description.

Properties

Published property Acceleration: Single read fAcceleration write fAcceleration;

This item has no description.

Published property AngleDeVue: TPointF write SetAngleDeVue;

This item has no description.

Published property Deplacement: TPoint3D read fPoint write fPoint;

This item has no description.

Published property Direction: TPoint3D read GetDirection;

Viewing angle property

Published property DirectionSidewayLeft: TPoint3D read GetDirectionSidewayLeft;

This item has no description.

Published property DirectionSidewayRight: TPoint3D read GetDirectionSidewayRight;

This item has no description.

Published property HitTest default true;

This item has no description.

Published property JoystickType: TGBEJoystickType read fJoystickType write SetJoystickType;

This item has no description.

Published property MouseCapture: Boolean read GetMouseCapture write SetMouseCapture;

This item has no description.

Published property PlayerPosition: TGBEPlayerPosition read fPlayerPosition write fPlayerPosition;

This item has no description.

Published property Sensitivity: Integer read fSensitivity write fSensitivity;

This item has no description.

Published property ShowIntegrateJoystick: Boolean read fShowIntegrateJoystick write SetShowIntegrateJoystick;

This item has no description.

Published property Viewport3D: TViewport3D read fViewport3D write fViewport3D;


GXSysHelp v.2.5: GBE.omOceanWaves

Unit GBE.omOceanWaves

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • System.Types
  • System.Threading
  • System.Math.Vectors
  • System.Generics.Collections
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • FMX.MaterialSources
  • GBE.PlaneExtend

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TWaveSystem |
Class TOceanSurface |
Class TWindArrowSurface |
Class TTwoWavesOceanSurface |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

compatibility w/ old forms


GXSysHelp v.2.5: GBE.omOceanWaves: Class TWaveSystem

Class TWaveSystem

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.omOceanWaves

Declaration

type TWaveSystem = class(TComponent)

Description

TGBEPlaneExtend and WaveRec

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TWaveSystem

Overview

Fields

Private | fTime: Single;
Private | fAmplitude: Single;
Private | fLongueur: Single;
Private | fVitesse: Single;
Private | fOrigine: TPoint3D;
Private | fAmplitude2: Single;
Private | fLongueur2: Single;
Private | fVitesse2: Single;
Private | fOrigine2: TPoint3D;
Private | fAmplitude3: Single;
Private | fLongueur3: Single;
Private | fVitesse3: Single;
Private | fOrigine3: TPoint3D;
Private | fAmplitude4: Single;
Private | fLongueur4: Single;
Private | fVitesse4: Single;
Private | fOrigine4: TPoint3D;
Private | fAmplitude5: Single;
Private | fLongueur5: Single;
Private | fVitesse5: Single;
Private | fOrigine5: TPoint3D;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure IncTime;

Properties

Published | property Amplitude: Single read fAmplitude write fAmplitude;
Published | property Amplitude2: Single read fAmplitude2 write fAmplitude2;
Published | property Amplitude3: Single read fAmplitude3 write fAmplitude3;
Published | property Amplitude4: Single read fAmplitude4 write fAmplitude4;
Published | property Amplitude5: Single read fAmplitude5 write fAmplitude5;
Published | property Longueur: Single read fLongueur write fLongueur;
Published | property Longueur2: Single read fLongueur2 write fLongueur2;
Published | property Longueur3: Single read fLongueur3 write fLongueur3;
Published | property Longueur4: Single read fLongueur4 write fLongueur4;
Published | property Longueur5: Single read fLongueur5 write fLongueur5;
Published | property Origine: TPoint3D read fOrigine write fOrigine;
Published | property Origine2: TPoint3D read fOrigine2 write fOrigine2;
Published | property Origine3: TPoint3D read fOrigine3 write fOrigine3;
Published | property Origine4: TPoint3D read fOrigine4 write fOrigine4;
Published | property Origine5: TPoint3D read fOrigine5 write fOrigine5;
Published | property Vitesse: Single read fVitesse write fVitesse;
Published | property Vitesse2: Single read fVitesse2 write fVitesse2;
Published | property Vitesse3: Single read fVitesse3 write fVitesse3;
Published | property Vitesse4: Single read fVitesse4 write fVitesse4;
Published | property Vitesse5: Single read fVitesse5 write fVitesse5;
Public | property WaveTime: Single read fTime write fTime;

Description

Fields

Private fTime: Single;

collection of sea surface sinoid waves (3 for now)

Private fAmplitude: Single;

Om: movd stuff to protected wave params

Private fLongueur: Single;

Om: movd stuff to protected wave params

Private fVitesse: Single;

Om: movd stuff to protected wave params

Private fOrigine: TPoint3D;

wave 1

Private fAmplitude2: Single;

This item has no description.

Private fLongueur2: Single;

This item has no description.

Private fVitesse2: Single;

This item has no description.

Private fOrigine2: TPoint3D;

This item has no description.

Private fAmplitude3: Single;

This item has no description.

Private fLongueur3: Single;

This item has no description.

Private fVitesse3: Single;

This item has no description.

Private fOrigine3: TPoint3D;

This item has no description.

Private fAmplitude4: Single;

This item has no description.

Private fLongueur4: Single;

This item has no description.

Private fVitesse4: Single;

This item has no description.

Private fOrigine4: TPoint3D;

This item has no description.

Private fAmplitude5: Single;

This item has no description.

Private fLongueur5: Single;

This item has no description.

Private fVitesse5: Single;

This item has no description.

Private fOrigine5: TPoint3D;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure IncTime;

This item has no description.

Properties

Published property Amplitude: Single read fAmplitude write fAmplitude;

wave 1

Published property Amplitude2: Single read fAmplitude2 write fAmplitude2;

wave 2

Published property Amplitude3: Single read fAmplitude3 write fAmplitude3;

wave 3

Published property Amplitude4: Single read fAmplitude4 write fAmplitude4;

wave 4

Published property Amplitude5: Single read fAmplitude5 write fAmplitude5;

wave 5

Published property Longueur: Single read fLongueur write fLongueur;

This item has no description.

Published property Longueur2: Single read fLongueur2 write fLongueur2;

This item has no description.

Published property Longueur3: Single read fLongueur3 write fLongueur3;

This item has no description.

Published property Longueur4: Single read fLongueur4 write fLongueur4;

This item has no description.

Published property Longueur5: Single read fLongueur5 write fLongueur5;

This item has no description.

Published property Origine: TPoint3D read fOrigine write fOrigine;

This item has no description.

Published property Origine2: TPoint3D read fOrigine2 write fOrigine2;

This item has no description.

Published property Origine3: TPoint3D read fOrigine3 write fOrigine3;

This item has no description.

Published property Origine4: TPoint3D read fOrigine4 write fOrigine4;

This item has no description.

Published property Origine5: TPoint3D read fOrigine5 write fOrigine5;

This item has no description.

Published property Vitesse: Single read fVitesse write fVitesse;

This item has no description.

Published property Vitesse2: Single read fVitesse2 write fVitesse2;

This item has no description.

Published property Vitesse3: Single read fVitesse3 write fVitesse3;

This item has no description.

Published property Vitesse4: Single read fVitesse4 write fVitesse4;

This item has no description.

Published property Vitesse5: Single read fVitesse5 write fVitesse5;

This item has no description.

Public property WaveTime: Single read fTime write fTime;


GXSysHelp v.2.5: GBE.omOceanWaves: Class TOceanSurface

Class TOceanSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.omOceanWaves

Declaration

type TOceanSurface = class(TPlane)

Description

This item has no description.

Hierarchy

  • TPlane
  • TOceanSurface

Overview

Fields

Private | fWaveSystem: TWaveSystem;
Public | fVirtualSeaOrigin: TPoint3D;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function calcWaveAmplitudeAndPitch(P: TPoint3D; const aCap: Single; var aAmplitude, aPitch: Single): boolean;
Public | procedure GetPointsTexCoordinates(var P, TC: String);
Public | procedure MoveTextureBy(var dx, dy: Single);
Public | procedure Render; override;
Private | procedure CalcWaves;

Properties

Published | property ActiveWaves: boolean read fActiveWaves write fActiveWaves;
Published | property DivPerM: TPoint3D read fDivPerM;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property ShowLines: boolean read fShowlines write fShowlines;
Published | property WaveSystem: TWaveSystem read fWaveSystem write fWaveSystem;

Description

Fields

Private fWaveSystem: TWaveSystem;

This item has no description.

Public fVirtualSeaOrigin: TPoint3D;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

position of the origin of the virtual sea

Public destructor Destroy; override;

This item has no description.

Public function calcWaveAmplitudeAndPitch(P: TPoint3D; const aCap: Single; var aAmplitude, aPitch: Single): boolean;

Property Data; //om: publica

Public procedure GetPointsTexCoordinates(var P, TC: String);

This item has no description.

Public procedure MoveTextureBy(var dx, dy: Single);

This item has no description.

Public procedure Render; override;

Om:

Private procedure CalcWaves;

This item has no description.

Properties

Published property ActiveWaves: boolean read fActiveWaves write fActiveWaves;

W1,W2 = Point3D(Amplitude, Longueur, Vitesse)

Published property DivPerM: TPoint3D read fDivPerM;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;

This item has no description.

Published property WaveSystem: TWaveSystem read fWaveSystem write fWaveSystem;


GXSysHelp v.2.5: GBE.omOceanWaves: Class TWindArrowSurface

Class TWindArrowSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.omOceanWaves

Declaration

type TWindArrowSurface = class(TPlane)

Description

This item has no description.

Hierarchy

  • TPlane
  • TWindArrowSurface

Overview

Fields

Private | fVersion: integer;
Private | fWaveSystem: TWaveSystem;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Render; override;
Private | procedure CalcArrowMesh;
Private | procedure setVersion(const Value: integer);

Properties

Published | property ActiveWaves: boolean read fActiveWaves write fActiveWaves;
Published | property DivPerM: TPoint3D read fDivPerM;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property ShowLines: boolean read fShowlines write fShowlines;
Published | property version: integer read fVersion write setVersion;

Description

Fields

Private fVersion: integer;

Ondulating wind arrow. Less CPU intensive then OceanSurface

Private fWaveSystem: TWaveSystem;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Render; override;

Property Data; //om: publica

Private procedure CalcArrowMesh;

using only wave 1 here

Private procedure setVersion(const Value: integer);

This item has no description.

Properties

Published property ActiveWaves: boolean read fActiveWaves write fActiveWaves;

This item has no description.

Published property DivPerM: TPoint3D read fDivPerM;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;

This item has no description.

Published property version: integer read fVersion write setVersion;


GXSysHelp v.2.5: GBE.omOceanWaves: Class TTwoWavesOceanSurface

Class TTwoWavesOceanSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.omOceanWaves

Declaration

type TTwoWavesOceanSurface = class(TOceanSurface)

Description

This item has no description.

Hierarchy

  • TPlane
  • TOceanSurface
  • TTwoWavesOceanSurface


GXSysHelp v.2.5: GBE.PlaneExtend

Unit GBE.PlaneExtend

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Generics.Collections
  • System.Threading
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TWaveRec |
Class TGBEPlaneExtend |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.PlaneExtend: Record TWaveRec

Record TWaveRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.PlaneExtend

Declaration

type TWaveRec = record

Description

This item has no description.

Overview

Fields

Public | P: TPoint3D;
Public | D: TPoint3D;

Methods

Public | function calcWaveAmplitudeAndPitch(aCap, aX, aY, aT: single; var aSumAmplitude, aSumDerivative: single): boolean;
Public | function Wave(aSum, aX, aY, aT: single): single;

Description

Fields

Public P: TPoint3D;

calculates sin() wave amplitude at a given P (x,y)

Public D: TPoint3D;

wave origin

Methods

Public function calcWaveAmplitudeAndPitch(aCap, aX, aY, aT: single; var aSumAmplitude, aSumDerivative: single): boolean;

This item has no description.

Public function Wave(aSum, aX, aY, aT: single): single;

wave params D = Point3D( MaxAmplitude, WaveLenght, WaveSpeed )


GXSysHelp v.2.5: GBE.PlaneExtend: Class TGBEPlaneExtend

Class TGBEPlaneExtend

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.PlaneExtend

Declaration

type TGBEPlaneExtend = class(TPlane)

Description

This item has no description.

Hierarchy

  • TPlane
  • TGBEPlaneExtend

Overview

Fields

Private | fAmplitude: single;
Private | fLongueur: single;
Private | fVitesse: single;
Private | fOrigine: TPoint3D;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Altura(P: TPoint3D): single;
Public | procedure Render; override;
Private | procedure CalcWaves(D: TPoint3D);

Properties

Published | property ActiveWaves: boolean read fActiveWaves write fActiveWaves;
Published | property Amplitude: single read fAmplitude write fAmplitude;
Published | property Longueur: single read fLongueur write fLongueur;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property Origine: TPoint3D read fOrigine write fOrigine;
Published | property ShowLines: boolean read fShowlines write fShowlines;
Published | property UseTasks: boolean read fUseTasks write fUseTasks;
Published | property Vitesse: single read fVitesse write fVitesse;

Description

Fields

Private fAmplitude: single;

This item has no description.

Private fLongueur: single;

This item has no description.

Private fVitesse: single;

This item has no description.

Private fOrigine: TPoint3D;

wave 1

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Altura(P: TPoint3D): single;

Property Data; //om: public

Public procedure Render; override;

This item has no description.

Private procedure CalcWaves(D: TPoint3D);

This item has no description.

Properties

Published property ActiveWaves: boolean read fActiveWaves write fActiveWaves;

Om: calc wave amplitude on a point

Published property Amplitude: single read fAmplitude write fAmplitude;

This item has no description.

Published property Longueur: single read fLongueur write fLongueur;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property Origine: TPoint3D read fOrigine write fOrigine;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;

This item has no description.

Published property UseTasks: boolean read fUseTasks write fUseTasks;

This item has no description.

Published property Vitesse: single read fVitesse write fVitesse;


GXSysHelp v.2.5: GBE.PlayerPosition

Unit GBE.PlayerPosition

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBEPlayerPosition |

Functions and Procedures

procedure Register;

Types

TGBETypePosition = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TGBETypePosition = (...);

This item has no description.

Values
  • firstPerson
  • thirdPerson
  • other


GXSysHelp v.2.5: GBE.PlayerPosition: Class TGBEPlayerPosition

Class TGBEPlayerPosition

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.PlayerPosition

Declaration

type TGBEPlayerPosition = class(TDummy)

Description

This item has no description.

Hierarchy

  • TDummy
  • TGBEPlayerPosition

Overview

Fields

Private | fDummyOrientation: TDummy;
Private | fNextPosition: TDummy;
Private | fPositionDirection: TDummy;
Private | fCamera: TCamera;
Private | fTypePosition: TGBETypePosition;
Private | fWidth: single;
Private | fDepth: single;
Private | fHeight: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCamera: TCamera;
Public | function GetDummyOrientation: TDummy;
Public | function GetPositionDirection: TDummy;
Private | function GetAngleOfView: single;
Private | function GetPositionCamera: TPoint3D;
Private | procedure SetAngleOfView(const Value: single);
Private | procedure SetDepth(const Value: single);
Private | procedure SetHeight(const Value: single);
Private | procedure SetPositionCamera(const Value: TPoint3D);
Private | procedure SetTypePosition(const Value: TGBETypePosition);
Private | procedure SetWidth(const Value: single);

Properties

Published | property AngleOfView: single read GetAngleOfView write SetAngleOfView;
Published | property Depth: single read fDepth write SetDepth;
Published | property Height: single read fHeight write SetHeight;
Published | property HitTest default False;
Published | property NextPosition: TDummy read fNextPosition write fNextPosition;
Published | property PositionCameraThirdPerson: TPoint3D read GetPositionCamera write SetPositionCamera;
Published | property TypePosition: TGBETypePosition read fTypePosition write SetTypePosition;
Published | property Width: single read fWidth write SetWidth;

Description

Fields

Private fDummyOrientation: TDummy;

This item has no description.

Private fNextPosition: TDummy;

This item has no description.

Private fPositionDirection: TDummy;

This item has no description.

Private fCamera: TCamera;

This item has no description.

Private fTypePosition: TGBETypePosition;

This item has no description.

Private fWidth: single;

This item has no description.

Private fDepth: single;

This item has no description.

Private fHeight: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetCamera: TCamera;

This item has no description.

Public function GetDummyOrientation: TDummy;

This item has no description.

Public function GetPositionDirection: TDummy;

This item has no description.

Private function GetAngleOfView: single;

This item has no description.

Private function GetPositionCamera: TPoint3D;

This item has no description.

Private procedure SetAngleOfView(const Value: single);

This item has no description.

Private procedure SetDepth(const Value: single);

This item has no description.

Private procedure SetHeight(const Value: single);

This item has no description.

Private procedure SetPositionCamera(const Value: TPoint3D);

This item has no description.

Private procedure SetTypePosition(const Value: TGBETypePosition);

This item has no description.

Private procedure SetWidth(const Value: single);

This item has no description.

Properties

Published property AngleOfView: single read GetAngleOfView write SetAngleOfView;

This item has no description.

Published property Depth: single read fDepth write SetDepth;

This item has no description.

Published property Height: single read fHeight write SetHeight;

This item has no description.

Published property HitTest default False;

This item has no description.

Published property NextPosition: TDummy read fNextPosition write fNextPosition;

This item has no description.

Published property PositionCameraThirdPerson: TPoint3D read GetPositionCamera write SetPositionCamera;

This item has no description.

Published property TypePosition: TGBETypePosition read fTypePosition write SetTypePosition;

This item has no description.

Published property Width: single read fWidth write SetWidth;


GXSysHelp v.2.5: GBE.SphereExtend

Unit GBE.SphereExtend

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Types3D
  • System.RTLConsts
  • System.Math.Vectors
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCustomMeshHelper |
Class TGBESphereExtend |

Functions and Procedures

procedure Register;

Types

TSpheroid = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TSpheroid = (...);

This item has no description.

Values
  • capsule
  • dome
  • culbuto
  • sphere
  • apple
  • pot
  • diamond


GXSysHelp v.2.5: GBE.SphereExtend: Class TCustomMeshHelper

Class TCustomMeshHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.SphereExtend

Declaration

type TCustomMeshHelper = class(TCustomMesh)

Description

This item has no description.

Hierarchy

  • TCustomMesh
  • TCustomMeshHelper


GXSysHelp v.2.5: GBE.SphereExtend: Class TGBESphereExtend

Class TGBESphereExtend

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.SphereExtend

Declaration

type TGBESphereExtend = class(TMesh)

Description

This item has no description.

Hierarchy

  • TMesh
  • TGBESphereExtend

Overview

Fields

Private | fSubdivisionsAxes: integer;
Private | fSubdivisionsHeight: integer;
Private | fSpheroid: TSpheroid;
Private | fLongueur: single;
Private | fShowlines: boolean;
Private | fMaterialLignes: TColorMaterialSource;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Render; override;
Private | procedure CreateGBESphere(Const aData: TMeshData; Const aForme: TSpheroid = TSpheroid.sphere; Const aLength: single = 1.0);

Properties

Published | property Forme: TSpheroid read fSpheroid write SetForme;
Published | property Longueur: single read fLongueur write SetLongueur;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property ShowLines: boolean read fShowlines write fShowlines;
Published | property SubdivisionsAxes: integer read fSubdivisionsAxes write SetSubdivisionsAxes;
Published | property SubdivisionsHeight: integer read fSubdivisionsHeight write SetSubdivisionsHeight;

Description

Fields

Private fSubdivisionsAxes: integer;

This item has no description.

Private fSubdivisionsHeight: integer;

This item has no description.

Private fSpheroid: TSpheroid;

This item has no description.

Private fLongueur: single;

This item has no description.

Private fShowlines: boolean;

This item has no description.

Private fMaterialLignes: TColorMaterialSource;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Render; override;

This item has no description.

Private procedure CreateGBESphere(Const aData: TMeshData; Const aForme: TSpheroid = TSpheroid.sphere; Const aLength: single = 1.0);

This item has no description.

Properties

Published property Forme: TSpheroid read fSpheroid write SetForme;

This item has no description.

Published property Longueur: single read fLongueur write SetLongueur;

This item has no description.

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;

This item has no description.

Published property SubdivisionsAxes: integer read fSubdivisionsAxes write SetSubdivisionsAxes;

This item has no description.

Published property SubdivisionsHeight: integer read fSubdivisionsHeight write SetSubdivisionsHeight;


GXSysHelp v.2.5: GBE.Terrain

Unit GBE.Terrain

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Types
  • System.Math.Vectors
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.Graphics
  • Math
  • uGBEUtils3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGBETerrain |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Terrain: Class TGBETerrain

Class TGBETerrain

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Terrain

Declaration

type TGBETerrain = class(TMesh)

Description

This item has no description.

Hierarchy

  • TMesh
  • TGBETerrain

Overview

Fields

Private | fAmplitude: single;
Private | fRoughness: single;
Private | fScalling: single;
Private | fOctaves: integer;
Private | fSubdivX: integer;
Private | fSubdivZ: integer;
Private | fSeed: integer;
Private | fXOffset: integer;
Private | fZOffset: integer;
Private | FUseRamp: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetHeight(P: TPoint3d): single;
Private | function GenerateHeight(X, Z: integer): single;
Private | function GetInterpolatedNoise(X, Z: single): single;
Private | function Interpolate(a, b, blend: single): single;
Private | function Noise(X, Z: integer): single;
Private | function SmoothNoise(X, Z: integer): single;
Public | procedure Clean;
Public | procedure GenerateTerrain;
Private | procedure SetUseRamp(const Value: boolean);

Properties

Published | property Amplitude: single read fAmplitude write fAmplitude;
Published | property Octaves: integer read fOctaves write fOctaves;
Published | property Roughness: single read fRoughness write fRoughness;
Published | property Seed: integer read fSeed write fSeed;
Published | property SubdivX: integer read fSubdivX write fSubdivX;
Published | property SubdivZ: integer read fSubdivZ write fSubdivZ;
Published | property UseRamp: boolean read FUseRamp write SetUseRamp;
Published | property XOffset: integer read fXOffset write fXOffset;
Published | property ZOffset: integer read fZOffset write fZOffset;

Description

Fields

Private fAmplitude: single;

This item has no description.

Private fRoughness: single;

This item has no description.

Private fScalling: single;

This item has no description.

Private fOctaves: integer;

This item has no description.

Private fSubdivX: integer;

This item has no description.

Private fSubdivZ: integer;

This item has no description.

Private fSeed: integer;

This item has no description.

Private fXOffset: integer;

This item has no description.

Private fZOffset: integer;

This item has no description.

Private FUseRamp: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetHeight(P: TPoint3d): single;

This item has no description.

Private function GenerateHeight(X, Z: integer): single;

This item has no description.

Private function GetInterpolatedNoise(X, Z: single): single;

This item has no description.

Private function Interpolate(a, b, blend: single): single;

This item has no description.

Private function Noise(X, Z: integer): single;

This item has no description.

Private function SmoothNoise(X, Z: integer): single;

This item has no description.

Public procedure Clean;

This item has no description.

Public procedure GenerateTerrain;

This item has no description.

Private procedure SetUseRamp(const Value: boolean);

This item has no description.

Properties

Published property Amplitude: single read fAmplitude write fAmplitude;

This item has no description.

Published property Octaves: integer read fOctaves write fOctaves;

This item has no description.

Published property Roughness: single read fRoughness write fRoughness;

This item has no description.

Published property Seed: integer read fSeed write fSeed;

This item has no description.

Published property SubdivX: integer read fSubdivX write fSubdivX;

This item has no description.

Published property SubdivZ: integer read fSubdivZ write fSubdivZ;

This item has no description.

Published property UseRamp: boolean read FUseRamp write SetUseRamp;

This item has no description.

Published property XOffset: integer read fXOffset write fXOffset;

This item has no description.

Published property ZOffset: integer read fZOffset write fZOffset;


GXSysHelp v.2.5: GBE.TimeLine

Unit GBE.TimeLine

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Types
  • FMX.Ani
  • System.Generics.Collections

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGBEStep |
Class TGBETimeline |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.TimeLine: Record TGBEStep

Record TGBEStep

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.TimeLine

Declaration

type TGBEStep = record

Description

This item has no description.

Overview

Fields

Public | Duration: single;
Public | Delay: single;
Public | PropertyName: string;
Public | StartValue: single;
Public | StopValue: single;
Public | AutoReverse: boolean;
Public | Inverse: boolean;
Public | StartFromCurrent: boolean;
Public | Interpolation: TInterpolationType;
Public | AnimationType: TAnimationType;

Description

Fields

Public Duration: single;

This item has no description.

Public Delay: single;

This item has no description.

Public PropertyName: string;

This item has no description.

Public StartValue: single;

This item has no description.

Public StopValue: single;

This item has no description.

Public AutoReverse: boolean;

This item has no description.

Public Inverse: boolean;

This item has no description.

Public StartFromCurrent: boolean;

This item has no description.

Public Interpolation: TInterpolationType;

This item has no description.

Public AnimationType: TAnimationType;


GXSysHelp v.2.5: GBE.TimeLine: Class TGBETimeline

Class TGBETimeline

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.TimeLine

Declaration

type TGBETimeline = class(TFloatAnimation)

Description

This item has no description.

Hierarchy

  • TFloatAnimation
  • TGBETimeline

Overview

Fields

Private | fListeAnimation: TList<TGBEStep>;
Private | fLoopSteps: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetCount: integer;
Public | procedure AddStep(aStep: TGBEStep);
Public | procedure Clear;
Public | procedure Run;
Private | procedure Finish(Sender: TObject);
Private | procedure RunAnimation(Indice: integer);

Properties

Published | property count: integer read GetCount;
Published | property loopSteps: boolean read fLoopSteps write fLoopSteps;

Description

Fields

Private fListeAnimation: TList<TGBEStep>;

This item has no description.

Private fLoopSteps: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetCount: integer;

This item has no description.

Public procedure AddStep(aStep: TGBEStep);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Run;

This item has no description.

Private procedure Finish(Sender: TObject);

This item has no description.

Private procedure RunAnimation(Indice: integer);

This item has no description.

Properties

Published property count: integer read GetCount;

This item has no description.

Published property loopSteps: boolean read fLoopSteps write fLoopSteps;


GXSysHelp v.2.5: GBE.Viewport3D

Unit GBE.Viewport3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Generics.Collections
  • System.Types
  • System.Math.Vectors
  • System.DateUtils
  • System.UITypes
  • FMX.Types
  • FMX.Controls
  • FMX.Viewport3D
  • FMX.Graphics
  • FMX.Types3D
  • FMX.Controls3D
  • FMX.Layouts

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class THelpOpenControl3D |
Class TGBEViewport3D |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GBE.Viewport3D: Class THelpOpenControl3D

Class THelpOpenControl3D

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Viewport3D

Declaration

type THelpOpenControl3D = class(TControl3D)

Description

This item has no description.

Hierarchy

  • TControl3D
  • THelpOpenControl3D


GXSysHelp v.2.5: GBE.Viewport3D: Class TGBEViewport3D

Class TGBEViewport3D

Description
Hierarchy
Fields
Methods
Properties

Unit

GBE.Viewport3D

Declaration

type TGBEViewport3D = class(TViewport3D)

Description

This item has no description.

Hierarchy

  • TViewport3D
  • TGBEViewport3D

Overview

Fields

Private | FDrawing: boolean;
Private | fActiveFPS: boolean;
Private | fFPS: integer;
Private | fComputeFPS: integer;
Private | FMyBitmap: TBitmap;
Private | FMyTexture: TTexture;
Private | fMyContext: TContext3D;
Private | fBackgroundColor: cardinal;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function getBitmapFromView(camera: TCamera): TBitmap;
Public | procedure DoAddView(camera: TCamera);
Public | procedure DoClearListView;
Public | procedure DoRemoveView(camera: TCamera);

Properties

Published | property ActiveFPS: boolean read fActiveFPS write fActiveFPS;
Public | property BackgroundColor: cardinal read fBackgroundColor write fBackgroundColor;
Published | property FPS: integer read fFPS;
Public | property MyContext: TContext3D read fMyContext write fMyContext;

Description

Fields

Private FDrawing: boolean;

This item has no description.

Private fActiveFPS: boolean;

This item has no description.

Private fFPS: integer;

This item has no description.

Private fComputeFPS: integer;

This item has no description.

Private FMyBitmap: TBitmap;

This item has no description.

Private FMyTexture: TTexture;

This item has no description.

Private fMyContext: TContext3D;

This item has no description.

Private fBackgroundColor: cardinal;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function getBitmapFromView(camera: TCamera): TBitmap;

This item has no description.

Public procedure DoAddView(camera: TCamera);

This item has no description.

Public procedure DoClearListView;

This item has no description.

Public procedure DoRemoveView(camera: TCamera);

This item has no description.

Properties

Published property ActiveFPS: boolean read fActiveFPS write fActiveFPS;

This item has no description.

Public property BackgroundColor: cardinal read fBackgroundColor write fBackgroundColor;

This item has no description.

Published property FPS: integer read fFPS;

This item has no description.

Public property MyContext: TContext3D read fMyContext write fMyContext;


GXSysHelp v.2.5: GLScene.AnimationUtils

Unit GLScene.AnimationUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;
function Tweener(Current, Target: TGLVector; Time, Duration: Single; EaseType: TEaseType): TGLVector; overload;
function Tweener(Current, Target: TVector2f; Time, Duration: Single; EaseType: TEaseType): TVector2f; overload;
function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

Types

TEaseType = (...);

Description

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;

This item has no description.

function Tweener(Current, Target: TGLVector; Time, Duration: Single; EaseType: TEaseType): TGLVector; overload;

This item has no description.

function Tweener(Current, Target: TVector2f; Time, Duration: Single; EaseType: TEaseType): TVector2f; overload;

This item has no description.

function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

This item has no description.

Types

TEaseType = (...);

This item has no description.

Values
  • etLinear
  • etQuadIn
  • etQuadOut
  • etQuadInOut
  • etQuadOutIn
  • etCubicIn
  • etCubicOut
  • etCubicInOut
  • etCubicOutIn
  • etQuintIn
  • etQuintOut
  • etQuintInOut
  • etQuintOutIn
  • etSineIn
  • etSineOut
  • etSineInOut
  • etSineOutIn
  • etCircIn
  • etCircOut
  • etCircInOut
  • etCircOutIn
  • etExpoIn
  • etExpoOut
  • etExpoInOut
  • etExpoOutIn
  • etElasticIn
  • etElasticOut
  • etElasticInOut
  • etElasticOutIn
  • etBackIn
  • etBackOut
  • etBackInOut
  • etBackOutIn
  • etBounceIn
  • etBounceOut
  • etBounceInOut
  • etBounceOutIn


GXSysHelp v.2.5: GLScene.GeometryBB

Unit GLScene.GeometryBB

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • GLScene.VectorGeometry
  • GLS.VectorLists
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record THmgBoundingBox |
Record TAABB |
Record TBSphere |
Record TGClipRect |

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: THmgBoundingBox): Boolean; overload;
function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: PHmgBoundingBox): Boolean; overload;
function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox): THmgBoundingBox;
procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);
procedure SetBB(var C: THmgBoundingBox; const V: TGLVector);
procedure SetAABB(var Bb: TAABB; const V: TGLVector); inline;
procedure BBTransform(var C: THmgBoundingBox; const M: TGLMatrix);
procedure AABBTransform(var Bb: TAABB; const M: TGLMatrix);
procedure AABBScale(var Bb: TAABB; const V: TAffineVector);
function BBMinX(const C: THmgBoundingBox): Single;
function BBMaxX(const C: THmgBoundingBox): Single;
function BBMinY(const C: THmgBoundingBox): Single;
function BBMaxY(const C: THmgBoundingBox): Single;
function BBMinZ(const C: THmgBoundingBox): Single;
function BBMaxZ(const C: THmgBoundingBox): Single;
procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);
procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TGLVector; const Radius: Single);
function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;
function BBToAABB(const ABB: THmgBoundingBox): TAABB;
function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;
function AABBToBB(const AnAABB: TAABB; const M: TGLMatrix): THmgBoundingBox; overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TGLVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;
procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;
function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TGLMatrix): Boolean; overload;
function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function PointInAABB(const P: TAffineVector; const Aabb: TAABB): Boolean; overload;
function PointInAABB(const P: TGLVector; const Aabb: TAABB): Boolean; overload;
function PlaneIntersectAABB(const Normal: TAffineVector; D: Single; const Aabb: TAABB): Boolean;
function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TGLAffineVectorList;
function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;
procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);
procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);
procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;
function BSphereToAABB(const Center: TAffineVector; Radius: Single): TAABB; overload;
function BSphereToAABB(const Center: TGLVector; Radius: Single): TAABB; overload;
function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;
function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB): TSpaceContains;
function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere): TSpaceContains;
function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere): TSpaceContains;
function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB): TSpaceContains;
function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;
function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;
procedure IncludeInClipRect(var ClipRect: TGClipRect; X, Y: Single);
function AABBToClipRect(const Aabb: TAABB; const ModelViewProjection: TGLMatrix; ViewportSizeX, ViewportSizeY: Integer): TGClipRect;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; IntersectPoint: PGLVector = nil): Boolean; overload;

Types

PAABB = ˆTAABB;
PHmgBoundingBox = ˆTHmgBoundingBox;
TAABBCorners = array [0 .. 7] of TAffineVector;
TDirPlan = array [0 .. 5] of Integer;
TPlanBB = array [0 .. 5] of TPlanIndices;
TPlanIndices = array [0 .. 3] of Integer;
TSpaceContains = (...);

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));
CBBFront: TPlanIndices = (0, 1, 2, 3);
CBBBack: TPlanIndices = (4, 5, 6, 7);
CBBLeft: TPlanIndices = (0, 4, 7, 3);
CBBRight: TPlanIndices = (1, 5, 6, 2);
CBBTop: TPlanIndices = (0, 1, 5, 4);
CBBBottom: TPlanIndices = (2, 3, 7, 6);
CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));
CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);

Description

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: THmgBoundingBox): Boolean; overload;

—————————————————————————— Bounding Box functions ——————————————————————————

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2: PHmgBoundingBox): Boolean; overload;

This item has no description.

function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox): THmgBoundingBox;

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.

procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);

This item has no description.

procedure SetBB(var C: THmgBoundingBox; const V: TGLVector);

This item has no description.

procedure SetAABB(var Bb: TAABB; const V: TGLVector); inline;

This item has no description.

procedure BBTransform(var C: THmgBoundingBox; const M: TGLMatrix);

This item has no description.

procedure AABBTransform(var Bb: TAABB; const M: TGLMatrix);

This item has no description.

procedure AABBScale(var Bb: TAABB; const V: TAffineVector);

This item has no description.

function BBMinX(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxX(const C: THmgBoundingBox): Single;

This item has no description.

function BBMinY(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxY(const C: THmgBoundingBox): Single;

This item has no description.

function BBMinZ(const C: THmgBoundingBox): Single;

This item has no description.

function BBMaxZ(const C: THmgBoundingBox): Single;

This item has no description.

procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);

Resize the AABB if necessary to include p.

procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TGLVector; const Radius: Single);

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest

function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).

function BBToAABB(const ABB: THmgBoundingBox): TAABB;

Extract AABB information from a BB.

function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;

Converts an AABB to its canonical BB.

function AABBToBB(const AnAABB: TAABB; const M: TGLMatrix): THmgBoundingBox; overload;

Transforms an AABB to a BB.

procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;

Adds delta to min and max of the AABB.

procedure OffsetAABB(var Aabb: TAABB; const Delta: TGLVector); overload;

This item has no description.

procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;

Adds delta to min and max of the BB.

procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;

This item has no description.

procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TGLVector); overload;

The same as above but uses AddPoint() instead of AddVector().

function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TGLMatrix): Boolean; overload;

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system

function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.

function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.

function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether two Bounding boxes aligned with the world axes collide.

function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;

Checks whether one Bounding box aligned with the world axes fits within another Bounding box

function PointInAABB(const P: TAffineVector; const Aabb: TAABB): Boolean; overload;

Checks if a point "p" is inside an AABB

function PointInAABB(const P: TGLVector; const Aabb: TAABB): Boolean; overload;

This item has no description.

function PlaneIntersectAABB(const Normal: TAffineVector; D: Single; const Aabb: TAABB): Boolean;

Checks if a plane (given by the normal+d) intersects the AABB

function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TGLAffineVectorList;

Compute the intersection between a plane and the AABB

function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB

procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);

Extract the corners from an AABB

procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);

Convert an AABB to a BSphere

procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;

Convert a BSphere to an AABB

function BSphereToAABB(const Center: TAffineVector; Radius: Single): TAABB; overload;

This item has no description.

function BSphereToAABB(const Center: TGLVector; Radius: Single): TAABB; overload;

This item has no description.

function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;

Determines to which extent one AABB contains another AABB

function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB): TSpaceContains;

Determines to which extent a BSphere contains an AABB

function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere): TSpaceContains;

Determines to which extent one BSphere contains another BSphere

function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent an AABB contains a BSpher

function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent a plane contains a BSphere

function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;

Determines to which extent a frustum contains a BSphere

function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB): TSpaceContains;

Determines to which extent a frustum contains an AABB

function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;

Clips a position to an AABB

function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;

Determines if one BSphere intersects another BSphere

procedure IncludeInClipRect(var ClipRect: TGClipRect; X, Y: Single);

Extend the clip rect to include given coordinate.

function AABBToClipRect(const Aabb: TAABB; const ModelViewProjection: TGLMatrix; ViewportSizeX, ViewportSizeY: Integer): TGClipRect;

Projects an AABB and determines the extent of its projection as a clip rect.

function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;

Finds the intersection between a ray and an axis aligned bounding box.

function RayCastAABBIntersect(const RayOrigin, RayDirection: TGLVector; const Aabb: TAABB; IntersectPoint: PGLVector = nil): Boolean; overload;

This item has no description.

Types

PAABB = ˆTAABB;

This item has no description.

PHmgBoundingBox = ˆTHmgBoundingBox;

Structure for storing Bounding Boxes

TAABBCorners = array [0 .. 7] of TAffineVector;

Structure for storing the corners of an AABB, used with ExtractAABBCorners

TDirPlan = array [0 .. 5] of Integer;

This item has no description.

TPlanBB = array [0 .. 5] of TPlanIndices;

This item has no description.

TPlanIndices = array [0 .. 3] of Integer;

This item has no description.

TSpaceContains = (...);

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB

Values
  • ScNoOverlap
  • ScContainsFully
  • ScContainsPartially

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

CBBFront: TPlanIndices = (0, 1, 2, 3);

This item has no description.

CBBBack: TPlanIndices = (4, 5, 6, 7);

This item has no description.

CBBLeft: TPlanIndices = (0, 4, 7, 3);

This item has no description.

CBBRight: TPlanIndices = (1, 5, 6, 2);

This item has no description.

CBBTop: TPlanIndices = (0, 1, 5, 4);

This item has no description.

CBBBottom: TPlanIndices = (2, 3, 7, 6);

This item has no description.

CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));

This item has no description.

CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);


GXSysHelp v.2.5: GLScene.GeometryBB: Record THmgBoundingBox

Record THmgBoundingBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type THmgBoundingBox = record

Description

This item has no description.

Overview

Fields

Public BBox: array [0 .. 7] of TGLVector;

Description

Fields

Public BBox: array [0 .. 7] of TGLVector;


GXSysHelp v.2.5: GLScene.GeometryBB: Record TAABB

Record TAABB

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TAABB = record

Description

Structure for storing Axis Aligned Bounding Boxes

Overview

Fields

Public | Min: TAffineVector;
Public | Max: TAffineVector;

Description

Fields

Public Min: TAffineVector;

This item has no description.

Public Max: TAffineVector;


GXSysHelp v.2.5: GLScene.GeometryBB: Record TBSphere

Record TBSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TBSphere = record

Description

Structure for storing BoundingSpheres. Similar to TAABB

Overview

Fields

Public | Center: TAffineVector;
Public | Radius: Single;

Description

Fields

Public Center: TAffineVector;

Center of Bounding Sphere

Public Radius: Single;

Radius of Bounding Sphere


GXSysHelp v.2.5: GLScene.GeometryBB: Record TGClipRect

Record TGClipRect

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.GeometryBB

Declaration

type TGClipRect = record

Description

This item has no description.

Overview

Fields

Public | Left: Single;
Public | Top: Single;
Public | Right: Single;
Public | Bottom: Single;

Description

Fields

Public Left: Single;

This item has no description.

Public Top: Single;

This item has no description.

Public Right: Single;

This item has no description.

Public Bottom: Single;


GXSysHelp v.2.5: GLScene.Keyboard

Unit GLScene.Keyboard

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.SysUtils

Overview

Functions and Procedures

function IsKeyDown(c: Char): Boolean; overload;
function IsKeyDown(vk: TVirtualKeyCode): Boolean; overload;
function KeyPressed(minVkCode: TVirtualKeyCode = 0): TVirtualKeyCode;
function VirtualKeyCodeToKeyName(vk: TVirtualKeyCode): String;
function KeyNameToVirtualKeyCode(const keyName: String): TVirtualKeyCode;
function CharToVirtualKeyCode(c: Char): TVirtualKeyCode;
procedure KeyboardNotifyWheelMoved(wheelDelta: Integer);

Types

TVirtualKeyCode = Integer;

Constants

VK_MOUSEWHEELUP = VK_F23;
VK_MOUSEWHEELDOWN = VK_F24;

Variables

vLastWheelDelta: Integer;

Description

Functions and Procedures

function IsKeyDown(c: Char): Boolean; overload;

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

function IsKeyDown(vk: TVirtualKeyCode): Boolean; overload;

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.

function KeyPressed(minVkCode: TVirtualKeyCode = 0): TVirtualKeyCode;

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.

function VirtualKeyCodeToKeyName(vk: TVirtualKeyCode): String;

Converts a virtual key code to its name. The name is expressed using the locale windows options.

function KeyNameToVirtualKeyCode(const keyName: String): TVirtualKeyCode;

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

function CharToVirtualKeyCode(c: Char): TVirtualKeyCode;

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

procedure KeyboardNotifyWheelMoved(wheelDelta: Integer);

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed

Types

TVirtualKeyCode = Integer;

This item has no description.

Constants

VK_MOUSEWHEELUP = VK_F23;

pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved

VK_MOUSEWHEELDOWN = VK_F24;

This item has no description.

Variables

vLastWheelDelta: Integer;


GXSysHelp v.2.5: GLScene.Logger

Unit GLScene.Logger

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • Winapi.ShellApi
  • System.StrUtils
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.SyncObjs

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLogBufferFlushThread |
Class TLogCheckSizeThread |
Class TLogSession |
Class TGLSLogger |

Functions and Procedures

function UserLog: TLogSession;
function ReadLine(var TextFile: Text): string;
function GLSLogger(): TLogSession;
procedure UseCustomGLSLogger(const ALogger: TLogSession);
function ConstArrayToString(const Elements: array of const): String;

Types

CLogSession = class of TLogSession;
TIDELogProc = procedure(const AMsg: string);
TLogBufferingMode = (...);
TLogLevel = (...);
TLogLevels = set of TLogLevel;
TLogMessageLimitAction = (...);
TLogTimeFormat = (...);

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];
llMin: TLogLevels = [lkError, lkFatalError];

Variables

llMessageLimit: array [TLogLevel] of Integer = ( MaxInt, MaxInt, MaxInt, 500, 100, 10 );
lkPrefix: array [TLogLevel] of string = ( ' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ' );
vIDELogProc: TIDELogProc;

Description

Functions and Procedures

function UserLog: TLogSession;

Return logger wich created by TGLSLogger component

function ReadLine(var TextFile: Text): string;

This item has no description.

function GLSLogger(): TLogSession;

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).

procedure UseCustomGLSLogger(const ALogger: TLogSession);

This item has no description.

function ConstArrayToString(const Elements: array of const): String;

This item has no description.

Types

CLogSession = class of TLogSession;

Class reference to log session class

TIDELogProc = procedure(const AMsg: string);

This item has no description.

TLogBufferingMode = (...);

How log is buffered.

Values
  • lbmWriteEmidiatly
  • lbmWritePeriodically
  • lbmWriteInTheEnd
TLogLevel = (...);

Levels of importance of log messages

Values
  • lkDebug
  • lkInfo
  • lkNotice
  • lkWarning
  • lkError
  • lkFatalError
TLogLevels = set of TLogLevel;

Log level setting type

TLogMessageLimitAction = (...);

What to do when number of messages exceeds message limit.

Values
  • mlaContinue
  • mlaStopLogging
  • mlaHalt
TLogTimeFormat = (...);

Log date and time setting type

Values
  • lfNone: doesn't output any time information
  • lfDate: include date in the log
  • lfTime: include time in the log
  • lfTimeExact: include time in the log, including milliseconds
  • lfDateTime: include date and time in the log
  • lfElapsed: include time elapsed since startup in the log

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

llMin: TLogLevels = [lkError, lkFatalError];

This item has no description.

Variables

llMessageLimit: array [TLogLevel] of Integer = ( MaxInt, MaxInt, MaxInt, 500, 100, 10 );

This item has no description.

lkPrefix: array [TLogLevel] of string = ( ' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ' );

This item has no description.

vIDELogProc: TIDELogProc;


GXSysHelp v.2.5: GLScene.Logger: Class TLogBufferFlushThread

Class TLogBufferFlushThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogBufferFlushThread = class(TThread)

Description

Thread that periodically flushes the buffer to disk.

Hierarchy

  • TObject
  • TThread
  • TLogBufferFlushThread

Overview

Fields

Private FParent: TLogSession;

Methods

Public constructor Create(const AParent: TLogSession);

Description

Fields

Private FParent: TLogSession;

This item has no description.

Methods

Public constructor Create(const AParent: TLogSession);


GXSysHelp v.2.5: GLScene.Logger: Class TLogCheckSizeThread

Class TLogCheckSizeThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogCheckSizeThread = class(TThread)

Description

Thread that checks file size and splits the file if nessesary.

Hierarchy

  • TObject
  • TThread
  • TLogCheckSizeThread

Overview

Fields

Private FParent: TLogSession;

Methods

Public constructor Create(const AParent: TLogSession);

Description

Fields

Private FParent: TLogSession;

This item has no description.

Methods

Public constructor Create(const AParent: TLogSession);


GXSysHelp v.2.5: GLScene.Logger: Class TLogSession

Class TLogSession

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TLogSession = class(TPersistent)

Description

Abstract Logger class

Hierarchy

  • TObject
  • TPersistent
  • TLogSession

Overview

Fields

Private | FBuffer: TStringList;
Private | FBuffered: Boolean;
Private | FBufferProcessingThread: TLogBufferFlushThread;
Private | FCheckLogSizeThread: TLogCheckSizeThread;
Private | FFlushBufferPeriod: Integer;
Private | FLogFile: Text;
Private | FDestroying: Boolean;
Private | FOriginalLogFileName: string;
Private | FCurrentLogFileName: string;
Private | FUsedLogFileNames: TStringList;
Private | FLogLevels: TLogLevels;
Private | FEnabled: Boolean;
Private | FBufferCriticalSection: TCriticalSection;
Private | FFileAccessCriticalSection: TCriticalSection;
Private | FModeTitles: array [TLogLevel] of string;
Private | FLogKindCount: array [TLogLevel] of Integer;
Private | FLogThreadId: Boolean;
Private | FMessageLimitAction: TLogMessageLimitAction;
Private | FTimeFormat: TLogTimeFormat;
Private | FStartedMs: Cardinal;
Private | FLogFileMaxSize: Integer;
Private | FCheckFileSizePeriod: Integer;
Private | FDisplayLogOnExitIfItContains: TLogLevels;
Private | FWriteInternalMessages: Boolean;
Private | FDisplayErrorDialogs: Boolean;

Methods

Public | constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ABackUpOldLogs: Boolean = False; const AClearOldLogs: Boolean = True; const AWriteInternalMessages: Boolean = True); virtual;
Private | constructor OnlyCreate;
Public | destructor Destroy; override;
Public | procedure DisplayLog();
Public | procedure FlushBuffer();
Public | procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);
Public | procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogDebug(const Desc: string);
Public | procedure LogDebugFmt(const Desc: string; const args: array of const);
Public | procedure LogEmtryLine();
Public | procedure LogError(const Desc: string);
Public | procedure LogErrorFmt(const Desc: string; const args: array of const);
Public | procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogFatalError(const Desc: string);
Public | procedure LogFatalErrorFmt(const Desc: string; const args: array of const);
Public | procedure LogInfo(const Desc: string);
Public | procedure LogInfoFmt(const Desc: string; const args: array of const);
Public | procedure LogNotice(const Desc: string);
Public | procedure LogNoticeFmt(const Desc: string; const args: array of const);
Public | procedure LogWarning(const Desc: string);
Public | procedure LogWarningFmt(const Desc: string; const args: array of const);
Private | procedure ChangeBufferedState();
Private | procedure SetBuffered(const Value: Boolean);
Private | procedure SetEnabled(const Value: Boolean);
Private | procedure SetLogFileMaxSize(const Value: Integer);
Private | procedure SetMode(const NewMode: TLogLevels);

Properties

Public | property Buffered: Boolean read FBuffered write SetBuffered default False;
Public | property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod default 4000;
Public | property DisplayErrorDialogs: Boolean read FDisplayErrorDialogs write FDisplayErrorDialogs default True;
Public | property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Public | property Enabled: Boolean read FEnabled write SetEnabled default True;
Public | property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod default 5000;
Public | property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize default 0;
Public | property LogLevels: TLogLevels read FLogLevels write SetMode default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Public | property LogThreadId: Boolean read FLogThreadId write FLogThreadId default True;
Public | property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;
Public | property WriteInternalMessages: Boolean read FWriteInternalMessages write FWriteInternalMessages default True;

Description

Fields

Private FBuffer: TStringList;

This item has no description.

Private FBuffered: Boolean;

This item has no description.

Private FBufferProcessingThread: TLogBufferFlushThread;

This item has no description.

Private FCheckLogSizeThread: TLogCheckSizeThread;

This item has no description.

Private FFlushBufferPeriod: Integer;

This item has no description.

Private FLogFile: Text;

This item has no description.

Private FDestroying: Boolean;

TextFile.

Private FOriginalLogFileName: string;

This item has no description.

Private FCurrentLogFileName: string;

Original name

Private FUsedLogFileNames: TStringList;

Current log file, if original exceeded certain size limit.

Private FLogLevels: TLogLevels;

List of all created log files.

Private FEnabled: Boolean;

This item has no description.

Private FBufferCriticalSection: TCriticalSection;

This item has no description.

Private FFileAccessCriticalSection: TCriticalSection;

This item has no description.

Private FModeTitles: array [TLogLevel] of string;

This item has no description.

Private FLogKindCount: array [TLogLevel] of Integer;

This item has no description.

Private FLogThreadId: Boolean;

This item has no description.

Private FMessageLimitAction: TLogMessageLimitAction;

This item has no description.

Private FTimeFormat: TLogTimeFormat;

Determines which date or time to include in the log

Private FStartedMs: Cardinal;

Startup timestamp in milliseconds

Private FLogFileMaxSize: Integer;

This item has no description.

Private FCheckFileSizePeriod: Integer;

This item has no description.

Private FDisplayLogOnExitIfItContains: TLogLevels;

This item has no description.

Private FWriteInternalMessages: Boolean;

This item has no description.

Private FDisplayErrorDialogs: Boolean;

This item has no description.

Methods

Public constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ABackUpOldLogs: Boolean = False; const AClearOldLogs: Boolean = True; const AWriteInternalMessages: Boolean = True); virtual;

Initializes a log session with the specified log file name, time and level settings

Private constructor OnlyCreate;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DisplayLog();

Mics procedures.

Public procedure FlushBuffer();

This item has no description.

Public procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);

General Logging procedures

Public procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);

This item has no description.

Public procedure LogDebug(const Desc: string);

Logs a string Desc if Level matches current USE_LOGGING level (see LogLevels)

Public procedure LogDebugFmt(const Desc: string; const args: array of const);

Logs a formatted string assembled from a format string and an array of arguments.

Public procedure LogEmtryLine();

This item has no description.

Public procedure LogError(const Desc: string);

This item has no description.

Public procedure LogErrorFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);

This item has no description.

Public procedure LogFatalError(const Desc: string);

This item has no description.

Public procedure LogFatalErrorFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogInfo(const Desc: string);

This item has no description.

Public procedure LogInfoFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogNotice(const Desc: string);

This item has no description.

Public procedure LogNoticeFmt(const Desc: string; const args: array of const);

This item has no description.

Public procedure LogWarning(const Desc: string);

This item has no description.

Public procedure LogWarningFmt(const Desc: string; const args: array of const);

This item has no description.

Private procedure ChangeBufferedState();

This item has no description.

Private procedure SetBuffered(const Value: Boolean);

This item has no description.

Private procedure SetEnabled(const Value: Boolean);

This item has no description.

Private procedure SetLogFileMaxSize(const Value: Integer);

This item has no description.

Private procedure SetMode(const NewMode: TLogLevels);

This item has no description.

Properties

Public property Buffered: Boolean read FBuffered write SetBuffered default False;

This item has no description.

Public property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod default 4000;

In bytes, limited to 2Gb.

Public property DisplayErrorDialogs: Boolean read FDisplayErrorDialogs write FDisplayErrorDialogs default True;

This item has no description.

Public property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

To always display log, put all log types. To never display log, leave this empty.

Public property Enabled: Boolean read FEnabled write SetEnabled default True;

This item has no description.

Public property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod default 5000;

This item has no description.

Public property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize default 0;

If LogFileMaxSize is not 0, then: 1) At start, all logs with the same extention will be deleted. 2) All logs wil be periodically cheked for FileSize. New log file will be created when this size exceeds limit.

Public property LogLevels: TLogLevels read FLogLevels write SetMode default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

If log is buffered, calling this will flush the buffer. Set of levels which to include in the log

Public property LogThreadId: Boolean read FLogThreadId write FLogThreadId default True;

In ms.

Public property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;

This item has no description.

Public property WriteInternalMessages: Boolean read FWriteInternalMessages write FWriteInternalMessages default True;


GXSysHelp v.2.5: GLScene.Logger: Class TGLSLogger

Class TGLSLogger

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Logger

Declaration

type TGLSLogger = class(TComponent)

Description

Abstract class for control logging.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TGLSLogger

Overview

Fields

Private | FReplaceAssertion: Boolean;
Private | FTimeFormat: TLogTimeFormat;
Private | FLogLevels: TLogLevels;
Private | FLog: TLogSession;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetLog: TLogSession;
Public | procedure DoPrimary;
Private | procedure SetReplaceAssertion(Value: Boolean);

Properties

Public | property Log: TLogSession read GetLog;
Published | property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Published | property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;
Published | property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;

Description

Fields

Private FReplaceAssertion: Boolean;

This item has no description.

Private FTimeFormat: TLogTimeFormat;

This item has no description.

Private FLogLevels: TLogLevels;

This item has no description.

Private FLog: TLogSession;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetLog: TLogSession;

This item has no description.

Public procedure DoPrimary;

Set component primary and then UserLog return it's log

Private procedure SetReplaceAssertion(Value: Boolean);

This item has no description.

Properties

Public property Log: TLogSession read GetLog;

This item has no description.

Published property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];

This item has no description.

Published property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;

This item has no description.

Published property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;

Only design time sets. Define Log initial properties


GXSysHelp v.2.5: GLScene.Manager

Unit GLScene.Manager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Types

Overview

Functions and Procedures

procedure RegisterManager(aManager: TComponent);
procedure DeRegisterManager(aManager: TComponent);
function FindManager(classType: TComponentClass; const managerName: String) : TComponent;

Description

Functions and Procedures

procedure RegisterManager(aManager: TComponent);

This item has no description.

procedure DeRegisterManager(aManager: TComponent);

This item has no description.

function FindManager(classType: TComponentClass; const managerName: String) : TComponent;


GXSysHelp v.2.5: GLScene.OpenGL4

Unit GLScene.OpenGL4

Description

Uses

Classes, Interfaces, Objects and Records

Functions and Procedures

Types

Constants

Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

System.SysUtils

System.Math

Winapi.Windows

GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name

Description

Packed Record _WGLSWAP

Record TGPUDEVICE

Record TGLUNurbs

Record TGLUQuadric

Record TGLUTesselator

Class EOpenGLError

Functions and Procedures

procedure glAccum(op: TGLuint; value: Single); stdcall; external opengl32;

procedure glAlphaFunc(func: Cardinal; ref: TGLclampf); stdcall; external opengl32;

function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;

procedure glArrayElement(i: TGLint); stdcall; external opengl32;

procedure glBegin(mode: Cardinal); stdcall; external opengl32;

procedure glBindTexture(target: Cardinal; texture: TGLuint); stdcall; external opengl32;

procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: Single; xmove: Single; ymove: Single; bitmap: Pointer); stdcall; external opengl32;

procedure glBlendFunc(sfactor: Cardinal; dfactor: Cardinal); stdcall; external opengl32;

procedure glCallList(list: TGLuint); stdcall; external opengl32;

procedure glCallLists(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall; external opengl32;

procedure glClear(mask: TGLbitfield); stdcall; external opengl32;

procedure glClearAccum(red, green, blue, alpha: Single); stdcall; external opengl32;

procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;

procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;

procedure glClearIndex(c: Single); stdcall; external opengl32;

procedure glClearStencil(s: TGLint ); stdcall; external opengl32;

procedure glClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;

procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;

procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;

procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;

procedure glColor3f(red, green, blue: Single); stdcall; external opengl32;

procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;

procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;

procedure glColor3iv(v: PGLint); stdcall; external opengl32;

procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;

procedure glColor3sv(v: PGLshort); stdcall; external opengl32;

procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;

procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;

procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;

procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;

procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;

procedure glColor3usv(v: PGLushort); stdcall; external opengl32;

procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;

procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;

procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;

procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;

procedure glColor4f(red, green, blue, alpha: Single); stdcall; external opengl32;

procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;

procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;

procedure glColor4iv(v: PGLint); stdcall; external opengl32;

procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;

procedure glColor4sv(v: TGLshort); stdcall; external opengl32;

procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;

procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;

procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;

procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;

procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;

procedure glColor4usv(v: PGLushort); stdcall; external opengl32;

procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;

procedure glColorMaterial(face: Cardinal; mode: Cardinal); stdcall; external opengl32;

procedure glColorPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: Cardinal); stdcall; external opengl32;

procedure glCopyTexImage1D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;

procedure glCopyTexImage2D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;

procedure glCopyTexSubImage1D(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;

procedure glCopyTexSubImage2D(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

procedure glCullFace(mode: Cardinal); stdcall; external opengl32;

procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;

procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

procedure glDepthFunc(func: Cardinal); stdcall; external opengl32;

procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;

procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;

procedure glDisable(cap: Cardinal); stdcall; external opengl32;

procedure glDisableClientState(aarray: Cardinal); stdcall; external opengl32;

procedure glDrawArrays(mode: Cardinal; first: TGLint; count: TGLsizei); stdcall; external opengl32;

procedure glDrawBuffer(mode: Cardinal); stdcall; external opengl32;

procedure glDrawElements(mode: Cardinal; count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall; external opengl32;

procedure glDrawPixels(width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;

procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;

procedure glEnable(cap: Cardinal); stdcall; external opengl32;

procedure glEnableClientState(aarray: Cardinal); stdcall; external opengl32;

procedure glEnd; stdcall; external opengl32;

procedure glEndList; stdcall; external opengl32;

procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;

procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;

procedure glEvalCoord1f(u: Single); stdcall; external opengl32;

procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;

procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;

procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;

procedure glEvalCoord2f(u, v: Single); stdcall; external opengl32;

procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;

procedure glEvalMesh1(mode: Cardinal; i1, i2: TGLint); stdcall; external opengl32;

procedure glEvalMesh2(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall; external opengl32;

procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;

procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;

procedure glFeedbackBuffer(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall; external opengl32;

procedure glFinish; stdcall; external opengl32;

procedure glFlush; stdcall; external opengl32;

procedure glFogf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glFogfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glFogi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glFogiv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glFrontFace(mode: Cardinal); stdcall; external opengl32;

procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;

procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

procedure glGetBooleanv(pname: Cardinal; params: PGLboolean); stdcall; external opengl32;

procedure glGetClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

procedure glGetDoublev(pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

function glGetError: TGLuint; stdcall; external opengl32;

procedure glGetFloatv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetIntegerv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetMapdv(target, query: Cardinal; v: PGLdouble); stdcall; external opengl32;

procedure glGetMapfv(target, query: Cardinal; v: PGLfloat); stdcall; external opengl32;

procedure glGetMapiv(target, query: Cardinal; v: PGLint); stdcall; external opengl32;

procedure glGetMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetPixelMapfv(map: Cardinal; values: PGLfloat); stdcall; external opengl32;

procedure glGetPixelMapuiv(map: Cardinal; values: PGLuint); stdcall; external opengl32;

procedure glGetPixelMapusv(map: Cardinal; values: PGLushort); stdcall; external opengl32;

procedure glGetPointerv(pname: Cardinal; var params); stdcall; external opengl32;

procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

function glGetString(name: Cardinal): PChar; stdcall; external opengl32;

procedure glGetTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

procedure glGetTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexImage(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glGetTexLevelParameterfv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexLevelParameteriv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glGetTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glGetTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glHint(target, mode: Cardinal); stdcall; external opengl32;

procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;

procedure glIndexPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glIndexd(c: TGLdouble); stdcall; external opengl32;

procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;

procedure glIndexf(c: Single); stdcall; external opengl32;

procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;

procedure glIndexi(c: TGLint); stdcall; external opengl32;

procedure glIndexiv(c: PGLint); stdcall; external opengl32;

procedure glIndexs(c: TGLshort); stdcall; external opengl32;

procedure glIndexsv(c: PGLshort); stdcall; external opengl32;

procedure glIndexub(c: TGLubyte); stdcall; external opengl32;

procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;

procedure glInitNames; stdcall; external opengl32;

procedure glInterleavedArrays(format: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

function glIsEnabled(cap: Cardinal): TGLboolean; stdcall; external opengl32;

function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;

function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;

procedure glLightModelf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glLightModelfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glLightModeli(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glLightModeliv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glLightf(light, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glLighti(light, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;

procedure glLineWidth(width: Single); stdcall; external opengl32;

procedure glListBase(base: TGLuint); stdcall; external opengl32;

procedure glLoadIdentity; stdcall; external opengl32;

procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;

procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;

procedure glLoadName(name: TGLuint); stdcall; external opengl32;

procedure glLogicOp(opcode: Cardinal); stdcall; external opengl32;

procedure glMap1d(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;

procedure glMap1f(target: Cardinal; u1, u2: Single; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;

procedure glMap2d(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;

procedure glMap2f(target: Cardinal; u1, u2: Single; ustride, uorder: TGLint; v1, v2: Single; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;

procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;

procedure glMapGrid1f(un: TGLint; u1, u2: Single); stdcall; external opengl32;

procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;

procedure glMapGrid2f(un: TGLint; u1, u2: Single; vn: TGLint; v1, v2: Single); stdcall; external opengl32;

procedure glMaterialf(face, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glMateriali(face, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glMatrixMode(mode: Cardinal); stdcall; external opengl32;

procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;

procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;

procedure glNewList(list: TGLuint; mode: Cardinal); stdcall; external opengl32;

procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;

procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;

procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;

procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;

procedure glNormal3f(nx, ny, nz: Single); stdcall; external opengl32;

procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;

procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;

procedure glNormal3iv(v: PGLint); stdcall; external opengl32;

procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;

procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;

procedure glNormalPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

procedure glPassThrough(token: Single); stdcall; external opengl32;

procedure glPixelMapfv(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;

procedure glPixelMapuiv(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;

procedure glPixelMapusv(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;

procedure glPixelStoref(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glPixelStorei(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glPixelTransferf(pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glPixelTransferi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glPixelZoom(xfactor, yfactor: Single); stdcall; external opengl32;

procedure glPointSize(size: Single); stdcall; external opengl32;

procedure glPolygonMode(face, mode: Cardinal); stdcall; external opengl32;

procedure glPolygonOffset(factor, units: Single); stdcall; external opengl32;

procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

procedure glPopAttrib; stdcall; external opengl32;

procedure glPopClientAttrib; stdcall; external opengl32;

procedure glPopMatrix; stdcall; external opengl32;

procedure glPopName; stdcall; external opengl32;

procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;

procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;

procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;

procedure glPushMatrix; stdcall; external opengl32;

procedure glPushName(name: TGLuint); stdcall; external opengl32;

procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;

procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos2f(x, y: Single); stdcall; external opengl32;

procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;

procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;

procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;

procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos3f(x, y, z: Single); stdcall; external opengl32;

procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;

procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;

procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;

procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;

procedure glRasterPos4f(x, y, z, w: Single); stdcall; external opengl32;

procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;

procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;

procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;

procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;

procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;

procedure glReadBuffer(mode: Cardinal); stdcall; external opengl32;

procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;

procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;

procedure glRectf(x1, y1, x2, y2: Single); stdcall; external opengl32;

procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;

procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;

procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;

procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;

procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;

function glRenderMode(mode: Cardinal): TGLint; stdcall; external opengl32;

procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;

procedure glRotatef(angle, x, y, z: Single); stdcall; external opengl32;

procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glScalef(x, y, z: Single); stdcall; external opengl32;

procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;

procedure glShadeModel(mode: Cardinal); stdcall; external opengl32;

procedure glStencilFunc(func: Cardinal; ref: TGLint; mask: TGLuint); stdcall; external opengl32;

procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;

procedure glStencilOp(fail, zfail, zpass: Cardinal); stdcall; external opengl32;

procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;

procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord1f(s: Single); stdcall; external opengl32;

procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;

procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;

procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;

procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord2f(s, t: Single); stdcall; external opengl32;

procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;

procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;

procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;

procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord3f(s, t, r: Single); stdcall; external opengl32;

procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;

procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;

procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;

procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;

procedure glTexCoord4f(s, t, r, q: Single); stdcall; external opengl32;

procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;

procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;

procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;

procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;

procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;

procedure glTexCoordPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glTexEnvf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexEnvi(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexGend(coord, pname: Cardinal; param: TGLdouble); stdcall; external opengl32;

procedure glTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

procedure glTexGenf(coord, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexGeni(coord, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexImage1D(target: Cardinal; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTexImage2D(target: Cardinal; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: Cardinal; Pixels:Pointer); stdcall; external opengl32;

procedure glTexParameterf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

procedure glTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

procedure glTexParameteri(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

procedure glTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

procedure glTexSubImage1D(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTexSubImage2D(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glTranslatef(x, y, z: Single); stdcall; external opengl32;

procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;

procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex2f(x, y: Single); stdcall; external opengl32;

procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;

procedure glVertex2iv(v: PGLint); stdcall; external opengl32;

procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;

procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;

procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;

procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex3f(x, y, z: Single); stdcall; external opengl32;

procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;

procedure glVertex3iv(v: PGLint); stdcall; external opengl32;

procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;

procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;

procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;

procedure glVertex4f(x, y, z, w: Single); stdcall; external opengl32;

procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;

procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;

procedure glVertex4iv(v: PGLint); stdcall; external opengl32;

procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;

procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;

procedure glVertexPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

function gluErrorString(errCode: Cardinal): PGLChar; stdcall; external glu32;

function gluGetString(name: Cardinal): PGLChar; stdcall; external glu32;

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

function gluBuild1DMipmaps(target: Cardinal; components, width: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

function gluBuild2DMipmaps(target: Cardinal; components, width, height: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

function gluNewTess: PGLUtesselator; stdcall; external glu32;

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: PGLfloat); stdcall; external glu32;

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; value: PGLdouble); stdcall; external glu32;

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: Single); stdcall; external glu32;

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;

procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; value: TGLdouble); stdcall; external glu32;

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

function wglGetCurrentDC: HDC; stdcall; external opengl32;

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;

function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';

function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';

function GLGetProcAddress(ProcName: PGLChar): Pointer;

procedure ReadExtensions;

procedure ReadImplementationProperties;

procedure ReadWGLExtensions;

procedure ReadWGLImplementationProperties;

procedure CloseOpenGL;

function InitOpenGL: Boolean;

function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;

function IsOpenGLInitialized: Boolean;

procedure UnloadOpenGL;

function LoadOpenGL: Boolean;

function LoadOpenGLFromLibrary(const GLName, GLUName: String): Boolean;

function IsOpenGLLoaded: Boolean;

function IsMesaGL: Boolean;

procedure TrimAndSplitVersionString(Buffer: String; out Max, Min: Integer);

function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;

function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;

procedure CheckOpenGLError;

procedure ClearGLError;

procedure RaiseOpenGLError(const msg : String);

Types

GLbitfield = UINT;

GLboolean = BYTEBOOL;

GLbyte = ShortInt;

GLclampd = Double;

GLclampf = Single;

GLdouble = Double;

GLenum = Cardinal;

GLfloat = Single;

GLhandleARB = Cardinal;

GLint = Integer;

GLint64 = Int64;

GLint64EXT = Int64;

GLshort = SmallInt;

GLsizei = Integer;

GLubyte = Byte;

GLuint = UINT;

GLuint64 = UInt64;

GLuint64EXT = UInt64;

GLushort = Word;

HGPUNV = THandle;

HPBUFFERARB = Integer;

HVIDEOINPUTDEVICENV = THandle;

PGLbitfield = ˆTGLbitfield;

PGLboolean = ˆTGLboolean;

PGLbyte = ˆTGLbyte;

PGLChar = PAnsiChar;

PGLclampd = ˆTGLclampd;

PGLclampf = ˆTGLclampf;

PGLdouble = System.PDouble;

PGLenum = ˆCardinal;

PGLfloat = System.PSingle;

PGLhandleARB = ˆGLhandleARB;

PGLint = ˆInteger;

PGLint64 = ˆTGLint64;

PGLint64EXT = ˆTGLint64EXT;

PGLintptr = ˆTGLintptr;

PGLPCharArray = ˆPGLChar;

PGLPointer = ˆPointer;

PGLshort = ˆTGLshort;

PGLsizei = ˆTGLsizei;

PGLubyte = System.PByte;

PGLuint = ˆTGLuint;

PGLuint64 = ˆTGLuint64;

PGLuint64EXT = ˆTGLuint64EXT;

PGLUNurbs = ˆTGLUNurbs;

PGLUNurbsObj = PGLUNurbs;

PGLUQuadric = ˆTGLUQuadric;

PGLUQuadricObj = PGLUQuadric;

PGLushort = System.PWord;

PGLUTesselator = ˆTGLUTesselator;

PGLUTesselatorObj = PGLUTesselator;

PGLUTriangulatorObj = PGLUTesselator;

PGLvoid = Pointer;

PGPUDEVICE = ˆTGPUDEVICE;

PHGPUNV = ˆHGPUNV;

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

PWGLSwap = ˆTWGLSwap;

TGLbitfield = UINT;

TGLboolean = BYTEBOOL;

TGLbyte = ShortInt;

TGLclampd = Double;

TGLclampf = Single;

TGLdouble = Double;

TGLEnum = Cardinal;

TGLfloat = Single;

TGLint = Integer;

TGLint64 = Int64;

TGLint64EXT = Int64;

TGLintptr = NativeInt;

TGLshort = SmallInt;

TGLsizei = Integer;

TGLsizeiptr = NativeInt;

TGLString = AnsiString;

TGLsync = NativeInt;

TGLubyte = Byte;

TGLuint = UINT;

TGLuint64 = UInt64;

TGLuint64EXT = UInt64;

TGLUNurbsErrorProc = procedure(errorCode: Cardinal); stdcall;

TGLUNurbsObj = TGLUNurbs;

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

TGLUQuadricObj = TGLUQuadric;

TGLushort = Word;

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

TGLUTesselatorObj = TGLUTesselator;

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

TGLUTessEndProc = procedure; stdcall;

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

TGLUTriangulatorObj = TGLUTesselator;

TRCOptions = set of ( opDoubleBuffered, opGDI, opStereo );

TVector4p = array[0..3] of Pointer;

TWGLSwap = _WGLSWAP;

WGLSWAP = _WGLSWAP;

Constants

opengl32 = 'OpenGL32.dll';

glu32 = 'GLU32.dll';

libEGL = 'libEGL.dll';

libGLES2 = 'libGLESv2.dll';

GL_DEPTH_BUFFER_BIT = $00000100;

GL_STENCIL_BUFFER_BIT = $00000400;

GL_COLOR_BUFFER_BIT = $00004000;

GL_TRUE = 1;

GL_FALSE = 0;

GL_POINTS = $0000;

GL_LINES = $0001;

GL_LINE_LOOP = $0002;

GL_LINE_STRIP = $0003;

GL_TRIANGLES = $0004;

GL_TRIANGLE_STRIP = $0005;

GL_TRIANGLE_FAN = $0006;

GL_NEVER = $0200;

GL_LESS = $0201;

GL_EQUAL = $0202;

GL_LEQUAL = $0203;

GL_GREATER = $0204;

GL_NOTEQUAL = $0205;

GL_GEQUAL = $0206;

GL_ALWAYS = $0207;

GL_ZERO = 0;

GL_ONE = 1;

GL_SRC_COLOR = $0300;

GL_ONE_MINUS_SRC_COLOR = $0301;

GL_SRC_ALPHA = $0302;

GL_ONE_MINUS_SRC_ALPHA = $0303;

GL_DST_ALPHA = $0304;

GL_ONE_MINUS_DST_ALPHA = $0305;

GL_DST_COLOR = $0306;

GL_ONE_MINUS_DST_COLOR = $0307;

GL_SRC_ALPHA_SATURATE = $0308;

GL_NONE = 0;

GL_FRONT_LEFT = $0400;

GL_FRONT_RIGHT = $0401;

GL_BACK_LEFT = $0402;

GL_BACK_RIGHT = $0403;

GL_FRONT = $0404;

GL_BACK = $0405;

GL_LEFT = $0406;

GL_RIGHT = $0407;

GL_FRONT_AND_BACK = $0408;

GL_NO_ERROR = 0;

GL_INVALID_ENUM = $0500;

GL_INVALID_VALUE = $0501;

GL_INVALID_OPERATION = $0502;

GL_OUT_OF_MEMORY = $0505;

GL_CW = $0900;

GL_CCW = $0901;

GL_POINT_SIZE = $0B11;

GL_POINT_SIZE_RANGE = $0B12;

GL_POINT_SIZE_GRANULARITY = $0B13;

GL_LINE_SMOOTH = $0B20;

GL_LINE_WIDTH = $0B21;

GL_LINE_WIDTH_RANGE = $0B22;

GL_LINE_WIDTH_GRANULARITY = $0B23;

GL_POLYGON_SMOOTH = $0B41;

GL_CULL_FACE = $0B44;

GL_CULL_FACE_MODE = $0B45;

GL_FRONT_FACE = $0B46;

GL_DEPTH_RANGE = $0B70;

GL_DEPTH_TEST = $0B71;

GL_DEPTH_WRITEMASK = $0B72;

GL_DEPTH_CLEAR_VALUE = $0B73;

GL_DEPTH_FUNC = $0B74;

GL_STENCIL_TEST = $0B90;

GL_STENCIL_CLEAR_VALUE = $0B91;

GL_STENCIL_FUNC = $0B92;

GL_STENCIL_VALUE_MASK = $0B93;

GL_STENCIL_FAIL = $0B94;

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

GL_STENCIL_REF = $0B97;

GL_STENCIL_WRITEMASK = $0B98;

GL_VIEWPORT = $0BA2;

GL_DITHER = $0BD0;

GL_BLEND_DST = $0BE0;

GL_BLEND_SRC = $0BE1;

GL_BLEND = $0BE2;

GL_LOGIC_OP_MODE = $0BF0;

GL_COLOR_LOGIC_OP = $0BF2;

GL_DRAW_BUFFER = $0C01;

GL_READ_BUFFER = $0C02;

GL_SCISSOR_BOX = $0C10;

GL_SCISSOR_TEST = $0C11;

GL_COLOR_CLEAR_VALUE = $0C22;

GL_COLOR_WRITEMASK = $0C23;

GL_DOUBLEBUFFER = $0C32;

GL_STEREO = $0C33;

GL_LINE_SMOOTH_HINT = $0C52;

GL_POLYGON_SMOOTH_HINT = $0C53;

GL_UNPACK_SWAP_BYTES = $0CF0;

GL_UNPACK_LSB_FIRST = $0CF1;

GL_UNPACK_ROW_LENGTH = $0CF2;

GL_UNPACK_SKIP_ROWS = $0CF3;

GL_UNPACK_SKIP_PIXELS = $0CF4;

GL_UNPACK_ALIGNMENT = $0CF5;

GL_PACK_SWAP_BYTES = $0D00;

GL_PACK_LSB_FIRST = $0D01;

GL_PACK_ROW_LENGTH = $0D02;

GL_PACK_SKIP_ROWS = $0D03;

GL_PACK_SKIP_PIXELS = $0D04;

GL_PACK_ALIGNMENT = $0D05;

GL_MAX_TEXTURE_SIZE = $0D33;

GL_MAX_VIEWPORT_DIMS = $0D3A;

GL_SUBPIXEL_BITS = $0D50;

GL_TEXTURE_1D = $0DE0;

GL_TEXTURE_2D = $0DE1;

GL_POLYGON_OFFSET_UNITS = $2A00;

GL_POLYGON_OFFSET_POINT = $2A01;

GL_POLYGON_OFFSET_LINE = $2A02;

GL_POLYGON_OFFSET_FILL = $8037;

GL_POLYGON_OFFSET_FACTOR = $8038;

GL_TEXTURE_BINDING_1D = $8068;

GL_TEXTURE_BINDING_2D = $8069;

GL_TEXTURE_WIDTH = $1000;

GL_TEXTURE_HEIGHT = $1001;

GL_TEXTURE_INTERNAL_FORMAT = $1003;

GL_TEXTURE_BORDER_COLOR = $1004;

GL_TEXTURE_BORDER = $1005;

GL_TEXTURE_RED_SIZE = $805C;

GL_TEXTURE_GREEN_SIZE = $805D;

GL_TEXTURE_BLUE_SIZE = $805E;

GL_TEXTURE_ALPHA_SIZE = $805F;

GL_DONT_CARE = $1100;

GL_FASTEST = $1101;

GL_NICEST = $1102;

GL_BYTE = $1400;

GL_UNSIGNED_BYTE = $1401;

GL_SHORT = $1402;

GL_UNSIGNED_SHORT = $1403;

GL_INT = $1404;

GL_UNSIGNED_INT = $1405;

GL_FLOAT = $1406;

GL_DOUBLE = $140A;

GL_CLEAR = $1500;

GL_AND = $1501;

GL_AND_REVERSE = $1502;

GL_COPY = $1503;

GL_AND_INVERTED = $1504;

GL_NOOP = $1505;

GL_XOR = $1506;

GL_OR = $1507;

GL_NOR = $1508;

GL_EQUIV = $1509;

GL_INVERT = $150A;

GL_OR_REVERSE = $150B;

GL_COPY_INVERTED = $150C;

GL_OR_INVERTED = $150D;

GL_NAND = $150E;

GL_SET = $150F;

GL_TEXTURE = $1702;

GL_COLOR = $1800;

GL_DEPTH = $1801;

GL_STENCIL = $1802;

GL_STENCIL_INDEX = $1901;

GL_DEPTH_COMPONENT = $1902;

GL_RED = $1903;

GL_GREEN = $1904;

GL_BLUE = $1905;

GL_ALPHA = $1906;

GL_RGB = $1907;

GL_RGBA = $1908;

GL_POINT = $1B00;

GL_LINE = $1B01;

GL_FILL = $1B02;

GL_KEEP = $1E00;

GL_REPLACE = $1E01;

GL_INCR = $1E02;

GL_DECR = $1E03;

GL_VENDOR = $1F00;

GL_RENDERER = $1F01;

GL_VERSION = $1F02;

GL_EXTENSIONS = $1F03;

GL_NEAREST = $2600;

GL_LINEAR = $2601;

GL_NEAREST_MIPMAP_NEAREST = $2700;

GL_LINEAR_MIPMAP_NEAREST = $2701;

GL_NEAREST_MIPMAP_LINEAR = $2702;

GL_LINEAR_MIPMAP_LINEAR = $2703;

GL_TEXTURE_MAG_FILTER = $2800;

GL_TEXTURE_MIN_FILTER = $2801;

GL_TEXTURE_WRAP_S = $2802;

GL_TEXTURE_WRAP_T = $2803;

GL_PROXY_TEXTURE_1D = $8063;

GL_PROXY_TEXTURE_2D = $8064;

GL_REPEAT = $2901;

GL_R3_G3_B2 = $2A10;

GL_RGB4 = $804F;

GL_RGB5 = $8050;

GL_RGB8 = $8051;

GL_RGB10 = $8052;

GL_RGB12 = $8053;

GL_RGB16 = $8054;

GL_RGBA2 = $8055;

GL_RGBA4 = $8056;

GL_RGB5_A1 = $8057;

GL_RGBA8 = $8058;

GL_RGB10_A2 = $8059;

GL_RGBA12 = $805A;

GL_RGBA16 = $805B;

GL_ACCUM = $0100;

GL_LOAD = $0101;

GL_RETURN = $0102;

GL_MULT = $0103;

GL_ADD = $0104;

GL_CURRENT_BIT = $00000001;

GL_POINT_BIT = $00000002;

GL_LINE_BIT = $00000004;

GL_POLYGON_BIT = $00000008;

GL_POLYGON_STIPPLE_BIT = $00000010;

GL_PIXEL_MODE_BIT = $00000020;

GL_LIGHTING_BIT = $00000040;

GL_FOG_BIT = $00000080;

GL_ACCUM_BUFFER_BIT = $00000200;

GL_VIEWPORT_BIT = $00000800;

GL_TRANSFORM_BIT = $00001000;

GL_ENABLE_BIT = $00002000;

GL_HINT_BIT = $00008000;

GL_EVAL_BIT = $00010000;

GL_LIST_BIT = $00020000;

GL_TEXTURE_BIT = $00040000;

GL_SCISSOR_BIT = $00080000;

GL_ALL_ATTRIB_BITS = $000FFFFF;

GL_QUADS = $0007;

GL_QUAD_STRIP = $0008;

GL_POLYGON = $0009;

GL_CLIP_PLANE0 = $3000;

GL_CLIP_PLANE1 = $3001;

GL_CLIP_PLANE2 = $3002;

GL_CLIP_PLANE3 = $3003;

GL_CLIP_PLANE4 = $3004;

GL_CLIP_PLANE5 = $3005;

GL_2_BYTES = $1407;

GL_3_BYTES = $1408;

GL_4_BYTES = $1409;

GL_AUX0 = $0409;

GL_AUX1 = $040A;

GL_AUX2 = $040B;

GL_AUX3 = $040C;

GL_STACK_OVERFLOW = $0503;

GL_STACK_UNDERFLOW = $0504;

GL_2D = $0600;

GL_3D = $0601;

GL_3D_COLOR = $0602;

GL_3D_COLOR_TEXTURE = $0603;

GL_4D_COLOR_TEXTURE = $0604;

GL_PASS_THROUGH_TOKEN = $0700;

GL_POINT_TOKEN = $0701;

GL_LINE_TOKEN = $0702;

GL_POLYGON_TOKEN = $0703;

GL_BITMAP_TOKEN = $0704;

GL_DRAW_PIXEL_TOKEN = $0705;

GL_COPY_PIXEL_TOKEN = $0706;

GL_LINE_RESET_TOKEN = $0707;

GL_EXP = $0800;

GL_EXP2 = $0801;

GL_COEFF = $0A00;

GL_ORDER = $0A01;

GL_DOMAIN = $0A02;

GL_CURRENT_COLOR = $0B00;

GL_CURRENT_INDEX = $0B01;

GL_CURRENT_NORMAL = $0B02;

GL_CURRENT_TEXTURE_COORDS = $0B03;

GL_CURRENT_RASTER_COLOR = $0B04;

GL_CURRENT_RASTER_INDEX = $0B05;

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06;

GL_CURRENT_RASTER_POSITION = $0B07;

GL_CURRENT_RASTER_POSITION_VALID = $0B08;

GL_CURRENT_RASTER_DISTANCE = $0B09;

GL_POINT_SMOOTH = $0B10;

GL_LINE_STIPPLE = $0B24;

GL_LINE_STIPPLE_PATTERN = $0B25;

GL_LINE_STIPPLE_REPEAT = $0B26;

GL_LIST_MODE = $0B30;

GL_MAX_LIST_NESTING = $0B31;

GL_LIST_BASE = $0B32;

GL_LIST_INDEX = $0B33;

GL_POLYGON_MODE = $0B40;

GL_POLYGON_STIPPLE = $0B42;

GL_EDGE_FLAG = $0B43;

GL_LIGHTING = $0B50;

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51;

GL_LIGHT_MODEL_TWO_SIDE = $0B52;

GL_LIGHT_MODEL_AMBIENT = $0B53;

GL_SHADE_MODEL = $0B54;

GL_COLOR_MATERIAL_FACE = $0B55;

GL_COLOR_MATERIAL_PARAMETER = $0B56;

GL_COLOR_MATERIAL = $0B57;

GL_FOG = $0B60;

GL_FOG_INDEX = $0B61;

GL_FOG_DENSITY = $0B62;

GL_FOG_START = $0B63;

GL_FOG_END = $0B64;

GL_FOG_MODE = $0B65;

GL_FOG_COLOR = $0B66;

GL_ACCUM_CLEAR_VALUE = $0B80;

GL_MATRIX_MODE = $0BA0;

GL_NORMALIZE = $0BA1;

GL_MODELVIEW_STACK_DEPTH = $0BA3;

GL_PROJECTION_STACK_DEPTH = $0BA4;

GL_TEXTURE_STACK_DEPTH = $0BA5;

GL_MODELVIEW_MATRIX = $0BA6;

GL_PROJECTION_MATRIX = $0BA7;

GL_TEXTURE_MATRIX = $0BA8;

GL_ATTRIB_STACK_DEPTH = $0BB0;

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1;

GL_ALPHA_TEST = $0BC0;

GL_ALPHA_TEST_FUNC = $0BC1;

GL_ALPHA_TEST_REF = $0BC2;

GL_INDEX_LOGIC_OP = $0BF1;

GL_AUX_BUFFERS = $0C00;

GL_INDEX_CLEAR_VALUE = $0C20;

GL_INDEX_WRITEMASK = $0C21;

GL_INDEX_MODE = $0C30;

GL_RGBA_MODE = $0C31;

GL_RENDER_MODE = $0C40;

GL_PERSPECTIVE_CORRECTION_HINT = $0C50;

GL_POINT_SMOOTH_HINT = $0C51;

GL_FOG_HINT = $0C54;

GL_TEXTURE_GEN_S = $0C60;

GL_TEXTURE_GEN_T = $0C61;

GL_TEXTURE_GEN_R = $0C62;

GL_TEXTURE_GEN_Q = $0C63;

GL_PIXEL_MAP_I_TO_I = $0C70;

GL_PIXEL_MAP_S_TO_S = $0C71;

GL_PIXEL_MAP_I_TO_R = $0C72;

GL_PIXEL_MAP_I_TO_G = $0C73;

GL_PIXEL_MAP_I_TO_B = $0C74;

GL_PIXEL_MAP_I_TO_A = $0C75;

GL_PIXEL_MAP_R_TO_R = $0C76;

GL_PIXEL_MAP_G_TO_G = $0C77;

GL_PIXEL_MAP_B_TO_B = $0C78;

GL_PIXEL_MAP_A_TO_A = $0C79;

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0;

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1;

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2;

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3;

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4;

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5;

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6;

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7;

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8;

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9;

GL_MAP_COLOR = $0D10;

GL_MAP_STENCIL = $0D11;

GL_INDEX_SHIFT = $0D12;

GL_INDEX_OFFSET = $0D13;

GL_RED_SCALE = $0D14;

GL_RED_BIAS = $0D15;

GL_ZOOM_X = $0D16;

GL_ZOOM_Y = $0D17;

GL_GREEN_SCALE = $0D18;

GL_GREEN_BIAS = $0D19;

GL_BLUE_SCALE = $0D1A;

GL_BLUE_BIAS = $0D1B;

GL_ALPHA_SCALE = $0D1C;

GL_ALPHA_BIAS = $0D1D;

GL_DEPTH_SCALE = $0D1E;

GL_DEPTH_BIAS = $0D1F;

GL_MAX_EVAL_ORDER = $0D30;

GL_MAX_LIGHTS = $0D31;

GL_MAX_CLIP_PLANES = $0D32;

GL_MAX_PIXEL_MAP_TABLE = $0D34;

GL_MAX_ATTRIB_STACK_DEPTH = $0D35;

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36;

GL_MAX_NAME_STACK_DEPTH = $0D37;

GL_MAX_PROJECTION_STACK_DEPTH = $0D38;

GL_MAX_TEXTURE_STACK_DEPTH = $0D39;

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B;

GL_INDEX_BITS = $0D51;

GL_RED_BITS = $0D52;

GL_GREEN_BITS = $0D53;

GL_BLUE_BITS = $0D54;

GL_ALPHA_BITS = $0D55;

GL_DEPTH_BITS = $0D56;

GL_STENCIL_BITS = $0D57;

GL_ACCUM_RED_BITS = $0D58;

GL_ACCUM_GREEN_BITS = $0D59;

GL_ACCUM_BLUE_BITS = $0D5A;

GL_ACCUM_ALPHA_BITS = $0D5B;

GL_NAME_STACK_DEPTH = $0D70;

GL_AUTO_NORMAL = $0D80;

GL_MAP1_COLOR_4 = $0D90;

GL_MAP1_INDEX = $0D91;

GL_MAP1_NORMAL = $0D92;

GL_MAP1_TEXTURE_COORD_1 = $0D93;

GL_MAP1_TEXTURE_COORD_2 = $0D94;

GL_MAP1_TEXTURE_COORD_3 = $0D95;

GL_MAP1_TEXTURE_COORD_4 = $0D96;

GL_MAP1_VERTEX_3 = $0D97;

GL_MAP1_VERTEX_4 = $0D98;

GL_MAP2_COLOR_4 = $0DB0;

GL_MAP2_INDEX = $0DB1;

GL_MAP2_NORMAL = $0DB2;

GL_MAP2_TEXTURE_COORD_1 = $0DB3;

GL_MAP2_TEXTURE_COORD_2 = $0DB4;

GL_MAP2_TEXTURE_COORD_3 = $0DB5;

GL_MAP2_TEXTURE_COORD_4 = $0DB6;

GL_MAP2_VERTEX_3 = $0DB7;

GL_MAP2_VERTEX_4 = $0DB8;

GL_MAP1_GRID_DOMAIN = $0DD0;

GL_MAP1_GRID_SEGMENTS = $0DD1;

GL_MAP2_GRID_DOMAIN = $0DD2;

GL_MAP2_GRID_SEGMENTS = $0DD3;

GL_FEEDBACK_BUFFER_POINTER = $0DF0;

GL_FEEDBACK_BUFFER_SIZE = $0DF1;

GL_FEEDBACK_BUFFER_TYPE = $0DF2;

GL_SELECTION_BUFFER_POINTER = $0DF3;

GL_SELECTION_BUFFER_SIZE = $0DF4;

GL_LIGHT0 = $4000;

GL_LIGHT1 = $4001;

GL_LIGHT2 = $4002;

GL_LIGHT3 = $4003;

GL_LIGHT4 = $4004;

GL_LIGHT5 = $4005;

GL_LIGHT6 = $4006;

GL_LIGHT7 = $4007;

GL_AMBIENT = $1200;

GL_DIFFUSE = $1201;

GL_SPECULAR = $1202;

GL_POSITION = $1203;

GL_SPOT_DIRECTION = $1204;

GL_SPOT_EXPONENT = $1205;

GL_SPOT_CUTOFF = $1206;

GL_CONSTANT_ATTENUATION = $1207;

GL_LINEAR_ATTENUATION = $1208;

GL_QUADRATIC_ATTENUATION = $1209;

GL_COMPILE = $1300;

GL_COMPILE_AND_EXECUTE = $1301;

GL_EMISSION = $1600;

GL_SHININESS = $1601;

GL_AMBIENT_AND_DIFFUSE = $1602;

GL_COLOR_INDEXES = $1603;

GL_MODELVIEW = $1700;

GL_PROJECTION = $1701;

GL_COLOR_INDEX = $1900;

GL_LUMINANCE = $1909;

GL_LUMINANCE_ALPHA = $190A;

GL_BITMAP = $1A00;

GL_RENDER = $1C00;

GL_FEEDBACK = $1C01;

GL_SELECT = $1C02;

GL_FLAT = $1D00;

GL_SMOOTH = $1D01;

GL_S = $2000;

GL_T = $2001;

GL_R = $2002;

GL_Q = $2003;

GL_MODULATE = $2100;

GL_DECAL = $2101;

GL_TEXTURE_ENV_MODE = $2200;

GL_TEXTURE_ENV_COLOR = $2201;

GL_TEXTURE_ENV = $2300;

GL_EYE_LINEAR = $2400;

GL_OBJECT_LINEAR = $2401;

GL_SPHERE_MAP = $2402;

GL_TEXTURE_GEN_MODE = $2500;

GL_OBJECT_PLANE = $2501;

GL_EYE_PLANE = $2502;

GL_CLAMP = $2900;

GL_CLIENT_PIXEL_STORE_BIT = $00000001;

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002;

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF;

GL_ALPHA4 = $803B;

GL_ALPHA8 = $803C;

GL_ALPHA12 = $803D;

GL_ALPHA16 = $803E;

GL_LUMINANCE4 = $803F;

GL_LUMINANCE8 = $8040;

GL_LUMINANCE12 = $8041;

GL_LUMINANCE16 = $8042;

GL_LUMINANCE4_ALPHA4 = $8043;

GL_LUMINANCE6_ALPHA2 = $8044;

GL_LUMINANCE8_ALPHA8 = $8045;

GL_LUMINANCE12_ALPHA4 = $8046;

GL_LUMINANCE12_ALPHA12 = $8047;

GL_LUMINANCE16_ALPHA16 = $8048;

GL_INTENSITY = $8049;

GL_INTENSITY4 = $804A;

GL_INTENSITY8 = $804B;

GL_INTENSITY12 = $804C;

GL_INTENSITY16 = $804D;

GL_TEXTURE_LUMINANCE_SIZE = $8060;

GL_TEXTURE_INTENSITY_SIZE = $8061;

GL_TEXTURE_PRIORITY = $8066;

GL_TEXTURE_RESIDENT = $8067;

GL_VERTEX_ARRAY = $8074;

GL_NORMAL_ARRAY = $8075;

GL_COLOR_ARRAY = $8076;

GL_INDEX_ARRAY = $8077;

GL_TEXTURE_COORD_ARRAY = $8078;

GL_EDGE_FLAG_ARRAY = $8079;

GL_VERTEX_ARRAY_SIZE = $807A;

GL_VERTEX_ARRAY_TYPE = $807B;

GL_VERTEX_ARRAY_STRIDE = $807C;

GL_NORMAL_ARRAY_TYPE = $807E;

GL_NORMAL_ARRAY_STRIDE = $807F;

GL_COLOR_ARRAY_SIZE = $8081;

GL_COLOR_ARRAY_TYPE = $8082;

GL_COLOR_ARRAY_STRIDE = $8083;

GL_INDEX_ARRAY_TYPE = $8085;

GL_INDEX_ARRAY_STRIDE = $8086;

GL_TEXTURE_COORD_ARRAY_SIZE = $8088;

GL_TEXTURE_COORD_ARRAY_TYPE = $8089;

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A;

GL_EDGE_FLAG_ARRAY_STRIDE = $808C;

GL_VERTEX_ARRAY_POINTER = $808E;

GL_NORMAL_ARRAY_POINTER = $808F;

GL_COLOR_ARRAY_POINTER = $8090;

GL_INDEX_ARRAY_POINTER = $8091;

GL_TEXTURE_COORD_ARRAY_POINTER = $8092;

GL_EDGE_FLAG_ARRAY_POINTER = $8093;

GL_V2F = $2A20;

GL_V3F = $2A21;

GL_C4UB_V2F = $2A22;

GL_C4UB_V3F = $2A23;

GL_C3F_V3F = $2A24;

GL_N3F_V3F = $2A25;

GL_C4F_N3F_V3F = $2A26;

GL_T2F_V3F = $2A27;

GL_T4F_V4F = $2A28;

GL_T2F_C4UB_V3F = $2A29;

GL_T2F_C3F_V3F = $2A2A;

GL_T2F_N3F_V3F = $2A2B;

GL_T2F_C4F_N3F_V3F = $2A2C;

GL_T4F_C4F_N3F_V4F = $2A2D;

GL_COLOR_TABLE_FORMAT_EXT = $80D8;

GL_COLOR_TABLE_WIDTH_EXT = $80D9;

GL_COLOR_TABLE_RED_SIZE_EXT = $80DA;

GL_COLOR_TABLE_GREEN_SIZE_EXT = $80DB;

GL_COLOR_TABLE_BLUE_SIZE_EXT = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE_EXT = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE_EXT = $80DF;

GL_LOGIC_OP = GL_INDEX_LOGIC_OP;

GL_TEXTURE_COMPONENTS = GL_TEXTURE_INTERNAL_FORMAT;

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

GL_UNSIGNED_INT_8_8_8_8 = $8035;

GL_UNSIGNED_INT_10_10_10_2 = $8036;

GL_TEXTURE_BINDING_3D = $806A;

GL_PACK_SKIP_IMAGES = $806B;

GL_PACK_IMAGE_HEIGHT = $806C;

GL_UNPACK_SKIP_IMAGES = $806D;

GL_UNPACK_IMAGE_HEIGHT = $806E;

GL_TEXTURE_3D = $806F;

GL_PROXY_TEXTURE_3D = $8070;

GL_TEXTURE_DEPTH = $8071;

GL_TEXTURE_WRAP_R = $8072;

GL_MAX_3D_TEXTURE_SIZE = $8073;

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

GL_UNSIGNED_SHORT_5_6_5 = $8363;

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

GL_BGR = $80E0;

GL_BGRA = $80E1;

GL_MAX_ELEMENTS_VERTICES = $80E8;

GL_MAX_ELEMENTS_INDICES = $80E9;

GL_CLAMP_TO_EDGE = $812F;

GL_TEXTURE_MIN_LOD = $813A;

GL_TEXTURE_MAX_LOD = $813B;

GL_TEXTURE_BASE_LEVEL = $813C;

GL_TEXTURE_MAX_LEVEL = $813D;

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

GL_RESCALE_NORMAL = $803A;

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8;

GL_SINGLE_COLOR = $81F9;

GL_SEPARATE_SPECULAR_COLOR = $81FA;

GL_ALIASED_POINT_SIZE_RANGE = $846D;

GL_TEXTURE0 = $84C0;

GL_TEXTURE1 = $84C1;

GL_TEXTURE2 = $84C2;

GL_TEXTURE3 = $84C3;

GL_TEXTURE4 = $84C4;

GL_TEXTURE5 = $84C5;

GL_TEXTURE6 = $84C6;

GL_TEXTURE7 = $84C7;

GL_TEXTURE8 = $84C8;

GL_TEXTURE9 = $84C9;

GL_TEXTURE10 = $84CA;

GL_TEXTURE11 = $84CB;

GL_TEXTURE12 = $84CC;

GL_TEXTURE13 = $84CD;

GL_TEXTURE14 = $84CE;

GL_TEXTURE15 = $84CF;

GL_TEXTURE16 = $84D0;

GL_TEXTURE17 = $84D1;

GL_TEXTURE18 = $84D2;

GL_TEXTURE19 = $84D3;

GL_TEXTURE20 = $84D4;

GL_TEXTURE21 = $84D5;

GL_TEXTURE22 = $84D6;

GL_TEXTURE23 = $84D7;

GL_TEXTURE24 = $84D8;

GL_TEXTURE25 = $84D9;

GL_TEXTURE26 = $84DA;

GL_TEXTURE27 = $84DB;

GL_TEXTURE28 = $84DC;

GL_TEXTURE29 = $84DD;

GL_TEXTURE30 = $84DE;

GL_TEXTURE31 = $84DF;

GL_ACTIVE_TEXTURE = $84E0;

GL_MULTISAMPLE = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

GL_SAMPLE_ALPHA_TO_ONE = $809F;

GL_SAMPLE_COVERAGE = $80A0;

GL_SAMPLE_BUFFERS = $80A8;

GL_SAMPLES = $80A9;

GL_SAMPLE_COVERAGE_VALUE = $80AA;

GL_SAMPLE_COVERAGE_INVERT = $80AB;

GL_TEXTURE_CUBE_MAP = $8513;

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

GL_COMPRESSED_RGB = $84ED;

GL_COMPRESSED_RGBA = $84EE;

GL_TEXTURE_COMPRESSION_HINT = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

GL_TEXTURE_COMPRESSED = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

GL_CLAMP_TO_BORDER = $812D;

GL_CLIENT_ACTIVE_TEXTURE = $84E1;

GL_MAX_TEXTURE_UNITS = $84E2;

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5;

GL_TRANSPOSE_COLOR_MATRIX = $84E6;

GL_MULTISAMPLE_BIT = $20000000;

GL_NORMAL_MAP = $8511;

GL_REFLECTION_MAP = $8512;

GL_COMPRESSED_ALPHA = $84E9;

GL_COMPRESSED_LUMINANCE = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB;

GL_COMPRESSED_INTENSITY = $84EC;

GL_COMBINE = $8570;

GL_COMBINE_RGB = $8571;

GL_COMBINE_ALPHA = $8572;

GL_SOURCE0_RGB = $8580;

GL_SOURCE1_RGB = $8581;

GL_SOURCE2_RGB = $8582;

GL_SOURCE0_ALPHA = $8588;

GL_SOURCE1_ALPHA = $8589;

GL_SOURCE2_ALPHA = $858A;

GL_OPERAND0_RGB = $8590;

GL_OPERAND1_RGB = $8591;

GL_OPERAND2_RGB = $8592;

GL_OPERAND0_ALPHA = $8598;

GL_OPERAND1_ALPHA = $8599;

GL_OPERAND2_ALPHA = $859A;

GL_RGB_SCALE = $8573;

GL_ADD_SIGNED = $8574;

GL_INTERPOLATE = $8575;

GL_SUBTRACT = $84E7;

GL_CONSTANT = $8576;

GL_PRIMARY_COLOR = $8577;

GL_PREVIOUS = $8578;

GL_DOT3_RGB = $86AE;

GL_DOT3_RGBA = $86AF;

GL_BLEND_DST_RGB = $80C8;

GL_BLEND_SRC_RGB = $80C9;

GL_BLEND_DST_ALPHA = $80CA;

GL_BLEND_SRC_ALPHA = $80CB;

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

GL_DEPTH_COMPONENT16 = $81A5;

GL_DEPTH_COMPONENT24 = $81A6;

GL_DEPTH_COMPONENT32 = $81A7;

GL_MIRRORED_REPEAT = $8370;

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

GL_TEXTURE_LOD_BIAS = $8501;

GL_INCR_WRAP = $8507;

GL_DECR_WRAP = $8508;

GL_TEXTURE_DEPTH_SIZE = $884A;

GL_TEXTURE_COMPARE_MODE = $884C;

GL_TEXTURE_COMPARE_FUNC = $884D;

GL_POINT_SIZE_MIN = $8126;

GL_POINT_SIZE_MAX = $8127;

GL_POINT_DISTANCE_ATTENUATION = $8129;

GL_GENERATE_MIPMAP = $8191;

GL_GENERATE_MIPMAP_HINT = $8192;

GL_FOG_COORDINATE_SOURCE = $8450;

GL_FOG_COORDINATE = $8451;

GL_FRAGMENT_DEPTH = $8452;

GL_CURRENT_FOG_COORDINATE = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER = $8456;

GL_FOG_COORDINATE_ARRAY = $8457;

GL_COLOR_SUM = $8458;

GL_CURRENT_SECONDARY_COLOR = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D;

GL_SECONDARY_COLOR_ARRAY = $845E;

GL_TEXTURE_FILTER_CONTROL = $8500;

GL_DEPTH_TEXTURE_MODE = $884B;

GL_COMPARE_R_TO_TEXTURE = $884E;

GL_BUFFER_SIZE = $8764;

GL_BUFFER_USAGE = $8765;

GL_QUERY_COUNTER_BITS = $8864;

GL_CURRENT_QUERY = $8865;

GL_QUERY_RESULT = $8866;

GL_QUERY_RESULT_AVAILABLE = $8867;

GL_ARRAY_BUFFER = $8892;

GL_ELEMENT_ARRAY_BUFFER = $8893;

GL_ARRAY_BUFFER_BINDING = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

GL_READ_ONLY = $88B8;

GL_WRITE_ONLY = $88B9;

GL_READ_WRITE = $88BA;

GL_BUFFER_ACCESS = $88BB;

GL_BUFFER_MAPPED = $88BC;

GL_BUFFER_MAP_POINTER = $88BD;

GL_STREAM_DRAW = $88E0;

GL_STREAM_READ = $88E1;

GL_STREAM_COPY = $88E2;

GL_STATIC_DRAW = $88E4;

GL_STATIC_READ = $88E5;

GL_STATIC_COPY = $88E6;

GL_DYNAMIC_DRAW = $88E8;

GL_DYNAMIC_READ = $88E9;

GL_DYNAMIC_COPY = $88EA;

GL_SAMPLES_PASSED = $8914;

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E;

GL_FOG_COORD_SRC = $8450;

GL_FOG_COORD = $8451;

GL_CURRENT_FOG_COORD = $8453;

GL_FOG_COORD_ARRAY_TYPE = $8454;

GL_FOG_COORD_ARRAY_STRIDE = $8455;

GL_FOG_COORD_ARRAY_POINTER = $8456;

GL_FOG_COORD_ARRAY = $8457;

GL_FOG_COORD_ARRAY_BUFFER_BINDING = $889D;

GL_SRC0_RGB = $8580;

GL_SRC1_RGB = $8581;

GL_SRC2_RGB = $8582;

GL_SRC0_ALPHA = $8588;

GL_SRC1_ALPHA = $8589;

GL_SRC2_ALPHA = $858A;

GL_BLEND_EQUATION_RGB = $8009;

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

GL_CURRENT_VERTEX_ATTRIB = $8626;

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

GL_STENCIL_BACK_FUNC = $8800;

GL_STENCIL_BACK_FAIL = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

GL_MAX_DRAW_BUFFERS = $8824;

GL_DRAW_BUFFER0 = $8825;

GL_DRAW_BUFFER1 = $8826;

GL_DRAW_BUFFER2 = $8827;

GL_DRAW_BUFFER3 = $8828;

GL_DRAW_BUFFER4 = $8829;

GL_DRAW_BUFFER5 = $882A;

GL_DRAW_BUFFER6 = $882B;

GL_DRAW_BUFFER7 = $882C;

GL_DRAW_BUFFER8 = $882D;

GL_DRAW_BUFFER9 = $882E;

GL_DRAW_BUFFER10 = $882F;

GL_DRAW_BUFFER11 = $8830;

GL_DRAW_BUFFER12 = $8831;

GL_DRAW_BUFFER13 = $8832;

GL_DRAW_BUFFER14 = $8833;

GL_DRAW_BUFFER15 = $8834;

GL_BLEND_EQUATION_ALPHA = $883D;

GL_MAX_VERTEX_ATTRIBS = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

GL_FRAGMENT_SHADER = $8B30;

GL_VERTEX_SHADER = $8B31;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

GL_MAX_VARYING_FLOATS = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

GL_SHADER_TYPE = $8B4F;

GL_FLOAT_VEC2 = $8B50;

GL_FLOAT_VEC3 = $8B51;

GL_FLOAT_VEC4 = $8B52;

GL_INT_VEC2 = $8B53;

GL_INT_VEC3 = $8B54;

GL_INT_VEC4 = $8B55;

GL_BOOL = $8B56;

GL_BOOL_VEC2 = $8B57;

GL_BOOL_VEC3 = $8B58;

GL_BOOL_VEC4 = $8B59;

GL_FLOAT_MAT2 = $8B5A;

GL_FLOAT_MAT3 = $8B5B;

GL_FLOAT_MAT4 = $8B5C;

GL_SAMPLER_1D = $8B5D;

GL_SAMPLER_2D = $8B5E;

GL_SAMPLER_3D = $8B5F;

GL_SAMPLER_CUBE = $8B60;

GL_SAMPLER_1D_SHADOW = $8B61;

GL_SAMPLER_2D_SHADOW = $8B62;

GL_DELETE_STATUS = $8B80;

GL_COMPILE_STATUS = $8B81;

GL_LINK_STATUS = $8B82;

GL_VALIDATE_STATUS = $8B83;

GL_INFO_LOG_LENGTH = $8B84;

GL_ATTACHED_SHADERS = $8B85;

GL_ACTIVE_UNIFORMS = $8B86;

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

GL_SHADER_SOURCE_LENGTH = $8B88;

GL_ACTIVE_ATTRIBUTES = $8B89;

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

GL_SHADING_LANGUAGE_VERSION = $8B8C;

GL_CURRENT_PROGRAM = $8B8D;

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

GL_LOWER_LEFT = $8CA1;

GL_UPPER_LEFT = $8CA2;

GL_STENCIL_BACK_REF = $8CA3;

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

GL_STENCIL_BACK_WRITEMASK = $8CA5;

GL_VERTEX_PROGRAM_TWO_SIDE = $8643;

GL_POINT_SPRITE = $8861;

GL_COORD_REPLACE = $8862;

GL_MAX_TEXTURE_COORDS = $8871;

GL_PIXEL_PACK_BUFFER = $88EB;

GL_PIXEL_UNPACK_BUFFER = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

GL_FLOAT_MAT2x3 = $8B65;

GL_FLOAT_MAT2x4 = $8B66;

GL_FLOAT_MAT3x2 = $8B67;

GL_FLOAT_MAT3x4 = $8B68;

GL_FLOAT_MAT4x2 = $8B69;

GL_FLOAT_MAT4x3 = $8B6A;

GL_SRGB = $8C40;

GL_SRGB8 = $8C41;

GL_SRGB_ALPHA = $8C42;

GL_SRGB8_ALPHA8 = $8C43;

GL_COMPRESSED_SRGB = $8C48;

GL_COMPRESSED_SRGB_ALPHA = $8C49;

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F;

GL_SLUMINANCE_ALPHA = $8C44;

GL_SLUMINANCE8_ALPHA8 = $8C45;

GL_SLUMINANCE = $8C46;

GL_SLUMINANCE8 = $8C47;

GL_COMPRESSED_SLUMINANCE = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B;

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_CLIP_DISTANCE0 = $3000;

GL_CLIP_DISTANCE1 = $3001;

GL_CLIP_DISTANCE2 = $3002;

GL_CLIP_DISTANCE3 = $3003;

GL_CLIP_DISTANCE4 = $3004;

GL_CLIP_DISTANCE5 = $3005;

GL_CLIP_DISTANCE6 = $3006;

GL_CLIP_DISTANCE7 = $3007;

GL_MAX_CLIP_DISTANCES = $0D32;

GL_MAJOR_VERSION = $821B;

GL_MINOR_VERSION = $821C;

GL_NUM_EXTENSIONS = $821D;

GL_CONTEXT_FLAGS = $821E;

GL_DEPTH_BUFFER = $8223;

GL_STENCIL_BUFFER = $8224;

GL_COMPRESSED_RED = $8225;

GL_COMPRESSED_RG = $8226;

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

GL_RGBA32F = $8814;

GL_RGB32F = $8815;

GL_RGBA16F = $881A;

GL_RGB16F = $881B;

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

GL_CLAMP_READ_COLOR = $891C;

GL_FIXED_ONLY = $891D;

GL_MAX_VARYING_COMPONENTS = $8B4B;

GL_TEXTURE_1D_ARRAY = $8C18;

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

GL_TEXTURE_2D_ARRAY = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

GL_R11F_G11F_B10F = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

GL_RGB9_E5 = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

GL_TEXTURE_SHARED_SIZE = $8C3F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

GL_PRIMITIVES_GENERATED = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

GL_RASTERIZER_DISCARD = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

GL_INTERLEAVED_ATTRIBS = $8C8C;

GL_SEPARATE_ATTRIBS = $8C8D;

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

GL_RGBA32UI = $8D70;

GL_RGB32UI = $8D71;

GL_RGBA16UI = $8D76;

GL_RGB16UI = $8D77;

GL_RGBA8UI = $8D7C;

GL_RGB8UI = $8D7D;

GL_RGBA32I = $8D82;

GL_RGB32I = $8D83;

GL_RGBA16I = $8D88;

GL_RGB16I = $8D89;

GL_RGBA8I = $8D8E;

GL_RGB8I = $8D8F;

GL_RED_INTEGER = $8D94;

GL_GREEN_INTEGER = $8D95;

GL_BLUE_INTEGER = $8D96;

GL_RGB_INTEGER = $8D98;

GL_RGBA_INTEGER = $8D99;

GL_BGR_INTEGER = $8D9A;

GL_BGRA_INTEGER = $8D9B;

GL_SAMPLER_1D_ARRAY = $8DC0;

GL_SAMPLER_2D_ARRAY = $8DC1;

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

GL_SAMPLER_CUBE_SHADOW = $8DC5;

GL_UNSIGNED_INT_VEC2 = $8DC6;

GL_UNSIGNED_INT_VEC3 = $8DC7;

GL_UNSIGNED_INT_VEC4 = $8DC8;

GL_INT_SAMPLER_1D = $8DC9;

GL_INT_SAMPLER_2D = $8DCA;

GL_INT_SAMPLER_3D = $8DCB;

GL_INT_SAMPLER_CUBE = $8DCC;

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

GL_QUERY_WAIT = $8E13;

GL_QUERY_NO_WAIT = $8E14;

GL_QUERY_BY_REGION_WAIT = $8E15;

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

GL_BUFFER_ACCESS_FLAGS = $911F;

GL_BUFFER_MAP_LENGTH = $9120;

GL_BUFFER_MAP_OFFSET = $9121;

GL_CLAMP_VERTEX_COLOR = $891A;

GL_CLAMP_FRAGMENT_COLOR = $891B;

GL_ALPHA_INTEGER = $8D97;

GL_SAMPLER_2D_RECT = $8B63;

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

GL_SAMPLER_BUFFER = $8DC2;

GL_INT_SAMPLER_2D_RECT = $8DCD;

GL_INT_SAMPLER_BUFFER = $8DD0;

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

GL_TEXTURE_BUFFER = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

GL_TEXTURE_BINDING_BUFFER = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

GL_TEXTURE_RECTANGLE = $84F5;

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

GL_RED_SNORM = $8F90;

GL_RG_SNORM = $8F91;

GL_RGB_SNORM = $8F92;

GL_RGBA_SNORM = $8F93;

GL_R8_SNORM = $8F94;

GL_RG8_SNORM = $8F95;

GL_RGB8_SNORM = $8F96;

GL_RGBA8_SNORM = $8F97;

GL_R16_SNORM = $8F98;

GL_RG16_SNORM = $8F99;

GL_RGB16_SNORM = $8F9A;

GL_RGBA16_SNORM = $8F9B;

GL_SIGNED_NORMALIZED = $8F9C;

GL_PRIMITIVE_RESTART = $8F9D;

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

GL_LINES_ADJACENCY = $000A;

GL_LINE_STRIP_ADJACENCY = $000B;

GL_TRIANGLES_ADJACENCY = $000C;

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

GL_PROGRAM_POINT_SIZE = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

GL_GEOMETRY_SHADER = $8DD9;

GL_GEOMETRY_VERTICES_OUT = $8916;

GL_GEOMETRY_INPUT_TYPE = $8917;

GL_GEOMETRY_OUTPUT_TYPE = $8918;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

GL_CONTEXT_PROFILE_MASK = $9126;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_SAMPLE_SHADING = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

GL_NUM_SHADING_LANGUAGE_VERSIONS = $82E9;

GL_VERTEX_ATTRIB_ARRAY_LONG = $874E;

GL_MULTISAMPLE_3DFX = $86B2;

GL_SAMPLE_BUFFERS_3DFX = $86B3;

GL_SAMPLES_3DFX = $86B4;

GL_MULTISAMPLE_BIT_3DFX = $20000000;

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

GL_UNPACK_CLIENT_STORAGE_APPLE = $85B2;

GL_ELEMENT_ARRAY_APPLE = $8A0C;

GL_ELEMENT_ARRAY_TYPE_APPLE = $8A0D;

GL_ELEMENT_ARRAY_POINTER_APPLE = $8A0E;

GL_DRAW_PIXELS_APPLE = $8A0A;

GL_FENCE_APPLE = $8A0B;

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE = $85B0;

GL_TRANSFORM_HINT_APPLE = $85B1;

GL_VERTEX_ARRAY_BINDING_APPLE = $85B5;

GL_VERTEX_ARRAY_RANGE_APPLE = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE = $851E;

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE = $851F;

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE = $8521;

GL_STORAGE_CLIENT_APPLE = $85B4;

GL_STORAGE_CACHED_APPLE = $85BE;

GL_STORAGE_SHARED_APPLE = $85BF;

GL_YCBCR_422_APPLE = $85B9;

GL_UNSIGNED_SHORT_8_8_APPLE = $85BA;

GL_UNSIGNED_SHORT_8_8_REV_APPLE = $85BB;

GL_RGB_RAW_422_APPLE = $8A51;

GL_TEXTURE_RANGE_LENGTH_APPLE = $85B7;

GL_TEXTURE_RANGE_POINTER_APPLE = $85B8;

GL_TEXTURE_STORAGE_HINT_APPLE = $85BC;

GL_STORAGE_PRIVATE_APPLE = $85BD;

GL_HALF_APPLE = $140B;

GL_RGBA_FLOAT32_APPLE = $8814;

GL_RGB_FLOAT32_APPLE = $8815;

GL_ALPHA_FLOAT32_APPLE = $8816;

GL_INTENSITY_FLOAT32_APPLE = $8817;

GL_LUMINANCE_FLOAT32_APPLE = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_APPLE = $8819;

GL_RGBA_FLOAT16_APPLE = $881A;

GL_RGB_FLOAT16_APPLE = $881B;

GL_ALPHA_FLOAT16_APPLE = $881C;

GL_INTENSITY_FLOAT16_APPLE = $881D;

GL_LUMINANCE_FLOAT16_APPLE = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_APPLE = $881F;

GL_COLOR_FLOAT_APPLE = $8A0F;

GL_VERTEX_ATTRIB_MAP1_APPLE = $8A00;

GL_VERTEX_ATTRIB_MAP2_APPLE = $8A01;

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE = $8A02;

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE = $8A03;

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE = $8A04;

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE = $8A05;

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE = $8A06;

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE = $8A07;

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE = $8A08;

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE = $8A09;

GL_AUX_DEPTH_STENCIL_APPLE = $8A14;

GL_BUFFER_OBJECT_APPLE = $85B3;

GL_RELEASED_APPLE = $8A19;

GL_VOLATILE_APPLE = $8A1A;

GL_RETAINED_APPLE = $8A1B;

GL_UNDEFINED_APPLE = $8A1C;

GL_PURGEABLE_APPLE = $8A1D;

GL_PACK_ROW_BYTES_APPLE = $8A15;

GL_UNPACK_ROW_BYTES_APPLE = $8A16;

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_DEPTH_COMPONENT24_ARB = $81A6;

GL_DEPTH_COMPONENT32_ARB = $81A7;

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

GL_MAX_TEXTURE_COORDS_ARB = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

GL_CONSTANT_COLOR_ARB = $8001;

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

GL_CONSTANT_ALPHA = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

GL_BLEND_COLOR = $8005;

GL_FUNC_ADD = $8006;

GL_MIN = $8007;

GL_MAX = $8008;

GL_BLEND_EQUATION = $8009;

GL_FUNC_SUBTRACT = $800A;

GL_FUNC_REVERSE_SUBTRACT = $800B;

GL_CONVOLUTION_1D = $8010;

GL_CONVOLUTION_2D = $8011;

GL_SEPARABLE_2D = $8012;

GL_CONVOLUTION_BORDER_MODE = $8013;

GL_CONVOLUTION_FILTER_SCALE = $8014;

GL_CONVOLUTION_FILTER_BIAS = $8015;

GL_REDUCE = $8016;

GL_CONVOLUTION_FORMAT = $8017;

GL_CONVOLUTION_WIDTH = $8018;

GL_CONVOLUTION_HEIGHT = $8019;

GL_MAX_CONVOLUTION_WIDTH = $801A;

GL_MAX_CONVOLUTION_HEIGHT = $801B;

GL_POST_CONVOLUTION_RED_SCALE = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F;

GL_POST_CONVOLUTION_RED_BIAS = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023;

GL_HISTOGRAM = $8024;

GL_PROXY_HISTOGRAM = $8025;

GL_HISTOGRAM_WIDTH = $8026;

GL_HISTOGRAM_FORMAT = $8027;

GL_HISTOGRAM_RED_SIZE = $8028;

GL_HISTOGRAM_GREEN_SIZE = $8029;

GL_HISTOGRAM_BLUE_SIZE = $802A;

GL_HISTOGRAM_ALPHA_SIZE = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE = $802C;

GL_HISTOGRAM_SINK = $802D;

GL_MINMAX = $802E;

GL_MINMAX_FORMAT = $802F;

GL_MINMAX_SINK = $8030;

GL_TABLE_TOO_LARGE = $8031;

GL_COLOR_MATRIX = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB;

GL_COLOR_TABLE = $80D0;

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1;

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2;

GL_PROXY_COLOR_TABLE = $80D3;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5;

GL_COLOR_TABLE_SCALE = $80D6;

GL_COLOR_TABLE_BIAS = $80D7;

GL_COLOR_TABLE_FORMAT = $80D8;

GL_COLOR_TABLE_WIDTH = $80D9;

GL_COLOR_TABLE_RED_SIZE = $80DA;

GL_COLOR_TABLE_GREEN_SIZE = $80DB;

GL_COLOR_TABLE_BLUE_SIZE = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF;

GL_CONSTANT_BORDER = $8151;

GL_REPLICATE_BORDER = $8153;

GL_CONVOLUTION_BORDER_COLOR = $8154;

GL_MATRIX_PALETTE_ARB = $8840;

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

GL_MAX_PALETTE_MATRICES_ARB = $8842;

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

GL_MULTISAMPLE_ARB = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

GL_SAMPLE_COVERAGE_ARB = $80A0;

GL_SAMPLE_BUFFERS_ARB = $80A8;

GL_SAMPLES_ARB = $80A9;

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

GL_MULTISAMPLE_BIT_ARB = $20000000;

GL_TEXTURE0_ARB = $84C0;

GL_TEXTURE1_ARB = $84C1;

GL_TEXTURE2_ARB = $84C2;

GL_TEXTURE3_ARB = $84C3;

GL_TEXTURE4_ARB = $84C4;

GL_TEXTURE5_ARB = $84C5;

GL_TEXTURE6_ARB = $84C6;

GL_TEXTURE7_ARB = $84C7;

GL_TEXTURE8_ARB = $84C8;

GL_TEXTURE9_ARB = $84C9;

GL_TEXTURE10_ARB = $84CA;

GL_TEXTURE11_ARB = $84CB;

GL_TEXTURE12_ARB = $84CC;

GL_TEXTURE13_ARB = $84CD;

GL_TEXTURE14_ARB = $84CE;

GL_TEXTURE15_ARB = $84CF;

GL_TEXTURE16_ARB = $84D0;

GL_TEXTURE17_ARB = $84D1;

GL_TEXTURE18_ARB = $84D2;

GL_TEXTURE19_ARB = $84D3;

GL_TEXTURE20_ARB = $84D4;

GL_TEXTURE21_ARB = $84D5;

GL_TEXTURE22_ARB = $84D6;

GL_TEXTURE23_ARB = $84D7;

GL_TEXTURE24_ARB = $84D8;

GL_TEXTURE25_ARB = $84D9;

GL_TEXTURE26_ARB = $84DA;

GL_TEXTURE27_ARB = $84DB;

GL_TEXTURE28_ARB = $84DC;

GL_TEXTURE29_ARB = $84DD;

GL_TEXTURE30_ARB = $84DE;

GL_TEXTURE31_ARB = $84DF;

GL_ACTIVE_TEXTURE_ARB = $84E0;

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

GL_POINT_SIZE_MIN_ARB = $8126;

GL_POINT_SIZE_MAX_ARB = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

GL_POINT_DISTANCE_ATTENUATION_ARB = $8129;

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_SPARSE_STORAGE_BIT_ARB = $0400;

GL_SPARSE_BUFFER_PAGE_SIZE_ARB = $82F8;

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

GL_COMPRESSED_INTENSITY_ARB = $84EC;

GL_COMPRESSED_RGB_ARB = $84ED;

GL_COMPRESSED_RGBA_ARB = $84EE;

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

GL_TEXTURE_COMPRESSED_ARB = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

GL_NORMAL_MAP_ARB = $8511;

GL_REFLECTION_MAP_ARB = $8512;

GL_TEXTURE_CUBE_MAP_ARB = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

GL_COMBINE_ARB = $8570;

GL_COMBINE_RGB_ARB = $8571;

GL_COMBINE_ALPHA_ARB = $8572;

GL_SOURCE0_RGB_ARB = $8580;

GL_SOURCE1_RGB_ARB = $8581;

GL_SOURCE2_RGB_ARB = $8582;

GL_SOURCE0_ALPHA_ARB = $8588;

GL_SOURCE1_ALPHA_ARB = $8589;

GL_SOURCE2_ALPHA_ARB = $858A;

GL_OPERAND0_RGB_ARB = $8590;

GL_OPERAND1_RGB_ARB = $8591;

GL_OPERAND2_RGB_ARB = $8592;

GL_OPERAND0_ALPHA_ARB = $8598;

GL_OPERAND1_ALPHA_ARB = $8599;

GL_OPERAND2_ALPHA_ARB = $859A;

GL_RGB_SCALE_ARB = $8573;

GL_ADD_SIGNED_ARB = $8574;

GL_INTERPOLATE_ARB = $8575;

GL_SUBTRACT_ARB = $84E7;

GL_CONSTANT_ARB = $8576;

GL_PRIMARY_COLOR_ARB = $8577;

GL_PREVIOUS_ARB = $8578;

GL_DOT3_RGB_ARB = $86AE;

GL_DOT3_RGBA_ARB = $86AF;

GL_TEXTURE_REDUCTION_MODE_ARB = $9366;

GL_WEIGHTED_AVERAGE_ARB = $9367;

GL_MIRRORED_REPEAT_ARB = $8370;

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

GL_VERTEX_BLEND_ARB = $86A7;

GL_CURRENT_WEIGHT_ARB = $86A8;

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

GL_WEIGHT_ARRAY_ARB = $86AD;

GL_MODELVIEW0_ARB = $1700;

GL_MODELVIEW1_ARB = $850A;

GL_MODELVIEW2_ARB = $8722;

GL_MODELVIEW3_ARB = $8723;

GL_MODELVIEW4_ARB = $8724;

GL_MODELVIEW5_ARB = $8725;

GL_MODELVIEW6_ARB = $8726;

GL_MODELVIEW7_ARB = $8727;

GL_MODELVIEW8_ARB = $8728;

GL_MODELVIEW9_ARB = $8729;

GL_MODELVIEW10_ARB = $872A;

GL_MODELVIEW11_ARB = $872B;

GL_MODELVIEW12_ARB = $872C;

GL_MODELVIEW13_ARB = $872D;

GL_MODELVIEW14_ARB = $872E;

GL_MODELVIEW15_ARB = $872F;

GL_MODELVIEW16_ARB = $8730;

GL_MODELVIEW17_ARB = $8731;

GL_MODELVIEW18_ARB = $8732;

GL_MODELVIEW19_ARB = $8733;

GL_MODELVIEW20_ARB = $8734;

GL_MODELVIEW21_ARB = $8735;

GL_MODELVIEW22_ARB = $8736;

GL_MODELVIEW23_ARB = $8737;

GL_MODELVIEW24_ARB = $8738;

GL_MODELVIEW25_ARB = $8739;

GL_MODELVIEW26_ARB = $873A;

GL_MODELVIEW27_ARB = $873B;

GL_MODELVIEW28_ARB = $873C;

GL_MODELVIEW29_ARB = $873D;

GL_MODELVIEW30_ARB = $873E;

GL_MODELVIEW31_ARB = $873F;

GL_BUFFER_SIZE_ARB = $8764;

GL_BUFFER_USAGE_ARB = $8765;

GL_ARRAY_BUFFER_ARB = $8892;

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

GL_READ_ONLY_ARB = $88B8;

GL_WRITE_ONLY_ARB = $88B9;

GL_READ_WRITE_ARB = $88BA;

GL_BUFFER_ACCESS_ARB = $88BB;

GL_BUFFER_MAPPED_ARB = $88BC;

GL_BUFFER_MAP_POINTER_ARB = $88BD;

GL_STREAM_DRAW_ARB = $88E0;

GL_STREAM_READ_ARB = $88E1;

GL_STREAM_COPY_ARB = $88E2;

GL_STATIC_DRAW_ARB = $88E4;

GL_STATIC_READ_ARB = $88E5;

GL_STATIC_COPY_ARB = $88E6;

GL_DYNAMIC_DRAW_ARB = $88E8;

GL_DYNAMIC_READ_ARB = $88E9;

GL_DYNAMIC_COPY_ARB = $88EA;

GL_COLOR_SUM_ARB = $8458;

GL_VERTEX_PROGRAM_ARB = $8620;

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

GL_PROGRAM_LENGTH_ARB = $8627;

GL_PROGRAM_STRING_ARB = $8628;

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

GL_CURRENT_MATRIX_ARB = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

GL_PROGRAM_BINDING_ARB = $8677;

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

GL_PROGRAM_ERROR_STRING_ARB = $8874;

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

GL_PROGRAM_FORMAT_ARB = $8876;

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

GL_PROGRAM_PARAMETERS_ARB = $88A8;

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

GL_PROGRAM_ATTRIBS_ARB = $88AC;

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

GL_MATRIX0_ARB = $88C0;

GL_MATRIX1_ARB = $88C1;

GL_MATRIX2_ARB = $88C2;

GL_MATRIX3_ARB = $88C3;

GL_MATRIX4_ARB = $88C4;

GL_MATRIX5_ARB = $88C5;

GL_MATRIX6_ARB = $88C6;

GL_MATRIX7_ARB = $88C7;

GL_MATRIX8_ARB = $88C8;

GL_MATRIX9_ARB = $88C9;

GL_MATRIX10_ARB = $88CA;

GL_MATRIX11_ARB = $88CB;

GL_MATRIX12_ARB = $88CC;

GL_MATRIX13_ARB = $88CD;

GL_MATRIX14_ARB = $88CE;

GL_MATRIX15_ARB = $88CF;

GL_MATRIX16_ARB = $88D0;

GL_MATRIX17_ARB = $88D1;

GL_MATRIX18_ARB = $88D2;

GL_MATRIX19_ARB = $88D3;

GL_MATRIX20_ARB = $88D4;

GL_MATRIX21_ARB = $88D5;

GL_MATRIX22_ARB = $88D6;

GL_MATRIX23_ARB = $88D7;

GL_MATRIX24_ARB = $88D8;

GL_MATRIX25_ARB = $88D9;

GL_MATRIX26_ARB = $88DA;

GL_MATRIX27_ARB = $88DB;

GL_MATRIX28_ARB = $88DC;

GL_MATRIX29_ARB = $88DD;

GL_MATRIX30_ARB = $88DE;

GL_MATRIX31_ARB = $88DF;

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_DRAW_BUFFER0_ARB = $8825;

GL_DRAW_BUFFER1_ARB = $8826;

GL_DRAW_BUFFER2_ARB = $8827;

GL_DRAW_BUFFER3_ARB = $8828;

GL_DRAW_BUFFER4_ARB = $8829;

GL_DRAW_BUFFER5_ARB = $882A;

GL_DRAW_BUFFER6_ARB = $882B;

GL_DRAW_BUFFER7_ARB = $882C;

GL_DRAW_BUFFER8_ARB = $882D;

GL_DRAW_BUFFER9_ARB = $882E;

GL_DRAW_BUFFER10_ARB = $882F;

GL_DRAW_BUFFER11_ARB = $8830;

GL_DRAW_BUFFER12_ARB = $8831;

GL_DRAW_BUFFER13_ARB = $8832;

GL_DRAW_BUFFER14_ARB = $8833;

GL_DRAW_BUFFER15_ARB = $8834;

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

GL_CLAMP_READ_COLOR_ARB = $891C;

GL_FIXED_ONLY_ARB = $891D;

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

GLX_RGBA_FLOAT_TYPE = $20B9;

GLX_RGBA_FLOAT_BIT = $00000004;

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB = $9344;

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB = $90EB;

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB = $9345;

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB = $91BF;

GL_HALF_FLOAT_ARB = $140B;

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

GL_RGBA32F_ARB = $8814;

GL_RGB32F_ARB = $8815;

GL_ALPHA32F_ARB = $8816;

GL_INTENSITY32F_ARB = $8817;

GL_LUMINANCE32F_ARB = $8818;

GL_LUMINANCE_ALPHA32F_ARB = $8819;

GL_RGBA16F_ARB = $881A;

GL_RGB16F_ARB = $881B;

GL_ALPHA16F_ARB = $881C;

GL_INTENSITY16F_ARB = $881D;

GL_LUMINANCE16F_ARB = $881E;

GL_LUMINANCE_ALPHA16F_ARB = $881F;

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

GL_DEPTH_COMPONENT32F = $8CAC;

GL_DEPTH32F_STENCIL8 = $8CAD;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

GL_FRAMEBUFFER_DEFAULT = $8218;

GL_FRAMEBUFFER_UNDEFINED = $8219;

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

GL_MAX_RENDERBUFFER_SIZE = $84E8;

GL_DEPTH_STENCIL = $84F9;

GL_UNSIGNED_INT_24_8 = $84FA;

GL_DEPTH24_STENCIL8 = $88F0;

GL_TEXTURE_STENCIL_SIZE = $88F1;

GL_TEXTURE_RED_TYPE = $8C10;

GL_TEXTURE_GREEN_TYPE = $8C11;

GL_TEXTURE_BLUE_TYPE = $8C12;

GL_TEXTURE_ALPHA_TYPE = $8C13;

GL_TEXTURE_DEPTH_TYPE = $8C16;

GL_UNSIGNED_NORMALIZED = $8C17;

GL_FRAMEBUFFER_BINDING = $8CA6;

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

GL_RENDERBUFFER_BINDING = $8CA7;

GL_READ_FRAMEBUFFER = $8CA8;

GL_DRAW_FRAMEBUFFER = $8CA9;

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

GL_RENDERBUFFER_SAMPLES = $8CAB;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

GL_FRAMEBUFFER_COMPLETE = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

GL_COLOR_ATTACHMENT0 = $8CE0;

GL_COLOR_ATTACHMENT1 = $8CE1;

GL_COLOR_ATTACHMENT2 = $8CE2;

GL_COLOR_ATTACHMENT3 = $8CE3;

GL_COLOR_ATTACHMENT4 = $8CE4;

GL_COLOR_ATTACHMENT5 = $8CE5;

GL_COLOR_ATTACHMENT6 = $8CE6;

GL_COLOR_ATTACHMENT7 = $8CE7;

GL_COLOR_ATTACHMENT8 = $8CE8;

GL_COLOR_ATTACHMENT9 = $8CE9;

GL_COLOR_ATTACHMENT10 = $8CEA;

GL_COLOR_ATTACHMENT11 = $8CEB;

GL_COLOR_ATTACHMENT12 = $8CEC;

GL_COLOR_ATTACHMENT13 = $8CED;

GL_COLOR_ATTACHMENT14 = $8CEE;

GL_COLOR_ATTACHMENT15 = $8CEF;

GL_DEPTH_ATTACHMENT = $8D00;

GL_STENCIL_ATTACHMENT = $8D20;

GL_FRAMEBUFFER = $8D40;

GL_RENDERBUFFER = $8D41;

GL_RENDERBUFFER_WIDTH = $8D42;

GL_RENDERBUFFER_HEIGHT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

GL_STENCIL_INDEX1 = $8D46;

GL_STENCIL_INDEX4 = $8D47;

GL_STENCIL_INDEX8 = $8D48;

GL_STENCIL_INDEX16 = $8D49;

GL_RENDERBUFFER_RED_SIZE = $8D50;

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

GL_MAX_SAMPLES = $8D57;

GL_INDEX = $8222;

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

GL_TEXTURE_INTENSITY_TYPE = $8C15;

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_LINES_ADJACENCY_ARB = $000A;

GL_LINE_STRIP_ADJACENCY_ARB = $000B;

GL_TRIANGLES_ADJACENCY_ARB = $000C;

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $000D;

GL_PROGRAM_POINT_SIZE_ARB = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

GL_GEOMETRY_SHADER_ARB = $8DD9;

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB = $9551;

GL_SPIR_V_BINARY_ARB = $9552;

GL_HALF_FLOAT = $140B;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_MAP_READ_BIT = $0001;

GL_MAP_WRITE_BIT = $0002;

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

GL_COMPRESSED_RG_RGTC2 = $8DBD;

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

GL_RG = $8227;

GL_RG_INTEGER = $8228;

GL_R8 = $8229;

GL_R16 = $822A;

GL_RG8 = $822B;

GL_RG16 = $822C;

GL_R16F = $822D;

GL_R32F = $822E;

GL_RG16F = $822F;

GL_RG32F = $8230;

GL_R8I = $8231;

GL_R8UI = $8232;

GL_R16I = $8233;

GL_R16UI = $8234;

GL_R32I = $8235;

GL_R32UI = $8236;

GL_RG8I = $8237;

GL_RG8UI = $8238;

GL_RG16I = $8239;

GL_RG16UI = $823A;

GL_RG32I = $823B;

GL_RG32UI = $823C;

GL_VERTEX_ARRAY_BINDING = $85B5;

GL_UNIFORM_BUFFER = $8A11;

GL_UNIFORM_BUFFER_BINDING = $8A28;

GL_UNIFORM_BUFFER_START = $8A29;

GL_UNIFORM_BUFFER_SIZE = $8A2A;

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

GL_UNIFORM_TYPE = $8A37;

GL_UNIFORM_SIZE = $8A38;

GL_UNIFORM_NAME_LENGTH = $8A39;

GL_UNIFORM_BLOCK_INDEX = $8A3A;

GL_UNIFORM_OFFSET = $8A3B;

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

GL_UNIFORM_BLOCK_BINDING = $8A3F;

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

GL_INVALID_INDEX = $FFFFFFFF;

GL_COPY_READ_BUFFER_BINDING = $8F36;

GL_COPY_READ_BUFFER = GL_COPY_READ_BUFFER_BINDING;

GL_COPY_WRITE_BUFFER_BINDING = $8F37;

GL_COPY_WRITE_BUFFER = GL_COPY_WRITE_BUFFER_BINDING;

GL_DEPTH_CLAMP = $864F;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_FIRST_VERTEX_CONVENTION = $8E4D;

GL_LAST_VERTEX_CONVENTION = $8E4E;

GL_PROVOKING_VERTEX = $8E4F;

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_OBJECT_TYPE = $9112;

GL_SYNC_CONDITION = $9113;

GL_SYNC_STATUS = $9114;

GL_SYNC_FLAGS = $9115;

GL_SYNC_FENCE = $9116;

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

GL_UNSIGNALED = $9118;

GL_SIGNALED = $9119;

GL_ALREADY_SIGNALED = $911A;

GL_TIMEOUT_EXPIRED = $911B;

GL_CONDITION_SATISFIED = $911C;

GL_WAIT_FAILED = $911D;

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

GL_SAMPLE_POSITION = $8E50;

GL_SAMPLE_MASK = $8E51;

GL_SAMPLE_MASK_VALUE = $8E52;

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

GL_TEXTURE_2D_MULTISAMPLE = $9100;

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

GL_TEXTURE_SAMPLES = $9106;

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

GL_SAMPLER_2D_MULTISAMPLE = $9108;

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

GL_MAX_INTEGER_SAMPLES = $9110;

GL_SAMPLE_SHADING_ARB = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB = $933D;

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB = $933E;

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB = $933F;

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB = $9340;

GL_SAMPLE_LOCATION_ARB = $8E50;

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB = $9341;

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB = $9342;

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB = $9343;

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

GL_SHADER_INCLUDE_ARB = $8DAE;

GL_NAMED_STRING_LENGTH_ARB = $8DE9;

GL_NAMED_STRING_TYPE_ARB = $8DEA;

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

GL_SRC1_COLOR = $88F9;

GL_ONE_MINUS_SRC1_COLOR = $88FA;

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_MAX_SHADER_COMPILER_THREADS_ARB = $91B0;

GL_COMPLETION_STATUS_ARB = $91B1;

GL_SAMPLER_BINDING = $8919;

GL_RGB10_A2UI = $906F;

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_TEXTURE_SWIZZLE_G = $8E43;

GL_TEXTURE_SWIZZLE_B = $8E44;

GL_TEXTURE_SWIZZLE_A = $8E45;

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

GL_TEXTURE_SPARSE_ARB = $91A6;

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB = $91A7;

GL_NUM_VIRTUAL_PAGE_SIZES_ARB = $91A8;

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB = $91A9;

GL_NUM_SPARSE_LEVELS_ARB = $91AA;

GL_VIRTUAL_PAGE_SIZE_X_ARB = $9195;

GL_VIRTUAL_PAGE_SIZE_Y_ARB = $9196;

GL_VIRTUAL_PAGE_SIZE_Z_ARB = $9197;

GL_MAX_SPARSE_TEXTURE_SIZE_ARB = $9198;

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB = $9199;

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB = $919A;

GL_MIN_SPARSE_LEVEL_ARB = $919B;

GL_TIME_ELAPSED = $88BF;

GL_TIMESTAMP = $8E28;

GL_INT_2_10_10_10_REV = $8D9F;

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

GL_DOUBLE_VEC2 = $8FFC;

GL_DOUBLE_VEC3 = $8FFD;

GL_DOUBLE_VEC4 = $8FFE;

GL_DOUBLE_MAT2 = $8F46;

GL_DOUBLE_MAT3 = $8F47;

GL_DOUBLE_MAT4 = $8F48;

GL_DOUBLE_MAT2x3 = $8F49;

GL_DOUBLE_MAT2x4 = $8F4A;

GL_DOUBLE_MAT3x2 = $8F4B;

GL_DOUBLE_MAT3x4 = $8F4C;

GL_DOUBLE_MAT4x2 = $8F4D;

GL_DOUBLE_MAT4x3 = $8F4E;

GL_INT64_ARB = $140E;

GL_INT64_VEC2_ARB = $8FE9;

GL_INT64_VEC3_ARB = $8FEA;

GL_INT64_VEC4_ARB = $8FEB;

GL_UNSIGNED_INT64_VEC2_ARB = $8FF5;

GL_UNSIGNED_INT64_VEC3_ARB = $8FF6;

GL_UNSIGNED_INT64_VEC4_ARB = $8FF7;

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

GL_MAX_SUBROUTINES = $8DE7;

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

GL_COMPATIBLE_SUBROUTINES = $8E4B;

GL_PATCHES = $000E;

GL_PATCH_VERTICES = $8E72;

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

GL_TESS_GEN_MODE = $8E76;

GL_TESS_GEN_SPACING = $8E77;

GL_TESS_GEN_VERTEX_ORDER = $8E78;

GL_TESS_GEN_POINT_MODE = $8E79;

GL_ISOLINES = $8E7A;

GL_FRACTIONAL_ODD = $8E7B;

GL_FRACTIONAL_EVEN = $8E7C;

GL_MAX_PATCH_VERTICES = $8E7D;

GL_MAX_TESS_GEN_LEVEL = $8E7E;

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

GL_TESS_EVALUATION_SHADER = $8E87;

GL_TESS_CONTROL_SHADER = $8E88;

GL_TRANSFORM_FEEDBACK = $8E22;

GL_TRANSFORM_FEEDBACK_PAUSED = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = GL_TRANSFORM_FEEDBACK_PAUSED;

GL_TRANSFORM_FEEDBACK_ACTIVE = $8E24;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = GL_TRANSFORM_FEEDBACK_ACTIVE;

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB = $82EC;

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB = $82ED;

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_MAX_VERTEX_STREAMS = $8E71;

GL_FIXED = $140C;

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

GL_LOW_FLOAT = $8DF0;

GL_MEDIUM_FLOAT = $8DF1;

GL_HIGH_FLOAT = $8DF2;

GL_LOW_INT = $8DF3;

GL_MEDIUM_INT = $8DF4;

GL_HIGH_INT = $8DF5;

GL_SHADER_COMPILER = $8DFA;

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

GL_MAX_VARYING_VECTORS = $8DFC;

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

GL_RGB565 = $8D62;

GL_PRIMITIVE_BOUNDING_BOX_ARB = $092BE;

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB = $09381;

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB = $09382;

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_PROGRAM_BINARY_LENGTH = $8741;

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

GL_PROGRAM_BINARY_FORMATS = $87FF;

GL_VERTEX_SHADER_BIT = $00000001;

GL_FRAGMENT_SHADER_BIT = $00000002;

GL_GEOMETRY_SHADER_BIT = $00000004;

GL_TESS_CONTROL_SHADER_BIT = $00000008;

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

GL_ALL_SHADER_BITS = $FFFFFFFF;

GL_PROGRAM_SEPARABLE = $8258;

GL_ACTIVE_PROGRAM = $8259;

GL_PROGRAM_PIPELINE_BINDING = $825A;

GL_MAX_VIEWPORTS = $825B;

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

GL_VIEWPORT_BOUNDS_RANGE = $825D;

GL_LAYER_PROVOKING_VERTEX = $825E;

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

GL_UNDEFINED_VERTEX = $8260;

GL_SYNC_CL_EVENT_ARB = $8240;

GL_SYNC_CL_EVENT_COMPLETE_ARB = $8241;

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

GL_DEBUG_SOURCE_API_ARB = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

GL_DEBUG_TYPE_ERROR_ARB = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

GL_DEBUG_TYPE_OTHER_ARB = $8251;

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GL_NO_RESET_NOTIFICATION_ARB = $8261;

GL_UNPACK_COMPRESSED_BLOCK_WIDTH = $09127;

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT = $09128;

GL_UNPACK_COMPRESSED_BLOCK_DEPTH = $09129;

GL_UNPACK_COMPRESSED_BLOCK_SIZE = $0912A;

GL_PACK_COMPRESSED_BLOCK_WIDTH = $0912B;

GL_PACK_COMPRESSED_BLOCK_HEIGHT = $0912C;

GL_PACK_COMPRESSED_BLOCK_DEPTH = $0912D;

GL_PACK_COMPRESSED_BLOCK_SIZE = $0912E;

GL_NUM_SAMPLE_COUNTS = $09380;

GL_MIN_MAP_BUFFER_ALIGNMENT = $090BC;

GL_ATOMIC_COUNTER_BUFFER = $92C0;

GL_ATOMIC_COUNTER_BUFFER_BINDING = $92C1;

GL_ATOMIC_COUNTER_BUFFER_START = $92C2;

GL_ATOMIC_COUNTER_BUFFER_SIZE = $92C3;

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE = $92C4;

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS = $92C5;

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES = $92C6;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER = $92C7;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER = $92C8;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER = $92C9;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER = $92CA;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER = $92CB;

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS = $92CC;

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS = $92CD;

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS = $92CE;

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS = $92CF;

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS = $92D0;

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS = $92D1;

GL_MAX_VERTEX_ATOMIC_COUNTERS = $92D2;

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS = $92D3;

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS = $92D4;

GL_MAX_GEOMETRY_ATOMIC_COUNTERS = $92D5;

GL_MAX_FRAGMENT_ATOMIC_COUNTERS = $92D6;

GL_MAX_COMBINED_ATOMIC_COUNTERS = $92D7;

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE = $92D8;

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS = $92DC;

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS = $92D9;

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX = $92DA;

GL_UNSIGNED_INT_ATOMIC_COUNTER = $92DB;

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT = $00000001;

GL_ELEMENT_ARRAY_BARRIER_BIT = $00000002;

GL_UNIFORM_BARRIER_BIT = $00000004;

GL_TEXTURE_FETCH_BARRIER_BIT = $00000008;

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT = $00000020;

GL_COMMAND_BARRIER_BIT = $00000040;

GL_PIXEL_BUFFER_BARRIER_BIT = $00000080;

GL_TEXTURE_UPDATE_BARRIER_BIT = $00000100;

GL_BUFFER_UPDATE_BARRIER_BIT = $00000200;

GL_FRAMEBUFFER_BARRIER_BIT = $00000400;

GL_TRANSFORM_FEEDBACK_BARRIER_BIT = $00000800;

GL_ATOMIC_COUNTER_BARRIER_BIT = $00001000;

GL_ALL_BARRIER_BITS = $FFFFFFFF;

GL_MAX_IMAGE_UNITS = $8F38;

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS = $8F39;

GL_IMAGE_BINDING_NAME = $8F3A;

GL_IMAGE_BINDING_LEVEL = $8F3B;

GL_IMAGE_BINDING_LAYERED = $8F3C;

GL_IMAGE_BINDING_LAYER = $8F3D;

GL_IMAGE_BINDING_ACCESS = $8F3E;

GL_IMAGE_1D = $904C;

GL_IMAGE_2D = $904D;

GL_IMAGE_3D = $904E;

GL_IMAGE_2D_RECT = $904F;

GL_IMAGE_CUBE = $9050;

GL_IMAGE_BUFFER = $9051;

GL_IMAGE_1D_ARRAY = $9052;

GL_IMAGE_2D_ARRAY = $9053;

GL_IMAGE_CUBE_MAP_ARRAY = $9054;

GL_IMAGE_2D_MULTISAMPLE = $9055;

GL_IMAGE_2D_MULTISAMPLE_ARRAY = $9056;

GL_INT_IMAGE_1D = $9057;

GL_INT_IMAGE_2D = $9058;

GL_INT_IMAGE_3D = $9059;

GL_INT_IMAGE_2D_RECT = $905A;

GL_INT_IMAGE_CUBE = $905B;

GL_INT_IMAGE_BUFFER = $905C;

GL_INT_IMAGE_1D_ARRAY = $905D;

GL_INT_IMAGE_2D_ARRAY = $905E;

GL_INT_IMAGE_CUBE_MAP_ARRAY = $905F;

GL_INT_IMAGE_2D_MULTISAMPLE = $9060;

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $9061;

GL_UNSIGNED_INT_IMAGE_1D = $9062;

GL_UNSIGNED_INT_IMAGE_2D = $9063;

GL_UNSIGNED_INT_IMAGE_3D = $9064;

GL_UNSIGNED_INT_IMAGE_2D_RECT = $9065;

GL_UNSIGNED_INT_IMAGE_CUBE = $9066;

GL_UNSIGNED_INT_IMAGE_BUFFER = $9067;

GL_UNSIGNED_INT_IMAGE_1D_ARRAY = $9068;

GL_UNSIGNED_INT_IMAGE_2D_ARRAY = $9069;

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY = $906A;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE = $906B;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $906C;

GL_MAX_IMAGE_SAMPLES = $906D;

GL_IMAGE_BINDING_FORMAT = $906E;

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE = $90C7;

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE = $90C8;

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS = $90C9;

GL_MAX_VERTEX_IMAGE_UNIFORMS = $90CA;

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS = $90CB;

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS = $90CC;

GL_MAX_GEOMETRY_IMAGE_UNIFORMS = $90CD;

GL_MAX_FRAGMENT_IMAGE_UNIFORMS = $90CE;

GL_MAX_COMBINED_IMAGE_UNIFORMS = $90CF;

GL_TEXTURE_IMMUTABLE_FORMAT = $912F;

GL_COMPRESSED_RGBA_ASTC_4x4_KHR = $93B0;

GL_COMPRESSED_RGBA_ASTC_5x4_KHR = $93B1;

GL_COMPRESSED_RGBA_ASTC_5x5_KHR = $93B2;

GL_COMPRESSED_RGBA_ASTC_6x5_KHR = $93B3;

GL_COMPRESSED_RGBA_ASTC_6x6_KHR = $93B4;

GL_COMPRESSED_RGBA_ASTC_8x5_KHR = $93B5;

GL_COMPRESSED_RGBA_ASTC_8x6_KHR = $93B6;

GL_COMPRESSED_RGBA_ASTC_8x8_KHR = $93B7;

GL_COMPRESSED_RGBA_ASTC_105_KHR = $93B8;

GL_COMPRESSED_RGBA_ASTC_106_KHR = $93B9;

GL_COMPRESSED_RGBA_ASTC_108_KHR = $93BA;

GL_COMPRESSED_RGBA_ASTC_110_KHR = $93BB;

GL_COMPRESSED_RGBA_ASTC_12x10_KHR = $93BC;

GL_COMPRESSED_RGBA_ASTC_12x12_KHR = $93BD;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR = $93D0;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR = $93D1;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR = $93D2;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR = $93D3;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR = $93D4;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR = $93D5;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR = $93D6;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR = $93D7;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR = $93D8;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR = $93D9;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR = $93DA;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR = $93DB;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR = $93DC;

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR = $93DD;

GL_DEBUG_OUTPUT_SYNCHRONOUS = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH = $8243;

GL_DEBUG_CALLBACK_FUNCTION = $8244;

GL_DEBUG_CALLBACK_USER_PARAM = $8245;

GL_DEBUG_SOURCE_API = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY = $8249;

GL_DEBUG_SOURCE_APPLICATION = $824A;

GL_DEBUG_SOURCE_OTHER = $824B;

GL_DEBUG_TYPE_ERROR = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR = $824E;

GL_DEBUG_TYPE_PORTABILITY = $824F;

GL_DEBUG_TYPE_PERFORMANCE = $8250;

GL_DEBUG_TYPE_OTHER = $8251;

GL_DEBUG_TYPE_MARKER = $8268;

GL_DEBUG_TYPE_PUSH_GROUP = $8269;

GL_DEBUG_TYPE_POP_GROUP = $826A;

GL_DEBUG_SEVERITY_NOTIFICATION = $826B;

GL_MAX_DEBUG_GROUP_STACK_DEPTH = $826C;

GL_DEBUG_GROUP_STACK_DEPTH = $826D;

GL_BUFFER = $82E0;

GL_SHADER = $82E1;

GL_PROGRAM = $82E2;

GL_QUERY = $82E3;

GL_PROGRAM_PIPELINE = $82E4;

GL_SAMPLER = $82E6;

GL_DISPLAY_LIST = $82E7;

GL_MAX_LABEL_LENGTH = $82E8;

GL_MAX_DEBUG_MESSAGE_LENGTH = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES = $9144;

GL_DEBUG_LOGGED_MESSAGES = $9145;

GL_DEBUG_SEVERITY_HIGH = $9146;

GL_DEBUG_SEVERITY_MEDIUM = $9147;

GL_DEBUG_SEVERITY_LOW = $9148;

GL_DEBUG_OUTPUT = $92E0;

GL_CONTEXT_FLAG_DEBUG_BIT = $00000002;

GL_COMPUTE_SHADER = $91B9;

GL_MAX_COMPUTE_UNIFORM_BLOCKS = $91BB;

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS = $91BC;

GL_MAX_COMPUTE_IMAGE_UNIFORMS = $91BD;

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE = $8262;

GL_MAX_COMPUTE_UNIFORM_COMPONENTS = $8263;

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS = $8264;

GL_MAX_COMPUTE_ATOMIC_COUNTERS = $8265;

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS = $8266;

GL_MAX_COMPUTE_LOCAL_INVOCATIONS = $90EB;

GL_MAX_COMPUTE_WORK_GROUP_COUNT = $91BE;

GL_MAX_COMPUTE_WORK_GROUP_SIZE = $91BF;

GL_COMPUTE_LOCAL_WORK_SIZE = $8267;

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER = $90EC;

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER = $90ED;

GL_DISPATCH_INDIRECT_BUFFER = $90EE;

GL_DISPATCH_INDIRECT_BUFFER_BINDING = $90EF;

GL_COMPUTE_SHADER_BIT = $00000020;

GL_COMPRESSED_RGB8_ETC2 = $9274;

GL_COMPRESSED_SRGB8_ETC2 = $9275;

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9276;

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9277;

GL_COMPRESSED_RGBA8_ETC2_EAC = $9278;

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC = $9279;

GL_COMPRESSED_R11_EAC = $9270;

GL_COMPRESSED_SIGNED_R11_EAC = $9271;

GL_COMPRESSED_RG11_EAC = $9272;

GL_COMPRESSED_SIGNED_RG11_EAC = $9273;

GL_PRIMITIVE_RESTART_FIXED_INDEX = $8D69;

GL_ANY_SAMPLES_PASSED_CONSERVATIVE = $8D6A;

GL_MAX_ELEMENT_INDEX = $8D6B;

GL_MAX_UNIFORM_LOCATIONS = $826E;

GL_FRAMEBUFFER_DEFAULT_WIDTH = $9310;

GL_FRAMEBUFFER_DEFAULT_HEIGHT = $9311;

GL_FRAMEBUFFER_DEFAULT_LAYERS = $9312;

GL_FRAMEBUFFER_DEFAULT_SAMPLES = $9313;

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS = $9314;

GL_MAX_FRAMEBUFFER_WIDTH = $9315;

GL_MAX_FRAMEBUFFER_HEIGHT = $9316;

GL_MAX_FRAMEBUFFER_LAYERS = $9317;

GL_MAX_FRAMEBUFFER_SAMPLES = $9318;

GL_INTERNALFORMAT_SUPPORTED = $826F;

GL_INTERNALFORMAT_PREFERRED = $8270;

GL_INTERNALFORMAT_RED_SIZE = $8271;

GL_INTERNALFORMAT_GREEN_SIZE = $8272;

GL_INTERNALFORMAT_BLUE_SIZE = $8273;

GL_INTERNALFORMAT_ALPHA_SIZE = $8274;

GL_INTERNALFORMAT_DEPTH_SIZE = $8275;

GL_INTERNALFORMAT_STENCIL_SIZE = $8276;

GL_INTERNALFORMAT_SHARED_SIZE = $8277;

GL_INTERNALFORMAT_RED_TYPE = $8278;

GL_INTERNALFORMAT_GREEN_TYPE = $8279;

GL_INTERNALFORMAT_BLUE_TYPE = $827A;

GL_INTERNALFORMAT_ALPHA_TYPE = $827B;

GL_INTERNALFORMAT_DEPTH_TYPE = $827C;

GL_INTERNALFORMAT_STENCIL_TYPE = $827D;

GL_MAX_WIDTH = $827E;

GL_MAX_HEIGHT = $827F;

GL_MAX_DEPTH = $8280;

GL_MAX_LAYERS = $8281;

GL_MAX_COMBINED_DIMENSIONS = $8282;

GL_COLOR_COMPONENTS = $8283;

GL_DEPTH_COMPONENTS = $8284;

GL_STENCIL_COMPONENTS = $8285;

GL_COLOR_RENDERABLE = $8286;

GL_DEPTH_RENDERABLE = $8287;

GL_STENCIL_RENDERABLE = $8288;

GL_FRAMEBUFFER_RENDERABLE = $8289;

GL_FRAMEBUFFER_RENDERABLE_LAYERED = $828A;

GL_FRAMEBUFFER_BLEND = $828B;

GL_READ_PIXELS = $828C;

GL_READ_PIXELS_FORMAT = $828D;

GL_READ_PIXELS_TYPE = $828E;

GL_TEXTURE_IMAGE_FORMAT = $828F;

GL_TEXTURE_IMAGE_TYPE = $8290;

GL_GET_TEXTURE_IMAGE_FORMAT = $8291;

GL_GET_TEXTURE_IMAGE_TYPE = $8292;

GL_MIPMAP = $8293;

GL_MANUAL_GENERATE_MIPMAP = $8294;

GL_AUTO_GENERATE_MIPMAP = $8295;

GL_COLOR_ENCODING = $8296;

GL_SRGB_READ = $8297;

GL_SRGB_WRITE = $8298;

GL_SRGB_DECODE_ARB = $8299;

GL_FILTER = $829A;

GL_VERTEX_TEXTURE = $829B;

GL_TESS_CONTROL_TEXTURE = $829C;

GL_TESS_EVALUATION_TEXTURE = $829D;

GL_GEOMETRY_TEXTURE = $829E;

GL_FRAGMENT_TEXTURE = $829F;

GL_COMPUTE_TEXTURE = $82A0;

GL_TEXTURE_SHADOW = $82A1;

GL_TEXTURE_GATHER = $82A2;

GL_TEXTURE_GATHER_SHADOW = $82A3;

GL_SHADER_IMAGE_LOAD = $82A4;

GL_SHADER_IMAGE_STORE = $82A5;

GL_SHADER_IMAGE_ATOMIC = $82A6;

GL_IMAGE_TEXEL_SIZE = $82A7;

GL_IMAGE_COMPATIBILITY_CLASS = $82A8;

GL_IMAGE_PIXEL_FORMAT = $82A9;

GL_IMAGE_PIXEL_TYPE = $82AA;

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST = $82AC;

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST = $82AD;

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE = $82AE;

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE = $82AF;

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH = $82B1;

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT = $82B2;

GL_TEXTURE_COMPRESSED_BLOCK_SIZE = $82B3;

GL_CLEAR_BUFFER = $82B4;

GL_TEXTURE_VIEW = $82B5;

GL_VIEW_COMPATIBILITY_CLASS = $82B6;

GL_FULL_SUPPORT = $82B7;

GL_CAVEAT_SUPPORT = $82B8;

GL_IMAGE_CLASS_4_X_32 = $82B9;

GL_IMAGE_CLASS_2_X_32 = $82BA;

GL_IMAGE_CLASS_1_X_32 = $82BB;

GL_IMAGE_CLASS_4_X_16 = $82BC;

GL_IMAGE_CLASS_2_X_16 = $82BD;

GL_IMAGE_CLASS_1_X_16 = $82BE;

GL_IMAGE_CLASS_4_X_8 = $82BF;

GL_IMAGE_CLASS_2_X_8 = $82C0;

GL_IMAGE_CLASS_1_X_8 = $82C1;

GL_IMAGE_CLASS_11_11_10 = $82C2;

GL_IMAGE_CLASS_10_10_10_2 = $82C3;

GL_VIEW_CLASS_128_BITS = $82C4;

GL_VIEW_CLASS_96_BITS = $82C5;

GL_VIEW_CLASS_64_BITS = $82C6;

GL_VIEW_CLASS_48_BITS = $82C7;

GL_VIEW_CLASS_32_BITS = $82C8;

GL_VIEW_CLASS_24_BITS = $82C9;

GL_VIEW_CLASS_16_BITS = $82CA;

GL_VIEW_CLASS_8_BITS = $82CB;

GL_VIEW_CLASS_S3TC_DXT1_RGB = $82CC;

GL_VIEW_CLASS_S3TC_DXT1_RGBA = $82CD;

GL_VIEW_CLASS_S3TC_DXT3_RGBA = $82CE;

GL_VIEW_CLASS_S3TC_DXT5_RGBA = $82CF;

GL_VIEW_CLASS_RGTC1_RED = $82D0;

GL_VIEW_CLASS_RGTC2_RG = $82D1;

GL_VIEW_CLASS_BPTC_UNORM = $82D2;

GL_VIEW_CLASS_BPTC_FLOAT = $82D3;

GL_UNIFORM = $92E1;

GL_UNIFORM_BLOCK = $92E2;

GL_PROGRAM_INPUT = $92E3;

GL_PROGRAM_OUTPUT = $92E4;

GL_BUFFER_VARIABLE = $92E5;

GL_SHADER_STORAGE_BLOCK = $92E6;

GL_VERTEX_SUBROUTINE = $92E8;

GL_TESS_CONTROL_SUBROUTINE = $92E9;

GL_TESS_EVALUATION_SUBROUTINE = $92EA;

GL_GEOMETRY_SUBROUTINE = $92EB;

GL_FRAGMENT_SUBROUTINE = $92EC;

GL_COMPUTE_SUBROUTINE = $92ED;

GL_VERTEX_SUBROUTINE_UNIFORM = $92EE;

GL_TESS_CONTROL_SUBROUTINE_UNIFORM = $92EF;

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM = $92F0;

GL_GEOMETRY_SUBROUTINE_UNIFORM = $92F1;

GL_FRAGMENT_SUBROUTINE_UNIFORM = $92F2;

GL_COMPUTE_SUBROUTINE_UNIFORM = $92F3;

GL_TRANSFORM_FEEDBACK_VARYING = $92F4;

GL_ACTIVE_RESOURCES = $92F5;

GL_MAX_NAME_LENGTH = $92F6;

GL_MAX_NUM_ACTIVE_VARIABLES = $92F7;

GL_MAX_NUM_COMPATIBLE_SUBROUTINES = $92F8;

GL_NAME_LENGTH = $92F9;

GL_TYPE = $92FA;

GL_ARRAY_SIZE = $92FB;

GL_OFFSET = $92FC;

GL_BLOCK_INDEX = $92FD;

GL_ARRAY_STRIDE = $92FE;

GL_MATRIX_STRIDE = $92FF;

GL_IS_ROW_MAJOR = $9300;

GL_ATOMIC_COUNTER_BUFFER_INDEX = $9301;

GL_BUFFER_BINDING = $9302;

GL_BUFFER_DATA_SIZE = $9303;

GL_NUM_ACTIVE_VARIABLES = $9304;

GL_ACTIVE_VARIABLES = $9305;

GL_REFERENCED_BY_VERTEX_SHADER = $9306;

GL_REFERENCED_BY_TESS_CONTROL_SHADER = $9307;

GL_REFERENCED_BY_TESS_EVALUATION_SHADER = $9308;

GL_REFERENCED_BY_GEOMETRY_SHADER = $9309;

GL_REFERENCED_BY_FRAGMENT_SHADER = $930A;

GL_REFERENCED_BY_COMPUTE_SHADER = $930B;

GL_TOP_LEVEL_ARRAY_SIZE = $930C;

GL_TOP_LEVEL_ARRAY_STRIDE = $930D;

GL_LOCATION = $930E;

GL_LOCATION_INDEX = $930F;

GL_IS_PER_PATCH = $92E7;

GL_SHADER_STORAGE_BUFFER = $90D2;

GL_SHADER_STORAGE_BUFFER_BINDING = $90D3;

GL_SHADER_STORAGE_BUFFER_START = $90D4;

GL_SHADER_STORAGE_BUFFER_SIZE = $90D5;

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS = $90D6;

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS = $90D7;

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS = $90D8;

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS = $90D9;

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS = $90DA;

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS = $90DB;

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS = $90DC;

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS = $90DD;

GL_MAX_SHADER_STORAGE_BLOCK_SIZE = $90DE;

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT = $90DF;

GL_SHADER_STORAGE_BARRIER_BIT = $2000;

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES = GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS;

GL_DEPTH_STENCIL_TEXTURE_MODE = $90EA;

GL_TEXTURE_BUFFER_OFFSET = $919D;

GL_TEXTURE_BUFFER_SIZE = $919E;

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT = $919F;

GL_TEXTURE_VIEW_MIN_LEVEL = $82DB;

GL_TEXTURE_VIEW_NUM_LEVELS = $82DC;

GL_TEXTURE_VIEW_MIN_LAYER = $82DD;

GL_TEXTURE_VIEW_NUM_LAYERS = $82DE;

GL_TEXTURE_IMMUTABLE_LEVELS = $82DF;

GL_VERTEX_ATTRIB_BINDING = $82D4;

GL_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D5;

GL_VERTEX_BINDING_DIVISOR = $82D6;

GL_VERTEX_BINDING_OFFSET = $82D7;

GL_VERTEX_BINDING_STRIDE = $82D8;

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D9;

GL_MAX_VERTEX_ATTRIB_BINDINGS = $82DA;

GL_MAX_VERTEX_ATTRIB_STRIDE = $82E5;

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED = $8221;

GL_TEXTURE_BUFFER_BINDING = $8C2A;

GL_MAP_PERSISTENT_BIT = $0040;

GL_MAP_COHERENT_BIT = $0080;

GL_DYNAMIC_STORAGE_BIT = $0100;

GL_CLIENT_STORAGE_BIT = $0200;

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT = $00004000;

GL_BUFFER_IMMUTABLE_STORAGE = $821F;

GL_BUFFER_STORAGE_FLAGS = $8220;

GL_CLEAR_TEXTURE = $9365;

GL_LOCATION_COMPONENT = $934A;

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX = $934B;

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE = $934C;

GL_QUERY_BUFFER = $9192;

GL_QUERY_BUFFER_BARRIER_BIT = $00008000;

GL_QUERY_BUFFER_BINDING = $9193;

GL_QUERY_RESULT_NO_WAIT = $9194;

GL_MIRROR_CLAMP_TO_EDGE = $8743;

GL_CONTEXT_LOST = $0507;

GL_NEGATIVE_ONE_TO_ONE = $935E;

GL_ZERO_TO_ONE = $935F;

GL_CLIP_ORIGIN = $935C;

GL_CLIP_DEPTH_MODE = $935D;

GL_QUERY_WAIT_INVERTED = $8E17;

GL_QUERY_NO_WAIT_INVERTED = $8E18;

GL_QUERY_BY_REGION_WAIT_INVERTED = $8E19;

GL_QUERY_BY_REGION_NO_WAIT_INVERTED = $8E1A;

GL_MAX_CULL_DISTANCES = $82F9;

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES = $82FA;

GL_TEXTURE_TARGET = $1006;

GL_QUERY_TARGET = $82EA;

GL_TEXTURE_BINDING = $82EB;

GL_GUILTY_CONTEXT_RESET = $8253;

GL_INNOCENT_CONTEXT_RESET = $8254;

GL_UNKNOWN_CONTEXT_RESET = $8255;

GL_RESET_NOTIFICATION_STRATEGY = $8256;

GL_LOSE_CONTEXT_ON_RESET = $8252;

GL_NO_RESET_NOTIFICATION = $8261;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT = $00000004;

GL_CONTEXT_RELEASE_BEHAVIOR = $82FB;

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH = $82FC;

GL_SHADER_BINARY_FORMAT_SPIR_V = $9551;

GL_SPIR_V_BINARY = $9552;

GL_PARAMETER_BUFFER = $80EE;

GL_PARAMETER_BUFFER_BINDING = $80EF;

GL_CONTEXT_FLAG_NO_ERROR_BIT = $00000008;

GL_VERTICES_SUBMITTED = $82EE;

GL_PRIMITIVES_SUBMITTED = $82EF;

GL_VERTEX_SHADER_INVOCATIONS = $82F0;

GL_TESS_CONTROL_SHADER_PATCHES = $82F1;

GL_TESS_EVALUATION_SHADER_INVOCATIONS = $82F2;

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED = $82F3;

GL_FRAGMENT_SHADER_INVOCATIONS = $82F4;

GL_COMPUTE_SHADER_INVOCATIONS = $82F5;

GL_CLIPPING_INPUT_PRIMITIVES = $82F6;

GL_CLIPPING_OUTPUT_PRIMITIVES = $82F7;

GL_POLYGON_OFFSET_CLAMP = $8E1B;

GL_SPIR_V_EXTENSIONS = $9553;

GL_NUM_SPIR_V_EXTENSIONS = $9554;

GL_TEXTURE_MAX_ANISOTROPY = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY = $84FF;

GL_TRANSFORM_FEEDBACK_OVERFLOW = $82EC;

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW = $82ED;

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_DRAW_BUFFER0_ATI = $8825;

GL_DRAW_BUFFER1_ATI = $8826;

GL_DRAW_BUFFER2_ATI = $8827;

GL_DRAW_BUFFER3_ATI = $8828;

GL_DRAW_BUFFER4_ATI = $8829;

GL_DRAW_BUFFER5_ATI = $882A;

GL_DRAW_BUFFER6_ATI = $882B;

GL_DRAW_BUFFER7_ATI = $882C;

GL_DRAW_BUFFER8_ATI = $882D;

GL_DRAW_BUFFER9_ATI = $882E;

GL_DRAW_BUFFER10_ATI = $882F;

GL_DRAW_BUFFER11_ATI = $8830;

GL_DRAW_BUFFER12_ATI = $8831;

GL_DRAW_BUFFER13_ATI = $8832;

GL_DRAW_BUFFER14_ATI = $8833;

GL_DRAW_BUFFER15_ATI = $8834;

GL_ELEMENT_ARRAY_ATI = $8768;

GL_ELEMENT_ARRAY_TYPE_ATI = $8769;

GL_ELEMENT_ARRAY_POINTER_ATI = $876A;

GL_BUMP_ROT_MATRIX_ATI = $8775;

GL_BUMP_ROT_MATRIX_SIZE_ATI = $8776;

GL_BUMP_NUM_TEX_UNITS_ATI = $8777;

GL_BUMP_TEX_UNITS_ATI = $8778;

GL_DUDV_ATI = $8779;

GL_DU8DV8_ATI = $877A;

GL_BUMP_ENVMAP_ATI = $877B;

GL_BUMP_TARGET_ATI = $877C;

GL_FRAGMENT_SHADER_ATI = $8920;

GL_REG_0_ATI = $8921;

GL_REG_1_ATI = $8922;

GL_REG_2_ATI = $8923;

GL_REG_3_ATI = $8924;

GL_REG_4_ATI = $8925;

GL_REG_5_ATI = $8926;

GL_REG_6_ATI = $8927;

GL_REG_7_ATI = $8928;

GL_REG_8_ATI = $8929;

GL_REG_9_ATI = $892A;

GL_REG_10_ATI = $892B;

GL_REG_11_ATI = $892C;

GL_REG_12_ATI = $892D;

GL_REG_13_ATI = $892E;

GL_REG_14_ATI = $892F;

GL_REG_15_ATI = $8930;

GL_REG_16_ATI = $8931;

GL_REG_17_ATI = $8932;

GL_REG_18_ATI = $8933;

GL_REG_19_ATI = $8934;

GL_REG_20_ATI = $8935;

GL_REG_21_ATI = $8936;

GL_REG_22_ATI = $8937;

GL_REG_23_ATI = $8938;

GL_REG_24_ATI = $8939;

GL_REG_25_ATI = $893A;

GL_REG_26_ATI = $893B;

GL_REG_27_ATI = $893C;

GL_REG_28_ATI = $893D;

GL_REG_29_ATI = $893E;

GL_REG_30_ATI = $893F;

GL_REG_31_ATI = $8940;

GL_CON_0_ATI = $8941;

GL_CON_1_ATI = $8942;

GL_CON_2_ATI = $8943;

GL_CON_3_ATI = $8944;

GL_CON_4_ATI = $8945;

GL_CON_5_ATI = $8946;

GL_CON_6_ATI = $8947;

GL_CON_7_ATI = $8948;

GL_CON_8_ATI = $8949;

GL_CON_9_ATI = $894A;

GL_CON_10_ATI = $894B;

GL_CON_11_ATI = $894C;

GL_CON_12_ATI = $894D;

GL_CON_13_ATI = $894E;

GL_CON_14_ATI = $894F;

GL_CON_15_ATI = $8950;

GL_CON_16_ATI = $8951;

GL_CON_17_ATI = $8952;

GL_CON_18_ATI = $8953;

GL_CON_19_ATI = $8954;

GL_CON_20_ATI = $8955;

GL_CON_21_ATI = $8956;

GL_CON_22_ATI = $8957;

GL_CON_23_ATI = $8958;

GL_CON_24_ATI = $8959;

GL_CON_25_ATI = $895A;

GL_CON_26_ATI = $895B;

GL_CON_27_ATI = $895C;

GL_CON_28_ATI = $895D;

GL_CON_29_ATI = $895E;

GL_CON_30_ATI = $895F;

GL_CON_31_ATI = $8960;

GL_MOV_ATI = $8961;

GL_ADD_ATI = $8963;

GL_MUL_ATI = $8964;

GL_SUB_ATI = $8965;

GL_DOT3_ATI = $8966;

GL_DOT4_ATI = $8967;

GL_MAD_ATI = $8968;

GL_LERP_ATI = $8969;

GL_CND_ATI = $896A;

GL_CND0_ATI = $896B;

GL_DOT2_ADD_ATI = $896C;

GL_SECONDARY_INTERPOLATOR_ATI = $896D;

GL_NUM_FRAGMENT_REGISTERS_ATI = $896E;

GL_NUM_FRAGMENT_CONSTANTS_ATI = $896F;

GL_NUM_PASSES_ATI = $8970;

GL_NUM_INSTRUCTIONS_PER_PASS_ATI = $8971;

GL_NUM_INSTRUCTIONS_TOTAL_ATI = $8972;

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI = $8973;

GL_NUM_LOOPBACK_COMPONENTS_ATI = $8974;

GL_COLOR_ALPHA_PAIRING_ATI = $8975;

GL_SWIZZLE_STR_ATI = $8976;

GL_SWIZZLE_STQ_ATI = $8977;

GL_SWIZZLE_STR_DR_ATI = $8978;

GL_SWIZZLE_STQ_DQ_ATI = $8979;

GL_SWIZZLE_STRQ_ATI = $897A;

GL_SWIZZLE_STRQ_DQ_ATI = $897B;

GL_RED_BIT_ATI = $00000001;

GL_GREEN_BIT_ATI = $00000002;

GL_BLUE_BIT_ATI = $00000004;

GL_2X_BIT_ATI = $00000001;

GL_4X_BIT_ATI = $00000002;

GL_8X_BIT_ATI = $00000004;

GL_HALF_BIT_ATI = $00000008;

GL_QUARTER_BIT_ATI = $00000010;

GL_EIGHTH_BIT_ATI = $00000020;

GL_SATURATE_BIT_ATI = $00000040;

GL_COMP_BIT_ATI = $00000002;

GL_NEGATE_BIT_ATI = $00000004;

GL_BIAS_BIT_ATI = $00000008;

GL_PN_TRIANGLES_ATI = $87F0;

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F1;

GL_PN_TRIANGLES_POINT_MODE_ATI = $87F2;

GL_PN_TRIANGLES_NORMAL_MODE_ATI = $87F3;

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F4;

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI = $87F5;

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI = $87F6;

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI = $87F7;

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI = $87F8;

GL_STENCIL_BACK_FUNC_ATI = $8800;

GL_STENCIL_BACK_FAIL_ATI = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI = $8803;

GL_TEXT_FRAGMENT_SHADER_ATI = $8200;

GL_MODULATE_ADD_ATI = $8744;

GL_MODULATE_SIGNED_ADD_ATI = $8745;

GL_MODULATE_SUBTRACT_ATI = $8746;

GL_RGBA_FLOAT32_ATI = $8814;

GL_RGB_FLOAT32_ATI = $8815;

GL_ALPHA_FLOAT32_ATI = $8816;

GL_INTENSITY_FLOAT32_ATI = $8817;

GL_LUMINANCE_FLOAT32_ATI = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

GL_RGBA_FLOAT16_ATI = $881A;

GL_RGB_FLOAT16_ATI = $881B;

GL_ALPHA_FLOAT16_ATI = $881C;

GL_INTENSITY_FLOAT16_ATI = $881D;

GL_LUMINANCE_FLOAT16_ATI = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

GL_MIRROR_CLAMP_ATI = $8742;

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

GL_STATIC_ATI = $8760;

GL_DYNAMIC_ATI = $8761;

GL_PRESERVE_ATI = $8762;

GL_DISCARD_ATI = $8763;

GL_OBJECT_BUFFER_SIZE_ATI = $8764;

GL_OBJECT_BUFFER_USAGE_ATI = $8765;

GL_ARRAY_OBJECT_BUFFER_ATI = $8766;

GL_ARRAY_OBJECT_OFFSET_ATI = $8767;

GL_MAX_VERTEX_STREAMS_ATI = $876B;

GL_VERTEX_STREAM0_ATI = $876C;

GL_VERTEX_STREAM1_ATI = $876D;

GL_VERTEX_STREAM2_ATI = $876E;

GL_VERTEX_STREAM3_ATI = $876F;

GL_VERTEX_STREAM4_ATI = $8770;

GL_VERTEX_STREAM5_ATI = $8771;

GL_VERTEX_STREAM6_ATI = $8772;

GL_VERTEX_STREAM7_ATI = $8773;

GL_VERTEX_SOURCE_ATI = $8774;

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

GL_COUNTER_TYPE_AMD = $8BC0;

GL_COUNTER_RANGE_AMD = $8BC1;

GL_UNSIGNED_INT64_AMD = $8BC2;

GL_PERCENTAGE_AMD = $8BC3;

GL_PERFMON_RESULT_AVAILABLE_AMD = $8BC4;

GL_PERFMON_RESULT_SIZE_AMD = $8BC5;

GL_PERFMON_RESULT_AMD = $8BC6;

GL_SAMPLER_BUFFER_AMD = $9001;

GL_INT_SAMPLER_BUFFER_AMD = $9002;

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

GL_TESSELLATION_MODE_AMD = $9004;

GL_TESSELLATION_FACTOR_AMD = $9005;

GL_DISCRETE_AMD = $9006;

GL_CONTINUOUS_AMD = $9007;

GL_DATA_BUFFER_AMD = $9151;

GL_PERFORMANCE_MONITOR_AMD = $9152;

GL_QUERY_OBJECT_AMD = $9153;

GL_VERTEX_ARRAY_OBJECT_AMD = $9154;

GL_SAMPLER_OBJECT_AMD = $9155;

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD = $9144;

GL_DEBUG_LOGGED_MESSAGES_AMD = $9145;

GL_DEBUG_SEVERITY_HIGH_AMD = $9146;

GL_DEBUG_SEVERITY_MEDIUM_AMD = $9147;

GL_DEBUG_SEVERITY_LOW_AMD = $9148;

GL_DEBUG_CATEGORY_API_ERROR_AMD = $9149;

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD = $914A;

GL_DEBUG_CATEGORY_DEPRECATION_AMD = $914B;

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD = $914C;

GL_DEBUG_CATEGORY_PERFORMANCE_AMD = $914D;

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD = $914E;

GL_DEBUG_CATEGORY_APPLICATION_AMD = $914F;

GL_DEBUG_CATEGORY_OTHER_AMD = $9150;

GL_DEPTH_CLAMP_NEAR_AMD = $901E;

GL_DEPTH_CLAMP_FAR_AMD = $901F;

GL_422_EXT = $80CC;

GL_422_REV_EXT = $80CD;

GL_422_AVERAGE_EXT = $80CE;

GL_422_REV_AVERAGE_EXT = $80CF;

GL_ABGR_EXT = $8000;

GL_BGR_EXT = $80E0;

GL_BGRA_EXT = $80E1;

GL_CONSTANT_COLOR_EXT = $8001;

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

GL_CONSTANT_ALPHA_EXT = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

GL_BLEND_COLOR_EXT = $8005;

GL_BLEND_DST_RGB_EXT = $80C8;

GL_BLEND_SRC_RGB_EXT = $80C9;

GL_BLEND_DST_ALPHA_EXT = $80CA;

GL_BLEND_SRC_ALPHA_EXT = $80CB;

GL_FUNC_ADD_EXT = $8006;

GL_MIN_EXT = $8007;

GL_MAX_EXT = $8008;

GL_BLEND_EQUATION_EXT = $8009;

GL_FUNC_SUBTRACT_EXT = $800A;

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_CMYK_EXT = $800C;

GL_CMYKA_EXT = $800D;

GL_PACK_CMYK_HINT_EXT = $800E;

GL_UNPACK_CMYK_HINT_EXT = $800F;

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

GL_CONVOLUTION_1D_EXT = $8010;

GL_CONVOLUTION_2D_EXT = $8011;

GL_SEPARABLE_2D_EXT = $8012;

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

GL_REDUCE_EXT = $8016;

GL_CONVOLUTION_FORMAT_EXT = $8017;

GL_CONVOLUTION_WIDTH_EXT = $8018;

GL_CONVOLUTION_HEIGHT_EXT = $8019;

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

GL_TANGENT_ARRAY_EXT = $8439;

GL_BINORMAL_ARRAY_EXT = $843A;

GL_CURRENT_TANGENT_EXT = $843B;

GL_CURRENT_BINORMAL_EXT = $843C;

GL_TANGENT_ARRAY_TYPE_EXT = $843E;

GL_TANGENT_ARRAY_STRIDE_EXT = $843F;

GL_BINORMAL_ARRAY_TYPE_EXT = $8440;

GL_BINORMAL_ARRAY_STRIDE_EXT = $8441;

GL_TANGENT_ARRAY_POINTER_EXT = $8442;

GL_BINORMAL_ARRAY_POINTER_EXT = $8443;

GL_MAP1_TANGENT_EXT = $8444;

GL_MAP2_TANGENT_EXT = $8445;

GL_MAP1_BINORMAL_EXT = $8446;

GL_MAP2_BINORMAL_EXT = $8447;

GL_CULL_VERTEX_EXT = $81AA;

GL_CULL_VERTEX_EYE_POSITION_EXT = $81AB;

GL_CULL_VERTEX_OBJECT_POSITION_EXT = $81AC;

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_FOG_COORDINATE_EXT = $8451;

GL_FRAGMENT_DEPTH_EXT = $8452;

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

GL_FRAMEBUFFER_EXT = $8D40;

GL_RENDERBUFFER_EXT = $8D41;

GL_STENCIL_INDEX_EXT = $8D45;

GL_STENCIL_INDEX1_EXT = $8D46;

GL_STENCIL_INDEX4_EXT = $8D47;

GL_STENCIL_INDEX8_EXT = $8D48;

GL_STENCIL_INDEX16_EXT = $8D49;

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

GL_COLOR_ATTACHMENT13_EXT = $8CED;

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

GL_DEPTH_ATTACHMENT_EXT = $8D00;

GL_STENCIL_ATTACHMENT_EXT = $8D20;

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

GL_FRAMEBUFFER_STATUS_ERROR_EXT = $8CDE;

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

GL_HISTOGRAM_EXT = $8024;

GL_PROXY_HISTOGRAM_EXT = $8025;

GL_HISTOGRAM_WIDTH_EXT = $8026;

GL_HISTOGRAM_FORMAT_EXT = $8027;

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

GL_HISTOGRAM_SINK_EXT = $802D;

GL_MINMAX_EXT = $802E;

GL_MINMAX_FORMAT_EXT = $802F;

GL_MINMAX_SINK_EXT = $8030;

GL_TABLE_TOO_LARGE_EXT = $8031;

GL_IUI_V2F_EXT = $81AD;

GL_IUI_V3F_EXT = $81AE;

GL_IUI_N3F_V2F_EXT = $81AF;

GL_IUI_N3F_V3F_EXT = $81B0;

GL_T2F_IUI_V2F_EXT = $81B1;

GL_T2F_IUI_V3F_EXT = $81B2;

GL_T2F_IUI_N3F_V2F_EXT = $81B3;

GL_T2F_IUI_N3F_V3F_EXT = $81B4;

GL_INDEX_TEST_EXT = $81B5;

GL_INDEX_TEST_FUNC_EXT = $81B6;

GL_INDEX_TEST_REF_EXT = $81B7;

GL_INDEX_MATERIAL_EXT = $81B8;

GL_INDEX_MATERIAL_PARAMETER_EXT = $81B9;

GL_INDEX_MATERIAL_FACE_EXT = $81BA;

GL_FRAGMENT_MATERIAL_EXT = $8349;

GL_FRAGMENT_NORMAL_EXT = $834A;

GL_FRAGMENT_COLOR_EXT = $834C;

GL_ATTENUATION_EXT = $834D;

GL_SHADOW_ATTENUATION_EXT = $834E;

GL_TEXTURE_APPLICATION_MODE_EXT = $834F;

GL_TEXTURE_LIGHT_EXT = $8350;

GL_TEXTURE_MATERIAL_FACE_EXT = $8351;

GL_TEXTURE_MATERIAL_PARAMETER_EXT = $8352;

GL_MULTISAMPLE_EXT = $809D;

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

GL_SAMPLE_MASK_EXT = $80A0;

GL_1PASS_EXT = $80A1;

GL_2PASS_0_EXT = $80A2;

GL_2PASS_1_EXT = $80A3;

GL_4PASS_0_EXT = $80A4;

GL_4PASS_1_EXT = $80A5;

GL_4PASS_2_EXT = $80A6;

GL_4PASS_3_EXT = $80A7;

GL_SAMPLE_BUFFERS_EXT = $80A8;

GL_SAMPLES_EXT = $80A9;

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

GL_SAMPLE_PATTERN_EXT = $80AC;

GL_MULTISAMPLE_BIT_EXT = $20000000;

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

GL_COLOR_INDEX1_EXT = $80E2;

GL_COLOR_INDEX2_EXT = $80E3;

GL_COLOR_INDEX4_EXT = $80E4;

GL_COLOR_INDEX8_EXT = $80E5;

GL_COLOR_INDEX12_EXT = $80E6;

GL_COLOR_INDEX16_EXT = $80E7;

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

GL_PIXEL_TRANSFORM_2D_EXT = $8330;

GL_PIXEL_MAG_FILTER_EXT = $8331;

GL_PIXEL_MIN_FILTER_EXT = $8332;

GL_PIXEL_CUBIC_WEIGHT_EXT = $8333;

GL_CUBIC_EXT = $8334;

GL_AVERAGE_EXT = $8335;

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8336;

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8337;

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT = $8338;

GL_POINT_SIZE_MIN_EXT = $8126;

GL_POINT_SIZE_MAX_EXT = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_EXT = $8128;

GL_DISTANCE_ATTENUATION_EXT = $8129;

GL_POLYGON_OFFSET_EXT = $8037;

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

GL_RESCALE_NORMAL_EXT = $803A;

GL_COLOR_SUM_EXT = $8458;

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_SINGLE_COLOR_EXT = $81F9;

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

GL_INCR_WRAP_EXT = $8507;

GL_DECR_WRAP_EXT = $8508;

GL_ALPHA4_EXT = $803B;

GL_ALPHA8_EXT = $803C;

GL_ALPHA12_EXT = $803D;

GL_ALPHA16_EXT = $803E;

GL_LUMINANCE4_EXT = $803F;

GL_LUMINANCE8_EXT = $8040;

GL_LUMINANCE12_EXT = $8041;

GL_LUMINANCE16_EXT = $8042;

GL_LUMINANCE4_ALPHA4_EXT = $8043;

GL_LUMINANCE6_ALPHA2_EXT = $8044;

GL_LUMINANCE8_ALPHA8_EXT = $8045;

GL_LUMINANCE12_ALPHA4_EXT = $8046;

GL_LUMINANCE12_ALPHA12_EXT = $8047;

GL_LUMINANCE16_ALPHA16_EXT = $8048;

GL_INTENSITY_EXT = $8049;

GL_INTENSITY4_EXT = $804A;

GL_INTENSITY8_EXT = $804B;

GL_INTENSITY12_EXT = $804C;

GL_INTENSITY16_EXT = $804D;

GL_RGB2_EXT = $804E;

GL_RGB4_EXT = $804F;

GL_RGB5_EXT = $8050;

GL_RGB8_EXT = $8051;

GL_RGB10_EXT = $8052;

GL_RGB12_EXT = $8053;

GL_RGB16_EXT = $8054;

GL_RGBA2_EXT = $8055;

GL_RGBA4_EXT = $8056;

GL_RGB5_A1_EXT = $8057;

GL_RGBA8_EXT = $8058;

GL_RGB10_A2_EXT = $8059;

GL_RGBA12_EXT = $805A;

GL_RGBA16_EXT = $805B;

GL_TEXTURE_RED_SIZE_EXT = $805C;

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

GL_REPLACE_EXT = $8062;

GL_PROXY_TEXTURE_1D_EXT = $8063;

GL_PROXY_TEXTURE_2D_EXT = $8064;

GL_TEXTURE_TOO_LARGE_EXT = $8065;

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

GL_TEXTURE_3D_EXT = $806F;

GL_PROXY_TEXTURE_3D_EXT = $8070;

GL_TEXTURE_DEPTH_EXT = $8071;

GL_TEXTURE_WRAP_R_EXT = $8072;

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

GL_NORMAL_MAP_EXT = $8511;

GL_REFLECTION_MAP_EXT = $8512;

GL_TEXTURE_CUBE_MAP_EXT = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

GL_CLAMP_TO_EDGE_EXT = $812F;

GL_COMBINE_EXT = $8570;

GL_COMBINE_RGB_EXT = $8571;

GL_COMBINE_ALPHA_EXT = $8572;

GL_RGB_SCALE_EXT = $8573;

GL_ADD_SIGNED_EXT = $8574;

GL_INTERPOLATE_EXT = $8575;

GL_CONSTANT_EXT = $8576;

GL_PRIMARY_COLOR_EXT = $8577;

GL_PREVIOUS_EXT = $8578;

GL_SOURCE0_RGB_EXT = $8580;

GL_SOURCE1_RGB_EXT = $8581;

GL_SOURCE2_RGB_EXT = $8582;

GL_SOURCE0_ALPHA_EXT = $8588;

GL_SOURCE1_ALPHA_EXT = $8589;

GL_SOURCE2_ALPHA_EXT = $858A;

GL_OPERAND0_RGB_EXT = $8590;

GL_OPERAND1_RGB_EXT = $8591;

GL_OPERAND2_RGB_EXT = $8592;

GL_OPERAND0_ALPHA_EXT = $8598;

GL_OPERAND1_ALPHA_EXT = $8599;

GL_OPERAND2_ALPHA_EXT = $859A;

GL_DOT3_RGB_EXT = $8740;

GL_DOT3_RGBA_EXT = $8741;

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

GL_TEXTURE_LOD_BIAS_EXT = $8501;

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_TEXTURE_RESIDENT_EXT = $8067;

GL_TEXTURE_1D_BINDING_EXT = $8068;

GL_TEXTURE_2D_BINDING_EXT = $8069;

GL_TEXTURE_3D_BINDING_EXT = $806A;

GL_PERTURB_EXT = $85AE;

GL_TEXTURE_NORMAL_EXT = $85AF;

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

GL_VERTEX_ARRAY_EXT = $8074;

GL_NORMAL_ARRAY_EXT = $8075;

GL_COLOR_ARRAY_EXT = $8076;

GL_INDEX_ARRAY_EXT = $8077;

GL_TEXTURE_COORD_ARRAY_EXT = $8078;

GL_EDGE_FLAG_ARRAY_EXT = $8079;

GL_VERTEX_ARRAY_SIZE_EXT = $807A;

GL_VERTEX_ARRAY_TYPE_EXT = $807B;

GL_VERTEX_ARRAY_STRIDE_EXT = $807C;

GL_VERTEX_ARRAY_COUNT_EXT = $807D;

GL_NORMAL_ARRAY_TYPE_EXT = $807E;

GL_NORMAL_ARRAY_STRIDE_EXT = $807F;

GL_NORMAL_ARRAY_COUNT_EXT = $8080;

GL_COLOR_ARRAY_SIZE_EXT = $8081;

GL_COLOR_ARRAY_TYPE_EXT = $8082;

GL_COLOR_ARRAY_STRIDE_EXT = $8083;

GL_COLOR_ARRAY_COUNT_EXT = $8084;

GL_INDEX_ARRAY_TYPE_EXT = $8085;

GL_INDEX_ARRAY_STRIDE_EXT = $8086;

GL_INDEX_ARRAY_COUNT_EXT = $8087;

GL_TEXTURE_COORD_ARRAY_SIZE_EXT = $8088;

GL_TEXTURE_COORD_ARRAY_TYPE_EXT = $8089;

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT = $808A;

GL_TEXTURE_COORD_ARRAY_COUNT_EXT = $808B;

GL_EDGE_FLAG_ARRAY_STRIDE_EXT = $808C;

GL_EDGE_FLAG_ARRAY_COUNT_EXT = $808D;

GL_VERTEX_ARRAY_POINTER_EXT = $808E;

GL_NORMAL_ARRAY_POINTER_EXT = $808F;

GL_COLOR_ARRAY_POINTER_EXT = $8090;

GL_INDEX_ARRAY_POINTER_EXT = $8091;

GL_TEXTURE_COORD_ARRAY_POINTER_EXT = $8092;

GL_EDGE_FLAG_ARRAY_POINTER_EXT = $8093;

GL_VERTEX_SHADER_EXT = $8780;

GL_VERTEX_SHADER_BINDING_EXT = $8781;

GL_OP_INDEX_EXT = $8782;

GL_OP_NEGATE_EXT = $8783;

GL_OP_DOT3_EXT = $8784;

GL_OP_DOT4_EXT = $8785;

GL_OP_MUL_EXT = $8786;

GL_OP_ADD_EXT = $8787;

GL_OP_MADD_EXT = $8788;

GL_OP_FRAC_EXT = $8789;

GL_OP_MAX_EXT = $878A;

GL_OP_MIN_EXT = $878B;

GL_OP_SET_GE_EXT = $878C;

GL_OP_SET_LT_EXT = $878D;

GL_OP_CLAMP_EXT = $878E;

GL_OP_FLOOR_EXT = $878F;

GL_OP_ROUND_EXT = $8790;

GL_OP_EXP_BASE_2_EXT = $8791;

GL_OP_LOG_BASE_2_EXT = $8792;

GL_OP_POWER_EXT = $8793;

GL_OP_RECIP_EXT = $8794;

GL_OP_RECIP_SQRT_EXT = $8795;

GL_OP_SUB_EXT = $8796;

GL_OP_CROSS_PRODUCT_EXT = $8797;

GL_OP_MULTIPLY_MATRIX_EXT = $8798;

GL_OP_MOV_EXT = $8799;

GL_OUTPUT_VERTEX_EXT = $879A;

GL_OUTPUT_COLOR0_EXT = $879B;

GL_OUTPUT_COLOR1_EXT = $879C;

GL_OUTPUT_TEXTURE_COORD0_EXT = $879D;

GL_OUTPUT_TEXTURE_COORD1_EXT = $879E;

GL_OUTPUT_TEXTURE_COORD2_EXT = $879F;

GL_OUTPUT_TEXTURE_COORD3_EXT = $87A0;

GL_OUTPUT_TEXTURE_COORD4_EXT = $87A1;

GL_OUTPUT_TEXTURE_COORD5_EXT = $87A2;

GL_OUTPUT_TEXTURE_COORD6_EXT = $87A3;

GL_OUTPUT_TEXTURE_COORD7_EXT = $87A4;

GL_OUTPUT_TEXTURE_COORD8_EXT = $87A5;

GL_OUTPUT_TEXTURE_COORD9_EXT = $87A6;

GL_OUTPUT_TEXTURE_COORD10_EXT = $87A7;

GL_OUTPUT_TEXTURE_COORD11_EXT = $87A8;

GL_OUTPUT_TEXTURE_COORD12_EXT = $87A9;

GL_OUTPUT_TEXTURE_COORD13_EXT = $87AA;

GL_OUTPUT_TEXTURE_COORD14_EXT = $87AB;

GL_OUTPUT_TEXTURE_COORD15_EXT = $87AC;

GL_OUTPUT_TEXTURE_COORD16_EXT = $87AD;

GL_OUTPUT_TEXTURE_COORD17_EXT = $87AE;

GL_OUTPUT_TEXTURE_COORD18_EXT = $87AF;

GL_OUTPUT_TEXTURE_COORD19_EXT = $87B0;

GL_OUTPUT_TEXTURE_COORD20_EXT = $87B1;

GL_OUTPUT_TEXTURE_COORD21_EXT = $87B2;

GL_OUTPUT_TEXTURE_COORD22_EXT = $87B3;

GL_OUTPUT_TEXTURE_COORD23_EXT = $87B4;

GL_OUTPUT_TEXTURE_COORD24_EXT = $87B5;

GL_OUTPUT_TEXTURE_COORD25_EXT = $87B6;

GL_OUTPUT_TEXTURE_COORD26_EXT = $87B7;

GL_OUTPUT_TEXTURE_COORD27_EXT = $87B8;

GL_OUTPUT_TEXTURE_COORD28_EXT = $87B9;

GL_OUTPUT_TEXTURE_COORD29_EXT = $87BA;

GL_OUTPUT_TEXTURE_COORD30_EXT = $87BB;

GL_OUTPUT_TEXTURE_COORD31_EXT = $87BC;

GL_OUTPUT_FOG_EXT = $87BD;

GL_SCALAR_EXT = $87BE;

GL_VECTOR_EXT = $87BF;

GL_MATRIX_EXT = $87C0;

GL_VARIANT_EXT = $87C1;

GL_INVARIANT_EXT = $87C2;

GL_LOCAL_CONSTANT_EXT = $87C3;

GL_LOCAL_EXT = $87C4;

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT = $87C5;

GL_MAX_VERTEX_SHADER_VARIANTS_EXT = $87C6;

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT = $87C7;

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87C8;

GL_MAX_VERTEX_SHADER_LOCALS_EXT = $87C9;

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CA;

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT = $87CB;

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87CC;

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT = $87CD;

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT = $87CE;

GL_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CF;

GL_VERTEX_SHADER_VARIANTS_EXT = $87D0;

GL_VERTEX_SHADER_INVARIANTS_EXT = $87D1;

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87D2;

GL_VERTEX_SHADER_LOCALS_EXT = $87D3;

GL_VERTEX_SHADER_OPTIMIZED_EXT = $87D4;

GL_X_EXT = $87D5;

GL_Y_EXT = $87D6;

GL_Z_EXT = $87D7;

GL_W_EXT = $87D8;

GL_NEGATIVE_X_EXT = $87D9;

GL_NEGATIVE_Y_EXT = $87DA;

GL_NEGATIVE_Z_EXT = $87DB;

GL_NEGATIVE_W_EXT = $87DC;

GL_ZERO_EXT = $87DD;

GL_ONE_EXT = $87DE;

GL_NEGATIVE_ONE_EXT = $87DF;

GL_NORMALIZED_RANGE_EXT = $87E0;

GL_FULL_RANGE_EXT = $87E1;

GL_CURRENT_VERTEX_EXT = $87E2;

GL_MVP_MATRIX_EXT = $87E3;

GL_VARIANT_VALUE_EXT = $87E4;

GL_VARIANT_DATATYPE_EXT = $87E5;

GL_VARIANT_ARRAY_STRIDE_EXT = $87E6;

GL_VARIANT_ARRAY_TYPE_EXT = $87E7;

GL_VARIANT_ARRAY_EXT = $87E8;

GL_VARIANT_ARRAY_POINTER_EXT = $87E9;

GL_INVARIANT_VALUE_EXT = $87EA;

GL_INVARIANT_DATATYPE_EXT = $87EB;

GL_LOCAL_CONSTANT_VALUE_EXT = $87EC;

GL_LOCAL_CONSTANT_DATATYPE_EXT = $87ED;

GL_MODELVIEW0_STACK_DEPTH_EXT = $0BA3;

GL_MODELVIEW1_STACK_DEPTH_EXT = $8502;

GL_MODELVIEW0_MATRIX_EXT = $0BA6;

GL_MODELVIEW1_MATRIX_EXT = $8506;

GL_VERTEX_WEIGHTING_EXT = $8509;

GL_MODELVIEW0_EXT = $1700;

GL_MODELVIEW1_EXT = $850A;

GL_CURRENT_VERTEX_WEIGHT_EXT = $850B;

GL_VERTEX_WEIGHT_ARRAY_EXT = $850C;

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT = $850D;

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT = $850E;

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT = $850F;

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT = $8510;

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_DEPTH_BOUNDS_EXT = $8891;

GL_MIRROR_CLAMP_EXT = $8742;

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

GL_DEPTH_STENCIL_EXT = $84F9;

GL_UNSIGNED_INT_24_8_EXT = $84FA;

GL_DEPTH24_STENCIL8_EXT = $88F0;

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

GL_SRGB_EXT = $8C40;

GL_SRGB8_EXT = $8C41;

GL_SRGB_ALPHA_EXT = $8C42;

GL_SRGB8_ALPHA8_EXT = $8C43;

GL_SLUMINANCE_ALPHA_EXT = $8C44;

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

GL_SLUMINANCE_EXT = $8C46;

GL_SLUMINANCE8_EXT = $8C47;

GL_COMPRESSED_SRGB_EXT = $8C48;

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

GL_READ_FRAMEBUFFER_BINDING_EXT = GL_FRAMEBUFFER_BINDING_EXT;

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CAA;

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

GL_MAX_SAMPLES_EXT = $8D57;

GL_TIME_ELAPSED_EXT = $88BF;

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

GL_UNIFORM_BUFFER_EXT = $8DEE;

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

GL_LINES_ADJACENCY_EXT = $A;

GL_LINE_STRIP_ADJACENCY_EXT = $B;

GL_TRIANGLES_ADJACENCY_EXT = $C;

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

GL_PROGRAM_POINT_SIZE_EXT = $8642;

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

GL_SAMPLER_BUFFER_EXT = $8DC2;

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

GL_INT_SAMPLER_1D_EXT = $8DC9;

GL_INT_SAMPLER_2D_EXT = $8DCA;

GL_INT_SAMPLER_3D_EXT = $8DCB;

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_RGBA32UI_EXT = $8D70;

GL_RGB32UI_EXT = $8D71;

GL_ALPHA32UI_EXT = $8D72;

GL_INTENSITY32UI_EXT = $8D73;

GL_LUMINANCE32UI_EXT = $8D74;

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

GL_RGBA16UI_EXT = $8D76;

GL_RGB16UI_EXT = $8D77;

GL_ALPHA16UI_EXT = $8D78;

GL_INTENSITY16UI_EXT = $8D79;

GL_LUMINANCE16UI_EXT = $8D7A;

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

GL_RGBA8UI_EXT = $8D7C;

GL_RGB8UI_EXT = $8D7D;

GL_ALPHA8UI_EXT = $8D7E;

GL_INTENSITY8UI_EXT = $8D7F;

GL_LUMINANCE8UI_EXT = $8D80;

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

GL_RGBA32I_EXT = $8D82;

GL_RGB32I_EXT = $8D83;

GL_ALPHA32I_EXT = $8D84;

GL_INTENSITY32I_EXT = $8D85;

GL_LUMINANCE32I_EXT = $8D86;

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

GL_RGBA16I_EXT = $8D88;

GL_RGB16I_EXT = $8D89;

GL_ALPHA16I_EXT = $8D8A;

GL_INTENSITY16I_EXT = $8D8B;

GL_LUMINANCE16I_EXT = $8D8C;

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

GL_RGBA8I_EXT = $8D8E;

GL_RGB8I_EXT = $8D8F;

GL_ALPHA8I_EXT = $8D90;

GL_INTENSITY8I_EXT = $8D91;

GL_LUMINANCE8I_EXT = $8D92;

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

GL_RED_INTEGER_EXT = $8D94;

GL_GREEN_INTEGER_EXT = $8D95;

GL_BLUE_INTEGER_EXT = $8D96;

GL_ALPHA_INTEGER_EXT = $8D97;

GL_RGB_INTEGER_EXT = $8D98;

GL_RGBA_INTEGER_EXT = $8D99;

GL_BGR_INTEGER_EXT = $8D9A;

GL_BGRA_INTEGER_EXT = $8D9B;

GL_LUMINANCE_INTEGER_EXT = $8D9C;

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

GL_RGB9_E5_EXT = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

GL_PRIMITIVES_GENERATED_EXT = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

GL_RASTERIZER_DISCARD_EXT = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

GL_PROGRAM_MATRIX_EXT = $8E2D;

GL_TRANSPOSE_PROGRAM_MATRIX_EXT = $8E2E;

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT = $8E2F;

GL_TEXTURE_SWIZZLE_R_EXT = $8E42;

GL_TEXTURE_SWIZZLE_G_EXT = $8E43;

GL_TEXTURE_SWIZZLE_B_EXT = $8E44;

GL_TEXTURE_SWIZZLE_A_EXT = $8E45;

GL_TEXTURE_SWIZZLE_RGBA_EXT = $8E46;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT = $8E4C;

GL_FIRST_VERTEX_CONVENTION_EXT = $8E4D;

GL_LAST_VERTEX_CONVENTION_EXT = $8E4E;

GL_PROVOKING_VERTEX_EXT = $8E4F;

GL_ALPHA_SNORM = $9010;

GL_LUMINANCE_SNORM = $9011;

GL_LUMINANCE_ALPHA_SNORM = $9012;

GL_INTENSITY_SNORM = $9013;

GL_ALPHA8_SNORM = $9014;

GL_LUMINANCE8_SNORM = $9015;

GL_LUMINANCE8_ALPHA8_SNORM = $9016;

GL_INTENSITY8_SNORM = $9017;

GL_ALPHA16_SNORM = $9018;

GL_LUMINANCE16_SNORM = $9019;

GL_LUMINANCE16_ALPHA16_SNORM = $901A;

GL_INTENSITY16_SNORM = $901B;

GL_ACTIVE_PROGRAM_EXT = $8B8D;

GL_MAX_IMAGE_UNITS_EXT = $8F38;

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT = $8F39;

GL_IMAGE_BINDING_NAME_EXT = $8F3A;

GL_IMAGE_BINDING_LEVEL_EXT = $8F3B;

GL_IMAGE_BINDING_LAYERED_EXT = $8F3C;

GL_IMAGE_BINDING_LAYER_EXT = $8F3D;

GL_IMAGE_BINDING_ACCESS_EXT = $8F3E;

GL_IMAGE_1D_EXT = $904C;

GL_IMAGE_2D_EXT = $904D;

GL_IMAGE_3D_EXT = $904E;

GL_IMAGE_2D_RECT_EXT = $904F;

GL_IMAGE_CUBE_EXT = $9050;

GL_IMAGE_BUFFER_EXT = $9051;

GL_IMAGE_1D_ARRAY_EXT = $9052;

GL_IMAGE_2D_ARRAY_EXT = $9053;

GL_IMAGE_CUBE_MAP_ARRAY_EXT = $9054;

GL_IMAGE_2D_MULTISAMPLE_EXT = $9055;

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9056;

GL_INT_IMAGE_1D_EXT = $9057;

GL_INT_IMAGE_2D_EXT = $9058;

GL_INT_IMAGE_3D_EXT = $9059;

GL_INT_IMAGE_2D_RECT_EXT = $905A;

GL_INT_IMAGE_CUBE_EXT = $905B;

GL_INT_IMAGE_BUFFER_EXT = $905C;

GL_INT_IMAGE_1D_ARRAY_EXT = $905D;

GL_INT_IMAGE_2D_ARRAY_EXT = $905E;

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $905F;

GL_INT_IMAGE_2D_MULTISAMPLE_EXT = $9060;

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9061;

GL_UNSIGNED_INT_IMAGE_1D_EXT = $9062;

GL_UNSIGNED_INT_IMAGE_2D_EXT = $9063;

GL_UNSIGNED_INT_IMAGE_3D_EXT = $9064;

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT = $9065;

GL_UNSIGNED_INT_IMAGE_CUBE_EXT = $9066;

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT = $9067;

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT = $9068;

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT = $9069;

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $906A;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT = $906B;

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $906C;

GL_MAX_IMAGE_SAMPLES_EXT = $906D;

GL_IMAGE_BINDING_FORMAT_EXT = $906E;

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT = $00000001;

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT = $00000002;

GL_UNIFORM_BARRIER_BIT_EXT = $00000004;

GL_TEXTURE_FETCH_BARRIER_BIT_EXT = $00000008;

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT = $00000020;

GL_COMMAND_BARRIER_BIT_EXT = $00000040;

GL_PIXEL_BUFFER_BARRIER_BIT_EXT = $00000080;

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT = $00000100;

GL_BUFFER_UPDATE_BARRIER_BIT_EXT = $00000200;

GL_FRAMEBUFFER_BARRIER_BIT_EXT = $00000400;

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT = $00000800;

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT = $00001000;

GL_ALL_BARRIER_BITS_EXT = $FFFFFFFF;

GL_DOUBLE_VEC2_EXT = $8FFC;

GL_DOUBLE_VEC3_EXT = $8FFD;

GL_DOUBLE_VEC4_EXT = $8FFE;

GL_DOUBLE_MAT2_EXT = $8F46;

GL_DOUBLE_MAT3_EXT = $8F47;

GL_DOUBLE_MAT4_EXT = $8F48;

GL_DOUBLE_MAT2x3_EXT = $8F49;

GL_DOUBLE_MAT2x4_EXT = $8F4A;

GL_DOUBLE_MAT3x2_EXT = $8F4B;

GL_DOUBLE_MAT3x4_EXT = $8F4C;

GL_DOUBLE_MAT4x2_EXT = $8F4D;

GL_DOUBLE_MAT4x3_EXT = $8F4E;

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_DECODE_EXT = $8A49;

GL_SKIP_DECODE_EXT = $8A4A;

GL_TEXTURE_COVERAGE_SAMPLES_NV = $9045;

GL_TEXTURE_COLOR_SAMPLES_NV = $9046;

GL_FACTOR_MIN_AMD = $901C;

GL_FACTOR_MAX_AMD = $901D;

GL_SUBSAMPLE_DISTANCE_AMD = $883F;

GL_SYNC_X11_FENCE_EXT = $90E1;

GL_SCALED_RESOLVE_FASTEST_EXT = $90BA;

GL_SCALED_RESOLVE_NICEST_EXT = $90BB;

GL_PATH_FORMAT_SVG_NV = $9070;

GL_PATH_FORMAT_PS_NV = $9071;

GL_STANDARD_FONT_NAME_NV = $9072;

GL_SYSTEM_FONT_NAME_NV = $9073;

GL_FILE_NAME_NV = $9074;

GL_PATH_STROKE_WIDTH_NV = $9075;

GL_PATH_END_CAPS_NV = $9076;

GL_PATH_INITIAL_END_CAP_NV = $9077;

GL_PATH_TERMINAL_END_CAP_NV = $9078;

GL_PATH_JOIN_STYLE_NV = $9079;

GL_PATH_MITER_LIMIT_NV = $907A;

GL_PATH_DASH_CAPS_NV = $907B;

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

GL_PATH_DASH_OFFSET_NV = $907E;

GL_PATH_CLIENT_LENGTH_NV = $907F;

GL_PATH_FILL_MODE_NV = $9080;

GL_PATH_FILL_MASK_NV = $9081;

GL_PATH_FILL_COVER_MODE_NV = $9082;

GL_PATH_STROKE_COVER_MODE_NV = $9083;

GL_PATH_STROKE_MASK_NV = $9084;

GL_PATH_SAMPLE_QUALITY_NV = $9085;

GL_PATH_STROKE_BOUND_NV = $9086;

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV= $9087;

GL_COUNT_UP_NV = $9088;

GL_COUNT_DOWN_NV = $9089;

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

GL_CONVEX_HULL_NV = $908B;

GL_MULTI_HULLS_NV = $908C;

GL_BOUNDING_BOX_NV = $908D;

GL_TRANSLATE_X_NV = $908E;

GL_TRANSLATE_Y_NV = $908F;

GL_TRANSLATE_2D_NV = $9090;

GL_TRANSLATE_3D_NV = $9091;

GL_AFFINE_2D_NV = $9092;

GL_PROJECTIVE_2D_NV = $9093;

GL_AFFINE_3D_NV = $9094;

GL_PROJECTIVE_3D_NV = $9095;

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

GL_TRANSPOSE_PROJECTIVE_2D_NV = $9097;

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

GL_TRANSPOSE_PROJECTIVE_3D_NV = $9099;

GL_UTF8_NV = $909A;

GL_UTF16_NV = $909B;

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV= $909C;

GL_PATH_COMMAND_COUNT_NV = $909D;

GL_PATH_COORD_COUNT_NV = $909E;

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

GL_SQUARE_NV = $90A3;

GL_ROUND_NV = $90A4;

GL_TRIANGULAR_NV = $90A5;

GL_BEVEL_NV = $90A6;

GL_MITER_REVERT_NV = $90A7;

GL_MITER_TRUNCATE_NV = $90A8;

GL_SKIP_MISSING_GLYPH_NV = $90A9;

GL_USE_MISSING_GLYPH_NV = $90AA;

GL_PATH_ERROR_POSITION_NV = $90AB;

GL_PATH_FOG_GEN_MODE_NV = $90AC;

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

GL_ADJACENT_PAIRS_NV = $90AE;

GL_FIRST_TO_REST_NV = $90AF;

GL_PATH_GEN_MODE_NV = $90B0;

GL_PATH_GEN_COEFF_NV = $90B1;

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

GL_PATH_GEN_COMPONENTS_NV = $90B3;

GL_PATH_STENCIL_FUNC_NV = $90B7;

GL_PATH_STENCIL_REF_NV = $90B8;

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV= $90BD;

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV= $90BE;

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

GL_MOVE_TO_RESETS_NV = $90B5;

GL_MOVE_TO_CONTINUES_NV = $90B6;

GL_CLOSE_PATH_NV = $00;

GL_MOVE_TO_NV = $02;

GL_RELATIVE_MOVE_TO_NV = $03;

GL_LINE_TO_NV = $04;

GL_RELATIVE_LINE_TO_NV = $05;

GL_HORIZONTAL_LINE_TO_NV = $06;

GL_RELATIVE_HORIZONTAL_LINE_TO_NV= $07;

GL_VERTICAL_LINE_TO_NV = $08;

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

GL_QUADRATIC_CURVE_TO_NV = $0A;

GL_RELATIVE_QUADRATIC_CURVE_TO_NV= $0B;

GL_CUBIC_CURVE_TO_NV = $0C;

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV= $0F;

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV= $11;

GL_SMALL_CCW_ARC_TO_NV = $12;

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

GL_SMALL_CW_ARC_TO_NV = $14;

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

GL_LARGE_CCW_ARC_TO_NV = $16;

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

GL_LARGE_CW_ARC_TO_NV = $18;

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

GL_RESTART_PATH_NV = $F0;

GL_DUP_FIRST_CUBIC_CURVE_TO_NV = $F2;

GL_DUP_LAST_CUBIC_CURVE_TO_NV = $F4;

GL_RECT_NV = $F6;

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

GL_ARC_TO_NV = $FE;

GL_RELATIVE_ARC_TO_NV = $FF;

GL_BOLD_BIT_NV = $01;

GL_ITALIC_BIT_NV = $02;

GL_GLYPH_WIDTH_BIT_NV = $01;

GL_GLYPH_HEIGHT_BIT_NV = $02;

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV= $04;

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV= $08;

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV= $10;

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV= $20;

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV= $40;

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV= $80;

GL_GLYPH_HAS_KERNING_NV = $100;

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

GL_FONT_UNITS_PER_EM_NV = $00100000;

GL_FONT_ASCENDER_NV = $00200000;

GL_FONT_DESCENDER_NV = $00400000;

GL_FONT_HEIGHT_NV = $00800000;

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

GL_FONT_HAS_KERNING_NV = $10000000;

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD= $9160;

GL_SET_AMD = $874A;

GL_REPLACE_VALUE_AMD = $874B;

GL_STENCIL_OP_VALUE_AMD = $874C;

GL_STENCIL_BACK_OP_VALUE_AMD = $874D;

GL_QUERY_BUFFER_AMD = $9192;

GL_QUERY_BUFFER_BINDING_AMD = $9193;

GL_QUERY_RESULT_NO_WAIT_AMD = $9194;

GL_TEXTURE_DEFORMATION_BIT_SGIX = $00000001;

GL_GEOMETRY_DEFORMATION_BIT_SGIX = $00000002;

GL_IGNORE_BORDER_HP = $8150;

GL_CONSTANT_BORDER_HP = $8151;

GL_REPLICATE_BORDER_HP = $8153;

GL_CONVOLUTION_BORDER_COLOR_HP = $8154;

GL_IMAGE_SCALE_X_HP = $8155;

GL_IMAGE_SCALE_Y_HP = $8156;

GL_IMAGE_TRANSLATE_X_HP = $8157;

GL_IMAGE_TRANSLATE_Y_HP = $8158;

GL_IMAGE_ROTATE_ANGLE_HP = $8159;

GL_IMAGE_ROTATE_ORIGIN_X_HP = $815A;

GL_IMAGE_ROTATE_ORIGIN_Y_HP = $815B;

GL_IMAGE_MAG_FILTER_HP = $815C;

GL_IMAGE_MIN_FILTER_HP = $815D;

GL_IMAGE_CUBIC_WEIGHT_HP = $815E;

GL_CUBIC_HP = $815F;

GL_AVERAGE_HP = $8160;

GL_IMAGE_TRANSFORM_2D_HP = $8161;

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8162;

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8163;

GL_OCCLUSION_TEST_HP = $8165;

GL_OCCLUSION_TEST_RESULT_HP = $8166;

GL_TEXTURE_LIGHTING_MODE_HP = $8167;

GL_TEXTURE_POST_SPECULAR_HP = $8168;

GL_TEXTURE_PRE_SPECULAR_HP = $8169;

GL_CULL_VERTEX_IBM = 103050;

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_MIRRORED_REPEAT_IBM = $8370;

GL_VERTEX_ARRAY_LIST_IBM = 103070;

GL_NORMAL_ARRAY_LIST_IBM = 103071;

GL_COLOR_ARRAY_LIST_IBM = 103072;

GL_INDEX_ARRAY_LIST_IBM = 103073;

GL_TEXTURE_COORD_ARRAY_LIST_IBM = 103074;

GL_EDGE_FLAG_ARRAY_LIST_IBM = 103075;

GL_FOG_COORDINATE_ARRAY_LIST_IBM = 103076;

GL_SECONDARY_COLOR_ARRAY_LIST_IBM = 103077;

GL_VERTEX_ARRAY_LIST_STRIDE_IBM = 103080;

GL_NORMAL_ARRAY_LIST_STRIDE_IBM = 103081;

GL_COLOR_ARRAY_LIST_STRIDE_IBM = 103082;

GL_INDEX_ARRAY_LIST_STRIDE_IBM = 103083;

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM = 103084;

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM = 103085;

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM = 103086;

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM = 103087;

GL_RED_MIN_CLAMP_INGR = $8560;

GL_GREEN_MIN_CLAMP_INGR = $8561;

GL_BLUE_MIN_CLAMP_INGR = $8562;

GL_ALPHA_MIN_CLAMP_INGR = $8563;

GL_RED_MAX_CLAMP_INGR = $8564;

GL_GREEN_MAX_CLAMP_INGR = $8565;

GL_BLUE_MAX_CLAMP_INGR = $8566;

GL_ALPHA_MAX_CLAMP_INGR = $8567;

GL_INTERLACE_READ_INGR = $8568;

GL_PARALLEL_ARRAYS_INTEL = $83F4;

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL = $83F5;

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL = $83F6;

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL = $83F7;

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL = $83F8;

GL_DEPTH_STENCIL_TO_RGBA_NV = $886E;

GL_DEPTH_STENCIL_TO_BGRA_NV = $886F;

GL_DEPTH_CLAMP_NV = $864F;

GL_EVAL_2D_NV = $86C0;

GL_EVAL_TRIANGULAR_2D_NV = $86C1;

GL_MAP_TESSELLATION_NV = $86C2;

GL_MAP_ATTRIB_U_ORDER_NV = $86C3;

GL_MAP_ATTRIB_V_ORDER_NV = $86C4;

GL_EVAL_FRACTIONAL_TESSELLATION_NV = $86C5;

GL_EVAL_VERTEX_ATTRIB0_NV = $86C6;

GL_EVAL_VERTEX_ATTRIB1_NV = $86C7;

GL_EVAL_VERTEX_ATTRIB2_NV = $86C8;

GL_EVAL_VERTEX_ATTRIB3_NV = $86C9;

GL_EVAL_VERTEX_ATTRIB4_NV = $86CA;

GL_EVAL_VERTEX_ATTRIB5_NV = $86CB;

GL_EVAL_VERTEX_ATTRIB6_NV = $86CC;

GL_EVAL_VERTEX_ATTRIB7_NV = $86CD;

GL_EVAL_VERTEX_ATTRIB8_NV = $86CE;

GL_EVAL_VERTEX_ATTRIB9_NV = $86CF;

GL_EVAL_VERTEX_ATTRIB10_NV = $86D0;

GL_EVAL_VERTEX_ATTRIB11_NV = $86D1;

GL_EVAL_VERTEX_ATTRIB12_NV = $86D2;

GL_EVAL_VERTEX_ATTRIB13_NV = $86D3;

GL_EVAL_VERTEX_ATTRIB14_NV = $86D4;

GL_EVAL_VERTEX_ATTRIB15_NV = $86D5;

GL_MAX_MAP_TESSELLATION_NV = $86D6;

GL_MAX_RATIONAL_EVAL_ORDER_NV = $86D7;

GL_ALL_COMPLETED_NV = $84F2;

GL_FENCE_STATUS_NV = $84F3;

GL_FENCE_CONDITION_NV = $84F4;

GL_FLOAT_R_NV = $8880;

GL_FLOAT_RG_NV = $8881;

GL_FLOAT_RGB_NV = $8882;

GL_FLOAT_RGBA_NV = $8883;

GL_FLOAT_R16_NV = $8884;

GL_FLOAT_R32_NV = $8885;

GL_FLOAT_RG16_NV = $8886;

GL_FLOAT_RG32_NV = $8887;

GL_FLOAT_RGB16_NV = $8888;

GL_FLOAT_RGB32_NV = $8889;

GL_FLOAT_RGBA16_NV = $888A;

GL_FLOAT_RGBA32_NV = $888B;

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

GL_FLOAT_RGBA_MODE_NV = $888E;

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_EYE_RADIAL_NV = $855B;

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV = $8868;

GL_FRAGMENT_PROGRAM_NV = $8870;

GL_MAX_TEXTURE_COORDS_NV = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_NV = $8872;

GL_FRAGMENT_PROGRAM_BINDING_NV = $8873;

GL_PROGRAM_ERROR_STRING_NV = $8874;

GL_HALF_FLOAT_NV = $140B;

GL_MAX_SHININESS_NV = $8504;

GL_MAX_SPOT_EXPONENT_NV = $8505;

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

GL_PIXEL_COUNT_NV = $8866;

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

GL_DEPTH_STENCIL_NV = $84F9;

GL_UNSIGNED_INT_24_8_NV = $84FA;

GL_WRITE_PIXEL_DATA_RANGE_NV = $8878;

GL_READ_PIXEL_DATA_RANGE_NV = $8879;

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV = $887A;

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV = $887B;

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV = $887C;

GL_READ_PIXEL_DATA_RANGE_POINTER_NV = $887D;

GL_POINT_SPRITE_NV = $8861;

GL_COORD_REPLACE_NV = $8862;

GL_POINT_SPRITE_R_MODE_NV = $8863;

GL_PRIMITIVE_RESTART_NV = $8558;

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

GL_REGISTER_COMBINERS_NV = $8522;

GL_VARIABLE_A_NV = $8523;

GL_VARIABLE_B_NV = $8524;

GL_VARIABLE_C_NV = $8525;

GL_VARIABLE_D_NV = $8526;

GL_VARIABLE_E_NV = $8527;

GL_VARIABLE_F_NV = $8528;

GL_VARIABLE_G_NV = $8529;

GL_CONSTANT_COLOR0_NV = $852A;

GL_CONSTANT_COLOR1_NV = $852B;

GL_PRIMARY_COLOR_NV = $852C;

GL_SECONDARY_COLOR_NV = $852D;

GL_SPARE0_NV = $852E;

GL_SPARE1_NV = $852F;

GL_DISCARD_NV = $8530;

GL_E_TIMES_F_NV = $8531;

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

GL_UNSIGNED_IDENTITY_NV = $8536;

GL_UNSIGNED_INVERT_NV = $8537;

GL_EXPAND_NORMAL_NV = $8538;

GL_EXPAND_NEGATE_NV = $8539;

GL_HALF_BIAS_NORMAL_NV = $853A;

GL_HALF_BIAS_NEGATE_NV = $853B;

GL_SIGNED_IDENTITY_NV = $853C;

GL_SIGNED_NEGATE_NV = $853D;

GL_SCALE_BY_TWO_NV = $853E;

GL_SCALE_BY_FOUR_NV = $853F;

GL_SCALE_BY_ONE_HALF_NV = $8540;

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

GL_COMBINER_INPUT_NV = $8542;

GL_COMBINER_MAPPING_NV = $8543;

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

GL_COMBINER_MUX_SUM_NV = $8547;

GL_COMBINER_SCALE_NV = $8548;

GL_COMBINER_BIAS_NV = $8549;

GL_COMBINER_AB_OUTPUT_NV = $854A;

GL_COMBINER_CD_OUTPUT_NV = $854B;

GL_COMBINER_SUM_OUTPUT_NV = $854C;

GL_MAX_GENERAL_COMBINERS_NV = $854D;

GL_NUM_GENERAL_COMBINERS_NV = $854E;

GL_COLOR_SUM_CLAMP_NV = $854F;

GL_COMBINER0_NV = $8550;

GL_COMBINER1_NV = $8551;

GL_COMBINER2_NV = $8552;

GL_COMBINER3_NV = $8553;

GL_COMBINER4_NV = $8554;

GL_COMBINER5_NV = $8555;

GL_COMBINER6_NV = $8556;

GL_COMBINER7_NV = $8557;

GL_PER_STAGE_CONSTANTS_NV = $8535;

GL_EMBOSS_LIGHT_NV = $855D;

GL_EMBOSS_CONSTANT_NV = $855E;

GL_EMBOSS_MAP_NV = $855F;

GL_NORMAL_MAP_NV = $8511;

GL_REFLECTION_MAP_NV = $8512;

GL_COMBINE4_NV = $8503;

GL_SOURCE3_RGB_NV = $8583;

GL_SOURCE3_ALPHA_NV = $858B;

GL_OPERAND3_RGB_NV = $8593;

GL_OPERAND3_ALPHA_NV = $859B;

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV = $888F;

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

GL_DSDT_MAG_INTENSITY_NV = $86DC;

GL_SHADER_CONSISTENT_NV = $86DD;

GL_TEXTURE_SHADER_NV = $86DE;

GL_SHADER_OPERATION_NV = $86DF;

GL_CULL_MODES_NV = $86E0;

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

GL_CONST_EYE_NV = $86E5;

GL_PASS_THROUGH_NV = $86E6;

GL_CULL_FRAGMENT_NV = $86E7;

GL_OFFSET_TEXTURE_2D_NV = $86E8;

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

GL_DOT_PRODUCT_NV = $86EC;

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

GL_HILO_NV = $86F4;

GL_DSDT_NV = $86F5;

GL_DSDT_MAG_NV = $86F6;

GL_DSDT_MAG_VIB_NV = $86F7;

GL_HILO16_NV = $86F8;

GL_SIGNED_HILO_NV = $86F9;

GL_SIGNED_HILO16_NV = $86FA;

GL_SIGNED_RGBA_NV = $86FB;

GL_SIGNED_RGBA8_NV = $86FC;

GL_SIGNED_RGB_NV = $86FE;

GL_SIGNED_RGB8_NV = $86FF;

GL_SIGNED_LUMINANCE_NV = $8701;

GL_SIGNED_LUMINANCE8_NV = $8702;

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

GL_SIGNED_ALPHA_NV = $8705;

GL_SIGNED_ALPHA8_NV = $8706;

GL_SIGNED_INTENSITY_NV = $8707;

GL_SIGNED_INTENSITY8_NV = $8708;

GL_DSDT8_NV = $8709;

GL_DSDT8_MAG8_NV = $870A;

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

GL_HI_SCALE_NV = $870E;

GL_LO_SCALE_NV = $870F;

GL_DS_SCALE_NV = $8710;

GL_DT_SCALE_NV = $8711;

GL_MAGNITUDE_SCALE_NV = $8712;

GL_VIBRANCE_SCALE_NV = $8713;

GL_HI_BIAS_NV = $8714;

GL_LO_BIAS_NV = $8715;

GL_DS_BIAS_NV = $8716;

GL_DT_BIAS_NV = $8717;

GL_MAGNITUDE_BIAS_NV = $8718;

GL_VIBRANCE_BIAS_NV = $8719;

GL_TEXTURE_BORDER_VALUES_NV = $871A;

GL_TEXTURE_HI_SIZE_NV = $871B;

GL_TEXTURE_LO_SIZE_NV = $871C;

GL_TEXTURE_DS_SIZE_NV = $871D;

GL_TEXTURE_DT_SIZE_NV = $871E;

GL_TEXTURE_MAG_SIZE_NV = $871F;

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

GL_HILO8_NV = $885E;

GL_SIGNED_HILO8_NV = $885F;

GL_FORCE_BLUE_TO_ONE_NV = $8860;

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_VERTEX_PROGRAM_NV = $8620;

GL_VERTEX_STATE_PROGRAM_NV = $8621;

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

GL_CURRENT_ATTRIB_NV = $8626;

GL_PROGRAM_LENGTH_NV = $8627;

GL_PROGRAM_STRING_NV = $8628;

GL_MODELVIEW_PROJECTION_NV = $8629;

GL_IDENTITY_NV = $862A;

GL_INVERSE_NV = $862B;

GL_TRANSPOSE_NV = $862C;

GL_INVERSE_TRANSPOSE_NV = $862D;

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

GL_MAX_TRACK_MATRICES_NV = $862F;

GL_MATRIX0_NV = $8630;

GL_MATRIX1_NV = $8631;

GL_MATRIX2_NV = $8632;

GL_MATRIX3_NV = $8633;

GL_MATRIX4_NV = $8634;

GL_MATRIX5_NV = $8635;

GL_MATRIX6_NV = $8636;

GL_MATRIX7_NV = $8637;

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

GL_CURRENT_MATRIX_NV = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

GL_PROGRAM_PARAMETER_NV = $8644;

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

GL_PROGRAM_TARGET_NV = $8646;

GL_PROGRAM_RESIDENT_NV = $8647;

GL_TRACK_MATRIX_NV = $8648;

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

GL_PROGRAM_ERROR_POSITION_NV = $864B;

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV = $88F4;

GL_MAX_PROGRAM_CALL_DEPTH_NV = $88F5;

GL_MAX_PROGRAM_IF_DEPTH_NV = $88F6;

GL_MAX_PROGRAM_LOOP_DEPTH_NV = $88F7;

GL_MAX_PROGRAM_LOOP_COUNT_NV = $88F8;

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV = $8DAD;

GL_DEPTH_BUFFER_FLOAT_MODE_NV = $8DAF;

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV = $8CAB;

GL_RENDERBUFFER_COLOR_SAMPLES_NV = $8E10;

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

GL_PROGRAM_ATTRIB_COMPONENTS_NV = $8906;

GL_PROGRAM_RESULT_COMPONENTS_NV = $8907;

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV = $8908;

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV = $8909;

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV = $8DA5;

GL_MAX_PROGRAM_GENERIC_RESULTS_NV = $8DA6;

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV = $8DA0;

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV = $8DA1;

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV = $8DA2;

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV = $8DA3;

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV = $8DA4;

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

GL_SEPARATE_ATTRIBS_NV = $8C8D;

GL_PRIMITIVES_GENERATED_NV = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

GL_RASTERIZER_DISCARD_NV = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

GL_ACTIVE_VARYINGS_NV = $8C81;

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

GL_BACK_PRIMARY_COLOR_NV = $8C77;

GL_BACK_SECONDARY_COLOR_NV = $8C78;

GL_TEXTURE_COORD_NV = $8C79;

GL_CLIP_DISTANCE_NV = $8C7A;

GL_VERTEX_ID_NV = $8C7B;

GL_PRIMITIVE_ID_NV = $8C7C;

GL_GENERIC_ATTRIB_NV = $8C7D;

GL_LAYER_NV = $8DAA;

GL_NEXT_BUFFER_NV = -2;

GL_SKIP_COMPONENTS4_NV = -3;

GL_SKIP_COMPONENTS3_NV = -4;

GL_SKIP_COMPONENTS2_NV = -5;

GL_SKIP_COMPONENTS1_NV = -6;

GL_QUERY_WAIT_NV = $8E13;

GL_QUERY_NO_WAIT_NV = $8E14;

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

GL_CONSERVATIVE_RASTERIZATION_NV = $9346;

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV = $9347;

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV = $9348;

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV = $9349;

GL_CONSERVATIVE_RASTER_DILATE_NV = $9379;

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV = $937A;

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV = $937B;

GL_FRAME_NV = $8E26;

GL_FIELDS_NV = $8E27;

GL_CURRENT_TIME_NV = $8E28;

GL_NUM_FILL_STREAMS_NV = $8E29;

GL_PRESENT_TIME_NV = $8E2A;

GL_PRESENT_DURATION_NV = $8E2B;

GL_SAMPLE_POSITION_NV = $8E50;

GL_SAMPLE_MASK_NV = $8E51;

GL_SAMPLE_MASK_VALUE_NV = $8E52;

GL_TEXTURE_BINDING_RENDERBUFFER_NV = $8E53;

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV = $8E54;

GL_TEXTURE_RENDERBUFFER_NV = $8E55;

GL_SAMPLER_RENDERBUFFER_NV = $8E56;

GL_INT_SAMPLER_RENDERBUFFER_NV = $8E57;

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV = $8E58;

GL_MAX_SAMPLE_MASK_WORDS_NV = $8E59;

GL_TRANSFORM_FEEDBACK_NV = $8E22;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV = $8E24;

GL_TRANSFORM_FEEDBACK_BINDING_NV = $8E25;

GL_VIDEO_BUFFER_NV = $9020;

GL_VIDEO_BUFFER_BINDING_NV = $9021;

GL_FIELD_UPPER_NV = $9022;

GL_FIELD_LOWER_NV = $9023;

GL_NUM_VIDEO_CAPTURE_STREAMS_NV = $9024;

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV = $9025;

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV = $9026;

GL_LAST_VIDEO_CAPTURE_STATUS_NV = $9027;

GL_VIDEO_BUFFER_PITCH_NV = $9028;

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV = $9029;

GL_VIDEO_COLOR_CONVERSION_MAX_NV = $902A;

GL_VIDEO_COLOR_CONVERSION_MIN_NV = $902B;

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV = $902C;

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV = $902D;

GL_PARTIAL_SUCCESS_NV = $902E;

GL_SUCCESS_NV = $902F;

GL_FAILURE_NV = $9030;

GL_YCBYCR8_422_NV = $9031;

GL_YCBAYCR8A_4224_NV = $9032;

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV = $9033;

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV = $9034;

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV = $9035;

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV = $9036;

GL_Z4Y12Z4CB12Z4CR12_444_NV = $9037;

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV = $9038;

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV = $9039;

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV = $903A;

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV = $903B;

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV = $903C;

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_GPU_ADDRESS_NV = $8F34;

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

GL_DRAW_INDIRECT_UNIFIED_NV = $8F40;

GL_DRAW_INDIRECT_ADDRESS_NV = $8F41;

GL_DRAW_INDIRECT_LENGTH_NV = $8F42;

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5C;

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV = $8E5D;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5F;

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV = $8F44;

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV = $8F45;

GL_INT64_NV = $140E;

GL_UNSIGNED_INT64_NV = $140F;

GL_INT8_NV = $8FE0;

GL_INT8_VEC2_NV = $8FE1;

GL_INT8_VEC3_NV = $8FE2;

GL_INT8_VEC4_NV = $8FE3;

GL_INT16_NV = $8FE4;

GL_INT16_VEC2_NV = $8FE5;

GL_INT16_VEC3_NV = $8FE6;

GL_INT16_VEC4_NV = $8FE7;

GL_INT64_VEC2_NV = $8FE9;

GL_INT64_VEC3_NV = $8FEA;

GL_INT64_VEC4_NV = $8FEB;

GL_UNSIGNED_INT8_NV = $8FEC;

GL_UNSIGNED_INT8_VEC2_NV = $8FED;

GL_UNSIGNED_INT8_VEC3_NV = $8FEE;

GL_UNSIGNED_INT8_VEC4_NV = $8FEF;

GL_UNSIGNED_INT16_NV = $8FF0;

GL_UNSIGNED_INT16_VEC2_NV = $8FF1;

GL_UNSIGNED_INT16_VEC3_NV = $8FF2;

GL_UNSIGNED_INT16_VEC4_NV = $8FF3;

GL_UNSIGNED_INT64_VEC2_NV = $8FF5;

GL_UNSIGNED_INT64_VEC3_NV = $8FF6;

GL_UNSIGNED_INT64_VEC4_NV = $8FF7;

GL_FLOAT16_NV = $8FF8;

GL_FLOAT16_VEC2_NV = $8FF9;

GL_FLOAT16_VEC3_NV = $8FFA;

GL_FLOAT16_VEC4_NV = $8FFB;

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV = $00000010;

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV = $86D8;

GL_TESS_CONTROL_PROGRAM_NV = $891E;

GL_TESS_EVALUATION_PROGRAM_NV = $891F;

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV = $8C74;

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV = $8C75;

GL_COVERAGE_SAMPLES_NV = $80A9;

GL_COLOR_SAMPLES_NV = $8E20;

GL_SURFACE_STATE_NV = $86EB;

GL_SURFACE_REGISTERED_NV = $86FD;

GL_SURFACE_MAPPED_NV = $8700;

GL_WRITE_DISCARD_NV = $88BE;

GL_INTERLACE_OML = $8980;

GL_INTERLACE_READ_OML = $8981;

GL_PACK_RESAMPLE_OML = $8984;

GL_UNPACK_RESAMPLE_OML = $8985;

GL_RESAMPLE_REPLICATE_OML = $8986;

GL_RESAMPLE_ZERO_FILL_OML = $8987;

GL_RESAMPLE_AVERAGE_OML = $8988;

GL_RESAMPLE_DECIMATE_OML = $8989;

GL_FORMAT_SUBSAMPLE_24_24_OML = $8982;

GL_FORMAT_SUBSAMPLE_244_244_OML = $8983;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR = $9630;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR = $9632;

GL_MAX_VIEWS_OVR = $9631;

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR = $9633;

GL_PREFER_DOUBLEBUFFER_HINT_PGI = $1A1F8;

GL_CONSERVE_MEMORY_HINT_PGI = $1A1FD;

GL_RECLAIM_MEMORY_HINT_PGI = $1A1FE;

GL_NATIVE_GRAPHICS_HANDLE_PGI = $1A202;

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI = $1A203;

GL_NATIVE_GRAPHICS_END_HINT_PGI = $1A204;

GL_ALWAYS_FAST_HINT_PGI = $1A20C;

GL_ALWAYS_SOFT_HINT_PGI = $1A20D;

GL_ALLOW_DRAW_OBJ_HINT_PGI = $1A20E;

GL_ALLOW_DRAW_WIN_HINT_PGI = $1A20F;

GL_ALLOW_DRAW_FRG_HINT_PGI = $1A210;

GL_ALLOW_DRAW_MEM_HINT_PGI = $1A211;

GL_STRICT_DEPTHFUNC_HINT_PGI = $1A216;

GL_STRICT_LIGHTING_HINT_PGI = $1A217;

GL_STRICT_SCISSOR_HINT_PGI = $1A218;

GL_FULL_STIPPLE_HINT_PGI = $1A219;

GL_CLIP_NEAR_HINT_PGI = $1A220;

GL_CLIP_FAR_HINT_PGI = $1A221;

GL_WIDE_LINE_HINT_PGI = $1A222;

GL_BACK_NORMALS_HINT_PGI = $1A223;

GL_VERTEX_DATA_HINT_PGI = $1A22A;

GL_VERTEX_CONSISTENT_HINT_PGI = $1A22B;

GL_MATERIAL_SIDE_HINT_PGI = $1A22C;

GL_MAX_VERTEX_HINT_PGI = $1A22D;

GL_COLOR3_BIT_PGI = $00010000;

GL_COLOR4_BIT_PGI = $00020000;

GL_EDGEFLAG_BIT_PGI = $00040000;

GL_INDEX_BIT_PGI = $00080000;

GL_MAT_AMBIENT_BIT_PGI = $00100000;

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI = $00200000;

GL_MAT_DIFFUSE_BIT_PGI = $00400000;

GL_MAT_EMISSION_BIT_PGI = $00800000;

GL_MAT_COLOR_INDEXES_BIT_PGI = $01000000;

GL_MAT_SHININESS_BIT_PGI = $02000000;

GL_MAT_SPECULAR_BIT_PGI = $04000000;

GL_NORMAL_BIT_PGI = $08000000;

GL_TEXCOORD1_BIT_PGI = $10000000;

GL_TEXCOORD2_BIT_PGI = $20000000;

GL_TEXCOORD3_BIT_PGI = $40000000;

GL_TEXCOORD4_BIT_PGI = $80000000;

GL_VERTEX23_BIT_PGI = $00000004;

GL_VERTEX4_BIT_PGI = $00000008;

GL_SCREEN_COORDINATES_REND = $8490;

GL_INVERTED_SCREEN_W_REND = $8491;

GL_RGB_S3TC = $83A0;

GL_RGB4_S3TC = $83A1;

GL_RGBA_S3TC = $83A2;

GL_RGBA4_S3TC = $83A3;

GL_DETAIL_TEXTURE_2D_SGIS = $8095;

GL_DETAIL_TEXTURE_2D_BINDING_SGIS = $8096;

GL_LINEAR_DETAIL_SGIS = $8097;

GL_LINEAR_DETAIL_ALPHA_SGIS = $8098;

GL_LINEAR_DETAIL_COLOR_SGIS = $8099;

GL_DETAIL_TEXTURE_LEVEL_SGIS = $809A;

GL_DETAIL_TEXTURE_MODE_SGIS = $809B;

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS = $809C;

GL_FOG_FUNC_SGIS = $812A;

GL_FOG_FUNC_POINTS_SGIS = $812B;

GL_MAX_FOG_FUNC_POINTS_SGIS = $812C;

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

GL_MULTISAMPLE_SGIS = $809D;

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

GL_SAMPLE_MASK_SGIS = $80A0;

GL_1PASS_SGIS = $80A1;

GL_2PASS_0_SGIS = $80A2;

GL_2PASS_1_SGIS = $80A3;

GL_4PASS_0_SGIS = $80A4;

GL_4PASS_1_SGIS = $80A5;

GL_4PASS_2_SGIS = $80A6;

GL_4PASS_3_SGIS = $80A7;

GL_SAMPLE_BUFFERS_SGIS = $80A8;

GL_SAMPLES_SGIS = $80A9;

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

GL_SAMPLE_PATTERN_SGIS = $80AC;

GL_PIXEL_TEXTURE_SGIS = $8353;

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS = $8354;

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS = $8355;

GL_PIXEL_GROUP_COLOR_SGIS = $8356;

GL_EYE_DISTANCE_TO_POINT_SGIS = $81F0;

GL_OBJECT_DISTANCE_TO_POINT_SGIS = $81F1;

GL_EYE_DISTANCE_TO_LINE_SGIS = $81F2;

GL_OBJECT_DISTANCE_TO_LINE_SGIS = $81F3;

GL_EYE_POINT_SGIS = $81F4;

GL_OBJECT_POINT_SGIS = $81F5;

GL_EYE_LINE_SGIS = $81F6;

GL_OBJECT_LINE_SGIS = $81F7;

GL_POINT_SIZE_MIN_SGIS = $8126;

GL_POINT_SIZE_MAX_SGIS = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_SGIS = $8128;

GL_DISTANCE_ATTENUATION_SGIS = $8129;

GL_LINEAR_SHARPEN_SGIS = $80AD;

GL_LINEAR_SHARPEN_ALPHA_SGIS = $80AE;

GL_LINEAR_SHARPEN_COLOR_SGIS = $80AF;

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS = $80B0;

GL_PACK_SKIP_VOLUMES_SGIS = $8130;

GL_PACK_IMAGE_DEPTH_SGIS = $8131;

GL_UNPACK_SKIP_VOLUMES_SGIS = $8132;

GL_UNPACK_IMAGE_DEPTH_SGIS = $8133;

GL_TEXTURE_4D_SGIS = $8134;

GL_PROXY_TEXTURE_4D_SGIS = $8135;

GL_TEXTURE_4DSIZE_SGIS = $8136;

GL_TEXTURE_WRAP_Q_SGIS = $8137;

GL_MAX_4D_TEXTURE_SIZE_SGIS = $8138;

GL_TEXTURE_4D_BINDING_SGIS = $814F;

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_FILTER4_SGIS = $8146;

GL_TEXTURE_FILTER4_SIZE_SGIS = $8147;

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_TEXTURE_MAX_LOD_SGIS = $813B;

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

GL_DUAL_ALPHA4_SGIS = $8110;

GL_DUAL_ALPHA8_SGIS = $8111;

GL_DUAL_ALPHA12_SGIS = $8112;

GL_DUAL_ALPHA16_SGIS = $8113;

GL_DUAL_LUMINANCE4_SGIS = $8114;

GL_DUAL_LUMINANCE8_SGIS = $8115;

GL_DUAL_LUMINANCE12_SGIS = $8116;

GL_DUAL_LUMINANCE16_SGIS = $8117;

GL_DUAL_INTENSITY4_SGIS = $8118;

GL_DUAL_INTENSITY8_SGIS = $8119;

GL_DUAL_INTENSITY12_SGIS = $811A;

GL_DUAL_INTENSITY16_SGIS = $811B;

GL_DUAL_LUMINANCE_ALPHA4_SGIS = $811C;

GL_DUAL_LUMINANCE_ALPHA8_SGIS = $811D;

GL_QUAD_ALPHA4_SGIS = $811E;

GL_QUAD_ALPHA8_SGIS = $811F;

GL_QUAD_LUMINANCE4_SGIS = $8120;

GL_QUAD_LUMINANCE8_SGIS = $8121;

GL_QUAD_INTENSITY4_SGIS = $8122;

GL_QUAD_INTENSITY8_SGIS = $8123;

GL_DUAL_TEXTURE_SELECT_SGIS = $8124;

GL_QUAD_TEXTURE_SELECT_SGIS = $8125;

GL_ASYNC_MARKER_SGIX = $8329;

GL_ASYNC_HISTOGRAM_SGIX = $832C;

GL_MAX_ASYNC_HISTOGRAM_SGIX = $832D;

GL_ASYNC_TEX_IMAGE_SGIX = $835C;

GL_ASYNC_DRAW_PIXELS_SGIX = $835D;

GL_ASYNC_READ_PIXELS_SGIX = $835E;

GL_MAX_ASYNC_TEX_IMAGE_SGIX = $835F;

GL_MAX_ASYNC_DRAW_PIXELS_SGIX = $8360;

GL_MAX_ASYNC_READ_PIXELS_SGIX = $8361;

GL_ALPHA_MIN_SGIX = $8320;

GL_ALPHA_MAX_SGIX = $8321;

GL_CALLIGRAPHIC_FRAGMENT_SGIX = $8183;

GL_LINEAR_CLIPMAP_LINEAR_SGIX = $8170;

GL_TEXTURE_CLIPMAP_CENTER_SGIX = $8171;

GL_TEXTURE_CLIPMAP_FRAME_SGIX = $8172;

GL_TEXTURE_CLIPMAP_OFFSET_SGIX = $8173;

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8174;

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX = $8175;

GL_TEXTURE_CLIPMAP_DEPTH_SGIX = $8176;

GL_MAX_CLIPMAP_DEPTH_SGIX = $8177;

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8178;

GL_NEAREST_CLIPMAP_NEAREST_SGIX = $844D;

GL_NEAREST_CLIPMAP_LINEAR_SGIX = $844E;

GL_LINEAR_CLIPMAP_NEAREST_SGIX = $844F;

GL_CONVOLUTION_HINT_SGIX = $8316;

GL_DEPTH_COMPONENT16_SGIX = $81A5;

GL_DEPTH_COMPONENT24_SGIX = $81A6;

GL_DEPTH_COMPONENT32_SGIX = $81A7;

GL_FOG_OFFSET_SGIX = $8198;

GL_FOG_OFFSET_VALUE_SGIX = $8199;

GL_FOG_SCALE_SGIX = $81FC;

GL_FOG_SCALE_VALUE_SGIX = $81FD;

GL_FRAGMENT_LIGHTING_SGIX = $8400;

GL_FRAGMENT_COLOR_MATERIAL_SGIX = $8401;

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX = $8402;

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX = $8403;

GL_MAX_FRAGMENT_LIGHTS_SGIX = $8404;

GL_MAX_ACTIVE_LIGHTS_SGIX = $8405;

GL_CURRENT_RASTER_NORMAL_SGIX = $8406;

GL_LIGHT_ENV_MODE_SGIX = $8407;

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX = $8408;

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX = $8409;

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX = $840A;

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX = $840B;

GL_FRAGMENT_LIGHT0_SGIX = $840C;

GL_FRAGMENT_LIGHT1_SGIX = $840D;

GL_FRAGMENT_LIGHT2_SGIX = $840E;

GL_FRAGMENT_LIGHT3_SGIX = $840F;

GL_FRAGMENT_LIGHT4_SGIX = $8410;

GL_FRAGMENT_LIGHT5_SGIX = $8411;

GL_FRAGMENT_LIGHT6_SGIX = $8412;

GL_FRAGMENT_LIGHT7_SGIX = $8413;

GL_FRAMEZOOM_SGIX = $818B;

GL_FRAMEZOOM_FACTOR_SGIX = $818C;

GL_MAX_FRAMEZOOM_FACTOR_SGIX = $818D;

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX = $8184;

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX = $8185;

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX = $8186;

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX = $8187;

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX = $8188;

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX = $8189;

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX = $818A;

GL_INSTRUMENT_BUFFER_POINTER_SGIX = $8180;

GL_INSTRUMENT_MEASUREMENTS_SGIX = $8181;

GL_INTERLACE_SGIX = $8094;

GL_IR_INSTRUMENT1_SGIX = $817F;

GL_LIST_PRIORITY_SGIX = $8182;

GL_PIXEL_TEX_GEN_SGIX = $8139;

GL_PIXEL_TEX_GEN_MODE_SGIX = $832B;

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX = $813E;

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX = $813F;

GL_PIXEL_TILE_WIDTH_SGIX = $8140;

GL_PIXEL_TILE_HEIGHT_SGIX = $8141;

GL_PIXEL_TILE_GRID_WIDTH_SGIX = $8142;

GL_PIXEL_TILE_GRID_HEIGHT_SGIX = $8143;

GL_PIXEL_TILE_GRID_DEPTH_SGIX = $8144;

GL_PIXEL_TILE_CACHE_SIZE_SGIX = $8145;

GL_GEOMETRY_DEFORMATION_SGIX = $8194;

GL_TEXTURE_DEFORMATION_SGIX = $8195;

GL_DEFORMATIONS_MASK_SGIX = $8196;

GL_MAX_DEFORMATION_ORDER_SGIX = $8197;

GL_REFERENCE_PLANE_SGIX = $817D;

GL_REFERENCE_PLANE_EQUATION_SGIX = $817E;

GL_PACK_RESAMPLE_SGIX = $842C;

GL_UNPACK_RESAMPLE_SGIX = $842D;

GL_RESAMPLE_REPLICATE_SGIX = $842E;

GL_RESAMPLE_ZERO_FILL_SGIX = $842F;

GL_RESAMPLE_DECIMATE_SGIX = $8430;

GL_SCALEBIAS_HINT_SGIX = $8322;

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_SPRITE_SGIX = $8148;

GL_SPRITE_MODE_SGIX = $8149;

GL_SPRITE_AXIS_SGIX = $814A;

GL_SPRITE_TRANSLATION_SGIX = $814B;

GL_SPRITE_AXIAL_SGIX = $814C;

GL_SPRITE_OBJECT_ALIGNED_SGIX = $814D;

GL_SPRITE_EYE_ALIGNED_SGIX = $814E;

GL_PACK_SUBSAMPLE_RATE_SGIX = $85A0;

GL_UNPACK_SUBSAMPLE_RATE_SGIX = $85A1;

GL_PIXEL_SUBSAMPLE_4444_SGIX = $85A2;

GL_PIXEL_SUBSAMPLE_2424_SGIX = $85A3;

GL_PIXEL_SUBSAMPLE_4242_SGIX = $85A4;

GL_TEXTURE_ENV_BIAS_SGIX = $80BE;

GL_TEXTURE_MAX_CLAMP_S_SGIX = $8369;

GL_TEXTURE_MAX_CLAMP_T_SGIX = $836A;

GL_TEXTURE_MAX_CLAMP_R_SGIX = $836B;

GL_TEXTURE_LOD_BIAS_S_SGIX = $818E;

GL_TEXTURE_LOD_BIAS_T_SGIX = $818F;

GL_TEXTURE_LOD_BIAS_R_SGIX = $8190;

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX = $812E;

GL_POST_TEXTURE_FILTER_BIAS_SGIX = $8179;

GL_POST_TEXTURE_FILTER_SCALE_SGIX = $817A;

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX = $817B;

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX = $817C;

GL_VERTEX_PRECLIP_SGIX = $83EE;

GL_VERTEX_PRECLIP_HINT_SGIX = $83EF;

GL_YCRCB_422_SGIX = $81BB;

GL_YCRCB_444_SGIX = $81BC;

GL_YCRCB_SGIX = $8318;

GL_YCRCBA_SGIX = $8319;

GL_COLOR_MATRIX_SGI = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

GL_COLOR_TABLE_SGI = $80D0;

GL_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D1;

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D2;

GL_PROXY_COLOR_TABLE_SGI = $80D3;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D4;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D5;

GL_COLOR_TABLE_SCALE_SGI = $80D6;

GL_COLOR_TABLE_BIAS_SGI = $80D7;

GL_COLOR_TABLE_FORMAT_SGI = $80D8;

GL_COLOR_TABLE_WIDTH_SGI = $80D9;

GL_COLOR_TABLE_RED_SIZE_SGI = $80DA;

GL_COLOR_TABLE_GREEN_SIZE_SGI = $80DB;

GL_COLOR_TABLE_BLUE_SIZE_SGI = $80DC;

GL_COLOR_TABLE_ALPHA_SIZE_SGI = $80DD;

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI = $80DE;

GL_COLOR_TABLE_INTENSITY_SIZE_SGI = $80DF;

GL_DEPTH_PASS_INSTRUMENT_SGIX = $8310;

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX = $8311;

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX = $8312;

GL_TEXTURE_COLOR_TABLE_SGI = $80BC;

GL_PROXY_TEXTURE_COLOR_TABLE_SGI = $80BD;

GL_UNPACK_CONSTANT_DATA_SUNX = $81D5;

GL_TEXTURE_CONSTANT_DATA_SUNX = $81D6;

GL_WRAP_BORDER_SUN = $81D4;

GL_GLOBAL_ALPHA_SUN = $81D9;

GL_GLOBAL_ALPHA_FACTOR_SUN = $81DA;

GL_QUAD_MESH_SUN = $8614;

GL_TRIANGLE_MESH_SUN = $8615;

GL_SLICE_ACCUM_SUN = $85CC;

GL_RESTART_SUN = $0001;

GL_REPLACE_MIDDLE_SUN = $0002;

GL_REPLACE_OLDEST_SUN = $0003;

GL_TRIANGLE_LIST_SUN = $81D7;

GL_REPLACEMENT_CODE_SUN = $81D8;

GL_REPLACEMENT_CODE_ARRAY_SUN = $85C0;

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN = $85C1;

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN = $85C2;

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN = $85C3;

GL_R1UI_V3F_SUN = $85C4;

GL_R1UI_C4UB_V3F_SUN = $85C5;

GL_R1UI_C3F_V3F_SUN = $85C6;

GL_R1UI_N3F_V3F_SUN = $85C7;

GL_R1UI_C4F_N3F_V3F_SUN = $85C8;

GL_R1UI_T2F_V3F_SUN = $85C9;

GL_R1UI_T2F_N3F_V3F_SUN = $85CA;

GL_R1UI_T2F_C4F_N3F_V3F_SUN = $85CB;

GL_PHONG_WIN = $80EA;

GL_PHONG_HINT_WIN = $80EB;

GL_FOG_SPECULAR_TEXTURE_WIN = $80EC;

GL_VERTEX_SHADER_ARB = $8B31;

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

GL_MULTIPLY_KHR = $9294;

GL_SCREEN_KHR = $9295;

GL_OVERLAY_KHR = $9296;

GL_DARKEN_KHR = $9297;

GL_LIGHTEN_KHR = $9298;

GL_COLORDODGE_KHR = $9299;

GL_COLORBURN_KHR = $929A;

GL_HARDLIGHT_KHR = $929B;

GL_SOFTLIGHT_KHR = $929C;

GL_DIFFERENCE_KHR = $929E;

GL_EXCLUSION_KHR = $92A0;

GL_HSL_HUE_KHR = $92AD;

GL_HSL_SATURATION_KHR = $92AE;

GL_HSL_COLOR_KHR = $92AF;

GL_HSL_LUMINOSITY_KHR = $92B0;

GL_BLEND_ADVANCED_COHERENT_KHR = $9285;

GL_CONTEXT_ROBUST_ACCESS = $90F3;

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR = $00000008;

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

GL_SAMPLES_PASSED_ARB = $8914;

GL_QUERY_COUNTER_BITS_ARB = $8864;

GL_CURRENT_QUERY_ARB = $8865;

GL_QUERY_RESULT_ARB = $8866;

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

GL_VERTICES_SUBMITTED_ARB = $82EE;

GL_PRIMITIVES_SUBMITTED_ARB = $82EF;

GL_VERTEX_SHADER_INVOCATIONS_ARB = $82F0;

GL_TESS_CONTROL_SHADER_PATCHES_ARB = $82F1;

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB = $82F2;

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB = $82F3;

GL_FRAGMENT_SHADER_INVOCATIONS_ARB = $82F4;

GL_COMPUTE_SHADER_INVOCATIONS_ARB = $82F5;

GL_CLIPPING_INPUT_PRIMITIVES_ARB = $82F6;

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB = $82F7;

GL_POINT_SPRITE_ARB = $8861;

GL_COORD_REPLACE_ARB = $8862;

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_PROGRAM_OBJECT_ARB = $8B40;

GL_OBJECT_TYPE_ARB = $8B4E;

GL_OBJECT_SUBTYPE_ARB = $8B4F;

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

GL_OBJECT_LINK_STATUS_ARB = $8B82;

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

GL_SHADER_OBJECT_ARB = $8B48;

GL_FLOAT_VEC2_ARB = $8B50;

GL_FLOAT_VEC3_ARB = $8B51;

GL_FLOAT_VEC4_ARB = $8B52;

GL_INT_VEC2_ARB = $8B53;

GL_INT_VEC3_ARB = $8B54;

GL_INT_VEC4_ARB = $8B55;

GL_BOOL_ARB = $8B56;

GL_BOOL_VEC2_ARB = $8B57;

GL_BOOL_VEC3_ARB = $8B58;

GL_BOOL_VEC4_ARB = $8B59;

GL_FLOAT_MAT2_ARB = $8B5A;

GL_FLOAT_MAT3_ARB = $8B5B;

GL_FLOAT_MAT4_ARB = $8B5C;

GL_SAMPLER_1D_ARB = $8B5D;

GL_SAMPLER_2D_ARB = $8B5E;

GL_SAMPLER_3D_ARB = $8B5F;

GL_SAMPLER_CUBE_ARB = $8B60;

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

GL_SAMPLER_2D_RECT_ARB = $8B63;

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

WGL_SAMPLE_BUFFERS_3DFX = $2060;

WGL_SAMPLES_3DFX = $2061;

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_SAMPLES_ARB = $2042;

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

WGL_PBUFFER_LARGEST_ARB = $2033;

WGL_PBUFFER_WIDTH_ARB = $2034;

WGL_PBUFFER_HEIGHT_ARB = $2035;

WGL_PBUFFER_LOST_ARB = $2036;

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_DRAW_TO_WINDOW_ARB = $2001;

WGL_DRAW_TO_BITMAP_ARB = $2002;

WGL_ACCELERATION_ARB = $2003;

WGL_NEED_PALETTE_ARB = $2004;

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

WGL_SWAP_METHOD_ARB = $2007;

WGL_NUMBER_OVERLAYS_ARB = $2008;

WGL_NUMBER_UNDERLAYS_ARB = $2009;

WGL_TRANSPARENT_ARB = $200A;

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

WGL_SHARE_DEPTH_ARB = $200C;

WGL_SHARE_STENCIL_ARB = $200D;

WGL_SHARE_ACCUM_ARB = $200E;

WGL_SUPPORT_GDI_ARB = $200F;

WGL_SUPPORT_OPENGL_ARB = $2010;

WGL_DOUBLE_BUFFER_ARB = $2011;

WGL_STEREO_ARB = $2012;

WGL_PIXEL_TYPE_ARB = $2013;

WGL_COLOR_BITS_ARB = $2014;

WGL_RED_BITS_ARB = $2015;

WGL_RED_SHIFT_ARB = $2016;

WGL_GREEN_BITS_ARB = $2017;

WGL_GREEN_SHIFT_ARB = $2018;

WGL_BLUE_BITS_ARB = $2019;

WGL_BLUE_SHIFT_ARB = $201A;

WGL_ALPHA_BITS_ARB = $201B;

WGL_ALPHA_SHIFT_ARB = $201C;

WGL_ACCUM_BITS_ARB = $201D;

WGL_ACCUM_RED_BITS_ARB = $201E;

WGL_ACCUM_GREEN_BITS_ARB = $201F;

WGL_ACCUM_BLUE_BITS_ARB = $2020;

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

WGL_DEPTH_BITS_ARB = $2022;

WGL_STENCIL_BITS_ARB = $2023;

WGL_AUX_BUFFERS_ARB = $2024;

WGL_NO_ACCELERATION_ARB = $2025;

WGL_GENERIC_ACCELERATION_ARB = $2026;

WGL_FULL_ACCELERATION_ARB = $2027;

WGL_SWAP_EXCHANGE_ARB = $2028;

WGL_SWAP_COPY_ARB = $2029;

WGL_SWAP_UNDEFINED_ARB = $202A;

WGL_TYPE_RGBA_ARB = $202B;

WGL_TYPE_COLORINDEX_ARB = $202C;

WGL_RGBA_FLOAT_MODE_ARB = $8820;

WGL_CLAMP_VERTEX_COLOR_ARB = $891A;

WGL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

WGL_CLAMP_READ_COLOR_ARB = $891C;

WGL_FIXED_ONLY_ARB = $891D;

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

WGL_TEXTURE_FORMAT_ARB = $2072;

WGL_TEXTURE_TARGET_ARB = $2073;

WGL_MIPMAP_TEXTURE_ARB = $2074;

WGL_TEXTURE_RGB_ARB = $2075;

WGL_TEXTURE_RGBA_ARB = $2076;

WGL_NO_TEXTURE_ARB = $2077;

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

WGL_TEXTURE_1D_ARB = $2079;

WGL_TEXTURE_2D_ARB = $207A;

WGL_MIPMAP_LEVEL_ARB = $207B;

WGL_CUBE_MAP_FACE_ARB = $207C;

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

WGL_FRONT_LEFT_ARB = $2083;

WGL_FRONT_RIGHT_ARB = $2084;

WGL_BACK_LEFT_ARB = $2085;

WGL_BACK_RIGHT_ARB = $2086;

WGL_AUX0_ARB = $2087;

WGL_AUX1_ARB = $2088;

WGL_AUX2_ARB = $2089;

WGL_AUX3_ARB = $208A;

WGL_AUX4_ARB = $208B;

WGL_AUX5_ARB = $208C;

WGL_AUX6_ARB = $208D;

WGL_AUX7_ARB = $208E;

WGL_AUX8_ARB = $208F;

WGL_AUX9_ARB = $2090;

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

WGL_CONTEXT_DEBUG_BIT_ARB = $00000001;

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

WGL_CONTEXT_FLAGS_ARB = $2094;

ERROR_INVALID_VERSION_ARB = $2095;

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

ERROR_INVALID_PROFILE_ARB = $2096;

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

WGL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

WGL_NO_RESET_NOTIFICATION_ARB = $8261;

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

GL_TYPE_RGBA_FLOAT_ATI = $8820;

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

WGL_GPU_VENDOR_AMD = $1F00;

WGL_GPU_RENDERER_STRING_AMD = $1F01;

WGL_GPU_OPENGL_VERSION_STRING_AMD = $1F02;

WGL_GPU_FASTEST_TARGET_GPUS_AMD = $21A2;

WGL_GPU_RAM_AMD = $21A3;

WGL_GPU_CLOCK_AMD = $21A4;

WGL_GPU_NUM_PIPES_AMD = $21A5;

WGL_GPU_NUM_SIMD_AMD = $21A6;

WGL_GPU_NUM_RB_AMD = $21A7;

WGL_GPU_NUM_SPI_AMD = $21A8;

WGL_DEPTH_FLOAT_EXT = $2040;

ERROR_INVALID_PIXEL_TYPE_EXT = $2043;

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_SAMPLES_EXT = $2042;

WGL_DRAW_TO_PBUFFER_EXT = $202D;

WGL_MAX_PBUFFER_PIXELS_EXT = $202E;

WGL_MAX_PBUFFER_WIDTH_EXT = $202F;

WGL_MAX_PBUFFER_HEIGHT_EXT = $2030;

WGL_OPTIMAL_PBUFFER_WIDTH_EXT = $2031;

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT = $2032;

WGL_PBUFFER_LARGEST_EXT = $2033;

WGL_PBUFFER_WIDTH_EXT = $2034;

WGL_PBUFFER_HEIGHT_EXT = $2035;

WGL_NUMBER_PIXEL_FORMATS_EXT = $2000;

WGL_DRAW_TO_WINDOW_EXT = $2001;

WGL_DRAW_TO_BITMAP_EXT = $2002;

WGL_ACCELERATION_EXT = $2003;

WGL_NEED_PALETTE_EXT = $2004;

WGL_NEED_SYSTEM_PALETTE_EXT = $2005;

WGL_SWAP_LAYER_BUFFERS_EXT = $2006;

WGL_SWAP_METHOD_EXT = $2007;

WGL_NUMBER_OVERLAYS_EXT = $2008;

WGL_NUMBER_UNDERLAYS_EXT = $2009;

WGL_TRANSPARENT_EXT = $200A;

WGL_TRANSPARENT_VALUE_EXT = $200B;

WGL_SHARE_DEPTH_EXT = $200C;

WGL_SHARE_STENCIL_EXT = $200D;

WGL_SHARE_ACCUM_EXT = $200E;

WGL_SUPPORT_GDI_EXT = $200F;

WGL_SUPPORT_OPENGL_EXT = $2010;

WGL_DOUBLE_BUFFER_EXT = $2011;

WGL_STEREO_EXT = $2012;

WGL_PIXEL_TYPE_EXT = $2013;

WGL_COLOR_BITS_EXT = $2014;

WGL_RED_BITS_EXT = $2015;

WGL_RED_SHIFT_EXT = $2016;

WGL_GREEN_BITS_EXT = $2017;

WGL_GREEN_SHIFT_EXT = $2018;

WGL_BLUE_BITS_EXT = $2019;

WGL_BLUE_SHIFT_EXT = $201A;

WGL_ALPHA_BITS_EXT = $201B;

WGL_ALPHA_SHIFT_EXT = $201C;

WGL_ACCUM_BITS_EXT = $201D;

WGL_ACCUM_RED_BITS_EXT = $201E;

WGL_ACCUM_GREEN_BITS_EXT = $201F;

WGL_ACCUM_BLUE_BITS_EXT = $2020;

WGL_ACCUM_ALPHA_BITS_EXT = $2021;

WGL_DEPTH_BITS_EXT = $2022;

WGL_STENCIL_BITS_EXT = $2023;

WGL_AUX_BUFFERS_EXT = $2024;

WGL_NO_ACCELERATION_EXT = $2025;

WGL_GENERIC_ACCELERATION_EXT = $2026;

WGL_FULL_ACCELERATION_EXT = $2027;

WGL_SWAP_EXCHANGE_EXT = $2028;

WGL_SWAP_COPY_EXT = $2029;

WGL_SWAP_UNDEFINED_EXT = $202A;

WGL_TYPE_RGBA_EXT = $202B;

WGL_TYPE_COLORINDEX_EXT = $202C;

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D = $2050;

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D = $2051;

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D = $2052;

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D = $2053;

WGL_GAMMA_TABLE_SIZE_I3D = $204E;

WGL_GAMMA_EXCLUDE_DESKTOP_I3D = $204F;

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D = $2044;

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D = $2045;

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D = $2046;

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D = $2047;

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D = $2048;

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D = $2049;

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D = $204A;

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D = $204B;

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D = $204C;

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D = $00000001;

WGL_IMAGE_BUFFER_LOCK_I3D = $00000002;

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

WGL_TEXTURE_FLOAT_R_NV = $20B5;

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

WGL_BIND_TO_TEXTURE_DEPTH_NV = $20A3;

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV = $20A4;

WGL_DEPTH_TEXTURE_FORMAT_NV = $20A5;

WGL_TEXTURE_DEPTH_COMPONENT_NV = $20A6;

WGL_DEPTH_COMPONENT_NV = $20A7;

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV = $20A0;

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV = $20A1;

WGL_TEXTURE_RECTANGLE_NV = $20A2;

WGL_NUM_VIDEO_SLOTS_NV = $20F0;

WGL_BIND_TO_VIDEO_RGB_NV = $20C0;

WGL_BIND_TO_VIDEO_RGBA_NV = $20C1;

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV = $20C2;

WGL_VIDEO_OUT_COLOR_NV = $20C3;

WGL_VIDEO_OUT_ALPHA_NV = $20C4;

WGL_VIDEO_OUT_DEPTH_NV = $20C5;

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

WGL_VIDEO_OUT_FRAME = $20C8;

WGL_VIDEO_OUT_FIELD_1 = $20C9;

WGL_VIDEO_OUT_FIELD_2 = $20CA;

WGL_VIDEO_OUT_STACKED_FIELDS_1_2 = $20CB;

WGL_VIDEO_OUT_STACKED_FIELDS_2_1 = $20CC;

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV = $20D0;

WGL_ERROR_MISSING_AFFINITY_MASK_NV = $20D1;

WGL_UNIQUE_ID_NV = $20CE;

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

WGL_COVERAGE_SAMPLES_NV = $2042;

WGL_COLOR_SAMPLES_NV = $20B9;

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

WGL_ACCESS_READ_ONLY_NV = $00000000;

WGL_ACCESS_READ_WRITE_NV = $00000001;

WGL_ACCESS_WRITE_DISCARD_NV = $00000002;

GL_MAX_ELEMENTS_VERTICES_WIN = $80E8;

GL_MAX_ELEMENTS_INDICES_WIN = $80E9;

GLX_VENDOR = 1;

GLX_VERSION = 2;

GLX_EXTENSIONS = 3;

GLX_USE_GL = 1;

GLX_BUFFER_SIZE = 2;

GLX_LEVEL = 3;

GLX_RGBA = 4;

GLX_DOUBLEBUFFER = 5;

GLX_STEREO = 6;

GLX_AUX_BUFFERS = 7;

GLX_RED_SIZE = 8;

GLX_GREEN_SIZE = 9;

GLX_BLUE_SIZE = 10;

GLX_ALPHA_SIZE = 11;

GLX_DEPTH_SIZE = 12;

GLX_STENCIL_SIZE = 13;

GLX_ACCUM_RED_SIZE = 14;

GLX_ACCUM_GREEN_SIZE = 15;

GLX_ACCUM_BLUE_SIZE = 16;

GLX_ACCUM_ALPHA_SIZE = 17;

GLX_WINDOW_BIT = $00000001;

GLX_PIXMAP_BIT = $00000002;

GLX_PBUFFER_BIT = $00000004;

GLX_RGBA_BIT = $00000001;

GLX_COLOR_INDEX_BIT = $00000002;

GLX_PBUFFER_CLOBBER_MASK = $08000000;

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

GLX_AUX_BUFFERS_BIT = $00000010;

GLX_DEPTH_BUFFER_BIT = $00000020;

GLX_STENCIL_BUFFER_BIT = $00000040;

GLX_ACCUM_BUFFER_BIT = $00000080;

GLX_CONFIG_CAVEAT = $20;

GLX_X_VISUAL_TYPE = $22;

GLX_TRANSPARENT_TYPE = $23;

GLX_TRANSPARENT_INDEX_VALUE = $24;

GLX_TRANSPARENT_RED_VALUE = $25;

GLX_TRANSPARENT_GREEN_VALUE = $26;

GLX_TRANSPARENT_BLUE_VALUE = $27;

GLX_TRANSPARENT_ALPHA_VALUE = $28;

GLX_DONT_CARE = $FFFFFFFF;

GLX_NONE = $8000;

GLX_SLOW_CONFIG = $8001;

GLX_TRUE_COLOR = $8002;

GLX_DIRECT_COLOR = $8003;

GLX_PSEUDO_COLOR = $8004;

GLX_STATIC_COLOR = $8005;

GLX_GRAY_SCALE = $8006;

GLX_STATIC_GRAY = $8007;

GLX_TRANSPARENT_RGB = $8008;

GLX_TRANSPARENT_INDEX = $8009;

GLX_VISUAL_ID = $800B;

GLX_SCREEN = $800C;

GLX_NON_CONFORMANT_CONFIG = $800D;

GLX_DRAWABLE_TYPE = $8010;

GLX_RENDER_TYPE = $8011;

GLX_X_RENDERABLE = $8012;

GLX_FBCONFIG_ID = $8013;

GLX_RGBA_TYPE = $8014;

GLX_COLOR_INDEX_TYPE = $8015;

GLX_MAX_PBUFFER_WIDTH = $8016;

GLX_MAX_PBUFFER_HEIGHT = $8017;

GLX_MAX_PBUFFER_PIXELS = $8018;

GLX_PRESERVED_CONTENTS = $801B;

GLX_LARGEST_PBUFFER = $801C;

GLX_WIDTH = $801D;

GLX_HEIGHT = $801E;

GLX_EVENT_MASK = $801F;

GLX_DAMAGED = $8020;

GLX_SAVED = $8021;

GLX_WINDOW = $8022;

GLX_PBUFFER = $8023;

GLX_PBUFFER_HEIGHT = $8040;

GLX_PBUFFER_WIDTH = $8041;

GLX_SAMPLE_BUFFERS = 100000;

GLX_SAMPLES = 100001;

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_SAMPLES_ARB = 100001;

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

GLX_CONTEXT_FLAGS_ARB = $2094;

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB = $2095;

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

GLX_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GLX_NO_RESET_NOTIFICATION_ARB = $8261;

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_TRANSPARENT_TYPE_EXT = $23;

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

GLX_NONE_EXT = $8000;

GLX_TRUE_COLOR_EXT = $8002;

GLX_DIRECT_COLOR_EXT = $8003;

GLX_PSEUDO_COLOR_EXT = $8004;

GLX_STATIC_COLOR_EXT = $8005;

GLX_GRAY_SCALE_EXT = $8006;

GLX_STATIC_GRAY_EXT = $8007;

GLX_TRANSPARENT_RGB_EXT = $8008;

GLX_TRANSPARENT_INDEX_EXT = $8009;

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_SLOW_VISUAL_EXT = $8001;

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_VISUAL_ID_EXT = $800B;

GLX_SCREEN_EXT = $800C;

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_TEXTURE_2D_BIT_EXT = $00000002;

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

GLX_Y_INVERTED_EXT = $20D4;

GLX_TEXTURE_FORMAT_EXT = $20D5;

GLX_TEXTURE_TARGET_EXT = $20D6;

GLX_MIPMAP_TEXTURE_EXT = $20D7;

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

GLX_TEXTURE_1D_EXT = $20DB;

GLX_TEXTURE_2D_EXT = $20DC;

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

GLX_FRONT_LEFT_EXT = $20DE;

GLX_FRONT_RIGHT_EXT = $20DF;

GLX_BACK_LEFT_EXT = $20E0;

GLX_BACK_RIGHT_EXT = $20E1;

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

GLX_AUX0_EXT = $20E2;

GLX_AUX1_EXT = $20E3;

GLX_AUX2_EXT = $20E4;

GLX_AUX3_EXT = $20E5;

GLX_AUX4_EXT = $20E6;

GLX_AUX5_EXT = $20E7;

GLX_AUX6_EXT = $20E8;

GLX_AUX7_EXT = $20E9;

GLX_AUX8_EXT = $20EA;

GLX_AUX9_EXT = $20EB;

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

GLX_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

GLX_LATE_SWAPS_TEAR_EXT = $20F3;

GLU_INVALID_ENUM = 100900;

GLU_INVALID_VALUE = 100901;

GLU_OUT_OF_MEMORY = 100902;

GLU_INCOMPATIBLE_GL_VERSION = 100903;

GLU_VERSION = 100800;

GLU_EXTENSIONS = 100801;

GLU_TRUE = GL_TRUE;

GLU_FALSE = GL_FALSE;

GLU_SMOOTH = 100000;

GLU_FLAT = 100001;

GLU_NONE = 100002;

GLU_POINT = 100010;

GLU_LINE = 100011;

GLU_FILL = 100012;

GLU_SILHOUETTE = 100013;

GLU_OUTSIDE = 100020;

GLU_INSIDE = 100021;

GLU_TESS_MAX_COORD = 1.0E150;

GLU_TESS_WINDING_RULE = 100140;

GLU_TESS_BOUNDARY_ONLY = 100141;

GLU_TESS_TOLERANCE = 100142;

GLU_TESS_WINDING_ODD = 100130;

GLU_TESS_WINDING_NONZERO = 100131;

GLU_TESS_WINDING_POSITIVE = 100132;

GLU_TESS_WINDING_NEGATIVE = 100133;

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

GLU_TESS_BEGIN = 100100;

GLU_TESS_VERTEX = 100101;

GLU_TESS_END = 100102;

GLU_TESS_ERROR = 100103;

GLU_TESS_EDGE_FLAG = 100104;

GLU_TESS_COMBINE = 100105;

GLU_TESS_BEGIN_DATA = 100106;

GLU_TESS_VERTEX_DATA = 100107;

GLU_TESS_END_DATA = 100108;

GLU_TESS_ERROR_DATA = 100109;

GLU_TESS_EDGE_FLAG_DATA = 100110;

GLU_TESS_COMBINE_DATA = 100111;

GLU_TESS_ERROR1 = 100151;

GLU_TESS_ERROR2 = 100152;

GLU_TESS_ERROR3 = 100153;

GLU_TESS_ERROR4 = 100154;

GLU_TESS_ERROR5 = 100155;

GLU_TESS_ERROR6 = 100156;

GLU_TESS_ERROR7 = 100157;

GLU_TESS_ERROR8 = 100158;

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

GLU_AUTO_LOAD_MATRIX = 100200;

GLU_CULLING = 100201;

GLU_SAMPLING_TOLERANCE = 100203;

GLU_DISPLAY_MODE = 100204;

GLU_PARAMETRIC_TOLERANCE = 100202;

GLU_SAMPLING_METHOD = 100205;

GLU_U_STEP = 100206;

GLU_V_STEP = 100207;

GLU_PATH_LENGTH = 100215;

GLU_PARAMETRIC_ERROR = 100216;

GLU_DOMAIN_DISTANCE = 100217;

GLU_MAP1_TRIM_2 = 100210;

GLU_MAP1_TRIM_3 = 100211;

GLU_OUTLINE_POLYGON = 100240;

GLU_OUTLINE_PATCH = 100241;

GLU_NURBS_ERROR1 = 100251;

GLU_NURBS_ERROR2 = 100252;

GLU_NURBS_ERROR3 = 100253;

GLU_NURBS_ERROR4 = 100254;

GLU_NURBS_ERROR5 = 100255;

GLU_NURBS_ERROR6 = 100256;

GLU_NURBS_ERROR7 = 100257;

GLU_NURBS_ERROR8 = 100258;

GLU_NURBS_ERROR9 = 100259;

GLU_NURBS_ERROR10 = 100260;

GLU_NURBS_ERROR11 = 100261;

GLU_NURBS_ERROR12 = 100262;

GLU_NURBS_ERROR13 = 100263;

GLU_NURBS_ERROR14 = 100264;

GLU_NURBS_ERROR15 = 100265;

GLU_NURBS_ERROR16 = 100266;

GLU_NURBS_ERROR17 = 100267;

GLU_NURBS_ERROR18 = 100268;

GLU_NURBS_ERROR19 = 100269;

GLU_NURBS_ERROR20 = 100270;

GLU_NURBS_ERROR21 = 100271;

GLU_NURBS_ERROR22 = 100272;

GLU_NURBS_ERROR23 = 100273;

GLU_NURBS_ERROR24 = 100274;

GLU_NURBS_ERROR25 = 100275;

GLU_NURBS_ERROR26 = 100276;

GLU_NURBS_ERROR27 = 100277;

GLU_NURBS_ERROR28 = 100278;

GLU_NURBS_ERROR29 = 100279;

GLU_NURBS_ERROR30 = 100280;

GLU_NURBS_ERROR31 = 100281;

GLU_NURBS_ERROR32 = 100282;

GLU_NURBS_ERROR33 = 100283;

GLU_NURBS_ERROR34 = 100284;

GLU_NURBS_ERROR35 = 100285;

GLU_NURBS_ERROR36 = 100286;

GLU_NURBS_ERROR37 = 100287;

GLU_CW = 100120;

GLU_CCW = 100121;

GLU_INTERIOR = 100122;

GLU_EXTERIOR = 100123;

GLU_UNKNOWN = 100124;

GLU_BEGIN = GLU_TESS_BEGIN;

GLU_VERTEX = GLU_TESS_VERTEX;

GLU_END = GLU_TESS_END;

GLU_ERROR = GLU_TESS_ERROR;

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Variables

GL_VERSION_4_0: Boolean;

GL_VERSION_4_1: Boolean;

GL_VERSION_4_2: Boolean;

GL_VERSION_4_3: Boolean;

GL_VERSION_4_4: Boolean;

GL_VERSION_4_5: Boolean;

GL_VERSION_4_6: Boolean;

GLU_VERSION_1_3: Boolean;

GL_3DFX_multisample: Boolean;

GL_3DFX_tbuffer: Boolean;

GL_3DFX_texture_compression_FXT1: Boolean;

GL_APPLE_client_storage: Boolean;

GL_APPLE_element_array: Boolean;

GL_APPLE_fence: Boolean;

GL_APPLE_specular_vector: Boolean;

GL_APPLE_transform_hint: Boolean;

GL_APPLE_vertex_array_object: Boolean;

GL_APPLE_vertex_array_range: Boolean;

GL_APPLE_ycbcr_422: Boolean;

GL_APPLE_texture_range: Boolean;

GL_APPLE_float_pixels: Boolean;

GL_APPLE_vertex_program_evaluators: Boolean;

GL_APPLE_aux_depth_stencil: Boolean;

GL_APPLE_object_purgeable: Boolean;

GL_APPLE_row_bytes: Boolean;

GL_APPLE_rgb_422: Boolean;

GL_ARB_depth_texture: Boolean;

GL_ARB_fragment_program: Boolean;

GL_ARB_imaging: Boolean;

GL_ARB_matrix_palette: Boolean;

GL_ARB_multisample: Boolean;

GL_ARB_multitexture: Boolean;

GL_ARB_point_parameters: Boolean;

GL_ARB_shadow: Boolean;

GL_ARB_shadow_ambient: Boolean;

GL_ARB_texture_border_clamp: Boolean;

GL_ARB_texture_compression: Boolean;

GL_ARB_texture_cube_map: Boolean;

GL_ARB_texture_env_add: Boolean;

GL_ARB_texture_env_combine: Boolean;

GL_ARB_texture_env_crossbar: Boolean;

GL_ARB_texture_env_dot3: Boolean;

GL_ARB_texture_filter_minmax: Boolean;

GL_ARB_texture_mirrored_repeat: Boolean;

GL_ARB_transpose_matrix: Boolean;

GL_ARB_vertex_blend: Boolean;

GL_ARB_vertex_buffer_object: Boolean;

GL_ARB_vertex_program: Boolean;

GL_ARB_window_pos: Boolean;

GL_ARB_shader_objects: Boolean;

GL_ARB_vertex_shader: Boolean;

GL_ARB_fragment_shader: Boolean;

GL_ARB_fragment_shader_interlock: Boolean;

GL_ARB_shading_language_100: Boolean;

GL_ARB_occlusion_query: Boolean;

GL_ARB_texture_non_power_of_two: Boolean;

GL_ARB_point_sprite: Boolean;

GL_ARB_fragment_program_shadow: Boolean;

GL_ARB_draw_buffers: Boolean;

GL_ARB_texture_rectangle: Boolean;

GL_ARB_color_buffer_float: Boolean;

GL_ARB_half_float_pixel: Boolean;

GL_ARB_texture_float: Boolean;

GL_ARB_pixel_buffer_object: Boolean;

GL_ARB_depth_buffer_float: Boolean;

GL_ARB_draw_instanced: Boolean;

GL_ARB_framebuffer_object: Boolean;

GL_ARB_framebuffer_sRGB: Boolean;

GL_ARB_geometry_shader4: Boolean;

GL_ARB_half_float_vertex: Boolean;

GL_ARB_instanced_arrays: Boolean;

GL_ARB_map_buffer_range: Boolean;

GL_ARB_texture_buffer_object: Boolean;

GL_ARB_texture_compression_rgtc: Boolean;

GL_ARB_texture_rg: Boolean;

GL_ARB_vertex_array_object: Boolean;

GL_ARB_uniform_buffer_object: Boolean;

GL_ARB_compatibility: Boolean;

GL_ARB_copy_buffer: Boolean;

GL_ARB_shader_texture_lod: Boolean;

GL_ARB_shader_viewport_layer_array: Boolean;

GL_ARB_depth_clamp: Boolean;

GL_ARB_draw_elements_base_vertex: Boolean;

GL_ARB_fragment_coord_conventions: Boolean;

GL_ARB_provoking_vertex: Boolean;

GL_ARB_seamless_cube_map: Boolean;

GL_ARB_sync: Boolean;

GL_ARB_texture_multisample: Boolean;

GL_ARB_vertex_array_bgra: Boolean;

GL_ARB_draw_buffers_blend: Boolean;

GL_ARB_sample_shading: Boolean;

GL_ARB_sample_locations: Boolean;

GL_ARB_sparse_texture2: Boolean;

GL_ARB_sparse_texture_clamp: Boolean;

GL_ARB_texture_cube_map_array: Boolean;

GL_ARB_texture_gather: Boolean;

GL_ARB_texture_query_lod: Boolean;

GL_ARB_shading_language_include: Boolean;

GL_ARB_texture_compression_bptc: Boolean;

GL_ARB_blend_func_extended: Boolean;

GL_ARB_explicit_attrib_location: Boolean;

GL_ARB_occlusion_query2: Boolean;

GL_ARB_parallel_shader_compile: Boolean;

GL_ARB_post_depth_coverage: Boolean;

GL_ARB_sampler_objects: Boolean;

GL_ARB_shader_bit_encoding: Boolean;

GL_ARB_shader_clock: Boolean;

GL_ARB_texture_rgb10_a2ui: Boolean;

GL_ARB_texture_swizzle: Boolean;

GL_ARB_timer_query: Boolean;

GL_ARB_vertex_type_2_10_10_10_rev: Boolean;

GL_ARB_draw_indirect: Boolean;

GL_ARB_gpu_shader5: Boolean;

GL_ARB_gpu_shader_fp64: Boolean;

GL_ARB_gpu_shader_int64: Boolean;

GL_ARB_shader_subroutine: Boolean;

GL_ARB_tessellation_shader: Boolean;

GL_ARB_texture_buffer_object_rgb32: Boolean;

GL_ARB_transform_feedback2: Boolean;

GL_ARB_transform_feedback3: Boolean;

GL_ARB_ES2_compatibility: Boolean;

GL_ARB_ES3_2_compatibility: Boolean;

GL_ARB_get_program_binary: Boolean;

GL_ARB_separate_shader_objects: Boolean;

GL_ARB_shader_precision: Boolean;

GL_ARB_shader_ballot: Boolean;

GL_ARB_vertex_attrib_64bit: Boolean;

GL_ARB_viewport_array: Boolean;

GL_ARB_base_instance: Boolean;

GL_ARB_shading_language_420pack: Boolean;

GL_ARB_transform_feedback_instanced: Boolean;

GL_ARB_compressed_texture_pixel_storage: Boolean;

GL_ARB_conservative_depth: Boolean;

GL_ARB_internalformat_query: Boolean;

GL_ARB_map_buffer_alignment: Boolean;

GL_ARB_shader_atomic_counters: Boolean;

GL_ARB_shader_image_load_store: Boolean;

GL_ARB_shading_language_packing: Boolean;

GL_ARB_texture_storage: Boolean;

GL_ARB_arrays_of_arrays: Boolean;

GL_ARB_fragment_layer_viewport: Boolean;

GL_ARB_shader_image_size: Boolean;

GL_ARB_ES3_compatibility: Boolean;

GL_ARB_clear_buffer_object: Boolean;

GL_ARB_compute_shader: Boolean;

GL_ARB_copy_image: Boolean;

GL_KHR_debug: Boolean;

GL_ARB_explicit_uniform_location: Boolean;

GL_ARB_framebuffer_no_attachments: Boolean;

GL_ARB_internalformat_query2: Boolean;

GL_ARB_invalidate_subdata: Boolean;

GL_ARB_multi_draw_indirect: Boolean;

GL_ARB_program_interface_query: Boolean;

GL_ARB_robust_buffer_access_behavior: Boolean;

GL_ARB_shader_storage_buffer_object: Boolean;

GL_ARB_stencil_texturing: Boolean;

GL_ARB_texture_buffer_range: Boolean;

GL_ARB_texture_query_levels: Boolean;

GL_ARB_texture_storage_multisample: Boolean;

GL_ARB_texture_view: Boolean;

GL_ARB_vertex_attrib_binding: Boolean;

GL_NV_path_rendering: Boolean;

GL_AMD_pinned_memory: Boolean;

GL_AMD_stencil_operation_extended: Boolean;

GL_AMD_vertex_shader_viewport_index: Boolean;

GL_AMD_vertex_shader_layer: Boolean;

GL_NV_bindless_texture: Boolean;

GL_NV_shader_atomic_float: Boolean;

GL_AMD_query_buffer_object: Boolean;

GL_ARB_buffer_storage: Boolean;

GL_ARB_clear_texture: Boolean;

GL_ARB_enhanced_layouts: Boolean;

GL_ARB_multi_bind: Boolean;

GL_ARB_query_buffer_object: Boolean;

GL_ARB_texture_mirror_clamp_to_edge: Boolean;

GL_ARB_texture_stencil8: Boolean;

GL_ARB_vertex_type_10f_11f_11f_rev: Boolean;

GL_ARB_bindless_texture: Boolean;

GL_ARB_sparse_texture: Boolean;

GL_ARB_clip_control: Boolean;

GL_ARB_cull_distance: Boolean;

GL_ARB_ES3_1_compatibility: Boolean;

GL_ARB_conditional_render_inverted: Boolean;

GL_KHR_context_flush_control: Boolean;

GL_ARB_derivative_control: Boolean;

GL_ARB_direct_state_access: Boolean;

GL_ARB_get_texture_sub_image: Boolean;

GL_KHR_robustness: Boolean;

GL_KHR_blend_equation_advanced: Boolean;

GL_KHR_blend_equation_advanced_coherent: Boolean;

GL_KHR_robust_buffer_access_behavior: Boolean;

GL_ARB_shader_texture_image_samples: Boolean;

GL_ARB_texture_barrier: Boolean;

GL_ARB_indirect_parameters: Boolean;

GL_ARB_pipeline_statistics_query: Boolean;

GL_ARB_polygon_offset_clamp: Boolean;

GL_KHR_no_error: Boolean;

GL_ARB_shader_atomic_counter_ops: Boolean;

GL_ARB_shader_draw_parameters: Boolean;

GL_ARB_shader_group_vote: Boolean;

GL_ARB_gl_spirv: Boolean;

GL_ARB_spirv_extensions: Boolean;

GL_ARB_texture_filter_anisotropic: Boolean;

GL_ARB_transform_feedback_overflow_query: Boolean;

GL_ARB_cl_event: Boolean;

GL_ARB_compute_variable_group_size: Boolean;

GL_ARB_debug_output: Boolean;

GL_ARB_robustness: Boolean;

GL_ARB_shader_stencil_export: Boolean;

GL_ATI_draw_buffers: Boolean;

GL_ATI_element_array: Boolean;

GL_ATI_envmap_bumpmap: Boolean;

GL_ATI_fragment_shader: Boolean;

GL_ATI_map_object_buffer: Boolean;

GL_ATI_pn_triangles: Boolean;

GL_ATI_separate_stencil: Boolean;

GL_ATI_text_fragment_shader: Boolean;

GL_ATI_texture_env_combine3: Boolean;

GL_ATI_texture_float: Boolean;

GL_ATI_texture_mirror_once: Boolean;

GL_ATI_vertex_array_object: Boolean;

GL_ATI_vertex_attrib_array_object: Boolean;

GL_ATI_vertex_streams: Boolean;

GL_ATI_meminfo: Boolean;

GL_AMD_performance_monitor: Boolean;

GL_AMD_texture_texture4: Boolean;

GL_AMD_vertex_shader_tesselator: Boolean;

GL_AMD_draw_buffers_blend: Boolean;

GL_AMD_shader_stencil_export: Boolean;

GL_AMD_seamless_cubemap_per_texture: Boolean;

GL_AMD_conservative_depth: Boolean;

GL_AMD_name_gen_delete: Boolean;

GL_AMD_debug_output: Boolean;

GL_AMD_transform_feedback3_lines_triangles: Boolean;

GL_AMD_depth_clamp_separate: Boolean;

GL_EXT_422_pixels: Boolean;

GL_EXT_abgr: Boolean;

GL_EXT_bgra: Boolean;

GL_EXT_blend_color: Boolean;

GL_EXT_blend_func_separate: Boolean;

GL_EXT_blend_logic_op: Boolean;

GL_EXT_blend_minmax: Boolean;

GL_EXT_blend_subtract: Boolean;

GL_EXT_clip_volume_hint: Boolean;

GL_EXT_cmyka: Boolean;

GL_EXT_color_matrix: Boolean;

GL_EXT_color_subtable: Boolean;

GL_EXT_compiled_vertex_array: Boolean;

GL_EXT_convolution: Boolean;

GL_EXT_coordinate_frame: Boolean;

GL_EXT_copy_texture: Boolean;

GL_EXT_cull_vertex: Boolean;

GL_EXT_draw_range_elements: Boolean;

GL_EXT_fog_coord: Boolean;

GL_EXT_framebuffer_object: Boolean;

GL_EXT_histogram: Boolean;

GL_EXT_index_array_formats: Boolean;

GL_EXT_index_func: Boolean;

GL_EXT_index_material: Boolean;

GL_EXT_index_texture: Boolean;

GL_EXT_light_texture: Boolean;

GL_EXT_misc_attribute: Boolean;

GL_EXT_multi_draw_arrays: Boolean;

GL_EXT_multisample: Boolean;

GL_EXT_packed_pixels: Boolean;

GL_EXT_paletted_texture: Boolean;

GL_EXT_pixel_transform: Boolean;

GL_EXT_pixel_transform_color_table: Boolean;

GL_EXT_point_parameters: Boolean;

GL_EXT_polygon_offset: Boolean;

GL_EXT_rescale_normal: Boolean;

GL_EXT_secondary_color: Boolean;

GL_EXT_separate_specular_color: Boolean;

GL_EXT_shadow_funcs: Boolean;

GL_EXT_shared_texture_palette: Boolean;

GL_EXT_stencil_two_side: Boolean;

GL_EXT_stencil_wrap: Boolean;

GL_EXT_subtexture: Boolean;

GL_EXT_texture: Boolean;

GL_EXT_texture3D: Boolean;

GL_EXT_texture_compression_s3tc: Boolean;

GL_EXT_texture_cube_map: Boolean;

GL_EXT_texture_edge_clamp: Boolean;

GL_EXT_texture_env_add: Boolean;

GL_EXT_texture_env_combine: Boolean;

GL_EXT_texture_env_dot3: Boolean;

GL_EXT_texture_filter_anisotropic: Boolean;

GL_EXT_texture_lod_bias: Boolean;

GL_EXT_texture_object: Boolean;

GL_EXT_texture_perturb_normal: Boolean;

GL_EXT_texture_rectangle: Boolean;

GL_EXT_vertex_array: Boolean;

GL_EXT_vertex_shader: Boolean;

GL_EXT_vertex_weighting: Boolean;

GL_EXT_depth_bounds_test: Boolean;

GL_EXT_texture_mirror_clamp: Boolean;

GL_EXT_blend_equation_separate: Boolean;

GL_EXT_pixel_buffer_object: Boolean;

GL_EXT_texture_compression_dxt1: Boolean;

GL_EXT_stencil_clear_tag: Boolean;

GL_EXT_packed_depth_stencil: Boolean;

GL_EXT_texture_sRGB: Boolean;

GL_EXT_framebuffer_blit: Boolean;

GL_EXT_framebuffer_multisample: Boolean;

GL_EXT_timer_query: Boolean;

GL_EXT_gpu_program_parameters: Boolean;

GL_EXT_bindable_uniform: Boolean;

GL_EXT_draw_buffers2: Boolean;

GL_EXT_draw_instanced: Boolean;

GL_EXT_framebuffer_sRGB: Boolean;

GL_EXT_geometry_shader4: Boolean;

GL_EXT_gpu_shader4: Boolean;

GL_EXT_packed_float: Boolean;

GL_EXT_texture_array: Boolean;

GL_EXT_texture_buffer_object: Boolean;

GL_EXT_texture_compression_latc: Boolean;

GL_EXT_texture_compression_rgtc: Boolean;

GL_EXT_texture_integer: Boolean;

GL_EXT_texture_shared_exponent: Boolean;

GL_EXT_transform_feedback: Boolean;

GL_EXT_direct_state_access: Boolean;

GL_EXT_vertex_array_bgra: Boolean;

GL_EXT_texture_swizzle: Boolean;

GL_EXT_provoking_vertex: Boolean;

GL_EXT_texture_snorm: Boolean;

GL_EXT_separate_shader_objects: Boolean;

GL_EXT_shader_image_load_store: Boolean;

GL_EXT_vertex_attrib_64bit: Boolean;

GL_EXT_texture_sRGB_decode: Boolean;

GL_FfdMaskSGIX: Boolean;

GL_HP_convolution_border_modes: Boolean;

GL_HP_image_transform: Boolean;

GL_HP_occlusion_test: Boolean;

GL_HP_texture_lighting: Boolean;

GL_IBM_cull_vertex: Boolean;

GL_IBM_multimode_draw_arrays: Boolean;

GL_IBM_rasterpos_clip: Boolean;

GL_IBM_texture_mirrored_repeat: Boolean;

GL_IBM_vertex_array_lists: Boolean;

GL_INGR_blend_func_separate: Boolean;

GL_INGR_color_clamp: Boolean;

GL_INGR_interlace_read: Boolean;

GL_INGR_palette_buffer: Boolean;

GL_INTEL_framebuffer_CMAA: Boolean;

GL_INTEL_parallel_arrays: Boolean;

GL_INTEL_texture_scissor: Boolean;

GL_MESA_resize_buffers: Boolean;

GL_MESA_window_pos: Boolean;

GL_NV_blend_square: Boolean;

GL_NV_copy_depth_to_color: Boolean;

GL_NV_depth_clamp: Boolean;

GL_NV_evaluators: Boolean;

GL_NV_fence: Boolean;

GL_NV_float_buffer: Boolean;

GL_NV_fog_distance: Boolean;

GL_NV_fragment_program: Boolean;

GL_NV_half_float: Boolean;

GL_NV_light_max_exponent: Boolean;

GL_NV_multisample_filter_hint: Boolean;

GL_NV_occlusion_query: Boolean;

GL_NV_packed_depth_stencil: Boolean;

GL_NV_pixel_data_range: Boolean;

GL_NV_point_sprite: Boolean;

GL_NV_primitive_restart: Boolean;

GL_NV_register_combiners: Boolean;

GL_NV_register_combiners2: Boolean;

GL_NV_texgen_emboss: Boolean;

GL_NV_texgen_reflection: Boolean;

GL_NV_texture_compression_vtc: Boolean;

GL_NV_texture_env_combine4: Boolean;

GL_NV_texture_expand_normal: Boolean;

GL_NV_texture_rectangle: Boolean;

GL_NV_texture_shader: Boolean;

GL_NV_texture_shader2: Boolean;

GL_NV_texture_shader3: Boolean;

GL_NV_vertex_array_range: Boolean;

GL_NV_vertex_array_range2: Boolean;

GL_NV_vertex_program: Boolean;

GL_NV_vertex_program1_1: Boolean;

GL_NV_vertex_program2: Boolean;

GL_NV_fragment_program_option: Boolean;

GL_NV_fragment_program2: Boolean;

GL_NV_vertex_program2_option: Boolean;

GL_NV_vertex_program3: Boolean;

GL_NV_depth_buffer_float: Boolean;

GL_NV_fragment_program4: Boolean;

GL_NV_framebuffer_multisample_coverage: Boolean;

GL_NV_geometry_program4: Boolean;

GL_NV_gpu_program4: Boolean;

GL_NV_parameter_buffer_object: Boolean;

GL_NV_transform_feedback: Boolean;

GL_NV_vertex_program4: Boolean;

GL_NV_conditional_render: Boolean;

GL_NV_conservative_raster: Boolean;

GL_NV_conservative_raster_dilate: Boolean;

GL_NV_present_video: Boolean;

GL_NV_explicit_multisample: Boolean;

GL_NV_transform_feedback2: Boolean;

GL_NV_video_capture: Boolean;

GL_NV_copy_image: Boolean;

GL_NV_parameter_buffer_object2: Boolean;

GL_NV_shader_buffer_load: Boolean;

GL_NV_vertex_buffer_unified_memory: Boolean;

GL_NV_gpu_program5: Boolean;

GL_NV_gpu_shader5: Boolean;

GL_NV_shader_buffer_store: Boolean;

GL_NV_tessellation_program5: Boolean;

GL_NV_vertex_attrib_integer_64bit: Boolean;

GL_NV_multisample_coverage: Boolean;

GL_NV_vdpau_interop: Boolean;

GL_NV_texture_barrier: Boolean;

GL_OML_interlace: Boolean;

GL_OML_resample: Boolean;

GL_OML_subsample: Boolean;

GL_OVR_multiview: Boolean;

GL_OVR_multiview2: Boolean;

GL_PGI_misc_hints: Boolean;

GL_PGI_vertex_hints: Boolean;

GL_REND_screen_coordinates: Boolean;

GL_S3_s3tc: Boolean;

GL_SGIS_detail_texture: Boolean;

GL_SGIS_fog_function: Boolean;

GL_SGIS_generate_mipmap: Boolean;

GL_SGIS_multisample: Boolean;

GL_SGIS_pixel_texture: Boolean;

GL_SGIS_point_line_texgen: Boolean;

GL_SGIS_point_parameters: Boolean;

GL_SGIS_sharpen_texture: Boolean;

GL_SGIS_texture4D: Boolean;

GL_SGIS_texture_border_clamp: Boolean;

GL_SGIS_texture_color_mask: Boolean;

GL_SGIS_texture_edge_clamp: Boolean;

GL_SGIS_texture_filter4: Boolean;

GL_SGIS_texture_lod: Boolean;

GL_SGIS_texture_select: Boolean;

GL_SGIX_async: Boolean;

GL_SGIX_async_histogram: Boolean;

GL_SGIX_async_pixel: Boolean;

GL_SGIX_blend_alpha_minmax: Boolean;

GL_SGIX_calligraphic_fragment: Boolean;

GL_SGIX_clipmap: Boolean;

GL_SGIX_convolution_accuracy: Boolean;

GL_SGIX_depth_pass_instrument: Boolean;

GL_SGIX_depth_texture: Boolean;

GL_SGIX_flush_raster: Boolean;

GL_SGIX_fog_offset: Boolean;

GL_SGIX_fog_scale: Boolean;

GL_SGIX_fragment_lighting: Boolean;

GL_SGIX_framezoom: Boolean;

GL_SGIX_igloo_interface: Boolean;

GL_SGIX_impact_pixel_texture: Boolean;

GL_SGIX_instruments: Boolean;

GL_SGIX_interlace: Boolean;

GL_SGIX_ir_instrument1: Boolean;

GL_SGIX_list_priority: Boolean;

GL_SGIX_pixel_texture: Boolean;

GL_SGIX_pixel_tiles: Boolean;

GL_SGIX_polynomial_ffd: Boolean;

GL_SGIX_reference_plane: Boolean;

GL_SGIX_resample: Boolean;

GL_SGIX_scalebias_hint: Boolean;

GL_SGIX_shadow: Boolean;

GL_SGIX_shadow_ambient: Boolean;

GL_SGIX_sprite: Boolean;

GL_SGIX_subsample: Boolean;

GL_SGIX_tag_sample_buffer: Boolean;

GL_SGIX_texture_add_env: Boolean;

GL_SGIX_texture_coordinate_clamp: Boolean;

GL_SGIX_texture_lod_bias: Boolean;

GL_SGIX_texture_multi_buffer: Boolean;

GL_SGIX_texture_scale_bias: Boolean;

GL_SGIX_texture_select: Boolean;

GL_SGIX_vertex_preclip: Boolean;

GL_SGIX_ycrcb: Boolean;

GL_SGIX_ycrcb_subsample: Boolean;

GL_SGIX_ycrcba: Boolean;

GL_SGI_color_matrix: Boolean;

GL_SGI_color_table: Boolean;

GL_SGI_depth_pass_instrument: Boolean;

GL_SGI_texture_color_table: Boolean;

GL_SUNX_constant_data: Boolean;

GL_SUN_convolution_border_modes: Boolean;

GL_SUN_global_alpha: Boolean;

GL_SUN_mesh_array: Boolean;

GL_SUN_slice_accum: Boolean;

GL_SUN_triangle_list: Boolean;

GL_SUN_vertex: Boolean;

GL_WIN_phong_shading: Boolean;

GL_WIN_specular_fog: Boolean;

WGL_3DFX_multisample: Boolean;

WGL_ARB_buffer_region: Boolean;

WGL_ARB_extensions_string: Boolean;

WGL_ARB_make_current_read: Boolean;

WGL_ARB_multisample: Boolean;

WGL_ARB_pbuffer: Boolean;

WGL_ARB_pixel_format: Boolean;

WGL_ARB_pixel_format_float: Boolean;

WGL_ARB_render_texture: Boolean;

WGL_ARB_create_context: Boolean;

WGL_ARB_create_context_profile: Boolean;

WGL_ARB_framebuffer_sRGB: Boolean;

WGL_ARB_create_context_robustness: Boolean;

WGL_ATI_pixel_format_float: Boolean;

WGL_AMD_gpu_association: Boolean;

WGL_EXT_depth_float: Boolean;

WGL_EXT_display_color_table: Boolean;

WGL_EXT_extensions_string: Boolean;

WGL_EXT_make_current_read: Boolean;

WGL_EXT_multisample: Boolean;

WGL_EXT_pbuffer: Boolean;

WGL_EXT_pixel_format: Boolean;

WGL_EXT_swap_control: Boolean;

WGL_EXT_create_context_es2_profile: Boolean;

WGL_I3D_digital_video_control: Boolean;

WGL_I3D_gamma: Boolean;

WGL_I3D_genlock: Boolean;

WGL_I3D_image_buffer: Boolean;

WGL_I3D_swap_frame_lock: Boolean;

WGL_I3D_swap_frame_usage: Boolean;

WGL_NV_float_buffer: Boolean;

WGL_NV_render_depth_texture: Boolean;

WGL_NV_render_texture_rectangle: Boolean;

WGL_NV_vertex_array_range: Boolean;

WGL_NV_present_video: Boolean;

WGL_NV_video_output: Boolean;

WGL_NV_swap_group: Boolean;

WGL_NV_gpu_affinity: Boolean;

WGL_NV_video_capture: Boolean;

WGL_NV_copy_image: Boolean;

WGL_NV_multisample_coverage: Boolean;

WGL_NV_DX_interop: Boolean;

WGL_OML_sync_control: Boolean;

WGL_3DL_stereo_control: Boolean;

WGL_ARB_context_flush_control: Boolean;

WIN_draw_range_elements: Boolean;

WIN_swap_hint: Boolean;

GLX_VERSION_1_4: Boolean;

GLX_ARB_multisample: Boolean;

GLX_ARB_fbconfig_float: Boolean;

GLX_ARB_get_proc_address: Boolean;

GLX_ARB_create_context: Boolean;

GLX_ARB_create_context_profile: Boolean;

GLX_ARB_vertex_buffer_object: Boolean;

GLX_ARB_framebuffer_sRGB: Boolean;

GLX_ARB_create_context_robustness: Boolean;

GLX_EXT_visual_info: Boolean;

GLX_EXT_visual_rating: Boolean;

GLX_EXT_import_context: Boolean;

GLX_EXT_fbconfig_packed_float: Boolean;

GLX_EXT_framebuffer_sRGB: Boolean;

GLX_EXT_texture_from_pixmap: Boolean;

GLX_EXT_swap_control: Boolean;

GLX_ARB_context_flush_control: Boolean;

GLX_EXT_create_context_es2_profile: Boolean;

glBlendColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;

glBlendEquation: procedure(mode: Cardinal); stdcall;

glDrawRangeElements: procedure(mode: Cardinal; Astart, Aend: TGLuint; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

glTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

glCopyTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glColorTable: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

glColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glCopyColorTable: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

glGetColorTable: procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

glGetColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glColorSubTable: procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

glCopyColorSubTable: procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

glConvolutionFilter1D: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

glConvolutionFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

glConvolutionParameterf: procedure(target, pname: Cardinal; param: Single); stdcall;

glConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glConvolutionParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

glConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glCopyConvolutionFilter1D: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

glCopyConvolutionFilter2D: procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

glGetConvolutionFilter: procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

glGetConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glGetSeparableFilter: procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

glSeparableFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

glGetHistogram: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

glGetHistogramParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetHistogramParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glGetMinmax: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

glGetMinmaxParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetMinmaxParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glHistogram: procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

glMinmax: procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

glResetHistogram: procedure(target: Cardinal); stdcall;

glResetMinmax: procedure(target: Cardinal); stdcall;

glActiveTexture: procedure(texture: Cardinal); stdcall;

glSampleCoverage: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glCompressedTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage2D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage1D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage3D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage2D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage1D: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glGetCompressedTexImage: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

glClientActiveTexture: procedure(texture: Cardinal); stdcall;

glMultiTexCoord1d: procedure(target: Cardinal; s: TGLdouble); stdcall;

glMultiTexCoord1dV: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord1f: procedure(target: Cardinal; s: Single); stdcall;

glMultiTexCoord1fV: procedure(target: Cardinal; v: Single); stdcall;

glMultiTexCoord1i: procedure(target: Cardinal; s: TGLint); stdcall;

glMultiTexCoord1iV: procedure(target: Cardinal; v: PGLInt); stdcall;

glMultiTexCoord1s: procedure(target: Cardinal; s: TGLshort); stdcall;

glMultiTexCoord1sV: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord2d: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

glMultiTexCoord2dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord2f: procedure(target: Cardinal; s, t: Single); stdcall;

glMultiTexCoord2fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord2i: procedure(target: Cardinal; s, t: TGLint); stdcall;

glMultiTexCoord2iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord2s: procedure(target: Cardinal; s, t: TGLshort); stdcall;

glMultiTexCoord2sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord3d: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

glMultiTexCoord3dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord3f: procedure(target: Cardinal; s, t, r: Single); stdcall;

glMultiTexCoord3fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord3i: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

glMultiTexCoord3iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord3s: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

glMultiTexCoord3sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord4d: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

glMultiTexCoord4dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord4f: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

glMultiTexCoord4fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord4i: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

glMultiTexCoord4iv: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord4s: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

glMultiTexCoord4sv: procedure(target: Cardinal; v: PGLshort); stdcall;

glLoadTransposeMatrixf: procedure(m: PGLfloat); stdcall;

glLoadTransposeMatrixd: procedure(m: PGLdouble); stdcall;

glMultTransposeMatrixf: procedure(m: PGLfloat); stdcall;

glMultTransposeMatrixd: procedure(m: PGLdouble); stdcall;

glBlendFuncSeparate: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

glMultiDrawArrays: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

glMultiDrawElements: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

glPointParameterf: procedure(pname: Cardinal; param: Single); stdcall;

glPointParameterfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glPointParameteri: procedure(pname: Cardinal; param: TGLint); stdcall;

glPointParameteriv: procedure(pname: Cardinal; params: PGLint); stdcall;

glFogCoordf: procedure(coord: Single); stdcall;

glFogCoordfv: procedure(coord: PGLfloat); stdcall;

glFogCoordd: procedure(coord: TGLdouble); stdcall;

glFogCoorddv: procedure(coord: PGLdouble); stdcall;

glFogCoordPointer: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

glSecondaryColor3b: procedure(red, green, blue: TGLbyte); stdcall;

glSecondaryColor3bv: procedure(v: PGLbyte); stdcall;

glSecondaryColor3d: procedure(red, green, blue: TGLdouble); stdcall;

glSecondaryColor3dv: procedure(v: PGLdouble); stdcall;

glSecondaryColor3f: procedure(red, green, blue: Single); stdcall;

glSecondaryColor3fv: procedure(v: PGLfloat); stdcall;

glSecondaryColor3i: procedure(red, green, blue: TGLint); stdcall;

glSecondaryColor3iv: procedure(v: PGLint); stdcall;

glSecondaryColor3s: procedure(red, green, blue: TGLshort); stdcall;

glSecondaryColor3sv: procedure(v: PGLshort); stdcall;

glSecondaryColor3ub: procedure(red, green, blue: TGLubyte); stdcall;

glSecondaryColor3ubv: procedure(v: PGLubyte); stdcall;

glSecondaryColor3ui: procedure(red, green, blue: TGLuint); stdcall;

glSecondaryColor3uiv: procedure(v: PGLuint); stdcall;

glSecondaryColor3us: procedure(red, green, blue: TGLushort); stdcall;

glSecondaryColor3usv: procedure(v: PGLushort); stdcall;

glSecondaryColorPointer: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

glWindowPos2d: procedure(x,y : TGLdouble); stdcall;

glWindowPos2dv: procedure(v : PGLdouble); stdcall;

glWindowPos2f: procedure(x,y : Single); stdcall;

glWindowPos2fv: procedure(v : PGLfloat); stdcall;

glWindowPos2i: procedure(x,y : TGLint); stdcall;

glWindowPos2iv: procedure(v : PGLint); stdcall;

glWindowPos2s: procedure(x,y : TGLshort); stdcall;

glWindowPos2sv: procedure(v : PGLshort); stdcall;

glWindowPos3d: procedure(x,y,z : TGLdouble); stdcall;

glWindowPos3dv: procedure(v : PGLdouble); stdcall;

glWindowPos3f: procedure(x,y,z : Single); stdcall;

glWindowPos3fv: procedure(v : PGLfloat); stdcall;

glWindowPos3i: procedure(x,y,z : TGLint); stdcall;

glWindowPos3iv: procedure(v : PGLint); stdcall;

glWindowPos3s: procedure(x,y,z : TGLshort); stdcall;

glWindowPos3sv: procedure(v : PGLshort); stdcall;

glGenQueries: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteQueries: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsQuery: function(id: TGLuint): TGLboolean; stdcall;

glBeginQuery: procedure(target: Cardinal; id: TGLuint); stdcall;

glEndQuery: procedure(target: Cardinal); stdcall;

glGetQueryiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectiv: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectuiv: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glBindBuffer: procedure(target: GLenum; buffer: GLuint); stdcall;

glDeleteBuffers: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

glGenBuffers: procedure(n: GLsizei; buffers: PGLuint); stdcall;

glIsBuffer: function(buffer: GLuint): GLboolean; stdcall;

glBufferData: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

glBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

glGetBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

glMapBuffer: function(target: GLenum; access: GLenum): Pointer; stdcall;

glUnmapBuffer: function(target: GLenum): GLboolean; stdcall;

glGetBufferParameteriv: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetBufferPointerv: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

glBlendEquationSeparate: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glDrawBuffers: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

glStencilOpSeparate: procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

glStencilFuncSeparate: procedure(face, func: Cardinal; ref: TGLint; mask: TGLuint); stdcall;

glStencilMaskSeparate: procedure(face: Cardinal; mask: TGLuint); stdcall;

glAttachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

glBindAttribLocation: procedure(_program: TGLuint; index: TGLuint; const name: PGLChar);

glCompileShader: procedure(shader: TGLuint); stdcall;

glCreateProgram: function(): TGLuint; stdcall;

glCreateShader: function(_type: Cardinal): TGLuint; stdcall;

glDeleteProgram: procedure(_program: TGLuint); stdcall;

glDeleteShader: procedure(shader: TGLuint); stdcall;

glDetachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

glDisableVertexAttribArray: procedure(index: TGLuint); stdcall;

glEnableVertexAttribArray: procedure(index: TGLuint); stdcall;

glGetActiveAttrib: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetActiveUniform: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetAttachedShaders: procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

glGetAttribLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

glGetProgramiv: procedure(_program: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetProgramInfoLog: procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetShaderiv: procedure(shader: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetShaderInfoLog: procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetShaderSource: procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

glGetUniformLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

glGetUniformfv: procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

glGetUniformiv: procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

glGetVertexAttribdv: procedure(index:TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetVertexAttribfv: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetVertexAttribiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribPointerv: procedure(index: TGLuint; pname: Cardinal; _pointer:pointer); stdcall;

glIsProgram: function(_program: TGLuint):TGLboolean; stdcall;

glIsShader: function(shader: TGLuint): TGLboolean; stdcall;

glLinkProgram: procedure(_program: TGLuint); stdcall;

glShaderSource: procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

glUseProgram: procedure(_program: TGLuint); stdcall;

glUniform1f: procedure(location: GLint; v0: Single); stdcall;

glUniform2f: procedure(location: GLint; v0: Single; v1: Single); stdcall;

glUniform3f: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

glUniform4f: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

glUniform1i: procedure(location: GLint; v0: GLint); stdcall;

glUniform2i: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

glUniform3i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

glUniform4i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

glUniform1fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform2fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform3fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform4fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform1iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform2iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform3iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform4iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniformMatrix2fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix3fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix4fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glValidateProgram: procedure(_program: TGLuint); stdcall;

glVertexAttrib1d: procedure(index:TGLuint; x: TGLdouble); stdcall;

glVertexAttrib1dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib1f: procedure(index:TGLuint; x: Single); stdcall;

glVertexAttrib1fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib1s: procedure(index:TGLuint; x: TGLshort); stdcall;

glVertexAttrib1sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib2d: procedure(index:TGLuint; x,y: TGLdouble); stdcall;

glVertexAttrib2dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib2f: procedure(index:TGLuint; x,y: Single); stdcall;

glVertexAttrib2fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib2s: procedure(index:TGLuint; x,y: TGLshort); stdcall;

glVertexAttrib2sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib3d: procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

glVertexAttrib3dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib3f: procedure(index:TGLuint; x,y,z: Single); stdcall;

glVertexAttrib3fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib3s: procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

glVertexAttrib3sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4Nbv: procedure(index:TGLuint; v: PGLbyte); stdcall;

glVertexAttrib4Niv: procedure(index:TGLuint; v: PGLint); stdcall;

glVertexAttrib4Nsv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4Nub: procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

glVertexAttrib4Nubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

glVertexAttrib4Nuiv: procedure(index:TGLuint; v: PGLuint); stdcall;

glVertexAttrib4Nusv: procedure(index:TGLuint; v: PGLushort); stdcall;

glVertexAttrib4bv: procedure(index:TGLuint; v: PGLbyte); stdcall;

glVertexAttrib4d: procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

glVertexAttrib4dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

glVertexAttrib4f: procedure(index:TGLuint; x,y,z,w: Single); stdcall;

glVertexAttrib4fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

glVertexAttrib4iv: procedure(index:TGLuint; v: PGLint); stdcall;

glVertexAttrib4s: procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

glVertexAttrib4sv: procedure(index:TGLuint; v: PGLshort); stdcall;

glVertexAttrib4ubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

glVertexAttrib4uiv: procedure(index:TGLuint; v: PGLuint); stdcall;

glVertexAttrib4usv: procedure(index:TGLuint; v: PGLushort); stdcall;

glVertexAttribPointer: procedure(index:TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

glUniformMatrix2x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix3x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix2x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix4x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix3x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glUniformMatrix4x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

glVertexAttribI1i: procedure(index: TGLuint; x: TGLint); stdcall;

glVertexAttribI2i: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

glVertexAttribI3i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

glVertexAttribI4i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

glVertexAttribI1ui: procedure(index: TGLuint; x: TGLuint); stdcall;

glVertexAttribI2ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

glVertexAttribI3ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

glVertexAttribI4ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

glVertexAttribI1iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI2iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI3iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI4iv: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI1uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI2uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI3uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4bv: procedure(index: TGLuint; v:PGLbyte); stdcall;

glVertexAttribI4sv: procedure(index: TGLuint; v:PGLshort); stdcall;

glVertexAttribI4ubv: procedure(index: TGLuint; v: PGLUbyte); stdcall;

glVertexAttribI4usv: procedure(index: TGLuint; v: PGLushort); stdcall;

glVertexAttribIPointer: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

glGetVertexAttribIiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribIuiv: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glUniform1ui: procedure(location: TGLInt; v0: TGLuint); stdcall;

glUniform2ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

glUniform3ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

glUniform4ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

glUniform1uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform2uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform3uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform4uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glGetUniformuiv: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

glBindFragDataLocation: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

glGetFragDataLocation: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glBeginConditionalRender: procedure(id: TGLuint; mode: Cardinal); stdcall;

glEndConditionalRender: procedure(); stdcall;

glClampColor: procedure(target: Cardinal; clamp: Cardinal); stdcall;

glTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glGetTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glColorMaski: procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

glGetBooleani_v: procedure(target: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

glGetIntegeri_v: procedure(target: Cardinal; index: TGLuint; data: PGLint); stdcall;

glEnablei: procedure(target: Cardinal; index: TGLuint); stdcall;

glDisablei: procedure(target: Cardinal; index: TGLuint); stdcall;

glIsEnabledi: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

glBindBufferRange: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferBase: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glBeginTransformFeedback: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedback: procedure(); stdcall;

glTransformFeedbackVaryings: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

glGetTransformFeedbackVarying: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

glClearBufferiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

glClearBufferuiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

glClearBufferfv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

glClearBufferfi: procedure(buffer: Cardinal; drawbuffer: TGLint; depth: Single; stencil: TGLint); stdcall;

glGetStringi: function(name: Cardinal; index: TGLuint): PGLChar; stdcall;

glDrawArraysInstanced: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstanced: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glTexBuffer: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glPrimitiveRestartIndex: procedure(index: TGLuint); stdcall;

glGetInteger64i_v: procedure(target: Cardinal; index: TGLuint; data: PGLint64); stdcall;

glGetBufferParameteri64v: procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

glProgramParameteri: procedure(_program: TGLuint; pname: Cardinal; value: TGLint); stdcall;

glFramebufferTexture: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint); stdcall;

gluNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

gluNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

gluDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

wglCreateBufferRegionARB: function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

wglDeleteBufferRegionARB: procedure(hRegion: Integer); stdcall;

wglSaveBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

wglRestoreBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

wglGetExtensionsStringARB: function(DC: HDC): PGLChar; stdcall;

wglGetPixelFormatAttribivARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

wglGetPixelFormatAttribfvARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

wglChoosePixelFormatARB: function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

wglMakeContextCurrentARB: function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

wglGetCurrentReadDCARB: function(): HDC; stdcall;

wglCreatePbufferARB: function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

wglGetPbufferDCARB: function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

wglReleasePbufferDCARB: function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

wglDestroyPbufferARB: function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

wglQueryPbufferARB: function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

wglBindTexImageARB: function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

wglReleaseTexImageARB: function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

wglSetPbufferAttribARB: function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

wglCreateContextAttribsARB: function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

wglEnumGpusNV: function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

wglEnumGpuDevicesNV: function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean;

wglCreateAffinityDCNV: function(hGpuList: PHGPUNV): HDC;

wglEnumGpusFromAffinityDCNV: function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

wglDeleteDCNV: function(hdc: HDC): Boolean;

wglSwapIntervalEXT: function(interval : Integer) : BOOL; stdcall;

wglGetSwapIntervalEXT: function: Integer; stdcall;

glSamplePassARB: procedure(pass: Cardinal); stdcall;

glActiveTextureARB: procedure(target: Cardinal); stdcall;

glClientActiveTextureARB: procedure(target: Cardinal); stdcall;

glMultiTexCoord1dARB: procedure(target: Cardinal; s: TGLdouble); stdcall;

glMultiTexCoord1dVARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord1fARB: procedure(target: Cardinal; s: Single); stdcall;

glMultiTexCoord1fVARB: procedure(target: Cardinal; v: Single); stdcall;

glMultiTexCoord1iARB: procedure(target: Cardinal; s: TGLint); stdcall;

glMultiTexCoord1iVARB: procedure(target: Cardinal; v: PGLInt); stdcall;

glMultiTexCoord1sARB: procedure(target: Cardinal; s: TGLshort); stdcall;

glMultiTexCoord1sVARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord2dARB: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

glMultiTexCoord2dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord2fARB: procedure(target: Cardinal; s, t: Single); stdcall;

glMultiTexCoord2fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord2iARB: procedure(target: Cardinal; s, t: TGLint); stdcall;

glMultiTexCoord2ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord2sARB: procedure(target: Cardinal; s, t: TGLshort); stdcall;

glMultiTexCoord2svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord3dARB: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

glMultiTexCoord3dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord3fARB: procedure(target: Cardinal; s, t, r: Single); stdcall;

glMultiTexCoord3fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord3iARB: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

glMultiTexCoord3ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord3sARB: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

glMultiTexCoord3svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glMultiTexCoord4dARB: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

glMultiTexCoord4dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

glMultiTexCoord4fARB: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

glMultiTexCoord4fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

glMultiTexCoord4iARB: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

glMultiTexCoord4ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

glMultiTexCoord4sARB: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

glMultiTexCoord4svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

glLoadTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

glLoadTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

glMultTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

glMultTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

glSampleCoverageARB: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glCompressedTexImage3DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage2DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexImage1DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage3DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage2DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glCompressedTexSubImage1DARB: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

glGetCompressedTexImageARB: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

glPointParameterfARB: procedure(pname: Cardinal; param: Single); stdcall;

glPointParameterfvARB: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glWeightbvARB: procedure(size: TGLint; weights: PGLbyte); stdcall;

glWeightsvARB: procedure(size: TGLint; weights: PGLshort); stdcall;

glWeightivARB: procedure(size: TGLint; weights: PGLint); stdcall;

glWeightfvARB: procedure(size: TGLint; weights: PGLfloat); stdcall;

glWeightdvARB: procedure(size: TGLint; weights: PGLdouble); stdcall;

glWeightubvARB: procedure(size: TGLint; weights: PGLubyte); stdcall;

glWeightusvARB: procedure(size: TGLint; weights: PGLushort); stdcall;

glWeightuivARB: procedure(size: TGLint; weights: PGLuint); stdcall;

glWeightPointerARB: procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

glVertexBlendARB: procedure(count: TGLint); stdcall;

glCurrentPaletteMatrixARB: procedure(index: TGLint); stdcall;

glMatrixIndexubvARB: procedure(size: TGLint; indices: PGLubyte); stdcall;

glMatrixIndexusvARB: procedure(size: TGLint; indices: PGLushort); stdcall;

glMatrixIndexuivARB: procedure(size: TGLint; indices: PGLuint); stdcall;

glMatrixIndexPointerARB: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

glWindowPos2dARB: procedure(x,y : TGLdouble); stdcall;

glWindowPos2dvARB: procedure(v : PGLdouble); stdcall;

glWindowPos2fARB: procedure(x,y : Single); stdcall;

glWindowPos2fvARB: procedure(v : PGLfloat); stdcall;

glWindowPos2iARB: procedure(x,y : TGLint); stdcall;

glWindowPos2ivARB: procedure(v : PGLint); stdcall;

glWindowPos2sARB: procedure(x,y : TGLshort); stdcall;

glWindowPos2svARB: procedure(v : PGLshort); stdcall;

glWindowPos3dARB: procedure(x,y,z : TGLdouble); stdcall;

glWindowPos3dvARB: procedure(v : PGLdouble); stdcall;

glWindowPos3fARB: procedure(x,y,z : Single); stdcall;

glWindowPos3fvARB: procedure(v : PGLfloat); stdcall;

glWindowPos3iARB: procedure(x,y,z : TGLint); stdcall;

glWindowPos3ivARB: procedure(v : PGLint); stdcall;

glWindowPos3sARB: procedure(x,y,z : TGLshort); stdcall;

glWindowPos3svARB: procedure(v : PGLshort); stdcall;

glVertexAttrib1dARB: procedure(index: GLuint; x: GLdouble); stdcall;

glVertexAttrib1dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib1fARB: procedure(index: GLuint; x: Single); stdcall;

glVertexAttrib1fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib1sARB: procedure(index: GLuint; x: GLshort); stdcall;

glVertexAttrib1svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib2dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

glVertexAttrib2dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib2fARB: procedure(index: GLuint; x: Single; y: Single); stdcall;

glVertexAttrib2fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib2sARB: procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

glVertexAttrib2svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib3dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

glVertexAttrib3dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib3fARB: procedure(index: GLuint; x: Single; y: Single; z: Single); stdcall;

glVertexAttrib3fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib3sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

glVertexAttrib3svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4NbvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

glVertexAttrib4NivARB: procedure(index: GLuint; const v: PGLint); stdcall;

glVertexAttrib4NsvARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4NubARB: procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

glVertexAttrib4NubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

glVertexAttrib4NuivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

glVertexAttrib4NusvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

glVertexAttrib4bvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

glVertexAttrib4dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glVertexAttrib4dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

glVertexAttrib4fARB: procedure(index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glVertexAttrib4fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

glVertexAttrib4ivARB: procedure(index: GLuint; const v: PGLint); stdcall;

glVertexAttrib4sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

glVertexAttrib4svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

glVertexAttrib4ubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

glVertexAttrib4uivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

glVertexAttrib4usvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

glVertexAttribPointerARB: procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

glEnableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

glDisableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

glProgramStringARB: procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

glBindProgramARB: procedure(target: GLenum; _program: GLuint); stdcall;

glDeleteProgramsARB: procedure(n: GLsizei; const programs: PGLuint); stdcall;

glGenProgramsARB: procedure(n: GLsizei; programs: PGLuint); stdcall;

glProgramEnvParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glProgramEnvParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

glProgramEnvParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glProgramEnvParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

glProgramLocalParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

glProgramLocalParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

glProgramLocalParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glProgramLocalParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

glGetProgramEnvParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

glGetProgramEnvParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

glGetProgramLocalParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

glGetProgramLocalParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

glGetProgramivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetProgramStringARB: procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

glGetVertexAttribdvARB: procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

glGetVertexAttribfvARB: procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

glGetVertexAttribivARB: procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

glGetVertexAttribPointervARB: procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

glIsProgramARB: function(_program: GLuint): GLboolean; stdcall;

glBindBufferARB: procedure(target: GLenum; buffer: GLuint); stdcall;

glDeleteBuffersARB: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

glGenBuffersARB: procedure(n: GLsizei; buffers: PGLuint); stdcall;

glIsBufferARB: function(buffer: GLuint): GLboolean; stdcall;

glBufferDataARB: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

glBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

glGetBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

glMapBufferARB: function(target: GLenum; access: GLenum): Pointer; stdcall;

glUnmapBufferARB: function(target: GLenum): GLboolean; stdcall;

glGetBufferParameterivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

glGetBufferPointervARB: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

glGenQueriesARB: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteQueriesARB: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsQueryARB: function(id: TGLuint): TGLboolean; stdcall;

glBeginQueryARB: procedure(target: Cardinal; id: TGLuint); stdcall;

glEndQueryARB: procedure(target: Cardinal); stdcall;

glGetQueryivARB: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetQueryObjectuivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glDeleteObjectARB: procedure(obj: GLhandleARB); stdcall;

glGetHandleARB: function(pname: GLenum): GLhandleARB; stdcall;

glDetachObjectARB: procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

glCreateShaderObjectARB: function(shaderType: GLenum): GLhandleARB; stdcall;

glShaderSourceARB: procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

glCompileShaderARB: procedure(shaderObj: GLhandleARB); stdcall;

glCreateProgramObjectARB: function(): GLhandleARB; stdcall;

glAttachObjectARB: procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

glLinkProgramARB: procedure(programObj: GLhandleARB); stdcall;

glUseProgramObjectARB: procedure(programObj: GLhandleARB); stdcall;

glValidateProgramARB: procedure(programObj: GLhandleARB); stdcall;

glUniform1fARB: procedure(location: GLint; v0: Single); stdcall;

glUniform2fARB: procedure(location: GLint; v0: Single; v1: Single); stdcall;

glUniform3fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

glUniform4fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

glUniform1iARB: procedure(location: GLint; v0: GLint); stdcall;

glUniform2iARB: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

glUniform3iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

glUniform4iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

glUniform1fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform2fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform3fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform4fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

glUniform1ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform2ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform3ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniform4ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

glUniformMatrix2fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix3fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glUniformMatrix4fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

glGetObjectParameterfvARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

glGetObjectParameterivARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

glGetInfoLogARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

glGetAttachedObjectsARB: procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

glGetUniformLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

glGetActiveUniformARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetUniformfvARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

glGetUniformivARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

glGetShaderSourceARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

glBindAttribLocationARB: procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

glGetActiveAttribARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

glGetAttribLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

glDrawBuffersARB: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

glClampColorARB: procedure(target: Cardinal; clamp: Cardinal); stdcall;

glDrawArraysInstancedARB: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstancedARB: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glIsRenderbuffer: function(renderbuffer: TGLuint): TGLBoolean; stdcall;

glBindRenderbuffer: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

glDeleteRenderbuffers: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glGenRenderbuffers: procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

glRenderbufferStorage: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glRenderbufferStorageMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetRenderbufferParameteriv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glIsFramebuffer: function(framebuffer: TGLuint): TGLboolean; stdcall;

glBindFramebuffer: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

glDeleteFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glGenFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glCheckFramebufferStatus: function(target: Cardinal): Cardinal; stdcall;

glFramebufferTexture1D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture2D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture3D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

glFramebufferTextureLayer: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

glFramebufferRenderbuffer: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

glGetFramebufferAttachmentParameteriv: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glBlitFramebuffer: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

glGenerateMipmap: procedure(target: Cardinal); stdcall;

glProgramParameteriARB: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

glFramebufferTextureARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

glFramebufferTextureLayerARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

glFramebufferTextureFaceARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

glVertexAttribDivisorARB: procedure(index: TGLuint; divisor: TGLuint); stdcall;

glMapBufferRange: function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

glFlushMappedBufferRange: procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

glTexBufferARB: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glBindVertexArray: procedure(_array: TGLuint); stdcall;

glDeleteVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

glGenVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

glIsVertexArray: function(_array: TGLuint): TGLboolean; stdcall;

glGetUniformIndices: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

glGetActiveUniformsiv: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetActiveUniformName: procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

glGetUniformBlockIndex: function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

glGetActiveUniformBlockiv: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetActiveUniformBlockName: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

glUniformBlockBinding: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

glCopyBufferSubData: procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

glDrawElementsBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

glDrawRangeElementsBaseVertex: procedure(mode: Cardinal; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

glDrawElementsInstancedBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

glMultiDrawElementsBaseVertex: procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

glProvokingVertex: procedure(mode: Cardinal); stdcall;

glFenceSync: function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

glIsSync: function(sync: TGLsync): TGLboolean; stdcall;

glDeleteSync: procedure(sync: TGLsync); stdcall;

glClientWaitSync: function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

glWaitSync: procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

glGetInteger64v: procedure(pname: Cardinal; params: PGLint64); stdcall;

glGetSynciv: procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

glTexImage2DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

glTexImage3DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

glGetMultisamplefv: procedure(pname: Cardinal; index: TGLuint; val: PGLfloat); stdcall;

glSampleMaski: procedure(index: TGLuint; mask: TGLbitfield); stdcall;

glBlendEquationi: procedure(buf: TGLuint; mode: Cardinal); stdcall;

glBlendEquationSeparatei: procedure(buf: TGLuint; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glBlendFunci: procedure(buf: TGLuint; src: Cardinal; dst: Cardinal); stdcall;

glBlendFuncSeparatei: procedure(buf: TGLuint; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

glMinSampleShading: procedure(value: TGLclampf); stdcall;

glBindFragDataLocationIndexed: procedure(_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

glGetFragDataIndex: function(_program: TGLuint; const name: PGLchar): TGLint; stdcall;

glGenSamplers: procedure(count: TGLsizei; samplers: PGLuint); stdcall;

glDeleteSamplers: procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

glIsSampler: function(sampler: TGLuint): TGLboolean; stdcall;

glBindSampler: procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

glSamplerParameteri: procedure(sampler: TGLuint; pname: Cardinal; param: TGLint); stdcall;

glSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

glSamplerParameterf: procedure(sampler: TGLuint; pname: Cardinal; param: Single); stdcall;

glSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLfloat); stdcall;

glSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

glSamplerParameterIuiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLuint); stdcall;

glGetSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetSamplerParameterIfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glQueryCounter: procedure(id: TGLuint; target: Cardinal); stdcall;

glGetQueryObjecti64v: procedure(id: TGLuint; pname: Cardinal; params: PGLint64); stdcall;

glGetQueryObjectui64v: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64); stdcall;

glVertexP2ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP2uiv: procedure(_type: Cardinal; const value: PGLuint ); stdcall;

glVertexP3ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP3uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

glVertexP4ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

glVertexP4uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

glTexCoordP1ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP1uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP2ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP2uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glTexCoordP4ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glTexCoordP4uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glMultiTexCoordP1ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP1uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP2ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP2uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP3ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP3uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glMultiTexCoordP4ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

glMultiTexCoordP4uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

glNormalP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

glNormalP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

glColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glColorP4ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glColorP4uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glSecondaryColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

glSecondaryColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

glVertexAttribP1ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP1uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP2ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP2uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP3ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP3uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glVertexAttribP4ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

glVertexAttribP4uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

glDrawArraysIndirect: procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

glDrawElementsIndirect: procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

glUniform1d: procedure(location: TGLint; x: TGLdouble); stdcall;

glUniform2d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

glUniform3d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glUniform4d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glUniform1dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform2dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform3dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniform4dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glUniformMatrix2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix2x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix2x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix3x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glUniformMatrix4x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glGetUniformdv: procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

glProgramUniform1dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

glProgramUniform2dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

glProgramUniform3dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glProgramUniform4dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glProgramUniform1dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniform4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

glProgramUniformMatrix2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix2x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix2x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix3x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glProgramUniformMatrix4x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

glGetSubroutineUniformLocation: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLint; stdcall;

glGetSubroutineIndex: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLuint; stdcall;

glGetActiveSubroutineUniformiv: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; pname: Cardinal; values: PGLint); stdcall;

glGetActiveSubroutineUniformName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

glGetActiveSubroutineName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

glUniformSubroutinesuiv: procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

glGetUniformSubroutineuiv: procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

glGetProgramStageiv: procedure(_program: TGLuint; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

glPatchParameteri: procedure(pname: Cardinal; value: TGLint); stdcall;

glPatchParameterfv: procedure(pname: Cardinal; const values: PGLfloat); stdcall;

glBindTransformFeedback: procedure(target: Cardinal; id: TGLuint); stdcall;

glDeleteTransformFeedbacks: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glGenTransformFeedbacks: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glIsTransformFeedback: function(id: TGLuint): TGLboolean; stdcall;

glPauseTransformFeedback: procedure(); stdcall;

glResumeTransformFeedback: procedure(); stdcall;

glDrawTransformFeedback: procedure(mode: Cardinal; id: TGLuint); stdcall;

glDrawTransformFeedbackStream: procedure(mode: Cardinal; id: TGLuint; stream: TGLuint); stdcall;

glBeginQueryIndexed: procedure(target: Cardinal; index: TGLuint; id: TGLuint); stdcall;

glEndQueryIndexed: procedure(target: Cardinal; index: TGLuint); stdcall;

glGetQueryIndexediv: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glArrayElementArrayEXT: procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

glAddSwapHintRectWIN: procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

glBlendColorEXT: procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

glPolygonOffsetEXT: procedure(factor, bias: Single); stdcall;

glTexImage3DEXT: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

glTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

glCopyTexImage1DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

glCopyTexImage2DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

glCopyTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

glCopyTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glCopyTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

glGenTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

glDeleteTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

glBindTextureEXT: procedure(target: Cardinal; texture: TGLuint); stdcall;

glPrioritizeTexturesEXT: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

glAreTexturesResidentEXT: function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

glIsTextureEXT: function(texture: TGLuint): TGLboolean; stdcall;

glSampleMaskSGIS: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glSamplePatternSGIS: procedure(pattern: Cardinal); stdcall;

glBlendEquationEXT: procedure(mode: Cardinal); stdcall;

glColorTableEXT: procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

glColorSubTableExt: procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

glGetColorTableEXT: procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: PGLint); stdcall;

glIndexMaterialEXT: procedure(face: Cardinal; mode: Cardinal); stdcall;

glIndexFuncEXT: procedure(func: Cardinal; ref: Single); stdcall;

glLockArraysEXT: procedure(first: TGLint; count: TGLsizei); stdcall;

glUnlockArraysEXT: procedure; stdcall;

glDrawRangeElementsEXT: procedure(mode: Cardinal; start, Aend: TGLuint; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

glBeginSceneEXT: procedure; stdcall;

glEndSceneEXT: procedure; stdcall;

glSecondaryColor3bEXT: procedure(red, green, blue: TGLbyte); stdcall;

glSecondaryColor3bvEXT: procedure(v: PGLbyte); stdcall;

glSecondaryColor3dEXT: procedure(red, green, blue: TGLdouble); stdcall;

glSecondaryColor3dvEXT: procedure(v: PGLdouble); stdcall;

glSecondaryColor3fEXT: procedure(red, green, blue: Single); stdcall;

glSecondaryColor3fvEXT: procedure(v: PGLfloat); stdcall;

glSecondaryColor3iEXT: procedure(red, green, blue: TGLint); stdcall;

glSecondaryColor3ivEXT: procedure(v: PGLint); stdcall;

glSecondaryColor3sEXT: procedure(red, green, blue: TGLshort); stdcall;

glSecondaryColor3svEXT: procedure(v: PGLshort); stdcall;

glSecondaryColor3ubEXT: procedure(red, green, blue: TGLubyte); stdcall;

glSecondaryColor3ubvEXT: procedure(v: PGLubyte); stdcall;

glSecondaryColor3uiEXT: procedure(red, green, blue: TGLuint); stdcall;

glSecondaryColor3uivEXT: procedure(v: PGLuint); stdcall;

glSecondaryColor3usEXT: procedure(red, green, blue: TGLushort); stdcall;

glSecondaryColor3usvEXT: procedure(v: PGLushort); stdcall;

glSecondaryColorPointerEXT: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

glMultiDrawArraysEXT: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

glMultiDrawElementsEXT: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

glFogCoordfEXT: procedure(coord: Single); stdcall;

glFogCoordfvEXT: procedure(coord: PGLfloat); stdcall;

glFogCoorddEXT: procedure(coord: TGLdouble); stdcall;

glFogCoorddvEXT: procedure(coord: PGLdouble); stdcall;

glFogCoordPointerEXT: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

glBlendFuncSeparateEXT: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

glFlushVertexArrayRangeNV: procedure; stdcall;

glVertexArrayRangeNV: procedure(Size: TGLsizei; p: pointer); stdcall;

wglAllocateMemoryNV: function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

wglFreeMemoryNV: procedure(ptr: Pointer); stdcall;

glCombinerParameterfvNV: procedure(pname: Cardinal; params: PGLfloat); stdcall;

glCombinerParameterfNV: procedure(pname: Cardinal; param: Single); stdcall;

glCombinerParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

glCombinerParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

glCombinerInputNV: procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

glCombinerOutputNV: procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

glFinalCombinerInputNV: procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

glGetCombinerInputParameterfvNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

glGetCombinerInputParameterivNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

glGetCombinerOutputParameterfvNV: procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

glGetCombinerOutputParameterivNV: procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

glGetFinalCombinerInputParameterfvNV: procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

glGetFinalCombinerInputParameterivNV: procedure(variable, pname: Cardinal; params: PGLint); stdcall;

glResizeBuffersMESA: procedure; stdcall;

glTbufferMask3DFX: procedure(mask: TGLuint); stdcall;

glSampleMaskEXT: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

glSamplePatternEXT: procedure(pattern: Cardinal); stdcall;

glTextureColorMaskSGIS: procedure(red, green, blue, alpha: TGLboolean); stdcall;

glGenFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

glDeleteFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

glSetFenceNV: procedure(fence: TGLuint; condition: Cardinal); stdcall;

glTestFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

glFinishFenceNV: procedure(fence: TGLuint); stdcall;

glIsFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

glGetFenceivNV: procedure(fence: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glAreProgramsResidentNV: procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

glBindProgramNV: procedure(target: Cardinal; id: TGLuint); stdcall;

glDeleteProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glExecuteProgramNV: procedure(target: Cardinal; id: TGLuint; params: PGLfloat); stdcall;

glGenProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glGetProgramParameterdvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetProgramParameterfvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetProgramivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetProgramStringNV: procedure(id: TGLuint; pname: Cardinal; programIdx: PGLubyte); stdcall;

glGetTrackMatrixivNV: procedure(target: Cardinal; address: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribdvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

glGetVertexAttribfvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

glGetVertexAttribivNV: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribPointervNV: procedure(index: TGLuint; pname: Cardinal; pointer: PGLPointer); stdcall;

glIsProgramNV: function(id: TGLuint): TGLboolean; stdcall;

glLoadProgramNV: procedure(target: Cardinal; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

glProgramParameter4dNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

glProgramParameter4dvNV: procedure(target: Cardinal; index: TGLuint; v: PGLdouble ); stdcall;

glProgramParameter4fNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: Single); stdcall;

glProgramParameter4fvNV: procedure(target: Cardinal; index: TGLuint; v: PGLfloat); stdcall;

glProgramParameters4dvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glProgramParameters4fvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glRequestResidentProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

glTrackMatrixNV: procedure(target: Cardinal; address: TGLuint; matrix: Cardinal; transform: Cardinal); stdcall;

glVertexAttribPointerNV: procedure(index: TGLuint; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

glVertexAttrib1dNV: procedure(index: TGLuint; x: TGLdouble); stdcall;

glVertexAttrib1dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib1fNV: procedure(index: TGLuint; x: Single); stdcall;

glVertexAttrib1fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib1sNV: procedure(index: TGLuint; x: TGLshort); stdcall;

glVertexAttrib1svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib2dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

glVertexAttrib2dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib2fNV: procedure(index: TGLuint; x: Single; y: Single); stdcall;

glVertexAttrib2fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib2sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

glVertexAttrib2svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib3dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

glVertexAttrib3dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib3fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single); stdcall;

glVertexAttrib3fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib3sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

glVertexAttrib3svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib4dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

glVertexAttrib4dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

glVertexAttrib4fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

glVertexAttrib4fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

glVertexAttrib4sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

glVertexAttrib4svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

glVertexAttrib4ubvNV: procedure(index: TGLuint; v: PGLubyte); stdcall;

glVertexAttribs1dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs1fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs1svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs2dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs2fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs2svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs3dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs3fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs3svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs4dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

glVertexAttribs4fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

glVertexAttribs4svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

glVertexAttribs4ubvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

glGenOcclusionQueriesNV: procedure(n: TGLsizei; ids: PGLuint); stdcall;

glDeleteOcclusionQueriesNV: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

glIsOcclusionQueryNV: function(id: TGLuint): TGLboolean; stdcall;

glBeginOcclusionQueryNV: procedure(id: TGLuint); stdcall;

glEndOcclusionQueryNV: procedure; stdcall;

glGetOcclusionQueryivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetOcclusionQueryuivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glPointParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

glPointParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

glActiveStencilFaceEXT: procedure(face: Cardinal); stdcall;

glDrawBuffersATI: procedure(n: GLsizei; const bufs: PGLenum); stdcall;

glPrimitiveRestartNV: procedure(); stdcall;

glPrimitiveRestartIndexNV: procedure(index: TGLuint); stdcall;

glDepthBoundsEXT: procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

glBlendEquationSeparateEXT: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

glIsRenderbufferEXT: function(renderbuffer: TGLuint): TGLboolean; stdcall;

glBindRenderbufferEXT: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

glDeleteRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glGenRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

glRenderbufferStorageEXT: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetRenderbufferParameterivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glIsFramebufferEXT: function(framebuffer: TGLuint): TGLboolean; stdcall;

glBindFramebufferEXT: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

glDeleteFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glGenFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

glCheckFramebufferStatusEXT: function(target: Cardinal): Cardinal; stdcall;

glFramebufferTexture1DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture2DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

glFramebufferTexture3DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

glFramebufferRenderbufferEXT: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

glGetFramebufferAttachmentParameterivEXT: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGenerateMipmapEXT: procedure(target: Cardinal); stdcall;

glStencilClearTagEXT: procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

glBlitFramebufferEXT: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

glRenderbufferStorageMultisampleEXT: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

glGetQueryObjecti64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLint64EXT); stdcall;

glGetQueryObjectui64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

glProgramEnvParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

glProgramLocalParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

glProgramVertexLimitNV: procedure(target: Cardinal; limit: TGLint); stdcall;

glProgramParameteriEXT: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

glFramebufferTextureEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

glFramebufferTextureLayerEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

glFramebufferTextureFaceEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

glVertexAttribI1iEXT: procedure(index: TGLuint; x: TGLint); stdcall;

glVertexAttribI2iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

glVertexAttribI3iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

glVertexAttribI4iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

glVertexAttribI1uiEXT: procedure(index: TGLuint; x: TGLuint); stdcall;

glVertexAttribI2uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

glVertexAttribI3uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

glVertexAttribI4uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

glVertexAttribI1ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI2ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI3ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI4ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

glVertexAttribI1uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI2uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI3uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

glVertexAttribI4bvEXT: procedure(index: TGLuint; v:PGLbyte); stdcall;

glVertexAttribI4svEXT: procedure(index: TGLuint; v:PGLshort); stdcall;

glVertexAttribI4ubvEXT: procedure(index: TGLuint; v: PGLUbyte); stdcall;

glVertexAttribI4usvEXT: procedure(index: TGLuint; v: PGLushort); stdcall;

glVertexAttribIPointerEXT: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

glGetVertexAttribIivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

glGetVertexAttribIuivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

glUniform1uiEXT: procedure(location: TGLInt; v0: TGLuint); stdcall;

glUniform2uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

glUniform3uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

glUniform4uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

glUniform1uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform2uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform3uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glUniform4uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

glGetUniformuivEXT: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

glBindFragDataLocationEXT: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

glGetFragDataLocationEXT: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glDrawArraysInstancedEXT: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

glDrawElementsInstancedEXT: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

glTexBufferEXT: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

glColorMaskIndexedEXT: procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

glGetBooleanIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

glGetIntegerIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLint); stdcall;

glEnableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

glDisableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

glIsEnabledIndexedEXT: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

glBindBufferRangeNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferOffsetNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

glBindBufferBaseNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glTransformFeedbackAttribsNV: procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

glTransformFeedbackVaryingsNV: procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

glBeginTransformFeedbackNV: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedbackNV: procedure(); stdcall;

glGetVaryingLocationNV: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

glGetActiveVaryingNV: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PGLChar); stdcall;

glActiveVaryingNV: procedure(_program: TGLuint; name: PGLChar); stdcall;

glGetTransformFeedbackVaryingNV: procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

glUniformBufferEXT: procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

glGetUniformBufferSizeEXT: function(_program: TGLuint; location: TGLint): TGLint; stdcall;

glGetUniformOffsetEXT: function(_program: TGLuint; location: TGLint): PGLint; stdcall;

glClearColorIiEXT: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

glClearColorIuiEXT: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

glTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glGetTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

glGetTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

glBeginConditionalRenderNV: procedure(id: TGLuint; mode: Cardinal); stdcall;

glEndConditionalRenderNV: procedure(); stdcall;

glBindBufferRangeEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

glBindBufferOffsetEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

glBindBufferBaseEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

glBeginTransformFeedbackEXT: procedure(primitiveMode: Cardinal); stdcall;

glEndTransformFeedbackEXT: procedure(); stdcall;

glTransformFeedbackVaryingsEXT: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

glGetTransformFeedbackVaryingEXT: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

glTessellationFactorAMD: procedure(factor: Single); stdcall;

glTessellationModeAMD: procedure(mode: Cardinal); stdcall;

glCopyImageSubDataNV: procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

glMakeBufferResidentNV: procedure(target: Cardinal; access: Cardinal); stdcall;

glMakeBufferNonResidentNV: procedure(target: Cardinal); stdcall;

glIsBufferResidentNV: function(target: Cardinal): TGLboolean; stdcall;

glMakeNamedBufferResidentNV: procedure(buffer: TGLuint; access: Cardinal); stdcall;

glMakeNamedBufferNonResidentNV: procedure(buffer: TGLuint); stdcall;

glIsNamedBufferResidentNV: function(buffer: TGLuint): TGLboolean; stdcall;

glGetBufferParameterui64vNV: procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

glGetNamedBufferParameterui64vNV: procedure(buffer: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

glGetIntegerui64vNV: procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

glUniformui64NV: procedure(location: TGLint; value: TGLuint64EXT); stdcall;

glUniformui64vNV: procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

glGetUniformui64vNV: procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

glProgramUniformui64NV: procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

glProgramUniformui64vNV: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

glBufferAddressRangeNV: procedure(pname: Cardinal; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

glVertexFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glNormalFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glIndexFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glTexCoordFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glEdgeFlagFormatNV: procedure(stride: TGLsizei); stdcall;

glSecondaryColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glFogCoordFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

glVertexAttribFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

glVertexAttribIFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

glGetIntegerui64i_vNV: procedure(value: Cardinal; index: TGLuint; result: PGLuint64EXT); stdcall;

glFrameTerminatorGREMEDY: procedure(); stdcall;

glStringMarkerGREMEDY: procedure(len: GLsizei; str: PGLChar); stdcall;

vIgnoreOpenGLErrors: Boolean = false;

Description

Functions and Procedures

procedure glAccum(op: TGLuint; value: Single); stdcall; external opengl32;

GL functions and procedures

procedure glAlphaFunc(func: Cardinal; ref: TGLclampf); stdcall; external opengl32;

deprecated;

function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;

deprecated;

procedure glArrayElement(i: TGLint); stdcall; external opengl32;

deprecated;

procedure glBegin(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glBindTexture(target: Cardinal; texture: TGLuint); stdcall; external opengl32;

deprecated;

procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: Single; xmove: Single; ymove: Single; bitmap: Pointer); stdcall; external opengl32;

This item has no description.

procedure glBlendFunc(sfactor: Cardinal; dfactor: Cardinal); stdcall; external opengl32;

deprecated;

procedure glCallList(list: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glCallLists(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall; external opengl32;

deprecated;

procedure glClear(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glClearAccum(red, green, blue, alpha: Single); stdcall; external opengl32;

This item has no description.

procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;

deprecated;

procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;

This item has no description.

procedure glClearIndex(c: Single); stdcall; external opengl32;

This item has no description.

procedure glClearStencil(s: TGLint ); stdcall; external opengl32;

deprecated;

procedure glClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor3f(red, green, blue: Single); stdcall; external opengl32;

deprecated;

procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;

deprecated;

procedure glColor3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;

deprecated;

procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;

deprecated;

procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;

deprecated;

procedure glColor3usv(v: PGLushort); stdcall; external opengl32;

deprecated;

procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;

deprecated;

procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glColor4f(red, green, blue, alpha: Single); stdcall; external opengl32;

deprecated;

procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;

deprecated;

procedure glColor4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor4sv(v: TGLshort); stdcall; external opengl32;

deprecated;

procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;

deprecated;

procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;

deprecated;

procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;

deprecated;

procedure glColor4usv(v: PGLushort); stdcall; external opengl32;

deprecated;

procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;

deprecated;

procedure glColorMaterial(face: Cardinal; mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glColorPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: Cardinal); stdcall; external opengl32;

deprecated;

procedure glCopyTexImage1D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;

deprecated;

procedure glCopyTexImage2D(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;

This item has no description.

procedure glCopyTexSubImage1D(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glCopyTexSubImage2D(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glCullFace(mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;

This item has no description.

procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

deprecated;

procedure glDepthFunc(func: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;

This item has no description.

procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;

This item has no description.

procedure glDisable(cap: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDisableClientState(aarray: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDrawArrays(mode: Cardinal; first: TGLint; count: TGLsizei); stdcall; external opengl32;

deprecated;

procedure glDrawBuffer(mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glDrawElements(mode: Cardinal; count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall; external opengl32;

This item has no description.

procedure glDrawPixels(width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;

deprecated;

procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;

deprecated;

procedure glEnable(cap: Cardinal); stdcall; external opengl32;

deprecated;

procedure glEnableClientState(aarray: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glEnd; stdcall; external opengl32;

deprecated;

procedure glEndList; stdcall; external opengl32;

deprecated;

procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1f(u: Single); stdcall; external opengl32;

deprecated;

procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2f(u, v: Single); stdcall; external opengl32;

deprecated;

procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glEvalMesh1(mode: Cardinal; i1, i2: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalMesh2(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;

deprecated;

procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;

deprecated;

procedure glFeedbackBuffer(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glFinish; stdcall; external opengl32;

deprecated;

procedure glFlush; stdcall; external opengl32;

This item has no description.

procedure glFogf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glFogfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glFogi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glFogiv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glFrontFace(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

This item has no description.

function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;

deprecated;

procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;

deprecated;

procedure glGetBooleanv(pname: Cardinal; params: PGLboolean); stdcall; external opengl32;

This item has no description.

procedure glGetClipPlane(plane: Cardinal; equation: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glGetDoublev(pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

function glGetError: TGLuint; stdcall; external opengl32;

This item has no description.

procedure glGetFloatv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetIntegerv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glGetLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetMapdv(target, query: Cardinal; v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glGetMapfv(target, query: Cardinal; v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetMapiv(target, query: Cardinal; v: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapfv(map: Cardinal; values: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapuiv(map: Cardinal; values: PGLuint); stdcall; external opengl32;

deprecated;

procedure glGetPixelMapusv(map: Cardinal; values: PGLushort); stdcall; external opengl32;

deprecated;

procedure glGetPointerv(pname: Cardinal; var params); stdcall; external opengl32;

deprecated;

procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

This item has no description.

function glGetString(name: Cardinal): PChar; stdcall; external opengl32;

deprecated;

procedure glGetTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glGetTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glGetTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glGetTexImage(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

deprecated;

procedure glGetTexLevelParameterfv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexLevelParameteriv(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glGetTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glGetTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glHint(target, mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glIndexPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glIndexd(c: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glIndexf(c: Single); stdcall; external opengl32;

deprecated;

procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glIndexi(c: TGLint); stdcall; external opengl32;

deprecated;

procedure glIndexiv(c: PGLint); stdcall; external opengl32;

deprecated;

procedure glIndexs(c: TGLshort); stdcall; external opengl32;

deprecated;

procedure glIndexsv(c: PGLshort); stdcall; external opengl32;

deprecated;

procedure glIndexub(c: TGLubyte); stdcall; external opengl32;

deprecated;

procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;

deprecated;

procedure glInitNames; stdcall; external opengl32;

deprecated;

procedure glInterleavedArrays(format: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

function glIsEnabled(cap: Cardinal): TGLboolean; stdcall; external opengl32;

deprecated;

function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;

This item has no description.

function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;

This item has no description.

procedure glLightModelf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glLightModelfv(pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLightModeli(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glLightModeliv(pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glLightf(light, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glLightfv(light, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLighti(light, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glLightiv(light, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;

deprecated;

procedure glLineWidth(width: Single); stdcall; external opengl32;

deprecated;

procedure glListBase(base: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glLoadIdentity; stdcall; external opengl32;

deprecated;

procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glLoadName(name: TGLuint); stdcall; external opengl32;

deprecated;

procedure glLogicOp(opcode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glMap1d(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;

This item has no description.

procedure glMap1f(target: Cardinal; u1, u2: Single; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMap2d(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glMap2f(target: Cardinal; u1, u2: Single; ustride, uorder: TGLint; v1, v2: Single; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glMapGrid1f(un: TGLint; u1, u2: Single); stdcall; external opengl32;

deprecated;

procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glMapGrid2f(un: TGLint; u1, u2: Single; vn: TGLint; v1, v2: Single); stdcall; external opengl32;

deprecated;

procedure glMaterialf(face, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glMaterialfv(face, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glMateriali(face, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glMaterialiv(face, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glMatrixMode(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glNewList(list: TGLuint; mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;

deprecated;

procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;

deprecated;

procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glNormal3f(nx, ny, nz: Single); stdcall; external opengl32;

deprecated;

procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;

deprecated;

procedure glNormal3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;

deprecated;

procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glNormalPointer(atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glPassThrough(token: Single); stdcall; external opengl32;

deprecated;

procedure glPixelMapfv(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glPixelMapuiv(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;

deprecated;

procedure glPixelMapusv(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;

deprecated;

procedure glPixelStoref(pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glPixelStorei(pname: Cardinal; param: TGLint); stdcall; external opengl32;

This item has no description.

procedure glPixelTransferf(pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glPixelTransferi(pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glPixelZoom(xfactor, yfactor: Single); stdcall; external opengl32;

deprecated;

procedure glPointSize(size: Single); stdcall; external opengl32;

deprecated;

procedure glPolygonMode(face, mode: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glPolygonOffset(factor, units: Single); stdcall; external opengl32;

This item has no description.

procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;

This item has no description.

procedure glPopAttrib; stdcall; external opengl32;

deprecated;

procedure glPopClientAttrib; stdcall; external opengl32;

deprecated;

procedure glPopMatrix; stdcall; external opengl32;

deprecated;

procedure glPopName; stdcall; external opengl32;

deprecated;

procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;

deprecated;

procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;

deprecated;

procedure glPushMatrix; stdcall; external opengl32;

deprecated;

procedure glPushName(name: TGLuint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos2f(x, y: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos3f(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRasterPos4f(x, y, z, w: Single); stdcall; external opengl32;

deprecated;

procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glReadBuffer(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glRectf(x1, y1, x2, y2: Single); stdcall; external opengl32;

deprecated;

procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;

deprecated;

procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;

deprecated;

procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;

deprecated;

procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;

deprecated;

function glRenderMode(mode: Cardinal): TGLint; stdcall; external opengl32;

deprecated;

procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glRotatef(angle, x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glScalef(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

deprecated;

procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;

This item has no description.

procedure glShadeModel(mode: Cardinal); stdcall; external opengl32;

deprecated;

procedure glStencilFunc(func: Cardinal; ref: TGLint; mask: TGLuint); stdcall; external opengl32;

deprecated;

procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;

This item has no description.

procedure glStencilOp(fail, zfail, zpass: Cardinal); stdcall; external opengl32;

This item has no description.

procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord1f(s: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord2f(s, t: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord3f(s, t, r: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexCoord4f(s, t, r, q: Single); stdcall; external opengl32;

deprecated;

procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glTexCoordPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glTexEnvf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glTexEnvfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexEnvi(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexEnviv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexGend(coord, pname: Cardinal; param: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexGendv(coord, pname: Cardinal; params: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glTexGenf(coord, pname: Cardinal; param: Single); stdcall; external opengl32;

deprecated;

procedure glTexGenfv(coord, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glTexGeni(coord, pname: Cardinal; param: TGLint); stdcall; external opengl32;

deprecated;

procedure glTexGeniv(coord, pname: Cardinal; params: PGLint); stdcall; external opengl32;

deprecated;

procedure glTexImage1D(target: Cardinal; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

deprecated;

procedure glTexImage2D(target: Cardinal; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: Cardinal; Pixels:Pointer); stdcall; external opengl32;

This item has no description.

procedure glTexParameterf(target, pname: Cardinal; param: Single); stdcall; external opengl32;

This item has no description.

procedure glTexParameterfv(target, pname: Cardinal; params: PGLfloat); stdcall; external opengl32;

This item has no description.

procedure glTexParameteri(target, pname: Cardinal; param: TGLint); stdcall; external opengl32;

This item has no description.

procedure glTexParameteriv(target, pname: Cardinal; params: PGLint); stdcall; external opengl32;

This item has no description.

procedure glTexSubImage1D(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glTexSubImage2D(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall; external opengl32;

This item has no description.

procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;

This item has no description.

procedure glTranslatef(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex2f(x, y: Single); stdcall; external opengl32;

deprecated;

procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex2iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex3f(x, y, z: Single); stdcall; external opengl32;

deprecated;

procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex3iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;

deprecated;

procedure glVertex4f(x, y, z, w: Single); stdcall; external opengl32;

deprecated;

procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;

deprecated;

procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;

deprecated;

procedure glVertex4iv(v: PGLint); stdcall; external opengl32;

deprecated;

procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;

deprecated;

procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;

deprecated;

procedure glVertexPointer(size: TGLint; atype: Cardinal; stride: TGLsizei; data: pointer); stdcall; external opengl32;

deprecated;

procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;

deprecated;

function gluErrorString(errCode: Cardinal): PGLChar; stdcall; external glu32;

GLU utility functions and procedures

function gluGetString(name: Cardinal): PGLChar; stdcall; external glu32;

This item has no description.

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild1DMipmaps(target: Cardinal; components, width: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild2DMipmaps(target: Cardinal; components, width, height: TGLint; format, atype: Cardinal; data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

This item has no description.

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

This item has no description.

function gluNewTess: PGLUtesselator; stdcall; external glu32;

This item has no description.

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

This item has no description.

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

This item has no description.

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: PGLfloat); stdcall; external glu32;

This item has no description.

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; value: PGLdouble); stdcall; external glu32;

This item has no description.

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

This item has no description.

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; value: Single); stdcall; external glu32;

This item has no description.

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

This item has no description.

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

This item has no description.

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; value: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;

This item has no description.

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

This item has no description.

function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;

This item has no description.

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

This item has no description.

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

This item has no description.

function wglGetCurrentDC: HDC; stdcall; external opengl32;

This item has no description.

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

This item has no description.

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;

This item has no description.

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;

This item has no description.

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;

This item has no description.

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;

This item has no description.

function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';

This item has no description.

function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';

This item has no description.

function GLGetProcAddress(ProcName: PGLChar): Pointer;

——————————————————————————

procedure ReadExtensions;

This item has no description.

procedure ReadImplementationProperties;

This item has no description.

procedure ReadWGLExtensions;

This item has no description.

procedure ReadWGLImplementationProperties;

This item has no description.

procedure CloseOpenGL;

This item has no description.

function InitOpenGL: Boolean;

This item has no description.

function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;

This item has no description.

function IsOpenGLInitialized: Boolean;

This item has no description.

procedure UnloadOpenGL;

compatibility routines

function LoadOpenGL: Boolean;

This item has no description.

function LoadOpenGLFromLibrary(const GLName, GLUName: String): Boolean;

This item has no description.

function IsOpenGLLoaded: Boolean;

This item has no description.

function IsMesaGL: Boolean;

This item has no description.

procedure TrimAndSplitVersionString(Buffer: String; out Max, Min: Integer);

This item has no description.

function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;

This item has no description.

function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;

This item has no description.

procedure CheckOpenGLError;

This item has no description.

procedure ClearGLError;

Gets the oldest error and tries to clear the error queue

procedure RaiseOpenGLError(const msg : String);

Clears all pending OpenGL errors

Types

GLbitfield = UINT;

This item has no description.

GLboolean = BYTEBOOL;

This item has no description.

GLbyte = ShortInt;

This item has no description.

GLclampd = Double;

This item has no description.

GLclampf = Single;

This item has no description.

GLdouble = Double;

This item has no description.

GLenum = Cardinal;

This item has no description.

GLfloat = Single;

This item has no description.

GLhandleARB = Cardinal;

This item has no description.

GLint = Integer;

This item has no description.

GLint64 = Int64;

This item has no description.

GLint64EXT = Int64;

This item has no description.

GLshort = SmallInt;

This item has no description.

GLsizei = Integer;

This item has no description.

GLubyte = Byte;

This item has no description.

GLuint = UINT;

This item has no description.

GLuint64 = UInt64;

This item has no description.

GLuint64EXT = UInt64;

This item has no description.

GLushort = Word;

This item has no description.

HGPUNV = THandle;

This item has no description.

HPBUFFERARB = Integer;

This item has no description.

HVIDEOINPUTDEVICENV = THandle;

This item has no description.

PGLbitfield = ˆTGLbitfield;

This item has no description.

PGLboolean = ˆTGLboolean;

This item has no description.

PGLbyte = ˆTGLbyte;

This item has no description.

PGLChar = PAnsiChar;

This item has no description.

PGLclampd = ˆTGLclampd;

This item has no description.

PGLclampf = ˆTGLclampf;

This item has no description.

PGLdouble = System.PDouble;

This item has no description.

PGLenum = ˆCardinal;

This item has no description.

PGLfloat = System.PSingle;

This item has no description.

PGLhandleARB = ˆGLhandleARB;

This item has no description.

PGLint = ˆInteger;

This item has no description.

PGLint64 = ˆTGLint64;

This item has no description.

PGLint64EXT = ˆTGLint64EXT;

This item has no description.

PGLintptr = ˆTGLintptr;

This item has no description.

PGLPCharArray = ˆPGLChar;

This item has no description.

PGLPointer = ˆPointer;

This item has no description.

PGLshort = ˆTGLshort;

This item has no description.

PGLsizei = ˆTGLsizei;

This item has no description.

PGLubyte = System.PByte;

This item has no description.

PGLuint = ˆTGLuint;

This item has no description.

PGLuint64 = ˆTGLuint64;

This item has no description.

PGLuint64EXT = ˆTGLuint64EXT;

This item has no description.

PGLUNurbs = ˆTGLUNurbs;

This item has no description.

PGLUNurbsObj = PGLUNurbs;

This item has no description.

PGLUQuadric = ˆTGLUQuadric;

This item has no description.

PGLUQuadricObj = PGLUQuadric;

This item has no description.

PGLushort = System.PWord;

This item has no description.

PGLUTesselator = ˆTGLUTesselator;

This item has no description.

PGLUTesselatorObj = PGLUTesselator;

This item has no description.

PGLUTriangulatorObj = PGLUTesselator;

This item has no description.

PGLvoid = Pointer;

This item has no description.

PGPUDEVICE = ˆTGPUDEVICE;

This item has no description.

PHGPUNV = ˆHGPUNV;

—————————- OpenGL Utility (GLU) types ——————–

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

This item has no description.

PWGLSwap = ˆTWGLSwap;

This item has no description.

TGLbitfield = UINT;

This item has no description.

TGLboolean = BYTEBOOL;

This item has no description.

TGLbyte = ShortInt;

This item has no description.

TGLclampd = Double;

This item has no description.

TGLclampf = Single;

This item has no description.

TGLdouble = Double;

This item has no description.

TGLEnum = Cardinal;

This item has no description.

TGLfloat = Single;

This item has no description.

TGLint = Integer;

This item has no description.

TGLint64 = Int64;

This item has no description.

TGLint64EXT = Int64;

This item has no description.

TGLintptr = NativeInt;

the size of these depend on platform (32bit or 64bit)

TGLshort = SmallInt;

This item has no description.

TGLsizei = Integer;

This item has no description.

TGLsizeiptr = NativeInt;

This item has no description.

TGLString = AnsiString;

This item has no description.

TGLsync = NativeInt;

This item has no description.

TGLubyte = Byte;

This item has no description.

TGLuint = UINT;

This item has no description.

TGLuint64 = UInt64;

This item has no description.

TGLuint64EXT = UInt64;

This item has no description.

TGLUNurbsErrorProc = procedure(errorCode: Cardinal); stdcall;

GLUNurbsCallback

TGLUNurbsObj = TGLUNurbs;

backwards compatibility

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

GLUQuadricCallback

TGLUQuadricObj = TGLUQuadric;

This item has no description.

TGLushort = Word;

This item has no description.

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

GLUTessCallback

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

This item has no description.

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

This item has no description.

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

This item has no description.

TGLUTesselatorObj = TGLUTesselator;

This item has no description.

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

This item has no description.

TGLUTessEndProc = procedure; stdcall;

This item has no description.

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

This item has no description.

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

This item has no description.

TGLUTriangulatorObj = TGLUTesselator;

This item has no description.

TRCOptions = set of ( opDoubleBuffered, opGDI, opStereo );

This item has no description.

TVector4p = array[0..3] of Pointer;

This item has no description.

TWGLSwap = _WGLSWAP;

This item has no description.

WGLSWAP = _WGLSWAP;

This item has no description.

Constants

opengl32 = 'OpenGL32.dll';

This item has no description.

glu32 = 'GLU32.dll';

This item has no description.

libEGL = 'libEGL.dll';

This item has no description.

libGLES2 = 'libGLESv2.dll';

This item has no description.

GL_DEPTH_BUFFER_BIT = $00000100;

AttribMask

GL_STENCIL_BUFFER_BIT = $00000400;

This item has no description.

GL_COLOR_BUFFER_BIT = $00004000;

This item has no description.

GL_TRUE = 1;

This item has no description.

GL_FALSE = 0;

This item has no description.

GL_POINTS = $0000;

BeginMode

GL_LINES = $0001;

This item has no description.

GL_LINE_LOOP = $0002;

This item has no description.

GL_LINE_STRIP = $0003;

This item has no description.

GL_TRIANGLES = $0004;

This item has no description.

GL_TRIANGLE_STRIP = $0005;

This item has no description.

GL_TRIANGLE_FAN = $0006;

This item has no description.

GL_NEVER = $0200;

AlphaFunction

GL_LESS = $0201;

This item has no description.

GL_EQUAL = $0202;

This item has no description.

GL_LEQUAL = $0203;

This item has no description.

GL_GREATER = $0204;

This item has no description.

GL_NOTEQUAL = $0205;

This item has no description.

GL_GEQUAL = $0206;

This item has no description.

GL_ALWAYS = $0207;

This item has no description.

GL_ZERO = 0;

BlendingFactorDest

GL_ONE = 1;

This item has no description.

GL_SRC_COLOR = $0300;

This item has no description.

GL_ONE_MINUS_SRC_COLOR = $0301;

This item has no description.

GL_SRC_ALPHA = $0302;

This item has no description.

GL_ONE_MINUS_SRC_ALPHA = $0303;

This item has no description.

GL_DST_ALPHA = $0304;

This item has no description.

GL_ONE_MINUS_DST_ALPHA = $0305;

This item has no description.

GL_DST_COLOR = $0306;

BlendingFactorSrc

GL_ONE_MINUS_DST_COLOR = $0307;

This item has no description.

GL_SRC_ALPHA_SATURATE = $0308;

This item has no description.

GL_NONE = 0;

DrawBufferMode

GL_FRONT_LEFT = $0400;

This item has no description.

GL_FRONT_RIGHT = $0401;

This item has no description.

GL_BACK_LEFT = $0402;

This item has no description.

GL_BACK_RIGHT = $0403;

This item has no description.

GL_FRONT = $0404;

This item has no description.

GL_BACK = $0405;

This item has no description.

GL_LEFT = $0406;

This item has no description.

GL_RIGHT = $0407;

This item has no description.

GL_FRONT_AND_BACK = $0408;

This item has no description.

GL_NO_ERROR = 0;

ErrorCode

GL_INVALID_ENUM = $0500;

This item has no description.

GL_INVALID_VALUE = $0501;

This item has no description.

GL_INVALID_OPERATION = $0502;

This item has no description.

GL_OUT_OF_MEMORY = $0505;

This item has no description.

GL_CW = $0900;

FrontFaceDirection

GL_CCW = $0901;

This item has no description.

GL_POINT_SIZE = $0B11;

GetPName

GL_POINT_SIZE_RANGE = $0B12;

This item has no description.

GL_POINT_SIZE_GRANULARITY = $0B13;

This item has no description.

GL_LINE_SMOOTH = $0B20;

This item has no description.

GL_LINE_WIDTH = $0B21;

This item has no description.

GL_LINE_WIDTH_RANGE = $0B22;

This item has no description.

GL_LINE_WIDTH_GRANULARITY = $0B23;

This item has no description.

GL_POLYGON_SMOOTH = $0B41;

This item has no description.

GL_CULL_FACE = $0B44;

This item has no description.

GL_CULL_FACE_MODE = $0B45;

This item has no description.

GL_FRONT_FACE = $0B46;

This item has no description.

GL_DEPTH_RANGE = $0B70;

This item has no description.

GL_DEPTH_TEST = $0B71;

This item has no description.

GL_DEPTH_WRITEMASK = $0B72;

This item has no description.

GL_DEPTH_CLEAR_VALUE = $0B73;

This item has no description.

GL_DEPTH_FUNC = $0B74;

This item has no description.

GL_STENCIL_TEST = $0B90;

This item has no description.

GL_STENCIL_CLEAR_VALUE = $0B91;

This item has no description.

GL_STENCIL_FUNC = $0B92;

This item has no description.

GL_STENCIL_VALUE_MASK = $0B93;

This item has no description.

GL_STENCIL_FAIL = $0B94;

This item has no description.

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

This item has no description.

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

This item has no description.

GL_STENCIL_REF = $0B97;

This item has no description.

GL_STENCIL_WRITEMASK = $0B98;

This item has no description.

GL_VIEWPORT = $0BA2;

This item has no description.

GL_DITHER = $0BD0;

This item has no description.

GL_BLEND_DST = $0BE0;

This item has no description.

GL_BLEND_SRC = $0BE1;

This item has no description.

GL_BLEND = $0BE2;

This item has no description.

GL_LOGIC_OP_MODE = $0BF0;

This item has no description.

GL_COLOR_LOGIC_OP = $0BF2;

This item has no description.

GL_DRAW_BUFFER = $0C01;

This item has no description.

GL_READ_BUFFER = $0C02;

This item has no description.

GL_SCISSOR_BOX = $0C10;

This item has no description.

GL_SCISSOR_TEST = $0C11;

This item has no description.

GL_COLOR_CLEAR_VALUE = $0C22;

This item has no description.

GL_COLOR_WRITEMASK = $0C23;

This item has no description.

GL_DOUBLEBUFFER = $0C32;

This item has no description.

GL_STEREO = $0C33;

This item has no description.

GL_LINE_SMOOTH_HINT = $0C52;

This item has no description.

GL_POLYGON_SMOOTH_HINT = $0C53;

This item has no description.

GL_UNPACK_SWAP_BYTES = $0CF0;

This item has no description.

GL_UNPACK_LSB_FIRST = $0CF1;

This item has no description.

GL_UNPACK_ROW_LENGTH = $0CF2;

This item has no description.

GL_UNPACK_SKIP_ROWS = $0CF3;

This item has no description.

GL_UNPACK_SKIP_PIXELS = $0CF4;

This item has no description.

GL_UNPACK_ALIGNMENT = $0CF5;

This item has no description.

GL_PACK_SWAP_BYTES = $0D00;

This item has no description.

GL_PACK_LSB_FIRST = $0D01;

This item has no description.

GL_PACK_ROW_LENGTH = $0D02;

This item has no description.

GL_PACK_SKIP_ROWS = $0D03;

This item has no description.

GL_PACK_SKIP_PIXELS = $0D04;

This item has no description.

GL_PACK_ALIGNMENT = $0D05;

This item has no description.

GL_MAX_TEXTURE_SIZE = $0D33;

This item has no description.

GL_MAX_VIEWPORT_DIMS = $0D3A;

This item has no description.

GL_SUBPIXEL_BITS = $0D50;

This item has no description.

GL_TEXTURE_1D = $0DE0;

This item has no description.

GL_TEXTURE_2D = $0DE1;

This item has no description.

GL_POLYGON_OFFSET_UNITS = $2A00;

This item has no description.

GL_POLYGON_OFFSET_POINT = $2A01;

This item has no description.

GL_POLYGON_OFFSET_LINE = $2A02;

This item has no description.

GL_POLYGON_OFFSET_FILL = $8037;

This item has no description.

GL_POLYGON_OFFSET_FACTOR = $8038;

This item has no description.

GL_TEXTURE_BINDING_1D = $8068;

This item has no description.

GL_TEXTURE_BINDING_2D = $8069;

This item has no description.

GL_TEXTURE_WIDTH = $1000;

GetTextureParameter

GL_TEXTURE_HEIGHT = $1001;

This item has no description.

GL_TEXTURE_INTERNAL_FORMAT = $1003;

This item has no description.

GL_TEXTURE_BORDER_COLOR = $1004;

This item has no description.

GL_TEXTURE_BORDER = $1005;

This item has no description.

GL_TEXTURE_RED_SIZE = $805C;

This item has no description.

GL_TEXTURE_GREEN_SIZE = $805D;

This item has no description.

GL_TEXTURE_BLUE_SIZE = $805E;

This item has no description.

GL_TEXTURE_ALPHA_SIZE = $805F;

This item has no description.

GL_DONT_CARE = $1100;

HintMode

GL_FASTEST = $1101;

This item has no description.

GL_NICEST = $1102;

This item has no description.

GL_BYTE = $1400;

DataType

GL_UNSIGNED_BYTE = $1401;

This item has no description.

GL_SHORT = $1402;

This item has no description.

GL_UNSIGNED_SHORT = $1403;

This item has no description.

GL_INT = $1404;

This item has no description.

GL_UNSIGNED_INT = $1405;

This item has no description.

GL_FLOAT = $1406;

This item has no description.

GL_DOUBLE = $140A;

This item has no description.

GL_CLEAR = $1500;

LogicOp

GL_AND = $1501;

This item has no description.

GL_AND_REVERSE = $1502;

This item has no description.

GL_COPY = $1503;

This item has no description.

GL_AND_INVERTED = $1504;

This item has no description.

GL_NOOP = $1505;

This item has no description.

GL_XOR = $1506;

This item has no description.

GL_OR = $1507;

This item has no description.

GL_NOR = $1508;

This item has no description.

GL_EQUIV = $1509;

This item has no description.

GL_INVERT = $150A;

This item has no description.

GL_OR_REVERSE = $150B;

This item has no description.

GL_COPY_INVERTED = $150C;

This item has no description.

GL_OR_INVERTED = $150D;

This item has no description.

GL_NAND = $150E;

This item has no description.

GL_SET = $150F;

This item has no description.

GL_TEXTURE = $1702;

MatrixMode (for gl3.h, FBO attachment type)

GL_COLOR = $1800;

PixelCopyType

GL_DEPTH = $1801;

This item has no description.

GL_STENCIL = $1802;

This item has no description.

GL_STENCIL_INDEX = $1901;

PixelFormat

GL_DEPTH_COMPONENT = $1902;

This item has no description.

GL_RED = $1903;

This item has no description.

GL_GREEN = $1904;

This item has no description.

GL_BLUE = $1905;

This item has no description.

GL_ALPHA = $1906;

This item has no description.

GL_RGB = $1907;

This item has no description.

GL_RGBA = $1908;

This item has no description.

GL_POINT = $1B00;

PolygonMode

GL_LINE = $1B01;

This item has no description.

GL_FILL = $1B02;

This item has no description.

GL_KEEP = $1E00;

StencilOp

GL_REPLACE = $1E01;

This item has no description.

GL_INCR = $1E02;

This item has no description.

GL_DECR = $1E03;

This item has no description.

GL_VENDOR = $1F00;

StringName

GL_RENDERER = $1F01;

This item has no description.

GL_VERSION = $1F02;

This item has no description.

GL_EXTENSIONS = $1F03;

This item has no description.

GL_NEAREST = $2600;

TextureMagFilter

GL_LINEAR = $2601;

This item has no description.

GL_NEAREST_MIPMAP_NEAREST = $2700;

TextureMinFilter

GL_LINEAR_MIPMAP_NEAREST = $2701;

This item has no description.

GL_NEAREST_MIPMAP_LINEAR = $2702;

This item has no description.

GL_LINEAR_MIPMAP_LINEAR = $2703;

This item has no description.

GL_TEXTURE_MAG_FILTER = $2800;

TextureParameterName

GL_TEXTURE_MIN_FILTER = $2801;

This item has no description.

GL_TEXTURE_WRAP_S = $2802;

This item has no description.

GL_TEXTURE_WRAP_T = $2803;

This item has no description.

GL_PROXY_TEXTURE_1D = $8063;

TextureTarget

GL_PROXY_TEXTURE_2D = $8064;

This item has no description.

GL_REPEAT = $2901;

TextureWrapMode

GL_R3_G3_B2 = $2A10;

PixelInternalFormat

GL_RGB4 = $804F;

This item has no description.

GL_RGB5 = $8050;

This item has no description.

GL_RGB8 = $8051;

This item has no description.

GL_RGB10 = $8052;

This item has no description.

GL_RGB12 = $8053;

This item has no description.

GL_RGB16 = $8054;

This item has no description.

GL_RGBA2 = $8055;

This item has no description.

GL_RGBA4 = $8056;

This item has no description.

GL_RGB5_A1 = $8057;

This item has no description.

GL_RGBA8 = $8058;

This item has no description.

GL_RGB10_A2 = $8059;

This item has no description.

GL_RGBA12 = $805A;

This item has no description.

GL_RGBA16 = $805B;

This item has no description.

GL_ACCUM = $0100;

This item has no description.

GL_LOAD = $0101;

This item has no description.

GL_RETURN = $0102;

This item has no description.

GL_MULT = $0103;

This item has no description.

GL_ADD = $0104;

This item has no description.

GL_CURRENT_BIT = $00000001;

This item has no description.

GL_POINT_BIT = $00000002;

This item has no description.

GL_LINE_BIT = $00000004;

This item has no description.

GL_POLYGON_BIT = $00000008;

This item has no description.

GL_POLYGON_STIPPLE_BIT = $00000010;

This item has no description.

GL_PIXEL_MODE_BIT = $00000020;

This item has no description.

GL_LIGHTING_BIT = $00000040;

This item has no description.

GL_FOG_BIT = $00000080;

This item has no description.

GL_ACCUM_BUFFER_BIT = $00000200;

This item has no description.

GL_VIEWPORT_BIT = $00000800;

This item has no description.

GL_TRANSFORM_BIT = $00001000;

This item has no description.

GL_ENABLE_BIT = $00002000;

This item has no description.

GL_HINT_BIT = $00008000;

This item has no description.

GL_EVAL_BIT = $00010000;

This item has no description.

GL_LIST_BIT = $00020000;

This item has no description.

GL_TEXTURE_BIT = $00040000;

This item has no description.

GL_SCISSOR_BIT = $00080000;

This item has no description.

GL_ALL_ATTRIB_BITS = $000FFFFF;

This item has no description.

GL_QUADS = $0007;

This item has no description.

GL_QUAD_STRIP = $0008;

This item has no description.

GL_POLYGON = $0009;

This item has no description.

GL_CLIP_PLANE0 = $3000;

This item has no description.

GL_CLIP_PLANE1 = $3001;

This item has no description.

GL_CLIP_PLANE2 = $3002;

This item has no description.

GL_CLIP_PLANE3 = $3003;

This item has no description.

GL_CLIP_PLANE4 = $3004;

This item has no description.

GL_CLIP_PLANE5 = $3005;

This item has no description.

GL_2_BYTES = $1407;

This item has no description.

GL_3_BYTES = $1408;

This item has no description.

GL_4_BYTES = $1409;

This item has no description.

GL_AUX0 = $0409;

This item has no description.

GL_AUX1 = $040A;

This item has no description.

GL_AUX2 = $040B;

This item has no description.

GL_AUX3 = $040C;

This item has no description.

GL_STACK_OVERFLOW = $0503;

This item has no description.

GL_STACK_UNDERFLOW = $0504;

This item has no description.

GL_2D = $0600;

This item has no description.

GL_3D = $0601;

This item has no description.

GL_3D_COLOR = $0602;

This item has no description.

GL_3D_COLOR_TEXTURE = $0603;

This item has no description.

GL_4D_COLOR_TEXTURE = $0604;

This item has no description.

GL_PASS_THROUGH_TOKEN = $0700;

This item has no description.

GL_POINT_TOKEN = $0701;

This item has no description.

GL_LINE_TOKEN = $0702;

This item has no description.

GL_POLYGON_TOKEN = $0703;

This item has no description.

GL_BITMAP_TOKEN = $0704;

This item has no description.

GL_DRAW_PIXEL_TOKEN = $0705;

This item has no description.

GL_COPY_PIXEL_TOKEN = $0706;

This item has no description.

GL_LINE_RESET_TOKEN = $0707;

This item has no description.

GL_EXP = $0800;

This item has no description.

GL_EXP2 = $0801;

This item has no description.

GL_COEFF = $0A00;

This item has no description.

GL_ORDER = $0A01;

This item has no description.

GL_DOMAIN = $0A02;

This item has no description.

GL_CURRENT_COLOR = $0B00;

This item has no description.

GL_CURRENT_INDEX = $0B01;

This item has no description.

GL_CURRENT_NORMAL = $0B02;

This item has no description.

GL_CURRENT_TEXTURE_COORDS = $0B03;

This item has no description.

GL_CURRENT_RASTER_COLOR = $0B04;

This item has no description.

GL_CURRENT_RASTER_INDEX = $0B05;

This item has no description.

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06;

This item has no description.

GL_CURRENT_RASTER_POSITION = $0B07;

This item has no description.

GL_CURRENT_RASTER_POSITION_VALID = $0B08;

This item has no description.

GL_CURRENT_RASTER_DISTANCE = $0B09;

This item has no description.

GL_POINT_SMOOTH = $0B10;

This item has no description.

GL_LINE_STIPPLE = $0B24;

This item has no description.

GL_LINE_STIPPLE_PATTERN = $0B25;

This item has no description.

GL_LINE_STIPPLE_REPEAT = $0B26;

This item has no description.

GL_LIST_MODE = $0B30;

This item has no description.

GL_MAX_LIST_NESTING = $0B31;

This item has no description.

GL_LIST_BASE = $0B32;

This item has no description.

GL_LIST_INDEX = $0B33;

This item has no description.

GL_POLYGON_MODE = $0B40;

This item has no description.

GL_POLYGON_STIPPLE = $0B42;

This item has no description.

GL_EDGE_FLAG = $0B43;

This item has no description.

GL_LIGHTING = $0B50;

This item has no description.

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51;

This item has no description.

GL_LIGHT_MODEL_TWO_SIDE = $0B52;

This item has no description.

GL_LIGHT_MODEL_AMBIENT = $0B53;

This item has no description.

GL_SHADE_MODEL = $0B54;

This item has no description.

GL_COLOR_MATERIAL_FACE = $0B55;

This item has no description.

GL_COLOR_MATERIAL_PARAMETER = $0B56;

This item has no description.

GL_COLOR_MATERIAL = $0B57;

This item has no description.

GL_FOG = $0B60;

This item has no description.

GL_FOG_INDEX = $0B61;

This item has no description.

GL_FOG_DENSITY = $0B62;

This item has no description.

GL_FOG_START = $0B63;

This item has no description.

GL_FOG_END = $0B64;

This item has no description.

GL_FOG_MODE = $0B65;

This item has no description.

GL_FOG_COLOR = $0B66;

This item has no description.

GL_ACCUM_CLEAR_VALUE = $0B80;

This item has no description.

GL_MATRIX_MODE = $0BA0;

This item has no description.

GL_NORMALIZE = $0BA1;

This item has no description.

GL_MODELVIEW_STACK_DEPTH = $0BA3;

This item has no description.

GL_PROJECTION_STACK_DEPTH = $0BA4;

This item has no description.

GL_TEXTURE_STACK_DEPTH = $0BA5;

This item has no description.

GL_MODELVIEW_MATRIX = $0BA6;

This item has no description.

GL_PROJECTION_MATRIX = $0BA7;

This item has no description.

GL_TEXTURE_MATRIX = $0BA8;

This item has no description.

GL_ATTRIB_STACK_DEPTH = $0BB0;

This item has no description.

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1;

This item has no description.

GL_ALPHA_TEST = $0BC0;

This item has no description.

GL_ALPHA_TEST_FUNC = $0BC1;

This item has no description.

GL_ALPHA_TEST_REF = $0BC2;

This item has no description.

GL_INDEX_LOGIC_OP = $0BF1;

This item has no description.

GL_AUX_BUFFERS = $0C00;

This item has no description.

GL_INDEX_CLEAR_VALUE = $0C20;

This item has no description.

GL_INDEX_WRITEMASK = $0C21;

This item has no description.

GL_INDEX_MODE = $0C30;

This item has no description.

GL_RGBA_MODE = $0C31;

This item has no description.

GL_RENDER_MODE = $0C40;

This item has no description.

GL_PERSPECTIVE_CORRECTION_HINT = $0C50;

This item has no description.

GL_POINT_SMOOTH_HINT = $0C51;

This item has no description.

GL_FOG_HINT = $0C54;

This item has no description.

GL_TEXTURE_GEN_S = $0C60;

This item has no description.

GL_TEXTURE_GEN_T = $0C61;

This item has no description.

GL_TEXTURE_GEN_R = $0C62;

This item has no description.

GL_TEXTURE_GEN_Q = $0C63;

This item has no description.

GL_PIXEL_MAP_I_TO_I = $0C70;

This item has no description.

GL_PIXEL_MAP_S_TO_S = $0C71;

This item has no description.

GL_PIXEL_MAP_I_TO_R = $0C72;

This item has no description.

GL_PIXEL_MAP_I_TO_G = $0C73;

This item has no description.

GL_PIXEL_MAP_I_TO_B = $0C74;

This item has no description.

GL_PIXEL_MAP_I_TO_A = $0C75;

This item has no description.

GL_PIXEL_MAP_R_TO_R = $0C76;

This item has no description.

GL_PIXEL_MAP_G_TO_G = $0C77;

This item has no description.

GL_PIXEL_MAP_B_TO_B = $0C78;

This item has no description.

GL_PIXEL_MAP_A_TO_A = $0C79;

This item has no description.

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0;

This item has no description.

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1;

This item has no description.

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2;

This item has no description.

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3;

This item has no description.

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4;

This item has no description.

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5;

This item has no description.

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6;

This item has no description.

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7;

This item has no description.

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8;

This item has no description.

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9;

This item has no description.

GL_MAP_COLOR = $0D10;

This item has no description.

GL_MAP_STENCIL = $0D11;

This item has no description.

GL_INDEX_SHIFT = $0D12;

This item has no description.

GL_INDEX_OFFSET = $0D13;

This item has no description.

GL_RED_SCALE = $0D14;

This item has no description.

GL_RED_BIAS = $0D15;

This item has no description.

GL_ZOOM_X = $0D16;

This item has no description.

GL_ZOOM_Y = $0D17;

This item has no description.

GL_GREEN_SCALE = $0D18;

This item has no description.

GL_GREEN_BIAS = $0D19;

This item has no description.

GL_BLUE_SCALE = $0D1A;

This item has no description.

GL_BLUE_BIAS = $0D1B;

This item has no description.

GL_ALPHA_SCALE = $0D1C;

This item has no description.

GL_ALPHA_BIAS = $0D1D;

This item has no description.

GL_DEPTH_SCALE = $0D1E;

This item has no description.

GL_DEPTH_BIAS = $0D1F;

This item has no description.

GL_MAX_EVAL_ORDER = $0D30;

This item has no description.

GL_MAX_LIGHTS = $0D31;

This item has no description.

GL_MAX_CLIP_PLANES = $0D32;

This item has no description.

GL_MAX_PIXEL_MAP_TABLE = $0D34;

This item has no description.

GL_MAX_ATTRIB_STACK_DEPTH = $0D35;

This item has no description.

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36;

This item has no description.

GL_MAX_NAME_STACK_DEPTH = $0D37;

This item has no description.

GL_MAX_PROJECTION_STACK_DEPTH = $0D38;

This item has no description.

GL_MAX_TEXTURE_STACK_DEPTH = $0D39;

This item has no description.

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B;

This item has no description.

GL_INDEX_BITS = $0D51;

This item has no description.

GL_RED_BITS = $0D52;

This item has no description.

GL_GREEN_BITS = $0D53;

This item has no description.

GL_BLUE_BITS = $0D54;

This item has no description.

GL_ALPHA_BITS = $0D55;

This item has no description.

GL_DEPTH_BITS = $0D56;

This item has no description.

GL_STENCIL_BITS = $0D57;

This item has no description.

GL_ACCUM_RED_BITS = $0D58;

This item has no description.

GL_ACCUM_GREEN_BITS = $0D59;

This item has no description.

GL_ACCUM_BLUE_BITS = $0D5A;

This item has no description.

GL_ACCUM_ALPHA_BITS = $0D5B;

This item has no description.

GL_NAME_STACK_DEPTH = $0D70;

This item has no description.

GL_AUTO_NORMAL = $0D80;

This item has no description.

GL_MAP1_COLOR_4 = $0D90;

This item has no description.

GL_MAP1_INDEX = $0D91;

This item has no description.

GL_MAP1_NORMAL = $0D92;

This item has no description.

GL_MAP1_TEXTURE_COORD_1 = $0D93;

This item has no description.

GL_MAP1_TEXTURE_COORD_2 = $0D94;

This item has no description.

GL_MAP1_TEXTURE_COORD_3 = $0D95;

This item has no description.

GL_MAP1_TEXTURE_COORD_4 = $0D96;

This item has no description.

GL_MAP1_VERTEX_3 = $0D97;

This item has no description.

GL_MAP1_VERTEX_4 = $0D98;

This item has no description.

GL_MAP2_COLOR_4 = $0DB0;

This item has no description.

GL_MAP2_INDEX = $0DB1;

This item has no description.

GL_MAP2_NORMAL = $0DB2;

This item has no description.

GL_MAP2_TEXTURE_COORD_1 = $0DB3;

This item has no description.

GL_MAP2_TEXTURE_COORD_2 = $0DB4;

This item has no description.

GL_MAP2_TEXTURE_COORD_3 = $0DB5;

This item has no description.

GL_MAP2_TEXTURE_COORD_4 = $0DB6;

This item has no description.

GL_MAP2_VERTEX_3 = $0DB7;

This item has no description.

GL_MAP2_VERTEX_4 = $0DB8;

This item has no description.

GL_MAP1_GRID_DOMAIN = $0DD0;

This item has no description.

GL_MAP1_GRID_SEGMENTS = $0DD1;

This item has no description.

GL_MAP2_GRID_DOMAIN = $0DD2;

This item has no description.

GL_MAP2_GRID_SEGMENTS = $0DD3;

This item has no description.

GL_FEEDBACK_BUFFER_POINTER = $0DF0;

This item has no description.

GL_FEEDBACK_BUFFER_SIZE = $0DF1;

This item has no description.

GL_FEEDBACK_BUFFER_TYPE = $0DF2;

This item has no description.

GL_SELECTION_BUFFER_POINTER = $0DF3;

This item has no description.

GL_SELECTION_BUFFER_SIZE = $0DF4;

This item has no description.

GL_LIGHT0 = $4000;

This item has no description.

GL_LIGHT1 = $4001;

This item has no description.

GL_LIGHT2 = $4002;

This item has no description.

GL_LIGHT3 = $4003;

This item has no description.

GL_LIGHT4 = $4004;

This item has no description.

GL_LIGHT5 = $4005;

This item has no description.

GL_LIGHT6 = $4006;

This item has no description.

GL_LIGHT7 = $4007;

This item has no description.

GL_AMBIENT = $1200;

This item has no description.

GL_DIFFUSE = $1201;

This item has no description.

GL_SPECULAR = $1202;

This item has no description.

GL_POSITION = $1203;

This item has no description.

GL_SPOT_DIRECTION = $1204;

This item has no description.

GL_SPOT_EXPONENT = $1205;

This item has no description.

GL_SPOT_CUTOFF = $1206;

This item has no description.

GL_CONSTANT_ATTENUATION = $1207;

This item has no description.

GL_LINEAR_ATTENUATION = $1208;

This item has no description.

GL_QUADRATIC_ATTENUATION = $1209;

This item has no description.

GL_COMPILE = $1300;

This item has no description.

GL_COMPILE_AND_EXECUTE = $1301;

This item has no description.

GL_EMISSION = $1600;

This item has no description.

GL_SHININESS = $1601;

This item has no description.

GL_AMBIENT_AND_DIFFUSE = $1602;

This item has no description.

GL_COLOR_INDEXES = $1603;

This item has no description.

GL_MODELVIEW = $1700;

This item has no description.

GL_PROJECTION = $1701;

This item has no description.

GL_COLOR_INDEX = $1900;

This item has no description.

GL_LUMINANCE = $1909;

This item has no description.

GL_LUMINANCE_ALPHA = $190A;

This item has no description.

GL_BITMAP = $1A00;

This item has no description.

GL_RENDER = $1C00;

This item has no description.

GL_FEEDBACK = $1C01;

This item has no description.

GL_SELECT = $1C02;

This item has no description.

GL_FLAT = $1D00;

This item has no description.

GL_SMOOTH = $1D01;

This item has no description.

GL_S = $2000;

This item has no description.

GL_T = $2001;

This item has no description.

GL_R = $2002;

This item has no description.

GL_Q = $2003;

This item has no description.

GL_MODULATE = $2100;

This item has no description.

GL_DECAL = $2101;

This item has no description.

GL_TEXTURE_ENV_MODE = $2200;

This item has no description.

GL_TEXTURE_ENV_COLOR = $2201;

This item has no description.

GL_TEXTURE_ENV = $2300;

This item has no description.

GL_EYE_LINEAR = $2400;

This item has no description.

GL_OBJECT_LINEAR = $2401;

This item has no description.

GL_SPHERE_MAP = $2402;

This item has no description.

GL_TEXTURE_GEN_MODE = $2500;

This item has no description.

GL_OBJECT_PLANE = $2501;

This item has no description.

GL_EYE_PLANE = $2502;

This item has no description.

GL_CLAMP = $2900;

This item has no description.

GL_CLIENT_PIXEL_STORE_BIT = $00000001;

This item has no description.

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002;

This item has no description.

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF;

This item has no description.

GL_ALPHA4 = $803B;

This item has no description.

GL_ALPHA8 = $803C;

This item has no description.

GL_ALPHA12 = $803D;

This item has no description.

GL_ALPHA16 = $803E;

This item has no description.

GL_LUMINANCE4 = $803F;

This item has no description.

GL_LUMINANCE8 = $8040;

This item has no description.

GL_LUMINANCE12 = $8041;

This item has no description.

GL_LUMINANCE16 = $8042;

This item has no description.

GL_LUMINANCE4_ALPHA4 = $8043;

This item has no description.

GL_LUMINANCE6_ALPHA2 = $8044;

This item has no description.

GL_LUMINANCE8_ALPHA8 = $8045;

This item has no description.

GL_LUMINANCE12_ALPHA4 = $8046;

This item has no description.

GL_LUMINANCE12_ALPHA12 = $8047;

This item has no description.

GL_LUMINANCE16_ALPHA16 = $8048;

This item has no description.

GL_INTENSITY = $8049;

This item has no description.

GL_INTENSITY4 = $804A;

This item has no description.

GL_INTENSITY8 = $804B;

This item has no description.

GL_INTENSITY12 = $804C;

This item has no description.

GL_INTENSITY16 = $804D;

This item has no description.

GL_TEXTURE_LUMINANCE_SIZE = $8060;

This item has no description.

GL_TEXTURE_INTENSITY_SIZE = $8061;

This item has no description.

GL_TEXTURE_PRIORITY = $8066;

This item has no description.

GL_TEXTURE_RESIDENT = $8067;

This item has no description.

GL_VERTEX_ARRAY = $8074;

This item has no description.

GL_NORMAL_ARRAY = $8075;

This item has no description.

GL_COLOR_ARRAY = $8076;

This item has no description.

GL_INDEX_ARRAY = $8077;

This item has no description.

GL_TEXTURE_COORD_ARRAY = $8078;

This item has no description.

GL_EDGE_FLAG_ARRAY = $8079;

This item has no description.

GL_VERTEX_ARRAY_SIZE = $807A;

This item has no description.

GL_VERTEX_ARRAY_TYPE = $807B;

This item has no description.

GL_VERTEX_ARRAY_STRIDE = $807C;

This item has no description.

GL_NORMAL_ARRAY_TYPE = $807E;

This item has no description.

GL_NORMAL_ARRAY_STRIDE = $807F;

This item has no description.

GL_COLOR_ARRAY_SIZE = $8081;

This item has no description.

GL_COLOR_ARRAY_TYPE = $8082;

This item has no description.

GL_COLOR_ARRAY_STRIDE = $8083;

This item has no description.

GL_INDEX_ARRAY_TYPE = $8085;

This item has no description.

GL_INDEX_ARRAY_STRIDE = $8086;

This item has no description.

GL_TEXTURE_COORD_ARRAY_SIZE = $8088;

This item has no description.

GL_TEXTURE_COORD_ARRAY_TYPE = $8089;

This item has no description.

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A;

This item has no description.

GL_EDGE_FLAG_ARRAY_STRIDE = $808C;

This item has no description.

GL_VERTEX_ARRAY_POINTER = $808E;

This item has no description.

GL_NORMAL_ARRAY_POINTER = $808F;

This item has no description.

GL_COLOR_ARRAY_POINTER = $8090;

This item has no description.

GL_INDEX_ARRAY_POINTER = $8091;

This item has no description.

GL_TEXTURE_COORD_ARRAY_POINTER = $8092;

This item has no description.

GL_EDGE_FLAG_ARRAY_POINTER = $8093;

This item has no description.

GL_V2F = $2A20;

This item has no description.

GL_V3F = $2A21;

This item has no description.

GL_C4UB_V2F = $2A22;

This item has no description.

GL_C4UB_V3F = $2A23;

This item has no description.

GL_C3F_V3F = $2A24;

This item has no description.

GL_N3F_V3F = $2A25;

This item has no description.

GL_C4F_N3F_V3F = $2A26;

This item has no description.

GL_T2F_V3F = $2A27;

This item has no description.

GL_T4F_V4F = $2A28;

This item has no description.

GL_T2F_C4UB_V3F = $2A29;

This item has no description.

GL_T2F_C3F_V3F = $2A2A;

This item has no description.

GL_T2F_N3F_V3F = $2A2B;

This item has no description.

GL_T2F_C4F_N3F_V3F = $2A2C;

This item has no description.

GL_T4F_C4F_N3F_V4F = $2A2D;

This item has no description.

GL_COLOR_TABLE_FORMAT_EXT = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH_EXT = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE_EXT = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE_EXT = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE_EXT = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE_EXT = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE_EXT = $80DF;

This item has no description.

GL_LOGIC_OP = GL_INDEX_LOGIC_OP;

This item has no description.

GL_TEXTURE_COMPONENTS = GL_TEXTURE_INTERNAL_FORMAT;

This item has no description.

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_VERSION_1_2

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

This item has no description.

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8 = $8035;

This item has no description.

GL_UNSIGNED_INT_10_10_10_2 = $8036;

This item has no description.

GL_TEXTURE_BINDING_3D = $806A;

This item has no description.

GL_PACK_SKIP_IMAGES = $806B;

This item has no description.

GL_PACK_IMAGE_HEIGHT = $806C;

This item has no description.

GL_UNPACK_SKIP_IMAGES = $806D;

This item has no description.

GL_UNPACK_IMAGE_HEIGHT = $806E;

This item has no description.

GL_TEXTURE_3D = $806F;

This item has no description.

GL_PROXY_TEXTURE_3D = $8070;

This item has no description.

GL_TEXTURE_DEPTH = $8071;

This item has no description.

GL_TEXTURE_WRAP_R = $8072;

This item has no description.

GL_MAX_3D_TEXTURE_SIZE = $8073;

This item has no description.

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

This item has no description.

GL_UNSIGNED_SHORT_5_6_5 = $8363;

This item has no description.

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

This item has no description.

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

This item has no description.

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

This item has no description.

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

This item has no description.

GL_BGR = $80E0;

This item has no description.

GL_BGRA = $80E1;

This item has no description.

GL_MAX_ELEMENTS_VERTICES = $80E8;

This item has no description.

GL_MAX_ELEMENTS_INDICES = $80E9;

This item has no description.

GL_CLAMP_TO_EDGE = $812F;

This item has no description.

GL_TEXTURE_MIN_LOD = $813A;

This item has no description.

GL_TEXTURE_MAX_LOD = $813B;

This item has no description.

GL_TEXTURE_BASE_LEVEL = $813C;

This item has no description.

GL_TEXTURE_MAX_LEVEL = $813D;

This item has no description.

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

This item has no description.

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

This item has no description.

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

This item has no description.

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

This item has no description.

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

This item has no description.

GL_RESCALE_NORMAL = $803A;

This item has no description.

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8;

This item has no description.

GL_SINGLE_COLOR = $81F9;

This item has no description.

GL_SEPARATE_SPECULAR_COLOR = $81FA;

This item has no description.

GL_ALIASED_POINT_SIZE_RANGE = $846D;

This item has no description.

GL_TEXTURE0 = $84C0;

GL_VERSION_1_3

GL_TEXTURE1 = $84C1;

This item has no description.

GL_TEXTURE2 = $84C2;

This item has no description.

GL_TEXTURE3 = $84C3;

This item has no description.

GL_TEXTURE4 = $84C4;

This item has no description.

GL_TEXTURE5 = $84C5;

This item has no description.

GL_TEXTURE6 = $84C6;

This item has no description.

GL_TEXTURE7 = $84C7;

This item has no description.

GL_TEXTURE8 = $84C8;

This item has no description.

GL_TEXTURE9 = $84C9;

This item has no description.

GL_TEXTURE10 = $84CA;

This item has no description.

GL_TEXTURE11 = $84CB;

This item has no description.

GL_TEXTURE12 = $84CC;

This item has no description.

GL_TEXTURE13 = $84CD;

This item has no description.

GL_TEXTURE14 = $84CE;

This item has no description.

GL_TEXTURE15 = $84CF;

This item has no description.

GL_TEXTURE16 = $84D0;

This item has no description.

GL_TEXTURE17 = $84D1;

This item has no description.

GL_TEXTURE18 = $84D2;

This item has no description.

GL_TEXTURE19 = $84D3;

This item has no description.

GL_TEXTURE20 = $84D4;

This item has no description.

GL_TEXTURE21 = $84D5;

This item has no description.

GL_TEXTURE22 = $84D6;

This item has no description.

GL_TEXTURE23 = $84D7;

This item has no description.

GL_TEXTURE24 = $84D8;

This item has no description.

GL_TEXTURE25 = $84D9;

This item has no description.

GL_TEXTURE26 = $84DA;

This item has no description.

GL_TEXTURE27 = $84DB;

This item has no description.

GL_TEXTURE28 = $84DC;

This item has no description.

GL_TEXTURE29 = $84DD;

This item has no description.

GL_TEXTURE30 = $84DE;

This item has no description.

GL_TEXTURE31 = $84DF;

This item has no description.

GL_ACTIVE_TEXTURE = $84E0;

This item has no description.

GL_MULTISAMPLE = $809D;

This item has no description.

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE = $809F;

This item has no description.

GL_SAMPLE_COVERAGE = $80A0;

This item has no description.

GL_SAMPLE_BUFFERS = $80A8;

This item has no description.

GL_SAMPLES = $80A9;

This item has no description.

GL_SAMPLE_COVERAGE_VALUE = $80AA;

This item has no description.

GL_SAMPLE_COVERAGE_INVERT = $80AB;

This item has no description.

GL_TEXTURE_CUBE_MAP = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

This item has no description.

GL_COMPRESSED_RGB = $84ED;

This item has no description.

GL_COMPRESSED_RGBA = $84EE;

This item has no description.

GL_TEXTURE_COMPRESSION_HINT = $84EF;

This item has no description.

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

This item has no description.

GL_TEXTURE_COMPRESSED = $86A1;

This item has no description.

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

This item has no description.

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

This item has no description.

GL_CLAMP_TO_BORDER = $812D;

This item has no description.

GL_CLIENT_ACTIVE_TEXTURE = $84E1;

This item has no description.

GL_MAX_TEXTURE_UNITS = $84E2;

This item has no description.

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3;

This item has no description.

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4;

This item has no description.

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5;

This item has no description.

GL_TRANSPOSE_COLOR_MATRIX = $84E6;

This item has no description.

GL_MULTISAMPLE_BIT = $20000000;

This item has no description.

GL_NORMAL_MAP = $8511;

This item has no description.

GL_REFLECTION_MAP = $8512;

This item has no description.

GL_COMPRESSED_ALPHA = $84E9;

This item has no description.

GL_COMPRESSED_LUMINANCE = $84EA;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB;

This item has no description.

GL_COMPRESSED_INTENSITY = $84EC;

This item has no description.

GL_COMBINE = $8570;

This item has no description.

GL_COMBINE_RGB = $8571;

This item has no description.

GL_COMBINE_ALPHA = $8572;

This item has no description.

GL_SOURCE0_RGB = $8580;

This item has no description.

GL_SOURCE1_RGB = $8581;

This item has no description.

GL_SOURCE2_RGB = $8582;

This item has no description.

GL_SOURCE0_ALPHA = $8588;

This item has no description.

GL_SOURCE1_ALPHA = $8589;

This item has no description.

GL_SOURCE2_ALPHA = $858A;

This item has no description.

GL_OPERAND0_RGB = $8590;

This item has no description.

GL_OPERAND1_RGB = $8591;

This item has no description.

GL_OPERAND2_RGB = $8592;

This item has no description.

GL_OPERAND0_ALPHA = $8598;

This item has no description.

GL_OPERAND1_ALPHA = $8599;

This item has no description.

GL_OPERAND2_ALPHA = $859A;

This item has no description.

GL_RGB_SCALE = $8573;

This item has no description.

GL_ADD_SIGNED = $8574;

This item has no description.

GL_INTERPOLATE = $8575;

This item has no description.

GL_SUBTRACT = $84E7;

This item has no description.

GL_CONSTANT = $8576;

This item has no description.

GL_PRIMARY_COLOR = $8577;

This item has no description.

GL_PREVIOUS = $8578;

This item has no description.

GL_DOT3_RGB = $86AE;

This item has no description.

GL_DOT3_RGBA = $86AF;

This item has no description.

GL_BLEND_DST_RGB = $80C8;

GL_VERSION_1_4

GL_BLEND_SRC_RGB = $80C9;

This item has no description.

GL_BLEND_DST_ALPHA = $80CA;

This item has no description.

GL_BLEND_SRC_ALPHA = $80CB;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

This item has no description.

GL_DEPTH_COMPONENT16 = $81A5;

This item has no description.

GL_DEPTH_COMPONENT24 = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32 = $81A7;

This item has no description.

GL_MIRRORED_REPEAT = $8370;

This item has no description.

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

This item has no description.

GL_TEXTURE_LOD_BIAS = $8501;

This item has no description.

GL_INCR_WRAP = $8507;

This item has no description.

GL_DECR_WRAP = $8508;

This item has no description.

GL_TEXTURE_DEPTH_SIZE = $884A;

This item has no description.

GL_TEXTURE_COMPARE_MODE = $884C;

This item has no description.

GL_TEXTURE_COMPARE_FUNC = $884D;

This item has no description.

GL_POINT_SIZE_MIN = $8126;

This item has no description.

GL_POINT_SIZE_MAX = $8127;

This item has no description.

GL_POINT_DISTANCE_ATTENUATION = $8129;

This item has no description.

GL_GENERATE_MIPMAP = $8191;

This item has no description.

GL_GENERATE_MIPMAP_HINT = $8192;

This item has no description.

GL_FOG_COORDINATE_SOURCE = $8450;

This item has no description.

GL_FOG_COORDINATE = $8451;

This item has no description.

GL_FRAGMENT_DEPTH = $8452;

This item has no description.

GL_CURRENT_FOG_COORDINATE = $8453;

This item has no description.

GL_FOG_COORDINATE_ARRAY_TYPE = $8454;

This item has no description.

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455;

This item has no description.

GL_FOG_COORDINATE_ARRAY_POINTER = $8456;

This item has no description.

GL_FOG_COORDINATE_ARRAY = $8457;

This item has no description.

GL_COLOR_SUM = $8458;

This item has no description.

GL_CURRENT_SECONDARY_COLOR = $8459;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D;

This item has no description.

GL_SECONDARY_COLOR_ARRAY = $845E;

This item has no description.

GL_TEXTURE_FILTER_CONTROL = $8500;

This item has no description.

GL_DEPTH_TEXTURE_MODE = $884B;

This item has no description.

GL_COMPARE_R_TO_TEXTURE = $884E;

This item has no description.

GL_BUFFER_SIZE = $8764;

GL_VERSION_1_5

GL_BUFFER_USAGE = $8765;

This item has no description.

GL_QUERY_COUNTER_BITS = $8864;

This item has no description.

GL_CURRENT_QUERY = $8865;

This item has no description.

GL_QUERY_RESULT = $8866;

This item has no description.

GL_QUERY_RESULT_AVAILABLE = $8867;

This item has no description.

GL_ARRAY_BUFFER = $8892;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER = $8893;

This item has no description.

GL_ARRAY_BUFFER_BINDING = $8894;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

This item has no description.

GL_READ_ONLY = $88B8;

This item has no description.

GL_WRITE_ONLY = $88B9;

This item has no description.

GL_READ_WRITE = $88BA;

This item has no description.

GL_BUFFER_ACCESS = $88BB;

This item has no description.

GL_BUFFER_MAPPED = $88BC;

This item has no description.

GL_BUFFER_MAP_POINTER = $88BD;

This item has no description.

GL_STREAM_DRAW = $88E0;

This item has no description.

GL_STREAM_READ = $88E1;

This item has no description.

GL_STREAM_COPY = $88E2;

This item has no description.

GL_STATIC_DRAW = $88E4;

This item has no description.

GL_STATIC_READ = $88E5;

This item has no description.

GL_STATIC_COPY = $88E6;

This item has no description.

GL_DYNAMIC_DRAW = $88E8;

This item has no description.

GL_DYNAMIC_READ = $88E9;

This item has no description.

GL_DYNAMIC_COPY = $88EA;

This item has no description.

GL_SAMPLES_PASSED = $8914;

This item has no description.

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896;

This item has no description.

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897;

This item has no description.

GL_COLOR_ARRAY_BUFFER_BINDING = $8898;

This item has no description.

GL_INDEX_ARRAY_BUFFER_BINDING = $8899;

This item has no description.

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A;

This item has no description.

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C;

This item has no description.

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D;

This item has no description.

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E;

This item has no description.

GL_FOG_COORD_SRC = $8450;

This item has no description.

GL_FOG_COORD = $8451;

This item has no description.

GL_CURRENT_FOG_COORD = $8453;

This item has no description.

GL_FOG_COORD_ARRAY_TYPE = $8454;

This item has no description.

GL_FOG_COORD_ARRAY_STRIDE = $8455;

This item has no description.

GL_FOG_COORD_ARRAY_POINTER = $8456;

This item has no description.

GL_FOG_COORD_ARRAY = $8457;

This item has no description.

GL_FOG_COORD_ARRAY_BUFFER_BINDING = $889D;

This item has no description.

GL_SRC0_RGB = $8580;

This item has no description.

GL_SRC1_RGB = $8581;

This item has no description.

GL_SRC2_RGB = $8582;

This item has no description.

GL_SRC0_ALPHA = $8588;

This item has no description.

GL_SRC1_ALPHA = $8589;

This item has no description.

GL_SRC2_ALPHA = $858A;

This item has no description.

GL_BLEND_EQUATION_RGB = $8009;

GL_VERSION_2_0

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

This item has no description.

GL_CURRENT_VERTEX_ATTRIB = $8626;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

This item has no description.

GL_STENCIL_BACK_FUNC = $8800;

This item has no description.

GL_STENCIL_BACK_FAIL = $8801;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

This item has no description.

GL_MAX_DRAW_BUFFERS = $8824;

This item has no description.

GL_DRAW_BUFFER0 = $8825;

This item has no description.

GL_DRAW_BUFFER1 = $8826;

This item has no description.

GL_DRAW_BUFFER2 = $8827;

This item has no description.

GL_DRAW_BUFFER3 = $8828;

This item has no description.

GL_DRAW_BUFFER4 = $8829;

This item has no description.

GL_DRAW_BUFFER5 = $882A;

This item has no description.

GL_DRAW_BUFFER6 = $882B;

This item has no description.

GL_DRAW_BUFFER7 = $882C;

This item has no description.

GL_DRAW_BUFFER8 = $882D;

This item has no description.

GL_DRAW_BUFFER9 = $882E;

This item has no description.

GL_DRAW_BUFFER10 = $882F;

This item has no description.

GL_DRAW_BUFFER11 = $8830;

This item has no description.

GL_DRAW_BUFFER12 = $8831;

This item has no description.

GL_DRAW_BUFFER13 = $8832;

This item has no description.

GL_DRAW_BUFFER14 = $8833;

This item has no description.

GL_DRAW_BUFFER15 = $8834;

This item has no description.

GL_BLEND_EQUATION_ALPHA = $883D;

This item has no description.

GL_MAX_VERTEX_ATTRIBS = $8869;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

This item has no description.

GL_FRAGMENT_SHADER = $8B30;

This item has no description.

GL_VERTEX_SHADER = $8B31;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

This item has no description.

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

This item has no description.

GL_MAX_VARYING_FLOATS = $8B4B;

This item has no description.

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

This item has no description.

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

This item has no description.

GL_SHADER_TYPE = $8B4F;

This item has no description.

GL_FLOAT_VEC2 = $8B50;

This item has no description.

GL_FLOAT_VEC3 = $8B51;

This item has no description.

GL_FLOAT_VEC4 = $8B52;

This item has no description.

GL_INT_VEC2 = $8B53;

This item has no description.

GL_INT_VEC3 = $8B54;

This item has no description.

GL_INT_VEC4 = $8B55;

This item has no description.

GL_BOOL = $8B56;

This item has no description.

GL_BOOL_VEC2 = $8B57;

This item has no description.

GL_BOOL_VEC3 = $8B58;

This item has no description.

GL_BOOL_VEC4 = $8B59;

This item has no description.

GL_FLOAT_MAT2 = $8B5A;

This item has no description.

GL_FLOAT_MAT3 = $8B5B;

This item has no description.

GL_FLOAT_MAT4 = $8B5C;

This item has no description.

GL_SAMPLER_1D = $8B5D;

This item has no description.

GL_SAMPLER_2D = $8B5E;

This item has no description.

GL_SAMPLER_3D = $8B5F;

This item has no description.

GL_SAMPLER_CUBE = $8B60;

This item has no description.

GL_SAMPLER_1D_SHADOW = $8B61;

This item has no description.

GL_SAMPLER_2D_SHADOW = $8B62;

This item has no description.

GL_DELETE_STATUS = $8B80;

This item has no description.

GL_COMPILE_STATUS = $8B81;

This item has no description.

GL_LINK_STATUS = $8B82;

This item has no description.

GL_VALIDATE_STATUS = $8B83;

This item has no description.

GL_INFO_LOG_LENGTH = $8B84;

This item has no description.

GL_ATTACHED_SHADERS = $8B85;

This item has no description.

GL_ACTIVE_UNIFORMS = $8B86;

This item has no description.

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

This item has no description.

GL_SHADER_SOURCE_LENGTH = $8B88;

This item has no description.

GL_ACTIVE_ATTRIBUTES = $8B89;

This item has no description.

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

This item has no description.

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

This item has no description.

GL_SHADING_LANGUAGE_VERSION = $8B8C;

This item has no description.

GL_CURRENT_PROGRAM = $8B8D;

This item has no description.

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

This item has no description.

GL_LOWER_LEFT = $8CA1;

This item has no description.

GL_UPPER_LEFT = $8CA2;

This item has no description.

GL_STENCIL_BACK_REF = $8CA3;

This item has no description.

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

This item has no description.

GL_STENCIL_BACK_WRITEMASK = $8CA5;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE = $8643;

This item has no description.

GL_POINT_SPRITE = $8861;

This item has no description.

GL_COORD_REPLACE = $8862;

This item has no description.

GL_MAX_TEXTURE_COORDS = $8871;

This item has no description.

GL_PIXEL_PACK_BUFFER = $88EB;

GL_VERSION_2_1

GL_PIXEL_UNPACK_BUFFER = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

This item has no description.

GL_FLOAT_MAT2x3 = $8B65;

This item has no description.

GL_FLOAT_MAT2x4 = $8B66;

This item has no description.

GL_FLOAT_MAT3x2 = $8B67;

This item has no description.

GL_FLOAT_MAT3x4 = $8B68;

This item has no description.

GL_FLOAT_MAT4x2 = $8B69;

This item has no description.

GL_FLOAT_MAT4x3 = $8B6A;

This item has no description.

GL_SRGB = $8C40;

This item has no description.

GL_SRGB8 = $8C41;

This item has no description.

GL_SRGB_ALPHA = $8C42;

This item has no description.

GL_SRGB8_ALPHA8 = $8C43;

This item has no description.

GL_COMPRESSED_SRGB = $8C48;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA = $8C49;

This item has no description.

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F;

This item has no description.

GL_SLUMINANCE_ALPHA = $8C44;

This item has no description.

GL_SLUMINANCE8_ALPHA8 = $8C45;

This item has no description.

GL_SLUMINANCE = $8C46;

This item has no description.

GL_SLUMINANCE8 = $8C47;

This item has no description.

GL_COMPRESSED_SLUMINANCE = $8C4A;

This item has no description.

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B;

This item has no description.

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_VERSION_3_0

GL_CLIP_DISTANCE0 = $3000;

This item has no description.

GL_CLIP_DISTANCE1 = $3001;

This item has no description.

GL_CLIP_DISTANCE2 = $3002;

This item has no description.

GL_CLIP_DISTANCE3 = $3003;

This item has no description.

GL_CLIP_DISTANCE4 = $3004;

This item has no description.

GL_CLIP_DISTANCE5 = $3005;

This item has no description.

GL_CLIP_DISTANCE6 = $3006;

This item has no description.

GL_CLIP_DISTANCE7 = $3007;

This item has no description.

GL_MAX_CLIP_DISTANCES = $0D32;

This item has no description.

GL_MAJOR_VERSION = $821B;

This item has no description.

GL_MINOR_VERSION = $821C;

This item has no description.

GL_NUM_EXTENSIONS = $821D;

This item has no description.

GL_CONTEXT_FLAGS = $821E;

This item has no description.

GL_DEPTH_BUFFER = $8223;

This item has no description.

GL_STENCIL_BUFFER = $8224;

This item has no description.

GL_COMPRESSED_RED = $8225;

This item has no description.

GL_COMPRESSED_RG = $8226;

This item has no description.

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

This item has no description.

GL_RGBA32F = $8814;

This item has no description.

GL_RGB32F = $8815;

This item has no description.

GL_RGBA16F = $881A;

This item has no description.

GL_RGB16F = $881B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

This item has no description.

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

This item has no description.

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

This item has no description.

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

This item has no description.

GL_CLAMP_READ_COLOR = $891C;

This item has no description.

GL_FIXED_ONLY = $891D;

This item has no description.

GL_MAX_VARYING_COMPONENTS = $8B4B;

This item has no description.

GL_TEXTURE_1D_ARRAY = $8C18;

This item has no description.

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

This item has no description.

GL_TEXTURE_2D_ARRAY = $8C1A;

This item has no description.

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

This item has no description.

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

This item has no description.

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

This item has no description.

GL_R11F_G11F_B10F = $8C3A;

This item has no description.

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

This item has no description.

GL_RGB9_E5 = $8C3D;

This item has no description.

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

This item has no description.

GL_TEXTURE_SHARED_SIZE = $8C3F;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

This item has no description.

GL_PRIMITIVES_GENERATED = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

This item has no description.

GL_INTERLEAVED_ATTRIBS = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS = $8C8D;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

This item has no description.

GL_RGBA32UI = $8D70;

This item has no description.

GL_RGB32UI = $8D71;

This item has no description.

GL_RGBA16UI = $8D76;

This item has no description.

GL_RGB16UI = $8D77;

This item has no description.

GL_RGBA8UI = $8D7C;

This item has no description.

GL_RGB8UI = $8D7D;

This item has no description.

GL_RGBA32I = $8D82;

This item has no description.

GL_RGB32I = $8D83;

This item has no description.

GL_RGBA16I = $8D88;

This item has no description.

GL_RGB16I = $8D89;

This item has no description.

GL_RGBA8I = $8D8E;

This item has no description.

GL_RGB8I = $8D8F;

This item has no description.

GL_RED_INTEGER = $8D94;

This item has no description.

GL_GREEN_INTEGER = $8D95;

This item has no description.

GL_BLUE_INTEGER = $8D96;

This item has no description.

GL_RGB_INTEGER = $8D98;

This item has no description.

GL_RGBA_INTEGER = $8D99;

This item has no description.

GL_BGR_INTEGER = $8D9A;

This item has no description.

GL_BGRA_INTEGER = $8D9B;

This item has no description.

GL_SAMPLER_1D_ARRAY = $8DC0;

This item has no description.

GL_SAMPLER_2D_ARRAY = $8DC1;

This item has no description.

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

This item has no description.

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

This item has no description.

GL_SAMPLER_CUBE_SHADOW = $8DC5;

This item has no description.

GL_UNSIGNED_INT_VEC2 = $8DC6;

This item has no description.

GL_UNSIGNED_INT_VEC3 = $8DC7;

This item has no description.

GL_UNSIGNED_INT_VEC4 = $8DC8;

This item has no description.

GL_INT_SAMPLER_1D = $8DC9;

This item has no description.

GL_INT_SAMPLER_2D = $8DCA;

This item has no description.

GL_INT_SAMPLER_3D = $8DCB;

This item has no description.

GL_INT_SAMPLER_CUBE = $8DCC;

This item has no description.

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

This item has no description.

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

This item has no description.

GL_QUERY_WAIT = $8E13;

This item has no description.

GL_QUERY_NO_WAIT = $8E14;

This item has no description.

GL_QUERY_BY_REGION_WAIT = $8E15;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

This item has no description.

GL_BUFFER_ACCESS_FLAGS = $911F;

This item has no description.

GL_BUFFER_MAP_LENGTH = $9120;

This item has no description.

GL_BUFFER_MAP_OFFSET = $9121;

This item has no description.

GL_CLAMP_VERTEX_COLOR = $891A;

This item has no description.

GL_CLAMP_FRAGMENT_COLOR = $891B;

This item has no description.

GL_ALPHA_INTEGER = $8D97;

This item has no description.

GL_SAMPLER_2D_RECT = $8B63;

GL_VERSION_3_1

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

This item has no description.

GL_SAMPLER_BUFFER = $8DC2;

This item has no description.

GL_INT_SAMPLER_2D_RECT = $8DCD;

This item has no description.

GL_INT_SAMPLER_BUFFER = $8DD0;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

This item has no description.

GL_TEXTURE_BUFFER = $8C2A;

This item has no description.

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

This item has no description.

GL_TEXTURE_RECTANGLE = $84F5;

This item has no description.

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

This item has no description.

GL_RED_SNORM = $8F90;

This item has no description.

GL_RG_SNORM = $8F91;

This item has no description.

GL_RGB_SNORM = $8F92;

This item has no description.

GL_RGBA_SNORM = $8F93;

This item has no description.

GL_R8_SNORM = $8F94;

This item has no description.

GL_RG8_SNORM = $8F95;

This item has no description.

GL_RGB8_SNORM = $8F96;

This item has no description.

GL_RGBA8_SNORM = $8F97;

This item has no description.

GL_R16_SNORM = $8F98;

This item has no description.

GL_RG16_SNORM = $8F99;

This item has no description.

GL_RGB16_SNORM = $8F9A;

This item has no description.

GL_RGBA16_SNORM = $8F9B;

This item has no description.

GL_SIGNED_NORMALIZED = $8F9C;

This item has no description.

GL_PRIMITIVE_RESTART = $8F9D;

This item has no description.

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

This item has no description.

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_VERSION_3_2

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

This item has no description.

GL_LINES_ADJACENCY = $000A;

This item has no description.

GL_LINE_STRIP_ADJACENCY = $000B;

This item has no description.

GL_TRIANGLES_ADJACENCY = $000C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

This item has no description.

GL_PROGRAM_POINT_SIZE = $8642;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

This item has no description.

GL_GEOMETRY_SHADER = $8DD9;

This item has no description.

GL_GEOMETRY_VERTICES_OUT = $8916;

This item has no description.

GL_GEOMETRY_INPUT_TYPE = $8917;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE = $8918;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

This item has no description.

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

This item has no description.

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

This item has no description.

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

This item has no description.

GL_CONTEXT_PROFILE_MASK = $9126;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_VERSION_3_3

GL_SAMPLE_SHADING = $8C36;

GL_VERSION_4_0

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

This item has no description.

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

This item has no description.

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

This item has no description.

GL_NUM_SHADING_LANGUAGE_VERSIONS = $82E9;

GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3

GL_VERTEX_ATTRIB_ARRAY_LONG = $874E;

This item has no description.

GL_MULTISAMPLE_3DFX = $86B2;

GL_3DFX_multisample

GL_SAMPLE_BUFFERS_3DFX = $86B3;

This item has no description.

GL_SAMPLES_3DFX = $86B4;

This item has no description.

GL_MULTISAMPLE_BIT_3DFX = $20000000;

This item has no description.

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_3DFX_texture_compression_FXT1

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

This item has no description.

GL_UNPACK_CLIENT_STORAGE_APPLE = $85B2;

GL_APPLE_client_storage

GL_ELEMENT_ARRAY_APPLE = $8A0C;

GL_APPLE_element_array

GL_ELEMENT_ARRAY_TYPE_APPLE = $8A0D;

This item has no description.

GL_ELEMENT_ARRAY_POINTER_APPLE = $8A0E;

This item has no description.

GL_DRAW_PIXELS_APPLE = $8A0A;

GL_APPLE_fence

GL_FENCE_APPLE = $8A0B;

This item has no description.

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE = $85B0;

GL_APPLE_specular_vector

GL_TRANSFORM_HINT_APPLE = $85B1;

GL_APPLE_transform_hint

GL_VERTEX_ARRAY_BINDING_APPLE = $85B5;

GL_APPLE_vertex_array_object

GL_VERTEX_ARRAY_RANGE_APPLE = $851D;

GL_APPLE_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE = $851E;

This item has no description.

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE = $851F;

This item has no description.

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE = $8521;

This item has no description.

GL_STORAGE_CLIENT_APPLE = $85B4;

This item has no description.

GL_STORAGE_CACHED_APPLE = $85BE;

This item has no description.

GL_STORAGE_SHARED_APPLE = $85BF;

This item has no description.

GL_YCBCR_422_APPLE = $85B9;

GL_APPLE_ycbcr_422

GL_UNSIGNED_SHORT_8_8_APPLE = $85BA;

This item has no description.

GL_UNSIGNED_SHORT_8_8_REV_APPLE = $85BB;

This item has no description.

GL_RGB_RAW_422_APPLE = $8A51;

This item has no description.

GL_TEXTURE_RANGE_LENGTH_APPLE = $85B7;

GL_APPLE_texture_range

GL_TEXTURE_RANGE_POINTER_APPLE = $85B8;

This item has no description.

GL_TEXTURE_STORAGE_HINT_APPLE = $85BC;

This item has no description.

GL_STORAGE_PRIVATE_APPLE = $85BD;

This item has no description.

GL_HALF_APPLE = $140B;

GL_APPLE_float_pixels

GL_RGBA_FLOAT32_APPLE = $8814;

This item has no description.

GL_RGB_FLOAT32_APPLE = $8815;

This item has no description.

GL_ALPHA_FLOAT32_APPLE = $8816;

This item has no description.

GL_INTENSITY_FLOAT32_APPLE = $8817;

This item has no description.

GL_LUMINANCE_FLOAT32_APPLE = $8818;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT32_APPLE = $8819;

This item has no description.

GL_RGBA_FLOAT16_APPLE = $881A;

This item has no description.

GL_RGB_FLOAT16_APPLE = $881B;

This item has no description.

GL_ALPHA_FLOAT16_APPLE = $881C;

This item has no description.

GL_INTENSITY_FLOAT16_APPLE = $881D;

This item has no description.

GL_LUMINANCE_FLOAT16_APPLE = $881E;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT16_APPLE = $881F;

This item has no description.

GL_COLOR_FLOAT_APPLE = $8A0F;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_APPLE = $8A00;

GL_APPLE_vertex_program_evaluators

GL_VERTEX_ATTRIB_MAP2_APPLE = $8A01;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE = $8A02;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE = $8A03;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE = $8A04;

This item has no description.

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE = $8A05;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE = $8A06;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE = $8A07;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE = $8A08;

This item has no description.

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE = $8A09;

This item has no description.

GL_AUX_DEPTH_STENCIL_APPLE = $8A14;

GL_APPLE_aux_depth_stencil

GL_BUFFER_OBJECT_APPLE = $85B3;

GL_APPLE_object_purgeable

GL_RELEASED_APPLE = $8A19;

This item has no description.

GL_VOLATILE_APPLE = $8A1A;

This item has no description.

GL_RETAINED_APPLE = $8A1B;

This item has no description.

GL_UNDEFINED_APPLE = $8A1C;

This item has no description.

GL_PURGEABLE_APPLE = $8A1D;

This item has no description.

GL_PACK_ROW_BYTES_APPLE = $8A15;

GL_APPLE_row_bytes

GL_UNPACK_ROW_BYTES_APPLE = $8A16;

This item has no description.

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_ARB_depth_texture

GL_DEPTH_COMPONENT24_ARB = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32_ARB = $81A7;

This item has no description.

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

This item has no description.

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

This item has no description.

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_ARB_fragment_program

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

This item has no description.

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

This item has no description.

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

This item has no description.

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

This item has no description.

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

This item has no description.

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

This item has no description.

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

This item has no description.

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

This item has no description.

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

This item has no description.

GL_MAX_TEXTURE_COORDS_ARB = $8871;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

This item has no description.

GL_CONSTANT_COLOR_ARB = $8001;

GL_ARB_imaging

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

This item has no description.

GL_CONSTANT_ALPHA = $8003;

This item has no description.

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

This item has no description.

GL_BLEND_COLOR = $8005;

This item has no description.

GL_FUNC_ADD = $8006;

This item has no description.

GL_MIN = $8007;

This item has no description.

GL_MAX = $8008;

This item has no description.

GL_BLEND_EQUATION = $8009;

This item has no description.

GL_FUNC_SUBTRACT = $800A;

This item has no description.

GL_FUNC_REVERSE_SUBTRACT = $800B;

This item has no description.

GL_CONVOLUTION_1D = $8010;

This item has no description.

GL_CONVOLUTION_2D = $8011;

This item has no description.

GL_SEPARABLE_2D = $8012;

This item has no description.

GL_CONVOLUTION_BORDER_MODE = $8013;

This item has no description.

GL_CONVOLUTION_FILTER_SCALE = $8014;

This item has no description.

GL_CONVOLUTION_FILTER_BIAS = $8015;

This item has no description.

GL_REDUCE = $8016;

This item has no description.

GL_CONVOLUTION_FORMAT = $8017;

This item has no description.

GL_CONVOLUTION_WIDTH = $8018;

This item has no description.

GL_CONVOLUTION_HEIGHT = $8019;

This item has no description.

GL_MAX_CONVOLUTION_WIDTH = $801A;

This item has no description.

GL_MAX_CONVOLUTION_HEIGHT = $801B;

This item has no description.

GL_POST_CONVOLUTION_RED_SCALE = $801C;

This item has no description.

GL_POST_CONVOLUTION_GREEN_SCALE = $801D;

This item has no description.

GL_POST_CONVOLUTION_BLUE_SCALE = $801E;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F;

This item has no description.

GL_POST_CONVOLUTION_RED_BIAS = $8020;

This item has no description.

GL_POST_CONVOLUTION_GREEN_BIAS = $8021;

This item has no description.

GL_POST_CONVOLUTION_BLUE_BIAS = $8022;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023;

This item has no description.

GL_HISTOGRAM = $8024;

This item has no description.

GL_PROXY_HISTOGRAM = $8025;

This item has no description.

GL_HISTOGRAM_WIDTH = $8026;

This item has no description.

GL_HISTOGRAM_FORMAT = $8027;

This item has no description.

GL_HISTOGRAM_RED_SIZE = $8028;

This item has no description.

GL_HISTOGRAM_GREEN_SIZE = $8029;

This item has no description.

GL_HISTOGRAM_BLUE_SIZE = $802A;

This item has no description.

GL_HISTOGRAM_ALPHA_SIZE = $802B;

This item has no description.

GL_HISTOGRAM_LUMINANCE_SIZE = $802C;

This item has no description.

GL_HISTOGRAM_SINK = $802D;

This item has no description.

GL_MINMAX = $802E;

This item has no description.

GL_MINMAX_FORMAT = $802F;

This item has no description.

GL_MINMAX_SINK = $8030;

This item has no description.

GL_TABLE_TOO_LARGE = $8031;

This item has no description.

GL_COLOR_MATRIX = $80B1;

This item has no description.

GL_COLOR_MATRIX_STACK_DEPTH = $80B2;

This item has no description.

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3;

This item has no description.

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7;

This item has no description.

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB;

This item has no description.

GL_COLOR_TABLE = $80D0;

This item has no description.

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1;

This item has no description.

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2;

This item has no description.

GL_PROXY_COLOR_TABLE = $80D3;

This item has no description.

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4;

This item has no description.

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5;

This item has no description.

GL_COLOR_TABLE_SCALE = $80D6;

This item has no description.

GL_COLOR_TABLE_BIAS = $80D7;

This item has no description.

GL_COLOR_TABLE_FORMAT = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF;

This item has no description.

GL_CONSTANT_BORDER = $8151;

This item has no description.

GL_REPLICATE_BORDER = $8153;

This item has no description.

GL_CONVOLUTION_BORDER_COLOR = $8154;

This item has no description.

GL_MATRIX_PALETTE_ARB = $8840;

GL_ARB_matrix_palette

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

This item has no description.

GL_MAX_PALETTE_MATRICES_ARB = $8842;

This item has no description.

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

This item has no description.

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

This item has no description.

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

This item has no description.

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

This item has no description.

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

This item has no description.

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

This item has no description.

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

This item has no description.

GL_MULTISAMPLE_ARB = $809D;

GL_ARB_multisample

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

This item has no description.

GL_SAMPLE_COVERAGE_ARB = $80A0;

This item has no description.

GL_SAMPLE_BUFFERS_ARB = $80A8;

This item has no description.

GL_SAMPLES_ARB = $80A9;

This item has no description.

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

This item has no description.

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

This item has no description.

GL_MULTISAMPLE_BIT_ARB = $20000000;

This item has no description.

GL_TEXTURE0_ARB = $84C0;

GL_ARB_multitexture

GL_TEXTURE1_ARB = $84C1;

This item has no description.

GL_TEXTURE2_ARB = $84C2;

This item has no description.

GL_TEXTURE3_ARB = $84C3;

This item has no description.

GL_TEXTURE4_ARB = $84C4;

This item has no description.

GL_TEXTURE5_ARB = $84C5;

This item has no description.

GL_TEXTURE6_ARB = $84C6;

This item has no description.

GL_TEXTURE7_ARB = $84C7;

This item has no description.

GL_TEXTURE8_ARB = $84C8;

This item has no description.

GL_TEXTURE9_ARB = $84C9;

This item has no description.

GL_TEXTURE10_ARB = $84CA;

This item has no description.

GL_TEXTURE11_ARB = $84CB;

This item has no description.

GL_TEXTURE12_ARB = $84CC;

This item has no description.

GL_TEXTURE13_ARB = $84CD;

This item has no description.

GL_TEXTURE14_ARB = $84CE;

This item has no description.

GL_TEXTURE15_ARB = $84CF;

This item has no description.

GL_TEXTURE16_ARB = $84D0;

This item has no description.

GL_TEXTURE17_ARB = $84D1;

This item has no description.

GL_TEXTURE18_ARB = $84D2;

This item has no description.

GL_TEXTURE19_ARB = $84D3;

This item has no description.

GL_TEXTURE20_ARB = $84D4;

This item has no description.

GL_TEXTURE21_ARB = $84D5;

This item has no description.

GL_TEXTURE22_ARB = $84D6;

This item has no description.

GL_TEXTURE23_ARB = $84D7;

This item has no description.

GL_TEXTURE24_ARB = $84D8;

This item has no description.

GL_TEXTURE25_ARB = $84D9;

This item has no description.

GL_TEXTURE26_ARB = $84DA;

This item has no description.

GL_TEXTURE27_ARB = $84DB;

This item has no description.

GL_TEXTURE28_ARB = $84DC;

This item has no description.

GL_TEXTURE29_ARB = $84DD;

This item has no description.

GL_TEXTURE30_ARB = $84DE;

This item has no description.

GL_TEXTURE31_ARB = $84DF;

This item has no description.

GL_ACTIVE_TEXTURE_ARB = $84E0;

This item has no description.

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

This item has no description.

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

This item has no description.

GL_POINT_SIZE_MIN_ARB = $8126;

GL_ARB_point_parameters

GL_POINT_SIZE_MAX_ARB = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

This item has no description.

GL_POINT_DISTANCE_ATTENUATION_ARB = $8129;

This item has no description.

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_ARB_shadow

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

This item has no description.

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

This item has no description.

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_ARB_shadow_ambient

GL_SPARSE_STORAGE_BIT_ARB = $0400;

GL_ARB_sparse_buffer

GL_SPARSE_BUFFER_PAGE_SIZE_ARB = $82F8;

This item has no description.

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_ARB_texture_border_clamp

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_ARB_texture_compression

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

This item has no description.

GL_COMPRESSED_INTENSITY_ARB = $84EC;

This item has no description.

GL_COMPRESSED_RGB_ARB = $84ED;

This item has no description.

GL_COMPRESSED_RGBA_ARB = $84EE;

This item has no description.

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

This item has no description.

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

This item has no description.

GL_TEXTURE_COMPRESSED_ARB = $86A1;

This item has no description.

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

This item has no description.

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

This item has no description.

GL_NORMAL_MAP_ARB = $8511;

GL_ARB_texture_cube_map

GL_REFLECTION_MAP_ARB = $8512;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARB = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

This item has no description.

GL_COMBINE_ARB = $8570;

GL_ARB_texture_env_combine

GL_COMBINE_RGB_ARB = $8571;

This item has no description.

GL_COMBINE_ALPHA_ARB = $8572;

This item has no description.

GL_SOURCE0_RGB_ARB = $8580;

This item has no description.

GL_SOURCE1_RGB_ARB = $8581;

This item has no description.

GL_SOURCE2_RGB_ARB = $8582;

This item has no description.

GL_SOURCE0_ALPHA_ARB = $8588;

This item has no description.

GL_SOURCE1_ALPHA_ARB = $8589;

This item has no description.

GL_SOURCE2_ALPHA_ARB = $858A;

This item has no description.

GL_OPERAND0_RGB_ARB = $8590;

This item has no description.

GL_OPERAND1_RGB_ARB = $8591;

This item has no description.

GL_OPERAND2_RGB_ARB = $8592;

This item has no description.

GL_OPERAND0_ALPHA_ARB = $8598;

This item has no description.

GL_OPERAND1_ALPHA_ARB = $8599;

This item has no description.

GL_OPERAND2_ALPHA_ARB = $859A;

This item has no description.

GL_RGB_SCALE_ARB = $8573;

This item has no description.

GL_ADD_SIGNED_ARB = $8574;

This item has no description.

GL_INTERPOLATE_ARB = $8575;

This item has no description.

GL_SUBTRACT_ARB = $84E7;

This item has no description.

GL_CONSTANT_ARB = $8576;

This item has no description.

GL_PRIMARY_COLOR_ARB = $8577;

This item has no description.

GL_PREVIOUS_ARB = $8578;

This item has no description.

GL_DOT3_RGB_ARB = $86AE;

GL_ARB_texture_env_dot3

GL_DOT3_RGBA_ARB = $86AF;

This item has no description.

GL_TEXTURE_REDUCTION_MODE_ARB = $9366;

GL_ARB_texture_filter_minmax

GL_WEIGHTED_AVERAGE_ARB = $9367;

This item has no description.

GL_MIRRORED_REPEAT_ARB = $8370;

GL_ARB_texture_mirrored_repeat

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_ARB_transpose_matrix

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

This item has no description.

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

This item has no description.

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

This item has no description.

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ARB_vertex_blend

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

This item has no description.

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

This item has no description.

GL_VERTEX_BLEND_ARB = $86A7;

This item has no description.

GL_CURRENT_WEIGHT_ARB = $86A8;

This item has no description.

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

This item has no description.

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

This item has no description.

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

This item has no description.

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

This item has no description.

GL_WEIGHT_ARRAY_ARB = $86AD;

This item has no description.

GL_MODELVIEW0_ARB = $1700;

This item has no description.

GL_MODELVIEW1_ARB = $850A;

This item has no description.

GL_MODELVIEW2_ARB = $8722;

This item has no description.

GL_MODELVIEW3_ARB = $8723;

This item has no description.

GL_MODELVIEW4_ARB = $8724;

This item has no description.

GL_MODELVIEW5_ARB = $8725;

This item has no description.

GL_MODELVIEW6_ARB = $8726;

This item has no description.

GL_MODELVIEW7_ARB = $8727;

This item has no description.

GL_MODELVIEW8_ARB = $8728;

This item has no description.

GL_MODELVIEW9_ARB = $8729;

This item has no description.

GL_MODELVIEW10_ARB = $872A;

This item has no description.

GL_MODELVIEW11_ARB = $872B;

This item has no description.

GL_MODELVIEW12_ARB = $872C;

This item has no description.

GL_MODELVIEW13_ARB = $872D;

This item has no description.

GL_MODELVIEW14_ARB = $872E;

This item has no description.

GL_MODELVIEW15_ARB = $872F;

This item has no description.

GL_MODELVIEW16_ARB = $8730;

This item has no description.

GL_MODELVIEW17_ARB = $8731;

This item has no description.

GL_MODELVIEW18_ARB = $8732;

This item has no description.

GL_MODELVIEW19_ARB = $8733;

This item has no description.

GL_MODELVIEW20_ARB = $8734;

This item has no description.

GL_MODELVIEW21_ARB = $8735;

This item has no description.

GL_MODELVIEW22_ARB = $8736;

This item has no description.

GL_MODELVIEW23_ARB = $8737;

This item has no description.

GL_MODELVIEW24_ARB = $8738;

This item has no description.

GL_MODELVIEW25_ARB = $8739;

This item has no description.

GL_MODELVIEW26_ARB = $873A;

This item has no description.

GL_MODELVIEW27_ARB = $873B;

This item has no description.

GL_MODELVIEW28_ARB = $873C;

This item has no description.

GL_MODELVIEW29_ARB = $873D;

This item has no description.

GL_MODELVIEW30_ARB = $873E;

This item has no description.

GL_MODELVIEW31_ARB = $873F;

This item has no description.

GL_BUFFER_SIZE_ARB = $8764;

GL_ARB_vertex_buffer_object

GL_BUFFER_USAGE_ARB = $8765;

This item has no description.

GL_ARRAY_BUFFER_ARB = $8892;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

This item has no description.

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

This item has no description.

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

This item has no description.

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

This item has no description.

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

This item has no description.

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

This item has no description.

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

This item has no description.

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

This item has no description.

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

This item has no description.

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

This item has no description.

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

This item has no description.

GL_READ_ONLY_ARB = $88B8;

This item has no description.

GL_WRITE_ONLY_ARB = $88B9;

This item has no description.

GL_READ_WRITE_ARB = $88BA;

This item has no description.

GL_BUFFER_ACCESS_ARB = $88BB;

This item has no description.

GL_BUFFER_MAPPED_ARB = $88BC;

This item has no description.

GL_BUFFER_MAP_POINTER_ARB = $88BD;

This item has no description.

GL_STREAM_DRAW_ARB = $88E0;

This item has no description.

GL_STREAM_READ_ARB = $88E1;

This item has no description.

GL_STREAM_COPY_ARB = $88E2;

This item has no description.

GL_STATIC_DRAW_ARB = $88E4;

This item has no description.

GL_STATIC_READ_ARB = $88E5;

This item has no description.

GL_STATIC_COPY_ARB = $88E6;

This item has no description.

GL_DYNAMIC_DRAW_ARB = $88E8;

This item has no description.

GL_DYNAMIC_READ_ARB = $88E9;

This item has no description.

GL_DYNAMIC_COPY_ARB = $88EA;

This item has no description.

GL_COLOR_SUM_ARB = $8458;

GL_ARB_vertex_program

GL_VERTEX_PROGRAM_ARB = $8620;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

This item has no description.

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

This item has no description.

GL_PROGRAM_LENGTH_ARB = $8627;

This item has no description.

GL_PROGRAM_STRING_ARB = $8628;

This item has no description.

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

This item has no description.

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

This item has no description.

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

This item has no description.

GL_CURRENT_MATRIX_ARB = $8641;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

This item has no description.

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

This item has no description.

GL_PROGRAM_BINDING_ARB = $8677;

This item has no description.

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

This item has no description.

GL_PROGRAM_ERROR_STRING_ARB = $8874;

This item has no description.

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

This item has no description.

GL_PROGRAM_FORMAT_ARB = $8876;

This item has no description.

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

This item has no description.

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

This item has no description.

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

This item has no description.

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

This item has no description.

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

This item has no description.

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

This item has no description.

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

This item has no description.

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

This item has no description.

GL_PROGRAM_PARAMETERS_ARB = $88A8;

This item has no description.

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

This item has no description.

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

This item has no description.

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

This item has no description.

GL_PROGRAM_ATTRIBS_ARB = $88AC;

This item has no description.

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

This item has no description.

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

This item has no description.

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

This item has no description.

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

This item has no description.

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

This item has no description.

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

This item has no description.

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

This item has no description.

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

This item has no description.

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

This item has no description.

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

This item has no description.

GL_MATRIX0_ARB = $88C0;

This item has no description.

GL_MATRIX1_ARB = $88C1;

This item has no description.

GL_MATRIX2_ARB = $88C2;

This item has no description.

GL_MATRIX3_ARB = $88C3;

This item has no description.

GL_MATRIX4_ARB = $88C4;

This item has no description.

GL_MATRIX5_ARB = $88C5;

This item has no description.

GL_MATRIX6_ARB = $88C6;

This item has no description.

GL_MATRIX7_ARB = $88C7;

This item has no description.

GL_MATRIX8_ARB = $88C8;

This item has no description.

GL_MATRIX9_ARB = $88C9;

This item has no description.

GL_MATRIX10_ARB = $88CA;

This item has no description.

GL_MATRIX11_ARB = $88CB;

This item has no description.

GL_MATRIX12_ARB = $88CC;

This item has no description.

GL_MATRIX13_ARB = $88CD;

This item has no description.

GL_MATRIX14_ARB = $88CE;

This item has no description.

GL_MATRIX15_ARB = $88CF;

This item has no description.

GL_MATRIX16_ARB = $88D0;

This item has no description.

GL_MATRIX17_ARB = $88D1;

This item has no description.

GL_MATRIX18_ARB = $88D2;

This item has no description.

GL_MATRIX19_ARB = $88D3;

This item has no description.

GL_MATRIX20_ARB = $88D4;

This item has no description.

GL_MATRIX21_ARB = $88D5;

This item has no description.

GL_MATRIX22_ARB = $88D6;

This item has no description.

GL_MATRIX23_ARB = $88D7;

This item has no description.

GL_MATRIX24_ARB = $88D8;

This item has no description.

GL_MATRIX25_ARB = $88D9;

This item has no description.

GL_MATRIX26_ARB = $88DA;

This item has no description.

GL_MATRIX27_ARB = $88DB;

This item has no description.

GL_MATRIX28_ARB = $88DC;

This item has no description.

GL_MATRIX29_ARB = $88DD;

This item has no description.

GL_MATRIX30_ARB = $88DE;

This item has no description.

GL_MATRIX31_ARB = $88DF;

This item has no description.

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_ARB_draw_buffers

GL_DRAW_BUFFER0_ARB = $8825;

This item has no description.

GL_DRAW_BUFFER1_ARB = $8826;

This item has no description.

GL_DRAW_BUFFER2_ARB = $8827;

This item has no description.

GL_DRAW_BUFFER3_ARB = $8828;

This item has no description.

GL_DRAW_BUFFER4_ARB = $8829;

This item has no description.

GL_DRAW_BUFFER5_ARB = $882A;

This item has no description.

GL_DRAW_BUFFER6_ARB = $882B;

This item has no description.

GL_DRAW_BUFFER7_ARB = $882C;

This item has no description.

GL_DRAW_BUFFER8_ARB = $882D;

This item has no description.

GL_DRAW_BUFFER9_ARB = $882E;

This item has no description.

GL_DRAW_BUFFER10_ARB = $882F;

This item has no description.

GL_DRAW_BUFFER11_ARB = $8830;

This item has no description.

GL_DRAW_BUFFER12_ARB = $8831;

This item has no description.

GL_DRAW_BUFFER13_ARB = $8832;

This item has no description.

GL_DRAW_BUFFER14_ARB = $8833;

This item has no description.

GL_DRAW_BUFFER15_ARB = $8834;

This item has no description.

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_ARB_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

This item has no description.

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_ARB_color_buffer_float

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

This item has no description.

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

This item has no description.

GL_CLAMP_READ_COLOR_ARB = $891C;

This item has no description.

GL_FIXED_ONLY_ARB = $891D;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

This item has no description.

GLX_RGBA_FLOAT_TYPE = $20B9;

This item has no description.

GLX_RGBA_FLOAT_BIT = $00000004;

This item has no description.

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB = $9344;

GL_ARB_compute_variable_group_size

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB = $90EB;

This item has no description.

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB = $9345;

This item has no description.

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB = $91BF;

This item has no description.

GL_HALF_FLOAT_ARB = $140B;

GL_ARB_half_float_pixel

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_ARB_texture_float

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

This item has no description.

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

This item has no description.

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

This item has no description.

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

This item has no description.

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

This item has no description.

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

This item has no description.

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

This item has no description.

GL_RGBA32F_ARB = $8814;

This item has no description.

GL_RGB32F_ARB = $8815;

This item has no description.

GL_ALPHA32F_ARB = $8816;

This item has no description.

GL_INTENSITY32F_ARB = $8817;

This item has no description.

GL_LUMINANCE32F_ARB = $8818;

This item has no description.

GL_LUMINANCE_ALPHA32F_ARB = $8819;

This item has no description.

GL_RGBA16F_ARB = $881A;

This item has no description.

GL_RGB16F_ARB = $881B;

This item has no description.

GL_ALPHA16F_ARB = $881C;

This item has no description.

GL_INTENSITY16F_ARB = $881D;

This item has no description.

GL_LUMINANCE16F_ARB = $881E;

This item has no description.

GL_LUMINANCE_ALPHA16F_ARB = $881F;

This item has no description.

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_ARB_pixel_buffer_object

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

This item has no description.

GL_DEPTH_COMPONENT32F = $8CAC;

GL_ARB_depth_buffer_float

GL_DEPTH32F_STENCIL8 = $8CAD;

This item has no description.

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

This item has no description.

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_ARB_framebuffer_object

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

This item has no description.

GL_FRAMEBUFFER_DEFAULT = $8218;

This item has no description.

GL_FRAMEBUFFER_UNDEFINED = $8219;

This item has no description.

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

This item has no description.

GL_MAX_RENDERBUFFER_SIZE = $84E8;

This item has no description.

GL_DEPTH_STENCIL = $84F9;

This item has no description.

GL_UNSIGNED_INT_24_8 = $84FA;

This item has no description.

GL_DEPTH24_STENCIL8 = $88F0;

This item has no description.

GL_TEXTURE_STENCIL_SIZE = $88F1;

This item has no description.

GL_TEXTURE_RED_TYPE = $8C10;

This item has no description.

GL_TEXTURE_GREEN_TYPE = $8C11;

This item has no description.

GL_TEXTURE_BLUE_TYPE = $8C12;

This item has no description.

GL_TEXTURE_ALPHA_TYPE = $8C13;

This item has no description.

GL_TEXTURE_DEPTH_TYPE = $8C16;

This item has no description.

GL_UNSIGNED_NORMALIZED = $8C17;

This item has no description.

GL_FRAMEBUFFER_BINDING = $8CA6;

This item has no description.

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

This item has no description.

GL_RENDERBUFFER_BINDING = $8CA7;

This item has no description.

GL_READ_FRAMEBUFFER = $8CA8;

This item has no description.

GL_DRAW_FRAMEBUFFER = $8CA9;

This item has no description.

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

This item has no description.

GL_RENDERBUFFER_SAMPLES = $8CAB;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

This item has no description.

GL_FRAMEBUFFER_COMPLETE = $8CD5;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

This item has no description.

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

This item has no description.

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

This item has no description.

GL_COLOR_ATTACHMENT0 = $8CE0;

This item has no description.

GL_COLOR_ATTACHMENT1 = $8CE1;

This item has no description.

GL_COLOR_ATTACHMENT2 = $8CE2;

This item has no description.

GL_COLOR_ATTACHMENT3 = $8CE3;

This item has no description.

GL_COLOR_ATTACHMENT4 = $8CE4;

This item has no description.

GL_COLOR_ATTACHMENT5 = $8CE5;

This item has no description.

GL_COLOR_ATTACHMENT6 = $8CE6;

This item has no description.

GL_COLOR_ATTACHMENT7 = $8CE7;

This item has no description.

GL_COLOR_ATTACHMENT8 = $8CE8;

This item has no description.

GL_COLOR_ATTACHMENT9 = $8CE9;

This item has no description.

GL_COLOR_ATTACHMENT10 = $8CEA;

This item has no description.

GL_COLOR_ATTACHMENT11 = $8CEB;

This item has no description.

GL_COLOR_ATTACHMENT12 = $8CEC;

This item has no description.

GL_COLOR_ATTACHMENT13 = $8CED;

This item has no description.

GL_COLOR_ATTACHMENT14 = $8CEE;

This item has no description.

GL_COLOR_ATTACHMENT15 = $8CEF;

This item has no description.

GL_DEPTH_ATTACHMENT = $8D00;

This item has no description.

GL_STENCIL_ATTACHMENT = $8D20;

This item has no description.

GL_FRAMEBUFFER = $8D40;

This item has no description.

GL_RENDERBUFFER = $8D41;

This item has no description.

GL_RENDERBUFFER_WIDTH = $8D42;

This item has no description.

GL_RENDERBUFFER_HEIGHT = $8D43;

This item has no description.

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

This item has no description.

GL_STENCIL_INDEX1 = $8D46;

This item has no description.

GL_STENCIL_INDEX4 = $8D47;

This item has no description.

GL_STENCIL_INDEX8 = $8D48;

This item has no description.

GL_STENCIL_INDEX16 = $8D49;

This item has no description.

GL_RENDERBUFFER_RED_SIZE = $8D50;

This item has no description.

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

This item has no description.

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

This item has no description.

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

This item has no description.

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

This item has no description.

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

This item has no description.

GL_MAX_SAMPLES = $8D57;

This item has no description.

GL_INDEX = $8222;

This item has no description.

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

This item has no description.

GL_TEXTURE_INTENSITY_TYPE = $8C15;

This item has no description.

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_ARB_framebuffer_sRGB

GL_LINES_ADJACENCY_ARB = $000A;

GL_ARB_geometry_shader4

GL_LINE_STRIP_ADJACENCY_ARB = $000B;

This item has no description.

GL_TRIANGLES_ADJACENCY_ARB = $000C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $000D;

This item has no description.

GL_PROGRAM_POINT_SIZE_ARB = $8642;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

This item has no description.

GL_GEOMETRY_SHADER_ARB = $8DD9;

This item has no description.

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

This item has no description.

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

This item has no description.

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

This item has no description.

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

This item has no description.

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB = $9551;

GL_ARB_gl_spirv

GL_SPIR_V_BINARY_ARB = $9552;

This item has no description.

GL_HALF_FLOAT = $140B;

GL_ARB_half_float_vertex

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_ARB_instanced_arrays

GL_MAP_READ_BIT = $0001;

GL_ARB_map_buffer_range

GL_MAP_WRITE_BIT = $0002;

This item has no description.

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

This item has no description.

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

This item has no description.

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

This item has no description.

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

This item has no description.

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_ARB_texture_buffer_object

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

This item has no description.

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_ARB_texture_compression_rgtc

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

This item has no description.

GL_COMPRESSED_RG_RGTC2 = $8DBD;

This item has no description.

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

This item has no description.

GL_RG = $8227;

GL_ARB_texture_rg

GL_RG_INTEGER = $8228;

This item has no description.

GL_R8 = $8229;

This item has no description.

GL_R16 = $822A;

This item has no description.

GL_RG8 = $822B;

This item has no description.

GL_RG16 = $822C;

This item has no description.

GL_R16F = $822D;

This item has no description.

GL_R32F = $822E;

This item has no description.

GL_RG16F = $822F;

This item has no description.

GL_RG32F = $8230;

This item has no description.

GL_R8I = $8231;

This item has no description.

GL_R8UI = $8232;

This item has no description.

GL_R16I = $8233;

This item has no description.

GL_R16UI = $8234;

This item has no description.

GL_R32I = $8235;

This item has no description.

GL_R32UI = $8236;

This item has no description.

GL_RG8I = $8237;

This item has no description.

GL_RG8UI = $8238;

This item has no description.

GL_RG16I = $8239;

This item has no description.

GL_RG16UI = $823A;

This item has no description.

GL_RG32I = $823B;

This item has no description.

GL_RG32UI = $823C;

This item has no description.

GL_VERTEX_ARRAY_BINDING = $85B5;

GL_ARB_vertex_array_object

GL_UNIFORM_BUFFER = $8A11;

GL_ARB_uniform_buffer_object

GL_UNIFORM_BUFFER_BINDING = $8A28;

This item has no description.

GL_UNIFORM_BUFFER_START = $8A29;

This item has no description.

GL_UNIFORM_BUFFER_SIZE = $8A2A;

This item has no description.

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

This item has no description.

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

This item has no description.

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

This item has no description.

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

This item has no description.

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

This item has no description.

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

This item has no description.

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

This item has no description.

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

This item has no description.

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

This item has no description.

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

This item has no description.

GL_UNIFORM_TYPE = $8A37;

This item has no description.

GL_UNIFORM_SIZE = $8A38;

This item has no description.

GL_UNIFORM_NAME_LENGTH = $8A39;

This item has no description.

GL_UNIFORM_BLOCK_INDEX = $8A3A;

This item has no description.

GL_UNIFORM_OFFSET = $8A3B;

This item has no description.

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

This item has no description.

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

This item has no description.

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

This item has no description.

GL_UNIFORM_BLOCK_BINDING = $8A3F;

This item has no description.

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

This item has no description.

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

This item has no description.

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

This item has no description.

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

This item has no description.

GL_INVALID_INDEX = $FFFFFFFF;

This item has no description.

GL_COPY_READ_BUFFER_BINDING = $8F36;

GL_ARB_copy_buffer

GL_COPY_READ_BUFFER = GL_COPY_READ_BUFFER_BINDING;

This item has no description.

GL_COPY_WRITE_BUFFER_BINDING = $8F37;

This item has no description.

GL_COPY_WRITE_BUFFER = GL_COPY_WRITE_BUFFER_BINDING;

This item has no description.

GL_DEPTH_CLAMP = $864F;

GL_ARB_depth_clamp

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_ARB_provoking_vertex

GL_FIRST_VERTEX_CONVENTION = $8E4D;

This item has no description.

GL_LAST_VERTEX_CONVENTION = $8E4E;

This item has no description.

GL_PROVOKING_VERTEX = $8E4F;

This item has no description.

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_ARB_seamless_cube_map

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_ARB_sync

GL_OBJECT_TYPE = $9112;

This item has no description.

GL_SYNC_CONDITION = $9113;

This item has no description.

GL_SYNC_STATUS = $9114;

This item has no description.

GL_SYNC_FLAGS = $9115;

This item has no description.

GL_SYNC_FENCE = $9116;

This item has no description.

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

This item has no description.

GL_UNSIGNALED = $9118;

This item has no description.

GL_SIGNALED = $9119;

This item has no description.

GL_ALREADY_SIGNALED = $911A;

This item has no description.

GL_TIMEOUT_EXPIRED = $911B;

This item has no description.

GL_CONDITION_SATISFIED = $911C;

This item has no description.

GL_WAIT_FAILED = $911D;

This item has no description.

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

This item has no description.

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

This item has no description.

GL_SAMPLE_POSITION = $8E50;

GL_ARB_texture_multisample

GL_SAMPLE_MASK = $8E51;

This item has no description.

GL_SAMPLE_MASK_VALUE = $8E52;

This item has no description.

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

This item has no description.

GL_TEXTURE_2D_MULTISAMPLE = $9100;

This item has no description.

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

This item has no description.

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

This item has no description.

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

This item has no description.

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

This item has no description.

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

This item has no description.

GL_TEXTURE_SAMPLES = $9106;

This item has no description.

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

This item has no description.

GL_SAMPLER_2D_MULTISAMPLE = $9108;

This item has no description.

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

This item has no description.

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

This item has no description.

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

This item has no description.

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

This item has no description.

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

This item has no description.

GL_MAX_INTEGER_SAMPLES = $9110;

This item has no description.

GL_SAMPLE_SHADING_ARB = $8C36;

GL_ARB_sample_shading

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

This item has no description.

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB = $933D;

GL_ARB_sample_locations

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB = $933E;

This item has no description.

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB = $933F;

This item has no description.

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB = $9340;

This item has no description.

GL_SAMPLE_LOCATION_ARB = $8E50;

This item has no description.

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB = $9341;

This item has no description.

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB = $9342;

This item has no description.

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB = $9343;

This item has no description.

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_ARB_texture_cube_map_array

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

This item has no description.

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

This item has no description.

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_ARB_texture_gather

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

This item has no description.

GL_SHADER_INCLUDE_ARB = $8DAE;

GL_ARB_shading_language_include

GL_NAMED_STRING_LENGTH_ARB = $8DE9;

This item has no description.

GL_NAMED_STRING_TYPE_ARB = $8DEA;

This item has no description.

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_ARB_texture_compression_bptc

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

This item has no description.

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

This item has no description.

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

This item has no description.

GL_SRC1_COLOR = $88F9;

GL_ARB_blend_func_extended

GL_ONE_MINUS_SRC1_COLOR = $88FA;

This item has no description.

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

This item has no description.

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

This item has no description.

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_ARB_occlusion_query2

GL_MAX_SHADER_COMPILER_THREADS_ARB = $91B0;

GL_ARB_parallel_shader_compile

GL_COMPLETION_STATUS_ARB = $91B1;

This item has no description.

GL_SAMPLER_BINDING = $8919;

GL_ARB_sampler_objects

GL_RGB10_A2UI = $906F;

GL_ARB_texture_rgb10_a2ui

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_ARB_texture_swizzle

GL_TEXTURE_SWIZZLE_G = $8E43;

This item has no description.

GL_TEXTURE_SWIZZLE_B = $8E44;

This item has no description.

GL_TEXTURE_SWIZZLE_A = $8E45;

This item has no description.

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

This item has no description.

GL_TEXTURE_SPARSE_ARB = $91A6;

GL_ARB_SPARSE_TEXTURE

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB = $91A7;

This item has no description.

GL_NUM_VIRTUAL_PAGE_SIZES_ARB = $91A8;

This item has no description.

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB = $91A9;

This item has no description.

GL_NUM_SPARSE_LEVELS_ARB = $91AA;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_X_ARB = $9195;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_Y_ARB = $9196;

This item has no description.

GL_VIRTUAL_PAGE_SIZE_Z_ARB = $9197;

This item has no description.

GL_MAX_SPARSE_TEXTURE_SIZE_ARB = $9198;

This item has no description.

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB = $9199;

This item has no description.

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB = $919A;

This item has no description.

GL_MIN_SPARSE_LEVEL_ARB = $919B;

This item has no description.

GL_TIME_ELAPSED = $88BF;

GL_ARB_timer_query

GL_TIMESTAMP = $8E28;

This item has no description.

GL_INT_2_10_10_10_REV = $8D9F;

reuse GL_UNSIGNED_INT_2_10_10_10_REV

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_ARB_draw_indirect

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

This item has no description.

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_ARB_gpu_shader5

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

This item has no description.

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

This item has no description.

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

This item has no description.

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

This item has no description.

GL_DOUBLE_VEC2 = $8FFC;

GL_ARB_gpu_shader_fp64

GL_DOUBLE_VEC3 = $8FFD;

This item has no description.

GL_DOUBLE_VEC4 = $8FFE;

This item has no description.

GL_DOUBLE_MAT2 = $8F46;

This item has no description.

GL_DOUBLE_MAT3 = $8F47;

This item has no description.

GL_DOUBLE_MAT4 = $8F48;

This item has no description.

GL_DOUBLE_MAT2x3 = $8F49;

This item has no description.

GL_DOUBLE_MAT2x4 = $8F4A;

This item has no description.

GL_DOUBLE_MAT3x2 = $8F4B;

This item has no description.

GL_DOUBLE_MAT3x4 = $8F4C;

This item has no description.

GL_DOUBLE_MAT4x2 = $8F4D;

This item has no description.

GL_DOUBLE_MAT4x3 = $8F4E;

This item has no description.

GL_INT64_ARB = $140E;

GL_ARB_gpu_shader_int64

GL_INT64_VEC2_ARB = $8FE9;

This item has no description.

GL_INT64_VEC3_ARB = $8FEA;

This item has no description.

GL_INT64_VEC4_ARB = $8FEB;

This item has no description.

GL_UNSIGNED_INT64_VEC2_ARB = $8FF5;

This item has no description.

GL_UNSIGNED_INT64_VEC3_ARB = $8FF6;

This item has no description.

GL_UNSIGNED_INT64_VEC4_ARB = $8FF7;

This item has no description.

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ARB_shader_subroutine

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

This item has no description.

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

This item has no description.

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

This item has no description.

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

This item has no description.

GL_MAX_SUBROUTINES = $8DE7;

This item has no description.

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

This item has no description.

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

This item has no description.

GL_COMPATIBLE_SUBROUTINES = $8E4B;

This item has no description.

GL_PATCHES = $000E;

GL_ARB_tessellation_shader

GL_PATCH_VERTICES = $8E72;

This item has no description.

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

This item has no description.

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

This item has no description.

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

This item has no description.

GL_TESS_GEN_MODE = $8E76;

This item has no description.

GL_TESS_GEN_SPACING = $8E77;

This item has no description.

GL_TESS_GEN_VERTEX_ORDER = $8E78;

This item has no description.

GL_TESS_GEN_POINT_MODE = $8E79;

This item has no description.

GL_ISOLINES = $8E7A;

This item has no description.

GL_FRACTIONAL_ODD = $8E7B;

This item has no description.

GL_FRACTIONAL_EVEN = $8E7C;

This item has no description.

GL_MAX_PATCH_VERTICES = $8E7D;

This item has no description.

GL_MAX_TESS_GEN_LEVEL = $8E7E;

This item has no description.

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

This item has no description.

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

This item has no description.

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

This item has no description.

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

This item has no description.

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

This item has no description.

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

This item has no description.

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

This item has no description.

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

This item has no description.

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

This item has no description.

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

This item has no description.

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

This item has no description.

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

This item has no description.

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

This item has no description.

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

This item has no description.

GL_TESS_EVALUATION_SHADER = $8E87;

This item has no description.

GL_TESS_CONTROL_SHADER = $8E88;

This item has no description.

GL_TRANSFORM_FEEDBACK = $8E22;

GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2

GL_TRANSFORM_FEEDBACK_PAUSED = $8E23;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = GL_TRANSFORM_FEEDBACK_PAUSED;

This item has no description.

GL_TRANSFORM_FEEDBACK_ACTIVE = $8E24;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = GL_TRANSFORM_FEEDBACK_ACTIVE;

This item has no description.

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

This item has no description.

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB = $82EC;

GL_ARB_transform_feedback_overflow_query

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB = $82ED;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_ARB_transform_feedback3

GL_MAX_VERTEX_STREAMS = $8E71;

This item has no description.

GL_FIXED = $140C;

GL_ARB_ES2_compatibility

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

This item has no description.

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

This item has no description.

GL_LOW_FLOAT = $8DF0;

This item has no description.

GL_MEDIUM_FLOAT = $8DF1;

This item has no description.

GL_HIGH_FLOAT = $8DF2;

This item has no description.

GL_LOW_INT = $8DF3;

This item has no description.

GL_MEDIUM_INT = $8DF4;

This item has no description.

GL_HIGH_INT = $8DF5;

This item has no description.

GL_SHADER_COMPILER = $8DFA;

This item has no description.

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

This item has no description.

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

This item has no description.

GL_MAX_VARYING_VECTORS = $8DFC;

This item has no description.

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

This item has no description.

GL_RGB565 = $8D62;

This item has no description.

GL_PRIMITIVE_BOUNDING_BOX_ARB = $092BE;

GL_ARB_ES3_2_compatibility

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB = $09381;

This item has no description.

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB = $09382;

This item has no description.

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_ARB_get_program_binary

GL_PROGRAM_BINARY_LENGTH = $8741;

This item has no description.

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

This item has no description.

GL_PROGRAM_BINARY_FORMATS = $87FF;

This item has no description.

GL_VERTEX_SHADER_BIT = $00000001;

GL_ARB_separate_shader_objects

GL_FRAGMENT_SHADER_BIT = $00000002;

This item has no description.

GL_GEOMETRY_SHADER_BIT = $00000004;

This item has no description.

GL_TESS_CONTROL_SHADER_BIT = $00000008;

This item has no description.

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

This item has no description.

GL_ALL_SHADER_BITS = $FFFFFFFF;

This item has no description.

GL_PROGRAM_SEPARABLE = $8258;

This item has no description.

GL_ACTIVE_PROGRAM = $8259;

This item has no description.

GL_PROGRAM_PIPELINE_BINDING = $825A;

This item has no description.

GL_MAX_VIEWPORTS = $825B;

GL_ARB_vertex_attrib_64bit

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

This item has no description.

GL_VIEWPORT_BOUNDS_RANGE = $825D;

This item has no description.

GL_LAYER_PROVOKING_VERTEX = $825E;

This item has no description.

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

This item has no description.

GL_UNDEFINED_VERTEX = $8260;

This item has no description.

GL_SYNC_CL_EVENT_ARB = $8240;

GL_ARB_cl_event

GL_SYNC_CL_EVENT_COMPLETE_ARB = $8241;

This item has no description.

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_ARB_debug_output

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

This item has no description.

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

This item has no description.

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

This item has no description.

GL_DEBUG_SOURCE_API_ARB = $8246;

This item has no description.

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

This item has no description.

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

This item has no description.

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

This item has no description.

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

This item has no description.

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

This item has no description.

GL_DEBUG_TYPE_ERROR_ARB = $824C;

This item has no description.

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

This item has no description.

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

This item has no description.

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

This item has no description.

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

This item has no description.

GL_DEBUG_TYPE_OTHER_ARB = $8251;

This item has no description.

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

This item has no description.

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

This item has no description.

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_ARB_robustness

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

This item has no description.

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

This item has no description.

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

This item has no description.

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

GL_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_WIDTH = $09127;

GL_ARB_compressed_texture_pixel_storage

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT = $09128;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_DEPTH = $09129;

This item has no description.

GL_UNPACK_COMPRESSED_BLOCK_SIZE = $0912A;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_WIDTH = $0912B;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_HEIGHT = $0912C;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_DEPTH = $0912D;

This item has no description.

GL_PACK_COMPRESSED_BLOCK_SIZE = $0912E;

This item has no description.

GL_NUM_SAMPLE_COUNTS = $09380;

GL_ARB_internalformat_query

GL_MIN_MAP_BUFFER_ALIGNMENT = $090BC;

GL_ARB_map_buffer_alignment

GL_ATOMIC_COUNTER_BUFFER = $92C0;

GL_ARB_shader_atomic_counters

GL_ATOMIC_COUNTER_BUFFER_BINDING = $92C1;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_START = $92C2;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_SIZE = $92C3;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE = $92C4;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS = $92C5;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES = $92C6;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER = $92C7;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER = $92C8;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER = $92C9;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER = $92CA;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER = $92CB;

This item has no description.

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS = $92CC;

This item has no description.

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS = $92CD;

This item has no description.

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS = $92CE;

This item has no description.

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS = $92CF;

This item has no description.

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS = $92D0;

This item has no description.

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS = $92D1;

This item has no description.

GL_MAX_VERTEX_ATOMIC_COUNTERS = $92D2;

This item has no description.

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS = $92D3;

This item has no description.

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS = $92D4;

This item has no description.

GL_MAX_GEOMETRY_ATOMIC_COUNTERS = $92D5;

This item has no description.

GL_MAX_FRAGMENT_ATOMIC_COUNTERS = $92D6;

This item has no description.

GL_MAX_COMBINED_ATOMIC_COUNTERS = $92D7;

This item has no description.

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE = $92D8;

This item has no description.

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS = $92DC;

This item has no description.

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS = $92D9;

This item has no description.

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX = $92DA;

This item has no description.

GL_UNSIGNED_INT_ATOMIC_COUNTER = $92DB;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT = $00000001;

GL_ARB_shader_image_load_store

GL_ELEMENT_ARRAY_BARRIER_BIT = $00000002;

This item has no description.

GL_UNIFORM_BARRIER_BIT = $00000004;

This item has no description.

GL_TEXTURE_FETCH_BARRIER_BIT = $00000008;

This item has no description.

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT = $00000020;

This item has no description.

GL_COMMAND_BARRIER_BIT = $00000040;

This item has no description.

GL_PIXEL_BUFFER_BARRIER_BIT = $00000080;

This item has no description.

GL_TEXTURE_UPDATE_BARRIER_BIT = $00000100;

This item has no description.

GL_BUFFER_UPDATE_BARRIER_BIT = $00000200;

This item has no description.

GL_FRAMEBUFFER_BARRIER_BIT = $00000400;

This item has no description.

GL_TRANSFORM_FEEDBACK_BARRIER_BIT = $00000800;

This item has no description.

GL_ATOMIC_COUNTER_BARRIER_BIT = $00001000;

This item has no description.

GL_ALL_BARRIER_BITS = $FFFFFFFF;

This item has no description.

GL_MAX_IMAGE_UNITS = $8F38;

This item has no description.

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS = $8F39;

This item has no description.

GL_IMAGE_BINDING_NAME = $8F3A;

This item has no description.

GL_IMAGE_BINDING_LEVEL = $8F3B;

This item has no description.

GL_IMAGE_BINDING_LAYERED = $8F3C;

This item has no description.

GL_IMAGE_BINDING_LAYER = $8F3D;

This item has no description.

GL_IMAGE_BINDING_ACCESS = $8F3E;

This item has no description.

GL_IMAGE_1D = $904C;

This item has no description.

GL_IMAGE_2D = $904D;

This item has no description.

GL_IMAGE_3D = $904E;

This item has no description.

GL_IMAGE_2D_RECT = $904F;

This item has no description.

GL_IMAGE_CUBE = $9050;

This item has no description.

GL_IMAGE_BUFFER = $9051;

This item has no description.

GL_IMAGE_1D_ARRAY = $9052;

This item has no description.

GL_IMAGE_2D_ARRAY = $9053;

This item has no description.

GL_IMAGE_CUBE_MAP_ARRAY = $9054;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE = $9055;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_ARRAY = $9056;

This item has no description.

GL_INT_IMAGE_1D = $9057;

This item has no description.

GL_INT_IMAGE_2D = $9058;

This item has no description.

GL_INT_IMAGE_3D = $9059;

This item has no description.

GL_INT_IMAGE_2D_RECT = $905A;

This item has no description.

GL_INT_IMAGE_CUBE = $905B;

This item has no description.

GL_INT_IMAGE_BUFFER = $905C;

This item has no description.

GL_INT_IMAGE_1D_ARRAY = $905D;

This item has no description.

GL_INT_IMAGE_2D_ARRAY = $905E;

This item has no description.

GL_INT_IMAGE_CUBE_MAP_ARRAY = $905F;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE = $9060;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $9061;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D = $9062;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D = $9063;

This item has no description.

GL_UNSIGNED_INT_IMAGE_3D = $9064;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_RECT = $9065;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE = $9066;

This item has no description.

GL_UNSIGNED_INT_IMAGE_BUFFER = $9067;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_ARRAY = $9068;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_ARRAY = $9069;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY = $906A;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE = $906B;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY = $906C;

This item has no description.

GL_MAX_IMAGE_SAMPLES = $906D;

This item has no description.

GL_IMAGE_BINDING_FORMAT = $906E;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE = $90C7;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE = $90C8;

This item has no description.

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS = $90C9;

This item has no description.

GL_MAX_VERTEX_IMAGE_UNIFORMS = $90CA;

This item has no description.

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS = $90CB;

This item has no description.

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS = $90CC;

This item has no description.

GL_MAX_GEOMETRY_IMAGE_UNIFORMS = $90CD;

This item has no description.

GL_MAX_FRAGMENT_IMAGE_UNIFORMS = $90CE;

This item has no description.

GL_MAX_COMBINED_IMAGE_UNIFORMS = $90CF;

This item has no description.

GL_TEXTURE_IMMUTABLE_FORMAT = $912F;

GL_ARB_texture_storage

GL_COMPRESSED_RGBA_ASTC_4x4_KHR = $93B0;

4.3 GL_KHR_texture_compression_astc_hdr

GL_COMPRESSED_RGBA_ASTC_5x4_KHR = $93B1;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_5x5_KHR = $93B2;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_6x5_KHR = $93B3;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_6x6_KHR = $93B4;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x5_KHR = $93B5;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x6_KHR = $93B6;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_8x8_KHR = $93B7;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_105_KHR = $93B8;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_106_KHR = $93B9;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_108_KHR = $93BA;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_110_KHR = $93BB;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_12x10_KHR = $93BC;

This item has no description.

GL_COMPRESSED_RGBA_ASTC_12x12_KHR = $93BD;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR = $93D0;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR = $93D1;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR = $93D2;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR = $93D3;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR = $93D4;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR = $93D5;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR = $93D6;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR = $93D7;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR = $93D8;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR = $93D9;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR = $93DA;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR = $93DB;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR = $93DC;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR = $93DD;

This item has no description.

GL_DEBUG_OUTPUT_SYNCHRONOUS = $8242;

(4.3) GL_KHR_debug

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH = $8243;

This item has no description.

GL_DEBUG_CALLBACK_FUNCTION = $8244;

This item has no description.

GL_DEBUG_CALLBACK_USER_PARAM = $8245;

This item has no description.

GL_DEBUG_SOURCE_API = $8246;

This item has no description.

GL_DEBUG_SOURCE_WINDOW_SYSTEM = $8247;

This item has no description.

GL_DEBUG_SOURCE_SHADER_COMPILER = $8248;

This item has no description.

GL_DEBUG_SOURCE_THIRD_PARTY = $8249;

This item has no description.

GL_DEBUG_SOURCE_APPLICATION = $824A;

This item has no description.

GL_DEBUG_SOURCE_OTHER = $824B;

This item has no description.

GL_DEBUG_TYPE_ERROR = $824C;

This item has no description.

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR = $824D;

This item has no description.

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR = $824E;

This item has no description.

GL_DEBUG_TYPE_PORTABILITY = $824F;

This item has no description.

GL_DEBUG_TYPE_PERFORMANCE = $8250;

This item has no description.

GL_DEBUG_TYPE_OTHER = $8251;

This item has no description.

GL_DEBUG_TYPE_MARKER = $8268;

This item has no description.

GL_DEBUG_TYPE_PUSH_GROUP = $8269;

This item has no description.

GL_DEBUG_TYPE_POP_GROUP = $826A;

This item has no description.

GL_DEBUG_SEVERITY_NOTIFICATION = $826B;

This item has no description.

GL_MAX_DEBUG_GROUP_STACK_DEPTH = $826C;

This item has no description.

GL_DEBUG_GROUP_STACK_DEPTH = $826D;

This item has no description.

GL_BUFFER = $82E0;

This item has no description.

GL_SHADER = $82E1;

This item has no description.

GL_PROGRAM = $82E2;

This item has no description.

GL_QUERY = $82E3;

This item has no description.

GL_PROGRAM_PIPELINE = $82E4;

This item has no description.

GL_SAMPLER = $82E6;

This item has no description.

GL_DISPLAY_LIST = $82E7;

This item has no description.

GL_MAX_LABEL_LENGTH = $82E8;

This item has no description.

GL_MAX_DEBUG_MESSAGE_LENGTH = $9143;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES = $9144;

This item has no description.

GL_DEBUG_LOGGED_MESSAGES = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW = $9148;

This item has no description.

GL_DEBUG_OUTPUT = $92E0;

This item has no description.

GL_CONTEXT_FLAG_DEBUG_BIT = $00000002;

This item has no description.

GL_COMPUTE_SHADER = $91B9;

This item has no description.

GL_MAX_COMPUTE_UNIFORM_BLOCKS = $91BB;

This item has no description.

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS = $91BC;

This item has no description.

GL_MAX_COMPUTE_IMAGE_UNIFORMS = $91BD;

This item has no description.

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE = $8262;

This item has no description.

GL_MAX_COMPUTE_UNIFORM_COMPONENTS = $8263;

This item has no description.

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS = $8264;

This item has no description.

GL_MAX_COMPUTE_ATOMIC_COUNTERS = $8265;

This item has no description.

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS = $8266;

This item has no description.

GL_MAX_COMPUTE_LOCAL_INVOCATIONS = $90EB;

This item has no description.

GL_MAX_COMPUTE_WORK_GROUP_COUNT = $91BE;

This item has no description.

GL_MAX_COMPUTE_WORK_GROUP_SIZE = $91BF;

This item has no description.

GL_COMPUTE_LOCAL_WORK_SIZE = $8267;

This item has no description.

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER = $90EC;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER = $90ED;

This item has no description.

GL_DISPATCH_INDIRECT_BUFFER = $90EE;

This item has no description.

GL_DISPATCH_INDIRECT_BUFFER_BINDING = $90EF;

This item has no description.

GL_COMPUTE_SHADER_BIT = $00000020;

This item has no description.

GL_COMPRESSED_RGB8_ETC2 = $9274;

This item has no description.

GL_COMPRESSED_SRGB8_ETC2 = $9275;

This item has no description.

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9276;

This item has no description.

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2 = $9277;

This item has no description.

GL_COMPRESSED_RGBA8_ETC2_EAC = $9278;

This item has no description.

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC = $9279;

This item has no description.

GL_COMPRESSED_R11_EAC = $9270;

This item has no description.

GL_COMPRESSED_SIGNED_R11_EAC = $9271;

This item has no description.

GL_COMPRESSED_RG11_EAC = $9272;

This item has no description.

GL_COMPRESSED_SIGNED_RG11_EAC = $9273;

This item has no description.

GL_PRIMITIVE_RESTART_FIXED_INDEX = $8D69;

This item has no description.

GL_ANY_SAMPLES_PASSED_CONSERVATIVE = $8D6A;

This item has no description.

GL_MAX_ELEMENT_INDEX = $8D6B;

This item has no description.

GL_MAX_UNIFORM_LOCATIONS = $826E;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_WIDTH = $9310;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_HEIGHT = $9311;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_LAYERS = $9312;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_SAMPLES = $9313;

This item has no description.

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS = $9314;

This item has no description.

GL_MAX_FRAMEBUFFER_WIDTH = $9315;

This item has no description.

GL_MAX_FRAMEBUFFER_HEIGHT = $9316;

This item has no description.

GL_MAX_FRAMEBUFFER_LAYERS = $9317;

This item has no description.

GL_MAX_FRAMEBUFFER_SAMPLES = $9318;

This item has no description.

GL_INTERNALFORMAT_SUPPORTED = $826F;

This item has no description.

GL_INTERNALFORMAT_PREFERRED = $8270;

This item has no description.

GL_INTERNALFORMAT_RED_SIZE = $8271;

This item has no description.

GL_INTERNALFORMAT_GREEN_SIZE = $8272;

This item has no description.

GL_INTERNALFORMAT_BLUE_SIZE = $8273;

This item has no description.

GL_INTERNALFORMAT_ALPHA_SIZE = $8274;

This item has no description.

GL_INTERNALFORMAT_DEPTH_SIZE = $8275;

This item has no description.

GL_INTERNALFORMAT_STENCIL_SIZE = $8276;

This item has no description.

GL_INTERNALFORMAT_SHARED_SIZE = $8277;

This item has no description.

GL_INTERNALFORMAT_RED_TYPE = $8278;

This item has no description.

GL_INTERNALFORMAT_GREEN_TYPE = $8279;

This item has no description.

GL_INTERNALFORMAT_BLUE_TYPE = $827A;

This item has no description.

GL_INTERNALFORMAT_ALPHA_TYPE = $827B;

This item has no description.

GL_INTERNALFORMAT_DEPTH_TYPE = $827C;

This item has no description.

GL_INTERNALFORMAT_STENCIL_TYPE = $827D;

This item has no description.

GL_MAX_WIDTH = $827E;

This item has no description.

GL_MAX_HEIGHT = $827F;

This item has no description.

GL_MAX_DEPTH = $8280;

This item has no description.

GL_MAX_LAYERS = $8281;

This item has no description.

GL_MAX_COMBINED_DIMENSIONS = $8282;

This item has no description.

GL_COLOR_COMPONENTS = $8283;

This item has no description.

GL_DEPTH_COMPONENTS = $8284;

This item has no description.

GL_STENCIL_COMPONENTS = $8285;

This item has no description.

GL_COLOR_RENDERABLE = $8286;

This item has no description.

GL_DEPTH_RENDERABLE = $8287;

This item has no description.

GL_STENCIL_RENDERABLE = $8288;

This item has no description.

GL_FRAMEBUFFER_RENDERABLE = $8289;

This item has no description.

GL_FRAMEBUFFER_RENDERABLE_LAYERED = $828A;

This item has no description.

GL_FRAMEBUFFER_BLEND = $828B;

This item has no description.

GL_READ_PIXELS = $828C;

This item has no description.

GL_READ_PIXELS_FORMAT = $828D;

This item has no description.

GL_READ_PIXELS_TYPE = $828E;

This item has no description.

GL_TEXTURE_IMAGE_FORMAT = $828F;

This item has no description.

GL_TEXTURE_IMAGE_TYPE = $8290;

This item has no description.

GL_GET_TEXTURE_IMAGE_FORMAT = $8291;

This item has no description.

GL_GET_TEXTURE_IMAGE_TYPE = $8292;

This item has no description.

GL_MIPMAP = $8293;

This item has no description.

GL_MANUAL_GENERATE_MIPMAP = $8294;

This item has no description.

GL_AUTO_GENERATE_MIPMAP = $8295;

This item has no description.

GL_COLOR_ENCODING = $8296;

This item has no description.

GL_SRGB_READ = $8297;

This item has no description.

GL_SRGB_WRITE = $8298;

This item has no description.

GL_SRGB_DECODE_ARB = $8299;

This item has no description.

GL_FILTER = $829A;

This item has no description.

GL_VERTEX_TEXTURE = $829B;

This item has no description.

GL_TESS_CONTROL_TEXTURE = $829C;

This item has no description.

GL_TESS_EVALUATION_TEXTURE = $829D;

This item has no description.

GL_GEOMETRY_TEXTURE = $829E;

This item has no description.

GL_FRAGMENT_TEXTURE = $829F;

This item has no description.

GL_COMPUTE_TEXTURE = $82A0;

This item has no description.

GL_TEXTURE_SHADOW = $82A1;

This item has no description.

GL_TEXTURE_GATHER = $82A2;

This item has no description.

GL_TEXTURE_GATHER_SHADOW = $82A3;

This item has no description.

GL_SHADER_IMAGE_LOAD = $82A4;

This item has no description.

GL_SHADER_IMAGE_STORE = $82A5;

This item has no description.

GL_SHADER_IMAGE_ATOMIC = $82A6;

This item has no description.

GL_IMAGE_TEXEL_SIZE = $82A7;

This item has no description.

GL_IMAGE_COMPATIBILITY_CLASS = $82A8;

This item has no description.

GL_IMAGE_PIXEL_FORMAT = $82A9;

This item has no description.

GL_IMAGE_PIXEL_TYPE = $82AA;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST = $82AC;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST = $82AD;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE = $82AE;

This item has no description.

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE = $82AF;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH = $82B1;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT = $82B2;

This item has no description.

GL_TEXTURE_COMPRESSED_BLOCK_SIZE = $82B3;

This item has no description.

GL_CLEAR_BUFFER = $82B4;

This item has no description.

GL_TEXTURE_VIEW = $82B5;

This item has no description.

GL_VIEW_COMPATIBILITY_CLASS = $82B6;

This item has no description.

GL_FULL_SUPPORT = $82B7;

This item has no description.

GL_CAVEAT_SUPPORT = $82B8;

This item has no description.

GL_IMAGE_CLASS_4_X_32 = $82B9;

This item has no description.

GL_IMAGE_CLASS_2_X_32 = $82BA;

This item has no description.

GL_IMAGE_CLASS_1_X_32 = $82BB;

This item has no description.

GL_IMAGE_CLASS_4_X_16 = $82BC;

This item has no description.

GL_IMAGE_CLASS_2_X_16 = $82BD;

This item has no description.

GL_IMAGE_CLASS_1_X_16 = $82BE;

This item has no description.

GL_IMAGE_CLASS_4_X_8 = $82BF;

This item has no description.

GL_IMAGE_CLASS_2_X_8 = $82C0;

This item has no description.

GL_IMAGE_CLASS_1_X_8 = $82C1;

This item has no description.

GL_IMAGE_CLASS_11_11_10 = $82C2;

This item has no description.

GL_IMAGE_CLASS_10_10_10_2 = $82C3;

This item has no description.

GL_VIEW_CLASS_128_BITS = $82C4;

This item has no description.

GL_VIEW_CLASS_96_BITS = $82C5;

This item has no description.

GL_VIEW_CLASS_64_BITS = $82C6;

This item has no description.

GL_VIEW_CLASS_48_BITS = $82C7;

This item has no description.

GL_VIEW_CLASS_32_BITS = $82C8;

This item has no description.

GL_VIEW_CLASS_24_BITS = $82C9;

This item has no description.

GL_VIEW_CLASS_16_BITS = $82CA;

This item has no description.

GL_VIEW_CLASS_8_BITS = $82CB;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT1_RGB = $82CC;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT1_RGBA = $82CD;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT3_RGBA = $82CE;

This item has no description.

GL_VIEW_CLASS_S3TC_DXT5_RGBA = $82CF;

This item has no description.

GL_VIEW_CLASS_RGTC1_RED = $82D0;

This item has no description.

GL_VIEW_CLASS_RGTC2_RG = $82D1;

This item has no description.

GL_VIEW_CLASS_BPTC_UNORM = $82D2;

This item has no description.

GL_VIEW_CLASS_BPTC_FLOAT = $82D3;

This item has no description.

GL_UNIFORM = $92E1;

This item has no description.

GL_UNIFORM_BLOCK = $92E2;

This item has no description.

GL_PROGRAM_INPUT = $92E3;

This item has no description.

GL_PROGRAM_OUTPUT = $92E4;

This item has no description.

GL_BUFFER_VARIABLE = $92E5;

This item has no description.

GL_SHADER_STORAGE_BLOCK = $92E6;

This item has no description.

GL_VERTEX_SUBROUTINE = $92E8;

This item has no description.

GL_TESS_CONTROL_SUBROUTINE = $92E9;

This item has no description.

GL_TESS_EVALUATION_SUBROUTINE = $92EA;

This item has no description.

GL_GEOMETRY_SUBROUTINE = $92EB;

This item has no description.

GL_FRAGMENT_SUBROUTINE = $92EC;

This item has no description.

GL_COMPUTE_SUBROUTINE = $92ED;

This item has no description.

GL_VERTEX_SUBROUTINE_UNIFORM = $92EE;

This item has no description.

GL_TESS_CONTROL_SUBROUTINE_UNIFORM = $92EF;

This item has no description.

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM = $92F0;

This item has no description.

GL_GEOMETRY_SUBROUTINE_UNIFORM = $92F1;

This item has no description.

GL_FRAGMENT_SUBROUTINE_UNIFORM = $92F2;

This item has no description.

GL_COMPUTE_SUBROUTINE_UNIFORM = $92F3;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING = $92F4;

This item has no description.

GL_ACTIVE_RESOURCES = $92F5;

This item has no description.

GL_MAX_NAME_LENGTH = $92F6;

This item has no description.

GL_MAX_NUM_ACTIVE_VARIABLES = $92F7;

This item has no description.

GL_MAX_NUM_COMPATIBLE_SUBROUTINES = $92F8;

This item has no description.

GL_NAME_LENGTH = $92F9;

This item has no description.

GL_TYPE = $92FA;

This item has no description.

GL_ARRAY_SIZE = $92FB;

This item has no description.

GL_OFFSET = $92FC;

This item has no description.

GL_BLOCK_INDEX = $92FD;

This item has no description.

GL_ARRAY_STRIDE = $92FE;

This item has no description.

GL_MATRIX_STRIDE = $92FF;

This item has no description.

GL_IS_ROW_MAJOR = $9300;

This item has no description.

GL_ATOMIC_COUNTER_BUFFER_INDEX = $9301;

This item has no description.

GL_BUFFER_BINDING = $9302;

This item has no description.

GL_BUFFER_DATA_SIZE = $9303;

This item has no description.

GL_NUM_ACTIVE_VARIABLES = $9304;

This item has no description.

GL_ACTIVE_VARIABLES = $9305;

This item has no description.

GL_REFERENCED_BY_VERTEX_SHADER = $9306;

This item has no description.

GL_REFERENCED_BY_TESS_CONTROL_SHADER = $9307;

This item has no description.

GL_REFERENCED_BY_TESS_EVALUATION_SHADER = $9308;

This item has no description.

GL_REFERENCED_BY_GEOMETRY_SHADER = $9309;

This item has no description.

GL_REFERENCED_BY_FRAGMENT_SHADER = $930A;

This item has no description.

GL_REFERENCED_BY_COMPUTE_SHADER = $930B;

This item has no description.

GL_TOP_LEVEL_ARRAY_SIZE = $930C;

This item has no description.

GL_TOP_LEVEL_ARRAY_STRIDE = $930D;

This item has no description.

GL_LOCATION = $930E;

This item has no description.

GL_LOCATION_INDEX = $930F;

This item has no description.

GL_IS_PER_PATCH = $92E7;

This item has no description.

GL_SHADER_STORAGE_BUFFER = $90D2;

This item has no description.

GL_SHADER_STORAGE_BUFFER_BINDING = $90D3;

This item has no description.

GL_SHADER_STORAGE_BUFFER_START = $90D4;

This item has no description.

GL_SHADER_STORAGE_BUFFER_SIZE = $90D5;

This item has no description.

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS = $90D6;

This item has no description.

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS = $90D7;

This item has no description.

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS = $90D8;

This item has no description.

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS = $90D9;

This item has no description.

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS = $90DA;

This item has no description.

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS = $90DB;

This item has no description.

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS = $90DC;

This item has no description.

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS = $90DD;

This item has no description.

GL_MAX_SHADER_STORAGE_BLOCK_SIZE = $90DE;

This item has no description.

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT = $90DF;

This item has no description.

GL_SHADER_STORAGE_BARRIER_BIT = $2000;

This item has no description.

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES = GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS;

This item has no description.

GL_DEPTH_STENCIL_TEXTURE_MODE = $90EA;

This item has no description.

GL_TEXTURE_BUFFER_OFFSET = $919D;

This item has no description.

GL_TEXTURE_BUFFER_SIZE = $919E;

This item has no description.

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT = $919F;

This item has no description.

GL_TEXTURE_VIEW_MIN_LEVEL = $82DB;

This item has no description.

GL_TEXTURE_VIEW_NUM_LEVELS = $82DC;

This item has no description.

GL_TEXTURE_VIEW_MIN_LAYER = $82DD;

This item has no description.

GL_TEXTURE_VIEW_NUM_LAYERS = $82DE;

This item has no description.

GL_TEXTURE_IMMUTABLE_LEVELS = $82DF;

This item has no description.

GL_VERTEX_ATTRIB_BINDING = $82D4;

This item has no description.

GL_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D5;

This item has no description.

GL_VERTEX_BINDING_DIVISOR = $82D6;

This item has no description.

GL_VERTEX_BINDING_OFFSET = $82D7;

This item has no description.

GL_VERTEX_BINDING_STRIDE = $82D8;

This item has no description.

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET = $82D9;

This item has no description.

GL_MAX_VERTEX_ATTRIB_BINDINGS = $82DA;

This item has no description.

GL_MAX_VERTEX_ATTRIB_STRIDE = $82E5;

GL 4.4

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED = $8221;

This item has no description.

GL_TEXTURE_BUFFER_BINDING = $8C2A;

This item has no description.

GL_MAP_PERSISTENT_BIT = $0040;

This item has no description.

GL_MAP_COHERENT_BIT = $0080;

This item has no description.

GL_DYNAMIC_STORAGE_BIT = $0100;

This item has no description.

GL_CLIENT_STORAGE_BIT = $0200;

This item has no description.

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT = $00004000;

This item has no description.

GL_BUFFER_IMMUTABLE_STORAGE = $821F;

This item has no description.

GL_BUFFER_STORAGE_FLAGS = $8220;

This item has no description.

GL_CLEAR_TEXTURE = $9365;

This item has no description.

GL_LOCATION_COMPONENT = $934A;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX = $934B;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE = $934C;

This item has no description.

GL_QUERY_BUFFER = $9192;

This item has no description.

GL_QUERY_BUFFER_BARRIER_BIT = $00008000;

This item has no description.

GL_QUERY_BUFFER_BINDING = $9193;

This item has no description.

GL_QUERY_RESULT_NO_WAIT = $9194;

This item has no description.

GL_MIRROR_CLAMP_TO_EDGE = $8743;

This item has no description.

GL_CONTEXT_LOST = $0507;

GL 4.5

GL_NEGATIVE_ONE_TO_ONE = $935E;

This item has no description.

GL_ZERO_TO_ONE = $935F;

This item has no description.

GL_CLIP_ORIGIN = $935C;

This item has no description.

GL_CLIP_DEPTH_MODE = $935D;

This item has no description.

GL_QUERY_WAIT_INVERTED = $8E17;

This item has no description.

GL_QUERY_NO_WAIT_INVERTED = $8E18;

This item has no description.

GL_QUERY_BY_REGION_WAIT_INVERTED = $8E19;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT_INVERTED = $8E1A;

This item has no description.

GL_MAX_CULL_DISTANCES = $82F9;

This item has no description.

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES = $82FA;

This item has no description.

GL_TEXTURE_TARGET = $1006;

This item has no description.

GL_QUERY_TARGET = $82EA;

This item has no description.

GL_TEXTURE_BINDING = $82EB;

This item has no description.

GL_GUILTY_CONTEXT_RESET = $8253;

This item has no description.

GL_INNOCENT_CONTEXT_RESET = $8254;

This item has no description.

GL_UNKNOWN_CONTEXT_RESET = $8255;

This item has no description.

GL_RESET_NOTIFICATION_STRATEGY = $8256;

This item has no description.

GL_LOSE_CONTEXT_ON_RESET = $8252;

This item has no description.

GL_NO_RESET_NOTIFICATION = $8261;

This item has no description.

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT = $00000004;

This item has no description.

GL_CONTEXT_RELEASE_BEHAVIOR = $82FB;

This item has no description.

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH = $82FC;

This item has no description.

GL_SHADER_BINARY_FORMAT_SPIR_V = $9551;

4.6

GL_SPIR_V_BINARY = $9552;

This item has no description.

GL_PARAMETER_BUFFER = $80EE;

This item has no description.

GL_PARAMETER_BUFFER_BINDING = $80EF;

This item has no description.

GL_CONTEXT_FLAG_NO_ERROR_BIT = $00000008;

This item has no description.

GL_VERTICES_SUBMITTED = $82EE;

This item has no description.

GL_PRIMITIVES_SUBMITTED = $82EF;

This item has no description.

GL_VERTEX_SHADER_INVOCATIONS = $82F0;

This item has no description.

GL_TESS_CONTROL_SHADER_PATCHES = $82F1;

This item has no description.

GL_TESS_EVALUATION_SHADER_INVOCATIONS = $82F2;

This item has no description.

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED = $82F3;

This item has no description.

GL_FRAGMENT_SHADER_INVOCATIONS = $82F4;

This item has no description.

GL_COMPUTE_SHADER_INVOCATIONS = $82F5;

This item has no description.

GL_CLIPPING_INPUT_PRIMITIVES = $82F6;

This item has no description.

GL_CLIPPING_OUTPUT_PRIMITIVES = $82F7;

This item has no description.

GL_POLYGON_OFFSET_CLAMP = $8E1B;

This item has no description.

GL_SPIR_V_EXTENSIONS = $9553;

This item has no description.

GL_NUM_SPIR_V_EXTENSIONS = $9554;

This item has no description.

GL_TEXTURE_MAX_ANISOTROPY = $84FE;

This item has no description.

GL_MAX_TEXTURE_MAX_ANISOTROPY = $84FF;

This item has no description.

GL_TRANSFORM_FEEDBACK_OVERFLOW = $82EC;

This item has no description.

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW = $82ED;

This item has no description.

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_ATI_draw_buffers

GL_DRAW_BUFFER0_ATI = $8825;

This item has no description.

GL_DRAW_BUFFER1_ATI = $8826;

This item has no description.

GL_DRAW_BUFFER2_ATI = $8827;

This item has no description.

GL_DRAW_BUFFER3_ATI = $8828;

This item has no description.

GL_DRAW_BUFFER4_ATI = $8829;

This item has no description.

GL_DRAW_BUFFER5_ATI = $882A;

This item has no description.

GL_DRAW_BUFFER6_ATI = $882B;

This item has no description.

GL_DRAW_BUFFER7_ATI = $882C;

This item has no description.

GL_DRAW_BUFFER8_ATI = $882D;

This item has no description.

GL_DRAW_BUFFER9_ATI = $882E;

This item has no description.

GL_DRAW_BUFFER10_ATI = $882F;

This item has no description.

GL_DRAW_BUFFER11_ATI = $8830;

This item has no description.

GL_DRAW_BUFFER12_ATI = $8831;

This item has no description.

GL_DRAW_BUFFER13_ATI = $8832;

This item has no description.

GL_DRAW_BUFFER14_ATI = $8833;

This item has no description.

GL_DRAW_BUFFER15_ATI = $8834;

This item has no description.

GL_ELEMENT_ARRAY_ATI = $8768;

GL_ATI_element_array

GL_ELEMENT_ARRAY_TYPE_ATI = $8769;

This item has no description.

GL_ELEMENT_ARRAY_POINTER_ATI = $876A;

This item has no description.

GL_BUMP_ROT_MATRIX_ATI = $8775;

GL_ATI_envmap_bumpmap

GL_BUMP_ROT_MATRIX_SIZE_ATI = $8776;

This item has no description.

GL_BUMP_NUM_TEX_UNITS_ATI = $8777;

This item has no description.

GL_BUMP_TEX_UNITS_ATI = $8778;

This item has no description.

GL_DUDV_ATI = $8779;

This item has no description.

GL_DU8DV8_ATI = $877A;

This item has no description.

GL_BUMP_ENVMAP_ATI = $877B;

This item has no description.

GL_BUMP_TARGET_ATI = $877C;

This item has no description.

GL_FRAGMENT_SHADER_ATI = $8920;

GL_ATI_fragment_shader

GL_REG_0_ATI = $8921;

This item has no description.

GL_REG_1_ATI = $8922;

This item has no description.

GL_REG_2_ATI = $8923;

This item has no description.

GL_REG_3_ATI = $8924;

This item has no description.

GL_REG_4_ATI = $8925;

This item has no description.

GL_REG_5_ATI = $8926;

This item has no description.

GL_REG_6_ATI = $8927;

This item has no description.

GL_REG_7_ATI = $8928;

This item has no description.

GL_REG_8_ATI = $8929;

This item has no description.

GL_REG_9_ATI = $892A;

This item has no description.

GL_REG_10_ATI = $892B;

This item has no description.

GL_REG_11_ATI = $892C;

This item has no description.

GL_REG_12_ATI = $892D;

This item has no description.

GL_REG_13_ATI = $892E;

This item has no description.

GL_REG_14_ATI = $892F;

This item has no description.

GL_REG_15_ATI = $8930;

This item has no description.

GL_REG_16_ATI = $8931;

This item has no description.

GL_REG_17_ATI = $8932;

This item has no description.

GL_REG_18_ATI = $8933;

This item has no description.

GL_REG_19_ATI = $8934;

This item has no description.

GL_REG_20_ATI = $8935;

This item has no description.

GL_REG_21_ATI = $8936;

This item has no description.

GL_REG_22_ATI = $8937;

This item has no description.

GL_REG_23_ATI = $8938;

This item has no description.

GL_REG_24_ATI = $8939;

This item has no description.

GL_REG_25_ATI = $893A;

This item has no description.

GL_REG_26_ATI = $893B;

This item has no description.

GL_REG_27_ATI = $893C;

This item has no description.

GL_REG_28_ATI = $893D;

This item has no description.

GL_REG_29_ATI = $893E;

This item has no description.

GL_REG_30_ATI = $893F;

This item has no description.

GL_REG_31_ATI = $8940;

This item has no description.

GL_CON_0_ATI = $8941;

This item has no description.

GL_CON_1_ATI = $8942;

This item has no description.

GL_CON_2_ATI = $8943;

This item has no description.

GL_CON_3_ATI = $8944;

This item has no description.

GL_CON_4_ATI = $8945;

This item has no description.

GL_CON_5_ATI = $8946;

This item has no description.

GL_CON_6_ATI = $8947;

This item has no description.

GL_CON_7_ATI = $8948;

This item has no description.

GL_CON_8_ATI = $8949;

This item has no description.

GL_CON_9_ATI = $894A;

This item has no description.

GL_CON_10_ATI = $894B;

This item has no description.

GL_CON_11_ATI = $894C;

This item has no description.

GL_CON_12_ATI = $894D;

This item has no description.

GL_CON_13_ATI = $894E;

This item has no description.

GL_CON_14_ATI = $894F;

This item has no description.

GL_CON_15_ATI = $8950;

This item has no description.

GL_CON_16_ATI = $8951;

This item has no description.

GL_CON_17_ATI = $8952;

This item has no description.

GL_CON_18_ATI = $8953;

This item has no description.

GL_CON_19_ATI = $8954;

This item has no description.

GL_CON_20_ATI = $8955;

This item has no description.

GL_CON_21_ATI = $8956;

This item has no description.

GL_CON_22_ATI = $8957;

This item has no description.

GL_CON_23_ATI = $8958;

This item has no description.

GL_CON_24_ATI = $8959;

This item has no description.

GL_CON_25_ATI = $895A;

This item has no description.

GL_CON_26_ATI = $895B;

This item has no description.

GL_CON_27_ATI = $895C;

This item has no description.

GL_CON_28_ATI = $895D;

This item has no description.

GL_CON_29_ATI = $895E;

This item has no description.

GL_CON_30_ATI = $895F;

This item has no description.

GL_CON_31_ATI = $8960;

This item has no description.

GL_MOV_ATI = $8961;

This item has no description.

GL_ADD_ATI = $8963;

This item has no description.

GL_MUL_ATI = $8964;

This item has no description.

GL_SUB_ATI = $8965;

This item has no description.

GL_DOT3_ATI = $8966;

This item has no description.

GL_DOT4_ATI = $8967;

This item has no description.

GL_MAD_ATI = $8968;

This item has no description.

GL_LERP_ATI = $8969;

This item has no description.

GL_CND_ATI = $896A;

This item has no description.

GL_CND0_ATI = $896B;

This item has no description.

GL_DOT2_ADD_ATI = $896C;

This item has no description.

GL_SECONDARY_INTERPOLATOR_ATI = $896D;

This item has no description.

GL_NUM_FRAGMENT_REGISTERS_ATI = $896E;

This item has no description.

GL_NUM_FRAGMENT_CONSTANTS_ATI = $896F;

This item has no description.

GL_NUM_PASSES_ATI = $8970;

This item has no description.

GL_NUM_INSTRUCTIONS_PER_PASS_ATI = $8971;

This item has no description.

GL_NUM_INSTRUCTIONS_TOTAL_ATI = $8972;

This item has no description.

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI = $8973;

This item has no description.

GL_NUM_LOOPBACK_COMPONENTS_ATI = $8974;

This item has no description.

GL_COLOR_ALPHA_PAIRING_ATI = $8975;

This item has no description.

GL_SWIZZLE_STR_ATI = $8976;

This item has no description.

GL_SWIZZLE_STQ_ATI = $8977;

This item has no description.

GL_SWIZZLE_STR_DR_ATI = $8978;

This item has no description.

GL_SWIZZLE_STQ_DQ_ATI = $8979;

This item has no description.

GL_SWIZZLE_STRQ_ATI = $897A;

This item has no description.

GL_SWIZZLE_STRQ_DQ_ATI = $897B;

This item has no description.

GL_RED_BIT_ATI = $00000001;

This item has no description.

GL_GREEN_BIT_ATI = $00000002;

This item has no description.

GL_BLUE_BIT_ATI = $00000004;

This item has no description.

GL_2X_BIT_ATI = $00000001;

This item has no description.

GL_4X_BIT_ATI = $00000002;

This item has no description.

GL_8X_BIT_ATI = $00000004;

This item has no description.

GL_HALF_BIT_ATI = $00000008;

This item has no description.

GL_QUARTER_BIT_ATI = $00000010;

This item has no description.

GL_EIGHTH_BIT_ATI = $00000020;

This item has no description.

GL_SATURATE_BIT_ATI = $00000040;

This item has no description.

GL_COMP_BIT_ATI = $00000002;

This item has no description.

GL_NEGATE_BIT_ATI = $00000004;

This item has no description.

GL_BIAS_BIT_ATI = $00000008;

This item has no description.

GL_PN_TRIANGLES_ATI = $87F0;

GL_ATI_pn_triangles

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F1;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_ATI = $87F2;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_ATI = $87F3;

This item has no description.

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI = $87F4;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI = $87F5;

This item has no description.

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI = $87F6;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI = $87F7;

This item has no description.

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI = $87F8;

This item has no description.

GL_STENCIL_BACK_FUNC_ATI = $8800;

GL_ATI_separate_stencil

GL_STENCIL_BACK_FAIL_ATI = $8801;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI = $8802;

This item has no description.

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI = $8803;

This item has no description.

GL_TEXT_FRAGMENT_SHADER_ATI = $8200;

GL_ATI_text_fragment_shader

GL_MODULATE_ADD_ATI = $8744;

GL_ATI_texture_env_combine3

GL_MODULATE_SIGNED_ADD_ATI = $8745;

This item has no description.

GL_MODULATE_SUBTRACT_ATI = $8746;

This item has no description.

GL_RGBA_FLOAT32_ATI = $8814;

GL_ATI_texture_float

GL_RGB_FLOAT32_ATI = $8815;

This item has no description.

GL_ALPHA_FLOAT32_ATI = $8816;

This item has no description.

GL_INTENSITY_FLOAT32_ATI = $8817;

This item has no description.

GL_LUMINANCE_FLOAT32_ATI = $8818;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

This item has no description.

GL_RGBA_FLOAT16_ATI = $881A;

This item has no description.

GL_RGB_FLOAT16_ATI = $881B;

This item has no description.

GL_ALPHA_FLOAT16_ATI = $881C;

This item has no description.

GL_INTENSITY_FLOAT16_ATI = $881D;

This item has no description.

GL_LUMINANCE_FLOAT16_ATI = $881E;

This item has no description.

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

This item has no description.

GL_MIRROR_CLAMP_ATI = $8742;

GL_ATI_texture_mirror_once

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

This item has no description.

GL_STATIC_ATI = $8760;

GL_ATI_vertex_array_object

GL_DYNAMIC_ATI = $8761;

This item has no description.

GL_PRESERVE_ATI = $8762;

This item has no description.

GL_DISCARD_ATI = $8763;

This item has no description.

GL_OBJECT_BUFFER_SIZE_ATI = $8764;

This item has no description.

GL_OBJECT_BUFFER_USAGE_ATI = $8765;

This item has no description.

GL_ARRAY_OBJECT_BUFFER_ATI = $8766;

This item has no description.

GL_ARRAY_OBJECT_OFFSET_ATI = $8767;

This item has no description.

GL_MAX_VERTEX_STREAMS_ATI = $876B;

GL_ATI_vertex_streams

GL_VERTEX_STREAM0_ATI = $876C;

This item has no description.

GL_VERTEX_STREAM1_ATI = $876D;

This item has no description.

GL_VERTEX_STREAM2_ATI = $876E;

This item has no description.

GL_VERTEX_STREAM3_ATI = $876F;

This item has no description.

GL_VERTEX_STREAM4_ATI = $8770;

This item has no description.

GL_VERTEX_STREAM5_ATI = $8771;

This item has no description.

GL_VERTEX_STREAM6_ATI = $8772;

This item has no description.

GL_VERTEX_STREAM7_ATI = $8773;

This item has no description.

GL_VERTEX_SOURCE_ATI = $8774;

This item has no description.

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_ATI_meminfo

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

This item has no description.

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

This item has no description.

GL_COUNTER_TYPE_AMD = $8BC0;

GL_AMD_performance_monitor

GL_COUNTER_RANGE_AMD = $8BC1;

This item has no description.

GL_UNSIGNED_INT64_AMD = $8BC2;

This item has no description.

GL_PERCENTAGE_AMD = $8BC3;

This item has no description.

GL_PERFMON_RESULT_AVAILABLE_AMD = $8BC4;

This item has no description.

GL_PERFMON_RESULT_SIZE_AMD = $8BC5;

This item has no description.

GL_PERFMON_RESULT_AMD = $8BC6;

This item has no description.

GL_SAMPLER_BUFFER_AMD = $9001;

GL_AMD_vertex_shader_tesselator

GL_INT_SAMPLER_BUFFER_AMD = $9002;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

This item has no description.

GL_TESSELLATION_MODE_AMD = $9004;

This item has no description.

GL_TESSELLATION_FACTOR_AMD = $9005;

This item has no description.

GL_DISCRETE_AMD = $9006;

This item has no description.

GL_CONTINUOUS_AMD = $9007;

This item has no description.

GL_DATA_BUFFER_AMD = $9151;

GL_AMD_name_gen_delete

GL_PERFORMANCE_MONITOR_AMD = $9152;

This item has no description.

GL_QUERY_OBJECT_AMD = $9153;

This item has no description.

GL_VERTEX_ARRAY_OBJECT_AMD = $9154;

This item has no description.

GL_SAMPLER_OBJECT_AMD = $9155;

This item has no description.

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD = $9144;

GL_AMD_debug_output

GL_DEBUG_LOGGED_MESSAGES_AMD = $9145;

This item has no description.

GL_DEBUG_SEVERITY_HIGH_AMD = $9146;

This item has no description.

GL_DEBUG_SEVERITY_MEDIUM_AMD = $9147;

This item has no description.

GL_DEBUG_SEVERITY_LOW_AMD = $9148;

This item has no description.

GL_DEBUG_CATEGORY_API_ERROR_AMD = $9149;

This item has no description.

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD = $914A;

This item has no description.

GL_DEBUG_CATEGORY_DEPRECATION_AMD = $914B;

This item has no description.

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD = $914C;

This item has no description.

GL_DEBUG_CATEGORY_PERFORMANCE_AMD = $914D;

This item has no description.

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD = $914E;

This item has no description.

GL_DEBUG_CATEGORY_APPLICATION_AMD = $914F;

This item has no description.

GL_DEBUG_CATEGORY_OTHER_AMD = $9150;

This item has no description.

GL_DEPTH_CLAMP_NEAR_AMD = $901E;

GL_AMD_depth_clamp_separate

GL_DEPTH_CLAMP_FAR_AMD = $901F;

This item has no description.

GL_422_EXT = $80CC;

GL_EXT_422_pixels

GL_422_REV_EXT = $80CD;

This item has no description.

GL_422_AVERAGE_EXT = $80CE;

This item has no description.

GL_422_REV_AVERAGE_EXT = $80CF;

This item has no description.

GL_ABGR_EXT = $8000;

GL_EXT_abgr

GL_BGR_EXT = $80E0;

GL_EXT_bgra

GL_BGRA_EXT = $80E1;

This item has no description.

GL_CONSTANT_COLOR_EXT = $8001;

GL_EXT_blend_color

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

This item has no description.

GL_CONSTANT_ALPHA_EXT = $8003;

This item has no description.

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

This item has no description.

GL_BLEND_COLOR_EXT = $8005;

This item has no description.

GL_BLEND_DST_RGB_EXT = $80C8;

GL_EXT_blend_func_separate

GL_BLEND_SRC_RGB_EXT = $80C9;

This item has no description.

GL_BLEND_DST_ALPHA_EXT = $80CA;

This item has no description.

GL_BLEND_SRC_ALPHA_EXT = $80CB;

This item has no description.

GL_FUNC_ADD_EXT = $8006;

GL_EXT_blend_minmax

GL_MIN_EXT = $8007;

This item has no description.

GL_MAX_EXT = $8008;

This item has no description.

GL_BLEND_EQUATION_EXT = $8009;

This item has no description.

GL_FUNC_SUBTRACT_EXT = $800A;

GL_EXT_blend_subtract

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

This item has no description.

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_EXT_clip_volume_hint

GL_CMYK_EXT = $800C;

GL_EXT_cmyka

GL_CMYKA_EXT = $800D;

This item has no description.

GL_PACK_CMYK_HINT_EXT = $800E;

This item has no description.

GL_UNPACK_CMYK_HINT_EXT = $800F;

This item has no description.

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_EXT_compiled_vertex_array

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

This item has no description.

GL_CONVOLUTION_1D_EXT = $8010;

GL_EXT_convolution

GL_CONVOLUTION_2D_EXT = $8011;

This item has no description.

GL_SEPARABLE_2D_EXT = $8012;

This item has no description.

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

This item has no description.

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

This item has no description.

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

This item has no description.

GL_REDUCE_EXT = $8016;

This item has no description.

GL_CONVOLUTION_FORMAT_EXT = $8017;

This item has no description.

GL_CONVOLUTION_WIDTH_EXT = $8018;

This item has no description.

GL_CONVOLUTION_HEIGHT_EXT = $8019;

This item has no description.

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

This item has no description.

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

This item has no description.

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

This item has no description.

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

This item has no description.

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

This item has no description.

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

This item has no description.

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

This item has no description.

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

This item has no description.

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

This item has no description.

GL_TANGENT_ARRAY_EXT = $8439;

GL_EXT_coordinate_frame

GL_BINORMAL_ARRAY_EXT = $843A;

This item has no description.

GL_CURRENT_TANGENT_EXT = $843B;

This item has no description.

GL_CURRENT_BINORMAL_EXT = $843C;

This item has no description.

GL_TANGENT_ARRAY_TYPE_EXT = $843E;

This item has no description.

GL_TANGENT_ARRAY_STRIDE_EXT = $843F;

This item has no description.

GL_BINORMAL_ARRAY_TYPE_EXT = $8440;

This item has no description.

GL_BINORMAL_ARRAY_STRIDE_EXT = $8441;

This item has no description.

GL_TANGENT_ARRAY_POINTER_EXT = $8442;

This item has no description.

GL_BINORMAL_ARRAY_POINTER_EXT = $8443;

This item has no description.

GL_MAP1_TANGENT_EXT = $8444;

This item has no description.

GL_MAP2_TANGENT_EXT = $8445;

This item has no description.

GL_MAP1_BINORMAL_EXT = $8446;

This item has no description.

GL_MAP2_BINORMAL_EXT = $8447;

This item has no description.

GL_CULL_VERTEX_EXT = $81AA;

GL_EXT_cull_vertex

GL_CULL_VERTEX_EYE_POSITION_EXT = $81AB;

This item has no description.

GL_CULL_VERTEX_OBJECT_POSITION_EXT = $81AC;

This item has no description.

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_EXT_draw_range_elements

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

This item has no description.

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_EXT_fog_coord

GL_FOG_COORDINATE_EXT = $8451;

This item has no description.

GL_FRAGMENT_DEPTH_EXT = $8452;

This item has no description.

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

This item has no description.

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

This item has no description.

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

This item has no description.

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

This item has no description.

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

This item has no description.

GL_FRAMEBUFFER_EXT = $8D40;

GL_EXT_framebuffer_object

GL_RENDERBUFFER_EXT = $8D41;

This item has no description.

GL_STENCIL_INDEX_EXT = $8D45;

This item has no description.

GL_STENCIL_INDEX1_EXT = $8D46;

This item has no description.

GL_STENCIL_INDEX4_EXT = $8D47;

This item has no description.

GL_STENCIL_INDEX8_EXT = $8D48;

This item has no description.

GL_STENCIL_INDEX16_EXT = $8D49;

This item has no description.

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

This item has no description.

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

This item has no description.

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

This item has no description.

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

This item has no description.

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

This item has no description.

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

This item has no description.

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

This item has no description.

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

This item has no description.

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

This item has no description.

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

This item has no description.

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

This item has no description.

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

This item has no description.

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

This item has no description.

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

This item has no description.

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

This item has no description.

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

This item has no description.

GL_COLOR_ATTACHMENT13_EXT = $8CED;

This item has no description.

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

This item has no description.

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

This item has no description.

GL_DEPTH_ATTACHMENT_EXT = $8D00;

This item has no description.

GL_STENCIL_ATTACHMENT_EXT = $8D20;

This item has no description.

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

This item has no description.

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

This item has no description.

GL_FRAMEBUFFER_STATUS_ERROR_EXT = $8CDE;

This item has no description.

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

This item has no description.

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

This item has no description.

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

This item has no description.

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

This item has no description.

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

This item has no description.

GL_HISTOGRAM_EXT = $8024;

GL_EXT_histogram

GL_PROXY_HISTOGRAM_EXT = $8025;

This item has no description.

GL_HISTOGRAM_WIDTH_EXT = $8026;

This item has no description.

GL_HISTOGRAM_FORMAT_EXT = $8027;

This item has no description.

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

This item has no description.

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

This item has no description.

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

This item has no description.

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

This item has no description.

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

This item has no description.

GL_HISTOGRAM_SINK_EXT = $802D;

This item has no description.

GL_MINMAX_EXT = $802E;

This item has no description.

GL_MINMAX_FORMAT_EXT = $802F;

This item has no description.

GL_MINMAX_SINK_EXT = $8030;

This item has no description.

GL_TABLE_TOO_LARGE_EXT = $8031;

This item has no description.

GL_IUI_V2F_EXT = $81AD;

GL_EXT_index_array_formats

GL_IUI_V3F_EXT = $81AE;

This item has no description.

GL_IUI_N3F_V2F_EXT = $81AF;

This item has no description.

GL_IUI_N3F_V3F_EXT = $81B0;

This item has no description.

GL_T2F_IUI_V2F_EXT = $81B1;

This item has no description.

GL_T2F_IUI_V3F_EXT = $81B2;

This item has no description.

GL_T2F_IUI_N3F_V2F_EXT = $81B3;

This item has no description.

GL_T2F_IUI_N3F_V3F_EXT = $81B4;

This item has no description.

GL_INDEX_TEST_EXT = $81B5;

GL_EXT_index_func

GL_INDEX_TEST_FUNC_EXT = $81B6;

This item has no description.

GL_INDEX_TEST_REF_EXT = $81B7;

This item has no description.

GL_INDEX_MATERIAL_EXT = $81B8;

GL_EXT_index_material

GL_INDEX_MATERIAL_PARAMETER_EXT = $81B9;

This item has no description.

GL_INDEX_MATERIAL_FACE_EXT = $81BA;

This item has no description.

GL_FRAGMENT_MATERIAL_EXT = $8349;

GL_EXT_light_texture

GL_FRAGMENT_NORMAL_EXT = $834A;

This item has no description.

GL_FRAGMENT_COLOR_EXT = $834C;

This item has no description.

GL_ATTENUATION_EXT = $834D;

This item has no description.

GL_SHADOW_ATTENUATION_EXT = $834E;

This item has no description.

GL_TEXTURE_APPLICATION_MODE_EXT = $834F;

This item has no description.

GL_TEXTURE_LIGHT_EXT = $8350;

This item has no description.

GL_TEXTURE_MATERIAL_FACE_EXT = $8351;

This item has no description.

GL_TEXTURE_MATERIAL_PARAMETER_EXT = $8352;

This item has no description.

GL_MULTISAMPLE_EXT = $809D;

GL_EXT_multisample

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

This item has no description.

GL_SAMPLE_MASK_EXT = $80A0;

This item has no description.

GL_1PASS_EXT = $80A1;

This item has no description.

GL_2PASS_0_EXT = $80A2;

This item has no description.

GL_2PASS_1_EXT = $80A3;

This item has no description.

GL_4PASS_0_EXT = $80A4;

This item has no description.

GL_4PASS_1_EXT = $80A5;

This item has no description.

GL_4PASS_2_EXT = $80A6;

This item has no description.

GL_4PASS_3_EXT = $80A7;

This item has no description.

GL_SAMPLE_BUFFERS_EXT = $80A8;

This item has no description.

GL_SAMPLES_EXT = $80A9;

This item has no description.

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

This item has no description.

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

This item has no description.

GL_SAMPLE_PATTERN_EXT = $80AC;

This item has no description.

GL_MULTISAMPLE_BIT_EXT = $20000000;

This item has no description.

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_EXT_packed_pixels

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

This item has no description.

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

This item has no description.

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

This item has no description.

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

This item has no description.

GL_COLOR_INDEX1_EXT = $80E2;

GL_EXT_paletted_texture

GL_COLOR_INDEX2_EXT = $80E3;

This item has no description.

GL_COLOR_INDEX4_EXT = $80E4;

This item has no description.

GL_COLOR_INDEX8_EXT = $80E5;

This item has no description.

GL_COLOR_INDEX12_EXT = $80E6;

This item has no description.

GL_COLOR_INDEX16_EXT = $80E7;

This item has no description.

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

This item has no description.

GL_PIXEL_TRANSFORM_2D_EXT = $8330;

GL_EXT_pixel_transform

GL_PIXEL_MAG_FILTER_EXT = $8331;

This item has no description.

GL_PIXEL_MIN_FILTER_EXT = $8332;

This item has no description.

GL_PIXEL_CUBIC_WEIGHT_EXT = $8333;

This item has no description.

GL_CUBIC_EXT = $8334;

This item has no description.

GL_AVERAGE_EXT = $8335;

This item has no description.

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8336;

This item has no description.

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT = $8337;

This item has no description.

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT = $8338;

This item has no description.

GL_POINT_SIZE_MIN_EXT = $8126;

GL_EXT_point_parameters

GL_POINT_SIZE_MAX_EXT = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_EXT = $8128;

This item has no description.

GL_DISTANCE_ATTENUATION_EXT = $8129;

This item has no description.

GL_POLYGON_OFFSET_EXT = $8037;

GL_EXT_polygon_offset

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

This item has no description.

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

This item has no description.

GL_RESCALE_NORMAL_EXT = $803A;

GL_EXT_rescale_normal

GL_COLOR_SUM_EXT = $8458;

GL_EXT_secondary_color

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

This item has no description.

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_EXT_separate_specular_color

GL_SINGLE_COLOR_EXT = $81F9;

This item has no description.

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

This item has no description.

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_EXT_shared_texture_palette

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_EXT_stencil_two_side

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

This item has no description.

GL_INCR_WRAP_EXT = $8507;

GL_EXT_stencil_wrap

GL_DECR_WRAP_EXT = $8508;

This item has no description.

GL_ALPHA4_EXT = $803B;

GL_EXT_texture

GL_ALPHA8_EXT = $803C;

This item has no description.

GL_ALPHA12_EXT = $803D;

This item has no description.

GL_ALPHA16_EXT = $803E;

This item has no description.

GL_LUMINANCE4_EXT = $803F;

This item has no description.

GL_LUMINANCE8_EXT = $8040;

This item has no description.

GL_LUMINANCE12_EXT = $8041;

This item has no description.

GL_LUMINANCE16_EXT = $8042;

This item has no description.

GL_LUMINANCE4_ALPHA4_EXT = $8043;

This item has no description.

GL_LUMINANCE6_ALPHA2_EXT = $8044;

This item has no description.

GL_LUMINANCE8_ALPHA8_EXT = $8045;

This item has no description.

GL_LUMINANCE12_ALPHA4_EXT = $8046;

This item has no description.

GL_LUMINANCE12_ALPHA12_EXT = $8047;

This item has no description.

GL_LUMINANCE16_ALPHA16_EXT = $8048;

This item has no description.

GL_INTENSITY_EXT = $8049;

This item has no description.

GL_INTENSITY4_EXT = $804A;

This item has no description.

GL_INTENSITY8_EXT = $804B;

This item has no description.

GL_INTENSITY12_EXT = $804C;

This item has no description.

GL_INTENSITY16_EXT = $804D;

This item has no description.

GL_RGB2_EXT = $804E;

This item has no description.

GL_RGB4_EXT = $804F;

This item has no description.

GL_RGB5_EXT = $8050;

This item has no description.

GL_RGB8_EXT = $8051;

This item has no description.

GL_RGB10_EXT = $8052;

This item has no description.

GL_RGB12_EXT = $8053;

This item has no description.

GL_RGB16_EXT = $8054;

This item has no description.

GL_RGBA2_EXT = $8055;

This item has no description.

GL_RGBA4_EXT = $8056;

This item has no description.

GL_RGB5_A1_EXT = $8057;

This item has no description.

GL_RGBA8_EXT = $8058;

This item has no description.

GL_RGB10_A2_EXT = $8059;

This item has no description.

GL_RGBA12_EXT = $805A;

This item has no description.

GL_RGBA16_EXT = $805B;

This item has no description.

GL_TEXTURE_RED_SIZE_EXT = $805C;

This item has no description.

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

This item has no description.

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

This item has no description.

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

This item has no description.

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

This item has no description.

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

This item has no description.

GL_REPLACE_EXT = $8062;

This item has no description.

GL_PROXY_TEXTURE_1D_EXT = $8063;

This item has no description.

GL_PROXY_TEXTURE_2D_EXT = $8064;

This item has no description.

GL_TEXTURE_TOO_LARGE_EXT = $8065;

This item has no description.

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_EXT_texture3D

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

This item has no description.

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

This item has no description.

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

This item has no description.

GL_TEXTURE_3D_EXT = $806F;

This item has no description.

GL_PROXY_TEXTURE_3D_EXT = $8070;

This item has no description.

GL_TEXTURE_DEPTH_EXT = $8071;

This item has no description.

GL_TEXTURE_WRAP_R_EXT = $8072;

This item has no description.

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

This item has no description.

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_EXT_texture_compression_s3tc

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

This item has no description.

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

This item has no description.

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

This item has no description.

GL_NORMAL_MAP_EXT = $8511;

GL_EXT_texture_cube_map

GL_REFLECTION_MAP_EXT = $8512;

This item has no description.

GL_TEXTURE_CUBE_MAP_EXT = $8513;

This item has no description.

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

This item has no description.

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

This item has no description.

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

This item has no description.

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

This item has no description.

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

This item has no description.

GL_CLAMP_TO_EDGE_EXT = $812F;

GL_EXT_texture_edge_clamp

GL_COMBINE_EXT = $8570;

GL_EXT_texture_env_combine

GL_COMBINE_RGB_EXT = $8571;

This item has no description.

GL_COMBINE_ALPHA_EXT = $8572;

This item has no description.

GL_RGB_SCALE_EXT = $8573;

This item has no description.

GL_ADD_SIGNED_EXT = $8574;

This item has no description.

GL_INTERPOLATE_EXT = $8575;

This item has no description.

GL_CONSTANT_EXT = $8576;

This item has no description.

GL_PRIMARY_COLOR_EXT = $8577;

This item has no description.

GL_PREVIOUS_EXT = $8578;

This item has no description.

GL_SOURCE0_RGB_EXT = $8580;

This item has no description.

GL_SOURCE1_RGB_EXT = $8581;

This item has no description.

GL_SOURCE2_RGB_EXT = $8582;

This item has no description.

GL_SOURCE0_ALPHA_EXT = $8588;

This item has no description.

GL_SOURCE1_ALPHA_EXT = $8589;

This item has no description.

GL_SOURCE2_ALPHA_EXT = $858A;

This item has no description.

GL_OPERAND0_RGB_EXT = $8590;

This item has no description.

GL_OPERAND1_RGB_EXT = $8591;

This item has no description.

GL_OPERAND2_RGB_EXT = $8592;

This item has no description.

GL_OPERAND0_ALPHA_EXT = $8598;

This item has no description.

GL_OPERAND1_ALPHA_EXT = $8599;

This item has no description.

GL_OPERAND2_ALPHA_EXT = $859A;

This item has no description.

GL_DOT3_RGB_EXT = $8740;

GL_EXT_texture_env_dot3

GL_DOT3_RGBA_EXT = $8741;

This item has no description.

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_EXT_texture_filter_anisotropic

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

This item has no description.

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_EXT_texture_lod_bias

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

This item has no description.

GL_TEXTURE_LOD_BIAS_EXT = $8501;

This item has no description.

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_EXT_texture_object

GL_TEXTURE_RESIDENT_EXT = $8067;

This item has no description.

GL_TEXTURE_1D_BINDING_EXT = $8068;

This item has no description.

GL_TEXTURE_2D_BINDING_EXT = $8069;

This item has no description.

GL_TEXTURE_3D_BINDING_EXT = $806A;

This item has no description.

GL_PERTURB_EXT = $85AE;

GL_EXT_texture_perturb_normal

GL_TEXTURE_NORMAL_EXT = $85AF;

This item has no description.

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_EXT_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

This item has no description.

GL_VERTEX_ARRAY_EXT = $8074;

GL_EXT_vertex_array

GL_NORMAL_ARRAY_EXT = $8075;

This item has no description.

GL_COLOR_ARRAY_EXT = $8076;

This item has no description.

GL_INDEX_ARRAY_EXT = $8077;

This item has no description.

GL_TEXTURE_COORD_ARRAY_EXT = $8078;

This item has no description.

GL_EDGE_FLAG_ARRAY_EXT = $8079;

This item has no description.

GL_VERTEX_ARRAY_SIZE_EXT = $807A;

This item has no description.

GL_VERTEX_ARRAY_TYPE_EXT = $807B;

This item has no description.

GL_VERTEX_ARRAY_STRIDE_EXT = $807C;

This item has no description.

GL_VERTEX_ARRAY_COUNT_EXT = $807D;

This item has no description.

GL_NORMAL_ARRAY_TYPE_EXT = $807E;

This item has no description.

GL_NORMAL_ARRAY_STRIDE_EXT = $807F;

This item has no description.

GL_NORMAL_ARRAY_COUNT_EXT = $8080;

This item has no description.

GL_COLOR_ARRAY_SIZE_EXT = $8081;

This item has no description.

GL_COLOR_ARRAY_TYPE_EXT = $8082;

This item has no description.

GL_COLOR_ARRAY_STRIDE_EXT = $8083;

This item has no description.

GL_COLOR_ARRAY_COUNT_EXT = $8084;

This item has no description.

GL_INDEX_ARRAY_TYPE_EXT = $8085;

This item has no description.

GL_INDEX_ARRAY_STRIDE_EXT = $8086;

This item has no description.

GL_INDEX_ARRAY_COUNT_EXT = $8087;

This item has no description.

GL_TEXTURE_COORD_ARRAY_SIZE_EXT = $8088;

This item has no description.

GL_TEXTURE_COORD_ARRAY_TYPE_EXT = $8089;

This item has no description.

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT = $808A;

This item has no description.

GL_TEXTURE_COORD_ARRAY_COUNT_EXT = $808B;

This item has no description.

GL_EDGE_FLAG_ARRAY_STRIDE_EXT = $808C;

This item has no description.

GL_EDGE_FLAG_ARRAY_COUNT_EXT = $808D;

This item has no description.

GL_VERTEX_ARRAY_POINTER_EXT = $808E;

This item has no description.

GL_NORMAL_ARRAY_POINTER_EXT = $808F;

This item has no description.

GL_COLOR_ARRAY_POINTER_EXT = $8090;

This item has no description.

GL_INDEX_ARRAY_POINTER_EXT = $8091;

This item has no description.

GL_TEXTURE_COORD_ARRAY_POINTER_EXT = $8092;

This item has no description.

GL_EDGE_FLAG_ARRAY_POINTER_EXT = $8093;

This item has no description.

GL_VERTEX_SHADER_EXT = $8780;

GL_EXT_vertex_shader

GL_VERTEX_SHADER_BINDING_EXT = $8781;

This item has no description.

GL_OP_INDEX_EXT = $8782;

This item has no description.

GL_OP_NEGATE_EXT = $8783;

This item has no description.

GL_OP_DOT3_EXT = $8784;

This item has no description.

GL_OP_DOT4_EXT = $8785;

This item has no description.

GL_OP_MUL_EXT = $8786;

This item has no description.

GL_OP_ADD_EXT = $8787;

This item has no description.

GL_OP_MADD_EXT = $8788;

This item has no description.

GL_OP_FRAC_EXT = $8789;

This item has no description.

GL_OP_MAX_EXT = $878A;

This item has no description.

GL_OP_MIN_EXT = $878B;

This item has no description.

GL_OP_SET_GE_EXT = $878C;

This item has no description.

GL_OP_SET_LT_EXT = $878D;

This item has no description.

GL_OP_CLAMP_EXT = $878E;

This item has no description.

GL_OP_FLOOR_EXT = $878F;

This item has no description.

GL_OP_ROUND_EXT = $8790;

This item has no description.

GL_OP_EXP_BASE_2_EXT = $8791;

This item has no description.

GL_OP_LOG_BASE_2_EXT = $8792;

This item has no description.

GL_OP_POWER_EXT = $8793;

This item has no description.

GL_OP_RECIP_EXT = $8794;

This item has no description.

GL_OP_RECIP_SQRT_EXT = $8795;

This item has no description.

GL_OP_SUB_EXT = $8796;

This item has no description.

GL_OP_CROSS_PRODUCT_EXT = $8797;

This item has no description.

GL_OP_MULTIPLY_MATRIX_EXT = $8798;

This item has no description.

GL_OP_MOV_EXT = $8799;

This item has no description.

GL_OUTPUT_VERTEX_EXT = $879A;

This item has no description.

GL_OUTPUT_COLOR0_EXT = $879B;

This item has no description.

GL_OUTPUT_COLOR1_EXT = $879C;

This item has no description.

GL_OUTPUT_TEXTURE_COORD0_EXT = $879D;

This item has no description.

GL_OUTPUT_TEXTURE_COORD1_EXT = $879E;

This item has no description.

GL_OUTPUT_TEXTURE_COORD2_EXT = $879F;

This item has no description.

GL_OUTPUT_TEXTURE_COORD3_EXT = $87A0;

This item has no description.

GL_OUTPUT_TEXTURE_COORD4_EXT = $87A1;

This item has no description.

GL_OUTPUT_TEXTURE_COORD5_EXT = $87A2;

This item has no description.

GL_OUTPUT_TEXTURE_COORD6_EXT = $87A3;

This item has no description.

GL_OUTPUT_TEXTURE_COORD7_EXT = $87A4;

This item has no description.

GL_OUTPUT_TEXTURE_COORD8_EXT = $87A5;

This item has no description.

GL_OUTPUT_TEXTURE_COORD9_EXT = $87A6;

This item has no description.

GL_OUTPUT_TEXTURE_COORD10_EXT = $87A7;

This item has no description.

GL_OUTPUT_TEXTURE_COORD11_EXT = $87A8;

This item has no description.

GL_OUTPUT_TEXTURE_COORD12_EXT = $87A9;

This item has no description.

GL_OUTPUT_TEXTURE_COORD13_EXT = $87AA;

This item has no description.

GL_OUTPUT_TEXTURE_COORD14_EXT = $87AB;

This item has no description.

GL_OUTPUT_TEXTURE_COORD15_EXT = $87AC;

This item has no description.

GL_OUTPUT_TEXTURE_COORD16_EXT = $87AD;

This item has no description.

GL_OUTPUT_TEXTURE_COORD17_EXT = $87AE;

This item has no description.

GL_OUTPUT_TEXTURE_COORD18_EXT = $87AF;

This item has no description.

GL_OUTPUT_TEXTURE_COORD19_EXT = $87B0;

This item has no description.

GL_OUTPUT_TEXTURE_COORD20_EXT = $87B1;

This item has no description.

GL_OUTPUT_TEXTURE_COORD21_EXT = $87B2;

This item has no description.

GL_OUTPUT_TEXTURE_COORD22_EXT = $87B3;

This item has no description.

GL_OUTPUT_TEXTURE_COORD23_EXT = $87B4;

This item has no description.

GL_OUTPUT_TEXTURE_COORD24_EXT = $87B5;

This item has no description.

GL_OUTPUT_TEXTURE_COORD25_EXT = $87B6;

This item has no description.

GL_OUTPUT_TEXTURE_COORD26_EXT = $87B7;

This item has no description.

GL_OUTPUT_TEXTURE_COORD27_EXT = $87B8;

This item has no description.

GL_OUTPUT_TEXTURE_COORD28_EXT = $87B9;

This item has no description.

GL_OUTPUT_TEXTURE_COORD29_EXT = $87BA;

This item has no description.

GL_OUTPUT_TEXTURE_COORD30_EXT = $87BB;

This item has no description.

GL_OUTPUT_TEXTURE_COORD31_EXT = $87BC;

This item has no description.

GL_OUTPUT_FOG_EXT = $87BD;

This item has no description.

GL_SCALAR_EXT = $87BE;

This item has no description.

GL_VECTOR_EXT = $87BF;

This item has no description.

GL_MATRIX_EXT = $87C0;

This item has no description.

GL_VARIANT_EXT = $87C1;

This item has no description.

GL_INVARIANT_EXT = $87C2;

This item has no description.

GL_LOCAL_CONSTANT_EXT = $87C3;

This item has no description.

GL_LOCAL_EXT = $87C4;

This item has no description.

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT = $87C5;

This item has no description.

GL_MAX_VERTEX_SHADER_VARIANTS_EXT = $87C6;

This item has no description.

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT = $87C7;

This item has no description.

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87C8;

This item has no description.

GL_MAX_VERTEX_SHADER_LOCALS_EXT = $87C9;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CA;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT = $87CB;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87CC;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT = $87CD;

This item has no description.

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT = $87CE;

This item has no description.

GL_VERTEX_SHADER_INSTRUCTIONS_EXT = $87CF;

This item has no description.

GL_VERTEX_SHADER_VARIANTS_EXT = $87D0;

This item has no description.

GL_VERTEX_SHADER_INVARIANTS_EXT = $87D1;

This item has no description.

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT = $87D2;

This item has no description.

GL_VERTEX_SHADER_LOCALS_EXT = $87D3;

This item has no description.

GL_VERTEX_SHADER_OPTIMIZED_EXT = $87D4;

This item has no description.

GL_X_EXT = $87D5;

This item has no description.

GL_Y_EXT = $87D6;

This item has no description.

GL_Z_EXT = $87D7;

This item has no description.

GL_W_EXT = $87D8;

This item has no description.

GL_NEGATIVE_X_EXT = $87D9;

This item has no description.

GL_NEGATIVE_Y_EXT = $87DA;

This item has no description.

GL_NEGATIVE_Z_EXT = $87DB;

This item has no description.

GL_NEGATIVE_W_EXT = $87DC;

This item has no description.

GL_ZERO_EXT = $87DD;

This item has no description.

GL_ONE_EXT = $87DE;

This item has no description.

GL_NEGATIVE_ONE_EXT = $87DF;

This item has no description.

GL_NORMALIZED_RANGE_EXT = $87E0;

This item has no description.

GL_FULL_RANGE_EXT = $87E1;

This item has no description.

GL_CURRENT_VERTEX_EXT = $87E2;

This item has no description.

GL_MVP_MATRIX_EXT = $87E3;

This item has no description.

GL_VARIANT_VALUE_EXT = $87E4;

This item has no description.

GL_VARIANT_DATATYPE_EXT = $87E5;

This item has no description.

GL_VARIANT_ARRAY_STRIDE_EXT = $87E6;

This item has no description.

GL_VARIANT_ARRAY_TYPE_EXT = $87E7;

This item has no description.

GL_VARIANT_ARRAY_EXT = $87E8;

This item has no description.

GL_VARIANT_ARRAY_POINTER_EXT = $87E9;

This item has no description.

GL_INVARIANT_VALUE_EXT = $87EA;

This item has no description.

GL_INVARIANT_DATATYPE_EXT = $87EB;

This item has no description.

GL_LOCAL_CONSTANT_VALUE_EXT = $87EC;

This item has no description.

GL_LOCAL_CONSTANT_DATATYPE_EXT = $87ED;

This item has no description.

GL_MODELVIEW0_STACK_DEPTH_EXT = $0BA3;

GL_EXT_vertex_weighting

GL_MODELVIEW1_STACK_DEPTH_EXT = $8502;

This item has no description.

GL_MODELVIEW0_MATRIX_EXT = $0BA6;

This item has no description.

GL_MODELVIEW1_MATRIX_EXT = $8506;

This item has no description.

GL_VERTEX_WEIGHTING_EXT = $8509;

This item has no description.

GL_MODELVIEW0_EXT = $1700;

This item has no description.

GL_MODELVIEW1_EXT = $850A;

This item has no description.

GL_CURRENT_VERTEX_WEIGHT_EXT = $850B;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_EXT = $850C;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT = $850D;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT = $850E;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT = $850F;

This item has no description.

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT = $8510;

This item has no description.

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_EXT_depth_bounds_test

GL_DEPTH_BOUNDS_EXT = $8891;

This item has no description.

GL_MIRROR_CLAMP_EXT = $8742;

GL_EXT_texture_mirror_clamp

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

This item has no description.

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

This item has no description.

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_EXT_blend_equation_separate

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

This item has no description.

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_EXT_pixel_buffer_object

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

This item has no description.

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

This item has no description.

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

This item has no description.

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_EXT_stencil_clear_tag

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

This item has no description.

GL_DEPTH_STENCIL_EXT = $84F9;

GL_EXT_packed_depth_stencil

GL_UNSIGNED_INT_24_8_EXT = $84FA;

This item has no description.

GL_DEPTH24_STENCIL8_EXT = $88F0;

This item has no description.

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

This item has no description.

GL_SRGB_EXT = $8C40;

GL_EXT_texture_sRGB

GL_SRGB8_EXT = $8C41;

This item has no description.

GL_SRGB_ALPHA_EXT = $8C42;

This item has no description.

GL_SRGB8_ALPHA8_EXT = $8C43;

This item has no description.

GL_SLUMINANCE_ALPHA_EXT = $8C44;

This item has no description.

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

This item has no description.

GL_SLUMINANCE_EXT = $8C46;

This item has no description.

GL_SLUMINANCE8_EXT = $8C47;

This item has no description.

GL_COMPRESSED_SRGB_EXT = $8C48;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

This item has no description.

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

This item has no description.

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

This item has no description.

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

This item has no description.

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

This item has no description.

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_EXT_framebuffer_blit

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

This item has no description.

GL_READ_FRAMEBUFFER_BINDING_EXT = GL_FRAMEBUFFER_BINDING_EXT;

This item has no description.

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CAA;

This item has no description.

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_EXT_framebuffer_multisample

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

This item has no description.

GL_MAX_SAMPLES_EXT = $8D57;

This item has no description.

GL_TIME_ELAPSED_EXT = $88BF;

GL_EXT_timer_query

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_EXT_bindable_uniform

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

This item has no description.

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

This item has no description.

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

This item has no description.

GL_UNIFORM_BUFFER_EXT = $8DEE;

This item has no description.

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

This item has no description.

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

GL_EXT_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

This item has no description.

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

This item has no description.

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

This item has no description.

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_EXT_geometry_shader4

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

This item has no description.

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

This item has no description.

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

This item has no description.

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

This item has no description.

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

This item has no description.

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

This item has no description.

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

This item has no description.

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

This item has no description.

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

This item has no description.

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

This item has no description.

GL_LINES_ADJACENCY_EXT = $A;

This item has no description.

GL_LINE_STRIP_ADJACENCY_EXT = $B;

This item has no description.

GL_TRIANGLES_ADJACENCY_EXT = $C;

This item has no description.

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

This item has no description.

GL_PROGRAM_POINT_SIZE_EXT = $8642;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_EXT_gpu_shader4

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

This item has no description.

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

This item has no description.

GL_SAMPLER_BUFFER_EXT = $8DC2;

This item has no description.

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

This item has no description.

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

This item has no description.

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

This item has no description.

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

This item has no description.

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

This item has no description.

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

This item has no description.

GL_INT_SAMPLER_1D_EXT = $8DC9;

This item has no description.

GL_INT_SAMPLER_2D_EXT = $8DCA;

This item has no description.

GL_INT_SAMPLER_3D_EXT = $8DCB;

This item has no description.

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

This item has no description.

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

This item has no description.

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

This item has no description.

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

This item has no description.

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

This item has no description.

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

This item has no description.

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

This item has no description.

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_EXT_packed_float

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

This item has no description.

RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

This item has no description.

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

This item has no description.

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

This item has no description.

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

This item has no description.

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_EXT_texture_array

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

This item has no description.

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

This item has no description.

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

This item has no description.

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

This item has no description.

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

This item has no description.

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

This item has no description.

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

This item has no description.

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_EXT_texture_buffer_object

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

This item has no description.

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

This item has no description.

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

This item has no description.

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

This item has no description.

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_EXT_texture_compression_latc

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

This item has no description.

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

This item has no description.

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

This item has no description.

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_EXT_texture_compression_rgtc

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

This item has no description.

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

This item has no description.

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

This item has no description.

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_EXT_texture_integer

GL_RGBA32UI_EXT = $8D70;

This item has no description.

GL_RGB32UI_EXT = $8D71;

This item has no description.

GL_ALPHA32UI_EXT = $8D72;

This item has no description.

GL_INTENSITY32UI_EXT = $8D73;

This item has no description.

GL_LUMINANCE32UI_EXT = $8D74;

This item has no description.

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

This item has no description.

GL_RGBA16UI_EXT = $8D76;

This item has no description.

GL_RGB16UI_EXT = $8D77;

This item has no description.

GL_ALPHA16UI_EXT = $8D78;

This item has no description.

GL_INTENSITY16UI_EXT = $8D79;

This item has no description.

GL_LUMINANCE16UI_EXT = $8D7A;

This item has no description.

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

This item has no description.

GL_RGBA8UI_EXT = $8D7C;

This item has no description.

GL_RGB8UI_EXT = $8D7D;

This item has no description.

GL_ALPHA8UI_EXT = $8D7E;

This item has no description.

GL_INTENSITY8UI_EXT = $8D7F;

This item has no description.

GL_LUMINANCE8UI_EXT = $8D80;

This item has no description.

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

This item has no description.

GL_RGBA32I_EXT = $8D82;

This item has no description.

GL_RGB32I_EXT = $8D83;

This item has no description.

GL_ALPHA32I_EXT = $8D84;

This item has no description.

GL_INTENSITY32I_EXT = $8D85;

This item has no description.

GL_LUMINANCE32I_EXT = $8D86;

This item has no description.

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

This item has no description.

GL_RGBA16I_EXT = $8D88;

This item has no description.

GL_RGB16I_EXT = $8D89;

This item has no description.

GL_ALPHA16I_EXT = $8D8A;

This item has no description.

GL_INTENSITY16I_EXT = $8D8B;

This item has no description.

GL_LUMINANCE16I_EXT = $8D8C;

This item has no description.

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

This item has no description.

GL_RGBA8I_EXT = $8D8E;

This item has no description.

GL_RGB8I_EXT = $8D8F;

This item has no description.

GL_ALPHA8I_EXT = $8D90;

This item has no description.

GL_INTENSITY8I_EXT = $8D91;

This item has no description.

GL_LUMINANCE8I_EXT = $8D92;

This item has no description.

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

This item has no description.

GL_RED_INTEGER_EXT = $8D94;

This item has no description.

GL_GREEN_INTEGER_EXT = $8D95;

This item has no description.

GL_BLUE_INTEGER_EXT = $8D96;

This item has no description.

GL_ALPHA_INTEGER_EXT = $8D97;

This item has no description.

GL_RGB_INTEGER_EXT = $8D98;

This item has no description.

GL_RGBA_INTEGER_EXT = $8D99;

This item has no description.

GL_BGR_INTEGER_EXT = $8D9A;

This item has no description.

GL_BGRA_INTEGER_EXT = $8D9B;

This item has no description.

GL_LUMINANCE_INTEGER_EXT = $8D9C;

This item has no description.

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

This item has no description.

GL_RGB9_E5_EXT = $8C3D;

GL_EXT_texture_shared_exponent

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

This item has no description.

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_EXT_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

This item has no description.

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

This item has no description.

GL_PRIMITIVES_GENERATED_EXT = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD_EXT = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

This item has no description.

GL_PROGRAM_MATRIX_EXT = $8E2D;

GL_EXT_direct_state_access

GL_TRANSPOSE_PROGRAM_MATRIX_EXT = $8E2E;

This item has no description.

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT = $8E2F;

This item has no description.

GL_TEXTURE_SWIZZLE_R_EXT = $8E42;

GL_EXT_texture_swizzle

GL_TEXTURE_SWIZZLE_G_EXT = $8E43;

This item has no description.

GL_TEXTURE_SWIZZLE_B_EXT = $8E44;

This item has no description.

GL_TEXTURE_SWIZZLE_A_EXT = $8E45;

This item has no description.

GL_TEXTURE_SWIZZLE_RGBA_EXT = $8E46;

This item has no description.

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT = $8E4C;

GL_EXT_provoking_vertex

GL_FIRST_VERTEX_CONVENTION_EXT = $8E4D;

This item has no description.

GL_LAST_VERTEX_CONVENTION_EXT = $8E4E;

This item has no description.

GL_PROVOKING_VERTEX_EXT = $8E4F;

This item has no description.

GL_ALPHA_SNORM = $9010;

GL_EXT_texture_snorm

GL_LUMINANCE_SNORM = $9011;

This item has no description.

GL_LUMINANCE_ALPHA_SNORM = $9012;

This item has no description.

GL_INTENSITY_SNORM = $9013;

This item has no description.

GL_ALPHA8_SNORM = $9014;

This item has no description.

GL_LUMINANCE8_SNORM = $9015;

This item has no description.

GL_LUMINANCE8_ALPHA8_SNORM = $9016;

This item has no description.

GL_INTENSITY8_SNORM = $9017;

This item has no description.

GL_ALPHA16_SNORM = $9018;

This item has no description.

GL_LUMINANCE16_SNORM = $9019;

This item has no description.

GL_LUMINANCE16_ALPHA16_SNORM = $901A;

This item has no description.

GL_INTENSITY16_SNORM = $901B;

This item has no description.

GL_ACTIVE_PROGRAM_EXT = $8B8D;

GL_EXT_separate_shader_objects

GL_MAX_IMAGE_UNITS_EXT = $8F38;

GL_EXT_shader_image_load_store

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT = $8F39;

This item has no description.

GL_IMAGE_BINDING_NAME_EXT = $8F3A;

This item has no description.

GL_IMAGE_BINDING_LEVEL_EXT = $8F3B;

This item has no description.

GL_IMAGE_BINDING_LAYERED_EXT = $8F3C;

This item has no description.

GL_IMAGE_BINDING_LAYER_EXT = $8F3D;

This item has no description.

GL_IMAGE_BINDING_ACCESS_EXT = $8F3E;

This item has no description.

GL_IMAGE_1D_EXT = $904C;

This item has no description.

GL_IMAGE_2D_EXT = $904D;

This item has no description.

GL_IMAGE_3D_EXT = $904E;

This item has no description.

GL_IMAGE_2D_RECT_EXT = $904F;

This item has no description.

GL_IMAGE_CUBE_EXT = $9050;

This item has no description.

GL_IMAGE_BUFFER_EXT = $9051;

This item has no description.

GL_IMAGE_1D_ARRAY_EXT = $9052;

This item has no description.

GL_IMAGE_2D_ARRAY_EXT = $9053;

This item has no description.

GL_IMAGE_CUBE_MAP_ARRAY_EXT = $9054;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_EXT = $9055;

This item has no description.

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9056;

This item has no description.

GL_INT_IMAGE_1D_EXT = $9057;

This item has no description.

GL_INT_IMAGE_2D_EXT = $9058;

This item has no description.

GL_INT_IMAGE_3D_EXT = $9059;

This item has no description.

GL_INT_IMAGE_2D_RECT_EXT = $905A;

This item has no description.

GL_INT_IMAGE_CUBE_EXT = $905B;

This item has no description.

GL_INT_IMAGE_BUFFER_EXT = $905C;

This item has no description.

GL_INT_IMAGE_1D_ARRAY_EXT = $905D;

This item has no description.

GL_INT_IMAGE_2D_ARRAY_EXT = $905E;

This item has no description.

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $905F;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_EXT = $9060;

This item has no description.

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $9061;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_EXT = $9062;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_EXT = $9063;

This item has no description.

GL_UNSIGNED_INT_IMAGE_3D_EXT = $9064;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT = $9065;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_EXT = $9066;

This item has no description.

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT = $9067;

This item has no description.

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT = $9068;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT = $9069;

This item has no description.

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT = $906A;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT = $906B;

This item has no description.

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT = $906C;

This item has no description.

GL_MAX_IMAGE_SAMPLES_EXT = $906D;

This item has no description.

GL_IMAGE_BINDING_FORMAT_EXT = $906E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT = $00000001;

This item has no description.

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT = $00000002;

This item has no description.

GL_UNIFORM_BARRIER_BIT_EXT = $00000004;

This item has no description.

GL_TEXTURE_FETCH_BARRIER_BIT_EXT = $00000008;

This item has no description.

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT = $00000020;

This item has no description.

GL_COMMAND_BARRIER_BIT_EXT = $00000040;

This item has no description.

GL_PIXEL_BUFFER_BARRIER_BIT_EXT = $00000080;

This item has no description.

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT = $00000100;

This item has no description.

GL_BUFFER_UPDATE_BARRIER_BIT_EXT = $00000200;

This item has no description.

GL_FRAMEBUFFER_BARRIER_BIT_EXT = $00000400;

This item has no description.

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT = $00000800;

This item has no description.

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT = $00001000;

This item has no description.

GL_ALL_BARRIER_BITS_EXT = $FFFFFFFF;

This item has no description.

GL_DOUBLE_VEC2_EXT = $8FFC;

reuse GL_DOUBLE

GL_DOUBLE_VEC3_EXT = $8FFD;

This item has no description.

GL_DOUBLE_VEC4_EXT = $8FFE;

This item has no description.

GL_DOUBLE_MAT2_EXT = $8F46;

This item has no description.

GL_DOUBLE_MAT3_EXT = $8F47;

This item has no description.

GL_DOUBLE_MAT4_EXT = $8F48;

This item has no description.

GL_DOUBLE_MAT2x3_EXT = $8F49;

This item has no description.

GL_DOUBLE_MAT2x4_EXT = $8F4A;

This item has no description.

GL_DOUBLE_MAT3x2_EXT = $8F4B;

This item has no description.

GL_DOUBLE_MAT3x4_EXT = $8F4C;

This item has no description.

GL_DOUBLE_MAT4x2_EXT = $8F4D;

This item has no description.

GL_DOUBLE_MAT4x3_EXT = $8F4E;

This item has no description.

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_EXT_texture_sRGB_decode

GL_DECODE_EXT = $8A49;

This item has no description.

GL_SKIP_DECODE_EXT = $8A4A;

This item has no description.

GL_TEXTURE_COVERAGE_SAMPLES_NV = $9045;

GL_NV_texture_multisample

GL_TEXTURE_COLOR_SAMPLES_NV = $9046;

This item has no description.

GL_FACTOR_MIN_AMD = $901C;

GL_AMD_blend_minmax_factor

GL_FACTOR_MAX_AMD = $901D;

This item has no description.

GL_SUBSAMPLE_DISTANCE_AMD = $883F;

GL_AMD_sample_positions

GL_SYNC_X11_FENCE_EXT = $90E1;

GL_EXT_x11_sync_object

GL_SCALED_RESOLVE_FASTEST_EXT = $90BA;

GL_EXT_framebuffer_multisample_blit_scaled

GL_SCALED_RESOLVE_NICEST_EXT = $90BB;

This item has no description.

GL_PATH_FORMAT_SVG_NV = $9070;

(4.3) GL_NV_path_rendering

GL_PATH_FORMAT_PS_NV = $9071;

This item has no description.

GL_STANDARD_FONT_NAME_NV = $9072;

This item has no description.

GL_SYSTEM_FONT_NAME_NV = $9073;

This item has no description.

GL_FILE_NAME_NV = $9074;

This item has no description.

GL_PATH_STROKE_WIDTH_NV = $9075;

This item has no description.

GL_PATH_END_CAPS_NV = $9076;

This item has no description.

GL_PATH_INITIAL_END_CAP_NV = $9077;

This item has no description.

GL_PATH_TERMINAL_END_CAP_NV = $9078;

This item has no description.

GL_PATH_JOIN_STYLE_NV = $9079;

This item has no description.

GL_PATH_MITER_LIMIT_NV = $907A;

This item has no description.

GL_PATH_DASH_CAPS_NV = $907B;

This item has no description.

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

This item has no description.

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

This item has no description.

GL_PATH_DASH_OFFSET_NV = $907E;

This item has no description.

GL_PATH_CLIENT_LENGTH_NV = $907F;

This item has no description.

GL_PATH_FILL_MODE_NV = $9080;

This item has no description.

GL_PATH_FILL_MASK_NV = $9081;

This item has no description.

GL_PATH_FILL_COVER_MODE_NV = $9082;

This item has no description.

GL_PATH_STROKE_COVER_MODE_NV = $9083;

This item has no description.

GL_PATH_STROKE_MASK_NV = $9084;

This item has no description.

GL_PATH_SAMPLE_QUALITY_NV = $9085;

This item has no description.

GL_PATH_STROKE_BOUND_NV = $9086;

This item has no description.

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV= $9087;

This item has no description.

GL_COUNT_UP_NV = $9088;

This item has no description.

GL_COUNT_DOWN_NV = $9089;

This item has no description.

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

This item has no description.

GL_CONVEX_HULL_NV = $908B;

This item has no description.

GL_MULTI_HULLS_NV = $908C;

This item has no description.

GL_BOUNDING_BOX_NV = $908D;

This item has no description.

GL_TRANSLATE_X_NV = $908E;

This item has no description.

GL_TRANSLATE_Y_NV = $908F;

This item has no description.

GL_TRANSLATE_2D_NV = $9090;

This item has no description.

GL_TRANSLATE_3D_NV = $9091;

This item has no description.

GL_AFFINE_2D_NV = $9092;

This item has no description.

GL_PROJECTIVE_2D_NV = $9093;

This item has no description.

GL_AFFINE_3D_NV = $9094;

This item has no description.

GL_PROJECTIVE_3D_NV = $9095;

This item has no description.

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

This item has no description.

GL_TRANSPOSE_PROJECTIVE_2D_NV = $9097;

This item has no description.

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

This item has no description.

GL_TRANSPOSE_PROJECTIVE_3D_NV = $9099;

This item has no description.

GL_UTF8_NV = $909A;

This item has no description.

GL_UTF16_NV = $909B;

This item has no description.

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV= $909C;

This item has no description.

GL_PATH_COMMAND_COUNT_NV = $909D;

This item has no description.

GL_PATH_COORD_COUNT_NV = $909E;

This item has no description.

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

This item has no description.

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

This item has no description.

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

This item has no description.

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

This item has no description.

GL_SQUARE_NV = $90A3;

This item has no description.

GL_ROUND_NV = $90A4;

This item has no description.

GL_TRIANGULAR_NV = $90A5;

This item has no description.

GL_BEVEL_NV = $90A6;

This item has no description.

GL_MITER_REVERT_NV = $90A7;

This item has no description.

GL_MITER_TRUNCATE_NV = $90A8;

This item has no description.

GL_SKIP_MISSING_GLYPH_NV = $90A9;

This item has no description.

GL_USE_MISSING_GLYPH_NV = $90AA;

This item has no description.

GL_PATH_ERROR_POSITION_NV = $90AB;

This item has no description.

GL_PATH_FOG_GEN_MODE_NV = $90AC;

This item has no description.

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

This item has no description.

GL_ADJACENT_PAIRS_NV = $90AE;

This item has no description.

GL_FIRST_TO_REST_NV = $90AF;

This item has no description.

GL_PATH_GEN_MODE_NV = $90B0;

This item has no description.

GL_PATH_GEN_COEFF_NV = $90B1;

This item has no description.

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

This item has no description.

GL_PATH_GEN_COMPONENTS_NV = $90B3;

This item has no description.

GL_PATH_STENCIL_FUNC_NV = $90B7;

This item has no description.

GL_PATH_STENCIL_REF_NV = $90B8;

This item has no description.

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

This item has no description.

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV= $90BD;

This item has no description.

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV= $90BE;

This item has no description.

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

This item has no description.

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

This item has no description.

GL_MOVE_TO_RESETS_NV = $90B5;

This item has no description.

GL_MOVE_TO_CONTINUES_NV = $90B6;

This item has no description.

GL_CLOSE_PATH_NV = $00;

This item has no description.

GL_MOVE_TO_NV = $02;

This item has no description.

GL_RELATIVE_MOVE_TO_NV = $03;

This item has no description.

GL_LINE_TO_NV = $04;

This item has no description.

GL_RELATIVE_LINE_TO_NV = $05;

This item has no description.

GL_HORIZONTAL_LINE_TO_NV = $06;

This item has no description.

GL_RELATIVE_HORIZONTAL_LINE_TO_NV= $07;

This item has no description.

GL_VERTICAL_LINE_TO_NV = $08;

This item has no description.

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

This item has no description.

GL_QUADRATIC_CURVE_TO_NV = $0A;

This item has no description.

GL_RELATIVE_QUADRATIC_CURVE_TO_NV= $0B;

This item has no description.

GL_CUBIC_CURVE_TO_NV = $0C;

This item has no description.

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

This item has no description.

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

This item has no description.

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV= $0F;

This item has no description.

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

This item has no description.

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV= $11;

This item has no description.

GL_SMALL_CCW_ARC_TO_NV = $12;

This item has no description.

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

This item has no description.

GL_SMALL_CW_ARC_TO_NV = $14;

This item has no description.

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

This item has no description.

GL_LARGE_CCW_ARC_TO_NV = $16;

This item has no description.

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

This item has no description.

GL_LARGE_CW_ARC_TO_NV = $18;

This item has no description.

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

This item has no description.

GL_RESTART_PATH_NV = $F0;

This item has no description.

GL_DUP_FIRST_CUBIC_CURVE_TO_NV = $F2;

This item has no description.

GL_DUP_LAST_CUBIC_CURVE_TO_NV = $F4;

This item has no description.

GL_RECT_NV = $F6;

This item has no description.

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

This item has no description.

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

This item has no description.

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

This item has no description.

GL_ARC_TO_NV = $FE;

This item has no description.

GL_RELATIVE_ARC_TO_NV = $FF;

This item has no description.

GL_BOLD_BIT_NV = $01;

This item has no description.

GL_ITALIC_BIT_NV = $02;

This item has no description.

GL_GLYPH_WIDTH_BIT_NV = $01;

This item has no description.

GL_GLYPH_HEIGHT_BIT_NV = $02;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV= $04;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV= $08;

This item has no description.

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV= $10;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV= $20;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV= $40;

This item has no description.

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV= $80;

This item has no description.

GL_GLYPH_HAS_KERNING_NV = $100;

This item has no description.

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

This item has no description.

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

This item has no description.

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

This item has no description.

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

This item has no description.

GL_FONT_UNITS_PER_EM_NV = $00100000;

This item has no description.

GL_FONT_ASCENDER_NV = $00200000;

This item has no description.

GL_FONT_DESCENDER_NV = $00400000;

This item has no description.

GL_FONT_HEIGHT_NV = $00800000;

This item has no description.

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

This item has no description.

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

This item has no description.

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

This item has no description.

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

This item has no description.

GL_FONT_HAS_KERNING_NV = $10000000;

This item has no description.

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD= $9160;

(4.3) GL_AMD_pinned_memory

GL_SET_AMD = $874A;

(4.3) GL_AMD_stencil_operation_extended

GL_REPLACE_VALUE_AMD = $874B;

This item has no description.

GL_STENCIL_OP_VALUE_AMD = $874C;

This item has no description.

GL_STENCIL_BACK_OP_VALUE_AMD = $874D;

This item has no description.

GL_QUERY_BUFFER_AMD = $9192;

(4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object

GL_QUERY_BUFFER_BINDING_AMD = $9193;

This item has no description.

GL_QUERY_RESULT_NO_WAIT_AMD = $9194;

This item has no description.

GL_TEXTURE_DEFORMATION_BIT_SGIX = $00000001;

GL_FfdMaskSGIX

GL_GEOMETRY_DEFORMATION_BIT_SGIX = $00000002;

This item has no description.

GL_IGNORE_BORDER_HP = $8150;

GL_HP_convolution_border_modes

GL_CONSTANT_BORDER_HP = $8151;

This item has no description.

GL_REPLICATE_BORDER_HP = $8153;

This item has no description.

GL_CONVOLUTION_BORDER_COLOR_HP = $8154;

This item has no description.

GL_IMAGE_SCALE_X_HP = $8155;

GL_HP_image_transform

GL_IMAGE_SCALE_Y_HP = $8156;

This item has no description.

GL_IMAGE_TRANSLATE_X_HP = $8157;

This item has no description.

GL_IMAGE_TRANSLATE_Y_HP = $8158;

This item has no description.

GL_IMAGE_ROTATE_ANGLE_HP = $8159;

This item has no description.

GL_IMAGE_ROTATE_ORIGIN_X_HP = $815A;

This item has no description.

GL_IMAGE_ROTATE_ORIGIN_Y_HP = $815B;

This item has no description.

GL_IMAGE_MAG_FILTER_HP = $815C;

This item has no description.

GL_IMAGE_MIN_FILTER_HP = $815D;

This item has no description.

GL_IMAGE_CUBIC_WEIGHT_HP = $815E;

This item has no description.

GL_CUBIC_HP = $815F;

This item has no description.

GL_AVERAGE_HP = $8160;

This item has no description.

GL_IMAGE_TRANSFORM_2D_HP = $8161;

This item has no description.

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8162;

This item has no description.

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP = $8163;

This item has no description.

GL_OCCLUSION_TEST_HP = $8165;

GL_HP_occlusion_test

GL_OCCLUSION_TEST_RESULT_HP = $8166;

This item has no description.

GL_TEXTURE_LIGHTING_MODE_HP = $8167;

GL_HP_texture_lighting

GL_TEXTURE_POST_SPECULAR_HP = $8168;

This item has no description.

GL_TEXTURE_PRE_SPECULAR_HP = $8169;

This item has no description.

GL_CULL_VERTEX_IBM = 103050;

GL_IBM_cull_vertex

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_IBM_rasterpos_clip

GL_MIRRORED_REPEAT_IBM = $8370;

GL_IBM_texture_mirrored_repeat

GL_VERTEX_ARRAY_LIST_IBM = 103070;

GL_IBM_vertex_array_lists

GL_NORMAL_ARRAY_LIST_IBM = 103071;

This item has no description.

GL_COLOR_ARRAY_LIST_IBM = 103072;

This item has no description.

GL_INDEX_ARRAY_LIST_IBM = 103073;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LIST_IBM = 103074;

This item has no description.

GL_EDGE_FLAG_ARRAY_LIST_IBM = 103075;

This item has no description.

GL_FOG_COORDINATE_ARRAY_LIST_IBM = 103076;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LIST_IBM = 103077;

This item has no description.

GL_VERTEX_ARRAY_LIST_STRIDE_IBM = 103080;

This item has no description.

GL_NORMAL_ARRAY_LIST_STRIDE_IBM = 103081;

This item has no description.

GL_COLOR_ARRAY_LIST_STRIDE_IBM = 103082;

This item has no description.

GL_INDEX_ARRAY_LIST_STRIDE_IBM = 103083;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM = 103084;

This item has no description.

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM = 103085;

This item has no description.

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM = 103086;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM = 103087;

This item has no description.

GL_RED_MIN_CLAMP_INGR = $8560;

GL_INGR_color_clamp

GL_GREEN_MIN_CLAMP_INGR = $8561;

This item has no description.

GL_BLUE_MIN_CLAMP_INGR = $8562;

This item has no description.

GL_ALPHA_MIN_CLAMP_INGR = $8563;

This item has no description.

GL_RED_MAX_CLAMP_INGR = $8564;

This item has no description.

GL_GREEN_MAX_CLAMP_INGR = $8565;

This item has no description.

GL_BLUE_MAX_CLAMP_INGR = $8566;

This item has no description.

GL_ALPHA_MAX_CLAMP_INGR = $8567;

This item has no description.

GL_INTERLACE_READ_INGR = $8568;

GL_INGR_interlace_read

GL_PARALLEL_ARRAYS_INTEL = $83F4;

GL_INTEL_parallel_arrays

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL = $83F5;

This item has no description.

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL = $83F6;

This item has no description.

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL = $83F7;

This item has no description.

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL = $83F8;

This item has no description.

GL_DEPTH_STENCIL_TO_RGBA_NV = $886E;

GL_NV_copy_depth_to_color

GL_DEPTH_STENCIL_TO_BGRA_NV = $886F;

This item has no description.

GL_DEPTH_CLAMP_NV = $864F;

GL_NV_depth_clamp

GL_EVAL_2D_NV = $86C0;

GL_NV_evaluators

GL_EVAL_TRIANGULAR_2D_NV = $86C1;

This item has no description.

GL_MAP_TESSELLATION_NV = $86C2;

This item has no description.

GL_MAP_ATTRIB_U_ORDER_NV = $86C3;

This item has no description.

GL_MAP_ATTRIB_V_ORDER_NV = $86C4;

This item has no description.

GL_EVAL_FRACTIONAL_TESSELLATION_NV = $86C5;

This item has no description.

GL_EVAL_VERTEX_ATTRIB0_NV = $86C6;

This item has no description.

GL_EVAL_VERTEX_ATTRIB1_NV = $86C7;

This item has no description.

GL_EVAL_VERTEX_ATTRIB2_NV = $86C8;

This item has no description.

GL_EVAL_VERTEX_ATTRIB3_NV = $86C9;

This item has no description.

GL_EVAL_VERTEX_ATTRIB4_NV = $86CA;

This item has no description.

GL_EVAL_VERTEX_ATTRIB5_NV = $86CB;

This item has no description.

GL_EVAL_VERTEX_ATTRIB6_NV = $86CC;

This item has no description.

GL_EVAL_VERTEX_ATTRIB7_NV = $86CD;

This item has no description.

GL_EVAL_VERTEX_ATTRIB8_NV = $86CE;

This item has no description.

GL_EVAL_VERTEX_ATTRIB9_NV = $86CF;

This item has no description.

GL_EVAL_VERTEX_ATTRIB10_NV = $86D0;

This item has no description.

GL_EVAL_VERTEX_ATTRIB11_NV = $86D1;

This item has no description.

GL_EVAL_VERTEX_ATTRIB12_NV = $86D2;

This item has no description.

GL_EVAL_VERTEX_ATTRIB13_NV = $86D3;

This item has no description.

GL_EVAL_VERTEX_ATTRIB14_NV = $86D4;

This item has no description.

GL_EVAL_VERTEX_ATTRIB15_NV = $86D5;

This item has no description.

GL_MAX_MAP_TESSELLATION_NV = $86D6;

This item has no description.

GL_MAX_RATIONAL_EVAL_ORDER_NV = $86D7;

This item has no description.

GL_ALL_COMPLETED_NV = $84F2;

GL_NV_fence

GL_FENCE_STATUS_NV = $84F3;

This item has no description.

GL_FENCE_CONDITION_NV = $84F4;

This item has no description.

GL_FLOAT_R_NV = $8880;

GL_NV_float_buffer

GL_FLOAT_RG_NV = $8881;

This item has no description.

GL_FLOAT_RGB_NV = $8882;

This item has no description.

GL_FLOAT_RGBA_NV = $8883;

This item has no description.

GL_FLOAT_R16_NV = $8884;

This item has no description.

GL_FLOAT_R32_NV = $8885;

This item has no description.

GL_FLOAT_RG16_NV = $8886;

This item has no description.

GL_FLOAT_RG32_NV = $8887;

This item has no description.

GL_FLOAT_RGB16_NV = $8888;

This item has no description.

GL_FLOAT_RGB32_NV = $8889;

This item has no description.

GL_FLOAT_RGBA16_NV = $888A;

This item has no description.

GL_FLOAT_RGBA32_NV = $888B;

This item has no description.

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

This item has no description.

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

This item has no description.

GL_FLOAT_RGBA_MODE_NV = $888E;

This item has no description.

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_NV_fog_distance

GL_EYE_RADIAL_NV = $855B;

This item has no description.

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

This item has no description.

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV = $8868;

GL_NV_fragment_program

GL_FRAGMENT_PROGRAM_NV = $8870;

This item has no description.

GL_MAX_TEXTURE_COORDS_NV = $8871;

This item has no description.

GL_MAX_TEXTURE_IMAGE_UNITS_NV = $8872;

This item has no description.

GL_FRAGMENT_PROGRAM_BINDING_NV = $8873;

This item has no description.

GL_PROGRAM_ERROR_STRING_NV = $8874;

This item has no description.

GL_HALF_FLOAT_NV = $140B;

GL_NV_half_float

GL_MAX_SHININESS_NV = $8504;

GL_NV_light_max_exponent

GL_MAX_SPOT_EXPONENT_NV = $8505;

This item has no description.

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_NV_multisample_filter_hint

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_NV_occlusion_query

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

This item has no description.

GL_PIXEL_COUNT_NV = $8866;

This item has no description.

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

This item has no description.

GL_DEPTH_STENCIL_NV = $84F9;

GL_NV_packed_depth_stencil

GL_UNSIGNED_INT_24_8_NV = $84FA;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_NV = $8878;

GL_NV_pixel_data_range

GL_READ_PIXEL_DATA_RANGE_NV = $8879;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV = $887A;

This item has no description.

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV = $887B;

This item has no description.

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV = $887C;

This item has no description.

GL_READ_PIXEL_DATA_RANGE_POINTER_NV = $887D;

This item has no description.

GL_POINT_SPRITE_NV = $8861;

GL_NV_point_sprite

GL_COORD_REPLACE_NV = $8862;

This item has no description.

GL_POINT_SPRITE_R_MODE_NV = $8863;

This item has no description.

GL_PRIMITIVE_RESTART_NV = $8558;

GL_NV_primitive_restart

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

This item has no description.

GL_REGISTER_COMBINERS_NV = $8522;

GL_NV_register_combiners

GL_VARIABLE_A_NV = $8523;

This item has no description.

GL_VARIABLE_B_NV = $8524;

This item has no description.

GL_VARIABLE_C_NV = $8525;

This item has no description.

GL_VARIABLE_D_NV = $8526;

This item has no description.

GL_VARIABLE_E_NV = $8527;

This item has no description.

GL_VARIABLE_F_NV = $8528;

This item has no description.

GL_VARIABLE_G_NV = $8529;

This item has no description.

GL_CONSTANT_COLOR0_NV = $852A;

This item has no description.

GL_CONSTANT_COLOR1_NV = $852B;

This item has no description.

GL_PRIMARY_COLOR_NV = $852C;

This item has no description.

GL_SECONDARY_COLOR_NV = $852D;

This item has no description.

GL_SPARE0_NV = $852E;

This item has no description.

GL_SPARE1_NV = $852F;

This item has no description.

GL_DISCARD_NV = $8530;

This item has no description.

GL_E_TIMES_F_NV = $8531;

This item has no description.

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

This item has no description.

GL_UNSIGNED_IDENTITY_NV = $8536;

This item has no description.

GL_UNSIGNED_INVERT_NV = $8537;

This item has no description.

GL_EXPAND_NORMAL_NV = $8538;

This item has no description.

GL_EXPAND_NEGATE_NV = $8539;

This item has no description.

GL_HALF_BIAS_NORMAL_NV = $853A;

This item has no description.

GL_HALF_BIAS_NEGATE_NV = $853B;

This item has no description.

GL_SIGNED_IDENTITY_NV = $853C;

This item has no description.

GL_SIGNED_NEGATE_NV = $853D;

This item has no description.

GL_SCALE_BY_TWO_NV = $853E;

This item has no description.

GL_SCALE_BY_FOUR_NV = $853F;

This item has no description.

GL_SCALE_BY_ONE_HALF_NV = $8540;

This item has no description.

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

This item has no description.

GL_COMBINER_INPUT_NV = $8542;

This item has no description.

GL_COMBINER_MAPPING_NV = $8543;

This item has no description.

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

This item has no description.

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

This item has no description.

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

This item has no description.

GL_COMBINER_MUX_SUM_NV = $8547;

This item has no description.

GL_COMBINER_SCALE_NV = $8548;

This item has no description.

GL_COMBINER_BIAS_NV = $8549;

This item has no description.

GL_COMBINER_AB_OUTPUT_NV = $854A;

This item has no description.

GL_COMBINER_CD_OUTPUT_NV = $854B;

This item has no description.

GL_COMBINER_SUM_OUTPUT_NV = $854C;

This item has no description.

GL_MAX_GENERAL_COMBINERS_NV = $854D;

This item has no description.

GL_NUM_GENERAL_COMBINERS_NV = $854E;

This item has no description.

GL_COLOR_SUM_CLAMP_NV = $854F;

This item has no description.

GL_COMBINER0_NV = $8550;

This item has no description.

GL_COMBINER1_NV = $8551;

This item has no description.

GL_COMBINER2_NV = $8552;

This item has no description.

GL_COMBINER3_NV = $8553;

This item has no description.

GL_COMBINER4_NV = $8554;

This item has no description.

GL_COMBINER5_NV = $8555;

This item has no description.

GL_COMBINER6_NV = $8556;

This item has no description.

GL_COMBINER7_NV = $8557;

This item has no description.

GL_PER_STAGE_CONSTANTS_NV = $8535;

GL_NV_register_combiners2

GL_EMBOSS_LIGHT_NV = $855D;

GL_NV_texgen_emboss

GL_EMBOSS_CONSTANT_NV = $855E;

This item has no description.

GL_EMBOSS_MAP_NV = $855F;

This item has no description.

GL_NORMAL_MAP_NV = $8511;

GL_NV_texgen_reflection

GL_REFLECTION_MAP_NV = $8512;

This item has no description.

GL_COMBINE4_NV = $8503;

GL_NV_texture_env_combine4

GL_SOURCE3_RGB_NV = $8583;

This item has no description.

GL_SOURCE3_ALPHA_NV = $858B;

This item has no description.

GL_OPERAND3_RGB_NV = $8593;

This item has no description.

GL_OPERAND3_ALPHA_NV = $859B;

This item has no description.

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV = $888F;

GL_NV_texture_expand_normal

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_NV_texture_rectangle

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

This item has no description.

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

This item has no description.

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

This item has no description.

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_NV_texture_shader

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

This item has no description.

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

This item has no description.

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

This item has no description.

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

This item has no description.

GL_DSDT_MAG_INTENSITY_NV = $86DC;

This item has no description.

GL_SHADER_CONSISTENT_NV = $86DD;

This item has no description.

GL_TEXTURE_SHADER_NV = $86DE;

This item has no description.

GL_SHADER_OPERATION_NV = $86DF;

This item has no description.

GL_CULL_MODES_NV = $86E0;

This item has no description.

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

This item has no description.

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

This item has no description.

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

This item has no description.

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

This item has no description.

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

This item has no description.

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

This item has no description.

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

This item has no description.

GL_CONST_EYE_NV = $86E5;

This item has no description.

GL_PASS_THROUGH_NV = $86E6;

This item has no description.

GL_CULL_FRAGMENT_NV = $86E7;

This item has no description.

GL_OFFSET_TEXTURE_2D_NV = $86E8;

This item has no description.

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

This item has no description.

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

This item has no description.

GL_DOT_PRODUCT_NV = $86EC;

This item has no description.

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

This item has no description.

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

This item has no description.

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

This item has no description.

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

This item has no description.

GL_HILO_NV = $86F4;

This item has no description.

GL_DSDT_NV = $86F5;

This item has no description.

GL_DSDT_MAG_NV = $86F6;

This item has no description.

GL_DSDT_MAG_VIB_NV = $86F7;

This item has no description.

GL_HILO16_NV = $86F8;

This item has no description.

GL_SIGNED_HILO_NV = $86F9;

This item has no description.

GL_SIGNED_HILO16_NV = $86FA;

This item has no description.

GL_SIGNED_RGBA_NV = $86FB;

This item has no description.

GL_SIGNED_RGBA8_NV = $86FC;

This item has no description.

GL_SIGNED_RGB_NV = $86FE;

This item has no description.

GL_SIGNED_RGB8_NV = $86FF;

This item has no description.

GL_SIGNED_LUMINANCE_NV = $8701;

This item has no description.

GL_SIGNED_LUMINANCE8_NV = $8702;

This item has no description.

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

This item has no description.

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

This item has no description.

GL_SIGNED_ALPHA_NV = $8705;

This item has no description.

GL_SIGNED_ALPHA8_NV = $8706;

This item has no description.

GL_SIGNED_INTENSITY_NV = $8707;

This item has no description.

GL_SIGNED_INTENSITY8_NV = $8708;

This item has no description.

GL_DSDT8_NV = $8709;

This item has no description.

GL_DSDT8_MAG8_NV = $870A;

This item has no description.

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

This item has no description.

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

This item has no description.

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

This item has no description.

GL_HI_SCALE_NV = $870E;

This item has no description.

GL_LO_SCALE_NV = $870F;

This item has no description.

GL_DS_SCALE_NV = $8710;

This item has no description.

GL_DT_SCALE_NV = $8711;

This item has no description.

GL_MAGNITUDE_SCALE_NV = $8712;

This item has no description.

GL_VIBRANCE_SCALE_NV = $8713;

This item has no description.

GL_HI_BIAS_NV = $8714;

This item has no description.

GL_LO_BIAS_NV = $8715;

This item has no description.

GL_DS_BIAS_NV = $8716;

This item has no description.

GL_DT_BIAS_NV = $8717;

This item has no description.

GL_MAGNITUDE_BIAS_NV = $8718;

This item has no description.

GL_VIBRANCE_BIAS_NV = $8719;

This item has no description.

GL_TEXTURE_BORDER_VALUES_NV = $871A;

This item has no description.

GL_TEXTURE_HI_SIZE_NV = $871B;

This item has no description.

GL_TEXTURE_LO_SIZE_NV = $871C;

This item has no description.

GL_TEXTURE_DS_SIZE_NV = $871D;

This item has no description.

GL_TEXTURE_DT_SIZE_NV = $871E;

This item has no description.

GL_TEXTURE_MAG_SIZE_NV = $871F;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_NV_texture_shader2

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_NV_texture_shader3

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

This item has no description.

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

This item has no description.

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

This item has no description.

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

This item has no description.

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

This item has no description.

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

This item has no description.

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

This item has no description.

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

This item has no description.

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

This item has no description.

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

This item has no description.

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

This item has no description.

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

This item has no description.

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

This item has no description.

GL_HILO8_NV = $885E;

This item has no description.

GL_SIGNED_HILO8_NV = $885F;

This item has no description.

GL_FORCE_BLUE_TO_ONE_NV = $8860;

This item has no description.

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_NV_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

This item has no description.

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

This item has no description.

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

This item has no description.

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

This item has no description.

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_NV_vertex_array_range2

GL_VERTEX_PROGRAM_NV = $8620;

GL_NV_vertex_program

GL_VERTEX_STATE_PROGRAM_NV = $8621;

This item has no description.

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

This item has no description.

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

This item has no description.

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

This item has no description.

GL_CURRENT_ATTRIB_NV = $8626;

This item has no description.

GL_PROGRAM_LENGTH_NV = $8627;

This item has no description.

GL_PROGRAM_STRING_NV = $8628;

This item has no description.

GL_MODELVIEW_PROJECTION_NV = $8629;

This item has no description.

GL_IDENTITY_NV = $862A;

This item has no description.

GL_INVERSE_NV = $862B;

This item has no description.

GL_TRANSPOSE_NV = $862C;

This item has no description.

GL_INVERSE_TRANSPOSE_NV = $862D;

This item has no description.

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

This item has no description.

GL_MAX_TRACK_MATRICES_NV = $862F;

This item has no description.

GL_MATRIX0_NV = $8630;

This item has no description.

GL_MATRIX1_NV = $8631;

This item has no description.

GL_MATRIX2_NV = $8632;

This item has no description.

GL_MATRIX3_NV = $8633;

This item has no description.

GL_MATRIX4_NV = $8634;

This item has no description.

GL_MATRIX5_NV = $8635;

This item has no description.

GL_MATRIX6_NV = $8636;

This item has no description.

GL_MATRIX7_NV = $8637;

This item has no description.

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

This item has no description.

GL_CURRENT_MATRIX_NV = $8641;

This item has no description.

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

This item has no description.

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

This item has no description.

GL_PROGRAM_PARAMETER_NV = $8644;

This item has no description.

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

This item has no description.

GL_PROGRAM_TARGET_NV = $8646;

This item has no description.

GL_PROGRAM_RESIDENT_NV = $8647;

This item has no description.

GL_TRACK_MATRIX_NV = $8648;

This item has no description.

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

This item has no description.

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

This item has no description.

GL_PROGRAM_ERROR_POSITION_NV = $864B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

This item has no description.

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

This item has no description.

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

This item has no description.

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

This item has no description.

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

This item has no description.

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

This item has no description.

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

This item has no description.

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

This item has no description.

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

This item has no description.

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

This item has no description.

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

This item has no description.

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

This item has no description.

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

This item has no description.

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

This item has no description.

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

This item has no description.

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

This item has no description.

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

This item has no description.

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

This item has no description.

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

This item has no description.

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

This item has no description.

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

This item has no description.

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

This item has no description.

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

This item has no description.

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

This item has no description.

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

This item has no description.

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

This item has no description.

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

This item has no description.

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

This item has no description.

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

This item has no description.

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

This item has no description.

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

This item has no description.

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

This item has no description.

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

This item has no description.

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV = $88F4;

GL_NV_fragment_program2 and GL_NV_vertex_program2_option

GL_MAX_PROGRAM_CALL_DEPTH_NV = $88F5;

This item has no description.

GL_MAX_PROGRAM_IF_DEPTH_NV = $88F6;

GL_NV_fragment_program2

GL_MAX_PROGRAM_LOOP_DEPTH_NV = $88F7;

This item has no description.

GL_MAX_PROGRAM_LOOP_COUNT_NV = $88F8;

This item has no description.

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_NV_vertex_program3

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV = $8DAD;

GL_NV_depth_buffer_float

GL_DEPTH_BUFFER_FLOAT_MODE_NV = $8DAF;

This item has no description.

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV = $8CAB;

GL_NV_framebuffer_multisample_coverage

GL_RENDERBUFFER_COLOR_SAMPLES_NV = $8E10;

This item has no description.

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_NV_geometry_program4

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

This item has no description.

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

This item has no description.

GL_PROGRAM_ATTRIB_COMPONENTS_NV = $8906;

GL_NV_gpu_program4

GL_PROGRAM_RESULT_COMPONENTS_NV = $8907;

This item has no description.

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV = $8908;

This item has no description.

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV = $8909;

This item has no description.

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV = $8DA5;

This item has no description.

GL_MAX_PROGRAM_GENERIC_RESULTS_NV = $8DA6;

This item has no description.

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV = $8DA0;

GL_NV_parameter_buffer_object

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV = $8DA1;

This item has no description.

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV = $8DA2;

This item has no description.

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV = $8DA3;

This item has no description.

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV = $8DA4;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_NV_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

This item has no description.

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

This item has no description.

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

This item has no description.

GL_SEPARATE_ATTRIBS_NV = $8C8D;

This item has no description.

GL_PRIMITIVES_GENERATED_NV = $8C87;

This item has no description.

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

This item has no description.

GL_RASTERIZER_DISCARD_NV = $8C89;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

This item has no description.

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

This item has no description.

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

This item has no description.

GL_ACTIVE_VARYINGS_NV = $8C81;

This item has no description.

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

This item has no description.

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

This item has no description.

GL_BACK_PRIMARY_COLOR_NV = $8C77;

This item has no description.

GL_BACK_SECONDARY_COLOR_NV = $8C78;

This item has no description.

GL_TEXTURE_COORD_NV = $8C79;

This item has no description.

GL_CLIP_DISTANCE_NV = $8C7A;

This item has no description.

GL_VERTEX_ID_NV = $8C7B;

This item has no description.

GL_PRIMITIVE_ID_NV = $8C7C;

This item has no description.

GL_GENERIC_ATTRIB_NV = $8C7D;

This item has no description.

GL_LAYER_NV = $8DAA;

This item has no description.

GL_NEXT_BUFFER_NV = -2;

This item has no description.

GL_SKIP_COMPONENTS4_NV = -3;

This item has no description.

GL_SKIP_COMPONENTS3_NV = -4;

This item has no description.

GL_SKIP_COMPONENTS2_NV = -5;

This item has no description.

GL_SKIP_COMPONENTS1_NV = -6;

This item has no description.

GL_QUERY_WAIT_NV = $8E13;

GL_NV_conditional_render

GL_QUERY_NO_WAIT_NV = $8E14;

This item has no description.

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

This item has no description.

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

This item has no description.

GL_CONSERVATIVE_RASTERIZATION_NV = $9346;

GL_NV_conservative_raster

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV = $9347;

This item has no description.

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV = $9348;

This item has no description.

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV = $9349;

This item has no description.

GL_CONSERVATIVE_RASTER_DILATE_NV = $9379;

GL_NV_conservative_raster_dilate

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV = $937A;

This item has no description.

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV = $937B;

This item has no description.

GL_FRAME_NV = $8E26;

GL_NV_present_video

GL_FIELDS_NV = $8E27;

This item has no description.

GL_CURRENT_TIME_NV = $8E28;

This item has no description.

GL_NUM_FILL_STREAMS_NV = $8E29;

This item has no description.

GL_PRESENT_TIME_NV = $8E2A;

This item has no description.

GL_PRESENT_DURATION_NV = $8E2B;

This item has no description.

GL_SAMPLE_POSITION_NV = $8E50;

GL_NV_explicit_multisample

GL_SAMPLE_MASK_NV = $8E51;

This item has no description.

GL_SAMPLE_MASK_VALUE_NV = $8E52;

This item has no description.

GL_TEXTURE_BINDING_RENDERBUFFER_NV = $8E53;

This item has no description.

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV = $8E54;

This item has no description.

GL_TEXTURE_RENDERBUFFER_NV = $8E55;

This item has no description.

GL_SAMPLER_RENDERBUFFER_NV = $8E56;

This item has no description.

GL_INT_SAMPLER_RENDERBUFFER_NV = $8E57;

This item has no description.

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV = $8E58;

This item has no description.

GL_MAX_SAMPLE_MASK_WORDS_NV = $8E59;

This item has no description.

GL_TRANSFORM_FEEDBACK_NV = $8E22;

GL_NV_transform_feedback2

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV = $8E23;

This item has no description.

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV = $8E24;

This item has no description.

GL_TRANSFORM_FEEDBACK_BINDING_NV = $8E25;

This item has no description.

GL_VIDEO_BUFFER_NV = $9020;

GL_NV_video_capture

GL_VIDEO_BUFFER_BINDING_NV = $9021;

This item has no description.

GL_FIELD_UPPER_NV = $9022;

This item has no description.

GL_FIELD_LOWER_NV = $9023;

This item has no description.

GL_NUM_VIDEO_CAPTURE_STREAMS_NV = $9024;

This item has no description.

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV = $9025;

This item has no description.

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV = $9026;

This item has no description.

GL_LAST_VIDEO_CAPTURE_STATUS_NV = $9027;

This item has no description.

GL_VIDEO_BUFFER_PITCH_NV = $9028;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV = $9029;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MAX_NV = $902A;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_MIN_NV = $902B;

This item has no description.

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV = $902C;

This item has no description.

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV = $902D;

This item has no description.

GL_PARTIAL_SUCCESS_NV = $902E;

This item has no description.

GL_SUCCESS_NV = $902F;

This item has no description.

GL_FAILURE_NV = $9030;

This item has no description.

GL_YCBYCR8_422_NV = $9031;

This item has no description.

GL_YCBAYCR8A_4224_NV = $9032;

This item has no description.

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV = $9033;

This item has no description.

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV = $9034;

This item has no description.

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV = $9035;

This item has no description.

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV = $9036;

This item has no description.

GL_Z4Y12Z4CB12Z4CR12_444_NV = $9037;

This item has no description.

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV = $9038;

This item has no description.

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV = $9039;

This item has no description.

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV = $903A;

This item has no description.

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV = $903B;

This item has no description.

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV = $903C;

This item has no description.

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_NV_shader_buffer_load

GL_GPU_ADDRESS_NV = $8F34;

This item has no description.

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_NV_vertex_buffer_unified_memory

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

This item has no description.

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

This item has no description.

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

This item has no description.

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

This item has no description.

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

This item has no description.

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

This item has no description.

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

This item has no description.

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

This item has no description.

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

This item has no description.

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

This item has no description.

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

This item has no description.

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

This item has no description.

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

This item has no description.

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

This item has no description.

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

This item has no description.

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

This item has no description.

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

This item has no description.

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

This item has no description.

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

This item has no description.

GL_DRAW_INDIRECT_UNIFIED_NV = $8F40;

This item has no description.

GL_DRAW_INDIRECT_ADDRESS_NV = $8F41;

This item has no description.

GL_DRAW_INDIRECT_LENGTH_NV = $8F42;

This item has no description.

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV = $8E5A;

GL_NV_gpu_program5

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5B;

This item has no description.

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV = $8E5C;

This item has no description.

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV = $8E5D;

This item has no description.

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5E;

This item has no description.

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV = $8E5F;

This item has no description.

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV = $8F44;

This item has no description.

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV = $8F45;

This item has no description.

GL_INT64_NV = $140E;

GL_NV_gpu_shader5

GL_UNSIGNED_INT64_NV = $140F;

This item has no description.

GL_INT8_NV = $8FE0;

This item has no description.

GL_INT8_VEC2_NV = $8FE1;

This item has no description.

GL_INT8_VEC3_NV = $8FE2;

This item has no description.

GL_INT8_VEC4_NV = $8FE3;

This item has no description.

GL_INT16_NV = $8FE4;

This item has no description.

GL_INT16_VEC2_NV = $8FE5;

This item has no description.

GL_INT16_VEC3_NV = $8FE6;

This item has no description.

GL_INT16_VEC4_NV = $8FE7;

This item has no description.

GL_INT64_VEC2_NV = $8FE9;

This item has no description.

GL_INT64_VEC3_NV = $8FEA;

This item has no description.

GL_INT64_VEC4_NV = $8FEB;

This item has no description.

GL_UNSIGNED_INT8_NV = $8FEC;

This item has no description.

GL_UNSIGNED_INT8_VEC2_NV = $8FED;

This item has no description.

GL_UNSIGNED_INT8_VEC3_NV = $8FEE;

This item has no description.

GL_UNSIGNED_INT8_VEC4_NV = $8FEF;

This item has no description.

GL_UNSIGNED_INT16_NV = $8FF0;

This item has no description.

GL_UNSIGNED_INT16_VEC2_NV = $8FF1;

This item has no description.

GL_UNSIGNED_INT16_VEC3_NV = $8FF2;

This item has no description.

GL_UNSIGNED_INT16_VEC4_NV = $8FF3;

This item has no description.

GL_UNSIGNED_INT64_VEC2_NV = $8FF5;

This item has no description.

GL_UNSIGNED_INT64_VEC3_NV = $8FF6;

This item has no description.

GL_UNSIGNED_INT64_VEC4_NV = $8FF7;

This item has no description.

GL_FLOAT16_NV = $8FF8;

This item has no description.

GL_FLOAT16_VEC2_NV = $8FF9;

This item has no description.

GL_FLOAT16_VEC3_NV = $8FFA;

This item has no description.

GL_FLOAT16_VEC4_NV = $8FFB;

This item has no description.

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV = $00000010;

GL_NV_shader_buffer_store

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV = $86D8;

GL_NV_tessellation_program5

GL_TESS_CONTROL_PROGRAM_NV = $891E;

This item has no description.

GL_TESS_EVALUATION_PROGRAM_NV = $891F;

This item has no description.

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV = $8C74;

This item has no description.

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV = $8C75;

This item has no description.

GL_COVERAGE_SAMPLES_NV = $80A9;

GL_NV_multisample_coverage

GL_COLOR_SAMPLES_NV = $8E20;

This item has no description.

GL_SURFACE_STATE_NV = $86EB;

GL_NV_vdpau_interop

GL_SURFACE_REGISTERED_NV = $86FD;

This item has no description.

GL_SURFACE_MAPPED_NV = $8700;

This item has no description.

GL_WRITE_DISCARD_NV = $88BE;

This item has no description.

GL_INTERLACE_OML = $8980;

GL_OML_interlace

GL_INTERLACE_READ_OML = $8981;

This item has no description.

GL_PACK_RESAMPLE_OML = $8984;

GL_OML_resample

GL_UNPACK_RESAMPLE_OML = $8985;

This item has no description.

GL_RESAMPLE_REPLICATE_OML = $8986;

This item has no description.

GL_RESAMPLE_ZERO_FILL_OML = $8987;

This item has no description.

GL_RESAMPLE_AVERAGE_OML = $8988;

This item has no description.

GL_RESAMPLE_DECIMATE_OML = $8989;

This item has no description.

GL_FORMAT_SUBSAMPLE_24_24_OML = $8982;

GL_OML_subsample

GL_FORMAT_SUBSAMPLE_244_244_OML = $8983;

This item has no description.

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR = $9630;

GL_OVR_multiview

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR = $9632;

This item has no description.

GL_MAX_VIEWS_OVR = $9631;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR = $9633;

This item has no description.

GL_PREFER_DOUBLEBUFFER_HINT_PGI = $1A1F8;

GL_PGI_misc_hints

GL_CONSERVE_MEMORY_HINT_PGI = $1A1FD;

This item has no description.

GL_RECLAIM_MEMORY_HINT_PGI = $1A1FE;

This item has no description.

GL_NATIVE_GRAPHICS_HANDLE_PGI = $1A202;

This item has no description.

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI = $1A203;

This item has no description.

GL_NATIVE_GRAPHICS_END_HINT_PGI = $1A204;

This item has no description.

GL_ALWAYS_FAST_HINT_PGI = $1A20C;

This item has no description.

GL_ALWAYS_SOFT_HINT_PGI = $1A20D;

This item has no description.

GL_ALLOW_DRAW_OBJ_HINT_PGI = $1A20E;

This item has no description.

GL_ALLOW_DRAW_WIN_HINT_PGI = $1A20F;

This item has no description.

GL_ALLOW_DRAW_FRG_HINT_PGI = $1A210;

This item has no description.

GL_ALLOW_DRAW_MEM_HINT_PGI = $1A211;

This item has no description.

GL_STRICT_DEPTHFUNC_HINT_PGI = $1A216;

This item has no description.

GL_STRICT_LIGHTING_HINT_PGI = $1A217;

This item has no description.

GL_STRICT_SCISSOR_HINT_PGI = $1A218;

This item has no description.

GL_FULL_STIPPLE_HINT_PGI = $1A219;

This item has no description.

GL_CLIP_NEAR_HINT_PGI = $1A220;

This item has no description.

GL_CLIP_FAR_HINT_PGI = $1A221;

This item has no description.

GL_WIDE_LINE_HINT_PGI = $1A222;

This item has no description.

GL_BACK_NORMALS_HINT_PGI = $1A223;

This item has no description.

GL_VERTEX_DATA_HINT_PGI = $1A22A;

GL_PGI_vertex_hints

GL_VERTEX_CONSISTENT_HINT_PGI = $1A22B;

This item has no description.

GL_MATERIAL_SIDE_HINT_PGI = $1A22C;

This item has no description.

GL_MAX_VERTEX_HINT_PGI = $1A22D;

This item has no description.

GL_COLOR3_BIT_PGI = $00010000;

This item has no description.

GL_COLOR4_BIT_PGI = $00020000;

This item has no description.

GL_EDGEFLAG_BIT_PGI = $00040000;

This item has no description.

GL_INDEX_BIT_PGI = $00080000;

This item has no description.

GL_MAT_AMBIENT_BIT_PGI = $00100000;

This item has no description.

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI = $00200000;

This item has no description.

GL_MAT_DIFFUSE_BIT_PGI = $00400000;

This item has no description.

GL_MAT_EMISSION_BIT_PGI = $00800000;

This item has no description.

GL_MAT_COLOR_INDEXES_BIT_PGI = $01000000;

This item has no description.

GL_MAT_SHININESS_BIT_PGI = $02000000;

This item has no description.

GL_MAT_SPECULAR_BIT_PGI = $04000000;

This item has no description.

GL_NORMAL_BIT_PGI = $08000000;

This item has no description.

GL_TEXCOORD1_BIT_PGI = $10000000;

This item has no description.

GL_TEXCOORD2_BIT_PGI = $20000000;

This item has no description.

GL_TEXCOORD3_BIT_PGI = $40000000;

This item has no description.

GL_TEXCOORD4_BIT_PGI = $80000000;

This item has no description.

GL_VERTEX23_BIT_PGI = $00000004;

This item has no description.

GL_VERTEX4_BIT_PGI = $00000008;

This item has no description.

GL_SCREEN_COORDINATES_REND = $8490;

GL_REND_screen_coordinates

GL_INVERTED_SCREEN_W_REND = $8491;

This item has no description.

GL_RGB_S3TC = $83A0;

GL_S3_s3tc

GL_RGB4_S3TC = $83A1;

This item has no description.

GL_RGBA_S3TC = $83A2;

This item has no description.

GL_RGBA4_S3TC = $83A3;

This item has no description.

GL_DETAIL_TEXTURE_2D_SGIS = $8095;

GL_SGIS_detail_texture

GL_DETAIL_TEXTURE_2D_BINDING_SGIS = $8096;

This item has no description.

GL_LINEAR_DETAIL_SGIS = $8097;

This item has no description.

GL_LINEAR_DETAIL_ALPHA_SGIS = $8098;

This item has no description.

GL_LINEAR_DETAIL_COLOR_SGIS = $8099;

This item has no description.

GL_DETAIL_TEXTURE_LEVEL_SGIS = $809A;

This item has no description.

GL_DETAIL_TEXTURE_MODE_SGIS = $809B;

This item has no description.

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS = $809C;

This item has no description.

GL_FOG_FUNC_SGIS = $812A;

GL_SGIS_fog_function

GL_FOG_FUNC_POINTS_SGIS = $812B;

This item has no description.

GL_MAX_FOG_FUNC_POINTS_SGIS = $812C;

This item has no description.

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_SGIS_generate_mipmap

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

This item has no description.

GL_MULTISAMPLE_SGIS = $809D;

GL_SGIS_multisample

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

This item has no description.

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

This item has no description.

GL_SAMPLE_MASK_SGIS = $80A0;

This item has no description.

GL_1PASS_SGIS = $80A1;

This item has no description.

GL_2PASS_0_SGIS = $80A2;

This item has no description.

GL_2PASS_1_SGIS = $80A3;

This item has no description.

GL_4PASS_0_SGIS = $80A4;

This item has no description.

GL_4PASS_1_SGIS = $80A5;

This item has no description.

GL_4PASS_2_SGIS = $80A6;

This item has no description.

GL_4PASS_3_SGIS = $80A7;

This item has no description.

GL_SAMPLE_BUFFERS_SGIS = $80A8;

This item has no description.

GL_SAMPLES_SGIS = $80A9;

This item has no description.

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

This item has no description.

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

This item has no description.

GL_SAMPLE_PATTERN_SGIS = $80AC;

This item has no description.

GL_PIXEL_TEXTURE_SGIS = $8353;

GL_SGIS_pixel_texture

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS = $8354;

This item has no description.

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS = $8355;

This item has no description.

GL_PIXEL_GROUP_COLOR_SGIS = $8356;

This item has no description.

GL_EYE_DISTANCE_TO_POINT_SGIS = $81F0;

GL_SGIS_point_line_texgen

GL_OBJECT_DISTANCE_TO_POINT_SGIS = $81F1;

This item has no description.

GL_EYE_DISTANCE_TO_LINE_SGIS = $81F2;

This item has no description.

GL_OBJECT_DISTANCE_TO_LINE_SGIS = $81F3;

This item has no description.

GL_EYE_POINT_SGIS = $81F4;

This item has no description.

GL_OBJECT_POINT_SGIS = $81F5;

This item has no description.

GL_EYE_LINE_SGIS = $81F6;

This item has no description.

GL_OBJECT_LINE_SGIS = $81F7;

This item has no description.

GL_POINT_SIZE_MIN_SGIS = $8126;

GL_SGIS_point_parameters

GL_POINT_SIZE_MAX_SGIS = $8127;

This item has no description.

GL_POINT_FADE_THRESHOLD_SIZE_SGIS = $8128;

This item has no description.

GL_DISTANCE_ATTENUATION_SGIS = $8129;

This item has no description.

GL_LINEAR_SHARPEN_SGIS = $80AD;

GL_SGIS_sharpen_texture

GL_LINEAR_SHARPEN_ALPHA_SGIS = $80AE;

This item has no description.

GL_LINEAR_SHARPEN_COLOR_SGIS = $80AF;

This item has no description.

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS = $80B0;

This item has no description.

GL_PACK_SKIP_VOLUMES_SGIS = $8130;

GL_SGIS_texture4D

GL_PACK_IMAGE_DEPTH_SGIS = $8131;

This item has no description.

GL_UNPACK_SKIP_VOLUMES_SGIS = $8132;

This item has no description.

GL_UNPACK_IMAGE_DEPTH_SGIS = $8133;

This item has no description.

GL_TEXTURE_4D_SGIS = $8134;

This item has no description.

GL_PROXY_TEXTURE_4D_SGIS = $8135;

This item has no description.

GL_TEXTURE_4DSIZE_SGIS = $8136;

This item has no description.

GL_TEXTURE_WRAP_Q_SGIS = $8137;

This item has no description.

GL_MAX_4D_TEXTURE_SIZE_SGIS = $8138;

This item has no description.

GL_TEXTURE_4D_BINDING_SGIS = $814F;

This item has no description.

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_SGIS_texture_color_mask

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_SGIS_texture_edge_clamp

GL_FILTER4_SGIS = $8146;

GL_SGIS_texture_filter4

GL_TEXTURE_FILTER4_SIZE_SGIS = $8147;

This item has no description.

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_SGIS_texture_lod

GL_TEXTURE_MAX_LOD_SGIS = $813B;

This item has no description.

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

This item has no description.

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

This item has no description.

GL_DUAL_ALPHA4_SGIS = $8110;

GL_SGIS_texture_select

GL_DUAL_ALPHA8_SGIS = $8111;

This item has no description.

GL_DUAL_ALPHA12_SGIS = $8112;

This item has no description.

GL_DUAL_ALPHA16_SGIS = $8113;

This item has no description.

GL_DUAL_LUMINANCE4_SGIS = $8114;

This item has no description.

GL_DUAL_LUMINANCE8_SGIS = $8115;

This item has no description.

GL_DUAL_LUMINANCE12_SGIS = $8116;

This item has no description.

GL_DUAL_LUMINANCE16_SGIS = $8117;

This item has no description.

GL_DUAL_INTENSITY4_SGIS = $8118;

This item has no description.

GL_DUAL_INTENSITY8_SGIS = $8119;

This item has no description.

GL_DUAL_INTENSITY12_SGIS = $811A;

This item has no description.

GL_DUAL_INTENSITY16_SGIS = $811B;

This item has no description.

GL_DUAL_LUMINANCE_ALPHA4_SGIS = $811C;

This item has no description.

GL_DUAL_LUMINANCE_ALPHA8_SGIS = $811D;

This item has no description.

GL_QUAD_ALPHA4_SGIS = $811E;

This item has no description.

GL_QUAD_ALPHA8_SGIS = $811F;

This item has no description.

GL_QUAD_LUMINANCE4_SGIS = $8120;

This item has no description.

GL_QUAD_LUMINANCE8_SGIS = $8121;

This item has no description.

GL_QUAD_INTENSITY4_SGIS = $8122;

This item has no description.

GL_QUAD_INTENSITY8_SGIS = $8123;

This item has no description.

GL_DUAL_TEXTURE_SELECT_SGIS = $8124;

This item has no description.

GL_QUAD_TEXTURE_SELECT_SGIS = $8125;

This item has no description.

GL_ASYNC_MARKER_SGIX = $8329;

GL_SGIX_async

GL_ASYNC_HISTOGRAM_SGIX = $832C;

GL_SGIX_async_histogram

GL_MAX_ASYNC_HISTOGRAM_SGIX = $832D;

This item has no description.

GL_ASYNC_TEX_IMAGE_SGIX = $835C;

GL_SGIX_async_pixel

GL_ASYNC_DRAW_PIXELS_SGIX = $835D;

This item has no description.

GL_ASYNC_READ_PIXELS_SGIX = $835E;

This item has no description.

GL_MAX_ASYNC_TEX_IMAGE_SGIX = $835F;

This item has no description.

GL_MAX_ASYNC_DRAW_PIXELS_SGIX = $8360;

This item has no description.

GL_MAX_ASYNC_READ_PIXELS_SGIX = $8361;

This item has no description.

GL_ALPHA_MIN_SGIX = $8320;

GL_SGIX_blend_alpha_minmax

GL_ALPHA_MAX_SGIX = $8321;

This item has no description.

GL_CALLIGRAPHIC_FRAGMENT_SGIX = $8183;

GL_SGIX_calligraphic_fragment

GL_LINEAR_CLIPMAP_LINEAR_SGIX = $8170;

GL_SGIX_clipmap

GL_TEXTURE_CLIPMAP_CENTER_SGIX = $8171;

This item has no description.

GL_TEXTURE_CLIPMAP_FRAME_SGIX = $8172;

This item has no description.

GL_TEXTURE_CLIPMAP_OFFSET_SGIX = $8173;

This item has no description.

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8174;

This item has no description.

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX = $8175;

This item has no description.

GL_TEXTURE_CLIPMAP_DEPTH_SGIX = $8176;

This item has no description.

GL_MAX_CLIPMAP_DEPTH_SGIX = $8177;

This item has no description.

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX = $8178;

This item has no description.

GL_NEAREST_CLIPMAP_NEAREST_SGIX = $844D;

This item has no description.

GL_NEAREST_CLIPMAP_LINEAR_SGIX = $844E;

This item has no description.

GL_LINEAR_CLIPMAP_NEAREST_SGIX = $844F;

This item has no description.

GL_CONVOLUTION_HINT_SGIX = $8316;

GL_SGIX_convolution_accuracy

GL_DEPTH_COMPONENT16_SGIX = $81A5;

GL_SGIX_depth_texture

GL_DEPTH_COMPONENT24_SGIX = $81A6;

This item has no description.

GL_DEPTH_COMPONENT32_SGIX = $81A7;

This item has no description.

GL_FOG_OFFSET_SGIX = $8198;

GL_SGIX_fog_offset

GL_FOG_OFFSET_VALUE_SGIX = $8199;

This item has no description.

GL_FOG_SCALE_SGIX = $81FC;

GL_SGIX_fog_scale

GL_FOG_SCALE_VALUE_SGIX = $81FD;

This item has no description.

GL_FRAGMENT_LIGHTING_SGIX = $8400;

GL_SGIX_fragment_lighting

GL_FRAGMENT_COLOR_MATERIAL_SGIX = $8401;

This item has no description.

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX = $8402;

This item has no description.

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX = $8403;

This item has no description.

GL_MAX_FRAGMENT_LIGHTS_SGIX = $8404;

This item has no description.

GL_MAX_ACTIVE_LIGHTS_SGIX = $8405;

This item has no description.

GL_CURRENT_RASTER_NORMAL_SGIX = $8406;

This item has no description.

GL_LIGHT_ENV_MODE_SGIX = $8407;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX = $8408;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX = $8409;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX = $840A;

This item has no description.

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX = $840B;

This item has no description.

GL_FRAGMENT_LIGHT0_SGIX = $840C;

This item has no description.

GL_FRAGMENT_LIGHT1_SGIX = $840D;

This item has no description.

GL_FRAGMENT_LIGHT2_SGIX = $840E;

This item has no description.

GL_FRAGMENT_LIGHT3_SGIX = $840F;

This item has no description.

GL_FRAGMENT_LIGHT4_SGIX = $8410;

This item has no description.

GL_FRAGMENT_LIGHT5_SGIX = $8411;

This item has no description.

GL_FRAGMENT_LIGHT6_SGIX = $8412;

This item has no description.

GL_FRAGMENT_LIGHT7_SGIX = $8413;

This item has no description.

GL_FRAMEZOOM_SGIX = $818B;

GL_SGIX_framezoom

GL_FRAMEZOOM_FACTOR_SGIX = $818C;

This item has no description.

GL_MAX_FRAMEZOOM_FACTOR_SGIX = $818D;

This item has no description.

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX = $8184;

GL_SGIX_impact_pixel_texture

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX = $8185;

This item has no description.

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX = $8186;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX = $8187;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX = $8188;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX = $8189;

This item has no description.

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX = $818A;

This item has no description.

GL_INSTRUMENT_BUFFER_POINTER_SGIX = $8180;

GL_SGIX_instruments

GL_INSTRUMENT_MEASUREMENTS_SGIX = $8181;

This item has no description.

GL_INTERLACE_SGIX = $8094;

GL_SGIX_interlace

GL_IR_INSTRUMENT1_SGIX = $817F;

GL_SGIX_ir_instrument1

GL_LIST_PRIORITY_SGIX = $8182;

GL_SGIX_list_priority

GL_PIXEL_TEX_GEN_SGIX = $8139;

GL_SGIX_pixel_texture

GL_PIXEL_TEX_GEN_MODE_SGIX = $832B;

This item has no description.

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX = $813E;

GL_SGIX_pixel_tiles

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX = $813F;

This item has no description.

GL_PIXEL_TILE_WIDTH_SGIX = $8140;

This item has no description.

GL_PIXEL_TILE_HEIGHT_SGIX = $8141;

This item has no description.

GL_PIXEL_TILE_GRID_WIDTH_SGIX = $8142;

This item has no description.

GL_PIXEL_TILE_GRID_HEIGHT_SGIX = $8143;

This item has no description.

GL_PIXEL_TILE_GRID_DEPTH_SGIX = $8144;

This item has no description.

GL_PIXEL_TILE_CACHE_SIZE_SGIX = $8145;

This item has no description.

GL_GEOMETRY_DEFORMATION_SGIX = $8194;

GL_SGIX_polynomial_ffd

GL_TEXTURE_DEFORMATION_SGIX = $8195;

This item has no description.

GL_DEFORMATIONS_MASK_SGIX = $8196;

This item has no description.

GL_MAX_DEFORMATION_ORDER_SGIX = $8197;

This item has no description.

GL_REFERENCE_PLANE_SGIX = $817D;

GL_SGIX_reference_plane

GL_REFERENCE_PLANE_EQUATION_SGIX = $817E;

This item has no description.

GL_PACK_RESAMPLE_SGIX = $842C;

GL_SGIX_resample

GL_UNPACK_RESAMPLE_SGIX = $842D;

This item has no description.

GL_RESAMPLE_REPLICATE_SGIX = $842E;

This item has no description.

GL_RESAMPLE_ZERO_FILL_SGIX = $842F;

This item has no description.

GL_RESAMPLE_DECIMATE_SGIX = $8430;

This item has no description.

GL_SCALEBIAS_HINT_SGIX = $8322;

GL_SGIX_scalebias_hint

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_SGIX_shadow

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

This item has no description.

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

This item has no description.

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

This item has no description.

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_SGIX_shadow_ambient

GL_SPRITE_SGIX = $8148;

GL_SGIX_sprite

GL_SPRITE_MODE_SGIX = $8149;

This item has no description.

GL_SPRITE_AXIS_SGIX = $814A;

This item has no description.

GL_SPRITE_TRANSLATION_SGIX = $814B;

This item has no description.

GL_SPRITE_AXIAL_SGIX = $814C;

This item has no description.

GL_SPRITE_OBJECT_ALIGNED_SGIX = $814D;

This item has no description.

GL_SPRITE_EYE_ALIGNED_SGIX = $814E;

This item has no description.

GL_PACK_SUBSAMPLE_RATE_SGIX = $85A0;

GL_SGIX_subsample

GL_UNPACK_SUBSAMPLE_RATE_SGIX = $85A1;

This item has no description.

GL_PIXEL_SUBSAMPLE_4444_SGIX = $85A2;

This item has no description.

GL_PIXEL_SUBSAMPLE_2424_SGIX = $85A3;

This item has no description.

GL_PIXEL_SUBSAMPLE_4242_SGIX = $85A4;

This item has no description.

GL_TEXTURE_ENV_BIAS_SGIX = $80BE;

GL_SGIX_texture_add_env

GL_TEXTURE_MAX_CLAMP_S_SGIX = $8369;

GL_SGIX_texture_coordinate_clamp

GL_TEXTURE_MAX_CLAMP_T_SGIX = $836A;

This item has no description.

GL_TEXTURE_MAX_CLAMP_R_SGIX = $836B;

This item has no description.

GL_TEXTURE_LOD_BIAS_S_SGIX = $818E;

GL_SGIX_texture_lod_bias

GL_TEXTURE_LOD_BIAS_T_SGIX = $818F;

This item has no description.

GL_TEXTURE_LOD_BIAS_R_SGIX = $8190;

This item has no description.

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX = $812E;

GL_SGIX_texture_multi_buffer

GL_POST_TEXTURE_FILTER_BIAS_SGIX = $8179;

GL_SGIX_texture_scale_bias

GL_POST_TEXTURE_FILTER_SCALE_SGIX = $817A;

This item has no description.

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX = $817B;

This item has no description.

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX = $817C;

This item has no description.

GL_VERTEX_PRECLIP_SGIX = $83EE;

GL_SGIX_vertex_preclip

GL_VERTEX_PRECLIP_HINT_SGIX = $83EF;

This item has no description.

GL_YCRCB_422_SGIX = $81BB;

GL_SGIX_ycrcb

GL_YCRCB_444_SGIX = $81BC;

This item has no description.

GL_YCRCB_SGIX = $8318;

GL_SGIX_ycrcba

GL_YCRCBA_SGIX = $8319;

This item has no description.

GL_COLOR_MATRIX_SGI = $80B1;

GL_SGI_color_matrix

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

This item has no description.

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

This item has no description.

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

This item has no description.

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

This item has no description.

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

This item has no description.

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

This item has no description.

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

This item has no description.

GL_COLOR_TABLE_SGI = $80D0;

GL_SGI_color_table

GL_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D1;

This item has no description.

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D2;

This item has no description.

GL_PROXY_COLOR_TABLE_SGI = $80D3;

This item has no description.

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI = $80D4;

This item has no description.

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI = $80D5;

This item has no description.

GL_COLOR_TABLE_SCALE_SGI = $80D6;

This item has no description.

GL_COLOR_TABLE_BIAS_SGI = $80D7;

This item has no description.

GL_COLOR_TABLE_FORMAT_SGI = $80D8;

This item has no description.

GL_COLOR_TABLE_WIDTH_SGI = $80D9;

This item has no description.

GL_COLOR_TABLE_RED_SIZE_SGI = $80DA;

This item has no description.

GL_COLOR_TABLE_GREEN_SIZE_SGI = $80DB;

This item has no description.

GL_COLOR_TABLE_BLUE_SIZE_SGI = $80DC;

This item has no description.

GL_COLOR_TABLE_ALPHA_SIZE_SGI = $80DD;

This item has no description.

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI = $80DE;

This item has no description.

GL_COLOR_TABLE_INTENSITY_SIZE_SGI = $80DF;

This item has no description.

GL_DEPTH_PASS_INSTRUMENT_SGIX = $8310;

GL_SGI_depth_pass_instrument

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX = $8311;

This item has no description.

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX = $8312;

This item has no description.

GL_TEXTURE_COLOR_TABLE_SGI = $80BC;

GL_SGI_texture_color_table

GL_PROXY_TEXTURE_COLOR_TABLE_SGI = $80BD;

This item has no description.

GL_UNPACK_CONSTANT_DATA_SUNX = $81D5;

GL_SUNX_constant_data

GL_TEXTURE_CONSTANT_DATA_SUNX = $81D6;

This item has no description.

GL_WRAP_BORDER_SUN = $81D4;

GL_SUN_convolution_border_modes

GL_GLOBAL_ALPHA_SUN = $81D9;

GL_SUN_global_alpha

GL_GLOBAL_ALPHA_FACTOR_SUN = $81DA;

This item has no description.

GL_QUAD_MESH_SUN = $8614;

GL_SUN_mesh_array

GL_TRIANGLE_MESH_SUN = $8615;

This item has no description.

GL_SLICE_ACCUM_SUN = $85CC;

GL_SUN_slice_accum

GL_RESTART_SUN = $0001;

GL_SUN_triangle_list

GL_REPLACE_MIDDLE_SUN = $0002;

This item has no description.

GL_REPLACE_OLDEST_SUN = $0003;

This item has no description.

GL_TRIANGLE_LIST_SUN = $81D7;

This item has no description.

GL_REPLACEMENT_CODE_SUN = $81D8;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_SUN = $85C0;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN = $85C1;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN = $85C2;

This item has no description.

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN = $85C3;

This item has no description.

GL_R1UI_V3F_SUN = $85C4;

This item has no description.

GL_R1UI_C4UB_V3F_SUN = $85C5;

This item has no description.

GL_R1UI_C3F_V3F_SUN = $85C6;

This item has no description.

GL_R1UI_N3F_V3F_SUN = $85C7;

This item has no description.

GL_R1UI_C4F_N3F_V3F_SUN = $85C8;

This item has no description.

GL_R1UI_T2F_V3F_SUN = $85C9;

This item has no description.

GL_R1UI_T2F_N3F_V3F_SUN = $85CA;

This item has no description.

GL_R1UI_T2F_C4F_N3F_V3F_SUN = $85CB;

This item has no description.

GL_PHONG_WIN = $80EA;

GL_WIN_phong_shading

GL_PHONG_HINT_WIN = $80EB;

This item has no description.

GL_FOG_SPECULAR_TEXTURE_WIN = $80EC;

GL_WIN_specular_fog

GL_VERTEX_SHADER_ARB = $8B31;

GL_ARB_vertex_shader

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

This item has no description.

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

This item has no description.

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

This item has no description.

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

This item has no description.

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

This item has no description.

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

This item has no description.

GL_MULTIPLY_KHR = $9294;

GL_KHR_blend_equation_advanced

GL_SCREEN_KHR = $9295;

This item has no description.

GL_OVERLAY_KHR = $9296;

This item has no description.

GL_DARKEN_KHR = $9297;

This item has no description.

GL_LIGHTEN_KHR = $9298;

This item has no description.

GL_COLORDODGE_KHR = $9299;

This item has no description.

GL_COLORBURN_KHR = $929A;

This item has no description.

GL_HARDLIGHT_KHR = $929B;

This item has no description.

GL_SOFTLIGHT_KHR = $929C;

This item has no description.

GL_DIFFERENCE_KHR = $929E;

This item has no description.

GL_EXCLUSION_KHR = $92A0;

This item has no description.

GL_HSL_HUE_KHR = $92AD;

This item has no description.

GL_HSL_SATURATION_KHR = $92AE;

This item has no description.

GL_HSL_COLOR_KHR = $92AF;

This item has no description.

GL_HSL_LUMINOSITY_KHR = $92B0;

This item has no description.

GL_BLEND_ADVANCED_COHERENT_KHR = $9285;

GL_KHR_blend_equation_advanced_coherent

GL_CONTEXT_ROBUST_ACCESS = $90F3;

GL_KHR_robustness

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR = $00000008;

GL_KHR_no_error

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_ARB_fragment_shader

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

This item has no description.

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

1.4

GL_SAMPLES_PASSED_ARB = $8914;

1.4 GL_ARB_occlusion_query

GL_QUERY_COUNTER_BITS_ARB = $8864;

This item has no description.

GL_CURRENT_QUERY_ARB = $8865;

This item has no description.

GL_QUERY_RESULT_ARB = $8866;

This item has no description.

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

This item has no description.

GL_VERTICES_SUBMITTED_ARB = $82EE;

GL_ARB_pipeline_statistics_query

GL_PRIMITIVES_SUBMITTED_ARB = $82EF;

This item has no description.

GL_VERTEX_SHADER_INVOCATIONS_ARB = $82F0;

This item has no description.

GL_TESS_CONTROL_SHADER_PATCHES_ARB = $82F1;

This item has no description.

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB = $82F2;

This item has no description.

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB = $82F3;

This item has no description.

GL_FRAGMENT_SHADER_INVOCATIONS_ARB = $82F4;

This item has no description.

GL_COMPUTE_SHADER_INVOCATIONS_ARB = $82F5;

This item has no description.

GL_CLIPPING_INPUT_PRIMITIVES_ARB = $82F6;

This item has no description.

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB = $82F7;

This item has no description.

GL_POINT_SPRITE_ARB = $8861;

GL_ARB_point_sprite

GL_COORD_REPLACE_ARB = $8862;

This item has no description.

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_ARB_shading_language_100

GL_PROGRAM_OBJECT_ARB = $8B40;

1.4 GL_ARB_shader_objects

GL_OBJECT_TYPE_ARB = $8B4E;

This item has no description.

GL_OBJECT_SUBTYPE_ARB = $8B4F;

This item has no description.

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

This item has no description.

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

This item has no description.

GL_OBJECT_LINK_STATUS_ARB = $8B82;

This item has no description.

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

This item has no description.

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

This item has no description.

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

This item has no description.

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

This item has no description.

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

This item has no description.

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

This item has no description.

GL_SHADER_OBJECT_ARB = $8B48;

This item has no description.

GL_FLOAT_VEC2_ARB = $8B50;

This item has no description.

GL_FLOAT_VEC3_ARB = $8B51;

This item has no description.

GL_FLOAT_VEC4_ARB = $8B52;

This item has no description.

GL_INT_VEC2_ARB = $8B53;

This item has no description.

GL_INT_VEC3_ARB = $8B54;

This item has no description.

GL_INT_VEC4_ARB = $8B55;

This item has no description.

GL_BOOL_ARB = $8B56;

This item has no description.

GL_BOOL_VEC2_ARB = $8B57;

This item has no description.

GL_BOOL_VEC3_ARB = $8B58;

This item has no description.

GL_BOOL_VEC4_ARB = $8B59;

This item has no description.

GL_FLOAT_MAT2_ARB = $8B5A;

This item has no description.

GL_FLOAT_MAT3_ARB = $8B5B;

This item has no description.

GL_FLOAT_MAT4_ARB = $8B5C;

This item has no description.

GL_SAMPLER_1D_ARB = $8B5D;

This item has no description.

GL_SAMPLER_2D_ARB = $8B5E;

This item has no description.

GL_SAMPLER_3D_ARB = $8B5F;

This item has no description.

GL_SAMPLER_CUBE_ARB = $8B60;

This item has no description.

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

This item has no description.

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

This item has no description.

GL_SAMPLER_2D_RECT_ARB = $8B63;

This item has no description.

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

This item has no description.

WGL_SAMPLE_BUFFERS_3DFX = $2060;

WGL_3DFX_multisample

WGL_SAMPLES_3DFX = $2061;

This item has no description.

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_ARB_buffer_region

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

This item has no description.

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

This item has no description.

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

This item has no description.

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

WGL_ARB_context_flush_control

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

This item has no description.

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

This item has no description.

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

WGL_ARB_make_current_read

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

This item has no description.

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_ARB_multisample

WGL_SAMPLES_ARB = $2042;

This item has no description.

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_ARB_pbuffer

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

This item has no description.

WGL_PBUFFER_LARGEST_ARB = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_ARB = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_ARB = $2035;

This item has no description.

WGL_PBUFFER_LOST_ARB = $2036;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_ARB_pixel_format

WGL_DRAW_TO_WINDOW_ARB = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_ARB = $2002;

This item has no description.

WGL_ACCELERATION_ARB = $2003;

This item has no description.

WGL_NEED_PALETTE_ARB = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

This item has no description.

WGL_SWAP_METHOD_ARB = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_ARB = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_ARB = $2009;

This item has no description.

WGL_TRANSPARENT_ARB = $200A;

This item has no description.

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

This item has no description.

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

This item has no description.

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

This item has no description.

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

This item has no description.

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

This item has no description.

WGL_SHARE_DEPTH_ARB = $200C;

This item has no description.

WGL_SHARE_STENCIL_ARB = $200D;

This item has no description.

WGL_SHARE_ACCUM_ARB = $200E;

This item has no description.

WGL_SUPPORT_GDI_ARB = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_ARB = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_ARB = $2011;

This item has no description.

WGL_STEREO_ARB = $2012;

This item has no description.

WGL_PIXEL_TYPE_ARB = $2013;

This item has no description.

WGL_COLOR_BITS_ARB = $2014;

This item has no description.

WGL_RED_BITS_ARB = $2015;

This item has no description.

WGL_RED_SHIFT_ARB = $2016;

This item has no description.

WGL_GREEN_BITS_ARB = $2017;

This item has no description.

WGL_GREEN_SHIFT_ARB = $2018;

This item has no description.

WGL_BLUE_BITS_ARB = $2019;

This item has no description.

WGL_BLUE_SHIFT_ARB = $201A;

This item has no description.

WGL_ALPHA_BITS_ARB = $201B;

This item has no description.

WGL_ALPHA_SHIFT_ARB = $201C;

This item has no description.

WGL_ACCUM_BITS_ARB = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_ARB = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_ARB = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_ARB = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

This item has no description.

WGL_DEPTH_BITS_ARB = $2022;

This item has no description.

WGL_STENCIL_BITS_ARB = $2023;

This item has no description.

WGL_AUX_BUFFERS_ARB = $2024;

This item has no description.

WGL_NO_ACCELERATION_ARB = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_ARB = $2026;

This item has no description.

WGL_FULL_ACCELERATION_ARB = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_ARB = $2028;

This item has no description.

WGL_SWAP_COPY_ARB = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_ARB = $202A;

This item has no description.

WGL_TYPE_RGBA_ARB = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_ARB = $202C;

This item has no description.

WGL_RGBA_FLOAT_MODE_ARB = $8820;

WGL_ARB_pixel_format_float

WGL_CLAMP_VERTEX_COLOR_ARB = $891A;

This item has no description.

WGL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

This item has no description.

WGL_CLAMP_READ_COLOR_ARB = $891C;

This item has no description.

WGL_FIXED_ONLY_ARB = $891D;

This item has no description.

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

This item has no description.

WGL_TEXTURE_FORMAT_ARB = $2072;

This item has no description.

WGL_TEXTURE_TARGET_ARB = $2073;

This item has no description.

WGL_MIPMAP_TEXTURE_ARB = $2074;

This item has no description.

WGL_TEXTURE_RGB_ARB = $2075;

This item has no description.

WGL_TEXTURE_RGBA_ARB = $2076;

This item has no description.

WGL_NO_TEXTURE_ARB = $2077;

This item has no description.

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

This item has no description.

WGL_TEXTURE_1D_ARB = $2079;

This item has no description.

WGL_TEXTURE_2D_ARB = $207A;

This item has no description.

WGL_MIPMAP_LEVEL_ARB = $207B;

This item has no description.

WGL_CUBE_MAP_FACE_ARB = $207C;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

This item has no description.

WGL_FRONT_LEFT_ARB = $2083;

This item has no description.

WGL_FRONT_RIGHT_ARB = $2084;

This item has no description.

WGL_BACK_LEFT_ARB = $2085;

This item has no description.

WGL_BACK_RIGHT_ARB = $2086;

This item has no description.

WGL_AUX0_ARB = $2087;

This item has no description.

WGL_AUX1_ARB = $2088;

This item has no description.

WGL_AUX2_ARB = $2089;

This item has no description.

WGL_AUX3_ARB = $208A;

This item has no description.

WGL_AUX4_ARB = $208B;

This item has no description.

WGL_AUX5_ARB = $208C;

This item has no description.

WGL_AUX6_ARB = $208D;

This item has no description.

WGL_AUX7_ARB = $208E;

This item has no description.

WGL_AUX8_ARB = $208F;

This item has no description.

WGL_AUX9_ARB = $2090;

This item has no description.

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

WGL_ARB_robustness_application_isolation

WGL_CONTEXT_DEBUG_BIT_ARB = $00000001;

WGL_ARB_create_context

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

This item has no description.

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

This item has no description.

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

This item has no description.

WGL_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

ERROR_INVALID_VERSION_ARB = $2095;

This item has no description.

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_ARB_create_context_profile

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

This item has no description.

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

ERROR_INVALID_PROFILE_ARB = $2096;

This item has no description.

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

WGL_ARB_framebuffer_sRGB

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

WGL_ARB_create_context_robustness

WGL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

WGL_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

WGL_ATI_pixel_format_float

GL_TYPE_RGBA_FLOAT_ATI = $8820;

This item has no description.

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

This item has no description.

WGL_GPU_VENDOR_AMD = $1F00;

WGL_AMD_gpu_association

WGL_GPU_RENDERER_STRING_AMD = $1F01;

This item has no description.

WGL_GPU_OPENGL_VERSION_STRING_AMD = $1F02;

This item has no description.

WGL_GPU_FASTEST_TARGET_GPUS_AMD = $21A2;

This item has no description.

WGL_GPU_RAM_AMD = $21A3;

This item has no description.

WGL_GPU_CLOCK_AMD = $21A4;

This item has no description.

WGL_GPU_NUM_PIPES_AMD = $21A5;

This item has no description.

WGL_GPU_NUM_SIMD_AMD = $21A6;

This item has no description.

WGL_GPU_NUM_RB_AMD = $21A7;

This item has no description.

WGL_GPU_NUM_SPI_AMD = $21A8;

This item has no description.

WGL_DEPTH_FLOAT_EXT = $2040;

WGL_EXT_depth_float

ERROR_INVALID_PIXEL_TYPE_EXT = $2043;

WGL_EXT_make_current_read

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_EXT_multisample

WGL_SAMPLES_EXT = $2042;

This item has no description.

WGL_DRAW_TO_PBUFFER_EXT = $202D;

WGL_EXT_pbuffer

WGL_MAX_PBUFFER_PIXELS_EXT = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_EXT = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_EXT = $2030;

This item has no description.

WGL_OPTIMAL_PBUFFER_WIDTH_EXT = $2031;

This item has no description.

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT = $2032;

This item has no description.

WGL_PBUFFER_LARGEST_EXT = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_EXT = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_EXT = $2035;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_EXT = $2000;

WGL_EXT_pixel_format

WGL_DRAW_TO_WINDOW_EXT = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_EXT = $2002;

This item has no description.

WGL_ACCELERATION_EXT = $2003;

This item has no description.

WGL_NEED_PALETTE_EXT = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_EXT = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_EXT = $2006;

This item has no description.

WGL_SWAP_METHOD_EXT = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_EXT = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_EXT = $2009;

This item has no description.

WGL_TRANSPARENT_EXT = $200A;

This item has no description.

WGL_TRANSPARENT_VALUE_EXT = $200B;

This item has no description.

WGL_SHARE_DEPTH_EXT = $200C;

This item has no description.

WGL_SHARE_STENCIL_EXT = $200D;

This item has no description.

WGL_SHARE_ACCUM_EXT = $200E;

This item has no description.

WGL_SUPPORT_GDI_EXT = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_EXT = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_EXT = $2011;

This item has no description.

WGL_STEREO_EXT = $2012;

This item has no description.

WGL_PIXEL_TYPE_EXT = $2013;

This item has no description.

WGL_COLOR_BITS_EXT = $2014;

This item has no description.

WGL_RED_BITS_EXT = $2015;

This item has no description.

WGL_RED_SHIFT_EXT = $2016;

This item has no description.

WGL_GREEN_BITS_EXT = $2017;

This item has no description.

WGL_GREEN_SHIFT_EXT = $2018;

This item has no description.

WGL_BLUE_BITS_EXT = $2019;

This item has no description.

WGL_BLUE_SHIFT_EXT = $201A;

This item has no description.

WGL_ALPHA_BITS_EXT = $201B;

This item has no description.

WGL_ALPHA_SHIFT_EXT = $201C;

This item has no description.

WGL_ACCUM_BITS_EXT = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_EXT = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_EXT = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_EXT = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_EXT = $2021;

This item has no description.

WGL_DEPTH_BITS_EXT = $2022;

This item has no description.

WGL_STENCIL_BITS_EXT = $2023;

This item has no description.

WGL_AUX_BUFFERS_EXT = $2024;

This item has no description.

WGL_NO_ACCELERATION_EXT = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_EXT = $2026;

This item has no description.

WGL_FULL_ACCELERATION_EXT = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_EXT = $2028;

This item has no description.

WGL_SWAP_COPY_EXT = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_EXT = $202A;

This item has no description.

WGL_TYPE_RGBA_EXT = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_EXT = $202C;

This item has no description.

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D = $2050;

WGL_I3D_digital_video_control

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D = $2051;

This item has no description.

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D = $2052;

This item has no description.

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D = $2053;

This item has no description.

WGL_GAMMA_TABLE_SIZE_I3D = $204E;

WGL_I3D_gamma

WGL_GAMMA_EXCLUDE_DESKTOP_I3D = $204F;

This item has no description.

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D = $2044;

WGL_I3D_genlock

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D = $2045;

This item has no description.

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D = $2046;

This item has no description.

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D = $2047;

This item has no description.

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D = $2048;

This item has no description.

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D = $2049;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D = $204A;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D = $204B;

This item has no description.

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D = $204C;

This item has no description.

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D = $00000001;

WGL_I3D_image_buffer

WGL_IMAGE_BUFFER_LOCK_I3D = $00000002;

This item has no description.

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_NV_float_buffer

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

This item has no description.

WGL_TEXTURE_FLOAT_R_NV = $20B5;

This item has no description.

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

This item has no description.

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

This item has no description.

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

This item has no description.

WGL_BIND_TO_TEXTURE_DEPTH_NV = $20A3;

WGL_NV_render_depth_texture

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV = $20A4;

This item has no description.

WGL_DEPTH_TEXTURE_FORMAT_NV = $20A5;

This item has no description.

WGL_TEXTURE_DEPTH_COMPONENT_NV = $20A6;

This item has no description.

WGL_DEPTH_COMPONENT_NV = $20A7;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV = $20A0;

WGL_NV_render_texture_rectangle

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV = $20A1;

This item has no description.

WGL_TEXTURE_RECTANGLE_NV = $20A2;

This item has no description.

WGL_NUM_VIDEO_SLOTS_NV = $20F0;

WGL_NV_present_video

WGL_BIND_TO_VIDEO_RGB_NV = $20C0;

WGL_NV_video_output

WGL_BIND_TO_VIDEO_RGBA_NV = $20C1;

This item has no description.

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV = $20C2;

This item has no description.

WGL_VIDEO_OUT_COLOR_NV = $20C3;

This item has no description.

WGL_VIDEO_OUT_ALPHA_NV = $20C4;

This item has no description.

WGL_VIDEO_OUT_DEPTH_NV = $20C5;

This item has no description.

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

This item has no description.

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

This item has no description.

WGL_VIDEO_OUT_FRAME = $20C8;

This item has no description.

WGL_VIDEO_OUT_FIELD_1 = $20C9;

This item has no description.

WGL_VIDEO_OUT_FIELD_2 = $20CA;

This item has no description.

WGL_VIDEO_OUT_STACKED_FIELDS_1_2 = $20CB;

This item has no description.

WGL_VIDEO_OUT_STACKED_FIELDS_2_1 = $20CC;

This item has no description.

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV = $20D0;

WGL_NV_gpu_affinity

WGL_ERROR_MISSING_AFFINITY_MASK_NV = $20D1;

This item has no description.

WGL_UNIQUE_ID_NV = $20CE;

WGL_NV_video_capture

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

This item has no description.

WGL_COVERAGE_SAMPLES_NV = $2042;

WGL_NV_multisample_coverage

WGL_COLOR_SAMPLES_NV = $20B9;

This item has no description.

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

WGL_EXT_create_context_es2_profile

WGL_ACCESS_READ_ONLY_NV = $00000000;

WGL_NV_DX_interop

WGL_ACCESS_READ_WRITE_NV = $00000001;

This item has no description.

WGL_ACCESS_WRITE_DISCARD_NV = $00000002;

This item has no description.

GL_MAX_ELEMENTS_VERTICES_WIN = $80E8;

WIN_draw_range_elements

GL_MAX_ELEMENTS_INDICES_WIN = $80E9;

This item has no description.

GLX_VENDOR = 1;

GLX 1.1 and later:

GLX_VERSION = 2;

This item has no description.

GLX_EXTENSIONS = 3;

This item has no description.

GLX_USE_GL = 1;

This item has no description.

GLX_BUFFER_SIZE = 2;

This item has no description.

GLX_LEVEL = 3;

This item has no description.

GLX_RGBA = 4;

This item has no description.

GLX_DOUBLEBUFFER = 5;

This item has no description.

GLX_STEREO = 6;

This item has no description.

GLX_AUX_BUFFERS = 7;

This item has no description.

GLX_RED_SIZE = 8;

This item has no description.

GLX_GREEN_SIZE = 9;

This item has no description.

GLX_BLUE_SIZE = 10;

This item has no description.

GLX_ALPHA_SIZE = 11;

This item has no description.

GLX_DEPTH_SIZE = 12;

This item has no description.

GLX_STENCIL_SIZE = 13;

This item has no description.

GLX_ACCUM_RED_SIZE = 14;

This item has no description.

GLX_ACCUM_GREEN_SIZE = 15;

This item has no description.

GLX_ACCUM_BLUE_SIZE = 16;

This item has no description.

GLX_ACCUM_ALPHA_SIZE = 17;

This item has no description.

GLX_WINDOW_BIT = $00000001;

GLX_VERSION_1_3

GLX_PIXMAP_BIT = $00000002;

This item has no description.

GLX_PBUFFER_BIT = $00000004;

This item has no description.

GLX_RGBA_BIT = $00000001;

This item has no description.

GLX_COLOR_INDEX_BIT = $00000002;

This item has no description.

GLX_PBUFFER_CLOBBER_MASK = $08000000;

This item has no description.

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

This item has no description.

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

This item has no description.

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

This item has no description.

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

This item has no description.

GLX_AUX_BUFFERS_BIT = $00000010;

This item has no description.

GLX_DEPTH_BUFFER_BIT = $00000020;

This item has no description.

GLX_STENCIL_BUFFER_BIT = $00000040;

This item has no description.

GLX_ACCUM_BUFFER_BIT = $00000080;

This item has no description.

GLX_CONFIG_CAVEAT = $20;

This item has no description.

GLX_X_VISUAL_TYPE = $22;

This item has no description.

GLX_TRANSPARENT_TYPE = $23;

This item has no description.

GLX_TRANSPARENT_INDEX_VALUE = $24;

This item has no description.

GLX_TRANSPARENT_RED_VALUE = $25;

This item has no description.

GLX_TRANSPARENT_GREEN_VALUE = $26;

This item has no description.

GLX_TRANSPARENT_BLUE_VALUE = $27;

This item has no description.

GLX_TRANSPARENT_ALPHA_VALUE = $28;

This item has no description.

GLX_DONT_CARE = $FFFFFFFF;

This item has no description.

GLX_NONE = $8000;

This item has no description.

GLX_SLOW_CONFIG = $8001;

This item has no description.

GLX_TRUE_COLOR = $8002;

This item has no description.

GLX_DIRECT_COLOR = $8003;

This item has no description.

GLX_PSEUDO_COLOR = $8004;

This item has no description.

GLX_STATIC_COLOR = $8005;

This item has no description.

GLX_GRAY_SCALE = $8006;

This item has no description.

GLX_STATIC_GRAY = $8007;

This item has no description.

GLX_TRANSPARENT_RGB = $8008;

This item has no description.

GLX_TRANSPARENT_INDEX = $8009;

This item has no description.

GLX_VISUAL_ID = $800B;

This item has no description.

GLX_SCREEN = $800C;

This item has no description.

GLX_NON_CONFORMANT_CONFIG = $800D;

This item has no description.

GLX_DRAWABLE_TYPE = $8010;

This item has no description.

GLX_RENDER_TYPE = $8011;

This item has no description.

GLX_X_RENDERABLE = $8012;

This item has no description.

GLX_FBCONFIG_ID = $8013;

This item has no description.

GLX_RGBA_TYPE = $8014;

This item has no description.

GLX_COLOR_INDEX_TYPE = $8015;

This item has no description.

GLX_MAX_PBUFFER_WIDTH = $8016;

This item has no description.

GLX_MAX_PBUFFER_HEIGHT = $8017;

This item has no description.

GLX_MAX_PBUFFER_PIXELS = $8018;

This item has no description.

GLX_PRESERVED_CONTENTS = $801B;

This item has no description.

GLX_LARGEST_PBUFFER = $801C;

This item has no description.

GLX_WIDTH = $801D;

This item has no description.

GLX_HEIGHT = $801E;

This item has no description.

GLX_EVENT_MASK = $801F;

This item has no description.

GLX_DAMAGED = $8020;

This item has no description.

GLX_SAVED = $8021;

This item has no description.

GLX_WINDOW = $8022;

This item has no description.

GLX_PBUFFER = $8023;

This item has no description.

GLX_PBUFFER_HEIGHT = $8040;

This item has no description.

GLX_PBUFFER_WIDTH = $8041;

This item has no description.

GLX_SAMPLE_BUFFERS = 100000;

GLX_VERSION_1_4

GLX_SAMPLES = 100001;

This item has no description.

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_ARB_multisample

GLX_SAMPLES_ARB = 100001;

This item has no description.

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB = $00000008;

GLX_ARB_robustness_application_isolation

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_ARB_fbconfig_float

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

This item has no description.

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB = $2097;

GLX_ARB_context_flush_control

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB = 0;

This item has no description.

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB = $2098;

This item has no description.

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_ARB_create_context

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

This item has no description.

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

This item has no description.

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

GLX_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_ARB_create_context_profile

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

This item has no description.

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB = $2095;

GLX_ARB_vertex_buffer_object

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

GLX_ARB_framebuffer_sRGB

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB = $00000004;

GLX_ARB_create_context_robustness

GLX_LOSE_CONTEXT_ON_RESET_ARB = $8252;

This item has no description.

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

This item has no description.

GLX_NO_RESET_NOTIFICATION_ARB = $8261;

This item has no description.

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_EXT_visual_info

GLX_TRANSPARENT_TYPE_EXT = $23;

This item has no description.

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

This item has no description.

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

This item has no description.

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

This item has no description.

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

This item has no description.

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

This item has no description.

GLX_NONE_EXT = $8000;

This item has no description.

GLX_TRUE_COLOR_EXT = $8002;

This item has no description.

GLX_DIRECT_COLOR_EXT = $8003;

This item has no description.

GLX_PSEUDO_COLOR_EXT = $8004;

This item has no description.

GLX_STATIC_COLOR_EXT = $8005;

This item has no description.

GLX_GRAY_SCALE_EXT = $8006;

This item has no description.

GLX_STATIC_GRAY_EXT = $8007;

This item has no description.

GLX_TRANSPARENT_RGB_EXT = $8008;

This item has no description.

GLX_TRANSPARENT_INDEX_EXT = $8009;

This item has no description.

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_EXT_visual_rating

GLX_SLOW_VISUAL_EXT = $8001;

This item has no description.

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

This item has no description.

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_EXT_import_context

GLX_VISUAL_ID_EXT = $800B;

This item has no description.

GLX_SCREEN_EXT = $800C;

This item has no description.

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap

GLX_TEXTURE_2D_BIT_EXT = $00000002;

This item has no description.

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

This item has no description.

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

This item has no description.

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

This item has no description.

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

This item has no description.

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

This item has no description.

GLX_Y_INVERTED_EXT = $20D4;

This item has no description.

GLX_TEXTURE_FORMAT_EXT = $20D5;

This item has no description.

GLX_TEXTURE_TARGET_EXT = $20D6;

This item has no description.

GLX_MIPMAP_TEXTURE_EXT = $20D7;

This item has no description.

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

This item has no description.

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

This item has no description.

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

This item has no description.

GLX_TEXTURE_1D_EXT = $20DB;

This item has no description.

GLX_TEXTURE_2D_EXT = $20DC;

This item has no description.

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

This item has no description.

GLX_FRONT_LEFT_EXT = $20DE;

This item has no description.

GLX_FRONT_RIGHT_EXT = $20DF;

This item has no description.

GLX_BACK_LEFT_EXT = $20E0;

This item has no description.

GLX_BACK_RIGHT_EXT = $20E1;

This item has no description.

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

This item has no description.

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

This item has no description.

GLX_AUX0_EXT = $20E2;

This item has no description.

GLX_AUX1_EXT = $20E3;

This item has no description.

GLX_AUX2_EXT = $20E4;

This item has no description.

GLX_AUX3_EXT = $20E5;

This item has no description.

GLX_AUX4_EXT = $20E6;

This item has no description.

GLX_AUX5_EXT = $20E7;

This item has no description.

GLX_AUX6_EXT = $20E8;

This item has no description.

GLX_AUX7_EXT = $20E9;

This item has no description.

GLX_AUX8_EXT = $20EA;

This item has no description.

GLX_AUX9_EXT = $20EB;

This item has no description.

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_EXT_swap_control

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

This item has no description.

GLX_CONTEXT_ES2_PROFILE_BIT_EXT = $00000004;

GLX_EXT_create_context_es2_profile

GLX_LATE_SWAPS_TEAR_EXT = $20F3;

GL_EXT_Late_Swaps

GLU_INVALID_ENUM = 100900;

GLU

GLU_INVALID_VALUE = 100901;

This item has no description.

GLU_OUT_OF_MEMORY = 100902;

This item has no description.

GLU_INCOMPATIBLE_GL_VERSION = 100903;

This item has no description.

GLU_VERSION = 100800;

This item has no description.

GLU_EXTENSIONS = 100801;

This item has no description.

GLU_TRUE = GL_TRUE;

This item has no description.

GLU_FALSE = GL_FALSE;

This item has no description.

GLU_SMOOTH = 100000;

This item has no description.

GLU_FLAT = 100001;

This item has no description.

GLU_NONE = 100002;

This item has no description.

GLU_POINT = 100010;

This item has no description.

GLU_LINE = 100011;

This item has no description.

GLU_FILL = 100012;

This item has no description.

GLU_SILHOUETTE = 100013;

This item has no description.

GLU_OUTSIDE = 100020;

This item has no description.

GLU_INSIDE = 100021;

This item has no description.

GLU_TESS_MAX_COORD = 1.0E150;

This item has no description.

GLU_TESS_WINDING_RULE = 100140;

This item has no description.

GLU_TESS_BOUNDARY_ONLY = 100141;

This item has no description.

GLU_TESS_TOLERANCE = 100142;

This item has no description.

GLU_TESS_WINDING_ODD = 100130;

This item has no description.

GLU_TESS_WINDING_NONZERO = 100131;

This item has no description.

GLU_TESS_WINDING_POSITIVE = 100132;

This item has no description.

GLU_TESS_WINDING_NEGATIVE = 100133;

This item has no description.

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

This item has no description.

GLU_TESS_BEGIN = 100100;

This item has no description.

GLU_TESS_VERTEX = 100101;

This item has no description.

GLU_TESS_END = 100102;

This item has no description.

GLU_TESS_ERROR = 100103;

This item has no description.

GLU_TESS_EDGE_FLAG = 100104;

This item has no description.

GLU_TESS_COMBINE = 100105;

This item has no description.

GLU_TESS_BEGIN_DATA = 100106;

This item has no description.

GLU_TESS_VERTEX_DATA = 100107;

This item has no description.

GLU_TESS_END_DATA = 100108;

This item has no description.

GLU_TESS_ERROR_DATA = 100109;

This item has no description.

GLU_TESS_EDGE_FLAG_DATA = 100110;

This item has no description.

GLU_TESS_COMBINE_DATA = 100111;

This item has no description.

GLU_TESS_ERROR1 = 100151;

This item has no description.

GLU_TESS_ERROR2 = 100152;

This item has no description.

GLU_TESS_ERROR3 = 100153;

This item has no description.

GLU_TESS_ERROR4 = 100154;

This item has no description.

GLU_TESS_ERROR5 = 100155;

This item has no description.

GLU_TESS_ERROR6 = 100156;

This item has no description.

GLU_TESS_ERROR7 = 100157;

This item has no description.

GLU_TESS_ERROR8 = 100158;

This item has no description.

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

This item has no description.

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

This item has no description.

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

This item has no description.

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

This item has no description.

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

This item has no description.

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

This item has no description.

GLU_AUTO_LOAD_MATRIX = 100200;

This item has no description.

GLU_CULLING = 100201;

This item has no description.

GLU_SAMPLING_TOLERANCE = 100203;

This item has no description.

GLU_DISPLAY_MODE = 100204;

This item has no description.

GLU_PARAMETRIC_TOLERANCE = 100202;

This item has no description.

GLU_SAMPLING_METHOD = 100205;

This item has no description.

GLU_U_STEP = 100206;

This item has no description.

GLU_V_STEP = 100207;

This item has no description.

GLU_PATH_LENGTH = 100215;

This item has no description.

GLU_PARAMETRIC_ERROR = 100216;

This item has no description.

GLU_DOMAIN_DISTANCE = 100217;

This item has no description.

GLU_MAP1_TRIM_2 = 100210;

This item has no description.

GLU_MAP1_TRIM_3 = 100211;

This item has no description.

GLU_OUTLINE_POLYGON = 100240;

This item has no description.

GLU_OUTLINE_PATCH = 100241;

This item has no description.

GLU_NURBS_ERROR1 = 100251;

This item has no description.

GLU_NURBS_ERROR2 = 100252;

This item has no description.

GLU_NURBS_ERROR3 = 100253;

This item has no description.

GLU_NURBS_ERROR4 = 100254;

This item has no description.

GLU_NURBS_ERROR5 = 100255;

This item has no description.

GLU_NURBS_ERROR6 = 100256;

This item has no description.

GLU_NURBS_ERROR7 = 100257;

This item has no description.

GLU_NURBS_ERROR8 = 100258;

This item has no description.

GLU_NURBS_ERROR9 = 100259;

This item has no description.

GLU_NURBS_ERROR10 = 100260;

This item has no description.

GLU_NURBS_ERROR11 = 100261;

This item has no description.

GLU_NURBS_ERROR12 = 100262;

This item has no description.

GLU_NURBS_ERROR13 = 100263;

This item has no description.

GLU_NURBS_ERROR14 = 100264;

This item has no description.

GLU_NURBS_ERROR15 = 100265;

This item has no description.

GLU_NURBS_ERROR16 = 100266;

This item has no description.

GLU_NURBS_ERROR17 = 100267;

This item has no description.

GLU_NURBS_ERROR18 = 100268;

This item has no description.

GLU_NURBS_ERROR19 = 100269;

This item has no description.

GLU_NURBS_ERROR20 = 100270;

This item has no description.

GLU_NURBS_ERROR21 = 100271;

This item has no description.

GLU_NURBS_ERROR22 = 100272;

This item has no description.

GLU_NURBS_ERROR23 = 100273;

This item has no description.

GLU_NURBS_ERROR24 = 100274;

This item has no description.

GLU_NURBS_ERROR25 = 100275;

This item has no description.

GLU_NURBS_ERROR26 = 100276;

This item has no description.

GLU_NURBS_ERROR27 = 100277;

This item has no description.

GLU_NURBS_ERROR28 = 100278;

This item has no description.

GLU_NURBS_ERROR29 = 100279;

This item has no description.

GLU_NURBS_ERROR30 = 100280;

This item has no description.

GLU_NURBS_ERROR31 = 100281;

This item has no description.

GLU_NURBS_ERROR32 = 100282;

This item has no description.

GLU_NURBS_ERROR33 = 100283;

This item has no description.

GLU_NURBS_ERROR34 = 100284;

This item has no description.

GLU_NURBS_ERROR35 = 100285;

This item has no description.

GLU_NURBS_ERROR36 = 100286;

This item has no description.

GLU_NURBS_ERROR37 = 100287;

This item has no description.

GLU_CW = 100120;

This item has no description.

GLU_CCW = 100121;

This item has no description.

GLU_INTERIOR = 100122;

This item has no description.

GLU_EXTERIOR = 100123;

This item has no description.

GLU_UNKNOWN = 100124;

This item has no description.

GLU_BEGIN = GLU_TESS_BEGIN;

This item has no description.

GLU_VERTEX = GLU_TESS_VERTEX;

This item has no description.

GLU_END = GLU_TESS_END;

This item has no description.

GLU_ERROR = GLU_TESS_ERROR;

This item has no description.

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

This item has no description.

Variables

GL_VERSION_4_0: Boolean;

This item has no description.

GL_VERSION_4_1: Boolean;

This item has no description.

GL_VERSION_4_2: Boolean;

This item has no description.

GL_VERSION_4_3: Boolean;

This item has no description.

GL_VERSION_4_4: Boolean;

This item has no description.

GL_VERSION_4_5: Boolean;

This item has no description.

GL_VERSION_4_6: Boolean;

This item has no description.

GLU_VERSION_1_3: Boolean;

This item has no description.

GL_3DFX_multisample: Boolean;

This item has no description.

GL_3DFX_tbuffer: Boolean;

This item has no description.

GL_3DFX_texture_compression_FXT1: Boolean;

This item has no description.

GL_APPLE_client_storage: Boolean;

This item has no description.

GL_APPLE_element_array: Boolean;

This item has no description.

GL_APPLE_fence: Boolean;

This item has no description.

GL_APPLE_specular_vector: Boolean;

This item has no description.

GL_APPLE_transform_hint: Boolean;

This item has no description.

GL_APPLE_vertex_array_object: Boolean;

This item has no description.

GL_APPLE_vertex_array_range: Boolean;

This item has no description.

GL_APPLE_ycbcr_422: Boolean;

This item has no description.

GL_APPLE_texture_range: Boolean;

This item has no description.

GL_APPLE_float_pixels: Boolean;

This item has no description.

GL_APPLE_vertex_program_evaluators: Boolean;

This item has no description.

GL_APPLE_aux_depth_stencil: Boolean;

This item has no description.

GL_APPLE_object_purgeable: Boolean;

This item has no description.

GL_APPLE_row_bytes: Boolean;

This item has no description.

GL_APPLE_rgb_422: Boolean;

This item has no description.

GL_ARB_depth_texture: Boolean;

This item has no description.

GL_ARB_fragment_program: Boolean;

This item has no description.

GL_ARB_imaging: Boolean;

This item has no description.

GL_ARB_matrix_palette: Boolean;

This item has no description.

GL_ARB_multisample: Boolean;

This item has no description.

GL_ARB_multitexture: Boolean;

This item has no description.

GL_ARB_point_parameters: Boolean;

This item has no description.

GL_ARB_shadow: Boolean;

This item has no description.

GL_ARB_shadow_ambient: Boolean;

This item has no description.

GL_ARB_texture_border_clamp: Boolean;

This item has no description.

GL_ARB_texture_compression: Boolean;

This item has no description.

GL_ARB_texture_cube_map: Boolean;

This item has no description.

GL_ARB_texture_env_add: Boolean;

This item has no description.

GL_ARB_texture_env_combine: Boolean;

This item has no description.

GL_ARB_texture_env_crossbar: Boolean;

This item has no description.

GL_ARB_texture_env_dot3: Boolean;

This item has no description.

GL_ARB_texture_filter_minmax: Boolean;

This item has no description.

GL_ARB_texture_mirrored_repeat: Boolean;

This item has no description.

GL_ARB_transpose_matrix: Boolean;

This item has no description.

GL_ARB_vertex_blend: Boolean;

This item has no description.

GL_ARB_vertex_buffer_object: Boolean;

This item has no description.

GL_ARB_vertex_program: Boolean;

This item has no description.

GL_ARB_window_pos: Boolean;

This item has no description.

GL_ARB_shader_objects: Boolean;

This item has no description.

GL_ARB_vertex_shader: Boolean;

This item has no description.

GL_ARB_fragment_shader: Boolean;

This item has no description.

GL_ARB_fragment_shader_interlock: Boolean;

This item has no description.

GL_ARB_shading_language_100: Boolean;

This item has no description.

GL_ARB_occlusion_query: Boolean;

This item has no description.

GL_ARB_texture_non_power_of_two: Boolean;

This item has no description.

GL_ARB_point_sprite: Boolean;

This item has no description.

GL_ARB_fragment_program_shadow: Boolean;

This item has no description.

GL_ARB_draw_buffers: Boolean;

This item has no description.

GL_ARB_texture_rectangle: Boolean;

This item has no description.

GL_ARB_color_buffer_float: Boolean;

This item has no description.

GL_ARB_half_float_pixel: Boolean;

This item has no description.

GL_ARB_texture_float: Boolean;

This item has no description.

GL_ARB_pixel_buffer_object: Boolean;

This item has no description.

GL_ARB_depth_buffer_float: Boolean;

This item has no description.

GL_ARB_draw_instanced: Boolean;

This item has no description.

GL_ARB_framebuffer_object: Boolean;

This item has no description.

GL_ARB_framebuffer_sRGB: Boolean;

This item has no description.

GL_ARB_geometry_shader4: Boolean;

This item has no description.

GL_ARB_half_float_vertex: Boolean;

This item has no description.

GL_ARB_instanced_arrays: Boolean;

This item has no description.

GL_ARB_map_buffer_range: Boolean;

This item has no description.

GL_ARB_texture_buffer_object: Boolean;

This item has no description.

GL_ARB_texture_compression_rgtc: Boolean;

This item has no description.

GL_ARB_texture_rg: Boolean;

This item has no description.

GL_ARB_vertex_array_object: Boolean;

This item has no description.

GL_ARB_uniform_buffer_object: Boolean;

This item has no description.

GL_ARB_compatibility: Boolean;

This item has no description.

GL_ARB_copy_buffer: Boolean;

This item has no description.

GL_ARB_shader_texture_lod: Boolean;

This item has no description.

GL_ARB_shader_viewport_layer_array: Boolean;

This item has no description.

GL_ARB_depth_clamp: Boolean;

This item has no description.

GL_ARB_draw_elements_base_vertex: Boolean;

This item has no description.

GL_ARB_fragment_coord_conventions: Boolean;

This item has no description.

GL_ARB_provoking_vertex: Boolean;

This item has no description.

GL_ARB_seamless_cube_map: Boolean;

This item has no description.

GL_ARB_sync: Boolean;

This item has no description.

GL_ARB_texture_multisample: Boolean;

This item has no description.

GL_ARB_vertex_array_bgra: Boolean;

This item has no description.

GL_ARB_draw_buffers_blend: Boolean;

This item has no description.

GL_ARB_sample_shading: Boolean;

This item has no description.

GL_ARB_sample_locations: Boolean;

This item has no description.

GL_ARB_sparse_texture2: Boolean;

This item has no description.

GL_ARB_sparse_texture_clamp: Boolean;

This item has no description.

GL_ARB_texture_cube_map_array: Boolean;

This item has no description.

GL_ARB_texture_gather: Boolean;

This item has no description.

GL_ARB_texture_query_lod: Boolean;

This item has no description.

GL_ARB_shading_language_include: Boolean;

This item has no description.

GL_ARB_texture_compression_bptc: Boolean;

This item has no description.

GL_ARB_blend_func_extended: Boolean;

This item has no description.

GL_ARB_explicit_attrib_location: Boolean;

This item has no description.

GL_ARB_occlusion_query2: Boolean;

This item has no description.

GL_ARB_parallel_shader_compile: Boolean;

This item has no description.

GL_ARB_post_depth_coverage: Boolean;

This item has no description.

GL_ARB_sampler_objects: Boolean;

This item has no description.

GL_ARB_shader_bit_encoding: Boolean;

This item has no description.

GL_ARB_shader_clock: Boolean;

This item has no description.

GL_ARB_texture_rgb10_a2ui: Boolean;

This item has no description.

GL_ARB_texture_swizzle: Boolean;

This item has no description.

GL_ARB_timer_query: Boolean;

This item has no description.

GL_ARB_vertex_type_2_10_10_10_rev: Boolean;

This item has no description.

GL_ARB_draw_indirect: Boolean;

This item has no description.

GL_ARB_gpu_shader5: Boolean;

This item has no description.

GL_ARB_gpu_shader_fp64: Boolean;

This item has no description.

GL_ARB_gpu_shader_int64: Boolean;

This item has no description.

GL_ARB_shader_subroutine: Boolean;

This item has no description.

GL_ARB_tessellation_shader: Boolean;

This item has no description.

GL_ARB_texture_buffer_object_rgb32: Boolean;

This item has no description.

GL_ARB_transform_feedback2: Boolean;

This item has no description.

GL_ARB_transform_feedback3: Boolean;

This item has no description.

GL_ARB_ES2_compatibility: Boolean;

This item has no description.

GL_ARB_ES3_2_compatibility: Boolean;

This item has no description.

GL_ARB_get_program_binary: Boolean;

This item has no description.

GL_ARB_separate_shader_objects: Boolean;

This item has no description.

GL_ARB_shader_precision: Boolean;

This item has no description.

GL_ARB_shader_ballot: Boolean;

This item has no description.

GL_ARB_vertex_attrib_64bit: Boolean;

This item has no description.

GL_ARB_viewport_array: Boolean;

This item has no description.

GL_ARB_base_instance: Boolean;

GL 4.2

GL_ARB_shading_language_420pack: Boolean;

GL 4.2

GL_ARB_transform_feedback_instanced: Boolean;

GL 4.2

GL_ARB_compressed_texture_pixel_storage: Boolean;

GL 4.2

GL_ARB_conservative_depth: Boolean;

GL 4.2

GL_ARB_internalformat_query: Boolean;

GL 4.2

GL_ARB_map_buffer_alignment: Boolean;

GL 4.2

GL_ARB_shader_atomic_counters: Boolean;

GL 4.2

GL_ARB_shader_image_load_store: Boolean;

GL 4.2

GL_ARB_shading_language_packing: Boolean;

GL 4.2

GL_ARB_texture_storage: Boolean;

GL 4.2

GL_ARB_arrays_of_arrays: Boolean;

GL 4.3

GL_ARB_fragment_layer_viewport: Boolean;

GL 4.3

GL_ARB_shader_image_size: Boolean;

GL 4.3

GL_ARB_ES3_compatibility: Boolean;

GL 4.3

GL_ARB_clear_buffer_object: Boolean;

GL 4.3

GL_ARB_compute_shader: Boolean;

GL 4.3

GL_ARB_copy_image: Boolean;

GL 4.3

GL_KHR_debug: Boolean;

GL 4.3

GL_ARB_explicit_uniform_location: Boolean;

GL 4.3

GL_ARB_framebuffer_no_attachments: Boolean;

GL 4.3

GL_ARB_internalformat_query2: Boolean;

GL 4.3

GL_ARB_invalidate_subdata: Boolean;

GL 4.3

GL_ARB_multi_draw_indirect: Boolean;

GL 4.3

GL_ARB_program_interface_query: Boolean;

GL 4.3

GL_ARB_robust_buffer_access_behavior: Boolean;

GL 4.3

GL_ARB_shader_storage_buffer_object: Boolean;

GL 4.3

GL_ARB_stencil_texturing: Boolean;

GL 4.3

GL_ARB_texture_buffer_range: Boolean;

GL 4.3

GL_ARB_texture_query_levels: Boolean;

GL 4.3

GL_ARB_texture_storage_multisample: Boolean;

GL 4.3

GL_ARB_texture_view: Boolean;

GL 4.3

GL_ARB_vertex_attrib_binding: Boolean;

GL 4.3

GL_NV_path_rendering: Boolean;

GL 4.3

GL_AMD_pinned_memory: Boolean;

GL 4.3

GL_AMD_stencil_operation_extended: Boolean;

GL 4.3

GL_AMD_vertex_shader_viewport_index: Boolean;

GL 4.3

GL_AMD_vertex_shader_layer: Boolean;

GL 4.3

GL_NV_bindless_texture: Boolean;

GL 4.3

GL_NV_shader_atomic_float: Boolean;

GL 4.3

GL_AMD_query_buffer_object: Boolean;

GL 4.3

GL_ARB_buffer_storage: Boolean;

GL 4.4

GL_ARB_clear_texture: Boolean;

GL 4.4

GL_ARB_enhanced_layouts: Boolean;

GL 4.4

GL_ARB_multi_bind: Boolean;

GL 4.4

GL_ARB_query_buffer_object: Boolean;

GL 4.4

GL_ARB_texture_mirror_clamp_to_edge: Boolean;

GL 4.4

GL_ARB_texture_stencil8: Boolean;

GL 4.4

GL_ARB_vertex_type_10f_11f_11f_rev: Boolean;

GL 4.4

GL_ARB_bindless_texture: Boolean;

GL 4.4

GL_ARB_sparse_texture: Boolean;

GL 4.4

GL_ARB_clip_control: Boolean;

GL 4.5

GL_ARB_cull_distance: Boolean;

GL 4.5

GL_ARB_ES3_1_compatibility: Boolean;

GL 4.5

GL_ARB_conditional_render_inverted: Boolean;

GL 4.5

GL_KHR_context_flush_control: Boolean;

GL 4.5

GL_ARB_derivative_control: Boolean;

GL 4.5

GL_ARB_direct_state_access: Boolean;

GL 4.5

GL_ARB_get_texture_sub_image: Boolean;

GL 4.5

GL_KHR_robustness: Boolean;

GL 4.5

GL_KHR_blend_equation_advanced: Boolean;

GL 4.5

GL_KHR_blend_equation_advanced_coherent: Boolean;

GL 4.5

GL_KHR_robust_buffer_access_behavior: Boolean;

GL 4.5

GL_ARB_shader_texture_image_samples: Boolean;

GL 4.5

GL_ARB_texture_barrier: Boolean;

GL 4.5

GL_ARB_indirect_parameters: Boolean;

GL 4.6

GL_ARB_pipeline_statistics_query: Boolean;

GL 4.6

GL_ARB_polygon_offset_clamp: Boolean;

GL 4.6

GL_KHR_no_error: Boolean;

GL 4.6

GL_ARB_shader_atomic_counter_ops: Boolean;

GL 4.6

GL_ARB_shader_draw_parameters: Boolean;

GL 4.6

GL_ARB_shader_group_vote: Boolean;

GL 4.6

GL_ARB_gl_spirv: Boolean;

GL 4.6

GL_ARB_spirv_extensions: Boolean;

GL 4.6

GL_ARB_texture_filter_anisotropic: Boolean;

GL 4.6

GL_ARB_transform_feedback_overflow_query: Boolean;

GL 4.6

GL_ARB_cl_event: Boolean;

GL 4.6

GL_ARB_compute_variable_group_size: Boolean;

GL 4.6

GL_ARB_debug_output: Boolean;

GL 4.6

GL_ARB_robustness: Boolean;

GL 4.6

GL_ARB_shader_stencil_export: Boolean;

GL 4.6

GL_ATI_draw_buffers: Boolean;

GL 4.6

GL_ATI_element_array: Boolean;

GL 4.6

GL_ATI_envmap_bumpmap: Boolean;

GL 4.6

GL_ATI_fragment_shader: Boolean;

GL 4.6

GL_ATI_map_object_buffer: Boolean;

GL 4.6

GL_ATI_pn_triangles: Boolean;

GL 4.6

GL_ATI_separate_stencil: Boolean;

GL 4.6

GL_ATI_text_fragment_shader: Boolean;

GL 4.6

GL_ATI_texture_env_combine3: Boolean;

GL 4.6

GL_ATI_texture_float: Boolean;

GL 4.6

GL_ATI_texture_mirror_once: Boolean;

GL 4.6

GL_ATI_vertex_array_object: Boolean;

GL 4.6

GL_ATI_vertex_attrib_array_object: Boolean;

GL 4.6

GL_ATI_vertex_streams: Boolean;

GL 4.6

GL_ATI_meminfo: Boolean;

GL 4.6

GL_AMD_performance_monitor: Boolean;

GL 4.6

GL_AMD_texture_texture4: Boolean;

GL 4.6

GL_AMD_vertex_shader_tesselator: Boolean;

GL 4.6

GL_AMD_draw_buffers_blend: Boolean;

GL 4.6

GL_AMD_shader_stencil_export: Boolean;

GL 4.6

GL_AMD_seamless_cubemap_per_texture: Boolean;

GL 4.6

GL_AMD_conservative_depth: Boolean;

GL 4.6

GL_AMD_name_gen_delete: Boolean;

GL 4.6

GL_AMD_debug_output: Boolean;

GL 4.6

GL_AMD_transform_feedback3_lines_triangles: Boolean;

GL 4.6

GL_AMD_depth_clamp_separate: Boolean;

GL 4.6

GL_EXT_422_pixels: Boolean;

GL 4.6

GL_EXT_abgr: Boolean;

GL 4.6

GL_EXT_bgra: Boolean;

GL 4.6

GL_EXT_blend_color: Boolean;

GL 4.6

GL_EXT_blend_func_separate: Boolean;

GL 4.6

GL_EXT_blend_logic_op: Boolean;

GL 4.6

GL_EXT_blend_minmax: Boolean;

GL 4.6

GL_EXT_blend_subtract: Boolean;

GL 4.6

GL_EXT_clip_volume_hint: Boolean;

GL 4.6

GL_EXT_cmyka: Boolean;

GL 4.6

GL_EXT_color_matrix: Boolean;

GL 4.6

GL_EXT_color_subtable: Boolean;

GL 4.6

GL_EXT_compiled_vertex_array: Boolean;

GL 4.6

GL_EXT_convolution: Boolean;

GL 4.6

GL_EXT_coordinate_frame: Boolean;

GL 4.6

GL_EXT_copy_texture: Boolean;

GL 4.6

GL_EXT_cull_vertex: Boolean;

GL 4.6

GL_EXT_draw_range_elements: Boolean;

GL 4.6

GL_EXT_fog_coord: Boolean;

GL 4.6

GL_EXT_framebuffer_object: Boolean;

GL 4.6

GL_EXT_histogram: Boolean;

GL 4.6

GL_EXT_index_array_formats: Boolean;

GL 4.6

GL_EXT_index_func: Boolean;

GL 4.6

GL_EXT_index_material: Boolean;

GL 4.6

GL_EXT_index_texture: Boolean;

GL 4.6

GL_EXT_light_texture: Boolean;

GL 4.6

GL_EXT_misc_attribute: Boolean;

GL 4.6

GL_EXT_multi_draw_arrays: Boolean;

GL 4.6

GL_EXT_multisample: Boolean;

GL 4.6

GL_EXT_packed_pixels: Boolean;

GL 4.6

GL_EXT_paletted_texture: Boolean;

GL 4.6

GL_EXT_pixel_transform: Boolean;

GL 4.6

GL_EXT_pixel_transform_color_table: Boolean;

GL 4.6

GL_EXT_point_parameters: Boolean;

GL 4.6

GL_EXT_polygon_offset: Boolean;

GL 4.6

GL_EXT_rescale_normal: Boolean;

GL 4.6

GL_EXT_secondary_color: Boolean;

GL 4.6

GL_EXT_separate_specular_color: Boolean;

GL 4.6

GL_EXT_shadow_funcs: Boolean;

GL 4.6

GL_EXT_shared_texture_palette: Boolean;

GL 4.6

GL_EXT_stencil_two_side: Boolean;

GL 4.6

GL_EXT_stencil_wrap: Boolean;

GL 4.6

GL_EXT_subtexture: Boolean;

GL 4.6

GL_EXT_texture: Boolean;

GL 4.6

GL_EXT_texture3D: Boolean;

GL 4.6

GL_EXT_texture_compression_s3tc: Boolean;

GL 4.6

GL_EXT_texture_cube_map: Boolean;

GL 4.6

GL_EXT_texture_edge_clamp: Boolean;

GL 4.6

GL_EXT_texture_env_add: Boolean;

GL 4.6

GL_EXT_texture_env_combine: Boolean;

GL 4.6

GL_EXT_texture_env_dot3: Boolean;

GL 4.6

GL_EXT_texture_filter_anisotropic: Boolean;

GL 4.6

GL_EXT_texture_lod_bias: Boolean;

GL 4.6

GL_EXT_texture_object: Boolean;

GL 4.6

GL_EXT_texture_perturb_normal: Boolean;

GL 4.6

GL_EXT_texture_rectangle: Boolean;

GL 4.6

GL_EXT_vertex_array: Boolean;

GL 4.6

GL_EXT_vertex_shader: Boolean;

GL 4.6

GL_EXT_vertex_weighting: Boolean;

GL 4.6

GL_EXT_depth_bounds_test: Boolean;

GL 4.6

GL_EXT_texture_mirror_clamp: Boolean;

GL 4.6

GL_EXT_blend_equation_separate: Boolean;

GL 4.6

GL_EXT_pixel_buffer_object: Boolean;

GL 4.6

GL_EXT_texture_compression_dxt1: Boolean;

GL 4.6

GL_EXT_stencil_clear_tag: Boolean;

GL 4.6

GL_EXT_packed_depth_stencil: Boolean;

GL 4.6

GL_EXT_texture_sRGB: Boolean;

GL 4.6

GL_EXT_framebuffer_blit: Boolean;

GL 4.6

GL_EXT_framebuffer_multisample: Boolean;

GL 4.6

GL_EXT_timer_query: Boolean;

GL 4.6

GL_EXT_gpu_program_parameters: Boolean;

GL 4.6

GL_EXT_bindable_uniform: Boolean;

GL 4.6

GL_EXT_draw_buffers2: Boolean;

GL 4.6

GL_EXT_draw_instanced: Boolean;

GL 4.6

GL_EXT_framebuffer_sRGB: Boolean;

GL 4.6

GL_EXT_geometry_shader4: Boolean;

GL 4.6

GL_EXT_gpu_shader4: Boolean;

GL 4.6

GL_EXT_packed_float: Boolean;

GL 4.6

GL_EXT_texture_array: Boolean;

GL 4.6

GL_EXT_texture_buffer_object: Boolean;

GL 4.6

GL_EXT_texture_compression_latc: Boolean;

GL 4.6

GL_EXT_texture_compression_rgtc: Boolean;

GL 4.6

GL_EXT_texture_integer: Boolean;

GL 4.6

GL_EXT_texture_shared_exponent: Boolean;

GL 4.6

GL_EXT_transform_feedback: Boolean;

GL 4.6

GL_EXT_direct_state_access: Boolean;

GL 4.6

GL_EXT_vertex_array_bgra: Boolean;

GL 4.6

GL_EXT_texture_swizzle: Boolean;

GL 4.6

GL_EXT_provoking_vertex: Boolean;

GL 4.6

GL_EXT_texture_snorm: Boolean;

GL 4.6

GL_EXT_separate_shader_objects: Boolean;

GL 4.6

GL_EXT_shader_image_load_store: Boolean;

GL 4.6

GL_EXT_vertex_attrib_64bit: Boolean;

GL 4.6

GL_EXT_texture_sRGB_decode: Boolean;

GL 4.6

GL_FfdMaskSGIX: Boolean;

GL 4.6

GL_HP_convolution_border_modes: Boolean;

GL 4.6

GL_HP_image_transform: Boolean;

GL 4.6

GL_HP_occlusion_test: Boolean;

GL 4.6

GL_HP_texture_lighting: Boolean;

GL 4.6

GL_IBM_cull_vertex: Boolean;

GL 4.6

GL_IBM_multimode_draw_arrays: Boolean;

GL 4.6

GL_IBM_rasterpos_clip: Boolean;

GL 4.6

GL_IBM_texture_mirrored_repeat: Boolean;

GL 4.6

GL_IBM_vertex_array_lists: Boolean;

GL 4.6

GL_INGR_blend_func_separate: Boolean;

GL 4.6

GL_INGR_color_clamp: Boolean;

GL 4.6

GL_INGR_interlace_read: Boolean;

GL 4.6

GL_INGR_palette_buffer: Boolean;

GL 4.6

GL_INTEL_framebuffer_CMAA: Boolean;

GL 4.6

GL_INTEL_parallel_arrays: Boolean;

GL 4.6

GL_INTEL_texture_scissor: Boolean;

GL 4.6

GL_MESA_resize_buffers: Boolean;

GL 4.6

GL_MESA_window_pos: Boolean;

GL 4.6

GL_NV_blend_square: Boolean;

GL 4.6

GL_NV_copy_depth_to_color: Boolean;

GL 4.6

GL_NV_depth_clamp: Boolean;

GL 4.6

GL_NV_evaluators: Boolean;

GL 4.6

GL_NV_fence: Boolean;

GL 4.6

GL_NV_float_buffer: Boolean;

GL 4.6

GL_NV_fog_distance: Boolean;

GL 4.6

GL_NV_fragment_program: Boolean;

GL 4.6

GL_NV_half_float: Boolean;

GL 4.6

GL_NV_light_max_exponent: Boolean;

GL 4.6

GL_NV_multisample_filter_hint: Boolean;

GL 4.6

GL_NV_occlusion_query: Boolean;

GL 4.6

GL_NV_packed_depth_stencil: Boolean;

GL 4.6

GL_NV_pixel_data_range: Boolean;

GL 4.6

GL_NV_point_sprite: Boolean;

GL 4.6

GL_NV_primitive_restart: Boolean;

GL 4.6

GL_NV_register_combiners: Boolean;

GL 4.6

GL_NV_register_combiners2: Boolean;

GL 4.6

GL_NV_texgen_emboss: Boolean;

GL 4.6

GL_NV_texgen_reflection: Boolean;

GL 4.6

GL_NV_texture_compression_vtc: Boolean;

GL 4.6

GL_NV_texture_env_combine4: Boolean;

GL 4.6

GL_NV_texture_expand_normal: Boolean;

GL 4.6

GL_NV_texture_rectangle: Boolean;

GL 4.6

GL_NV_texture_shader: Boolean;

GL 4.6

GL_NV_texture_shader2: Boolean;

GL 4.6

GL_NV_texture_shader3: Boolean;

GL 4.6

GL_NV_vertex_array_range: Boolean;

GL 4.6

GL_NV_vertex_array_range2: Boolean;

GL 4.6

GL_NV_vertex_program: Boolean;

GL 4.6

GL_NV_vertex_program1_1: Boolean;

GL 4.6

GL_NV_vertex_program2: Boolean;

GL 4.6

GL_NV_fragment_program_option: Boolean;

GL 4.6

GL_NV_fragment_program2: Boolean;

GL 4.6

GL_NV_vertex_program2_option: Boolean;

GL 4.6

GL_NV_vertex_program3: Boolean;

GL 4.6

GL_NV_depth_buffer_float: Boolean;

GL 4.6

GL_NV_fragment_program4: Boolean;

GL 4.6

GL_NV_framebuffer_multisample_coverage: Boolean;

GL 4.6

GL_NV_geometry_program4: Boolean;

GL 4.6

GL_NV_gpu_program4: Boolean;

GL 4.6

GL_NV_parameter_buffer_object: Boolean;

GL 4.6

GL_NV_transform_feedback: Boolean;

GL 4.6

GL_NV_vertex_program4: Boolean;

GL 4.6

GL_NV_conditional_render: Boolean;

GL 4.6

GL_NV_conservative_raster: Boolean;

GL 4.6

GL_NV_conservative_raster_dilate: Boolean;

GL 4.6

GL_NV_present_video: Boolean;

GL 4.6

GL_NV_explicit_multisample: Boolean;

GL 4.6

GL_NV_transform_feedback2: Boolean;

GL 4.6

GL_NV_video_capture: Boolean;

GL 4.6

GL_NV_copy_image: Boolean;

GL 4.6

GL_NV_parameter_buffer_object2: Boolean;

GL 4.6

GL_NV_shader_buffer_load: Boolean;

GL 4.6

GL_NV_vertex_buffer_unified_memory: Boolean;

GL 4.6

GL_NV_gpu_program5: Boolean;

GL 4.6

GL_NV_gpu_shader5: Boolean;

GL 4.6

GL_NV_shader_buffer_store: Boolean;

GL 4.6

GL_NV_tessellation_program5: Boolean;

GL 4.6

GL_NV_vertex_attrib_integer_64bit: Boolean;

GL 4.6

GL_NV_multisample_coverage: Boolean;

GL 4.6

GL_NV_vdpau_interop: Boolean;

GL 4.6

GL_NV_texture_barrier: Boolean;

GL 4.6

GL_OML_interlace: Boolean;

GL 4.6

GL_OML_resample: Boolean;

GL 4.6

GL_OML_subsample: Boolean;

GL 4.6

GL_OVR_multiview: Boolean;

GL 4.6

GL_OVR_multiview2: Boolean;

GL 4.6

GL_PGI_misc_hints: Boolean;

GL 4.6

GL_PGI_vertex_hints: Boolean;

GL 4.6

GL_REND_screen_coordinates: Boolean;

GL 4.6

GL_S3_s3tc: Boolean;

GL 4.6

GL_SGIS_detail_texture: Boolean;

GL 4.6

GL_SGIS_fog_function: Boolean;

GL 4.6

GL_SGIS_generate_mipmap: Boolean;

GL 4.6

GL_SGIS_multisample: Boolean;

GL 4.6

GL_SGIS_pixel_texture: Boolean;

GL 4.6

GL_SGIS_point_line_texgen: Boolean;

GL 4.6

GL_SGIS_point_parameters: Boolean;

GL 4.6

GL_SGIS_sharpen_texture: Boolean;

GL 4.6

GL_SGIS_texture4D: Boolean;

GL 4.6

GL_SGIS_texture_border_clamp: Boolean;

GL 4.6

GL_SGIS_texture_color_mask: Boolean;

GL 4.6

GL_SGIS_texture_edge_clamp: Boolean;

GL 4.6

GL_SGIS_texture_filter4: Boolean;

GL 4.6

GL_SGIS_texture_lod: Boolean;

GL 4.6

GL_SGIS_texture_select: Boolean;

GL 4.6

GL_SGIX_async: Boolean;

GL 4.6

GL_SGIX_async_histogram: Boolean;

GL 4.6

GL_SGIX_async_pixel: Boolean;

GL 4.6

GL_SGIX_blend_alpha_minmax: Boolean;

GL 4.6

GL_SGIX_calligraphic_fragment: Boolean;

GL 4.6

GL_SGIX_clipmap: Boolean;

GL 4.6

GL_SGIX_convolution_accuracy: Boolean;

GL 4.6

GL_SGIX_depth_pass_instrument: Boolean;

GL 4.6

GL_SGIX_depth_texture: Boolean;

GL 4.6

GL_SGIX_flush_raster: Boolean;

GL 4.6

GL_SGIX_fog_offset: Boolean;

GL 4.6

GL_SGIX_fog_scale: Boolean;

GL 4.6

GL_SGIX_fragment_lighting: Boolean;

GL 4.6

GL_SGIX_framezoom: Boolean;

GL 4.6

GL_SGIX_igloo_interface: Boolean;

GL 4.6

GL_SGIX_impact_pixel_texture: Boolean;

GL 4.6

GL_SGIX_instruments: Boolean;

GL 4.6

GL_SGIX_interlace: Boolean;

GL 4.6

GL_SGIX_ir_instrument1: Boolean;

GL 4.6

GL_SGIX_list_priority: Boolean;

GL 4.6

GL_SGIX_pixel_texture: Boolean;

GL 4.6

GL_SGIX_pixel_tiles: Boolean;

GL 4.6

GL_SGIX_polynomial_ffd: Boolean;

GL 4.6

GL_SGIX_reference_plane: Boolean;

GL 4.6

GL_SGIX_resample: Boolean;

GL 4.6

GL_SGIX_scalebias_hint: Boolean;

GL 4.6

GL_SGIX_shadow: Boolean;

GL 4.6

GL_SGIX_shadow_ambient: Boolean;

GL 4.6

GL_SGIX_sprite: Boolean;

GL 4.6

GL_SGIX_subsample: Boolean;

GL 4.6

GL_SGIX_tag_sample_buffer: Boolean;

GL 4.6

GL_SGIX_texture_add_env: Boolean;

GL 4.6

GL_SGIX_texture_coordinate_clamp: Boolean;

GL 4.6

GL_SGIX_texture_lod_bias: Boolean;

GL 4.6

GL_SGIX_texture_multi_buffer: Boolean;

GL 4.6

GL_SGIX_texture_scale_bias: Boolean;

GL 4.6

GL_SGIX_texture_select: Boolean;

GL 4.6

GL_SGIX_vertex_preclip: Boolean;

GL 4.6

GL_SGIX_ycrcb: Boolean;

GL 4.6

GL_SGIX_ycrcb_subsample: Boolean;

GL 4.6

GL_SGIX_ycrcba: Boolean;

GL 4.6

GL_SGI_color_matrix: Boolean;

GL 4.6

GL_SGI_color_table: Boolean;

GL 4.6

GL_SGI_depth_pass_instrument: Boolean;

GL 4.6

GL_SGI_texture_color_table: Boolean;

GL 4.6

GL_SUNX_constant_data: Boolean;

GL 4.6

GL_SUN_convolution_border_modes: Boolean;

GL 4.6

GL_SUN_global_alpha: Boolean;

GL 4.6

GL_SUN_mesh_array: Boolean;

GL 4.6

GL_SUN_slice_accum: Boolean;

GL 4.6

GL_SUN_triangle_list: Boolean;

GL 4.6

GL_SUN_vertex: Boolean;

GL 4.6

GL_WIN_phong_shading: Boolean;

WGL

GL_WIN_specular_fog: Boolean;

WGL

WGL_3DFX_multisample: Boolean;

WGL

WGL_ARB_buffer_region: Boolean;

WGL

WGL_ARB_extensions_string: Boolean;

WGL

WGL_ARB_make_current_read: Boolean;

WGL

WGL_ARB_multisample: Boolean;

WGL

WGL_ARB_pbuffer: Boolean;

WGL

WGL_ARB_pixel_format: Boolean;

WGL

WGL_ARB_pixel_format_float: Boolean;

WGL

WGL_ARB_render_texture: Boolean;

WGL

WGL_ARB_create_context: Boolean;

WGL

WGL_ARB_create_context_profile: Boolean;

WGL

WGL_ARB_framebuffer_sRGB: Boolean;

WGL

WGL_ARB_create_context_robustness: Boolean;

WGL

WGL_ATI_pixel_format_float: Boolean;

WGL

WGL_AMD_gpu_association: Boolean;

WGL

WGL_EXT_depth_float: Boolean;

WGL

WGL_EXT_display_color_table: Boolean;

WGL

WGL_EXT_extensions_string: Boolean;

WGL

WGL_EXT_make_current_read: Boolean;

WGL

WGL_EXT_multisample: Boolean;

WGL

WGL_EXT_pbuffer: Boolean;

WGL

WGL_EXT_pixel_format: Boolean;

WGL

WGL_EXT_swap_control: Boolean;

WGL

WGL_EXT_create_context_es2_profile: Boolean;

WGL

WGL_I3D_digital_video_control: Boolean;

WGL

WGL_I3D_gamma: Boolean;

WGL

WGL_I3D_genlock: Boolean;

WGL

WGL_I3D_image_buffer: Boolean;

WGL

WGL_I3D_swap_frame_lock: Boolean;

WGL

WGL_I3D_swap_frame_usage: Boolean;

WGL

WGL_NV_float_buffer: Boolean;

WGL

WGL_NV_render_depth_texture: Boolean;

WGL

WGL_NV_render_texture_rectangle: Boolean;

WGL

WGL_NV_vertex_array_range: Boolean;

WGL

WGL_NV_present_video: Boolean;

WGL

WGL_NV_video_output: Boolean;

WGL

WGL_NV_swap_group: Boolean;

WGL

WGL_NV_gpu_affinity: Boolean;

WGL

WGL_NV_video_capture: Boolean;

WGL

WGL_NV_copy_image: Boolean;

WGL

WGL_NV_multisample_coverage: Boolean;

WGL

WGL_NV_DX_interop: Boolean;

WGL

WGL_OML_sync_control: Boolean;

WGL

WGL_3DL_stereo_control: Boolean;

WGL

WGL_ARB_context_flush_control: Boolean;

WGL

WIN_draw_range_elements: Boolean;

WGL

WIN_swap_hint: Boolean;

WGL

GLX_VERSION_1_4: Boolean;

GLX

GLX_ARB_multisample: Boolean;

GLX

GLX_ARB_fbconfig_float: Boolean;

GLX

GLX_ARB_get_proc_address: Boolean;

GLX

GLX_ARB_create_context: Boolean;

GLX

GLX_ARB_create_context_profile: Boolean;

GLX

GLX_ARB_vertex_buffer_object: Boolean;

GLX

GLX_ARB_framebuffer_sRGB: Boolean;

GLX

GLX_ARB_create_context_robustness: Boolean;

GLX

GLX_EXT_visual_info: Boolean;

GLX

GLX_EXT_visual_rating: Boolean;

GLX

GLX_EXT_import_context: Boolean;

GLX

GLX_EXT_fbconfig_packed_float: Boolean;

GLX

GLX_EXT_framebuffer_sRGB: Boolean;

GLX

GLX_EXT_texture_from_pixmap: Boolean;

GLX

GLX_EXT_swap_control: Boolean;

GLX

GLX_ARB_context_flush_control: Boolean;

GLX

GLX_EXT_create_context_es2_profile: Boolean;

GLX

glBlendColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)

glBlendEquation: procedure(mode: Cardinal); stdcall;

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

glDrawRangeElements: procedure(mode: Cardinal; Astart, Aend: TGLuint; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

glTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_texture3D (#6)

glTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glCopyTexSubImage3D: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

promoted to core v1.2 from GL_EXT_copy_texture

glColorTable: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

glColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glCopyColorTable: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glGetColorTable: procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

deprecated;

glGetColorTableParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetColorTableParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glColorSubTable: procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

glCopyColorSubTable: procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glConvolutionFilter1D: procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

glConvolutionFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

glConvolutionParameterf: procedure(target, pname: Cardinal; param: Single); stdcall;

deprecated;

glConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glConvolutionParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

deprecated;

glConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glCopyConvolutionFilter1D: procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

glCopyConvolutionFilter2D: procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

deprecated;

glGetConvolutionFilter: procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

glGetConvolutionParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetConvolutionParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glGetSeparableFilter: procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

deprecated;

glSeparableFilter2D: procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

deprecated;

glGetHistogram: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

glGetHistogramParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetHistogramParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glGetMinmax: procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated;

glGetMinmaxParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

glGetMinmaxParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

glHistogram: procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

glMinmax: procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

glResetHistogram: procedure(target: Cardinal); stdcall;

deprecated;

glResetMinmax: procedure(target: Cardinal); stdcall;

deprecated;

glActiveTexture: procedure(texture: Cardinal); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)

glSampleCoverage: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

promoted to core v1.3 from GL_ARB_multisample (#5)

glCompressedTexImage3D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

glCompressedTexImage2D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexImage1D: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage3D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage2D: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage1D: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glGetCompressedTexImage: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

glClientActiveTexture: procedure(texture: Cardinal); stdcall;

promoted to core v1.3 from GL_ARB_multitexture (#1)

glMultiTexCoord1d: procedure(target: Cardinal; s: TGLdouble); stdcall;

deprecated;

glMultiTexCoord1dV: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord1f: procedure(target: Cardinal; s: Single); stdcall;

deprecated;

glMultiTexCoord1fV: procedure(target: Cardinal; v: Single); stdcall;

deprecated;

glMultiTexCoord1i: procedure(target: Cardinal; s: TGLint); stdcall;

deprecated;

glMultiTexCoord1iV: procedure(target: Cardinal; v: PGLInt); stdcall;

deprecated;

glMultiTexCoord1s: procedure(target: Cardinal; s: TGLshort); stdcall;

deprecated;

glMultiTexCoord1sV: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord2d: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

deprecated;

glMultiTexCoord2dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord2f: procedure(target: Cardinal; s, t: Single); stdcall;

deprecated;

glMultiTexCoord2fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord2i: procedure(target: Cardinal; s, t: TGLint); stdcall;

deprecated;

glMultiTexCoord2iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord2s: procedure(target: Cardinal; s, t: TGLshort); stdcall;

deprecated;

glMultiTexCoord2sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord3d: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

deprecated;

glMultiTexCoord3dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord3f: procedure(target: Cardinal; s, t, r: Single); stdcall;

deprecated;

glMultiTexCoord3fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord3i: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

deprecated;

glMultiTexCoord3iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord3s: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

deprecated;

glMultiTexCoord3sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glMultiTexCoord4d: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

deprecated;

glMultiTexCoord4dv: procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

glMultiTexCoord4f: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

deprecated;

glMultiTexCoord4fv: procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

glMultiTexCoord4i: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

deprecated;

glMultiTexCoord4iv: procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

glMultiTexCoord4s: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

deprecated;

glMultiTexCoord4sv: procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

glLoadTransposeMatrixf: procedure(m: PGLfloat); stdcall;

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

glLoadTransposeMatrixd: procedure(m: PGLdouble); stdcall;

deprecated;

glMultTransposeMatrixf: procedure(m: PGLfloat); stdcall;

deprecated;

glMultTransposeMatrixd: procedure(m: PGLdouble); stdcall;

deprecated;

glBlendFuncSeparate: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

glMultiDrawArrays: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

glMultiDrawElements: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

glPointParameterf: procedure(pname: Cardinal; param: Single); stdcall;

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

glPointParameterfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glPointParameteri: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glPointParameteriv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glFogCoordf: procedure(coord: Single); stdcall;

promoted to core v1.4 from GL_EXT_fog_coord (#149)

glFogCoordfv: procedure(coord: PGLfloat); stdcall;

deprecated;

glFogCoordd: procedure(coord: TGLdouble); stdcall;

deprecated;

glFogCoorddv: procedure(coord: PGLdouble); stdcall;

deprecated;

glFogCoordPointer: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

deprecated;

glSecondaryColor3b: procedure(red, green, blue: TGLbyte); stdcall;

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

glSecondaryColor3bv: procedure(v: PGLbyte); stdcall;

deprecated;

glSecondaryColor3d: procedure(red, green, blue: TGLdouble); stdcall;

deprecated;

glSecondaryColor3dv: procedure(v: PGLdouble); stdcall;

deprecated;

glSecondaryColor3f: procedure(red, green, blue: Single); stdcall;

deprecated;

glSecondaryColor3fv: procedure(v: PGLfloat); stdcall;

deprecated;

glSecondaryColor3i: procedure(red, green, blue: TGLint); stdcall;

deprecated;

glSecondaryColor3iv: procedure(v: PGLint); stdcall;

deprecated;

glSecondaryColor3s: procedure(red, green, blue: TGLshort); stdcall;

deprecated;

glSecondaryColor3sv: procedure(v: PGLshort); stdcall;

deprecated;

glSecondaryColor3ub: procedure(red, green, blue: TGLubyte); stdcall;

deprecated;

glSecondaryColor3ubv: procedure(v: PGLubyte); stdcall;

deprecated;

glSecondaryColor3ui: procedure(red, green, blue: TGLuint); stdcall;

deprecated;

glSecondaryColor3uiv: procedure(v: PGLuint); stdcall;

deprecated;

glSecondaryColor3us: procedure(red, green, blue: TGLushort); stdcall;

deprecated;

glSecondaryColor3usv: procedure(v: PGLushort); stdcall;

deprecated;

glSecondaryColorPointer: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

deprecated;

glWindowPos2d: procedure(x,y : TGLdouble); stdcall;

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

glWindowPos2dv: procedure(v : PGLdouble); stdcall;

deprecated;

glWindowPos2f: procedure(x,y : Single); stdcall;

deprecated;

glWindowPos2fv: procedure(v : PGLfloat); stdcall;

deprecated;

glWindowPos2i: procedure(x,y : TGLint); stdcall;

deprecated;

glWindowPos2iv: procedure(v : PGLint); stdcall;

deprecated;

glWindowPos2s: procedure(x,y : TGLshort); stdcall;

deprecated;

glWindowPos2sv: procedure(v : PGLshort); stdcall;

deprecated;

glWindowPos3d: procedure(x,y,z : TGLdouble); stdcall;

deprecated;

glWindowPos3dv: procedure(v : PGLdouble); stdcall;

deprecated;

glWindowPos3f: procedure(x,y,z : Single); stdcall;

deprecated;

glWindowPos3fv: procedure(v : PGLfloat); stdcall;

deprecated;

glWindowPos3i: procedure(x,y,z : TGLint); stdcall;

deprecated;

glWindowPos3iv: procedure(v : PGLint); stdcall;

deprecated;

glWindowPos3s: procedure(x,y,z : TGLshort); stdcall;

deprecated;

glWindowPos3sv: procedure(v : PGLshort); stdcall;

deprecated;

glGenQueries: procedure(n: TGLsizei; ids: PGLuint); stdcall;

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)

glDeleteQueries: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsQuery: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginQuery: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glEndQuery: procedure(target: Cardinal); stdcall;

This item has no description.

glGetQueryiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectiv: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectuiv: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glBindBuffer: procedure(target: GLenum; buffer: GLuint); stdcall;

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

glDeleteBuffers: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

This item has no description.

glGenBuffers: procedure(n: GLsizei; buffers: PGLuint); stdcall;

This item has no description.

glIsBuffer: function(buffer: GLuint): GLboolean; stdcall;

This item has no description.

glBufferData: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

This item has no description.

glBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

This item has no description.

glGetBufferSubData: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

This item has no description.

glMapBuffer: function(target: GLenum; access: GLenum): Pointer; stdcall;

This item has no description.

glUnmapBuffer: function(target: GLenum): GLboolean; stdcall;

This item has no description.

glGetBufferParameteriv: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetBufferPointerv: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

This item has no description.

glBlendEquationSeparate: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

glDrawBuffers: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

glStencilOpSeparate: procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

glStencilFuncSeparate: procedure(face, func: Cardinal; ref: TGLint; mask: TGLuint); stdcall;

This item has no description.

glStencilMaskSeparate: procedure(face: Cardinal; mask: TGLuint); stdcall;

This item has no description.

glAttachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

glBindAttribLocation: procedure(_program: TGLuint; index: TGLuint; const name: PGLChar);

This item has no description.

glCompileShader: procedure(shader: TGLuint); stdcall;

This item has no description.

glCreateProgram: function(): TGLuint; stdcall;

This item has no description.

glCreateShader: function(_type: Cardinal): TGLuint; stdcall;

This item has no description.

glDeleteProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glDeleteShader: procedure(shader: TGLuint); stdcall;

This item has no description.

glDetachShader: procedure(_program: TGLuint; shader: TGLuint); stdcall;

This item has no description.

glDisableVertexAttribArray: procedure(index: TGLuint); stdcall;

This item has no description.

glEnableVertexAttribArray: procedure(index: TGLuint); stdcall;

This item has no description.

glGetActiveAttrib: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetActiveUniform: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetAttachedShaders: procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

This item has no description.

glGetAttribLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

This item has no description.

glGetProgramiv: procedure(_program: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetProgramInfoLog: procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetShaderiv: procedure(shader: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetShaderInfoLog: procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetShaderSource: procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

This item has no description.

glGetUniformLocation: function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

This item has no description.

glGetUniformfv: procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

glGetUniformiv: procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribdv: procedure(index:TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfv: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointerv: procedure(index: TGLuint; pname: Cardinal; _pointer:pointer); stdcall;

This item has no description.

glIsProgram: function(_program: TGLuint):TGLboolean; stdcall;

This item has no description.

glIsShader: function(shader: TGLuint): TGLboolean; stdcall;

This item has no description.

glLinkProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glShaderSource: procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

glUseProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glUniform1f: procedure(location: GLint; v0: Single); stdcall;

This item has no description.

glUniform2f: procedure(location: GLint; v0: Single; v1: Single); stdcall;

This item has no description.

glUniform3f: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

This item has no description.

glUniform4f: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

This item has no description.

glUniform1i: procedure(location: GLint; v0: GLint); stdcall;

This item has no description.

glUniform2i: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

This item has no description.

glUniform3i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

This item has no description.

glUniform4i: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

This item has no description.

glUniform1fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform2fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform3fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform4fv: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform1iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform2iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform3iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform4iv: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniformMatrix2fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4fv: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glValidateProgram: procedure(_program: TGLuint); stdcall;

This item has no description.

glVertexAttrib1d: procedure(index:TGLuint; x: TGLdouble); stdcall;

This item has no description.

glVertexAttrib1dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1f: procedure(index:TGLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1s: procedure(index:TGLuint; x: TGLshort); stdcall;

This item has no description.

glVertexAttrib1sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2d: procedure(index:TGLuint; x,y: TGLdouble); stdcall;

This item has no description.

glVertexAttrib2dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2f: procedure(index:TGLuint; x,y: Single); stdcall;

This item has no description.

glVertexAttrib2fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2s: procedure(index:TGLuint; x,y: TGLshort); stdcall;

This item has no description.

glVertexAttrib2sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3d: procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

This item has no description.

glVertexAttrib3dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3f: procedure(index:TGLuint; x,y,z: Single); stdcall;

This item has no description.

glVertexAttrib3fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3s: procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

This item has no description.

glVertexAttrib3sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4Nbv: procedure(index:TGLuint; v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4Niv: procedure(index:TGLuint; v: PGLint); stdcall;

This item has no description.

glVertexAttrib4Nsv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4Nub: procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

This item has no description.

glVertexAttrib4Nubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4Nuiv: procedure(index:TGLuint; v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4Nusv: procedure(index:TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttrib4bv: procedure(index:TGLuint; v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4d: procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

This item has no description.

glVertexAttrib4dv: procedure(index:TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4f: procedure(index:TGLuint; x,y,z,w: Single); stdcall;

This item has no description.

glVertexAttrib4fv: procedure(index:TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4iv: procedure(index:TGLuint; v: PGLint); stdcall;

This item has no description.

glVertexAttrib4s: procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

This item has no description.

glVertexAttrib4sv: procedure(index:TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubv: procedure(index:TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4uiv: procedure(index:TGLuint; v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4usv: procedure(index:TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribPointer: procedure(index:TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glUniformMatrix2x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################

glUniformMatrix3x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix2x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4x2fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3x4fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4x3fv: procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

glVertexAttribI1i: procedure(index: TGLuint; x: TGLint); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################

glVertexAttribI2i: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

This item has no description.

glVertexAttribI3i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

glVertexAttribI4i: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

glVertexAttribI1ui: procedure(index: TGLuint; x: TGLuint); stdcall;

This item has no description.

glVertexAttribI2ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

This item has no description.

glVertexAttribI3ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

This item has no description.

glVertexAttribI4ui: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

This item has no description.

glVertexAttribI1iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI2iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI3iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI4iv: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI1uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI2uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI3uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4uiv: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4bv: procedure(index: TGLuint; v:PGLbyte); stdcall;

This item has no description.

glVertexAttribI4sv: procedure(index: TGLuint; v:PGLshort); stdcall;

This item has no description.

glVertexAttribI4ubv: procedure(index: TGLuint; v: PGLUbyte); stdcall;

This item has no description.

glVertexAttribI4usv: procedure(index: TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribIPointer: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

glGetVertexAttribIiv: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribIuiv: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glUniform1ui: procedure(location: TGLInt; v0: TGLuint); stdcall;

This item has no description.

glUniform2ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

This item has no description.

glUniform3ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

This item has no description.

glUniform4ui: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

This item has no description.

glUniform1uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform2uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform3uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform4uiv: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glGetUniformuiv: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glBindFragDataLocation: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetFragDataLocation: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glBeginConditionalRender: procedure(id: TGLuint; mode: Cardinal); stdcall;

This item has no description.

glEndConditionalRender: procedure(); stdcall;

This item has no description.

glClampColor: procedure(target: Cardinal; clamp: Cardinal); stdcall;

This item has no description.

glTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}

glTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glGetTexParameterIiv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetTexParameterIuiv: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glColorMaski: procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

promoted to core v3.0 from GL_EXT_draw_buffers2

glGetBooleani_v: procedure(target: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

This item has no description.

glGetIntegeri_v: procedure(target: Cardinal; index: TGLuint; data: PGLint); stdcall;

This item has no description.

glEnablei: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glDisablei: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glIsEnabledi: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindBufferRange: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

promoted to core v3.0 from GL_EXT_transform_feedback

glBindBufferBase: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glBeginTransformFeedback: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedback: procedure(); stdcall;

This item has no description.

glTransformFeedbackVaryings: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

glGetTransformFeedbackVarying: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glClearBufferiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

New commands in OpenGL 3.0

glClearBufferuiv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

This item has no description.

glClearBufferfv: procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

This item has no description.

glClearBufferfi: procedure(buffer: Cardinal; drawbuffer: TGLint; depth: Single; stencil: TGLint); stdcall;

This item has no description.

glGetStringi: function(name: Cardinal; index: TGLuint): PGLChar; stdcall;

This item has no description.

glDrawArraysInstanced: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################

glDrawElementsInstanced: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glTexBuffer: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

This item has no description.

glPrimitiveRestartIndex: procedure(index: TGLuint); stdcall;

This item has no description.

glGetInteger64i_v: procedure(target: Cardinal; index: TGLuint; data: PGLint64); stdcall;

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################

glGetBufferParameteri64v: procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glProgramParameteri: procedure(_program: TGLuint; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

glFramebufferTexture: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

gluNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions

gluNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

This item has no description.

gluDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

wglCreateBufferRegionARB: function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)

wglDeleteBufferRegionARB: procedure(hRegion: Integer); stdcall;

This item has no description.

wglSaveBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

This item has no description.

wglRestoreBufferRegionARB: function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

This item has no description.

wglGetExtensionsStringARB: function(DC: HDC): PGLChar; stdcall;

WGL_ARB_extensions_string (ARB #8)

wglGetPixelFormatAttribivARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

WGL_ARB_pixel_format (ARB #9)

wglGetPixelFormatAttribfvARB: function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

This item has no description.

wglChoosePixelFormatARB: function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

This item has no description.

wglMakeContextCurrentARB: function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

WGL_make_current_read (ARB #10)

wglGetCurrentReadDCARB: function(): HDC; stdcall;

This item has no description.

wglCreatePbufferARB: function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

WGL_ARB_pbuffer (ARB #11)

wglGetPbufferDCARB: function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

This item has no description.

wglReleasePbufferDCARB: function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

This item has no description.

wglDestroyPbufferARB: function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

This item has no description.

wglQueryPbufferARB: function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

This item has no description.

wglBindTexImageARB: function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

WGL_ARB_render_texture (ARB #20)

wglReleaseTexImageARB: function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

This item has no description.

wglSetPbufferAttribARB: function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

This item has no description.

wglCreateContextAttribsARB: function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

WGL_ARB_create_context (ARB #55)

wglEnumGpusNV: function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

WGL_NV_gpu_affinity

wglEnumGpuDevicesNV: function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean;

This item has no description.

wglCreateAffinityDCNV: function(hGpuList: PHGPUNV): HDC;

This item has no description.

wglEnumGpusFromAffinityDCNV: function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean;

This item has no description.

wglDeleteDCNV: function(hdc: HDC): Boolean;

This item has no description.

wglSwapIntervalEXT: function(interval : Integer) : BOOL; stdcall;

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

wglGetSwapIntervalEXT: function: Integer; stdcall;

This item has no description.

glSamplePassARB: procedure(pass: Cardinal); stdcall;

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension

glActiveTextureARB: procedure(target: Cardinal); stdcall;

GL_ARB_multitexture (ARB #1)

glClientActiveTextureARB: procedure(target: Cardinal); stdcall;

This item has no description.

glMultiTexCoord1dARB: procedure(target: Cardinal; s: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord1dVARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord1fARB: procedure(target: Cardinal; s: Single); stdcall;

This item has no description.

glMultiTexCoord1fVARB: procedure(target: Cardinal; v: Single); stdcall;

This item has no description.

glMultiTexCoord1iARB: procedure(target: Cardinal; s: TGLint); stdcall;

This item has no description.

glMultiTexCoord1iVARB: procedure(target: Cardinal; v: PGLInt); stdcall;

This item has no description.

glMultiTexCoord1sARB: procedure(target: Cardinal; s: TGLshort); stdcall;

This item has no description.

glMultiTexCoord1sVARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord2dARB: procedure(target: Cardinal; s, t: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord2dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord2fARB: procedure(target: Cardinal; s, t: Single); stdcall;

This item has no description.

glMultiTexCoord2fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord2iARB: procedure(target: Cardinal; s, t: TGLint); stdcall;

This item has no description.

glMultiTexCoord2ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord2sARB: procedure(target: Cardinal; s, t: TGLshort); stdcall;

This item has no description.

glMultiTexCoord2svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord3dARB: procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord3dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord3fARB: procedure(target: Cardinal; s, t, r: Single); stdcall;

This item has no description.

glMultiTexCoord3fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord3iARB: procedure(target: Cardinal; s, t, r: TGLint); stdcall;

This item has no description.

glMultiTexCoord3ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord3sARB: procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

This item has no description.

glMultiTexCoord3svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glMultiTexCoord4dARB: procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

This item has no description.

glMultiTexCoord4dvARB: procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

glMultiTexCoord4fARB: procedure(target: Cardinal; s, t, r, q: Single); stdcall;

This item has no description.

glMultiTexCoord4fvARB: procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

glMultiTexCoord4iARB: procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

This item has no description.

glMultiTexCoord4ivARB: procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

glMultiTexCoord4sARB: procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

This item has no description.

glMultiTexCoord4svARB: procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

glLoadTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

GL_ARB_transpose_matrix (ARB #3)

glLoadTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

This item has no description.

glMultTransposeMatrixfARB: procedure(m: PGLfloat); stdcall;

This item has no description.

glMultTransposeMatrixdARB: procedure(m: PGLdouble); stdcall;

This item has no description.

glSampleCoverageARB: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_ARB_multisample (ARB #5)

glCompressedTexImage3DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

GL_ARB_texture_compression (ARB #12)

glCompressedTexImage2DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexImage1DARB: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage3DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage2DARB: procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glCompressedTexSubImage1DARB: procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

glGetCompressedTexImageARB: procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

glPointParameterfARB: procedure(pname: Cardinal; param: Single); stdcall;

GL_ARB_point_parameter (ARB #14)

glPointParameterfvARB: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glWeightbvARB: procedure(size: TGLint; weights: PGLbyte); stdcall;

GL_ARB_vertex_blend (ARB #15) {deprecated?}

glWeightsvARB: procedure(size: TGLint; weights: PGLshort); stdcall;

This item has no description.

glWeightivARB: procedure(size: TGLint; weights: PGLint); stdcall;

This item has no description.

glWeightfvARB: procedure(size: TGLint; weights: PGLfloat); stdcall;

This item has no description.

glWeightdvARB: procedure(size: TGLint; weights: PGLdouble); stdcall;

This item has no description.

glWeightubvARB: procedure(size: TGLint; weights: PGLubyte); stdcall;

This item has no description.

glWeightusvARB: procedure(size: TGLint; weights: PGLushort); stdcall;

This item has no description.

glWeightuivARB: procedure(size: TGLint; weights: PGLuint); stdcall;

This item has no description.

glWeightPointerARB: procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glVertexBlendARB: procedure(count: TGLint); stdcall;

This item has no description.

glCurrentPaletteMatrixARB: procedure(index: TGLint); stdcall;

GL_ARB_matrix_palette (ARB #16) {deprecated?}

glMatrixIndexubvARB: procedure(size: TGLint; indices: PGLubyte); stdcall;

This item has no description.

glMatrixIndexusvARB: procedure(size: TGLint; indices: PGLushort); stdcall;

This item has no description.

glMatrixIndexuivARB: procedure(size: TGLint; indices: PGLuint); stdcall;

This item has no description.

glMatrixIndexPointerARB: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

This item has no description.

glWindowPos2dARB: procedure(x,y : TGLdouble); stdcall;

GL_ARB_window_pos (ARB #25)

glWindowPos2dvARB: procedure(v : PGLdouble); stdcall;

This item has no description.

glWindowPos2fARB: procedure(x,y : Single); stdcall;

This item has no description.

glWindowPos2fvARB: procedure(v : PGLfloat); stdcall;

This item has no description.

glWindowPos2iARB: procedure(x,y : TGLint); stdcall;

This item has no description.

glWindowPos2ivARB: procedure(v : PGLint); stdcall;

This item has no description.

glWindowPos2sARB: procedure(x,y : TGLshort); stdcall;

This item has no description.

glWindowPos2svARB: procedure(v : PGLshort); stdcall;

This item has no description.

glWindowPos3dARB: procedure(x,y,z : TGLdouble); stdcall;

This item has no description.

glWindowPos3dvARB: procedure(v : PGLdouble); stdcall;

This item has no description.

glWindowPos3fARB: procedure(x,y,z : Single); stdcall;

This item has no description.

glWindowPos3fvARB: procedure(v : PGLfloat); stdcall;

This item has no description.

glWindowPos3iARB: procedure(x,y,z : TGLint); stdcall;

This item has no description.

glWindowPos3ivARB: procedure(v : PGLint); stdcall;

This item has no description.

glWindowPos3sARB: procedure(x,y,z : TGLshort); stdcall;

This item has no description.

glWindowPos3svARB: procedure(v : PGLshort); stdcall;

This item has no description.

glVertexAttrib1dARB: procedure(index: GLuint; x: GLdouble); stdcall;

GL_ARB_vertex_program (ARB #26)

glVertexAttrib1dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1fARB: procedure(index: GLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1sARB: procedure(index: GLuint; x: GLshort); stdcall;

This item has no description.

glVertexAttrib1svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

This item has no description.

glVertexAttrib2dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2fARB: procedure(index: GLuint; x: Single; y: Single); stdcall;

This item has no description.

glVertexAttrib2fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2sARB: procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

This item has no description.

glVertexAttrib2svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

This item has no description.

glVertexAttrib3dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3fARB: procedure(index: GLuint; x: Single; y: Single; z: Single); stdcall;

This item has no description.

glVertexAttrib3fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

This item has no description.

glVertexAttrib3svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4NbvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4NivARB: procedure(index: GLuint; const v: PGLint); stdcall;

This item has no description.

glVertexAttrib4NsvARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4NubARB: procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

This item has no description.

glVertexAttrib4NubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4NuivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4NusvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

This item has no description.

glVertexAttrib4bvARB: procedure(index: GLuint; const v: PGLbyte); stdcall;

This item has no description.

glVertexAttrib4dARB: procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glVertexAttrib4dvARB: procedure(index: GLuint; const v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4fARB: procedure(index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glVertexAttrib4fvARB: procedure(index: GLuint; const v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4ivARB: procedure(index: GLuint; const v: PGLint); stdcall;

This item has no description.

glVertexAttrib4sARB: procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

This item has no description.

glVertexAttrib4svARB: procedure(index: GLuint; const v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubvARB: procedure(index: GLuint; const v: PGLubyte); stdcall;

This item has no description.

glVertexAttrib4uivARB: procedure(index: GLuint; const v: PGLuint); stdcall;

This item has no description.

glVertexAttrib4usvARB: procedure(index: GLuint; const v: PGLushort); stdcall;

This item has no description.

glVertexAttribPointerARB: procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

This item has no description.

glEnableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

This item has no description.

glDisableVertexAttribArrayARB: procedure(index: GLuint); stdcall;

This item has no description.

glProgramStringARB: procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

This item has no description.

glBindProgramARB: procedure(target: GLenum; _program: GLuint); stdcall;

This item has no description.

glDeleteProgramsARB: procedure(n: GLsizei; const programs: PGLuint); stdcall;

This item has no description.

glGenProgramsARB: procedure(n: GLsizei; programs: PGLuint); stdcall;

This item has no description.

glProgramEnvParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glProgramEnvParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

This item has no description.

glProgramEnvParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glProgramEnvParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

This item has no description.

glProgramLocalParameter4dARB: procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

This item has no description.

glProgramLocalParameter4dvARB: procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

This item has no description.

glProgramLocalParameter4fARB: procedure(target: GLenum; index: GLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glProgramLocalParameter4fvARB: procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

This item has no description.

glGetProgramEnvParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

This item has no description.

glGetProgramEnvParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

This item has no description.

glGetProgramLocalParameterdvARB: procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

This item has no description.

glGetProgramLocalParameterfvARB: procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

This item has no description.

glGetProgramivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetProgramStringARB: procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

This item has no description.

glGetVertexAttribdvARB: procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfvARB: procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribivARB: procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointervARB: procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

This item has no description.

glIsProgramARB: function(_program: GLuint): GLboolean; stdcall;

This item has no description.

glBindBufferARB: procedure(target: GLenum; buffer: GLuint); stdcall;

GL_ARB_vertex_buffer_object (ARB #28)

glDeleteBuffersARB: procedure(n: GLsizei; const buffers: PGLuint); stdcall;

This item has no description.

glGenBuffersARB: procedure(n: GLsizei; buffers: PGLuint); stdcall;

This item has no description.

glIsBufferARB: function(buffer: GLuint): GLboolean; stdcall;

This item has no description.

glBufferDataARB: procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

This item has no description.

glBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

This item has no description.

glGetBufferSubDataARB: procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

This item has no description.

glMapBufferARB: function(target: GLenum; access: GLenum): Pointer; stdcall;

This item has no description.

glUnmapBufferARB: function(target: GLenum): GLboolean; stdcall;

This item has no description.

glGetBufferParameterivARB: procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetBufferPointervARB: procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

This item has no description.

glGenQueriesARB: procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_ARB_occlusion_query (ARB #29)

glDeleteQueriesARB: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsQueryARB: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginQueryARB: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glEndQueryARB: procedure(target: Cardinal); stdcall;

This item has no description.

glGetQueryivARB: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetQueryObjectuivARB: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glDeleteObjectARB: procedure(obj: GLhandleARB); stdcall;

GL_ARB_shader_objects (ARB #30)

glGetHandleARB: function(pname: GLenum): GLhandleARB; stdcall;

This item has no description.

glDetachObjectARB: procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

This item has no description.

glCreateShaderObjectARB: function(shaderType: GLenum): GLhandleARB; stdcall;

This item has no description.

glShaderSourceARB: procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

glCompileShaderARB: procedure(shaderObj: GLhandleARB); stdcall;

This item has no description.

glCreateProgramObjectARB: function(): GLhandleARB; stdcall;

This item has no description.

glAttachObjectARB: procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

This item has no description.

glLinkProgramARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glUseProgramObjectARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glValidateProgramARB: procedure(programObj: GLhandleARB); stdcall;

This item has no description.

glUniform1fARB: procedure(location: GLint; v0: Single); stdcall;

This item has no description.

glUniform2fARB: procedure(location: GLint; v0: Single; v1: Single); stdcall;

This item has no description.

glUniform3fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single); stdcall;

This item has no description.

glUniform4fARB: procedure(location: GLint; v0: Single; v1: Single; v2: Single; v3: Single); stdcall;

This item has no description.

glUniform1iARB: procedure(location: GLint; v0: GLint); stdcall;

This item has no description.

glUniform2iARB: procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

This item has no description.

glUniform3iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

This item has no description.

glUniform4iARB: procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

This item has no description.

glUniform1fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform2fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform3fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform4fvARB: procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

This item has no description.

glUniform1ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform2ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform3ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniform4ivARB: procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

This item has no description.

glUniformMatrix2fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix3fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glUniformMatrix4fvARB: procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

This item has no description.

glGetObjectParameterfvARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

This item has no description.

glGetObjectParameterivARB: procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

This item has no description.

glGetInfoLogARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

This item has no description.

glGetAttachedObjectsARB: procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

This item has no description.

glGetUniformLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

This item has no description.

glGetActiveUniformARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetUniformfvARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

This item has no description.

glGetUniformivARB: procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

This item has no description.

glGetShaderSourceARB: procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

This item has no description.

glBindAttribLocationARB: procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

GL_ARB_vertex_shader (ARB #31)

glGetActiveAttribARB: procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glGetAttribLocationARB: function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

This item has no description.

glDrawBuffersARB: procedure(n: GLSizei; const bufs: PGLenum); stdcall;

GL_ARB_DrawBuffers (ARB #37)

glClampColorARB: procedure(target: Cardinal; clamp: Cardinal); stdcall;

GL_ARB_color_buffer_float (ARB #39)

glDrawArraysInstancedARB: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_ARB_draw_instanced (ARB #44)

glDrawElementsInstancedARB: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glIsRenderbuffer: function(renderbuffer: TGLuint): TGLBoolean; stdcall;

GL_ARB_framebuffer_object (ARB #45)

glBindRenderbuffer: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glDeleteRenderbuffers: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glGenRenderbuffers: procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glRenderbufferStorage: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glRenderbufferStorageMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glGetRenderbufferParameteriv: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIsFramebuffer: function(framebuffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindFramebuffer: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

This item has no description.

glDeleteFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glGenFramebuffers: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glCheckFramebufferStatus: function(target: Cardinal): Cardinal; stdcall;

This item has no description.

glFramebufferTexture1D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture2D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture3D: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

This item has no description.

glFramebufferTextureLayer: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

This item has no description.

glFramebufferRenderbuffer: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glGetFramebufferAttachmentParameteriv: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glBlitFramebuffer: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

This item has no description.

glGenerateMipmap: procedure(target: Cardinal); stdcall;

This item has no description.

glProgramParameteriARB: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

GL_ARB_geometry_shader4 (ARB #47)

glFramebufferTextureARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

This item has no description.

glFramebufferTextureLayerARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

This item has no description.

glFramebufferTextureFaceARB: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

This item has no description.

glVertexAttribDivisorARB: procedure(index: TGLuint; divisor: TGLuint); stdcall;

GL_ARB_instanced_arrays (ARB #49)

glMapBufferRange: function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

GL_ARB_map_buffer_range (ARB #50)

glFlushMappedBufferRange: procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

This item has no description.

glTexBufferARB: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

GL_ARB_texture_buffer_object (ARB #51)

glBindVertexArray: procedure(_array: TGLuint); stdcall;

GL_ARB_vertex_array_object (ARB #54)

glDeleteVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

glGenVertexArrays: procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

glIsVertexArray: function(_array: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetUniformIndices: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

GL_ARB_uniform_buffer_object (ARB #57)

glGetActiveUniformsiv: procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetActiveUniformName: procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

This item has no description.

glGetUniformBlockIndex: function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

This item has no description.

glGetActiveUniformBlockiv: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetActiveUniformBlockName: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

This item has no description.

glUniformBlockBinding: procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

This item has no description.

glCopyBufferSubData: procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_ARB_copy_buffer (ARB #59)

glDrawElementsBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

GL_ARB_draw_elements_base_vertex (ARB #62)

glDrawRangeElementsBaseVertex: procedure(mode: Cardinal; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

This item has no description.

glDrawElementsInstancedBaseVertex: procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

This item has no description.

glMultiDrawElementsBaseVertex: procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

This item has no description.

glProvokingVertex: procedure(mode: Cardinal); stdcall;

GL_ARB_provoking_vertex (ARB #64)

glFenceSync: function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_sync (ARB #66)

glIsSync: function(sync: TGLsync): TGLboolean; stdcall;

This item has no description.

glDeleteSync: procedure(sync: TGLsync); stdcall;

This item has no description.

glClientWaitSync: function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

This item has no description.

glWaitSync: procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

This item has no description.

glGetInteger64v: procedure(pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glGetSynciv: procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

glTexImage2DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

GL_ARB_texture_multisample (ARB #67)

glTexImage3DMultisample: procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

This item has no description.

glGetMultisamplefv: procedure(pname: Cardinal; index: TGLuint; val: PGLfloat); stdcall;

This item has no description.

glSampleMaski: procedure(index: TGLuint; mask: TGLbitfield); stdcall;

This item has no description.

glBlendEquationi: procedure(buf: TGLuint; mode: Cardinal); stdcall;

GL_ARB_draw_buffers_blend (ARB #69)

glBlendEquationSeparatei: procedure(buf: TGLuint; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

glBlendFunci: procedure(buf: TGLuint; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

glBlendFuncSeparatei: procedure(buf: TGLuint; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

glMinSampleShading: procedure(value: TGLclampf); stdcall;

GL_ARB_sample_shading (ARB #70)

glBindFragDataLocationIndexed: procedure(_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

GL_ARB_blend_func_extended (ARB #78)

glGetFragDataIndex: function(_program: TGLuint; const name: PGLchar): TGLint; stdcall;

This item has no description.

glGenSamplers: procedure(count: TGLsizei; samplers: PGLuint); stdcall;

GL_ARB_sampler_objects (ARB #81)

glDeleteSamplers: procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

This item has no description.

glIsSampler: function(sampler: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindSampler: procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

This item has no description.

glSamplerParameteri: procedure(sampler: TGLuint; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

glSamplerParameterf: procedure(sampler: TGLuint; pname: Cardinal; param: Single); stdcall;

This item has no description.

glSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

glSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

glSamplerParameterIuiv: procedure(sampler: TGLuint; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

glGetSamplerParameteriv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetSamplerParameterIiv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetSamplerParameterfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetSamplerParameterIfv: procedure(sampler: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glQueryCounter: procedure(id: TGLuint; target: Cardinal); stdcall;

GL_ARB_timer_query (ARB #85)

glGetQueryObjecti64v: procedure(id: TGLuint; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

glGetQueryObjectui64v: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64); stdcall;

This item has no description.

glVertexP2ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

glVertexP2uiv: procedure(_type: Cardinal; const value: PGLuint ); stdcall;

This item has no description.

glVertexP3ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

This item has no description.

glVertexP3uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

glVertexP4ui: procedure(_type: Cardinal; value: TGLuint); stdcall;

This item has no description.

glVertexP4uiv: procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

glTexCoordP1ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP1uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP2ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP2uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glTexCoordP4ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glTexCoordP4uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP1ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP1uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP2ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP2uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP3ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP3uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glMultiTexCoordP4ui: procedure(texture: Cardinal; _type: GLenum; coords: TGLuint); stdcall;

This item has no description.

glMultiTexCoordP4uiv: procedure(texture: Cardinal; _type: GLenum; const coords: PGLuint); stdcall;

This item has no description.

glNormalP3ui: procedure(_type: Cardinal; coords: TGLuint); stdcall;

This item has no description.

glNormalP3uiv: procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

glColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glColorP4ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glColorP4uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glSecondaryColorP3ui: procedure(_type: Cardinal; color: TGLuint); stdcall;

This item has no description.

glSecondaryColorP3uiv: procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

glVertexAttribP1ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP1uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP2ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP2uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP3ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP3uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glVertexAttribP4ui: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; value: TGLuint); stdcall;

This item has no description.

glVertexAttribP4uiv: procedure(index: TGLuint; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

glDrawArraysIndirect: procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

GL_ARB_draw_indirect (ARB #87)

glDrawElementsIndirect: procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

This item has no description.

glUniform1d: procedure(location: TGLint; x: TGLdouble); stdcall;

GL_ARB_gpu_shader_fp64 (ARB #89)

glUniform2d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glUniform3d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glUniform4d: procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glUniform1dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform2dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform3dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniform4dv: procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix2x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix3x4dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4x2dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glUniformMatrix4x3dv: procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glGetUniformdv: procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

This item has no description.

glProgramUniform1dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

glProgramUniformXXX only valid if EXT_direct_state_access is available

glProgramUniform2dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glProgramUniform3dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glProgramUniform4dEXT: procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glProgramUniform1dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniform4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix2x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix3x4dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4x2dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glProgramUniformMatrix4x3dvEXT: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

glGetSubroutineUniformLocation: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLint; stdcall;

GL_ARB_shader_subroutine (ARB #90)

glGetSubroutineIndex: function(_program: TGLuint; shadertype: Cardinal; const name: PGLchar): TGLuint; stdcall;

This item has no description.

glGetActiveSubroutineUniformiv: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

glGetActiveSubroutineUniformName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

This item has no description.

glGetActiveSubroutineName: procedure(_program: TGLuint; shadertype: Cardinal; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

This item has no description.

glUniformSubroutinesuiv: procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

This item has no description.

glGetUniformSubroutineuiv: procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glGetProgramStageiv: procedure(_program: TGLuint; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

glPatchParameteri: procedure(pname: Cardinal; value: TGLint); stdcall;

GL_ARB_tessellation_shader (ARB #91)

glPatchParameterfv: procedure(pname: Cardinal; const values: PGLfloat); stdcall;

This item has no description.

glBindTransformFeedback: procedure(target: Cardinal; id: TGLuint); stdcall;

GL_ARB_transform_feedback2 (ARB #93)

glDeleteTransformFeedbacks: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glGenTransformFeedbacks: procedure(n: TGLsizei; ids: PGLuint); stdcall;

This item has no description.

glIsTransformFeedback: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glPauseTransformFeedback: procedure(); stdcall;

This item has no description.

glResumeTransformFeedback: procedure(); stdcall;

This item has no description.

glDrawTransformFeedback: procedure(mode: Cardinal; id: TGLuint); stdcall;

This item has no description.

glDrawTransformFeedbackStream: procedure(mode: Cardinal; id: TGLuint; stream: TGLuint); stdcall;

GL_ARB_transform_feedback3 (ARB #94)

glBeginQueryIndexed: procedure(target: Cardinal; index: TGLuint; id: TGLuint); stdcall;

This item has no description.

glEndQueryIndexed: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glGetQueryIndexediv: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glArrayElementArrayEXT: procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions

glAddSwapHintRectWIN: procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

GL_WIN_swap_hint (extension # not found)

glBlendColorEXT: procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

GL_EXT_blend_color (EXT #2)

glPolygonOffsetEXT: procedure(factor, bias: Single); stdcall;

GL_EXT_polygon_offset (EXT #3)

glTexImage3DEXT: procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

GL_EXT_texture3D (EXT #6)

glTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

GL_EXT_subtexture (EXT #9)

glTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

glCopyTexImage1DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

GL_EXT_copy_texture (EXT #10)

glCopyTexImage2DEXT: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

This item has no description.

glCopyTexSubImage1DEXT: procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

This item has no description.

glCopyTexSubImage2DEXT: procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

glCopyTexSubImage3DEXT: procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

glGenTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

GL_EXT_texture_object (EXT #20)

glDeleteTexturesEXT: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

glBindTextureEXT: procedure(target: Cardinal; texture: TGLuint); stdcall;

This item has no description.

glPrioritizeTexturesEXT: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

This item has no description.

glAreTexturesResidentEXT: function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

This item has no description.

glIsTextureEXT: function(texture: TGLuint): TGLboolean; stdcall;

This item has no description.

glSampleMaskSGIS: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_SGIS_multisample (EXT #25)

glSamplePatternSGIS: procedure(pattern: Cardinal); stdcall;

This item has no description.

glBlendEquationEXT: procedure(mode: Cardinal); stdcall;

GL_EXT_blend_minmax (EXT #37)

glColorTableEXT: procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

GL_EXT_paletted_texture (EXT #78)

glColorSubTableExt: procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

glGetColorTableEXT: procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIndexMaterialEXT: procedure(face: Cardinal; mode: Cardinal); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)

glIndexFuncEXT: procedure(func: Cardinal; ref: Single); stdcall;

GL_EXT_index_func (EXT #95)

glLockArraysEXT: procedure(first: TGLint; count: TGLsizei); stdcall;

GL_EXT_compiled_vertex_array (EXT #97)

glUnlockArraysEXT: procedure; stdcall;

This item has no description.

glDrawRangeElementsEXT: procedure(mode: Cardinal; start, Aend: TGLuint; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

GL_EXT_draw_range_elements (EXT #112)

glBeginSceneEXT: procedure; stdcall;

GL_EXT_scene_marker (EXT #120)

glEndSceneEXT: procedure; stdcall;

This item has no description.

glSecondaryColor3bEXT: procedure(red, green, blue: TGLbyte); stdcall;

GL_EXT_secondary_color (EXT #145)

glSecondaryColor3bvEXT: procedure(v: PGLbyte); stdcall;

This item has no description.

glSecondaryColor3dEXT: procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

glSecondaryColor3dvEXT: procedure(v: PGLdouble); stdcall;

This item has no description.

glSecondaryColor3fEXT: procedure(red, green, blue: Single); stdcall;

This item has no description.

glSecondaryColor3fvEXT: procedure(v: PGLfloat); stdcall;

This item has no description.

glSecondaryColor3iEXT: procedure(red, green, blue: TGLint); stdcall;

This item has no description.

glSecondaryColor3ivEXT: procedure(v: PGLint); stdcall;

This item has no description.

glSecondaryColor3sEXT: procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

glSecondaryColor3svEXT: procedure(v: PGLshort); stdcall;

This item has no description.

glSecondaryColor3ubEXT: procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

glSecondaryColor3ubvEXT: procedure(v: PGLubyte); stdcall;

This item has no description.

glSecondaryColor3uiEXT: procedure(red, green, blue: TGLuint); stdcall;

This item has no description.

glSecondaryColor3uivEXT: procedure(v: PGLuint); stdcall;

This item has no description.

glSecondaryColor3usEXT: procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

glSecondaryColor3usvEXT: procedure(v: PGLushort); stdcall;

This item has no description.

glSecondaryColorPointerEXT: procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

This item has no description.

glMultiDrawArraysEXT: procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_multi_draw_arrays (EXT #148)

glMultiDrawElementsEXT: procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

glFogCoordfEXT: procedure(coord: Single); stdcall;

GL_EXT_fog_coord (EXT #149)

glFogCoordfvEXT: procedure(coord: PGLfloat); stdcall;

This item has no description.

glFogCoorddEXT: procedure(coord: TGLdouble); stdcall;

This item has no description.

glFogCoorddvEXT: procedure(coord: PGLdouble); stdcall;

This item has no description.

glFogCoordPointerEXT: procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

This item has no description.

glBlendFuncSeparateEXT: procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

GL_EXT_blend_func_separate (EXT #173)

glFlushVertexArrayRangeNV: procedure; stdcall;

GL_NV_vertex_array_range (EXT #190)

glVertexArrayRangeNV: procedure(Size: TGLsizei; p: pointer); stdcall;

This item has no description.

wglAllocateMemoryNV: function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

This item has no description.

wglFreeMemoryNV: procedure(ptr: Pointer); stdcall;

This item has no description.

glCombinerParameterfvNV: procedure(pname: Cardinal; params: PGLfloat); stdcall;

GL_NV_register_combiners (EXT #191)

glCombinerParameterfNV: procedure(pname: Cardinal; param: Single); stdcall;

This item has no description.

glCombinerParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glCombinerParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

glCombinerInputNV: procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

glCombinerOutputNV: procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

This item has no description.

glFinalCombinerInputNV: procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

glGetCombinerInputParameterfvNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetCombinerInputParameterivNV: procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetCombinerOutputParameterfvNV: procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetCombinerOutputParameterivNV: procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetFinalCombinerInputParameterfvNV: procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetFinalCombinerInputParameterivNV: procedure(variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glResizeBuffersMESA: procedure; stdcall;

GL_MESA_resize_buffers (EXT #196)

glTbufferMask3DFX: procedure(mask: TGLuint); stdcall;

GL_3DFX_tbuffer (EXT #208)

glSampleMaskEXT: procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

GL_EXT_multisample (EXT #209)

glSamplePatternEXT: procedure(pattern: Cardinal); stdcall;

This item has no description.

glTextureColorMaskSGIS: procedure(red, green, blue, alpha: TGLboolean); stdcall;

GL_SGIS_texture_color_mask (EXT #214)

glGenFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

GL_NV_fence (EXT #222)

glDeleteFencesNV: procedure(n: TGLsizei; fences: PGLuint); stdcall;

This item has no description.

glSetFenceNV: procedure(fence: TGLuint; condition: Cardinal); stdcall;

This item has no description.

glTestFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

This item has no description.

glFinishFenceNV: procedure(fence: TGLuint); stdcall;

This item has no description.

glIsFenceNV: function(fence: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetFenceivNV: procedure(fence: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glAreProgramsResidentNV: procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

GL_NV_vertex_program (EXT #233)

glBindProgramNV: procedure(target: Cardinal; id: TGLuint); stdcall;

This item has no description.

glDeleteProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glExecuteProgramNV: procedure(target: Cardinal; id: TGLuint; params: PGLfloat); stdcall;

This item has no description.

glGenProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glGetProgramParameterdvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetProgramParameterfvNV: procedure(target: Cardinal; index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetProgramivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetProgramStringNV: procedure(id: TGLuint; pname: Cardinal; programIdx: PGLubyte); stdcall;

This item has no description.

glGetTrackMatrixivNV: procedure(target: Cardinal; address: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribdvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

glGetVertexAttribfvNV: procedure(index: TGLuint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

glGetVertexAttribivNV: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribPointervNV: procedure(index: TGLuint; pname: Cardinal; pointer: PGLPointer); stdcall;

This item has no description.

glIsProgramNV: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glLoadProgramNV: procedure(target: Cardinal; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

This item has no description.

glProgramParameter4dNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

This item has no description.

glProgramParameter4dvNV: procedure(target: Cardinal; index: TGLuint; v: PGLdouble ); stdcall;

This item has no description.

glProgramParameter4fNV: procedure(target: Cardinal; index: TGLuint; x, y, z, w: Single); stdcall;

This item has no description.

glProgramParameter4fvNV: procedure(target: Cardinal; index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glProgramParameters4dvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glProgramParameters4fvNV: procedure(target: Cardinal; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glRequestResidentProgramsNV: procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

glTrackMatrixNV: procedure(target: Cardinal; address: TGLuint; matrix: Cardinal; transform: Cardinal); stdcall;

This item has no description.

glVertexAttribPointerNV: procedure(index: TGLuint; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

This item has no description.

glVertexAttrib1dNV: procedure(index: TGLuint; x: TGLdouble); stdcall;

This item has no description.

glVertexAttrib1dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib1fNV: procedure(index: TGLuint; x: Single); stdcall;

This item has no description.

glVertexAttrib1fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib1sNV: procedure(index: TGLuint; x: TGLshort); stdcall;

This item has no description.

glVertexAttrib1svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib2dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

glVertexAttrib2dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib2fNV: procedure(index: TGLuint; x: Single; y: Single); stdcall;

This item has no description.

glVertexAttrib2fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib2sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

glVertexAttrib2svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib3dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

glVertexAttrib3dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib3fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single); stdcall;

This item has no description.

glVertexAttrib3fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib3sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

glVertexAttrib3svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4dNV: procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

glVertexAttrib4dvNV: procedure(index: TGLuint; v: PGLdouble); stdcall;

This item has no description.

glVertexAttrib4fNV: procedure(index: TGLuint; x: Single; y: Single; z: Single; w: Single); stdcall;

This item has no description.

glVertexAttrib4fvNV: procedure(index: TGLuint; v: PGLfloat); stdcall;

This item has no description.

glVertexAttrib4sNV: procedure(index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

This item has no description.

glVertexAttrib4svNV: procedure(index: TGLuint; v: PGLshort); stdcall;

This item has no description.

glVertexAttrib4ubvNV: procedure(index: TGLuint; v: PGLubyte); stdcall;

This item has no description.

glVertexAttribs1dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs1fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs1svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs2dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs2fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs2svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs3dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs3fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs3svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs4dvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

glVertexAttribs4fvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

glVertexAttribs4svNV: procedure(index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

glVertexAttribs4ubvNV: procedure(index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

This item has no description.

glGenOcclusionQueriesNV: procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_NV_occlusion_query (EXT #261)

glDeleteOcclusionQueriesNV: procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

glIsOcclusionQueryNV: function(id: TGLuint): TGLboolean; stdcall;

This item has no description.

glBeginOcclusionQueryNV: procedure(id: TGLuint); stdcall;

This item has no description.

glEndOcclusionQueryNV: procedure; stdcall;

This item has no description.

glGetOcclusionQueryivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetOcclusionQueryuivNV: procedure(id: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glPointParameteriNV: procedure(pname: Cardinal; param: TGLint); stdcall;

GL_NV_point_sprite (EXT #262)

glPointParameterivNV: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glActiveStencilFaceEXT: procedure(face: Cardinal); stdcall;

GL_EXT_stencil_two_side (EXT #268)

glDrawBuffersATI: procedure(n: GLsizei; const bufs: PGLenum); stdcall;

GL_ATI_draw_buffers (EXT #277)

glPrimitiveRestartNV: procedure(); stdcall;

GL_NV_primitive_restart (EXT #285)

glPrimitiveRestartIndexNV: procedure(index: TGLuint); stdcall;

This item has no description.

glDepthBoundsEXT: procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

GL_EXT_depth_bounds_test (EXT #297)

glBlendEquationSeparateEXT: procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

GL_EXT_blend_equation_separate (EXT #299)

glIsRenderbufferEXT: function(renderbuffer: TGLuint): TGLboolean; stdcall;

GL_EXT_framebuffer_object (EXT #310)

glBindRenderbufferEXT: procedure(target: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glDeleteRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glGenRenderbuffersEXT: procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

glRenderbufferStorageEXT: procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

glGetRenderbufferParameterivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glIsFramebufferEXT: function(framebuffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindFramebufferEXT: procedure(target: Cardinal; framebuffer: TGLuint); stdcall;

This item has no description.

glDeleteFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glGenFramebuffersEXT: procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

glCheckFramebufferStatusEXT: function(target: Cardinal): Cardinal; stdcall;

This item has no description.

glFramebufferTexture1DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture2DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint); stdcall;

This item has no description.

glFramebufferTexture3DEXT: procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

glFramebufferRenderbufferEXT: procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: TGLuint); stdcall;

This item has no description.

glGetFramebufferAttachmentParameterivEXT: procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGenerateMipmapEXT: procedure(target: Cardinal); stdcall;

This item has no description.

glStencilClearTagEXT: procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

GL_EXT_stencil_clear_tag (EXT #314)

glBlitFramebufferEXT: procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

GL_EXT_framebuffer_blit (#316)

glRenderbufferStorageMultisampleEXT: procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

GL_EXT_framebuffer_multisample (#317)

glGetQueryObjecti64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLint64EXT); stdcall;

GL_EXT_timer_query (#319)

glGetQueryObjectui64vEXT: procedure(id: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

glProgramEnvParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

GL_EXT_gpu_program_parameters (EXT #320)

glProgramLocalParameters4fvEXT: procedure(target:Cardinal; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

This item has no description.

glProgramVertexLimitNV: procedure(target: Cardinal; limit: TGLint); stdcall;

GL_NV_geometry_program4 (EXT #323)

glProgramParameteriEXT: procedure( _program:TGLuint; pname:Cardinal; value: TGLint); stdcall;

GL_EXT_geometry_shader4 (EXT #324)

glFramebufferTextureEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint); stdcall;

This item has no description.

glFramebufferTextureLayerEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

This item has no description.

glFramebufferTextureFaceEXT: procedure( target:Cardinal; attachment:Cardinal; texture:TGLuint; level:TGLint; face:Cardinal); stdcall;

This item has no description.

glVertexAttribI1iEXT: procedure(index: TGLuint; x: TGLint); stdcall;

GL_EXT_gpu_shader4 (EXT #326)

glVertexAttribI2iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

This item has no description.

glVertexAttribI3iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

glVertexAttribI4iEXT: procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

glVertexAttribI1uiEXT: procedure(index: TGLuint; x: TGLuint); stdcall;

This item has no description.

glVertexAttribI2uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

This item has no description.

glVertexAttribI3uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

This item has no description.

glVertexAttribI4uiEXT: procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

This item has no description.

glVertexAttribI1ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI2ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI3ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI4ivEXT: procedure(index: TGLuint; v:PGLint); stdcall;

This item has no description.

glVertexAttribI1uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI2uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI3uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4uivEXT: procedure(index: TGLuint; v:PGLuint); stdcall;

This item has no description.

glVertexAttribI4bvEXT: procedure(index: TGLuint; v:PGLbyte); stdcall;

This item has no description.

glVertexAttribI4svEXT: procedure(index: TGLuint; v:PGLshort); stdcall;

This item has no description.

glVertexAttribI4ubvEXT: procedure(index: TGLuint; v: PGLUbyte); stdcall;

This item has no description.

glVertexAttribI4usvEXT: procedure(index: TGLuint; v: PGLushort); stdcall;

This item has no description.

glVertexAttribIPointerEXT: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

glGetVertexAttribIivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetVertexAttribIuivEXT: procedure(index: TGLuint; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glUniform1uiEXT: procedure(location: TGLInt; v0: TGLuint); stdcall;

This item has no description.

glUniform2uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

This item has no description.

glUniform3uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

This item has no description.

glUniform4uiEXT: procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

This item has no description.

glUniform1uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform2uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform3uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glUniform4uivEXT: procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

glGetUniformuivEXT: procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

This item has no description.

glBindFragDataLocationEXT: procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetFragDataLocationEXT: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glDrawArraysInstancedEXT: procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_draw_instanced (#327)

glDrawElementsInstancedEXT: procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

glTexBufferEXT: procedure(target: Cardinal; internalformat: Cardinal; buffer: TGLuint); stdcall;

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)

glColorMaskIndexedEXT: procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

GL_EXT_draw_buffers2 (#340)

glGetBooleanIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLboolean); stdcall;

This item has no description.

glGetIntegerIndexedvEXT: procedure(value: Cardinal; index: TGLuint; data: PGLint); stdcall;

This item has no description.

glEnableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glDisableIndexedEXT: procedure(target: Cardinal; index: TGLuint); stdcall;

This item has no description.

glIsEnabledIndexedEXT: function(target: Cardinal; index: TGLuint): TGLboolean; stdcall;

This item has no description.

glBindBufferRangeNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_NV_transform_feedback (#341)

glBindBufferOffsetNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

This item has no description.

glBindBufferBaseNV: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glTransformFeedbackAttribsNV: procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

glTransformFeedbackVaryingsNV: procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

glBeginTransformFeedbackNV: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedbackNV: procedure(); stdcall;

This item has no description.

glGetVaryingLocationNV: function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

This item has no description.

glGetActiveVaryingNV: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PGLChar); stdcall;

This item has no description.

glActiveVaryingNV: procedure(_program: TGLuint; name: PGLChar); stdcall;

This item has no description.

glGetTransformFeedbackVaryingNV: procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

This item has no description.

glUniformBufferEXT: procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

GL_EXT_bindable_uniform (#342)

glGetUniformBufferSizeEXT: function(_program: TGLuint; location: TGLint): TGLint; stdcall;

This item has no description.

glGetUniformOffsetEXT: function(_program: TGLuint; location: TGLint): PGLint; stdcall;

This item has no description.

glClearColorIiEXT: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

GL_EXT_texture_integer (#343)

glClearColorIuiEXT: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

This item has no description.

glTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glGetTexParameterIivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

glGetTexParameterIuivEXT: procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

glBeginConditionalRenderNV: procedure(id: TGLuint; mode: Cardinal); stdcall;

GL_NV_conditional_render (#346)

glEndConditionalRenderNV: procedure(); stdcall;

This item has no description.

glBindBufferRangeEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

GL_EXT_transform_feedback (#352)

glBindBufferOffsetEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

This item has no description.

glBindBufferBaseEXT: procedure(target: Cardinal; index: TGLuint; buffer: TGLuint); stdcall;

This item has no description.

glBeginTransformFeedbackEXT: procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

glEndTransformFeedbackEXT: procedure(); stdcall;

This item has no description.

glTransformFeedbackVaryingsEXT: procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

glGetTransformFeedbackVaryingEXT: procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

This item has no description.

glTessellationFactorAMD: procedure(factor: Single); stdcall;

GL_AMD_vertex_shader_tessellator (#363)

glTessellationModeAMD: procedure(mode: Cardinal); stdcall;

This item has no description.

glCopyImageSubDataNV: procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

GL_NV_copy_image (#376)

glMakeBufferResidentNV: procedure(target: Cardinal; access: Cardinal); stdcall;

GL_NV_shader_buffer_load (#379)

glMakeBufferNonResidentNV: procedure(target: Cardinal); stdcall;

This item has no description.

glIsBufferResidentNV: function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

glMakeNamedBufferResidentNV: procedure(buffer: TGLuint; access: Cardinal); stdcall;

This item has no description.

glMakeNamedBufferNonResidentNV: procedure(buffer: TGLuint); stdcall;

This item has no description.

glIsNamedBufferResidentNV: function(buffer: TGLuint): TGLboolean; stdcall;

This item has no description.

glGetBufferParameterui64vNV: procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

This item has no description.

glGetNamedBufferParameterui64vNV: procedure(buffer: TGLuint; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

glGetIntegerui64vNV: procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

glUniformui64NV: procedure(location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

glUniformui64vNV: procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

glGetUniformui64vNV: procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

This item has no description.

glProgramUniformui64NV: procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

glProgramUniformui64vNV: procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

glBufferAddressRangeNV: procedure(pname: Cardinal; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

GL_NV_vertex_buffer_unified_memory (#380)

glVertexFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glNormalFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glIndexFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glTexCoordFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glEdgeFlagFormatNV: procedure(stride: TGLsizei); stdcall;

This item has no description.

glSecondaryColorFormatNV: procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glFogCoordFormatNV: procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glVertexAttribFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

This item has no description.

glVertexAttribIFormatNV: procedure(index: TGLuint; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

glGetIntegerui64i_vNV: procedure(value: Cardinal; index: TGLuint; result: PGLuint64EXT); stdcall;

This item has no description.

glFrameTerminatorGREMEDY: procedure(); stdcall;

Special Gremedy debugger extension

glStringMarkerGREMEDY: procedure(len: GLsizei; str: PGLChar); stdcall;

This item has no description.

vIgnoreOpenGLErrors: Boolean = false;

Raises an EOpenGLError with 'msg' error string


GXSysHelp v.2.5: GLScene.OpenGL4: Packed Record _WGLSWAP

Packed Record _WGLSWAP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type _WGLSWAP = packed record

Description

This item has no description.

Overview

Fields

Public | hdc: HDC;
Public | uiFlags: UINT;

Description

Fields

Public hdc: HDC;

This item has no description.

Public uiFlags: UINT;


GXSysHelp v.2.5: GLScene.OpenGL4: Record TGPUDEVICE

Record TGPUDEVICE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGPUDEVICE = record

Description

This item has no description.

Overview

Fields

Public | cb: Cardinal;
Public | DeviceName: array [0 .. 31] of AnsiChar;
Public | DeviceString: array [0 .. 127] of AnsiChar;
Public | Flags: Cardinal;
Public | rcVirtualScreen: TRect;

Description

Fields

Public cb: Cardinal;

This item has no description.

Public DeviceName: array [0 .. 31] of AnsiChar;

This item has no description.

Public DeviceString: array [0 .. 127] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public rcVirtualScreen: TRect;


GXSysHelp v.2.5: GLScene.OpenGL4: Record TGLUNurbs

Record TGLUNurbs

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUNurbs = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: GLScene.OpenGL4: Record TGLUQuadric

Record TGLUQuadric

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUQuadric = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: GLScene.OpenGL4: Record TGLUTesselator

Record TGLUTesselator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type TGLUTesselator = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: GLScene.OpenGL4: Class EOpenGLError

Class EOpenGLError

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGL4

Declaration

type EOpenGLError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EOpenGLError


GXSysHelp v.2.5: GLScene.OpenGLTokens

Unit GLScene.OpenGLTokens

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGLext
  • System.SysUtils
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record _WGLSWAP |
Record TGPUDEVICE |
Record TGLUNurbs |
Record TGLUQuadric |
Record TGLUTesselator |

Types

HGPUNV = THandle;
HPBUFFERARB = type UINT_PTR;
HVIDEOINPUTDEVICENV = THandle;
PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: Cardinal; _program: Cardinal); stdcall;
PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: Cardinal); stdcall;
PFNGLACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;
PFNGLACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;
PFNGLACTIVEVARYINGNVPROC = procedure(_program: Cardinal; name: PAnsiChar); stdcall;
PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;
PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;
PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;
PFNGLATTACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; obj: TGLhandleARB); stdcall;
PFNGLATTACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;
PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;
PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;
PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: Cardinal); stdcall;
PFNGLBEGINQUERYARBPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINQUERYPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBEGINSCENEEXTPROC = procedure; stdcall;
PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: Cardinal); stdcall;
PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDBUFFERARBPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERBASEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr); stdcall;
PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr); stdcall;
PFNGLBINDBUFFERPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;
PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBINDBUFFERRANGENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBINDBUFFERRANGEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLBindBuffersBase = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLUint); stdcall;
PFNGLBindBuffersRange = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLuint; const offsets : TGLintptr; const sizes : TGLsizeiptr); stdcall;
PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;
PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: Cardinal; colorNumber: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;
PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;
PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;
PFNGLBINDFRAMEBUFFERPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;
PFNGLBindImageTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;
PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: Cardinal; target: Cardinal; texture: Cardinal); stdcall;
PFNGLBINDPROGRAMARBPROC = procedure(target: Cardinal; _program: Cardinal); stdcall;
PFNGLBINDPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;
PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLBINDRENDERBUFFERPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLBINDSAMPLERPROC = procedure(_unit: Cardinal; sampler: Cardinal); stdcall;
PFNGLBindSamplers = procedure(first : Cardinal; count : TGLsizei; const samplers : PGLuint); stdcall;
PFNGLBINDTEXTUREEXTPROC = procedure(target: Cardinal; texture: Cardinal); stdcall;
PFNGLBindTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;
PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: Cardinal; id: Cardinal); stdcall;
PFNGLBINDVERTEXARRAYPROC = procedure(_array: Cardinal); stdcall;
PFNGLBindVertexBuffer = procedure(bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;
PFNGLBindVertexBuffers = procedure(first : Cardinal; count : TGLsizei; const buffers : Cardinal; const offsets : TGLintptr; const strides : PGLsizei); stdcall;
PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: Single; alpha: Single); stdcall;
PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: Single); stdcall;
PFNGLBLENDEQUATIONEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONIARBPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONIPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONPROC = procedure(mode: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCIARBPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;
PFNGLBLENDFUNCIPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;
PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;
PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;
PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;
PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: Cardinal; index: Cardinal; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;
PFNGLBUFFERDATAARBPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;
PFNGLBUFFERDATAPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;
PFNGLBufferStorage = procedure(target : Cardinal; size : TGLsizeiptr; const data : pointer; flags : TGLbitfield); stdcall;
PFNGLBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;
PFNGLBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;
PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: Cardinal): Cardinal; stdcall;
PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: Cardinal): Cardinal; stdcall;
PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: Cardinal; target: Cardinal): Cardinal; stdcall;
PFNGLCLAMPCOLORARBPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;
PFNGLCLAMPCOLORPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;
PFNGLClearBufferData = procedure(target : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLCLEARBUFFERFIPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;
PFNGLCLEARBUFFERFVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;
PFNGLCLEARBUFFERIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;
PFNGLClearBufferSubData = procedure(target : Cardinal; internalformat : Cardinal; offset : TGLintptr; size : TGLsizeiptr; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLCLEARBUFFERUIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;
PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;
PFNGLCLEARCOLORIUIEXTPROC = procedure(r: Cardinal; g: Cardinal; b: Cardinal; a: Cardinal); stdcall;
PFNGLCLEARDEPTHFPROC = procedure(depth: TGLclampd); stdcall;
PFNGLClearNamedBufferData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;
PFNGLClearNamedBufferSubData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; offset : TGLsizeiptr; size : TGLsizeiptr; const data : Pointer); stdcall;
PFNGLClearTexImage = procedure(texture : Cardinal; level : TGLint; format : Cardinal; _type : Cardinal; const data : Pointer); stdcall;
PFNGLClearTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei; format : Cardinal; _type : Cardinal; const Data : Pointer); stdcall;
PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;
PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;
PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;
PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;
PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;
PFNGLCOLORMASKIPROC = procedure(index: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;
PFNGLCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLCOLORP4UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLCOLORP4UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLCOLORSUBTABLEEXTPROC = procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORSUBTABLEPROC = procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;
PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLCOLORTABLEPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;
PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;
PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;
PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: TGLhandleARB); stdcall;
PFNGLCOMPILESHADERPROC = procedure(shader: Cardinal); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;
PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;
PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;
PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: Cardinal; param: TGLint); stdcall;
PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCopyImageSubData = procedure(srcName : Cardinal; srcTarget : Cardinal; srcLevel : TGLint; srcX : TGLint; srcY : TGLint; srcZ : TGLint; dstName : Cardinal; dstTarget : Cardinal; dstLevel : TGLint; dstX : TGLint; dstY : TGLint; dstZ : TGLint; srcWidth : TGLsizei; srcHeight : TGLsizei; srcDepth : TGLsizei); stdcall;
PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: Cardinal; srcTarget: Cardinal; srcLevel: TGLint; srcX: TGLint; srcY: TGLint; srcZ: TGLint; dstName: Cardinal; dstTarget: Cardinal; dstLevel: TGLint; dstX: TGLint; dstY: TGLint; dstZ: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei); stdcall;
PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYPATHNVPROC = procedure (resultPath: Cardinal; srcPath: Cardinal); stdcall;
PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;
PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;
PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;
PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLCOVERFILLPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;
PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLCOVERSTROKEPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;
PFNGLCREATEPROGRAMOBJECTARBPROC = function(): TGLhandleARB; stdcall;
PFNGLCREATEPROGRAMPROC = function(): Cardinal; stdcall;
PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: Cardinal): TGLhandleARB; stdcall;
PFNGLCREATESHADERPROC = function(_type: Cardinal): Cardinal; stdcall;
PFNGLCREATESHADERPROGRAMVPROC = function(_type: Cardinal; count: TGLsizei; const strings: PGLPCharArray): Cardinal; stdcall;
PFNGLCreateSyncFromCLevent = function(context: p_cl_context; event: p_cl_event; flags: TGLbitfield): TGLsync; stdcall;
PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;
PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;
PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: Cardinal; _type: Cardinal; severity: Cardinal; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;
PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: Cardinal; _type: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; buf: PAnsiChar); stdcall;
PFNGLDELETEBUFFERSARBPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;
PFNGLDELETEBUFFERSPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;
PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;
PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLDELETEOBJECTARBPROC = procedure(obj: TGLhandleARB); stdcall;
PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEPATHSNVPROC = procedure(path: Cardinal; range: TGLsizei); stdcall;
PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;
PFNGLDELETEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLDELETEPROGRAMSARBPROC = procedure(n: TGLsizei; const programs: PGLuint); stdcall;
PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;
PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;
PFNGLDELETESHADERPROC = procedure(shader: Cardinal); stdcall;
PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;
PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;
PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;
PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;
PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;
PFNGLDEPTHRANGEARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLclampd); stdcall;
PFNGLDEPTHRANGEFPROC = procedure(n: Single; f: Single); stdcall;
PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: Cardinal; n: TGLclampd; f: TGLclampd); stdcall;
PFNGLDETACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; attachedObj: TGLhandleARB); stdcall;
PFNGLDETACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;
PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;
PFNGLDISABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLDISABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;
PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;
PFNGLDispatchCompute = procedure(num_groups_x : Cardinal; num_groups_y : Cardinal; num_groups_z : Cardinal); stdcall;
PFNGLDispatchComputeIndirect = procedure(indirect : TGLintptr); stdcall;
PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;
PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;
PFNGLDRAWBUFFERSARBPROC = procedure (n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWBUFFERSATIPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWBUFFERSPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;
PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;
PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;
PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;
PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; start: Cardinal; _end: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;
PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: Cardinal; start, Aend: Cardinal; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;
PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: Cardinal; Astart, Aend: Cardinal; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;
PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: Cardinal; id: Cardinal); stdcall;
PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: Cardinal; id: Cardinal; stream: Cardinal); stdcall;
PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;
PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;
PFNGLENABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;
PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;
PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;
PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;
PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;
PFNGLENDQUERYARBPROC = procedure(target: Cardinal); stdcall;
PFNGLENDQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal); stdcall;
PFNGLENDQUERYPROC = procedure(target: Cardinal); stdcall;
PFNGLENDSCENEEXTPROC = procedure; stdcall;
PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;
PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;
PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLEXECUTEPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal; params: PGLfloat); stdcall;
PFNGLFENCESYNCPROC = function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;
PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;
PFNGLFINISHFENCENVPROC = procedure(fence: Cardinal); stdcall;
PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;
PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr); stdcall;
PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;
PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;
PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;
PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;
PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;
PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;
PFNGLFOGCOORDFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;
PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;
PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;
PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;
PFNGLFOGCOORDPOINTERPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;
PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;
PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: Cardinal; n: TGLsizei; const bufs: PCardinal); stdcall;
PFNGLFramebufferParameteri = procedure(target : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;
PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;
PFNGLGENBUFFERSARBPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;
PFNGLGENBUFFERSPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;
PFNGLGENERATEMIPMAPEXTPROC = procedure(target: Cardinal); stdcall;
PFNGLGENERATEMIPMAPPROC = procedure(target: Cardinal); stdcall;
PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: Cardinal; target: Cardinal); stdcall;
PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: Cardinal; target: Cardinal); stdcall;
PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;
PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;
PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENPATHSNVPROC = function (range: TGLsizei): Cardinal; stdcall;
PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;
PFNGLGENPROGRAMSARBPROC = procedure(n: TGLsizei; programs: PGLuint); stdcall;
PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;
PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;
PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;
PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;
PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;
PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;
PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;
PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEATTRIBPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;
PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; pname: Cardinal; values: PGLint); stdcall;
PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: Cardinal; uniformIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformName: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PAnsiChar); stdcall;
PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: TGLhandleARB; maxCount: TGLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;
PFNGLGETATTACHEDSHADERSPROC = procedure(_program: Cardinal; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;
PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETATTRIBLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLboolean); stdcall;
PFNGLGETBOOLEANI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLboolean); stdcall;
PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;
PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;
PFNGLGETBUFFERPOINTERVPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;
PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;
PFNGLGETBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;
PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: Cardinal; data: Pointer); stdcall;
PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;
PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;
PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;
PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;
PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;
PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;
PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: Cardinal; bufsize: TGLsizei; sources: PCardinal; types: PCardinal; ids: PGLuint; severities: PCardinal; lengths: PGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;
PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLdouble); stdcall;
PFNGLGETDOUBLEI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLdouble); stdcall;
PFNGLGETFENCEIVNVPROC = procedure(fence: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLfloat); stdcall;
PFNGLGETFLOATI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLfloat); stdcall;
PFNGLGETFRAGDATAINDEXPROC = function (_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAGDATALOCATIONPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetFramebufferParameteriv = procedure(target : Cardinal; pname : Cardinal; params : PGLint); stdcall;
PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): Cardinal; stdcall;
PFNGLGETHANDLEARBPROC = function(pname: Cardinal): TGLhandleARB; stdcall;
PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETHISTOGRAMPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;
PFNGLGETINFOLOGARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETINTEGER64I_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint64); stdcall;
PFNGLGETINTEGER64VPROC = procedure(pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLint); stdcall;
PFNGLGETINTEGERI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint); stdcall;
PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;
PFNGLGETINTEGERUI64VNVPROC = procedure(value: Cardinal; result: PGLuint64EXT); stdcall;
PFNGLGetInternalformati64v = procedure(target : Cardinal; internalformat : Cardinal; pname : Cardinal; bufSize : TGLsizei; params : PGLint64); stdcall;
PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMINMAXPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;
PFNGLGETMULTISAMPLEFVPROC = procedure(pname: Cardinal; index: Cardinal; val: PGLfloat); stdcall;
PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;
PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;
PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLvoid); stdcall;
PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; data: PGLvoid); stdcall;
PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetNamedFramebufferParameteriv = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLdouble); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLfloat); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLint); stdcall;
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLuint); stdcall;
PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; string_: PGLvoid); stdcall;
PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETNCOLORTABLEARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; table: Pointer); stdcall;
PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;
PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; image: Pointer); stdcall;
PFNGLGETNHISTOGRAMARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;
PFNGLGETNMAPDVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLdouble); stdcall;
PFNGLGETNMAPFVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLfloat); stdcall;
PFNGLGETNMAPIVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLint); stdcall;
PFNGLGETNMINMAXARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;
PFNGLGETNPIXELMAPFVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLfloat); stdcall;
PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLuint); stdcall;
PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLushort); stdcall;
PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;
PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;
PFNGLGETNTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; img: Pointer); stdcall;
PFNGLGETNUNIFORMDVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;
PFNGLGETNUNIFORMFVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;
PFNGLGETNUNIFORMIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;
PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;
PFNGLGetObjectLabel = procedure(identifier : Cardinal; name : Cardinal; bufsize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;
PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetObjectPtrLabel = procedure(const ptr : Pointer; bufSize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;
PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPATHCOMMANDSNVPROC = procedure (path: Cardinal; commands: PGLubyte); stdcall;
PFNGLGETPATHCOORDSNVPROC = procedure (path: Cardinal; coords: PGLfloat); stdcall;
PFNGLGETPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashArray: PGLfloat); stdcall;
PFNGLGETPATHLENGTHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei): TGLfloat; stdcall;
PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: TGLbitfield; firstPathName: Cardinal; numPaths: TGLsizei; stride: TGLsizei; metrics: PGLfloat); stdcall;
PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: TGLbitfield; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; stride: TGLsizei; metrics: PGLfloat); stdcall;
PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: Cardinal; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; advanceScale: TGLfloat; kerningScale: TGLfloat; transformType: Cardinal; returnedSpacing: PGLfloat); stdcall;
PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLvoid); stdcall;
PFNGLGETPROGRAMBINARYPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PCardinal; binary: Pointer); stdcall;
PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGetProgramInterfaceiv = procedure(program_ : Cardinal;programInterface : Cardinal; pname : Cardinal; params : PGLint); stdcall;
PFNGLGETPROGRAMIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMIVNVPROC = procedure (id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMIVPROC = procedure(_program: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGetProgramResourceIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : Cardinal; stdcall;
PFNGLGetProgramResourceiv = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; propCount : TGLsizei; const props : PCardinal; bufSize : TGLsizei; length : PGLsizei; params : PGLint); stdcall;
PFNGLGetProgramResourceLocation = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;
PFNGLGetProgramResourceLocationIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;
PFNGLGetProgramResourceName = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; bufSize : TGLsizei; length : PGLsizei; name : PAnsiChar); stdcall;
PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;
PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: Cardinal; pname: Cardinal; _string: pointer); stdcall;
PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: Cardinal; pname: Cardinal; programIdx: PGLubyte); stdcall;
PFNGLGETQUERYINDEXEDIVPROC = procedure(target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64EXT); stdcall;
PFNGLGETQUERYOBJECTI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64); stdcall;
PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;
PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64); stdcall;
PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETQUERYOBJECTUIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;
PFNGLGETSHADERINFOLOGPROC = procedure(shader: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;
PFNGLGETSHADERIVPROC = procedure(shader: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: Cardinal; precisiontype: Cardinal; range: PGLint; precision: PGLint); stdcall;
PFNGLGETSHADERSOURCEARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;
PFNGLGETSHADERSOURCEPROC = procedure(shader:Cardinal; bufSize: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;
PFNGLGETSTRINGIPROC = function(name: Cardinal; index: Cardinal): PAnsiChar; stdcall;
PFNGLGETSUBROUTINEINDEXPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): Cardinal; stdcall;
PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;
PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;
PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: TGLint); stdcall;
PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: Cardinal; address: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; location: PGLint); stdcall;
PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;
PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: Cardinal; uniformBlockName: PAnsiChar): Cardinal; stdcall;
PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: Cardinal; location: TGLint): TGLint; stdcall;
PFNGLGETUNIFORMDVPROC = procedure(_program: Cardinal; location: TGLint; params : PGLdouble); stdcall;
PFNGLGETUNIFORMFVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLfloat); stdcall;
PFNGLGETUNIFORMFVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLfloat); stdcall;
PFNGLGETUNIFORMINDICESPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;
PFNGLGETUNIFORMIVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLint); stdcall;
PFNGLGETUNIFORMIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLint); stdcall;
PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETUNIFORMLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;
PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: Cardinal; location: TGLint): PGLint; stdcall;
PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint64EXT); stdcall;
PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETUNIFORMUIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;
PFNGLGETVARYINGLOCATIONNVPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;
PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBDVPROC = procedure(index:Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBFVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;
PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: Cardinal; pname: Cardinal; _pointer: pointer); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: Cardinal; pname: Cardinal; pointer: PGLPointer); stdcall;
PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: Cardinal; pname: Cardinal; _pointer:pointer); stdcall;
PFNGLHISTOGRAMPROC = procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;
PFNGLINDEXFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLINDEXFUNCEXTPROC = procedure(func: Cardinal; ref: TGLfloat); stdcall;
PFNGLINDEXMATERIALEXTPROC = procedure(face: Cardinal; mode: Cardinal); stdcall;
PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: Cardinal; pathA: Cardinal; pathB: Cardinal; weight: TGLfloat); stdcall;
PFNGLInvalidateBufferData = procedure(buffer : Cardinal); stdcall;
PFNGLInvalidateBufferSubData = procedure(buffer : Cardinal; offset : TGLintptr; length : TGLsizeiptr); stdcall;
PFNGLInvalidateFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal); stdcall;
PFNGLInvalidateSubFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal; x : TGLint; y : TGLint; width : TGLsizei; height : TGLsizei); stdcall;
PFNGLInvalidateTexImage = procedure(texture : Cardinal; level : TGLint); stdcall;
PFNGLInvalidateTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei); stdcall;
PFNGLISBUFFERARBPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLISBUFFERPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLISBUFFERRESIDENTNVPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLISENABLEDINDEXEDEXTPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;
PFNGLISENABLEDIPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;
PFNGLISFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;
PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;
PFNGLISFRAMEBUFFERPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;
PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: Cardinal): TGLboolean; stdcall;
PFNGLISOCCLUSIONQUERYNVPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISPATHNVPROC = function(path: Cardinal): TGLboolean; stdcall;
PFNGLISPOINTINFILLPATHNVPROC = function (path: Cardinal; mask: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;
PFNGLISPOINTINSTROKEPATHNVPROC = function (path: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;
PFNGLISPROGRAMARBPROC = function(_program: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMNVPROC = function (id: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMPIPELINEPROC = function(pipeline: Cardinal): TGLboolean; stdcall;
PFNGLISPROGRAMPROC = function(_program: Cardinal):TGLboolean; stdcall;
PFNGLISQUERYARBPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISQUERYPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: Cardinal): TGLboolean; stdcall;
PFNGLISRENDERBUFFERPROC = function(renderbuffer: Cardinal): TGLBoolean; stdcall;
PFNGLISSAMPLERPROC = function(sampler: Cardinal): TGLboolean; stdcall;
PFNGLISSHADERPROC = function(shader: Cardinal): TGLboolean; stdcall;
PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;
PFNGLISTEXTUREEXTPROC = function(texture: Cardinal): TGLboolean; stdcall;
PFNGLISTRANSFORMFEEDBACKPROC = function(id: Cardinal): TGLboolean; stdcall;
PFNGLISVERTEXARRAYPROC = function(_array: Cardinal): TGLboolean; stdcall;
PFNGLLINKPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLLINKPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLLOADPROGRAMNVPROC = procedure (target: Cardinal; id: Cardinal; len: TGLSizei; programIdx: PGLubyte); stdcall;
PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;
PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;
PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;
PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;
PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;
PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: Cardinal); stdcall;
PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: Cardinal; access: Cardinal); stdcall;
PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: Cardinal); stdcall;
PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: Cardinal; access: Cardinal); stdcall;
PFNGLMAPBUFFERARBPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;
PFNGLMAPBUFFERPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;
PFNGLMAPBUFFERRANGEPROC = function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;
PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal; access: Cardinal): PGLvoid; stdcall;
PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr; access: TGLbitfield): PGLvoid; stdcall;
PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;
PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;
PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;
PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;
PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;
PFNGLMATRIXLOADDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXLOADFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXMULTDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXMULTFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;
PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;
PFNGLMATRIXORTHOEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;
PFNGLMATRIXPOPEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXPUSHEXTPROC = procedure(mode: Cardinal); stdcall;
PFNGLMATRIXROTATEDEXTPROC = procedure(mode: Cardinal; angle: TGLdouble; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXROTATEFEXTPROC = procedure(mode: Cardinal; angle: TGLfloat; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMATRIXSCALEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXSCALEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLMINMAXPROC = procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;
PFNGLMINSAMPLESHADINGARBPROC = procedure(value: Single); stdcall;
PFNGLMINSAMPLESHADINGPROC = procedure(value: Single); stdcall;
PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;
PFNGLMultiDrawArraysIndirect = procedure(mode : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;
PFNGLMULTIDRAWARRAYSPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;
PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;
PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;
PFNGLMultiDrawElementsIndirect = procedure(mode : Cardinal; type_ : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;
PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;
PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; interformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLMULTITEXCOORD1DARBPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;
PFNGLMULTITEXCOORD1DPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;
PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD1DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD1FARBPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1FVPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;
PFNGLMULTITEXCOORD1IARBPROC = procedure(target: Cardinal; s: TGLint); stdcall;
PFNGLMULTITEXCOORD1IPROC = procedure(target: Cardinal; s: TGLint); stdcall;
PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: Cardinal; v: PGLInt); stdcall;
PFNGLMULTITEXCOORD1IVPROC = procedure(target: Cardinal; v: PGLInt); stdcall;
PFNGLMULTITEXCOORD1SARBPROC = procedure(target: Cardinal; s: TGLshort); stdcall;
PFNGLMULTITEXCOORD1SPROC = procedure(target: Cardinal; s: TGLshort); stdcall;
PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD1SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD2DARBPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;
PFNGLMULTITEXCOORD2DPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;
PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD2DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD2FARBPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;
PFNGLMULTITEXCOORD2FPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;
PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD2FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD2IARBPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;
PFNGLMULTITEXCOORD2IPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;
PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD2IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD2SARBPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;
PFNGLMULTITEXCOORD2SPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;
PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD2SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD3DARBPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;
PFNGLMULTITEXCOORD3DPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;
PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD3DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD3FARBPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;
PFNGLMULTITEXCOORD3FPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;
PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD3FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD3IARBPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;
PFNGLMULTITEXCOORD3IPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;
PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD3IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD3SARBPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;
PFNGLMULTITEXCOORD3SPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;
PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD3SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD4DARBPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;
PFNGLMULTITEXCOORD4DPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;
PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD4DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;
PFNGLMULTITEXCOORD4FARBPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;
PFNGLMULTITEXCOORD4FPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;
PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD4FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;
PFNGLMULTITEXCOORD4IARBPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;
PFNGLMULTITEXCOORD4IPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;
PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD4IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;
PFNGLMULTITEXCOORD4SARBPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;
PFNGLMULTITEXCOORD4SPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;
PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORD4SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;
PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;
PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;
PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: Cardinal; size: TGLint; type_: Cardinal; stride: TGLsizei; const pointer: PGLvoid); stdcall;
PFNGLMULTITEXENVFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXENVIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXGENDEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLdouble); stdcall;
PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLdouble); stdcall;
PFNGLMULTITEXGENFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXGENIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels:PGLvoid); stdcall;
PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;
PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;
PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;
PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;
PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: Cardinal; size: TGLsizei; const data: PGLvoid; usage: Cardinal); stdcall;
PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; const data: PGLvoid); stdcall;
PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: Cardinal; writeBuffer: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;
PFNGLNamedFramebufferParameteri = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; face: Cardinal); stdcall;
PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLdouble); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLuint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLfloat); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLint); stdcall;
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLuint); stdcall;
PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; format: Cardinal; len: TGLsizei; const string_: PGLvoid); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: Cardinal; interformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: Cardinal; coverageSamples: TGLsizei; colorSamples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLNORMALFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;
PFNGLNORMALP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLNORMALP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLObjectLabel = procedure(identifier : Cardinal; name : Cardinal; length : TGLsizei; const label_ : PAnsiChar); stdcall;
PFNGLObjectPtrLabel = procedure(const ptr : Pointer; length : TGLsizei; const label_ : PAnsiChar); stdcall;
PFNGLPATCHPARAMETERFVPROC = procedure(pname: Cardinal; const values: PGLfloat); stdcall;
PFNGLPATCHPARAMETERIPROC = procedure(pname: Cardinal; value: TGLint); stdcall;
PFNGLPATHCOLORGENNVPROC = procedure (color: Cardinal; genMode: Cardinal; colorFormat: Cardinal; coeffs: PGLfloat); stdcall;
PFNGLPATHCOMMANDSNVPROC = procedure(path: Cardinal; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHCOORDSNVPROC = procedure(path: Cardinal; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: Cardinal); stdcall;
PFNGLPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashCount: TGLsizei; dashArray: PGLfloat); stdcall;
PFNGLPATHFOGGENNVPROC = procedure (genMode: Cardinal); stdcall;
PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PAnsiChar; fontStyle: TGLbitfield; firstGlyph: Cardinal; numGlyphs: TGLsizei; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;
PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PGLvoid; fontStyle: TGLbitfield; numGlyphs: TGLsizei; _type: Cardinal; charcodes: PGLvoid; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;
PFNGLPATHPARAMETERFNVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLfloat); stdcall;
PFNGLPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;
PFNGLPATHPARAMETERINVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLint); stdcall;
PFNGLPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;
PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: TGLfloat; units: TGLfloat); stdcall;
PFNGLPATHSTENCILFUNCNVPROC = procedure (func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
PFNGLPATHSTRINGNVPROC = procedure(path: Cardinal; format: Cardinal; length: TGLsizei; pathString: PGLvoid); stdcall;
PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: Cardinal; commandStart: TGLsizei; commandsToDelete: TGLsizei; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHSUBCOORDSNVPROC = procedure(path: Cardinal; coordStart: TGLsizei; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;
PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: Cardinal; genMode: Cardinal; components: TGLint; coeffs: PGLfloat); stdcall;
PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLPOINTALONGPATHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei; distance: TGLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): TGLboolean; stdcall;
PFNGLPOINTPARAMETERFARBPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLPOINTPARAMETERFPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;
PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLPOINTPARAMETERFVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;
PFNGLPOINTPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLPOINTPARAMETERIPROC = procedure(pname: Cardinal; param: TGLint); stdcall;
PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLPOINTPARAMETERIVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;
PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;
PFNGLPopDebugGroup = procedure; stdcall;
PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: Cardinal); stdcall;
PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: Cardinal); stdcall;
PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;
PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;
PFNGLPROGRAMBINARYPROC = procedure(_program: Cardinal; binaryFormat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;
PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;
PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;
PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;
PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;
PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLFloat); stdcall;
PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLdouble); stdcall;
PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLdouble ); stdcall;
PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLfloat); stdcall;
PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLfloat); stdcall;
PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERIPROC = procedure(_program: Cardinal; pname: Cardinal; value: TGLint); stdcall;
PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLPROGRAMSTRINGARBPROC = procedure(target: Cardinal; format: Cardinal; len: TGLsizei; const _string: pointer); stdcall;
PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint); stdcall;
PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;
PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: Cardinal; location: TGLint; value: TGLuint64EXT); stdcall;
PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;
PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: Cardinal; limit: TGLint); stdcall;
PFNGLPROVOKINGVERTEXPROC = procedure(mode: Cardinal); stdcall;
PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;
PFNGLPushDebugGroup = procedure(source : Cardinal; id : Cardinal; length : TGLsizei; const message_ : PAnsiChar); stdcall;
PFNGLQUERYCOUNTERPROC = procedure(id: Cardinal; target: Cardinal); stdcall;
PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; data: Pointer); stdcall;
PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;
PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;
PFNGLRESETHISTOGRAMPROC = procedure(target: Cardinal); stdcall;
PFNGLRESETMINMAXPROC = procedure(target: Cardinal); stdcall;
PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;
PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;
PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLECOVERAGEPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEMASKEXTPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEMASKIPROC = procedure(index: Cardinal; mask: TGLbitfield); stdcall;
PFNGLSAMPLEMASKSGISPROC = procedure(Value: Single; invert: TGLboolean); stdcall;
PFNGLSAMPLEPASSARBPROC = procedure(pass: Cardinal); stdcall;
PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: Cardinal); stdcall;
PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: Cardinal); stdcall;
PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;
PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLSCISSORARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLint); stdcall;
PFNGLSCISSORINDEXEDPROC = procedure(index: Cardinal; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;
PFNGLSCISSORINDEXEDVPROC = procedure(index: Cardinal; v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;
PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;
PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;
PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;
PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;
PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;
PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;
PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;
PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;
PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;
PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;
PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;
PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;
PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;
PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: Cardinal); stdcall;
PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: Cardinal); stdcall;
PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;
PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;
PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;
PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;
PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;
PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;
PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;
PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;
PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;
PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;
PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;
PFNGLSETFENCENVPROC = procedure(fence: Cardinal; condition: Cardinal); stdcall;
PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;
PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: TGLhandleARB; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;
PFNGLSHADERSOURCEPROC = procedure(shader: Cardinal; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;
PFNGLShaderStorageBlockBinding = procedure(program_ : Cardinal; storageBlockIndex : Cardinal; storageBlockBinding : Cardinal); stdcall;
PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: Cardinal); stdcall;
PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; fillMode: Cardinal; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLSTENCILFILLPATHNVPROC = procedure (path: Cardinal; fillMode: Cardinal; mask: Cardinal); stdcall;
PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
PFNGLSTENCILMASKSEPARATEPROC = procedure(face: Cardinal; mask: Cardinal); stdcall;
PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;
PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; reference: TGLint; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: Cardinal; reference: TGLint; mask: Cardinal); stdcall;
PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: TGLsizei; str: PAnsiChar); stdcall;
PFNGLTBUFFERMASK3DFXPROC = procedure(mask: Cardinal); stdcall;
PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: TGLfloat); stdcall;
PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: Cardinal); stdcall;
PFNGLTESTFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;
PFNGLTEXBUFFERARBPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTEXBUFFEREXTPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTEXBUFFERPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTexBufferRange = procedure(target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset: TGLintptr; size : TGLsizeiptr); stdcall;
PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLTEXCOORDP1UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP1UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP2UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP2UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXCOORDP4UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;
PFNGLTEXCOORDP4UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;
PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;
PFNGLTEXIMAGE3DEXTPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;
PFNGLTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;
PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;
PFNGLTexStorage2DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTexStorage3DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;
PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;
PFNGLTextureBufferRange = procedure(texture : Cardinal; target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset : TGLintptr; size : TGLsizeiptr); stdcall;
PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;
PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;
PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;
PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;
PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;
PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;
PFNGLTextureStorage2DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTextureStorage3DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;
PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;
PFNGLTextureView = procedure(texture : Cardinal; target : Cardinal; origtexture : Cardinal; internalformat : Cardinal; minlevel : Cardinal; numlevels : Cardinal; minlayer : Cardinal; numlayers : Cardinal); stdcall;
PFNGLTRACKMATRIXNVPROC = procedure (target: Cardinal; address: Cardinal; matrix: Cardinal; transform: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: Cardinal; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;
PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: Cardinal; srcPath: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;
PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;
PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;
PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;
PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM1FARBPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;
PFNGLUNIFORM1FPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;
PFNGLUNIFORM1FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM1FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM1IARBPROC = procedure(location: TGLint; v0: TGLint); stdcall;
PFNGLUNIFORM1IPROC = procedure(location: TGLint; v0: TGLint); stdcall;
PFNGLUNIFORM1IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM1IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;
PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;
PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM2FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLUNIFORM2FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;
PFNGLUNIFORM2FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM2FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM2IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLUNIFORM2IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;
PFNGLUNIFORM2IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM2IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;
PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM3FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLUNIFORM3FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;
PFNGLUNIFORM3FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM3FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM3IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLUNIFORM3IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;
PFNGLUNIFORM3IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM3IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;
PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;
PFNGLUNIFORM4FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLUNIFORM4FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;
PFNGLUNIFORM4FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM4FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;
PFNGLUNIFORM4IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLUNIFORM4IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;
PFNGLUNIFORM4IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM4IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;
PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;
PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;
PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; uniformBlockBinding: Cardinal); stdcall;
PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: Cardinal; location: TGLint; buffer: Cardinal); stdcall;
PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;
PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;
PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;
PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;
PFNGLUNIFORMUI64VNVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;
PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;
PFNGLUNMAPBUFFERARBPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLUNMAPBUFFERPROC = function(target: Cardinal): TGLboolean; stdcall;
PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal): TGLboolean; stdcall;
PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLUSEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: Cardinal; stages: TGLbitfield; _program: Cardinal); stdcall;
PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;
PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;
PFNGLVALIDATEPROGRAMPROC = procedure(_program: Cardinal); stdcall;
PFNGLVertexArrayBindVertexBuffer = procedure(vaobj : Cardinal; bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;
PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;
PFNGLVertexArrayVertexAttribBinding = procedure(vaobj : Cardinal; attribindex : Cardinal; bindingindex : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribIFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVertexArrayVertexAttribLFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: Cardinal; buffer: Cardinal; index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; offset: TGLintptr); stdcall;
PFNGLVertexArrayVertexBindingDivisor = procedure(vaobj : Cardinal; bindingindex : Cardinal; divisor : Cardinal); stdcall;
PFNGLVERTEXATTRIB1DARBPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DNVPROC = procedure (index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DPROC = procedure(index:Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB1FARBPROC = procedure(index: Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FNVPROC = procedure (index: Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FPROC = procedure(index:Cardinal; x: TGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB1SARBPROC = procedure(index: Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SNVPROC = procedure (index: Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SPROC = procedure(index:Cardinal; x: TGLshort); stdcall;
PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB1SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DPROC = procedure(index:Cardinal; x,y: TGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB2FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FPROC = procedure(index:Cardinal; x,y: TGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB2SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SPROC = procedure(index:Cardinal; x,y: TGLshort); stdcall;
PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB2SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DPROC = procedure(index:Cardinal; x,y,z: TGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB3FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FPROC = procedure(index:Cardinal; x,y,z: TGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB3SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SPROC = procedure(index:Cardinal; x,y,z: TGLshort); stdcall;
PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB3SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4BVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DPROC = procedure(index:Cardinal; x,y,z,w: TGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIB4FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FNVPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FPROC = procedure(index:Cardinal; x,y,z,w: TGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;
PFNGLVERTEXATTRIB4IVPROC = procedure(index:Cardinal; v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4NBVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;
PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NIVPROC = procedure(index:Cardinal; v: PGLint); stdcall;
PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4NSVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: Cardinal; x: TGLubyte; y: TGLubyte; z: TGLubyte; w: TGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBPROC = procedure(index:Cardinal; x,y,z,w: TGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort; w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SPROC = procedure(index:Cardinal; x,y,z,w: TGLshort); stdcall;
PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;
PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;
PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4UIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;
PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;
PFNGLVERTEXATTRIB4USVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;
PFNGLVertexAttribBinding = procedure(attribindex : Cardinal; bindingindex : Cardinal); stdcall;
PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;
PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;
PFNGLVertexAttribFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;
PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: Cardinal; x: TGLint); stdcall;
PFNGLVERTEXATTRIBI1IPROC = procedure(index: Cardinal; x: TGLint); stdcall;
PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI1IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: Cardinal; x: Cardinal); stdcall;
PFNGLVERTEXATTRIBI1UIPROC = procedure(index: Cardinal; x: Cardinal); stdcall;
PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;
PFNGLVERTEXATTRIBI2IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;
PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI2IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;
PFNGLVERTEXATTRIBI2UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;
PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;
PFNGLVERTEXATTRIBI3IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;
PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI3IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;
PFNGLVERTEXATTRIBI3UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;
PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;
PFNGLVERTEXATTRIBI4BVPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;
PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLVERTEXATTRIBI4IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;
PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI4IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;
PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: Cardinal; v:PGLshort); stdcall;
PFNGLVERTEXATTRIBI4SVPROC = procedure(index: Cardinal; v:PGLshort); stdcall;
PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;
PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;
PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLVERTEXATTRIBI4UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;
PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;
PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: Cardinal; v: PGLushort); stdcall;
PFNGLVERTEXATTRIBI4USVPROC = procedure(index: Cardinal; v: PGLushort); stdcall;
PFNGLVertexAttribIFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBL1DPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL1DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL2DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL2DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL3DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL3DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBL4DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;
PFNGLVERTEXATTRIBL4DVPROC = procedure(index: Cardinal; v :PGLdouble); stdcall;
PFNGLVertexAttribLFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;
PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; ptr: Pointer); stdcall;
PFNGLVERTEXATTRIBP1UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP2UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP3UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBP4UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;
PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;
PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei; const _pointer: pointer); stdcall;
PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: Cardinal; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;
PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;
PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;
PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;
PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;
PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLubyte); stdcall;
PFNGLVertexBindingDivisor = procedure(bindingindex : Cardinal; divisor : Cardinal); stdcall;
PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;
PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;
PFNGLVERTEXP2UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP2UIVPROC = procedure(_type: Cardinal; const value: PGLuint ); stdcall;
PFNGLVERTEXP3UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP3UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;
PFNGLVERTEXP4UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;
PFNGLVERTEXP4UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;
PFNGLVIEWPORTARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLfloat); stdcall;
PFNGLVIEWPORTINDEXEDFPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;
PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;
PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;
PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;
PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;
PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;
PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;
PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: Cardinal; numPaths: TGLsizei; paths: PGLuint; weights: PGLfloat); stdcall;
PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;
PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;
PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;
PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;
PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;
PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;
PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;
PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;
PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;
PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;
PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;
PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;
PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;
PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;
PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;
PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;
PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;
PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;
PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;
PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;
PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;
PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;
PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;
PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;
PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;
PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;
PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;
PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;
PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: Cardinal; piFormats: PGLint; nNumFormats: PCardinal) : BOOL; stdcall;
PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;
PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;
PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;
PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: TGLint; iWidth, iHeight : TGLint; const piAttribList: PGLint) : HPBUFFERARB; stdcall;
PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;
PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;
PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;
PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;
PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;
PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: Cardinal): BOOL; stdcall;
PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;
PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: Cardinal; atype: Cardinal; access: Cardinal): THandle; stdcall;
PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;
PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;
PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;
PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;
PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;
PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;
PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;
PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;
PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PAnsiChar; stdcall;
PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;
PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;
PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;
PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;
PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;
PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;
PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;
PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;
PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;
PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;
PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;
PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;
PGLbitfield = ˆTGLbitfield;
PGLboolean = ˆTGLboolean;
PGLbyte = ˆTGLbyte;
PGLchar = MarshaledAString;
PGLclampd = System.PDouble;
PGLclampf = System.PSingle;
PGLdouble = System.PDouble;
PGLenum = ˆTGLenum;
PGLfloat = System.PSingle;
PGLhalf = ˆTGLhalf;
PGLhandleARB = ˆTGLhandleARB;
PGLint = System.PInteger;
PGLint64 = System.PInt64;
PGLint64EXT = System.PInt64;
PGLintptr = ˆTGLintptr;
PGLPCharArray = ˆPAnsiChar;
PGLPointer = ˆPGLvoid;
PGLshort = ˆTGLshort;
PGLsizei = System.PInteger;
PGLsizeiptr = ˆTGLsizeiptr;
PGLsync = ˆTGLsync;
PGLubyte = System.PByte;
PGLuint = System.PCardinal;
PGLuint64 = System.PUInt64;
PGLuint64EXT = System.PUInt64;
PGLUNurbs = ˆTGLUNurbs;
PGLUNurbsObj = PGLUNurbs;
PGLUQuadric = ˆTGLUQuadric;
PGLUQuadricObj = PGLUQuadric;
PGLushort = System.PWord;
PGLUTesselator= ˆTGLUTesselator;
PGLUTesselatorObj = PGLUTesselator;
PGLUTriangulatorObj = PGLUTesselator;
PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;
PGLvoid = Pointer;
PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;
PGPUDEVICE = ˆTGPUDEVICE;
PHGPUNV = ˆHGPUNV;
PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;
PWGLswap = ˆTWGLswap;
TDebugProc = procedure( source: Cardinal; type_: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; const message: PAnsiChar; userParam: Pointer); stdcall;
TDebugProcAMD = procedure( id: Cardinal; category: Cardinal; severity: Cardinal; length: TGLsizei; message: PAnsiChar; userParam: Pointer); stdcall;
TGLbitfield = LongWord;
TGLboolean = BYTEBOOL;
TGLbyte = ShortInt;
TGLchar = Byte;
TGLclampd = Double;
TGLDEBUGPROCARB = TDebugProc;
TGLdouble = Double;
TGLenum = Cardinal;
TGLfloat = Single;
TGLhalf = WORD;
TGLhandleARB = Cardinal;
TGLint = Integer;
TGLint64 = Int64;
TGLint64EXT = Int64;
TGLintptr = NativeInt;
TGLshort = SmallInt;
TGLsizei = Integer;
TGLsizeiptr = NativeInt;
TGLsync = NativeInt;
TGLubyte = Byte;
TGLuint = Cardinal;
TGLuint64 = UInt64;
TGLuint64EXT = UInt64;
TGLUNurbsErrorProc = procedure(ErrorCode: Cardinal); stdcall;
TGLUNurbsObj = TGLUNurbs;
TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;
TGLUQuadricObj = TGLUQuadric;
TGLushort = Word;
TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;
TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;
TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;
TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;
TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;
TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;
TGLUTesselatorObj = TGLUTesselator;
TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;
TGLUTessEndProc = procedure; stdcall;
TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;
TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;
TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;
TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;
TGLUTriangulatorObj = TGLUTesselator;
TGLvdpauSurfaceNV = TGLintptr;
TWGLswap = _WGLSWAP;
WGLSWAP = _WGLSWAP;

Constants

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;
WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;
WGL_DEPTH_BUFFER_BIT_ARB = $00000004;
WGL_STENCIL_BUFFER_BIT_ARB = $00000008;
WGL_SAMPLE_BUFFERS_ARB = $2041;
WGL_SAMPLES_ARB = $2042;
WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;
WGL_DRAW_TO_WINDOW_ARB = $2001;
WGL_DRAW_TO_BITMAP_ARB = $2002;
WGL_ACCELERATION_ARB = $2003;
WGL_NEED_PALETTE_ARB = $2004;
WGL_NEED_SYSTEM_PALETTE_ARB = $2005;
WGL_SWAP_LAYER_BUFFERS_ARB = $2006;
WGL_SWAP_METHOD_ARB = $2007;
WGL_NUMBER_OVERLAYS_ARB = $2008;
WGL_NUMBER_UNDERLAYS_ARB = $2009;
WGL_TRANSPARENT_ARB = $200A;
WGL_TRANSPARENT_RED_VALUE_ARB = $2037;
WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;
WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;
WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;
WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;
WGL_SHARE_DEPTH_ARB = $200C;
WGL_SHARE_STENCIL_ARB = $200D;
WGL_SHARE_ACCUM_ARB = $200E;
WGL_SUPPORT_GDI_ARB = $200F;
WGL_SUPPORT_OPENGL_ARB = $2010;
WGL_DOUBLE_BUFFER_ARB = $2011;
WGL_STEREO_ARB = $2012;
WGL_PIXEL_TYPE_ARB = $2013;
WGL_COLOR_BITS_ARB = $2014;
WGL_RED_BITS_ARB = $2015;
WGL_RED_SHIFT_ARB = $2016;
WGL_GREEN_BITS_ARB = $2017;
WGL_GREEN_SHIFT_ARB = $2018;
WGL_BLUE_BITS_ARB = $2019;
WGL_BLUE_SHIFT_ARB = $201A;
WGL_ALPHA_BITS_ARB = $201B;
WGL_ALPHA_SHIFT_ARB = $201C;
WGL_ACCUM_BITS_ARB = $201D;
WGL_ACCUM_RED_BITS_ARB = $201E;
WGL_ACCUM_GREEN_BITS_ARB = $201F;
WGL_ACCUM_BLUE_BITS_ARB = $2020;
WGL_ACCUM_ALPHA_BITS_ARB = $2021;
WGL_DEPTH_BITS_ARB = $2022;
WGL_STENCIL_BITS_ARB = $2023;
WGL_AUX_BUFFERS_ARB = $2024;
WGL_NO_ACCELERATION_ARB = $2025;
WGL_GENERIC_ACCELERATION_ARB = $2026;
WGL_FULL_ACCELERATION_ARB = $2027;
WGL_SWAP_EXCHANGE_ARB = $2028;
WGL_SWAP_COPY_ARB = $2029;
WGL_SWAP_UNDEFINED_ARB = $202A;
WGL_TYPE_RGBA_ARB = $202B;
WGL_TYPE_COLORINDEX_ARB = $202C;
WGL_DRAW_TO_PBUFFER_ARB = $202D;
WGL_MAX_PBUFFER_PIXELS_ARB = $202E;
WGL_MAX_PBUFFER_WIDTH_ARB = $202F;
WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;
WGL_PBUFFER_LARGEST_ARB = $2033;
WGL_PBUFFER_WIDTH_ARB = $2034;
WGL_PBUFFER_HEIGHT_ARB = $2035;
WGL_PBUFFER_LOST_ARB = $2036;
WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;
WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;
WGL_TEXTURE_FORMAT_ARB = $2072;
WGL_TEXTURE_TARGET_ARB = $2073;
WGL_MIPMAP_TEXTURE_ARB = $2074;
WGL_TEXTURE_RGB_ARB = $2075;
WGL_TEXTURE_RGBA_ARB = $2076;
WGL_NO_TEXTURE_ARB = $2077;
WGL_TEXTURE_CUBE_MAP_ARB = $2078;
WGL_TEXTURE_1D_ARB = $2079;
WGL_TEXTURE_2D_ARB = $207A;
WGL_MIPMAP_LEVEL_ARB = $207B;
WGL_CUBE_MAP_FACE_ARB = $207C;
WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;
WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;
WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;
WGL_FRONT_LEFT_ARB = $2083;
WGL_FRONT_RIGHT_ARB = $2084;
WGL_BACK_LEFT_ARB = $2085;
WGL_BACK_RIGHT_ARB = $2086;
WGL_AUX0_ARB = $2087;
WGL_AUX1_ARB = $2088;
WGL_AUX2_ARB = $2089;
WGL_AUX3_ARB = $208A;
WGL_AUX4_ARB = $208B;
WGL_AUX5_ARB = $208C;
WGL_AUX6_ARB = $208D;
WGL_AUX7_ARB = $208E;
WGL_AUX8_ARB = $208F;
WGL_AUX9_ARB = $2090;
WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;
WGL_COLOR_SAMPLES_NV = $20B9;
WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;
WGL_CONTEXT_MINOR_VERSION_ARB = $2092;
WGL_CONTEXT_LAYER_PLANE_ARB = $2093;
WGL_CONTEXT_FLAGS_ARB = $2094;
WGL_CONTEXT_DEBUG_BIT_ARB = $0001;
WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;
ERROR_INVALID_VERSION_ARB = $2095;
WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;
WGL_CONTEXT_PROFILE_MASK_ARB = $9126;
WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;
WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;
ERROR_INVALID_PROFILE_ARB = $2096;
WGL_TYPE_RGBA_FLOAT_ATI = $21A0;
WGL_FLOAT_COMPONENTS_NV = $20B0;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;
WGL_TEXTURE_FLOAT_R_NV = $20B5;
WGL_TEXTURE_FLOAT_RG_NV = $20B6;
WGL_TEXTURE_FLOAT_RGB_NV = $20B7;
WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;
WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;
GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;
GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;
WGL_ACCESS_READ_ONLY_NV = $0000;
WGL_ACCESS_READ_WRITE_NV = $0001;
WGL_ACCESS_WRITE_DISCARD_NV = $0002;
GLU_TESS_BEGIN = 100100;
GLU_TESS_VERTEX = 100101;
GLU_TESS_END = 100102;
GLU_TESS_ERROR = 100103;
GLU_TESS_EDGE_FLAG = 100104;
GLU_TESS_COMBINE = 100105;
GLU_TESS_BEGIN_DATA = 100106;
GLU_TESS_VERTEX_DATA = 100107;
GLU_TESS_END_DATA = 100108;
GLU_TESS_ERROR_DATA = 100109;
GLU_TESS_EDGE_FLAG_DATA = 100110;
GLU_TESS_COMBINE_DATA = 100111;
GLU_TESS_ERROR1 = 100151;
GLU_TESS_ERROR2 = 100152;
GLU_TESS_ERROR3 = 100153;
GLU_TESS_ERROR4 = 100154;
GLU_TESS_ERROR5 = 100155;
GLU_TESS_ERROR6 = 100156;
GLU_TESS_ERROR7 = 100157;
GLU_TESS_ERROR8 = 100158;
GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;
GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;
GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;
GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;
GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;
GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;
GLU_AUTO_LOAD_MATRIX = 100200;
GLU_CULLING = 100201;
GLU_SAMPLING_TOLERANCE = 100203;
GLU_DISPLAY_MODE = 100204;
GLU_PARAMETRIC_TOLERANCE = 100202;
GLU_SAMPLING_METHOD = 100205;
GLU_U_STEP = 100206;
GLU_V_STEP = 100207;
GLU_PATH_LENGTH = 100215;
GLU_PARAMETRIC_ERROR = 100216;
GLU_DOMAIN_DISTANCE = 100217;
GLU_MAP1_TRIM_2 = 100210;
GLU_MAP1_TRIM_3 = 100211;
GLU_OUTLINE_POLYGON = 100240;
GLU_OUTLINE_PATCH = 100241;
GLU_NURBS_ERROR1 = 100251;
GLU_NURBS_ERROR2 = 100252;
GLU_NURBS_ERROR3 = 100253;
GLU_NURBS_ERROR4 = 100254;
GLU_NURBS_ERROR5 = 100255;
GLU_NURBS_ERROR6 = 100256;
GLU_NURBS_ERROR7 = 100257;
GLU_NURBS_ERROR8 = 100258;
GLU_NURBS_ERROR9 = 100259;
GLU_NURBS_ERROR10 = 100260;
GLU_NURBS_ERROR11 = 100261;
GLU_NURBS_ERROR12 = 100262;
GLU_NURBS_ERROR13 = 100263;
GLU_NURBS_ERROR14 = 100264;
GLU_NURBS_ERROR15 = 100265;
GLU_NURBS_ERROR16 = 100266;
GLU_NURBS_ERROR17 = 100267;
GLU_NURBS_ERROR18 = 100268;
GLU_NURBS_ERROR19 = 100269;
GLU_NURBS_ERROR20 = 100270;
GLU_NURBS_ERROR21 = 100271;
GLU_NURBS_ERROR22 = 100272;
GLU_NURBS_ERROR23 = 100273;
GLU_NURBS_ERROR24 = 100274;
GLU_NURBS_ERROR25 = 100275;
GLU_NURBS_ERROR26 = 100276;
GLU_NURBS_ERROR27 = 100277;
GLU_NURBS_ERROR28 = 100278;
GLU_NURBS_ERROR29 = 100279;
GLU_NURBS_ERROR30 = 100280;
GLU_NURBS_ERROR31 = 100281;
GLU_NURBS_ERROR32 = 100282;
GLU_NURBS_ERROR33 = 100283;
GLU_NURBS_ERROR34 = 100284;
GLU_NURBS_ERROR35 = 100285;
GLU_NURBS_ERROR36 = 100286;
GLU_NURBS_ERROR37 = 100287;
GLU_CW = 100120;
GLU_CCW = 100121;
GLU_INTERIOR = 100122;
GLU_EXTERIOR = 100123;
GLU_UNKNOWN = 100124;
GLU_BEGIN = GLU_TESS_BEGIN;
GLU_VERTEX = GLU_TESS_VERTEX;
GLU_END = GLU_TESS_END;
GLU_ERROR = GLU_TESS_ERROR;
GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Description

Types

HGPUNV = THandle;

This item has no description.

HPBUFFERARB = type UINT_PTR;

This item has no description.

HVIDEOINPUTDEVICENV = THandle;

This item has no description.

PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: Cardinal; _program: Cardinal); stdcall;

This item has no description.

PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: Cardinal); stdcall;

GL_EXT_stencil_two_side (EXT #268)

PFNGLACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;

GL_ARB_multitexture (ARB #1)

PFNGLACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLACTIVEVARYINGNVPROC = procedure(_program: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

GL_WIN_swap_hint (extension # not found)

PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

GL_NV_vertex_program (EXT #233)

PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

This item has no description.

PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: Cardinal; count: TGLsizei; pi: Pointer); stdcall;

EXT/Vendor extensions Unknown Vendor/EXT functions

PFNGLATTACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; obj: TGLhandleARB); stdcall;

This item has no description.

PFNGLATTACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;

GL_NV_conditional_render (EXT #346)

PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: Cardinal; mode: Cardinal); stdcall;

promoted to core v3.0 from GL_NV_conditional_render

PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYARBPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINQUERYPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBEGINSCENEEXTPROC = procedure; stdcall;

GL_EXT_scene_marker (EXT #120)

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: Cardinal); stdcall;

This item has no description.

PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; const name: PAnsiChar); stdcall;

GL_ARB_vertex_shader (ARB #31)

PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDBUFFERARBPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;

GL_ARB_vertex_buffer_object (ARB #28)

PFNGLBINDBUFFERBASEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFERBASENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFERBASEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr); stdcall;

This item has no description.

PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr); stdcall;

This item has no description.

PFNGLBINDBUFFERPROC = procedure(target: Cardinal; buffer: Cardinal); stdcall;

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;

GL_EXT_transform_feedback (EXT #352)

PFNGLBINDBUFFERRANGENVPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_NV_transform_feedback (EXT #341)

PFNGLBINDBUFFERRANGEPROC = procedure(target: Cardinal; index: Cardinal; buffer: Cardinal; offset:TGLintptr; size: TGLsizeiptr); stdcall;

promoted to core v3.0 from GL_EXT_transform_feedback

PFNGLBindBuffersBase = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLUint); stdcall;

This item has no description.

PFNGLBindBuffersRange = procedure(target : Cardinal; first : Cardinal; count : TGLsizei; const buffers : PGLuint; const offsets : TGLintptr; const sizes : TGLsizeiptr); stdcall;

This item has no description.

PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: Cardinal; colorNumber: Cardinal; index: Cardinal; const name: PAnsiChar); stdcall;

GL_ARB_blend_func_extended (ARB #78)

PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: Cardinal; colorNumber: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDFRAMEBUFFERPROC = procedure(target: Cardinal; framebuffer: Cardinal); stdcall;

This item has no description.

PFNGLBindImageTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;

This item has no description.

PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: Cardinal; target: Cardinal; texture: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMARBPROC = procedure(target: Cardinal; _program: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;

This item has no description.

PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDRENDERBUFFERPROC = procedure(target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLBINDSAMPLERPROC = procedure(_unit: Cardinal; sampler: Cardinal); stdcall;

This item has no description.

PFNGLBindSamplers = procedure(first : Cardinal; count : TGLsizei; const samplers : PGLuint); stdcall;

This item has no description.

PFNGLBINDTEXTUREEXTPROC = procedure(target: Cardinal; texture: Cardinal); stdcall;

This item has no description.

PFNGLBindTextures = procedure(first : Cardinal; count : TGLsizei; const textures : PGLuint); stdcall;

This item has no description.

PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: Cardinal; id: Cardinal); stdcall;

GL_ARB_transform_feedback2 (ARB #93)

PFNGLBINDVERTEXARRAYPROC = procedure(_array: Cardinal); stdcall;

GL_ARB_vertex_array_object (ARB #54)

PFNGLBindVertexBuffer = procedure(bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;

GL_ARB_vertex_attrib_binding (ARB #125)

PFNGLBindVertexBuffers = procedure(first : Cardinal; count : TGLsizei; const buffers : Cardinal; const offsets : TGLintptr; const strides : PGLsizei); stdcall;

This item has no description.

PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: Single; alpha: Single); stdcall;

GL_EXT_blend_color (EXT #2)

PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: Single); stdcall;

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)

PFNGLBLENDEQUATIONEXTPROC = procedure(mode: Cardinal); stdcall;

GL_EXT_blend_minmax (EXT #37)

PFNGLBLENDEQUATIONIARBPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;

GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONIPROC = procedure(buf: Cardinal; mode: Cardinal); stdcall;

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONPROC = procedure(mode: Cardinal); stdcall;

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

GL_EXT_blend_equation_separate (EXT #299)

PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: Cardinal; modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: Cardinal; modeAlpha: Cardinal); stdcall;

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

PFNGLBLENDFUNCIARBPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCIPROC = procedure(buf: Cardinal; src: Cardinal; dst: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

GL_EXT_blend_func_separate (EXT #173)

PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: Cardinal; srcRGB: Cardinal; dstRGB: Cardinal; srcAlpha: Cardinal; dstAlpha: Cardinal); stdcall;

This item has no description.

PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: Cardinal); stdcall;

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

GL_EXT_framebuffer_blit (EXT #316)

PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: Cardinal); stdcall;

This item has no description.

PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: Cardinal; index: Cardinal; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

GL_NV_vertex_buffer_unified_memory (EXT #380)

PFNGLBUFFERDATAARBPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;

This item has no description.

PFNGLBUFFERDATAPROC = procedure(target: Cardinal; size: TGLsizei; const data: Pointer; usage: Cardinal); stdcall;

This item has no description.

PFNGLBufferStorage = procedure(target : Cardinal; size : TGLsizeiptr; const data : pointer; flags : TGLbitfield); stdcall;

This item has no description.

PFNGLBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;

This item has no description.

PFNGLBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; const data: Pointer); stdcall;

This item has no description.

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: Cardinal; target: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCLAMPCOLORARBPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;

GL_ARB_color_buffer_float (ARB #39)

PFNGLCLAMPCOLORPROC = procedure (target: Cardinal; clamp: Cardinal); stdcall;

promoted to core v3.0 from GL_ARB_color_buffer_float

PFNGLClearBufferData = procedure(target : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

GL_ARB_clear_buffer_object (ARB #121)

PFNGLCLEARBUFFERFIPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;

This item has no description.

PFNGLCLEARBUFFERFVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLfloat); stdcall;

This item has no description.

PFNGLCLEARBUFFERIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLint); stdcall;

New commands in OpenGL 3.0

PFNGLClearBufferSubData = procedure(target : Cardinal; internalformat : Cardinal; offset : TGLintptr; size : TGLsizeiptr; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLCLEARBUFFERUIVPROC = procedure(buffer: Cardinal; drawbuffer: TGLint; value: PGLuint); stdcall;

This item has no description.

PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

GL_EXT_texture_integer (EXT #343)

PFNGLCLEARCOLORIUIEXTPROC = procedure(r: Cardinal; g: Cardinal; b: Cardinal; a: Cardinal); stdcall;

This item has no description.

PFNGLCLEARDEPTHFPROC = procedure(depth: TGLclampd); stdcall;

This item has no description.

PFNGLClearNamedBufferData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLClearNamedBufferSubData = procedure(buffer : Cardinal; internalformat : Cardinal; format : Cardinal; type_ : Cardinal; offset : TGLsizeiptr; size : TGLsizeiptr; const data : Pointer); stdcall;

This item has no description.

PFNGLClearTexImage = procedure(texture : Cardinal; level : TGLint; format : Cardinal; _type : Cardinal; const data : Pointer); stdcall;

This item has no description.

PFNGLClearTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei; format : Cardinal; _type : Cardinal; const Data : Pointer); stdcall;

This item has no description.

PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: Cardinal); stdcall;

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;

GL_EXT_direct_state_access

PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): Cardinal; stdcall;

This item has no description.

PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

GL_EXT_draw_buffers2 (EXT #340)

PFNGLCOLORMASKIPROC = procedure(index: Cardinal; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

promoted to core v3.0 from GL_EXT_draw_buffers2

PFNGLCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLCOLORP4UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLCOLORP4UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLCOLORSUBTABLEEXTPROC = procedure(target: Cardinal; start, count: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

PFNGLCOLORSUBTABLEPROC = procedure(target: Cardinal; start, count: TGLsizei; format, Atype: Cardinal; data: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: Cardinal; width: TGLsizei; format, atype: Cardinal; data: Pointer); stdcall;

GL_EXT_paletted_texture (EXT #78)

PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLCOLORTABLEPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; table: Pointer); stdcall;

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: Cardinal; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

GL_NV_register_combiners (EXT #191)

PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLCOMPILESHADERPROC = procedure(shader: Cardinal); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

GL_ARB_texture_compression (ARB #12)

PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: Cardinal; imageSize: TGLsizei; data: pointer); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; imageSize: TGLsizei; const bits: PGLvoid); stdcall;

This item has no description.

PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; width: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: Cardinal; param: TGLint); stdcall;

deprecated;

PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: Cardinal; writeTarget: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

GL_ARB_copy_buffer (ARB #59)

PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: Cardinal; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width: TGLsizei); stdcall;

deprecated;

PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: Cardinal; x, y: TGLint; width, height: TGLsizei); stdcall;

deprecated;

PFNGLCopyImageSubData = procedure(srcName : Cardinal; srcTarget : Cardinal; srcLevel : TGLint; srcX : TGLint; srcY : TGLint; srcZ : TGLint; dstName : Cardinal; dstTarget : Cardinal; dstLevel : TGLint; dstX : TGLint; dstY : TGLint; dstZ : TGLint; srcWidth : TGLsizei; srcHeight : TGLsizei; srcDepth : TGLsizei); stdcall;

GL_ARB_copy_image (ARB #123)

PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: Cardinal; srcTarget: Cardinal; srcLevel: TGLint; srcX: TGLint; srcY: TGLint; srcZ: TGLint; dstName: Cardinal; dstTarget: Cardinal; dstLevel: TGLint; dstX: TGLint; dstY: TGLint; dstZ: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei); stdcall;

GL_NV_copy_image (EXT #376)

PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYPATHNVPROC = procedure (resultPath: Cardinal; srcPath: Cardinal); stdcall;

This item has no description.

PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

GL_EXT_copy_texture (EXT #10)

PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

promoted to core v1.2 from GL_EXT_copy_texture

PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; border: TGLint); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLCOVERFILLPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;

This item has no description.

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; coverMode: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLCOVERSTROKEPATHNVPROC = procedure (path: Cardinal; coverMode: Cardinal); stdcall;

This item has no description.

PFNGLCREATEPROGRAMOBJECTARBPROC = function(): TGLhandleARB; stdcall;

This item has no description.

PFNGLCREATEPROGRAMPROC = function(): Cardinal; stdcall;

This item has no description.

PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: Cardinal): TGLhandleARB; stdcall;

This item has no description.

PFNGLCREATESHADERPROC = function(_type: Cardinal): Cardinal; stdcall;

This item has no description.

PFNGLCREATESHADERPROGRAMVPROC = function(_type: Cardinal; count: TGLsizei; const strings: PGLPCharArray): Cardinal; stdcall;

This item has no description.

PFNGLCreateSyncFromCLevent = function(context: p_cl_context; event: p_cl_event; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)

PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;

GL_ARB_matrix_palette (ARB #16) {deprecated?}

PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;

This item has no description.

PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: Cardinal; _type: Cardinal; severity: Cardinal; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;

GL_ARB_debug_output (ARB #104)

PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: Cardinal; _type: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; buf: PAnsiChar); stdcall;

This item has no description.

PFNGLDELETEBUFFERSARBPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEBUFFERSPROC = procedure(n: TGLsizei; const buffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETEOBJECTARBPROC = procedure(obj: TGLhandleARB); stdcall;

GL_ARB_shader_objects (ARB #30)

PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPATHSNVPROC = procedure(path: Cardinal; range: TGLsizei); stdcall;

This item has no description.

PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLDELETEPROGRAMSARBPROC = procedure(n: TGLsizei; const programs: PGLuint); stdcall;

This item has no description.

PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

This item has no description.

PFNGLDELETESHADERPROC = procedure(shader: Cardinal); stdcall;

This item has no description.

PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;

This item has no description.

PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

This item has no description.

PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

GL_EXT_depth_bounds_test (EXT #297)

PFNGLDEPTHRANGEARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLclampd); stdcall;

This item has no description.

PFNGLDEPTHRANGEFPROC = procedure(n: Single; f: Single); stdcall;

This item has no description.

PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: Cardinal; n: TGLclampd; f: TGLclampd); stdcall;

This item has no description.

PFNGLDETACHOBJECTARBPROC = procedure(containerObj: TGLhandleARB; attachedObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLDETACHSHADERPROC = procedure(_program: Cardinal; shader: Cardinal); stdcall;

This item has no description.

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLDispatchCompute = procedure(num_groups_x : Cardinal; num_groups_y : Cardinal; num_groups_z : Cardinal); stdcall;

GL_ARB_compute_shader (ARB #122)

PFNGLDispatchComputeIndirect = procedure(indirect : TGLintptr); stdcall;

This item has no description.

PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: Cardinal; const indirect: PGLvoid); stdcall;

GL_ARB_draw_indirect (ARB #87)

PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_ARB_draw_instanced (ARB #44)

PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_draw_instanced (EXT #327)

PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: Cardinal; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

Core 3.1 New commands in OpenGL 3.1

PFNGLDRAWBUFFERSARBPROC = procedure (n: TGLsizei; const bufs: PCardinal); stdcall;

GL_ARB_DrawBuffers (ARB #37)

PFNGLDRAWBUFFERSATIPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;

GL_ATI_draw_buffers (EXT #277)

PFNGLDRAWBUFFERSPROC = procedure(n: TGLsizei; const bufs: PCardinal); stdcall;

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

GL_ARB_draw_elements_base_vertex (ARB #62)

PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: Cardinal; _type: Cardinal; const indirect: PGLvoid); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: Cardinal; count: TGLSizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; start: Cardinal; _end: Cardinal; count: TGLsizei; _type: Cardinal; indices: PGLvoid; basevertex: TGLint); stdcall;

This item has no description.

PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: Cardinal; start, Aend: Cardinal; Count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

GL_EXT_draw_range_elements (EXT #112)

PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: Cardinal; Astart, Aend: Cardinal; count: TGLsizei; Atype: Cardinal; indices: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: Cardinal; id: Cardinal); stdcall;

This item has no description.

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: Cardinal; id: Cardinal; stream: Cardinal); stdcall;

GL_ARB_transform_feedback3 (ARB #94)

PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;

This item has no description.

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: Cardinal; index_: Cardinal); stdcall;

This item has no description.

PFNGLENABLEINDEXEDEXTPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEIPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;

This item has no description.

PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;

This item has no description.

PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;

This item has no description.

PFNGLENDQUERYARBPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLENDQUERYINDEXEDPROC = procedure(target: Cardinal; index: Cardinal); stdcall;

This item has no description.

PFNGLENDQUERYPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLENDSCENEEXTPROC = procedure; stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;

This item has no description.

PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLEXECUTEPROGRAMNVPROC = procedure(target: Cardinal; id: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLFENCESYNCPROC = function(condition: Cardinal; flags: TGLbitfield): TGLsync; stdcall;

GL_ARB_sync (ARB #66)

PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: Cardinal); stdcall;

This item has no description.

PFNGLFINISHFENCENVPROC = procedure(fence: Cardinal); stdcall;

This item has no description.

PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: Cardinal; offset: TGLint; length: TGLsizei ); stdcall;

This item has no description.

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr); stdcall;

This item has no description.

PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;

GL_NV_vertex_array_range (EXT #190)

PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;

This item has no description.

PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;

deprecated;

PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;

This item has no description.

PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;

deprecated;

PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;

GL_EXT_fog_coord (EXT #149)

PFNGLFOGCOORDFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)

PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;

This item has no description.

PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;

deprecated;

PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

This item has no description.

PFNGLFOGCOORDPOINTERPROC = procedure(AType: Cardinal; stride: TGLsizei; p: Pointer); stdcall;

deprecated;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: Cardinal; n: TGLsizei; const bufs: PCardinal); stdcall;

This item has no description.

PFNGLFramebufferParameteri = procedure(target : Cardinal; pname : Cardinal; param : TGLint); stdcall;

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)

PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: Cardinal; mode: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; face:Cardinal); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:Cardinal; attachment:Cardinal; texture:Cardinal; level:TGLint; layer:TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;

GL_GREMEDY_frame_terminator (EXT #345)

PFNGLGENBUFFERSARBPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;

This item has no description.

PFNGLGENBUFFERSPROC = procedure(n: TGLsizei; buffers: PGLuint); stdcall;

This item has no description.

PFNGLGENERATEMIPMAPEXTPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATEMIPMAPPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: Cardinal; target: Cardinal); stdcall;

This item has no description.

PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: Cardinal; target: Cardinal); stdcall;

This item has no description.

PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

GL_NV_fence (EXT #222)

PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_NV_occlusion_query (EXT #261)

PFNGLGENPATHSNVPROC = function (range: TGLsizei): Cardinal; stdcall;

GL_NV_path_rendering

PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

This item has no description.

PFNGLGENPROGRAMSARBPROC = procedure(n: TGLsizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

GL_ARB_occlusion_query (ARB #29)

PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)

PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

This item has no description.

PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;

GL_ARB_sampler_objects (ARB #81)

PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

GL_EXT_texture_object (EXT #20)

PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

This item has no description.

PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

This item has no description.

PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEATTRIBPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: Cardinal; shadertype: Cardinal; index: Cardinal; bufsize: TGLsizei; length: PGLsizei; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: TGLhandleARB; index: Cardinal; maxLength: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: Cardinal; uniformIndex: Cardinal; bufSize: TGLsizei; length: PGLsizei; uniformName: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: Cardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: TGLhandleARB; maxCount: TGLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

This item has no description.

PFNGLGETATTACHEDSHADERSPROC = procedure(_program: Cardinal; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

This item has no description.

PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETATTRIBLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLboolean); stdcall;

This item has no description.

PFNGLGETBOOLEANI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLboolean); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint64EXT ); stdcall;

This item has no description.

PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERPOINTERVPROC = procedure(target: Cardinal; pname: Cardinal; params: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLGETBUFFERSUBDATAPROC = procedure(target: Cardinal; offset: Cardinal; size: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: Cardinal; data: Pointer); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: Cardinal; table: Pointer); stdcall;

deprecated;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: Cardinal; level: TGLint; img: pointer); stdcall;

This item has no description.

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; lod: TGLint; img: PGLvoid); stdcall;

This item has no description.

PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: Cardinal; image: Pointer); stdcall;

deprecated;

PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: Cardinal; bufsize: TGLsizei; sources: PCardinal; types: PCardinal; ids: PGLuint; severities: PCardinal; lengths: PGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLdouble); stdcall;

This item has no description.

PFNGLGETDOUBLEI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLdouble); stdcall;

This item has no description.

PFNGLGETFENCEIVNVPROC = procedure(fence: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLfloat); stdcall;

This item has no description.

PFNGLGETFLOATI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLfloat); stdcall;

This item has no description.

PFNGLGETFRAGDATAINDEXPROC = function (_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAGDATALOCATIONPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetFramebufferParameteriv = procedure(target : Cardinal; pname : Cardinal; params : PGLint); stdcall;

This item has no description.

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): Cardinal; stdcall;

GL_ARB_robustness (ARB #105)

PFNGLGETHANDLEARBPROC = function(pname: Cardinal): TGLhandleARB; stdcall;

This item has no description.

PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETHISTOGRAMPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

PFNGLGETINFOLOGARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETINTEGER64I_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint64); stdcall;

Core 3.2

PFNGLGETINTEGER64VPROC = procedure(pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: Cardinal; index: Cardinal; data: PGLint); stdcall;

This item has no description.

PFNGLGETINTEGERI_VPROC = procedure(target: Cardinal; index: Cardinal; data: PGLint); stdcall;

This item has no description.

PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETINTEGERUI64VNVPROC = procedure(value: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGetInternalformati64v = procedure(target : Cardinal; internalformat : Cardinal; pname : Cardinal; bufSize : TGLsizei; params : PGLint64); stdcall;

GL_ARB_internalformat_query2 (ARB #131)

PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

deprecated;

PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: Cardinal; params: PGLint); stdcall;

deprecated;

PFNGLGETMINMAXPROC = procedure(target: Cardinal; reset: TGLboolean; format, Atype: Cardinal; values: Pointer); stdcall;

deprecated;

PFNGLGETMULTISAMPLEFVPROC = procedure(pname: Cardinal; index: Cardinal; val: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; coord: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;

This item has no description.

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: Cardinal; pname: Cardinal; params: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; data: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetNamedFramebufferParameteriv = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; pname: Cardinal; string_: PGLvoid); stdcall;

This item has no description.

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETNCOLORTABLEARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; table: Pointer); stdcall;

This item has no description.

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: Cardinal; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;

This item has no description.

PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; image: Pointer); stdcall;

This item has no description.

PFNGLGETNHISTOGRAMARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;

This item has no description.

PFNGLGETNMAPDVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLGETNMAPFVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLGETNMAPIVARBPROC = procedure(target: Cardinal; query: Cardinal; bufSize: TGLsizei; v: PGLint); stdcall;

This item has no description.

PFNGLGETNMINMAXARBPROC = procedure(target: Cardinal; reset: TGLboolean; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; values: Pointer); stdcall;

This item has no description.

PFNGLGETNPIXELMAPFVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLfloat); stdcall;

This item has no description.

PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLuint); stdcall;

This item has no description.

PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: Cardinal; bufSize: TGLsizei; values: PGLushort); stdcall;

This item has no description.

PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;

This item has no description.

PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: Cardinal; format: Cardinal; _type: Cardinal; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;

This item has no description.

PFNGLGETNTEXIMAGEARBPROC = procedure(target: Cardinal; level: TGLint; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; img: Pointer); stdcall;

This item has no description.

PFNGLGETNUNIFORMDVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETNUNIFORMFVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETNUNIFORMIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;

This item has no description.

PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: Cardinal; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;

This item has no description.

PFNGLGetObjectLabel = procedure(identifier : Cardinal; name : Cardinal; bufsize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: TGLhandleARB; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetObjectPtrLabel = procedure(const ptr : Pointer; bufSize : TGLsizei; length : PGLsizei; label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPATHCOMMANDSNVPROC = procedure (path: Cardinal; commands: PGLubyte); stdcall;

This item has no description.

PFNGLGETPATHCOORDSNVPROC = procedure (path: Cardinal; coords: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashArray: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHLENGTHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei): TGLfloat; stdcall;

This item has no description.

PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: TGLbitfield; firstPathName: Cardinal; numPaths: TGLsizei; stride: TGLsizei; metrics: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: TGLbitfield; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; stride: TGLsizei; metrics: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: Cardinal; numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; advanceScale: TGLfloat; kerningScale: TGLfloat; transformType: Cardinal; returnedSpacing: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: Cardinal; index_: Cardinal; data: PGLvoid); stdcall;

This item has no description.

PFNGLGETPROGRAMBINARYPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PCardinal; binary: Pointer); stdcall;

GL_ARB_get_program_binary (ARB #96)

PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGetProgramInterfaceiv = procedure(program_ : Cardinal;programInterface : Cardinal; pname : Cardinal; params : PGLint); stdcall;

GL_ARB_program_interface_query (ARB #134)

PFNGLGETPROGRAMIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMIVNVPROC = procedure (id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMIVPROC = procedure(_program: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: Cardinal; index: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGetProgramResourceIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : Cardinal; stdcall;

This item has no description.

PFNGLGetProgramResourceiv = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; propCount : TGLsizei; const props : PCardinal; bufSize : TGLsizei; length : PGLsizei; params : PGLint); stdcall;

This item has no description.

PFNGLGetProgramResourceLocation = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;

This item has no description.

PFNGLGetProgramResourceLocationIndex = function(program_ : Cardinal;programInterface : Cardinal; const name : PAnsiChar) : TGLint; stdcall;

This item has no description.

PFNGLGetProgramResourceName = procedure(program_ : Cardinal;programInterface : Cardinal; index : Cardinal; bufSize : TGLsizei; length : PGLsizei; name : PAnsiChar); stdcall;

This item has no description.

PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: Cardinal; shadertype: Cardinal; pname: Cardinal; values: PGLint); stdcall;

This item has no description.

PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: Cardinal; pname: Cardinal; _string: pointer); stdcall;

This item has no description.

PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: Cardinal; pname: Cardinal; programIdx: PGLubyte); stdcall;

This item has no description.

PFNGLGETQUERYINDEXEDIVPROC = procedure(target: Cardinal; index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYIVARBPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64EXT); stdcall;

GL_EXT_timer_query (EXT #319)

PFNGLGETQUERYOBJECTI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint64); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint64); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETQUERYOBJECTUIVPROC = procedure(id: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: Cardinal; row, column, span: Pointer); stdcall;

deprecated;

PFNGLGETSHADERINFOLOGPROC = procedure(shader: Cardinal; bufSize: TGLsizei; length: PGLsizei; infoLog: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSHADERIVPROC = procedure(shader: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: Cardinal; precisiontype: Cardinal; range: PGLint; precision: PGLint); stdcall;

This item has no description.

PFNGLGETSHADERSOURCEARBPROC = procedure(obj: TGLhandleARB; maxLength: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSHADERSOURCEPROC = procedure(shader:Cardinal; bufSize: TGLsizei; length: PGLsizei; source: PAnsiChar); stdcall;

This item has no description.

PFNGLGETSTRINGIPROC = function(name: Cardinal; index: Cardinal): PAnsiChar; stdcall;

This item has no description.

PFNGLGETSUBROUTINEINDEXPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: Cardinal; shadertype: Cardinal; const name: PAnsiChar): TGLint; stdcall;

GL_ARB_shader_subroutine (ARB #90)

PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; format: Cardinal; type_: Cardinal; pixels: PGLvoid); stdcall;

This item has no description.

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; pname: Cardinal; params: TGLint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: Cardinal; address: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: Cardinal; index: Cardinal; location: PGLint); stdcall;

This item has no description.

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: Cardinal; index: Cardinal; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PCardinal; name: PAnsiChar); stdcall;

This item has no description.

PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: Cardinal; uniformBlockName: PAnsiChar): Cardinal; stdcall;

This item has no description.

PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: Cardinal; location: TGLint): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMDVPROC = procedure(_program: Cardinal; location: TGLint; params : PGLdouble); stdcall;

This item has no description.

PFNGLGETUNIFORMFVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETUNIFORMFVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETUNIFORMINDICESPROC = procedure(_program: Cardinal; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

GL_ARB_uniform_buffer_object (ARB #57)

PFNGLGETUNIFORMIVARBPROC = procedure(programObj: TGLhandleARB; location: TGLint; params: PGLint); stdcall;

This item has no description.

PFNGLGETUNIFORMIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLint); stdcall;

This item has no description.

PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: TGLhandleARB; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMLOCATIONPROC = function(_program: Cardinal; const name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: Cardinal; location: TGLint): PGLint; stdcall;

This item has no description.

PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint64EXT); stdcall;

This item has no description.

PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETUNIFORMUIVPROC = procedure(_program: Cardinal; location: TGLint; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVARYINGLOCATIONNVPROC = function(_program: Cardinal; name: PAnsiChar): TGLint; stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBDVPROC = procedure(index:Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBFVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBIVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: Cardinal; pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: Cardinal; pname: Cardinal; _pointer: pointer); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: Cardinal; pname: Cardinal; pointer: PGLPointer); stdcall;

This item has no description.

PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: Cardinal; pname: Cardinal; _pointer:pointer); stdcall;

This item has no description.

PFNGLHISTOGRAMPROC = procedure(target: Cardinal; width: TGLsizei; internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

PFNGLINDEXFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLINDEXFUNCEXTPROC = procedure(func: Cardinal; ref: TGLfloat); stdcall;

GL_EXT_index_func (EXT #95)

PFNGLINDEXMATERIALEXTPROC = procedure(face: Cardinal; mode: Cardinal); stdcall;

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)

PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: Cardinal; pathA: Cardinal; pathB: Cardinal; weight: TGLfloat); stdcall;

This item has no description.

PFNGLInvalidateBufferData = procedure(buffer : Cardinal); stdcall;

This item has no description.

PFNGLInvalidateBufferSubData = procedure(buffer : Cardinal; offset : TGLintptr; length : TGLsizeiptr); stdcall;

This item has no description.

PFNGLInvalidateFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal); stdcall;

This item has no description.

PFNGLInvalidateSubFramebuffer = procedure(target : Cardinal; numAttachments : TGLsizei; const attachments : PCardinal; x : TGLint; y : TGLint; width : TGLsizei; height : TGLsizei); stdcall;

This item has no description.

PFNGLInvalidateTexImage = procedure(texture : Cardinal; level : TGLint); stdcall;

This item has no description.

PFNGLInvalidateTexSubImage = procedure(texture : Cardinal; level : TGLint; xoffset : TGLint; yoffset : TGLint; zoffset : TGLint; width : TGLsizei; height : TGLsizei; depth : TGLsizei); stdcall;

GL_ARB_invalidate_subdata (ARB #132)

PFNGLISBUFFERARBPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISBUFFERPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISBUFFERRESIDENTNVPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISENABLEDINDEXEDEXTPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISENABLEDIPROC = function(target: Cardinal; index: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISFRAMEBUFFERPROC = function(framebuffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISOCCLUSIONQUERYNVPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPATHNVPROC = function(path: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPOINTINFILLPATHNVPROC = function (path: Cardinal; mask: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLISPOINTINSTROKEPATHNVPROC = function (path: Cardinal; x: TGLfloat; y: TGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMARBPROC = function(_program: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMNVPROC = function (id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMPIPELINEPROC = function(pipeline: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISPROGRAMPROC = function(_program: Cardinal):TGLboolean; stdcall;

This item has no description.

PFNGLISQUERYARBPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISQUERYPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: Cardinal): TGLboolean; stdcall;

GL_EXT_framebuffer_object (EXT #310)

PFNGLISRENDERBUFFERPROC = function(renderbuffer: Cardinal): TGLBoolean; stdcall;

GL_ARB_framebuffer_object (ARB #45)

PFNGLISSAMPLERPROC = function(sampler: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISSHADERPROC = function(shader: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;

This item has no description.

PFNGLISTEXTUREEXTPROC = function(texture: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISTRANSFORMFEEDBACKPROC = function(id: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLISVERTEXARRAYPROC = function(_array: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLLINKPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLLINKPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLLOADPROGRAMNVPROC = procedure (target: Cardinal; id: Cardinal; len: TGLSizei; programIdx: PGLubyte); stdcall;

This item has no description.

PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

This item has no description.

PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

deprecated;

PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

GL_ARB_transpose_matrix (ARB #3)

PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;

GL_EXT_compiled_vertex_array (EXT #97)

PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: Cardinal); stdcall;

This item has no description.

PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: Cardinal; access: Cardinal); stdcall;

GL_NV_shader_buffer_load (EXT #379)

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: Cardinal); stdcall;

This item has no description.

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: Cardinal; access: Cardinal); stdcall;

This item has no description.

PFNGLMAPBUFFERARBPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;

This item has no description.

PFNGLMAPBUFFERPROC = function(target: Cardinal; access: Cardinal): Pointer; stdcall;

This item has no description.

PFNGLMAPBUFFERRANGEPROC = function(target: Cardinal; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

GL_ARB_map_buffer_range (ARB #50)

PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal; access: Cardinal): PGLvoid; stdcall;

This item has no description.

PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: Cardinal; offset: TGLintptr; length: TGLsizeiptr; access: TGLbitfield): PGLvoid; stdcall;

This item has no description.

PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;

This item has no description.

PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;

This item has no description.

PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;

This item has no description.

PFNGLMATRIXLOADDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXLOADFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXMULTDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXMULTFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: Cardinal; const m: PGLdouble); stdcall;

This item has no description.

PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: Cardinal; const m: PGLfloat); stdcall;

This item has no description.

PFNGLMATRIXORTHOEXTPROC = procedure(mode: Cardinal; left: TGLdouble; right: TGLdouble; bottom: TGLdouble; top: TGLdouble; zNear: TGLdouble; zFar: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXPOPEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXPUSHEXTPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLMATRIXROTATEDEXTPROC = procedure(mode: Cardinal; angle: TGLdouble; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXROTATEFEXTPROC = procedure(mode: Cardinal; angle: TGLfloat; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMATRIXSCALEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXSCALEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLMINMAXPROC = procedure(target, internalformat: Cardinal; sink: TGLboolean); stdcall;

deprecated;

PFNGLMINSAMPLESHADINGARBPROC = procedure(value: Single); stdcall;

GL_ARB_sample_shading (ARB #70)

PFNGLMINSAMPLESHADINGPROC = procedure(value: Single); stdcall;

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)

PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

GL_EXT_multi_draw_arrays (EXT #148)

PFNGLMultiDrawArraysIndirect = procedure(mode : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;

GL_ARB_multi_draw_indirect (ARB #133)

PFNGLMULTIDRAWARRAYSPROC = procedure(mode: Cardinal; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: Cardinal; count: PGLsizei; _type: Cardinal; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

This item has no description.

PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLMultiDrawElementsIndirect = procedure(mode : Cardinal; type_ : Cardinal; const indirect : Pointer; drawcount : TGLsizei; stride : TGLsizei); stdcall;

This item has no description.

PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: Cardinal; Count: PGLsizei; AType: Cardinal; var indices; primcount: TGLsizei); stdcall;

This item has no description.

PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; interformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DARBPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DPROC = procedure(target: Cardinal; s: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD1FARBPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1FPROC = procedure(target: Cardinal; s: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1FVPROC = procedure(target: Cardinal; v: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD1IARBPROC = procedure(target: Cardinal; s: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1IPROC = procedure(target: Cardinal; s: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: Cardinal; v: PGLInt); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1IVPROC = procedure(target: Cardinal; v: PGLInt); stdcall;

deprecated;

PFNGLMULTITEXCOORD1SARBPROC = procedure(target: Cardinal; s: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1SPROC = procedure(target: Cardinal; s: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD1SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD2DARBPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2DPROC = procedure(target: Cardinal; s, t: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD2FARBPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2FPROC = procedure(target: Cardinal; s, t: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD2IARBPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2IPROC = procedure(target: Cardinal; s, t: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD2SARBPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2SPROC = procedure(target: Cardinal; s, t: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD2SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD3DARBPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3DPROC = procedure(target: Cardinal; s, t, r: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD3FARBPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3FPROC = procedure(target: Cardinal; s, t, r: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD3IARBPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3IPROC = procedure(target: Cardinal; s, t, r: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD3SARBPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3SPROC = procedure(target: Cardinal; s, t, r: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD3SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD4DARBPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4DPROC = procedure(target: Cardinal; s, t, r, q: TGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4DVPROC = procedure(target: Cardinal; v: PGLdouble); stdcall;

deprecated;

PFNGLMULTITEXCOORD4FARBPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4FPROC = procedure(target: Cardinal; s, t, r, q: TGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4FVPROC = procedure(target: Cardinal; v: PGLfloat); stdcall;

deprecated;

PFNGLMULTITEXCOORD4IARBPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4IPROC = procedure(target: Cardinal; s, t, r, q: TGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4IVPROC = procedure(target: Cardinal; v: PGLint); stdcall;

deprecated;

PFNGLMULTITEXCOORD4SARBPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4SPROC = procedure(target: Cardinal; s, t, r, q: TGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLMULTITEXCOORD4SVPROC = procedure(target: Cardinal; v: PGLshort); stdcall;

deprecated;

PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: Cardinal; _type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: Cardinal; _type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: Cardinal; size: TGLint; type_: Cardinal; stride: TGLsizei; const pointer: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXENVFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXENVIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXGENDEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLMULTITEXGENFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXGENIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels:PGLvoid); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

deprecated;

PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

This item has no description.

PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

deprecated;

PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: Cardinal; size: TGLsizei; const data: PGLvoid; usage: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: Cardinal; offset: TGLintptr; size: TGLsizeiptr; const data: PGLvoid); stdcall;

This item has no description.

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: Cardinal; writeBuffer: Cardinal; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

This item has no description.

PFNGLNamedFramebufferParameteri = procedure(framebuffer : Cardinal; pname : Cardinal; param : TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; renderbuffertarget: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; textarget: Cardinal; texture: Cardinal; level: TGLint; zoffset: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; face: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLfloat); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: Cardinal; target: Cardinal; index_: Cardinal; count: TGLsizei; const params: PGLuint); stdcall;

This item has no description.

PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: Cardinal; target: Cardinal; format: Cardinal; len: TGLsizei; const string_: PGLvoid); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: Cardinal; interformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: Cardinal; coverageSamples: TGLsizei; colorSamples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLNORMALFORMATNVPROC = procedure(_type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLNORMALP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLNORMALP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLObjectLabel = procedure(identifier : Cardinal; name : Cardinal; length : TGLsizei; const label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLObjectPtrLabel = procedure(const ptr : Pointer; length : TGLsizei; const label_ : PAnsiChar); stdcall;

This item has no description.

PFNGLPATCHPARAMETERFVPROC = procedure(pname: Cardinal; const values: PGLfloat); stdcall;

This item has no description.

PFNGLPATCHPARAMETERIPROC = procedure(pname: Cardinal; value: TGLint); stdcall;

GL_ARB_tessellation_shader (ARB #91)

PFNGLPATHCOLORGENNVPROC = procedure (color: Cardinal; genMode: Cardinal; colorFormat: Cardinal; coeffs: PGLfloat); stdcall;

This item has no description.

PFNGLPATHCOMMANDSNVPROC = procedure(path: Cardinal; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHCOORDSNVPROC = procedure(path: Cardinal; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: Cardinal); stdcall;

This item has no description.

PFNGLPATHDASHARRAYNVPROC = procedure (path: Cardinal; dashCount: TGLsizei; dashArray: PGLfloat); stdcall;

This item has no description.

PFNGLPATHFOGGENNVPROC = procedure (genMode: Cardinal); stdcall;

This item has no description.

PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PAnsiChar; fontStyle: TGLbitfield; firstGlyph: Cardinal; numGlyphs: TGLsizei; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;

This item has no description.

PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: Cardinal; fontTarget: Cardinal; fontName: PGLvoid; fontStyle: TGLbitfield; numGlyphs: TGLsizei; _type: Cardinal; charcodes: PGLvoid; handleMissingGlyphs: Cardinal; pathParameterTemplate: Cardinal; emScale: TGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERFNVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERFVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLfloat); stdcall;

This item has no description.

PFNGLPATHPARAMETERINVPROC = procedure (path: Cardinal; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

PFNGLPATHPARAMETERIVNVPROC = procedure (path: Cardinal; pname: Cardinal; value: PGLint); stdcall;

This item has no description.

PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: TGLfloat; units: TGLfloat); stdcall;

This item has no description.

PFNGLPATHSTENCILFUNCNVPROC = procedure (func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLPATHSTRINGNVPROC = procedure(path: Cardinal; format: Cardinal; length: TGLsizei; pathString: PGLvoid); stdcall;

This item has no description.

PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: Cardinal; commandStart: TGLsizei; commandsToDelete: TGLsizei; numCommands: TGLsizei; commands: PGLubyte; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHSUBCOORDSNVPROC = procedure(path: Cardinal; coordStart: TGLsizei; numCoords: TGLsizei; coordType: Cardinal; coords: PGLvoid); stdcall;

This item has no description.

PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: Cardinal; genMode: Cardinal; components: TGLint; coeffs: PGLfloat); stdcall;

This item has no description.

PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLPOINTALONGPATHNVPROC = function (path: Cardinal; startSegment: TGLsizei; numSegments: TGLsizei; distance: TGLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): TGLboolean; stdcall;

This item has no description.

PFNGLPOINTPARAMETERFARBPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

GL_ARB_point_parameter (ARB #14)

PFNGLPOINTPARAMETERFPROC = procedure(pname: Cardinal; param: TGLfloat); stdcall;

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLPOINTPARAMETERFVPROC = procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

PFNGLPOINTPARAMETERINVPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

GL_NV_point_sprite (EXT #262)

PFNGLPOINTPARAMETERIPROC = procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLPOINTPARAMETERIVPROC = procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;

GL_EXT_polygon_offset (EXT #3)

PFNGLPopDebugGroup = procedure; stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: Cardinal); stdcall;

This item has no description.

PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;

GL_NV_primitive_restart (EXT #285)

PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;

This item has no description.

PFNGLPROGRAMBINARYPROC = procedure(_program: Cardinal; binaryFormat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLfloat); stdcall;

GL_EXT_gpu_program_parameters (EXT #320)

PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: Cardinal; index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: Cardinal; index: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:Cardinal; index:Cardinal; count:TGLsizei; const params:PGLFloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLdouble ); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: Cardinal; index: Cardinal; x, y, z, w: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: Cardinal; index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;

GL_ARB_geometry_shader4 (ARB #47)

PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:Cardinal; pname:Cardinal; value: TGLint); stdcall;

GL_EXT_geometry_shader4 (EXT #324)

PFNGLPROGRAMPARAMETERIPROC = procedure(_program: Cardinal; pname: Cardinal; value: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: Cardinal; index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMSTRINGARBPROC = procedure(target: Cardinal; format: Cardinal; len: TGLsizei; const _string: pointer); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: Cardinal; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: Cardinal; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: Cardinal; location: TGLint; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: Cardinal; location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: Cardinal; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: Cardinal; limit: TGLint); stdcall;

GL_NV_geometry_program4 (EXT #323)

PFNGLPROVOKINGVERTEXPROC = procedure(mode: Cardinal); stdcall;

GL_ARB_provoking_vertex (ARB #64)

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: TGLbitfield); stdcall;

This item has no description.

PFNGLPushDebugGroup = procedure(source : Cardinal; id : Cardinal; length : TGLsizei; const message_ : PAnsiChar); stdcall;

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)

PFNGLQUERYCOUNTERPROC = procedure(id: Cardinal; target: Cardinal); stdcall;

GL_ARB_timer_query (ARB #85)

PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; _type: Cardinal; bufSize: TGLsizei; data: Pointer); stdcall;

This item has no description.

PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;

GL_ARB_ES2_compatibility (ARB #95)

PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

GL_EXT_framebuffer_multisample (EXT #317)

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: Cardinal; internalformat: Cardinal; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;

This item has no description.

PFNGLRESETHISTOGRAMPROC = procedure(target: Cardinal); stdcall;

deprecated;

PFNGLRESETMINMAXPROC = procedure(target: Cardinal); stdcall;

deprecated;

PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;

GL_MESA_resize_buffers (EXT #196)

PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;

This item has no description.

PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_ARB_multisample (ARB #5)

PFNGLSAMPLECOVERAGEPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

promoted to core v1.3 from GL_ARB_multisample (#5)

PFNGLSAMPLEMASKEXTPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_EXT_multisample (EXT #209)

PFNGLSAMPLEMASKIPROC = procedure(index: Cardinal; mask: TGLbitfield); stdcall;

This item has no description.

PFNGLSAMPLEMASKSGISPROC = procedure(Value: Single; invert: TGLboolean); stdcall;

GL_SGIS_multisample (EXT #25)

PFNGLSAMPLEPASSARBPROC = procedure(pass: Cardinal); stdcall;

ARB Extensions unknown ARB extension

PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: Cardinal); stdcall;

This item has no description.

PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: Cardinal); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLSCISSORARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLint); stdcall;

This item has no description.

PFNGLSCISSORINDEXEDPROC = procedure(index: Cardinal; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

This item has no description.

PFNGLSCISSORINDEXEDVPROC = procedure(index: Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;

GL_EXT_secondary_color (EXT #145)

PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: Cardinal); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: Cardinal); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;

deprecated;

PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;

This item has no description.

PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;

deprecated;

PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: Cardinal; color: Cardinal); stdcall;

This item has no description.

PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: Cardinal; const color: PGLuint); stdcall;

This item has no description.

PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

This item has no description.

PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: Cardinal; stride: TGLsizei; p: pointer); stdcall;

deprecated;

PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: Cardinal; width, height: TGLsizei; format, Atype: Cardinal; row, column: Pointer); stdcall;

deprecated;

PFNGLSETFENCENVPROC = procedure(fence: Cardinal; condition: Cardinal); stdcall;

This item has no description.

PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: Cardinal; binary: Pointer; length: TGLsizei); stdcall;

This item has no description.

PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: TGLhandleARB; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

PFNGLSHADERSOURCEPROC = procedure(shader: Cardinal; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

This item has no description.

PFNGLShaderStorageBlockBinding = procedure(program_ : Cardinal; storageBlockIndex : Cardinal; storageBlockBinding : Cardinal); stdcall;

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)

PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: Cardinal); stdcall;

GL_EXT_stencil_clear_tag (EXT #314)

PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; fillMode: Cardinal; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLSTENCILFILLPATHNVPROC = procedure (path: Cardinal; fillMode: Cardinal; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILMASKSEPARATEPROC = procedure(face: Cardinal; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: Cardinal); stdcall;

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: TGLsizei; pathNameType: Cardinal; paths: PGLvoid; pathBase: Cardinal; reference: TGLint; mask: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: Cardinal; reference: TGLint; mask: Cardinal); stdcall;

This item has no description.

PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: TGLsizei; str: PAnsiChar); stdcall;

GL_GREMEDY_string_marker (EXT #311)

PFNGLTBUFFERMASK3DFXPROC = procedure(mask: Cardinal); stdcall;

GL_3DFX_tbuffer (EXT #208)

PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: TGLfloat); stdcall;

GL_AMD_vertex_shader_tessellator (EXT #363)

PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: Cardinal); stdcall;

This item has no description.

PFNGLTESTFENCENVPROC = function(fence: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLTEXBUFFERARBPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

GL_ARB_texture_buffer_object (ARB #51)

PFNGLTEXBUFFEREXTPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)

PFNGLTEXBUFFERPROC = procedure(target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLTexBufferRange = procedure(target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset: TGLintptr; size : TGLsizeiptr); stdcall;

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)

PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLTEXCOORDP1UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP1UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP2UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP2UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP3UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP3UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXCOORDP4UIPROC = procedure(_type: Cardinal; coords: Cardinal); stdcall;

This item has no description.

PFNGLTEXCOORDP4UIVPROC = procedure(_type: Cardinal; const coords: PGLuint); stdcall;

This item has no description.

PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

GL_ARB_texture_multisample (ARB #67)

PFNGLTEXIMAGE3DEXTPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; Format, AType: Cardinal; pixels: Pointer); stdcall;

GL_EXT_texture3D (EXT #6)

PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: Cardinal; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

This item has no description.

PFNGLTEXIMAGE3DPROC = procedure(target: Cardinal; level: TGLint; internalformat: Cardinal; width, height, depth: TGLsizei; border: TGLint; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

promoted to core v1.2 from GL_EXT_texture3D (#6)

PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

PFNGLTEXPARAMETERIIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLint); stdcall;

promoted to core v3.0 from GL_EXT_texture_integer

PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLTEXPARAMETERIUIVPROC = procedure(target: Cardinal; pname: Cardinal; params: PGLuint); stdcall;

This item has no description.

PFNGLTexStorage2DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)

PFNGLTexStorage3DMultisample = procedure(target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: Cardinal; level, xoffset: TGLint; width: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

GL_EXT_subtexture (EXT #9)

PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXSUBIMAGE3DPROC = procedure(target: Cardinal; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: Cardinal; Atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; internalformat: Cardinal; buffer: Cardinal); stdcall;

This item has no description.

PFNGLTextureBufferRange = procedure(texture : Cardinal; target : Cardinal; internalformat : Cardinal; buffer : Cardinal; offset : TGLintptr; size : TGLsizeiptr); stdcall;

This item has no description.

PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;

GL_SGIS_texture_color_mask (EXT #214)

PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; internalformat: Cardinal; width: TGLsizei; height: TGLsizei; depth: TGLsizei; border: TGLint; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLfloat); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; param: TGLint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLuint); stdcall;

This item has no description.

PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: Cardinal; target: Cardinal; pname: Cardinal; const params: PGLint); stdcall;

This item has no description.

PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: Cardinal; target: Cardinal; renderbuffer: Cardinal); stdcall;

This item has no description.

PFNGLTextureStorage2DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTextureStorage3DMultisample = procedure(texture : Cardinal; target : Cardinal; samples : TGLsizei; internalformat : Cardinal; width : TGLsizei; height : TGLsizei; depth : TGLsizei; fixedsamplelocations : TGLboolean); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; width: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; width: TGLsizei; height: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: Cardinal; target: Cardinal; level: TGLint; xoffset: TGLint; yoffset: TGLint; zoffset: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; format: Cardinal; type_: Cardinal; const pixels: PGLvoid); stdcall;

This item has no description.

PFNGLTextureView = procedure(texture : Cardinal; target : Cardinal; origtexture : Cardinal; internalformat : Cardinal; minlevel : Cardinal; numlevels : Cardinal; minlayer : Cardinal; numlayers : Cardinal); stdcall;

GL_ARB_texture_view (ARB #124)

PFNGLTRACKMATRIXNVPROC = procedure (target: Cardinal; address: Cardinal; matrix: Cardinal; transform: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: Cardinal; count: TGLsizei; locations: PGLint; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: Cardinal; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: Cardinal); stdcall;

This item has no description.

PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: Cardinal; srcPath: Cardinal; transformType: Cardinal; transformValues: PGLfloat); stdcall;

This item has no description.

PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;

This item has no description.

PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;

GL_ARB_gpu_shader_fp64 (ARB #89)

PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM1FARBPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FPROC = procedure(location: TGLint; v0: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM1IARBPROC = procedure(location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IPROC = procedure(location: TGLint; v0: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM1IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM2FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM2IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM2IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM3FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM3IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM3IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORM4FARBPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FPROC = procedure(location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4FVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORM4IARBPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IPROC = procedure(location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IVARBPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM4IVPROC = procedure(location: TGLint; count: TGLsizei; value: PGLint); stdcall;

This item has no description.

PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: Cardinal; v1: Cardinal; v2: Cardinal; v3: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: Cardinal; uniformBlockIndex: Cardinal; uniformBlockBinding: Cardinal); stdcall;

This item has no description.

PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: Cardinal; location: TGLint; buffer: Cardinal); stdcall;

GL_EXT_bindable_uniform (EXT #342)

PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

core 2.1 new commands in OpenGL 2.1

PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

This item has no description.

PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

This item has no description.

PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: Cardinal; count: TGLsizei; const indices: PGLuint); stdcall;

This item has no description.

PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;

This item has no description.

PFNGLUNIFORMUI64VNVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

This item has no description.

PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;

This item has no description.

PFNGLUNMAPBUFFERARBPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNMAPBUFFERPROC = function(target: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: Cardinal): TGLboolean; stdcall;

This item has no description.

PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

GLU extensions (might not be same naming as c versions?)

PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLUSEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: Cardinal; stages: TGLbitfield; _program: Cardinal); stdcall;

GL_ARB_separate_shader_objects (ARB #97)

PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: TGLhandleARB); stdcall;

This item has no description.

PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: Cardinal); stdcall;

This item has no description.

PFNGLVALIDATEPROGRAMPROC = procedure(_program: Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayBindVertexBuffer = procedure(vaobj : Cardinal; bindingindex : Cardinal; buffer : Cardinal; offset : TGLintptr; stride : TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribBinding = procedure(vaobj : Cardinal; attribindex : Cardinal; bindingindex : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribIFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVertexArrayVertexAttribLFormat = procedure(vaobj : Cardinal; attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: Cardinal; buffer: Cardinal; index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; offset: TGLintptr); stdcall;

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available

PFNGLVertexArrayVertexBindingDivisor = procedure(vaobj : Cardinal; bindingindex : Cardinal; divisor : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DARBPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;

GL_ARB_vertex_program (ARB #26)

PFNGLVERTEXATTRIB1DNVPROC = procedure (index: Cardinal; x: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DPROC = procedure(index:Cardinal; x: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FARBPROC = procedure(index: Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FNVPROC = procedure (index: Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FPROC = procedure(index:Cardinal; x: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SARBPROC = procedure(index: Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SNVPROC = procedure (index: Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SPROC = procedure(index:Cardinal; x: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB1SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DPROC = procedure(index:Cardinal; x,y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FPROC = procedure(index:Cardinal; x,y: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SPROC = procedure(index:Cardinal; x,y: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB2SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DPROC = procedure(index:Cardinal; x,y,z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FNVPROC = procedure (index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FPROC = procedure(index:Cardinal; x,y,z: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SPROC = procedure(index:Cardinal; x,y,z: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB3SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4BVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DARBPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DNVPROC = procedure (index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DPROC = procedure(index:Cardinal; x,y,z,w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: Cardinal; const v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4DVPROC = procedure(index:Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FARBPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FNVPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FPROC = procedure(index:Cardinal; x,y,z,w: TGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: Cardinal; const v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4FVPROC = procedure(index:Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4IVPROC = procedure(index:Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: Cardinal; const v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NBVPROC = procedure(index:Cardinal; v: PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: Cardinal; const v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NIVPROC = procedure(index:Cardinal; v: PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NSVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: Cardinal; x: TGLubyte; y: TGLubyte; z: TGLubyte; w: TGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBPROC = procedure(index:Cardinal; x,y,z,w: TGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SARBPROC = procedure(index: Cardinal; x: TGLshort; y: TGLshort; z: TGLshort; w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SNVPROC = procedure (index: Cardinal; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SPROC = procedure(index:Cardinal; x,y,z,w: TGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: Cardinal; const v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4SVPROC = procedure(index:Cardinal; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: Cardinal; const v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UBVPROC = procedure(index:Cardinal; v: PGLubyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: Cardinal; const v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4UIVPROC = procedure(index:Cardinal; v: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: Cardinal; const v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIB4USVPROC = procedure(index:Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVertexAttribBinding = procedure(attribindex : Cardinal; bindingindex : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;

GL_ARB_instanced_arrays (ARB #49)

PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: Cardinal; divisor: Cardinal); stdcall;

Core 3.3

PFNGLVertexAttribFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; normalized : TGLboolean; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: Cardinal; x: TGLint); stdcall;

GL_EXT_gpu_shader4 (EXT #326)

PFNGLVERTEXATTRIBI1IPROC = procedure(index: Cardinal; x: TGLint); stdcall;

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4

PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: Cardinal; x: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIPROC = procedure(index: Cardinal; x: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4BVPROC = procedure(index: Cardinal; v:PGLbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IPROC = procedure(index: Cardinal; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4IVPROC = procedure(index: Cardinal; v:PGLint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: Cardinal; v:PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4SVPROC = procedure(index: Cardinal; v:PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: Cardinal; v: PGLUbyte); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIPROC = procedure(index: Cardinal; x: Cardinal; y: Cardinal; z: Cardinal; w: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: Cardinal; v:PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBI4USVPROC = procedure(index: Cardinal; v: PGLushort); stdcall;

This item has no description.

PFNGLVertexAttribIFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL1DPROC = procedure(index: Cardinal; x: TGLdouble); stdcall;

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)

PFNGLVERTEXATTRIBL1DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL2DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL2DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL3DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL3DVPROC = procedure(index: Cardinal; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL4DPROC = procedure(index: Cardinal; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBL4DVPROC = procedure(index: Cardinal; v :PGLdouble); stdcall;

This item has no description.

PFNGLVertexAttribLFormat = procedure(attribindex : Cardinal; size : TGLint; type_ : Cardinal; relativeoffset : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; stride: TGLsizei; ptr: Pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP1UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP2UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP3UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP4UIPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: Cardinal; _type: Cardinal; normalized: TGLboolean; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride: TGLsizei; const _pointer: pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: Cardinal; fsize: TGLint; vertextype: Cardinal; stride: TGLSizei; pointer: Pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:Cardinal; size: TGLint; _type: Cardinal; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLdouble); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLfloat); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLshort); stdcall;

This item has no description.

PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: Cardinal; count: TGLSizei; v: PGLubyte); stdcall;

This item has no description.

PFNGLVertexBindingDivisor = procedure(bindingindex : Cardinal; divisor : Cardinal); stdcall;

This item has no description.

PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;

This item has no description.

PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: Cardinal; stride: TGLsizei); stdcall;

This item has no description.

PFNGLVERTEXP2UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

PFNGLVERTEXP2UIVPROC = procedure(_type: Cardinal; const value: PGLuint ); stdcall;

This item has no description.

PFNGLVERTEXP3UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXP3UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

PFNGLVERTEXP4UIPROC = procedure(_type: Cardinal; value: Cardinal); stdcall;

This item has no description.

PFNGLVERTEXP4UIVPROC = procedure(_type: Cardinal; const value: PGLuint); stdcall;

This item has no description.

PFNGLVIEWPORTARRAYVPROC = procedure(first: Cardinal; count: TGLsizei; v: PGLfloat); stdcall;

GL_ARB_viewport_array (ARB #100)

PFNGLVIEWPORTINDEXEDFPROC = procedure(index: Cardinal; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;

This item has no description.

PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: Cardinal; v: PGLfloat); stdcall;

This item has no description.

PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

This item has no description.

PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;

GL_ARB_vertex_blend (ARB #15) {deprecated?}

PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;

This item has no description.

PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;

This item has no description.

PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;

This item has no description.

PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: Cardinal; numPaths: TGLsizei; paths: PGLuint; weights: PGLfloat); stdcall;

This item has no description.

PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: Cardinal; stride:TGLsizei; _pointer:pointer); stdcall;

This item has no description.

PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;

This item has no description.

PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;

This item has no description.

PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;

This item has no description.

PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;

This item has no description.

PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;

GL_ARB_window_pos (ARB #25)

PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;

deprecated;

PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;

deprecated;

PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;

This item has no description.

PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;

deprecated;

PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;

This item has no description.

PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;

deprecated;

PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;

deprecated;

PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;

This item has no description.

PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;

deprecated;

PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;

deprecated;

PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;

This item has no description.

PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;

deprecated;

PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

This item has no description.

PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

WGL_ARB_render_texture (ARB #20)

PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: Cardinal; piFormats: PGLint; nNumFormats: PCardinal) : BOOL; stdcall;

This item has no description.

PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;

This item has no description.

PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: Cardinal) : Integer; stdcall;

WGL WGL - ARB WGL_buffer_region (ARB #4)

PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

WGL_ARB_create_context (ARB #55)

PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: TGLint; iWidth, iHeight : TGLint; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

WGL_ARB_pbuffer (ARB #11)

PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;

This item has no description.

PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;

This item has no description.

PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

This item has no description.

PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;

This item has no description.

PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;

This item has no description.

PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: Cardinal): BOOL; stdcall;

This item has no description.

PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;

This item has no description.

PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: Cardinal; atype: Cardinal; access: Cardinal): THandle; stdcall;

This item has no description.

PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;

WGL_NV_DX_interop (EXT #407)

PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: TGLint; hObjects: PHandle): BOOL; stdcall;

This item has no description.

PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;

This item has no description.

PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;

This item has no description.

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

This item has no description.

PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

WGL_NV_gpu_affinity (EXT #355)

PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;

This item has no description.

PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;

This item has no description.

PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PAnsiChar; stdcall;

WGL_ARB_extensions_string (ARB #8)

PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

This item has no description.

PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

This item has no description.

PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: Cardinal; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

WGL_ARB_pixel_format (ARB #9)

PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;

This item has no description.

PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

WGL_make_current_read (ARB #10)

PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

This item has no description.

PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

This item has no description.

PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

This item has no description.

PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

This item has no description.

PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

This item has no description.

PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

This item has no description.

PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;

WGL - EXT WGL_EXT_swap_control (EXT #172)

PGLbitfield = ˆTGLbitfield;

UINT

PGLboolean = ˆTGLboolean;

This item has no description.

PGLbyte = ˆTGLbyte;

This item has no description.

PGLchar = MarshaledAString;

This item has no description.

PGLclampd = System.PDouble;

This item has no description.

PGLclampf = System.PSingle;

This item has no description.

PGLdouble = System.PDouble;

This item has no description.

PGLenum = ˆTGLenum;

This item has no description.

PGLfloat = System.PSingle;

This item has no description.

PGLhalf = ˆTGLhalf;

This item has no description.

PGLhandleARB = ˆTGLhandleARB;

This item has no description.

PGLint = System.PInteger;

This item has no description.

PGLint64 = System.PInt64;

This item has no description.

PGLint64EXT = System.PInt64;

This item has no description.

PGLintptr = ˆTGLintptr;

This item has no description.

PGLPCharArray = ˆPAnsiChar;

This item has no description.

PGLPointer = ˆPGLvoid;

This item has no description.

PGLshort = ˆTGLshort;

This item has no description.

PGLsizei = System.PInteger;

This item has no description.

PGLsizeiptr = ˆTGLsizeiptr;

This item has no description.

PGLsync = ˆTGLsync;

This item has no description.

PGLubyte = System.PByte;

This item has no description.

PGLuint = System.PCardinal;

This item has no description.

PGLuint64 = System.PUInt64;

This item has no description.

PGLuint64EXT = System.PUInt64;

This item has no description.

PGLUNurbs = ˆTGLUNurbs;

This item has no description.

PGLUNurbsObj = PGLUNurbs;

This item has no description.

PGLUQuadric = ˆTGLUQuadric;

This item has no description.

PGLUQuadricObj = PGLUQuadric;

This item has no description.

PGLushort = System.PWord;

This item has no description.

PGLUTesselator= ˆTGLUTesselator;

This item has no description.

PGLUTesselatorObj = PGLUTesselator;

This item has no description.

PGLUTriangulatorObj = PGLUTesselator;

This item has no description.

PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;

This item has no description.

PGLvoid = Pointer;

This item has no description.

PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: Cardinal; index: Cardinal; result: PGLuint64EXT); stdcall;

This item has no description.

PGPUDEVICE = ˆTGPUDEVICE;

This item has no description.

PHGPUNV = ˆHGPUNV;

This item has no description.

PHVIDEOINPUTDEVICENV = ˆHVIDEOINPUTDEVICENV;

This item has no description.

PWGLswap = ˆTWGLswap;

========= Windows types ==============

TDebugProc = procedure( source: Cardinal; type_: Cardinal; id: Cardinal; severity: Cardinal; length: TGLsizei; const message: PAnsiChar; userParam: Pointer); stdcall;

This item has no description.

TDebugProcAMD = procedure( id: Cardinal; category: Cardinal; severity: Cardinal; length: TGLsizei; message: PAnsiChar; userParam: Pointer); stdcall;

This item has no description.

TGLbitfield = LongWord;

This item has no description.

TGLboolean = BYTEBOOL;

=========== OpenGL types ============

TGLbyte = ShortInt;

This item has no description.

TGLchar = Byte;

This item has no description.

TGLclampd = Double;

This item has no description.

TGLDEBUGPROCARB = TDebugProc;

This item has no description.

TGLdouble = Double;

This item has no description.

TGLenum = Cardinal;

This item has no description.

TGLfloat = Single;

This item has no description.

TGLhalf = WORD;

This item has no description.

TGLhandleARB = Cardinal;

This item has no description.

TGLint = Integer;

This item has no description.

TGLint64 = Int64;

This item has no description.

TGLint64EXT = Int64;

This item has no description.

TGLintptr = NativeInt;

the size of these depend on platform (32bit or 64bit)

TGLshort = SmallInt;

This item has no description.

TGLsizei = Integer;

This item has no description.

TGLsizeiptr = NativeInt;

This item has no description.

TGLsync = NativeInt;

This item has no description.

TGLubyte = Byte;

This item has no description.

TGLuint = Cardinal;

This item has no description.

TGLuint64 = UInt64;

This item has no description.

TGLuint64EXT = UInt64;

This item has no description.

TGLUNurbsErrorProc = procedure(ErrorCode: Cardinal); stdcall;

This item has no description.

TGLUNurbsObj = TGLUNurbs;

backwards compatibility

TGLUQuadricErrorProc = procedure(errorCode: Cardinal); stdcall;

Callback function prototypes

TGLUQuadricObj = TGLUQuadric;

This item has no description.

TGLushort = Word;

This item has no description.

TGLUTessBeginDataProc = procedure(AType: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessBeginProc = procedure(AType: Cardinal); stdcall;

This item has no description.

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

This item has no description.

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

This item has no description.

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

This item has no description.

TGLUTesselatorObj = TGLUTesselator;

This item has no description.

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

This item has no description.

TGLUTessEndProc = procedure; stdcall;

This item has no description.

TGLUTessErrorDataProc = procedure(ErrNo: Cardinal; UserData: Pointer); stdcall;

This item has no description.

TGLUTessErrorProc = procedure(ErrNo: Cardinal); stdcall;

This item has no description.

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

This item has no description.

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

This item has no description.

TGLUTriangulatorObj = TGLUTesselator;

This item has no description.

TGLvdpauSurfaceNV = TGLintptr;

This item has no description.

TWGLswap = _WGLSWAP;

This item has no description.

WGLSWAP = _WGLSWAP;

This item has no description.

Constants

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

—————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

This item has no description.

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

This item has no description.

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

This item has no description.

WGL_SAMPLE_BUFFERS_ARB = $2041;

This item has no description.

WGL_SAMPLES_ARB = $2042;

This item has no description.

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)

WGL_DRAW_TO_WINDOW_ARB = $2001;

This item has no description.

WGL_DRAW_TO_BITMAP_ARB = $2002;

This item has no description.

WGL_ACCELERATION_ARB = $2003;

This item has no description.

WGL_NEED_PALETTE_ARB = $2004;

This item has no description.

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

This item has no description.

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

This item has no description.

WGL_SWAP_METHOD_ARB = $2007;

This item has no description.

WGL_NUMBER_OVERLAYS_ARB = $2008;

This item has no description.

WGL_NUMBER_UNDERLAYS_ARB = $2009;

This item has no description.

WGL_TRANSPARENT_ARB = $200A;

This item has no description.

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

This item has no description.

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

This item has no description.

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

This item has no description.

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

This item has no description.

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

This item has no description.

WGL_SHARE_DEPTH_ARB = $200C;

This item has no description.

WGL_SHARE_STENCIL_ARB = $200D;

This item has no description.

WGL_SHARE_ACCUM_ARB = $200E;

This item has no description.

WGL_SUPPORT_GDI_ARB = $200F;

This item has no description.

WGL_SUPPORT_OPENGL_ARB = $2010;

This item has no description.

WGL_DOUBLE_BUFFER_ARB = $2011;

This item has no description.

WGL_STEREO_ARB = $2012;

This item has no description.

WGL_PIXEL_TYPE_ARB = $2013;

This item has no description.

WGL_COLOR_BITS_ARB = $2014;

This item has no description.

WGL_RED_BITS_ARB = $2015;

This item has no description.

WGL_RED_SHIFT_ARB = $2016;

This item has no description.

WGL_GREEN_BITS_ARB = $2017;

This item has no description.

WGL_GREEN_SHIFT_ARB = $2018;

This item has no description.

WGL_BLUE_BITS_ARB = $2019;

This item has no description.

WGL_BLUE_SHIFT_ARB = $201A;

This item has no description.

WGL_ALPHA_BITS_ARB = $201B;

This item has no description.

WGL_ALPHA_SHIFT_ARB = $201C;

This item has no description.

WGL_ACCUM_BITS_ARB = $201D;

This item has no description.

WGL_ACCUM_RED_BITS_ARB = $201E;

This item has no description.

WGL_ACCUM_GREEN_BITS_ARB = $201F;

This item has no description.

WGL_ACCUM_BLUE_BITS_ARB = $2020;

This item has no description.

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

This item has no description.

WGL_DEPTH_BITS_ARB = $2022;

This item has no description.

WGL_STENCIL_BITS_ARB = $2023;

This item has no description.

WGL_AUX_BUFFERS_ARB = $2024;

This item has no description.

WGL_NO_ACCELERATION_ARB = $2025;

This item has no description.

WGL_GENERIC_ACCELERATION_ARB = $2026;

This item has no description.

WGL_FULL_ACCELERATION_ARB = $2027;

This item has no description.

WGL_SWAP_EXCHANGE_ARB = $2028;

This item has no description.

WGL_SWAP_COPY_ARB = $2029;

This item has no description.

WGL_SWAP_UNDEFINED_ARB = $202A;

This item has no description.

WGL_TYPE_RGBA_ARB = $202B;

This item has no description.

WGL_TYPE_COLORINDEX_ARB = $202C;

This item has no description.

WGL_DRAW_TO_PBUFFER_ARB = $202D;

ARB Extension #11 - WGL_ARB_pbuffer

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

This item has no description.

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

This item has no description.

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

This item has no description.

WGL_PBUFFER_LARGEST_ARB = $2033;

This item has no description.

WGL_PBUFFER_WIDTH_ARB = $2034;

This item has no description.

WGL_PBUFFER_HEIGHT_ARB = $2035;

This item has no description.

WGL_PBUFFER_LOST_ARB = $2036;

This item has no description.

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

ARB Extension #20 - WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

This item has no description.

WGL_TEXTURE_FORMAT_ARB = $2072;

This item has no description.

WGL_TEXTURE_TARGET_ARB = $2073;

This item has no description.

WGL_MIPMAP_TEXTURE_ARB = $2074;

This item has no description.

WGL_TEXTURE_RGB_ARB = $2075;

This item has no description.

WGL_TEXTURE_RGBA_ARB = $2076;

This item has no description.

WGL_NO_TEXTURE_ARB = $2077;

This item has no description.

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

This item has no description.

WGL_TEXTURE_1D_ARB = $2079;

This item has no description.

WGL_TEXTURE_2D_ARB = $207A;

This item has no description.

WGL_MIPMAP_LEVEL_ARB = $207B;

This item has no description.

WGL_CUBE_MAP_FACE_ARB = $207C;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

This item has no description.

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

This item has no description.

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

This item has no description.

WGL_FRONT_LEFT_ARB = $2083;

This item has no description.

WGL_FRONT_RIGHT_ARB = $2084;

This item has no description.

WGL_BACK_LEFT_ARB = $2085;

This item has no description.

WGL_BACK_RIGHT_ARB = $2086;

This item has no description.

WGL_AUX0_ARB = $2087;

This item has no description.

WGL_AUX1_ARB = $2088;

This item has no description.

WGL_AUX2_ARB = $2089;

This item has no description.

WGL_AUX3_ARB = $208A;

This item has no description.

WGL_AUX4_ARB = $208B;

This item has no description.

WGL_AUX5_ARB = $208C;

This item has no description.

WGL_AUX6_ARB = $208D;

This item has no description.

WGL_AUX7_ARB = $208E;

This item has no description.

WGL_AUX8_ARB = $208F;

This item has no description.

WGL_AUX9_ARB = $2090;

This item has no description.

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

ARB Extension #46 - GL_ARB_framebuffer_sRGB

WGL_COLOR_SAMPLES_NV = $20B9;

unknown extension, where does it come from?

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

This item has no description.

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

This item has no description.

WGL_CONTEXT_FLAGS_ARB = $2094;

This item has no description.

WGL_CONTEXT_DEBUG_BIT_ARB = $0001;

This item has no description.

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;

This item has no description.

ERROR_INVALID_VERSION_ARB = $2095;

This item has no description.

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;

EXT #400 WGL_EXT_create_context_es2_profile

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

This item has no description.

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

This item has no description.

ERROR_INVALID_PROFILE_ARB = $2096;

This item has no description.

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

WGL_ATI_pixel_format_float (#278)

WGL_FLOAT_COMPONENTS_NV = $20B0;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

This item has no description.

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

This item has no description.

WGL_TEXTURE_FLOAT_R_NV = $20B5;

This item has no description.

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

This item has no description.

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

This item has no description.

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

This item has no description.

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

This item has no description.

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

Vendor/EXT extensions constants, in extension number order

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;

GL_ATI_texture_compression_3dc

WGL_ACCESS_READ_ONLY_NV = $0000;

WGL_NV_DX_interop (EXT #407)

WGL_ACCESS_READ_WRITE_NV = $0001;

This item has no description.

WGL_ACCESS_WRITE_DISCARD_NV = $0002;

This item has no description.

GLU_TESS_BEGIN = 100100;

********** GLU generic constants ********** TessCallback

GLU_TESS_VERTEX = 100101;

TGLUTessBeginProc

GLU_TESS_END = 100102;

TGLUTessVertexProc

GLU_TESS_ERROR = 100103;

TGLUTessEndProc

GLU_TESS_EDGE_FLAG = 100104;

TGLUTessErrorProc

GLU_TESS_COMBINE = 100105;

TGLUTessEdgeFlagProc

GLU_TESS_BEGIN_DATA = 100106;

TGLUTessCombineProc

GLU_TESS_VERTEX_DATA = 100107;

TGLUTessBeginDataProc

GLU_TESS_END_DATA = 100108;

TGLUTessVertexDataProc

GLU_TESS_ERROR_DATA = 100109;

TGLUTessEndDataProc

GLU_TESS_EDGE_FLAG_DATA = 100110;

TGLUTessErrorDataProc

GLU_TESS_COMBINE_DATA = 100111;

TGLUTessEdgeFlagDataProc

GLU_TESS_ERROR1 = 100151;

TGLUTessCombineDataProc TessError

GLU_TESS_ERROR2 = 100152;

This item has no description.

GLU_TESS_ERROR3 = 100153;

This item has no description.

GLU_TESS_ERROR4 = 100154;

This item has no description.

GLU_TESS_ERROR5 = 100155;

This item has no description.

GLU_TESS_ERROR6 = 100156;

This item has no description.

GLU_TESS_ERROR7 = 100157;

This item has no description.

GLU_TESS_ERROR8 = 100158;

This item has no description.

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

This item has no description.

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

This item has no description.

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

This item has no description.

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

This item has no description.

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

This item has no description.

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

This item has no description.

GLU_AUTO_LOAD_MATRIX = 100200;

NURBS constants NurbsProperty

GLU_CULLING = 100201;

This item has no description.

GLU_SAMPLING_TOLERANCE = 100203;

This item has no description.

GLU_DISPLAY_MODE = 100204;

This item has no description.

GLU_PARAMETRIC_TOLERANCE = 100202;

This item has no description.

GLU_SAMPLING_METHOD = 100205;

This item has no description.

GLU_U_STEP = 100206;

This item has no description.

GLU_V_STEP = 100207;

This item has no description.

GLU_PATH_LENGTH = 100215;

NurbsSampling

GLU_PARAMETRIC_ERROR = 100216;

This item has no description.

GLU_DOMAIN_DISTANCE = 100217;

This item has no description.

GLU_MAP1_TRIM_2 = 100210;

NurbsTrim

GLU_MAP1_TRIM_3 = 100211;

This item has no description.

GLU_OUTLINE_POLYGON = 100240;

NurbsDisplay

GLU_OUTLINE_PATCH = 100241;

This item has no description.

GLU_NURBS_ERROR1 = 100251;

NurbsErrors

GLU_NURBS_ERROR2 = 100252;

This item has no description.

GLU_NURBS_ERROR3 = 100253;

This item has no description.

GLU_NURBS_ERROR4 = 100254;

This item has no description.

GLU_NURBS_ERROR5 = 100255;

This item has no description.

GLU_NURBS_ERROR6 = 100256;

This item has no description.

GLU_NURBS_ERROR7 = 100257;

This item has no description.

GLU_NURBS_ERROR8 = 100258;

This item has no description.

GLU_NURBS_ERROR9 = 100259;

This item has no description.

GLU_NURBS_ERROR10 = 100260;

This item has no description.

GLU_NURBS_ERROR11 = 100261;

This item has no description.

GLU_NURBS_ERROR12 = 100262;

This item has no description.

GLU_NURBS_ERROR13 = 100263;

This item has no description.

GLU_NURBS_ERROR14 = 100264;

This item has no description.

GLU_NURBS_ERROR15 = 100265;

This item has no description.

GLU_NURBS_ERROR16 = 100266;

This item has no description.

GLU_NURBS_ERROR17 = 100267;

This item has no description.

GLU_NURBS_ERROR18 = 100268;

This item has no description.

GLU_NURBS_ERROR19 = 100269;

This item has no description.

GLU_NURBS_ERROR20 = 100270;

This item has no description.

GLU_NURBS_ERROR21 = 100271;

This item has no description.

GLU_NURBS_ERROR22 = 100272;

This item has no description.

GLU_NURBS_ERROR23 = 100273;

This item has no description.

GLU_NURBS_ERROR24 = 100274;

This item has no description.

GLU_NURBS_ERROR25 = 100275;

This item has no description.

GLU_NURBS_ERROR26 = 100276;

This item has no description.

GLU_NURBS_ERROR27 = 100277;

This item has no description.

GLU_NURBS_ERROR28 = 100278;

This item has no description.

GLU_NURBS_ERROR29 = 100279;

This item has no description.

GLU_NURBS_ERROR30 = 100280;

This item has no description.

GLU_NURBS_ERROR31 = 100281;

This item has no description.

GLU_NURBS_ERROR32 = 100282;

This item has no description.

GLU_NURBS_ERROR33 = 100283;

This item has no description.

GLU_NURBS_ERROR34 = 100284;

This item has no description.

GLU_NURBS_ERROR35 = 100285;

This item has no description.

GLU_NURBS_ERROR36 = 100286;

This item has no description.

GLU_NURBS_ERROR37 = 100287;

This item has no description.

GLU_CW = 100120;

Contours types – obsolete!

GLU_CCW = 100121;

This item has no description.

GLU_INTERIOR = 100122;

This item has no description.

GLU_EXTERIOR = 100123;

This item has no description.

GLU_UNKNOWN = 100124;

This item has no description.

GLU_BEGIN = GLU_TESS_BEGIN;

Names without "TESS_" prefix

GLU_VERTEX = GLU_TESS_VERTEX;

This item has no description.

GLU_END = GLU_TESS_END;

This item has no description.

GLU_ERROR = GLU_TESS_ERROR;

This item has no description.

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;


GXSysHelp v.2.5: GLScene.OpenGLTokens: Packed Record _WGLSWAP

Packed Record _WGLSWAP

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type _WGLSWAP = packed record

Description

This item has no description.

Overview

Fields

Public | hdc: HDC;
Public | uiFlags: UINT;

Description

Fields

Public hdc: HDC;

This item has no description.

Public uiFlags: UINT;


GXSysHelp v.2.5: GLScene.OpenGLTokens: Record TGPUDEVICE

Record TGPUDEVICE

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGPUDEVICE = record

Description

This item has no description.

Overview

Fields

Public | cb: Cardinal;
Public | DeviceName: array[0..31] of AnsiChar;
Public | DeviceString: array[0..127] of AnsiChar;
Public | Flags: Cardinal;
Public | rcVirtualScreen: TRect;

Description

Fields

Public cb: Cardinal;

This item has no description.

Public DeviceName: array[0..31] of AnsiChar;

This item has no description.

Public DeviceString: array[0..127] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public rcVirtualScreen: TRect;


GXSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUNurbs

Record TGLUNurbs

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUNurbs = record

Description

——————- OpenGL Utility (GLU) types —————- GLU types


GXSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUQuadric

Record TGLUQuadric

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUQuadric = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: GLScene.OpenGLTokens: Record TGLUTesselator

Record TGLUTesselator

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.OpenGLTokens

Declaration

type TGLUTesselator = record

Description

This item has no description.

Generated by PasDoc 0.16.0-snapshot.


GXSysHelp v.2.5: GLScene.PipelineTransform

Unit GLScene.PipelineTransform

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Logger

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgTransformationRec |
Class TgTransformation |

Types

PgTransformationRec = ˆTgTransformationRec;
TgOnMatricesPush = procedure() of object;
TgPipelineTransformationState = (...);
TgPipelineTransformationStates = set of TgPipelineTransformationState;

Constants

MAX_MATRIX_STACK_DEPTH = 128;
cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];

Description

Types

PgTransformationRec = ˆTgTransformationRec;

This item has no description.

TgOnMatricesPush = procedure() of object;

This item has no description.

TgPipelineTransformationState = (...);

This item has no description.

Values
  • trsModelViewChanged
  • trsInvModelViewChanged
  • trsInvModelChanged
  • trsNormalModelChanged
  • trsViewProjChanged
  • trsFrustum
TgPipelineTransformationStates = set of TgPipelineTransformationState;

This item has no description.

Constants

MAX_MATRIX_STACK_DEPTH = 128;

This item has no description.

cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];


GXSysHelp v.2.5: GLScene.PipelineTransform: Record TgTransformationRec

Record TgTransformationRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.PipelineTransform

Declaration

type TgTransformationRec = record

Description

This item has no description.

Overview

Fields

Public | FStates: TgPipelineTransformationStates;
Public | FModelMatrix: TGLMatrix;
Public | FViewMatrix: TGLMatrix;
Public | FProjectionMatrix: TGLMatrix;
Public | FInvModelMatrix: TGLMatrix;
Public | FNormalModelMatrix: TAffineMatrix;
Public | FModelViewMatrix: TGLMatrix;
Public | FInvModelViewMatrix: TGLMatrix;
Public | FViewProjectionMatrix: TGLMatrix;
Public | FFrustum: TFrustum;

Description

Fields

Public FStates: TgPipelineTransformationStates;

This item has no description.

Public FModelMatrix: TGLMatrix;

This item has no description.

Public FViewMatrix: TGLMatrix;

This item has no description.

Public FProjectionMatrix: TGLMatrix;

This item has no description.

Public FInvModelMatrix: TGLMatrix;

This item has no description.

Public FNormalModelMatrix: TAffineMatrix;

This item has no description.

Public FModelViewMatrix: TGLMatrix;

This item has no description.

Public FInvModelViewMatrix: TGLMatrix;

This item has no description.

Public FViewProjectionMatrix: TGLMatrix;

This item has no description.

Public FFrustum: TFrustum;


GXSysHelp v.2.5: GLScene.PipelineTransform: Class TgTransformation

Class TgTransformation

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.PipelineTransform

Declaration

type TgTransformation = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgTransformation

Overview

Fields

Private | FStackPos: Integer;
Private | FStack: array of TgTransformationRec;
Private | FLoadMatricesEnabled: Boolean;
Private | FOnPush: TGOnMatricesPush;

Methods

Public | constructor Create;
Public | function StackTop: TGTransformationRec; inline;
Private | function GetFrustum: TFrustum; inline;
Private | function GetInvModelMatrix: PGLMatrix; inline;
Private | function GetInvModelViewMatrix: PGLMatrix; inline;
Private | function GetModelMatrix: PGLMatrix; inline;
Private | function GetModelViewMatrix: PGLMatrix; inline;
Private | function GetNormalModelMatrix: PAffineMatrix; inline;
Private | function GetProjectionMatrix: PGLMatrix; inline;
Private | function GetViewMatrix: PGLMatrix; inline;
Private | function GetViewProjectionMatrix: PGLMatrix; inline;
Public | procedure IdentityAll; inline;
Public | procedure Pop;
Public | procedure Push(); overload; inline;
Public | procedure Push(AValue: PGTransformationRec); overload;
Public | procedure ReplaceFromStack;
Public | procedure SetModelMatrix(const AMatrix: TGLMatrix); inline;
Public | procedure SetProjectionMatrix(const AMatrix: TGLMatrix); inline;
Public | procedure SetViewMatrix(const AMatrix: TGLMatrix); inline;

Properties

Public | property Frustum: TFrustum read GetFrustum;
Public | property InvModelMatrix: PGLMatrix read GetInvModelMatrix;
Public | property InvModelViewMatrix: PGLMatrix read GetInvModelViewMatrix;
Public | property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;
Public | property ModelMatrix: PGLMatrix read GetModelMatrix;
Public | property ModelViewMatrix: PGLMatrix read GetModelViewMatrix;
Public | property NormalModelMatrix: PAffineMatrix read GetNormalModelMatrix;
Public | property ProjectionMatrix: PGLMatrix read GetProjectionMatrix;
Public | property ViewMatrix: PGLMatrix read GetViewMatrix;
Public | property ViewProjectionMatrix: PGLMatrix read GetViewProjectionMatrix;

Description

Fields

Private FStackPos: Integer;

This item has no description.

Private FStack: array of TgTransformationRec;

This item has no description.

Private FLoadMatricesEnabled: Boolean;

This item has no description.

Private FOnPush: TGOnMatricesPush;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public function StackTop: TGTransformationRec; inline;

This item has no description.

Private function GetFrustum: TFrustum; inline;

This item has no description.

Private function GetInvModelMatrix: PGLMatrix; inline;

This item has no description.

Private function GetInvModelViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetModelMatrix: PGLMatrix; inline;

This item has no description.

Private function GetModelViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetNormalModelMatrix: PAffineMatrix; inline;

This item has no description.

Private function GetProjectionMatrix: PGLMatrix; inline;

This item has no description.

Private function GetViewMatrix: PGLMatrix; inline;

This item has no description.

Private function GetViewProjectionMatrix: PGLMatrix; inline;

This item has no description.

Public procedure IdentityAll; inline;

This item has no description.

Public procedure Pop;

This item has no description.

Public procedure Push(); overload; inline;

This item has no description.

Public procedure Push(AValue: PGTransformationRec); overload;

This item has no description.

Public procedure ReplaceFromStack;

This item has no description.

Public procedure SetModelMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Public procedure SetProjectionMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Public procedure SetViewMatrix(const AMatrix: TGLMatrix); inline;

This item has no description.

Properties

Public property Frustum: TFrustum read GetFrustum;

This item has no description.

Public property InvModelMatrix: PGLMatrix read GetInvModelMatrix;

This item has no description.

Public property InvModelViewMatrix: PGLMatrix read GetInvModelViewMatrix;

This item has no description.

Public property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;

This item has no description.

Public property ModelMatrix: PGLMatrix read GetModelMatrix;

This item has no description.

Public property ModelViewMatrix: PGLMatrix read GetModelViewMatrix;

This item has no description.

Public property NormalModelMatrix: PAffineMatrix read GetNormalModelMatrix;

This item has no description.

Public property ProjectionMatrix: PGLMatrix read GetProjectionMatrix;

This item has no description.

Public property ViewMatrix: PGLMatrix read GetViewMatrix;

This item has no description.

Public property ViewProjectionMatrix: PGLMatrix read GetViewProjectionMatrix;


GXSysHelp v.2.5: GLScene.Polynomials

Unit GLScene.Polynomials

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorGeometry

Overview

Functions and Procedures

function EvalPolynom(const poly: TDoubleArray; const x: Double): Double;
function DerivatedPolynom(const poly: TDoubleArray): TDoubleArray;
function FindRoot(const poly: TDoubleArray; min, max, epsilon: Double): Double;
function MinPositiveCoef(const coefs: TDoubleArray; var aMin: Double): Boolean;
function cbrt(const x: Double): Double;
function SolveQuadric(const c: PDoubleArray): TDoubleArray;
function SolveCubic(const c: PDoubleArray): TDoubleArray;
function SolveQuartic(const c: PDoubleArray): TDoubleArray;

Types

TDoubleArray = array of Double;

Description

Functions and Procedures

function EvalPolynom(const poly: TDoubleArray; const x: Double): Double;

Computes polynom's value for given x

function DerivatedPolynom(const poly: TDoubleArray): TDoubleArray;

Calculates the polynom's derivative

function FindRoot(const poly: TDoubleArray; min, max, epsilon: Double): Double;

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign

function MinPositiveCoef(const coefs: TDoubleArray; var aMin: Double): Boolean;

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.

function cbrt(const x: Double): Double;

Calculates the cube root of its parameter.

function SolveQuadric(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2

function SolveCubic(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

function SolveQuartic(const c: PDoubleArray): TDoubleArray;

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4

Types

TDoubleArray = array of Double;


GXSysHelp v.2.5: GLScene.RandomLib

Unit GLScene.RandomLib

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Math
  • System.SysUtils

Overview

Functions and Procedures

function GenRandom: Extended;
function RandUniform(RLow, RHigh: Single): Single; overload;
function RandUniform(RLow, RHigh: Integer): Integer; overload;
function RandExponent(Mean: Single): single;
function RandNorm(Mean, StDev: single): single;
function RandLogNorm(Mean, StDev: single): single;
function RandGauss(Mean, StdDev: single): single;
function RandEmpiric(X: array of single; Fx: array of single; NClass: integer): single;
function Random_Normal: Extended; overload;
function Random_Normal(RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Normal(const Mean, StdDev: Extended): Extended; overload;
function Random_Normal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_LogNormal(const Mean, StdDev: Extended): Extended; overload;
function Random_LogNormal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Gamma(const Shape: Extended): Extended; overload;
function Random_Gamma(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Gamma1(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended;
function Random_ChiSq(const DF: Integer): Extended; overload;
function Random_ChiSq(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Exponential: Extended; overload;
function Random_Exponential(RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Weibull(const a: Extended): Extended; overload;
function Random_Weibull(const a: Extended; RandomGenerator: TRandomGenFunction) : Extended; overload;
function Random_Beta(const aa, bb: Extended): Extended; overload;
function Random_Beta(const aa, bb: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_T(const DF: Integer): Extended; overload;
function Random_T(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;
procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer); overload;
procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer; RandomGenerator: TRandomGenFunction); overload;
function Random_Inv_Gauss(const h, b: Extended): Extended; overload;
function Random_Inv_Gauss(const h, b: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Binomial1(const n: Integer; const p: Extended): Int64; overload;
function Random_Binomial1(const n: Integer; const p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_Binomial2(const n: Int64; const pp: Extended): Int64; overload;
function Random_Binomial2(const n: Int64; const pp: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_Neg_Binomial(const sk, p: Extended): Int64; overload;
function Random_Neg_Binomial(const sk, p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;
function Random_von_Mises(const k: Extended): Extended; overload;
function Random_von_Mises(const k: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Cauchy: Extended; overload;
function Random_Cauchy(RandomGenerator: TRandomGenFunction): Extended; overload;
function Random_Poisson(var mu: Extended): Int64; overload;
function Random_Poisson(var mu: Extended; RandomGenerator: TRandomGenFunction) : Int64; overload;
function LnGamma(const x: Extended): Extended;

Types

TAMFloatVector = array of Extended;
TRandomGenFunction = function: Extended;

Description

Functions and Procedures

function GenRandom: Extended;

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.

function RandUniform(RLow, RHigh: Single): Single; overload;

Uniform Random single numbers in RLow..RHigh range

function RandUniform(RLow, RHigh: Integer): Integer; overload;

This item has no description.

function RandExponent(Mean: Single): single;

This item has no description.

function RandNorm(Mean, StDev: single): single;

This item has no description.

function RandLogNorm(Mean, StDev: single): single;

This item has no description.

function RandGauss(Mean, StdDev: single): single;

Marsaglia-Bray algorithm

function RandEmpiric(X: array of single; Fx: array of single; NClass: integer): single;

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]

function Random_Normal: Extended; overload;

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance

function Random_Normal(RandomGenerator: TRandomGenFunction): Extended; overload;

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves

function Random_Normal(const Mean, StdDev: Extended): Extended; overload;

This item has no description.

function Random_Normal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_LogNormal(const Mean, StdDev: Extended): Extended; overload;

Adapted from approach suggested by Greg Hood, used with Permission.

function Random_LogNormal(const Mean, StdDev: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

Adapted from approach suggested by Greg Hood, used with Permission.

function Random_Gamma(const Shape: Extended): Extended; overload;

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).

function Random_Gamma(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)

function Random_Gamma1(const Shape: Extended; RandomGenerator: TRandomGenFunction): Extended;

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.

function Random_ChiSq(const DF: Integer): Extended; overload;

Generates a random variate from the chi-squared distribution with dff degrees of freedom.

function Random_ChiSq(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Exponential: Extended; overload;

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.

function Random_Exponential(RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Weibull(const a: Extended): Extended; overload;

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e

function Random_Weibull(const a: Extended; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

function Random_Beta(const aa, bb: Extended): Extended; overload;

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)

function Random_Beta(const aa, bb: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_T(const DF: Integer): Extended; overload;

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)

function Random_T(const DF: Integer; RandomGenerator: TRandomGenFunction) : Extended; overload;

This item has no description.

procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer); overload;

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.

ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)

D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise

procedure Random_MVNorm(const h, d: TAMFloatVector; var f, x: TAMFloatVector; var ier: Integer; RandomGenerator: TRandomGenFunction); overload;

This item has no description.

function Random_Inv_Gauss(const h, b: Extended): Extended; overload;

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.

h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)

function Random_Inv_Gauss(const h, b: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Binomial1(const n: Integer; const p: Extended): Int64; overload;

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.

function Random_Binomial1(const n: Integer; const p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

This item has no description.

function Random_Binomial2(const n: Int64; const pp: Extended): Int64; overload;

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.

Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P

function Random_Binomial2(const n: Int64; const pp: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.

function Random_Neg_Binomial(const sk, p: Extended): Int64; overload;

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.

function Random_Neg_Binomial(const sk, p: Extended; RandomGenerator: TRandomGenFunction): Int64; overload;

This item has no description.

function Random_von_Mises(const k: Extended): Extended; overload;

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.

function Random_von_Mises(const k: Extended; RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Cauchy: Extended; overload;

Generate a random deviate from the standard Cauchy distribution

function Random_Cauchy(RandomGenerator: TRandomGenFunction): Extended; overload;

This item has no description.

function Random_Poisson(var mu: Extended): Int64; overload;

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179

TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL

function Random_Poisson(var mu: Extended; RandomGenerator: TRandomGenFunction) : Int64; overload;

This item has no description.

function LnGamma(const x: Extended): Extended;

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988

Types

TAMFloatVector = array of Extended;

Used as a Dynamic Vector

TRandomGenFunction = function: Extended;

Used for passing Random Number Generators


GXSysHelp v.2.5: GLScene.RedBlackTree

Unit GLScene.RedBlackTree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class GRedBlackTree |

Functions and Procedures

function CompareInteger(const Item1, Item2: Integer): Integer;

Types

TRBColor = (...);

Description

Functions and Procedures

function CompareInteger(const Item1, Item2: Integer): Integer;

This item has no description.

Types

TRBColor = (...);

This item has no description.

Values
  • clRed
  • clBlack


GXSysHelp v.2.5: GLScene.RedBlackTree: Class GRedBlackTree

Class GRedBlackTree

Description
Hierarchy
Nested Classes and Records
Nested Types
Fields
Methods
Properties

Unit

GLScene.RedBlackTree

Declaration

type GRedBlackTree<TKey,TValue> = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • GRedBlackTree

Overview

Nested Classes and Records

Public TRBNode = class(TObject)

Nested Types

Published | TForEachProc = procedure(AKey: TKey; AValue: TValue; out AContinue: Boolean);
Published | TKeyCompareFunc = function(const Item1, Item2: TKey): Integer;
Published | TValueCompareFunc = function(const Item1, Item2: TValue): Boolean;

Fields

Public | var FRoot: TRBNode;
Public | FLeftmost: TRBNode;
Public | FRightmost: TRBNode;
Public | FLastFound: TRBNode;
Public | FLastNode: TRBNode;
Public | FCount: Integer;
Public | FKeyCompareFunc: TKeyCompareFunc;
Public | FDuplicateKeys: Boolean;
Public | FValueCompareFunc: TValueCompareFunc;
Public | FOnChange: TNotifyEvent;

Methods

Public | constructor Create(KeyCompare: TKeyCompareFunc; ValueCompare: TValueCompareFunc);
Public | destructor Destroy; override;
Public | function Find(const Key: TKey; out Value: TValue): Boolean;
Public | function FindNode(const Key: TKey): TRBNode;
Public | function GetFirst: TKey;
Public | function GetLast: TKey;
Public | function Maximum(var x: TRBNode): TRBNode;
Public | function Minimum(var x: TRBNode): TRBNode;
Public | function NextDublicate(out Value: TValue): Boolean;
Public | function NextKey(var Key: TKey; out Value: TValue): Boolean;
Public | function PrevKey(var Key: TKey; out Value: TValue): Boolean;
Public | procedure Add(const Key: TKey; const Value: TValue);
Public | procedure Clear;
Public | procedure Delete(const Key: TKey);
Public | class procedure FastErase(x: TRBNode);
Public | procedure ForEach(AProc: TForEachProc);
Public | procedure RotateLeft(var x: TRBNode);
Public | procedure RotateRight(var x: TRBNode);
Public | procedure SetDuplicateKeys(Value: Boolean);

Properties

Public | property Count: Integer read FCount;
Public | property DuplicateKeys: Boolean read FDuplicateKeys write SetDuplicateKeys;
Public | property First: TKey read GetFirst;
Public | property Last: TKey read GetLast;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Nested Types

Published TForEachProc = procedure(AKey: TKey; AValue: TValue; out AContinue: Boolean);

This item has no description.

Published TKeyCompareFunc = function(const Item1, Item2: TKey): Integer;

This item has no description.

Published TValueCompareFunc = function(const Item1, Item2: TValue): Boolean;

This item has no description.

Fields

Public var FRoot: TRBNode;

This item has no description.

Public FLeftmost: TRBNode;

This item has no description.

Public FRightmost: TRBNode;

This item has no description.

Public FLastFound: TRBNode;

This item has no description.

Public FLastNode: TRBNode;

This item has no description.

Public FCount: Integer;

This item has no description.

Public FKeyCompareFunc: TKeyCompareFunc;

This item has no description.

Public FDuplicateKeys: Boolean;

This item has no description.

Public FValueCompareFunc: TValueCompareFunc;

This item has no description.

Public FOnChange: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(KeyCompare: TKeyCompareFunc; ValueCompare: TValueCompareFunc);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Find(const Key: TKey; out Value: TValue): Boolean;

Find value by key.

Public function FindNode(const Key: TKey): TRBNode;

This item has no description.

Public function GetFirst: TKey;

This item has no description.

Public function GetLast: TKey;

This item has no description.

Public function Maximum(var x: TRBNode): TRBNode;

This item has no description.

Public function Minimum(var x: TRBNode): TRBNode;

This item has no description.

Public function NextDublicate(out Value: TValue): Boolean;

This item has no description.

Public function NextKey(var Key: TKey; out Value: TValue): Boolean;

This item has no description.

Public function PrevKey(var Key: TKey; out Value: TValue): Boolean;

This item has no description.

Public procedure Add(const Key: TKey; const Value: TValue);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(const Key: TKey);

This item has no description.

Public class procedure FastErase(x: TRBNode);

This item has no description.

Public procedure ForEach(AProc: TForEachProc);

This item has no description.

Public procedure RotateLeft(var x: TRBNode);

This item has no description.

Public procedure RotateRight(var x: TRBNode);

This item has no description.

Public procedure SetDuplicateKeys(Value: Boolean);

This item has no description.

Properties

Public property Count: Integer read FCount;

This item has no description.

Public property DuplicateKeys: Boolean read FDuplicateKeys write SetDuplicateKeys;

This item has no description.

Public property First: TKey read GetFirst;

This item has no description.

Public property Last: TKey read GetLast;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;


GXSysHelp v.2.5: GLScene.RedBlackTree: Class GRedBlackTree.TRBNode

Class GRedBlackTree.TRBNode

Description
Hierarchy
Enclosing Class
Fields
Methods
Properties

Unit

GLScene.RedBlackTree

Declaration

type TRBNode = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • GRedBlackTree.TRBNode

Enclosing Class

  • GRedBlackTree

Overview

Fields

Public | Key: TKey;
Public | Left: TRBNode;
Public | Right: TRBNode;
Public | Parent: TRBNode;
Public | Twin: TRBNode;
Public | Color: TRBColor;
Public | Value: TValue;

Description

Fields

Public Key: TKey;

This item has no description.

Public Left: TRBNode;

This item has no description.

Public Right: TRBNode;

This item has no description.

Public Parent: TRBNode;

This item has no description.

Public Twin: TRBNode;

This item has no description.

Public Color: TRBColor;

This item has no description.

Public Value: TValue;


GXSysHelp v.2.5: GLScene.RGBE

Unit GLScene.RGBE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);
procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);
procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);
procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);

Description

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);

This item has no description.

procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);

This item has no description.

procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);

This item has no description.

procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);


GXSysHelp v.2.5: GLScene.Spline

Unit GLScene.Spline

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCubicSpline |

Types

TCubicSplineMatrix = array of array [0 .. 3] of Single;

Description

Types

TCubicSplineMatrix = array of array [0 .. 3] of Single;


GXSysHelp v.2.5: GLScene.Spline: Class TCubicSpline

Class TCubicSpline

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Spline

Declaration

type TCubicSpline = class(TObject)

Description

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.

Hierarchy

  • TObject
  • TCubicSpline

Overview

Fields

Private | matX: TCubicSplineMatrix;
Private | matY: TCubicSplineMatrix;
Private | matZ: TCubicSplineMatrix;
Private | matW: TCubicSplineMatrix;
Private | FNb: Integer;

Methods

Public | constructor Create(const X, Y, Z, W: PFloatArray; const nb: Integer);
Public | destructor Destroy; override;
Public | function SplineAffineVector(const t: Single): TAffineVector; overload;
Public | function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;
Public | function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;
Public | function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;
Public | function SplineSlopeVector(const t: Single): TAffineVector; overload;
Public | function SplineSlopeW(const t: Single): Single;
Public | function SplineSlopeX(const t: Single): Single;
Public | function SplineSlopeY(const t: Single): Single;
Public | function SplineSlopeZ(const t: Single): Single;
Public | function SplineVector(const t: Single): TGLVector; overload;
Public | function SplineW(const t: Single): Single;
Public | function SplineX(const t: Single): Single;
Public | function SplineY(const t: Single): Single;
Public | function SplineZ(const t: Single): Single;
Public | procedure SplineAffineVector(const t: Single; var vector: TAffineVector); overload;
Public | procedure SplineVector(const t: Single; var vector: TGLVector); overload;
Public | procedure SplineXY(const t: Single; out X, Y: Single);
Public | procedure SplineXYZ(const t: Single; out X, Y, Z: Single);
Public | procedure SplineXYZW(const t: Single; out X, Y, Z, W: Single);

Description

Fields

Private matX: TCubicSplineMatrix;

This item has no description.

Private matY: TCubicSplineMatrix;

This item has no description.

Private matZ: TCubicSplineMatrix;

This item has no description.

Private matW: TCubicSplineMatrix;

This item has no description.

Private FNb: Integer;

This item has no description.

Methods

Public constructor Create(const X, Y, Z, W: PFloatArray; const nb: Integer);

Creates the spline and declares interpolation points. Time references go from 0 (first point) to nb-1 (last point), the first and last reference matrices respectively are used when T is used beyond this range. Note : "nil" single arrays are accepted, in this case the axis is disabled and calculus will return 0 (zero) for this component.

Public destructor Destroy; override;

This item has no description.

Public function SplineAffineVector(const t: Single): TAffineVector; overload;

Calculates affine vector at time t.

Public function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;

Calculates the intersection of the spline with the XY plane. Returns True if an intersection was found.

Public function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;

Calculates the intersection of the spline with the XZ plane. Returns True if an intersection was found.

Public function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;

Calculates the intersection of the spline with the YZ plane. Returns True if an intersection was found.

Public function SplineSlopeVector(const t: Single): TAffineVector; overload;

Calculates the spline slope at time t.

Public function SplineSlopeW(const t: Single): Single;

Calculates W component slope at time t.

Public function SplineSlopeX(const t: Single): Single;

Calculates X component slope at time t.

Public function SplineSlopeY(const t: Single): Single;

Calculates Y component slope at time t.

Public function SplineSlopeZ(const t: Single): Single;

Calculates Z component slope at time t.

Public function SplineVector(const t: Single): TGLVector; overload;

Calculates vector at time t.

Public function SplineW(const t: Single): Single;

Calculates W component at time t.

Public function SplineX(const t: Single): Single;

Calculates X component at time t.

Public function SplineY(const t: Single): Single;

Calculates Y component at time t.

Public function SplineZ(const t: Single): Single;

Calculates Z component at time t.

Public procedure SplineAffineVector(const t: Single; var vector: TAffineVector); overload;

Calculates affine vector at time t.

Public procedure SplineVector(const t: Single; var vector: TGLVector); overload;

Calculates vector at time t.

Public procedure SplineXY(const t: Single; out X, Y: Single);

Calculates X and Y components at time t.

Public procedure SplineXYZ(const t: Single; out X, Y, Z: Single);

Calculates X, Y and Z components at time t.

Public procedure SplineXYZW(const t: Single; out X, Y, Z, W: Single);

Calculates X, Y, Z and W components at time t.


GXSysHelp v.2.5: GLScene.Strings

Unit GLScene.Strings

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Constants

strDot = '.';
strError = 'Error!';
strErrorEx = 'Error: ';
strErrorLIB = 'ErrorLIB';
strInvalidType = 'Invalid data type';
strNothing = 'Nothing';
strStateCashMissing = 'States cash missing: ';
strUnknownArchiveVersion = 'Unknown archive version: ';
strObjectsNotSupported = 'Linked object not supported';
strGLSceneEditor = 'GLScene Editor';
strNoRenderingContext = 'Could not create a rendering context';
strWrongVersion = 'Need at least OpenGL version 1.1';
strTooManyLights = 'Too many lights in the scene';
strDisplayList = 'Failed to create a new display list for object ''%s''';
strWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';
strWrongPrinter = 'Couldn''t render to printer';
strAlreadyRendering = 'Already rendering';
strSceneViewerNotDefined = 'SceneViewer not defined!';
strCadencerNotDefined = 'Cadencer not defined!';
strCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';
strCannotAlterAnActiveContext = 'Cannot alter an active context';
strContextActivationFailed = 'Context activation failed: %X, %s';
strContextAlreadyCreated = 'Context already created';
strContextDeactivationFailed = 'Context deactivation failed';
strContextNotCreated = 'Context not created';
strDeleteContextFailed = 'Delete context failed';
strFailedToShare = 'DoCreateContext - Failed to share contexts';
strIncompatibleContexts = 'Incompatible contexts';
strInvalidContextRegistration = 'Invalid context registration';
strInvalidNotificationRemoval = 'Invalid notification removal';
strNoActiveRC = 'No active rendering context';
strUnbalancedContexActivations = 'Unbalanced context activations';
strUnableToCreateLegacyContext = 'Unable to create legacy context';
strOpenGLError = 'OpenGL error - %s';
str3DSMapNotFound = 'Loading %s map texture failed: %s in %s';
strError3DS_NO_MEM = 'Not enough memory to complete operation.';
strError3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';
strError3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';
strError3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';
strError3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';
strError3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';
strError3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';
strError3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';
strError3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';
strError3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';
strError3DS_OPENING_FILE = 'Could not open requested file.';
strError3DS_CLOSING_FILE = 'Could not close requested file.';
strError3DS_READING_FILE = 'Error occured while reading file.';
strError3DS_CREATING_DATABASE = 'Error occured while creating database.';
strError3DS_READING_DATABASE = 'Error occured while reading database.';
strError3DS_WRITING_DATABASE = 'Error occured while writing database.';
strError3DS_WRITING_FILE = 'Error occured while writing file.';
strError3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';
strError3DS_GET_FAIL = 'Failed to get new data from database.';
strError3DS_PUT_FAIL = 'Failed to add new data to the database.';
strError3DS_INVALID_INDEX = 'Invalid index %d.';
strCUTILFailed = 'Can not initialize cutil32.dll';
strCantConvertImg = '%s: can''t convert image to RGBA8 format';
strNoJoystickDriver = 'There''s no joystick driver present';
strConnectJoystick = 'Joystick is not connected to your system';
strJoystickError = 'Your system reports a joystick error, can''t do anything about it';
strCyclicRefMat = 'Cyclic reference detected in material "%s"';
strOctreeMustBePreparedBeforeUse = 'Octree must be prepared before use';
strInvalidFileSignature = 'Invalid file signature';
strBrokenObjectListArchive = 'Broken ObjectList archive';
strListIndexError = 'Invalid list index';
strForwardContextFailed = 'Can not create forward compatible context: #%X, %s';
strBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';
strFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';
strTmpRC_Created = 'Temporary rendering context created';
strDriverNotSupportFRC = 'Driver not support creating of forward context';
strDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';
strDriverNotSupportDebugRC = 'Driver not support creating of debug context';
strOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';
strFRC_created = 'Forward core context seccussfuly created';
strOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';
strPBufferRC_created = 'Backward compatible core PBuffer context successfully created';
strOpenGLCategoryName = 'OpenGL';
strLayoutCategoryName = 'Layout';
strLocalizableCategoryName = 'Localizable';
strVisualCategoryName = 'Visual';
strShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';
strShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';
strSceneRoot = 'Scene root';
strObjectRoot = 'Scene objects';
strCameraRoot = 'Cameras';
strCamera = 'Camera';
strImageInvalid = 'Could not load texture, image is invalid';
strNoNewTexture = 'Could not get new texture name';
strMatLibNotDefined = 'Material Library not defined!';
strMaterialNotFoundInMatlib = 'Material not found in current Material Library!';
strMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';
strSphereTopBottom = 'The top angle must be higher than the bottom angle';
strSphereStartStop = 'The start angle must be smaller than then stop angle';
strMaterialNotFound = 'Loading failed: could not find material %s';
strInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';
strUnknownArchive = '%s : unknown archive version %d';
strOutOfMemory = 'Fatal: Out of memory';
strFileNotFound = 'File %s not found';
strFailedOpenFile = 'Could not open file: %s';
strFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';
strNoDescriptionAvailable = 'No description available';
strUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';
strUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;
strMissingResource = 'Missing application resource: %s: %s';
strIncompatibleTypes = 'Incompatible types!';
strUnknownType = 'Unknown type!';
strUnsupportedType = 'Unsupported type!';
strOCBasicGeometry = 'Basic geometry';
strOCAdvancedGeometry = 'Advanced geometry';
strOCMeshObjects = 'Mesh objects';
strOCParticleSystems = 'Particle systems';
strOCEnvironmentObjects = 'Environment objects';
strOCSpecialObjects = 'Special objects';
strOCGraphPlottingObjects = 'Graph-plotting objects';
strOCDoodad = 'Doodad objects';
strOCHUDObjects = 'HUD objects';
strOCGuiObjects = 'GUI objects';
strOCProxyObjects = 'Proxy objects';
strOCExperimental = 'Experimental objects';
strInvalidColor = '''%s'' is not a valid color format!';
strUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';
strXCollectionEditor = 'XCollection editor';
strModuleAbsent = 'Module is absent';
strInvalidParamType = 'Invalid parameter type';
strInvalidContextReg = 'Invalid context registration.';
strInvalidValue = 'Invalid value';
strWrongParamSetup = 'Function''s parameters must be setup in OnParameterSetup event';
strLaunchFailed = 'Kernel function "%s" launch failed';
strFailMap = 'Unable to map %s - already mapped';
strFailUnmap = 'Unable to unmap %s - not mapped';
strFailCompilation = 'NVCC failed to compile:' + #10#13 + '%s';
strFailCreatePipe = 'Unable to create Pipe';
strFailRunNVCC = 'Unable to run process (NVCC)';
strFuncRetErr = '%s return error: %s';
strFuncNotConnected = '%s.Launch: Kernel function not connected';
strOnlyHostData = 'Only host data or mapped device or array data can be written/read';
strOutOfRange = 'Indexes out of range';
strSizeMismatch = 'Element size mismatch';
strCUDAEditor = 'Scene CUDA Component Editor';
strRequireFreeThread = 'CUFFT functions require context-free thread';
strBadPlanSize = 'MemData size less then Plan size';
strContextNotInit = 'Context not initialized';
strNoDeviceToCreate = 'No device to create CUDA context';
strThreadBusy = 'Unable to create CUDA context - thread is busy by another context';
strMakeFloatingFail = 'Unable to make context floating after creation';
strUnbalansedUsage = 'Unbalansed CUDA context usage';
strInvalidGLContext = 'Unable to create CUDA context with OpenGL interop' + ' - OpenGL context not ready';
strFFTFuncRetErr = '%s return error: %s';
strFailToBindArrayToTex = 'Unable to bind CUDA array to OpenGL unmaped t' + 'exture';
strOutOfAttribSize = 'The amount of device''s data less then size of att' + 'ribute''s data.';
strOutOfElementSize = 'The amount of device''s data less then size of in' + 'dexes data.';
strSourceFileNotFound = 'Source file not found';
strSuccessCompilation = 'Successful compilation:' + #10#13 + '%s';

Variables

Language: Integer;

Description

Constants

strDot = '.';

General

strError = 'Error!';

This item has no description.

strErrorEx = 'Error: ';

This item has no description.

strErrorLIB = 'ErrorLIB';

This item has no description.

strInvalidType = 'Invalid data type';

This item has no description.

strNothing = 'Nothing';

This item has no description.

strStateCashMissing = 'States cash missing: ';

This item has no description.

strUnknownArchiveVersion = 'Unknown archive version: ';

This item has no description.

strObjectsNotSupported = 'Linked object not supported';

This item has no description.

strGLSceneEditor = 'GLScene Editor';

SceneEdit

strNoRenderingContext = 'Could not create a rendering context';

SceneViewer

strWrongVersion = 'Need at least OpenGL version 1.1';

This item has no description.

strTooManyLights = 'Too many lights in the scene';

This item has no description.

strDisplayList = 'Failed to create a new display list for object ''%s''';

This item has no description.

strWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';

This item has no description.

strWrongPrinter = 'Couldn''t render to printer';

This item has no description.

strAlreadyRendering = 'Already rendering';

This item has no description.

strSceneViewerNotDefined = 'SceneViewer not defined!';

This item has no description.

strCadencerNotDefined = 'Cadencer not defined!';

Cadencer

strCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';

This item has no description.

strCannotAlterAnActiveContext = 'Cannot alter an active context';

Context

strContextActivationFailed = 'Context activation failed: %X, %s';

This item has no description.

strContextAlreadyCreated = 'Context already created';

This item has no description.

strContextDeactivationFailed = 'Context deactivation failed';

This item has no description.

strContextNotCreated = 'Context not created';

This item has no description.

strDeleteContextFailed = 'Delete context failed';

This item has no description.

strFailedToShare = 'DoCreateContext - Failed to share contexts';

This item has no description.

strIncompatibleContexts = 'Incompatible contexts';

This item has no description.

strInvalidContextRegistration = 'Invalid context registration';

This item has no description.

strInvalidNotificationRemoval = 'Invalid notification removal';

This item has no description.

strNoActiveRC = 'No active rendering context';

This item has no description.

strUnbalancedContexActivations = 'Unbalanced context activations';

This item has no description.

strUnableToCreateLegacyContext = 'Unable to create legacy context';

This item has no description.

strOpenGLError = 'OpenGL error - %s';

InitOpenGL

str3DSMapNotFound = 'Loading %s map texture failed: %s in %s';

File3DS

strError3DS_NO_MEM = 'Not enough memory to complete operation.';

This item has no description.

strError3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';

This item has no description.

strError3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';

This item has no description.

strError3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';

This item has no description.

strError3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';

This item has no description.

strError3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';

This item has no description.

strError3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';

This item has no description.

strError3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';

This item has no description.

strError3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';

This item has no description.

strError3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';

This item has no description.

strError3DS_OPENING_FILE = 'Could not open requested file.';

This item has no description.

strError3DS_CLOSING_FILE = 'Could not close requested file.';

This item has no description.

strError3DS_READING_FILE = 'Error occured while reading file.';

This item has no description.

strError3DS_CREATING_DATABASE = 'Error occured while creating database.';

This item has no description.

strError3DS_READING_DATABASE = 'Error occured while reading database.';

This item has no description.

strError3DS_WRITING_DATABASE = 'Error occured while writing database.';

This item has no description.

strError3DS_WRITING_FILE = 'Error occured while writing file.';

This item has no description.

strError3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';

This item has no description.

strError3DS_GET_FAIL = 'Failed to get new data from database.';

This item has no description.

strError3DS_PUT_FAIL = 'Failed to add new data to the database.';

This item has no description.

strError3DS_INVALID_INDEX = 'Invalid index %d.';

This item has no description.

strCUTILFailed = 'Can not initialize cutil32.dll';

FilePGM

strCantConvertImg = '%s: can''t convert image to RGBA8 format';

Graphics

strNoJoystickDriver = 'There''s no joystick driver present';

Joystick

strConnectJoystick = 'Joystick is not connected to your system';

This item has no description.

strJoystickError = 'Your system reports a joystick error, can''t do anything about it';

This item has no description.

strCyclicRefMat = 'Cyclic reference detected in material "%s"';

Material

strOctreeMustBePreparedBeforeUse = 'Octree must be prepared before use';

Octree

strInvalidFileSignature = 'Invalid file signature';

PersistentClasses

strBrokenObjectListArchive = 'Broken ObjectList archive';

This item has no description.

strListIndexError = 'Invalid list index';

This item has no description.

strForwardContextFailed = 'Can not create forward compatible context: #%X, %s';

SceneContext

strBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';

This item has no description.

strFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';

This item has no description.

strTmpRC_Created = 'Temporary rendering context created';

This item has no description.

strDriverNotSupportFRC = 'Driver not support creating of forward context';

This item has no description.

strDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';

This item has no description.

strDriverNotSupportDebugRC = 'Driver not support creating of debug context';

This item has no description.

strOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';

This item has no description.

strFRC_created = 'Forward core context seccussfuly created';

This item has no description.

strOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';

This item has no description.

strPBufferRC_created = 'Backward compatible core PBuffer context successfully created';

This item has no description.

strOpenGLCategoryName = 'OpenGL';

SceneRegister, strings additional to Designintf

strLayoutCategoryName = 'Layout';

This item has no description.

strLocalizableCategoryName = 'Localizable';

This item has no description.

strVisualCategoryName = 'Visual';

This item has no description.

strShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';

Shaders

strShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';

This item has no description.

strSceneRoot = 'Scene root';

Tree

strObjectRoot = 'Scene objects';

This item has no description.

strCameraRoot = 'Cameras';

This item has no description.

strCamera = 'Camera';

This item has no description.

strImageInvalid = 'Could not load texture, image is invalid';

Textures

strNoNewTexture = 'Could not get new texture name';

This item has no description.

strMatLibNotDefined = 'Material Library not defined!';

Materials

strMaterialNotFoundInMatlib = 'Material not found in current Material Library!';

This item has no description.

strMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';

This item has no description.

strSphereTopBottom = 'The top angle must be higher than the bottom angle';

Objects

strSphereStartStop = 'The start angle must be smaller than then stop angle';

This item has no description.

strMaterialNotFound = 'Loading failed: could not find material %s';

This item has no description.

strInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';

This item has no description.

strUnknownArchive = '%s : unknown archive version %d';

Common messages

strOutOfMemory = 'Fatal: Out of memory';

This item has no description.

strFileNotFound = 'File %s not found';

This item has no description.

strFailedOpenFile = 'Could not open file: %s';

This item has no description.

strFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';

This item has no description.

strNoDescriptionAvailable = 'No description available';

This item has no description.

strUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';

This item has no description.

strUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;

This item has no description.

strMissingResource = 'Missing application resource: %s: %s';

This item has no description.

strIncompatibleTypes = 'Incompatible types!';

This item has no description.

strUnknownType = 'Unknown type!';

This item has no description.

strUnsupportedType = 'Unsupported type!';

This item has no description.

strOCBasicGeometry = 'Basic geometry';

Object categories in GLScene Registry

strOCAdvancedGeometry = 'Advanced geometry';

This item has no description.

strOCMeshObjects = 'Mesh objects';

This item has no description.

strOCParticleSystems = 'Particle systems';

This item has no description.

strOCEnvironmentObjects = 'Environment objects';

This item has no description.

strOCSpecialObjects = 'Special objects';

This item has no description.

strOCGraphPlottingObjects = 'Graph-plotting objects';

This item has no description.

strOCDoodad = 'Doodad objects';

This item has no description.

strOCHUDObjects = 'HUD objects';

This item has no description.

strOCGuiObjects = 'GUI objects';

This item has no description.

strOCProxyObjects = 'Proxy objects';

This item has no description.

strOCExperimental = 'Experimental objects';

This item has no description.

strInvalidColor = '''%s'' is not a valid color format!';

Utils

strUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';

This item has no description.

strXCollectionEditor = 'XCollection editor';

FXCollectionEditor

strModuleAbsent = 'Module is absent';

CUDA strings

strInvalidParamType = 'Invalid parameter type';

This item has no description.

strInvalidContextReg = 'Invalid context registration.';

This item has no description.

strInvalidValue = 'Invalid value';

This item has no description.

strWrongParamSetup = 'Function''s parameters must be setup in OnParameterSetup event';

This item has no description.

strLaunchFailed = 'Kernel function "%s" launch failed';

This item has no description.

strFailMap = 'Unable to map %s - already mapped';

This item has no description.

strFailUnmap = 'Unable to unmap %s - not mapped';

This item has no description.

strFailCompilation = 'NVCC failed to compile:' + #10#13 + '%s';

This item has no description.

strFailCreatePipe = 'Unable to create Pipe';

This item has no description.

strFailRunNVCC = 'Unable to run process (NVCC)';

This item has no description.

strFuncRetErr = '%s return error: %s';

This item has no description.

strFuncNotConnected = '%s.Launch: Kernel function not connected';

This item has no description.

strOnlyHostData = 'Only host data or mapped device or array data can be written/read';

This item has no description.

strOutOfRange = 'Indexes out of range';

This item has no description.

strSizeMismatch = 'Element size mismatch';

This item has no description.

strCUDAEditor = 'Scene CUDA Component Editor';

This item has no description.

strRequireFreeThread = 'CUFFT functions require context-free thread';

This item has no description.

strBadPlanSize = 'MemData size less then Plan size';

This item has no description.

strContextNotInit = 'Context not initialized';

This item has no description.

strNoDeviceToCreate = 'No device to create CUDA context';

This item has no description.

strThreadBusy = 'Unable to create CUDA context - thread is busy by another context';

This item has no description.

strMakeFloatingFail = 'Unable to make context floating after creation';

This item has no description.

strUnbalansedUsage = 'Unbalansed CUDA context usage';

This item has no description.

strInvalidGLContext = 'Unable to create CUDA context with OpenGL interop' + ' - OpenGL context not ready';

This item has no description.

strFFTFuncRetErr = '%s return error: %s';

This item has no description.

strFailToBindArrayToTex = 'Unable to bind CUDA array to OpenGL unmaped t' + 'exture';

This item has no description.

strOutOfAttribSize = 'The amount of device''s data less then size of att' + 'ribute''s data.';

This item has no description.

strOutOfElementSize = 'The amount of device''s data less then size of in' + 'dexes data.';

This item has no description.

strSourceFileNotFound = 'Source file not found';

This item has no description.

strSuccessCompilation = 'Successful compilation:' + #10#13 + '%s';

This item has no description.

Variables

Language: Integer;

String constants that are used for internationalization

To build your project with a single language's translations in the executable itself, define one of the next languages

Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es


GXSysHelp v.2.5: GLScene.TextureFormat

Unit GLScene.TextureFormat

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.OpenGLTokens
  • GLScene.Strings

Overview

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): Cardinal;
function OpenGLFormatToInternalFormat(glFormat: Cardinal): TGLInternalFormat;
function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;
function GetTextureElementSize(colorFormat: Cardinal; dataType: Cardinal): Integer; overload;
procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: Cardinal; out dType: Cardinal);
function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;
function IsTargetSupported(glTarget: Cardinal): Boolean; overload;
function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;
function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;
function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsFloatFormat(glFormat: Cardinal): Boolean; overload;
function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;
function IsDepthFormat(glFormat: Cardinal): Boolean; overload;
function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsCompressedFormat(glFormat: Cardinal): Boolean; overload;
function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: Cardinal; out internalFormat: Cardinal): Boolean;
function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: Cardinal): Boolean;
function DecodeTextureTarget(const TextureTarget: TGLTextureTarget): Cardinal;
function EncodeGLTextureTarget(const glTarget: Cardinal): TGLTextureTarget;
function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;
function IsTargetSupportMipmap(const glTarget: Cardinal): Boolean; overload;

Types

TglInternalCompression = (...);
TglInternalFormat = (...);
TglSeparateTextureWrap = (...);
TglSwizzleVector = array[0..3] of TglTextureSwizzle;
TglTextureCompareMode = (...);
TglTextureFilteringQuality = (...);
TglTextureSwizzle = (...);
TglTextureTarget = (...);

Constants

cDefaultSwizzleVector: TglSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

Variables

vDefaultTextureFormat: TglInternalFormat = tfRGBA8;
vDefaultTextureCompression: TglInternalCompression = tcNone;

Description

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): Cardinal;

Give a openGL texture format from GLScene texture format

function OpenGLFormatToInternalFormat(glFormat: Cardinal): TGLInternalFormat;

Give a GLScene texture format from openGL texture format

function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;

Give a pixel size in bytes from texture format or data format

function GetTextureElementSize(colorFormat: Cardinal; dataType: Cardinal): Integer; overload;

This item has no description.

procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: Cardinal; out dType: Cardinal);

Give compatible openGL image format and data type

function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format

function IsTargetSupported(glTarget: Cardinal): Boolean; overload;

True if texture target supported

function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;

This item has no description.

function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;

True if texture format is supported by hardware or software

function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture format is float

function IsFloatFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;

True if depth texture

function IsDepthFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture compressed

function IsCompressedFormat(glFormat: Cardinal): Boolean; overload;

This item has no description.

function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: Cardinal; out internalFormat: Cardinal): Boolean;

Give generic compressed OpenGL texture format

function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: Cardinal): Boolean;

Give uncompressed texture format and OpenGL color format

function DecodeTextureTarget(const TextureTarget: TGLTextureTarget): Cardinal;

This item has no description.

function EncodeGLTextureTarget(const glTarget: Cardinal): TGLTextureTarget;

This item has no description.

function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;

This item has no description.

function IsTargetSupportMipmap(const glTarget: Cardinal): Boolean; overload;

This item has no description.

Types

TglInternalCompression = (...);

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression

Values
  • tcDefault
  • tcNone
  • tcStandard
  • tcHighQuality
  • tcHighSpeed
TglInternalFormat = (...);

This item has no description.

Values
  • tfALPHA4
  • tfALPHA8
  • tfALPHA12
  • tfALPHA16
  • tfDEPTH_COMPONENT16
  • tfDEPTH_COMPONENT24
  • tfDEPTH_COMPONENT32
  • tfLUMINANCE4
  • tfLUMINANCE8
  • tfLUMINANCE12
  • tfLUMINANCE16
  • tfLUMINANCE4_ALPHA4
  • tfLUMINANCE6_ALPHA2
  • tfLUMINANCE8_ALPHA8
  • tfLUMINANCE12_ALPHA4
  • tfLUMINANCE12_ALPHA12
  • tfLUMINANCE16_ALPHA16
  • tfINTENSITY4
  • tfINTENSITY8
  • tfINTENSITY12
  • tfINTENSITY16
  • tfR3_G3_B2
  • tfRGB4
  • tfRGB5
  • tfRGB8
  • tfRGB10
  • tfRGB12
  • tfR16G16B16
  • tfRGBA2
  • tfRGBA4
  • tfRGB5_A1
  • tfRGBA8
  • tfRGB10_A2
  • tfRGBA12
  • tfR16G16B16A16
  • tfCOMPRESSED_RGB_S3TC_DXT1
  • tfCOMPRESSED_RGBA_S3TC_DXT1
  • tfCOMPRESSED_RGBA_S3TC_DXT3
  • tfCOMPRESSED_RGBA_S3TC_DXT5
  • tfSIGNED_LUMINANCE8
  • tfSIGNED_LUMINANCE8_ALPHA8
  • tfSIGNED_RGB8
  • tfSIGNED_RGBA8
  • tfSIGNED_RGB8_UNSIGNED_ALPHA8
  • tfSIGNED_ALPHA8
  • tfSIGNED_INTENSITY8
  • tfHILO16
  • tfSIGNED_HILO16
  • tfDSDT8
  • tfDSDT8_MAG8
  • tfDSDT8_MAG8_INTENSITY8
  • tfHILO8
  • tfSIGNED_HILO8
  • tfFLOAT_R16
  • tfFLOAT_R32
  • tfFLOAT_RG16
  • tfFLOAT_RGB16
  • tfFLOAT_RGBA16
  • tfFLOAT_RG32
  • tfFLOAT_RGB32
  • tfFLOAT_RGBA32
  • tfRGBA_FLOAT32
  • tfRGB_FLOAT32
  • tfALPHA_FLOAT32
  • tfINTENSITY_FLOAT32
  • tfLUMINANCE_FLOAT32
  • tfLUMINANCE_ALPHA_FLOAT32
  • tfRGBA_FLOAT16
  • tfRGB_FLOAT16
  • tfALPHA_FLOAT16
  • tfINTENSITY_FLOAT16
  • tfLUMINANCE_FLOAT16
  • tfLUMINANCE_ALPHA_FLOAT16
  • tfDEPTH24_STENCIL8
  • tfDEPTH_COMPONENT32F
  • tfDEPTH32F_STENCIL8
  • tfSRGB8
  • tfSRGB8_ALPHA8
  • tfSLUMINANCE8
  • tfSLUMINANCE8_ALPHA8
  • tfCOMPRESSED_SRGB_S3TC_DXT1
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT1
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT3
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT5
  • tfRGB9_E5
  • tfR11F_G11F_B10F
  • tfCOMPRESSED_LUMINANCE_LATC1
  • tfCOMPRESSED_SIGNED_LUMINANCE_LATC1
  • tfCOMPRESSED_LUMINANCE_ALPHA_LATC2
  • tfCOMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2
  • tfCOMPRESSED_LUMINANCE_ALPHA_3DC
  • tfRGBA32UI
  • tfRGB32UI
  • tfALPHA32UI
  • tfINTENSITY32UI
  • tfLUMINANCE32UI
  • tfLUMINANCE_ALPHA32UI
  • tfRGBA16UI
  • tfRGB16UI
  • tfALPHA16UI
  • tfINTENSITY16UI
  • tfLUMINANCE16UI
  • tfLUMINANCE_ALPHA16UI
  • tfRGBA8UI
  • tfRGB8UI
  • tfALPHA8UI
  • tfINTENSITY8UI
  • tfLUMINANCE8UI
  • tfLUMINANCE_ALPHA8UI
  • tfRGBA32I
  • tfRGB32I
  • tfALPHA32I
  • tfINTENSITY32I
  • tfLUMINANCE32I
  • tfLUMINANCE_ALPHA32I
  • tfRGBA16I
  • tfRGB16I
  • tfALPHA16I
  • tfINTENSITY16I
  • tfLUMINANCE16I
  • tfLUMINANCE_ALPHA16I
  • tfRGBA8I
  • tfRGB8I
  • tfALPHA8I
  • tfINTENSITY8I
  • tfLUMINANCE8I
  • tfLUMINANCE_ALPHA8I
  • tfRG32UI
  • tfR32UI
  • tfRG16UI
  • tfR16UI
  • tfRG8UI
  • tfR8UI
  • tfRG32I
  • tfR32I
  • tfRG16I
  • tfR16I
  • tfRG8I
  • tfR8I
  • tfRG8
  • tfR8
  • tfRG16
  • tfR16
  • tfRG16F
  • tfR16F
  • tfRG32F
  • tfR32F
  • tfCOMPRESSED_RED_RGTC1
  • tfCOMPRESSED_SIGNED_RED_RGTC1
  • tfCOMPRESSED_RG_RGTC2
  • tfCOMPRESSED_SIGNED_RG_RGTC2
  • tfR8_SNORM
  • tfRG8_SNORM
  • tfRGB8_SNORM
  • tfRGBA8_SNORM
  • tfR16_SNORM
  • tfRG16_SNORM
  • tfRGB16_SNORM
  • tfRGBA16_SNORM
TglSeparateTextureWrap = (...);

Texture addressing rules

Values
  • twRepeat
  • twClampToEdge
  • twClampToBorder
  • twMirrorRepeat
  • twMirrorClampToEdge
  • twMirrorClampToBorder
TglSwizzleVector = array[0..3] of TglTextureSwizzle;

This item has no description.

TglTextureCompareMode = (...);

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*

Values
  • tcmNone
  • tcmCompareRtoTexture
TglTextureFilteringQuality = (...);

Filtering quality

Values
  • tfIsotropic
  • tfAnisotropic
TglTextureSwizzle = (...);

This item has no description.

Values
  • tswRed
  • tswGreen
  • tswBlue
  • tswAlpha
  • tswZero
  • tswOne
TglTextureTarget = (...);

This item has no description.

Values
  • ttNoShape
  • ttTexture1D
  • ttTexture2D
  • ttTexture3D
  • ttTexture1DArray
  • ttTexture2DArray
  • ttTextureRect
  • ttTextureBuffer
  • ttTextureCube
  • ttTexture2DMultisample
  • ttTexture2DMultisampleArray
  • ttTextureCubeArray

Constants

cDefaultSwizzleVector: TglSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

This item has no description.

Variables

vDefaultTextureFormat: TglInternalFormat = tfRGBA8;

This item has no description.

vDefaultTextureCompression: TglInternalCompression = tcNone;


GXSysHelp v.2.5: GLScene.Triangulation

Unit GLScene.Triangulation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.Types
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record DVertex |
Record DTriangle |
Class TGDelaunay2D |

Types

TDComplete = array of Boolean;
TDEdges = array of array of LongInt;
TDProgressEvent = procedure(State: string; Pos, Max: Integer; AlwaysUpdate: Boolean = False) of object;
TDTriangle = array of DTriangle;
TDVertex = array of DVertex;

Constants

MaxVertices = 500000;
MaxTriangles = 1000000;
ExPtTolerance = 0.000001;

Description

Types

TDComplete = array of Boolean;

This item has no description.

TDEdges = array of array of LongInt;

This item has no description.

TDProgressEvent = procedure(State: string; Pos, Max: Integer; AlwaysUpdate: Boolean = False) of object;

This item has no description.

TDTriangle = array of DTriangle;

This item has no description.

TDVertex = array of DVertex;

This item has no description.

Constants

MaxVertices = 500000;

Set these as applicable

MaxTriangles = 1000000;

This item has no description.

ExPtTolerance = 0.000001;


GXSysHelp v.2.5: GLScene.Triangulation: Record DVertex

Record DVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type DVertex = record

Description

Points (Vertices)

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | Z: Single;
Public | U: Single;
Public | V: Single;
Public | MatIndex: Integer;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public Z: Single;

This item has no description.

Public U: Single;

Added to save height of terrain.

Public V: Single;

This item has no description.

Public MatIndex: Integer;


GXSysHelp v.2.5: GLScene.Triangulation: Record DTriangle

Record DTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type DTriangle = record

Description

Created Triangles, vv# are the vertex pointers

Overview

Fields

Public | vv0: LongInt;
Public | vv1: LongInt;
Public | vv2: LongInt;
Public | PreCalc: Integer;
Public | Xc: Single;
Public | Yc: Single;
Public | R: Single;

Description

Fields

Public vv0: LongInt;

This item has no description.

Public vv1: LongInt;

This item has no description.

Public vv2: LongInt;

This item has no description.

Public PreCalc: Integer;

This item has no description.

Public Xc: Single;

This item has no description.

Public Yc: Single;

This item has no description.

Public R: Single;


GXSysHelp v.2.5: GLScene.Triangulation: Class TGDelaunay2D

Class TGDelaunay2D

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Triangulation

Declaration

type TGDelaunay2D = class(TObject)

Description

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact

Hierarchy

  • TObject
  • TGDelaunay2D

Overview

Fields

Public | Vertex: TDVertex;
Public | Triangle: TDTriangle;
Public | HowMany: Integer;
Public | TPoints: Integer;
Public | OnProgress: TDProgressEvent;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function InCircle(Xp, Yp, X1, Y1, X2, Y2, X3, Y3: Single; out Xc,Yc, R: Single; j: Integer): Boolean;
Private | function Triangulate(nvert: Integer): Integer;
Public | procedure AddPoint(X, Y, Z, U, V: Single; MatIndex: Integer);
Public | procedure AddPointNoCheck(X, Y, Z, U, V: Single; MatIndex: Integer);
Public | procedure Mesh(sort: Boolean);
Public | procedure QuickSort(var A: TDVertex; Low, High: Integer);
Public | procedure RemoveLastPoint;

Description

Fields

Public Vertex: TDVertex;

This item has no description.

Public Triangle: TDTriangle;

This item has no description.

Public HowMany: Integer;

This item has no description.

Public TPoints: Integer;

Total number of points (vertices)

Public OnProgress: TDProgressEvent;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function InCircle(Xp, Yp, X1, Y1, X2, Y2, X3, Y3: Single; out Xc,Yc, R: Single; j: Integer): Boolean;

This item has no description.

Private function Triangulate(nvert: Integer): Integer;

Takes as input NVERT vertices in arrays Vertex() Returned is a list of NTRI triangular faces in the array Triangle(). These triangles are arranged in clockwise order.

Public procedure AddPoint(X, Y, Z, U, V: Single; MatIndex: Integer);

This item has no description.

Public procedure AddPointNoCheck(X, Y, Z, U, V: Single; MatIndex: Integer);

This item has no description.

Public procedure Mesh(sort: Boolean);

This item has no description.

Public procedure QuickSort(var A: TDVertex; Low, High: Integer);

This item has no description.

Public procedure RemoveLastPoint;


GXSysHelp v.2.5: GLScene.Utils

Unit GLScene.Utils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.ShellApi
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • GLScene.VectorGeometry
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLUtilsException |

Functions and Procedures

function GetCurrentAssetPath(): TFileName;
procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);
function RoundUpToPowerOf2(value: Integer): Integer;
function RoundDownToPowerOf2(value: Integer): Integer;
function IsPowerOf2(value: Integer): Boolean;
function ReadCRLFString(aStream: TStream): String;
procedure WriteCRLFString(aStream: TStream; const aString: String);
function StrToFloatDef(const strValue: string; defValue: Extended = 0) : Extended;
function Str2Float(const S: string): Single;
function ParseInteger(var p: PChar): Integer;
function ParseFloat(var p: PChar): Extended;
procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);
function LoadAnsiStringFromFile(const fileName: string): AnsiString;
procedure SaveStringToFile(const fileName: string; const data: String);
function LoadStringFromFile(const fileName: string): String;
procedure SaveComponentToFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);
procedure LoadComponentFromFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);
function SizeOfFile(const fileName: string): Int64;
function GetSqrt255Array: PSqrt255Array;
function GetGLRect(const aLeft, aTop, aRight, aBottom: Integer): TRect;
procedure InflateGLRect(var aRect: TRect; dx, dy: Integer);
procedure IntersectGLRect(var aRect: TRect; const rect2: TRect);
procedure RaiseLastOSError;
procedure FixPathDelimiter(var S: string);
function RelativePath(const S: string): string;
procedure QueryPerformanceCounter(out val: Int64);
function QueryPerformanceFrequency(out val: Int64): Boolean;
function StartPrecisionTimer: Int64;
function PrecisionTimerLap(const precisionTimer: Int64): Double;
function StopPrecisionTimer(const precisionTimer: Int64): Double;
function AppTime: Double;
procedure ShowHTMLUrl(const Url: string);
procedure SetExeDirectory;
function AnsiStartsText(const ASubText, AText: string): Boolean;
function IsSubComponent(const AComponent: TComponent): Boolean; inline;
procedure MakeSubComponent(const AComponent: TComponent; const value: Boolean);
function FindUnitName(anObject: TObject): string; overload;
function FindUnitName(aClass: TClass): string; overload;
function FloatToHalf(Float: Single): THalfFloat;
function HalfToFloat(Half: THalfFloat): Single;
function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;
function IsDirectoryWriteable(const AName: string): Boolean;
function CharToWideChar(const AChar: AnsiChar): WideChar;
function GLStrToFloatDef(const S: string; const Default: Extended; fs: TFormatSettings): Extended; overload;
function GLStrToFloatDef(const S: string; const Default: Extended) : Extended; overload;
function GLStrToFloatDef(const S: string): Extended; overload;

Types

EGLOSError = EOSError;
PHalfFloat = ˆTHalfFloat;
PSqrt255Array = ˆTSqrt255Array;
THalfFloat = type Word;
TProjectTargetNameFunc = function(): string;
TSqrt255Array = array [0 .. 255] of Byte;

Constants

FONT_CHARS_COUNT = 2024;

Variables

IsDesignTime: Boolean = False;
vProjectTargetName: TProjectTargetNameFunc;

Description

Functions and Procedures

function GetCurrentAssetPath(): TFileName;

Get current path to assets from dir examples

procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);

Copies the values of Source to Dest (converting word values to integer values)

function RoundUpToPowerOf2(value: Integer): Integer;

Round ups to the nearest power of two, value must be positive

function RoundDownToPowerOf2(value: Integer): Integer;

Round down to the nearest power of two, value must be strictly positive

function IsPowerOf2(value: Integer): Boolean;

Returns True if value is a true power of two

function ReadCRLFString(aStream: TStream): String;

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.

procedure WriteCRLFString(aStream: TStream; const aString: String);

Write the string and a CRLF in the stream

function StrToFloatDef(const strValue: string; defValue: Extended = 0) : Extended;

Similar to SysUtils.StrToFloatDef, but ignores user's locale

function Str2Float(const S: string): Single;

Trying to read string otherwise using '.' as Decimal Separator

function ParseInteger(var p: PChar): Integer;

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

function ParseFloat(var p: PChar): Extended;

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);

Saves ansistring "data" to "filename".

function LoadAnsiStringFromFile(const fileName: string): AnsiString;

Returns the ansistring content of "filename".

procedure SaveStringToFile(const fileName: string; const data: String);

Saves string "data" to "filename".

function LoadStringFromFile(const fileName: string): String;

Returns the string content of "filename".

procedure SaveComponentToFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);

Saves component to a file.

procedure LoadComponentFromFile(const Component: TComponent; const fileName: string; const AsText: Boolean = True);

Loads component from a file.

function SizeOfFile(const fileName: string): Int64;

Returns the size of "filename". Returns 0 (zero) is file does not exists.

function GetSqrt255Array: PSqrt255Array;

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

function GetGLRect(const aLeft, aTop, aRight, aBottom: Integer): TRect;

Rectangle as function

procedure InflateGLRect(var aRect: TRect; dx, dy: Integer);

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

procedure IntersectGLRect(var aRect: TRect; const rect2: TRect);

This item has no description.

procedure RaiseLastOSError;

This item has no description.

procedure FixPathDelimiter(var S: string);

Replace path delimiter to delimiter of the current platform.

function RelativePath(const S: string): string;

Remove if possible part of path witch leads to project executable.

procedure QueryPerformanceCounter(out val: Int64);

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

function QueryPerformanceFrequency(out val: Int64): Boolean;

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.

function StartPrecisionTimer: Int64;

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

function PrecisionTimerLap(const precisionTimer: Int64): Double;

Computes time elapsed since timer start. Return time lap in seconds.

function StopPrecisionTimer(const precisionTimer: Int64): Double;

Computes time elapsed since timer start and stop timer. Return time lap in seconds.

function AppTime: Double;

Returns time in milisecond from application start.

procedure ShowHTMLUrl(const Url: string);

This item has no description.

procedure SetExeDirectory;

This item has no description.

function AnsiStartsText(const ASubText, AText: string): Boolean;

StrUtils.pas

function IsSubComponent(const AComponent: TComponent): Boolean; inline;

Classes.pas

procedure MakeSubComponent(const AComponent: TComponent; const value: Boolean);

This item has no description.

function FindUnitName(anObject: TObject): string; overload;

This item has no description.

function FindUnitName(aClass: TClass): string; overload;

This item has no description.

function FloatToHalf(Float: Single): THalfFloat;

This item has no description.

function HalfToFloat(Half: THalfFloat): Single;

This item has no description.

function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;

This item has no description.

function IsDirectoryWriteable(const AName: string): Boolean;

Determine if the directory is writable.

function CharToWideChar(const AChar: AnsiChar): WideChar;

This item has no description.

function GLStrToFloatDef(const S: string; const Default: Extended; fs: TFormatSettings): Extended; overload;

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...

function GLStrToFloatDef(const S: string; const Default: Extended) : Extended; overload;

This item has no description.

function GLStrToFloatDef(const S: string): Extended; overload;

This item has no description.

Types

EGLOSError = EOSError;

This item has no description.

PHalfFloat = ˆTHalfFloat;

This item has no description.

PSqrt255Array = ˆTSqrt255Array;

This item has no description.

THalfFloat = type Word;

This item has no description.

TProjectTargetNameFunc = function(): string;

This item has no description.

TSqrt255Array = array [0 .. 255] of Byte;

This item has no description.

Constants

FONT_CHARS_COUNT = 2024;

This item has no description.

Variables

IsDesignTime: Boolean = False;

This item has no description.

vProjectTargetName: TProjectTargetNameFunc;


GXSysHelp v.2.5: GLScene.Utils: Class EGLUtilsException

Class EGLUtilsException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.Utils

Declaration

type EGLUtilsException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLUtilsException


GXSysHelp v.2.5: GLScene.VectorGeometry

Unit GLScene.VectorGeometry

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TTexPoint |
Record TQuaternion |
Record TRectangle |
Record TFrustum |

Functions and Procedures

function TexPointMake(const S, T: Single): TTexPoint; inline;
function AffineVectorMake(const X, Y, Z: Single): TAffineVector; overload; inline;
function AffineVectorMake(const V: TGLVector): TAffineVector; overload; inline;
procedure SetAffineVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure SetVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure SetVector(out V: TAffineVector; const vSrc: TGLVector); overload; inline;
procedure SetVector(out V: TAffineVector; const vSrc: TAffineVector); overload; inline;
procedure SetVector(out V: TAffineDblVector; const vSrc: TAffineVector); overload; inline;
procedure SetVector(out V: TAffineDblVector; const vSrc: TGLVector); overload; inline;
function VectorMake(const V: TAffineVector; W: Single = 0): TGLVector; overload; inline;
function VectorMake(const X, Y, Z: Single; W: Single = 0): TGLVector; overload; inline;
function VectorMake(const Q: TQuaternion): TGLVector; overload; inline;
function PointMake(const X, Y, Z: Single): TGLVector; overload; inline;
function PointMake(const V: TAffineVector): TGLVector; overload; inline;
function PointMake(const V: TGLVector): TGLVector; overload; inline;
procedure SetVector(out V: TGLVector; const X, Y, Z: Single; W: Single = 0); overload; inline;
procedure SetVector(out V: TGLVector; const av: TAffineVector; W: Single = 0); overload; inline;
procedure SetVector(out V: TGLVector; const vSrc: TGLVector); overload; inline;
procedure MakePoint(out V: TGLVector; const X, Y, Z: Single); overload; inline;
procedure MakePoint(out V: TGLVector; const av: TAffineVector); overload; inline;
procedure MakePoint(out V: TGLVector; const av: TGLVector); overload; inline;
procedure MakeVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;
procedure MakeVector(out V: TGLVector; const X, Y, Z: Single); overload; inline;
procedure MakeVector(out V: TGLVector; const av: TAffineVector); overload; inline;
procedure MakeVector(out V: TGLVector; const av: TGLVector); overload; inline;
procedure RstVector(var V: TAffineVector); overload; inline;
procedure RstVector(var V: TGLVector); overload; inline;
function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload; inline;
function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector2b): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector3b): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4i): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4d): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4s): Boolean; overload; inline;
function VectorEquals(const V1, V2: TVector4b): Boolean; overload; inline;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;
function Vector2fMake(const X, Y: Single): TVector2f; overload; inline;
function Vector2iMake(const X, Y: Longint): TVector2i; overload; inline;
function Vector2sMake(const X, Y: SmallInt): TVector2s; overload; inline;
function Vector2dMake(const X, Y: Double): TVector2d; overload; inline;
function Vector2bMake(const X, Y: Byte): TVector2b; overload; inline;
function Vector2fMake(const Vector: TVector3f): TVector2f; overload; inline;
function Vector2iMake(const Vector: TVector3i): TVector2i; overload; inline;
function Vector2sMake(const Vector: TVector3s): TVector2s; overload; inline;
function Vector2dMake(const Vector: TVector3d): TVector2d; overload; inline;
function Vector2bMake(const Vector: TVector3b): TVector2b; overload; inline;
function Vector2fMake(const Vector: TVector4f): TVector2f; overload; inline;
function Vector2iMake(const Vector: TVector4i): TVector2i; overload; inline;
function Vector2sMake(const Vector: TVector4s): TVector2s; overload; inline;
function Vector2dMake(const Vector: TVector4d): TVector2d; overload; inline;
function Vector2bMake(const Vector: TVector4b): TVector2b; overload; inline;
function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0) : TVector3f; overload; inline;
function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload; inline;
function Vector3sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0): TVector3s; overload; inline;
function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload; inline;
function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload; inline;
function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload; inline;
function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload; inline;
function Vector3sMake(const Vector: TVector2s; const Z: SmallInt = 0): TVector3s; overload; inline;
function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload; inline;
function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload; inline;
function Vector3fMake(const Vector: TVector4f): TVector3f; overload; inline;
function Vector3iMake(const Vector: TVector4i): TVector3i; overload; inline;
function Vector3sMake(const Vector: TVector4s): TVector3s; overload; inline;
function Vector3dMake(const Vector: TVector4d): TVector3d; overload; inline;
function Vector3bMake(const Vector: TVector4b): TVector3b; overload; inline;
function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;
function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;
function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const Vector: TVector3s; const W: SmallInt = 0) : TVector4s; overload; inline;
function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload; inline;
function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;
function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;
function Vector4sMake(const Vector: TVector2s; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;
function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;
function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorAdd(const V1, V2: TVector2f): TVector2f; overload;
function VectorAdd(const V1, V2: TAffineVector): TAffineVector; overload;
procedure VectorAdd(const V1, V2: TAffineVector; var vr: TAffineVector); overload;
procedure VectorAdd(const V1, V2: TAffineVector; vr: PAffineVector); overload;
function VectorAdd(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorAdd(const V1, V2: TGLVector; var vr: TGLVector); overload;
function VectorAdd(const V: TAffineVector; const f: Single): TAffineVector; overload; inline;
function VectorAdd(const V: TGLVector; const f: Single): TGLVector; overload; inline;
procedure AddVector(var V1: TAffineVector; const V2: TAffineVector); overload;
procedure AddVector(var V1: TAffineVector; const V2: TGLVector); overload;
procedure AddVector(var V1: TGLVector; const V2: TGLVector); overload;
procedure AddVector(var V: TAffineVector; const f: Single); overload; inline;
procedure AddVector(var V: TGLVector; const f: Single); overload; inline;
procedure AddPoint(var V1: TGLVector; const V2: TGLVector); overload; inline;
function PointAdd(var V1: TGLVector; const V2: TGLVector): TGLVector; overload; inline;
procedure TexPointArrayAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; dest: PTexPointArray); overload;
procedure TexPointArrayScaleAndAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; const scale: TTexPoint; dest: PTexPointArray); overload;
procedure VectorArrayAdd(const src: PAffineVectorArray; const delta: TAffineVector; const nb: Integer; dest: PAffineVectorArray); overload;
function VectorSubtract(const V1, V2: TVector2f): TVector2f; overload;
procedure SubtractVector(var V1: TVector2f; const V2: TVector2f); overload;
function VectorSubtract(const V1, V2: TAffineVector): TAffineVector; overload;
procedure VectorSubtract(const V1, V2: TAffineVector; var result: TAffineVector); overload;
procedure VectorSubtract(const V1, V2: TAffineVector; var result: TGLVector); overload;
procedure VectorSubtract(const V1: TGLVector; const V2: TAffineVector; var result: TGLVector); overload;
function VectorSubtract(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorSubtract(const V1, V2: TGLVector; var result: TGLVector); overload;
procedure VectorSubtract(const V1, V2: TGLVector; var result: TAffineVector); overload;
function VectorSubtract(const V1: TAffineVector; delta: Single): TAffineVector; overload; inline;
function VectorSubtract(const V1: TGLVector; delta: Single): TGLVector; overload; inline;
procedure SubtractVector(var V1: TAffineVector; const V2: TAffineVector); overload;
procedure SubtractVector(var V1: TGLVector; const V2: TGLVector); overload;
procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; var f: Single); overload;
procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; pf: PFloat); overload;
function TexPointCombine(const t1, t2: TTexPoint; f1, f2: Single): TTexPoint; inline;
function VectorCombine(const V1, V2: TAffineVector; const f1, f2: Single): TAffineVector; overload; inline;
function VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single): TAffineVector; overload; inline;
procedure VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single; var vr: TAffineVector); overload; inline;
procedure CombineVector(var vr: TGLVector; const V: TGLVector; var f: Single); overload;
procedure CombineVector(var vr: TGLVector; const V: TAffineVector; var f: Single); overload;
function VectorCombine(const V1, V2: TGLVector; const F1, F2: Single): TGLVector; overload; inline;
function VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single): TGLVector; overload; inline;
procedure VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single; var VR: TGLVector); overload; inline;
procedure VectorCombine(const V1, V2: TGLVector; const F1, F2: Single; var vr: TGLVector); overload;
procedure VectorCombine(const V1, V2: TGLVector; const F2: Single; var vr: TGLVector); overload;
function VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single): TGLVector; overload; inline;
procedure VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single; var vr: TGLVector); overload;
function VectorDotProduct(const V1, V2: TVector2f): Single; overload;
function VectorDotProduct(const V1, V2: TAffineVector): Single; overload;
function VectorDotProduct(const V1, V2: TGLVector): Single; overload;
function VectorDotProduct(const V1: TGLVector; const V2: TAffineVector): Single; overload;
function PointProject(const p, origin, direction: TAffineVector): Single; overload;
function PointProject(const p, origin, direction: TGLVector): Single; overload;
function VectorCrossProduct(const V1, V2: TAffineVector): TAffineVector; overload;
function VectorCrossProduct(const V1, V2: TGLVector): TGLVector; overload;
procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TGLVector); overload;
procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TGLVector); overload;
procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TAffineVector); overload;
procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TAffineVector); overload;
function Lerp(const start, stop, T: Single): Single; inline;
function AngleLerp(start, stop, T: Single): Single; inline;
function MatrixLerp(const m1, m2: TGLMatrix; const delta: Single): TGLMatrix;
function DistanceBetweenAngles(angle1, angle2: Single): Single;
function TexPointLerp(const t1, t2: TTexPoint; T: Single): TTexPoint; overload; inline;
function VectorLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload; inline;
procedure VectorLerp(const V1, V2: TAffineVector; T: Single; var vr: TAffineVector); overload;
function VectorLerp(const V1, V2: TGLVector; T: Single): TGLVector; overload; inline;
procedure VectorLerp(const V1, V2: TGLVector; T: Single; var vr: TGLVector); overload; inline;
function VectorAngleLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload;
function VectorAngleCombine(const V1, V2: TAffineVector; f: Single): TAffineVector; overload;
procedure VectorArrayLerp(const src1, src2: PVectorArray; T: Single; n: Integer; dest: PVectorArray); overload;
procedure VectorArrayLerp(const src1, src2: PAffineVectorArray; T: Single; n: Integer; dest: PAffineVectorArray); overload;
procedure VectorArrayLerp(const src1, src2: PTexPointArray; T: Single; n: Integer; dest: PTexPointArray); overload;
function InterpolatePower(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateLn(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateExp(const start, stop, delta: Single; const DistortionDegree: Single): Single;
function InterpolateSin(const start, stop, delta: Single): Single;
function InterpolateTan(const start, stop, delta: Single): Single;
function InterpolateSinAlt(const start, stop, delta: Single): Single;
function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single; inline;
function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function InterpolateCombined(const start, stop, delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;
function VectorLength(const X, Y: Single): Single; overload;
function VectorLength(const X, Y, Z: Single): Single; overload;
function VectorLength(const V: TVector2f): Single; overload;
function VectorLength(const V: TAffineVector): Single; overload;
function VectorLength(const V: TGLVector): Single; overload;
function VectorLength(const V: array of Single): Single; overload;
function VectorNorm(const X, Y: Single): Single; overload;
function VectorNorm(const V: TAffineVector): Single; overload;
function VectorNorm(const V: TGLVector): Single; overload;
function VectorNorm(var V: array of Single): Single; overload;
procedure NormalizeVector(var V: TVector2f); overload;
procedure NormalizeVector(var V: TAffineVector); overload;
procedure NormalizeVector(var V: TGLVector); overload;
function VectorNormalize(const V: TVector2f): TVector2f; overload;
function VectorNormalize(const V: TAffineVector): TAffineVector; overload;
function VectorNormalize(const V: TGLVector): TGLVector; overload;
procedure NormalizeVectorArray(list: PAffineVectorArray; n: Integer); overload; inline;
function VectorAngleCosine(const V1, V2: TAffineVector): Single; overload;
function VectorAngleCosine(const V1, V2: TGLVector): Single; overload;
function VectorNegate(const Vector: TAffineVector): TAffineVector; overload;
function VectorNegate(const Vector: TGLVector): TGLVector; overload;
procedure NegateVector(var V: TAffineVector); overload;
procedure NegateVector(var V: TGLVector); overload;
procedure NegateVector(var V: array of Single); overload;
procedure ScaleVector(var V: TVector2f; factor: Single); overload;
procedure ScaleVector(var V: TAffineVector; factor: Single); overload;
procedure ScaleVector(var V: TAffineVector; const factor: TAffineVector); overload;
procedure ScaleVector(var V: TGLVector; factor: Single); overload;
procedure ScaleVector(var V: TGLVector; const factor: TGLVector); overload;
function VectorScale(const V: TVector2f; factor: Single): TVector2f; overload;
function VectorScale(const V: TAffineVector; factor: Single): TAffineVector; overload;
procedure VectorScale(const V: TAffineVector; factor: Single; var vr: TAffineVector); overload;
function VectorScale(const V: TGLVector; factor: Single): TGLVector; overload;
procedure VectorScale(const V: TGLVector; factor: Single; var vr: TGLVector); overload;
procedure VectorScale(const V: TGLVector; factor: Single; var vr: TAffineVector); overload;
function VectorScale(const V: TAffineVector; const factor: TAffineVector): TAffineVector; overload;
function VectorScale(const V: TGLVector; const factor: TGLVector): TGLVector; overload;
procedure DivideVector(var V: TGLVector; const divider: TGLVector); overload; inline;
procedure DivideVector(var V: TAffineVector; const divider: TAffineVector); overload; inline;
function VectorDivide(const V: TGLVector; const divider: TGLVector): TGLVector; overload; inline;
function VectorDivide(const V: TAffineVector; const divider: TAffineVector): TAffineVector; overload; inline;
function TexpointEquals(const p1, p2: TTexPoint): Boolean; inline;
function RectEquals(const Rect1, Rect2: TRect): Boolean; inline;
function VectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;
function VectorEquals(const V1, V2: TAffineVector): Boolean; overload; inline;
function AffineVectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;
function VectorIsNull(const V: TGLVector): Boolean; overload; inline;
function VectorIsNull(const V: TAffineVector): Boolean; overload; inline;
function VectorSpacing(const V1, V2: TTexPoint): Single; overload;
function VectorSpacing(const V1, V2: TAffineVector): Single; overload;
function VectorSpacing(const V1, V2: TGLVector): Single; overload;
function VectorDistance(const V1, V2: TAffineVector): Single; overload;
function VectorDistance(const V1, V2: TGLVector): Single; overload;
function VectorDistance2(const V1, V2: TAffineVector): Single; overload;
function VectorDistance2(const V1, V2: TGLVector): Single; overload;
function VectorPerpendicular(const V, n: TAffineVector): TAffineVector;
function VectorReflect(const V, n: TAffineVector): TAffineVector;
procedure RotateVector(var Vector: TGLVector; const axis: TAffineVector; angle: Single); overload;
procedure RotateVector(var Vector: TGLVector; const axis: TGLVector; angle: Single); overload;
procedure RotateVectorAroundY(var V: TAffineVector; alpha: Single);
function VectorRotateAroundX(const V: TAffineVector; alpha: Single): TAffineVector; overload;
function VectorRotateAroundY(const V: TAffineVector; alpha: Single): TAffineVector; overload;
procedure VectorRotateAroundY(const V: TAffineVector; alpha: Single; var vr: TAffineVector); overload;
function VectorRotateAroundZ(const V: TAffineVector; alpha: Single): TAffineVector; overload;
procedure AbsVector(var V: TGLVector); overload; inline;
procedure AbsVector(var V: TAffineVector); overload; inline;
function VectorAbs(const V: TGLVector): TGLVector; overload; inline;
function VectorAbs(const V: TAffineVector): TAffineVector; overload; inline;
function IsColinear(const V1, V2: TVector2f): Boolean; overload;
function IsColinear(const V1, V2: TAffineVector): Boolean; overload;
function IsColinear(const V1, V2: TGLVector): Boolean; overload;
procedure SetMatrix(var dest: THomogeneousDblMatrix; const src: TGLMatrix); overload;
procedure SetMatrix(var dest: TAffineMatrix; const src: TGLMatrix); overload;
procedure SetMatrix(var dest: TGLMatrix; const src: TAffineMatrix); overload;
procedure SetMatrixRow(var dest: TGLMatrix; rowNb: Integer; const aRow: TGLVector); overload;
function CreateScaleMatrix(const V: TAffineVector): TGLMatrix; overload;
function CreateScaleMatrix(const V: TGLVector): TGLMatrix; overload;
function CreateTranslationMatrix(const V: TAffineVector): TGLMatrix; overload;
function CreateTranslationMatrix(const V: TGLVector): TGLMatrix; overload;
function CreateScaleAndTranslationMatrix(const scale, offset: TGLVector): TGLMatrix; overload;
function CreateRotationMatrixX(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixX(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrixY(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixY(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrixZ(const sine, cosine: Single): TGLMatrix; overload;
function CreateRotationMatrixZ(const angle: Single): TGLMatrix; overload;
function CreateRotationMatrix(const anAxis: TAffineVector; angle: Single): TGLMatrix; overload;
function CreateRotationMatrix(const anAxis: TGLVector; angle: Single): TGLMatrix; overload;
function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;
function MatrixMultiply(const m1, m2: TAffineMatrix): TAffineMatrix; overload;
function MatrixMultiply(const m1, m2: TGLMatrix): TGLMatrix; overload;
procedure MatrixMultiply(const m1, m2: TGLMatrix; var MResult: TGLMatrix); overload;
function VectorTransform(const V: TGLVector; const M: TGLMatrix): TGLVector; overload;
function VectorTransform(const V: TGLVector; const M: TAffineMatrix): TGLVector; overload;
function VectorTransform(const V: TAffineVector; const M: TGLMatrix): TAffineVector; overload;
function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;
function MatrixDeterminant(const M: TAffineMatrix): Single; overload;
function MatrixDeterminant(const M: TGLMatrix): Single; overload;
procedure AdjointMatrix(var M: TGLMatrix); overload;
procedure AdjointMatrix(var M: TAffineMatrix); overload;
procedure ScaleMatrix(var M: TAffineMatrix; const factor: Single); overload;
procedure ScaleMatrix(var M: TGLMatrix; const factor: Single); overload;
procedure TranslateMatrix(var M: TGLMatrix; const V: TAffineVector); overload;
procedure TranslateMatrix(var M: TGLMatrix; const V: TGLVector); overload;
procedure NormalizeMatrix(var M: TGLMatrix);
procedure TransposeMatrix(var M: TAffineMatrix); overload;
procedure TransposeMatrix(var M: TGLMatrix); overload;
procedure InvertMatrix(var M: TGLMatrix); overload;
function MatrixInvert(const M: TGLMatrix): TGLMatrix; overload;
procedure InvertMatrix(var M: TAffineMatrix); overload;
function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;
function AnglePreservingMatrixInvert(const mat: TGLMatrix): TGLMatrix;
function MatrixDecompose(const M: TGLMatrix; var Tran: TTransformations): Boolean;
function CreateLookAtMatrix(const eye, center, normUp: TGLVector): TGLMatrix;
function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;
function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TGLMatrix;
function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;
function CreatePickMatrix(X, Y, deltax, deltay: Single; const viewport: TVector4i): TGLMatrix;
function Project(objectVector: TGLVector; const ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out WindowVector: TGLVector): Boolean;
function UnProject(WindowVector: TGLVector; ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out objectVector: TGLVector): Boolean;
function PlaneMake(const p1, p2, p3: TAffineVector): THmgPlane; overload;
function PlaneMake(const p1, p2, p3: TGLVector): THmgPlane; overload;
function PlaneMake(const point, normal: TAffineVector): THmgPlane; overload;
function PlaneMake(const point, normal: TGLVector): THmgPlane; overload;
procedure SetPlane(var dest: TDoubleHmgPlane; const src: THmgPlane);
procedure NormalizePlane(var plane: THmgPlane);
function PlaneEvaluatePoint(const plane: THmgPlane; const point: TAffineVector): Single; overload;
function PlaneEvaluatePoint(const plane: THmgPlane; const point: TGLVector): Single; overload;
function CalcPlaneNormal(const p1, p2, p3: TAffineVector): TAffineVector; overload;
procedure CalcPlaneNormal(const p1, p2, p3: TAffineVector; var vr: TAffineVector); overload;
procedure CalcPlaneNormal(const p1, p2, p3: TGLVector; var vr: TAffineVector); overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal: TGLVector): Boolean; overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal: TAffineVector): Boolean; overload;
function PointIsInHalfSpace(const point: TAffineVector; const plane: THmgPlane): Boolean; overload;
function PointPlaneDistance(const point, planePoint, planeNormal: TGLVector): Single; overload;
function PointPlaneDistance(const point, planePoint, planeNormal: TAffineVector): Single; overload;
function PointPlaneDistance(const point: TAffineVector; const plane: THmgPlane): Single; overload;
function PointPlaneOrthoProjection(const point: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointPlaneProjection(const point, direction: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function SegmentPlaneIntersection(const ptA, ptB: TAffineVector; const plane: THmgPlane; var inter: TAffineVector): Boolean;
function PointTriangleOrthoProjection(const point, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointTriangleProjection(const point, direction, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC: TAffineVector): Boolean;
function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD: TAffineVector): Boolean;
function PointDiskOrthoProjection(const point, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointDiskProjection(const point, direction, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TAffineVector): TAffineVector; overload;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TGLVector): TGLVector; overload;
function PointSegmentDistance(const point, segmentStart, segmentStop: TAffineVector): Single;
function PointLineClosestPoint(const point, linePoint, lineDirection: TAffineVector): TAffineVector;
function PointLineDistance(const point, linePoint, lineDirection: TAffineVector): Single;
procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector; var Segment0Closest, Segment1Closest: TAffineVector);
function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector): Single;
function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1: TAffineVector): Single;
function QuaternionMake(const Imag: array of Single; Real: Single): TQuaternion; overload;
function QuaternionMake(const X,Y,Z,W: Single): TQuaternion; overload;
function QuaternionMake(const V: TGLVector): TQuaternion; overload;
function QuaternionConjugate(const Q: TQuaternion): TQuaternion;
function QuaternionMagnitude(const Q: TQuaternion): Single;
procedure NormalizeQuaternion(var Q: TQuaternion);
function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;
procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);
function QuaternionFromMatrix(const mat: TGLMatrix): TQuaternion;
function QuaternionToMatrix(quat: TQuaternion): TGLMatrix;
function QuaternionToAffineMatrix(quat: TQuaternion): TAffineMatrix;
function QuaternionFromAngleAxis(const angle: Single; const axis: TAffineVector): TQuaternion;
function QuaternionFromRollPitchYaw(const r, p, Y: Single): TQuaternion;
function QuaternionFromEuler(const X, Y, Z: Single; eulerOrder: TEulerOrder): TQuaternion;
function QuaternionMultiply(const qL, qR: TQuaternion): TQuaternion;
function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; T: Single): TQuaternion; overload;
function QuaternionSlerp(const source, dest: TQuaternion; const T: Single): TQuaternion; overload;
function Logarithm2(const X: Single): Single; inline;
function PowerSingle(const Base, Exponent: Single): Single; overload;
function PowerInteger(Base: Single; Exponent: Integer): Single; overload;
function PowerInt64(Base: Single; Exponent: Int64): Single; overload;
function DegToRadian(const Degrees: Extended): Extended; overload;
function DegToRadian(const Degrees: Single): Single; overload;
function RadianToDeg(const Radians: Extended): Extended; overload;
function RadianToDeg(const Radians: Single): Single; overload;
function NormalizeAngle(angle: Single): Single;
function NormalizeDegAngle(angle: Single): Single;
procedure SinCosine(const Theta: Double; out Sin, Cos: Double); overload;
procedure SinCosine(const Theta: Single; out Sin, Cos: Single); overload;
procedure SinCosine(const Theta, radius: Double; out Sin, Cos: Double); overload;
procedure SinCosine(const Theta, radius: Single; out Sin, Cos: Single); overload;
procedure PrepareSinCosCache(var S, c: array of Single; startAngle, stopAngle: Single);
function ArcCosine(const X: Extended): Extended; overload;
function FastArcTangent2(Y, X: Single): Single;
function RSqrt(V: Single): Single;
function RLength(X, Y: Single): Single;
function ISqrt(i: Integer): Integer;
function ILength(X, Y: Integer): Integer; overload;
function ILength(X, Y, Z: Integer): Integer; overload;
procedure RandomPointOnSphere(var p: TAffineVector);
function RoundInt(V: Single): Single; overload;
function RoundInt(V: Extended): Extended; overload;
function ScaleAndRound(i: Integer; var S: Single): Integer;
function SignStrict(X: Single): Integer;
function IsInRange(const X, a, b: Single): Boolean; overload;
function IsInRange(const X, a, b: Double): Boolean; overload;
function IsInCube(const p, d: TAffineVector): Boolean; overload;
function IsInCube(const p, d: TGLVector): Boolean; overload;
function MinFloat(values: PSingleArray; nbItems: Integer): Single; overload;
function MinFloat(values: PDoubleArray; nbItems: Integer): Double; overload;
function MinFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;
function MinFloat(const V1, V2: Single): Single; overload;
function MinFloat(const V: array of Single): Single; overload;
function MinFloat(const V1, V2: Double): Double; overload;
function MinFloat(const V1, V2, V3: Single): Single; overload;
function MinFloat(const V1, V2, V3: Double): Double; overload;
function MaxFloat(values: PSingleArray; nbItems: Integer): Single; overload;
function MaxFloat(values: PDoubleArray; nbItems: Integer): Double; overload;
function MaxFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;
function MaxFloat(const V: array of Single): Single; overload;
function MaxFloat(const V1, V2: Single): Single; overload;
function MaxFloat(const V1, V2: Double): Double; overload;
function MaxFloat(const V1, V2, V3: Single): Single; overload;
function MaxFloat(const V1, V2, V3: Double): Double; overload;
function MinInteger(const V1, V2: Integer): Integer; overload;
function MinInteger(const V1, V2: Cardinal): Cardinal; overload;
function MinInteger(const V1, V2, V3: Integer): Integer; overload;
function MinInteger(const V1, V2, V3: Cardinal): Cardinal; overload;
function MaxInteger(const V1, V2: Integer): Integer; overload;
function MaxInteger(const V1, V2: Cardinal): Cardinal; overload;
function MaxInteger(const V1, V2, V3: Integer): Integer; overload;
function MaxInteger(const V1, V2, V3: Cardinal): Cardinal; overload;
function ClampInteger(const value, min, max: Integer): Integer; overload; inline;
function ClampInteger(const value, min, max: Cardinal): Cardinal; overload; inline;
function TriangleArea(const p1, p2, p3: TAffineVector): Single; overload;
function PolygonArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;
function TriangleSignedArea(const p1, p2, p3: TAffineVector): Single; overload;
function PolygonSignedArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;
procedure ScaleFloatArray(values: PSingleArray; nb: Integer; var factor: Single); overload;
procedure ScaleFloatArray(var values: TSingleArray; factor: Single); overload;
procedure OffsetFloatArray(values: PSingleArray; nb: Integer; var delta: Single); overload;
procedure OffsetFloatArray(var values: array of Single; delta: Single); overload;
procedure OffsetFloatArray(valuesDest, valuesDelta: PSingleArray; nb: Integer); overload;
function MaxXYZComponent(const V: TGLVector): Single; overload;
function MaxXYZComponent(const V: TAffineVector): Single; overload;
function MinXYZComponent(const V: TGLVector): Single; overload;
function MinXYZComponent(const V: TAffineVector): Single; overload;
function MaxAbsXYZComponent(V: TGLVector): Single;
function MinAbsXYZComponent(V: TGLVector): Single;
procedure MaxVector(var V: TGLVector; const V1: TGLVector); overload;
procedure MaxVector(var V: TAffineVector; const V1: TAffineVector); overload;
procedure MinVector(var V: TGLVector; const V1: TGLVector); overload;
procedure MinVector(var V: TAffineVector; const V1: TAffineVector); overload;
procedure SortArrayAscending(var a: array of Extended);
function ClampValue(const aValue, aMin, aMax: Single): Single; overload;
function ClampValue(const aValue, aMin: Single): Single; overload;
function GeometryOptimizationMode: String;
procedure BeginFPUOnlySection;
procedure EndFPUOnlySection;
function ConvertRotation(const Angles: TAffineVector): TGLVector;
function MakeAffineDblVector(var V: array of Double): TAffineDblVector;
function MakeDblVector(var V: array of Double): THomogeneousDblVector;
function VectorAffineDblToFlt(const V: TAffineDblVector): TAffineVector;
function VectorDblToFlt(const V: THomogeneousDblVector): THomogeneousVector;
function VectorAffineFltToDbl(const V: TAffineVector): TAffineDblVector;
function VectorFltToDbl(const V: TGLVector): THomogeneousDblVector;
function PointInPolygon(const xp, yp: array of Single; X, Y: Single): Boolean;
function IsPointInPolygon(const Polygon: array of TPoint; const p: TPoint): Boolean;
procedure DivMod(Dividend: Integer; Divisor: Word; var result, Remainder: Word);
function Turn(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Turn(const Matrix: TGLMatrix; const MasterUp: TAffineVector; Angle: Single): TGLMatrix; overload;
function Pitch(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Pitch(const Matrix: TGLMatrix; const MasterRight: TAffineVector; Angle: Single): TGLMatrix; overload;
function Roll(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;
function Roll(const Matrix: TGLMatrix; const MasterDirection: TAffineVector; Angle: Single): TGLMatrix; overload;
function IntersectLinePlane(const point, direction: TGLVector; const plane: THmgPlane; intersectPoint: PGLVector = nil): Integer; overload;
function IntersectTriangleBox(const p1, p2, p3, aMinExtent, aMaxExtent: TAffineVector): Boolean;
function IntersectSphereBox(const SpherePos: TGLVector; const SphereRadius: Single; const BoxMatrix: TGLMatrix; const BoxScale: TAffineVector; intersectPoint: PAffineVector = nil; normal: PAffineVector = nil; depth: PSingle = nil): Boolean;
function RayCastPlaneIntersect(const rayStart, rayVector: TGLVector; const planePoint, planeNormal: TGLVector; intersectPoint: PGLVector = nil): Boolean; overload;
function RayCastPlaneXZIntersect(const rayStart, rayVector: TGLVector; const planeY: Single; intersectPoint: PGLVector = nil): Boolean; overload;
function RayCastTriangleIntersect(const rayStart, rayVector: TGLVector; const p1, p2, p3: TAffineVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;
function RayCastMinDistToPoint(const rayStart, rayVector: TGLVector; const point: TGLVector): Single;
function RayCastIntersectsSphere(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single): Boolean; overload;
function RayCastSphereIntersect(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single; var i1, i2: TGLVector): Integer; overload;
function RayCastBoxIntersect(const rayStart, rayVector, aMinExtent, aMaxExtent: TAffineVector; intersectPoint: PAffineVector = nil): Boolean;
function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;
function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;
function SphereVisibleRadius(distance, radius: Single): Single;
function ExtractFrustumFromModelViewProjection(const modelViewProj: TGLMatrix): TFrustum;
function IsVolumeClipped(const objPos: TAffineVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload;
function IsVolumeClipped(const objPos: TGLVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload; inline;
function IsVolumeClipped(const min, max: TAffineVector; const Frustum: TFrustum): Boolean; overload; inline;
function MakeParallelProjectionMatrix(const plane: THmgPlane; const dir: TGLVector): TGLMatrix;
function MakeShadowMatrix(const planePoint, planeNormal, lightPos: TGLVector): TGLMatrix;
function MakeReflectionMatrix(const planePoint, planeNormal: TAffineVector): TGLMatrix;
function PackRotationMatrix(const mat: TGLMatrix): TPackedRotationMatrix;
function UnPackRotationMatrix(const packedMatrix: TPackedRotationMatrix): TGLMatrix;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TGLVector): TVector2f; overload;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;
function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TGLVector; pitchDelta, turnDelta: Single): TGLVector;
function AngleBetweenVectors(const a, b, ACenterPoint: TGLVector): Single; overload;
function AngleBetweenVectors(const a, b, ACenterPoint: TAffineVector): Single; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TGLVector; const ACenter: TGLVector; const ADistance: Single; const AFromCenterSpot: Boolean): TGLVector; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

Types

PAffineByteVector = ˆTAffineByteVector;
PAffineDblVector = ˆTAffineDblVector;
PAffineExtVector = ˆTAffineExtVector;
PAffineFltVector = ˆTAffineFltVector;
PAffineIntVector = ˆTAffineIntVector;
PAffineMatrix = ˆTAffineMatrix;
PAffinePtrVector = ˆTAffinePtrVector;
PAffineVector = ˆTAffineVector;
PAffineVectorArray = ˆTAffineVectorArray;
PAffineWordVector = ˆTAffineWordVector;
PByteArray = PByteVector;
PByteVector = ˆTByteVector;
PCardinalArray = PCardinalVector;
PCardinalVector = ˆTCardinalVector;
PDoubleArray = PDoubleVector;
PDoubleVector = ˆTDoubleVector;
PExtendedArray = PExtendedVector;
PExtendedVector = ˆTExtendedVector;
PFloat = PSingle;
PFloatArray = PFloatVector;
PFloatVector = ˆTFloatVector;
PFrustum = ˆTFrustum;
PHomogeneousByteVector = ˆTHomogeneousByteVector;
PHomogeneousDblVector = ˆTHomogeneousDblVector;
PHomogeneousExtVector = ˆTHomogeneousExtVector;
PHomogeneousFltVector = ˆTHomogeneousFltVector;
PHomogeneousIntVector = ˆTHomogeneousIntVector;
PHomogeneousMatrix = ˆTHomogeneousMatrix;
PHomogeneousPtrVector = ˆTHomogeneousPtrVector;
PHomogeneousVector = ˆTHomogeneousVector;
PHomogeneousWordVector = ˆTHomogeneousWordVector;
PIntegerArray = PIntegerVector;
PIntegerVector = ˆTIntegerVector;
PLongWordArray = PLongWordVector;
PLongWordVector = ˆTLongWordVector;
PMatrixArray = ˆTMatrixArray;
PPointerArray = PPointerVector;
PPointerVector = ˆTPointerVector;
PQuaternion = ˆTQuaternion;
PQuaternionArray = ˆTQuaternionArray;
PSingleArray = PFloatArray;
PTexPoint = ˆTTexPoint;
PTexPointArray = ˆTTexPointArray;
PVector2f = ˆTVector2f;
PVectorArray = ˆTVectorArray;
PVertex = ˆTVertex;
PWordVector = ˆTWordVector;
TAffineByteMatrix = TMatrix3b;
TAffineByteVector = TVector3b;
TAffineDblMatrix = TMatrix3d;
TAffineDblVector = TVector3d;
TAffineExtMatrix = array [0 .. 2] of TAffineExtVector;
TAffineExtVector = TVector3e;
TAffineFltMatrix = TMatrix3f;
TAffineFltVector = TVector3f;
TAffineIntMatrix = TMatrix3i;
TAffineIntVector = TVector3i;
TAffineMatrix = TAffineFltMatrix;
TAffinePtrVector = TVector3p;
TAffineVector = TVector3f;
TAffineVectorArray = array [0 .. MaxInt shr 4] of TAffineVector;
TAffineWordMatrix = array [0 .. 2] of TAffineWordVector;
TAffineWordVector = TVector3w;
TByteVector = array [0 .. cMaxArray] of Byte;
TCardinalVector = array [0 .. cMaxArray] of Cardinal;
TDoubleHmgPlane = THomogeneousDblVector;
TDoubleVector = array [0 .. cMaxArray] of Double;
TEulerOrder = (...);
TExtendedVector = array [0 .. cMaxArray] of Extended;
TFloatVector = array [0 .. cMaxArray] of Single;
TGLInterpolationType = (...);
THmgPlane = TGLVector;
THomogeneousByteMatrix = TMatrix4b;
THomogeneousByteVector = TVector4b;
THomogeneousDblMatrix = TMatrix4d;
THomogeneousDblVector = TVector4d;
THomogeneousExtMatrix = array [0 .. 3] of THomogeneousExtVector;
THomogeneousExtVector = TVector4e;
THomogeneousFltMatrix = TMatrix4f;
THomogeneousFltVector = TVector4f;
THomogeneousIntMatrix = TMatrix4i;
THomogeneousIntVector = TVector4i;
THomogeneousMatrix = THomogeneousFltMatrix;
THomogeneousPtrVector = TVector4p;
THomogeneousVector = THomogeneousFltVector;
THomogeneousWordMatrix = array [0 .. 3] of THomogeneousWordVector;
THomogeneousWordVector = TVector4w;
TIntegerVector = array [0 .. cMaxArray] of Integer;
TLongWordVector = array [0 .. cMaxArray] of LongWord;
TMatrixArray = array [0 .. MaxInt shr 7] of TGLMatrix;
TPackedRotationMatrix = array [0 .. 2] of SmallInt;
TPointerVector = array [0 .. cMaxArray] of Pointer;
TQuaternionArray = array [0 .. MaxInt shr 5] of TQuaternion;
TSingleArray = array of Single;
TTexPointArray = array [0 .. MaxInt shr 4] of TTexPoint;
TTransformations = array [TTransType] of Single;
TTransType = (...);
TVectorArray = array [0 .. MaxInt shr 5] of TGLVector;
TVertex = TAffineVector;
TWordVector = array [0 .. cMaxArray] of Word;

Constants

cMaxArray = (MaxInt shr 4);
cColinearBias = 1E-8;
XTexPoint: TTexPoint = (S: 1; T: 0);
YTexPoint: TTexPoint = (S: 0; T: 1);
XYTexPoint: TTexPoint = (S: 1; T: 1);
NullTexPoint: TTexPoint = (S: 0; T: 0);
MidTexPoint: TTexPoint = (S: 0.5; T: 0.5);
XVector: TAffineVector = (X: 1; Y: 0; Z: 0);
YVector: TAffineVector = (X: 0; Y: 1; Z: 0);
ZVector: TAffineVector = (X: 0; Y: 0; Z: 1);
XYVector: TAffineVector = (X: 1; Y: 1; Z: 0);
XZVector: TAffineVector = (X: 1; Y: 0; Z: 1);
YZVector: TAffineVector = (X: 0; Y: 1; Z: 1);
XYZVector: TAffineVector = (X: 1; Y: 1; Z: 1);
NullVector: TAffineVector = (X: 0; Y: 0; Z: 0);
MinusXVector: TAffineVector = (X: - 1; Y: 0; Z: 0);
MinusYVector: TAffineVector = (X: 0; Y: - 1; Z: 0);
MinusZVector: TAffineVector = (X: 0; Y: 0; Z: - 1);
XHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 0);
YHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 0);
ZHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 0);
WHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
XYHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 0; W: 0);
YZHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 1; W: 0);
XZHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 1; W: 0);
XYZHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 0);
XYZWHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 1);
NullHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 0);
XHmgPoint: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 1);
YHmgPoint: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 1);
ZHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 1);
WHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
NullHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);
IdentityMatrix: TAffineMatrix = (V: ((X: 1; Y: 0; Z: 0), (X: 0; Y: 1; Z: 0), (X: 0; Y: 0; Z: 1)));
IdentityHmgMatrix: TGLMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));
IdentityHmgDblMatrix: THomogeneousDblMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));
EmptyMatrix: TAffineMatrix = (V: ((X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0)));
EmptyHmgMatrix: TGLMatrix = (V: ((X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0)));
IdentityQuaternion: TQuaternion = (ImagPart: (X: 0; Y: 0; Z: 0); RealPart: 1);
EPSILON: Single = 1E-40;
EPSILON2: Single = 1E-30;
cPI: Single = 3.141592654;
cPIdiv180: Single = 0.017453292;
c180divPI: Single = 57.29577951;
c2PI: Single = 6.283185307;
cPIdiv2: Single = 1.570796326;
cPIdiv4: Single = 0.785398163;
c3PIdiv2: Single = 4.71238898;
c3PIdiv4: Single = 2.35619449;
cInv2PI: Single = 1 / 6.283185307;
cInv360: Single = 1 / 360;
c180: Single = 180;
c360: Single = 360;
cOneHalf: Single = 0.5;
cLn10: Single = 2.302585093;
MinSingle = 1.5E-45;
MaxSingle = 3.4E+38;
MinDouble = 5.0E-324;
MaxDouble = 1.7E+308;
MinExtended = 3.4E-4932;
MaxExtended = MaxDouble;
MinComp = -9.223372036854775807E+18;
MaxComp = 9.223372036854775807E+18;

Variables

vSIMD: Byte = 0;

Description

Functions and Procedures

function TexPointMake(const S, T: Single): TTexPoint; inline;

————————————————————————– Vector functions ————————————————————————–

function AffineVectorMake(const X, Y, Z: Single): TAffineVector; overload; inline;

This item has no description.

function AffineVectorMake(const V: TGLVector): TAffineVector; overload; inline;

This item has no description.

procedure SetAffineVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const vSrc: TGLVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineVector; const vSrc: TAffineVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineDblVector; const vSrc: TAffineVector); overload; inline;

This item has no description.

procedure SetVector(out V: TAffineDblVector; const vSrc: TGLVector); overload; inline;

This item has no description.

function VectorMake(const V: TAffineVector; W: Single = 0): TGLVector; overload; inline;

This item has no description.

function VectorMake(const X, Y, Z: Single; W: Single = 0): TGLVector; overload; inline;

This item has no description.

function VectorMake(const Q: TQuaternion): TGLVector; overload; inline;

This item has no description.

function PointMake(const X, Y, Z: Single): TGLVector; overload; inline;

This item has no description.

function PointMake(const V: TAffineVector): TGLVector; overload; inline;

This item has no description.

function PointMake(const V: TGLVector): TGLVector; overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const X, Y, Z: Single; W: Single = 0); overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const av: TAffineVector; W: Single = 0); overload; inline;

This item has no description.

procedure SetVector(out V: TGLVector; const vSrc: TGLVector); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const av: TAffineVector); overload; inline;

This item has no description.

procedure MakePoint(out V: TGLVector; const av: TGLVector); overload; inline;

This item has no description.

procedure MakeVector(out V: TAffineVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const X, Y, Z: Single); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const av: TAffineVector); overload; inline;

This item has no description.

procedure MakeVector(out V: TGLVector; const av: TGLVector); overload; inline;

This item has no description.

procedure RstVector(var V: TAffineVector); overload; inline;

This item has no description.

procedure RstVector(var V: TGLVector); overload; inline;

This item has no description.

function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload; inline;

This item has no description.

function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector2b): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3i): Boolean; overload; inline;

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further

function VectorEquals(const V1, V2: TVector3d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector3b): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4i): Boolean; overload; inline;

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further

function VectorEquals(const V1, V2: TVector4d): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4s): Boolean; overload; inline;

This item has no description.

function VectorEquals(const V1, V2: TVector4b): Boolean; overload; inline;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;

3x3

function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;

4x4

function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;

This item has no description.

function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;

This item has no description.

function Vector2fMake(const X, Y: Single): TVector2f; overload; inline;

2x

function Vector2iMake(const X, Y: Longint): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const X, Y: SmallInt): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const X, Y: Double): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const X, Y: Byte): TVector2b; overload; inline;

This item has no description.

function Vector2fMake(const Vector: TVector3f): TVector2f; overload; inline;

This item has no description.

function Vector2iMake(const Vector: TVector3i): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const Vector: TVector3s): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const Vector: TVector3d): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const Vector: TVector3b): TVector2b; overload; inline;

This item has no description.

function Vector2fMake(const Vector: TVector4f): TVector2f; overload; inline;

This item has no description.

function Vector2iMake(const Vector: TVector4i): TVector2i; overload; inline;

This item has no description.

function Vector2sMake(const Vector: TVector4s): TVector2s; overload; inline;

This item has no description.

function Vector2dMake(const Vector: TVector4d): TVector2d; overload; inline;

This item has no description.

function Vector2bMake(const Vector: TVector4b): TVector2b; overload; inline;

This item has no description.

function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0) : TVector3f; overload; inline;

3x

function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload; inline;

This item has no description.

function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload; inline;

This item has no description.

function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const Vector: TVector2s; const Z: SmallInt = 0): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload; inline;

This item has no description.

function Vector3fMake(const Vector: TVector4f): TVector3f; overload; inline;

This item has no description.

function Vector3iMake(const Vector: TVector4i): TVector3i; overload; inline;

This item has no description.

function Vector3sMake(const Vector: TVector4s): TVector3s; overload; inline;

This item has no description.

function Vector3dMake(const Vector: TVector4d): TVector3d; overload; inline;

This item has no description.

function Vector3bMake(const Vector: TVector4b): TVector3b; overload; inline;

This item has no description.

function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;

4x

function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const X: SmallInt; const Y: SmallInt = 0; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload; inline;

This item has no description.

function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const Vector: TVector3s; const W: SmallInt = 0) : TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload; inline;

This item has no description.

function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload; inline;

This item has no description.

function Vector4sMake(const Vector: TVector2s; const Z: SmallInt = 0; const W: SmallInt = 0): TVector4s; overload; inline;

This item has no description.

function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload; inline;

This item has no description.

function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload; inline;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

Vector comparison functions: 3f

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

4f

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

3i

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

4i

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

3s

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

4s

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

ComparedNumber 3f

function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

4f

function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

3i

function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

4i

function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

3s

function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

4s

function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;

This item has no description.

function VectorAdd(const V1, V2: TVector2f): TVector2f; overload;

This item has no description.

function VectorAdd(const V1, V2: TAffineVector): TAffineVector; overload;

Returns the sum of two affine vectors

procedure VectorAdd(const V1, V2: TAffineVector; var vr: TAffineVector); overload;

Adds two vectors and places result in vr

procedure VectorAdd(const V1, V2: TAffineVector; vr: PAffineVector); overload;

This item has no description.

function VectorAdd(const V1, V2: TGLVector): TGLVector; overload;

Returns the sum of two homogeneous vectors

procedure VectorAdd(const V1, V2: TGLVector; var vr: TGLVector); overload;

This item has no description.

function VectorAdd(const V: TAffineVector; const f: Single): TAffineVector; overload; inline;

Sums up f to each component of the vector

function VectorAdd(const V: TGLVector; const f: Single): TGLVector; overload; inline;

Sums up f to each component of the vector

procedure AddVector(var V1: TAffineVector; const V2: TAffineVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V1: TAffineVector; const V2: TGLVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V1: TGLVector; const V2: TGLVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var V: TAffineVector; const f: Single); overload; inline;

Sums up f to each component of the vector

procedure AddVector(var V: TGLVector; const f: Single); overload; inline;

Sums up f to each component of the vector

procedure AddPoint(var V1: TGLVector; const V2: TGLVector); overload; inline;

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

function PointAdd(var V1: TGLVector; const V2: TGLVector): TGLVector; overload; inline;

Returns the sum of two homogeneous vectors. W coordinate is always 1.

procedure TexPointArrayAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; dest: PTexPointArray); overload;

Adds delta to nb texpoints in src and places result in dest

procedure TexPointArrayScaleAndAdd(const src: PTexPointArray; const delta: TTexPoint; const nb: Integer; const scale: TTexPoint; dest: PTexPointArray); overload;

This item has no description.

procedure VectorArrayAdd(const src: PAffineVectorArray; const delta: TAffineVector; const nb: Integer; dest: PAffineVectorArray); overload;

Adds delta to nb vectors in src and places result in dest

function VectorSubtract(const V1, V2: TVector2f): TVector2f; overload;

Returns V1-V2

procedure SubtractVector(var V1: TVector2f; const V2: TVector2f); overload;

Subtracts V2 from V1, result is placed in V1

function VectorSubtract(const V1, V2: TAffineVector): TAffineVector; overload;

Returns V1-V2

procedure VectorSubtract(const V1, V2: TAffineVector; var result: TAffineVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1, V2: TAffineVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1: TGLVector; const V2: TAffineVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const V1, V2: TGLVector): TGLVector; overload;

Returns V1-V2

procedure VectorSubtract(const V1, V2: TGLVector; var result: TGLVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const V1, V2: TGLVector; var result: TAffineVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const V1: TAffineVector; delta: Single): TAffineVector; overload; inline;

This item has no description.

function VectorSubtract(const V1: TGLVector; delta: Single): TGLVector; overload; inline;

This item has no description.

procedure SubtractVector(var V1: TAffineVector; const V2: TAffineVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure SubtractVector(var V1: TGLVector; const V2: TGLVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr: TAffineVector; const V: TAffineVector; pf: PFloat); overload;

This item has no description.

function TexPointCombine(const t1, t2: TTexPoint; f1, f2: Single): TTexPoint; inline;

Makes a linear combination of two texpoints

function VectorCombine(const V1, V2: TAffineVector; const f1, f2: Single): TAffineVector; overload; inline;

Makes a linear combination of two vectors and return the result

function VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single): TAffineVector; overload; inline;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TAffineVector; const f1, f2, F3: Single; var vr: TAffineVector); overload; inline;

This item has no description.

procedure CombineVector(var vr: TGLVector; const V: TGLVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr: TGLVector; const V: TAffineVector; var f: Single); overload;

Combine the first vector with the second : vr:=vr+v*f

function VectorCombine(const V1, V2: TGLVector; const F1, F2: Single): TGLVector; overload; inline;

Makes a linear combination of two vectors and return the result

function VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single): TGLVector; overload; inline;

Makes a linear combination of two vectors and return the result

procedure VectorCombine(const V1: TGLVector; const V2: TAffineVector; const F1, F2: Single; var VR: TGLVector); overload; inline;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TGLVector; const F1, F2: Single; var vr: TGLVector); overload;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TGLVector; const F2: Single; var vr: TGLVector); overload;

Makes a linear combination of two vectors and place result in vr, F1=1.0

function VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single): TGLVector; overload; inline;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TGLVector; const F1, F2, F3: Single; var vr: TGLVector); overload;

Makes a linear combination of three vectors and return the result

function VectorDotProduct(const V1, V2: TVector2f): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

function VectorDotProduct(const V1, V2: TAffineVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1, V2: TGLVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1: TGLVector; const V2: TAffineVector): Single; overload;

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function PointProject(const p, origin, direction: TAffineVector): Single; overload;

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line

function PointProject(const p, origin, direction: TGLVector): Single; overload;

This item has no description.

function VectorCrossProduct(const V1, V2: TAffineVector): TAffineVector; overload;

Calculates the cross product between vector 1 and 2

function VectorCrossProduct(const V1, V2: TGLVector): TGLVector; overload;

Calculates the cross product between vector 1 and 2

procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TGLVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TGLVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TGLVector; var vr: TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const V1, V2: TAffineVector; var vr: TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

function Lerp(const start, stop, T: Single): Single; inline;

Calculates linear interpolation between start and stop at point t

function AngleLerp(start, stop, T: Single): Single; inline;

Calculates angular interpolation between start and stop at point t

function MatrixLerp(const m1, m2: TGLMatrix; const delta: Single): TGLMatrix;

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

function DistanceBetweenAngles(angle1, angle2: Single): Single;

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.

function TexPointLerp(const t1, t2: TTexPoint; T: Single): TTexPoint; overload; inline;

Calculates linear interpolation between texpoint1 and texpoint2 at point t

function VectorLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const V1, V2: TAffineVector; T: Single; var vr: TAffineVector); overload;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorLerp(const V1, V2: TGLVector; T: Single): TGLVector; overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const V1, V2: TGLVector; T: Single; var vr: TGLVector); overload; inline;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorAngleLerp(const V1, V2: TAffineVector; T: Single): TAffineVector; overload;

This item has no description.

function VectorAngleCombine(const V1, V2: TAffineVector; f: Single): TAffineVector; overload;

This item has no description.

procedure VectorArrayLerp(const src1, src2: PVectorArray; T: Single; n: Integer; dest: PVectorArray); overload;

Calculates linear interpolation between vector arrays

procedure VectorArrayLerp(const src1, src2: PAffineVectorArray; T: Single; n: Integer; dest: PAffineVectorArray); overload;

This item has no description.

procedure VectorArrayLerp(const src1, src2: PTexPointArray; T: Single; n: Integer; dest: PTexPointArray); overload;

This item has no description.

function InterpolatePower(const start, stop, delta: Single; const DistortionDegree: Single): Single;

There functions that do the same as "Lerp", but add some distortions

function InterpolateLn(const start, stop, delta: Single; const DistortionDegree: Single): Single;

This item has no description.

function InterpolateExp(const start, stop, delta: Single; const DistortionDegree: Single): Single;

This item has no description.

function InterpolateSin(const start, stop, delta: Single): Single;

Only valid where Delta belongs to [0..1]

function InterpolateTan(const start, stop, delta: Single): Single;

This item has no description.

function InterpolateSinAlt(const start, stop, delta: Single): Single;

"Alt" functions are valid everywhere

function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single; inline;

This item has no description.

function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function InterpolateCombined(const start, stop, delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single; inline;

This item has no description.

function VectorLength(const X, Y: Single): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const X, Y, Z: Single): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const V: TVector2f): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const V: TAffineVector): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const V: TGLVector): Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

function VectorLength(const V: array of Single): Single; overload;

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

function VectorNorm(const X, Y: Single): Single; overload;

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const V: TAffineVector): Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const V: TGLVector): Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(var V: array of Single): Single; overload;

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).

procedure NormalizeVector(var V: TVector2f); overload;

Transforms a vector to unit length

procedure NormalizeVector(var V: TAffineVector); overload;

Returns the vector transformed to unit length Transforms a vector to unit length

procedure NormalizeVector(var V: TGLVector); overload;

Transforms a vector to unit length

function VectorNormalize(const V: TVector2f): TVector2f; overload;

Returns the vector transformed to unit length

function VectorNormalize(const V: TAffineVector): TAffineVector; overload;

Returns the vector transformed to unit length

function VectorNormalize(const V: TGLVector): TGLVector; overload;

Returns the vector transformed to unit length (w component dropped)

procedure NormalizeVectorArray(list: PAffineVectorArray; n: Integer); overload; inline;

Transforms vectors to unit length

function VectorAngleCosine(const V1, V2: TAffineVector): Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorAngleCosine(const V1, V2: TGLVector): Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorNegate(const Vector: TAffineVector): TAffineVector; overload;

Negates the vector

function VectorNegate(const Vector: TGLVector): TGLVector; overload;

This item has no description.

procedure NegateVector(var V: TAffineVector); overload;

Negates the vector

procedure NegateVector(var V: TGLVector); overload;

Negates the vector

procedure NegateVector(var V: array of Single); overload;

Negates the vector

procedure ScaleVector(var V: TVector2f; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TAffineVector; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TAffineVector; const factor: TAffineVector); overload;

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

procedure ScaleVector(var V: TGLVector; factor: Single); overload;

Scales given vector by a factor

procedure ScaleVector(var V: TGLVector; const factor: TGLVector); overload;

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

function VectorScale(const V: TVector2f; factor: Single): TVector2f; overload;

Returns a vector scaled by a factor

function VectorScale(const V: TAffineVector; factor: Single): TAffineVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const V: TAffineVector; factor: Single; var vr: TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const V: TGLVector; factor: Single): TGLVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const V: TGLVector; factor: Single; var vr: TGLVector); overload;

Scales a vector by a factor and places result in vr

procedure VectorScale(const V: TGLVector; factor: Single; var vr: TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const V: TAffineVector; const factor: TAffineVector): TAffineVector; overload;

Scales given vector by another vector

function VectorScale(const V: TGLVector; const factor: TGLVector): TGLVector; overload;

RScales given vector by another vector

procedure DivideVector(var V: TGLVector; const divider: TGLVector); overload; inline;

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

procedure DivideVector(var V: TAffineVector; const divider: TAffineVector); overload; inline;

This item has no description.

function VectorDivide(const V: TGLVector; const divider: TGLVector): TGLVector; overload; inline;

This item has no description.

function VectorDivide(const V: TAffineVector; const divider: TAffineVector): TAffineVector; overload; inline;

This item has no description.

function TexpointEquals(const p1, p2: TTexPoint): Boolean; inline;

True if all components are equal.

function RectEquals(const Rect1, Rect2: TRect): Boolean; inline;

True if all components are equal.

function VectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;

True if all components are equal.

function VectorEquals(const V1, V2: TAffineVector): Boolean; overload; inline;

True if all components are equal.

function AffineVectorEquals(const V1, V2: TGLVector): Boolean; overload; inline;

True if X, Y and Z components are equal.

function VectorIsNull(const V: TGLVector): Boolean; overload; inline;

True if x=y=z=0, w ignored

function VectorIsNull(const V: TAffineVector): Boolean; overload; inline;

True if x=y=z=0, w ignored

function VectorSpacing(const V1, V2: TTexPoint): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".

function VectorSpacing(const V1, V2: TAffineVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

function VectorSpacing(const V1, V2: TGLVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

function VectorDistance(const V1, V2: TAffineVector): Single; overload;

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)

function VectorDistance(const V1, V2: TGLVector): Single; overload;

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

function VectorDistance2(const V1, V2: TAffineVector): Single; overload;

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...

function VectorDistance2(const V1, V2: TGLVector): Single; overload;

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)

function VectorPerpendicular(const V, n: TAffineVector): TAffineVector;

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N

function VectorReflect(const V, n: TAffineVector): TAffineVector;

Reflects vector V against N (assumes N is normalized)

procedure RotateVector(var Vector: TGLVector; const axis: TAffineVector; angle: Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVector(var Vector: TGLVector; const axis: TGLVector; angle: Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVectorAroundY(var V: TAffineVector; alpha: Single);

Rotate given vector around the Y axis (alpha is in rad)

function VectorRotateAroundX(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the X axis (alpha is in rad)

function VectorRotateAroundY(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the Y axis (alpha is in rad)

procedure VectorRotateAroundY(const V: TAffineVector; alpha: Single; var vr: TAffineVector); overload;

Returns given vector rotated around the Y axis in vr (alpha is in rad)

function VectorRotateAroundZ(const V: TAffineVector; alpha: Single): TAffineVector; overload;

Returns given vector rotated around the Z axis (alpha is in rad)

procedure AbsVector(var V: TGLVector); overload; inline;

Vector components are replaced by their Abs() value. }

procedure AbsVector(var V: TAffineVector); overload; inline;

Vector components are replaced by their Abs() value. }

function VectorAbs(const V: TGLVector): TGLVector; overload; inline;

Returns a vector with components replaced by their Abs value. }

function VectorAbs(const V: TAffineVector): TAffineVector; overload; inline;

Returns a vector with components replaced by their Abs value. }

function IsColinear(const V1, V2: TVector2f): Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const V1, V2: TAffineVector): Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const V1, V2: TGLVector): Boolean; overload;

Returns true if both vector are colinear

procedure SetMatrix(var dest: THomogeneousDblMatrix; const src: TGLMatrix); overload;

—————————————————————————- Matrix functions —————————————————————————-

procedure SetMatrix(var dest: TAffineMatrix; const src: TGLMatrix); overload;

This item has no description.

procedure SetMatrix(var dest: TGLMatrix; const src: TAffineMatrix); overload;

This item has no description.

procedure SetMatrixRow(var dest: TGLMatrix; rowNb: Integer; const aRow: TGLVector); overload;

This item has no description.

function CreateScaleMatrix(const V: TAffineVector): TGLMatrix; overload;

Creates scale matrix

function CreateScaleMatrix(const V: TGLVector): TGLMatrix; overload;

Creates scale matrix

function CreateTranslationMatrix(const V: TAffineVector): TGLMatrix; overload;

Creates translation matrix

function CreateTranslationMatrix(const V: TGLVector): TGLMatrix; overload;

Creates translation matrix

function CreateScaleAndTranslationMatrix(const scale, offset: TGLVector): TGLMatrix; overload;

Creates a scale+translation matrix. Scale is applied BEFORE applying offset

function CreateRotationMatrixX(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about x-axis (angle in rad)

function CreateRotationMatrixX(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrixY(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about y-axis (angle in rad)

function CreateRotationMatrixY(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrixZ(const sine, cosine: Single): TGLMatrix; overload;

Creates matrix for rotation about z-axis (angle in rad)

function CreateRotationMatrixZ(const angle: Single): TGLMatrix; overload;

This item has no description.

function CreateRotationMatrix(const anAxis: TAffineVector; angle: Single): TGLMatrix; overload;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function CreateRotationMatrix(const anAxis: TGLVector; angle: Single): TGLMatrix; overload;

This item has no description.

function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function MatrixMultiply(const m1, m2: TAffineMatrix): TAffineMatrix; overload;

Multiplies two 3x3 matrices

function MatrixMultiply(const m1, m2: TGLMatrix): TGLMatrix; overload;

Multiplies two 4x4 matrices

procedure MatrixMultiply(const m1, m2: TGLMatrix; var MResult: TGLMatrix); overload;

Multiplies M1 by M2 and places result in MResult

function VectorTransform(const V: TGLVector; const M: TGLMatrix): TGLVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TGLVector; const M: TAffineMatrix): TGLVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TGLMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function MatrixDeterminant(const M: TAffineMatrix): Single; overload;

Determinant of a 3x3 matrix

function MatrixDeterminant(const M: TGLMatrix): Single; overload;

Determinant of a 4x4 matrix

procedure AdjointMatrix(var M: TGLMatrix); overload;

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix

procedure AdjointMatrix(var M: TAffineMatrix); overload;

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix

procedure ScaleMatrix(var M: TAffineMatrix; const factor: Single); overload;

Multiplies all elements of a 3x3 matrix with a factor

procedure ScaleMatrix(var M: TGLMatrix; const factor: Single); overload;

Multiplies all elements of a 4x4 matrix with a factor

procedure TranslateMatrix(var M: TGLMatrix; const V: TAffineVector); overload;

Adds the translation vector into the matrix

procedure TranslateMatrix(var M: TGLMatrix; const V: TGLVector); overload;

This item has no description.

procedure NormalizeMatrix(var M: TGLMatrix);

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

procedure TransposeMatrix(var M: TAffineMatrix); overload;

Computes transpose of 3x3 matrix

procedure TransposeMatrix(var M: TGLMatrix); overload;

Computes transpose of 4x4 matrix

procedure InvertMatrix(var M: TGLMatrix); overload;

Finds the inverse of a 4x4 matrix

function MatrixInvert(const M: TGLMatrix): TGLMatrix; overload;

This item has no description.

procedure InvertMatrix(var M: TAffineMatrix); overload;

Finds the inverse of a 3x3 matrix;

function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;

This item has no description.

function AnglePreservingMatrixInvert(const mat: TGLMatrix): TGLMatrix;

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

function MatrixDecompose(const M: TGLMatrix; var Tran: TTransformations): Boolean;

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.

function CreateLookAtMatrix(const eye, center, normUp: TGLVector): TGLMatrix;

This item has no description.

function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TGLMatrix;

This item has no description.

function CreatePickMatrix(X, Y, deltax, deltay: Single; const viewport: TVector4i): TGLMatrix;

This item has no description.

function Project(objectVector: TGLVector; const ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out WindowVector: TGLVector): Boolean;

This item has no description.

function UnProject(WindowVector: TGLVector; ViewProjMatrix: TGLMatrix; const viewport: TVector4i; out objectVector: TGLVector): Boolean;

This item has no description.

function PlaneMake(const p1, p2, p3: TAffineVector): THmgPlane; overload;

Computes the parameters of a plane defined by three points.

function PlaneMake(const p1, p2, p3: TGLVector): THmgPlane; overload;

This item has no description.

function PlaneMake(const point, normal: TAffineVector): THmgPlane; overload;

Computes the parameters of a plane defined by a point and a normal.

function PlaneMake(const point, normal: TGLVector): THmgPlane; overload;

This item has no description.

procedure SetPlane(var dest: TDoubleHmgPlane; const src: THmgPlane);

Converts from single to double representation

procedure NormalizePlane(var plane: THmgPlane);

Normalize a plane so that point evaluation = plane distance. }

function PlaneEvaluatePoint(const plane: THmgPlane; const point: TAffineVector): Single; overload;

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.

function PlaneEvaluatePoint(const plane: THmgPlane; const point: TGLVector): Single; overload;

This item has no description.

function CalcPlaneNormal(const p1, p2, p3: TAffineVector): TAffineVector; overload;

Calculate the normal of a plane defined by three points.

procedure CalcPlaneNormal(const p1, p2, p3: TAffineVector; var vr: TAffineVector); overload;

This item has no description.

procedure CalcPlaneNormal(const p1, p2, p3: TGLVector; var vr: TAffineVector); overload;

This item has no description.

function PointIsInHalfSpace(const point, planePoint, planeNormal: TGLVector): Boolean; overload;

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.

function PointIsInHalfSpace(const point, planePoint, planeNormal: TAffineVector): Boolean; overload;

This item has no description.

function PointIsInHalfSpace(const point: TAffineVector; const plane: THmgPlane): Boolean; overload;

This item has no description.

function PointPlaneDistance(const point, planePoint, planeNormal: TGLVector): Single; overload;

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

function PointPlaneDistance(const point, planePoint, planeNormal: TAffineVector): Single; overload;

This item has no description.

function PointPlaneDistance(const point: TAffineVector; const plane: THmgPlane): Single; overload;

This item has no description.

function PointPlaneOrthoProjection(const point: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to plane projection. Plane and direction have to be normalized

function PointPlaneProjection(const point, direction: TAffineVector; const plane: THmgPlane; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function SegmentPlaneIntersection(const ptA, ptB: TAffineVector; const plane: THmgPlane; var inter: TAffineVector): Boolean;

Computes segment / plane intersection return false if there isn't an intersection

function PointTriangleOrthoProjection(const point, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to triangle projection. Direction has to be normalized

function PointTriangleProjection(const point, direction, ptA, ptB, ptC: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC: TAffineVector): Boolean;

Returns true if line intersect ABC triangle

function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD: TAffineVector; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD: TAffineVector): Boolean;

Returns true if line intersect ABCD quad. Quad have to be flat and convex

function PointDiskOrthoProjection(const point, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;

Computes point to disk projection. Direction has to be normalized

function PointDiskProjection(const point, direction, center, up: TAffineVector; const radius: Single; var inter: TAffineVector; bothface: Boolean = True): Boolean;

This item has no description.

function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TAffineVector): TAffineVector; overload;

Computes closest point on a segment (a segment is a limited line)

function PointSegmentClosestPoint(const point, segmentStart, segmentStop: TGLVector): TGLVector; overload;

This item has no description.

function PointSegmentDistance(const point, segmentStart, segmentStop: TAffineVector): Single;

Computes algebraic distance between segment and line (a segment is a limited line)

function PointLineClosestPoint(const point, linePoint, lineDirection: TAffineVector): TAffineVector;

Computes closest point on a line

function PointLineDistance(const point, linePoint, lineDirection: TAffineVector): Single;

Computes algebraic distance between point and line

procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector; var Segment0Closest, Segment1Closest: TAffineVector);

Computes the closest points (2) given two segments

function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop: TAffineVector): Single;

Computes the closest distance between two segments

function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1: TAffineVector): Single;

Computes the closest distance between two lines

function QuaternionMake(const Imag: array of Single; Real: Single): TQuaternion; overload;

Creates a quaternion from the given values

function QuaternionMake(const X,Y,Z,W: Single): TQuaternion; overload;

This item has no description.

function QuaternionMake(const V: TGLVector): TQuaternion; overload;

This item has no description.

function QuaternionConjugate(const Q: TQuaternion): TQuaternion;

Returns the conjugate of a quaternion

function QuaternionMagnitude(const Q: TQuaternion): Single;

Returns the magnitude of the quaternion

procedure NormalizeQuaternion(var Q: TQuaternion);

Normalizes the given quaternion

function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;

Constructs a unit quaternion from two points on unit sphere

procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);

Converts a unit quaternion into two points on a unit sphere

function QuaternionFromMatrix(const mat: TGLMatrix): TQuaternion;

Constructs a unit quaternion from a rotation matrix

function QuaternionToMatrix(quat: TQuaternion): TGLMatrix;

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations

function QuaternionToAffineMatrix(quat: TQuaternion): TAffineMatrix;

Constructs an affine rotation matrix from (possibly non-unit) quaternion

function QuaternionFromAngleAxis(const angle: Single; const axis: TAffineVector): TQuaternion;

Constructs quaternion from angle (in deg) and axis

function QuaternionFromRollPitchYaw(const r, p, Y: Single): TQuaternion;

Constructs quaternion from Euler angles

function QuaternionFromEuler(const X, Y, Z: Single; eulerOrder: TEulerOrder): TQuaternion;

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

function QuaternionMultiply(const qL, qR: TQuaternion): TQuaternion;

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond

function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; T: Single): TQuaternion; overload;

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve

function QuaternionSlerp(const source, dest: TQuaternion; const T: Single): TQuaternion; overload;

This item has no description.

function Logarithm2(const X: Single): Single; inline;

—————————————————————————- Exponential functions —————————————————————————–

function PowerSingle(const Base, Exponent: Single): Single; overload;

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0

function PowerInteger(Base: Single; Exponent: Integer): Single; overload;

Raise base to an integer

function PowerInt64(Base: Single; Exponent: Int64): Single; overload;

This item has no description.

function DegToRadian(const Degrees: Extended): Extended; overload;

—————————————————————————- Trigonometric functions —————————————————————————-

function DegToRadian(const Degrees: Single): Single; overload;

This item has no description.

function RadianToDeg(const Radians: Extended): Extended; overload;

This item has no description.

function RadianToDeg(const Radians: Single): Single; overload;

This item has no description.

function NormalizeAngle(angle: Single): Single;

Normalize to an angle in the [-PI; +PI] range

function NormalizeDegAngle(angle: Single): Single;

Normalize to an angle in the [-180; 180] range

procedure SinCosine(const Theta: Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta

procedure SinCosine(const Theta: Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta

procedure SinCosine(const Theta, radius: Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

procedure SinCosine(const Theta, radius: Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

procedure PrepareSinCosCache(var S, c: array of Single; startAngle, stopAngle: Single);

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

function ArcCosine(const X: Extended): Extended; overload;

This item has no description.

function FastArcTangent2(Y, X: Single): Single;

Fast ArcTangent2 approximation, about 0.07 rads accuracy

function RSqrt(V: Single): Single;

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)

function RLength(X, Y: Single): Single;

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

function ISqrt(i: Integer): Integer;

Computes an integer sqrt approximation

function ILength(X, Y: Integer): Integer; overload;

Computes an integer length Result:=Sqrt(x*x+y*y)

function ILength(X, Y, Z: Integer): Integer; overload;

This item has no description.

procedure RandomPointOnSphere(var p: TAffineVector);

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction

function RoundInt(V: Single): Single; overload;

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.

function RoundInt(V: Extended): Extended; overload;

This item has no description.

function ScaleAndRound(i: Integer; var S: Single): Integer;

Multiples i by s and returns the rounded result.

function SignStrict(X: Single): Integer;

Returns the sign of the x value using the (-1, 0, +1) convention

function IsInRange(const X, a, b: Single): Boolean; overload;

Returns True if x is in [a; b]

function IsInRange(const X, a, b: Double): Boolean; overload;

This item has no description.

function IsInCube(const p, d: TAffineVector): Boolean; overload;

Returns True if p is in the cube defined by d.

function IsInCube(const p, d: TGLVector): Boolean; overload;

This item has no description.

function MinFloat(values: PSingleArray; nbItems: Integer): Single; overload;

Returns the minimum value of the array.

function MinFloat(values: PDoubleArray; nbItems: Integer): Double; overload;

This item has no description.

function MinFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;

This item has no description.

function MinFloat(const V1, V2: Single): Single; overload;

Returns the minimum of given values.

function MinFloat(const V: array of Single): Single; overload;

This item has no description.

function MinFloat(const V1, V2: Double): Double; overload;

This item has no description.

function MinFloat(const V1, V2, V3: Single): Single; overload;

This item has no description.

function MinFloat(const V1, V2, V3: Double): Double; overload;

This item has no description.

function MaxFloat(values: PSingleArray; nbItems: Integer): Single; overload;

Returns the maximum value of the array.

function MaxFloat(values: PDoubleArray; nbItems: Integer): Double; overload;

This item has no description.

function MaxFloat(values: PExtendedArray; nbItems: Integer): Extended; overload;

This item has no description.

function MaxFloat(const V: array of Single): Single; overload;

This item has no description.

function MaxFloat(const V1, V2: Single): Single; overload;

Returns the maximum of given values.

function MaxFloat(const V1, V2: Double): Double; overload;

This item has no description.

function MaxFloat(const V1, V2, V3: Single): Single; overload;

This item has no description.

function MaxFloat(const V1, V2, V3: Double): Double; overload;

This item has no description.

function MinInteger(const V1, V2: Integer): Integer; overload;

This item has no description.

function MinInteger(const V1, V2: Cardinal): Cardinal; overload;

This item has no description.

function MinInteger(const V1, V2, V3: Integer): Integer; overload;

This item has no description.

function MinInteger(const V1, V2, V3: Cardinal): Cardinal; overload;

This item has no description.

function MaxInteger(const V1, V2: Integer): Integer; overload;

This item has no description.

function MaxInteger(const V1, V2: Cardinal): Cardinal; overload;

This item has no description.

function MaxInteger(const V1, V2, V3: Integer): Integer; overload;

This item has no description.

function MaxInteger(const V1, V2, V3: Cardinal): Cardinal; overload;

This item has no description.

function ClampInteger(const value, min, max: Integer): Integer; overload; inline;

This item has no description.

function ClampInteger(const value, min, max: Cardinal): Cardinal; overload; inline;

This item has no description.

function TriangleArea(const p1, p2, p3: TAffineVector): Single; overload;

Computes the triangle's area

function PolygonArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex

function TriangleSignedArea(const p1, p2, p3: TAffineVector): Single; overload;

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored

function PolygonSignedArea(const p: PAffineVectorArray; nSides: Integer): Single; overload;

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex

procedure ScaleFloatArray(values: PSingleArray; nb: Integer; var factor: Single); overload;

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available

procedure ScaleFloatArray(var values: TSingleArray; factor: Single); overload;

This item has no description.

procedure OffsetFloatArray(values: PSingleArray; nb: Integer; var delta: Single); overload;

Adds delta to values in the array. Array size must be a multiple of four

procedure OffsetFloatArray(var values: array of Single; delta: Single); overload;

This item has no description.

procedure OffsetFloatArray(valuesDest, valuesDelta: PSingleArray; nb: Integer); overload;

This item has no description.

function MaxXYZComponent(const V: TGLVector): Single; overload;

Returns the max of the X, Y and Z components of a vector (W is ignored)

function MaxXYZComponent(const V: TAffineVector): Single; overload;

This item has no description.

function MinXYZComponent(const V: TGLVector): Single; overload;

Returns the min of the X, Y and Z components of a vector (W is ignored)

function MinXYZComponent(const V: TAffineVector): Single; overload;

This item has no description.

function MaxAbsXYZComponent(V: TGLVector): Single;

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

function MinAbsXYZComponent(V: TGLVector): Single;

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

procedure MaxVector(var V: TGLVector; const V1: TGLVector); overload;

Replace components of v with the max of v or v1 component. Maximum is computed per component

procedure MaxVector(var V: TAffineVector; const V1: TAffineVector); overload;

This item has no description.

procedure MinVector(var V: TGLVector; const V1: TGLVector); overload;

Replace components of v with the min of v or v1 component. Minimum is computed per component

procedure MinVector(var V: TAffineVector; const V1: TAffineVector); overload;

This item has no description.

procedure SortArrayAscending(var a: array of Extended);

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...

function ClampValue(const aValue, aMin, aMax: Single): Single; overload;

Clamps aValue in the aMin-aMax interval

function ClampValue(const aValue, aMin: Single): Single; overload;

Clamps aValue in the aMin-INF interval

function GeometryOptimizationMode: String;

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'

procedure BeginFPUOnlySection;

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

procedure EndFPUOnlySection;

Ends a FPU-only section. See BeginFPUOnlySection

function ConvertRotation(const Angles: TAffineVector): TGLVector;

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)

function MakeAffineDblVector(var V: array of Double): TAffineDblVector;

Miscellaneous functions

function MakeDblVector(var V: array of Double): THomogeneousDblVector;

This item has no description.

function VectorAffineDblToFlt(const V: TAffineDblVector): TAffineVector;

Converts a vector containing double sized values into a vector with single sized values

function VectorDblToFlt(const V: THomogeneousDblVector): THomogeneousVector;

Converts a vector containing double sized values into a vector with single sized values

function VectorAffineFltToDbl(const V: TAffineVector): TAffineDblVector;

Converts a vector containing single sized values into a vector with double sized values

function VectorFltToDbl(const V: TGLVector): THomogeneousDblVector;

Converts a vector containing single sized values into a vector with double sized values

function PointInPolygon(const xp, yp: array of Single; X, Y: Single): Boolean;

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary

function IsPointInPolygon(const Polygon: array of TPoint; const p: TPoint): Boolean;

PtInRegion

procedure DivMod(Dividend: Integer; Divisor: Word; var result, Remainder: Word);

This item has no description.

function Turn(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis

function Turn(const Matrix: TGLMatrix; const MasterUp: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterUp

function Pitch(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its X-axis

function Pitch(const Matrix: TGLMatrix; const MasterRight: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterRight

function Roll(const Matrix: TGLMatrix; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its Z-axis

function Roll(const Matrix: TGLMatrix; const MasterDirection: TAffineVector; Angle: Single): TGLMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterDirection

function IntersectLinePlane(const point, direction: TGLVector; const plane: THmgPlane; intersectPoint: PGLVector = nil): Integer; overload;

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

function IntersectTriangleBox(const p1, p2, p3, aMinExtent, aMaxExtent: TAffineVector): Boolean;

Compute intersection between a triangle and a box. Returns True if an intersection was found

function IntersectSphereBox(const SpherePos: TGLVector; const SphereRadius: Single; const BoxMatrix: TGLMatrix; const BoxScale: TAffineVector; intersectPoint: PAffineVector = nil; normal: PAffineVector = nil; depth: PSingle = nil): Boolean;

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube

function RayCastPlaneIntersect(const rayStart, rayVector: TGLVector; const planePoint, planeNormal: TGLVector; intersectPoint: PGLVector = nil): Boolean; overload;

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil

function RayCastPlaneXZIntersect(const rayStart, rayVector: TGLVector; const planeY: Single; intersectPoint: PGLVector = nil): Boolean; overload;

This item has no description.

function RayCastTriangleIntersect(const rayStart, rayVector: TGLVector; const p1, p2, p3: TAffineVector; intersectPoint: PGLVector = nil; intersectNormal: PGLVector = nil): Boolean; overload;

Compute intersection between a ray and a triangle

function RayCastMinDistToPoint(const rayStart, rayVector: TGLVector; const point: TGLVector): Single;

Compute the min distance a ray will pass to a point

function RayCastIntersectsSphere(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single): Boolean; overload;

Determines if a ray will intersect with a given sphere

function RayCastSphereIntersect(const rayStart, rayVector: TGLVector; const sphereCenter: TGLVector; const SphereRadius: Single; var i1, i2: TGLVector): Integer; overload;

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)

function RayCastBoxIntersect(const rayStart, rayVector, aMinExtent, aMaxExtent: TAffineVector; intersectPoint: PAffineVector = nil): Boolean;

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil

function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;

Determine if 2 rectanges intersect

function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;

Determine if BigRect completely contains SmallRect

function SphereVisibleRadius(distance, radius: Single): Single;

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

function ExtractFrustumFromModelViewProjection(const modelViewProj: TGLMatrix): TFrustum;

Extracts a TFrustum for combined modelview and projection matrices

function IsVolumeClipped(const objPos: TAffineVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload;

Determines if volume is clipped or not

function IsVolumeClipped(const objPos: TGLVector; const objRadius: Single; const Frustum: TFrustum): Boolean; overload; inline;

This item has no description.

function IsVolumeClipped(const min, max: TAffineVector; const Frustum: TFrustum): Boolean; overload; inline;

This item has no description.

function MakeParallelProjectionMatrix(const plane: THmgPlane; const dir: TGLVector): TGLMatrix;

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction

function MakeShadowMatrix(const planePoint, planeNormal, lightPos: TGLVector): TGLMatrix;

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos

function MakeReflectionMatrix(const planePoint, planeNormal: TAffineVector): TGLMatrix;

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)

function PackRotationMatrix(const mat: TGLMatrix): TPackedRotationMatrix;

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition

function UnPackRotationMatrix(const packedMatrix: TPackedRotationMatrix): TGLMatrix;

Restores a packed rotation matrix. See PackRotationMatrix

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TGLVector): TVector2f; overload;

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;

This item has no description.

function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TGLVector; pitchDelta, turnDelta: Single): TGLVector;

Extracted from Camera.MoveAroundTarget(pitch, turn)

function AngleBetweenVectors(const a, b, ACenterPoint: TGLVector): Single; overload;

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians

function AngleBetweenVectors(const a, b, ACenterPoint: TAffineVector): Single; overload;

This item has no description.

function ShiftObjectFromCenter(const AOriginalPosition: TGLVector; const ACenter: TGLVector; const ADistance: Single; const AFromCenterSpot: Boolean): TGLVector; overload;

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center

function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

This item has no description.

Types

PAffineByteVector = ˆTAffineByteVector;

This item has no description.

PAffineDblVector = ˆTAffineDblVector;

This item has no description.

PAffineExtVector = ˆTAffineExtVector;

This item has no description.

PAffineFltVector = ˆTAffineFltVector;

This item has no description.

PAffineIntVector = ˆTAffineIntVector;

This item has no description.

PAffineMatrix = ˆTAffineMatrix;

This item has no description.

PAffinePtrVector = ˆTAffinePtrVector;

This item has no description.

PAffineVector = ˆTAffineVector;

This item has no description.

PAffineVectorArray = ˆTAffineVectorArray;

Arrays of vectors

PAffineWordVector = ˆTAffineWordVector;

This item has no description.

PByteArray = PByteVector;

This item has no description.

PByteVector = ˆTByteVector;

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits

PCardinalArray = PCardinalVector;

This item has no description.

PCardinalVector = ˆTCardinalVector;

This item has no description.

PDoubleArray = PDoubleVector;

This item has no description.

PDoubleVector = ˆTDoubleVector;

This item has no description.

PExtendedArray = PExtendedVector;

This item has no description.

PExtendedVector = ˆTExtendedVector;

This item has no description.

PFloat = PSingle;

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)

PFloatArray = PFloatVector;

This item has no description.

PFloatVector = ˆTFloatVector;

This item has no description.

PFrustum = ˆTFrustum;

This item has no description.

PHomogeneousByteVector = ˆTHomogeneousByteVector;

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3

PHomogeneousDblVector = ˆTHomogeneousDblVector;

This item has no description.

PHomogeneousExtVector = ˆTHomogeneousExtVector;

This item has no description.

PHomogeneousFltVector = ˆTHomogeneousFltVector;

This item has no description.

PHomogeneousIntVector = ˆTHomogeneousIntVector;

This item has no description.

PHomogeneousMatrix = ˆTHomogeneousMatrix;

This item has no description.

PHomogeneousPtrVector = ˆTHomogeneousPtrVector;

This item has no description.

PHomogeneousVector = ˆTHomogeneousVector;

some simplified names

PHomogeneousWordVector = ˆTHomogeneousWordVector;

This item has no description.

PIntegerArray = PIntegerVector;

This item has no description.

PIntegerVector = ˆTIntegerVector;

This item has no description.

PLongWordArray = PLongWordVector;

This item has no description.

PLongWordVector = ˆTLongWordVector;

This item has no description.

PMatrixArray = ˆTMatrixArray;

This item has no description.

PPointerArray = PPointerVector;

This item has no description.

PPointerVector = ˆTPointerVector;

This item has no description.

PQuaternion = ˆTQuaternion;

q = ([x, y, z], w)

PQuaternionArray = ˆTQuaternionArray;

This item has no description.

PSingleArray = PFloatArray;

This item has no description.

PTexPoint = ˆTTexPoint;

This item has no description.

PTexPointArray = ˆTTexPointArray;

This item has no description.

PVector2f = ˆTVector2f;

This item has no description.

PVectorArray = ˆTVectorArray;

This item has no description.

PVertex = ˆTVertex;

This item has no description.

PWordVector = ˆTWordVector;

This item has no description.

TAffineByteMatrix = TMatrix3b;

This item has no description.

TAffineByteVector = TVector3b;

This item has no description.

TAffineDblMatrix = TMatrix3d;

This item has no description.

TAffineDblVector = TVector3d;

This item has no description.

TAffineExtMatrix = array [0 .. 2] of TAffineExtVector;

This item has no description.

TAffineExtVector = TVector3e;

This item has no description.

TAffineFltMatrix = TMatrix3f;

This item has no description.

TAffineFltVector = TVector3f;

This item has no description.

TAffineIntMatrix = TMatrix3i;

This item has no description.

TAffineIntVector = TVector3i;

This item has no description.

TAffineMatrix = TAffineFltMatrix;

This item has no description.

TAffinePtrVector = TVector3p;

This item has no description.

TAffineVector = TVector3f;

This item has no description.

TAffineVectorArray = array [0 .. MaxInt shr 4] of TAffineVector;

This item has no description.

TAffineWordMatrix = array [0 .. 2] of TAffineWordVector;

This item has no description.

TAffineWordVector = TVector3w;

This item has no description.

TByteVector = array [0 .. cMaxArray] of Byte;

This item has no description.

TCardinalVector = array [0 .. cMaxArray] of Cardinal;

This item has no description.

TDoubleHmgPlane = THomogeneousDblVector;

This item has no description.

TDoubleVector = array [0 .. cMaxArray] of Double;

This item has no description.

TEulerOrder = (...);

—————————————————————————- Quaternion functions —————————————————————————-

Values
  • eulXYZ
  • eulXZY
  • eulYXZ
  • eulYZX
  • eulZXY
  • eulZYX
TExtendedVector = array [0 .. cMaxArray] of Extended;

This item has no description.

TFloatVector = array [0 .. cMaxArray] of Single;

This item has no description.

TGLInterpolationType = (...);

This item has no description.

Values
  • itLinear
  • itPower
  • itSin
  • itSinAlt
  • itTan
  • itLn
  • itExp
THmgPlane = TGLVector;

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation

THomogeneousByteMatrix = TMatrix4b;

Matrices

THomogeneousByteVector = TVector4b;

This item has no description.

THomogeneousDblMatrix = TMatrix4d;

This item has no description.

THomogeneousDblVector = TVector4d;

This item has no description.

THomogeneousExtMatrix = array [0 .. 3] of THomogeneousExtVector;

This item has no description.

THomogeneousExtVector = TVector4e;

This item has no description.

THomogeneousFltMatrix = TMatrix4f;

This item has no description.

THomogeneousFltVector = TVector4f;

This item has no description.

THomogeneousIntMatrix = TMatrix4i;

This item has no description.

THomogeneousIntVector = TVector4i;

This item has no description.

THomogeneousMatrix = THomogeneousFltMatrix;

This item has no description.

THomogeneousPtrVector = TVector4p;

This item has no description.

THomogeneousVector = THomogeneousFltVector;

This item has no description.

THomogeneousWordMatrix = array [0 .. 3] of THomogeneousWordVector;

This item has no description.

THomogeneousWordVector = TVector4w;

This item has no description.

TIntegerVector = array [0 .. cMaxArray] of Integer;

This item has no description.

TLongWordVector = array [0 .. cMaxArray] of LongWord;

This item has no description.

TMatrixArray = array [0 .. MaxInt shr 7] of TGLMatrix;

Some simplified names

TPackedRotationMatrix = array [0 .. 2] of SmallInt;

This item has no description.

TPointerVector = array [0 .. cMaxArray] of Pointer;

This item has no description.

TQuaternionArray = array [0 .. MaxInt shr 5] of TQuaternion;

This item has no description.

TSingleArray = array of Single;

This item has no description.

TTexPointArray = array [0 .. MaxInt shr 4] of TTexPoint;

This item has no description.

TTransformations = array [TTransType] of Single;

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)

TTransType = (...);

This item has no description.

Values
  • ttScaleX
  • ttScaleY
  • ttScaleZ
  • ttShearXY
  • ttShearXZ
  • ttShearYZ
  • ttRotateX
  • ttRotateY
  • ttRotateZ
  • ttTranslateX
  • ttTranslateY
  • ttTranslateZ
  • ttPerspectiveX
  • ttPerspectiveY
  • ttPerspectiveZ
  • ttPerspectiveW
TVectorArray = array [0 .. MaxInt shr 5] of TGLVector;

This item has no description.

TVertex = TAffineVector;

This item has no description.

TWordVector = array [0 .. cMaxArray] of Word;

This item has no description.

Constants

cMaxArray = (MaxInt shr 4);

This item has no description.

cColinearBias = 1E-8;

This item has no description.

XTexPoint: TTexPoint = (S: 1; T: 0);

TexPoints (2D space)

YTexPoint: TTexPoint = (S: 0; T: 1);

This item has no description.

XYTexPoint: TTexPoint = (S: 1; T: 1);

This item has no description.

NullTexPoint: TTexPoint = (S: 0; T: 0);

This item has no description.

MidTexPoint: TTexPoint = (S: 0.5; T: 0.5);

This item has no description.

XVector: TAffineVector = (X: 1; Y: 0; Z: 0);

standard vectors

YVector: TAffineVector = (X: 0; Y: 1; Z: 0);

This item has no description.

ZVector: TAffineVector = (X: 0; Y: 0; Z: 1);

This item has no description.

XYVector: TAffineVector = (X: 1; Y: 1; Z: 0);

This item has no description.

XZVector: TAffineVector = (X: 1; Y: 0; Z: 1);

This item has no description.

YZVector: TAffineVector = (X: 0; Y: 1; Z: 1);

This item has no description.

XYZVector: TAffineVector = (X: 1; Y: 1; Z: 1);

This item has no description.

NullVector: TAffineVector = (X: 0; Y: 0; Z: 0);

This item has no description.

MinusXVector: TAffineVector = (X: - 1; Y: 0; Z: 0);

This item has no description.

MinusYVector: TAffineVector = (X: 0; Y: - 1; Z: 0);

This item has no description.

MinusZVector: TAffineVector = (X: 0; Y: 0; Z: - 1);

This item has no description.

XHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 0);

Standard homogeneous vectors

YHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 0);

This item has no description.

ZHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 0);

This item has no description.

WHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

XYHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 0; W: 0);

This item has no description.

YZHmgVector: THomogeneousVector = (X: 0; Y: 1; Z: 1; W: 0);

This item has no description.

XZHmgVector: THomogeneousVector = (X: 1; Y: 0; Z: 1; W: 0);

This item has no description.

XYZHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 0);

This item has no description.

XYZWHmgVector: THomogeneousVector = (X: 1; Y: 1; Z: 1; W: 1);

This item has no description.

NullHmgVector: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 0);

This item has no description.

XHmgPoint: THomogeneousVector = (X: 1; Y: 0; Z: 0; W: 1);

Standard homogeneous points

YHmgPoint: THomogeneousVector = (X: 0; Y: 1; Z: 0; W: 1);

This item has no description.

ZHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 1; W: 1);

This item has no description.

WHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

NullHmgPoint: THomogeneousVector = (X: 0; Y: 0; Z: 0; W: 1);

This item has no description.

IdentityMatrix: TAffineMatrix = (V: ((X: 1; Y: 0; Z: 0), (X: 0; Y: 1; Z: 0), (X: 0; Y: 0; Z: 1)));

This item has no description.

IdentityHmgMatrix: TGLMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

IdentityHmgDblMatrix: THomogeneousDblMatrix = (V: ((X: 1; Y: 0; Z: 0; W: 0), (X: 0; Y: 1; Z: 0; W: 0), (X: 0; Y: 0; Z: 1; W: 0), (X: 0; Y: 0; Z: 0; W: 1)));

This item has no description.

EmptyMatrix: TAffineMatrix = (V: ((X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0), (X: 0; Y: 0; Z: 0)));

This item has no description.

EmptyHmgMatrix: TGLMatrix = (V: ((X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0), (X: 0; Y: 0; Z: 0; W: 0)));

This item has no description.

IdentityQuaternion: TQuaternion = (ImagPart: (X: 0; Y: 0; Z: 0); RealPart: 1);

Quaternions

EPSILON: Single = 1E-40;

Some very small numbers

EPSILON2: Single = 1E-30;

This item has no description.

cPI: Single = 3.141592654;

This item has no description.

cPIdiv180: Single = 0.017453292;

This item has no description.

c180divPI: Single = 57.29577951;

This item has no description.

c2PI: Single = 6.283185307;

This item has no description.

cPIdiv2: Single = 1.570796326;

This item has no description.

cPIdiv4: Single = 0.785398163;

This item has no description.

c3PIdiv2: Single = 4.71238898;

This item has no description.

c3PIdiv4: Single = 2.35619449;

This item has no description.

cInv2PI: Single = 1 / 6.283185307;

This item has no description.

cInv360: Single = 1 / 360;

This item has no description.

c180: Single = 180;

This item has no description.

c360: Single = 360;

This item has no description.

cOneHalf: Single = 0.5;

This item has no description.

cLn10: Single = 2.302585093;

This item has no description.

MinSingle = 1.5E-45;

Ranges of the IEEE floating point types, including denormals with Math.pas compatible name

MaxSingle = 3.4E+38;

This item has no description.

MinDouble = 5.0E-324;

This item has no description.

MaxDouble = 1.7E+308;

This item has no description.

MinExtended = 3.4E-4932;

This item has no description.

MaxExtended = MaxDouble;

This item has no description.

MinComp = -9.223372036854775807E+18;

1.1E+4932 <-Overflowing in c++;

MaxComp = 9.223372036854775807E+18;

This item has no description.

Variables

vSIMD: Byte = 0;

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)


GXSysHelp v.2.5: GLScene.VectorGeometry: Packed Record TTexPoint

Packed Record TTexPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TTexPoint = packed record

Description

This item has no description.

Overview

Fields

Public | S: Single;
Public | T: Single;

Description

Fields

Public S: Single;

This item has no description.

Public T: Single;


GXSysHelp v.2.5: GLScene.VectorGeometry: Record TQuaternion

Record TQuaternion

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TQuaternion = record

Description

This item has no description.

Overview

Fields

Public | ImagPart: TAffineVector;
Public | RealPart: Single
Public | X: Single
Public | Y: Single
Public | Z: Single
Public | W: Single

Description

Fields

Public ImagPart: TAffineVector;

This item has no description.

Public RealPart: Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single

This item has no description.

Public W: Single


GXSysHelp v.2.5: GLScene.VectorGeometry: Record TRectangle

Record TRectangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TRectangle = record

Description

This item has no description.

Overview

Fields

Public | Left: Integer;
Public | Top: Integer;
Public | Width: Integer;
Public | Height: Integer;

Description

Fields

Public Left: Integer;

This item has no description.

Public Top: Integer;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;


GXSysHelp v.2.5: GLScene.VectorGeometry: Record TFrustum

Record TFrustum

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorGeometry

Declaration

type TFrustum = record

Description

This item has no description.

Overview

Fields

Public | pLeft: THmgPlane;
Public | pTop: THmgPlane;
Public | pRight: THmgPlane;
Public | pBottom: THmgPlane;
Public | pNear: THmgPlane;
Public | pFar: THmgPlane;

Description

Fields

Public pLeft: THmgPlane;

This item has no description.

Public pTop: THmgPlane;

This item has no description.

Public pRight: THmgPlane;

This item has no description.

Public pBottom: THmgPlane;

This item has no description.

Public pNear: THmgPlane;

This item has no description.

Public pFar: THmgPlane;


GXSysHelp v.2.5: GLScene.VectorTypes

Unit GLScene.VectorTypes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TVector2d |
Record TVector2f |
Record TVector2h |
Record TVector2i |
Record TVector2ui |
Record TVector2s |
Record TVector2b |
Record TVector2sb |
Record TVector2e |
Record TVector2w |
Record TVector2p |
Record TVector3d |
Record TVector3f |
Record TVector3h |
Record TVector3i |
Record TVector3ui |
Record TVector3s |
Record TVector3b |
Record TVector3sb |
Record TVector3e |
Record TVector3w |
Record TVector3p |
Record TVector4d |
Record TVector4f |
Record TVector4h |
Record TVector4i |
Record TVector4ui |
Record TVector4s |
Record TVector4b |
Record TVector4sb |
Record TVector4e |
Record TVector4w |
Record TVector4p |
Record TMatrix2d |
Record TMatrix2f |
Record TMatrix2i |
Record TMatrix2s |
Record TMatrix2b |
Record TMatrix2e |
Record TMatrix2w |
Record TMatrix2p |
Record TMatrix3d |
Record TMatrix3f |
Record TMatrix3i |
Record TMatrix3s |
Record TMatrix3b |
Record TMatrix3e |
Record TMatrix3w |
Record TMatrix3p |
Record TMatrix4d |
Record TMatrix4f |
Record TMatrix4i |
Record TMatrix4s |
Record TMatrix4b |
Record TMatrix4e |
Record TMatrix4w |
Record TMatrix4p |
Packed Record TD3DVector |
Packed Record TD3DMatrix |

Types

PGLMatrix = ˆTGLMatrix;
PGLVector = ˆTGLVector;
PMatrix4f = ˆTMatrix4f;
PVector4f = ˆTVector4f;
TGLMatrix = TMatrix4f;
TGLVector = TVector4f;

Description

Types

PGLMatrix = ˆTGLMatrix;

The matrix by default

PGLVector = ˆTGLVector;

The vector by default

PMatrix4f = ˆTMatrix4f;

the matrix by default

PVector4f = ˆTVector4f;

This item has no description.

TGLMatrix = TMatrix4f;

This item has no description.

TGLVector = TVector4f;


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2d

Record TVector2d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2d = record

Description

=========== Vectors ============ 2

Overview

Fields

Public | V: array[0..1] of Double
Public | X: Double;
Public | Y: Double

Description

Fields

Public V: array[0..1] of Double

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2f

Record TVector2f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Single
Public | X: Single
Public | Y: Single

Description

Fields

Public V: array[0..1] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2h

Record TVector2h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Word
Public | X: Word
Public | Y: Word

Description

Fields

Public V: array[0..1] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2i

Record TVector2i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Longint
Public | X: Longint
Public | Y: Longint

Description

Fields

Public V: array[0..1] of Longint

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2ui

Record TVector2ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Longword
Public | X: Longword
Public | Y: Longword

Description

Fields

Public V: array[0..1] of Longword

This item has no description.

Public X: Longword

This item has no description.

Public Y: Longword


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2s

Record TVector2s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Smallint
Public | X: Smallint
Public | Y: Smallint

Description

Fields

Public V: array[0..1] of Smallint

This item has no description.

Public X: Smallint

This item has no description.

Public Y: Smallint


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2b

Record TVector2b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Byte
Public | X: Byte
Public | Y: Byte

Description

Fields

Public V: array[0..1] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2sb

Record TVector2sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt

Description

Fields

Public V: array[0..1] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2e

Record TVector2e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Extended
Public | X: Extended
Public | Y: Extended

Description

Fields

Public V: array[0..1] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2w

Record TVector2w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Word
Public | X: Word
Public | Y: Word

Description

Fields

Public V: array[0..1] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector2p

Record TVector2p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector2p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of Pointer
Public | X: Pointer
Public | Y: Pointer

Description

Fields

Public V: array[0..1] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3d

Record TVector3d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3d = record

Description

3

Overview

Fields

Public | V: array[0..2] of Double
Public | X: Double
Public | Y: Double
Public | Z: Double

Description

Fields

Public V: array[0..2] of Double

This item has no description.

Public X: Double

This item has no description.

Public Y: Double

This item has no description.

Public Z: Double


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3f

Record TVector3f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Single
Public | X: Single
Public | Y: Single
Public | Z: Single

Description

Fields

Public V: array[0..2] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3h

Record TVector3h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word

Description

Fields

Public V: array[0..2] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3i

Record TVector3i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Longint
Public | X: Longint
Public | Y: Longint
Public | Z: Longint

Description

Fields

Public V: array[0..2] of Longint

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint

This item has no description.

Public Z: Longint


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3ui

Record TVector3ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Longword
Public | X: Longword
Public | Y: Longword
Public | Z: Longword

Description

Fields

Public V: array[0..2] of Longword

This item has no description.

Public X: Longword

This item has no description.

Public Y: Longword

This item has no description.

Public Z: Longword


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3s

Record TVector3s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Smallint
Public | X: Smallint
Public | Y: Smallint
Public | Z: Smallint

Description

Fields

Public V: array[0..2] of Smallint

This item has no description.

Public X: Smallint

This item has no description.

Public Y: Smallint

This item has no description.

Public Z: Smallint


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3b

Record TVector3b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Byte
Public | X: Byte
Public | Y: Byte
Public | Z: Byte

Description

Fields

Public V: array[0..2] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte

This item has no description.

Public Z: Byte


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3sb

Record TVector3sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt
Public | Z: ShortInt

Description

Fields

Public V: array[0..2] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt

This item has no description.

Public Z: ShortInt


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3e

Record TVector3e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Extended
Public | X: Extended
Public | Y: Extended
Public | Z: Extended

Description

Fields

Public V: array[0..2] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended

This item has no description.

Public Z: Extended


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3w

Record TVector3w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word

Description

Fields

Public V: array[0..2] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector3p

Record TVector3p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector3p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of Pointer
Public | X: Pointer
Public | Y: Pointer
Public | Z: Pointer

Description

Fields

Public V: array[0..2] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer

This item has no description.

Public Z: Pointer


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4d

Record TVector4d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4d = record

Description

4

Overview

Fields

Public | V: array[0..3] of Double
Public | X: Double
Public | Y: Double
Public | Z: Double
Public | W: Double

Description

Fields

Public V: array[0..3] of Double

This item has no description.

Public X: Double

This item has no description.

Public Y: Double

This item has no description.

Public Z: Double

This item has no description.

Public W: Double


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4f

Record TVector4f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Single
Public | X: Single
Public | Y: Single
Public | Z: Single
Public | W: Single

Description

Fields

Public V: array[0..3] of Single

This item has no description.

Public X: Single

This item has no description.

Public Y: Single

This item has no description.

Public Z: Single

This item has no description.

Public W: Single


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4h

Record TVector4h

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4h = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word
Public | W: Word

Description

Fields

Public V: array[0..3] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word

This item has no description.

Public W: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4i

Record TVector4i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of LongInt
Public | X: Longint
Public | Y: Longint
Public | Z: Longint
Public | W: Longint

Description

Fields

Public V: array[0..3] of LongInt

This item has no description.

Public X: Longint

This item has no description.

Public Y: Longint

This item has no description.

Public Z: Longint

This item has no description.

Public W: Longint


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4ui

Record TVector4ui

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4ui = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of LongWord
Public | X: LongWord
Public | Y: LongWord
Public | Z: LongWord
Public | W: LongWord

Description

Fields

Public V: array[0..3] of LongWord

This item has no description.

Public X: LongWord

This item has no description.

Public Y: LongWord

This item has no description.

Public Z: LongWord

This item has no description.

Public W: LongWord


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4s

Record TVector4s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of SmallInt
Public | X: SmallInt
Public | Y: SmallInt
Public | Z: SmallInt
Public | W: SmallInt

Description

Fields

Public V: array[0..3] of SmallInt

This item has no description.

Public X: SmallInt

This item has no description.

Public Y: SmallInt

This item has no description.

Public Z: SmallInt

This item has no description.

Public W: SmallInt


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4b

Record TVector4b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Byte
Public | X: Byte
Public | Y: Byte
Public | Z: Byte
Public | W: Byte

Description

Fields

Public V: array[0..3] of Byte

This item has no description.

Public X: Byte

This item has no description.

Public Y: Byte

This item has no description.

Public Z: Byte

This item has no description.

Public W: Byte


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4sb

Record TVector4sb

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4sb = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of ShortInt
Public | X: ShortInt
Public | Y: ShortInt
Public | Z: ShortInt
Public | W: ShortInt

Description

Fields

Public V: array[0..3] of ShortInt

This item has no description.

Public X: ShortInt

This item has no description.

Public Y: ShortInt

This item has no description.

Public Z: ShortInt

This item has no description.

Public W: ShortInt


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4e

Record TVector4e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Extended
Public | X: Extended
Public | Y: Extended
Public | Z: Extended
Public | W: Extended

Description

Fields

Public V: array[0..3] of Extended

This item has no description.

Public X: Extended

This item has no description.

Public Y: Extended

This item has no description.

Public Z: Extended

This item has no description.

Public W: Extended


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4w

Record TVector4w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Word
Public | X: Word
Public | Y: Word
Public | Z: Word
Public | W: Word

Description

Fields

Public V: array[0..3] of Word

This item has no description.

Public X: Word

This item has no description.

Public Y: Word

This item has no description.

Public Z: Word

This item has no description.

Public W: Word


GXSysHelp v.2.5: GLScene.VectorTypes: Record TVector4p

Record TVector4p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TVector4p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of Pointer
Public | X: Pointer
Public | Y: Pointer
Public | Z: Pointer
Public | W: Pointer

Description

Fields

Public V: array[0..3] of Pointer

This item has no description.

Public X: Pointer

This item has no description.

Public Y: Pointer

This item has no description.

Public Z: Pointer

This item has no description.

Public W: Pointer


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2d

Record TMatrix2d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2d = record

Description

=========== Matrices ============

Overview

Fields

Public | V: array[0..1] of TVector2d
Public | X: TVector2d
Public | Y: TVector2d

Description

Fields

Public V: array[0..1] of TVector2d

This item has no description.

Public X: TVector2d

This item has no description.

Public Y: TVector2d


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2f

Record TMatrix2f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2f
Public | X: TVector2f
Public | Y: TVector2f

Description

Fields

Public V: array[0..1] of TVector2f

This item has no description.

Public X: TVector2f

This item has no description.

Public Y: TVector2f


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2i

Record TMatrix2i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2i
Public | X: TVector2i
Public | Y: TVector2i

Description

Fields

Public V: array[0..1] of TVector2i

This item has no description.

Public X: TVector2i

This item has no description.

Public Y: TVector2i


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2s

Record TMatrix2s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2s
Public | X: TVector2s
Public | Y: TVector2s

Description

Fields

Public V: array[0..1] of TVector2s

This item has no description.

Public X: TVector2s

This item has no description.

Public Y: TVector2s


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2b

Record TMatrix2b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2b
Public | X: TVector2b
Public | Y: TVector2b

Description

Fields

Public V: array[0..1] of TVector2b

This item has no description.

Public X: TVector2b

This item has no description.

Public Y: TVector2b


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2e

Record TMatrix2e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2e
Public | X: TVector2e
Public | Y: TVector2e

Description

Fields

Public V: array[0..1] of TVector2e

This item has no description.

Public X: TVector2e

This item has no description.

Public Y: TVector2e


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2w

Record TMatrix2w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2w
Public | X: TVector2w
Public | Y: TVector2w

Description

Fields

Public V: array[0..1] of TVector2w

This item has no description.

Public X: TVector2w

This item has no description.

Public Y: TVector2w


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix2p

Record TMatrix2p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix2p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..1] of TVector2p
Public | X: TVector2p
Public | Y: TVector2p

Description

Fields

Public V: array[0..1] of TVector2p

This item has no description.

Public X: TVector2p

This item has no description.

Public Y: TVector2p


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3d

Record TMatrix3d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3d = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3d
Public | X: TVector3d
Public | Y: TVector3d
Public | Z: TVector3d

Description

Fields

Public V: array[0..2] of TVector3d

This item has no description.

Public X: TVector3d

This item has no description.

Public Y: TVector3d

This item has no description.

Public Z: TVector3d


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3f

Record TMatrix3f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3f
Public | X: TVector3f
Public | Y: TVector3f
Public | Z: TVector3f

Description

Fields

Public V: array[0..2] of TVector3f

This item has no description.

Public X: TVector3f

This item has no description.

Public Y: TVector3f

This item has no description.

Public Z: TVector3f


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3i

Record TMatrix3i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3i
Public | X: TVector3i
Public | Y: TVector3i
Public | Z: TVector3i

Description

Fields

Public V: array[0..2] of TVector3i

This item has no description.

Public X: TVector3i

This item has no description.

Public Y: TVector3i

This item has no description.

Public Z: TVector3i


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3s

Record TMatrix3s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3s
Public | X: TVector3s
Public | Y: TVector3s
Public | Z: TVector3s

Description

Fields

Public V: array[0..2] of TVector3s

This item has no description.

Public X: TVector3s

This item has no description.

Public Y: TVector3s

This item has no description.

Public Z: TVector3s


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3b

Record TMatrix3b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3b
Public | X: TVector3b
Public | Y: TVector3b
Public | Z: TVector3b

Description

Fields

Public V: array[0..2] of TVector3b

This item has no description.

Public X: TVector3b

This item has no description.

Public Y: TVector3b

This item has no description.

Public Z: TVector3b


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3e

Record TMatrix3e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3e
Public | X: TVector3e
Public | Y: TVector3e
Public | Z: TVector3e

Description

Fields

Public V: array[0..2] of TVector3e

This item has no description.

Public X: TVector3e

This item has no description.

Public Y: TVector3e

This item has no description.

Public Z: TVector3e


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3w

Record TMatrix3w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3w
Public | X: TVector3w
Public | Y: TVector3w
Public | Z: TVector3w

Description

Fields

Public V: array[0..2] of TVector3w

This item has no description.

Public X: TVector3w

This item has no description.

Public Y: TVector3w

This item has no description.

Public Z: TVector3w


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix3p

Record TMatrix3p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix3p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..2] of TVector3p
Public | X: TVector3p
Public | Y: TVector3p
Public | Z: TVector3p

Description

Fields

Public V: array[0..2] of TVector3p

This item has no description.

Public X: TVector3p

This item has no description.

Public Y: TVector3p

This item has no description.

Public Z: TVector3p


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4d

Record TMatrix4d

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4d = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4d
Public | X: TVector4d
Public | Y: TVector4d
Public | Z: TVector4d
Public | W: TVector4d

Description

Fields

Public V: array[0..3] of TVector4d

This item has no description.

Public X: TVector4d

This item has no description.

Public Y: TVector4d

This item has no description.

Public Z: TVector4d

This item has no description.

Public W: TVector4d


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4f

Record TMatrix4f

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4f = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4f
Public | X: TVector4f
Public | Y: TVector4f
Public | Z: TVector4f
Public | W: TVector4f

Description

Fields

Public V: array[0..3] of TVector4f

This item has no description.

Public X: TVector4f

This item has no description.

Public Y: TVector4f

This item has no description.

Public Z: TVector4f

This item has no description.

Public W: TVector4f


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4i

Record TMatrix4i

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4i = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4i
Public | X: TVector4i
Public | Y: TVector4i
Public | Z: TVector4i
Public | W: TVector4i

Description

Fields

Public V: array[0..3] of TVector4i

This item has no description.

Public X: TVector4i

This item has no description.

Public Y: TVector4i

This item has no description.

Public Z: TVector4i

This item has no description.

Public W: TVector4i


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4s

Record TMatrix4s

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4s = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4s
Public | X: TVector4s
Public | Y: TVector4s
Public | Z: TVector4s
Public | W: TVector4s

Description

Fields

Public V: array[0..3] of TVector4s

This item has no description.

Public X: TVector4s

This item has no description.

Public Y: TVector4s

This item has no description.

Public Z: TVector4s

This item has no description.

Public W: TVector4s


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4b

Record TMatrix4b

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4b = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4b
Public | X: TVector4b
Public | Y: TVector4b
Public | Z: TVector4b
Public | W: TVector4b

Description

Fields

Public V: array[0..3] of TVector4b

This item has no description.

Public X: TVector4b

This item has no description.

Public Y: TVector4b

This item has no description.

Public Z: TVector4b

This item has no description.

Public W: TVector4b


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4e

Record TMatrix4e

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4e = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4e
Public | X: TVector4e
Public | Y: TVector4e
Public | Z: TVector4e
Public | W: TVector4e

Description

Fields

Public V: array[0..3] of TVector4e

This item has no description.

Public X: TVector4e

This item has no description.

Public Y: TVector4e

This item has no description.

Public Z: TVector4e

This item has no description.

Public W: TVector4e


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4w

Record TMatrix4w

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4w = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4w
Public | X: TVector4w
Public | Y: TVector4w
Public | Z: TVector4w
Public | W: TVector4w

Description

Fields

Public V: array[0..3] of TVector4w

This item has no description.

Public X: TVector4w

This item has no description.

Public Y: TVector4w

This item has no description.

Public Z: TVector4w

This item has no description.

Public W: TVector4w


GXSysHelp v.2.5: GLScene.VectorTypes: Record TMatrix4p

Record TMatrix4p

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TMatrix4p = record

Description

This item has no description.

Overview

Fields

Public | V: array[0..3] of TVector4p
Public | X: TVector4p
Public | Y: TVector4p
Public | Z: TVector4p
Public | W: TVector4p

Description

Fields

Public V: array[0..3] of TVector4p

This item has no description.

Public X: TVector4p

This item has no description.

Public Y: TVector4p

This item has no description.

Public Z: TVector4p

This item has no description.

Public W: TVector4p


GXSysHelp v.2.5: GLScene.VectorTypes: Packed Record TD3DVector

Packed Record TD3DVector

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TD3DVector = packed record

Description

This item has no description.

Overview

Fields

Public | X: single;
Public | Y: single;
Public | Z: single
Public | V: TVector3f

Description

Fields

Public X: single;

This item has no description.

Public Y: single;

This item has no description.

Public Z: single

This item has no description.

Public V: TVector3f


GXSysHelp v.2.5: GLScene.VectorTypes: Packed Record TD3DMatrix

Packed Record TD3DMatrix

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypes

Declaration

type TD3DMatrix = packed record

Description

This item has no description.

Overview

Fields

Public | _11: single;
Public | _12: single;
Public | _13: single;
Public | _14: single;
Public | _21: single;
Public | _22: single;
Public | _23: single;
Public | _24: single;
Public | _31: single;
Public | _32: single;
Public | _33: single;
Public | _34: single;
Public | _41: single
Public | _42: single
Public | _43: single
Public | _44: single
Public | M: TMatrix4f

Description

Fields

Public _11: single;

This item has no description.

Public _12: single;

This item has no description.

Public _13: single;

This item has no description.

Public _14: single;

This item has no description.

Public _21: single;

This item has no description.

Public _22: single;

This item has no description.

Public _23: single;

This item has no description.

Public _24: single;

This item has no description.

Public _31: single;

This item has no description.

Public _32: single;

This item has no description.

Public _33: single;

This item has no description.

Public _34: single;

This item has no description.

Public _41: single

This item has no description.

Public _42: single

This item has no description.

Public _43: single

This item has no description.

Public _44: single

This item has no description.

Public M: TMatrix4f


GXSysHelp v.2.5: GLScene.VectorTypesExt

Unit GLScene.VectorTypesExt

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Types
  • System.TypInfo
  • System.SysUtils
  • System.Rtti
  • System.Math
  • System.Math.Vectors
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TQuaternionRec |
Record TVectorRec |
Record TMatrixRec |
Record TQuaternionHelper |
Record TVectorHelper |
Class TDim |
Record TVertexRec |
Record TFaceRec |
Record TPoint2DRec |
Record TPoint3DRec |
Record TVoxelRec |
Record TVector2DRec |
Record TVector3DRec |
Record TMatrix2DRec |
Record TMatrix3DRec |
Record TTriangleRec |
Record TMesh2DVert |
Packed Record TMesh3DVert |
Record TQuat3DRec |
Record TBoxRec |

Functions and Procedures

function GetVectorRec(V: TVectorExt): TVectorRec;
function GetMatrixRec(M: TMatrixExt): TMatrixRec;
function GetQuaternionRec(Q: TVectorExt): TQuaternionRec;
procedure Init(Obj, TypeInfoOfObj: Pointer; Offset: Integer = 0);

Types

PMatrixRec = ˆTMatrixRec;
PPoint2DRec = ˆTPoint2DRec;
PPoint3DRec = ˆTPoint3DRec;
PTriangleRecArray = ˆTTriangleRecArray;
PVectorRec = ˆTVectorRec;
PVertArray = ˆTVertArray;
PVoxelData = ˆTVoxelData;
PVoxelRec = ˆTVoxelRec;
TArray3DExt = array of array of array of Extended;
TDoubleArray = array of Double;
TIntegerArray = array of Integer;
TMatrix2DArray = array of TMatrix2DRec;
TMatrix2DType = array [0 .. 3] of TVector2DRec;
TMatrix3DArray = array of TMatrix3DRec;
TMatrix3DType = array [0 .. 3] of TVector3DRec;
TMatrixExt = array of array of Extended;
TMesh2DArray = array of TMesh2DVert;
TMesh3DArray = array of TMesh3DVert;
TPoint2DArray = array of TPoint2DRec;
TPoint3DArray = array of TPoint3DRec;
TPolygon2D = TPoint2DArray;
TPolygon3D = TPoint3DArray;
TPolyhedronArray = array of TPolygon3D;
TQuatArray = array of TQuat3DRec;
TScalarField = function(X, Y, Z: Extended): TScalarValue;
TScalarFieldInt = function(iX, iY, iZ: Integer): TScalarValue of object;
TScalarValue = Extended;
TTriangleRecArray = array [0 .. (MaxInt shr 8)] of TTriangleRec;
TVector2DArray = array of TVector2DRec;
TVector2DType = array [0 .. 1] of Extended;
TVector3DArray = array of TVector3DRec;
TVector3DType = array [0 .. 2] of Extended;
TVectorExt = array of Extended;
TVertArray = array [0 .. (MaxInt shr 8)] of TVertexRec;
TVertexArray = array of TVector3f;
TVoxelData = array [0 .. (MaxInt shr 8)] of TVoxelRec;
TVoxelStatus = (...);

Constants

ClosedPolygon2D: TPoint2DRec = (X: $FFFF; Y: $FFFF);
ClosedPolygon3D: TPoint3DRec = (X: $FFFF; Y: $FFFF; Z: $FFFF);
sWRONG_ELEMENT = 'Wrong element';
sWRONG_SIZE = 'Wrong size';
sNOT_QUAD = 'Matrix not quadratic';
sSINGULAR = 'Singular matrix founded';

Description

Functions and Procedures

function GetVectorRec(V: TVectorExt): TVectorRec;

This item has no description.

function GetMatrixRec(M: TMatrixExt): TMatrixRec;

This item has no description.

function GetQuaternionRec(Q: TVectorExt): TQuaternionRec;

This item has no description.

procedure Init(Obj, TypeInfoOfObj: Pointer; Offset: Integer = 0);

This item has no description.

Types

PMatrixRec = ˆTMatrixRec;

This item has no description.

PPoint2DRec = ˆTPoint2DRec;

This item has no description.

PPoint3DRec = ˆTPoint3DRec;

This item has no description.

PTriangleRecArray = ˆTTriangleRecArray;

This item has no description.

PVectorRec = ˆTVectorRec;

This item has no description.

PVertArray = ˆTVertArray;

This item has no description.

PVoxelData = ˆTVoxelData;

This item has no description.

PVoxelRec = ˆTVoxelRec;

This item has no description.

TArray3DExt = array of array of array of Extended;

This item has no description.

TDoubleArray = array of Double;

This item has no description.

TIntegerArray = array of Integer;

Extended may be replaced with BigDecimals

TMatrix2DArray = array of TMatrix2DRec;

Matrix Arrays

TMatrix2DType = array [0 .. 3] of TVector2DRec;

———————– Matrix types ———————–

TMatrix3DArray = array of TMatrix3DRec;

This item has no description.

TMatrix3DType = array [0 .. 3] of TVector3DRec;

This item has no description.

TMatrixExt = array of array of Extended;

This item has no description.

TMesh2DArray = array of TMesh2DVert;

This item has no description.

TMesh3DArray = array of TMesh3DVert;

This item has no description.

TPoint2DArray = array of TPoint2DRec;

This item has no description.

TPoint3DArray = array of TPoint3DRec;

This item has no description.

TPolygon2D = TPoint2DArray;

———————– Polygon types ———————–

TPolygon3D = TPoint3DArray;

This item has no description.

TPolyhedronArray = array of TPolygon3D;

———————– Polyhedron types ———————–

TQuatArray = array of TQuat3DRec;

This item has no description.

TScalarField = function(X, Y, Z: Extended): TScalarValue;

This item has no description.

TScalarFieldInt = function(iX, iY, iZ: Integer): TScalarValue of object;

if data are made on integer XYZ index may be replaced with BigIntegers

TScalarValue = Extended;

———————– Point types ———————–

TTriangleRecArray = array [0 .. (MaxInt shr 8)] of TTriangleRec;

This item has no description.

TVector2DArray = array of TVector2DRec;

Vector Arrays

TVector2DType = array [0 .. 1] of Extended;

———————– Vector types ———————–

TVector3DArray = array of TVector3DRec;

This item has no description.

TVector3DType = array [0 .. 2] of Extended;

This item has no description.

TVectorExt = array of Extended;

This item has no description.

TVertArray = array [0 .. (MaxInt shr 8)] of TVertexRec;

This item has no description.

TVertexArray = array of TVector3f;

This item has no description.

TVoxelData = array [0 .. (MaxInt shr 8)] of TVoxelRec;

This item has no description.

TVoxelStatus = (...);

Voxel types

Values
  • bpExternal
  • bpInternal

Constants

ClosedPolygon2D: TPoint2DRec = (X: $FFFF; Y: $FFFF);

TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;

ClosedPolygon3D: TPoint3DRec = (X: $FFFF; Y: $FFFF; Z: $FFFF);

This item has no description.

sWRONG_ELEMENT = 'Wrong element';

This item has no description.

sWRONG_SIZE = 'Wrong size';

This item has no description.

sNOT_QUAD = 'Matrix not quadratic';

This item has no description.

sSINGULAR = 'Singular matrix founded';


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuaternionRec

Record TQuaternionRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuaternionRec = record

Description

This item has no description.

Overview

Fields

Private FData: array [0 .. 3] of Extended;

Methods

Public | constructor Create(Q: TVectorExt);
Public | function Inv: TQuaternionRec;
Public | function TruncateSTI: TQuaternionRec;
Private | function GetElement(Index: Byte): Extended;
Private | procedure SetElement(Index: Byte; Value: Extended);
Public | class operator Implicit(V: TVectorExt): TQuaternionRec;
Public | class operator Multiply(Q1, Q2: TQuaternionRec): TQuaternionRec;
Public | class operator Multiply(Q: TQuaternionRec; Sc: Extended): TQuaternionRec;
Public | class operator Multiply(Scalar: Extended; Q: TQuaternionRec) : TQuaternionRec;

Properties

Public property Element[index: Byte]: Extended read GetElement write SetElement;

Description

Fields

Private FData: array [0 .. 3] of Extended;

This item has no description.

Methods

Public constructor Create(Q: TVectorExt);

This item has no description.

Public function Inv: TQuaternionRec;

This item has no description.

Public function TruncateSTI: TQuaternionRec;

This item has no description.

Private function GetElement(Index: Byte): Extended;

This item has no description.

Private procedure SetElement(Index: Byte; Value: Extended);

This item has no description.

Public class operator Implicit(V: TVectorExt): TQuaternionRec;

This item has no description.

Public class operator Multiply(Q1, Q2: TQuaternionRec): TQuaternionRec;

This item has no description.

Public class operator Multiply(Q: TQuaternionRec; Sc: Extended): TQuaternionRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; Q: TQuaternionRec) : TQuaternionRec;

This item has no description.

Properties

Public property Element[index: Byte]: Extended read GetElement write SetElement;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVectorRec

Record TVectorRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVectorRec = record

Description

This item has no description.

Overview

Fields

Private | FData: TVectorExt;
Private | FCount: Word;

Methods

Public | constructor Create(V: TVectorExt); overload;
Public | constructor Create(ElementsCount: Word); overload;
Public | function Norm: Extended;
Public | function ScalarMult(V: TVectorRec): Extended;
Public | function SumOfElments: Extended;
Public | function SumOfSquares: Extended;
Public | function ToQuat: TQuaternionRec;
Public | function TruncateSTI: TVectorRec;
Private | function GetElement(Index: Word): Extended;
Public | procedure Fill(Value: Extended);
Private | procedure CheckUnique;
Private | procedure SetElement(Index: Word; Value: Extended);
Public | class operator Add(V1, V2: TVectorRec): TVectorRec;
Public | class operator Add(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Add(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Divide(V1, V2: TVectorRec): TVectorRec;
Public | class operator Divide(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Implicit(V: TVectorExt): TVectorRec;
Public | class operator Multiply(V1, V2: TVectorRec): TVectorRec;
Public | class operator Multiply(V: TVectorRec; Scalar: Extended): TVectorRec;
Public | class operator Multiply(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Subtract(V1, V2: TVectorRec): TVectorRec;
Public | class operator Subtract(Scalar: Extended; V: TVectorRec): TVectorRec;
Public | class operator Subtract(V: TVectorRec; Scalar: Extended): TVectorRec;

Properties

Public | property Count: Word read FCount;
Public | property Elements[index: Word]: Extended read GetElement write SetElement;

Description

Fields

Private FData: TVectorExt;

This item has no description.

Private FCount: Word;

This item has no description.

Methods

Public constructor Create(V: TVectorExt); overload;

This item has no description.

Public constructor Create(ElementsCount: Word); overload;

This item has no description.

Public function Norm: Extended;

This item has no description.

Public function ScalarMult(V: TVectorRec): Extended;

This item has no description.

Public function SumOfElments: Extended;

This item has no description.

Public function SumOfSquares: Extended;

This item has no description.

Public function ToQuat: TQuaternionRec;

This item has no description.

Public function TruncateSTI: TVectorRec;

This item has no description.

Private function GetElement(Index: Word): Extended;

This item has no description.

Public procedure Fill(Value: Extended);

This item has no description.

Private procedure CheckUnique;

This item has no description.

Private procedure SetElement(Index: Word; Value: Extended);

This item has no description.

Public class operator Add(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Add(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Add(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Divide(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Divide(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Implicit(V: TVectorExt): TVectorRec;

This item has no description.

Public class operator Multiply(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Multiply(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(V1, V2: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(Scalar: Extended; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Subtract(V: TVectorRec; Scalar: Extended): TVectorRec;

This item has no description.

Properties

Public property Count: Word read FCount;

This item has no description.

Public property Elements[index: Word]: Extended read GetElement write SetElement;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrixRec

Record TMatrixRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrixRec = record

Description

This item has no description.

Overview

Fields

Private | FData: TMatrixExt;
Private | FRowsCount: Word;
Private | FColsCount: Word;

Methods

Public | constructor Create(M: TMatrixExt); overload;
Public | constructor Create(RowsCount, ColsCount: Word); overload;
Public | constructor CreateDiag(Dim: Word; Value: Extended = 1.0);
Public | function Determinant: Extended;
Public | function Inv: TMatrixRec;
Public | function ToQuat: TQuaternionRec;
Public | function Trace: Extended;
Public | function Transp: TMatrixRec;
Public | function TruncateSTI: TMatrixRec;
Private | function Del(A: TMatrixRec; I, J: Integer; M: Integer): TMatrixRec;
Private | function Det(A: TMatrixRec; M: Integer): Extended;
Private | function GetCol(Col: Word): TVectorRec;
Private | function GetElement(Row, Col: Word): Extended;
Private | function GetRow(Row: Word): TVectorRec;
Public | procedure Fill(Scalar: Extended);
Private | procedure CheckUnique;
Private | procedure SetCol(Col: Word; Value: TVectorRec);
Private | procedure SetElement(Row, Col: Word; Value: Extended);
Private | procedure SetRow(Row: Word; Value: TVectorRec);
Public | class operator Add(M1, M2: TMatrixRec): TMatrixRec;
Public | class operator Implicit(M: TMatrixExt): TMatrixRec;
Public | class operator Multiply(V: TVectorRec; M: TMatrixRec): TVectorRec;
Public | class operator Multiply(M: TMatrixRec; V: TVectorRec): TVectorRec;
Public | class operator Multiply(M1, M2: TMatrixRec): TMatrixRec;
Public | class operator Multiply(M: TMatrixRec; Q: TQuaternionRec): TQuaternionRec;
Public | class operator Multiply(Scalar: Extended; M: TMatrixRec): TMatrixRec;
Public | class operator Multiply(M: TMatrixRec; Scalar: Extended): TMatrixRec;
Public | class operator Subtract(M1, M2: TMatrixRec): TMatrixRec;

Properties

Public | property Col[Col: Word]: TVectorRec read GetCol write SetCol;
Public | property ColCount: Word read FColsCount;
Public | property Elements[Row,Col: Word]: Extended read GetElement write SetElement;
Public | property Row[Row: Word]: TVectorRec read GetRow write SetRow;
Public | property RowCount: Word read FRowsCount;

Description

Fields

Private FData: TMatrixExt;

This item has no description.

Private FRowsCount: Word;

This item has no description.

Private FColsCount: Word;

This item has no description.

Methods

Public constructor Create(M: TMatrixExt); overload;

This item has no description.

Public constructor Create(RowsCount, ColsCount: Word); overload;

This item has no description.

Public constructor CreateDiag(Dim: Word; Value: Extended = 1.0);

This item has no description.

Public function Determinant: Extended;

This item has no description.

Public function Inv: TMatrixRec;

This item has no description.

Public function ToQuat: TQuaternionRec;

This item has no description.

Public function Trace: Extended;

This item has no description.

Public function Transp: TMatrixRec;

This item has no description.

Public function TruncateSTI: TMatrixRec;

This item has no description.

Private function Del(A: TMatrixRec; I, J: Integer; M: Integer): TMatrixRec;

This item has no description.

Private function Det(A: TMatrixRec; M: Integer): Extended;

This item has no description.

Private function GetCol(Col: Word): TVectorRec;

This item has no description.

Private function GetElement(Row, Col: Word): Extended;

This item has no description.

Private function GetRow(Row: Word): TVectorRec;

This item has no description.

Public procedure Fill(Scalar: Extended);

sum on diagonal elements

Private procedure CheckUnique;

This item has no description.

Private procedure SetCol(Col: Word; Value: TVectorRec);

This item has no description.

Private procedure SetElement(Row, Col: Word; Value: Extended);

This item has no description.

Private procedure SetRow(Row: Word; Value: TVectorRec);

This item has no description.

Public class operator Add(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Implicit(M: TMatrixExt): TMatrixRec;

This item has no description.

Public class operator Multiply(V: TVectorRec; M: TMatrixRec): TVectorRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; V: TVectorRec): TVectorRec;

This item has no description.

Public class operator Multiply(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; Q: TQuaternionRec): TQuaternionRec;

This item has no description.

Public class operator Multiply(Scalar: Extended; M: TMatrixRec): TMatrixRec;

This item has no description.

Public class operator Multiply(M: TMatrixRec; Scalar: Extended): TMatrixRec;

This item has no description.

Public class operator Subtract(M1, M2: TMatrixRec): TMatrixRec;

This item has no description.

Properties

Public property Col[Col: Word]: TVectorRec read GetCol write SetCol;

This item has no description.

Public property ColCount: Word read FColsCount;

This item has no description.

Public property Elements[Row,Col: Word]: Extended read GetElement write SetElement;

This item has no description.

Public property Row[Row: Word]: TVectorRec read GetRow write SetRow;

This item has no description.

Public property RowCount: Word read FRowsCount;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuaternionHelper

Record TQuaternionHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuaternionHelper = record helper for TQuaternionRec

Description

This item has no description.

Overview

Methods

Public function ToMatrix: TMatrixRec;

Description

Methods

Public function ToMatrix: TMatrixRec;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVectorHelper

Record TVectorHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVectorHelper = record helper for TVectorRec

Description

This item has no description.

Overview

Methods

Public function ToDiagMatrix: TMatrixRec;

Description

Methods

Public function ToDiagMatrix: TMatrixRec;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Class TDim

Class TDim

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TDim = class(TCustomAttribute)

Description

This item has no description.

Hierarchy

  • TCustomAttribute
  • TDim

Overview

Fields

Private | FRowCount: Integer;
Private | FColCount: Integer;

Methods

Public constructor Create(ARowCount: Integer; AColCount: Integer = 0); overload;

Properties

Public | property ColCount: Integer read FColCount;
Public | property RowCount: Integer read FRowCount;

Description

Fields

Private FRowCount: Integer;

This item has no description.

Private FColCount: Integer;

This item has no description.

Methods

Public constructor Create(ARowCount: Integer; AColCount: Integer = 0); overload;

This item has no description.

Properties

Public property ColCount: Integer read FColCount;

This item has no description.

Public property RowCount: Integer read FRowCount;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVertexRec

Record TVertexRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVertexRec = record

Description

This item has no description.

Overview

Fields

Public | P: TVector3f;
Public | N: TVector3f;
Public | Density: Extended;

Description

Fields

Public P: TVector3f;

This item has no description.

Public N: TVector3f;

This item has no description.

Public Density: Extended;

Position and Normal


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TFaceRec

Record TFaceRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TFaceRec = record

Description

This item has no description.

Overview

Fields

Public | Normal: TVector3f;
Public | V1: TVector3f;
Public | V2: TVector3f;
Public | V3: TVector3f;
Public | Padding: array [0 .. 1] of Byte;

Description

Fields

Public Normal: TVector3f;

This item has no description.

Public V1: TVector3f;

This item has no description.

Public V2: TVector3f;

vertex 1

Public V3: TVector3f;

vertex 2

Public Padding: array [0 .. 1] of Byte;

vertex 3


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TPoint2DRec

Record TPoint2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TPoint2DRec = record

Description

This item has no description.

Overview

Fields

Public | X: Extended;
Public | Y: Extended;

Methods

Public | function Add(const APoint2D: TPoint2DRec): TPoint2DRec;
Public | function Create(X, Y: Extended): TPoint2DRec;
Public | function Distance(const APoint2D: TPoint2DRec): Extended;
Public | function Length: Extended;
Public | class function PointInCircle(const Point, Center: TPoint2DRec; const Radius: Integer): Boolean; static; inline;
Public | procedure Offset(const ADeltaX, ADeltaY: Extended);
Public | procedure SetPosition(const X, Y: Extended);

Description

Fields

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Methods

Public function Add(const APoint2D: TPoint2DRec): TPoint2DRec;

This item has no description.

Public function Create(X, Y: Extended): TPoint2DRec;

This item has no description.

Public function Distance(const APoint2D: TPoint2DRec): Extended;

distance to origin

Public function Length: Extended;

This item has no description.

Public class function PointInCircle(const Point, Center: TPoint2DRec; const Radius: Integer): Boolean; static; inline;

This item has no description.

Public procedure Offset(const ADeltaX, ADeltaY: Extended);

This item has no description.

Public procedure SetPosition(const X, Y: Extended);


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TPoint3DRec

Record TPoint3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TPoint3DRec = record

Description

This item has no description.

Overview

Fields

Public | X: Extended;
Public | Y: Extended;
Public | Z: Extended;

Methods

Public | function Add(const AGLPoint3D: TPoint3DRec): TPoint3DRec;
Public | function Create(X, Y, Z: Extended): TPoint3DRec;
Public | function Distance(const APoint3D: TPoint3DRec): Extended;
Public | function Length: Single;
Public | procedure Offset(const ADeltaX, ADeltaY, ADeltaZ: Extended);
Public | procedure SetPosition(const X, Y, Z: Extended);

Description

Fields

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public Z: Extended;

This item has no description.

Methods

Public function Add(const AGLPoint3D: TPoint3DRec): TPoint3DRec;

This item has no description.

Public function Create(X, Y, Z: Extended): TPoint3DRec;

This item has no description.

Public function Distance(const APoint3D: TPoint3DRec): Extended;

distance to origin

Public function Length: Single;

This item has no description.

Public procedure Offset(const ADeltaX, ADeltaY, ADeltaZ: Extended);

This item has no description.

Public procedure SetPosition(const X, Y, Z: Extended);


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVoxelRec

Record TVoxelRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVoxelRec = record

Description

This item has no description.

Overview

Fields

Public | P: TVector3f;
Public | Density: TScalarValue;
Public | Status: TVoxelStatus;

Description

Fields

Public P: TVector3f;

This item has no description.

Public Density: TScalarValue;

This item has no description.

Public Status: TVoxelStatus;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVector2DRec

Record TVector2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVector2DRec = record

Description

This item has no description.

Overview

Fields

Public | V: TVector2DType;
Public | X: Extended;
Public | Y: Extended;
Public | W: Extended;

Methods

Public | function Add(const AVector2D: TVector2DRec): TVector2DRec;
Public | function Create(const AX, AY, AW: Single): TVector2DRec;
Public | function CrossProduct(const AVector: TVector2DRec): TVector2DRec;
Public | function DotProduct(const AVector: TVector2DRec): Extended;
Public | function Length: Extended;
Public | function Norm: Extended;
Public | function Normalize: TVector2DRec;

Description

Fields

Public V: TVector2DType;

This item has no description.

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public W: Extended;

This item has no description.

Methods

Public function Add(const AVector2D: TVector2DRec): TVector2DRec;

This item has no description.

Public function Create(const AX, AY, AW: Single): TVector2DRec;

This item has no description.

Public function CrossProduct(const AVector: TVector2DRec): TVector2DRec;

This item has no description.

Public function DotProduct(const AVector: TVector2DRec): Extended;

This item has no description.

Public function Length: Extended;

This item has no description.

Public function Norm: Extended;

This item has no description.

Public function Normalize: TVector2DRec;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TVector3DRec

Record TVector3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TVector3DRec = record

Description

This item has no description.

Overview

Fields

Public | V: TVector3DType;
Public | X: Extended;
Public | Y: Extended;
Public | Z: Extended;
Public | W: Extended;

Methods

Public | function Add(const AVector3D: TVector3DRec): TVector3DRec;
Public | function Create(const AX, AY, AZ, AW: Single): TVector3DRec;
Public | function CrossProduct(const AVector3D: TVector3D): TVector3D;
Public | function DotProduct(const AVector3D: TVector3D): Single; inline;
Public | function Length: Single;
Public | function Norm: Single;
Public | function Normalize: TVector3DRec;

Description

Fields

Public V: TVector3DType;

This item has no description.

Public X: Extended;

This item has no description.

Public Y: Extended;

This item has no description.

Public Z: Extended;

This item has no description.

Public W: Extended;

This item has no description.

Methods

Public function Add(const AVector3D: TVector3DRec): TVector3DRec;

This item has no description.

Public function Create(const AX, AY, AZ, AW: Single): TVector3DRec;

This item has no description.

Public function CrossProduct(const AVector3D: TVector3D): TVector3D;

This item has no description.

Public function DotProduct(const AVector3D: TVector3D): Single; inline;

This item has no description.

Public function Length: Single;

This item has no description.

Public function Norm: Single;

This item has no description.

Public function Normalize: TVector3DRec;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrix2DRec

Record TMatrix2DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrix2DRec = record

Description

This item has no description.

Overview

Fields

Public | M: TMatrix2DType;
Public | e11: Single;
Public | e12: Single;
Public | e13: Single;
Public | e21: Single;
Public | e22: Single;
Public | e23: Single;
Public | e31: Single
Public | e32: Single
Public | e33: Single

Description

Fields

Public M: TMatrix2DType;

This item has no description.

Public e11: Single;

This item has no description.

Public e12: Single;

This item has no description.

Public e13: Single;

This item has no description.

Public e21: Single;

This item has no description.

Public e22: Single;

This item has no description.

Public e23: Single;

This item has no description.

Public e31: Single

This item has no description.

Public e32: Single

This item has no description.

Public e33: Single


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TMatrix3DRec

Record TMatrix3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMatrix3DRec = record

Description

This item has no description.

Overview

Fields

Public | M: TMatrix3DType;
Public | e11: Single;
Public | e12: Single;
Public | e13: Single;
Public | e14: Single;
Public | e21: Single;
Public | e22: Single;
Public | e23: Single;
Public | e24: Single;
Public | e31: Single;
Public | e32: Single;
Public | e33: Single;
Public | e34: Single;
Public | e41: Single
Public | e42: Single
Public | e43: Single
Public | e44: Single

Description

Fields

Public M: TMatrix3DType;

This item has no description.

Public e11: Single;

This item has no description.

Public e12: Single;

This item has no description.

Public e13: Single;

This item has no description.

Public e14: Single;

This item has no description.

Public e21: Single;

This item has no description.

Public e22: Single;

This item has no description.

Public e23: Single;

This item has no description.

Public e24: Single;

This item has no description.

Public e31: Single;

This item has no description.

Public e32: Single;

This item has no description.

Public e33: Single;

This item has no description.

Public e34: Single;

This item has no description.

Public e41: Single

This item has no description.

Public e42: Single

This item has no description.

Public e43: Single

This item has no description.

Public e44: Single


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TTriangleRec

Record TTriangleRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TTriangleRec = record

Description

This item has no description.

Overview

Fields

Public | V1: Integer;
Public | V2: Integer;
Public | V3: Integer;

Description

Fields

Public V1: Integer;

This item has no description.

Public V2: Integer;

This item has no description.

Public V3: Integer;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TMesh2DVert

Record TMesh2DVert

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMesh2DVert = record

Description

————————– Mesh simple record types ————————–

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | NX: Single;
Public | NY: Single;
Public | tU: Single;
Public | tV: Single;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public NX: Single;

This item has no description.

Public NY: Single;

This item has no description.

Public tU: Single;

This item has no description.

Public tV: Single;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Packed Record TMesh3DVert

Packed Record TMesh3DVert

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TMesh3DVert = packed record

Description

This item has no description.

Overview

Fields

Public | X: Single;
Public | Y: Single;
Public | Z: Single;
Public | NX: Single;
Public | NY: Single;
Public | NZ: Single;
Public | tU: Single;
Public | tV: Single;

Description

Fields

Public X: Single;

This item has no description.

Public Y: Single;

This item has no description.

Public Z: Single;

This item has no description.

Public NX: Single;

This item has no description.

Public NY: Single;

This item has no description.

Public NZ: Single;

This item has no description.

Public tU: Single;

This item has no description.

Public tV: Single;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TQuat3DRec

Record TQuat3DRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TQuat3DRec = record

Description

————————– Quaternion simple record types ————————–

Overview

Fields

Public | ImPart: TVector3DRec;
Public | RePart: Single;

Description

Fields

Public ImPart: TVector3DRec;

This item has no description.

Public RePart: Single;


GXSysHelp v.2.5: GLScene.VectorTypesExt: Record TBoxRec

Record TBoxRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.VectorTypesExt

Declaration

type TBoxRec = record

Description

This item has no description.

Overview

Fields

Public | ALeft: Single;
Public | ATop: Single;
Public | ANear: Single;
Public | ARight: Single;
Public | ABottom: Single;
Public | AFar: Single;

Description

Fields

Public ALeft: Single;

This item has no description.

Public ATop: Single;

This item has no description.

Public ANear: Single;

This item has no description.

Public ARight: Single;

This item has no description.

Public ABottom: Single;

This item has no description.

Public AFar: Single;


GXSysHelp v.2.5: GLScene.XCollection

Unit GLScene.XCollection

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.Strings
  • GLS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EFilerException |
Class TXCollectionItem |
Class TXCollection |

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);
procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);
function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;
function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;
procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

Types

TXCollectionItemClass = class of TXCollectionItem;

Description

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

Registers an event to be called when an XCollection is destroyed

procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

DeRegisters event

procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);

Registers a TXCollectionItem subclass for persistence requirements

procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);

Removes a TXCollectionItem subclass from the list

function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;

Retrieves a registered TXCollectionItemClass from its classname

function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

This item has no description.

Types

TXCollectionItemClass = class of TXCollectionItem;


GXSysHelp v.2.5: GLScene.XCollection: Class EFilerException

Class EFilerException

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type EFilerException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EFilerException


GXSysHelp v.2.5: GLScene.XCollection: Class TXCollectionItem

Class TXCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type TXCollectionItem = class(TGLInterfacedPersistent)

Description

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem

Overview

Fields

Private | FOwner: TXCollection;
Private | FName: string;

Methods

Public | constructor Create(aOwner: TXCollection); virtual;
Public | destructor Destroy; override;
Public | class function CanAddTo(collection: TXCollection): Boolean; virtual;
Public | class function FriendlyDescription: String; virtual;
Public | class function FriendlyName: String; virtual; abstract;
Public | function GetNamePath: string; override;
Public | function Index: integer;
Public | class function ItemCategory: string; virtual;
Public | class function UniqueItem: Boolean; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MoveDown;
Public | procedure MoveUp;

Properties

Published | property Name: string read FName write SetName;
Public | property Owner: TXCollection read FOwner;

Description

Fields

Private FOwner: TXCollection;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function CanAddTo(collection: TXCollection): Boolean; virtual;

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: String; virtual;

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; virtual; abstract;

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function GetNamePath: string; override;

This item has no description.

Public function Index: integer;

This item has no description.

Public class function ItemCategory: string; virtual;

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public class function UniqueItem: Boolean; virtual;

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure MoveDown;

This item has no description.

Public procedure MoveUp;

This item has no description.

Properties

Published property Name: string read FName write SetName;

This item has no description.

Public property Owner: TXCollection read FOwner;


GXSysHelp v.2.5: GLScene.XCollection: Class TXCollection

Class TXCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollection

Declaration

type TXCollection = class(TPersistent)

Description

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection

Overview

Fields

Private | FOwner: TPersistent;
Private | FList: TList;
Private | FCount: integer;
Private | FArchiveVersion: integer;

Methods

Public | constructor Create(aOwner: TPersistent); virtual;
Public | destructor Destroy; override;
Public | function Add(anItem: TXCollectionItem): integer;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; virtual;
Public | function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;
Public | function GetNamePath: string; override;
Public | function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;
Public | function IndexOf(anItem: TXCollectionItem): integer;
Public | function IndexOfClass(aClass: TXCollectionItemClass): integer;
Public | function IndexOfName(const aName: string): integer;
Public | class function ItemsClass: TXCollectionItemClass; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure Delete(Index: integer);
Public | procedure Loaded;
Public | procedure Remove(anItem: TXCollectionItem);

Properties

Public | property ArchiveVersion: integer read FArchiveVersion;
Public | property Count: integer read FCount;
Public | property Items[index: integer]: TXCollectionItem read GetItems;
Public | property Owner: TPersistent read FOwner write FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FList: TList;

This item has no description.

Private FCount: integer;

This item has no description.

Private FArchiveVersion: integer;

Archive Version is used to update the way data items is loaded

Methods

Public constructor Create(aOwner: TPersistent); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(anItem: TXCollectionItem): integer;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; virtual;

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;

Returns the first XCollection of the given class (or nil)

Public function GetNamePath: string; override;

This item has no description.

Public function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;

This item has no description.

Public function IndexOf(anItem: TXCollectionItem): integer;

This item has no description.

Public function IndexOfClass(aClass: TXCollectionItemClass): integer;

Returns the index of the first XCollectionItem of the given class (or -1)

Public function IndexOfName(const aName: string): integer;

Returns the index of the first XCollectionItem of the given name (or -1)

Public class function ItemsClass: TXCollectionItemClass; virtual;

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(Index: integer);

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure Remove(anItem: TXCollectionItem);

This item has no description.

Properties

Public property ArchiveVersion: integer read FArchiveVersion;

This item has no description.

Public property Count: integer read FCount;

This item has no description.

Public property Items[index: integer]: TXCollectionItem read GetItems;

This item has no description.

Public property Owner: TPersistent read FOwner write FOwner;


GXSysHelp v.2.5: GLScene.XCollectionRegister

Unit GLScene.XCollectionRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.TypInfo
  • GLScene.XCollection
  • FMxXCollectionEditor

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GLScene.XCollectionRegister: Class TXCollectionProperty

Class TXCollectionProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GLScene.XCollectionRegister

Declaration

type TXCollectionProperty = class(TClassProperty)

Description

ToDo DesignEditors, DesignIntf,

Hierarchy

  • TObject
  • TClassProperty
  • TXCollectionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.AnimatedSprite

Unit GXS.AnimatedSprite

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.XCollection
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GLScene.Strings
  • GXS.Scene
  • GXS.Context
  • GXS.Material
  • GXS.RenderContextInfo
  • GXS.BaseClasses
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSpriteAnimFrame |
Class TgxSpriteAnimFrameList |
Class TgxSpriteAnimMargins |
Class TgxSpriteAnimation |
Class TgxSpriteAnimationList |
Class TgxAnimatedSprite |

Types

TgxSpriteAnimationMode = (...);
TgxSpriteFrameDimensions = (...);

Description

Types

TgxSpriteAnimationMode = (...);

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.

Values
  • samNone
  • samPlayOnce
  • samLoop
  • samBounceForward
  • samBounceBackward
  • samLoopBackward
TgxSpriteFrameDimensions = (...);

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

Values
  • sfdAuto
  • sfdManual


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxSpriteAnimFrame

Class TgxSpriteAnimFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxSpriteAnimFrame = class(TXCollectionItem)

Description

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxSpriteAnimFrame

Overview

Fields

Private | FOffsetX: Integer;
Private | FOffsetY: Integer;
Private | FWidth: Integer;
Private | FHeight: Integer;

Methods

Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Private | procedure DoChanged;

Properties

Published | property Height: Integer read FHeight write SetHeight;
Published | property OffsetX: Integer read FOffsetX write SetOffsetX;
Published | property OffsetY: Integer read FOffsetY write SetOffsetY;
Published | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FOffsetX: Integer;

This item has no description.

Private FOffsetY: Integer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Methods

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure DoChanged;

This item has no description.

Properties

Published property Height: Integer read FHeight write SetHeight;

This item has no description.

Published property OffsetX: Integer read FOffsetX write SetOffsetX;

This item has no description.

Published property OffsetY: Integer read FOffsetY write SetOffsetY;

This item has no description.

Published property Width: Integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxSpriteAnimFrameList

Class TgxSpriteAnimFrameList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxSpriteAnimFrameList = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxSpriteAnimFrameList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxSpriteAnimMargins

Class TgxSpriteAnimMargins

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxSpriteAnimMargins = class(TPersistent)

Description

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

Hierarchy

  • TObject
  • TPersistent
  • TgxSpriteAnimMargins

Overview

Fields

Private | FOwner: TgxSpriteAnimation;
Private | FLeft: Integer;
Private | FTop: Integer;
Private | FRight: Integer;
Private | FBottom: Integer;

Methods

Public constructor Create(Animation: TgxSpriteAnimation);

Properties

Published | property Bottom: Integer read FBottom write SetBottom;
Published | property Left: Integer read FLeft write SetLeft;
Public | property Owner: TgxSpriteAnimation read FOwner;
Published | property Right: Integer read FRight write SetRight;
Published | property Top: Integer read FTop write SetTop;

Description

Fields

Private FOwner: TgxSpriteAnimation;

This item has no description.

Private FLeft: Integer;

This item has no description.

Private FTop: Integer;

This item has no description.

Private FRight: Integer;

This item has no description.

Private FBottom: Integer;

This item has no description.

Methods

Public constructor Create(Animation: TgxSpriteAnimation);

This item has no description.

Properties

Published property Bottom: Integer read FBottom write SetBottom;

This item has no description.

Published property Left: Integer read FLeft write SetLeft;

This item has no description.

Public property Owner: TgxSpriteAnimation read FOwner;

This item has no description.

Published property Right: Integer read FRight write SetRight;

This item has no description.

Published property Top: Integer read FTop write SetTop;


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxSpriteAnimation

Class TgxSpriteAnimation

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxSpriteAnimation = class(TXCollectionItem, IgxMaterialLibrarySupported)

Description

Animations define how the texture coordinates for each offset are to be determined.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxSpriteAnimation

Overview

Fields

Private | FCurrentFrame: NativeInt;
Private | FStartFrame: NativeInt;
Private | FEndFrame: NativeInt;
Private | FFrameWidth: NativeInt;
Private | FFrameHeight: NativeInt;
Private | FInterval: NativeInt;
Private | FFrames: TgxSpriteAnimFrameList;
Private | FLibMaterialName: TgxLibMaterialName;
Private | FLibMaterialCached: TgxLibMaterial;
Private | FDimensions: TgxSpriteFrameDimensions;
Private | FMargins: TgxSpriteAnimMargins;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Private | procedure DoChanged;

Properties

Published | property CurrentFrame: NativeInt read FCurrentFrame write SetCurrentFrame;
Published | property Dimensions: TgxSpriteFrameDimensions read FDimensions write SetDimensions;
Published | property EndFrame: NativeInt read FEndFrame write FEndFrame;
Published | property FrameHeight: NativeInt read FFrameHeight write SetFrameHeight;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Frames: TgxSpriteAnimFrameList read FFrames;
Published | property FrameWidth: NativeInt read FFrameWidth write SetFrameWidth;
Published | property Interval: NativeInt read FInterval write SetInterval;
Public | property LibMaterialCached: TgxLibMaterial read GetLibMaterialCached;
Published | property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property Margins: TgxSpriteAnimMargins read FMargins;
Published | property StartFrame: NativeInt read FStartFrame write FStartFrame;

Description

Fields

Private FCurrentFrame: NativeInt;

This item has no description.

Private FStartFrame: NativeInt;

This item has no description.

Private FEndFrame: NativeInt;

This item has no description.

Private FFrameWidth: NativeInt;

This item has no description.

Private FFrameHeight: NativeInt;

This item has no description.

Private FInterval: NativeInt;

This item has no description.

Private FFrames: TgxSpriteAnimFrameList;

This item has no description.

Private FLibMaterialName: TgxLibMaterialName;

This item has no description.

Private FLibMaterialCached: TgxLibMaterial;

This item has no description.

Private FDimensions: TgxSpriteFrameDimensions;

This item has no description.

Private FMargins: TgxSpriteAnimMargins;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure DoChanged;

This item has no description.

Properties

Published property CurrentFrame: NativeInt read FCurrentFrame write SetCurrentFrame;

The current showing frame for this animation.

Published property Dimensions: TgxSpriteFrameDimensions read FDimensions write SetDimensions;

Automatic or manual texture coordinate generation.

Published property EndFrame: NativeInt read FEndFrame write FEndFrame;

Defines the ending frame for auto dimension animations.

Published property FrameHeight: NativeInt read FFrameHeight write SetFrameHeight;

Height of each frame in an auto dimension animation.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

The number of frames per second for the animation. Will automatically calculate the Interval value when set. Precision will depend on Interval since Interval has priority.

Published property Frames: TgxSpriteAnimFrameList read FFrames;

Manual dimension animation frames. Stores the offsets and dimensions for each frame in the animation.

Published property FrameWidth: NativeInt read FFrameWidth write SetFrameWidth;

Width of each frame in an auto dimension animation.

Published property Interval: NativeInt read FInterval write SetInterval;

The number of milliseconds between each frame in the animation. Will automatically calculate the FrameRate value when set. Will override the TgxAnimatedSprite Interval is greater than zero.

Public property LibMaterialCached: TgxLibMaterial read GetLibMaterialCached;

This item has no description.

Published property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;

The name of the lib material the sprites associated material library for this animation.

Published property Margins: TgxSpriteAnimMargins read FMargins;

Sets cropping margins for auto dimension animations.

Published property StartFrame: NativeInt read FStartFrame write FStartFrame;

Defines the starting frame for auto dimension animations.


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxSpriteAnimationList

Class TgxSpriteAnimationList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxSpriteAnimationList = class(TXCollection)

Description

A collection for storing SpriteAnimation objects.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxSpriteAnimationList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GXSysHelp v.2.5: GXS.AnimatedSprite: Class TgxAnimatedSprite

Class TgxAnimatedSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AnimatedSprite

Declaration

type TgxAnimatedSprite = class(TgxBaseSceneObject)

Description

An animated version for using offset texture coordinate animation.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxAnimatedSprite

Overview

Fields

Private | FAnimations: TgxSpriteAnimationList;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FAnimationIndex: Integer;
Private | FInterval: Integer;
Private | FRotation: Integer;
Private | FPixelRatio: Integer;
Private | FMirrorU: Boolean;
Private | FMirrorV: Boolean;
Private | FAnimationMode: TgxSpriteAnimationMode;
Private | FCurrentFrameDelta: Double;
Private | FOnFrameChanged: TNotifyEvent;
Private | FOnEndFrameReached: TNotifyEvent;
Private | FOnStartFrameReached: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure NextFrame;

Properties

Published | property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;
Published | property AnimationMode: TgxSpriteAnimationMode read FAnimationMode write SetAnimationMode;
Published | property Animations: TgxSpriteAnimationList read FAnimations;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Interval: Integer read FInterval write SetInterval;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property PixelRatio: Integer read FPixelRatio write SetPixelRatio;
Published | property Position;
Published | property Rotation: Integer read FRotation write SetRotation;
Published | property Scale;
Published | property Visible;

Description

Fields

Private FAnimations: TgxSpriteAnimationList;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FAnimationIndex: Integer;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FRotation: Integer;

This item has no description.

Private FPixelRatio: Integer;

This item has no description.

Private FMirrorU: Boolean;

This item has no description.

Private FMirrorV: Boolean;

This item has no description.

Private FAnimationMode: TgxSpriteAnimationMode;

This item has no description.

Private FCurrentFrameDelta: Double;

This item has no description.

Private FOnFrameChanged: TNotifyEvent;

This item has no description.

Private FOnEndFrameReached: TNotifyEvent;

This item has no description.

Private FOnStartFrameReached: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure NextFrame;

Steps the current animation to the next frame

Properties

Published property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;

Index of the sprite animation to be used.

Published property AnimationMode: TgxSpriteAnimationMode read FAnimationMode write SetAnimationMode;

Playback mode for the current animation.

Published property Animations: TgxSpriteAnimationList read FAnimations;

A collection of animations. Stores the settings for animating then sprite.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

Sets the frames per second for the current animation. Automatically calculates the Interval. Precision will be restricted to the values of Interval since Interval takes priority.

Published property Interval: Integer read FInterval write SetInterval;

Sets the number of milliseconds between each frame. Will recalculate the Framerate when set. Will be overridden by the TgxSpriteAnimation Interval if it is greater than zero.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

The material library that stores the lib materials for the animations.

Published property MirrorU: Boolean read FMirrorU write SetMirrorU;

Mirror the generated texture coords in the U axis.

Published property MirrorV: Boolean read FMirrorV write SetMirrorV;

Mirror the generated texture coords in the V axis.

Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

An event fired when the animation reaches the end frame.

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

An event fired when the animation changes to it's next frame.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

An event fired when the animation reaches the start frame.

Published property PixelRatio: Integer read FPixelRatio write SetPixelRatio;

Used to automatically calculate the width and height of a sprite based on the size of the frame it is showing. For example, if PixelRatio is set to 100 and the current animation frame is 100 pixels wide it will set the width of the sprite to 1. If the frame is 50 pixels width the sprite will be 0.5 wide.

Published property Position;

This item has no description.

Published property Rotation: Integer read FRotation write SetRotation;

Rotates the sprite (in degrees).

Published property Scale;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.ApplicationFileIO

Unit GXS.ApplicationFileIO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • GXS.BaseClasses
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxApplicationFileIO |
Class TgxDataFile |

Functions and Procedures

function ApplicationFileIODefined: Boolean;
function FileStreamExists(const fileName: string): Boolean;
function CreateResourceStream(const ResName: string; ResType: PChar): TgxResourceStream;
function StrToResType(const AStrRes: string): TgxApplicationResource;

Types

TDataFileCapabilities = set of TgxDataFileCapability;
TgxAFIOCreateFileStream = function(const fileName: String; mode: Word): TStream;
TgxAFIOFileStreamEvent = procedure(const fileName: String; mode: Word; var Stream: TStream) of object;
TgxAFIOFileStreamExists = function(const fileName: String): Boolean;
TgxAFIOFileStreamExistsEvent = function(const fileName: String): Boolean of object;
TgxApplicationResource = (...);
TgxDataFileCapability = (...);
TgxDataFileClass = class of TgxDataFile;
TgxResourceStream = TResourceStream;

Constants

RC_DDS_Type = RT_RCDATA;
RC_JPG_Type = RT_RCDATA;
RC_XML_Type = RT_RCDATA;
RC_String_Type = RT_RCDATA;

Variables

vGXAFIOCreateFileStream: TgxAFIOCreateFileStream = nil;
vGXAFIOFileStreamExists: TgxAFIOFileStreamExists = nil;

Description

Functions and Procedures

function ApplicationFileIODefined: Boolean;

Returns true if an ApplicationFileIO has been defined

function FileStreamExists(const fileName: string): Boolean;

Queries is a file stream corresponding to the fileName exists.

function CreateResourceStream(const ResName: string; ResType: PChar): TgxResourceStream;

This item has no description.

function StrToResType(const AStrRes: string): TgxApplicationResource;

This item has no description.

Types

TDataFileCapabilities = set of TgxDataFileCapability;

This item has no description.

TgxAFIOCreateFileStream = function(const fileName: String; mode: Word): TStream;

This item has no description.

TgxAFIOFileStreamEvent = procedure(const fileName: String; mode: Word; var Stream: TStream) of object;

This item has no description.

TgxAFIOFileStreamExists = function(const fileName: String): Boolean;

This item has no description.

TgxAFIOFileStreamExistsEvent = function(const fileName: String): Boolean of object;

This item has no description.

TgxApplicationResource = (...);

This item has no description.

Values
  • aresNone
  • aresSplash
  • aresTexture
  • aresMaterial
  • aresSampler
  • aresFont
  • aresMesh
TgxDataFileCapability = (...);

This item has no description.

Values
  • dfcRead
  • dfcWrite
TgxDataFileClass = class of TgxDataFile;

This item has no description.

TgxResourceStream = TResourceStream;

This item has no description.

Constants

RC_DDS_Type = RT_RCDATA;

This item has no description.

RC_JPG_Type = RT_RCDATA;

This item has no description.

RC_XML_Type = RT_RCDATA;

This item has no description.

RC_String_Type = RT_RCDATA;

This item has no description.

Variables

vGXAFIOCreateFileStream: TgxAFIOCreateFileStream = nil;

This item has no description.

vGXAFIOFileStreamExists: TgxAFIOFileStreamExists = nil;


GXSysHelp v.2.5: GXS.ApplicationFileIO: Class TgxApplicationFileIO

Class TgxApplicationFileIO

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ApplicationFileIO

Declaration

type TgxApplicationFileIO = class(TComponent)

Description

Allows specifying a custom behaviour for TFileStream.Create. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxApplicationFileIO

Overview

Fields

Private | FOnFileStream: TgxAFIOFileStreamEvent;
Private | FOnFileStreamExists: TgxAFIOFileStreamExistsEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property OnFileStream: TgxAFIOFileStreamEvent read FOnFileStream write FOnFileStream;
Published | property OnFileStreamExists: TgxAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Description

Fields

Private FOnFileStream: TgxAFIOFileStreamEvent;

This item has no description.

Private FOnFileStreamExists: TgxAFIOFileStreamExistsEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property OnFileStream: TgxAFIOFileStreamEvent read FOnFileStream write FOnFileStream;

Event that allows you to specify a stream for the file. Destruction of the stream is at the discretion of the code that invoked TFileStream.Create. Return nil to let the default mechanism take place (ie. attempt a regular file system access).

Published property OnFileStreamExists: TgxAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Event that allows you to specify if a stream for the file exists.


GXSysHelp v.2.5: GXS.ApplicationFileIO: Class TgxDataFile

Class TgxDataFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ApplicationFileIO

Declaration

type TgxDataFile = class(TgxUpdateAbleObject)

Description

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile

Overview

Fields

Private | FOwner: TPersistent;
Private | FResourceName: string;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Public | destructor Destroy; override;
Public | class function Capabilities: TDataFileCapabilities; virtual;
Public | function CreateCopy(AOwner: TPersistent): TgxDataFile; virtual;
Public | procedure LoadFromFile(const fileName: string); virtual;
Public | procedure LoadFromStream(Stream: TStream); virtual;
Public | procedure SaveToFile(const fileName: string); virtual;
Public | procedure SaveToStream(Stream: TStream); virtual;

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FResourceName: string;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function Capabilities: TDataFileCapabilities; virtual;

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TgxDataFile; virtual;

Duplicates Self and returns a copy. Subclasses should override this method to duplicate their data.

Public procedure LoadFromFile(const fileName: string); virtual;

This item has no description.

Public procedure LoadFromStream(Stream: TStream); virtual;

This item has no description.

Public procedure SaveToFile(const fileName: string); virtual;

This item has no description.

Public procedure SaveToStream(Stream: TStream); virtual;

This item has no description.

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Optionnal resource name. When using LoadFromFile/SaveToFile, the filename is placed in it, when using the Stream variants, the caller may place the resource name in it for parser use.


GXSysHelp v.2.5: GXS.ArchiveManager

Unit GXS.ArchiveManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.Strings
  • GXS.PersistentClasses
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBaseArchive |
Class TArchiveFileFormat |
Class TgxArchiveFileFormatsList |
Class TLibArchive |
Class TLibArchives |
Class TgxSArchiveManager |
Class EInvalidArchiveFile |

Functions and Procedures

function GetArchiveFileFormats: TgxArchiveFileFormatsList;
procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TgxBaseArchiveClass);
procedure UnregisterArchiveFormat(AClass: TgxBaseArchiveClass);
function GetArchiveManager: TgxSArchiveManager;
function ArcCreateFileStream(const fileName: string; mode: word): TStream;
function ArcFileStreamExists(const fileName: string): boolean;

Types

TCompressionLevel = (...);
TgxBaseArchiveClass = class of TgxBaseArchive;

Description

Functions and Procedures

function GetArchiveFileFormats: TgxArchiveFileFormatsList;

This item has no description.

procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TgxBaseArchiveClass);

This item has no description.

procedure UnregisterArchiveFormat(AClass: TgxBaseArchiveClass);

This item has no description.

function GetArchiveManager: TgxSArchiveManager;

Note! It's working only with one manager

function ArcCreateFileStream(const fileName: string; mode: word): TStream;

Users getting results after LoadFromFile with this functions

function ArcFileStreamExists(const fileName: string): boolean;

This item has no description.

Types

TCompressionLevel = (...);

This item has no description.

Values
  • clNone
  • clFastest
  • clDefault
  • clMax
  • clLevel1
  • clLevel2
  • clLevel3
  • clLevel4
  • clLevel5
  • clLevel6
  • clLevel7
  • clLevel8
  • clLevel9
TgxBaseArchiveClass = class of TgxBaseArchive;


GXSysHelp v.2.5: GXS.ArchiveManager: Class TgxBaseArchive

Class TgxBaseArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TgxBaseArchive = class(TgxDataFile)

Description

Base classes for archivers

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseArchive

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; virtual; abstract;
Public | function GetContent(ContentName: string): TStream; overload; virtual; abstract;
Public | function GetContent(index: integer): TStream; overload; virtual; abstract;
Public | function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;
Public | function GetContentSize(ContentName: string): integer; overload; virtual; abstract;
Public | function GetContentSize(index: integer): integer; overload; virtual; abstract;
Public | procedure AddFromFile(FileName, Path: string); virtual; abstract;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;
Public | procedure Clear; virtual; abstract;
Public | procedure Extract(index: integer; NewName: string); overload; virtual; abstract;
Public | procedure Extract(ContentName, NewName: string); overload; virtual; abstract;
Public | procedure RemoveContent(index: integer); overload; virtual; abstract;
Public | procedure RemoveContent(ContentName: string); overload; virtual; abstract;

Properties

Public | property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;
Public | property ContentList: TStrings read FContentList;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(ContentName: string): boolean; virtual; abstract;

This item has no description.

Public function GetContent(ContentName: string): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContent(index: integer): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;

This item has no description.

Public function GetContentSize(ContentName: string): integer; overload; virtual; abstract;

This item has no description.

Public function GetContentSize(index: integer): integer; overload; virtual; abstract;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); virtual; abstract;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;

This item has no description.

Public procedure Clear; virtual; abstract;

This item has no description.

Public procedure Extract(index: integer; NewName: string); overload; virtual; abstract;

This item has no description.

Public procedure Extract(ContentName, NewName: string); overload; virtual; abstract;

This item has no description.

Public procedure RemoveContent(index: integer); overload; virtual; abstract;

This item has no description.

Public procedure RemoveContent(ContentName: string); overload; virtual; abstract;

This item has no description.

Properties

Public property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;

This item has no description.

Public property ContentList: TStrings read FContentList;


GXSysHelp v.2.5: GXS.ArchiveManager: Class TArchiveFileFormat

Class TArchiveFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TArchiveFileFormat = class(TObject)

Description

Registered archives for using extentions, e.g.: GLFilePak,GLFileZLib

Hierarchy

  • TObject
  • TArchiveFileFormat

Overview

Fields

Public | BaseArchiveClass: TgxBaseArchiveClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public BaseArchiveClass: TgxBaseArchiveClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: Integer;


GXSysHelp v.2.5: GXS.ArchiveManager: Class TgxArchiveFileFormatsList

Class TgxArchiveFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TgxArchiveFileFormatsList = class(TgxPersistentObjectList)

Description

List of registered classes

Hierarchy

  • TgxPersistentObjectList
  • TgxArchiveFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TgxBaseArchiveClass;
Public | function FindFromFileName(const fileName: string): TgxBaseArchiveClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxBaseArchiveClass);
Public | procedure Remove(AClass: TgxBaseArchiveClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(ext: string): TgxBaseArchiveClass;

This item has no description.

Public function FindFromFileName(const fileName: string): TgxBaseArchiveClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxBaseArchiveClass);

This item has no description.

Public procedure Remove(AClass: TgxBaseArchiveClass);


GXSysHelp v.2.5: GXS.ArchiveManager: Class TLibArchive

Class TLibArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TLibArchive = class(TCollectionItem)

Description

To work with several archives simultaniously collections implemented Item to work with one archive

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TLibArchive

Overview

Fields

Private | vArchive: TgxBaseArchive;
Private | ArcClass: TgxBaseArchiveClass;
Private | FFileName: string;
Private | FName: string;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetContent(aContentName: string): TStream; overload;
Public | function GetContent(aindex: integer): TStream; overload;
Public | function GetContentSize(aindex: integer): integer; overload;
Public | function GetContentSize(aContentName: string): integer; overload;
Private | function GetCompressionLevel: TCompressionLevel;
Private | function GetContentList: TStrings;
Public | procedure AddFromFile(aFileName, aPath: string); overload;
Public | procedure AddFromFile(aFileName: string); overload;
Public | procedure AddFromStream(aContentName: string; aF: TStream); overload;
Public | procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;
Public | procedure Clear;
Public | procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);
Public | procedure Extract(aindex: integer; aNewName: string); overload;
Public | procedure Extract(aContentName, aNewName: string); overload;
Public | procedure LoadFromFile(aFileName: string); overload;
Public | procedure LoadFromFile(aFileName, aAchiverType: string); overload;
Public | procedure RemoveContent(aContentName: string); overload;
Public | procedure RemoveContent(aindex: integer); overload;
Private | procedure SetCompressionLevel(aValue: TCompressionLevel);
Private | procedure SetName(const val: string);

Properties

Public | property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clNone;
Public | property ContentList: TStrings read GetContentList;
Public | property FileName: string read FFileName;
Published | property Name: string read FName write SetName;

Description

Fields

Private vArchive: TgxBaseArchive;

This item has no description.

Private ArcClass: TgxBaseArchiveClass;

This item has no description.

Private FFileName: string;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(aContentName: string): boolean;

This item has no description.

Public function GetContent(aContentName: string): TStream; overload;

This item has no description.

Public function GetContent(aindex: integer): TStream; overload;

This item has no description.

Public function GetContentSize(aindex: integer): integer; overload;

This item has no description.

Public function GetContentSize(aContentName: string): integer; overload;

This item has no description.

Private function GetCompressionLevel: TCompressionLevel;

This item has no description.

Private function GetContentList: TStrings;

This item has no description.

Public procedure AddFromFile(aFileName, aPath: string); overload;

This item has no description.

Public procedure AddFromFile(aFileName: string); overload;

This item has no description.

Public procedure AddFromStream(aContentName: string; aF: TStream); overload;

This item has no description.

Public procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);

This item has no description.

Public procedure Extract(aindex: integer; aNewName: string); overload;

This item has no description.

Public procedure Extract(aContentName, aNewName: string); overload;

This item has no description.

Public procedure LoadFromFile(aFileName: string); overload;

This item has no description.

Public procedure LoadFromFile(aFileName, aAchiverType: string); overload;

This item has no description.

Public procedure RemoveContent(aContentName: string); overload;

This item has no description.

Public procedure RemoveContent(aindex: integer); overload;

This item has no description.

Private procedure SetCompressionLevel(aValue: TCompressionLevel);

This item has no description.

Private procedure SetName(const val: string);

This item has no description.

Properties

Public property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clNone;

This item has no description.

Public property ContentList: TStrings read GetContentList;

This item has no description.

Public property FileName: string read FFileName;

This item has no description.

Published property Name: string read FName write SetName;


GXSysHelp v.2.5: GXS.ArchiveManager: Class TLibArchives

Class TLibArchives

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TLibArchives = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TLibArchives

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TLibArchive;
Public | function FindItemID(ID: integer): TLibArchive;
Public | function GetArchiveByFileName(const AName: string): TLibArchive;
Public | function GetFileNameOfArchive(aValue: TLibArchive): string;
Public | function GetLibArchiveByName(const AName: string): TLibArchive;
Public | function GetNameOfLibArchive(const Archive: TLibArchive): string;
Public | function IndexOf(const Item: TLibArchive): integer;
Public | function MakeUniqueName(const nameRoot: string): string;
Public | function Owner: TPersistent;

Properties

Public property Items[index: integer]: TLibArchive read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TLibArchive;

This item has no description.

Public function FindItemID(ID: integer): TLibArchive;

This item has no description.

Public function GetArchiveByFileName(const AName: string): TLibArchive;

Looking for an archive by the name of an open archive

Public function GetFileNameOfArchive(aValue: TLibArchive): string;

This item has no description.

Public function GetLibArchiveByName(const AName: string): TLibArchive;

This item has no description.

Public function GetNameOfLibArchive(const Archive: TLibArchive): string;

This item has no description.

Public function IndexOf(const Item: TLibArchive): integer;

This item has no description.

Public function MakeUniqueName(const nameRoot: string): string;

Looking for an necessary item

Public function Owner: TPersistent;

This item has no description.

Properties

Public property Items[index: integer]: TLibArchive read GetItems write SetItems;


GXSysHelp v.2.5: GXS.ArchiveManager: Class TgxSArchiveManager

Class TgxSArchiveManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type TgxSArchiveManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSArchiveManager

Overview

Fields

Private FArchives: TLibArchives;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetArchiveByFileName(const aName: string): TLibArchive;
Public | function GetContent(aContentName: string): TStream;
Public | function GetFileNameOfArchive(const aArchive: TLibArchive): string;
Public | function OpenArchive(aFileName, aAchiverType: string): TLibArchive; overload;
Public | function OpenArchive(aFileName: string): TLibArchive; overload;
Public | procedure CloseArchive(aArchive: TLibArchive);
Private | Procedure SetArchives(aValue: TLibArchives);

Properties

Published property Archives: TLibArchives read FArchives write SetArchives;

Description

Fields

Private FArchives: TLibArchives;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(aContentName: string): boolean;

This item has no description.

Public function GetArchiveByFileName(const aName: string): TLibArchive;

This item has no description.

Public function GetContent(aContentName: string): TStream;

This item has no description.

Public function GetFileNameOfArchive(const aArchive: TLibArchive): string;

This item has no description.

Public function OpenArchive(aFileName, aAchiverType: string): TLibArchive; overload;

This item has no description.

Public function OpenArchive(aFileName: string): TLibArchive; overload;

This item has no description.

Public procedure CloseArchive(aArchive: TLibArchive);

This item has no description.

Private Procedure SetArchives(aValue: TLibArchives);

This item has no description.

Properties

Published property Archives: TLibArchives read FArchives write SetArchives;


GXSysHelp v.2.5: GXS.ArchiveManager: Class EInvalidArchiveFile

Class EInvalidArchiveFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ArchiveManager

Declaration

type EInvalidArchiveFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EInvalidArchiveFile


GXSysHelp v.2.5: GXS.AsyncHDS

Unit GXS.AsyncHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

/ The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.HeightData

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxAsyncHDS |
Class TgxAsyncHDThread |

Types

TIdleEvent = procedure(Sender: TgxAsyncHDS; TilesUpdated: boolean) of object;
TNewTilePreparedEvent = procedure(Sender: TgxAsyncHDS; HeightData: TgxHeightData) of object;
TUseDirtyTiles = (...);

Description

Types

TIdleEvent = procedure(Sender: TgxAsyncHDS; TilesUpdated: boolean) of object;

This item has no description.

TNewTilePreparedEvent = procedure(Sender: TgxAsyncHDS; HeightData: TgxHeightData) of object;

This item has no description.

TUseDirtyTiles = (...);

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)

Values
  • dtNever
  • dtUntilReplaced
  • dtUntilAllReplaced


GXSysHelp v.2.5: GXS.AsyncHDS: Class TgxAsyncHDS

Class TgxAsyncHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AsyncHDS

Declaration

type TgxAsyncHDS = class(TgxHeightDataSourceFilter)

Description

This item has no description. Showing description inherited from TgxHeightDataSourceFilter.

Height Data Source Filter. This component sits between the TgxTerrainRenderer, and a real TgxHeightDataSource. i.e. TgxTerrainRenderer links to this. This links to the real TgxHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TgxHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TgxHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TgxHeightData object from the Source HDS's cache, before linking your texture. See the new version of TgxBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxHeightDataSourceFilter
  • TgxAsyncHDS

Overview

Fields

Private | FOnIdleEvent: TIdleEvent;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FUseDirtyTiles: TUseDirtyTiles;
Private | FTilesUpdated: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ThreadCount: integer;
Public | function TilesUpdated: boolean;
Public | procedure BeforePreparingData(HeightData: TgxHeightData); override;
Public | procedure NewTilePrepared(HeightData: TgxHeightData);
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;
Public | procedure ThreadIsIdle; override;
Public | procedure TilesUpdatedFlagReset;
Public | procedure WaitFor(TimeOut: integer = 2000);

Properties

Published | property Active;
Published | property MaxThreads;
Published | property OnIdle: TIdleEvent read FOnIdleEvent write FOnIdleEvent;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property UseDirtyTiles: TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;

Description

Fields

Private FOnIdleEvent: TIdleEvent;

This item has no description.

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FUseDirtyTiles: TUseDirtyTiles;

This item has no description.

Private FTilesUpdated: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

TilesUpdated:boolean;

Public destructor Destroy; override;

This item has no description.

Public function ThreadCount: integer;

This item has no description.

Public function TilesUpdated: boolean;

This function prevents the user from trying to write directly to this variable. FTilesUpdated if NOT threadsafe and should only be reset with TilesUpdatedFlagReset.

Public procedure BeforePreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.BeforePreparingData.

This is called BEFORE StartPreparing Data, but always from the main thread.

Public procedure NewTilePrepared(HeightData: TgxHeightData);

This item has no description.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure ThreadIsIdle; override;

This item has no description.

Public procedure TilesUpdatedFlagReset;

Returns true if tiles have been updated since the flag was last reset

Public procedure WaitFor(TimeOut: integer = 2000);

Wait for all running threads to finish. Should only be called after setting Active to false, to prevent new threads from starting.

Properties

Published property Active;

sets the maximum number of simultaineous threads that will prepare tiles.(>1 is rarely needed)

Published property MaxThreads;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxThreads.

Maximum number of background threads. If 0 (zero), multithreading is disabled and StartPreparingData will be called from the mainthread, and all preload requirements (queued TgxHeightData objects) will be loaded in sequence from the main thread. If 1, basic multithreading and queueing gets enabled, ie. StartPreparingData will be called from a thread, but from one thread only (ie. there is no need to implement a TgxHeightDataThread, just make sure StartPreparingData code is thread-safe). Other values (2 and more) are relevant only if you implement a TgxHeightDataThread subclass and fire it in StartPreparingData.

Published property OnIdle: TIdleEvent read FOnIdleEvent write FOnIdleEvent;

sets the TilesUpdatedFlag to false; (is ThreadSafe)

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

This item has no description.

Published property UseDirtyTiles: TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;


GXSysHelp v.2.5: GXS.AsyncHDS: Class TgxAsyncHDThread

Class TgxAsyncHDThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AsyncHDS

Declaration

type TgxAsyncHDThread = class(TgxHeightDataThread)

Description

This item has no description. Showing description inherited from TgxHeightDataThread.

A thread specialized for processing TgxHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TgxHeightDataThread
  • TgxAsyncHDThread

Overview

Fields

Public | Owner: TgxAsyncHDS;
Public | HDS: TgxHeightDataSource;

Methods

Public | Procedure Execute; override;
Public | Procedure Sync;

Description

Fields

Public Owner: TgxAsyncHDS;

This item has no description.

Public HDS: TgxHeightDataSource;

This item has no description.

Methods

Public Procedure Execute; override;

This item has no description.

Public Procedure Sync;


GXSysHelp v.2.5: GXS.AsyncTimer

Unit GXS.AsyncTimer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxAsyncTimer |

Constants

cDEFAULT_TIMER_INTERVAL = 1000;

Description

Constants

cDEFAULT_TIMER_INTERVAL = 1000;


GXSysHelp v.2.5: GXS.AsyncTimer: Class TgxAsyncTimer

Class TgxAsyncTimer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AsyncTimer

Declaration

type TgxAsyncTimer = class(TComponent)

Description

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxAsyncTimer

Overview

Fields

Private | FEnabled: Boolean;
Private | FOnTimer: TNotifyEvent;
Private | FTimerThread: TThread;
Private | FMutex: TCriticalSection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;
Published | property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;
Published | property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FOnTimer: TNotifyEvent;

This item has no description.

Private FTimerThread: TThread;

This item has no description.

Private FMutex: TCriticalSection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default False;

This item has no description.

Published property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;

This item has no description.

Published property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;

This item has no description.

Published property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;


GXSysHelp v.2.5: GXS.Atmosphere

Unit GXS.Atmosphere

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • GXS.Scene
  • GXS.Objects
  • GXS.Cadencer
  • GLScene.VectorGeometry
  • GXS.Context
  • GLScene.Strings
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLAtmosphereException |
Class TgxCustomAtmosphere |
Class TgxAtmosphere |

Types

TgxAtmosphereBlendingMode = (...);

Description

Types

TgxAtmosphereBlendingMode = (...);

With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big. With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

Values
  • abmOneMinusDstColor
  • abmOneMinusSrcAlpha


GXSysHelp v.2.5: GXS.Atmosphere: Class EGLAtmosphereException

Class EGLAtmosphereException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Atmosphere

Declaration

type EGLAtmosphereException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLAtmosphereException


GXSysHelp v.2.5: GXS.Atmosphere: Class TgxCustomAtmosphere

Class TgxCustomAtmosphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Atmosphere

Declaration

type TgxCustomAtmosphere = class(TgxBaseSceneObject)

Description

This class imitates an atmosphere around a planet.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomAtmosphere

Overview

Fields

Private | cosCache: array of Single;
Private | sinCache: array of Single;
Private | pVertex: PVectorArray;
Private | pColor: PVectorArray;
Private | FSlices: Integer;
Private | FBlendingMode: TgxAtmosphereBlendingMode;
Private | FPlanetRadius: Single;
Private | FAtmosphereRadius: Single;
Private | FOpacity: Single;
Private | FLowAtmColor: TgxColor;
Private | FHighAtmColor: TgxColor;
Private | FSun: TgxBaseSceneObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Private | function StoreAtmosphereRadius: Boolean;
Private | function StoreHighAtmColor: Boolean;
Private | function StoreLowAtmColor: Boolean;
Private | function StoreOpacity: Boolean;
Private | function StorePlanetRadius: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetOptimalAtmosphere(const ARadius: Single);
Public | procedure SetOptimalAtmosphere2(const ARadius: Single);
Public | procedure TogleBlendingMode;
Private | procedure EnableGLBlendingMode(StateCache: TgxStateCache);
Private | procedure SetAtmosphereRadius(const Value: Single);
Private | procedure SetHighAtmColor(const AValue: TgxColor);
Private | procedure SetLowAtmColor(const AValue: TgxColor);
Private | procedure SetPlanetRadius(const Value: Single);
Private | procedure SetSlices(const Value: Integer);
Private | procedure SetSun(const Value: TgxBaseSceneObject);

Properties

Public | property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;
Public | property BlendingMode: TgxAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;
Public | property HighAtmColor: TgxColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;
Public | property LowAtmColor: TgxColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;
Public | property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;
Public | property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;
Public | property Slices: Integer read FSlices write SetSlices default 60;
Public | property Sun: TgxBaseSceneObject read FSun write SetSun;

Description

Fields

Private cosCache: array of Single;

Used in DoRenderl

Private sinCache: array of Single;

Used in DoRenderl

Private pVertex: PVectorArray;

This item has no description.

Private pColor: PVectorArray;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FBlendingMode: TgxAtmosphereBlendingMode;

This item has no description.

Private FPlanetRadius: Single;

This item has no description.

Private FAtmosphereRadius: Single;

This item has no description.

Private FOpacity: Single;

This item has no description.

Private FLowAtmColor: TgxColor;

This item has no description.

Private FHighAtmColor: TgxColor;

This item has no description.

Private FSun: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

Used to determine extents.

Private function StoreAtmosphereRadius: Boolean;

This item has no description.

Private function StoreHighAtmColor: Boolean;

This item has no description.

Private function StoreLowAtmColor: Boolean;

This item has no description.

Private function StoreOpacity: Boolean;

This item has no description.

Private function StorePlanetRadius: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

changes between 2 blending modes Standard component stuff.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Main rendering procedure.

Public procedure SetOptimalAtmosphere(const ARadius: Single);

This item has no description.

Public procedure SetOptimalAtmosphere2(const ARadius: Single);

absolute

Public procedure TogleBlendingMode;

relative

Private procedure EnableGLBlendingMode(StateCache: TgxStateCache);

This item has no description.

Private procedure SetAtmosphereRadius(const Value: Single);

This item has no description.

Private procedure SetHighAtmColor(const AValue: TgxColor);

This item has no description.

Private procedure SetLowAtmColor(const AValue: TgxColor);

This item has no description.

Private procedure SetPlanetRadius(const Value: Single);

This item has no description.

Private procedure SetSlices(const Value: Integer);

This item has no description.

Private procedure SetSun(const Value: TgxBaseSceneObject);

This item has no description.

Properties

Public property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;

AtmosphereRadius > PlanetRadius!!!

Public property BlendingMode: TgxAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;

This item has no description.

Public property HighAtmColor: TgxColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;

This item has no description.

Public property LowAtmColor: TgxColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;

Use value slightly lower than actual radius, for antialiasing effect.

Public property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;

This item has no description.

Public property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;

This item has no description.

Public property Slices: Integer read FSlices write SetSlices default 60;

This item has no description.

Public property Sun: TgxBaseSceneObject read FSun write SetSun;


GXSysHelp v.2.5: GXS.Atmosphere: Class TgxAtmosphere

Class TgxAtmosphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Atmosphere

Declaration

type TgxAtmosphere = class(TgxCustomAtmosphere)

Description

This item has no description. Showing description inherited from TgxCustomAtmosphere.

This class imitates an atmosphere around a planet.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomAtmosphere
  • TgxAtmosphere

Overview

Properties

Published | property AtmosphereRadius;
Published | property Behaviours;
Published | property BlendingMode;
Published | property Effects;
Published | property HighAtmColor;
Published | property LowAtmColor;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Opacity;
Published | property PlanetRadius;
Published | property Position;
Published | property ShowAxes;
Published | property Slices;
Published | property Sun;
Published | property Visible;

Description

Properties

Published property AtmosphereRadius;

This item has no description. Showing description inherited from TgxCustomAtmosphere.AtmosphereRadius.

AtmosphereRadius > PlanetRadius!!!

Published property Behaviours;

This item has no description.

Published property BlendingMode;

This item has no description.

Published property Effects;

This item has no description.

Published property HighAtmColor;

This item has no description.

Published property LowAtmColor;

This item has no description. Showing description inherited from TgxCustomAtmosphere.LowAtmColor.

Use value slightly lower than actual radius, for antialiasing effect.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Opacity;

This item has no description.

Published property PlanetRadius;

This item has no description.

Published property Position;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property Slices;

This item has no description.

Published property Sun;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.AVIRecorder

Unit GXS.AVIRecorder

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • FMX.Controls
  • FMX.Forms
  • FMX.Extctrls
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.Types
  • GXS.Graphics
  • GXS.Scene
  • GXS.SceneViewer
  • Formats.VFW

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxAVIRecorder |

Types

PAVIStream = ˆIAVIStream;
TAVICompressor = (...);
TAVIImageRetrievalMode = (...);
TAVIRecorderPostProcessEvent = procedure(Sender: TObject; frame: TBitmap) of object;
TAVIRecorderState = (...);
TAVISizeRestriction = (...);

Description

Types

PAVIStream = ˆIAVIStream;

This item has no description.

TAVICompressor = (...);

This item has no description.

Values
  • acDefault
  • acShowDialog
  • acDivX
TAVIImageRetrievalMode = (...);

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution

Values
  • irmSnapShot
  • irmRenderToBitmap
  • irmBitBlt
TAVIRecorderPostProcessEvent = procedure(Sender: TObject; frame: TBitmap) of object;

This item has no description.

TAVIRecorderState = (...);

This item has no description.

Values
  • rsNone
  • rsRecording
TAVISizeRestriction = (...);

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

Values
  • srNoRestriction
  • srForceBlock2x2
  • srForceBlock4x4
  • srForceBlock8x8


GXSysHelp v.2.5: GXS.AVIRecorder: Class TgxAVIRecorder

Class TgxAVIRecorder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.AVIRecorder

Declaration

type TgxAVIRecorder = class(TComponent)

Description

Component to make it easy to record GLScene frames into an AVI file.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxAVIRecorder

Overview

Fields

Private | AVIBitmap: TBitmap;
Private | AVIFrameIndex: integer;
Private | AVI_DPI: integer;
Private | asi: TAVIStreamInfo;
Private | pfile: IAVIFile;
Private | Stream: IAVIStream;
Private | Stream_c: IAVIStream;
Private | FBitmapInfo: PBitmapInfoHeader;
Private | FBitmapBits: Pointer;
Private | FBitmapSize: Dword;
Private | FTempName: String;
Private | FAVIFilename: string;
Private | FFPS: byte;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FSizeRestriction: TAVISizeRestriction;
Private | FImageRetrievalMode: TAVIImageRetrievalMode;
Private | RecorderState: TAVIRecorderState;
Private | FOnPostProcessEvent: TAVIRecorderPostProcessEvent;
Private | FBuffer: TgxSceneBuffer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateAVIFile(DPI: integer = 0): boolean;
Public | function Recording: boolean;
Public | procedure AddAVIFrame(bmp: TBitmap); overload;
Public | procedure AddAVIFrame; overload;
Public | procedure CloseAVIFile(UserAbort: boolean = false);
Private | procedure SetGLXceneViewer(const Value: TgxSceneViewer);
Private | procedure SetHeight(const val: integer);
Private | procedure SetSizeRestriction(const val: TAVISizeRestriction);
Private | procedure SetVKNonVisualViewer(const Value: TgxNonVisualViewer);
Private | procedure SetWidth(const val: integer);

Properties

Published | property Compressor: TAVICompressor read FCompressor write FCompressor default acDefault;
Published | property Filename: String read FAVIFilename write FAVIFilename;
Published | property FPS: byte read FFPS write FFPS default 25;
Published | property GLXceneViewer: TgxSceneViewer read FGLXceneViewer write SetGLXceneViewer;
Published | property Height: integer read FHeight write SetHeight;
Published | property ImageRetrievalMode: TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;
Published | property OnPostProcessEvent: TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;
Published | property SizeRestriction: TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;
Published | property VKNonVisualViewer: TgxNonVisualViewer read FVKNonVisualViewer write SetVKNonVisualViewer;
Published | property Width: integer read FWidth write SetWidth;

Description

Fields

Private AVIBitmap: TBitmap;

This item has no description.

Private AVIFrameIndex: integer;

This item has no description.

Private AVI_DPI: integer;

This item has no description.

Private asi: TAVIStreamInfo;

This item has no description.

Private pfile: IAVIFile;

This item has no description.

Private Stream: IAVIStream;

This item has no description.

Private Stream_c: IAVIStream;

This item has no description.

Private FBitmapInfo: PBitmapInfoHeader;

AVI stream and stream to be compressed

Private FBitmapBits: Pointer;

This item has no description.

Private FBitmapSize: Dword;

This item has no description.

Private FTempName: String;

This item has no description.

Private FAVIFilename: string;

so that we know the filename to delete case of user abort

Private FFPS: byte;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FSizeRestriction: TAVISizeRestriction;

This item has no description.

Private FImageRetrievalMode: TAVIImageRetrievalMode;

This item has no description.

Private RecorderState: TAVIRecorderState;

This item has no description.

Private FOnPostProcessEvent: TAVIRecorderPostProcessEvent;

This item has no description.

Private FBuffer: TgxSceneBuffer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateAVIFile(DPI: integer = 0): boolean;

This item has no description.

Public function Recording: boolean;

This item has no description.

Public procedure AddAVIFrame(bmp: TBitmap); overload;

This item has no description.

Public procedure AddAVIFrame; overload;

This item has no description.

Public procedure CloseAVIFile(UserAbort: boolean = false);

This item has no description.

Private procedure SetGLXceneViewer(const Value: TgxSceneViewer);

This item has no description.

Private procedure SetHeight(const val: integer);

This item has no description.

Private procedure SetSizeRestriction(const val: TAVISizeRestriction);

This item has no description.

Private procedure SetVKNonVisualViewer(const Value: TgxNonVisualViewer);

This item has no description.

Private procedure SetWidth(const val: integer);

This item has no description.

Properties

Published property Compressor: TAVICompressor read FCompressor write FCompressor default acDefault;

This item has no description.

Published property Filename: String read FAVIFilename write FAVIFilename;

This item has no description.

Published property FPS: byte read FFPS write FFPS default 25;

This item has no description.

Published property GLXceneViewer: TgxSceneViewer read FGLXceneViewer write SetGLXceneViewer;

This item has no description.

Published property Height: integer read FHeight write SetHeight;

This item has no description.

Published property ImageRetrievalMode: TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;

This item has no description.

Published property OnPostProcessEvent: TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;

This item has no description.

Published property SizeRestriction: TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;

This item has no description.

Published property VKNonVisualViewer: TgxNonVisualViewer read FVKNonVisualViewer write SetVKNonVisualViewer;

This item has no description.

Published property Width: integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.BaseMeshSilhouette

Unit GXS.BaseMeshSilhouette

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.VectorFileObjects
  • GXS.Silhouette

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFaceGroupConnectivity |
Class TgxBaseMeshConnectivity |


GXSysHelp v.2.5: GXS.BaseMeshSilhouette: Class TgxFaceGroupConnectivity

Class TgxFaceGroupConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BaseMeshSilhouette

Declaration

type TgxFaceGroupConnectivity = class(TConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TBaseConnectivity
  • TConnectivity
  • TgxFaceGroupConnectivity

Overview

Fields

Private | FMeshObject: TgxMeshObject;
Private | FOwnsVertices: boolean;

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aMeshObject: TgxMeshObject; APrecomputeFaceNormal: boolean);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure RebuildEdgeList;
Private | procedure SetMeshObject(const Value: TgxMeshObject);

Properties

Public property MeshObject: TgxMeshObject read FMeshObject write SetMeshObject;

Description

Fields

Private FMeshObject: TgxMeshObject;

This item has no description.

Private FOwnsVertices: boolean;

This item has no description.

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;

This item has no description.

Public constructor CreateFromMesh(aMeshObject: TgxMeshObject; APrecomputeFaceNormal: boolean);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TConnectivity.Clear.

Clears out all connectivity information.

Public procedure RebuildEdgeList;

Builds the connectivity information.

Private procedure SetMeshObject(const Value: TgxMeshObject);

This item has no description.

Properties

Public property MeshObject: TgxMeshObject read FMeshObject write SetMeshObject;


GXSysHelp v.2.5: GXS.BaseMeshSilhouette: Class TgxBaseMeshConnectivity

Class TgxBaseMeshConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BaseMeshSilhouette

Declaration

type TgxBaseMeshConnectivity = class(TBaseConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TBaseConnectivity
  • TgxBaseMeshConnectivity

Overview

Fields

Private | FBaseMesh: TgxBaseMesh;
Private | FFaceGroupConnectivityList: TList;

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aBaseMesh: TgxBaseMesh);
Public | destructor Destroy; override;
Private | function GetConnectivityCount: integer;
Private | function GetFaceGroupConnectivity(i: integer): TgxFaceGroupConnectivity;
Public | procedure Clear(SaveFaceGroupConnectivity: boolean);
Public | procedure CreateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters; var aSilhouette: TgxSilhouette; AddToSilhouette: boolean);
Public | procedure RebuildEdgeList;
Private | procedure SetBaseMesh(const Value: TgxBaseMesh);

Properties

Public | property BaseMesh: TgxBaseMesh read FBaseMesh write SetBaseMesh;
Public | property ConnectivityCount: integer read GetConnectivityCount;
Public | property FaceGroupConnectivity[i: integer]: TgxFaceGroupConnectivity read GetFaceGroupConnectivity;

Description

Fields

Private FBaseMesh: TgxBaseMesh;

This item has no description.

Private FFaceGroupConnectivityList: TList;

This item has no description.

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;

This item has no description.

Public constructor CreateFromMesh(aBaseMesh: TgxBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetConnectivityCount: integer;

This item has no description.

Private function GetFaceGroupConnectivity(i: integer): TgxFaceGroupConnectivity;

This item has no description.

Public procedure Clear(SaveFaceGroupConnectivity: boolean);

This item has no description.

Public procedure CreateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters; var aSilhouette: TgxSilhouette; AddToSilhouette: boolean);

This item has no description.

Public procedure RebuildEdgeList;

Builds the connectivity information.

Private procedure SetBaseMesh(const Value: TgxBaseMesh);

This item has no description.

Properties

Public property BaseMesh: TgxBaseMesh read FBaseMesh write SetBaseMesh;

This item has no description.

Public property ConnectivityCount: integer read GetConnectivityCount;

This item has no description.

Public property FaceGroupConnectivity[i: integer]: TgxFaceGroupConnectivity read GetFaceGroupConnectivity;


GXSysHelp v.2.5: GXS.Behaviours

Unit GXS.Behaviours

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLScene.VectorTypes
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.BaseClasses
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDamping |
Class TgxBInertia |
Class TgxBAcceleration |

Functions and Procedures

function GetInertia(const AGLXceneObject: TgxBaseSceneObject): TgxBInertia;
function GetOrCreateInertia(behaviours: TgxBehaviours): TgxBInertia; overload;
function GetOrCreateInertia(obj: TgxBaseSceneObject): TgxBInertia; overload;
function GetOrCreateAcceleration(behaviours: TgxBehaviours): TgxBAcceleration; overload;
function GetOrCreateAcceleration(obj: TgxBaseSceneObject): TgxBAcceleration; overload;

Description

Functions and Procedures

function GetInertia(const AGLXceneObject: TgxBaseSceneObject): TgxBInertia;

Returns or creates the TgxBInertia within the given behaviours. This helper function is convenient way to access a TgxBInertia.

function GetOrCreateInertia(behaviours: TgxBehaviours): TgxBInertia; overload;

This item has no description.

function GetOrCreateInertia(obj: TgxBaseSceneObject): TgxBInertia; overload;

This item has no description.

function GetOrCreateAcceleration(behaviours: TgxBehaviours): TgxBAcceleration; overload;

Returns or creates the TgxBAcceleration within the given behaviours. This helper function is convenient way to access a TgxBAcceleration.

function GetOrCreateAcceleration(obj: TgxBaseSceneObject): TgxBAcceleration; overload;


GXSysHelp v.2.5: GXS.Behaviours: Class TgxDamping

Class TgxDamping

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Behaviours

Declaration

type TgxDamping = class(TgxUpdateAbleObject)

Description

Holds parameters for TgxScene basic damping model. Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas : damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics :). A note on the components : constant : use it for solid friction (will stop abruptly an object after decreasing its speed. linear : linear friction damping. quadratic : expresses viscosity.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDamping

Overview

Fields

Private | FConstant: single;
Private | FLinear: single;
Private | FQuadratic: single;

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsString(const damping: TgxDamping): string;
Public | function Calculate(speed, deltaTime: double): double;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader);
Public | procedure SetDamping(const constant: single = 0; const linear: single = 0; const quadratic: single = 0);
Public | procedure WriteToFiler(writer: TWriter);

Properties

Published | property Constant: single read FConstant write FConstant;
Published | property Linear: single read FLinear write FLinear;
Published | property Quadratic: single read FQuadratic write FQuadratic;

Description

Fields

Private FConstant: single;

This item has no description.

Private FLinear: single;

This item has no description.

Private FQuadratic: single;

This item has no description.

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsString(const damping: TgxDamping): string;

Returns a "[constant; linear; quadractic]" string

Public function Calculate(speed, deltaTime: double): double;

Calculates attenuated speed over deltaTime. Integration step is 0.01 sec, and the following formula is applied at each step: constant+linear*speed+quadratic*speedˆ2

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader);

This item has no description.

Public procedure SetDamping(const constant: single = 0; const linear: single = 0; const quadratic: single = 0);

Sets all damping parameters in a single call.

Public procedure WriteToFiler(writer: TWriter);

This item has no description.

Properties

Published property Constant: single read FConstant write FConstant;

This item has no description.

Published property Linear: single read FLinear write FLinear;

This item has no description.

Published property Quadratic: single read FQuadratic write FQuadratic;


GXSysHelp v.2.5: GXS.Behaviours: Class TgxBInertia

Class TgxBInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Behaviours

Declaration

type TgxBInertia = class(TgxBehaviour)

Description

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBInertia

Overview

Fields

Private | FMass: single;
Private | FTranslationSpeed: TgxCoordinates;
Private | FTurnSpeed: single;
Private | FRollSpeed: single;
Private | FPitchSpeed: single;
Private | FTranslationDamping: TgxDamping;
Private | FRotationDamping: TgxDamping;
Private | FDampingEnabled: boolean;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure ApplyForce(const deltaTime: double; const force: TVector4f);
Public | procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);
Public | procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TVector4f);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure MirrorTranslation;
Public | procedure SurfaceBounce(const surfaceNormal: TVector4f; restitution: single);

Properties

Published | property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;
Published | property Mass: single read FMass write FMass;
Published | property PitchSpeed: single read FPitchSpeed write FPitchSpeed;
Published | property RollSpeed: single read FRollSpeed write FRollSpeed;
Published | property RotationDamping: TgxDamping read FRotationDamping write SetRotationDamping;
Published | property TranslationDamping: TgxDamping read FTranslationDamping write SetTranslationDamping;
Published | property TranslationSpeed: TgxCoordinates read FTranslationSpeed write SetTranslationSpeed;
Published | property TurnSpeed: single read FTurnSpeed write FTurnSpeed;

Description

Fields

Private FMass: single;

This item has no description.

Private FTranslationSpeed: TgxCoordinates;

This item has no description.

Private FTurnSpeed: single;

This item has no description.

Private FRollSpeed: single;

This item has no description.

Private FPitchSpeed: single;

This item has no description.

Private FTranslationDamping: TgxDamping;

This item has no description.

Private FRotationDamping: TgxDamping;

This item has no description.

Private FDampingEnabled: boolean;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyForce(const deltaTime: double; const force: TVector4f);

Applies a timed force to the inertia. If Mass is null, nothing is done.

Public procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);

Applies a timed torque to the inertia (yuck!). This gets a "yuck!" because it is as false as the rest of the rotation model.

Public procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TVector4f);

Adds time-proportionned acceleration to the speed.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure MirrorTranslation;

Inverts the translation vector.

Public procedure SurfaceBounce(const surfaceNormal: TVector4f; restitution: single);

Bounce speed as if hitting a surface. restitution is the coefficient of restituted energy (1=no energy loss, 0=no bounce). The normal is NOT assumed to be normalized.

Properties

Published property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;

Enable/Disable damping (damping has a high cpu-cycle cost). Damping is enabled by default.

Published property Mass: single read FMass write FMass;

This item has no description.

Published property PitchSpeed: single read FPitchSpeed write FPitchSpeed;

This item has no description.

Published property RollSpeed: single read FRollSpeed write FRollSpeed;

This item has no description.

Published property RotationDamping: TgxDamping read FRotationDamping write SetRotationDamping;

Damping applied to rotation speed (yuck!). Well, this one is not "exact", like TranslationDamping, and neither it is "physical" since I'm reusing the mass and... and... well don't show this to your science teacher 8). Anyway that's easier to use than the realworld formulas, calculated faster, and properly used can give a good illusion of reality.

Published property TranslationDamping: TgxDamping read FTranslationDamping write SetTranslationDamping;

Damping applied to translation speed. Note that it is not "exactly" applied, ie. if damping would stop your object after 0.5 time unit, and your progression steps are of 1 time unit, there will be an integration error of 0.5 time unit.

Published property TranslationSpeed: TgxCoordinates read FTranslationSpeed write SetTranslationSpeed;

This item has no description.

Published property TurnSpeed: single read FTurnSpeed write FTurnSpeed;


GXSysHelp v.2.5: GXS.Behaviours: Class TgxBAcceleration

Class TgxBAcceleration

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Behaviours

Declaration

type TgxBAcceleration = class(TgxBehaviour)

Description

Applies a constant acceleration to a TgxBInertia.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBAcceleration

Overview

Fields

Private FAcceleration: TgxCoordinates;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;

Properties

Published property Acceleration: TgxCoordinates read FAcceleration write FAcceleration;

Description

Fields

Private FAcceleration: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Properties

Published property Acceleration: TgxCoordinates read FAcceleration write FAcceleration;


GXSysHelp v.2.5: GXS.BitmapFont

Unit GXS.BitmapFont

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.UITypes
  • FMX.Objects
  • FMX.Graphics
  • FMX.Types
  • GXS.XOpenGL
  • GXS.PersistentClasses
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Texture
  • GXS.State
  • GLScene.Utils
  • GXS.ImageUtils
  • GXS.Graphics
  • GXS.Color
  • GXS.BaseClasses
  • GXS.RenderContextInfo
  • GLScene.TextureFormat
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBitmapFontRange |
Class TgxBitmapFontRanges |
Record TCharInfo |
Class TgxCustomBitmapFont |
Class TgxBitmapFont |
Class TgxFlatText |

Types

PCharInfo = ˆTCharInfo;
TgxFlatTextOption = (...);
TgxFlatTextOptions = set of TgxFlatTextOption;

Description

Types

PCharInfo = ˆTCharInfo;

This item has no description.

TgxFlatTextOption = (...);

This item has no description.

Values
  • ftoTwoSided
TgxFlatTextOptions = set of TgxFlatTextOption;


GXSysHelp v.2.5: GXS.BitmapFont: Class TgxBitmapFontRange

Class TgxBitmapFontRange

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TgxBitmapFontRange = class(TCollectionItem)

Description

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxBitmapFontRange

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetStartASCII: WideString;
Private | function GetStopASCII: WideString;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;

Properties

Published | property CharCount: Integer read FCharCount;
Published | property StartASCII: WideString read GetStartASCII write SetStartASCII;
Published | property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;
Published | property StopASCII: WideString read GetStopASCII write SetStopASCII;
Published | property StopGlyphIdx: Integer read FStopGlyphIdx;

Description

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetStartASCII: WideString;

This item has no description.

Private function GetStopASCII: WideString;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Published property CharCount: Integer read FCharCount;

This item has no description.

Published property StartASCII: WideString read GetStartASCII write SetStartASCII;

This item has no description.

Published property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;

This item has no description.

Published property StopASCII: WideString read GetStopASCII write SetStopASCII;

This item has no description.

Published property StopGlyphIdx: Integer read FStopGlyphIdx;


GXSysHelp v.2.5: GXS.BitmapFont: Class TgxBitmapFontRanges

Class TgxBitmapFontRanges

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TgxBitmapFontRanges = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxBitmapFontRanges

Overview

Fields

Private FCharCount: Integer;

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;
Public | function Add(const StartASCII, StopASCII: AnsiChar) : TgxBitmapFontRange; overload;
Public | function Add(const StartASCII, StopASCII: WideChar) : TgxBitmapFontRange; overload;
Public | function Add: TgxBitmapFontRange; overload;
Public | function CharacterToTileIndex(aChar: WideChar): Integer;
Public | function FindItemID(ID: Integer): TgxBitmapFontRange;
Public | function TileIndexToChar(aIndex: Integer): WideChar;
Public | procedure NotifyChange;

Properties

Public | property CharacterCount: Integer read FCharCount;
Public | property Items[index: Integer]: TgxBitmapFontRange read GetItems write SetItems;

Description

Fields

Private FCharCount: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(const StartASCII, StopASCII: AnsiChar) : TgxBitmapFontRange; overload;

This item has no description.

Public function Add(const StartASCII, StopASCII: WideChar) : TgxBitmapFontRange; overload;

This item has no description.

Public function Add: TgxBitmapFontRange; overload;

This item has no description.

Public function CharacterToTileIndex(aChar: WideChar): Integer;

Converts an ASCII character into a tile index. Return -1 if character cannot be rendered.

Public function FindItemID(ID: Integer): TgxBitmapFontRange;

This item has no description.

Public function TileIndexToChar(aIndex: Integer): WideChar;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property CharacterCount: Integer read FCharCount;

Total number of characters in the ranges; cached for performance

Public property Items[index: Integer]: TgxBitmapFontRange read GetItems write SetItems;


GXSysHelp v.2.5: GXS.BitmapFont: Record TCharInfo

Record TCharInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TCharInfo = record

Description

This item has no description.

Overview

Fields

Public | l: word;
Public | t: word;
Public | w: word;

Description

Fields

Public l: word;

This item has no description.

Public t: word;

This item has no description.

Public w: word;


GXSysHelp v.2.5: GXS.BitmapFont: Class TgxCustomBitmapFont

Class TgxCustomBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TgxCustomBitmapFont = class(TgxUpdateAbleComponent)

Description

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomBitmapFont

Overview

Fields

Private | FRanges: TgxBitmapFontRanges;
Private | FGlyphs: TImage;
Private | FCharWidth: Integer;
Private | FCharHeight: Integer;
Private | FGlyphsIntervalX: Integer;
Private | FGlyphsIntervalY: Integer;
Private | FHSpace: Integer;
Private | FVSpace: Integer;
Private | FHSpaceFix: Integer;
Private | FUsers: TList;
Private | FMinFilter: TgxMinFilter;
Private | FMagFilter: TgxMagFilter;
Private | FTextureWidth: Integer;
Private | FTextureHeight: Integer;
Private | FTextRows: Integer;
Private | FTextCols: Integer;
Private | FGlyphsAlpha: TgxTextureImageAlpha;
Private | FTextures: TList;
Private | FTextureModified: boolean;
Private | FLastTexture: TgxTextureHandle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;
Public | function CharacterCount: Integer; virtual;
Public | function CharacterToTileIndex(aChar: WideChar): Integer; virtual;
Public | function GetCharWidth(Ch: WideChar): Integer;
Public | function TextWidth(const Text: UnicodeString): Integer;
Public | function TileIndexToChar(aIndex: Integer): WideChar; virtual;
Public | procedure CheckTexture(var ARci: TgxRenderContextInfo);
Public | procedure RegisterUser(anObject: TgxBaseSceneObject); virtual;
Public | procedure RenderString(var ARci: TgxRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TgxTextLayout; const aColor: TgxColorVector; aPosition: PVector4f = nil; aReverseY: boolean = False); overload; virtual;
Public | procedure TextOut(var rci: TgxRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TgxColorVector); overload;
Public | procedure TextOut(var rci: TgxRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TColor); overload;
Public | procedure UnRegisterUser(anObject: TgxBaseSceneObject); virtual;

Properties

Public | property CharHeight: Integer read FCharHeight write SetCharHeight default 16;
Public | property TextureHeight: Integer read FTextureHeight write FTextureHeight;
Public | property TextureWidth: Integer read FTextureWidth write FTextureWidth;

Description

Fields

Private FRanges: TgxBitmapFontRanges;

This item has no description.

Private FGlyphs: TImage;

This item has no description.

Private FCharWidth: Integer;

This item has no description.

Private FCharHeight: Integer;

This item has no description.

Private FGlyphsIntervalX: Integer;

This item has no description.

Private FGlyphsIntervalY: Integer;

This item has no description.

Private FHSpace: Integer;

This item has no description.

Private FVSpace: Integer;

This item has no description.

Private FHSpaceFix: Integer;

This item has no description.

Private FUsers: TList;

This item has no description.

Private FMinFilter: TgxMinFilter;

This item has no description.

Private FMagFilter: TgxMagFilter;

This item has no description.

Private FTextureWidth: Integer;

This item has no description.

Private FTextureHeight: Integer;

This item has no description.

Private FTextRows: Integer;

This item has no description.

Private FTextCols: Integer;

This item has no description.

Private FGlyphsAlpha: TgxTextureImageAlpha;

This item has no description.

Private FTextures: TList;

This item has no description.

Private FTextureModified: boolean;

This item has no description.

Private FLastTexture: TgxTextureHandle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;

Get the actual pixel width for this string.

Public function CharacterCount: Integer; virtual;

This item has no description.

Public function CharacterToTileIndex(aChar: WideChar): Integer; virtual;

This item has no description.

Public function GetCharWidth(Ch: WideChar): Integer;

Get the actual width for this char.

Public function TextWidth(const Text: UnicodeString): Integer;

This item has no description.

Public function TileIndexToChar(aIndex: Integer): WideChar; virtual;

This item has no description.

Public procedure CheckTexture(var ARci: TgxRenderContextInfo);

make texture if needed

Public procedure RegisterUser(anObject: TgxBaseSceneObject); virtual;

This item has no description.

Public procedure RenderString(var ARci: TgxRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TgxTextLayout; const aColor: TgxColorVector; aPosition: PVector4f = nil; aReverseY: boolean = False); overload; virtual;

Renders the given string at current position or at position given by the optional position variable. The current matrix is blindly used, meaning you can render all kinds of rotated and linear distorted text with this method, OpenGL Enable states are also possibly altered.

Public procedure TextOut(var rci: TgxRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TgxColorVector); overload;

A simpler canvas-style TextOut helper for RenderString. The rendering is reversed along Y by default, to allow direct use with TgxCanvas

Public procedure TextOut(var rci: TgxRenderContextInfo; X, Y: Single; const Text: UnicodeString; const Color: TColor); overload;

This item has no description.

Public procedure UnRegisterUser(anObject: TgxBaseSceneObject); virtual;

This item has no description.

Properties

Public property CharHeight: Integer read FCharHeight write SetCharHeight default 16;

Height of a single character.

Public property TextureHeight: Integer read FTextureHeight write FTextureHeight;

This item has no description.

Public property TextureWidth: Integer read FTextureWidth write FTextureWidth;


GXSysHelp v.2.5: GXS.BitmapFont: Class TgxBitmapFont

Class TgxBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TgxBitmapFont = class(TgxCustomBitmapFont)

Description

See TgxCustomBitmapFont. This class only publuishes some of the properties.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomBitmapFont
  • TgxBitmapFont

Overview

Properties

Published | property CharHeight;
Published | property CharWidth;
Published | property Glyphs;
Published | property GlyphsAlpha;
Published | property GlyphsIntervalX;
Published | property GlyphsIntervalY;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges;
Published | property VSpace;

Description

Properties

Published property CharHeight;

This item has no description. Showing description inherited from TgxCustomBitmapFont.CharHeight.

Height of a single character.

Published property CharWidth;

This item has no description.

Published property Glyphs;

This item has no description.

Published property GlyphsAlpha;

This item has no description.

Published property GlyphsIntervalX;

This item has no description.

Published property GlyphsIntervalY;

This item has no description.

Published property HSpace;

This item has no description.

Published property MagFilter;

This item has no description.

Published property MinFilter;

This item has no description.

Published property Ranges;

This item has no description.

Published property VSpace;


GXSysHelp v.2.5: GXS.BitmapFont: Class TgxFlatText

Class TgxFlatText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BitmapFont

Declaration

type TgxFlatText = class(TgxImmaterialSceneObject)

Description

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TgxBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxFlatText

Overview

Fields

Private | FBitmapFont: TgxCustomBitmapFont;
Private | FText: UnicodeString;
Private | FAlignment: TAlignment;
Private | FLayout: TgxTextLayout;
Private | FModulateColor: TgxColor;
Private | FOptions: TgxFlatTextOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: boolean); override;

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property BitmapFont: TgxCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TgxTextLayout read FLayout write SetLayout;
Published | property ModulateColor: TgxColor read FModulateColor write SetModulateColor;
Published | property Options: TgxFlatTextOptions read FOptions write SetOptions;
Published | property Text: UnicodeString read FText write SetText;

Description

Fields

Private FBitmapFont: TgxCustomBitmapFont;

This item has no description.

Private FText: UnicodeString;

This item has no description.

Private FAlignment: TAlignment;

This item has no description.

Private FLayout: TgxTextLayout;

This item has no description.

Private FModulateColor: TgxColor;

This item has no description.

Private FOptions: TgxFlatTextOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: boolean); override;

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;

Controls the text alignment (horizontal). Possible values : taLeftJustify, taRightJustify, taCenter

Published property BitmapFont: TgxCustomBitmapFont read FBitmapFont write SetBitmapFont;

Refers the bitmap font to use. The referred bitmap font component stores and allows access to individual character bitmaps.

Published property Layout: TgxTextLayout read FLayout write SetLayout;

Controls the text layout (vertical). Possible values : tlTop, tlCenter, tlBottom

Published property ModulateColor: TgxColor read FModulateColor write SetModulateColor;

Color modulation, can be used for fade in/out too.

Published property Options: TgxFlatTextOptions read FOptions write SetOptions;

Flat text options. ftoTwoSided : when set the text will be visible from its two sides even if faceculling is on (at the scene-level).

Published property Text: UnicodeString read FText write SetText;

Text to render. Be aware that only the characters available in the bitmap font will be rendered. CR LF sequences are allowed.


GXSysHelp v.2.5: GXS.Blur

Unit GXS.Blur

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • FMX.Graphics
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GXS.Scene
  • GXS.Coordinates
  • GLScene.VectorGeometry
  • GXS.Objects
  • GXS.BitmapFont
  • GXS.Texture
  • GXS.Material
  • GXS.HudObjects
  • GXS.Color
  • GXS.Graphics
  • GXS.Context
  • GXS.State
  • GLScene.Strings
  • GLScene.TextureFormat
  • GXS.BaseClasses
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TRGBPixel |
Class EGLMotionBlurException |
Class TgxBlur |
Class TgxMotionBlur |

Types

TgxAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TgxBitmap32; var DoBlur: boolean) of object;
TgxBlurkind = (...);
TgxBlurPreset = (...);
TRGBPixelBuffer = array of TRGBPixel;

Description

Types

TgxAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TgxBitmap32; var DoBlur: boolean) of object;

This item has no description.

TgxBlurkind = (...);

This item has no description.

Values
  • bNone
  • bSimple
  • bAdvanced
TgxBlurPreset = (...);

This item has no description.

Values
  • pNone
  • pGlossy
  • pBeastView
  • pOceanDepth
  • pDream
  • pOverBlur
  • pAdvancedBlur
TRGBPixelBuffer = array of TRGBPixel;


GXSysHelp v.2.5: GXS.Blur: Record TRGBPixel

Record TRGBPixel

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Blur

Declaration

type TRGBPixel = record

Description

This item has no description.

Overview

Fields

Public | R: GLubyte;
Public | G: GLubyte;
Public | B: GLubyte;

Description

Fields

Public R: GLubyte;

This item has no description.

Public G: GLubyte;

This item has no description.

Public B: GLubyte;


GXSysHelp v.2.5: GXS.Blur: Class EGLMotionBlurException

Class EGLMotionBlurException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Blur

Declaration

type EGLMotionBlurException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLMotionBlurException


GXSysHelp v.2.5: GXS.Blur: Class TgxBlur

Class TgxBlur

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Blur

Declaration

type TgxBlur = class(TgxHUDSprite)

Description

This item has no description. Showing description inherited from TgxHUDSprite.

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TgxHUDSprite in 2D only scenes : The most convenient way to use a TgxHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TgxHUDSprite works in absolute coordinates, TgxProxyObject can't be used to duplicate an hud sprite.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxSprite
  • TgxHUDSprite
  • TgxBlur

Overview

Fields

Private | FViewer: TgxMemoryViewer;
Private | OldTime: Double;
Private | FDoingMemView: boolean;
Private | FBlurDeltaTime: Double;
Private | FBlurTop: Single;
Private | FBlurBottom: Single;
Private | FBlurLeft: Single;
Private | FBlurRight: Single;
Private | FRenderHeight: Integer;
Private | FRenderWidth: Integer;
Private | FPreset: TgxBlurPreset;
Private | FTargetObject: TgxbaseSceneObject;
Private | FOnAdvancedBlurImagePrepareEvent: TgxAdvancedBlurImagePrepareEvent;
Private | FBlur: TgxBlurkind;
Private | Pixelbuffer: TRGBPixelBuffer;
Private | FAdvancedBlurPasses: Integer;
Private | FOnAfterTargetRender: TNotifyEvent;
Private | FOnBeforeTargetRender: TNotifyEvent;
Private | FAdvancedBlurAmp: Single;
Private | FBlurSelf: boolean;
Private | FAdvancedBlurLowClamp: byte;
Private | FAdvancedBlurHiClamp: byte;
Private | FRenderBackgroundColor: TColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreBlurBottom: boolean;
Private | function StoreBlurDeltaTime: boolean;
Private | function StoreBlurLeft: boolean;
Private | function StoreBlurRight: boolean;
Private | function StoreBlurTop: boolean;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure DoMemView(baseObject: TgxbaseSceneObject);
Private | procedure SetAdvancedBlurAmp(const Value: Single);
Private | procedure SetAdvancedBlurHiClamp(const Value: byte);
Private | procedure SetAdvancedBlurLowClamp(const Value: byte);
Private | procedure SetAdvancedBlurPasses(const Value: Integer);
Private | procedure SetBlur(const Value: TgxBlurkind);
Private | procedure SetBlurSelf(const Value: boolean);
Private | procedure SetOnAdvancedBlurImagePrepareEvent(const Value : TgxAdvancedBlurImagePrepareEvent);
Private | procedure SetOnAfterTargetRender(const Value: TNotifyEvent);
Private | procedure SetOnBeforeTargetRender(const Value: TNotifyEvent);
Private | procedure SetPreset(const Value: TgxBlurPreset);
Private | procedure SetRenderBackgroundColor(const Value: TColor);
Private | procedure SetRenderHeight(const Value: Integer);
Private | procedure SetRenderWidth(const Value: Integer);
Private | procedure SetTargetObject(const Value: TgxbaseSceneObject);
Private | procedure UpdateImageSettings;

Properties

Published | property AdvancedBlurAmp: Single read FAdvancedBlurAmp write SetAdvancedBlurAmp;
Published | property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;
Published | property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;
Published | property AdvancedBlurPasses: Integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;
Published | property Blur: TgxBlurkind read FBlur write SetBlur;
Published | property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;
Published | property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;
Published | property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;
Published | property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;
Published | property BlurSelf: boolean read FBlurSelf write SetBlurSelf;
Published | property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;
Published | property OnAdvancedBlurImagePrepareEvent: TgxAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;
Published | property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;
Published | property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;
Published | property Preset: TgxBlurPreset read FPreset write SetPreset stored false;
Published | property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;
Published | property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;
Published | property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;
Published | property TargetObject: TgxbaseSceneObject read FTargetObject write SetTargetObject;

Description

Fields

Private FViewer: TgxMemoryViewer;

This item has no description.

Private OldTime: Double;

This item has no description.

Private FDoingMemView: boolean;

This item has no description.

Private FBlurDeltaTime: Double;

This item has no description.

Private FBlurTop: Single;

This item has no description.

Private FBlurBottom: Single;

This item has no description.

Private FBlurLeft: Single;

This item has no description.

Private FBlurRight: Single;

This item has no description.

Private FRenderHeight: Integer;

This item has no description.

Private FRenderWidth: Integer;

This item has no description.

Private FPreset: TgxBlurPreset;

This item has no description.

Private FTargetObject: TgxbaseSceneObject;

This item has no description.

Private FOnAdvancedBlurImagePrepareEvent: TgxAdvancedBlurImagePrepareEvent;

This item has no description.

Private FBlur: TgxBlurkind;

This item has no description.

Private Pixelbuffer: TRGBPixelBuffer;

This item has no description.

Private FAdvancedBlurPasses: Integer;

This item has no description.

Private FOnAfterTargetRender: TNotifyEvent;

This item has no description.

Private FOnBeforeTargetRender: TNotifyEvent;

This item has no description.

Private FAdvancedBlurAmp: Single;

This item has no description.

Private FBlurSelf: boolean;

This item has no description.

Private FAdvancedBlurLowClamp: byte;

This item has no description.

Private FAdvancedBlurHiClamp: byte;

This item has no description.

Private FRenderBackgroundColor: TColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreBlurBottom: boolean;

This item has no description.

Private function StoreBlurDeltaTime: boolean;

This item has no description.

Private function StoreBlurLeft: boolean;

This item has no description.

Private function StoreBlurRight: boolean;

This item has no description.

Private function StoreBlurTop: boolean;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure DoMemView(baseObject: TgxbaseSceneObject);

This item has no description.

Private procedure SetAdvancedBlurAmp(const Value: Single);

This item has no description.

Private procedure SetAdvancedBlurHiClamp(const Value: byte);

This item has no description.

Private procedure SetAdvancedBlurLowClamp(const Value: byte);

This item has no description.

Private procedure SetAdvancedBlurPasses(const Value: Integer);

This item has no description.

Private procedure SetBlur(const Value: TgxBlurkind);

This item has no description.

Private procedure SetBlurSelf(const Value: boolean);

This item has no description.

Private procedure SetOnAdvancedBlurImagePrepareEvent(const Value : TgxAdvancedBlurImagePrepareEvent);

This item has no description.

Private procedure SetOnAfterTargetRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetOnBeforeTargetRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetPreset(const Value: TgxBlurPreset);

This item has no description.

Private procedure SetRenderBackgroundColor(const Value: TColor);

This item has no description.

Private procedure SetRenderHeight(const Value: Integer);

This item has no description.

Private procedure SetRenderWidth(const Value: Integer);

This item has no description.

Private procedure SetTargetObject(const Value: TgxbaseSceneObject);

This item has no description.

Private procedure UpdateImageSettings;

This item has no description.

Properties

Published property AdvancedBlurAmp: Single read FAdvancedBlurAmp write SetAdvancedBlurAmp;

This item has no description.

Published property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;

This item has no description.

Published property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;

This item has no description.

Published property AdvancedBlurPasses: Integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;

This item has no description.

Published property Blur: TgxBlurkind read FBlur write SetBlur;

This item has no description.

Published property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;

This item has no description.

Published property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;

This item has no description.

Published property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;

This item has no description.

Published property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;

This item has no description.

Published property BlurSelf: boolean read FBlurSelf write SetBlurSelf;

This item has no description.

Published property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;

This item has no description.

Published property OnAdvancedBlurImagePrepareEvent: TgxAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;

This item has no description.

Published property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;

This item has no description.

Published property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;

This item has no description.

Published property Preset: TgxBlurPreset read FPreset write SetPreset stored false;

This item has no description.

Published property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;

This item has no description.

Published property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;

This item has no description.

Published property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;

This item has no description.

Published property TargetObject: TgxbaseSceneObject read FTargetObject write SetTargetObject;


GXSysHelp v.2.5: GXS.Blur: Class TgxMotionBlur

Class TgxMotionBlur

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Blur

Declaration

type TgxMotionBlur = class(TgxCustomSceneObject, IgxInitializable)

Description

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxMotionBlur

Overview

Fields

Private FIntensity: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function SupportsRequiredExtensions: boolean;
Private | function StoreIntensity: boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;

Properties

Published | property Behaviours;
Published | property Effects;
Published | property Hint;
Published | property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;
Published | property OnProgress;
Published | property Visible;

Description

Fields

Private FIntensity: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function SupportsRequiredExtensions: boolean;

This function is only valid AFTER OpenGL has been initialized.

Private function StoreIntensity: boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;

The more the intensity, the more blur you have.

Published property OnProgress;

This item has no description.

Published property Visible;

From TgxBaseSceneObject.


GXSysHelp v.2.5: GXS.BSP

Unit GXS.BSP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GXS.Material
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Color
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TBSPCullingSphere |
Record TBSPRenderContextInfo |
Class TBSPClusterVisibility |
Class TBSPMeshObject |
Class TFGBSPNode |

Types

TBSPRenderSort = (...);

Description

Types

TBSPRenderSort = (...);

This item has no description.

Values
  • rsNone
  • rsBackToFront
  • rsFrontToBack


GXSysHelp v.2.5: GXS.BSP: Record TBSPCullingSphere

Record TBSPCullingSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BSP

Declaration

type TBSPCullingSphere = record

Description

This item has no description.

Overview

Fields

Public | position: TVector4f;
Public | radius: Single;

Description

Fields

Public position: TVector4f;

This item has no description.

Public radius: Single;


GXSysHelp v.2.5: GXS.BSP: Record TBSPRenderContextInfo

Record TBSPRenderContextInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BSP

Declaration

type TBSPRenderContextInfo = record

Description

This item has no description.

Overview

Fields

Public | cameraLocal: TVector4f;
Public | rci: PGXRenderContextInfo;
Public | faceGroups: TList;
Public | cullingSpheres: array of TBSPCullingSphere;

Description

Fields

Public cameraLocal: TVector4f;

Local coordinates of the camera (can be a vector or point)

Public rci: PGXRenderContextInfo;

This item has no description.

Public faceGroups: TList;

This item has no description.

Public cullingSpheres: array of TBSPCullingSphere;


GXSysHelp v.2.5: GXS.BSP: Class TBSPClusterVisibility

Class TBSPClusterVisibility

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BSP

Declaration

type TBSPClusterVisibility = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TBSPClusterVisibility

Overview

Fields

Private | FData: PByteArray;
Private | FSize: Integer;
Private | FBytesPerCluster: Integer;
Private | FCount: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure SetData(Source: PByte; NumClusters: Integer);

Properties

Public | property Count: Integer read FCount write SetCount;
Public | property Visibility[src,dst: Integer]: Boolean read GetVisibility write SetVisibility;

Description

Fields

Private FData: PByteArray;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FBytesPerCluster: Integer;

This item has no description.

Private FCount: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure SetData(Source: PByte; NumClusters: Integer);

This item has no description.

Properties

Public property Count: Integer read FCount write SetCount;

This item has no description.

Public property Visibility[src,dst: Integer]: Boolean read GetVisibility write SetVisibility;


GXSysHelp v.2.5: GXS.BSP: Class TBSPMeshObject

Class TBSPMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BSP

Declaration

type TBSPMeshObject = class(TgxMeshObject)

Description

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TBSPMeshObject

Overview

Fields

Private | FRenderSort: TBSPRenderSort;
Private | FClusterVisibility: TBSPClusterVisibility;
Private | FUseClusterVisibility: Boolean;

Methods

Public | constructor CreateOwned(AOwner: TgxMeshObjectList);
Public | destructor Destroy; override;
Public | function AverageDepth: Single;
Public | function FindNodeByPoint(const aPoint: TVector4f): TFGBSPNode;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure CleanupUnusedNodes;

Properties

Public | property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;
Public | property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;
Public | property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;

Description

Fields

Private FRenderSort: TBSPRenderSort;

This item has no description.

Private FClusterVisibility: TBSPClusterVisibility;

This item has no description.

Private FUseClusterVisibility: Boolean;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TgxMeshObjectList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AverageDepth: Single;

Returns the average BSP tree depth of end nodes. Sums up the depth each end node (starting at 1 for root node), divides by the number of end nodes. This is a simple estimator of tree balancing (structurally speaking, not polygon-wise).

Public function FindNodeByPoint(const aPoint: TVector4f): TFGBSPNode;

Traverses the tree to the given point and returns the node index.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure CleanupUnusedNodes;

Drops all unused nodes from the facegroups list. An unused node is a node that renders nothing and whose children render nothing. Indices are remapped in the process.

Properties

Public property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;

Cluster visibility. A property for defining node cluster-cluster visibility potential.

Public property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;

Rendering sort mode. This sort mode can currently *not* blend with the sort by materials flag, default mode is rsBackToFront. Note that in rsNone mode, the hierarchical nature of the tree is still honoured (positive subnode, self, then negative subnode).

Public property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;

Use cluster visibility. Toggles the use of the visibility set for culling clusters of nodes when rendering.


GXSysHelp v.2.5: GXS.BSP: Class TFGBSPNode

Class TFGBSPNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BSP

Declaration

type TFGBSPNode = class(TgxFGVertexIndexList)

Description

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList
  • TFGBSPNode

Overview

Fields

Private | FSplitPlane: THmgPlane;
Private | FPositiveSubNodeIndex: Integer;
Private | FNegativeSubNodeIndex: Integer;
Private | FCluster: Integer;

Methods

Public | constructor CreateOwned(AOwner: TgxFaceGroups); override;
Public | destructor Destroy; override;
Public | function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;
Public | procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);
Public | procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);
Public | procedure FixTJunctions(const tJunctionsCandidates: TgxIntegerList);
Public | procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);
Public | procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Properties

Public | property Cluster: Integer read FCluster write FCluster;
Public | property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;
Public | property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;
Public | property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;

Description

Fields

Private FSplitPlane: THmgPlane;

This item has no description.

Private FPositiveSubNodeIndex: Integer;

This item has no description.

Private FNegativeSubNodeIndex: Integer;

This item has no description.

Private FCluster: Integer;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TgxFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;

Try to find a 'decent' split plane for the node. Use this function to build a BSP tree, on leafy nodes. The split plane is chosen among the polygon planes, the coefficient are used to determine what a 'good' split plane is by assigning a cost to splitted triangles (cut by the split plane) and tree imbalance.

Public procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);

This item has no description.

Public procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);

Evaluates a split plane. Used by FindSplitPlane. For splitted triangles, the extra spawned triangles required are accounted for in the nbXxxTriangles values.

Public procedure FixTJunctions(const tJunctionsCandidates: TgxIntegerList);

Goes through all triangle edges, looking for tjunctions. The candidates are indices of points to lookup a tjunction vertices.

Public procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);

This item has no description.

Public procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Splits a leafy node along the specified plane. Will trigger an exception if the node already has subnodes. Currently also changes the mode from strips/fan to list.

Properties

Public property Cluster: Integer read FCluster write FCluster;

The index of the cluster that this node belongs to. Used for visibility determination.

Public property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;

Index of the negative sub-node index in the list. Zero if empty.

Public property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;

Index of the positive sub-node index in the list. Zero if empty.

Public property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;

BSP node split plane. Divides space between positive and negative half-space, positive half-space being the one were the evaluation of an homogeneous vector against the plane is positive.


GXSysHelp v.2.5: GXS.BumpmapHDS

Unit GXS.BumpmapHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • GXS.HeightData
  • GXS.Graphics
  • GXS.Coordinates
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.Texture
  • GXS.Material
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBumpmapHDS |

Types

TNewTilePreparedEvent = procedure(Sender: TgxBumpmapHDS; heightData: TgxHeightData; normalMapMaterial: TgxLibMaterial) of object;

Description

Types

TNewTilePreparedEvent = procedure(Sender: TgxBumpmapHDS; heightData: TgxHeightData; normalMapMaterial: TgxLibMaterial) of object;


GXSysHelp v.2.5: GXS.BumpmapHDS: Class TgxBumpmapHDS

Class TgxBumpmapHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.BumpmapHDS

Declaration

type TgxBumpmapHDS = class(TgxHeightDataSourceFilter)

Description

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxHeightDataSourceFilter
  • TgxBumpmapHDS

Overview

Fields

Private | FBumpmapLibrary: TgxMaterialLibrary;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FBumpScale: Single;
Private | FSubSampling: Integer;
Private | FMaxTextures: Integer;
Private | Uno: TCriticalSection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure GenerateNormalMap(heightData: TgxHeightData; normalMap: TgxBitmap32; scale: Single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(heightData: TgxHeightData); override;
Public | procedure Release(aHeightData: TgxHeightData); override;
Public | procedure TrimTextureCache(MaxTextureCount: Integer);

Properties

Published | property BumpmapLibrary: TgxMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;
Published | property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;
Published | property MaxPoolSize;
Published | property MaxTextures: Integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Description

Fields

Private FBumpmapLibrary: TgxMaterialLibrary;

FElevationHDS : TgxHeightDataSource;

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FBumpScale: Single;

This item has no description.

Private FSubSampling: Integer;

This item has no description.

Private FMaxTextures: Integer;

This item has no description.

Private Uno: TCriticalSection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure GenerateNormalMap(heightData: TgxHeightData; normalMap: TgxBitmap32; scale: Single);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreparingData(heightData: TgxHeightData); override;

procedure TileTextureCoordinates(heightData : TgxHeightData; TextureScale:TTexPoint; TextureOffset:TTexPoint);

Public procedure Release(aHeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.Release.

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure TrimTextureCache(MaxTextureCount: Integer);

This will repeatedly delete the oldest unused texture from the TgxMaterialLibrary, until the texture count drops to MaxTextureCount. DONT use this if you used TgxHeightData.MaterialName to link your terrain textures. Either use with TgxHeightData.LibMaterial, or manually delete unused Normal-Map textures.

Properties

Published property BumpmapLibrary: TgxMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;

This item has no description.

Published property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property MaxTextures: Integer read FMaxTextures write FMaxTextures;

If MaxTextures>0 then the Bumpmap library is trimmed down to size whenever the texture count is larger than MaxTextures. The oldest, unused texture is trimmed first. However, if you used TgxHeightData.MaterialName, instead of TgxHeightData.LibMaterial, then the TgxHeightData component does not register the texture as being used. So, if you use TgxHeightData.MaterialName then make sure MaxTextures=0. If MaxTextures=0 or if treads(GXS.AsyncHDS) are used, then the texture cache is NOT trimmed automatically. You will have to manually trim the cache from the main thread, by calling 'TrimTextureCache'. (GXS.AsyncHDS.OnIdle is a good place.)

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

This item has no description.

Published property OnSourceDataFetched;

This item has no description.

Published property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Specifies the amount of subsampling for the bump texture. This value must be a power of 2, and is used to divide the height tile resolution to determine the bump texture resolution (f.i. a tile size of 128 with a subsampling of 4 will result in textures of a resolution of 32x32. SubSampling won't allow texture resolution to get below 16x16 (minimal bumpmap resolution).


GXSysHelp v.2.5: GXS.BumpMapping

Unit GXS.BumpMapping

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.UITypes
  • FMX.Graphics
  • GXS.Color
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.VectorTypes

Overview

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TgxAffineVectorList; Colors: TgxVectorList);
procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TgxAffineVectorList);
procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TgxAffineVectorList; Colors: TgxVectorList);
function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TgxAffineVectorList) : TBitmap;
function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TgxAffineVectorList) : TBitmap;

Types

TNormalMapSpace = (...);

Description

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TgxAffineVectorList; Colors: TgxVectorList);

This item has no description.

procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TgxAffineVectorList);

This item has no description.

procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TgxAffineVectorList; Colors: TgxVectorList);

This item has no description.

function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TgxAffineVectorList) : TBitmap;

This item has no description.

function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TgxAffineVectorList) : TBitmap;

This item has no description.

Types

TNormalMapSpace = (...);

This item has no description.

Values
  • nmsObject
  • nmsTangent


GXSysHelp v.2.5: GXS.Cadencer

Unit GXS.Cadencer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Messaging
  • Winapi.Messages
  • System.Classes
  • System.Types
  • System.SysUtils
  • FMX.Forms
  • GXS.Scene
  • GXS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCadencer |
Class TgxCustomCadencedComponent |
Class TgxCadencedComponent |

Types

TgxCadencerMode = (...);
TgxCadencerTimeReference = (...);

Description

Types

TgxCadencerMode = (...);

Determines how the TgxCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

Values
  • cmManual
  • cmASAP
  • cmApplicationIdle
TgxCadencerTimeReference = (...);

Determines which time reference the TgxCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used

Values
  • cmRTC
  • cmPerformanceCounter
  • cmExternal


GXSysHelp v.2.5: GXS.Cadencer: Class TgxCadencer

Class TgxCadencer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Cadencer

Declaration

type TgxCadencer = class(TComponent)

Description

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TgxScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxCadencer

Overview

Fields

Private | FSubscribedCadenceableComponents: TList;
Private | FScene: TgxScene;
Private | FTimeMultiplier: Double;
Private | lastTime: Double;
Private | downTime: Double;
Private | lastMultiplier: Double;
Private | FEnabled: Boolean;
Private | FSleepLength: Integer;
Private | FMode: TgxCadencerMode;
Private | FTimeReference: TgxCadencerTimeReference;
Private | FCurrentTime: Double;
Private | FOriginTime: Double;
Private | FMaxDeltaTime: Double;
Private | FMinDeltaTime: Double;
Private | FFixedDeltaTime: Double;
Private | FOnProgress: TgxProgressEvent;
Private | FOnTotalProgress: TgxProgressEvent;
Private | FProgressing: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCurrenttime: Double;
Public | function IsBusy: Boolean;
Public | procedure Progress;
Public | procedure Reset;
Public | procedure Subscribe(aComponent: TgxCadenceAbleComponent);
Public | procedure UnSubscribe(aComponent: TgxCadenceAbleComponent);
Private | procedure SetCurrentTime(const Value: Double);

Properties

Public | property CurrentTime: Double read FCurrentTime write SetCurrentTime;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Published | property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;
Published | property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;
Published | property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;
Published | property Mode: TgxCadencerMode read FMode write SetMode default cmASAP;
Published | property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;
Published | property OnTotalProgress : TgxProgressEvent read FOnTotalProgress write FOnTotalProgress;
Public | property OriginTime: Double read FOriginTime write FOriginTime;
Published | property Scene: TgxScene read FScene write SetScene;
Published | property SleepLength: Integer read FSleepLength write FSleepLength default -1;
Published | property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;
Published | property TimeReference: TgxCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Description

Fields

Private FSubscribedCadenceableComponents: TList;

This item has no description.

Private FScene: TgxScene;

This item has no description.

Private FTimeMultiplier: Double;

This item has no description.

Private lastTime: Double;

This item has no description.

Private downTime: Double;

This item has no description.

Private lastMultiplier: Double;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSleepLength: Integer;

This item has no description.

Private FMode: TgxCadencerMode;

This item has no description.

Private FTimeReference: TgxCadencerTimeReference;

This item has no description.

Private FCurrentTime: Double;

This item has no description.

Private FOriginTime: Double;

This item has no description.

Private FMaxDeltaTime: Double;

This item has no description.

Private FMinDeltaTime: Double;

This item has no description.

Private FFixedDeltaTime: Double;

This item has no description.

Private FOnProgress: TgxProgressEvent;

This item has no description.

Private FOnTotalProgress: TgxProgressEvent;

This item has no description.

Private FProgressing: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetCurrenttime: Double;

Adjusts CurrentTime if necessary, then returns its value.

Public function IsBusy: Boolean;

Returns True if a "Progress" is underway. Be aware that as long as IsBusy is True, the Cadencer may be sending messages and progression calls to cadenceable components and scenes.

Public procedure Progress;

Allows to manually trigger a progression. Time stuff is handled automatically. If cadencer is disabled, this functions does nothing.

Public procedure Reset;

Reset the time parameters and returns to zero.

Public procedure Subscribe(aComponent: TgxCadenceAbleComponent);

This item has no description.

Public procedure UnSubscribe(aComponent: TgxCadenceAbleComponent);

This item has no description.

Private procedure SetCurrentTime(const Value: Double);

This item has no description.

Properties

Public property CurrentTime: Double read FCurrentTime write SetCurrentTime;

Current time (manually or automatically set, see TimeReference).

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Enables/Disables cadencing. Disabling won't cause a jump when restarting, it is working like a play/pause (ie. may modify OriginTime to keep things smooth).

Published property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;

Fixed time-step value for progression events. If superior to zero, progression steps will happen with that fixed delta time. The progression remains time based, so zero to N events may be fired depending on the actual deltaTime (if deltaTime is inferior to FixedDeltaTime, no event will be fired, if it is superior to two times FixedDeltaTime, two events will be fired, etc.). This option allows to use fixed time steps in simulations (while the animation and rendering itself may happen at a lower or higher framerate).

Published property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;

Maximum value for deltaTime in progression events. If null or negative, no max deltaTime is defined, otherwise, whenever an event whose actual deltaTime would be superior to MaxDeltaTime occurs, deltaTime is clamped to this max, and the extra time is hidden by the cadencer (it isn't visible in CurrentTime either). This option allows to limit progression rate in simulations where high values would result in errors/random behaviour.

Published property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;

Minimum value for deltaTime in progression events. If superior to zero, this value specifies the minimum time step between two progression events. This option allows to limit progression rate in simulations where low values would result in errors/random behaviour.

Published property Mode: TgxCadencerMode read FMode write SetMode default cmASAP;

Adjusts how progression events are triggered. See TgxCadencerMode.

Published property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;

Happens AFTER scene was progressed.

Published property OnTotalProgress : TgxProgressEvent read FOnTotalProgress write FOnTotalProgress;

Happens AFTER all iterations with fixed delta time.

Public property OriginTime: Double read FOriginTime write FOriginTime;

Value soustracted to current time to obtain progression time.

Published property Scene: TgxScene read FScene write SetScene;

The TgxScene that will be cadenced (progressed).

Published property SleepLength: Integer read FSleepLength write FSleepLength default -1;

Allows relinquishing time to other threads/processes. A "sleep" is issued BEFORE each progress if SleepLength>=0 (see help for the "sleep" procedure in delphi for details).

Published property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;

Multiplier applied to the time reference. Zero isn't an allowed value, and be aware that if negative values are accepted, they may not be supported by other GLScene objects. Changing the TimeMultiplier will alter OriginTime.

Published property TimeReference: TgxCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Defines how CurrentTime is updated. See TgxCadencerTimeReference. Dynamically changeing the TimeReference may cause a "jump".


GXSysHelp v.2.5: GXS.Cadencer: Class TgxCustomCadencedComponent

Class TgxCustomCadencedComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Cadencer

Declaration

type TgxCustomCadencedComponent = class(TgxUpdateAbleComponent)

Description

Adds a property to connect/subscribe to a cadencer.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent

Overview

Fields

Private FCadencer: TgxCadencer;

Methods

Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Description

Fields

Private FCadencer: TgxCadencer;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;


GXSysHelp v.2.5: GXS.Cadencer: Class TgxCadencedComponent

Class TgxCadencedComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Cadencer

Declaration

type TgxCadencedComponent = class(TgxCustomCadencedComponent)

Description

This item has no description. Showing description inherited from TgxCustomCadencedComponent.

Adds a property to connect/subscribe to a cadencer.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent

Overview

Properties

Published property Cadencer;

Description

Properties

Published property Cadencer;


GXSysHelp v.2.5: GXS.CameraController

Unit GXS.CameraController

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • System.Contnrs
  • GXS.PersistentClasses
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Coordinates
  • GXS.SmoothNavigator
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCameraController |
Class TgxCameraJobList |
Class TgxCameraJob |
Class TgxMoveToPosJob |
Class TgxZoomToDistanceJob |
Class TgxOrbitToPosJob |
Class TgxSmoothOrbitToPos |
Class TgxOrbitToPosAdvJob |
Class TgxSmoothOrbitToPosAdvJob |
Class TgxCameraController |

Types

TgxCameraJobEvent = procedure(Sender : TgxCameraJob) of object;

Description

Types

TgxCameraJobEvent = procedure(Sender : TgxCameraJob) of object;


GXSysHelp v.2.5: GXS.CameraController: Class EGLCameraController

Class EGLCameraController

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type EGLCameraController = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLCameraController


GXSysHelp v.2.5: GXS.CameraController: Class TgxCameraJobList

Class TgxCameraJobList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxCameraJobList = class(TObjectList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TObjectList
  • TgxCameraJobList

Overview

Fields

Private FController: TgxCameraController;

Methods

Public | constructor Create(AController: TgxCameraController);
Public | function Add(ACameraJob: TgxCameraJob): integer;
Public | function First: TgxCameraJob;
Public | function Last: TgxCameraJob;
Private | function GetCameraJob(const AIndex: integer): TgxCameraJob;
Private | procedure SetCameraJob(const AIndex: integer; const Value: TgxCameraJob);

Properties

Public property Items[const AIndex: integer]: TgxCameraJob read GetCameraJob write SetCameraJob;

Description

Fields

Private FController: TgxCameraController;

This item has no description.

Methods

Public constructor Create(AController: TgxCameraController);

This item has no description.

Public function Add(ACameraJob: TgxCameraJob): integer;

This item has no description.

Public function First: TgxCameraJob;

This item has no description.

Public function Last: TgxCameraJob;

This item has no description.

Private function GetCameraJob(const AIndex: integer): TgxCameraJob;

This item has no description.

Private procedure SetCameraJob(const AIndex: integer; const Value: TgxCameraJob);

This item has no description.

Properties

Public property Items[const AIndex: integer]: TgxCameraJob read GetCameraJob write SetCameraJob;


GXSysHelp v.2.5: GXS.CameraController: Class TgxCameraJob

Class TgxCameraJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxCameraJob = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob

Overview

Fields

Private FJoblist: TgxCameraJobList;

Methods

Public | constructor Create(const AJoblist : TgxCameraJobList); virtual;
Public | destructor Destroy; override;
Public | procedure Abort;
Public | procedure Init; virtual; abstract;
Public | procedure Step; virtual; abstract;

Properties

Public | property ElapsedTime: Double read FElapsedTime write FElapsedTime;
Public | property ProceedTime: Double read FProceedTime write FProceedTime;
Public | property Running: Boolean read FRunning write FRunning;
Public | property StartTime: Double read FStartTime write FStartTime;

Description

Fields

Private FJoblist: TgxCameraJobList;

This item has no description.

Methods

Public constructor Create(const AJoblist : TgxCameraJobList); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Abort;

This item has no description.

Public procedure Init; virtual; abstract;

This item has no description.

Public procedure Step; virtual; abstract;

This item has no description.

Properties

Public property ElapsedTime: Double read FElapsedTime write FElapsedTime;

This item has no description.

Public property ProceedTime: Double read FProceedTime write FProceedTime;

This item has no description.

Public property Running: Boolean read FRunning write FRunning;

This item has no description.

Public property StartTime: Double read FStartTime write FStartTime;


GXSysHelp v.2.5: GXS.CameraController: Class TgxMoveToPosJob

Class TgxMoveToPosJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxMoveToPosJob = class(TgxCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxMoveToPosJob

Overview

Fields

Private | FInitialPos: TVector4f;
Private | FFinalPos: TVector4f;
Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector4f read FFinalPos;
Public | property InitialPos: TVector4f read FInitialPos;

Description

Fields

Private FInitialPos: TVector4f;

This item has no description.

Private FFinalPos: TVector4f;

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double;

This item has no description.

Public Z: Double;

This item has no description.

Public Time: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TVector4f read FFinalPos;

This item has no description.

Public property InitialPos: TVector4f read FInitialPos;

Properties.


GXSysHelp v.2.5: GXS.CameraController: Class TgxZoomToDistanceJob

Class TgxZoomToDistanceJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxZoomToDistanceJob = class(TgxCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxZoomToDistanceJob

Overview

Fields

Private | FInitialPos: TVector4f;
Private | FFinalPos: TVector4f;
Public | Distance: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector4f read FFinalPos;
Public | property InitialPos: TVector4f read FInitialPos;

Description

Fields

Private FInitialPos: TVector4f;

This item has no description.

Private FFinalPos: TVector4f;

This item has no description.

Public Distance: Double;

This item has no description.

Public Time: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TVector4f read FFinalPos;

This item has no description.

Public property InitialPos: TVector4f read FInitialPos;

Properties.


GXSysHelp v.2.5: GXS.CameraController: Class TgxOrbitToPosJob

Class TgxOrbitToPosJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxOrbitToPosJob = class(TgxCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxOrbitToPosJob

Overview

Fields

Private | FFinalPos: TVector4f;
Private | FRotateSpeed: TVector2f;
Private | FCameraUpVector: TVector4f;
Private | FTargetPosition: TVector4f;
Private | FTime: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property CameraUpVector: TVector4f read FCameraUpVector;
Public | property FinalPos: TVector4f read FFinalPos;
Public | property RotateSpeed: TVector2f read FRotateSpeed;
Public | property TargetPosition: TVector4f read FTargetPosition;
Public | property Time: Double read FTime;

Description

Fields

Private FFinalPos: TVector4f;

This item has no description.

Private FRotateSpeed: TVector2f;

Yep, FFinalPos is stored in relative coordinates.

Private FCameraUpVector: TVector4f;

This item has no description.

Private FTargetPosition: TVector4f;

Absolute Coordinates, can even be not normalized by radius. Procesed in Init, not used anywhere else.

Private FTime: Double;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property CameraUpVector: TVector4f read FCameraUpVector;

This item has no description.

Public property FinalPos: TVector4f read FFinalPos;

This item has no description.

Public property RotateSpeed: TVector2f read FRotateSpeed;

Properties.

Public property TargetPosition: TVector4f read FTargetPosition;

This item has no description.

Public property Time: Double read FTime;


GXSysHelp v.2.5: GXS.CameraController: Class TgxSmoothOrbitToPos

Class TgxSmoothOrbitToPos

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxSmoothOrbitToPos = class(TgxOrbitToPosJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxOrbitToPosJob
  • TgxSmoothOrbitToPos

Overview

Fields

Private | FCutoffAngle: Single;
Private | FNeedToRecalculateZoom: Boolean;
Private | FShouldBeMatrix: TMatrix4f;
Private | FSmoothNavigator: TgxNavigatorSmoothChangeVector;

Methods

Public | constructor Create(const AJoblist : TgxCameraJobList); override;
Public | procedure Step; override;

Properties

Public | property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;
Public | property NeedToRecalculateZoom: Boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;

Description

Fields

Private FCutoffAngle: Single;

This item has no description.

Private FNeedToRecalculateZoom: Boolean;

This item has no description.

Private FShouldBeMatrix: TMatrix4f;

This item has no description.

Private FSmoothNavigator: TgxNavigatorSmoothChangeVector;

This item has no description.

Methods

Public constructor Create(const AJoblist : TgxCameraJobList); override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;

This item has no description.

Public property NeedToRecalculateZoom: Boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;


GXSysHelp v.2.5: GXS.CameraController: Class TgxOrbitToPosAdvJob

Class TgxOrbitToPosAdvJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxOrbitToPosAdvJob = class(TgxCameraJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxOrbitToPosAdvJob

Overview

Fields

Private | FInitialPos: TVector4f;
Private | FFinalPos: TVector4f;
Private | FInitialUp: TVector4f;
Private | FInitialDir: TVector4f;
Private | FRotAxis: TVector4f;
Private | FAngle: Double;
Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;
Public | PreferUpAxis: Boolean;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector4f read FFinalPos;
Public | property InitialDir: TVector4f read FInitialDir;
Public | property InitialPos: TVector4f read FInitialPos;
Public | property InitialUp: TVector4f read FInitialUp;

Description

Fields

Private FInitialPos: TVector4f;

This item has no description.

Private FFinalPos: TVector4f;

This item has no description.

Private FInitialUp: TVector4f;

This item has no description.

Private FInitialDir: TVector4f;

This item has no description.

Private FRotAxis: TVector4f;

This item has no description.

Private FAngle: Double;

This item has no description.

Public X: Double;

This item has no description.

Public Y: Double;

This item has no description.

Public Z: Double;

This item has no description.

Public Time: Double;

This item has no description.

Public PreferUpAxis: Boolean;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;

This item has no description.

Properties

Public property FinalPos: TVector4f read FFinalPos;

This item has no description.

Public property InitialDir: TVector4f read FInitialDir;

This item has no description.

Public property InitialPos: TVector4f read FInitialPos;

Properties.

Public property InitialUp: TVector4f read FInitialUp;


GXSysHelp v.2.5: GXS.CameraController: Class TgxSmoothOrbitToPosAdvJob

Class TgxSmoothOrbitToPosAdvJob

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxSmoothOrbitToPosAdvJob = class(TgxOrbitToPosAdvJob)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCameraJob
  • TgxOrbitToPosAdvJob
  • TgxSmoothOrbitToPosAdvJob

Overview

Fields

Private | FPreviousPosition: TVector4f;
Private | FSmoothNavigator: TgxNavigatorSmoothChangeVector;
Private | FRestoreUpVector: Boolean;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Description

Fields

Private FPreviousPosition: TVector4f;

This item has no description.

Private FSmoothNavigator: TgxNavigatorSmoothChangeVector;

This item has no description.

Private FRestoreUpVector: Boolean;

This item has no description.

Methods

Public procedure Init; override;

This item has no description.

Public procedure Step; override;


GXSysHelp v.2.5: GXS.CameraController: Class TgxCameraController

Class TgxCameraController

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CameraController

Declaration

type TgxCameraController = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxCameraController

Overview

Fields

Private | FCameraJobList: TgxCameraJobList;
Private | FCamera: TgxBaseSceneObject;
Private | FCameraTarget: TgxBaseSceneObject;
Private | FOnJobAdded: TgxCameraJobEvent;
Private | FOnJobFinished: TgxCameraJobEvent;
Private | FOnJobStep: TgxCameraJobEvent;
Private | FsoSafeDist:double;
Private | FsoTimeToSafePlacement:double;
Private | FsoTimeToOrbit:double;
Private | FsoTimeToZoomBackIn:double;

Methods

Public | constructor Create(AOwner:TComponent); override;
Public | destructor Destroy; override;
Public | function MoveToPos(x,y,z,time:double): TgxMoveToPosJob;
Public | function OrbitToPos(x,y,z,time:double): TgxOrbitToPosJob;
Public | function OrbitToPosAdvanced(x,y,z,time:double; PreferUpAxis: Boolean = True): TgxOrbitToPosAdvJob;
Public | function OrbitToPosAdvancedSmooth(const x,y,z, time: double; const ASmoothNavigator: TgxNavigatorSmoothChangeVector; const PreferUpAxis: Boolean = True): TgxSmoothOrbitToPosAdvJob;
Public | function OrbitToPosSmooth(const ATargetPosition: TVector4f; const ATime: Double; const ASmoothNavigator: TgxNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: Boolean; const ACameraUpVector: PVector4f = nil): TgxSmoothOrbitToPos;
Public | function ZoomToDistance(Distance,Time:double): TgxZoomToDistanceJob;
Public | procedure SafeOrbitAndZoomToPos(x,y,z:double);
Public | procedure Step(const deltaTime, newTime: Double);
Public | procedure StopMovement;
Private | procedure CheckAssignments(Extended: boolean);
Private | procedure SetCamera(const Value: TgxBaseSceneObject);
Private | procedure SetCameraTarget(const Value: TgxBaseSceneObject);
Private | procedure SetOnJobAdded(const Value: TgxCameraJobEvent);
Private | procedure SetOnJobFinished(const Value: TgxCameraJobEvent);
Private | procedure SetOnJobStep(const Value: TgxCameraJobEvent);

Properties

Published | property Camera: TgxBaseSceneObject read FCamera write SetCamera;
Public | property CameraJobList: TgxCameraJobList read FCameraJobList;
Published | property CameraTarget: TgxBaseSceneObject read FCameraTarget write SetCameraTarget;
Published | property OnJobAdded : TgxCameraJobEvent read FOnJobAdded write SetOnJobAdded;
Published | property OnJobFinished : TgxCameraJobEvent read FOnJobFinished write SetOnJobFinished;
Published | property OnJobStep : TgxCameraJobEvent read FOnJobStep write SetOnJobStep;
Published | property soSafeDistance: double read FsoSafeDist write FsoSafeDist;
Published | property soTimeToOrbit: double read FsoTimeToOrbit write FsoTimeToOrbit;
Published | property soTimeToSafePlacement: double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;
Published | property soTimeToZoomBackIn: double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;

Description

Fields

Private FCameraJobList: TgxCameraJobList;

Objects.

Private FCamera: TgxBaseSceneObject;

This item has no description.

Private FCameraTarget: TgxBaseSceneObject;

This item has no description.

Private FOnJobAdded: TgxCameraJobEvent;

Events.

Private FOnJobFinished: TgxCameraJobEvent;

This item has no description.

Private FOnJobStep: TgxCameraJobEvent;

This item has no description.

Private FsoSafeDist:double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToSafePlacement:double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToOrbit:double;

fields used by SafeOrbitAndZoomToPos

Private FsoTimeToZoomBackIn:double;

fields used by SafeOrbitAndZoomToPos

Methods

Public constructor Create(AOwner:TComponent); override;

Constructor.

Public destructor Destroy; override;

This item has no description.

Public function MoveToPos(x,y,z,time:double): TgxMoveToPosJob;

methods linear movement from current pos

Public function OrbitToPos(x,y,z,time:double): TgxOrbitToPosJob;

orbiting from current pos to the pos where the camera points at the camera.targetObject TROUGH the given point it will not move to the given point(!), use SafeOrbitAndZoomToPos instead there has to be a camera.targetObject assigned!

Public function OrbitToPosAdvanced(x,y,z,time:double; PreferUpAxis: Boolean = True): TgxOrbitToPosAdvJob;

Same function as OrbitToPos but support all camera states PreferUpAxis value is to setup if function use Camera Up based rotation axis instead of Camera direction based rotation axis when destination and camera position are opposite from Camera Target

Public function OrbitToPosAdvancedSmooth(const x,y,z, time: double; const ASmoothNavigator: TgxNavigatorSmoothChangeVector; const PreferUpAxis: Boolean = True): TgxSmoothOrbitToPosAdvJob;

Same as OrbitToPosAdvanced(), but makes use of SmoothNavigator to make sure all camera movements are smooth.

Public function OrbitToPosSmooth(const ATargetPosition: TVector4f; const ATime: Double; const ASmoothNavigator: TgxNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: Boolean; const ACameraUpVector: PVector4f = nil): TgxSmoothOrbitToPos;

Same as OrbitToPos(), but makes use of SmoothNavigator to make sure all camera movements are smooth.

Public function ZoomToDistance(Distance,Time:double): TgxZoomToDistanceJob;

zooms in/out by moving to the given distance from camera.targetObject there has to be a camera.targetObject assigned!

Public procedure SafeOrbitAndZoomToPos(x,y,z:double);

google earth - like "fly-to" = zoom out to safe distance, orbit, and then zoom in to the given point there has to be a camera.targetObject assigned!

Public procedure Step(const deltaTime, newTime: Double);

Called by the cadencer to animate the camera

Public procedure StopMovement;

Dan Bartlett said in the GLScene newsgroup that it might be a good idea to introduce ability to stop movement and return control to user here it is

Private procedure CheckAssignments(Extended: boolean);

private methods used to test whether camera and cadencer are assigned Extended = true -> will test also for Camera.TargetObject

Private procedure SetCamera(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetCameraTarget(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetOnJobAdded(const Value: TgxCameraJobEvent);

after AdjustScene the Camera.DepthofView will be modified if you want to zoom back in from GUI you should use something like Camera.DepthOfView:=2*Camera.DistanceToTarget+2*camera.TargetObject.BoundingSphereRadius;

Private procedure SetOnJobFinished(const Value: TgxCameraJobEvent);

This item has no description.

Private procedure SetOnJobStep(const Value: TgxCameraJobEvent);

This item has no description.

Properties

Published property Camera: TgxBaseSceneObject read FCamera write SetCamera;

Assign a Moving object (usually a TgxCamera).

Public property CameraJobList: TgxCameraJobList read FCameraJobList;

This item has no description.

Published property CameraTarget: TgxBaseSceneObject read FCameraTarget write SetCameraTarget;

Assign a target, around which Moving object should rotate(usually TgxCamera.TargetObject).

Published property OnJobAdded : TgxCameraJobEvent read FOnJobAdded write SetOnJobAdded;

this event is triggered when a job is init

Published property OnJobFinished : TgxCameraJobEvent read FOnJobFinished write SetOnJobFinished;

this event is triggered when a job is finished (not canceled)

Published property OnJobStep : TgxCameraJobEvent read FOnJobStep write SetOnJobStep;

this event is triggered when a job is step (like an OnMove)

Published property soSafeDistance: double read FsoSafeDist write FsoSafeDist;

specifies whether user should be able interract with the GLSceneViewer it is set to false while the camera is moving and coders should check this value and block GUI access to GLSceneViewer property AllowUserAction:boolean read FAllowUserAction; safe distance to avoid moving the camera trough the camera.targetObject while performing SafeOrbitAndZoomToPos

Published property soTimeToOrbit: double read FsoTimeToOrbit write FsoTimeToOrbit;

time to orbit while performing SafeOrbitAndZoomToPos

Published property soTimeToSafePlacement: double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;

time to zoom in/out to the safe position while performing SafeOrbitAndZoomToPos

Published property soTimeToZoomBackIn: double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;

time to zoom in/out to the given final position while performing SafeOrbitAndZoomToPos


GXSysHelp v.2.5: GXS.Canvas

Unit GXS.Canvas

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Types
  • System.Classes
  • System.UITypes
  • System.Math
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GXS.Color
  • GXS.Context
  • GLScene.VectorTypes
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCanvas |

Types

TgxArcDirection = (...);

Description

Types

TgxArcDirection = (...);

This item has no description.

Values
  • adCounterClockWise
  • adClockWise


GXSysHelp v.2.5: GXS.Canvas: Class TgxCanvas

Class TgxCanvas

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Canvas

Declaration

type TgxCanvas = class(TObject)

Description

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

Hierarchy

  • TObject
  • TgxCanvas

Overview

Fields

Private | FBufferSizeX: Integer;
Private | FBufferSizeY: Integer;
Private | FLastPrimitive: Integer;
Private | FCurrentPos: TAffineVector;
Private | FPenColor: TColor;
Private | FPenWidth: Integer;
Private | FCurrentPenColorVector: TVector4f;
Private | FArcDirection: TgxArcDirection;

Methods

Public | constructor Create(bufferSizeX, bufferSizeY: Integer); overload;
Public | constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TMatrix4f); overload;
Public | destructor Destroy; override;
Public | procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure Ellipse(const x, y: Single; const Radius: Single); overload;
Public | procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const Radius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TgxColorVector); overload;
Public | procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TgxColorVector); overload;
Public | procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TgxColorVector); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Single); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TgxColorVector); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TgxColorVector); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Single); overload;
Public | procedure InvertYAxis;
Public | procedure Line(const x1, y1, x2, y2: Integer); overload;
Public | procedure Line(const x1, y1, x2, y2: Single); overload;
Public | procedure LineTo(const x, y: Integer); overload;
Public | procedure LineTo(const x, y: Single); overload;
Public | procedure LineToRel(const x, y: Integer); overload;
Public | procedure LineToRel(const x, y: Single); overload;
Public | procedure MoveTo(const x, y: Single); overload;
Public | procedure MoveTo(const x, y: Integer); overload;
Public | procedure MoveToRel(const x, y: Integer); overload;
Public | procedure MoveToRel(const x, y: Single); overload;
Public | procedure PlotPixel(const x, y: Single); overload;
Public | procedure PlotPixel(const x, y: Integer); overload;
Public | procedure Polygon(const points: array of TPoint);
Public | procedure Polyline(const points: array of TPoint);
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;
Public | procedure StopPrimitive;

Properties

Public | property ArcDirection: TgxArcDirection read FArcDirection write FArcDirection;
Public | property CanvasSizeX: Integer read FBufferSizeX;
Public | property CanvasSizeY: Integer read FBufferSizeY;
Public | property PenAlpha : Single read GetPenAlpha write SetPenAlpha;
Public | property PenColor: TColor read FPenColor write SetPenColor;
Public | property PenWidth: Integer read FPenWidth write SetPenWidth;

Description

Fields

Private FBufferSizeX: Integer;

This item has no description.

Private FBufferSizeY: Integer;

This item has no description.

Private FLastPrimitive: Integer;

This item has no description.

Private FCurrentPos: TAffineVector;

This item has no description.

Private FPenColor: TColor;

This item has no description.

Private FPenWidth: Integer;

This item has no description.

Private FCurrentPenColorVector: TVector4f;

This item has no description.

Private FArcDirection: TgxArcDirection;

This item has no description.

Methods

Public constructor Create(bufferSizeX, bufferSizeY: Integer); overload;

This item has no description.

Public constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TMatrix4f); overload;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;

This item has no description.

Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Draw an elliptical arc. The points (x1, y1) and (x2, y2) specify the bounding rectangle. An ellipse formed by the specified bounding rectangle defines the curve of the arc. The arc extends in the current drawing direction from the point where it intersects the radial from the center of the bounding rectangle to the (x3, y3) point. The arc ends where it intersects the radial from the center of the bounding rectangle to the (x4, y4) point. If the starting point and ending point are the same, a complete ellipse is drawn. Use the ArcDirection property to get and set the current drawing direction for a device context. The default drawing direction is counterclockwise.

Public procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;

This item has no description.

Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;

This item has no description.

Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Same as Arc but update the current position.

Public procedure Ellipse(const x, y: Single; const Radius: Single); overload;

This item has no description.

Public procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;

This item has no description.

Public procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draws and ellipse centered at (x, y) with given radiuses.

Public procedure EllipseBB(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;

Draws an ellipse with (x1,y1)-(x2, y2) bounding rectangle.

Public procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draw a filled ellipse.

Public procedure FillEllipse(const x, y: Single; const Radius: Single); overload;

This item has no description.

Public procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TgxColorVector); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TgxColorVector); overload;

This item has no description.

Public procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TgxColorVector); overload;

Draw a filled gradient ellipse. OpenGL will use the last PenColor and PenAlpha as the center color and do gradient to edge of ellipse using the edgeColor parameter.

Public procedure FillRect(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure FillRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with PenColor).

Public procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TgxColorVector); overload;

This item has no description.

Public procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TgxColorVector); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with given gradient's color).

Public procedure FrameRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle's frame (border).

Public procedure FrameRect(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure InvertYAxis;

Inverts the orientation of the Y Axis. If (0, 0) was in the top left corner, it will move to the bottom left corner or vice-versa.

Public procedure Line(const x1, y1, x2, y2: Integer); overload;

Draws a line from (x1, y1) to (x2, y2). The current position is NOT updated.

Public procedure Line(const x1, y1, x2, y2: Single); overload;

This item has no description.

Public procedure LineTo(const x, y: Integer); overload;

Draws a line from current position to given coordinate. Current position is updated.

Public procedure LineTo(const x, y: Single); overload;

This item has no description.

Public procedure LineToRel(const x, y: Integer); overload;

This item has no description.

Public procedure LineToRel(const x, y: Single); overload;

This item has no description.

Public procedure MoveTo(const x, y: Single); overload;

This item has no description.

Public procedure MoveTo(const x, y: Integer); overload;

Updates the current position (absolute coords).

Public procedure MoveToRel(const x, y: Integer); overload;

Updates the current position (relative coords).

Public procedure MoveToRel(const x, y: Single); overload;

This item has no description.

Public procedure PlotPixel(const x, y: Single); overload;

This item has no description.

Public procedure PlotPixel(const x, y: Integer); overload;

Plots a pixel at given coordinate. PenWidth affects pixel size. The current position is NOT updated.

Public procedure Polygon(const points: array of TPoint);

Similar to Polyline but also connects the last point to the first.

Public procedure Polyline(const points: array of TPoint);

Draws the set of lines defined by connecting the points. Similar to invoking MoveTo on the first point, then LineTo on all the following points.

Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;

This item has no description.

Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;

This item has no description.

Public procedure StopPrimitive;

Stops the current internal primitive. This function is invoked automatically by TGLCanvas when changeing primitives, you should directly call if you want to render your own stuff intertwined with TgxCanvas drawings. In that case, call it before your own OpenGL calls.

Properties

Public property ArcDirection: TgxArcDirection read FArcDirection write FArcDirection;

This item has no description.

Public property CanvasSizeX: Integer read FBufferSizeX;

This item has no description.

Public property CanvasSizeY: Integer read FBufferSizeY;

This item has no description.

Public property PenAlpha : Single read GetPenAlpha write SetPenAlpha;

Current Pen Alpha channel (from 0.0 to 1.0)

Public property PenColor: TColor read FPenColor write SetPenColor;

Current Pen Color.

Public property PenWidth: Integer read FPenWidth write SetPenWidth;

Current Pen Width.


GXSysHelp v.2.5: GXS.CelShader

Unit GXS.CelShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.Color
  • GLScene.TextureFormat
  • GXS.Texture
  • GXS.Context
  • GXS.Graphics
  • GXS.ImageUtils
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCelShader |

Types

TgxCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;
TgxCelShaderOption = (...);
TgxCelShaderOptions = set of TgxCelShaderOption;

Description

Types

TgxCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;

An event for user defined cel intensity.

TgxCelShaderOption = (...);

Cel shading options. csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

Values
  • csoOutlines
  • csoTextured
  • csoNoBuildShadeTexture
TgxCelShaderOptions = set of TgxCelShaderOption;


GXSysHelp v.2.5: GXS.CelShader: Class TgxCelShader

Class TgxCelShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CelShader

Declaration

type TgxCelShader = class(TgxShader)

Description

A generic cel shader.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCelShader

Overview

Fields

Private | FOutlineWidth: Single;
Private | FCelShaderOptions: TgxCelShaderOptions;
Private | FVPHandle: TgxVertexProgramHandle;
Private | FShadeTexture: TgxTexture;
Private | FOnGetIntensity: TgxCelShaderGetIntensity;
Private | FOutlinePass: Boolean;
Private | FUnApplyShadeTexture: Boolean;
Private | FOutlineColor: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;
Public | procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;

Properties

Published | property CelShaderOptions: TgxCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;
Published | property OnGetIntensity: TgxCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;
Published | property OutlineColor: TgxColor read FOutlineColor write SetOutlineColor;
Published | property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;
Public | property ShadeTexture: TgxTexture read FShadeTexture;

Description

Fields

Private FOutlineWidth: Single;

This item has no description.

Private FCelShaderOptions: TgxCelShaderOptions;

This item has no description.

Private FVPHandle: TgxVertexProgramHandle;

This item has no description.

Private FShadeTexture: TgxTexture;

This item has no description.

Private FOnGetIntensity: TgxCelShaderGetIntensity;

This item has no description.

Private FOutlinePass: Boolean;

This item has no description.

Private FUnApplyShadeTexture: Boolean;

This item has no description.

Private FOutlineColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;

This item has no description.

Public procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;

This item has no description.

Properties

Published property CelShaderOptions: TgxCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;

This item has no description.

Published property OnGetIntensity: TgxCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;

This item has no description.

Published property OutlineColor: TgxColor read FOutlineColor write SetOutlineColor;

This item has no description.

Published property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;

This item has no description.

Public property ShadeTexture: TgxTexture read FShadeTexture;


GXSysHelp v.2.5: GXS.CgBombShader

Unit GXS.CgBombShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.Texture
  • GXS.Cadencer
  • GXS.Context
  • GLScene.Strings
  • GXS.Material
  • GXS.RenderContextInfo
  • GLScene.TextureFormat
  • GXS.State
  • Cg.GL
  • GXS.CgShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class ECGxBombShaderException |
Class TCGxCustomBombShader |
Class TCGxBombShader |

Types

TCGxBombShaderTextureSource = (...);

Description

Types

TCGxBombShaderTextureSource = (...);

This item has no description.

Values
  • stsPrimaryTexture
  • stsSecondadyTexture
  • stsThirdTexture
  • stsUserSelectedTexture


GXSysHelp v.2.5: GXS.CgBombShader: Class ECGxBombShaderException

Class ECGxBombShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgBombShader

Declaration

type ECGxBombShaderException = class(ECGxShaderException)

Description

This item has no description. Showing description inherited from ECGxShaderException.

Define OutputCompilerWarnings to output CG compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECGxShaderException
  • ECGxBombShaderException


GXSysHelp v.2.5: GXS.CgBombShader: Class TCGxCustomBombShader

Class TCGxCustomBombShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgBombShader

Declaration

type TCGxCustomBombShader = class(TCGxCadencableCustomShader, IgxMaterialLibrarySupported)

Description

Just a good-looking shader.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxCadencableCustomShader
  • TCGxCustomBombShader

Overview

Fields

Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FGradientTexture: TgxTexture;
Private | FMainTexture: TgxTexture;
Private | FMainTextureName: TgxLibMaterialName;
Private | FGradientTextureName: TgxLibMaterialName;
Private | FSharpness: Single;
Private | FColorRange: Single;
Private | FSpeed: Single;
Private | FDisplacement: Single;
Private | FAlpha: Single;
Private | FTurbDensity: Single;
Private | FColorSharpness: Single;
Private | FGradientTextureShare: Single;
Private | FMainTextureShare: Single;
Private | FMainTextureSource: TCGxBombShaderTextureSource;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetGradientTextureName: TgxLibMaterialName;
Private | function GetMainTextureName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function StoreColorRange: Boolean;
Private | function StoreColorSharpness: Boolean;
Private | function StoreDisplacement: Boolean;
Private | function StoreGradientTextureShare: Boolean;
Private | function StoreMainTextureShare: Boolean;
Private | function StoreSharpness: Boolean;
Private | function StoreSpeed: Boolean;
Private | function StoreTurbDensity: Boolean;
Private | procedure SetGradientTexture(const Value: TgxTexture);
Private | procedure SetGradientTextureName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexture(const Value: TgxTexture);
Private | procedure SetMainTextureName(const Value: TgxLibMaterialName);

Properties

Public | property Alpha: Single read FAlpha write FAlpha;
Public | property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;
Public | property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;
Public | property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;
Public | property GradientTexture: TgxTexture read FGradientTexture write SetGradientTexture;
Public | property GradientTextureName: TgxLibMaterialName read GetGradientTextureName write SetGradientTextureName;
Public | property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;
Public | property MainTexture: TgxTexture read FMainTexture write SetMainTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;
Public | property MainTextureSource: TCGxBombShaderTextureSource read FMainTextureSource write FMainTextureSource;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;
Public | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Public | property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;

Description

Fields

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FGradientTexture: TgxTexture;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTextureName: TgxLibMaterialName;

This item has no description.

Private FGradientTextureName: TgxLibMaterialName;

This item has no description.

Private FSharpness: Single;

This item has no description.

Private FColorRange: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FDisplacement: Single;

This item has no description.

Private FAlpha: Single;

This item has no description.

Private FTurbDensity: Single;

This item has no description.

Private FColorSharpness: Single;

This item has no description.

Private FGradientTextureShare: Single;

This item has no description.

Private FMainTextureShare: Single;

This item has no description.

Private FMainTextureSource: TCGxBombShaderTextureSource;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetGradientTextureName: TgxLibMaterialName;

This item has no description.

Private function GetMainTextureName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private function StoreColorRange: Boolean;

This item has no description.

Private function StoreColorSharpness: Boolean;

This item has no description.

Private function StoreDisplacement: Boolean;

This item has no description.

Private function StoreGradientTextureShare: Boolean;

This item has no description.

Private function StoreMainTextureShare: Boolean;

This item has no description.

Private function StoreSharpness: Boolean;

This item has no description.

Private function StoreSpeed: Boolean;

This item has no description.

Private function StoreTurbDensity: Boolean;

This item has no description.

Private procedure SetGradientTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetGradientTextureName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetMainTextureName(const Value: TgxLibMaterialName);

This item has no description.

Properties

Public property Alpha: Single read FAlpha write FAlpha;

This item has no description.

Public property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;

This item has no description.

Public property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;

This item has no description.

Public property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;

This item has no description.

Public property GradientTexture: TgxTexture read FGradientTexture write SetGradientTexture;

This item has no description.

Public property GradientTextureName: TgxLibMaterialName read GetGradientTextureName write SetGradientTextureName;

This item has no description.

Public property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;

This item has no description.

Public property MainTexture: TgxTexture read FMainTexture write SetMainTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;

This item has no description.

Public property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;

This item has no description.

Public property MainTextureSource: TCGxBombShaderTextureSource read FMainTextureSource write FMainTextureSource;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;

This item has no description.

Public property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

This item has no description.

Public property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;


GXSysHelp v.2.5: GXS.CgBombShader: Class TCGxBombShader

Class TCGxBombShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgBombShader

Declaration

type TCGxBombShader = class(TCGxCustomBombShader)

Description

This item has no description. Showing description inherited from TCGxCustomBombShader.

Just a good-looking shader.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxCadencableCustomShader
  • TCGxCustomBombShader
  • TCGxBombShader

Overview

Properties

Published | property Alpha;
Published | property Cadencer;
Published | property ColorRange;
Published | property ColorSharpness;
Published | property DesignEnable;
Published | property Displacement;
Published | property GradientTextureName;
Published | property GradientTextureShare;
Published | property MainTextureName;
Published | property MainTextureShare;
Published | property MaterialLibrary;
Published | property Sharpness;
Published | property Speed;
Published | property TurbDensity;

Description

Properties

Published property Alpha;

This item has no description.

Published property Cadencer;

This item has no description.

Published property ColorRange;

This item has no description.

Published property ColorSharpness;

This item has no description.

Published property DesignEnable;

This item has no description.

Published property Displacement;

This item has no description.

Published property GradientTextureName;

This item has no description.

Published property GradientTextureShare;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MainTextureShare;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property Sharpness;

This item has no description.

Published property Speed;

This item has no description.

Published property TurbDensity;


GXSysHelp v.2.5: GXS.CgPostTransformationShader

Unit GXS.CgPostTransformationShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.Texture
  • GXS.Cadencer
  • GXS.Context
  • GXS.Scene
  • GXS.RenderContextInfo
  • GLScene.TextureFormat
  • GXSL.CustomShader
  • Cg.GL
  • Cg.Import
  • GXS.CgShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCGxCustomPostTransformationShader |
Class TCGxPostTransformationShader |


GXSysHelp v.2.5: GXS.CgPostTransformationShader: Class TCGxCustomPostTransformationShader

Class TCGxCustomPostTransformationShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgPostTransformationShader

Declaration

type TCGxCustomPostTransformationShader = class(TCGxCustomShader, IgxPostShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxCustomPostTransformationShader

Overview

Fields

Private | FTransformationPower: Single;
Private | FTransformationTexture: TgxTexture;

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Public | property TransformationPower: Single read FTransformationPower write FTransformationPower;
Public | property TransformationTexture: TgxTexture read FTransformationTexture write FTransformationTexture;

Description

Fields

Private FTransformationPower: Single;

This item has no description.

Private FTransformationTexture: TgxTexture;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Public property TransformationPower: Single read FTransformationPower write FTransformationPower;

This item has no description.

Public property TransformationTexture: TgxTexture read FTransformationTexture write FTransformationTexture;


GXSysHelp v.2.5: GXS.CgPostTransformationShader: Class TCGxPostTransformationShader

Class TCGxPostTransformationShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgPostTransformationShader

Declaration

type TCGxPostTransformationShader = class(TCGxCustomPostTransformationShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxCustomPostTransformationShader
  • TCGxPostTransformationShader

Overview

Properties

Published | property TransformationPower;
Published | property TransformationTexture;

Description

Properties

Published property TransformationPower;

This item has no description.

Published property TransformationTexture;


GXSysHelp v.2.5: GXS.CgRegister

Unit GXS.CgRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Material
  • Cg.Import
  • Cg.GL
  • GXS.SceneRegister
  • GXS.CgShader
  • GXS.CgBombShader

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

ToDo DesignIntf, not implemented DesignEditors, FMXEditors, for TgxLibMaterialNameProperty


GXSysHelp v.2.5: GXS.CgShader

Unit GXS.CgShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GXS.Texture
  • GLScene.Strings
  • GXS.Cadencer
  • GXS.Context
  • GXS.BaseClasses
  • GXS.RenderContextInfo
  • GXS.Material
  • GLScene.TextureFormat
  • Cg.Import
  • Cg.GL

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class ECGxShaderException |
Class TCGxProgram |
Class TCGxParameter |
Class TCGxVertexProgram |
Class TCGxFragmentProgram |
Class TCGxCustomShader |
Class TCGxCadencableCustomShader |
Class TCGxShader |

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Types

TCgFPProfile = (...);
TCgUnApplyEvent = procedure(CgProgram: TCGxProgram) of object;
TCgVPProfile = (...);
TCGxApplyEvent = procedure(CgProgram: TCGxProgram; Sender: TObject) of object;
TCGxProgramType = (...);
TCGxShaderEvent = procedure(CgShader: TCGxCustomShader) of object;
TPrecisionSetting = (...);

Variables

IncludeFilePath: string;

Description

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Misc. global functions

Types

TCgFPProfile = (...);

Available fragment program profile

Values
  • fpDetectLatest
  • fp20
  • fp30
  • fp40
  • arbfp1
TCgUnApplyEvent = procedure(CgProgram: TCGxProgram) of object;

This item has no description.

TCgVPProfile = (...);

Available vertex program profile

Values
  • vpDetectLatest
  • vp20
  • vp30
  • vp40
  • arbvp1
TCGxApplyEvent = procedure(CgProgram: TCGxProgram; Sender: TObject) of object;

This item has no description.

TCGxProgramType = (...);

This item has no description.

Values
  • ptVertex
  • ptFragment
TCGxShaderEvent = procedure(CgShader: TCGxCustomShader) of object;

This item has no description.

TPrecisionSetting = (...);

This item has no description.

Values
  • psFull
  • psFast

Variables

IncludeFilePath: string;

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.


GXSysHelp v.2.5: GXS.CgShader: Class ECGxShaderException

Class ECGxShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type ECGxShaderException = class(EShaderException)

Description

Define OutputCompilerWarnings to output CG compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECGxShaderException


GXSysHelp v.2.5: GXS.CgShader: Class TCGxProgram

Class TCGxProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxProgram = class(TgxUpdateAbleObject)

Description

Wrapper around a Cg program.

Hierarchy

  • TgxUpdateAbleObject
  • TCGxProgram

Overview

Fields

Private | FCgContext: PcgContext;
Private | FCode: TStrings;
Private | FProgramName: String;
Private | FHandle: PCGprogram;
Private | FParams: TList;
Private | FOnApply: TCGxApplyEvent;
Private | FOnUnApply: TCgUnApplyEvent;
Private | FOnProgramChanged: TNotifyEvent;
Private | FEnabled: boolean;
Private | FDetectProfile: boolean;
Private | FPrecision: TPrecisionSetting;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function DirectParamByName(const name: String): PCGParameter;
Public | function GetLatestProfile: TcgProfile; virtual; abstract;
Public | function GetProfileStringA: string;
Public | function LongName: string;
Public | function ParamByName(const name: String): TCGxParameter;
Public | function ParamCount: Integer;
Private | function GetManualNotification: boolean;
Public | procedure Apply(var rci: TgxRenderContextInfo; Sender: TObject);
Public | procedure Finalize;
Public | procedure Initialize; virtual;
Public | procedure ListCompilation(Output: TStrings);
Public | procedure ListParameters(Output: TStrings);
Public | procedure LoadFromFile(const fileName: String);
Public | procedure SetParam(ParamName: string; const Vector2fVal: TVector2f); overload;
Public | procedure SetParam(ParamName: string; const Vector3fVal: TVector3f); overload;
Public | procedure SetParam(ParamName: string; const Vector4fVal: TVector4f); overload;
Public | procedure SetParam(ParamName: string; SingleVal: Single); overload;
Public | procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);
Public | procedure SetTexture(ParamName: string; TextureID: Cardinal);
Public | procedure UnApply(var rci: TgxRenderContextInfo);
Private | procedure SetManualNotification(const Value: boolean);
Private | procedure SetPrecision(const Value: TPrecisionSetting);

Properties

Published | property Code: TStrings read FCode write SetCode;
Public | property DirectProfile: TcgProfile read FProfile write FProfile;
Published | property Enabled: boolean read FEnabled write FEnabled default True;
Public | property ManualNotification: boolean read GetManualNotification write SetManualNotification default False;
Published | property OnApply: TCGxApplyEvent read FOnApply write FOnApply;
Public | property OnProgramChanged: TNotifyEvent read FOnProgramChanged write FOnProgramChanged;
Published | property OnUnApply: TCgUnApplyEvent read FOnUnApply write FOnUnApply;
Public | property Param[index: String]: TCGxParameter read GetParam;
Public | property Params: TList read FParams;
Published | property Precision: TPrecisionSetting read FPrecision write SetPrecision default psFull;
Published | property ProgramName: String read FProgramName write SetProgramName;

Description

Fields

Private FCgContext: PcgContext;

This item has no description.

Private FCode: TStrings;

This item has no description.

Private FProgramName: String;

the Cg program itself

Private FHandle: PCGprogram;

This item has no description.

Private FParams: TList;

This item has no description.

Private FOnApply: TCGxApplyEvent;

This item has no description.

Private FOnUnApply: TCgUnApplyEvent;

This item has no description.

Private FOnProgramChanged: TNotifyEvent;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FDetectProfile: boolean;

This item has no description.

Private FPrecision: TPrecisionSetting;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DirectParamByName(const name: String): PCGParameter;

Returns a handle to a Cg parameter

Public function GetLatestProfile: TcgProfile; virtual; abstract;

This item has no description.

Public function GetProfileStringA: string;

This item has no description.

Public function LongName: string;

retruns ShaderName.[program type].ProgramName

Public function ParamByName(const name: String): TCGxParameter;

ParamByName returns CgParameter; returns nil if not found.

Public function ParamCount: Integer;

This item has no description.

Private function GetManualNotification: boolean;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo; Sender: TObject);

This item has no description.

Public procedure Finalize;

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure ListCompilation(Output: TStrings);

This item has no description.

Public procedure ListParameters(Output: TStrings);

This item has no description.

Public procedure LoadFromFile(const fileName: String);

This item has no description.

Public procedure SetParam(ParamName: string; const Vector2fVal: TVector2f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; const Vector3fVal: TVector3f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; const Vector4fVal: TVector4f); overload;

This item has no description.

Public procedure SetParam(ParamName: string; SingleVal: Single); overload;

shorthands for accessing parameters

Public procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);

This item has no description.

Public procedure SetTexture(ParamName: string; TextureID: Cardinal);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetManualNotification(const Value: boolean);

This item has no description.

Private procedure SetPrecision(const Value: TPrecisionSetting);

This item has no description.

Properties

Published property Code: TStrings read FCode write SetCode;

This item has no description.

Public property DirectProfile: TcgProfile read FProfile write FProfile;

Direct access to the profile. Set Profile of the sub-classes to any but DetectLatest if you want to specify the profile directly.

Published property Enabled: boolean read FEnabled write FEnabled default True;

This item has no description.

Public property ManualNotification: boolean read GetManualNotification write SetManualNotification default False;

If True, that shader is not reset when TCGxProgram' parameters change.

Published property OnApply: TCGxApplyEvent read FOnApply write FOnApply;

This item has no description.

Public property OnProgramChanged: TNotifyEvent read FOnProgramChanged write FOnProgramChanged;

Seams, that this event is never called. Probably should be deleted...

Published property OnUnApply: TCgUnApplyEvent read FOnUnApply write FOnUnApply;

This item has no description.

Public property Param[index: String]: TCGxParameter read GetParam;

Use Param instead of ParamByName if you want implicit check for the existence of your requested parameter.

Public property Params: TList read FParams;

This item has no description.

Published property Precision: TPrecisionSetting read FPrecision write SetPrecision default psFull;

Precision controls data precision of GPU operation. Possible options are 16-bit (psFast) or 32-bit (psFull). 16-bit operation is generally faster.

Published property ProgramName: String read FProgramName write SetProgramName;


GXSysHelp v.2.5: GXS.CgShader: Class TCGxParameter

Class TCGxParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxParameter = class(TObject)

Description

Wrapper around a Cg parameter of the main program.

Hierarchy

  • TObject
  • TCGxParameter

Overview

Fields

Private | FOwner: TCGxProgram;
Private | FName: String;
Private | FHandle: PCGParameter;
Private | FValueType: TCGtype;
Private | FDirection: TCGenum;
Private | FVariability: TCGenum;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function LongName: string;
Public | procedure DisableClientState;
Public | procedure DisableTexture;
Public | procedure EnableClientState;
Public | procedure EnableTexture;
Public | procedure SetAsMatrix(const val: TMatrix4f);
Public | procedure SetAsScalar(const val: Single); overload;
Public | procedure SetAsScalar(const val: boolean); overload;
Public | procedure SetAsStateMatrix(matrix, Transform: Cardinal);
Public | procedure SetAsTexture(TextureID: Cardinal);
Public | procedure SetAsTexture1D(TextureID: Cardinal);
Public | procedure SetAsTexture2D(TextureID: Cardinal);
Public | procedure SetAsTexture3D(TextureID: Cardinal);
Public | procedure SetAsTextureCUBE(TextureID: Cardinal);
Public | procedure SetAsTextureRECT(TextureID: Cardinal);
Public | procedure SetAsVector(const val: TVector4f); overload;
Public | procedure SetAsVector(const val: TVector3f); overload;
Public | procedure SetAsVector(const val: TVector2f); overload;
Public | procedure SetAsVector(const val: array of Single); overload;
Public | procedure SetParameterPointer(Values: TgxVectorList); overload;
Public | procedure SetParameterPointer(Values: TgxAffineVectorList); overload;
Public | procedure SetToTextureOf(LibMaterial: TgxLibMaterial);

Properties

Public | property AsAffineVector: TAffineVector write SetAsVector3f;
Public | property AsVector: TVector4f write SetAsVector4f;
Public | property AsVector2f: TVector2f write SetAsVector2f;
Public | property Direction: TCGenum read FDirection write FDirection;
Public | property Handle: PCGParameter read FHandle write FHandle;
Public | property Name: String read FName;
Public | property Owner: TCGxProgram read FOwner;
Public | property ValueType: TCGtype read FValueType;
Public | property Variability: TCGenum read FVariability write FVariability;

Description

Fields

Private FOwner: TCGxProgram;

This item has no description.

Private FName: String;

This item has no description.

Private FHandle: PCGParameter;

This item has no description.

Private FValueType: TCGtype;

This item has no description.

Private FDirection: TCGenum;

e.g. CG_FLOAT

Private FVariability: TCGenum;

e.g. CG_INOUT

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LongName: string;

LongName retruns ShaderName.[program type].ProgramName.ParamName.

Public procedure DisableClientState;

This item has no description.

Public procedure DisableTexture;

This item has no description.

Public procedure EnableClientState;

This item has no description.

Public procedure EnableTexture;

This item has no description.

Public procedure SetAsMatrix(const val: TMatrix4f);

This item has no description.

Public procedure SetAsScalar(const val: Single); overload;

Procedures for setting uniform pamareters. Implicitly check for data type.

Public procedure SetAsScalar(const val: boolean); overload;

This item has no description.

Public procedure SetAsStateMatrix(matrix, Transform: Cardinal);

This item has no description.

Public procedure SetAsTexture(TextureID: Cardinal);

SetAsTexture checks for all texture types

Public procedure SetAsTexture1D(TextureID: Cardinal);

SetAsTexture* check for specific type

Public procedure SetAsTexture2D(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTexture3D(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTextureCUBE(TextureID: Cardinal);

This item has no description.

Public procedure SetAsTextureRECT(TextureID: Cardinal);

This item has no description.

Public procedure SetAsVector(const val: TVector4f); overload;

This item has no description.

Public procedure SetAsVector(const val: TVector3f); overload;

This item has no description.

Public procedure SetAsVector(const val: TVector2f); overload;

This item has no description.

Public procedure SetAsVector(const val: array of Single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVector([0.1, 0.2]). Array length must between 1-4.

Public procedure SetParameterPointer(Values: TgxVectorList); overload;

Procedures for setting varying parameters with an array of values.

Public procedure SetParameterPointer(Values: TgxAffineVectorList); overload;

This item has no description.

Public procedure SetToTextureOf(LibMaterial: TgxLibMaterial);

SetToTextureOf determines texture type on-the-fly.

Properties

Public property AsAffineVector: TAffineVector write SetAsVector3f;

position f.i.

Public property AsVector: TVector4f write SetAsVector4f;

GLScene-friendly properties

Public property AsVector2f: TVector2f write SetAsVector2f;

normal f.i.

Public property Direction: TCGenum read FDirection write FDirection;

This item has no description.

Public property Handle: PCGParameter read FHandle write FHandle;

This item has no description.

Public property Name: String read FName;

This item has no description.

Public property Owner: TCGxProgram read FOwner;

This item has no description.

Public property ValueType: TCGtype read FValueType;

This item has no description.

Public property Variability: TCGenum read FVariability write FVariability;


GXSysHelp v.2.5: GXS.CgShader: Class TCGxVertexProgram

Class TCGxVertexProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxVertexProgram = class(TCGxProgram)

Description

This item has no description. Showing description inherited from TCGxProgram.

Wrapper around a Cg program.

Hierarchy

  • TgxUpdateAbleObject
  • TCGxProgram
  • TCGxVertexProgram

Overview

Fields

Private FVPProfile: TCgVPProfile;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;
Private | procedure SetVPProfile(v: TCgVPProfile);

Properties

Published property Profile: TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;

Description

Fields

Private FVPProfile: TCgVPProfile;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function GetLatestProfile: TcgProfile; override;

This item has no description.

Private procedure SetVPProfile(v: TCgVPProfile);

This item has no description.

Properties

Published property Profile: TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;


GXSysHelp v.2.5: GXS.CgShader: Class TCGxFragmentProgram

Class TCGxFragmentProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxFragmentProgram = class(TCGxProgram)

Description

This item has no description. Showing description inherited from TCGxProgram.

Wrapper around a Cg program.

Hierarchy

  • TgxUpdateAbleObject
  • TCGxProgram
  • TCGxFragmentProgram

Overview

Fields

Private | FFPProfile: TCgFPProfile;
Private | FManageTexture: boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;
Public | procedure Initialize; override;
Private | procedure SetFPProfile(v: TCgFPProfile);
Private | procedure SetManageTexture(const Value: boolean);

Properties

Published | property ManageTexture: boolean read FManageTexture write SetManageTexture default False;
Published | property Profile: TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;

Description

Fields

Private FFPProfile: TCgFPProfile;

This item has no description.

Private FManageTexture: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function GetLatestProfile: TcgProfile; override;

This item has no description.

Public procedure Initialize; override;

This item has no description.

Private procedure SetFPProfile(v: TCgFPProfile);

This item has no description.

Private procedure SetManageTexture(const Value: boolean);

This item has no description.

Properties

Published property ManageTexture: boolean read FManageTexture write SetManageTexture default False;

Switch for auto enabling of texture parameters (Cg 1.2 feature) With Cg 1.2.1, default is OFF

Published property Profile: TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;


GXSysHelp v.2.5: GXS.CgShader: Class TCGxCustomShader

Class TCGxCustomShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxCustomShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader

Overview

Fields

Private | FVertexProgram: TCGxVertexProgram;
Private | FFragmentProgram: TCGxFragmentProgram;
Private | FOnInitialize: TCGxShaderEvent;
Private | FDesignEnable: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: boolean; override;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename: string);

Description

Fields

Private FVertexProgram: TCGxVertexProgram;

This item has no description.

Private FFragmentProgram: TCGxFragmentProgram;

This item has no description.

Private FOnInitialize: TCGxShaderEvent;

This item has no description.

Private FDesignEnable: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: boolean; override;

This item has no description. Showing description inherited from TgxShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure LoadShaderPrograms(const VPFilename, FPFilename: string);


GXSysHelp v.2.5: GXS.CgShader: Class TCGxCadencableCustomShader

Class TCGxCadencableCustomShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxCadencableCustomShader = class(TCGxCustomShader)

Description

Allows to use a Cadencer, which is used for noise generation in many shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxCadencableCustomShader

Overview

Fields

Private FCadencer: TgxCadencer;

Methods

Private procedure SetCadencer(const Value: TgxCadencer);

Properties

Public property Cadencer: TgxCadencer read FCadencer write SetCadencer;

Description

Fields

Private FCadencer: TgxCadencer;

This item has no description.

Methods

Private procedure SetCadencer(const Value: TgxCadencer);

This item has no description.

Properties

Public property Cadencer: TgxCadencer read FCadencer write SetCadencer;


GXSysHelp v.2.5: GXS.CgShader: Class TCGxShader

Class TCGxShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CgShader

Declaration

type TCGxShader = class(TCGxCustomShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TCGxCustomShader
  • TCGxShader

Overview

Properties

Published | property DesignEnable;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property OnApplyFP;
Published | property OnApplyVP;
Published | property OnInitialize;
Published | property OnUnApplyFP;
Published | property OnUnApplyVP;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property DesignEnable;

This item has no description.

Published property FailedInitAction;

This item has no description. Showing description inherited from TgxShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property OnApplyFP;

This item has no description.

Published property OnApplyVP;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnUnApplyFP;

This item has no description.

Published property OnUnApplyVP;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TgxShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property VertexProgram;


GXSysHelp v.2.5: GXS.Collision

Unit GXS.Collision

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.GeometryBB
  • GLScene.Manager
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCollisionManager |
Class TgxBCollision |

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckPointVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckPointVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckPointVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckSphereVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckSphereVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckSphereVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckSphereVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckEllipsoidVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckEllipsoidVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckEllipsoidVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckEllipsoidVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckCubeVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckCubeVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckCubeVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckCubeVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckCubeVsFace(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckFaceVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;
function FastCheckFaceVsFace(obj1, obj2: TgxBaseSceneObject): Boolean;
function IntersectCubes(obj1, obj2: TgxBaseSceneObject): Boolean; overload;
function GetOrCreateCollision(behaviours: TgxBehaviours) : TgxBCollision; overload;
function GetOrCreateCollision(obj: TgxBaseSceneObject): TgxBCollision; overload;

Types

PFastCollisionChecker = ˆTFastCollisionChecker;
TCollisionBoundingMode = (...);
TFastCollisionChecker = function(obj1, obj2: TgxBaseSceneObject): Boolean;
TObjectCollisionEvent = procedure(Sender: TObject; object1, object2: TgxBaseSceneObject) of object;

Description

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;

Fast Collision detection routines that are heavily specialized and just return a boolean

function FastCheckPointVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckPointVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckPointVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckSphereVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckEllipsoidVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsPoint(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsSphere(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsEllipsoid(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckCubeVsFace(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

function FastCheckFaceVsCube(obj1, obj2: TgxBaseSceneObject): Boolean;

experimental

function FastCheckFaceVsFace(obj1, obj2: TgxBaseSceneObject): Boolean;

experimental

function IntersectCubes(obj1, obj2: TgxBaseSceneObject): Boolean; overload;

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.

function GetOrCreateCollision(behaviours: TgxBehaviours) : TgxBCollision; overload;

Returns or creates the TgxBCollision within the given behaviours. This helper function is convenient way to access a TgxBCollision.

function GetOrCreateCollision(obj: TgxBaseSceneObject): TgxBCollision; overload;

Returns or creates the TgxBCollision within the given object's behaviours. This helper function is convenient way to access a TgxBCollision.

Types

PFastCollisionChecker = ˆTFastCollisionChecker;

This item has no description.

TCollisionBoundingMode = (...);

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code)

Values
  • cbmPoint
  • cbmSphere
  • cbmEllipsoid
  • cbmCube
  • cbmFaces
TFastCollisionChecker = function(obj1, obj2: TgxBaseSceneObject): Boolean;

This item has no description.

TObjectCollisionEvent = procedure(Sender: TObject; object1, object2: TgxBaseSceneObject) of object;


GXSysHelp v.2.5: GXS.Collision: Class TgxCollisionManager

Class TgxCollisionManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Collision

Declaration

type TgxCollisionManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxCollisionManager

Overview

Fields

Private | FClients: TList;
Private | FOnCollision: TObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CheckCollisions;

Properties

Published property OnCollision: TObjectCollisionEvent read FOnCollision write FOnCollision;

Description

Fields

Private FClients: TList;

This item has no description.

Private FOnCollision: TObjectCollisionEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CheckCollisions;

This item has no description.

Properties

Published property OnCollision: TObjectCollisionEvent read FOnCollision write FOnCollision;


GXSysHelp v.2.5: GXS.Collision: Class TgxBCollision

Class TgxBCollision

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Collision

Declaration

type TgxBCollision = class(TgxBehaviour)

Description

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TgxBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBCollision

Overview

Fields

Private | FBoundingMode: TCollisionBoundingMode;
Private | FManager: TgxCollisionManager;
Private | FManagerName: String;
Private | FGroupIndex: Integer;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BoundingMode: TCollisionBoundingMode read FBoundingMode write FBoundingMode;
Published | property GroupIndex: Integer read FGroupIndex write SetGroupIndex;
Published | property Manager: TgxCollisionManager read FManager write SetManager;

Description

Fields

Private FBoundingMode: TCollisionBoundingMode;

This item has no description.

Private FManager: TgxCollisionManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FGroupIndex: Integer;

NOT persistent, temporarily used for persistence

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Properties

Published property BoundingMode: TCollisionBoundingMode read FBoundingMode write FBoundingMode;

This item has no description.

Published property GroupIndex: Integer read FGroupIndex write SetGroupIndex;

This item has no description.

Published property Manager: TgxCollisionManager read FManager write SetManager;

Refers the collision manager.


GXSysHelp v.2.5: GXS.CompositeImage

Unit GXS.CompositeImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • FMX.Graphics
  • GLScene.TextureFormat
  • GXS.Graphics
  • GXS.Texture
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCompositeImage |


GXSysHelp v.2.5: GXS.CompositeImage: Class TgxCompositeImage

Class TgxCompositeImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CompositeImage

Declaration

type TgxCompositeImage = class(TgxTextureImage)

Description

This item has no description. Showing description inherited from TgxTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxCompositeImage

Overview

Fields

Private | FBitmap: TgxBitmap32;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FDepth: integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxBitmap32; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadFromStream(const AStream: TStream);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Published | property Depth: Integer read GetDepth write SetDepth;
Published | property Height: Integer read GetHeight write SetHeight;
Public | property NativeTextureTarget;
Published | property Width: Integer read GetWidth write SetWidth;

Description

Fields

Private FBitmap: TgxBitmap32;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FDepth: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure LoadFromStream(const AStream: TStream);

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Published property Depth: Integer read GetDepth write SetDepth;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight;

This item has no description.

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TgxTextureImage.NativeTextureTarget.

Native OpenGL texture target.

Published property Width: Integer read GetWidth write SetWidth;


GXSysHelp v.2.5: GXS.Console

Unit GXS.Console

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • System.UITypes
  • System.UIConsts
  • FMX.Graphics
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.Strings
  • GLScene.Utils
  • GXS.Coordinates
  • GXS.Scene
  • GXS.Objects
  • GXS.HUDObjects
  • GXS.SceneViewer
  • GXS.BitmapFont
  • GXS.Context
  • GXS.Texture
  • GXS.Material
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLConsoleException |
Record TgxUserInputCommand |
Class TgxConsoleStringList |
Class TgxConsoleCommand |
Class TgxConsoleCommandList |
Class TgxConsoleControls |
Class TgxCustomConsole |
Class TgxConsole |

Types

TgxConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;
TgxConsoleOption = (...);
TgxConsoleOptions = set of TgxConsoleOption;
TgxlConsoleEvent = procedure(const ConsoleCommand: TgxConsoleCommand; const Console: TgxCustomConsole; var Command: TgxUserInputCommand) of object;

Constants

CONSOLE_MAX_COMMANDS = 120;

Description

Types

TgxConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;

This item has no description.

TgxConsoleOption = (...);

This item has no description.

Values
  • coAutoCompleteCommandsOnKeyPress
  • coAutoCompleteCommandsOnEnter: commands are auto-completed as user types them
  • coShowConsoleHelpIfUnknownCommand: commands are auto-completed when user presses the "Enter" key
  • coRemoveQuotes: take a wild guess ;)
TgxConsoleOptions = set of TgxConsoleOption;

remove quotes when a command line is parsed

TgxlConsoleEvent = procedure(const ConsoleCommand: TgxConsoleCommand; const Console: TgxCustomConsole; var Command: TgxUserInputCommand) of object;

Event called when used presses the "Enter"

Constants

CONSOLE_MAX_COMMANDS = 120;


GXSysHelp v.2.5: GXS.Console: Class EGLConsoleException

Class EGLConsoleException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type EGLConsoleException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLConsoleException


GXSysHelp v.2.5: GXS.Console: Record TgxUserInputCommand

Record TgxUserInputCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxUserInputCommand = record

Description

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

Overview

Fields

Public | CommandCount: Integer;
Public | Strings: array of string;
Public | UnknownCommand: Boolean;

Description

Fields

Public CommandCount: Integer;

This item has no description.

Public Strings: array of string;

This item has no description.

Public UnknownCommand: Boolean;


GXSysHelp v.2.5: GXS.Console: Class TgxConsoleStringList

Class TgxConsoleStringList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxConsoleStringList = class(TStringList)

Description

A class that checks for duplicates.

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TgxConsoleStringList

Overview

Fields

Private FConsole: TgxCustomConsole;

Methods

Public | constructor Create(const Owner: TgxCustomConsole);
Public | function CommandExists(const Command: string): Boolean;

Description

Fields

Private FConsole: TgxCustomConsole;

This item has no description.

Methods

Public constructor Create(const Owner: TgxCustomConsole);

This item has no description.

Public function CommandExists(const Command: string): Boolean;


GXSysHelp v.2.5: GXS.Console: Class TgxConsoleCommand

Class TgxConsoleCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxConsoleCommand = class(TCollectionItem)

Description

A wrapper for a console command.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxConsoleCommand

Overview

Fields

Private | FVisible: Boolean;
Private | FEnabled: Boolean;
Private | FSilentDisabled: Boolean;
Private | FCommandList: TgxConsoleCommandList;
Private | FCommandName: string;
Private | FShortHelp: string;
Private | FLongHelp: TStringList;
Private | FOnCommand: TgxlConsoleEvent;
Private | FOnHelp: TNotifyEvent;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ShowHelp; virtual;
Public | procedure ShowShortHelp; virtual;
Private | procedure SetCommandName(const Value: string);

Properties

Published | property CommandName: string read FCommandName write SetCommandName;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property LongHelp: TStringList read FLongHelp;
Published | property OnCommand: TgxlConsoleEvent read FOnCommand write FOnCommand;
Published | property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;
Published | property ShortHelp: string read FShortHelp write FShortHelp;
Published | property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;
Published | property Visible: Boolean read FVisible write FVisible default True;

Description

Fields

Private FVisible: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSilentDisabled: Boolean;

This item has no description.

Private FCommandList: TgxConsoleCommandList;

This item has no description.

Private FCommandName: string;

This item has no description.

Private FShortHelp: string;

This item has no description.

Private FLongHelp: TStringList;

This item has no description.

Private FOnCommand: TgxlConsoleEvent;

This item has no description.

Private FOnHelp: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ShowHelp; virtual;

procedures

Public procedure ShowShortHelp; virtual;

This item has no description.

Private procedure SetCommandName(const Value: string);

This item has no description.

Properties

Published property CommandName: string read FCommandName write SetCommandName;

properties

Published property Enabled: Boolean read FEnabled write FEnabled default True;

Disabled commands won't execute

Published property LongHelp: TStringList read FLongHelp;

This item has no description.

Published property OnCommand: TgxlConsoleEvent read FOnCommand write FOnCommand;

This item has no description.

Published property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;

This item has no description.

Published property ShortHelp: string read FShortHelp write FShortHelp;

This item has no description.

Published property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;

If command is disabled and user calls it, no error report will be generated if SilentDisabled is enabled

Published property Visible: Boolean read FVisible write FVisible default True;

Hidden commands won't show when user requests command list or uses auto-complete


GXSysHelp v.2.5: GXS.Console: Class TgxConsoleCommandList

Class TgxConsoleCommandList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxConsoleCommandList = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxConsoleCommandList

Overview

Fields

Private FConsole: TgxCustomConsole;

Methods

Public | constructor Create(const AOwner: TgxCustomConsole);
Public | destructor Destroy; override;
Public | function Add: TgxConsoleCommand; overload;
Public | function CommandExists(const Command: string): Boolean;
Public | function GetCommandIndex(const Command: string): Integer;
Public | function LastConsoleCommand: TgxConsoleCommand;
Private | function GetItems(const Index: Integer): TgxConsoleCommand;
Public | procedure SortCommands(const Ascending: Boolean = True);

Properties

Public property Items[const Index: Integer]: TgxConsoleCommand read GetItems;

Description

Fields

Private FConsole: TgxCustomConsole;

This item has no description.

Methods

Public constructor Create(const AOwner: TgxCustomConsole);

Standard stuff.

Public destructor Destroy; override;

This item has no description.

Public function Add: TgxConsoleCommand; overload;

This item has no description.

Public function CommandExists(const Command: string): Boolean;

This item has no description.

Public function GetCommandIndex(const Command: string): Integer;

This item has no description.

Public function LastConsoleCommand: TgxConsoleCommand;

General list stuff.

Private function GetItems(const Index: Integer): TgxConsoleCommand;

This item has no description.

Public procedure SortCommands(const Ascending: Boolean = True);

This item has no description.

Properties

Public property Items[const Index: Integer]: TgxConsoleCommand read GetItems;


GXSysHelp v.2.5: GXS.Console: Class TgxConsoleControls

Class TgxConsoleControls

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxConsoleControls = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxConsoleControls

Overview

Fields

Private | FOwner: TPersistent;
Private | FNavigatePageUp: Byte;
Private | FAutoCompleteCommand: Byte;
Private | FPreviousCommand: Byte;
Private | FNextCommand: Byte;
Private | FNavigateUp: Byte;
Private | FNavigatePageDown: Byte;
Private | FNavigateDown: Byte;
Private | FDblClickDelay: Integer;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default VK_CONTROL;
Published | property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;
Published | property NavigateDown: Byte read FNavigateDown write FNavigateDown default VK_END;
Published | property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default VK_NEXT;
Published | property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default VK_PRIOR;
Published | property NavigateUp: Byte read FNavigateUp write FNavigateUp default VK_HOME;
Published | property NextCommand: Byte read FNextCommand write FNextCommand default VK_DOWN;
Published | property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default VK_UP;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FNavigatePageUp: Byte;

This item has no description.

Private FAutoCompleteCommand: Byte;

This item has no description.

Private FPreviousCommand: Byte;

This item has no description.

Private FNextCommand: Byte;

This item has no description.

Private FNavigateUp: Byte;

This item has no description.

Private FNavigatePageDown: Byte;

This item has no description.

Private FNavigateDown: Byte;

This item has no description.

Private FDblClickDelay: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default VK_CONTROL;

This item has no description.

Published property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;

This item has no description.

Published property NavigateDown: Byte read FNavigateDown write FNavigateDown default VK_END;

This item has no description.

Published property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default VK_NEXT;

This item has no description.

Published property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default VK_PRIOR;

This item has no description.

Published property NavigateUp: Byte read FNavigateUp write FNavigateUp default VK_HOME;

This item has no description.

Published property NextCommand: Byte read FNextCommand write FNextCommand default VK_DOWN;

This item has no description.

Published property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default VK_UP;


GXSysHelp v.2.5: GXS.Console: Class TgxCustomConsole

Class TgxCustomConsole

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxCustomConsole = class(TgxBaseSceneObject)

Description

TgxCustomConsole

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomConsole

Overview

Fields

Private | FHudSprite: TgxHudSprite;
Private | FHudText: TgxHudText;
Private | FSceneViewer: TgxSceneViewer;
Private | FInputLine: string;
Private | FStartLine: Integer;
Private | FCurrentCommand: Integer;
Private | FPreviousTickCount: Integer;
Private | FSize: Single;
Private | FColsoleLog: TStringList;
Private | FCommands: TgxConsoleCommandList;
Private | FAdditionalCommands: TgxConsoleStringList;
Private | FTypedCommands: TStringList;
Private | FControls: TgxConsoleControls;
Private | FOnCommandIssued: TgxlConsoleEvent;
Private | FOptions: TgxConsoleOptions;
Private | FHint: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetFont: TgxCustomBitmapFont;
Public | procedure AddLine(const str: string);
Public | procedure ClearTypedCommands;
Public | procedure ExecuteCommand(const Command: string);
Public | procedure ExecuteCommands(const Commands: TStrings);
Public | procedure NavigateDown;
Public | procedure NavigatePageDown;
Public | procedure NavigatePageUp;
Public | procedure NavigateUp;
Public | procedure ProcessKeyDown(const key: word); virtual;
Public | procedure ProcessKeyPress(const c: Char); virtual;
Public | procedure RefreshHudSize; virtual;
Private | procedure SetFont(const Value: TgxCustomBitmapFont);
Private | procedure SetSceneViewer(const Value: TgxSceneViewer);
Private | procedure SetSize(const Value: Single);

Properties

Public | property AdditionalCommands: TgxConsoleStringList read FAdditionalCommands;
Public | property ColsoleLog: TStringList read FColsoleLog;
Public | property Commands: TgxConsoleCommandList read FCommands;
Public | property Controls: TgxConsoleControls read FControls;
Public | property Font: TgxCustomBitmapFont read GetFont write SetFont stored False;
Public | property FontColor: TColor read GetFontColor write SetFontColor stored False;
Public | property Hint: string read FHint write FHint;
Public | property HudSprite: TgxHudSprite read FHudSprite;
Public | property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;
Public | property HudText: TgxHudText read FHudText;
Public | property InputLine: string read FInputLine write FInputLine;
Public | property OnCommandIssued: TgxlConsoleEvent read FOnCommandIssued write FOnCommandIssued;
Public | property Options: TgxConsoleOptions read FOptions write FOptions;
Public | property SceneViewer: TgxSceneViewer read FSceneViewer write SetSceneViewer;
Public | property Size: Single read FSize write SetSize;
Public | property TypedCommands: TStringList read FTypedCommands;
Public | property Visible default False;

Description

Fields

Private FHudSprite: TgxHudSprite;

This item has no description.

Private FHudText: TgxHudText;

This item has no description.

Private FSceneViewer: TgxSceneViewer;

This item has no description.

Private FInputLine: string;

This item has no description.

Private FStartLine: Integer;

This item has no description.

Private FCurrentCommand: Integer;

This item has no description.

Private FPreviousTickCount: Integer;

This item has no description.

Private FSize: Single;

This item has no description.

Private FColsoleLog: TStringList;

This item has no description.

Private FCommands: TgxConsoleCommandList;

This item has no description.

Private FAdditionalCommands: TgxConsoleStringList;

This item has no description.

Private FTypedCommands: TStringList;

This item has no description.

Private FControls: TgxConsoleControls;

This item has no description.

Private FOnCommandIssued: TgxlConsoleEvent;

This item has no description.

Private FOptions: TgxConsoleOptions;

This item has no description.

Private FHint: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetFont: TgxCustomBitmapFont;

This item has no description.

Public procedure AddLine(const str: string);

Adds a line (which is not treated as a command).

Public procedure ClearTypedCommands;

TypedCommands are cleared and current command index is reset.

Public procedure ExecuteCommand(const Command: string);

This item has no description.

Public procedure ExecuteCommands(const Commands: TStrings);

This item has no description.

Public procedure NavigateDown;

This item has no description.

Public procedure NavigatePageDown;

This item has no description.

Public procedure NavigatePageUp;

This item has no description.

Public procedure NavigateUp;

Navigation through code from outside

Public procedure ProcessKeyDown(const key: word); virtual;

This item has no description.

Public procedure ProcessKeyPress(const c: Char); virtual;

Methods: User *must* call these methods in his code.

Public procedure RefreshHudSize; virtual;

Refreshes the size of the hud to reflect changes on the viewer. Should be called whenever the viewer's size changes.

Private procedure SetFont(const Value: TgxCustomBitmapFont);

This item has no description.

Private procedure SetSceneViewer(const Value: TgxSceneViewer);

This item has no description.

Private procedure SetSize(const Value: Single);

This item has no description.

Properties

Public property AdditionalCommands: TgxConsoleStringList read FAdditionalCommands;

Aditional commands can be registered to participate in command auto-completion. They can be interpreted in the global OnCommandIssued event handler.

Public property ColsoleLog: TStringList read FColsoleLog;

list of commands that user typed and console's responces.

Public property Commands: TgxConsoleCommandList read FCommands;

Commands have events that are called when user types a sertauin command

Public property Controls: TgxConsoleControls read FControls;

User controls.

Public property Font: TgxCustomBitmapFont read GetFont write SetFont stored False;

This item has no description.

Public property FontColor: TColor read GetFontColor write SetFontColor stored False;

Changes the console font color.

Public property Hint: string read FHint write FHint;

Standard stuff

Public property HudSprite: TgxHudSprite read FHudSprite;

This item has no description.

Public property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;

This item has no description.

Public property HudText: TgxHudText read FHudText;

This item has no description.

Public property InputLine: string read FInputLine write FInputLine;

Where user enters his commands.

Public property OnCommandIssued: TgxlConsoleEvent read FOnCommandIssued write FOnCommandIssued;

Main event of the console. Happens whenever the enter key is pressed. First the input line is compared to all registered commands, then everything is parsed into a TgxUserInputCommand record and sent to the event. Empty lines are not ignored (i.e. they also trigger events)

Public property Options: TgxConsoleOptions read FOptions write FOptions;

This item has no description.

Public property SceneViewer: TgxSceneViewer read FSceneViewer write SetSceneViewer;

Visual stuff.

Public property Size: Single read FSize write SetSize;

Allows to change consol's height from 0 to 1.

Public property TypedCommands: TStringList read FTypedCommands;

List of commands that user typed.

Public property Visible default False;


GXSysHelp v.2.5: GXS.Console: Class TgxConsole

Class TgxConsole

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Console

Declaration

type TgxConsole = class(TgxCustomConsole)

Description

This item has no description. Showing description inherited from TgxCustomConsole.

TgxCustomConsole

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomConsole
  • TgxConsole

Overview

Properties

Published | property AdditionalCommands;
Published | property ColsoleLog;
Published | property Commands;
Published | property Controls;
Published | property Font;
Published | property FontColor;
Published | property Hint;
Published | property HudSprite;
Published | property HUDSpriteColor;
Published | property HudText;
Published | property InputLine;
Published | property ObjectsSorting;
Published | property OnCommandIssued;
Published | property OnProgress;
Published | property Options;
Published | property SceneViewer;
Published | property Tag;
Published | property TypedCommands;
Published | property Visible;

Description

Properties

Published property AdditionalCommands;

This item has no description. Showing description inherited from TgxCustomConsole.AdditionalCommands.

Aditional commands can be registered to participate in command auto-completion. They can be interpreted in the global OnCommandIssued event handler.

Published property ColsoleLog;

This item has no description. Showing description inherited from TgxCustomConsole.ColsoleLog.

list of commands that user typed and console's responces.

Published property Commands;

This item has no description. Showing description inherited from TgxCustomConsole.Commands.

Commands have events that are called when user types a sertauin command

Published property Controls;

This item has no description. Showing description inherited from TgxCustomConsole.Controls.

User controls.

Published property Font;

This item has no description.

Published property FontColor;

This item has no description. Showing description inherited from TgxCustomConsole.FontColor.

Changes the console font color.

Published property Hint;

This item has no description. Showing description inherited from TgxCustomConsole.Hint.

Standard stuff

Published property HudSprite;

This item has no description.

Published property HUDSpriteColor;

This item has no description.

Published property HudText;

This item has no description.

Published property InputLine;

This item has no description. Showing description inherited from TgxCustomConsole.InputLine.

Where user enters his commands.

Published property ObjectsSorting;

This item has no description.

Published property OnCommandIssued;

This item has no description. Showing description inherited from TgxCustomConsole.OnCommandIssued.

Main event of the console. Happens whenever the enter key is pressed. First the input line is compared to all registered commands, then everything is parsed into a TgxUserInputCommand record and sent to the event. Empty lines are not ignored (i.e. they also trigger events)

Published property OnProgress;

This item has no description.

Published property Options;

This item has no description.

Published property SceneViewer;

This item has no description. Showing description inherited from TgxCustomConsole.SceneViewer.

Visual stuff.

Published property Tag;

This item has no description.

Published property TypedCommands;

This item has no description. Showing description inherited from TgxCustomConsole.TypedCommands.

List of commands that user typed.

Published property Visible;


GXSysHelp v.2.5: GXS.Context

Unit GXS.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.SyncObjs
  • System.StrUtils
  • FMX.Consts
  • FMX.Forms
  • FMX.Controls
  • FMX.Types
  • FMX.Dialogs
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.State
  • GLScene.PipelineTransform
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFinishTaskEvent |
Record TgxServiceContextTask |
Class TgxAbstractMultitextureCoordinator |
Class TgxContext |
Class TgxScreenControlingContext |
Record TgxRCHandle |
Class TgxContextHandle |
Class TgxVirtualHandle |
Class TgxVirtualHandleTransf |
Class TgxListHandle |
Class TgxTextureHandle |
Class TgxSamplerHandle |
Class TgxQueryHandle |
Class TgxOcclusionQueryHandle |
Class TgxBooleanOcclusionQueryHandle |
Class TgxTimerQueryHandle |
Class TgxPrimitiveQueryHandle |
Class TgxBufferObjectHandle |
Class TgxVBOHandle |
Class TgxVBOArrayBufferHandle |
Class TgxVBOElementArrayHandle |
Class TgxPackPBOHandle |
Class TgxUnpackPBOHandle |
Class TgxTransformFeedbackBufferHandle |
Class TgxTextureBufferHandle |
Class TgxUniformBufferHandle |
Class TgxVertexArrayHandle |
Class TgxFramebufferHandle |
Class TgxRenderbufferHandle |
Class TgxProgramHandleEXT |
Class TgxVertexProgramHandle |
Class TgxFragmentProgramHandle |
Class TgxGeometryProgramHandle |
Class TgxSLHandle |
Class TgxShaderHandle |
Class TgxVertexShaderHandle |
Class TgxGeometryShaderHandle |
Class TgxFragmentShaderHandle |
Class TgxTessControlShaderHandle |
Class TgxTessEvaluationShaderHandle |
Class TgxProgramHandle |
Record TgxContextNotification |
Class TgxContextManager |
Class EVXContext |
Class EPBuffer |
Class EVXShader |

Functions and Procedures

procedure RegisterContextClass(aContextClass: TgxContextClass);
function CurrentContext: TgxContext;
function SafeCurrentContext: TgxContext;
function IsMainThread: Boolean;
function IsServiceContextAvaible: Boolean;
function GetServiceWindow: TForm;

Types

PgxRCHandle = ˆTgxRCHandle;
TgxAbstractMultitextureCoordinatorClass = class of TgxAbstractMultitextureCoordinator;
TgxAntiAliasing = (...);
TgxContextAcceleration = (...);
TgxContextClass = class of TgxContext;
TgxContextLayer = (...);
TgxFramebufferStatus = (...);
TgxRCOption = (...);
TgxRCOptions = set of TgxRCOption;
TgxShaderHandleClass = class of TgxShaderHandle;
TgxSyncMode = (...);
TgxTaskProcedure = procedure of object; stdcall;
TgxVirtualHandleEvent = procedure(Sender: TgxVirtualHandle; var Handle: LongWord) of object;
TOnPrepareHandleData = procedure(aContext: TgxContext) of object;

Constants

MRT_BUFFERS: array [0 .. 3] of Cardinal = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);

Variables

GXContextManager: TgxContextManager;
vIgnoreOpenGXErrors: Boolean = False;
vContextActivationFailureOccurred: Boolean = False;
vMultitextureCoordinatorClass: TgxAbstractMultitextureCoordinatorClass;
vCurrentContext: TgxContext;

Description

Functions and Procedures

procedure RegisterContextClass(aContextClass: TgxContextClass);

Drivers should register themselves via this function.

function CurrentContext: TgxContext;

The TgxContext that is the currently active context, if any. Returns nil if no context is active.

function SafeCurrentContext: TgxContext;

This item has no description.

function IsMainThread: Boolean;

This item has no description.

function IsServiceContextAvaible: Boolean;

This item has no description.

function GetServiceWindow: TForm;

This item has no description.

Types

PgxRCHandle = ˆTgxRCHandle;

This item has no description.

TgxAbstractMultitextureCoordinatorClass = class of TgxAbstractMultitextureCoordinator;

This item has no description.

TgxAntiAliasing = (...);

This item has no description.

Values
  • aaDefault: Multisample Antialiasing
  • aaNone
  • aa2x
  • aa2xHQ
  • aa4x
  • aa4xHQ
  • aa6x
  • aa8x
  • aa16x
  • csa8x: Coverage Sampling Antialiasing
  • csa8xHQ
  • csa16x
  • csa16xHQ
TgxContextAcceleration = (...);

This item has no description.

Values
  • chaUnknown
  • chaHardware
  • chaSoftware
TgxContextClass = class of TgxContext;

This item has no description.

TgxContextLayer = (...);

This item has no description.

Values
  • clUnderlay2
  • clUnderlay1
  • clMainPlane
  • clOverlay1
  • clOverlay2
TgxFramebufferStatus = (...);

This item has no description.

Values
  • fsComplete
  • fsIncompleteAttachment
  • fsIncompleteMissingAttachment
  • fsIncompleteDuplicateAttachment
  • fsIncompleteDimensions
  • fsIncompleteFormats
  • fsIncompleteDrawBuffer
  • fsIncompleteReadBuffer
  • fsUnsupported
  • fsIncompleteMultisample
  • fsStatusError
TgxRCOption = (...);

This item has no description.

Values
  • rcoDoubleBuffered
  • rcoStereo
  • rcoDebug
  • rcoOGL_ES
TgxRCOptions = set of TgxRCOption;

This item has no description.

TgxShaderHandleClass = class of TgxShaderHandle;

This item has no description.

TgxSyncMode = (...);

This item has no description.

Values
  • vsmSync
  • vsmNoSync
TgxTaskProcedure = procedure of object; stdcall;

This item has no description.

TgxVirtualHandleEvent = procedure(Sender: TgxVirtualHandle; var Handle: LongWord) of object;

This item has no description.

TOnPrepareHandleData = procedure(aContext: TgxContext) of object;

This item has no description.

Constants

MRT_BUFFERS: array [0 .. 3] of Cardinal = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);

GXS.OpenGLx, Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)

Variables

GXContextManager: TgxContextManager;

This item has no description.

vIgnoreOpenGXErrors: Boolean = False;

This item has no description.

vContextActivationFailureOccurred: Boolean = False;

This item has no description.

vMultitextureCoordinatorClass: TgxAbstractMultitextureCoordinatorClass;

This item has no description.

vCurrentContext: TgxContext;


GXSysHelp v.2.5: GXS.Context: Class TgxFinishTaskEvent

Class TgxFinishTaskEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxFinishTaskEvent = class(TEvent)

Description

This item has no description.

Hierarchy

  • TEvent
  • TgxFinishTaskEvent

Overview

Methods

Public constructor Create; reintroduce;

Description

Methods

Public constructor Create; reintroduce;


GXSysHelp v.2.5: GXS.Context: Record TgxServiceContextTask

Record TgxServiceContextTask

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxServiceContextTask = record

Description

This item has no description.

Overview

Fields

Public | Task: TgxTaskProcedure;
Public | Event: TgxFinishTaskEvent;

Description

Fields

Public Task: TgxTaskProcedure;

This item has no description.

Public Event: TgxFinishTaskEvent;


GXSysHelp v.2.5: GXS.Context: Class TgxAbstractMultitextureCoordinator

Class TgxAbstractMultitextureCoordinator

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxAbstractMultitextureCoordinator = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxAbstractMultitextureCoordinator

Overview

Methods

Public constructor Create(AOwner: TgxContext); virtual;

Description

Methods

Public constructor Create(AOwner: TgxContext); virtual;


GXSysHelp v.2.5: GXS.Context: Class TgxContext

Class TgxContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxContext = class(TObject)

Description

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists.

Hierarchy

  • TObject
  • TgxContext

Overview

Fields

Private | FColorBits: Integer;
Private | FAlphaBits: Integer;
Private | FDepthBits: Integer;
Private | FStencilBits: Integer;
Private | FAccumBits: Integer;
Private | FAuxBuffers: Integer;
Private | FAntiAliasing: TgxAntiAliasing;
Private | FOptions: TgxRCOptions;
Private | FOnDestroyContext: TNotifyEvent;
Private | FManager: TgxContextManager;
Private | FActivationCount: Integer;
Private | FOwnedHandlesCount: Integer;
Private | FIsPraparationNeed: Boolean;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function FindCompatibleContext: TgxContext;
Public | function IsValid: Boolean; virtual; abstract;
Public | function RenderOutputDevice: Pointer; virtual; abstract;
Private | function GetActive: Boolean; inline;
Public | procedure Activate;
Public | procedure CreateContext(ADeviceHandle: THandle); overload;
Public | procedure CreateMemoryContext(OutputDevice: THandle; Width, Height: Integer; BufferCount: Integer = 1);
Public | procedure Deactivate;
Public | procedure DestroyAllHandles;
Public | procedure DestroyContext;
Public | procedure PrepareHandlesData;
Public | procedure ShareLists(aContext: TgxContext);
Public | procedure SwapBuffers; virtual; abstract;
Private | procedure SetAcceleration(const val: TgxContextAcceleration); inline;
Private | procedure SetAccumBits(const aAccumBits: Integer); inline;
Private | procedure SetActive(const aActive: Boolean); inline;
Private | procedure SetAlphaBits(const aAlphaBits: Integer); inline;
Private | procedure SetAntiAliasing(const val: TgxAntiAliasing); inline;
Private | procedure SetAuxBuffers(const aAuxBuffers: Integer); inline;
Private | procedure SetColorBits(const aColorBits: Integer); inline;
Private | procedure SetDepthBits(const val: Integer); inline;
Private | procedure SetLayer(const Value: TgxContextLayer); inline;
Private | procedure SetOptions(const aOptions: TgxRCOptions); inline;
Private | procedure SetStencilBits(const aStencilBits: Integer); inline;

Properties

Public | property Acceleration: TgxContextAcceleration read FAcceleration write SetAcceleration;
Public | property AccumBits: Integer read FAccumBits write SetAccumBits;
Public | property Active: Boolean read GetActive write SetActive;
Public | property AlphaBits: Integer read FAlphaBits write SetAlphaBits;
Public | property AntiAliasing: TgxAntiAliasing read FAntiAliasing write SetAntiAliasing;
Public | property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;
Public | property ColorBits: Integer read FColorBits write SetColorBits;
Public | property DepthBits: Integer read FDepthBits write SetDepthBits;
Public | property GXStates: TgxStateCache read FgxStates;
Public | property IsPraparationNeed: Boolean read FIsPraparationNeed;
Public | property Layer: TgxContextLayer read FLayer write SetLayer;
Public | property Manager: TgxContextManager read FManager;
Public | property MultitextureCoordinator: TgxAbstractMultitextureCoordinator read GetGXS;
Public | property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;
Public | property Options: TgxRCOptions read FOptions write SetOptions;
Public | property PipelineTransformation: TgTransformation read FTransformation;
Public | property StencilBits: Integer read FStencilBits write SetStencilBits;

Description

Fields

Private FColorBits: Integer;

This item has no description.

Private FAlphaBits: Integer;

This item has no description.

Private FDepthBits: Integer;

This item has no description.

Private FStencilBits: Integer;

This item has no description.

Private FAccumBits: Integer;

This item has no description.

Private FAuxBuffers: Integer;

This item has no description.

Private FAntiAliasing: TgxAntiAliasing;

This item has no description.

Private FOptions: TgxRCOptions;

This item has no description.

Private FOnDestroyContext: TNotifyEvent;

This item has no description.

Private FManager: TgxContextManager;

This item has no description.

Private FActivationCount: Integer;

This item has no description.

Private FOwnedHandlesCount: Integer;

This item has no description.

Private FIsPraparationNeed: Boolean;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindCompatibleContext: TgxContext;

Returns the first compatible context that isn't self in the shares.

Public function IsValid: Boolean; virtual; abstract;

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; virtual; abstract;

This item has no description.

Private function GetActive: Boolean; inline;

This item has no description.

Public procedure Activate;

Activates the context. A context can be activated multiple times (and must be deactivated the same number of times), but this function will fail if another context is already active.

Public procedure CreateContext(ADeviceHandle: THandle); overload;

Creates the context. This method must be invoked before the context can be used.

Public procedure CreateMemoryContext(OutputDevice: THandle; Width, Height: Integer; BufferCount: Integer = 1);

Creates an in-memory context. The function should fail if no hardware-accelerated memory context can be created (the CreateContext method can handle software OpenGL contexts).

Public procedure Deactivate;

Deactivates the context. Will fail if the context is not active or another context has been activated.

Public procedure DestroyAllHandles;

This item has no description.

Public procedure DestroyContext;

Destroy the context. Will fail if no context has been created. The method will first invoke the OnDestroyContext event, then attempts to deactivate the context (if it is active) before destroying it.

Public procedure PrepareHandlesData;

Call OnPrepare for all handles.

Public procedure ShareLists(aContext: TgxContext);

Setup display list sharing between two rendering contexts. Both contexts must have the same pixel format.

Public procedure SwapBuffers; virtual; abstract;

Request to swap front and back buffers if they were defined.

Private procedure SetAcceleration(const val: TgxContextAcceleration); inline;

This item has no description.

Private procedure SetAccumBits(const aAccumBits: Integer); inline;

This item has no description.

Private procedure SetActive(const aActive: Boolean); inline;

This item has no description.

Private procedure SetAlphaBits(const aAlphaBits: Integer); inline;

This item has no description.

Private procedure SetAntiAliasing(const val: TgxAntiAliasing); inline;

This item has no description.

Private procedure SetAuxBuffers(const aAuxBuffers: Integer); inline;

This item has no description.

Private procedure SetColorBits(const aColorBits: Integer); inline;

This item has no description.

Private procedure SetDepthBits(const val: Integer); inline;

This item has no description.

Private procedure SetLayer(const Value: TgxContextLayer); inline;

This item has no description.

Private procedure SetOptions(const aOptions: TgxRCOptions); inline;

This item has no description.

Private procedure SetStencilBits(const aStencilBits: Integer); inline;

This item has no description.

Properties

Public property Acceleration: TgxContextAcceleration read FAcceleration write SetAcceleration;

Indicates if the context is hardware-accelerated.

Public property AccumBits: Integer read FAccumBits write SetAccumBits;

Accumulation buffer bits for the rendering context

Public property Active: Boolean read GetActive write SetActive;

Allows reading and defining the activity for the context. The methods of this property are just wrappers around calls to Activate and Deactivate.

Public property AlphaBits: Integer read FAlphaBits write SetAlphaBits;

Alpha bits for the rendering context

Public property AntiAliasing: TgxAntiAliasing read FAntiAliasing write SetAntiAliasing;

AntiAliasing option. Ignored if not hardware supported, currently based on ARB_multisample.

Public property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;

Auxiliary buffers bits for the rendering context

Public property ColorBits: Integer read FColorBits write SetColorBits;

Color bits for the rendering context

Public property DepthBits: Integer read FDepthBits write SetDepthBits;

Depth bits for the rendering context

Public property GXStates: TgxStateCache read FgxStates;

An application-side cache of global per-context OpenGL states and parameters

Public property IsPraparationNeed: Boolean read FIsPraparationNeed;

This item has no description.

Public property Layer: TgxContextLayer read FLayer write SetLayer;

Specifies the layer plane that the rendering context is bound to.

Public property Manager: TgxContextManager read FManager;

Context manager reference

Public property MultitextureCoordinator: TgxAbstractMultitextureCoordinator read GetGXS;

Access to OpenGL command and extension. property GL: TGLExtensionsAndEntryPoints read FGL; depricated from OpenGLAdapter

Public property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;

Triggered whenever the context is destroyed. This events happens *before* the context has been actually destroyed, OpenGL resource cleanup can still occur here.

Public property Options: TgxRCOptions read FOptions write SetOptions;

Rendering context options.

Public property PipelineTransformation: TgTransformation read FTransformation;

This item has no description.

Public property StencilBits: Integer read FStencilBits write SetStencilBits;

Stencil bits for the rendering context


GXSysHelp v.2.5: GXS.Context: Class TgxScreenControlingContext

Class TgxScreenControlingContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxScreenControlingContext = class(TgxContext)

Description

Context with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TgxSceneViewer won't use them, TgxMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.

Hierarchy

  • TObject
  • TgxContext
  • TgxScreenControlingContext

Overview

Properties

Public | property FullScreen: Boolean read FFullScreen write FFullScreen;
Public | property Height: Integer read FHeight write FHeight;
Public | property Width: Integer read FWidth write FWidth;

Description

Properties

Public property FullScreen: Boolean read FFullScreen write FFullScreen;

This item has no description.

Public property Height: Integer read FHeight write FHeight;

This item has no description.

Public property Width: Integer read FWidth write FWidth;


GXSysHelp v.2.5: GXS.Context: Record TgxRCHandle

Record TgxRCHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxRCHandle = record

Description

This item has no description.

Overview

Fields

Public | FRenderingContext: TgxContext;
Public | FHandle: Cardinal;
Public | FChanged: Boolean;

Description

Fields

Public FRenderingContext: TgxContext;

This item has no description.

Public FHandle: Cardinal;

This item has no description.

Public FChanged: Boolean;


GXSysHelp v.2.5: GXS.Context: Class TgxContextHandle

Class TgxContextHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxContextHandle = class(TObject)

Description

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

Hierarchy

  • TObject
  • TgxContextHandle

Overview

Fields

Private | FHandles: TList;
Private | FLastHandle: PgxRCHandle;
Private | FOnPrepare: TOnPrepareHandleData;

Methods

Public | constructor Create; virtual;
Public | constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);
Public | destructor Destroy; override;
Public | function AllocateHandle: Cardinal;
Public | function IsAllocatedForContext(aContext: TgxContext = nil): Boolean;
Public | function IsDataComplitelyUpdated: Boolean;
Public | function IsDataNeedUpdate: Boolean; inline;
Public | function IsShared: Boolean;
Public | class function IsSupported: Boolean; virtual;
Private | function GetContext: TgxContext;
Private | function GetHandle: Cardinal; inline;
Private | function RCItem(AIndex: Integer): PgxRCHandle; inline;
Private | function SearchRC(aContext: TgxContext): PgxRCHandle;
Public | procedure DestroyHandle;
Public | procedure NotifyChangesOfData;
Public | procedure NotifyDataUpdated;
Private | procedure CheckCurrentRC;

Properties

Public | property Handle: LongWord read GetHandle;
Public | property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;
Public | property RenderingContext: TgxContext read GetContext;

Description

Fields

Private FHandles: TList;

This item has no description.

Private FLastHandle: PgxRCHandle;

This item has no description.

Private FOnPrepare: TOnPrepareHandleData;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AllocateHandle: Cardinal;

This item has no description.

Public function IsAllocatedForContext(aContext: TgxContext = nil): Boolean;

This item has no description.

Public function IsDataComplitelyUpdated: Boolean;

Return True if data updated in all contexts.

Public function IsDataNeedUpdate: Boolean; inline;

Return True is data need update in current context.

Public function IsShared: Boolean;

This item has no description.

Public class function IsSupported: Boolean; virtual;

Checks if required extensions / OpenGL version are met

Private function GetContext: TgxContext;

This item has no description.

Private function GetHandle: Cardinal; inline;

This item has no description.

Private function RCItem(AIndex: Integer): PgxRCHandle; inline;

This item has no description.

Private function SearchRC(aContext: TgxContext): PgxRCHandle;

This item has no description.

Public procedure DestroyHandle;

This item has no description.

Public procedure NotifyChangesOfData;

Notify the data was changed through all context.

Public procedure NotifyDataUpdated;

Notify the data was updated in current context.

Private procedure CheckCurrentRC;

This item has no description.

Properties

Public property Handle: LongWord read GetHandle;

Return OpenGL identifier in current context.

Public property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;

This item has no description.

Public property RenderingContext: TgxContext read GetContext;

Return current rendering context if handle is allocated in it or first context where handle is allocated.


GXSysHelp v.2.5: GXS.Context: Class TgxVirtualHandle

Class TgxVirtualHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVirtualHandle = class(TgxContextHandle)

Description

A context handle with event-based handle allocation and destruction.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxVirtualHandle

Overview

Fields

Private | FOnAllocate: TgxVirtualHandleEvent;
Private | FOnDestroy: TgxVirtualHandleEvent;
Private | FTag: Integer;

Properties

Public | property OnAllocate: TgxVirtualHandleEvent read FOnAllocate write FOnAllocate;
Public | property OnDestroy: TgxVirtualHandleEvent read FOnDestroy write FOnDestroy;
Public | property Tag: Integer read FTag write FTag;

Description

Fields

Private FOnAllocate: TgxVirtualHandleEvent;

This item has no description.

Private FOnDestroy: TgxVirtualHandleEvent;

This item has no description.

Private FTag: Integer;

This item has no description.

Properties

Public property OnAllocate: TgxVirtualHandleEvent read FOnAllocate write FOnAllocate;

This item has no description.

Public property OnDestroy: TgxVirtualHandleEvent read FOnDestroy write FOnDestroy;

This item has no description.

Public property Tag: Integer read FTag write FTag;


GXSysHelp v.2.5: GXS.Context: Class TgxVirtualHandleTransf

Class TgxVirtualHandleTransf

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVirtualHandleTransf = class(TgxVirtualHandle)

Description

Transferable virtual handle.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxVirtualHandle
  • TgxVirtualHandleTransf


GXSysHelp v.2.5: GXS.Context: Class TgxListHandle

Class TgxListHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxListHandle = class(TgxContextHandle)

Description

Manages a handle to a display list.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxListHandle

Overview

Methods

Public | procedure CallList;
Public | procedure EndList;
Public | procedure NewList(mode: Cardinal);

Description

Methods

Public procedure CallList;

This item has no description.

Public procedure EndList;

This item has no description.

Public procedure NewList(mode: Cardinal);


GXSysHelp v.2.5: GXS.Context: Class TgxTextureHandle

Class TgxTextureHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTextureHandle = class(TgxContextHandle)

Description

Manages a handle to a texture.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxTextureHandle

Overview

Fields

Private FTarget: TglTextureTarget;

Methods

Private procedure SetTarget(ATarget: TglTextureTarget);

Properties

Public property Target: TglTextureTarget read FTarget write SetTarget;

Description

Fields

Private FTarget: TglTextureTarget;

This item has no description.

Methods

Private procedure SetTarget(ATarget: TglTextureTarget);

This item has no description.

Properties

Public property Target: TglTextureTarget read FTarget write SetTarget;


GXSysHelp v.2.5: GXS.Context: Class TgxSamplerHandle

Class TgxSamplerHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxSamplerHandle = class(TgxContextHandle)

Description

Manages a handle to a sampler.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSamplerHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxQueryHandle

Class TgxQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxQueryHandle = class(TgxContextHandle)

Description

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxQueryHandle

Overview

Fields

Private FActive: Boolean;

Methods

Public | function CounterBits: Integer;
Public | function IsResultAvailable: Boolean;
Public | function QueryResultBool: BYTEBOOL;
Public | function QueryResultInt: GLint;
Public | function QueryResultInt64: GLint64EXT;
Public | function QueryResultUInt: LongWord;
Public | function QueryResultUInt64: GLUint64EXT;
Public | procedure BeginQuery;
Public | procedure EndQuery;

Properties

Public | property Active: Boolean read FActive;
Public | property QueryType: TgxQueryType read GetQueryType;
Public | property Target: LongWord read GetTarget;

Description

Fields

Private FActive: Boolean;

This item has no description.

Methods

Public function CounterBits: Integer;

Number of bits used to store the query result. eg. 32/64 bit

Public function IsResultAvailable: Boolean;

Check if result is available from the query. Result may not be available immediately after ending the query

Public function QueryResultBool: BYTEBOOL;

This item has no description.

Public function QueryResultInt: GLint;

Retrieve query result, may cause a stall if the result is not available yet

Public function QueryResultInt64: GLint64EXT;

This item has no description.

Public function QueryResultUInt: LongWord;

This item has no description.

Public function QueryResultUInt64: GLUint64EXT;

This item has no description.

Public procedure BeginQuery;

This item has no description.

Public procedure EndQuery;

This item has no description.

Properties

Public property Active: Boolean read FActive;

True if within a Begin/EndQuery.

Public property QueryType: TgxQueryType read GetQueryType;

This item has no description.

Public property Target: LongWord read GetTarget;


GXSysHelp v.2.5: GXS.Context: Class TgxOcclusionQueryHandle

Class TgxOcclusionQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxOcclusionQueryHandle = class(TgxQueryHandle)

Description

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxQueryHandle
  • TgxOcclusionQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PixelCount: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function PixelCount: Integer;

Number of samples (pixels) drawn during the query, some pixels may be drawn to several times in the same query


GXSysHelp v.2.5: GXS.Context: Class TgxBooleanOcclusionQueryHandle

Class TgxBooleanOcclusionQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxBooleanOcclusionQueryHandle = class(TgxQueryHandle)

Description

This item has no description. Showing description inherited from TgxQueryHandle.

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxQueryHandle
  • TgxBooleanOcclusionQueryHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxTimerQueryHandle

Class TgxTimerQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTimerQueryHandle = class(TgxQueryHandle)

Description

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxQueryHandle
  • TgxTimerQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function Time: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function Time: Integer;

Time, in nanoseconds (1 ns = 10ˆ-9 s) between starting + ending the query. with 32 bit integer can measure up to approximately 4 seconds, use QueryResultUInt64 if you may need longer


GXSysHelp v.2.5: GXS.Context: Class TgxPrimitiveQueryHandle

Class TgxPrimitiveQueryHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxPrimitiveQueryHandle = class(TgxQueryHandle)

Description

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxQueryHandle
  • TgxPrimitiveQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PrimitivesGenerated: Integer;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function PrimitivesGenerated: Integer;

Number of primitives (eg. Points, Triangles etc.) drawn whilst the query was active


GXSysHelp v.2.5: GXS.Context: Class TgxBufferObjectHandle

Class TgxBufferObjectHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxBufferObjectHandle = class(TgxContextHandle)

Description

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle

Overview

Fields

Private FSize: Integer;

Methods

Public | constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: LongWord);
Public | class function IsSupported: Boolean; override;
Public | function MapBuffer(access: LongWord): Pointer;
Public | function MapBufferRange(offset: GLint; len: GLsizei; access: GLbitfield): Pointer;
Public | function UnmapBuffer: BYTEBOOL;
Public | procedure Bind; virtual; abstract;
Public | procedure BindBase(index: LongWord); virtual;
Public | procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: LongWord);
Public | procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); virtual;
Public | procedure BufferData(p: Pointer; size: Integer; bufferUsage: LongWord);
Public | procedure BufferSubData(offset, size: Integer; p: Pointer);
Public | procedure Flush(offset: GLint; len: GLsizei);
Public | procedure UnBind; virtual; abstract;
Public | procedure UnBindBase(index: LongWord); virtual;

Properties

Public | property BufferSize: Integer read FSize;
Public | property Target: LongWord read GetTarget;

Description

Fields

Private FSize: Integer;

This item has no description.

Methods

Public constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: LongWord);

Creates the buffer object buffer and initializes it.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public function MapBuffer(access: LongWord): Pointer;

Map buffer content to memory. Values for access are GL_READ_ONLY_ARB, GL_WRITE_ONLY_ARB and GL_READ_WRITE_ARB. Valid only if the buffer has been bound, must be followed by an UnmapBuffer, only one buffer may be mapped at a time.

Public function MapBufferRange(offset: GLint; len: GLsizei; access: GLbitfield): Pointer;

This item has no description.

Public function UnmapBuffer: BYTEBOOL;

Unmap buffer content from memory. Must follow a MapBuffer, and happen before the buffer is unbound.

Public procedure Bind; virtual; abstract;

This item has no description.

Public procedure BindBase(index: LongWord); virtual;

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: LongWord);

Invokes Bind then BufferData

Public procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); virtual;

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure BufferData(p: Pointer; size: Integer; bufferUsage: LongWord);

Specifies buffer content. Common bufferUsage values are GL_STATIC_DRAW_ARB for data that will change rarely, but be used often, GL_STREAM_DRAW_ARB for data specified once but used only a few times, and GL_DYNAMIC_DRAW_ARB for data that is re-specified very often. Valid only if the buffer has been bound.

Public procedure BufferSubData(offset, size: Integer; p: Pointer);

Updates part of an already existing buffer. offset and size indicate which part of the data in the buffer is to bo modified and p where the data should be taken from.

Public procedure Flush(offset: GLint; len: GLsizei);

This item has no description.

Public procedure UnBind; virtual; abstract;

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: LongWord); virtual;

This item has no description.

Properties

Public property BufferSize: Integer read FSize;

This item has no description.

Public property Target: LongWord read GetTarget;


GXSysHelp v.2.5: GXS.Context: Class TgxVBOHandle

Class TgxVBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVBOHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to an Vertex Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxVBOHandle

Overview

Methods

Private function GetVBOTarget: LongWord;

Properties

Public property VBOTarget: LongWord read GetVBOTarget;

Description

Methods

Private function GetVBOTarget: LongWord;

This item has no description.

Properties

Public property VBOTarget: LongWord read GetVBOTarget;


GXSysHelp v.2.5: GXS.Context: Class TgxVBOArrayBufferHandle

Class TgxVBOArrayBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVBOArrayBufferHandle = class(TgxVBOHandle)

Description

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxVBOHandle
  • TgxVBOArrayBufferHandle

Overview

Methods

Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GXSysHelp v.2.5: GXS.Context: Class TgxVBOElementArrayHandle

Class TgxVBOElementArrayHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVBOElementArrayHandle = class(TgxVBOHandle)

Description

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxVBOHandle
  • TgxVBOElementArrayHandle

Overview

Methods

Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GXSysHelp v.2.5: GXS.Context: Class TgxPackPBOHandle

Class TgxPackPBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxPackPBOHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxPackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GXSysHelp v.2.5: GXS.Context: Class TgxUnpackPBOHandle

Class TgxUnpackPBOHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxUnpackPBOHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxUnpackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GXSysHelp v.2.5: GXS.Context: Class TgxTransformFeedbackBufferHandle

Class TgxTransformFeedbackBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTransformFeedbackBufferHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxTransformFeedbackBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure BeginTransformFeedback(primitiveMode: GLenum);
Public | procedure Bind; override;
Public | procedure BindBase(index: LongWord); override;
Public | procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); override;
Public | procedure EndTransformFeedback();
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: LongWord); override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure BeginTransformFeedback(primitiveMode: GLenum);

This item has no description.

Public procedure Bind; override;

This item has no description.

Public procedure BindBase(index: LongWord); override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.BindBase.

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.BindRange.

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure EndTransformFeedback();

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: LongWord); override;


GXSysHelp v.2.5: GXS.Context: Class TgxTextureBufferHandle

Class TgxTextureBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTextureBufferHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to a Buffer Texture. (TBO)

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxTextureBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.


GXSysHelp v.2.5: GXS.Context: Class TgxUniformBufferHandle

Class TgxUniformBufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxUniformBufferHandle = class(TgxBufferObjectHandle)

Description

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxBufferObjectHandle
  • TgxUniformBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind; override;
Public | procedure BindBase(index: GLuint); override;
Public | procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); override;
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: GLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind; override;

This item has no description.

Public procedure BindBase(index: GLuint); override;

This item has no description.

Public procedure BindRange(index: LongWord; offset: PGLint; size: PGLsizei); override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.BindRange.

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure UnBind; override;

This item has no description. Showing description inherited from TgxBufferObjectHandle.UnBind.

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: GLuint); override;


GXSysHelp v.2.5: GXS.Context: Class TgxVertexArrayHandle

Class TgxVertexArrayHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVertexArrayHandle = class(TgxContextHandle)

Description

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxVertexArrayHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind;
Public | procedure UnBind;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind;

This item has no description.

Public procedure UnBind;


GXSysHelp v.2.5: GXS.Context: Class TgxFramebufferHandle

Class TgxFramebufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxFramebufferHandle = class(TgxContextHandle)

Description

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxFramebufferHandle

Overview

Methods

Public | function GetAttachmentObjectName(Target: GLenum; attachment: GLenum): GLint;
Public | function GetAttachmentObjectType(Target: GLenum; attachment: GLenum): GLint;
Public | function GetAttachmentParameter(Target: GLenum; attachment: GLenum; pname: GLenum): GLint;
Public | function GetStatus: TgxFramebufferStatus;
Public | function GetStringStatus(out clarification: string): TgxFramebufferStatus;
Public | class function IsSupported: Boolean; override;
Public | procedure Attach1DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint);
Public | procedure Attach2DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint);
Public | procedure Attach3DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint; Layer: GLint);
Public | procedure AttachLayer(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint; Layer: GLint);
Public | procedure AttachRenderBuffer(Target: GLenum; attachment: GLenum; renderbuffertarget: GLenum; renderbuffer: LongWord);
Public | procedure AttachTexture(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint);
Public | procedure AttachTextureLayer(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint; Layer: GLint);
Public | procedure Bind;
Public | procedure BindForDrawing;
Public | procedure BindForReading;
Public | procedure Blit(srcX0: GLint; srcY0: GLint; srcX1: GLint; srcY1: GLint; dstX0: GLint; dstY0: GLint; dstX1: GLint; dstY1: GLint; mask: GLbitfield; filter: GLenum);
Public | procedure UnBind;
Public | procedure UnBindForDrawing;
Public | procedure UnBindForReading;

Description

Methods

Public function GetAttachmentObjectName(Target: GLenum; attachment: GLenum): GLint;

Returns the name (ID) of the texture or renderbuffer attached to attachment point

Public function GetAttachmentObjectType(Target: GLenum; attachment: GLenum): GLint;

Returns the type of object bound to attachment point: GL_NONE, GL_FRAMEBUFFER_DEFAULT, GL_TEXTURE, or GL_RENDERBUFFER

Public function GetAttachmentParameter(Target: GLenum; attachment: GLenum; pname: GLenum): GLint;

target = GL_DRAW_FRAMEBUFFER, GL_READ_FRAMEBUFFER, GL_FRAMEBUFFER (equivalent to GL_DRAW_FRAMEBUFFER) If default framebuffer (0) is bound: attachment = GL_FRONT_LEFT, GL_FRONT_RIGHT, GL_BACK_LEFT, or GL_BACK_RIGHT, GL_DEPTH, GL_STENCIL if a framebuffer object is bound: attachment = GL_COLOR_ATTACHMENTi, GL_DEPTH_ATTACHMENT, GL_STENCIL_ATTACHMENT, GL_DEPTH_STENCIL_ATTACHMENT param = GL_FRAMEBUFFER_ATTACHMENT_(OBJECT_TYPE, OBJECT_NAME, RED_SIZE, GREEN_SIZE, BLUE_SIZE, ALPHA_SIZE, DEPTH_SIZE, STENCIL_SIZE, COMPONENT_TYPE, COLOR_ENCODING, TEXTURE_LEVEL, LAYERED, TEXTURE_CUBE_MAP_FACE, TEXTURE_LAYER

Public function GetStatus: TgxFramebufferStatus;

This item has no description.

Public function GetStringStatus(out clarification: string): TgxFramebufferStatus;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Attach1DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint);

target = GL_DRAW_FRAMEBUFFER, GL_READ_FRAMEBUFFER, GL_FRAMEBUFFER (attach to both READ + DRAW) attachment = COLOR_ATTACHMENTi, DEPTH_ATTACHMENT, STENCIL_ATTACHMENT, DEPTH_STENCIL_ATTACHMENT

Public procedure Attach2DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint);

This item has no description.

Public procedure Attach3DTexture(Target: GLenum; attachment: GLenum; textarget: GLenum; texture: LongWord; level: GLint; Layer: GLint);

This item has no description.

Public procedure AttachLayer(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint; Layer: GLint);

This item has no description.

Public procedure AttachRenderBuffer(Target: GLenum; attachment: GLenum; renderbuffertarget: GLenum; renderbuffer: LongWord);

This item has no description.

Public procedure AttachTexture(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint);

If texture is the name of a three-dimensional texture, cube map texture, one-or two-dimensional array texture, or two-dimensional multisample array texture, the texture level attached to the framebuffer attachment point is an array of images, and the framebuffer attachment is considered layered.

Public procedure AttachTextureLayer(Target: GLenum; attachment: GLenum; texture: LongWord; level: GLint; Layer: GLint);

This item has no description.

Public procedure Bind;

Bind framebuffer for both drawing + reading

Public procedure BindForDrawing;

Bind framebuffer for drawing

Public procedure BindForReading;

Bind framebuffer for reading

Public procedure Blit(srcX0: GLint; srcY0: GLint; srcX1: GLint; srcY1: GLint; dstX0: GLint; dstY0: GLint; dstX1: GLint; dstY1: GLint; mask: GLbitfield; filter: GLenum);

copy rect from bound read framebuffer to bound draw framebuffer

Public procedure UnBind;

Note that it is not necessary to unbind before binding another framebuffer.

Public procedure UnBindForDrawing;

This item has no description.

Public procedure UnBindForReading;


GXSysHelp v.2.5: GXS.Context: Class TgxRenderbufferHandle

Class TgxRenderbufferHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxRenderbufferHandle = class(TgxContextHandle)

Description

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxRenderbufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Bind;
Public | procedure SetStorage(internalformat: GLenum; Width, Height: GLsizei);
Public | procedure SetStorageMultisample(internalformat: GLenum; samples: GLsizei; Width, Height: GLsizei);
Public | procedure UnBind;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met

Public procedure Bind;

This item has no description.

Public procedure SetStorage(internalformat: GLenum; Width, Height: GLsizei);

This item has no description.

Public procedure SetStorageMultisample(internalformat: GLenum; samples: GLsizei; Width, Height: GLsizei);

This item has no description.

Public procedure UnBind;


GXSysHelp v.2.5: GXS.Context: Class TgxProgramHandleEXT

Class TgxProgramHandleEXT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxProgramHandleEXT = class(TgxContextHandle)

Description

This item has no description. Showing description inherited from TgxContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxProgramHandleEXT

Overview

Fields

Private | FReady: Boolean;
Private | FInfoLog: string;

Methods

Public | procedure Bind;
Public | procedure Disable;
Public | procedure Enable;
Public | procedure LoadARBProgram(AText: string);

Properties

Public | property InfoLog: string read FInfoLog;
Public | property Ready: Boolean read FReady;

Description

Fields

Private FReady: Boolean;

This item has no description.

Private FInfoLog: string;

This item has no description.

Methods

Public procedure Bind;

This item has no description.

Public procedure Disable;

This item has no description.

Public procedure Enable;

This item has no description.

Public procedure LoadARBProgram(AText: string);

This item has no description.

Properties

Public property InfoLog: string read FInfoLog;

This item has no description.

Public property Ready: Boolean read FReady;


GXSysHelp v.2.5: GXS.Context: Class TgxVertexProgramHandle

Class TgxVertexProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVertexProgramHandle = class(TgxProgramHandleEXT)

Description

This item has no description. Showing description inherited from TgxContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxProgramHandleEXT
  • TgxVertexProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxFragmentProgramHandle

Class TgxFragmentProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxFragmentProgramHandle = class(TgxProgramHandleEXT)

Description

This item has no description. Showing description inherited from TgxContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxProgramHandleEXT
  • TgxFragmentProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxGeometryProgramHandle

Class TgxGeometryProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxGeometryProgramHandle = class(TgxProgramHandleEXT)

Description

This item has no description. Showing description inherited from TgxContextHandle.

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxProgramHandleEXT
  • TgxGeometryProgramHandle

Overview

Methods

Public class function IsSupported: Boolean; override;

Description

Methods

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxSLHandle

Class TgxSLHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxSLHandle = class(TgxContextHandle)

Description

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle

Overview

Methods

Public | function InfoLog: string;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public function InfoLog: string;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxShaderHandle

Class TgxShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxShaderHandle = class(TgxSLHandle)

Description

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle

Overview

Fields

Private FShaderType: Cardinal;

Methods

Public | function CompileShader: Boolean;
Public | procedure ShaderSource(const source: AnsiString); overload;

Properties

Public property ShaderType: Cardinal read FShaderType;

Description

Fields

Private FShaderType: Cardinal;

This item has no description.

Methods

Public function CompileShader: Boolean;

Returns True if compilation sucessful

Public procedure ShaderSource(const source: AnsiString); overload;

This item has no description.

Properties

Public property ShaderType: Cardinal read FShaderType;


GXSysHelp v.2.5: GXS.Context: Class TgxVertexShaderHandle

Class TgxVertexShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxVertexShaderHandle = class(TgxShaderHandle)

Description

Manages a handle to a Vertex Shader Object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle
  • TgxVertexShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxGeometryShaderHandle

Class TgxGeometryShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxGeometryShaderHandle = class(TgxShaderHandle)

Description

Manages a handle to a Geometry Shader Object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle
  • TgxGeometryShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxFragmentShaderHandle

Class TgxFragmentShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxFragmentShaderHandle = class(TgxShaderHandle)

Description

Manages a handle to a Fragment Shader Object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle
  • TgxFragmentShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxTessControlShaderHandle

Class TgxTessControlShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTessControlShaderHandle = class(TgxShaderHandle)

Description

Manages a handle to a Tessellation Control Shader Object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle
  • TgxTessControlShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxTessEvaluationShaderHandle

Class TgxTessEvaluationShaderHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxTessEvaluationShaderHandle = class(TgxShaderHandle)

Description

Manages a handle to a Tessellation Evaluation Shader Object.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxShaderHandle
  • TgxTessEvaluationShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;

This item has no description.

Public class function IsSupported: Boolean; override;

This item has no description. Showing description inherited from TgxContextHandle.IsSupported.

Checks if required extensions / OpenGL version are met


GXSysHelp v.2.5: GXS.Context: Class TgxProgramHandle

Class TgxProgramHandle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxProgramHandle = class(TgxSLHandle)

Description

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TgxContextHandle
  • TgxSLHandle
  • TgxProgramHandle

Overview

Fields

Private FName: string;

Methods

Public | constructor Create; override;
Public | function GetAttribLocation(const aName: string): GLint;
Public | function GetUniformBlockIndex(const aName: string): GLint;
Public | function GetUniformBufferSize(const aName: string): GLint;
Public | function GetUniformLocation(const aName: string): GLint;
Public | function GetUniformOffset(const aName: string): GLint;
Public | function GetVaryingLocation(const aName: string): GLint;
Public | class function IsValid(const ID: LongWord): BYTEBOOL; override;
Public | function LinkProgram: Boolean;
Public | function ValidateProgram: Boolean;
Private | function GetUniform1f(const index: string): Single;
Private | function GetUniform1i(const index: string): Integer;
Private | function GetUniform2f(const index: string): TVector2f;
Private | function GetUniform2i(const index: string): TVector2i;
Private | function GetUniform3f(const index: string): TAffineVector;
Private | function GetUniform3i(const index: string): TVector3i;
Private | function GetUniform4f(const index: string): TVector4f;
Private | function GetUniform4i(const index: string): TVector4i;
Private | function GetUniformMatrix2fv(const index: string): TMatrix2f;
Private | function GetUniformMatrix3fv(const index: string): TMatrix3f;
Private | function GetUniformMatrix4fv(const index: string): TMatrix4f;
Private | function GetUniformTextureHandle(const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget): Cardinal;
Public | procedure AddActiveVarying(const aName: string);
Public | procedure AddShader(ShaderType: TgxShaderHandleClass; const ShaderSource: string; treatWarningsAsErrors: Boolean = False);
Public | procedure AttachObject(shader: TgxShaderHandle);
Public | procedure BindAttribLocation(index: Integer; const aName: string);
Public | procedure BindFragDataLocation(index: Integer; const aName: string);
Public | procedure DetachAllObject;
Public | procedure EndUseProgramObject;
Public | procedure SetUniformf(const index: string; const val: TVector3f); overload;
Public | procedure SetUniformf(const index: string; const val: TVector4f); overload;
Public | procedure SetUniformf(const index: string; const val: TVector2f); overload;
Public | procedure SetUniformf(const index: string; const val: Single); overload;
Public | procedure SetUniformi(const index: string; const val: TVector2i); overload;
Public | procedure SetUniformi(const index: string; const val: GLint); overload;
Public | procedure SetUniformi(const index: string; const val: TVector4i); overload;
Public | procedure SetUniformi(const index: string; const val: TVector3i); overload;
Public | procedure UseProgramObject;
Private | procedure SetUniform1f(const index: string; val: Single);
Private | procedure SetUniform1i(const index: string; val: Integer);
Private | procedure SetUniform2f(const index: string; const val: TVector2f);
Private | procedure SetUniform2i(const index: string; const Value: TVector2i);
Private | procedure SetUniform3f(const index: string; const val: TAffineVector);
Private | procedure SetUniform3i(const index: string; const Value: TVector3i);
Private | procedure SetUniform4f(const index: string; const val: TVector4f);
Private | procedure SetUniform4i(const index: string; const Value: TVector4i);
Private | procedure SetUniformBuffer(const index: string; Value: TgxUniformBufferHandle);
Private | procedure SetUniformMatrix2fv(const index: string; const val: TMatrix2f);
Private | procedure SetUniformMatrix3fv(const index: string; const val: TMatrix3f);
Private | procedure SetUniformMatrix4fv(const index: string; const val: TMatrix4f);
Private | procedure SetUniformTextureHandle(const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget; const Value: Cardinal);

Properties

Public | property Name: string read FName write FName;
Public | property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;
Public | property Uniform1i[const index: string]: GLint read GetUniform1i write SetUniform1i;
Public | property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;
Public | property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;
Public | property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;
Public | property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;
Public | property Uniform4f[const index: string]: TVector4f read GetUniform4f write SetUniform4f;
Public | property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;
Public | property UniformBuffer[const index: string]: TgxUniformBufferHandle write SetUniformBuffer;
Public | property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;
Public | property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;
Public | property UniformMatrix4fv[const index: string]: TMatrix4f read GetUniformMatrix4fv write SetUniformMatrix4fv;
Public | property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget]: LongWord read GetUniformTextureHandle write SetUniformTextureHandle;

Description

Fields

Private FName: string;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public function GetAttribLocation(const aName: string): GLint;

This item has no description.

Public function GetUniformBlockIndex(const aName: string): GLint;

This item has no description.

Public function GetUniformBufferSize(const aName: string): GLint;

Currently, NVidia-specific.

Public function GetUniformLocation(const aName: string): GLint;

This item has no description.

Public function GetUniformOffset(const aName: string): GLint;

This item has no description.

Public function GetVaryingLocation(const aName: string): GLint;

This item has no description.

Public class function IsValid(const ID: LongWord): BYTEBOOL; override;

This item has no description.

Public function LinkProgram: Boolean;

This item has no description.

Public function ValidateProgram: Boolean;

This item has no description.

Private function GetUniform1f(const index: string): Single;

This item has no description.

Private function GetUniform1i(const index: string): Integer;

This item has no description.

Private function GetUniform2f(const index: string): TVector2f;

This item has no description.

Private function GetUniform2i(const index: string): TVector2i;

This item has no description.

Private function GetUniform3f(const index: string): TAffineVector;

This item has no description.

Private function GetUniform3i(const index: string): TVector3i;

This item has no description.

Private function GetUniform4f(const index: string): TVector4f;

This item has no description.

Private function GetUniform4i(const index: string): TVector4i;

This item has no description.

Private function GetUniformMatrix2fv(const index: string): TMatrix2f;

This item has no description.

Private function GetUniformMatrix3fv(const index: string): TMatrix3f;

This item has no description.

Private function GetUniformMatrix4fv(const index: string): TMatrix4f;

This item has no description.

Private function GetUniformTextureHandle(const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget): Cardinal;

This item has no description.

Public procedure AddActiveVarying(const aName: string);

Currently, NVidia-specific.

Public procedure AddShader(ShaderType: TgxShaderHandleClass; const ShaderSource: string; treatWarningsAsErrors: Boolean = False);

Compile and attach a new shader. Raises an EGLShader exception in case of failure.

Public procedure AttachObject(shader: TgxShaderHandle);

This item has no description.

Public procedure BindAttribLocation(index: Integer; const aName: string);

This item has no description.

Public procedure BindFragDataLocation(index: Integer; const aName: string);

This item has no description.

Public procedure DetachAllObject;

This item has no description.

Public procedure EndUseProgramObject;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector3f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector4f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: TVector2f); overload;

This item has no description.

Public procedure SetUniformf(const index: string; const val: Single); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector2i); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: GLint); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector4i); overload;

This item has no description.

Public procedure SetUniformi(const index: string; const val: TVector3i); overload;

This item has no description.

Public procedure UseProgramObject;

This item has no description.

Private procedure SetUniform1f(const index: string; val: Single);

This item has no description.

Private procedure SetUniform1i(const index: string; val: Integer);

This item has no description.

Private procedure SetUniform2f(const index: string; const val: TVector2f);

This item has no description.

Private procedure SetUniform2i(const index: string; const Value: TVector2i);

This item has no description.

Private procedure SetUniform3f(const index: string; const val: TAffineVector);

This item has no description.

Private procedure SetUniform3i(const index: string; const Value: TVector3i);

This item has no description.

Private procedure SetUniform4f(const index: string; const val: TVector4f);

This item has no description.

Private procedure SetUniform4i(const index: string; const Value: TVector4i);

This item has no description.

Private procedure SetUniformBuffer(const index: string; Value: TgxUniformBufferHandle);

This item has no description.

Private procedure SetUniformMatrix2fv(const index: string; const val: TMatrix2f);

This item has no description.

Private procedure SetUniformMatrix3fv(const index: string; const val: TMatrix3f);

This item has no description.

Private procedure SetUniformMatrix4fv(const index: string; const val: TMatrix4f);

This item has no description.

Private procedure SetUniformTextureHandle(const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget; const Value: Cardinal);

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;

This item has no description.

Public property Uniform1i[const index: string]: GLint read GetUniform1i write SetUniform1i;

Shader parameters.

Public property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;

This item has no description.

Public property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;

This item has no description.

Public property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;

This item has no description.

Public property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;

This item has no description.

Public property Uniform4f[const index: string]: TVector4f read GetUniform4f write SetUniform4f;

This item has no description.

Public property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;

This item has no description.

Public property UniformBuffer[const index: string]: TgxUniformBufferHandle write SetUniformBuffer;

This item has no description.

Public property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;

This item has no description.

Public property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;

This item has no description.

Public property UniformMatrix4fv[const index: string]: TMatrix4f read GetUniformMatrix4fv write SetUniformMatrix4fv;

This item has no description.

Public property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TglTextureTarget]: LongWord read GetUniformTextureHandle write SetUniformTextureHandle;


GXSysHelp v.2.5: GXS.Context: Record TgxContextNotification

Record TgxContextNotification

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxContextNotification = record

Description

This item has no description.

Overview

Fields

Public | obj: TObject;
Public | Event: TNotifyEvent;

Description

Fields

Public obj: TObject;

This item has no description.

Public Event: TNotifyEvent;


GXSysHelp v.2.5: GXS.Context: Class TgxContextManager

Class TgxContextManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type TgxContextManager = class(TObject)

Description

Stores and manages all the TgxContext objects.

Hierarchy

  • TObject
  • TgxContextManager

Overview

Fields

Private | FList: TThreadList;
Private | FTerminated: Boolean;
Private | FNotifications: array of TgxContextNotification;
Private | FCreatedRCCount: Integer;
Private | FHandles: TThreadList;
Private | FThread: TThread;
Private | FServiceStarter: TEvent;
Private | FServiceContext: TgxContext;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function ContextCount: Integer;
Public | function CreateContext(AClass: TgxContextClass = nil): TgxContext;
Public | procedure DestroyAllHandles;
Public | procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);
Public | procedure NotifyPreparationNeed;
Public | procedure RemoveNotification(anObject: TObject);
Public | procedure Terminate;

Description

Fields

Private FList: TThreadList;

This item has no description.

Private FTerminated: Boolean;

This item has no description.

Private FNotifications: array of TgxContextNotification;

This item has no description.

Private FCreatedRCCount: Integer;

This item has no description.

Private FHandles: TThreadList;

This item has no description.

Private FThread: TThread;

This item has no description.

Private FServiceStarter: TEvent;

This item has no description.

Private FServiceContext: TgxContext;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ContextCount: Integer;

Returns the number of TgxContext object. This is *not* the number of OpenGL rendering contexts!

Public function CreateContext(AClass: TgxContextClass = nil): TgxContext;

Returns an appropriate, ready-to use context. The returned context should be freed by caller.

Public procedure DestroyAllHandles;

Request all contexts to destroy all their handles.

Public procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);

Registers a new object to notify when the last context is destroyed. When the last rendering context is destroyed, the 'anEvent' will be invoked with 'anObject' as parameter. Note that the registration is kept until the notification is triggered or a RemoveNotification on 'anObject' is issued.

Public procedure NotifyPreparationNeed;

Notify all contexts about necessity of handles preparation.

Public procedure RemoveNotification(anObject: TObject);

Unregisters an object from the notification lists.

Public procedure Terminate;

Marks the context manager for termination


GXSysHelp v.2.5: GXS.Context: Class EVXContext

Class EVXContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type EVXContext = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EVXContext


GXSysHelp v.2.5: GXS.Context: Class EPBuffer

Class EPBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type EPBuffer = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EPBuffer


GXSysHelp v.2.5: GXS.Context: Class EVXShader

Class EVXShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Context

Declaration

type EVXShader = class(EVXContext)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EVXContext
  • EVXShader


GXSysHelp v.2.5: GXS.CUDA.API

Unit GXS.CUDA.API

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Dialogs
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.Strings
  • GLScene.Utils
  • GXS.Context
  • GXS.Graphics
  • CUDA.Runtime
  • CUDA.Parser
  • CUDA.FourierTransform
  • CUDA.DataAccess
  • CUDA.Import
  • GXS.CUDA.Compiler
  • GXS.CUDA.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TChannelTypeAndNum |
Class TCUDAComponent |
Class TCUDAModule |
Class TCUDAGraphicResource |
Class TCUDAMemData |
Class TCUDAUniform |
Class TCUDAConstant |
Class TCUDAFuncParam |
Class TCUDAFunction |
Class TCUDATexture |
Class TgxSCUDA |

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;
procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);
procedure DeRegisterCUDAComponentNameChangeEvent;

Types

TCuAddresMode = (...);
TCUDAChange = (...);
TCUDAChanges = set of TCUDAChange;
TCUDAChannelNum = (...);
TCUDAChannelType = (...);
TCUDAComponentClass = class of TCUDAComponent;
TCUDAMapping = (...);
TCUDAMemMapFlag = (...);
TCUDAMemMapFlags = set of TCUDAMemMapFlag;
TCUDAMemType = (...);
TCuFilterMode = (...);
TgxResourceType = (...);

Description

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;

This item has no description.

procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);

This item has no description.

procedure DeRegisterCUDAComponentNameChangeEvent;

This item has no description.

Types

TCuAddresMode = (...);

This item has no description.

Values
  • amWrap
  • amClamp
  • amMirror
TCUDAChange = (...);

This item has no description.

Values
  • cuchDevice
  • cuchContext
  • cuchSize
  • cuchAddresMode
  • cuchFlag
  • cuchFilterMode
  • cuchArray
  • cuchFormat
  • cuchMapping
TCUDAChanges = set of TCUDAChange;

This item has no description.

TCUDAChannelNum = (...);

This item has no description.

Values
  • cnOne
  • cnTwo
  • cnThree
  • cnFour
TCUDAChannelType = (...);

This item has no description.

Values
  • ctUndefined
  • ctUInt8
  • ctUInt16
  • ctUInt32
  • ctInt8
  • ctInt16
  • ctInt32
  • ctHalfFloat
  • ctFloat
  • ctDouble
TCUDAComponentClass = class of TCUDAComponent;

This item has no description.

TCUDAMapping = (...);

This item has no description.

Values
  • grmDefault
  • grmReadOnly
  • grmWriteDiscard
TCUDAMemMapFlag = (...);

This item has no description.

Values
  • mmfPortable
  • mmfFastWrite: Memory is shared between contexts
TCUDAMemMapFlags = set of TCUDAMemMapFlag;

Fast write, slow read

TCUDAMemType = (...);

This item has no description.

Values
  • mtHost
  • mtDevice
  • mtArray
TCuFilterMode = (...);

This item has no description.

Values
  • fmPoint
  • fmLinear
TgxResourceType = (...);

This item has no description.

Values
  • rtTexture
  • rtBuffer


GXSysHelp v.2.5: GXS.CUDA.API: Record TChannelTypeAndNum

Record TChannelTypeAndNum

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TChannelTypeAndNum = record

Description

This item has no description.

Overview

Fields

Public | F: TCUDAChannelType;
Public | C: TCUDAChannelNum;

Description

Fields

Public F: TCUDAChannelType;

This item has no description.

Public C: TCUDAChannelNum;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAComponent

Class TCUDAComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAComponent = class(TCUDAHandlesMaster)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent

Overview

Fields

Private | FMaster: TCUDAComponent;
Private | FItems: TgxPersistentObjectList;

Methods

Public | destructor Destroy; override;
Public | function GetItemByName(const name: string): TCUDAComponent;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override;
Public | function MakeUniqueName(const BaseName: string): string;
Private | function GetItem(const i: Integer): TCUDAComponent;
Private | function GetItemsCount: Integer;
Public | procedure CuNotifyChange(AChange: TCUDAChange); virtual;
Public | procedure SetParentComponent(Value: TComponent); override;
Private | procedure SetMaster(AMaster: TCUDAComponent);

Properties

Public | property Context: TCUDAContext read GetContext;
Public | property IsAllocated: Boolean read GetIsAllocated;
Public | property Items[const i: Integer]: TCUDAComponent read GetItem;
Public | property ItemsCount: Integer read GetItemsCount;
Public | property Master: TCUDAComponent read FMaster write SetMaster;
Public | property Status: TCUresult read FStatus;

Description

Fields

Private FMaster: TCUDAComponent;

This item has no description.

Private FItems: TgxPersistentObjectList;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function GetItemByName(const name: string): TCUDAComponent;

This item has no description.

Public function GetParentComponent: TComponent; override;

This item has no description.

Public function HasParent: Boolean; override;

This item has no description.

Public function MakeUniqueName(const BaseName: string): string;

This item has no description.

Private function GetItem(const i: Integer): TCUDAComponent;

This item has no description.

Private function GetItemsCount: Integer;

This item has no description.

Public procedure CuNotifyChange(AChange: TCUDAChange); virtual;

This item has no description.

Public procedure SetParentComponent(Value: TComponent); override;

This item has no description.

Private procedure SetMaster(AMaster: TCUDAComponent);

This item has no description.

Properties

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property IsAllocated: Boolean read GetIsAllocated;

Return true if handle is allocated (i.e. component has device object)

Public property Items[const i: Integer]: TCUDAComponent read GetItem;

This item has no description.

Public property ItemsCount: Integer read GetItemsCount;

This item has no description.

Public property Master: TCUDAComponent read FMaster write SetMaster;

This item has no description.

Public property Status: TCUresult read FStatus;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAModule

Class TCUDAModule

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAModule = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAModule

Overview

Fields

Private | FHandle: PCUmodule;
Private | FCode: TStringList;
Private | FCodeType: TgxSCUDACompilerOutput;
Private | FCompiler: TgxSCUDACompiler;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetKernelConstant(const AName: string): TCUDAConstant;
Private | function GetKernelFunction(const AName: string): TCUDAFunction;
Private | function GetKernelTexture(const AName: string): TCUDATexture;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAndCompile;
Public | procedure LoadFromFile(const AFilename: string);
Public | procedure LoadFromSource;
Public | procedure Unload;
Private | procedure SetCode(const Value: TStringList);
Private | procedure SetCompiler(const Value: TgxSCUDACompiler);

Properties

Published | property Code: TStringList read FCode write SetCode;
Public | property CodeType: TgxSCUDACompilerOutput read FCodeType;
Published | property Compiler: TgxSCUDACompiler read FCompiler write SetCompiler;
Public | property Context: TCUDAContext read GetContext;
Public | property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;
Public | property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;
Public | property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;

Description

Fields

Private FHandle: PCUmodule;

This item has no description.

Private FCode: TStringList;

This item has no description.

Private FCodeType: TgxSCUDACompilerOutput;

This item has no description.

Private FCompiler: TgxSCUDACompiler;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetKernelConstant(const AName: string): TCUDAConstant;

This item has no description.

Private function GetKernelFunction(const AName: string): TCUDAFunction;

This item has no description.

Private function GetKernelTexture(const AName: string): TCUDATexture;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadAndCompile;

This item has no description.

Public procedure LoadFromFile(const AFilename: string);

This item has no description.

Public procedure LoadFromSource;

This item has no description.

Public procedure Unload;

This item has no description.

Private procedure SetCode(const Value: TStringList);

This item has no description.

Private procedure SetCompiler(const Value: TgxSCUDACompiler);

This item has no description.

Properties

Published property Code: TStringList read FCode write SetCode;

This item has no description.

Public property CodeType: TgxSCUDACompilerOutput read FCodeType;

This item has no description.

Published property Compiler: TgxSCUDACompiler read FCompiler write SetCompiler;

This item has no description.

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;

This item has no description.

Public property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;

This item has no description.

Public property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAGraphicResource

Class TCUDAGraphicResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAGraphicResource = class(TCUDAComponent)

Description

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource

Overview

Methods

Public | procedure MapResources; virtual; abstract;
Public | procedure UnMapResources; virtual; abstract;

Description

Methods

Public procedure MapResources; virtual; abstract;

This item has no description.

Public procedure UnMapResources; virtual; abstract;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAMemData

Class TCUDAMemData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAMemData = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAMemData

Overview

Fields

Private | FData: TCUdeviceptr;
Private | FMappedMemory: TCUdeviceptr;
Private | FHandle: PCUarray;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FPitch: Cardinal;
Private | FElementSize: Integer;
Private | FDataSize: Integer;
Private | FChannelsType: TCUDAChannelType;
Private | fChannelsNum: TCUDAChannelNum;
Private | FMemoryType: TCUDAMemType;
Private | FTexture: TCUDATexture;
Private | FOpenGLRefArray: Boolean;
Private | FMapping: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;
Private | function GetArrayHandle: PCUarray;
Private | function GetData: TCUdeviceptr;
Public | procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CopyFrom(const AGLImage: TgxBitmap32); overload;
Public | procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;
Public | procedure CopyTo(const ADstMemData: TCUDAMemData); overload;
Public | procedure CopyTo(const AGLImage: TgxImage); overload;
Public | procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CuNotifyChange(AChange: TCUDAChange); override;
Public | procedure FillMem(const Value);
Public | procedure Map(const AFlags: TCUDAMemMapFlags = []);
Public | procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);
Public | procedure UnMap;
Private | procedure SetChannelNum(const Value: TCUDAChannelNum);
Private | procedure SetChannelType(const Value: TCUDAChannelType);
Private | procedure SetDepth(const Value: Integer);
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetMemoryType(const AType: TCUDAMemType);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property ArrayHandle: PCUarray read GetArrayHandle;
Published | property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;
Published | property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;
Public | property DataSize: Integer read FDataSize;
Published | property Depth: Integer read fDepth write SetDepth default 0;
Public | property ElementSize: Integer read FElementSize;
Published | property Height: Integer read fHeight write SetHeight default 0;
Public | property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;
Published | property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;
Public | property Pitch: Cardinal read fPitch;
Public | property RawData: TCUdeviceptr read GetData;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Fields

Private FData: TCUdeviceptr;

This item has no description.

Private FMappedMemory: TCUdeviceptr;

This item has no description.

Private FHandle: PCUarray;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FPitch: Cardinal;

This item has no description.

Private FElementSize: Integer;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FChannelsType: TCUDAChannelType;

This item has no description.

Private fChannelsNum: TCUDAChannelNum;

This item has no description.

Private FMemoryType: TCUDAMemType;

This item has no description.

Private FTexture: TCUDATexture;

This item has no description.

Private FOpenGLRefArray: Boolean;

This item has no description.

Private FMapping: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Public function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Public function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;

This item has no description.

Private function GetArrayHandle: PCUarray;

This item has no description.

Private function GetData: TCUdeviceptr;

This item has no description.

Public procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;

This item has no description.

Public procedure CopyFrom(const AGLImage: TgxBitmap32); overload;

This item has no description.

Public procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;

This item has no description.

Public procedure CopyTo(const ADstMemData: TCUDAMemData); overload;

This item has no description.

Public procedure CopyTo(const AGLImage: TgxImage); overload;

This item has no description.

Public procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;

Copy data to Graphic resource.

Public procedure CuNotifyChange(AChange: TCUDAChange); override;

This item has no description.

Public procedure FillMem(const Value);

Fill device data

Public procedure Map(const AFlags: TCUDAMemMapFlags = []);

Map device and array memory to host or host memory to device. Mapping is necessary for modifying device data. When mapped host memory - it can be accessed in device side via MappedHostAddress.

Public procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);

This item has no description.

Public procedure UnMap;

Done mapping operation.

Private procedure SetChannelNum(const Value: TCUDAChannelNum);

This item has no description.

Private procedure SetChannelType(const Value: TCUDAChannelType);

This item has no description.

Private procedure SetDepth(const Value: Integer);

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetMemoryType(const AType: TCUDAMemType);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property ArrayHandle: PCUarray read GetArrayHandle;

This item has no description.

Published property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;

This item has no description.

Published property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;

This item has no description.

Public property DataSize: Integer read FDataSize;

This item has no description.

Published property Depth: Integer read fDepth write SetDepth default 0;

This item has no description.

Public property ElementSize: Integer read FElementSize;

This item has no description.

Published property Height: Integer read fHeight write SetHeight default 0;

This item has no description.

Public property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;

This item has no description.

Published property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;

This item has no description.

Public property Pitch: Cardinal read fPitch;

This item has no description.

Public property RawData: TCUdeviceptr read GetData;

This item has no description.

Published property Width: Integer read fWidth write SetWidth default 256;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAUniform

Class TCUDAUniform

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAUniform = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Public property IsValueDefined: Boolean read FDefined write SetDefined;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Public property IsValueDefined: Boolean read FDefined write SetDefined;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAConstant

Class TCUDAConstant

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAConstant = class(TCUDAUniform)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAConstant

Overview

Properties

Published | property CustomType;
Published | property DataType;
Public | property DeviceAddress: TCUdeviceptr read GetDeviceAddress;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Properties

Published property CustomType;

This item has no description.

Published property DataType;

This item has no description.

Public property DeviceAddress: TCUdeviceptr read GetDeviceAddress;

This item has no description.

Published property KernelName;

This item has no description.

Published property Reference;

This item has no description.

Published property Size;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAFuncParam

Class TCUDAFuncParam

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAFuncParam = class(TCUDAUniform)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAFuncParam

Overview

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Published | property CustomType;
Published | property DataType;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Published property CustomType;

This item has no description.

Published property DataType;

This item has no description.

Published property KernelName;

This item has no description.

Published property Reference;

This item has no description.

Published property Size;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDAFunction

Class TCUDAFunction

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDAFunction = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFunction

Overview

Fields

Private | FKernelName: string;
Private | FHandle: PCUfunction;
Private | FAutoSync: Boolean;
Private | FBlockShape: TCUDADimensions;
Private | FGrid: TCUDADimensions;
Private | ParamOffset: Integer;
Private | FLaunching: Boolean;
Private | FOnParameterSetup: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetConstMemorySize: Integer;
Private | function GetHandle: PCUfunction;
Private | function GetLocalMemorySize: Integer;
Private | function GetMaxThreadPerBlock: Integer;
Private | function GetNumRegisters: Integer;
Private | function GetParameter(const AName: string): TCUDAFuncParam;
Private | function GetSharedMemorySize: Integer;
Public | procedure Launch(Grided: Boolean = true);
Public | procedure SetParam(Value: TVector3f); overload;
Public | procedure SetParam(Value: TVector2f); overload;
Public | procedure SetParam(Value: TVector4i); overload;
Public | procedure SetParam(Value: TVector4f); overload;
Public | procedure SetParam(Ptr: Pointer); overload;
Public | procedure SetParam(TexRef: TCUDATexture); overload;
Public | procedure SetParam(MemData: TCUDAMemData); overload;
Public | procedure SetParam(Value: TVector3i); overload;
Public | procedure SetParam(Value: Cardinal); overload;
Public | procedure SetParam(Value: Integer); overload;
Public | procedure SetParam(Value: TVector2i); overload;
Public | procedure SetParam(Value: Single); overload;
Private | procedure SetBlockShape(const AShape: TCUDADimensions);
Private | procedure SetGrid(const AGrid: TCUDADimensions);
Private | procedure SetKernelName(const AName: string);
Private | procedure SetSharedMemorySize(Value: Integer);

Properties

Published | property AutoSync: Boolean read FAutoSync write FAutoSync default true;
Published | property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;
Public | property ConstMemorySize: Integer read GetConstMemorySize;
Published | property Grid: TCUDADimensions read FGrid write SetGrid;
Public | property Handle: PCUfunction read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Public | property LocalMemorySize: Integer read GetLocalMemorySize;
Public | property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;
Public | property NumRegisters: Integer read GetNumRegisters;
Published | property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;
Public | property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;
Public | property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;

Description

Fields

Private FKernelName: string;

This item has no description.

Private FHandle: PCUfunction;

This item has no description.

Private FAutoSync: Boolean;

This item has no description.

Private FBlockShape: TCUDADimensions;

This item has no description.

Private FGrid: TCUDADimensions;

This item has no description.

Private ParamOffset: Integer;

This item has no description.

Private FLaunching: Boolean;

This item has no description.

Private FOnParameterSetup: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetConstMemorySize: Integer;

This item has no description.

Private function GetHandle: PCUfunction;

This item has no description.

Private function GetLocalMemorySize: Integer;

This item has no description.

Private function GetMaxThreadPerBlock: Integer;

This item has no description.

Private function GetNumRegisters: Integer;

This item has no description.

Private function GetParameter(const AName: string): TCUDAFuncParam;

This item has no description.

Private function GetSharedMemorySize: Integer;

This item has no description.

Public procedure Launch(Grided: Boolean = true);

This item has no description.

Public procedure SetParam(Value: TVector3f); overload;

This item has no description.

Public procedure SetParam(Value: TVector2f); overload;

This item has no description.

Public procedure SetParam(Value: TVector4i); overload;

This item has no description.

Public procedure SetParam(Value: TVector4f); overload;

This item has no description.

Public procedure SetParam(Ptr: Pointer); overload;

This item has no description.

Public procedure SetParam(TexRef: TCUDATexture); overload;

This item has no description.

Public procedure SetParam(MemData: TCUDAMemData); overload;

This item has no description.

Public procedure SetParam(Value: TVector3i); overload;

This item has no description.

Public procedure SetParam(Value: Cardinal); overload;

This item has no description.

Public procedure SetParam(Value: Integer); overload;

This item has no description.

Public procedure SetParam(Value: TVector2i); overload;

This item has no description.

Public procedure SetParam(Value: Single); overload;

This item has no description.

Private procedure SetBlockShape(const AShape: TCUDADimensions);

This item has no description.

Private procedure SetGrid(const AGrid: TCUDADimensions);

This item has no description.

Private procedure SetKernelName(const AName: string);

This item has no description.

Private procedure SetSharedMemorySize(Value: Integer);

This item has no description.

Properties

Published property AutoSync: Boolean read FAutoSync write FAutoSync default true;

This item has no description.

Published property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;

This item has no description.

Public property ConstMemorySize: Integer read GetConstMemorySize;

This item has no description.

Published property Grid: TCUDADimensions read FGrid write SetGrid;

This item has no description.

Public property Handle: PCUfunction read GetHandle;

This item has no description.

Published property KernelName: string read FKernelName write SetKernelName;

This item has no description.

Public property LocalMemorySize: Integer read GetLocalMemorySize;

This item has no description.

Public property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;

This item has no description.

Public property NumRegisters: Integer read GetNumRegisters;

This item has no description.

Published property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;

This item has no description.

Public property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;

This item has no description.

Public property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;


GXSysHelp v.2.5: GXS.CUDA.API: Class TCUDATexture

Class TCUDATexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TCUDATexture = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDATexture

Overview

Fields

Private | FKernelName: string;
Private | FHandle: PCUtexref;
Private | fArray: TCUDAMemData;
Private | fAddressModeS: TCuAddresMode;
Private | fAddressModeT: TCuAddresMode;
Private | fAddressModeR: TCuAddresMode;
Private | fNormalizedCoord: Boolean;
Private | fReadAsInteger: Boolean;
Private | fFilterMode: TCuFilterMode;
Private | fFormat: TCUDAChannelType;
Private | fChannelNum: TCUDAChannelNum;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetHandle: PCUtexref;
Private | procedure SetAddressModeR(const AMode: TCuAddresMode);
Private | procedure SetAddressModeS(const AMode: TCuAddresMode);
Private | procedure SetAddressModeT(const AMode: TCuAddresMode);
Private | procedure SetArray(Value: TCUDAMemData);
Private | procedure SetChannelNum(AValue: TCUDAChannelNum);
Private | procedure SetFilterMode(const mode: TCuFilterMode);
Private | procedure SetFormat(AValue: TCUDAChannelType);
Private | procedure SetKernelName(const AName: string);
Private | procedure SetNormalizedCoord(const flag: Boolean);
Private | procedure SetReadAsInteger(const flag: Boolean);

Properties

Published | property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;
Published | property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;
Published | property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;
Published | property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;
Published | property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;
Published | property Format: TCUDAChannelType read fFormat write SetFormat;
Public | property Handle: PCUtexref read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Published | property MemDataArray: TCUDAMemData read fArray write SetArray;
Published | property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;
Published | property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;

Description

Fields

Private FKernelName: string;

This item has no description.

Private FHandle: PCUtexref;

This item has no description.

Private fArray: TCUDAMemData;

This item has no description.

Private fAddressModeS: TCuAddresMode;

This item has no description.

Private fAddressModeT: TCuAddresMode;

This item has no description.

Private fAddressModeR: TCuAddresMode;

This item has no description.

Private fNormalizedCoord: Boolean;

This item has no description.

Private fReadAsInteger: Boolean;

This item has no description.

Private fFilterMode: TCuFilterMode;

This item has no description.

Private fFormat: TCUDAChannelType;

This item has no description.

Private fChannelNum: TCUDAChannelNum;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetHandle: PCUtexref;

This item has no description.

Private procedure SetAddressModeR(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetAddressModeS(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetAddressModeT(const AMode: TCuAddresMode);

This item has no description.

Private procedure SetArray(Value: TCUDAMemData);

This item has no description.

Private procedure SetChannelNum(AValue: TCUDAChannelNum);

This item has no description.

Private procedure SetFilterMode(const mode: TCuFilterMode);

This item has no description.

Private procedure SetFormat(AValue: TCUDAChannelType);

This item has no description.

Private procedure SetKernelName(const AName: string);

This item has no description.

Private procedure SetNormalizedCoord(const flag: Boolean);

This item has no description.

Private procedure SetReadAsInteger(const flag: Boolean);

This item has no description.

Properties

Published property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;

This item has no description.

Published property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;

This item has no description.

Published property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;

This item has no description.

Published property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;

This item has no description.

Published property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;

This item has no description.

Published property Format: TCUDAChannelType read fFormat write SetFormat;

This item has no description.

Public property Handle: PCUtexref read GetHandle;

This item has no description.

Published property KernelName: string read FKernelName write SetKernelName;

This item has no description.

Published property MemDataArray: TCUDAMemData read fArray write SetArray;

This item has no description.

Published property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;

This item has no description.

Published property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;


GXSysHelp v.2.5: GXS.CUDA.API: Class TgxSCUDA

Class TgxSCUDA

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.API

Declaration

type TgxSCUDA = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TgxSCUDA

Overview

Fields

Private | fDevice: TgxSCUDADevice;
Private | fContext: TCUDAContext;
Private | FOnOpenGLInteropInit: TOnOpenGLInteropInit;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetModule(const i: Integer): TCUDAModule;
Private | procedure SetDevice(const Value: TgxSCUDADevice);
Private | procedure SetOnOpenGLInteropInit(AEvent: TOnOpenGLInteropInit);

Properties

Published | property ComputingDevice: TgxSCUDADevice read fDevice write SetDevice;
Public | property Context: TCUDAContext read GetContext;
Public | property Modules[const i: Integer]: TCUDAModule read GetModule;
Published | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;

Description

Fields

Private fDevice: TgxSCUDADevice;

This item has no description.

Private fContext: TCUDAContext;

This item has no description.

Private FOnOpenGLInteropInit: TOnOpenGLInteropInit;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetModule(const i: Integer): TCUDAModule;

This item has no description.

Private procedure SetDevice(const Value: TgxSCUDADevice);

This item has no description.

Private procedure SetOnOpenGLInteropInit(AEvent: TOnOpenGLInteropInit);

This item has no description.

Properties

Published property ComputingDevice: TgxSCUDADevice read fDevice write SetDevice;

This item has no description.

Public property Context: TCUDAContext read GetContext;

This item has no description.

Public property Modules[const i: Integer]: TCUDAModule read GetModule;

This item has no description.

Published property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;


GXSysHelp v.2.5: GXS.CUDA.Compiler

Unit GXS.CUDA.Compiler

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • Winapi.ShellAPI
  • Winapi.TlHelp32
  • System.SysUtils
  • System.Classes
  • System.UITypes
  • FMX.Forms
  • FMX.Dialogs
  • GXS.ApplicationFileIO
  • GLScene.Strings
  • CUDA.Parser

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSCUDACompiler |

Types

TFindCuFileFunc = function(var AModuleName: string): Boolean;
TgxSCUDACompilerOutput = (...);
TgxSCUDARealArch = (...);
TgxSCUDARealArchs = set of TgxSCUDARealArch;
TgxSCUDAVirtArch = (...);

Variables

vFindCuFileFunc: TFindCuFileFunc;

Description

Types

TFindCuFileFunc = function(var AModuleName: string): Boolean;

This item has no description.

TgxSCUDACompilerOutput = (...);

This item has no description.

Values
  • codeUndefined
  • codePtx
  • codeCubin
  • codeGpu
TgxSCUDARealArch = (...);

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

Values
  • sm_10
  • sm_11
  • sm_12
  • sm_13
  • sm_20
  • sm_21
TgxSCUDARealArchs = set of TgxSCUDARealArch;

This item has no description.

TgxSCUDAVirtArch = (...);

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

Values
  • compute_10
  • compute_11
  • compute_12
  • compute_13
  • compute_20

Variables

vFindCuFileFunc: TFindCuFileFunc;


GXSysHelp v.2.5: GXS.CUDA.Compiler: Class TgxSCUDACompiler

Class TgxSCUDACompiler

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Compiler

Declaration

type TgxSCUDACompiler = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSCUDACompiler

Overview

Fields

Private | FNVCCPath: string;
Private | FCppCompilerPath: string;
Private | FProduct: TStringList;
Private | FProjectModule: string;
Private | FSourceCodeFile: string;
Private | FConsoleContent: string;
Private | FOutputCodeType: TgxSCUDACompilerOutput;
Private | FVirtualArch: TgxSCUDAVirtArch;
Private | FRealArch: TgxSCUDARealArchs;
Private | FMaxRegisterCount: Integer;
Private | FModuleInfo: TCUDAModuleInfo;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Compile: Boolean;
Private | function StoreProjectModule: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetSourceCodeFile(const AFileName: string);
Private | procedure SetCppCompilerPath(const AValue: string);
Private | procedure SetMaxRegisterCount(Value: Integer);
Private | procedure SetNVCCPath(const AValue: string);
Private | procedure SetOutputCodeType(const Value: TgxSCUDACompilerOutput);
Private | procedure SetRealArch(AValue: TgxSCUDARealArchs);

Properties

Public | property ConsoleContent: string read FConsoleContent;
Published | property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;
Published | property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;
Public | property ModuleInfo: TCUDAModuleInfo read FModuleInfo;
Published | property NVCCPath: string read FNVCCPath write SetNVCCPath;
Published | property OutputCodeType: TgxSCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;
Public | property Product: TStringList read FProduct write FProduct;
Published | property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;
Published | property RealArchitecture: TgxSCUDARealArchs read FRealArch write SetRealArch default [sm_13];
Published | property SourceCodeFile: string read FSourceCodeFile;
Published | property VirtualArchitecture: TgxSCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;

Description

Fields

Private FNVCCPath: string;

This item has no description.

Private FCppCompilerPath: string;

This item has no description.

Private FProduct: TStringList;

This item has no description.

Private FProjectModule: string;

This item has no description.

Private FSourceCodeFile: string;

This item has no description.

Private FConsoleContent: string;

This item has no description.

Private FOutputCodeType: TgxSCUDACompilerOutput;

This item has no description.

Private FVirtualArch: TgxSCUDAVirtArch;

This item has no description.

Private FRealArch: TgxSCUDARealArchs;

This item has no description.

Private FMaxRegisterCount: Integer;

This item has no description.

Private FModuleInfo: TCUDAModuleInfo;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Compile: Boolean;

This item has no description.

Private function StoreProjectModule: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetSourceCodeFile(const AFileName: string);

This item has no description.

Private procedure SetCppCompilerPath(const AValue: string);

This item has no description.

Private procedure SetMaxRegisterCount(Value: Integer);

This item has no description.

Private procedure SetNVCCPath(const AValue: string);

This item has no description.

Private procedure SetOutputCodeType(const Value: TgxSCUDACompilerOutput);

This item has no description.

Private procedure SetRealArch(AValue: TgxSCUDARealArchs);

This item has no description.

Properties

Public property ConsoleContent: string read FConsoleContent;

This item has no description.

Published property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;

Microsoft Visual Studio Compiler. Pascal compiler is still not done.

Published property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;

Maximum registers that kernel can use.

Public property ModuleInfo: TCUDAModuleInfo read FModuleInfo;

This item has no description.

Published property NVCCPath: string read FNVCCPath write SetNVCCPath;

NVidia CUDA Compiler.

Published property OutputCodeType: TgxSCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;

Output code type for module kernel - Ptx - Parallel Thread Execution - Cubin - CUDA Binary

Public property Product: TStringList read FProduct write FProduct;

Product of compilation.

Published property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;

Disign-time only property. Make choose of one of the Project module as CUDA kernel source

Published property RealArchitecture: TgxSCUDARealArchs read FRealArch write SetRealArch default [sm_13];

In the CUDA naming scheme, GPUs are named sm_xy, where x denotes the GPU generation number, and y the version in that generation.

Published property SourceCodeFile: string read FSourceCodeFile;

Full file name of source code file.

Published property VirtualArchitecture: TgxSCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;

Virtual architecture.


GXSysHelp v.2.5: GXS.CUDA.Context

Unit GXS.CUDA.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Dialogs
  • CUDA.Import
  • CUDA.RunTime
  • GLScene.Strings
  • GLScene.Generics
  • GXS.BaseClasses
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDADimensions |
Class TCUDADevice |
Class TgxSCUDADevice |
Class TCUDAHandlesMaster |
Class TCUDAContext |
Class CUDAContextManager |

Types

TCUDAContextList = GList<TCUDAContext>;
TCUDADeviceList = GList<TCUDADevice>;
TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;
TOnOpenGLInteropInit = procedure(out Context: TgxContext) of object;

Description

Types

TCUDAContextList = GList<TCUDAContext>;

This item has no description.

TCUDADeviceList = GList<TCUDADevice>;

This item has no description.

TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;

This item has no description.

TOnOpenGLInteropInit = procedure(out Context: TgxContext) of object;


GXSysHelp v.2.5: GXS.CUDA.Context: Class TCUDADimensions

Class TCUDADimensions

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type TCUDADimensions = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TCUDADimensions

Overview

Fields

Private | FXYZ: TDim3;
Private | FMaxXYZ: TDim3;
Private | FReadOnly: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function GetDimComponent(index: Integer): Integer;
Private | function GetMaxDimComponent(index: Integer): Integer;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetDimComponent(index: Integer; Value: Integer);
Private | procedure SetMaxDimComponent(index: Integer; Value: Integer);

Properties

Public | property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;
Public | property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;
Published | property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;
Published | property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;
Published | property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;

Description

Fields

Private FXYZ: TDim3;

This item has no description.

Private FMaxXYZ: TDim3;

This item has no description.

Private FReadOnly: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function GetDimComponent(index: Integer): Integer;

This item has no description.

Private function GetMaxDimComponent(index: Integer): Integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetDimComponent(index: Integer; Value: Integer);

This item has no description.

Private procedure SetMaxDimComponent(index: Integer; Value: Integer);

This item has no description.

Properties

Public property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;

This item has no description.

Public property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;

This item has no description.

Published property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;

This item has no description.

Published property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;

This item has no description.

Published property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;


GXSysHelp v.2.5: GXS.CUDA.Context: Class TCUDADevice

Class TCUDADevice

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type TCUDADevice = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCUDADevice

Overview

Fields

Private | fID: Integer;
Private | fHandle: TCUdevice;
Private | fGFlops: Integer;
Private | fDeviceProperties: TCudaDeviceProp;
Private | FSuitable: Boolean;
Private | FUsed: Boolean;
Private | fMaxThreadsDim: TCUDADimensions;
Private | fMaxGridSize: TCUDADimensions;

Methods

Public | constructor Create; reintroduce;
Public | destructor Destroy; override;
Public | function TotalMemory: Cardinal;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property ClockRate: Integer read fDeviceProperties.ClockRate;
Published | property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;
Published | property Major: Integer read fDeviceProperties.Major;
Published | property MaxGridSize: TCUDADimensions read fMaxGridSize;
Published | property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;
Published | property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;
Published | property MemPitch: NativeUInt read fDeviceProperties.MemPitch;
Published | property Minor: Integer read fDeviceProperties.Minor;
Published | property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;
Published | property Name: string read GetName;
Published | property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;
Published | property SharedMemPerBlock: NativeUInt read fDeviceProperties.SharedMemPerBlock;
Published | property TextureAlignment: NativeUInt read fDeviceProperties.TextureAlignment;
Published | property TotalConstMem: NativeUInt read fDeviceProperties.TotalConstMem;
Published | property TotalGlobalMem: NativeUInt read fDeviceProperties.TotalGlobalMem;
Published | property WarpSize: Integer read fDeviceProperties.WarpSize;

Description

Fields

Private fID: Integer;

This item has no description.

Private fHandle: TCUdevice;

This item has no description.

Private fGFlops: Integer;

This item has no description.

Private fDeviceProperties: TCudaDeviceProp;

This item has no description.

Private FSuitable: Boolean;

This item has no description.

Private FUsed: Boolean;

This item has no description.

Private fMaxThreadsDim: TCUDADimensions;

This item has no description.

Private fMaxGridSize: TCUDADimensions;

This item has no description.

Methods

Public constructor Create; reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TotalMemory: Cardinal;

Returns in bytes the total amount of memory available on the device dev in bytes.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ClockRate: Integer read fDeviceProperties.ClockRate;

This item has no description.

Published property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;

This item has no description.

Published property Major: Integer read fDeviceProperties.Major;

This item has no description.

Published property MaxGridSize: TCUDADimensions read fMaxGridSize;

This item has no description.

Published property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;

This item has no description.

Published property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;

This item has no description.

Published property MemPitch: NativeUInt read fDeviceProperties.MemPitch;

This item has no description.

Published property Minor: Integer read fDeviceProperties.Minor;

This item has no description.

Published property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;

This item has no description.

Published property Name: string read GetName;

This item has no description.

Published property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;

This item has no description.

Published property SharedMemPerBlock: NativeUInt read fDeviceProperties.SharedMemPerBlock;

This item has no description.

Published property TextureAlignment: NativeUInt read fDeviceProperties.TextureAlignment;

This item has no description.

Published property TotalConstMem: NativeUInt read fDeviceProperties.TotalConstMem;

This item has no description.

Published property TotalGlobalMem: NativeUInt read fDeviceProperties.TotalGlobalMem;

This item has no description.

Published property WarpSize: Integer read fDeviceProperties.WarpSize;


GXSysHelp v.2.5: GXS.CUDA.Context: Class TgxSCUDADevice

Class TgxSCUDADevice

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type TgxSCUDADevice = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSCUDADevice

Overview

Fields

Private FSelectDeviceName: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Suitable: Boolean;
Private | function GetDevice: TCUDADevice;
Private | procedure SetDevice(AValue: TCUDADevice);
Private | procedure SetDeviceName(const AName: string);

Properties

Published | property Device: TCUDADevice read GetDevice write SetDevice;
Published | property SelectDevice: string read FSelectDeviceName write SetDeviceName;

Description

Fields

Private FSelectDeviceName: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Suitable: Boolean;

This item has no description.

Private function GetDevice: TCUDADevice;

This item has no description.

Private procedure SetDevice(AValue: TCUDADevice);

This item has no description.

Private procedure SetDeviceName(const AName: string);

This item has no description.

Properties

Published property Device: TCUDADevice read GetDevice write SetDevice;

This item has no description.

Published property SelectDevice: string read FSelectDeviceName write SetDeviceName;


GXSysHelp v.2.5: GXS.CUDA.Context: Class TCUDAHandlesMaster

Class TCUDAHandlesMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type TCUDAHandlesMaster = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster


GXSysHelp v.2.5: GXS.CUDA.Context: Class TCUDAContext

Class TCUDAContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type TCUDAContext = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TCUDAContext

Overview

Fields

Private | fHandle: PCUcontext;
Private | FDevice: TCUDADevice;
Private | FOnOpenGLInteropInit: TOnOpenGLInteropInit;
Private | FHandleList: TCUDAHandleList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; inline;
Public | procedure DestroyAllHandles;
Public | procedure Release;
Public | procedure Requires;
Private | procedure SetDevice(ADevice: TCUDADevice);

Properties

Public | property Device: TCUDADevice read FDevice write SetDevice;
Public | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;

Description

Fields

Private fHandle: PCUcontext;

This item has no description.

Private FDevice: TCUDADevice;

This item has no description.

Private FOnOpenGLInteropInit: TOnOpenGLInteropInit;

This item has no description.

Private FHandleList: TCUDAHandleList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; inline;

This item has no description.

Public procedure DestroyAllHandles;

Destroy all handles based of this context.

Public procedure Release;

Pops context from current CPU thread.

Public procedure Requires;

Pushes context onto CPU thread’s stack of current contexts.

Private procedure SetDevice(ADevice: TCUDADevice);

This item has no description.

Properties

Public property Device: TCUDADevice read FDevice write SetDevice;

This item has no description.

Public property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;


GXSysHelp v.2.5: GXS.CUDA.Context: Class CUDAContextManager

Class CUDAContextManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Context

Declaration

type CUDAContextManager = class(TObject)

Description

Static class of CUDA contexts manager.

Hierarchy

  • TObject
  • CUDAContextManager

Overview

Fields

Private | class var fDeviceList: TCUDADeviceList;
Private | class var fContextList: TCUDAContextList;
Private | class var FContextStacks: array of TCUDAContextList;

Methods

Public | class function ContextCount: Integer;
Public | class function DeviceCount: Integer;
Public | class function GetCurrentThreadContext: TCUDAContext;
Public | class function GetDeviceByName(const AName: string): TCUDADevice;
Public | class function GetMaxGflopsDevice: TCUDADevice;
Public | class function PopContext: TCUDAContext;
Public | class procedure CreateContext(aContext: TCUDAContext);
Public | class procedure CreateContextOf(ADevice: TCUDADevice);
Public | class procedure DestroyContext(aContext: TCUDAContext);
Public | class procedure DestroyContextOf(ADevice: TCUDADevice);
Public | class procedure Done;
Public | class procedure FillUnusedDeviceList(var AList: TStringList);
Public | class procedure Init;
Public | class procedure PushContext(aContext: TCUDAContext);

Properties

Public | property Contexts[i: Integer]: TCUDAContext read GetContext;
Public | property Devices[i: Integer]: TCUDADevice read GetDevice;

Description

Fields

Private class var fDeviceList: TCUDADeviceList;

This item has no description.

Private class var fContextList: TCUDAContextList;

This item has no description.

Private class var FContextStacks: array of TCUDAContextList;

This item has no description.

Methods

Public class function ContextCount: Integer;

Returns the number of TCUDAcontext object.

Public class function DeviceCount: Integer;

Returns the number of CUDA compatiable devices.

Public class function GetCurrentThreadContext: TCUDAContext;

Return CUDA context of current thread.

Public class function GetDeviceByName(const AName: string): TCUDADevice;

Return device by name.

Public class function GetMaxGflopsDevice: TCUDADevice;

Returns a device that has a maximum Giga flops.

Public class function PopContext: TCUDAContext;

This item has no description.

Public class procedure CreateContext(aContext: TCUDAContext);

This item has no description.

Public class procedure CreateContextOf(ADevice: TCUDADevice);

This item has no description.

Public class procedure DestroyContext(aContext: TCUDAContext);

This item has no description.

Public class procedure DestroyContextOf(ADevice: TCUDADevice);

This item has no description.

Public class procedure Done;

This item has no description.

Public class procedure FillUnusedDeviceList(var AList: TStringList);

Fill unused device list to show its in property.

Public class procedure Init;

Managment.

Public class procedure PushContext(aContext: TCUDAContext);

This item has no description.

Properties

Public property Contexts[i: Integer]: TCUDAContext read GetContext;

Access to contexts list.

Public property Devices[i: Integer]: TCUDADevice read GetDevice;

Access to devices list.


GXSysHelp v.2.5: GXS.CUDA.FFTPlan

Unit GXS.CUDA.FFTPlan

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Dialogs
  • CUDA.Import
  • CUDA.FourierTransform
  • GXS.CUDA.API
  • GXS.CUDA.Context
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAFFTPlan |

Types

TCUDAFFTdir = (...);
TCUDAFFTransform = (...);

Description

Types

TCUDAFFTdir = (...);

This item has no description.

Values
  • fftdForward
  • fftdInverse
TCUDAFFTransform = (...);

This item has no description.

Values
  • fftRealToComplex
  • fftComplexToReal
  • fftComplexToComplex
  • fftDoubleToDoubleComplex
  • fftDoubleComplexToDouble
  • fftDoubleComplexToDoubleComplex


GXSysHelp v.2.5: GXS.CUDA.FFTPlan: Class TCUDAFFTPlan

Class TCUDAFFTPlan

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.FFTPlan

Declaration

type TCUDAFFTPlan = class(TCUDAComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFFTPlan

Overview

Fields

Private | FHandle: TcufftHandle;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FBatch: Integer;
Private | FSize: Integer;
Private | FPaddedSize: Integer;
Private | FTransform: TCUDAFFTransform;
Private | FStatus: TcufftResult;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);
Private | procedure SetBatch(Value: Integer);
Private | procedure SetDepth(Value: Integer);
Private | procedure SetHeight(Value: Integer);
Private | procedure SetTransform(Value: TCUDAFFTransform);
Private | procedure SetWidth(Value: Integer);

Properties

Published | property Batch: Integer read FBatch write SetBatch default 1;
Published | property Depth: Integer read FDepth write SetDepth default 0;
Published | property Height: Integer read FHeight write SetHeight default 0;
Published | property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Fields

Private FHandle: TcufftHandle;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FBatch: Integer;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FPaddedSize: Integer;

This item has no description.

Private FTransform: TCUDAFFTransform;

This item has no description.

Private FStatus: TcufftResult;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);

This item has no description.

Private procedure SetBatch(Value: Integer);

This item has no description.

Private procedure SetDepth(Value: Integer);

This item has no description.

Private procedure SetHeight(Value: Integer);

This item has no description.

Private procedure SetTransform(Value: TCUDAFFTransform);

This item has no description.

Private procedure SetWidth(Value: Integer);

This item has no description.

Properties

Published property Batch: Integer read FBatch write SetBatch default 1;

This item has no description.

Published property Depth: Integer read FDepth write SetDepth default 0;

This item has no description.

Published property Height: Integer read FHeight write SetHeight default 0;

This item has no description.

Published property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;

This item has no description.

Published property Width: Integer read fWidth write SetWidth default 256;


GXSysHelp v.2.5: GXS.CUDA.Graphics

Unit GXS.CUDA.Graphics

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.Classes
  • FMX.Dialogs
  • CUDA.Import
  • GXS.CUDA.API
  • GXS.Context
  • GXS.State
  • GXS.Scene
  • GXS.Graphics
  • GXS.Material
  • GXS.Texture
  • GXSL.Shader
  • GXSL.Parameter
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAVertexAttribute |
Class TCUDAVertexAttributes |
Class TgxCustomFeedBackMesh |
Class TgxFeedBackMesh |
Class TCUDAImageResource |
Class TCUDAGeometryResource |

Types

TFeedBackMeshLaunching = (...);
TFeedBackMeshPrimitive = (...);
TOnBeforeKernelLaunch = procedure(Sender: TCUDAVertexAttribute) of object;

Description

Types

TFeedBackMeshLaunching = (...);

This item has no description.

Values
  • fblCommon
  • fblOnePerAtttribute
TFeedBackMeshPrimitive = (...);

This item has no description.

Values
  • fbmpPoint
  • fbmpLine
  • fbmpTriangle
TOnBeforeKernelLaunch = procedure(Sender: TCUDAVertexAttribute) of object;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TCUDAVertexAttribute

Class TCUDAVertexAttribute

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TCUDAVertexAttribute = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TCUDAVertexAttribute

Overview

Fields

Private | FName: string;
Private | FType: TgxSLDataType;
Private | FFunc: TCUDAFunction;
Private | FLocation: Integer;
Private | FOnBeforeKernelLaunch: TOnBeforeKernelLaunch;

Methods

Public | constructor Create(ACollection: TCollection); override;
Private | function GetLocation: Integer;
Private | function GetOwner: TCUDAVertexAttributes; reintroduce;
Public | procedure NotifyChange(Sender: TObject);
Private | procedure SetFunc(AFunc: TCUDAFunction);
Private | procedure SetName(const AName: string);
Private | procedure SetType(AType: TgxSLDataType);

Properties

Published | property GLSLType: TgxSLDataType read FType write SetType;
Published | property KernelFunction: TCUDAFunction read FFunc write SetFunc;
Public | property Location: Integer read GetLocation;
Published | property Name: string read FName write SetName;
Published | property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;

Description

Fields

Private FName: string;

This item has no description.

Private FType: TgxSLDataType;

This item has no description.

Private FFunc: TCUDAFunction;

This item has no description.

Private FLocation: Integer;

This item has no description.

Private FOnBeforeKernelLaunch: TOnBeforeKernelLaunch;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Private function GetLocation: Integer;

This item has no description.

Private function GetOwner: TCUDAVertexAttributes; reintroduce;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Private procedure SetFunc(AFunc: TCUDAFunction);

This item has no description.

Private procedure SetName(const AName: string);

This item has no description.

Private procedure SetType(AType: TgxSLDataType);

This item has no description.

Properties

Published property GLSLType: TgxSLDataType read FType write SetType;

This item has no description.

Published property KernelFunction: TCUDAFunction read FFunc write SetFunc;

This item has no description.

Public property Location: Integer read GetLocation;

This item has no description.

Published property Name: string read FName write SetName;

This item has no description.

Published property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TCUDAVertexAttributes

Class TCUDAVertexAttributes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TCUDAVertexAttributes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TCUDAVertexAttributes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TCUDAVertexAttribute;
Public | function GetAttributeByName(const AName: string): TCUDAVertexAttribute;
Public | function MakeUniqueName(const ANameRoot: string): string;
Private | function GetItems(Index: Integer): TCUDAVertexAttribute;
Public | procedure NotifyChange(Sender: TObject);
Private | procedure SetItems(Index: Integer; const AValue: TCUDAVertexAttribute);

Properties

Public property Attributes[Index: Integer]: TCUDAVertexAttribute read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TCUDAVertexAttribute;

This item has no description.

Public function GetAttributeByName(const AName: string): TCUDAVertexAttribute;

This item has no description.

Public function MakeUniqueName(const ANameRoot: string): string;

This item has no description.

Private function GetItems(Index: Integer): TCUDAVertexAttribute;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Private procedure SetItems(Index: Integer; const AValue: TCUDAVertexAttribute);

This item has no description.

Properties

Public property Attributes[Index: Integer]: TCUDAVertexAttribute read GetItems write SetItems;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TgxCustomFeedBackMesh

Class TgxCustomFeedBackMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TgxCustomFeedBackMesh = class(TgxBaseSceneObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomFeedBackMesh

Overview

Fields

Private | FGeometryResource: TCUDAGraphicResource;
Private | FAttributes: TCUDAVertexAttributes;
Private | FVAO: TgxVertexArrayHandle;
Private | FVBO: TgxVBOArrayBufferHandle;
Private | FEBO: TgxVBOElementArrayHandle;
Private | FPrimitiveType: TFeedBackMeshPrimitive;
Private | FVertexNumber: Integer;
Private | FElementNumber: Integer;
Private | FShader: TgxSLShader;
Private | FCommonFunc: TCUDAFunction;
Private | FLaunching: TFeedBackMeshLaunching;
Private | FBlend: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Private | procedure SetAttributes(AValue: TCUDAVertexAttributes);
Private | procedure SetCommonFunc(AFunc: TCUDAFunction);
Private | procedure SetElementNumber(AValue: Integer);
Private | procedure SetPrimitiveType(AValue: TFeedBackMeshPrimitive);
Private | procedure SetShader(AShader: TgxSLShader);
Private | procedure SetVertexNumber(AValue: Integer);

Properties

Public | property ArrayBufferHandle: TgxVBOArrayBufferHandle read FVBO;
Public | property ElementArrayHandle: TgxVBOElementArrayHandle read FEBO;

Description

Fields

Private FGeometryResource: TCUDAGraphicResource;

This item has no description.

Private FAttributes: TCUDAVertexAttributes;

This item has no description.

Private FVAO: TgxVertexArrayHandle;

This item has no description.

Private FVBO: TgxVBOArrayBufferHandle;

This item has no description.

Private FEBO: TgxVBOElementArrayHandle;

This item has no description.

Private FPrimitiveType: TFeedBackMeshPrimitive;

This item has no description.

Private FVertexNumber: Integer;

This item has no description.

Private FElementNumber: Integer;

This item has no description.

Private FShader: TgxSLShader;

This item has no description.

Private FCommonFunc: TCUDAFunction;

This item has no description.

Private FLaunching: TFeedBackMeshLaunching;

This item has no description.

Private FBlend: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetAttributes(AValue: TCUDAVertexAttributes);

This item has no description.

Private procedure SetCommonFunc(AFunc: TCUDAFunction);

This item has no description.

Private procedure SetElementNumber(AValue: Integer);

This item has no description.

Private procedure SetPrimitiveType(AValue: TFeedBackMeshPrimitive);

This item has no description.

Private procedure SetShader(AShader: TgxSLShader);

This item has no description.

Private procedure SetVertexNumber(AValue: Integer);

This item has no description.

Properties

Public property ArrayBufferHandle: TgxVBOArrayBufferHandle read FVBO;

This item has no description.

Public property ElementArrayHandle: TgxVBOElementArrayHandle read FEBO;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TgxFeedBackMesh

Class TgxFeedBackMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TgxFeedBackMesh = class(TgxCustomFeedBackMesh)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomFeedBackMesh
  • TgxFeedBackMesh

Overview

Properties

Published | property Attributes;
Published | property Behaviours;
Published | property Blend;
Published | property CommonKernelFunction;
Published | property Direction;
Published | property Effects;
Published | property ElementNumber;
Published | property Launching;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property PrimitiveType;
Published | property RollAngle;
Published | property Scale;
Published | property Shader;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VertexNumber;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Attributes;

This item has no description.

Published property Behaviours;

This item has no description.

Published property Blend;

This item has no description.

Published property CommonKernelFunction;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property ElementNumber;

This item has no description.

Published property Launching;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property PrimitiveType;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property Shader;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VertexNumber;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TCUDAImageResource

Class TCUDAImageResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TCUDAImageResource = class(TCUDAGraphicResource)

Description

This item has no description. Showing description inherited from TCUDAGraphicResource.

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAImageResource

Overview

Fields

Private | fMaterialLibrary: TgxMaterialLibrary;
Private | fTextureName: TgxLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetTextureName(const Value: TgxLibMaterialName);

Properties

Published | property Mapping;
Published | property MaterialLibrary: TgxMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;
Published | property TextureName: TgxLibMaterialName read fTextureName write SetTextureName;

Description

Fields

Private fMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private fTextureName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;

This item has no description.

Public procedure MapResources; override;

This item has no description.

Public procedure UnMapResources; override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetTextureName(const Value: TgxLibMaterialName);

This item has no description.

Properties

Published property Mapping;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property TextureName: TgxLibMaterialName read fTextureName write SetTextureName;


GXSysHelp v.2.5: GXS.CUDA.Graphics: Class TCUDAGeometryResource

Class TCUDAGeometryResource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CUDA.Graphics

Declaration

type TCUDAGeometryResource = class(TCUDAGraphicResource)

Description

This item has no description. Showing description inherited from TCUDAGraphicResource.

Abstract class of graphic resources.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAGeometryResource

Overview

Fields

Private FFeedBackMesh: TgxCustomFeedBackMesh;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetAttribArraySize(AAttr: TCUDAVertexAttribute): LongWord;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Private | procedure SetFeedBackMesh(const Value: TgxCustomFeedBackMesh);

Properties

Public | property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;
Public | property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;
Published | property FeedBackMesh: TgxCustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;
Public | property IndexDataAddress: Pointer read GetElementArrayAddress;
Public | property IndexDataSize: LongWord read GetElementArrayDataSize;
Published | property Mapping;

Description

Fields

Private FFeedBackMesh: TgxCustomFeedBackMesh;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAttribArraySize(AAttr: TCUDAVertexAttribute): LongWord;

This item has no description.

Public procedure MapResources; override;

This item has no description.

Public procedure UnMapResources; override;

This item has no description.

Private procedure SetFeedBackMesh(const Value: TgxCustomFeedBackMesh);

This item has no description.

Properties

Public property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;

This item has no description.

Public property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;

This item has no description.

Published property FeedBackMesh: TgxCustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;

This item has no description.

Public property IndexDataAddress: Pointer read GetElementArrayAddress;

This item has no description.

Public property IndexDataSize: LongWord read GetElementArrayDataSize;

This item has no description.

Published property Mapping;


GXSysHelp v.2.5: GXS.CyborgManager

Unit GXS.CyborgManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • GXS.SmartObjects
  • GXS.Scene
  • GXS.Objects
  • GXS.FileGLTF
  • GXS.File3DS
  • GXS.FilePly
  • GXS.FileOBJ

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCyborgManager |


GXSysHelp v.2.5: GXS.CyborgManager: Class TgxCyborgManager

Class TgxCyborgManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.CyborgManager

Declaration

type TgxCyborgManager = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxCyborgManager

Overview

Fields

Private | FMasterObject: TgxDummyCube;
Private | FModelList: TStringList;
Private | FModelPath: string;

Methods

Public | constructor Create(AMaster: TgxDummyCube; APath: string); virtual;
Public | destructor Destroy; override;
Public | function LoadModel(AFilename: string): TgxCyborg;
Private | procedure SetPathToModel(const Value: String);

Properties

Public | property MasterObject: TgxDummyCube read FMasterObject;
Public | property ModelList: TStringList read FModelList;
Public | property Path: string read FModelPath write SetPathToModel;

Description

Fields

Private FMasterObject: TgxDummyCube;

This item has no description.

Private FModelList: TStringList;

This item has no description.

Private FModelPath: string;

This item has no description.

Methods

Public constructor Create(AMaster: TgxDummyCube; APath: string); virtual;

It will create the list, assign the path to the models and the master object where the new models will be loaded

Public destructor Destroy; override;

It will free all the loaded models

Public function LoadModel(AFilename: string): TgxCyborg;

It will load a new model if it's not in the list and then return the new freeform. If it,s already in the list, it will return the existing freeform

Private procedure SetPathToModel(const Value: String);

Changing the path to the models and refresh the already existing freeforms

Properties

Public property MasterObject: TgxDummyCube read FMasterObject;

This item has no description.

Public property ModelList: TStringList read FModelList;

This item has no description.

Public property Path: string read FModelPath write SetPathToModel;


GXSysHelp v.2.5: GXS.DCE

Unit GXS.DCE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

* The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.BaseClasses
  • GLScene.Manager
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Coordinates
  • GXS.Scene
  • GXS.VectorFileObjects
  • GXS.DCEMisc
  • GXS.EllipseCollision
  • GXS.TerrainRenderer

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxDCECollision |
Class TgxDCEManager |
Class TgxDCEStatic |
Class TgxDCEDynamic |

Functions and Procedures

function GetOrCreateDCEStatic(behaviours: TgxBehaviours): TgxDCEStatic; overload;
function GetOrCreateDCEStatic(obj: TgxBaseSceneObject): TgxDCEStatic; overload;
function GetOrCreateDCEDynamic(behaviours: TgxBehaviours): TgxDCEDynamic; overload;
function GetOrCreateDCEDynamic(obj: TgxBaseSceneObject): TgxDCEDynamic; overload;

Types

TgxDCECollisionEvent = procedure(Sender: TObject; object1, object2: TgxBaseSceneObject; CollisionInfo: TgxDCECollision) of object;
TgxDCECollisionSelection = (...);
TgxDCEObjectCollisionEvent = procedure(Sender: TObject; ObjectCollided: TgxBaseSceneObject; CollisionInfo: TgxDCECollision) of object;
TgxDCEShape = (...);
TgxDCESlideOrBounce = (...);

Description

Functions and Procedures

function GetOrCreateDCEStatic(behaviours: TgxBehaviours): TgxDCEStatic; overload;

This item has no description.

function GetOrCreateDCEStatic(obj: TgxBaseSceneObject): TgxDCEStatic; overload;

This item has no description.

function GetOrCreateDCEDynamic(behaviours: TgxBehaviours): TgxDCEDynamic; overload;

This item has no description.

function GetOrCreateDCEDynamic(obj: TgxBaseSceneObject): TgxDCEDynamic; overload;

This item has no description.

Types

TgxDCECollisionEvent = procedure(Sender: TObject; object1, object2: TgxBaseSceneObject; CollisionInfo: TgxDCECollision) of object;

This item has no description.

TgxDCECollisionSelection = (...);

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)

Values
  • ccsDCEStandard
  • ccsCollisionStandard
  • ccsHybrid
TgxDCEObjectCollisionEvent = procedure(Sender: TObject; ObjectCollided: TgxBaseSceneObject; CollisionInfo: TgxDCECollision) of object;

This item has no description.

TgxDCEShape = (...);

Only csEllipsoid can have dynamic behaviour

Values
  • csEllipsoid
  • csBox
  • csFreeform
  • csTerrain
TgxDCESlideOrBounce = (...);

This item has no description.

Values
  • csbSlide
  • csbBounce


GXSysHelp v.2.5: GXS.DCE: Record TgxDCECollision

Record TgxDCECollision

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DCE

Declaration

type TgxDCECollision = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | Normal: TAffineVector;
Public | Bounce: TAffineVector;
Public | Nearest: Boolean;
Public | RootCollision: Boolean;
Public | Distance: single;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public Bounce: TAffineVector;

Surface normal

Public Nearest: Boolean;

Surface reflection

Public RootCollision: Boolean;

This item has no description.

Public Distance: single;


GXSysHelp v.2.5: GXS.DCE: Class TgxDCEManager

Class TgxDCEManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DCE

Declaration

type TgxDCEManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxDCEManager

Overview

Fields

Private | FStatics: TList;
Private | FDynamics: TList;
Private | FGravity: single;
Private | FWorldDirection: TgxCoordinates;
Private | FWorldScale: single;
Private | FMovimentScale: single;
Private | FStandardiseLayers: TgxDCECollisionSelection;
Private | FManualStep: Boolean;
Private | FOnCollision: TgxDCECollisionEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MoveByDistance(var Body: TgxDCEDynamic; deltaS, deltaAbsS: TAffineVector): single;
Private | function GetDynamicCount: Integer;
Private | function GetStaticCount: Integer;
Public | procedure Step(deltaTime: Double);
Private | procedure SetWorldDirection(const Value: TgxCoordinates);
Private | procedure SetWorldScale(const Value: single);

Properties

Public | property DynamicCount: Integer read GetDynamicCount;
Published | property Gravity: single read FGravity write FGravity;
Published | property ManualStep: Boolean read FManualStep write FManualStep;
Published | property MovimentScale: single read FMovimentScale write FMovimentScale;
Published | property OnCollision: TgxDCECollisionEvent read FOnCollision write FOnCollision;
Published | property StandardiseLayers: TgxDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;
Public | property StaticCount: Integer read GetStaticCount;
Published | property WorldDirection: TgxCoordinates read FWorldDirection write SetWorldDirection;
Published | property WorldScale: single read FWorldScale write SetWorldScale;

Description

Fields

Private FStatics: TList;

This item has no description.

Private FDynamics: TList;

This item has no description.

Private FGravity: single;

This item has no description.

Private FWorldDirection: TgxCoordinates;

This item has no description.

Private FWorldScale: single;

Used to calculate jumps f.i.

Private FMovimentScale: single;

This item has no description.

Private FStandardiseLayers: TgxDCECollisionSelection;

This item has no description.

Private FManualStep: Boolean;

This item has no description.

Private FOnCollision: TgxDCECollisionEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MoveByDistance(var Body: TgxDCEDynamic; deltaS, deltaAbsS: TAffineVector): single;

Moves the body by the distance and returns the average friction

Private function GetDynamicCount: Integer;

This item has no description.

Private function GetStaticCount: Integer;

This item has no description.

Public procedure Step(deltaTime: Double);

This item has no description.

Private procedure SetWorldDirection(const Value: TgxCoordinates);

This item has no description.

Private procedure SetWorldScale(const Value: single);

This item has no description.

Properties

Public property DynamicCount: Integer read GetDynamicCount;

This item has no description.

Published property Gravity: single read FGravity write FGravity;

This item has no description.

Published property ManualStep: Boolean read FManualStep write FManualStep;

This item has no description.

Published property MovimentScale: single read FMovimentScale write FMovimentScale;

This item has no description.

Published property OnCollision: TgxDCECollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property StandardiseLayers: TgxDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;

This item has no description.

Public property StaticCount: Integer read GetStaticCount;

This item has no description.

Published property WorldDirection: TgxCoordinates read FWorldDirection write SetWorldDirection;

This item has no description.

Published property WorldScale: single read FWorldScale write SetWorldScale;


GXSysHelp v.2.5: GXS.DCE: Class TgxDCEStatic

Class TgxDCEStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DCE

Declaration

type TgxDCEStatic = class(TgxBehaviour)

Description

This item has no description. Showing description inherited from TgxBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxDCEStatic

Overview

Fields

Private | FManager: TgxDCEManager;
Private | FManagerName: String;
Private | FActive: Boolean;
Private | FShape: TgxDCEShape;
Private | FLayer: Integer;
Private | FSolid: Boolean;
Private | FFriction: single;
Private | FBounceFactor: single;
Private | FSize: TgxCoordinates;
Private | FOnCollision: TgxDCEObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetBounceFactor(const Value: single);
Private | procedure SetFriction(const Value: single);
Private | procedure SetShape(const Value: TgxDCEShape);
Private | procedure SetSize(const Value: TgxCoordinates);

Properties

Published | property Active: Boolean read FActive write FActive;
Published | property BounceFactor: single read FBounceFactor write SetBounceFactor;
Published | property Friction: single read FFriction write SetFriction;
Published | property Layer: Integer read FLayer write FLayer;
Published | property Manager: TgxDCEManager read FManager write SetManager;
Public | property OnCollision: TgxDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Shape: TgxDCEShape read FShape write SetShape;
Published | property Size: TgxCoordinates read FSize write SetSize;
Published | property Solid: Boolean read FSolid write FSolid;

Description

Fields

Private FManager: TgxDCEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FActive: Boolean;

NOT persistent, temporarily used for persistence

Private FShape: TgxDCEShape;

This item has no description.

Private FLayer: Integer;

Collides only with lower or equal layers

Private FSolid: Boolean;

Collide and slide if true, otherwise it "walk thru walls"

Private FFriction: single;

This item has no description.

Private FBounceFactor: single;

0 (no friction); 100 (no movement)

Private FSize: TgxCoordinates;

0 (don't bounce); 1 (bounce forever)

Private FOnCollision: TgxDCEObjectCollisionEvent;

Events

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Private procedure SetBounceFactor(const Value: single);

This item has no description.

Private procedure SetFriction(const Value: single);

This item has no description.

Private procedure SetShape(const Value: TgxDCEShape);

This item has no description.

Private procedure SetSize(const Value: TgxCoordinates);

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

This item has no description.

Published property BounceFactor: single read FBounceFactor write SetBounceFactor;

This item has no description.

Published property Friction: single read FFriction write SetFriction;

This item has no description.

Published property Layer: Integer read FLayer write FLayer;

This item has no description.

Published property Manager: TgxDCEManager read FManager write SetManager;

This item has no description.

Public property OnCollision: TgxDCEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Shape: TgxDCEShape read FShape write SetShape;

This item has no description.

Published property Size: TgxCoordinates read FSize write SetSize;

This item has no description.

Published property Solid: Boolean read FSolid write FSolid;


GXSysHelp v.2.5: GXS.DCE: Class TgxDCEDynamic

Class TgxDCEDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DCE

Declaration

type TgxDCEDynamic = class(TgxBehaviour)

Description

This item has no description. Showing description inherited from TgxBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxDCEDynamic

Overview

Fields

Private | FManager: TgxDCEManager;
Private | FManagerName: String;
Private | FActive: Boolean;
Private | FUseGravity: Boolean;
Private | FLayer: Integer;
Private | FSolid: Boolean;
Private | FFriction: single;
Private | FBounceFactor: single;
Private | FSize: TgxCoordinates;
Private | FMaxRecursionDepth: byte;
Private | FSlideOrBounce: TgxDCESlideOrBounce;
Private | FAccel: TAffineVector;
Private | FSpeed: TAffineVector;
Private | FAbsAccel: TAffineVector;
Private | FAbsSpeed: TAffineVector;
Private | FGravSpeed: TAffineVector;
Private | FTotalFriction: single;
Private | FInGround: Boolean;
Private | FGroundNormal: TAffineVector;
Private | FJumpHeight: single;
Private | FJumpForce: single;
Private | FJumpSpeed: single;
Private | FJumping: Boolean;
Private | FOnCollision: TgxDCEObjectCollisionEvent;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;
Public | procedure ApplyAbsAccel(x, y, z: single); overload;
Public | procedure ApplyAccel(x, y, z: single); overload;
Public | procedure ApplyAccel(NewAccel: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoMove(deltaTime: Double);
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure Jump(jHeight, jSpeed: single);
Public | procedure Move(deltaS: TAffineVector; deltaTime: Double);
Public | procedure MoveTo(Position: TAffineVector; Amount: single);
Public | procedure StopAbsAccel;
Public | procedure StopAccel;
Private | procedure SetBounceFactor(const Value: single);
Private | procedure SetFriction(const Value: single);
Private | procedure SetSize(const Value: TgxCoordinates);

Properties

Published | property Active: Boolean read FActive write FActive;
Published | property BounceFactor: single read FBounceFactor write SetBounceFactor;
Published | property Friction: single read FFriction write SetFriction;
Public | property InGround: Boolean read FInGround;
Published | property Layer: Integer read FLayer write FLayer;
Published | property Manager: TgxDCEManager read FManager write SetManager;
Public | property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;
Public | property OnCollision: TgxDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Size: TgxCoordinates read FSize write SetSize;
Published | property SlideOrBounce: TgxDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;
Published | property Solid: Boolean read FSolid write FSolid;
Public | property Speed: TAffineVector read FSpeed write FSpeed;
Published | property UseGravity: Boolean read FUseGravity write FUseGravity;

Description

Fields

Private FManager: TgxDCEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FActive: Boolean;

NOT persistent, temporarily used for persistence

Private FUseGravity: Boolean;

This item has no description.

Private FLayer: Integer;

This item has no description.

Private FSolid: Boolean;

Collides only with lower or equal layers

Private FFriction: single;

Collide and slide if true, otherwise it "walk thru walls"

Private FBounceFactor: single;

0 (no friction); 100 (no movement)

Private FSize: TgxCoordinates;

0 (don't bounce); 1 (bounce forever)

Private FMaxRecursionDepth: byte;

Number of iterations of the collision method

Private FSlideOrBounce: TgxDCESlideOrBounce;

This item has no description.

Private FAccel: TAffineVector;

gak20041122 Movement

Private FSpeed: TAffineVector;

Current acceleration

Private FAbsAccel: TAffineVector;

Current speed

Private FAbsSpeed: TAffineVector;

Current absolute accel

Private FGravSpeed: TAffineVector;

Current absolute speed

Private FTotalFriction: single;

Current gravity speed

Private FInGround: Boolean;

Current sum of all contatcs friction

Private FGroundNormal: TAffineVector;

This item has no description.

Private FJumpHeight: single;

This item has no description.

Private FJumpForce: single;

This item has no description.

Private FJumpSpeed: single;

This item has no description.

Private FJumping: Boolean;

This item has no description.

Private FOnCollision: TgxDCEObjectCollisionEvent;

Events

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;

This item has no description.

Public procedure ApplyAbsAccel(x, y, z: single); overload;

This item has no description.

Public procedure ApplyAccel(x, y, z: single); overload;

This item has no description.

Public procedure ApplyAccel(NewAccel: TAffineVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoMove(deltaTime: Double);

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure Jump(jHeight, jSpeed: single);

This item has no description.

Public procedure Move(deltaS: TAffineVector; deltaTime: Double);

This item has no description.

Public procedure MoveTo(Position: TAffineVector; Amount: single);

This item has no description.

Public procedure StopAbsAccel;

This item has no description.

Public procedure StopAccel;

This item has no description.

Private procedure SetBounceFactor(const Value: single);

This item has no description.

Private procedure SetFriction(const Value: single);

This item has no description.

Private procedure SetSize(const Value: TgxCoordinates);

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

This item has no description.

Published property BounceFactor: single read FBounceFactor write SetBounceFactor;

This item has no description.

Published property Friction: single read FFriction write SetFriction;

This item has no description.

Public property InGround: Boolean read FInGround;

This item has no description.

Published property Layer: Integer read FLayer write FLayer;

This item has no description.

Published property Manager: TgxDCEManager read FManager write SetManager;

This item has no description.

Public property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;

This item has no description.

Public property OnCollision: TgxDCEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Size: TgxCoordinates read FSize write SetSize;

This item has no description.

Published property SlideOrBounce: TgxDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;

This item has no description.

Published property Solid: Boolean read FSolid write FSolid;

This item has no description.

Public property Speed: TAffineVector read FSpeed write FSpeed;

Runtime only

Published property UseGravity: Boolean read FUseGravity write FUseGravity;


GXSysHelp v.2.5: GXS.DCEMisc

Unit GXS.DCEMisc

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

* The graphics engine GXScene https://github.com/glscene

Uses

  • GXS.Coordinates
  • GXS.VectorFileObjects
  • GXS.EllipseCollision
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Scene
  • GXS.TerrainRenderer
  • GXS.ProxyObjects
  • GXS.MultiProxy
  • GLScene.VectorTypes

Overview

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);
procedure ECResetColliders(var MovePack: TECMovePack);
procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TgxBaseSceneObject; Solid: Boolean; ObjectID: Integer);
procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TgxBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);
procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TgxTerrainRenderer; Resolution: Single; Solid: Boolean; ObjectID: Integer);
procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);

Constants

DCEBox: array [0..35] of TAffineVector = ( (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X: 1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y:-1; Z:-1), (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1) );

Description

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);

Calculate and set the collision range

procedure ECResetColliders(var MovePack: TECMovePack);

Set the collider lists to null

procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TgxBaseSceneObject; Solid: Boolean; ObjectID: Integer);

Add freeform's octree data

procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TgxBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);

Add a TriMesh box

procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TgxTerrainRenderer; Resolution: Single; Solid: Boolean; ObjectID: Integer);

Add the terrain as a TriMesh

procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);

Add a static ellipsoid

Constants

DCEBox: array [0..35] of TAffineVector = ( (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X: 1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y:-1; Z:-1), (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1) );


GXSysHelp v.2.5: GXS.DwsObjects

Unit GXS.DwsObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Base classes and logic for DelphiWebScript enabled objects

Uses

  • System.Classes
  • System.SysUtils
  • DwsComp
  • DwsExprs
  • DwsSymbols
  • GXS.Scene
  • GXS.GLScene.XCollection
  • GXS.ScriptDws
  • GXS.BaseClasses
  • GLScene.Manager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDwsActiveBehaviour |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GXS.DwsObjects: Class TgxDwsActiveBehaviour

Class TgxDwsActiveBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DwsObjects

Declaration

type TgxDwsActiveBehaviour = class(TgxBehaviour)

Description

A DelphiWebScript enabled behaviour. This behaviour also calls on the OnProgress and OnBeginProgram procedures in the script if they are found. Once compiled and executed the program remains active until killed, deactivated or the script is invalidated.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxDwsActiveBehaviour

Overview

Fields

Private | FActive: Boolean;
Private | FScript: TStringList;
Private | FDwsProgram: TProgram;
Private | FCompiler: TgxDelphiWebScriptII;
Private | FCompilerName: String;

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: String; override;
Public | procedure DoProgress(const ProgressTimes : TgxProgressTimes); override;
Public | procedure InvalidateScript;
Private | procedure BeginProgram;
Private | procedure CompileProgram;
Private | procedure EndProgram;
Private | procedure KillProgram;
Private | procedure SetActive(const Value : Boolean);
Private | procedure SetCompiler(const Value : TgxDelphiWebScript);
Private | procedure SetScript(const Value : TStringList);

Properties

Published | property Active : Boolean read FActive write SetActive;
Published | property Compiler : TgxDelphiWebScriptII read FCompiler write SetCompiler;
Public | property DwsProgram : TProgram read FDwsProgram;
Published | property Script : TStringList read FScript write SetScript;

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FScript: TStringList;

This item has no description.

Private FDwsProgram: TProgram;

This item has no description.

Private FCompiler: TgxDelphiWebScriptII;

This item has no description.

Private FCompilerName: String;

This item has no description.

Methods

Public constructor Create(AOwner : TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure DoProgress(const ProgressTimes : TgxProgressTimes); override;

This item has no description.

Public procedure InvalidateScript;

This item has no description.

Private procedure BeginProgram;

This item has no description.

Private procedure CompileProgram;

This item has no description.

Private procedure EndProgram;

This item has no description.

Private procedure KillProgram;

This item has no description.

Private procedure SetActive(const Value : Boolean);

This item has no description.

Private procedure SetCompiler(const Value : TgxDelphiWebScript);

This item has no description.

Private procedure SetScript(const Value : TStringList);

This item has no description.

Properties

Published property Active : Boolean read FActive write SetActive;

This item has no description.

Published property Compiler : TgxDelphiWebScriptII read FCompiler write SetCompiler;

This item has no description.

Public property DwsProgram : TProgram read FDwsProgram;

This item has no description.

Published property Script : TStringList read FScript write SetScript;


GXSysHelp v.2.5: GXS.DynamicTexture

Unit GXS.DynamicTexture

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

* The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.Context
  • GXS.Texture
  • GLScene.TextureFormat
  • GXS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDynamicTextureImage |


GXSysHelp v.2.5: GXS.DynamicTexture: Class TgxDynamicTextureImage

Class TgxDynamicTextureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.DynamicTexture

Declaration

type TgxDynamicTextureImage = class(TgxBlankImage)

Description

Allows for fast updating of the texture at runtime.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxBlankImage
  • TgxDynamicTextureImage

Overview

Fields

Private | FUpdating: integer;
Private | FTexSize: integer;
Private | FBuffer: pointer;
Private | FPBO: TgxBufferObjectHandle;
Private | FData: pointer;
Private | FDirtyRect: TRect;
Private | FUseBGR: boolean;
Private | FUsePBO: boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetDirtyRectangle(const Value: TRect);
Private | procedure SetUsePBO(const Value: boolean);

Properties

Public | property Data: pointer read FData;
Public | property DirtyRectangle: TRect read FDirtyRect write SetDirtyRectangle;
Public | property UseBGR: boolean read FUseBGR write FUseBGR;
Public | property UsePBO: boolean read FUsePBO write SetUsePBO;

Description

Fields

Private FUpdating: integer;

This item has no description.

Private FTexSize: integer;

This item has no description.

Private FBuffer: pointer;

This item has no description.

Private FPBO: TgxBufferObjectHandle;

This item has no description.

Private FData: pointer;

This item has no description.

Private FDirtyRect: TRect;

This item has no description.

Private FUseBGR: boolean;

This item has no description.

Private FUsePBO: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public procedure BeginUpdate;

Must be called before using the Data pointer. Rendering context must be active!

Public procedure EndUpdate;

Must be called after data is changed. This will upload the new data

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetDirtyRectangle(const Value: TRect);

This item has no description.

Private procedure SetUsePBO(const Value: boolean);

This item has no description.

Properties

Public property Data: pointer read FData;

Pointer to buffer data. Will be nil outside a BeginUpdate / EndUpdate block

Public property DirtyRectangle: TRect read FDirtyRect write SetDirtyRectangle;

Marks the dirty rectangle inside the texture. BeginUpdate sets it to ((0, 0), (Width, Height)), ie the entire texture. Override it if you're only changing a small piece of the texture. Note that the Data pointer is relative to the DirtyRectangle, NOT the entire texture.

Public property UseBGR: boolean read FUseBGR write FUseBGR;

Indicates that the data is stored as BGR(A) instead of RGB(A). The default is BGR(A)

Public property UsePBO: boolean read FUsePBO write SetUsePBO;

Enables or disables use of a PBO. Default is true


GXSysHelp v.2.5: GXS.EllipseCollision

Unit GXS.EllipseCollision

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • GLScene.VectorGeometry
  • GXS.Octree
  • GXS.VectorLists
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TECPlane |
Record TECObjectInfo |
Record TECTriangle |
Record TECTriMesh |
Record TECFreeForm |
Record TECCollider |
Record TECContact |
Record TECCollisionPacket |
Record TECMovePack |

Functions and Procedures

function VectorDivide(const v, divider: TAffineVector): TAffineVector;
procedure CollideAndSlide(var MP: TECMovePack);
procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

Types

TECColliderList = Array of TECCollider;
TECColliderShape = (...);
TECContactList = Array of TECContact;
TECFreeFormList = Array of TECFreeForm;
TECTriMeshList = Array of TECTriMesh;

Constants

cECCloseDistance: Single = 0.005;

Variables

Debug_tri: Array of TECTriangle;

Description

Functions and Procedures

function VectorDivide(const v, divider: TAffineVector): TAffineVector;

This item has no description.

procedure CollideAndSlide(var MP: TECMovePack);

This item has no description.

procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

This item has no description.

Types

TECColliderList = Array of TECCollider;

This item has no description.

TECColliderShape = (...);

This item has no description.

Values
  • csEllipsoid
  • csPoint
TECContactList = Array of TECContact;

This item has no description.

TECFreeFormList = Array of TECFreeForm;

This item has no description.

TECTriMeshList = Array of TECTriMesh;

This item has no description.

Constants

cECCloseDistance: Single = 0.005;

This item has no description.

Variables

Debug_tri: Array of TECTriangle;

.$DEFINE DEBUG


GXSysHelp v.2.5: GXS.EllipseCollision: Class TECPlane

Class TECPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECPlane = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TECPlane

Overview

Fields

Public | Equation: array [0 .. 3] of Single;
Public | Origin: TAffineVector;
Public | Normal: TAffineVector;

Methods

Public | function isFrontFacingTo(const Direction: TAffineVector): Boolean;
Public | function signedDistanceTo(const Point: TAffineVector): Single;
Public | procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;
Public | procedure MakePlane(const p1, p2, p3: TAffineVector); overload;

Description

Fields

Public Equation: array [0 .. 3] of Single;

This item has no description.

Public Origin: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Methods

Public function isFrontFacingTo(const Direction: TAffineVector): Boolean;

This item has no description.

Public function signedDistanceTo(const Point: TAffineVector): Single;

This item has no description.

Public procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;

This item has no description.

Public procedure MakePlane(const p1, p2, p3: TAffineVector); overload;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECObjectInfo

Record TECObjectInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECObjectInfo = record

Description

Object collision properties

Overview

Fields

Public | AbsoluteMatrix: TMatrix4f;
Public | Solid: Boolean;
Public | IsDynamic: Boolean;
Public | ObjectID: Integer;

Description

Fields

Public AbsoluteMatrix: TMatrix4f;

This item has no description.

Public Solid: Boolean;

This item has no description.

Public IsDynamic: Boolean;

This item has no description.

Public ObjectID: Integer;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECTriangle

Record TECTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECTriangle = record

Description

This item has no description.

Overview

Fields

Public | p1: TAffineVector;
Public | p2: TAffineVector;
Public | p3: TAffineVector;

Description

Fields

Public p1: TAffineVector;

This item has no description.

Public p2: TAffineVector;

This item has no description.

Public p3: TAffineVector;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECTriMesh

Record TECTriMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECTriMesh = record

Description

This item has no description.

Overview

Fields

Public | Triangles: Array of TECTriangle;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Triangles: Array of TECTriangle;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECFreeForm

Record TECFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECFreeForm = record

Description

This item has no description.

Overview

Fields

Public | OctreeNodes: array of PgxOctreeNode;
Public | triangleFiler: ˆTgxAffineVectorList;
Public | InvertedNormals: Boolean;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public OctreeNodes: array of PgxOctreeNode;

This item has no description.

Public triangleFiler: ˆTgxAffineVectorList;

This item has no description.

Public InvertedNormals: Boolean;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECCollider

Record TECCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECCollider = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | Radius: TAffineVector;
Public | Shape: TECColliderShape;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Radius: TAffineVector;

This item has no description.

Public Shape: TECColliderShape;

This item has no description.

Public ObjectInfo: TECObjectInfo;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECContact

Record TECContact

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECContact = record

Description

This item has no description.

Overview

Fields

Public | Position: TAffineVector;
Public | SurfaceNormal: TAffineVector;
Public | Distance: Single;
Public | ObjectInfo: TECObjectInfo;

Description

Fields

Public Position: TAffineVector;

Generated by the collision procedure

Public SurfaceNormal: TAffineVector;

This item has no description.

Public Distance: Single;

This item has no description.

Public ObjectInfo: TECObjectInfo;

Collider data


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECCollisionPacket

Record TECCollisionPacket

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECCollisionPacket = record

Description

This item has no description.

Overview

Fields

Public | Velocity: TAffineVector;
Public | NormalizedVelocity: TAffineVector;
Public | BasePoint: TAffineVector;
Public | FoundCollision: Boolean;
Public | NearestDistance: Single;
Public | NearestObject: Integer;
Public | IntersectionPoint: TAffineVector;
Public | IntersectionNormal: TAffineVector;

Description

Fields

Public Velocity: TAffineVector;

Information about the move being requested: (in eSpace)

Public NormalizedVelocity: TAffineVector;

This item has no description.

Public BasePoint: TAffineVector;

This item has no description.

Public FoundCollision: Boolean;

Hit information

Public NearestDistance: Single;

This item has no description.

Public NearestObject: Integer;

This item has no description.

Public IntersectionPoint: TAffineVector;

This item has no description.

Public IntersectionNormal: TAffineVector;


GXSysHelp v.2.5: GXS.EllipseCollision: Record TECMovePack

Record TECMovePack

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EllipseCollision

Declaration

type TECMovePack = record

Description

This item has no description.

Overview

Fields

Public | TriMeshes: TECTriMeshList;
Public | Freeforms: TECFreeFormList;
Public | Colliders: TECColliderList;
Public | Position: TAffineVector;
Public | Velocity: TAffineVector;
Public | Gravity: TAffineVector;
Public | Radius: TAffineVector;
Public | ObjectInfo: TECObjectInfo;
Public | CollisionRange: Single;
Public | UnitScale: Double;
Public | MaxRecursionDepth: Byte;
Public | CP: TECCollisionPacket;
Public | collisionRecursionDepth: Byte;
Public | ResultPos: TAffineVector;
Public | NearestObject: Integer;
Public | VelocityCollided: Boolean;
Public | GravityCollided: Boolean;
Public | GroundNormal: TAffineVector;
Public | Contacts: TECContactList

Description

Fields

Public TriMeshes: TECTriMeshList;

List of closest triangles

Public Freeforms: TECFreeFormList;

List of freeform octree nodes

Public Colliders: TECColliderList;

List of other colliders (f.i. ellipsoids)

Public Position: TAffineVector;

Movement params

Public Velocity: TAffineVector;

This item has no description.

Public Gravity: TAffineVector;

This item has no description.

Public Radius: TAffineVector;

This item has no description.

Public ObjectInfo: TECObjectInfo;

This item has no description.

Public CollisionRange: Single;

This item has no description.

Public UnitScale: Double;

Stores the range where objects may collide Internal

Public MaxRecursionDepth: Byte;

This item has no description.

Public CP: TECCollisionPacket;

This item has no description.

Public collisionRecursionDepth: Byte;

This item has no description.

Public ResultPos: TAffineVector;

Result

Public NearestObject: Integer;

This item has no description.

Public VelocityCollided: Boolean;

This item has no description.

Public GravityCollided: Boolean;

This item has no description.

Public GroundNormal: TAffineVector;

This item has no description.

Public Contacts: TECContactList


GXSysHelp v.2.5: GXS.EParticleMasksManager

Unit GXS.EParticleMasksManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Types
  • System.SysUtils
  • System.Classes
  • System.UITypes
  • FMX.Graphics
  • GXS.Color
  • GXS.Texture
  • GXS.Material
  • GXS.Scene
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.ParticleFX
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxEParticleMask |
Class TgxEParticleMasks |
Class TgxEParticleMasksManager |

Types

TgxEProjectedParticleMask = (...);

Description

Types

TgxEProjectedParticleMask = (...);

This item has no description.

Values
  • pptXMask
  • pptYMask
  • pptZMask


GXSysHelp v.2.5: GXS.EParticleMasksManager: Class TgxEParticleMask

Class TgxEParticleMask

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EParticleMasksManager

Declaration

type TgxEParticleMask = class(TCollectionItem, IgxMaterialLibrarySupported)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxEParticleMask

Overview

Fields

Private | FName: string;
Private | FScale: TgxCoordinates;
Private | FPosition: TgxCoordinates;
Private | FYMask: TgxLibMaterialName;
Private | FZMask: TgxLibMaterialName;
Private | FXMask: TgxLibMaterialName;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FBackgroundColor: TColor;
Private | FMaskColor: TColor;
Private | FMaxX: Integer;
Private | FMaxY: Integer;
Private | FMaxZ: Integer;
Private | FMinX: Integer;
Private | FMinY: Integer;
Private | FMinZ: Integer;
Private | IXW: Integer;
Private | IXH: Integer;
Private | IYW: Integer;
Private | IYH: Integer;
Private | IZW: Integer;
Private | IZH: Integer;
Private | LX: Integer;
Private | LY: Integer;
Private | LZ: Integer;
Private | MX: Integer;
Private | MY: Integer;
Private | BogusMask: Boolean;
Private | BogusMaskX: Boolean;
Private | BogusMaskY: Boolean;
Private | BogusMaskZ: Boolean;
Private | FRollAngle: Single;
Private | FPitchAngle: Single;
Private | FTurnAngle: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Private | function XCan: TBitmap;
Private | function YCan: TBitmap;
Private | function ZCan: TBitmap;
Private | function _AddRef: Integer; stdcall;
Private | function _Release: Integer; stdcall;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMaskFromProjection(FromMask, ToMask: TgxEProjectedParticleMask; Depth: Integer);
Public | procedure Pitch(Angle: Single);
Public | procedure Roll(Angle: Single);
Public | procedure Turn(Angle: Single);
Public | procedure UpdateExtents;
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetName(const Value: string);
Private | procedure SetXMask(const Value: TgxLibMaterialName);
Private | procedure SetYMask(const Value: TgxLibMaterialName);
Private | procedure SetZMask(const Value: TgxLibMaterialName);

Properties

Published | property BackgroundColor: TColor read FBackgroundColor write FBackgroundColor;
Published | property MaskColor: TColor read FMaskColor write FMaskColor;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;
Published | property PitchAngle: Single read FPitchAngle write FPitchAngle;
Published | property Position: TgxCoordinates read FPosition write FPosition;
Published | property RollAngle: Single read FRollAngle write FRollAngle;
Published | property Scale: TgxCoordinates read FScale write FScale;
Published | property TurnAngle: Single read FTurnAngle write FTurnAngle;
Published | property XMask: TgxLibMaterialName read FXMask write SetXMask;
Published | property YMask: TgxLibMaterialName read FYMask write SetYMask;
Published | property ZMask: TgxLibMaterialName read FZMask write SetZMask;

Description

Fields

Private FName: string;

This item has no description.

Private FScale: TgxCoordinates;

This item has no description.

Private FPosition: TgxCoordinates;

This item has no description.

Private FYMask: TgxLibMaterialName;

This item has no description.

Private FZMask: TgxLibMaterialName;

This item has no description.

Private FXMask: TgxLibMaterialName;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FBackgroundColor: TColor;

This item has no description.

Private FMaskColor: TColor;

This item has no description.

Private FMaxX: Integer;

This item has no description.

Private FMaxY: Integer;

This item has no description.

Private FMaxZ: Integer;

This item has no description.

Private FMinX: Integer;

This item has no description.

Private FMinY: Integer;

This item has no description.

Private FMinZ: Integer;

This item has no description.

Private IXW: Integer;

This item has no description.

Private IXH: Integer;

This item has no description.

Private IYW: Integer;

This item has no description.

Private IYH: Integer;

This item has no description.

Private IZW: Integer;

This item has no description.

Private IZH: Integer;

This item has no description.

Private LX: Integer;

This item has no description.

Private LY: Integer;

This item has no description.

Private LZ: Integer;

This item has no description.

Private MX: Integer;

This item has no description.

Private MY: Integer;

This item has no description.

Private BogusMask: Boolean;

This item has no description.

Private BogusMaskX: Boolean;

This item has no description.

Private BogusMaskY: Boolean;

This item has no description.

Private BogusMaskZ: Boolean;

This item has no description.

Private FRollAngle: Single;

we might have a pitch mask

Private FPitchAngle: Single;

This item has no description.

Private FTurnAngle: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Private function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;

implementing IInterface

Private function XCan: TBitmap;

This item has no description.

Private function YCan: TBitmap;

This item has no description.

Private function ZCan: TBitmap;

This item has no description.

Private function _AddRef: Integer; stdcall;

This item has no description.

Private function _Release: Integer; stdcall;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GenerateMaskFromProjection(FromMask, ToMask: TgxEProjectedParticleMask; Depth: Integer);

this generates a xmask from another mask just to fill gaps, depth is dependant on frommask width and height

Public procedure Pitch(Angle: Single);

This item has no description.

Public procedure Roll(Angle: Single);

This item has no description.

Public procedure Turn(Angle: Single);

This item has no description.

Public procedure UpdateExtents;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Private procedure SetXMask(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetYMask(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetZMask(const Value: TgxLibMaterialName);

This item has no description.

Properties

Published property BackgroundColor: TColor read FBackgroundColor write FBackgroundColor;

background color is the color that prevents particles from being positioned there

Published property MaskColor: TColor read FMaskColor write FMaskColor;

maskcolor is where particles are allowed to be positioned

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Name: string read FName write SetName;

the reference name of the particle mask

Published property PitchAngle: Single read FPitchAngle write FPitchAngle;

This item has no description.

Published property Position: TgxCoordinates read FPosition write FPosition;

This item has no description.

Published property RollAngle: Single read FRollAngle write FRollAngle;

just the average angles for orientation

Published property Scale: TgxCoordinates read FScale write FScale;

scales and positions

Published property TurnAngle: Single read FTurnAngle write FTurnAngle;

This item has no description.

Published property XMask: TgxLibMaterialName read FXMask write SetXMask;

mask images, make sure materiallibrary is assigned

Published property YMask: TgxLibMaterialName read FYMask write SetYMask;

This item has no description.

Published property ZMask: TgxLibMaterialName read FZMask write SetZMask;


GXSysHelp v.2.5: GXS.EParticleMasksManager: Class TgxEParticleMasks

Class TgxEParticleMasks

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EParticleMasksManager

Declaration

type TgxEParticleMasks = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxEParticleMasks

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxEParticleMask;

Properties

Public property Items[Index: Integer]: TgxEParticleMask read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxEParticleMask;

This item has no description.

Properties

Public property Items[Index: Integer]: TgxEParticleMask read GetItems write SetItems;


GXSysHelp v.2.5: GXS.EParticleMasksManager: Class TgxEParticleMasksManager

Class TgxEParticleMasksManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.EParticleMasksManager

Declaration

type TgxEParticleMasksManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxEParticleMasksManager

Overview

Fields

Private FParticleMasks: TgxEParticleMasks;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticlePositionFromMask(MaskName: string): TVector3f;
Public | function ParticleMaskByName(MaskName: string): TgxEParticleMask;
Public | function TargetParticlePositionFromMask(TargetObject: TgxBaseSceneObject; MaskName: string): TVector3f;
Public | procedure SetParticlePositionFromMask(Particle: TgxParticle; MaskName: string);
Public | procedure SetParticlePositionFromMaskTarget(Particle: TgxParticle; MaskName: string; TargetObject: TgxBaseSceneObject);

Properties

Published property ParticleMasks: TgxEParticleMasks read FParticleMasks write FParticleMasks;

Description

Fields

Private FParticleMasks: TgxEParticleMasks;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticlePositionFromMask(MaskName: string): TVector3f;

This item has no description.

Public function ParticleMaskByName(MaskName: string): TgxEParticleMask;

This item has no description.

Public function TargetParticlePositionFromMask(TargetObject: TgxBaseSceneObject; MaskName: string): TVector3f;

This item has no description.

Public procedure SetParticlePositionFromMask(Particle: TgxParticle; MaskName: string);

This item has no description.

Public procedure SetParticlePositionFromMaskTarget(Particle: TgxParticle; MaskName: string; TargetObject: TgxBaseSceneObject);

This item has no description.

Properties

Published property ParticleMasks: TgxEParticleMasks read FParticleMasks write FParticleMasks;


GXSysHelp v.2.5: GXS.ExplosionFx

Unit GXS.ExplosionFx

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.Scene
  • GXS.VectorFileObjects
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBExplosionFX |


GXSysHelp v.2.5: GXS.ExplosionFx: Class TgxBExplosionFX

Class TgxBExplosionFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ExplosionFx

Declaration

type TgxBExplosionFX = class(TgxObjectPreEffect)

Description

This item has no description. Showing description inherited from TgxObjectPreEffect.

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPreEffect
  • TgxBExplosionFX

Overview

Fields

Private | FTriList: TgxAffineVectorList;
Private | FRotList: TgxAffineVectorList;
Private | FDirList: TgxAffineVectorList;
Private | FPosList: TgxAffineVectorList;
Private | FEnabled: boolean;
Private | FFaceCount: integer;
Private | FSpeed: single;
Private | FDirection: TgxCoordinates;
Private | FMaxSteps: integer;
Private | FStep: integer;

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Render(var rci : TgxRenderContextInfo); override;
Public | procedure Reset;
Private | procedure SetDirection(value: TgxCoordinates);
Private | procedure SetDirList(Value: TgxAffineVectorList);
Private | procedure SetEnabled(value: boolean);
Private | procedure SetPosList(Value: TgxAffineVectorList);
Private | procedure SetRotList(Value: TgxAffineVectorList);
Private | procedure SetTriList(Value: TgxAffineVectorList);

Properties

Published | property Direction: TgxCoordinates read FDirection write SetDirection;
Public | property Enabled: boolean read FEnabled write SetEnabled;
Published | property MaxSteps: integer read FMaxSteps write FMaxSteps;
Published | property Speed: single read FSpeed write FSpeed;
Public | property Step: integer read FStep;

Description

Fields

Private FTriList: TgxAffineVectorList;

This item has no description.

Private FRotList: TgxAffineVectorList;

This item has no description.

Private FDirList: TgxAffineVectorList;

This item has no description.

Private FPosList: TgxAffineVectorList;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FFaceCount: integer;

This item has no description.

Private FSpeed: single;

This item has no description.

Private FDirection: TgxCoordinates;

This item has no description.

Private FMaxSteps: integer;

This item has no description.

Private FStep: integer;

This item has no description.

Methods

Public constructor Create(aOwner : TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Render(var rci : TgxRenderContextInfo); override;

This item has no description.

Public procedure Reset;

Resets the behaviour, so the information can be re-cached and the mesh can be exploded again

Private procedure SetDirection(value: TgxCoordinates);

This item has no description.

Private procedure SetDirList(Value: TgxAffineVectorList);

This item has no description.

Private procedure SetEnabled(value: boolean);

This item has no description.

Private procedure SetPosList(Value: TgxAffineVectorList);

This item has no description.

Private procedure SetRotList(Value: TgxAffineVectorList);

This item has no description.

Private procedure SetTriList(Value: TgxAffineVectorList);

This item has no description.

Properties

Published property Direction: TgxCoordinates read FDirection write SetDirection;

This item has no description.

Public property Enabled: boolean read FEnabled write SetEnabled;

This item has no description.

Published property MaxSteps: integer read FMaxSteps write FMaxSteps;

This item has no description.

Published property Speed: single read FSpeed write FSpeed;

This item has no description.

Public property Step: integer read FStep;


GXSysHelp v.2.5: GXS.Extrusion

Unit GXS.Extrusion

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.Classes
  • System.Math
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GLScene.Spline
  • GXS.Context
  • GXS.Objects
  • GXS.Scene
  • GXS.MultiPolygon
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Nodes
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxRevolutionSolid |
Class TgxExtrusionSolid |
Class TgxPipeNode |
Class TgxPipeNodes |
Class TgxPipe |

Types

TgxExtrusionSolidPart = (...);
TgxExtrusionSolidParts = set of TgxExtrusionSolidPart;
TgxRevolutionSolidPart = (...);
TgxRevolutionSolidParts = set of TgxRevolutionSolidPart;
TPipeNodesColorMode = (...);
TPipeNormalMode = (...);
TPipePart = (...);
TPipeParts = set of TPipePart;
TPipeTexCoordMode = (...);

Description

Types

TgxExtrusionSolidPart = (...);

This item has no description.

Values
  • espOutside
  • espInside
  • espStartPolygon
  • espStopPolygon
TgxExtrusionSolidParts = set of TgxExtrusionSolidPart;

This item has no description.

TgxRevolutionSolidPart = (...);

This item has no description.

Values
  • rspOutside
  • rspInside
  • rspStartPolygon
  • rspStopPolygon
TgxRevolutionSolidParts = set of TgxRevolutionSolidPart;

This item has no description.

TPipeNodesColorMode = (...);

This item has no description.

Values
  • pncmNone
  • pncmEmission
  • pncmAmbient
  • pncmDiffuse
  • pncmAmbientAndDiffuse
TPipeNormalMode = (...);

This item has no description.

Values
  • pnmDefault
  • pnmAdvanced
TPipePart = (...);

This item has no description.

Values
  • ppOutside
  • ppInside
  • ppStartDisk
  • ppStopDisk
TPipeParts = set of TPipePart;

This item has no description.

TPipeTexCoordMode = (...);

This item has no description.

Values
  • ptcmDefault
  • ptcmManual


GXSysHelp v.2.5: GXS.Extrusion: Class TgxRevolutionSolid

Class TgxRevolutionSolid

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Extrusion

Declaration

type TgxRevolutionSolid = class(TgxPolygonBase)

Description

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TgxRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPolygonBase
  • TgxRevolutionSolid

Overview

Fields

Private | FSlices: Integer;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FNormals: TgxNormalSmoothing;
Private | FYOffsetPerTurn: Single;
Private | FTriangleCount: Integer;
Private | FNormalDirection: TgxNormalDirection;
Private | FParts: TgxRevolutionSolidParts;
Private | FAxisAlignedDimensionsCache: TVector4f;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure StructureChanged; override;

Properties

Published | property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TgxRevolutionSolidParts read FParts write SetParts default [rspOutside];
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;
Public | property TriangleCount: Integer read FTriangleCount;
Published | property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Description

Fields

Private FSlices: Integer;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FNormals: TgxNormalSmoothing;

This item has no description.

Private FYOffsetPerTurn: Single;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FNormalDirection: TgxNormalDirection;

This item has no description.

Private FParts: TgxRevolutionSolidParts;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsFlat;

This item has no description.

Published property Parts: TgxRevolutionSolidParts read FParts write SetParts default [rspOutside];

Parts of the rotation solid to be generated for rendering. rspInside and rspOutside are generated from the curve and make the inside/outside as long as NormalDirection=ndOutside and the solid is described by the curve that goes from top to bottom. Start/StopPolygon are tesselated from the curve (considered as closed).

Published property Slices: Integer read FSlices write SetSlices default 16;

Number of slices per turn (360deg.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.

Published property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Y offset applied to the curve position for each turn. This amount is applied proportionnally, for instance if your curve is a small circle, off from the Y axis, with a YOffset set to 0 (zero), you will get a torus, but with a non null value, you will get a small helicoidal spring. This can be useful for rendering, lots of helicoidal objects from screws, to nails to stairs etc.


GXSysHelp v.2.5: GXS.Extrusion: Class TgxExtrusionSolid

Class TgxExtrusionSolid

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Extrusion

Declaration

type TgxExtrusionSolid = class(TgxMultiPolygonBase)

Description

Extrudes a complex Polygon into Z direction. For contour description see TgxMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TgxRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMultiPolygonBase
  • TgxExtrusionSolid

Overview

Fields

Private | FStacks: Integer;
Private | FNormals: TgxNormalSmoothing;
Private | FTriangleCount: Integer;
Private | FNormalDirection: TgxNormalDirection;
Private | FParts: TgxExtrusionSolidParts;
Private | FHeight: Single;
Private | FMinSmoothAngle: Single;
Private | FMinSmoothAngleCos: Single;
Private | FAxisAlignedDimensionsCache: TVector4f;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure StructureChanged; override;
Private | procedure SetHeight(const Value: Single);
Private | procedure SetMinSmoothAngle(const Value: Single);

Properties

Published | property Height: Single read FHeight write SetHeight;
Published | property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;
Published | property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TgxExtrusionSolidParts read FParts write SetParts default [espOutside];
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Fields

Private FStacks: Integer;

This item has no description.

Private FNormals: TgxNormalSmoothing;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FNormalDirection: TgxNormalDirection;

This item has no description.

Private FParts: TgxExtrusionSolidParts;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FMinSmoothAngle: Single;

This item has no description.

Private FMinSmoothAngleCos: Single;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description. Showing description inherited from TgxMultiPolygonBase.Create.

property PNormal:PAffineVector read FPNormal;

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetHeight(const Value: Single);

This item has no description.

Private procedure SetMinSmoothAngle(const Value: Single);

This item has no description.

Properties

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;

This item has no description.

Published property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsFlat;

This item has no description.

Published property Parts: TgxExtrusionSolidParts read FParts write SetParts default [espOutside];

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 1;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.


GXSysHelp v.2.5: GXS.Extrusion: Class TgxPipeNode

Class TgxPipeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Extrusion

Declaration

type TgxPipeNode = class(TgxNode)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNode
  • TgxPipeNode

Overview

Fields

Private | FRadiusFactor: Single;
Private | FColor: TgxColor;
Private | FTexCoordT: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Color: TgxColor read FColor write SetColor;
Published | property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;
Published | property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;

Description

Fields

Private FRadiusFactor: Single;

This item has no description.

Private FColor: TgxColor;

This item has no description.

Private FTexCoordT: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TgxColor read FColor write SetColor;

This item has no description.

Published property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;

This item has no description.

Published property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;


GXSysHelp v.2.5: GXS.Extrusion: Class TgxPipeNodes

Class TgxPipeNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Extrusion

Declaration

type TgxPipeNodes = class(TgxLinesNodes)

Description

This item has no description. Showing description inherited from TgxLinesNodes.

Specialized collection for Nodes in a TgxLines objects. Stores TgxLinesNode items.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxNodes
  • TgxLinesNodes
  • TgxPipeNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxPipeNode;
Public | function FindItemID(ID: Integer): TgxPipeNode;

Properties

Public property Items[index: Integer]: TgxPipeNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxPipeNode;

This item has no description.

Public function FindItemID(ID: Integer): TgxPipeNode;

This item has no description.

Properties

Public property Items[index: Integer]: TgxPipeNode read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Extrusion: Class TgxPipe

Class TgxPipe

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Extrusion

Declaration

type TgxPipe = class(TgxPolygonBase)

Description

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPolygonBase
  • TgxPipe

Overview

Fields

Private | FSlices: Integer;
Private | FParts: TPipeParts;
Private | FTriangleCount: Integer;
Private | FRadius: Single;
Private | FNodesColorMode: TPipeNodesColorMode;
Private | FTextCoordMode: TPipeTexCoordMode;
Private | FTextCoordTileS: Single;
Private | FTextCoordTileT: Single;
Private | FNormalMode: TPipeNormalMode;
Private | FNormalSmoothAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;
Published | property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;
Published | property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;
Published | property Parts: TPipeParts read FParts write SetParts default [ppOutside];
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;
Published | property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;
Published | property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Fields

Private FSlices: Integer;

This item has no description.

Private FParts: TPipeParts;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FNodesColorMode: TPipeNodesColorMode;

This item has no description.

Private FTextCoordMode: TPipeTexCoordMode;

This item has no description.

Private FTextCoordTileS: Single;

This item has no description.

Private FTextCoordTileT: Single;

This item has no description.

Private FNormalMode: TPipeNormalMode;

This item has no description.

Private FNormalSmoothAngle: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;

This item has no description.

Published property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;

This item has no description.

Published property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;

This item has no description.

Published property Parts: TPipeParts read FParts write SetParts default [ppOutside];

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: Integer read FSlices write SetSlices default 16;

This item has no description.

Published property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;

This item has no description.

Published property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;

This item has no description.

Published property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.


GXSysHelp v.2.5: GXS.FBO

Unit GXS.FBO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • FMX.Dialogs
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.Context
  • GXS.State
  • GXS.Texture
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.MultisampleImage
  • GXS.Graphics
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxRenderbuffer |
Class TgxDepthRBO |
Class TgxStencilRBO |
Class TgxFrameBuffer |

Types

TgxStencilPrecision = (...);

Constants

MaxColorAttachments = 32;

Description

Types

TgxStencilPrecision = (...);

This item has no description.

Values
  • spDefault
  • sp1bit
  • sp4bits
  • sp8bits
  • sp16bits

Constants

MaxColorAttachments = 32;


GXSysHelp v.2.5: GXS.FBO: Class TgxRenderbuffer

Class TgxRenderbuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FBO

Declaration

type TgxRenderbuffer = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRenderbuffer

Overview

Fields

Private | FRenderbufferHandle: TgxRenderbufferHandle;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FStorageValid: Boolean;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function GetHandle: GLuint;
Public | procedure Bind;
Public | procedure Unbind;
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property Handle: GLuint read GetHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FRenderbufferHandle: TgxRenderbufferHandle;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FStorageValid: Boolean;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetHandle: GLuint;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure Unbind;

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property Handle: GLuint read GetHandle;

Handle to the OpenGL render buffer object. If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.FBO: Class TgxDepthRBO

Class TgxDepthRBO

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FBO

Declaration

type TgxDepthRBO = class(TgxRenderbuffer)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRenderbuffer
  • TgxDepthRBO

Overview

Fields

Private FDepthPrecision: TgxDepthPrecision;

Methods

Public | constructor Create;
Private | procedure SetDepthPrecision(const Value: TgxDepthPrecision);

Properties

Public property DepthPrecision: TgxDepthPrecision read FDepthPrecision write SetDepthPrecision;

Description

Fields

Private FDepthPrecision: TgxDepthPrecision;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private procedure SetDepthPrecision(const Value: TgxDepthPrecision);

This item has no description.

Properties

Public property DepthPrecision: TgxDepthPrecision read FDepthPrecision write SetDepthPrecision;


GXSysHelp v.2.5: GXS.FBO: Class TgxStencilRBO

Class TgxStencilRBO

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FBO

Declaration

type TgxStencilRBO = class(TgxRenderbuffer)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRenderbuffer
  • TgxStencilRBO

Overview

Fields

Private FStencilPrecision: TgxStencilPrecision;

Methods

Public | constructor Create;
Private | procedure SetStencilPrecision(const Value: TgxStencilPrecision);

Properties

Public property StencilPrecision: TgxStencilPrecision read FStencilPrecision write SetStencilPrecision;

Description

Fields

Private FStencilPrecision: TgxStencilPrecision;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private procedure SetStencilPrecision(const Value: TgxStencilPrecision);

This item has no description.

Properties

Public property StencilPrecision: TgxStencilPrecision read FStencilPrecision write SetStencilPrecision;


GXSysHelp v.2.5: GXS.FBO: Class TgxFrameBuffer

Class TgxFrameBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FBO

Declaration

type TgxFrameBuffer = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxFrameBuffer

Overview

Fields

Private | FFrameBufferHandle: TgxFramebufferHandle;
Private | FTarget: GLEnum;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FLayer: Integer;
Private | FLevel: Integer;
Private | FTextureMipmap: cardinal;
Private | FAttachedTexture: array[0..MaxColorAttachments - 1] of TgxTexture;
Private | FDepthTexture: TgxTexture;
Private | FDRBO: TgxDepthRBO;
Private | FSRBO: TgxStencilRBO;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetStringStatus(out clarification: string): TgxFramebufferStatus;
Private | function GetStatus: TgxFramebufferStatus;
Public | procedure AttachDepthBuffer(DepthBuffer: TgxDepthRBO); overload;
Public | procedure AttachDepthTexture(Texture: TgxTexture); overload;
Public | procedure AttachStencilBuffer(StencilBuffer: TgxStencilRBO); overload;
Public | procedure AttachTexture(n: Cardinal; Texture: TgxTexture); overload;
Public | procedure Bind;
Public | procedure DetachDepthBuffer;
Public | procedure DetachDepthTexture;
Public | procedure DetachStencilBuffer;
Public | procedure DetachTexture(n: Cardinal);
Public | procedure PostRender(const PostGenerateMipmap: Boolean);
Public | procedure PreRender;
Public | procedure Render(var rci: TgxRenderContextInfo; baseObject: TgxBaseSceneObject);
Public | procedure Unbind;
Private | procedure SetHeight(const Value: Integer);
Private | procedure SetLayer(const Value: Integer);
Private | procedure SetLevel(const Value: Integer);
Private | procedure SetWidth(const Value: Integer);

Properties

Public | property Handle: TgxFramebufferHandle read FFrameBufferHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Layer: Integer read FLayer write SetLayer;
Public | property Level: Integer read FLevel write SetLevel;
Public | property Status: TgxFramebufferStatus read GetStatus;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FFrameBufferHandle: TgxFramebufferHandle;

This item has no description.

Private FTarget: GLEnum;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FLayer: Integer;

This item has no description.

Private FLevel: Integer;

This item has no description.

Private FTextureMipmap: cardinal;

This item has no description.

Private FAttachedTexture: array[0..MaxColorAttachments - 1] of TgxTexture;

This item has no description.

Private FDepthTexture: TgxTexture;

This item has no description.

Private FDRBO: TgxDepthRBO;

This item has no description.

Private FSRBO: TgxStencilRBO;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetStringStatus(out clarification: string): TgxFramebufferStatus;

This item has no description.

Private function GetStatus: TgxFramebufferStatus;

This item has no description.

Public procedure AttachDepthBuffer(DepthBuffer: TgxDepthRBO); overload;

attaches a depth rbo to the fbo the depth buffer must have the same dimentions as the fbo

Public procedure AttachDepthTexture(Texture: TgxTexture); overload;

attaches a depth texture to the fbo the depth texture must have the same dimentions as the fbo

Public procedure AttachStencilBuffer(StencilBuffer: TgxStencilRBO); overload;

attaches a stencil rbo to the fbo the stencil buffer must have the same dimentions as the fbo

Public procedure AttachTexture(n: Cardinal; Texture: TgxTexture); overload;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure DetachDepthBuffer;

detaches depth attachment from the fbo

Public procedure DetachDepthTexture;

This item has no description.

Public procedure DetachStencilBuffer;

detaches stencil attachment from the fbo

Public procedure DetachTexture(n: Cardinal);

This item has no description.

Public procedure PostRender(const PostGenerateMipmap: Boolean);

This item has no description.

Public procedure PreRender;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo; baseObject: TgxBaseSceneObject);

This item has no description.

Public procedure Unbind;

This item has no description.

Private procedure SetHeight(const Value: Integer);

This item has no description.

Private procedure SetLayer(const Value: Integer);

This item has no description.

Private procedure SetLevel(const Value: Integer);

This item has no description.

Private procedure SetWidth(const Value: Integer);

This item has no description.

Properties

Public property Handle: TgxFramebufferHandle read FFrameBufferHandle;

This item has no description.

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Layer: Integer read FLayer write SetLayer;

This item has no description.

Public property Level: Integer read FLevel write SetLevel;

This item has no description.

Public property Status: TgxFramebufferStatus read GetStatus;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.FBORenderer

Unit GXS.FBORenderer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • FMX.Dialogs
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Texture
  • GXS.Context
  • GXS.FBO
  • GXS.Color
  • GXS.Material
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.PipelineTransform
  • GLScene.TextureFormat
  • GLScene.VectorTypes
  • GXS.MultisampleImage

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFBORenderer |

Types

TgxEnabledRenderBuffer = (...);
TgxEnabledRenderBuffers = set of TgxEnabledRenderBuffer;
TgxFBOClearOption = (...);
TgxFBOClearOptions = set of TgxFBOClearOption;
TgxFBOTargetVisibility = (...);
TgxTextureArray = array of TgxTexture;
TSetTextureTargetsEvent = procedure(Sender: TObject; var colorTexs: TgxTextureArray) of object;

Description

Types

TgxEnabledRenderBuffer = (...);

This item has no description.

Values
  • erbDepth
  • erbStencil
TgxEnabledRenderBuffers = set of TgxEnabledRenderBuffer;

This item has no description.

TgxFBOClearOption = (...);

This item has no description.

Values
  • coColorBufferClear
  • coDepthBufferClear
  • coStencilBufferClear
  • coUseBufferBackground
TgxFBOClearOptions = set of TgxFBOClearOption;

This item has no description.

TgxFBOTargetVisibility = (...);

This item has no description.

Values
  • tvDefault
  • tvFBOOnly
TgxTextureArray = array of TgxTexture;

This item has no description.

TSetTextureTargetsEvent = procedure(Sender: TObject; var colorTexs: TgxTextureArray) of object;


GXSysHelp v.2.5: GXS.FBORenderer: Class TgxFBORenderer

Class TgxFBORenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FBORenderer

Declaration

type TgxFBORenderer = class(TgxBaseSceneObject, IgxMaterialLibrarySupported)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxFBORenderer

Overview

Fields

Private | FFbo: TgxFrameBuffer;
Private | FDepthRBO: TgxDepthRBO;
Private | FStencilRBO: TgxStencilRBO;
Private | FColorAttachment: Integer;
Private | FRendering: Boolean;
Private | FHasColor: Boolean;
Private | FHasDepth: Boolean;
Private | FHasStencil: Boolean;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FColorTextureName: TgxLibMaterialName;
Private | FDepthTextureName: TgxLibMaterialName;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FForceTextureDimensions: Boolean;
Private | FStencilPrecision: TgxStencilPrecision;
Private | FRootObject: TgxBaseSceneObject;
Private | FRootVisible: Boolean;
Private | FCamera: TgxCamera;
Private | FEnabledRenderBuffers: TgxEnabledRenderBuffers;
Private | FTargetVisibility: TgxFBOTargetVisibility;
Private | FBeforeRender: TDirectRenderEvent;
Private | FPostInitialize: TNotifyEvent;
Private | FAfterRender: TDirectRenderEvent;
Private | FPreInitialize: TNotifyEvent;
Private | FBackgroundColor: TgxColor;
Private | FClearOptions: TgxFBOClearOptions;
Private | FAspect: Single;
Private | FSceneScaleFactor: Single;
Private | FUseLibraryAsMultiTarget: Boolean;
Private | FPostGenerateMipmap: Boolean;
Private | FMaxSize: Integer;
Private | FMaxAttachment: Integer;
Private | FStoreCamera: array [0 .. 2] of TVector4f;
Private | FOnSetTextureTargets: TSetTextureTargetsEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetLayer: Integer;
Private | function GetLevel: Integer;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetViewport: TRectangle;
Private | function StoreAspect: Boolean;
Private | function StoreSceneScaleFactor: Boolean;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;
Private | procedure SetBackgroundColor(const Value: TgxColor);
Private | procedure SetCamera(const Value: TgxCamera);
Private | procedure SetColorTextureName(const Value: TgxLibMaterialName);
Private | procedure SetDepthTextureName(const Value: TgxLibMaterialName);
Private | procedure SetEnabledRenderBuffers(const Value: TgxEnabledRenderBuffers);
Private | procedure SetForceTextureDimentions(const Value: Boolean);
Private | procedure SetHeight(Value: Integer);
Private | procedure SetLayer(const Value: Integer);
Private | procedure SetLevel(const Value: Integer);
Private | procedure SetMaterialLibrary(const Value: TgxAbstractMaterialLibrary);
Private | procedure SetPostGenerateMipmap(const Value: Boolean);
Private | procedure SetRootObject(const Value: TgxBaseSceneObject);
Private | procedure SetStencilPrecision(const Value: TgxStencilPrecision);
Private | procedure SetTargetVisibility(const Value: TgxFBOTargetVisibility);
Private | procedure SetUseLibraryAsMultiTarget(Value: Boolean);
Private | procedure SetWidth(Value: Integer);

Properties

Published | property Active: Boolean read GetVisible write SetVisible default True;
Published | property AfterRender: TDirectRenderEvent read FAfterRender write FAfterRender;
Published | property Aspect: Single read FAspect write FAspect stored StoreAspect;
Published | property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;
Published | property BeforeRender: TDirectRenderEvent read FBeforeRender write FBeforeRender;
Published | property Camera: TgxCamera read FCamera write SetCamera;
Published | property ClearOptions: TgxFBOClearOptions read FClearOptions write FClearOptions;
Published | property ColorTextureName: TgxLibMaterialName read FColorTextureName write SetColorTextureName;
Published | property DepthTextureName: TgxLibMaterialName read FDepthTextureName write SetDepthTextureName;
Published | property EnabledRenderBuffers: TgxEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;
Published | property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;
Published | property Height: Integer read FHeight write SetHeight default 256;
Public | property Layer: Integer read GetLayer write SetLayer;
Public | property Level: Integer read GetLevel write SetLevel;
Published | property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Published | property OnSetTextureTargets: TSetTextureTargetsEvent read FOnSetTextureTargets write FOnSetTextureTargets;
Published | property PickableTarget: Boolean read GetPickable write SetPickable default False;
Published | property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;
Published | property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;
Published | property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;
Published | property RootObject: TgxBaseSceneObject read FRootObject write SetRootObject;
Published | property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;
Published | property StencilPrecision: TgxStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;
Published | property TargetVisibility: TgxFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;
Published | property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;
Published | property Width: Integer read FWidth write SetWidth default 256;

Description

Fields

Private FFbo: TgxFrameBuffer;

This item has no description.

Private FDepthRBO: TgxDepthRBO;

This item has no description.

Private FStencilRBO: TgxStencilRBO;

This item has no description.

Private FColorAttachment: Integer;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FHasColor: Boolean;

This item has no description.

Private FHasDepth: Boolean;

This item has no description.

Private FHasStencil: Boolean;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FColorTextureName: TgxLibMaterialName;

This item has no description.

Private FDepthTextureName: TgxLibMaterialName;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FForceTextureDimensions: Boolean;

This item has no description.

Private FStencilPrecision: TgxStencilPrecision;

This item has no description.

Private FRootObject: TgxBaseSceneObject;

This item has no description.

Private FRootVisible: Boolean;

This item has no description.

Private FCamera: TgxCamera;

This item has no description.

Private FEnabledRenderBuffers: TgxEnabledRenderBuffers;

This item has no description.

Private FTargetVisibility: TgxFBOTargetVisibility;

This item has no description.

Private FBeforeRender: TDirectRenderEvent;

This item has no description.

Private FPostInitialize: TNotifyEvent;

This item has no description.

Private FAfterRender: TDirectRenderEvent;

This item has no description.

Private FPreInitialize: TNotifyEvent;

This item has no description.

Private FBackgroundColor: TgxColor;

This item has no description.

Private FClearOptions: TgxFBOClearOptions;

This item has no description.

Private FAspect: Single;

This item has no description.

Private FSceneScaleFactor: Single;

This item has no description.

Private FUseLibraryAsMultiTarget: Boolean;

This item has no description.

Private FPostGenerateMipmap: Boolean;

This item has no description.

Private FMaxSize: Integer;

This item has no description.

Private FMaxAttachment: Integer;

This item has no description.

Private FStoreCamera: array [0 .. 2] of TVector4f;

This item has no description.

Private FOnSetTextureTargets: TSetTextureTargetsEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetLayer: Integer;

This item has no description.

Private function GetLevel: Integer;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Private function GetViewport: TRectangle;

This item has no description.

Private function StoreAspect: Boolean;

This item has no description.

Private function StoreSceneScaleFactor: Boolean;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetBackgroundColor(const Value: TgxColor);

This item has no description.

Private procedure SetCamera(const Value: TgxCamera);

This item has no description.

Private procedure SetColorTextureName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetDepthTextureName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetEnabledRenderBuffers(const Value: TgxEnabledRenderBuffers);

This item has no description.

Private procedure SetForceTextureDimentions(const Value: Boolean);

This item has no description.

Private procedure SetHeight(Value: Integer);

This item has no description.

Private procedure SetLayer(const Value: Integer);

This item has no description.

Private procedure SetLevel(const Value: Integer);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxAbstractMaterialLibrary);

This item has no description.

Private procedure SetPostGenerateMipmap(const Value: Boolean);

This item has no description.

Private procedure SetRootObject(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetStencilPrecision(const Value: TgxStencilPrecision);

This item has no description.

Private procedure SetTargetVisibility(const Value: TgxFBOTargetVisibility);

This item has no description.

Private procedure SetUseLibraryAsMultiTarget(Value: Boolean);

This item has no description.

Private procedure SetWidth(Value: Integer);

This item has no description.

Properties

Published property Active: Boolean read GetVisible write SetVisible default True;

This item has no description.

Published property AfterRender: TDirectRenderEvent read FAfterRender write FAfterRender;

called after the rendering to the FBO

Published property Aspect: Single read FAspect write FAspect stored StoreAspect;

This item has no description.

Published property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;

This item has no description.

Published property BeforeRender: TDirectRenderEvent read FBeforeRender write FBeforeRender;

called before rendering to the FBO

Published property Camera: TgxCamera read FCamera write SetCamera;

camera used for rendering to the FBO if not assigned, use the active view's camera

Published property ClearOptions: TgxFBOClearOptions read FClearOptions write FClearOptions;

This item has no description.

Published property ColorTextureName: TgxLibMaterialName read FColorTextureName write SetColorTextureName;

This item has no description.

Published property DepthTextureName: TgxLibMaterialName read FDepthTextureName write SetDepthTextureName;

This item has no description.

Published property EnabledRenderBuffers: TgxEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;

Enables the use of a render buffer if a texture is not assigned

Published property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;

force texture dimensions when initializing only works with TgxBlankImage and GLfloatDataImage, otherwise does nothing

Published property Height: Integer read FHeight write SetHeight default 256;

This item has no description.

Public property Layer: Integer read GetLayer write SetLayer;

Layer (also cube map face) is activated only on the volume textures, texture array and cube map. You can select the layer during the drawing to.

Public property Level: Integer read GetLevel write SetLevel;

Mipmap Level where will be rendering

Published property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property OnSetTextureTargets: TSetTextureTargetsEvent read FOnSetTextureTargets write FOnSetTextureTargets;

Allows multiTargeting to different texture sources instead of all coming from one single MatLib with UseLibraryAsMultiTarget. OnSetTextureTargets overrides the other method of setting target textures via the MaterialLibrary, ColorTextureName and DepthTextureName propertes

Published property PickableTarget: Boolean read GetPickable write SetPickable default False;

This item has no description.

Published property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;

Control mipmap generation after rendering texture must have MinFilter with mipmaping

Published property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;

Called after the FBO is initialized, but before any rendering the FBO is bound before calling this event

Published property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;

Called before the FBO is initialized the FBO is bound before calling this event

Published property RootObject: TgxBaseSceneObject read FRootObject write SetRootObject;

root object used when rendering to the FBO if not assigned, uses itself as root and renders the child objects to the FBO

Published property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;

adjust the scene scale of the camera so that the rendering becomes independent of the width of the fbo renderer 0 = disabled

Published property StencilPrecision: TgxStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;

use stencil buffer

Published property TargetVisibility: TgxFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;

determines if target is rendered to FBO only or rendered normally in FBO only mode, if RootObject is assigned, the RootObject's Visible flag is modified in default mode, if RootObject is not assigned, children are rendered normally after being rendered to the FBO

Published property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;

This item has no description.

Published property Width: Integer read FWidth write SetWidth default 256;


GXSysHelp v.2.5: GXS.Feedback

Unit GXS.Feedback

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Scene
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.State
  • GLScene.PipelineTransform
  • GXS.MeshUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFeedback |

Types

TFeedbackMode = (...);

Description

Types

TFeedbackMode = (...);

This item has no description.

Values
  • fm2D
  • fm3D
  • fm3DColor
  • fm3DColorTexture
  • fm4DColorTexture


GXSysHelp v.2.5: GXS.Feedback: Class TgxFeedback

Class TgxFeedback

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Feedback

Declaration

type TgxFeedback = class(TgxBaseSceneObject)

Description

An object encapsulating the feedback rendering mode.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxFeedback

Overview

Fields

Private | FActive: Boolean;
Private | FBuffer: TgxSingleList;
Private | FMaxBufferSize: Cardinal;
Private | FBuffered: Boolean;
Private | FCorrectionScaling: Single;
Private | FMode: TFeedbackMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildMeshFromBuffer( Vertices: TgxAffineVectorList = nil; Normals: TgxAffineVectorList = nil; Colors: TgxVectorList = nil; TexCoords: TgxAffineVectorList = nil; VertexIndices: TgxIntegerList = nil);
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Active: Boolean read FActive write FActive;
Public | property Buffer: TgxSingleList read FBuffer;
Public | property Buffered: Boolean read FBuffered;
Public | property CorrectionScaling: Single read FCorrectionScaling;
Published | property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;
Published | property Mode: TFeedbackMode read FMode write SetMode;
Published | property Visible;

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FBuffer: TgxSingleList;

This item has no description.

Private FMaxBufferSize: Cardinal;

This item has no description.

Private FBuffered: Boolean;

This item has no description.

Private FCorrectionScaling: Single;

This item has no description.

Private FMode: TFeedbackMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildMeshFromBuffer( Vertices: TgxAffineVectorList = nil; Normals: TgxAffineVectorList = nil; Colors: TgxVectorList = nil; TexCoords: TgxAffineVectorList = nil; VertexIndices: TgxIntegerList = nil);

Parse the feedback buffer for polygon data and build a mesh into the assigned lists.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive;

Toggles the feedback rendering

Public property Buffer: TgxSingleList read FBuffer;

The feedback buffer

Public property Buffered: Boolean read FBuffered;

True when there is data in the buffer ready for parsing

Public property CorrectionScaling: Single read FCorrectionScaling;

Vertex positions in the buffer needs to be scaled by CorrectionScaling to get correct coordinates.

Published property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;

Maximum size allocated for the feedback buffer

Published property Mode: TFeedbackMode read FMode write SetMode;

The type of data that is collected in the feedback buffer

Published property Visible;


GXSysHelp v.2.5: GXS.File3DS

Unit GXS.File3DS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.Strings
  • GLScene.OpenGL4
  • GXS.Scene
  • GXS.Objects
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.PersistentClasses
  • GXS.File3DSSceneObjects
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.RenderContextInfo
  • GXS.Material
  • Formats.m3DS
  • Formats.m3DSTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLFile3DS |
Packed Record TgxFile3DSAnimationData |
Class TgxFile3DSAnimationKeys |
Class TgxFile3DSScaleAnimationKeys |
Class TgxFile3DSRotationAnimationKeys |
Class TgxFile3DSPositionAnimationKeys |
Class TgxFile3DSColorAnimationKeys |
Class TTgxFile3DSPositionAnimationKeys |
Class TgxFile3DSSpotLightCutOffAnimationKeys |
Class TgxFile3DSLightHotSpotAnimationKeys |
Class TgxFile3DSRollAnimationKeys |
Class TgxFile3DSAnimationKeyList |
Class TgxFile3DSDummyObject |
Class TgxFile3DSMeshObject |
Class TgxFile3DSOmniLightObject |
Class TgxFile3DSSpotLightObject |
Class TgxFile3DSCameraObject |
Class Tgx3DSVectorFile |

Types

TgxFile3DSAnimKeysClassType = (...);

Variables

vFile3DS_UseTextureEx: boolean = False;
vFile3DS_EnableAnimation: boolean = False;
vFile3DS_FixDefaultUpAxisY: boolean = False;
vFile3DS_LoadedStaticFrame: integer = -1;

Description

Types

TgxFile3DSAnimKeysClassType = (...);

Used only for serialization. There probably is a more efficient way to do it.

Values
  • ctScale
  • ctRot
  • ctPos
  • ctCol
  • ctTPos
  • ctFall
  • ctHot
  • ctRoll

Variables

vFile3DS_UseTextureEx: boolean = False;

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vFile3DS_EnableAnimation: boolean = False;

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TgxFreeForm.AutoCentering does now work correctly. - TgxMeshObject.vertices return values different from TgxMeshObject.ExtractTriangles()

vFile3DS_FixDefaultUpAxisY: boolean = False;

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vFile3DS_EnableAnimation = true)

vFile3DS_LoadedStaticFrame: integer = -1;

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.


GXSysHelp v.2.5: GXS.File3DS: Class EGLFile3DS

Class EGLFile3DS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type EGLFile3DS = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLFile3DS


GXSysHelp v.2.5: GXS.File3DS: Packed Record TgxFile3DSAnimationData

Packed Record TgxFile3DSAnimationData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSAnimationData = packed record

Description

A record that holds all the information that is used during 3ds animation.

Overview

Fields

Public | ModelMatrix: TMatrix4f;
Public | Color: TVector4f;
Public | TargetPos: TAffineVector;
Public | SpotLightCutOff: single;
Public | HotSpot: single;
Public | Roll: single;

Description

Fields

Public ModelMatrix: TMatrix4f;

This item has no description.

Public Color: TVector4f;

This item has no description.

Public TargetPos: TAffineVector;

Omni Light.

Public SpotLightCutOff: single;

Spot Light.

Public HotSpot: single;

This item has no description.

Public Roll: single;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSAnimationKeys

Class TgxFile3DSAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSAnimationKeys = class(TgxPersistentObject)

Description

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys

Overview

Fields

Private | FNumKeys: integer;
Private | FKeys: array of TKeyHeader3DS;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;
Private | procedure InterpolateFrame(var I: integer; var w: real; const AFrame: real);

Description

Fields

Private FNumKeys: integer;

This item has no description.

Private FKeys: array of TKeyHeader3DS;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); virtual; abstract;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;

This item has no description.

Private procedure InterpolateFrame(var I: integer; var w: real; const AFrame: real);


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSScaleAnimationKeys

Class TgxFile3DSScaleAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSScaleAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSScaleAnimationKeys

Overview

Fields

Private FScale: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FScale: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSRotationAnimationKeys

Class TgxFile3DSRotationAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSRotationAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSRotationAnimationKeys

Overview

Fields

Private FRot: array of TKFRotKey3DS;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FRot: array of TKFRotKey3DS;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSPositionAnimationKeys

Class TgxFile3DSPositionAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSPositionAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSPositionAnimationKeys

Overview

Fields

Private FPos: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FPos: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSColorAnimationKeys

Class TgxFile3DSColorAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSColorAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSColorAnimationKeys

Overview

Fields

Private FCol: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FCol: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TTgxFile3DSPositionAnimationKeys

Class TTgxFile3DSPositionAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TTgxFile3DSPositionAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TTgxFile3DSPositionAnimationKeys

Overview

Fields

Private FTPos: array of TAffineVector;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FTPos: array of TAffineVector;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSSpotLightCutOffAnimationKeys

Class TgxFile3DSSpotLightCutOffAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSSpotLightCutOffAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSSpotLightCutOffAnimationKeys

Overview

Fields

Private FFall: array of single;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FFall: array of single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSLightHotSpotAnimationKeys

Class TgxFile3DSLightHotSpotAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSLightHotSpotAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSLightHotSpotAnimationKeys

Overview

Fields

Private FHot: array of single;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FHot: array of single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSRollAnimationKeys

Class TgxFile3DSRollAnimationKeys

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSRollAnimationKeys = class(TgxFile3DSAnimationKeys)

Description

This item has no description. Showing description inherited from TgxFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeys
  • TgxFile3DSRollAnimationKeys

Overview

Fields

Private FRoll: array of single;

Methods

Public | procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FRoll: array of single;

This item has no description.

Methods

Public procedure Apply(var DataTransf: TgxFile3DSAnimationData; const AFrame: real); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSAnimationKeyList

Class TgxFile3DSAnimationKeyList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSAnimationKeyList = class(TgxPersistentObject)

Description

This item has no description.

Hierarchy

  • TgxPersistentObject
  • TgxFile3DSAnimationKeyList

Overview

Fields

Private FAnimKeysList: array of TgxFile3DSAnimationKeys;

Methods

Public | destructor Destroy; override;
Public | procedure AddKeys(const AItem: TgxFile3DSAnimationKeys);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearKeys;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FAnimKeysList: array of TgxFile3DSAnimationKeys;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure AddKeys(const AItem: TgxFile3DSAnimationKeys);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ClearKeys;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSDummyObject

Class TgxFile3DSDummyObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSDummyObject = class(TgxMorphableMeshObject)

Description

A 3ds-specific TgxMorphableMeshObject.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxFile3DSDummyObject

Overview

Fields

Private | FAnimList: TgxFile3DSAnimationKeyList;
Private | FAnimData: Pointer;
Private | FRefTranf: TgxFile3DSAnimationData;
Private | FAnimTransf: TgxFile3DSAnimationData;
Private | FParent: TgxFile3DSDummyObject;
Private | FParentName: String64;
Private | FStatic: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GetExtents(out min, max: TAffineVector); override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: integer; lerpFactor: single); override;
Public | procedure LoadAnimation(const AData: Pointer); virtual;
Public | procedure MorphTo(morphTargetIndex: integer); override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); virtual;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Properties

Public | property AnimList: TgxFile3DSAnimationKeyList read FAnimList;
Public | property Parent: TgxFile3DSDummyObject read FParent write FParent;
Public | property RefrenceTransf: TgxFile3DSAnimationData read FRefTranf write FRefTranf;

Description

Fields

Private FAnimList: TgxFile3DSAnimationKeyList;

This item has no description.

Private FAnimData: Pointer;

This item has no description.

Private FRefTranf: TgxFile3DSAnimationData;

This item has no description.

Private FAnimTransf: TgxFile3DSAnimationData;

This item has no description.

Private FParent: TgxFile3DSDummyObject;

This item has no description.

Private FParentName: String64;

This item has no description.

Private FStatic: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.ExtractTriangles.

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector); override;

This item has no description. Showing description inherited from TgxMeshObject.GetExtents.

The extents of the object (min and max coordinates)

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: integer; lerpFactor: single); override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); virtual;

Static tag used in BuildList to not apply animation matrix

Public procedure MorphTo(morphTargetIndex: integer); override;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); virtual;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property AnimList: TgxFile3DSAnimationKeyList read FAnimList;

This item has no description.

Public property Parent: TgxFile3DSDummyObject read FParent write FParent;

This item has no description.

Public property RefrenceTransf: TgxFile3DSAnimationData read FRefTranf write FRefTranf;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSMeshObject

Class TgxFile3DSMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSMeshObject = class(TgxFile3DSDummyObject)

Description

A 3ds-specific mesh object.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxFile3DSDummyObject
  • TgxFile3DSMeshObject

Overview

Methods

Public | procedure BuildList(var ARci: TgxRenderContextInfo); override;
Public | procedure LoadAnimation(const AData: Pointer); override;

Description

Methods

Public procedure BuildList(var ARci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TgxFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSOmniLightObject

Class TgxFile3DSOmniLightObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSOmniLightObject = class(TgxFile3DSDummyObject)

Description

A 3ds-specific omni light.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxFile3DSDummyObject
  • TgxFile3DSOmniLightObject

Overview

Fields

Private | FLightSrc: TgxFile3DSLight;
Private | FLightSrcName: String64;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TgxBaseMesh; const AData: PLight3DS); virtual;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FLightSrc: TgxFile3DSLight;

This item has no description.

Private FLightSrcName: String64;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TgxFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(const AOwner: TgxBaseMesh; const AData: PLight3DS); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSSpotLightObject

Class TgxFile3DSSpotLightObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSSpotLightObject = class(TgxFile3DSOmniLightObject)

Description

A 3ds-specific spot light.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxFile3DSDummyObject
  • TgxFile3DSOmniLightObject
  • TgxFile3DSSpotLightObject

Overview

Methods

Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TgxBaseMesh; const AData: PLight3DS); override;
Public | procedure SetFrame(const AFrame: real); override;

Description

Methods

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TgxFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(const AOwner: TgxBaseMesh; const AData: PLight3DS); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;


GXSysHelp v.2.5: GXS.File3DS: Class TgxFile3DSCameraObject

Class TgxFile3DSCameraObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type TgxFile3DSCameraObject = class(TgxFile3DSDummyObject)

Description

A 3ds-specific camera.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxFile3DSDummyObject
  • TgxFile3DSCameraObject

Overview

Fields

Private | FTargetObj: TgxDummyCube;
Private | FCameraSrc: TgxFile3DSCamera;
Private | FCameraSrcName: String64;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(Owner: TgxBaseMesh; AData: PCamera3DS);
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Description

Fields

Private FTargetObj: TgxDummyCube;

This item has no description.

Private FCameraSrc: TgxFile3DSCamera;

This item has no description.

Private FCameraSrcName: String64;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadAnimation(const AData: Pointer); override;

This item has no description. Showing description inherited from TgxFile3DSDummyObject.LoadAnimation.

Static tag used in BuildList to not apply animation matrix

Public procedure LoadData(Owner: TgxBaseMesh; AData: PCamera3DS);

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure SetFrame(const AFrame: real); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;


GXSysHelp v.2.5: GXS.File3DS: Class Tgx3DSVectorFile

Class Tgx3DSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DS

Declaration

type Tgx3DSVectorFile = class(TgxVectorFile)

Description

The 3DStudio vector file. A 3DS file may contain material information and require textures when loading.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • Tgx3DSVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.File3DSSceneObjects

Unit GXS.File3DSSceneObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Graphic Scene Engine, http://glscene.org

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Scene
  • GXS.VectorFileObjects
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFile3DSLight |
Class TgxFile3DSCamera |
Class TgxFile3DSActor |
Class TgxFile3DSFreeForm |

Variables

vFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;

Description

Variables

vFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;


GXSysHelp v.2.5: GXS.File3DSSceneObjects: Class TgxFile3DSLight

Class TgxFile3DSLight

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DSSceneObjects

Declaration

type TgxFile3DSLight = class(TgxLightSource)

Description

This item has no description. Showing description inherited from TgxLightSource.

Standard light source. The standard light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TgxScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxLightSource
  • TgxFile3DSLight

Overview

Fields

Private | FTargetPos: TgxCoordinates;
Private | FHotSpot: Single;
Private | FMultipler: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property HotSpot: Single read FHotSpot write FHotSpot;
Published | property Multipler: Single read FMultipler write FMultipler;
Published | property SpotTargetPos: TgxCoordinates read FTargetPos;

Description

Fields

Private FTargetPos: TgxCoordinates;

This item has no description.

Private FHotSpot: Single;

This item has no description.

Private FMultipler: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property HotSpot: Single read FHotSpot write FHotSpot;

This item has no description.

Published property Multipler: Single read FMultipler write FMultipler;

This item has no description.

Published property SpotTargetPos: TgxCoordinates read FTargetPos;


GXSysHelp v.2.5: GXS.File3DSSceneObjects: Class TgxFile3DSCamera

Class TgxFile3DSCamera

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DSSceneObjects

Declaration

type TgxFile3DSCamera = class(TgxCamera)

Description

This item has no description. Showing description inherited from TgxCamera.

Camera object. This object is commonly referred by TgxSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCamera
  • TgxFile3DSCamera

Overview

Fields

Private | FTargetPos: TgxCoordinates;
Private | FQuadCyl: array[0..1] of GLUquadricObj;
Private | FQuadDisk: array[0..1] of GLUquadricObj;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property CameraTargetPos: TgxCoordinates read FTargetPos;
Published | property RollAngle;

Description

Fields

Private FTargetPos: TgxCoordinates;

This item has no description.

Private FQuadCyl: array[0..1] of GLUquadricObj;

This item has no description.

Private FQuadDisk: array[0..1] of GLUquadricObj;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property CameraTargetPos: TgxCoordinates read FTargetPos;

This item has no description.

Published property RollAngle;


GXSysHelp v.2.5: GXS.File3DSSceneObjects: Class TgxFile3DSActor

Class TgxFile3DSActor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DSSceneObjects

Declaration

type TgxFile3DSActor = class(TgxActor)

Description

This item has no description. Showing description inherited from TgxActor.

Mesh class specialized in animated meshes. The TgxActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TgxAnimationControler components).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxActor
  • TgxFile3DSActor

Overview

Methods

Private | procedure ReadMesh(Stream: TStream);
Private | procedure WriteMesh(Stream: TStream);

Description

Methods

Private procedure ReadMesh(Stream: TStream);

This item has no description.

Private procedure WriteMesh(Stream: TStream);


GXSysHelp v.2.5: GXS.File3DSSceneObjects: Class TgxFile3DSFreeForm

Class TgxFile3DSFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.File3DSSceneObjects

Declaration

type TgxFile3DSFreeForm = class(TgxFreeForm)

Description

This item has no description. Showing description inherited from TgxFreeForm.

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxFreeForm
  • TgxFile3DSFreeForm

Overview

Fields

Private | FTransfMat: TMatrix4f;
Private | FScaleMat: TMatrix4f;
Private | ParentMatrix: TMatrix4f;
Private | FS_Rot3DS: TgxCoordinates4;
Private | FRot3DS: TgxCoordinates4;
Private | FScale3DS: TgxCoordinates4;
Public | FRefMat: TMatrix4f;

Methods

Public | constructor Create(AOWner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function BarycenterAbsolutePosition: TVector4f; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;
Private | procedure ReadMesh(Stream: TStream);
Private | procedure WriteMesh(Stream: TStream);

Properties

Published | property Rot3DS: TgxCoordinates4 read FRot3DS;
Published | property Scale3DS: TgxCoordinates4 read FScale3DS;
Published | property S_Rot3DS: TgxCoordinates4 read FS_Rot3DS;

Description

Fields

Private FTransfMat: TMatrix4f;

This item has no description.

Private FScaleMat: TMatrix4f;

This item has no description.

Private ParentMatrix: TMatrix4f;

This item has no description.

Private FS_Rot3DS: TgxCoordinates4;

This item has no description.

Private FRot3DS: TgxCoordinates4;

This item has no description.

Private FScale3DS: TgxCoordinates4;

This item has no description.

Public FRefMat: TMatrix4f;

This item has no description.

Methods

Public constructor Create(AOWner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Private procedure ReadMesh(Stream: TStream);

This item has no description.

Private procedure WriteMesh(Stream: TStream);

This item has no description.

Properties

Published property Rot3DS: TgxCoordinates4 read FRot3DS;

This item has no description.

Published property Scale3DS: TgxCoordinates4 read FScale3DS;

This item has no description.

Published property S_Rot3DS: TgxCoordinates4 read FS_Rot3DS;


GXSysHelp v.2.5: GXS.FileASE

Unit GXS.FileASE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Texture
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxASEFaceTexure |
Record TgxASEFaceTexureChannels |
Record TgxASESmoothingGroups |
Class TgxASEFace |
Class TgxASEFaceList |
Class TgxASEMeshObject |
Record TgxASEMaterialTextureMap |
Record TgxASEMaterialTextureMaps |
Record TgxASESubMaterial |
Record TgxASESubMaterialList |
Class TgxASEMaterial |
Class TgxASEMaterialList |
Class TgxASEVectorFile |

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);
procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

Types

TASETextureMap = (...);

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;
GL_ASE_MAX_SUBMATERIALS = 5;
GL_ASE_MAX_SMOOTH_GROUPS = 5;
GL_ASE_MAX_TEXTURE_MAPS = 12;

Description

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

Use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map

procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

This item has no description.

Types

TASETextureMap = (...);

This item has no description.

Values
  • tmGeneric
  • tmAmbient
  • tmDiffuse
  • tmSpecular
  • tmShine
  • tmShinestrength
  • tmSelfillum
  • tmOpacity
  • tmFiltercolor
  • tmBump
  • tmReflect
  • tmRefract

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;

This item has no description.

GL_ASE_MAX_SUBMATERIALS = 5;

maximum texture channels

GL_ASE_MAX_SMOOTH_GROUPS = 5;

maximum material submaterials

GL_ASE_MAX_TEXTURE_MAPS = 12;

maximum smoothing groups


GXSysHelp v.2.5: GXS.FileASE: Record TgxASEFaceTexure

Record TgxASEFaceTexure

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEFaceTexure = record

Description

maximum texture maps face texture channel indices

Overview

Fields

Public | Idx0: Integer;
Public | Idx1: Integer;
Public | Idx2: Integer;

Description

Fields

Public Idx0: Integer;

This item has no description.

Public Idx1: Integer;

This item has no description.

Public Idx2: Integer;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASEFaceTexureChannels

Record TgxASEFaceTexureChannels

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEFaceTexureChannels = record

Description

face texture channels

Overview

Fields

Public | Count: Integer;
Public | ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TgxASEFaceTexure;

Description

Fields

Public Count: Integer;

This item has no description.

Public ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TgxASEFaceTexure;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASESmoothingGroups

Record TgxASESmoothingGroups

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASESmoothingGroups = record

Description

This item has no description.

Overview

Fields

Public | Count: Integer;
Public | Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;

Description

Fields

Public Count: Integer;

This item has no description.

Public Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEFace

Class TgxASEFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEFace = class(TObject)

Description

ASE mesh face

Hierarchy

  • TObject
  • TgxASEFace

Overview

Fields

Private | FV: array [0..2] of Integer;
Private | FNormal: TAffineVector;
Private | FN: array [0..2] of TAffineVector;
Private | FSmoothing: TgxASESmoothingGroups;
Private | FSubMaterialID: Integer;
Private | FTextChannels: TgxASEFaceTexureChannels;

Methods

Public constructor Create;

Properties

Public | property Normal: TAffineVector read FNormal;
Public | property Normal1: TAffineVector read FN[0];
Public | property Normal2: TAffineVector read FN[1];
Public | property Normal3: TAffineVector read FN[2];
Public | property Smoothing: TgxASESmoothingGroups read FSmoothing;
Public | property SubMaterialID: Integer read FSubMaterialID;
Public | property TextChannels: TgxASEFaceTexureChannels read FTextChannels;
Public | property VertIdx1: Integer read FV[0];
Public | property VertIdx2: Integer read FV[1];
Public | property VertIdx3: Integer read FV[2];

Description

Fields

Private FV: array [0..2] of Integer;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Private FN: array [0..2] of TAffineVector;

This item has no description.

Private FSmoothing: TgxASESmoothingGroups;

This item has no description.

Private FSubMaterialID: Integer;

This item has no description.

Private FTextChannels: TgxASEFaceTexureChannels;

submaterial ID

Methods

Public constructor Create;

This item has no description.

Properties

Public property Normal: TAffineVector read FNormal;

vertex 2 index

Public property Normal1: TAffineVector read FN[0];

face normal

Public property Normal2: TAffineVector read FN[1];

vertex 0 normal

Public property Normal3: TAffineVector read FN[2];

vertex 1 normal

Public property Smoothing: TgxASESmoothingGroups read FSmoothing;

channels texture coordinates

Public property SubMaterialID: Integer read FSubMaterialID;

smoothing group list

Public property TextChannels: TgxASEFaceTexureChannels read FTextChannels;

vertex 2 normal

Public property VertIdx1: Integer read FV[0];

This item has no description.

Public property VertIdx2: Integer read FV[1];

vertex 0 index

Public property VertIdx3: Integer read FV[2];

vertex 1 index


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEFaceList

Class TgxASEFaceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEFaceList = class(TObject)

Description

ASE mesh faces list

Hierarchy

  • TObject
  • TgxASEFaceList

Overview

Fields

Private FItems: TList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TgxASEFace;
Private | function GetCount: Integer;
Private | function GetFace(Index: Integer): TgxASEFace;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Face[Index: Integer]: TgxASEFace read GetFace;

Description

Fields

Private FItems: TList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add: TgxASEFace;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetFace(Index: Integer): TgxASEFace;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(aIndex: Integer);

This item has no description.

Properties

Public property Count: Integer read GetCount;

This item has no description.

Public property Face[Index: Integer]: TgxASEFace read GetFace;


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEMeshObject

Class TgxASEMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEMeshObject = class(TObject)

Description

ASE geom object, represents single mesh object; contains: vertices, faces, vertex indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into TgxMeshObject

Hierarchy

  • TObject
  • TgxASEMeshObject

Overview

Fields

Private | FFaces: TgxASEFaceList;
Private | FVertices: TgxAffineVectorList;
Private | FMatrix: TMatrix4f;
Private | FInheritedPosition: TAffineVector;
Private | FInheritedScale: TAffineVector;
Private | FInheritedRotation: TAffineVector;
Private | FRotationAngle: Single;
Private | FRotationAxis: TAffineVector;
Private | FPosition: TVector4f;
Private | FScale: TAffineVector;
Private | FScaleAxisAngle: Single;
Private | FScaleAxis: TAffineVector;
Private | FTexChannels: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TgxAffineVectorList;
Private | FTexChannelsCount: Integer;
Private | FHasNormals: Boolean;
Private | FMaterialID: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function AddTexChannel: TgxAffineVectorList;
Private | function GetTextChannel(Channel: Integer): TgxAffineVectorList;

Properties

Public | property Faces: TgxASEFaceList read FFaces;
Public | property HasNormals: Boolean read FHasNormals;
Public | property InheritedPosition: TAffineVector read FInheritedPosition;
Public | property InheritedRotation: TAffineVector read FInheritedRotation;
Public | property InheritedScale: TAffineVector read FInheritedScale;
Public | property MaterialID: Integer read FMaterialID;
Public | property Matrix: TMatrix4f read FMatrix;
Public | property Position: TVector4f read FPosition;
Public | property RotationAngle: Single read FRotationAngle;
Public | property RotationAxis: TAffineVector read FRotationAxis;
Public | property Scale: TAffineVector read FScale;
Public | property ScaleAxis: TAffineVector read FScaleAxis;
Public | property ScaleAxisAngle: Single read FScaleAxisAngle;
Public | property TextChannel[Channel: Integer]: TgxAffineVectorList read GetTextChannel;
Public | property TextChannelsCount: Integer read FTexChannelsCount;
Public | property Vertices: TgxAffineVectorList read FVertices;

Description

Fields

Private FFaces: TgxASEFaceList;

This item has no description.

Private FVertices: TgxAffineVectorList;

This item has no description.

Private FMatrix: TMatrix4f;

This item has no description.

Private FInheritedPosition: TAffineVector;

This item has no description.

Private FInheritedScale: TAffineVector;

This item has no description.

Private FInheritedRotation: TAffineVector;

This item has no description.

Private FRotationAngle: Single;

This item has no description.

Private FRotationAxis: TAffineVector;

This item has no description.

Private FPosition: TVector4f;

This item has no description.

Private FScale: TAffineVector;

This item has no description.

Private FScaleAxisAngle: Single;

This item has no description.

Private FScaleAxis: TAffineVector;

This item has no description.

Private FTexChannels: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TgxAffineVectorList;

This item has no description.

Private FTexChannelsCount: Integer;

This item has no description.

Private FHasNormals: Boolean;

This item has no description.

Private FMaterialID: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function AddTexChannel: TgxAffineVectorList;

This item has no description.

Private function GetTextChannel(Channel: Integer): TgxAffineVectorList;

This item has no description.

Properties

Public property Faces: TgxASEFaceList read FFaces;

This item has no description.

Public property HasNormals: Boolean read FHasNormals;

This item has no description.

Public property InheritedPosition: TAffineVector read FInheritedPosition;

This item has no description.

Public property InheritedRotation: TAffineVector read FInheritedRotation;

This item has no description.

Public property InheritedScale: TAffineVector read FInheritedScale;

This item has no description.

Public property MaterialID: Integer read FMaterialID;

This item has no description.

Public property Matrix: TMatrix4f read FMatrix;

This item has no description.

Public property Position: TVector4f read FPosition;

This item has no description.

Public property RotationAngle: Single read FRotationAngle;

This item has no description.

Public property RotationAxis: TAffineVector read FRotationAxis;

This item has no description.

Public property Scale: TAffineVector read FScale;

This item has no description.

Public property ScaleAxis: TAffineVector read FScaleAxis;

This item has no description.

Public property ScaleAxisAngle: Single read FScaleAxisAngle;

This item has no description.

Public property TextChannel[Channel: Integer]: TgxAffineVectorList read GetTextChannel;

This item has no description.

Public property TextChannelsCount: Integer read FTexChannelsCount;

This item has no description.

Public property Vertices: TgxAffineVectorList read FVertices;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASEMaterialTextureMap

Record TgxASEMaterialTextureMap

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEMaterialTextureMap = record

Description

This item has no description.

Overview

Fields

Public | Kind: string;
Public | Name: string;
Public | _Class: string;
Public | No: Integer;
Public | Amount: Single;
Public | Bitmap: string;
Public | UOffset: Single;
Public | VOffset: Single;
Public | UTiling: Single;
Public | VTiling: Single;
Public | Angle: Single;
Public | Blur: Single;
Public | BlurOffset: Single;
Public | NouseAmount: Single;
Public | NoiseSize: Single;
Public | NoiseLevel: Integer;
Public | NoisePhase: Single;

Description

Fields

Public Kind: string;

This item has no description.

Public Name: string;

This item has no description.

Public _Class: string;

This item has no description.

Public No: Integer;

This item has no description.

Public Amount: Single;

This item has no description.

Public Bitmap: string;

This item has no description.

Public UOffset: Single;

This item has no description.

Public VOffset: Single;

This item has no description.

Public UTiling: Single;

This item has no description.

Public VTiling: Single;

This item has no description.

Public Angle: Single;

This item has no description.

Public Blur: Single;

This item has no description.

Public BlurOffset: Single;

This item has no description.

Public NouseAmount: Single;

This item has no description.

Public NoiseSize: Single;

This item has no description.

Public NoiseLevel: Integer;

This item has no description.

Public NoisePhase: Single;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASEMaterialTextureMaps

Record TgxASEMaterialTextureMaps

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEMaterialTextureMaps = record

Description

This item has no description.

Overview

Fields

Public | Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TgxASEMaterialTextureMap;
Public | Count: Integer;

Description

Fields

Public Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TgxASEMaterialTextureMap;

This item has no description.

Public Count: Integer;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASESubMaterial

Record TgxASESubMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASESubMaterial = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | Ambient: TAffineVector;
Public | Diffuse: TAffineVector;
Public | Specular: TAffineVector;
Public | Shiness: Single;
Public | ShineStrength: Single;
Public | Transparency: Single;
Public | WireSize: Single;
Public | SelfIllumination: Single;
Public | TextureMaps: TgxASEMaterialTextureMaps;

Description

Fields

Public Name: string;

This item has no description.

Public Ambient: TAffineVector;

This item has no description.

Public Diffuse: TAffineVector;

This item has no description.

Public Specular: TAffineVector;

This item has no description.

Public Shiness: Single;

This item has no description.

Public ShineStrength: Single;

This item has no description.

Public Transparency: Single;

This item has no description.

Public WireSize: Single;

This item has no description.

Public SelfIllumination: Single;

This item has no description.

Public TextureMaps: TgxASEMaterialTextureMaps;


GXSysHelp v.2.5: GXS.FileASE: Record TgxASESubMaterialList

Record TgxASESubMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASESubMaterialList = record

Description

This item has no description.

Overview

Fields

Public | SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TgxASESubMaterial;
Public | Count: Integer;

Description

Fields

Public SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TgxASESubMaterial;

This item has no description.

Public Count: Integer;


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEMaterial

Class TgxASEMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEMaterial = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxASEMaterial

Overview

Fields

Private | FWireSize: Single;
Private | FShineStrength: Single;
Private | FShiness: Single;
Private | FTransparency: Single;
Private | FName: string;
Private | FDiffuse: TAffineVector;
Private | FAmbient: TAffineVector;
Private | FSpecular: TAffineVector;
Private | FSubMaterials: TgxASESubMaterialList;
Private | FTextureMaps: TgxASEMaterialTextureMaps;

Methods

Public constructor Create;

Properties

Public | property Ambient: TAffineVector read FAmbient;
Public | property Diffuse: TAffineVector read FDiffuse;
Public | property Name: string read FName;
Public | property Shiness: Single read FShiness;
Public | property ShineStrength: Single read FShineStrength;
Public | property Specular: TAffineVector read FSpecular;
Public | property SubMaterials: TgxASESubMaterialList read FSubMaterials;
Public | property TextureMaps: TgxASEMaterialTextureMaps read FTextureMaps;
Public | property Transparency: Single read FTransparency;
Public | property WireSize: Single read FWireSize;

Description

Fields

Private FWireSize: Single;

This item has no description.

Private FShineStrength: Single;

This item has no description.

Private FShiness: Single;

This item has no description.

Private FTransparency: Single;

This item has no description.

Private FName: string;

This item has no description.

Private FDiffuse: TAffineVector;

This item has no description.

Private FAmbient: TAffineVector;

This item has no description.

Private FSpecular: TAffineVector;

This item has no description.

Private FSubMaterials: TgxASESubMaterialList;

This item has no description.

Private FTextureMaps: TgxASEMaterialTextureMaps;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Properties

Public property Ambient: TAffineVector read FAmbient;

This item has no description.

Public property Diffuse: TAffineVector read FDiffuse;

This item has no description.

Public property Name: string read FName;

This item has no description.

Public property Shiness: Single read FShiness;

This item has no description.

Public property ShineStrength: Single read FShineStrength;

This item has no description.

Public property Specular: TAffineVector read FSpecular;

This item has no description.

Public property SubMaterials: TgxASESubMaterialList read FSubMaterials;

This item has no description.

Public property TextureMaps: TgxASEMaterialTextureMaps read FTextureMaps;

This item has no description.

Public property Transparency: Single read FTransparency;

This item has no description.

Public property WireSize: Single read FWireSize;


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEMaterialList

Class TgxASEMaterialList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEMaterialList = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxASEMaterialList

Overview

Fields

Private FItems: TList;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TgxASEMaterial;
Private | function GetCount: Integer;
Private | function GetMaterial(Index: Integer): TgxASEMaterial;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Material[Index: Integer]: TgxASEMaterial read GetMaterial;

Description

Fields

Private FItems: TList;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add: TgxASEMaterial;

This item has no description.

Private function GetCount: Integer;

This item has no description.

Private function GetMaterial(Index: Integer): TgxASEMaterial;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Delete(aIndex: Integer);

This item has no description.

Properties

Public property Count: Integer read GetCount;

This item has no description.

Public property Material[Index: Integer]: TgxASEMaterial read GetMaterial;


GXSysHelp v.2.5: GXS.FileASE: Class TgxASEVectorFile

Class TgxASEVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileASE

Declaration

type TgxASEVectorFile = class(TgxVectorFile)

Description

ASE vector file parser

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxASEVectorFile

Overview

Fields

Private | FStringData: TStringList;
Private | FHeader: string;
Private | FComment: string;
Private | FRECVShadow: Boolean;
Private | FCastShadow: Boolean;
Private | FMotionBlur: Boolean;
Private | FMaterialList: TgxASEMaterialList;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function Capabilities: TDataFileCapabilities; override;
Private | function CheckTextureMap(var aLineIndex: Integer; var aMaps: TgxASEMaterialTextureMaps): Boolean;
Private | function CheckUnknownData(var aLineIndex: Integer): Boolean;
Private | function ContainString(const aData, aString: string): Boolean;
Private | function GetDoubleValue(const aData: string): Double;
Private | function GetEndOfFirstValue(const aData: string): Integer;
Private | function GetFirstValue(aData: string): string;
Private | function GetPropCastShadow(const aData: string): Boolean;
Private | function GetPropMBlur(const aData: string): Boolean;
Private | function GetPropRECVShadow(const aData: string): Boolean;
Private | function GetStringValue(const aData: string): string;
Private | function GetTagOnData(const aData: string): Integer;
Private | function GetValue3D(const aData: string): TAffineVector;
Private | function GetValue4D(const aData: string; var Value0: Integer): TAffineVector;
Private | function IsEndOfSection(const aData: string): Boolean;
Private | function IsSectionBegingin(const aData: string): Boolean;
Public | procedure LoadFromStream(aStream: TStream); override;
Private | procedure Parse;
Private | procedure ParseFaceString(const aData: string; var Index, A, B, C, AB, BC, CA, MatID: Integer; var Smooth: TgxASESmoothingGroups);
Private | procedure ParseGeomObject(var aLineIndex: Integer);
Private | procedure ParseMappingChannel(var aLineIndex: Integer; aMesh: TgxASEMeshObject);
Private | procedure ParseMaterial(var aLineIndex: Integer; aMaterial: TgxASEMaterial);
Private | procedure ParseMaterialList(var aLineIndex: Integer);
Private | procedure ParseMeshFaces(var aLineIndex: Integer; aMesh: TgxASEMeshObject; FacesCount: Integer);
Private | procedure ParseMeshGeom(var aLineIndex: Integer; aMesh: TgxASEMeshObject);
Private | procedure ParseMeshNormals(var aLineIndex: Integer; aMesh: TgxASEMeshObject; FacesCount: Integer);
Private | procedure ParseMeshOptions(var aLineIndex: Integer; aMesh: TgxASEMeshObject);
Private | procedure ParseMeshTextureFaces(var aLineIndex: Integer; aMesh: TgxASEMeshObject; TextureFacesCount: Integer);
Private | procedure ParseMeshTextureVertices(var aLineIndex: Integer; aMesh: TgxASEMeshObject; TextureVerticesCount: Integer);
Private | procedure ParseMeshVertices(var aLineIndex: Integer; aMesh: TgxASEMeshObject; VerticesCount: Integer);
Private | procedure ParseScene(var aLineIndex: Integer);
Private | procedure ParseSubMaterial(var aLineIndex: Integer; aMaterial: TgxASEMaterial);
Private | procedure ParseTextureMap(var aLineIndex: Integer; var aMaps: TgxASEMaterialTextureMaps; const aMapKind: string);
Private | procedure SkipSection(var aLineIndex: Integer);

Properties

Public | property CastShadow: Boolean read FCastShadow;
Public | property Comment: string read FComment;
Public | property Header: string read FHeader;
Public | property MotionBlur: Boolean read FMotionBlur;
Public | property RECVShadow: Boolean read FRECVShadow;

Description

Fields

Private FStringData: TStringList;

This item has no description.

Private FHeader: string;

This item has no description.

Private FComment: string;

This item has no description.

Private FRECVShadow: Boolean;

This item has no description.

Private FCastShadow: Boolean;

This item has no description.

Private FMotionBlur: Boolean;

This item has no description.

Private FMaterialList: TgxASEMaterialList;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Private function CheckTextureMap(var aLineIndex: Integer; var aMaps: TgxASEMaterialTextureMaps): Boolean;

This item has no description.

Private function CheckUnknownData(var aLineIndex: Integer): Boolean;

This item has no description.

Private function ContainString(const aData, aString: string): Boolean;

This item has no description.

Private function GetDoubleValue(const aData: string): Double;

This item has no description.

Private function GetEndOfFirstValue(const aData: string): Integer;

This item has no description.

Private function GetFirstValue(aData: string): string;

This item has no description.

Private function GetPropCastShadow(const aData: string): Boolean;

This item has no description.

Private function GetPropMBlur(const aData: string): Boolean;

This item has no description.

Private function GetPropRECVShadow(const aData: string): Boolean;

This item has no description.

Private function GetStringValue(const aData: string): string;

This item has no description.

Private function GetTagOnData(const aData: string): Integer;

This item has no description.

Private function GetValue3D(const aData: string): TAffineVector;

This item has no description.

Private function GetValue4D(const aData: string; var Value0: Integer): TAffineVector;

This item has no description.

Private function IsEndOfSection(const aData: string): Boolean;

This item has no description.

Private function IsSectionBegingin(const aData: string): Boolean;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Private procedure Parse;

This item has no description.

Private procedure ParseFaceString(const aData: string; var Index, A, B, C, AB, BC, CA, MatID: Integer; var Smooth: TgxASESmoothingGroups);

This item has no description.

Private procedure ParseGeomObject(var aLineIndex: Integer);

This item has no description.

Private procedure ParseMappingChannel(var aLineIndex: Integer; aMesh: TgxASEMeshObject);

This item has no description.

Private procedure ParseMaterial(var aLineIndex: Integer; aMaterial: TgxASEMaterial);

This item has no description.

Private procedure ParseMaterialList(var aLineIndex: Integer);

This item has no description.

Private procedure ParseMeshFaces(var aLineIndex: Integer; aMesh: TgxASEMeshObject; FacesCount: Integer);

This item has no description.

Private procedure ParseMeshGeom(var aLineIndex: Integer; aMesh: TgxASEMeshObject);

This item has no description.

Private procedure ParseMeshNormals(var aLineIndex: Integer; aMesh: TgxASEMeshObject; FacesCount: Integer);

This item has no description.

Private procedure ParseMeshOptions(var aLineIndex: Integer; aMesh: TgxASEMeshObject);

This item has no description.

Private procedure ParseMeshTextureFaces(var aLineIndex: Integer; aMesh: TgxASEMeshObject; TextureFacesCount: Integer);

This item has no description.

Private procedure ParseMeshTextureVertices(var aLineIndex: Integer; aMesh: TgxASEMeshObject; TextureVerticesCount: Integer);

This item has no description.

Private procedure ParseMeshVertices(var aLineIndex: Integer; aMesh: TgxASEMeshObject; VerticesCount: Integer);

This item has no description.

Private procedure ParseScene(var aLineIndex: Integer);

This item has no description.

Private procedure ParseSubMaterial(var aLineIndex: Integer; aMaterial: TgxASEMaterial);

This item has no description.

Private procedure ParseTextureMap(var aLineIndex: Integer; var aMaps: TgxASEMaterialTextureMaps; const aMapKind: string);

This item has no description.

Private procedure SkipSection(var aLineIndex: Integer);

This item has no description.

Properties

Public property CastShadow: Boolean read FCastShadow;

This item has no description.

Public property Comment: string read FComment;

This item has no description.

Public property Header: string read FHeader;

This item has no description.

Public property MotionBlur: Boolean read FMotionBlur;

This item has no description.

Public property RECVShadow: Boolean read FRECVShadow;


GXSysHelp v.2.5: GXS.FileB3D

Unit GXS.FileB3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.TextureFormat
  • GXS.ApplicationFileIO
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.Material
  • Formats.B3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxB3DVectorFile |


GXSysHelp v.2.5: GXS.FileB3D: Class TgxB3DVectorFile

Class TgxB3DVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileB3D

Declaration

type TgxB3DVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxB3DVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(AStream: TStream); override;


GXSysHelp v.2.5: GXS.FileBMP

Unit GXS.FileBMP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBMPImage |


GXSysHelp v.2.5: GXS.FileBMP: Class TgxBMPImage

Class TgxBMPImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileBMP

Declaration

type TgxBMPImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxBMPImage

Overview

Fields

Private | FTopDown: Boolean;
Private | RedMask: LongWord;
Private | GreenMask: LongWord;
Private | BlueMask: LongWord;
Private | RedShift: ShortInt;
Private | GreenShift: ShortInt;
Private | BlueShift: ShortInt;
Private | FLineBuffer: PByteArray;
Private | FReadSize: Integer;
Private | FDeltaX: Integer;
Private | FDeltaY: Integer;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Private | function CountBits(Value: byte): shortint;
Private | function ExpandColor(Value: longword): TgxPixel32;
Private | function Monochrome(N: Integer): Integer;
Private | function Octochrome(N: Integer): Integer;
Private | function Quadrochrome(N: Integer): Integer;
Private | function ShiftCount(Mask: longword): shortint;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;
Private | procedure ExpandRLE4ScanLine(Row: Integer; Stream: TStream);
Private | procedure ExpandRLE8ScanLine(Row: Integer; Stream: TStream);

Description

Fields

Private FTopDown: Boolean;

This item has no description.

Private RedMask: LongWord;

This item has no description.

Private GreenMask: LongWord;

This item has no description.

Private BlueMask: LongWord;

This item has no description.

Private RedShift: ShortInt;

This item has no description.

Private GreenShift: ShortInt;

This item has no description.

Private BlueShift: ShortInt;

This item has no description.

Private FLineBuffer: PByteArray;

This item has no description.

Private FReadSize: Integer;

This item has no description.

Private FDeltaX: Integer;

This item has no description.

Private FDeltaY: Integer;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Private function CountBits(Value: byte): shortint;

This item has no description.

Private function ExpandColor(Value: longword): TgxPixel32;

This item has no description.

Private function Monochrome(N: Integer): Integer;

This item has no description.

Private function Octochrome(N: Integer): Integer;

This item has no description.

Private function Quadrochrome(N: Integer): Integer;

This item has no description.

Private function ShiftCount(Mask: longword): shortint;

This item has no description.

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;

This item has no description.

Private procedure ExpandRLE4ScanLine(Row: Integer; Stream: TStream);

This item has no description.

Private procedure ExpandRLE8ScanLine(Row: Integer; Stream: TStream);


GXSysHelp v.2.5: GXS.FileDAE

Unit GXS.FileDAE

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Quake2 MD2 vector file format implementation.

Uses

  • System.Classes
  • System.SysUtils
  • FMX.DAE.Importer
  • FMX.DAE.Model
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFileDAE |


GXSysHelp v.2.5: GXS.FileDAE: Class TgxFileDAE

Class TgxFileDAE

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileDAE

Declaration

type TgxFileDAE = class(TgxVectorFile)

Description

The DAE vector file (COLLADA actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxFileDAE

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GXSysHelp v.2.5: GXS.FileDDS

Unit GXS.FileDDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorGeometry
  • GLScene.RGBE
  • GLScene.Strings
  • GXS.ApplicationFileIO
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat
  • Formats.DXTC

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDDSImage |

Types

TgxDDSDetailLevels = (...);

Variables

vDDSDetailLevel: TgxDDSDetailLevels = ddsHighDet;

Description

Types

TgxDDSDetailLevels = (...);

This item has no description.

Values
  • ddsHighDet
  • ddsMediumDet
  • ddsLowDet

Variables

vDDSDetailLevel: TgxDDSDetailLevels = ddsHighDet;

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.


GXSysHelp v.2.5: GXS.FileDDS: Class TgxDDSImage

Class TgxDDSImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileDDS

Declaration

type TgxDDSImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxDDSImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;
Private | procedure flipSurface(chgData: PGLubyte; w, h, d: integer);

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;

This item has no description.

Private procedure flipSurface(chgData: PGLubyte; w, h, d: integer);


GXSysHelp v.2.5: GXS.FileDXF

Unit GXS.FileDXF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Scene
  • GXS.Texture
  • GXS.VectorFileObjects
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDXFVectorFile |


GXSysHelp v.2.5: GXS.FileDXF: Class TgxDXFVectorFile

Class TgxDXFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileDXF

Declaration

type TgxDXFVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxDXFVectorFile

Overview

Fields

Private | FSourceStream: TStream;
Private | FBuffer: String;
Private | FLineNo: Integer;
Private | FEof: Boolean;
Private | FBufPos: Integer;
Private | HasPushedCode: Boolean;
Private | PushedCode: Integer;
Private | FLayers: TStringList;
Private | FBlocks: TStringList;
Private | FLastpercentdone: BYTE;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FBuffer: String;

Load from this stream

Private FLineNo: Integer;

Buffer and current line

Private FEof: Boolean;

current Line number - for error messages

Private FBufPos: Integer;

Stream done?

Private HasPushedCode: Boolean;

Position in the buffer

Private PushedCode: Integer;

This item has no description.

Private FLayers: TStringList;

This item has no description.

Private FBlocks: TStringList;

This item has no description.

Private FLastpercentdone: BYTE;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileGL2

Unit GXS.FileGL2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Vector file object loading of Ghoul2 model and animation files.

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GXS.Material
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • Formatx.FileGL2

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGLMVectorFile |
Class TgxGLAVectorFile |

Variables

vGhoul2LevelOfDetail: Integer = 0;
vGhoul2MaxBonesPerVertex: Integer = 4;

Description

Variables

vGhoul2LevelOfDetail: Integer = 0;

This item has no description.

vGhoul2MaxBonesPerVertex: Integer = 4;

Highest detail level by default


GXSysHelp v.2.5: GXS.FileGL2: Class TgxGLMVectorFile

Class TgxGLMVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileGL2

Declaration

type TgxGLMVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxGLMVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GXSysHelp v.2.5: GXS.FileGL2: Class TgxGLAVectorFile

Class TgxGLAVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileGL2

Declaration

type TgxGLAVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxGLAVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GXSysHelp v.2.5: GXS.FileGLTF

Unit GXS.FileGLTF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.ApplicationFileIO
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • PasGLTF
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TglTFVectorFile |


GXSysHelp v.2.5: GXS.FileGLTF: Class TglTFVectorFile

Class TglTFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileGLTF

Declaration

type TglTFVectorFile = class(TgxVectorFile)

Description

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TglTFVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileGRD

Unit GXS.FileGRD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GXS.Graph

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGRDVectorFile |


GXSysHelp v.2.5: GXS.FileGRD: Class TgxGRDVectorFile

Class TgxGRDVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileGRD

Declaration

type TgxGRDVectorFile = class(TgxVectorFile)

Description

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxGRDVectorFile

Overview

Fields

Public | HeightField: TgxHeightField;
Public | Nodes: array of TSingleArray;
Private | StrVal: String;
Private | StrLine: String;
Private | MaxZ: Single;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Private | function ExtractWord(N: Integer; const S: string; const WordDelims: TSysCharSet): string;
Private | function WordPosition(const N: Integer; const S: string; const WordDelims: TSysCharSet): Integer;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Public HeightField: TgxHeightField;

This item has no description.

Public Nodes: array of TSingleArray;

This item has no description.

Private StrVal: String;

This item has no description.

Private StrLine: String;

This item has no description.

Private MaxZ: Single;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Private function ExtractWord(N: Integer; const S: string; const WordDelims: TSysCharSet): string;

This item has no description.

Private function WordPosition(const N: Integer; const S: string; const WordDelims: TSysCharSet): Integer;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileGTS

Unit GXS.FileGTS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGTSVectorFile |


GXSysHelp v.2.5: GXS.FileGTS: Class TgxGTSVectorFile

Class TgxGTSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileGTS

Declaration

type TgxGTSVectorFile = class(TgxVectorFile)

Description

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxGTSVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileHDR

Unit GXS.FileHDR

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.RGBE
  • GLScene.Strings
  • GXS.ApplicationFileIO
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxHDRImage |


GXSysHelp v.2.5: GXS.FileHDR: Class TgxHDRImage

Class TgxHDRImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileHDR

Declaration

type TgxHDRImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxHDRImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Private | function GetProgramType: Ansistring;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Private | procedure SetProgramType(aval: Ansistring);

Properties

Public | property Exposure: Single read fExposure;
Public | property Gamma: Single read fGamma;
Public | property ProgramType: Ansistring read GetProgramType write SetProgramType;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Private function GetProgramType: Ansistring;

This item has no description.

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Private procedure SetProgramType(aval: Ansistring);

This item has no description.

Properties

Public property Exposure: Single read fExposure;

This item has no description.

Public property Gamma: Single read fGamma;

This item has no description.

Public property ProgramType: Ansistring read GetProgramType write SetProgramType;


GXSysHelp v.2.5: GXS.FileJPEG

Unit GXS.FileJPEG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxJPEGImage |


GXSysHelp v.2.5: GXS.FileJPEG: Class TgxJPEGImage

Class TgxJPEGImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileJPEG

Declaration

type TgxJPEGImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxJPEGImage

Overview

Fields

Private | FAbortLoading: boolean;
Private | FDivScale: longword;
Private | FDither: boolean;
Private | FSmoothing: boolean;
Private | FProgressiveEncoding: boolean;

Methods

Public | constructor Create; override;
Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: Cardinal; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;
Private | procedure SetSmoothing(const AValue: boolean);

Properties

Public | property Dither: boolean read FDither write FDither;
Public | property DivScale: longword read FDivScale write FDivScale;
Public | property ProgressiveEncoding: boolean read FProgressiveEncoding;
Public | property Smoothing: boolean read FSmoothing write SetSmoothing;

Description

Fields

Private FAbortLoading: boolean;

This item has no description.

Private FDivScale: longword;

This item has no description.

Private FDither: boolean;

This item has no description.

Private FSmoothing: boolean;

This item has no description.

Private FProgressiveEncoding: boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: Cardinal; textureTarget: TglTextureTarget; const CurrentFormat: boolean; const intFormat: TglInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;

This item has no description.

Private procedure SetSmoothing(const AValue: boolean);

This item has no description.

Properties

Public property Dither: boolean read FDither write FDither;

This item has no description.

Public property DivScale: longword read FDivScale write FDivScale;

This item has no description.

Public property ProgressiveEncoding: boolean read FProgressiveEncoding;

This item has no description.

Public property Smoothing: boolean read FSmoothing write SetSmoothing;


GXSysHelp v.2.5: GXS.FileLMTS

Unit GXS.FileLMTS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Graphics
  • GLScene.VectorTypes
  • GXS.ApplicationFileIO
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GXS.VectorFileObjects
  • GXS.Graphics
  • GXS.Texture
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TLMTS_Header |
Record TLMTS_TexData |
Record TLMTS_Subset |
Record TLMTS_Vertex |
Record TLMTS |
Record TMaterialInfo |
Class TgxLMTSVectorFile |

Types

PLMTS = ˆTLMTS;
PLMTS_Header = ˆTLMTS_Header;
PLMTS_Subset = ˆTLMTS_Subset;
PLMTS_TexData = ˆTLMTS_TexData;
PLMTS_Vertex = ˆTLMTS_Vertex;

Constants

C_LMTS_ID = $53544D4C;
C_LMTS_VER = 4;
C_LMTS_SUBS = $53425553;
C_LMTS_TEXT = $54584554;
C_LMTS_TRIS = $53495254;
C_LMTS_TEXFNLEN = 255;

Description

Types

PLMTS = ˆTLMTS;

This item has no description.

PLMTS_Header = ˆTLMTS_Header;

max texture filename length

PLMTS_Subset = ˆTLMTS_Subset;

This item has no description.

PLMTS_TexData = ˆTLMTS_TexData;

This item has no description.

PLMTS_Vertex = ˆTLMTS_Vertex;

This item has no description.

Constants

C_LMTS_ID = $53544D4C;

This item has no description.

C_LMTS_VER = 4;

This item has no description.

C_LMTS_SUBS = $53425553;

This item has no description.

C_LMTS_TEXT = $54584554;

This item has no description.

C_LMTS_TRIS = $53495254;

This item has no description.

C_LMTS_TEXFNLEN = 255;


GXSysHelp v.2.5: GXS.FileLMTS: Record TLMTS_Header

Record TLMTS_Header

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TLMTS_Header = record

Description

This item has no description.

Overview

Fields

Public | ID: cardinal;
Public | Ver: cardinal;
Public | headerSize: cardinal;
Public | nTexts: word;
Public | nSubsets: word;
Public | nTris: cardinal;
Public | subSize: word;
Public | vtxSize: word;

Description

Fields

Public ID: cardinal;

packed

Public Ver: cardinal;

This item has no description.

Public headerSize: cardinal;

This item has no description.

Public nTexts: word;

This item has no description.

Public nSubsets: word;

# of textures

Public nTris: cardinal;

This item has no description.

Public subSize: word;

This item has no description.

Public vtxSize: word;


GXSysHelp v.2.5: GXS.FileLMTS: Record TLMTS_TexData

Record TLMTS_TexData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TLMTS_TexData = record

Description

This item has no description.

Overview

Fields

Public | fName: array [0 .. C_LMTS_TEXFNLEN] of ansichar;
Public | Flags: word;

Description

Fields

Public fName: array [0 .. C_LMTS_TEXFNLEN] of ansichar;

packed

Public Flags: word;


GXSysHelp v.2.5: GXS.FileLMTS: Record TLMTS_Subset

Record TLMTS_Subset

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TLMTS_Subset = record

Description

This item has no description.

Overview

Fields

Public | Offset: longint;
Public | Count: longint;
Public | TextID1: word;
Public | TextID2: word;

Description

Fields

Public Offset: longint;

packed

Public Count: longint;

This item has no description.

Public TextID1: word;

This item has no description.

Public TextID2: word;


GXSysHelp v.2.5: GXS.FileLMTS: Record TLMTS_Vertex

Record TLMTS_Vertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TLMTS_Vertex = record

Description

This item has no description.

Overview

Fields

Public | x: single;
Public | y: single;
Public | z: single;
Public | u1: single;
Public | v1: single;
Public | u2: single;
Public | v2: single;

Description

Fields

Public x: single;

packed

Public y: single;

packed

Public z: single;

packed

Public u1: single;

This item has no description.

Public v1: single;

This item has no description.

Public u2: single;

This item has no description.

Public v2: single;


GXSysHelp v.2.5: GXS.FileLMTS: Record TLMTS

Record TLMTS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TLMTS = record

Description

This item has no description.

Overview

Fields

Public | header: TLMTS_Header;
Public | usrData: pointer;
Public | usrSize: cardinal;
Public | texData: pointer;
Public | subsets: pointer;
Public | tris: pointer;
Public | ok: boolean;

Description

Fields

Public header: TLMTS_Header;

This item has no description.

Public usrData: pointer;

This item has no description.

Public usrSize: cardinal;

This item has no description.

Public texData: pointer;

This item has no description.

Public subsets: pointer;

This item has no description.

Public tris: pointer;

This item has no description.

Public ok: boolean;


GXSysHelp v.2.5: GXS.FileLMTS: Record TMaterialInfo

Record TMaterialInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TMaterialInfo = record

Description

This item has no description.

Overview

Fields

Public | FShininess: TgxShininess;
Public | BShininess: TgxShininess;
Public | FAmbient: TVector4f;
Public | FDiffuse: TVector4f;
Public | FEmission: TVector4f;
Public | FSpecular: TVector4f;
Public | BAmbient: TVector4f;
Public | BDiffuse: TVector4f;
Public | BEmission: TVector4f;
Public | BSpecular: TVector4f;
Public | ImageAlpha: TgxTextureImageAlpha;
Public | magFilter: TgxMagFilter;
Public | minFilter: TgxMinFilter;
Public | TextureMode: TgxTextureMode;
Public | TextureWrap: TgxTextureWrap;
Public | Blendingmode: TgxBlendingMode;
Public | FaceCulling: TgxFaceCulling;
Public | mathash: integer;

Description

Fields

Public FShininess: TgxShininess;

This item has no description.

Public BShininess: TgxShininess;

This item has no description.

Public FAmbient: TVector4f;

This item has no description.

Public FDiffuse: TVector4f;

This item has no description.

Public FEmission: TVector4f;

This item has no description.

Public FSpecular: TVector4f;

This item has no description.

Public BAmbient: TVector4f;

This item has no description.

Public BDiffuse: TVector4f;

This item has no description.

Public BEmission: TVector4f;

This item has no description.

Public BSpecular: TVector4f;

This item has no description.

Public ImageAlpha: TgxTextureImageAlpha;

This item has no description.

Public magFilter: TgxMagFilter;

This item has no description.

Public minFilter: TgxMinFilter;

This item has no description.

Public TextureMode: TgxTextureMode;

This item has no description.

Public TextureWrap: TgxTextureWrap;

This item has no description.

Public Blendingmode: TgxBlendingMode;

This item has no description.

Public FaceCulling: TgxFaceCulling;

This item has no description.

Public mathash: integer;


GXSysHelp v.2.5: GXS.FileLMTS: Class TgxLMTSVectorFile

Class TgxLMTSVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLMTS

Declaration

type TgxLMTSVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxLMTSVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileLWO

Unit GXS.FileLWO

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Texture
  • GXS.Material
  • GXS.VectorFileObjects
  • Formats.LWO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxLWOVectorFile |


GXSysHelp v.2.5: GXS.FileLWO: Class TgxLWOVectorFile

Class TgxLWOVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileLWO

Declaration

type TgxLWOVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxLWOVectorFile

Overview

Fields

Private | FLWO: TLWObjectFile;
Private | FPnts: TLWPnts;

Methods

Public | procedure LoadFromStream(aStream: TStream); override;
Private | procedure AddLayr(Layr: TLWLayr; LWO: TLWObjectFile);
Private | procedure AddPnts(Pnts: TLWPnts; Mesh: TgxMeshObject);
Private | procedure AddPols(Pols: TLWPols; Mesh: TgxMeshObject);
Private | procedure AddSurf(Surf: TLWSurf; LWO: TLWObjectFile);
Private | procedure AddVMap(VMap: TLWVMap; Mesh: TgxMeshObject);

Description

Fields

Private FLWO: TLWObjectFile;

This item has no description.

Private FPnts: TLWPnts;

This item has no description.

Methods

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Private procedure AddLayr(Layr: TLWLayr; LWO: TLWObjectFile);

This item has no description.

Private procedure AddPnts(Pnts: TLWPnts; Mesh: TgxMeshObject);

This item has no description.

Private procedure AddPols(Pols: TLWPols; Mesh: TgxMeshObject);

This item has no description.

Private procedure AddSurf(Surf: TLWSurf; LWO: TLWObjectFile);

This item has no description.

Private procedure AddVMap(VMap: TLWVMap; Mesh: TgxMeshObject);


GXSysHelp v.2.5: GXS.FileMD2

Unit GXS.FileMD2

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • Formatx.FileMD2

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMD2VectorFile |


GXSysHelp v.2.5: GXS.FileMD2: Class TgxMD2VectorFile

Class TgxMD2VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMD2

Declaration

type TgxMD2VectorFile = class(TgxVectorFile)

Description

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxMD2VectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileMD3

Unit GXS.FileMD3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GXS.VectorFileObjects
  • GXS.Material
  • GXS.Texture
  • Formats.MD3

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMD3VectorFile |


GXSysHelp v.2.5: GXS.FileMD3: Class TgxMD3VectorFile

Class TgxMD3VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMD3

Declaration

type TgxMD3VectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxMD3VectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream : TStream); override;


GXSysHelp v.2.5: GXS.FileMD5

Unit GXS.FileMD5

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GLScene.Utils
  • GXS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMD5VectorFile |

Variables

vMD5TextureExtensions: TStringList;

Description

Variables

vMD5TextureExtensions: TStringList;


GXSysHelp v.2.5: GXS.FileMD5: Class TgxMD5VectorFile

Class TgxMD5VectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMD5

Declaration

type TgxMD5VectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxMD5VectorFile

Overview

Fields

Private | FMD5String: TStringList;
Private | FTempString: TStringList;
Private | FBoneNames: TStringList;
Private | FCurrentPos: Integer;
Private | FBasePose: TgxSkeletonFrame;
Private | FFramePositions: TgxAffineVectorList;
Private | FFrameQuaternions: TGQuaternionList;
Private | FJointFlags: TgxIntegerList;
Private | FNumFrames: Integer;
Private | FFirstFrame: Integer;
Private | FFrameRate: Integer;
Private | FNumJoints: Integer;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Private | function ReadLine: String;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Fields

Private FMD5String: TStringList;

This item has no description.

Private FTempString: TStringList;

This item has no description.

Private FBoneNames: TStringList;

This item has no description.

Private FCurrentPos: Integer;

This item has no description.

Private FBasePose: TgxSkeletonFrame;

This item has no description.

Private FFramePositions: TgxAffineVectorList;

This item has no description.

Private FFrameQuaternions: TGQuaternionList;

This item has no description.

Private FJointFlags: TgxIntegerList;

This item has no description.

Private FNumFrames: Integer;

This item has no description.

Private FFirstFrame: Integer;

This item has no description.

Private FFrameRate: Integer;

This item has no description.

Private FNumJoints: Integer;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Private function ReadLine: String;

This item has no description.

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileMDC

Unit GXS.FileMDC

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GXS.Material
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TMDCFileHeader |
Packed Record TMDCBorderFrame |
Packed Record TMDCTagName |
Packed Record TMDCTagFrame |
Packed Record TMDCTag |
Packed Record TMDCSurfaceHeader |
Packed Record TMDCSkin |
Packed Record TMDCBaseFrame |
Packed Record TMDCCompFrame |
Class TgxMDCVectorFile |

Types

PMDCTagFrame = ˆTMDCTagFrame;
PMDCTagName = ˆTMDCTagName;
TMDCAngle = TMDCPoint;
TMDCBaseVertex = array [0 .. 3] of SmallInt;
TMDCCompVertex = array [0 .. 3] of Byte;
TMDCPoint = array [0 .. 2] of Single;
TMDCTexCoord = array [0 .. 1] of Single;
TMDCTriangle = array [0 .. 2] of Cardinal;

Constants

MDCFILE_IDENTITY = 'IDPC';
MDCFILE_VERSION = 2;
MDC_BASEVERTEX_FACTOR = 0.015625;
MDC_COMPVERTEX_FACTOR = 0.046875;

Description

Types

PMDCTagFrame = ˆTMDCTagFrame;

This item has no description.

PMDCTagName = ˆTMDCTagName;

This item has no description.

TMDCAngle = TMDCPoint;

This item has no description.

TMDCBaseVertex = array [0 .. 3] of SmallInt;

This item has no description.

TMDCCompVertex = array [0 .. 3] of Byte;

This item has no description.

TMDCPoint = array [0 .. 2] of Single;

3/64;

TMDCTexCoord = array [0 .. 1] of Single;

This item has no description.

TMDCTriangle = array [0 .. 2] of Cardinal;

This item has no description.

Constants

MDCFILE_IDENTITY = 'IDPC';

This item has no description.

MDCFILE_VERSION = 2;

This item has no description.

MDC_BASEVERTEX_FACTOR = 0.015625;

This item has no description.

MDC_COMPVERTEX_FACTOR = 0.046875;

1/64;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCFileHeader

Packed Record TMDCFileHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCFileHeader = packed record

Description

This item has no description.

Overview

Fields

Public | Ident: array [0 .. 3] of AnsiChar;
Public | Version: Cardinal;
Public | Name: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;
Public | NumFrames: Cardinal;
Public | NumTags: Cardinal;
Public | NumSurfaces: Cardinal;
Public | NumSkins: Cardinal;
Public | OffsetBorderFrames: Cardinal;
Public | OffsetTagNames: Cardinal;
Public | OffsetTagFrames: Cardinal;
Public | OffsetSurfaces: Cardinal;
Public | OffsetEnd: Cardinal;

Description

Fields

Public Ident: array [0 .. 3] of AnsiChar;

This item has no description.

Public Version: Cardinal;

This item has no description.

Public Name: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public NumFrames: Cardinal;

This item has no description.

Public NumTags: Cardinal;

This item has no description.

Public NumSurfaces: Cardinal;

This item has no description.

Public NumSkins: Cardinal;

This item has no description.

Public OffsetBorderFrames: Cardinal;

This item has no description.

Public OffsetTagNames: Cardinal;

This item has no description.

Public OffsetTagFrames: Cardinal;

This item has no description.

Public OffsetSurfaces: Cardinal;

This item has no description.

Public OffsetEnd: Cardinal;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCBorderFrame

Packed Record TMDCBorderFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCBorderFrame = packed record

Description

This item has no description.

Overview

Fields

Public | BBMin: TMDCPoint;
Public | BBMax: TMDCPoint;
Public | LocalOrigin: TMDCPoint;
Public | Radius: Single;
Public | Name: array [0 .. 15] of AnsiChar;

Description

Fields

Public BBMin: TMDCPoint;

This item has no description.

Public BBMax: TMDCPoint;

This item has no description.

Public LocalOrigin: TMDCPoint;

This item has no description.

Public Radius: Single;

This item has no description.

Public Name: array [0 .. 15] of AnsiChar;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCTagName

Packed Record TMDCTagName

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCTagName = packed record

Description

This item has no description.

Overview

Fields

Public Name: array [0 .. 63] of AnsiChar;

Description

Fields

Public Name: array [0 .. 63] of AnsiChar;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCTagFrame

Packed Record TMDCTagFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCTagFrame = packed record

Description

This item has no description.

Overview

Fields

Public | TagPosition: array [0 .. 2] of Word;
Public | TagAngle: array [0 .. 2] of Word;

Description

Fields

Public TagPosition: array [0 .. 2] of Word;

This item has no description.

Public TagAngle: array [0 .. 2] of Word;

or ShortInt?


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCTag

Packed Record TMDCTag

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCTag = packed record

Description

This item has no description.

Overview

Fields

Public | TagName: PMDCTagName;
Public | TagFrame: PMDCTagFrame;

Description

Fields

Public TagName: PMDCTagName;

This item has no description.

Public TagFrame: PMDCTagFrame;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCSurfaceHeader

Packed Record TMDCSurfaceHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCSurfaceHeader = packed record

Description

This item has no description.

Overview

Fields

Public | Ident: array [0 .. 3] of AnsiChar;
Public | Name: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;
Public | NumCompFrames: Cardinal;
Public | NumBaseFrames: Cardinal;
Public | NumSkins: Cardinal;
Public | NumVertices: Cardinal;
Public | NumTriangles: Cardinal;
Public | OffsetTriangles: Cardinal;
Public | OffsetSkins: Cardinal;
Public | OffsetTexCoords: Cardinal;
Public | OffsetBaseVerts: Cardinal;
Public | OffsetCompVerts: Cardinal;
Public | OffsetFrameBaseFrames: Cardinal;
Public | OffsetFrameCompFrames: Cardinal;
Public | OffsetEnd: Cardinal;

Description

Fields

Public Ident: array [0 .. 3] of AnsiChar;

This item has no description.

Public Name: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;

This item has no description.

Public NumCompFrames: Cardinal;

This item has no description.

Public NumBaseFrames: Cardinal;

This item has no description.

Public NumSkins: Cardinal;

This item has no description.

Public NumVertices: Cardinal;

This item has no description.

Public NumTriangles: Cardinal;

This item has no description.

Public OffsetTriangles: Cardinal;

This item has no description.

Public OffsetSkins: Cardinal;

This item has no description.

Public OffsetTexCoords: Cardinal;

This item has no description.

Public OffsetBaseVerts: Cardinal;

This item has no description.

Public OffsetCompVerts: Cardinal;

This item has no description.

Public OffsetFrameBaseFrames: Cardinal;

This item has no description.

Public OffsetFrameCompFrames: Cardinal;

This item has no description.

Public OffsetEnd: Cardinal;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCSkin

Packed Record TMDCSkin

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCSkin = packed record

Description

This item has no description.

Overview

Fields

Public | Shader: array [0 .. 63] of AnsiChar;
Public | Flags: Cardinal;

Description

Fields

Public Shader: array [0 .. 63] of AnsiChar;

This item has no description.

Public Flags: Cardinal;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCBaseFrame

Packed Record TMDCBaseFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCBaseFrame = packed record

Description

This item has no description.

Overview

Fields

Public BaseVertices: array of TMDCBaseVertex;

Description

Fields

Public BaseVertices: array of TMDCBaseVertex;


GXSysHelp v.2.5: GXS.FileMDC: Packed Record TMDCCompFrame

Packed Record TMDCCompFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TMDCCompFrame = packed record

Description

This item has no description.

Overview

Fields

Public CompVertices: array of TMDCCompVertex;

Description

Fields

Public CompVertices: array of TMDCCompVertex;


GXSysHelp v.2.5: GXS.FileMDC: Class TgxMDCVectorFile

Class TgxMDCVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMDC

Declaration

type TgxMDCVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxMDCVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(AStream: TStream); override;


GXSysHelp v.2.5: GXS.FileMP3

Unit GXS.FileMP3

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.ApplicationFileIO
  • GXS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMP3File |


GXSysHelp v.2.5: GXS.FileMP3: Class TgxMP3File

Class TgxMP3File

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMP3

Declaration

type TgxMP3File = class(TgxSoundFile)

Description

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxSoundFile
  • TgxMP3File

Overview

Fields

Private data: array of Byte;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent): TgxDataFile; override;
Public | function LengthInBytes: Integer; override;
Public | function PCMData: Pointer; override;
Public | function WAVData: Pointer; override;
Public | function WAVDataSize: Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Fields

Private data: array of Byte;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TgxDataFile; override;

used to store MP3 bitstream

Public function LengthInBytes: Integer; override;

This item has no description. Showing description inherited from TgxSoundFile.LengthInBytes.

Length of PCM data, in bytes.

Public function PCMData: Pointer; override;

This item has no description. Showing description inherited from TgxSoundFile.PCMData.

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; override;

This item has no description. Showing description inherited from TgxSoundFile.WAVData.

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; override;

This item has no description. Showing description inherited from TgxSoundFile.WAVDataSize.

Returns the size (in bytes) of the WAVData.

Public procedure LoadFromStream(Stream: TStream); override;

This item has no description.

Public procedure PlayOnWaveOut; override;

This item has no description.

Public procedure SaveToStream(Stream: TStream); override;


GXSysHelp v.2.5: GXS.FileMS3D

Unit GXS.FileMS3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GXS.VectorFileObjects
  • GLScene.VectorTypes
  • GXS.Material
  • GXS.Color
  • GXS.Texture
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMS3DGroup |
Record TMS3DHeader |
Record TMS3DVertex |
Record TMS3DTriangle |
Record TMS3DMaterial |
Record TMS3DKeyframeRotation |
Record TMS3DKeyframePosition |
Record TMS3DJointBase |
Record TMS3DJoint |
Record TMS3DComment |
Class TMS3DCommentList |
Record TMS3D_vertex_ex_t |
Class TVertexWeightList |
Class TgxMS3DVectorFile |

Types

pMS3DComment=ˆTMS3DComment;
PMS3DJointArray = ˆTMS3DJointArray;
PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;
PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;
PMS3DTriangleArray = ˆTMS3DTriangleArray;
PMS3DVertexArray = ˆTMS3DVertexArray;
pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;
TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;
TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;
TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;
TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;
TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;

Constants

MAX_MS3D_VERTICES = 8192;
MAX_MS3D_TRIANGLES = 16384;
MAX_MS3D_GROUPS = 128;
MAX_MS3D_MATERIALS = 128;
MAX_MS3D_JOINTS = 128;
MAX_MS3D_KEYFRAMES = 5000;

Description

Types

pMS3DComment=ˆTMS3DComment;

This item has no description.

PMS3DJointArray = ˆTMS3DJointArray;

This item has no description.

PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;

This item has no description.

PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;

This item has no description.

PMS3DTriangleArray = ˆTMS3DTriangleArray;

This item has no description.

PMS3DVertexArray = ˆTMS3DVertexArray;

This item has no description.

pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;

This item has no description.

TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;

This item has no description.

TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;

This item has no description.

TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;

This item has no description.

TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;

This item has no description.

TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;

This item has no description.

Constants

MAX_MS3D_VERTICES = 8192;

This item has no description.

MAX_MS3D_TRIANGLES = 16384;

This item has no description.

MAX_MS3D_GROUPS = 128;

This item has no description.

MAX_MS3D_MATERIALS = 128;

This item has no description.

MAX_MS3D_JOINTS = 128;

This item has no description.

MAX_MS3D_KEYFRAMES = 5000;


GXSysHelp v.2.5: GXS.FileMS3D: Class TMS3DGroup

Class TMS3DGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DGroup = class(TObject)

Description

typedef struct { byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material } ms3d_group_t;

Hierarchy

  • TObject
  • TMS3DGroup

Overview

Fields

Public | Flags: byte;
Public | Name: array[0..31] of AnsiChar;
Public | NumTriangles: word;
Public | TriangleIndices: TList;
Public | MaterialIndex: Shortint;

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Fields

Public Flags: byte;

This item has no description.

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public NumTriangles: word;

This item has no description.

Public TriangleIndices: TList;

This item has no description.

Public MaterialIndex: Shortint;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DHeader

Record TMS3DHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DHeader = record

Description

typdef struct { char id[10]; // always "MS3D000000" int version; // 4 } ms3d_header_t;

Overview

Fields

Public | ID: array[0..9] of AnsiChar;
Public | Version: integer;

Description

Fields

Public ID: array[0..9] of AnsiChar;

This item has no description.

Public Version: integer;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DVertex

Record TMS3DVertex

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DVertex = record

Description

typedef struct { byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; } ms3d_vertex_t;

Overview

Fields

Public | Flags: byte;
Public | Vertex: TD3DVector;
Public | BoneId: AnsiChar;
Public | ReferenceCount: byte;

Description

Fields

Public Flags: byte;

This item has no description.

Public Vertex: TD3DVector;

This item has no description.

Public BoneId: AnsiChar;

This item has no description.

Public ReferenceCount: byte;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DTriangle

Record TMS3DTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DTriangle = record

Description

typedef struct { word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // } ms3d_triangle_t;

Overview

Fields

Public | Flags: word;
Public | VertexIndices: array[0..2] of word;
Public | VertexNormals: array[0..2] of TD3DVector;
Public | S: array[0..2] of single;
Public | T: array[0..2] of single;
Public | SmoothingGroup: byte;
Public | GroupIndex: byte;

Description

Fields

Public Flags: word;

This item has no description.

Public VertexIndices: array[0..2] of word;

This item has no description.

Public VertexNormals: array[0..2] of TD3DVector;

This item has no description.

Public S: array[0..2] of single;

This item has no description.

Public T: array[0..2] of single;

This item has no description.

Public SmoothingGroup: byte;

This item has no description.

Public GroupIndex: byte;

1 - 32


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DMaterial

Record TMS3DMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DMaterial = record

Description

typedef struct { char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp } ms3d_material_t;

Overview

Fields

Public | Name: array[0..31] of AnsiChar;
Public | Ambient: TgxColorVector;
Public | Diffuse: TgxColorVector;
Public | Specular: TgxColorVector;
Public | Emissive: TgxColorVector;
Public | Shininess: single;
Public | Transparency: single;
Public | Mode: AnsiChar;
Public | Texture: array[0..127] of AnsiChar;
Public | Alphamap: array[0..127] of AnsiChar;

Description

Fields

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public Ambient: TgxColorVector;

This item has no description.

Public Diffuse: TgxColorVector;

This item has no description.

Public Specular: TgxColorVector;

This item has no description.

Public Emissive: TgxColorVector;

This item has no description.

Public Shininess: single;

This item has no description.

Public Transparency: single;

This item has no description.

Public Mode: AnsiChar;

This item has no description.

Public Texture: array[0..127] of AnsiChar;

This item has no description.

Public Alphamap: array[0..127] of AnsiChar;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DKeyframeRotation

Record TMS3DKeyframeRotation

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DKeyframeRotation = record

Description

typedef struct { float time; // time in seconds float rotation[3]; // x, y, z angles } ms3d_keyframe_rot_t;

Overview

Fields

Public | Time: single;
Public | Rotation: TD3DVector;

Description

Fields

Public Time: single;

This item has no description.

Public Rotation: TD3DVector;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DKeyframePosition

Record TMS3DKeyframePosition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DKeyframePosition = record

Description

typedef struct { float time; // time in seconds float position[3]; // local position } ms3d_keyframe_pos_t;

Overview

Fields

Public | Time: single;
Public | Position: TD3DVector;

Description

Fields

Public Time: single;

This item has no description.

Public Position: TD3DVector;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DJointBase

Record TMS3DJointBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DJointBase = record

Description

typedef struct { byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];

word numKeyFramesRot; // word numKeyFramesTrans; //

ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices } ms3d_joint_t;

Overview

Fields

Public | Flags: byte;
Public | Name: array[0..31] of AnsiChar;
Public | ParentName: array[0..31] of AnsiChar;
Public | Rotation: TD3DVector;
Public | Position: TD3DVector;
Public | NumKeyFramesRot: word;
Public | NumKeyFramesTrans: word;

Description

Fields

Public Flags: byte;

This item has no description.

Public Name: array[0..31] of AnsiChar;

This item has no description.

Public ParentName: array[0..31] of AnsiChar;

This item has no description.

Public Rotation: TD3DVector;

This item has no description.

Public Position: TD3DVector;

This item has no description.

Public NumKeyFramesRot: word;

This item has no description.

Public NumKeyFramesTrans: word;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DJoint

Record TMS3DJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DJoint = record

Description

This item has no description.

Overview

Fields

Public | Base: TMS3DJointBase;
Public | KeyFramesRot: PMS3DKeyframeRotationArray;
Public | KeyFramesTrans: PMS3DKeyframePositionArray;

Description

Fields

Public Base: TMS3DJointBase;

This item has no description.

Public KeyFramesRot: PMS3DKeyframeRotationArray;

This item has no description.

Public KeyFramesTrans: PMS3DKeyframePositionArray;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3DComment

Record TMS3DComment

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DComment = record

Description

This item has no description.

Overview

Fields

Public | index: Integer;
Public | commentLength: integer;
Public | comment: array of AnsiChar;

Description

Fields

Public index: Integer;

This item has no description.

Public commentLength: integer;

This item has no description.

Public comment: array of AnsiChar;


GXSysHelp v.2.5: GXS.FileMS3D: Class TMS3DCommentList

Class TMS3DCommentList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3DCommentList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TMS3DCommentList

Overview

Methods

Public | destructor Destroy; override;
Public | function NewComment: pMS3DComment;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function NewComment: pMS3DComment;


GXSysHelp v.2.5: GXS.FileMS3D: Record TMS3D_vertex_ex_t

Record TMS3D_vertex_ex_t

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TMS3D_vertex_ex_t = record

Description

This item has no description.

Overview

Fields

Public | boneIds: array[0..2] of byte;
Public | weights: array[0..2] of byte;
Public | extra: cardinal;
Public | unknown: cardinal;

Description

Fields

Public boneIds: array[0..2] of byte;

This item has no description.

Public weights: array[0..2] of byte;

This item has no description.

Public extra: cardinal;

This item has no description.

Public unknown: cardinal;


GXSysHelp v.2.5: GXS.FileMS3D: Class TVertexWeightList

Class TVertexWeightList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TVertexWeightList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TVertexWeightList

Overview

Fields

Private FsubVersion: Integer;

Methods

Public | destructor Destroy; override;
Public | function newWeight: pMS3D_vertex_ex_t;
Private | function GetWeight(idx: Integer): pMS3D_vertex_ex_t;
Public | procedure Clear; override;
Private | procedure SetsubVersion(const Value: Integer);

Properties

Public | property subVersion: Integer read FsubVersion write SetsubVersion;
Public | property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;

Description

Fields

Private FsubVersion: Integer;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function newWeight: pMS3D_vertex_ex_t;

This item has no description.

Private function GetWeight(idx: Integer): pMS3D_vertex_ex_t;

This item has no description.

Public procedure Clear; override;

This item has no description.

Private procedure SetsubVersion(const Value: Integer);

This item has no description.

Properties

Public property subVersion: Integer read FsubVersion write SetsubVersion;

This item has no description.

Public property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;


GXSysHelp v.2.5: GXS.FileMS3D: Class TgxMS3DVectorFile

Class TgxMS3DVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileMS3D

Declaration

type TgxMS3DVectorFile = class(TgxVectorFile)

Description

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxMS3DVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileNMF

Unit GXS.FileNMF

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TNmHeader |
Record TNmRawTriangle |
Class TFileNMF |
Class TgxNMFVectorFile |

Constants

NMF_HEADER_TAG = 'NMF ';
NMF_TRIANGLE_TAG = 'TRIS';

Description

Constants

NMF_HEADER_TAG = 'NMF ';

This item has no description.

NMF_TRIANGLE_TAG = 'TRIS';


GXSysHelp v.2.5: GXS.FileNMF: Record TNmHeader

Record TNmHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileNMF

Declaration

type TNmHeader = record

Description

This item has no description.

Overview

Fields

Public | hdr: array [0 .. 3] of AnsiChar;
Public | size: cardinal;

Description

Fields

Public hdr: array [0 .. 3] of AnsiChar;

This item has no description.

Public size: cardinal;


GXSysHelp v.2.5: GXS.FileNMF: Record TNmRawTriangle

Record TNmRawTriangle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileNMF

Declaration

type TNmRawTriangle = record

Description

This item has no description.

Overview

Fields

Public | vert: array [0 .. 2] of TAffineVector;
Public | norm: array [0 .. 2] of TAffineVector;
Public | texCoord: array [0 .. 2] of TTexPoint;

Description

Fields

Public vert: array [0 .. 2] of TAffineVector;

This item has no description.

Public norm: array [0 .. 2] of TAffineVector;

This item has no description.

Public texCoord: array [0 .. 2] of TTexPoint;


GXSysHelp v.2.5: GXS.FileNMF: Class TFileNMF

Class TFileNMF

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileNMF

Declaration

type TFileNMF = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TFileNMF

Overview

Fields

Public | FileHeader: TNmHeader;
Public | TrisHeader: TNmHeader;
Public | NumTris: Integer;
Public | RawTriangles: array of TNmRawTriangle;

Methods

Public | procedure LoadFromStream(Stream: TStream);
Public | procedure SaveToStream(Stream: TStream);

Description

Fields

Public FileHeader: TNmHeader;

This item has no description.

Public TrisHeader: TNmHeader;

This item has no description.

Public NumTris: Integer;

This item has no description.

Public RawTriangles: array of TNmRawTriangle;

This item has no description.

Methods

Public procedure LoadFromStream(Stream: TStream);

This item has no description.

Public procedure SaveToStream(Stream: TStream);


GXSysHelp v.2.5: GXS.FileNMF: Class TgxNMFVectorFile

Class TgxNMFVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileNMF

Declaration

type TgxNMFVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxNMFVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileNurbs

Unit GXS.FileNurbs

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.VectorFileObjects
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO
  • GXS.ParametricSurfaces
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxNurbsVectorFile |


GXSysHelp v.2.5: GXS.FileNurbs: Class TgxNurbsVectorFile

Class TgxNurbsVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileNurbs

Declaration

type TgxNurbsVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxNurbsVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(stream: TStream); override;


GXSysHelp v.2.5: GXS.FileOBJ

Unit GXS.FileOBJ

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Context
  • GXS.MeshUtils
  • GXS.ImageUtils
  • GXS.ApplicationFileIO
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.VectorFileObjects
  • GXS.VectorLists
  • GXS.Texture
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxOBJVectorFile |
Class EGLOBJFileError |
Class TgxMTLFile |

Constants

BufSize = 10240;
LineLen = 100;

Variables

vFileOBJ_SplitMesh: Boolean = False;

Description

Constants

BufSize = 10240;

This item has no description.

LineLen = 100;

Load input data in chunks of BufSize Bytes.

Variables

vFileOBJ_SplitMesh: Boolean = False;

If enabled, main mesh will be splitted into multiple mesh from facegroup data.


GXSysHelp v.2.5: GXS.FileOBJ: Class TgxOBJVectorFile

Class TgxOBJVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileOBJ

Declaration

type TgxOBJVectorFile = class(TgxVectorFile)

Description

Allocate memory for the current line in chunks of LineLen Bytes

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxOBJVectorFile

Overview

Fields

Private | FSourceStream: TStream;
Private | FBuffer: AnsiString;
Private | FLine: string;
Private | FLineNo: Integer;
Private | FEof: Boolean;
Private | FBufPos: Integer;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FBuffer: AnsiString;

Load from this stream

Private FLine: string;

Buffer

Private FLineNo: Integer;

current line

Private FEof: Boolean;

current Line number - for error messages

Private FBufPos: Integer;

Stream done?

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileOBJ: Class EGLOBJFileError

Class EGLOBJFileError

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileOBJ

Declaration

type EGLOBJFileError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLOBJFileError

Overview

Fields

Private FLineNo: Integer;

Properties

Public property LineNo: Integer read FLineNo;

Description

Fields

Private FLineNo: Integer;

This item has no description.

Properties

Public property LineNo: Integer read FLineNo;


GXSysHelp v.2.5: GXS.FileOBJ: Class TgxMTLFile

Class TgxMTLFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileOBJ

Declaration

type TgxMTLFile = class(TStringList)

Description

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)

Hierarchy

  • TObject
  • TPersistent
  • TStrings
  • TStringList
  • TgxMTLFile

Overview

Methods

Public | function MaterialStringProperty(const materialName, propertyName: string): string;
Public | function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TVector4f): TVector4f;
Public | procedure Prepare;

Description

Methods

Public function MaterialStringProperty(const materialName, propertyName: string): string;

This item has no description.

Public function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TVector4f): TVector4f;

This item has no description.

Public procedure Prepare;


GXSysHelp v.2.5: GXS.FileOCT

Unit GXS.FileOCT

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GLScene.TextureFormat
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GXS.Texture
  • GXS.Material
  • GXS.Graphics
  • GXS.State
  • GXS.ImageUtils
  • Formats.OCT

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxOCTgxVectorFile |

Variables

vFileOCTLightmapBrightness: single = 1;
vFileOCTLightmapGammaCorrection: single = 1;
vFileOCTAllocateMaterials: boolean = True;

Description

Variables

vFileOCTLightmapBrightness: single = 1;

Scaling factor, 1.0 = unchanged

vFileOCTLightmapGammaCorrection: single = 1;

Scaling factor, 1.0 = unchanged

vFileOCTAllocateMaterials: boolean = True;

Flag to avoid loading materials (useful for IDE Extensions or scene editors)


GXSysHelp v.2.5: GXS.FileOCT: Class TgxOCTgxVectorFile

Class TgxOCTgxVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileOCT

Declaration

type TgxOCTgxVectorFile = class(TgxVectorFile)

Description

The OCT vector file (FSRad output).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxOCTgxVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FilePGM

Unit GXS.FilePGM

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Graphic Scene Engine, http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPGMImage |


GXSysHelp v.2.5: GXS.FilePGM: Class TgxPGMImage

Class TgxPGMImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FilePGM

Declaration

type TgxPGMImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxPGMImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLEnum; textureTarget: TgxTextureTarget; const CurrentFormat: Boolean; const intFormat: TgxInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLEnum; textureTarget: TgxTextureTarget; const CurrentFormat: Boolean; const intFormat: TgxInternalFormat); reintroduce;

This item has no description.

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GXSysHelp v.2.5: GXS.FilePLY

Unit GXS.FilePLY

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.Utils
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPLYVectorFile |


GXSysHelp v.2.5: GXS.FilePLY: Class TgxPLYVectorFile

Class TgxPLYVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FilePLY

Declaration

type TgxPLYVectorFile = class(TgxVectorFile)

Description

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxPLYVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FilePNG

Unit GXS.FilePNG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.Context
  • GXS.Graphics
  • GLScene.TextureFormat
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPNGImage |


GXSysHelp v.2.5: GXS.FilePNG: Class TgxPNGImage

Class TgxPNGImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FilePNG

Declaration

type TgxPNGImage = class(TgxBaseImage)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxPNGImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure AssignFromTexture(textureContext: TgxContext; const textureHandle: GLuint; textureTarget: TglTextureTarget; const CurrentFormat: Boolean; const intFormat: TglInternalFormat); reintroduce;

Assigns from any Texture

Public procedure LoadFromFile(const filename: string); override;

This item has no description.

Public procedure LoadFromStream(stream: TStream); override;

This item has no description.

Public procedure SaveToFile(const filename: string); override;

This item has no description.

Public procedure SaveToStream(stream: TStream); override;


GXSysHelp v.2.5: GXS.FileQ3BSP

Unit GXS.FileQ3BSP

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Graphics
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.BSP
  • GXS.Texture
  • GXS.Graphics
  • GXS.State
  • GXS.ImageUtils
  • GXS.Material
  • GLScene.TextureFormat
  • Formats.Q3BSP

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxQ3BSPVectorFile |

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;
vQ3BSPLightmapBrightness: Single = 2;
vFileQ3BSPLoadMaterials: boolean = True;

Description

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;

Q3 lightmaps are quite dark, we brighten them a lot by default

vQ3BSPLightmapBrightness: Single = 2;

This item has no description.

vFileQ3BSPLoadMaterials: boolean = True;

scaling factor, 1.0 = unchanged


GXSysHelp v.2.5: GXS.FileQ3BSP: Class TgxQ3BSPVectorFile

Class TgxQ3BSPVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileQ3BSP

Declaration

type TgxQ3BSPVectorFile = class(TgxVectorFile)

Description

The Q3BSP vector file (Quake III BSP).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxQ3BSPVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileSMD

Unit GXS.FileSMD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.Utils
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GXS.Material
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGXSMDVectorFile |


GXSysHelp v.2.5: GXS.FileSMD: Class TGXSMDVectorFile

Class TGXSMDVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileSMD

Declaration

type TGXSMDVectorFile = class(TgxVectorFile)

Description

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TGXSMDVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileSTL

Unit GXS.FileSTL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TSTLHeader |
Packed Record TSTLFace |
Class TGXSTLVectorFile |

Types

TSTLVertex = TAffineVector;

Description

Types

TSTLVertex = TAffineVector;


GXSysHelp v.2.5: GXS.FileSTL: Packed Record TSTLHeader

Packed Record TSTLHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileSTL

Declaration

type TSTLHeader = packed record

Description

This item has no description.

Overview

Fields

Public | dummy: array [0 .. 79] of byte;
Public | nbFaces: Longint;

Description

Fields

Public dummy: array [0 .. 79] of byte;

This item has no description.

Public nbFaces: Longint;


GXSysHelp v.2.5: GXS.FileSTL: Packed Record TSTLFace

Packed Record TSTLFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileSTL

Declaration

type TSTLFace = packed record

Description

Original specs : = packed record x : single; y : single; z : single; end;

Overview

Fields

Public | normal: TSTLVertex;
Public | v1: TSTLVertex;
Public | v2: TSTLVertex;
Public | v3: TSTLVertex;
Public | padding: array [0 .. 1] of byte;

Description

Fields

Public normal: TSTLVertex;

This item has no description.

Public v1: TSTLVertex;

facet surface normal

Public v2: TSTLVertex;

vertex 1

Public v3: TSTLVertex;

vertex 2

Public padding: array [0 .. 1] of byte;

vertex 3


GXSysHelp v.2.5: GXS.FileSTL: Class TGXSTLVectorFile

Class TGXSTLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileSTL

Declaration

type TGXSTLVectorFile = class(TgxVectorFile)

Description

The STL vector file (stereolithography format). It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines. There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version. Original Binary importer code by Paul M. Bearne, Text importer by Adem.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TGXSTLVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileTGA

Unit GXS.FileTGA

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Graphics
  • FMX.Types
  • GXS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TTGAImage |
Class ETGAException |


GXSysHelp v.2.5: GXS.FileTGA: Class TTGAImage

Class TTGAImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileTGA

Declaration

type TTGAImage = class(TBitmap)

Description

TGA image load/save capable class for Delphi. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

Hierarchy

  • TBitmap
  • TTGAImage

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(stream: TStream);
Public | procedure SaveToStream(stream: TStream);

Description

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure LoadFromStream(stream: TStream);

This item has no description.

Public procedure SaveToStream(stream: TStream);

in VCL override;


GXSysHelp v.2.5: GXS.FileTGA: Class ETGAException

Class ETGAException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileTGA

Declaration

type ETGAException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • ETGAException


GXSysHelp v.2.5: GXS.FileTIN

Unit GXS.FileTIN

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.VectorTypesExt
  • GXS.ApplicationFileIO
  • GXS.VectorFileObjects
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTINVectorFile |


GXSysHelp v.2.5: GXS.FileTIN: Class TgxTINVectorFile

Class TgxTINVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileTIN

Declaration

type TgxTINVectorFile = class(TgxVectorFile)

Description

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxTINVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileVRML

Unit GXS.FileVRML

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO
  • GXS.VectorFileObjects
  • GXS.Material
  • GXS.MeshUtils
  • Formatx.VRML

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxVRMLVectorFile |


GXSysHelp v.2.5: GXS.FileVRML: Class TgxVRMLVectorFile

Class TgxVRMLVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileVRML

Declaration

type TgxVRMLVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxVRMLVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileWAV

Unit GXS.FileWAV

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.MMSystem
  • System.Classes
  • GXS.ApplicationFileIO
  • GXS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxWAVFile |


GXSysHelp v.2.5: GXS.FileWAV: Class TgxWAVFile

Class TgxWAVFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileWAV

Declaration

type TgxWAVFile = class(TgxSoundFile)

Description

Support for Windows WAV format.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxSoundFile
  • TgxWAVFile

Overview

Fields

Private | waveFormat: TWaveFormatEx;
Private | pcmOffset: Integer;
Private | FPCMDataLength: Integer;
Private | data: array of Byte;

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent): TgxDataFile; override;
Public | function LengthInBytes: Integer; override;
Public | function PCMData: Pointer; override;
Public | function WAVData: Pointer; override;
Public | function WAVDataSize: Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Fields

Private waveFormat: TWaveFormatEx;

This item has no description.

Private pcmOffset: Integer;

This item has no description.

Private FPCMDataLength: Integer;

This item has no description.

Private data: array of Byte;

This item has no description.

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TgxDataFile; override;

used to store WAVE bitstream

Public function LengthInBytes: Integer; override;

This item has no description. Showing description inherited from TgxSoundFile.LengthInBytes.

Length of PCM data, in bytes.

Public function PCMData: Pointer; override;

This item has no description. Showing description inherited from TgxSoundFile.PCMData.

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; override;

This item has no description. Showing description inherited from TgxSoundFile.WAVData.

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; override;

This item has no description. Showing description inherited from TgxSoundFile.WAVDataSize.

Returns the size (in bytes) of the WAVData.

Public procedure LoadFromStream(Stream: TStream); override;

This item has no description.

Public procedure PlayOnWaveOut; override;

This item has no description.

Public procedure SaveToStream(Stream: TStream); override;


GXSysHelp v.2.5: GXS.FileX

Unit GXS.FileX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GXS.ApplicationFileIO
  • GLScene.VectorGeometry
  • GXS.Texture
  • GXS.VectorLists
  • GXS.Material
  • Formatx.X

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxXVectorFile |


GXSysHelp v.2.5: GXS.FileX: Class TgxXVectorFile

Class TgxXVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileX

Declaration

type TgxXVectorFile = class(TgxVectorFile)

Description

This item has no description. Showing description inherited from TgxVectorFile.

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxXVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.FileZLIB

Unit GXS.FileZLIB

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Graphic Scene Engine, http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • GXS.ArchiveManager
  • GXS.zLibEx

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TZLibHeader |
Record TFileSection |
Class TZLibArchive |

Constants

SIGN = 'ZLIB';

Description

Constants

SIGN = 'ZLIB';


GXSysHelp v.2.5: GXS.FileZLIB: Record TZLibHeader

Record TZLibHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileZLIB

Declaration

type TZLibHeader = record

Description

Signature for compressed zlib.

Overview

Fields

Public | Signature: array[0..3] of AnsiChar;
Public | DirOffset: integer;
Public | DirLength: integer;

Description

Fields

Public Signature: array[0..3] of AnsiChar;

This item has no description.

Public DirOffset: integer;

This item has no description.

Public DirLength: integer;


GXSysHelp v.2.5: GXS.FileZLIB: Record TFileSection

Record TFileSection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileZLIB

Declaration

type TFileSection = record

Description

This item has no description.

Overview

Fields

Public | FileName: array[0..119] of AnsiChar;
Public | FilePos: integer;
Public | FileLength: integer;
Public | CbrMode: TCompressionLevel;

Description

Fields

Public FileName: array[0..119] of AnsiChar;

This item has no description.

Public FilePos: integer;

This item has no description.

Public FileLength: integer;

This item has no description.

Public CbrMode: TCompressionLevel;


GXSysHelp v.2.5: GXS.FileZLIB: Class TZLibArchive

Class TZLibArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FileZLIB

Declaration

type TZLibArchive = class(TgxBaseArchive)

Description

TZLibArchive

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseArchive
  • TZLibArchive

Overview

Fields

Private | FHeader: TZLibHeader;
Private | FStream: TFileStream;

Methods

Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(aStream: TStream; index: integer): TStream; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContentSize(index: integer): integer; override;
Public | function GetContentSize(ContentName: string): integer; override;
Private | function GetContentCount: integer;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(ContentName: string); overload; override;
Public | procedure RemoveContent(index: integer); overload; override;
Private | procedure MakeContentList;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Fields

Private FHeader: TZLibHeader;

This item has no description.

Private FStream: TFileStream;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function ContentExists(ContentName: string): boolean; override;

This item has no description.

Public function GetContent(aStream: TStream; index: integer): TStream; override;

This item has no description.

Public function GetContent(index: integer): TStream; override;

This item has no description.

Public function GetContent(ContentName: string): TStream; override;

This item has no description.

Public function GetContentSize(index: integer): integer; override;

This item has no description.

Public function GetContentSize(ContentName: string): integer; override;

This item has no description.

Private function GetContentCount: integer;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); override;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Extract(ContentName, NewName: string); override;

This item has no description.

Public procedure Extract(index: integer; NewName: string); override;

This item has no description.

Public procedure LoadFromFile(const FileName: string); override;

This item has no description.

Public procedure RemoveContent(ContentName: string); overload; override;

This item has no description.

Public procedure RemoveContent(index: integer); overload; override;

This item has no description.

Private procedure MakeContentList;

This item has no description.

Properties

Public property ContentCount: integer Read GetContentCount;


GXSysHelp v.2.5: GXS.FireFX

Unit GXS.FireFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GXS.BaseClasses
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Manager
  • GXS.Scene
  • GXS.Context
  • GXS.Cadencer
  • GXS.Color
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.PipelineTransform
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TFireParticle |
Class TgxFireFXManager |
Class TgxBFireFX |

Functions and Procedures

function GetOrCreateFireFX(effects: TgxEffects): TgxBFireFX; overload;
function GetOrCreateFireFX(obj: TgxBaseSceneObject): TgxBFireFX; overload;

Types

PFireParticle = ˆTFireParticle;
PFireParticleArray = ˆTFireParticleArray;
TFireParticleArray = array[0..MAXINT shr 6] of TFireParticle;

Description

Functions and Procedures

function GetOrCreateFireFX(effects: TgxEffects): TgxBFireFX; overload;

Returns or creates the TgxBFireFX within the given behaviours. This helper function is convenient way to access a TgxBFireFX.

function GetOrCreateFireFX(obj: TgxBaseSceneObject): TgxBFireFX; overload;

Returns or creates the TgxBFireFX within the given object's behaviours. This helper function is convenient way to access a TgxBFireFX.

Types

PFireParticle = ˆTFireParticle;

This item has no description.

PFireParticleArray = ˆTFireParticleArray;

This item has no description.

TFireParticleArray = array[0..MAXINT shr 6] of TFireParticle;


GXSysHelp v.2.5: GXS.FireFX: Record TFireParticle

Record TFireParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FireFX

Declaration

type TFireParticle = record

Description

This item has no description.

Overview

Fields

Public | Position: TVector4f;
Public | Speed: TVector4f;
Public | Alpha: Single;
Public | TimeToLive: Single;
Public | LifeLength: Single;

Description

Fields

Public Position: TVector4f;

This item has no description.

Public Speed: TVector4f;

This item has no description.

Public Alpha: Single;

This item has no description.

Public TimeToLive: Single;

This item has no description.

Public LifeLength: Single;


GXSysHelp v.2.5: GXS.FireFX: Class TgxFireFXManager

Class TgxFireFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FireFX

Declaration

type TgxFireFXManager = class(TgxCadenceAbleComponent)

Description

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxFireFXManager

Overview

Fields

Private | FClients: TList;
Private | FFireParticles: PFireParticleArray;
Private | FFireDir: TgxCoordinates;
Private | FInitialDir: TgxCoordinates;
Private | FCadencer: TgxCadencer;
Private | FMaxParticles: Integer;
Private | FParticleLife: Integer;
Private | FParticleSize: Single;
Private | FFireDensity: Single;
Private | FFireEvaporation: Single;
Private | FFireCrown: Single;
Private | FParticleInterval: Single;
Private | IntervalDelta: Single;
Private | NP: Integer;
Private | FInnerColor: TgxColor;
Private | FOuterColor: TgxColor;
Private | FFireBurst: Single;
Private | FFireRadius: Single;
Private | FDisabled: Boolean;
Private | FPaused: Boolean;
Private | FUseInterval: Boolean;
Private | FReference: TgxBaseSceneObject;
Private | FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure FireInit;
Public | procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);
Public | procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);

Properties

Published | property Cadencer: TgxCadencer read FCadencer write SetCadencer;
Published | property Disabled: Boolean read FDisabled write FDisabled;
Published | property FireBurst: Single read FFireBurst write FFireBurst;
Published | property FireCrown: Single read FFireCrown write FFireCrown;
Published | property FireDensity: Single read FFireDensity write FFireDensity;
Published | property FireDir: TgxCoordinates read FFireDir write SetFireDir;
Published | property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;
Published | property FireRadius: Single read FFireRadius write FFireRadius;
Published | property InitialDir: TgxCoordinates read FInitialDir write SetInitialDir;
Published | property InnerColor: TgxColor read FInnerColor write SetInnerColor;
Published | property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;
Published | property OuterColor: TgxColor read FOuterColor write SetOuterColor;
Public | property ParticleCount: Integer read NP;
Published | property ParticleInterval: Single read FParticleInterval write FParticleInterval;
Published | property ParticleLife: Integer read FParticleLife write FParticleLife default 3;
Published | property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;
Published | property Paused: Boolean read FPaused write FPaused;
Published | property Reference: TgxBaseSceneObject read FReference write SetReference;
Published | property UseInterval: Boolean read FUseInterval write FUseInterval;

Description

Fields

Private FClients: TList;

This item has no description.

Private FFireParticles: PFireParticleArray;

This item has no description.

Private FFireDir: TgxCoordinates;

This item has no description.

Private FInitialDir: TgxCoordinates;

This item has no description.

Private FCadencer: TgxCadencer;

This item has no description.

Private FMaxParticles: Integer;

This item has no description.

Private FParticleLife: Integer;

This item has no description.

Private FParticleSize: Single;

This item has no description.

Private FFireDensity: Single;

This item has no description.

Private FFireEvaporation: Single;

This item has no description.

Private FFireCrown: Single;

This item has no description.

Private FParticleInterval: Single;

This item has no description.

Private IntervalDelta: Single;

This item has no description.

Private NP: Integer;

This item has no description.

Private FInnerColor: TgxColor;

This item has no description.

Private FOuterColor: TgxColor;

This item has no description.

Private FFireBurst: Single;

This item has no description.

Private FFireRadius: Single;

This item has no description.

Private FDisabled: Boolean;

This item has no description.

Private FPaused: Boolean;

This item has no description.

Private FUseInterval: Boolean;

This item has no description.

Private FReference: TgxBaseSceneObject;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure FireInit;

Reinitializes the fire.

Public procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate an isotropic explosion. This method generates an isotropic explosion, i.e. there is no privilegied direction in the initial vector.

Public procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate a ring explosion. This method generates a ring explosion. The plane of the ring is described by ringVectorX/Y, which should be of unit length (but you may not make them of unit length if you want "elliptic" rings).

Properties

Published property Cadencer: TgxCadencer read FCadencer write SetCadencer;

The cadencer that will "drive" the animation of the system.

Published property Disabled: Boolean read FDisabled write FDisabled;

If true, no new particles are spawn. But current ones continue to live and die.

Published property FireBurst: Single read FFireBurst write FFireBurst;

This item has no description.

Published property FireCrown: Single read FFireCrown write FFireCrown;

Adjust a crown (circular) radius on which particles are spawned. With a value of zero, the particles are spawned in the FireRadius cube around the origin, with a non zero value, they appear in a torus of major radius FireCrown, and minor radius FireRadius*1.73.

Published property FireDensity: Single read FFireDensity write FFireDensity;

default clrWhite;

Published property FireDir: TgxCoordinates read FFireDir write SetFireDir;

Adjusts the acceleration direction (abs coordinates).

Published property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;

This item has no description.

Published property FireRadius: Single read FFireRadius write FFireRadius;

Adjusts the random birth radius for particles (actually a birth cube).

Published property InitialDir: TgxCoordinates read FInitialDir write SetInitialDir;

Adjusts the initial direction (abs coordinates).

Published property InnerColor: TgxColor read FInnerColor write SetInnerColor;

Inner color of a particle.

Published property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;

Maximum number of simultaneous particles in the system.

Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;

Particle's render won't write to Z-Buffer

Published property OuterColor: TgxColor read FOuterColor write SetOuterColor;

Outer color of a particle.

Public property ParticleCount: Integer read NP;

Current Nb of particles.

Published property ParticleInterval: Single read FParticleInterval write FParticleInterval;

Interval between particles births (in sec). The interval may not be honoured if MawParticles is reached.

Published property ParticleLife: Integer read FParticleLife write FParticleLife default 3;

Life length of particle.

Published property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;

Size of the particle, in absolute units.

Published property Paused: Boolean read FPaused write FPaused;

When paused, the fire animation is freezed.

Published property Reference: TgxBaseSceneObject read FReference write SetReference;

Specifies an optional object whose position to use as reference. This property allows switching between static/shared fires (for fireplaces or static torches) and dynamic fire trails. The absolute position of the reference object is 'central' spawning point for new particles, usually, the object will be the one and only one on which the effect is applied.

Published property UseInterval: Boolean read FUseInterval write FUseInterval;

Enable/disable use of ParticleInterval. If true ParticleInterval is used, if False, the system will attempt to maintain a particle count of MaxParticles, by spawning new particles to replace the dead ones ASAP.


GXSysHelp v.2.5: GXS.FireFX: Class TgxBFireFX

Class TgxBFireFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FireFX

Declaration

type TgxBFireFX = class(TgxObjectPostEffect)

Description

Fire special effect. This effect works as a client of TFireFXManager

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPostEffect
  • TgxBFireFX

Overview

Fields

Private | FManager: TgxFireFXManager;
Private | FManagerName: string;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published property Manager: TgxFireFXManager read FManager write SetManager;

Description

Fields

Private FManager: TgxFireFXManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Manager: TgxFireFXManager read FManager write SetManager;

Refers the collision manager.


GXSysHelp v.2.5: GXS.FMX.Viewer

Unit GXS.FMX.Viewer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This unit is part of the GLScene Project, http://glscene.org

Uses

  • WinAPI.Windows
  • System.Types
  • System.Classes
  • System.UITypes
  • System.SysUtils
  • FMX.Types
  • FMX.Types3D
  • FMX.Forms
  • GLScene.OpenGLTokens
  • GLScene.TextureFormat
  • GXS.Scene
  • GXS.Context
  • FMX.Platform.Win

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneViewport |


GXSysHelp v.2.5: GXS.FMX.Viewer: Class TGLSceneViewport

Class TGLSceneViewport

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FMX.Viewer

Declaration

type TGLSceneViewport = class

Description

This item has no description.

Overview

Fields

Private | FGLSBuffer: TGLSceneBuffer;
Private | FFMXBuffer: FMX.Types.TBitmap;
Private | FFMXContext: FMX.Types3D.TContext3D;
Private | FMultisample: FMX.Types3D.TMultisample;
Private | FParentHandle: HWND;
Private | FOwnDC: HDC;
Private | FDrawing: Boolean;
Private | FPostRender: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetAfterRender: TNotifyEvent;
Private | function GetBeforeRender: TNotifyEvent;
Private | function GetGLSceneCamera: TGLCamera;
Public | procedure Realign;
Private | procedure CopyBuffer(Sender: TObject);
Private | procedure SetAfterRender(const Value: TNotifyEvent);
Private | procedure SetBeforeRender(const Value: TNotifyEvent);
Private | procedure SetBuffer(const Value: TGLSceneBuffer);
Private | procedure SetGLSceneCamera(const Value: TGLCamera);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FGLSBuffer write SetBuffer;
Published | property GLSceneCamera: TGLCamera read GetGLSceneCamera write SetGLSceneCamera;
Published | property PostRender: TNotifyEvent read FPostRender write FPostRender;

Description

Fields

Private FGLSBuffer: TGLSceneBuffer;

should be not class(FMX.Types.TControl)

Private FFMXBuffer: FMX.Types.TBitmap;

This item has no description.

Private FFMXContext: FMX.Types3D.TContext3D;

This item has no description.

Private FMultisample: FMX.Types3D.TMultisample;

This item has no description.

Private FParentHandle: HWND;

This item has no description.

Private FOwnDC: HDC;

This item has no description.

Private FDrawing: Boolean;

This item has no description.

Private FPostRender: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAfterRender: TNotifyEvent;

This item has no description.

Private function GetBeforeRender: TNotifyEvent;

This item has no description.

Private function GetGLSceneCamera: TGLCamera;

This item has no description.

Public procedure Realign;

procedure Realign; override; - E2179, removed override;

Private procedure CopyBuffer(Sender: TObject);

This item has no description.

Private procedure SetAfterRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetBeforeRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetBuffer(const Value: TGLSceneBuffer);

This item has no description.

Private procedure SetGLSceneCamera(const Value: TGLCamera);

This item has no description.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered.<p> You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FGLSBuffer write SetBuffer;

Access to buffer properties.

Published property GLSceneCamera: TGLCamera read GetGLSceneCamera write SetGLSceneCamera;

Camera from which the scene is rendered.

Published property PostRender: TNotifyEvent read FPostRender write FPostRender;

Triggered just after all the scene's objects have been rendered.<p> The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.


GXSysHelp v.2.5: GXS.FPSMovement

Unit GXS.FPSMovement

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • FMX.Graphics
  • GLScene.XCollection
  • GLScene.VectorTypes
  • GXS.Context
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Coordinates
  • GXS.VectorFileObjects
  • GXS.VectorLists
  • GXS.GeomObjects
  • GXS.Navigator
  • GXS.RenderContextInfo
  • GXS.BaseClasses
  • GLScene.Manager
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TContactPoint |
Class TCollisionState |
Class TCollisionStates |
Class TgxMapCollectionItem |
Class TgxMapCollection |
Class TgxFPSMovementManager |
Class TgxBFPSMovement |

Functions and Procedures

function GetFPSMovement(behaviours: TgxBehaviours): TgxBFPSMovement; overload;
function GetFPSMovement(obj: TgxBaseSceneObject): TgxBFPSMovement; overload;
function GetOrCreateFPSMovement(behaviours: TgxBehaviours): TgxBFPSMovement; overload;
function GetOrCreateFPSMovement(obj: TgxBaseSceneObject): TgxBFPSMovement; overload;

Types

TgxMapCollectionItemClass = class of TgxMapCollectionItem;

Description

Functions and Procedures

function GetFPSMovement(behaviours: TgxBehaviours): TgxBFPSMovement; overload;

This item has no description.

function GetFPSMovement(obj: TgxBaseSceneObject): TgxBFPSMovement; overload;

This item has no description.

function GetOrCreateFPSMovement(behaviours: TgxBehaviours): TgxBFPSMovement; overload;

This item has no description.

function GetOrCreateFPSMovement(obj: TgxBaseSceneObject): TgxBFPSMovement; overload;

This item has no description.

Types

TgxMapCollectionItemClass = class of TgxMapCollectionItem;


GXSysHelp v.2.5: GXS.FPSMovement: Record TContactPoint

Record TContactPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TContactPoint = record

Description

This item has no description.

Overview

Fields

Public | intPoint: TVector4f;
Public | intNormal: TVector4f;

Description

Fields

Public intPoint: TVector4f;

This item has no description.

Public intNormal: TVector4f;


GXSysHelp v.2.5: GXS.FPSMovement: Class TCollisionState

Class TCollisionState

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TCollisionState = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TCollisionState

Overview

Fields

Public | Position: TVector4f;
Public | Contact: TContactPoint;
Public | Time: Int64;

Description

Fields

Public Position: TVector4f;

This item has no description.

Public Contact: TContactPoint;

This item has no description.

Public Time: Int64;


GXSysHelp v.2.5: GXS.FPSMovement: Class TCollisionStates

Class TCollisionStates

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TCollisionStates = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TCollisionStates


GXSysHelp v.2.5: GXS.FPSMovement: Class TgxMapCollectionItem

Class TgxMapCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TgxMapCollectionItem = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxMapCollectionItem

Overview

Fields

Private | FMap: TgxFreeForm;
Private | FMapName: string;
Private | FCollisionGroup: integer;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | class function FriendlyName: String; override;
Private | procedure setMap(value: TgxFreeForm);

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property Map: TgxFreeForm read FMap write setMap;

Description

Fields

Private FMap: TgxFreeForm;

This item has no description.

Private FMapName: string;

This item has no description.

Private FCollisionGroup: integer;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Private procedure setMap(value: TgxFreeForm);

This item has no description.

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;

Indicates the collision group of this map. A Collision Group is a set of logical maps and movers that can collide between themselves (i.e. a Behaviour with group 1 can only collide with maps that are also on group 1).

Published property Map: TgxFreeForm read FMap write setMap;


GXSysHelp v.2.5: GXS.FPSMovement: Class TgxMapCollection

Class TgxMapCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TgxMapCollection = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxMapCollection

Overview

Methods

Public | function addMap(Map: TgxFreeForm; CollisionGroup: integer = 0) : TgxMapCollectionItem;
Public | function findMap(mapFreeForm: TgxFreeForm): TgxMapCollectionItem;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public function addMap(Map: TgxFreeForm; CollisionGroup: integer = 0) : TgxMapCollectionItem;

This item has no description.

Public function findMap(mapFreeForm: TgxFreeForm): TgxMapCollectionItem;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.


GXSysHelp v.2.5: GXS.FPSMovement: Class TgxFPSMovementManager

Class TgxFPSMovementManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TgxFPSMovementManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxFPSMovementManager

Overview

Fields

Private | FNavigator: TgxNavigator;
Private | FDisplayTime: integer;
Private | FMovementScale: single;
Private | FMaps: TgxMapCollection;
Private | FScene: TgxScene;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function SphereSweepAndSlide(freeform: TgxFreeForm; behaviour: TgxBFPSMovement; SphereStart: TVector4f; var Velocity, newPosition: TVector4f; sphereRadius: single) : boolean; overload;
Public | procedure SphereSweepAndSlide(behaviour: TgxBFPSMovement; SphereStart: TVector4f; var Velocity, newPosition: TVector4f; sphereRadius: single); overload;
Private | procedure DrawArrows(intPoint, intNormal, Ray: TVector4f; Arrow1, Arrow2: TgxArrowLine);
Private | procedure SetNavigator(value: TgxNavigator);
Private | procedure setScene(value: TgxScene);

Properties

Published | property DisplayTime: integer read FDisplayTime write FDisplayTime;
Published | property Maps: TgxMapCollection read FMaps write FMaps;
Published | property MovementScale: single read FMovementScale write FMovementScale;
Published | property Navigator: TgxNavigator read FNavigator write SetNavigator;
Published | property Scene: TgxScene read FScene write setScene;

Description

Fields

Private FNavigator: TgxNavigator;

This item has no description.

Private FDisplayTime: integer;

This item has no description.

Private FMovementScale: single;

This item has no description.

Private FMaps: TgxMapCollection;

This item has no description.

Private FScene: TgxScene;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function SphereSweepAndSlide(freeform: TgxFreeForm; behaviour: TgxBFPSMovement; SphereStart: TVector4f; var Velocity, newPosition: TVector4f; sphereRadius: single) : boolean; overload;

Basic idea is to OctreeSphereSweepIntersect to plane, update position then change velocity to slide along the plane Camera can collide with multiple planes (e.g. floor + multiple walls + ceiling) limit iterations to 4 or 5 for now, may need to be higher for more complex maps or fast motion

Public procedure SphereSweepAndSlide(behaviour: TgxBFPSMovement; SphereStart: TVector4f; var Velocity, newPosition: TVector4f; sphereRadius: single); overload;

This item has no description.

Private procedure DrawArrows(intPoint, intNormal, Ray: TVector4f; Arrow1, Arrow2: TgxArrowLine);

This item has no description.

Private procedure SetNavigator(value: TgxNavigator);

This item has no description.

Private procedure setScene(value: TgxScene);

This item has no description.

Properties

Published property DisplayTime: integer read FDisplayTime write FDisplayTime;

Display Time for the arrow lines.

Published property Maps: TgxMapCollection read FMaps write FMaps;

This item has no description.

Published property MovementScale: single read FMovementScale write FMovementScale;

This item has no description.

Published property Navigator: TgxNavigator read FNavigator write SetNavigator;

This item has no description.

Published property Scene: TgxScene read FScene write setScene;


GXSysHelp v.2.5: GXS.FPSMovement: Class TgxBFPSMovement

Class TgxBFPSMovement

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FPSMovement

Declaration

type TgxBFPSMovement = class(TgxBehaviour)

Description

This item has no description. Showing description inherited from TgxBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBFPSMovement

Overview

Fields

Private | FManager: TgxFPSMovementManager;
Private | CollisionStates: TCollisionStates;
Private | ArrowLine1: TgxArrowLine;
Private | ArrowLine2: TgxArrowLine;
Private | ArrowLine3: TgxArrowLine;
Private | ArrowLine4: TgxArrowLine;
Private | ArrowLine5: TgxArrowLine;
Private | ArrowLine6: TgxArrowLine;
Private | dirGl: TgxDirectOpenGL;
Private | tickCount: Int64;
Private | oldPosition: TVector4f;
Private | FGravityEnabled: boolean;
Private | FSphereRadius: single;
Private | FShowArrows: boolean;
Private | FCollisionGroup: integer;
Private | FManagerName: string;
Public | Velocity: TVector4f;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | Procedure MoveForward(Distance: single);
Public | Procedure StrafeHorizontal(Distance: single);
Public | Procedure StrafeVertical(Distance: single);
Public | Procedure Straighten;
Public | Procedure TurnHorizontal(Angle: single);
Public | Procedure TurnVertical(Angle: single);
Private | procedure RenderArrowLines(Sender: TObject; var rci: TgxRenderContextInfo);
Private | procedure setShowArrows(value: boolean);

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;
Published | property Manager: TgxFPSMovementManager read FManager write FManager;
Published | property ShowArrows: boolean read FShowArrows write setShowArrows;
Published | property sphereRadius: single read FSphereRadius write FSphereRadius;

Description

Fields

Private FManager: TgxFPSMovementManager;

This item has no description.

Private CollisionStates: TCollisionStates;

This item has no description.

Private ArrowLine1: TgxArrowLine;

This item has no description.

Private ArrowLine2: TgxArrowLine;

This item has no description.

Private ArrowLine3: TgxArrowLine;

This item has no description.

Private ArrowLine4: TgxArrowLine;

This item has no description.

Private ArrowLine5: TgxArrowLine;

This item has no description.

Private ArrowLine6: TgxArrowLine;

This item has no description.

Private dirGl: TgxDirectOpenGL;

This item has no description.

Private tickCount: Int64;

This item has no description.

Private oldPosition: TVector4f;

This item has no description.

Private FGravityEnabled: boolean;

This item has no description.

Private FSphereRadius: single;

This item has no description.

Private FShowArrows: boolean;

This item has no description.

Private FCollisionGroup: integer;

This item has no description.

Private FManagerName: string;

This item has no description.

Public Velocity: TVector4f;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public Procedure MoveForward(Distance: single);

This item has no description.

Public Procedure StrafeHorizontal(Distance: single);

This item has no description.

Public Procedure StrafeVertical(Distance: single);

This item has no description.

Public Procedure Straighten;

This item has no description.

Public Procedure TurnHorizontal(Angle: single);

This item has no description.

Public Procedure TurnVertical(Angle: single);

This item has no description.

Private procedure RenderArrowLines(Sender: TObject; var rci: TgxRenderContextInfo);

This item has no description.

Private procedure setShowArrows(value: boolean);

This item has no description.

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;

Indicates the collision group of this behaviour. A Collision Group is a set of logical maps and movers that can collide between themselves (i.e. a Behaviour with group 1 can only collide with maps that are also on group 1)

Published property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;

This item has no description.

Published property Manager: TgxFPSMovementManager read FManager write FManager;

This item has no description.

Published property ShowArrows: boolean read FShowArrows write setShowArrows;

Show Arrows and trailing for debuging.

Published property sphereRadius: single read FSphereRadius write FSphereRadius;

Radius to execute the testing with. A value < 0 indicates to use the boundingSphereRadius of the object.


GXSysHelp v.2.5: GXS.FullScreenViewer

Unit GXS.FullScreenViewer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Messages
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Types
  • FMX.Forms
  • FMX.Controls
  • FMX.Menus
  • GXS.Scene
  • GXS.Context
  • GXS.SceneViewer
  • GXS.WinContext
  • GXS.ImageUtils
  • GXS.Screen

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFullScreenViewer |

Functions and Procedures

procedure Register;

Types

TgxScreenDepth = (...);

Description

Functions and Procedures

procedure Register;

This item has no description.

Types

TgxScreenDepth = (...);

This item has no description.

Values
  • sd8bits
  • sd16bits
  • sd24bits
  • sd32bits


GXSysHelp v.2.5: GXS.FullScreenViewer: Class TgxFullScreenViewer

Class TgxFullScreenViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.FullScreenViewer

Declaration

type TgxFullScreenViewer = class(TgxNonVisualViewer)

Description

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNonVisualViewer
  • TgxFullScreenViewer

Overview

Fields

Private | FFormIsOwned: Boolean;
Private | FForm: TForm;
Private | FOwnDC: THandle;
Private | FScreenDepth: TgxScreenDepth;
Private | FActive: Boolean;
Private | FSwitchedResolution: Boolean;
Private | FManualRendering: Boolean;
Private | FUpdateCount: Integer;
Private | FOnMouseDown: TMouseEvent;
Private | FOnMouseUp: TMouseEvent;
Private | FOnMouseMove: TMouseMoveEvent;
Private | FOnMouseWheel: TMouseWheelEvent;
Private | FOnMouseWheelDown: TMouseWheelEvent;
Private | FOnMouseWheelUp: TMouseWheelEvent;
Private | FOnClick: TNotifyEvent;
Private | FOnDblClick: TNotifyEvent;
Private | FOnKeyDown: TKeyEvent;
Private | FOnKeyUp: TKeyEvent;
Private | FOnKeyPress: TKeyEvent;
Private | FOnClose: TCloseEvent;
Private | FOnCloseQuery: TCloseQueryEvent;
Private | FStayOnTop: Boolean;
Private | FVSync: TgxSyncMode;
Private | FRefreshRate: Integer;
Private | FPopupMenu: TPopupMenu;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): String;
Public | function LastFrameTime: Single;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure ReActivate;
Public | procedure Render(baseObject: TgxBaseSceneObject = nil); override;
Public | procedure ResetPerformanceMonitor;
Public | procedure UseCurrentResolution;
Private | procedure SetActive(const val: Boolean);
Private | procedure SetForm(aVal: TForm);
Private | procedure SetManualRendering(const val: Boolean);
Private | procedure SetOnClick(const val: TNotifyEvent);
Private | procedure SetOnClose(const val: TCloseEvent);
Private | procedure SetOnCloseQuery(const val: TCloseQueryEvent);
Private | procedure SetOnDblClick(const val: TNotifyEvent);
Private | procedure SetOnKeyDown(const val: TKeyEvent);
Private | procedure SetOnKeyPress(const val: TKeyEvent);
Private | procedure SetOnKeyUp(const val: TKeyEvent);
Private | procedure SetOnMouseDown(const val: TMouseEvent);
Private | procedure SetOnMouseMove(const val: TMouseMoveEvent);
Private | procedure SetOnMouseUp(const val: TMouseEvent);
Private | procedure SetOnMouseWheel(const val: TMouseWheelEvent);
Private | procedure SetOnMouseWheelDown(const val: TMouseWheelEvent);
Private | procedure SetOnMouseWheelUp(const val: TMouseWheelEvent);
Private | procedure SetPopupMenu(const val: TPopupMenu);
Private | procedure SetScreenDepth(const val: TgxScreenDepth);
Private | procedure SetStayOnTop(const val: Boolean);

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Form: TForm read FForm write SetForm;
Public | property Handle: TWindowHandle read GetHandle;
Published | property ManualRendering: Boolean read FManualRendering write SetManualRendering;
Published | property OnClick: TNotifyEvent read FOnClick write SetOnClick;
Published | property OnClose: TCloseEvent read FOnClose write SetOnClose;
Published | property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;
Published | property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;
Published | property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;
Published | property OnKeyPress: TKeyEvent read FOnKeyPress write SetOnKeyPress;
Published | property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;
Published | property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;
Published | property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;
Published | property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;
Published | property OnMouseWheelDown: TMouseWheelEvent read FOnMouseWheelDown write SetOnMouseWheelDown;
Published | property OnMouseWheelUp: TMouseWheelEvent read FOnMouseWheelUp write SetOnMouseWheelUp;
Published | property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;
Published | property RefreshRate: Integer read FRefreshRate write FRefreshRate;
Public | property RenderDC: THandle read FOwnDC;
Published | property ScreenDepth: TgxScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;
Published | property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;
Published | property VSync: TgxSyncMode read FVSync write FVSync default vsmSync;

Description

Fields

Private FFormIsOwned: Boolean;

This item has no description.

Private FForm: TForm;

This item has no description.

Private FOwnDC: THandle;

This item has no description.

Private FScreenDepth: TgxScreenDepth;

in VCL HWND;

Private FActive: Boolean;

This item has no description.

Private FSwitchedResolution: Boolean;

This item has no description.

Private FManualRendering: Boolean;

This item has no description.

Private FUpdateCount: Integer;

This item has no description.

Private FOnMouseDown: TMouseEvent;

This item has no description.

Private FOnMouseUp: TMouseEvent;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Private FOnMouseWheel: TMouseWheelEvent;

This item has no description.

Private FOnMouseWheelDown: TMouseWheelEvent;

in VCL TMouseWheelEvent;

Private FOnMouseWheelUp: TMouseWheelEvent;

in VCL TMouseWheelUpDownEvent;

Private FOnClick: TNotifyEvent;

in VCL TMouseWheelUpDownEvent;

Private FOnDblClick: TNotifyEvent;

in VCL TMouseWheelUpDownEvent;

Private FOnKeyDown: TKeyEvent;

This item has no description.

Private FOnKeyUp: TKeyEvent;

This item has no description.

Private FOnKeyPress: TKeyEvent;

This item has no description.

Private FOnClose: TCloseEvent;

In VCL TKeyPressEvent;

Private FOnCloseQuery: TCloseQueryEvent;

This item has no description.

Private FStayOnTop: Boolean;

This item has no description.

Private FVSync: TgxSyncMode;

This item has no description.

Private FRefreshRate: Integer;

This item has no description.

Private FPopupMenu: TPopupMenu;

FCursor: TCursor;

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FramesPerSecond: Single;

This item has no description.

Public function FramesPerSecondText(decimals: Integer = 1): String;

This item has no description.

Public function LastFrameTime: Single;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure ReActivate;

This item has no description.

Public procedure Render(baseObject: TgxBaseSceneObject = nil); override;

This item has no description.

Public procedure ResetPerformanceMonitor;

This item has no description.

Public procedure UseCurrentResolution;

Adjusts property so that current resolution will be used. Call this method if you want to make sure video mode isn't switched.

Private procedure SetActive(const val: Boolean);

This item has no description.

Private procedure SetForm(aVal: TForm);

This item has no description.

Private procedure SetManualRendering(const val: Boolean);

This item has no description.

Private procedure SetOnClick(const val: TNotifyEvent);

in VCL TMouseWheelUpDownEvent

Private procedure SetOnClose(const val: TCloseEvent);

This item has no description.

Private procedure SetOnCloseQuery(const val: TCloseQueryEvent);

This item has no description.

Private procedure SetOnDblClick(const val: TNotifyEvent);

This item has no description.

Private procedure SetOnKeyDown(const val: TKeyEvent);

This item has no description.

Private procedure SetOnKeyPress(const val: TKeyEvent);

This item has no description.

Private procedure SetOnKeyUp(const val: TKeyEvent);

This item has no description.

Private procedure SetOnMouseDown(const val: TMouseEvent);

This item has no description.

Private procedure SetOnMouseMove(const val: TMouseMoveEvent);

This item has no description.

Private procedure SetOnMouseUp(const val: TMouseEvent);

This item has no description.

Private procedure SetOnMouseWheel(const val: TMouseWheelEvent);

This item has no description.

Private procedure SetOnMouseWheelDown(const val: TMouseWheelEvent);

This item has no description.

Private procedure SetOnMouseWheelUp(const val: TMouseWheelEvent);

in VCL TMouseWheelUpDownEvent

Private procedure SetPopupMenu(const val: TPopupMenu);

procedure SetCursor(const val: TCursor);

Private procedure SetScreenDepth(const val: TgxScreenDepth);

This item has no description.

Private procedure SetStayOnTop(const val: Boolean);

in VCL TKeyPressEvent

Properties

Public property Active: Boolean read FActive write SetActive;

Activates/deactivates full screen mode.

Published property Form: TForm read FForm write SetForm;

HWND

Public property Handle: TWindowHandle read GetHandle;

Read access to the underlying form handle. Returns 0 (zero) if the viewer is not active or has not yet instantiated its form.

Published property ManualRendering: Boolean read FManualRendering write SetManualRendering;

This item has no description.

Published property OnClick: TNotifyEvent read FOnClick write SetOnClick;

This item has no description.

Published property OnClose: TCloseEvent read FOnClose write SetOnClose;

This item has no description.

Published property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;

This item has no description.

Published property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;

This item has no description.

Published property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;

This item has no description.

Published property OnKeyPress: TKeyEvent read FOnKeyPress write SetOnKeyPress;

This item has no description.

Published property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;

This item has no description.

Published property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;

This item has no description.

Published property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;

This item has no description.

Published property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;

This item has no description.

Published property OnMouseWheelDown: TMouseWheelEvent read FOnMouseWheelDown write SetOnMouseWheelDown;

This item has no description.

Published property OnMouseWheelUp: TMouseWheelEvent read FOnMouseWheelUp write SetOnMouseWheelUp;

This item has no description.

Published property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;

property Cursor: TCursor read FCursor write SetCursor default crDefault;

Published property RefreshRate: Integer read FRefreshRate write FRefreshRate;

Screen refresh rate. Use zero for system default. This property allows you to work around the winxp bug that limits uses a refresh rate of 60hz when changeing resolution. it is however suggested to give the user the opportunity to adjust it instead of having a fixed value (expecially beyond 75hz or for resolutions beyond 1024x768). the value will be automatically clamped to the highest value *reported* compatible with the monitor.

Public property RenderDC: THandle read FOwnDC;

This item has no description.

Published property ScreenDepth: TgxScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;

Requested ScreenDepth.

Published property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;

Specifies if the underlying form is "fsStayOnTop". The benefit of StayOnTop is that it hides the windows bar and other background windows. The "fsStayOnTop" is automatically switched off/on when the underlying form loses/gains focus. It is recommended not to use StayOnTop while running in the IDE or during the debugging phase.

Published property VSync: TgxSyncMode read FVSync write FVSync default vsmSync;

Specifies if the refresh should be synchronized with the VSync signal. If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.


GXSysHelp v.2.5: GXS.GameMenu

Unit GXS.GameMenu

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.Coordinates
  • GXS.Material
  • GXS.BitmapFont
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Canvas
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGameMenu |

Types

TgxGameMenuScale = (...);

Description

Types

TgxGameMenuScale = (...);

This item has no description.

Values
  • gmsNormal
  • gms1024x768


GXSysHelp v.2.5: GXS.GameMenu: Class TgxGameMenu

Class TgxGameMenu

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GameMenu

Declaration

type TgxGameMenu = class(TgxSceneObject, IgxMaterialLibrarySupported)

Description

Classic game menu interface made of several lines.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxGameMenu

Overview

Fields

Private | FItems: TStrings;
Private | FSelected: Integer;
Private | FFont: TgxCustomBitmapFont;
Private | FMarginVert: Integer;
Private | FMarginHorz: Integer;
Private | FSpacing: Integer;
Private | FMenuScale: TgxGameMenuScale;
Private | FBackColor: TgxColor;
Private | FInactiveColor: TgxColor;
Private | FActiveColor: TgxColor;
Private | FDisabledColor: TgxColor;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FTitleMaterialName: TgxLibMaterialName;
Private | FTitleWidth: Integer;
Private | FTitleHeight: Integer;
Private | FOnSelectedChanged: TNotifyEvent;
Private | FBoxTop: Integer;
Private | FBoxBottom: Integer;
Private | FBoxLeft: Integer;
Private | FBoxRight: Integer;
Private | FMenuTop: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure MouseMenuSelect(const X, Y: Integer);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SelectNext;
Public | procedure SelectPrev;

Properties

Published | property ActiveColor: TgxColor read FActiveColor write SetActiveColor;
Published | property BackColor: TgxColor read FBackColor write SetBackColor;
Published | property Behaviours;
Published | property BoxBottom: Integer read FBoxBottom;
Published | property BoxLeft: Integer read FBoxLeft;
Published | property BoxRight: Integer read FBoxRight;
Published | property BoxTop: Integer read FBoxTop;
Published | property DisabledColor: TgxColor read FDisabledColor write SetDisabledColor;
Published | property Effects;
Public | property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;
Published | property Font: TgxCustomBitmapFont read FFont write SetFont;
Published | property InactiveColor: TgxColor read FInactiveColor write SetInactiveColor;
Published | property Items: TStrings read FItems write SetItems;
Published | property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;
Published | property MarginVert: Integer read FMarginVert write SetMarginVert default 16;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MenuScale: TgxGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;
Published | property MenuTop: Integer read FMenuTop;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;
Published | property Position;
Published | property Selected: Integer read FSelected write SetSelected default -1;
Public | property SelectedText: string read GetSelectedText;
Published | property Spacing: Integer read FSpacing write SetSpacing default 16;
Published | property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;
Published | property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;
Published | property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;
Published | property VisibilityCulling;
Published | property Visible;

Description

Fields

Private FItems: TStrings;

This item has no description.

Private FSelected: Integer;

This item has no description.

Private FFont: TgxCustomBitmapFont;

This item has no description.

Private FMarginVert: Integer;

This item has no description.

Private FMarginHorz: Integer;

This item has no description.

Private FSpacing: Integer;

This item has no description.

Private FMenuScale: TgxGameMenuScale;

This item has no description.

Private FBackColor: TgxColor;

This item has no description.

Private FInactiveColor: TgxColor;

This item has no description.

Private FActiveColor: TgxColor;

This item has no description.

Private FDisabledColor: TgxColor;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FTitleMaterialName: TgxLibMaterialName;

This item has no description.

Private FTitleWidth: Integer;

This item has no description.

Private FTitleHeight: Integer;

This item has no description.

Private FOnSelectedChanged: TNotifyEvent;

This item has no description.

Private FBoxTop: Integer;

This item has no description.

Private FBoxBottom: Integer;

This item has no description.

Private FBoxLeft: Integer;

This item has no description.

Private FBoxRight: Integer;

This item has no description.

Private FMenuTop: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

implementing IGLMaterialLibrarySupported

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure MouseMenuSelect(const X, Y: Integer);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure SelectNext;

This item has no description.

Public procedure SelectPrev;

This item has no description.

Properties

Published property ActiveColor: TgxColor read FActiveColor write SetActiveColor;

This item has no description.

Published property BackColor: TgxColor read FBackColor write SetBackColor;

This item has no description.

Published property Behaviours;

This item has no description.

Published property BoxBottom: Integer read FBoxBottom;

This item has no description.

Published property BoxLeft: Integer read FBoxLeft;

This item has no description.

Published property BoxRight: Integer read FBoxRight;

This item has no description.

Published property BoxTop: Integer read FBoxTop;

these are the extents of the menu

Published property DisabledColor: TgxColor read FDisabledColor write SetDisabledColor;

This item has no description.

Published property Effects;

This item has no description.

Public property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;

This item has no description.

Published property Font: TgxCustomBitmapFont read FFont write SetFont;

This item has no description.

Published property InactiveColor: TgxColor read FInactiveColor write SetInactiveColor;

This item has no description.

Published property Items: TStrings read FItems write SetItems;

This item has no description.

Published property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;

This item has no description.

Published property MarginVert: Integer read FMarginVert write SetMarginVert default 16;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MenuScale: TgxGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;

This item has no description.

Published property MenuTop: Integer read FMenuTop;

this is the top of the first menu item

Published property ObjectsSorting;

publish other stuff from TgxBaseSceneObject

Published property OnProgress;

This item has no description.

Published property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;

This item has no description.

Published property Position;

This item has no description.

Published property Selected: Integer read FSelected write SetSelected default -1;

This item has no description.

Public property SelectedText: string read GetSelectedText;

This item has no description.

Published property Spacing: Integer read FSpacing write SetSpacing default 16;

This item has no description.

Published property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;

This item has no description.

Published property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;

This item has no description.

Published property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.GeomObjects

Unit GXS.GeomObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Math
  • System.Classes
  • GXS.Scene
  • GXS.State
  • GXS.PersistentClasses
  • GLScene.VectorTypes
  • GXS.Silhouette
  • GLScene.GeometryBB
  • GLScene.VectorGeometry
  • GLScene.Polynomials
  • GXS.VectorFileObjects
  • GLScene.PipelineTransform
  • GXS.Material
  • GXS.Texture
  • GXS.Context
  • GXS.Objects
  • GXS.Mesh
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTetrahedron |
Class TgxOctahedron |
Class TgxHexahedron |
Class TgxDodecahedron |
Class TgxIcosahedron |
Class TgxDisk |
Class TgxCylinderBase |
Class TgxCone |
Class TgxCylinder |
Class TgxCapsule |
Class TgxAnnulus |
Class TgxTorus |
Class TgxArrowLine |
Class TgxArrowArc |
Class TgxPolygon |
Class TgxFrustrum |
Class TgxTeapot |

Types

TFrustrumPart = (...);
TFrustrumParts = set of TFrustrumPart;
TgxAnnulusPart = (...);
TgxAnnulusParts = set of TgxAnnulusPart;
TgxArrowArcPart = (...);
TgxArrowArcParts = set of TgxArrowArcPart;
TgxArrowHeadStyle = (...);
TgxArrowLinePart = (...);
TgxArrowLineParts = set of TgxArrowLinePart;
TgxConePart = (...);
TgxConeParts = set of TgxConePart;
TgxCylinderAlignment = (...);
TgxCylinderPart = (...);
TgxCylinderParts = set of TgxCylinderPart;
TgxPolygonPart = (...);
TgxPolygonParts = set of TgxPolygonPart;
TgxTorusPart = (...);
TgxTorusParts = set of TgxTorusPart;

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];

Description

Types

TFrustrumPart = (...);

This item has no description.

Values
  • fpTop
  • fpBottom
  • fpFront
  • fpBack
  • fpLeft
  • fpRight
TFrustrumParts = set of TFrustrumPart;

This item has no description.

TgxAnnulusPart = (...);

This item has no description.

Values
  • anInnerSides
  • anOuterSides
  • anBottom
  • anTop
TgxAnnulusParts = set of TgxAnnulusPart;

This item has no description.

TgxArrowArcPart = (...);

This item has no description.

Values
  • aaArc
  • aaTopArrow
  • aaBottomArrow
TgxArrowArcParts = set of TgxArrowArcPart;

This item has no description.

TgxArrowHeadStyle = (...);

Arrow Head Stacking Style

Values
  • ahssStacked
  • ahssCentered
  • ahssIncluded
TgxArrowLinePart = (...);

This item has no description.

Values
  • alLine
  • alTopArrow
  • alBottomArrow
TgxArrowLineParts = set of TgxArrowLinePart;

This item has no description.

TgxConePart = (...);

This item has no description.

Values
  • coSides
  • coBottom
TgxConeParts = set of TgxConePart;

This item has no description.

TgxCylinderAlignment = (...);

This item has no description.

Values
  • caCenter
  • caTop
  • caBottom
TgxCylinderPart = (...);

This item has no description.

Values
  • cySides
  • cyBottom
  • cyTop
TgxCylinderParts = set of TgxCylinderPart;

This item has no description.

TgxPolygonPart = (...);

This item has no description.

Values
  • ppTop
  • ppBottom
TgxPolygonParts = set of TgxPolygonPart;

This item has no description.

TgxTorusPart = (...);

This item has no description.

Values
  • toSides
  • toStartDisk
  • toStopDisk
TgxTorusParts = set of TgxTorusPart;

This item has no description.

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxTetrahedron

Class TgxTetrahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxTetrahedron = class(TgxBaseMesh)

Description

The tetrahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxTetrahedron

Overview

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxOctahedron

Class TgxOctahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxOctahedron = class(TgxBaseMesh)

Description

The octahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxOctahedron

Overview

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxHexahedron

Class TgxHexahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxHexahedron = class(TgxBaseMesh)

Description

The hexahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxHexahedron

Overview

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxDodecahedron

Class TgxDodecahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxDodecahedron = class(TgxBaseMesh)

Description

The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxDodecahedron

Overview

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxIcosahedron

Class TgxIcosahedron

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxIcosahedron = class(TgxBaseMesh)

Description

The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxIcosahedron

Overview

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxDisk

Class TgxDisk

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxDisk = class(TgxQuadricObject)

Description

A Disk object. The disk may not be complete, it can have a hole (controled by the InnerRadius property) and can only be a slice (controled by the StartAngle and SweepAngle properties).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxDisk

Overview

Fields

Private | FStartAngle: Single;
Private | FSweepAngle: Single;
Private | FOuterRadius: Single;
Private | FInnerRadius: Single;
Private | FSlices: Integer;
Private | FLoops: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Private | procedure SetInnerRadius(const aValue: Single);
Private | procedure SetLoops(aValue: Integer);
Private | procedure SetOuterRadius(const aValue: Single);
Private | procedure SetSlices(aValue: Integer);
Private | procedure SetStartAngle(const aValue: Single);
Private | procedure SetSweepAngle(const aValue: Single);

Properties

Published | property InnerRadius: Single read FInnerRadius write SetInnerRadius;
Published | property Loops: Integer read FLoops write SetLoops default 2;
Published | property OuterRadius: Single read FOuterRadius write SetOuterRadius;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property SweepAngle: Single read FSweepAngle write SetSweepAngle;

Description

Fields

Private FStartAngle: Single;

This item has no description.

Private FSweepAngle: Single;

This item has no description.

Private FOuterRadius: Single;

This item has no description.

Private FInnerRadius: Single;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FLoops: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetInnerRadius(const aValue: Single);

This item has no description.

Private procedure SetLoops(aValue: Integer);

This item has no description.

Private procedure SetOuterRadius(const aValue: Single);

This item has no description.

Private procedure SetSlices(aValue: Integer);

This item has no description.

Private procedure SetStartAngle(const aValue: Single);

This item has no description.

Private procedure SetSweepAngle(const aValue: Single);

This item has no description.

Properties

Published property InnerRadius: Single read FInnerRadius write SetInnerRadius;

Allows defining a "hole" in the disk.

Published property Loops: Integer read FLoops write SetLoops default 2;

Number of radial mesh subdivisions.

Published property OuterRadius: Single read FOuterRadius write SetOuterRadius;

Outer radius for the disk. If you leave InnerRadius at 0, this is the disk radius.

Published property Slices: Integer read FSlices write SetSlices default 16;

Number of mesh slices. For instance, if Slices=6, your disk will look like an hexagon.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property SweepAngle: Single read FSweepAngle write SetSweepAngle;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxCylinderBase

Class TgxCylinderBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxCylinderBase = class(TgxQuadricObject)

Description

Base class to cylinder-like objects. Introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase

Overview

Fields

Private | FBottomRadius: Single;
Private | FSlices: GLint;
Private | FStacks: GLint;
Private | FLoops: GLint;
Private | FHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BottomRadius: Single read FBottomRadius write SetBottomRadius;
Published | property Height: Single read FHeight write SetHeight;
Published | property Loops: GLint read FLoops write SetLoops default 1;
Published | property Slices: GLint read FSlices write SetSlices default 16;
Published | property Stacks: GLint read FStacks write SetStacks default 4;

Description

Fields

Private FBottomRadius: Single;

This item has no description.

Private FSlices: GLint;

This item has no description.

Private FStacks: GLint;

This item has no description.

Private FLoops: GLint;

This item has no description.

Private FHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property BottomRadius: Single read FBottomRadius write SetBottomRadius;

This item has no description.

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property Loops: GLint read FLoops write SetLoops default 1;

Number of concentric rings for top/bottom disk(s).

Published property Slices: GLint read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: GLint read FStacks write SetStacks default 4;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxCone

Class TgxCone

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxCone = class(TgxCylinderBase)

Description

A cone object

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxCone

Overview

Fields

Private FParts: TgxConeParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published property Parts: TgxConeParts read FParts write SetParts default [coSides, coBottom];

Description

Fields

Private FParts: TgxConeParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TgxConeParts read FParts write SetParts default [coSides, coBottom];


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxCylinder

Class TgxCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxCylinder = class(TgxCylinderBase)

Description

Cylinder object, can also be used to make truncated cones

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxCylinder

Overview

Fields

Private | FParts: TgxCylinderParts;
Private | FTopRadius: Single;
Private | FAlignment: TgxCylinderAlignment;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Align(const startObj, endObj: TgxBaseSceneObject); overload;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startPoint, endPoint: TVector4f); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Alignment: TgxCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Parts: TgxCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TgxCylinderParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private FAlignment: TgxCylinderAlignment;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Align(const startObj, endObj: TgxBaseSceneObject); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TAffineVector); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TVector4f); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Alignment: TgxCylinderAlignment read FAlignment write SetAlignment default caCenter;

This item has no description.

Published property Parts: TgxCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxCapsule

Class TgxCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxCapsule = class(TgxSceneObject)

Description

Capsule object, can also be used to make truncated cones

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxCapsule

Overview

Fields

Private | FParts: TgxCylinderParts;
Private | FRadius: Single;
Private | FSlices: Integer;
Private | FStacks: Integer;
Private | FHeight: Single;
Private | FAlignment: TgxCylinderAlignment;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Align(const startObj, endObj: TgxBaseSceneObject); overload;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startPoint, endPoint: TVector4f); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Alignment: TgxCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Height: Single read FHeight write SetHeight;
Published | property Parts: TgxCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: GLint read FSlices write SetSlices;
Published | property Stacks: GLint read FStacks write SetStacks;

Description

Fields

Private FParts: TgxCylinderParts;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FAlignment: TgxCylinderAlignment;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Align(const startObj, endObj: TgxBaseSceneObject); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TAffineVector); overload;

This item has no description.

Public procedure Align(const startPoint, endPoint: TVector4f); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Alignment: TgxCylinderAlignment read FAlignment write SetAlignment default caCenter;

This item has no description.

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property Parts: TgxCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: GLint read FSlices write SetSlices;

This item has no description.

Published property Stacks: GLint read FStacks write SetStacks;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxAnnulus

Class TgxAnnulus

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxAnnulus = class(TgxCylinderBase)

Description

An annulus is a cylinder that can be made hollow (pipe-like).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxAnnulus

Overview

Fields

Private | FParts: TgxAnnulusParts;
Private | FBottomInnerRadius: Single;
Private | FTopInnerRadius: Single;
Private | FTopRadius: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property BottomInnerRadius: Single read FBottomInnerRadius write SetBottomInnerRadius;
Published | property Parts: TgxAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];
Published | property TopInnerRadius: Single read FTopInnerRadius write SetTopInnerRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TgxAnnulusParts;

This item has no description.

Private FBottomInnerRadius: Single;

This item has no description.

Private FTopInnerRadius: Single;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property BottomInnerRadius: Single read FBottomInnerRadius write SetBottomInnerRadius;

This item has no description.

Published property Parts: TgxAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];

This item has no description.

Published property TopInnerRadius: Single read FTopInnerRadius write SetTopInnerRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxTorus

Class TgxTorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxTorus = class(TgxSceneObject)

Description

A Torus object

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTorus

Overview

Fields

Private | FParts: TgxTorusParts;
Private | FRings: Cardinal;
Private | FSides: Cardinal;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FMinorRadius: Single;
Private | FMajorRadius: Single;
Private | FMesh: array of array of TVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property MajorRadius: Single read FMajorRadius write SetMajorRadius;
Published | property MinorRadius: Single read FMinorRadius write SetMinorRadius;
Published | property Parts: TgxTorusParts read FParts write SetParts default [toSides];
Published | property Rings: Cardinal read FRings write SetRings default 25;
Published | property Sides: Cardinal read FSides write SetSides default 15;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;

Description

Fields

Private FParts: TgxTorusParts;

This item has no description.

Private FRings: Cardinal;

This item has no description.

Private FSides: Cardinal;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FMinorRadius: Single;

This item has no description.

Private FMajorRadius: Single;

This item has no description.

Private FMesh: array of array of TVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property MajorRadius: Single read FMajorRadius write SetMajorRadius;

This item has no description.

Published property MinorRadius: Single read FMinorRadius write SetMinorRadius;

This item has no description.

Published property Parts: TgxTorusParts read FParts write SetParts default [toSides];

This item has no description.

Published property Rings: Cardinal read FRings write SetRings default 25;

This item has no description.

Published property Sides: Cardinal read FSides write SetSides default 15;

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxArrowLine

Class TgxArrowLine

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxArrowLine = class(TgxCylinderBase)

Description

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxArrowLine

Overview

Fields

Private | FParts: TgxArrowLineParts;
Private | FTopRadius: Single;
Private | fTopArrowHeadHeight: Single;
Private | fTopArrowHeadRadius: Single;
Private | fBottomArrowHeadHeight: Single;
Private | fBottomArrowHeadRadius: Single;
Private | FHeadStackingStyle: TgxArrowHeadStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TgxArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TgxArrowLineParts read FParts write SetParts default [alLine, alTopArrow];
Published | property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private FParts: TgxArrowLineParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private fTopArrowHeadHeight: Single;

This item has no description.

Private fTopArrowHeadRadius: Single;

This item has no description.

Private fBottomArrowHeadHeight: Single;

This item has no description.

Private fBottomArrowHeadRadius: Single;

This item has no description.

Private FHeadStackingStyle: TgxArrowHeadStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;

This item has no description.

Published property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;

This item has no description.

Published property HeadStackingStyle: TgxArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;

This item has no description.

Published property Parts: TgxArrowLineParts read FParts write SetParts default [alLine, alTopArrow];

This item has no description.

Published property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;

This item has no description.

Published property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxArrowArc

Class TgxArrowArc

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxArrowArc = class(TgxCylinderBase)

Description

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxArrowArc

Overview

Fields

Private | fArcRadius: Single;
Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FParts: TgxArrowArcParts;
Private | FTopRadius: Single;
Private | fTopArrowHeadHeight: Single;
Private | fTopArrowHeadRadius: Single;
Private | fBottomArrowHeadHeight: Single;
Private | fBottomArrowHeadRadius: Single;
Private | FHeadStackingStyle: TgxArrowHeadStyle;
Private | FMesh: array of array of TVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property ArcRadius: Single read fArcRadius write SetArcRadius;
Published | property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TgxArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TgxArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;
Published | property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: Single read FTopRadius write SetTopRadius;

Description

Fields

Private fArcRadius: Single;

This item has no description.

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FParts: TgxArrowArcParts;

This item has no description.

Private FTopRadius: Single;

This item has no description.

Private fTopArrowHeadHeight: Single;

This item has no description.

Private fTopArrowHeadRadius: Single;

This item has no description.

Private fBottomArrowHeadHeight: Single;

This item has no description.

Private fBottomArrowHeadRadius: Single;

This item has no description.

Private FHeadStackingStyle: TgxArrowHeadStyle;

This item has no description.

Private FMesh: array of array of TVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property ArcRadius: Single read fArcRadius write SetArcRadius;

This item has no description.

Published property BottomArrowHeadHeight: Single read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;

This item has no description.

Published property BottomArrowHeadRadius: Single read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;

This item has no description.

Published property HeadStackingStyle: TgxArrowHeadStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;

This item has no description.

Published property Parts: TgxArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;

This item has no description.

Published property TopArrowHeadHeight: Single read fTopArrowHeadHeight write SetTopArrowHeadHeight;

This item has no description.

Published property TopArrowHeadRadius: Single read fTopArrowHeadRadius write SetTopArrowHeadRadius;

This item has no description.

Published property TopRadius: Single read FTopRadius write SetTopRadius;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxPolygon

Class TgxPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxPolygon = class(TgxPolygonBase)

Description

A basic polygon object. The curve is described by the Nodes and SplineMode properties, should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single curve, if you need "complex polygons" with holes, patches and cutouts, see GLMultiPolygon.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPolygonBase
  • TgxPolygon

Overview

Fields

Private FParts: TgxPolygonParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published property Parts: TgxPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Fields

Private FParts: TgxPolygonParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TgxPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Parts of polygon. The 'top' of the polygon is the position were the curve describing the polygon spin counter-clockwise (i.e. right handed convention).


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxFrustrum

Class TgxFrustrum

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxFrustrum = class(TgxSceneObject)

Description

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxFrustrum

Overview

Fields

Private | FApexHeight: Single;
Private | FBaseDepth: Single;
Private | FBaseWidth: Single;
Private | FHeight: Single;
Private | FParts: TFrustrumParts;
Private | FNormalDirection: TgxNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedBoundingBoxUnscaled: TAABB;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function TopDepth: Single;
Public | function TopWidth: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Private | procedure SetApexHeight(const aValue: Single);
Private | procedure SetBaseDepth(const aValue: Single);
Private | procedure SetBaseWidth(const aValue: Single);
Private | procedure SetHeight(const aValue: Single);
Private | procedure SetNormalDirection(aValue: TgxNormalDirection);
Private | procedure SetParts(aValue: TFrustrumParts);

Properties

Published | property ApexHeight: Single read FApexHeight write SetApexHeight stored False;
Published | property BaseDepth: Single read FBaseDepth write SetBaseDepth stored False;
Published | property BaseWidth: Single read FBaseWidth write SetBaseWidth stored False;
Published | property Height: Single read FHeight write SetHeight stored False;
Published | property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TFrustrumParts read FParts write SetParts default cAllFrustrumParts;

Description

Fields

Private FApexHeight: Single;

This item has no description.

Private FBaseDepth: Single;

This item has no description.

Private FBaseWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FParts: TFrustrumParts;

This item has no description.

Private FNormalDirection: TgxNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedBoundingBoxUnscaled: TAABB;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function TopDepth: Single;

This item has no description.

Public function TopWidth: Single;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetApexHeight(const aValue: Single);

This item has no description.

Private procedure SetBaseDepth(const aValue: Single);

This item has no description.

Private procedure SetBaseWidth(const aValue: Single);

This item has no description.

Private procedure SetHeight(const aValue: Single);

This item has no description.

Private procedure SetNormalDirection(aValue: TgxNormalDirection);

This item has no description.

Private procedure SetParts(aValue: TFrustrumParts);

This item has no description.

Properties

Published property ApexHeight: Single read FApexHeight write SetApexHeight stored False;

This item has no description.

Published property BaseDepth: Single read FBaseDepth write SetBaseDepth stored False;

This item has no description.

Published property BaseWidth: Single read FBaseWidth write SetBaseWidth stored False;

This item has no description.

Published property Height: Single read FHeight write SetHeight stored False;

This item has no description.

Published property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Parts: TFrustrumParts read FParts write SetParts default cAllFrustrumParts;


GXSysHelp v.2.5: GXS.GeomObjects: Class TgxTeapot

Class TgxTeapot

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GeomObjects

Declaration

type TgxTeapot = class(TgxSceneObject)

Description

The classic teapot. The only use of this object is as placeholder for testing...

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTeapot

Overview

Fields

Private FGrid: Cardinal;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Description

Fields

Private FGrid: Cardinal;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;


GXSysHelp v.2.5: GXS.Gizmo

Unit GXS.Gizmo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • FMX.TextLayout
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Scene
  • GXS.Color
  • GXS.Objects
  • GXS.Material
  • GXS.GeomObjects
  • GXS.BitmapFont
  • GXS.SceneViewer
  • GXS.VectorFileObjects
  • GXS.ImageUtils
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.Selection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGizmoUndoItem |
Class TgxGizmoUndoCollection |
Class TgxGizmoRayCastHitData |
Class TgxGizmoPickCube |
Class TgxGizmoPickTorus |
Class TgxGizmo |

Types

TgxGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TgxBaseSceneObject; var Accept: Boolean; var Dimensions: TVector4f) of object;
TgxGizmoAxis = (...);
TgxGizmoElement = (...);
TgxGizmoElements = set of TgxGizmoElement;
TgxGizmoOperation = (...);
TgxGizmoPickMode = (...);
TgxGizmoUpdateEvent = procedure(Sender: TObject; Obj: TgxBaseSceneObject; Axis: TgxGizmoAxis; Operation: TgxGizmoOperation; var Vector: TVector4f) of object;
TgxGizmoVisibleInfoLabel = (...);
TgxGizmoVisibleInfoLabels = set of TgxGizmoVisibleInfoLabel;

Description

Types

TgxGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TgxBaseSceneObject; var Accept: Boolean; var Dimensions: TVector4f) of object;

This item has no description.

TgxGizmoAxis = (...);

This item has no description.

Values
  • gaNone
  • gaX
  • gaY
  • gaZ
  • gaXY
  • gaXZ
  • gaYZ
TgxGizmoElement = (...);

This item has no description.

Values
  • geMove
  • geRotate
  • geScale
  • geAxisLabel
  • geObjectInfos
  • geBoundingBox
TgxGizmoElements = set of TgxGizmoElement;

This item has no description.

TgxGizmoOperation = (...);

This item has no description.

Values
  • gopMove
  • gopRotate
  • gopScale
  • gopNone
  • gpMoveGizmo
  • gpRotateGizmo
TgxGizmoPickMode = (...);

This item has no description.

Values
  • pmGetPickedObjects
  • pmRayCast
TgxGizmoUpdateEvent = procedure(Sender: TObject; Obj: TgxBaseSceneObject; Axis: TgxGizmoAxis; Operation: TgxGizmoOperation; var Vector: TVector4f) of object;

This item has no description.

TgxGizmoVisibleInfoLabel = (...);

This item has no description.

Values
  • vliName
  • vliOperation
  • vliCoords
TgxGizmoVisibleInfoLabels = set of TgxGizmoVisibleInfoLabel;


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmoUndoItem

Class TgxGizmoUndoItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmoUndoItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxGizmoUndoItem

Overview

Fields

Private | FOldLibMaterialName: string;
Private | FOldAutoScaling: TgxCoordinates;
Private | FEffectedObject: TgxCustomSceneObject;
Private | FOldMatr: TMatrix4f;
Private | FOldMatrix: TMatrix4f;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignFromObject(const AObject: TgxCustomSceneObject);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Private | procedure SetEffectedObject(const Value: TgxCustomSceneObject);
Private | procedure SetOldAutoScaling(const Value: TgxCoordinates);
Private | procedure SetOldMatrix(const Value: TMatrix4f);

Properties

Published | property EffectedObject: TgxCustomSceneObject read FEffectedObject write SetEffectedObject;
Published | property OldAutoScaling: TgxCoordinates read FOldAutoScaling write SetOldAutoScaling;
Published | property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;
Public | property OldMatrix: TMatrix4f read FOldMatrix write SetOldMatrix;

Description

Fields

Private FOldLibMaterialName: string;

This item has no description.

Private FOldAutoScaling: TgxCoordinates;

This item has no description.

Private FEffectedObject: TgxCustomSceneObject;

This item has no description.

Private FOldMatr: TMatrix4f;

This item has no description.

Private FOldMatrix: TMatrix4f;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignFromObject(const AObject: TgxCustomSceneObject);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;

This item has no description.

Private procedure SetEffectedObject(const Value: TgxCustomSceneObject);

This item has no description.

Private procedure SetOldAutoScaling(const Value: TgxCoordinates);

This item has no description.

Private procedure SetOldMatrix(const Value: TMatrix4f);

This item has no description.

Properties

Published property EffectedObject: TgxCustomSceneObject read FEffectedObject write SetEffectedObject;

This item has no description.

Published property OldAutoScaling: TgxCoordinates read FOldAutoScaling write SetOldAutoScaling;

This item has no description.

Published property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;

This item has no description.

Public property OldMatrix: TMatrix4f read FOldMatrix write SetOldMatrix;

TODO: create a special type for Matrix.


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmoUndoCollection

Class TgxGizmoUndoCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmoUndoCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxGizmoUndoCollection

Overview

Methods

Public | function Add: TgxGizmoUndoItem;
Private | function GetItems(const Index: Integer): TgxGizmoUndoItem;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TgxCustomSceneObject);
Private | procedure SetItems(const Index: Integer; const Value: TgxGizmoUndoItem);

Properties

Public property Items[const Index: Integer]: TgxGizmoUndoItem read GetItems write SetItems;

Description

Methods

Public function Add: TgxGizmoUndoItem;

This item has no description.

Private function GetItems(const Index: Integer): TgxGizmoUndoItem;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveByObject(const AObject: TgxCustomSceneObject);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TgxGizmoUndoItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TgxGizmoUndoItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmoRayCastHitData

Class TgxGizmoRayCastHitData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmoRayCastHitData = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxGizmoRayCastHitData

Overview

Fields

Public | Obj: TgxBaseSceneObject;
Public | Point: TVector4f;

Description

Fields

Public Obj: TgxBaseSceneObject;

This item has no description.

Public Point: TVector4f;


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmoPickCube

Class TgxGizmoPickCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmoPickCube = class(TgxCube)

Description

This item has no description. Showing description inherited from TgxCube.

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TgxFreeForm and a material library.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxCube
  • TgxGizmoPickCube


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmoPickTorus

Class TgxGizmoPickTorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmoPickTorus = class(TgxTorus)

Description

This item has no description. Showing description inherited from TgxTorus.

A Torus object

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTorus
  • TgxGizmoPickTorus


GXSysHelp v.2.5: GXS.Gizmo: Class TgxGizmo

Class TgxGizmo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gizmo

Declaration

type TgxGizmo = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxGizmo

Overview

Fields

Private | _GZObaseGizmo: TgxBaseSceneObject;
Private | _GZOBoundingcube: TgxCube;
Private | _GZOrootHelpers: TgxBaseSceneObject;
Private | _GZOrootLines: TgxBaseSceneObject;
Private | _GZOrootTorus: TgxBaseSceneObject;
Private | _GZOrootCubes: TgxBaseSceneObject;
Private | _GZORootAxisLabel: TgxBaseSceneObject;
Private | _GZORootVisibleInfoLabels: TgxBaseSceneObject;
Private | _GZOlineX: TgxLines;
Private | _GZOlineY: TgxLines;
Private | _GZOlineZ: TgxLines;
Private | _GZOplaneXY: TgxLines;
Private | _GZOplaneXZ: TgxLines;
Private | _GZOplaneYZ: TgxLines;
Private | _GZOTorusX: TgxGizmoPickTorus;
Private | _GZOTorusY: TgxGizmoPickTorus;
Private | _GZOTorusZ: TgxGizmoPickTorus;
Private | _GZOCubeX: TgxGizmoPickCube;
Private | _GZOCubeY: TgxGizmoPickCube;
Private | _GZOCubeZ: TgxGizmoPickCube;
Private | _GZOAxisLabelX: TgxFlatText;
Private | _GZOAxisLabelY: TgxFlatText;
Private | _GZOAxisLabelZ: TgxFlatText;
Private | _GZOVisibleInfoLabels: TgxFlatText;
Private | FRootGizmo: TgxBaseSceneObject;
Private | FSelectedObj: TgxBaseSceneObject;
Private | FOperation: TgxGizmoOperation;
Private | FSelAxis: TgxGizmoAxis;
Private | FBoundingBoxColor: TgxColor;
Private | FSelectedColor: TgxColor;
Private | FVisibleInfoLabelsColor: TgxColor;
Private | FBoundingBoxColorChanged: Boolean;
Private | FVisibleInfoLabelsColorChanged: Boolean;
Private | FForceOperation: Boolean;
Private | FForceAxis: Boolean;
Private | FForceUniformScale: Boolean;
Private | FAutoZoom: Boolean;
Private | FExcludeObjects: Boolean;
Private | FNoZWrite: Boolean;
Private | FEnabled: Boolean;
Private | FAutoZoomFactor: Single;
Private | FZoomFactor: Single;
Private | FMoveCoef: Single;
Private | FRotationCoef: Single;
Private | FViewer: TgxSceneViewer;
Private | FGizmoElements: TgxGizmoElements;
Private | FVisibleVisibleInfoLabels: TgxGizmoVisibleInfoLabels;
Private | FExcludeObjectsList: TStrings;
Private | Moving: Boolean;
Private | Mx: Integer;
Private | My: Integer;
Private | Rx: Integer;
Private | Ry: Integer;
Private | dglEnable: TgxDirectOpenGL;
Private | dglDisable: TgxDirectOpenGL;
Private | dgtEnable: TgxDirectOpenGL;
Private | dgtDisable: TgxDirectOpenGL;
Private | dgcEnable: TgxDirectOpenGL;
Private | dgcDisable: TgxDirectOpenGL;
Private | dglaEnable: TgxDirectOpenGL;
Private | dglaDisable: TgxDirectOpenGL;
Private | dgliEnable: TgxDirectOpenGL;
Private | dgliDisable: TgxDirectOpenGL;
Private | LastMousePos: TVector4f;
Private | ObjDimensions: TVector4f;
Private | FOnBeforeSelect: TgxGizmoAcceptEvent;
Private | FOnBeforeUpdate: TgxGizmoUpdateEvent;
Private | FOnSelectionLost: TNotifyEvent;
Private | FScaleCoef: Single;
Private | FGizmoThickness: Single;
Private | FPickMode: TgxGizmoPickMode;
Private | FInternalRaycastHitData: TList;
Private | FUndoHistory: TgxGizmoUndoCollection;
Private | FLabelFont: TgxCustomBitmapFont;
Public | PickableObjectsWithRayCast: TList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetPickedObjectPoint(const Obj: TgxBaseSceneObject): TVector4f;
Private | function CheckObjectInExcludeList(const Obj: TgxBaseSceneObject): Boolean;
Private | function InternalGetPickedObjects(const X1, Y1, X2, Y2: Integer; const GuessCount: Integer = 8): TgxPickList;
Private | function MouseWorldPos(const X, Y: Integer): TVector4f;
Public | procedure Loaded; override;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SetVisible(const AValue: Boolean);
Public | procedure UndoAdd(const AObject: TgxCustomSceneObject);
Public | procedure UpdateGizmo(const NewDimensions: TVector4f); overload;
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);
Private | procedure ClearInternalRaycastHitData;
Private | procedure DirectGLDisable(Sender: TObject; var Rci: TgxRenderContextInfo);
Private | procedure DirectGLEnable(Sender: TObject; var Rci: TgxRenderContextInfo);
Private | procedure SetBoundingBoxColor(const AValue: TgxColor);
Private | procedure SetExcludeObjectsList(const AValue: TStrings);
Private | procedure SetGizmoElements(const AValue: TgxGizmoElements);
Private | procedure SetGizmoThickness(const Value: Single);
Private | procedure SetGizmoVisibleInfoLabels(const AValue : TgxGizmoVisibleInfoLabels);
Private | procedure SetLabelFont(const Value: TgxCustomBitmapFont);
Private | procedure SetRootGizmo(const AValue: TgxBaseSceneObject);
Private | procedure SetSelectedColor(const AValue: TgxColor);
Private | procedure SetSelectedObj(const Value: TgxBaseSceneObject);
Private | procedure SetViewer(const Value: TgxSceneViewer);
Private | procedure SetVisibleInfoLabelsColor(const AValue: TgxColor);
Private | procedure UpdateVisibleInfoLabels;

Properties

Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;
Published | property BoundingBoxColor: TgxColor read FBoundingBoxColor write SetBoundingBoxColor;
Published | property Enabled: Boolean read FEnabled write FEnabled default False;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property ForceAxis: Boolean read FForceAxis write FForceAxis;
Published | property ForceOperation: Boolean read FForceOperation write FForceoperation;
Published | property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;
Published | property GizmoElements: TgxGizmoElements read FGizmoElements write SetGizmoElements;
Published | property GizmoThickness: Single read FGizmoThickness write SetGizmoThickness;
Published | property LabelFont: TgxCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Published | property OnBeforeSelect: TgxGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;
Published | property OnBeforeUpdate: TgxGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property Operation: TgxGizmoOperation read FOperation write FOperation;
Published | property PickMode: TgxGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;
Public | property RootGizmo: TgxBaseSceneObject read FRootGizmo write SetRootGizmo;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published | property SelAxis: TgxGizmoAxis read FSelAxis write FSelAxis;
Published | property SelectedColor: TgxColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TgxBaseSceneObject read FSelectedObj write SetSelectedObj;
Published | property Viewer: TgxSceneViewer read FViewer write SetViewer;
Published | property VisibleInfoLabels: TgxGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SetGizmoVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TgxColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write FZoomFactor;

Description

Fields

Private _GZObaseGizmo: TgxBaseSceneObject;

This item has no description.

Private _GZOBoundingcube: TgxCube;

This item has no description.

Private _GZOrootHelpers: TgxBaseSceneObject;

This item has no description.

Private _GZOrootLines: TgxBaseSceneObject;

This item has no description.

Private _GZOrootTorus: TgxBaseSceneObject;

This item has no description.

Private _GZOrootCubes: TgxBaseSceneObject;

This item has no description.

Private _GZORootAxisLabel: TgxBaseSceneObject;

This item has no description.

Private _GZORootVisibleInfoLabels: TgxBaseSceneObject;

This item has no description.

Private _GZOlineX: TgxLines;

This item has no description.

Private _GZOlineY: TgxLines;

This item has no description.

Private _GZOlineZ: TgxLines;

This item has no description.

Private _GZOplaneXY: TgxLines;

This item has no description.

Private _GZOplaneXZ: TgxLines;

This item has no description.

Private _GZOplaneYZ: TgxLines;

This item has no description.

Private _GZOTorusX: TgxGizmoPickTorus;

For Move

Private _GZOTorusY: TgxGizmoPickTorus;

For Move

Private _GZOTorusZ: TgxGizmoPickTorus;

For Move

Private _GZOCubeX: TgxGizmoPickCube;

For Rotate

Private _GZOCubeY: TgxGizmoPickCube;

For Rotate

Private _GZOCubeZ: TgxGizmoPickCube;

For Rotate

Private _GZOAxisLabelX: TgxFlatText;

For Scale

Private _GZOAxisLabelY: TgxFlatText;

For Scale

Private _GZOAxisLabelZ: TgxFlatText;

For Scale

Private _GZOVisibleInfoLabels: TgxFlatText;

This item has no description.

Private FRootGizmo: TgxBaseSceneObject;

This item has no description.

Private FSelectedObj: TgxBaseSceneObject;

This item has no description.

Private FOperation: TgxGizmoOperation;

FLastOperation,

Private FSelAxis: TgxGizmoAxis;

This item has no description.

Private FBoundingBoxColor: TgxColor;

This item has no description.

Private FSelectedColor: TgxColor;

This item has no description.

Private FVisibleInfoLabelsColor: TgxColor;

This item has no description.

Private FBoundingBoxColorChanged: Boolean;

This item has no description.

Private FVisibleInfoLabelsColorChanged: Boolean;

This item has no description.

Private FForceOperation: Boolean;

This item has no description.

Private FForceAxis: Boolean;

This item has no description.

Private FForceUniformScale: Boolean;

This item has no description.

Private FAutoZoom: Boolean;

This item has no description.

Private FExcludeObjects: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAutoZoomFactor: Single;

This item has no description.

Private FZoomFactor: Single;

This item has no description.

Private FMoveCoef: Single;

This item has no description.

Private FRotationCoef: Single;

This item has no description.

Private FViewer: TgxSceneViewer;

This item has no description.

Private FGizmoElements: TgxGizmoElements;

This item has no description.

Private FVisibleVisibleInfoLabels: TgxGizmoVisibleInfoLabels;

This item has no description.

Private FExcludeObjectsList: TStrings;

This item has no description.

Private Moving: Boolean;

This item has no description.

Private Mx: Integer;

This item has no description.

Private My: Integer;

This item has no description.

Private Rx: Integer;

This item has no description.

Private Ry: Integer;

This item has no description.

Private dglEnable: TgxDirectOpenGL;

This item has no description.

Private dglDisable: TgxDirectOpenGL;

This item has no description.

Private dgtEnable: TgxDirectOpenGL;

This item has no description.

Private dgtDisable: TgxDirectOpenGL;

This item has no description.

Private dgcEnable: TgxDirectOpenGL;

This item has no description.

Private dgcDisable: TgxDirectOpenGL;

This item has no description.

Private dglaEnable: TgxDirectOpenGL;

This item has no description.

Private dglaDisable: TgxDirectOpenGL;

This item has no description.

Private dgliEnable: TgxDirectOpenGL;

This item has no description.

Private dgliDisable: TgxDirectOpenGL;

This item has no description.

Private LastMousePos: TVector4f;

This item has no description.

Private ObjDimensions: TVector4f;

This item has no description.

Private FOnBeforeSelect: TgxGizmoAcceptEvent;

This item has no description.

Private FOnBeforeUpdate: TgxGizmoUpdateEvent;

This item has no description.

Private FOnSelectionLost: TNotifyEvent;

This item has no description.

Private FScaleCoef: Single;

This item has no description.

Private FGizmoThickness: Single;

This item has no description.

Private FPickMode: TgxGizmoPickMode;

This item has no description.

Private FInternalRaycastHitData: TList;

This item has no description.

Private FUndoHistory: TgxGizmoUndoCollection;

This item has no description.

Private FLabelFont: TgxCustomBitmapFont;

This item has no description.

Public PickableObjectsWithRayCast: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetPickedObjectPoint(const Obj: TgxBaseSceneObject): TVector4f;

This item has no description.

Private function CheckObjectInExcludeList(const Obj: TgxBaseSceneObject): Boolean;

This item has no description.

Private function InternalGetPickedObjects(const X1, Y1, X2, Y2: Integer; const GuessCount: Integer = 8): TgxPickList;

This item has no description.

Private function MouseWorldPos(const X, Y: Integer): TVector4f;

This item has no description.

Public procedure Loaded; override;

This item has no description.

Public procedure LooseSelection; virtual;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure SetVisible(const AValue: Boolean);

This item has no description.

Public procedure UndoAdd(const AObject: TgxCustomSceneObject);

This item has no description.

Public procedure UpdateGizmo(const NewDimensions: TVector4f); overload;

This item has no description.

Public procedure UpdateGizmo; overload;

This item has no description.

Public procedure ViewerMouseDown(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseMove(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseUp(const X, Y: Integer);

This item has no description.

Private procedure ClearInternalRaycastHitData;

This item has no description.

Private procedure DirectGLDisable(Sender: TObject; var Rci: TgxRenderContextInfo);

This item has no description.

Private procedure DirectGLEnable(Sender: TObject; var Rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetBoundingBoxColor(const AValue: TgxColor);

This item has no description.

Private procedure SetExcludeObjectsList(const AValue: TStrings);

This item has no description.

Private procedure SetGizmoElements(const AValue: TgxGizmoElements);

This item has no description.

Private procedure SetGizmoThickness(const Value: Single);

This item has no description.

Private procedure SetGizmoVisibleInfoLabels(const AValue : TgxGizmoVisibleInfoLabels);

This item has no description.

Private procedure SetLabelFont(const Value: TgxCustomBitmapFont);

This item has no description.

Private procedure SetRootGizmo(const AValue: TgxBaseSceneObject);

This item has no description.

Private procedure SetSelectedColor(const AValue: TgxColor);

This item has no description.

Private procedure SetSelectedObj(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetViewer(const Value: TgxSceneViewer);

This item has no description.

Private procedure SetVisibleInfoLabelsColor(const AValue: TgxColor);

This item has no description.

Private procedure UpdateVisibleInfoLabels;

This item has no description.

Properties

Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom;

This item has no description.

Published property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;

This item has no description.

Published property BoundingBoxColor: TgxColor read FBoundingBoxColor write SetBoundingBoxColor;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default False;

Warning Enable is ReadOnly property if you set to False, Gizmo is not Hidden use Visible instead if you want to Hide, if you want to Hide but keep enabled see the VisibleGizmo property

Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;

This item has no description.

Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;

This item has no description.

Published property ForceAxis: Boolean read FForceAxis write FForceAxis;

This item has no description.

Published property ForceOperation: Boolean read FForceOperation write FForceoperation;

This item has no description.

Published property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;

This item has no description.

Published property GizmoElements: TgxGizmoElements read FGizmoElements write SetGizmoElements;

This item has no description.

Published property GizmoThickness: Single read FGizmoThickness write SetGizmoThickness;

This item has no description.

Published property LabelFont: TgxCustomBitmapFont read FLabelFont write SetLabelFont default nil;

This item has no description.

Published property MoveCoef: Single read FMoveCoef write FMoveCoef;

This item has no description.

Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

This item has no description.

Published property OnBeforeSelect: TgxGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;

This item has no description.

Published property OnBeforeUpdate: TgxGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;

Called before an Update is applied. The "vector" parameter is the difference that will be applied to the object, according to the axis and operation selected.

Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;

This item has no description.

Published property Operation: TgxGizmoOperation read FOperation write FOperation;

This item has no description.

Published property PickMode: TgxGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;

This item has no description.

Public property RootGizmo: TgxBaseSceneObject read FRootGizmo write SetRootGizmo;

This item has no description.

Published property RotationCoef: Single read FRotationCoef write FRotationCoef;

This item has no description.

Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;

This item has no description.

Published property SelAxis: TgxGizmoAxis read FSelAxis write FSelAxis;

This item has no description.

Published property SelectedColor: TgxColor read FSelectedColor write SetSelectedColor;

This item has no description.

Published property SelectedObj: TgxBaseSceneObject read FSelectedObj write SetSelectedObj;

This item has no description.

Published property Viewer: TgxSceneViewer read FViewer write SetViewer;

——————————————————————–

Published property VisibleInfoLabels: TgxGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SetGizmoVisibleInfoLabels;

This item has no description.

Published property VisibleInfoLabelsColor: TgxColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;

This item has no description.

Published property ZoomFactor: Single read FZoomFactor write FZoomFactor;


GXSysHelp v.2.5: GXS.GizmoEx

Unit GXS.GizmoEx

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Types
  • System.Classes
  • System.SysUtils
  • System.Math
  • FMX.TextLayout
  • GLScene.GeometryBB
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GLScene.Strings
  • GXS.Scene
  • GXS.Color
  • GXS.Material
  • GXS.Objects
  • GXS.SceneViewer
  • GXS.GeomObjects
  • GXS.BitmapFont
  • GXS.VectorFileObjects
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.Canvas
  • GXS.Screen
  • GXS.State
  • GLScene.PipelineTransform
  • GXS.Selection
  • GXS.ImageUtils
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxGizmoExObjectItem |
Class TgxGizmoExObjectCollection |
Class TgxGizmoExActionHistoryItem |
Class TgxGizmoExActionHistoryCollection |
Class TgxGizmoExUIFrustrum |
Class TgxGizmoExUISphere |
Class TgxGizmoExUIDisk |
Class TgxGizmoExUITorus |
Class TgxGizmoExUIPolygon |
Class TgxGizmoExUIArrowLine |
Class TgxGizmoExUILines |
Class TgxGizmoExUIFlatText |
Class TgxGizmoEx |

Types

TgxGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TgxPickList) of object;
TgxGizmoExAxis = (...);
TgxGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TgxGizmoExAxis) of object;
TgxGizmoExOperation = (...);
TgxGizmoExOperationMode = (...);
TgxGizmoExPickMode = (...);
TgxGizmoExReferenceCoordinateSystem = (...);
TgxGizmoExSelectionRegion = (...);
TgxGizmoExSelRec = array of TPoint;
TgxGizmoExVisibleInfoLabel = (...);
TgxGizmoExVisibleInfoLabels = set of TgxGizmoExVisibleInfoLabel;
TInfoLabelCoordType = (...);

Description

Types

TgxGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TgxPickList) of object;

This item has no description.

TgxGizmoExAxis = (...);

This item has no description.

Values
  • gaNone
  • gaX
  • gaY
  • gaZ
  • gaXY
  • gaXZ
  • gaYZ
  • gaXYZ
TgxGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TgxGizmoExAxis) of object;

This item has no description.

TgxGizmoExOperation = (...);

This item has no description.

Values
  • gopMove
  • gopRotate
  • gopScale
  • gopNone
TgxGizmoExOperationMode = (...);

This item has no description.

Values
  • gomNone
  • gomSelect
  • gomMove
  • gomRotate
  • gomScale
TgxGizmoExPickMode = (...);

This item has no description.

Values
  • pmGetPickedObjects
  • pmRayCast
TgxGizmoExReferenceCoordinateSystem = (...);

This item has no description.

Values
  • rcsView
  • rcsLocal
TgxGizmoExSelectionRegion = (...);

This item has no description.

Values
  • gsrRectangular
  • gsrCircular
  • gsrFence
  • gsrLasso
TgxGizmoExSelRec = array of TPoint;

This item has no description.

TgxGizmoExVisibleInfoLabel = (...);

This item has no description.

Values
  • vliName
  • vliOperation
  • vliCoords
TgxGizmoExVisibleInfoLabels = set of TgxGizmoExVisibleInfoLabel;

This item has no description.

TInfoLabelCoordType = (...);

This item has no description.

Values
  • ilcChanging
  • ilcChangeRate


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExObjectItem

Class TgxGizmoExObjectItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExObjectItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxGizmoExObjectItem

Overview

Fields

Private | FOldAutoScaling: TVector4f;
Private | FEffectedObject: TgxBaseSceneObject;
Private | FParentOldObject: TgxBaseSceneObject;
Private | FIndexOldObject: Integer;
Private | FNameOldObject: string;
Private | FReturnObject: Boolean;
Private | FOldMatrix: TMatrix4f;
Private | FGizmoTmpRoot: TgxBaseSceneObject;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignFromObject(const AObject: TgxBaseSceneObject; AssignAndRemoveObj: Boolean = False);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Private | procedure SetEffectedObject(const Value: TgxBaseSceneObject);
Private | procedure SetOldMatrix(const Value: TMatrix4f);

Properties

Published | property EffectedObject: TgxBaseSceneobject read FEffectedObject write SetEffectedObject;
Public | property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property OldMatrix: TMatrix4f read FOldMatrix write SetOldMatrix;

Description

Fields

Private FOldAutoScaling: TVector4f;

This item has no description.

Private FEffectedObject: TgxBaseSceneObject;

This item has no description.

Private FParentOldObject: TgxBaseSceneObject;

This item has no description.

Private FIndexOldObject: Integer;

This item has no description.

Private FNameOldObject: string;

This item has no description.

Private FReturnObject: Boolean;

This item has no description.

Private FOldMatrix: TMatrix4f;

This item has no description.

Private FGizmoTmpRoot: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignFromObject(const AObject: TgxBaseSceneObject; AssignAndRemoveObj: Boolean = False);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;

This item has no description.

Private procedure SetEffectedObject(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetOldMatrix(const Value: TMatrix4f);

This item has no description.

Properties

Published property EffectedObject: TgxBaseSceneobject read FEffectedObject write SetEffectedObject;

This item has no description.

Public property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;

This item has no description.

Public property OldMatrix: TMatrix4f read FOldMatrix write SetOldMatrix;

TODO: create a special type for Matrix.


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExObjectCollection

Class TgxGizmoExObjectCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExObjectCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxGizmoExObjectCollection

Overview

Methods

Public | function Add: TgxGizmoExObjectItem;
Private | function GetItems(const Index: Integer): TgxGizmoExObjectItem;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TgxCustomSceneObject);
Private | procedure SetItems(const Index: Integer; const Value: TgxGizmoExObjectItem);

Properties

Public property Items[const Index: Integer]: TgxGizmoExObjectItem read GetItems write SetItems;

Description

Methods

Public function Add: TgxGizmoExObjectItem;

This item has no description.

Private function GetItems(const Index: Integer): TgxGizmoExObjectItem;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveByObject(const AObject: TgxCustomSceneObject);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TgxGizmoExObjectItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TgxGizmoExObjectItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExActionHistoryItem

Class TgxGizmoExActionHistoryItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExActionHistoryItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxGizmoExActionHistoryItem

Overview

Fields

Private | FObject: TObject;
Private | FGizmoObjectCollection: TgxGizmoExObjectCollection;

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Private | procedure SetGizmoObjectCollection(aValue: TgxGizmoExObjectCollection);
Private | procedure SetObject(aValue: TObject);

Properties

Public | property BaseObject: TObject read FObject write SetObject;
Public | property GizmoObjectCollection: TgxGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;

Description

Fields

Private FObject: TObject;

This item has no description.

Private FGizmoObjectCollection: TgxGizmoExObjectCollection;

This item has no description.

Methods

Public constructor Create(AOwner: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetGizmoObjectCollection(aValue: TgxGizmoExObjectCollection);

This item has no description.

Private procedure SetObject(aValue: TObject);

This item has no description.

Properties

Public property BaseObject: TObject read FObject write SetObject;

This item has no description.

Public property GizmoObjectCollection: TgxGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExActionHistoryCollection

Class TgxGizmoExActionHistoryCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExActionHistoryCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxGizmoExActionHistoryCollection

Overview

Fields

Private | FItemIndex: Integer;
Private | FItemsMaxCount: Integer;
Private | FGizmoTmpRoot: TgxBaseSceneObject;

Methods

Public | constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);
Public | function Redo: TgxGizmoExActionHistoryItem;
Public | function Undo: TgxGizmoExActionHistoryItem;
Private | function Add: TgxGizmoExActionHistoryItem;
Private | function GetItems(const Index: Integer): TgxGizmoExActionHistoryItem;
Public | procedure AddObject(obj: TObject);
Public | procedure AddObjects(objs: TgxPickList);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveObjects(objs: TgxPickList);
Private | procedure SetItems(const Index: Integer; const Value: TgxGizmoExActionHistoryItem);

Properties

Public | property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property ItemIndex: Integer read FItemIndex write FItemIndex;
Public | property Items[const Index: Integer]: TgxGizmoExActionHistoryItem read GetItems write SetItems;
Public | property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;

Description

Fields

Private FItemIndex: Integer;

This item has no description.

Private FItemsMaxCount: Integer;

This item has no description.

Private FGizmoTmpRoot: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);

This item has no description.

Public function Redo: TgxGizmoExActionHistoryItem;

This item has no description.

Public function Undo: TgxGizmoExActionHistoryItem;

This item has no description.

Private function Add: TgxGizmoExActionHistoryItem;

This item has no description.

Private function GetItems(const Index: Integer): TgxGizmoExActionHistoryItem;

This item has no description.

Public procedure AddObject(obj: TObject);

This item has no description.

Public procedure AddObjects(objs: TgxPickList);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation);

This item has no description.

Public procedure RemoveObjects(objs: TgxPickList);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TgxGizmoExActionHistoryItem);

This item has no description.

Properties

Public property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;

This item has no description.

Public property ItemIndex: Integer read FItemIndex write FItemIndex;

This item has no description.

Public property Items[const Index: Integer]: TgxGizmoExActionHistoryItem read GetItems write SetItems;

This item has no description.

Public property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUIFrustrum

Class TgxGizmoExUIFrustrum

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUIFrustrum = class(TgxFrustrum)

Description

Gizmo objects

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxFrustrum
  • TgxGizmoExUIFrustrum

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUISphere

Class TgxGizmoExUISphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUISphere = class(TgxSphere)

Description

This item has no description. Showing description inherited from TgxSphere.

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxSphere
  • TgxGizmoExUISphere

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUIDisk

Class TgxGizmoExUIDisk

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUIDisk = class(TgxDisk)

Description

This item has no description. Showing description inherited from TgxDisk.

A Disk object. The disk may not be complete, it can have a hole (controled by the InnerRadius property) and can only be a slice (controled by the StartAngle and SweepAngle properties).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxDisk
  • TgxGizmoExUIDisk

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUITorus

Class TgxGizmoExUITorus

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUITorus = class(TgxTorus)

Description

This item has no description. Showing description inherited from TgxTorus.

A Torus object

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTorus
  • TgxGizmoExUITorus

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUIPolygon

Class TgxGizmoExUIPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUIPolygon = class(TgxPolygon)

Description

This item has no description. Showing description inherited from TgxPolygon.

A basic polygon object. The curve is described by the Nodes and SplineMode properties, should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single curve, if you need "complex polygons" with holes, patches and cutouts, see GLMultiPolygon.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPolygonBase
  • TgxPolygon
  • TgxGizmoExUIPolygon

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUIArrowLine

Class TgxGizmoExUIArrowLine

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUIArrowLine = class(TgxArrowLine)

Description

This item has no description. Showing description inherited from TgxArrowLine.

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxCylinderBase
  • TgxArrowLine
  • TgxGizmoExUIArrowLine

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUILines

Class TgxGizmoExUILines

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUILines = class(TgxLines)

Description

This item has no description. Showing description inherited from TgxLines.

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase
  • TgxNodedLines
  • TgxLines
  • TgxGizmoExUILines

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoExUIFlatText

Class TgxGizmoExUIFlatText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoExUIFlatText = class(TgxFlatText)

Description

This item has no description. Showing description inherited from TgxFlatText.

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TgxBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxFlatText
  • TgxGizmoExUIFlatText

Overview

Fields

Private FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;


GXSysHelp v.2.5: GXS.GizmoEx: Class TgxGizmoEx

Class TgxGizmoEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GizmoEx

Declaration

type TgxGizmoEx = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxGizmoEx

Overview

Fields

Private | FUIBaseGizmo: TgxBaseSceneObject;
Private | FUIRootHelpers: TgxBaseSceneObject;
Private | FUIRootSelect: TgxBaseSceneObject;
Private | FUIRootMovement: TgxBaseSceneObject;
Private | FUIRootRotate: TgxBaseSceneObject;
Private | FUIRootRotateAxisLabel: TgxBaseSceneObject;
Private | FUIRootScale: TgxBaseSceneObject;
Private | FUIRootAxisLabel: TgxBaseSceneObject;
Private | FUIRootVisibleInfoLabels: TgxBaseSceneObject;
Private | FInterfaceRender: TgxDirectOpenGL;
Private | FInternalRender: TgxDirectOpenGL;
Private | FUISelectLineX: TgxGizmoExUILines;
Private | FUISelectLineY: TgxGizmoExUILines;
Private | FUISelectLineZ: TgxGizmoExUILines;
Private | FUIICMovementLineX: TgxGizmoExUIFrustrum;
Private | FUIICMovementLineY: TgxGizmoExUIFrustrum;
Private | FUIICMovementLineZ: TgxGizmoExUIFrustrum;
Private | FUIICMovementLineXY: TgxGizmoExUIFrustrum;
Private | FUIICMovementLineXZ: TgxGizmoExUIFrustrum;
Private | FUIICMovementLineYZ: TgxGizmoExUIFrustrum;
Private | FUIMovementArrowX: TgxGizmoExUIArrowLine;
Private | FUIMovementArrowY: TgxGizmoExUIArrowLine;
Private | FUIMovementArrowZ: TgxGizmoExUIArrowLine;
Private | FUIMovementLineX: TgxGizmoExUILines;
Private | FUIMovementLineY: TgxGizmoExUILines;
Private | FUIMovementLineZ: TgxGizmoExUILines;
Private | FUIMovementLineXY: TgxGizmoExUILines;
Private | FUIMovementLineXZ: TgxGizmoExUILines;
Private | FUIMovementLineYZ: TgxGizmoExUILines;
Private | FUIMovementPlaneXY: TgxGizmoExUIPolyGon;
Private | FUIMovementPlaneXZ: TgxGizmoExUIPolyGon;
Private | FUIMovementPlaneYZ: TgxGizmoExUIPolyGon;
Private | FUIRotateLineX: TgxGizmoExUILines;
Private | FUIRotateLineY: TgxGizmoExUILines;
Private | FUIRotateLineZ: TgxGizmoExUILines;
Private | FUIRotateLineXY: TgxGizmoExUILines;
Private | FUIRotateLineXZ: TgxGizmoExUILines;
Private | FUIICRotateTorusX: TgxGizmoExUITorus;
Private | FUIICRotateTorusY: TgxGizmoExUITorus;
Private | FUIICRotateTorusZ: TgxGizmoExUITorus;
Private | FUIICRotateTorusXZ: TgxGizmoExUITorus;
Private | FUIRotateDiskXY: TgxGizmoExUIDisk;
Private | FUIRotateDiskX: TgxGizmoExUIDisk;
Private | FUIRotateDiskX2: TgxGizmoExUIDisk;
Private | FUIRotateDiskY: TgxGizmoExUIDisk;
Private | FUIRotateDiskY2: TgxGizmoExUIDisk;
Private | FUIRotateDiskZ: TgxGizmoExUIDisk;
Private | FUIRotateDiskZ2: TgxGizmoExUIDisk;
Private | FUIRotateLineArrowX: TgxGizmoExUILines;
Private | FUIRotateLineArrowY: TgxGizmoExUILines;
Private | FUIRotateLineArrowZ: TgxGizmoExUILines;
Private | FUIICRotateSphereXY: TgxGizmoExUISphere;
Private | FUIRotateAxisLabelX: TgxGizmoExUIFlatText;
Private | FUIRotateAxisLabelY: TgxGizmoExUIFlatText;
Private | FUIRotateAxisLabelZ: TgxGizmoExUIFlatText;
Private | FUIScaleArrowX: TgxGizmoExUISphere;
Private | FUIScaleArrowY: TgxGizmoExUISphere;
Private | FUIScaleArrowZ: TgxGizmoExUISphere;
Private | FUIScaleLineX: TgxGizmoExUILines;
Private | FUIScaleLineY: TgxGizmoExUILines;
Private | FUIScaleLineZ: TgxGizmoExUILines;
Private | FUIScaleLineXY: TgxGizmoExUILines;
Private | FUIScaleLineYZ: TgxGizmoExUILines;
Private | FUIScaleLineXZ: TgxGizmoExUILines;
Private | FUIICScaleLineX: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineY: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineZ: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineXY: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineXZ: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineYZ: TgxGizmoExUIFrustrum;
Private | FUIICScaleLineXYZ: TgxGizmoExUIFrustrum;
Private | FUIScalePlaneXY: TgxGizmoExUIPolyGon;
Private | FUIScalePlaneXZ: TgxGizmoExUIPolyGon;
Private | FUIScalePlaneYZ: TgxGizmoExUIPolyGon;
Private | FUIScalePlaneXYZ: TgxGizmoExUIPolyGon;
Private | FUIAxisLabelX: TgxGizmoExUIFlatText;
Private | FUIAxisLabelY: TgxGizmoExUIFlatText;
Private | FUIAxisLabelZ: TgxGizmoExUIFlatText;
Private | FUIVisibleInfoLabels: TgxGizmoExUIFlatText;
Private | FRootGizmo: TgxBaseSceneObject;
Private | FRootObjects: TgxBaseSceneObject;
Private | FGizmoTmpRoot: TgxBaseSceneObject;
Private | FSelectedObj: TgxBaseSceneObject;
Private | FOperation: TgxGizmoExOperation;
Private | FOperationMode: TgxGizmoExOperationMode;
Private | FSelAxis: TgxGizmoExAxis;
Private | fInfoLabelCoordType: TInfoLabelCoordType;
Private | FReferenceCoordSystem: TgxGizmoExReferenceCoordinateSystem;
Private | FBoundingBoxColor: TgxColor;
Private | FSelectedColor: TgxColor;
Private | FVisibleInfoLabelsColor: TgxColor;
Private | FSelectionRegionColor: TgxColor;
Private | FVisibleInfoLabelsColorChanged: Boolean;
Private | FAutoZoom: Boolean;
Private | FExcludeObjects: Boolean;
Private | FExcludeClassname: Boolean;
Private | FNoZWrite: Boolean;
Private | FEnabled: Boolean;
Private | FAutoZoomFactor: Single;
Private | FZoomFactor: Single;
Private | FMoveCoef: Single;
Private | FRotationCoef: Single;
Private | FViewer: TgxSceneViewer;
Private | FVisibleVisibleInfoLabels: TgxGizmoExVisibleInfoLabels;
Private | FExcludeObjectsList: TStrings;
Private | FExcludeClassNameList: TStrings;
Private | FSelectionRegion: TgxGizmoExSelectionRegion;
Private | FEnableMultiSelection: Boolean;
Private | FShowMultiSelecting: Boolean;
Private | FSelectionRec: TgxGizmoExSelRec;
Private | FCanAddObjToSelectionList: Boolean;
Private | FCanRemoveObjFromSelectionList: Boolean;
Private | FSelectedObjects: TgxPickList;
Private | FAntiAliasedLines: Boolean;
Private | FShowAxisLabel: Boolean;
Private | FShowObjectInfos: Boolean;
Private | FShowBoundingBox: Boolean;
Private | FCanChangeWithChildren: Boolean;
Private | moving: Boolean;
Private | mx: Integer;
Private | my: Integer;
Private | fCursorPos: TPoint;
Private | fLastCursorPos: TPoint;
Private | fChangeRate: TAffineVector;
Private | FEnableLoopCursorMoving: Boolean;
Private | lastMousePos: TVector4f;
Private | FOnUpdate: TNotifyEvent;
Private | FOnSelect: TgxGizmoExAcceptEvent;
Private | FOnOperationChange: TNotifyEvent;
Private | FOnOperationModeChange: TNotifyEvent;
Private | FOnSelectionLost: TNotifyEvent;
Private | FOnAxisSelected: TgxGizmoExAxisSelected;
Private | FScaleCoef: Single;
Private | FGizmoThickness: Single;
Private | FPickMode: TgxGizmoExPickMode;
Private | FEnableHistory: Boolean;
Private | FHistory: TgxGizmoExActionHistoryCollection;
Private | FHistoryStepsCount: Integer;
Private | FLabelFont: TgxCustomBitmapFont;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Redo: TgxGizmoExActionHistoryItem;
Public | function Undo: TgxGizmoExActionHistoryItem;
Private | function CheckClassNameInExcludeList(const Obj: TgxBaseSceneObject): Boolean;
Private | function CheckObjectInExcludeList(const Obj: TgxBaseSceneObject): Boolean;
Private | function GetPickList: TgxPickList;
Private | function GetSelectedObj: TgxBaseSceneObject;
Private | function GetVisible: Boolean;
Private | function InternalGetPickedObjects(const x1, y1, x2, y2: Integer; const guessCount: Integer = 8): TgxPickList;
Private | function MouseWorldPos(const X, Y: Integer): TVector4f;
Public | procedure Loaded; override;
Public | procedure LooseCursorSelection;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RemoveSelectedObjects;
Public | procedure UndoAdd(const AObject: TObject);
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);
Private | procedure ActivatingElements(PickList: TgxPickList);
Private | procedure AddObjToSelectionList(Obj: TgxBaseSceneObject);
Private | procedure AssignPickList(aList: TgxPickList; RemoveObj: Boolean = False);
Private | procedure ClearSelection;
Private | procedure InterfaceRender(Sender: TObject; var rci: TgxRenderContextInfo);
Private | procedure InternalRender(Sender: TObject; var rci: TgxRenderContextInfo);
Private | procedure MultiSelMouseDown(X, Y: Integer);
Private | procedure MultiSelMouseMove(X, Y: Integer);
Private | procedure MultiSelMouseUp(X, Y: Integer);
Private | procedure RemoveObjFromSelectionList(Obj: TgxBaseSceneObject);
Private | procedure SetAALines(aValue: Boolean);
Private | procedure SetAngleDisk(aAngle: Single);
Private | procedure SetAutoZoomFactor(const AValue: Single);
Private | procedure SetBoundingBoxColor(const AValue: TgxColor);
Private | procedure SetCanChangeWithChildren(AValue: Boolean);
Private | procedure SetEnableLoopCursorMoving(const AValue: Boolean);
Private | procedure SetEnableMultiSelection(const AValue: Boolean);
Private | procedure SetExcludeClassNameList(const AValue: TStrings);
Private | procedure SetExcludeObjectsList(const AValue: TStrings);
Private | procedure SetGizmoExThickness(const Value: Single);
Private | procedure SetGizmoExVisibleInfoLabels(const AValue: TgxGizmoExVisibleInfoLabels);
Private | procedure SetGizmoTmpRoot(const AValue: TgxBaseSceneObject);
Private | procedure SetHistoryStepsCount(aValue: Integer);
Private | procedure SetInfoLabelCoordType(aValue: TInfoLabelCoordType);
Private | procedure SetLabelFont(const Value: TgxCustomBitmapFont);
Private | procedure SetNoZWrite(const Value: Boolean);
Private | procedure SetOperation(const Value: TgxGizmoExOperation);
Private | procedure SetOperationMode(const Value: TgxGizmoExOperationMode);
Private | procedure SetPickList(aValue: TgxPickList);
Private | procedure SetPickMode(APickMode: TgxGizmoExPickMode);
Private | procedure SetReferenceCoordSystem(aValue: TgxGizmoExReferenceCoordinateSystem);
Private | procedure SetRootGizmo(const AValue: TgxBaseSceneObject);
Private | procedure SetRootObjects(const AValue: TgxBaseSceneObject);
Private | procedure SetSelAxis(aValue: TgxGizmoExAxis);
Private | procedure SetSelectedColor(const AValue: TgxColor);
Private | procedure SetSelectedObj(const Value: TgxBaseSceneObject);
Private | procedure SetSelectionRegion(const AValue: TgxGizmoExSelectionRegion);
Private | procedure SetSelectionRegionColor(const AValue: TgxColor);
Private | procedure SetShowAxisLabel(const AValue: Boolean);
Private | procedure SetShowBoundingBox(const AValue: Boolean);
Private | procedure SetShowObjectInfos(const AValue: Boolean);
Private | procedure SetViewer(const Value: TgxSceneViewer);
Private | procedure SetVisible(const AValue: Boolean);
Private | procedure SetVisibleInfoLabelsColor(const AValue: TgxColor);
Private | procedure SetZoomFactor(const AValue: Single);
Private | procedure UpdateVisibleInfoLabels;

Properties

Published | property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;
Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;
Published | property BoundingBoxColor: TgxColor read FBoundingBoxColor write SetBoundingBoxColor;
Public | property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;
Published | property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;
Public | property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;
Public | property CursorSelectingRegion: Boolean read FShowMultiSelecting;
Published | property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;
Published | property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;
Published | property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;
Published | property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property GizmoThickness: Single read FGizmoThickness write SetGizmoExThickness;
Public | property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;
Published | property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;
Published | property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;
Published | property LabelFont: TgxCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;
Published | property OnAxisSelected: TgxGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;
Published | property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;
Published | property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;
Published | property OnSelect: TgxGizmoExAcceptEvent read FOnSelect write FOnSelect;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;
Private | property Operation: TgxGizmoExOperation read FOperation write SetOperation;
Published | property OperationMode: TgxGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;
Published | property PickMode: TgxGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;
Published | property ReferenceCoordSystem: TgxGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;
Public | property RootGizmo: TgxBaseSceneObject read FRootGizmo write SetRootGizmo;
Public | property RootObjects: TgxBaseSceneObject read FRootObjects write SetRootObjects;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Private | property SelAxis: TgxGizmoExAxis read FSelAxis write SetSelAxis;
Published | property SelectedColor: TgxColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TgxBaseSceneObject read GetSelectedObj write SetSelectedObj;
Published | property SelectedObjects: TgxPickList read GetPickList write SetPickList;
Published | property SelectionRegion: TgxGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;
Published | property SelectionRegionColor: TgxColor read FSelectionRegionColor write SetSelectionRegionColor;
Published | property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;
Published | property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;
Published | property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;
Published | property Viewer: TgxSceneViewer read FViewer write SetViewer;
Published | property Visible: Boolean read GetVisible write SetVisible;
Published | property VisibleInfoLabels: TgxGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SetGizmoExVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TgxColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write SetZoomFactor;

Description

Fields

Private FUIBaseGizmo: TgxBaseSceneObject;

This item has no description.

Private FUIRootHelpers: TgxBaseSceneObject;

This item has no description.

Private FUIRootSelect: TgxBaseSceneObject;

This item has no description.

Private FUIRootMovement: TgxBaseSceneObject;

for None

Private FUIRootRotate: TgxBaseSceneObject;

for Move

Private FUIRootRotateAxisLabel: TgxBaseSceneObject;

for Rotate

Private FUIRootScale: TgxBaseSceneObject;

This item has no description.

Private FUIRootAxisLabel: TgxBaseSceneObject;

for Scale

Private FUIRootVisibleInfoLabels: TgxBaseSceneObject;

This item has no description.

Private FInterfaceRender: TgxDirectOpenGL;

This item has no description.

Private FInternalRender: TgxDirectOpenGL;

This item has no description.

Private FUISelectLineX: TgxGizmoExUILines;

This item has no description.

Private FUISelectLineY: TgxGizmoExUILines;

This item has no description.

Private FUISelectLineZ: TgxGizmoExUILines;

This item has no description.

Private FUIICMovementLineX: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIICMovementLineY: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIICMovementLineZ: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIICMovementLineXY: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIICMovementLineXZ: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIICMovementLineYZ: TgxGizmoExUIFrustrum;

For None (Select) IC- Invisible Contro, for move

Private FUIMovementArrowX: TgxGizmoExUIArrowLine;

This item has no description.

Private FUIMovementArrowY: TgxGizmoExUIArrowLine;

This item has no description.

Private FUIMovementArrowZ: TgxGizmoExUIArrowLine;

This item has no description.

Private FUIMovementLineX: TgxGizmoExUILines;

For Move

Private FUIMovementLineY: TgxGizmoExUILines;

For Move

Private FUIMovementLineZ: TgxGizmoExUILines;

For Move

Private FUIMovementLineXY: TgxGizmoExUILines;

For Move

Private FUIMovementLineXZ: TgxGizmoExUILines;

For Move

Private FUIMovementLineYZ: TgxGizmoExUILines;

For Move

Private FUIMovementPlaneXY: TgxGizmoExUIPolyGon;

For Move

Private FUIMovementPlaneXZ: TgxGizmoExUIPolyGon;

For Move

Private FUIMovementPlaneYZ: TgxGizmoExUIPolyGon;

For Move

Private FUIRotateLineX: TgxGizmoExUILines;

For Move ForRotate

Private FUIRotateLineY: TgxGizmoExUILines;

For Move ForRotate

Private FUIRotateLineZ: TgxGizmoExUILines;

For Move ForRotate

Private FUIRotateLineXY: TgxGizmoExUILines;

For Move ForRotate

Private FUIRotateLineXZ: TgxGizmoExUILines;

For Move ForRotate

Private FUIICRotateTorusX: TgxGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusY: TgxGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusZ: TgxGizmoExUITorus;

This item has no description.

Private FUIICRotateTorusXZ: TgxGizmoExUITorus;

This item has no description.

Private FUIRotateDiskXY: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskX: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskX2: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskY: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskY2: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskZ: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateDiskZ2: TgxGizmoExUIDisk;

For Rotate

Private FUIRotateLineArrowX: TgxGizmoExUILines;

This item has no description.

Private FUIRotateLineArrowY: TgxGizmoExUILines;

This item has no description.

Private FUIRotateLineArrowZ: TgxGizmoExUILines;

This item has no description.

Private FUIICRotateSphereXY: TgxGizmoExUISphere;

This item has no description.

Private FUIRotateAxisLabelX: TgxGizmoExUIFlatText;

This item has no description.

Private FUIRotateAxisLabelY: TgxGizmoExUIFlatText;

This item has no description.

Private FUIRotateAxisLabelZ: TgxGizmoExUIFlatText;

This item has no description.

Private FUIScaleArrowX: TgxGizmoExUISphere;

ForScale

Private FUIScaleArrowY: TgxGizmoExUISphere;

ForScale

Private FUIScaleArrowZ: TgxGizmoExUISphere;

ForScale

Private FUIScaleLineX: TgxGizmoExUILines;

This item has no description.

Private FUIScaleLineY: TgxGizmoExUILines;

This item has no description.

Private FUIScaleLineZ: TgxGizmoExUILines;

This item has no description.

Private FUIScaleLineXY: TgxGizmoExUILines;

This item has no description.

Private FUIScaleLineYZ: TgxGizmoExUILines;

This item has no description.

Private FUIScaleLineXZ: TgxGizmoExUILines;

This item has no description.

Private FUIICScaleLineX: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineY: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineZ: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXY: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXZ: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineYZ: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIICScaleLineXYZ: TgxGizmoExUIFrustrum;

This item has no description.

Private FUIScalePlaneXY: TgxGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneXZ: TgxGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneYZ: TgxGizmoExUIPolyGon;

This item has no description.

Private FUIScalePlaneXYZ: TgxGizmoExUIPolyGon;

This item has no description.

Private FUIAxisLabelX: TgxGizmoExUIFlatText;

For Move

Private FUIAxisLabelY: TgxGizmoExUIFlatText;

For Move

Private FUIAxisLabelZ: TgxGizmoExUIFlatText;

For Move

Private FUIVisibleInfoLabels: TgxGizmoExUIFlatText;

This item has no description.

Private FRootGizmo: TgxBaseSceneObject;

This item has no description.

Private FRootObjects: TgxBaseSceneObject;

This item has no description.

Private FGizmoTmpRoot: TgxBaseSceneObject;

This item has no description.

Private FSelectedObj: TgxBaseSceneObject;

This item has no description.

Private FOperation: TgxGizmoExOperation;

This item has no description.

Private FOperationMode: TgxGizmoExOperationMode;

This item has no description.

Private FSelAxis: TgxGizmoExAxis;

This item has no description.

Private fInfoLabelCoordType: TInfoLabelCoordType;

This item has no description.

Private FReferenceCoordSystem: TgxGizmoExReferenceCoordinateSystem;

This item has no description.

Private FBoundingBoxColor: TgxColor;

This item has no description.

Private FSelectedColor: TgxColor;

This item has no description.

Private FVisibleInfoLabelsColor: TgxColor;

This item has no description.

Private FSelectionRegionColor: TgxColor;

This item has no description.

Private FVisibleInfoLabelsColorChanged: Boolean;

This item has no description.

Private FAutoZoom: Boolean;

This item has no description.

Private FExcludeObjects: Boolean;

This item has no description.

Private FExcludeClassname: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAutoZoomFactor: Single;

This item has no description.

Private FZoomFactor: Single;

This item has no description.

Private FMoveCoef: Single;

This item has no description.

Private FRotationCoef: Single;

This item has no description.

Private FViewer: TgxSceneViewer;

This item has no description.

Private FVisibleVisibleInfoLabels: TgxGizmoExVisibleInfoLabels;

This item has no description.

Private FExcludeObjectsList: TStrings;

This item has no description.

Private FExcludeClassNameList: TStrings;

This item has no description.

Private FSelectionRegion: TgxGizmoExSelectionRegion;

This item has no description.

Private FEnableMultiSelection: Boolean;

This item has no description.

Private FShowMultiSelecting: Boolean;

This item has no description.

Private FSelectionRec: TgxGizmoExSelRec;

This item has no description.

Private FCanAddObjToSelectionList: Boolean;

This item has no description.

Private FCanRemoveObjFromSelectionList: Boolean;

This item has no description.

Private FSelectedObjects: TgxPickList;

This item has no description.

Private FAntiAliasedLines: Boolean;

This item has no description.

Private FShowAxisLabel: Boolean;

This item has no description.

Private FShowObjectInfos: Boolean;

This item has no description.

Private FShowBoundingBox: Boolean;

This item has no description.

Private FCanChangeWithChildren: Boolean;

This item has no description.

Private moving: Boolean;

This item has no description.

Private mx: Integer;

This item has no description.

Private my: Integer;

This item has no description.

Private fCursorPos: TPoint;

This item has no description.

Private fLastCursorPos: TPoint;

This item has no description.

Private fChangeRate: TAffineVector;

This item has no description.

Private FEnableLoopCursorMoving: Boolean;

total rotate angle

Private lastMousePos: TVector4f;

This item has no description.

Private FOnUpdate: TNotifyEvent;

This item has no description.

Private FOnSelect: TgxGizmoExAcceptEvent;

This item has no description.

Private FOnOperationChange: TNotifyEvent;

This item has no description.

Private FOnOperationModeChange: TNotifyEvent;

This item has no description.

Private FOnSelectionLost: TNotifyEvent;

This item has no description.

Private FOnAxisSelected: TgxGizmoExAxisSelected;

This item has no description.

Private FScaleCoef: Single;

This item has no description.

Private FGizmoThickness: Single;

This item has no description.

Private FPickMode: TgxGizmoExPickMode;

This item has no description.

Private FEnableHistory: Boolean;

This item has no description.

Private FHistory: TgxGizmoExActionHistoryCollection;

This item has no description.

Private FHistoryStepsCount: Integer;

This item has no description.

Private FLabelFont: TgxCustomBitmapFont;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Redo: TgxGizmoExActionHistoryItem;

This item has no description.

Public function Undo: TgxGizmoExActionHistoryItem;

This item has no description.

Private function CheckClassNameInExcludeList(const Obj: TgxBaseSceneObject): Boolean;

This item has no description.

Private function CheckObjectInExcludeList(const Obj: TgxBaseSceneObject): Boolean;

This item has no description.

Private function GetPickList: TgxPickList;

This item has no description.

Private function GetSelectedObj: TgxBaseSceneObject;

This item has no description.

Private function GetVisible: Boolean;

This item has no description.

Private function InternalGetPickedObjects(const x1, y1, x2, y2: Integer; const guessCount: Integer = 8): TgxPickList;

This item has no description.

Private function MouseWorldPos(const X, Y: Integer): TVector4f;

This item has no description.

Public procedure Loaded; override;

This item has no description.

Public procedure LooseCursorSelection;

This item has no description.

Public procedure LooseSelection; virtual;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RemoveSelectedObjects;

This item has no description.

Public procedure UndoAdd(const AObject: TObject);

This item has no description.

Public procedure UpdateGizmo; overload;

This item has no description.

Public procedure ViewerMouseDown(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseMove(const X, Y: Integer);

This item has no description.

Public procedure ViewerMouseUp(const X, Y: Integer);

This item has no description.

Private procedure ActivatingElements(PickList: TgxPickList);

This item has no description.

Private procedure AddObjToSelectionList(Obj: TgxBaseSceneObject);

This item has no description.

Private procedure AssignPickList(aList: TgxPickList; RemoveObj: Boolean = False);

This item has no description.

Private procedure ClearSelection;

This item has no description.

Private procedure InterfaceRender(Sender: TObject; var rci: TgxRenderContextInfo);

This item has no description.

Private procedure InternalRender(Sender: TObject; var rci: TgxRenderContextInfo);

This item has no description.

Private procedure MultiSelMouseDown(X, Y: Integer);

This item has no description.

Private procedure MultiSelMouseMove(X, Y: Integer);

This item has no description.

Private procedure MultiSelMouseUp(X, Y: Integer);

This item has no description.

Private procedure RemoveObjFromSelectionList(Obj: TgxBaseSceneObject);

This item has no description.

Private procedure SetAALines(aValue: Boolean);

This item has no description.

Private procedure SetAngleDisk(aAngle: Single);

This item has no description.

Private procedure SetAutoZoomFactor(const AValue: Single);

This item has no description.

Private procedure SetBoundingBoxColor(const AValue: TgxColor);

This item has no description.

Private procedure SetCanChangeWithChildren(AValue: Boolean);

This item has no description.

Private procedure SetEnableLoopCursorMoving(const AValue: Boolean);

This item has no description.

Private procedure SetEnableMultiSelection(const AValue: Boolean);

This item has no description.

Private procedure SetExcludeClassNameList(const AValue: TStrings);

This item has no description.

Private procedure SetExcludeObjectsList(const AValue: TStrings);

This item has no description.

Private procedure SetGizmoExThickness(const Value: Single);

This item has no description.

Private procedure SetGizmoExVisibleInfoLabels(const AValue: TgxGizmoExVisibleInfoLabels);

This item has no description.

Private procedure SetGizmoTmpRoot(const AValue: TgxBaseSceneObject);

This item has no description.

Private procedure SetHistoryStepsCount(aValue: Integer);

This item has no description.

Private procedure SetInfoLabelCoordType(aValue: TInfoLabelCoordType);

This item has no description.

Private procedure SetLabelFont(const Value: TgxCustomBitmapFont);

This item has no description.

Private procedure SetNoZWrite(const Value: Boolean);

This item has no description.

Private procedure SetOperation(const Value: TgxGizmoExOperation);

This item has no description.

Private procedure SetOperationMode(const Value: TgxGizmoExOperationMode);

This item has no description.

Private procedure SetPickList(aValue: TgxPickList);

This item has no description.

Private procedure SetPickMode(APickMode: TgxGizmoExPickMode);

This item has no description.

Private procedure SetReferenceCoordSystem(aValue: TgxGizmoExReferenceCoordinateSystem);

This item has no description.

Private procedure SetRootGizmo(const AValue: TgxBaseSceneObject);

This item has no description.

Private procedure SetRootObjects(const AValue: TgxBaseSceneObject);

This item has no description.

Private procedure SetSelAxis(aValue: TgxGizmoExAxis);

This item has no description.

Private procedure SetSelectedColor(const AValue: TgxColor);

This item has no description.

Private procedure SetSelectedObj(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetSelectionRegion(const AValue: TgxGizmoExSelectionRegion);

This item has no description.

Private procedure SetSelectionRegionColor(const AValue: TgxColor);

This item has no description.

Private procedure SetShowAxisLabel(const AValue: Boolean);

This item has no description.

Private procedure SetShowBoundingBox(const AValue: Boolean);

This item has no description.

Private procedure SetShowObjectInfos(const AValue: Boolean);

This item has no description.

Private procedure SetViewer(const Value: TgxSceneViewer);

This item has no description.

Private procedure SetVisible(const AValue: Boolean);

This item has no description.

Private procedure SetVisibleInfoLabelsColor(const AValue: TgxColor);

This item has no description.

Private procedure SetZoomFactor(const AValue: Single);

This item has no description.

Private procedure UpdateVisibleInfoLabels;

This item has no description.

Properties

Published property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;

This item has no description.

Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;

This item has no description.

Published property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;

This item has no description.

Published property BoundingBoxColor: TgxColor read FBoundingBoxColor write SetBoundingBoxColor;

This item has no description.

Public property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;

This item has no description.

Published property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;

This item has no description.

Public property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;

This item has no description.

Public property CursorSelectingRegion: Boolean read FShowMultiSelecting;

This item has no description.

Published property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default True;

Use the property OperationMode=gomNone to unactivate gizmo and make it invisible

Published property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;

This item has no description.

Published property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;

This item has no description.

Published property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;

This item has no description.

Published property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;

This item has no description.

Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;

This item has no description.

Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;

This item has no description.

Published property GizmoThickness: Single read FGizmoThickness write SetGizmoExThickness;

This item has no description.

Public property GizmoTmpRoot: TgxBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;

This item has no description.

Published property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;

This item has no description.

Published property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;

This item has no description.

Published property LabelFont: TgxCustomBitmapFont read FLabelFont write SetLabelFont default nil;

This item has no description.

Published property MoveCoef: Single read FMoveCoef write FMoveCoef;

This item has no description.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;

This item has no description.

Published property OnAxisSelected: TgxGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;

This item has no description.

Published property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;

This item has no description.

Published property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;

This item has no description.

Published property OnSelect: TgxGizmoExAcceptEvent read FOnSelect write FOnSelect;

This item has no description.

Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;

This item has no description.

Published property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;

This item has no description.

Private property Operation: TgxGizmoExOperation read FOperation write SetOperation;

This item has no description.

Published property OperationMode: TgxGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;

This item has no description.

Published property PickMode: TgxGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;

This item has no description.

Published property ReferenceCoordSystem: TgxGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;

This item has no description.

Public property RootGizmo: TgxBaseSceneObject read FRootGizmo write SetRootGizmo;

This item has no description.

Public property RootObjects: TgxBaseSceneObject read FRootObjects write SetRootObjects;

This item has no description.

Published property RotationCoef: Single read FRotationCoef write FRotationCoef;

This item has no description.

Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;

This item has no description.

Private property SelAxis: TgxGizmoExAxis read FSelAxis write SetSelAxis;

This item has no description.

Published property SelectedColor: TgxColor read FSelectedColor write SetSelectedColor;

This item has no description.

Published property SelectedObj: TgxBaseSceneObject read GetSelectedObj write SetSelectedObj;

This item has no description.

Published property SelectedObjects: TgxPickList read GetPickList write SetPickList;

This item has no description.

Published property SelectionRegion: TgxGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;

This item has no description.

Published property SelectionRegionColor: TgxColor read FSelectionRegionColor write SetSelectionRegionColor;

This item has no description.

Published property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;

This item has no description.

Published property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;

This item has no description.

Published property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;

This item has no description.

Published property Viewer: TgxSceneViewer read FViewer write SetViewer;

——————————————————————–

Published property Visible: Boolean read GetVisible write SetVisible;

This item has no description.

Published property VisibleInfoLabels: TgxGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SetGizmoExVisibleInfoLabels;

This item has no description.

Published property VisibleInfoLabelsColor: TgxColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;

This item has no description.

Published property ZoomFactor: Single read FZoomFactor write SetZoomFactor;


GXSysHelp v.2.5: GXS.GPURegister

Unit GXS.GPURegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.CUDA.Context
  • GXS.CUDA.API
  • GXS.CUDA.Compiler
  • GXS.CUDA.FFTPlan
  • GXS.CUDA.Graphics
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAEditor |
Class TCUDACompilerEditor |
Class TCUDACompilerSourceProperty |
Class TCUDADeviceProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

ToolsAPI, STREDIT,


GXSysHelp v.2.5: GXS.GPURegister: Class TCUDAEditor

Class TCUDAEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GPURegister

Declaration

type TCUDAEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TCUDAEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.GPURegister: Class TCUDACompilerEditor

Class TCUDACompilerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GPURegister

Declaration

type TCUDACompilerEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TCUDACompilerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.GPURegister: Class TCUDACompilerSourceProperty

Class TCUDACompilerSourceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GPURegister

Declaration

type TCUDACompilerSourceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TCUDACompilerSourceProperty

Overview

Fields

Private FModuleList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;
Private | procedure RefreshModuleList;

Description

Fields

Private FModuleList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;

This item has no description.

Private procedure RefreshModuleList;


GXSysHelp v.2.5: GXS.GPURegister: Class TCUDADeviceProperty

Class TCUDADeviceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.GPURegister

Declaration

type TCUDADeviceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TCUDADeviceProperty

Overview

Fields

Private FDeviceList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;

Description

Fields

Private FDeviceList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;


GXSysHelp v.2.5: GXS.Graph

Unit GXS.Graph

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.OpenGL4
  • GXS.XOpenGL
  • GXS.Scene
  • GXS.Context
  • GLScene.VectorGeometry
  • GXS.Material
  • GXS.Objects
  • GXS.VectorLists
  • GXS.Color
  • GXS.BaseClasses
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSamplingScale |
Class TgxHeightField |
Class TgxXYZGrid |

Types

TgxHeightFieldColorMode = (...);
TgxHeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TgxColorVector; var TexPoint: TTexPoint) of object;
TgxHeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TgxColorVector; var TexPoint: TTexPoint) of object;
TgxHeightFieldOption = (...);
TgxHeightFieldOptions = set of TgxHeightFieldOption;
TXYZGridLinesStyle = (...);
TXYZGridPart = (...);
TXYZGridParts = set of TXYZGridPart;

Description

Types

TgxHeightFieldColorMode = (...);

This item has no description.

Values
  • hfcmNone
  • hfcmEmission
  • hfcmAmbient
  • hfcmDiffuse
  • hfcmAmbientAndDiffuse
TgxHeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TgxColorVector; var TexPoint: TTexPoint) of object;

This item has no description.

TgxHeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TgxColorVector; var TexPoint: TTexPoint) of object;

This item has no description.

TgxHeightFieldOption = (...);

This item has no description.

Values
  • hfoTextureCoordinates
  • hfoTwoSided
TgxHeightFieldOptions = set of TgxHeightFieldOption;

This item has no description.

TXYZGridLinesStyle = (...);

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.

Values
  • strLine
  • glsSegments
TXYZGridPart = (...);

This item has no description.

Values
  • gpX
  • gpY
  • gpZ
TXYZGridParts = set of TXYZGridPart;


GXSysHelp v.2.5: GXS.Graph: Class TgxSamplingScale

Class TgxSamplingScale

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graph

Declaration

type TgxSamplingScale = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TgxSamplingScale

Overview

Fields

Private | FMin: Single;
Private | FMax: Single;
Private | FOrigin: Single;
Private | FStep: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Public | function MaxStepCount: Integer;
Public | function StepBase: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);

Properties

Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property Origin: Single read FOrigin write SetOrigin;
Published | property Step: Single read FStep write SetStep;

Description

Fields

Private FMin: Single;

This item has no description.

Private FMax: Single;

This item has no description.

Private FOrigin: Single;

This item has no description.

Private FStep: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean;

This item has no description.

Public function MaxStepCount: Integer;

Maximum number of steps that can occur between Min and Max.

Public function StepBase: Single;

Returns the Base value for Step browsing. ie. the lowest value (superior to Min) that verifies Frac((Origin-StepBase)/Step)=0.0, this value may be superior to Max.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);

This item has no description.

Properties

Published property Max: Single read FMax write SetMax;

This item has no description.

Published property Min: Single read FMin write SetMin;

This item has no description.

Published property Origin: Single read FOrigin write SetOrigin;

This item has no description.

Published property Step: Single read FStep write SetStep;


GXSysHelp v.2.5: GXS.Graph: Class TgxHeightField

Class TgxHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graph

Declaration

type TgxHeightField = class(TgxSceneObject)

Description

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxHeightField

Overview

Fields

Private | FOnGetHeight: TgxHeightFieldGetHeightEvent;
Private | FOnGetHeight2: TgxHeightFieldGetHeight2Event;
Private | FXSamplingScale: TgxSamplingScale;
Private | FYSamplingScale: TgxSamplingScale;
Private | FOptions: TgxHeightFieldOptions;
Private | FTriangleCount: Integer;
Private | FColorMode: TgxHeightFieldColorMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property ColorMode: TgxHeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;
Published | property OnGetHeight: TgxHeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;
Published | property OnGetHeight2: TgxHeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;
Published | property Options: TgxHeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];
Public | property TriangleCount: Integer read FTriangleCount;
Published | property XSamplingScale: TgxSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TgxSamplingScale read FYSamplingScale write SetYSamplingScale;

Description

Fields

Private FOnGetHeight: TgxHeightFieldGetHeightEvent;

This item has no description.

Private FOnGetHeight2: TgxHeightFieldGetHeight2Event;

This item has no description.

Private FXSamplingScale: TgxSamplingScale;

This item has no description.

Private FYSamplingScale: TgxSamplingScale;

This item has no description.

Private FOptions: TgxHeightFieldOptions;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FColorMode: TgxHeightFieldColorMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property ColorMode: TgxHeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;

Define if and how per vertex color is used.

Published property OnGetHeight: TgxHeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;

Primary event to return heights.

Published property OnGetHeight2: TgxHeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;

Alternate this event to return heights. This events passes an extra "Sender" parameter, it will be invoked only if OnGetHeight isn't defined.

Published property Options: TgxHeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

This item has no description.

Published property XSamplingScale: TgxSamplingScale read FXSamplingScale write SetXSamplingScale;

This item has no description.

Published property YSamplingScale: TgxSamplingScale read FYSamplingScale write SetYSamplingScale;


GXSysHelp v.2.5: GXS.Graph: Class TgxXYZGrid

Class TgxXYZGrid

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graph

Declaration

type TgxXYZGrid = class(TgxLineBase)

Description

An XYZ Grid object. Renders an XYZ grid using lines.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase
  • TgxXYZGrid

Overview

Fields

Private | FXSamplingScale: TgxSamplingScale;
Private | FYSamplingScale: TgxSamplingScale;
Private | FZSamplingScale: TgxSamplingScale;
Private | FParts: TXYZGridParts;
Private | FLinesStyle: TXYZGridLinesStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property LinesSmoothing: Boolean write SetLinesSmoothing stored False;
Published | property LinesStyle: TXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;
Published | property Parts: TXYZGridParts read FParts write SetParts default [gpX, gpY];
Published | property XSamplingScale: TgxSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TgxSamplingScale read FYSamplingScale write SetYSamplingScale;
Published | property ZSamplingScale: TgxSamplingScale read FZSamplingScale write SetZSamplingScale;

Description

Fields

Private FXSamplingScale: TgxSamplingScale;

This item has no description.

Private FYSamplingScale: TgxSamplingScale;

This item has no description.

Private FZSamplingScale: TgxSamplingScale;

This item has no description.

Private FParts: TXYZGridParts;

This item has no description.

Private FLinesStyle: TXYZGridLinesStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property LinesSmoothing: Boolean write SetLinesSmoothing stored False;

Adjusts lines smoothing (or antialiasing). Obsolete, now maps to Antialiased property.

Published property LinesStyle: TXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;

This item has no description.

Published property Parts: TXYZGridParts read FParts write SetParts default [gpX, gpY];

This item has no description.

Published property XSamplingScale: TgxSamplingScale read FXSamplingScale write SetXSamplingScale;

This item has no description.

Published property YSamplingScale: TgxSamplingScale read FYSamplingScale write SetYSamplingScale;

This item has no description.

Published property ZSamplingScale: TgxSamplingScale read FZSamplingScale write SetZSamplingScale;


GXSysHelp v.2.5: GXS.Graphics

Unit GXS.Graphics

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • System.UITypes
  • System.Math
  • FMX.Graphics
  • FMX.Dialogs
  • FMX.Types
  • FMX.Consts
  • GLScene.OpenGL4
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GXS.ApplicationFileIO
  • GXS.Context
  • GXS.ImageUtils
  • GLScene.Utils
  • GXS.Color
  • GLScene.TextureFormat
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxPixel24 |
Packed Record TgxPixel32 |
Record TgxImageLevelDesc |
Class TgxBaseImage |
Class TgxImage |
Class TRasterFileFormat |
Class TRasterFileFormatsList |
Class EInvalidRasterFile |

Functions and Procedures

procedure Div2(var Value: Integer);
procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);
procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);
procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);
function GetRasterFileFormats: TRasterFileFormatsList;
function RasterFileFormatExtensionByIndex(index: Integer): string;
procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TgxBaseImageClass);
procedure UnregisterRasterFormat(AClass: TgxBaseImageClass);
function GetImageLodNumber(w, h, d: integer; IsVolume: Boolean): Integer;

Types

PgxPixel24 = ˆTgxPixel24;
PgxPixel32 = ˆTgxPixel32;
PgxPixel32Array = ˆTgxPixel32Array;
TgxBaseImageClass = class of TgxBaseImage;
TgxBitmap32 = TgxImage;
TgxImageLODRange = 0..15;
TgxImagePiramid = array[TgxImageLODRange] of TgxImageLevelDesc;
TgxLODStreamingState = (...);
TgxPixel32Array = array[0..MaxInt shr 3] of TgxPixel32;

Variables

vVerticalFlipDDS: Boolean = True;

Description

Functions and Procedures

procedure Div2(var Value: Integer);

This item has no description.

procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);

This item has no description.

procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);

This item has no description.

procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);

This item has no description.

function GetRasterFileFormats: TRasterFileFormatsList;

Read access to the list of registered vector file formats

function RasterFileFormatExtensionByIndex(index: Integer): string;

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.

procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TgxBaseImageClass);

This item has no description.

procedure UnregisterRasterFormat(AClass: TgxBaseImageClass);

This item has no description.

function GetImageLodNumber(w, h, d: integer; IsVolume: Boolean): Integer;

Return an optimal number of texture pyramid

Types

PgxPixel24 = ˆTgxPixel24;

This item has no description.

PgxPixel32 = ˆTgxPixel32;

This item has no description.

PgxPixel32Array = ˆTgxPixel32Array;

This item has no description.

TgxBaseImageClass = class of TgxBaseImage;

This item has no description.

TgxBitmap32 = TgxImage;

This item has no description.

TgxImageLODRange = 0..15;

This item has no description.

TgxImagePiramid = array[TgxImageLODRange] of TgxImageLevelDesc;

This item has no description.

TgxLODStreamingState = (...);

This item has no description.

Values
  • ssKeeping
  • ssLoading
  • ssLoaded
  • ssTransfered
TgxPixel32Array = array[0..MaxInt shr 3] of TgxPixel32;

This item has no description.

Variables

vVerticalFlipDDS: Boolean = True;


GXSysHelp v.2.5: GXS.Graphics: Packed Record TgxPixel24

Packed Record TgxPixel24

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TgxPixel24 = packed record

Description

This item has no description.

Overview

Fields

Public | r: Byte;
Public | g: Byte;
Public | b: Byte;

Description

Fields

Public r: Byte;

This item has no description.

Public g: Byte;

This item has no description.

Public b: Byte;


GXSysHelp v.2.5: GXS.Graphics: Packed Record TgxPixel32

Packed Record TgxPixel32

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TgxPixel32 = packed record

Description

This item has no description.

Overview

Fields

Public | r: Byte;
Public | g: Byte;
Public | b: Byte;
Public | a: Byte;

Description

Fields

Public r: Byte;

This item has no description.

Public g: Byte;

This item has no description.

Public b: Byte;

This item has no description.

Public a: Byte;


GXSysHelp v.2.5: GXS.Graphics: Record TgxImageLevelDesc

Record TgxImageLevelDesc

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TgxImageLevelDesc = record

Description

This item has no description.

Overview

Fields

Public | Width: Integer;
Public | Height: Integer;
Public | Depth: Integer;
Public | PBO: TgxUnpackPBOHandle;
Public | MapAddress: Pointer;
Public | Offset: LongWord;
Public | StreamOffset: LongWord;
Public | Size: LongWord;
Public | State: TgxLODStreamingState;

Description

Fields

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public Depth: Integer;

This item has no description.

Public PBO: TgxUnpackPBOHandle;

This item has no description.

Public MapAddress: Pointer;

This item has no description.

Public Offset: LongWord;

This item has no description.

Public StreamOffset: LongWord;

This item has no description.

Public Size: LongWord;

This item has no description.

Public State: TgxLODStreamingState;


GXSysHelp v.2.5: GXS.Graphics: Class TgxBaseImage

Class TgxBaseImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TgxBaseImage = class(TgxDataFile)

Description

This item has no description. Showing description inherited from TgxDataFile.

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage

Overview

Fields

Private | FSourceStream: TStream;
Private | FStreamLevel: TgxImageLODRange;
Private | FFinishEvent: TgxFinishTaskEvent;

Methods

Public | constructor Create; reintroduce; virtual;
Public | destructor Destroy; override;
Public | function AssignFromTexture( AHandle: TgxTextureHandle; const CastToFormat: Boolean; const intFormat: TglInternalFormat = tfRGBA8; const colorFormat: NativeUInt = 0; const dataType: NativeUInt = 0): Boolean; virtual;
Public | function ConvertCrossToCubeMap: Boolean;
Public | function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;
Public | function DataSize: Cardinal;
Public | function GetTextureTarget: TGLTextureTarget;
Public | function IsCompressed: Boolean;
Public | function IsEmpty: Boolean;
Public | function IsVolume: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;
Public | procedure Narrow;
Public | procedure RegisterAsOpenRXTexture( AHandle: TgxTextureHandle; aMipmapGen: Boolean; aTexFormat: NativeUInt; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;
Public | procedure SetErrorImage;
Public | procedure UnMipmap; virtual;
Public | procedure UpdateLevelsInfo;

Properties

Public | property ColorFormat: Cardinal read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap;
Public | property Data: PgxPixel32Array read GetData;
Public | property DataType: Cardinal read fDataType;
Public | property ElementSize: Integer read fElementSize;
Public | property InternalFormat: TglInternalFormat read FInternalFormat;
Public | property LevelCount: TgxImageLODRange read fLevelCount;
Public | property LevelDepth[ALOD: TgxImageLODRange]: Integer read GetLevelDepth;
Public | property LevelHeight[ALOD: TgxImageLODRange]: Integer read GetLevelHeight;
Public | property LevelOffset[ALOD: TgxImageLODRange]: Integer read GetLevelOffset;
Public | property LevelPixelBuffer[ALOD: TgxImageLODRange]: TgxUnpackPBOHandle read GetLevelPBO;
Public | property LevelSizeInByte[ALOD: TgxImageLODRange]: Integer read GetLevelSizeInByte;
Public | property LevelStreamingState[ALOD: TgxImageLODRange]: TgxLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;
Public | property LevelWidth[ALOD: TgxImageLODRange]: Integer read GetLevelWidth;
Public | property TextureArray: Boolean read fTextureArray;

Description

Fields

Private FSourceStream: TStream;

This item has no description.

Private FStreamLevel: TgxImageLODRange;

This item has no description.

Private FFinishEvent: TgxFinishTaskEvent;

This item has no description.

Methods

Public constructor Create; reintroduce; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AssignFromTexture( AHandle: TgxTextureHandle; const CastToFormat: Boolean; const intFormat: TglInternalFormat = tfRGBA8; const colorFormat: NativeUInt = 0; const dataType: NativeUInt = 0): Boolean; virtual;

Assigns from any Texture.

Public function ConvertCrossToCubeMap: Boolean;

Convert vertical cross format of non compressed, non mipmaped image to six face of cube map

Public function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;

Convert flat image to volume by dividing it into slice.

Public function DataSize: Cardinal;

Return size in byte of all image

Public function GetTextureTarget: TGLTextureTarget;

This item has no description.

Public function IsCompressed: Boolean;

This item has no description.

Public function IsEmpty: Boolean;

True if the bitmap is empty (ie. width or height is zero).

Public function IsVolume: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;

Generate LOD pyramid

Public procedure Narrow;

Narrow image data to simple RGBA8 ubyte

Public procedure RegisterAsOpenRXTexture( AHandle: TgxTextureHandle; aMipmapGen: Boolean; aTexFormat: NativeUInt; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;

Registers the bitmap's content as an OpenGL texture map.

Public procedure SetErrorImage;

Set image of error.

Public procedure UnMipmap; virtual;

Leave top level and remove other

Public procedure UpdateLevelsInfo;

Recalculate levels information based on first level.

Properties

Public property ColorFormat: Cardinal read fColorFormat;

This item has no description.

Public property CubeMap: Boolean read fCubeMap;

This item has no description.

Public property Data: PgxPixel32Array read GetData;

Direct Access to image data

Public property DataType: Cardinal read fDataType;

This item has no description.

Public property ElementSize: Integer read fElementSize;

This item has no description.

Public property InternalFormat: TglInternalFormat read FInternalFormat;

This item has no description.

Public property LevelCount: TgxImageLODRange read fLevelCount;

Number of levels.

Public property LevelDepth[ALOD: TgxImageLODRange]: Integer read GetLevelDepth;

This item has no description.

Public property LevelHeight[ALOD: TgxImageLODRange]: Integer read GetLevelHeight;

This item has no description.

Public property LevelOffset[ALOD: TgxImageLODRange]: Integer read GetLevelOffset;

LOD offset in byte

Public property LevelPixelBuffer[ALOD: TgxImageLODRange]: TgxUnpackPBOHandle read GetLevelPBO;

This item has no description.

Public property LevelSizeInByte[ALOD: TgxImageLODRange]: Integer read GetLevelSizeInByte;

LOD size in byte

Public property LevelStreamingState[ALOD: TgxImageLODRange]: TgxLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;

This item has no description.

Public property LevelWidth[ALOD: TgxImageLODRange]: Integer read GetLevelWidth;

This item has no description.

Public property TextureArray: Boolean read fTextureArray;


GXSysHelp v.2.5: GXS.Graphics: Class TgxImage

Class TgxImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TgxImage = class(TgxBaseImage)

Description

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GXS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseImage
  • TgxImage

Overview

Fields

Private | FVerticalReverseOnAssignFromBitmap: Boolean;
Private | FBlank: boolean;
Private | fOldColorFormat: Cardinal;
Private | fOldDataType: Cardinal;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Create32BitsBitmap: TBitmap;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TBitmap);
Public | procedure AssignFromTexture2D(textureHandle: TgxTextureHandle); overload;
Public | procedure AssignFromTexture2D(textureHandle: Cardinal); overload;
Public | procedure AssignToBitmap(aBitmap: TBitmap);
Public | procedure BrightnessCorrection(const factor: Single);
Public | procedure DownSampleByFactor2;
Public | procedure DrawPixels(const x, y: Single);
Public | procedure GammaCorrection(const gamma: Single);
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); override;
Public | procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);
Public | procedure InvertAlpha;
Public | procedure NormalizeNormalMap;
Public | procedure ReadPixels(const area: TRect);
Public | procedure SetAlphaFromIntensity;
Public | procedure SetAlphaToFloatValue(const aValue: Single);
Public | procedure SetAlphaToValue(const aValue: Byte);
Public | procedure SetAlphaTransparentForColor(const aColor: TgxPixel32); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TColor); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TgxPixel24); overload;
Public | procedure SetColorFormatDataType(const AColorFormat, ADataType: Cardinal);
Public | procedure SqrtAlpha;
Public | procedure UnMipmap; override;
Private | procedure DataConvertTask;

Properties

Public | property Blank: boolean read FBlank write SetBlank;
Public | property ColorFormat: Cardinal read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap write SetCubeMap;
Public | property DataType: Cardinal read fDataType;
Public | property Depth: Integer read GetDepth write SetDepth;
Public | property ElementSize: Integer read fElementSize;
Public | property Height: Integer read GetHeight write SetHeight;
Public | property InternalFormat: TglInternalFormat read FInternalFormat write FInternalFormat;
Public | property ScanLine[index: Integer]: PgxPixel32Array read GetScanLine;
Public | property TextureArray: Boolean read fTextureArray write SetArray;
Public | property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;
Public | property Width: Integer read GetWidth write SetWidth;

Description

Fields

Private FVerticalReverseOnAssignFromBitmap: Boolean;

This item has no description.

Private FBlank: boolean;

This item has no description.

Private fOldColorFormat: Cardinal;

This item has no description.

Private fOldDataType: Cardinal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Create32BitsBitmap: TBitmap;

Create a 32 bits TBitmap from self content.

Public procedure Assign(Source: TPersistent); override;

Accepts TgxImage and TGraphic subclasses.

Public procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TBitmap);

Assigns from a 24 bits bitmap without swapping RGB. This is faster than a regular assignment, but R and B channels will be reversed (from what you would view in a TImage). Suitable if you do your own drawing and reverse RGB on the drawing side. If you're after speed, don't forget to set the bitmap's dimensions to a power of two!

Public procedure AssignFromTexture2D(textureHandle: TgxTextureHandle); overload;

Assigns from a Texture handle. If the handle is invalid, the bitmap32 will be empty.

Public procedure AssignFromTexture2D(textureHandle: Cardinal); overload;

Assigns from a 2D Texture. The context which holds the texture must be active and the texture handle valid.

Public procedure AssignToBitmap(aBitmap: TBitmap);

Converts a TImage back into a TBitmap

Public procedure BrightnessCorrection(const factor: Single);

Apply a brightness (scaled saturating) correction to the RGB components.

Public procedure DownSampleByFactor2;

Downsample the bitmap by a factor of 2 in both dimensions. If one of the dimensions is 1 or less, does nothing.

Public procedure DrawPixels(const x, y: Single);

Draws the whole bitmap at given position in the current OpenGL context. This function must be called with a rendering context active. Blending and Alpha channel functions are not altered by this function and must be adjusted separately.

Public procedure GammaCorrection(const gamma: Single);

Apply a gamma correction to the RGB components.

Public procedure GenerateMipmap(AFilter: TImageFilterFunction); override;

Generate level of detail.

Public procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);

Converts a grayscale 'elevation' bitmap to normal map. Actually, only the Green component in the original bitmap is used.

Public procedure InvertAlpha;

Inverts the AlphaChannel component. What was transparent becomes opaque and vice-versa.

Public procedure NormalizeNormalMap;

Assumes the bitmap content is a normal map and normalizes all pixels.

Public procedure ReadPixels(const area: TRect);

Reads the given area from the current active OpenGL rendering context. The best spot for reading pixels is within a SceneViewer's PostRender event : the scene has been fully rendered and the OpenGL context is still active.

Public procedure SetAlphaFromIntensity;

Set Alpha channel values to the pixel intensity. The intensity is calculated as the mean of RGB components.

Public procedure SetAlphaToFloatValue(const aValue: Single);

Set Alpha channel values to given float [0..1] value.

Public procedure SetAlphaToValue(const aValue: Byte);

Set Alpha channel values to given byte value.

Public procedure SetAlphaTransparentForColor(const aColor: TgxPixel32); overload;

This item has no description.

Public procedure SetAlphaTransparentForColor(const aColor: TColor); overload;

Set Alpha channel to 0 for pixels of given color, 255 for others). This makes pixels of given color totally transparent while the others are completely opaque.

Public procedure SetAlphaTransparentForColor(const aColor: TgxPixel24); overload;

This item has no description.

Public procedure SetColorFormatDataType(const AColorFormat, ADataType: Cardinal);

Recast image OpenGL data type and color format.

Public procedure SqrtAlpha;

AlphaChannel components are replaced by their sqrt.

Public procedure UnMipmap; override;

Clear all levels except first.

Private procedure DataConvertTask;

This item has no description.

Properties

Public property Blank: boolean read FBlank write SetBlank;

Set Blank to true if you actually don't need to allocate data in main memory. Useful for textures that are generated by the GPU on the fly.

Public property ColorFormat: Cardinal read fColorFormat;

OpenGL color format

Public property CubeMap: Boolean read fCubeMap write SetCubeMap;

This item has no description.

Public property DataType: Cardinal read fDataType;

OpenGL data type

Public property Depth: Integer read GetDepth write SetDepth;

Depth of the bitmap.

Public property ElementSize: Integer read fElementSize;

Size in bytes of pixel or block

Public property Height: Integer read GetHeight write SetHeight;

Height of the bitmap.

Public property InternalFormat: TglInternalFormat read FInternalFormat write FInternalFormat;

Recommended texture internal format

Public property ScanLine[index: Integer]: PgxPixel32Array read GetScanLine;

Access to a specific Bitmap ScanLine. index should be in the [0; Height[ range. Warning : this function is NOT protected against invalid indexes, and invoking it is invalid if the bitmap is Empty.

Public property TextureArray: Boolean read fTextureArray write SetArray;

This item has no description.

Public property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;

This item has no description.

Public property Width: Integer read GetWidth write SetWidth;

Width of the bitmap.


GXSysHelp v.2.5: GXS.Graphics: Class TRasterFileFormat

Class TRasterFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TRasterFileFormat = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TRasterFileFormat

Overview

Fields

Public | BaseImageClass: TgxBaseImageClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public BaseImageClass: TgxBaseImageClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: Integer;


GXSysHelp v.2.5: GXS.Graphics: Class TRasterFileFormatsList

Class TRasterFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type TRasterFileFormatsList = class(TgxPersistentObjectList)

Description

Stores registered raster file Formatx.

Hierarchy

  • TgxPersistentObjectList
  • TRasterFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TgxBaseImageClass;
Public | function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const fileName: string): TgxBaseImageClass;
Public | function FindFromStream(const AStream: TStream): TgxBaseImageClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxBaseImageClass);
Public | procedure BuildFilterStrings(imageFileClass: TgxBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TgxBaseImageClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(ext: string): TgxBaseImageClass;

This item has no description.

Public function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;

This item has no description.

Public function FindFromFileName(const fileName: string): TgxBaseImageClass;

This item has no description.

Public function FindFromStream(const AStream: TStream): TgxBaseImageClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxBaseImageClass);

This item has no description.

Public procedure BuildFilterStrings(imageFileClass: TgxBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);

This item has no description.

Public procedure Remove(AClass: TgxBaseImageClass);


GXSysHelp v.2.5: GXS.Graphics: Class EInvalidRasterFile

Class EInvalidRasterFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Graphics

Declaration

type EInvalidRasterFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EInvalidRasterFile


GXSysHelp v.2.5: GXS.Gui

Unit GXS.Gui

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.BitmapFont
  • GXS.Material
  • GXS.Context
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Coordinates
  • GXS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBaseGuiObject |
Record TGUIRect |
Class TgxGuiElement |
Class TgxGuiElementList |
Class TgxGuiComponent |
Class TgxGuiComponentList |
Class TgxGuiLayout |

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean;

Types

TGUIAlignments = (...);
TGUIDrawResult = array[TGUIAlignments] of TGUIRect;
TgxGuiComponentName = string;
TgxGuiElementName = string;

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);

Description

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean;

This item has no description.

Types

TGUIAlignments = (...);

This item has no description.

Values
  • GLAlTopLeft
  • GLAlTop
  • GLAlTopRight
  • GLAlLeft
  • GLAlCenter
  • GLAlRight
  • GLAlBottomLeft
  • GLAlBottom
  • GLAlBottomRight
  • GLAlBorder
TGUIDrawResult = array[TGUIAlignments] of TGUIRect;

This item has no description.

TgxGuiComponentName = string;

This item has no description.

TgxGuiElementName = string;

This item has no description.

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);


GXSysHelp v.2.5: GXS.Gui: Class TgxBaseGuiObject

Class TgxBaseGuiObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxBaseGuiObject = class(TgxBaseSceneObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject

Overview

Fields

Private | FRecursiveVisible: Boolean;
Private | FWidth: Single;
Private | FHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure AddChild(AChild: TgxBaseSceneObject); override;
Public | procedure Insert(aIndex: Integer; aChild: TgxBaseSceneObject); override;

Properties

Public | property Height: Single read FHeight write SetHeight;
Public | property Left: Single read GetLeft write SetLeft;
Public | property RecursiveVisible: Boolean read FRecursiveVisible;
Public | property Top: Single read GetTop write SetTop;
Public | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FRecursiveVisible: Boolean;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure AddChild(AChild: TgxBaseSceneObject); override;

This item has no description.

Public procedure Insert(aIndex: Integer; aChild: TgxBaseSceneObject); override;

This item has no description.

Properties

Public property Height: Single read FHeight write SetHeight;

GuiComponent Height in 3D world units.

Public property Left: Single read GetLeft write SetLeft;

GuiComponent Left in 3D world units.

Public property RecursiveVisible: Boolean read FRecursiveVisible;

This item has no description.

Public property Top: Single read GetTop write SetTop;

GuiComponent Top in 3D world units.

Public property Width: Single read FWidth write SetWidth;

GuiComponent Width in 3D world units.


GXSysHelp v.2.5: GXS.Gui: Record TGUIRect

Record TGUIRect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TGUIRect = record

Description

This item has no description.

Overview

Fields

Public | X1: Single;
Public | Y1: Single;
Public | X2: Single;
Public | Y2: Single;
Public | XTiles: Single;
Public | YTiles: Single;

Description

Fields

Public X1: Single;

This item has no description.

Public Y1: Single;

This item has no description.

Public X2: Single;

This item has no description.

Public Y2: Single;

This item has no description.

Public XTiles: Single;

This item has no description.

Public YTiles: Single;


GXSysHelp v.2.5: GXS.Gui: Class TgxGuiElement

Class TgxGuiElement

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxGuiElement = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxGuiElement

Overview

Fields

Private | FTopLeft: TgxCoordinates2;
Private | FBottomRight: TgxCoordinates2;
Private | FScale: TgxCoordinates2;
Private | FAlign: TGUIAlignments;
Private | FName: TgxGuiElementName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure AssignTo(Dest: TPersistent); override;

Properties

Published | property Align: TGUIAlignments read FAlign write FAlign;
Published | property BottomRight: TgxCoordinates2 read FBottomRight write FBottomRight;
Published | property Name: TgxGuiElementName read FName write SetName;
Published | property Scale: TgxCoordinates2 read FScale write FScale;
Published | property TopLeft: TgxCoordinates2 read FTopLeft write FTopLeft;

Description

Fields

Private FTopLeft: TgxCoordinates2;

This item has no description.

Private FBottomRight: TgxCoordinates2;

This item has no description.

Private FScale: TgxCoordinates2;

This item has no description.

Private FAlign: TGUIAlignments;

This item has no description.

Private FName: TgxGuiElementName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Properties

Published property Align: TGUIAlignments read FAlign write FAlign;

This item has no description.

Published property BottomRight: TgxCoordinates2 read FBottomRight write FBottomRight;

This item has no description.

Published property Name: TgxGuiElementName read FName write SetName;

This item has no description.

Published property Scale: TgxCoordinates2 read FScale write FScale;

This item has no description.

Published property TopLeft: TgxCoordinates2 read FTopLeft write FTopLeft;


GXSysHelp v.2.5: GXS.Gui: Class TgxGuiElementList

Class TgxGuiElementList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxGuiElementList = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxGuiElementList

Overview

Fields

Private FGuiComponent: TgxGuiComponent;

Methods

Public | constructor Create(AOwner: TgxGuiComponent);
Public | function GetOwner: TPersistent; override;
Public | function IndexOf(const Item: TgxGuiElement): Integer;
Public | procedure AssignTo(Dest: TPersistent); override;

Properties

Public property Items[index: Integer]: TgxGuiElement read GetItems write SetItems;

Description

Fields

Private FGuiComponent: TgxGuiComponent;

This item has no description.

Methods

Public constructor Create(AOwner: TgxGuiComponent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public function IndexOf(const Item: TgxGuiElement): Integer;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Properties

Public property Items[index: Integer]: TgxGuiElement read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Gui: Class TgxGuiComponent

Class TgxGuiComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxGuiComponent = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxGuiComponent

Overview

Fields

Private | FElements: TgxGuiElementList;
Private | FName: TgxGuiComponentName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function GetOwnerList: TgxGuiComponentList;
Public | procedure AssignTo(Dest: TPersistent); override;
Public | procedure RenderToArea(X1, Y1, X2, Y2: Single; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: Single = 1);

Properties

Published | property Elements: TgxGuiElementList read FElements write FElements;
Published | property Name: TgxGuiComponentName read FName write SetName;
Public | property Owner: TgxGuiComponentList read GetOwnerList;

Description

Fields

Private FElements: TgxGuiElementList;

This item has no description.

Private FName: TgxGuiComponentName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetOwnerList: TgxGuiComponentList;

This item has no description.

Public procedure AssignTo(Dest: TPersistent); override;

This item has no description.

Public procedure RenderToArea(X1, Y1, X2, Y2: Single; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: Single = 1);

This item has no description.

Properties

Published property Elements: TgxGuiElementList read FElements write FElements;

This item has no description.

Published property Name: TgxGuiComponentName read FName write SetName;

This item has no description.

Public property Owner: TgxGuiComponentList read GetOwnerList;


GXSysHelp v.2.5: GXS.Gui: Class TgxGuiComponentList

Class TgxGuiComponentList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxGuiComponentList = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxGuiComponentList

Overview

Fields

Private FLayout: TgxGuiLayout;

Methods

Public | constructor Create(AOwner: TgxGuiLayout);
Public | function FindItem(name: TgxGuiComponentName): TgxGuiComponent;
Public | function GetOwner: TPersistent; override;

Properties

Public property Items[index: Integer]: TgxGuiComponent read GetItems write SetItems;

Description

Fields

Private FLayout: TgxGuiLayout;

This item has no description.

Methods

Public constructor Create(AOwner: TgxGuiLayout);

This item has no description.

Public function FindItem(name: TgxGuiComponentName): TgxGuiComponent;

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Properties

Public property Items[index: Integer]: TgxGuiComponent read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Gui: Class TgxGuiLayout

Class TgxGuiLayout

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Gui

Declaration

type TgxGuiLayout = class(TgxUpdateAbleComponent)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxGuiLayout

Overview

Fields

Private | FBitmapFont: TgxCustomBitmapFont;
Private | FMaterial: TgxMaterial;
Private | FGuiComponents: TgxGuiComponentList;
Private | FFileName: string;
Private | FGuiComponentList: TList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddGuiComponent(Component: TgxUpdateAbleComponent);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure LoadFromFile(FN: string);
Public | procedure LoadFromStream(Stream: TStream);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RemoveGuiComponent(Component: TgxUpdateAbleComponent);
Public | procedure SaveToFile(FN: string);
Public | procedure SaveToStream(Stream: TStream);

Properties

Published | property BitmapFont: TgxCustomBitmapFont read FBitmapFont write FBitmapFont;
Published | property FileName: string read FFileName write SetFileName;
Published | property GuiComponents: TgxGuiComponentList read FGuiComponents write FGuiComponents;
Published | property Material: TgxMaterial read FMaterial write FMaterial;

Description

Fields

Private FBitmapFont: TgxCustomBitmapFont;

This item has no description.

Private FMaterial: TgxMaterial;

This item has no description.

Private FGuiComponents: TgxGuiComponentList;

This item has no description.

Private FFileName: string;

This item has no description.

Private FGuiComponentList: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddGuiComponent(Component: TgxUpdateAbleComponent);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure LoadFromFile(FN: string);

This item has no description.

Public procedure LoadFromStream(Stream: TStream);

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure RemoveGuiComponent(Component: TgxUpdateAbleComponent);

This item has no description.

Public procedure SaveToFile(FN: string);

This item has no description.

Public procedure SaveToStream(Stream: TStream);

This item has no description.

Properties

Published property BitmapFont: TgxCustomBitmapFont read FBitmapFont write FBitmapFont;

This item has no description.

Published property FileName: string read FFileName write SetFileName;

This item has no description.

Published property GuiComponents: TgxGuiComponentList read FGuiComponents write FGuiComponents;

This item has no description.

Published property Material: TgxMaterial read FMaterial write FMaterial;


GXSysHelp v.2.5: GXS.HeightData

Unit GXS.HeightData

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Objects
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.BaseClasses
  • GXS.ApplicationFileIO
  • GXS.ImageUtils
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxHeightDataSource |
Record TgxHeightDataUser |
Class TgxHeightData |
Class TgxHeightDataThread |
Class TgxBitmapHDS |
Class TgxCustomHDS |
Class TgxTerrainBaseHDS |
Class TgxHeightDataSourceFilter |

Types

PByteRaster = ˆTByteRaster;
PSingleRaster = ˆTSingleRaster;
PSmallIntArray = ˆTSmallintArray;
PSmallIntRaster = ˆTSmallIntRaster;
TByteArray = array [0 .. MaxInt div (2 * SizeOf(Byte))] of Byte;
TByteRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PByteArray;
TgxHeightDataClass = class of TgxHeightData;
TgxHeightDataState = (...);
TgxHeightDataType = (...);
THDTextureCoordinatesMode = (...);
TMarkDirtyEvent = procedure(const Area: TRect) of object;
TOnHeightDataDirtyEvent = procedure(sender: TgxHeightData) of object;
TSingleRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSingleArray;
TSmallintArray = array [0 .. MaxInt div (2 * SizeOf(SmallInt))] of SmallInt;
TSmallIntRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer)) ] of PSmallIntArray;
TSourceDataFetchedEvent = procedure(sender: TgxHeightDataSourceFilter; HeightData: TgxHeightData) of object;
TStartPreparingDataEvent = procedure(HeightData: TgxHeightData) of object;

Description

Types

PByteRaster = ˆTByteRaster;

This item has no description.

PSingleRaster = ˆTSingleRaster;

This item has no description.

PSmallIntArray = ˆTSmallintArray;

This item has no description.

PSmallIntRaster = ˆTSmallIntRaster;

This item has no description.

TByteArray = array [0 .. MaxInt div (2 * SizeOf(Byte))] of Byte;

for CreateMonochromeBitmap

TByteRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PByteArray;

This item has no description.

TgxHeightDataClass = class of TgxHeightData;

This item has no description.

TgxHeightDataState = (...);

Possible states for a TgxHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile

Values
  • hdsQueued
  • hdsPreparing
  • hdsReady
  • hdsNone
TgxHeightDataType = (...);

Determines the type of data stored in a TgxHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.

Values
  • hdtByte
  • hdtSmallInt
  • hdtSingle
  • hdtDefault
THDTextureCoordinatesMode = (...);

This item has no description.

Values
  • tcmWorld
  • tcmLocal
TMarkDirtyEvent = procedure(const Area: TRect) of object;

This item has no description.

TOnHeightDataDirtyEvent = procedure(sender: TgxHeightData) of object;

This item has no description.

TSingleRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer))] of PSingleArray;

This item has no description.

TSmallintArray = array [0 .. MaxInt div (2 * SizeOf(SmallInt))] of SmallInt;

This item has no description.

TSmallIntRaster = array [0 .. MaxInt div (2 * SizeOf(Pointer)) ] of PSmallIntArray;

This item has no description.

TSourceDataFetchedEvent = procedure(sender: TgxHeightDataSourceFilter; HeightData: TgxHeightData) of object;

This item has no description.

TStartPreparingDataEvent = procedure(HeightData: TgxHeightData) of object;


GXSysHelp v.2.5: GXS.HeightData: Class TgxHeightDataSource

Class TgxHeightDataSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxHeightDataSource = class(TComponent)

Description

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TgxHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TgxHeightData with its "Release" method) Pre-loading : specify a list of TgxHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource

Overview

Fields

Private | FData: TThreadList;
Private | FDataHash: array [0 .. 255] of TList;
Private | FThread: TThread;
Private | FMaxThreads: Integer;
Private | FMaxPoolSize: Integer;
Private | FHeightDataClass: TgxHeightDataClass;
Private | FDefaultHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetData(XLeft, YTop, size: Integer; DataType: TgxHeightDataType) : TgxHeightData; virtual;
Public | function Height: Integer; virtual; abstract;
Public | function InterpolatedHeight(x, y: Single; tileSize: Integer) : Single; virtual;
Public | function PreLoad(XLeft, YTop, size: Integer; DataType: TgxHeightDataType) : TgxHeightData; virtual;
Public | function Width: Integer; virtual; abstract;
Public | procedure AfterPreparingData(HeightData: TgxHeightData); virtual;
Public | procedure BeforePreparingData(HeightData: TgxHeightData); virtual;
Public | procedure CleanUp;
Public | procedure Clear;
Public | procedure MarkDirty(const Area: TRect); overload; virtual;
Public | procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;
Public | procedure MarkDirty; overload;
Public | procedure PreloadReplacement(aHeightData: TgxHeightData);
Public | procedure Release(aHeightData: TgxHeightData); virtual;
Public | procedure StartPreparingData(HeightData: TgxHeightData); virtual;
Public | procedure TextureCoordinates(HeightData: TgxHeightData; Stretch: boolean = false);
Public | procedure ThreadIsIdle; virtual;

Properties

Public | property Data: TThreadList read FData;
Public | property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;
Public | property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;
Public | property MaxThreads: Integer read FMaxThreads write SetMaxThreads;

Description

Fields

Private FData: TThreadList;

This item has no description.

Private FDataHash: array [0 .. 255] of TList;

stores all TgxHeightData, whatever their state/type

Private FThread: TThread;

X/Y hash references for HeightDatas

Private FMaxThreads: Integer;

queue manager

Private FMaxPoolSize: Integer;

This item has no description.

Private FHeightDataClass: TgxHeightDataClass;

This item has no description.

Private FDefaultHeight: Single;

FReleaseLatency : TDateTime; //Not used anymore???

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetData(XLeft, YTop, size: Integer; DataType: TgxHeightDataType) : TgxHeightData; virtual;

Base TgxHeightData requester method. Returns (by rebuilding it or from the cache) a TgxHeightData corresponding to the given area. Size must be a power of two. Subclasses may choose to publish it or just publish datasource- specific requester method using specific parameters.

Public function Height: Integer; virtual; abstract;

This item has no description.

Public function InterpolatedHeight(x, y: Single; tileSize: Integer) : Single; virtual;

Interpolates height for the given point.

Public function PreLoad(XLeft, YTop, size: Integer; DataType: TgxHeightDataType) : TgxHeightData; virtual;

Preloading request. See GetData for details.

Public function Width: Integer; virtual; abstract;

This item has no description.

Public procedure AfterPreparingData(HeightData: TgxHeightData); virtual;

This is called After "StartPreparingData", but always from the main thread.

Public procedure BeforePreparingData(HeightData: TgxHeightData); virtual;

This is called BEFORE StartPreparing Data, but always from the main thread.

Public procedure CleanUp;

Removes less used TDataHeight objects from the pool. Only removes objects whose state is hdsReady and UseCounter is zero, starting from the end of the list until total data size gets below MaxPoolSize (or nothing can be removed).

Public procedure Clear;

Empties the Data list, terminating thread if necessary. If some TgxHeightData are hdsInUse, triggers an exception and does nothing.

Public procedure MarkDirty(const Area: TRect); overload; virtual;

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;

This item has no description.

Public procedure MarkDirty; overload;

This item has no description.

Public procedure PreloadReplacement(aHeightData: TgxHeightData);

Replacing dirty tiles.

Public procedure Release(aHeightData: TgxHeightData); virtual;

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure StartPreparingData(HeightData: TgxHeightData); virtual;

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure TextureCoordinates(HeightData: TgxHeightData; Stretch: boolean = false);

This item has no description.

Public procedure ThreadIsIdle; virtual;

This item has no description.

Properties

Public property Data: TThreadList read FData;

Access to currently pooled TgxHeightData objects, and Thread locking

Public property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;

Height to return for undefined tiles.

Public property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Public property MaxThreads: Integer read FMaxThreads write SetMaxThreads;

Maximum number of background threads. If 0 (zero), multithreading is disabled and StartPreparingData will be called from the mainthread, and all preload requirements (queued TgxHeightData objects) will be loaded in sequence from the main thread. If 1, basic multithreading and queueing gets enabled, ie. StartPreparingData will be called from a thread, but from one thread only (ie. there is no need to implement a TgxHeightDataThread, just make sure StartPreparingData code is thread-safe). Other values (2 and more) are relevant only if you implement a TgxHeightDataThread subclass and fire it in StartPreparingData.


GXSysHelp v.2.5: GXS.HeightData: Record TgxHeightDataUser

Record TgxHeightDataUser

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxHeightDataUser = record

Description

This item has no description.

Overview

Fields

Public | user: TObject;
Public | event: TOnHeightDataDirtyEvent;

Description

Fields

Public user: TObject;

This item has no description.

Public event: TOnHeightDataDirtyEvent;


GXSysHelp v.2.5: GXS.HeightData: Class TgxHeightData

Class TgxHeightData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxHeightData = class(TgxUpdateAbleObject)

Description

TgxHeightData = class (TObject)

Hierarchy

  • TgxUpdateAbleObject
  • TgxHeightData

Overview

Fields

Private | FUsers: array of TgxHeightDataUser;
Private | FOwner: TgxHeightDataSource;
Private | FDataState: TgxHeightDataState;
Private | FSize: Integer;
Private | FXLeft: Integer;
Private | FYTop: Integer;
Private | FUseCounter: Integer;
Private | FDataType: TgxHeightDataType;
Private | FDataSize: Integer;
Private | FByteData: PByteArray;
Private | FByteRaster: PByteRaster;
Private | FSmallIntData: PSmallIntArray;
Private | FSmallIntRaster: PSmallIntRaster;
Private | FSingleData: PSingleArray;
Private | FSingleRaster: PSingleRaster;
Private | FTextureCoordinatesMode: THDTextureCoordinatesMode;
Private | FTCOffset: TTexPoint;
Private | FTCScale: TTexPoint;
Private | FMaterialName: String;
Private | FLibMaterial: TgxLibMaterial;
Private | FObjectTag: TObject;
Private | FTag: Integer;
Private | FTag2: Integer;
Private | FOnDestroy: TNotifyEvent;
Private | FDirty: boolean;
Private | FHeightMin: Single;
Private | FHeightMax: Single;
Public | OldVersion: TgxHeightData;
Public | NewVersion: TgxHeightData;
Public | DontUse: boolean;

Methods

Public | constructor Create(AOwner: TgxHeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: TgxHeightDataType); reintroduce; virtual;
Public | destructor Destroy; override;
Public | function ByteHeight(x, y: Integer): Byte;
Public | function Height(x, y: Integer): Single;
Public | function InterpolatedHeight(x, y: Single): Single;
Public | function Normal(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public | function NormalAtNode(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public | function OverlapsArea(const Area: TRect): boolean;
Public | function SingleHeight(x, y: Integer): Single;
Public | function SmallIntHeight(x, y: Integer): SmallInt;
Public | procedure Allocate(const Val: TgxHeightDataType); virtual;
Public | procedure MarkDirty;
Public | procedure RegisterUse;
Public | procedure Release;
Private | procedure BuildByteRaster;
Private | procedure BuildSingleRaster;
Private | procedure BuildSmallIntRaster;
Private | procedure ConvertByteToSingle;
Private | procedure ConvertByteToSmallInt;
Private | procedure ConvertSingleToByte;
Private | procedure ConvertSingleToSmallInt;
Private | procedure ConvertSmallIntToByte;
Private | procedure ConvertSmallIntToSingle;

Properties

Public | property ByteData: PByteArray read FByteData;
Public | property ByteRaster: PByteRaster read FByteRaster;
Public | property DataSize: Integer read FDataSize;
Public | property DataState: TgxHeightDataState read FDataState write FDataState;
Public | property DataType: TgxHeightDataType read FDataType write SetDataType;
Public | property Dirty: boolean read FDirty write FDirty;
Public | property HeightMax: Single read GetHeightMax write FHeightMax;
Public | property HeightMin: Single read GetHeightMin write FHeightMin;
Public | property LibMaterial: TgxLibMaterial read FLibMaterial write SetLibMaterial;
Public | property MaterialName: String read FMaterialName write SetMaterialName;
Public | property ObjectTag: TObject read FObjectTag write FObjectTag;
Public | property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;
Public | property Owner: TgxHeightDataSource read FOwner;
Public | property SingleData: PSingleArray read FSingleData;
Public | property SingleRaster: PSingleRaster read FSingleRaster;
Public | property Size: Integer read FSize;
Public | property SmallIntData: PSmallIntArray read FSmallIntData;
Public | property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;
Public | property Tag: Integer read FTag write FTag;
Public | property Tag2: Integer read FTag2 write FTag2;
Public | property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;
Public | property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;
Public | property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;
Public | property Thread: TgxHeightDataThread read FThread write FThread;
Public | property UseCounter: Integer read FUseCounter;
Public | property XLeft: Integer read FXLeft;
Public | property YTop: Integer read FYTop;

Description

Fields

Private FUsers: array of TgxHeightDataUser;

This item has no description.

Private FOwner: TgxHeightDataSource;

This item has no description.

Private FDataState: TgxHeightDataState;

This item has no description.

Private FSize: Integer;

This item has no description.

Private FXLeft: Integer;

This item has no description.

Private FYTop: Integer;

This item has no description.

Private FUseCounter: Integer;

This item has no description.

Private FDataType: TgxHeightDataType;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FByteData: PByteArray;

This item has no description.

Private FByteRaster: PByteRaster;

This item has no description.

Private FSmallIntData: PSmallIntArray;

This item has no description.

Private FSmallIntRaster: PSmallIntRaster;

This item has no description.

Private FSingleData: PSingleArray;

This item has no description.

Private FSingleRaster: PSingleRaster;

This item has no description.

Private FTextureCoordinatesMode: THDTextureCoordinatesMode;

This item has no description.

Private FTCOffset: TTexPoint;

This item has no description.

Private FTCScale: TTexPoint;

This item has no description.

Private FMaterialName: String;

This item has no description.

Private FLibMaterial: TgxLibMaterial;

Unsafe. Use FLibMaterial instead

Private FObjectTag: TObject;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FTag2: Integer;

This item has no description.

Private FOnDestroy: TNotifyEvent;

This item has no description.

Private FDirty: boolean;

This item has no description.

Private FHeightMin: Single;

This item has no description.

Private FHeightMax: Single;

This item has no description.

Public OldVersion: TgxHeightData;

This item has no description.

Public NewVersion: TgxHeightData;

previous version of this tile

Public DontUse: boolean;

the replacement tile

Methods

Public constructor Create(AOwner: TgxHeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: TgxHeightDataType); reintroduce; virtual;

Tells TerrainRenderer which version to use constructor Create(AOwner : TComponent); override;

Public destructor Destroy; override;

This item has no description.

Public function ByteHeight(x, y: Integer): Byte;

Height of point x, y as a Byte.

Public function Height(x, y: Integer): Single;

Returns the height as a single, whatever the DataType (slow).

Public function InterpolatedHeight(x, y: Single): Single;

Interopolated height of point x, y as a Single.

Public function Normal(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;

Calculates and returns the normal for vertex point x, y. Sub classes may provide normal cacheing, the default implementation being rather blunt.

Public function NormalAtNode(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;

Calculates and returns the normal for cell x, y.(between vertexes)

Public function OverlapsArea(const Area: TRect): boolean;

Returns True if the data tile overlaps the area.

Public function SingleHeight(x, y: Integer): Single;

Height of point x, y as a Single.

Public function SmallIntHeight(x, y: Integer): SmallInt;

Height of point x, y as a SmallInt.

Public procedure Allocate(const Val: TgxHeightDataType); virtual;

Allocate memory and prepare lookup tables for current datatype. Fails if already allocated. Made Dynamic to allow descendants

Public procedure MarkDirty;

Marks the tile as dirty. The immediate effect is currently the destruction of the tile.

Public procedure RegisterUse;

Increments UseCounter. User objects should implement a method that will be notified when the data becomes dirty, when invoked they should release the heightdata immediately after performing their own cleanups.

Public procedure Release;

Decrements UseCounter. When the counter reaches zero, notifies the Owner TgxHeightDataSource that the data is no longer used. The renderer should call Release when it no longer needs a THeighData, and never free/destroy the object directly.

Private procedure BuildByteRaster;

This item has no description.

Private procedure BuildSingleRaster;

This item has no description.

Private procedure BuildSmallIntRaster;

This item has no description.

Private procedure ConvertByteToSingle;

This item has no description.

Private procedure ConvertByteToSmallInt;

This item has no description.

Private procedure ConvertSingleToByte;

This item has no description.

Private procedure ConvertSingleToSmallInt;

This item has no description.

Private procedure ConvertSmallIntToByte;

This item has no description.

Private procedure ConvertSmallIntToSingle;

This item has no description.

Properties

Public property ByteData: PByteArray read FByteData;

Access to data as a byte array (n = y*Size+x). If TgxHeightData is not of type hdtByte, this value is nil.

Public property ByteRaster: PByteRaster read FByteRaster;

Access to data as a byte raster (y, x). If TgxHeightData is not of type hdtByte, this value is nil.

Public property DataSize: Integer read FDataSize;

Memory Size of the raw data in bytes.

Public property DataState: TgxHeightDataState read FDataState write FDataState;

Current state of the data.

Public property DataType: TgxHeightDataType read FDataType write SetDataType;

Type of the data. Assigning a new datatype will result in the data being converted.

Public property Dirty: boolean read FDirty write FDirty;

True if the data is dirty (ie. no longer up-to-date).

Public property HeightMax: Single read GetHeightMax write FHeightMax;

Maximum height in the tile. DataSources may assign a value to prevent automatic computation if they have a faster/already computed value.

Public property HeightMin: Single read GetHeightMin write FHeightMin;

Minimum height in the tile. DataSources may assign a value to prevent automatic computation if they have a faster/already computed value.

Public property LibMaterial: TgxLibMaterial read FLibMaterial write SetLibMaterial;

property LibMaterial : Links directly to the tile's TgxLibMaterial. Unlike 'MaterialName', this property also registers the tile as a user of the texture. This prevents TgxLibMaterials.DeleteUnusedTextures from deleting the used texture by mistake and causing Access Violations. Use this instead of the old MaterialName property, to prevent AV's.

Public property MaterialName: String read FMaterialName write SetMaterialName;

property MaterialName : String read FMaterialName write FMaterialName; (WARNING: Unsafe when deleting textures! If possible, rather use LibMaterial.)

Public property ObjectTag: TObject read FObjectTag write FObjectTag;

Reserved for renderer use.

Public property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;

Fired when the object is destroyed.

Public property Owner: TgxHeightDataSource read FOwner;

The component who created and maintains this data.

Public property SingleData: PSingleArray read FSingleData;

Access to data as a Single array (n = y*Size+x). If TgxHeightData is not of type hdtSingle, this value is nil.

Public property SingleRaster: PSingleRaster read FSingleRaster;

Access to data as a Single raster (y, x). If TgxHeightData is not of type hdtSingle, this value is nil.

Public property Size: Integer read FSize;

Size of the data square, in data units.

Public property SmallIntData: PSmallIntArray read FSmallIntData;

Access to data as a SmallInt array (n = y*Size+x). If TgxHeightData is not of type hdtSmallInt, this value is nil.

Public property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;

Access to data as a SmallInt raster (y, x). If TgxHeightData is not of type hdtSmallInt, this value is nil.

Public property Tag: Integer read FTag write FTag;

Reserved for renderer use.

Public property Tag2: Integer read FTag2 write FTag2;

Reserved for renderer use.

Public property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;

Texture coordinates generation mode. Default is tcmWorld coordinates.

Public property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;

This item has no description.

Public property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;

This item has no description.

Public property Thread: TgxHeightDataThread read FThread write FThread;

Used by perlin HDS.

Public property UseCounter: Integer read FUseCounter;

Counter for use registration. A TgxHeightData is not returned to the pool until this counter reaches a value of zero.

Public property XLeft: Integer read FXLeft;

World X coordinate of top left point.

Public property YTop: Integer read FYTop;

World Y coordinate of top left point.


GXSysHelp v.2.5: GXS.HeightData: Class TgxHeightDataThread

Class TgxHeightDataThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxHeightDataThread = class(TThread)

Description

A thread specialized for processing TgxHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TgxHeightDataThread

Overview

Methods

Public destructor Destroy; override;

Properties

Public property HeightData: TgxHeightData read FHeightData write FHeightData;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Properties

Public property HeightData: TgxHeightData read FHeightData write FHeightData;

The Height Data the thread is to prepare.


GXSysHelp v.2.5: GXS.HeightData: Class TgxBitmapHDS

Class TgxBitmapHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxBitmapHDS = class(TgxHeightDataSource)

Description

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBitmapHDS

Overview

Fields

Private | FScanLineCache: array of PByteArray;
Private | FBitmap: TBitmap;
Private | FPicture: TImage;
Private | FInfiniteWrap: boolean;
Private | FInverted: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Public | procedure MarkDirty(const Area: TRect); override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published | property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted: boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property Picture: TImage read FPicture write SetPicture;

Description

Fields

Private FScanLineCache: array of PByteArray;

This item has no description.

Private FBitmap: TBitmap;

This item has no description.

Private FPicture: TImage;

This item has no description.

Private FInfiniteWrap: boolean;

This item has no description.

Private FInverted: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure MarkDirty(const Area: TRect); override;

This item has no description. Showing description inherited from TgxHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;

If true the height field is wrapped indefinetely.

Published property Inverted: boolean read FInverted write SetInverted default True;

If true, the rendered terrain is a mirror image of the input data.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property Picture: TImage read FPicture write SetPicture;

The picture serving as Height field data reference. The picture is (if not already) internally converted to a 8 bit bitmap (grayscale). For better performance and to save memory, feed it this format!


GXSysHelp v.2.5: GXS.HeightData: Class TgxCustomHDS

Class TgxCustomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxCustomHDS = class(TgxHeightDataSource)

Description

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxCustomHDS

Overview

Fields

Private | FOnStartPreparingData: TStartPreparingDataEvent;
Private | FOnMarkDirty: TMarkDirtyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const Area: TRect); override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;

Description

Fields

Private FOnStartPreparingData: TStartPreparingDataEvent;

This item has no description.

Private FOnMarkDirty: TMarkDirtyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure MarkDirty(const Area: TRect); override;

This item has no description. Showing description inherited from TgxHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;

This item has no description.

Published property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;


GXSysHelp v.2.5: GXS.HeightData: Class TgxTerrainBaseHDS

Class TgxTerrainBaseHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxTerrainBaseHDS = class(TgxHeightDataSource)

Description

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxTerrainBaseHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published property MaxPoolSize;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.


GXSysHelp v.2.5: GXS.HeightData: Class TgxHeightDataSourceFilter

Class TgxHeightDataSourceFilter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightData

Declaration

type TgxHeightDataSourceFilter = class(TgxHeightDataSource)

Description

Height Data Source Filter. This component sits between the TgxTerrainRenderer, and a real TgxHeightDataSource. i.e. TgxTerrainRenderer links to this. This links to the real TgxHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TgxHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TgxHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TgxHeightData object from the Source HDS's cache, before linking your texture. See the new version of TgxBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxHeightDataSourceFilter

Overview

Fields

Private | FHDS: TgxHeightDataSource;
Private | FOnSourceDataFetched: TSourceDataFetchedEvent;
Private | FActive: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Release(aHeightData: TgxHeightData); override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published | property Active: boolean read FActive write FActive;
Published | property HeightDataSource: TgxHeightDataSource read FHDS write SetHDS;
Published | property MaxPoolSize;
Public | property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;

Description

Fields

Private FHDS: TgxHeightDataSource;

This item has no description.

Private FOnSourceDataFetched: TSourceDataFetchedEvent;

This item has no description.

Private FActive: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure Release(aHeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.Release.

Notification that the data is no longer used by the renderer. Default behaviour is just to change DataState to hdsReady (ie. return the data to the pool)

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property Active: boolean read FActive write FActive;

This item has no description.

Published property HeightDataSource: TgxHeightDataSource read FHDS write SetHDS;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Public property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;


GXSysHelp v.2.5: GXS.HeightTileFile

Unit GXS.HeightTileFile

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.ApplicationFileIO

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxHeightTileInfo |
Packed Record TgxHeightTile |
Packed Record THTFHeader |
Class TgxHeightTileFile |

Types

PgxHeightTileInfo = ˆTgxHeightTileInfo;
PHeightTile = ˆTgxHeightTile;
PIntegerArray = ˆTIntegerArray;
PPHeightTileInfo = ˆPgxHeightTileInfo;
PShortIntArray = ˆTShortIntArray;
PSmallIntArray = ˆTSmallIntArray;
TIntegerArray = array [0 .. MaxInt shr 3] of Integer;
TShortIntArray = array [0 .. MaxInt shr 2] of ShortInt;
TSmallIntArray = array [0 .. MaxInt shr 2] of SmallInt;

Constants

cHTFHashTableSize = 1023;
cHTFQuadTableSize = 31;

Description

Types

PgxHeightTileInfo = ˆTgxHeightTileInfo;

This item has no description.

PHeightTile = ˆTgxHeightTile;

This item has no description.

PIntegerArray = ˆTIntegerArray;

This item has no description.

PPHeightTileInfo = ˆPgxHeightTileInfo;

This item has no description.

PShortIntArray = ˆTShortIntArray;

This item has no description.

PSmallIntArray = ˆTSmallIntArray;

This item has no description.

TIntegerArray = array [0 .. MaxInt shr 3] of Integer;

This item has no description.

TShortIntArray = array [0 .. MaxInt shr 2] of ShortInt;

This item has no description.

TSmallIntArray = array [0 .. MaxInt shr 2] of SmallInt;

This item has no description.

Constants

cHTFHashTableSize = 1023;

This item has no description.

cHTFQuadTableSize = 31;


GXSysHelp v.2.5: GXS.HeightTileFile: Packed Record TgxHeightTileInfo

Packed Record TgxHeightTileInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightTileFile

Declaration

type TgxHeightTileInfo = packed record

Description

This item has no description.

Overview

Fields

Public | left: Integer;
Public | top: Integer;
Public | width: Integer;
Public | height: Integer;
Public | min: SmallInt;
Public | max: SmallInt;
Public | average: SmallInt;
Public | fileOffset: Int64;

Description

Fields

Public left: Integer;

This item has no description.

Public top: Integer;

This item has no description.

Public width: Integer;

This item has no description.

Public height: Integer;

This item has no description.

Public min: SmallInt;

This item has no description.

Public max: SmallInt;

This item has no description.

Public average: SmallInt;

This item has no description.

Public fileOffset: Int64;


GXSysHelp v.2.5: GXS.HeightTileFile: Packed Record TgxHeightTile

Packed Record TgxHeightTile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightTileFile

Declaration

type TgxHeightTile = packed record

Description

This item has no description.

Overview

Fields

Public | info: TgxHeightTileInfo;
Public | data: array of SmallInt;

Description

Fields

Public info: TgxHeightTileInfo;

This item has no description.

Public data: array of SmallInt;


GXSysHelp v.2.5: GXS.HeightTileFile: Packed Record THTFHeader

Packed Record THTFHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightTileFile

Declaration

type THTFHeader = packed record

Description

This item has no description.

Overview

Fields

Public | FileVersion: array [0 .. 5] of AnsiChar;
Public | TileIndexOffset: Int64;
Public | SizeX: Integer;
Public | SizeY: Integer;
Public | TileSize: Integer;
Public | DefaultZ: SmallInt;

Description

Fields

Public FileVersion: array [0 .. 5] of AnsiChar;

This item has no description.

Public TileIndexOffset: Int64;

This item has no description.

Public SizeX: Integer;

This item has no description.

Public SizeY: Integer;

This item has no description.

Public TileSize: Integer;

This item has no description.

Public DefaultZ: SmallInt;


GXSysHelp v.2.5: GXS.HeightTileFile: Class TgxHeightTileFile

Class TgxHeightTileFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightTileFile

Declaration

type TgxHeightTileFile = class(TObject)

Description

Interfaces a Tiled file

Hierarchy

  • TObject
  • TgxHeightTileFile

Overview

Fields

Private | FFile: TStream;
Private | FHeader: THTFHeader;
Private | FTileIndex: packed of TgxHeightTileInfo;
Private | FTileMark: array of Cardinal;
Private | FLastMark: Cardinal;
Private | FHashTable: array [0 .. cHTFHashTableSize] of array of Integer;
Private | FQuadTable: array [0 .. cHTFQuadTableSize, 0 .. cHTFQuadTableSize] of array of Integer;
Private | FCreating: Boolean;
Private | FHeightTile: TgxHeightTile;
Private | FInBuf: array of ShortInt;

Methods

Public | constructor Create(const fileName: String);
Public | constructor CreateNew(const fileName: String; aSizeX, aSizeY, aTileSize: Integer);
Public | destructor Destroy; override;
Public | function GetTile(aLeft, aTop: Integer; pTileInfo: PPHeightTileInfo = nil) : PHeightTile;
Public | function GetTileIndex(aLeft, aTop: Integer): Integer;
Public | function IndexOfTile(aTile: PgxHeightTileInfo): Integer;
Public | function TileCompressedSize(tileIndex: Integer): Integer;
Public | function TileCount: Integer;
Public | function XYHeight(anX, anY: Integer): SmallInt;
Public | function XYTileInfo(anX, anY: Integer): PgxHeightTileInfo;
Public | procedure CompressTile(aLeft, aTop, aWidth, aHeight: Integer; aData: PSmallIntArray);
Public | procedure ExtractRow(x, y, len: Integer; dest: PSmallIntArray);
Public | procedure TilesInRect(aLeft, aTop, aRight, aBottom: Integer; destList: TList);

Properties

Public | property DefaultZ: SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;
Public | property SizeX: Integer read FHeader.SizeX;
Public | property SizeY: Integer read FHeader.SizeY;
Public | property Tiles[index: Integer]: PgxHeightTileInfo read GetTiles;
Public | property TileSize: Integer read FHeader.TileSize;

Description

Fields

Private FFile: TStream;

This item has no description.

Private FHeader: THTFHeader;

This item has no description.

Private FTileIndex: packed of TgxHeightTileInfo;

This item has no description.

Private FTileMark: array of Cardinal;

This item has no description.

Private FLastMark: Cardinal;

This item has no description.

Private FHashTable: array [0 .. cHTFHashTableSize] of array of Integer;

This item has no description.

Private FQuadTable: array [0 .. cHTFQuadTableSize, 0 .. cHTFQuadTableSize] of array of Integer;

This item has no description.

Private FCreating: Boolean;

This item has no description.

Private FHeightTile: TgxHeightTile;

This item has no description.

Private FInBuf: array of ShortInt;

This item has no description.

Methods

Public constructor Create(const fileName: String);

This item has no description.

Public constructor CreateNew(const fileName: String; aSizeX, aSizeY, aTileSize: Integer);

Creates a new HTF file. Read and data access methods are not available when creating.

Public destructor Destroy; override;

This item has no description.

Public function GetTile(aLeft, aTop: Integer; pTileInfo: PPHeightTileInfo = nil) : PHeightTile;

Returns tile of corresponding left/top.

Public function GetTileIndex(aLeft, aTop: Integer): Integer;

Returns tile index for corresponding left/top.

Public function IndexOfTile(aTile: PgxHeightTileInfo): Integer;

This item has no description.

Public function TileCompressedSize(tileIndex: Integer): Integer;

This item has no description.

Public function TileCount: Integer;

This item has no description.

Public function XYHeight(anX, anY: Integer): SmallInt;

Returns the height at given coordinates. This is definetely NOT the fastest way to access HTF data and should only be used as utility function.

Public function XYTileInfo(anX, anY: Integer): PgxHeightTileInfo;

Returns the tile that contains x and y.

Public procedure CompressTile(aLeft, aTop, aWidth, aHeight: Integer; aData: PSmallIntArray);

Stores and compresses give tile data. aLeft and top MUST be a multiple of TileSize, aWidth and aHeight MUST be lower or equal to TileSize.

Public procedure ExtractRow(x, y, len: Integer; dest: PSmallIntArray);

Extract a single row from the HTF file. This is NOT the fastest way to access HTF data. All of the row must be contained in the world, otherwise result is undefined.

Public procedure TilesInRect(aLeft, aTop, aRight, aBottom: Integer; destList: TList);

Clears the list then add all tiles that overlap the rectangular area.

Properties

Public property DefaultZ: SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;

This item has no description.

Public property SizeX: Integer read FHeader.SizeX;

This item has no description.

Public property SizeY: Integer read FHeader.SizeY;

This item has no description.

Public property Tiles[index: Integer]: PgxHeightTileInfo read GetTiles;

This item has no description.

Public property TileSize: Integer read FHeader.TileSize;

Maximum width and height for a tile. Actual tiles may not be square, can assume random layouts, and may overlap.


GXSysHelp v.2.5: GXS.HeightTileFileHDS

Unit GXS.HeightTileFileHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.HeightData
  • GXS.HeightTileFile

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxHeightTileFileHDS |


GXSysHelp v.2.5: GXS.HeightTileFileHDS: Class TgxHeightTileFileHDS

Class TgxHeightTileFileHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HeightTileFileHDS

Declaration

type TgxHeightTileFileHDS = class(TgxHeightDataSource)

Description

An Height Data Source for the HTF format.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxHeightTileFileHDS

Overview

Fields

Private | FInfiniteWrap: Boolean;
Private | FInverted: Boolean;
Private | FHTFFileName: String;
Private | FHTF: TgxHeightTileFile;
Private | FMinElevation: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function OpenHTF: TgxHeightTileFile;
Public | function Width: Integer; override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published | property DefaultHeight;
Published | property HTFFileName: String read FHTFFileName write SetHTFFileName;
Published | property InfiniteWrap: Boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted: Boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property MinElevation: Integer read FMinElevation write SetMinElevation default -32768;

Description

Fields

Private FInfiniteWrap: Boolean;

This item has no description.

Private FInverted: Boolean;

This item has no description.

Private FHTFFileName: String;

This item has no description.

Private FHTF: TgxHeightTileFile;

This item has no description.

Private FMinElevation: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Height: Integer; override;

This item has no description.

Public function OpenHTF: TgxHeightTileFile;

This item has no description.

Public function Width: Integer; override;

This item has no description.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property DefaultHeight;

This item has no description. Showing description inherited from TgxHeightDataSource.DefaultHeight.

Height to return for undefined tiles.

Published property HTFFileName: String read FHTFFileName write SetHTFFileName;

FileName of the HTF file. Note that it is accessed via the services of GXS.ApplicationFileIO, so this may not necessarily be a regular file on a disk...

Published property InfiniteWrap: Boolean read FInfiniteWrap write SetInfiniteWrap default True;

If true the height field is wrapped indefinetely.

Published property Inverted: Boolean read FInverted write SetInverted default True;

If true the height data is inverted.(Top to bottom)

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property MinElevation: Integer read FMinElevation write SetMinElevation default -32768;

Minimum elevation of the tiles that are considered to exist. This property can typically be used to hide underwater tiles.


GXSysHelp v.2.5: GXS.HiddenLineShader

Unit GXS.HiddenLineShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GXS.Material
  • GXS.Scene
  • GXS.Color
  • GXS.BaseClasses
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxLineSettings |
Class TgxHiddenLineShader |


GXSysHelp v.2.5: GXS.HiddenLineShader: Class TgxLineSettings

Class TgxLineSettings

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HiddenLineShader

Declaration

type TgxLineSettings = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TgxLineSettings

Overview

Fields

Private | FColor: TgxColor;
Private | FWidth: Single;
Private | FPattern: GLushort;
Private | FForceMaterial: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure UnApply(var rci: TgxRenderContextInfo);
Private | procedure SetColor(const v: TgxColor);
Private | procedure SetForceMaterial(v: boolean);
Private | procedure SetPattern(const value: GLushort);
Private | procedure SetWidth(const Value: Single);

Properties

Published | property Color: TgxColor read FColor write SetColor;
Published | property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;
Published | property Pattern: GLushort read FPattern write SetPattern default $FFFF;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FColor: TgxColor;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FPattern: GLushort;

This item has no description.

Private FForceMaterial: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetColor(const v: TgxColor);

This item has no description.

Private procedure SetForceMaterial(v: boolean);

This item has no description.

Private procedure SetPattern(const value: GLushort);

This item has no description.

Private procedure SetWidth(const Value: Single);

This item has no description.

Properties

Published property Color: TgxColor read FColor write SetColor;

This item has no description.

Published property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;

Set ForceMaterial to true to enforce the application of the line settings for objects that sets their own color, line width and pattern.

Published property Pattern: GLushort read FPattern write SetPattern default $FFFF;

This item has no description.

Published property Width: Single read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.HiddenLineShader: Class TgxHiddenLineShader

Class TgxHiddenLineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HiddenLineShader

Declaration

type TgxHiddenLineShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxHiddenLineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineSmooth: Boolean;
Private | FSolid: Boolean;
Private | FBackGroundColor: TgxColor;
Private | FFrontLine: TgxLineSettings;
Private | FBackLine: TgxLineSettings;
Private | FLighting: Boolean;
Private | FShadeModel: TgxShadeModel;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetBackgroundColor(AColor: TgxColor);
Private | procedure SetLighting(v: boolean);
Private | procedure SetlineSmooth(v: boolean);
Private | procedure SetShadeModel(const val: TgxShadeModel);
Private | procedure SetSolid(v: boolean);

Properties

Published | property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;
Published | property BackLine: TgxLineSettings read FBackLine write FBackLine;
Published | property FrontLine: TgxLineSettings read FFrontLine write FFrontLine;
Published | property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;
Published | property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;
Published | property Solid: Boolean read FSolid write SetSolid default false;
Published | property SurfaceLit: Boolean read FLighting write SetLighting default true;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineSmooth: Boolean;

This item has no description.

Private FSolid: Boolean;

This item has no description.

Private FBackGroundColor: TgxColor;

This item has no description.

Private FFrontLine: TgxLineSettings;

This item has no description.

Private FBackLine: TgxLineSettings;

This item has no description.

Private FLighting: Boolean;

This item has no description.

Private FShadeModel: TgxShadeModel;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetBackgroundColor(AColor: TgxColor);

This item has no description.

Private procedure SetLighting(v: boolean);

This item has no description.

Private procedure SetlineSmooth(v: boolean);

This item has no description.

Private procedure SetShadeModel(const val: TgxShadeModel);

This item has no description.

Private procedure SetSolid(v: boolean);

This item has no description.

Properties

Published property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;

Color used for solid fill.

Published property BackLine: TgxLineSettings read FBackLine write FBackLine;

This item has no description.

Published property FrontLine: TgxLineSettings read FFrontLine write FFrontLine;

This item has no description.

Published property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;

Line smoothing control

Published property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model. Default is "Smooth".

Published property Solid: Boolean read FSolid write SetSolid default false;

Solid controls if you can see through the front-line wireframe.

Published property SurfaceLit: Boolean read FLighting write SetLighting default true;

When Solid is True, determines if lighting or background color is used.


GXSysHelp v.2.5: GXS.HUDObjects

Unit GXS.HUDObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GXS.Scene
  • GXS.Coordinates
  • GLScene.VectorGeometry
  • GXS.Objects
  • GXS.BitmapFont
  • GXS.ImageUtils
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxHUDSprite |
Class TgxHUDText |
Class TgxAbsoluteHUDText |
Class TgxResolutionIndependantHUDText |


GXSysHelp v.2.5: GXS.HUDObjects: Class TgxHUDSprite

Class TgxHUDSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HUDObjects

Declaration

type TgxHUDSprite = class(TgxSprite)

Description

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TgxHUDSprite in 2D only scenes : The most convenient way to use a TgxHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TgxHUDSprite works in absolute coordinates, TgxProxyObject can't be used to duplicate an hud sprite.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxSprite
  • TgxHUDSprite

Overview

Fields

Private | FXTiles: Integer;
Private | FYTiles: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function StoreHeight: Boolean;
Private | function StoreWidth: Boolean;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Height stored StoreHeight;
Published | property Width stored StoreWidth;
Published | property XTiles: Integer read FXTiles write SetXTiles default 1;
Published | property YTiles: Integer read FYTiles write SetYTiles default 1;

Description

Fields

Private FXTiles: Integer;

This item has no description.

Private FYTiles: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function StoreHeight: Boolean;

This item has no description.

Private function StoreWidth: Boolean;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property Height stored StoreHeight;

This item has no description. Showing description inherited from TgxSprite.Height.

Sprite Height in 3D world units.

Published property Width stored StoreWidth;

Redeclare them with new default values.

Published property XTiles: Integer read FXTiles write SetXTiles default 1;

This item has no description.

Published property YTiles: Integer read FYTiles write SetYTiles default 1;


GXSysHelp v.2.5: GXS.HUDObjects: Class TgxHUDText

Class TgxHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HUDObjects

Declaration

type TgxHUDText = class(TgxImmaterialSceneObject)

Description

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TgxBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxHUDText

Overview

Fields

Private | FBitmapFont: TgxCustomBitmapFont;
Private | FText: UnicodeString;
Private | FRotation: Single;
Private | FAlignment: TAlignment;
Private | FLayout: TgxTextLayout;
Private | FModulateColor: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;
Published | property BitmapFont: TgxCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TgxTextLayout read FLayout write SetLayout default tlTop;
Published | property ModulateColor: TgxColor read FModulateColor write SetModulateColor;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property Text: UnicodeString read FText write SetText;

Description

Fields

Private FBitmapFont: TgxCustomBitmapFont;

This item has no description.

Private FText: UnicodeString;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FAlignment: TAlignment;

This item has no description.

Private FLayout: TgxTextLayout;

This item has no description.

Private FModulateColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;

Controls the text alignment (horizontal). Possible values : taLeftJustify, taRightJustify, taCenter

Published property BitmapFont: TgxCustomBitmapFont read FBitmapFont write SetBitmapFont;

Refers the bitmap font to use. The referred bitmap font component stores and allows access to individual character bitmaps.

Published property Layout: TgxTextLayout read FLayout write SetLayout default tlTop;

Controls the text layout (vertical). Possible values : tlTop, tlCenter, tlBottom

Published property ModulateColor: TgxColor read FModulateColor write SetModulateColor;

Color modulation, can be used for fade in/out too.

Published property Rotation: Single read FRotation write SetRotation;

Rotation angle in degrees (2d).

Published property Text: UnicodeString read FText write SetText;

Text to render. Be aware that only the characters available in the bitmap font will be rendered. CR LF sequences are allowed.


GXSysHelp v.2.5: GXS.HUDObjects: Class TgxAbsoluteHUDText

Class TgxAbsoluteHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HUDObjects

Declaration

type TgxAbsoluteHUDText = class(TgxHUDText)

Description

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxHUDText
  • TgxAbsoluteHUDText

Overview

Methods

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GXSysHelp v.2.5: GXS.HUDObjects: Class TgxResolutionIndependantHUDText

Class TgxResolutionIndependantHUDText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.HUDObjects

Declaration

type TgxResolutionIndependantHUDText = class(TgxHUDText)

Description

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxHUDText
  • TgxResolutionIndependantHUDText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GXSysHelp v.2.5: GXS.ImageUtils

Unit GXS.ImageUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.UiTypes
  • System.UiConsts
  • System.Classes
  • System.Math
  • FMX.Types
  • FMX.Forms
  • FMX.Dialogs
  • FMX.Graphics
  • FMX.Consts
  • GLScene.Strings
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TIntermediateFormat |
Class EGLImageUtils |

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;
function ImageTriangleFilter(Value: Single): Single;
function ImageHermiteFilter(Value: Single): Single;
function ImageBellFilter(Value: Single): Single;
function ImageSplineFilter(Value: Single): Single;
function ImageLanczos3Filter(Value: Single): Single;
function ImageMitchellFilter(Value: Single): Single;
procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);
procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);
procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);
procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: Cardinal; ASrcDataType, ADstDataType: Cardinal; AWidth, AHeight: Integer);
procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);
procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);
procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);
function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;
function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;
function StringToColorAdvanced(const Str: string): TColor;
function GetDeviceLogicalPixelsX(device: HDC): Integer;
function GetCurrentColorDepth: Integer;
function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;
function BitmapScanLine(aBitmap: TBitmap; aRow: Integer): Pointer;
function GLOKMessageBox(const Text, Caption: string): Integer;
procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; const AName: string);
procedure InformationDlg(const msg: string);
function QuestionDlg(const msg: string): Boolean;
function InputDlg(const aCaption, aPrompt, aDefault: string): string;
function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;
function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Types

PIntermediateFormatArray = ˆTIntermediateFormatArray;
PRGBA32F = ˆTIntermediateFormat;
T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;
TGraphicClass = class of TBitmap;
TgxTextLayout = (...);
TImageAlphaProc = procedure(var AColor: TIntermediateFormat);
TImageFilterFunction = function(Value: Single): Single;
TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;
TPointerArray = array of Pointer;
TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;

Constants

sAllFilter: string = SMsgDlgAll;

Variables

vImageScaleFilterWidth: Integer = 5;

Description

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;

in VCL -> sAllFilter;

function ImageTriangleFilter(Value: Single): Single;

This item has no description.

function ImageHermiteFilter(Value: Single): Single;

This item has no description.

function ImageBellFilter(Value: Single): Single;

This item has no description.

function ImageSplineFilter(Value: Single): Single;

This item has no description.

function ImageLanczos3Filter(Value: Single): Single;

This item has no description.

function ImageMitchellFilter(Value: Single): Single;

This item has no description.

procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);

This item has no description.

procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);

This item has no description.

procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: Cardinal; ASrcDataType, ADstDataType: Cardinal; AWidth, AHeight: Integer);

This item has no description.

procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);

This item has no description.

procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: Cardinal; ADataType: Cardinal; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);

This item has no description.

procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: Cardinal; ADataType: Cardinal; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);

This item has no description.

function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;

Converts a string into color

function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;

Converts a string into color

function StringToColorAdvanced(const Str: string): TColor;

Converts a string into color

function GetDeviceLogicalPixelsX(device: HDC): Integer;

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.

function GetCurrentColorDepth: Integer;

Number of bits per pixel for the current desktop resolution.

function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;

Returns the number of color bits associated to the given pixel format.

function BitmapScanLine(aBitmap: TBitmap; aRow: Integer): Pointer;

Returns the bitmap's scanline for the specified row.

function GLOKMessageBox(const Text, Caption: string): Integer;

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.

procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; const AName: string);

This item has no description.

procedure InformationDlg(const msg: string);

Pops up a simple dialog with msg and an Ok button.

function QuestionDlg(const msg: string): Boolean;

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".

function InputDlg(const aCaption, aPrompt, aDefault: string): string;

Posp a simple dialog with a string input.

function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple save picture dialog.

function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple open picture dialog.

Types

PIntermediateFormatArray = ˆTIntermediateFormatArray;

This item has no description.

PRGBA32F = ˆTIntermediateFormat;

This item has no description.

T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;

This item has no description.

TGraphicClass = class of TBitmap;

This item has no description.

TgxTextLayout = (...);

in vcl class of TGraphic

Values
  • tlTop
  • tlCenter
  • tlBottom
TImageAlphaProc = procedure(var AColor: TIntermediateFormat);

This item has no description.

TImageFilterFunction = function(Value: Single): Single;

This item has no description.

TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;

This item has no description.

TPointerArray = array of Pointer;

This item has no description.

TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;

This item has no description.

Constants

sAllFilter: string = SMsgDlgAll;

TglTextLayout

Variables

vImageScaleFilterWidth: Integer = 5;


GXSysHelp v.2.5: GXS.ImageUtils: Record TIntermediateFormat

Record TIntermediateFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ImageUtils

Declaration

type TIntermediateFormat = record

Description

Relative sample radius for filtering

Overview

Fields

Public | R: Single;
Public | G: Single;
Public | B: Single;
Public | A: Single;

Description

Fields

Public R: Single;

This item has no description.

Public G: Single;

This item has no description.

Public B: Single;

This item has no description.

Public A: Single;


GXSysHelp v.2.5: GXS.ImageUtils: Class EGLImageUtils

Class EGLImageUtils

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ImageUtils

Declaration

type EGLImageUtils = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLImageUtils


GXSysHelp v.2.5: GXS.Imposter

Unit GXS.Imposter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • GXS.Scene
  • GXS.Context
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.PersistentClasses
  • GXS.Graphics
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Coordinates
  • GXS.BaseClasses
  • GXS.State
  • GLScene.PipelineTransform
  • GLScene.TextureFormat
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TImposter |
Class TgxImposterBuilder |
Class TgxStaticImposterBuilderCorona |
Record TCoronaTangentLookup |
Class TgxStaticImposterBuilderCoronas |
Class TStaticImposter |
Class TgxStaticImposterBuilder |
Class TgxDynamicImposterBuilder |
Class TgxImposter |

Types

TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter) of object;
TImposterOption = (...);
TImposterOptions = set of TImposterOption;
TImposterReference = (...);
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter) : TgxBitmap32 of object;
TSIBLigthing = (...);

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];

Description

Types

TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter) of object;

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter; var result : TgxBitmap32) of object;

TImposterOption = (...);

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing

Values
  • impoBlended
  • impoAlphaTest
  • impoNearestFiltering
  • impoPerspectiveCorrection
TImposterOptions = set of TImposterOption;

This item has no description.

TImposterReference = (...);

This item has no description.

Values
  • irCenter
  • irTop
  • irBottom
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter) : TgxBitmap32 of object;

Imposter loading events

TSIBLigthing = (...);

This item has no description.

Values
  • siblNoLighting
  • siblStaticLighting
  • siblLocalLighting

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];


GXSysHelp v.2.5: GXS.Imposter: Class TImposter

Class TImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TImposter = class(TObject)

Description

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.

Hierarchy

  • TObject
  • TImposter

Overview

Fields

Private | FRequestCount: Integer;
Private | FBuilder: TgxImposterBuilder;
Private | FTexture: TgxTextureHandle;
Private | FImpostoredObject: TgxBaseSceneObject;
Private | FAspectRatio: Single;
Private | FModulated: Boolean;

Methods

Public | constructor Create(aBuilder: TgxImposterBuilder); virtual;
Public | destructor Destroy; override;
Public | procedure BeginRender(var rci: TgxRenderContextInfo); virtual;
Public | procedure EndRender(var rci: TgxRenderContextInfo); virtual;
Public | procedure Render(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single); virtual;
Public | procedure RenderOnce(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single);

Properties

Public | property AspectRatio: Single read FAspectRatio write FAspectRatio;
Public | property Builder: TgxImposterBuilder read FBuilder;
Public | property ImpostoredObject: TgxBaseSceneObject read FImpostoredObject write FImpostoredObject;
Public | property Modulated: Boolean read FModulated write FModulated;
Public | property Texture: TgxTextureHandle read FTexture;

Description

Fields

Private FRequestCount: Integer;

This item has no description.

Private FBuilder: TgxImposterBuilder;

This item has no description.

Private FTexture: TgxTextureHandle;

This item has no description.

Private FImpostoredObject: TgxBaseSceneObject;

This item has no description.

Private FAspectRatio: Single;

This item has no description.

Private FModulated: Boolean;

This item has no description.

Methods

Public constructor Create(aBuilder: TgxImposterBuilder); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeginRender(var rci: TgxRenderContextInfo); virtual;

This item has no description.

Public procedure EndRender(var rci: TgxRenderContextInfo); virtual;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single); virtual;

This item has no description.

Public procedure RenderOnce(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single);

This item has no description.

Properties

Public property AspectRatio: Single read FAspectRatio write FAspectRatio;

This item has no description.

Public property Builder: TgxImposterBuilder read FBuilder;

This item has no description.

Public property ImpostoredObject: TgxBaseSceneObject read FImpostoredObject write FImpostoredObject;

This item has no description.

Public property Modulated: Boolean read FModulated write FModulated;

This item has no description.

Public property Texture: TgxTextureHandle read FTexture;


GXSysHelp v.2.5: GXS.Imposter: Class TgxImposterBuilder

Class TgxImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxImposterBuilder = class(TgxUpdateAbleComponent)

Description

Abstract ImposterBuilder class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxImposterBuilder

Overview

Fields

Private | FBackColor: TgxColor;
Private | FBuildOffset: TgxCoordinates;
Private | FImposterRegister: TgxPersistentObjectList;
Private | FRenderPoint: TgxRenderPoint;
Private | FImposterOptions: TImposterOptions;
Private | FAlphaTreshold: Single;
Private | FImposterReference: TImposterReference;
Private | FOnLoadingImposter: TLoadingImposterEvent;
Private | FOnImposterLoaded: TImposterLoadedEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ImposterFor(impostoredObject: TgxBaseSceneObject): TImposter;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RequestImposterFor(impostoredObject: TgxBaseSceneObject);
Public | procedure UnRequestImposterFor(impostoredObject: TgxBaseSceneObject);

Properties

Published | property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;
Published | property BackColor: TgxColor read FBackColor write SetBackColor;
Published | property BuildOffset: TgxCoordinates read FBuildOffset write SetBuildOffset;
Published | property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;
Published | property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;
Published | property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;
Published | property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;
Published | property RenderPoint: TgxRenderPoint read FRenderPoint write SetRenderPoint;

Description

Fields

Private FBackColor: TgxColor;

This item has no description.

Private FBuildOffset: TgxCoordinates;

This item has no description.

Private FImposterRegister: TgxPersistentObjectList;

This item has no description.

Private FRenderPoint: TgxRenderPoint;

This item has no description.

Private FImposterOptions: TImposterOptions;

This item has no description.

Private FAlphaTreshold: Single;

This item has no description.

Private FImposterReference: TImposterReference;

This item has no description.

Private FOnLoadingImposter: TLoadingImposterEvent;

This item has no description.

Private FOnImposterLoaded: TImposterLoadedEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ImposterFor(impostoredObject: TgxBaseSceneObject): TImposter;

Returns a valid imposter for the specified object. Imposter must have been requested first, and the builder given an opportunity to prepare it before it can be available.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure RequestImposterFor(impostoredObject: TgxBaseSceneObject);

Request an imposter to be prepared for the specified object

Public procedure UnRequestImposterFor(impostoredObject: TgxBaseSceneObject);

Tells the imposter for the specified object is no longer needed

Properties

Published property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;

Alpha testing teshold.

Published property BackColor: TgxColor read FBackColor write SetBackColor;

Background color for impostor rendering. Typically, you'll want to leave the alpha channel to zero, and pick as RGB as color that matches the impostor'ed objects edge colors most.

Published property BuildOffset: TgxCoordinates read FBuildOffset write SetBuildOffset;

Offset applied to the impostor'ed object during imposter construction. Can be used to manually tune the centering of objects.

Published property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;

Imposter rendering options

Published property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;

Determines how the imposter are handled. This is the reference point for imposters, impostor'ed objects that are centered should use irCenter, those whose bottom is the origin should use irBottom, etc.

Published property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;

Event fired after preparing/loading an imposter. This events gives an opportunity to save the imposter after it has been loaded or prepared.

Published property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;

Event fired before preparing/loading an imposter. If an already prepared version of the importer is available, place it in the TgxBitmap32 the event shall return (the bitmap will be freed by the imposter builder). If a bitmap is specified, it will be used in place of what automatic generation could have generated.

Published property RenderPoint: TgxRenderPoint read FRenderPoint write SetRenderPoint;

Specifies the render point at which the impostor texture(s) can be prepared. For best result, the render point should happen in viewer that has a destination alpha (otherwise, impostors will be opaque).


GXSysHelp v.2.5: GXS.Imposter: Class TgxStaticImposterBuilderCorona

Class TgxStaticImposterBuilderCorona

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxStaticImposterBuilderCorona = class(TCollectionItem)

Description

Describes a set of orientation in a corona fashion

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxStaticImposterBuilderCorona

Overview

Fields

Private | FSamples: Integer;
Private | FElevation: Single;
Private | FSampleBaseIndex: Integer;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Elevation: Single read FElevation write SetElevation;
Published | property Samples: Integer read FSamples write SetSamples default 8;

Description

Fields

Private FSamples: Integer;

This item has no description.

Private FElevation: Single;

This item has no description.

Private FSampleBaseIndex: Integer;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Elevation: Single read FElevation write SetElevation;

This item has no description.

Published property Samples: Integer read FSamples write SetSamples default 8;


GXSysHelp v.2.5: GXS.Imposter: Record TCoronaTangentLookup

Record TCoronaTangentLookup

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TCoronaTangentLookup = record

Description

This item has no description.

Overview

Fields

Public | minTan: Single;
Public | maxTan: Single;
Public | corona: TgxStaticImposterBuilderCorona;

Description

Fields

Public minTan: Single;

This item has no description.

Public maxTan: Single;

This item has no description.

Public corona: TgxStaticImposterBuilderCorona;


GXSysHelp v.2.5: GXS.Imposter: Class TgxStaticImposterBuilderCoronas

Class TgxStaticImposterBuilderCoronas

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxStaticImposterBuilderCoronas = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxStaticImposterBuilderCoronas

Overview

Fields

Private FCoronaTangentLookup: array of TCoronaTangentLookup;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add(const elevation: Single; samples: Integer): TgxStaticImposterBuilderCorona; overload;
Public | function Add: TgxStaticImposterBuilderCorona; overload;
Public | function SampleCount: Integer;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[AIndex: Integer]: TgxStaticImposterBuilderCorona read GetItems write SetItems;

Description

Fields

Private FCoronaTangentLookup: array of TCoronaTangentLookup;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add(const elevation: Single; samples: Integer): TgxStaticImposterBuilderCorona; overload;

This item has no description.

Public function Add: TgxStaticImposterBuilderCorona; overload;

This item has no description.

Public function SampleCount: Integer;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[AIndex: Integer]: TgxStaticImposterBuilderCorona read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Imposter: Class TStaticImposter

Class TStaticImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TStaticImposter = class(TImposter)

Description

Imposter class whose texture contains several views from different angles

Hierarchy

  • TObject
  • TImposter
  • TStaticImposter

Overview

Methods

Public procedure Render(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single); override;

Description

Methods

Public procedure Render(var rci: TgxRenderContextInfo; const objPos, localCameraPos: TVector4f; size: Single); override;


GXSysHelp v.2.5: GXS.Imposter: Class TgxStaticImposterBuilder

Class TgxStaticImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxStaticImposterBuilder = class(TgxImposterBuilder)

Description

Builds imposters whose texture is a catalog of prerendered views

Hierarchy

  • TgxUpdateAbleComponent
  • TgxImposterBuilder
  • TgxStaticImposterBuilder

Overview

Fields

Private | FCoronas: TgxStaticImposterBuilderCoronas;
Private | FSampleSize: Integer;
Private | FTextureSize: TPoint;
Private | FSamplesPerAxis: TPoint;
Private | FInvSamplesPerAxis: TVector2f;
Private | FSamplingRatioBias: Single;
Private | FInvSamplingRatioBias: Single;
Private | FLighting: TSIBLigthing;
Private | FSamplesAlphaScale: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function TextureFillRatio: Single;
Public | procedure Render(var rci: TgxRenderContextInfo; impostoredObject: TgxBaseSceneObject; destImposter: TImposter);

Properties

Published | property Coronas: TgxStaticImposterBuilderCoronas read FCoronas write SetCoronas;
Published | property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;
Published | property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;
Published | property SampleSize: Integer read FSampleSize write SetSampleSize default 32;
Public | property SamplesPerAxis: TPoint read FSamplesPerAxis;
Published | property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;
Public | property TextureSize: TPoint read FTextureSize;
Published | property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Description

Fields

Private FCoronas: TgxStaticImposterBuilderCoronas;

This item has no description.

Private FSampleSize: Integer;

This item has no description.

Private FTextureSize: TPoint;

This item has no description.

Private FSamplesPerAxis: TPoint;

This item has no description.

Private FInvSamplesPerAxis: TVector2f;

This item has no description.

Private FSamplingRatioBias: Single;

This item has no description.

Private FInvSamplingRatioBias: Single;

This item has no description.

Private FLighting: TSIBLigthing;

This item has no description.

Private FSamplesAlphaScale: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TextureFillRatio: Single;

Ratio (0..1) of the texture that will be used by samples. If this value is below 1, you're wasting texture space and may as well increase the number of samples.

Public procedure Render(var rci: TgxRenderContextInfo; impostoredObject: TgxBaseSceneObject; destImposter: TImposter);

Render imposter texture. Buffer and object must be compatible, RC must have been activated.

Properties

Published property Coronas: TgxStaticImposterBuilderCoronas read FCoronas write SetCoronas;

Description of the samples looking orientations

Published property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;

Lighting mode to apply during samples construction

Published property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;

Scale factor apply to the sample alpha channel. Main use is to saturate the samples alpha channel, and make fully opaque what would have been partially transparent, while leaving fully transparent what was fully transparent.

Published property SampleSize: Integer read FSampleSize write SetSampleSize default 32;

Size of the imposter samples (square)

Public property SamplesPerAxis: TPoint read FSamplesPerAxis;

This item has no description.

Published property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;

Size ratio applied to the impostor'ed objects during sampling. Values greater than one can be used to "fill" the samples more by scaling up the object. This is especially useful when the impostor'ed object doesn't fill its bounding sphere, and/or if the outer details are not relevant for impostoring.

Public property TextureSize: TPoint read FTextureSize;

Meaningful only after imposter texture has been prepared

Published property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Dummy property that returns the size of the imposter texture. This property is essentially here as a helper at design time, to give you the requirements your coronas and samplesize parameters imply.


GXSysHelp v.2.5: GXS.Imposter: Class TgxDynamicImposterBuilder

Class TgxDynamicImposterBuilder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxDynamicImposterBuilder = class(TgxImposterBuilder)

Description

This item has no description. Showing description inherited from TgxImposterBuilder.

Abstract ImposterBuilder class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxImposterBuilder
  • TgxDynamicImposterBuilder

Overview

Fields

Private | FMinTexSize: Integer;
Private | FMaxTexSize: Integer;
Private | FMinDistance: Single;
Private | FTolerance: Single;
Private | FUseMatrixError: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property MinTexSize: Integer read FMinTexSize write FMinTexSize;
Published | property Tolerance: Single read FTolerance write FTolerance;
Published | property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;

Description

Fields

Private FMinTexSize: Integer;

This item has no description.

Private FMaxTexSize: Integer;

This item has no description.

Private FMinDistance: Single;

This item has no description.

Private FTolerance: Single;

This item has no description.

Private FUseMatrixError: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;

This item has no description.

Published property MinDistance: Single read FMinDistance write SetMinDistance;

This item has no description.

Published property MinTexSize: Integer read FMinTexSize write FMinTexSize;

procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;

Published property Tolerance: Single read FTolerance write FTolerance;

This item has no description.

Published property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;


GXSysHelp v.2.5: GXS.Imposter: Class TgxImposter

Class TgxImposter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Imposter

Declaration

type TgxImposter = class(TgxImmaterialSceneObject)

Description

This item has no description. Showing description inherited from TgxImmaterialSceneObject.

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxImposter

Overview

Fields

Private | FBuilder: TgxImposterBuilder;
Private | FImpostoredObject: TgxBaseSceneObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Builder: TgxImposterBuilder read FBuilder write SetBuilder;
Published | property ImpostoredObject: TgxBaseSceneObject read FImpostoredObject write SetImpostoredObject;

Description

Fields

Private FBuilder: TgxImposterBuilder;

This item has no description.

Private FImpostoredObject: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property Builder: TgxImposterBuilder read FBuilder write SetBuilder;

This item has no description.

Published property ImpostoredObject: TgxBaseSceneObject read FImpostoredObject write SetImpostoredObject;


GXSysHelp v.2.5: GXS.InitOpenGL

Unit GXS.InitOpenGL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • FMX.Forms

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxOpenGL |
Class TgxShader |
Class TgxShaderV |
Class TgxShaderG |
Class TgxShaderF |
Class TgxProgram |
Class TgxBuffer |
Class TgxBufferV |
Class TgxBufferI |
Class TgxBufferU |
Class TgxArray |

Variables

GXOpenGL: TgxOpenGL;

Description

Variables

GXOpenGL: TgxOpenGL;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxOpenGL

Class TgxOpenGL

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxOpenGL = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxOpenGL

Overview

Fields

Private | CommonCustomForm: TCommonCustomForm;
Private | _WND: HWND;
Private | _DC: HDC;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | class function DefaultPFD: TPixelFormatDescriptor;
Public | procedure ApplyPixelFormat(const DC_: HDC);
Public | procedure BeginGL;
Public | procedure EndGL;
Public | procedure InitOpenGL;

Properties

Public | property PFD: TPixelFormatDescriptor read _PFD write SetPFD;
Public | property PFI: Integer read _PFI write SetPFI;
Public | property RC: HGLRC read _RC;

Description

Fields

Private CommonCustomForm: TCommonCustomForm;

This item has no description.

Private _WND: HWND;

This item has no description.

Private _DC: HDC;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function DefaultPFD: TPixelFormatDescriptor;

This item has no description.

Public procedure ApplyPixelFormat(const DC_: HDC);

This item has no description.

Public procedure BeginGL;

This item has no description.

Public procedure EndGL;

This item has no description.

Public procedure InitOpenGL;

This item has no description.

Properties

Public property PFD: TPixelFormatDescriptor read _PFD write SetPFD;

This item has no description.

Public property PFI: Integer read _PFI write SetPFI;

This item has no description.

Public property RC: HGLRC read _RC;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxShader

Class TgxShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxShader = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader

Overview

Methods

Public | constructor Create(const Kind_: GLenum);
Public | destructor Destroy; override;
Public | procedure SetSource(const Source_: String);

Properties

Public property ID: GLuint read _ID;

Description

Methods

Public constructor Create(const Kind_: GLenum);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure SetSource(const Source_: String);

This item has no description.

Properties

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxShaderV

Class TgxShaderV

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxShaderV = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxShaderG

Class TgxShaderG

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxShaderG = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderG

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxShaderF

Class TgxShaderF

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxShaderF = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderF

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxProgram

Class TgxProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxProgram = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxProgram

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Attach(const Shader_: TgxShader);
Public | procedure Detach(const Shader_: TgxShader);
Public | procedure Link;
Public | procedure Use;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Attach(const Shader_: TgxShader);

This item has no description.

Public procedure Detach(const Shader_: TgxShader);

This item has no description.

Public procedure Link;

This item has no description.

Public procedure Use;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxBuffer

Class TgxBuffer

Description
Hierarchy
Nested Types
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxBuffer<_TYPE_:record> = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer

Overview

Nested Types

Public _PValue_ = ˆ_TYPE_;

Methods

Public | constructor Create(const Kind_: GLenum);
Public | destructor Destroy; override;
Public | procedure Bind;
Public | procedure Map;
Public | procedure Unbind;
Public | procedure Unmap;

Properties

Public | property Count: Integer read _Count write SetCount;
Public | property ID: GLuint read _ID;

Description

Nested Types

Public _PValue_ = ˆ_TYPE_;

This item has no description.

Methods

Public constructor Create(const Kind_: GLenum);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure Map;

This item has no description.

Public procedure Unbind;

This item has no description.

Public procedure Unmap;

This item has no description.

Properties

Public property Count: Integer read _Count write SetCount;

This item has no description.

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxBufferV

Class TgxBufferV

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxBufferV<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxBufferI

Class TgxBufferI

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxBufferI<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferI

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxBufferU

Class TgxBufferU

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxBufferU<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferU

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.InitOpenGL: Class TgxArray

Class TgxArray

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.InitOpenGL

Declaration

type TgxArray = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxArray

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure BeginBind;
Public | procedure EndBind;

Properties

Public property ID: GLuint read _ID;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeginBind;

This item has no description.

Public procedure EndBind;

This item has no description.

Properties

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: GXS.Isolines

Unit GXS.Isolines

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • System.Generics.Collections
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GLScene.Spline
  • GXS.Objects
  • GXS.MultiPolygon
  • GXS.Coordinates
  • GXS.Color
  • GXS.SpaceText
  • GXS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxIsoline |
Class TgxIsolines |

Functions and Procedures

procedure Initialize_Contouring(var DataGrid: TMatrixArr; NXpoints, NYpoints: integer; CurrentIsoline: Single);
procedure Release_Memory_Isoline;
function GetNextIsoline(var Isoline: TgxIsoline): Boolean;
procedure TriangleElevationSegments(const p1, p2, p3: TAffineVector; ElevationDelta: Single; Segments: TgxAffineVectorList);

Types

PVertex2DArr = ˆTVertex2DArr;
PVXIsoline = ˆTgxIsoline;
TByteMatrixArr = array of array of Byte;
TByteVectorArr = array of Byte;
TCastArray = array [0 .. 2, 0 .. 2, 0 .. 2] of Integer;
TgxIsolineState = (...);
TMatrixArr = array of array of Single;
TVectorArr = array of Single;
TVectorL4D = array [0 .. 4] of Single;
TVectorL4I = array [0 .. 4] of Integer;
TVertex2DArr = array [0 .. 32767] of TPoint2DRec;

Description

Functions and Procedures

procedure Initialize_Contouring(var DataGrid: TMatrixArr; NXpoints, NYpoints: integer; CurrentIsoline: Single);

This item has no description.

procedure Release_Memory_Isoline;

This item has no description.

function GetNextIsoline(var Isoline: TgxIsoline): Boolean;

This item has no description.

procedure TriangleElevationSegments(const p1, p2, p3: TAffineVector; ElevationDelta: Single; Segments: TgxAffineVectorList);

Defines contouring segments inside a triangle using elevations

Types

PVertex2DArr = ˆTVertex2DArr;

This item has no description.

PVXIsoline = ˆTgxIsoline;

This item has no description.

TByteMatrixArr = array of array of Byte;

This item has no description.

TByteVectorArr = array of Byte;

This item has no description.

TCastArray = array [0 .. 2, 0 .. 2, 0 .. 2] of Integer;

This item has no description.

TgxIsolineState = (...);

This item has no description.

Values
  • ilsEmpty
  • ilsCalculating
  • ilsReady
TMatrixArr = array of array of Single;

This item has no description.

TVectorArr = array of Single;

This item has no description.

TVectorL4D = array [0 .. 4] of Single;

This item has no description.

TVectorL4I = array [0 .. 4] of Integer;

This item has no description.

TVertex2DArr = array [0 .. 32767] of TPoint2DRec;


GXSysHelp v.2.5: GXS.Isolines: Class TgxIsoline

Class TgxIsoline

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Isolines

Declaration

type TgxIsoline = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxIsoline

Overview

Fields

Public | NP: Integer;
Public | Line: PVertex2DArr;

Methods

Public | constructor Create(LineSize: integer); virtual;
Public | destructor Destroy; override;

Description

Fields

Public NP: Integer;

This item has no description.

Public Line: PVertex2DArr;

This item has no description.

Methods

Public constructor Create(LineSize: integer); virtual;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.Isolines: Class TgxIsolines

Class TgxIsolines

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Isolines

Declaration

type TgxIsolines = class(TgxLines)

Description

This item has no description. Showing description inherited from TgxLines.

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase
  • TgxNodedLines
  • TgxLines
  • TgxIsolines

Overview

Fields

Public | IsoVertex: TAffineVector;
Public | SpaceTextSF: array of TgxSpaceText;
Private | CoordRange: Integer;
Private | LineList: TList;
Private | IsolineState: TgxIsolineState;

Methods

Public | constructor Create(AOwner: TComponent); virtual;
Public | destructor Destroy; override;
Public | procedure Conrec(PlaneSFindex:Integer; PlaneSF: TgxFreeForm; Data: TMatrixArr; ilb, iub, jlb, jub: Integer; X: TVectorArr; Y: TVectorArr; NC: Integer; HgtL: TVectorArr; Z_Kfix: Single; res3Dmax, res3Dmin: Single);
Public | procedure FreeList;
Public | procedure MakeIsolines(var Depths: TMatrixArr; bmSize: Integer; StartDepth, EndDepth: Single; Interval: Integer);

Description

Fields

Public IsoVertex: TAffineVector;

This item has no description.

Public SpaceTextSF: array of TgxSpaceText;

This item has no description.

Private CoordRange: Integer;

This item has no description.

Private LineList: TList;

This item has no description.

Private IsolineState: TgxIsolineState;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Conrec(PlaneSFindex:Integer; PlaneSF: TgxFreeForm; Data: TMatrixArr; ilb, iub, jlb, jub: Integer; X: TVectorArr; Y: TVectorArr; NC: Integer; HgtL: TVectorArr; Z_Kfix: Single; res3Dmax, res3Dmin: Single);

CONREC is a contouring routine for rectangular spaced data or regular 2D grids It takes each rectangle of adjacent data points and splits it into 4 triangles after choosing the height at the centre of the rectangle. For each of the triangles the line segment resulting from the intersection with each contour plane. A routine is then called with the starting and stopping coordinates of the line segment that make up a contour curve and then output these isolines. See details in http://paulbourke.net/papers/conrec/

The input parameters are as follows : PlaneSFindex - PlaneSF - Data - Scalar field in 2D grid ilb - lower bound in west - east direction iub - upper bound in west - east direction jlb - lower bound in north - south direction jub upper bound in north - south direction X - coord. vector for west - east Y - coord. vector for north - south NC - number of cut levels HgtL - values of cut levels Z_Kfix - res3Dmin -

Public procedure FreeList;

This item has no description.

Public procedure MakeIsolines(var Depths: TMatrixArr; bmSize: Integer; StartDepth, EndDepth: Single; Interval: Integer);


GXSysHelp v.2.5: GXS.Isosurface

Unit GXS.Isosurface

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GLScene.VectorTypesExt
  • GXS.Mesh
  • GXS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMarchingCube |
Class TIsoSurfaceExtractor |

Functions and Procedures

function SFSphere(X, Y, Z: Extended): TScalarValue;
function SFMinkowski(X, Y, Z: Extended): TScalarValue;
function SFKleinBottle(X, Y, Z: Extended): TScalarValue;
function SFChmutov1(X, Y, Z: Extended): TScalarValue;
function SFChmutov2(X, Y, Z: Extended): TScalarValue;
function SFToroidal(X, Y, Z: Extended): TScalarValue;
function SFDoubleTorus(X, Y, Z: Extended): TScalarValue;

Constants

ALLOC_SIZE = 65536;

Description

Functions and Procedures

function SFSphere(X, Y, Z: Extended): TScalarValue;

Sphere surface

function SFMinkowski(X, Y, Z: Extended): TScalarValue;

Minkowski space (http://mathworld.wolfram.com)

function SFKleinBottle(X, Y, Z: Extended): TScalarValue;

Klein Bottle (http://mathworld.wolfram.com)

function SFChmutov1(X, Y, Z: Extended): TScalarValue;

Chmutov-surface-1 (http://mathworld.wolfram.com)

function SFChmutov2(X, Y, Z: Extended): TScalarValue;

Chmutov-surface-2 (http://mathworld.wolfram.com)

function SFToroidal(X, Y, Z: Extended): TScalarValue;

Toroidal surface (phantasy!)

function SFDoubleTorus(X, Y, Z: Extended): TScalarValue;

Double torus Surface (phantasy!)

Constants

ALLOC_SIZE = 65536;


GXSysHelp v.2.5: GXS.Isosurface: Class TgxMarchingCube

Class TgxMarchingCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Isosurface

Declaration

type TgxMarchingCube = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxMarchingCube

Overview

Fields

Private | FIsoValue: TScalarValue;
Private | PVertsX: PIntegerArray;
Private | PVertsY: PIntegerArray;
Private | PVertsZ: PIntegerArray;
Private | _Nverts: Integer;
Private | _Ntrigs: Integer;
Private | _Sverts: Integer;
Private | _Strigs: Integer;
Private | PVertices: PVertArray;
Private | PTriangles: PTriangleRecArray;
Private | _i: Longword;
Private | _j: Longword;
Private | _k: Longword;
Private | _Cube: array [0 .. 7] of TVoxelRec;
Private | _lut_entry: Byte;
Public | ScalarField: TScalarField;

Methods

Public | constructor Create(SizeX, SizeY, SizeZ: Integer; AIsoValue: TScalarValue = 0.0; xMin: Single = -0.5; xMax: Single = 0.5; yMin: Single = -0.5; yMax: Single = 0.5; zMin: Single = -0.5; zMax: Single = 0.5); overload; virtual;
Public | constructor Create; overload; virtual;
Public | destructor Destroy; override;
Public | function Internal(AValue: TScalarValue): Boolean; virtual;
Public | procedure CalcMeshObject(AMeshObject: TgxMeshObject; Alpha: Single = 1);
Public | procedure CalcVertices(Vertices: TgxVertexList; Alpha: Single = 1);
Public | procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarFieldInt); overload; virtual;
Public | procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarField = nil); overload; virtual;
Public | procedure FillVoxelData; overload; virtual;
Public | procedure ReDim(ASizeX, ASizeY, ASizeZ: Integer; xMin, xMax, yMin, yMax, zMin, zMax: Single); virtual;
Public | procedure Run(IsoValue: TScalarValue); overload;
Public | procedure Run; overload;
Private | procedure Clean_all(keepFacets: Boolean = False);
Private | procedure Clean_space;
Private | procedure Clean_temps;
Private | procedure Init_all;
Private | procedure Init_space;
Private | procedure Init_temps;
Private | procedure Test_vertex_addiction;

Properties

Public property IsoValue: TScalarValue read FIsoValue write FIsoValue;

Description

Fields

Private FIsoValue: TScalarValue;

This item has no description.

Private PVertsX: PIntegerArray;

sliceSize:Longword;

Private PVertsY: PIntegerArray;

This item has no description.

Private PVertsZ: PIntegerArray;

This item has no description.

Private _Nverts: Integer;

This item has no description.

Private _Ntrigs: Integer;

This item has no description.

Private _Sverts: Integer;

This item has no description.

Private _Strigs: Integer;

This item has no description.

Private PVertices: PVertArray;

This item has no description.

Private PTriangles: PTriangleRecArray;

This item has no description.

Private _i: Longword;

This item has no description.

Private _j: Longword;

This item has no description.

Private _k: Longword;

This item has no description.

Private _Cube: array [0 .. 7] of TVoxelRec;

This item has no description.

Private _lut_entry: Byte;

This item has no description.

Public ScalarField: TScalarField;

This item has no description.

Methods

Public constructor Create(SizeX, SizeY, SizeZ: Integer; AIsoValue: TScalarValue = 0.0; xMin: Single = -0.5; xMax: Single = 0.5; yMin: Single = -0.5; yMax: Single = 0.5; zMin: Single = -0.5; zMax: Single = 0.5); overload; virtual;

This item has no description.

Public constructor Create; overload; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Internal(AValue: TScalarValue): Boolean; virtual;

This item has no description.

Public procedure CalcMeshObject(AMeshObject: TgxMeshObject; Alpha: Single = 1);

This item has no description.

Public procedure CalcVertices(Vertices: TgxVertexList; Alpha: Single = 1);

This item has no description.

Public procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarFieldInt); overload; virtual;

This item has no description.

Public procedure FillVoxelData(AIsoValue: TScalarValue; AScalarField: TScalarField = nil); overload; virtual;

This item has no description.

Public procedure FillVoxelData; overload; virtual;

This item has no description.

Public procedure ReDim(ASizeX, ASizeY, ASizeZ: Integer; xMin, xMax, yMin, yMax, zMin, zMax: Single); virtual;

This item has no description.

Public procedure Run(IsoValue: TScalarValue); overload;

This item has no description.

Public procedure Run; overload;

This item has no description.

Private procedure Clean_all(keepFacets: Boolean = False);

This item has no description.

Private procedure Clean_space;

This item has no description.

Private procedure Clean_temps;

This item has no description.

Private procedure Init_all;

This item has no description.

Private procedure Init_space;

This item has no description.

Private procedure Init_temps;

_case:Byte; _config:Byte; _subconfig:Byte;

Private procedure Test_vertex_addiction;

This item has no description.

Properties

Public property IsoValue: TScalarValue read FIsoValue write FIsoValue;


GXSysHelp v.2.5: GXS.Isosurface: Class TIsoSurfaceExtractor

Class TIsoSurfaceExtractor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Isosurface

Declaration

type TIsoSurfaceExtractor = class(TObject)

Description

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue

Hierarchy

  • TObject
  • TIsoSurfaceExtractor

Overview

Fields

Private | Data: TArray3DExt;
Private | Dimensions: array ['x' .. 'z'] of Integer;

Methods

Public | constructor Create(); overload;
Public | constructor Create(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt); overload;
Public | destructor Destroy(); override;
Private | function BuildIndex(var ADatavals: array of Single; Isovalue: Single): word;
Private | function Interpolate(const V0, V1: TAffineVector; var Val0, Val1, Isovalue: Single; isPolished: boolean): TVertex;
Public | procedure AssignData(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt);
Public | procedure MarchingCubes(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);
Public | procedure MarchingTetrahedra(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Description

Fields

Private Data: TArray3DExt;

This item has no description.

Private Dimensions: array ['x' .. 'z'] of Integer;

This item has no description.

Methods

Public constructor Create(); overload;

This item has no description.

Public constructor Create(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt); overload;

This item has no description.

Public destructor Destroy(); override;

This item has no description.

Private function BuildIndex(var ADatavals: array of Single; Isovalue: Single): word;

Build Index depending on whether the edges are outside or inside the surface

Private function Interpolate(const V0, V1: TAffineVector; var Val0, Val1, Isovalue: Single; isPolished: boolean): TVertex;

This item has no description.

Public procedure AssignData(Xdim, Ydim, Zdim: Integer; var AData: TArray3DExt);

This item has no description.

Public procedure MarchingCubes(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Launch Marching Cubes

Public procedure MarchingTetrahedra(Isovalue: Single; out Vertices: TVertexArray; out Triangles: TIntegerArray; isPolished: boolean);

Launch Marching Tetrahedra


GXSysHelp v.2.5: GXS.Joystick

Unit GXS.Joystick

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • Winapi.MMSystem
  • System.Classes
  • System.SysUtils
  • FMX.Forms
  • FMX.Controls
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxJoystick |

Types

TJoyAxis = (...);
TJoyPos = (...);
TJoystickButton = (...);
TJoystickButtons = set of TJoystickButton;
TJoystickDesignMode = (...);
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;
TJoystickID = (...);

Description

Types

TJoyAxis = (...);

This item has no description.

Values
  • jaX
  • jaY
  • jaZ
  • jaR
  • jaU
  • jaV
TJoyPos = (...);

This item has no description.

Values
  • jpMin
  • jpCenter
  • jpMax
TJoystickButton = (...);

This item has no description.

Values
  • jbButton1
  • jbButton2
  • jbButton3
  • jbButton4
TJoystickButtons = set of TJoystickButton;

This item has no description.

TJoystickDesignMode = (...);

This item has no description.

Values
  • jdmInactive
  • jdmActive
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;

This item has no description.

TJoystickID = (...);

This item has no description.

Values
  • jidNoJoystick
  • jidJoystick1
  • jidJoystick2


GXSysHelp v.2.5: GXS.Joystick: Class TgxJoystick

Class TgxJoystick

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Joystick

Declaration

type TgxJoystick = class(TComponent)

Description

A component interfacing the Joystick via the (regular) windows API.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxJoystick

Overview

Fields

Private | FWindowHandle: HWND;
Private | FNumButtons: Integer;
Private | FLastX: Integer;
Private | FLastY: Integer;
Private | FLastZ: Integer;
Private | FThreshold: Cardinal;
Private | FInterval: Cardinal;
Private | FCapture: Boolean;
Private | FNoCaptureErrors: Boolean;
Private | FJoystickID: TJoystickID;
Private | FMinMaxInfo: array [TJoyAxis, TJoyPos] of Integer;
Private | FXPosInfo: array [0 .. 4] of Integer;
Private | FYPosInfo: array [0 .. 4] of Integer;
Private | FOnJoystickButtonChange: TJoystickEvent;
Private | FOnJoystickMove: TJoystickEvent;
Private | FXPosition: Integer;
Private | FYPosition: Integer;
Private | FJoyButtons: TJoystickButtons;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetCapture(AValue: Boolean);
Private | procedure SetInterval(AValue: Cardinal);
Private | procedure SetJoystickID(AValue: TJoystickID);
Private | procedure SetThreshold(AValue: Cardinal);

Properties

Published | property Capture: Boolean read FCapture write SetCapture default False;
Published | property Interval: Cardinal read FInterval write SetInterval default 100;
Public | property JoyButtons: TJoystickButtons read FJoyButtons;
Published | property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;
Published | property NoCaptureErrors: Boolean read FNoCaptureErrors write FNoCaptureErrors default True;
Published | property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;
Published | property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;
Published | property Threshold: Cardinal read FThreshold write SetThreshold default 1000;
Public | property XPosition: Integer read FXPosition;
Public | property YPosition: Integer read FYPosition;

Description

Fields

Private FWindowHandle: HWND;

This item has no description.

Private FNumButtons: Integer;

This item has no description.

Private FLastX: Integer;

This item has no description.

Private FLastY: Integer;

This item has no description.

Private FLastZ: Integer;

This item has no description.

Private FThreshold: Cardinal;

This item has no description.

Private FInterval: Cardinal;

This item has no description.

Private FCapture: Boolean;

This item has no description.

Private FNoCaptureErrors: Boolean;

This item has no description.

Private FJoystickID: TJoystickID;

This item has no description.

Private FMinMaxInfo: array [TJoyAxis, TJoyPos] of Integer;

This item has no description.

Private FXPosInfo: array [0 .. 4] of Integer;

This item has no description.

Private FYPosInfo: array [0 .. 4] of Integer;

This item has no description.

Private FOnJoystickButtonChange: TJoystickEvent;

This item has no description.

Private FOnJoystickMove: TJoystickEvent;

This item has no description.

Private FXPosition: Integer;

This item has no description.

Private FYPosition: Integer;

This item has no description.

Private FJoyButtons: TJoystickButtons;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetCapture(AValue: Boolean);

This item has no description.

Private procedure SetInterval(AValue: Cardinal);

This item has no description.

Private procedure SetJoystickID(AValue: TJoystickID);

This item has no description.

Private procedure SetThreshold(AValue: Cardinal);

This item has no description.

Properties

Published property Capture: Boolean read FCapture write SetCapture default False;

When set to True, the component attempts to capture the joystick. If capture is successfull, retrieving joystick status is possible, if not, an error message is triggered.

Published property Interval: Cardinal read FInterval write SetInterval default 100;

Polling frequency (milliseconds)

Public property JoyButtons: TJoystickButtons read FJoyButtons;

This item has no description.

Published property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;

This item has no description.

Published property NoCaptureErrors: Boolean read FNoCaptureErrors write FNoCaptureErrors default True;

If true joystick capture errors do not result in exceptions.

Published property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;

This item has no description.

Published property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;

This item has no description.

Published property Threshold: Cardinal read FThreshold write SetThreshold default 1000;

This item has no description.

Public property XPosition: Integer read FXPosition;

This item has no description.

Public property YPosition: Integer read FYPosition;


GXSysHelp v.2.5: GXS.LensFlare

Unit GXS.LensFlare

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GXS.Scene
  • GXS.Objects
  • GLScene.PipelineTransform
  • GXS.Context
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.ImageUtils
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxFlareGradient |
Class TgxLensFlare |

Types

TFlareElement = (...);
TFlareElements = set of TFlareElement;

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];

Description

Types

TFlareElement = (...);

This item has no description.

Values
  • feGlow
  • feRing
  • feStreaks
  • feRays
  • feSecondaries
TFlareElements = set of TFlareElement;

This item has no description.

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];


GXSysHelp v.2.5: GXS.LensFlare: Class TgxFlareGradient

Class TgxFlareGradient

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.LensFlare

Declaration

type TgxFlareGradient = class(TgxUpdateAbleObject)

Description

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.

Hierarchy

  • TgxUpdateAbleObject
  • TgxFlareGradient

Overview

Fields

Private | FFromColor: TgxColor;
Private | FToColor: TgxColor;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TgxColorVector);
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property fromColor: TgxColor read FFromColor write SetFromColor;
Published | property toColor: TgxColor read FToColor write SetToColor;

Description

Fields

Private FFromColor: TgxColor;

This item has no description.

Private FToColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TgxColorVector);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property fromColor: TgxColor read FFromColor write SetFromColor;

This item has no description.

Published property toColor: TgxColor read FToColor write SetToColor;


GXSysHelp v.2.5: GXS.LensFlare: Class TgxLensFlare

Class TgxLensFlare

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.LensFlare

Declaration

type TgxLensFlare = class(TgxBaseSceneObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxLensFlare

Overview

Fields

Private | FSize: Integer;
Private | FDeltaTime: Single;
Private | FCurrSize: Single;
Private | FSeed: Integer;
Private | FSqueeze: Single;
Private | FNumStreaks: Integer;
Private | FStreakWidth: Single;
Private | FStreakAngle: Single;
Private | FNumSecs: Integer;
Private | FResolution: Integer;
Private | FAutoZTest: Boolean;
Private | FElements: TFlareElements;
Private | FSin20Res: array of Single;
Private | FCos20Res: array of Single;
Private | FSinRes: array of Single;
Private | FCosRes: array of Single;
Private | FTexRays: TgxTextureHandle;
Private | FFlareIsNotOccluded: Boolean;
Private | FOcclusionQuery: TgxOcclusionQueryHandle;
Private | FGlowGradient: TgxFlareGradient;
Private | FRingGradient: TgxFlareGradient;
Private | FStreaksGradient: TgxFlareGradient;
Private | FRaysGradient: TgxFlareGradient;
Private | FSecondariesGradient: TgxFlareGradient;
Private | FDynamic: Boolean;
Private | FPreRenderPoint: TgxRenderPoint;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreRender(activeBuffer: TgxSceneBuffer);

Properties

Published | property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Dynamic: Boolean read FDynamic write FDynamic default True;
Published | property Effects;
Published | property Elements: TFlareElements read FElements write SetElements default cDefaultFlareElements;
Public | property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;
Published | property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;
Published | property GlowGradient: TgxFlareGradient read FGlowGradient write SetGlowGradient;
Published | property NumSecs: Integer read FNumSecs write SetNumSecs default 8;
Published | property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property PreRenderPoint: TgxRenderPoint read FPreRenderPoint write SetPreRenderPoint;
Published | property RaysGradient: TgxFlareGradient read FRaysGradient;
Published | property Resolution: Integer read FResolution write SetResolution default 64;
Published | property RingGradient: TgxFlareGradient read FRingGradient;
Published | property SecondariesGradient: TgxFlareGradient read FSecondariesGradient;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property size: Integer read FSize write SetSize default 50;
Published | property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;
Published | property StreakAngle: Single read FStreakAngle write SetStreakAngle;
Published | property StreaksGradient: TgxFlareGradient read FStreaksGradient;
Published | property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;
Published | property Visible;

Description

Fields

Private FSize: Integer;

This item has no description.

Private FDeltaTime: Single;

This item has no description.

Private FCurrSize: Single;

This item has no description.

Private FSeed: Integer;

This item has no description.

Private FSqueeze: Single;

This item has no description.

Private FNumStreaks: Integer;

This item has no description.

Private FStreakWidth: Single;

This item has no description.

Private FStreakAngle: Single;

This item has no description.

Private FNumSecs: Integer;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FAutoZTest: Boolean;

This item has no description.

Private FElements: TFlareElements;

This item has no description.

Private FSin20Res: array of Single;

This item has no description.

Private FCos20Res: array of Single;

This item has no description.

Private FSinRes: array of Single;

This item has no description.

Private FCosRes: array of Single;

This item has no description.

Private FTexRays: TgxTextureHandle;

This item has no description.

Private FFlareIsNotOccluded: Boolean;

This item has no description.

Private FOcclusionQuery: TgxOcclusionQueryHandle;

This item has no description.

Private FGlowGradient: TgxFlareGradient;

This item has no description.

Private FRingGradient: TgxFlareGradient;

This item has no description.

Private FStreaksGradient: TgxFlareGradient;

This item has no description.

Private FRaysGradient: TgxFlareGradient;

This item has no description.

Private FSecondariesGradient: TgxFlareGradient;

This item has no description.

Private FDynamic: Boolean;

This item has no description.

Private FPreRenderPoint: TgxRenderPoint;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreRender(activeBuffer: TgxSceneBuffer);

Prepares pre-rendered texture to speed up actual rendering. Will use the currently active context as scratch space, and will automatically do nothing if things have already been prepared, thus you can invoke it systematically in a Viewer.BeforeRender event f.i.

Properties

Published property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;

Automatically computes FlareIsNotOccluded depending on ZBuffer test. Not that the automated test may use test result from the previous frame into the next (to avoid a rendering stall).

Published property Behaviours;

This item has no description.

Published property Dynamic: Boolean read FDynamic write FDynamic default True;

Is the flare size adjusted dynamically? If true, the flare size will be grown and reduced over a few frames when it switches between occluded and non-occluded states. This requires animation to be active, but results in a smoother appearance. When false, flare will either be at full size or hidden. The flare is always considered non-dynamic at design-time.

Published property Effects;

This item has no description.

Published property Elements: TFlareElements read FElements write SetElements default cDefaultFlareElements;

Which elements should be rendered?

Public property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;

Access to the Flare's current size. Flares decay or grow back over several frames, depending on their occlusion status, and this property allows to track or manually alter this instantaneous size.

Published property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;

Is the LensFlare not occluded?. If false the flare will fade away, if true, it will fade in and stay. This value is automatically updated if AutoZTest is set.

Published property GlowGradient: TgxFlareGradient read FGlowGradient write SetGlowGradient;

This item has no description.

Published property NumSecs: Integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;

Number of streaks.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property PreRenderPoint: TgxRenderPoint read FPreRenderPoint write SetPreRenderPoint;

PreRender point for pre-rendered flare textures. See PreRender method for more details.

Published property RaysGradient: TgxFlareGradient read FRaysGradient;

This item has no description.

Published property Resolution: Integer read FResolution write SetResolution default 64;

Number of segments used when rendering circles.

Published property RingGradient: TgxFlareGradient read FRingGradient;

This item has no description.

Published property SecondariesGradient: TgxFlareGradient read FSecondariesGradient;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property size: Integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;

To create elliptic flares.

Published property StreakAngle: Single read FStreakAngle write SetStreakAngle;

Angle of the streaks (in degrees)

Published property StreaksGradient: TgxFlareGradient read FStreaksGradient;

This item has no description.

Published property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;

Width of the streaks.

Published property Visible;


GXSysHelp v.2.5: GXS.LinePFX

Unit GXS.LinePFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.ParticleFX
  • GXS.Texture
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxLineParticle |
Class TgxLinePFXManager |


GXSysHelp v.2.5: GXS.LinePFX: Class TgxLineParticle

Class TgxLineParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.LinePFX

Declaration

type TgxLineParticle = class(TgxParticle)

Description

Linear particle.

Hierarchy

  • TgxPersistentObject
  • TgxParticle
  • TgxLineParticle

Overview

Fields

Private | FDirection: TAffineVector;
Private | FLength: Single;

Methods

Public | procedure ReadFromFiler(reader : TgxVirtualReader); override;
Public | procedure WriteToFiler(writer : TgxVirtualWriter); override;

Properties

Public | property Direction : TAffineVector read FDirection write FDirection;
Public | property Length : Single read FLength write FLength;

Description

Fields

Private FDirection: TAffineVector;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public procedure ReadFromFiler(reader : TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer : TgxVirtualWriter); override;

This item has no description.

Properties

Public property Direction : TAffineVector read FDirection write FDirection;

Direction of the line.

Public property Length : Single read FLength write FLength;

Length of the line


GXSysHelp v.2.5: GXS.LinePFX: Class TgxLinePFXManager

Class TgxLinePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.LinePFX

Declaration

type TgxLinePFXManager = class(TgxLifeColoredPFXManager)

Description

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxLinePFXManager

Overview

Fields

Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | FNvx: TAffineVector;
Private | FNvy: TAffineVector;
Private | FDefaultLength: Single;

Methods

Public | constructor Create(aOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TgxParticle; override;
Public | class function ParticlesClass: TgxParticleClass; override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property DefaultLength : Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;
Published | property LifeColors;
Published | property ParticleSize;

Description

Fields

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private FNvx: TAffineVector;

NOT persistent

Private FNvy: TAffineVector;

NOT persistent

Private FDefaultLength: Single;

NOT persistent

Methods

Public constructor Create(aOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TgxParticle; override;

This item has no description. Showing description inherited from TgxParticleFXManager.CreateParticle.

Creates a new particle controlled by the manager.

Public class function ParticlesClass: TgxParticleClass; override;

This item has no description. Showing description inherited from TgxParticleFXManager.ParticlesClass.

Class of particles created by this manager. }

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property DefaultLength : Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;

This item has no description.

Published property LifeColors;

This item has no description.

Published property ParticleSize;


GXSysHelp v.2.5: GXS.Material

Unit GXS.Material

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • FMX.Dialogs
  • FMX.Graphics
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GLScene.Strings
  • GLScene.TextureFormat
  • GXS.Color
  • GXS.Coordinates
  • GLScene.Utils
  • GXS.ApplicationFileIO
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.Texture
  • GXS.State
  • GXS.Graphics
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IgxMaterialLibrarySupported |
Class TgxShader |
Class TgxFaceProperties |
Class TgxDepthProperties |
Class TgxBlendingParameters |
Class TgxMaterial |
Class TgxAbstractLibMaterial |
Class TgxLibMaterial |
Class TgxAbstractLibMaterials |
Class TgxLibMaterials |
Class TgxAbstractMaterialLibrary |
Class TgxMaterialLibrary |

Types

TgxAlphaFunc = TgxComparisonFunction;
TgxBlendingMode = (...);
TgxFaceCulling = (...);
TgxLibMaterialName = string;
TgxMaterialOption = (...);
TgxMaterialOptions = set of TgxMaterialOption;
TgxShaderClass = class of TgxShader;
TgxShaderFailedInitAction = (...);
TgxShaderStyle = (...);
TgxShininess = 0 .. 128;

Description

Types

TgxAlphaFunc = TgxComparisonFunction;

To show up in design-time editor vTGlAlphaFuncValues and vTgxBlendFuncFactorValues arrays if you type smth like af_GL_NEVER = GL_NEVER in the definition.

TgxBlendingMode = (...);

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TgxBlendingParameters options

Values
  • bmOpaque
  • bmTransparency
  • bmAdditive
  • bmAlphaTest50
  • bmAlphaTest100
  • bmModulate
  • bmCustom
TgxFaceCulling = (...);

This item has no description.

Values
  • fcBufferDefault
  • fcCull
  • fcNoCull
TgxLibMaterialName = string;

This item has no description.

TgxMaterialOption = (...);

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered

Values
  • moIgnoreFog
  • moNoLighting
TgxMaterialOptions = set of TgxMaterialOption;

This item has no description.

TgxShaderClass = class of TgxShader;

This item has no description.

TgxShaderFailedInitAction = (...);

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)

Values
  • fiaSilentDisable
  • fiaRaiseStandardException
  • fiaRaiseHandledException
  • fiaReRaiseException
TgxShaderStyle = (...);

Define VXShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)

Values
  • ssHighLevel
  • ssLowLevel
  • ssReplace
TgxShininess = 0 .. 128;


GXSysHelp v.2.5: GXS.Material: Interface IgxMaterialLibrarySupported

Interface IgxMaterialLibrarySupported

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type IgxMaterialLibrarySupported = interface(IInterface)

Description

an interface for proper TgxLibMaterialNameProperty support

Hierarchy

  • IInterface
  • IgxMaterialLibrarySupported

Overview

Methods

Public function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Description

Methods

Public function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Attributes
GUID['{8E442AF9-D212-4A5E-8A88-92F798BABFD1}']


GXSysHelp v.2.5: GXS.Material: Class TgxShader

Class TgxShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxShader = class(TgxUpdateAbleComponent)

Description

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader

Overview

Fields

Private | FEnabled: Boolean;
Private | FLibMatUsers: TList;
Private | FVirtualHandle: TgxVirtualHandle;
Private | FShaderStyle: TgxShaderStyle;
Private | FUpdateCount: Integer;
Private | FShaderActive: Boolean;
Private | FFailedInitAction: TgxShaderFailedInitAction;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; virtual;
Public | function UnApply(var rci: TgxRenderContextInfo): Boolean;
Public | procedure Apply(var rci: TgxRenderContextInfo; Sender: TObject);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Public | property FailedInitAction: TgxShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;
Public | property ShaderStyle: TgxShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FLibMatUsers: TList;

This item has no description.

Private FVirtualHandle: TgxVirtualHandle;

This item has no description.

Private FShaderStyle: TgxShaderStyle;

This item has no description.

Private FUpdateCount: Integer;

This item has no description.

Private FShaderActive: Boolean;

This item has no description.

Private FFailedInitAction: TgxShaderFailedInitAction;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; virtual;

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public function UnApply(var rci: TgxRenderContextInfo): Boolean;

UnApply shader. When returning True, the caller is expected to perform a multipass rendering by re-rendering then invoking UnApply again, until a "False" is returned.

Public procedure Apply(var rci: TgxRenderContextInfo; Sender: TObject);

Apply shader to OpenGL state machine.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

Subclasses should invoke this function when shader properties are altered. This procedure can also be used to reset/recompile the shader.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Turns on/off shader application. Note that this only turns on/off the shader application, if the ShaderStyle is ssReplace, the material won't be applied even if the shader is disabled.

Public property FailedInitAction: TgxShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Public property ShaderStyle: TgxShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Shader application style (default is ssLowLevel).


GXSysHelp v.2.5: GXS.Material: Class TgxFaceProperties

Class TgxFaceProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxFaceProperties = class(TgxUpdateAbleObject)

Description

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

Hierarchy

  • TgxUpdateAbleObject
  • TgxFaceProperties

Overview

Fields

Private | FAmbient: TgxColor;
Private | FDiffuse: TgxColor;
Private | FSpecular: TgxColor;
Private | FEmission: TgxColor;
Private | FShininess: TgxShininess;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TgxRenderContextInfo; AFace: TgxCullFaceMode);
Public | procedure ApplyNoLighting(var rci: TgxRenderContextInfo; AFace: TgxCullFaceMode);
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Ambient: TgxColor read FAmbient write SetAmbient;
Published | property Diffuse: TgxColor read FDiffuse write SetDiffuse;
Published | property Emission: TgxColor read FEmission write SetEmission;
Published | property Shininess: TgxShininess read FShininess write SetShininess default 0;
Published | property Specular: TgxColor read FSpecular write SetSpecular;

Description

Fields

Private FAmbient: TgxColor;

This item has no description.

Private FDiffuse: TgxColor;

This item has no description.

Private FSpecular: TgxColor;

This item has no description.

Private FEmission: TgxColor;

This item has no description.

Private FShininess: TgxShininess;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo; AFace: TgxCullFaceMode);

This item has no description.

Public procedure ApplyNoLighting(var rci: TgxRenderContextInfo; AFace: TgxCullFaceMode);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Ambient: TgxColor read FAmbient write SetAmbient;

This item has no description.

Published property Diffuse: TgxColor read FDiffuse write SetDiffuse;

This item has no description.

Published property Emission: TgxColor read FEmission write SetEmission;

This item has no description.

Published property Shininess: TgxShininess read FShininess write SetShininess default 0;

This item has no description.

Published property Specular: TgxColor read FSpecular write SetSpecular;


GXSysHelp v.2.5: GXS.Material: Class TgxDepthProperties

Class TgxDepthProperties

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxDepthProperties = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDepthProperties

Overview

Fields

Private | FDepthTest: Boolean;
Private | FDepthWrite: Boolean;
Private | FZNear: Single;
Private | FZFar: Single;
Private | FCompareFunc: TgxDepthfunction;
Private | FDepthClamp: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;
Published | property DepthCompareFunction: TgxDepthfunction read FCompareFunc write SetCompareFunc default cfLequal;
Published | property DepthTest: Boolean read FDepthTest write SetDepthTest default True;
Published | property DepthWrite: Boolean read FDepthWrite write SetDepthWrite default False;
Published | property ZFar: Single read FZFar write SetZFar stored StoreZFar;
Published | property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Description

Fields

Private FDepthTest: Boolean;

This item has no description.

Private FDepthWrite: Boolean;

This item has no description.

Private FZNear: Single;

This item has no description.

Private FZFar: Single;

This item has no description.

Private FCompareFunc: TgxDepthfunction;

This item has no description.

Private FDepthClamp: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;

Enable clipping depth to the near and far planes

Published property DepthCompareFunction: TgxDepthfunction read FCompareFunc write SetCompareFunc default cfLequal;

Specifies the function used to compare each incoming pixel depth value with the depth value present in the depth buffer.

Published property DepthTest: Boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling. When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering). When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera. Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property DepthWrite: Boolean read FDepthWrite write SetDepthWrite default False;

If True, object will not write to Z-Buffer.

Published property ZFar: Single read FZFar write SetZFar stored StoreZFar;

Specifies the mapping of the far clipping plane to window coordinates. The initial value is 1.

Published property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Specifies the mapping of the near clipping plane to window coordinates. The initial value is 0.


GXSysHelp v.2.5: GXS.Material: Class TgxBlendingParameters

Class TgxBlendingParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxBlendingParameters = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TgxBlendingParameters

Overview

Fields

Private | FUseAlphaFunc: Boolean;
Private | FUseBlendFunc: Boolean;
Private | FSeparateBlendFunc: Boolean;
Private | FAlphaFuncType: TgxAlphaFunc;
Private | FAlphaFuncRef: Single;
Private | FBlendFuncSFactor: TgxBlendFunction;
Private | FBlendFuncDFactor: TgxBlendFunction;
Private | FAlphaBlendFuncSFactor: TgxBlendFunction;
Private | FAlphaBlendFuncDFactor: TgxBlendFunction;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreAlphaFuncRef: Boolean;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Private | procedure SetAlphaBlendFuncDFactor(const Value: TgxBlendFunction);
Private | procedure SetAlphaBlendFuncSFactor(const Value: TgxBlendFunction);
Private | procedure SetAlphaFuncRef(const Value: Single);
Private | procedure SetAlphaFuncType(const Value: TgxAlphaFunc);
Private | procedure SetBlendFuncDFactor(const Value: TgxBlendFunction);
Private | procedure SetBlendFuncSFactor(const Value: TgxBlendFunction);
Private | procedure SetSeparateBlendFunc(const Value: Boolean);
Private | procedure SetUseAlphaFunc(const Value: Boolean);
Private | procedure SetUseBlendFunc(const Value: Boolean);

Properties

Published | property AlphaBlendFuncDFactor: TgxBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property AlphaBlendFuncSFactor: TgxBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;
Published | property AlphaFuncRef: Single read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;
Published | property AlphaFunctType: TgxAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;
Published | property BlendFuncDFactor: TgxBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property BlendFuncSFactor: TgxBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;
Published | property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;
Published | property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;
Published | property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;

Description

Fields

Private FUseAlphaFunc: Boolean;

This item has no description.

Private FUseBlendFunc: Boolean;

This item has no description.

Private FSeparateBlendFunc: Boolean;

This item has no description.

Private FAlphaFuncType: TgxAlphaFunc;

This item has no description.

Private FAlphaFuncRef: Single;

This item has no description.

Private FBlendFuncSFactor: TgxBlendFunction;

This item has no description.

Private FBlendFuncDFactor: TgxBlendFunction;

This item has no description.

Private FAlphaBlendFuncSFactor: TgxBlendFunction;

This item has no description.

Private FAlphaBlendFuncDFactor: TgxBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreAlphaFuncRef: Boolean;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetAlphaBlendFuncDFactor(const Value: TgxBlendFunction);

This item has no description.

Private procedure SetAlphaBlendFuncSFactor(const Value: TgxBlendFunction);

This item has no description.

Private procedure SetAlphaFuncRef(const Value: Single);

This item has no description.

Private procedure SetAlphaFuncType(const Value: TgxAlphaFunc);

This item has no description.

Private procedure SetBlendFuncDFactor(const Value: TgxBlendFunction);

This item has no description.

Private procedure SetBlendFuncSFactor(const Value: TgxBlendFunction);

This item has no description.

Private procedure SetSeparateBlendFunc(const Value: Boolean);

This item has no description.

Private procedure SetUseAlphaFunc(const Value: Boolean);

This item has no description.

Private procedure SetUseBlendFunc(const Value: Boolean);

This item has no description.

Properties

Published property AlphaBlendFuncDFactor: TgxBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;

This item has no description.

Published property AlphaBlendFuncSFactor: TgxBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;

This item has no description.

Published property AlphaFuncRef: Single read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;

This item has no description.

Published property AlphaFunctType: TgxAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;

This item has no description.

Published property BlendFuncDFactor: TgxBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;

This item has no description.

Published property BlendFuncSFactor: TgxBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;

This item has no description.

Published property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;

This item has no description.

Published property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;

This item has no description.

Published property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;


GXSysHelp v.2.5: GXS.Material: Class TgxMaterial

Class TgxMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxMaterial = class(TgxUpdateAbleObject, IgxMaterialLibrarySupported, IgxNotifyable, IgxTextureNotifyAble)

Description

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TgxLibMaterial (taken for a material library). The TgxLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps

Hierarchy

  • TgxUpdateAbleObject
  • TgxMaterial

Overview

Fields

Private | FFrontProperties: TgxFaceProperties;
Private | FBackProperties: TgxFaceProperties;
Private | FDepthProperties: TgxDepthProperties;
Private | FBlendingMode: TgxBlendingMode;
Private | FBlendingParams: TgxBlendingParameters;
Private | FTexture: TgxTexture;
Private | FTextureEx: TgxTextureEx;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FLibMaterialName: TgxLibMaterialName;
Private | FMaterialOptions: TgxMaterialOptions;
Private | FFaceCulling: TgxFaceCulling;
Private | FPolygonMode: TgxPolygonMode;
Private | currentLibMaterial: TgxAbstractLibMaterial;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean;
Public | function GetActualPrimaryMaterial: TgxMaterial;
Public | function GetActualPrimaryTexture: TgxTexture;
Public | function GetLibMaterial: TgxLibMaterial;
Public | function HasSecondaryTexture: Boolean;
Public | function MaterialIsLinkedToLib: Boolean;
Public | function UnApply(var rci: TgxRenderContextInfo): Boolean;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure PrepareBuildList;
Public | procedure QuickAssignMaterial(const MaterialLibrary: TgxMaterialLibrary; const Material: TgxLibMaterial);

Properties

Published | property BackProperties: TgxFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;
Published | property BlendingMode: TgxBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;
Published | property BlendingParams: TgxBlendingParameters read FBlendingParams write SetBlendingParams;
Published | property DepthProperties: TgxDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;
Published | property FaceCulling: TgxFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published | property FrontProperties: TgxFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;
Published | property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TgxAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaterialOptions: TgxMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published | property PolygonMode: TgxPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published | property Texture: TgxTexture read GetTexture write SetTexture stored StoreMaterialProps;
Published | property TextureEx: TgxTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;

Description

Fields

Private FFrontProperties: TgxFaceProperties;

This item has no description.

Private FBackProperties: TgxFaceProperties;

This item has no description.

Private FDepthProperties: TgxDepthProperties;

This item has no description.

Private FBlendingMode: TgxBlendingMode;

This item has no description.

Private FBlendingParams: TgxBlendingParameters;

This item has no description.

Private FTexture: TgxTexture;

This item has no description.

Private FTextureEx: TgxTextureEx;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FLibMaterialName: TgxLibMaterialName;

This item has no description.

Private FMaterialOptions: TgxMaterialOptions;

This item has no description.

Private FFaceCulling: TgxFaceCulling;

This item has no description.

Private FPolygonMode: TgxPolygonMode;

This item has no description.

Private currentLibMaterial: TgxAbstractLibMaterial;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean;

Returns True if the material is blended. Will return the libmaterial's blending if it is linked to a material library.

Public function GetActualPrimaryMaterial: TgxMaterial;

Gets the primary Material either from material library or the texture property

Public function GetActualPrimaryTexture: TgxTexture;

Gets the primary texture either from material library or the texture property

Public function GetLibMaterial: TgxLibMaterial;

Return the LibMaterial (see LibMaterialName)

Public function HasSecondaryTexture: Boolean;

True if the material has a secondary texture

Public function MaterialIsLinkedToLib: Boolean;

True if the material comes from the library instead of the texture property

Public function UnApply(var rci: TgxRenderContextInfo): Boolean;

Restore non-standard material states that were altered; A return value of True is a multipass request.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IVXMaterialLibrarySupported.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Public procedure PrepareBuildList;

This item has no description.

Public procedure QuickAssignMaterial(const MaterialLibrary: TgxMaterialLibrary; const Material: TgxLibMaterial);

This item has no description.

Properties

Published property BackProperties: TgxFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;

This item has no description.

Published property BlendingMode: TgxBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;

This item has no description.

Published property BlendingParams: TgxBlendingParameters read FBlendingParams write SetBlendingParams;

This item has no description.

Published property DepthProperties: TgxDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;

This item has no description.

Published property FaceCulling: TgxFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;

This item has no description.

Published property FrontProperties: TgxFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;

This item has no description.

Published property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;

This item has no description.

Published property MaterialLibrary: TgxAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MaterialOptions: TgxMaterialOptions read FMaterialOptions write SetMaterialOptions default [];

This item has no description.

Published property PolygonMode: TgxPolygonMode read FPolygonMode write SetPolygonMode default pmFill;

This item has no description.

Published property Texture: TgxTexture read GetTexture write SetTexture stored StoreMaterialProps;

This item has no description.

Published property TextureEx: TgxTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;


GXSysHelp v.2.5: GXS.Material: Class TgxAbstractLibMaterial

Class TgxAbstractLibMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxAbstractLibMaterial = class(TCollectionItem, IgxMaterialLibrarySupported, IgxNotifyable)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxAbstractLibMaterial

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; virtual;
Public | function IsUsed: Boolean;
Public | function UnApply(var ARci: TgxRenderContextInfo): Boolean; virtual; abstract;
Public | procedure Apply(var ARci: TgxRenderContextInfo); virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); virtual;
Public | procedure NotifyUsers;
Public | procedure RegisterUser(libMaterial: TgxLibMaterial); overload;
Public | procedure RegisterUser(comp: TgxUpdateAbleComponent); overload;
Public | procedure RegisterUser(Obj: TgxUpdateAbleObject); overload;
Public | procedure UnRegisterUser(libMaterial: TgxLibMaterial); overload;
Public | procedure UnRegisterUser(Obj: TgxUpdateAbleObject); overload;
Public | procedure UnRegisterUser(comp: TgxUpdateAbleComponent); overload;

Properties

Public | property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary;
Published | property Name: TgxLibMaterialName read FName write SetName;
Public | property NameHashKey: Integer read FNameHashKey;
Published | property Tag: Integer read FTag write FTag;

Description

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; virtual;

This item has no description.

Public function IsUsed: Boolean;

This item has no description.

Public function UnApply(var ARci: TgxRenderContextInfo): Boolean; virtual; abstract;

Restore non-standard material states that were altered

Public procedure Apply(var ARci: TgxRenderContextInfo); virtual; abstract;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); virtual;

This item has no description.

Public procedure NotifyUsers;

This item has no description.

Public procedure RegisterUser(libMaterial: TgxLibMaterial); overload;

This item has no description.

Public procedure RegisterUser(comp: TgxUpdateAbleComponent); overload;

This item has no description.

Public procedure RegisterUser(Obj: TgxUpdateAbleObject); overload;

This item has no description.

Public procedure UnRegisterUser(libMaterial: TgxLibMaterial); overload;

This item has no description.

Public procedure UnRegisterUser(Obj: TgxUpdateAbleObject); overload;

This item has no description.

Public procedure UnRegisterUser(comp: TgxUpdateAbleComponent); overload;

This item has no description.

Properties

Public property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary;

This item has no description.

Published property Name: TgxLibMaterialName read FName write SetName;

This item has no description.

Public property NameHashKey: Integer read FNameHashKey;

returns true if the texture has registed users

Published property Tag: Integer read FTag write FTag;


GXSysHelp v.2.5: GXS.Material: Class TgxLibMaterial

Class TgxLibMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxLibMaterial = class(TgxAbstractLibMaterial, IgxTextureNotifyAble)

Description

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxAbstractLibMaterial
  • TgxLibMaterial

Overview

Fields

Private | FMaterial: TgxMaterial;
Private | FTextureOffset: TgxCoordinates;
Private | FTextureScale: TgxCoordinates;
Private | FTextureRotate: Single;
Private | FTextureMatrixIsIdentity: Boolean;
Private | FTextureOverride: Boolean;
Private | FTextureMatrix: TMatrix4f;
Private | FTexture2Name: TgxLibMaterialName;
Private | FShader: TgxShader;
Private | libMatTexture2: TgxLibMaterial;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; override;
Public | function UnApply(var ARci: TgxRenderContextInfo): Boolean; override;
Public | procedure Apply(var ARci: TgxRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure NotifyUsersOfTexMapChange;
Public | procedure PrepareBuildList;

Properties

Published | property Material: TgxMaterial read FMaterial write SetMaterial;
Published | property Shader: TgxShader read FShader write SetShader;
Published | property Texture2Name: TgxLibMaterialName read FTexture2Name write SetTexture2Name;
Public | property TextureMatrix: TMatrix4f read FTextureMatrix write SetTextureMatrix;
Public | property TextureMatrixIsIdentity: Boolean read FTextureMatrixIsIdentity;
Published | property TextureOffset: TgxCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published | property TextureScale: TgxCoordinates read FTextureScale write SetTextureScale;

Description

Fields

Private FMaterial: TgxMaterial;

This item has no description.

Private FTextureOffset: TgxCoordinates;

This item has no description.

Private FTextureScale: TgxCoordinates;

This item has no description.

Private FTextureRotate: Single;

This item has no description.

Private FTextureMatrixIsIdentity: Boolean;

This item has no description.

Private FTextureOverride: Boolean;

This item has no description.

Private FTextureMatrix: TMatrix4f;

This item has no description.

Private FTexture2Name: TgxLibMaterialName;

This item has no description.

Private FShader: TgxShader;

This item has no description.

Private libMatTexture2: TgxLibMaterial;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Blended: Boolean; override;

This item has no description.

Public function UnApply(var ARci: TgxRenderContextInfo): Boolean; override;

Restore non-standard material states that were altered

Public procedure Apply(var ARci: TgxRenderContextInfo); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Public procedure NotifyUsersOfTexMapChange;

This item has no description.

Public procedure PrepareBuildList;

This item has no description.

Properties

Published property Material: TgxMaterial read FMaterial write SetMaterial;

This item has no description.

Published property Shader: TgxShader read FShader write SetShader;

Optionnal shader for the material.

Published property Texture2Name: TgxLibMaterialName read FTexture2Name write SetTexture2Name;

Reference to the second texture. The referred LibMaterial *must* be in the same material library. Second textures are supported only through ARB multitexturing (ignored if not supported).

Public property TextureMatrix: TMatrix4f read FTextureMatrix write SetTextureMatrix;

This item has no description.

Public property TextureMatrixIsIdentity: Boolean read FTextureMatrixIsIdentity;

This item has no description.

Published property TextureOffset: TgxCoordinates read FTextureOffset write SetTextureOffset;

Texture offset in texture coordinates. The offset is applied after scaling.

Published property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;

This item has no description.

Published property TextureScale: TgxCoordinates read FTextureScale write SetTextureScale;

Texture coordinates scaling. Scaling is applied before applying the offset, and is applied to the texture coordinates, meaning that a scale factor of (2, 2, 2) will make your texture look twice smaller


GXSysHelp v.2.5: GXS.Material: Class TgxAbstractLibMaterials

Class TgxAbstractLibMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxAbstractLibMaterials = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxAbstractLibMaterials

Overview

Methods

Public function MakeUniqueName(const nameRoot: TgxLibMaterialName): TgxLibMaterialName; virtual;

Description

Methods

Public function MakeUniqueName(const nameRoot: TgxLibMaterialName): TgxLibMaterialName; virtual;


GXSysHelp v.2.5: GXS.Material: Class TgxLibMaterials

Class TgxLibMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxLibMaterials = class(TgxAbstractLibMaterials)

Description

A collection of materials, mainly used in material libraries.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxAbstractLibMaterials
  • TgxLibMaterials

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxLibMaterial;
Public | function FindItemID(ID: Integer): TgxLibMaterial;
Public | function GetLibMaterialByName(const AName: TgxLibMaterialName): TgxLibMaterial;
Public | function GetMaterialIndex(const Material: TgxMaterial): Integer;
Public | function GetNameOfLibMaterial(const Material: TgxLibMaterial): TgxLibMaterialName;
Public | function GetNameOfTexture(const Texture: TgxTexture): TgxLibMaterialName;
Public | function GetTextureIndex(const Texture: TgxTexture): Integer;
Public | function IndexOf(const Item: TgxLibMaterial): Integer;
Public | function Owner: TPersistent;
Public | procedure DeleteUnusedMaterials;
Public | procedure PrepareBuildList;

Properties

Public property Items[index: Integer]: TgxLibMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxLibMaterial;

This item has no description.

Public function FindItemID(ID: Integer): TgxLibMaterial;

This item has no description.

Public function GetLibMaterialByName(const AName: TgxLibMaterialName): TgxLibMaterial;

This item has no description.

Public function GetMaterialIndex(const Material: TgxMaterial): Integer;

Returns index of this Material if it exists.

Public function GetNameOfLibMaterial(const Material: TgxLibMaterial): TgxLibMaterialName;

Returns name of this Material if it exists.

Public function GetNameOfTexture(const Texture: TgxTexture): TgxLibMaterialName;

Returns name of this Texture if it exists.

Public function GetTextureIndex(const Texture: TgxTexture): Integer;

Returns index of this Texture if it exists.

Public function IndexOf(const Item: TgxLibMaterial): Integer;

This item has no description.

Public function Owner: TPersistent;

This item has no description.

Public procedure DeleteUnusedMaterials;

Deletes all the unused materials in the collection. A material is considered unused if no other material or updateable object references it. WARNING: For this to work, objects that use the texture, have to REGISTER to the texture.

Public procedure PrepareBuildList;

This item has no description.

Properties

Public property Items[index: Integer]: TgxLibMaterial read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Material: Class TgxAbstractMaterialLibrary

Class TgxAbstractMaterialLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxAbstractMaterialLibrary = class(TgxCadenceAbleComponent)

Description

This item has no description.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxAbstractMaterialLibrary

Overview

Methods

Public | function ApplyMaterial(const AName: string; var ARci: TgxRenderContextInfo): Boolean; virtual;
Public | function UnApplyMaterial(var ARci: TgxRenderContextInfo): Boolean; virtual;
Public | procedure SetNamesToTStrings(AStrings: TStrings);

Description

Methods

Public function ApplyMaterial(const AName: string; var ARci: TgxRenderContextInfo): Boolean; virtual;

Applies the material of given name. Returns False if the material could not be found. ake sure this call is balanced with a corresponding UnApplyMaterial (or an assertion will be triggered in the destructor). If a material is already applied, and has not yet been unapplied, an assertion will be triggered.

Public function UnApplyMaterial(var ARci: TgxRenderContextInfo): Boolean; virtual;

Un-applies the last applied material. Use this function in conjunction with ApplyMaterial. If no material was applied, an assertion will be triggered.

Public procedure SetNamesToTStrings(AStrings: TStrings);


GXSysHelp v.2.5: GXS.Material: Class TgxMaterialLibrary

Class TgxMaterialLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Material

Declaration

type TgxMaterialLibrary = class(TgxAbstractMaterialLibrary)

Description

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxAbstractMaterialLibrary
  • TgxMaterialLibrary

Overview

Fields

Private | FDoNotClearMaterialsOnLoad: Boolean;
Private | FOnTextureNeeded: TgxTextureNeededEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddTextureMaterial(const MaterialName: string; Graphic: TBitmap): TgxLibMaterial; overload;
Public | function AddTextureMaterial(const MaterialName, fileName: string; persistent: Boolean = True): TgxLibMaterial; overload;
Public | function GetNameOfLibMaterial(const libMat: TgxLibMaterial): TgxLibMaterialName;
Public | function GetNameOfTexture(const Texture: TgxTexture): TgxLibMaterialName;
Public | function LibMaterialByName(const AName: TgxLibMaterialName): TgxLibMaterial;
Public | function TextureByName(const LibMatName: TgxLibMaterialName): TgxTexture;
Public | procedure AddMaterialsFromFile(const fileName: string);
Public | procedure AddMaterialsFromStream(aStream: TStream);
Public | procedure DestroyHandles;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream); virtual;
Public | procedure ReadFromFiler(reader: TgxVirtualReader);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream); virtual;
Public | procedure WriteToFiler(writer: TgxVirtualWriter);

Properties

Published | property Materials: TgxLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;
Published | property OnTextureNeeded: TgxTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Published | property TexturePaths;

Description

Fields

Private FDoNotClearMaterialsOnLoad: Boolean;

This item has no description.

Private FOnTextureNeeded: TgxTextureNeededEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddTextureMaterial(const MaterialName: string; Graphic: TBitmap): TgxLibMaterial; overload;

Add a "standard" texture material. TgxGraphic based variant.

Public function AddTextureMaterial(const MaterialName, fileName: string; persistent: Boolean = True): TgxLibMaterial; overload;

Add a "standard" texture material. "standard" means linear texturing mode with mipmaps and texture modulation mode with default-strength color components. If persistent is True, the image will be loaded persistently in memory (via a TgxPersistentImage), if false, it will be unloaded after upload to OpenRX (via TgxPicFileImage).

Public function GetNameOfLibMaterial(const libMat: TgxLibMaterial): TgxLibMaterialName;

Returns name of Material if any exists.

Public function GetNameOfTexture(const Texture: TgxTexture): TgxLibMaterialName;

Returns name of texture if any exists.

Public function LibMaterialByName(const AName: TgxLibMaterialName): TgxLibMaterial;

Returns libMaterial of given name if any exists.

Public function TextureByName(const LibMatName: TgxLibMaterialName): TgxTexture;

Returns Texture of given material's name if any exists.

Public procedure AddMaterialsFromFile(const fileName: string);

This item has no description.

Public procedure AddMaterialsFromStream(aStream: TStream);

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

This item has no description.

Public procedure LoadFromStream(aStream: TStream); virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader);

This item has no description.

Public procedure SaveToFile(const fileName: string);

Save library content to a file. Recommended extension : .GLML Currently saves only texture, ambient, diffuse, emission and specular colors.

Public procedure SaveToStream(aStream: TStream); virtual;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter);

This item has no description.

Properties

Published property Materials: TgxLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;

The materials collection.

Published property OnTextureNeeded: TgxTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;

This event is fired whenever a texture needs to be loaded from disk. The event is triggered before even attempting to load the texture, and before TexturePaths is used.

Published property TexturePaths;

Paths to lookup when attempting to load a texture. You can specify multiple paths when loading a texture, the separator being the semi-colon ';' character. Directories are looked up from first to last, the first file name match is used. The current directory is always implicit and checked last. Note that you can also use the OnTextureNeeded event to provide a filename.


GXSysHelp v.2.5: GXS.MaterialMultiProxy

Unit GXS.MaterialMultiProxy

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.Texture
  • GXS.Material
  • GXS.Silhouette
  • GXS.Scene
  • GXS.RenderContextInfo
  • GXS.Context
  • GLScene.PipelineTransform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMaterialMultiProxyMaster |
Class TgxMaterialMultiProxyMasters |
Class TgxMaterialMultiProxy |


GXSysHelp v.2.5: GXS.MaterialMultiProxy: Class TgxMaterialMultiProxyMaster

Class TgxMaterialMultiProxyMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialMultiProxy

Declaration

type TgxMaterialMultiProxyMaster = class(TgxInterfacedCollectionItem, IgxMaterialLibrarySupported)

Description

MasterObject description for a MultiProxy object.

Hierarchy

  • TgxInterfacedCollectionItem
  • TgxMaterialMultiProxyMaster

Overview

Fields

Private | FMasterObject: TgxBaseSceneObject;
Private | FMasterLibMaterial: TgxLibMaterial;
Private | FTempLibMaterialName: TgxLibMaterialName;
Private | FDistanceMin2: Single;
Private | FDistanceMax2: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject: TgxMaterialMultiProxy;
Private | function GetMasterLibMaterialName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;
Private | procedure SetMasterLibMaterialName(const Value: TgxLibMaterialName);

Properties

Published | property DistanceMax: Single read GetDistanceMax write SetDistanceMax;
Published | property DistanceMin: Single read GetDistanceMin write SetDistanceMin;
Public | property MasterLibMaterial: TgxLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TgxLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;

Description

Fields

Private FMasterObject: TgxBaseSceneObject;

This item has no description.

Private FMasterLibMaterial: TgxLibMaterial;

This item has no description.

Private FTempLibMaterialName: TgxLibMaterialName;

This item has no description.

Private FDistanceMin2: Single;

This item has no description.

Private FDistanceMax2: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerObject: TgxMaterialMultiProxy;

This item has no description.

Private function GetMasterLibMaterialName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Private procedure SetMasterLibMaterialName(const Value: TgxLibMaterialName);

This item has no description.

Properties

Published property DistanceMax: Single read GetDistanceMax write SetDistanceMax;

Maximum visibility Distance (exclusive).

Published property DistanceMin: Single read GetDistanceMin write SetDistanceMin;

Minimum visibility Distance (inclusive).

Public property MasterLibMaterial: TgxLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TgxLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.


GXSysHelp v.2.5: GXS.MaterialMultiProxy: Class TgxMaterialMultiProxyMasters

Class TgxMaterialMultiProxyMasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialMultiProxy

Declaration

type TgxMaterialMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TgxMaterialMultiProxyMaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxMaterialMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add(Master: TgxBaseSceneObject; MasterLibMaterial: TgxLibMaterial; DistanceMin, DistanceMax: Single): TgxMaterialMultiProxyMaster; overload;
Public | function Add(Master: TgxBaseSceneObject; DistanceMin, DistanceMax: Single): TgxMaterialMultiProxyMaster; overload;
Public | function Add: TgxMaterialMultiProxyMaster; overload;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TgxMaterialMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add(Master: TgxBaseSceneObject; MasterLibMaterial: TgxLibMaterial; DistanceMin, DistanceMax: Single): TgxMaterialMultiProxyMaster; overload;

This item has no description.

Public function Add(Master: TgxBaseSceneObject; DistanceMin, DistanceMax: Single): TgxMaterialMultiProxyMaster; overload;

This item has no description.

Public function Add: TgxMaterialMultiProxyMaster; overload;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TgxMaterialMultiProxyMaster read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MaterialMultiProxy: Class TgxMaterialMultiProxy

Class TgxMaterialMultiProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialMultiProxy

Declaration

type TgxMaterialMultiProxy = class(TgxBaseSceneObject)

Description

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxMaterialMultiProxy

Overview

Fields

Private | FMasterObjects: TgxMaterialMultiProxyMasters;
Private | FRendering: Boolean;
Private | FMaterialLibrary: TgxMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property MasterObjects: TgxMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObjects: TgxMaterialMultiProxyMasters;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

internal use (loop protection)

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property MasterObjects: TgxMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.MaterialScript

Unit GXS.MaterialScript

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • FMX.StdCtrls
  • FMX.Memo
  • GLScene.VectorTypes
  • GLScene.Utils
  • GXS.Texture
  • GLScene.TextureFormat
  • GXS.Graphics
  • GXS.ImageUtils
  • GXS.Color
  • GXS.Coordinates
  • GXS.Material
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxShaderItem |
Class TgxShaderItems |
Class TgxMaterialLibraryItem |
Class TgxMaterialLibraryItems |
Class TgxMaterialScripter |


GXSysHelp v.2.5: GXS.MaterialScript: Class TgxShaderItem

Class TgxShaderItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialScript

Declaration

type TgxShaderItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxShaderItem

Overview

Fields

Private | FShader: TgxShader;
Private | FName: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetName(const Value: string);
Private | procedure SetShader(const Value: TgxShader);

Properties

Published | property Name: string read FName write SetName;
Published | property Shader: TgxShader read FShader write SetShader;

Description

Fields

Private FShader: TgxShader;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Private procedure SetShader(const Value: TgxShader);

This item has no description.

Properties

Published property Name: string read FName write SetName;

This item has no description.

Published property Shader: TgxShader read FShader write SetShader;


GXSysHelp v.2.5: GXS.MaterialScript: Class TgxShaderItems

Class TgxShaderItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialScript

Declaration

type TgxShaderItems = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxShaderItems

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Private | function GetItems(Index: Integer): TgxShaderItem;
Private | procedure SetItems(Index: Integer; const Val: TgxShaderItem);

Properties

Public property Items[Index: Integer]: TgxShaderItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Private function GetItems(Index: Integer): TgxShaderItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TgxShaderItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TgxShaderItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MaterialScript: Class TgxMaterialLibraryItem

Class TgxMaterialLibraryItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialScript

Declaration

type TgxMaterialLibraryItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxMaterialLibraryItem

Overview

Fields

Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FName: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetName(const Value: string);

Properties

Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;

Description

Fields

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FName: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetName(const Value: string);

This item has no description.

Properties

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Name: string read FName write SetName;


GXSysHelp v.2.5: GXS.MaterialScript: Class TgxMaterialLibraryItems

Class TgxMaterialLibraryItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialScript

Declaration

type TgxMaterialLibraryItems = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxMaterialLibraryItems

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Private | function GetItems(Index: Integer): TgxMaterialLibraryItem;
Private | procedure SetItems(Index: Integer; const Val: TgxMaterialLibraryItem);

Properties

Public property Items[Index: Integer]: TgxMaterialLibraryItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Private function GetItems(Index: Integer): TgxMaterialLibraryItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TgxMaterialLibraryItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TgxMaterialLibraryItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MaterialScript: Class TgxMaterialScripter

Class TgxMaterialScripter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MaterialScript

Declaration

type TgxMaterialScripter = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxMaterialScripter

Overview

Fields

Private | FShaderItems: TgxShaderItems;
Private | FMaterialLibraryItems: TgxMaterialLibraryItems;
Private | FAppend: Boolean;
Private | FOverwrite: Boolean;
Private | FScript: TStrings;
Private | FMemo: TMemo;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | Count: Longint;
Private | infini: Longint;
Private | done: Boolean;
Private | NewMat: TgxLibMaterial;
Private | tmpcoords: TgxCoordinates;
Private | tmpcolor: TgxColor;
Private | tmpcoords4: TgxCoordinates4;
Private | tmpstr: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function CheckRepeatDone: Boolean;
Private | function ClassExists(arguement: string): Boolean;
Private | function DeleteSpaces(Value: string): string;
Private | function ExtractValue: string;
Private | function SubstrExists(substr: string): Boolean;
Private | function ValueExists(Value: string): Boolean;
Public | procedure CompileScript;
Private | procedure CheckError;
Private | procedure ExtractColors;
Private | procedure ExtractCoords3;
Private | procedure ExtractCoords4;
Private | procedure SetAppend(const Value: Boolean);
Private | procedure SeTgxMaterialLibraryItems(const Value: TgxMaterialLibraryItems);
Private | procedure SeTgxShaderItems(const Value: TgxShaderItems);
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetMemo(const Value: TMemo);
Private | procedure SetOverwrite(const Value: Boolean);
Private | procedure SetScript(const Value: TStrings);
Private | procedure XBackAmbient;
Private | procedure XBackDiffuse;
Private | procedure XBackEmission;
Private | procedure XBackProperties;
Private | procedure XBackShininess;
Private | procedure XBackSpecular;
Private | procedure XBlankImage;
Private | procedure XBlendingMode;
Private | procedure XCompression;
Private | procedure XEnvColor;
Private | procedure XFacingCulling;
Private | procedure XFilteringQuality;
Private | procedure XFrontAmbient;
Private | procedure XFrontDiffuse;
Private | procedure XFrontEmission;
Private | procedure XFrontProperties;
Private | procedure XFrontShininess;
Private | procedure XFrontSpecular;
Private | procedure XImageAlpha;
Private | procedure XImageBrightness;
Private | procedure XImageClass;
Private | procedure XImageGamma;
Private | procedure XLibMaterialName;
Private | procedure XMagFilter;
Private | procedure XMappingMode;
Private | procedure XMappingSCoordinates;
Private | procedure XMappingTCoordinates;
Private | procedure XMaterial;
Private | procedure XMaterialLibrary;
Private | procedure XMaterialOptions;
Private | procedure XMinFilter;
Private | procedure XName;
Private | procedure XNormalMapScale;
Private | procedure XPersistantImage;
Private | procedure XPictureFileName;
Private | procedure XPictureNX;
Private | procedure XPictureNY;
Private | procedure XPictureNZ;
Private | procedure XPicturePX;
Private | procedure XPicturePY;
Private | procedure XPicturePZ;
Private | procedure XPolygonMode;
Private | procedure XShader;
Private | procedure XTexture;
Private | procedure XTexture2Name;
Private | procedure XTextureFormat;
Private | procedure XTextureMode;
Private | procedure XTextureOffset;
Private | procedure XTextureScale;
Private | procedure XTextureWrap;
Private | procedure ZMaterial;

Properties

Published | property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;
Public | property DebugMemo: TMemo read FMemo write SetMemo;
Published | property MaterialLibraries: TgxMaterialLibraryItems read FMaterialLibraryItems write SeTgxMaterialLibraryItems;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;
Published | property Script: TStrings read FScript write SetScript;
Published | property Shaders: TgxShaderItems read FShaderItems write SeTgxShaderItems;

Description

Fields

Private FShaderItems: TgxShaderItems;

This item has no description.

Private FMaterialLibraryItems: TgxMaterialLibraryItems;

This item has no description.

Private FAppend: Boolean;

This item has no description.

Private FOverwrite: Boolean;

This item has no description.

Private FScript: TStrings;

This item has no description.

Private FMemo: TMemo;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private Count: Longint;

This item has no description.

Private infini: Longint;

This item has no description.

Private done: Boolean;

This item has no description.

Private NewMat: TgxLibMaterial;

This item has no description.

Private tmpcoords: TgxCoordinates;

This item has no description.

Private tmpcolor: TgxColor;

This item has no description.

Private tmpcoords4: TgxCoordinates4;

This item has no description.

Private tmpstr: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function CheckRepeatDone: Boolean;

This item has no description.

Private function ClassExists(arguement: string): Boolean;

This item has no description.

Private function DeleteSpaces(Value: string): string;

This item has no description.

Private function ExtractValue: string;

extraction functions

Private function SubstrExists(substr: string): Boolean;

This item has no description.

Private function ValueExists(Value: string): Boolean;

This item has no description.

Public procedure CompileScript;

This item has no description.

Private procedure CheckError;

error checking

Private procedure ExtractColors;

This item has no description.

Private procedure ExtractCoords3;

This item has no description.

Private procedure ExtractCoords4;

This item has no description.

Private procedure SetAppend(const Value: Boolean);

This item has no description.

Private procedure SeTgxMaterialLibraryItems(const Value: TgxMaterialLibraryItems);

This item has no description.

Private procedure SeTgxShaderItems(const Value: TgxShaderItems);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetMemo(const Value: TMemo);

This item has no description.

Private procedure SetOverwrite(const Value: Boolean);

This item has no description.

Private procedure SetScript(const Value: TStrings);

This item has no description.

Private procedure XBackAmbient;

This item has no description.

Private procedure XBackDiffuse;

This item has no description.

Private procedure XBackEmission;

This item has no description.

Private procedure XBackProperties;

This item has no description.

Private procedure XBackShininess;

This item has no description.

Private procedure XBackSpecular;

This item has no description.

Private procedure XBlankImage;

This item has no description.

Private procedure XBlendingMode;

This item has no description.

Private procedure XCompression;

This item has no description.

Private procedure XEnvColor;

This item has no description.

Private procedure XFacingCulling;

This item has no description.

Private procedure XFilteringQuality;

This item has no description.

Private procedure XFrontAmbient;

This item has no description.

Private procedure XFrontDiffuse;

This item has no description.

Private procedure XFrontEmission;

This item has no description.

Private procedure XFrontProperties;

This item has no description.

Private procedure XFrontShininess;

This item has no description.

Private procedure XFrontSpecular;

This item has no description.

Private procedure XImageAlpha;

This item has no description.

Private procedure XImageBrightness;

This item has no description.

Private procedure XImageClass;

This item has no description.

Private procedure XImageGamma;

This item has no description.

Private procedure XLibMaterialName;

This item has no description.

Private procedure XMagFilter;

This item has no description.

Private procedure XMappingMode;

This item has no description.

Private procedure XMappingSCoordinates;

This item has no description.

Private procedure XMappingTCoordinates;

This item has no description.

Private procedure XMaterial;

internally called scripts for value extraction

Private procedure XMaterialLibrary;

This item has no description.

Private procedure XMaterialOptions;

This item has no description.

Private procedure XMinFilter;

This item has no description.

Private procedure XName;

This item has no description.

Private procedure XNormalMapScale;

This item has no description.

Private procedure XPersistantImage;

This item has no description.

Private procedure XPictureFileName;

This item has no description.

Private procedure XPictureNX;

This item has no description.

Private procedure XPictureNY;

This item has no description.

Private procedure XPictureNZ;

This item has no description.

Private procedure XPicturePX;

This item has no description.

Private procedure XPicturePY;

This item has no description.

Private procedure XPicturePZ;

This item has no description.

Private procedure XPolygonMode;

This item has no description.

Private procedure XShader;

This item has no description.

Private procedure XTexture;

This item has no description.

Private procedure XTexture2Name;

This item has no description.

Private procedure XTextureFormat;

This item has no description.

Private procedure XTextureMode;

This item has no description.

Private procedure XTextureOffset;

This item has no description.

Private procedure XTextureScale;

This item has no description.

Private procedure XTextureWrap;

This item has no description.

Private procedure ZMaterial;

these are our viable scripts

Properties

Published property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;

This item has no description.

Public property DebugMemo: TMemo read FMemo write SetMemo;

This item has no description.

Published property MaterialLibraries: TgxMaterialLibraryItems read FMaterialLibraryItems write SeTgxMaterialLibraryItems;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;

This item has no description.

Published property Script: TStrings read FScript write SetScript;

This item has no description.

Published property Shaders: TgxShaderItems read FShaderItems write SeTgxShaderItems;


GXSysHelp v.2.5: GXS.Mesh

Unit GXS.Mesh

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.OpenGL4
  • System.Classes
  • System.SysUtils
  • GXS.BaseClasses
  • GLScene.VectorTypes
  • GLScene.Strings
  • GLScene.VectorGeometry
  • GXS.Color
  • GXS.State
  • GXS.Context
  • GXS.Scene
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxVertexData |
Class TgxVertexList |
Class TgxMesh |

Types

PgxVertexData = ˆTgxVertexData;
PVKVertexDataArray = ˆTgxVertexDataArray;
TgxVertexDataArray = array[0..(MAXINT shr 6)] of TgxVertexData;
TMeshMode = (...);
TVertexMode = (...);

Constants

cMeshModeToGLEnum: array[Low(TMeshMode)..High(TMeshMode) ] of GLEnum = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);
cVertexModeToGLEnum: array[Low(TVertexMode)..High(TVertexMode) ] of GLEnum = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);

Description

Types

PgxVertexData = ˆTgxVertexData;

This item has no description.

PVKVertexDataArray = ˆTgxVertexDataArray;

This item has no description.

TgxVertexDataArray = array[0..(MAXINT shr 6)] of TgxVertexData;

This item has no description.

TMeshMode = (...);

wglAllocateMemoryNV

Values
  • mmTriangleStrip
  • mmTriangleFan
  • mmTriangles
  • mmQuadStrip
  • mmQuads
  • mmPolygon
TVertexMode = (...);

This item has no description.

Values
  • vmV
  • vmVN
  • vmVNC
  • vmVNCT
  • vmVNT
  • vmVT

Constants

cMeshModeToGLEnum: array[Low(TMeshMode)..High(TMeshMode) ] of GLEnum = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);

This item has no description.

cVertexModeToGLEnum: array[Low(TVertexMode)..High(TVertexMode) ] of GLEnum = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);


GXSysHelp v.2.5: GXS.Mesh: Packed Record TgxVertexData

Packed Record TgxVertexData

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Mesh

Declaration

type TgxVertexData = packed record

Description

This item has no description.

Overview

Fields

Public | textCoord: TTexPoint;
Public | color: TVector4f;
Public | normal: TAffineVector;
Public | coord: TVertex;

Description

Fields

Public textCoord: TTexPoint;

This item has no description.

Public color: TVector4f;

This item has no description.

Public normal: TAffineVector;

This item has no description.

Public coord: TVertex;


GXSysHelp v.2.5: GXS.Mesh: Class TgxVertexList

Class TgxVertexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Mesh

Declaration

type TgxVertexList = class(TgxUpdateAbleObject)

Description

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.

Hierarchy

  • TgxUpdateAbleObject
  • TgxVertexList

Overview

Fields

Private | FValues: PVKVertexDataArray;
Private | FCount: Integer;
Private | FCapacity: Integer;
Private | FGrowth: Integer;
Private | FLockedOldValues: PVKVertexDataArray;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function CreateInterpolatedCoords(list2: TgxVertexList; lerpFactor: Single): TgxVertexList;
Public | function SumVertexCoords: TAffineVector;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TgxColorVector); overload;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;
Public | procedure AddVertex(const vertexData: TgxVertexData); overload;
Public | procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TgxColorVector; const aTexPoint: TTexPoint); overload;
Public | procedure AddVertex3(const vd1, vd2, vd3: TgxVertexData); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure DefineOpenGLArrays;
Public | procedure DuplicateVertex(index: Integer);
Public | procedure EnterLockSection;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure LeaveLockSection;
Public | procedure NormalizeNormals;
Public | procedure Translate(const v: TAffineVector);

Properties

Public | property Capacity: Integer read FCapacity write SetCapacity;
Public | property Count: Integer read FCount;
Public | property FirstColor: PGLFloat read GetFirstColor;
Public | property FirstEntry: PGLFloat read GetFirstEntry;
Public | property FirstNormal: PGLFloat read GetFirstNormal;
Public | property FirstTexPoint: PGLFloat read GetFirstTexPoint;
Public | property FirstVertex: PGLFloat read GetFirstVertex;
Public | property Growth: Integer read FGrowth write SetGrowth;
Public | property Locked: Boolean read GetLocked write SetLocked;
Public | property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;
Public | property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;
Public | property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;
Public | property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;
Public | property Vertices[index: Integer]: TgxVertexData read GetVertices write SetVertices;

Description

Fields

Private FValues: PVKVertexDataArray;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FCapacity: Integer;

This item has no description.

Private FGrowth: Integer;

This item has no description.

Private FLockedOldValues: PVKVertexDataArray;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateInterpolatedCoords(list2: TgxVertexList; lerpFactor: Single): TgxVertexList;

This item has no description.

Public function SumVertexCoords: TAffineVector;

Calculates the sum of all vertex coords

Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TgxColorVector); overload;

Adds a vertex to the list, no texturing version.

Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;

Adds a vertex to the list, no texturing, not color version.

Public procedure AddVertex(const vertexData: TgxVertexData); overload;

Adds a vertex to the list, fastest method.

Public procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TgxColorVector; const aTexPoint: TTexPoint); overload;

Adds a vertex to the list. Use the NullVector, NullHmgVector or NullTexPoint constants for params you don't want to set.

Public procedure AddVertex3(const vd1, vd2, vd3: TgxVertexData); overload;

Adds a vertex to the list, fastest method for adding a triangle.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure DefineOpenGLArrays;

This item has no description.

Public procedure DuplicateVertex(index: Integer);

Duplicates the vertex of given index and adds it at the end of the list.

Public procedure EnterLockSection;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

Calculates the extents of the vertice coords.

Public procedure LeaveLockSection;

This item has no description.

Public procedure NormalizeNormals;

Normalizes all normals.

Public procedure Translate(const v: TAffineVector);

Translate all coords by given vector

Properties

Public property Capacity: Integer read FCapacity write SetCapacity;

Capacity of the list (nb of vertex). Use this to allocate memory quickly before calling AddVertex.

Public property Count: Integer read FCount;

This item has no description.

Public property FirstColor: PGLFloat read GetFirstColor;

This item has no description.

Public property FirstEntry: PGLFloat read GetFirstEntry;

This item has no description.

Public property FirstNormal: PGLFloat read GetFirstNormal;

This item has no description.

Public property FirstTexPoint: PGLFloat read GetFirstTexPoint;

This item has no description.

Public property FirstVertex: PGLFloat read GetFirstVertex;

This item has no description.

Public property Growth: Integer read FGrowth write SetGrowth;

Vertex capacity that will be added each time the list needs to grow. default value is 256 (chunks of approx 13 kb).

Public property Locked: Boolean read GetLocked write SetLocked;

Locking state of the vertex list. You can "Lock" a list to increase rendering performance on some OpenGL implementations (NVidia's). A Locked list size shouldn't be changed and calculations should be avoided. Performance can only be gained from a lock for osDirectDraw object, ie. meshes that are updated for each frame (the default build list mode is faster on static meshes). Be aware that the "Locked" state enforcement is not very strict to avoid performance hits, and GXScene may not always notify you that you're doing things you shouldn't on a locked list!

Public property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;

This item has no description.

Public property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;

This item has no description.

Public property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;

This item has no description.

Public property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;

This item has no description.

Public property Vertices[index: Integer]: TgxVertexData read GetVertices write SetVertices;


GXSysHelp v.2.5: GXS.Mesh: Class TgxMesh

Class TgxMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Mesh

Declaration

type TgxMesh = class(TgxSceneObject)

Description

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMesh

Overview

Fields

Private | FVertices: TgxVertexList;
Private | FMode: TMeshMode;
Private | FVertexMode: TVertexMode;
Private | FAxisAlignedDimensionsCache: TVector4f;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure CalcNormals(Frontface: TgxFaceWinding);
Public | procedure StructureChanged; override;

Properties

Published | property Mode: TMeshMode read FMode write SetMode;
Published | property VertexMode: TVertexMode read FVertexMode write SetVertexMode default vmVNCT;
Public | property Vertices: TgxVertexList read FVertices write SetVertices;

Description

Fields

Private FVertices: TgxVertexList;

This item has no description.

Private FMode: TMeshMode;

This item has no description.

Private FVertexMode: TVertexMode;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CalcNormals(Frontface: TgxFaceWinding);

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Mode: TMeshMode read FMode write SetMode;

This item has no description.

Published property VertexMode: TVertexMode read FVertexMode write SetVertexMode default vmVNCT;

This item has no description.

Public property Vertices: TgxVertexList read FVertices write SetVertices;


GXSysHelp v.2.5: GXS.MeshBuilder

Unit GXS.MeshBuilder

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • GXS.Scene
  • GXS.VectorFileObjects
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists

Overview

Functions and Procedures

procedure BuildCube(Mesh: TgxMeshObject; Position, Scale: TAffineVector);
procedure BuildCylinder(Mesh: TgxMeshObject; Position, Scale: TAffineVector; Slices: Integer);
procedure BuildCylinder2(Mesh: TgxMeshObject; Position, Scale: TAffineVector; TopRadius, BottomRadius, Height: single; Slices: Integer);

Description

Functions and Procedures

procedure BuildCube(Mesh: TgxMeshObject; Position, Scale: TAffineVector);

This item has no description.

procedure BuildCylinder(Mesh: TgxMeshObject; Position, Scale: TAffineVector; Slices: Integer);

This item has no description.

procedure BuildCylinder2(Mesh: TgxMeshObject; Position, Scale: TAffineVector; TopRadius, BottomRadius, Height: single; Slices: Integer);


GXSysHelp v.2.5: GXS.MeshCSG

Unit GXS.MeshCSG

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • System.Math
  • GXS.Scene
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GLScene.VectorGeometry
  • GXS.BSP
  • GXS.VectorLists

Overview

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TgxMeshObject; Operation: TCSGOperation; Res: TgxMeshObject; const MaterialName1, MaterialName2: string);

Types

TCSGOperation = (...);

Description

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TgxMeshObject; Operation: TCSGOperation; Res: TgxMeshObject; const MaterialName1, MaterialName2: string);

This item has no description.

Types

TCSGOperation = (...);

This item has no description.

Values
  • CSG_Union
  • CSG_Subtraction
  • CSG_Intersection


GXSysHelp v.2.5: GXS.MeshLines

Unit GXS.MeshLines

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.Spline
  • GXS.Scene
  • GXS.Objects
  • GXS.Texture
  • GXS.VectorFileObjects
  • GXS.Coordinates
  • GXS.Context
  • GXS.Material
  • GXS.Color
  • GXS.State
  • GXS.Nodes
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLineNode |
Class TLineNodes |
Class TLineItem |
Class TLineCollection |
Class TLightmapBounds |
Class TgxMeshLines |


GXSysHelp v.2.5: GXS.MeshLines: Class TLineNode

Class TLineNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TLineNode = class(TgxNode)

Description

Specialized Node for use in a TgxLines objects. Adds a Width property

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNode
  • TLineNode

Overview

Fields

Private FData: Pointer;

Methods

Public | constructor Create(Collection : TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public property Data: Pointer read FData write FData;

Description

Fields

Private FData: Pointer;

This item has no description.

Methods

Public constructor Create(Collection : TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Data: Pointer read FData write FData;


GXSysHelp v.2.5: GXS.MeshLines: Class TLineNodes

Class TLineNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TLineNodes = class(TgxNodes)

Description

Specialized collection for Nodes in TgxMeshLines objects. Stores TLineNode items.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxNodes
  • TLineNodes

Overview

Methods

Public | constructor Create(AOwner : TComponent); overload;
Public | destructor destroy; override;
Public | function IndexOf(LineNode: TLineNode): Integer;
Public | procedure NotifyChange; override;

Description

Methods

Public constructor Create(AOwner : TComponent); overload;

This item has no description.

Public destructor destroy; override;

This item has no description.

Public function IndexOf(LineNode: TLineNode): Integer;

This item has no description.

Public procedure NotifyChange; override;


GXSysHelp v.2.5: GXS.MeshLines: Class TLineItem

Class TLineItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TLineItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TLineItem

Overview

Fields

Private | FName: String;
Private | FBreakAngle: Single;
Private | FDivision: Integer;
Private | FNodes: TLineNodes;
Private | FSplineMode: TgxLineSplineMode;
Private | FTextureLength: Single;
Private | FWidth: Single;
Private | FTextureCorrection: Boolean;
Private | FHide: Boolean;
Private | FData: Pointer;

Methods

Published | constructor Create(Collection: TCollection); override;
Published | destructor Destroy; override;
Private | procedure SetBreakAngle(const Value: Single);
Private | procedure SetDivision(const Value: Integer);
Private | procedure SetHide(const Value: Boolean);
Private | procedure SetNodes(const Value: TLineNodes);
Private | procedure SetSplineMode(const Value:TgxLineSplineMode);
Private | procedure SetTextureCorrection(const Value: Boolean);
Private | procedure SetTextureLength(const Value: Single);
Private | procedure SetWidth(const Value: Single);

Properties

Published | property BreakAngle: Single read FBreakAngle write SetBreakAngle;
Public | property Data: Pointer read FData write FData;
Published | property Division: Integer read FDivision write SetDivision;
Published | property Hide: Boolean read FHide write SetHide;
Published | property Name: String read FName write FName;
Published | property Nodes : TLineNodes read FNodes write SetNodes;
Published | property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode;
Published | property TextureCorrection: Boolean read FTextureCorrection write SetTextureCorrection;
Published | property TextureLength: Single read FTextureLength write SetTextureLength;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FName: String;

This item has no description.

Private FBreakAngle: Single;

This item has no description.

Private FDivision: Integer;

This item has no description.

Private FNodes: TLineNodes;

This item has no description.

Private FSplineMode: TgxLineSplineMode;

This item has no description.

Private FTextureLength: Single;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FTextureCorrection: Boolean;

This item has no description.

Private FHide: Boolean;

This item has no description.

Private FData: Pointer;

This item has no description.

Methods

Published constructor Create(Collection: TCollection); override;

This item has no description.

Published destructor Destroy; override;

This item has no description.

Private procedure SetBreakAngle(const Value: Single);

This item has no description.

Private procedure SetDivision(const Value: Integer);

This item has no description.

Private procedure SetHide(const Value: Boolean);

This item has no description.

Private procedure SetNodes(const Value: TLineNodes);

This item has no description.

Private procedure SetSplineMode(const Value:TgxLineSplineMode);

This item has no description.

Private procedure SetTextureCorrection(const Value: Boolean);

This item has no description.

Private procedure SetTextureLength(const Value: Single);

This item has no description.

Private procedure SetWidth(const Value: Single);

This item has no description.

Properties

Published property BreakAngle: Single read FBreakAngle write SetBreakAngle;

This item has no description.

Public property Data: Pointer read FData write FData;

This item has no description.

Published property Division: Integer read FDivision write SetDivision;

This item has no description.

Published property Hide: Boolean read FHide write SetHide;

This item has no description.

Published property Name: String read FName write FName;

This item has no description.

Published property Nodes : TLineNodes read FNodes write SetNodes;

This item has no description.

Published property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode;

This item has no description.

Published property TextureCorrection: Boolean read FTextureCorrection write SetTextureCorrection;

This item has no description.

Published property TextureLength: Single read FTextureLength write SetTextureLength;

This item has no description.

Published property Width: Single read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.MeshLines: Class TLineCollection

Class TLineCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TLineCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TLineCollection

Overview

Methods

Public | function Add: TLineItem; overload;
Public | function Add(Name: String): TLineItem; overload;
Private | function GetItems(Index: Integer): TLineItem;
Private | procedure SetItems(Index: Integer; const Val: TLineItem);

Properties

Public property Items[Index: Integer]: TLineItem read GetItems write SetItems;

Description

Methods

Public function Add: TLineItem; overload;

This item has no description.

Public function Add(Name: String): TLineItem; overload;

This item has no description.

Private function GetItems(Index: Integer): TLineItem;

This item has no description.

Private procedure SetItems(Index: Integer; const Val: TLineItem);

This item has no description.

Properties

Public property Items[Index: Integer]: TLineItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MeshLines: Class TLightmapBounds

Class TLightmapBounds

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TLightmapBounds = class(TgxCustomCoordinates)

Description

This item has no description.

Hierarchy

  • TgxCustomCoordinates
  • TLightmapBounds

Overview

Methods

Private | function GetBottom: Single;
Private | function GetHeight: Single;
Private | function GetLeft: Single;
Private | function GetRight: Single;
Private | function GetTop: Single;
Private | function GetWidth: Single;
Private | procedure SetBottom(const value: Single);
Private | procedure SetLeft(const value: Single);
Private | procedure SetRight(const value: Single);
Private | procedure SetTop(const value: Single);

Properties

Published | property Bottom: Single read GetBottom write SetBottom stored False;
Published | property Height: Single read GetHeight;
Published | property Left: Single read GetLeft write SetLeft stored False;
Published | property Right: Single read GetRight write SetRight stored False;
Published | property Top: Single read GetTop write SetTop stored False;
Published | property Width: Single read GetWidth;

Description

Methods

Private function GetBottom: Single;

This item has no description.

Private function GetHeight: Single;

This item has no description.

Private function GetLeft: Single;

This item has no description.

Private function GetRight: Single;

This item has no description.

Private function GetTop: Single;

This item has no description.

Private function GetWidth: Single;

This item has no description.

Private procedure SetBottom(const value: Single);

This item has no description.

Private procedure SetLeft(const value: Single);

This item has no description.

Private procedure SetRight(const value: Single);

This item has no description.

Private procedure SetTop(const value: Single);

This item has no description.

Properties

Published property Bottom: Single read GetBottom write SetBottom stored False;

This item has no description.

Published property Height: Single read GetHeight;

This item has no description.

Published property Left: Single read GetLeft write SetLeft stored False;

This item has no description.

Published property Right: Single read GetRight write SetRight stored False;

This item has no description.

Published property Top: Single read GetTop write SetTop stored False;

This item has no description.

Published property Width: Single read GetWidth;


GXSysHelp v.2.5: GXS.MeshLines: Class TgxMeshLines

Class TgxMeshLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MeshLines

Declaration

type TgxMeshLines = class(TgxFreeForm)

Description

This item has no description. Showing description inherited from TgxFreeForm.

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxFreeForm
  • TgxMeshLines

Overview

Fields

Private | FLines: TLineCollection;
Private | FMesh: TgxMeshObject;
Private | FLightmapBounds: TLightmapBounds;
Private | FLightmapIndex: Integer;
Private | FLightmapMaterialName: String;
Private | FFaceGroup: TgxFGVertexIndexList;
Private | FIndex: Integer;
Private | FNoZWrite: boolean;
Private | FShowNodes: Boolean;
Private | FUpdating: Integer;
Private | FSelectedLineItem: TLineItem;
Private | FSelectedNode: TLineNode;
Private | FNode1: TLineNode;
Private | FNode2: TLineNode;

Methods

Published | constructor Create(AOwner: TComponent); override;
Published | destructor Destroy; override;
Public | function SelectLineItem(LineItem: TLineItem): TLineItem; overload;
Public | function SelectLineItem(const X,Z: Single; Tolerance: single = 1): TLineItem; overload;
Public | function SelectLineItem(LineNode: TLineNode): TLineItem; overload;
Private | function GetUpdating: Boolean;
Private | function PointNearLine(const LineItem: TLineItem; const X,Z: Single; Tolerance: single = 1): boolean;
Private | function PointNearSegment(const StartNode, EndNode: TLineNode; const X,Z: Single; LineWidth: single; Tolerance: single = 1): boolean;
Private | function SelectNode(LineItem: TLineItem; X,Z: Single):TLineNode;
Public | procedure BeginUpdate;
Public | procedure BuildList(var rci : TgxRenderContextInfo); override;
Public | procedure Clear;
Public | procedure DeselectLineItem;
Public | procedure DeselectLineNode;
Public | procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender : TObject); override;
Private | procedure AddIndex;
Private | procedure AddStitchMarker(idx: TgxIntegerList);
Private | procedure AddVertices(Up, Inner, Outer: TAffineVector; S: Single; Correction: Single; UseDegenerate: Boolean; LineItem: TLineItem);
Private | procedure BuildGeometry;
Private | procedure BuildLineItem(LineItem: TLineItem);
Private | procedure DoChanged;
Private | procedure DrawCircle(Radius: Single);
Private | procedure DrawNode(var rci : TgxRenderContextInfo; Node: TLineNode; LineWidth: Single);
Private | procedure SetLightmapBounds(const value: TLightmapBounds);
Private | procedure SetLightmapIndex(const value: Integer);
Private | procedure SetLightmapMaterialName(const value: String);
Private | procedure SetNoZWrite(const Value: Boolean);
Private | procedure SetShowNodes(const Value: Boolean);
Private | procedure StitchStrips(idx: TgxIntegerList);

Properties

Published | property LightmapBounds: TLightmapBounds read FLightmapBounds write SetLightmapBounds;
Published | property LightmapIndex: Integer read FLightmapIndex write SetLightmapIndex;
Published | property LightmapMaterialName: String read FLightmapMaterialName write SetLightmapMaterialName;
Published | property Lines: TLineCollection read FLines;
Published | property Material;
Public | property Node1: TLineNode read FNode1;
Public | property Node2: TLineNode read FNode2;
Published | property NoZWrite: boolean read FNoZWrite write SetNoZWrite;
Public | property SelectedLineItem: TLineItem read FSelectedLineItem;
Public | property SelectedNode: TLineNode read FSelectedNode;
Published | property ShowNodes: Boolean read FSHowNodes write SetShowNodes;
Published | property Updating: Boolean Read GetUpdating;

Description

Fields

Private FLines: TLineCollection;

This item has no description.

Private FMesh: TgxMeshObject;

This item has no description.

Private FLightmapBounds: TLightmapBounds;

This item has no description.

Private FLightmapIndex: Integer;

This item has no description.

Private FLightmapMaterialName: String;

This item has no description.

Private FFaceGroup: TgxFGVertexIndexList;

This item has no description.

Private FIndex: Integer;

This item has no description.

Private FNoZWrite: boolean;

This item has no description.

Private FShowNodes: Boolean;

This item has no description.

Private FUpdating: Integer;

This item has no description.

Private FSelectedLineItem: TLineItem;

This item has no description.

Private FSelectedNode: TLineNode;

This item has no description.

Private FNode1: TLineNode;

This item has no description.

Private FNode2: TLineNode;

This item has no description.

Methods

Published constructor Create(AOwner: TComponent); override;

This item has no description.

Published destructor Destroy; override;

This item has no description.

Public function SelectLineItem(LineItem: TLineItem): TLineItem; overload;

This item has no description.

Public function SelectLineItem(const X,Z: Single; Tolerance: single = 1): TLineItem; overload;

This item has no description.

Public function SelectLineItem(LineNode: TLineNode): TLineItem; overload;

This item has no description.

Private function GetUpdating: Boolean;

This item has no description.

Private function PointNearLine(const LineItem: TLineItem; const X,Z: Single; Tolerance: single = 1): boolean;

This item has no description.

Private function PointNearSegment(const StartNode, EndNode: TLineNode; const X,Z: Single; LineWidth: single; Tolerance: single = 1): boolean;

This item has no description.

Private function SelectNode(LineItem: TLineItem; X,Z: Single):TLineNode;

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure BuildList(var rci : TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure Clear;

This item has no description.

Public procedure DeselectLineItem;

This item has no description.

Public procedure DeselectLineNode;

This item has no description.

Public procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure NotifyChange(Sender : TObject); override;

This item has no description.

Private procedure AddIndex;

This item has no description.

Private procedure AddStitchMarker(idx: TgxIntegerList);

This item has no description.

Private procedure AddVertices(Up, Inner, Outer: TAffineVector; S: Single; Correction: Single; UseDegenerate: Boolean; LineItem: TLineItem);

This item has no description.

Private procedure BuildGeometry;

This item has no description.

Private procedure BuildLineItem(LineItem: TLineItem);

This item has no description.

Private procedure DoChanged;

This item has no description.

Private procedure DrawCircle(Radius: Single);

This item has no description.

Private procedure DrawNode(var rci : TgxRenderContextInfo; Node: TLineNode; LineWidth: Single);

This item has no description.

Private procedure SetLightmapBounds(const value: TLightmapBounds);

This item has no description.

Private procedure SetLightmapIndex(const value: Integer);

This item has no description.

Private procedure SetLightmapMaterialName(const value: String);

This item has no description.

Private procedure SetNoZWrite(const Value: Boolean);

This item has no description.

Private procedure SetShowNodes(const Value: Boolean);

This item has no description.

Private procedure StitchStrips(idx: TgxIntegerList);

This item has no description.

Properties

Published property LightmapBounds: TLightmapBounds read FLightmapBounds write SetLightmapBounds;

This item has no description.

Published property LightmapIndex: Integer read FLightmapIndex write SetLightmapIndex;

This item has no description.

Published property LightmapMaterialName: String read FLightmapMaterialName write SetLightmapMaterialName;

This item has no description.

Published property Lines: TLineCollection read FLines;

This item has no description.

Published property Material;

This item has no description.

Public property Node1: TLineNode read FNode1;

This item has no description.

Public property Node2: TLineNode read FNode2;

This item has no description.

Published property NoZWrite: boolean read FNoZWrite write SetNoZWrite;

This item has no description.

Public property SelectedLineItem: TLineItem read FSelectedLineItem;

This item has no description.

Public property SelectedNode: TLineNode read FSelectedNode;

This item has no description.

Published property ShowNodes: Boolean read FSHowNodes write SetShowNodes;

This item has no description.

Published property Updating: Boolean Read GetUpdating;


GXSysHelp v.2.5: GXS.MeshOptimizer

Unit GXS.MeshOptimizer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • GXS.PersistentClasses
  • GXS.VectorLists
  • GXS.MeshUtils

Overview

Functions and Procedures

procedure OptimizeMesh(aList : TgxMeshObjectList; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aList : TgxMeshObjectList); overload;
procedure OptimizeMesh(aMeshObject : TgxMeshObject; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aMeshObject : TgxMeshObject); overload;
procedure FacesSmooth(aMeshObj: TgxMeshObject; aWeldDistance: Single=0.0000001; aThreshold: Single=35.0; InvertNormals:boolean=false);

Types

TMeshOptimizerOption = (...);
TMeshOptimizerOptions = set of TMeshOptimizerOption;

Variables

vDefaultMeshOptimizerOptions: TMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];

Description

Functions and Procedures

procedure OptimizeMesh(aList : TgxMeshObjectList; options : TMeshOptimizerOptions); overload;

This item has no description.

procedure OptimizeMesh(aList : TgxMeshObjectList); overload;

This item has no description.

procedure OptimizeMesh(aMeshObject : TgxMeshObject; options : TMeshOptimizerOptions); overload;

This item has no description.

procedure OptimizeMesh(aMeshObject : TgxMeshObject); overload;

This item has no description.

procedure FacesSmooth(aMeshObj: TgxMeshObject; aWeldDistance: Single=0.0000001; aThreshold: Single=35.0; InvertNormals:boolean=false);

This item has no description.

Types

TMeshOptimizerOption = (...);

This item has no description.

Values
  • mooStandardize
  • mooVertexCache
  • mooSortByMaterials
  • mooMergeObjects
TMeshOptimizerOptions = set of TMeshOptimizerOption;

This item has no description.

Variables

vDefaultMeshOptimizerOptions: TMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];


GXSysHelp v.2.5: GXS.MeshUtils

Unit GXS.MeshUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GXS.PersistentClasses
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Functions and Procedures

procedure ConvertStripToList(const strip: TgxAffineVectorList; list: TgxAffineVectorList); overload;
procedure ConvertStripToList(const strip: TgxIntegerList; list: TgxIntegerList); overload;
procedure ConvertStripToList(const strip: TgxAffineVectorList; const indices: TgxIntegerList; list: TgxAffineVectorList); overload;
function ConvertStripToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLongWordList; overload;
function ConvertFansToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLongWordList;
procedure ConvertIndexedListToList(const data: TgxAffineVectorList; const indices: TgxIntegerList; list: TgxAffineVectorList);
function BuildVectorCountOptimizedIndices(const vertices: TgxAffineVectorList; const normals: TgxAffineVectorList = nil; const texCoords: TgxAffineVectorList = nil): TgxIntegerList;
procedure RemapReferences(reference: TgxAffineVectorList; const indices: TgxIntegerList); overload;
procedure RemapReferences(reference: TgxIntegerList; const indices: TgxIntegerList); overload;
procedure RemapAndCleanupReferences(reference: TgxAffineVectorList; indices: TgxIntegerList);
function RemapIndicesToIndicesMap(remapIndices: TgxIntegerList): TgxIntegerList;
procedure RemapTrianglesIndices(indices, indicesMap: TgxIntegerList);
procedure remapIndices(indices, indicesMap: TgxIntegerList);
procedure UnifyTrianglesWinding(indices: TgxIntegerList);
procedure InvertTrianglesWinding(indices: TgxIntegerList);
function BuildNormals(reference: TgxAffineVectorList; indices: TgxIntegerList) : TgxAffineVectorList;
function BuildNonOrientedEdgesList(triangleIndices: TgxIntegerList; triangleEdges: TgxIntegerList = nil; edgesTriangles: TgxIntegerList = nil) : TgxIntegerList;
procedure WeldVertices(vertices: TgxAffineVectorList; indicesMap: TgxIntegerList; weldRadius: Single);
function StripifyMesh(indices: TgxIntegerList; maxVertexIndex: Integer; agglomerateLoneTriangles: Boolean = False): TgxPersistentObjectList;
procedure IncreaseCoherency(indices: TgxIntegerList; cacheSize: Integer);
procedure SubdivideTriangles(smoothFactor: Single; vertices: TgxAffineVectorList; triangleIndices: TgxIntegerList; normals: TgxAffineVectorList = nil; onSubdivideEdge: TSubdivideEdgeEvent = nil);
function MakeTriangleAdjacencyList(const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TGLongWordList;

Types

TSubdivideEdgeEvent = procedure(const idxA, idxB, newIdx: Integer); register;

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;
vEdgeInfoReserveSize: LongWord = 64;

Description

Functions and Procedures

procedure ConvertStripToList(const strip: TgxAffineVectorList; list: TgxAffineVectorList); overload;

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

procedure ConvertStripToList(const strip: TgxIntegerList; list: TgxIntegerList); overload;

This item has no description.

procedure ConvertStripToList(const strip: TgxAffineVectorList; const indices: TgxIntegerList; list: TgxAffineVectorList); overload;

This item has no description.

function ConvertStripToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLongWordList; overload;

This item has no description.

function ConvertFansToList(const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TGLongWordList;

This item has no description.

procedure ConvertIndexedListToList(const data: TgxAffineVectorList; const indices: TgxIntegerList; list: TgxAffineVectorList);

Expands an indexed structure into a non-indexed structure.

function BuildVectorCountOptimizedIndices(const vertices: TgxAffineVectorList; const normals: TgxAffineVectorList = nil; const texCoords: TgxAffineVectorList = nil): TgxIntegerList;

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

procedure RemapReferences(reference: TgxAffineVectorList; const indices: TgxIntegerList); overload;

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

procedure RemapReferences(reference: TgxIntegerList; const indices: TgxIntegerList); overload;

This item has no description.

procedure RemapAndCleanupReferences(reference: TgxAffineVectorList; indices: TgxIntegerList);

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

function RemapIndicesToIndicesMap(remapIndices: TgxIntegerList): TgxIntegerList;

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)

procedure RemapTrianglesIndices(indices, indicesMap: TgxIntegerList);

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure remapIndices(indices, indicesMap: TgxIntegerList);

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure UnifyTrianglesWinding(indices: TgxIntegerList);

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

procedure InvertTrianglesWinding(indices: TgxIntegerList);

Inverts the triangles winding (vertex order).

function BuildNormals(reference: TgxAffineVectorList; indices: TgxIntegerList) : TgxAffineVectorList;

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.

function BuildNonOrientedEdgesList(triangleIndices: TgxIntegerList; triangleEdges: TgxIntegerList = nil; edgesTriangles: TgxIntegerList = nil) : TgxIntegerList;

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.

procedure WeldVertices(vertices: TgxAffineVectorList; indicesMap: TgxIntegerList; weldRadius: Single);

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

function StripifyMesh(indices: TgxIntegerList; maxVertexIndex: Integer; agglomerateLoneTriangles: Boolean = False): TgxPersistentObjectList;

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TgxIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

procedure IncreaseCoherency(indices: TgxIntegerList; cacheSize: Integer);

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

procedure SubdivideTriangles(smoothFactor: Single; vertices: TgxAffineVectorList; triangleIndices: TgxIntegerList; normals: TgxAffineVectorList = nil; onSubdivideEdge: TSubdivideEdgeEvent = nil);

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.

function MakeTriangleAdjacencyList(const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TGLongWordList;

Create list of indices of triangles with adjacency from triangle list

Types

TSubdivideEdgeEvent = procedure(const idxA, idxB, newIdx: Integer); register;

This item has no description.

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;

This item has no description.

vEdgeInfoReserveSize: LongWord = 64;


GXSysHelp v.2.5: GXS.Mirror

Unit GXS.Mirror

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.XCollection
  • GXS.PersistentClasses
  • GXS.Scene
  • GLScene.PipelineTransform
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Material
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMirror |

Types

TMirrorOption = (...);
TMirrorOptions = set of TMirrorOption;
TMirrorShapes = (...);

Constants

cDefaultMirrorOptions = [moUseStencil];

Description

Types

TMirrorOption = (...);

This item has no description.

Values
  • moUseStencil
  • moOpaque
  • moMirrorPlaneClip
  • moClearZBuffer
TMirrorOptions = set of TMirrorOption;

This item has no description.

TMirrorShapes = (...);

This item has no description.

Values
  • msRect
  • msDisk

Constants

cDefaultMirrorOptions = [moUseStencil];


GXSysHelp v.2.5: GXS.Mirror: Class TgxMirror

Class TgxMirror

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Mirror

Declaration

type TgxMirror = class(TgxSceneObject)

Description

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMirror

Overview

Fields

Private | FRendering: Boolean;
Private | FMirrorObject: TgxBaseSceneObject;
Private | FWidth: Single;
Private | FHeight: Single;
Private | FMirrorOptions: TMirrorOptions;
Private | FOnBeginRenderingMirrors: TNotifyEvent;
Private | FOnEndRenderingMirrors: TNotifyEvent;
Private | FShape: TMirrorShapes;
Private | FRadius: Single;
Private | FSlices: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TgxRenderContextInfo); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Height: Single read FHeight write SetHeight;
Published | property MirrorObject: TgxBaseSceneObject read FMirrorObject write SetMirrorObject;
Published | property MirrorOptions: TMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;
Published | property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;
Published | property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;
Published | property Radius: Single read FRadius write SetRadius;
Published | property Shape: TMirrorShapes read FShape write SetShape default msRect;
Published | property Slices: GLint read FSlices write SetSlices default 16;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FRendering: Boolean;

This item has no description.

Private FMirrorObject: TgxBaseSceneObject;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FMirrorOptions: TMirrorOptions;

This item has no description.

Private FOnBeginRenderingMirrors: TNotifyEvent;

This item has no description.

Private FOnEndRenderingMirrors: TNotifyEvent;

This item has no description.

Private FShape: TMirrorShapes;

This item has no description.

Private FRadius: Single;

ORL

Private FSlices: Integer;

ORL

Methods

Public constructor Create(AOwner: TComponent); override;

ORL

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var ARci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property MirrorObject: TgxBaseSceneObject read FMirrorObject write SetMirrorObject;

Selects the object to mirror. If nil, the whole scene is mirrored.

Published property MirrorOptions: TMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;

Controls rendering options. moUseStencil: mirror area is stenciled, prevents reflected objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer) moOpaque: mirror is opaque (ie. painted with background color) moMirrorPlaneClip: a ClipPlane is defined to prevent reflections from popping out of the mirror (for objects behind or halfway through) moClearZBuffer: mirror area's ZBuffer is cleared so that background objects don't interfere with reflected objects (reflected objects must be rendered AFTER the mirror in the hierarchy). Works only along with stenciling.

Published property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;

Fired before the object's mirror images are rendered.

Published property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;

Fired after the object's mirror images are rendered.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Shape: TMirrorShapes read FShape write SetShape default msRect;

ORL

Published property Slices: GLint read FSlices write SetSlices default 16;

ORL

Published property Width: Single read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.Movement

Unit GXS.Movement

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Spline
  • GLScene.Strings
  • GXS.Scene
  • GXS.Objects
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPathNode |
Class TgxPathNodes |
Class TgxMovementPath |
Class TgxMovementPaths |
Class TgxMovement |

Functions and Procedures

function GetMovement(const behaviours: TgxBehaviours): TgxMovement; overload;
function GetMovement(const obj: TgxBaseSceneObject): TgxMovement; overload;
function GetOrCreateMovement(const behaviours: TgxBehaviours): TgxMovement; overload;
function GetOrCreateMovement(const obj: TgxBaseSceneObject): TgxMovement; overload;
procedure StartAllMovements(const Scene: TgxScene; const StartCamerasMove, StartObjectsMove: Boolean);
procedure StopAllMovements(const Scene: TgxScene; const StopCamerasMove, StopObjectsMove: Boolean);

Types

TgxMovementRotationMode = (...);
TPathTravelStartEvent = procedure (Sender: TObject; Path: TgxMovementPath) of object;
TPathTravelStopEvent = procedure (Sender: TObject; Path: TgxMovementPath; var Looped: boolean) of object;

Description

Functions and Procedures

function GetMovement(const behaviours: TgxBehaviours): TgxMovement; overload;

This item has no description.

function GetMovement(const obj: TgxBaseSceneObject): TgxMovement; overload;

This item has no description.

function GetOrCreateMovement(const behaviours: TgxBehaviours): TgxMovement; overload;

This item has no description.

function GetOrCreateMovement(const obj: TgxBaseSceneObject): TgxMovement; overload;

This item has no description.

procedure StartAllMovements(const Scene: TgxScene; const StartCamerasMove, StartObjectsMove: Boolean);

This item has no description.

procedure StopAllMovements(const Scene: TgxScene; const StopCamerasMove, StopObjectsMove: Boolean);

This item has no description.

Types

TgxMovementRotationMode = (...);

This item has no description.

Values
  • rmTurnPitchRoll
  • rmUpDirection
TPathTravelStartEvent = procedure (Sender: TObject; Path: TgxMovementPath) of object;

Event for path related event

TPathTravelStopEvent = procedure (Sender: TObject; Path: TgxMovementPath; var Looped: boolean) of object;


GXSysHelp v.2.5: GXS.Movement: Class TgxPathNode

Class TgxPathNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Movement

Declaration

type TgxPathNode = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxPathNode

Overview

Fields

Private | FPosition: TVector4f;
Private | FScale: TVector4f;
Private | FRotation: TVector4f;
Private | FDirection: TVector4f;
Private | FUp: TVector4f;
Private | FSpeed: single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function EqualNode(const aNode: TgxPathNode): boolean;
Public | function PositionAsAddress: PGLFloat;
Public | function RotationAsAddress: PGLFloat;
Public | function ScaleAsAddress: PGLFloat;
Private | function GetDirectionCoordinate(const Index: Integer): Single;
Private | function GetPositionCoordinate(const Index: Integer): Single;
Private | function GetRotationCoordinate(const Index: Integer): Single;
Private | function GetScaleCoordinate(const Index: Integer): Single;
Private | function GetUpCoordinate(const Index: Integer): Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure InitializeByObject(const Obj: TgxBaseSceneObject);
Private | procedure SetDirectionCoordinate(const Index: integer; const AValue: Single);
Private | procedure SetPositionAsVector(const Value: TVector4f);
Private | procedure SetPositionCoordinate(const Index: integer; const AValue: Single);
Private | procedure SetRotationAsVector(const Value: TVector4f);
Private | procedure SetRotationCoordinate(const Index: integer; const AValue: Single);
Private | procedure SetScaleAsVector(const Value: TVector4f);
Private | procedure SetScaleCoordinate(const Index: integer; const AValue: Single);
Private | procedure SetSpeed(const Value: single);
Private | procedure SetUpCoordinate(const Index: integer; const AValue: Single);

Properties

Public | property DirectionAsVector: TVector4f read FDirection write FDirection;
Published | property DirectionX: Single index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionY: Single index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionZ: Single index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property PitchAngle: Single index 0 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property PositionAsVector: TVector4f Read FPosition Write SetPositionAsVector;
Published | property RollAngle: Single index 2 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property RotationAsVector: TVector4f Read FRotation Write SetRotationAsVector;
Public | property ScaleAsVector: TVector4f Read FScale Write SetScaleAsVector;
Published | property ScaleX: Single index 0 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleY: Single index 1 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleZ: Single index 2 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property Speed: single Read FSpeed Write SetSpeed;
Published | property TurnAngle: Single index 1 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property UpAsVector: TVector4f read FUp write FUp;
Published | property UpX: Single index 0 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpY: Single index 1 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpZ: Single index 2 Read GetUpCoordinate Write SetUpCoordinate;
Published | property X: Single index 0 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Y: Single index 1 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Z: Single index 2 Read GetPositionCoordinate Write SetPositionCoordinate;

Description

Fields

Private FPosition: TVector4f;

This item has no description.

Private FScale: TVector4f;

This item has no description.

Private FRotation: TVector4f;

This item has no description.

Private FDirection: TVector4f;

This item has no description.

Private FUp: TVector4f;

This item has no description.

Private FSpeed: single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function EqualNode(const aNode: TgxPathNode): boolean;

Warning: does not take speed into account.

Public function PositionAsAddress: PGLFloat;

This item has no description.

Public function RotationAsAddress: PGLFloat;

This item has no description.

Public function ScaleAsAddress: PGLFloat;

This item has no description.

Private function GetDirectionCoordinate(const Index: Integer): Single;

This item has no description.

Private function GetPositionCoordinate(const Index: Integer): Single;

This item has no description.

Private function GetRotationCoordinate(const Index: Integer): Single;

This item has no description.

Private function GetScaleCoordinate(const Index: Integer): Single;

This item has no description.

Private function GetUpCoordinate(const Index: Integer): Single;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure InitializeByObject(const Obj: TgxBaseSceneObject);

This item has no description.

Private procedure SetDirectionCoordinate(const Index: integer; const AValue: Single);

This item has no description.

Private procedure SetPositionAsVector(const Value: TVector4f);

This item has no description.

Private procedure SetPositionCoordinate(const Index: integer; const AValue: Single);

This item has no description.

Private procedure SetRotationAsVector(const Value: TVector4f);

This item has no description.

Private procedure SetRotationCoordinate(const Index: integer; const AValue: Single);

This item has no description.

Private procedure SetScaleAsVector(const Value: TVector4f);

This item has no description.

Private procedure SetScaleCoordinate(const Index: integer; const AValue: Single);

This item has no description.

Private procedure SetSpeed(const Value: single);

This item has no description.

Private procedure SetUpCoordinate(const Index: integer; const AValue: Single);

This item has no description.

Properties

Public property DirectionAsVector: TVector4f read FDirection write FDirection;

This item has no description.

Published property DirectionX: Single index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property DirectionY: Single index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property DirectionZ: Single index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;

This item has no description.

Published property PitchAngle: Single index 0 Read GetRotationCoordinate Write SetRotationCoordinate;

Rotation.X means PitchAngle; Rotation.Y means TurnAngle; Rotation.Z means RollAngle;

Public property PositionAsVector: TVector4f Read FPosition Write SetPositionAsVector;

This item has no description.

Published property RollAngle: Single index 2 Read GetRotationCoordinate Write SetRotationCoordinate;

This item has no description.

Public property RotationAsVector: TVector4f Read FRotation Write SetRotationAsVector;

Rotation.X means PitchAngle, Rotation.Y means TurnAngle, Rotation.Z means RollAngle.

Public property ScaleAsVector: TVector4f Read FScale Write SetScaleAsVector;

This item has no description.

Published property ScaleX: Single index 0 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property ScaleY: Single index 1 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property ScaleZ: Single index 2 Read GetScaleCoordinate Write SetScaleCoordinate;

This item has no description.

Published property Speed: single Read FSpeed Write SetSpeed;

This item has no description.

Published property TurnAngle: Single index 1 Read GetRotationCoordinate Write SetRotationCoordinate;

This item has no description.

Public property UpAsVector: TVector4f read FUp write FUp;

This item has no description.

Published property UpX: Single index 0 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property UpY: Single index 1 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property UpZ: Single index 2 Read GetUpCoordinate Write SetUpCoordinate;

This item has no description.

Published property X: Single index 0 Read GetPositionCoordinate Write SetPositionCoordinate;

This item has no description.

Published property Y: Single index 1 Read GetPositionCoordinate Write SetPositionCoordinate;

This item has no description.

Published property Z: Single index 2 Read GetPositionCoordinate Write SetPositionCoordinate;


GXSysHelp v.2.5: GXS.Movement: Class TgxPathNodes

Class TgxPathNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Movement

Declaration

type TgxPathNodes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxPathNodes

Overview

Methods

Public | constructor Create(aOwner: TgxMovementPath);
Public | function Add: TgxPathNode;
Public | function FindItemID(const ID: integer): TgxPathNode;
Public | function GetOwnerMovementPath: TgxMovementPath;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[const index: integer]: TgxPathNode Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TgxMovementPath);

This item has no description.

Public function Add: TgxPathNode;

This item has no description.

Public function FindItemID(const ID: integer): TgxPathNode;

This item has no description.

Public function GetOwnerMovementPath: TgxMovementPath;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[const index: integer]: TgxPathNode Read GetItems Write SetItems;


GXSysHelp v.2.5: GXS.Movement: Class TgxMovementPath

Class TgxMovementPath

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Movement

Declaration

type TgxMovementPath = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxMovementPath

Overview

Fields

Private | FPathLine: TgxLines;
Private | FShowPath: Boolean;
Private | FPathSplineMode: TgxLineSplineMode;
Private | FNodes: TgxPathNodes;
Private | FStartTimeApplied: Boolean;
Private | FStartTime: double;
Private | FInitialTime: Double;
Private | FEstimateTime: double;
Private | FCurrentNode: TgxPathNode;
Private | FInTravel: boolean;
Private | FLooped: boolean;
Private | FName: string;
Private | FRotationMode: TgxMovementRotationMode;
Private | MotionSplineControl: TCubicSpline;
Private | RotationSplineControl: TCubicSpline;
Private | ScaleSplineControl: TCubicSpline;
Private | DirectionSplineControl: TCubicSpline;
Private | UpSplineControl: TCubicSpline;
Private | FOnTravelStart: TNotifyEvent;
Private | FOnTravelStop: TNotifyEvent;
Private | FCurrentNodeIndex: integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function AddNode: TgxPathNode; overload;
Public | function AddNode(const Node: TgxPathNode): TgxPathNode; overload;
Public | function AddNodeFromObject(const Obj: TgxBaseSceneObject): TgxPathNode;
Public | function DeleteNode(const Node: TgxPathNode): TgxPathNode; overload;
Public | function DeleteNode(const Index: integer): TgxPathNode; overload;
Public | function GetMovement: TgxMovement;
Public | function InsertNode(const Index: integer): TgxPathNode; overload;
Public | function InsertNode(const Node: TgxPathNode; const Index: integer): TgxPathNode; overload;
Public | function InsertNodeFromObject(const Obj: TgxBaseSceneObject; const Index: integer): TgxPathNode;
Public | function NextNode: integer;
Public | function NodeDistance(const Node1, Node2: TgxPathNode): double;
Public | function PrevNode: integer;
Private | function GetNodeCount: integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalculateState(const CurrentTime: double);
Public | procedure ClearNodes;
Public | procedure TravelPath(const Start: boolean); overload;
Public | procedure TravelPath(const Start: boolean; const aStartTime: double); overload;
Public | procedure UpdatePathLine;
Private | procedure SetCurrentNodeIndex(const Value: integer);
Private | procedure SetPathSplineMode(const Value: TgxLineSplineMode);
Private | procedure SetShowPath(const Value: Boolean);
Private | procedure SetStartTime(const Value: double);

Properties

Public | property CurrentNode: TgxPathNode Read FCurrentNode;
Public | property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;
Published | property EstimateTime: double Read FEstimateTime;
Public | property InTravel: boolean Read FInTravel;
Published | property Looped: boolean Read FLooped Write FLooped;
Published | property Name: string Read FName Write FName;
Public | property NodeCount: integer Read GetNodeCount;
Published | property Nodes: TgxPathNodes Read FNodes;
Public | property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;
Public | property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;
Published | property PathSplineMode: TgxLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;
Published | property RotationMode: TgxMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;
Published | property ShowPath: Boolean read FShowPath write SetShowPath;
Published | property StartTime: double Read FStartTime Write SetStartTime;

Description

Fields

Private FPathLine: TgxLines;

This item has no description.

Private FShowPath: Boolean;

This item has no description.

Private FPathSplineMode: TgxLineSplineMode;

This item has no description.

Private FNodes: TgxPathNodes;

This item has no description.

Private FStartTimeApplied: Boolean;

All the time saved in ms

Private FStartTime: double;

This item has no description.

Private FInitialTime: Double;

This item has no description.

Private FEstimateTime: double;

This item has no description.

Private FCurrentNode: TgxPathNode;

This item has no description.

Private FInTravel: boolean;

This item has no description.

Private FLooped: boolean;

This item has no description.

Private FName: string;

This item has no description.

Private FRotationMode: TgxMovementRotationMode;

This item has no description.

Private MotionSplineControl: TCubicSpline;

This item has no description.

Private RotationSplineControl: TCubicSpline;

This item has no description.

Private ScaleSplineControl: TCubicSpline;

This item has no description.

Private DirectionSplineControl: TCubicSpline;

This item has no description.

Private UpSplineControl: TCubicSpline;

This item has no description.

Private FOnTravelStart: TNotifyEvent;

This item has no description.

Private FOnTravelStop: TNotifyEvent;

This item has no description.

Private FCurrentNodeIndex: integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNode: TgxPathNode; overload;

This item has no description.

Public function AddNode(const Node: TgxPathNode): TgxPathNode; overload;

This item has no description.

Public function AddNodeFromObject(const Obj: TgxBaseSceneObject): TgxPathNode;

This item has no description.

Public function DeleteNode(const Node: TgxPathNode): TgxPathNode; overload;

This item has no description.

Public function DeleteNode(const Index: integer): TgxPathNode; overload;

This item has no description.

Public function GetMovement: TgxMovement;

This item has no description.

Public function InsertNode(const Index: integer): TgxPathNode; overload;

This item has no description.

Public function InsertNode(const Node: TgxPathNode; const Index: integer): TgxPathNode; overload;

This item has no description.

Public function InsertNodeFromObject(const Obj: TgxBaseSceneObject; const Index: integer): TgxPathNode;

This item has no description.

Public function NextNode: integer;

This item has no description.

Public function NodeDistance(const Node1, Node2: TgxPathNode): double;

This item has no description.

Public function PrevNode: integer;

This item has no description.

Private function GetNodeCount: integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure CalculateState(const CurrentTime: double);

This item has no description.

Public procedure ClearNodes;

This item has no description.

Public procedure TravelPath(const Start: boolean); overload;

This item has no description.

Public procedure TravelPath(const Start: boolean; const aStartTime: double); overload;

This item has no description.

Public procedure UpdatePathLine;

This item has no description.

Private procedure SetCurrentNodeIndex(const Value: integer);

This item has no description.

Private procedure SetPathSplineMode(const Value: TgxLineSplineMode);

This item has no description.

Private procedure SetShowPath(const Value: Boolean);

This item has no description.

Private procedure SetStartTime(const Value: double);

This item has no description.

Properties

Public property CurrentNode: TgxPathNode Read FCurrentNode;

This item has no description.

Public property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;

This item has no description.

Published property EstimateTime: double Read FEstimateTime;

This item has no description.

Public property InTravel: boolean Read FInTravel;

This item has no description.

Published property Looped: boolean Read FLooped Write FLooped;

This item has no description.

Published property Name: string Read FName Write FName;

This item has no description.

Public property NodeCount: integer Read GetNodeCount;

This item has no description.

Published property Nodes: TgxPathNodes Read FNodes;

This item has no description.

Public property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;

This item has no description.

Public property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;

This item has no description.

Published property PathSplineMode: TgxLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;

This property is currently ignored.

Published property RotationMode: TgxMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;

This item has no description.

Published property ShowPath: Boolean read FShowPath write SetShowPath;

This item has no description.

Published property StartTime: double Read FStartTime Write SetStartTime;


GXSysHelp v.2.5: GXS.Movement: Class TgxMovementPaths

Class TgxMovementPaths

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Movement

Declaration

type TgxMovementPaths = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxMovementPaths

Overview

Methods

Public | constructor Create(aOwner: TgxMovement);
Public | function Add: TgxMovementPath;
Public | function FindItemID(const ID: integer): TgxMovementPath;
Public | procedure NotifyChange; virtual;

Properties

Public property Items[const index: integer]: TgxMovementPath Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TgxMovement);

This item has no description.

Public function Add: TgxMovementPath;

This item has no description.

Public function FindItemID(const ID: integer): TgxMovementPath;

This item has no description.

Public procedure NotifyChange; virtual;

This item has no description.

Properties

Public property Items[const index: integer]: TgxMovementPath Read GetItems Write SetItems;


GXSysHelp v.2.5: GXS.Movement: Class TgxMovement

Class TgxMovement

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Movement

Declaration

type TgxMovement = class(TgxBehaviour)

Description

This item has no description. Showing description inherited from TgxBehaviour.

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxMovement

Overview

Fields

Private | FPaths: TgxMovementPaths;
Private | FAutoStartNextPath: boolean;
Private | FActivePathIndex: integer;
Private | FOnAllPathTravelledOver: TNotifyEvent;
Private | FOnPathTravelStart: TPathTravelStartEvent;
Private | FOnPathTravelStop: TPathTravelStopEvent;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddPath(aObject: TgxBaseSceneObject): TgxMovementPath; overload;
Public | function AddPath: TgxMovementPath; overload;
Public | function AddPath(Path: TgxMovementPath): TgxMovementPath; overload;
Public | function DeletePath: TgxMovementPath; overload;
Public | function DeletePath(Index: integer): TgxMovementPath; overload;
Public | function DeletePath(Path: TgxMovementPath): TgxMovementPath; overload;
Public | function FirstPath: integer;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function LastPath: integer;
Public | function NextPath: integer;
Public | function PrevPath: integer;
Public | class function UniqueItem: boolean; override;
Private | function GetActivePath: TgxMovementPath;
Private | function GetPathCount: integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearPaths;
Public | procedure DoProgress(const progressTime : TgxProgressTimes); override;
Public | procedure StartPathTravel;
Public | procedure StopPathTravel;
Private | procedure SetActivePath(Value: TgxMovementPath);
Private | procedure SetActivePathIndex(Value: integer);

Properties

Published | property ActivePath: TgxMovementPath Read GetActivePath Write SetActivePath;
Published | property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;
Published | property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;
Public | property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;
Public | property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;
Public | property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;
Public | property PathCount: integer Read GetPathCount;
Published | property Paths: TgxMovementPaths Read FPaths;

Description

Fields

Private FPaths: TgxMovementPaths;

This item has no description.

Private FAutoStartNextPath: boolean;

This item has no description.

Private FActivePathIndex: integer;

This item has no description.

Private FOnAllPathTravelledOver: TNotifyEvent;

This item has no description.

Private FOnPathTravelStart: TPathTravelStartEvent;

This item has no description.

Private FOnPathTravelStop: TPathTravelStopEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddPath(aObject: TgxBaseSceneObject): TgxMovementPath; overload;

add an path with one node, and the node is based on aObject

Public function AddPath: TgxMovementPath; overload;

add an empty path;

Public function AddPath(Path: TgxMovementPath): TgxMovementPath; overload;

add one path to the new one

Public function DeletePath: TgxMovementPath; overload;

This item has no description.

Public function DeletePath(Index: integer): TgxMovementPath; overload;

This item has no description.

Public function DeletePath(Path: TgxMovementPath): TgxMovementPath; overload;

Result is current path

Public function FirstPath: integer;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function LastPath: integer;

This item has no description.

Public function NextPath: integer;

This item has no description.

Public function PrevPath: integer;

This item has no description.

Public class function UniqueItem: boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Private function GetActivePath: TgxMovementPath;

This item has no description.

Private function GetPathCount: integer;

function GetMovementPath(Index: integer): TgxMovementPath; procedure SetMovementPath(Index: integer; AValue: TgxMovementPath);

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ClearPaths;

This item has no description.

Public procedure DoProgress(const progressTime : TgxProgressTimes); override;

This item has no description.

Public procedure StartPathTravel;

This item has no description.

Public procedure StopPathTravel;

This item has no description.

Private procedure SetActivePath(Value: TgxMovementPath);

This item has no description.

Private procedure SetActivePathIndex(Value: integer);

This item has no description.

Properties

Published property ActivePath: TgxMovementPath Read GetActivePath Write SetActivePath;

This item has no description.

Published property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;

This item has no description.

Published property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;

This item has no description.

Public property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;

why do these property can't be saved in IDE ?

Public property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;

This item has no description.

Public property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;

This item has no description.

Public property PathCount: integer Read GetPathCount;

property Paths[index: Integer]: TgxMovementPath read GetMovementPath write SetMovementPath;

Published property Paths: TgxMovementPaths Read FPaths;


GXSysHelp v.2.5: GXS.MultiMaterialShader

Unit GXS.MultiMaterialShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Material
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMultiMaterialShader |


GXSysHelp v.2.5: GXS.MultiMaterialShader: Class TgxMultiMaterialShader

Class TgxMultiMaterialShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiMaterialShader

Declaration

type TgxMultiMaterialShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxMultiMaterialShader

Overview

Fields

Private | FPass: Integer;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FVisibleAtDesignTime: boolean;
Private | FShaderActiveAtDesignTime: boolean;
Private | FShaderStyle: TgxShaderStyle;

Methods

Public | constructor Create(aOwner: TComponent); override;
Private | procedure SetShaderStyle(const Value: TgxShaderStyle);
Private | procedure SetVisibleAtDesignTime(const Value: boolean);

Properties

Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ShaderStyle: TgxShaderStyle read FShaderStyle write SetShaderStyle;
Published | property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;

Description

Fields

Private FPass: Integer;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FVisibleAtDesignTime: boolean;

This item has no description.

Private FShaderActiveAtDesignTime: boolean;

This item has no description.

Private FShaderStyle: TgxShaderStyle;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Private procedure SetShaderStyle(const Value: TgxShaderStyle);

This item has no description.

Private procedure SetVisibleAtDesignTime(const Value: boolean);

This item has no description.

Properties

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property ShaderStyle: TgxShaderStyle read FShaderStyle write SetShaderStyle;

This item has no description.

Published property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;


GXSysHelp v.2.5: GXS.MultiPolygon

Unit GXS.MultiPolygon

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.XOpenGL
  • GLScene.Spline
  • GXS.Context
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.PersistentClasses
  • GXS.Scene
  • GXS.Objects
  • GXS.GeomObjects
  • GXS.Nodes
  • GXS.BaseClasses
  • GXS.Coordinates
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxContourNodes |
Class TgxContour |
Class TgxContours |
Class TgxPolygonList |
Class TgxMultiPolygonBase |
Class TgxMultiPolygon |

Types

TgxContourClass = class of TgxContour;

Description

Types

TgxContourClass = class of TgxContour;


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxContourNodes

Class TgxContourNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxContourNodes = class(TgxNodes)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxNodes
  • TgxContourNodes

Overview

Methods

Public procedure NotifyChange; override;

Description

Methods

Public procedure NotifyChange; override;


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxContour

Class TgxContour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxContour = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxContour

Overview

Fields

Private | FNodes: TgxContourNodes;
Private | FDivision: Integer;
Private | FSplineMode: TgxLineSplineMode;
Private | FDescription: string;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetDescription(const Value: string);
Private | procedure SetDivision(Value: Integer);
Private | procedure SetNodes(const Value: TgxContourNodes);
Private | procedure SetSplineMode(const Value: TgxLineSplineMode);

Properties

Published | property Description: string read FDescription write SetDescription;
Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TgxContourNodes read FNodes write SetNodes;
Published | property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FNodes: TgxContourNodes;

This item has no description.

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TgxLineSplineMode;

This item has no description.

Private FDescription: string;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetDescription(const Value: string);

This item has no description.

Private procedure SetDivision(Value: Integer);

This item has no description.

Private procedure SetNodes(const Value: TgxContourNodes);

This item has no description.

Private procedure SetSplineMode(const Value: TgxLineSplineMode);

This item has no description.

Properties

Published property Description: string read FDescription write SetDescription;

This item has no description.

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Published property Nodes: TgxContourNodes read FNodes write SetNodes;

The nodes list.

Published property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode. This mode is used only for the curve, not for the rotation path.


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxContours

Class TgxContours

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxContours = class(TGNotifyCollection)

Description

This item has no description.

Hierarchy

  • TGNotifyCollection
  • TgxContours

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | function Add: TgxContour;
Public | function FindItemID(ID: Integer): TgxContour;
Private | function GetItems(index: Integer): TgxContour;
Public | procedure GetExtents(var min, max: TAffineVector);
Private | procedure SetItems(index: Integer; const Value: TgxContour);

Properties

Public property Items[index: Integer]: TgxContour read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;

This item has no description.

Public function Add: TgxContour;

This item has no description.

Public function FindItemID(ID: Integer): TgxContour;

This item has no description.

Private function GetItems(index: Integer): TgxContour;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Private procedure SetItems(index: Integer; const Value: TgxContour);

This item has no description.

Properties

Public property Items[index: Integer]: TgxContour read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxPolygonList

Class TgxPolygonList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxPolygonList = class(TgxPersistentObjectList)

Description

This item has no description.

Hierarchy

  • TgxPersistentObjectList
  • TgxPolygonList

Overview

Fields

Private FAktList: TgxAffineVectorList;

Methods

Private | function GetList(I: Integer): TgxAffineVectorList;
Public | procedure Add;

Properties

Public | property AktList: TgxAffineVectorList read FAktList;
Public | property List[I: Integer]: TgxAffineVectorList read GetList;

Description

Fields

Private FAktList: TgxAffineVectorList;

This item has no description.

Methods

Private function GetList(I: Integer): TgxAffineVectorList;

This item has no description.

Public procedure Add;

This item has no description.

Properties

Public property AktList: TgxAffineVectorList read FAktList;

This item has no description.

Public property List[I: Integer]: TgxAffineVectorList read GetList;


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxMultiPolygonBase

Class TgxMultiPolygonBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxMultiPolygonBase = class(TgxSceneObject)

Description

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TgxMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GXS.VectorLists.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMultiPolygonBase

Overview

Fields

Private | FContours: TgxContours;
Private | FOutline: TgxPolygonList;
Private | FContoursNormal: TAffineVector;
Private | FAxisAlignedDimensionsCache: TVector4f;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Private | function GetOutline: TgxPolygonList;
Private | function GetPath(i: Integer): TgxContourNodes;
Public | procedure AddNode(const i: Integer; const X, Y, Z: Single); overload;
Public | procedure AddNode(const i: Integer; const coords: TgxCoordinates); overload;
Public | procedure AddNode(const i: Integer; const value: TAffineVector); overload;
Public | procedure AddNode(const i: Integer; const value: TVector4f); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure StructureChanged; override;
Private | procedure SetContours(const Value: TgxContours);
Private | procedure SetContoursNormal(const Value: TAffineVector);
Private | procedure SetPath(i: Integer; const value: TgxContourNodes);

Properties

Published | property Contours: TgxContours read FContours write SetContours;
Public | property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;
Public | property Outline: TgxPolygonList read GetOutline;
Public | property Path[i: Integer]: TgxContourNodes read GetPath write SetPath;

Description

Fields

Private FContours: TgxContours;

This item has no description.

Private FOutline: TgxPolygonList;

This item has no description.

Private FContoursNormal: TAffineVector;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

property PNormal:PAffineVector read FPNormal;

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Private function GetOutline: TgxPolygonList;

This item has no description.

Private function GetPath(i: Integer): TgxContourNodes;

This item has no description.

Public procedure AddNode(const i: Integer; const X, Y, Z: Single); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const coords: TgxCoordinates); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const i: Integer; const value: TVector4f); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetContours(const Value: TgxContours);

This item has no description.

Private procedure SetContoursNormal(const Value: TAffineVector);

This item has no description.

Private procedure SetPath(i: Integer; const value: TgxContourNodes);

This item has no description.

Properties

Published property Contours: TgxContours read FContours write SetContours;

This item has no description.

Public property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;

This item has no description.

Public property Outline: TgxPolygonList read GetOutline;

This item has no description.

Public property Path[i: Integer]: TgxContourNodes read GetPath write SetPath;


GXSysHelp v.2.5: GXS.MultiPolygon: Class TgxMultiPolygon

Class TgxMultiPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiPolygon

Declaration

type TgxMultiPolygon = class(TgxMultiPolygonBase)

Description

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMultiPolygonBase
  • TgxMultiPolygon

Overview

Fields

Private FParts: TgxPolygonParts;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published property Parts: TgxPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Fields

Private FParts: TgxPolygonParts;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description. Showing description inherited from TgxMultiPolygonBase.Create.

property PNormal:PAffineVector read FPNormal;

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Parts: TgxPolygonParts read FParts write SetParts default [ppTop, ppBottom];


GXSysHelp v.2.5: GXS.MultiProxy

Unit GXS.MultiProxy

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GXS.Context
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Silhouette
  • GXS.RenderContextInfo
  • GXS.BaseClasses
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMultiProxyMaster |
Class TgxMultiProxyMasters |
Class TgxMultiProxy |


GXSysHelp v.2.5: GXS.MultiProxy: Class TgxMultiProxyMaster

Class TgxMultiProxyMaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiProxy

Declaration

type TgxMultiProxyMaster = class(TCollectionItem)

Description

MasterObject description for a MultiProxy object.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxMultiProxyMaster

Overview

Fields

Private | FMasterObject: TgxBaseSceneObject;
Private | FDistanceMin: Single;
Private | FDistanceMin2: Single;
Private | FDistanceMax: Single;
Private | FDistanceMax2: Single;
Private | FVisible: Boolean;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject: TgxMultiProxy;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;

Properties

Published | property DistanceMax: Single read FDistanceMax write SetDistanceMax;
Published | property DistanceMin: Single read FDistanceMin write SetDistanceMin;
Published | property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;
Published | property Visible: Boolean read FVisible write SetVisible default True;

Description

Fields

Private FMasterObject: TgxBaseSceneObject;

This item has no description.

Private FDistanceMin: Single;

This item has no description.

Private FDistanceMin2: Single;

This item has no description.

Private FDistanceMax: Single;

This item has no description.

Private FDistanceMax2: Single;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerObject: TgxMultiProxy;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Published property DistanceMax: Single read FDistanceMax write SetDistanceMax;

Maximum visibility distance (exclusive).

Published property DistanceMin: Single read FDistanceMin write SetDistanceMin;

Minimum visibility distance (inclusive).

Published property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property Visible: Boolean read FVisible write SetVisible default True;

Determines if the master object can be visible (proxy'ed). Note: the master object's distance also has to be within DistanceMin and DistanceMax.


GXSysHelp v.2.5: GXS.MultiProxy: Class TgxMultiProxyMasters

Class TgxMultiProxyMasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiProxy

Declaration

type TgxMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TgxMultiProxyMaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add(master: TgxBaseSceneObject; DistanceMin, DistanceMax: Single): TgxMultiProxyMaster; overload;
Public | function Add: TgxMultiProxyMaster; overload;
Public | procedure EndUpdate; override;
Public | procedure Notification(AComponent: TComponent);
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TgxMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add(master: TgxBaseSceneObject; DistanceMin, DistanceMax: Single): TgxMultiProxyMaster; overload;

This item has no description.

Public function Add: TgxMultiProxyMaster; overload;

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure Notification(AComponent: TComponent);

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TgxMultiProxyMaster read GetItems write SetItems;


GXSysHelp v.2.5: GXS.MultiProxy: Class TgxMultiProxy

Class TgxMultiProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultiProxy

Declaration

type TgxMultiProxy = class(TgxSceneObject)

Description

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMultiProxy

Overview

Fields

Private | FMasterObjects: TgxMultiProxyMasters;
Private | FRendering: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObjects: TgxMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObjects: TgxMultiProxyMasters;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property MasterObjects: TgxMultiProxyMasters read FMasterObjects write SetMasterObjects;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.MultisampleImage

Unit GXS.MultisampleImage

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GXS.Context
  • GXS.Texture
  • GXS.Graphics
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMultisampleImage |


GXSysHelp v.2.5: GXS.MultisampleImage: Class TgxMultisampleImage

Class TgxMultisampleImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.MultisampleImage

Declaration

type TgxMultisampleImage = class(TgxTextureImage)

Description

This item has no description. Showing description inherited from TgxTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxMultisampleImage

Overview

Fields

Private | FBitmap: TgxBitmap32;
Private | FSamplesCount: Integer;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDepth: Integer;
Private | FFixedSamplesLocation: GLboolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxBitmap32; override;
Public | class function IsSelfLoading: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadTexture(AInternalFormat: TglInternalFormat); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Private | procedure SetDepth(val: Integer);
Private | procedure SetFixedSamplesLocation(val: GLboolean);
Private | procedure SetHeight(val: Integer);
Private | procedure SetSamplesCount(val: Integer);
Private | procedure SetWidth(val: Integer);

Properties

Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property FixedSamplesLocation: GLboolean read FFixedSamplesLocation write SetFixedSamplesLocation;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Public | property NativeTextureTarget;
Published | property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Fields

Private FBitmap: TgxBitmap32;

This item has no description.

Private FSamplesCount: Integer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDepth: Integer;

This item has no description.

Private FFixedSamplesLocation: GLboolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public class function IsSelfLoading: Boolean; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure LoadTexture(AInternalFormat: TglInternalFormat); override;

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Private procedure SetDepth(val: Integer);

This item has no description.

Private procedure SetFixedSamplesLocation(val: GLboolean);

This item has no description.

Private procedure SetHeight(val: Integer);

This item has no description.

Private procedure SetSamplesCount(val: Integer);

This item has no description.

Private procedure SetWidth(val: Integer);

This item has no description.

Properties

Published property Depth: Integer read GetDepth write SetDepth default 0;

This item has no description.

Published property FixedSamplesLocation: GLboolean read FFixedSamplesLocation write SetFixedSamplesLocation;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 256;

Width of the blank image (for memory allocation).

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TgxTextureImage.NativeTextureTarget.

Native OpenGL texture target.

Published property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 256;

Width of the blank image (for memory allocation).


GXSysHelp v.2.5: GXS.Navigator

Unit GXS.Navigator

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Types
  • System.SysUtils
  • System.Classes
  • System.Math
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Coordinates
  • GXS.Screen
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxNavigator |
Class TgxUserInterface |


GXSysHelp v.2.5: GXS.Navigator: Class TgxNavigator

Class TgxNavigator

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Navigator

Declaration

type TgxNavigator = class(TComponent)

Description

TgxNavigator is the component for moving a TgxBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction

The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNavigator

Overview

Fields

Private | FObject: TgxBaseSceneObject;
Private | FVirtualRight: TVector4f;
Private | FVirtualUp: TgxCoordinates;
Private | FUseVirtualUp: boolean;
Private | FAutoUpdateObject: boolean;
Private | FMaxAngle: single;
Private | FMinAngle: single;
Private | FCurrentVAngle: single;
Private | FCurrentHAngle: single;
Private | FAngleLock: boolean;
Private | FMoveUpWhenMovingForward: boolean;
Private | FInvertHorizontalSteeringWhenUpsideDown: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure FlyForward(Distance: single);
Public | procedure LoadState(Stream: TStream);
Public | procedure MoveForward(Distance: single);
Public | procedure SaveState(Stream: TStream);
Public | procedure StrafeHorizontal(Distance: single);
Public | procedure StrafeVertical(Distance: single);
Public | procedure Straighten;
Public | procedure TurnHorizontal(Angle: single);
Public | procedure TurnVertical(Angle: single);

Properties

Published | property AngleLock: boolean read FAngleLock write FAngleLock default False;
Published | property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;
Public | property CurrentHAngle: single read FCurrentHAngle;
Public | property CurrentVAngle: single read FCurrentVAngle;
Published | property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;
Published | property MaxAngle: single read FMaxAngle write FMaxAngle;
Published | property MinAngle: single read FMinAngle write FMinAngle;
Published | property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;
Published | property MovingObject: TgxBaseSceneObject read FObject write SetObject;
Published | property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;
Published | property VirtualUp: TgxCoordinates read FVirtualUp write SetVirtualUp;

Description

Fields

Private FObject: TgxBaseSceneObject;

This item has no description.

Private FVirtualRight: TVector4f;

This item has no description.

Private FVirtualUp: TgxCoordinates;

This item has no description.

Private FUseVirtualUp: boolean;

This item has no description.

Private FAutoUpdateObject: boolean;

This item has no description.

Private FMaxAngle: single;

This item has no description.

Private FMinAngle: single;

This item has no description.

Private FCurrentVAngle: single;

This item has no description.

Private FCurrentHAngle: single;

This item has no description.

Private FAngleLock: boolean;

This item has no description.

Private FMoveUpWhenMovingForward: boolean;

This item has no description.

Private FInvertHorizontalSteeringWhenUpsideDown: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure FlyForward(Distance: single);

This item has no description.

Public procedure LoadState(Stream: TStream);

This item has no description.

Public procedure MoveForward(Distance: single);

This item has no description.

Public procedure SaveState(Stream: TStream);

This item has no description.

Public procedure StrafeHorizontal(Distance: single);

This item has no description.

Public procedure StrafeVertical(Distance: single);

This item has no description.

Public procedure Straighten;

This item has no description.

Public procedure TurnHorizontal(Angle: single);

This item has no description.

Public procedure TurnVertical(Angle: single);

This item has no description.

Properties

Published property AngleLock: boolean read FAngleLock write FAngleLock default False;

This item has no description.

Published property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;

This item has no description.

Public property CurrentHAngle: single read FCurrentHAngle;

This item has no description.

Public property CurrentVAngle: single read FCurrentVAngle;

This item has no description.

Published property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;

This item has no description.

Published property MaxAngle: single read FMaxAngle write FMaxAngle;

This item has no description.

Published property MinAngle: single read FMinAngle write FMinAngle;

This item has no description.

Published property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;

This item has no description.

Published property MovingObject: TgxBaseSceneObject read FObject write SetObject;

This item has no description.

Published property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;

This item has no description.

Published property VirtualUp: TgxCoordinates read FVirtualUp write SetVirtualUp;


GXSysHelp v.2.5: GXS.Navigator: Class TgxUserInterface

Class TgxUserInterface

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Navigator

Declaration

type TgxUserInterface = class(TComponent)

Description

TgxUserInterface is the component which reads the userinput and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GXNavigator : The Navigator which receives the user movement. GXVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxUserInterface

Overview

Fields

Private | FPrevPoint: TPoint;
Private | midScreenX: integer;
Private | midScreenY: integer;
Private | FMouseActive: boolean;
Private | FMouseSpeed: single;
Private | FGLNavigator: TgxNavigator;
Private | FGLVertNavigator: TgxNavigator;
Private | FInvertMouse: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function IsMouseLookOn: Boolean;
Public | function MouseLook: Boolean;
Public | procedure MouseLookActivate;
Public | procedure MouseLookActiveToggle;
Public | procedure MouseLookDeactivate;
Public | procedure MouseUpdate;
Public | procedure TurnHorizontal(Angle : Double);
Public | procedure TurnVertical(Angle : Double);
Private | procedure MouseInitialize;
Private | procedure SetMouseLookActive(const val: boolean);
Private | procedure setNavigator(val: TgxNavigator);
Private | procedure setVertNavigator(val: TgxNavigator);

Properties

Published | property GLNavigator: TgxNavigator read FGLNavigator write setNavigator;
Published | property GLVertNavigator: TgxNavigator read FGLVertNavigator write setVertNavigator;
Published | property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;
Public | property MouseLookActive : Boolean read FMouseActive write SetMouseLookActive;
Published | property MouseSpeed: single read FMouseSpeed write FMouseSpeed;

Description

Fields

Private FPrevPoint: TPoint;

This item has no description.

Private midScreenX: integer;

This item has no description.

Private midScreenY: integer;

This item has no description.

Private FMouseActive: boolean;

This item has no description.

Private FMouseSpeed: single;

This item has no description.

Private FGLNavigator: TgxNavigator;

This item has no description.

Private FGLVertNavigator: TgxNavigator;

This item has no description.

Private FInvertMouse: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsMouseLookOn: Boolean;

This item has no description.

Public function MouseLook: Boolean;

This item has no description.

Public procedure MouseLookActivate;

This item has no description.

Public procedure MouseLookActiveToggle;

This item has no description.

Public procedure MouseLookDeactivate;

This item has no description.

Public procedure MouseUpdate;

This item has no description.

Public procedure TurnHorizontal(Angle : Double);

This item has no description.

Public procedure TurnVertical(Angle : Double);

This item has no description.

Private procedure MouseInitialize;

This item has no description.

Private procedure SetMouseLookActive(const val: boolean);

This item has no description.

Private procedure setNavigator(val: TgxNavigator);

This item has no description.

Private procedure setVertNavigator(val: TgxNavigator);

This item has no description.

Properties

Published property GLNavigator: TgxNavigator read FGLNavigator write setNavigator;

This item has no description.

Published property GLVertNavigator: TgxNavigator read FGLVertNavigator write setVertNavigator;

This item has no description.

Published property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;

This item has no description.

Public property MouseLookActive : Boolean read FMouseActive write SetMouseLookActive;

This item has no description.

Published property MouseSpeed: single read FMouseSpeed write FMouseSpeed;


GXSysHelp v.2.5: GXS.NGDManager

Unit GXS.NGDManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • System.Types
  • NGD.Import
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.XCollection
  • GLScene.GeometryBB
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GXS.Scene
  • GLScene.Manager
  • GXS.Coordinates
  • GXS.Objects
  • GXS.GeomObjects
  • GXS.VectorFileObjects
  • GXS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxNGDHeightField |
Class TgxNGDBehaviourList |
Class TgxNGDDebugOption |
Class TgxNGDManager |
Class TgxNGDBehaviour |
Class TgxNGDDynamic |
Class TgxNGDStatic |
Class TgxNGDSurfaceItem |
Class TgxNGDSurfacePair |
Class TgxNGDJointPivot |
Class TgxNGDJointPin |
Class TgxNGDJointPin2 |
Class TgxNGDJointBallAndSocket |
Class TgxNGDJointHinge |
Class TgxNGDJointSlider |
Class TgxNGDJointKinematicController |
Class TgxNGDJoint |

Functions and Procedures

function GetNGDStatic(Obj: TgxBaseSceneObject): TgxNGDStatic;
function GetOrCreateNGDStatic(Obj: TgxBaseSceneObject): TgxNGDStatic;
function GetNGDDynamic(Obj: TgxBaseSceneObject): TgxNGDDynamic;
function GetOrCreateNGDDynamic(Obj: TgxBaseSceneObject): TgxNGDDynamic;
function GetBodyFromGLXceneObject(Obj: TgxBaseSceneObject): PNewtonBody;

Types

PdFloat = ˆdFloat;
TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer) : Boolean of object;
TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: dFloat; threadIndex: Integer) of object;
TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PdFloat; faceId: Integer) of object;
TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer) of object;
TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;
TgxNGDCollisions = (...);
TgxNGDFrictionModels = (...);
TgxNGDJoints = (...);
TgxNGDManagerDebug = (...);
TgxNGDManagerDebugs = set of TgxNGDManagerDebug;
TgxNGDPickedActions = (...);
TgxNGDSolverModels = (...);
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;
TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PdFloat; threadIndex: Integer) of object;

Description

Functions and Procedures

function GetNGDStatic(Obj: TgxBaseSceneObject): TgxNGDStatic;

Global function

function GetOrCreateNGDStatic(Obj: TgxBaseSceneObject): TgxNGDStatic;

This item has no description.

function GetNGDDynamic(Obj: TgxBaseSceneObject): TgxNGDDynamic;

This item has no description.

function GetOrCreateNGDDynamic(Obj: TgxBaseSceneObject): TgxNGDDynamic;

This item has no description.

function GetBodyFromGLXceneObject(Obj: TgxBaseSceneObject): PNewtonBody;

This item has no description.

Types

PdFloat = ˆdFloat;

TComponent Tlist TWriter TReader TPersistent System utilities Samevalue isZero to compare single PVector4f TVector4f TMatrix4f PMatrix4f NullHmgVector... TgxAffineVectorList for Tree TXCollection file function cube cone freeform... For show debug

TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer) : Boolean of object;

This item has no description.

TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: dFloat; threadIndex: Integer) of object;

This item has no description.

TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PdFloat; faceId: Integer) of object;

Events for Newton Callback

TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer) of object;

This item has no description.

TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;

This item has no description.

TgxNGDCollisions = (...);

This item has no description.

Values
  • nc_Primitive = 0
  • nc_Convex
  • nc_BBox
  • nc_BSphere
  • nc_Tree
  • nc_Mesh
  • nc_Null
  • nc_HeightField
  • nc_NGDFile
TgxNGDFrictionModels = (...);

This item has no description.

Values
  • fmExact = 0
  • fmAdaptive
TgxNGDJoints = (...);

This item has no description.

Values
  • nj_BallAndSocket
  • nj_Hinge
  • nj_Slider
  • nj_Corkscrew
  • nj_Universal
  • nj_CustomBallAndSocket
  • nj_CustomHinge
  • nj_CustomSlider
  • nj_UpVector
  • nj_KinematicController
TgxNGDManagerDebug = (...);

This item has no description.

Values
  • mdShowGeometry
  • mdShowAABB
  • mdShowCenterOfMass
  • mdShowContact
  • mdShowJoint
  • mdShowForce
  • mdShowAppliedForce
  • mdShowAppliedVelocity
TgxNGDManagerDebugs = set of TgxNGDManagerDebug;

This item has no description.

TgxNGDPickedActions = (...);

This item has no description.

Values
  • paAttach = 0
  • paMove
  • paDetach
TgxNGDSolverModels = (...);

This item has no description.

Values
  • smExact = 0
  • smLinear1
  • smLinear2
  • smLinear3
  • smLinear4
  • smLinear5
  • smLinear6
  • smLinear7
  • smLinear8
  • smLinear9
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;

This item has no description.

TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PdFloat; threadIndex: Integer) of object;


GXSysHelp v.2.5: GXS.NGDManager: Record TgxNGDHeightField

Record TgxNGDHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDHeightField = record

Description

This item has no description.

Overview

Fields

Public | heightArray: array of Word;
Public | width: Integer;
Public | depth: Integer;
Public | gridDiagonals: Boolean;
Public | widthDepthScale: Single;
Public | heightScale: Single;

Description

Fields

Public heightArray: array of Word;

This item has no description.

Public width: Integer;

This item has no description.

Public depth: Integer;

This item has no description.

Public gridDiagonals: Boolean;

This item has no description.

Public widthDepthScale: Single;

This item has no description.

Public heightScale: Single;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDBehaviourList

Class TgxNGDBehaviourList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDBehaviourList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxNGDBehaviourList

Overview

Properties

Public property ItemsBehav[index: Integer]: TgxNGDBehaviour read GetBehav write PutBehav;

Description

Properties

Public property ItemsBehav[index: Integer]: TgxNGDBehaviour read GetBehav write PutBehav;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDDebugOption

Class TgxNGDDebugOption

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDDebugOption = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDDebugOption

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;

Properties

Published | property AABBColor: TgxColor read FAABBColor write FAABBColor;
Published | property AABBColorSleep: TgxColor read FAABBColorSleep write FAABBColorSleep;
Published | property AppliedForceColor: TgxColor read FAppliedForceColor write FAppliedForceColor;
Published | property AppliedVelocityColor: TgxColor read FAppliedVelocityColor write FAppliedVelocityColor;
Published | property CenterOfMassColor: TgxColor read FCenterOfMassColor write FCenterOfMassColor;
Published | property ContactColor: TgxColor read FContactColor write FContactColor;
Published | property CustomColor: TgxColor read FCustomColor write FCustomColor;
Published | property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;
Published | property ForceColor: TgxColor read FForceColor write FForceColor;
Published | property GeomColorDyn: TgxColor read FGeomColorDyn write FGeomColorDyn;
Published | property GeomColorStat: TgxColor read FGeomColorStat write FGeomColorStat;
Published | property JointAxisColor: TgxColor read FJointAxisColor write FJointAxisColor;
Published | property JointPivotColor: TgxColor read FJointPivotColor write FJointPivotColor;
Published | property NGDManagerDebugs: TgxNGDManagerDebugs read FManagerDebugs write SetManagerDebugs default [];

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property AABBColor: TgxColor read FAABBColor write FAABBColor;

This item has no description.

Published property AABBColorSleep: TgxColor read FAABBColorSleep write FAABBColorSleep;

This item has no description.

Published property AppliedForceColor: TgxColor read FAppliedForceColor write FAppliedForceColor;

This item has no description.

Published property AppliedVelocityColor: TgxColor read FAppliedVelocityColor write FAppliedVelocityColor;

This item has no description.

Published property CenterOfMassColor: TgxColor read FCenterOfMassColor write FCenterOfMassColor;

This item has no description.

Published property ContactColor: TgxColor read FContactColor write FContactColor;

This item has no description.

Published property CustomColor: TgxColor read FCustomColor write FCustomColor;

This item has no description.

Published property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;

This item has no description.

Published property ForceColor: TgxColor read FForceColor write FForceColor;

This item has no description.

Published property GeomColorDyn: TgxColor read FGeomColorDyn write FGeomColorDyn;

This item has no description.

Published property GeomColorStat: TgxColor read FGeomColorStat write FGeomColorStat;

This item has no description.

Published property JointAxisColor: TgxColor read FJointAxisColor write FJointAxisColor;

This item has no description.

Published property JointPivotColor: TgxColor read FJointPivotColor write FJointPivotColor;

This item has no description.

Published property NGDManagerDebugs: TgxNGDManagerDebugs read FManagerDebugs write SetManagerDebugs default [];


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDManager

Class TgxNGDManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNGDManager

Overview

Fields

Private | FNewtonWorld: PNewtonWorld;
Private | FNGDBehaviours: TgxNGDBehaviourList;
Private | FCurrentColor: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Step(deltatime: Single);

Properties

Published | property DebugOption: TgxNGDDebugOption read FNewtonDebugOption write FNewtonDebugOption;
Published | property DllVersion: Integer read FDllVersion;
Published | property FrictionModel: TgxNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;
Published | property Gravity: TgxCoordinates read FGravity write FGravity;
Published | property Line: TgxLines read FGLLines write SetGXLines;
Published | property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;
Published | property NewtonBodyCount: Integer read GetBodyCount;
Published | property NewtonConstraintCount: Integer read GetConstraintCount;
Published | property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;
Published | property NewtonSurfaceItem: TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;
Published | property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;
Published | property SolverModel: TgxNGDSolverModels read FSolverModel write SetSolverModel default smExact;
Published | property ThreadCount: Integer read FThreadCount write SetThreadCount default 1;
Published | property Visible: Boolean read FVisible write SetVisible default True;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Published | property WorldSizeMax: TgxCoordinates read FWorldSizeMax write FWorldSizeMax;
Published | property WorldSizeMin: TgxCoordinates read FWorldSizeMin write FWorldSizeMin;

Description

Fields

Private FNewtonWorld: PNewtonWorld;

This item has no description.

Private FNGDBehaviours: TgxNGDBehaviourList;

This item has no description.

Private FCurrentColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

Debug view

Public destructor Destroy; override;

This item has no description.

Public procedure Step(deltatime: Single);

This item has no description.

Properties

Published property DebugOption: TgxNGDDebugOption read FNewtonDebugOption write FNewtonDebugOption;

This item has no description.

Published property DllVersion: Integer read FDllVersion;

This item has no description.

Published property FrictionModel: TgxNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;

This item has no description.

Published property Gravity: TgxCoordinates read FGravity write FGravity;

This item has no description.

Published property Line: TgxLines read FGLLines write SetGXLines;

This item has no description.

Published property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;

This item has no description.

Published property NewtonBodyCount: Integer read GetBodyCount;

This item has no description.

Published property NewtonConstraintCount: Integer read GetConstraintCount;

This item has no description.

Published property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;

This item has no description.

Published property NewtonSurfaceItem: TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;

This item has no description.

Published property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;

This item has no description.

Published property SolverModel: TgxNGDSolverModels read FSolverModel write SetSolverModel default smExact;

This item has no description.

Published property ThreadCount: Integer read FThreadCount write SetThreadCount default 1;

This item has no description.

Published property Visible: Boolean read FVisible write SetVisible default True;

This item has no description.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

This item has no description.

Published property WorldSizeMax: TgxCoordinates read FWorldSizeMax write FWorldSizeMax;

This item has no description.

Published property WorldSizeMin: TgxCoordinates read FWorldSizeMin write FWorldSizeMin;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDBehaviour

Class TgxNGDBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDBehaviour = class(TgxBehaviour)

Description

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxNGDBehaviour

Overview

Fields

Private | FManager: TgxNGDManager;
Private | FManagerName: string;
Private | FInitialized: Boolean;
Private | FNewtonBody: PNewtonBody;
Private | FCollision: PNewtonCollision;
Private | FNewtonBodyMatrix: TMatrix4f;
Private | FContinuousCollisionMode: Boolean;
Private | FNewtonCollisions: TgxNGDCollisions;
Private | FCollisionIteratorEvent: TCollisionIteratorEvent;
Private | FOwnerBaseSceneObject: TgxBaseSceneObject;
Private | FTreeCollisionOptimize: Boolean;
Private | FConvexCollisionTolerance: Single;
Private | FFileCollision: string;
Private | FSurfaceItem: TgxNGDSurfaceItem;
Private | FHeightFieldOptions: TgxNGDHeightField;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure DeSerialize(filename: string);
Public | procedure Reinitialize;
Public | procedure Serialize(filename: string);

Properties

Published | property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property ConvexCollisionTolerance: Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;
Published | property FileCollision: string read FFileCollision write FFileCollision;
Public | property HeightFieldOptions: TgxNGDHeightField read FHeightFieldOptions write SetHeightFieldOptions;
Public | property Initialized: Boolean read FInitialized;
Published | property Manager: TgxNGDManager read FManager write SetManager;
Public | property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;
Public | property NewtonBodyMatrix: TMatrix4f read GetNewtonBodyMatrix write SetNewtonBodyMatrix;
Published | property NGDNewtonCollisions: TgxNGDCollisions read FNewtonCollisions write SetNewtonCollisions default nc_Primitive;
Published | property NGDSurfaceItem: TgxNGDSurfaceItem read FSurfaceItem write SetNewtonSurfaceItem;
Published | property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;

Description

Fields

Private FManager: TgxNGDManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FNewtonBody: PNewtonBody;

This item has no description.

Private FCollision: PNewtonCollision;

This item has no description.

Private FNewtonBodyMatrix: TMatrix4f;

This item has no description.

Private FContinuousCollisionMode: Boolean;

Position and Orientation

Private FNewtonCollisions: TgxNGDCollisions;

Default=False

Private FCollisionIteratorEvent: TCollisionIteratorEvent;

This item has no description.

Private FOwnerBaseSceneObject: TgxBaseSceneObject;

This item has no description.

Private FTreeCollisionOptimize: Boolean;

FNullCollisionMass: Single; // Default=0

Private FConvexCollisionTolerance: Single;

Default=True

Private FFileCollision: string;

Default=0.01 1%

Private FSurfaceItem: TgxNGDSurfaceItem;

This item has no description.

Private FHeightFieldOptions: TgxNGDHeightField;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure DeSerialize(filename: string);

This item has no description.

Public procedure Reinitialize;

This item has no description.

Public procedure Serialize(filename: string);

This item has no description.

Properties

Published property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;

This item has no description.

Published property ConvexCollisionTolerance: Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;

This item has no description.

Published property FileCollision: string read FFileCollision write FFileCollision;

This item has no description.

Public property HeightFieldOptions: TgxNGDHeightField read FHeightFieldOptions write SetHeightFieldOptions;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Published property Manager: TgxNGDManager read FManager write SetManager;

This item has no description.

Public property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;

This item has no description.

Public property NewtonBodyMatrix: TMatrix4f read GetNewtonBodyMatrix write SetNewtonBodyMatrix;

This item has no description.

Published property NGDNewtonCollisions: TgxNGDCollisions read FNewtonCollisions write SetNewtonCollisions default nc_Primitive;

This item has no description.

Published property NGDSurfaceItem: TgxNGDSurfaceItem read FSurfaceItem write SetNewtonSurfaceItem;

This item has no description.

Published property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDDynamic

Class TgxNGDDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDDynamic = class(TgxNGDBehaviour)

Description

This item has no description. Showing description inherited from TgxNGDBehaviour.

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxNGDBehaviour
  • TgxNGDDynamic

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function GetOmega: TVector4f;
Public | function GetVelocity: TVector4f;
Public | procedure AddImpulse(const veloc, pointposit: TVector4f);
Public | procedure SetOmega(const Omega: TVector4f);
Public | procedure SetVelocity(const Velocity: TVector4f);

Properties

Published | property AngularDamping: TgxCoordinates read FAngularDamping write FAngularDamping;
Published | property AppliedForce: TgxCoordinates read FAppliedForce;
Published | property AppliedOmega: TgxCoordinates read FAppliedOmega;
Published | property AppliedTorque: TgxCoordinates read FAppliedTorque;
Published | property AppliedVelocity: TgxCoordinates read FAppliedVelocity;
Published | property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;
Published | property CenterOfMass: TgxCoordinates read FCenterOfMass write FCenterOfMass;
Public | property CustomForceAndTorqueEvent: TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;
Published | property Density: Single read FDensity write SetDensity stored StoredDensity;
Published | property Force: TgxCoordinates read FForce write FForce;
Published | property LinearDamping: Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;
Published | property Mass: Single read FMass;
Published | property NullCollisionVolume: Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;
Public | property Omega: TVector4f read GetOmega write SetOmega;
Published | property Torque: TgxCoordinates read FTorque write FTorque;
Published | property UseGravity: Boolean read FUseGravity write FUseGravity default True;
Public | property Velocity: TVector4f read GetVelocity write SetVelocity;
Published | property Volume: Single read FVolume;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function GetOmega: TVector4f;

This item has no description.

Public function GetVelocity: TVector4f;

This item has no description.

Public procedure AddImpulse(const veloc, pointposit: TVector4f);

This item has no description.

Public procedure SetOmega(const Omega: TVector4f);

This item has no description.

Public procedure SetVelocity(const Velocity: TVector4f);

This item has no description.

Properties

Published property AngularDamping: TgxCoordinates read FAngularDamping write FAngularDamping;

This item has no description.

Published property AppliedForce: TgxCoordinates read FAppliedForce;

This item has no description.

Published property AppliedOmega: TgxCoordinates read FAppliedOmega;

Read Only

Published property AppliedTorque: TgxCoordinates read FAppliedTorque;

This item has no description.

Published property AppliedVelocity: TgxCoordinates read FAppliedVelocity;

This item has no description.

Published property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;

This item has no description.

Published property CenterOfMass: TgxCoordinates read FCenterOfMass write FCenterOfMass;

This item has no description.

Public property CustomForceAndTorqueEvent: TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;

This item has no description.

Published property Density: Single read FDensity write SetDensity stored StoredDensity;

This item has no description.

Published property Force: TgxCoordinates read FForce write FForce;

This item has no description.

Published property LinearDamping: Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;

This item has no description.

Published property Mass: Single read FMass;

This item has no description.

Published property NullCollisionVolume: Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;

This item has no description.

Public property Omega: TVector4f read GetOmega write SetOmega;

This item has no description.

Published property Torque: TgxCoordinates read FTorque write FTorque;

This item has no description.

Published property UseGravity: Boolean read FUseGravity write FUseGravity default True;

This item has no description.

Public property Velocity: TVector4f read GetVelocity write SetVelocity;

This item has no description.

Published property Volume: Single read FVolume;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDStatic

Class TgxNGDStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDStatic = class(TgxNGDBehaviour)

Description

This item has no description. Showing description inherited from TgxNGDBehaviour.

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxNGDBehaviour
  • TgxNGDStatic

Overview

Methods

Public class function FriendlyName: string; override;

Description

Methods

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDSurfaceItem

Class TgxNGDSurfaceItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDSurfaceItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNGDSurfaceItem

Overview

Fields

Private FDisplayName: string;

Properties

Published | property DisplayName;
Published | property ID;

Description

Fields

Private FDisplayName: string;

This item has no description.

Properties

Published property DisplayName;

This item has no description.

Published property ID;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDSurfacePair

Class TgxNGDSurfacePair

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDSurfacePair = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNGDSurfacePair

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Private | class function NewtonAABBOverlap(const material: PNewtonMaterial; const body0: PNewtonBody; const body1: PNewtonBody; threadIndex: Integer) : Integer; static; cdecl;
Private | function OnNewtonAABBOverlapEvent(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean;
Public | procedure SetMaterialItems(const item1, item2: TgxNGDSurfaceItem);
Private | class procedure NewtonContactsProcess(const contact: PNewtonJoint; timestep: dFloat; threadIndex: Integer); static; cdecl;
Private | procedure OnNewtonContactsProcessEvent(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer);

Properties

Published | property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;
Published | property Collidable: Boolean read FCollidable write SetCollidable default True;
Published | property ContactProcessEvent: TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;
Published | property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;
Published | property KineticFriction: Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;
Public | property NGDSurfaceItem1: TgxNGDSurfaceItem read FSurfaceItem1;
Public | property NGDSurfaceItem2: TgxNGDSurfaceItem read FSurfaceItem2;
Published | property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;
Published | property StaticFriction: Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;
Published | property Thickness: Boolean read FThickness write SetThickness default False;

Description

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Private class function NewtonAABBOverlap(const material: PNewtonMaterial; const body0: PNewtonBody; const body1: PNewtonBody; threadIndex: Integer) : Integer; static; cdecl;

Callback

Private function OnNewtonAABBOverlapEvent(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean;

Event

Public procedure SetMaterialItems(const item1, item2: TgxNGDSurfaceItem);

This item has no description.

Private class procedure NewtonContactsProcess(const contact: PNewtonJoint; timestep: dFloat; threadIndex: Integer); static; cdecl;

This item has no description.

Private procedure OnNewtonContactsProcessEvent(const ccontact: PNewtonJoint; timestep: dFloat; threadIndex: Integer);

This item has no description.

Properties

Published property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;

This item has no description.

Published property Collidable: Boolean read FCollidable write SetCollidable default True;

This item has no description.

Published property ContactProcessEvent: TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;

This item has no description.

Published property ContinuousCollisionMode: Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;

This item has no description.

Published property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;

This item has no description.

Published property KineticFriction: Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;

This item has no description.

Public property NGDSurfaceItem1: TgxNGDSurfaceItem read FSurfaceItem1;

This item has no description.

Public property NGDSurfaceItem2: TgxNGDSurfaceItem read FSurfaceItem2;

This item has no description.

Published property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;

This item has no description.

Published property StaticFriction: Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;

This item has no description.

Published property Thickness: Boolean read FThickness write SetThickness default False;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointPivot

Class TgxNGDJointPivot

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointPivot = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot

Overview

Fields

Private | FManager: TgxNGDManager;
Private | FPivotPoint: TgxCoordinates;
Private | FOuter: TgxNGDJoint;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); virtual;
Public | destructor Destroy; override;

Properties

Published property PivotPoint: TgxCoordinates read FPivotPoint write FPivotPoint;

Description

Fields

Private FManager: TgxNGDManager;

This item has no description.

Private FPivotPoint: TgxCoordinates;

This item has no description.

Private FOuter: TgxNGDJoint;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PivotPoint: TgxCoordinates read FPivotPoint write FPivotPoint;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointPin

Class TgxNGDJointPin

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointPin = class(TgxNGDJointPivot)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot
  • TgxNGDJointPin

Overview

Fields

Private FPinDirection: TgxCoordinates;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection: TgxCoordinates read FPinDirection write FPinDirection;

Description

Fields

Private FPinDirection: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PinDirection: TgxCoordinates read FPinDirection write FPinDirection;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointPin2

Class TgxNGDJointPin2

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointPin2 = class(TgxNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot
  • TgxNGDJointPin
  • TgxNGDJointPin2

Overview

Fields

Private FPinDirection2: TgxCoordinates;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection2: TgxCoordinates read FPinDirection2 write FPinDirection2;

Description

Fields

Private FPinDirection2: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property PinDirection2: TgxCoordinates read FPinDirection2 write FPinDirection2;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointBallAndSocket

Class TgxNGDJointBallAndSocket

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointBallAndSocket = class(TgxNGDJointPivot)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot
  • TgxNGDJointBallAndSocket

Overview

Fields

Private | FConeAngle: Single;
Private | FMinTwistAngle: Single;
Private | FMaxTwistAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;
Private | function StoredConeAngle: Boolean;
Private | function StoredMaxTwistAngle: Boolean;
Private | function StoredMinTwistAngle: Boolean;
Private | procedure SetConeAngle(const Value: Single);
Private | procedure SetMaxTwistAngle(const Value: Single);
Private | procedure SetMinTwistAngle(const Value: Single);

Properties

Published | property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;
Published | property MaxTwistAngle: Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;
Published | property MinTwistAngle: Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;

Description

Fields

Private FConeAngle: Single;

This item has no description.

Private FMinTwistAngle: Single;

90

Private FMaxTwistAngle: Single;

-90

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;

This item has no description.

Private function StoredConeAngle: Boolean;

This item has no description.

Private function StoredMaxTwistAngle: Boolean;

This item has no description.

Private function StoredMinTwistAngle: Boolean;

This item has no description.

Private procedure SetConeAngle(const Value: Single);

90

Private procedure SetMaxTwistAngle(const Value: Single);

This item has no description.

Private procedure SetMinTwistAngle(const Value: Single);

This item has no description.

Properties

Published property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;

This item has no description.

Published property MaxTwistAngle: Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;

This item has no description.

Published property MinTwistAngle: Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointHinge

Class TgxNGDJointHinge

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointHinge = class(TgxNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot
  • TgxNGDJointPin
  • TgxNGDJointHinge

Overview

Fields

Private | FMinAngle: Single;
Private | FMaxAngle: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;
Private | function StoredMaxAngle: Boolean;
Private | function StoredMinAngle: Boolean;
Private | procedure SetMaxAngle(const Value: Single);
Private | procedure SetMinAngle(const Value: Single);

Properties

Published | property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;
Published | property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;

Description

Fields

Private FMinAngle: Single;

This item has no description.

Private FMaxAngle: Single;

-90

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;

This item has no description.

Private function StoredMaxAngle: Boolean;

This item has no description.

Private function StoredMinAngle: Boolean;

This item has no description.

Private procedure SetMaxAngle(const Value: Single);

90

Private procedure SetMinAngle(const Value: Single);

This item has no description.

Properties

Published property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;

This item has no description.

Published property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointSlider

Class TgxNGDJointSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointSlider = class(TgxNGDJointPin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointPivot
  • TgxNGDJointPin
  • TgxNGDJointSlider

Overview

Fields

Private | FMinDistance: Single;
Private | FMaxDistance: Single;

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;
Private | function StoredMaxDistance: Boolean;
Private | function StoredMinDistance: Boolean;
Private | procedure SetMaxDistance(const Value: Single);
Private | procedure SetMinDistance(const Value: Single);

Properties

Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;

Description

Fields

Private FMinDistance: Single;

This item has no description.

Private FMaxDistance: Single;

-10

Methods

Public constructor Create(AOwner: TComponent; aOuter: TgxNGDJoint); override;

This item has no description.

Private function StoredMaxDistance: Boolean;

This item has no description.

Private function StoredMinDistance: Boolean;

This item has no description.

Private procedure SetMaxDistance(const Value: Single);

10

Private procedure SetMinDistance(const Value: Single);

This item has no description.

Properties

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;

This item has no description.

Published property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJointKinematicController

Class TgxNGDJointKinematicController

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJointKinematicController = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxNGDJointKinematicController

Overview

Fields

Private | FPickModeLinear: Boolean;
Private | FLinearFriction: Single;
Private | FAngularFriction: Single;

Methods

Public | constructor Create();
Private | function StoredAngularFriction: Boolean;
Private | function StoredLinearFriction: Boolean;

Properties

Published | property AngularFriction: Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;
Published | property LinearFriction: Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;
Published | property PickModeLinear: Boolean read FPickModeLinear write FPickModeLinear default False;

Description

Fields

Private FPickModeLinear: Boolean;

This item has no description.

Private FLinearFriction: Single;

False

Private FAngularFriction: Single;

750

Methods

Public constructor Create();

This item has no description.

Private function StoredAngularFriction: Boolean;

250

Private function StoredLinearFriction: Boolean;

This item has no description.

Properties

Published property AngularFriction: Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;

This item has no description.

Published property LinearFriction: Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;

This item has no description.

Published property PickModeLinear: Boolean read FPickModeLinear write FPickModeLinear default False;


GXSysHelp v.2.5: GXS.NGDManager: Class TgxNGDJoint

Class TgxNGDJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDManager

Declaration

type TgxNGDJoint = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNGDJoint

Overview

Fields

Private | FManager: TgxNGDManager;
Private | FParentObject: TgxBaseSceneObject;
Private | FJointType: TgxNGDJoints;
Private | FStiffness: Single;
Private | FChildObject: TgxBaseSceneObject;
Private | FCollisionState: Boolean;
Private | FNewtonJoint: PNewtonJoint;
Private | FNewtonUserJoint: Pointer;
Private | FUPVectorDirection: TgxCoordinates;
Private | FBallAndSocketOptions: TgxNGDJointPivot;
Private | FHingeOptions: TgxNGDJointPin;
Private | FSliderOptions: TgxNGDJointPin;
Private | FCorkscrewOptions: TgxNGDJointPin;
Private | FUniversalOptions: TgxNGDJointPin2;
Private | FCustomBallAndSocketOptions: TgxNGDJointBallAndSocket;
Private | FCustomHingeOptions: TgxNGDJointHinge;
Private | FCustomSliderOptions: TgxNGDJointSlider;
Private | FKinematicOptions: TgxNGDJointKinematicController;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function StoredStiffness: Boolean;
Public | procedure KinematicControllerPick(pickpoint: TVector4f; PickedActions: TgxNGDPickedActions);
Private | procedure DestroyNewtonData;
Private | procedure Render;
Private | procedure SetChildObject(const Value: TgxBaseSceneObject);
Private | procedure SetCollisionState(const Value: Boolean);
Private | procedure SetJointType(const Value: TgxNGDJoints);
Private | procedure SetParentObject(const Value: TgxBaseSceneObject);
Private | procedure SetStiffness(const Value: Single);

Properties

Published | property BallAndSocketOptions: TgxNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;
Published | property ChildObject: TgxBaseSceneObject read FChildObject write SetChildObject;
Published | property CollisionState: Boolean read FCollisionState write SetCollisionState default False;
Published | property CorkscrewOptions: TgxNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;
Published | property CustomBallAndSocketOptions: TgxNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;
Published | property CustomHingeOptions: TgxNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;
Published | property CustomSliderOptions: TgxNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;
Published | property HingeOptions: TgxNGDJointPin read FHingeOptions write FHingeOptions;
Published | property JointType: TgxNGDJoints read FJointType write SetJointType;
Published | property KinematicControllerOptions: TgxNGDJointKinematicController read FKinematicOptions write FKinematicOptions;
Published | property ParentObject: TgxBaseSceneObject read FParentObject write SetParentObject;
Published | property SliderOptions: TgxNGDJointPin read FSliderOptions write FSliderOptions;
Published | property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;
Published | property UniversalOptions: TgxNGDJointPin2 read FUniversalOptions write FUniversalOptions;
Published | property UPVectorDirection: TgxCoordinates read FUPVectorDirection write FUPVectorDirection;

Description

Fields

Private FManager: TgxNGDManager;

Global

Private FParentObject: TgxBaseSceneObject;

This item has no description.

Private FJointType: TgxNGDJoints;

This item has no description.

Private FStiffness: Single;

This item has no description.

Private FChildObject: TgxBaseSceneObject;

0.9 With Two object Every joint except nj_UpVector and nj_KinematicController

Private FCollisionState: Boolean;

This item has no description.

Private FNewtonJoint: PNewtonJoint;

False With classic joint nj_BallAndSocket, nj_Hinge, nj_Slider, nj_Corkscrew nj_Universal, nj_UpVector

Private FNewtonUserJoint: Pointer;

With CustomJoint nj_CustomBallAndSocket, nj_CustomHinge, nj_CustomSlider nj_KinematicController

Private FUPVectorDirection: TgxCoordinates;

nj_UpVector

Private FBallAndSocketOptions: TgxNGDJointPivot;

This item has no description.

Private FHingeOptions: TgxNGDJointPin;

This item has no description.

Private FSliderOptions: TgxNGDJointPin;

This item has no description.

Private FCorkscrewOptions: TgxNGDJointPin;

This item has no description.

Private FUniversalOptions: TgxNGDJointPin2;

This item has no description.

Private FCustomBallAndSocketOptions: TgxNGDJointBallAndSocket;

This item has no description.

Private FCustomHingeOptions: TgxNGDJointHinge;

This item has no description.

Private FCustomSliderOptions: TgxNGDJointSlider;

This item has no description.

Private FKinematicOptions: TgxNGDJointKinematicController;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoredStiffness: Boolean;

This item has no description.

Public procedure KinematicControllerPick(pickpoint: TVector4f; PickedActions: TgxNGDPickedActions);

This item has no description.

Private procedure DestroyNewtonData;

This item has no description.

Private procedure Render;

This item has no description.

Private procedure SetChildObject(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetCollisionState(const Value: Boolean);

This item has no description.

Private procedure SetJointType(const Value: TgxNGDJoints);

This item has no description.

Private procedure SetParentObject(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetStiffness(const Value: Single);

This item has no description.

Properties

Published property BallAndSocketOptions: TgxNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;

This item has no description.

Published property ChildObject: TgxBaseSceneObject read FChildObject write SetChildObject;

This item has no description.

Published property CollisionState: Boolean read FCollisionState write SetCollisionState default False;

This item has no description.

Published property CorkscrewOptions: TgxNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;

This item has no description.

Published property CustomBallAndSocketOptions: TgxNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;

This item has no description.

Published property CustomHingeOptions: TgxNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;

This item has no description.

Published property CustomSliderOptions: TgxNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;

This item has no description.

Published property HingeOptions: TgxNGDJointPin read FHingeOptions write FHingeOptions;

This item has no description.

Published property JointType: TgxNGDJoints read FJointType write SetJointType;

This item has no description.

Published property KinematicControllerOptions: TgxNGDJointKinematicController read FKinematicOptions write FKinematicOptions;

This item has no description.

Published property ParentObject: TgxBaseSceneObject read FParentObject write SetParentObject;

This item has no description.

Published property SliderOptions: TgxNGDJointPin read FSliderOptions write FSliderOptions;

This item has no description.

Published property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;

This item has no description.

Published property UniversalOptions: TgxNGDJointPin2 read FUniversalOptions write FUniversalOptions;

This item has no description.

Published property UPVectorDirection: TgxCoordinates read FUPVectorDirection write FUPVectorDirection;


GXSysHelp v.2.5: GXS.NGDRagdoll

Unit GXS.NGDRagdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorFileObjects
  • NGD.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TNewtonRagdoll |

Functions and Procedures

function GetBoneParent(actor: TgxActor; bone: integer): integer;

Description

Functions and Procedures

function GetBoneParent(actor: TgxActor; bone: integer): integer;


GXSysHelp v.2.5: GXS.NGDRagdoll: Class TNewtonRagdoll

Class TNewtonRagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.NGDRagdoll

Declaration

type TNewtonRagdoll = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TNewtonRagdoll

Overview

Fields

Private | FERP: single;
Private | FSlideLimit: single;
Private | FAngleLimit: single;
Private | FEnabled: boolean;
Private | newtonworld: PNewtonWorld;
Public | Actor: TgxActor;
Public | Bodies: TList;
Public | Joints: array of PNewtonJoint;
Public | Norm_matrices: array of TMatrix4f;
Public | Envelopes: array of record kind: byte; Mat: TMatrix4f; Pt: TVector3f; W, D, H, Mass: single; end;

Methods

Public | constructor Create(model: TgxActor; world: PNewtonWorld; min_env_size: single = 0.8; slide_limit: single = 0.5; erp_: single = 0.8; angle_limit: single = 15; full: boolean = true);
Public | destructor Destroy; override;
Public | function TranslatePos(n: integer; add: boolean): TVector4f;
Public | procedure Conform;
Public | procedure LoadFromFile(filename: string);
Public | procedure SaveToFile(filename: string);
Private | procedure Clean;
Private | procedure SetAngleLimit(value: single);
Private | procedure SetEnabled(value: boolean);
Private | procedure SetERP(value: single);
Private | procedure SetSlideLimit(value: single);

Properties

Public | property AngleLimit: single read FAngleLimit write SetAngleLimit;
Public | property Enabled: boolean read FEnabled write SetEnabled;
Public | property ERP: single read FERP write SetERP;
Public | property SlideLimit: single read FSlideLimit write SetSlideLimit;

Description

Fields

Private FERP: single;

This item has no description.

Private FSlideLimit: single;

This item has no description.

Private FAngleLimit: single;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private newtonworld: PNewtonWorld;

This item has no description.

Public Actor: TgxActor;

This item has no description.

Public Bodies: TList;

This item has no description.

Public Joints: array of PNewtonJoint;

This item has no description.

Public Norm_matrices: array of TMatrix4f;

This item has no description.

Public Envelopes: array of record kind: byte; Mat: TMatrix4f; Pt: TVector3f; W, D, H, Mass: single; end;

This item has no description.

Methods

Public constructor Create(model: TgxActor; world: PNewtonWorld; min_env_size: single = 0.8; slide_limit: single = 0.5; erp_: single = 0.8; angle_limit: single = 15; full: boolean = true);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TranslatePos(n: integer; add: boolean): TVector4f;

This item has no description.

Public procedure Conform;

This item has no description.

Public procedure LoadFromFile(filename: string);

This item has no description.

Public procedure SaveToFile(filename: string);

This item has no description.

Private procedure Clean;

This item has no description.

Private procedure SetAngleLimit(value: single);

This item has no description.

Private procedure SetEnabled(value: boolean);

This item has no description.

Private procedure SetERP(value: single);

This item has no description.

Private procedure SetSlideLimit(value: single);

This item has no description.

Properties

Public property AngleLimit: single read FAngleLimit write SetAngleLimit;

This item has no description.

Public property Enabled: boolean read FEnabled write SetEnabled;

This item has no description.

Public property ERP: single read FERP write SetERP;

This item has no description.

Public property SlideLimit: single read FSlideLimit write SetSlideLimit;


GXSysHelp v.2.5: GXS.Nodes

Unit GXS.Nodes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.Spline
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.XOpenGL
  • GXS.BaseClasses
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxNode |
Class TgxNodes |

Types

TgxNodesClass = class of TgxNodes;

Description

Types

TgxNodesClass = class of TgxNodes;


GXSysHelp v.2.5: GXS.Nodes: Class TgxNode

Class TgxNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Nodes

Declaration

type TgxNode = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNode

Overview

Fields

Private | FCoords: TVector4f;
Private | FTagObject: TObject;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function AsAddress: PGLFloat;
Private | function GetAsAffineVector: TAffineVector;
Private | function GetCoordinate(const Index: Integer): Single;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetAsAffineVector(const Value: TAffineVector);
Private | procedure SetAsVector(const Value: TVector4f);
Private | procedure SetCoordinate(AIndex: Integer; AValue: Single);

Properties

Public | property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public | property AsVector: TVector4f read FCoords write SetAsVector;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property W: Single index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property X: Single index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Y: Single index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Z: Single index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;

Description

Fields

Private FCoords: TVector4f;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsAddress: PGLFloat;

This item has no description.

Private function GetAsAffineVector: TAffineVector;

This item has no description.

Private function GetCoordinate(const Index: Integer): Single;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetAsAffineVector(const Value: TAffineVector);

This item has no description.

Private procedure SetAsVector(const Value: TVector4f);

This item has no description.

Private procedure SetCoordinate(AIndex: Integer; AValue: Single);

This item has no description.

Properties

Public property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;

The coordinates viewed as an affine vector. Assigning a value to this property will trigger notification events, if you don't want so, use DirectVector instead. The W component is automatically adjustes depending on style.

Public property AsVector: TVector4f read FCoords write SetAsVector;

The coordinates viewed as a vector. Assigning a value to this property will trigger notification events, if you don't want so, use DirectVector instead.

Public property TagObject: TObject read FTagObject write FTagObject;

This item has no description.

Public property W: Single index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property X: Single index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property Y: Single index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;

This item has no description.

Published property Z: Single index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;


GXSysHelp v.2.5: GXS.Nodes: Class TgxNodes

Class TgxNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Nodes

Declaration

type TgxNodes = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxNodes

Overview

Methods

Public | constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);
Public | function Add: TgxNode;
Public | function Barycenter: TAffineVector;
Public | function CreateCopy(AOwner: TPersistent): TgxNodes;
Public | function CreateNewCubicSpline: TCubicSpline;
Public | function FindItemID(ID: Integer): TgxNode;
Public | function First: TgxNode;
Public | function Last: TgxNode;
Public | function Normal: TAffineVector;
Public | function Vector(I: Integer): TAffineVector;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const Coords: TgxCustomCoordinates); overload;
Public | procedure AddNode(const X, Y, Z: Single); overload;
Public | procedure AddNode(const Value: TVector4f); overload;
Public | procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);
Public | procedure EndUpdate; override;
Public | procedure GetExtents(var Min, Max: TAffineVector);
Public | procedure NotifyChange; virtual;
Public | procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);
Public | procedure RotateAroundX(Angle: Single);
Public | procedure RotateAroundY(Angle: Single);
Public | procedure RotateAroundZ(Angle: Single);
Public | procedure Scale(const Fv: TAffineVector); overload;
Public | procedure Scale(F: Single); overload;
Public | procedure Translate(const Tv: TAffineVector);

Properties

Public property Items[index: Integer]: TgxNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);

This item has no description.

Public function Add: TgxNode;

This item has no description.

Public function Barycenter: TAffineVector;

Calculates and returns the barycenter of the nodes

Public function CreateCopy(AOwner: TPersistent): TgxNodes;

This item has no description.

Public function CreateNewCubicSpline: TCubicSpline;

This item has no description.

Public function FindItemID(ID: Integer): TgxNode;

This item has no description.

Public function First: TgxNode;

This item has no description.

Public function Last: TgxNode;

This item has no description.

Public function Normal: TAffineVector;

Computes normal based on the 1st three nodes. Returns NullVector if there are less than 3 nodes.

Public function Vector(I: Integer): TAffineVector;

Returns normalized vector Nodes[i+1]-Nodes[i]

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const Coords: TgxCustomCoordinates); overload;

This item has no description.

Public procedure AddNode(const X, Y, Z: Single); overload;

This item has no description.

Public procedure AddNode(const Value: TVector4f); overload;

This item has no description.

Public procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);

This item has no description.

Public procedure EndUpdate; override;

This item has no description.

Public procedure GetExtents(var Min, Max: TAffineVector);

Calculates the extents of the nodes (min-max for all coordinates). The returned values are also the two corners of the axis-aligned bounding box.

Public procedure NotifyChange; virtual;

This item has no description.

Public procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);

This item has no description.

Public procedure RotateAroundX(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure RotateAroundY(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure RotateAroundZ(Angle: Single);

Rotate nodes around Y axis by the given angle (degrees)

Public procedure Scale(const Fv: TAffineVector); overload;

Scale all node coordinates

Public procedure Scale(F: Single); overload;

Scale all node coordinates

Public procedure Translate(const Tv: TAffineVector);

Translate all nodes

Properties

Public property Items[index: Integer]: TgxNode read GetItems write SetItems;


GXSysHelp v.2.5: GXS.ObjectManager

Unit GXS.ObjectManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.UITypes
  • FMX.Graphics
  • FMX.Controls
  • FMX.Menus
  • GXS.ImageUtils
  • GXS.Scene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxSceneObjectEntry |
Class TgxObjectManager |

Types

PSceneObjectEntry = ˆTgxSceneObjectEntry;

Description

Types

PSceneObjectEntry = ˆTgxSceneObjectEntry;


GXSysHelp v.2.5: GXS.ObjectManager: Record TgxSceneObjectEntry

Record TgxSceneObjectEntry

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ObjectManager

Declaration

type TgxSceneObjectEntry = record

Description

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference

Overview

Fields

Public | ObjectClass: TgxSceneObjectClass;
Public | Name: string;
Public | Category: string;
Public | Index: Integer;
Public | ImageIndex: Integer;

Description

Fields

Public ObjectClass: TgxSceneObjectClass;

This item has no description.

Public Name: string;

This item has no description.

Public Category: string;

type name of the object

Public Index: Integer;

category of object

Public ImageIndex: Integer;

index into "FSceneObjectList"


GXSysHelp v.2.5: GXS.ObjectManager: Class TgxObjectManager

Class TgxObjectManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ObjectManager

Declaration

type TgxObjectManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxObjectManager

Overview

Fields

Private | FSceneObjectList: TList;
Private | FObjectIcons: TStyleBook;
Private | FOverlayIndex: Integer;
Private | FSceneRootIndex: Integer;
Private | FCameraRootIndex: Integer;
Private | FLightsourceRootIndex: Integer;
Private | FObjectRootIndex: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCategory(ASceneObject: TgxSceneObjectClass): string;
Public | function GetClassFromIndex(Index: Integer): TgxSceneObjectClass;
Public | function GetImageIndex(ASceneObject: TgxSceneObjectClass): Integer;
Public | procedure CreateDefaultObjectIcons(ResourceModule: Cardinal);
Public | procedure GetRegisteredSceneObjects(ObjectList: TStringList);
Public | procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; AClickEvent: TNotifyEvent);
Public | procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;
Public | procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string; ABitmap: TBitmap); overload;
Public | procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string); overload;
Public | procedure UnRegisterSceneObject(ASceneObject: TgxSceneObjectClass);

Properties

Public | property CameraRootIndex: Integer read FCameraRootIndex;
Public | property LightsourceRootIndex: Integer read FLightsourceRootIndex;
Public | property ObjectIcons: TStyleBook read FObjectIcons;
Public | property ObjectRootIndex: Integer read FObjectRootIndex;
Public | property SceneRootIndex: Integer read FSceneRootIndex;

Description

Fields

Private FSceneObjectList: TList;

This item has no description.

Private FObjectIcons: TStyleBook;

This item has no description.

Private FOverlayIndex: Integer;

In VCL FObjectIcons: TImageList; <- a list of icons for scene objects

Private FSceneRootIndex: Integer;

indices into the object icon list

Private FCameraRootIndex: Integer;

indices into the object icon list

Private FLightsourceRootIndex: Integer;

indices into the object icon list

Private FObjectRootIndex: Integer;

indices into the object icon list

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetCategory(ASceneObject: TgxSceneObjectClass): string;

This item has no description.

Public function GetClassFromIndex(Index: Integer): TgxSceneObjectClass;

This item has no description.

Public function GetImageIndex(ASceneObject: TgxSceneObjectClass): Integer;

This item has no description.

Public procedure CreateDefaultObjectIcons(ResourceModule: Cardinal);

This item has no description.

Public procedure GetRegisteredSceneObjects(ObjectList: TStringList);

This item has no description.

Public procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; AClickEvent: TNotifyEvent);

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string; ABitmap: TBitmap); overload;

This item has no description.

Public procedure RegisterSceneObject(ASceneObject: TgxSceneObjectClass; const AName, ACategory: string); overload;

Registers a stock object and adds it to the stock object list

Public procedure UnRegisterSceneObject(ASceneObject: TgxSceneObjectClass);

Unregisters a stock object and removes it from the stock object list

Properties

Public property CameraRootIndex: Integer read FCameraRootIndex;

This item has no description.

Public property LightsourceRootIndex: Integer read FLightsourceRootIndex;

This item has no description.

Public property ObjectIcons: TStyleBook read FObjectIcons;

This item has no description.

Public property ObjectRootIndex: Integer read FObjectRootIndex;

This item has no description.

Public property SceneRootIndex: Integer read FSceneRootIndex;

In VCL TImageList


GXSysHelp v.2.5: GXS.Objects

Unit GXS.Objects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • System.SysUtils
  • System.Math
  • GXS.XOpenGL
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.Strings
  • GXS.Scene
  • GXS.Context
  • GXS.Silhouette
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Nodes
  • GLScene.PipelineTransform
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TVertexRec |
Class TgxDummyCube |
Class TgxPlane |
Class TgxSprite |
Class TgxPointParameters |
Class TgxPoints |
Class TgxLinesNode |
Class TgxLinesNodes |
Class TgxLineBase |
Class TgxNodedLines |
Class TgxLines |
Class TgxCube |
Class TgxQuadricObject |
Class TgxSphere |
Class TgxPolygonBase |
Class TgxSuperellipsoid |

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TgxRenderContextInfo; Size: Single; Stipple: Boolean; const Color: TgxColorVector);

Types

PVertexRec = ˆTVertexRec;
TAngleLimit1 = -90 .. 90;
TAngleLimit2 = 0 .. 360;
TgxCapType = (...);
TgxCubePart = (...);
TgxCubeParts = set of TgxCubePart;
TgxLinesOptions = set of TLinesOption;
TgxLineSplineMode = (...);
TgxNormalSmoothing = (...);
TgxPlaneStyle = (...);
TgxPlaneStyles = set of TgxPlaneStyle;
TgxPointStyle = (...);
TgxVisibilityDeterminationEvent = function(Sender: TObject; var rci: TgxRenderContextInfo): Boolean of object;
TLineNodesAspect = (...);
TLinesOption = (...);

Constants

cDefaultPointSize: Single = 1.0;

Variables

TangentAttributeName: AnsiString = 'Tangent';
BinormalAttributeName: AnsiString = 'Binormal';

Description

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TgxRenderContextInfo; Size: Single; Stipple: Boolean; const Color: TgxColorVector);

Issues for a unit-size cube stippled wireframe.

Types

PVertexRec = ˆTVertexRec;

This item has no description.

TAngleLimit1 = -90 .. 90;

This item has no description.

TAngleLimit2 = 0 .. 360;

This item has no description.

TgxCapType = (...);

This item has no description.

Values
  • ctNone
  • ctCenter
  • ctFlat
TgxCubePart = (...);

This item has no description.

Values
  • cpTop
  • cpBottom
  • cpFront
  • cpBack
  • cpLeft
  • cpRight
TgxCubeParts = set of TgxCubePart;

This item has no description.

TgxLinesOptions = set of TLinesOption;

This item has no description.

TgxLineSplineMode = (...);

Available spline modes for a TLine.

Values
  • lsmLines
  • lsmCubicSpline
  • lsmBezierSpline
  • lsmNURBSCurve
  • lsmSegments
  • lsmLoop
TgxNormalSmoothing = (...);

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing

Values
  • nsFlat
  • nsSmooth
  • nsNone
TgxPlaneStyle = (...);

This item has no description.

Values
  • psSingleQuad
  • psTileTexture
TgxPlaneStyles = set of TgxPlaneStyle;

This item has no description.

TgxPointStyle = (...);

This item has no description.

Values
  • psSquare
  • psRound
  • psSmooth
  • psSmoothAdditive
  • psSquareAdditive
TgxVisibilityDeterminationEvent = function(Sender: TObject; var rci: TgxRenderContextInfo): Boolean of object;

This item has no description.

TLineNodesAspect = (...);

Possible aspects for the nodes of a TLine.

Values
  • lnaInvisible
  • lnaAxes
  • lnaCube
TLinesOption = (...);

This item has no description.

Values
  • loUseNodeColorForLines
  • loColorLogicXor

Constants

cDefaultPointSize: Single = 1.0;

This item has no description.

Variables

TangentAttributeName: AnsiString = 'Tangent';

This item has no description.

BinormalAttributeName: AnsiString = 'Binormal';


GXSysHelp v.2.5: GXS.Objects: Record TVertexRec

Record TVertexRec

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TVertexRec = record

Description

This item has no description.

Overview

Fields

Public | Position: TVector3f;
Public | Normal: TVector3f;
Public | Binormal: TVector3f;
Public | Tangent: TVector3f;
Public | TexCoord: TVector2f;

Description

Fields

Public Position: TVector3f;

This item has no description.

Public Normal: TVector3f;

This item has no description.

Public Binormal: TVector3f;

This item has no description.

Public Tangent: TVector3f;

This item has no description.

Public TexCoord: TVector2f;


GXSysHelp v.2.5: GXS.Objects: Class TgxDummyCube

Class TgxDummyCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxDummyCube = class(TgxCameraInvariantObject)

Description

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxCameraInvariantObject
  • TgxDummyCube

Overview

Fields

Private | FCubeSize: Single;
Private | FEdgeColor: TgxColor;
Private | FVisibleAtRunTime: Boolean;
Private | FAmalgamate: Boolean;
Private | FGroupList: TgxListHandle;
Private | FOnVisibilityDetermination: TgxVisibilityDeterminationEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function BarycenterAbsolutePosition: TVector4f; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;

Properties

Published | property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;
Published | property CamInvarianceMode default cimNone;
Published | property CubeSize: Single read FCubeSize write SetCubeSize;
Published | property EdgeColor: TgxColor read FEdgeColor write SetEdgeColor;
Published | property OnVisibilityDetermination: TgxVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Fields

Private FCubeSize: Single;

This item has no description.

Private FEdgeColor: TgxColor;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private FAmalgamate: Boolean;

This item has no description.

Private FGroupList: TgxListHandle;

This item has no description.

Private FOnVisibilityDetermination: TgxVisibilityDeterminationEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;

Amalgamate the dummy's children in a single OpenGL entity. This activates a special rendering mode, which will compile the rendering of all of the dummycube's children objects into a single display list. This may provide a significant speed up in some situations, however, this means that changes to the children will be ignored untill you call StructureChanged on the dummy cube. Some objects, that have their own display list management, may not be compatible with this behaviour. This will also prevents sorting and culling to operate as usual. In short, this features is best used for static, non-transparent geometry, or when the point of view won't change over a large number of frames.

Published property CamInvarianceMode default cimNone;

Camera Invariance Options. These options allow to "deactivate" sensitivity to camera, f.i. by centering the object on the camera or ignoring camera orientation.

Published property CubeSize: Single read FCubeSize write SetCubeSize;

This item has no description.

Published property EdgeColor: TgxColor read FEdgeColor write SetEdgeColor;

This item has no description.

Published property OnVisibilityDetermination: TgxVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;

Event for custom visibility determination. Event handler should return True if the dummycube and its children are to be considered visible for the current render.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

If true the dummycube's edges will be visible at runtime. The default behaviour of the dummycube is to be visible at design-time only, and invisible at runtime.


GXSysHelp v.2.5: GXS.Objects: Class TgxPlane

Class TgxPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxPlane = class(TgxSceneObject)

Description

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPlane

Overview

Fields

Private | FXOffset: Single;
Private | FYOffset: Single;
Private | FXScope: Single;
Private | FYScope: Single;
Private | FWidth: Single;
Private | FHeight: Single;
Private | FXTiles: Cardinal;
Private | FYTiles: Cardinal;
Private | FStyle: TgxPlaneStyles;
Private | FMesh: array of array of TVertexRec;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;
Public | function PointDistance(const aPoint: TVector4f): Single;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Public | function ScreenRect(aBuffer: TgxSceneBuffer): TRect;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Height: Single read FHeight write SetHeight;
Published | property Style: TgxPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];
Published | property Width: Single read FWidth write SetWidth;
Published | property XOffset: Single read FXOffset write SetXOffset;
Published | property XScope: Single read FXScope write SetXScope stored StoreXScope;
Published | property XTiles: Cardinal read FXTiles write SetXTiles default 1;
Published | property YOffset: Single read FYOffset write SetYOffset;
Published | property YScope: Single read FYScope write SetYScope stored StoreYScope;
Published | property YTiles: Cardinal read FYTiles write SetYTiles default 1;

Description

Fields

Private FXOffset: Single;

This item has no description.

Private FYOffset: Single;

This item has no description.

Private FXScope: Single;

This item has no description.

Private FYScope: Single;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FXTiles: Cardinal;

This item has no description.

Private FYTiles: Cardinal;

This item has no description.

Private FStyle: TgxPlaneStyles;

This item has no description.

Private FMesh: array of array of TVertexRec;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function PointDistance(const aPoint: TVector4f): Single;

Computes the signed distance to the point. Point coordinates are expected in absolute coordinates.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function ScreenRect(aBuffer: TgxSceneBuffer): TRect;

Computes the screen coordinates of the smallest rectangle encompassing the plane. Returned extents are NOT limited to any physical screen extents.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Height: Single read FHeight write SetHeight;

This item has no description.

Published property Style: TgxPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];

This item has no description.

Published property Width: Single read FWidth write SetWidth;

This item has no description.

Published property XOffset: Single read FXOffset write SetXOffset;

This item has no description.

Published property XScope: Single read FXScope write SetXScope stored StoreXScope;

This item has no description.

Published property XTiles: Cardinal read FXTiles write SetXTiles default 1;

This item has no description.

Published property YOffset: Single read FYOffset write SetYOffset;

This item has no description.

Published property YScope: Single read FYScope write SetYScope stored StoreYScope;

This item has no description.

Published property YTiles: Cardinal read FYTiles write SetYTiles default 1;


GXSysHelp v.2.5: GXS.Objects: Class TgxSprite

Class TgxSprite

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxSprite = class(TgxSceneObject)

Description

A rectangular area, perspective projected, but always facing the camera. A TgxSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TgxHUDSprite.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxSprite

Overview

Fields

Private | FWidth: Single;
Private | FHeight: Single;
Private | FRotation: Single;
Private | FAlphaChannel: Single;
Private | FMirrorU: Boolean;
Private | FMirrorV: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure SetSize(const Width, Height: Single);
Public | procedure SetSquareSize(const Size: Single);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Height: Single read FHeight write SetHeight;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU default False;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV default False;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FWidth: Single;

This item has no description.

Private FHeight: Single;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FAlphaChannel: Single;

This item has no description.

Private FMirrorU: Boolean;

This item has no description.

Private FMirrorV: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure SetSize(const Width, Height: Single);

This item has no description.

Public procedure SetSquareSize(const Size: Single);

Set width and height to "size"

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;

If different from 1, this value will replace that of Diffuse.Alpha

Published property Height: Single read FHeight write SetHeight;

Sprite Height in 3D world units.

Published property MirrorU: Boolean read FMirrorU write SetMirrorU default False;

Reverses the texture coordinates in the U and V direction to mirror the texture.

Published property MirrorV: Boolean read FMirrorV write SetMirrorV default False;

This item has no description.

Published property Rotation: Single read FRotation write SetRotation;

This the ON-SCREEN rotation of the sprite. Rotatation=0 is handled faster.

Published property Width: Single read FWidth write SetWidth;

Sprite Width in 3D world units.


GXSysHelp v.2.5: GXS.Objects: Class TgxPointParameters

Class TgxPointParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxPointParameters = class(TgxUpdateAbleObject)

Description

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.

Hierarchy

  • TgxUpdateAbleObject
  • TgxPointParameters

Overview

Fields

Private | FEnabled: Boolean;
Private | FMinSize: Single;
Private | FMaxSize: Single;
Private | FFadeTresholdSize: Single;
Private | FDistanceAttenuation: TgxCoordinates;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure UnApply;

Properties

Published | property DistanceAttenuation: TgxCoordinates read FDistanceAttenuation write SetDistanceAttenuation;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;
Published | property MaxSize: Single read FMaxSize write SetMaxSize stored False;
Published | property MinSize: Single read FMinSize write SetMinSize stored False;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FMinSize: Single;

This item has no description.

Private FMaxSize: Single;

This item has no description.

Private FFadeTresholdSize: Single;

This item has no description.

Private FDistanceAttenuation: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure UnApply;

This item has no description.

Properties

Published property DistanceAttenuation: TgxCoordinates read FDistanceAttenuation write SetDistanceAttenuation;

Components XYZ are for constant, linear and quadratic attenuation.

Published property Enabled: Boolean read FEnabled write SetEnabled default False;

This item has no description.

Published property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;

This item has no description.

Published property MaxSize: Single read FMaxSize write SetMaxSize stored False;

This item has no description.

Published property MinSize: Single read FMinSize write SetMinSize stored False;


GXSysHelp v.2.5: GXS.Objects: Class TgxPoints

Class TgxPoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxPoints = class(TgxImmaterialSceneObject)

Description

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxPoints

Overview

Fields

Private | FPositions: TgxAffineVectorList;
Private | FColors: TgxVectorList;
Private | FSize: Single;
Private | FStyle: TgxPointStyle;
Private | FPointParameters: TgxPointParameters;
Private | FStatic: Boolean;
Private | FNoZWrite: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Public | property Colors: TgxVectorList read FColors write SetColors;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property PointParameters: TgxPointParameters read FPointParameters write SetPointParameters;
Public | property Positions: TgxAffineVectorList read FPositions write SetPositions;
Published | property Size: Single read FSize write SetSize stored StoreSize;
Published | property Static: Boolean read FStatic write SetStatic;
Published | property Style: TgxPointStyle read FStyle write SetStyle default psSquare;

Description

Fields

Private FPositions: TgxAffineVectorList;

This item has no description.

Private FColors: TgxVectorList;

This item has no description.

Private FSize: Single;

This item has no description.

Private FStyle: TgxPointStyle;

This item has no description.

Private FPointParameters: TgxPointParameters;

This item has no description.

Private FStatic: Boolean;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Public property Colors: TgxVectorList read FColors write SetColors;

Defines the points colors. if empty, point color will be opaque white if contains a single color, all points will use that color if contains N colors, the first N points (at max) will be rendered using the corresponding colors.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If true points do not write their Z to the depth buffer.

Published property PointParameters: TgxPointParameters read FPointParameters write SetPointParameters;

Point parameters as of ARB_point_parameters. Allows to vary the size and transparency of points depending on their distance to the observer.

Public property Positions: TgxAffineVectorList read FPositions write SetPositions;

Points positions. If empty, a single point is assumed at (0, 0, 0)

Published property Size: Single read FSize write SetSize stored StoreSize;

Point size, all points have a fixed size.

Published property Static: Boolean read FStatic write SetStatic;

Tells the component if point coordinates are static. If static, changes to the positions should be notified via an explicit StructureChanged call, or may not refresh. Static sets of points may render faster than dynamic ones.

Published property Style: TgxPointStyle read FStyle write SetStyle default psSquare;

Points style.


GXSysHelp v.2.5: GXS.Objects: Class TgxLinesNode

Class TgxLinesNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxLinesNode = class(TgxNode)

Description

Specialized Node for use in a TgxLines objects. Adds a Color property (TgxColor).

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxNode
  • TgxLinesNode

Overview

Fields

Private FColor: TgxColor;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Color: TgxColor read FColor write SetColor stored StoreColor;

Description

Fields

Private FColor: TgxColor;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TgxColor read FColor write SetColor stored StoreColor;

The node color. Can also defined the line color (interpolated between nodes) if loUseNodeColorForLines is set (in TgxLines).


GXSysHelp v.2.5: GXS.Objects: Class TgxLinesNodes

Class TgxLinesNodes

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxLinesNodes = class(TgxNodes)

Description

Specialized collection for Nodes in a TgxLines objects. Stores TgxLinesNode items.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxNodes
  • TgxLinesNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | procedure NotifyChange; override;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;

This item has no description.

Public procedure NotifyChange; override;


GXSysHelp v.2.5: GXS.Objects: Class TgxLineBase

Class TgxLineBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxLineBase = class(TgxImmaterialSceneObject)

Description

Base class for line objects. Introduces line style properties (width, color...)

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase

Overview

Fields

Private | FLineColor: TgxColor;
Private | FLinePattern: GLushort;
Private | FLineWidth: Single;
Private | FAntiAliased: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;
Published | property LineColor: TgxColor read FLineColor write SetLineColor;
Published | property LinePattern: GLushort read FLinePattern write SetLinePattern default $FFFF;
Published | property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;
Published | property Visible;

Description

Fields

Private FLineColor: TgxColor;

This item has no description.

Private FLinePattern: GLushort;

This item has no description.

Private FLineWidth: Single;

This item has no description.

Private FAntiAliased: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;

Indicates if OpenGL should smooth line edges. Smoothed lines looks better but are poorly implemented in most OpenGL drivers and take *lots* of rendering time.

Published property LineColor: TgxColor read FLineColor write SetLineColor;

Default color of the lines.

Published property LinePattern: GLushort read FLinePattern write SetLinePattern default $FFFF;

Bitwise line pattern. For instance $FFFF (65535) is a white line (stipple disabled), $0000 is a black line, $CCCC is the stipple used in axes and dummycube, etc.

Published property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;

Default width of the lines.

Published property Visible;


GXSysHelp v.2.5: GXS.Objects: Class TgxNodedLines

Class TgxNodedLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxNodedLines = class(TgxLineBase)

Description

Class that defines lines via a series of nodes. Base class, does not render anything.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase
  • TgxNodedLines

Overview

Fields

Private | FNodes: TgxLinesNodes;
Private | FNodesAspect: TLineNodesAspect;
Private | FNodeColor: TgxColor;
Private | FNodeSize: Single;
Private | FOldNodeColor: TgxColorVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure AddNode(const Value: TVector4f); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const X, Y, Z: Single); overload;
Public | procedure AddNode(const coords: TgxCoordinates); overload;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property NodeColor: TgxColor read FNodeColor write SetNodeColor;
Published | property Nodes: TgxLinesNodes read FNodes write SetNodes;
Published | property NodesAspect: TLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;
Published | property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;

Description

Fields

Private FNodes: TgxLinesNodes;

This item has no description.

Private FNodesAspect: TLineNodesAspect;

This item has no description.

Private FNodeColor: TgxColor;

This item has no description.

Private FNodeSize: Single;

This item has no description.

Private FOldNodeColor: TgxColorVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure AddNode(const Value: TVector4f); overload;

This item has no description.

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure AddNode(const X, Y, Z: Single); overload;

This item has no description.

Public procedure AddNode(const coords: TgxCoordinates); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property NodeColor: TgxColor read FNodeColor write SetNodeColor;

Default color for nodes. lnaInvisible and lnaAxes ignore this setting.

Published property Nodes: TgxLinesNodes read FNodes write SetNodes;

The nodes list.

Published property NodesAspect: TLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;

Default aspect of line nodes. May help you materialize nodes, segments and control points.

Published property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;

Size for the various node aspects.


GXSysHelp v.2.5: GXS.Objects: Class TgxLines

Class TgxLines

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxLines = class(TgxNodedLines)

Description

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxLineBase
  • TgxNodedLines
  • TgxLines

Overview

Fields

Private | FDivision: Integer;
Private | FSplineMode: TgxLineSplineMode;
Private | FOptions: TgxLinesOptions;
Private | FNURBSOrder: Integer;
Private | FNURBSTolerance: Single;
Private | FNURBSKnots: TgxSingleList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Public | property NURBSKnots: TgxSingleList read FNURBSKnots;
Public | property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;
Public | property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;
Published | property Options: TgxLinesOptions read FOptions write SetOptions;
Published | property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TgxLineSplineMode;

This item has no description.

Private FOptions: TgxLinesOptions;

This item has no description.

Private FNURBSOrder: Integer;

This item has no description.

Private FNURBSTolerance: Single;

This item has no description.

Private FNURBSKnots: TgxSingleList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Public property NURBSKnots: TgxSingleList read FNURBSKnots;

This item has no description.

Public property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;

This item has no description.

Public property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;

This item has no description.

Published property Options: TgxLinesOptions read FOptions write SetOptions;

Rendering options for the line. loUseNodeColorForLines: if set lines will be drawn using node colors (and color interpolation between nodes), if not, LineColor will be used (single color). loColorLogicXor: enable logic operation for color of XOR type.

Published property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode.


GXSysHelp v.2.5: GXS.Objects: Class TgxCube

Class TgxCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxCube = class(TgxSceneObject)

Description

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TgxFreeForm and a material library.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxCube

Overview

Fields

Private | FCubeSize: TAffineVector;
Private | FParts: TgxCubeParts;
Private | FNormalDirection: TgxNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Private | function GetCubeWHD(const Index: Integer): Single; inline;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Private | procedure SetCubeWHD(Index: Integer; AValue: Single); inline;
Private | procedure SetNormalDirection(aValue: TgxNormalDirection); inline;
Private | procedure SetParts(aValue: TgxCubeParts); inline;

Properties

Published | property CubeDepth: Single index 2 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeHeight: Single index 1 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeWidth: Single index 0 read GetCubeWHD write SetCubeWHD stored False;
Published | property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TgxCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];

Description

Fields

Private FCubeSize: TAffineVector;

This item has no description.

Private FParts: TgxCubeParts;

This item has no description.

Private FNormalDirection: TgxNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Private function GetCubeWHD(const Index: Integer): Single; inline;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetCubeWHD(Index: Integer; AValue: Single); inline;

This item has no description.

Private procedure SetNormalDirection(aValue: TgxNormalDirection); inline;

This item has no description.

Private procedure SetParts(aValue: TgxCubeParts); inline;

This item has no description.

Properties

Published property CubeDepth: Single index 2 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property CubeHeight: Single index 1 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property CubeWidth: Single index 0 read GetCubeWHD write SetCubeWHD stored False;

This item has no description.

Published property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Parts: TgxCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];


GXSysHelp v.2.5: GXS.Objects: Class TgxQuadricObject

Class TgxQuadricObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxQuadricObject = class(TgxSceneObject)

Description

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject

Overview

Fields

Private | FNormals: TgxNormalSmoothing;
Private | FNormalDirection: TgxNormalDirection;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsSmooth;

Description

Fields

Private FNormals: TgxNormalSmoothing;

This item has no description.

Private FNormalDirection: TgxNormalDirection;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property NormalDirection: TgxNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;

This item has no description.

Published property Normals: TgxNormalSmoothing read FNormals write SetNormals default nsSmooth;


GXSysHelp v.2.5: GXS.Objects: Class TgxSphere

Class TgxSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxSphere = class(TgxQuadricObject)

Description

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxSphere

Overview

Fields

Private | FRadius: Single;
Private | FSlices: GLint;
Private | FStacks: GLint;
Private | FTop: TAngleLimit1;
Private | FBottom: TAngleLimit1;
Private | FStart: TAngleLimit2;
Private | FStop: TAngleLimit2;
Private | FTopCap: TgxCapType;
Private | FBottomCap: TgxCapType;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Private | procedure SetBottom(aValue: TAngleLimit1);
Private | procedure SetBottomCap(aValue: TgxCapType);
Private | procedure SetRadius(const aValue: Single);
Private | procedure SetSlices(aValue: GLint);
Private | procedure SetStacks(aValue: GLint);
Private | procedure SetStart(aValue: TAngleLimit2);
Private | procedure SetStop(aValue: TAngleLimit2);
Private | procedure SetTop(aValue: TAngleLimit1);
Private | procedure SetTopCap(aValue: TgxCapType);

Properties

Published | property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;
Published | property BottomCap: TgxCapType read FBottomCap write SetBottomCap default ctNone;
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: GLint read FSlices write SetSlices default 16;
Published | property Stacks: GLint read FStacks write SetStacks default 16;
Published | property Start: TAngleLimit2 read FStart write SetStart default 0;
Published | property Stop: TAngleLimit2 read FStop write SetStop default 360;
Published | property Top: TAngleLimit1 read FTop write SetTop default 90;
Published | property TopCap: TgxCapType read FTopCap write SetTopCap default ctNone;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FSlices: GLint;

This item has no description.

Private FStacks: GLint;

This item has no description.

Private FTop: TAngleLimit1;

This item has no description.

Private FBottom: TAngleLimit1;

This item has no description.

Private FStart: TAngleLimit2;

This item has no description.

Private FStop: TAngleLimit2;

This item has no description.

Private FTopCap: TgxCapType;

This item has no description.

Private FBottomCap: TgxCapType;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetBottom(aValue: TAngleLimit1);

This item has no description.

Private procedure SetBottomCap(aValue: TgxCapType);

This item has no description.

Private procedure SetRadius(const aValue: Single);

This item has no description.

Private procedure SetSlices(aValue: GLint);

This item has no description.

Private procedure SetStacks(aValue: GLint);

This item has no description.

Private procedure SetStart(aValue: TAngleLimit2);

This item has no description.

Private procedure SetStop(aValue: TAngleLimit2);

This item has no description.

Private procedure SetTop(aValue: TAngleLimit1);

This item has no description.

Private procedure SetTopCap(aValue: TgxCapType);

This item has no description.

Properties

Published property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;

This item has no description.

Published property BottomCap: TgxCapType read FBottomCap write SetBottomCap default ctNone;

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: GLint read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: GLint read FStacks write SetStacks default 16;

This item has no description.

Published property Start: TAngleLimit2 read FStart write SetStart default 0;

This item has no description.

Published property Stop: TAngleLimit2 read FStop write SetStop default 360;

This item has no description.

Published property Top: TAngleLimit1 read FTop write SetTop default 90;

This item has no description.

Published property TopCap: TgxCapType read FTopCap write SetTopCap default ctNone;


GXSysHelp v.2.5: GXS.Objects: Class TgxPolygonBase

Class TgxPolygonBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxPolygonBase = class(TgxSceneObject)

Description

Base class for objects based on a polygon.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPolygonBase

Overview

Fields

Private | FDivision: Integer;
Private | FSplineMode: TgxLineSplineMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddNode(const X, Y, Z: Single); overload;
Public | procedure AddNode(const Value: TVector4f); overload;
Public | procedure AddNode(const coords: TgxCoordinates); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TgxNodes read FNodes write SetNodes;
Published | property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Private FDivision: Integer;

This item has no description.

Private FSplineMode: TgxLineSplineMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddNode(const X, Y, Z: Single); overload;

This item has no description.

Public procedure AddNode(const Value: TVector4f); overload;

This item has no description.

Public procedure AddNode(const coords: TgxCoordinates); overload;

This item has no description.

Public procedure AddNode(const Value: TAffineVector); overload;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes. Minimum 1 (disabled), ignored in lsmLines mode.

Published property Nodes: TgxNodes read FNodes write SetNodes;

The nodes list.

Published property SplineMode: TgxLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode. This mode is used only for the curve, not for the rotation path.


GXSysHelp v.2.5: GXS.Objects: Class TgxSuperellipsoid

Class TgxSuperellipsoid

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Objects

Declaration

type TgxSuperellipsoid = class(TgxQuadricObject)

Description

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxQuadricObject
  • TgxSuperellipsoid

Overview

Fields

Private | FRadius: Single;
Private | FVCurve: Single;
Private | FHCurve: Single;
Private | FSlices: GLInt;
Private | FStacks: GLInt;
Private | FTop: TAngleLimit1;
Private | FBottom: TAngleLimit1;
Private | FStart: TAngleLimit2;
Private | FStop: TAngleLimit2;
Private | FTopCap: TgxCapType;
Private | FBottomCap: TgxCapType;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Private | procedure SetBottom(aValue: TAngleLimit1);
Private | procedure SetBottomCap(aValue: TgxCapType);
Private | procedure SetHCurve(const aValue: Single);
Private | procedure SetRadius(const aValue: Single);
Private | procedure SetSlices(aValue: GLInt);
Private | procedure SetStacks(aValue: GLint);
Private | procedure SetStart(aValue: TAngleLimit2);
Private | procedure SetStop(aValue: TAngleLimit2);
Private | procedure SetTop(aValue: TAngleLimit1);
Private | procedure SetTopCap(aValue: TgxCapType);
Private | procedure SetVCurve(const aValue: Single);

Properties

Published | property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;
Published | property BottomCap: TgxCapType read FBottomCap write SetBottomCap default ctNone;
Published | property HCurve: Single read FHCurve write SetHCurve;
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: GLInt read FSlices write SetSlices default 16;
Published | property Stacks: GLInt read FStacks write SetStacks default 16;
Published | property Start: TAngleLimit2 read FStart write SetStart default 0;
Published | property Stop: TAngleLimit2 read FStop write SetStop default 360;
Published | property Top: TAngleLimit1 read FTop write SetTop default 90;
Published | property TopCap: TgxCapType read FTopCap write SetTopCap default ctNone;
Published | property VCurve: Single read FVCurve write SetVCurve;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FVCurve: Single;

This item has no description.

Private FHCurve: Single;

This item has no description.

Private FSlices: GLInt;

This item has no description.

Private FStacks: GLInt;

This item has no description.

Private FTop: TAngleLimit1;

This item has no description.

Private FBottom: TAngleLimit1;

This item has no description.

Private FStart: TAngleLimit2;

This item has no description.

Private FStop: TAngleLimit2;

This item has no description.

Private FTopCap: TgxCapType;

This item has no description.

Private FBottomCap: TgxCapType;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters : TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Private procedure SetBottom(aValue: TAngleLimit1);

This item has no description.

Private procedure SetBottomCap(aValue: TgxCapType);

This item has no description.

Private procedure SetHCurve(const aValue: Single);

This item has no description.

Private procedure SetRadius(const aValue: Single);

This item has no description.

Private procedure SetSlices(aValue: GLInt);

This item has no description.

Private procedure SetStacks(aValue: GLint);

This item has no description.

Private procedure SetStart(aValue: TAngleLimit2);

This item has no description.

Private procedure SetStop(aValue: TAngleLimit2);

This item has no description.

Private procedure SetTop(aValue: TAngleLimit1);

This item has no description.

Private procedure SetTopCap(aValue: TgxCapType);

This item has no description.

Private procedure SetVCurve(const aValue: Single);

This item has no description.

Properties

Published property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;

This item has no description.

Published property BottomCap: TgxCapType read FBottomCap write SetBottomCap default ctNone;

This item has no description.

Published property HCurve: Single read FHCurve write SetHCurve;

This item has no description.

Published property Radius: Single read FRadius write SetRadius;

This item has no description.

Published property Slices: GLInt read FSlices write SetSlices default 16;

This item has no description.

Published property Stacks: GLInt read FStacks write SetStacks default 16;

This item has no description.

Published property Start: TAngleLimit2 read FStart write SetStart default 0;

This item has no description.

Published property Stop: TAngleLimit2 read FStop write SetStop default 360;

This item has no description.

Published property Top: TAngleLimit1 read FTop write SetTop default 90;

This item has no description.

Published property TopCap: TgxCapType read FTopCap write SetTopCap default ctNone;

This item has no description.

Published property VCurve: Single read FVCurve write SetVCurve;


GXSysHelp v.2.5: GXS.Octree

Unit GXS.Octree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.GeometryBB
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxOctreeTriangleInfo |
Record TgxOctreeNode |
Class TgxOctree |

Types

PgxOctreeNode = ˆTgxOctreeNode;
PgxOctreeTriangleInfo = ˆTgxOctreeTriangleInfo;
TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;
TProcInt = procedure(I: Integer) of object;

Description

Types

PgxOctreeNode = ˆTgxOctreeNode;

This item has no description.

PgxOctreeTriangleInfo = ˆTgxOctreeTriangleInfo;

This item has no description.

TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;

This item has no description.

TProcInt = procedure(I: Integer) of object;


GXSysHelp v.2.5: GXS.Octree: Record TgxOctreeTriangleInfo

Record TgxOctreeTriangleInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Octree

Declaration

type TgxOctreeTriangleInfo = record

Description

Stores information about an intersected triangle.

Overview

Fields

Public | Index: Integer;
Public | Vertex: array [0 .. 2] of TAffineVector;

Description

Fields

Public Index: Integer;

This item has no description.

Public Vertex: array [0 .. 2] of TAffineVector;


GXSysHelp v.2.5: GXS.Octree: Record TgxOctreeNode

Record TgxOctreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Octree

Declaration

type TgxOctreeNode = record

Description

This item has no description.

Overview

Fields

Public | MinExtent: TAffineFLTVector;
Public | MaxExtent: TAffineFLTVector;
Public | ListHandle: TgxListHandle;
Public | WillDraw: Boolean;
Public | TriArray: array of Integer;
Public | ChildArray: array [0 .. 7] of PgxOctreeNode;

Description

Fields

Public MinExtent: TAffineFLTVector;

This item has no description.

Public MaxExtent: TAffineFLTVector;

This item has no description.

Public ListHandle: TgxListHandle;

TextureHandle:TgxTextureHandle;

Public WillDraw: Boolean;

This item has no description.

Public TriArray: array of Integer;

temporary change Duplicates possible?

Public ChildArray: array [0 .. 7] of PgxOctreeNode;

array of triangle references


GXSysHelp v.2.5: GXS.Octree: Class TgxOctree

Class TgxOctree

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Octree

Declaration

type TgxOctree = class(TObject)

Description

Manages an Octree containing references to triangles.

Hierarchy

  • TObject
  • TgxOctree

Overview

Fields

Public | WorldMinExtent: TAffineFLTVector;
Public | WorldMaxExtent: TAffineFLTVector;
Public | RootNode: PgxOctreeNode;
Public | MaxOlevel: Integer;
Public | NodeCount: Integer;
Public | TriCountMesh: Integer;
Public | TriCountOctree: Integer;
Public | MeshCount: Integer;
Public | ResultArray: array of PgxOctreeNode;
Public | TriangleFiler: TgxAffineVectorList;

Methods

Public | destructor Destroy; override;
Public | function AABBIntersect(const AABB: TAABB; M1to2, M2to1: TMatrix4f; Triangles: TgxAffineVectorList = nil): Boolean;
Public | function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TgxAffineVectorList;
Public | function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TMatrix4f): TgxAffineVectorList;
Public | function RayCastIntersect(const RayStart, RayVector: TVector4f; IntersectPoint: PVector4f = nil; IntersectNormal: PVector4f = nil; TriangleInfo: PgxOctreeTriangleInfo = nil): Boolean;
Public | function SphereSweepIntersect(const RayStart, RayVector: TVector4f; const Velocity, Radius: Single; IntersectPoint: PVector4f = nil; IntersectNormal: PVector4f = nil): Boolean;
Public | function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;
Public | procedure DisposeTree;
Public | procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TgxAffineVectorList; const ATreeDepth: Integer);
Public | procedure WalkSphereToLeaf(Onode: PgxOctreeNode; const P: TVector4f; Radius: Single);

Description

Fields

Public WorldMinExtent: TAffineFLTVector;

This item has no description.

Public WorldMaxExtent: TAffineFLTVector;

This item has no description.

Public RootNode: PgxOctreeNode;

This item has no description.

Public MaxOlevel: Integer;

always points to root node

Public NodeCount: Integer;

max depth level of TgxOctreeNode

Public TriCountMesh: Integer;

number of nodes (ex: 8 for level 1, 72 for level 2 etc).

Public TriCountOctree: Integer;

total number of triangles in the mesh

Public MeshCount: Integer;

total number of triangles cut into the octree

Public ResultArray: array of PgxOctreeNode;

number of meshes currently cut into the Octree

Public TriangleFiler: TgxAffineVectorList;

holds the result nodes of various calls Needed this change - Used in ECMisc.pas

Methods

Public destructor Destroy; override;

This item has no description.

Public function AABBIntersect(const AABB: TAABB; M1to2, M2to1: TMatrix4f; Triangles: TgxAffineVectorList = nil): Boolean;

Checks if an AABB intersects a face on the octree

Public function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TgxAffineVectorList;

Returns all triangles in the AABB.

Public function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TMatrix4f): TgxAffineVectorList;

Returns all triangles in an arbitrarily placed cube

Public function RayCastIntersect(const RayStart, RayVector: TVector4f; IntersectPoint: PVector4f = nil; IntersectNormal: PVector4f = nil; TriangleInfo: PgxOctreeTriangleInfo = nil): Boolean;

This item has no description.

Public function SphereSweepIntersect(const RayStart, RayVector: TVector4f; const Velocity, Radius: Single; IntersectPoint: PVector4f = nil; IntersectNormal: PVector4f = nil): Boolean;

This item has no description.

Public function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;

This item has no description.

Public procedure DisposeTree;

This item has no description.

Public procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TgxAffineVectorList; const ATreeDepth: Integer);

Initializes the tree from the triangle list. All triangles must be contained in the world extent to be properly taken into account.

Public procedure WalkSphereToLeaf(Onode: PgxOctreeNode; const P: TVector4f; Radius: Single);


GXSysHelp v.2.5: GXS.ODEManager

Unit GXS.ODEManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GXS.XOpenGL
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLScene.Manager
  • GXS.Scene
  • GXS.Texture
  • GXS.Objects
  • GXS.PersistentClasses
  • GXS.VectorLists
  • GXS.Color
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.VectorTypes
  • GXS.TerrainRenderer
  • GXS.Graph
  • GXS.ODEUtils
  • ODE.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxODEManager |
Class TgxODECollisionSurface |
Class TgxODEBehaviour |
Class TgxODEDynamic |
Class TgxODEStatic |
Class TgxODEElements |
Class TgxODEElementBase |
Class TgxODEElementBox |
Class TgxODEElementSphere |
Class TgxODEElementCapsule |
Class TgxODEElementCylinder |
Class TgxODEElementTriMesh |
Class TgxODEElementPlane |
Class TgxODEJoints |
Class TgxODEJointList |
Class TgxODEJointBase |
Class TgxODEJointParams |
Class TgxODEJointHinge |
Class TgxODEJointBall |
Class TgxODEJointSlider |
Class TgxODEJointFixed |
Class TgxODEJointHinge2 |
Class TgxODEJointUniversal |
Class TgxODEContactPoint |
Class TgxODECustomCollider |
Class TgxODEHeightField |

Functions and Procedures

procedure nearCallBack(Data: Pointer; o1, o2: PdxGeom); cdecl;
function GetBodyFromObject(anObject: TObject): PdxBody;
function GetBodyFromGLXceneObject(anObject: TgxBaseSceneObject): PdxBody;
function GetSurfaceFromObject(anObject: TObject): TgxODECollisionSurface;
procedure RegisterGLXceneObject(anObject: TgxBaseSceneObject);
procedure UnregisterGLXceneObject(anObject: TgxBaseSceneObject);
function GetGLXceneObject(anObjectName: String): TgxBaseSceneObject;
function GetOdeStatic(obj: TgxBaseSceneObject): TgxODEStatic;
function GetOrCreateOdeStatic(obj: TgxBaseSceneObject): TgxODEStatic;
function GetOdeDynamic(obj: TgxBaseSceneObject): TgxODEDynamic;
function GetOrCreateOdeDynamic(obj: TgxBaseSceneObject): TgxODEDynamic;
function GetODEHeightField(obj: TgxBaseSceneObject): TgxODEHeightField;
function GetOrCreateODEHeightField(obj: TgxBaseSceneObject): TgxODEHeightField;

Types

TgxODECollisionEvent = procedure(Sender: TObject; Object1, Object2: TObject; var Contact: TdContact; var HandleCollision: Boolean) of object;
TgxODECollisionSurfaceMode = (...);
TgxODECustomCollisionEvent = procedure(Geom1, Geom2: PdxGeom) of object;
TgxODEElementClass = class of TgxODEElementBase;
TgxODEGetParamCallback = function(Param: Integer; var Value: TdReal): Boolean of object;
TgxODEObjectCollisionEvent = procedure(Sender: TObject; Object2: TObject; var Contact: TdContact; var HandleCollision: Boolean) of object;
TgxODESetParamCallback = function(Param: Integer; const Value: TdReal): Boolean of object;
TgxODESolverMethod = (...);
TgxSurfaceModes = set of TgxODECollisionSurfaceMode;
TJointOption = (...);
TJointOptions = set of TJointOption;

Variables

vODEObjectRegister: TList;
vCustomColliderClass: TdGeomClass;
vCustomColliderClassNum: Integer;

Description

Functions and Procedures

procedure nearCallBack(Data: Pointer; o1, o2: PdxGeom); cdecl;

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer

function GetBodyFromObject(anObject: TObject): PdxBody;

Helper functions for extracting data from objects with different inheritance.

function GetBodyFromGLXceneObject(anObject: TgxBaseSceneObject): PdxBody;

This item has no description.

function GetSurfaceFromObject(anObject: TObject): TgxODECollisionSurface;

This item has no description.

procedure RegisterGLXceneObject(anObject: TgxBaseSceneObject);

GLODEObject register methods (used for joint object persistence)

procedure UnregisterGLXceneObject(anObject: TgxBaseSceneObject);

This item has no description.

function GetGLXceneObject(anObjectName: String): TgxBaseSceneObject;

This item has no description.

function GetOdeStatic(obj: TgxBaseSceneObject): TgxODEStatic;

Get and GetOrCreate functions for ode behaviours

function GetOrCreateOdeStatic(obj: TgxBaseSceneObject): TgxODEStatic;

This item has no description.

function GetOdeDynamic(obj: TgxBaseSceneObject): TgxODEDynamic;

This item has no description.

function GetOrCreateOdeDynamic(obj: TgxBaseSceneObject): TgxODEDynamic;

This item has no description.

function GetODEHeightField(obj: TgxBaseSceneObject): TgxODEHeightField;

Get and GetOrCreate functions for ODE HeightField

function GetOrCreateODEHeightField(obj: TgxBaseSceneObject): TgxODEHeightField;

This item has no description.

Types

TgxODECollisionEvent = procedure(Sender: TObject; Object1, Object2: TObject; var Contact: TdContact; var HandleCollision: Boolean) of object;

This item has no description.

TgxODECollisionSurfaceMode = (...);

This item has no description.

Values
  • csmMu2
  • csmFDir1
  • csmBounce
  • csmSoftERP
  • csmSoftCFM
  • csmMotion1
  • csmMotion2
  • csmSlip1
  • csmSlip2
TgxODECustomCollisionEvent = procedure(Geom1, Geom2: PdxGeom) of object;

This item has no description.

TgxODEElementClass = class of TgxODEElementBase;

This item has no description.

TgxODEGetParamCallback = function(Param: Integer; var Value: TdReal): Boolean of object;

This item has no description.

TgxODEObjectCollisionEvent = procedure(Sender: TObject; Object2: TObject; var Contact: TdContact; var HandleCollision: Boolean) of object;

This item has no description.

TgxODESetParamCallback = function(Param: Integer; const Value: TdReal): Boolean of object;

This item has no description.

TgxODESolverMethod = (...);

This item has no description.

Values
  • osmDefault
  • osmStepFast
  • osmQuickStep
TgxSurfaceModes = set of TgxODECollisionSurfaceMode;

This item has no description.

TJointOption = (...);

This item has no description.

Values
  • joBothObjectsMustBeAssigned
TJointOptions = set of TJointOption;

This item has no description.

Variables

vODEObjectRegister: TList;

This item has no description.

vCustomColliderClass: TdGeomClass;

This item has no description.

vCustomColliderClassNum: Integer;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEManager

Class TgxODEManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEManager = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxODEManager

Overview

Fields

Private | FWorld: PdxWorld;
Private | FSpace: PdxSpace;
Private | FContactGroup: TdJointGroupID;
Private | FGravity: TgxCoordinates;
Private | FOnCollision: TgxODECollisionEvent;
Private | FOnCustomCollision: TgxODECustomCollisionEvent;
Private | FNumContactJoints: Integer;
Private | FMaxContacts: Integer;
Private | FODEBehaviours: TgxPersistentObjectList;
Private | FRFContactList: TList;
Private | FIterations: Integer;
Private | FSolver: TgxODESolverMethod;
Private | FContacts: array of TdContact;
Private | FContactGeoms: array of TdContactGeom;
Private | FRenderPoint: TgxRenderPoint;
Private | FVisible: Boolean;
Private | FVisibleAtRunTime: Boolean;
Private | FGeomColorDynD: TgxColor;
Private | FGeomColorDynE: TgxColor;
Private | FGeomColorStat: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Step(deltaTime: double);

Properties

Public | property ContactGroup: TdJointGroupID read FContactGroup;
Published | property GeomColorDynD: TgxColor read FGeomColorDynD write SetGeomColorDynD;
Published | property GeomColorDynE: TgxColor read FGeomColorDynE write SetGeomColorDynE;
Published | property GeomColorStat: TgxColor read FGeomColorStat write SetGeomColorStat;
Published | property Gravity: TgxCoordinates read FGravity write SetGravity;
Published | property Iterations: Integer read FIterations write SetIterations;
Published | property MaxContacts: Integer read FMaxContacts write SetMaxContacts;
Public | property NumContactJoints: Integer read FNumContactJoints;
Published | property OnCollision: TgxODECollisionEvent read FOnCollision write FOnCollision;
Published | property OnCustomCollision: TgxODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;
Published | property RenderPoint: TgxRenderPoint read FRenderPoint write SetRenderPoint;
Published | property Solver: TgxODESolverMethod read FSolver write FSolver;
Public | property Space: PdxSpace read FSpace;
Published | property Visible: Boolean read FVisible write SetVisible;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;
Public | property World: PdxWorld read FWorld;

Description

Fields

Private FWorld: PdxWorld;

This item has no description.

Private FSpace: PdxSpace;

This item has no description.

Private FContactGroup: TdJointGroupID;

This item has no description.

Private FGravity: TgxCoordinates;

This item has no description.

Private FOnCollision: TgxODECollisionEvent;

This item has no description.

Private FOnCustomCollision: TgxODECustomCollisionEvent;

This item has no description.

Private FNumContactJoints: Integer;

This item has no description.

Private FMaxContacts: Integer;

This item has no description.

Private FODEBehaviours: TgxPersistentObjectList;

This item has no description.

Private FRFContactList: TList;

This item has no description.

Private FIterations: Integer;

This item has no description.

Private FSolver: TgxODESolverMethod;

This item has no description.

Private FContacts: array of TdContact;

This item has no description.

Private FContactGeoms: array of TdContactGeom;

This item has no description.

Private FRenderPoint: TgxRenderPoint;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private FGeomColorDynD: TgxColor;

This item has no description.

Private FGeomColorDynE: TgxColor;

This item has no description.

Private FGeomColorStat: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Step(deltaTime: double);

This item has no description.

Properties

Public property ContactGroup: TdJointGroupID read FContactGroup;

This item has no description.

Published property GeomColorDynD: TgxColor read FGeomColorDynD write SetGeomColorDynD;

This item has no description.

Published property GeomColorDynE: TgxColor read FGeomColorDynE write SetGeomColorDynE;

This item has no description.

Published property GeomColorStat: TgxColor read FGeomColorStat write SetGeomColorStat;

This item has no description.

Published property Gravity: TgxCoordinates read FGravity write SetGravity;

This item has no description.

Published property Iterations: Integer read FIterations write SetIterations;

This item has no description.

Published property MaxContacts: Integer read FMaxContacts write SetMaxContacts;

This item has no description.

Public property NumContactJoints: Integer read FNumContactJoints;

This item has no description.

Published property OnCollision: TgxODECollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property OnCustomCollision: TgxODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;

This item has no description.

Published property RenderPoint: TgxRenderPoint read FRenderPoint write SetRenderPoint;

This item has no description.

Published property Solver: TgxODESolverMethod read FSolver write FSolver;

This item has no description.

Public property Space: PdxSpace read FSpace;

This item has no description.

Published property Visible: Boolean read FVisible write SetVisible;

This item has no description.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;

This item has no description.

Public property World: PdxWorld read FWorld;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODECollisionSurface

Class TgxODECollisionSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODECollisionSurface = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxODECollisionSurface

Overview

Fields

Private | FOwner: TPersistent;
Private | FSurfaceParams: TdSurfaceParameters;
Private | FRFCoeff: Single;
Private | FRFEnabled: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Bounce: TdReal read GetBounce write SetBounce;
Published | property Bounce_Vel: TdReal read GetBounce_Vel write SetBounce_Vel;
Published | property Motion1: TdReal read GetMotion1 write SetMotion1;
Published | property Motion2: TdReal read GetMotion2 write SetMotion2;
Published | property Mu: TdReal read GetMu write SetMu;
Published | property Mu2: TdReal read GetMu2 write SetMu2;
Published | property RollingFrictionCoeff: Single read FRFCoeff write FRFCoeff;
Published | property RollingFrictionEnabled: Boolean read FRFEnabled write FRFEnabled;
Published | property Slip1: TdReal read GetSlip1 write SetSlip1;
Published | property Slip2: TdReal read GetSlip2 write SetSlip2;
Published | property SoftCFM: TdReal read GetSoftCFM write SetSoftCFM;
Published | property SoftERP: TdReal read GetSoftERP write SetSoftERP;
Published | property SurfaceMode: TgxSurfaceModes read GetSurfaceMode write SetSurfaceMode;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FSurfaceParams: TdSurfaceParameters;

This item has no description.

Private FRFCoeff: Single;

This item has no description.

Private FRFEnabled: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Bounce: TdReal read GetBounce write SetBounce;

This item has no description.

Published property Bounce_Vel: TdReal read GetBounce_Vel write SetBounce_Vel;

This item has no description.

Published property Motion1: TdReal read GetMotion1 write SetMotion1;

This item has no description.

Published property Motion2: TdReal read GetMotion2 write SetMotion2;

This item has no description.

Published property Mu: TdReal read GetMu write SetMu;

This item has no description.

Published property Mu2: TdReal read GetMu2 write SetMu2;

This item has no description.

Published property RollingFrictionCoeff: Single read FRFCoeff write FRFCoeff;

This item has no description.

Published property RollingFrictionEnabled: Boolean read FRFEnabled write FRFEnabled;

This item has no description.

Published property Slip1: TdReal read GetSlip1 write SetSlip1;

This item has no description.

Published property Slip2: TdReal read GetSlip2 write SetSlip2;

This item has no description.

Published property SoftCFM: TdReal read GetSoftCFM write SetSoftCFM;

This item has no description.

Published property SoftERP: TdReal read GetSoftERP write SetSoftERP;

This item has no description.

Published property SurfaceMode: TgxSurfaceModes read GetSurfaceMode write SetSurfaceMode;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEBehaviour

Class TgxODEBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEBehaviour = class(TgxBehaviour)

Description

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxODEBehaviour

Overview

Fields

Private | FManager: TgxODEManager;
Private | FManagerName: String;
Private | FSurface: TgxODECollisionSurface;
Private | FOnCollision: TgxODEObjectCollisionEvent;
Private | FInitialized: Boolean;
Private | FOwnerBaseSceneObject: TgxBaseSceneObject;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Reinitialize;
Public | procedure Render(var rci: TgxRenderContextInfo); virtual;

Properties

Public | property AbsoluteMatrix: TMatrix4f read GetAbsoluteMatrix;
Public | property Initialized: Boolean read FInitialized;
Published | property Manager: TgxODEManager read FManager write SetManager;
Published | property OnCollision: TgxODEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Surface: TgxODECollisionSurface read FSurface write SetSurface;

Description

Fields

Private FManager: TgxODEManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FSurface: TgxODECollisionSurface;

This item has no description.

Private FOnCollision: TgxODEObjectCollisionEvent;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FOwnerBaseSceneObject: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Reinitialize;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo); virtual;

This item has no description.

Properties

Public property AbsoluteMatrix: TMatrix4f read GetAbsoluteMatrix;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Published property Manager: TgxODEManager read FManager write SetManager;

This item has no description.

Published property OnCollision: TgxODEObjectCollisionEvent read FOnCollision write FOnCollision;

This item has no description.

Published property Surface: TgxODECollisionSurface read FSurface write SetSurface;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEDynamic

Class TgxODEDynamic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEDynamic = class(TgxODEBehaviour)

Description

This item has no description. Showing description inherited from TgxODEBehaviour.

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxODEBehaviour
  • TgxODEDynamic

Overview

Fields

Private | FBody: PdxBody;
Private | FMass: TdMass;
Private | FElements: TgxODEElements;
Private | FEnabled: Boolean;
Private | FJointRegister: TList;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild: TgxODEElementClass): TgxODEElementBase; virtual;
Public | function CalculateMass: TdMass;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure AddForce(Force: TAffineVector);
Public | procedure AddForceAtPos(Force, Pos: TAffineVector);
Public | procedure AddForceAtRelPos(Force, Pos: TAffineVector);
Public | procedure AddRelForce(Force: TAffineVector);
Public | procedure AddRelForceAtPos(Force, Pos: TAffineVector);
Public | procedure AddRelForceAtRelPos(Force, Pos: TAffineVector);
Public | procedure AddRelTorque(Torque: TAffineVector);
Public | procedure AddTorque(Torque: TAffineVector);
Public | procedure AlignObject;
Public | procedure CalibrateCenterOfMass;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Public | property Body: PdxBody read FBody;
Published | property Elements: TgxODEElements read FElements;
Published | property Enabled: Boolean read GetEnabled write SetEnabled;
Public | property Mass: TdMass read GetMass write SetMass;

Description

Fields

Private FBody: PdxBody;

This item has no description.

Private FMass: TdMass;

This item has no description.

Private FElements: TgxODEElements;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FJointRegister: TList;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNewElement(AChild: TgxODEElementClass): TgxODEElementBase; virtual;

This item has no description.

Public function CalculateMass: TdMass;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure AddForce(Force: TAffineVector);

This item has no description.

Public procedure AddForceAtPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddForceAtRelPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelForce(Force: TAffineVector);

This item has no description.

Public procedure AddRelForceAtPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelForceAtRelPos(Force, Pos: TAffineVector);

This item has no description.

Public procedure AddRelTorque(Torque: TAffineVector);

This item has no description.

Public procedure AddTorque(Torque: TAffineVector);

This item has no description.

Public procedure AlignObject;

This item has no description.

Public procedure CalibrateCenterOfMass;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Public property Body: PdxBody read FBody;

This item has no description.

Published property Elements: TgxODEElements read FElements;

This item has no description.

Published property Enabled: Boolean read GetEnabled write SetEnabled;

This item has no description.

Public property Mass: TdMass read GetMass write SetMass;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEStatic

Class TgxODEStatic

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEStatic = class(TgxODEBehaviour)

Description

This item has no description. Showing description inherited from TgxODEBehaviour.

Basis structures for behaviour style implementations.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxODEBehaviour
  • TgxODEStatic

Overview

Fields

Private FElements: TgxODEElements;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild: TgxODEElementClass): TgxODEElementBase; virtual;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published property Elements: TgxODEElements read FElements;

Description

Fields

Private FElements: TgxODEElements;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddNewElement(AChild: TgxODEElementClass): TgxODEElementBase; virtual;

This item has no description.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Elements: TgxODEElements read FElements;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElements

Class TgxODEElements

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElements = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxODEElements

Overview

Methods

Public | destructor Destroy; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Private | function GetElement(index: Integer): TgxODEElementBase;
Public | procedure Finalize;
Public | procedure Initialize;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure Render(var rci: TgxRenderContextInfo);

Properties

Public property Element[index: Integer]: TgxODEElementBase read GetElement;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Private function GetElement(index: Integer): TgxODEElementBase;

This item has no description.

Public procedure Finalize;

This item has no description.

Public procedure Initialize;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo);

This item has no description.

Properties

Public property Element[index: Integer]: TgxODEElementBase read GetElement;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementBase

Class TgxODEElementBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementBase = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase

Overview

Fields

Private | FMass: TdMass;
Private | FDensity: TdReal;
Private | FGeomTransform: PdxGeom;
Private | FGeomElement: PdxGeom;
Private | FPosition: TgxCoordinates;
Private | FDirection: TgxCoordinates;
Private | FUp: TgxCoordinates;
Private | FLocalMatrix: TMatrix4f;
Private | FRealignODE: Boolean;
Private | FInitialized: Boolean;
Private | FDynamic: Boolean;
Private | FIsCalculating: Boolean;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AbsoluteMatrix: TMatrix4f;
Public | function AbsolutePosition: TAffineVector;
Public | procedure Render(var rci: TgxRenderContextInfo); virtual;

Properties

Published | property Density: TdReal read FDensity write SetDensity;
Published | property Direction: TgxCoordinates read FDirection write SetDirection;
Public | property Geom: PdxGeom read FGeomElement;
Public | property GeomTransform: PdxGeom read FGeomTransform;
Public | property Initialized: Boolean read FInitialized;
Public | property Matrix: TMatrix4f read GetMatrix write SetMatrix;
Published | property Position: TgxCoordinates read FPosition write SetPosition;
Published | property Up: TgxCoordinates read FUp write SetUp;

Description

Fields

Private FMass: TdMass;

This item has no description.

Private FDensity: TdReal;

This item has no description.

Private FGeomTransform: PdxGeom;

This item has no description.

Private FGeomElement: PdxGeom;

This item has no description.

Private FPosition: TgxCoordinates;

This item has no description.

Private FDirection: TgxCoordinates;

This item has no description.

Private FUp: TgxCoordinates;

This item has no description.

Private FLocalMatrix: TMatrix4f;

This item has no description.

Private FRealignODE: Boolean;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FDynamic: Boolean;

This item has no description.

Private FIsCalculating: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteMatrix: TMatrix4f;

This item has no description.

Public function AbsolutePosition: TAffineVector;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo); virtual;

This item has no description.

Properties

Published property Density: TdReal read FDensity write SetDensity;

This item has no description.

Published property Direction: TgxCoordinates read FDirection write SetDirection;

This item has no description.

Public property Geom: PdxGeom read FGeomElement;

This item has no description.

Public property GeomTransform: PdxGeom read FGeomTransform;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Public property Matrix: TMatrix4f read GetMatrix write SetMatrix;

This item has no description.

Published property Position: TgxCoordinates read FPosition write SetPosition;

This item has no description.

Published property Up: TgxCoordinates read FUp write SetUp;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementBox

Class TgxODEElementBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementBox = class(TgxODEElementBase)

Description

ODE box implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementBox

Overview

Fields

Private | FBoxWidth: TdReal;
Private | FBoxHeight: TdReal;
Private | FBoxDepth: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published | property BoxDepth: TdReal read GetBoxDepth write SetBoxDepth;
Published | property BoxHeight: TdReal read GetBoxHeight write SetBoxHeight;
Published | property BoxWidth: TdReal read GetBoxWidth write SetBoxWidth;

Description

Fields

Private FBoxWidth: TdReal;

This item has no description.

Private FBoxHeight: TdReal;

This item has no description.

Private FBoxDepth: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property BoxDepth: TdReal read GetBoxDepth write SetBoxDepth;

This item has no description.

Published property BoxHeight: TdReal read GetBoxHeight write SetBoxHeight;

This item has no description.

Published property BoxWidth: TdReal read GetBoxWidth write SetBoxWidth;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementSphere

Class TgxODEElementSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementSphere = class(TgxODEElementBase)

Description

ODE sphere implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementSphere

Overview

Fields

Private FRadius: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Radius: TdReal read GetRadius write SetRadius;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementCapsule

Class TgxODEElementCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementCapsule = class(TgxODEElementBase)

Description

ODE capped cylinder implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementCapsule

Overview

Fields

Private | FRadius: TdReal;
Private | FLength: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published | property Length: TdReal read GetLength write SetLength;
Published | property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Private FLength: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Length: TdReal read GetLength write SetLength;

This item has no description.

Published property Radius: TdReal read GetRadius write SetRadius;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementCylinder

Class TgxODEElementCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementCylinder = class(TgxODEElementBase)

Description

ODE cylinder implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementCylinder

Overview

Fields

Private | FRadius: TdReal;
Private | FLength: TdReal;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published | property Length: TdReal read GetLength write SetLength;
Published | property Radius: TdReal read GetRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Private FLength: TdReal;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Length: TdReal read GetLength write SetLength;

This item has no description.

Published property Radius: TdReal read GetRadius write SetRadius;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementTriMesh

Class TgxODEElementTriMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementTriMesh = class(TgxODEElementBase)

Description

ODE tri-mesh implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementTriMesh

Overview

Fields

Private | FTriMeshData: PdxTriMeshData;
Private | FVertices: TgxAffineVectorList;
Private | FIndices: TgxIntegerList;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure RefreshTriMeshData;

Properties

Public | property Indices: TgxIntegerList read FIndices write SetIndices;
Public | property Vertices: TgxAffineVectorList read FVertices write SetVertices;

Description

Fields

Private FTriMeshData: PdxTriMeshData;

This item has no description.

Private FVertices: TgxAffineVectorList;

This item has no description.

Private FIndices: TgxIntegerList;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure RefreshTriMeshData;

This item has no description.

Properties

Public property Indices: TgxIntegerList read FIndices write SetIndices;

This item has no description.

Public property Vertices: TgxAffineVectorList read FVertices write SetVertices;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEElementPlane

Class TgxODEElementPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEElementPlane = class(TgxODEElementBase)

Description

ODE plane implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEElementBase
  • TgxODEElementPlane

Overview

Methods

Public | class function CanAddTo(collection: TXCollection): Boolean; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;

Description

Methods

Public class function CanAddTo(collection: TXCollection): Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.CanAddTo.

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJoints

Class TgxODEJoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJoints = class(TXCollection)

Description

An XCollection decendant for ODE Joints.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxODEJoints

Overview

Methods

Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure Finalize;
Public | procedure Initialize;

Properties

Public property Joint[index: Integer]: TgxODEJointBase read GetJoint;

Description

Methods

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Finalize;

This item has no description.

Public procedure Initialize;

This item has no description.

Properties

Public property Joint[index: Integer]: TgxODEJointBase read GetJoint;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointList

Class TgxODEJointList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointList = class(TComponent)

Description

Component front-end for storing ODE Joints.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxODEJointList

Overview

Fields

Private FJoints: TgxODEJoints;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Joints: TgxODEJoints read FJoints;

Description

Fields

Private FJoints: TgxODEJoints;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Joints: TgxODEJoints read FJoints;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointBase

Class TgxODEJointBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointBase = class(TXCollectionItem)

Description

Base structures for ODE Joints.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase

Overview

Fields

Private | FJointID: TdJointID;
Private | FObject1: TgxBaseSceneObject;
Private | FObject2: TgxBaseSceneObject;
Private | FManager: TgxODEManager;
Private | FObject1Name: String;
Private | FObject2Name: String;
Private | FManagerName: String;
Private | FInitialized: Boolean;
Private | FEnabled: Boolean;
Private | FJointOptions: TJointOptions;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function IsAttached: Boolean;
Public | procedure DoLoaded;
Public | procedure Finalize; virtual;
Public | procedure Initialize; virtual;
Public | procedure StructureChanged; virtual;

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled;
Public | property Initialized: Boolean read FInitialized;
Public | property JointID: TdJointID read FJointID;
Published | property Manager: TgxODEManager read FManager write SetManager;
Published | property Object1: TgxBaseSceneObject read FObject1 write SetObject1;
Published | property Object2: TgxBaseSceneObject read FObject2 write SetObject2;

Description

Fields

Private FJointID: TdJointID;

This item has no description.

Private FObject1: TgxBaseSceneObject;

This item has no description.

Private FObject2: TgxBaseSceneObject;

This item has no description.

Private FManager: TgxODEManager;

This item has no description.

Private FObject1Name: String;

This item has no description.

Private FObject2Name: String;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FInitialized: Boolean;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FJointOptions: TJointOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsAttached: Boolean;

This item has no description.

Public procedure DoLoaded;

This item has no description.

Public procedure Finalize; virtual;

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure StructureChanged; virtual;

This item has no description.

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled;

This item has no description.

Public property Initialized: Boolean read FInitialized;

This item has no description.

Public property JointID: TdJointID read FJointID;

This item has no description.

Published property Manager: TgxODEManager read FManager write SetManager;

This item has no description.

Published property Object1: TgxBaseSceneObject read FObject1 write SetObject1;

This item has no description.

Published property Object2: TgxBaseSceneObject read FObject2 write SetObject2;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointParams

Class TgxODEJointParams

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointParams = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxODEJointParams

Overview

Fields

Private | FOwner: TPersistent;
Private | FSetCallback: TgxODESetParamCallback;
Private | FGetCallback: TgxODEGetParamCallback;
Private | FLoStop: TdReal;
Private | FHiStop: TdReal;
Private | FVel: TdReal;
Private | FFMax: TdReal;
Private | FFudgeFactor: TdReal;
Private | FBounce: TdReal;
Private | FCFM: TdReal;
Private | FStopERP: TdReal;
Private | FStopCFM: TdReal;
Private | FSuspensionERP: TdReal;
Private | FSuspensionCFM: TdReal;
Private | FFlagLoStop: Boolean;
Private | FFlagHiStop: Boolean;
Private | FFlagVel: Boolean;
Private | FFlagFMax: Boolean;
Private | FFlagFudgeFactor: Boolean;
Private | FFlagBounce: Boolean;
Private | FFlagCFM: Boolean;
Private | FFlagStopERP: Boolean;
Private | FFlagStopCFM: Boolean;
Private | FFlagSuspensionERP: Boolean;
Private | FFlagSuspensionCFM: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function GetOwner: TPersistent; override;
Public | procedure ApplyFlagged;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Bounce: TdReal read GetBounce write SetBounce;
Published | property CFM: TdReal read GetCFM write SetCFM;
Published | property FMax: TdReal read GetFMax write SetFMax;
Published | property FudgeFactor: TdReal read GetFudgeFactor write SetFudgeFactor;
Public | property GetCallback: TgxODEGetParamCallback read FGetCallback write FGetCallback;
Published | property HiStop: TdReal read GetHiStop write SetHiStop;
Published | property LoStop: TdReal read GetLoStop write SetLoStop;
Public | property SetCallback: TgxODESetParamCallback read FSetCallback write FSetCallback;
Published | property StopCFM: TdReal read GetStopCFM write SetStopCFM;
Published | property StopERP: TdReal read GetStopERP write SetStopERP;
Published | property SuspensionCFM: TdReal read GetSuspensionCFM write SetSuspensionCFM;
Published | property SuspensionERP: TdReal read GetSuspensionERP write SetSuspensionERP;
Published | property Vel: TdReal read GetVel write SetVel;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FSetCallback: TgxODESetParamCallback;

This item has no description.

Private FGetCallback: TgxODEGetParamCallback;

This item has no description.

Private FLoStop: TdReal;

This item has no description.

Private FHiStop: TdReal;

This item has no description.

Private FVel: TdReal;

This item has no description.

Private FFMax: TdReal;

This item has no description.

Private FFudgeFactor: TdReal;

This item has no description.

Private FBounce: TdReal;

This item has no description.

Private FCFM: TdReal;

This item has no description.

Private FStopERP: TdReal;

This item has no description.

Private FStopCFM: TdReal;

This item has no description.

Private FSuspensionERP: TdReal;

This item has no description.

Private FSuspensionCFM: TdReal;

This item has no description.

Private FFlagLoStop: Boolean;

This item has no description.

Private FFlagHiStop: Boolean;

This item has no description.

Private FFlagVel: Boolean;

This item has no description.

Private FFlagFMax: Boolean;

This item has no description.

Private FFlagFudgeFactor: Boolean;

This item has no description.

Private FFlagBounce: Boolean;

This item has no description.

Private FFlagCFM: Boolean;

This item has no description.

Private FFlagStopERP: Boolean;

This item has no description.

Private FFlagStopCFM: Boolean;

This item has no description.

Private FFlagSuspensionERP: Boolean;

This item has no description.

Private FFlagSuspensionCFM: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function GetOwner: TPersistent; override;

This item has no description.

Public procedure ApplyFlagged;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Bounce: TdReal read GetBounce write SetBounce;

This item has no description.

Published property CFM: TdReal read GetCFM write SetCFM;

This item has no description.

Published property FMax: TdReal read GetFMax write SetFMax;

This item has no description.

Published property FudgeFactor: TdReal read GetFudgeFactor write SetFudgeFactor;

This item has no description.

Public property GetCallback: TgxODEGetParamCallback read FGetCallback write FGetCallback;

This item has no description.

Published property HiStop: TdReal read GetHiStop write SetHiStop;

This item has no description.

Published property LoStop: TdReal read GetLoStop write SetLoStop;

This item has no description.

Public property SetCallback: TgxODESetParamCallback read FSetCallback write FSetCallback;

This item has no description.

Published property StopCFM: TdReal read GetStopCFM write SetStopCFM;

This item has no description.

Published property StopERP: TdReal read GetStopERP write SetStopERP;

This item has no description.

Published property SuspensionCFM: TdReal read GetSuspensionCFM write SetSuspensionCFM;

This item has no description.

Published property SuspensionERP: TdReal read GetSuspensionERP write SetSuspensionERP;

This item has no description.

Published property Vel: TdReal read GetVel write SetVel;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointHinge

Class TgxODEJointHinge

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointHinge = class(TgxODEJointBase)

Description

ODE hinge joint implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointHinge

Overview

Fields

Private | FAnchor: TgxCoordinates;
Private | FAxis: TgxCoordinates;
Private | FAxisParams: TgxODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TgxCoordinates read FAnchor write SetAnchor;
Published | property Axis: TgxCoordinates read FAxis write SetAxis;
Published | property AxisParams: TgxODEJointParams read FAxisParams write SetAxisParams;

Description

Fields

Private FAnchor: TgxCoordinates;

This item has no description.

Private FAxis: TgxCoordinates;

This item has no description.

Private FAxisParams: TgxODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TgxCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis: TgxCoordinates read FAxis write SetAxis;

This item has no description.

Published property AxisParams: TgxODEJointParams read FAxisParams write SetAxisParams;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointBall

Class TgxODEJointBall

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointBall = class(TgxODEJointBase)

Description

ODE ball joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointBall

Overview

Fields

Private FAnchor: TgxCoordinates;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published property Anchor: TgxCoordinates read FAnchor write SetAnchor;

Description

Fields

Private FAnchor: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TgxCoordinates read FAnchor write SetAnchor;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointSlider

Class TgxODEJointSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointSlider = class(TgxODEJointBase)

Description

ODE slider joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointSlider

Overview

Fields

Private | FAxis: TgxCoordinates;
Private | FAxisParams: TgxODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Axis: TgxCoordinates read FAxis write SetAxis;
Published | property AxisParams: TgxODEJointParams read FAxisParams write SetAxisParams;

Description

Fields

Private FAxis: TgxCoordinates;

This item has no description.

Private FAxisParams: TgxODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Axis: TgxCoordinates read FAxis write SetAxis;

This item has no description.

Published property AxisParams: TgxODEJointParams read FAxisParams write SetAxisParams;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointFixed

Class TgxODEJointFixed

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointFixed = class(TgxODEJointBase)

Description

ODE fixed joint implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointFixed

Overview

Methods

Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;

Description

Methods

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointHinge2

Class TgxODEJointHinge2

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointHinge2 = class(TgxODEJointBase)

Description

ODE hinge2 joint implementation.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointHinge2

Overview

Fields

Private | FAnchor: TgxCoordinates;
Private | FAxis1: TgxCoordinates;
Private | FAxis2: TgxCoordinates;
Private | FAxis1Params: TgxODEJointParams;
Private | FAxis2Params: TgxODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TgxCoordinates read FAnchor write SetAnchor;
Published | property Axis1: TgxCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params: TgxODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2: TgxCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params: TgxODEJointParams read FAxis2Params write SetAxis2Params;

Description

Fields

Private FAnchor: TgxCoordinates;

This item has no description.

Private FAxis1: TgxCoordinates;

This item has no description.

Private FAxis2: TgxCoordinates;

This item has no description.

Private FAxis1Params: TgxODEJointParams;

This item has no description.

Private FAxis2Params: TgxODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TgxCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis1: TgxCoordinates read FAxis1 write SetAxis1;

This item has no description.

Published property Axis1Params: TgxODEJointParams read FAxis1Params write SetAxis1Params;

This item has no description.

Published property Axis2: TgxCoordinates read FAxis2 write SetAxis2;

This item has no description.

Published property Axis2Params: TgxODEJointParams read FAxis2Params write SetAxis2Params;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEJointUniversal

Class TgxODEJointUniversal

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEJointUniversal = class(TgxODEJointBase)

Description

ODE universal joint implementation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxODEJointBase
  • TgxODEJointUniversal

Overview

Fields

Private | FAnchor: TgxCoordinates;
Private | FAxis1: TgxCoordinates;
Private | FAxis2: TgxCoordinates;
Private | FAxis1Params: TgxODEJointParams;
Private | FAxis2Params: TgxODEJointParams;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;

Properties

Published | property Anchor: TgxCoordinates read FAnchor write SetAnchor;
Published | property Axis1: TgxCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params: TgxODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2: TgxCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params: TgxODEJointParams read FAxis2Params write SetAxis2Params;

Description

Fields

Private FAnchor: TgxCoordinates;

This item has no description.

Private FAxis1: TgxCoordinates;

This item has no description.

Private FAxis2: TgxCoordinates;

This item has no description.

Private FAxis1Params: TgxODEJointParams;

This item has no description.

Private FAxis2Params: TgxODEJointParams;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Initialize; override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property Anchor: TgxCoordinates read FAnchor write SetAnchor;

This item has no description.

Published property Axis1: TgxCoordinates read FAxis1 write SetAxis1;

This item has no description.

Published property Axis1Params: TgxODEJointParams read FAxis1Params write SetAxis1Params;

This item has no description.

Published property Axis2: TgxCoordinates read FAxis2 write SetAxis2;

This item has no description.

Published property Axis2Params: TgxODEJointParams read FAxis2Params write SetAxis2Params;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEContactPoint

Class TgxODEContactPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEContactPoint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxODEContactPoint

Overview

Fields

Public | Position: TAffineVector;
Public | Normal: TAffineVector;
Public | Depth: Single;

Description

Fields

Public Position: TAffineVector;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public Depth: Single;


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODECustomCollider

Class TgxODECustomCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODECustomCollider = class(TgxODEBehaviour)

Description

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxODEBehaviour
  • TgxODECustomCollider

Overview

Fields

Private | FGeom: PdxGeom;
Private | FContactList: TList;
Private | FContactCache: TList;
Private | FTransform: TMatrix4f;
Private | FContactResolution: Single;
Private | FRenderContacts: Boolean;
Private | FContactRenderPoints: TgxAffineVectorList;
Private | FPointSize: Single;
Private | FContactColor: TgxColor;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published | property ContactColor: TgxColor read FContactColor write SetContactColor;
Published | property ContactResolution: Single read FContactResolution write SetContactResolution;
Public | property Geom: PdxGeom read FGeom;
Published | property PointSize: Single read FPointSize write SetPointSize;
Published | property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Description

Fields

Private FGeom: PdxGeom;

This item has no description.

Private FContactList: TList;

This item has no description.

Private FContactCache: TList;

This item has no description.

Private FTransform: TMatrix4f;

This item has no description.

Private FContactResolution: Single;

This item has no description.

Private FRenderContacts: Boolean;

This item has no description.

Private FContactRenderPoints: TgxAffineVectorList;

This item has no description.

Private FPointSize: Single;

This item has no description.

Private FContactColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property ContactColor: TgxColor read FContactColor write SetContactColor;

Contact point rendering color.

Published property ContactResolution: Single read FContactResolution write SetContactResolution;

Defines the resolution of the contact points created for the colliding Geom. The number of contact points generated change base don the size of the object and the ContactResolution. Lower values generate higher resolution contact boundaries, and thus smoother but slower collisions.

Public property Geom: PdxGeom read FGeom;

This item has no description.

Published property PointSize: Single read FPointSize write SetPointSize;

Contact point rendering size (in pixels).

Published property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Toggle contact point rendering on and off. (Rendered through the assigned Manager.RenderPoint.


GXSysHelp v.2.5: GXS.ODEManager: Class TgxODEHeightField

Class TgxODEHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODEManager

Declaration

type TgxODEHeightField = class(TgxODECustomCollider)

Description

Add this behaviour to a TgxHeightField or TgxTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxODEBehaviour
  • TgxODECustomCollider
  • TgxODEHeightField

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function CanAddTo(collection: TXCollection): Boolean; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: Boolean; override;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public class function CanAddTo(collection: TXCollection): Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.CanAddTo.

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.


GXSysHelp v.2.5: GXS.ODERagdoll

Unit GXS.ODERagdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.Ragdoll
  • GXS.Scene
  • GXS.Objects
  • GXS.Texture
  • GXS.VectorFileObjects
  • ODE.Import
  • GXS.ODEUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxODERagdollCube |
Class TgxODERagdollWorld |
Class TgxODERagdollDummyJoint |
Class TgxODERagdollHingeJoint |
Class TgxODERagdollUniversalJoint |
Class TgxODERagdollBone |
Class TgxODERagdoll |

Constants

cMaxContacts = 4;

Variables

vODERagdoll_cDensity: Single;
vODERagdoll_cMass: Single;

Description

Constants

cMaxContacts = 4;

This item has no description.

Variables

vODERagdoll_cDensity: Single;

This item has no description.

vODERagdoll_cMass: Single;


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollCube

Class TgxODERagdollCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollCube = class(TgxCube)

Description

This item has no description. Showing description inherited from TgxCube.

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TgxFreeForm and a material library.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxCube
  • TgxODERagdollCube

Overview

Fields

Public | Bone: TgxODERagdollBone;
Public | Ragdoll: TgxODERagdoll;

Description

Fields

Public Bone: TgxODERagdollBone;

This item has no description.

Public Ragdoll: TgxODERagdoll;

Useful in Oncollision Event


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollWorld

Class TgxODERagdollWorld

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollWorld = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxODERagdollWorld

Overview

Fields

Private | FSpace: PdxSpace;
Private | FWorld: PdxWorld;
Private | FContactGroup: TdJointGroupID;
Private | FRagdoll: TgxODERagdoll;
Private | isWorldCreated: Boolean;

Methods

Public | constructor Create;
Public | constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);
Public | destructor Destroy; override;
Public | procedure WorldUpdate;

Properties

Public | property ContactGroup: TdJointGroupID read FContactGroup;
Public | property Ragdoll: TgxODERagdoll read FRagdoll;
Public | property Space: PdxSpace read FSpace;
Public | property World: PdxWorld read FWorld;

Description

Fields

Private FSpace: PdxSpace;

This item has no description.

Private FWorld: PdxWorld;

This item has no description.

Private FContactGroup: TdJointGroupID;

This item has no description.

Private FRagdoll: TgxODERagdoll;

This item has no description.

Private isWorldCreated: Boolean;

This item has no description.

Methods

Public constructor Create;

NEW1

Public constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);

Create the world from any existing ODE world

Public destructor Destroy; override;

This item has no description.

Public procedure WorldUpdate;

This item has no description.

Properties

Public property ContactGroup: TdJointGroupID read FContactGroup;

This item has no description.

Public property Ragdoll: TgxODERagdoll read FRagdoll;

This item has no description.

Public property Space: PdxSpace read FSpace;

This item has no description.

Public property World: PdxWorld read FWorld;


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollDummyJoint

Class TgxODERagdollDummyJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollDummyJoint = class(TgxRagdolJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRagdolJoint
  • TgxODERagdollDummyJoint


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollHingeJoint

Class TgxODERagdollHingeJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollHingeJoint = class(TgxRagdolJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRagdolJoint
  • TgxODERagdollHingeJoint

Overview

Fields

Private | FParamHiStop: Single;
Private | FParamLoStop: Single;
Private | FAxis: TAffineVector;

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

Properties

Public | property Axis: TAffineVector read FAxis;
Public | property ParamHiStop: Single read FParamHiStop write FParamHiStop;
Public | property ParamLoStop: Single read FParamLoStop write FParamLoStop;

Description

Fields

Private FParamHiStop: Single;

This item has no description.

Private FParamLoStop: Single;

This item has no description.

Private FAxis: TAffineVector;

This item has no description.

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis;

This item has no description.

Public property ParamHiStop: Single read FParamHiStop write FParamHiStop;

This item has no description.

Public property ParamLoStop: Single read FParamLoStop write FParamLoStop;


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollUniversalJoint

Class TgxODERagdollUniversalJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollUniversalJoint = class(TgxODERagdollHingeJoint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRagdolJoint
  • TgxODERagdollHingeJoint
  • TgxODERagdollUniversalJoint

Overview

Fields

Private | FParamHiStop2: Single;
Private | FParamLoStop2: Single;
Private | FAxis2: TAffineVector;

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

Properties

Public | property Axis2: TAffineVector read FAxis2;
Public | property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;
Public | property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;

Description

Fields

Private FParamHiStop2: Single;

This item has no description.

Private FParamLoStop2: Single;

This item has no description.

Private FAxis2: TAffineVector;

This item has no description.

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

This item has no description.

Properties

Public property Axis2: TAffineVector read FAxis2;

This item has no description.

Public property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;

This item has no description.

Public property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdollBone

Class TgxODERagdollBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdollBone = class(TgxRagdolBone)

Description

This item has no description.

Hierarchy

  • TgxPersistentObjectList
  • TgxRagdolBoneList
  • TgxRagdolBone
  • TgxODERagdollBone

Overview

Fields

Private | FOwner: TgxODERagdollBone;
Private | FRagdoll: TgxODERagdoll;
Private | FBody: PdxBody;
Private | FGeom: PdxGeom;
Private | FJointId: TdJointID;

Methods

Public | constructor Create(Ragdoll: TgxODERagdoll);
Public | constructor CreateOwned(aOwner: TgxODERagdollBone);
Private | procedure AlignBodyToMatrix(Mat: TMatrix4f);

Properties

Public | property Body: PdxBody read FBody;
Public | property Geom: PdxGeom read FGeom;

Description

Fields

Private FOwner: TgxODERagdollBone;

This item has no description.

Private FRagdoll: TgxODERagdoll;

This item has no description.

Private FBody: PdxBody;

This item has no description.

Private FGeom: PdxGeom;

This item has no description.

Private FJointId: TdJointID;

This item has no description.

Methods

Public constructor Create(Ragdoll: TgxODERagdoll);

This item has no description.

Public constructor CreateOwned(aOwner: TgxODERagdollBone);

This item has no description.

Private procedure AlignBodyToMatrix(Mat: TMatrix4f);

This item has no description.

Properties

Public property Body: PdxBody read FBody;

This item has no description.

Public property Geom: PdxGeom read FGeom;


GXSysHelp v.2.5: GXS.ODERagdoll: Class TgxODERagdoll

Class TgxODERagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODERagdoll

Declaration

type TgxODERagdoll = class(TgxRagdoll)

Description

This item has no description.

Hierarchy

  • TgxPersistentObject
  • TgxRagdoll
  • TgxODERagdoll

Overview

Fields

Private | FODEWorld: TgxODERagdollWorld;
Private | FGLXceneRoot: TgxBaseSceneObject;
Private | FShowBoundingBoxes: Boolean;

Methods

Public constructor Create(aOwner: TgxBaseMesh);

Properties

Public | property GLXceneRoot: TgxBaseSceneObject read FGLXceneRoot write FGLXceneRoot;
Public | property ODEWorld: TgxODERagdollWorld read FODEWorld write FODEWorld;
Public | property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;

Description

Fields

Private FODEWorld: TgxODERagdollWorld;

This item has no description.

Private FGLXceneRoot: TgxBaseSceneObject;

This item has no description.

Private FShowBoundingBoxes: Boolean;

This item has no description.

Methods

Public constructor Create(aOwner: TgxBaseMesh);

This item has no description.

Properties

Public property GLXceneRoot: TgxBaseSceneObject read FGLXceneRoot write FGLXceneRoot;

This item has no description.

Public property ODEWorld: TgxODERagdollWorld read FODEWorld write FODEWorld;

This item has no description.

Public property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;


GXSysHelp v.2.5: GXS.ODESkeletonColliders

Unit GXS.ODESkeletonColliders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • ODE.Import
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSCODEBase |
Class TSCODESphere |
Class TSCODECCylinder |
Class TSCODEBox |

Functions and Procedures

procedure AddSCODEGeomsToODESpace(colliders: TgxSkeletonColliderList; Space: PdxSpace);

Description

Functions and Procedures

procedure AddSCODEGeomsToODESpace(colliders: TgxSkeletonColliderList; Space: PdxSpace);

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.


GXSysHelp v.2.5: GXS.ODESkeletonColliders: Class TSCODEBase

Class TSCODEBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODESkeletonColliders

Declaration

type TSCODEBase = class(TgxSkeletonCollider)

Description

Base ODE skeleton collider class.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TSCODEBase

Overview

Fields

Private FGeom: PdxGeom;

Methods

Public | procedure AddToSpace(Space: PdxSpace); virtual;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property Geom: PdxGeom read FGeom;

Description

Fields

Private FGeom: PdxGeom;

This item has no description.

Methods

Public procedure AddToSpace(Space: PdxSpace); virtual;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TgxSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Geom: PdxGeom read FGeom;

The geoms are created through the AddToSpace procedure


GXSysHelp v.2.5: GXS.ODESkeletonColliders: Class TSCODESphere

Class TSCODESphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODESkeletonColliders

Declaration

type TSCODESphere = class(TSCODEBase)

Description

Sphere shaped ODE geom in a skeleton collider.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TSCODEBase
  • TSCODESphere

Overview

Fields

Private FRadius: TdReal;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property Radius: TdReal read FRadius write SetRadius;

Description

Fields

Private FRadius: TdReal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Radius: TdReal read FRadius write SetRadius;


GXSysHelp v.2.5: GXS.ODESkeletonColliders: Class TSCODECCylinder

Class TSCODECCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODESkeletonColliders

Declaration

type TSCODECCylinder = class(TSCODEBase)

Description

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TSCODEBase
  • TSCODECCylinder

Overview

Fields

Private | FRadius: Single;
Private | FLength: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GXSysHelp v.2.5: GXS.ODESkeletonColliders: Class TSCODEBox

Class TSCODEBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ODESkeletonColliders

Declaration

type TSCODEBox = class(TSCODEBase)

Description

Box shaped ODE geom in a skeleton collider.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TSCODEBase
  • TSCODEBox

Overview

Fields

Private | FBoxWidth: TdReal;
Private | FBoxHeight: TdReal;
Private | FBoxDepth: TdReal;

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space: PdxSpace); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property BoxDepth: TdReal read FBoxDepth write SetBoxDepth;
Public | property BoxHeight: TdReal read FBoxHeight write SetBoxHeight;
Public | property BoxWidth: TdReal read FBoxWidth write SetBoxWidth;

Description

Fields

Private FBoxWidth: TdReal;

This item has no description.

Private FBoxHeight: TdReal;

This item has no description.

Private FBoxDepth: TdReal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToSpace(Space: PdxSpace); override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property BoxDepth: TdReal read FBoxDepth write SetBoxDepth;

This item has no description.

Public property BoxHeight: TdReal read FBoxHeight write SetBoxHeight;

This item has no description.

Public property BoxWidth: TdReal read FBoxWidth write SetBoxWidth;


GXSysHelp v.2.5: GXS.ODEUtils

Unit GXS.ODEUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • ODE.Import
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.PersistentClasses
  • GXS.Scene
  • GXS.Context
  • GXS.Coordinates
  • GXS.Objects
  • GXS.VerletClothify
  • GXS.VectorFileObjects

Overview

Functions and Procedures

procedure DrawBox(Sides: TdVector3);
procedure setTransform(pos: TdVector3; R: TdMatrix3);
procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;
procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;
procedure ODERToSceneMatrix(var m: TMatrix4f; R: TdMatrix3; pos: TdVector3); overload;
procedure ODERToSceneMatrix(var m: TMatrix4f; R: PdMatrix3; pos: PdVector3); overload;
procedure ODERToSceneMatrix(var m: TMatrix4f; R: TdMatrix3_As3x4; pos: TdVector3); overload;
function SceneMatrixToODER(m: TMatrix4f): TdMatrix3;
function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;
function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;
function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;
function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;
function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;
function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;
function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;
function ConvertVector3fTodVector3(R: TVector3f): TdVector3;
function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;
function ConvertVector4fTodVector3(R: TVector4f): TdVector3;
function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;
function dVector3Length(R: TdVector3): single; overload;
function dVector3Length(R: PdVector3): single; overload;
function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;
procedure CopyPosFromGeomToGX(Geom: PdxGeom; BaseSceneObject: TgxBaseSceneObject);
procedure PositionSceneObject(BaseSceneObject: TgxBaseSceneObject; Geom: PdxGeom);
procedure PositionSceneObjectForGeom(Geom: PdxGeom);
procedure CopyCubeSizeFromBox(Cube: TgxCube; Geom: PdxGeom);
procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TgxCube; Space: PdxSpace);
function CreateGeomFromCube(Cube: TgxCube; Space: PdxSpace): PdxGeom;
function CreateBodyFromCube(var Geom: PdxGeom; Cube: TgxCube; World: PdxWorld; Space: PdxSpace): PdxBody;
function CreateTriMeshFromBaseMesh(BaseMesh: TgxBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;
function SceneMatrixFromGeom(Geom: PdxGeom): TMatrix4f;
function SceneDirectionFromGeom(Geom: PdxGeom): TVector4f;
function CreateODEPlaneFromScenePlane(Plane: TgxPlane; Space: PdxSpace): PdxGeom;
procedure RenderGeomList(GeomList: TGeomList);
function RandomColorVector: TVector4f;

Description

Functions and Procedures

procedure DrawBox(Sides: TdVector3);

This item has no description.

procedure setTransform(pos: TdVector3; R: TdMatrix3);

This item has no description.

procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;

This item has no description.

procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;

This item has no description.

procedure ODERToSceneMatrix(var m: TMatrix4f; R: TdMatrix3; pos: TdVector3); overload;

This item has no description.

procedure ODERToSceneMatrix(var m: TMatrix4f; R: PdMatrix3; pos: PdVector3); overload;

This item has no description.

procedure ODERToSceneMatrix(var m: TMatrix4f; R: TdMatrix3_As3x4; pos: TdVector3); overload;

This item has no description.

function SceneMatrixToODER(m: TMatrix4f): TdMatrix3;

This item has no description.

function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;

Converting between ODE and Scene formats

function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;

This item has no description.

function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;

This item has no description.

function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;

This item has no description.

function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;

This item has no description.

function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;

This item has no description.

function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;

This item has no description.

function ConvertVector3fTodVector3(R: TVector3f): TdVector3;

Converting between Scene and ODE formats

function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;

This item has no description.

function ConvertVector4fTodVector3(R: TVector4f): TdVector3;

This item has no description.

function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;

This item has no description.

function dVector3Length(R: TdVector3): single; overload;

This item has no description.

function dVector3Length(R: PdVector3): single; overload;

This item has no description.

function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;

This item has no description.

procedure CopyPosFromGeomToGX(Geom: PdxGeom; BaseSceneObject: TgxBaseSceneObject);

This item has no description.

procedure PositionSceneObject(BaseSceneObject: TgxBaseSceneObject; Geom: PdxGeom);

This item has no description.

procedure PositionSceneObjectForGeom(Geom: PdxGeom);

This item has no description.

procedure CopyCubeSizeFromBox(Cube: TgxCube; Geom: PdxGeom);

This item has no description.

procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TgxCube; Space: PdxSpace);

This item has no description.

function CreateGeomFromCube(Cube: TgxCube; Space: PdxSpace): PdxGeom;

This item has no description.

function CreateBodyFromCube(var Geom: PdxGeom; Cube: TgxCube; World: PdxWorld; Space: PdxSpace): PdxBody;

This item has no description.

function CreateTriMeshFromBaseMesh(BaseMesh: TgxBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;

This method requires you to manually deallocate vertices and indices when you're done with the trimesh

function SceneMatrixFromGeom(Geom: PdxGeom): TMatrix4f;

This item has no description.

function SceneDirectionFromGeom(Geom: PdxGeom): TVector4f;

This item has no description.

function CreateODEPlaneFromScenePlane(Plane: TgxPlane; Space: PdxSpace): PdxGeom;

This item has no description.

procedure RenderGeomList(GeomList: TGeomList);

This item has no description.

function RandomColorVector: TVector4f;


GXSysHelp v.2.5: GXS.OpenGLAdapter

Unit GXS.OpenGLAdapter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GLScene.Strings
  • GLScene.Logger
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EOpenGLError |
Class TGLExtensionsAndEntryPoints |

Functions and Procedures

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;
function gluErrorString(errCode: Cardinal): PAnsiChar; stdcall; external glu32;
function gluGetString(Name: Cardinal): PAnsiChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: Cardinal; Components, Width: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: Cardinal; Components, Width, Height: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; Value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; Value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function GetProcAddressGLLib(ProcName: PAnsiChar): Pointer;
function GetProcAddressGLS(ProcName: PAnsiChar): Pointer;
procedure CloseOpenGL;
function InitOpenGL: boolean;
function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;
function IsOpenGLInitialized: boolean;
procedure UnloadOpenGL;
function LoadOpenGL: boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;
function IsOpenGLLoaded: boolean;
function IsMesaGL: boolean;
procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);
function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;

Constants

opengl32 = 'OpenGL32.dll';
glu32 = 'GLU32.dll';

Description

Functions and Procedures

function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;

function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;

This item has no description.

function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;

This item has no description.

function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;

This item has no description.

function wglGetCurrentContext: HGLRC; stdcall; external opengl32;

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

function wglGetCurrentDC: HDC; stdcall; external opengl32;

This item has no description.

function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;

This item has no description.

function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;

This item has no description.

function gluErrorString(errCode: Cardinal): PAnsiChar; stdcall; external glu32;

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';

function gluGetString(Name: Cardinal): PAnsiChar; stdcall; external glu32;

This item has no description.

procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;

This item has no description.

function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;

This item has no description.

function gluScaleImage(format: Cardinal; widthin, heightin: TGLint; typein: Cardinal; datain: Pointer; widthout, heightout: TGLint; typeout: Cardinal; dataout: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild1DMipmaps(target: Cardinal; Components, Width: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluBuild2DMipmaps(target: Cardinal; Components, Width, Height: TGLint; format, atype: Cardinal; Data: Pointer): TGLint; stdcall; external glu32;

This item has no description.

function gluNewQuadric: PGLUquadric; stdcall; external glu32;

This item has no description.

procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;

This item has no description.

procedure gluQuadricNormals(quadObject: PGLUquadric; normals: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;

This item has no description.

procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;

This item has no description.

procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;

This item has no description.

procedure gluQuadricCallback(quadObject: PGLUquadric; which: Cardinal; fn: TGLUQuadricErrorProc); stdcall; external glu32;

This item has no description.

function gluNewTess: PGLUtesselator; stdcall; external glu32;

This item has no description.

procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;

This item has no description.

procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluTessProperty(tess: PGLUtesselator; which: Cardinal; Value: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;

This item has no description.

procedure gluTessCallback(tess: PGLUtesselator; which: Cardinal; fn: Pointer); stdcall; external glu32;

This item has no description.

procedure gluGetTessProperty(tess: PGLUtesselator; which: Cardinal; Value: PGLdouble); stdcall; external glu32;

This item has no description.

function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;

This item has no description.

procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;

This item has no description.

procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;

This item has no description.

procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: TGLfloat); stdcall; external glu32;

This item has no description.

procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: Cardinal; Value: PGLfloat); stdcall; external glu32;

This item has no description.

procedure gluNurbsCallback(nobj: PGLUnurbs; which: Cardinal; fn: TGLUNurbsErrorProc); stdcall; external glu32;

This item has no description.

procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

procedure gluNextContour(tess: PGLUtesselator; atype: Cardinal); stdcall; external glu32;

This item has no description.

procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;

This item has no description.

function GetProcAddressGLLib(ProcName: PAnsiChar): Pointer;

This item has no description.

function GetProcAddressGLS(ProcName: PAnsiChar): Pointer;

This item has no description.

procedure CloseOpenGL;

This item has no description.

function InitOpenGL: boolean;

This item has no description.

function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;

This item has no description.

function IsOpenGLInitialized: boolean;

This item has no description.

procedure UnloadOpenGL;

compatibility routines

function LoadOpenGL: boolean;

This item has no description.

function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;

This item has no description.

function IsOpenGLLoaded: boolean;

This item has no description.

function IsMesaGL: boolean;

This item has no description.

procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);

This item has no description.

function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;

This item has no description.

Constants

opengl32 = 'OpenGL32.dll';

This item has no description.

glu32 = 'GLU32.dll';


GXSysHelp v.2.5: GXS.OpenGLAdapter: Class EOpenGLError

Class EOpenGLError

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.OpenGLAdapter

Declaration

type EOpenGLError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EOpenGLError


GXSysHelp v.2.5: GXS.OpenGLAdapter: Class TGLExtensionsAndEntryPoints

Class TGLExtensionsAndEntryPoints

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.OpenGLAdapter

Declaration

type TGLExtensionsAndEntryPoints = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLExtensionsAndEntryPoints

Overview

Fields

Private | FBuffer: string;
Private | FInitialized: boolean;
Private | FDebug: boolean;
Private | FDebugIds: Cardinal;
Public | VERSION_1_0: boolean;
Public | VERSION_1_1: boolean;
Public | VERSION_1_2: boolean;
Public | VERSION_1_3: boolean;
Public | VERSION_1_4: boolean;
Public | VERSION_1_5: boolean;
Public | VERSION_2_0: boolean;
Public | VERSION_2_1: boolean;
Public | VERSION_3_0: boolean;
Public | VERSION_3_1: boolean;
Public | VERSION_3_2: boolean;
Public | VERSION_3_3: boolean;
Public | VERSION_4_0: boolean;
Public | VERSION_4_1: boolean;
Public | VERSION_4_2: boolean;
Public | ARB_blend_func_extended: boolean;
Public | ARB_color_buffer_float: boolean;
Public | ARB_compatibility: boolean;
Public | ARB_copy_buffer: boolean;
Public | ARB_depth_buffer_float: boolean;
Public | ARB_depth_clamp: boolean;
Public | ARB_depth_texture: boolean;
Public | ARB_draw_buffers: boolean;
Public | ARB_draw_buffers_blend: boolean;
Public | ARB_draw_elements_base_vertex: boolean;
Public | ARB_draw_indirect: boolean;
Public | ARB_draw_instanced: boolean;
Public | ARB_explicit_attrib_location: boolean;
Public | ARB_fragment_coord_conventions: boolean;
Public | ARB_fragment_program: boolean;
Public | ARB_fragment_program_shadow: boolean;
Public | ARB_fragment_shader: boolean;
Public | ARB_framebuffer_object: boolean;
Public | ARB_framebuffer_sRGB: boolean;
Public | ARB_geometry_shader4: boolean;
Public | ARB_gpu_shader_fp64: boolean;
Public | ARB_gpu_shader5: boolean;
Public | ARB_half_float_pixel: boolean;
Public | ARB_half_float_vertex: boolean;
Public | ARB_imaging: boolean;
Public | ARB_instanced_arrays: boolean;
Public | ARB_map_buffer_range: boolean;
Public | ARB_matrix_palette: boolean;
Public | ARB_multisample: boolean;
Public | ARB_multitexture: boolean;
Public | ARB_occlusion_query: boolean;
Public | ARB_occlusion_query2: boolean;
Public | ARB_pixel_buffer_object: boolean;
Public | ARB_point_parameters: boolean;
Public | ARB_point_sprite: boolean;
Public | ARB_provoking_vertex: boolean;
Public | ARB_sample_shading: boolean;
Public | ARB_sampler_objects: boolean;
Public | ARB_seamless_cube_map: boolean;
Public | ARB_shader_bit_encoding: boolean;
Public | ARB_shader_subroutine: boolean;
Public | ARB_shader_texture_lod: boolean;
Public | ARB_shading_language_100: boolean;
Public | ARB_shadow: boolean;
Public | ARB_shadow_ambient: boolean;
Public | ARB_shader_objects: boolean;
Public | ARB_sync: boolean;
Public | ARB_tessellation_shader: boolean;
Public | ARB_texture_border_clamp: boolean;
Public | ARB_texture_buffer_object: boolean;
Public | ARB_texture_buffer_object_rgb32: boolean;
Public | ARB_texture_compression: boolean;
Public | ARB_texture_compression_rgtc: boolean;
Public | ARB_texture_cube_map: boolean;
Public | ARB_texture_cube_map_array: boolean;
Public | ARB_texture_env_add: boolean;
Public | ARB_texture_env_combine: boolean;
Public | ARB_texture_env_crossbar: boolean;
Public | ARB_texture_env_dot3: boolean;
Public | ARB_texture_float: boolean;
Public | ARB_texture_gather: boolean;
Public | ARB_texture_mirrored_repeat: boolean;
Public | ARB_texture_multisample: boolean;
Public | ARB_texture_non_power_of_two: boolean;
Public | ARB_texture_query_lod: boolean;
Public | ARB_texture_rectangle: boolean;
Public | ARB_texture_rg: boolean;
Public | ARB_texture_rgb10_a2ui: boolean;
Public | ARB_texture_swizzle: boolean;
Public | ARB_timer_query: boolean;
Public | ARB_transform_feedback2: boolean;
Public | ARB_transform_feedback3: boolean;
Public | ARB_transpose_matrix: boolean;
Public | ARB_uniform_buffer_object: boolean;
Public | ARB_vertex_array_bgra: boolean;
Public | ARB_vertex_array_object: boolean;
Public | ARB_vertex_blend: boolean;
Public | ARB_vertex_buffer_object: boolean;
Public | ARB_vertex_program: boolean;
Public | ARB_vertex_shader: boolean;
Public | ARB_vertex_type_2_10_10_10_rev: boolean;
Public | ARB_window_pos: boolean;
Public | ARB_texture_compression_bptc: boolean;
Public | ARB_get_program_binary: boolean;
Public | ARB_separate_shader_objects: boolean;
Public | ARB_shader_stencil_export: boolean;
Public | KHR_debug: boolean;
Public | ARB_clear_buffer_object: boolean;
Public | ARB_compute_shader: boolean;
Public | ARB_copy_image: boolean;
Public | ARB_debug_group: boolean;
Public | ARB_debug_label: boolean;
Public | ARB_debug_output2: boolean;
Public | ARB_ES3_compatibility: boolean;
Public | ARB_explicit_uniform_location: boolean;
Public | ARB_fragment_layer_viewport: boolean;
Public | ARB_framebuffer_no_attachments: boolean;
Public | ARB_internalformat_query2: boolean;
Public | ARB_invalidate_subdata: boolean;
Public | ARB_multi_draw_indirect: boolean;
Public | ARB_program_interface_query: boolean;
Public | ARB_shader_image_size: boolean;
Public | ARB_shader_storage_buffer_object: boolean;
Public | ARB_stencil_texturing: boolean;
Public | ARB_texture_buffer_range: boolean;
Public | ARB_texture_query_levels: boolean;
Public | ARB_texture_storage_multisample: boolean;
Public | ARB_texture_view: boolean;
Public | ARB_vertex_attrib_binding: boolean;
Public | ARB_robustness_isolation: boolean;
Public | ARB_cl_event: boolean;
Public | _3DFX_multisample: boolean;
Public | _3DFX_tbuffer: boolean;
Public | _3DFX_texture_compression_FXT1: boolean;
Public | ATI_draw_buffers: boolean;
Public | ATI_texture_compression_3dc: boolean;
Public | ATI_texture_float: boolean;
Public | ATI_texture_mirror_once: boolean;
Public | S3_s3tc: boolean;
Public | EXT_abgr: boolean;
Public | EXT_bgra: boolean;
Public | EXT_bindable_uniform: boolean;
Public | EXT_blend_color: boolean;
Public | EXT_blend_equation_separate: boolean;
Public | EXT_blend_func_separate: boolean;
Public | EXT_blend_logic_op: boolean;
Public | EXT_blend_minmax: boolean;
Public | EXT_blend_subtract: boolean;
Public | EXT_Cg_shader: boolean;
Public | EXT_clip_volume_hint: boolean;
Public | EXT_compiled_vertex_array: boolean;
Public | EXT_copy_texture: boolean;
Public | EXT_depth_bounds_test: boolean;
Public | EXT_draw_buffers2: boolean;
Public | EXT_draw_instanced: boolean;
Public | EXT_draw_range_elements: boolean;
Public | EXT_fog_coord: boolean;
Public | EXT_framebuffer_blit: boolean;
Public | EXT_framebuffer_multisample: boolean;
Public | EXT_framebuffer_object: boolean;
Public | EXT_framebuffer_sRGB: boolean;
Public | EXT_geometry_shader4: boolean;
Public | EXT_gpu_program_parameters: boolean;
Public | EXT_gpu_shader4: boolean;
Public | EXT_multi_draw_arrays: boolean;
Public | EXT_multisample: boolean;
Public | EXT_packed_depth_stencil: boolean;
Public | EXT_packed_float: boolean;
Public | EXT_packed_pixels: boolean;
Public | EXT_paletted_texture: boolean;
Public | EXT_pixel_buffer_object: boolean;
Public | EXT_polygon_offset: boolean;
Public | EXT_rescale_normal: boolean;
Public | EXT_secondary_color: boolean;
Public | EXT_separate_specular_color: boolean;
Public | EXT_shadow_funcs: boolean;
Public | EXT_shared_texture_palette: boolean;
Public | EXT_stencil_clear_tag: boolean;
Public | EXT_stencil_two_side: boolean;
Public | EXT_stencil_wrap: boolean;
Public | EXT_texture3D: boolean;
Public | EXT_texture_array: boolean;
Public | EXT_texture_buffer_object: boolean;
Public | EXT_texture_compression_latc: boolean;
Public | EXT_texture_compression_rgtc: boolean;
Public | EXT_texture_compression_s3tc: boolean;
Public | EXT_texture_cube_map: boolean;
Public | EXT_texture_edge_clamp: boolean;
Public | EXT_texture_env_add: boolean;
Public | EXT_texture_env_combine: boolean;
Public | EXT_texture_env_dot3: boolean;
Public | EXT_texture_filter_anisotropic: boolean;
Public | EXT_texture_integer: boolean;
Public | EXT_texture_lod: boolean;
Public | EXT_texture_lod_bias: boolean;
Public | EXT_texture_mirror_clamp: boolean;
Public | EXT_texture_object: boolean;
Public | EXT_texture_rectangle: boolean;
Public | EXT_texture_sRGB: boolean;
Public | EXT_texture_shared_exponent: boolean;
Public | EXT_timer_query: boolean;
Public | EXT_transform_feedback: boolean;
Public | EXT_vertex_array: boolean;
Public | EXT_texture_sRGB_decode: boolean;
Public | EXT_direct_state_access: boolean;
Public | EXT_texture_swizzle: boolean;
Public | HP_occlusion_test: boolean;
Public | IBM_rasterpos_clip: boolean;
Public | KTX_buffer_region: boolean;
Public | MESA_resize_buffers: boolean;
Public | NV_blend_square: boolean;
Public | NV_conditional_render: boolean;
Public | NV_copy_image: boolean;
Public | NV_depth_buffer_float: boolean;
Public | NV_fence: boolean;
Public | NV_float_buffer: boolean;
Public | NV_fog_distance: boolean;
Public | NV_geometry_program4: boolean;
Public | NV_light_max_exponent: boolean;
Public | NV_multisample_filter_hint: boolean;
Public | NV_occlusion_query: boolean;
Public | NV_point_sprite: boolean;
Public | NV_primitive_restart: boolean;
Public | NV_register_combiners: boolean;
Public | NV_shader_buffer_load: boolean;
Public | NV_texgen_reflection: boolean;
Public | NV_texture_compression_vtc: boolean;
Public | NV_texture_env_combine4: boolean;
Public | NV_texture_rectangle: boolean;
Public | NV_texture_shader: boolean;
Public | NV_texture_shader2: boolean;
Public | NV_texture_shader3: boolean;
Public | NV_transform_feedback: boolean;
Public | NV_vertex_array_range: boolean;
Public | NV_vertex_array_range2: boolean;
Public | NV_vertex_buffer_unified_memory: boolean;
Public | NV_vertex_program: boolean;
Public | SGI_color_matrix: boolean;
Public | SGIS_generate_mipmap: boolean;
Public | SGIS_multisample: boolean;
Public | SGIS_texture_border_clamp: boolean;
Public | SGIS_texture_color_mask: boolean;
Public | SGIS_texture_edge_clamp: boolean;
Public | SGIS_texture_lod: boolean;
Public | SGIX_depth_texture: boolean;
Public | SGIX_shadow: boolean;
Public | SGIX_shadow_ambient: boolean;
Public | AMD_vertex_shader_tessellator: boolean;
Public | WIN_swap_hint: boolean;
Public | ATI_meminfo: boolean;
Public | NVX_gpu_memory_info: boolean;
Public | NV_vdpau_interop: boolean;
Public | NV_path_rendering: boolean;
Public | GREMEDY_frame_terminator: boolean;
Public | GREMEDY_string_marker: boolean;
Public | AMDX_debug_output: boolean;
Public | ARB_debug_output: boolean;
Public | BindTexture: procedure(target: Cardinal; texture: Cardinal); stdcall;
Public | BlendFunc: procedure(sfactor: Cardinal; dfactor: Cardinal); stdcall;
Public | Clear: procedure(mask: TGLbitfield); stdcall;
Public | ClearColor: procedure(red, green, blue, alpha: Single); stdcall;
Public | ClearDepth: procedure(depth: TGLclampd); stdcall;
Public | ClearStencil: procedure(s: TGLint); stdcall;
Public | ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;
Public | CopyTexImage1D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;
Public | CopyTexImage2D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;
Public | CopyTexSubImage1D: procedure(target: Cardinal; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;
Public | CopyTexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | CullFace: procedure(mode: Cardinal); stdcall;
Public | DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | DepthFunc: procedure(func: Cardinal); stdcall;
Public | DepthMask: procedure(flag: TGLboolean); stdcall;
Public | DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;
Public | Disable: procedure(cap: Cardinal); stdcall;
Public | DrawArrays: procedure(mode: Cardinal; First: TGLint; Count: TGLsizei); stdcall;
Public | DrawBuffer: procedure(mode: Cardinal); stdcall;
Public | DrawElements: procedure(mode: Cardinal; Count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall;
Public | Enable: procedure(cap: Cardinal); stdcall;
Public | Finish: procedure(); stdcall;
Public | Flush: procedure(); stdcall;
Public | FrontFace: procedure(mode: Cardinal); stdcall;
Public | GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | GetBooleanv: procedure(pname: Cardinal; params: PGLboolean); stdcall;
Public | GetDoublev: procedure(pname: Cardinal; params: PGLdouble); stdcall;
Public | GetError: function: Cardinal; stdcall;
Public | GetFloatv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | GetIntegerv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | GetPointerv: procedure(pname: Cardinal; var params); stdcall;
Public | GetString: function(Name: Cardinal): PAnsiChar; stdcall;
Public | GetTexImage: procedure(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | GetTexLevelParameterfv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexLevelParameteriv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;
Public | GetTexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | Hint: procedure(target, mode: Cardinal); stdcall;
Public | IsEnabled: function(cap: Cardinal): TGLboolean; stdcall;
Public | IsTexture: function(texture: Cardinal): TGLboolean; stdcall;
Public | LineWidth: procedure(Width: TGLfloat); stdcall;
Public | LogicOp: procedure(opcode: Cardinal); stdcall;
Public | PixelStoref: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | PixelStorei: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | PointSize: procedure(size: TGLfloat); stdcall;
Public | PolygonMode: procedure(face, mode: Cardinal); stdcall;
Public | PolygonOffset: procedure(factor, units: TGLfloat); stdcall;
Public | ReadBuffer: procedure(mode: Cardinal); stdcall;
Public | ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | StencilFunc: procedure(func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;
Public | StencilMask: procedure(mask: Cardinal); stdcall;
Public | StencilOp: procedure(fail, zfail, zpass: Cardinal); stdcall;
Public | TexImage1D: procedure(target: Cardinal; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexImage2D: procedure(target: Cardinal; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexParameterf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;
Public | TexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | TexSubImage1D: procedure(target: Cardinal; level, xoffset: TGLint; Width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | TexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | Accum: procedure(op: Cardinal; Value: TGLfloat); stdcall;
Public | AlphaFunc: procedure(func: Cardinal; ref: Single); stdcall;
Public | AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;
Public | ArrayElement: procedure(i: TGLint); stdcall;
Public | Begin_: procedure(mode: Cardinal); stdcall;
Public | Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;
Public | CallList: procedure(list: Cardinal); stdcall;
Public | CallLists: procedure(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall;
Public | ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | ClearIndex: procedure(c: TGLfloat); stdcall;
Public | ClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;
Public | Color3b: procedure(red, green, blue: TGLbyte); stdcall;
Public | Color3bv: procedure(v: PGLbyte); stdcall;
Public | Color3d: procedure(red, green, blue: TGLdouble); stdcall;
Public | Color3dv: procedure(v: PGLdouble); stdcall;
Public | Color3f: procedure(red, green, blue: TGLfloat); stdcall;
Public | Color3fv: procedure(v: PGLfloat); stdcall;
Public | Color3i: procedure(red, green, blue: TGLint); stdcall;
Public | Color3iv: procedure(v: PGLint); stdcall;
Public | Color3s: procedure(red, green, blue: TGLshort); stdcall;
Public | Color3sv: procedure(v: PGLshort); stdcall;
Public | Color3ub: procedure(red, green, blue: TGLubyte); stdcall;
Public | Color3ubv: procedure(v: PGLubyte); stdcall;
Public | Color3ui: procedure(red, green, blue: Cardinal); stdcall;
Public | Color3uiv: procedure(v: PGLuint); stdcall;
Public | Color3us: procedure(red, green, blue: TGLushort); stdcall;
Public | Color3usv: procedure(v: PGLushort); stdcall;
Public | Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;
Public | Color4bv: procedure(v: PGLbyte); stdcall;
Public | Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;
Public | Color4dv: procedure(v: PGLdouble); stdcall;
Public | Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | Color4fv: procedure(v: PGLfloat); stdcall;
Public | Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;
Public | Color4iv: procedure(v: PGLint); stdcall;
Public | Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;
Public | Color4sv: procedure(v: TGLshort); stdcall;
Public | Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;
Public | Color4ubv: procedure(v: PGLubyte); stdcall;
Public | Color4ui: procedure(red, green, blue, alpha: Cardinal); stdcall;
Public | Color4uiv: procedure(v: PGLuint); stdcall;
Public | Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;
Public | Color4usv: procedure(v: PGLushort); stdcall;
Public | ColorMaterial: procedure(face: Cardinal; mode: Cardinal); stdcall;
Public | ColorPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: Cardinal); stdcall;
Public | DeleteLists: procedure(list: Cardinal; range: TGLsizei); stdcall;
Public | DisableClientState: procedure(aarray: Cardinal); stdcall;
Public | DrawPixels: procedure(Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;
Public | EdgeFlag: procedure(flag: TGLboolean); stdcall;
Public | EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;
Public | EdgeFlagv: procedure(flag: PGLboolean); stdcall;
Public | EnableClientState: procedure(aarray: Cardinal); stdcall;
Public | End_: procedure(); stdcall;
Public | EndList: procedure(); stdcall;
Public | EvalCoord1d: procedure(u: TGLdouble); stdcall;
Public | EvalCoord1dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord1f: procedure(u: TGLfloat); stdcall;
Public | EvalCoord1fv: procedure(u: PGLfloat); stdcall;
Public | EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;
Public | EvalCoord2dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord2f: procedure(u, v: TGLfloat); stdcall;
Public | EvalCoord2fv: procedure(u: PGLfloat); stdcall;
Public | EvalMesh1: procedure(mode: Cardinal; i1, i2: TGLint); stdcall;
Public | EvalMesh2: procedure(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall;
Public | EvalPoint1: procedure(i: TGLint); stdcall;
Public | EvalPoint2: procedure(i, j: TGLint); stdcall;
Public | FeedbackBuffer: procedure(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall;
Public | Fogf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | Fogfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | Fogi: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | Fogiv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | GenLists: function(range: TGLsizei): Cardinal; stdcall;
Public | GetClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;
Public | GetLightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetLightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;
Public | GetMapdv: procedure(target, query: Cardinal; v: PGLdouble); stdcall;
Public | GetMapfv: procedure(target, query: Cardinal; v: PGLfloat); stdcall;
Public | GetMapiv: procedure(target, query: Cardinal; v: PGLint); stdcall;
Public | GetMaterialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetMaterialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;
Public | GetPixelMapfv: procedure(map: Cardinal; values: PGLfloat); stdcall;
Public | GetPixelMapuiv: procedure(map: Cardinal; values: PGLuint); stdcall;
Public | GetPixelMapusv: procedure(map: Cardinal; values: PGLushort); stdcall;
Public | GetPolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | GetTexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | GetTexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;
Public | GetTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
Public | GetTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
Public | IndexMask: procedure(mask: Cardinal); stdcall;
Public | IndexPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | Indexd: procedure(c: TGLdouble); stdcall;
Public | Indexdv: procedure(c: PGLdouble); stdcall;
Public | Indexf: procedure(c: TGLfloat); stdcall;
Public | Indexfv: procedure(c: PGLfloat); stdcall;
Public | Indexi: procedure(c: TGLint); stdcall;
Public | Indexiv: procedure(c: PGLint); stdcall;
Public | Indexs: procedure(c: TGLshort); stdcall;
Public | Indexsv: procedure(c: PGLshort); stdcall;
Public | Indexub: procedure(c: TGLubyte); stdcall;
Public | Indexubv: procedure(c: PGLubyte); stdcall;
Public | InitNames: procedure(); stdcall;
Public | InterleavedArrays: procedure(format: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | IsList: function(list: Cardinal): TGLboolean; stdcall;
Public | LightModelf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | LightModelfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;
Public | LightModeli: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | LightModeliv: procedure(pname: Cardinal; params: PGLint); stdcall;
Public | Lightf: procedure(light, pname: Cardinal; param: TGLfloat); stdcall;
Public | Lightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;
Public | Lighti: procedure(light, pname: Cardinal; param: TGLint); stdcall;
Public | Lightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;
Public | LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;
Public | ListBase: procedure(base: Cardinal); stdcall;
Public | LoadIdentity: procedure(); stdcall;
Public | LoadMatrixd: procedure(m: PGLdouble); stdcall;
Public | LoadMatrixf: procedure(m: PGLfloat); stdcall;
Public | LoadName: procedure(Name: Cardinal); stdcall;
Public | Map1d: procedure(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;
Public | Map1f: procedure(target: Cardinal; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;
Public | Map2d: procedure(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;
Public | Map2f: procedure(target: Cardinal; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;
Public | MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;
Public | MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;
Public | MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;
Public | MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;
Public | Materialf: procedure(face, pname: Cardinal; param: TGLfloat); stdcall;
Public | Materialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;
Public | Materiali: procedure(face, pname: Cardinal; param: TGLint); stdcall;
Public | Materialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;
Public | MatrixMode: procedure(mode: Cardinal); stdcall;
Public | MultMatrixd: procedure(m: PGLdouble); stdcall;
Public | MultMatrixf: procedure(m: PGLfloat); stdcall;
Public | NewList: procedure(list: Cardinal; mode: Cardinal); stdcall;
Public | Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;
Public | Normal3bv: procedure(v: PGLbyte); stdcall;
Public | Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;
Public | Normal3dv: procedure(v: PGLdouble); stdcall;
Public | Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;
Public | Normal3fv: procedure(v: PGLfloat); stdcall;
Public | Normal3i: procedure(nx, ny, nz: TGLint); stdcall;
Public | Normal3iv: procedure(v: PGLint); stdcall;
Public | Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;
Public | Normal3sv: procedure(v: PGLshort); stdcall;
Public | NormalPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | PassThrough: procedure(token: TGLfloat); stdcall;
Public | PixelMapfv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall;
Public | PixelMapuiv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall;
Public | PixelMapusv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall;
Public | PixelTransferf: procedure(pname: Cardinal; param: TGLfloat); stdcall;
Public | PixelTransferi: procedure(pname: Cardinal; param: TGLint); stdcall;
Public | PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;
Public | PolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | PopAttrib: procedure(); stdcall;
Public | PopClientAttrib: procedure(); stdcall;
Public | PopMatrix: procedure(); stdcall;
Public | PopName: procedure(); stdcall;
Public | PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;
Public | PushAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushClientAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushMatrix: procedure(); stdcall;
Public | PushName: procedure(Name: Cardinal); stdcall;
Public | RasterPos2d: procedure(X, y: TGLdouble); stdcall;
Public | RasterPos2dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos2f: procedure(X, y: TGLfloat); stdcall;
Public | RasterPos2fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos2i: procedure(X, y: TGLint); stdcall;
Public | RasterPos2iv: procedure(v: PGLint); stdcall;
Public | RasterPos2s: procedure(X, y: PGLshort); stdcall;
Public | RasterPos2sv: procedure(v: PGLshort); stdcall;
Public | RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;
Public | RasterPos3dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;
Public | RasterPos3fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos3i: procedure(X, y, z: TGLint); stdcall;
Public | RasterPos3iv: procedure(v: PGLint); stdcall;
Public | RasterPos3s: procedure(X, y, z: TGLshort); stdcall;
Public | RasterPos3sv: procedure(v: PGLshort); stdcall;
Public | RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | RasterPos4dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | RasterPos4fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;
Public | RasterPos4iv: procedure(v: PGLint); stdcall;
Public | RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | RasterPos4sv: procedure(v: PGLshort); stdcall;
Public | Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;
Public | Rectdv: procedure(v1, v2: PGLdouble); stdcall;
Public | Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;
Public | Rectfv: procedure(v1, v2: PGLfloat); stdcall;
Public | Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;
Public | Rectiv: procedure(v1, v2: PGLint); stdcall;
Public | Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;
Public | Rectsv: procedure(v1, v2: PGLshort); stdcall;
Public | RenderMode: function(mode: Cardinal): TGLint; stdcall;
Public | Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;
Public | Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;
Public | Scaled: procedure(X, y, z: TGLdouble); stdcall;
Public | Scalef: procedure(X, y, z: TGLfloat); stdcall;
Public | SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;
Public | ShadeModel: procedure(mode: Cardinal); stdcall;
Public | TexCoord1d: procedure(s: TGLdouble); stdcall;
Public | TexCoord1dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord1f: procedure(s: TGLfloat); stdcall;
Public | TexCoord1fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord1i: procedure(s: TGLint); stdcall;
Public | TexCoord1iv: procedure(v: PGLint); stdcall;
Public | TexCoord1s: procedure(s: TGLshort); stdcall;
Public | TexCoord1sv: procedure(v: PGLshort); stdcall;
Public | TexCoord2d: procedure(s, t: TGLdouble); stdcall;
Public | TexCoord2dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public | TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord2i: procedure(s, t: TGLint); stdcall;
Public | TexCoord2iv: procedure(v: PGLint); stdcall;
Public | TexCoord2s: procedure(s, t: TGLshort); stdcall;
Public | TexCoord2sv: procedure(v: PGLshort); stdcall;
Public | TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;
Public | TexCoord3dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public | TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord3i: procedure(s, t, r: TGLint); stdcall;
Public | TexCoord3iv: procedure(v: PGLint); stdcall;
Public | TexCoord3s: procedure(s, t, r: TGLshort); stdcall;
Public | TexCoord3sv: procedure(v: PGLshort); stdcall;
Public | TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;
Public | TexCoord4dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public | TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;
Public | TexCoord4iv: procedure(v: PGLint); stdcall;
Public | TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;
Public | TexCoord4sv: procedure(v: PGLshort); stdcall;
Public | TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | TexEnvf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexEnvi: procedure(target, pname: Cardinal; param: TGLint); stdcall;
Public | TexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;
Public | TexGend: procedure(coord, pname: Cardinal; param: TGLdouble); stdcall;
Public | TexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;
Public | TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;
Public | TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
Public | TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;
Public | TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
Public | Translated: procedure(X, y, z: TGLdouble); stdcall;
Public | Translatef: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex2d: procedure(X, y: TGLdouble); stdcall;
Public | Vertex2dv: procedure(v: PGLdouble); stdcall;
Public | Vertex2f: procedure(X, y: TGLfloat); stdcall;
Public | Vertex2fv: procedure(v: PGLfloat); stdcall;
Public | Vertex2i: procedure(X, y: TGLint); stdcall;
Public | Vertex2iv: procedure(v: PGLint); stdcall;
Public | Vertex2s: procedure(X, y: TGLshort); stdcall;
Public | Vertex2sv: procedure(v: PGLshort); stdcall;
Public | Vertex3d: procedure(X, y, z: TGLdouble); stdcall;
Public | Vertex3dv: procedure(v: PGLdouble); stdcall;
Public | Vertex3f: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex3fv: procedure(v: PGLfloat); stdcall;
Public | Vertex3i: procedure(X, y, z: TGLint); stdcall;
Public | Vertex3iv: procedure(v: PGLint); stdcall;
Public | Vertex3s: procedure(X, y, z: TGLshort); stdcall;
Public | Vertex3sv: procedure(v: PGLshort); stdcall;
Public | Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | Vertex4dv: procedure(v: PGLdouble); stdcall;
Public | Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | Vertex4fv: procedure(v: PGLfloat); stdcall;
Public | Vertex4i: procedure(X, y, z, w: TGLint); stdcall;
Public | Vertex4iv: procedure(v: PGLint); stdcall;
Public | Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | Vertex4sv: procedure(v: PGLshort); stdcall;
Public | VertexPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;
Public | BlendColor: PFNGLBLENDCOLORPROC;
Public | BlendEquation: PFNGLBLENDEQUATIONPROC;
Public | DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
Public | TexImage3D: PFNGLTEXIMAGE3DPROC;
Public | TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
Public | CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
Public | BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
Public | MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
Public | MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
Public | PointParameterf: PFNGLPOINTPARAMETERFPROC;
Public | PointParameterfv: PFNGLPOINTPARAMETERFVPROC;
Public | PointParameteri: PFNGLPOINTPARAMETERIPROC;
Public | PointParameteriv: PFNGLPOINTPARAMETERIVPROC;
Public | BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
Public | DrawBuffers: PFNGLDRAWBUFFERSPROC;
Public | StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
Public | StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
Public | StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
Public | LockArrays: PFNGLLOCKARRAYSEXTPROC;
Public | UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;
Public | BindBuffer: PFNGLBINDBUFFERPROC;
Public | DeleteBuffers: PFNGLDELETEBUFFERSPROC;
Public | GenBuffers: PFNGLGENBUFFERSPROC;
Public | IsBuffer: PFNGLISBUFFERPROC;
Public | BufferData: PFNGLBUFFERDATAPROC;
Public | BufferSubData: PFNGLBUFFERSUBDATAPROC;
Public | GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
Public | MapBuffer: PFNGLMAPBUFFERPROC;
Public | UnmapBuffer: PFNGLUNMAPBUFFERPROC;
Public | GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
Public | GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
Public | MapBufferRange: PFNGLMAPBUFFERRANGEPROC;
Public | FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
Public | BindBufferRange: PFNGLBINDBUFFERRANGEPROC;
Public | BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;
Public | BindBufferBase: PFNGLBINDBUFFERBASEPROC;
Public | TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
Public | TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
Public | TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
Public | GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
Public | BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
Public | EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
Public | TexBuffer: PFNGLTEXBUFFERPROC;
Public | ClearBufferiv: PFNGLCLEARBUFFERIVPROC;
Public | ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
Public | ClearBufferfv: PFNGLCLEARBUFFERFVPROC;
Public | ClearBufferfi: PFNGLCLEARBUFFERFIPROC;
Public | GetStringi: PFNGLGETSTRINGIPROC;
Public | BindVertexArray: PFNGLBINDVERTEXARRAYPROC;
Public | DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
Public | GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
Public | IsVertexArray: PFNGLISVERTEXARRAYPROC;
Public | FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
Public | VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
Public | GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
Public | GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
Public | GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
Public | GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
Public | GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
Public | GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
Public | UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
Public | CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
Public | UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;
Public | GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
Public | GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;
Public | PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
Public | DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
Public | DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
Public | DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
Public | MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
Public | DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
Public | DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
Public | VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
Public | VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
Public | VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
Public | VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
Public | VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
Public | VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
Public | VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
Public | VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
Public | VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
Public | VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
Public | VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
Public | VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
Public | VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
Public | VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
Public | VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
Public | VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
Public | VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
Public | VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
Public | VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
Public | VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
Public | VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
Public | VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
Public | VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
Public | VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
Public | VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
Public | VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
Public | VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
Public | VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
Public | VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
Public | VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
Public | VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
Public | VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
Public | VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
Public | VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
Public | VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
Public | VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
Public | VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
Public | VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
Public | VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
Public | VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
Public | VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
Public | VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
Public | VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
Public | VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
Public | VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
Public | VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
Public | VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
Public | VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
Public | VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
Public | VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
Public | VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
Public | VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
Public | VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
Public | VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
Public | VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
Public | VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
Public | VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
Public | VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
Public | GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
Public | GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
Public | Uniform1ui: PFNGLUNIFORM1UIPROC;
Public | Uniform2ui: PFNGLUNIFORM2UIPROC;
Public | Uniform3ui: PFNGLUNIFORM3UIPROC;
Public | Uniform4ui: PFNGLUNIFORM4UIPROC;
Public | Uniform1uiv: PFNGLUNIFORM1UIVPROC;
Public | Uniform2uiv: PFNGLUNIFORM2UIVPROC;
Public | Uniform3uiv: PFNGLUNIFORM3UIVPROC;
Public | Uniform4uiv: PFNGLUNIFORM4UIVPROC;
Public | GetUniformuiv: PFNGLGETUNIFORMUIVPROC;
Public | BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
Public | GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
Public | ClampColor: PFNGLCLAMPCOLORPROC;
Public | ColorMaski: PFNGLCOLORMASKIPROC;
Public | GetBooleani_v: PFNGLGETBOOLEANI_VPROC;
Public | GetIntegeri_v: PFNGLGETINTEGERI_VPROC;
Public | Enablei: PFNGLENABLEIPROC;
Public | Disablei: PFNGLDISABLEIPROC;
Public | IsEnabledi: PFNGLISENABLEDIPROC;
Public | EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
Public | DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
Public | VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
Public | ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;
Public | ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;
Public | TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
Public | TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
Public | GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
Public | GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
Public | PatchParameteri: PFNGLPATCHPARAMETERIPROC;
Public | PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
Public | BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
Public | VertexFormatNV: PFNGLVERTEXFORMATNVPROC;
Public | NormalFormatNV: PFNGLNORMALFORMATNVPROC;
Public | ColorFormatNV: PFNGLCOLORFORMATNVPROC;
Public | IndexFormatNV: PFNGLINDEXFORMATNVPROC;
Public | TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
Public | EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
Public | SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
Public | FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
Public | VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
Public | VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
Public | GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
Public | GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;
Public | MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
Public | MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
Public | IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
Public | IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
Public | GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
Public | GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
Public | Uniformui64NV: PFNGLUNIFORMUI64NVPROC;
Public | Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
Public | GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
Public | ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
Public | ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
Public | ClearBufferData: PFNGLClearBufferData;
Public | ClearBufferSubData: PFNGLClearBufferSubData;
Public | ClearNamedBufferData: PFNGLClearNamedBufferData;
Public | ClearNamedBufferSubData: PFNGLClearNamedBufferSubData;
Public | InvalidateTexSubImage: PFNGLInvalidateTexSubImage;
Public | InvalidateTexImage: PFNGLInvalidateTexImage;
Public | InvalidateBufferSubData: PFNGLInvalidateBufferSubData;
Public | InvalidateBufferData: PFNGLInvalidateBufferData;
Public | InvalidateFramebuffer: PFNGLInvalidateFramebuffer;
Public | InvalidateSubFramebuffer: PFNGLInvalidateSubFramebuffer;
Public | MultiDrawArraysIndirect: PFNGLMultiDrawArraysIndirect;
Public | MultiDrawElementsIndirect: PFNGLMultiDrawElementsIndirect;
Public | BindVertexBuffer: PFNGLBindVertexBuffer;
Public | VertexAttribFormat: PFNGLVertexAttribFormat;
Public | VertexAttribIFormat: PFNGLVertexAttribIFormat;
Public | VertexAttribLFormat: PFNGLVertexAttribLFormat;
Public | VertexAttribBinding: PFNGLVertexAttribBinding;
Public | VertexBindingDivisor: PFNGLVertexBindingDivisor;
Public | VertexArrayBindVertexBuffer: PFNGLVertexArrayBindVertexBuffer;
Public | VertexArrayVertexAttribFormat: PFNGLVertexArrayVertexAttribFormat;
Public | VertexArrayVertexAttribIFormat: PFNGLVertexArrayVertexAttribIFormat;
Public | VertexArrayVertexAttribLFormat: PFNGLVertexArrayVertexAttribLFormat;
Public | VertexArrayVertexAttribBinding: PFNGLVertexArrayVertexAttribBinding;
Public | VertexArrayVertexBindingDivisor: PFNGLVertexArrayVertexBindingDivisor;
Public | DeleteObject: PFNGLDELETEOBJECTARBPROC;
Public | GetHandle: PFNGLGETHANDLEARBPROC;
Public | DetachShader: PFNGLDETACHSHADERPROC;
Public | CreateShader: PFNGLCREATESHADERPROC;
Public | DeleteShader: PFNGLDELETESHADERPROC;
Public | ShaderSource: PFNGLSHADERSOURCEPROC;
Public | CompileShader: PFNGLCOMPILESHADERPROC;
Public | CreateProgram: PFNGLCREATEPROGRAMPROC;
Public | DeleteProgram: PFNGLDELETEPROGRAMPROC;
Public | AttachShader: PFNGLATTACHSHADERPROC;
Public | LinkProgram: PFNGLLINKPROGRAMPROC;
Public | UseProgram: PFNGLUSEPROGRAMPROC;
Public | ValidateProgram: PFNGLVALIDATEPROGRAMPROC;
Public | Uniform1f: PFNGLUNIFORM1FPROC;
Public | Uniform2f: PFNGLUNIFORM2FPROC;
Public | Uniform3f: PFNGLUNIFORM3FPROC;
Public | Uniform4f: PFNGLUNIFORM4FPROC;
Public | Uniform1i: PFNGLUNIFORM1IPROC;
Public | Uniform2i: PFNGLUNIFORM2IPROC;
Public | Uniform3i: PFNGLUNIFORM3IPROC;
Public | Uniform4i: PFNGLUNIFORM4IPROC;
Public | Uniform1fv: PFNGLUNIFORM1FVPROC;
Public | Uniform2fv: PFNGLUNIFORM2FVPROC;
Public | Uniform3fv: PFNGLUNIFORM3FVPROC;
Public | Uniform4fv: PFNGLUNIFORM4FVPROC;
Public | Uniform1iv: PFNGLUNIFORM1IVPROC;
Public | Uniform2iv: PFNGLUNIFORM2IVPROC;
Public | Uniform3iv: PFNGLUNIFORM3IVPROC;
Public | Uniform4iv: PFNGLUNIFORM4IVPROC;
Public | UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
Public | UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
Public | UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
Public | GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;
Public | GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;
Public | GetInfoLog: PFNGLGETINFOLOGARBPROC;
Public | GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;
Public | GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
Public | GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
Public | GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
Public | GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
Public | GetProgramiv: PFNGLGETPROGRAMIVPROC;
Public | GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
Public | GetShaderiv: PFNGLGETSHADERIVPROC;
Public | GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
Public | GetShaderSource: PFNGLGETSHADERSOURCEPROC;
Public | GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
Public | GetUniformfv: PFNGLGETUNIFORMFVPROC;
Public | GetUniformiv: PFNGLGETUNIFORMIVPROC;
Public | GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
Public | GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
Public | GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
Public | GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
Public | IsProgram: PFNGLISPROGRAMPROC;
Public | IsShader: PFNGLISSHADERPROC;
Public | BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
Public | BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
Public | GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
Public | GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;
Public | GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;
Public | ActiveVarying: PFNGLACTIVEVARYINGNVPROC;
Public | GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;
Public | ProgramBinary: PFNGLPROGRAMBINARYPROC;
Public | UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
Public | ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
Public | CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
Public | BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
Public | DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
Public | GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
Public | IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
Public | GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
Public | ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
Public | ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
Public | ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
Public | ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
Public | ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
Public | ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
Public | ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
Public | ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
Public | ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
Public | ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
Public | ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
Public | ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
Public | ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
Public | ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
Public | ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
Public | ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
Public | ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
Public | ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
Public | ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
Public | ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
Public | ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
Public | ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
Public | ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
Public | ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
Public | ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
Public | ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
Public | ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
Public | ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
Public | ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
Public | ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
Public | ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
Public | ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
Public | ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
Public | ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
Public | ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
Public | ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
Public | ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
Public | ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
Public | ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
Public | ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
Public | ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
Public | ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
Public | ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
Public | ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
Public | ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
Public | ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
Public | ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
Public | ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
Public | ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
Public | ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
Public | ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
Public | GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
Public | DispatchCompute: PFNGLDispatchCompute;
Public | DispatchComputeIndirect: PFNGLDispatchComputeIndirect;
Public | ShaderStorageBlockBinding: PFNGLShaderStorageBlockBinding;
Public | IsRenderbuffer: PFNGLISRENDERBUFFERPROC;
Public | BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
Public | DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
Public | GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
Public | RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
Public | RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
Public | GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
Public | IsFramebuffer: PFNGLISFRAMEBUFFERPROC;
Public | BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
Public | DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
Public | GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
Public | CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
Public | FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
Public | FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
Public | FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
Public | FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
Public | FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
Public | FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
Public | FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
Public | GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
Public | BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
Public | GenerateMipmap: PFNGLGENERATEMIPMAPPROC;
Public | FramebufferParameteri: PFNGLFramebufferParameteri;
Public | NamedFramebufferParameteri: PFNGLNamedFramebufferParameteri;
Public | GetNamedFramebufferParameteriv: PFNGLGetNamedFramebufferParameteriv;
Public | GenQueries: PFNGLGENQUERIESPROC;
Public | DeleteQueries: PFNGLDELETEQUERIESPROC;
Public | IsQuery: PFNGLISQUERYPROC;
Public | BeginQuery: PFNGLBEGINQUERYPROC;
Public | EndQuery: PFNGLENDQUERYPROC;
Public | GetQueryiv: PFNGLGETQUERYIVPROC;
Public | GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
Public | GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
Public | QueryCounter: PFNGLQUERYCOUNTERPROC;
Public | GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
Public | GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
Public | GetInternalformati64v: PFNGLGetInternalformati64v;
Public | GetProgramInterfaceiv: PFNGLGetProgramInterfaceiv;
Public | GetProgramResourceIndex: PFNGLGetProgramResourceIndex;
Public | GetProgramResourceName: PFNGLGetProgramResourceName;
Public | GetProgramResourceiv: PFNGLGetProgramResourceiv;
Public | GetProgramResourceLocation: PFNGLGetProgramResourceLocation;
Public | GetProgramResourceLocationIndex: PFNGLGetProgramResourceLocationIndex;
Public | ActiveTexture: PFNGLACTIVETEXTUREPROC;
Public | SampleCoverage: PFNGLSAMPLECOVERAGEPROC;
Public | CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
Public | CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
Public | CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
Public | CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
Public | CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
Public | CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
Public | GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
Public | ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
Public | MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
Public | MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
Public | MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
Public | MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;
Public | MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
Public | MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;
Public | MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
Public | MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;
Public | MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
Public | MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
Public | MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
Public | MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
Public | MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
Public | MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
Public | MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
Public | MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
Public | MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
Public | MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
Public | MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
Public | MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
Public | MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
Public | MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
Public | MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
Public | MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
Public | MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
Public | MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
Public | MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
Public | MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
Public | MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
Public | MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
Public | MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
Public | MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
Public | GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
Public | GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
Public | ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;
Public | ProgramString: PFNGLPROGRAMSTRINGARBPROC;
Public | BindProgram: PFNGLBINDPROGRAMARBPROC;
Public | DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;
Public | GenPrograms: PFNGLGENPROGRAMSARBPROC;
Public | ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;
Public | ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
Public | ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;
Public | ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
Public | ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
Public | ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
Public | ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
Public | ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
Public | GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
Public | GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
Public | GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
Public | GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
Public | TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
Public | TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
Public | GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
Public | SampleMaski: PFNGLSAMPLEMASKIPROC;
Public | ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
Public | FenceSync: PFNGLFENCESYNCPROC;
Public | IsSync: PFNGLISSYNCPROC;
Public | DeleteSync: PFNGLDELETESYNCPROC;
Public | ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
Public | WaitSync: PFNGLWAITSYNCPROC;
Public | GetInteger64v: PFNGLGETINTEGER64VPROC;
Public | GetSynciv: PFNGLGETSYNCIVPROC;
Public | BlendEquationi: PFNGLBLENDEQUATIONIPROC;
Public | BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
Public | BlendFunci: PFNGLBLENDFUNCIPROC;
Public | BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
Public | MinSampleShading: PFNGLMINSAMPLESHADINGPROC;
Public | GenSamplers: PFNGLGENSAMPLERSPROC;
Public | DeleteSamplers: PFNGLDELETESAMPLERSPROC;
Public | IsSampler: PFNGLISSAMPLERPROC;
Public | BindSampler: PFNGLBINDSAMPLERPROC;
Public | SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
Public | SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
Public | SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
Public | SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
Public | SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
Public | SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
Public | GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
Public | GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
Public | GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
Public | GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
Public | CopyImageSubData: PFNGLCopyImageSubData;
Public | TexBufferRange: PFNGLTexBufferRange;
Public | TextureBufferRange: PFNGLTextureBufferRange;
Public | TexStorage2DMultisample: PFNGLTexStorage2DMultisample;
Public | TexStorage3DMultisample: PFNGLTexStorage3DMultisample;
Public | TextureStorage2DMultisample: PFNGLTextureStorage2DMultisample;
Public | TextureStorage3DMultisample: PFNGLTextureStorage3DMultisample;
Public | BufferStorage: PFNGLBufferStorage;
Public | ClearTexImage: PFNGLClearTexImage;
Public | ClearTexSubImage: PFNGLClearTexSubImage;
Public | BindBuffersBase: PFNGLBindBuffersBase;
Public | BindBuffersRange: PFNGLBindBuffersRange;
Public | BindTextures: PFNGLBindTextures;
Public | BindSamplers: PFNGLBindSamplers;
Public | BindImageTextures: PFNGLBindImageTextures;
Public | BindVertexBuffers: PFNGLBindVertexBuffers;
Public | TextureView: PFNGLTextureView;
Public | ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;
Public | PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;
Public | MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;
Public | MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;
Public | MatrixMultf: PFNGLMATRIXMULTFEXTPROC;
Public | MatrixMultd: PFNGLMATRIXMULTDEXTPROC;
Public | MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;
Public | MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;
Public | MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;
Public | MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;
Public | MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;
Public | MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;
Public | MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;
Public | MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;
Public | MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;
Public | MatrixPop: PFNGLMATRIXPOPEXTPROC;
Public | MatrixPush: PFNGLMATRIXPUSHEXTPROC;
Public | MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;
Public | MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;
Public | MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;
Public | MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;
Public | TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;
Public | TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;
Public | TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;
Public | TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;
Public | TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;
Public | TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;
Public | TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;
Public | CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;
Public | CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;
Public | CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;
Public | CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;
Public | GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;
Public | GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;
Public | GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;
Public | GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;
Public | GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;
Public | TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;
Public | TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;
Public | CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;
Public | MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;
Public | MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;
Public | MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;
Public | MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;
Public | MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;
Public | MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;
Public | MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;
Public | MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;
Public | CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;
Public | CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;
Public | CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;
Public | CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;
Public | GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;
Public | GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;
Public | GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;
Public | GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;
Public | GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;
Public | MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;
Public | MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;
Public | CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;
Public | BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;
Public | EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;
Public | DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;
Public | MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;
Public | MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;
Public | MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;
Public | MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;
Public | MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;
Public | MultiTexGend: PFNGLMULTITEXGENDEXTPROC;
Public | MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;
Public | MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;
Public | MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;
Public | MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;
Public | MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;
Public | GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;
Public | GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;
Public | GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;
Public | GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;
Public | GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;
Public | GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;
Public | GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;
Public | GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;
Public | CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;
Public | CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;
Public | CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;
Public | CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;
Public | CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;
Public | CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;
Public | GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;
Public | CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;
Public | CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;
Public | CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;
Public | CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;
Public | CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;
Public | CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;
Public | GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;
Public | NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;
Public | NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;
Public | NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;
Public | NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;
Public | GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;
Public | GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;
Public | GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;
Public | GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;
Public | NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;
Public | NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;
Public | NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;
Public | NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;
Public | NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;
Public | NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;
Public | GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;
Public | GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;
Public | TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;
Public | TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;
Public | GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;
Public | GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;
Public | MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;
Public | MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;
Public | GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;
Public | GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;
Public | NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;
Public | NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;
Public | MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;
Public | UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;
Public | MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;
Public | FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;
Public | NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;
Public | GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;
Public | GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;
Public | GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;
Public | TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;
Public | MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;
Public | NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;
Public | GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;
Public | CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;
Public | NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;
Public | NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;
Public | NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;
Public | NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;
Public | GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
Public | GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;
Public | GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;
Public | FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;
Public | FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;
Public | FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;
Public | GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;
Public | NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
Public | NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;
Public | NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;
Public | NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;
Public | NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;
Public | TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;
Public | MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;
Public | FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
Public | StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
Public | DebugMessageEnableAMDX: procedure(category: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean);
Public | PushDebugGroup: PFNGLPushDebugGroup;
Public | PopDebugGroup: PFNGLPopDebugGroup;
Public | ObjectLabel: PFNGLObjectLabel;
Public | GetObjectLabel: PFNGLGetObjectLabel;
Public | ObjectPtrLabel: PFNGLObjectPtrLabel;
Public | GetObjectPtrLabel: PFNGLGetObjectPtrLabel;
Public | DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;
Public | DebugMessageControl: procedure(type_: Cardinal; Source: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean); stdcall;
Public | DebugMessageInsert: procedure(Source: Cardinal; severity: Cardinal; id: Cardinal; length: TGLsizei; const buf: PAnsiChar); stdcall;
Public | DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;
Public | GetDebugMessageLog: function(Count: Cardinal; bufSize: TGLsizei; var severity: Cardinal; var severities: Cardinal; var ids: Cardinal; var lengths: TGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;
Public | CreateSyncFromCLevent: PFNGLCreateSyncFromCLevent;
Public | VDPAUInitNV: procedure(const vdpDevice: Pointer; const getProcAddress: Pointer); stdcall;
Public | VDPAUFiniNV: procedure(); stdcall;
Public | VDPAURegisterVideoSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;
Public | VDPAURegisterOutputSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;
Public | VDPAUIsSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;
Public | VDPAUUnregisterSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;
Public | VDPAUGetSurfaceivNV: procedure(surface: TGLvdpauSurfaceNV; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;
Public | VDPAUSurfaceAccessNV: procedure(surface: TGLvdpauSurfaceNV; access: Cardinal); stdcall;
Public | VDPAUMapSurfacesNV: procedure(numSurfaces: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;
Public | VDPAUUnmapSurfacesNV: procedure(numSurface: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;
Public | GenPathsNV: PFNGLGENPATHSNVPROC;
Public | DeletePathsNV: PFNGLDELETEPATHSNVPROC;
Public | IsPathNV: PFNGLISPATHNVPROC;
Public | PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;
Public | PathCoordsNV: PFNGLPATHCOORDSNVPROC;
Public | PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;
Public | PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;
Public | PathStringNV: PFNGLPATHSTRINGNVPROC;
Public | PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;
Public | PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;
Public | WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;
Public | CopyPathNV: PFNGLCOPYPATHNVPROC;
Public | InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;
Public | PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;
Public | PathParameteriNV: PFNGLPATHPARAMETERINVPROC;
Public | PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;
Public | PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;
Public | PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;
Public | PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;
Public | StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;
Public | StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;
Public | StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;
Public | StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;
Public | PathColorGenNV: PFNGLPATHCOLORGENNVPROC;
Public | PathTexGenNV: PFNGLPATHTEXGENNVPROC;
Public | PathFogGenNV: PFNGLPATHFOGGENNVPROC;
Public | CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;
Public | CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;
Public | CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;
Public | CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;
Public | GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;
Public | GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;
Public | GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;
Public | GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;
Public | GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;
Public | GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;
Public | GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;
Public | GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;
Public | GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;
Public | GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;
Public | GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;
Public | GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;
Public | IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;
Public | IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;
Public | GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;
Public | PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;
Public | PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;
Public | PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;
Public | W_ARB_buffer_region: boolean;
Public | W_ARB_create_context: boolean;
Public | W_ARB_create_context_profile: boolean;
Public | W_ARB_extensions_string: boolean;
Public | W_ARB_framebuffer_sRGB: boolean;
Public | W_ARB_make_current_read: boolean;
Public | W_ARB_multisample: boolean;
Public | W_ARB_pbuffer: boolean;
Public | W_ARB_pixel_format: boolean;
Public | W_ARB_pixel_format_float: boolean;
Public | W_ARB_render_texture: boolean;
Public | W_ATI_pixel_format_float: boolean;
Public | W_EXT_framebuffer_sRGB: boolean;
Public | W_EXT_pixel_format_packed_float: boolean;
Public | W_EXT_swap_control: boolean;
Public | W_NV_gpu_affinity: boolean;
Public | W_EXT_create_context_es2_profile: boolean;
Public | W_NV_DX_interop: boolean;
Public | W_NV_DX_interop2: boolean;
Public | WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
Public | WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
Public | WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
Public | WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
Public | WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
Public | WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
Public | WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
Public | WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
Public | WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
Public | WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
Public | WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
Public | WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
Public | WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
Public | WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
Public | WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
Public | WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
Public | WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
Public | WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
Public | WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
Public | WEnumGpusNV: PFNWGLENUMGPUSNVPROC;
Public | WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
Public | WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
Public | WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
Public | WDeleteDCNV: PFNWGLDELETEDCNVPROC;
Public | WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;
Public | WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;
Public | WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;
Public | WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;
Public | WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;
Public | WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;
Public | WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;
Public | WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;
Public | WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
Public | WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
Public | WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
Public | WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
Public | UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
Public | UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;
Public | UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

Methods

Public | constructor Create;
Private | function CheckExtension(const Extension: string): boolean;
Private | function GetAddress(const ProcName: string): Pointer;
Private | function GetAddressAlt(const ProcName1, ProcName2: string): Pointer;
Private | function GetAddressNoSuffixes(const ProcName: string): Pointer;
Private | function GetCapAddress: Pointer;
Public | procedure CheckError;
Public | procedure ClearError;
Public | procedure Close;
Public | procedure Initialize(ATemporary: boolean = False);
Private | procedure ReadWGLExtensions;
Private | procedure ReadWGLImplementationProperties;

Properties

Public | property DebugMode: boolean read FDebug write FDebug;
Public | property IsInitialized: boolean read FInitialized;

Description

Fields

Private FBuffer: string;

This item has no description.

Private FInitialized: boolean;

This item has no description.

Private FDebug: boolean;

This item has no description.

Private FDebugIds: Cardinal;

This item has no description.

Public VERSION_1_0: boolean;

This item has no description.

Public VERSION_1_1: boolean;

This item has no description.

Public VERSION_1_2: boolean;

This item has no description.

Public VERSION_1_3: boolean;

This item has no description.

Public VERSION_1_4: boolean;

This item has no description.

Public VERSION_1_5: boolean;

This item has no description.

Public VERSION_2_0: boolean;

This item has no description.

Public VERSION_2_1: boolean;

This item has no description.

Public VERSION_3_0: boolean;

This item has no description.

Public VERSION_3_1: boolean;

This item has no description.

Public VERSION_3_2: boolean;

This item has no description.

Public VERSION_3_3: boolean;

This item has no description.

Public VERSION_4_0: boolean;

This item has no description.

Public VERSION_4_1: boolean;

This item has no description.

Public VERSION_4_2: boolean;

This item has no description.

Public ARB_blend_func_extended: boolean;

This item has no description.

Public ARB_color_buffer_float: boolean;

This item has no description.

Public ARB_compatibility: boolean;

This item has no description.

Public ARB_copy_buffer: boolean;

This item has no description.

Public ARB_depth_buffer_float: boolean;

This item has no description.

Public ARB_depth_clamp: boolean;

This item has no description.

Public ARB_depth_texture: boolean;

This item has no description.

Public ARB_draw_buffers: boolean;

This item has no description.

Public ARB_draw_buffers_blend: boolean;

This item has no description.

Public ARB_draw_elements_base_vertex: boolean;

This item has no description.

Public ARB_draw_indirect: boolean;

This item has no description.

Public ARB_draw_instanced: boolean;

This item has no description.

Public ARB_explicit_attrib_location: boolean;

This item has no description.

Public ARB_fragment_coord_conventions: boolean;

This item has no description.

Public ARB_fragment_program: boolean;

This item has no description.

Public ARB_fragment_program_shadow: boolean;

This item has no description.

Public ARB_fragment_shader: boolean;

This item has no description.

Public ARB_framebuffer_object: boolean;

This item has no description.

Public ARB_framebuffer_sRGB: boolean;

This item has no description.

Public ARB_geometry_shader4: boolean;

This item has no description.

Public ARB_gpu_shader_fp64: boolean;

This item has no description.

Public ARB_gpu_shader5: boolean;

This item has no description.

Public ARB_half_float_pixel: boolean;

This item has no description.

Public ARB_half_float_vertex: boolean;

This item has no description.

Public ARB_imaging: boolean;

This item has no description.

Public ARB_instanced_arrays: boolean;

This item has no description.

Public ARB_map_buffer_range: boolean;

This item has no description.

Public ARB_matrix_palette: boolean;

This item has no description.

Public ARB_multisample: boolean;

This item has no description.

Public ARB_multitexture: boolean;

This item has no description.

Public ARB_occlusion_query: boolean;

This item has no description.

Public ARB_occlusion_query2: boolean;

This item has no description.

Public ARB_pixel_buffer_object: boolean;

This item has no description.

Public ARB_point_parameters: boolean;

This item has no description.

Public ARB_point_sprite: boolean;

This item has no description.

Public ARB_provoking_vertex: boolean;

This item has no description.

Public ARB_sample_shading: boolean;

This item has no description.

Public ARB_sampler_objects: boolean;

This item has no description.

Public ARB_seamless_cube_map: boolean;

This item has no description.

Public ARB_shader_bit_encoding: boolean;

This item has no description.

Public ARB_shader_subroutine: boolean;

This item has no description.

Public ARB_shader_texture_lod: boolean;

This item has no description.

Public ARB_shading_language_100: boolean;

This item has no description.

Public ARB_shadow: boolean;

This item has no description.

Public ARB_shadow_ambient: boolean;

This item has no description.

Public ARB_shader_objects: boolean;

This item has no description.

Public ARB_sync: boolean;

This item has no description.

Public ARB_tessellation_shader: boolean;

This item has no description.

Public ARB_texture_border_clamp: boolean;

This item has no description.

Public ARB_texture_buffer_object: boolean;

This item has no description.

Public ARB_texture_buffer_object_rgb32: boolean;

This item has no description.

Public ARB_texture_compression: boolean;

This item has no description.

Public ARB_texture_compression_rgtc: boolean;

This item has no description.

Public ARB_texture_cube_map: boolean;

This item has no description.

Public ARB_texture_cube_map_array: boolean;

This item has no description.

Public ARB_texture_env_add: boolean;

This item has no description.

Public ARB_texture_env_combine: boolean;

This item has no description.

Public ARB_texture_env_crossbar: boolean;

This item has no description.

Public ARB_texture_env_dot3: boolean;

This item has no description.

Public ARB_texture_float: boolean;

This item has no description.

Public ARB_texture_gather: boolean;

This item has no description.

Public ARB_texture_mirrored_repeat: boolean;

This item has no description.

Public ARB_texture_multisample: boolean;

This item has no description.

Public ARB_texture_non_power_of_two: boolean;

This item has no description.

Public ARB_texture_query_lod: boolean;

This item has no description.

Public ARB_texture_rectangle: boolean;

This item has no description.

Public ARB_texture_rg: boolean;

This item has no description.

Public ARB_texture_rgb10_a2ui: boolean;

This item has no description.

Public ARB_texture_swizzle: boolean;

This item has no description.

Public ARB_timer_query: boolean;

This item has no description.

Public ARB_transform_feedback2: boolean;

This item has no description.

Public ARB_transform_feedback3: boolean;

This item has no description.

Public ARB_transpose_matrix: boolean;

This item has no description.

Public ARB_uniform_buffer_object: boolean;

This item has no description.

Public ARB_vertex_array_bgra: boolean;

This item has no description.

Public ARB_vertex_array_object: boolean;

This item has no description.

Public ARB_vertex_blend: boolean;

This item has no description.

Public ARB_vertex_buffer_object: boolean;

This item has no description.

Public ARB_vertex_program: boolean;

This item has no description.

Public ARB_vertex_shader: boolean;

This item has no description.

Public ARB_vertex_type_2_10_10_10_rev: boolean;

This item has no description.

Public ARB_window_pos: boolean;

This item has no description.

Public ARB_texture_compression_bptc: boolean;

This item has no description.

Public ARB_get_program_binary: boolean;

This item has no description.

Public ARB_separate_shader_objects: boolean;

This item has no description.

Public ARB_shader_stencil_export: boolean;

This item has no description.

Public KHR_debug: boolean;

This item has no description.

Public ARB_clear_buffer_object: boolean;

This item has no description.

Public ARB_compute_shader: boolean;

This item has no description.

Public ARB_copy_image: boolean;

This item has no description.

Public ARB_debug_group: boolean;

This item has no description.

Public ARB_debug_label: boolean;

This item has no description.

Public ARB_debug_output2: boolean;

This item has no description.

Public ARB_ES3_compatibility: boolean;

This item has no description.

Public ARB_explicit_uniform_location: boolean;

This item has no description.

Public ARB_fragment_layer_viewport: boolean;

This item has no description.

Public ARB_framebuffer_no_attachments: boolean;

This item has no description.

Public ARB_internalformat_query2: boolean;

This item has no description.

Public ARB_invalidate_subdata: boolean;

This item has no description.

Public ARB_multi_draw_indirect: boolean;

This item has no description.

Public ARB_program_interface_query: boolean;

This item has no description.

Public ARB_shader_image_size: boolean;

This item has no description.

Public ARB_shader_storage_buffer_object: boolean;

This item has no description.

Public ARB_stencil_texturing: boolean;

This item has no description.

Public ARB_texture_buffer_range: boolean;

This item has no description.

Public ARB_texture_query_levels: boolean;

This item has no description.

Public ARB_texture_storage_multisample: boolean;

This item has no description.

Public ARB_texture_view: boolean;

This item has no description.

Public ARB_vertex_attrib_binding: boolean;

This item has no description.

Public ARB_robustness_isolation: boolean;

This item has no description.

Public ARB_cl_event: boolean;

This item has no description.

Public _3DFX_multisample: boolean;

This item has no description.

Public _3DFX_tbuffer: boolean;

This item has no description.

Public _3DFX_texture_compression_FXT1: boolean;

This item has no description.

Public ATI_draw_buffers: boolean;

This item has no description.

Public ATI_texture_compression_3dc: boolean;

This item has no description.

Public ATI_texture_float: boolean;

This item has no description.

Public ATI_texture_mirror_once: boolean;

This item has no description.

Public S3_s3tc: boolean;

This item has no description.

Public EXT_abgr: boolean;

This item has no description.

Public EXT_bgra: boolean;

This item has no description.

Public EXT_bindable_uniform: boolean;

This item has no description.

Public EXT_blend_color: boolean;

This item has no description.

Public EXT_blend_equation_separate: boolean;

This item has no description.

Public EXT_blend_func_separate: boolean;

This item has no description.

Public EXT_blend_logic_op: boolean;

This item has no description.

Public EXT_blend_minmax: boolean;

This item has no description.

Public EXT_blend_subtract: boolean;

This item has no description.

Public EXT_Cg_shader: boolean;

This item has no description.

Public EXT_clip_volume_hint: boolean;

This item has no description.

Public EXT_compiled_vertex_array: boolean;

This item has no description.

Public EXT_copy_texture: boolean;

This item has no description.

Public EXT_depth_bounds_test: boolean;

This item has no description.

Public EXT_draw_buffers2: boolean;

This item has no description.

Public EXT_draw_instanced: boolean;

This item has no description.

Public EXT_draw_range_elements: boolean;

This item has no description.

Public EXT_fog_coord: boolean;

This item has no description.

Public EXT_framebuffer_blit: boolean;

This item has no description.

Public EXT_framebuffer_multisample: boolean;

This item has no description.

Public EXT_framebuffer_object: boolean;

This item has no description.

Public EXT_framebuffer_sRGB: boolean;

This item has no description.

Public EXT_geometry_shader4: boolean;

This item has no description.

Public EXT_gpu_program_parameters: boolean;

This item has no description.

Public EXT_gpu_shader4: boolean;

This item has no description.

Public EXT_multi_draw_arrays: boolean;

This item has no description.

Public EXT_multisample: boolean;

This item has no description.

Public EXT_packed_depth_stencil: boolean;

This item has no description.

Public EXT_packed_float: boolean;

This item has no description.

Public EXT_packed_pixels: boolean;

This item has no description.

Public EXT_paletted_texture: boolean;

This item has no description.

Public EXT_pixel_buffer_object: boolean;

This item has no description.

Public EXT_polygon_offset: boolean;

This item has no description.

Public EXT_rescale_normal: boolean;

This item has no description.

Public EXT_secondary_color: boolean;

This item has no description.

Public EXT_separate_specular_color: boolean;

This item has no description.

Public EXT_shadow_funcs: boolean;

This item has no description.

Public EXT_shared_texture_palette: boolean;

This item has no description.

Public EXT_stencil_clear_tag: boolean;

This item has no description.

Public EXT_stencil_two_side: boolean;

This item has no description.

Public EXT_stencil_wrap: boolean;

This item has no description.

Public EXT_texture3D: boolean;

This item has no description.

Public EXT_texture_array: boolean;

This item has no description.

Public EXT_texture_buffer_object: boolean;

This item has no description.

Public EXT_texture_compression_latc: boolean;

This item has no description.

Public EXT_texture_compression_rgtc: boolean;

This item has no description.

Public EXT_texture_compression_s3tc: boolean;

This item has no description.

Public EXT_texture_cube_map: boolean;

This item has no description.

Public EXT_texture_edge_clamp: boolean;

This item has no description.

Public EXT_texture_env_add: boolean;

This item has no description.

Public EXT_texture_env_combine: boolean;

This item has no description.

Public EXT_texture_env_dot3: boolean;

This item has no description.

Public EXT_texture_filter_anisotropic: boolean;

This item has no description.

Public EXT_texture_integer: boolean;

This item has no description.

Public EXT_texture_lod: boolean;

This item has no description.

Public EXT_texture_lod_bias: boolean;

This item has no description.

Public EXT_texture_mirror_clamp: boolean;

This item has no description.

Public EXT_texture_object: boolean;

This item has no description.

Public EXT_texture_rectangle: boolean;

This item has no description.

Public EXT_texture_sRGB: boolean;

This item has no description.

Public EXT_texture_shared_exponent: boolean;

This item has no description.

Public EXT_timer_query: boolean;

This item has no description.

Public EXT_transform_feedback: boolean;

This item has no description.

Public EXT_vertex_array: boolean;

This item has no description.

Public EXT_texture_sRGB_decode: boolean;

This item has no description.

Public EXT_direct_state_access: boolean;

This item has no description.

Public EXT_texture_swizzle: boolean;

This item has no description.

Public HP_occlusion_test: boolean;

This item has no description.

Public IBM_rasterpos_clip: boolean;

This item has no description.

Public KTX_buffer_region: boolean;

This item has no description.

Public MESA_resize_buffers: boolean;

This item has no description.

Public NV_blend_square: boolean;

This item has no description.

Public NV_conditional_render: boolean;

This item has no description.

Public NV_copy_image: boolean;

This item has no description.

Public NV_depth_buffer_float: boolean;

This item has no description.

Public NV_fence: boolean;

This item has no description.

Public NV_float_buffer: boolean;

This item has no description.

Public NV_fog_distance: boolean;

This item has no description.

Public NV_geometry_program4: boolean;

This item has no description.

Public NV_light_max_exponent: boolean;

This item has no description.

Public NV_multisample_filter_hint: boolean;

This item has no description.

Public NV_occlusion_query: boolean;

This item has no description.

Public NV_point_sprite: boolean;

This item has no description.

Public NV_primitive_restart: boolean;

This item has no description.

Public NV_register_combiners: boolean;

This item has no description.

Public NV_shader_buffer_load: boolean;

This item has no description.

Public NV_texgen_reflection: boolean;

This item has no description.

Public NV_texture_compression_vtc: boolean;

This item has no description.

Public NV_texture_env_combine4: boolean;

This item has no description.

Public NV_texture_rectangle: boolean;

This item has no description.

Public NV_texture_shader: boolean;

This item has no description.

Public NV_texture_shader2: boolean;

This item has no description.

Public NV_texture_shader3: boolean;

This item has no description.

Public NV_transform_feedback: boolean;

This item has no description.

Public NV_vertex_array_range: boolean;

This item has no description.

Public NV_vertex_array_range2: boolean;

This item has no description.

Public NV_vertex_buffer_unified_memory: boolean;

This item has no description.

Public NV_vertex_program: boolean;

This item has no description.

Public SGI_color_matrix: boolean;

This item has no description.

Public SGIS_generate_mipmap: boolean;

This item has no description.

Public SGIS_multisample: boolean;

This item has no description.

Public SGIS_texture_border_clamp: boolean;

This item has no description.

Public SGIS_texture_color_mask: boolean;

This item has no description.

Public SGIS_texture_edge_clamp: boolean;

This item has no description.

Public SGIS_texture_lod: boolean;

This item has no description.

Public SGIX_depth_texture: boolean;

This item has no description.

Public SGIX_shadow: boolean;

This item has no description.

Public SGIX_shadow_ambient: boolean;

This item has no description.

Public AMD_vertex_shader_tessellator: boolean;

This item has no description.

Public WIN_swap_hint: boolean;

This item has no description.

Public ATI_meminfo: boolean;

This item has no description.

Public NVX_gpu_memory_info: boolean;

This item has no description.

Public NV_vdpau_interop: boolean;

This item has no description.

Public NV_path_rendering: boolean;

This item has no description.

Public GREMEDY_frame_terminator: boolean;

This item has no description.

Public GREMEDY_string_marker: boolean;

This item has no description.

Public AMDX_debug_output: boolean;

This item has no description.

Public ARB_debug_output: boolean;

This item has no description.

Public BindTexture: procedure(target: Cardinal; texture: Cardinal); stdcall;

OpenGL 1.1 core functions and procedures

Public BlendFunc: procedure(sfactor: Cardinal; dfactor: Cardinal); stdcall;

This item has no description.

Public Clear: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public ClearColor: procedure(red, green, blue, alpha: Single); stdcall;

This item has no description.

Public ClearDepth: procedure(depth: TGLclampd); stdcall;

This item has no description.

Public ClearStencil: procedure(s: TGLint); stdcall;

This item has no description.

Public ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;

This item has no description.

Public CopyTexImage1D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;

This item has no description.

Public CopyTexImage2D: procedure(target: Cardinal; level: TGLint; internalFormat: Cardinal; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;

This item has no description.

Public CopyTexSubImage1D: procedure(target: Cardinal; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;

This item has no description.

Public CopyTexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public CullFace: procedure(mode: Cardinal); stdcall;

This item has no description.

Public DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

Public DepthFunc: procedure(func: Cardinal); stdcall;

This item has no description.

Public DepthMask: procedure(flag: TGLboolean); stdcall;

This item has no description.

Public DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;

This item has no description.

Public Disable: procedure(cap: Cardinal); stdcall;

This item has no description.

Public DrawArrays: procedure(mode: Cardinal; First: TGLint; Count: TGLsizei); stdcall;

This item has no description.

Public DrawBuffer: procedure(mode: Cardinal); stdcall;

This item has no description.

Public DrawElements: procedure(mode: Cardinal; Count: TGLsizei; atype: Cardinal; indices: Pointer); stdcall;

This item has no description.

Public Enable: procedure(cap: Cardinal); stdcall;

This item has no description.

Public Finish: procedure(); stdcall;

This item has no description.

Public Flush: procedure(); stdcall;

This item has no description.

Public FrontFace: procedure(mode: Cardinal); stdcall;

This item has no description.

Public GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;

This item has no description.

Public GetBooleanv: procedure(pname: Cardinal; params: PGLboolean); stdcall;

This item has no description.

Public GetDoublev: procedure(pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public GetError: function: Cardinal; stdcall;

This item has no description.

Public GetFloatv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetIntegerv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetPointerv: procedure(pname: Cardinal; var params); stdcall;

This item has no description.

Public GetString: function(Name: Cardinal): PAnsiChar; stdcall;

This item has no description.

Public GetTexImage: procedure(target: Cardinal; level: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public GetTexLevelParameterfv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexLevelParameteriv: procedure(target: Cardinal; level: TGLint; pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetTexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Hint: procedure(target, mode: Cardinal); stdcall;

This item has no description.

Public IsEnabled: function(cap: Cardinal): TGLboolean; stdcall;

This item has no description.

Public IsTexture: function(texture: Cardinal): TGLboolean; stdcall;

This item has no description.

Public LineWidth: procedure(Width: TGLfloat); stdcall;

This item has no description.

Public LogicOp: procedure(opcode: Cardinal); stdcall;

This item has no description.

Public PixelStoref: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public PixelStorei: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public PointSize: procedure(size: TGLfloat); stdcall;

This item has no description.

Public PolygonMode: procedure(face, mode: Cardinal); stdcall;

This item has no description.

Public PolygonOffset: procedure(factor, units: TGLfloat); stdcall;

This item has no description.

Public ReadBuffer: procedure(mode: Cardinal); stdcall;

This item has no description.

Public ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public StencilFunc: procedure(func: Cardinal; ref: TGLint; mask: Cardinal); stdcall;

This item has no description.

Public StencilMask: procedure(mask: Cardinal); stdcall;

This item has no description.

Public StencilOp: procedure(fail, zfail, zpass: Cardinal); stdcall;

This item has no description.

Public TexImage1D: procedure(target: Cardinal; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexImage2D: procedure(target: Cardinal; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexParameterf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexParameterfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexParameteri: procedure(target, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexParameteriv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public TexSubImage1D: procedure(target: Cardinal; level, xoffset: TGLint; Width: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public TexSubImage2D: procedure(target: Cardinal; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;

This item has no description.

Public Accum: procedure(op: Cardinal; Value: TGLfloat); stdcall;

—————————— OpenGL 1.1 deprecated

Public AlphaFunc: procedure(func: Cardinal; ref: Single); stdcall;

This item has no description.

Public AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;

This item has no description.

Public ArrayElement: procedure(i: TGLint); stdcall;

This item has no description.

Public Begin_: procedure(mode: Cardinal); stdcall;

This item has no description.

Public Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;

This item has no description.

Public CallList: procedure(list: Cardinal); stdcall;

This item has no description.

Public CallLists: procedure(n: TGLsizei; atype: Cardinal; lists: Pointer); stdcall;

This item has no description.

Public ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;

This item has no description.

Public ClearIndex: procedure(c: TGLfloat); stdcall;

This item has no description.

Public ClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;

This item has no description.

Public Color3b: procedure(red, green, blue: TGLbyte); stdcall;

This item has no description.

Public Color3bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Color3d: procedure(red, green, blue: TGLdouble); stdcall;

This item has no description.

Public Color3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Color3f: procedure(red, green, blue: TGLfloat); stdcall;

This item has no description.

Public Color3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Color3i: procedure(red, green, blue: TGLint); stdcall;

This item has no description.

Public Color3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Color3s: procedure(red, green, blue: TGLshort); stdcall;

This item has no description.

Public Color3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Color3ub: procedure(red, green, blue: TGLubyte); stdcall;

This item has no description.

Public Color3ubv: procedure(v: PGLubyte); stdcall;

This item has no description.

Public Color3ui: procedure(red, green, blue: Cardinal); stdcall;

This item has no description.

Public Color3uiv: procedure(v: PGLuint); stdcall;

This item has no description.

Public Color3us: procedure(red, green, blue: TGLushort); stdcall;

This item has no description.

Public Color3usv: procedure(v: PGLushort); stdcall;

This item has no description.

Public Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;

This item has no description.

Public Color4bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;

This item has no description.

Public Color4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;

This item has no description.

Public Color4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;

This item has no description.

Public Color4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;

This item has no description.

Public Color4sv: procedure(v: TGLshort); stdcall;

This item has no description.

Public Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;

This item has no description.

Public Color4ubv: procedure(v: PGLubyte); stdcall;

This item has no description.

Public Color4ui: procedure(red, green, blue, alpha: Cardinal); stdcall;

This item has no description.

Public Color4uiv: procedure(v: PGLuint); stdcall;

This item has no description.

Public Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;

This item has no description.

Public Color4usv: procedure(v: PGLushort); stdcall;

This item has no description.

Public ColorMaterial: procedure(face: Cardinal; mode: Cardinal); stdcall;

This item has no description.

Public ColorPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: Cardinal); stdcall;

This item has no description.

Public DeleteLists: procedure(list: Cardinal; range: TGLsizei); stdcall;

This item has no description.

Public DisableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public DrawPixels: procedure(Width, Height: TGLsizei; format, atype: Cardinal; pixels: Pointer); stdcall;

This item has no description.

Public EdgeFlag: procedure(flag: TGLboolean); stdcall;

This item has no description.

Public EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public EdgeFlagv: procedure(flag: PGLboolean); stdcall;

This item has no description.

Public EnableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

Public End_: procedure(); stdcall;

This item has no description.

Public EndList: procedure(); stdcall;

This item has no description.

Public EvalCoord1d: procedure(u: TGLdouble); stdcall;

This item has no description.

Public EvalCoord1dv: procedure(u: PGLdouble); stdcall;

This item has no description.

Public EvalCoord1f: procedure(u: TGLfloat); stdcall;

This item has no description.

Public EvalCoord1fv: procedure(u: PGLfloat); stdcall;

This item has no description.

Public EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;

This item has no description.

Public EvalCoord2dv: procedure(u: PGLdouble); stdcall;

This item has no description.

Public EvalCoord2f: procedure(u, v: TGLfloat); stdcall;

This item has no description.

Public EvalCoord2fv: procedure(u: PGLfloat); stdcall;

This item has no description.

Public EvalMesh1: procedure(mode: Cardinal; i1, i2: TGLint); stdcall;

This item has no description.

Public EvalMesh2: procedure(mode: Cardinal; i1, i2, j1, j2: TGLint); stdcall;

This item has no description.

Public EvalPoint1: procedure(i: TGLint); stdcall;

This item has no description.

Public EvalPoint2: procedure(i, j: TGLint); stdcall;

This item has no description.

Public FeedbackBuffer: procedure(size: TGLsizei; atype: Cardinal; buffer: PGLfloat); stdcall;

This item has no description.

Public Fogf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Fogfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Fogi: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Fogiv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;

This item has no description.

Public GenLists: function(range: TGLsizei): Cardinal; stdcall;

This item has no description.

Public GetClipPlane: procedure(plane: Cardinal; equation: PGLdouble); stdcall;

This item has no description.

Public GetLightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetLightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetMapdv: procedure(target, query: Cardinal; v: PGLdouble); stdcall;

This item has no description.

Public GetMapfv: procedure(target, query: Cardinal; v: PGLfloat); stdcall;

This item has no description.

Public GetMapiv: procedure(target, query: Cardinal; v: PGLint); stdcall;

This item has no description.

Public GetMaterialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetMaterialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetPixelMapfv: procedure(map: Cardinal; values: PGLfloat); stdcall;

This item has no description.

Public GetPixelMapuiv: procedure(map: Cardinal; values: PGLuint); stdcall;

This item has no description.

Public GetPixelMapusv: procedure(map: Cardinal; values: PGLushort); stdcall;

This item has no description.

Public GetPolygonStipple: procedure(mask: PGLubyte); stdcall;

This item has no description.

Public GetTexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public GetTexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public GetTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public GetTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public IndexMask: procedure(mask: Cardinal); stdcall;

This item has no description.

Public IndexPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public Indexd: procedure(c: TGLdouble); stdcall;

This item has no description.

Public Indexdv: procedure(c: PGLdouble); stdcall;

This item has no description.

Public Indexf: procedure(c: TGLfloat); stdcall;

This item has no description.

Public Indexfv: procedure(c: PGLfloat); stdcall;

This item has no description.

Public Indexi: procedure(c: TGLint); stdcall;

This item has no description.

Public Indexiv: procedure(c: PGLint); stdcall;

This item has no description.

Public Indexs: procedure(c: TGLshort); stdcall;

This item has no description.

Public Indexsv: procedure(c: PGLshort); stdcall;

This item has no description.

Public Indexub: procedure(c: TGLubyte); stdcall;

This item has no description.

Public Indexubv: procedure(c: PGLubyte); stdcall;

This item has no description.

Public InitNames: procedure(); stdcall;

This item has no description.

Public InterleavedArrays: procedure(format: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public IsList: function(list: Cardinal): TGLboolean; stdcall;

This item has no description.

Public LightModelf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public LightModelfv: procedure(pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public LightModeli: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public LightModeliv: procedure(pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Lightf: procedure(light, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Lightfv: procedure(light, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Lighti: procedure(light, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Lightiv: procedure(light, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;

This item has no description.

Public ListBase: procedure(base: Cardinal); stdcall;

This item has no description.

Public LoadIdentity: procedure(); stdcall;

This item has no description.

Public LoadMatrixd: procedure(m: PGLdouble); stdcall;

This item has no description.

Public LoadMatrixf: procedure(m: PGLfloat); stdcall;

This item has no description.

Public LoadName: procedure(Name: Cardinal); stdcall;

This item has no description.

Public Map1d: procedure(target: Cardinal; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;

This item has no description.

Public Map1f: procedure(target: Cardinal; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;

This item has no description.

Public Map2d: procedure(target: Cardinal; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;

This item has no description.

Public Map2f: procedure(target: Cardinal; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;

This item has no description.

Public MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;

This item has no description.

Public MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;

This item has no description.

Public MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;

This item has no description.

Public MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;

This item has no description.

Public Materialf: procedure(face, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public Materialfv: procedure(face, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public Materiali: procedure(face, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public Materialiv: procedure(face, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public MatrixMode: procedure(mode: Cardinal); stdcall;

This item has no description.

Public MultMatrixd: procedure(m: PGLdouble); stdcall;

This item has no description.

Public MultMatrixf: procedure(m: PGLfloat); stdcall;

This item has no description.

Public NewList: procedure(list: Cardinal; mode: Cardinal); stdcall;

This item has no description.

Public Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;

This item has no description.

Public Normal3bv: procedure(v: PGLbyte); stdcall;

This item has no description.

Public Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;

This item has no description.

Public Normal3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;

This item has no description.

Public Normal3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Normal3i: procedure(nx, ny, nz: TGLint); stdcall;

This item has no description.

Public Normal3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;

This item has no description.

Public Normal3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public NormalPointer: procedure(atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;

This item has no description.

Public PassThrough: procedure(token: TGLfloat); stdcall;

This item has no description.

Public PixelMapfv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLfloat); stdcall;

This item has no description.

Public PixelMapuiv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLuint); stdcall;

This item has no description.

Public PixelMapusv: procedure(map: Cardinal; mapsize: TGLsizei; values: PGLushort); stdcall;

This item has no description.

Public PixelTransferf: procedure(pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public PixelTransferi: procedure(pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;

This item has no description.

Public PolygonStipple: procedure(mask: PGLubyte); stdcall;

This item has no description.

Public PopAttrib: procedure(); stdcall;

This item has no description.

Public PopClientAttrib: procedure(); stdcall;

This item has no description.

Public PopMatrix: procedure(); stdcall;

This item has no description.

Public PopName: procedure(); stdcall;

This item has no description.

Public PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PSingle); stdcall;

This item has no description.

Public PushAttrib: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public PushClientAttrib: procedure(mask: TGLbitfield); stdcall;

This item has no description.

Public PushMatrix: procedure(); stdcall;

This item has no description.

Public PushName: procedure(Name: Cardinal); stdcall;

This item has no description.

Public RasterPos2d: procedure(X, y: TGLdouble); stdcall;

This item has no description.

Public RasterPos2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos2f: procedure(X, y: TGLfloat); stdcall;

This item has no description.

Public RasterPos2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos2i: procedure(X, y: TGLint); stdcall;

This item has no description.

Public RasterPos2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos2s: procedure(X, y: PGLshort); stdcall;

This item has no description.

Public RasterPos2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public RasterPos3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public RasterPos3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos3i: procedure(X, y, z: TGLint); stdcall;

This item has no description.

Public RasterPos3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos3s: procedure(X, y, z: TGLshort); stdcall;

This item has no description.

Public RasterPos3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;

This item has no description.

Public RasterPos4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;

This item has no description.

Public RasterPos4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;

This item has no description.

Public RasterPos4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;

This item has no description.

Public RasterPos4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;

This item has no description.

Public Rectdv: procedure(v1, v2: PGLdouble); stdcall;

This item has no description.

Public Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;

This item has no description.

Public Rectfv: procedure(v1, v2: PGLfloat); stdcall;

This item has no description.

Public Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;

This item has no description.

Public Rectiv: procedure(v1, v2: PGLint); stdcall;

This item has no description.

Public Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;

This item has no description.

Public Rectsv: procedure(v1, v2: PGLshort); stdcall;

This item has no description.

Public RenderMode: function(mode: Cardinal): TGLint; stdcall;

This item has no description.

Public Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;

This item has no description.

Public Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;

This item has no description.

Public Scaled: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Scalef: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;

This item has no description.

Public ShadeModel: procedure(mode: Cardinal); stdcall;

This item has no description.

Public TexCoord1d: procedure(s: TGLdouble); stdcall;

This item has no description.

Public TexCoord1dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord1f: procedure(s: TGLfloat); stdcall;

This item has no description.

Public TexCoord1fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord1i: procedure(s: TGLint); stdcall;

This item has no description.

Public TexCoord1iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord1s: procedure(s: TGLshort); stdcall;

This item has no description.

Public TexCoord1sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord2d: procedure(s, t: TGLdouble); stdcall;

This item has no description.

Public TexCoord2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord2f: procedure(s, t: TGLfloat); stdcall;

This item has no description.

Public TexCoord2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord2i: procedure(s, t: TGLint); stdcall;

This item has no description.

Public TexCoord2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord2s: procedure(s, t: TGLshort); stdcall;

This item has no description.

Public TexCoord2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;

This item has no description.

Public TexCoord3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;

This item has no description.

Public TexCoord3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord3i: procedure(s, t, r: TGLint); stdcall;

This item has no description.

Public TexCoord3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord3s: procedure(s, t, r: TGLshort); stdcall;

This item has no description.

Public TexCoord3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;

This item has no description.

Public TexCoord4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;

This item has no description.

Public TexCoord4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;

This item has no description.

Public TexCoord4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;

This item has no description.

Public TexCoord4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public TexCoordPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public TexEnvf: procedure(target, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexEnvfv: procedure(target, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexEnvi: procedure(target, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexEnviv: procedure(target, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public TexGend: procedure(coord, pname: Cardinal; param: TGLdouble); stdcall;

This item has no description.

Public TexGendv: procedure(coord, pname: Cardinal; params: PGLdouble); stdcall;

This item has no description.

Public TexGenf: procedure(coord, pname: Cardinal; param: TGLfloat); stdcall;

This item has no description.

Public TexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

Public TexGeni: procedure(coord, pname: Cardinal; param: TGLint); stdcall;

This item has no description.

Public TexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

Public Translated: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Translatef: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public Vertex2d: procedure(X, y: TGLdouble); stdcall;

This item has no description.

Public Vertex2dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex2f: procedure(X, y: TGLfloat); stdcall;

This item has no description.

Public Vertex2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex2i: procedure(X, y: TGLint); stdcall;

This item has no description.

Public Vertex2iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex2s: procedure(X, y: TGLshort); stdcall;

This item has no description.

Public Vertex2sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Vertex3d: procedure(X, y, z: TGLdouble); stdcall;

This item has no description.

Public Vertex3dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex3f: procedure(X, y, z: TGLfloat); stdcall;

This item has no description.

Public Vertex3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex3i: procedure(X, y, z: TGLint); stdcall;

This item has no description.

Public Vertex3iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex3s: procedure(X, y, z: TGLshort); stdcall;

This item has no description.

Public Vertex3sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;

This item has no description.

Public Vertex4dv: procedure(v: PGLdouble); stdcall;

This item has no description.

Public Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;

This item has no description.

Public Vertex4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

Public Vertex4i: procedure(X, y, z, w: TGLint); stdcall;

This item has no description.

Public Vertex4iv: procedure(v: PGLint); stdcall;

This item has no description.

Public Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;

This item has no description.

Public Vertex4sv: procedure(v: PGLshort); stdcall;

This item has no description.

Public VertexPointer: procedure(size: TGLint; atype: Cardinal; stride: TGLsizei; Data: Pointer); stdcall;

This item has no description.

Public BlendColor: PFNGLBLENDCOLORPROC;

***************************************************************** ——— New core function/procedure definitions in OpenGL 1.2'} *****************************************************************

Public BlendEquation: PFNGLBLENDEQUATIONPROC;

This item has no description.

Public DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;

This item has no description.

Public TexImage3D: PFNGLTEXIMAGE3DPROC;

This item has no description.

Public TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;

This item has no description.

Public CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;

This item has no description.

Public BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;

——– New core function/procedure definitions in OpenGL 1.4'}

Public MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;

This item has no description.

Public MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;

This item has no description.

Public PointParameterf: PFNGLPOINTPARAMETERFPROC;

This item has no description.

Public PointParameterfv: PFNGLPOINTPARAMETERFVPROC;

This item has no description.

Public PointParameteri: PFNGLPOINTPARAMETERIPROC;

This item has no description.

Public PointParameteriv: PFNGLPOINTPARAMETERIVPROC;

This item has no description.

Public BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;

————- New core function/procedure definitions in OpenGL 2.0'}

Public DrawBuffers: PFNGLDRAWBUFFERSPROC;

This item has no description.

Public StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;

This item has no description.

Public StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;

This item has no description.

Public StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;

This item has no description.

Public LockArrays: PFNGLLOCKARRAYSEXTPROC;

—————- Buffer objects

Public UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;

EXT only

Public BindBuffer: PFNGLBINDBUFFERPROC;

EXT only

Public DeleteBuffers: PFNGLDELETEBUFFERSPROC;

This item has no description.

Public GenBuffers: PFNGLGENBUFFERSPROC;

This item has no description.

Public IsBuffer: PFNGLISBUFFERPROC;

This item has no description.

Public BufferData: PFNGLBUFFERDATAPROC;

This item has no description.

Public BufferSubData: PFNGLBUFFERSUBDATAPROC;

This item has no description.

Public GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;

This item has no description.

Public MapBuffer: PFNGLMAPBUFFERPROC;

This item has no description.

Public UnmapBuffer: PFNGLUNMAPBUFFERPROC;

This item has no description.

Public GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;

This item has no description.

Public GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;

This item has no description.

Public MapBufferRange: PFNGLMAPBUFFERRANGEPROC;

This item has no description.

Public FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;

This item has no description.

Public BindBufferRange: PFNGLBINDBUFFERRANGEPROC;

This item has no description.

Public BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;

This item has no description.

Public BindBufferBase: PFNGLBINDBUFFERBASEPROC;

EXT + NV only

Public TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;

This item has no description.

Public TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;

NV only

Public TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;

NV only

Public GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;

This item has no description.

Public BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;

This item has no description.

Public EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;

This item has no description.

Public TexBuffer: PFNGLTEXBUFFERPROC;

This item has no description.

Public ClearBufferiv: PFNGLCLEARBUFFERIVPROC;

This item has no description.

Public ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;

This item has no description.

Public ClearBufferfv: PFNGLCLEARBUFFERFVPROC;

This item has no description.

Public ClearBufferfi: PFNGLCLEARBUFFERFIPROC;

This item has no description.

Public GetStringi: PFNGLGETSTRINGIPROC;

This item has no description.

Public BindVertexArray: PFNGLBINDVERTEXARRAYPROC;

This item has no description.

Public DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;

This item has no description.

Public GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;

This item has no description.

Public IsVertexArray: PFNGLISVERTEXARRAYPROC;

This item has no description.

Public FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;

This item has no description.

Public VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;

This item has no description.

Public GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;

This item has no description.

Public GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;

This item has no description.

Public GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;

This item has no description.

Public GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;

This item has no description.

Public GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;

This item has no description.

Public GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;

This item has no description.

Public UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;

This item has no description.

Public CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;

This item has no description.

Public UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;

This item has no description.

Public GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;

This item has no description.

Public GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;

EXT only

Public PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;

EXT only

Public DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;

This item has no description.

Public MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;

This item has no description.

Public DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;

This item has no description.

Public DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;

This item has no description.

Public VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;

This item has no description.

Public VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;

This item has no description.

Public VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;

This item has no description.

Public VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;

This item has no description.

Public VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;

This item has no description.

Public VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;

This item has no description.

Public VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;

This item has no description.

Public VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;

This item has no description.

Public VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;

This item has no description.

Public VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;

This item has no description.

Public VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;

This item has no description.

Public VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;

This item has no description.

Public VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;

This item has no description.

Public VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;

This item has no description.

Public VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;

This item has no description.

Public VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;

This item has no description.

Public VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;

This item has no description.

Public VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;

This item has no description.

Public VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;

This item has no description.

Public VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;

This item has no description.

Public VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;

This item has no description.

Public VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;

This item has no description.

Public VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;

This item has no description.

Public VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;

This item has no description.

Public VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;

This item has no description.

Public VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;

This item has no description.

Public VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;

This item has no description.

Public VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;

This item has no description.

Public VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;

This item has no description.

Public VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;

This item has no description.

Public VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;

This item has no description.

Public VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;

This item has no description.

Public VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;

This item has no description.

Public VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;

This item has no description.

Public VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;

This item has no description.

Public VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;

This item has no description.

Public VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;

This item has no description.

Public VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;

This item has no description.

Public VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;

This item has no description.

Public VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;

This item has no description.

Public VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;

This item has no description.

Public VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;

This item has no description.

Public VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;

This item has no description.

Public VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;

This item has no description.

Public VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;

This item has no description.

Public VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;

This item has no description.

Public VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;

This item has no description.

Public VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;

This item has no description.

Public VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;

This item has no description.

Public VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;

This item has no description.

Public VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;

This item has no description.

Public VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;

This item has no description.

Public VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;

This item has no description.

Public VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;

This item has no description.

Public VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;

This item has no description.

Public VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;

This item has no description.

Public VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;

This item has no description.

Public VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;

This item has no description.

Public GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;

This item has no description.

Public GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;

This item has no description.

Public Uniform1ui: PFNGLUNIFORM1UIPROC;

This item has no description.

Public Uniform2ui: PFNGLUNIFORM2UIPROC;

This item has no description.

Public Uniform3ui: PFNGLUNIFORM3UIPROC;

This item has no description.

Public Uniform4ui: PFNGLUNIFORM4UIPROC;

This item has no description.

Public Uniform1uiv: PFNGLUNIFORM1UIVPROC;

This item has no description.

Public Uniform2uiv: PFNGLUNIFORM2UIVPROC;

This item has no description.

Public Uniform3uiv: PFNGLUNIFORM3UIVPROC;

This item has no description.

Public Uniform4uiv: PFNGLUNIFORM4UIVPROC;

This item has no description.

Public GetUniformuiv: PFNGLGETUNIFORMUIVPROC;

This item has no description.

Public BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;

This item has no description.

Public GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;

This item has no description.

Public ClampColor: PFNGLCLAMPCOLORPROC;

This item has no description.

Public ColorMaski: PFNGLCOLORMASKIPROC;

This item has no description.

Public GetBooleani_v: PFNGLGETBOOLEANI_VPROC;

This item has no description.

Public GetIntegeri_v: PFNGLGETINTEGERI_VPROC;

This item has no description.

Public Enablei: PFNGLENABLEIPROC;

This item has no description.

Public Disablei: PFNGLDISABLEIPROC;

This item has no description.

Public IsEnabledi: PFNGLISENABLEDIPROC;

This item has no description.

Public EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;

This item has no description.

Public DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;

This item has no description.

Public VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;

This item has no description.

Public ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;

This item has no description.

Public ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;

EXT only

Public TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;

EXT only

Public TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;

This item has no description.

Public GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;

This item has no description.

Public GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;

This item has no description.

Public PatchParameteri: PFNGLPATCHPARAMETERIPROC;

This item has no description.

Public PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;

This item has no description.

Public BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;

This item has no description.

Public VertexFormatNV: PFNGLVERTEXFORMATNVPROC;

This item has no description.

Public NormalFormatNV: PFNGLNORMALFORMATNVPROC;

This item has no description.

Public ColorFormatNV: PFNGLCOLORFORMATNVPROC;

This item has no description.

Public IndexFormatNV: PFNGLINDEXFORMATNVPROC;

This item has no description.

Public TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;

This item has no description.

Public EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;

This item has no description.

Public SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;

This item has no description.

Public FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;

This item has no description.

Public VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;

This item has no description.

Public VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;

This item has no description.

Public GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;

This item has no description.

Public GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;

This item has no description.

Public MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;

This item has no description.

Public IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;

This item has no description.

Public MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;

This item has no description.

Public IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;

This item has no description.

Public GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;

This item has no description.

Public GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;

This item has no description.

Public Uniformui64NV: PFNGLUNIFORMUI64NVPROC;

This item has no description.

Public Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;

This item has no description.

Public GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;

This item has no description.

Public ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;

This item has no description.

Public ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;

This item has no description.

Public ClearBufferData: PFNGLClearBufferData;

This item has no description.

Public ClearBufferSubData: PFNGLClearBufferSubData;

This item has no description.

Public ClearNamedBufferData: PFNGLClearNamedBufferData;

This item has no description.

Public ClearNamedBufferSubData: PFNGLClearNamedBufferSubData;

This item has no description.

Public InvalidateTexSubImage: PFNGLInvalidateTexSubImage;

This item has no description.

Public InvalidateTexImage: PFNGLInvalidateTexImage;

This item has no description.

Public InvalidateBufferSubData: PFNGLInvalidateBufferSubData;

This item has no description.

Public InvalidateBufferData: PFNGLInvalidateBufferData;

This item has no description.

Public InvalidateFramebuffer: PFNGLInvalidateFramebuffer;

This item has no description.

Public InvalidateSubFramebuffer: PFNGLInvalidateSubFramebuffer;

This item has no description.

Public MultiDrawArraysIndirect: PFNGLMultiDrawArraysIndirect;

This item has no description.

Public MultiDrawElementsIndirect: PFNGLMultiDrawElementsIndirect;

This item has no description.

Public BindVertexBuffer: PFNGLBindVertexBuffer;

This item has no description.

Public VertexAttribFormat: PFNGLVertexAttribFormat;

This item has no description.

Public VertexAttribIFormat: PFNGLVertexAttribIFormat;

This item has no description.

Public VertexAttribLFormat: PFNGLVertexAttribLFormat;

This item has no description.

Public VertexAttribBinding: PFNGLVertexAttribBinding;

This item has no description.

Public VertexBindingDivisor: PFNGLVertexBindingDivisor;

This item has no description.

Public VertexArrayBindVertexBuffer: PFNGLVertexArrayBindVertexBuffer;

This item has no description.

Public VertexArrayVertexAttribFormat: PFNGLVertexArrayVertexAttribFormat;

This item has no description.

Public VertexArrayVertexAttribIFormat: PFNGLVertexArrayVertexAttribIFormat;

This item has no description.

Public VertexArrayVertexAttribLFormat: PFNGLVertexArrayVertexAttribLFormat;

This item has no description.

Public VertexArrayVertexAttribBinding: PFNGLVertexArrayVertexAttribBinding;

This item has no description.

Public VertexArrayVertexBindingDivisor: PFNGLVertexArrayVertexBindingDivisor;

This item has no description.

Public DeleteObject: PFNGLDELETEOBJECTARBPROC;

—————————— Shader object

Public GetHandle: PFNGLGETHANDLEARBPROC;

ARB only

Public DetachShader: PFNGLDETACHSHADERPROC;

ARB only

Public CreateShader: PFNGLCREATESHADERPROC;

This item has no description.

Public DeleteShader: PFNGLDELETESHADERPROC;

This item has no description.

Public ShaderSource: PFNGLSHADERSOURCEPROC;

This item has no description.

Public CompileShader: PFNGLCOMPILESHADERPROC;

This item has no description.

Public CreateProgram: PFNGLCREATEPROGRAMPROC;

This item has no description.

Public DeleteProgram: PFNGLDELETEPROGRAMPROC;

This item has no description.

Public AttachShader: PFNGLATTACHSHADERPROC;

This item has no description.

Public LinkProgram: PFNGLLINKPROGRAMPROC;

This item has no description.

Public UseProgram: PFNGLUSEPROGRAMPROC;

This item has no description.

Public ValidateProgram: PFNGLVALIDATEPROGRAMPROC;

This item has no description.

Public Uniform1f: PFNGLUNIFORM1FPROC;

This item has no description.

Public Uniform2f: PFNGLUNIFORM2FPROC;

This item has no description.

Public Uniform3f: PFNGLUNIFORM3FPROC;

This item has no description.

Public Uniform4f: PFNGLUNIFORM4FPROC;

This item has no description.

Public Uniform1i: PFNGLUNIFORM1IPROC;

This item has no description.

Public Uniform2i: PFNGLUNIFORM2IPROC;

This item has no description.

Public Uniform3i: PFNGLUNIFORM3IPROC;

This item has no description.

Public Uniform4i: PFNGLUNIFORM4IPROC;

This item has no description.

Public Uniform1fv: PFNGLUNIFORM1FVPROC;

This item has no description.

Public Uniform2fv: PFNGLUNIFORM2FVPROC;

This item has no description.

Public Uniform3fv: PFNGLUNIFORM3FVPROC;

This item has no description.

Public Uniform4fv: PFNGLUNIFORM4FVPROC;

This item has no description.

Public Uniform1iv: PFNGLUNIFORM1IVPROC;

This item has no description.

Public Uniform2iv: PFNGLUNIFORM2IVPROC;

This item has no description.

Public Uniform3iv: PFNGLUNIFORM3IVPROC;

This item has no description.

Public Uniform4iv: PFNGLUNIFORM4IVPROC;

This item has no description.

Public UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;

This item has no description.

Public UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;

This item has no description.

Public UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;

This item has no description.

Public GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;

This item has no description.

Public GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;

ARB only

Public GetInfoLog: PFNGLGETINFOLOGARBPROC;

ARB only

Public GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;

ARB only

Public GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;

ARB only

Public GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;

This item has no description.

Public GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;

This item has no description.

Public GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;

This item has no description.

Public GetProgramiv: PFNGLGETPROGRAMIVPROC;

This item has no description.

Public GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;

This item has no description.

Public GetShaderiv: PFNGLGETSHADERIVPROC;

This item has no description.

Public GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;

This item has no description.

Public GetShaderSource: PFNGLGETSHADERSOURCEPROC;

This item has no description.

Public GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;

This item has no description.

Public GetUniformfv: PFNGLGETUNIFORMFVPROC;

This item has no description.

Public GetUniformiv: PFNGLGETUNIFORMIVPROC;

This item has no description.

Public GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;

This item has no description.

Public GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;

This item has no description.

Public GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;

This item has no description.

Public GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;

This item has no description.

Public IsProgram: PFNGLISPROGRAMPROC;

This item has no description.

Public IsShader: PFNGLISSHADERPROC;

This item has no description.

Public BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;

This item has no description.

Public BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;

This item has no description.

Public GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;

This item has no description.

Public GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;

This item has no description.

Public GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;

NV only

Public ActiveVarying: PFNGLACTIVEVARYINGNVPROC;

NV only

Public GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;

NV only

Public ProgramBinary: PFNGLPROGRAMBINARYPROC;

This item has no description.

Public UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;

This item has no description.

Public ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;

This item has no description.

Public CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;

This item has no description.

Public BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;

This item has no description.

Public DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;

This item has no description.

Public GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;

This item has no description.

Public IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;

This item has no description.

Public GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;

This item has no description.

Public ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;

This item has no description.

Public ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;

This item has no description.

Public ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;

This item has no description.

Public ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;

This item has no description.

Public ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;

This item has no description.

Public ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;

This item has no description.

Public ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;

This item has no description.

Public ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;

This item has no description.

Public ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;

This item has no description.

Public ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;

This item has no description.

Public ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;

This item has no description.

Public ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;

This item has no description.

Public ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;

This item has no description.

Public ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;

This item has no description.

Public ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;

This item has no description.

Public ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;

This item has no description.

Public ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;

This item has no description.

Public ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;

This item has no description.

Public ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;

This item has no description.

Public ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;

This item has no description.

Public ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;

This item has no description.

Public ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;

This item has no description.

Public ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;

This item has no description.

Public ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;

This item has no description.

Public ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;

This item has no description.

Public ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;

This item has no description.

Public ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;

This item has no description.

Public ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;

This item has no description.

Public ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;

This item has no description.

Public ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;

This item has no description.

Public ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;

This item has no description.

Public ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;

This item has no description.

Public ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;

This item has no description.

Public ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;

This item has no description.

Public ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;

This item has no description.

Public ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;

This item has no description.

Public ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;

This item has no description.

Public ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;

This item has no description.

Public ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;

This item has no description.

Public ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;

This item has no description.

Public ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;

This item has no description.

Public ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;

This item has no description.

Public ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;

This item has no description.

Public ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;

This item has no description.

Public ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;

This item has no description.

Public ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;

This item has no description.

Public ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;

This item has no description.

Public ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;

This item has no description.

Public ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;

This item has no description.

Public ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;

This item has no description.

Public ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;

This item has no description.

Public GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;

This item has no description.

Public DispatchCompute: PFNGLDispatchCompute;

This item has no description.

Public DispatchComputeIndirect: PFNGLDispatchComputeIndirect;

This item has no description.

Public ShaderStorageBlockBinding: PFNGLShaderStorageBlockBinding;

This item has no description.

Public IsRenderbuffer: PFNGLISRENDERBUFFERPROC;

————- Framebuffer object

Public BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;

This item has no description.

Public DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;

This item has no description.

Public GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;

This item has no description.

Public RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;

This item has no description.

Public RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;

This item has no description.

Public GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;

This item has no description.

Public IsFramebuffer: PFNGLISFRAMEBUFFERPROC;

This item has no description.

Public BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;

This item has no description.

Public DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;

This item has no description.

Public GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;

This item has no description.

Public CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;

This item has no description.

Public FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;

This item has no description.

Public FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;

This item has no description.

Public FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;

This item has no description.

Public FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;

This item has no description.

Public FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;

This item has no description.

Public FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;

This item has no description.

Public FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;

ARB only

Public GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;

This item has no description.

Public BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;

This item has no description.

Public GenerateMipmap: PFNGLGENERATEMIPMAPPROC;

This item has no description.

Public FramebufferParameteri: PFNGLFramebufferParameteri;

This item has no description.

Public NamedFramebufferParameteri: PFNGLNamedFramebufferParameteri;

This item has no description.

Public GetNamedFramebufferParameteriv: PFNGLGetNamedFramebufferParameteriv;

This item has no description.

Public GenQueries: PFNGLGENQUERIESPROC;

—————————— Queries object

Public DeleteQueries: PFNGLDELETEQUERIESPROC;

This item has no description.

Public IsQuery: PFNGLISQUERYPROC;

This item has no description.

Public BeginQuery: PFNGLBEGINQUERYPROC;

This item has no description.

Public EndQuery: PFNGLENDQUERYPROC;

This item has no description.

Public GetQueryiv: PFNGLGETQUERYIVPROC;

This item has no description.

Public GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;

This item has no description.

Public GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;

This item has no description.

Public QueryCounter: PFNGLQUERYCOUNTERPROC;

This item has no description.

Public GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;

This item has no description.

Public GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;

This item has no description.

Public GetInternalformati64v: PFNGLGetInternalformati64v;

This item has no description.

Public GetProgramInterfaceiv: PFNGLGetProgramInterfaceiv;

This item has no description.

Public GetProgramResourceIndex: PFNGLGetProgramResourceIndex;

This item has no description.

Public GetProgramResourceName: PFNGLGetProgramResourceName;

This item has no description.

Public GetProgramResourceiv: PFNGLGetProgramResourceiv;

This item has no description.

Public GetProgramResourceLocation: PFNGLGetProgramResourceLocation;

This item has no description.

Public GetProgramResourceLocationIndex: PFNGLGetProgramResourceLocationIndex;

This item has no description.

Public ActiveTexture: PFNGLACTIVETEXTUREPROC;

—————————— Texture & Sampler object promoted to core v1.3 from GL_ARB_multitexture (#1)

Public SampleCoverage: PFNGLSAMPLECOVERAGEPROC;

This item has no description.

Public CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;

promoted to core v1.3 from GL_ARB_texture_compression (#12)

Public CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;

This item has no description.

Public CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;

This item has no description.

Public CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;

This item has no description.

Public CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;

This item has no description.

Public CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;

This item has no description.

Public GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;

This item has no description.

Public ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;

This item has no description.

Public MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;

This item has no description.

Public MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;

This item has no description.

Public MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;

This item has no description.

Public MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;

This item has no description.

Public MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;

This item has no description.

Public MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;

This item has no description.

Public MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;

This item has no description.

Public MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;

This item has no description.

Public MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;

This item has no description.

Public MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;

This item has no description.

Public MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;

This item has no description.

Public MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;

This item has no description.

Public MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;

This item has no description.

Public MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;

This item has no description.

Public MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;

This item has no description.

Public MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;

This item has no description.

Public MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;

This item has no description.

Public MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;

This item has no description.

Public MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;

This item has no description.

Public MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;

This item has no description.

Public MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;

This item has no description.

Public MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;

This item has no description.

Public MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;

This item has no description.

Public MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;

This item has no description.

Public MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;

This item has no description.

Public MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;

This item has no description.

Public MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;

This item has no description.

Public MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;

This item has no description.

Public MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;

This item has no description.

Public MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;

This item has no description.

Public MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;

This item has no description.

Public MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;

This item has no description.

Public GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;

This item has no description.

Public GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;

This item has no description.

Public ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;

This item has no description.

Public ProgramString: PFNGLPROGRAMSTRINGARBPROC;

This item has no description.

Public BindProgram: PFNGLBINDPROGRAMARBPROC;

ARB only

Public DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;

ARB + NV only

Public GenPrograms: PFNGLGENPROGRAMSARBPROC;

ARB + NV only

Public ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;

ARB + NV only

Public ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;

ARB only

Public ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;

ARB only

Public ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;

ARB only

Public ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;

ARB only

Public ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;

ARB only

Public ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;

ARB only

Public ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;

ARB only

Public GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;

ARB only

Public GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;

ARB only

Public GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;

ARB only

Public GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;

ARB only

Public TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;

ARB only

Public TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;

This item has no description.

Public GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;

This item has no description.

Public SampleMaski: PFNGLSAMPLEMASKIPROC;

This item has no description.

Public ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;

This item has no description.

Public FenceSync: PFNGLFENCESYNCPROC;

This item has no description.

Public IsSync: PFNGLISSYNCPROC;

This item has no description.

Public DeleteSync: PFNGLDELETESYNCPROC;

This item has no description.

Public ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;

This item has no description.

Public WaitSync: PFNGLWAITSYNCPROC;

This item has no description.

Public GetInteger64v: PFNGLGETINTEGER64VPROC;

This item has no description.

Public GetSynciv: PFNGLGETSYNCIVPROC;

This item has no description.

Public BlendEquationi: PFNGLBLENDEQUATIONIPROC;

This item has no description.

Public BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;

This item has no description.

Public BlendFunci: PFNGLBLENDFUNCIPROC;

This item has no description.

Public BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;

This item has no description.

Public MinSampleShading: PFNGLMINSAMPLESHADINGPROC;

This item has no description.

Public GenSamplers: PFNGLGENSAMPLERSPROC;

This item has no description.

Public DeleteSamplers: PFNGLDELETESAMPLERSPROC;

This item has no description.

Public IsSampler: PFNGLISSAMPLERPROC;

This item has no description.

Public BindSampler: PFNGLBINDSAMPLERPROC;

This item has no description.

Public SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;

This item has no description.

Public SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;

This item has no description.

Public SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;

This item has no description.

Public SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;

This item has no description.

Public SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;

This item has no description.

Public SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;

This item has no description.

Public GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;

This item has no description.

Public GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;

This item has no description.

Public GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;

This item has no description.

Public GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;

This item has no description.

Public CopyImageSubData: PFNGLCopyImageSubData;

This item has no description.

Public TexBufferRange: PFNGLTexBufferRange;

This item has no description.

Public TextureBufferRange: PFNGLTextureBufferRange;

This item has no description.

Public TexStorage2DMultisample: PFNGLTexStorage2DMultisample;

This item has no description.

Public TexStorage3DMultisample: PFNGLTexStorage3DMultisample;

This item has no description.

Public TextureStorage2DMultisample: PFNGLTextureStorage2DMultisample;

This item has no description.

Public TextureStorage3DMultisample: PFNGLTextureStorage3DMultisample;

This item has no description.

Public BufferStorage: PFNGLBufferStorage;

This item has no description.

Public ClearTexImage: PFNGLClearTexImage;

This item has no description.

Public ClearTexSubImage: PFNGLClearTexSubImage;

This item has no description.

Public BindBuffersBase: PFNGLBindBuffersBase;

This item has no description.

Public BindBuffersRange: PFNGLBindBuffersRange;

This item has no description.

Public BindTextures: PFNGLBindTextures;

This item has no description.

Public BindSamplers: PFNGLBindSamplers;

This item has no description.

Public BindImageTextures: PFNGLBindImageTextures;

This item has no description.

Public BindVertexBuffers: PFNGLBindVertexBuffers;

This item has no description.

Public TextureView: PFNGLTextureView;

This item has no description.

Public ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;

—————————— Direct access

Public PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;

This item has no description.

Public MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;

This item has no description.

Public MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;

This item has no description.

Public MatrixMultf: PFNGLMATRIXMULTFEXTPROC;

This item has no description.

Public MatrixMultd: PFNGLMATRIXMULTDEXTPROC;

This item has no description.

Public MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;

This item has no description.

Public MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;

This item has no description.

Public MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;

This item has no description.

Public MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;

This item has no description.

Public MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;

This item has no description.

Public MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;

This item has no description.

Public MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;

This item has no description.

Public MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;

This item has no description.

Public MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;

This item has no description.

Public MatrixPop: PFNGLMATRIXPOPEXTPROC;

This item has no description.

Public MatrixPush: PFNGLMATRIXPUSHEXTPROC;

This item has no description.

Public MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;

This item has no description.

Public MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;

This item has no description.

Public MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;

This item has no description.

Public MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;

This item has no description.

Public TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;

This item has no description.

Public TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;

This item has no description.

Public TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;

This item has no description.

Public TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;

This item has no description.

Public GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;

This item has no description.

Public GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;

This item has no description.

Public GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;

This item has no description.

Public GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;

This item has no description.

Public TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;

This item has no description.

Public TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;

This item has no description.

Public MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;

This item has no description.

Public MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;

This item has no description.

Public MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;

This item has no description.

Public MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;

This item has no description.

Public GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;

This item has no description.

Public GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;

This item has no description.

Public GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;

This item has no description.

Public GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;

This item has no description.

Public MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;

This item has no description.

Public MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;

This item has no description.

Public EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;

This item has no description.

Public DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;

This item has no description.

Public MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;

This item has no description.

Public MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;

This item has no description.

Public MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;

This item has no description.

Public MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;

This item has no description.

Public MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;

This item has no description.

Public MultiTexGend: PFNGLMULTITEXGENDEXTPROC;

This item has no description.

Public MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;

This item has no description.

Public MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;

This item has no description.

Public MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;

This item has no description.

Public MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;

This item has no description.

Public MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;

This item has no description.

Public GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;

This item has no description.

Public GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;

This item has no description.

Public GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;

This item has no description.

Public GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;

This item has no description.

Public GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;

This item has no description.

Public GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;

This item has no description.

Public GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;

This item has no description.

Public GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;

This item has no description.

Public CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;

This item has no description.

Public CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;

This item has no description.

Public CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;

This item has no description.

Public CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;

This item has no description.

Public CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;

This item has no description.

Public CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;

This item has no description.

Public GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;

This item has no description.

Public CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;

This item has no description.

Public CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;

This item has no description.

Public CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;

This item has no description.

Public CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;

This item has no description.

Public GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;

This item has no description.

Public NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;

This item has no description.

Public NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;

This item has no description.

Public GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;

This item has no description.

Public GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;

This item has no description.

Public NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;

This item has no description.

Public NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;

This item has no description.

Public NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;

This item has no description.

Public NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;

This item has no description.

Public GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;

This item has no description.

Public TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;

This item has no description.

Public TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;

This item has no description.

Public GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;

This item has no description.

Public GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;

This item has no description.

Public MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;

This item has no description.

Public MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;

This item has no description.

Public GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;

This item has no description.

Public GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;

This item has no description.

Public NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;

This item has no description.

Public NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;

This item has no description.

Public MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;

This item has no description.

Public UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;

This item has no description.

Public MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;

This item has no description.

Public FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;

This item has no description.

Public NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;

This item has no description.

Public GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;

This item has no description.

Public GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;

This item has no description.

Public TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;

This item has no description.

Public MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;

This item has no description.

Public NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;

This item has no description.

Public GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;

This item has no description.

Public NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;

This item has no description.

Public NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;

This item has no description.

Public NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;

This item has no description.

Public NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;

This item has no description.

Public GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;

This item has no description.

Public GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;

This item has no description.

Public GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;

This item has no description.

Public FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;

This item has no description.

Public FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;

This item has no description.

Public FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;

This item has no description.

Public GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;

This item has no description.

Public NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;

This item has no description.

Public NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;

This item has no description.

Public NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;

This item has no description.

Public NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;

This item has no description.

Public NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;

This item has no description.

Public TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;

This item has no description.

Public MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;

This item has no description.

Public FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;

—————————— Debugging Special Gremedy debugger extension

Public StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;

This item has no description.

Public DebugMessageEnableAMDX: procedure(category: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean);

This item has no description.

Public PushDebugGroup: PFNGLPushDebugGroup;

This item has no description.

Public PopDebugGroup: PFNGLPopDebugGroup;

This item has no description.

Public ObjectLabel: PFNGLObjectLabel;

This item has no description.

Public GetObjectLabel: PFNGLGetObjectLabel;

This item has no description.

Public ObjectPtrLabel: PFNGLObjectPtrLabel;

This item has no description.

Public GetObjectPtrLabel: PFNGLGetObjectPtrLabel;

This item has no description.

Public DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;

This item has no description.

Public DebugMessageControl: procedure(type_: Cardinal; Source: Cardinal; severity: Cardinal; Count: TGLsizei; var ids: Cardinal; Enabled: boolean); stdcall;

This item has no description.

Public DebugMessageInsert: procedure(Source: Cardinal; severity: Cardinal; id: Cardinal; length: TGLsizei; const buf: PAnsiChar); stdcall;

This item has no description.

Public DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;

This item has no description.

Public GetDebugMessageLog: function(Count: Cardinal; bufSize: TGLsizei; var severity: Cardinal; var severities: Cardinal; var ids: Cardinal; var lengths: TGLsizei; messageLog: PAnsiChar): Cardinal; stdcall;

This item has no description.

Public CreateSyncFromCLevent: PFNGLCreateSyncFromCLevent;

—————————— Interrop

Public VDPAUInitNV: procedure(const vdpDevice: Pointer; const getProcAddress: Pointer); stdcall;

This item has no description.

Public VDPAUFiniNV: procedure(); stdcall;

This item has no description.

Public VDPAURegisterVideoSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;

This item has no description.

Public VDPAURegisterOutputSurfaceNV: function(const vdpSurface: Pointer; target: Cardinal; numTextureNames: TGLsizei; const textureNames: PGLuint) : TGLvdpauSurfaceNV; stdcall;

This item has no description.

Public VDPAUIsSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUUnregisterSurfaceNV: procedure(surface: TGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUGetSurfaceivNV: procedure(surface: TGLvdpauSurfaceNV; pname: Cardinal; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

This item has no description.

Public VDPAUSurfaceAccessNV: procedure(surface: TGLvdpauSurfaceNV; access: Cardinal); stdcall;

This item has no description.

Public VDPAUMapSurfacesNV: procedure(numSurfaces: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;

This item has no description.

Public VDPAUUnmapSurfacesNV: procedure(numSurface: TGLsizei; const surfaces: PGLvdpauSurfaceNV); stdcall;

This item has no description.

Public GenPathsNV: PFNGLGENPATHSNVPROC;

—————————— Path rendering

Public DeletePathsNV: PFNGLDELETEPATHSNVPROC;

This item has no description.

Public IsPathNV: PFNGLISPATHNVPROC;

This item has no description.

Public PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;

This item has no description.

Public PathCoordsNV: PFNGLPATHCOORDSNVPROC;

This item has no description.

Public PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;

This item has no description.

Public PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;

This item has no description.

Public PathStringNV: PFNGLPATHSTRINGNVPROC;

This item has no description.

Public PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;

This item has no description.

Public PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;

This item has no description.

Public WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;

This item has no description.

Public CopyPathNV: PFNGLCOPYPATHNVPROC;

This item has no description.

Public InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;

This item has no description.

Public PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;

This item has no description.

Public PathParameteriNV: PFNGLPATHPARAMETERINVPROC;

This item has no description.

Public PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;

This item has no description.

Public PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;

This item has no description.

Public PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;

This item has no description.

Public PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;

This item has no description.

Public StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;

This item has no description.

Public StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;

This item has no description.

Public StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;

This item has no description.

Public StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;

This item has no description.

Public PathColorGenNV: PFNGLPATHCOLORGENNVPROC;

This item has no description.

Public PathTexGenNV: PFNGLPATHTEXGENNVPROC;

This item has no description.

Public PathFogGenNV: PFNGLPATHFOGGENNVPROC;

This item has no description.

Public CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;

This item has no description.

Public CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;

This item has no description.

Public CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;

This item has no description.

Public CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;

This item has no description.

Public GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;

This item has no description.

Public GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;

This item has no description.

Public GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;

This item has no description.

Public GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;

This item has no description.

Public GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;

This item has no description.

Public GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;

This item has no description.

Public GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;

This item has no description.

Public GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;

This item has no description.

Public GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;

This item has no description.

Public GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;

This item has no description.

Public GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;

This item has no description.

Public GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;

This item has no description.

Public IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;

This item has no description.

Public IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;

This item has no description.

Public GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;

This item has no description.

Public PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;

This item has no description.

Public PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;

This item has no description.

Public PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;

This item has no description.

Public W_ARB_buffer_region: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_create_context: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_create_context_profile: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_extensions_string: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_framebuffer_sRGB: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_make_current_read: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_multisample: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pbuffer: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pixel_format: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_pixel_format_float: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ARB_render_texture: boolean;

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### ARB approved WGL extension checks

Public W_ATI_pixel_format_float: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_framebuffer_sRGB: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_pixel_format_packed_float: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_swap_control: boolean;

Vendor/EXT WGL extension checks

Public W_NV_gpu_affinity: boolean;

Vendor/EXT WGL extension checks

Public W_EXT_create_context_es2_profile: boolean;

Vendor/EXT WGL extension checks

Public W_NV_DX_interop: boolean;

Vendor/EXT WGL extension checks

Public W_NV_DX_interop2: boolean;

Vendor/EXT WGL extension checks

Public WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;

WGL_buffer_region (ARB #4)

Public WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;

This item has no description.

Public WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;

This item has no description.

Public WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;

This item has no description.

Public WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;

WGL_ARB_extensions_string (ARB #8)

Public WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;

WGL_ARB_pixel_format (ARB #9)

Public WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;

This item has no description.

Public WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;

This item has no description.

Public WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;

WGL_make_current_read (ARB #10)

Public WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;

This item has no description.

Public WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;

WGL_ARB_pbuffer (ARB #11)

Public WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;

This item has no description.

Public WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;

This item has no description.

Public WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;

This item has no description.

Public WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;

This item has no description.

Public WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;

WGL_ARB_render_texture (ARB #20)

Public WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;

This item has no description.

Public WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;

This item has no description.

Public WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;

WGL_ARB_create_context (ARB #55)

Public WEnumGpusNV: PFNWGLENUMGPUSNVPROC;

WGL_NV_gpu_affinity

Public WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;

This item has no description.

Public WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;

This item has no description.

Public WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;

This item has no description.

Public WDeleteDCNV: PFNWGLDELETEDCNVPROC;

This item has no description.

Public WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;

WGL_NV_DX_interop (EXT #407)

Public WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;

This item has no description.

Public WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;

This item has no description.

Public WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;

This item has no description.

Public WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;

This item has no description.

Public WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;

This item has no description.

Public WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;

This item has no description.

Public WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;

This item has no description.

Public WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

Public WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;

This item has no description.

Public WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;

GL_NV_vertex_array_range (EXT #190)

Public WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;

This item has no description.

Public UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

—————————— EGL function/procedure —————————— locate functions/procedures for OpenGL Utility (GLU) extensions'} {$ENDIF} ########################################################### locate functions and procedures for GLU extensions ###########################################################

Public UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;

This item has no description.

Public UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Private function CheckExtension(const Extension: string): boolean;

This item has no description.

Private function GetAddress(const ProcName: string): Pointer;

This item has no description.

Private function GetAddressAlt(const ProcName1, ProcName2: string): Pointer;

This item has no description.

Private function GetAddressNoSuffixes(const ProcName: string): Pointer;

This item has no description.

Private function GetCapAddress: Pointer;

This item has no description.

Public procedure CheckError;

This item has no description.

Public procedure ClearError;

This item has no description.

Public procedure Close;

This item has no description.

Public procedure Initialize(ATemporary: boolean = False);

This item has no description.

Private procedure ReadWGLExtensions;

This item has no description.

Private procedure ReadWGLImplementationProperties;

This item has no description.

Properties

Public property DebugMode: boolean read FDebug write FDebug;

This item has no description.

Public property IsInitialized: boolean read FInitialized;


GXSysHelp v.2.5: GXS.OutlineShader

Unit GXS.OutlineShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GXS.Material
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxOutlineShader |


GXSysHelp v.2.5: GXS.OutlineShader: Class TgxOutlineShader

Class TgxOutlineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.OutlineShader

Declaration

type TgxOutlineShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxOutlineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineColor: TgxColor;
Private | FOutlineSmooth: Boolean;
Private | FOutlineWidth: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetOutlineSmooth(v: boolean);
Private | procedure SetOutlineWidth(v: single);

Properties

Published | property LineColor: TgxColor read FLineColor write FLineColor;
Published | property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;
Published | property LineWidth: Single read FOutlineWidth write SetOutlineWidth;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineColor: TgxColor;

This item has no description.

Private FOutlineSmooth: Boolean;

This item has no description.

Private FOutlineWidth: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetOutlineSmooth(v: boolean);

This item has no description.

Private procedure SetOutlineWidth(v: single);

This item has no description.

Properties

Published property LineColor: TgxColor read FLineColor write FLineColor;

This item has no description.

Published property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;

Line smoothing control

Published property LineWidth: Single read FOutlineWidth write SetOutlineWidth;


GXSysHelp v.2.5: GXS.PAKArchive

Unit GXS.PAKArchive

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.ArchiveManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TPakHeader |
Record TFileSection |
Class TPAKArchive |

Constants

SIGN = 'PACK';

Description

Constants

SIGN = 'PACK';


GXSysHelp v.2.5: GXS.PAKArchive: Record TPakHeader

Record TPakHeader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PAKArchive

Declaration

type TPakHeader = record

Description

This item has no description.

Overview

Fields

Public | Signature: array [0 .. 3] of AnsiChar;
Public | DirOffset: integer;
Public | DirLength: integer;

Description

Fields

Public Signature: array [0 .. 3] of AnsiChar;

This item has no description.

Public DirOffset: integer;

This item has no description.

Public DirLength: integer;


GXSysHelp v.2.5: GXS.PAKArchive: Record TFileSection

Record TFileSection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PAKArchive

Declaration

type TFileSection = record

Description

This item has no description.

Overview

Fields

Public | FileName: array [0 .. 119] of AnsiChar;
Public | FilePos: integer;
Public | FileLength: integer;

Description

Fields

Public FileName: array [0 .. 119] of AnsiChar;

This item has no description.

Public FilePos: integer;

This item has no description.

Public FileLength: integer;


GXSysHelp v.2.5: GXS.PAKArchive: Class TPAKArchive

Class TPAKArchive

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PAKArchive

Declaration

type TPAKArchive = class(TgxBaseArchive)

Description

This item has no description. Showing description inherited from TgxBaseArchive.

Base classes for archivers

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxBaseArchive
  • TPAKArchive

Overview

Fields

Private | FHeader: TPakHeader;
Private | FStream: TFileStream;

Methods

Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(Stream: TStream; index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContentSize(index: integer): integer; override;
Public | function GetContentSize(ContentName: string): integer; override;
Private | function GetContentCount: integer;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(ContentName: string); override;
Public | procedure RemoveContent(index: integer); override;
Private | procedure MakeContentList;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Fields

Private FHeader: TPakHeader;

This item has no description.

Private FStream: TFileStream;

This item has no description.

Methods

Public function ContentExists(ContentName: string): boolean; override;

This item has no description.

Public function GetContent(Stream: TStream; index: integer): TStream; override;

This item has no description.

Public function GetContent(ContentName: string): TStream; override;

This item has no description.

Public function GetContent(index: integer): TStream; override;

This item has no description.

Public function GetContentSize(index: integer): integer; override;

This item has no description.

Public function GetContentSize(ContentName: string): integer; override;

This item has no description.

Private function GetContentCount: integer;

This item has no description.

Public procedure AddFromFile(FileName, Path: string); override;

This item has no description.

Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure Extract(ContentName, NewName: string); override;

This item has no description.

Public procedure Extract(index: integer; NewName: string); override;

This item has no description.

Public procedure LoadFromFile(const FileName: string); override;

This item has no description.

Public procedure RemoveContent(ContentName: string); override;

This item has no description.

Public procedure RemoveContent(index: integer); override;

This item has no description.

Private procedure MakeContentList;

This item has no description.

Properties

Public property ContentCount: integer Read GetContentCount;


GXSysHelp v.2.5: GXS.ParallelRegister

Unit GXS.ParallelRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • DesignIntf
  • DesignEditors
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAEditor |
Class TCUDACompilerEditor |
Class TCUDACompilerSourceProperty |
Class TCUDADeviceProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

ToolsAPI, STREDIT,


GXSysHelp v.2.5: GXS.ParallelRegister: Class TCUDAEditor

Class TCUDAEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParallelRegister

Declaration

type TCUDAEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TCUDAEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.ParallelRegister: Class TCUDACompilerEditor

Class TCUDACompilerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParallelRegister

Declaration

type TCUDACompilerEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TCUDACompilerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.ParallelRegister: Class TCUDACompilerSourceProperty

Class TCUDACompilerSourceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParallelRegister

Declaration

type TCUDACompilerSourceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TCUDACompilerSourceProperty

Overview

Fields

Private FModuleList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;
Private | procedure RefreshModuleList;

Description

Fields

Private FModuleList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;

This item has no description.

Private procedure RefreshModuleList;


GXSysHelp v.2.5: GXS.ParallelRegister: Class TCUDADeviceProperty

Class TCUDADeviceProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParallelRegister

Declaration

type TCUDADeviceProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TCUDADeviceProperty

Overview

Fields

Private FDeviceList: TStringList;

Methods

Public | constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;

Description

Fields

Private FDeviceList: TStringList;

This item has no description.

Methods

Public constructor Create(const ADesigner: IDesigner; APropCount: Integer); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: String); override;


GXSysHelp v.2.5: GXS.ParametricSurfaces

Unit GXS.ParametricSurfaces

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLScene.VectorTypes
  • GXS.CurvesAndSurfaces
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.PersistentClasses
  • GXS.VectorFileObjects
  • GXS.Texture
  • GXS.State
  • GXS.Context
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMOParametricSurface |
Class TFGBezierSurface |

Types

TParametricSurfaceBasis = (...);
TParametricSurfaceRenderer = (...);

Description

Types

TParametricSurfaceBasis = (...);

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

Values
  • psbBezier
  • psbBSpline
TParametricSurfaceRenderer = (...);

psrGLXcene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenVX uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

Values
  • psrGLXcene
  • psrOpenVX


GXSysHelp v.2.5: GXS.ParametricSurfaces: Class TMOParametricSurface

Class TMOParametricSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParametricSurfaces

Declaration

type TMOParametricSurface = class(TgxMeshObject)

Description

This item has no description. Showing description inherited from TgxMeshObject.

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TMOxxx".

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TMOParametricSurface

Overview

Fields

Private | FControlPoints: TgxAffineVectorList;
Private | FWeightedControlPoints: TgxAffineVectorList;
Private | FKnotsU: TgxSingleList;
Private | FKnotsV: TgxSingleList;
Private | FWeights: TgxSingleList;
Private | FOrderU: Integer;
Private | FOrderV: Integer;
Private | FCountU: Integer;
Private | FCountV: Integer;
Private | FResolution: Integer;
Private | FAutoKnots: Boolean;
Private | FContinuity: TBSplineContinuity;
Private | FRenderer: TParametricSurfaceRenderer;
Private | FBasis: TParametricSurfaceBasis;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure Clear; override;
Public | procedure GenerateMesh;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;
Private | procedure SetBasis(Value: TParametricSurfaceBasis);
Private | procedure SetControlPoints(Value: TgxAffineVectorList);
Private | procedure SetKnotsU(Value: TgxSingleList);
Private | procedure SetKnotsV(Value: TgxSingleList);
Private | procedure SetRenderer(Value: TParametricSurfaceRenderer);
Private | procedure SetWeights(Value: TgxSingleList);

Properties

Public | property AutoKnots: Boolean read FAutoKnots write FAutoKnots;
Public | property Basis: TParametricSurfaceBasis read FBasis write SetBasis;
Public | property Continuity: TBSplineContinuity read FContinuity write FContinuity;
Public | property ControlPoints: TgxAffineVectorList read FControlPoints write SetControlPoints;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property KnotsU: TgxSingleList read FKnotsU write SetKnotsU;
Public | property KnotsV: TgxSingleList read FKnotsV write SetKnotsV;
Public | property OrderU: Integer read FOrderU write FOrderU;
Public | property OrderV: Integer read FOrderV write FOrderV;
Public | property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property Weights: TgxSingleList read FWeights write SetWeights;

Description

Fields

Private FControlPoints: TgxAffineVectorList;

This item has no description.

Private FWeightedControlPoints: TgxAffineVectorList;

This item has no description.

Private FKnotsU: TgxSingleList;

This item has no description.

Private FKnotsV: TgxSingleList;

This item has no description.

Private FWeights: TgxSingleList;

This item has no description.

Private FOrderU: Integer;

This item has no description.

Private FOrderV: Integer;

This item has no description.

Private FCountU: Integer;

This item has no description.

Private FCountV: Integer;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FAutoKnots: Boolean;

This item has no description.

Private FContinuity: TBSplineContinuity;

This item has no description.

Private FRenderer: TParametricSurfaceRenderer;

This item has no description.

Private FBasis: TParametricSurfaceBasis;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure Clear; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure GenerateMesh;

Generates a mesh approximation of the surface defined by the properties below. This is used to construct the mesh when using Renderer = psrGLXcene. If you want to render using OpenGL calls but would like to obtain the mesh data also use this call to generate the mesh data. Fills in Vertices, Normals, etc.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TgxMeshObject.Prepare.

Precalculate whatever is needed for rendering, called once

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Private procedure SetBasis(Value: TParametricSurfaceBasis);

This item has no description.

Private procedure SetControlPoints(Value: TgxAffineVectorList);

This item has no description.

Private procedure SetKnotsU(Value: TgxSingleList);

This item has no description.

Private procedure SetKnotsV(Value: TgxSingleList);

This item has no description.

Private procedure SetRenderer(Value: TParametricSurfaceRenderer);

This item has no description.

Private procedure SetWeights(Value: TgxSingleList);

This item has no description.

Properties

Public property AutoKnots: Boolean read FAutoKnots write FAutoKnots;

Automatically generate the knot vectors based on the Continuity. Only applies to BSpline surfaces.

Public property Basis: TParametricSurfaceBasis read FBasis write SetBasis;

Basis determines the style of curve, psbBezier or psbBSpline

Public property Continuity: TBSplineContinuity read FContinuity write FContinuity;

This item has no description.

Public property ControlPoints: TgxAffineVectorList read FControlPoints write SetControlPoints;

Control points define the parametric surface.

Public property CountU: Integer read FCountU write FCountU;

CountU and CountV describe the number of control points in the U and V direciton. Basically a control point width and height in (u,v) space.

Public property CountV: Integer read FCountV write FCountV;

This item has no description.

Public property KnotsU: TgxSingleList read FKnotsU write SetKnotsU;

KnotsU and KnotsV are the knot vectors in the U and V direction. Knots define the continuity of curves and how control points influence the parametric values to build the surface.

Public property KnotsV: TgxSingleList read FKnotsV write SetKnotsV;

This item has no description.

Public property OrderU: Integer read FOrderU write FOrderU;

OrderU and OrderV defines the curve order in the U and V direction

Public property OrderV: Integer read FOrderV write FOrderV;

This item has no description.

Public property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;

Determines whether to use OpenGL calls (psrOpenGL) or the GLScene mesh objects (psrGLScene) to render the surface.

Public property Resolution: Integer read FResolution write FResolution;

Defines how fine the resultant mesh will be. Higher values create finer meshes. Resolution = 50 would produce a 50x50 mesh. The GLU Nurbs rendering uses resolution as the U_STEP and V_STEP using the sampling method GLU_DOMAIN_DISTANCE, so the resolution works a little differently there.

Public property Weights: TgxSingleList read FWeights write SetWeights;

Weights define how much a control point effects the surface.


GXSysHelp v.2.5: GXS.ParametricSurfaces: Class TFGBezierSurface

Class TFGBezierSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParametricSurfaces

Declaration

type TFGBezierSurface = class(TgxFaceGroup)

Description

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TFGBezierSurface

Overview

Fields

Private | FCountU: Integer;
Private | FCountV: Integer;
Private | FControlPointIndices: TgxIntegerList;
Private | FTexCoordIndices: TgxIntegerList;
Private | FResolution: Integer;
Private | FMinU: Single;
Private | FMaxU: Single;
Private | FMinV: Single;
Private | FMaxV: Single;
Private | FTempControlPoints: TgxAffineVectorList;
Private | FTempTexCoords: TgxAffineVectorList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property ControlPointIndices: TgxIntegerList read FControlPointIndices write SetControlPointIndices;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property MaxU: Single read FMaxU write FMaxU;
Public | property MaxV: Single read FMaxV write FMaxV;
Public | property MinU: Single read FMinU write FMinU;
Public | property MinV: Single read FMinV write FMinV;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property TexCoordIndices: TgxIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Fields

Private FCountU: Integer;

This item has no description.

Private FCountV: Integer;

This item has no description.

Private FControlPointIndices: TgxIntegerList;

This item has no description.

Private FTexCoordIndices: TgxIntegerList;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FMinU: Single;

This item has no description.

Private FMaxU: Single;

This item has no description.

Private FMinV: Single;

This item has no description.

Private FMaxV: Single;

This item has no description.

Private FTempControlPoints: TgxAffineVectorList;

This item has no description.

Private FTempTexCoords: TgxAffineVectorList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TgxFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property ControlPointIndices: TgxIntegerList read FControlPointIndices write SetControlPointIndices;

This item has no description.

Public property CountU: Integer read FCountU write FCountU;

This item has no description.

Public property CountV: Integer read FCountV write FCountV;

This item has no description.

Public property MaxU: Single read FMaxU write FMaxU;

This item has no description.

Public property MaxV: Single read FMaxV write FMaxV;

This item has no description.

Public property MinU: Single read FMinU write FMinU;

This item has no description.

Public property MinV: Single read FMinV write FMinV;

This item has no description.

Public property Resolution: Integer read FResolution write FResolution;

This item has no description.

Public property TexCoordIndices: TgxIntegerList read FTexCoordIndices write SetTexCoordIndices;


GXSysHelp v.2.5: GXS.ParticleFX

Unit GXS.ParticleFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.PersistentClasses
  • GXS.VectorLists
  • GLScene.Manager
  • GXS.Scene
  • GXS.ImageUtils
  • GXS.State
  • GXS.Material
  • GXS.Cadencer
  • GXS.Graphics
  • GXS.Context
  • GXS.Color
  • GXS.BaseClasses
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GLScene.PipelineTransform
  • GLScene.XCollection
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxParticle |
Class TgxParticleList |
Class TgxParticleFXManager |
Class TgxParticleFXEffect |
Packed Record TParticleReference |
Record TPFXRegion |
Class TgxParticleFXRenderer |
Class TgxSourcePFXEffect |
Class TgxDynamicPFXManager |
Class TPFXLifeColor |
Class TPFXLifeColors |
Class TgxLifeColoredPFXManager |
Class TgxCustomPFXManager |
Class TgxPolygonPFXManager |
Class TgxBaseSpritePFXManager |
Class TgxCustomSpritePFXManager |
Class TgxPointLightPFXManager |

Functions and Procedures

function GetOrCreateSourcePFX(obj: TgxBaseSceneObject; const name: string = ''): TgxSourcePFXEffect;

Types

PFXPointerList = ˆTFXPointerList;
PGLParticleArray = ˆTgxParticleArray;
PParticleReference = ˆTParticleReference;
PParticleReferenceArray = ˆTParticleReferenceArray;
PPFXRegion = ˆTPFXRegion;
TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;
TgxParticleArray = array[0..MaxInt shr 4] of TgxParticle;
TgxParticleClass = class of TgxParticle;
TgxSourcePFXDispersionMode = (...);
TgxSourcePFXPositionMode = (...);
TgxSourcePFXVelocityMode = (...);
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;
TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TgxParticle) of object;
TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TgxParticle; var rci: TgxRenderContextInfo) of object;
TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;
TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TgxProgressTimes; aParticle: TgxParticle; var killParticle: Boolean) of object;
TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TgxBitmap32; var texFormat: Integer) of object;
TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TgxProgressTimes; var defaultProgress: Boolean) of object;
TPFXSortAccuracy = (...);
TSpriteColorMode = (...);
TSpritesPerTexture = (...);

Constants

cPFXNbRegions = 128;
cPFXGranularity = 128;

Description

Functions and Procedures

function GetOrCreateSourcePFX(obj: TgxBaseSceneObject; const name: string = ''): TgxSourcePFXEffect;

Returns or creates the TgxBInertia within the given object's behaviours.

Types

PFXPointerList = ˆTFXPointerList;

This item has no description.

PGLParticleArray = ˆTgxParticleArray;

This item has no description.

PParticleReference = ˆTParticleReference;

This item has no description.

PParticleReferenceArray = ˆTParticleReferenceArray;

This item has no description.

PPFXRegion = ˆTPFXRegion;

This item has no description.

TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;

This item has no description.

TgxParticleArray = array[0..MaxInt shr 4] of TgxParticle;

This item has no description.

TgxParticleClass = class of TgxParticle;

This item has no description.

TgxSourcePFXDispersionMode = (...);

This item has no description.

Values
  • sdmFast
  • sdmIsotropic
TgxSourcePFXPositionMode = (...);

This item has no description.

Values
  • spmAbsoluteOffset
  • spmRelative
TgxSourcePFXVelocityMode = (...);

This item has no description.

Values
  • svmAbsolute
  • svmRelative
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;

This item has no description.

TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TgxParticle) of object;

This item has no description.

TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TgxParticle; var rci: TgxRenderContextInfo) of object;

This item has no description.

TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;

This item has no description.

TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TgxProgressTimes; aParticle: TgxParticle; var killParticle: Boolean) of object;

This item has no description.

TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TgxBitmap32; var texFormat: Integer) of object;

This item has no description.

TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TgxProgressTimes; var defaultProgress: Boolean) of object;

This item has no description.

TPFXSortAccuracy = (...);

This item has no description.

Values
  • saLow
  • saOneTenth
  • saOneThird
  • saOneHalf
  • saHigh
TSpriteColorMode = (...);

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored).

Values
  • scmFade
  • scmInner
  • scmOuter
  • scmNone
TSpritesPerTexture = (...);

Sprites per sprite texture for the SpritePFX.

Values
  • sptOne
  • sptFour

Constants

cPFXNbRegions = 128;

This item has no description.

cPFXGranularity = 128;

number of distance regions


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxParticle

Class TgxParticle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxParticle = class(TgxPersistentObject)

Description

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

Hierarchy

  • TgxPersistentObject
  • TgxParticle

Overview

Fields

Private | FID: Integer;
Private | FTag: Integer;
Private | FManager: TgxParticleFXManager;
Private | FPosition: TAffineVector;
Private | FVelocity: TAffineVector;
Private | FRotation: Single;
Private | FCreationTime: Double;
Private | FEffectScale: Single;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Private | function GetPosition(const Index: Integer): Single;
Private | function GetVelocity(const Index: Integer): Single;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;
Private | procedure WritePosition(const Index: Integer; const aValue: Single);
Private | procedure WriteVelocity(const Index: Integer; const aValue: Single);

Properties

Public | property CreationTime: Double read FCreationTime write FCreationTime;
Public | property ID: Integer read FID;
Public | property Manager: TgxParticleFXManager read FManager write FManager;
Public | property Position: TAffineVector read FPosition write FPosition;
Public | property PosX : Single index 0 read GetPosition write WritePosition;
Public | property PosY : Single index 1 read GetPosition write WritePosition;
Public | property PosZ : Single index 2 read GetPosition write WritePosition;
Public | property Tag: Integer read FTag write FTag;
Public | property Velocity: TAffineVector read FVelocity write FVelocity;
Public | property VelX : Single index 0 read GetVelocity write WriteVelocity;
Public | property VelY : Single index 1 read GetVelocity write WriteVelocity;
Public | property VelZ : Single index 2 read GetVelocity write WriteVelocity;

Description

Fields

Private FID: Integer;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FManager: TgxParticleFXManager;

This item has no description.

Private FPosition: TAffineVector;

NOT persistent

Private FVelocity: TAffineVector;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FCreationTime: Double;

This item has no description.

Private FEffectScale: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetPosition(const Index: Integer): Single;

This item has no description.

Private function GetVelocity(const Index: Integer): Single;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Private procedure WritePosition(const Index: Integer; const aValue: Single);

This item has no description.

Private procedure WriteVelocity(const Index: Integer; const aValue: Single);

This item has no description.

Properties

Public property CreationTime: Double read FCreationTime write FCreationTime;

Time at which particle was created

Public property ID: Integer read FID;

Particle's ID, given at birth. ID is a value unique per manager.

Public property Manager: TgxParticleFXManager read FManager write FManager;

This item has no description.

Public property Position: TAffineVector read FPosition write FPosition;

Particle's absolute position. Note that this property is read-accessed directly at rendering time in the innards of the depth-sorting code.

Public property PosX : Single index 0 read GetPosition write WritePosition;

This item has no description.

Public property PosY : Single index 1 read GetPosition write WritePosition;

This item has no description.

Public property PosZ : Single index 2 read GetPosition write WritePosition;

This item has no description.

Public property Tag: Integer read FTag write FTag;

This item has no description.

Public property Velocity: TAffineVector read FVelocity write FVelocity;

Particle's velocity. This velocity is indicative and is NOT automatically applied to the position during progression events by this class (subclasses may implement that).

Public property VelX : Single index 0 read GetVelocity write WriteVelocity;

This item has no description.

Public property VelY : Single index 1 read GetVelocity write WriteVelocity;

This item has no description.

Public property VelZ : Single index 2 read GetVelocity write WriteVelocity;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxParticleList

Class TgxParticleList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxParticleList = class(TgxPersistentObject)

Description

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.

Hierarchy

  • TgxPersistentObject
  • TgxParticleList

Overview

Fields

Private | FOwner: TgxParticleFXManager;
Private | FItemList: TgxPersistentObjectList;
Private | FDirectList: PGLParticleArray;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function AddItem(aItem: TgxParticle): Integer;
Public | function IndexOfItem(aItem: TgxParticle): Integer;
Public | function ItemCount: Integer;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure RemoveAndFreeItem(aItem: TgxParticle);
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Items[index: Integer]: TgxParticle read GetItems write SetItems;
Public | property List: PGLParticleArray read FDirectList;
Public | property Owner: TgxParticleFXManager read FOwner write FOwner;

Description

Fields

Private FOwner: TgxParticleFXManager;

This item has no description.

Private FItemList: TgxPersistentObjectList;

NOT persistent

Private FDirectList: PGLParticleArray;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddItem(aItem: TgxParticle): Integer;

Adds a particle to the list. Particle owneship is defined blindly, if the particle was previously in another list, it won't be automatically removed from that list.

Public function IndexOfItem(aItem: TgxParticle): Integer;

This item has no description.

Public function ItemCount: Integer;

This item has no description.

Public procedure Pack;

Packs the list by removing all "nil" items. Note: this functions is orders of magnitude faster than the TList version.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure RemoveAndFreeItem(aItem: TgxParticle);

Removes and frees a particular item for the list. If the item is not part of the list, nothing is done. If found in the list, the item's "slot" is set to nil and item is freed (after setting its ownership to nil). The nils can be removed with a call to Pack.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Items[index: Integer]: TgxParticle read GetItems write SetItems;

This item has no description.

Public property List: PGLParticleArray read FDirectList;

This item has no description.

Public property Owner: TgxParticleFXManager read FOwner write FOwner;

Refers owner manager


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxParticleFXManager

Class TgxParticleFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxParticleFXManager = class(TgxCadencedComponent)

Description

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager

Overview

Fields

Private | FBlendingMode: TgxBlendingMode;
Private | FRenderer: TgxParticleFXRenderer;
Private | FParticles: TgxParticleList;
Private | FNextID: Integer;
Private | FOnCreateParticle: TPFXCreateParticleEvent;
Private | FAutoFreeWhenEmpty: Boolean;
Private | FUsers: TList;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TgxParticle; virtual;
Public | function ParticleCount: Integer; virtual;
Public | class function ParticlesClass: TgxParticleClass; virtual;
Public | procedure CreateParticles(nbParticles: Integer);
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Public | property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;
Published | property Cadencer;
Published | property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;
Public | property Particles: TgxParticleList read FParticles write SetParticles;
Published | property Renderer: TgxParticleFXRenderer read FRenderer write SetRenderer;

Description

Fields

Private FBlendingMode: TgxBlendingMode;

This item has no description.

Private FRenderer: TgxParticleFXRenderer;

This item has no description.

Private FParticles: TgxParticleList;

This item has no description.

Private FNextID: Integer;

This item has no description.

Private FOnCreateParticle: TPFXCreateParticleEvent;

This item has no description.

Private FAutoFreeWhenEmpty: Boolean;

This item has no description.

Private FUsers: TList;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TgxParticle; virtual;

Creates a new particle controlled by the manager.

Public function ParticleCount: Integer; virtual;

Return the number of particles. Note that subclasses may decide to return a particle count inferior to Particles.ItemCount, and the value returned by this method will be the one honoured at render time.

Public class function ParticlesClass: TgxParticleClass; virtual;

Class of particles created by this manager. }

Public procedure CreateParticles(nbParticles: Integer);

Create several particles at once.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Public property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;

If True the manager will free itself when its particle count reaches zero. Check happens in the progression event, use with caution and only if you know what you're doing!

Published property Cadencer;

This item has no description.

Published property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;

Event triggered after standard particle creation and initialization.

Public property Particles: TgxParticleList read FParticles write SetParticles;

A TgxParticleList property.

Published property Renderer: TgxParticleFXRenderer read FRenderer write SetRenderer;

References the renderer. The renderer takes care of ordering the particles of the manager (and other managers linked to it) and rendering them all depth-sorted.


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxParticleFXEffect

Class TgxParticleFXEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxParticleFXEffect = class(TgxObjectPostEffect)

Description

Base class for linking scene objects to a particle FX manager.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPostEffect
  • TgxParticleFXEffect

Overview

Fields

Private | FManager: TgxParticleFXManager;
Private | FManagerName: string;
Private | FEffectScale: single;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Private | procedure SetEffectScale(const Value: single);

Properties

Published | property EffectScale: single read FEffectScale write SetEffectScale;
Published | property Manager: TgxParticleFXManager read FManager write SetManager;

Description

Fields

Private FManager: TgxParticleFXManager;

This item has no description.

Private FManagerName: string;

This item has no description.

Private FEffectScale: single;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetEffectScale(const Value: single);

This item has no description.

Properties

Published property EffectScale: single read FEffectScale write SetEffectScale;

This item has no description.

Published property Manager: TgxParticleFXManager read FManager write SetManager;

Reference to the Particle FX manager


GXSysHelp v.2.5: GXS.ParticleFX: Packed Record TParticleReference

Packed Record TParticleReference

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TParticleReference = packed record

Description

PFX region rendering structures

Overview

Fields

Public | particle: TgxParticle;
Public | distance: Integer;

Description

Fields

Public particle: TgxParticle;

This item has no description.

Public distance: Integer;


GXSysHelp v.2.5: GXS.ParticleFX: Record TPFXRegion

Record TPFXRegion

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TPFXRegion = record

Description

This item has no description.

Overview

Fields

Public | count: Integer;
Public | capacity: Integer;
Public | particleRef: PParticleReferenceArray;
Public | particleOrder: PFXPointerList;

Description

Fields

Public count: Integer;

This item has no description.

Public capacity: Integer;

This item has no description.

Public particleRef: PParticleReferenceArray;

This item has no description.

Public particleOrder: PFXPointerList;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxParticleFXRenderer

Class TgxParticleFXRenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxParticleFXRenderer = class(TgxBaseSceneObject)

Description

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxParticleFXRenderer

Overview

Fields

Private | FManagerList: TList;
Private | FLastSortTime: Double;
Private | FLastParticleCount: Integer;
Private | FZWrite: Boolean;
Private | FZTest: Boolean;
Private | FZCull: Boolean;
Private | FZSortAccuracy: TPFXSortAccuracy;
Private | FZMaxDistance: Single;
Private | FBlendingMode: TgxBlendingMode;
Private | FRegions: array[0..cPFXNbRegions - 1] of TPFXRegion;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property BlendingMode: TgxBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;
Public | property LastParticleCount: Integer read FLastParticleCount;
Public | property LastSortTime: Double read FLastSortTime;
Published | property Visible;
Published | property ZCull: Boolean read FZCull write FZCull default True;
Published | property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;
Published | property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;
Published | property ZTest: Boolean read FZTest write FZTest default True;
Published | property ZWrite: Boolean read FZWrite write FZWrite default False;

Description

Fields

Private FManagerList: TList;

This item has no description.

Private FLastSortTime: Double;

This item has no description.

Private FLastParticleCount: Integer;

This item has no description.

Private FZWrite: Boolean;

This item has no description.

Private FZTest: Boolean;

This item has no description.

Private FZCull: Boolean;

This item has no description.

Private FZSortAccuracy: TPFXSortAccuracy;

This item has no description.

Private FZMaxDistance: Single;

This item has no description.

Private FBlendingMode: TgxBlendingMode;

This item has no description.

Private FRegions: array[0..cPFXNbRegions - 1] of TPFXRegion;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

Quick Explanation of what is below: The purpose is to depth-sort a large number (thousandths) of particles and render them back to front. The rendering part is not particularly complex, it just invokes the various PFX managers involved and request particle renderings. The sort uses a first-pass region partition (the depth range is split into regions, and particles are assigned directly to the region they belong to), then each region is sorted with a QuickSort. The QuickSort itself is the regular classic variant, but the comparison is made on singles as if they were integers, this is allowed by the IEEE format in a very efficient manner if all values are superior to 1, which is ensured by the distance calculation and a fixed offset of 1

Properties

Published property BlendingMode: TgxBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;

Default blending mode for particles. "Additive" blending is the usual mode (increases brightness and saturates), "transparency" may be used for smoke or systems that opacify view, "opaque" is more rarely used. Note: specific PFX managers may override/ignore this setting.

Public property LastParticleCount: Integer read FLastParticleCount;

Amount of particles during the last render.

Public property LastSortTime: Double read FLastSortTime;

Time (in msec) spent sorting the particles for last render.

Published property Visible;

This item has no description.

Published property ZCull: Boolean read FZCull write FZCull default True;

If true the renderer will cull particles that are behind the camera.

Published property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;

Maximum distance for rendering PFX particles. If zero, camera's DepthOfView is used.

Published property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;

If true particles will be accurately sorted back to front. When false, only a rough ordering is used, which can result in visual glitches but may be faster.

Published property ZTest: Boolean read FZTest write FZTest default True;

Specifies if particles should write to test ZBuffer.

Published property ZWrite: Boolean read FZWrite write FZWrite default False;

Specifies if particles should write to ZBuffer. If the PFXRenderer is the last object to be rendered in the scene, it is not necessary to write to the ZBuffer since the particles are depth-sorted. Writing to the ZBuffer has a performance penalty.


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxSourcePFXEffect

Class TgxSourcePFXEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxSourcePFXEffect = class(TgxParticleFXEffect)

Description

Simple Particles Source.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPostEffect
  • TgxParticleFXEffect
  • TgxSourcePFXEffect

Overview

Fields

Private | FInitialVelocity: TgxCoordinates;
Private | FInitialPosition: TgxCoordinates;
Private | FPositionDispersionRange: TgxCoordinates;
Private | FVelocityDispersion: Single;
Private | FPositionDispersion: Single;
Private | FParticleInterval: Single;
Private | FVelocityMode: TgxSourcePFXVelocityMode;
Private | FPositionMode: TgxSourcePFXPositionMode;
Private | FDispersionMode: TgxSourcePFXDispersionMode;
Private | FEnabled: Boolean;
Private | FDisabledIfOwnerInvisible: Boolean;
Private | FTimeRemainder: Double;
Private | FRotationDispersion: Single;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure Burst(time: Double; nb: Integer);
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);

Properties

Published | property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;
Published | property DispersionMode: TgxSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;
Published | property Enabled: boolean read FEnabled write FEnabled;
Published | property InitialPosition: TgxCoordinates read FInitialPosition write SetInitialPosition;
Published | property InitialVelocity: TgxCoordinates read FInitialVelocity write SetInitialVelocity;
Published | property ParticleInterval: Single read FParticleInterval write SetParticleInterval;
Published | property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;
Published | property PositionDispersionRange: TgxCoordinates read FPositionDispersionRange write SetPositionDispersionRange;
Published | property PositionMode: TgxSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;
Published | property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;
Published | property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;
Published | property VelocityMode: TgxSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;

Description

Fields

Private FInitialVelocity: TgxCoordinates;

This item has no description.

Private FInitialPosition: TgxCoordinates;

This item has no description.

Private FPositionDispersionRange: TgxCoordinates;

This item has no description.

Private FVelocityDispersion: Single;

This item has no description.

Private FPositionDispersion: Single;

This item has no description.

Private FParticleInterval: Single;

This item has no description.

Private FVelocityMode: TgxSourcePFXVelocityMode;

This item has no description.

Private FPositionMode: TgxSourcePFXPositionMode;

This item has no description.

Private FDispersionMode: TgxSourcePFXDispersionMode;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FDisabledIfOwnerInvisible: Boolean;

This item has no description.

Private FTimeRemainder: Double;

This item has no description.

Private FRotationDispersion: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Burst(time: Double; nb: Integer);

Instantaneously creates nb particles

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);

This item has no description.

Properties

Published property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;

This item has no description.

Published property DispersionMode: TgxSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;

This item has no description.

Published property Enabled: boolean read FEnabled write FEnabled;

This item has no description.

Published property InitialPosition: TgxCoordinates read FInitialPosition write SetInitialPosition;

This item has no description.

Published property InitialVelocity: TgxCoordinates read FInitialVelocity write SetInitialVelocity;

This item has no description.

Published property ParticleInterval: Single read FParticleInterval write SetParticleInterval;

This item has no description.

Published property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;

This item has no description.

Published property PositionDispersionRange: TgxCoordinates read FPositionDispersionRange write SetPositionDispersionRange;

This item has no description.

Published property PositionMode: TgxSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;

This item has no description.

Published property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;

This item has no description.

Published property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;

This item has no description.

Published property VelocityMode: TgxSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxDynamicPFXManager

Class TgxDynamicPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxDynamicPFXManager = class(TgxParticleFXManager)

Description

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager

Overview

Fields

Private | FAcceleration: TgxCoordinates;
Private | FFriction: Single;
Private | FCurrentTime: Double;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;

Properties

Published | property Acceleration: TgxCoordinates read FAcceleration write SetAcceleration;
Published | property Friction: Single read FFriction write FFriction;

Description

Fields

Private FAcceleration: TgxCoordinates;

This item has no description.

Private FFriction: Single;

This item has no description.

Private FCurrentTime: Double;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Properties

Published property Acceleration: TgxCoordinates read FAcceleration write SetAcceleration;

Oriented acceleration applied to the particles.

Published property Friction: Single read FFriction write FFriction;

Friction applied to the particles. Friction is applied as a speed scaling factor over 1 second, ie. a friction of 0.5 will half speed over 1 second, a friction of 3 will triple speed over 1 second, and a friction of 1 (default value) will have no effect.


GXSysHelp v.2.5: GXS.ParticleFX: Class TPFXLifeColor

Class TPFXLifeColor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TPFXLifeColor = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TPFXLifeColor

Overview

Fields

Private | FColorInner: TgxColor;
Private | FColorOuter: TgxColor;
Private | FLifeTime: Single;
Private | FInvLifeTime: Single;
Private | FIntervalRatio: Single;
Private | FSizeScale: Single;
Private | FDoScale: Boolean;
Private | FDoRotate: boolean;
Private | FRotateAngle: Single;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property ColorInner: TgxColor read FColorInner write SetColorInner;
Published | property ColorOuter: TgxColor read FColorOuter write SetColorOuter;
Public | property InvIntervalRatio: Single read FIntervalRatio;
Public | property InvLifeTime: Single read FInvLifeTime;
Published | property LifeTime: Single read FLifeTime write SetLifeTime;
Published | property RotateAngle: Single read FRotateAngle write SetRotateAngle;
Published | property SizeScale: Single read FSizeScale write SetSizeScale;

Description

Fields

Private FColorInner: TgxColor;

This item has no description.

Private FColorOuter: TgxColor;

This item has no description.

Private FLifeTime: Single;

This item has no description.

Private FInvLifeTime: Single;

This item has no description.

Private FIntervalRatio: Single;

This item has no description.

Private FSizeScale: Single;

This item has no description.

Private FDoScale: Boolean;

This item has no description.

Private FDoRotate: boolean;

This item has no description.

Private FRotateAngle: Single;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

indirectly persistent

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ColorInner: TgxColor read FColorInner write SetColorInner;

This item has no description.

Published property ColorOuter: TgxColor read FColorOuter write SetColorOuter;

This item has no description.

Public property InvIntervalRatio: Single read FIntervalRatio;

Stores 1/(LifeTime[Next]-LifeTime[Self])

Public property InvLifeTime: Single read FInvLifeTime;

Stores 1/LifeTime

Published property LifeTime: Single read FLifeTime write SetLifeTime;

This item has no description.

Published property RotateAngle: Single read FRotateAngle write SetRotateAngle;

This item has no description.

Published property SizeScale: Single read FSizeScale write SetSizeScale;


GXSysHelp v.2.5: GXS.ParticleFX: Class TPFXLifeColors

Class TPFXLifeColors

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TPFXLifeColors = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TPFXLifeColors

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add: TPFXLifeColor;
Public | function FindItemID(ID: Integer): TPFXLifeColor;
Public | function MaxLifeTime: Double;
Public | function RotationsDefined: Boolean;
Public | function ScalingDefined: Boolean;
Public | procedure PrepareIntervalRatios;

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public function Add: TPFXLifeColor;

This item has no description.

Public function FindItemID(ID: Integer): TPFXLifeColor;

This item has no description.

Public function MaxLifeTime: Double;

This item has no description.

Public function RotationsDefined: Boolean;

This item has no description.

Public function ScalingDefined: Boolean;

This item has no description.

Public procedure PrepareIntervalRatios;

This item has no description.

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxLifeColoredPFXManager

Class TgxLifeColoredPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxLifeColoredPFXManager = class(TgxDynamicPFXManager)

Description

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager

Overview

Fields

Private | FLifeColors: TPFXLifeColors;
Private | FLifeColorsLookup: TList;
Private | FLifeRotations: Boolean;
Private | FLifeScaling: Boolean;
Private | FColorInner: TgxColor;
Private | FColorOuter: TgxColor;
Private | FParticleSize: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property BlendingMode default bmAdditive;
Public | property ColorInner: TgxColor read FColorInner write SetColorInner;
Public | property ColorOuter: TgxColor read FColorOuter write SetColorOuter;
Public | property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;
Public | property ParticleSize: Single read FParticleSize write FParticleSize;

Description

Fields

Private FLifeColors: TPFXLifeColors;

This item has no description.

Private FLifeColorsLookup: TList;

This item has no description.

Private FLifeRotations: Boolean;

This item has no description.

Private FLifeScaling: Boolean;

This item has no description.

Private FColorInner: TgxColor;

This item has no description.

Private FColorOuter: TgxColor;

This item has no description.

Private FParticleSize: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property BlendingMode default bmAdditive;

This item has no description.

Public property ColorInner: TgxColor read FColorInner write SetColorInner;

This item has no description.

Public property ColorOuter: TgxColor read FColorOuter write SetColorOuter;

This item has no description.

Public property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;

This item has no description.

Public property ParticleSize: Single read FParticleSize write FParticleSize;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxCustomPFXManager

Class TgxCustomPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxCustomPFXManager = class(TgxLifeColoredPFXManager)

Description

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxCustomPFXManager

Overview

Fields

Private | FOnInitializeRendering: TDirectRenderEvent;
Private | FOnBeginParticles: TDirectRenderEvent;
Private | FOnRenderParticle: TPFXDirectRenderEvent;
Private | FOnEndParticles: TDirectRenderEvent;
Private | FOnFinalizeRendering: TDirectRenderEvent;
Private | FOnProgress: TPFXProgressEvent;
Private | FOnParticleProgress: TPFXParticleProgress;
Private | FOnGetParticleCountEvent: TPFXGetParticleCountEvent;

Methods

Public | function ParticleCount: Integer; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnBeginParticles: TDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;
Published | property OnEndParticles: TDirectRenderEvent read FOnEndParticles write FOnEndParticles;
Published | property OnFinalizeRendering: TDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;
Published | property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;
Published | property OnInitializeRendering: TDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;
Published | property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;
Published | property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;
Published | property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;
Published | property ParticleSize;

Description

Fields

Private FOnInitializeRendering: TDirectRenderEvent;

This item has no description.

Private FOnBeginParticles: TDirectRenderEvent;

This item has no description.

Private FOnRenderParticle: TPFXDirectRenderEvent;

This item has no description.

Private FOnEndParticles: TDirectRenderEvent;

This item has no description.

Private FOnFinalizeRendering: TDirectRenderEvent;

This item has no description.

Private FOnProgress: TPFXProgressEvent;

This item has no description.

Private FOnParticleProgress: TPFXParticleProgress;

This item has no description.

Private FOnGetParticleCountEvent: TPFXGetParticleCountEvent;

This item has no description.

Methods

Public function ParticleCount: Integer; override;

This item has no description. Showing description inherited from TgxParticleFXManager.ParticleCount.

Return the number of particles. Note that subclasses may decide to return a particle count inferior to Particles.ItemCount, and the value returned by this method will be the one honoured at render time.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property OnBeginParticles: TDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;

This item has no description.

Published property OnEndParticles: TDirectRenderEvent read FOnEndParticles write FOnEndParticles;

This item has no description.

Published property OnFinalizeRendering: TDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;

This item has no description.

Published property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;

This item has no description.

Published property OnInitializeRendering: TDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;

This item has no description.

Published property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;

This item has no description.

Published property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Published property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;

This item has no description.

Published property ParticleSize;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxPolygonPFXManager

Class TgxPolygonPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxPolygonPFXManager = class(TgxLifeColoredPFXManager)

Description

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxPolygonPFXManager

Overview

Fields

Private | FNbSides: Integer;
Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | FVertices: TgxAffineVectorList;
Private | FVertBuf: TgxAffineVectorList;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property NbSides: Integer read FNbSides write SetNbSides default 6;
Published | property ParticleSize;

Description

Fields

Private FNbSides: Integer;

This item has no description.

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private FVertices: TgxAffineVectorList;

NOT persistent

Private FVertBuf: TgxAffineVectorList;

NOT persistent

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property NbSides: Integer read FNbSides write SetNbSides default 6;

This item has no description.

Published property ParticleSize;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxBaseSpritePFXManager

Class TgxBaseSpritePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxBaseSpritePFXManager = class(TgxLifeColoredPFXManager)

Description

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxBaseSpritePFXManager

Overview

Fields

Private | FTexHandle: TgxTextureHandle;
Private | Fvx: TAffineVector;
Private | Fvy: TAffineVector;
Private | Fvz: TAffineVector;
Private | FVertices: TgxAffineVectorList;
Private | FVertBuf: TgxAffineVectorList;
Private | FAspectRatio: Single;
Private | FRotation: Single;
Private | FShareSprites: TgxBaseSpritePFXManager;
Private | FSpritesPerTexture: TSpritesPerTexture;
Private | FColorMode: TSpriteColorMode;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;
Public | property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property ShareSprites: TgxBaseSpritePFXManager read FShareSprites write FShareSprites;

Description

Fields

Private FTexHandle: TgxTextureHandle;

This item has no description.

Private Fvx: TAffineVector;

This item has no description.

Private Fvy: TAffineVector;

This item has no description.

Private Fvz: TAffineVector;

This item has no description.

Private FVertices: TgxAffineVectorList;

NOT persistent

Private FVertBuf: TgxAffineVectorList;

NOT persistent

Private FAspectRatio: Single;

NOT persistent

Private FRotation: Single;

This item has no description.

Private FShareSprites: TgxBaseSpritePFXManager;

This item has no description.

Private FSpritesPerTexture: TSpritesPerTexture;

This item has no description.

Private FColorMode: TSpriteColorMode;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;

Ratio between width and height. An AspectRatio of 1 (default) will result in square sprite particles, values higher than one will result in horizontally stretched sprites, values below one will stretch vertically (assuming no rotation is applied).

Public property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;

This item has no description.

Published property Rotation: Single read FRotation write SetRotation;

Particle sprites rotation (in degrees). All particles of the PFX manager share this rotation.

Published property ShareSprites: TgxBaseSpritePFXManager read FShareSprites write FShareSprites;

If specified the manager will reuse the other manager's sprites. Sharing sprites between PFX managers can help at the rendering stage if particles of the managers are mixed by helping reduce the number of texture switches. Note that only the texture is shared, not the colors, sizes or other dynamic parameters.


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxCustomSpritePFXManager

Class TgxCustomSpritePFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxCustomSpritePFXManager = class(TgxBaseSpritePFXManager)

Description

A sprite-based particles FX managers using user-specified code to prepare the texture .

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxBaseSpritePFXManager
  • TgxCustomSpritePFXManager

Overview

Fields

Private FOnPrepareTextureImage: TPFXPrepareTextureImageEvent;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;
Published | property ParticleSize;
Published | property SpritesPerTexture default sptOne;

Description

Fields

Private FOnPrepareTextureImage: TPFXPrepareTextureImageEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;

Place your texture rendering code in this event.

Published property ParticleSize;

This item has no description.

Published property SpritesPerTexture default sptOne;


GXSysHelp v.2.5: GXS.ParticleFX: Class TgxPointLightPFXManager

Class TgxPointLightPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ParticleFX

Declaration

type TgxPointLightPFXManager = class(TgxBaseSpritePFXManager)

Description

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TgxPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxBaseSpritePFXManager
  • TgxPointLightPFXManager

Overview

Fields

Private FTexMapSize: Integer;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property ParticleSize;
Published | property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Description

Fields

Private FTexMapSize: Integer;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property LifeColors;

This item has no description.

Published property ParticleSize;

This item has no description.

Published property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Underlying texture map size, as a power of two. Min value is 3 (size=8), max value is 9 (size=512).


GXSysHelp v.2.5: GXS.Particles

Unit GXS.Particles

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Context
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxParticles |

Types

TgxParticleEvent = procedure(Sender: TObject; particle: TgxBaseSceneObject) of object;

Description

Types

TgxParticleEvent = procedure(Sender: TObject; particle: TgxBaseSceneObject) of object;


GXSysHelp v.2.5: GXS.Particles: Class TgxParticles

Class TgxParticles

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Particles

Declaration

type TgxParticles = class(TgxImmaterialSceneObject)

Description

Manager object of a particle system. Particles in a TgxParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TgxParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TgxParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GXS.ParticleFX instead, TgxParticles being rather focused on complex particles.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxParticles

Overview

Fields

Private | FCubeSize: Single;
Private | FEdgeColor: TgxColor;
Private | FVisibleAtRunTime: Boolean;
Private | particlePool: TList;
Private | FParticlePoolSize: Integer;
Private | FOnCreateParticle: TgxParticleEvent;
Private | FOnActivateParticle: TgxParticleEvent;
Private | FOnKillParticle: TgxParticleEvent;
Private | FOnDestroyParticle: TgxParticleEvent;
Private | FOnBeforeRenderParticles: TDirectRenderEvent;
Private | FOnAfterRenderParticles: TDirectRenderEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TgxBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure KillParticle(aParticle: TgxBaseSceneObject);
Public | procedure KillParticles;

Properties

Published | property CubeSize: Single read FCubeSize write SetCubeSize;
Published | property EdgeColor: TgxColor read FEdgeColor write SetEdgeColor;
Published | property OnActivateParticle: TgxParticleEvent read FOnActivateParticle write FOnActivateParticle;
Published | property OnAfterRenderParticles: TDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;
Published | property OnBeforeRenderParticles: TDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;
Published | property OnCreateParticle: TgxParticleEvent read FOnCreateParticle write FOnCreateParticle;
Published | property OnDestroyParticle: TgxParticleEvent read FOnDestroyParticle write FOnDestroyParticle;
Published | property OnKillParticle: TgxParticleEvent read FOnKillParticle write FOnKillParticle;
Published | property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Fields

Private FCubeSize: Single;

This item has no description.

Private FEdgeColor: TgxColor;

This item has no description.

Private FVisibleAtRunTime: Boolean;

This item has no description.

Private particlePool: TList;

This item has no description.

Private FParticlePoolSize: Integer;

This item has no description.

Private FOnCreateParticle: TgxParticleEvent;

This item has no description.

Private FOnActivateParticle: TgxParticleEvent;

This item has no description.

Private FOnKillParticle: TgxParticleEvent;

This item has no description.

Private FOnDestroyParticle: TgxParticleEvent;

This item has no description.

Private FOnBeforeRenderParticles: TDirectRenderEvent;

This item has no description.

Private FOnAfterRenderParticles: TDirectRenderEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateParticle: TgxBaseSceneObject;

Request creation of a new particle. Particle will be either created or retrieved from the particlePool.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var ARci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure KillParticle(aParticle: TgxBaseSceneObject);

Kill given particle. If particlePool is not full, particle will be sent to the pool, if not, it will be freed.

Public procedure KillParticles;

Kill all particles.

Properties

Published property CubeSize: Single read FCubeSize write SetCubeSize;

This item has no description.

Published property EdgeColor: TgxColor read FEdgeColor write SetEdgeColor;

This item has no description.

Published property OnActivateParticle: TgxParticleEvent read FOnActivateParticle write FOnActivateParticle;

Fired when a particle will get in the "live" list. The particle has just been "Assigned" with the template, may happen after a creation or a pick from the particle pool.

Published property OnAfterRenderParticles: TDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;

Fired after rendering the last of the particles.

Published property OnBeforeRenderParticles: TDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;

Fired before rendering the first of the particles.

Published property OnCreateParticle: TgxParticleEvent read FOnCreateParticle write FOnCreateParticle;

Fired a particle has been created as a template duplicate. When the event is triggered, the particle has yet been added to the scene.

Published property OnDestroyParticle: TgxParticleEvent read FOnDestroyParticle write FOnDestroyParticle;

Triggered just before destroying a particle. The particle can be in the pool (ie. not parented).

Published property OnKillParticle: TgxParticleEvent read FOnKillParticle write FOnKillParticle;

Triggered when a particle is killed. When the event is fired, the particle is still parented, after this event, the particle will either go to the pool or be destroyed if the pool is full.

Published property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;

Size of the particle pool (for storing killed particles). Default size is zero, meaning the particlePool is disabled.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;


GXSysHelp v.2.5: GXS.Perlin

Unit GXS.Perlin

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GXS.ImageUtils
  • GXS.HeightData

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBasePerlinOctav |
Class TgxBasePerlin |
Class Tgx1DPerlin |
Class Tgx2DPerlinOctav |
Class Tgx2DPerlin |
Class TgxPerlinHDS |
Class TgxPerlinHDSThread |

Functions and Procedures

function Linear_Interpolate(const a, b, x: Double): Double;
function Cubic_Interpolate(v0, v1, v2, v3, x: Double): Double;
function Cosine_Interpolate(const a, b, x: Double): Double;
function Perlin_Random1(x: Integer): Double;
function Perlin_Random2(Const x, Y: Integer): Double;
procedure Perlin_Random1DStrip(x, Width, Step: Integer; Amp: Double; Res: T1DPerlinArray);
procedure Cubic_Interpolate_Strip(B1, B2, B3, B4, Res: T1DPerlinArray; Width: Integer);
procedure Smooth_Interpolate_Strip(B1, B2, B3, Res: T1DPerlinArray; Width: Integer);
function ExponateCrap(root, exponant: Integer): Integer;

Types

T1DPerlinArray = array of Double;
T2DPerlinArray = array of T1DPerlinArray;
TgxPerlinInterpolation = (...);
TgxPerlinOctav = class of TgxBasePerlinOctav;

Description

Functions and Procedures

function Linear_Interpolate(const a, b, x: Double): Double;

Useless for final output! Usefull for after interpolation, as its FAST!

function Cubic_Interpolate(v0, v1, v2, v3, x: Double): Double;

does a cubic interpolation

function Cosine_Interpolate(const a, b, x: Double): Double;

does a cosine interpolation

function Perlin_Random1(x: Integer): Double;

just a random controlled by X

function Perlin_Random2(Const x, Y: Integer): Double;

just a random controlled by X,Y

procedure Perlin_Random1DStrip(x, Width, Step: Integer; Amp: Double; Res: T1DPerlinArray);

generates a random strip

procedure Cubic_Interpolate_Strip(B1, B2, B3, B4, Res: T1DPerlinArray; Width: Integer);

cubic interpolate 4 strips into one...

procedure Smooth_Interpolate_Strip(B1, B2, B3, Res: T1DPerlinArray; Width: Integer);

smooth interpolate 3 strips into one...

function ExponateCrap(root, exponant: Integer): Integer;

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.

Types

T1DPerlinArray = array of Double;

This item has no description.

T2DPerlinArray = array of T1DPerlinArray;

This item has no description.

TgxPerlinInterpolation = (...);

This item has no description.

Values
  • pi_none
  • pi_simple
  • pi_linear
  • pi_Smoothed
  • pi_Cosine
  • pi_cubic
TgxPerlinOctav = class of TgxBasePerlinOctav;


GXSysHelp v.2.5: GXS.Perlin: Class TgxBasePerlinOctav

Class TgxBasePerlinOctav

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type TgxBasePerlinOctav = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxBasePerlinOctav

Overview

Fields

Private | FAmplitude: Double;
Private | FScale: Double;
Private | FInterpolation: TgxPerlinInterpolation;
Private | FSmoothing: TgxPerlinInterpolation;

Methods

Public procedure Generate; virtual; abstract;

Properties

Public | property Amplitude: Double read FAmplitude write FAmplitude;
Public | property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Scale: Double read FScale write FScale;
Public | property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;

Description

Fields

Private FAmplitude: Double;

This item has no description.

Private FScale: Double;

This item has no description.

Private FInterpolation: TgxPerlinInterpolation;

This item has no description.

Private FSmoothing: TgxPerlinInterpolation;

This item has no description.

Methods

Public procedure Generate; virtual; abstract;

This item has no description.

Properties

Public property Amplitude: Double read FAmplitude write FAmplitude;

This item has no description.

Public property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Public property Scale: Double read FScale write FScale;

This item has no description.

Public property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;


GXSysHelp v.2.5: GXS.Perlin: Class TgxBasePerlin

Class TgxBasePerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type TgxBasePerlin = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxBasePerlin

Overview

Fields

Private | FPersistence: Double;
Private | FNumber_Of_Octaves: Integer;
Private | FOctaves: TList;
Private | FOctavClass: TgxPerlinOctav;
Private | FInterpolation: TgxPerlinInterpolation;
Private | FSmoothing: TgxPerlinInterpolation;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | Procedure Generate; virtual; abstract;

Properties

Published | property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;
Public | property Octaves[index: Integer]: TgxBasePerlinOctav read GetOctave;
Published | property Persistence: Double read FPersistence write SetPersistence;
Published | property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;

Description

Fields

Private FPersistence: Double;

This item has no description.

Private FNumber_Of_Octaves: Integer;

This item has no description.

Private FOctaves: TList;

This item has no description.

Private FOctavClass: TgxPerlinOctav;

This item has no description.

Private FInterpolation: TgxPerlinInterpolation;

This item has no description.

Private FSmoothing: TgxPerlinInterpolation;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public Procedure Generate; virtual; abstract;

This item has no description.

Properties

Published property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;

This item has no description.

Public property Octaves[index: Integer]: TgxBasePerlinOctav read GetOctave;

This item has no description.

Published property Persistence: Double read FPersistence write SetPersistence;

This item has no description.

Published property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;


GXSysHelp v.2.5: GXS.Perlin: Class Tgx1DPerlin

Class Tgx1DPerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type Tgx1DPerlin = class(TgxBasePerlin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxBasePerlin
  • Tgx1DPerlin

Overview

Methods

Public function GetPerlinValue_1D(x: Double): Double;

Description

Methods

Public function GetPerlinValue_1D(x: Double): Double;


GXSysHelp v.2.5: GXS.Perlin: Class Tgx2DPerlinOctav

Class Tgx2DPerlinOctav

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type Tgx2DPerlinOctav = class(TgxBasePerlinOctav)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxBasePerlinOctav
  • Tgx2DPerlinOctav

Overview

Fields

Public | Data: T2DPerlinArray;
Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | YRate: Integer;

Methods

Public | function GetCosine(x, y: Double): Double;
Public | function GetCubic(x, y: Double): Double;
Public | function GetData(x, y: Integer): Double;
Public | function GetDataSmoothed(x, y: Integer): Double;
Public | function GetPerling(x, y: Double): Double;
Public | procedure Generate; override;
Public | procedure Generate_CubicInterpolate;
Public | procedure Generate_NonInterpolated;
Public | procedure Generate_SmoothInterpolate;

Description

Fields

Public Data: T2DPerlinArray;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public XStart: Integer;

This item has no description.

Public YStart: Integer;

This item has no description.

Public XStep: Integer;

This item has no description.

Public YStep: Integer;

This item has no description.

Public YRate: Integer;

This item has no description.

Methods

Public function GetCosine(x, y: Double): Double;

This item has no description.

Public function GetCubic(x, y: Double): Double;

This item has no description.

Public function GetData(x, y: Integer): Double;

This item has no description.

Public function GetDataSmoothed(x, y: Integer): Double;

This item has no description.

Public function GetPerling(x, y: Double): Double;

This item has no description.

Public procedure Generate; override;

This item has no description.

Public procedure Generate_CubicInterpolate;

This item has no description.

Public procedure Generate_NonInterpolated;

This item has no description.

Public procedure Generate_SmoothInterpolate;


GXSysHelp v.2.5: GXS.Perlin: Class Tgx2DPerlin

Class Tgx2DPerlin

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type Tgx2DPerlin = class(TgxBasePerlin)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxBasePerlin
  • Tgx2DPerlin

Overview

Fields

Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | MaxValue: Double;
Public | MinValue: Double;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | Function GetPerlinValue_2D(x, y: Double): Double;
Public | Procedure Generate; override;
Public | Procedure MakeBitmap(Param: TBitmap);
Public | Procedure SetHeightData(heightData: TgxHeightData);

Description

Fields

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public XStart: Integer;

This item has no description.

Public YStart: Integer;

This item has no description.

Public XStep: Integer;

This item has no description.

Public YStep: Integer;

This item has no description.

Public MaxValue: Double;

This item has no description.

Public MinValue: Double;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public Function GetPerlinValue_2D(x, y: Double): Double;

This item has no description.

Public Procedure Generate; override;

This item has no description.

Public Procedure MakeBitmap(Param: TBitmap);

This item has no description.

Public Procedure SetHeightData(heightData: TgxHeightData);


GXSysHelp v.2.5: GXS.Perlin: Class TgxPerlinHDS

Class TgxPerlinHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type TgxPerlinHDS = class(TgxHeightDataSource)

Description

This item has no description. Showing description inherited from TgxHeightDataSource.

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TgxHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TgxHeightData with its "Release" method) Pre-loading : specify a list of TgxHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxPerlinHDS

Overview

Fields

Private | FInterpolation: TgxPerlinInterpolation;
Private | FSmoothing: TgxPerlinInterpolation;
Private | FPersistence: Double;
Private | FNumber_Of_Octaves: Integer;
Private | FLines: TStrings;
Private | FLinesChanged: Boolean;
Private | FXStart: Integer;
Private | FYStart: Integer;
Public | MaxValue: Double;
Public | MinValue: Double;
Public | Stall: Boolean;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | procedure StartPreparingData(heightData: TgxHeightData); override;
Public | procedure WaitFor;

Properties

Published | property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Lines: TStrings read FLines;
Public | property LinesChanged: Boolean read FLinesChanged write FLinesChanged;
Published | property MaxPoolSize;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;
Published | property Persistence: Double read FPersistence write FPersistence;
Published | property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;
Published | property XStart: Integer read FXStart write FXStart;
Published | property YStart: Integer read FYStart write FYStart;

Description

Fields

Private FInterpolation: TgxPerlinInterpolation;

This item has no description.

Private FSmoothing: TgxPerlinInterpolation;

This item has no description.

Private FPersistence: Double;

This item has no description.

Private FNumber_Of_Octaves: Integer;

This item has no description.

Private FLines: TStrings;

This item has no description.

Private FLinesChanged: Boolean;

This item has no description.

Private FXStart: Integer;

This item has no description.

Private FYStart: Integer;

This item has no description.

Public MaxValue: Double;

This item has no description.

Public MinValue: Double;

This item has no description.

Public Stall: Boolean;

This item has no description.

Methods

Public Constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure StartPreparingData(heightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure WaitFor;

This item has no description.

Properties

Published property Interpolation: TgxPerlinInterpolation read FInterpolation write FInterpolation;

This item has no description.

Public property Lines: TStrings read FLines;

This item has no description.

Public property LinesChanged: Boolean read FLinesChanged write FLinesChanged;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;

This item has no description.

Published property Persistence: Double read FPersistence write FPersistence;

This item has no description.

Published property Smoothing: TgxPerlinInterpolation read FSmoothing write FSmoothing;

This item has no description.

Published property XStart: Integer read FXStart write FXStart;

This item has no description.

Published property YStart: Integer read FYStart write FYStart;


GXSysHelp v.2.5: GXS.Perlin: Class TgxPerlinHDSThread

Class TgxPerlinHDSThread

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Perlin

Declaration

type TgxPerlinHDSThread = class(TgxHeightDataThread)

Description

This item has no description. Showing description inherited from TgxHeightDataThread.

A thread specialized for processing TgxHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

Hierarchy

  • TObject
  • TThread
  • TgxHeightDataThread
  • TgxPerlinHDSThread

Overview

Fields

Public | Perlin: Tgx2DPerlin;
Public | PerlinSource: TgxPerlinHDS;

Methods

Public | Procedure Execute; override;
Public | Procedure OpdateOutSide;

Description

Fields

Public Perlin: Tgx2DPerlin;

This item has no description.

Public PerlinSource: TgxPerlinHDS;

This item has no description.

Methods

Public Procedure Execute; override;

This item has no description.

Public Procedure OpdateOutSide;


GXSysHelp v.2.5: GXS.PerlinPFX

Unit GXS.PerlinPFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.ParticleFX
  • GXS.Graphics

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPerlinPFXManager |
Class TgxPerlin3DNoise |

Constants

cPERLIN_TABLE_SIZE = 256;

Description

Constants

cPERLIN_TABLE_SIZE = 256;


GXSysHelp v.2.5: GXS.PerlinPFX: Class TgxPerlinPFXManager

Class TgxPerlinPFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PerlinPFX

Declaration

type TgxPerlinPFXManager = class(TgxBaseSpritePFXManager)

Description

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomCadencedComponent
  • TgxCadencedComponent
  • TgxParticleFXManager
  • TgxDynamicPFXManager
  • TgxLifeColoredPFXManager
  • TgxBaseSpritePFXManager
  • TgxPerlinPFXManager

Overview

Fields

Private | FTexMapSize: Integer;
Private | FNoiseSeed: Integer;
Private | FNoiseScale: Integer;
Private | FNoiseAmplitude: Integer;
Private | FSmoothness: Single;
Private | FBrightness: Single;
Private | FGamma: Single;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Brightness: Single read FBrightness write SetBrightness;
Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property Gamma: Single read FGamma write SetGamma;
Published | property LifeColors;
Published | property NoiseAmplitude: Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;
Published | property NoiseScale: Integer read FNoiseScale write SetNoiseScale default 100;
Published | property NoiseSeed: Integer read FNoiseSeed write SetNoiseSeed default 0;
Published | property ParticleSize;
Published | property Smoothness: Single read FSmoothness write SetSmoothness;
Published | property SpritesPerTexture default sptFour;
Published | property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 6;

Description

Fields

Private FTexMapSize: Integer;

This item has no description.

Private FNoiseSeed: Integer;

This item has no description.

Private FNoiseScale: Integer;

This item has no description.

Private FNoiseAmplitude: Integer;

This item has no description.

Private FSmoothness: Single;

This item has no description.

Private FBrightness: Single;

This item has no description.

Private FGamma: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Brightness: Single read FBrightness write SetBrightness;

Brightness factor applied to the perlin texture intensity. Brightness acts as a scaling, non-saturating factor. Examples: Brightness = 1 : intensities in the [0; 1] range Brightness = 2 : intensities in the [0.5; 1] range Brightness = 0.5 : intensities in the [0; 0.5] range Brightness is applied to the final texture (and thus affects the distance based intensity).

Published property ColorInner;

This item has no description.

Published property ColorMode default scmInner;

This item has no description.

Published property ColorOuter;

This item has no description.

Published property Gamma: Single read FGamma write SetGamma;

This item has no description.

Published property LifeColors;

This item has no description.

Published property NoiseAmplitude: Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;

Amplitude applied to the perlin noise (intensity). This value represent the percentage of the sprite luminance affected by the perlin texture.

Published property NoiseScale: Integer read FNoiseScale write SetNoiseScale default 100;

Scale applied to the perlin noise (stretching).

Published property NoiseSeed: Integer read FNoiseSeed write SetNoiseSeed default 0;

Random seed to use for the perlin noise.

Published property ParticleSize;

This item has no description.

Published property Smoothness: Single read FSmoothness write SetSmoothness;

Smoothness of the distance-based intensity. This value is the exponent applied to the intensity in the texture, basically with a value of 1 (default) the intensity decreases linearly, with higher values, it will remain 'constant' in the center then fade-off more abruptly, and with values below 1, there will be a sharp spike in the center.

Published property SpritesPerTexture default sptFour;

This item has no description.

Published property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 6;

Underlying texture map size, as a power of two. Min value is 3 (size=8), max value is 9 (size=512).


GXSysHelp v.2.5: GXS.PerlinPFX: Class TgxPerlin3DNoise

Class TgxPerlin3DNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PerlinPFX

Declaration

type TgxPerlin3DNoise = class(TObject)

Description

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice

Hierarchy

  • TObject
  • TgxPerlin3DNoise

Overview

Methods

Public | constructor Create(randomSeed: Integer);
Public | function Noise(const v: TAffineVector): Single; overload;
Public | function Noise(const v: TVector4f): Single; overload;
Public | function Noise(const x, y, z: Single): Single; overload;
Public | function Noise(const x, y: Single): Single; overload;
Public | procedure Initialize(randomSeed: Integer);

Description

Methods

Public constructor Create(randomSeed: Integer);

This item has no description.

Public function Noise(const v: TAffineVector): Single; overload;

This item has no description.

Public function Noise(const v: TVector4f): Single; overload;

This item has no description.

Public function Noise(const x, y, z: Single): Single; overload;

This item has no description.

Public function Noise(const x, y: Single): Single; overload;

This item has no description.

Public procedure Initialize(randomSeed: Integer);


GXSysHelp v.2.5: GXS.PhysFields

Unit GXS.PhysFields

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorGeometry
  • GLScene.XCollection
  • GXS.Coordinates
  • GXS.Scene
  • GXS.Behaviours
  • GXS.PhysInertias
  • GXS.PhysManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLUniformGravityEmitter |
Class TGLRadialGravityEmitter |
Class TgxDampingFieldEmitter |

Constants

GravitationalConstant = 6.6726E-11;

Description

Constants

GravitationalConstant = 6.6726E-11;


GXSysHelp v.2.5: GXS.PhysFields: Class TGLUniformGravityEmitter

Class TGLUniformGravityEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysFields

Declaration

type TGLUniformGravityEmitter = class(TgxBaseForceFieldEmitter)

Description

GXS.RigidBodyInertia

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseForceFieldEmitter
  • TGLUniformGravityEmitter

Overview

Fields

Private fGravity: TgxCoordinates;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Gravity: TgxCoordinates read fGravity write SetGravity;

Description

Fields

Private fGravity: TgxCoordinates;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TgxBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Gravity: TgxCoordinates read fGravity write SetGravity;


GXSysHelp v.2.5: GXS.PhysFields: Class TGLRadialGravityEmitter

Class TGLRadialGravityEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysFields

Declaration

type TGLRadialGravityEmitter = class(TgxBaseForceFieldEmitter)

Description

This item has no description. Showing description inherited from TgxBaseForceFieldEmitter.

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseForceFieldEmitter
  • TGLRadialGravityEmitter

Overview

Fields

Private | fMass: Real;
Private | fMassOverG: Real;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Mass: Real read fMass write fMass;

Description

Fields

Private fMass: Real;

This item has no description.

Private fMassOverG: Real;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TgxBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Mass: Real read fMass write fMass;


GXSysHelp v.2.5: GXS.PhysFields: Class TgxDampingFieldEmitter

Class TgxDampingFieldEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysFields

Declaration

type TgxDampingFieldEmitter = class(TgxBaseForceFieldEmitter)

Description

This item has no description. Showing description inherited from TgxBaseForceFieldEmitter.

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseForceFieldEmitter
  • TgxDampingFieldEmitter

Overview

Fields

Private fDamping: TgxDamping;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Damping: TgxDamping read fDamping write SetDamping;

Description

Fields

Private fDamping: TgxDamping;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TgxBaseForceFieldEmitter.Destroy.

abstract;

Public function CalculateForceField(Body: TgxBaseSceneObject) : TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Damping: TgxDamping read fDamping write SetDamping;


GXSysHelp v.2.5: GXS.PhysForces

Unit GXS.PhysForces

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.VectorTypes
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GXS.Coordinates
  • GLScene.Strings
  • GXS.Scene
  • GXS.Behaviours

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxForce |
Class TgxHookesSpring |
Class TgxHookesString |

Types

TgxForceType = (...);
TOnCustomForce = procedure() of object;

Description

Types

TgxForceType = (...);

This item has no description.

Values
  • ftHookes
  • ftGravitation
  • ftCustom
TOnCustomForce = procedure() of object;


GXSysHelp v.2.5: GXS.PhysForces: Class TgxForce

Class TgxForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysForces

Declaration

type TgxForce = class(TXCollectionItem)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxForce

Overview

Fields

Private | fObject1: TgxBaseSceneObject;
Private | fObject2: TgxBaseSceneObject;
Private | fposition1: TgxCoordinates;
Private | fposition2: TgxCoordinates;
Private | object1Name: String;
Private | object2Name: String;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; virtual;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure SetObject1(const val: TgxBaseSceneObject);
Public | procedure SetObject2(const val: TgxBaseSceneObject);
Public | procedure SetPosition1(const val: TgxCoordinates);
Public | procedure SetPosition2(const val: TgxCoordinates);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Object1: TgxBaseSceneObject read fObject1 write SetObject1;
Published | property Object2: TgxBaseSceneObject read fObject2 write SetObject2;
Published | property Position1: TgxCoordinates read fposition1 write SetPosition1;
Published | property Position2: TgxCoordinates read fposition2 write SetPosition2;

Description

Fields

Private fObject1: TgxBaseSceneObject;

This item has no description.

Private fObject2: TgxBaseSceneObject;

This item has no description.

Private fposition1: TgxCoordinates;

This item has no description.

Private fposition2: TgxCoordinates;

This item has no description.

Private object1Name: String;

This item has no description.

Private object2Name: String;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; virtual;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ReadFromFiler(reader: TReader); override;

Override this function to read subclass data.

Public procedure SetObject1(const val: TgxBaseSceneObject);

This item has no description.

Public procedure SetObject2(const val: TgxBaseSceneObject);

This item has no description.

Public procedure SetPosition1(const val: TgxCoordinates);

This item has no description.

Public procedure SetPosition2(const val: TgxCoordinates);

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

Override this function to write subclass data.

Properties

Published property Object1: TgxBaseSceneObject read fObject1 write SetObject1;

This item has no description.

Published property Object2: TgxBaseSceneObject read fObject2 write SetObject2;

This item has no description.

Published property Position1: TgxCoordinates read fposition1 write SetPosition1;

This item has no description.

Published property Position2: TgxCoordinates read fposition2 write SetPosition2;


GXSysHelp v.2.5: GXS.PhysForces: Class TgxHookesSpring

Class TgxHookesSpring

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysForces

Declaration

type TgxHookesSpring = class(TgxForce)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxForce
  • TgxHookesSpring

Overview

Fields

Private | fNaturalLength: Real;
Private | fElasticity: Real;
Private | fLength: Real;
Private | fExtension: Real;
Private | fDamping: TgxDamping;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure SetDamping(const val: TgxDamping);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Damping: TgxDamping read fDamping write SetDamping;
Published | property Elasticity: Real read fElasticity write fElasticity;
Published | property NaturalLength: Real read fNaturalLength write fNaturalLength;

Description

Fields

Private fNaturalLength: Real;

This item has no description.

Private fElasticity: Real;

This item has no description.

Private fLength: Real;

This item has no description.

Private fExtension: Real;

This item has no description.

Private fDamping: TgxDamping;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description. Showing description inherited from TgxForce.ReadFromFiler.

Override this function to read subclass data.

Public procedure SetDamping(const val: TgxDamping);

This item has no description.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description. Showing description inherited from TgxForce.WriteToFiler.

Override this function to write subclass data.

Properties

Published property Damping: TgxDamping read fDamping write SetDamping;

This item has no description.

Published property Elasticity: Real read fElasticity write fElasticity;

This item has no description.

Published property NaturalLength: Real read fNaturalLength write fNaturalLength;


GXSysHelp v.2.5: GXS.PhysForces: Class TgxHookesString

Class TgxHookesString

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysForces

Declaration

type TgxHookesString = class(TgxHookesSpring)

Description

This item has no description. Showing description inherited from TXCollectionItem.

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxForce
  • TgxHookesSpring
  • TgxHookesString

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForce(): TAffineVector; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;

procedure WriteToFiler(writer : TWriter); override; procedure ReadFromFiler(reader : TReader); override;

Public destructor Destroy; override;

This item has no description.

Public function CalculateForce(): TAffineVector; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.


GXSysHelp v.2.5: GXS.Physics.Register

Unit GXS.Physics.Register

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.ODEManager
  • GXS.NGDManager

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;

GXS.PhysManager todo


GXSysHelp v.2.5: GXS.PhysInertias

Unit GXS.PhysInertias

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.SysUtils
  • System.Classes
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Coordinates
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GXS.PhysManager
  • GXS.Scene
  • GXS.Behaviours

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxParticleInertia |
Class TgxInertiaTensor |
Class TgxRigidBodyInertia |

Functions and Procedures

function GetOrCreateParticleInertia(behaviours: TgxBehaviours): TgxParticleInertia; overload;
function GetOrCreateParticleInertia(obj: TgxBaseSceneObject): TgxParticleInertia; overload;
function GetOrCreateRigidBodyInertia(behaviours: TgxBehaviours): TgxRigidBodyInertia; overload;
function GetOrCreateRigidBodyInertia(obj: TgxBaseSceneObject): TgxRigidBodyInertia; overload;

Constants

DebugMode = false;

Description

Functions and Procedures

function GetOrCreateParticleInertia(behaviours: TgxBehaviours): TgxParticleInertia; overload;

Returns or creates the TgxParticleInertia within the given behaviours. This helper function is convenient way to access a TgxParticleInertia.

function GetOrCreateParticleInertia(obj: TgxBaseSceneObject): TgxParticleInertia; overload;

Returns or creates the TgxParticleInertia within the given object's behaviours. This helper function is convenient way to access a TgxParticleInertia.

function GetOrCreateRigidBodyInertia(behaviours: TgxBehaviours): TgxRigidBodyInertia; overload;

Returns or creates the TgxRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.

function GetOrCreateRigidBodyInertia(obj: TgxBaseSceneObject): TgxRigidBodyInertia; overload;

Returns or creates the TgxRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.

Constants

DebugMode = false;


GXSysHelp v.2.5: GXS.PhysInertias: Class TgxParticleInertia

Class TgxParticleInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysInertias

Declaration

type TgxParticleInertia = class(TgxBaseInertia)

Description

This item has no description. Showing description inherited from TgxBaseInertia.

purpose of TgxBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TgxParticleInertia (for a 3D particle) TgxRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. Tgx1DParticleInertia, this will allow for faster speed

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseInertia
  • TgxParticleInertia

Overview

Fields

Private | FMass: Single;
Private | FTranslationSpeed: TgxCoordinates;
Private | FTranslationDamping: TgxDamping;
Public | fForce: TAffineVector;
Public | LinearPosition: TAffineVector;
Public | LinearMomentum: TAffineVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real; override;
Public | function CalculatePE(): Real; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure ApplyDamping(damping: TgxDamping); virtual;
Public | procedure ApplyForce(x, y, z: Real); overload; virtual;
Public | procedure ApplyForce(Force: TAffineVector); overload; virtual;
Public | procedure ApplyForce(pos, Force: TAffineVector); overload; virtual;
Public | procedure ApplyImpulse(j: Single; normal: TAffineVector); overload; virtual;
Public | procedure ApplyImpulse(j, x, y, z: Real); overload; virtual;
Public | procedure ApplyLocalForce(pos, Force: TAffineVector); virtual;
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); override;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure CalculateForceFieldForce(ForceFieldEmitter : TgxBaseForceFieldEmitter); override;
Public | procedure MirrorTranslation;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure RemoveForces(); override;
Public | procedure SetForce(x, y, z: Real); virtual;
Public | procedure SetUpStartingState(); override;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: Single);
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Mass: Single read FMass write FMass;
Published | property TranslationDamping: TgxDamping read FTranslationDamping write SetTranslationDamping;
Published | property TranslationSpeed: TgxCoordinates read FTranslationSpeed write SetTranslationSpeed;

Description

Fields

Private FMass: Single;

modified from TgxBInertia

Private FTranslationSpeed: TgxCoordinates;

This item has no description.

Private FTranslationDamping: TgxDamping;

This item has no description.

Public fForce: TAffineVector;

This item has no description.

Public LinearPosition: TAffineVector;

This item has no description.

Public LinearMomentum: TAffineVector;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TgxBaseInertia.Destroy.

abstract;

Public function CalculateKE(): Real; override;

This item has no description.

Public function CalculatePE(): Real; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyDamping(damping: TgxDamping); virtual;

This item has no description.

Public procedure ApplyForce(x, y, z: Real); overload; virtual;

This item has no description.

Public procedure ApplyForce(Force: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyForce(pos, Force: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyImpulse(j: Single; normal: TAffineVector); overload; virtual;

This item has no description.

Public procedure ApplyImpulse(j, x, y, z: Real); overload; virtual;

This item has no description.

Public procedure ApplyLocalForce(pos, Force: TAffineVector); virtual;

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); override;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure CalculateForceFieldForce(ForceFieldEmitter : TgxBaseForceFieldEmitter); override;

This item has no description.

Public procedure MirrorTranslation;

Inverts the translation vector

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure RemoveForces(); override;

This item has no description.

Public procedure SetForce(x, y, z: Real); virtual;

This item has no description.

Public procedure SetUpStartingState(); override;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description. Showing description inherited from TgxBaseInertia.StateToArray.

don't re-declare this in sub-classes just initialise it in constructor

Public procedure SurfaceBounce(const surfaceNormal: TGLVector; restitution: Single);

Bounce speed as if hitting a surface. restitution is the coefficient of restituted energy (1=no energy loss, 0=no bounce). The normal is NOT assumed to be normalized.

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Mass: Single read FMass write FMass;

This item has no description.

Published property TranslationDamping: TgxDamping read FTranslationDamping write SetTranslationDamping;

Damping applied to translation speed.<br> Note that it is not "exactly" applied, ie. if damping would stop your object after 0.5 time unit, and your progression steps are of 1 time unit, there will be an integration error of 0.5 time unit.

Published property TranslationSpeed: TgxCoordinates read FTranslationSpeed write SetTranslationSpeed;


GXSysHelp v.2.5: GXS.PhysInertias: Class TgxInertiaTensor

Class TgxInertiaTensor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysInertias

Declaration

type TgxInertiaTensor = class(TgxUpdateAbleObject)

Description

Stores Inertia Tensor for TgxRigidBodyInertia model

Hierarchy

  • TgxUpdateAbleObject
  • TgxInertiaTensor

Overview

Fields

Private | fm11: Single;
Private | fm12: Single;
Private | fm13: Single;
Private | fm21: Single;
Private | fm22: Single;
Private | fm23: Single;
Private | fm31: Single;
Private | fm32: Single;
Private | fm33: Single;

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader);
Public | procedure WriteToFiler(writer: TWriter);

Properties

Published | property m11: Single read fm11 write fm11;
Published | property m12: Single read fm12 write fm12;
Published | property m13: Single read fm13 write fm13;
Published | property m21: Single read fm21 write fm21;
Published | property m22: Single read fm22 write fm22;
Published | property m23: Single read fm23 write fm23;
Published | property m31: Single read fm31 write fm31;
Published | property m32: Single read fm32 write fm32;
Published | property m33: Single read fm33 write fm33;

Description

Fields

Private fm11: Single;

This item has no description.

Private fm12: Single;

This item has no description.

Private fm13: Single;

This item has no description.

Private fm21: Single;

This item has no description.

Private fm22: Single;

This item has no description.

Private fm23: Single;

This item has no description.

Private fm31: Single;

This item has no description.

Private fm32: Single;

This item has no description.

Private fm33: Single;

This item has no description.

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader);

This item has no description.

Public procedure WriteToFiler(writer: TWriter);

This item has no description.

Properties

Published property m11: Single read fm11 write fm11;

This item has no description.

Published property m12: Single read fm12 write fm12;

This item has no description.

Published property m13: Single read fm13 write fm13;

This item has no description.

Published property m21: Single read fm21 write fm21;

This item has no description.

Published property m22: Single read fm22 write fm22;

This item has no description.

Published property m23: Single read fm23 write fm23;

This item has no description.

Published property m31: Single read fm31 write fm31;

This item has no description.

Published property m32: Single read fm32 write fm32;

This item has no description.

Published property m33: Single read fm33 write fm33;


GXSysHelp v.2.5: GXS.PhysInertias: Class TgxRigidBodyInertia

Class TgxRigidBodyInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysInertias

Declaration

type TgxRigidBodyInertia = class(TgxParticleInertia)

Description

A more complex model than TgxBInertia for Inertia

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseInertia
  • TgxParticleInertia
  • TgxRigidBodyInertia

Overview

Fields

Private | fDensity: Real;
Private | fBodyInertiaTensor: TAffineMAtrix;
Private | fBodyInverseInertiaTensor: TAffineMAtrix;
Private | fInertiaTensor: TgxInertiaTensor;
Private | InverseInertiaTensor: TAffineMAtrix;
Private | fRotationSpeed: TgxCoordinates;
Private | FRotationDamping: TgxDamping;
Public | AngularOrientation: TQuaternion;
Public | R: TMatrix3f;
Public | AngularMomentum: TAffineVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalcAngularOrientationDot(): TQuaternion;
Public | function CalcAngularVelocityDot(): TAffineVector;
Public | function CalculateKE(): Real; override;
Public | function CalculatePE(): Real; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | function QuaternionToString(Quat: TQuaternion): String;
Public | class function UniqueItem: Boolean; override;
Public | procedure ApplyDamping(damping: TgxDamping); override;
Public | procedure ApplyForce(pos, Force: TAffineVector); override;
Public | procedure ApplyImpulse(j: Single; position, normal: TAffineVector); overload;
Public | procedure ApplyImpulse(j, xpos, ypos, zpos, x, y, z: Real); overload;
Public | procedure ApplyLocalForce(pos, Force: TVector3f); override;
Public | procedure ApplyLocalImpulse(xpos, ypos, zpos, x, y, z: Real);
Public | procedure ApplyTorque(x, y, z: Real);
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); override;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure ReadFromFiler(reader: TReader); override;
Public | procedure RemoveForces(); override;
Public | procedure SetInertiaTensor(newVal: TgxInertiaTensor);
Public | procedure SetRotationDamping(const val: TgxDamping);
Public | procedure SetRotationSpeed(const val: TgxCoordinates);
Public | procedure SetTorque(x, y, z: Real);
Public | procedure SetUpStartingState(); override;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;
Public | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Density: Real read fDensity write fDensity;
Published | property InertiaTensor: TgxInertiaTensor read fInertiaTensor write SetInertiaTensor;
Published | property RotationDamping: TgxDamping read FRotationDamping write SetRotationDamping;
Published | property RotationSpeed: TgxCoordinates read fRotationSpeed write SetRotationSpeed;

Description

Fields

Private fDensity: Real;

This item has no description.

Private fBodyInertiaTensor: TAffineMAtrix;

This item has no description.

Private fBodyInverseInertiaTensor: TAffineMAtrix;

This item has no description.

Private fInertiaTensor: TgxInertiaTensor;

This item has no description.

Private InverseInertiaTensor: TAffineMAtrix;

This item has no description.

Private fRotationSpeed: TgxCoordinates;

LinearVelocity:TAffineVector;

Private FRotationDamping: TgxDamping;

AngularVelocity:TAffineVector; //rotation about axis, magnitude=speed damping properties

Public AngularOrientation: TQuaternion;

This item has no description.

Public R: TMatrix3f;

As Quat will help improve accuracy

Public AngularMomentum: TAffineVector;

corresponds to AngularOrientation

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description. Showing description inherited from TgxBaseInertia.Destroy.

abstract;

Public function CalcAngularOrientationDot(): TQuaternion;

function CalcLinearPositionDot():TAffineVector; function CalcLinearMomentumDot():TAffineVector;

Public function CalcAngularVelocityDot(): TAffineVector;

This item has no description.

Public function CalculateKE(): Real; override;

This item has no description.

Public function CalculatePE(): Real; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function QuaternionToString(Quat: TQuaternion): String;

function Star(Vector:TAffineVector):TGLMatrix;

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure ApplyDamping(damping: TgxDamping); override;

This item has no description.

Public procedure ApplyForce(pos, Force: TAffineVector); override;

This item has no description.

Public procedure ApplyImpulse(j: Single; position, normal: TAffineVector); overload;

This item has no description.

Public procedure ApplyImpulse(j, xpos, ypos, zpos, x, y, z: Real); overload;

This item has no description.

Public procedure ApplyLocalForce(pos, Force: TVector3f); override;

This item has no description.

Public procedure ApplyLocalImpulse(xpos, ypos, zpos, x, y, z: Real);

This item has no description.

Public procedure ApplyTorque(x, y, z: Real);

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); override;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description.

Public procedure ReadFromFiler(reader: TReader); override;

This item has no description.

Public procedure RemoveForces(); override;

This item has no description.

Public procedure SetInertiaTensor(newVal: TgxInertiaTensor);

This item has no description.

Public procedure SetRotationDamping(const val: TgxDamping);

This item has no description.

Public procedure SetRotationSpeed(const val: TgxCoordinates);

This item has no description.

Public procedure SetTorque(x, y, z: Real);

This item has no description.

Public procedure SetUpStartingState(); override;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); override;

This item has no description. Showing description inherited from TgxBaseInertia.StateToArray.

don't re-declare this in sub-classes just initialise it in constructor

Public procedure WriteToFiler(writer: TWriter); override;

This item has no description.

Properties

Published property Density: Real read fDensity write fDensity;

This item has no description.

Published property InertiaTensor: TgxInertiaTensor read fInertiaTensor write SetInertiaTensor;

This item has no description.

Published property RotationDamping: TgxDamping read FRotationDamping write SetRotationDamping;

This item has no description.

Published property RotationSpeed: TgxCoordinates read fRotationSpeed write SetRotationSpeed;


GXSysHelp v.2.5: GXS.PhysJoints

Unit GXS.PhysJoints

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • GXS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseJoint |
Class TGLBaseLink |
Class TGLJoint |
Class TGLLink |
Class TGLType1Link |
Class TGLType2Link |
Class TGLType3Link |
Class TGLType4Link |
Class TGLType5Link |
Class TGLType6Link |
Class TGLType7Link |
Class TGLType8Link |
Class TGLPrismaticJoint |
Class TGLRevoluteJoint |
Class TGLBallAndSocketJoint |


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLBaseJoint

Class TGLBaseJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLBaseJoint = class(TObject)

Description

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLBaseLink

Class TGLBaseLink

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLBaseLink = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGLBaseLink


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLJoint

Class TGLJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLJoint = class(TGLBaseJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint

Overview

Fields

Public | Link1: TGLBaseLink;
Public | Link2: TGLBaseLink;

Description

Fields

Public Link1: TGLBaseLink;

This item has no description.

Public Link2: TGLBaseLink;

if Link1 is nil, assumed to be base


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLLink

Class TGLLink

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLLink = class(TGLBaseLink)

Description

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink

Overview

Fields

Public | fLinkLength: Real;
Public | fTwistAngle: Real;
Public | fLinkAngle: Real;
Public | fLinkDistance: Real;
Public | A: TGLMatrix;

Methods

Public constructor Create(LinkLength, TwistAngle, LinkAngle, LinkDistance: Real);

Description

Fields

Public fLinkLength: Real;

Link Parameters

Public fTwistAngle: Real;

Length of common normal which is orthogonal to both joint axes Z[n-1] and Z[n] (a.k.a. L)

Public fLinkAngle: Real;

Twist angle between joint axes, if joint frames were coincident (a.k.a. Theta?)

Public fLinkDistance: Real;

Angle between common normals X[n-1] and X[n] (a.k.a. Alpha?)

Public A: TGLMatrix;

// // A-Matrix // [ Cos(Theta) -Sin(Theta)*Cos(Alpha) Sin(Theta)*Sin(Alpha) L*Cos(Theta) ] // [ Sin(Theta) Cos(Theta)*cos(Alpha) -Cos(Theta)*Sin(Alpha) L*Sin(Theta) ] // [ 0 Sin(Alpha) Cos(Alpha) d ] // [ 0 0 0 1 ] //

Methods

Public constructor Create(LinkLength, TwistAngle, LinkAngle, LinkDistance: Real);


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType1Link

Class TGLType1Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType1Link = class(TGLLink)

Description

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType1Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

// A-Matrix // [ C1 -S1 0 L1C1 ] // [ S1 C1 0 L1S1 ] // [ 0 0 1 0 ] // [ 0 0 0 1 ] //


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType2Link

Class TGLType2Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType2Link = class(TGLLink)

Description

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType2Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType3Link

Class TGLType3Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType3Link = class(TGLLink)

Description

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType3Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

// A-Matrix // [ 1 0 0 0 ] // [ 0 1 0 0 ] // [ 0 0 1 d2 ] // [ 0 0 0 1 ] //


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType4Link

Class TGLType4Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType4Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType4Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType5Link

Class TGLType5Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType5Link = class(TGLLink)

Description

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType5Link

Overview

Fields

Public Length: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType6Link

Class TGLType6Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType6Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType6Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType7Link

Class TGLType7Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType7Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType7Link

Overview

Fields

Public | Length: Real;
Public | Angle: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Public Angle: Real;

fixed

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLType8Link

Class TGLType8Link

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLType8Link = class(TGLLink)

Description

This item has no description. Showing description inherited from TGLLink.

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

Hierarchy

  • TObject
  • TGLBaseLink
  • TGLLink
  • TGLType8Link

Overview

Fields

Public Length: Real;

Methods

Public constructor Create(Length, Angle: Real);

Description

Fields

Public Length: Real;

This item has no description.

Methods

Public constructor Create(Length, Angle: Real);

variable


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLPrismaticJoint

Class TGLPrismaticJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLPrismaticJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLPrismaticJoint


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLRevoluteJoint

Class TGLRevoluteJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLRevoluteJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLRevoluteJoint


GXSysHelp v.2.5: GXS.PhysJoints: Class TGLBallAndSocketJoint

Class TGLBallAndSocketJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysJoints

Declaration

type TGLBallAndSocketJoint = class(TGLJoint)

Description

This item has no description. Showing description inherited from TGLBaseJoint.

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

Hierarchy

  • TObject
  • TGLBaseJoint
  • TGLJoint
  • TGLBallAndSocketJoint


GXSysHelp v.2.5: GXS.PhysManager

Unit GXS.PhysManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.PhysForces
  • GXS.Behaviours

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDESolver |
Class TDESolverExplicit |
Class TDESolverEuler |
Class TDESolverRungeKutta4 |
Class TDESolverImplicit |
Class TDESolverVerlet |
Class TgxBaseInertia |
Class TgxBaseForceFieldEmitter |
Class TgxPhysManager |
Class TgxForces |

Types

TDESolverType = (...);
TStateArray = array of Real;

Description

Types

TDESolverType = (...);

only ssEuler is usable at the moment

Values
  • ssEuler
  • ssRungeKutta4
  • ssVerlet
TStateArray = array of Real;

TDESolver = procedure((*RigidBody:TgxRigidBody;*)DeltaTime:Real) of object;


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolver

Class TDESolver

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolver = class(TObject)

Description

need to have state array(s) seperate from inertias to allow for implicit & explicit methods

Hierarchy

  • TObject
  • TDESolver

Overview

Fields

Public | StateSize: Integer;
Public | StateArray: TStateArray;
Public | Owner: TgxPhysManager;

Methods

Public | constructor Create(aOwner: TgxPhysManager);
Public | destructor Destroy; override;
Public | function StateToArray(): TStateArray; virtual;
Public | procedure ArrayToState(StateArray: TStateArray); virtual;
Public | procedure Solve(DeltaTime: Real); virtual; abstract;

Description

Fields

Public StateSize: Integer;

This item has no description.

Public StateArray: TStateArray;

This item has no description.

Public Owner: TgxPhysManager;

This item has no description.

Methods

Public constructor Create(aOwner: TgxPhysManager);

This item has no description.

Public destructor Destroy; override;

override; //abstract;

Public function StateToArray(): TStateArray; virtual;

This item has no description.

Public procedure ArrayToState(StateArray: TStateArray); virtual;

This item has no description.

Public procedure Solve(DeltaTime: Real); virtual; abstract;


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolverExplicit

Class TDESolverExplicit

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolverExplicit = class(TDESolver)

Description

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit

Overview

Fields

Public StateArrayDot: TStateArray;

Methods

Public function CalcStateDot(): TStateArray; virtual;

Description

Fields

Public StateArrayDot: TStateArray;

This item has no description.

Methods

Public function CalcStateDot(): TStateArray; virtual;

Velocity stored


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolverEuler

Class TDESolverEuler

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolverEuler = class(TDESolverExplicit)

Description

This item has no description. Showing description inherited from TDESolverExplicit.

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit
  • TDESolverEuler

Overview

Methods

Public procedure Solve(DeltaTime: Real); override;

Description

Methods

Public procedure Solve(DeltaTime: Real); override;


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolverRungeKutta4

Class TDESolverRungeKutta4

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolverRungeKutta4 = class(TDESolverExplicit)

Description

This item has no description. Showing description inherited from TDESolverExplicit.

explicit e.g. Euler, Mid-point, Runge-Kutta integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverExplicit
  • TDESolverRungeKutta4

Overview

Methods

Public procedure Solve(DeltaTime: Real); override;

Description

Methods

Public procedure Solve(DeltaTime: Real); override;


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolverImplicit

Class TDESolverImplicit

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolverImplicit = class(TDESolver)

Description

implicit e.g. Verlet Integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverImplicit

Overview

Fields

Public LastStateArray: TStateArray;

Description

Fields

Public LastStateArray: TStateArray;


GXSysHelp v.2.5: GXS.PhysManager: Class TDESolverVerlet

Class TDESolverVerlet

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TDESolverVerlet = class(TDESolverImplicit)

Description

This item has no description. Showing description inherited from TDESolverImplicit.

implicit e.g. Verlet Integration

Hierarchy

  • TObject
  • TDESolver
  • TDESolverImplicit
  • TDESolverVerlet


GXSysHelp v.2.5: GXS.PhysManager: Class TgxBaseInertia

Class TgxBaseInertia

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TgxBaseInertia = class(TgxBehaviour)

Description

purpose of TgxBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TgxParticleInertia (for a 3D particle) TgxRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. Tgx1DParticleInertia, this will allow for faster speed

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseInertia

Overview

Fields

Private | FDampingEnabled: Boolean;
Private | FManager: TgxPhysManager;
Private | FManagerName: String;
Public | StateSize: Integer;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real; virtual;
Public | function CalculatePE(): Real; virtual;
Public | procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalcAuxiliary(); virtual;
Public | procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); virtual;
Public | procedure CalculateForceFieldForce(ForceFieldEmitter : TgxBaseForceFieldEmitter); virtual;
Public | procedure RemoveForces(); virtual;
Public | procedure SetManager(const val: TgxPhysManager);
Public | procedure SetUpStartingState(); virtual;
Public | procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); virtual;

Properties

Published | property DampingEnabled: Boolean read FDampingEnabled write FDampingEnabled;
Published | property Manager: TgxPhysManager read FManager write SetManager;

Description

Fields

Private FDampingEnabled: Boolean;

This item has no description.

Private FManager: TgxPhysManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Public StateSize: Integer;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

abstract;

Public function CalculateKE(): Real; virtual;

This item has no description.

Public function CalculatePE(): Real; virtual;

This item has no description.

Public procedure ArrayToState( StateArray: TStateArray; StatePos: Integer); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure CalcAuxiliary(); virtual;

This item has no description.

Public procedure CalcStateDot(var StateArray: TStateArray; StatePos: Integer); virtual;

This item has no description.

Public procedure CalculateForceFieldForce(ForceFieldEmitter : TgxBaseForceFieldEmitter); virtual;

This item has no description.

Public procedure RemoveForces(); virtual;

This item has no description.

Public procedure SetManager(const val: TgxPhysManager);

This item has no description.

Public procedure SetUpStartingState(); virtual;

This item has no description.

Public procedure StateToArray(var StateArray: TStateArray; StatePos: Integer); virtual;

don't re-declare this in sub-classes just initialise it in constructor

Properties

Published property DampingEnabled: Boolean read FDampingEnabled write FDampingEnabled;

This item has no description.

Published property Manager: TgxPhysManager read FManager write SetManager;


GXSysHelp v.2.5: GXS.PhysManager: Class TgxBaseForceFieldEmitter

Class TgxBaseForceFieldEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TgxBaseForceFieldEmitter = class(TgxBehaviour)

Description

A base for different types of force-field behaviours

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBaseForceFieldEmitter

Overview

Fields

Private | FManager: TgxPhysManager;
Private | FManagerName: String;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function CalculateForceField(Body: TgxBaseSceneObject): TAffineVector; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetManager(const val: TgxPhysManager);

Properties

Published property Manager: TgxPhysManager read FManager write SetManager;

Description

Fields

Private FManager: TgxPhysManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

abstract;

Public function CalculateForceField(Body: TgxBaseSceneObject): TAffineVector; virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure SetManager(const val: TgxPhysManager);

This item has no description.

Properties

Published property Manager: TgxPhysManager read FManager write SetManager;


GXSysHelp v.2.5: GXS.PhysManager: Class TgxPhysManager

Class TgxPhysManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TgxPhysManager = class(TComponent)

Description

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxPhysManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CalculateKE(): Real;
Public | function CalculatePE(): Real;
Public | function FindForceFieldEmitterByName(Name: String): TgxBaseSceneObject;
Public | function FindObjectByName(Name: String): TgxBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalculateNextState(DeltaTime: Real);
Public | procedure DeRegisterAllForceFieldEmitters;
Public | procedure DeRegisterAllInertias;
Public | procedure DeRegisterForceFieldEmitter(aForceField: TgxBaseForceFieldEmitter);
Public | procedure DeRegisterInertia(aInertia: TgxBaseInertia);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RegisterForceFieldEmitter(aForceField: TgxBaseForceFieldEmitter);
Public | procedure RegisterInertia(aInertia: TgxBaseInertia);
Public | procedure SetDESolver(SolverType: TDESolverType);

Properties

Public | property ForceFieldEmitters: TList read fForceFieldEmitters write SetForceFieldEmitters;
Published | property Forces: TgxForces read GetForces write SetForces;
Public | property Inertias: TList read fInertias write SetInertias;
Published | property Scene: TgxScene read fScene write SetScene;
Published | property Solver: TDESolverType read fDESolverType write SetDESolver;

Description

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculateKE(): Real;

This item has no description.

Public function CalculatePE(): Real;

This item has no description.

Public function FindForceFieldEmitterByName(Name: String): TgxBaseSceneObject;

This item has no description.

Public function FindObjectByName(Name: String): TgxBaseSceneObject;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure CalculateNextState(DeltaTime: Real);

This item has no description.

Public procedure DeRegisterAllForceFieldEmitters;

This item has no description.

Public procedure DeRegisterAllInertias;

This item has no description.

Public procedure DeRegisterForceFieldEmitter(aForceField: TgxBaseForceFieldEmitter);

This item has no description.

Public procedure DeRegisterInertia(aInertia: TgxBaseInertia);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RegisterForceFieldEmitter(aForceField: TgxBaseForceFieldEmitter);

This item has no description.

Public procedure RegisterInertia(aInertia: TgxBaseInertia);

This item has no description.

Public procedure SetDESolver(SolverType: TDESolverType);

This item has no description.

Properties

Public property ForceFieldEmitters: TList read fForceFieldEmitters write SetForceFieldEmitters;

stored False;

Published property Forces: TgxForces read GetForces write SetForces;

stored False;

Public property Inertias: TList read fInertias write SetInertias;

This item has no description.

Published property Scene: TgxScene read fScene write SetScene;

This item has no description.

Published property Solver: TDESolverType read fDESolverType write SetDESolver;

stored False;


GXSysHelp v.2.5: GXS.PhysManager: Class TgxForces

Class TgxForces

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.PhysManager

Declaration

type TgxForces = class(TXCollection)

Description

This item has no description. Showing description inherited from TXCollection.

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxForces

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Properties

Public property Force[index: Integer]: TgxForce read GetForce;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

destructor Destroy;override;

Properties

Public property Force[index: Integer]: TgxForce read GetForce;


GXSysHelp v.2.5: GXS.PhysX

Unit GXS.PhysX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows

Overview

Functions and Procedures

procedure SDK_Version(major, minor, bugfix: pdword); stdcall; external DLL;
procedure InitNx; stdcall; external DLL;
procedure ReleaseNx; stdcall; external DLL;
procedure SimulateNx(dt: single); stdcall; external DLL;
procedure GetResultsNx; stdcall; external DLL;
procedure ActorCount(count: pdword); stdcall; external DLL;
procedure GetActor(index: dword; obj: pdword); stdcall; external DLL;
procedure GetActorGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external DLL;
procedure SetActorGlobalPosition(actor: dword; x,y,z: single); stdcall; external DLL;
procedure GetActorGlobalOrientation(actor: dword; x,y,z,w: psingle); stdcall; external DLL;
procedure SetActorGlobalOrientation(actor: dword; x,y,z,w: single); stdcall; external DLL;
procedure GetActorCMassGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external DLL;
procedure SetActorCMassGlobalPosition(actor: dword; x,y,z: single); stdcall; external DLL;
procedure GetActorMass(actor: dword; m: psingle); stdcall; external DLL;
procedure SetActorMass(actor: dword; m: single); stdcall; external DLL;
procedure ActorAddForce(actor: dword; x,y,z: single); stdcall; external DLL;
procedure CreateGroundPlane(actor: pdword); stdcall; external DLL;
procedure CreateBox(actor: pdword; sx,sy,sz,dens: single); stdcall; external DLL;
procedure CreateSphere(actor: pdword; rad: single; dens: single); stdcall; external DLL;
procedure CreateCylinder(actor: pdword; rad: single; height: single; dens: single); stdcall; external DLL;

Constants

DLL = 'PhysXwrap.dll';

Description

Functions and Procedures

procedure SDK_Version(major, minor, bugfix: pdword); stdcall; external DLL;

This item has no description.

procedure InitNx; stdcall; external DLL;

This item has no description.

procedure ReleaseNx; stdcall; external DLL;

This item has no description.

procedure SimulateNx(dt: single); stdcall; external DLL;

This item has no description.

procedure GetResultsNx; stdcall; external DLL;

This item has no description.

procedure ActorCount(count: pdword); stdcall; external DLL;

This item has no description.

procedure GetActor(index: dword; obj: pdword); stdcall; external DLL;

This item has no description.

procedure GetActorGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external DLL;

This item has no description.

procedure SetActorGlobalPosition(actor: dword; x,y,z: single); stdcall; external DLL;

This item has no description.

procedure GetActorGlobalOrientation(actor: dword; x,y,z,w: psingle); stdcall; external DLL;

This item has no description.

procedure SetActorGlobalOrientation(actor: dword; x,y,z,w: single); stdcall; external DLL;

This item has no description.

procedure GetActorCMassGlobalPosition(actor: dword; x,y,z: psingle); stdcall; external DLL;

This item has no description.

procedure SetActorCMassGlobalPosition(actor: dword; x,y,z: single); stdcall; external DLL;

This item has no description.

procedure GetActorMass(actor: dword; m: psingle); stdcall; external DLL;

This item has no description.

procedure SetActorMass(actor: dword; m: single); stdcall; external DLL;

This item has no description.

procedure ActorAddForce(actor: dword; x,y,z: single); stdcall; external DLL;

This item has no description.

procedure CreateGroundPlane(actor: pdword); stdcall; external DLL;

This item has no description.

procedure CreateBox(actor: pdword; sx,sy,sz,dens: single); stdcall; external DLL;

This item has no description.

procedure CreateSphere(actor: pdword; rad: single; dens: single); stdcall; external DLL;

This item has no description.

procedure CreateCylinder(actor: pdword; rad: single; height: single; dens: single); stdcall; external DLL;

This item has no description.

Constants

DLL = 'PhysXwrap.dll';


GXSysHelp v.2.5: GXS.PictureRegisteredFormats

Unit GXS.PictureRegisteredFormats

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • FMX.Graphics
  • GXS.ImageUtils

Overview

Functions and Procedures

function GraphicClassForExtension(const anExtension: string): TGraphicClass;
procedure HackTPictureRegisteredFormats(destList: TStrings);

Description

Functions and Procedures

function GraphicClassForExtension(const anExtension: string): TGraphicClass;

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'

procedure HackTPictureRegisteredFormats(destList: TStrings);

Adds to the passed TStrings the list of registered Formatx. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').


GXSysHelp v.2.5: GXS.PolygonTesselation

Unit GXS.PolygonTesselation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • GXS.VectorFileObjects
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GLScene.VectorTypes

Overview

Functions and Procedures

procedure DoTesselate(Vertexes: TgxAffineVectorList; Mesh: TgxBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Description

Functions and Procedures

procedure DoTesselate(Vertexes: TgxAffineVectorList; Mesh: TgxBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.


GXSysHelp v.2.5: GXS.Portal

Unit GXS.Portal

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorFileObjects
  • GXS.Scene
  • GXS.Material
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPortalMeshObjectList |
Class TgxSectorMeshObject |
Class TFGPolygon |
Class TFGPortalPolygon |
Class TgxPortal |


GXSysHelp v.2.5: GXS.Portal: Class TgxPortalMeshObjectList

Class TgxPortalMeshObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Portal

Declaration

type TgxPortalMeshObjectList = class(TgxMeshObjectList)

Description

A mesh object list that handles portal rendering. The items are treated as being sectors.

Hierarchy

  • TgxPersistentObjectList
  • TgxMeshObjectList
  • TgxPortalMeshObjectList

Overview

Methods

Public | constructor CreateOwned(AOwner: TgxBaseMesh);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;

Description

Methods

Public constructor CreateOwned(AOwner: TgxBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxMeshObjectList.BuildList.

Similar to regular scene object's BuildList method


GXSysHelp v.2.5: GXS.Portal: Class TgxSectorMeshObject

Class TgxSectorMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Portal

Declaration

type TgxSectorMeshObject = class(TgxMorphableMeshObject)

Description

A portal renderer sector.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxSectorMeshObject

Overview

Fields

Private FRenderDone: Boolean;

Methods

Public | constructor CreateOwned(AOwner: TgxMeshObjectList);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property RenderDone: Boolean read FRenderDone write FRenderDone;

Description

Fields

Private FRenderDone: Boolean;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TgxMeshObjectList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxMeshObject.BuildList.

Similar to regular scene object's BuildList method

Public procedure Prepare; override;

This item has no description. Showing description inherited from TgxMeshObject.Prepare.

Precalculate whatever is needed for rendering, called once

Properties

Public property RenderDone: Boolean read FRenderDone write FRenderDone;


GXSysHelp v.2.5: GXS.Portal: Class TFGPolygon

Class TFGPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Portal

Declaration

type TFGPolygon = class(TFGVertexNormalTexIndexList)

Description

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon

Overview

Methods

Public | constructor CreateOwned(AOwner: TgxFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure Prepare; override;

Description

Methods

Public constructor CreateOwned(AOwner: TgxFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TgxFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once


GXSysHelp v.2.5: GXS.Portal: Class TFGPortalPolygon

Class TFGPortalPolygon

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Portal

Declaration

type TFGPortalPolygon = class(TFGPolygon)

Description

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon
  • TFGPortalPolygon

Overview

Fields

Private | FDestinationSectorIndex: Integer;
Private | FCenter: TAffineVector;
Private | FNormal: TAffineVector;
Private | FRadius: Single;

Methods

Public | constructor CreateOwned(AOwner: TgxFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property DestinationSectorIndex: Integer read FDestinationSectorIndex write FDestinationSectorIndex;

Description

Fields

Private FDestinationSectorIndex: Integer;

This item has no description.

Private FCenter: TAffineVector;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Methods

Public constructor CreateOwned(AOwner: TgxFaceGroups); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description.

Public procedure Prepare; override;

This item has no description. Showing description inherited from TgxFaceGroup.Prepare.

Precalculate whatever is needed for rendering, called once

Properties

Public property DestinationSectorIndex: Integer read FDestinationSectorIndex write FDestinationSectorIndex;


GXSysHelp v.2.5: GXS.Portal: Class TgxPortal

Class TgxPortal

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Portal

Declaration

type TgxPortal = class(TgxBaseMesh)

Description

Portal Renderer class.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxPortal

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property MaterialLibrary;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property MaterialLibrary;

This item has no description. Showing description inherited from TgxBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.


GXSysHelp v.2.5: GXS.ProcTextures

Unit GXS.ProcTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.Texture
  • GXS.Graphics
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxProcTextureNoise |

Constants

GRADIENT_TABLE_SIZE = 256;
DAMP_SHIFT = 20;

Description

Constants

GRADIENT_TABLE_SIZE = 256;

This item has no description.

DAMP_SHIFT = 20;


GXSysHelp v.2.5: GXS.ProcTextures: Class TgxProcTextureNoise

Class TgxProcTextureNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProcTextures

Declaration

type TgxProcTextureNoise = class(TgxTextureImage)

Description

This item has no description. Showing description inherited from TgxTextureImage.

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxProcTextureNoise

Overview

Fields

Private | FNoiseMap: TgxBitmap32;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FMinCut: Byte;
Private | FNoiseSharpness: Single;
Private | FNoiseAnimate: Single;
Private | FSeamless: Boolean;
Private | FNoiseRandSeed: Longint;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxBitmap32; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure NoiseAnimate(speed: Single);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Public | procedure SetPermFromData(inPERM: array of Byte);
Public | procedure SetPermToDefault;

Properties

Published | property Depth: Integer read GetDepth;
Published | property Height: Integer read GetHeight write SetHeight default 128;
Published | property MinCut: Byte read FMinCut write SetMinCut;
Published | property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;
Published | property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;
Published | property Seamless: Boolean read FSeamless write SetSeamless;
Published | property Width: Integer read GetWidth write SetWidth default 128;

Description

Fields

Private FNoiseMap: TgxBitmap32;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FMinCut: Byte;

This item has no description.

Private FNoiseSharpness: Single;

FMaxCut : Byte;

Private FNoiseAnimate: Single;

This item has no description.

Private FSeamless: Boolean;

This item has no description.

Private FNoiseRandSeed: Longint;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure NoiseAnimate(speed: Single);

This item has no description.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Public procedure SetPermFromData(inPERM: array of Byte);

This item has no description.

Public procedure SetPermToDefault;

This item has no description.

Properties

Published property Depth: Integer read GetDepth;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 128;

This item has no description.

Published property MinCut: Byte read FMinCut write SetMinCut;

This item has no description.

Published property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;

This item has no description.

Published property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;

This item has no description.

Published property Seamless: Boolean read FSeamless write SetSeamless;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 128;


GXSysHelp v.2.5: GXS.ProjectedTextures

Unit GXS.ProjectedTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.PersistentClasses
  • GXS.Texture
  • GLScene.VectorGeometry
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTextureEmitter |
Class TgxTextureEmitterItem |
Class TgxTextureEmitters |
Class TgxProjectedTextures |

Types

TgxProjectedTexturesStyle = (...);

Description

Types

TgxProjectedTexturesStyle = (...);

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).

Values
  • ptsOriginal
  • ptsInverse


GXSysHelp v.2.5: GXS.ProjectedTextures: Class TgxTextureEmitter

Class TgxTextureEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProjectedTextures

Declaration

type TgxTextureEmitter = class(TgxSceneObject)

Description

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTextureEmitter

Overview

Fields

Private | FFOVy: single;
Private | FAspect: single;

Methods

Public constructor Create(AOwner: TComponent); override;

Properties

Published | property Aspect: single read FAspect write FAspect;
Published | property FOVy: single read FFOVy write FFOVy;

Description

Fields

Private FFOVy: single;

This item has no description.

Private FAspect: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Properties

Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property FOVy: single read FFOVy write FFOVy;

Indicates the field-of-view of the projection frustum.


GXSysHelp v.2.5: GXS.ProjectedTextures: Class TgxTextureEmitterItem

Class TgxTextureEmitterItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProjectedTextures

Declaration

type TgxTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TgxTextureEmitters collection.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxTextureEmitterItem

Overview

Fields

Private FEmitter: TgxTextureEmitter;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Emitter: TgxTextureEmitter read FEmitter write SetEmitter;

Description

Fields

Private FEmitter: TgxTextureEmitter;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Emitter: TgxTextureEmitter read FEmitter write SetEmitter;


GXSysHelp v.2.5: GXS.ProjectedTextures: Class TgxTextureEmitters

Class TgxTextureEmitters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProjectedTextures

Declaration

type TgxTextureEmitters = class(TCollection)

Description

Collection of TgxTextureEmitter.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxTextureEmitters

Overview

Fields

Private FOwner: TgxProjectedTextures;

Methods

Public procedure AddEmitter(texEmitter: TgxTextureEmitter);

Properties

Public property Items[index: Integer]: TgxTextureEmitterItem read GetItems;

Description

Fields

Private FOwner: TgxProjectedTextures;

This item has no description.

Methods

Public procedure AddEmitter(texEmitter: TgxTextureEmitter);

This item has no description.

Properties

Public property Items[index: Integer]: TgxTextureEmitterItem read GetItems;


GXSysHelp v.2.5: GXS.ProjectedTextures: Class TgxProjectedTextures

Class TgxProjectedTextures

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProjectedTextures

Declaration

type TgxProjectedTextures = class(TgxImmaterialSceneObject)

Description

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxProjectedTextures

Overview

Fields

Private | FEmitters: TgxTextureEmitters;
Private | FStyle: TgxProjectedTexturesStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Emitters: TgxTextureEmitters read FEmitters write FEmitters;
Published | property Style: TgxProjectedTexturesStyle read FStyle write FStyle;

Description

Fields

Private FEmitters: TgxTextureEmitters;

This item has no description.

Private FStyle: TgxProjectedTexturesStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Emitters: TgxTextureEmitters read FEmitters write FEmitters;

List of texture emitters.

Published property Style: TgxProjectedTexturesStyle read FStyle write FStyle;

Indicates the style of the projected textures.


GXSysHelp v.2.5: GXS.ProxyObjects

Unit GXS.ProxyObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GXS.BaseClasses
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.Scene
  • GXS.Texture
  • GXS.VectorFileObjects
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.Context
  • GLScene.PipelineTransform

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EProxyException |
Class TgxColorProxy |
Class TgxMaterialProxy |
Class TgxFreeFormProxy |
Class TBoneMatrixObj |
Class TgxActorProxy |

Types

TgxActorProxyAnimationMode = (...);

Description

Types

TgxActorProxyAnimationMode = (...);

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.

Values
  • pamInherited
  • pamNone
  • pamPlayOnce


GXSysHelp v.2.5: GXS.ProxyObjects: Class EProxyException

Class EProxyException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type EProxyException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EProxyException


GXSysHelp v.2.5: GXS.ProxyObjects: Class TgxColorProxy

Class TgxColorProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type TgxColorProxy = class(TgxProxyObject)

Description

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxProxyObject
  • TgxColorProxy

Overview

Fields

Private FFrontColor: TgxFaceProperties;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMasterMaterialObject: TgxCustomSceneObject;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Private | procedure SetFrontColor(AValue: TgxFaceProperties);
Private | procedure SetMasterMaterialObject(const Value: TgxCustomSceneObject);

Properties

Published | property FrontColor: TgxFaceProperties read FFrontColor write SetFrontColor;
Published | property MasterObject: TgxCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Description

Fields

Private FFrontColor: TgxFaceProperties;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMasterMaterialObject: TgxCustomSceneObject;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Private procedure SetFrontColor(AValue: TgxFaceProperties);

This item has no description.

Private procedure SetMasterMaterialObject(const Value: TgxCustomSceneObject);

This item has no description.

Properties

Published property FrontColor: TgxFaceProperties read FFrontColor write SetFrontColor;

This item has no description.

Published property MasterObject: TgxCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Redeclare as TgxCustomSceneObject.


GXSysHelp v.2.5: GXS.ProxyObjects: Class TgxMaterialProxy

Class TgxMaterialProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type TgxMaterialProxy = class(TgxProxyObject, IgxMaterialLibrarySupported)

Description

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxProxyObject
  • TgxMaterialProxy

Overview

Fields

Private | FTempLibMaterialName: string;
Private | FMasterLibMaterial: TgxLibMaterial;
Private | FMaterialLibrary: TgxMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMasterLibMaterialName: TgxLibMaterialName;
Private | function GetMasterMaterialObject: TgxCustomSceneObject;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure SetMasterLibMaterialName(const Value: TgxLibMaterialName);
Private | procedure SetMasterMaterialObject(const Value: TgxCustomSceneObject);
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

Properties

Public | property MasterLibMaterial: TgxLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TgxLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TgxCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FTempLibMaterialName: string;

This item has no description.

Private FMasterLibMaterial: TgxLibMaterial;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMasterLibMaterialName: TgxLibMaterialName;

This item has no description.

Private function GetMasterMaterialObject: TgxCustomSceneObject;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure SetMasterLibMaterialName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMasterMaterialObject(const Value: TgxCustomSceneObject);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Properties

Public property MasterLibMaterial: TgxLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TgxLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TgxCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Redeclare as TgxCustomSceneObject.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GXSysHelp v.2.5: GXS.ProxyObjects: Class TgxFreeFormProxy

Class TgxFreeFormProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type TgxFreeFormProxy = class(TgxProxyObject)

Description

A proxy object specialized for FreeForms.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxProxyObject
  • TgxFreeFormProxy

Overview

Methods

Public | function OctreeRayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector4f; const velocity, radius, modelscale: Single; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;
Private | function GetMasterFreeFormObject: TgxFreeForm;
Private | procedure SetMasterFreeFormObject(const Value: TgxFreeForm);

Properties

Published property MasterObject: TgxFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;

Description

Methods

Public function OctreeRayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;

If the MasterObject is a FreeForm, you can raycast against the Octree, which is alot faster. You must build the octree before using.

Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector4f; const velocity, radius, modelscale: Single; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;

WARNING: This function is not yet 100% reliable with scale+rotation.

Private function GetMasterFreeFormObject: TgxFreeForm;

This item has no description.

Private procedure SetMasterFreeFormObject(const Value: TgxFreeForm);

This item has no description.

Properties

Published property MasterObject: TgxFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;

Redeclare as TgxFreeForm.


GXSysHelp v.2.5: GXS.ProxyObjects: Class TBoneMatrixObj

Class TBoneMatrixObj

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type TBoneMatrixObj = class(TObject)

Description

An object containing the bone matrix for TgxActorProxy.

Hierarchy

  • TObject
  • TBoneMatrixObj

Overview

Fields

Public | Matrix: TMatrix4f;
Public | BoneName: string;
Public | BoneIndex: integer;

Description

Fields

Public Matrix: TMatrix4f;

This item has no description.

Public BoneName: string;

This item has no description.

Public BoneIndex: integer;


GXSysHelp v.2.5: GXS.ProxyObjects: Class TgxActorProxy

Class TgxActorProxy

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ProxyObjects

Declaration

type TgxActorProxy = class(TgxProxyObject, IgxMaterialLibrarySupported)

Description

A proxy object specialized for Actors.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxProxyObject
  • TgxActorProxy

Overview

Fields

Private | FCurrentFrame: Integer;
Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FLastFrame: Integer;
Private | FCurrentFrameDelta: Single;
Private | FCurrentTime: TgxProgressTimes;
Private | FAnimation: TgxActorAnimationName;
Private | FTempLibMaterialName: string;
Private | FMasterLibMaterial: TgxLibMaterial;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FBonesMatrices: TStringList;
Private | FStoreBonesMatrix: boolean;
Private | FStoredBoneNames: TStrings;
Private | FOnBeforeRender: TgxProgressEvent;
Private | FAnimationMode: TgxActorProxyAnimationMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function BoneMatrix(BoneName: string): TMatrix4f; overload;
Public | function BoneMatrix(BoneIndex: integer): TMatrix4f; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;
Public | function RayCastIntersectEx(RefActor: TgxActor; const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; overload;
Private | function GetLibMaterialName: TgxLibMaterialName;
Private | function GetMasterActorObject: TgxActor;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure BoneMatricesClear;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Private | procedure SetAnimation(const Value: TgxActorAnimationName);
Private | procedure SetLibMaterialName(const Value: TgxLibMaterialName);
Private | procedure SetMasterActorObject(const Value: TgxActor);
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetOnBeforeRender(const Value: TgxProgressEvent);
Private | procedure SetStoreBonesMatrix(const Value: boolean);
Private | procedure SetStoredBoneNames(const Value: TStrings);

Properties

Published | property Animation: TgxActorAnimationName read FAnimation write SetAnimation;
Published | property AnimationMode: TgxActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;
Public | property CurrentFrame: Integer read FCurrentFrame;
Public | property CurrentFrameDelta: Single read FCurrentFrameDelta;
Public | property CurrentTime: TgxProgressTimes read FCurrentTime;
Public | property EndFrame: Integer read FEndFrame;
Published | property LibMaterialName: TgxLibMaterialName read GetLibMaterialName write SetLibMaterialName;
Published | property MasterObject: TgxActor read GetMasterActorObject write SetMasterActorObject;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OnBeforeRender: TgxProgressEvent read FOnBeforeRender write SetOnBeforeRender;
Published | property ProxyOptions default [pooEffects, pooObjects];
Public | property StartFrame: Integer read FStartFrame;
Published | property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;
Published | property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Description

Fields

Private FCurrentFrame: Integer;

This item has no description.

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FLastFrame: Integer;

This item has no description.

Private FCurrentFrameDelta: Single;

This item has no description.

Private FCurrentTime: TgxProgressTimes;

This item has no description.

Private FAnimation: TgxActorAnimationName;

This item has no description.

Private FTempLibMaterialName: string;

This item has no description.

Private FMasterLibMaterial: TgxLibMaterial;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FBonesMatrices: TStringList;

This item has no description.

Private FStoreBonesMatrix: boolean;

This item has no description.

Private FStoredBoneNames: TStrings;

This item has no description.

Private FOnBeforeRender: TgxProgressEvent;

This item has no description.

Private FAnimationMode: TgxActorProxyAnimationMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

stores matrices of bones of the current frame rendered

Public destructor Destroy; override;

This item has no description.

Public function BoneMatrix(BoneName: string): TMatrix4f; overload;

This item has no description.

Public function BoneMatrix(BoneIndex: integer): TMatrix4f; overload;

Gets the Bones Matrix in the current animation frame. (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; override;

A standard version of the RayCastIntersect function

Public function RayCastIntersectEx(RefActor: TgxActor; const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; overload;

Raycasts on self, but actually on the "RefActor" Actor. Note that the "RefActor" parameter does not necessarily have to be the same Actor refernced by the MasterObject property: This allows to pass a low-low-low-poly Actor to raycast in the "RefActor" parameter, while using a high-poly Actor in the "MasterObject" property, of course we assume that the two Masterobject Actors have same animations.

Private function GetLibMaterialName: TgxLibMaterialName;

This item has no description.

Private function GetMasterActorObject: TgxActor;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Public procedure BoneMatricesClear;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Private procedure SetAnimation(const Value: TgxActorAnimationName);

This item has no description.

Private procedure SetLibMaterialName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMasterActorObject(const Value: TgxActor);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetOnBeforeRender(const Value: TgxProgressEvent);

This item has no description.

Private procedure SetStoreBonesMatrix(const Value: boolean);

This item has no description.

Private procedure SetStoredBoneNames(const Value: TStrings);

This item has no description.

Properties

Published property Animation: TgxActorAnimationName read FAnimation write SetAnimation;

This item has no description.

Published property AnimationMode: TgxActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;

This item has no description.

Public property CurrentFrame: Integer read FCurrentFrame;

This item has no description.

Public property CurrentFrameDelta: Single read FCurrentFrameDelta;

This item has no description.

Public property CurrentTime: TgxProgressTimes read FCurrentTime;

This item has no description.

Public property EndFrame: Integer read FEndFrame;

This item has no description.

Published property LibMaterialName: TgxLibMaterialName read GetLibMaterialName write SetLibMaterialName;

Specifies the Material, that current proxy will use.

Published property MasterObject: TgxActor read GetMasterActorObject write SetMasterActorObject;

Redeclare as TgxActor.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Specifies the MaterialLibrary, that current proxy will use.

Published property OnBeforeRender: TgxProgressEvent read FOnBeforeRender write SetOnBeforeRender;

Event allowing to apply extra transformations (f.ex: bone rotations) to the referenced Actor on order to have the proxy render these changes.

Published property ProxyOptions default [pooEffects, pooObjects];

Redeclare without pooTransformation (Don't know why it causes the object to be oriented incorrecly.)

Public property StartFrame: Integer read FStartFrame;

This item has no description.

Published property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;

Specifies if it will store the Bones Matrices, accessible via the BoneMatrix function (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Published property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Specifies the names of the bones we want the matrices to be stored. If empty, all bones will be stored (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)


GXSysHelp v.2.5: GXS.Python.Script

Unit GXS.Python.Script

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics rendering engine GLScene http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.XCollection
  • GXS.ScriptBase
  • GLScene.Manager
  • Python.Engine

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPythonEngine |
Class TgxScriptPython |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GXS.Python.Script: Class TgxPythonEngine

Class TgxPythonEngine

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Python.Script

Declaration

type TgxPythonEngine = class(TPythonEngine)

Description

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TgxScriptPython) retain it's assigned compiler from design to run -time.

Hierarchy

  • TPythonEngine
  • TgxPythonEngine

Overview

Methods

Public | constructor Create(AOnwer: TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOnwer: TComponent); override;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXS.Python.Script: Class TgxScriptPython

Class TgxScriptPython

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Python.Script

Declaration

type TgxScriptPython = class(TgxScriptBase)

Description

Implements Python scripting functionality through the abstracted GLS.ScriptBase

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxScriptBase
  • TgxScriptPython

Overview

Fields

Private | FEngine: TgxPythonEngine;
Private | FEngineName: String;
Private | FCompiled: Boolean;
Private | FStarted: Boolean;

Methods

Public | destructor Destroy; override;
Public | function Call(aName: String; aParams: array of Variant): Variant; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | class function ItemCategory: String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; override;
Public | procedure Execute; override;
Public | procedure Invalidate; override;
Public | procedure Start; override;
Public | procedure Stop; override;

Properties

Published property Engine: TgxPythonEngine read FEngine write SetEngine;

Description

Fields

Private FEngine: TgxPythonEngine;

This item has no description.

Private FEngineName: String;

This item has no description.

Private FCompiled: Boolean;

This item has no description.

Private FStarted: Boolean;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public function Call(aName: String; aParams: array of Variant): Variant; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function ItemCategory: String; override;

This item has no description. Showing description inherited from TXCollectionItem.ItemCategory.

Category of the item class. This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Compile; override;

This item has no description.

Public procedure Execute; override;

This item has no description.

Public procedure Invalidate; override;

This item has no description.

Public procedure Start; override;

This item has no description.

Public procedure Stop; override;

This item has no description.

Properties

Published property Engine: TgxPythonEngine read FEngine write SetEngine;


GXSysHelp v.2.5: GXS.Ragdoll

Unit GXS.Ragdoll

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Scene
  • GXS.Objects
  • GXS.VectorFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxRagdolJoint |
Class TgxRagdolBoneList |
Class TgxRagdolBone |
Class TgxRagdoll |


GXSysHelp v.2.5: GXS.Ragdoll: Class TgxRagdolJoint

Class TgxRagdolJoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Ragdoll

Declaration

type TgxRagdolJoint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxRagdolJoint


GXSysHelp v.2.5: GXS.Ragdoll: Class TgxRagdolBoneList

Class TgxRagdolBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Ragdoll

Declaration

type TgxRagdolBoneList = class(TgxPersistentObjectList)

Description

This item has no description.

Hierarchy

  • TgxPersistentObjectList
  • TgxRagdolBoneList

Overview

Fields

Private FRagdoll: TgxRagdoll;

Methods

Public | constructor Create(Ragdoll: TgxRagdoll); reintroduce;
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader : TgxVirtualReader); override;
Public | procedure WriteToFiler(writer : TgxVirtualWriter); override;

Properties

Public | property Items[Index: Integer]: TgxRagdolBone read GetRagdollBone;
Public | property Ragdoll : TgxRagdoll read FRagdoll;

Description

Fields

Private FRagdoll: TgxRagdoll;

This item has no description.

Methods

Public constructor Create(Ragdoll: TgxRagdoll); reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader : TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer : TgxVirtualWriter); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TgxRagdolBone read GetRagdollBone;

This item has no description.

Public property Ragdoll : TgxRagdoll read FRagdoll;


GXSysHelp v.2.5: GXS.Ragdoll: Class TgxRagdolBone

Class TgxRagdolBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Ragdoll

Declaration

type TgxRagdolBone = class(TgxRagdolBoneList)

Description

This item has no description.

Hierarchy

  • TgxPersistentObjectList
  • TgxRagdolBoneList
  • TgxRagdolBone

Overview

Fields

Private | FOwner: TgxRagdolBoneList;
Private | FName: String;
Private | FBoneID: Integer;
Private | FBoundMax: TAffineVector;
Private | FBoundMin: TAffineVector;
Private | FBoundBoneDelta: TAffineVector;
Private | FOrigin: TAffineVector;
Private | FSize: TAffineVector;
Private | FBoneMatrix: TMatrix4f;
Private | FJoint: TgxRagdolJoint;
Private | FOriginalMatrix: TMatrix4f;
Private | FReferenceMatrix: TMatrix4f;
Private | FAnchor: TAffineVector;

Methods

Public | constructor Create(Ragdoll: TgxRagdoll);
Public | constructor CreateOwned(aOwner : TgxRagdolBoneList);
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader : TgxVirtualReader); override;
Public | procedure WriteToFiler(writer : TgxVirtualWriter); override;
Private | procedure AlignChild;
Private | procedure AlignToSkeleton;
Private | procedure CreateBoundingBox;
Private | procedure CreateBoundsChild;
Private | procedure SetAnchor(Anchor: TAffineVector);
Private | procedure StartChild;
Private | procedure StopChild;
Private | procedure UpdateChild;

Properties

Public | property Anchor : TAffineVector read FAnchor;
Public | property BoneID : Integer read FBoneID write FBoneID;
Public | property BoneMatrix : TMatrix4f read FBoneMatrix;
Public | property Items[Index: Integer]: TgxRagdolBone read GetRagdollBone;
Public | property Joint : TgxRagdolJoint read FJoint write FJoint;
Public | property Name : String read FName write FName;
Public | property Origin : TAffineVector read FOrigin;
Public | property Owner : TgxRagdolBoneList read FOwner;
Public | property ReferenceMatrix : TMatrix4f read FReferenceMatrix;
Public | property Size : TAffineVector read FSize;

Description

Fields

Private FOwner: TgxRagdolBoneList;

This item has no description.

Private FName: String;

This item has no description.

Private FBoneID: Integer;

This item has no description.

Private FBoundMax: TAffineVector;

Refering to TgxActor Bone

Private FBoundMin: TAffineVector;

This item has no description.

Private FBoundBoneDelta: TAffineVector;

This item has no description.

Private FOrigin: TAffineVector;

Stores the diference from the bone.GlobalMatrix to the center of the bone's bounding box

Private FSize: TAffineVector;

This item has no description.

Private FBoneMatrix: TMatrix4f;

This item has no description.

Private FJoint: TgxRagdolJoint;

This item has no description.

Private FOriginalMatrix: TMatrix4f;

This item has no description.

Private FReferenceMatrix: TMatrix4f;

Stores the Bone.GlobalMatrix before the ragdoll start

Private FAnchor: TAffineVector;

Stores the first bone matrix to be used as reference

Methods

Public constructor Create(Ragdoll: TgxRagdoll);

This item has no description.

Public constructor CreateOwned(aOwner : TgxRagdolBoneList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader : TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer : TgxVirtualWriter); override;

This item has no description.

Private procedure AlignChild;

This item has no description.

Private procedure AlignToSkeleton;

This item has no description.

Private procedure CreateBoundingBox;

The position of the joint

Private procedure CreateBoundsChild;

This item has no description.

Private procedure SetAnchor(Anchor: TAffineVector);

This item has no description.

Private procedure StartChild;

This item has no description.

Private procedure StopChild;

This item has no description.

Private procedure UpdateChild;

This item has no description.

Properties

Public property Anchor : TAffineVector read FAnchor;

This item has no description.

Public property BoneID : Integer read FBoneID write FBoneID;

This item has no description.

Public property BoneMatrix : TMatrix4f read FBoneMatrix;

This item has no description.

Public property Items[Index: Integer]: TgxRagdolBone read GetRagdollBone;

This item has no description.

Public property Joint : TgxRagdolJoint read FJoint write FJoint;

This item has no description.

Public property Name : String read FName write FName;

This item has no description.

Public property Origin : TAffineVector read FOrigin;

This item has no description.

Public property Owner : TgxRagdolBoneList read FOwner;

This item has no description.

Public property ReferenceMatrix : TMatrix4f read FReferenceMatrix;

This item has no description.

Public property Size : TAffineVector read FSize;


GXSysHelp v.2.5: GXS.Ragdoll: Class TgxRagdoll

Class TgxRagdoll

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Ragdoll

Declaration

type TgxRagdoll = class(TgxPersistentObject)

Description

This item has no description.

Hierarchy

  • TgxPersistentObject
  • TgxRagdoll

Overview

Fields

Private | FOwner: TgxBaseMesh;
Private | FRootBone: TgxRagdolBone;
Private | FEnabled: Boolean;
Private | FBuilt: Boolean;

Methods

Public | constructor Create(AOwner : TgxBaseMesh); reintroduce;
Public | destructor Destroy; override;
Public | procedure BuildRagdoll;
Public | procedure ReadFromFiler(reader : TgxVirtualReader); override;
Public | procedure SetRootBone(RootBone: TgxRagdolBone);
Public | procedure Start;
Public | procedure Stop;
Public | procedure Update;
Public | procedure WriteToFiler(writer : TgxVirtualWriter); override;

Properties

Public | property Enabled : Boolean read FEnabled;
Public | property Owner : TgxBaseMesh read FOwner;
Public | property RootBone : TgxRagdolBone read FRootBone;

Description

Fields

Private FOwner: TgxBaseMesh;

This item has no description.

Private FRootBone: TgxRagdolBone;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FBuilt: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner : TgxBaseMesh); reintroduce;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildRagdoll;

Create the bounding box and setup the ragdoll do be started later

Public procedure ReadFromFiler(reader : TgxVirtualReader); override;

This item has no description.

Public procedure SetRootBone(RootBone: TgxRagdolBone);

Must be set before build the ragdoll

Public procedure Start;

This item has no description.

Public procedure Stop;

This item has no description.

Public procedure Update;

This item has no description.

Public procedure WriteToFiler(writer : TgxVirtualWriter); override;

This item has no description.

Properties

Public property Enabled : Boolean read FEnabled;

This item has no description.

Public property Owner : TgxBaseMesh read FOwner;

This item has no description.

Public property RootBone : TgxRagdolBone read FRootBone;


GXSysHelp v.2.5: GXS.RandomHDS

Unit GXS.RandomHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.Math
  • System.SysUtils
  • System.UITypes
  • System.UIConsts
  • System.Contnrs
  • Fmx.Graphics
  • Fmx.Forms
  • GLScene.OpenGL4
  • GXS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.HeightData
  • GXS.TerrainRenderer
  • GXS.Texture
  • GXS.Color
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TSeaErosion |
Record TRainErosion |
Record TLifeErosion |
Record TFractionErosion |
Record TLandTileInfo |
Record TSteps |
Class TgxBaseRandomHDS |
Class TgxCustomRandomHDS |
Class TgxFractalHDS |
Record TRelativeCoordinate |
Class TgxTiledRndLandscape |
Class TgxFractalArchipelago |

Functions and Procedures

function NoisyColor(const Color: TColor; const Noise: single = 0.05): TgxColorVector;
function TextureGreen(const x, y: integer): TgxColorVector;
function TextureBlue(const x, y: integer): TgxColorVector;
function TextureSand(const x, y: integer): TgxColorVector;
function TextureBrownSoil(const x, y: integer): TgxColorVector;
function TextureDarkGreen(const x, y: integer): TgxColorVector;
function TextureDarkGray(const x, y: integer): TgxColorVector;
function TextureWhite(const x, y: integer): TgxColorVector;
procedure FractalMiddlePointHDS(const aDepth, aSeed, aAmplitude: integer; const aRoughness: single; aCyclic: boolean; var z: TMapOfSingle; var MinZ, MaxZ: single);
procedure InitializeRandomGenerator(const Seed: integer);
procedure PrimerNull(var z: TMapOfSingle);
procedure PrimerIsland(LowZ, HighZ: single; var z: TMapOfSingle);

Types

TIntegerClamp = procedure(var x, y: integer) of object;
TIsDefaultTile = function(x, z: integer): boolean of object;
TLandTile = TgxCustomRandomHDS;
TMapOfSingle = array of array of single;
TMapOfVector = array of array of TVector4f;
TOnCreateLandTile = procedure(x, z, Seed: integer; var aLandscape: TLandTile) of object;
TOnDrawTexture = function(const Sender: TgxBaseRandomHDS; x, y: integer; z: double; Normal: TVector4f): TgxColorVector of object;
TSingleClamp = procedure(var x, y: single) of object;

Constants

VerticalScalingFactor = 128;

Description

Functions and Procedures

function NoisyColor(const Color: TColor; const Noise: single = 0.05): TgxColorVector;

function LoadJPGtexture(const JpgName: string): tBitmap;

function TextureGreen(const x, y: integer): TgxColorVector;

This item has no description.

function TextureBlue(const x, y: integer): TgxColorVector;

This item has no description.

function TextureSand(const x, y: integer): TgxColorVector;

This item has no description.

function TextureBrownSoil(const x, y: integer): TgxColorVector;

This item has no description.

function TextureDarkGreen(const x, y: integer): TgxColorVector;

This item has no description.

function TextureDarkGray(const x, y: integer): TgxColorVector;

This item has no description.

function TextureWhite(const x, y: integer): TgxColorVector;

This item has no description.

procedure FractalMiddlePointHDS(const aDepth, aSeed, aAmplitude: integer; const aRoughness: single; aCyclic: boolean; var z: TMapOfSingle; var MinZ, MaxZ: single);

Random HDS functions

procedure InitializeRandomGenerator(const Seed: integer);

This item has no description.

procedure PrimerNull(var z: TMapOfSingle);

Landscape primers

procedure PrimerIsland(LowZ, HighZ: single; var z: TMapOfSingle);

This item has no description.

Types

TIntegerClamp = procedure(var x, y: integer) of object;

This item has no description.

TIsDefaultTile = function(x, z: integer): boolean of object;

This item has no description.

TLandTile = TgxCustomRandomHDS;

TMapOfLandscapes :array of array of TgxBaseRandomHDS;

TMapOfSingle = array of array of single;

This item has no description.

TMapOfVector = array of array of TVector4f;

This item has no description.

TOnCreateLandTile = procedure(x, z, Seed: integer; var aLandscape: TLandTile) of object;

This item has no description.

TOnDrawTexture = function(const Sender: TgxBaseRandomHDS; x, y: integer; z: double; Normal: TVector4f): TgxColorVector of object;

Function type to use for topography-based texture

TSingleClamp = procedure(var x, y: single) of object;

This item has no description.

Constants

VerticalScalingFactor = 128;


GXSysHelp v.2.5: GXS.RandomHDS: Record TSeaErosion

Record TSeaErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TSeaErosion = record

Description

Fmx.Imaging.jpeg,

Overview

Fields

Public | Enabled: boolean;
Public | BeachHeight: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public BeachHeight: single;


GXSysHelp v.2.5: GXS.RandomHDS: Record TRainErosion

Record TRainErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TRainErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | ErosionRate: single;
Public | DepositRate: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public ErosionRate: single;

This item has no description.

Public DepositRate: single;


GXSysHelp v.2.5: GXS.RandomHDS: Record TLifeErosion

Record TLifeErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TLifeErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Robustness: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Robustness: single;


GXSysHelp v.2.5: GXS.RandomHDS: Record TFractionErosion

Record TFractionErosion

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TFractionErosion = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Slope: single;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Slope: single;


GXSysHelp v.2.5: GXS.RandomHDS: Record TLandTileInfo

Record TLandTileInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TLandTileInfo = record

Description

This item has no description.

Overview

Fields

Public | x: integer;
Public | z: integer;
Public | State: TgxHeightDataState;

Description

Fields

Public x: integer;

This item has no description.

Public z: integer;

This item has no description.

Public State: TgxHeightDataState;

Coordinates of the landtile. Used to generate the seed


GXSysHelp v.2.5: GXS.RandomHDS: Record TSteps

Record TSteps

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TSteps = record

Description

This item has no description.

Overview

Fields

Public | Enabled: boolean;
Public | Count: integer;

Description

Fields

Public Enabled: boolean;

This item has no description.

Public Count: integer;


GXSysHelp v.2.5: GXS.RandomHDS: Class TgxBaseRandomHDS

Class TgxBaseRandomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TgxBaseRandomHDS = class(TgxHeightDataSource)

Description

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TgxCustomRandomLandscape: one tile landscape (cyclic or not) - TgxTiledRndLandscape: "infinite" landscapes (grids of TgxCustomRandomLandscape)

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBaseRandomHDS

Overview

Fields

Private | FSteps: TSteps;
Private | FLandCover: boolean;
Public | FErosionByRain: TRainErosion;
Public | FErosionBySea: TSeaErosion;
Public | FErosionByLife: TLifeErosion;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetLandCover(const Value: boolean);
Private | procedure SetOnDrawTexture(const Value: TOnDrawTexture);
Private | procedure SetSteps(const Value: TSteps);

Properties

Published | property AmbientLight: single read FAmbientLight write SetAmbientLight;
Published | property Cyclic: boolean read FCyclic write SetCyclic;
Published | property ErosionByFraction: TFractionErosion read FErosionByFraction write SetErosionByFraction;
Published | property ErosionByLife: TLifeErosion read FErosionByLife write SetErosionByLife;
Published | property ErosionByRain: TRainErosion read FErosionByRain write SetErosionByRain;
Published | property ErosionBySea: TSeaErosion read FErosionBySea write SetErosionBySea;
Published | property LandCover: boolean read FLandCover write SetLandCover;
Public | property LightColor: TgxColorVector read FLightColor write SetLightColor;
Public | property LightDirection: TVector4f read FLightDirection write SetLightDirection;
Published | property Lighting: boolean read FLighting write SetLighting;
Published | property LightSmoothing: boolean read FLightSmoothing write SetLightSmoothing;
Published | property MaterialName: string read FMaterialName write SetMaterialName;
Public | property OnDrawTexture: TOnDrawTexture read FOnDrawTexture write SetOnDrawTexture;
Published | property PrimerLandscape: boolean read FPrimerLandscape write SetPrimerLandscape;
Published | property Sea: boolean read FSea write SetSea;
Published | property SeaLevel: single read GetSeaLevel write SetSeaLevel;
Published | property SeaTransparency: single read GetSeaTransparency write SetSeaTransparency;
Published | property Seed: integer read FSeed write SetSeed;
Published | property Shadows: boolean read FShadows write SetShadows;
Published | property Steps: TSteps read FSteps write SetSteps;
Published | property TerrainRenderer: TgxTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;
Published | property TextureScale: integer read FTextureScale write SetTextureScale;

Description

Fields

Private FSteps: TSteps;

This item has no description.

Private FLandCover: boolean;

This item has no description.

Public FErosionByRain: TRainErosion;

This item has no description.

Public FErosionBySea: TSeaErosion;

This item has no description.

Public FErosionByLife: TLifeErosion;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetLandCover(const Value: boolean);

This item has no description.

Private procedure SetOnDrawTexture(const Value: TOnDrawTexture);

This item has no description.

Private procedure SetSteps(const Value: TSteps);

This item has no description.

Properties

Published property AmbientLight: single read FAmbientLight write SetAmbientLight;

This item has no description.

Published property Cyclic: boolean read FCyclic write SetCyclic;

If true, the landscape can be tiled to itself seamlessly. If false, the landscape is an isolated square.

Published property ErosionByFraction: TFractionErosion read FErosionByFraction write SetErosionByFraction;

Erosion parameters. See associated record types

Published property ErosionByLife: TLifeErosion read FErosionByLife write SetErosionByLife;

This item has no description.

Published property ErosionByRain: TRainErosion read FErosionByRain write SetErosionByRain;

This item has no description.

Published property ErosionBySea: TSeaErosion read FErosionBySea write SetErosionBySea;

This item has no description.

Published property LandCover: boolean read FLandCover write SetLandCover;

This item has no description.

Public property LightColor: TgxColorVector read FLightColor write SetLightColor;

Usually white, but you can generate e.g.sunset ambiance by setting it to red

Public property LightDirection: TVector4f read FLightDirection write SetLightDirection;

Light is parallel (sun light)

Published property Lighting: boolean read FLighting write SetLighting;

Enable or disable all lighting effects

Published property LightSmoothing: boolean read FLightSmoothing write SetLightSmoothing;

True by default. You can gain a little speed by disabling it.

Published property MaterialName: string read FMaterialName write SetMaterialName;

Not used

Public property OnDrawTexture: TOnDrawTexture read FOnDrawTexture write SetOnDrawTexture;

This function must be supplied by the user. Here he/she can define which colour to use depending on coordinates, elevation and normal. This provides a great flexibility. If no function is supplied (OnDrawTexture=nil), a default texture function is used (very basic, just blue and green).

Published property PrimerLandscape: boolean read FPrimerLandscape write SetPrimerLandscape;

If true, the height-field will not be emptied and generation will take the existing heights to shape the new landscape

Published property Sea: boolean read FSea write SetSea;

Enable the sea surface truncation

Published property SeaLevel: single read GetSeaLevel write SetSeaLevel;

Sea level

Published property SeaTransparency: single read GetSeaTransparency write SetSeaTransparency;

Depth at which the sea bottom becomes invisible. See DoSea for more information

Published property Seed: integer read FSeed write SetSeed;

Seed used by the random generator. Each seed generate a different reproductible landscape.

Published property Shadows: boolean read FShadows write SetShadows;

Enable shadow casting. May take some time for large Depth.

Published property Steps: TSteps read FSteps write SetSteps;

This item has no description.

Published property TerrainRenderer: TgxTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

TerrainRenderer used to render the HDS.

Published property TextureScale: integer read FTextureScale write SetTextureScale;

Defines how many texture pixels are drawn per height-field cell. The larger this number the better the quality of the resulting image, but it takes a more time to compute. Good results are got between 1 and 5.


GXSysHelp v.2.5: GXS.RandomHDS: Class TgxCustomRandomHDS

Class TgxCustomRandomHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TgxCustomRandomHDS = class(TgxBaseRandomHDS)

Description

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBaseRandomHDS
  • TgxCustomRandomHDS

Overview

Fields

Private | FSlave: boolean;
Private | FMaxHeight: single;
Private | FMinHeight: single;
Private | FRangeHeight: single;
Private | FTask: string;
Private | FSingleConstrain: TSingleClamp;
Private | FIntegerConstrain: TIntegerClamp;
Private | FKeepNormals: boolean;
Public | FHeight: TMapOfSingle;
Public | FLightMap: TMapOfSingle;
Public | FNormal: TMapOfVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function BoundaryX: integer;
Public | function BoundaryZ: integer;
Public | function Interpolate(x, y: single): single;
Public | function Normal(const Position: TVector4f): TVector4f;
Public | function PointInMap(const x, y: integer): boolean; overload;
Public | function PointInMap(const x, y: single): boolean; overload;
Public | function Scale: TgxCoordinates;
Public | function StandardisedHeight(const x, y: integer): single;
Public | function XMoveBoundary: single;
Public | function ZMoveBoundary: single;
Private | function GetHeight(x, y: integer): single;
Public | procedure BuildHeightField; overload; virtual; abstract;
Public | procedure BuildLandscape;
Public | procedure BuildLightMap(const aLightDirection: TVector4f); overload;
Public | procedure BuildLightMap; overload;
Public | procedure BuildNormals;
Public | procedure BuildTexture;
Public | procedure ClearHeightField;
Public | procedure ClearLightMap;
Public | procedure ConstrainCoordinates(var x, y: single); overload;
Public | procedure ConstrainCoordinates(var x, y: integer); overload;
Public | procedure DoCyclicBoundaries;
Public | procedure DoErosionByFraction;
Public | procedure DoErosionByLife;
Public | procedure DoErosionByRain;
Public | procedure DoErosionBySea;
Public | procedure DoSea;
Public | procedure DoSteps;
Public | procedure StartPreparingData(heightData: TgxHeightData); override;
Private | procedure SetHeight(x, y: integer; const Value: single);
Private | procedure SetKeepNormals(const Value: boolean);

Properties

Published | property Cyclic: boolean read FCyclic write SetCyclic;
Public | property Heights[x,y: integer]: single read GetHeight write SetHeight;
Public | property KeepNormals: boolean read FKeepNormals write SetKeepNormals;
Public | property LandTileInfo: TLandTileInfo read GetLandTileInfo write SetLandTileInfo;
Public | property MaxHeight: single read FMaxHeight;
Public | property MinHeight: single read FMinHeight;
Public | property RangeHeight: single read FRangeHeight;
Public | property Size: integer read FSize;
Public | property Task: string read FTask;
Public | property TaskProgress: integer read FTaskProgress;

Description

Fields

Private FSlave: boolean;

This item has no description.

Private FMaxHeight: single;

This item has no description.

Private FMinHeight: single;

This item has no description.

Private FRangeHeight: single;

This item has no description.

Private FTask: string;

This item has no description.

Private FSingleConstrain: TSingleClamp;

This item has no description.

Private FIntegerConstrain: TIntegerClamp;

This item has no description.

Private FKeepNormals: boolean;

This item has no description.

Public FHeight: TMapOfSingle;

This item has no description.

Public FLightMap: TMapOfSingle;

This item has no description.

Public FNormal: TMapOfVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoundaryX: integer;

Upper bounds of the tile

Public function BoundaryZ: integer;

This item has no description.

Public function Interpolate(x, y: single): single;

A specific implementation of THeightDataSource.InterpolatedHeight

Public function Normal(const Position: TVector4f): TVector4f;

Vector normal to the terrain at the position

Public function PointInMap(const x, y: integer): boolean; overload;

This item has no description.

Public function PointInMap(const x, y: single): boolean; overload;

Range checking

Public function Scale: TgxCoordinates;

Scale of the Terrain Renderer. They are set so as giving a identical vertical/horitontal ratio with any size. Therefore, Scale.X=Scale.Y=1 and only Scale.Z varies. If you want to increase the landscape scale, the best way would be to place the Terrain Renderer in a DummyCube and rescale it.

Public function StandardisedHeight(const x, y: integer): single;

A height rescaled between 0 and 1000 for

Public function XMoveBoundary: single;

Use these boundaries with non-cyclic landscapes to constrain camera movements.

Public function ZMoveBoundary: single;

This item has no description.

Private function GetHeight(x, y: integer): single;

This item has no description.

Public procedure BuildHeightField; overload; virtual; abstract;

Generate the heightfield array, based on the topographical properties

Public procedure BuildLandscape;

Provide an automated way to build a landscape. However, a greater control can be achieved by calling the various procedures manually (they are public methods) as one gets a sligthly different result depending on the sequence of erosion and sea steps.

Public procedure BuildLightMap(const aLightDirection: TVector4f); overload;

This item has no description.

Public procedure BuildLightMap; overload;

- Compute the light effects - Compute the casted shadows - Perform a basic smoothing if TextureScale>1

Public procedure BuildNormals;

Normals are needed for lighting and slope-based textures

Public procedure BuildTexture;

For every pixel of the texture, computes slope and interpolated height and sends these information to a user-supplied function (OnDrawTexture), whose result is a TgxColorVector. If no OnDrawTexture is supplied, a basic default texture will be used.

Public procedure ClearHeightField;

Fill the heightfield with "Empty" values (-999)

Public procedure ClearLightMap;

Fill the light map with 1

Public procedure ConstrainCoordinates(var x, y: single); overload;

Constrain x,y to be in the boundaries of the height field array. This is done in two way depending on the kind of landscape: Cyclic landscapes: mod Non-cyclic landscape: clamp

Public procedure ConstrainCoordinates(var x, y: integer); overload;

This item has no description.

Public procedure DoCyclicBoundaries;

Enforces an identical height on the opposing edges of the landscape

Public procedure DoErosionByFraction;

Not yet implemented

Public procedure DoErosionByLife;

Just a smoothing. Should be done last as it improves the look of other erosion effects. Too much biological erosion can ruin erase their results though. Some tweaking may be needed

Public procedure DoErosionByRain;

Create sharp valleys and canyons. If DepositRate>0, it will also fill the low pools, producing flat "lakes" and "ponds"

Public procedure DoErosionBySea;

Create a beach and a cliff around the islands

Public procedure DoSea;

Cut all elevations lower than sea level. If Transparency>0, the sea surface will not be flat, but a slight elevation change (unperceptible in 3D view) allow to fake transparency in the OnDrawTexture.

Public procedure DoSteps;

Discretise the heigthfield in a chosen number of steps

Public procedure StartPreparingData(heightData: TgxHeightData); override;

tTerrainRender event handler

Private procedure SetHeight(x, y: integer; const Value: single);

This item has no description.

Private procedure SetKeepNormals(const Value: boolean);

This item has no description.

Properties

Published property Cyclic: boolean read FCyclic write SetCyclic;

This item has no description.

Public property Heights[x,y: integer]: single read GetHeight write SetHeight;

x and y are range-checked and constrained into the array. This slows down computation. If you don't need to range-check (this is mainly useful in cyclic landscapes when you need a seamless joint), call fHeigth instead (this is a protected field, therefore only accessible from TgxFractalHDS descendents.

Public property KeepNormals: boolean read FKeepNormals write SetKeepNormals;

Keep the array of normals for future use

Public property LandTileInfo: TLandTileInfo read GetLandTileInfo write SetLandTileInfo;

Property used by TgxTiledRndLandscape to know where the landtile is located and other parameters. See tLandTileInfo

Public property MaxHeight: single read FMaxHeight;

Store the minimum and maximum elevations

Public property MinHeight: single read FMinHeight;

This item has no description.

Public property RangeHeight: single read FRangeHeight;

Max height - min height

Public property Size: integer read FSize;

Size of the square height array. With the middle-point algorithm, it is always Size = 2ˆN+1. In a cyclic landscape, the last row and columns are identical to the first.

Public property Task: string read FTask;

When long computations are running, this property contains the operation beeing processed.

Public property TaskProgress: integer read FTaskProgress;

A value between 0 and 100 indicating the percentage of completion


GXSysHelp v.2.5: GXS.RandomHDS: Class TgxFractalHDS

Class TgxFractalHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TgxFractalHDS = class(TgxCustomRandomHDS)

Description

Random landscape based on the middle-point displacement algorithm

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBaseRandomHDS
  • TgxCustomRandomHDS
  • TgxFractalHDS

Overview

Fields

Private | FAmplitude: integer;
Private | FDepth: integer;
Private | FRoughness: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildHeightField; overload; override;
Public | procedure BuildHeightField(const aDepth, aSeed, aAmplitude: integer); overload;
Private | procedure SetAmplitude(const Value: integer);
Private | procedure SetDepth(const Value: integer);
Private | procedure SetRoughness(const Value: single);

Properties

Published | property Amplitude: integer read fAmplitude write SetAmplitude;
Published | property Depth: integer read fDepth write SetDepth;
Published | property Roughness: single read fRoughness write SetRoughness;

Description

Fields

Private FAmplitude: integer;

This item has no description.

Private FDepth: integer;

This item has no description.

Private FRoughness: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure BuildHeightField; overload; override;

This item has no description. Showing description inherited from TgxCustomRandomHDS.BuildHeightField.

Generate the heightfield array, based on the topographical properties

Public procedure BuildHeightField(const aDepth, aSeed, aAmplitude: integer); overload;

This item has no description.

Private procedure SetAmplitude(const Value: integer);

This item has no description.

Private procedure SetDepth(const Value: integer);

This item has no description.

Private procedure SetRoughness(const Value: single);

This item has no description.

Properties

Published property Amplitude: integer read fAmplitude write SetAmplitude;

Proportional to the difference between highest and lowest altitude.

Published property Depth: integer read fDepth write SetDepth;

Number of levels in the fractal process. Depth defines the size of the landscape: Size = 2ˆDepth+1 . Good results are got with Depth>=6. Above 10 the landscape takes a lot of time to be generated.

Published property Roughness: single read fRoughness write SetRoughness;

The lower this parameter, the smoother the landscape. Takes value between 0 and 1


GXSysHelp v.2.5: GXS.RandomHDS: Record TRelativeCoordinate

Record TRelativeCoordinate

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TRelativeCoordinate = record

Description

This item has no description.

Overview

Fields

Public | DX: integer
Public | DZ: integer

Description

Fields

Public DX: integer

This item has no description.

Public DZ: integer


GXSysHelp v.2.5: GXS.RandomHDS: Class TgxTiledRndLandscape

Class TgxTiledRndLandscape

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TgxTiledRndLandscape = class(TgxBaseRandomHDS)

Description

Random Lansdscape with tiles

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBaseRandomHDS
  • TgxTiledRndLandscape

Overview

Fields

Private | FLandTileComputing: boolean;
Private | FExtentX: integer;
Private | FExtentZ: integer;
Private | FExtentXhalf: integer;
Private | FExtentZhalf: integer;
Private | fLandTileSize: integer;
Private | FSingleConstrain: TSingleClamp;
Private | FIntegerConstrain: TIntegerClamp;
Private | FTerrainRenderer: TgxTerrainRenderer;
Private | FCamera: TgxCamera;
Private | fOnCreateLandTile: TOnCreateLandTile;
Private | fOnCreateDefaultTile: TStartPreparingDataEvent;
Private | FIsDefaultTile: TIsDefaultTile;
Private | FSeed: integer;
Private | fBaseSeed: integer;
Private | fComputedLandTile: TLandTile;
Private | FLandTileCapacity: integer;
Private | FGenerationRadius: integer;
Private | FLandTileDensity: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function LandtileCount: integer;
Public | function TileDistance(const x1, z1, x2, z2: integer): single;
Public | function TileDistanceSquared(const x1, z1, x2, z2: integer): integer;
Public | function XMoveBoundary: single;
Public | function ZMoveBoundary: single;
Private | function fDefaultIsDefaultTile(x, z: integer): boolean;
Private | function GetTask: string;
Private | function GetTaskProgress: integer;
Public | procedure ApplyLighting(var aLandTile: TLandTile);
Public | procedure ApplyTexture(var aLandTile: TLandTile);
Public | procedure ApplyTopography(var aLandTile: TLandTile);
Public | procedure CameraPosition(var TileX, TileZ: integer);
Public | procedure CleanUp;
Public | procedure ConstrainCoordinates(var x, z: single); overload;
Public | procedure ConstrainCoordinates(var x, z: integer); overload;
Public | procedure FindLandTile(const x, z: single; var TileX, TileZ: integer);
Public | procedure Initialize(const aX, aZ: single); virtual;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;
Public | procedure Update;
Private | procedure fDefaultOnCreateDefaultTile(HeightData: TgxHeightData);
Private | procedure SetCamera(const Value: TgxCamera);
Private | procedure SetExtentX(const Value: integer);
Private | procedure SetExtentZ(const Value: integer);
Private | procedure SetGenerationRadius(const Value: integer);
Private | procedure SetIsDefaultTile(const Value: TIsDefaultTile);
Private | procedure SetLandTileCapacity(const Value: integer);
Private | procedure SetLandTileDensity(const Value: single);
Private | procedure SetOnCreateDefaultTile(const Value: TStartPreparingDataEvent);
Private | procedure SetOnCreateLandTile(const Value: TOnCreateLandTile);
Private | procedure SetSeed(const Value: integer);

Properties

Published | property Camera: TgxCamera read FCamera write SetCamera;
Published | property Cyclic: boolean read FCyclic write SetCyclic;
Published | property ExtentX: integer read FExtentX write SetExtentX;
Published | property ExtentZ: integer read FExtentZ write SetExtentZ;
Published | property GenerationRadius: integer read FGenerationRadius write SetGenerationRadius;
Public | property IsDefaultTile: TIsDefaultTile read FIsDefaultTile write SetIsDefaultTile;
Published | property LandTileCapacity: integer read FLandTileCapacity write SetLandTileCapacity;
Published | property LandTileDensity: single read FLandTileDensity write SetLandTileDensity;
Public | property LandTileSize: integer read fLandTileSize;
Public | property MapUpdating: boolean read FMapUpdating;
Public | property OnCreateLandTile: TOnCreateLandTile read fOnCreateLandTile write SetOnCreateLandTile;
Published | property Seed: integer read FSeed write SetSeed;
Public | property Task: string read GetTask;
Public | property TaskProgress: integer read GetTaskProgress;
Published | property TerrainRenderer: TgxTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

Description

Fields

Private FLandTileComputing: boolean;

This item has no description.

Private FExtentX: integer;

Is a landtile being computed?

Private FExtentZ: integer;

This item has no description.

Private FExtentXhalf: integer;

This item has no description.

Private FExtentZhalf: integer;

This item has no description.

Private fLandTileSize: integer;

This item has no description.

Private FSingleConstrain: TSingleClamp;

This item has no description.

Private FIntegerConstrain: TIntegerClamp;

This item has no description.

Private FTerrainRenderer: TgxTerrainRenderer;

This item has no description.

Private FCamera: TgxCamera;

This item has no description.

Private fOnCreateLandTile: TOnCreateLandTile;

This item has no description.

Private fOnCreateDefaultTile: TStartPreparingDataEvent;

This item has no description.

Private FIsDefaultTile: TIsDefaultTile;

This item has no description.

Private FSeed: integer;

This item has no description.

Private fBaseSeed: integer;

This item has no description.

Private fComputedLandTile: TLandTile;

This item has no description.

Private FLandTileCapacity: integer;

This item has no description.

Private FGenerationRadius: integer;

This item has no description.

Private FLandTileDensity: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LandtileCount: integer;

Number of landtile in memory

Public function TileDistance(const x1, z1, x2, z2: integer): single;

Distance between two landtiles

Public function TileDistanceSquared(const x1, z1, x2, z2: integer): integer;

Square of distance between two landtiles. Use this function to compare two distances.

Public function XMoveBoundary: single;

Use these boundaries with non-cyclic landscapes to constrain camera movements.

Public function ZMoveBoundary: single;

This item has no description.

Private function fDefaultIsDefaultTile(x, z: integer): boolean;

This item has no description.

Private function GetTask: string;

This item has no description.

Private function GetTaskProgress: integer;

This item has no description.

Public procedure ApplyLighting(var aLandTile: TLandTile);

This item has no description.

Public procedure ApplyTexture(var aLandTile: TLandTile);

This item has no description.

Public procedure ApplyTopography(var aLandTile: TLandTile);

This item has no description.

Public procedure CameraPosition(var TileX, TileZ: integer);

This item has no description.

Public procedure CleanUp;

This item has no description.

Public procedure ConstrainCoordinates(var x, z: single); overload;

Constrain x,y to be in the boundaries of the height field array. This is done in two way depending on the kind of landscape: Cyclic landscapes: mod Non-cyclic landscape: clamp

Public procedure ConstrainCoordinates(var x, z: integer); overload;

This item has no description.

Public procedure FindLandTile(const x, z: single; var TileX, TileZ: integer);

Compute the landtile containing (x,z)

Public procedure Initialize(const aX, aZ: single); virtual;

Build the first landtile and position the camera. Must be called first.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Public procedure Update;

This procedure check which landtiles must be generated or destroyed as a function of camera position. This is let to the descendent classes.

Private procedure fDefaultOnCreateDefaultTile(HeightData: TgxHeightData);

This item has no description.

Private procedure SetCamera(const Value: TgxCamera);

This item has no description.

Private procedure SetExtentX(const Value: integer);

This item has no description.

Private procedure SetExtentZ(const Value: integer);

This item has no description.

Private procedure SetGenerationRadius(const Value: integer);

This item has no description.

Private procedure SetIsDefaultTile(const Value: TIsDefaultTile);

This item has no description.

Private procedure SetLandTileCapacity(const Value: integer);

This item has no description.

Private procedure SetLandTileDensity(const Value: single);

This item has no description.

Private procedure SetOnCreateDefaultTile(const Value: TStartPreparingDataEvent);

This item has no description.

Private procedure SetOnCreateLandTile(const Value: TOnCreateLandTile);

This item has no description.

Private procedure SetSeed(const Value: integer);

This item has no description.

Properties

Published property Camera: TgxCamera read FCamera write SetCamera;

This item has no description.

Published property Cyclic: boolean read FCyclic write SetCyclic;

This item has no description.

Published property ExtentX: integer read FExtentX write SetExtentX;

Dimensions of the "infinite" landscape. Can be set very high. These parameters have neither memory nor speed consequence. They are mainly used to compute a unique seed for each landtile

Published property ExtentZ: integer read FExtentZ write SetExtentZ;

This item has no description.

Published property GenerationRadius: integer read FGenerationRadius write SetGenerationRadius;

Distance at which a new landtile begin to be built. Increasing this value allows for a higher camera speed but it will also increase the memory requirements.

Public property IsDefaultTile: TIsDefaultTile read FIsDefaultTile write SetIsDefaultTile;

User-supplied function determining if this landtile will be built by the OnCreateDefaultTile or if a landscape will be generated.

Published property LandTileCapacity: integer read FLandTileCapacity write SetLandTileCapacity;

Number of landtile to keep in memory. Should not be modified.

Published property LandTileDensity: single read FLandTileDensity write SetLandTileDensity;

Probability that a given landtile is non-default

Public property LandTileSize: integer read fLandTileSize;

Size of a landtile. Must be a power of two

Public property MapUpdating: boolean read FMapUpdating;

This item has no description.

Public property OnCreateLandTile: TOnCreateLandTile read fOnCreateLandTile write SetOnCreateLandTile;

User-specified event handler containing the particular code for tile generation

Published property Seed: integer read FSeed write SetSeed;

Base seed for the entire archipelago

Public property Task: string read GetTask;

When long computations are running, this property contains the operation beeing processed.

Public property TaskProgress: integer read GetTaskProgress;

A value between 0 and 100 indicating the percentage of completion

Published property TerrainRenderer: TgxTerrainRenderer read FTerrainRenderer write SetTerrainRenderer;

Terrain renderer linked to the HDS. Must be set just after creation.


GXSysHelp v.2.5: GXS.RandomHDS: Class TgxFractalArchipelago

Class TgxFractalArchipelago

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RandomHDS

Declaration

type TgxFractalArchipelago = class(TgxTiledRndLandscape)

Description

This item has no description. Showing description inherited from TgxTiledRndLandscape.

Random Lansdscape with tiles

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxBaseRandomHDS
  • TgxTiledRndLandscape
  • TgxFractalArchipelago

Overview

Fields

Private | FDepth: integer;
Private | FRoughnessMax: single;
Private | FRoughnessMin: single;
Private | FAmplitudeMin: integer;
Private | FAmplitudeMax: integer;
Private | FSeaDynamic: boolean;
Private | FSeaMaterialName: string;
Private | FWaveAmplitude: single;
Private | FWaveSpeed: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetIslandDensity: single;
Public | procedure ComputeLandTile(const aX, aZ: integer; var NewLandTile: TLandTile); override;
Private | procedure FPostRenderSeaDynamic(var rci: TgxRenderContextInfo; var HeightDatas: TList);
Private | procedure FPostRenderSeaStatic(var rci: TgxRenderContextInfo; var HeightDatas: TList);
Private | procedure SetAmplitudeMax(const Value: integer);
Private | procedure SetAmplitudeMin(const Value: integer);
Private | procedure SetDepth(const Value: integer);
Private | procedure SetIslandDensity(const Value: single);
Private | procedure SetRoughnessMax(const Value: single);
Private | procedure SetRoughnessMin(const Value: single);
Private | procedure SetSeaDynamic(const Value: boolean);
Private | procedure SetSeaMaterialName(const Value: string);
Private | procedure SetWaveAmplitude(const Value: single);
Private | procedure SetWaveSpeed(const Value: single);

Properties

Published | property AmplitudeMax: integer read FAmplitudeMax write SetAmplitudeMax;
Published | property AmplitudeMin: integer read FAmplitudeMin write SetAmplitudeMin;
Published | property Depth: integer read fDepth write SetDepth;
Published | property IslandDensity: single read GetIslandDensity write SetIslandDensity;
Published | property RoughnessMax: single read FRoughnessMax write SetRoughnessMax;
Published | property RoughnessMin: single read FRoughnessMin write SetRoughnessMin;
Published | property SeaDynamic: boolean read FSeaDynamic write SetSeaDynamic;
Published | property SeaMaterialName: string read FSeaMaterialName write SetSeaMaterialName;
Published | property WaveAmplitude: single read FWaveAmplitude write SetWaveAmplitude;
Published | property WaveSpeed: single read FWaveSpeed write SetWaveSpeed;

Description

Fields

Private FDepth: integer;

This item has no description.

Private FRoughnessMax: single;

This item has no description.

Private FRoughnessMin: single;

This item has no description.

Private FAmplitudeMin: integer;

This item has no description.

Private FAmplitudeMax: integer;

This item has no description.

Private FSeaDynamic: boolean;

This item has no description.

Private FSeaMaterialName: string;

This item has no description.

Private FWaveAmplitude: single;

This item has no description.

Private FWaveSpeed: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetIslandDensity: single;

This item has no description.

Public procedure ComputeLandTile(const aX, aZ: integer; var NewLandTile: TLandTile); override;

This item has no description.

Private procedure FPostRenderSeaDynamic(var rci: TgxRenderContextInfo; var HeightDatas: TList);

Sea with waves. Borrowed from Eric's Archipelago GLScene advanced demo

Private procedure FPostRenderSeaStatic(var rci: TgxRenderContextInfo; var HeightDatas: TList);

PostRender event handler drawing a static water plane between islands Code borrowed from Eric's Archipelago GLScene advanced demo

Private procedure SetAmplitudeMax(const Value: integer);

This item has no description.

Private procedure SetAmplitudeMin(const Value: integer);

This item has no description.

Private procedure SetDepth(const Value: integer);

This item has no description.

Private procedure SetIslandDensity(const Value: single);

This item has no description.

Private procedure SetRoughnessMax(const Value: single);

This item has no description.

Private procedure SetRoughnessMin(const Value: single);

This item has no description.

Private procedure SetSeaDynamic(const Value: boolean);

This item has no description.

Private procedure SetSeaMaterialName(const Value: string);

This item has no description.

Private procedure SetWaveAmplitude(const Value: single);

This item has no description.

Private procedure SetWaveSpeed(const Value: single);

This item has no description.

Properties

Published property AmplitudeMax: integer read FAmplitudeMax write SetAmplitudeMax;

Ranges for the amplitude parameter in the fractal algorithm

Published property AmplitudeMin: integer read FAmplitudeMin write SetAmplitudeMin;

This item has no description.

Published property Depth: integer read fDepth write SetDepth;

Depth of the fractal algorithm

Published property IslandDensity: single read GetIslandDensity write SetIslandDensity;

A wrapper for LandtileDensity. This is the probabilty for a landtile to contain an island.

Published property RoughnessMax: single read FRoughnessMax write SetRoughnessMax;

Ranges for the roughness parameter in the fractal algorithm

Published property RoughnessMin: single read FRoughnessMin write SetRoughnessMin;

This item has no description.

Published property SeaDynamic: boolean read FSeaDynamic write SetSeaDynamic;

If true, the sea will show dynamic waves. Slow.

Published property SeaMaterialName: string read FSeaMaterialName write SetSeaMaterialName;

Reference to a material in the TerrainRenderer's material library. This material will be used to drape the water plane.

Published property WaveAmplitude: single read FWaveAmplitude write SetWaveAmplitude;

Size of the waves

Published property WaveSpeed: single read FWaveSpeed write SetWaveSpeed;


GXSysHelp v.2.5: GXS.RegisterXCollection

Unit GXS.RegisterXCollection

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Register TXCollection property editor

Uses

  • System.Classes
  • System.TypInfo
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TClassProperty |
Class TXCollectionProperty |

Functions and Procedures

function GetOrdValueAt(Index: Integer): Longint;
function GetOrdValue: Longint;
procedure Register;

Types

TPropertyAttribute = (...);
TPropertyAttributes = set of TPropertyAttribute;

Description

Functions and Procedures

function GetOrdValueAt(Index: Integer): Longint;

This item has no description.

function GetOrdValue: Longint;

This item has no description.

procedure Register;

This item has no description.

Types

TPropertyAttribute = (...);

DesignIntf, DesignEditors,

Values
  • paValueList
  • paSubProperties
  • paDialog
  • paMultiSelect
  • paAutoUpdate
  • paSortList
  • paReadOnly
  • paRevertable
  • paFullWidthName
  • paVolatileSubProperties
  • paFMX
  • paNotNestable
  • paDisplayReadOnly
  • paCustomDropDown
  • paValueEditable
TPropertyAttributes = set of TPropertyAttribute;


GXSysHelp v.2.5: GXS.RegisterXCollection: Class TClassProperty

Class TClassProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RegisterXCollection

Declaration

type TClassProperty = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes;
Public | function GetValue: string;
Public | procedure GetProperties(Proc: TGetChildProc);

Description

Methods

Public function GetAttributes: TPropertyAttributes;

class(TPropertyEditor)

Public function GetValue: string;

in VCL -> (Proc: TGetPropProc) //override; <- not found in base class

Public procedure GetProperties(Proc: TGetChildProc);

override; <- not found in base class


GXSysHelp v.2.5: GXS.RegisterXCollection: Class TXCollectionProperty

Class TXCollectionProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RegisterXCollection

Declaration

type TXCollectionProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TXCollectionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes;
Public | procedure Edit;

Description

Methods

Public function GetAttributes: TPropertyAttributes;

This item has no description.

Public procedure Edit;

override; <- not found in base class


GXSysHelp v.2.5: GXS.RenderContextInfo

Unit GXS.RenderContextInfo

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.State
  • GLScene.PipelineTransform
  • GXS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGXSize |
Record TGXRenderContextClippingInfo |
Record TgxRenderContextInfo |

Types

PGXRenderContextInfo = ˆTgxRenderContextInfo;
TGXDrawState = (...);
TgxObjectsSorting = (...);
TgxVisibilityCulling = (...);

Description

Types

PGXRenderContextInfo = ˆTgxRenderContextInfo;

This item has no description.

TGXDrawState = (...);

This item has no description.

Values
  • dsRendering
  • dsPicking
  • dsPrinting
TgxObjectsSorting = (...);

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.

Values
  • osInherited
  • osNone
  • osRenderFarthestFirst
  • osRenderBlendedLast
  • osRenderNearestFirst
TgxVisibilityCulling = (...);

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

Values
  • vcInherited
  • vcNone
  • vcObjectBased
  • vcHierarchical


GXSysHelp v.2.5: GXS.RenderContextInfo: Record TGXSize

Record TGXSize

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RenderContextInfo

Declaration

type TGXSize = record

Description

This item has no description.

Overview

Fields

Public | cx: Longint;
Public | cy: Longint;

Description

Fields

Public cx: Longint;

This item has no description.

Public cy: Longint;


GXSysHelp v.2.5: GXS.RenderContextInfo: Record TGXRenderContextClippingInfo

Record TGXRenderContextClippingInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RenderContextInfo

Declaration

type TGXRenderContextClippingInfo = record

Description

This item has no description.

Overview

Fields

Public | origin: TVector4f;
Public | clippingDirection: TVector4f;
Public | viewPortRadius: Single;
Public | nearClippingDistance: Single;
Public | farClippingDistance: Single;
Public | frustum: TFrustum;

Description

Fields

Public origin: TVector4f;

This item has no description.

Public clippingDirection: TVector4f;

This item has no description.

Public viewPortRadius: Single;

This item has no description.

Public nearClippingDistance: Single;

viewport bounding radius per distance unit

Public farClippingDistance: Single;

This item has no description.

Public frustum: TFrustum;


GXSysHelp v.2.5: GXS.RenderContextInfo: Record TgxRenderContextInfo

Record TgxRenderContextInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.RenderContextInfo

Declaration

type TgxRenderContextInfo = record

Description

Stores contextual info useful during rendering methods.

Overview

Fields

Public | scene: TObject;
Public | buffer: TObject;
Public | cameraPosition: TVector4f;
Public | cameraDirection: TVector4f;
Public | cameraUp: TVector4f;
Public | viewPortSize: TGXSize;
Public | renderDPI: Integer;
Public | materialLibrary: TObject;
Public | lightmapLibrary: TObject;
Public | fogDisabledCounter: Integer;
Public | drawState: TGXDrawState;
Public | objectsSorting: TgxObjectsSorting;
Public | visibilityCulling: TgxVisibilityCulling;
Public | gxStates: TgxStateCache;
Public | PipelineTransformation: TgTransformation;
Public | rcci: TGXRenderContextClippingInfo;
Public | sceneAmbientColor: TgxColorVector;
Public | bufferFaceCull: Boolean;
Public | bufferLighting: Boolean;
Public | bufferFog: Boolean;
Public | bufferDepthTest: Boolean;
Public | proxySubObject: Boolean;
Public | ignoreMaterials: Boolean;
Public | ignoreBlendingRequests: Boolean;
Public | ignoreDepthRequests: Boolean;
Public | amalgamating: Boolean;
Public | lights: TgxPersistentObjectList;
Public | afterRenderEffects: TgxPersistentObjectList;
Public | currentMaterialLevel: TgxMaterialLevel;
Public | primitiveMask: TgxMeshPrimitives;
Public | orderCounter: Integer;

Description

Fields

Public scene: TObject;

This item has no description.

Public buffer: TObject;

usually TgxScene

Public cameraPosition: TVector4f;

usually TgxSceneBuffer

Public cameraDirection: TVector4f;

This item has no description.

Public cameraUp: TVector4f;

This item has no description.

Public viewPortSize: TGXSize;

This item has no description.

Public renderDPI: Integer;

This item has no description.

Public materialLibrary: TObject;

This item has no description.

Public lightmapLibrary: TObject;

usually TgxMaterialLibrary;

Public fogDisabledCounter: Integer;

usually TgxMaterialLibrary;

Public drawState: TGXDrawState;

This item has no description.

Public objectsSorting: TgxObjectsSorting;

This item has no description.

Public visibilityCulling: TgxVisibilityCulling;

This item has no description.

Public gxStates: TgxStateCache;

This item has no description.

Public PipelineTransformation: TgTransformation;

This item has no description.

Public rcci: TGXRenderContextClippingInfo;

This item has no description.

Public sceneAmbientColor: TgxColorVector;

This item has no description.

Public bufferFaceCull: Boolean;

This item has no description.

Public bufferLighting: Boolean;

This item has no description.

Public bufferFog: Boolean;

This item has no description.

Public bufferDepthTest: Boolean;

This item has no description.

Public proxySubObject: Boolean;

This item has no description.

Public ignoreMaterials: Boolean;

This item has no description.

Public ignoreBlendingRequests: Boolean;

This item has no description.

Public ignoreDepthRequests: Boolean;

This item has no description.

Public amalgamating: Boolean;

This item has no description.

Public lights: TgxPersistentObjectList;

This item has no description.

Public afterRenderEffects: TgxPersistentObjectList;

This item has no description.

Public currentMaterialLevel: TgxMaterialLevel;

This item has no description.

Public primitiveMask: TgxMeshPrimitives;

This item has no description.

Public orderCounter: Integer;


GXSysHelp v.2.5: GXS.ROAMPatch

Unit GXS.ROAMPatch

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.SysUtils
  • GLScene.OpenGL4
  • GLScene.VectorTypes
  • GXS.XOpenGL
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GLScene.Strings
  • GXS.HeightData
  • GXS.Isolines
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLROAMException |
Packed Record TgxROAMTriangleNode |
Packed Record TgxROAMRenderPoint |
Class TgxROAMPatch |

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: Integer);
function GetROAMTrianglesCapacity: Integer;
procedure DrawContours(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; ContourInterval: Integer; ContourWidth: Integer; DecVal: Integer);

Types

PROAMTriangleNode = ˆTgxROAMTriangleNode;

Description

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: Integer);

Specifies the maximum number of ROAM triangles that may be allocated.

function GetROAMTrianglesCapacity: Integer;

This item has no description.

procedure DrawContours(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; ContourInterval: Integer; ContourWidth: Integer; DecVal: Integer);

Draw contours on rendering terrain patches

Types

PROAMTriangleNode = ˆTgxROAMTriangleNode;


GXSysHelp v.2.5: GXS.ROAMPatch: Class EGLROAMException

Class EGLROAMException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ROAMPatch

Declaration

type EGLROAMException = class(Exception)

Description

GL_ARB_vertex_buffer_object Exception use by splitter for SafeTesselation

Hierarchy

  • TObject
  • Exception
  • EGLROAMException


GXSysHelp v.2.5: GXS.ROAMPatch: Packed Record TgxROAMTriangleNode

Packed Record TgxROAMTriangleNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ROAMPatch

Declaration

type TgxROAMTriangleNode = packed record

Description

This item has no description.

Overview

Fields

Public | Base: PROAMTriangleNode;
Public | Left: PROAMTriangleNode;
Public | Right: PROAMTriangleNode;
Public | LeftChild: PROAMTriangleNode;
Public | RightChild: PROAMTriangleNode;

Description

Fields

Public Base: PROAMTriangleNode;

This item has no description.

Public Left: PROAMTriangleNode;

This item has no description.

Public Right: PROAMTriangleNode;

This item has no description.

Public LeftChild: PROAMTriangleNode;

This item has no description.

Public RightChild: PROAMTriangleNode;


GXSysHelp v.2.5: GXS.ROAMPatch: Packed Record TgxROAMRenderPoint

Packed Record TgxROAMRenderPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ROAMPatch

Declaration

type TgxROAMRenderPoint = packed record

Description

This item has no description.

Overview

Fields

Public | X: Integer;
Public | Y: Integer;
Public | Idx: Integer;

Description

Fields

Public X: Integer;

This item has no description.

Public Y: Integer;

This item has no description.

Public Idx: Integer;


GXSysHelp v.2.5: GXS.ROAMPatch: Class TgxROAMPatch

Class TgxROAMPatch

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ROAMPatch

Declaration

type TgxROAMPatch = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxROAMPatch

Overview

Fields

Private | FID: Integer;
Private | FHeightData: TgxHeightData;
Private | FHeightRaster: PSmallIntRaster;
Private | FTLNode: PROAMTriangleNode;
Private | FBRNode: PROAMTriangleNode;
Private | FTLVariance: array of cardinal;
Private | FBRVariance: array of cardinal;
Private | FPatchSize: Integer;
Private | FTriangleCount: Integer;
Private | FListHandle: TgxListHandle;
Private | FTag: Integer;
Private | FObserverPosition: TAffineVector;
Private | FNorth: TgxROAMPatch;
Private | FSouth: TgxROAMPatch;
Private | FWest: TgxROAMPatch;
Private | FEast: TgxROAMPatch;
Private | FHighRes: Boolean;
Private | FMaxDepth: Integer;
Private | FVertexScale: TAffineVector;
Private | FVertexOffset: TAffineVector;
Private | FTextureScale: TAffineVector;
Private | FTextureOffset: TAffineVector;
Private | FMaxTLVarianceDepth: Integer;
Private | FMaxBRVarianceDepth: Integer;
Private | FOcclusionQuery: TgxOcclusionQueryHandle;
Private | FOcclusionSkip: Integer;
Private | FOcclusionCounter: Integer;
Private | FLastOcclusionTestPassed: Boolean;
Private | FContourInterval: Integer;
Private | FContourWidth: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function SafeTesselate: Boolean;
Public | function Tesselate: Boolean;
Public | procedure ComputeVariance(Variance: Integer);
Public | procedure ConnectToTheNorth(NorthPatch: TgxROAMPatch);
Public | procedure ConnectToTheWest(WestPatch: TgxROAMPatch);
Public | class procedure FlushAccum(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList);
Public | procedure RenderAccum(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList; AutoFlushVertexCount: Integer);
Public | procedure RenderHighRes(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList; ForceROAM: Boolean);
Public | procedure ResetTessellation;

Properties

Public | property ContourInterval: Integer read FContourInterval write FContourInterval default 0;
Public | property ContourWidth: Integer read FContourWidth write FContourWidth default 1;
Public | property HeightData: TgxHeightData read FHeightData write SetHeightData;
Public | property HighRes: Boolean read FHighRes write FHighRes;
Public | property ID: Integer read FID;
Public | property LastOcclusionTestPassed: Boolean read FLastOcclusionTestPassed;
Public | property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;
Public | property OcclusionCounter: Integer read FOcclusionCounter write FOcclusionCounter;
Public | property OcclusionSkip: Integer read FOcclusionSkip write SetOcclusionSkip;
Public | property Tag: Integer read FTag write FTag;
Public | property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;
Public | property TextureScale: TAffineVector read FTextureScale write FTextureScale;
Public | property TriangleCount: Integer read FTriangleCount;
Public | property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;
Public | property VertexScale: TAffineVector read FVertexScale write FVertexScale;

Description

Fields

Private FID: Integer;

This item has no description.

Private FHeightData: TgxHeightData;

This item has no description.

Private FHeightRaster: PSmallIntRaster;

Referred, not owned

Private FTLNode: PROAMTriangleNode;

This item has no description.

Private FBRNode: PROAMTriangleNode;

This item has no description.

Private FTLVariance: array of cardinal;

This item has no description.

Private FBRVariance: array of cardinal;

This item has no description.

Private FPatchSize: Integer;

This item has no description.

Private FTriangleCount: Integer;

This item has no description.

Private FListHandle: TgxListHandle;

This item has no description.

Private FTag: Integer;

This item has no description.

Private FObserverPosition: TAffineVector;

This item has no description.

Private FNorth: TgxROAMPatch;

This item has no description.

Private FSouth: TgxROAMPatch;

This item has no description.

Private FWest: TgxROAMPatch;

This item has no description.

Private FEast: TgxROAMPatch;

This item has no description.

Private FHighRes: Boolean;

neighbours

Private FMaxDepth: Integer;

This item has no description.

Private FVertexScale: TAffineVector;

This item has no description.

Private FVertexOffset: TAffineVector;

This item has no description.

Private FTextureScale: TAffineVector;

This item has no description.

Private FTextureOffset: TAffineVector;

This item has no description.

Private FMaxTLVarianceDepth: Integer;

This item has no description.

Private FMaxBRVarianceDepth: Integer;

This item has no description.

Private FOcclusionQuery: TgxOcclusionQueryHandle;

This item has no description.

Private FOcclusionSkip: Integer;

This item has no description.

Private FOcclusionCounter: Integer;

This item has no description.

Private FLastOcclusionTestPassed: Boolean;

This item has no description.

Private FContourInterval: Integer;

This item has no description.

Private FContourWidth: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function SafeTesselate: Boolean;

AV free version of Tesselate. When IncreaseTrianglesCapacity is called, all PROAMTriangleNode values in higher function became invalid due to the memory shifting. Recursivity is the main problem, that's why SafeTesselate is calling Tesselate in a try..except.

Public function Tesselate: Boolean;

Returns false if MaxCLODTriangles limit is reached(Lin)

Public procedure ComputeVariance(Variance: Integer);

This item has no description.

Public procedure ConnectToTheNorth(NorthPatch: TgxROAMPatch);

This item has no description.

Public procedure ConnectToTheWest(WestPatch: TgxROAMPatch);

This item has no description.

Public class procedure FlushAccum(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList);

Render all vertices accumulated in the arrays and set their count back to zero.

Public procedure RenderAccum(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList; AutoFlushVertexCount: Integer);

Render the patch by accumulating triangles. The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check). Once at least autoFlushVertexCount vertices have been accumulated, perform a FlushAccum

Public procedure RenderHighRes(Vertices: TgxAffineVectorList; VertexIndices: TgxIntegerList; TexCoords: TgxTexPointList; ForceROAM: Boolean);

Render the patch in high-resolution. The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check). High-resolution renders use display lists, and are assumed to be made together.

Public procedure ResetTessellation;

This item has no description.

Properties

Public property ContourInterval: Integer read FContourInterval write FContourInterval default 0;

Distance between contours - zero (default) for no contours

Public property ContourWidth: Integer read FContourWidth write FContourWidth default 1;

Width of contours

Public property HeightData: TgxHeightData read FHeightData write SetHeightData;

This item has no description.

Public property HighRes: Boolean read FHighRes write FHighRes;

This item has no description.

Public property ID: Integer read FID;

This item has no description.

Public property LastOcclusionTestPassed: Boolean read FLastOcclusionTestPassed;

Result for the last occlusion test. Note that this value is updated upon rendering the tile in non-high-res mode only.

Public property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;

This item has no description.

Public property OcclusionCounter: Integer read FOcclusionCounter write FOcclusionCounter;

Number of frames remaining to next occlusion test.

Public property OcclusionSkip: Integer read FOcclusionSkip write SetOcclusionSkip;

Number of frames to skip after an occlusion test returned zero pixels.

Public property Tag: Integer read FTag write FTag;

This item has no description.

Public property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;

This item has no description.

Public property TextureScale: TAffineVector read FTextureScale write FTextureScale;

This item has no description.

Public property TriangleCount: Integer read FTriangleCount;

This item has no description.

Public property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;

This item has no description.

Public property VertexScale: TAffineVector read FVertexScale write FVertexScale;


GXSysHelp v.2.5: GXS.Scene

Unit GXS.Scene

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Math
  • FMX.Graphics
  • FMX.Controls
  • FMX.Types
  • FMX.Dialogs
  • GLScene.OpenGLTokens
  • GLScene.XCollection
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.GeometryBB
  • GLScene.TextureFormat
  • GLScene.Strings
  • GLScene.Utils
  • GLScene.PipelineTransform
  • GXS.BaseClasses
  • GXS.Coordinates
  • GXS.VectorLists
  • GXS.Color
  • GXS.XOpenGL
  • GXS.PersistentClasses
  • GXS.ApplicationFileIO
  • GXS.Context
  • GXS.Silhouette
  • GXS.State
  • GXS.Graphics
  • GXS.Texture
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.Selection
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IgxInitializable |
Class TgxInitializableObjectList |
Class TgxBaseSceneObject |
Class TgxBaseBehaviour |
Class TgxBehaviour |
Class TgxBehaviours |
Class TgxEffect |
Class TgxObjectPreEffect |
Class TgxObjectPostEffect |
Class TgxObjectAfterEffect |
Class TgxEffects |
Class TgxCustomSceneObject |
Class TgxSceneRootObject |
Class TgxImmaterialSceneObject |
Class TgxCameraInvariantObject |
Class TgxSceneObject |
Class TgxDirectOpenGL |
Class TgxRenderPoint |
Class TgxProxyObject |
Class TgxLightSource |
Class TgxCamera |
Class TgxScene |
Class TgxFogEnvironment |
Class TgxSceneBuffer |
Class TgxNonVisualViewer |
Class TgxMemoryViewer |

Functions and Procedures

procedure RegisterBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure RegisterBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure AxesBuildList(var rci: TgxRenderContextInfo; pattern: Word; AxisLen: Single);
procedure RegisterInfoForm(infoForm: TInvokeInfoForm);
procedure InvokeInfoForm(aSceneBuffer: TgxSceneBuffer; Modal: Boolean);
function GetCurrentRenderingObject: TgxBaseSceneObject;

Types

TDirectRenderEvent = procedure(Sender: TObject; var rci: TgxRenderContextInfo) of object;
TgxBehaviourClass = class of TgxBehaviour;
TgxCameraInvarianceMode = (...);
TgxCameraKeepFOVMode = (...);
TgxCameraStyle = (...);
TgxColorDepth = (...);
TgxContextOption = (...);
TgxContextOptions = set of TgxContextOption;
TgxDepthPrecision = (...);
TgxEffectClass = class of TgxEffect;
TgxFogDistance = (...);
TgxFogMode = (...);
TgxLightStyle = (...);
TgxLimitType = (...);
TgxNormalDirection = (...);
TgxObjectBBChange = (...);
TgxObjectBBChanges = set of TgxObjectBBChange;
TgxObjectChange = (...);
TgxObjectChanges = set of TgxObjectChange;
TgxObjectStyle = (...);
TgxObjectStyles = set of TgxObjectStyle;
TgxOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;
TgxProxyObjectClass = class of TgxProxyObject;
TgxProxyObjectOption = (...);
TgxProxyObjectOptions = set of TgxProxyObjectOption;
TgxSceneObjectClass = class of TgxBaseSceneObject;
TgxSceneOperation = (...);
TgxSceneViewerMode = (...);
TgxShadeModel = (...);
TInvokeInfoForm = procedure(aSceneBuffer: TgxSceneBuffer; Modal: Boolean);

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];
SCENE_REVISION = '$Revision: 2024$';
SCENE_VERSION = 'v2.5 %s';

Variables

vCounterFrequency: Int64;
vCurrentRenderingObject: TgxBaseSceneObject;

Description

Functions and Procedures

procedure RegisterBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TgxBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FSceneEdit in the IDE.

procedure DeRegisterBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.

procedure RegisterBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TgxBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

procedure DeRegisterBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.

procedure AxesBuildList(var rci: TgxRenderContextInfo; pattern: Word; AxisLen: Single);

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

procedure RegisterInfoForm(infoForm: TInvokeInfoForm);

Registers the procedure call used to invoke the info form.

procedure InvokeInfoForm(aSceneBuffer: TgxSceneBuffer; Modal: Boolean);

This item has no description.

function GetCurrentRenderingObject: TgxBaseSceneObject;

This item has no description.

Types

TDirectRenderEvent = procedure(Sender: TObject; var rci: TgxRenderContextInfo) of object;

Event for user-specific rendering in a TgxDirectOpenVX object.

TgxBehaviourClass = class of TgxBehaviour;

This item has no description.

TgxCameraInvarianceMode = (...);

This item has no description.

Values
  • cimNone
  • cimPosition
  • cimOrientation
TgxCameraKeepFOVMode = (...);

This item has no description.

Values
  • ckmHorizontalFOV
  • ckmVerticalFOV
TgxCameraStyle = (...);

This item has no description.

Values
  • csPerspective
  • csOrthogonal
  • csOrtho2D
  • csCustom
  • csInfinitePerspective
  • csPerspectiveKeepFOV
TgxColorDepth = (...);

This item has no description.

Values
  • cdDefault
  • cd8bits
  • cd16bits
  • cd24bits
  • cdFloat64bits
  • cdFloat128bits
TgxContextOption = (...);

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (it needs a stereo device to test...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context

Values
  • roSoftwareMode
  • roDoubleBuffer
  • roStencilBuffer
  • roRenderToWindow
  • roTwoSideLighting
  • roStereo
  • roDestinationAlpha
  • roNoColorBuffer
  • roNoColorBufferClear
  • roNoSwapBuffers
  • roNoDepthBufferClear
  • roDebugContext
  • roForwardContext
  • roOpenGL_ES2_Context
TgxContextOptions = set of TgxContextOption;

This item has no description.

TgxDepthPrecision = (...);

This item has no description.

Values
  • dpDefault
  • dp16bits
  • dp24bits
  • dp32bits
TgxEffectClass = class of TgxEffect;

This item has no description.

TgxFogDistance = (...);

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

Values
  • fdDefault
  • fdEyeRadial
  • fdEyePlane
TgxFogMode = (...);

This item has no description.

Values
  • fmLinear
  • fmExp
  • fmExp2
TgxLightStyle = (...);

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)

Values
  • lsSpot
  • lsOmni
  • lsParallel
  • lsParallelSpot
TgxLimitType = (...);

IDs for limit determination

Values
  • limClipPlanes
  • limEvalOrder
  • limLights
  • limListNesting
  • limModelViewStack
  • limNameStack
  • limPixelMapTable
  • limProjectionStack
  • limTextureSize
  • limTextureStack
  • limViewportDims
  • limAccumAlphaBits
  • limAccumBlueBits
  • limAccumGreenBits
  • limAccumRedBits
  • limAlphaBits
  • limAuxBuffers
  • limBlueBits
  • limGreenBits
  • limRedBits
  • limIndexBits
  • limStereo
  • limDoubleBuffer
  • limSubpixelBits
  • limDepthBits
  • limStencilBits
  • limNbTextureUnits
TgxNormalDirection = (...);

This item has no description.

Values
  • ndInside
  • ndOutside
TgxObjectBBChange = (...);

This item has no description.

Values
  • oBBcChild
  • oBBcStructure
TgxObjectBBChanges = set of TgxObjectBBChange;

This item has no description.

TgxObjectChange = (...);

Used to describe only the changes in an object, which have to be reflected in the scene

Values
  • ocTransformation
  • ocAbsoluteMatrix
  • ocInvAbsoluteMatrix
  • ocStructure
TgxObjectChanges = set of TgxObjectChange;

This item has no description.

TgxObjectStyle = (...);

Possible styles/options for objects. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered

Values
  • osDirectDraw
  • osIgnoreDepthBuffer
  • osNoVisibilityCulling
TgxObjectStyles = set of TgxObjectStyle;

This item has no description.

TgxOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;

This item has no description.

TgxProxyObjectClass = class of TgxProxyObject;

This item has no description.

TgxProxyObjectOption = (...);

Defines which features are taken from the master object.

Values
  • pooEffects
  • pooObjects
  • pooTransformation
TgxProxyObjectOptions = set of TgxProxyObjectOption;

This item has no description.

TgxSceneObjectClass = class of TgxBaseSceneObject;

This item has no description.

TgxSceneOperation = (...);

Flags for design notification

Values
  • soAdd
  • soRemove
  • soMove
  • soRename
  • soSelect
  • soBeginUpdate
  • soEndUpdate
TgxSceneViewerMode = (...);

This item has no description.

Values
  • svmDisabled
  • svmDefault
  • svmNavigation
  • svmGizmo
TgxShadeModel = (...);

float_type

Values
  • smDefault
  • smSmooth
  • smFlat
TInvokeInfoForm = procedure(aSceneBuffer: TgxSceneBuffer; Modal: Boolean);

This item has no description.

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];

This item has no description.

SCENE_REVISION = '$Revision: 2024$';

This item has no description.

SCENE_VERSION = 'v2.5 %s';

This item has no description.

Variables

vCounterFrequency: Int64;

This item has no description.

vCurrentRenderingObject: TgxBaseSceneObject;


GXSysHelp v.2.5: GXS.Scene: Interface IgxInitializable

Interface IgxInitializable

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type IgxInitializable = interface(IInterface)

Description

Interface to objects that need initialization

Attributes
GUID['{EA40AE8E-79B3-42F5-ADF2-7A901B665E12}']

Hierarchy

  • IInterface
  • IgxInitializable

Overview

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TgxRenderContextInfo);

Description

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TgxRenderContextInfo);


GXSysHelp v.2.5: GXS.Scene: Class TgxInitializableObjectList

Class TgxInitializableObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxInitializableObjectList = class(TList)

Description

Just a list of objects that support IGLInitializable.

Hierarchy

  • TObject
  • TList
  • TgxInitializableObjectList

Overview

Methods

Public | function Add(const Item: IgxInitializable): Integer;
Private | function GetItems(const Index: Integer): IgxInitializable;
Private | procedure PutItems(const Index: Integer; const Value: IgxInitializable);

Properties

Public property Items[const Index: Integer]: IgxInitializable read GetItems write PutItems;

Description

Methods

Public function Add(const Item: IgxInitializable): Integer;

This item has no description.

Private function GetItems(const Index: Integer): IgxInitializable;

This item has no description.

Private procedure PutItems(const Index: Integer; const Value: IgxInitializable);

This item has no description.

Properties

Public property Items[const Index: Integer]: IgxInitializable read GetItems write PutItems;


GXSysHelp v.2.5: GXS.Scene: Class TgxBaseSceneObject

Class TgxBaseSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxBaseSceneObject = class(TgxCoordinatesUpdateAbleComponent)

Description

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject

Overview

Fields

Private | FAbsoluteMatrix: TMatrix4f;
Private | FInvAbsoluteMatrix: TMatrix4f;
Private | FLocalMatrix: TMatrix4f;
Private | FObjectStyle: TgxObjectStyles;
Private | FListHandle: TgxListHandle;
Private | FPosition: TgxCoordinates;
Private | FDirection: TgxCoordinates;
Private | FUp: TgxCoordinates;
Private | FScaling: TgxCoordinates;
Private | FChanges: TgxObjectChanges;
Private | FParent: TgxBaseSceneObject;
Private | FScene: TgxScene;
Private | FBBChanges: TgxObjectBBChanges;
Private | FBoundingBoxPersonalUnscaled: THmgBoundingBox;
Private | FBoundingBoxOfChildren: THmgBoundingBox;
Private | FBoundingBoxIncludingChildren: THmgBoundingBox;
Private | FChildren: TgxPersistentObjectList;
Private | FVisible: Boolean;
Private | FUpdateCount: Integer;
Private | FShowAxes: Boolean;
Private | FRotation: TgxCoordinates;
Private | FIsCalculating: Boolean;
Private | FObjectsSorting: TgxObjectsSorting;
Private | FVisibilityCulling: TgxVisibilityCulling;
Private | FOnProgress: TgxProgressEvent;
Private | FOnAddedToParent: TNotifyEvent;
Private | FBehaviours: TgxBehaviours;
Private | FEffects: TgxEffects;
Private | FPickable: Boolean;
Private | FOnPicked: TNotifyEvent;
Private | FTagObject: TObject;
Private | FTagFloat: Single;
Private | ObjList: TgxPersistentObjectList;
Private | DistList: TgxSingleList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | constructor CreateAsChild(aParentOwner: TgxBaseSceneObject);
Public | destructor Destroy; override;
Public | function AbsoluteLeft: TVector4f;
Public | function AbsoluteMatrixAsAddress: PMatrix4f;
Public | function AbsolutePositionAsAddress: PVector4f;
Public | function AbsoluteRight: TVector4f;
Public | function AbsoluteToLocal(const v: TVector4f): TVector4f; overload;
Public | function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;
Public | function AbsoluteXVector: TVector4f;
Public | function AbsoluteYVector: TVector4f;
Public | function AbsoluteZVector: TVector4f;
Public | function AddNewBehaviour(aBehaviour: TgxBehaviourClass): TgxBehaviour;
Public | function AddNewChild(AChild: TgxSceneObjectClass): TgxBaseSceneObject; virtual;
Public | function AddNewChildFirst(AChild: TgxSceneObjectClass): TgxBaseSceneObject; virtual;
Public | function AddNewEffect(anEffect: TgxEffectClass): TgxEffect;
Public | function AffineLeftVector: TAffineVector; inline;
Public | function AffineRight: TAffineVector; inline;
Public | function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;
Public | function AxisAlignedBoundingBoxAbsoluteEx: TAABB;
Public | function AxisAlignedBoundingBoxEx: TAABB;
Public | function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedDimensions: TVector4f; virtual;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; virtual;
Public | function BarycenterAbsolutePosition: TVector4f; virtual;
Public | function BarycenterSqrDistanceTo(const pt: TVector4f): Single;
Public | function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxIncludingChildrenEx: THmgBoundingBox;
Public | function BoundingBoxOfChildrenEx: THmgBoundingBox;
Public | function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;
Public | function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingSphereRadius: Single; inline;
Public | function BoundingSphereRadiusUnscaled: Single; inline;
Public | function DistanceTo(const pt: TVector4f): Single; overload;
Public | function DistanceTo(const pt: TAffineVector): Single; overload;
Public | function DistanceTo(anObject: TgxBaseSceneObject): Single; overload;
Public | function FindChild(const aName: string; ownChildrenOnly: Boolean): TgxBaseSceneObject;
Public | function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; virtual;
Public | function GetHandle(var rci: TgxRenderContextInfo): Cardinal;
Public | function GetOrCreateBehaviour(aBehaviour: TgxBehaviourClass): TgxBehaviour;
Public | function GetOrCreateEffect(anEffect: TgxEffectClass): TgxEffect;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override; final;
Public | function HasSubChildren: Boolean;
Public | function IndexOfChild(AChild: TgxBaseSceneObject): Integer;
Public | function InvAbsoluteMatrix: TMatrix4f; inline;
Public | function InvAbsoluteMatrixAsAddress: PMatrix4f;
Public | function IsUpdating: Boolean; inline;
Public | function LeftVector: TVector4f; inline;
Public | function ListHandleAllocated: Boolean; inline;
Public | function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;
Public | function LocalToAbsolute(const v: TVector4f): TVector4f; overload;
Public | function PointInObject(const point: TVector4f): Boolean; virtual;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; virtual;
Public | function Right: TVector4f; inline;
Public | function SqrDistanceTo(const pt: TVector4f): Single; overload;
Public | function SqrDistanceTo(const pt: TAffineVector): Single; overload;
Public | function SqrDistanceTo(anObject: TgxBaseSceneObject): Single; overload;
Private | function Get(Index: Integer): TgxBaseSceneObject; inline;
Private | function GetAbsoluteAffineScale: TAffineVector;
Private | function GetAbsoluteMatrix: TMatrix4f; inline;
Private | function GetAbsoluteScale: TVector4f;
Private | function GetBehaviours: TgxBehaviours;
Private | function GetCount: Integer; inline;
Private | function GetDirectAbsoluteMatrix: PMatrix4f;
Private | function GetEffects: TgxEffects;
Private | function GetIndex: Integer; inline;
Private | function GetLocalMatrix: PMatrix4f; inline;
Private | function GetMatrix: PMatrix4f; inline;
Private | function GetPitchAngle: Single; inline;
Private | function GetRollAngle: Single; inline;
Private | function GetTurnAngle: Single; inline;
Public | procedure AddChild(AChild: TgxBaseSceneObject); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate; inline;
Public | procedure BuildList(var rci: TgxRenderContextInfo); virtual;
Public | procedure ClearStructureChanged; inline;
Public | procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;
Public | procedure DeleteChildren; virtual;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;
Public | procedure EndUpdate; inline;
Public | procedure ExchangeChildren(anIndex1, anIndex2: Integer);
Public | procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);
Public | procedure ForceLocalMatrix(const aMatrix: TMatrix4f); inline;
Public | procedure Insert(AIndex: Integer; AChild: TgxBaseSceneObject); virtual;
Public | procedure Lift(ADistance: Single);
Public | procedure Move(ADistance: Single);
Public | procedure MoveChildDown(anIndex: Integer);
Public | procedure MoveChildFirst(anIndex: Integer);
Public | procedure MoveChildLast(anIndex: Integer);
Public | procedure MoveChildUp(anIndex: Integer);
Public | procedure MoveDown;
Public | procedure MoveFirst;
Public | procedure MoveLast;
Public | procedure MoveObjectAllAround(anObject: TgxBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveObjectAround(anObject: TgxBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveTo(newParent: TgxBaseSceneObject); virtual;
Public | procedure MoveUp;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Pitch(angle: Single);
Public | procedure PointTo(const ATargetObject: TgxBaseSceneObject; const AUpVector: TVector4f); overload;
Public | procedure PointTo(const AAbsolutePosition, AUpVector: TVector4f); overload;
Public | procedure Remove(AChild: TgxBaseSceneObject; keepChildren: Boolean); virtual;
Public | procedure Render(var ARci: TgxRenderContextInfo);
Public | procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TgxRenderContextInfo);
Public | procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);
Public | procedure ResetRotations;
Public | procedure Roll(angle: Single);
Public | procedure RotateAbsolute(const rx, ry, rz: Single); overload;
Public | procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;
Public | procedure SetMatrix(const aValue: TMatrix4f); inline;
Public | procedure Slide(ADistance: Single);
Public | procedure StructureChanged; virtual;
Public | procedure TransformationChanged; inline;
Public | procedure Translate(tx, ty, tz: Single);
Public | procedure Turn(angle: Single);
Private | procedure SetAbsoluteAffineScale(const Value: TAffineVector);
Private | procedure SetAbsoluteMatrix(const Value: TMatrix4f);
Private | procedure SetAbsoluteScale(const Value: TVector4f);
Private | procedure SetBBChanges(const Value: TgxObjectBBChanges);
Private | procedure SetBehaviours(const val: TgxBehaviours);
Private | procedure SetDirection(AVector: TgxCoordinates);
Private | procedure SetEffects(const val: TgxEffects);
Private | procedure SetIndex(aValue: Integer);
Private | procedure SetObjectsSorting(const val: TgxObjectsSorting);
Private | procedure SetParent(const val: TgxBaseSceneObject); inline;
Private | procedure SetPitchAngle(AValue: Single);
Private | procedure SetPosition(APosition: TgxCoordinates);
Private | procedure SetRollAngle(AValue: Single);
Private | procedure SetRotation(aRotation: TgxCoordinates);
Private | procedure SetScaling(AValue: TgxCoordinates);
Private | procedure SetShowAxes(AValue: Boolean);
Private | procedure SetTurnAngle(AValue: Single);
Private | procedure SetUp(AVector: TgxCoordinates);
Private | procedure SetVisibilityCulling(const val: TgxVisibilityCulling);

Properties

Public | property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;
Public | property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;
Public | property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;
Public | property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;
Public | property AbsoluteDirection: TVector4f read GetAbsoluteDirection write SetAbsoluteDirection;
Public | property AbsoluteMatrix: TMatrix4f read GetAbsoluteMatrix write SetAbsoluteMatrix;
Public | property AbsolutePosition: TVector4f read GetAbsolutePosition write SetAbsolutePosition;
Public | property AbsoluteScale: TVector4f read GetAbsoluteScale write SetAbsoluteScale;
Public | property AbsoluteUp: TVector4f read GetAbsoluteUp write SetAbsoluteUp;
Public | property BBChanges: TgxObjectBBChanges read FBBChanges write SetBBChanges;
Public | property Behaviours: TgxBehaviours read GetBehaviours write SetBehaviours stored False;
Public | property Changes: TgxObjectChanges read FChanges;
Public | property Children[Index: Integer]: TgxBaseSceneObject read Get;
Public | property Count: Integer read GetCount;
Public | property DirectAbsoluteMatrix: PMatrix4f read GetDirectAbsoluteMatrix;
Public | property Direction: TgxCoordinates read FDirection write SetDirection;
Public | property Effects: TgxEffects read GetEffects write SetEffects stored False;
Public | property Index: Integer read GetIndex write SetIndex;
Public | property LocalMatrix: PMatrix4f read GetLocalMatrix;
Public | property Matrix: PMatrix4f read GetMatrix;
Public | property ObjectsSorting: TgxObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;
Public | property ObjectStyle: TgxObjectStyles read FObjectStyle write FObjectStyle;
Public | property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;
Public | property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;
Public | property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;
Public | property Parent: TgxBaseSceneObject read FParent write SetParent;
Public | property Pickable: Boolean read FPickable write SetPickable default True;
Public | property PitchAngle: Single read GetPitchAngle write SetPitchAngle;
Public | property Position: TgxCoordinates read FPosition write SetPosition;
Public | property RollAngle: Single read GetRollAngle write SetRollAngle;
Public | property Rotation: TgxCoordinates read FRotation write SetRotation;
Public | property Scale: TgxCoordinates read FScaling write SetScaling;
Public | property Scene: TgxScene read FScene;
Public | property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;
Published | property TagFloat: Single read FTagFloat write FTagFloat;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property TurnAngle: Single read GetTurnAngle write SetTurnAngle;
Public | property Up: TgxCoordinates read FUp write SetUp;
Public | property VisibilityCulling: TgxVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;
Public | property Visible: Boolean read FVisible write SetVisible default True;

Description

Fields

Private FAbsoluteMatrix: TMatrix4f;

This item has no description.

Private FInvAbsoluteMatrix: TMatrix4f;

This item has no description.

Private FLocalMatrix: TMatrix4f;

This item has no description.

Private FObjectStyle: TgxObjectStyles;

This item has no description.

Private FListHandle: TgxListHandle;

This item has no description.

Private FPosition: TgxCoordinates;

created on 1st use

Private FDirection: TgxCoordinates;

This item has no description.

Private FUp: TgxCoordinates;

This item has no description.

Private FScaling: TgxCoordinates;

This item has no description.

Private FChanges: TgxObjectChanges;

This item has no description.

Private FParent: TgxBaseSceneObject;

This item has no description.

Private FScene: TgxScene;

This item has no description.

Private FBBChanges: TgxObjectBBChanges;

This item has no description.

Private FBoundingBoxPersonalUnscaled: THmgBoundingBox;

This item has no description.

Private FBoundingBoxOfChildren: THmgBoundingBox;

This item has no description.

Private FBoundingBoxIncludingChildren: THmgBoundingBox;

This item has no description.

Private FChildren: TgxPersistentObjectList;

This item has no description.

Private FVisible: Boolean;

created on 1st use

Private FUpdateCount: Integer;

This item has no description.

Private FShowAxes: Boolean;

This item has no description.

Private FRotation: TgxCoordinates;

This item has no description.

Private FIsCalculating: Boolean;

current rotation angles

Private FObjectsSorting: TgxObjectsSorting;

This item has no description.

Private FVisibilityCulling: TgxVisibilityCulling;

This item has no description.

Private FOnProgress: TgxProgressEvent;

This item has no description.

Private FOnAddedToParent: TNotifyEvent;

This item has no description.

Private FBehaviours: TgxBehaviours;

This item has no description.

Private FEffects: TgxEffects;

This item has no description.

Private FPickable: Boolean;

This item has no description.

Private FOnPicked: TNotifyEvent;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Private FTagFloat: Single;

This item has no description.

Private ObjList: TgxPersistentObjectList;

This item has no description.

Private DistList: TgxSingleList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public constructor CreateAsChild(aParentOwner: TgxBaseSceneObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteLeft: TVector4f;

Calculate the left vector in absolute coordinates.

Public function AbsoluteMatrixAsAddress: PMatrix4f;

See AbsoluteMatrix.

Public function AbsolutePositionAsAddress: PVector4f;

This item has no description.

Public function AbsoluteRight: TVector4f;

Calculate the right vector in absolute coordinates.

Public function AbsoluteToLocal(const v: TVector4f): TVector4f; overload;

Converts a vector/point from absolute coordinates to local coordinates.

Public function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;

Converts a vector from absolute coordinates to local coordinates.

Public function AbsoluteXVector: TVector4f;

Returns the Absolute X Vector expressed in local coordinates.

Public function AbsoluteYVector: TVector4f;

Returns the Absolute Y Vector expressed in local coordinates.

Public function AbsoluteZVector: TVector4f;

Returns the Absolute Z Vector expressed in local coordinates.

Public function AddNewBehaviour(aBehaviour: TgxBehaviourClass): TgxBehaviour;

This item has no description.

Public function AddNewChild(AChild: TgxSceneObjectClass): TgxBaseSceneObject; virtual;

Create a new scene object and add it to this object as new child

Public function AddNewChildFirst(AChild: TgxSceneObjectClass): TgxBaseSceneObject; virtual;

Create a new scene object and add it to this object as first child

Public function AddNewEffect(anEffect: TgxEffectClass): TgxEffect;

This item has no description.

Public function AffineLeftVector: TAffineVector; inline;

Returns the Left vector (based on Up and Direction)

Public function AffineRight: TAffineVector; inline;

Returns the Right vector (based on Up and Direction)

Public function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;

Calculates and return the AABB for the object. The AABB is currently calculated from the BB. There is no caching scheme for them.

Public function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;

This item has no description.

Public function AxisAlignedBoundingBoxAbsoluteEx: TAABB;

This item has no description.

Public function AxisAlignedBoundingBoxEx: TAABB;

Advanced AABB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;

This item has no description.

Public function AxisAlignedDimensions: TVector4f; virtual;

Shall returns the object's axis aligned extensions. The dimensions are measured from object center and are expressed with scale accounted for, in the object's coordinates (not in absolute coordinates). Default value is half the object's Scale.

Public function AxisAlignedDimensionsUnscaled: TVector4f; virtual;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; virtual;

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function BarycenterSqrDistanceTo(const pt: TVector4f): Single;

Calculates the object's barycenter distance to a point.

Public function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

Calculates and return the Bounding Box for the object. The BB is calculated each time this method is invoked, based on the AxisAlignedDimensions of the object and that of its children. There is no caching scheme for them.

Public function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

This item has no description.

Public function BoundingBoxIncludingChildrenEx: THmgBoundingBox;

This item has no description.

Public function BoundingBoxOfChildrenEx: THmgBoundingBox;

This item has no description.

Public function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;

Advanced BB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

This item has no description.

Public function BoundingSphereRadius: Single; inline;

Max distance of corners of the BoundingBox.

Public function BoundingSphereRadiusUnscaled: Single; inline;

This item has no description.

Public function DistanceTo(const pt: TVector4f): Single; overload;

This item has no description.

Public function DistanceTo(const pt: TAffineVector): Single; overload;

This item has no description.

Public function DistanceTo(anObject: TgxBaseSceneObject): Single; overload;

Computes the object's distance to a point/object. Only objects AbsolutePositions are considered.

Public function FindChild(const aName: string; ownChildrenOnly: Boolean): TgxBaseSceneObject;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; virtual;

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function GetHandle(var rci: TgxRenderContextInfo): Cardinal;

Returns the handle to the object's build list. Use with caution! Some objects don't support buildlists!

Public function GetOrCreateBehaviour(aBehaviour: TgxBehaviourClass): TgxBehaviour;

This item has no description.

Public function GetOrCreateEffect(anEffect: TgxEffectClass): TgxEffect;

This item has no description.

Public function GetParentComponent: TComponent; override;

This item has no description.

Public function HasParent: Boolean; override; final;

This item has no description.

Public function HasSubChildren: Boolean;

This item has no description.

Public function IndexOfChild(AChild: TgxBaseSceneObject): Integer;

This item has no description.

Public function InvAbsoluteMatrix: TMatrix4f; inline;

Calculates the object's absolute inverse matrix. Multiplying an absolute coordinate with this matrix gives a local coordinate. The current implem uses transposition(AbsoluteMatrix), which is true unless you're using some scaling...

Public function InvAbsoluteMatrixAsAddress: PMatrix4f;

See InvAbsoluteMatrix.

Public function IsUpdating: Boolean; inline;

This item has no description.

Public function LeftVector: TVector4f; inline;

Returns the Left vector (based on Up and Direction)

Public function ListHandleAllocated: Boolean; inline;

This item has no description.

Public function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;

Converts a vector from local coordinates to absolute coordinates.

Public function LocalToAbsolute(const v: TVector4f): TVector4f; overload;

Converts a vector/point from local coordinates to absolute coordinates.

Public function PointInObject(const point: TVector4f): Boolean; virtual;

Indicates if a point is within an object. Given coordinate is an absolute coordinate. Linear or surfacic objects shall always return False. Default value is based on AxisAlignedDimension and a cube bounding.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean; virtual;

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function Right: TVector4f; inline;

Returns the Right vector (based on Up and Direction)

Public function SqrDistanceTo(const pt: TVector4f): Single; overload;

This item has no description.

Public function SqrDistanceTo(const pt: TAffineVector): Single; overload;

This item has no description.

Public function SqrDistanceTo(anObject: TgxBaseSceneObject): Single; overload;

Calculates the object's square distance to a point/object. pt is assumed to be in absolute coordinates, AbsolutePosition is considered as being the object position.

Private function Get(Index: Integer): TgxBaseSceneObject; inline;

If somebody could look at DefineProperties, ReadBehaviours, ReadEffects and verify code is safe to use then it could be uncommented

Private function GetAbsoluteAffineScale: TAffineVector;

This item has no description.

Private function GetAbsoluteMatrix: TMatrix4f; inline;

This item has no description.

Private function GetAbsoluteScale: TVector4f;

This item has no description.

Private function GetBehaviours: TgxBehaviours;

This item has no description.

Private function GetCount: Integer; inline;

This item has no description.

Private function GetDirectAbsoluteMatrix: PMatrix4f;

This item has no description.

Private function GetEffects: TgxEffects;

This item has no description.

Private function GetIndex: Integer; inline;

This item has no description.

Private function GetLocalMatrix: PMatrix4f; inline;

This item has no description.

Private function GetMatrix: PMatrix4f; inline;

This item has no description.

Private function GetPitchAngle: Single; inline;

This item has no description.

Private function GetRollAngle: Single; inline;

This item has no description.

Private function GetTurnAngle: Single; inline;

This item has no description.

Public procedure AddChild(AChild: TgxBaseSceneObject); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate; inline;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); virtual;

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure ClearStructureChanged; inline;

This item has no description.

Public procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;

Recalculate an orthonormal system

Public procedure DeleteChildren; virtual;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;

This item has no description.

Public procedure EndUpdate; inline;

This item has no description.

Public procedure ExchangeChildren(anIndex1, anIndex2: Integer);

The "regular" version of this procedure does not perform any checks and calls FChildren.Exchange directly. User should/can perform range checks manualy.

Public procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);

The "safe" version of this procedure checks if indexes are inside the list. If not, no exception if raised.

Public procedure ForceLocalMatrix(const aMatrix: TMatrix4f); inline;

Forces the local matrix to the specified value. AbsoluteMatrix, InverseMatrix, etc. will honour that change, but may become invalid if the specified matrix isn't orthonormal (can be used for specific rendering or projection effects). The local matrix will be reset by the next TransformationChanged, position or attitude change.

Public procedure Insert(AIndex: Integer; AChild: TgxBaseSceneObject); virtual;

This item has no description.

Public procedure Lift(ADistance: Single);

Moves the object along the Up vector (move up/down)

Public procedure Move(ADistance: Single);

Moves the object along the direction vector

Public procedure MoveChildDown(anIndex: Integer);

This item has no description.

Public procedure MoveChildFirst(anIndex: Integer);

This item has no description.

Public procedure MoveChildLast(anIndex: Integer);

This item has no description.

Public procedure MoveChildUp(anIndex: Integer);

These procedures are safe.

Public procedure MoveDown;

This item has no description.

Public procedure MoveFirst;

This item has no description.

Public procedure MoveLast;

This item has no description.

Public procedure MoveObjectAllAround(anObject: TgxBaseSceneObject; pitchDelta, turnDelta: Single);

This item has no description.

Public procedure MoveObjectAround(anObject: TgxBaseSceneObject; pitchDelta, turnDelta: Single);

This item has no description.

Public procedure MoveTo(newParent: TgxBaseSceneObject); virtual;

This item has no description.

Public procedure MoveUp;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure Pitch(angle: Single);

This item has no description.

Public procedure PointTo(const ATargetObject: TgxBaseSceneObject; const AUpVector: TVector4f); overload;

Orients the object toward a target object

Public procedure PointTo(const AAbsolutePosition, AUpVector: TVector4f); overload;

Orients the object toward a target absolute position

Public procedure Remove(AChild: TgxBaseSceneObject; keepChildren: Boolean); virtual;

Takes a scene object out of the child list, but doesn't destroy it. If 'KeepChildren' is true its children will be kept as new children in this scene object.

Public procedure Render(var ARci: TgxRenderContextInfo);

This item has no description.

Public procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TgxRenderContextInfo);

This item has no description.

Public procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);

Reset rotations and applies them back in the specified order.

Public procedure ResetRotations;

Sets all rotations to zero and restores default Direction/Up. Using this function then applying roll/pitch/turn in the order that suits you, you can give an "absolute" meaning to rotation angles (they are still applied locally though). Scale and Position are not affected.

Public procedure Roll(angle: Single);

This item has no description.

Public procedure RotateAbsolute(const rx, ry, rz: Single); overload;

Applies rotations around absolute X, Y and Z axis.

Public procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;

Applies rotations around the absolute given vector (angle in degrees).

Public procedure SetMatrix(const aValue: TMatrix4f); inline;

The local transformation (relative to parent). If you're *sure* the local matrix is up-to-date, you may use LocalMatrix for quicker access.

Public procedure Slide(ADistance: Single);

Moves camera along the right vector (move left and right)

Public procedure StructureChanged; virtual;

This item has no description.

Public procedure TransformationChanged; inline;

This item has no description.

Public procedure Translate(tx, ty, tz: Single);

Translates the object

Public procedure Turn(angle: Single);

This item has no description.

Private procedure SetAbsoluteAffineScale(const Value: TAffineVector);

This item has no description.

Private procedure SetAbsoluteMatrix(const Value: TMatrix4f);

This item has no description.

Private procedure SetAbsoluteScale(const Value: TVector4f);

This item has no description.

Private procedure SetBBChanges(const Value: TgxObjectBBChanges);

This item has no description.

Private procedure SetBehaviours(const val: TgxBehaviours);

This item has no description.

Private procedure SetDirection(AVector: TgxCoordinates);

This item has no description.

Private procedure SetEffects(const val: TgxEffects);

This item has no description.

Private procedure SetIndex(aValue: Integer);

This item has no description.

Private procedure SetObjectsSorting(const val: TgxObjectsSorting);

This item has no description.

Private procedure SetParent(const val: TgxBaseSceneObject); inline;

This item has no description.

Private procedure SetPitchAngle(AValue: Single);

This item has no description.

Private procedure SetPosition(APosition: TgxCoordinates);

This item has no description.

Private procedure SetRollAngle(AValue: Single);

This item has no description.

Private procedure SetRotation(aRotation: TgxCoordinates);

This item has no description.

Private procedure SetScaling(AValue: TgxCoordinates);

This item has no description.

Private procedure SetShowAxes(AValue: Boolean);

This item has no description.

Private procedure SetTurnAngle(AValue: Single);

This item has no description.

Private procedure SetUp(AVector: TgxCoordinates);

This item has no description.

Private procedure SetVisibilityCulling(const val: TgxVisibilityCulling);

This item has no description.

Properties

Public property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;

This item has no description.

Public property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;

This item has no description.

Public property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;

This item has no description.

Public property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;

This item has no description.

Public property AbsoluteDirection: TVector4f read GetAbsoluteDirection write SetAbsoluteDirection;

Direction vector in absolute coordinates.

Public property AbsoluteMatrix: TMatrix4f read GetAbsoluteMatrix write SetAbsoluteMatrix;

The object's absolute matrix by composing all local matrices. Multiplying a local coordinate with this matrix gives an absolute coordinate.

Public property AbsolutePosition: TVector4f read GetAbsolutePosition write SetAbsolutePosition;

Computes and allows to set the object's absolute coordinates.

Public property AbsoluteScale: TVector4f read GetAbsoluteScale write SetAbsoluteScale;

Scale vector in absolute coordinates. Warning: SetAbsoluteScale() does not work correctly at the moment.

Public property AbsoluteUp: TVector4f read GetAbsoluteUp write SetAbsoluteUp;

Up vector in absolute coordinates.

Public property BBChanges: TgxObjectBBChanges read FBBChanges write SetBBChanges;

This item has no description.

Public property Behaviours: TgxBehaviours read GetBehaviours write SetBehaviours stored False;

This item has no description.

Public property Changes: TgxObjectChanges read FChanges;

This item has no description.

Public property Children[Index: Integer]: TgxBaseSceneObject read Get;

This item has no description.

Public property Count: Integer read GetCount;

This item has no description.

Public property DirectAbsoluteMatrix: PMatrix4f read GetDirectAbsoluteMatrix;

Holds the absolute transformation matrix. If you're not *sure* the absolute matrix is up-to-date, use the AbsoluteMatrix property, this one may be nil...

Public property Direction: TgxCoordinates read FDirection write SetDirection;

This item has no description.

Public property Effects: TgxEffects read GetEffects write SetEffects stored False;

This item has no description.

Public property Index: Integer read GetIndex write SetIndex;

This item has no description.

Public property LocalMatrix: PMatrix4f read GetLocalMatrix;

Holds the local transformation (relative to parent). If you're not *sure* the local matrix is up-to-date, use Matrix property.

Public property Matrix: PMatrix4f read GetMatrix;

This item has no description.

Public property ObjectsSorting: TgxObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;

This item has no description.

Public property ObjectStyle: TgxObjectStyles read FObjectStyle write FObjectStyle;

Controls and adjusts internal optimizations based on object's style. Advanced user only.

Public property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;

This item has no description.

Public property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;

This item has no description.

Public property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Public property Parent: TgxBaseSceneObject read FParent write SetParent;

This item has no description.

Public property Pickable: Boolean read FPickable write SetPickable default True;

This item has no description.

Public property PitchAngle: Single read GetPitchAngle write SetPitchAngle;

This item has no description.

Public property Position: TgxCoordinates read FPosition write SetPosition;

This item has no description.

Public property RollAngle: Single read GetRollAngle write SetRollAngle;

This item has no description.

Public property Rotation: TgxCoordinates read FRotation write SetRotation;

This item has no description.

Public property Scale: TgxCoordinates read FScaling write SetScaling;

This item has no description.

Public property Scene: TgxScene read FScene;

This item has no description.

Public property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;

This item has no description.

Published property TagFloat: Single read FTagFloat write FTagFloat;

This item has no description.

Public property TagObject: TObject read FTagObject write FTagObject;

This item has no description.

Public property TurnAngle: Single read GetTurnAngle write SetTurnAngle;

This item has no description.

Public property Up: TgxCoordinates read FUp write SetUp;

This item has no description.

Public property VisibilityCulling: TgxVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;

This item has no description.

Public property Visible: Boolean read FVisible write SetVisible default True;


GXSysHelp v.2.5: GXS.Scene: Class TgxBaseBehaviour

Class TgxBaseBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxBaseBehaviour = class(TXCollectionItem)

Description

Base class for implementing behaviours in TgxScene. Behaviours are regrouped in a collection attached to a TgxBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)

Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); virtual;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); virtual;


GXSysHelp v.2.5: GXS.Scene: Class TgxBehaviour

Class TgxBehaviour

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxBehaviour = class(TgxBaseBehaviour)

Description

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour


GXSysHelp v.2.5: GXS.Scene: Class TgxBehaviours

Class TgxBehaviours

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxBehaviours = class(TXCollection)

Description

Holds a list of TgxBehaviour objects. This object expects itself to be owned by a TgxBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TgxBehaviour subclasses.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxBehaviours

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure DoProgress(const progressTimes: TgxProgressTimes); inline;

Properties

Public property Behaviour[index: Integer]: TgxBehaviour read GetBehaviour;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetNamePath: string; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure DoProgress(const progressTimes: TgxProgressTimes); inline;

This item has no description.

Properties

Public property Behaviour[index: Integer]: TgxBehaviour read GetBehaviour;


GXSysHelp v.2.5: GXS.Scene: Class TgxEffect

Class TgxEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxEffect = class(TgxBaseBehaviour)

Description

TgxEffectClass = class of TgxEffect;

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect

Overview

Methods

Public procedure Render(var rci: TgxRenderContextInfo); virtual;

Description

Methods

Public procedure Render(var rci: TgxRenderContextInfo); virtual;


GXSysHelp v.2.5: GXS.Scene: Class TgxObjectPreEffect

Class TgxObjectPreEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxObjectPreEffect = class(TgxEffect)

Description

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPreEffect


GXSysHelp v.2.5: GXS.Scene: Class TgxObjectPostEffect

Class TgxObjectPostEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxObjectPostEffect = class(TgxEffect)

Description

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPostEffect


GXSysHelp v.2.5: GXS.Scene: Class TgxObjectAfterEffect

Class TgxObjectAfterEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxObjectAfterEffect = class(TgxEffect)

Description

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectAfterEffect


GXSysHelp v.2.5: GXS.Scene: Class TgxEffects

Class TgxEffects

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxEffects = class(TXCollection)

Description

Holds a list of object effects. This object expects itself to be owned by a TgxBaseSceneObject.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxEffects

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes);
Public | procedure RenderPostEffects(var rci: TgxRenderContextInfo); inline;
Public | procedure RenderPreEffects(var rci: TgxRenderContextInfo); inline;

Properties

Public property ObjectEffect[index: Integer]: TgxEffect read GetEffect;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public function GetNamePath: string; override;

This item has no description.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure DoProgress(const progressTime: TgxProgressTimes);

This item has no description.

Public procedure RenderPostEffects(var rci: TgxRenderContextInfo); inline;

Also take care of registering after effects with the GLXceneViewer.

Public procedure RenderPreEffects(var rci: TgxRenderContextInfo); inline;

This item has no description.

Properties

Public property ObjectEffect[index: Integer]: TgxEffect read GetEffect;


GXSysHelp v.2.5: GXS.Scene: Class TgxCustomSceneObject

Class TgxCustomSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxCustomSceneObject = class(TgxBaseSceneObject)

Description

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TgxMaterial.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject

Overview

Fields

Private | FMaterial: TgxMaterial;
Private | FHint: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Public | property Hint: string read FHint write FHint;
Public | property Material: TgxMaterial read FMaterial write SetVKMaterial;

Description

Fields

Private FMaterial: TgxMaterial;

This item has no description.

Private FHint: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Public property Hint: string read FHint write FHint;

This item has no description.

Public property Material: TgxMaterial read FMaterial write SetVKMaterial;


GXSysHelp v.2.5: GXS.Scene: Class TgxSceneRootObject

Class TgxSceneRootObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxSceneRootObject = class(TgxBaseSceneObject)

Description

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxSceneRootObject

Overview

Methods

Public constructor Create(AOwner: TComponent); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;


GXSysHelp v.2.5: GXS.Scene: Class TgxImmaterialSceneObject

Class TgxImmaterialSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxImmaterialSceneObject = class(TgxCustomSceneObject)

Description

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject

Overview

Methods

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Methods

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.Scene: Class TgxCameraInvariantObject

Class TgxCameraInvariantObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxCameraInvariantObject = class(TgxImmaterialSceneObject)

Description

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxCameraInvariantObject

Overview

Fields

Private FCamInvarianceMode: TgxCameraInvarianceMode;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Description

Fields

Private FCamInvarianceMode: TgxCameraInvarianceMode;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;


GXSysHelp v.2.5: GXS.Scene: Class TgxSceneObject

Class TgxSceneObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxSceneObject = class(TgxCustomSceneObject)

Description

Base class for standard scene objects. Publishes the Material property.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject

Overview

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property Material;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property Hint;

This item has no description.

Published property Material;

This item has no description.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.Scene: Class TgxDirectOpenGL

Class TgxDirectOpenGL

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxDirectOpenGL = class(TgxImmaterialSceneObject)

Description

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxDirectOpenGL

Overview

Fields

Private | FUseBuildList: Boolean;
Private | FOnRender: TDirectRenderEvent;
Private | FBlend: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Blend: Boolean read FBlend write SetBlend;
Published | property OnRender: TDirectRenderEvent read FOnRender write FOnRender;
Published | property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Description

Fields

Private FUseBuildList: Boolean;

This item has no description.

Private FOnRender: TDirectRenderEvent;

This item has no description.

Private FBlend: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Blend: Boolean read FBlend write SetBlend;

Defines if the object uses blending. This property will allow direct OpenGL objects to be flagged as blended for object sorting purposes.

Published property OnRender: TDirectRenderEvent read FOnRender write FOnRender;

Place your specific OpenGL code here. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

Published property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Specifies if a build list be made. If True, GXScene will generate a build list (side cache), ie. OnRender will only be invoked once for the first render, or after a StructureChanged call. This is suitable for "static" geometry and will usually speed up rendering of things that don't change. If false, OnRender will be invoked for each render. This is suitable for dynamic geometry (things that change often or constantly).


GXSysHelp v.2.5: GXS.Scene: Class TgxRenderPoint

Class TgxRenderPoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxRenderPoint = class(TgxImmaterialSceneObject)

Description

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxRenderPoint

Overview

Fields

Private | FCallBacks: array of TDirectRenderEvent;
Private | FFreeCallBacks: array of TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure Clear;
Public | procedure RegisterCallBack(renderEvent: TDirectRenderEvent; renderPointFreed: TNotifyEvent);
Public | procedure UnRegisterCallBack(renderEvent: TDirectRenderEvent);

Description

Fields

Private FCallBacks: array of TDirectRenderEvent;

This item has no description.

Private FFreeCallBacks: array of TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure Clear;

This item has no description.

Public procedure RegisterCallBack(renderEvent: TDirectRenderEvent; renderPointFreed: TNotifyEvent);

This item has no description.

Public procedure UnRegisterCallBack(renderEvent: TDirectRenderEvent);


GXSysHelp v.2.5: GXS.Scene: Class TgxProxyObject

Class TgxProxyObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxProxyObject = class(TgxBaseSceneObject)

Description

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxProxyObject

Overview

Fields

Private | FMasterObject: TgxBaseSceneObject;
Private | FProxyOptions: TgxProxyObjectOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensions: TVector4f; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function BarycenterAbsolutePosition: TVector4f; override;
Public | function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property ProxyOptions: TgxProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Private FMasterObject: TgxBaseSceneObject;

This item has no description.

Private FProxyOptions: TgxProxyObjectOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensions: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.AxisAlignedDimensions.

Shall returns the object's axis aligned extensions. The dimensions are measured from object center and are expressed with scale accounted for, in the object's coordinates (not in absolute coordinates). Default value is half the object's Scale.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Behaviours;

This item has no description.

Published property Direction;

This item has no description.

Published property MasterObject: TgxBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property ObjectsSorting;

This item has no description.

Published property OnPicked;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Pickable;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property ProxyOptions: TgxProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;

Specifies how and what is proxy'ed.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXS.Scene: Class TgxLightSource

Class TgxLightSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxLightSource = class(TgxBaseSceneObject)

Description

Standard light source. The standard light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TgxScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxLightSource

Overview

Fields

Private | FLightID: Cardinal;
Private | FSpotDirection: TgxCoordinates;
Private | FSpotExponent: Single;
Private | FSpotCutOff: Single;
Private | FConstAttenuation: Single;
Private | FLinearAttenuation: Single;
Private | FQuadraticAttenuation: Single;
Private | FShining: Boolean;
Private | FAmbient: TgxColor;
Private | FDiffuse: TgxColor;
Private | FSpecular: TgxColor;
Private | FLightStyle: TgxLightStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Attenuated: Boolean;
Public | function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Ambient: TgxColor read FAmbient write SetAmbient;
Published | property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;
Published | property Diffuse: TgxColor read FDiffuse write SetDiffuse;
Public | property LightID: Cardinal read FLightID;
Published | property LightStyle: TgxLightStyle read FLightStyle write SetLightStyle default lsSpot;
Published | property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;
Published | property OnProgress;
Published | property Position;
Published | property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;
Published | property Shining: Boolean read FShining write SetShining default True;
Published | property Specular: TgxColor read FSpecular write SetSpecular;
Published | property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;
Published | property SpotDirection: TgxCoordinates read FSpotDirection write SetSpotDirection;
Published | property SpotExponent: Single read FSpotExponent write SetSpotExponent;

Description

Fields

Private FLightID: Cardinal;

This item has no description.

Private FSpotDirection: TgxCoordinates;

This item has no description.

Private FSpotExponent: Single;

This item has no description.

Private FSpotCutOff: Single;

This item has no description.

Private FConstAttenuation: Single;

This item has no description.

Private FLinearAttenuation: Single;

This item has no description.

Private FQuadraticAttenuation: Single;

This item has no description.

Private FShining: Boolean;

This item has no description.

Private FAmbient: TgxColor;

This item has no description.

Private FDiffuse: TgxColor;

This item has no description.

Private FSpecular: TgxColor;

This item has no description.

Private FLightStyle: TgxLightStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Attenuated: Boolean;

This item has no description.

Public function GenerateSilhouette(const silhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

light sources have different handle types than normal scene objects

Public procedure CoordinateChanged(Sender: TgxCustomCoordinates); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.CoordinateChanged.

Recalculate an orthonormal system

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Ambient: TgxColor read FAmbient write SetAmbient;

This item has no description.

Published property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;

This item has no description.

Published property Diffuse: TgxColor read FDiffuse write SetDiffuse;

This item has no description.

Public property LightID: Cardinal read FLightID;

This item has no description.

Published property LightStyle: TgxLightStyle read FLightStyle write SetLightStyle default lsSpot;

This item has no description.

Published property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;

This item has no description.

Published property Shining: Boolean read FShining write SetShining default True;

This item has no description.

Published property Specular: TgxColor read FSpecular write SetSpecular;

This item has no description.

Published property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;

This item has no description.

Published property SpotDirection: TgxCoordinates read FSpotDirection write SetSpotDirection;

This item has no description.

Published property SpotExponent: Single read FSpotExponent write SetSpotExponent;


GXSysHelp v.2.5: GXS.Scene: Class TgxCamera

Class TgxCamera

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxCamera = class(TgxBaseSceneObject)

Description

Camera object. This object is commonly referred by TgxSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCamera

Overview

Fields

Private | FFocalLength: Single;
Private | FDepthOfView: Single;
Private | FNearPlane: Single;
Private | FNearPlaneBias: Single;
Private | FViewPortRadius: Single;
Private | FTargetObject: TgxBaseSceneObject;
Private | FLastDirection: TVector4f;
Private | FCameraStyle: TgxCameraStyle;
Private | FKeepFOVMode: TgxCameraKeepFOVMode;
Private | FSceneScale: Single;
Private | FDeferredApply: TNotifyEvent;
Private | FOnCustomPerspective: TgxOnCustomPerspective;
Private | FDesign: Boolean;
Private | FFOVY: Double;
Private | FFOVX: Double;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TVector4f;
Public | function AbsoluteRightVectorToTarget: TVector4f;
Public | function AbsoluteUpVectorToTarget: TVector4f;
Public | function AbsoluteVectorToTarget: TVector4f;
Public | function DistanceToTarget: Single;
Public | function GetFieldOfView(const AViewportDimension: Single): Single;
Public | function PointInFront(const point: TVector4f): Boolean; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TVector4f): TVector4f;
Public | function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TVector4f;
Public | function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TVector4f;
Public | function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TVector4f;
Public | procedure AdjustDistanceToTarget(distanceRatio: Single);
Public | procedure Apply;
Public | procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AutoLeveling(Factor: Single);
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure MoveAllAroundTarget(pitchDelta, turnDelta: Single);
Public | procedure MoveAroundTarget(pitchDelta, turnDelta: Single);
Public | procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure Reset(aSceneBuffer: TgxSceneBuffer);
Public | procedure RotateObject(obj: TgxBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure SetFieldOfView(const AFieldOfView, AViewportDimension: Single);
Public | procedure ZoomAll(aSceneBuffer: TgxSceneBuffer);

Properties

Published | property CameraStyle: TgxCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;
Published | property DepthOfView: Single read FDepthOfView write SetDepthOfView;
Published | property Direction;
Published | property FocalLength: Single read FFocalLength write SetFocalLength;
Published | property KeepFOVMode: TgxCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;
Public | property NearPlane: Single read FNearPlane;
Published | property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;
Published | property OnCustomPerspective: TgxOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;
Published | property OnProgress;
Published | property Position;
Published | property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;
Published | property TargetObject: TgxBaseSceneObject read FTargetObject write SetTargetObject;
Published | property Up;

Description

Fields

Private FFocalLength: Single;

This item has no description.

Private FDepthOfView: Single;

This item has no description.

Private FNearPlane: Single;

This item has no description.

Private FNearPlaneBias: Single;

nearest distance to the camera

Private FViewPortRadius: Single;

scaling bias applied to near plane

Private FTargetObject: TgxBaseSceneObject;

viewport bounding radius per distance unit

Private FLastDirection: TVector4f;

This item has no description.

Private FCameraStyle: TgxCameraStyle;

Not persistent

Private FKeepFOVMode: TgxCameraKeepFOVMode;

This item has no description.

Private FSceneScale: Single;

This item has no description.

Private FDeferredApply: TNotifyEvent;

This item has no description.

Private FOnCustomPerspective: TgxOnCustomPerspective;

This item has no description.

Private FDesign: Boolean;

This item has no description.

Private FFOVY: Double;

This item has no description.

Private FFOVX: Double;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TVector4f;

Computes the absolute vector corresponding to the eye-space translations.

Public function AbsoluteRightVectorToTarget: TVector4f;

Computes the absolute normalized right vector to the camera target. If no target is defined, AbsoluteRight is returned.

Public function AbsoluteUpVectorToTarget: TVector4f;

Computes the absolute normalized up vector to the camera target. If no target is defined, AbsoluteUpt is returned.

Public function AbsoluteVectorToTarget: TVector4f;

Computes the absolute normalized vector to the camera target. If no target is defined, AbsoluteDirection is returned.

Public function DistanceToTarget: Single;

Returns the distance from camera to target. If TargetObject is nil, returns 1.

Public function GetFieldOfView(const AViewportDimension: Single): Single;

Calculates the field of view in degrees, given a viewport dimension (width or height). F.i. you may wish to use the minimum of the two.

Public function PointInFront(const point: TVector4f): Boolean; overload;

Returns true if a point is in front of the camera.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TVector4f): TVector4f;

Calculate an absolute translation vector from a screen vector. Ratio is applied to both screen delta, planeNormal should be the translation plane's normal.

Public function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TVector4f;

Same as ScreenDeltaToVector but optimized for XY plane.

Public function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TVector4f;

Same as ScreenDeltaToVector but optimized for XZ plane.

Public function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TVector4f;

Same as ScreenDeltaToVector but optimized for YZ plane.

Public procedure AdjustDistanceToTarget(distanceRatio: Single);

Adjusts distance from camera to target by applying a ratio. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Only the camera's position is changed.

Public procedure Apply;

Apply camera transformation

Public procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure AutoLeveling(Factor: Single);

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure MoveAllAroundTarget(pitchDelta, turnDelta: Single);

Change camera's position to make it move all around its target. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are changed. Angle deltas are in degrees.

Public procedure MoveAroundTarget(pitchDelta, turnDelta: Single);

Change camera's position to make it move around its target. If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are unchanged. Angle deltas are in degrees, camera parent's coordinates should be identity. Tip : make the camera a child of a "target" dummycube and make it a target the dummycube. Now, to pan across the scene, just move the dummycube, to change viewing angle, use this method.

Public procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the camera in eye space coordinates.

Public procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the target in eye space coordinates.

Public procedure Reset(aSceneBuffer: TgxSceneBuffer);

This item has no description.

Public procedure RotateObject(obj: TgxBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);

This item has no description.

Public procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);

This item has no description.

Public procedure SetFieldOfView(const AFieldOfView, AViewportDimension: Single);

Sets the FocalLength in degrees, given a field of view and a viewport dimension (width or height).

Public procedure ZoomAll(aSceneBuffer: TgxSceneBuffer);

Position the camera so that the whole scene can be seen

Properties

Published property CameraStyle: TgxCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;

Adjust the camera style. Three styles are available : csPerspective, the default value for perspective projection csOrthogonal, for orthogonal (or isometric) projection. csOrtho2D, setups orthogonal 2D projection in which 1 unit (in x or y) represents 1 pixel. csInfinitePerspective, for perspective view without depth limit. csKeepCamAnglePerspective, for perspective view with keeping aspect on view resize. csCustom, setup is deferred to the OnCustomPerspective event.

Published property DepthOfView: Single read FDepthOfView write SetDepthOfView;

Depth of field/view. Adjusts the maximum distance, beyond which objects will be clipped (ie. not visisble). You must adjust this value if you are experiencing disappearing objects (increase the value) of Z-Buffer crawling (decrease the value). Z-Buffer crawling happens when depth of view is too large and the Z-Buffer precision cannot account for all that depth accurately : objects farther overlap closer objects and vice-versa. Note that this value is ignored in cSOrtho2D mode.

Published property Direction;

This item has no description.

Published property FocalLength: Single read FFocalLength write SetFocalLength;

Focal Length of the camera. Adjusting this value allows for lens zooming effects (use SceneScale for linear zooming). This property affects near/far planes clipping.

Published property KeepFOVMode: TgxCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;

Keep camera angle mode. When CameraStyle is csKeepCamAnglePerspective, select which camera angle you want to keep. kaHeight, for Keep Height oriented camera angle kaWidth, for Keep Width oriented camera angle

Public property NearPlane: Single read FNearPlane;

Nearest clipping plane for the frustum. This value depends on the FocalLength and DepthOfView fields and is calculated to minimize Z-Buffer crawling as suggested by the OpenGL documentation.

Published property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;

Scaling bias applied to near-plane calculation. Values inferior to one will move the nearplane nearer, and also reduce medium/long range Z-Buffer precision, values superior to one will move the nearplane farther, and also improve medium/long range Z-Buffer precision.

Published property OnCustomPerspective: TgxOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;

Custom perspective event. This event allows you to specify your custom perpective, either with a glFrustrum, a glOrtho or whatever method suits you. You must compute viewPortRadius for culling to work. This event is only called if CameraStyle is csCustom.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;

Scene scaling for camera point. This is a linear 2D scaling of the camera's output, allows for linear zooming (use FocalLength for lens zooming).

Published property TargetObject: TgxBaseSceneObject read FTargetObject write SetTargetObject;

If set, camera will point to this object. When camera is pointing an object, the Direction vector is ignored and the Up vector is used as an absolute vector to the up.

Published property Up;


GXSysHelp v.2.5: GXS.Scene: Class TgxScene

Class TgxScene

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxScene = class(TgxUpdateAbleComponent)

Description

Scene object. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TgxBaseSceneObject. It will usually contain one or more TgxCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TgxScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TgxBaseSceneObject.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxScene

Overview

Fields

Private | FUpdateCount: Integer;
Private | FObjects: TgxSceneRootObject;
Private | FBaseContext: TgxContext;
Private | FLights: TgxPersistentObjectList;
Private | FBuffers: TgxPersistentObjectList;
Private | FCurrentCamera: TgxCamera;
Private | FCurrentBuffer: TgxSceneBuffer;
Private | FObjectsSorting: TgxObjectsSorting;
Private | FVisibilityCulling: TgxVisibilityCulling;
Private | FOnBeforeProgress: TgxProgressEvent;
Private | FOnProgress: TgxProgressEvent;
Private | FCurrentDeltaTime: Double;
Private | FInitializableObjects: TgxInitializableObjectList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FindSceneObject(const aName: string): TgxBaseSceneObject;
Public | function IsUpdating: Boolean;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : TgxBaseSceneObject; virtual;
Public | procedure AddBuffer(aBuffer: TgxSceneBuffer);
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure LoadFromTextFile(const fileName: string);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Progress(const deltaTime, newTime: Double);
Public | procedure RemoveBuffer(aBuffer: TgxSceneBuffer);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SaveToTextFile(const fileName: string);
Public | procedure SetupLights(maxLights: Integer);
Public | procedure ShutdownAllLights;

Properties

Public | property CurrentBuffer: TgxSceneBuffer read FCurrentBuffer;
Public | property CurrentCamera: TgxCamera read FCurrentCamera;
Public | property CurrentDeltaTime: Double read FCurrentDeltaTime;
Public | property InitializableObjects: TgxInitializableObjectList read FInitializableObjects;
Public | property Lights: TgxPersistentObjectList read FLights;
Public | property Objects: TgxSceneRootObject read FObjects;
Published | property ObjectsSorting: TgxObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;
Published | property OnBeforeProgress: TgxProgressEvent read FOnBeforeProgress write FOnBeforeProgress;
Published | property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;
Published | property VisibilityCulling: TgxVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Description

Fields

Private FUpdateCount: Integer;

This item has no description.

Private FObjects: TgxSceneRootObject;

This item has no description.

Private FBaseContext: TgxContext;

This item has no description.

Private FLights: TgxPersistentObjectList;

reference, not owned!

Private FBuffers: TgxPersistentObjectList;

reference, not owned!

Private FCurrentCamera: TgxCamera;

This item has no description.

Private FCurrentBuffer: TgxSceneBuffer;

This item has no description.

Private FObjectsSorting: TgxObjectsSorting;

This item has no description.

Private FVisibilityCulling: TgxVisibilityCulling;

This item has no description.

Private FOnBeforeProgress: TgxProgressEvent;

This item has no description.

Private FOnProgress: TgxProgressEvent;

This item has no description.

Private FCurrentDeltaTime: Double;

This item has no description.

Private FInitializableObjects: TgxInitializableObjectList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindSceneObject(const aName: string): TgxBaseSceneObject;

This item has no description.

Public function IsUpdating: Boolean;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : TgxBaseSceneObject; virtual;

Calculates, finds and returns the first object intercepted by the ray. Returns nil if no intersection was found. This function will be accurate only for objects that overrided their RayCastIntersect method with accurate code, otherwise, bounding sphere intersections will be returned.

Public procedure AddBuffer(aBuffer: TgxSceneBuffer);

This item has no description.

Public procedure BeginUpdate;

This item has no description.

Public procedure EndUpdate;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

Load the scene from a file. Existing objects/lights/cameras are freed, then the file is loaded. Delphi's IDE is not handling this behaviour properly yet, ie. if you load a scene in the IDE, objects will be properly loaded, but no declare will be placed in the code.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure LoadFromTextFile(const fileName: string);

Load the scene from a text files. See LoadFromFile for details.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure Progress(const deltaTime, newTime: Double);

This item has no description.

Public procedure RemoveBuffer(aBuffer: TgxSceneBuffer);

This item has no description.

Public procedure SaveToFile(const fileName: string);

Saves the scene to a file (recommended extension : .GLS)

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure SaveToTextFile(const fileName: string);

Saves the scene to a text file

Public procedure SetupLights(maxLights: Integer);

This item has no description.

Public procedure ShutdownAllLights;

This item has no description.

Properties

Public property CurrentBuffer: TgxSceneBuffer read FCurrentBuffer;

This item has no description.

Public property CurrentCamera: TgxCamera read FCurrentCamera;

This item has no description.

Public property CurrentDeltaTime: Double read FCurrentDeltaTime;

This item has no description.

Public property InitializableObjects: TgxInitializableObjectList read FInitializableObjects;

List of objects that request to be initialized when rendering context is active. They are removed automaticly from this list once initialized.

Public property Lights: TgxPersistentObjectList read FLights;

This item has no description.

Public property Objects: TgxSceneRootObject read FObjects;

This item has no description.

Published property ObjectsSorting: TgxObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;

Defines default ObjectSorting option for scene objects.

Published property OnBeforeProgress: TgxProgressEvent read FOnBeforeProgress write FOnBeforeProgress;

This item has no description.

Published property OnProgress: TgxProgressEvent read FOnProgress write FOnProgress;

This item has no description.

Published property VisibilityCulling: TgxVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Defines default VisibilityCulling option for scene objects.


GXSysHelp v.2.5: GXS.Scene: Class TgxFogEnvironment

Class TgxFogEnvironment

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxFogEnvironment = class(TgxUpdateAbleObject)

Description

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

Hierarchy

  • TgxUpdateAbleObject
  • TgxFogEnvironment

Overview

Fields

Private | FSceneBuffer: TgxSceneBuffer;
Private | FFogColor: TgxColor;
Private | FFogStart: Single;
Private | FFogEnd: Single;
Private | FFogMode: TgxFogMode;
Private | FFogDistance: TgxFogDistance;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsAtDefaultValues: Boolean;
Public | procedure ApplyFog;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property FogColor: TgxColor read FFogColor write SetFogColor;
Published | property FogDistance: TgxFogDistance read FFogDistance write SetFogDistance default fdDefault;
Published | property FogEnd: Single read FFogEnd write SetFogEnd;
Published | property FogMode: TgxFogMode read FFogMode write SetFogMode default fmLinear;
Published | property FogStart: Single read FFogStart write SetFogStart;

Description

Fields

Private FSceneBuffer: TgxSceneBuffer;

This item has no description.

Private FFogColor: TgxColor;

This item has no description.

Private FFogStart: Single;

alpha value means the fog density

Private FFogEnd: Single;

alpha value means the fog density

Private FFogMode: TgxFogMode;

This item has no description.

Private FFogDistance: TgxFogDistance;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsAtDefaultValues: Boolean;

This item has no description.

Public procedure ApplyFog;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property FogColor: TgxColor read FFogColor write SetFogColor;

Color of the fog when it is at 100% intensity.

Published property FogDistance: TgxFogDistance read FFogDistance write SetFogDistance default fdDefault;

Adjusts the formula used for calculating fog distances. This option is honoured if and only if the OpenGL ICD supports the GL_NV_fog_distance extension, otherwise, it is ignored. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster)

Published property FogEnd: Single read FFogEnd write SetFogEnd;

Maximum distance for fog, what is farther is at 100% fog intensity.

Published property FogMode: TgxFogMode read FFogMode write SetFogMode default fmLinear;

The formula used for converting distance to fog intensity.

Published property FogStart: Single read FFogStart write SetFogStart;

Minimum distance for fog, what is closer is not affected.


GXSysHelp v.2.5: GXS.Scene: Class TgxSceneBuffer

Class TgxSceneBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxSceneBuffer = class(TgxUpdateAbleObject)

Description

Encapsulates an OpenGL frame/rendering buffer.

Hierarchy

  • TgxUpdateAbleObject
  • TgxSceneBuffer

Overview

Fields

Private | FRendering: Boolean;
Private | FRenderingContext: TgxContext;
Private | FAfterRenderEffects: TgxPersistentObjectList;
Private | FViewMatrixStack: array of TMatrix4f;
Private | FProjectionMatrixStack: array of TMatrix4f;
Private | FBaseProjectionMatrix: TMatrix4f;
Private | FCameraAbsolutePosition: TVector4f;
Private | FViewPort: TRectangle;
Private | FSelector: TgxBaseSelectTechnique;
Private | FFaceCulling: Boolean;
Private | FFogEnable: Boolean;
Private | FLighting: Boolean;
Private | FDepthTest: Boolean;
Private | FBackgroundColor: TColor;
Private | FBackgroundAlpha: Single;
Private | FAmbientColor: TgxColor;
Private | FAntiAliasing: TgxAntiAliasing;
Private | FDepthPrecision: TgxDepthPrecision;
Private | FColorDepth: TgxColorDepth;
Private | FContextOptions: TgxContextOptions;
Private | FShadeModel: TgxShadeModel;
Private | FRenderDPI: Integer;
Private | FFogEnvironment: TgxFogEnvironment;
Private | FAccumBufferBits: Integer;
Private | FLayer: TgxContextLayer;
Private | FCamera: TgxCamera;
Private | FFreezeBuffer: Pointer;
Private | FFreezed: Boolean;
Private | FFreezedViewPort: TRectangle;
Private | FFrameCount: Longint;
Private | FFramesPerSecond: Single;
Private | FFirstPerfCounter: Int64;
Private | FLastFrameTime: Single;
Private | FOnChange: TNotifyEvent;
Private | FOnStructuralChange: TNotifyEvent;
Private | FOnPrepareGLContext: TNotifyEvent;
Private | FBeforeRender: TNotifyEvent;
Private | FViewerBeforeRender: TNotifyEvent;
Private | FPostRender: TNotifyEvent;
Private | FAfterRender: TNotifyEvent;
Private | FInitiateRendering: TDirectRenderEvent;
Private | FWrapUpRendering: TDirectRenderEvent;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Acceleration: TgxContextAcceleration;
Public | function CreateSnapShot: TgxImage;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function GetPickedObject(x, y: Integer): TgxBaseSceneObject;
Public | function GetPickedObjects(const rect: TRect; objectCountGuess: Integer = 64): TgxPickList;
Public | function GetPixelColor(x, y: Integer): TColor;
Public | function GetPixelDepth(x, y: Integer): Single;
Public | function height: Integer;
Public | function ModelMatrix: TMatrix4f; deprecated;
Public | function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function PixelDepthToDistance(aDepth: Single): Single;
Public | function PixelRayToWorld(x, y: Integer): TAffineVector;
Public | function PixelToDistance(x, y: Integer): Single;
Public | function ProjectionMatrix: TMatrix4f; deprecated;
Public | function RCInstantiated: Boolean;
Public | function ScreenToVector(const aPoint: TVector4f): TVector4f; overload;
Public | function ScreenToVector(const x, y: Integer): TVector4f; overload;
Public | function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToWorld(const aPoint: TVector4f): TVector4f; overload;
Public | function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function ScreenVectorIntersectWithPlane(const aScreenPoint: TVector4f; const planePoint, planeNormal: TVector4f; var intersectPoint: TVector4f): Boolean;
Public | function ScreenVectorIntersectWithPlaneXY(const aScreenPoint: TVector4f; const z: Single; var intersectPoint: TVector4f): Boolean;
Public | function ScreenVectorIntersectWithPlaneXZ(const aScreenPoint: TVector4f; const y: Single; var intersectPoint: TVector4f): Boolean;
Public | function ScreenVectorIntersectWithPlaneYZ(const aScreenPoint: TVector4f; const x: Single; var intersectPoint: TVector4f): Boolean;
Public | function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;
Public | function ViewMatrix: TMatrix4f; deprecated;
Public | function width: Integer;
Public | function WorldToScreen(const aPoint: TVector4f): TVector4f; overload;
Public | function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;
Public | procedure ClearBuffers;
Public | procedure CopyToTexture(aTexture: TgxTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: GLEnum = 0); overload;
Public | procedure CopyToTexture(aTexture: TgxTexture); overload;
Public | procedure CreateRC(AWindowHandle: THandle; memoryContext: Boolean; BufferCount: Integer = 1); overload;
Public | procedure DestroyRC;
Public | procedure Freeze;
Public | procedure Melt;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyMouseMove(Shift: TShiftState; x, y: Single);
Public | procedure PickObjects(const rect: TRect; pickList: TgxPickList; objectCountGuess: Integer);
Public | procedure PopProjectionMatrix; deprecated;
Public | procedure PopViewMatrix; deprecated;
Public | procedure PushProjectionMatrix(const newMatrix: TMatrix4f); deprecated;
Public | procedure PushViewMatrix(const newMatrix: TMatrix4f); deprecated;
Public | procedure Render(baseObject: TgxBaseSceneObject); overload;
Public | procedure Render; overload;
Public | procedure RenderScene(aScene: TgxScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TGXDrawState; baseObject: TgxBaseSceneObject);
Public | procedure RenderToBitmap(ABitmap: TBitmap; DPI: Integer = 0);
Public | procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;
Public | procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;
Public | procedure ResetPerformanceMonitor;
Public | procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);
Public | procedure SaveAsFloatToFile(const aFilename: string);
Public | procedure SetViewPort(x, y, W, H: Integer);
Public | procedure ShowInfo(Modal: Boolean = False);
Public | procedure WorldToScreen(points: PVector4f; nbPoints: Integer); overload;
Private | procedure SetLayer(const Value: TgxContextLayer);

Properties

Published | property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;
Published | property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;
Published | property AmbientColor: TgxColor read FAmbientColor write SetAmbientColor;
Published | property AntiAliasing: TgxAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;
Public | property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;
Published | property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default TColors.SysBtnFace;
Public | property BaseProjectionMatrix: TMatrix4f read FBaseProjectionMatrix;
Published | property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;
Public | property Camera: TgxCamera read FCamera write SetCamera;
Published | property ColorDepth: TgxColorDepth read FColorDepth write SetColorDepth default cdDefault;
Published | property ContextOptions: TgxContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];
Published | property DepthPrecision: TgxDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;
Published | property DepthTest: Boolean read FDepthTest write SetDepthTest default True;
Published | property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;
Published | property FogEnable: Boolean read FFogEnable write SetFogEnable default False;
Published | property FogEnvironment: TgxFogEnvironment read FFogEnvironment write SetFogEnvironment stored StoreFog;
Public | property FramesPerSecond: Single read FFramesPerSecond;
Public | property Freezed: Boolean read FFreezed;
Published | property InitiateRendering: TDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;
Public | property LastFrameTime: Single read FLastFrameTime;
Public | property Layer: TgxContextLayer read FLayer write SetLayer default clMainPlane;
Published | property Lighting: Boolean read FLighting write SetLighting default True;
Public | property LimitOf[Which: TgxLimitType]: Integer read GetLimit;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;
Published | property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;
Published | property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;
Public | property Rendering: Boolean read FRendering;
Public | property RenderingContext: TgxContext read FRenderingContext;
Published | property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;
Public | property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;
Public | property viewport: TRectangle read FViewPort;
Published | property WrapUpRendering: TDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Description

Fields

Private FRendering: Boolean;

Internal state

Private FRenderingContext: TgxContext;

This item has no description.

Private FAfterRenderEffects: TgxPersistentObjectList;

This item has no description.

Private FViewMatrixStack: array of TMatrix4f;

This item has no description.

Private FProjectionMatrixStack: array of TMatrix4f;

This item has no description.

Private FBaseProjectionMatrix: TMatrix4f;

This item has no description.

Private FCameraAbsolutePosition: TVector4f;

This item has no description.

Private FViewPort: TRectangle;

This item has no description.

Private FSelector: TgxBaseSelectTechnique;

This item has no description.

Private FFaceCulling: Boolean;

Options & User Properties

Private FFogEnable: Boolean;

Options & User Properties

Private FLighting: Boolean;

Options & User Properties

Private FDepthTest: Boolean;

This item has no description.

Private FBackgroundColor: TColor;

This item has no description.

Private FBackgroundAlpha: Single;

This item has no description.

Private FAmbientColor: TgxColor;

This item has no description.

Private FAntiAliasing: TgxAntiAliasing;

This item has no description.

Private FDepthPrecision: TgxDepthPrecision;

This item has no description.

Private FColorDepth: TgxColorDepth;

This item has no description.

Private FContextOptions: TgxContextOptions;

This item has no description.

Private FShadeModel: TgxShadeModel;

This item has no description.

Private FRenderDPI: Integer;

This item has no description.

Private FFogEnvironment: TgxFogEnvironment;

This item has no description.

Private FAccumBufferBits: Integer;

This item has no description.

Private FLayer: TgxContextLayer;

This item has no description.

Private FCamera: TgxCamera;

Cameras

Private FFreezeBuffer: Pointer;

Freezing

Private FFreezed: Boolean;

This item has no description.

Private FFreezedViewPort: TRectangle;

This item has no description.

Private FFrameCount: Longint;

Monitoring

Private FFramesPerSecond: Single;

This item has no description.

Private FFirstPerfCounter: Int64;

This item has no description.

Private FLastFrameTime: Single;

This item has no description.

Private FOnChange: TNotifyEvent;

Events

Private FOnStructuralChange: TNotifyEvent;

This item has no description.

Private FOnPrepareGLContext: TNotifyEvent;

This item has no description.

Private FBeforeRender: TNotifyEvent;

This item has no description.

Private FViewerBeforeRender: TNotifyEvent;

This item has no description.

Private FPostRender: TNotifyEvent;

This item has no description.

Private FAfterRender: TNotifyEvent;

This item has no description.

Private FInitiateRendering: TDirectRenderEvent;

This item has no description.

Private FWrapUpRendering: TDirectRenderEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Acceleration: TgxContextAcceleration;

Indicates hardware acceleration support

Public function CreateSnapShot: TgxImage;

Creates a TgxBitmap32 that is a snapshot of current OpenGL content. When possible, use this function instead of RenderToBitmap, it won't request a redraw and will be significantly faster. The returned TgxBitmap32 should be freed by calling code.

Public function CreateSnapShotBitmap: TBitmap;

Creates a bitmap that is a snapshot of current graphic content.

Public function GetPickedObject(x, y: Integer): TgxBaseSceneObject;

Returns the nearest object at x, y coordinates or nil if there is none

Public function GetPickedObjects(const rect: TRect; objectCountGuess: Integer = 64): TgxPickList;

Returns a PickList with objects in Rect area. Returned list should be freed by caller. Objects are sorted by depth (nearest objects first).

Public function GetPixelColor(x, y: Integer): TColor;

Returns the color of the pixel at x, y in the frame buffer

Public function GetPixelDepth(x, y: Integer): Single;

Returns the raw depth (Z buffer) of the pixel at x, y in the frame buffer. This value does not map to the actual eye-object distance, but to a depth buffer value in the [0; 1] range.

Public function height: Integer;

This item has no description.

Public function ModelMatrix: TMatrix4f; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D coordinates for orthogonal projection. This function accepts standard canvas coordinates, with (0,0) being the top left corner, and returns, when the camera is in orthogonal mode, the corresponding 3D world point that is in the camera's plane.

Public function PixelDepthToDistance(aDepth: Single): Single;

Converts a raw depth (Z buffer value) to frustrum distance. This calculation is only accurate for the pixel at the centre of the viewer, because it does not take into account that the corners of the frustrum are further from the eye than its centre.

Public function PixelRayToWorld(x, y: Integer): TAffineVector;

Calculates a 3D coordinate from screen position and ZBuffer. This function returns a world absolute coordinate from a 2D point in the viewer, the depth being extracted from the ZBuffer data (DepthTesting and ZBuffer must be enabled for this function to work). Note that ZBuffer precision is not linear and can be quite low on some boards (either from compression or resolution approximations).

Public function PixelToDistance(x, y: Integer): Single;

Converts a raw depth (Z buffer value) to world distance. It also compensates for the fact that the corners of the frustrum are further from the eye, than its centre.

Public function ProjectionMatrix: TMatrix4f; deprecated;

Warning: this symbol is deprecated.

Returns the projection matrix in use or used for the last rendering.

Public function RCInstantiated: Boolean;

This item has no description.

Public function ScreenToVector(const aPoint: TVector4f): TVector4f; overload;

This item has no description.

Public function ScreenToVector(const x, y: Integer): TVector4f; overload;

This item has no description.

Public function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;

Calculates the 3D vector corresponding to a 2D screen coordinate. The vector originates from the camera's absolute position and is expressed in absolute coordinates. Note that screen coord (0,0) is the lower left corner.

Public function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;

Converts a screen coordinate into world (3D) coordinates. This methods wraps a call to gluUnProject. Note that screen coord (0,0) is the lower left corner.

Public function ScreenToWorld(const aPoint: TVector4f): TVector4f; overload;

This item has no description.

Public function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D world coordinates. This function accepts standard canvas coordinates, with (0,0) being the top left corner.

Public function ScreenVectorIntersectWithPlane(const aScreenPoint: TVector4f; const planePoint, planeNormal: TVector4f; var intersectPoint: TVector4f): Boolean;

Calculates intersection between a plane and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXY(const aScreenPoint: TVector4f; const z: Single; var intersectPoint: TVector4f): Boolean;

Calculates intersection between plane XY and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXZ(const aScreenPoint: TVector4f; const y: Single; var intersectPoint: TVector4f): Boolean;

Calculates intersection between plane XZ and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneYZ(const aScreenPoint: TVector4f; const x: Single; var intersectPoint: TVector4f): Boolean;

Calculates intersection between plane YZ and screen vector. If an intersection is found, returns True and places result in intersectPoint.

Public function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;

Calculates the 2D screen coordinate of a vector from the camera's absolute position and is expressed in absolute coordinates. Note that screen coord (0,0) is the lower left corner.

Public function ViewMatrix: TMatrix4f; deprecated;

Warning: this symbol is deprecated.

Returns the view matrix in use or used for the last rendering.

Public function width: Integer;

This item has no description.

Public function WorldToScreen(const aPoint: TVector4f): TVector4f; overload;

This item has no description.

Public function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;

Converts an absolute world coordinate into screen coordinate. This methods wraps a call to gluProject. Note that screen coord (0,0) is the lower left corner.

Public procedure ClearBuffers;

This item has no description.

Public procedure CopyToTexture(aTexture: TgxTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: GLEnum = 0); overload;

This item has no description.

Public procedure CopyToTexture(aTexture: TgxTexture); overload;

This item has no description.

Public procedure CreateRC(AWindowHandle: THandle; memoryContext: Boolean; BufferCount: Integer = 1); overload;

This item has no description.

Public procedure DestroyRC;

This item has no description.

Public procedure Freeze;

Freezes rendering leaving the last rendered scene on the buffer. This is usefull in windowed applications for temporarily stopping rendering (when moving the window, for example).

Public procedure Melt;

Restarts rendering after it was freezed.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyMouseMove(Shift: TShiftState; x, y: Single);

Design time notification

Public procedure PickObjects(const rect: TRect; pickList: TgxPickList; objectCountGuess: Integer);

Fills the PickList with objects in Rect area

Public procedure PopProjectionMatrix; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure PopViewMatrix; deprecated;

Warning: this symbol is deprecated.

Restore a View matrix previously pushed.

Public procedure PushProjectionMatrix(const newMatrix: TMatrix4f); deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure PushViewMatrix(const newMatrix: TMatrix4f); deprecated;

Warning: this symbol is deprecated.

Back up current View matrix and replace it with newMatrix. This method has no effect on theOpenVX matrix, only on the Buffer's matrix, and is intended for special effects rendering.

Public procedure Render(baseObject: TgxBaseSceneObject); overload;

Renders the scene on the viewer. You do not need to call this method, unless you explicitly want a render at a specific time. If you just want the control to get refreshed, use Invalidate instead.

Public procedure Render; overload;

This item has no description.

Public procedure RenderScene(aScene: TgxScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TGXDrawState; baseObject: TgxBaseSceneObject);

This item has no description.

Public procedure RenderToBitmap(ABitmap: TBitmap; DPI: Integer = 0);

Render the scene to a bitmap at given DPI. DPI = "dots per inch". The "magic" DPI of the screen is 96 under Windows.

Public procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;

Renders to bitmap of given size, then saves it to a file. DPI is adjusted to make the bitmap similar to the viewer.

Public procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;

Render the scene to a bitmap at given DPI and saves it to a file. DPI = "dots per inch". The "magic" DPI of the screen is 96 under Windows.

Public procedure ResetPerformanceMonitor;

Resets the perfomance monitor and begin a new statistics set. See FramesPerSecond.

Public procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);

This item has no description.

Public procedure SaveAsFloatToFile(const aFilename: string);

Save as raw float data to a file

Public procedure SetViewPort(x, y, W, H: Integer);

This item has no description.

Public procedure ShowInfo(Modal: Boolean = False);

Displays a window with info on current OpenGL ICD and context.

Public procedure WorldToScreen(points: PVector4f; nbPoints: Integer); overload;

Converts a set of point absolute world coordinates into screen coordinates.

Private procedure SetLayer(const Value: TgxContextLayer);

This item has no description.

Properties

Published property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;

Number of precision bits for the accumulation buffer.

Published property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property AmbientColor: TgxColor read FAmbientColor write SetAmbientColor;

Scene ambient color vector. This ambient color is defined independantly from all lightsources, which can have their own ambient components.

Published property AntiAliasing: TgxAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;

AntiAliasing option. Ignored if not hardware supported, currently based on ARB_multisample.

Public property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;

Adjusts background alpha channel.

Published property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default TColors.SysBtnFace;

Color used for filling the background prior to any rendering.

Public property BaseProjectionMatrix: TMatrix4f read FBaseProjectionMatrix;

Returns the base projection matrix in use or used for the last rendering. The "base" projection is (as of now) either identity or the pick matrix, ie. it is the matrix on which the perspective or orthogonal matrix gets applied.

Published property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering (usually background stuff).

Public property Camera: TgxCamera read FCamera write SetCamera;

The camera from which the scene is rendered. A camera is an object you can add and define in a TgxScene component.

Published property ColorDepth: TgxColorDepth read FColorDepth write SetColorDepth default cdDefault;

Color buffer depth. Default depth buffer is highest available (below and including 24 bits)

Published property ContextOptions: TgxContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];

Context options allows to setup specifics of the rendering context. Not all contexts support all options.

Published property DepthPrecision: TgxDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;

Depth buffer precision. Default is highest available (below and including 24 bits)

Published property DepthTest: Boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling. When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering). When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera. Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;

Enable or disable face culling in the renderer. Face culling is used in hidden faces removal algorithms : each face is given a normal or 'outside' direction. When face culling is enabled, only faces whose normal points towards the observer are rendered.

Published property FogEnable: Boolean read FFogEnable write SetFogEnable default False;

Toggle to enable or disable the fog settings.

Published property FogEnvironment: TgxFogEnvironment read FFogEnvironment write SetFogEnvironment stored StoreFog;

Fog environment options. See TgxFogEnvironment.

Public property FramesPerSecond: Single read FFramesPerSecond;

Current FramesPerSecond rendering speed. You must keep the renderer busy to get accurate figures from this property. This is an average value, to reset the counter, call ResetPerfomanceMonitor.

Public property Freezed: Boolean read FFreezed;

Indicates if the Viewer is "frozen".

Published property InitiateRendering: TDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;

Triggered after BeforeRender, before rendering objects. This one is fired after the rci has been initialized and can be used to alter it or perform early renderings that require an rci, the Sender is the buffer.

Public property LastFrameTime: Single read FLastFrameTime;

Time (in second) spent to issue rendering order for the last frame. Be aware that since execution by the hardware isn't synchronous, this value may not be an accurate measurement of the time it took to render the last frame, it's a measurement of only the time it took to issue rendering orders.

Public property Layer: TgxContextLayer read FLayer write SetLayer default clMainPlane;

Specifies the layer plane that the rendering context is bound to.

Published property Lighting: Boolean read FLighting write SetLighting default True;

Toggle to enable or disable lighting calculations. When lighting is enabled, objects will be lit according to lightsources, when lighting is disabled, objects are rendered in their own colors, without any shading. Lighting does NOT generate shadows in OpenGL.

Public property LimitOf[Which: TgxLimitType]: Integer read GetLimit;

Retrieve one of the OpenGL limits for the current viewer. Limits include max texture size, OpenGL stack depth, etc.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;

Indicates a change in the scene or buffer options. A simple re-render is enough to take into account the changes.

Published property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;

Indicates a structural change in the scene or buffer options. A reconstruction of the RC is necessary to take into account the changes (this may lead to a driver switch or lengthy operations).

Published property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering (usually for HUD, 2D overlays or after effects).

Public property Rendering: Boolean read FRendering;

Currently Rendering?

Public property RenderingContext: TgxContext read FRenderingContext;

Current rendering context. The context is a wrapper around platform-specific contexts (see TgxContext) and takes care of context activation and handle management.

Published property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model. Default is "Smooth".

Public property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;

Event reserved for viewer-specific uses.

Public property viewport: TRectangle read FViewPort;

ViewPort for current/last render

Published property WrapUpRendering: TDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Triggered after rendering all scene objects, before PostRender. This is the last point after which the rci becomes unavailable, the Sender is the buffer.


GXSysHelp v.2.5: GXS.Scene: Class TgxNonVisualViewer

Class TgxNonVisualViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxNonVisualViewer = class(TComponent)

Description

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNonVisualViewer

Overview

Fields

Private | FBuffer: TgxSceneBuffer;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FCubeMapRotIdx: Integer;
Private | FCubeMapZNear: Single;
Private | FCubeMapZFar: Single;
Private | FCubeMapTranslation: TAffineVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CopyToTexture(aTexture: TgxTexture); overload; virtual;
Public | procedure CopyToTexture(aTexture: TgxTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;
Public | procedure CopyToTextureMRT(aTexture: TgxTexture; BufferIndex: Integer); overload; virtual;
Public | procedure CopyToTextureMRT(aTexture: TgxTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: Integer); overload;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Render(baseObject: TgxBaseSceneObject = nil); virtual; abstract;
Public | procedure RenderCubeMapTextures(cubeMapTexture: TgxTexture; zNear: Single = 0; zFar: Single = 0);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TgxSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TgxCamera read GetCamera write SetCamera;
Published | property height: Integer read FHeight write SetHeight default 256;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Published | property width: Integer read FWidth write SetWidth default 256;

Description

Fields

Private FBuffer: TgxSceneBuffer;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FCubeMapRotIdx: Integer;

This item has no description.

Private FCubeMapZNear: Single;

This item has no description.

Private FCubeMapZFar: Single;

This item has no description.

Private FCubeMapTranslation: TAffineVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure CopyToTexture(aTexture: TgxTexture); overload; virtual;

This item has no description.

Public procedure CopyToTexture(aTexture: TgxTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;

This item has no description.

Public procedure CopyToTextureMRT(aTexture: TgxTexture; BufferIndex: Integer); overload; virtual;

CopyToTexture for Multiple-Render-Target

Public procedure CopyToTextureMRT(aTexture: TgxTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: Integer); overload;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure Render(baseObject: TgxBaseSceneObject = nil); virtual; abstract;

This item has no description.

Public procedure RenderCubeMapTextures(cubeMapTexture: TgxTexture; zNear: Single = 0; zFar: Single = 0);

Renders the 6 texture maps from a scene. The viewer is used to render the 6 images, one for each face of the cube, from the absolute position of the camera. This does NOT alter the content of the Pictures in the image, and will only change or define the content of textures as registered by OpenGL.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TgxSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TgxCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property height: Integer read FHeight write SetHeight default 256;

This item has no description.

Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Published property width: Integer read FWidth write SetWidth default 256;


GXSysHelp v.2.5: GXS.Scene: Class TgxMemoryViewer

Class TgxMemoryViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Scene

Declaration

type TgxMemoryViewer = class(TgxNonVisualViewer)

Description

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNonVisualViewer
  • TgxMemoryViewer

Overview

Fields

Private FBufferCount: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InstantiateRenderingContext;
Public | procedure Render(baseObject: TgxBaseSceneObject = nil); override;
Private | procedure SetBufferCount(const Value: Integer);

Properties

Published property BufferCount: Integer read FBufferCount write SetBufferCount default 1;

Description

Fields

Private FBufferCount: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InstantiateRenderingContext;

This item has no description.

Public procedure Render(baseObject: TgxBaseSceneObject = nil); override;

This item has no description.

Private procedure SetBufferCount(const Value: Integer);

This item has no description.

Properties

Published property BufferCount: Integer read FBufferCount write SetBufferCount default 1;

Set BufferCount > 1 for multiple render targets. Users should check if the corresponding extension (GL_ATI_draw_buffers) is supported. Current hardware limit is BufferCount = 4.


GXSysHelp v.2.5: GXS.SceneRegister

Unit GXS.SceneRegister

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • FMX.Forms
  • FMX.Dialogs
  • FMX.Controls
  • FMX.StdCtrls
  • FMX.Graphics
  • GLScene.Strings
  • GLScene.Utils
  • GXS.Scene
  • GXS.Context
  • GXS.Color
  • GXS.SceneViewer
  • GXS.ObjectManager

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxLibMaterialNameProperty |
Class TgxSceneViewerEditor |
Class TgxSceneEditor |
Class TgxResolutionProperty |
Class TgxTextureProperty |
Class TgxTextureImageProperty |
Class TgxImageClassProperty |
Class TgxColorProperty |
Class TgxSoundFileProperty |
Class TgxSoundNameProperty |
Class TgxCoordinatesProperty |
Class TgxMaterialProperty |
Class TgxGUILayoutEditor |
Class TgxReuseableDefaultEditor |
Class TgxMaterialLibraryEditor |
Class TgxAnimationNameProperty |
Class TgxSoundLibrarySelectionEditor |
Class TgxBaseSceneObjectSelectionEditor |
Class TgxSArchiveManagerEditor |
Class TgxMaterialComponentNameProperty |
Class TgxLibTextureNameProperty |
Class TgxLibSamplerNameProperty |
Class TgxLibCombinerNameProperty |
Class TgxLibShaderNameProperty |
Class TgxLibAttachmentNameProperty |
Class TgxLibAsmProgNameProperty |
Class TPictureFileProperty |
Class TShaderFileProperty |
Class TAsmProgFileProperty |
Class TUniformAutoSetProperty |
Class TgxShaderEditorProperty |

Functions and Procedures

procedure Register;
function ObjectManager: TgxObjectManager;

Description

Functions and Procedures

procedure Register;

This item has no description.

function ObjectManager: TgxObjectManager;

Auto-create for object manager


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibMaterialNameProperty

Class TgxLibMaterialNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibMaterialNameProperty = class(TStringProperty)

Description

DesignIntf, DesignEditors, DesignMenus,

Hierarchy

  • TStringProperty
  • TgxLibMaterialNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSceneViewerEditor

Class TgxSceneViewerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSceneViewerEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TgxSceneViewerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSceneEditor

Class TgxSceneEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSceneEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TgxSceneEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxResolutionProperty

Class TgxResolutionProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxResolutionProperty = class(TPropertyEditor)

Description

This item has no description.

Hierarchy

  • TPropertyEditor
  • TgxResolutionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public function GetValue: string; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: string); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxTextureProperty

Class TgxTextureProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxTextureProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxTextureProperty

Overview

Methods

Public function GetAttributes: TPropertyAttributes; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxTextureImageProperty

Class TgxTextureImageProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxTextureImageProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxTextureImageProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxImageClassProperty

Class TgxImageClassProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxImageClassProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxImageClassProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public function GetValue: string; override;

This item has no description. Showing description inherited from TClassProperty.GetValue.

in VCL -> (Proc: TGetPropProc) //override; <- not found in base class

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure SetValue(const Value: string); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxColorProperty

Class TgxColorProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxColorProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxColorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure Edit; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);
Public | procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);
Public | procedure PropDrawName(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure PropDrawValue(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public function GetValue: string; override;

This item has no description. Showing description inherited from TClassProperty.GetValue.

in VCL -> (Proc: TGetPropProc) //override; <- not found in base class

Public procedure Edit; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;

This item has no description.

Public procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

This item has no description.

Public procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);

ICustomPropertyListDrawing stuff

Public procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);

This item has no description.

Public procedure PropDrawName(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

CustomPropertyDrawing

Public procedure PropDrawValue(ACanvas: TCanvas; const ARect: TRect; ASelected: Boolean);

This item has no description.

Public procedure SetValue(const Value: string); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSoundFileProperty

Class TgxSoundFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSoundFileProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxSoundFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public function GetValue: string; override;

This item has no description. Showing description inherited from TClassProperty.GetValue.

in VCL -> (Proc: TGetPropProc) //override; <- not found in base class

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSoundNameProperty

Class TgxSoundNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSoundNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxSoundNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxCoordinatesProperty

Class TgxCoordinatesProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxCoordinatesProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxCoordinatesProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxMaterialProperty

Class TgxMaterialProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxMaterialProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxMaterialProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxGUILayoutEditor

Class TgxGUILayoutEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxGUILayoutEditor = class(TComponentEditor)

Description

This item has no description.

Hierarchy

  • TComponentEditor
  • TgxGUILayoutEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxReuseableDefaultEditor

Class TgxReuseableDefaultEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxReuseableDefaultEditor = class(TComponentEditor, IDefaultEditor)

Description

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TgxSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! Grrr...

Hierarchy

  • TComponentEditor
  • TgxReuseableDefaultEditor

Overview

Methods

Public procedure Edit; override;

Description

Methods

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxMaterialLibraryEditor

Class TgxMaterialLibraryEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxMaterialLibraryEditor = class(TgxReuseableDefaultEditor, IDefaultEditor)

Description

Editor for material library.

Hierarchy

  • TComponentEditor
  • TgxReuseableDefaultEditor
  • TgxMaterialLibraryEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxAnimationNameProperty

Class TgxAnimationNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxAnimationNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxAnimationNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSoundLibrarySelectionEditor

Class TgxSoundLibrarySelectionEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSoundLibrarySelectionEditor = class(TSelectionEditor)

Description

Selection editor for TgxSoundLibrary. Allows units to be added to the uses clause automatically when sound files are loaded into a TgxSoundLibrary at design-time.

Hierarchy

  • TSelectionEditor
  • TgxSoundLibrarySelectionEditor

Overview

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;

Description

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxBaseSceneObjectSelectionEditor

Class TgxBaseSceneObjectSelectionEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxBaseSceneObjectSelectionEditor = class(TSelectionEditor)

Description

Selection editor for TgxBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TgxBaseSceneObject at design-time.

Hierarchy

  • TSelectionEditor
  • TgxBaseSceneObjectSelectionEditor

Overview

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;

Description

Methods

Public procedure RequiresUnits(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxSArchiveManagerEditor

Class TgxSArchiveManagerEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxSArchiveManagerEditor = class(TgxReuseableDefaultEditor, IDefaultEditor)

Description

Editor for Archive Manager.

Hierarchy

  • TComponentEditor
  • TgxReuseableDefaultEditor
  • TgxSArchiveManagerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;

This item has no description.

Public function GetVerbCount: Integer; override;

This item has no description.

Public procedure ExecuteVerb(Index: Integer); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxMaterialComponentNameProperty

Class TgxMaterialComponentNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxMaterialComponentNameProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibTextureNameProperty

Class TgxLibTextureNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibTextureNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibTextureNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibSamplerNameProperty

Class TgxLibSamplerNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibSamplerNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibSamplerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibCombinerNameProperty

Class TgxLibCombinerNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibCombinerNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibCombinerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibShaderNameProperty

Class TgxLibShaderNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibShaderNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibShaderNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibAttachmentNameProperty

Class TgxLibAttachmentNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibAttachmentNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibAttachmentNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxLibAsmProgNameProperty

Class TgxLibAsmProgNameProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxLibAsmProgNameProperty = class(TgxMaterialComponentNameProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TgxMaterialComponentNameProperty
  • TgxLibAsmProgNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TPictureFileProperty

Class TPictureFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TPictureFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TPictureFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TShaderFileProperty

Class TShaderFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TShaderFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TShaderFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TAsmProgFileProperty

Class TAsmProgFileProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TAsmProgFileProperty = class(TStringProperty)

Description

This item has no description.

Hierarchy

  • TStringProperty
  • TAsmProgFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneRegister: Class TUniformAutoSetProperty

Class TUniformAutoSetProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TUniformAutoSetProperty = class(TPropertyEditor)

Description

This item has no description.

Hierarchy

  • TPropertyEditor
  • TUniformAutoSetProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;
Private | procedure PassUniform(const S: string);

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description.

Public procedure Edit; override;

This item has no description.

Private procedure PassUniform(const S: string);


GXSysHelp v.2.5: GXS.SceneRegister: Class TgxShaderEditorProperty

Class TgxShaderEditorProperty

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneRegister

Declaration

type TgxShaderEditorProperty = class(TClassProperty)

Description

This item has no description.

Hierarchy

  • TObject
  • TClassProperty
  • TgxShaderEditorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;

This item has no description. Showing description inherited from TClassProperty.GetAttributes.

class(TPropertyEditor)

Public procedure Edit; override;


GXSysHelp v.2.5: GXS.SceneViewer

Unit GXS.SceneViewer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.OpenGL4
  • Winapi.Windows
  • WinApi.Messages
  • System.Classes
  • System.SysUtils
  • System.Types
  • FMX.Graphics
  • FMX.Forms
  • FMX.Controls
  • FMX.Dialogs.Win
  • FMX.Viewport3D
  • GXS.Scene
  • GXS.Context
  • GXS.WinContext

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxCreateParams |
Class TgxSceneViewer |

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TgxSyncMode);

Types

TgxTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; MultiTouch : boolean) of object;

Variables

Handle: HWND;

Description

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TgxSyncMode);

This item has no description.

Types

TgxTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; MultiTouch : boolean) of object;

This item has no description.

Variables

Handle: HWND;


GXSysHelp v.2.5: GXS.SceneViewer: Record TgxCreateParams

Record TgxCreateParams

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneViewer

Declaration

type TgxCreateParams = record

Description

WGL_EXT_swap_control

Overview

Fields

Public | Caption: PChar;
Public | Style: DWORD;
Public | ExStyle: DWORD;
Public | X: Integer;
Public | Y: Integer;
Public | Width: Integer;
Public | Height: Integer;
Public | Param: Pointer;
Public | WinClassName: array[0..63] of Char;

Description

Fields

Public Caption: PChar;

This item has no description.

Public Style: DWORD;

This item has no description.

Public ExStyle: DWORD;

This item has no description.

Public X: Integer;

This item has no description.

Public Y: Integer;

This item has no description.

Public Width: Integer;

This item has no description.

Public Height: Integer;

This item has no description.

Public Param: Pointer;

WndParent: HWnd; - not fmx

Public WinClassName: array[0..63] of Char;

WindowClass: TWndClass; - not fmx


GXSysHelp v.2.5: GXS.SceneViewer: Class TgxSceneViewer

Class TgxSceneViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SceneViewer

Declaration

type TgxSceneViewer = class(TViewPort3D)

Description

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.

Hierarchy

  • TViewPort3D
  • TgxSceneViewer

Overview

Fields

Private | FBuffer: TgxSceneBuffer;
Private | FVSync: TgxSyncMode;
Private | FOwnDC: HDC;
Private | FOnMouseEnter: TNotifyEvent;
Private | FOnMouseLeave: TNotifyEvent;
Private | FMouseInControl: Boolean;
Private | FLastScreenPos: TPoint;
Private | FPenAsTouch: boolean;
Private | FOnTouchMove: TgxTouchEvent;
Private | FOnTouchUp: TgxTouchEvent;
Private | FOnTouchDown: TgxTouchEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): string;
Public | function LastFrameTime: Single;
Private | function GetFieldOfView: single;
Private | function GetIsRenderingContextAvailable: Boolean;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RecreateWnd;
Public | procedure RegisterTouch;
Public | procedure ResetPerformanceMonitor;
Public | procedure UnregisterTouch;
Private | procedure CMMouseEnter(var msg: TMessage);
Private | procedure CMMouseLeave(var msg: TMessage);
Private | procedure SetFieldOfView(const Value: single);
Private | procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;
Private | procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;
Private | procedure WMGetDglCode(var Message: TMessage); message WM_GETDLGCODE;
Private | procedure WMPaint(var Message: TWMPaint); message WM_PAINT;
Private | procedure WMSize(var Message: TWMSize); message WM_SIZE;
Private | procedure WMTouch(var Message: TMessage); message WM_TOUCH;

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property Align;
Published | property Anchors;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TgxSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TgxCamera read GetCamera write SetCamera;
Published | property DragMode;
Published | property Enabled;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property Hint;
Public | property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Public | property MouseInControl: Boolean read FMouseInControl;
Published | property OnClick;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGesture;
Published | property OnKeyDown;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMouseWheel;
Published | property OnTouchDown: TgxTouchEvent read FOnTouchDown write FOnTouchDown;
Published | property OnTouchMove: TgxTouchEvent read FOnTouchMove write FOnTouchMove;
Published | property OnTouchUp: TgxTouchEvent read FOnTouchUp write FOnTouchUp;
Published | property PenAsTouch: boolean read FPenAsTouch write FPenAsTouch;
Published | property PopupMenu;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HDC read FOwnDC;
Published | property TabOrder;
Published | property TabStop;
Published | property Touch;
Published | property Visible;
Published | property VSync: TgxSyncMode read FVSync write FVSync default vsmNoSync;

Description

Fields

Private FBuffer: TgxSceneBuffer;

This item has no description.

Private FVSync: TgxSyncMode;

This item has no description.

Private FOwnDC: HDC;

This item has no description.

Private FOnMouseEnter: TNotifyEvent;

This item has no description.

Private FOnMouseLeave: TNotifyEvent;

This item has no description.

Private FMouseInControl: Boolean;

This item has no description.

Private FLastScreenPos: TPoint;

This item has no description.

Private FPenAsTouch: boolean;

This item has no description.

Private FOnTouchMove: TgxTouchEvent;

This item has no description.

Private FOnTouchUp: TgxTouchEvent;

This item has no description.

Private FOnTouchDown: TgxTouchEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

Vcl - override;

Public destructor Destroy; override;

This item has no description.

Public function CreateSnapShotBitmap: TBitmap;

This item has no description.

Public function FramesPerSecond: Single;

This item has no description.

Public function FramesPerSecondText(decimals: Integer = 1): string;

This item has no description.

Public function LastFrameTime: Single;

This item has no description.

Private function GetFieldOfView: single;

message CM_MOUSELEAVE;

Private function GetIsRenderingContextAvailable: Boolean;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RecreateWnd;

Makes TWinControl's RecreateWnd public. This procedure allows to work around limitations in some OpenGL drivers (like MS Software OpenGL) that are not able to share lists between RCs that already have display lists.

Public procedure RegisterTouch;

This item has no description.

Public procedure ResetPerformanceMonitor;

This item has no description.

Public procedure UnregisterTouch;

This item has no description.

Private procedure CMMouseEnter(var msg: TMessage);

TODO -oPW -cMessages : Convert message CM_MOUSEENTER to FMX

Private procedure CMMouseLeave(var msg: TMessage);

TODO -oPW -cMessages : Convert message CM_MOUSELEAVE; to FMX

Private procedure SetFieldOfView(const Value: single);

This item has no description.

Private procedure WMDestroy(var Message: TWMDestroy); message WM_DESTROY;

This item has no description.

Private procedure WMEraseBkgnd(var Message: TWMEraseBkgnd); message WM_ERASEBKGND;

This item has no description.

Private procedure WMGetDglCode(var Message: TMessage); message WM_GETDLGCODE;

This item has no description.

Private procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

This item has no description.

Private procedure WMSize(var Message: TWMSize); message WM_SIZE;

This item has no description.

Private procedure WMTouch(var Message: TMessage); message WM_TOUCH;

This item has no description.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property Align;

This item has no description.

Published property Anchors;

This item has no description.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TgxSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TgxCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property DragMode;

property DragCursor;

Published property Enabled;

This item has no description.

Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;

Returns or sets the field of view for the viewer, in degrees. This value depends on the camera and the width and height of the scene. The value isn't persisted, if the width/height or camera.focallength is changed, FieldOfView is changed also.

Published property Hint;

property HelpContext; - Vcl

Public property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;

This item has no description.

Public property MouseInControl: Boolean read FMouseInControl;

This item has no description.

Published property OnClick;

This item has no description.

Published property OnDblClick;

This item has no description.

Published property OnDragDrop;

This item has no description.

Published property OnDragOver;

This item has no description.

Published property OnEnter;

This item has no description.

Published property OnExit;

This item has no description.

Published property OnGesture;

This item has no description.

Published property OnKeyDown;

property OnMouseWheelDown; - Vcl property OnMouseWheelUp; - Vcl

Published property OnKeyUp;

This item has no description.

Published property OnMouseDown;

property OnStartDrag; - Vcl property OnEndDrag; - Vcl

Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;

This item has no description.

Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;

This item has no description.

Published property OnMouseMove;

This item has no description.

Published property OnMouseUp;

This item has no description.

Published property OnMouseWheel;

This item has no description.

Published property OnTouchDown: TgxTouchEvent read FOnTouchDown write FOnTouchDown;

This item has no description.

Published property OnTouchMove: TgxTouchEvent read FOnTouchMove write FOnTouchMove;

This item has no description.

Published property OnTouchUp: TgxTouchEvent read FOnTouchUp write FOnTouchUp;

This item has no description.

Published property PenAsTouch: boolean read FPenAsTouch write FPenAsTouch;

Since Windows 10 Fall Creators Update in 2017, pen also triggers touch input. You can set PenAsTouch = false to filter out such input.

Published property PopupMenu;

This item has no description.

Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Public property RenderDC: HDC read FOwnDC;

This item has no description.

Published property TabOrder;

This item has no description.

Published property TabStop;

property OnContextPopup; - Vcl

Published property Touch;

This item has no description.

Published property Visible;

This item has no description.

Published property VSync: TgxSyncMode read FVSync write FVSync default vsmNoSync;

Specifies if the refresh should be synchronized with the VSync signal. If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.


GXSysHelp v.2.5: GXS.Screen

Unit GXS.Screen

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Forms
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxDisplayOptions |
Packed Record TgxVideoMode |

Functions and Procedures

function GetIndexFromResolution(XRes, YRes, BPP: Integer): TResolution;
procedure ReadVideoModes;
function SetFullscreenMode(modeIndex: TResolution; displayFrequency: Integer = 0): Boolean;
procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; const SrcRect: TRectangle);
procedure RestoreDefaultMode;
procedure GLShowCursor(AShow: Boolean);
procedure GLSetCursorPos(AScreenX, AScreenY: Integer);
procedure GLGetCursorPos(var point: TPoint);
function GLGetScreenWidth: Integer;
function GLGetScreenHeight: Integer;

Types

PgxVideoMode = ˆTgxVideoMode;
TgxWindowAttribute = (...);
TgxWindowAttributes = set of TgxWindowAttribute;
TgxWindowFitting = (...);
TResolution = 0 .. MaxVideoModes;

Constants

MaxVideoModes = 200;
lcl_release = 0;

Variables

vNumberVideoModes: Integer = 0;
vCurrentVideoMode: Integer = 0;
vVideoModes: array of TgxVideoMode;

Description

Functions and Procedures

function GetIndexFromResolution(XRes, YRes, BPP: Integer): TResolution;

This item has no description.

procedure ReadVideoModes;

This item has no description.

function SetFullscreenMode(modeIndex: TResolution; displayFrequency: Integer = 0): Boolean;

Changes to the video mode given by 'Index'

procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; const SrcRect: TRectangle);

This item has no description.

procedure RestoreDefaultMode;

This item has no description.

procedure GLShowCursor(AShow: Boolean);

This item has no description.

procedure GLSetCursorPos(AScreenX, AScreenY: Integer);

This item has no description.

procedure GLGetCursorPos(var point: TPoint);

This item has no description.

function GLGetScreenWidth: Integer;

This item has no description.

function GLGetScreenHeight: Integer;

This item has no description.

Types

PgxVideoMode = ˆTgxVideoMode;

This item has no description.

TgxWindowAttribute = (...);

window attributes

Values
  • woDesktop
  • woStayOnTop
  • woTransparent
TgxWindowAttributes = set of TgxWindowAttribute;

This item has no description.

TgxWindowFitting = (...);

window-to-screen fitting

Values
  • wfDefault
  • wfFitWindowToScreen
  • wfFitScreenToWindow
TResolution = 0 .. MaxVideoModes;

This item has no description.

Constants

MaxVideoModes = 200;

This item has no description.

lcl_release = 0;

This item has no description.

Variables

vNumberVideoModes: Integer = 0;

This item has no description.

vCurrentVideoMode: Integer = 0;

This item has no description.

vVideoModes: array of TgxVideoMode;


GXSysHelp v.2.5: GXS.Screen: Class TgxDisplayOptions

Class TgxDisplayOptions

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Screen

Declaration

type TgxDisplayOptions = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxDisplayOptions

Overview

Fields

Private | FFullScreen: Boolean;
Private | FScreenResolution: TResolution;
Private | FWindowAttributes: TgxWindowAttributes;
Private | FWindowFitting: TgxWindowFitting;

Methods

Public procedure Assign(Source: TPersistent); override;

Properties

Published | property FullScreen: Boolean read FFullScreen write FFullScreen default False;
Published | property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;
Published | property WindowAttributes: TgxWindowAttributes read FWindowAttributes write FWindowAttributes default [];
Published | property WindowFitting: TgxWindowFitting read FWindowFitting write FWindowFitting default wfDefault;

Description

Fields

Private FFullScreen: Boolean;

This item has no description.

Private FScreenResolution: TResolution;

This item has no description.

Private FWindowAttributes: TgxWindowAttributes;

This item has no description.

Private FWindowFitting: TgxWindowFitting;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property FullScreen: Boolean read FFullScreen write FFullScreen default False;

This item has no description.

Published property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;

This item has no description.

Published property WindowAttributes: TgxWindowAttributes read FWindowAttributes write FWindowAttributes default [];

This item has no description.

Published property WindowFitting: TgxWindowFitting read FWindowFitting write FWindowFitting default wfDefault;


GXSysHelp v.2.5: GXS.Screen: Packed Record TgxVideoMode

Packed Record TgxVideoMode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Screen

Declaration

type TgxVideoMode = packed record

Description

This item has no description.

Overview

Fields

Public | Width: Word;
Public | Height: Word;
Public | ColorDepth: Byte;
Public | MaxFrequency: Byte;
Public | Description: String;

Description

Fields

Public Width: Word;

This item has no description.

Public Height: Word;

This item has no description.

Public ColorDepth: Byte;

This item has no description.

Public MaxFrequency: Byte;

This item has no description.

Public Description: String;


GXSysHelp v.2.5: GXS.ScreenSaver

Unit GXS.ScreenSaver

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Win.Registry
  • FMX.Dialogs
  • FMX.Controls
  • FMX.Forms
  • FMX.Extctrls
  • FMX.Types

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxScreenSaver |

Functions and Procedures

procedure SetScreenSaverPassword;

Types

TScreenSaverOption = (...);
TScreenSaverOptions = set of TScreenSaverOption;
TScreenSaverPreviewEvent = procedure(Sender: TObject; previewHwnd: HWND) of object;

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];

Description

Functions and Procedures

procedure SetScreenSaverPassword;

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

Types

TScreenSaverOption = (...);

Options of screen-saver.

ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). - ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) - ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) - ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)

Values
  • ssoAutoAdjustFormProperties
  • ssoAutoHookKeyboardEvents
  • ssoAutoHookMouseEvents
  • ssoEnhancedMouseMoveDetection
TScreenSaverOptions = set of TScreenSaverOption;

This item has no description.

TScreenSaverPreviewEvent = procedure(Sender: TObject; previewHwnd: HWND) of object;

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];


GXSysHelp v.2.5: GXS.ScreenSaver: Class TgxScreenSaver

Class TgxScreenSaver

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ScreenSaver

Declaration

type TgxScreenSaver = class(TComponent)

Description

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible)

There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxScreenSaver

Overview

Fields

Private | mouseEventsToIgnore: Integer;
Private | FHonourWindowsPassword: Boolean;
Private | FOptions: TScreenSaverOptions;
Private | FOnPropertiesRequested: TNotifyEvent;
Private | FOnExecute: TNotifyEvent;
Private | FOnPreview: TScreenSaverPreviewEvent;
Private | FOnCloseQuery: TCloseQueryEvent;
Private | FAboutString: String;
Private | FInPreviewMode: Boolean;
Private | mouseTimer: TTimer;
Private | lastMousePosition: TPoint;
Private | FMutex: THandle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CloseSaver: Boolean;
Public | procedure SetPassword;

Properties

Published | property AboutString: String read FAboutString write FAboutString;
Published | property HonourWindowsPassword: Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;
Public | property InPreviewMode: Boolean read FInPreviewMode;
Published | property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;
Published | property OnExecute: TNotifyEvent read FOnExecute write FOnExecute;
Published | property OnPreview: TScreenSaverPreviewEvent read FOnPreview write FOnPreview;
Published | property OnPropertiesRequested: TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;
Published | property Options: TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;

Description

Fields

Private mouseEventsToIgnore: Integer;

This item has no description.

Private FHonourWindowsPassword: Boolean;

This item has no description.

Private FOptions: TScreenSaverOptions;

This item has no description.

Private FOnPropertiesRequested: TNotifyEvent;

This item has no description.

Private FOnExecute: TNotifyEvent;

This item has no description.

Private FOnPreview: TScreenSaverPreviewEvent;

This item has no description.

Private FOnCloseQuery: TCloseQueryEvent;

This item has no description.

Private FAboutString: String;

This item has no description.

Private FInPreviewMode: Boolean;

This item has no description.

Private mouseTimer: TTimer;

This item has no description.

Private lastMousePosition: TPoint;

alocated only if necessary

Private FMutex: THandle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CloseSaver: Boolean;

Properly handles request to close the main window. Returns True if the Close request wasn't canceled (by event or password fail) and will actually happen. Use this if you implemented specific screen-saver exiting in your main form. It first triggers the OnCloseQuery, where the close request can be canceled, if this passed, the password is checked if there is any, then sends a WM_CLOSE to the saver windows.

Public procedure SetPassword;

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

Properties

Published property AboutString: String read FAboutString write FAboutString;

This string is displayed if OnPropertiesRequested is not used. You may use it as a quick "AboutBox".

Published property HonourWindowsPassword: Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;

If True, windows screen-saver password is checked before closing. You may be wanting to set this prop to false if you're using your own password scheme or do not want any password to be set.

Public property InPreviewMode: Boolean read FInPreviewMode;

True if the screen-save is in preview mode. Valid only when the TScreenSaver has completed loading.

Published property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;

Fired when screen-saver execution should close. It is invoked before querying for password (if there is a password).

Published property OnExecute: TNotifyEvent read FOnExecute write FOnExecute;

Fired when the saver should start executing, after form props are adjusted

Published property OnPreview: TScreenSaverPreviewEvent read FOnPreview write FOnPreview;

Fired when preview is requested, after form props are adjusted.

Published property OnPropertiesRequested: TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;

Display the properties dialog when this event is triggered. This event may be called before Delphi's form auto-creation is complete, and should not rely on auto-created dialogs/forms but create what needs be

Published property Options: TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;


GXSysHelp v.2.5: GXS.ScriptBase

Unit GXS.ScriptBase

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GLScene.XCollection

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxScriptBase |
Class TgxScripts |
Class TgxScriptLibrary |

Types

TgxScriptState = (...);

Description

Types

TgxScriptState = (...);

This item has no description.

Values
  • ssUncompiled
  • ssCompileErrors: The script has yet to be compiled.
  • ssCompiled: Errors occurred while compiling.
  • ssRunningErrors: The script has been compiled and is ready to be executed/started.
  • ssRunning: Errors occured while the script was running.


GXSysHelp v.2.5: GXS.ScriptBase: Class TgxScriptBase

Class TgxScriptBase

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ScriptBase

Declaration

type TgxScriptBase = class(TXCollectionItem)

Description

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxScriptBase

Overview

Fields

Private | FText: TStringList;
Private | FDescription: String;
Private | FErrors: TStringList;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function Call(aName: String; aParams: array of Variant): Variant; virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; virtual; abstract;
Public | procedure Execute; virtual; abstract;
Public | procedure Invalidate; virtual; abstract;
Public | procedure Start; virtual; abstract;
Public | procedure Stop; virtual; abstract;

Properties

Published | property Description: String read FDescription write FDescription;
Public | property Errors: TStringList read FErrors;
Public | property State: TgxScriptState read GetState;
Published | property Text: TStringList read FText write SetText;

Description

Fields

Private FText: TStringList;

This item has no description.

Private FDescription: String;

This item has no description.

Private FErrors: TStringList;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Call(aName: String; aParams: array of Variant): Variant; virtual; abstract;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Compile; virtual; abstract;

This item has no description.

Public procedure Execute; virtual; abstract;

This item has no description.

Public procedure Invalidate; virtual; abstract;

This item has no description.

Public procedure Start; virtual; abstract;

This item has no description.

Public procedure Stop; virtual; abstract;

This item has no description.

Properties

Published property Description: String read FDescription write FDescription;

This item has no description.

Public property Errors: TStringList read FErrors;

This item has no description.

Public property State: TgxScriptState read GetState;

This item has no description.

Published property Text: TStringList read FText write SetText;


GXSysHelp v.2.5: GXS.ScriptBase: Class TgxScripts

Class TgxScripts

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ScriptBase

Declaration

type TgxScripts = class(TXCollection)

Description

XCollection descendant for storing and handling scripts.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxScripts

Overview

Methods

Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public property Items[index: Integer]: TgxScriptBase read GetItems;

Description

Methods

Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Items[index: Integer]: TgxScriptBase read GetItems;


GXSysHelp v.2.5: GXS.ScriptBase: Class TgxScriptLibrary

Class TgxScriptLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ScriptBase

Declaration

type TgxScriptLibrary = class(TComponent)

Description

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxScriptLibrary

Overview

Fields

Private FScripts: TgxScripts;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Scripts: TgxScripts read FScripts;

Description

Fields

Private FScripts: TgxScripts;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Scripts: TgxScripts read FScripts;


GXSysHelp v.2.5: GXS.Selection

Unit GXS.Selection

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.SysUtils
  • System.Classes
  • GXS.Context
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GXS.BaseClasses
  • GXS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPickRecord |
Class TgxPickList |
Class TgxBaseSelectTechnique |
Class TgxSelectRenderModeTechnique |

Functions and Procedures

function GetBestSelectorClass: TgxBaseSelectTechniqueClass;

Types

TgxBaseSelectTechniqueClass = class of TgxBaseSelectTechnique;
TPickSortType = (...);
TPickSubObjects = array of LongInt;

Constants

MAX_OBJECT_STACK_DEPTH = 512;

Description

Functions and Procedures

function GetBestSelectorClass: TgxBaseSelectTechniqueClass;

This item has no description.

Types

TgxBaseSelectTechniqueClass = class of TgxBaseSelectTechnique;

This item has no description.

TPickSortType = (...);

This item has no description.

Values
  • psDefault
  • psName
  • psMinDepth
  • psMaxDepth
TPickSubObjects = array of LongInt;

This item has no description.

Constants

MAX_OBJECT_STACK_DEPTH = 512;


GXSysHelp v.2.5: GXS.Selection: Class TPickRecord

Class TPickRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Selection

Declaration

type TPickRecord = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TPickRecord

Overview

Fields

Public | AObject: TgxUpdateAbleComponent;
Public | SubObjects: TPickSubObjects;
Public | ZMin: Single;
Public | ZMax: Single;

Description

Fields

Public AObject: TgxUpdateAbleComponent;

This item has no description.

Public SubObjects: TPickSubObjects;

This item has no description.

Public ZMin: Single;

This item has no description.

Public ZMax: Single;


GXSysHelp v.2.5: GXS.Selection: Class TgxPickList

Class TgxPickList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Selection

Declaration

type TgxPickList = class(TgxPersistentObjectList)

Description

List class for object picking. This list is used to store the results of a PickObjects call.

Hierarchy

  • TgxPersistentObjectList
  • TgxPickList

Overview

Methods

Public | constructor Create(aSortType: TPickSortType); reintroduce;
Public | function FindObject(AObject: TObject): Integer;
Private | function GetFar(aValue: Integer): Single;
Private | function GetHit(aValue: Integer): TObject;
Private | function GetNear(aValue: Integer): Single;
Private | function GetSubObjects(aValue: Integer): TPickSubObjects;
Public | procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);
Public | procedure Clear; override;

Properties

Public | property FarDistance[Index: Integer]: Single read GetFar;
Public | property Hit[Index: Integer]: TObject read GetHit;
Public | property NearDistance[Index: Integer]: Single read GetNear;
Public | property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;

Description

Methods

Public constructor Create(aSortType: TPickSortType); reintroduce;

This item has no description.

Public function FindObject(AObject: TObject): Integer;

This item has no description.

Private function GetFar(aValue: Integer): Single;

This item has no description.

Private function GetHit(aValue: Integer): TObject;

This item has no description.

Private function GetNear(aValue: Integer): Single;

This item has no description.

Private function GetSubObjects(aValue: Integer): TPickSubObjects;

This item has no description.

Public procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);

This item has no description.

Public procedure Clear; override;

This item has no description.

Properties

Public property FarDistance[Index: Integer]: Single read GetFar;

This item has no description.

Public property Hit[Index: Integer]: TObject read GetHit;

This item has no description.

Public property NearDistance[Index: Integer]: Single read GetNear;

This item has no description.

Public property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;


GXSysHelp v.2.5: GXS.Selection: Class TgxBaseSelectTechnique

Class TgxBaseSelectTechnique

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Selection

Declaration

type TgxBaseSelectTechnique = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxBaseSelectTechnique

Overview

Methods

Public | class function IsSupported: Boolean; virtual; abstract;
Public | function Stop: Boolean; virtual; abstract;
Public | procedure FillPickingList(var AList: TgxPickList); virtual; abstract;
Public | procedure LoadObject(AName: TObject); virtual; abstract;
Public | procedure PopObject(); virtual; abstract;
Public | procedure PushObject(AName: TObject); virtual; abstract;
Public | procedure Start; virtual; abstract;

Properties

Public | property CurrentObject: TObject read GetObject write SetObject;
Public | property Hits: Integer read GetHits write SetHits;
Public | property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;

Description

Methods

Public class function IsSupported: Boolean; virtual; abstract;

This item has no description.

Public function Stop: Boolean; virtual; abstract;

This item has no description.

Public procedure FillPickingList(var AList: TgxPickList); virtual; abstract;

This item has no description.

Public procedure LoadObject(AName: TObject); virtual; abstract;

This item has no description.

Public procedure PopObject(); virtual; abstract;

This item has no description.

Public procedure PushObject(AName: TObject); virtual; abstract;

This item has no description.

Public procedure Start; virtual; abstract;

This item has no description.

Properties

Public property CurrentObject: TObject read GetObject write SetObject;

This item has no description.

Public property Hits: Integer read GetHits write SetHits;

This item has no description.

Public property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;


GXSysHelp v.2.5: GXS.Selection: Class TgxSelectRenderModeTechnique

Class TgxSelectRenderModeTechnique

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Selection

Declaration

type TgxSelectRenderModeTechnique = class(TgxBaseSelectTechnique)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxBaseSelectTechnique
  • TgxSelectRenderModeTechnique

Overview

Fields

Private FBuffer: array of Cardinal;

Methods

Public | class function IsSupported: Boolean; override;
Public | function Stop: Boolean; override;
Public | procedure FillPickingList(var AList: TgxPickList); override;
Public | procedure Start; override;

Properties

Public | property CurrentObject;
Public | property Hits;
Public | property ObjectCountGuess;

Description

Fields

Private FBuffer: array of Cardinal;

This item has no description.

Methods

Public class function IsSupported: Boolean; override;

This item has no description.

Public function Stop: Boolean; override;

This item has no description.

Public procedure FillPickingList(var AList: TgxPickList); override;

This item has no description.

Public procedure Start; override;

This item has no description.

Properties

Public property CurrentObject;

This item has no description.

Public property Hits;

This item has no description.

Public property ObjectCountGuess;


GXSysHelp v.2.5: GXS.ShadowHDS

Unit GXS.ShadowHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.HeightData
  • GXS.Graphics
  • GLScene.VectorGeometry
  • GXS.Texture
  • GXS.Coordinates
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxShadowHDS |

Types

TNewTilePreparedEvent = procedure(Sender: TgxShadowHDS; HeightData: TgxHeightData; ShadowMapMaterial: TgxLibMaterial) of object;
TThreadBmp32 = procedure(Sender: TgxShadowHDS; HeightData: TgxHeightData; bmp32: TgxBitmap32) of object;

Description

Types

TNewTilePreparedEvent = procedure(Sender: TgxShadowHDS; HeightData: TgxHeightData; ShadowMapMaterial: TgxLibMaterial) of object;

This item has no description.

TThreadBmp32 = procedure(Sender: TgxShadowHDS; HeightData: TgxHeightData; bmp32: TgxBitmap32) of object;


GXSysHelp v.2.5: GXS.ShadowHDS: Class TgxShadowHDS

Class TgxShadowHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowHDS

Declaration

type TgxShadowHDS = class(TgxHeightDataSourceFilter)

Description

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxHeightDataSourceFilter
  • TgxShadowHDS

Overview

Fields

Private | FTileSize: integer;
Private | FShadowmapLibrary: TgxMaterialLibrary;
Private | FLightVector: TgxCoordinates;
Private | FScale: TgxCoordinates;
Private | FScaleVec: TVector3f;
Private | FOnNewTilePrepared: TNewTilePreparedEvent;
Private | FOnThreadBmp32: TThreadBmp32;
Private | FMaxTextures: integer;
Private | Step: TVector3f;
Private | FScanDistance: integer;
Private | FSoftRange: cardinal;
Private | FDiffuse: single;
Private | FAmbient: single;
Private | OwnerHDS: TgxHeightDataSource;
Public | SkipGenerate: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function RayCastShadowHeight(HD: TgxHeightData; localX, localY: single) : single; overload;
Public | function Shade(HeightData: TgxHeightData; x, y: integer; ShadowHeight, TerrainHeight: single): byte;
Public | procedure AfterPreparingData(HeightData: TgxHeightData); override;
Public | procedure BeforePreparingData(HeightData: TgxHeightData); override;
Public | procedure GenerateShadowMap(HeightData: TgxHeightData; ShadowMap: TgxBitmap32; scale: single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(HeightData: TgxHeightData); override;
Public | procedure RayCastLine(HeightData: TgxHeightData; Lx, Ly: single; ShadowMap: TgxBitmap32);
Public | procedure TrimTextureCache(MaxTextureCount: integer = 0);

Properties

Published | property Ambient: single read FAmbient write SetAmbient;
Published | property Diffuse: single read FDiffuse write SetDiffuse;
Published | property LightVector: TgxCoordinates read FLightVector write SetLightVector;
Published | property MaxTextures: integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property OnThreadBmp32: TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;
Published | property scale: TgxCoordinates read FScale write FScale;
Published | property ScanDistance: integer read FScanDistance write FScanDistance;
Published | property ShadowmapLibrary: TgxMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;
Published | property SoftRange: cardinal read FSoftRange write SetSoftRange;

Description

Fields

Private FTileSize: integer;

This item has no description.

Private FShadowmapLibrary: TgxMaterialLibrary;

This item has no description.

Private FLightVector: TgxCoordinates;

This item has no description.

Private FScale: TgxCoordinates;

This item has no description.

Private FScaleVec: TVector3f;

This item has no description.

Private FOnNewTilePrepared: TNewTilePreparedEvent;

This item has no description.

Private FOnThreadBmp32: TThreadBmp32;

This item has no description.

Private FMaxTextures: integer;

FSubSampling : Integer;

Private Step: TVector3f;

This item has no description.

Private FScanDistance: integer;

This item has no description.

Private FSoftRange: cardinal;

This item has no description.

Private FDiffuse: single;

This item has no description.

Private FAmbient: single;

This item has no description.

Private OwnerHDS: TgxHeightDataSource;

This item has no description.

Public SkipGenerate: boolean;

When true, only a blank ShadowMap is generated (FAST), but OnThreadBmp32 is still called in a subthread.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function RayCastShadowHeight(HD: TgxHeightData; localX, localY: single) : single; overload;

This traces a ray from a point on the terrain surface, back to the Lightsource, while testing for any intersections with the terrain. It returns the height of the shadow. There is no shadow if the shadow height is equal to terrain height. This is slow, but only needs to be done for pixels along the tile edge, facing the light.

Public function Shade(HeightData: TgxHeightData; x, y: integer; ShadowHeight, TerrainHeight: single): byte;

Calculate the pixel brightness, using Direct Diffuse light and Ambient light. DirectLight = 1 if in direct sunlight (no shadows) 0 if in shadow. (Use "SoftRange" for soft shadow edges i.e. 1>Directlight>0 ) AmbientLight = Relative to Angle between surface Normal and sky (Directly up) ie. Vertical walls are darker because they see less sky. DiffuseLight = Relative to Angle between surface Normal, and Sun vector.

Public procedure AfterPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.AfterPreparingData.

This is called After "StartPreparingData", but always from the main thread.

Public procedure BeforePreparingData(HeightData: TgxHeightData); override;

Prepare a blank texture for this tile's lightmap, from the main thread

Public procedure GenerateShadowMap(HeightData: TgxHeightData; ShadowMap: TgxBitmap32; scale: single);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PreparingData(HeightData: TgxHeightData); override;

Calculate the lightmap from the HD thread, using the attached blank texture

Public procedure RayCastLine(HeightData: TgxHeightData; Lx, Ly: single; ShadowMap: TgxBitmap32);

This item has no description.

Public procedure TrimTextureCache(MaxTextureCount: integer = 0);

This will repeatedly delete the oldest unused texture from the TGLMaterialLibrary, until the texture count drops to MaxTextureCount. DONT use this if you used TGLHeightData.MaterialName to link your terrain textures. Either use with TGLHeightData.LibMaterial, or manually delete unused LightMap textures.

Properties

Published property Ambient: single read FAmbient write SetAmbient;

This item has no description.

Published property Diffuse: single read FDiffuse write SetDiffuse;

Shadow height above sufrace for max diffuse light

Published property LightVector: TgxCoordinates read FLightVector write SetLightVector;

This item has no description.

Published property MaxTextures: integer read FMaxTextures write FMaxTextures;

This item has no description.

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;

WARNING: This runs in a subthread

Published property OnSourceDataFetched;

This item has no description.

Published property OnThreadBmp32: TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;

This item has no description.

Published property scale: TgxCoordinates read FScale write FScale;

This item has no description.

Published property ScanDistance: integer read FScanDistance write FScanDistance;

This item has no description.

Published property ShadowmapLibrary: TgxMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;

This item has no description.

Published property SoftRange: cardinal read FSoftRange write SetSoftRange;


GXSysHelp v.2.5: GXS.ShadowPlane

Unit GXS.ShadowPlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Types
  • System.Classes
  • FMX.Effects
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.ImageUtils
  • GXS.Scene
  • GLScene.PipelineTransform
  • GXS.Context
  • GXS.Objects
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxShadowPlane |

Types

TShadowPlaneOption = (...);
TShadowPlaneOptions = set of TShadowPlaneOption;

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];

Description

Types

TShadowPlaneOption = (...);

This item has no description.

Values
  • spoUseStencil
  • spoScissor
  • spoTransparent
  • spoIgnoreZ
TShadowPlaneOptions = set of TShadowPlaneOption;

This item has no description.

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];


GXSysHelp v.2.5: GXS.ShadowPlane: Class TgxShadowPlane

Class TgxShadowPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowPlane

Declaration

type TgxShadowPlane = class(TgxPlane)

Description

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxPlane
  • TgxShadowPlane

Overview

Fields

Private | FRendering: Boolean;
Private | FShadowingObject: TgxBaseSceneObject;
Private | FShadowedLight: TgxLightSource;
Private | FShadowColor: TgxColor;
Private | FShadowOptions: TShadowPlaneOptions;
Private | FOnBeginRenderingShadows: TNotifyEvent;
Private | FOnEndRenderingShadows: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;
Published | property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;
Published | property ShadowColor: TgxColor read FShadowColor write SetShadowColor;
Published | property ShadowedLight: TgxLightSource read FShadowedLight write SetShadowedLight;
Published | property ShadowingObject: TgxBaseSceneObject read FShadowingObject write SetShadowingObject;
Published | property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Description

Fields

Private FRendering: Boolean;

This item has no description.

Private FShadowingObject: TgxBaseSceneObject;

This item has no description.

Private FShadowedLight: TgxLightSource;

This item has no description.

Private FShadowColor: TgxColor;

This item has no description.

Private FShadowOptions: TShadowPlaneOptions;

This item has no description.

Private FOnBeginRenderingShadows: TNotifyEvent;

This item has no description.

Private FOnEndRenderingShadows: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;

Fired before the shadows are rendered.

Published property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;

Fired after the shadows are rendered.

Published property ShadowColor: TgxColor read FShadowColor write SetShadowColor;

The shadow's color. This color is transparently blended to make shadowed area darker.

Published property ShadowedLight: TgxLightSource read FShadowedLight write SetShadowedLight;

The light which casts shadows. The light must be enabled otherwise shadows won't be cast.

Published property ShadowingObject: TgxBaseSceneObject read FShadowingObject write SetShadowingObject;

Selects the object to mirror. If nil, the whole scene is mirrored.

Published property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Controls rendering options. spoUseStencil: plane area is stenciled, prevents shadowing objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer too). It also allows shadows to be partial (blended). spoScissor: plane area is 'scissored', this should improve rendering speed by limiting rendering operations and fill rate, may have adverse effects on old hardware in rare cases spoTransparent: does not render the plane's material, may help improve performance if you're fillrate limited, are using the stencil, and your hardware has optimized stencil-only writes


GXSysHelp v.2.5: GXS.ShadowVolume

Unit GXS.ShadowVolume

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.Classes
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GLScene.GeometryBB
  • GXS.Scene
  • GXS.Context
  • GXS.Silhouette
  • GXS.State
  • GLScene.PipelineTransform
  • GXS.Color
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxShadowVolumeCaster |
Class TgxShadowVolumeOccluder |
Class TgxShadowVolumeLight |
Class TgxShadowVolumeCasters |
Class TgxShadowVolume |

Types

TgxShadowCastingMode = (...);
TgxShadowVolumeCapping = (...);
TgxShadowVolumeMode = (...);
TgxShadowVolumeOption = (...);
TgxShadowVolumeOptions = set of TgxShadowVolumeOption;

Description

Types

TgxShadowCastingMode = (...);

Determines when a caster should actually produce a shadow;

scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)

Values
  • scmAlways
  • scmVisible
  • scmRecursivelyVisible
  • scmParentVisible
  • scmParentRecursivelyVisible
TgxShadowVolumeCapping = (...);

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.

svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps

Values
  • svcDefault
  • svcAlways
  • svcNever
TgxShadowVolumeMode = (...);

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place

Values
  • svmAccurate
  • svmDarkening
  • svmOff
TgxShadowVolumeOption = (...);

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface

Values
  • svoShowVolumes
  • svoCacheSilhouettes
  • svoScissorClips
  • svoWorldScissorClip
  • svoDesignVisible
TgxShadowVolumeOptions = set of TgxShadowVolumeOption;


GXSysHelp v.2.5: GXS.ShadowVolume: Class TgxShadowVolumeCaster

Class TgxShadowVolumeCaster

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowVolume

Declaration

type TgxShadowVolumeCaster = class(TCollectionItem)

Description

Specifies an individual shadow caster. Can be a light or an opaque object.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxShadowVolumeCaster

Overview

Fields

Private | FCaster: TgxBaseSceneObject;
Private | FEffectiveRadius: Single;
Private | FCapping: TgxShadowVolumeCapping;
Private | FCastingMode: TgxShadowCastingMode;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Capping: TgxShadowVolumeCapping read FCapping write FCapping default svcDefault;
Public | property Caster: TgxBaseSceneObject read FCaster write SetCaster;
Published | property CastingMode: TgxShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;
Published | property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;
Public | property GLShadowVolume: TgxShadowVolume read GetGLShadowVolume;

Description

Fields

Private FCaster: TgxBaseSceneObject;

This item has no description.

Private FEffectiveRadius: Single;

This item has no description.

Private FCapping: TgxShadowVolumeCapping;

This item has no description.

Private FCastingMode: TgxShadowCastingMode;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Capping: TgxShadowVolumeCapping read FCapping write FCapping default svcDefault;

Specifies if the shadow volume should be capped. Capping helps solve shadowing artefacts, at the cost of performance.

Public property Caster: TgxBaseSceneObject read FCaster write SetCaster;

Shadow casting object. Can be an opaque object or a lightsource.

Published property CastingMode: TgxShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;

Determines when an object should cast a shadow or not. Typically, objects should only cast shadows when recursively visible. But if you're using dummy shadow casters which are less complex than their parent objects, you should use scmParentRecursivelyVisible.

Published property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;

Radius beyond which the caster can be ignored. Zero (default value) means the caster can never be ignored.

Public property GLShadowVolume: TgxShadowVolume read GetGLShadowVolume;


GXSysHelp v.2.5: GXS.ShadowVolume: Class TgxShadowVolumeOccluder

Class TgxShadowVolumeOccluder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowVolume

Declaration

type TgxShadowVolumeOccluder = class(TgxShadowVolumeCaster)

Description

Specifies an individual shadow casting occluder.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxShadowVolumeCaster
  • TgxShadowVolumeOccluder

Overview

Properties

Published property Caster;

Description

Properties

Published property Caster;

This item has no description. Showing description inherited from TgxShadowVolumeCaster.Caster.

Shadow casting object. Can be an opaque object or a lightsource.


GXSysHelp v.2.5: GXS.ShadowVolume: Class TgxShadowVolumeLight

Class TgxShadowVolumeLight

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowVolume

Declaration

type TgxShadowVolumeLight = class(TgxShadowVolumeCaster)

Description

Specifies an individual shadow casting light.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxShadowVolumeCaster
  • TgxShadowVolumeLight

Overview

Fields

Private FSilhouettes: TgxPersistentObjectList;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure FlushSilhouetteCache;

Properties

Published property LightSource: TgxLightSource read GetLightSource write SetLightSource;

Description

Fields

Private FSilhouettes: TgxPersistentObjectList;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure FlushSilhouetteCache;

This item has no description.

Properties

Published property LightSource: TgxLightSource read GetLightSource write SetLightSource;

Shadow casting lightsource.


GXSysHelp v.2.5: GXS.ShadowVolume: Class TgxShadowVolumeCasters

Class TgxShadowVolumeCasters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowVolume

Declaration

type TgxShadowVolumeCasters = class(TOwnedCollection)

Description

Collection of TgxShadowVolumeCaster.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxShadowVolumeCasters

Overview

Methods

Public | function AddCaster(obj: TgxBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TgxShadowCastingMode = scmRecursivelyVisible): TgxShadowVolumeCaster;
Public | function IndexOfCaster(obj: TgxBaseSceneObject): Integer;
Public | procedure RemoveCaster(obj: TgxBaseSceneObject);

Properties

Public property Items[index: Integer]: TgxShadowVolumeCaster read GetItems;

Description

Methods

Public function AddCaster(obj: TgxBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TgxShadowCastingMode = scmRecursivelyVisible): TgxShadowVolumeCaster;

This item has no description.

Public function IndexOfCaster(obj: TgxBaseSceneObject): Integer;

This item has no description.

Public procedure RemoveCaster(obj: TgxBaseSceneObject);

This item has no description.

Properties

Public property Items[index: Integer]: TgxShadowVolumeCaster read GetItems;


GXSysHelp v.2.5: GXS.ShadowVolume: Class TgxShadowVolume

Class TgxShadowVolume

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ShadowVolume

Declaration

type TgxShadowVolume = class(TgxImmaterialSceneObject)

Description

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLXceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxShadowVolume

Overview

Fields

Private | FActive: Boolean;
Private | FRendering: Boolean;
Private | FLights: TgxShadowVolumeCasters;
Private | FOccluders: TgxShadowVolumeCasters;
Private | FCapping: TgxShadowVolumeCapping;
Private | FOptions: TgxShadowVolumeOptions;
Private | FMode: TgxShadowVolumeMode;
Private | FDarkeningColor: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure FlushSilhouetteCache;

Properties

Published | property Active: Boolean read FActive write SetActive default True;
Published | property Capping: TgxShadowVolumeCapping read FCapping write FCapping default svcAlways;
Published | property DarkeningColor: TgxColor read FDarkeningColor write SetDarkeningColor;
Published | property Lights: TgxShadowVolumeCasters read FLights write SetLights;
Published | property Mode: TgxShadowVolumeMode read FMode write SetMode default svmAccurate;
Published | property Occluders: TgxShadowVolumeCasters read FOccluders write SetOccluders;
Published | property Options: TgxShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FRendering: Boolean;

This item has no description.

Private FLights: TgxShadowVolumeCasters;

This item has no description.

Private FOccluders: TgxShadowVolumeCasters;

This item has no description.

Private FCapping: TgxShadowVolumeCapping;

This item has no description.

Private FOptions: TgxShadowVolumeOptions;

This item has no description.

Private FMode: TgxShadowVolumeMode;

This item has no description.

Private FDarkeningColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure FlushSilhouetteCache;

This item has no description.

Properties

Published property Active: Boolean read FActive write SetActive default True;

Determines if shadow volume rendering is active. When set to false, children will be rendered without any shadowing or multipass lighting.

Published property Capping: TgxShadowVolumeCapping read FCapping write FCapping default svcAlways;

Specifies if the shadow volume should be capped. Capping helps solve shadowing artefacts, at the cost of performance.

Published property DarkeningColor: TgxColor read FDarkeningColor write SetDarkeningColor;

Darkening color used in svmDarkening mode.

Published property Lights: TgxShadowVolumeCasters read FLights write SetLights;

Lights that cast shadow volumes.

Published property Mode: TgxShadowVolumeMode read FMode write SetMode default svmAccurate;

Shadow rendering mode.

Published property Occluders: TgxShadowVolumeCasters read FOccluders write SetOccluders;

Occluders that cast shadow volumes.

Published property Options: TgxShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Shadow volume rendering options.


GXSysHelp v.2.5: GXS.Silhouette

Unit GXS.Silhouette

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.VectorLists

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxSilhouetteParameters |
Class TgxSilhouette |
Class TBaseConnectivity |
Class TConnectivity |

Types

TgxSilhouetteStyle = (...);

Description

Types

TgxSilhouetteStyle = (...);

This item has no description.

Values
  • ssOmni
  • ssParallel


GXSysHelp v.2.5: GXS.Silhouette: Packed Record TgxSilhouetteParameters

Packed Record TgxSilhouetteParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Silhouette

Declaration

type TgxSilhouetteParameters = packed record

Description

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.

Overview

Fields

Public | SeenFrom: TAffineVector;
Public | LightDirection: TAffineVector;
Public | Style: TgxSilhouetteStyle;
Public | CappingRequired: Boolean;

Description

Fields

Public SeenFrom: TAffineVector;

This item has no description.

Public LightDirection: TAffineVector;

This item has no description.

Public Style: TgxSilhouetteStyle;

This item has no description.

Public CappingRequired: Boolean;


GXSysHelp v.2.5: GXS.Silhouette: Class TgxSilhouette

Class TgxSilhouette

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Silhouette

Declaration

type TgxSilhouette = class(TObject)

Description

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TgxSilhouette subclass if you need some helper methods for generating the indexed sets.

Hierarchy

  • TObject
  • TgxSilhouette

Overview

Fields

Private | FVertices: TgxVectorList;
Private | FIndices: TgxIntegerList;
Private | FCapIndices: TgxIntegerList;
Private | FParameters: TgxSilhouetteParameters;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure AddCapToSilhouette(const v0, v1, v2: TAffineVector; tightButSlow: Boolean);
Public | procedure AddEdgeToSilhouette(const v0, v1: TAffineVector; tightButSlow: Boolean);
Public | procedure AddIndexedCapToSilhouette(const Vi0, Vi1, vi2: integer);
Public | procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1: integer);
Public | procedure Clear;
Public | procedure ExtrudeVerticesToInfinity(const origin: TAffineVector);
Public | procedure Flush;

Properties

Public | property CapIndices: TgxIntegerList read FCapIndices write SetCapIndices;
Public | property Indices: TgxIntegerList read FIndices write SetIndices;
Public | property Parameters: TgxSilhouetteParameters read FParameters write FParameters;
Public | property Vertices: TgxVectorList read FVertices write SetVertices;

Description

Fields

Private FVertices: TgxVectorList;

This item has no description.

Private FIndices: TgxIntegerList;

This item has no description.

Private FCapIndices: TgxIntegerList;

This item has no description.

Private FParameters: TgxSilhouetteParameters;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddCapToSilhouette(const v0, v1, v2: TAffineVector; tightButSlow: Boolean);

Adds a capping triangle to the silhouette. If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddEdgeToSilhouette(const v0, v1: TAffineVector; tightButSlow: Boolean);

Adds an edge (two vertices) to the silhouette. If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddIndexedCapToSilhouette(const Vi0, Vi1, vi2: integer);

This item has no description.

Public procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1: integer);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ExtrudeVerticesToInfinity(const origin: TAffineVector);

This item has no description.

Public procedure Flush;

This item has no description.

Properties

Public property CapIndices: TgxIntegerList read FCapIndices write SetCapIndices;

This item has no description.

Public property Indices: TgxIntegerList read FIndices write SetIndices;

This item has no description.

Public property Parameters: TgxSilhouetteParameters read FParameters write FParameters;

This item has no description.

Public property Vertices: TgxVectorList read FVertices write SetVertices;


GXSysHelp v.2.5: GXS.Silhouette: Class TBaseConnectivity

Class TBaseConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Silhouette

Declaration

type TBaseConnectivity = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TBaseConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: Boolean); virtual;
Public | procedure CreateSilhouette(const ASilhouetteParameters: TgxSilhouetteParameters; var ASilhouette: TgxSilhouette; AddToSilhouette: Boolean); virtual;

Properties

Public | property EdgeCount: integer read GetEdgeCount;
Public | property FaceCount: integer read GetFaceCount;
Public | property PrecomputeFaceNormal: Boolean read FPrecomputeFaceNormal;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: Boolean); virtual;

This item has no description.

Public procedure CreateSilhouette(const ASilhouetteParameters: TgxSilhouetteParameters; var ASilhouette: TgxSilhouette; AddToSilhouette: Boolean); virtual;

This item has no description.

Properties

Public property EdgeCount: integer read GetEdgeCount;

This item has no description.

Public property FaceCount: integer read GetFaceCount;

This item has no description.

Public property PrecomputeFaceNormal: Boolean read FPrecomputeFaceNormal;


GXSysHelp v.2.5: GXS.Silhouette: Class TConnectivity

Class TConnectivity

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Silhouette

Declaration

type TConnectivity = class(TBaseConnectivity)

Description

This item has no description.

Hierarchy

  • TObject
  • TBaseConnectivity
  • TConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: Boolean); override;
Public | destructor Destroy; override;
Public | function AddFace(const vertex0, vertex1, vertex2: TAffineVector): integer;
Public | function AddIndexedEdge(vertexIndex0, vertexIndex1: integer; FaceID: integer): integer;
Public | function AddIndexedFace(Vi0, Vi1, vi2: integer): integer;
Public | function AddQuad(const vertex0, vertex1, vertex2, vertex3: TAffineVector): integer;
Public | procedure Clear; virtual;
Public | procedure CreateSilhouette(const silhouetteParameters: TgxSilhouetteParameters; var ASilhouette: TgxSilhouette; AddToSilhouette: Boolean); override;

Properties

Public | property EdgeCount: integer read GetEdgeCount;
Public | property FaceCount: integer read GetFaceCount;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: Boolean); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddFace(const vertex0, vertex1, vertex2: TAffineVector): integer;

This item has no description.

Public function AddIndexedEdge(vertexIndex0, vertexIndex1: integer; FaceID: integer): integer;

This item has no description.

Public function AddIndexedFace(Vi0, Vi1, vi2: integer): integer;

This item has no description.

Public function AddQuad(const vertex0, vertex1, vertex2, vertex3: TAffineVector): integer;

This item has no description.

Public procedure Clear; virtual;

Clears out all connectivity information.

Public procedure CreateSilhouette(const silhouetteParameters: TgxSilhouetteParameters; var ASilhouette: TgxSilhouette; AddToSilhouette: Boolean); override;

This item has no description.

Properties

Public property EdgeCount: integer read GetEdgeCount;

This item has no description.

Public property FaceCount: integer read GetFaceCount;


GXSysHelp v.2.5: GXS.SimpleNavigation

Unit GXS.SimpleNavigation

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • System.SysUtils
  • System.TypInfo
  • System.Math
  • FMX.Forms
  • FMX.Controls
  • FMX.ExtCtrls
  • FMX.Types
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.SceneViewer
  • GLScene.Strings

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSimpleNavigationKeyCombination |
Class TgxSimpleNavigationKeyCombinations |
Class TgxSimpleNavigation |

Types

TgxSimpleNavigationAction = (...);
TgxSimpleNavigationOption = (...);
TgxSimpleNavigationOptions = set of TgxSimpleNavigationOption;
TSimpleNavigationCustomActionEvent = procedure(Sender: TgxSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Single) of object;

Description

Types

TgxSimpleNavigationAction = (...);

This item has no description.

Values
  • snaNone
  • snaMoveAroundTarget
  • snaZoom
  • snaRotateTarget
  • snaCustom
TgxSimpleNavigationOption = (...);

This item has no description.

Values
  • snoInvertMoveAroundX
  • snoInvertMoveAroundY
  • snoInvertZoom: MoveAroundTarget.
  • snoInvertMouseWheel
  • snoInvertRotateX: Zoom.
  • snoInvertRotateY
  • snoMouseWheelHandled: RotateTarget.
  • snoShowFPS: MouseWheel.
TgxSimpleNavigationOptions = set of TgxSimpleNavigationOption;

Show FPS

TSimpleNavigationCustomActionEvent = procedure(Sender: TgxSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Single) of object;


GXSysHelp v.2.5: GXS.SimpleNavigation: Class TgxSimpleNavigationKeyCombination

Class TgxSimpleNavigationKeyCombination

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SimpleNavigation

Declaration

type TgxSimpleNavigationKeyCombination = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxSimpleNavigationKeyCombination

Overview

Fields

Private | FExitOnMatch: Boolean;
Private | FAction: TgxSimpleNavigationAction;
Private | FOnCustomAction: TSimpleNavigationCustomActionEvent;
Private | FShiftState: TShiftState;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Action: TgxSimpleNavigationAction read FAction write FAction default snaNone;
Published | property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;
Published | property OnCustomAction: TSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;
Published | property ShiftState: TShiftState read FShiftState write FShiftState default [];

Description

Fields

Private FExitOnMatch: Boolean;

This item has no description.

Private FAction: TgxSimpleNavigationAction;

This item has no description.

Private FOnCustomAction: TSimpleNavigationCustomActionEvent;

This item has no description.

Private FShiftState: TShiftState;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Action: TgxSimpleNavigationAction read FAction write FAction default snaNone;

This item has no description.

Published property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;

This item has no description.

Published property OnCustomAction: TSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;

This item has no description.

Published property ShiftState: TShiftState read FShiftState write FShiftState default [];


GXSysHelp v.2.5: GXS.SimpleNavigation: Class TgxSimpleNavigationKeyCombinations

Class TgxSimpleNavigationKeyCombinations

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SimpleNavigation

Declaration

type TgxSimpleNavigationKeyCombinations = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxSimpleNavigationKeyCombinations

Overview

Methods

Public | function Add: TgxSimpleNavigationKeyCombination; overload;
Public | function Add(const AShiftState: TShiftState; const AAction: TgxSimpleNavigationAction; const AExitOnMatch: Boolean = True): TgxSimpleNavigationKeyCombination; overload;
Private | function GetItems(Index: Integer): TgxSimpleNavigationKeyCombination;
Private | procedure SetItems(Index: Integer; const Value: TgxSimpleNavigationKeyCombination);

Properties

Public property Items[Index: Integer]: TgxSimpleNavigationKeyCombination read GetItems write SetItems;

Description

Methods

Public function Add: TgxSimpleNavigationKeyCombination; overload;

This item has no description.

Public function Add(const AShiftState: TShiftState; const AAction: TgxSimpleNavigationAction; const AExitOnMatch: Boolean = True): TgxSimpleNavigationKeyCombination; overload;

This item has no description.

Private function GetItems(Index: Integer): TgxSimpleNavigationKeyCombination;

This item has no description.

Private procedure SetItems(Index: Integer; const Value: TgxSimpleNavigationKeyCombination);

This item has no description.

Properties

Public property Items[Index: Integer]: TgxSimpleNavigationKeyCombination read GetItems write SetItems;


GXSysHelp v.2.5: GXS.SimpleNavigation: Class TgxSimpleNavigation

Class TgxSimpleNavigation

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SimpleNavigation

Declaration

type TgxSimpleNavigation = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSimpleNavigation

Overview

Fields

Private | FTimer: TTimer;
Private | FForm: TCustomForm;
Private | FGLXceneViewer: TgxSceneViewer;
Private | FOldX: Single;
Private | FOldY: Single;
Private | FFormCaption: string;
Private | FMoveAroundTargetSpeed: Single;
Private | FZoomSpeed: Single;
Private | FOptions: TgxSimpleNavigationOptions;
Private | FKeyCombinations: TgxSimpleNavigationKeyCombinations;
Private | FRotateTargetSpeed: Single;
Private | FOnMouseMove: TMouseMoveEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreFormCaption: Boolean;
Private | function StoreMoveAroundTargetSpeed: Boolean;
Private | function StoreRotateTargetSpeed: Boolean;
Private | function StoreZoomSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetForm(const Value: TCustomForm);
Private | procedure SetGLXceneViewer(const Value: TgxSceneViewer);
Private | procedure SetKeyCombinations(const Value: TgxSimpleNavigationKeyCombinations);
Private | procedure SetOptions(const Value: TgxSimpleNavigationOptions);
Private | procedure ShowFPS(Sender: TObject);
Private | procedure ViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);
Private | procedure ViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Properties

Published | property Form: TCustomForm read FForm write SetForm;
Published | property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;
Published | property GLXceneViewer: TgxSceneViewer read FGLXceneViewer write SetGLXceneViewer;
Published | property KeyCombinations: TgxSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;
Published | property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property Options: TgxSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];
Published | property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;
Published | property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;

Description

Fields

Private FTimer: TTimer;

This item has no description.

Private FForm: TCustomForm;

This item has no description.

Private FGLXceneViewer: TgxSceneViewer;

This item has no description.

Private FOldX: Single;

This item has no description.

Private FOldY: Single;

This item has no description.

Private FFormCaption: string;

This item has no description.

Private FMoveAroundTargetSpeed: Single;

This item has no description.

Private FZoomSpeed: Single;

This item has no description.

Private FOptions: TgxSimpleNavigationOptions;

This item has no description.

Private FKeyCombinations: TgxSimpleNavigationKeyCombinations;

This item has no description.

Private FRotateTargetSpeed: Single;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreFormCaption: Boolean;

This item has no description.

Private function StoreMoveAroundTargetSpeed: Boolean;

This item has no description.

Private function StoreRotateTargetSpeed: Boolean;

This item has no description.

Private function StoreZoomSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetForm(const Value: TCustomForm);

This item has no description.

Private procedure SetGLXceneViewer(const Value: TgxSceneViewer);

This item has no description.

Private procedure SetKeyCombinations(const Value: TgxSimpleNavigationKeyCombinations);

This item has no description.

Private procedure SetOptions(const Value: TgxSimpleNavigationOptions);

This item has no description.

Private procedure ShowFPS(Sender: TObject);

This item has no description.

Private procedure ViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Single);

This item has no description.

Private procedure ViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

This item has no description.

Properties

Published property Form: TCustomForm read FForm write SetForm;

This item has no description.

Published property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;

This item has no description.

Published property GLXceneViewer: TgxSceneViewer read FGLXceneViewer write SetGLXceneViewer;

This item has no description.

Published property KeyCombinations: TgxSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;

This item has no description.

Published property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;

This item has no description.

Published property Options: TgxSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];

This item has no description.

Published property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;

This item has no description.

Published property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;


GXSysHelp v.2.5: GXS.Skydome

Unit GXS.Skydome

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.UITypes
  • System.Math
  • FMX.Graphics
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Context
  • GXS.State
  • GXS.Graphics
  • GXS.Color
  • GXS.Material
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxStarRecord |
Class TgxSkyBox |
Class TgxSkyDomeBand |
Class TgxSkyDomeBands |
Class TgxSkyDomeStar |
Class TgxSkyDomeStars |
Class TgxSkyDome |
Class TgxEarthSkyDome |

Functions and Procedures

function StarRecordPositionZUp(const starRecord: TgxStarRecord): TAffineVector;
function StarRecordPositionYUp(const starRecord: TgxStarRecord): TAffineVector;
function StarRecordColor(const starRecord: TgxStarRecord; bias: Single): TVector4f;

Types

PgxStarRecord = ˆTgxStarRecord;
TEarthSkydomeOption = (...);
TEarthSkydomeOptions = set of TEarthSkydomeOption;
TgxSkyBoxStyle = (...);
TgxSkyDomeOption = (...);
TgxSkyDomeOptions = set of TgxSkyDomeOption;

Description

Functions and Procedures

function StarRecordPositionZUp(const starRecord: TgxStarRecord): TAffineVector;

Computes position on the unit sphere of a star record (Z=up).

function StarRecordPositionYUp(const starRecord: TgxStarRecord): TAffineVector;

Computes position on the unit sphere of a star record (Y=up).

function StarRecordColor(const starRecord: TgxStarRecord; bias: Single): TVector4f;

Computes star color from BV index (RGB) and magnitude (alpha).

Types

PgxStarRecord = ˆTgxStarRecord;

This item has no description.

TEarthSkydomeOption = (...);

This item has no description.

Values
  • esoFadeStarsWithSun
  • esoRotateOnTwelveHours
  • esoDepthTest
TEarthSkydomeOptions = set of TEarthSkydomeOption;

This item has no description.

TgxSkyBoxStyle = (...);

————————- SkyBox class ————————-

Values
  • sbsFull
  • sbsTopHalf
  • sbsBottomHalf
  • sbTopTwoThirds
  • sbsTopHalfClamped
TgxSkyDomeOption = (...);

This item has no description.

Values
  • sdoEquatorialGrid
  • sdoEclipticGrid
  • sdoGalacticGrid
  • sdoSupergalacticGrid
  • sdoTwinkle
TgxSkyDomeOptions = set of TgxSkyDomeOption;


GXSysHelp v.2.5: GXS.Skydome: Packed Record TgxStarRecord

Packed Record TgxStarRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxStarRecord = packed record

Description

This item has no description.

Overview

Fields

Public | RA: Word;
Public | DEC: SmallInt;
Public | BVColorIndex: Byte;
Public | VMagnitude: Byte;

Description

Fields

Public RA: Word;

This item has no description.

Public DEC: SmallInt;

x100 builtin factor, degrees

Public BVColorIndex: Byte;

x100 builtin factor, degrees

Public VMagnitude: Byte;

x100 builtin factor


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyBox

Class TgxSkyBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyBox = class(TgxCameraInvariantObject, IgxMaterialLibrarySupported)

Description

This item has no description. Showing description inherited from TgxCameraInvariantObject.

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxCameraInvariantObject
  • TgxSkyBox

Overview

Fields

Private | FMatNameTop: string;
Private | FMatNameRight: string;
Private | FMatNameFront: string;
Private | FMatNameLeft: string;
Private | FMatNameBack: string;
Private | FMatNameBottom: string;
Private | FMatNameClouds: string;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FCloudsPlaneOffset: Single;
Private | FCloudsPlaneSize: Single;
Private | FStyle: TgxSkyBoxStyle;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Public | procedure BuildList(var ARci: TgxRenderContextInfo); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;
Published | property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MatNameBack: TgxLibMaterialName read FMatNameBack write SetMatNameBack;
Published | property MatNameBottom: TgxLibMaterialName read FMatNameBottom write SetMatNameBottom;
Published | property MatNameClouds: TgxLibMaterialName read FMatNameClouds write SetMatNameClouds;
Published | property MatNameFront: TgxLibMaterialName read FMatNameFront write SetMatNameFront;
Published | property MatNameLeft: TgxLibMaterialName read FMatNameLeft write SetMatNameLeft;
Published | property MatNameRight: TgxLibMaterialName read FMatNameRight write SetMatNameRight;
Published | property MatNameTop: TgxLibMaterialName read FMatNameTop write SetMatNameTop;
Published | property Style: TgxSkyBoxStyle read FStyle write FStyle default sbsFull;

Description

Fields

Private FMatNameTop: string;

This item has no description.

Private FMatNameRight: string;

This item has no description.

Private FMatNameFront: string;

This item has no description.

Private FMatNameLeft: string;

This item has no description.

Private FMatNameBack: string;

This item has no description.

Private FMatNameBottom: string;

This item has no description.

Private FMatNameClouds: string;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FCloudsPlaneOffset: Single;

This item has no description.

Private FCloudsPlaneSize: Single;

This item has no description.

Private FStyle: TgxSkyBoxStyle;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

implementing IgxMaterialLibrarySupported

Public procedure BuildList(var ARci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;

This item has no description.

Published property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property MatNameBack: TgxLibMaterialName read FMatNameBack write SetMatNameBack;

This item has no description.

Published property MatNameBottom: TgxLibMaterialName read FMatNameBottom write SetMatNameBottom;

This item has no description.

Published property MatNameClouds: TgxLibMaterialName read FMatNameClouds write SetMatNameClouds;

This item has no description.

Published property MatNameFront: TgxLibMaterialName read FMatNameFront write SetMatNameFront;

This item has no description.

Published property MatNameLeft: TgxLibMaterialName read FMatNameLeft write SetMatNameLeft;

This item has no description.

Published property MatNameRight: TgxLibMaterialName read FMatNameRight write SetMatNameRight;

This item has no description.

Published property MatNameTop: TgxLibMaterialName read FMatNameTop write SetMatNameTop;

This item has no description.

Published property Style: TgxSkyBoxStyle read FStyle write FStyle default sbsFull;


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyDomeBand

Class TgxSkyDomeBand

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyDomeBand = class(TCollectionItem)

Description

——————— SkyDome classes —————————–

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxSkyDomeBand

Overview

Fields

Private | FStartAngle: Single;
Private | FStopAngle: Single;
Private | FStartColor: TgxColor;
Private | FStopColor: TgxColor;
Private | FSlices: Integer;
Private | FStacks: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo);

Properties

Published | property Slices: Integer read FSlices write SetSlices default 12;
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StartColor: TgxColor read FStartColor write SetStartColor;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;
Published | property StopColor: TgxColor read FStopColor write SetStopColor;

Description

Fields

Private FStartAngle: Single;

This item has no description.

Private FStopAngle: Single;

This item has no description.

Private FStartColor: TgxColor;

This item has no description.

Private FStopColor: TgxColor;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo);

This item has no description.

Properties

Published property Slices: Integer read FSlices write SetSlices default 12;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 1;

This item has no description.

Published property StartAngle: Single read FStartAngle write SetStartAngle;

This item has no description.

Published property StartColor: TgxColor read FStartColor write SetStartColor;

This item has no description.

Published property StopAngle: Single read FStopAngle write SetStopAngle;

This item has no description.

Published property StopColor: TgxColor read FStopColor write SetStopColor;


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyDomeBands

Class TgxSkyDomeBands

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyDomeBands = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxSkyDomeBands

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxSkyDomeBand;
Public | function FindItemID(ID: Integer): TgxSkyDomeBand;
Public | procedure BuildList(var rci: TgxRenderContextInfo);
Public | procedure NotifyChange;

Properties

Public property Items[index: Integer]: TgxSkyDomeBand read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxSkyDomeBand;

This item has no description.

Public function FindItemID(ID: Integer): TgxSkyDomeBand;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure NotifyChange;

This item has no description.

Properties

Public property Items[index: Integer]: TgxSkyDomeBand read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyDomeStar

Class TgxSkyDomeStar

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyDomeStar = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxSkyDomeStar

Overview

Fields

Private | FRA: Single;
Private | FDec: Single;
Private | FMagnitude: Single;
Private | FColor: TColor;
Private | FCacheCoord: TAffineVector;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Color: TColor read FColor write FColor;
Published | property DEC: Single read FDec write FDec;
Published | property Magnitude: Single read FMagnitude write FMagnitude;
Published | property RA: Single read FRA write FRA;

Description

Fields

Private FRA: Single;

This item has no description.

Private FDec: Single;

This item has no description.

Private FMagnitude: Single;

This item has no description.

Private FColor: TColor;

This item has no description.

Private FCacheCoord: TAffineVector;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Color: TColor read FColor write FColor;

Color of the star.

Published property DEC: Single read FDec write FDec;

Declination, in degrees.

Published property Magnitude: Single read FMagnitude write FMagnitude;

Absolute magnitude.

Published property RA: Single read FRA write FRA;

Right Ascension, in degrees.


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyDomeStars

Class TgxSkyDomeStars

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyDomeStars = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxSkyDomeStars

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxSkyDomeStar;
Public | function FindItemID(ID: Integer): TgxSkyDomeStar;
Public | procedure AddRandomStars(const nb: Integer; const Color: TColor; const limitToTopDome: Boolean = False); overload;
Public | procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax: TVector3b; const Magnitude_min, Magnitude_max: Single; const limitToTopDome: Boolean = False); overload;
Public | procedure BuildList(var rci: TgxRenderContextInfo; twinkle: Boolean);
Public | procedure LoadStarsFile(const starsFileName: string);

Properties

Public property Items[index: Integer]: TgxSkyDomeStar read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxSkyDomeStar;

This item has no description.

Public function FindItemID(ID: Integer): TgxSkyDomeStar;

This item has no description.

Public procedure AddRandomStars(const nb: Integer; const Color: TColor; const limitToTopDome: Boolean = False); overload;

Adds nb random stars of the given color. Stars are homogenously scattered on the complete sphere, not only the band defined or visible dome.

Public procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax: TVector3b; const Magnitude_min, Magnitude_max: Single; const limitToTopDome: Boolean = False); overload;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo; twinkle: Boolean);

This item has no description.

Public procedure LoadStarsFile(const starsFileName: string);

Load a 'stars' file, which is made of TGLStarRecord. Not that '.stars' files should already be sorted by magnitude and color.

Properties

Public property Items[index: Integer]: TgxSkyDomeStar read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Skydome: Class TgxSkyDome

Class TgxSkyDome

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxSkyDome = class(TgxCameraInvariantObject)

Description

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxCameraInvariantObject
  • TgxSkyDome

Overview

Fields

Private | FOptions: TgxSkyDomeOptions;
Private | FBands: TgxSkyDomeBands;
Private | FStars: TgxSkyDomeStars;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property Bands: TgxSkyDomeBands read FBands write SetBands;
Published | property Options: TgxSkyDomeOptions read FOptions write SetOptions default [];
Published | property Stars: TgxSkyDomeStars read FStars write SetStars;

Description

Fields

Private FOptions: TgxSkyDomeOptions;

This item has no description.

Private FBands: TgxSkyDomeBands;

This item has no description.

Private FStars: TgxSkyDomeStars;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property Bands: TgxSkyDomeBands read FBands write SetBands;

This item has no description.

Published property Options: TgxSkyDomeOptions read FOptions write SetOptions default [];

This item has no description.

Published property Stars: TgxSkyDomeStars read FStars write SetStars;


GXSysHelp v.2.5: GXS.Skydome: Class TgxEarthSkyDome

Class TgxEarthSkyDome

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Skydome

Declaration

type TgxEarthSkyDome = class(TgxSkyDome)

Description

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TgxEarthSkyDome.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxCameraInvariantObject
  • TgxSkyDome
  • TgxEarthSkyDome

Overview

Fields

Private | FSunElevation: Single;
Private | FTurbidity: Single;
Private | FCurSunColor: TgxColorVector;
Private | FCurSkyColor: TgxColorVector;
Private | FCurHazeColor: TgxColorVector;
Private | FCurHazeTurbid: Single;
Private | FCurSunSkyTurbid: Single;
Private | FSunZenithColor: TgxColor;
Private | FSunDawnColor: TgxColor;
Private | FHazeColor: TgxColor;
Private | FSkyColor: TgxColor;
Private | FNightColor: TgxColor;
Private | FDeepColor: TgxColor;
Private | FSlices: Integer;
Private | FStacks: Integer;
Private | FExtendedOptions: TEarthSkydomeOptions;
Private | FMorning: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure SetSunAtTime(HH, MM: Single);

Properties

Published | property DeepColor: TgxColor read FDeepColor write SetDeepColor;
Published | property ExtendedOptions: TEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;
Published | property HazeColor: TgxColor read FHazeColor write SetHazeColor;
Published | property NightColor: TgxColor read FNightColor write SetNightColor;
Published | property SkyColor: TgxColor read FSkyColor write SetSkyColor;
Published | property Slices: Integer read FSlices write SetSlices default 24;
Published | property Stacks: Integer read FStacks write SetStacks default 48;
Published | property SunDawnColor: TgxColor read FSunDawnColor write SetSunDawnColor;
Published | property SunElevation: Single read FSunElevation write SetSunElevation;
Published | property SunZenithColor: TgxColor read FSunZenithColor write SetSunZenithColor;
Published | property Turbidity: Single read FTurbidity write SetTurbidity;

Description

Fields

Private FSunElevation: Single;

This item has no description.

Private FTurbidity: Single;

This item has no description.

Private FCurSunColor: TgxColorVector;

This item has no description.

Private FCurSkyColor: TgxColorVector;

This item has no description.

Private FCurHazeColor: TgxColorVector;

This item has no description.

Private FCurHazeTurbid: Single;

This item has no description.

Private FCurSunSkyTurbid: Single;

This item has no description.

Private FSunZenithColor: TgxColor;

This item has no description.

Private FSunDawnColor: TgxColor;

This item has no description.

Private FHazeColor: TgxColor;

This item has no description.

Private FSkyColor: TgxColor;

This item has no description.

Private FNightColor: TgxColor;

This item has no description.

Private FDeepColor: TgxColor;

This item has no description.

Private FSlices: Integer;

This item has no description.

Private FStacks: Integer;

This item has no description.

Private FExtendedOptions: TEarthSkydomeOptions;

This item has no description.

Private FMorning: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure SetSunAtTime(HH, MM: Single);

This item has no description.

Properties

Published property DeepColor: TgxColor read FDeepColor write SetDeepColor;

This item has no description.

Published property ExtendedOptions: TEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;

This item has no description.

Published property HazeColor: TgxColor read FHazeColor write SetHazeColor;

This item has no description.

Published property NightColor: TgxColor read FNightColor write SetNightColor;

This item has no description.

Published property SkyColor: TgxColor read FSkyColor write SetSkyColor;

This item has no description.

Published property Slices: Integer read FSlices write SetSlices default 24;

This item has no description.

Published property Stacks: Integer read FStacks write SetStacks default 48;

This item has no description.

Published property SunDawnColor: TgxColor read FSunDawnColor write SetSunDawnColor;

This item has no description.

Published property SunElevation: Single read FSunElevation write SetSunElevation;

Elevation of the sun, measured in degrees

Published property SunZenithColor: TgxColor read FSunZenithColor write SetSunZenithColor;

This item has no description.

Published property Turbidity: Single read FTurbidity write SetTurbidity;

Expresses the purity of air. Value range is from 1 (pure atmosphere) to 120 (very nebulous)


GXSysHelp v.2.5: GXS.SmartObjects

Unit GXS.SmartObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GLScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • System.Math
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.VectorTypesExt
  • GXS.VectorLists
  • GXS.BaseClasses
  • GLScene.PipelineTransform
  • GXS.Coordinates
  • GLScene.GeometryBB
  • GXS.Color
  • GLScene.Strings
  • GXS.Scene
  • GXS.Silhouette
  • GXS.Texture
  • GXS.Material
  • GXS.Mesh
  • GXS.Octree
  • GXS.Objects
  • GXS.GeomObjects
  • GXS.ApplicationFileIO
  • GXS.Context
  • GXS.Selection
  • GXS.RenderContextInfo
  • GXS.VectorFileObjects
  • GXS.SoundManager
  • GXS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCyborgThinks |
Class TgxCyborgThinksList |
Class TgxCyborg |
Class TgxSwartSwarm |

Types

TgxCyborgOption = (...);
TgxCyborgOptions = set of TgxCyborgOption;
TgxCyborgReference = (...);
TgxCyborgSenceOrgans = (...);
TgxCyborgThinkMode = (...);
TgxSmartSwarmMode = (...);

Constants

cDefaultCyborgOptions = [coCollide];

Variables

vGLSmartObjectsAllocate: Boolean = True;
vGLSmartObjectsEnableByDefault: Boolean = True;

Description

Types

TgxCyborgOption = (...);

This item has no description.

Values
  • coCollide
  • coContact
  • coJoin
TgxCyborgOptions = set of TgxCyborgOption;

This item has no description.

TgxCyborgReference = (...);

This item has no description.

Values
  • crNone
  • crWeak
  • crStrong
TgxCyborgSenceOrgans = (...);

This item has no description.

Values
  • csoVision
  • csoHearing
  • csoSmell
  • csoTouch
  • taste
TgxCyborgThinkMode = (...);

This item has no description.

Values
  • ctmSelf
  • ctmSleep
  • ctmOutside
  • ctmZombie
  • ctmDeath
TgxSmartSwarmMode = (...);

This item has no description.

Values
  • isNone
  • isRandom
  • isTetra
  • isGrid

Constants

cDefaultCyborgOptions = [coCollide];

This item has no description.

Variables

vGLSmartObjectsAllocate: Boolean = True;

This item has no description.

vGLSmartObjectsEnableByDefault: Boolean = True;


GXSysHelp v.2.5: GXS.SmartObjects: Class TgxCyborgThinks

Class TgxCyborgThinks

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmartObjects

Declaration

type TgxCyborgThinks = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxCyborgThinks


GXSysHelp v.2.5: GXS.SmartObjects: Class TgxCyborgThinksList

Class TgxCyborgThinksList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmartObjects

Declaration

type TgxCyborgThinksList = class(TgxPersistentObjectList)

Description

A list of thinking periods for TgxCyborgThinkMode

Hierarchy

  • TgxPersistentObjectList
  • TgxCyborgThinksList


GXSysHelp v.2.5: GXS.SmartObjects: Class TgxCyborg

Class TgxCyborg

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmartObjects

Declaration

type TgxCyborg = class(TgxActor)

Description

The Cyborg class specialized as a smart actor with AI. The TgxCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxActor
  • TgxCyborg

Overview

Fields

Private | FBirthTime: TDateTime;
Private | FDeathTime: TDateTime;
Private | FReference: TgxCyborgReference;
Private | FThinkMode: TgxCyborgThinkMode;
Private | FControlers: TList;
Private | FInterval: Integer;
Private | FOptions: TgxCyborgOptions;
Private | FThinkings: TgxCyborgThinks;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CurrentThinking: string;
Public | function IsThinking: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure LoadFromStream(const Filename: string; aStream: TStream); override;
Public | procedure SwitchToThinking(anThinking: TgxCyborgThinks; smooth: Boolean = False);

Properties

Published | property Interval: Integer read FInterval write FInterval;
Published | property Options: TgxCyborgOptions read FOptions write SetOptions default cDefaultCyborgOptions;
Published | property SmartReference: TgxCyborgReference read FReference write FReference default crNone;
Published | property ThinkingMode: TgxCyborgThinkMode read FThinkMode write FThinkMode default ctmSelf;

Description

Fields

Private FBirthTime: TDateTime;

This item has no description.

Private FDeathTime: TDateTime;

This item has no description.

Private FReference: TgxCyborgReference;

This item has no description.

Private FThinkMode: TgxCyborgThinkMode;

This item has no description.

Private FControlers: TList;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FOptions: TgxCyborgOptions;

This item has no description.

Private FThinkings: TgxCyborgThinks;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CurrentThinking: string;

This item has no description.

Public function IsThinking: Boolean;

Indicates whether the cyborg is currently thinking

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure LoadFromStream(const Filename: string; aStream: TStream); override;

This item has no description. Showing description inherited from TgxBaseMesh.LoadFromStream.

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure SwitchToThinking(anThinking: TgxCyborgThinks; smooth: Boolean = False);

This item has no description.

Properties

Published property Interval: Integer read FInterval write FInterval;

Interval between thinking frames, in milliseconds.

Published property Options: TgxCyborgOptions read FOptions write SetOptions default cDefaultCyborgOptions;

Cyborg and thinking miscellanious options.

Published property SmartReference: TgxCyborgReference read FReference write FReference default crNone;

Reference Frame Animation mode. Allows specifying if the model is primarily morph or skeleton based

Published property ThinkingMode: TgxCyborgThinkMode read FThinkMode write FThinkMode default ctmSelf;

See TgxCyborgThinkMode.


GXSysHelp v.2.5: GXS.SmartObjects: Class TgxSwartSwarm

Class TgxSwartSwarm

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmartObjects

Declaration

type TgxSwartSwarm = class(TgxPoints)

Description

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxPoints
  • TgxSwartSwarm

Overview

Fields

Private | FBirthTime: TDateTime;
Private | FDeathTime: TDateTime;
Private | FReference: TgxCyborgReference;
Private | FThinkMode: TgxSmartSwarmMode;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property ThinkingMode: TgxSmartSwarmMode read FThinkMode;

Description

Fields

Private FBirthTime: TDateTime;

This item has no description.

Private FDeathTime: TDateTime;

This item has no description.

Private FReference: TgxCyborgReference;

This item has no description.

Private FThinkMode: TgxSmartSwarmMode;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property ThinkingMode: TgxSmartSwarmMode read FThinkMode;


GXSysHelp v.2.5: GXS.SmoothNavigator

Unit GXS.SmoothNavigator

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • GLScene.XCollection
  • GLScene.VectorTypes
  • GXS.Navigator
  • GLScene.VectorGeometry
  • GXS.Scene
  • GXS.Coordinates
  • GXS.Screen
  • GXS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxNavigatorAbstractParameters |
Class TgxNavigatorSmoothChangeItem |
Class TgxNavigatorSmoothChangeSingle |
Class TgxNavigatorSmoothChangeVector |
Class TgxNavigatorSmoothChangeItems |
Class TgxNavigatorAdjustDistanceParameters |
Class TgxNavigatorAdjustDistanceParametersEx |
Class TgxNavigatorInertiaParameters |
Class TgxNavigatorGeneralParameters |
Class TgxNavigatorMoveAroundParameters |
Class TgxSmoothNavigator |
Class TgxSmoothUserInterface |

Types

TgxNavigatorSmoothChangeItemClass = class of TgxNavigatorSmoothChangeItem;
TgxNavigatorSmoothChangeSingleGetEvent = function(const ASender: TgxNavigatorSmoothChangeSingle): Single of object;
TgxNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TgxNavigatorSmoothChangeSingle; const AValue: Single) of object;
TgxNavigatorSmoothChangeVectorGetEvent = function(const ASender: TgxNavigatorSmoothChangeVector): TVector4f of object;
TgxNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TgxNavigatorSmoothChangeVector; const AValue: TVector4f) of object;

Description

Types

TgxNavigatorSmoothChangeItemClass = class of TgxNavigatorSmoothChangeItem;

This item has no description.

TgxNavigatorSmoothChangeSingleGetEvent = function(const ASender: TgxNavigatorSmoothChangeSingle): Single of object;

This item has no description.

TgxNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TgxNavigatorSmoothChangeSingle; const AValue: Single) of object;

This item has no description.

TgxNavigatorSmoothChangeVectorGetEvent = function(const ASender: TgxNavigatorSmoothChangeVector): TVector4f of object;

This item has no description.

TgxNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TgxNavigatorSmoothChangeVector; const AValue: TVector4f) of object;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorAbstractParameters

Class TgxNavigatorAbstractParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorAbstractParameters = class(TPersistent)

Description

Includes a basic set of parameters that control the smoothness of movement.

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorAbstractParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FInertia: Single;
Private | FSpeed: Single;
Private | FCutoff: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreCutoff: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FInertia: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FCutoff: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreCutoff: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorSmoothChangeItem

Class TgxNavigatorSmoothChangeItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorSmoothChangeItem = class(TXCollectionItem)

Description

Includes a basic set of parameters that control the smoothness of movement

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxNavigatorSmoothChangeItem

Overview

Fields

Private | FInertia: Single;
Private | FSpeed: Single;
Private | FEnabled: Boolean;
Private | FSpeedLimit: Single;
Private | FCutoff: Double;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;
Private | function StoreCutoff: Boolean;
Private | function StoreInertia: Boolean;
Private | function StoreSpeed: Boolean;
Private | function StoreSpeedLimit: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); virtual; abstract;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;

Description

Fields

Private FInertia: Single;

This item has no description.

Private FSpeed: Single;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FSpeedLimit: Single;

This item has no description.

Private FCutoff: Double;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;

Returns False if there was no change.

Private function StoreCutoff: Boolean;

This item has no description.

Private function StoreInertia: Boolean;

This item has no description.

Private function StoreSpeed: Boolean;

This item has no description.

Private function StoreSpeedLimit: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); virtual; abstract;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Enabled: Boolean read FEnabled write FEnabled default True;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

This item has no description.

Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorSmoothChangeSingle

Class TgxNavigatorSmoothChangeSingle

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorSmoothChangeSingle = class(TgxNavigatorSmoothChangeItem)

Description

Smoothly change any Single value, so it will become TargetValue in the end.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxNavigatorSmoothChangeItem
  • TgxNavigatorSmoothChangeSingle

Overview

Fields

Private | FTargetValue: Single;
Private | FOnGetCurrentValue: TgxNavigatorSmoothChangeSingleGetEvent;
Private | FOnSetCurrentValue: TgxNavigatorSmoothChangeSingleSetEvent;

Methods

Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;

Properties

Published | property OnGetCurrentValue: TgxNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TgxNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: Single read FTargetValue write FTargetValue;

Description

Fields

Private FTargetValue: Single;

This item has no description.

Private FOnGetCurrentValue: TgxNavigatorSmoothChangeSingleGetEvent;

This item has no description.

Private FOnSetCurrentValue: TgxNavigatorSmoothChangeSingleSetEvent;

This item has no description.

Methods

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function Proceed(ADeltaTime: Double): Boolean; override;

This item has no description. Showing description inherited from TgxNavigatorSmoothChangeItem.Proceed.

Returns False if there was no change.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); override;

This item has no description.

Properties

Published property OnGetCurrentValue: TgxNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;

This item has no description.

Published property OnSetCurrentValue: TgxNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;

This item has no description.

Published property TargetValue: Single read FTargetValue write FTargetValue;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorSmoothChangeVector

Class TgxNavigatorSmoothChangeVector

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorSmoothChangeVector = class(TgxNavigatorSmoothChangeItem)

Description

Smoothly change any Vector4f value, so it will become TargetValue in the end.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxNavigatorSmoothChangeItem
  • TgxNavigatorSmoothChangeVector

Overview

Fields

Private | FTargetValue: TgxCoordinates;
Private | FOnGetCurrentValue: TgxNavigatorSmoothChangeVectorGetEvent;
Private | FOnSetCurrentValue: TgxNavigatorSmoothChangeVectorSetEvent;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;
Private | procedure SetTargetValue(const Value: TgxCoordinates);

Properties

Published | property OnGetCurrentValue: TgxNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TgxNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: TgxCoordinates read FTargetValue write SetTargetValue;

Description

Fields

Private FTargetValue: TgxCoordinates;

This item has no description.

Private FOnGetCurrentValue: TgxNavigatorSmoothChangeVectorGetEvent;

This item has no description.

Private FOnSetCurrentValue: TgxNavigatorSmoothChangeVectorSetEvent;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public function Proceed(ADeltaTime: Double): Boolean; override;

This item has no description. Showing description inherited from TgxNavigatorSmoothChangeItem.Proceed.

Returns False if there was no change.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure ResetTargetValue(); override;

This item has no description.

Private procedure SetTargetValue(const Value: TgxCoordinates);

This item has no description.

Properties

Published property OnGetCurrentValue: TgxNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;

This item has no description.

Published property OnSetCurrentValue: TgxNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;

This item has no description.

Published property TargetValue: TgxCoordinates read FTargetValue write SetTargetValue;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorSmoothChangeItems

Class TgxNavigatorSmoothChangeItems

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorSmoothChangeItems = class(TXCollection)

Description

XCollection of TgxNavigatorSmoothChangeItem.

Hierarchy

  • TObject
  • TPersistent
  • TXCollection
  • TgxNavigatorSmoothChangeItems

Overview

Methods

Public | function Add(AClass : TgxNavigatorSmoothChangeItemClass): TgxNavigatorSmoothChangeItem;
Public | function CanAdd(AClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Private | function GetItems(const Index : Integer): TgxNavigatorSmoothChangeItem;
Private | procedure SetItems(const Index : Integer; const Value: TgxNavigatorSmoothChangeItem);

Properties

Public property Items[const Index: Integer]: TgxNavigatorSmoothChangeItem read GetItems write SetItems;

Description

Methods

Public function Add(AClass : TgxNavigatorSmoothChangeItemClass): TgxNavigatorSmoothChangeItem;

This item has no description.

Public function CanAdd(AClass: TXCollectionItemClass): Boolean; override;

This item has no description. Showing description inherited from TXCollection.CanAdd.

Indicates if an object of the given class can be added. This function is used to enforce Unique XCollection.

Public class function ItemsClass: TXCollectionItemClass; override;

This item has no description. Showing description inherited from TXCollection.ItemsClass.

Class of the items. Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Private function GetItems(const Index : Integer): TgxNavigatorSmoothChangeItem;

This item has no description.

Private procedure SetItems(const Index : Integer; const Value: TgxNavigatorSmoothChangeItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TgxNavigatorSmoothChangeItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorAdjustDistanceParameters

Class TgxNavigatorAdjustDistanceParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorAdjustDistanceParameters = class(TgxNavigatorAbstractParameters)

Description

This is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorAbstractParameters
  • TgxNavigatorAdjustDistanceParameters

Overview

Fields

Private | FOldDistanceRatio: Single;
Private | FImpulseSpeed: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreImpulseSpeed: Boolean;
Public | procedure AddImpulse(const Impulse: Single); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); override;

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;

Description

Fields

Private FOldDistanceRatio: Single;

This item has no description.

Private FImpulseSpeed: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreImpulseSpeed: Boolean;

This item has no description.

Public procedure AddImpulse(const Impulse: Single); virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); override;

This item has no description.

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorAdjustDistanceParametersEx

Class TgxNavigatorAdjustDistanceParametersEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorAdjustDistanceParametersEx = class(TgxNavigatorAbstractParameters)

Description

This is a wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorAbstractParameters
  • TgxNavigatorAdjustDistanceParametersEx

Overview

Fields

Private | FSpeedLimit: Single;
Private | FTargetDistance: Single;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Private | function StoreSpeedLimit: Boolean;
Private | function StoreTargetDistance: Boolean;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;
Published | property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;

Description

Fields

Private FSpeedLimit: Single;

This item has no description.

Private FTargetDistance: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Private function StoreSpeedLimit: Boolean;

This item has no description.

Private function StoreTargetDistance: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;

This item has no description.

Published property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorInertiaParameters

Class TgxNavigatorInertiaParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorInertiaParameters = class(TPersistent)

Description

This is a wrapper for all parameters that affect the smoothness of movement

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorInertiaParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | OldTurnHorizontalAngle: Single;
Private | OldTurnVerticalAngle: Single;
Private | OldMoveForwardDistance: Single;
Private | OldStrafeHorizontalDistance: Single;
Private | OldStrafeVerticalDistance: Single;
Private | FTurnInertia: Single;
Private | FTurnSpeed: Single;
Private | FTurnMaxAngle: Single;
Private | FMovementAcceleration: Single;
Private | FMovementInertia: Single;
Private | FMovementSpeed: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreMovementAcceleration: Boolean;
Private | function StoreMovementInertia: Boolean;
Private | function StoreMovementSpeed: Boolean;
Private | function StoreTurnInertia: Boolean;
Private | function StoreTurnMaxAngle: Boolean;
Private | function StoreTurnSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;
Published | property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;
Published | property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;
Published | property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;
Published | property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private OldTurnHorizontalAngle: Single;

This item has no description.

Private OldTurnVerticalAngle: Single;

This item has no description.

Private OldMoveForwardDistance: Single;

This item has no description.

Private OldStrafeHorizontalDistance: Single;

This item has no description.

Private OldStrafeVerticalDistance: Single;

This item has no description.

Private FTurnInertia: Single;

This item has no description.

Private FTurnSpeed: Single;

This item has no description.

Private FTurnMaxAngle: Single;

This item has no description.

Private FMovementAcceleration: Single;

This item has no description.

Private FMovementInertia: Single;

This item has no description.

Private FMovementSpeed: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreMovementAcceleration: Boolean;

This item has no description.

Private function StoreMovementInertia: Boolean;

This item has no description.

Private function StoreMovementSpeed: Boolean;

This item has no description.

Private function StoreTurnInertia: Boolean;

This item has no description.

Private function StoreTurnMaxAngle: Boolean;

This item has no description.

Private function StoreTurnSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Properties

Published property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;

This item has no description.

Published property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;

This item has no description.

Published property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;

This item has no description.

Published property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;

This item has no description.

Published property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;

This item has no description.

Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorGeneralParameters

Class TgxNavigatorGeneralParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorGeneralParameters = class(TPersistent)

Description

This is a wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorGeneralParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FAutoScaleMin: Single;
Private | FAutoScaleMax: Single;
Private | FAutoScaleMult: Single;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreAutoScaleMax: Boolean;
Private | function StoreAutoScaleMin: Boolean;
Private | function StoreAutoScaleMult: Boolean;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;
Published | property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;
Published | property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FAutoScaleMin: Single;

This item has no description.

Private FAutoScaleMax: Single;

This item has no description.

Private FAutoScaleMult: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreAutoScaleMax: Boolean;

This item has no description.

Private function StoreAutoScaleMin: Boolean;

This item has no description.

Private function StoreAutoScaleMult: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;

This item has no description.

Published property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;

This item has no description.

Published property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxNavigatorMoveAroundParameters

Class TgxNavigatorMoveAroundParameters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxNavigatorMoveAroundParameters = class(TPersistent)

Description

This is a wrapper for all parameters that effect how the TgxBaseSceneObject.MoveObjectAround() procedure works

Hierarchy

  • TObject
  • TPersistent
  • TgxNavigatorMoveAroundParameters

Overview

Fields

Private | FOwner: TPersistent;
Private | FTargetObject: TgxBaseSceneObject;
Private | FOldPitchInertiaAngle: Single;
Private | FOldTurnInertiaAngle: Single;
Private | FPitchSpeed: Single;
Private | FTurnSpeed: Single;
Private | FInertia: Single;
Private | FMaxAngle: Single;
Private | FCutoff: Double;

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Private | function StoreCutoff: Boolean;
Private | function StoreInertia: Boolean;
Private | function StoreMaxAngle: Boolean;
Private | function StorePitchSpeed: Boolean;
Private | function StoreTurnSpeed: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;
Private | procedure SetTargetObject(const Value: TgxBaseSceneObject);

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;
Published | property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;
Published | property TargetObject: TgxBaseSceneObject read FTargetObject write SetTargetObject;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FTargetObject: TgxBaseSceneObject;

This item has no description.

Private FOldPitchInertiaAngle: Single;

This item has no description.

Private FOldTurnInertiaAngle: Single;

This item has no description.

Private FPitchSpeed: Single;

This item has no description.

Private FTurnSpeed: Single;

This item has no description.

Private FInertia: Single;

This item has no description.

Private FMaxAngle: Single;

This item has no description.

Private FCutoff: Double;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); virtual;

This item has no description.

Private function StoreCutoff: Boolean;

This item has no description.

Private function StoreInertia: Boolean;

This item has no description.

Private function StoreMaxAngle: Boolean;

This item has no description.

Private function StorePitchSpeed: Boolean;

This item has no description.

Private function StoreTurnSpeed: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

This item has no description.

Private procedure SetTargetObject(const Value: TgxBaseSceneObject);

This item has no description.

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;

This item has no description.

Published property Inertia: Single read FInertia write FInertia stored StoreInertia;

This item has no description.

Published property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;

This item has no description.

Published property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;

This item has no description.

Published property TargetObject: TgxBaseSceneObject read FTargetObject write SetTargetObject;

This item has no description.

Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxSmoothNavigator

Class TgxSmoothNavigator

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxSmoothNavigator = class(TgxNavigator)

Description

This is the component for moving a TgxBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNavigator
  • TgxSmoothNavigator

Overview

Fields

Private | FMaxExpectedDeltaTime: Double;
Private | FInertiaParams: TgxNavigatorInertiaParameters;
Private | FGeneralParams: TgxNavigatorGeneralParameters;
Private | FMoveAroundParams: TgxNavigatorMoveAroundParameters;
Private | FAdjustDistanceParams: TgxNavigatorAdjustDistanceParameters;
Private | FAdjustDistanceParamsEx: TgxNavigatorAdjustDistanceParametersEx;
Private | FCustomAnimatedItems: TgxNavigatorSmoothChangeItems;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AdjustDistanceToPoint(const APoint: TVector4f; const DistanceRatio : Single; ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToPointEx(const APoint: TVector4f; ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean; virtual;
Public | function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean; virtual;
Public | function MoveObjectAround(const AObject: TgxBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean; virtual;
Private | function StoreMaxExpectedDeltaTime: Boolean;
Public | procedure AnimateCustomItems(const ADeltaTime: Double); virtual;
Public | procedure AutoScaleParameters(const FPS: Single); virtual;
Public | procedure AutoScaleParametersUp(const FPS: Single); virtual;
Public | procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure ScaleParameters(const Value: Single); virtual;
Public | procedure SetObject(Value: TgxBaseSceneObject); override;
Public | procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;
Public | procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;
Private | procedure SetAdjustDistanceParams(const Value: TgxNavigatorAdjustDistanceParameters);
Private | procedure SetAdjustDistanceParamsEx( const Value: TgxNavigatorAdjustDistanceParametersEx);
Private | procedure SetCustomAnimatedItems( const Value: TgxNavigatorSmoothChangeItems);
Private | procedure SetGeneralParams(const Value: TgxNavigatorGeneralParameters);
Private | procedure SetInertiaParams(const Value: TgxNavigatorInertiaParameters);
Private | procedure SetMoveAroundParams(const Value: TgxNavigatorMoveAroundParameters);

Properties

Published | property AdjustDistanceParams: TgxNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;
Published | property AdjustDistanceParamsEx: TgxNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;
Published | property CustomAnimatedItems: TgxNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;
Published | property GeneralParams: TgxNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;
Published | property InertiaParams: TgxNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;
Published | property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;
Published | property MoveAroundParams: TgxNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;

Description

Fields

Private FMaxExpectedDeltaTime: Double;

This item has no description.

Private FInertiaParams: TgxNavigatorInertiaParameters;

This item has no description.

Private FGeneralParams: TgxNavigatorGeneralParameters;

This item has no description.

Private FMoveAroundParams: TgxNavigatorMoveAroundParameters;

This item has no description.

Private FAdjustDistanceParams: TgxNavigatorAdjustDistanceParameters;

This item has no description.

Private FAdjustDistanceParamsEx: TgxNavigatorAdjustDistanceParametersEx;

This item has no description.

Private FCustomAnimatedItems: TgxNavigatorSmoothChangeItems;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

Constructors-destructors.

Public destructor Destroy; override;

This item has no description.

Public function AdjustDistanceToPoint(const APoint: TVector4f; const DistanceRatio : Single; ADeltaTime: Double): Boolean; virtual;

Uses AdjustDistanceParams.

Public function AdjustDistanceToPointEx(const APoint: TVector4f; ADeltaTime: Double): Boolean; virtual;

Uses AdjustDistanceParamsEx.

Public function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean; virtual;

This item has no description.

Public function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean; virtual;

This item has no description.

Public function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean; virtual;

Uses MoveAroundParams. Returns True, if object was actually moved.

Public function MoveObjectAround(const AObject: TgxBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean; virtual;

This item has no description.

Private function StoreMaxExpectedDeltaTime: Boolean;

This item has no description.

Public procedure AnimateCustomItems(const ADeltaTime: Double); virtual;

Uses CustomAnimatedItems.

Public procedure AutoScaleParameters(const FPS: Single); virtual;

This item has no description.

Public procedure AutoScaleParametersUp(const FPS: Single); virtual;

This item has no description.

Public procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure ScaleParameters(const Value: Single); virtual;

In ScaleParameters, Value should be around 1.

Public procedure SetObject(Value: TgxBaseSceneObject); override;

From TgxNavigator. Probably, should not be public.

Public procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;

This item has no description.

Public procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;

Uses InertiaParams.

Public procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;

This item has no description.

Private procedure SetAdjustDistanceParams(const Value: TgxNavigatorAdjustDistanceParameters);

This item has no description.

Private procedure SetAdjustDistanceParamsEx( const Value: TgxNavigatorAdjustDistanceParametersEx);

This item has no description.

Private procedure SetCustomAnimatedItems( const Value: TgxNavigatorSmoothChangeItems);

This item has no description.

Private procedure SetGeneralParams(const Value: TgxNavigatorGeneralParameters);

This item has no description.

Private procedure SetInertiaParams(const Value: TgxNavigatorInertiaParameters);

This item has no description.

Private procedure SetMoveAroundParams(const Value: TgxNavigatorMoveAroundParameters);

This item has no description.

Properties

Published property AdjustDistanceParams: TgxNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;

This item has no description.

Published property AdjustDistanceParamsEx: TgxNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;

This item has no description.

Published property CustomAnimatedItems: TgxNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;

This item has no description.

Published property GeneralParams: TgxNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;

This item has no description.

Published property InertiaParams: TgxNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;

This item has no description.

Published property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;

This item has no description.

Published property MoveAroundParams: TgxNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;


GXSysHelp v.2.5: GXS.SmoothNavigator: Class TgxSmoothUserInterface

Class TgxSmoothUserInterface

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SmoothNavigator

Declaration

type TgxSmoothUserInterface = class(TComponent)

Description

This is the component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSmoothUserInterface

Overview

Fields

Private | FAutoUpdateMouse: Boolean;
Private | FMouseLookActive: Boolean;
Private | FSmoothNavigator: TgxSmoothNavigator;
Private | FSmoothVertNavigator: TgxSmoothNavigator;
Private | FInvertMouse: Boolean;
Private | FOriginalMousePos: TgxCoordinates2;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseLook(const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const NewXY: TPoint; const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;
Public | procedure MouseLookActiveToggle; virtual;
Public | procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;
Public | procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;
Private | procedure SetMouseLookActive(const Value: Boolean); virtual;
Private | procedure SetOriginalMousePos(const Value: TgxCoordinates2); virtual;
Private | procedure SetSmoothNavigator(const Value: TgxSmoothNavigator); virtual;
Private | procedure SetSmoothVertNavigator(const Value: TgxSmoothNavigator); virtual;

Properties

Published | property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;
Published | property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;
Published | property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;
Published | property OriginalMousePos: TgxCoordinates2 read FOriginalMousePos write SetOriginalMousePos;
Published | property SmoothNavigator: TgxSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;
Published | property SmoothVertNavigator: TgxSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;

Description

Fields

Private FAutoUpdateMouse: Boolean;

This item has no description.

Private FMouseLookActive: Boolean;

This item has no description.

Private FSmoothNavigator: TgxSmoothNavigator;

This item has no description.

Private FSmoothVertNavigator: TgxSmoothNavigator;

This item has no description.

Private FInvertMouse: Boolean;

This item has no description.

Private FOriginalMousePos: TgxCoordinates2;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MouseLook(const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public function MouseLook(const NewXY: TPoint; const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;

This item has no description.

Public procedure MouseLookActiveToggle; virtual;

This item has no description.

Public procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;

This item has no description.

Public procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;

This item has no description.

Private procedure SetMouseLookActive(const Value: Boolean); virtual;

This item has no description.

Private procedure SetOriginalMousePos(const Value: TgxCoordinates2); virtual;

This item has no description.

Private procedure SetSmoothNavigator(const Value: TgxSmoothNavigator); virtual;

This item has no description.

Private procedure SetSmoothVertNavigator(const Value: TgxSmoothNavigator); virtual;

This item has no description.

Properties

Published property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;

This item has no description.

Published property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;

This item has no description.

Published property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;

This item has no description.

Published property OriginalMousePos: TgxCoordinates2 read FOriginalMousePos write SetOriginalMousePos;

This item has no description.

Published property SmoothNavigator: TgxSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;

This item has no description.

Published property SmoothVertNavigator: TgxSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;


GXSysHelp v.2.5: GXS.SoundFileObjects

Unit GXS.SoundFileObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • Winapi.MMSystem
  • GXS.ApplicationFileIO
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSoundSampling |
Class TgxSoundFile |
Record TgxSoundFileFormat |
Class TgxSoundFileFormatsList |

Functions and Procedures

function GetGLSoundFileFormats: TgxSoundFileFormatsList;
procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TgxSoundFileClass);
procedure UnregisterSoundFileClass(AClass: TgxSoundFileClass);

Types

PSoundFileFormat = ˆTgxSoundFileFormat;
TgxSoundFileClass = class of TgxSoundFile;

Description

Functions and Procedures

function GetGLSoundFileFormats: TgxSoundFileFormatsList;

This item has no description.

procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TgxSoundFileClass);

This item has no description.

procedure UnregisterSoundFileClass(AClass: TgxSoundFileClass);

This item has no description.

Types

PSoundFileFormat = ˆTgxSoundFileFormat;

This item has no description.

TgxSoundFileClass = class of TgxSoundFile;


GXSysHelp v.2.5: GXS.SoundFileObjects: Class TgxSoundSampling

Class TgxSoundSampling

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundFileObjects

Declaration

type TgxSoundSampling = class(TPersistent)

Description

Defines a sound sampling quality.

Hierarchy

  • TObject
  • TPersistent
  • TgxSoundSampling

Overview

Fields

Private | FOwner: TPersistent;
Private | FFrequency: Integer;
Private | FNbChannels: Integer;
Private | FBitsPerSample: Integer;

Methods

Public | constructor Create(AOwner: TPersistent);
Public | destructor Destroy; override;
Public | function BytesPerSample: Integer;
Public | function BytesPerSec: Integer;
Public | function WaveFormat: TWaveFormatEx;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BitsPerSample: Integer read FBitsPerSample write FBitsPerSample default 8;
Published | property Frequency: Integer read FFrequency write FFrequency default 22050;
Published | property NbChannels: Integer read FNbChannels write FNbChannels default 1;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Private FFrequency: Integer;

This item has no description.

Private FNbChannels: Integer;

This item has no description.

Private FBitsPerSample: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BytesPerSample: Integer;

This item has no description.

Public function BytesPerSec: Integer;

This item has no description.

Public function WaveFormat: TWaveFormatEx;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property BitsPerSample: Integer read FBitsPerSample write FBitsPerSample default 8;

Nb of bits per sample. Common values are 8 and 16 bits.

Published property Frequency: Integer read FFrequency write FFrequency default 22050;

Sampling frequency in Hz (= samples per sec)

Published property NbChannels: Integer read FNbChannels write FNbChannels default 1;

Nb of sampling channels. 1 = mono, 2 = stereo, etc.


GXSysHelp v.2.5: GXS.SoundFileObjects: Class TgxSoundFile

Class TgxSoundFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundFileObjects

Declaration

type TgxSoundFile = class(TgxDataFile)

Description

Abstract base class for different Sound file Formatx. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TgxSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxSoundFile

Overview

Fields

Private FSampling: TgxSoundSampling;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function LengthInBytes: Integer; virtual; abstract;
Public | function LengthInSamples: Integer;
Public | function LengthInSec: Single;
Public | function PCMData: Pointer; virtual; abstract;
Public | function WAVData: Pointer; virtual; abstract;
Public | function WAVDataSize: Integer; virtual; abstract;
Public | procedure PlayOnWaveOut; virtual;

Properties

Public property Sampling: TgxSoundSampling read FSampling write SetSampling;

Description

Fields

Private FSampling: TgxSoundSampling;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LengthInBytes: Integer; virtual; abstract;

Length of PCM data, in bytes.

Public function LengthInSamples: Integer;

Nb of intensity samples in the sample.

Public function LengthInSec: Single;

Length of play of the sample at nominal speed in seconds.

Public function PCMData: Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData: Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize: Integer; virtual; abstract;

Returns the size (in bytes) of the WAVData.

Public procedure PlayOnWaveOut; virtual;

This item has no description.

Properties

Public property Sampling: TgxSoundSampling read FSampling write SetSampling;


GXSysHelp v.2.5: GXS.SoundFileObjects: Record TgxSoundFileFormat

Record TgxSoundFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundFileObjects

Declaration

type TgxSoundFileFormat = record

Description

This item has no description.

Overview

Fields

Public | SoundFileClass: TgxSoundFileClass;
Public | Extension: String;
Public | Description: String;
Public | DescResID: Integer;

Description

Fields

Public SoundFileClass: TgxSoundFileClass;

This item has no description.

Public Extension: String;

This item has no description.

Public Description: String;

This item has no description.

Public DescResID: Integer;


GXSysHelp v.2.5: GXS.SoundFileObjects: Class TgxSoundFileFormatsList

Class TgxSoundFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundFileObjects

Declaration

type TgxSoundFileFormatsList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxSoundFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TgxSoundFileClass;
Public | procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TgxSoundFileClass);
Public | procedure BuildFilterStrings(SoundFileClass: TgxSoundFileClass; out Descriptions, Filters: string);
Public | procedure Remove(AClass: TgxSoundFileClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(Ext: string): TgxSoundFileClass;

This item has no description.

Public procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TgxSoundFileClass);

This item has no description.

Public procedure BuildFilterStrings(SoundFileClass: TgxSoundFileClass; out Descriptions, Filters: string);

This item has no description.

Public procedure Remove(AClass: TgxSoundFileClass);


GXSysHelp v.2.5: GXS.SoundManager

Unit GXS.SoundManager

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.BaseClasses
  • GLScene.XCollection
  • GXS.SoundFileObjects
  • GXS.Scene
  • GXS.Cadencer
  • GLScene.Utils
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSoundSample |
Class TgxSoundSamples |
Class TgxSoundLibrary |
Class TgxBaseSoundSource |
Class TgxSoundSource |
Class TgxSoundSources |
Class TgxSoundManager |
Class TgxBSoundEmitter |

Functions and Procedures

function ActiveSoundManager: TgxSoundManager;
function GetSoundLibraryByName(const aName: string): TgxSoundLibrary;
function GetOrCreateSoundEmitter(behaviours: TgxBehaviours): TgxBSoundEmitter; overload;
function GetOrCreateSoundEmitter(obj: TgxBaseSceneObject): TgxBSoundEmitter; overload;

Types

TgxSoundEnvironment = (...);
TgxSoundSourceChange = (...);
TgxSoundSourceChanges = set of TgxSoundSourceChange;

Variables

vVerboseGLSMErrors: Boolean = True;

Description

Functions and Procedures

function ActiveSoundManager: TgxSoundManager;

This item has no description.

function GetSoundLibraryByName(const aName: string): TgxSoundLibrary;

This item has no description.

function GetOrCreateSoundEmitter(behaviours: TgxBehaviours): TgxBSoundEmitter; overload;

This item has no description.

function GetOrCreateSoundEmitter(obj: TgxBaseSceneObject): TgxBSoundEmitter; overload;

This item has no description.

Types

TgxSoundEnvironment = (...);

EAX standard sound environments

Values
  • seDefault
  • sePaddedCell
  • seRoom
  • seBathroom
  • seLivingRoom
  • seStoneroom
  • seAuditorium
  • seConcertHall
  • seCave
  • seArena
  • seHangar
  • seCarpetedHallway
  • seHallway
  • seStoneCorridor
  • seAlley
  • seForest
  • seCity
  • seMountains
  • seQuarry
  • sePlain
  • seParkingLot
  • seSewerPipe
  • seUnderWater
  • seDrugged
  • seDizzy
  • sePsychotic
TgxSoundSourceChange = (...);

This item has no description.

Values
  • sscTransformation
  • sscSample
  • sscStatus
TgxSoundSourceChanges = set of TgxSoundSourceChange;

This item has no description.

Variables

vVerboseGLSMErrors: Boolean = True;

If this variable is true, errors in GLSM may be displayed to the user


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundSample

Class TgxSoundSample

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundSample = class(TCollectionItem)

Description

Stores a single PCM coded sound sample.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxSoundSample

Overview

Fields

Private | FName: string;
Private | FData: TgxSoundFile;
Private | FTag: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function LengthInBytes: Integer;
Public | function LengthInSamples: Integer;
Public | function LengthInSec: Single;
Public | function Sampling: TgxSoundSampling;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure PlayOnWaveOut;

Properties

Published | property Data: TgxSoundFile read FData write SetData stored False;
Public | property ManagerTag: Integer read FTag write FTag;
Published | property Name: string read FName write FName;

Description

Fields

Private FName: string;

This item has no description.

Private FData: TgxSoundFile;

This item has no description.

Private FTag: Integer;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LengthInBytes: Integer;

This item has no description.

Public function LengthInSamples: Integer;

This item has no description.

Public function LengthInSec: Single;

This item has no description.

Public function Sampling: TgxSoundSampling;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string);

This item has no description.

Public procedure PlayOnWaveOut;

This item has no description.

Properties

Published property Data: TgxSoundFile read FData write SetData stored False;

This item has no description.

Public property ManagerTag: Integer read FTag write FTag;

This Tag is reserved for sound manager use only

Published property Name: string read FName write FName;


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundSamples

Class TgxSoundSamples

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundSamples = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxSoundSamples

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TgxSoundSample;
Public | function AddFile(const fileName: string; const sampleName: string = ''): TgxSoundSample;
Public | function FindItemID(ID: Integer): TgxSoundSample;
Public | function GetByName(const aName: string): TgxSoundSample;

Properties

Public property Items[index: Integer]: TgxSoundSample read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Public function Add: TgxSoundSample;

This item has no description.

Public function AddFile(const fileName: string; const sampleName: string = ''): TgxSoundSample;

This item has no description.

Public function FindItemID(ID: Integer): TgxSoundSample;

This item has no description.

Public function GetByName(const aName: string): TgxSoundSample;

This item has no description.

Properties

Public property Items[index: Integer]: TgxSoundSample read GetItems write SetItems;


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundLibrary

Class TgxSoundLibrary

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundLibrary = class(TComponent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSoundLibrary

Overview

Fields

Private FSamples: TgxSoundSamples;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property Samples: TgxSoundSamples read FSamples write SetSamples;

Description

Fields

Private FSamples: TgxSoundSamples;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Samples: TgxSoundSamples read FSamples write SetSamples;


GXSysHelp v.2.5: GXS.SoundManager: Class TgxBaseSoundSource

Class TgxBaseSoundSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxBaseSoundSource = class(TCollectionItem)

Description

Base class for origin of sound playback.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxBaseSoundSource

Overview

Fields

Private | FBehaviourToNotify: TgxBSoundEmitter;
Private | FPriority: Integer;
Private | FOrigin: TgxBaseSceneObject;
Private | FVolume: Single;
Private | FMinDistance: Single;
Private | FMaxDistance: Single;
Private | FInsideConeAngle: Single;
Private | FOutsideConeAngle: Single;
Private | FConeOutsideVolume: Single;
Private | FSoundLibraryName: string;
Private | FSoundLibrary: TgxSoundLibrary;
Private | FSoundName: string;
Private | FMute: Boolean;
Private | FPause: Boolean;
Private | FChanges: TgxSoundSourceChanges;
Private | FNbLoops: Integer;
Private | FTag: Cardinal;
Private | FFrequency: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function Sample: TgxSoundSample;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public | property Changes: TgxSoundSourceChanges read FChanges;
Published | property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;
Published | property Frequency: Integer read FFrequency write SetFrequency default -1;
Published | property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;
Public | property ManagerTag: Cardinal read FTag write FTag;
Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property NbLoops: Integer read FNbLoops write SetNbLoops default 1;
Public | property Origin: TgxBaseSceneObject read FOrigin write SetOrigin;
Published | property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property Priority: Integer read FPriority write SetPriority default 0;
Published | property SoundLibrary: TgxSoundLibrary read GetSoundLibrary write SetSoundLibrary;
Published | property SoundName: string read FSoundName write SetSoundName;
Published | property Volume: Single read FVolume write SetVolume;

Description

Fields

Private FBehaviourToNotify: TgxBSoundEmitter;

This item has no description.

Private FPriority: Integer;

private only, NOT persistent, not assigned

Private FOrigin: TgxBaseSceneObject;

This item has no description.

Private FVolume: Single;

NOT persistent

Private FMinDistance: Single;

This item has no description.

Private FMaxDistance: Single;

This item has no description.

Private FInsideConeAngle: Single;

This item has no description.

Private FOutsideConeAngle: Single;

This item has no description.

Private FConeOutsideVolume: Single;

This item has no description.

Private FSoundLibraryName: string;

This item has no description.

Private FSoundLibrary: TgxSoundLibrary;

used for persistence

Private FSoundName: string;

persistence via name

Private FMute: Boolean;

This item has no description.

Private FPause: Boolean;

This item has no description.

Private FChanges: TgxSoundSourceChanges;

This item has no description.

Private FNbLoops: Integer;

NOT persistent, not assigned

Private FTag: Cardinal;

This item has no description.

Private FFrequency: Integer;

NOT persistent, not assigned

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Sample: TgxSoundSample;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Public property Changes: TgxSoundSourceChanges read FChanges;

This item has no description.

Published property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;

Cone outside volume, [0.0; 1.0] range. See DirectX SDK for details.

Published property Frequency: Integer read FFrequency write SetFrequency default -1;

Sample custom playback frequency. Values null or negative are interpreted as 'default frequency'.

Published property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;

Inside cone angle, [0°; 360°]. Sound volume is maximal within this cone. See DirectX SDK for details.

Public property ManagerTag: Cardinal read FTag write FTag;

This Tag is reserved for sound manager use only

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance;

Max distance, if source is further away, it will not be heard. 100.0 by default

Published property MinDistance: Single read FMinDistance write SetMinDistance;

Min distance before spatial attenuation occurs. 1.0 by default

Published property Mute: Boolean read FMute write SetMute default False;

This item has no description.

Published property NbLoops: Integer read FNbLoops write SetNbLoops default 1;

Nb of playing loops.

Public property Origin: TgxBaseSceneObject read FOrigin write SetOrigin;

Origin object for the sound sources. Absolute object position/orientation are taken into account, the object's TgxBInertia is considered if any. If origin is nil, the source is assumed to be static at the origin. Note : since TCollectionItem do not support the "Notification" scheme, it is up to the Origin object to take care of updating this property prior to release/destruction.

Published property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;

Outside cone angle, [0°; 360°]. Between inside and outside cone, sound volume decreases between max and cone outside volume. See DirectX SDK for details.

Published property Pause: Boolean read FPause write SetPause default False;

This item has no description.

Published property Priority: Integer read FPriority write SetPriority default 0;

Sound source priority, the higher the better. When maximum number of sound sources is reached, only the sources with the highest priority will continue to play, however, even non-playing sources should be tracked by the manager, thus allowing an "unlimited" amount of sources from the application point of view.

Published property SoundLibrary: TgxSoundLibrary read GetSoundLibrary write SetSoundLibrary;

This item has no description.

Published property SoundName: string read FSoundName write SetSoundName;

This item has no description.

Published property Volume: Single read FVolume write SetVolume;

Volume of the source, [0.0; 1.0] range


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundSource

Class TgxSoundSource

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundSource = class(TgxBaseSoundSource)

Description

Origin of sound playback. Just publishes the 'Origin' property. Note: "orientation" is the the source's Direction, ie. the "Z" vector.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxBaseSoundSource
  • TgxSoundSource

Overview

Methods

Public destructor Destroy; override;

Properties

Published property Origin;

Description

Methods

Public destructor Destroy; override;

This item has no description.

Properties

Published property Origin;

This item has no description. Showing description inherited from TgxBaseSoundSource.Origin.

Origin object for the sound sources. Absolute object position/orientation are taken into account, the object's TgxBInertia is considered if any. If origin is nil, the source is assumed to be static at the origin. Note : since TCollectionItem do not support the "Notification" scheme, it is up to the Origin object to take care of updating this property prior to release/destruction.


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundSources

Class TgxSoundSources

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundSources = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxSoundSources

Overview

Methods

Public constructor Create(AOwner: TComponent);

Properties

Public property Items[index: Integer]: TgxSoundSource read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);

This item has no description.

Properties

Public property Items[index: Integer]: TgxSoundSource read GetItems write SetItems;


GXSysHelp v.2.5: GXS.SoundManager: Class TgxSoundManager

Class TgxSoundManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxSoundManager = class(TgxCadenceAbleComponent)

Description

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxSoundManager

Overview

Fields

Private | FActive: Boolean;
Private | FMute: Boolean;
Private | FPause: Boolean;
Private | FMasterVolume: Single;
Private | FListener: TgxBaseSceneObject;
Private | FLastListenerPosition: TVector4f;
Private | FSources: TgxSoundSources;
Private | FMaxChannels: Integer;
Private | FOutputFrequency: Integer;
Private | FUpdateFrequency: Single;
Private | FDistanceFactor: Single;
Private | FRollOffFactor: Single;
Private | FDopplerFactor: Single;
Private | FSoundEnvironment: TgxSoundEnvironment;
Private | FLastUpdateTime: Single;
Private | FLastDeltaTime: Single;
Private | FCadencer: TgxCadencer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; virtual;
Public | function EAXSupported: Boolean; virtual;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure StopAllSources;
Public | procedure UpdateSources; virtual;
Private | procedure ReadDoppler(reader: TReader);
Private | procedure SetActive(const val: Boolean);
Private | procedure SetMute(const val: Boolean);
Private | procedure SetPause(const val: Boolean);
Private | procedure WriteDoppler(writer: TWriter);

Properties

Published | property Active: Boolean read FActive write SetActive default False;
Published | property Cadencer: TgxCadencer read FCadencer write SetCadencer;
Published | property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;
Published | property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;
Published | property Environment: TgxSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;
Published | property Listener: TgxBaseSceneObject read FListener write SetListener;
Published | property MasterVolume: Single read FMasterVolume write SetMasterVolume;
Published | property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;
Published | property Sources: TgxSoundSources read FSources write SetSources;
Published | property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Description

Fields

Private FActive: Boolean;

This item has no description.

Private FMute: Boolean;

This item has no description.

Private FPause: Boolean;

This item has no description.

Private FMasterVolume: Single;

This item has no description.

Private FListener: TgxBaseSceneObject;

This item has no description.

Private FLastListenerPosition: TVector4f;

This item has no description.

Private FSources: TgxSoundSources;

This item has no description.

Private FMaxChannels: Integer;

This item has no description.

Private FOutputFrequency: Integer;

This item has no description.

Private FUpdateFrequency: Single;

This item has no description.

Private FDistanceFactor: Single;

This item has no description.

Private FRollOffFactor: Single;

This item has no description.

Private FDopplerFactor: Single;

This item has no description.

Private FSoundEnvironment: TgxSoundEnvironment;

This item has no description.

Private FLastUpdateTime: Single;

This item has no description.

Private FLastDeltaTime: Single;

This item has no description.

Private FCadencer: TgxCadencer;

last time UpdateSources was fired, not persistent

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CPUUsagePercent: Single; virtual;

Sound manager API reported CPU Usage. Returns -1 when unsupported.

Public function EAXSupported: Boolean; virtual;

True if EAX is supported.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

Progress notification for time synchronization. This method will call UpdateSources depending on the last time it was performed and the value of the UpdateFrequency property.

Public procedure StopAllSources;

Stop and free all sources.

Public procedure UpdateSources; virtual;

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Private procedure ReadDoppler(reader: TReader);

This item has no description.

Private procedure SetActive(const val: Boolean);

This item has no description.

Private procedure SetMute(const val: Boolean);

This item has no description.

Private procedure SetPause(const val: Boolean);

This item has no description.

Private procedure WriteDoppler(writer: TWriter);

This item has no description.

Properties

Published property Active: Boolean read FActive write SetActive default False;

Activation/deactivation of the low-level sound API

Published property Cadencer: TgxCadencer read FCadencer write SetCadencer;

Cadencer for time-based control.

Published property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;

Engine relative distance factor, compared to 1.0 meters. Equates to 'how many units per meter' your engine has.

Published property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;

Engine relative Doppler factor, compared to 1.0 meters. Equates to 'how many units per meter' your engine has.

Published property Environment: TgxSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;

Sound environment (requires EAX compatible soundboard).

Published property Listener: TgxBaseSceneObject read FListener write SetListener;

Scene object that materializes the listener. The sceneobject's AbsolutePosition and orientation are used to define the listener coordinates, velocity is automatically calculated (if you're using DoProgress or connected the manager to a cadencer). If this property is nil, the listener is assumed to be static at the NullPoint coordinate, facing Z axis, with up being Y (ie. the default orientation).

Published property MasterVolume: Single read FMasterVolume write SetMasterVolume;

Master Volume adjustement in the [0.0; 1.0] range. Driver should take care of properly clamping the master volume.

Published property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;

Maximum number of sound output channels. While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).

Published property Mute: Boolean read FMute write SetMute default False;

Request to mute all sounds. All sound requests should be handled as if sound is unmuted though, however drivers should try to take a CPU advantage of mute over MasterVolume=0

Published property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;

Sound output mixing frequency. Commonly used values ar 11025, 22050 and 44100. Note that most driver cannot dynamically adjust the output frequency (you need to de-ativate and re-activate the manager for this property to be taken into account).

Published property Pause: Boolean read FPause write SetPause default False;

Request to pause all sound, sound output should be muted too. When unpausing, all sound should resume at the point they were paused.

Published property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;

Sets the global attenuation rolloff factor. Normally volume for a sample will scale at 1 / distance. This gives a logarithmic attenuation of volume as the source gets further away (or closer). Setting this value makes the sound drop off faster or slower. The higher the value, the faster volume will fall off.

Published property Sources: TgxSoundSources read FSources write SetSources;

Currently active and playing sound sources.

Published property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Update frequency for time-based control (DoProgress). Default value is 10 Hz (frequency is clamped in the 1Hz-60Hz range).


GXSysHelp v.2.5: GXS.SoundManager: Class TgxBSoundEmitter

Class TgxBSoundEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SoundManager

Declaration

type TgxBSoundEmitter = class(TgxBehaviour)

Description

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TgxSoundSource, for editing convenience.

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxBehaviour
  • TgxBSoundEmitter

Overview

Fields

Private | FPlaying: Boolean;
Private | FSource: TgxBaseSoundSource;
Private | FPlayingSource: TgxSoundSource;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;

Properties

Published | property Playing: Boolean read GetPlaying write SetPlaying default False;
Public | property PlayingSource: TgxSoundSource read FPlayingSource;
Published | property Source: TgxBaseSoundSource read FSource write SetSource;

Description

Fields

Private FPlaying: Boolean;

This item has no description.

Private FSource: TgxBaseSoundSource;

used at design-time ONLY

Private FPlayingSource: TgxSoundSource;

This item has no description.

Methods

Public constructor Create(aOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public class function UniqueItem: Boolean; override;

This item has no description. Showing description inherited from TXCollectionItem.UniqueItem.

If true only one such XCollectionItem is allowed per BaseSceneObject. Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique). Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Properties

Published property Playing: Boolean read GetPlaying write SetPlaying default False;

This item has no description.

Public property PlayingSource: TgxSoundSource read FPlayingSource;

This item has no description.

Published property Source: TgxBaseSoundSource read FSource write SetSource;


GXSysHelp v.2.5: GXS.Sounds.BASS

Unit GXS.Sounds.BASS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • FMX.Forms
  • GLScene.VectorTypes
  • GXS.SoundManager
  • GXS.Scene
  • GLScene.VectorGeometry
  • BASS.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSMBASS |

Types

TBASS3DAlgorithm = (...);

Description

Types

TBASS3DAlgorithm = (...);

This item has no description.

Values
  • algDefault
  • algOff
  • algFull
  • algLight


GXSysHelp v.2.5: GXS.Sounds.BASS: Class TgxSMBASS

Class TgxSMBASS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Sounds.BASS

Declaration

type TgxSMBASS = class(TgxSoundManager)

Description

This item has no description. Showing description inherited from TgxSoundManager.

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxSoundManager
  • TgxSMBASS

Overview

Fields

Private | FActivated: Boolean;
Private | FAlgorithm3D: TBASS3DAlgorithm;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; override;
Public | function EAXSupported: Boolean; override;
Public | procedure UpdateSources; override;

Properties

Published property Algorithm3D: TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;

Description

Fields

Private FActivated: Boolean;

This item has no description.

Private FAlgorithm3D: TBASS3DAlgorithm;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CPUUsagePercent: Single; override;

This item has no description. Showing description inherited from TgxSoundManager.CPUUsagePercent.

Sound manager API reported CPU Usage. Returns -1 when unsupported.

Public function EAXSupported: Boolean; override;

This item has no description. Showing description inherited from TgxSoundManager.EAXSupported.

True if EAX is supported.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TgxSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Properties

Published property Algorithm3D: TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;


GXSysHelp v.2.5: GXS.Sounds.FMOD

Unit GXS.Sounds.FMOD

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

========================================================================================== FMOD Main header file. Copyright (c), FireLight Technologies Pty, Ltd. 1999-2003. ===========================================================================================

NOTE: For the demos to run you must have either fmod.dll (in Windows) or libfmod-3.75.so (in Linux) installed.

In Winapi.Windows, copy the fmod.dll file found in the api directory to either of the following locations (in order of preference) - your application directory - Windows\System (95/98) or WinNT\System32 (NT/2000/XP)

In Linux, make sure you are signed in as root and copy the libfmod-3.75.so file from the api directory to your /usr/lib/ directory. Then via a command line, navigate to the /usr/lib/ directory and create a symbolic link between libfmod-3.75.so and libfmod.so. This is done with the following command (assuming you are in /usr/lib/)... ln -s libfmod-3.75.so libfmod.so.

============================================================================================

Uses

  • System.SysUtils
  • Winapi.Windows
  • FMX.Dialogs
  • FMOD.Types

Overview

Functions and Procedures

function FMOD_Load(LibName: PChar = nil): boolean;
procedure FMOD_Unload;

Variables

FSOUND_SetOutput: function(OutputType: TFSoundOutputTypes): bytebool; stdcall;
FSOUND_SetDriver: function(Driver: integer): bytebool; stdcall;
FSOUND_SetMixer: function(Mixer: TFSoundMixerTypes): bytebool; stdcall;
FSOUND_SetBufferSize: function(LenMs: integer): bytebool; stdcall;
FSOUND_SetHWND: function(Hwnd: THandle): bytebool; stdcall;
FSOUND_SetMinHardwareChannels: function(Min: integer): bytebool; stdcall;
FSOUND_SetMaxHardwareChannels: function(Max: integer): bytebool; stdcall;
FSOUND_SetMemorySystem: function(Pool: Pointer; PoolLen: integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): bytebool; stdcall;
FSOUND_Init: function(MixRate: integer; MaxSoftwareChannels: integer; Flags: cardinal): bytebool; stdcall;
FSOUND_Close: procedure; stdcall;
FSOUND_Update: procedure; stdcall;
FSOUND_SetSpeakerMode: procedure(SpeakerMode: cardinal); stdcall;
FSOUND_SetSFXMasterVolume: procedure(Volume: integer); stdcall;
FSOUND_SetPanSeperation: procedure(PanSep: single); stdcall;
FSOUND_File_SetCallbacks: procedure(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
FSOUND_GetError: function: TFModErrors; stdcall;
FSOUND_GetVersion: function: single; stdcall;
FSOUND_GetOutput: function: TFSoundOutputTypes; stdcall;
FSOUND_GetOutputHandle: function: Pointer; stdcall;
FSOUND_GetDriver: function: integer; stdcall;
FSOUND_GetMixer: function: TFSoundMixerTypes; stdcall;
FSOUND_GetNumDrivers: function: integer; stdcall;
FSOUND_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_GetDriverCaps: function(Id: integer; var Caps: cardinal): bytebool; stdcall;
FSOUND_GetOutputRate: function: integer; stdcall;
FSOUND_GetMaxChannels: function: integer; stdcall;
FSOUND_GetMaxSamples: function: integer; stdcall;
FSOUND_GetSpeakerMode: function: integer; stdcall;
FSOUND_GetSFXMasterVolume: function: integer; stdcall;
FSOUND_GetNumHWChannels: function(var Num2D: integer; var Num3D: integer; var Total: integer): bytebool; stdcall;
FSOUND_GetChannelsPlaying: function: integer; stdcall;
FSOUND_GetCPUUsage: function: single; stdcall;
FSOUND_GetMemoryStats: procedure(var CurrentAlloced: cardinal; var MaxAlloced: cardinal); stdcall;
FSOUND_Sample_Load: function(Index: integer; const NameOrData: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundSample; stdcall;
FSOUND_Sample_Alloc: function(Index: integer; Length: integer; Mode: cardinal; DefFreq: integer; DefVol: integer; DefPan: integer; DefPri: integer) : PFSoundSample; stdcall;
FSOUND_Sample_Free: procedure(Sptr: PFSoundSample); stdcall;
FSOUND_Sample_Upload: function(Sptr: PFSoundSample; SrcData: Pointer; Mode: cardinal): bytebool; stdcall;
FSOUND_Sample_Lock: function(Sptr: PFSoundSample; Offset: integer; Length: integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: cardinal; var Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_Unlock: function(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: cardinal; Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_SetMode: function(Sptr: PFSoundSample; Mode: cardinal) : bytebool; stdcall;
FSOUND_Sample_SetLoopPoints: function(Sptr: PFSoundSample; LoopStart, LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaults: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaultsEx: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: integer) : bytebool; stdcall;
FSOUND_Sample_SetMinMaxDistance: function(Sptr: PFSoundSample; Min, Max: single): bytebool; stdcall;
FSOUND_Sample_SetMaxPlaybacks: function(Sptr: PFSoundSample; Max: integer) : bytebool; stdcall;
FSOUND_Sample_Get: function(SampNo: integer): PFSoundSample; stdcall;
FSOUND_Sample_GetName: function(Sptr: PFSoundSample): PChar; stdcall;
FSOUND_Sample_GetLength: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetLoopPoints: function(Sptr: PFSoundSample; var LoopStart: integer; var LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaults: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaultsEx: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer; var VarFreq: integer; var VarVol: integer; var VarPan) : bytebool; stdcall;
FSOUND_Sample_GetMode: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetMinMaxDistance: function(Sptr: PFSoundSample; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_PlaySound: function(Channel: integer; Sptr: PFSoundSample): integer; stdcall;
FSOUND_PlaySoundEx: function(Channel: integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_StopSound: function(Channel: integer): bytebool; stdcall;
FSOUND_SetFrequency: function(Channel: integer; Freq: integer): bytebool; stdcall;
FSOUND_SetVolume: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetVolumeAbsolute: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetPan: function(Channel: integer; Pan: integer): bytebool; stdcall;
FSOUND_SetSurround: function(Channel: integer; Surround: bytebool): bytebool; stdcall;
FSOUND_SetMute: function(Channel: integer; Mute: bytebool): bytebool; stdcall;
FSOUND_SetPriority: function(Channel: integer; Priority: integer): bytebool; stdcall;
FSOUND_SetReserved: function(Channel: integer; Reserved: bytebool): bytebool; stdcall;
FSOUND_SetPaused: function(Channel: integer; Paused: bytebool): bytebool; stdcall;
FSOUND_SetLoopMode: function(Channel: integer; LoopMode: cardinal): bytebool; stdcall;
FSOUND_SetCurrentPosition: function(Channel: integer; Offset: cardinal) : bytebool; stdcall;
FSOUND_3D_SetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_SetMinMaxDistance: function(Channel: integer; Min: single; Max: single): bytebool; stdcall;
FSOUND_IsPlaying: function(Channel: integer): bytebool; stdcall;
FSOUND_GetFrequency: function(Channel: integer): integer; stdcall;
FSOUND_GetVolume: function(Channel: integer): integer; stdcall;
FSOUND_GetAmplitude: function(Channel: integer): integer; stdcall;
FSOUND_GetPan: function(Channel: integer): integer; stdcall;
FSOUND_GetSurround: function(Channel: integer): bytebool; stdcall;
FSOUND_GetMute: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPriority: function(Channel: integer): integer; stdcall;
FSOUND_GetReserved: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPaused: function(Channel: integer): bytebool; stdcall;
FSOUND_GetLoopMode: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentPosition: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentSample: function(Channel: integer): PFSoundSample; stdcall;
FSOUND_GetCurrentLevels: function(Channel: integer; L, R: PSingle): bytebool; stdcall;
FSOUND_GetNumSubChannels: function(Channel: integer): integer; stdcall;
FSOUND_GetSubChannel: function(Channel: integer; SubChannel: integer) : integer; stdcall;
FSOUND_3D_GetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_GetMinMaxDistance: function(Channel: integer; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_3D_Listener_SetCurrent: procedure(current: integer); stdcall;
FSOUND_3D_Listener_SetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: single; fy: single; fz: single; tx: single; ty: single; tz: single); stdcall;
FSOUND_3D_Listener_GetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
FSOUND_3D_SetDopplerFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetDistanceFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetRolloffFactor: procedure(Scale: single); stdcall;
FSOUND_FX_Enable: function(Channel: integer; fx: TFSoundFXModes): integer; stdcall;
FSOUND_FX_Disable: function(Channel: integer): bytebool; stdcall;
FSOUND_FX_SetChorus: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer) : bytebool; stdcall;
FSOUND_FX_SetCompressor: function(FXId: integer; Gain, Attack, Release, Threshold, Ratio, Predelay: single): bytebool; stdcall;
FSOUND_FX_SetDistortion: function(FXId: integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff : single): bytebool; stdcall;
FSOUND_FX_SetEcho: function(FXId: integer; WetDryMix, Feedback, LeftDelay, RightDelay: single; PanDelay: integer): bytebool; stdcall;
FSOUND_FX_SetFlanger: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;
FSOUND_FX_SetGargle: function(FXId, RateHz, WaveShape: integer): bytebool; stdcall;
FSOUND_FX_SetI3DL2Reverb: function(FXId, Room, RoomHF: integer; RoomRolloffFactor, DecayTime, DecayHFRatio: single; Reflections: integer; ReflectionsDelay: single; Reverb: integer; ReverbDelay, Diffusion, Density, HFReference: single): bytebool; stdcall;
FSOUND_FX_SetParamEQ: function(FXId: integer; Center, Bandwidth, Gain: single) : bytebool; stdcall;
FSOUND_FX_SetWavesReverb: function(FXId: integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: single): bytebool; stdcall;
FSOUND_Stream_SetBufferSize: function(Ms: integer): bytebool; stdcall;
FSOUND_Stream_Open: function(const name_or_data: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundStream; stdcall;
FSOUND_Stream_Create: function(Callback: TFSoundStreamCallback; Length: integer; Mode: cardinal; SampleRate: integer; UserData: integer) : PFSoundStream; stdcall;
FSOUND_Stream_Close: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_Play: function(Channel: integer; Stream: PFSoundStream) : integer; stdcall;
FSOUND_Stream_PlayEx: function(Channel: integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_Stream_Stop: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_SetPosition: function(Stream: PFSoundStream; Position: cardinal) : bytebool; stdcall;
FSOUND_Stream_GetPosition: function(Stream: PFSoundStream): cardinal; stdcall;
FSOUND_Stream_SetTime: function(Stream: PFSoundStream; Ms: integer): bytebool; stdcall;
FSOUND_Stream_GetTime: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLength: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLengthMs: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetMode: function(Stream: PFSoundStream; Mode: integer) : bytebool; stdcall;
FSOUND_Stream_GetMode: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetLoopPoints: function(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: integer): bytebool; stdcall;
FSOUND_Stream_SetLoopCount: function(Stream: PFSoundStream; Count: integer) : bytebool; stdcall;
FSOUND_Stream_GetOpenState: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSample: function(Stream: PFSoundStream): PFSoundSample; stdcall;
FSOUND_Stream_CreateDSP: function(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: integer; Param: integer) : PFSoundDSPUnit; stdcall;
FSOUND_Stream_SetEndCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_SetSyncCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_AddSyncPoint: function(Stream: PFSoundStream; PCMOffset: cardinal; Name: PChar): PFSyncPoint; stdcall;
FSOUND_Stream_DeleteSyncPoint: function(Point: PFSyncPoint): bytebool; stdcall;
FSOUND_Stream_GetNumSyncPoints: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSyncPoint: function(Stream: PFSoundStream; Index: integer) : PFSyncPoint; stdcall;
FSOUND_Stream_GetSyncPointInfo: function(Point: PFSyncPoint; var PCMOffset: cardinal): integer; stdcall;
FSOUND_Stream_SetSubStream: function(Stream: PFSoundStream; Index: integer) : bytebool; stdcall;
FSOUND_Stream_GetNumSubStreams: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetSubStreamSentence: function(Stream: PFSoundStream; var sentencelist: cardinal; numitems: integer): bytebool; stdcall;
FSOUND_Stream_GetNumTagFields: function(Stream: PFSoundStream; var Num: integer): bytebool; stdcall;
FSOUND_Stream_GetTagField: function(Stream: PFSoundStream; Num: integer; var _Type: TFSoundTagFieldType; var Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_FindTagField: function(Stream: PFSoundStream; _Type: TFSoundTagFieldType; Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetProxy: function(Proxy: PChar): bytebool; stdcall;
FSOUND_Stream_Net_GetLastServerStatus: function: PChar; stdcall;
FSOUND_Stream_Net_SetBufferProperties: function(BufferSize: integer; PreBuffer_Percent: integer; ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetBufferProperties: function(var BufferSize: integer; var PreBuffer_Percent: integer; var ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetMetadataCallback: function(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetStatus: function(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: integer; var BitRate: integer; var Flags: cardinal): bytebool; stdcall;
FSOUND_CD_Play: function(Drive: byte; Track: integer): bytebool; stdcall;
FSOUND_CD_SetPlayMode: procedure(Drive: byte; Mode: integer); stdcall;
FSOUND_CD_Stop: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_SetPaused: function(Drive: byte; Paused: bytebool): bytebool; stdcall;
FSOUND_CD_SetVolume: function(Drive: byte; Volume: integer): bytebool; stdcall;
FSOUND_CD_SetTrackTime: function(Drive: byte; Ms: integer): bytebool; stdcall;
FSOUND_CD_OpenTray: function(Drive: byte; Open: byte): bytebool; stdcall;
FSOUND_CD_GetPaused: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_GetTrack: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetNumTracks: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetVolume: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetTrackLength: function(Drive: byte; Track: integer): integer; stdcall;
FSOUND_CD_GetTrackTime: function(Drive: byte): integer; stdcall;
FSOUND_DSP_Create: function(Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;
FSOUND_DSP_Free: procedure(DSPUnit: PFSoundDSPUnit); stdcall;
FSOUND_DSP_SetPriority: procedure(DSPUnit: PFSoundDSPUnit; Priority: integer); stdcall;
FSOUND_DSP_GetPriority: function(DSPUnit: PFSoundDSPUnit): integer; stdcall;
FSOUND_DSP_SetActive: procedure(DSPUnit: PFSoundDSPUnit; Active: bytebool); stdcall;
FSOUND_DSP_GetActive: function(DSPUnit: PFSoundDSPUnit): bytebool; stdcall;
FSOUND_DSP_GetClearUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetSFXUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetMusicUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetClipAndCopyUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetFFTUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_MixBuffers: function(DestBuffer: Pointer; SrcBuffer: Pointer; Len: integer; Freq: integer; Vol: integer; Pan: integer; Mode: cardinal) : bytebool; stdcall;
FSOUND_DSP_ClearMixBuffer: procedure; stdcall;
FSOUND_DSP_GetBufferLength: function: integer; stdcall;
FSOUND_DSP_GetBufferLengthTotal: function: integer; stdcall;
FSOUND_DSP_GetSpectrum: function: PSingle; stdcall;
FSOUND_Reverb_SetProperties: function(const Prop: TFSoundReverbProperties) : bytebool; stdcall;
FSOUND_Reverb_GetProperties: function(var Prop: TFSoundReverbProperties) : bytebool; stdcall;
FSOUND_Reverb_SetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Reverb_GetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Record_SetDriver: function(OutputType: integer): bytebool; stdcall;
FSOUND_Record_GetNumDrivers: function: integer; stdcall;
FSOUND_Record_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_Record_GetDriver: function: integer; stdcall;
FSOUND_Record_StartSample: function(Sptr: PFSoundSample; Loop: bytebool) : bytebool; stdcall;
FSOUND_Record_Stop: function: bytebool; stdcall;
FSOUND_Record_GetPosition: function: integer; stdcall;
FMUSIC_LoadSong: function(const Name: PChar): PFMusicModule; stdcall;
FMUSIC_LoadSongEx: function(name_or_data: Pointer; Offset: integer; Length: integer; Mode: cardinal; var SampleList: integer; SampleListNum: integer): PFMusicModule; stdcall;
FMUSIC_GetOpenState: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_FreeSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_PlaySong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopAllSongs: procedure; stdcall;
FMUSIC_SetZxxCallback: function(Module: PFMusicModule; Callback: TFMusicCallback): bytebool; stdcall;
FMUSIC_SetRowCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: integer): bytebool; stdcall;
FMUSIC_SetOrderCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: integer): bytebool; stdcall;
FMUSIC_SetInstCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: integer): bytebool; stdcall;
FMUSIC_SetSample: function(Module: PFMusicModule; SampNo: integer; Sptr: PFSoundSample): bytebool; stdcall;
FMUSIC_SetUserData: function(Module: PFMusicModule; UserData: integer) : bytebool; stdcall;
FMUSIC_OptimizeChannels: function(Module: PFMusicModule; MaxChannels: integer; MinVolume: integer): bytebool; stdcall;
FMUSIC_SetReverb: function(Reverb: bytebool): bytebool; stdcall;
FMUSIC_SetLooping: function(Module: PFMusicModule; Looping: bytebool) : bytebool; stdcall;
FMUSIC_SetOrder: function(Module: PFMusicModule; Order: integer): bytebool; stdcall;
FMUSIC_SetPaused: function(Module: PFMusicModule; Pause: bytebool): bytebool; stdcall;
FMUSIC_SetMasterVolume: function(Module: PFMusicModule; Volume: integer) : bytebool; stdcall;
FMUSIC_SetMasterSpeed: function(Module: PFMusicModule; Speed: single) : bytebool; stdcall;
FMUSIC_SetPanSeperation: function(Module: PFMusicModule; PanSep: single) : bytebool; stdcall;
FMUSIC_GetName: function(Module: PFMusicModule): PChar; stdcall;
FMUSIC_GetType: function(Module: PFMusicModule): TFMusicTypes; stdcall;
FMUSIC_GetNumOrders: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumPatterns: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumInstruments: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumSamples: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumChannels: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSample: function(Module: PFMusicModule; SampNo: integer) : PFSoundSample; stdcall;
FMUSIC_GetPatternLength: function(Module: PFMusicModule; OrderNo: integer): integer; stdcall;
FMUSIC_IsFinished: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_IsPlaying: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetMasterVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetGlobalVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetOrder: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPattern: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSpeed: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetBPM: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRow: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPaused: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetTime: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRealChannel: function(Module: PFMusicModule; ModChannel: integer): integer; stdcall;
FMUSIC_GetUserData: function(Module: PFMusicModule): integer; stdcall;

Description

Functions and Procedures

function FMOD_Load(LibName: PChar = nil): boolean;

If no library name is passed to FMOD_Load, then the default library name used.

procedure FMOD_Unload;

This item has no description.

Variables

FSOUND_SetOutput: function(OutputType: TFSoundOutputTypes): bytebool; stdcall;

Pre FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.

FSOUND_SetDriver: function(Driver: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetMixer: function(Mixer: TFSoundMixerTypes): bytebool; stdcall;

This item has no description.

FSOUND_SetBufferSize: function(LenMs: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetHWND: function(Hwnd: THandle): bytebool; stdcall;

This item has no description.

FSOUND_SetMinHardwareChannels: function(Min: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetMaxHardwareChannels: function(Max: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetMemorySystem: function(Pool: Pointer; PoolLen: integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): bytebool; stdcall;

This item has no description.

FSOUND_Init: function(MixRate: integer; MaxSoftwareChannels: integer; Flags: cardinal): bytebool; stdcall;

Main initialization / closedown functions Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)

FSOUND_Close: procedure; stdcall;

This item has no description.

FSOUND_Update: procedure; stdcall;

Runtime system level functions

FSOUND_SetSpeakerMode: procedure(SpeakerMode: cardinal); stdcall;

This is called to update 3d sound / non-realtime output

FSOUND_SetSFXMasterVolume: procedure(Volume: integer); stdcall;

This item has no description.

FSOUND_SetPanSeperation: procedure(PanSep: single); stdcall;

This item has no description.

FSOUND_File_SetCallbacks: procedure(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;

This item has no description.

FSOUND_GetError: function: TFModErrors; stdcall;

System information functions

FSOUND_GetVersion: function: single; stdcall;

This item has no description.

FSOUND_GetOutput: function: TFSoundOutputTypes; stdcall;

This item has no description.

FSOUND_GetOutputHandle: function: Pointer; stdcall;

This item has no description.

FSOUND_GetDriver: function: integer; stdcall;

This item has no description.

FSOUND_GetMixer: function: TFSoundMixerTypes; stdcall;

This item has no description.

FSOUND_GetNumDrivers: function: integer; stdcall;

This item has no description.

FSOUND_GetDriverName: function(Id: integer): PChar; stdcall;

This item has no description.

FSOUND_GetDriverCaps: function(Id: integer; var Caps: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_GetOutputRate: function: integer; stdcall;

This item has no description.

FSOUND_GetMaxChannels: function: integer; stdcall;

This item has no description.

FSOUND_GetMaxSamples: function: integer; stdcall;

This item has no description.

FSOUND_GetSpeakerMode: function: integer; stdcall;

This item has no description.

FSOUND_GetSFXMasterVolume: function: integer; stdcall;

This item has no description.

FSOUND_GetNumHWChannels: function(var Num2D: integer; var Num3D: integer; var Total: integer): bytebool; stdcall;

This item has no description.

FSOUND_GetChannelsPlaying: function: integer; stdcall;

This item has no description.

FSOUND_GetCPUUsage: function: single; stdcall;

This item has no description.

FSOUND_GetMemoryStats: procedure(var CurrentAlloced: cardinal; var MaxAlloced: cardinal); stdcall;

This item has no description.

FSOUND_Sample_Load: function(Index: integer; const NameOrData: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundSample; stdcall;

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.

FSOUND_Sample_Alloc: function(Index: integer; Length: integer; Mode: cardinal; DefFreq: integer; DefVol: integer; DefPan: integer; DefPri: integer) : PFSoundSample; stdcall;

This item has no description.

FSOUND_Sample_Free: procedure(Sptr: PFSoundSample); stdcall;

This item has no description.

FSOUND_Sample_Upload: function(Sptr: PFSoundSample; SrcData: Pointer; Mode: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_Sample_Lock: function(Sptr: PFSoundSample; Offset: integer; Length: integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: cardinal; var Len2: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_Sample_Unlock: function(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: cardinal; Len2: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_Sample_SetMode: function(Sptr: PFSoundSample; Mode: cardinal) : bytebool; stdcall;

Sample control functions

FSOUND_Sample_SetLoopPoints: function(Sptr: PFSoundSample; LoopStart, LoopEnd: integer): bytebool; stdcall;

This item has no description.

FSOUND_Sample_SetDefaults: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: integer): bytebool; stdcall;

This item has no description.

FSOUND_Sample_SetDefaultsEx: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: integer) : bytebool; stdcall;

This item has no description.

FSOUND_Sample_SetMinMaxDistance: function(Sptr: PFSoundSample; Min, Max: single): bytebool; stdcall;

This item has no description.

FSOUND_Sample_SetMaxPlaybacks: function(Sptr: PFSoundSample; Max: integer) : bytebool; stdcall;

This item has no description.

FSOUND_Sample_Get: function(SampNo: integer): PFSoundSample; stdcall;

Sample information functions

FSOUND_Sample_GetName: function(Sptr: PFSoundSample): PChar; stdcall;

This item has no description.

FSOUND_Sample_GetLength: function(Sptr: PFSoundSample): cardinal; stdcall;

This item has no description.

FSOUND_Sample_GetLoopPoints: function(Sptr: PFSoundSample; var LoopStart: integer; var LoopEnd: integer): bytebool; stdcall;

This item has no description.

FSOUND_Sample_GetDefaults: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer): bytebool; stdcall;

This item has no description.

FSOUND_Sample_GetDefaultsEx: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer; var VarFreq: integer; var VarVol: integer; var VarPan) : bytebool; stdcall;

This item has no description.

FSOUND_Sample_GetMode: function(Sptr: PFSoundSample): cardinal; stdcall;

This item has no description.

FSOUND_Sample_GetMinMaxDistance: function(Sptr: PFSoundSample; var Min: single; var Max: single): bytebool; stdcall;

This item has no description.

FSOUND_PlaySound: function(Channel: integer; Sptr: PFSoundSample): integer; stdcall;

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!

FSOUND_PlaySoundEx: function(Channel: integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;

This item has no description.

FSOUND_StopSound: function(Channel: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetFrequency: function(Channel: integer; Freq: integer): bytebool; stdcall;

Functions to control playback of a channel.

FSOUND_SetVolume: function(Channel: integer; Vol: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetVolumeAbsolute: function(Channel: integer; Vol: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetPan: function(Channel: integer; Pan: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetSurround: function(Channel: integer; Surround: bytebool): bytebool; stdcall;

This item has no description.

FSOUND_SetMute: function(Channel: integer; Mute: bytebool): bytebool; stdcall;

This item has no description.

FSOUND_SetPriority: function(Channel: integer; Priority: integer): bytebool; stdcall;

This item has no description.

FSOUND_SetReserved: function(Channel: integer; Reserved: bytebool): bytebool; stdcall;

This item has no description.

FSOUND_SetPaused: function(Channel: integer; Paused: bytebool): bytebool; stdcall;

This item has no description.

FSOUND_SetLoopMode: function(Channel: integer; LoopMode: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_SetCurrentPosition: function(Channel: integer; Offset: cardinal) : bytebool; stdcall;

This item has no description.

FSOUND_3D_SetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;

This item has no description.

FSOUND_3D_SetMinMaxDistance: function(Channel: integer; Min: single; Max: single): bytebool; stdcall;

This item has no description.

FSOUND_IsPlaying: function(Channel: integer): bytebool; stdcall;

Channel information functions

FSOUND_GetFrequency: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetVolume: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetAmplitude: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetPan: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetSurround: function(Channel: integer): bytebool; stdcall;

This item has no description.

FSOUND_GetMute: function(Channel: integer): bytebool; stdcall;

This item has no description.

FSOUND_GetPriority: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetReserved: function(Channel: integer): bytebool; stdcall;

This item has no description.

FSOUND_GetPaused: function(Channel: integer): bytebool; stdcall;

This item has no description.

FSOUND_GetLoopMode: function(Channel: integer): cardinal; stdcall;

This item has no description.

FSOUND_GetCurrentPosition: function(Channel: integer): cardinal; stdcall;

This item has no description.

FSOUND_GetCurrentSample: function(Channel: integer): PFSoundSample; stdcall;

This item has no description.

FSOUND_GetCurrentLevels: function(Channel: integer; L, R: PSingle): bytebool; stdcall;

This item has no description.

FSOUND_GetNumSubChannels: function(Channel: integer): integer; stdcall;

This item has no description.

FSOUND_GetSubChannel: function(Channel: integer; SubChannel: integer) : integer; stdcall;

This item has no description.

FSOUND_3D_GetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;

This item has no description.

FSOUND_3D_GetMinMaxDistance: function(Channel: integer; var Min: single; var Max: single): bytebool; stdcall;

This item has no description.

FSOUND_3D_Listener_SetCurrent: procedure(current: integer); stdcall;

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.

FSOUND_3D_Listener_SetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: single; fy: single; fz: single; tx: single; ty: single; tz: single); stdcall;

This item has no description.

FSOUND_3D_Listener_GetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;

This item has no description.

FSOUND_3D_SetDopplerFactor: procedure(Scale: single); stdcall;

This item has no description.

FSOUND_3D_SetDistanceFactor: procedure(Scale: single); stdcall;

This item has no description.

FSOUND_3D_SetRolloffFactor: procedure(Scale: single); stdcall;

This item has no description.

FSOUND_FX_Enable: function(Channel: integer; fx: TFSoundFXModes): integer; stdcall;

Functions to control DX8 only effects processing.

- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - Stopping or starting a sound resets all FX and they must be re-enabled each time if this happens.

FSOUND_FX_Disable: function(Channel: integer): bytebool; stdcall;

Set bits to enable following fx

FSOUND_FX_SetChorus: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer) : bytebool; stdcall;

This item has no description.

FSOUND_FX_SetCompressor: function(FXId: integer; Gain, Attack, Release, Threshold, Ratio, Predelay: single): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetDistortion: function(FXId: integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff : single): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetEcho: function(FXId: integer; WetDryMix, Feedback, LeftDelay, RightDelay: single; PanDelay: integer): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetFlanger: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetGargle: function(FXId, RateHz, WaveShape: integer): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetI3DL2Reverb: function(FXId, Room, RoomHF: integer; RoomRolloffFactor, DecayTime, DecayHFRatio: single; Reflections: integer; ReflectionsDelay: single; Reverb: integer; ReverbDelay, Diffusion, Density, HFReference: single): bytebool; stdcall;

This item has no description.

FSOUND_FX_SetParamEQ: function(FXId: integer; Center, Bandwidth, Gain: single) : bytebool; stdcall;

This item has no description.

FSOUND_FX_SetWavesReverb: function(FXId: integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: single): bytebool; stdcall;

This item has no description.

FSOUND_Stream_SetBufferSize: function(Ms: integer): bytebool; stdcall;

call this before opening streams, not after

FSOUND_Stream_Open: function(const name_or_data: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundStream; stdcall;

This item has no description.

FSOUND_Stream_Create: function(Callback: TFSoundStreamCallback; Length: integer; Mode: cardinal; SampleRate: integer; UserData: integer) : PFSoundStream; stdcall;

This item has no description.

FSOUND_Stream_Close: function(Stream: PFSoundStream): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Play: function(Channel: integer; Stream: PFSoundStream) : integer; stdcall;

This item has no description.

FSOUND_Stream_PlayEx: function(Channel: integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;

This item has no description.

FSOUND_Stream_Stop: function(Stream: PFSoundStream): bytebool; stdcall;

This item has no description.

FSOUND_Stream_SetPosition: function(Stream: PFSoundStream; Position: cardinal) : bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetPosition: function(Stream: PFSoundStream): cardinal; stdcall;

This item has no description.

FSOUND_Stream_SetTime: function(Stream: PFSoundStream; Ms: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetTime: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_GetLength: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_GetLengthMs: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_SetMode: function(Stream: PFSoundStream; Mode: integer) : bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetMode: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_SetLoopPoints: function(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_SetLoopCount: function(Stream: PFSoundStream; Count: integer) : bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetOpenState: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_GetSample: function(Stream: PFSoundStream): PFSoundSample; stdcall;

This item has no description.

FSOUND_Stream_CreateDSP: function(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: integer; Param: integer) : PFSoundDSPUnit; stdcall;

Every stream contains a sample to play back on

FSOUND_Stream_SetEndCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_SetSyncCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_AddSyncPoint: function(Stream: PFSoundStream; PCMOffset: cardinal; Name: PChar): PFSyncPoint; stdcall;

This item has no description.

FSOUND_Stream_DeleteSyncPoint: function(Point: PFSyncPoint): bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetNumSyncPoints: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_GetSyncPoint: function(Stream: PFSoundStream; Index: integer) : PFSyncPoint; stdcall;

This item has no description.

FSOUND_Stream_GetSyncPointInfo: function(Point: PFSyncPoint; var PCMOffset: cardinal): integer; stdcall;

This item has no description.

FSOUND_Stream_SetSubStream: function(Stream: PFSoundStream; Index: integer) : bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetNumSubStreams: function(Stream: PFSoundStream): integer; stdcall;

This item has no description.

FSOUND_Stream_SetSubStreamSentence: function(Stream: PFSoundStream; var sentencelist: cardinal; numitems: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetNumTagFields: function(Stream: PFSoundStream; var Num: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_GetTagField: function(Stream: PFSoundStream; Num: integer; var _Type: TFSoundTagFieldType; var Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_FindTagField: function(Stream: PFSoundStream; _Type: TFSoundTagFieldType; Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Net_SetProxy: function(Proxy: PChar): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Net_GetLastServerStatus: function: PChar; stdcall;

This item has no description.

FSOUND_Stream_Net_SetBufferProperties: function(BufferSize: integer; PreBuffer_Percent: integer; ReBuffer_Percent: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Net_GetBufferProperties: function(var BufferSize: integer; var PreBuffer_Percent: integer; var ReBuffer_Percent: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Net_SetMetadataCallback: function(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: integer): bytebool; stdcall;

This item has no description.

FSOUND_Stream_Net_GetStatus: function(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: integer; var BitRate: integer; var Flags: cardinal): bytebool; stdcall;

This item has no description.

FSOUND_CD_Play: function(Drive: byte; Track: integer): bytebool; stdcall;

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.

FSOUND_CD_SetPlayMode: procedure(Drive: byte; Mode: integer); stdcall;

This item has no description.

FSOUND_CD_Stop: function(Drive: byte): bytebool; stdcall;

This item has no description.

FSOUND_CD_SetPaused: function(Drive: byte; Paused: bytebool): bytebool; stdcall;

This item has no description.

FSOUND_CD_SetVolume: function(Drive: byte; Volume: integer): bytebool; stdcall;

This item has no description.

FSOUND_CD_SetTrackTime: function(Drive: byte; Ms: integer): bytebool; stdcall;

This item has no description.

FSOUND_CD_OpenTray: function(Drive: byte; Open: byte): bytebool; stdcall;

This item has no description.

FSOUND_CD_GetPaused: function(Drive: byte): bytebool; stdcall;

This item has no description.

FSOUND_CD_GetTrack: function(Drive: byte): integer; stdcall;

This item has no description.

FSOUND_CD_GetNumTracks: function(Drive: byte): integer; stdcall;

This item has no description.

FSOUND_CD_GetVolume: function(Drive: byte): integer; stdcall;

This item has no description.

FSOUND_CD_GetTrackLength: function(Drive: byte; Track: integer): integer; stdcall;

This item has no description.

FSOUND_CD_GetTrackTime: function(Drive: byte): integer; stdcall;

This item has no description.

FSOUND_DSP_Create: function(Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;

DSP Unit control and information functions.

FSOUND_DSP_Free: procedure(DSPUnit: PFSoundDSPUnit); stdcall;

This item has no description.

FSOUND_DSP_SetPriority: procedure(DSPUnit: PFSoundDSPUnit; Priority: integer); stdcall;

This item has no description.

FSOUND_DSP_GetPriority: function(DSPUnit: PFSoundDSPUnit): integer; stdcall;

This item has no description.

FSOUND_DSP_SetActive: procedure(DSPUnit: PFSoundDSPUnit; Active: bytebool); stdcall;

This item has no description.

FSOUND_DSP_GetActive: function(DSPUnit: PFSoundDSPUnit): bytebool; stdcall;

This item has no description.

FSOUND_DSP_GetClearUnit: function: PFSoundDSPUnit; stdcall;

Functions to get hold of FSOUND 'system DSP unit' handles.

FSOUND_DSP_GetSFXUnit: function: PFSoundDSPUnit; stdcall;

This item has no description.

FSOUND_DSP_GetMusicUnit: function: PFSoundDSPUnit; stdcall;

This item has no description.

FSOUND_DSP_GetClipAndCopyUnit: function: PFSoundDSPUnit; stdcall;

This item has no description.

FSOUND_DSP_GetFFTUnit: function: PFSoundDSPUnit; stdcall;

This item has no description.

FSOUND_DSP_MixBuffers: function(DestBuffer: Pointer; SrcBuffer: Pointer; Len: integer; Freq: integer; Vol: integer; Pan: integer; Mode: cardinal) : bytebool; stdcall;

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.

FSOUND_DSP_ClearMixBuffer: procedure; stdcall;

This item has no description.

FSOUND_DSP_GetBufferLength: function: integer; stdcall;

This item has no description.

FSOUND_DSP_GetBufferLengthTotal: function: integer; stdcall;

Length of each DSP update

FSOUND_DSP_GetSpectrum: function: PSingle; stdcall;

Total buffer length due to FSOUND_SetBufferSize

FSOUND_Reverb_SetProperties: function(const Prop: TFSoundReverbProperties) : bytebool; stdcall;

See structures above for definitions and information on the reverb parameters.

FSOUND_Reverb_GetProperties: function(var Prop: TFSoundReverbProperties) : bytebool; stdcall;

This item has no description.

FSOUND_Reverb_SetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;

This item has no description.

FSOUND_Reverb_GetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;

This item has no description.

FSOUND_Record_SetDriver: function(OutputType: integer): bytebool; stdcall;

Recording initialization functions

FSOUND_Record_GetNumDrivers: function: integer; stdcall;

This item has no description.

FSOUND_Record_GetDriverName: function(Id: integer): PChar; stdcall;

This item has no description.

FSOUND_Record_GetDriver: function: integer; stdcall;

This item has no description.

FSOUND_Record_StartSample: function(Sptr: PFSoundSample; Loop: bytebool) : bytebool; stdcall;

Recording functionality. Only one recording session will work at a time.

FSOUND_Record_Stop: function: bytebool; stdcall;

This item has no description.

FSOUND_Record_GetPosition: function: integer; stdcall;

This item has no description.

FMUSIC_LoadSong: function(const Name: PChar): PFMusicModule; stdcall;

Song management / playback functions.

FMUSIC_LoadSongEx: function(name_or_data: Pointer; Offset: integer; Length: integer; Mode: cardinal; var SampleList: integer; SampleListNum: integer): PFMusicModule; stdcall;

This item has no description.

FMUSIC_GetOpenState: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_FreeSong: function(Module: PFMusicModule): bytebool; stdcall;

This item has no description.

FMUSIC_PlaySong: function(Module: PFMusicModule): bytebool; stdcall;

This item has no description.

FMUSIC_StopSong: function(Module: PFMusicModule): bytebool; stdcall;

This item has no description.

FMUSIC_StopAllSongs: procedure; stdcall;

This item has no description.

FMUSIC_SetZxxCallback: function(Module: PFMusicModule; Callback: TFMusicCallback): bytebool; stdcall;

This item has no description.

FMUSIC_SetRowCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: integer): bytebool; stdcall;

This item has no description.

FMUSIC_SetOrderCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: integer): bytebool; stdcall;

This item has no description.

FMUSIC_SetInstCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: integer): bytebool; stdcall;

This item has no description.

FMUSIC_SetSample: function(Module: PFMusicModule; SampNo: integer; Sptr: PFSoundSample): bytebool; stdcall;

This item has no description.

FMUSIC_SetUserData: function(Module: PFMusicModule; UserData: integer) : bytebool; stdcall;

This item has no description.

FMUSIC_OptimizeChannels: function(Module: PFMusicModule; MaxChannels: integer; MinVolume: integer): bytebool; stdcall;

This item has no description.

FMUSIC_SetReverb: function(Reverb: bytebool): bytebool; stdcall;

Runtime song functions.

FMUSIC_SetLooping: function(Module: PFMusicModule; Looping: bytebool) : bytebool; stdcall;

This item has no description.

FMUSIC_SetOrder: function(Module: PFMusicModule; Order: integer): bytebool; stdcall;

This item has no description.

FMUSIC_SetPaused: function(Module: PFMusicModule; Pause: bytebool): bytebool; stdcall;

This item has no description.

FMUSIC_SetMasterVolume: function(Module: PFMusicModule; Volume: integer) : bytebool; stdcall;

This item has no description.

FMUSIC_SetMasterSpeed: function(Module: PFMusicModule; Speed: single) : bytebool; stdcall;

This item has no description.

FMUSIC_SetPanSeperation: function(Module: PFMusicModule; PanSep: single) : bytebool; stdcall;

This item has no description.

FMUSIC_GetName: function(Module: PFMusicModule): PChar; stdcall;

Static song information functions.

FMUSIC_GetType: function(Module: PFMusicModule): TFMusicTypes; stdcall;

This item has no description.

FMUSIC_GetNumOrders: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetNumPatterns: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetNumInstruments: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetNumSamples: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetNumChannels: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetSample: function(Module: PFMusicModule; SampNo: integer) : PFSoundSample; stdcall;

This item has no description.

FMUSIC_GetPatternLength: function(Module: PFMusicModule; OrderNo: integer): integer; stdcall;

This item has no description.

FMUSIC_IsFinished: function(Module: PFMusicModule): bytebool; stdcall;

Runtime song information.

FMUSIC_IsPlaying: function(Module: PFMusicModule): bytebool; stdcall;

This item has no description.

FMUSIC_GetMasterVolume: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetGlobalVolume: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetOrder: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetPattern: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetSpeed: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetBPM: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetRow: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetPaused: function(Module: PFMusicModule): bytebool; stdcall;

This item has no description.

FMUSIC_GetTime: function(Module: PFMusicModule): integer; stdcall;

This item has no description.

FMUSIC_GetRealChannel: function(Module: PFMusicModule; ModChannel: integer): integer; stdcall;

This item has no description.

FMUSIC_GetUserData: function(Module: PFMusicModule): integer; stdcall;


GXSysHelp v.2.5: GXS.Sounds.OpenAL

Unit GXS.Sounds.OpenAL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics rendering engine GLScene http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • FMX.Forms
  • FMX.Dialogs
  • OpenAL.Import
  • GLScene.VectorTypes
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Coordinates
  • GXS.SoundManager
  • GXS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSMOpenAL |

Types

EOpenALError = Exception;

Description

Types

EOpenALError = Exception;


GXSysHelp v.2.5: GXS.Sounds.OpenAL: Class TgxSMOpenAL

Class TgxSMOpenAL

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Sounds.OpenAL

Declaration

type TgxSMOpenAL = class(TgxSoundManager)

Description

al, alut, alTypes

Hierarchy

  • TgxCadenceAbleComponent
  • TgxSoundManager
  • TgxSMOpenAL

Overview

Fields

Private FActivated: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function EAXSupported: Boolean; override;
Public | procedure UpdateSources; override;

Description

Fields

Private FActivated: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function EAXSupported: Boolean; override;

This item has no description. Showing description inherited from TgxSoundManager.EAXSupported.

True if EAX is supported.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TgxSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.


GXSysHelp v.2.5: GXS.Sounds.Register

Unit GXS.Sounds.Register

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Sounds.BASS
  • GXS.Sounds.FMOD
  • GXS.Sounds.OpenAL
  • GXS.Sounds.WaveOut

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: GXS.Sounds.WaveOut

Unit GXS.Sounds.WaveOut

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

Basic sound manager based on WinMM

Uses

  • Winapi.MMSystem
  • System.Classes
  • System.SysUtils
  • GXS.SoundManager
  • GXS.SoundFileObjects

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSMWaveOut |

Functions and Procedures

procedure PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; sampling: TgxSoundSampling); overload;
function PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; waveFormat: TWaveFormatEx) : HWaveOut; overload;

Description

Functions and Procedures

procedure PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; sampling: TgxSoundSampling); overload;

This item has no description.

function PlayOnWaveOut(pcmData: Pointer; lengthInBytes: Integer; waveFormat: TWaveFormatEx) : HWaveOut; overload;


GXSysHelp v.2.5: GXS.Sounds.WaveOut: Class TgxSMWaveOut

Class TgxSMWaveOut

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Sounds.WaveOut

Declaration

type TgxSMWaveOut = class(TgxSoundManager)

Description

Basic sound manager based on WinMM WaveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

Hierarchy

  • TgxCadenceAbleComponent
  • TgxSoundManager
  • TgxSMWaveOut

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure UpdateSources; override;

Properties

Published property MaxChannels default 4;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure UpdateSources; override;

This item has no description. Showing description inherited from TgxSoundManager.UpdateSources.

Manual request to update all sources to reflect changes. Default implementation invokes UpdateSource for all known sources.

Properties

Published property MaxChannels default 4;

This item has no description. Showing description inherited from TgxSoundManager.MaxChannels.

Maximum number of sound output channels. While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).


GXSysHelp v.2.5: GXS.SpacePartition

Unit GXS.SpacePartition

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.GeometryBB
  • GXS.PersistentClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TSPCone |
Record TExtendedFrustum |
Class TSpacePartitionLeaf |
Class TSpacePartitionLeafList |
Class TBaseSpacePartition |
Class TLeavedSpacePartition |
Class TSectorNode |
Class TSectoredSpacePartition |
Class TSPOctreeNode |
Class TOctreeSpacePartition |
Class TSPQuadtreeNode |
Class TQuadtreeSpacePartition |

Functions and Procedures

function ConeContainsBSphere(const Cone: TSPCone; BSphere: TBSphere) : TSpaceContains;
function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum : TExtendedFrustum; ABSphere: TBSphere): Boolean;
function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TExtendedFrustum;

Types

TCullingMode = (...);
TGrowMethod = (...);
TSectorNodeArray = array [0 .. 7] of TSectorNode;

Constants

COctree_LEAF_TRHESHOLD = 30;
COctree_MAX_TREE_DEPTH = 8;
COctree_GROW_GRAVY = 0.1;

Description

Functions and Procedures

function ConeContainsBSphere(const Cone: TSPCone; BSphere: TBSphere) : TSpaceContains;

Determines to which extent one Cone contains an BSphere

function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum : TExtendedFrustum; ABSphere: TBSphere): Boolean;

Determines if a extended frustum intersects an BSphere

function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TExtendedFrustum;

Create an extended frustum from a number of values

Types

TCullingMode = (...);

This item has no description.

Values
  • CmFineCulling
  • CmGrossCulling
TGrowMethod = (...);

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees

Values
  • gmNever
  • gmBestFit
  • gmIncreaseToFitAll
TSectorNodeArray = array [0 .. 7] of TSectorNode;

This item has no description.

Constants

COctree_LEAF_TRHESHOLD = 30;

This item has no description.

COctree_MAX_TREE_DEPTH = 8;

This item has no description.

COctree_GROW_GRAVY = 0.1;


GXSysHelp v.2.5: GXS.SpacePartition: Record TSPCone

Record TSPCone

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSPCone = record

Description

Describes a cone, and is used for cone collision

Overview

Fields

Public | Base: TAffineVector;
Public | Axis: TAffineVector;
Public | Angle: Single;
Public | Length: Single;

Description

Fields

Public Base: TAffineVector;

The base of the cone

Public Axis: TAffineVector;

The axis of the cone

Public Angle: Single;

Angle of the cone

Public Length: Single;

Length of the cone


GXSysHelp v.2.5: GXS.SpacePartition: Record TExtendedFrustum

Record TExtendedFrustum

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TExtendedFrustum = record

Description

Extended frustum, used for fast intersection testing

Overview

Fields

Public | Frustum: TFrustum;
Public | BSphere: TBSphere;

Description

Fields

Public Frustum: TFrustum;

This item has no description.

Public BSphere: TBSphere;


GXSysHelp v.2.5: GXS.SpacePartition: Class TSpacePartitionLeaf

Class TSpacePartitionLeaf

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSpacePartitionLeaf = class(TgxPersistentObject)

Description

Used to store the actual objects in the SpacePartition

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf

Overview

Fields

Private | FSpacePartition: TBaseSpacePartition;
Public | FPartitionTag: Pointer;
Public | FCachedAABB: TAABB;
Public | FCachedBSphere: TBSphere;

Methods

Public | constructor CreateOwned(SpacePartition: TBaseSpacePartition);
Public | destructor Destroy; override;
Public | procedure Changed; virtual;
Public | procedure UpdateCachedAABBAndBSphere; virtual;
Private | procedure SetSpacePartition(const Value: TBaseSpacePartition);

Properties

Public | property PartitionTag: Pointer read FPartitionTag;
Public | property SpacePartition: TBaseSpacePartition read FSpacePartition write SetSpacePartition;

Description

Fields

Private FSpacePartition: TBaseSpacePartition;

This item has no description.

Public FPartitionTag: Pointer;

This can be used by the space partitioner as it sees fit

Public FCachedAABB: TAABB;

Leaves cache their AABBs so they can easily be accessed when needed by the space partitioner

Public FCachedBSphere: TBSphere;

Leaves cache their BoundingSpheres so they can easily be accessed when needed by the space partitioner

Methods

Public constructor CreateOwned(SpacePartition: TBaseSpacePartition);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Changed; virtual;

Whenever the size or location of the leaf changes, the space partitioner should be notified through a call to Changed. In the basic version, all it does is update the cached AABB and BSphere. You do not need to override this method.

Public procedure UpdateCachedAABBAndBSphere; virtual;

AABBs and BSpheres are cached for leafs, and this function should be overriden to update the cache from the structure that the leaf stores. This is the only function you MUST override to use space partitions.

Private procedure SetSpacePartition(const Value: TBaseSpacePartition);

This item has no description.

Properties

Public property PartitionTag: Pointer read FPartitionTag;

This tag can be used by the space partition to store vital information in the leaf

Public property SpacePartition: TBaseSpacePartition read FSpacePartition write SetSpacePartition;

The TBaseSpacePartition that owns this leaf


GXSysHelp v.2.5: GXS.SpacePartition: Class TSpacePartitionLeafList

Class TSpacePartitionLeafList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSpacePartitionLeafList = class(TgxPersistentObjectList)

Description

List for storing space partition leaves

Hierarchy

  • TgxPersistentObjectList
  • TSpacePartitionLeafList

Overview

Methods

Public | constructor Create; override;
Private | function GetItems(I: Integer): TSpacePartitionLeaf;
Private | procedure SetItems(I: Integer; const Value: TSpacePartitionLeaf);

Properties

Public property Items[I: Integer]: TSpacePartitionLeaf read GetItems write SetItems;

Description

Methods

Public constructor Create; override;

This item has no description.

Private function GetItems(I: Integer): TSpacePartitionLeaf;

This item has no description.

Private procedure SetItems(I: Integer; const Value: TSpacePartitionLeaf);

This item has no description.

Properties

Public property Items[I: Integer]: TSpacePartitionLeaf read GetItems write SetItems;


GXSysHelp v.2.5: GXS.SpacePartition: Class TBaseSpacePartition

Class TBaseSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TBaseSpacePartition = class(TgxPersistentObject)

Description

Basic space partition, does not implement any actual space partitioning

Hierarchy

  • TgxPersistentObject
  • TBaseSpacePartition

Overview

Fields

Private FCullingMode: TCullingMode;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; virtual;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; virtual;
Public | function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; virtual;
Public | function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; virtual;
Public | function QueryPlane(const Location, Normal: TAffineVector) : Integer; virtual;
Private | function QueryCone(const ACone: TSPCone): Integer; virtual;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); virtual;
Public | procedure Clear; virtual;
Public | procedure LeafChanged(ALeaf: TSpacePartitionLeaf); virtual;
Public | procedure ProcessUpdated; virtual;
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); virtual;

Properties

Public | property CullingMode: TCullingMode read FCullingMode write FCullingMode;
Public | property QueryInterObjectTests: Integer read FQueryInterObjectTests;
Public | property QueryResult: TSpacePartitionLeafList read FQueryResult;

Description

Fields

Private FCullingMode: TCullingMode;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function QueryAABB(const AAABB: TAABB): Integer; virtual;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult

Public function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult

Public function QueryFrustum(const Frustum: TFrustum): Integer; virtual;

Query space for Leaves that intersect a Frustum. Result is returned through QueryResult

Public function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; virtual;

Query space for Leaves that intersect an extended frustum. Result is returned through QueryResult. Extended frustum is slightly faster than the regular frustum because it uses a bounding sphere for the frustum

Public function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; virtual;

Query space for Leaves that intersect the bounding sphere or box of a leaf. Result is returned through QueryResult

Public function QueryPlane(const Location, Normal: TAffineVector) : Integer; virtual;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Private function QueryCone(const ACone: TSPCone): Integer; virtual;

Query space for Leaves that intersect a cone, result is returned in QueryResult

Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); virtual;

Add a leaf

Public procedure Clear; virtual;

Clear all internal storage Leaves

Public procedure LeafChanged(ALeaf: TSpacePartitionLeaf); virtual;

Called by leaf when it has changed

Public procedure ProcessUpdated; virtual;

Some space partitioners delay processing changes until all changes have been made. ProcessUpdated should be called when all changes have been performed.

Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); virtual;

Remove a leaf

Properties

Public property CullingMode: TCullingMode read FCullingMode write FCullingMode;

Determines if the spatial structure should do very simple preliminary culling (gross culling) or a more detailed form of culling (fine culling)

Public property QueryInterObjectTests: Integer read FQueryInterObjectTests;

Once a query has been run, this number tells of how many inter object tests that were run. This value must be set by all that override the queries.

Public property QueryResult: TSpacePartitionLeafList read FQueryResult;

The results from the last query


GXSysHelp v.2.5: GXS.SpacePartition: Class TLeavedSpacePartition

Class TLeavedSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TLeavedSpacePartition = class(TBaseSpacePartition)

Description

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods

Hierarchy

  • TgxPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition

Overview

Fields

Private FLeaves: TSpacePartitionLeafList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryPlane(const FLocation, FNormal: TAffineVector) : Integer; override;
Private | function QueryCone(const ACone: TSPCone): Integer; override;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;

Properties

Published property Leaves: TSpacePartitionLeafList read FLeaves;

Description

Fields

Private FLeaves: TSpacePartitionLeafList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function QueryAABB(const AAABB: TAABB): Integer; override;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult. This override scans _all_ leaves in the list, so it's far from optimal.

Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult. This override scans _all_ leaves in the list, so it's far from optimal.

Public function QueryPlane(const FLocation, FNormal: TAffineVector) : Integer; override;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Private function QueryCone(const ACone: TSPCone): Integer; override;

Query space for Leaves that intersect a cone, result is returned through QueryResult

Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;

Add a leaf

Public procedure Clear; override;

Clear all internal storage Leaves

Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;

Remove a leaf

Properties

Published property Leaves: TSpacePartitionLeafList read FLeaves;


GXSysHelp v.2.5: GXS.SpacePartition: Class TSectorNode

Class TSectorNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSectorNode = class(TObject)

Description

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8

Hierarchy

  • TObject
  • TSectorNode

Overview

Fields

Private | FLeaves: TSpacePartitionLeafList;
Private | FAABB: TAABB;
Private | FSectoredSpacePartition: TSectoredSpacePartition;
Private | FRecursiveLeafCount: Integer;
Private | FParent: TSectorNode;
Private | FNodeDepth: Integer;
Private | FChildCount: Integer;
Private | FChildren: TSectorNodeArray;
Private | FBSphere: TBSphere;

Methods

Public | constructor Create(ASectoredSpacePartition: TSectoredSpacePartition; AParent: TSectorNode);
Public | destructor Destroy; override;
Public | function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;
Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;
Public | function AddLeaf(ALeaf: TSpacePartitionLeaf): TSectorNode;
Public | function BSphereContainsSector(const BSphere: TBSphere) : TSpaceContains; virtual;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;
Public | function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;
Public | function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;
Public | function GetChildForAABB(AABB: TAABB): TSectorNode; virtual;
Public | function GetNodeCount: Integer;
Public | function RemoveLeaf(ALeaf: TSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;
Private | function GetCenter: TAffineVector;
Private | function GetNoChildren: Boolean;
Public | procedure AddAllLeavesRecursive(const QueryResult: TSpacePartitionLeafList);
Public | procedure Clear;
Public | procedure CollapseNode;
Public | procedure CreateChildren; virtual;
Public | procedure ExpandNode;
Public | procedure QueryAABB(const AAABB: TAABB; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TSpacePartitionLeafList);
Private | procedure SetAABB(const Value: TAABB);

Properties

Public | property AABB: TAABB read FAABB write SetAABB;
Public | property BSphere: TBSphere read FBSphere;
Public | property Center: TAffineVector read GetCenter;
Public | property ChildCount: Integer read FChildCount;
Public | property Children: TSectorNodeArray read FChildren;
Public | property Leaves: TSpacePartitionLeafList read FLeaves;
Public | property NoChildren: Boolean read GetNoChildren;
Public | property NodeDepth: Integer read FNodeDepth;
Public | property Parent: TSectorNode read FParent;
Public | property RecursiveLeafCount: Integer read FRecursiveLeafCount;
Public | property SectoredSpacePartition: TSectoredSpacePartition read FSectoredSpacePartition;

Description

Fields

Private FLeaves: TSpacePartitionLeafList;

This item has no description.

Private FAABB: TAABB;

This item has no description.

Private FSectoredSpacePartition: TSectoredSpacePartition;

This item has no description.

Private FRecursiveLeafCount: Integer;

This item has no description.

Private FParent: TSectorNode;

This item has no description.

Private FNodeDepth: Integer;

This item has no description.

Private FChildCount: Integer;

This item has no description.

Private FChildren: TSectorNodeArray;

This item has no description.

Private FBSphere: TBSphere;

This item has no description.

Methods

Public constructor Create(ASectoredSpacePartition: TSectoredSpacePartition; AParent: TSectorNode);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;

Checks if a AABB partially or completely contains this sector

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;

Checks if an AABB intersects this node

Public function AddLeaf(ALeaf: TSpacePartitionLeaf): TSectorNode;

Adds leaf to this node - or one of it's children. If the node has enough leaves and has no children, children will be created and all leaves will be spread among the children.

Public function BSphereContainsSector(const BSphere: TBSphere) : TSpaceContains; virtual;

Checks if a BSphere partially or completely contains this sector

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;

Checks if a BSphere intersects this node

Public function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;

Checks if this node partially or completely contains an AABB

Public function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;

Checks if this node partially or completely contains a BSphere

Public function GetChildForAABB(AABB: TAABB): TSectorNode; virtual;

Computes which child the AABB should go in. Returns nil if no such child exists

Public function GetNodeCount: Integer;

Returns the number of nodes in the Octree

Public function RemoveLeaf(ALeaf: TSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;

Remove leaf will remove a leaf from this node. If it is determined that this node has too few leaves after the delete, it may be collapsed. Returns true if the node was actually collapsed

Private function GetCenter: TAffineVector;

This item has no description.

Private function GetNoChildren: Boolean;

This item has no description.

Public procedure AddAllLeavesRecursive(const QueryResult: TSpacePartitionLeafList);

Adds all leaves to query result without testing if they intersect, and then do the same for all children. This is used when QueryAABB or QueryBSphere determines that a node fits completely in the searched space

Public procedure Clear;

Clear deletes all children and empties the leaves. It doesn't destroy the leaves, as they belong to the SpacePartition

Public procedure CollapseNode;

Delete all children for this node, adding their leaves to this node

Public procedure CreateChildren; virtual;

Create the number of children this node type needs

Public procedure ExpandNode;

Add children to this node and spread the leaves among it's children

Public procedure QueryAABB(const AAABB: TAABB; const QueryResult: TSpacePartitionLeafList);

Query the node and its children for leaves that match the AABB

Public procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TSpacePartitionLeafList);

Query the node and its children for leaves that match the BSphere

Public procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TSpacePartitionLeafList);

Query the node and its children for leaves that match the frustum.

Public procedure QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum; const QueryResult: TSpacePartitionLeafList);

Query the node and its children for leaves that match the extended frustum.

Public procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TSpacePartitionLeafList);

Query the node and its children for leaves that match the plane

Private procedure SetAABB(const Value: TAABB);

This item has no description.

Properties

Public property AABB: TAABB read FAABB write SetAABB;

The Axis Aligned Bounding Box for this node. All leaves MUST fit inside this box.

Public property BSphere: TBSphere read FBSphere;

BSphere for this node

Public property Center: TAffineVector read GetCenter;

Center of the AABB for this node.

Public property ChildCount: Integer read FChildCount;

The number of child sectors that have been created

Public property Children: TSectorNodeArray read FChildren;

A list of the children for this node, only ChildCount children are none nil

Public property Leaves: TSpacePartitionLeafList read FLeaves;

The leaves that are stored in this node

Public property NoChildren: Boolean read GetNoChildren;

NoChildren is true if the node has no children.

Public property NodeDepth: Integer read FNodeDepth;

The tree depth at which this node is located. For the root, this value is 0, for the roots children, it is 1 and so on

Public property Parent: TSectorNode read FParent;

The parent node of this node. If parent is nil, that means that this node is the root node

Public property RecursiveLeafCount: Integer read FRecursiveLeafCount;

The number of leaves stored in this node and all it's children.

Public property SectoredSpacePartition: TSectoredSpacePartition read FSectoredSpacePartition;

The Structure that owns this node


GXSysHelp v.2.5: GXS.SpacePartition: Class TSectoredSpacePartition

Class TSectoredSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSectoredSpacePartition = class(TLeavedSpacePartition)

Description

This item has no description. Showing description inherited from TLeavedSpacePartition.

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods

Hierarchy

  • TgxPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition

Overview

Fields

Private | FRootNode: TSectorNode;
Private | FLeafThreshold: Integer;
Private | FMaxTreeDepth: Integer;
Private | FGrowGravy: Single;
Private | FGrowMethod: TGrowMethod;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; virtual;
Public | function GetAABB: TAABB;
Public | function GetNodeCount: Integer;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; override;
Public | function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; override;
Public | function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; override;
Public | function QueryPlane(const Location, Normal: TAffineVector) : Integer; override;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure LeafChanged(ALeaf: TSpacePartitionLeaf); override;
Public | procedure RebuildTree(const NewAABB: TAABB);
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure UpdateStructureSize(Gravy: Single);
Private | procedure SetLeafThreshold(const Value: Integer);
Private | procedure SetMaxTreeDepth(const Value: Integer);

Properties

Published | property GrowGravy: Single read FGrowGravy write FGrowGravy;
Published | property GrowMethod: TGrowMethod read FGrowMethod write FGrowMethod;
Published | property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;
Published | property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;
Public | property QueryNodeTests: Integer read FQueryNodeTests;
Published | property RootNode: TSectorNode read FRootNode;

Description

Fields

Private FRootNode: TSectorNode;

This item has no description.

Private FLeafThreshold: Integer;

This item has no description.

Private FMaxTreeDepth: Integer;

This item has no description.

Private FGrowGravy: Single;

This item has no description.

Private FGrowMethod: TGrowMethod;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateNewNode(AParent: TSectorNode): TSectorNode; virtual;

CreateNewNode creates a new node of the TSectorNode subclass that this structure requires

Public function GetAABB: TAABB;

Returns the _total_ AABB in structure

Public function GetNodeCount: Integer;

Returns the number of nodes in the structure

Public function QueryAABB(const AAABB: TAABB): Integer; override;

Query space for Leaves that intersect the axis aligned bounding box, result is returned through QueryResult. This method simply defers to the QueryAABB method of the root node.

Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;

Query space for Leaves that intersect the bounding sphere, result is returned through QueryResult. This method simply defers to the QueryBSphere method of the root node.

Public function QueryFrustum(const Frustum: TFrustum): Integer; override;

Query space for Leaves that intersect a Frustum. Result is returned through QueryResult

Public function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; override;

Query space for Leaves that intersect an extended frustum. Result is returned through QueryResult

Public function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; override;

Query space for Leaves that intersect the bounding sphere or box of a leaf. Result is returned through QueryResult

Public function QueryPlane(const Location, Normal: TAffineVector) : Integer; override;

Query space for Leaves that intersect a plane. Result is returned through QueryResult

Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;

Add a leaf to the structure. If the leaf doesn't fit in the structure, the structure is either grown or an exception is raised. If GrowMethod is set to gmBestFit or gmIncreaseToFitAll, the octree will be grown.

Public procedure Clear; override;

This item has no description. Showing description inherited from TLeavedSpacePartition.Clear.

Clear all internal storage Leaves

Public procedure LeafChanged(ALeaf: TSpacePartitionLeaf); override;

Called by leaf when it has changed, the leaf will be moved to an apropriate node

Public procedure RebuildTree(const NewAABB: TAABB);

Rebuild tree will change the tree to the newAABB size, and completely rebuild it

Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;

Remove a leaf from the structure.

Public procedure UpdateStructureSize(Gravy: Single);

UpdateOctreeSize will grow and / or shrink the structure to fit the current leaves +-gravy

Private procedure SetLeafThreshold(const Value: Integer);

This item has no description.

Private procedure SetMaxTreeDepth(const Value: Integer);

This item has no description.

Properties

Published property GrowGravy: Single read FGrowGravy write FGrowGravy;

When the structure is recreated because it's no longer large enough to fit all leafs, it will become large enough to safely fit all leafs, plus GrowGravy. This is to prevent too many grows

Published property GrowMethod: TGrowMethod read FGrowMethod write FGrowMethod;

Determines if the structure should grow with new leaves, or if an exception should be raised

Published property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;

Determines when a node should be split up to form children.

Published property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;

Determines how deep a tree should be allowed to grow.

Public property QueryNodeTests: Integer read FQueryNodeTests;

After a query has been run, this value will contain the number of nodes that were checked during the query

Published property RootNode: TSectorNode read FRootNode;

Root TSectorNode that all others stem from


GXSysHelp v.2.5: GXS.SpacePartition: Class TSPOctreeNode

Class TSPOctreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSPOctreeNode = class(TSectorNode)

Description

Implements sector node that handles octrees

Hierarchy

  • TObject
  • TSectorNode
  • TSPOctreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | procedure CreateChildren; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB intersects this node

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere intersects this node

Public procedure CreateChildren; override;

Create 8 TSPOctreeNode children


GXSysHelp v.2.5: GXS.SpacePartition: Class TOctreeSpacePartition

Class TOctreeSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TOctreeSpacePartition = class(TSectoredSpacePartition)

Description

Implements octrees

Hierarchy

  • TgxPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition
  • TOctreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TSectorNode): TSectorNode; override;

CreateNewNode creates a new TSPOctreeNode

Public procedure SetSize(const Min, Max: TAffineVector);

Set size updates the size of the Octree


GXSysHelp v.2.5: GXS.SpacePartition: Class TSPQuadtreeNode

Class TSPQuadtreeNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TSPQuadtreeNode = class(TSPOctreeNode)

Description

Implements sector node that handles quadtrees.

Hierarchy

  • TObject
  • TSectorNode
  • TSPOctreeNode
  • TSPQuadtreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | function GetChildForAABB(AABB: TAABB): TSectorNode; override;
Public | procedure CreateChildren; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB fits completely inside this node

Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;

Checks if an AABB intersects this node

Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere fits completely inside this node

Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;

Checks if a BSphere intersects this node

Public function GetChildForAABB(AABB: TAABB): TSectorNode; override;

Computes which child the AABB should go in. Returns nil if no such child exists

Public procedure CreateChildren; override;

Create 4 TSPQuadtreeNode children


GXSysHelp v.2.5: GXS.SpacePartition: Class TQuadtreeSpacePartition

Class TQuadtreeSpacePartition

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpacePartition

Declaration

type TQuadtreeSpacePartition = class(TSectoredSpacePartition)

Description

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting).

Hierarchy

  • TgxPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition
  • TQuadtreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TSectorNode): TSectorNode; override;

CreateNewNode creates a new TSPOctreeNode

Public procedure SetSize(const Min, Max: TAffineVector);

Set size updates the size of the Octree


GXSysHelp v.2.5: GXS.SpaceText

Unit GXS.SpaceText

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • WinApi.Messages
  • System.Classes
  • System.UITypes
  • System.SysUtils
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.Texture
  • GXS.Context
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTextAdjust |
Record TFontEntry |
Class TgxSpaceText |
Class TFontManager |

Functions and Procedures

function FontManager: TFontManager;
procedure ReleaseFontManager;

Types

PFontEntry = ˆTFontEntry;
TgxSpaceTextCharRange = (...);
TgxTextHorzAdjust = (...);
TgxTextVertAdjust = (...);

Variables

vFontManagerMsgID: Cardinal;

Description

Functions and Procedures

function FontManager: TFontManager;

This item has no description.

procedure ReleaseFontManager;

This item has no description.

Types

PFontEntry = ˆTFontEntry;

Holds an entry in the font manager list (used in TgxSpaceText)

TgxSpaceTextCharRange = (...);

This item has no description.

Values
  • stcrDefault
  • stcrAlphaNum
  • stcrNumbers
  • stcrWide
TgxTextHorzAdjust = (...);

Note: haAligned, haCentrically, haFitIn have not been implemented!

Values
  • haLeft
  • haCenter
  • haRight
  • haAligned
  • haCentrically
  • haFitIn
TgxTextVertAdjust = (...);

This item has no description.

Values
  • vaTop
  • vaCenter
  • vaBottom
  • vaBaseLine

Variables

vFontManagerMsgID: Cardinal;


GXSysHelp v.2.5: GXS.SpaceText: Class TgxTextAdjust

Class TgxTextAdjust

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpaceText

Declaration

type TgxTextAdjust = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxTextAdjust

Overview

Fields

Private | FHorz: TgxTextHorzAdjust;
Private | FVert: TgxTextVertAdjust;
Private | FOnChange: TNotifyEvent;

Methods

Public | constructor Create;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetHorz(const Value: TgxTextHorzAdjust);
Private | procedure SetVert(const Value: TgxTextVertAdjust);

Properties

Published | property Horz: TgxTextHorzAdjust read FHorz write SetHorz default haLeft;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property Vert: TgxTextVertAdjust read FVert write SetVert default vaBaseLine;

Description

Fields

Private FHorz: TgxTextHorzAdjust;

This item has no description.

Private FVert: TgxTextVertAdjust;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetHorz(const Value: TgxTextHorzAdjust);

This item has no description.

Private procedure SetVert(const Value: TgxTextVertAdjust);

This item has no description.

Properties

Published property Horz: TgxTextHorzAdjust read FHorz write SetHorz default haLeft;

This item has no description.

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property Vert: TgxTextVertAdjust read FVert write SetVert default vaBaseLine;


GXSysHelp v.2.5: GXS.SpaceText: Record TFontEntry

Record TFontEntry

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpaceText

Declaration

type TFontEntry = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | FVirtualHandle: TgxVirtualHandleTransf;
Public | Styles: TFontStyles;
Public | Extrusion: Single;
Public | RefCount: Integer;
Public | allowedDeviation: Single;
Public | firstChar: Integer;
Public | lastChar: Integer;
Public | glyphMetrics: array of TGlyphMetricsFloat;
Public | FClients: TList;

Description

Fields

Public Name: string;

This item has no description.

Public FVirtualHandle: TgxVirtualHandleTransf;

This item has no description.

Public Styles: TFontStyles;

This item has no description.

Public Extrusion: Single;

This item has no description.

Public RefCount: Integer;

This item has no description.

Public allowedDeviation: Single;

This item has no description.

Public firstChar: Integer;

This item has no description.

Public lastChar: Integer;

This item has no description.

Public glyphMetrics: array of TGlyphMetricsFloat;

This item has no description.

Public FClients: TList;


GXSysHelp v.2.5: GXS.SpaceText: Class TgxSpaceText

Class TgxSpaceText

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpaceText

Declaration

type TgxSpaceText = class(TgxSceneObject)

Description

Renders a text in 3D.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxSpaceText

Overview

Fields

Private | FFont: TFont;
Private | FExtrusion: Single;
Private | FAllowedDeviation: Single;
Private | FCharacterRange: TgxSpaceTextCharRange;
Private | FAdjust: TgxTextAdjust;
Private | FAspectRatio: Single;
Private | FOblique: Single;
Private | FTextHeight: Single;
Private | FLines: TStringList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function BarycenterAbsolutePosition: TVector4f; override;
Public | function TextMaxHeight(const str: WideString = ''): Single;
Public | function TextMaxUnder(const str: WideString = ''): Single;
Public | function TextWidth(const str: WideString = ''): Single;
Private | function GetText: WideString;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DefaultHandler(var Message); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure NotifyChange(sender: TObject); override;
Public | procedure NotifyFontChanged;
Public | procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);
Private | procedure SetAdjust(const Value: TgxTextAdjust);
Private | procedure SetAllowedDeviation(const val: Single);
Private | procedure SetAspectRatio(const Value: Single);
Private | procedure SetCharacterRange(const val: TgxSpaceTextCharRange);
Private | procedure SetExtrusion(AValue: Single);
Private | procedure SetFont(AFont: TFont);
Private | procedure SetLines(const Value: TStringList);
Private | procedure SetOblique(const Value: Single);
Private | procedure SetText(const AText: WideString);
Private | procedure SetTextHeight(const Value: Single);

Properties

Published | property Adjust: TgxTextAdjust read FAdjust write SetAdjust;
Published | property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;
Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio;
Published | property CharacterRange: TgxSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;
Published | property Extrusion: Single read FExtrusion write SetExtrusion;
Published | property Font: TFont read FFont write SetFont;
Published | property Lines: TStringList read FLines write SetLines;
Published | property Oblique: Single read FOblique write SetOblique;
Published | property Text: WideString read GetText write SetText stored False;
Published | property TextHeight: Single read FTextHeight write SetTextHeight;

Description

Fields

Private FFont: TFont;

This item has no description.

Private FExtrusion: Single;

This item has no description.

Private FAllowedDeviation: Single;

This item has no description.

Private FCharacterRange: TgxSpaceTextCharRange;

This item has no description.

Private FAdjust: TgxTextAdjust;

This item has no description.

Private FAspectRatio: Single;

This item has no description.

Private FOblique: Single;

This item has no description.

Private FTextHeight: Single;

This item has no description.

Private FLines: TStringList;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function TextMaxHeight(const str: WideString = ''): Single;

This item has no description.

Public function TextMaxUnder(const str: WideString = ''): Single;

This item has no description.

Public function TextWidth(const str: WideString = ''): Single;

This item has no description.

Private function GetText: WideString;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DefaultHandler(var Message); override;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure NotifyChange(sender: TObject); override;

This item has no description.

Public procedure NotifyFontChanged;

This item has no description.

Public procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);

Note: this fuction is valid only after text has been rendered the first time. Before that it returns zeros.

Private procedure SetAdjust(const Value: TgxTextAdjust);

This item has no description.

Private procedure SetAllowedDeviation(const val: Single);

This item has no description.

Private procedure SetAspectRatio(const Value: Single);

This item has no description.

Private procedure SetCharacterRange(const val: TgxSpaceTextCharRange);

This item has no description.

Private procedure SetExtrusion(AValue: Single);

This item has no description.

Private procedure SetFont(AFont: TFont);

This item has no description.

Private procedure SetLines(const Value: TStringList);

This item has no description.

Private procedure SetOblique(const Value: Single);

This item has no description.

Private procedure SetText(const AText: WideString);

This item has no description.

Private procedure SetTextHeight(const Value: Single);

This item has no description.

Properties

Published property Adjust: TgxTextAdjust read FAdjust write SetAdjust;

This item has no description.

Published property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;

Quality related, see Win32 help for wglUseFontOutlines

Published property AspectRatio: Single read FAspectRatio write SetAspectRatio;

This item has no description.

Published property CharacterRange: TgxSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;

Character range to convert. Converting less characters saves time and memory...

Published property Extrusion: Single read FExtrusion write SetExtrusion;

Adjusts the 3D font extrusion. If Extrusion=0, the characters will be flat (2D), values >0 will give them a third dimension.

Published property Font: TFont read FFont write SetFont;

This item has no description.

Published property Lines: TStringList read FLines write SetLines;

This item has no description.

Published property Oblique: Single read FOblique write SetOblique;

This item has no description.

Published property Text: WideString read GetText write SetText stored False;

This item has no description.

Published property TextHeight: Single read FTextHeight write SetTextHeight;


GXSysHelp v.2.5: GXS.SpaceText: Class TFontManager

Class TFontManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpaceText

Declaration

type TFontManager = class(TList)

Description

Manages a list of fonts for which display lists were created.

Hierarchy

  • TObject
  • TList
  • TFontManager

Overview

Fields

Private FCurrentBase: Integer;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;
Public | function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;
Public | procedure Release(entry: PFontEntry; client: TObject);

Description

Fields

Private FCurrentBase: Integer;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;

This item has no description.

Public function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;

This item has no description.

Public procedure Release(entry: PFontEntry; client: TObject);


GXSysHelp v.2.5: GXS.SpatialPartitioning

Unit GXS.SpatialPartitioning

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.GeometryBB
  • GXS.SpacePartition
  • GXS.Scene
  • GXS.Coordinates
  • GXS.SceneViewer
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSceneObj |

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TgxRenderContextInfo; const Space: TSectoredSpacePartition);
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AVKCamera: TgxCamera) : TExtendedFrustum; overload;
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLXceneViewer: TgxSceneViewer) : TExtendedFrustum; overload;
procedure RenderAABB(var rci: TgxRenderContextInfo; AABB: TAABB; w, r, g, b: single); overload;
procedure RenderAABB(var rci: TgxRenderContextInfo; AABB: TAABB); overload;

Description

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TgxRenderContextInfo; const Space: TSectoredSpacePartition);

Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AVKCamera: TgxCamera) : TExtendedFrustum; overload;

Create an extended frustum from a SceneViewer - this makes the unit specific to the windows platform!

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLXceneViewer: TgxSceneViewer) : TExtendedFrustum; overload;

This item has no description.

procedure RenderAABB(var rci: TgxRenderContextInfo; AABB: TAABB; w, r, g, b: single); overload;

Renders an AABB as a line

procedure RenderAABB(var rci: TgxRenderContextInfo; AABB: TAABB); overload;


GXSysHelp v.2.5: GXS.SpatialPartitioning: Class TgxSceneObj

Class TgxSceneObj

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.SpatialPartitioning

Declaration

type TgxSceneObj = class(TSpacePartitionLeaf)

Description

Object for holding scene objects in a spatial partitioning

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf
  • TgxSceneObj

Overview

Fields

Public Obj: TgxBaseSceneObject;

Methods

Public | constructor CreateObj(Owner: TSectoredSpacePartition; aObj: TgxBaseSceneObject);
Public | destructor Destroy; override;
Public | procedure UpdateCachedAABBAndBSphere; override;

Description

Fields

Public Obj: TgxBaseSceneObject;

This item has no description.

Methods

Public constructor CreateObj(Owner: TSectoredSpacePartition; aObj: TgxBaseSceneObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure UpdateCachedAABBAndBSphere; override;

This item has no description. Showing description inherited from TSpacePartitionLeaf.UpdateCachedAABBAndBSphere.

AABBs and BSpheres are cached for leafs, and this function should be overriden to update the cache from the structure that the leaf stores. This is the only function you MUST override to use space partitions.


GXSysHelp v.2.5: GXS.State

Unit GXS.State

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.Strings
  • GLScene.TextureFormat
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.Color

Overview

Classes, Interfaces, Objects and Records

Name | Description
Packed Record TgxLightSourceState |
Packed Record TgxShaderLightSourceState |
Record TUBOStates |
Class TgxStateCache |
Record TgxStateRecord |

Types

TgxBlendEquation = (...);
TgxBlendFunction = (...);
TgxBufferBindingTarget = (...);
TgxColorComponent = (...);
TgxColorMask = set of TgxColorComponent;
TgxComparisonFunction = (...);
TgxCullFaceMode = (...);
TgxDepthFunction = TgxComparisonFunction;
TgxDstBlendFunction = bfZero..bfOneMinusConstantAlpha;
TgxFaceWinding = (...);
TgxHintType = (...);
TgxLogicOp = (...);
TgxMaterialLevel = (...);
TgxMeshPrimitive = (...);
TgxMeshPrimitives = set of TgxMeshPrimitive;
TgxOnLightsChanged = procedure(Sender: TObject);
TgxPolygonMode = (...);
TgxQueryType = (...);
TgxState = (...);
TgxStates = set of TgxState;
TgxStateType = (...);
TgxStateTypes = set of TgxStateType;
TgxStencilFunction = TgxComparisonFunction;
TgxStencilOp = (...);

Constants

VERTEX_ATTR_NUM = 16;
cAllAttribBits = [Low(TgxStateType)..High(TgxStateType)];
cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];
cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];
MAX_HARDWARE_LIGHT = 16;
MAX_SHADER_LIGHT = 8;
MAX_HARDWARE_TEXTURE_UNIT = 48;
MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;
cGLStateTypeToGLEnum: array[TgxStateType] of Cardinal = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);
cGLStateToGLEnum: array[TgxState] of TgxStateRecord = ((GLConst: GL_ALPHA_TEST; IsDeprecated: True), (GLConst: GL_AUTO_NORMAL; IsDeprecated: True), (GLConst: GL_BLEND; IsDeprecated: False), (GLConst: GL_COLOR_MATERIAL; IsDeprecated: True), (GLConst: GL_CULL_FACE; IsDeprecated: False), (GLConst: GL_DEPTH_TEST; IsDeprecated: False), (GLConst: GL_DITHER; IsDeprecated: False), (GLConst: GL_FOG; IsDeprecated: True), (GLConst: GL_LIGHTING; IsDeprecated: True), (GLConst: GL_LINE_SMOOTH; IsDeprecated: True), (GLConst: GL_LINE_STIPPLE; IsDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; IsDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; IsDeprecated: False), (GLConst: GL_NORMALIZE; IsDeprecated: True), (GLConst: GL_POINT_SMOOTH; IsDeprecated: True), (GLConst: GL_POINT_SPRITE; IsDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; IsDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; IsDeprecated: True), (GLConst: GL_SCISSOR_TEST; IsDeprecated: False), (GLConst: GL_STENCIL_TEST; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; IsDeprecated: False), (GLConst: GL_DEPTH_CLAMP; IsDeprecated: False) );
cGLTexTypeToGLEnum: array[TglTextureTarget] of GLEnum = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);
cGLQueryTypeToGLEnum: array[TgxQueryType] of GLEnum = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);
cGLStencilOpToGLEnum: array[TgxStencilOp] of GLEnum = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);
cGLLogicOpToGLEnum: array[TgxLogicOp] of GLEnum = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);
cGLComparisonFunctionToGLEnum: array[TgxComparisonFunction] of GLEnum = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);
cGLBlendFunctionToGLEnum: array[TgxBlendFunction] of GLEnum = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );
cGLBlendEquationToGLEnum: array[TgxBlendEquation] of GLEnum = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);
cGLFaceWindingToGLEnum: array[TgxFaceWinding] of GLEnum = (GL_CCW, GL_CW);
cGLPolygonModeToGLEnum: array[TgxPolygonMode] of GLEnum = (GL_FILL, GL_LINE, GL_POINT);
cGLCullFaceModeToGLEnum: array[TgxCullFaceMode] of GLEnum = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);
cGLHintToGLEnum: array[TgxHintType] of GLEnum = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);
cGLBufferBindingTarget: array[TgxBufferBindingTarget] of GLEnum = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);

Description

Types

TgxBlendEquation = (...);

This item has no description.

Values
  • beAdd
  • beSubtract
  • beReverseSubtract
  • beMin
  • beMax
TgxBlendFunction = (...);

This item has no description.

Values
  • bfZero
  • bfOne
  • bfSrcColor
  • bfOneMinusSrcColor
  • bfDstColor
  • bfOneMinusDstColor
  • bfSrcAlpha
  • bfOneMinusSrcAlpha
  • bfDstAlpha
  • bfOneMinusDstAlpha
  • bfConstantColor
  • bfOneMinusConstantColor
  • bfConstantAlpha
  • bfOneMinusConstantAlpha
  • bfSrcAlphaSat
TgxBufferBindingTarget = (...);

This item has no description.

Values
  • bbtUniform
  • bbtTransformFeedBack
TgxColorComponent = (...);

TSingleCullFaceMode = cmFront..cmBack;

Values
  • ccRed
  • ccGreen
  • ccBlue
  • ccAlpha
TgxColorMask = set of TgxColorComponent;

This item has no description.

TgxComparisonFunction = (...);

This item has no description.

Values
  • cfNever
  • cfAlways
  • cfLess
  • cfLEqual
  • cfEqual
  • cfGreater
  • cfNotEqual
  • cfGEqual
TgxCullFaceMode = (...);

This item has no description.

Values
  • cmFront
  • cmBack
  • cmFrontAndBack
TgxDepthFunction = TgxComparisonFunction;

This item has no description.

TgxDstBlendFunction = bfZero..bfOneMinusConstantAlpha;

This item has no description.

TgxFaceWinding = (...);

Describe what kind of winding has a front face

Values
  • fwCounterClockWise
  • fwClockWise
TgxHintType = (...);

This item has no description.

Values
  • hintDontCare
  • hintFastest
  • hintNicest
TgxLogicOp = (...);

This item has no description.

Values
  • loClear
  • loAnd
  • loAndReverse
  • loCopy
  • loAndInverted
  • loNoOp
  • loXOr
  • loOr
  • loNor
  • loEquiv
  • loInvert
  • loOrReverse
  • loCopyInverted
  • loOrInverted
  • loNAnd
  • loSet
TgxMaterialLevel = (...);

This item has no description.

Values
  • mlAuto
  • mlFixedFunction
  • mlMultitexturing
  • mlSM3
  • mlSM4
  • mlSM5
TgxMeshPrimitive = (...);

This item has no description.

Values
  • mpNOPRIMITIVE
  • mpTRIANGLES
  • mpTRIANGLE_STRIP
  • mpTRIANGLE_FAN
  • mpPOINTS
  • mpLINES
  • mpLINE_LOOP
  • mpLINE_STRIP
  • mpLINES_ADJACENCY
  • mpLINE_STRIP_ADJACENCY
  • mpTRIANGLES_ADJACENCY
  • mpTRIANGLE_STRIP_ADJACENCY
  • mpPATCHES
TgxMeshPrimitives = set of TgxMeshPrimitive;

This item has no description.

TgxOnLightsChanged = procedure(Sender: TObject);

This item has no description.

TgxPolygonMode = (...);

This item has no description.

Values
  • pmFill
  • pmLines
  • pmPoints
TgxQueryType = (...);

This item has no description.

Values
  • qrySamplesPassed
  • qryPrimitivesGenerated
  • qryTransformFeedbackPrimitivesWritten
  • qryTimeElapsed
  • qryAnySamplesPassed
TgxState = (...);

Reflects all relevant (binary) states of OpenGL subsystem

Values
  • stAlphaTest
  • stAutoNormal
  • stBlend
  • stColorMaterial
  • stCullFace
  • stDepthTest
  • stDither
  • stFog
  • stLighting
  • stLineSmooth
  • stLineStipple
  • stIndexLogicOp
  • stColorLogicOp
  • stNormalize
  • stPointSmooth
  • stPointSprite
  • stPolygonSmooth
  • stPolygonStipple
  • stScissorTest
  • stStencilTest
  • stPolygonOffsetPoint
  • stPolygonOffsetLine
  • stPolygonOffsetFill
  • stDepthClamp
TgxStates = set of TgxState;

This item has no description.

TgxStateType = (...);

This item has no description.

Values
  • sttCurrent
  • sttPoint
  • sttLine
  • sttPolygon
  • sttPolygonStipple
  • sttPixelMode
  • sttLighting
  • sttFog
  • sttDepthBuffer
  • sttAccumBuffer
  • sttStencilBuffer
  • sttViewport
  • sttTransform
  • sttEnable
  • sttColorBuffer
  • sttHint
  • sttEval
  • sttList
  • sttTexture
  • sttScissor
  • sttMultisample
TgxStateTypes = set of TgxStateType;

This item has no description.

TgxStencilFunction = TgxComparisonFunction;

This item has no description.

TgxStencilOp = (...);

This item has no description.

Values
  • soKeep
  • soZero
  • soReplace
  • soIncr
  • soDecr
  • soInvert
  • soIncrWrap
  • soDecrWrap

Constants

VERTEX_ATTR_NUM = 16;

This item has no description.

cAllAttribBits = [Low(TgxStateType)..High(TgxStateType)];

This item has no description.

cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];

This item has no description.

cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];

This item has no description.

MAX_HARDWARE_LIGHT = 16;

This item has no description.

MAX_SHADER_LIGHT = 8;

This item has no description.

MAX_HARDWARE_TEXTURE_UNIT = 48;

This item has no description.

MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;

This item has no description.

cGLStateTypeToGLEnum: array[TgxStateType] of Cardinal = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);

This item has no description.

cGLStateToGLEnum: array[TgxState] of TgxStateRecord = ((GLConst: GL_ALPHA_TEST; IsDeprecated: True), (GLConst: GL_AUTO_NORMAL; IsDeprecated: True), (GLConst: GL_BLEND; IsDeprecated: False), (GLConst: GL_COLOR_MATERIAL; IsDeprecated: True), (GLConst: GL_CULL_FACE; IsDeprecated: False), (GLConst: GL_DEPTH_TEST; IsDeprecated: False), (GLConst: GL_DITHER; IsDeprecated: False), (GLConst: GL_FOG; IsDeprecated: True), (GLConst: GL_LIGHTING; IsDeprecated: True), (GLConst: GL_LINE_SMOOTH; IsDeprecated: True), (GLConst: GL_LINE_STIPPLE; IsDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; IsDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; IsDeprecated: False), (GLConst: GL_NORMALIZE; IsDeprecated: True), (GLConst: GL_POINT_SMOOTH; IsDeprecated: True), (GLConst: GL_POINT_SPRITE; IsDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; IsDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; IsDeprecated: True), (GLConst: GL_SCISSOR_TEST; IsDeprecated: False), (GLConst: GL_STENCIL_TEST; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; IsDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; IsDeprecated: False), (GLConst: GL_DEPTH_CLAMP; IsDeprecated: False) );

This item has no description.

cGLTexTypeToGLEnum: array[TglTextureTarget] of GLEnum = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);

This item has no description.

cGLQueryTypeToGLEnum: array[TgxQueryType] of GLEnum = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);

This item has no description.

cGLStencilOpToGLEnum: array[TgxStencilOp] of GLEnum = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);

This item has no description.

cGLLogicOpToGLEnum: array[TgxLogicOp] of GLEnum = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);

This item has no description.

cGLComparisonFunctionToGLEnum: array[TgxComparisonFunction] of GLEnum = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);

This item has no description.

cGLBlendFunctionToGLEnum: array[TgxBlendFunction] of GLEnum = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );

This item has no description.

cGLBlendEquationToGLEnum: array[TgxBlendEquation] of GLEnum = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);

valid for src only

cGLFaceWindingToGLEnum: array[TgxFaceWinding] of GLEnum = (GL_CCW, GL_CW);

This item has no description.

cGLPolygonModeToGLEnum: array[TgxPolygonMode] of GLEnum = (GL_FILL, GL_LINE, GL_POINT);

This item has no description.

cGLCullFaceModeToGLEnum: array[TgxCullFaceMode] of GLEnum = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);

This item has no description.

cGLHintToGLEnum: array[TgxHintType] of GLEnum = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);

This item has no description.

cGLBufferBindingTarget: array[TgxBufferBindingTarget] of GLEnum = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);


GXSysHelp v.2.5: GXS.State: Packed Record TgxLightSourceState

Packed Record TgxLightSourceState

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.State

Declaration

type TgxLightSourceState = packed record

Description

This item has no description.

Overview

Fields

Public | Position: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | Ambient: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | Diffuse: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | Specular: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | SpotDirection: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | SpotCosCutoffExponent: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;
Public | Attenuation: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

Description

Fields

Public Position: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public Ambient: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public Diffuse: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public Specular: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public SpotDirection: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public SpotCosCutoffExponent: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;

This item has no description.

Public Attenuation: array[0..MAX_HARDWARE_LIGHT-1] of TVector4f;


GXSysHelp v.2.5: GXS.State: Packed Record TgxShaderLightSourceState

Packed Record TgxShaderLightSourceState

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.State

Declaration

type TgxShaderLightSourceState = packed record

Description

This item has no description.

Overview

Fields

Public | Position: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | Ambient: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | Diffuse: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | Specular: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | SpotDirection: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | SpotCosCutoffExponent: array[0..MAX_SHADER_LIGHT-1] of TVector4f;
Public | Attenuation: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

Description

Fields

Public Position: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public Ambient: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public Diffuse: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public Specular: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public SpotDirection: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public SpotCosCutoffExponent: array[0..MAX_SHADER_LIGHT-1] of TVector4f;

This item has no description.

Public Attenuation: array[0..MAX_SHADER_LIGHT-1] of TVector4f;


GXSysHelp v.2.5: GXS.State: Record TUBOStates

Record TUBOStates

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.State

Declaration

type TUBOStates = record

Description

This item has no description.

Overview

Fields

Public | FUniformBufferBinding: Cardinal;
Public | FOffset: ˆInteger;
Public | FSize: PGLsizei;

Description

Fields

Public FUniformBufferBinding: Cardinal;

This item has no description.

Public FOffset: ˆInteger;

This item has no description.

Public FSize: PGLsizei;


GXSysHelp v.2.5: GXS.State: Class TgxStateCache

Class TgxStateCache

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.State

Declaration

type TgxStateCache = class(TObject)

Description

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.

Hierarchy

  • TObject
  • TgxStateCache

Overview

Fields

Private | FFrontBackColors: array[0..1, 0..3] of TVector4f;
Private | FFrontBackShininess: array[0..1] of Integer;
Private | FAlphaFunc: TgxComparisonFunction;
Private | FAlphaRef: Single;
Private | FPolygonBackMode: TgxPolygonMode;
Private | FMaxLights: Cardinal;
Private | FLightEnabling: array[0..MAX_HARDWARE_LIGHT - 1] of Boolean;
Private | FLightIndices: array[0..MAX_HARDWARE_LIGHT - 1] of GLint;
Private | FLightNumber: Integer;
Private | FLightStates: TgxLightSourceState;
Private | FSpotCutoff: array[0..MAX_HARDWARE_LIGHT-1] of Single;
Private | FShaderLightStates: TgxShaderLightSourceState;
Private | FShaderLightStatesChanged: Boolean;
Private | FColorWriting: Boolean;
Private | FStates: TgxStates;
Private | FListStates: array of TgxStateTypes;
Private | FCurrentList: Cardinal;
Private | FTextureMatrixIsIdentity: array[0..3] of Boolean;
Private | FForwardContext: Boolean;
Private | FFFPLight: Boolean;
Private | FVertexArrayBinding: Cardinal;
Private | FArrayBufferBinding: Cardinal;
Private | FElementBufferBinding: Cardinal;
Private | FTextureBufferBinding: Cardinal;
Private | FEnablePrimitiveRestart: GLboolean;
Private | FPrimitiveRestartIndex: Cardinal;
Private | FViewPort: TVector4i;
Private | FDepthRange: array[0..1] of GLclampd;
Private | FEnableClipDistance: array[0..7] of GLboolean;
Private | FEnableDepthClamp: GLboolean;
Private | FClampReadColor: Cardinal;
Private | FProvokingVertex: Cardinal;
Private | FPointSize: Single;
Private | FPointFadeThresholdSize: Single;
Private | FPointSpriteCoordOrigin: Cardinal;
Private | FLineWidth: Single;
Private | FLineStippleFactor: GLint;
Private | FLineStipplePattern: GLushort;
Private | FEnableLineSmooth: GLboolean;
Private | FEnableCullFace: GLboolean;
Private | FCullFaceMode: TgxCullFaceMode;
Private | FFrontFace: TgxFaceWinding;
Private | FEnablePolygonSmooth: GLboolean;
Private | FPolygonMode: TgxPolygonMode;
Private | FPolygonOffsetFactor: Single;
Private | FPolygonOffsetUnits: Single;
Private | FEnablePolygonOffsetPoint: GLboolean;
Private | FEnablePolygonOffsetLine: GLboolean;
Private | FEnablePolygonOffsetFill: GLboolean;
Private | FEnableMultisample: GLboolean;
Private | FEnableSampleAlphaToCoverage: GLboolean;
Private | FEnableSampleAlphaToOne: GLboolean;
Private | FEnableSampleCoverage: GLboolean;
Private | FSampleCoverageValue: Single;
Private | FSampleCoverageInvert: GLboolean;
Private | FEnableSampleMask: GLboolean;
Private | FSampleMaskValue: array[0..15] of GLbitfield;
Private | FMaxTextureSize: Cardinal;
Private | FMax3DTextureSize: Cardinal;
Private | FMaxCubeTextureSize: Cardinal;
Private | FMaxArrayTextureSize: Cardinal;
Private | FMaxTextureImageUnits: Cardinal;
Private | FMaxTextureAnisotropy: Cardinal;
Private | FMaxSamples: Cardinal;
Private | FTextureBinding: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Cardinal;
Private | FTextureBindingTime: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Double;
Private | FSamplerBinding: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1] of Cardinal;
Private | FActiveTexture: GLint;
Private | FActiveTextureEnabling: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Boolean;
Private | FEnableScissorTest: GLboolean;
Private | FScissorBox: TVector4i;
Private | FEnableStencilTest: GLboolean;
Private | FStencilFunc: TgxStencilFunction;
Private | FStencilValueMask: Cardinal;
Private | FStencilRef: GLint;
Private | FStencilFail: TgxStencilOp;
Private | FStencilPassDepthFail: TgxStencilOp;
Private | FStencilPassDepthPass: TgxStencilOp;
Private | FStencilBackFunc: TgxStencilFunction;
Private | FStencilBackValueMask: GLuint;
Private | FStencilBackRef: GLuint;
Private | FStencilBackFail: TgxStencilOp;
Private | FStencilBackPassDepthPass: TgxStencilOp;
Private | FStencilBackPassDepthFail: TgxStencilOp;
Private | FEnableDepthTest: GLboolean;
Private | FDepthFunc: TgxDepthFunction;
Private | FEnableBlend: array[0..15] of GLboolean;
Private | FBlendSrcRGB: TgxBlendFunction;
Private | FBlendSrcAlpha: TgxBlendFunction;
Private | FBlendDstRGB: TgxDstBlendFunction;
Private | FBlendDstAlpha: TgxDstBlendFunction;
Private | FBlendEquationRGB: TgxBlendEquation;
Private | FBlendEquationAlpha: TgxBlendEquation;
Private | FBlendColor: TVector4f;
Private | FEnableFramebufferSRGB: GLboolean;
Private | FEnableDither: GLboolean;
Private | FEnableColorLogicOp: GLboolean;
Private | FLogicOpMode: TgxLogicOp;
Private | FColorWriteMask: array[0..15] of TgxColorMask;
Private | FDepthWriteMask: Boolean;
Private | FStencilWriteMask: GLuint;
Private | FStencilBackWriteMask: GLuint;
Private | FColorClearValue: TVector4f;
Private | FDepthClearValue: Single;
Private | FStencilClearValue: GLuint;
Private | FDrawFrameBuffer: Cardinal;
Private | FReadFrameBuffer: Cardinal;
Private | FRenderBuffer: Cardinal;
Private | FUnpackSwapBytes: GLboolean;
Private | FUnpackLSBFirst: GLboolean;
Private | FUnpackImageHeight: GLuint;
Private | FUnpackSkipImages: GLuint;
Private | FUnpackRowLength: GLuint;
Private | FUnpackSkipRows: GLuint;
Private | FUnpackSkipPixels: GLuint;
Private | FUnpackAlignment: Cardinal;
Private | FPackSwapBytes: GLboolean;
Private | FPackLSBFirst: GLboolean;
Private | FPackImageHeight: GLuint;
Private | FPackSkipImages: GLuint;
Private | FPackRowLength: GLuint;
Private | FPackSkipRows: GLuint;
Private | FPackSkipPixels: GLuint;
Private | FPackAlignment: GLuint;
Private | FPixelPackBufferBinding: GLuint;
Private | FPixelUnpackBufferBinding: GLuint;
Private | FCurrentProgram: GLuint;
Private | FMaxTextureUnits: GLuint;
Private | FUniformBufferBinding: GLuint;
Private | FUBOStates: array[TgxBufferBindingTarget, 0..MAX_HARDWARE_UNIFORM_BUFFER_BINDING-1] of TUBOStates;
Private | FCurrentVertexAttrib: array[0..15] of TVector4f;
Private | FEnableProgramPointSize: GLboolean;
Private | FTransformFeedbackBufferBinding: Cardinal;
Private | FTextureCompressionHint: TgxHintType;
Private | FPolygonSmoothHint: TgxHintType;
Private | FFragmentShaderDerivitiveHint: TgxHintType;
Private | FLineSmoothHint: TgxHintType;
Private | FMultisampleFilterHint: TgxHintType;
Private | FCurrentQuery: array[TgxQueryType] of GLuint;
Private | FCopyReadBufferBinding: GLuint;
Private | FCopyWriteBufferBinding: GLuint;
Private | FEnableTextureCubeMapSeamless: GLboolean;
Private | FInsideList: Boolean;
Private | FOnLightsChanged: TgxOnLightsChanged;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function GetLightIndicesAsAddress: PGLInt;
Public | function GetLightStateAsAddress: Pointer;
Public | procedure BeginQuery(const Target: TgxQueryType; const Value: GLuint);
Public | procedure CallList(list: Cardinal); inline;
Public | procedure Disable(const aState: TgxState);
Public | procedure Enable(const aState: TgxState);
Public | procedure EndList; inline;
Public | procedure EndQuery(const Target: TgxQueryType); inline;
Public | procedure InvertFrontFace; inline;
Public | procedure NewList(list: GLuint; mode: GLEnum); inline;
Public | procedure PerformDisable(const aState: TgxState);
Public | procedure PerformEnable(const aState: TgxState);
Public | procedure PopAttrib();
Public | procedure PushAttrib(stateTypes: TgxStateTypes);
Public | procedure ResetAll; deprecated;
Public | procedure ResetAllTextureMatrix; inline;
Public | procedure ResetCurrentTexture; deprecated;
Public | procedure ResetFrontFace; deprecated;
Public | procedure ResetMaterialColors; deprecated;
Public | procedure ResetPolygonMode; deprecated;
Public | procedure ResetTexture(const TextureUnit: Integer); deprecated;
Public | procedure ResetTextureMatrix; inline;
Public | procedure SetAlphaFunction(func: TgxComparisonFunction; ref: Single);
Public | procedure SetBlendEquation(const mode: TgxBlendEquation);
Public | procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TgxBlendEquation);
Public | procedure SetBlendFunc(const Src: TgxBlendFunction; const Dst: TgxDstBlendFunction);
Public | procedure SetBlendFuncSeparate(const SrcRGB: TgxBlendFunction; const DstRGB: TgxDstBlendFunction; const SrcAlpha: TgxBlendFunction; const DstAlpha: TgxDstBlendFunction); inline;
Public | procedure SetBufferIndexedBinding(const Value: GLuint; ATarget: TgxBufferBindingTarget; AIndex: GLuint; AOffset: GLint; ARangeSize: PGLsizei); overload;
Public | procedure SetBufferIndexedBinding(const Value: GLuint; ATarget: TgxBufferBindingTarget; AIndex: GLuint; ABufferSize: PGLsizei); overload;
Public | procedure SetColorMask(mask: TgxColorMask);
Public | procedure SetColorWriting(flag: Boolean); inline;
Public | procedure SetDepthRange(const ZNear, ZFar: GLclampd);
Public | procedure SetFrameBuffer(const Value: GLuint);
Public | procedure SetGLFrontFaceCW; deprecated;
Public | procedure SetMaterialAlphaChannel(const aFace: GLEnum; const alpha: Single);
Public | procedure SetMaterialColors(const aFace: TgxCullFaceMode; const emission, ambient, diffuse, specular: TVector4f; const shininess: Integer);
Public | procedure SetMaterialDiffuseColor(const aFace: GLEnum; const diffuse: TVector4f);
Public | procedure SetPolygonOffset(const factor, units: Single);
Public | procedure SetSampleCoverage(const Value: Single; invert: GLboolean);
Public | procedure SetStencilFunc(const func: TgxStencilFunction; const ref: GLint; const mask: GLuint);
Public | procedure SetStencilFuncSeparate(const face: TgxCullFaceMode; const func: TgxStencilFunction; const ref: GLint; const mask: GLuint); inline;
Public | procedure SetStencilOp(const fail, zfail, zpass: TgxStencilOp); inline;
Public | procedure SetStencilOpSeparate(const face: TgxCullFaceMode; const sfail, dpfail, dppass: TgxStencilOp);
Public | procedure SetTextureMatrix(const matrix: TMatrix4f); inline;
Public | procedure SetVxState(const aState : TgxState); deprecated;
Public | procedure UnSetVxState(const aState : TgxState); deprecated;

Properties

Public | property ActiveTexture: GLint read FActiveTexture write SetActiveTexture;
Public | property ActiveTextureEnabled[Target: TglTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;
Public | property ArrayBufferBinding: GLuint read GetArrayBufferBinding write SetArrayBufferBinding;
Public | property BlendColor: TVector4f read FBlendColor write SetBlendColor;
Public | property BlendDstAlpha: TgxDstBlendFunction read FBlendDstAlpha;
Public | property BlendDstRGB: TgxDstBlendFunction read FBlendDstRGB;
Public | property BlendEquationAlpha: TgxBlendEquation read FBlendEquationAlpha;
Public | property BlendEquationRGB: TgxBlendEquation read FBlendEquationRGB;
Public | property BlendSrcAlpha: TgxBlendFunction read FBlendSrcAlpha;
Public | property BlendSrcRGB: TgxBlendFunction read FBlendSrcRGB;
Public | property ClampReadColor: GLEnum read FClampReadColor write SetClampReadColor;
Public | property ColorClearValue: TVector4f read FColorClearValue write SetColorClearValue;
Public | property ColorWriteMask[Index: Integer]: TgxColorMask read GetColorWriteMask write SetColorWriteMask;
Public | property CopyReadBufferBinding: GLuint read FCopyReadBufferBinding write SetCopyReadBufferBinding;
Public | property CopyWriteBufferBinding: GLuint read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;
Public | property CullFaceMode: TgxCullFaceMode read FCullFaceMode write SetCullFaceMode;
Public | property CurrentProgram: GLuint read FCurrentProgram write SetCurrentProgram;
Public | property CurrentQuery[Index: TgxQueryType]: GLuint read GetCurrentQuery;
Public | property CurrentVertexAttrib[Index: Integer]: TVector4f read GetCurrentVertexAttrib write SetCurrentVertexAttrib;
Public | property DepthClearValue: Single read FDepthClearValue write SetDepthClearValue;
Public | property DepthFunc: TgxDepthFunction read FDepthFunc write SetDepthFunc;
Public | property DepthRangeFar: GLclampd read GetDepthRangeFar write SetDepthRangeFar;
Public | property DepthRangeNear: GLclampd read GetDepthRangeNear write SetDepthRangeNear;
Public | property DepthWriteMask: Boolean read FDepthWriteMask write SetDepthWriteMask;
Public | property DrawFrameBuffer: GLuint read FDrawFrameBuffer write SetDrawFrameBuffer;
Public | property ElementBufferBinding: GLuint read GetElementBufferBinding write SetElementBufferBinding;
Public | property EnableBlend[Index: Integer]: GLboolean read GetEnableBlend write SetEnableBlend;
Public | property EnableClipDistance[Index: Cardinal]: GLboolean read GetEnableClipDistance write SetEnableClipDistance;
Public | property EnableColorLogicOp: GLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;
Public | property EnableCullFace: GLboolean read FEnableCullFace write SetEnableCullFace;
Public | property EnableDepthClamp: GLboolean read FEnableDepthClamp write SetEnableDepthClamp;
Public | property EnableDepthTest: GLboolean read FEnableDepthTest write SetEnableDepthTest;
Public | property EnableDither: GLboolean read FEnableDither write SetEnableDither;
Public | property EnableFramebufferSRGB: GLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;
Public | property EnableLineSmooth: GLboolean read FEnableLineSmooth write SetEnableLineSmooth;
Public | property EnableMultisample: GLboolean read FEnableMultisample write SetEnableMultisample;
Public | property EnablePolygonOffsetFill: GLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;
Public | property EnablePolygonOffsetLine: GLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;
Public | property EnablePolygonOffsetPoint: GLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;
Public | property EnablePolygonSmooth: GLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;
Public | property EnablePrimitiveRestart: GLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;
Public | property EnableProgramPointSize: GLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;
Public | property EnableSampleAlphaToCoverage: GLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;
Public | property EnableSampleAlphaToOne: GLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;
Public | property EnableSampleCoverage: GLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;
Public | property EnableSampleMask: GLboolean read FEnableSampleMask write SetEnableSampleMask;
Public | property EnableScissorTest: GLboolean read FEnableScissorTest write SetEnableScissorTest;
Public | property EnableStencilTest: GLboolean read FEnableStencilTest write SetEnableStencilTest;
Public | property EnableTextureCubeMapSeamless: GLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;
Public | property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;
Public | property ForwardContext: Boolean read FForwardContext write SetForwardContext;
Public | property FragmentShaderDerivitiveHint: TgxHintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;
Public | property FrontFace: TgxFaceWinding read FFrontFace write SetFrontFace;
Public | property InsideList: Boolean read FInsideList;
Public | property LightAmbient[Index: Integer]: TVector4f read GetLightAmbient write SetLightAmbient;
Public | property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;
Public | property LightDiffuse[Index: Integer]: TVector4f read GetLightDiffuse write SetLightDiffuse;
Public | property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;
Public | property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;
Public | property LightNumber: Integer read FLightNumber;
Public | property LightPosition[Index: Integer]: TVector4f read GetLightPosition write SetLightPosition;
Public | property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;
Public | property LightSpecular[Index: Integer]: TVector4f read GetLightSpecular write SetLightSpecular;
Public | property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;
Public | property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;
Public | property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;
Public | property LineSmoothHint: TgxHintType read FLineSmoothHint write SetLineSmoothHint;
Public | property LineStippleFactor: GLint read FLineStippleFactor write SetLineStippleFactor;
Public | property LineStipplePattern: GLushort read FLineStipplePattern write SetLineStipplePattern;
Public | property LineWidth: Single read FLineWidth write SetLineWidth;
Public | property LogicOpMode: TgxLogicOp read FLogicOpMode write SetLogicOpMode;
Public | property MaterialAmbient[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialAmbient;
Public | property MaterialDiffuse[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialDiffuse;
Public | property MaterialEmission[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialEmission;
Public | property MaterialShininess[const aFace: TgxCullFaceMode]: Integer read GetMaterialShininess;
Public | property MaterialSpecular[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialSpecular;
Public | property Max3DTextureSize: GLuint read GetMax3DTextureSize;
Public | property MaxArrayTextureSize: GLuint read GetMaxArrayTextureSize;
Public | property MaxCubeTextureSize: GLuint read GetMaxCubeTextureSize;
Public | property MaxLights: Integer read GetMaxLights;
Public | property MaxSamples: GLuint read GetMaxSamples;
Public | property MaxTextureAnisotropy: GLuint read GetMaxTextureAnisotropy;
Public | property MaxTextureImageUnits: GLuint read GetMaxTextureImageUnits;
Public | property MaxTextureSize: GLuint read GetMaxTextureSize;
Public | property MaxTextureUnits: GLuint read GetMaxTextureUnits;
Public | property MultisampleFilterHint: TgxHintType read FMultisampleFilterHint write SetMultisampleFilterHint;
Public | property OnLightsChanged: TgxOnLightsChanged read FOnLightsChanged write FOnLightsChanged;
Public | property PackAlignment: GLuint read FPackAlignment write SetPackAlignment;
Public | property PackImageHeight: GLuint read FPackImageHeight write SetPackImageHeight;
Public | property PackLSBFirst: GLboolean read FPackLSBFirst write SetPackLSBFirst;
Public | property PackRowLength: GLuint read FPackRowLength write SetPackRowLength;
Public | property PackSkipImages: GLuint read FPackSkipImages write SetPackSkipImages;
Public | property PackSkipPixels: GLuint read FPackSkipPixels write SetPackSkipPixels;
Public | property PackSkipRows: GLuint read FPackSkipRows write SetPackSkipRows;
Public | property PackSwapBytes: GLboolean read FPackSwapBytes write SetPackSwapBytes;
Public | property PixelPackBufferBinding: GLuint read FPixelPackBufferBinding write SetPixelPackBufferBinding;
Public | property PixelUnpackBufferBinding: GLuint read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;
Public | property PointFadeThresholdSize: Single read FPointFadeThresholdSize write SetPointFadeThresholdSize;
Public | property PointSize: Single read FPointSize write SetPointSize;
Public | property PointSpriteCoordOrigin: GLEnum read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;
Public | property PolygonMode: TgxPolygonMode read FPolygonMode write SetPolygonMode;
Public | property PolygonOffsetFactor: Single read FPolygonOffsetFactor write SetPolygonOffsetFactor;
Public | property PolygonOffsetUnits: Single read FPolygonOffsetUnits write SetPolygonOffsetUnits;
Public | property PolygonSmoothHint: TgxHintType read FPolygonSmoothHint write SetPolygonSmoothHint;
Public | property PrimitiveRestartIndex: GLuint read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;
Public | property ProvokingVertex: GLEnum read FProvokingVertex write SetProvokingVertex;
Public | property ReadFrameBuffer: GLuint read FReadFrameBuffer write SetReadFrameBuffer;
Public | property RenderBuffer: GLuint read FRenderBuffer write SetRenderBuffer;
Public | property SampleCoverageInvert: GLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;
Public | property SampleCoverageValue: Single read FSampleCoverageValue write SetSampleCoverageValue;
Public | property SampleMaskValue[Index: Integer]: GLbitfield read GetSampleMaskValue write SetSampleMaskValue;
Public | property SamplerBinding[Index: GLuint]: GLuint read GetSamplerBinding write SetSamplerBinding;
Public | property ScissorBox: TVector4i read FScissorBox write SetScissorBox;
Public | property States: TgxStates read FStates;
Public | property StencilBackFail: TgxStencilOp read FStencilBackFail;
Public | property StencilBackFunc: TgxStencilFunction read FStencilBackFunc;
Public | property StencilBackPassDepthFail: TgxStencilOp read FStencilBackPassDepthFail;
Public | property StencilBackPassDepthPass: TgxStencilOp read FStencilBackPassDepthPass;
Public | property StencilBackRef: GLuint read FStencilBackRef;
Public | property StencilBackValueMask: GLuint read FStencilBackValueMask;
Public | property StencilBackWriteMask: GLuint read FStencilBackWriteMask write SetStencilBackWriteMask;
Public | property StencilClearValue: GLuint read FStencilClearValue write SetStencilClearValue;
Public | property StencilFail: TgxStencilOp read FStencilFail;
Public | property StencilFunc: TgxStencilFunction read FStencilFunc;
Public | property StencilPassDepthFail: TgxStencilOp read FStencilPassDepthFail;
Public | property StencilPassDepthPass: TgxStencilOp read FStencilPassDepthPass;
Public | property StencilRef: GLint read FStencilRef;
Public | property StencilValueMask: GLuint read FStencilValueMask;
Public | property StencilWriteMask: GLuint read FStencilWriteMask write SetStencilWriteMask;
Public | property TextureBinding[Index: Integer; target: TglTextureTarget]: GLuint read GetTextureBinding write SetTextureBinding;
Public | property TextureBindingTime[Index: Integer; target: TglTextureTarget]: Double read GetTextureBindingTime;
Public | property TextureBufferBinding: GLuint read FTextureBufferBinding write SetTextureBufferBinding;
Public | property TextureCompressionHint: TgxHintType read FTextureCompressionHint write SetTextureCompressionHint;
Public | property TransformFeedbackBufferBinding: GLuint read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;
Public | property UniformBufferBinding: GLuint read FUniformBufferBinding write SetUniformBufferBinding;
Public | property UnpackAlignment: GLuint read FUnpackAlignment write SetUnpackAlignment;
Public | property UnpackImageHeight: GLuint read FUnpackImageHeight write SetUnpackImageHeight;
Public | property UnpackLSBFirst: GLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;
Public | property UnpackRowLength: GLuint read FUnpackRowLength write SetUnpackRowLength;
Public | property UnpackSkipImages: GLuint read FUnpackSkipImages write SetUnpackSkipImages;
Public | property UnpackSkipPixels: GLuint read FUnpackSkipPixels write SetUnpackSkipPixels;
Public | property UnpackSkipRows: GLuint read FUnpackSkipRows write SetUnpackSkipRows;
Public | property UnpackSwapBytes: GLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;
Public | property VertexArrayBinding: GLuint read FVertexArrayBinding write SetVertexArrayBinding;
Public | property ViewPort: TVector4i read FViewPort write SetViewPort;

Description

Fields

Private FFrontBackColors: array[0..1, 0..3] of TVector4f;

Legacy state

Private FFrontBackShininess: array[0..1] of Integer;

This item has no description.

Private FAlphaFunc: TgxComparisonFunction;

This item has no description.

Private FAlphaRef: Single;

This item has no description.

Private FPolygonBackMode: TgxPolygonMode;

This item has no description.

Private FMaxLights: Cardinal;

Front + back have same polygon mode Lighting state

Private FLightEnabling: array[0..MAX_HARDWARE_LIGHT - 1] of Boolean;

This item has no description.

Private FLightIndices: array[0..MAX_HARDWARE_LIGHT - 1] of GLint;

This item has no description.

Private FLightNumber: Integer;

This item has no description.

Private FLightStates: TgxLightSourceState;

This item has no description.

Private FSpotCutoff: array[0..MAX_HARDWARE_LIGHT-1] of Single;

This item has no description.

Private FShaderLightStates: TgxShaderLightSourceState;

This item has no description.

Private FShaderLightStatesChanged: Boolean;

This item has no description.

Private FColorWriting: Boolean;

This item has no description.

Private FStates: TgxStates;

TODO: change to per draw buffer (FColorWriteMask)

Private FListStates: array of TgxStateTypes;

This item has no description.

Private FCurrentList: Cardinal;

This item has no description.

Private FTextureMatrixIsIdentity: array[0..3] of Boolean;

This item has no description.

Private FForwardContext: Boolean;

This item has no description.

Private FFFPLight: Boolean;

This item has no description.

Private FVertexArrayBinding: Cardinal;

Vertex Array Data state

Private FArrayBufferBinding: Cardinal;

This item has no description.

Private FElementBufferBinding: Cardinal;

This item has no description.

Private FTextureBufferBinding: Cardinal;

This item has no description.

Private FEnablePrimitiveRestart: GLboolean;

This item has no description.

Private FPrimitiveRestartIndex: Cardinal;

This item has no description.

Private FViewPort: TVector4i;

Transformation state

Private FDepthRange: array[0..1] of GLclampd;

This item has no description.

Private FEnableClipDistance: array[0..7] of GLboolean;

This item has no description.

Private FEnableDepthClamp: GLboolean;

This item has no description.

Private FClampReadColor: Cardinal;

Coloring state

Private FProvokingVertex: Cardinal;

GL_FIXED_ONLY

Private FPointSize: Single;

GL_LAST_VERTEX_CONVENTION Rasterization state

Private FPointFadeThresholdSize: Single;

This item has no description.

Private FPointSpriteCoordOrigin: Cardinal;

This item has no description.

Private FLineWidth: Single;

GL_UPPER_LEFT

Private FLineStippleFactor: GLint;

This item has no description.

Private FLineStipplePattern: GLushort;

This item has no description.

Private FEnableLineSmooth: GLboolean;

This item has no description.

Private FEnableCullFace: GLboolean;

This item has no description.

Private FCullFaceMode: TgxCullFaceMode;

This item has no description.

Private FFrontFace: TgxFaceWinding;

This item has no description.

Private FEnablePolygonSmooth: GLboolean;

This item has no description.

Private FPolygonMode: TgxPolygonMode;

This item has no description.

Private FPolygonOffsetFactor: Single;

This item has no description.

Private FPolygonOffsetUnits: Single;

This item has no description.

Private FEnablePolygonOffsetPoint: GLboolean;

This item has no description.

Private FEnablePolygonOffsetLine: GLboolean;

This item has no description.

Private FEnablePolygonOffsetFill: GLboolean;

This item has no description.

Private FEnableMultisample: GLboolean;

Multisample state

Private FEnableSampleAlphaToCoverage: GLboolean;

This item has no description.

Private FEnableSampleAlphaToOne: GLboolean;

This item has no description.

Private FEnableSampleCoverage: GLboolean;

This item has no description.

Private FSampleCoverageValue: Single;

This item has no description.

Private FSampleCoverageInvert: GLboolean;

This item has no description.

Private FEnableSampleMask: GLboolean;

This item has no description.

Private FSampleMaskValue: array[0..15] of GLbitfield;

This item has no description.

Private FMaxTextureSize: Cardinal;

Texture state

Private FMax3DTextureSize: Cardinal;

This item has no description.

Private FMaxCubeTextureSize: Cardinal;

This item has no description.

Private FMaxArrayTextureSize: Cardinal;

This item has no description.

Private FMaxTextureImageUnits: Cardinal;

This item has no description.

Private FMaxTextureAnisotropy: Cardinal;

This item has no description.

Private FMaxSamples: Cardinal;

This item has no description.

Private FTextureBinding: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Cardinal;

This item has no description.

Private FTextureBindingTime: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Double;

This item has no description.

Private FSamplerBinding: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1] of Cardinal;

This item has no description.

Private FActiveTexture: GLint;

Active texture state

Private FActiveTextureEnabling: array[0..MAX_HARDWARE_TEXTURE_UNIT - 1, TglTextureTarget] of Boolean;

0 .. Max_texture_units

Private FEnableScissorTest: GLboolean;

Pixel operation state

Private FScissorBox: TVector4i;

This item has no description.

Private FEnableStencilTest: GLboolean;

This item has no description.

Private FStencilFunc: TgxStencilFunction;

This item has no description.

Private FStencilValueMask: Cardinal;

This item has no description.

Private FStencilRef: GLint;

This item has no description.

Private FStencilFail: TgxStencilOp;

This item has no description.

Private FStencilPassDepthFail: TgxStencilOp;

This item has no description.

Private FStencilPassDepthPass: TgxStencilOp;

This item has no description.

Private FStencilBackFunc: TgxStencilFunction;

This item has no description.

Private FStencilBackValueMask: GLuint;

This item has no description.

Private FStencilBackRef: GLuint;

This item has no description.

Private FStencilBackFail: TgxStencilOp;

This item has no description.

Private FStencilBackPassDepthPass: TgxStencilOp;

This item has no description.

Private FStencilBackPassDepthFail: TgxStencilOp;

This item has no description.

Private FEnableDepthTest: GLboolean;

This item has no description.

Private FDepthFunc: TgxDepthFunction;

This item has no description.

Private FEnableBlend: array[0..15] of GLboolean;

This item has no description.

Private FBlendSrcRGB: TgxBlendFunction;

This item has no description.

Private FBlendSrcAlpha: TgxBlendFunction;

This item has no description.

Private FBlendDstRGB: TgxDstBlendFunction;

This item has no description.

Private FBlendDstAlpha: TgxDstBlendFunction;

This item has no description.

Private FBlendEquationRGB: TgxBlendEquation;

This item has no description.

Private FBlendEquationAlpha: TgxBlendEquation;

This item has no description.

Private FBlendColor: TVector4f;

This item has no description.

Private FEnableFramebufferSRGB: GLboolean;

This item has no description.

Private FEnableDither: GLboolean;

This item has no description.

Private FEnableColorLogicOp: GLboolean;

This item has no description.

Private FLogicOpMode: TgxLogicOp;

This item has no description.

Private FColorWriteMask: array[0..15] of TgxColorMask;

Framebuffer control state

Private FDepthWriteMask: Boolean;

This item has no description.

Private FStencilWriteMask: GLuint;

This item has no description.

Private FStencilBackWriteMask: GLuint;

This item has no description.

Private FColorClearValue: TVector4f;

This item has no description.

Private FDepthClearValue: Single;

This item has no description.

Private FStencilClearValue: GLuint;

This item has no description.

Private FDrawFrameBuffer: Cardinal;

Framebuffer state

Private FReadFrameBuffer: Cardinal;

This item has no description.

Private FRenderBuffer: Cardinal;

Renderbuffer state

Private FUnpackSwapBytes: GLboolean;

Pixels state

Private FUnpackLSBFirst: GLboolean;

This item has no description.

Private FUnpackImageHeight: GLuint;

This item has no description.

Private FUnpackSkipImages: GLuint;

This item has no description.

Private FUnpackRowLength: GLuint;

This item has no description.

Private FUnpackSkipRows: GLuint;

This item has no description.

Private FUnpackSkipPixels: GLuint;

This item has no description.

Private FUnpackAlignment: Cardinal;

This item has no description.

Private FPackSwapBytes: GLboolean;

This item has no description.

Private FPackLSBFirst: GLboolean;

This item has no description.

Private FPackImageHeight: GLuint;

This item has no description.

Private FPackSkipImages: GLuint;

This item has no description.

Private FPackRowLength: GLuint;

This item has no description.

Private FPackSkipRows: GLuint;

This item has no description.

Private FPackSkipPixels: GLuint;

This item has no description.

Private FPackAlignment: GLuint;

This item has no description.

Private FPixelPackBufferBinding: GLuint;

This item has no description.

Private FPixelUnpackBufferBinding: GLuint;

This item has no description.

Private FCurrentProgram: GLuint;

Program state

Private FMaxTextureUnits: GLuint;

This item has no description.

Private FUniformBufferBinding: GLuint;

This item has no description.

Private FUBOStates: array[TgxBufferBindingTarget, 0..MAX_HARDWARE_UNIFORM_BUFFER_BINDING-1] of TUBOStates;

This item has no description.

Private FCurrentVertexAttrib: array[0..15] of TVector4f;

Vector + Geometry Shader state

Private FEnableProgramPointSize: GLboolean;

This item has no description.

Private FTransformFeedbackBufferBinding: Cardinal;

Transform Feedback state

Private FTextureCompressionHint: TgxHintType;

Hints state

Private FPolygonSmoothHint: TgxHintType;

This item has no description.

Private FFragmentShaderDerivitiveHint: TgxHintType;

This item has no description.

Private FLineSmoothHint: TgxHintType;

This item has no description.

Private FMultisampleFilterHint: TgxHintType;

This item has no description.

Private FCurrentQuery: array[TgxQueryType] of GLuint;

Misc state

Private FCopyReadBufferBinding: GLuint;

This item has no description.

Private FCopyWriteBufferBinding: GLuint;

This item has no description.

Private FEnableTextureCubeMapSeamless: GLboolean;

This item has no description.

Private FInsideList: Boolean;

This item has no description.

Private FOnLightsChanged: TgxOnLightsChanged;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetLightIndicesAsAddress: PGLInt;

This item has no description.

Public function GetLightStateAsAddress: Pointer;

This item has no description.

Public procedure BeginQuery(const Target: TgxQueryType; const Value: GLuint);

Begins a query of "Target" type. "Value" must be a valid query object

Public procedure CallList(list: Cardinal); inline;

Call display list

Public procedure Disable(const aState: TgxState);

This item has no description.

Public procedure Enable(const aState: TgxState);

This item has no description.

Public procedure EndList; inline;

End display list

Public procedure EndQuery(const Target: TgxQueryType); inline;

Ends current query of type "Target".

Public procedure InvertFrontFace; inline;

Inverts front face winding (CCW/CW)

Public procedure NewList(list: GLuint; mode: GLEnum); inline;

Begin new display list

Public procedure PerformDisable(const aState: TgxState);

This item has no description.

Public procedure PerformEnable(const aState: TgxState);

This item has no description.

Public procedure PopAttrib();

This item has no description.

Public procedure PushAttrib(stateTypes: TgxStateTypes);

This item has no description.

Public procedure ResetAll; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetAllTextureMatrix; inline;

This item has no description.

Public procedure ResetCurrentTexture; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetFrontFace; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetMaterialColors; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetPolygonMode; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetTexture(const TextureUnit: Integer); deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure ResetTextureMatrix; inline;

This item has no description.

Public procedure SetAlphaFunction(func: TgxComparisonFunction; ref: Single);

Blending states

Public procedure SetBlendEquation(const mode: TgxBlendEquation);

write SetBlendEquationAlpha; Sets the blend equation for RGB + alpha to the same value.

Public procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TgxBlendEquation);

Sets the blend equations for RGB + alpha separately.

Public procedure SetBlendFunc(const Src: TgxBlendFunction; const Dst: TgxDstBlendFunction);

Sets the weighting factors to be used by the blending equation, for both color + alpha.

Public procedure SetBlendFuncSeparate(const SrcRGB: TgxBlendFunction; const DstRGB: TgxDstBlendFunction; const SrcAlpha: TgxBlendFunction; const DstAlpha: TgxDstBlendFunction); inline;

Sets the weighting factors to be used by the blending equation, with separate values used for color + alpha components.

Public procedure SetBufferIndexedBinding(const Value: GLuint; ATarget: TgxBufferBindingTarget; AIndex: GLuint; AOffset: GLint; ARangeSize: PGLsizei); overload;

This item has no description.

Public procedure SetBufferIndexedBinding(const Value: GLuint; ATarget: TgxBufferBindingTarget; AIndex: GLuint; ABufferSize: PGLsizei); overload;

This item has no description.

Public procedure SetColorMask(mask: TgxColorMask);

Set the color write mask for all draw buffers.

Public procedure SetColorWriting(flag: Boolean); inline;

note: needs to change to per draw-buffer

Public procedure SetDepthRange(const ZNear, ZFar: GLclampd);

Modifies the near + far clipping planes.

Public procedure SetFrameBuffer(const Value: GLuint);

set both draw + read framebuffer.

Public procedure SetGLFrontFaceCW; deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure SetMaterialAlphaChannel(const aFace: GLEnum; const alpha: Single);

Adjusts material alpha channel for a face.

Public procedure SetMaterialColors(const aFace: TgxCullFaceMode; const emission, ambient, diffuse, specular: TVector4f; const shininess: Integer);

Adjusts material colors for a face.

Public procedure SetMaterialDiffuseColor(const aFace: GLEnum; const diffuse: TVector4f);

Adjusts material diffuse color for a face.

Public procedure SetPolygonOffset(const factor, units: Single);

Set polygon offset.

Public procedure SetSampleCoverage(const Value: Single; invert: GLboolean);

Set sample coverage

Public procedure SetStencilFunc(const func: TgxStencilFunction; const ref: GLint; const mask: GLuint);

Used to set stencil Function, Reference + Mask values, for both front + back facing primitives.

Public procedure SetStencilFuncSeparate(const face: TgxCullFaceMode; const func: TgxStencilFunction; const ref: GLint; const mask: GLuint); inline;

Used to set stencil Function, Reference + Mask values for either the front or back facing primitives (or both, which is the same as calling SetStencilFunc).

Public procedure SetStencilOp(const fail, zfail, zpass: TgxStencilOp); inline;

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go.

Public procedure SetStencilOpSeparate(const face: TgxCullFaceMode; const sfail, dpfail, dppass: TgxStencilOp);

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go, for either front or back facing primitives.

Public procedure SetTextureMatrix(const matrix: TMatrix4f); inline;

Defines the OpenGL texture matrix. Assumed texture mode is GL_MODELVIEW.

Public procedure SetVxState(const aState : TgxState); deprecated;

Warning: this symbol is deprecated.

This item has no description.

Public procedure UnSetVxState(const aState : TgxState); deprecated;

Warning: this symbol is deprecated.

This item has no description.

Properties

Public property ActiveTexture: GLint read FActiveTexture write SetActiveTexture;

The active texture unit. Valid values are 0 .. Max texture units.

Public property ActiveTextureEnabled[Target: TglTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;

This item has no description.

Public property ArrayBufferBinding: GLuint read GetArrayBufferBinding write SetArrayBufferBinding;

The currently bound vertex buffer object (VAO).

Public property BlendColor: TVector4f read FBlendColor write SetBlendColor;

A constant blend color, that can be used in the blend equation.

Public property BlendDstAlpha: TgxDstBlendFunction read FBlendDstAlpha;

The weighting factor used in blending equation, for destination alpha.

Public property BlendDstRGB: TgxDstBlendFunction read FBlendDstRGB;

The weighting factor used in blending equation, for destination RGB.

Public property BlendEquationAlpha: TgxBlendEquation read FBlendEquationAlpha;

The blending equation. Determines how the incoming source fragment's alpha values are combined with the destination alpha values.

Public property BlendEquationRGB: TgxBlendEquation read FBlendEquationRGB;

The blending equation. Determines how the incoming source fragment's RGB are combined with the destination RGB.

Public property BlendSrcAlpha: TgxBlendFunction read FBlendSrcAlpha;

The weighting factor used in blending equation, for source alpha.

Public property BlendSrcRGB: TgxBlendFunction read FBlendSrcRGB;

The weighting factor used in blending equation, for source RGB.

Public property ClampReadColor: GLEnum read FClampReadColor write SetClampReadColor;

Coloring state. Controls read color clamping.

Public property ColorClearValue: TVector4f read FColorClearValue write SetColorClearValue;

The color clear value.

Public property ColorWriteMask[Index: Integer]: TgxColorMask read GetColorWriteMask write SetColorWriteMask;

The color write mask, for each draw buffer.

Public property CopyReadBufferBinding: GLuint read FCopyReadBufferBinding write SetCopyReadBufferBinding;

The buffer currently bound to the copy read buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CopyWriteBufferBinding: GLuint read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;

The buffer currently bound to the copy write buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CullFaceMode: TgxCullFaceMode read FCullFaceMode write SetCullFaceMode;

Selects which faces to cull: front, back or front+back.

Public property CurrentProgram: GLuint read FCurrentProgram write SetCurrentProgram;

Currently bound program

Public property CurrentQuery[Index: TgxQueryType]: GLuint read GetCurrentQuery;

Current queries. Misc

Public property CurrentVertexAttrib[Index: Integer]: TVector4f read GetCurrentVertexAttrib write SetCurrentVertexAttrib;

Default values to be used when a vertex array is not used for that attribute

Public property DepthClearValue: Single read FDepthClearValue write SetDepthClearValue;

The depth clear value.

Public property DepthFunc: TgxDepthFunction read FDepthFunc write SetDepthFunc;

The depth function. Used to determine whether to keep a fragment or discard it, depending on the current value stored in the depth buffer.

Public property DepthRangeFar: GLclampd read GetDepthRangeFar write SetDepthRangeFar;

The far clipping plane distance.

Public property DepthRangeNear: GLclampd read GetDepthRangeNear write SetDepthRangeNear;

The near clipping plane distance.

Public property DepthWriteMask: Boolean read FDepthWriteMask write SetDepthWriteMask;

The depth write mask.

Public property DrawFrameBuffer: GLuint read FDrawFrameBuffer write SetDrawFrameBuffer;

Framebuffer to be used for draw operations, 0 = default framebuffer.

Public property ElementBufferBinding: GLuint read GetElementBufferBinding write SetElementBufferBinding;

The currently bound element buffer object (EBO).

Public property EnableBlend[Index: Integer]: GLboolean read GetEnableBlend write SetEnableBlend;

Enables/disables blending for each draw buffer.

Public property EnableClipDistance[Index: Cardinal]: GLboolean read GetEnableClipDistance write SetEnableClipDistance;

Enables/Disables each of the clip distances, used in shaders.

Public property EnableColorLogicOp: GLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;

Enables/disables color logic op.

Public property EnableCullFace: GLboolean read FEnableCullFace write SetEnableCullFace;

Enable/Disable face culling.

Public property EnableDepthClamp: GLboolean read FEnableDepthClamp write SetEnableDepthClamp;

Enables/Disables depth clamping.

Public property EnableDepthTest: GLboolean read FEnableDepthTest write SetEnableDepthTest;

Enables/disables depth testing.

Public property EnableDither: GLboolean read FEnableDither write SetEnableDither;

Enables/disables dithering.

Public property EnableFramebufferSRGB: GLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;

Enables/disables framebuffer SRGB.

Public property EnableLineSmooth: GLboolean read FEnableLineSmooth write SetEnableLineSmooth;

Enable/Disable line smoothing.

Public property EnableMultisample: GLboolean read FEnableMultisample write SetEnableMultisample;

Multisample state Enable/Disable multisampling

Public property EnablePolygonOffsetFill: GLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;

Enable/Disable polygon offset for polygons in fill mode.

Public property EnablePolygonOffsetLine: GLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;

Enable/Disable polygon offset for polygons in line mode.

Public property EnablePolygonOffsetPoint: GLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;

Enable/Disable polygon offset for polygons in point mode.

Public property EnablePolygonSmooth: GLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;

Enables/Disables polygon smoothing.

Public property EnablePrimitiveRestart: GLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;

Determines whether primitive restart is turned on or off.

Public property EnableProgramPointSize: GLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;

Enables/disables program point size

Public property EnableSampleAlphaToCoverage: GLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;

Enable/Disable sample alpha to coverage

Public property EnableSampleAlphaToOne: GLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;

Enable/Disable sample alpha to one

Public property EnableSampleCoverage: GLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;

Enable/Disable sample coverage

Public property EnableSampleMask: GLboolean read FEnableSampleMask write SetEnableSampleMask;

Enable/Disable sample mask

Public property EnableScissorTest: GLboolean read FEnableScissorTest write SetEnableScissorTest;

Enables/Disables scissor test.

Public property EnableStencilTest: GLboolean read FEnableStencilTest write SetEnableStencilTest;

Enables/Disables stencil test.

Public property EnableTextureCubeMapSeamless: GLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;

Enables/Disables seamless texture cube maps.

Public property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;

Lighting states

Public property ForwardContext: Boolean read FForwardContext write SetForwardContext;

True for ignore deprecated and removed features in OpenGL 3x

Public property FragmentShaderDerivitiveHint: TgxHintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;

Fragment shader derivitive hint

Public property FrontFace: TgxFaceWinding read FFrontFace write SetFrontFace;

The winding direction that indicates a front facing primitive.

Public property InsideList: Boolean read FInsideList;

Indicates the current presence within the list

Public property LightAmbient[Index: Integer]: TVector4f read GetLightAmbient write SetLightAmbient;

This item has no description.

Public property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;

This item has no description.

Public property LightDiffuse[Index: Integer]: TVector4f read GetLightDiffuse write SetLightDiffuse;

This item has no description.

Public property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;

This item has no description.

Public property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;

This item has no description.

Public property LightNumber: Integer read FLightNumber;

This item has no description.

Public property LightPosition[Index: Integer]: TVector4f read GetLightPosition write SetLightPosition;

This item has no description.

Public property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;

This item has no description.

Public property LightSpecular[Index: Integer]: TVector4f read GetLightSpecular write SetLightSpecular;

This item has no description.

Public property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;

This item has no description.

Public property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;

This item has no description.

Public property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;

This item has no description.

Public property LineSmoothHint: TgxHintType read FLineSmoothHint write SetLineSmoothHint;

Line smooth hint

Public property LineStippleFactor: GLint read FLineStippleFactor write SetLineStippleFactor;

The line stipple.

Public property LineStipplePattern: GLushort read FLineStipplePattern write SetLineStipplePattern;

The line stipple.

Public property LineWidth: Single read FLineWidth write SetLineWidth;

The line width.

Public property LogicOpMode: TgxLogicOp read FLogicOpMode write SetLogicOpMode;

Logic op mode.

Public property MaterialAmbient[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialAmbient;

This item has no description.

Public property MaterialDiffuse[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialDiffuse;

This item has no description.

Public property MaterialEmission[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialEmission;

This item has no description.

Public property MaterialShininess[const aFace: TgxCullFaceMode]: Integer read GetMaterialShininess;

This item has no description.

Public property MaterialSpecular[const aFace: TgxCullFaceMode]: TVector4f read GetMaterialSpecular;

This item has no description.

Public property Max3DTextureSize: GLuint read GetMax3DTextureSize;

This item has no description.

Public property MaxArrayTextureSize: GLuint read GetMaxArrayTextureSize;

This item has no description.

Public property MaxCubeTextureSize: GLuint read GetMaxCubeTextureSize;

This item has no description.

Public property MaxLights: Integer read GetMaxLights;

This item has no description.

Public property MaxSamples: GLuint read GetMaxSamples;

This item has no description.

Public property MaxTextureAnisotropy: GLuint read GetMaxTextureAnisotropy;

This item has no description.

Public property MaxTextureImageUnits: GLuint read GetMaxTextureImageUnits;

This item has no description.

Public property MaxTextureSize: GLuint read GetMaxTextureSize;

This item has no description.

Public property MaxTextureUnits: GLuint read GetMaxTextureUnits;

This item has no description.

Public property MultisampleFilterHint: TgxHintType read FMultisampleFilterHint write SetMultisampleFilterHint;

This item has no description.

Public property OnLightsChanged: TgxOnLightsChanged read FOnLightsChanged write FOnLightsChanged;

This item has no description.

Public property PackAlignment: GLuint read FPackAlignment write SetPackAlignment;

Pack alignment

Public property PackImageHeight: GLuint read FPackImageHeight write SetPackImageHeight;

Pack image height

Public property PackLSBFirst: GLboolean read FPackLSBFirst write SetPackLSBFirst;

Whether packed data is required with LSB (least significant bit) first.

Public property PackRowLength: GLuint read FPackRowLength write SetPackRowLength;

Pack row length

Public property PackSkipImages: GLuint read FPackSkipImages write SetPackSkipImages;

Pack skip images

Public property PackSkipPixels: GLuint read FPackSkipPixels write SetPackSkipPixels;

Pack skip pixels

Public property PackSkipRows: GLuint read FPackSkipRows write SetPackSkipRows;

Pack skip rows

Public property PackSwapBytes: GLboolean read FPackSwapBytes write SetPackSwapBytes;

Controls whether byte swapping occurs during pixel packing.

Public property PixelPackBufferBinding: GLuint read FPixelPackBufferBinding write SetPixelPackBufferBinding;

Buffer bound for pixel packing (eg. ReadPixels)

Public property PixelUnpackBufferBinding: GLuint read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;

Buffer bound for pixel unpacking (eg. Tex*Image)

Public property PointFadeThresholdSize: Single read FPointFadeThresholdSize write SetPointFadeThresholdSize;

If multisampling is enabled, this can control when points are faded out.

Public property PointSize: Single read FPointSize write SetPointSize;

The default point size, used when EnableProgramPointSize = false.

Public property PointSpriteCoordOrigin: GLEnum read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;

The texture coordinate origin of point sprites.

Public property PolygonMode: TgxPolygonMode read FPolygonMode write SetPolygonMode;

Whether polygons appear filled, lines or points.

Public property PolygonOffsetFactor: Single read FPolygonOffsetFactor write SetPolygonOffsetFactor;

Scales the maximum depth of the polygon.

Public property PolygonOffsetUnits: Single read FPolygonOffsetUnits write SetPolygonOffsetUnits;

Scales an implementation-dependent constant that relates to the usable resolution of the depth buffer.

Public property PolygonSmoothHint: TgxHintType read FPolygonSmoothHint write SetPolygonSmoothHint;

Polygon smooth hint

Public property PrimitiveRestartIndex: GLuint read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;

The index Value that causes a primitive restart.

Public property ProvokingVertex: GLEnum read FProvokingVertex write SetProvokingVertex;

The provoking vertex used in flat shading. All the vertices of each primitive will the same value determined by this property.

Public property ReadFrameBuffer: GLuint read FReadFrameBuffer write SetReadFrameBuffer;

Framebuffer to be used for read operations, 0 = default framebuffer.

Public property RenderBuffer: GLuint read FRenderBuffer write SetRenderBuffer;

Currently bound render buffer.

Public property SampleCoverageInvert: GLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;

Inverts sample coverage Value

Public property SampleCoverageValue: Single read FSampleCoverageValue write SetSampleCoverageValue;

Sample coverage Value

Public property SampleMaskValue[Index: Integer]: GLbitfield read GetSampleMaskValue write SetSampleMaskValue;

Sample mask values

Public property SamplerBinding[Index: GLuint]: GLuint read GetSamplerBinding write SetSamplerBinding;

This item has no description.

Public property ScissorBox: TVector4i read FScissorBox write SetScissorBox;

The bounding box used in scissor test.

Public property States: TgxStates read FStates;

read only properties

Public property StencilBackFail: TgxStencilOp read FStencilBackFail;

The operation to perform when stencil test fails on back facing primitives.

Public property StencilBackFunc: TgxStencilFunction read FStencilBackFunc;

The stencil back function. Determines the comparison function to be used when comparing the reference + stored stencil values on back facing primitives.

Public property StencilBackPassDepthFail: TgxStencilOp read FStencilBackPassDepthFail;

The operation to perform when stencil test passes + depth test fails on back facing primitives.

Public property StencilBackPassDepthPass: TgxStencilOp read FStencilBackPassDepthPass;

The operation to perform when stencil test passes + depth test passes on back facing primitives.

Public property StencilBackRef: GLuint read FStencilBackRef;

The stencil back reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilBackValueMask: GLuint read FStencilBackValueMask;

The stencil back value mask. Masks both the reference + stored stencil values.

Public property StencilBackWriteMask: GLuint read FStencilBackWriteMask write SetStencilBackWriteMask;

The stencil back write mask.

Public property StencilClearValue: GLuint read FStencilClearValue write SetStencilClearValue;

The stencil clear value.

Public property StencilFail: TgxStencilOp read FStencilFail;

write SetStencilRef; The operation to perform when stencil test fails.

Public property StencilFunc: TgxStencilFunction read FStencilFunc;

The stencil function. Determines the comparison function to be used when comparing the reference + stored stencil values.

Public property StencilPassDepthFail: TgxStencilOp read FStencilPassDepthFail;

write SetStencilFail; The operation to perform when stencil test passes + depth test fails.

Public property StencilPassDepthPass: TgxStencilOp read FStencilPassDepthPass;

The operation to perform when stencil test passes + depth test passes.

Public property StencilRef: GLint read FStencilRef;

The stencil reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilValueMask: GLuint read FStencilValueMask;

The stencil value mask. Masks both the reference + stored stencil values

Public property StencilWriteMask: GLuint read FStencilWriteMask write SetStencilWriteMask;

The stencil write mask.

Public property TextureBinding[Index: Integer; target: TglTextureTarget]: GLuint read GetTextureBinding write SetTextureBinding;

Textures Textures bound to each texture unit + binding point.

Public property TextureBindingTime[Index: Integer; target: TglTextureTarget]: Double read GetTextureBindingTime;

This item has no description.

Public property TextureBufferBinding: GLuint read FTextureBufferBinding write SetTextureBufferBinding;

The currently bound texture buffer object (TBO).

Public property TextureCompressionHint: TgxHintType read FTextureCompressionHint write SetTextureCompressionHint;

Texture compression hint

Public property TransformFeedbackBufferBinding: GLuint read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;

Currently bound transform feedbac buffer

Public property UniformBufferBinding: GLuint read FUniformBufferBinding write SetUniformBufferBinding;

Currently bound uniform buffer

Public property UnpackAlignment: GLuint read FUnpackAlignment write SetUnpackAlignment;

Unpack alignment.

Public property UnpackImageHeight: GLuint read FUnpackImageHeight write SetUnpackImageHeight;

Unpack image height.

Public property UnpackLSBFirst: GLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;

Whether unpacked data is required with LSB (least significant bit) first.

Public property UnpackRowLength: GLuint read FUnpackRowLength write SetUnpackRowLength;

Unpack row length.

Public property UnpackSkipImages: GLuint read FUnpackSkipImages write SetUnpackSkipImages;

Unpack skip images.

Public property UnpackSkipPixels: GLuint read FUnpackSkipPixels write SetUnpackSkipPixels;

Unpack skip pixels.

Public property UnpackSkipRows: GLuint read FUnpackSkipRows write SetUnpackSkipRows;

Unpack skip rows.

Public property UnpackSwapBytes: GLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;

Controls whether byte swapping occurs during pixel unpacking.

Public property VertexArrayBinding: GLuint read FVertexArrayBinding write SetVertexArrayBinding;

The currently bound array buffer (calling glVertexAttribPointer locks this buffer to the currently bound VBO).

Public property ViewPort: TVector4i read FViewPort write SetViewPort;

Transformation state


GXSysHelp v.2.5: GXS.State: Record TgxStateRecord

Record TgxStateRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.State

Declaration

type TgxStateRecord = record

Description

This item has no description.

Overview

Fields

Public | GLConst: Cardinal;
Public | VKConst: Cardinal;
Public | IsDeprecated: Boolean;

Description

Fields

Public GLConst: Cardinal;

This item has no description.

Public VKConst: Cardinal;

OpenGL

Public IsDeprecated: Boolean;

Vulkan


GXSysHelp v.2.5: GXS.TerrainRenderer

Unit GXS.TerrainRenderer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GXS.XOpenGL
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Utils
  • GXS.VectorLists
  • GXS.Scene
  • GXS.HeightData
  • GXS.Material
  • GXS.Coordinates
  • GXS.Context
  • GXS.ROAMPatch
  • GXS.RenderContextInfo
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTerrainRenderer |

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: single) of object;
TgxHeightDataPostRenderEvent = procedure(var rci: TgxRenderContextInfo; var HeightDatas: TList) of object;
TgxTerrainHighResStyle = (...);
TgxTerrainOcclusionTesselate = (...);
TgxTileManagementFlag = (...);
TgxTileManagementFlags = set of TgxTileManagementFlag;
TMaxCLODTrianglesReachedEvent = procedure(var rci: TgxRenderContextInfo) of object;
TPatchPostRenderEvent = procedure(var rci: TgxRenderContextInfo; const patches: TList) of object;

Constants

cTilesHashSize = 255;

Description

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: single) of object;

This item has no description.

TgxHeightDataPostRenderEvent = procedure(var rci: TgxRenderContextInfo; var HeightDatas: TList) of object;

This item has no description.

TgxTerrainHighResStyle = (...);

This item has no description.

Values
  • hrsFullGeometry
  • hrsTesselated
TgxTerrainOcclusionTesselate = (...);

This item has no description.

Values
  • totTesselateAlways
  • totTesselateIfVisible
TgxTileManagementFlag = (...);

This item has no description.

Values
  • tmClearUsedFlags
  • tmMarkUsedTiles
  • tmReleaseUnusedTiles
  • tmAllocateNewTiles
  • tmWaitForPreparing
TgxTileManagementFlags = set of TgxTileManagementFlag;

This item has no description.

TMaxCLODTrianglesReachedEvent = procedure(var rci: TgxRenderContextInfo) of object;

This item has no description.

TPatchPostRenderEvent = procedure(var rci: TgxRenderContextInfo; const patches: TList) of object;

This item has no description.

Constants

cTilesHashSize = 255;


GXSysHelp v.2.5: GXS.TerrainRenderer: Class TgxTerrainRenderer

Class TgxTerrainRenderer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TerrainRenderer

Declaration

type TgxTerrainRenderer = class(TgxSceneObject)

Description

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TgxHeightDataSource, and expressed as z=f(x, y) data.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxTerrainRenderer

Overview

Fields

Private | FHeightDataSource: TgxHeightDataSource;
Private | FTileSize: Integer;
Private | FQualityDistance: single;
Private | FinvTileSize: single;
Private | FLastTriangleCount: Integer;
Private | FTilesPerTexture: single;
Private | FMaxCLODTriangles: Integer;
Private | FCLODPrecision: Integer;
Private | FBufferVertices: TgxAffineVectorList;
Private | FBufferTexPoints: TgxTexPointList;
Private | FBufferVertexIndices: TgxIntegerList;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FOnGetTerrainBounds: TGetTerrainBoundsEvent;
Private | FOnPatchPostRender: TPatchPostRenderEvent;
Private | FOnHeightDataPostRender: TgxHeightDataPostRenderEvent;
Private | FOnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent;
Private | FQualityStyle: TgxTerrainHighResStyle;
Private | FOcclusionFrameSkip: Integer;
Private | FOcclusionTesselate: TgxTerrainOcclusionTesselate;
Private | FContourInterval: Integer;
Private | FContourWidth: Integer;
Public | TileManagement: TgxTileManagementFlags;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function HashedTileCount: Integer;
Public | function InterpolatedHeight(const p: TVector4f): single; overload; virtual;
Public | function InterpolatedHeight(const p: TAffineVector): single; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;

Properties

Published | property CLODPrecision: Integer read FCLODPrecision write SetCLODPrecision default 100;
Published | property ContourInterval: Integer read FContourInterval write FContourInterval default 0;
Published | property ContourWidth: Integer read FContourWidth write FContourWidth default 1;
Published | property HeightDataSource: TgxHeightDataSource read FHeightDataSource write SetHeightDataSource;
Public | property LastTriangleCount: Integer read FLastTriangleCount;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaxCLODTriangles: Integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;
Published | property OcclusionFrameSkip: Integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;
Published | property OcclusionTesselate: TgxTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;
Published | property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;
Published | property OnHeightDataPostRender: TgxHeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;
Published | property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;
Published | property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;
Published | property QualityDistance: single read FQualityDistance write FQualityDistance;
Published | property QualityStyle: TgxTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;
Published | property TileSize: Integer read FTileSize write SetTileSize default 16;
Published | property TilesPerTexture: single read FTilesPerTexture write SetTilesPerTexture;

Description

Fields

Private FHeightDataSource: TgxHeightDataSource;

This item has no description.

Private FTileSize: Integer;

This item has no description.

Private FQualityDistance: single;

This item has no description.

Private FinvTileSize: single;

This item has no description.

Private FLastTriangleCount: Integer;

This item has no description.

Private FTilesPerTexture: single;

This item has no description.

Private FMaxCLODTriangles: Integer;

This item has no description.

Private FCLODPrecision: Integer;

This item has no description.

Private FBufferVertices: TgxAffineVectorList;

This item has no description.

Private FBufferTexPoints: TgxTexPointList;

This item has no description.

Private FBufferVertexIndices: TgxIntegerList;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FOnGetTerrainBounds: TGetTerrainBoundsEvent;

This item has no description.

Private FOnPatchPostRender: TPatchPostRenderEvent;

This item has no description.

Private FOnHeightDataPostRender: TgxHeightDataPostRenderEvent;

This item has no description.

Private FOnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent;

This item has no description.

Private FQualityStyle: TgxTerrainHighResStyle;

This item has no description.

Private FOcclusionFrameSkip: Integer;

This item has no description.

Private FOcclusionTesselate: TgxTerrainOcclusionTesselate;

This item has no description.

Private FContourInterval: Integer;

This item has no description.

Private FContourWidth: Integer;

This item has no description.

Public TileManagement: TgxTileManagementFlags;

TileManagement flags can be used to turn off various Tile cache management features. This helps to prevent unnecessary tile cache flushes, when rendering from multiple cameras.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function HashedTileCount: Integer;

This item has no description.

Public function InterpolatedHeight(const p: TVector4f): single; overload; virtual;

Interpolates height for the given point. Expects a point expressed in absolute coordinates.

Public function InterpolatedHeight(const p: TAffineVector): single; overload;

This item has no description.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.RayCastIntersect.

Request to determine an intersection with a casted ray. Given coordinates & vector are in absolute coordinates, rayVector must be normalized. rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray. When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined. The intersectNormal needs NOT be normalized by the implementations. Default value is based on bounding sphere.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Properties

Published property CLODPrecision: Integer read FCLODPrecision write SetCLODPrecision default 100;

Precision of CLOD tiles. The lower the value, the higher the precision and triangle count. Large values will result in coarse terrain. high-resolution tiles (closer than QualityDistance) ignore this setting.

Published property ContourInterval: Integer read FContourInterval write FContourInterval default 0;

Distance between contours - zero (default) for no contours PGS

Published property ContourWidth: Integer read FContourWidth write FContourWidth default 1;

Width of contour lines

Published property HeightDataSource: TgxHeightDataSource read FHeightDataSource write SetHeightDataSource;

Specifies the HeightData provider component.

Public property LastTriangleCount: Integer read FLastTriangleCount;

Triangle count for the last render.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Link to the material library holding terrain materials. If unspecified, and for all terrain tiles with unspecified material, the terrain renderer's material is used.

Published property MaxCLODTriangles: Integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;

Maximum number of CLOD triangles per scene. Triangles in high-resolution tiles (closer than QualityDistance) do not count toward this limit.

Published property OcclusionFrameSkip: Integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;

Numbers of frames to skip for a tile when occlusion testing found it invisible. Occlusion testing can help reduce CPU, T&L and fillrate requirements when tiles are occluded, either by the terrain itself (tiles behind a mountain or a cliff) or by geometry that was rendered before the terrain (large buildings). If there is little occlusion in your scene (such as in top down or high-altitude view), turning occlusion on may have a slightly negative effect on framerate. It works by turning off rendering of tiles for the specified number of frames if it has been found invisible, after FrameSkip number of frames have been skipped, it will be rendered again, and a new occlusion testing made. This makes occlusion-testing a frame-to-frame coherency optimization, and as such, shouldn't be used for static rendering (ie. leave value to its default of zero). This optimization requires the hardware to support GL_NV_occlusion_query.

Published property OcclusionTesselate: TgxTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;

Determines if and how occlusion testing affects tesselation. Turning off tesselation of tiles determined invisible can improve performance, however, it may result in glitches since the tesselation of an ivisible tile can have a slight effect on the tesselation of its adjacent tiles (by forcing higher resolution at the border for instance). This negative effect can be lessened by increasing the QualityDistance, so that glitches will apear farther away (this will mean increasing your triangle count though, so you'll trade CPU power against T&L power).

Published property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;

Allows to specify terrain bounds. Default rendering bounds will reach depth of view in all direction, with this event you can chose to specify a smaller rendered terrain area.

Published property OnHeightDataPostRender: TgxHeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;

Invoked for each heightData not culled out by the terrain renderer. The list holds TgxHeightData objects and allows per-patch post-processings, like waters, trees... It is invoked *after* OnPatchPostRender.

Published property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;

Invoked whenever the MaxCLODTriangles limit was reached during last rendering. This forced the terrain renderer to resize the buffer, which affects performance. If this event is fired frequently, one should increase MaxCLODTriangles.

Published property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;

Invoked for each rendered patch after terrain render has completed. The list holds TgxROAMPatch objects and allows per-patch post-processings, like waters, trees... It is invoked *before* OnHeightDataPostRender

Published property QualityDistance: single read FQualityDistance write FQualityDistance;

Quality distance hint. This parameter gives an hint to the terrain renderer at which distance the terrain quality can be degraded to favor speed. The distance is expressed in absolute coordinates units. All tiles closer than this distance are rendered according to QualityStyle and with a static resolution.

Published property QualityStyle: TgxTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;

Determines how high-res tiles (closer than QualityDistance) are rendered. hrsFullGeometry (default value) means that the high-res tiles are rendered with full-geometry, and no LOD of any kind, while hrsTesselated means the tiles will be tesselated once, with the best output for the CLODPrecision, and the result of that tesselation will be reused in further frames without any adpative tesselation.

Published property TileSize: Integer read FTileSize write SetTileSize default 16;

Size of the terrain tiles. Must be a power of two.

Published property TilesPerTexture: single read FTilesPerTexture write SetTilesPerTexture;

Number of tiles required for a full texture map.


GXSysHelp v.2.5: GXS.TexLensFlare

Unit GXS.TexLensFlare

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.PersistentClasses
  • GXS.Objects
  • GXS.Texture
  • GXS.Context
  • GXS.RenderContextInfo
  • GXS.BaseClasses
  • GXS.State
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTextureLensFlare |


GXSysHelp v.2.5: GXS.TexLensFlare: Class TgxTextureLensFlare

Class TgxTextureLensFlare

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TexLensFlare

Declaration

type TgxTextureLensFlare = class(TgxBaseSceneObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxTextureLensFlare

Overview

Fields

Private | FSize: integer;
Private | FCurrSize: Single;
Private | FNumSecs: integer;
Private | FAutoZTest: boolean;
Private | FDeltaTime: Double;
Private | FImgSecondaries: TgxTexture;
Private | FImgRays: TgxTexture;
Private | FImgRing: TgxTexture;
Private | FImgGlow: TgxTexture;
Private | FSeed: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Private | procedure SetImgGlow(const Value: TgxTexture);
Private | procedure SetImgRays(const Value: TgxTexture);
Private | procedure SetImgRing(const Value: TgxTexture);
Private | procedure SetImgSecondaries(const Value: TgxTexture);
Private | procedure SetSeed(const Value: Integer);

Properties

Published | property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Effects;
Published | property ImgGlow: TgxTexture read FImgGlow write SetImgGlow;
Published | property ImgRays: TgxTexture read FImgRays write SetImgRays;
Published | property ImgRing: TgxTexture read FImgRing write SetImgRing;
Published | property ImgSecondaries: TgxTexture read FImgSecondaries write SetImgSecondaries;
Published | property NumSecs: integer read FNumSecs write SetNumSecs default 8;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property Size: integer read FSize write SetSize default 50;
Published | property Visible;

Description

Fields

Private FSize: integer;

This item has no description.

Private FCurrSize: Single;

This item has no description.

Private FNumSecs: integer;

This item has no description.

Private FAutoZTest: boolean;

This item has no description.

Private FDeltaTime: Double;

used for internal calculation

Private FImgSecondaries: TgxTexture;

This item has no description.

Private FImgRays: TgxTexture;

This item has no description.

Private FImgRing: TgxTexture;

This item has no description.

Private FImgGlow: TgxTexture;

This item has no description.

Private FSeed: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Private procedure SetImgGlow(const Value: TgxTexture);

This item has no description.

Private procedure SetImgRays(const Value: TgxTexture);

This item has no description.

Private procedure SetImgRing(const Value: TgxTexture);

This item has no description.

Private procedure SetImgSecondaries(const Value: TgxTexture);

This item has no description.

Private procedure SetSeed(const Value: Integer);

This item has no description.

Properties

Published property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;

Number of segments used when rendering circles. property Resolution: integer read FResolution write SetResolution default 64;

Published property Behaviours;

This item has no description.

Published property Effects;

This item has no description.

Published property ImgGlow: TgxTexture read FImgGlow write SetImgGlow;

The Textures

Published property ImgRays: TgxTexture read FImgRays write SetImgRays;

This item has no description.

Published property ImgRing: TgxTexture read FImgRing write SetImgRing;

This item has no description.

Published property ImgSecondaries: TgxTexture read FImgSecondaries write SetImgSecondaries;

This item has no description.

Published property NumSecs: integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property Position;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property Size: integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Visible;


GXSysHelp v.2.5: GXS.Texture

Unit GXS.Texture

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • System.Types
  • FMX.Graphics
  • FMX.Objects
  • GLScene.TextureFormat
  • GLScene.Strings
  • GXS.XOpenGL
  • GXS.PersistentClasses
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.BaseClasses
  • GXS.ApplicationFileIO
  • GXS.Graphics
  • GXS.Context
  • GXS.State
  • GLScene.PipelineTransform
  • GXS.Color
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GXS.ImageUtils
  • GLScene.Utils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IgxTextureNotifyAble |
Class TgxTextureImage |
Class TgxBlankImage |
Class TgxPictureImage |
Class TgxPersistentImage |
Class TgxPicFileImage |
Class TgxCubeMapImage |
Class TgxTexture |
Class TgxTextureExItem |
Class TgxTextureEx |
Class ETexture |
Class EShaderException |

Functions and Procedures

procedure RegisterTextureImageClass(textureImageClass: TgxTextureImageClass);
function FindTextureImageClass(const className: string): TgxTextureImageClass;
function FindTextureImageClassByFriendlyName(const friendlyName: string): TgxTextureImageClass;
procedure SetTextureImageClassesToStrings(aStrings: TStrings);
function GetTextureImageClassesAsStrings: TStrings;
procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);
function CreateGraphicFromFile(const fileName: string): TBitmap;

Types

TgxCubeMapTarget = Integer;
TgxDepthCompareFunc = TgxDepthFunction;
TgxDepthTextureMode = (...);
TgxMagFilter = (...);
TgxMinFilter = (...);
TgxTextureChange = (...);
TgxTextureChanges = set of TgxTextureChange;
TgxTextureCompression = TglInternalCompression;
TgxTextureFormat = (...);
TgxTextureImageAlpha = (...);
TgxTextureImageClass = class of TgxTextureImage;
TgxTextureMappingMode = (...);
TgxTextureMode = (...);
TgxTextureNeededEvent = procedure(Sender: TObject; var TextureFileName: string) of object;
TgxTextureWrap = (...);

Constants

cDefaultNormalMapScale = 0.125;
CmtPX = 0;
CmtNX = 1;
CmtPY = 2;
CmtNY = 3;
CmtPZ = 4;
CmtNZ = 5;

Description

Functions and Procedures

procedure RegisterTextureImageClass(textureImageClass: TgxTextureImageClass);

Register a TgxTextureImageClass (used for persistence and IDE purposes)

function FindTextureImageClass(const className: string): TgxTextureImageClass;

Finds a registerer TgxTextureImageClass using its classname

function FindTextureImageClassByFriendlyName(const friendlyName: string): TgxTextureImageClass;

Finds a registerer TgxTextureImageClass using its FriendlyName

procedure SetTextureImageClassesToStrings(aStrings: TStrings);

Defines a TStrings with the list of registered TgxTextureImageClass.

function GetTextureImageClassesAsStrings: TStrings;

Creates a TStrings with the list of registered TgxTextureImageClass. To be freed by caller.

procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);

This item has no description.

function CreateGraphicFromFile(const fileName: string): TBitmap;

This item has no description.

Types

TgxCubeMapTarget = Integer;

This item has no description.

TgxDepthCompareFunc = TgxDepthFunction;

Specifies the depth comparison function.

TgxDepthTextureMode = (...);

Specifies how depth values should be treated during filtering and texture application

Values
  • dtmLuminance
  • dtmIntensity
  • dtmAlpha
TgxMagFilter = (...);

This item has no description.

Values
  • maNearest
  • maLinear
TgxMinFilter = (...);

This item has no description.

Values
  • miNearest
  • miLinear
  • miNearestMipmapNearest
  • miLinearMipmapNearest
  • miNearestMipmapLinear
  • miLinearMipmapLinear
TgxTextureChange = (...);

This item has no description.

Values
  • tcImage
  • tcParams
TgxTextureChanges = set of TgxTextureChange;

This item has no description.

TgxTextureCompression = TglInternalCompression;

This item has no description.

TgxTextureFormat = (...);

Texture format for OpenGL (rendering) use. Internally, GLXScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:

Values
  • tfDefault
  • tfRGB
  • tfRGBA: = tfRGB8
  • tfRGB16: = tfRGBA8
  • tfRGBA16: = tfRGB5
  • tfAlpha: = tfRGBA4
  • tfLuminance: = tfALPHA8
  • tfLuminanceAlpha: = tfLUMINANCE8
  • tfIntensity: = tfLUMINANCE8_ALPHA8
  • tfNormalMap: = tfINTENSITY8
  • tfRGBAFloat16: = tfRGB8
  • tfRGBAFloat32: = tfRGBA_FLOAT16_ATI
  • tfExtended: = tfRGBA_FLOAT32_ATI
TgxTextureImageAlpha = (...);

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.

Values
  • tiaDefault
  • tiaAlphaFromIntensity
  • tiaSuperBlackTransparent
  • tiaLuminance
  • tiaLuminanceSqrt
  • tiaOpaque
  • tiaTopLeftPointColorTransparent
  • tiaInverseLuminance
  • tiaInverseLuminanceSqrt
  • tiaBottomRightPointColorTransparent
TgxTextureImageClass = class of TgxTextureImage;

This item has no description.

TgxTextureMappingMode = (...);

This item has no description.

Values
  • tmmUser
  • tmmObjectLinear
  • tmmEyeLinear
  • tmmSphere
  • tmmCubeMapReflection
  • tmmCubeMapNormal
  • tmmCubeMapLight0
  • tmmCubeMapCamera
TgxTextureMode = (...);

This item has no description.

Values
  • tmDecal
  • tmModulate
  • tmBlend
  • tmReplace
  • tmAdd
TgxTextureNeededEvent = procedure(Sender: TObject; var TextureFileName: string) of object;

This item has no description.

TgxTextureWrap = (...);

This item has no description.

Values
  • twBoth
  • twNone
  • twVertical
  • twHorizontal
  • twSeparate

Constants

cDefaultNormalMapScale = 0.125;

This item has no description.

CmtPX = 0;

This item has no description.

CmtNX = 1;

This item has no description.

CmtPY = 2;

This item has no description.

CmtNY = 3;

This item has no description.

CmtPZ = 4;

This item has no description.

CmtNZ = 5;


GXSysHelp v.2.5: GXS.Texture: Interface IgxTextureNotifyAble

Interface IgxTextureNotifyAble

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type IgxTextureNotifyAble = interface(IgxNotifyable)

Description

This item has no description.

Hierarchy

  • IgxNotifyable
  • IgxTextureNotifyAble

Overview

Methods

Public procedure NotifyTexMapChange(Sender: TObject);

Description

Methods

Public procedure NotifyTexMapChange(Sender: TObject);

This item has no description.

Attributes
GUID['{0D9DC0B0-ECE4-4513-A8A1-5AE7022C9426}']


GXSysHelp v.2.5: GXS.Texture: Class TgxTextureImage

Class TgxTextureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxTextureImage = class(TgxUpdateAbleObject)

Description

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsBitmap: TBitmap;
Public | class function FriendlyDescription: string; virtual;
Public | class function FriendlyName: string; virtual;
Public | function GetBitmap32: TgxImage; virtual;
Private | function GetResourceName: string;
Public | procedure AssignToBitmap(aBitmap: TBitmap);
Public | procedure Invalidate; virtual;
Public | procedure LoadFromFile(const fileName: string); virtual;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure ReleaseBitmap32; virtual;
Public | procedure SaveToFile(const fileName: string); virtual;

Properties

Public | property Depth: Integer read GetDepth;
Public | property Height: Integer read GetHeight;
Public | property NativeTextureTarget: TglTextureTarget read GetTextureTarget;
Public | property OwnerTexture: TgxTexture read FOwnerTexture write FOwnerTexture;
Public | property ResourceName: string read GetResourceName;
Public | property Width: Integer read GetWidth;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AsBitmap: TBitmap;

AsBitmap : Returns the TextureImage as a TBitmap

Public class function FriendlyDescription: string; virtual;

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; virtual;

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxImage; virtual;

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Private function GetResourceName: string;

This item has no description.

Public procedure AssignToBitmap(aBitmap: TBitmap);

This item has no description.

Public procedure Invalidate; virtual;

Request reload/refresh of data upon next use.

Public procedure LoadFromFile(const fileName: string); virtual;

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure ReleaseBitmap32; virtual;

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); virtual;

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property Depth: Integer read GetDepth;

This item has no description.

Public property Height: Integer read GetHeight;

This item has no description.

Public property NativeTextureTarget: TglTextureTarget read GetTextureTarget;

Native OpenGL texture target.

Public property OwnerTexture: TgxTexture read FOwnerTexture write FOwnerTexture;

This item has no description.

Public property ResourceName: string read GetResourceName;

This item has no description.

Public property Width: Integer read GetWidth;


GXSysHelp v.2.5: GXS.Texture: Class TgxBlankImage

Class TgxBlankImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxBlankImage = class(TgxTextureImage)

Description

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TgxMemoryViewer for instance).

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxBlankImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Private | procedure SetArray(const val: Boolean);
Private | procedure SetCubeMap(const val: Boolean);
Private | procedure SetDepth(val: Integer);
Private | procedure SetHeight(val: Integer);
Private | procedure SetWidth(val: Integer);

Properties

Published | property ColorFormat: Cardinal read fColorFormat write fColorFormat;
Published | property CubeMap: Boolean read fCubeMap write SetCubeMap default false;
Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Published | property TextureArray: Boolean read fArray write SetArray default false;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxImage; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Private procedure SetArray(const val: Boolean);

This item has no description.

Private procedure SetCubeMap(const val: Boolean);

This item has no description.

Private procedure SetDepth(val: Integer);

This item has no description.

Private procedure SetHeight(val: Integer);

This item has no description.

Private procedure SetWidth(val: Integer);

This item has no description.

Properties

Published property ColorFormat: Cardinal read fColorFormat write fColorFormat;

This item has no description.

Published property CubeMap: Boolean read fCubeMap write SetCubeMap default false;

This item has no description.

Published property Depth: Integer read GetDepth write SetDepth default 0;

This item has no description.

Published property Height: Integer read GetHeight write SetHeight default 256;

This item has no description.

Published property TextureArray: Boolean read fArray write SetArray default false;

This item has no description.

Published property Width: Integer read GetWidth write SetWidth default 256;

Width, heigth and depth of the blank image (for memory allocation).


GXSysHelp v.2.5: GXS.Texture: Class TgxPictureImage

Class TgxPictureImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxPictureImage = class(TgxTextureImage)

Description

Base class for image data classes internally based on a TgxPicture.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxPictureImage

Overview

Fields

Private | FBitmap: TgxImage;
Private | FVKPicture: TImage;
Private | FUpdateCounter: Integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function GetBitmap32: TgxImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure ReleaseBitmap32; override;

Properties

Public property Picture: TImage read GetPicture write SetPicture;

Description

Fields

Private FBitmap: TgxImage;

This item has no description.

Private FVKPicture: TImage;

This item has no description.

Private FUpdateCounter: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetBitmap32: TgxImage; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly. Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;

Ends a direct picture modification session. Follows a BeginUpdate.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Properties

Public property Picture: TImage read GetPicture write SetPicture;

Holds the image content.


GXSysHelp v.2.5: GXS.Texture: Class TgxPersistentImage

Class TgxPersistentImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxPersistentImage = class(TgxPictureImage)

Description

Stores any image compatible with Delphi's TgxPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxPictureImage
  • TgxPersistentImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Published | property Picture;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TgxTextureImage.NativeTextureTarget.

Native OpenGL texture target.

Published property Picture;

This item has no description. Showing description inherited from TgxPictureImage.Picture.

Holds the image content.


GXSysHelp v.2.5: GXS.Texture: Class TgxPicFileImage

Class TgxPicFileImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxPicFileImage = class(TgxPictureImage)

Description

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxPictureImage
  • TgxPicFileImage

Overview

Fields

Private | FPictureFileName: string;
Private | FAlreadyWarnedAboutMissingFile: Boolean;
Private | FWidth: Integer;
Private | FHeight: Integer;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Invalidate; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Published | property PictureFileName: string read FPictureFileName write SetPictureFileName;

Description

Fields

Private FPictureFileName: string;

This item has no description.

Private FAlreadyWarnedAboutMissingFile: Boolean;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxImage; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure Invalidate; override;

This item has no description. Showing description inherited from TgxTextureImage.Invalidate.

Request reload/refresh of data upon next use.

Public procedure LoadFromFile(const fileName: string); override;

Load picture file name or use fileName as picture filename. The autodetection is based on the filelength and presence of zeros.

Public procedure SaveToFile(const fileName: string); override;

Only picture file name is saved

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TgxTextureImage.NativeTextureTarget.

Native OpenGL texture target.

Published property PictureFileName: string read FPictureFileName write SetPictureFileName;

Filename of the picture to use.


GXSysHelp v.2.5: GXS.Texture: Class TgxCubeMapImage

Class TgxCubeMapImage

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxCubeMapImage = class(TgxTextureImage)

Description

A texture image used for specifying and stroing a cube map. Not unlike TgxPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.

Hierarchy

  • TgxUpdateAbleObject
  • TgxTextureImage
  • TgxCubeMapImage

Overview

Fields

Private | FImage: TgxImage;
Private | FUpdateCounter: Integer;
Private | FPicture: array[cmtPX..cmtNZ] of TImage;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TgxImage; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Public | property Picture[index: TgxCubeMapTarget]: TImage read GetPicture write SetPicture;
Published | property PictureNX: TImage index cmtNX read GetPicture write SetPicture;
Published | property PictureNY: TImage index cmtNY read GetPicture write SetPicture;
Published | property PictureNZ: TImage index cmtNZ read GetPicture write SetPicture;
Published | property PicturePX: TImage index cmtPX read GetPicture write SetPicture;
Published | property PicturePY: TImage index cmtPY read GetPicture write SetPicture;
Published | property PicturePZ: TImage index cmtPZ read GetPicture write SetPicture;

Description

Fields

Private FImage: TgxImage;

This item has no description.

Private FUpdateCounter: Integer;

This item has no description.

Private FPicture: array[cmtPX..cmtNZ] of TImage;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; override;

This item has no description. Showing description inherited from TgxTextureImage.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TgxImage; override;

This item has no description. Showing description inherited from TgxTextureImage.GetBitmap32.

Returns image's bitmap handle. If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly. Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;

This item has no description.

Public procedure LoadFromFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.LoadFromFile.

Load textureImage from a file. This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture. Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure ReleaseBitmap32; override;

This item has no description. Showing description inherited from TgxTextureImage.ReleaseBitmap32.

Request for unloading bitmapData, to free some memory. This one is invoked when one no longer needs the Bitmap data it got through a call to GetHBitmap. Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); override;

This item has no description. Showing description inherited from TgxTextureImage.SaveToFile.

Save textureImage to file. This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Properties

Public property NativeTextureTarget;

This item has no description. Showing description inherited from TgxTextureImage.NativeTextureTarget.

Native OpenGL texture target.

Public property Picture[index: TgxCubeMapTarget]: TImage read GetPicture write SetPicture;

Indexed access to the cube map's sub pictures.

Published property PictureNX: TImage index cmtNX read GetPicture write SetPicture;

This item has no description.

Published property PictureNY: TImage index cmtNY read GetPicture write SetPicture;

This item has no description.

Published property PictureNZ: TImage index cmtNZ read GetPicture write SetPicture;

This item has no description.

Published property PicturePX: TImage index cmtPX read GetPicture write SetPicture;

This item has no description.

Published property PicturePY: TImage index cmtPY read GetPicture write SetPicture;

This item has no description.

Published property PicturePZ: TImage index cmtPZ read GetPicture write SetPicture;


GXSysHelp v.2.5: GXS.Texture: Class TgxTexture

Class TgxTexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxTexture = class(TgxUpdateAbleObject)

Description

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TgxTextureImageAlpha).

Hierarchy

  • TgxUpdateAbleObject
  • TgxTexture

Overview

Fields

Private | FTextureHandle: TgxTextureHandle;
Private | FSamplerHandle: TgxVirtualHandle;
Private | FTextureFormat: TglInternalFormat;
Private | FTextureMode: TgxTextureMode;
Private | FTextureWrap: TgxTextureWrap;
Private | FMinFilter: TgxMinFilter;
Private | FMagFilter: TgxMagFilter;
Private | FDisabled: Boolean;
Private | FImage: TgxTextureImage;
Private | FImageAlpha: TgxTextureImageAlpha;
Private | FImageBrightness: Single;
Private | FImageGamma: Single;
Private | FMappingMode: TgxTextureMappingMode;
Private | FMapSCoordinates: TgxCoordinates4;
Private | FMapTCoordinates: TgxCoordinates4;
Private | FMapRCoordinates: TgxCoordinates4;
Private | FMapQCoordinates: TgxCoordinates4;
Private | FOnTextureNeeded: TgxTextureNeededEvent;
Private | FCompression: TgxTextureCompression;
Private | FRequiredMemorySize: Integer;
Private | FFilteringQuality: TglTextureFilteringQuality;
Private | FTexWidth: Integer;
Private | FTexHeight: Integer;
Private | FTexDepth: Integer;
Private | FEnvColor: TgxColor;
Private | FBorderColor: TgxColor;
Private | FNormalMapScale: Single;
Private | FTextureWrapS: TglSeparateTextureWrap;
Private | FTextureWrapT: TglSeparateTextureWrap;
Private | FTextureWrapR: TglSeparateTextureWrap;
Private | fTextureCompareMode: TglTextureCompareMode;
Private | fTextureCompareFunc: TgxDepthCompareFunc;
Private | fDepthTextureMode: TgxDepthTextureMode;
Private | FKeepImageAfterTransfer: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AllocateHandle: Cardinal;
Public | function GetImageClassName: string;
Public | function IsFloatType: Boolean;
Public | function IsHandleAllocated: Boolean;
Public | function OpenGLTextureFormat: Integer;
Public | function TextureImageRequiredMemory: Integer;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure ApplyAsTexture2(var rci: TgxRenderContextInfo; textureMatrix: PMatrix4f = nil);
Public | procedure ApplyAsTextureN(n: Integer; var rci: TgxRenderContextInfo; textureMatrix: PMatrix4f = nil);
Public | procedure ApplyMappingMode;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyImageChange;
Public | procedure NotifyParamsChange;
Public | procedure PrepareBuildList;
Public | procedure SetImageClassName(const val: string);
Public | procedure UnApply(var rci: TgxRenderContextInfo);
Public | procedure UnApplyAsTexture2(var rci: TgxRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyAsTextureN(n: Integer; var rci: TgxRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyMappingMode;

Properties

Published | property BorderColor: TgxColor read FBorderColor write SetBorderColor;
Published | property Compression: TgxTextureCompression read FCompression write SetCompression default tcDefault;
Published | property DepthTextureMode: TgxDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;
Published | property Disabled: Boolean read FDisabled write SetDisabled default True;
Public | property Enabled: Boolean read GetEnabled write SetEnabled;
Published | property EnvColor: TgxColor read FEnvColor write SetEnvColor;
Published | property FilteringQuality: TglTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;
Public | property Handle: Cardinal read GetHandle;
Published | property Image: TgxTextureImage read FImage write SetImage;
Published | property ImageAlpha: TgxTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;
Published | property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;
Published | property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;
Published | property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;
Published | property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;
Published | property MagFilter: TgxMagFilter read FMagFilter write SetMagFilter default maLinear;
Published | property MappingMode: TgxTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;
Published | property MappingQCoordinates: TgxCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published | property MappingRCoordinates: TgxCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published | property MappingSCoordinates: TgxCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;
Published | property MappingTCoordinates: TgxCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published | property MinFilter: TgxMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;
Published | property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;
Public | property OnTextureNeeded: TgxTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public | property TexDepth: Integer read FTexDepth;
Public | property TexHeight: Integer read FTexHeight;
Published | property TextureCompareFunc: TgxDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;
Published | property TextureCompareMode: TglTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;
Published | property TextureFormat: TgxTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;
Published | property TextureFormatEx: TglInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;
Public | property TextureHandle: TgxTextureHandle read FTextureHandle;
Published | property TextureMode: TgxTextureMode read FTextureMode write SetTextureMode default tmDecal;
Published | property TextureWrap: TgxTextureWrap read FTextureWrap write SetTextureWrap default twBoth;
Published | property TextureWrapR: TglSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;
Published | property TextureWrapS: TglSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;
Published | property TextureWrapT: TglSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;
Public | property TexWidth: Integer read FTexWidth;

Description

Fields

Private FTextureHandle: TgxTextureHandle;

This item has no description.

Private FSamplerHandle: TgxVirtualHandle;

This item has no description.

Private FTextureFormat: TglInternalFormat;

This item has no description.

Private FTextureMode: TgxTextureMode;

This item has no description.

Private FTextureWrap: TgxTextureWrap;

This item has no description.

Private FMinFilter: TgxMinFilter;

This item has no description.

Private FMagFilter: TgxMagFilter;

This item has no description.

Private FDisabled: Boolean;

This item has no description.

Private FImage: TgxTextureImage;

This item has no description.

Private FImageAlpha: TgxTextureImageAlpha;

This item has no description.

Private FImageBrightness: Single;

This item has no description.

Private FImageGamma: Single;

This item has no description.

Private FMappingMode: TgxTextureMappingMode;

This item has no description.

Private FMapSCoordinates: TgxCoordinates4;

This item has no description.

Private FMapTCoordinates: TgxCoordinates4;

This item has no description.

Private FMapRCoordinates: TgxCoordinates4;

This item has no description.

Private FMapQCoordinates: TgxCoordinates4;

This item has no description.

Private FOnTextureNeeded: TgxTextureNeededEvent;

This item has no description.

Private FCompression: TgxTextureCompression;

This item has no description.

Private FRequiredMemorySize: Integer;

This item has no description.

Private FFilteringQuality: TglTextureFilteringQuality;

This item has no description.

Private FTexWidth: Integer;

This item has no description.

Private FTexHeight: Integer;

This item has no description.

Private FTexDepth: Integer;

This item has no description.

Private FEnvColor: TgxColor;

This item has no description.

Private FBorderColor: TgxColor;

This item has no description.

Private FNormalMapScale: Single;

This item has no description.

Private FTextureWrapS: TglSeparateTextureWrap;

This item has no description.

Private FTextureWrapT: TglSeparateTextureWrap;

This item has no description.

Private FTextureWrapR: TglSeparateTextureWrap;

This item has no description.

Private fTextureCompareMode: TglTextureCompareMode;

This item has no description.

Private fTextureCompareFunc: TgxDepthCompareFunc;

This item has no description.

Private fDepthTextureMode: TgxDepthTextureMode;

This item has no description.

Private FKeepImageAfterTransfer: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AllocateHandle: Cardinal;

Allocates the texture handle if not already allocated. The texture is binded and parameters are setup, but no image data is initialized by this call - for expert use only.

Public function GetImageClassName: string;

This item has no description.

Public function IsFloatType: Boolean;

Returns if of float data type

Public function IsHandleAllocated: Boolean;

This item has no description.

Public function OpenGLTextureFormat: Integer;

Returns OpenGL texture format corresponding to current options.

Public function TextureImageRequiredMemory: Integer;

Returns the OpenGL memory used by the texture. The compressed size is returned if, and only if texture compression if active and possible, and the texture has been allocated (Handle is defined), otherwise the estimated size (from TextureFormat specification) is returned.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure ApplyAsTexture2(var rci: TgxRenderContextInfo; textureMatrix: PMatrix4f = nil);

Applies to TEXTURE1

Public procedure ApplyAsTextureN(n: Integer; var rci: TgxRenderContextInfo; textureMatrix: PMatrix4f = nil);

N=1 for TEXTURE0, N=2 for TEXTURE1, etc.

Public procedure ApplyMappingMode;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DestroyHandles;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure NotifyImageChange;

This item has no description.

Public procedure NotifyParamsChange;

This item has no description.

Public procedure PrepareBuildList;

This item has no description.

Public procedure SetImageClassName(const val: string);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure UnApplyAsTexture2(var rci: TgxRenderContextInfo; reloadIdentityTextureMatrix: boolean);

This item has no description.

Public procedure UnApplyAsTextureN(n: Integer; var rci: TgxRenderContextInfo; reloadIdentityTextureMatrix: boolean);

This item has no description.

Public procedure UnApplyMappingMode;

This item has no description.

Properties

Published property BorderColor: TgxColor read FBorderColor write SetBorderColor;

Texture Border color.

Published property Compression: TgxTextureCompression read FCompression write SetCompression default tcDefault;

Texture compression control. If True the compressed TextureFormat variant (the OpenGL ICD must support GL_ARB_texture_compression, or this option is ignored).

Published property DepthTextureMode: TgxDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;

This item has no description.

Published property Disabled: Boolean read FDisabled write SetDisabled default True;

If true, the texture is disabled (not used).

Public property Enabled: Boolean read GetEnabled write SetEnabled;

Is the texture enabled? Always equals to 'not Disabled'.

Published property EnvColor: TgxColor read FEnvColor write SetEnvColor;

Texture Environment color.

Published property FilteringQuality: TglTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;

Specifies texture filtering quality. You can choose between bilinear and trilinear filetring (anisotropic). The OpenGL ICD must support GL_EXT_texture_filter_anisotropic or this property is ignored.

Public property Handle: Cardinal read GetHandle;

Handle to the OpenGL texture object. If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Published property Image: TgxTextureImage read FImage write SetImage;

Image data for the texture.

Published property ImageAlpha: TgxTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;

Automatic Image Alpha setting. Allows to control how and if the image's Alpha channel (transparency) is computed.

Published property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;

Texture brightness correction. This correction is applied upon loading a TgxTextureImage, it's a simple saturating scaling applied to the RGB components of the 32 bits image, before it is passed to OpenGL, and before gamma correction (if any).

Published property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;

Image ClassName for enabling True polymorphism. This is ugly, but since the default streaming mechanism does a really bad job at storing polymorphic owned-object properties, and neither TFiler nor TgxPicture allow proper use of the built-in streaming, that's the only way I found to allow a user-extensible mechanism.

Published property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;

Texture gamma correction. The gamma correction is applied upon loading a TgxTextureImage, applied to the RGB components of the 32 bits image, before it is passed to OpenGL, after brightness correction (if any).

Published property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;

Disable image release after transfering it to VGA.

Published property MagFilter: TgxMagFilter read FMagFilter write SetMagFilter default maLinear;

Texture magnification filter.

Published property MappingMode: TgxTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;

Texture coordinates mapping mode. This property controls automatic texture coordinates generation.

Published property MappingQCoordinates: TgxCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;

This item has no description.

Published property MappingRCoordinates: TgxCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;

This item has no description.

Published property MappingSCoordinates: TgxCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;

Texture mapping coordinates mode for S, T, R and Q axis. This property stores the coordinates for automatic texture coordinates generation.

Published property MappingTCoordinates: TgxCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;

This item has no description.

Published property MinFilter: TgxMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;

Texture minification filter.

Published property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;

Normal Map scaling. Only applies when TextureFormat is tfNormalMap, this property defines the scaling that is applied during normal map generation (ie. controls the intensity of the bumps).

Public property OnTextureNeeded: TgxTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;

This item has no description.

Public property TexDepth: Integer read FTexDepth;

This item has no description.

Public property TexHeight: Integer read FTexHeight;

This item has no description.

Published property TextureCompareFunc: TgxDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;

This item has no description.

Published property TextureCompareMode: TglTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;

This item has no description.

Published property TextureFormat: TgxTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;

Texture format for use by the renderer. See TgxTextureFormat for details.

Published property TextureFormatEx: TglInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;

This item has no description.

Public property TextureHandle: TgxTextureHandle read FTextureHandle;

This item has no description.

Published property TextureMode: TgxTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.

Published property TextureWrap: TgxTextureWrap read FTextureWrap write SetTextureWrap default twBoth;

Wrapping mode for the texture.

Published property TextureWrapR: TglSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;

This item has no description.

Published property TextureWrapS: TglSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;

Wrapping mode for the texture when TextureWrap=twSeparate.

Published property TextureWrapT: TglSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;

This item has no description.

Public property TexWidth: Integer read FTexWidth;

Actual width, height and depth used for last texture specification binding.


GXSysHelp v.2.5: GXS.Texture: Class TgxTextureExItem

Class TgxTextureExItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxTextureExItem = class(TCollectionItem, IgxTextureNotifyAble)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxTextureExItem

Overview

Fields

Private | FTexture: TgxTexture;
Private | FTextureIndex: Integer;
Private | FTextureOffset: TgxCoordinates;
Private | FTextureScale: TgxCoordinates;
Private | FTextureMatrixIsIdentity: Boolean;
Private | FTextureMatrix: TMatrix4f;
Private | FApplied: Boolean;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Private | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Private | function _AddRef: Integer; stdcall;
Private | function _Release: Integer; stdcall;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TgxRenderContextInfo);

Properties

Published | property Texture: TgxTexture read FTexture write SetTexture;
Published | property TextureIndex: Integer read FTextureIndex write SetTextureIndex;
Published | property TextureOffset: TgxCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureScale: TgxCoordinates read FTextureScale write SetTextureScale;

Description

Fields

Private FTexture: TgxTexture;

This item has no description.

Private FTextureIndex: Integer;

This item has no description.

Private FTextureOffset: TgxCoordinates;

This item has no description.

Private FTextureScale: TgxCoordinates;

This item has no description.

Private FTextureMatrixIsIdentity: Boolean;

This item has no description.

Private FTextureMatrix: TMatrix4f;

This item has no description.

Private FApplied: Boolean;

This item has no description.

Methods

Public constructor Create(ACollection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;

implementing IInterface

Private function _AddRef: Integer; stdcall;

This item has no description.

Private function _Release: Integer; stdcall;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Properties

Published property Texture: TgxTexture read FTexture write SetTexture;

This item has no description.

Published property TextureIndex: Integer read FTextureIndex write SetTextureIndex;

This item has no description.

Published property TextureOffset: TgxCoordinates read FTextureOffset write SetTextureOffset;

This item has no description.

Published property TextureScale: TgxCoordinates read FTextureScale write SetTextureScale;


GXSysHelp v.2.5: GXS.Texture: Class TgxTextureEx

Class TgxTextureEx

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type TgxTextureEx = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxTextureEx

Overview

Fields

Private FOwner: TgxUpdateAbleObject;

Methods

Public | constructor Create(AOwner: TgxUpdateAbleObject);
Public | function Add: TgxTextureExItem;
Public | function IsTextureEnabled(Index: Integer): Boolean;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TgxRenderContextInfo);

Properties

Public property Items[index: Integer]: TgxTextureExItem read GetItems write SetItems;

Description

Fields

Private FOwner: TgxUpdateAbleObject;

This item has no description.

Methods

Public constructor Create(AOwner: TgxUpdateAbleObject);

This item has no description.

Public function Add: TgxTextureExItem;

This item has no description.

Public function IsTextureEnabled(Index: Integer): Boolean;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Loaded;

This item has no description.

Public procedure NotifyChange(Sender: TObject);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Properties

Public property Items[index: Integer]: TgxTextureExItem read GetItems write SetItems;


GXSysHelp v.2.5: GXS.Texture: Class ETexture

Class ETexture

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type ETexture = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • ETexture


GXSysHelp v.2.5: GXS.Texture: Class EShaderException

Class EShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Texture

Declaration

type EShaderException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EShaderException


GXSysHelp v.2.5: GXS.TextureCombiners

Unit GXS.TextureCombiners

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.SysUtils
  • System.Classes
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TgxCombinerCommand |
Class EVXTextureCombinerError |

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TgxCombinerCache;

Types

TgxCombinerCache = array of TgxCombinerCommand;

Description

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TgxCombinerCache;

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment. Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color

Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

Types

TgxCombinerCache = array of TgxCombinerCommand;


GXSysHelp v.2.5: GXS.TextureCombiners: Record TgxCombinerCommand

Record TgxCombinerCommand

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureCombiners

Declaration

type TgxCombinerCommand = record

Description

This item has no description.

Overview

Fields

Public | ActiveUnit: Integer;
Public | Arg1: Integer;
Public | Arg2: Integer;

Description

Fields

Public ActiveUnit: Integer;

This item has no description.

Public Arg1: Integer;

This item has no description.

Public Arg2: Integer;


GXSysHelp v.2.5: GXS.TextureCombiners: Class EVXTextureCombinerError

Class EVXTextureCombinerError

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureCombiners

Declaration

type EVXTextureCombinerError = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EVXTextureCombinerError


GXSysHelp v.2.5: GXS.TexturedHDS

Unit GXS.TexturedHDS

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Types
  • System.Classes
  • GLScene.VectorTypes
  • GXS.Coordinates
  • GXS.HeightData
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTexturedHDS |


GXSysHelp v.2.5: GXS.TexturedHDS: Class TgxTexturedHDS

Class TgxTexturedHDS

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TexturedHDS

Declaration

type TgxTexturedHDS = class(TgxHeightDataSource)

Description

This item has no description. Showing description inherited from TgxHeightDataSource.

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TgxHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TgxHeightData with its "Release" method) Pre-loading : specify a list of TgxHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxHeightDataSource
  • TgxTexturedHDS

Overview

Fields

Private | FOnStartPreparingData: TStartPreparingDataEvent;
Private | FOnMarkDirty: TMarkDirtyEvent;
Private | FHeightDataSource: TgxHeightDataSource;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FWholeTilesOnly: Boolean;
Private | FTileSize: integer;
Private | FTilesPerTexture: integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const area: TRect); override;
Public | procedure StartPreparingData(HeightData: TgxHeightData); override;

Properties

Published | property HeightDataSource: TgxHeightDataSource read FHeightDataSource write SetHeightDataSource;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write FMaterialLibrary;
Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;
Published | property TileSize: integer read FTileSize write FTileSize;
Published | property TilesPerTexture: integer read FTilesPerTexture write FTilesPerTexture;
Published | property WholeTilesOnly: Boolean read FWholeTilesOnly write FWholeTilesOnly;

Description

Fields

Private FOnStartPreparingData: TStartPreparingDataEvent;

This item has no description.

Private FOnMarkDirty: TMarkDirtyEvent;

This item has no description.

Private FHeightDataSource: TgxHeightDataSource;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FWholeTilesOnly: Boolean;

This item has no description.

Private FTileSize: integer;

This item has no description.

Private FTilesPerTexture: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure MarkDirty(const area: TRect); override;

This item has no description. Showing description inherited from TgxHeightDataSource.MarkDirty.

Marks the given area as "dirty" (ie source data changed). All loaded and in-cache tiles overlapping the area are flushed.

Public procedure StartPreparingData(HeightData: TgxHeightData); override;

This item has no description. Showing description inherited from TgxHeightDataSource.StartPreparingData.

Request to start preparing data. If your subclass is thread-enabled, this is here that you'll create your thread and fire it (don't forget the requirements), if not, that'll be here you'll be doing your work. Either way, you are responsible for adjusting the DataState to hdsReady when you're done (DataState will be hdsPreparing when this method will be invoked).

Properties

Published property HeightDataSource: TgxHeightDataSource read FHeightDataSource write SetHeightDataSource;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write FMaterialLibrary;

This item has no description.

Published property MaxPoolSize;

This item has no description. Showing description inherited from TgxHeightDataSource.MaxPoolSize.

Maximum Size of TDataHeight pool in bytes. The pool (cache) can actually get larger if more data than the pool can accomodate is used, but as soon as data gets released and returns to the pool, TDataHeight will be freed until total pool Size gets below this figure. The pool manager frees TDataHeight objects who haven't been requested for the longest time first. The default value of zero effectively disables pooling.

Published property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;

This item has no description.

Published property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;

This item has no description.

Published property TileSize: integer read FTileSize write FTileSize;

This should match TileSize in TgxTerrainRenderer

Published property TilesPerTexture: integer read FTilesPerTexture write FTilesPerTexture;

This should match TilesPerTexture in TgxTerrainRenderer

Published property WholeTilesOnly: Boolean read FWholeTilesOnly write FWholeTilesOnly;


GXSysHelp v.2.5: GXS.TextureImageEditors

Unit GXS.TextureImageEditors

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.Texture
  • GXS.ProcTextures
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTextureImageEditor |
Class TgxBlankTIE |
Class TgxPersistentTIE |
Class TgxPicFileTIE |
Class TgxProcTextureNoiseTIE |

Functions and Procedures

function EditTextureImage(aTexImage: TgxTextureImage): Boolean;
procedure RegisterTextureImageEditor(aTexImageClass: TgxTextureImageClass; texImageEditor: TgxTextureImageEditorClass);
procedure UnRegisterTextureImageEditor(texImageEditor : TgxTextureImageEditorClass);

Types

TgxTextureImageEditorClass = class of TgxTextureImageEditor;

Description

Functions and Procedures

function EditTextureImage(aTexImage: TgxTextureImage): Boolean;

Invokes the editor for the given TgxTextureImage

procedure RegisterTextureImageEditor(aTexImageClass: TgxTextureImageClass; texImageEditor: TgxTextureImageEditorClass);

This item has no description.

procedure UnRegisterTextureImageEditor(texImageEditor : TgxTextureImageEditorClass);

This item has no description.

Types

TgxTextureImageEditorClass = class of TgxTextureImageEditor;


GXSysHelp v.2.5: GXS.TextureImageEditors: Class TgxTextureImageEditor

Class TgxTextureImageEditor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureImageEditors

Declaration

type TgxTextureImageEditor = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTextureImageEditor

Overview

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; virtual; abstract;

Description

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; virtual; abstract;

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GXSysHelp v.2.5: GXS.TextureImageEditors: Class TgxBlankTIE

Class TgxBlankTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureImageEditors

Declaration

type TgxBlankTIE = class(TgxTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTextureImageEditor
  • TgxBlankTIE

Overview

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

This item has no description. Showing description inherited from TgxTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GXSysHelp v.2.5: GXS.TextureImageEditors: Class TgxPersistentTIE

Class TgxPersistentTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureImageEditors

Declaration

type TgxPersistentTIE = class(TgxTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTextureImageEditor
  • TgxPersistentTIE

Overview

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

This item has no description. Showing description inherited from TgxTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GXSysHelp v.2.5: GXS.TextureImageEditors: Class TgxPicFileTIE

Class TgxPicFileTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureImageEditors

Declaration

type TgxPicFileTIE = class(TgxTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTextureImageEditor
  • TgxPicFileTIE

Overview

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

This item has no description. Showing description inherited from TgxTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GXSysHelp v.2.5: GXS.TextureImageEditors: Class TgxProcTextureNoiseTIE

Class TgxProcTextureNoiseTIE

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TextureImageEditors

Declaration

type TgxProcTextureNoiseTIE = class(TgxTextureImageEditor)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTextureImageEditor
  • TgxProcTextureNoiseTIE

Overview

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

Description

Methods

Public class function Edit(aTexImage: TgxTextureImage): Boolean; override;

This item has no description. Showing description inherited from TgxTextureImageEditor.Edit.

Request to edit a textureImage. Returns True if changes have been made. This method may be invoked from the IDE or at run-time.


GXSysHelp v.2.5: GXS.ThorFX

Unit GXS.ThorFX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.XCollection
  • GXS.Scene
  • GLScene.PipelineTransform
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.VectorLists
  • GLScene.VectorTypes
  • GXS.Cadencer
  • GXS.Color
  • GXS.BaseClasses
  • GXS.Coordinates
  • GXS.RenderContextInfo
  • GLScene.Manager
  • GXS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TThorpoint |
Class TgxThorFXManager |
Class TgxBThorFX |

Functions and Procedures

function GetOrCreateThorFX(obj: TgxBaseSceneObject; const name: String = '') : TgxBThorFX;

Types

PThorpoint = ˆTThorpoint;
PThorpointArray = ˆTThorpointArray;
TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;
TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;

Description

Functions and Procedures

function GetOrCreateThorFX(obj: TgxBaseSceneObject; const name: String = '') : TgxBThorFX;

Returns or creates the TgxBThorFX within the given object's effects.

Types

PThorpoint = ˆTThorpoint;

This item has no description.

PThorpointArray = ˆTThorpointArray;

This item has no description.

TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;

This item has no description.

TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;


GXSysHelp v.2.5: GXS.ThorFX: Record TThorpoint

Record TThorpoint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ThorFX

Declaration

type TThorpoint = record

Description

This item has no description.

Overview

Fields

Public | Position: TVector4f;
Public | Size: single;

Description

Fields

Public Position: TVector4f;

This item has no description.

Public Size: single;

Position


GXSysHelp v.2.5: GXS.ThorFX: Class TgxThorFXManager

Class TgxThorFXManager

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ThorFX

Declaration

type TgxThorFXManager = class(TgxCadenceAbleComponent)

Description

Thor special effect manager.

Hierarchy

  • TgxCadenceAbleComponent
  • TgxThorFXManager

Overview

Fields

Private | FClients: TList;
Private | FThorpoints: PThorpointArray;
Private | FTarget: TgxCoordinates;
Private | FCadencer: TgxCadencer;
Private | FMaxpoints: integer;
Private | FGlowSize: single;
Private | FVibrate: single;
Private | FWildness: single;
Private | NP: integer;
Private | FInnerColor: TgxColor;
Private | FOuterColor: TgxColor;
Private | FCoreColor: TgxColor;
Private | FDisabled: boolean;
Private | FCore: boolean;
Private | FGlow: boolean;
Private | FOnCalcPoint: TCalcPointEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;

Properties

Published | property Cadencer: TgxCadencer read FCadencer write SetCadencer;
Published | property Core: boolean read FCore write FCore;
Published | property CoreColor: TgxColor read FCoreColor write SetCoreColor;
Published | property Disabled: boolean read FDisabled write FDisabled;
Published | property Glow: boolean read FGlow write FGlow;
Published | property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;
Published | property InnerColor: TgxColor read FInnerColor write SetInnerColor;
Published | property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;
Published | property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;
Published | property OuterColor: TgxColor read FOuterColor write SetOuterColor;
Published | property Target: TgxCoordinates read FTarget write SetTarget;
Published | property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;
Published | property Wildness: single read FWildness write FWildness;

Description

Fields

Private FClients: TList;

This item has no description.

Private FThorpoints: PThorpointArray;

This item has no description.

Private FTarget: TgxCoordinates;

This item has no description.

Private FCadencer: TgxCadencer;

This item has no description.

Private FMaxpoints: integer;

This item has no description.

Private FGlowSize: single;

This item has no description.

Private FVibrate: single;

This item has no description.

Private FWildness: single;

This item has no description.

Private NP: integer;

This item has no description.

Private FInnerColor: TgxColor;

This item has no description.

Private FOuterColor: TgxColor;

This item has no description.

Private FCoreColor: TgxColor;

This item has no description.

Private FDisabled: boolean;

This item has no description.

Private FCore: boolean;

This item has no description.

Private FGlow: boolean;

This item has no description.

Private FOnCalcPoint: TCalcPointEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Properties

Published property Cadencer: TgxCadencer read FCadencer write SetCadencer;

This item has no description.

Published property Core: boolean read FCore write FCore;

This item has no description.

Published property CoreColor: TgxColor read FCoreColor write SetCoreColor;

default clrWhite;

Published property Disabled: boolean read FDisabled write FDisabled;

default clrWhite;

Published property Glow: boolean read FGlow write FGlow;

This item has no description.

Published property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;

This item has no description.

Published property InnerColor: TgxColor read FInnerColor write SetInnerColor;

This item has no description.

Published property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;

This item has no description.

Published property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;

This item has no description.

Published property OuterColor: TgxColor read FOuterColor write SetOuterColor;

This item has no description.

Published property Target: TgxCoordinates read FTarget write SetTarget;

This item has no description.

Published property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;

This item has no description.

Published property Wildness: single read FWildness write FWildness;


GXSysHelp v.2.5: GXS.ThorFX: Class TgxBThorFX

Class TgxBThorFX

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ThorFX

Declaration

type TgxBThorFX = class(TgxObjectPostEffect)

Description

Thor special effect

Hierarchy

  • TGLInterfacedPersistent
  • TXCollectionItem
  • TgxBaseBehaviour
  • TgxEffect
  • TgxObjectPostEffect
  • TgxBThorFX

Overview

Fields

Private | FManager: TgxThorFXManager;
Private | FManagerName: String;
Private | FTarget: TgxCoordinates;

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TgxRenderContextInfo); override;

Properties

Published property Manager: TgxThorFXManager read FManager write SetManager;

Description

Fields

Private FManager: TgxThorFXManager;

This item has no description.

Private FManagerName: String;

This item has no description.

Private FTarget: TgxCoordinates;

NOT persistent, temporarily used for persistence

Methods

Public constructor Create(AOwner: TXCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function FriendlyDescription: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyDescription.

Returns a user-friendly description for the class. This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; override;

This item has no description. Showing description inherited from TXCollectionItem.FriendlyName.

Returns a user-friendly denomination for the class. This denomination is used for picking a texture image class in the IDE expert

Public procedure Assign(Source: TPersistent); override;

This item has no description. Showing description inherited from TXCollectionItem.Assign.

Default implementation uses WriteToFiler/ReadFromFiler

Public procedure Render(var rci: TgxRenderContextInfo); override;

This item has no description.

Properties

Published property Manager: TgxThorFXManager read FManager write SetManager;

Refers the collision manager.


GXSysHelp v.2.5: GXS.TilePlane

Unit GXS.TilePlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GXS.XOpenGL
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Material
  • GXS.Objects
  • GXS.PersistentClasses
  • GXS.VectorLists
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTiledAreaRow |
Class TgxTiledArea |
Class TgxTilePlane |


GXSysHelp v.2.5: GXS.TilePlane: Class TgxTiledAreaRow

Class TgxTiledAreaRow

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TilePlane

Declaration

type TgxTiledAreaRow = class(TgxPersistentObject)

Description

Stores row information for a tiled area.

Hierarchy

  • TgxPersistentObject
  • TgxTiledAreaRow

Overview

Fields

Private | FColMin: Integer;
Private | FColMax: Integer;
Private | FData: TgxIntegerList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty: Boolean;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure RemapTiles(remapList: TgxIntegerList);
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Cell[col: Integer]: Integer read GetCell write SetCell;
Public | property ColMax: Integer read FColMax write SetColMax;
Public | property ColMin: Integer read FColMin write SetColMin;
Public | property Data: TgxIntegerList read FData;

Description

Fields

Private FColMin: Integer;

This item has no description.

Private FColMax: Integer;

This item has no description.

Private FData: TgxIntegerList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Empty: Boolean;

This item has no description.

Public procedure Pack;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure RemapTiles(remapList: TgxIntegerList);

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Cell[col: Integer]: Integer read GetCell write SetCell;

This item has no description.

Public property ColMax: Integer read FColMax write SetColMax;

This item has no description.

Public property ColMin: Integer read FColMin write SetColMin;

This item has no description.

Public property Data: TgxIntegerList read FData;


GXSysHelp v.2.5: GXS.TilePlane: Class TgxTiledArea

Class TgxTiledArea

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TilePlane

Declaration

type TgxTiledArea = class(TgxPersistentObject)

Description

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".

Hierarchy

  • TgxPersistentObject
  • TgxTiledArea

Overview

Fields

Private | FRowMin: Integer;
Private | FRowMax: Integer;
Private | FRows: TgxPersistentObjectList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty: Boolean;
Public | procedure Clear;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure RemapTiles(remapList: TgxIntegerList);
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property row[index: Integer]: TgxTiledAreaRow read GetRow;
Public | property RowMax: Integer read FRowMax write SetRowMax;
Public | property RowMin: Integer read FRowMin write SetRowMin;
Public | property Tile[col,row: Integer]: Integer read GetTile write SetTile;

Description

Fields

Private FRowMin: Integer;

This item has no description.

Private FRowMax: Integer;

This item has no description.

Private FRows: TgxPersistentObjectList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Empty: Boolean;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure Pack;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure RemapTiles(remapList: TgxIntegerList);

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property row[index: Integer]: TgxTiledAreaRow read GetRow;

This item has no description.

Public property RowMax: Integer read FRowMax write SetRowMax;

This item has no description.

Public property RowMin: Integer read FRowMin write SetRowMin;

This item has no description.

Public property Tile[col,row: Integer]: Integer read GetTile write SetTile;


GXSysHelp v.2.5: GXS.TilePlane: Class TgxTilePlane

Class TgxTilePlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TilePlane

Declaration

type TgxTilePlane = class(TgxImmaterialSceneObject)

Description

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxTilePlane

Overview

Fields

Private | FNoZWrite: Boolean;
Private | FTiles: TgxTiledArea;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FSortByMaterials: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Public | property SortByMaterials: Boolean read FSortByMaterials write SetSortByMaterials;
Public | property Tiles: TgxTiledArea read FTiles write SetTiles;

Description

Fields

Private FNoZWrite: Boolean;

This item has no description.

Private FTiles: TgxTiledArea;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FSortByMaterials: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where tiles materials will be stored/retrieved. The lower 16 bits of the tile integer value is understood as being the index of the tile's material in the library (material of index zero is thus unused).

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If True the tiles are rendered without writing to the ZBuffer.

Public property SortByMaterials: Boolean read FSortByMaterials write SetSortByMaterials;

Controls the sorting of tiles by material. This property should ideally be left always at its default, True, except for debugging and performance measurement, which is why it's only public and not published.

Public property Tiles: TgxTiledArea read FTiles write SetTiles;

Access to the TiledArea data


GXSysHelp v.2.5: GXS.TimeEventsMgr

Unit GXS.TimeEventsMgr

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.Cadencer
  • GXS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTimeEventsMGR |
Class TgxTimeEvents |
Class TgxTimeEvent |

Types

TgxTimeEventProc = procedure(event: TgxTimeEvent) of object;
TgxTimeEventType = (...);

Description

Types

TgxTimeEventProc = procedure(event: TgxTimeEvent) of object;

This item has no description.

TgxTimeEventType = (...);

This item has no description.

Values
  • etOneShot
  • etContinuous
  • etPeriodic


GXSysHelp v.2.5: GXS.TimeEventsMgr: Class TgxTimeEventsMGR

Class TgxTimeEventsMGR

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TimeEventsMgr

Declaration

type TgxTimeEventsMGR = class(TgxUpdateAbleComponent)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxTimeEventsMGR

Overview

Fields

Private | FCadencer: TgxCadencer;
Private | FEnabled: boolean;
Private | FFreeEventOnEnd: boolean;
Private | FEvents: TgxTimeEvents;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure Reset();

Properties

Published | property Cadencer: TgxCadencer read FCadencer write SetCadencer;
Published | property Enabled: boolean read FEnabled write FEnabled default True;
Published | property Events: TgxTimeEvents read FEvents write SetEvents;
Published | property FreeEventOnEnd: boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;

Description

Fields

Private FCadencer: TgxCadencer;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FFreeEventOnEnd: boolean;

This item has no description.

Private FEvents: TgxTimeEvents;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure Reset();

This item has no description.

Properties

Published property Cadencer: TgxCadencer read FCadencer write SetCadencer;

This item has no description.

Published property Enabled: boolean read FEnabled write FEnabled default True;

This item has no description.

Published property Events: TgxTimeEvents read FEvents write SetEvents;

This item has no description.

Published property FreeEventOnEnd: boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;


GXSysHelp v.2.5: GXS.TimeEventsMgr: Class TgxTimeEvents

Class TgxTimeEvents

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TimeEventsMgr

Declaration

type TgxTimeEvents = class(TCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxTimeEvents

Overview

Methods

Public | constructor Create(aOwner: TComponent);
Public | function Add: TgxTimeEvent;
Public | function EventByName(name: String): TgxTimeEvent;
Public | function FindItemID(ID: Integer): TgxTimeEvent;

Properties

Public property Items[index: Integer]: TgxTimeEvent read GetItems write SetItems;

Description

Methods

Public constructor Create(aOwner: TComponent);

This item has no description.

Public function Add: TgxTimeEvent;

This item has no description.

Public function EventByName(name: String): TgxTimeEvent;

This item has no description.

Public function FindItemID(ID: Integer): TgxTimeEvent;

This item has no description.

Properties

Public property Items[index: Integer]: TgxTimeEvent read GetItems write SetItems;


GXSysHelp v.2.5: GXS.TimeEventsMgr: Class TgxTimeEvent

Class TgxTimeEvent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.TimeEventsMgr

Declaration

type TgxTimeEvent = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxTimeEvent

Overview

Fields

Private | FName: String;
Private | FStartTime: Double;
Private | FEndTime: Double;
Private | FElapsedTime: Double;
Private | FPeriod: Double;
Private | FEventType: TgxTimeEventType;
Private | FOnEvent: TgxTimeEventProc;
Private | FEnabled: boolean;
Private | FTickCount: Cardinal;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | procedure SetEnabled(const Value: boolean);

Properties

Public | property ElapsedTime: Double read FElapsedTime;
Published | property Enabled: boolean read FEnabled write SetEnabled default True;
Published | property EndTime: Double read FEndTime write FEndTime;
Published | property EventType: TgxTimeEventType read FEventType write FEventType default etOneShot;
Published | property Name: String read FName write SetName;
Published | property OnEvent: TgxTimeEventProc read FOnEvent write FOnEvent;
Published | property Period: Double read FPeriod write FPeriod;
Published | property StartTime: Double read FStartTime write FStartTime;
Public | property TickCount: Cardinal read FTickCount;

Description

Fields

Private FName: String;

This item has no description.

Private FStartTime: Double;

This item has no description.

Private FEndTime: Double;

This item has no description.

Private FElapsedTime: Double;

This item has no description.

Private FPeriod: Double;

This item has no description.

Private FEventType: TgxTimeEventType;

This item has no description.

Private FOnEvent: TgxTimeEventProc;

This item has no description.

Private FEnabled: boolean;

This item has no description.

Private FTickCount: Cardinal;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetEnabled(const Value: boolean);

This item has no description.

Properties

Public property ElapsedTime: Double read FElapsedTime;

Elapsed time since the event was activated

Published property Enabled: boolean read FEnabled write SetEnabled default True;

This item has no description.

Published property EndTime: Double read FEndTime write FEndTime;

This item has no description.

Published property EventType: TgxTimeEventType read FEventType write FEventType default etOneShot;

This item has no description.

Published property Name: String read FName write SetName;

This item has no description.

Published property OnEvent: TgxTimeEventProc read FOnEvent write FOnEvent;

This item has no description.

Published property Period: Double read FPeriod write FPeriod;

This item has no description.

Published property StartTime: Double read FStartTime write FStartTime;

This item has no description.

Public property TickCount: Cardinal read FTickCount;

Number of times the event was triggered since activation


GXSysHelp v.2.5: GXS.Trail

Unit GXS.Trail

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.Scene
  • GLScene.VectorTypes
  • GXS.MeshUtils
  • GLScene.VectorGeometry
  • GXS.VectorFileObjects
  • GXS.Mesh
  • GXS.Objects
  • GXS.Material
  • GLScene.Strings
  • GXS.BaseClasses

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTrail |

Types

TMarkStyle = (...);

Constants

cMaxVerts = 2000;

Description

Types

TMarkStyle = (...);

This item has no description.

Values
  • msUp
  • msDirection
  • msFaceCamera
  • msRight

Constants

cMaxVerts = 2000;


GXSysHelp v.2.5: GXS.Trail: Class TgxTrail

Class TgxTrail

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Trail

Declaration

type TgxTrail = class(TgxMesh)

Description

This item has no description. Showing description inherited from TgxMesh.

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxMesh
  • TgxTrail

Overview

Fields

Private | fVertLimit: integer;
Private | fTimeLimit: single;
Private | fMinDistance: single;
Private | fAlpha: single;
Private | fAlphaFade: Boolean;
Private | fUVScale: single;
Private | fVerts: array [1 .. cMaxVerts] of TVector3f;
Private | fUVs: array [1 .. cMaxVerts] of TTexpoint;
Private | fTimeStamps: array [1 .. cMaxVerts] of Double;
Private | fVertStart: integer;
Private | fVertEnd: integer;
Private | fVertCount: integer;
Private | fLastV0Pos: TVector3f;
Private | fLastPos: TVector3f;
Private | fLastDir: TVector3f;
Private | fLastUp: TVector3f;
Private | FLastUVs: single;
Private | fLastP1: TVector3f;
Private | fLastP2: TVector3f;
Private | FTrailObject: TgxBaseSceneObject;
Private | FMarkStyle: TMarkStyle;
Private | FMarkWidth: single;
Private | FEnabled: Boolean;
Private | FAntiZFightOffset: single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateMark(p1, p2: TVector3f; CurrentTime: Double) : Boolean; overload;
Private | function StoreAntiZFightOffset: Boolean;
Public | procedure ClearMarks;
Public | procedure CreateMark(obj: TgxBaseSceneObject; width: single; CurrentTime: Double); overload;
Public | procedure CreateMark(APos, ADir, AUp: TVector3f; AWidth: single; ACurrentTime: Double); overload;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Private | procedure SetAlpha(const Value: single);
Private | procedure SetAlphaFade(const Value: Boolean);
Private | procedure SetEnabled(const Value: Boolean);
Private | procedure SetMarkStyle(const Value: TMarkStyle);
Private | procedure SetMarkWidth(const Value: single);
Private | procedure SetMinDistance(const Value: single);
Private | procedure SetTimeLimit(const Value: single);
Private | procedure SetTrailObject(const Value: TgxBaseSceneObject);
Private | procedure SetUVScale(const Value: single);
Private | procedure SetVertLimit(const Value: integer);

Properties

Published | property Alpha: single read fAlpha write SetAlpha;
Published | property AlphaFade: Boolean read fAlphaFade write SetAlphaFade default True;
Published | property AntiZFightOffset: single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Published | property MarkStyle: TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;
Published | property MarkWidth: single read FMarkWidth write SetMarkWidth;
Published | property MinDistance: single read fMinDistance write SetMinDistance;
Published | property TimeLimit: single read fTimeLimit write SetTimeLimit;
Published | property TrailObject: TgxBaseSceneObject read FTrailObject write SetTrailObject default nil;
Published | property UVScale: single read fUVScale write SetUVScale;
Published | property VertLimit: integer read fVertLimit write SetVertLimit default 150;

Description

Fields

Private fVertLimit: integer;

This item has no description.

Private fTimeLimit: single;

This item has no description.

Private fMinDistance: single;

This item has no description.

Private fAlpha: single;

This item has no description.

Private fAlphaFade: Boolean;

This item has no description.

Private fUVScale: single;

This item has no description.

Private fVerts: array [1 .. cMaxVerts] of TVector3f;

This item has no description.

Private fUVs: array [1 .. cMaxVerts] of TTexpoint;

This item has no description.

Private fTimeStamps: array [1 .. cMaxVerts] of Double;

This item has no description.

Private fVertStart: integer;

This item has no description.

Private fVertEnd: integer;

This item has no description.

Private fVertCount: integer;

This item has no description.

Private fLastV0Pos: TVector3f;

This item has no description.

Private fLastPos: TVector3f;

This item has no description.

Private fLastDir: TVector3f;

This item has no description.

Private fLastUp: TVector3f;

This item has no description.

Private FLastUVs: single;

This item has no description.

Private fLastP1: TVector3f;

used for UV scaling

Private fLastP2: TVector3f;

used for UV scaling

Private FTrailObject: TgxBaseSceneObject;

This item has no description.

Private FMarkStyle: TMarkStyle;

This item has no description.

Private FMarkWidth: single;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FAntiZFightOffset: single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CreateMark(p1, p2: TVector3f; CurrentTime: Double) : Boolean; overload;

This item has no description.

Private function StoreAntiZFightOffset: Boolean;

This item has no description.

Public procedure ClearMarks;

This item has no description.

Public procedure CreateMark(obj: TgxBaseSceneObject; width: single; CurrentTime: Double); overload;

This item has no description.

Public procedure CreateMark(APos, ADir, AUp: TVector3f; AWidth: single; ACurrentTime: Double); overload;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

EnableUVmapping: boolean; // generate UV's or not

Private procedure SetAlpha(const Value: single);

This item has no description.

Private procedure SetAlphaFade(const Value: Boolean);

This item has no description.

Private procedure SetEnabled(const Value: Boolean);

This item has no description.

Private procedure SetMarkStyle(const Value: TMarkStyle);

This item has no description.

Private procedure SetMarkWidth(const Value: single);

This item has no description.

Private procedure SetMinDistance(const Value: single);

This item has no description.

Private procedure SetTimeLimit(const Value: single);

This item has no description.

Private procedure SetTrailObject(const Value: TgxBaseSceneObject);

This item has no description.

Private procedure SetUVScale(const Value: single);

This item has no description.

Private procedure SetVertLimit(const Value: integer);

This item has no description.

Properties

Published property Alpha: single read fAlpha write SetAlpha;

This item has no description.

Published property AlphaFade: Boolean read fAlphaFade write SetAlphaFade default True;

This item has no description.

Published property AntiZFightOffset: single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;

Add a tiny bit of offset to help prevent z-fighting.. Need a better solution here as this will get out of whack on really long trails and is dependant on scene scale.

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

This item has no description.

Published property MarkStyle: TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;

This item has no description.

Published property MarkWidth: single read FMarkWidth write SetMarkWidth;

This item has no description.

Published property MinDistance: single read fMinDistance write SetMinDistance;

Don't create mark unless moved at least this distance.

Published property TimeLimit: single read fTimeLimit write SetTimeLimit;

This item has no description.

Published property TrailObject: TgxBaseSceneObject read FTrailObject write SetTrailObject default nil;

This item has no description.

Published property UVScale: single read fUVScale write SetUVScale;

This item has no description.

Published property VertLimit: integer read fVertLimit write SetVertLimit default 150;


GXSysHelp v.2.5: GXS.Tree

Unit GXS.Tree

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • System.Math
  • GXS.XOpenGL
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.ApplicationFileIO
  • GLScene.VectorTypes
  • GLScene.Strings
  • GXS.State
  • GXS.Scene
  • GXS.VectorFileObjects
  • GXS.RenderContextInfo
  • GXS.Context
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxTreeLeaves |
Class TgxTreeBranch |
Class TgxTreeBranches |
Class TgxTreeBranchNoise |
Class TgxTree |


GXSysHelp v.2.5: GXS.Tree: Class TgxTreeLeaves

Class TgxTreeLeaves

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Tree

Declaration

type TgxTreeLeaves = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTreeLeaves

Overview

Fields

Private | FOwner: TgxTree;
Private | FCount: Integer;
Private | FVertices: TgxAffineVectorList;
Private | FNormals: TgxAffineVectorList;
Private | FTexCoords: TgxAffineVectorList;

Methods

Public | constructor Create(AOwner: TgxTree);
Public | destructor Destroy; override;
Public | procedure AddNew(matrix: TMatrix4f);
Public | procedure BuildList(var rci: TgxRenderContextInfo);
Public | procedure Clear;

Properties

Public | property Count: Integer read FCount;
Public | property Normals: TgxAffineVectorList read FNormals;
Public | property Owner: TgxTree read FOwner;
Public | property TexCoords: TgxAffineVectorList read FTexCoords;
Public | property Vertices: TgxAffineVectorList read FVertices;

Description

Fields

Private FOwner: TgxTree;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FVertices: TgxAffineVectorList;

This item has no description.

Private FNormals: TgxAffineVectorList;

This item has no description.

Private FTexCoords: TgxAffineVectorList;

This item has no description.

Methods

Public constructor Create(AOwner: TgxTree);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddNew(matrix: TMatrix4f);

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Clear;

This item has no description.

Properties

Public property Count: Integer read FCount;

This item has no description.

Public property Normals: TgxAffineVectorList read FNormals;

This item has no description.

Public property Owner: TgxTree read FOwner;

This item has no description.

Public property TexCoords: TgxAffineVectorList read FTexCoords;

This item has no description.

Public property Vertices: TgxAffineVectorList read FVertices;


GXSysHelp v.2.5: GXS.Tree: Class TgxTreeBranch

Class TgxTreeBranch

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Tree

Declaration

type TgxTreeBranch = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTreeBranch

Overview

Fields

Private | FOwner: TgxTreeBranches;
Private | FLeft: TgxTreeBranch;
Private | FCenter: TgxTreeBranch;
Private | FRight: TgxTreeBranch;
Private | FParent: TgxTreeBranch;
Private | FBranchID: Integer;
Private | FParentID: Integer;
Private | FMatrix: TMatrix4f;
Private | FLower: TgxIntegerList;
Private | FUpper: TgxIntegerList;
Private | FCentralLeader: Boolean;

Methods

Public | constructor Create(AOwner: TgxTreeBranches; AParent: TgxTreeBranch);
Public | destructor Destroy; override;
Private | procedure BuildBranch(branchNoise: TgxTreeBranchNoise; const matrix: TMatrix4f; TexCoordY, Twist: Single; Level: Integer);

Properties

Public | property Center: TgxTreeBranch read FCenter;
Public | property Left: TgxTreeBranch read FLeft;
Public | property Lower: TgxIntegerList read FLower;
Public | property matrix: TMatrix4f read FMatrix;
Public | property Owner: TgxTreeBranches read FOwner;
Public | property Parent: TgxTreeBranch read FParent;
Public | property Right: TgxTreeBranch read FRight;
Public | property Upper: TgxIntegerList read FUpper;

Description

Fields

Private FOwner: TgxTreeBranches;

This item has no description.

Private FLeft: TgxTreeBranch;

This item has no description.

Private FCenter: TgxTreeBranch;

This item has no description.

Private FRight: TgxTreeBranch;

This item has no description.

Private FParent: TgxTreeBranch;

This item has no description.

Private FBranchID: Integer;

This item has no description.

Private FParentID: Integer;

This item has no description.

Private FMatrix: TMatrix4f;

This item has no description.

Private FLower: TgxIntegerList;

This item has no description.

Private FUpper: TgxIntegerList;

This item has no description.

Private FCentralLeader: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TgxTreeBranches; AParent: TgxTreeBranch);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure BuildBranch(branchNoise: TgxTreeBranchNoise; const matrix: TMatrix4f; TexCoordY, Twist: Single; Level: Integer);

This item has no description.

Properties

Public property Center: TgxTreeBranch read FCenter;

This item has no description.

Public property Left: TgxTreeBranch read FLeft;

This item has no description.

Public property Lower: TgxIntegerList read FLower;

This item has no description.

Public property matrix: TMatrix4f read FMatrix;

This item has no description.

Public property Owner: TgxTreeBranches read FOwner;

This item has no description.

Public property Parent: TgxTreeBranch read FParent;

This item has no description.

Public property Right: TgxTreeBranch read FRight;

This item has no description.

Public property Upper: TgxIntegerList read FUpper;


GXSysHelp v.2.5: GXS.Tree: Class TgxTreeBranches

Class TgxTreeBranches

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Tree

Declaration

type TgxTreeBranches = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTreeBranches

Overview

Fields

Private | FOwner: TgxTree;
Private | FSinList: TgxSingleList;
Private | FCosList: TgxSingleList;
Private | FVertices: TgxAffineVectorList;
Private | FNormals: TgxAffineVectorList;
Private | FTexCoords: TgxAffineVectorList;
Private | FIndices: TgxIntegerList;
Private | FRoot: TgxTreeBranch;
Private | FCount: Integer;
Private | FBranchCache: TList;
Private | FBranchIndices: TgxIntegerList;

Methods

Public | constructor Create(AOwner: TgxTree);
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo);
Public | procedure Clear;
Private | procedure BuildBranches;

Properties

Public | property CosList: TgxSingleList read FCosList;
Public | property Count: Integer read FCount;
Public | property Normals: TgxAffineVectorList read FNormals;
Public | property Owner: TgxTree read FOwner;
Public | property SinList: TgxSingleList read FSinList;
Public | property TexCoords: TgxAffineVectorList read FTexCoords;
Public | property Vertices: TgxAffineVectorList read FVertices;

Description

Fields

Private FOwner: TgxTree;

This item has no description.

Private FSinList: TgxSingleList;

This item has no description.

Private FCosList: TgxSingleList;

This item has no description.

Private FVertices: TgxAffineVectorList;

This item has no description.

Private FNormals: TgxAffineVectorList;

This item has no description.

Private FTexCoords: TgxAffineVectorList;

This item has no description.

Private FIndices: TgxIntegerList;

This item has no description.

Private FRoot: TgxTreeBranch;

This item has no description.

Private FCount: Integer;

This item has no description.

Private FBranchCache: TList;

This item has no description.

Private FBranchIndices: TgxIntegerList;

This item has no description.

Methods

Public constructor Create(AOwner: TgxTree);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure Clear;

This item has no description.

Private procedure BuildBranches;

This item has no description.

Properties

Public property CosList: TgxSingleList read FCosList;

This item has no description.

Public property Count: Integer read FCount;

This item has no description.

Public property Normals: TgxAffineVectorList read FNormals;

This item has no description.

Public property Owner: TgxTree read FOwner;

This item has no description.

Public property SinList: TgxSingleList read FSinList;

This item has no description.

Public property TexCoords: TgxAffineVectorList read FTexCoords;

This item has no description.

Public property Vertices: TgxAffineVectorList read FVertices;


GXSysHelp v.2.5: GXS.Tree: Class TgxTreeBranchNoise

Class TgxTreeBranchNoise

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Tree

Declaration

type TgxTreeBranchNoise = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxTreeBranchNoise

Overview

Fields

Private | FBranchNoise: Single;
Private | FLeft: TgxTreeBranchNoise;
Private | FRight: TgxTreeBranchNoise;
Private | FCenter: TgxTreeBranchNoise;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Private | function GetCenter: TgxTreeBranchNoise;
Private | function GetLeft: TgxTreeBranchNoise;
Private | function GetRight: TgxTreeBranchNoise;

Properties

Public | property branchNoise: Single read FBranchNoise;
Public | property Center: TgxTreeBranchNoise read GetCenter;
Public | property Left: TgxTreeBranchNoise read GetLeft;
Public | property Right: TgxTreeBranchNoise read GetRight;

Description

Fields

Private FBranchNoise: Single;

This item has no description.

Private FLeft: TgxTreeBranchNoise;

This item has no description.

Private FRight: TgxTreeBranchNoise;

This item has no description.

Private FCenter: TgxTreeBranchNoise;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetCenter: TgxTreeBranchNoise;

This item has no description.

Private function GetLeft: TgxTreeBranchNoise;

This item has no description.

Private function GetRight: TgxTreeBranchNoise;

This item has no description.

Properties

Public property branchNoise: Single read FBranchNoise;

This item has no description.

Public property Center: TgxTreeBranchNoise read GetCenter;

This item has no description.

Public property Left: TgxTreeBranchNoise read GetLeft;

This item has no description.

Public property Right: TgxTreeBranchNoise read GetRight;


GXSysHelp v.2.5: GXS.Tree: Class TgxTree

Class TgxTree

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Tree

Declaration

type TgxTree = class(TgxImmaterialSceneObject)

Description

This item has no description. Showing description inherited from TgxImmaterialSceneObject.

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxImmaterialSceneObject
  • TgxTree

Overview

Fields

Private | FDepth: Integer;
Private | FBranchFacets: Integer;
Private | FLeafSize: Single;
Private | FBranchSize: Single;
Private | FBranchNoise: Single;
Private | FBranchAngleBias: Single;
Private | FBranchAngle: Single;
Private | FBranchTwist: Single;
Private | FBranchRadius: Single;
Private | FLeafThreshold: Single;
Private | FCentralLeaderBias: Single;
Private | FCentralLeader: Boolean;
Private | FSeed: Integer;
Private | FAutoCenter: Boolean;
Private | FAutoRebuild: Boolean;
Private | FCenterBranchConstant: Single;
Private | FLeaves: TgxTreeLeaves;
Private | FBranches: TgxTreeBranches;
Private | FNoise: TgxTreeBranchNoise;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FLeafMaterialName: TgxLibMaterialName;
Private | FLeafBackMaterialName: TgxLibMaterialName;
Private | FBranchMaterialName: TgxLibMaterialName;
Private | FRebuildTree: Boolean;
Private | FAxisAlignedDimensionsCache: TVector4f;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure BuildMesh(GLBaseMesh: TgxBaseMesh);
Public | procedure Clear;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure ForceTotalRebuild;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure LoadFromFile(aFileName: String);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RebuildTree;
Public | procedure SaveToFile(aFileName: String);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure StructureChanged; override;

Properties

Published | property AutoCenter: Boolean read FAutoCenter write SetAutoCenter;
Published | property AutoRebuild: Boolean read FAutoRebuild write SetAutoRebuild;
Published | property BranchAngle: Single read FBranchAngle write SetBranchAngle;
Published | property BranchAngleBias: Single read FBranchAngleBias write SetBranchAngleBias;
Public | property Branches: TgxTreeBranches read FBranches;
Published | property BranchFacets: Integer read FBranchFacets write SetBranchFacets;
Published | property BranchMaterialName: TgxLibMaterialName read FBranchMaterialName write SetBranchMaterialName;
Published | property branchNoise: Single read FBranchNoise write SetBranchNoise;
Published | property BranchRadius: Single read FBranchRadius write SetBranchRadius;
Published | property BranchSize: Single read FBranchSize write SetBranchSize;
Published | property BranchTwist: Single read FBranchTwist write SetBranchTwist;
Published | property CenterBranchConstant: Single read FCenterBranchConstant write SetCenterBranchConstant;
Published | property CentralLeader: Boolean read FCentralLeader write SetCentralLeader;
Published | property CentralLeaderBias: Single read FCentralLeaderBias write SetCentralLeaderBias;
Published | property Depth: Integer read FDepth write SetDepth;
Published | property LeafBackMaterialName: TgxLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;
Published | property LeafMaterialName: TgxLibMaterialName read FLeafMaterialName write SetLeafMaterialName;
Published | property LeafSize: Single read FLeafSize write SetLeafSize;
Published | property LeafThreshold: Single read FLeafThreshold write SetLeafThreshold;
Public | property Leaves: TgxTreeLeaves read FLeaves;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Noise: TgxTreeBranchNoise read FNoise;
Published | property Seed: Integer read FSeed write SetSeed;

Description

Fields

Private FDepth: Integer;

This item has no description.

Private FBranchFacets: Integer;

This item has no description.

Private FLeafSize: Single;

This item has no description.

Private FBranchSize: Single;

This item has no description.

Private FBranchNoise: Single;

This item has no description.

Private FBranchAngleBias: Single;

This item has no description.

Private FBranchAngle: Single;

This item has no description.

Private FBranchTwist: Single;

This item has no description.

Private FBranchRadius: Single;

This item has no description.

Private FLeafThreshold: Single;

This item has no description.

Private FCentralLeaderBias: Single;

This item has no description.

Private FCentralLeader: Boolean;

This item has no description.

Private FSeed: Integer;

This item has no description.

Private FAutoCenter: Boolean;

This item has no description.

Private FAutoRebuild: Boolean;

This item has no description.

Private FCenterBranchConstant: Single;

This item has no description.

Private FLeaves: TgxTreeLeaves;

This item has no description.

Private FBranches: TgxTreeBranches;

This item has no description.

Private FNoise: TgxTreeBranchNoise;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FLeafMaterialName: TgxLibMaterialName;

This item has no description.

Private FLeafBackMaterialName: TgxLibMaterialName;

This item has no description.

Private FBranchMaterialName: TgxLibMaterialName;

This item has no description.

Private FRebuildTree: Boolean;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure BuildMesh(GLBaseMesh: TgxBaseMesh);

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Public procedure ForceTotalRebuild;

This item has no description.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Public procedure LoadFromFile(aFileName: String);

This item has no description.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure RebuildTree;

This item has no description.

Public procedure SaveToFile(aFileName: String);

This item has no description.

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Properties

Published property AutoCenter: Boolean read FAutoCenter write SetAutoCenter;

Automatically center the tree's vertices after building them.

Published property AutoRebuild: Boolean read FAutoRebuild write SetAutoRebuild;

Automatically rebuild the tree after changing the settings

Published property BranchAngle: Single read FBranchAngle write SetBranchAngle;

Effects the balance of the tree.

Published property BranchAngleBias: Single read FBranchAngleBias write SetBranchAngleBias;

Effects the habit of the tree. Values from 0 to 1 refer to Upright to Spreading respectively.

Public property Branches: TgxTreeBranches read FBranches;

This item has no description.

Published property BranchFacets: Integer read FBranchFacets write SetBranchFacets;

The number of facets for each branch in the tree.

Published property BranchMaterialName: TgxLibMaterialName read FBranchMaterialName write SetBranchMaterialName;

This item has no description.

Published property branchNoise: Single read FBranchNoise write SetBranchNoise;

Overall branch noise influence. Relates to the 'fullness' of the tree.

Published property BranchRadius: Single read FBranchRadius write SetBranchRadius;

Effects the thickness of the branches.

Published property BranchSize: Single read FBranchSize write SetBranchSize;

Branch length modifier.

Published property BranchTwist: Single read FBranchTwist write SetBranchTwist;

Effects the rotation of each sub branch in recursion.

Published property CenterBranchConstant: Single read FCenterBranchConstant write SetCenterBranchConstant;

Central branch can be thinner(lower values)/thicker(->1) depending on this constant. The effect also depends on the BranchAngle variable.

Published property CentralLeader: Boolean read FCentralLeader write SetCentralLeader;

Does this tree have a central leader?

Published property CentralLeaderBias: Single read FCentralLeaderBias write SetCentralLeaderBias;

Determines how BranchAngle effects the central leader (CentralLeader must = True).

Published property Depth: Integer read FDepth write SetDepth;

The depth of tree branch recursion.

Published property LeafBackMaterialName: TgxLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;

This item has no description.

Published property LeafMaterialName: TgxLibMaterialName read FLeafMaterialName write SetLeafMaterialName;

This item has no description.

Published property LeafSize: Single read FLeafSize write SetLeafSize;

Leaf size modifier. Leaf size is also influenced by branch recursion scale.

Published property LeafThreshold: Single read FLeafThreshold write SetLeafThreshold;

Determines how thin a branch can get before a leaf is substituted.

Public property Leaves: TgxTreeLeaves read FLeaves;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Noise: TgxTreeBranchNoise read FNoise;

This item has no description.

Published property Seed: Integer read FSeed write SetSeed;


GXSysHelp v.2.5: GXS.VectorFileObjects

Unit GXS.VectorFileObjects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.Math
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLScene.Utils
  • GLScene.GeometryBB
  • GLScene.TextureFormat
  • GXS.BaseClasses
  • GXS.VectorLists
  • GXS.PersistentClasses
  • GXS.Coordinates
  • GXS.XOpenGL
  • GXS.ApplicationFileIO
  • GXS.Scene
  • GXS.Texture
  • GXS.Material
  • GXS.Mesh
  • GXS.Octree
  • GXS.Silhouette
  • GXS.Context
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.ImageUtils
  • GXS.MeshUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBaseMeshObject |
Class TgxSkeletonFrame |
Class TgxSkeletonFrameList |
Class TgxSkeletonBoneList |
Class TgxSkeletonRootBoneList |
Class TgxSkeletonBone |
Class TgxSkeletonCollider |
Class TgxSkeletonColliderList |
Record TGXBlendedLerpInfo |
Class TgxSkeleton |
Class TgxMeshObject |
Class TgxMeshObjectList |
Class TgxMeshMorphTarget |
Class TgxMeshMorphTargetList |
Class TgxMorphableMeshObject |
Packed Record TgxVertexBoneWeight |
Class TgxSkeletonMeshObject |
Class TgxFaceGroup |
Class TgxFGVertexIndexList |
Class TFGVertexNormalTexIndexList |
Class TgxFGIndexTexCoordList |
Class TgxFaceGroups |
Class TgxVectorFile |
Class TgxVectorFileGLSM |
Class TgxBaseMesh |
Class TgxFreeForm |
Class TgxActorAnimation |
Class TgxActorAnimations |
Class TgxBaseAnimationControler |
Class TgxAnimationControler |
Class TgxActor |
Class TgxVectorFileFormat |
Class TgxVectorFileFormatsList |
Class EgxInvalidVectorFile |

Functions and Procedures

function GetVectorFileFormats: TgxVectorFileFormatsList;
function VectorFileFormatsFilter: string;
function VectorFileFormatsSaveFilter: string;
function VectorFileFormatExtensionByIndex(Index: Integer): string;
procedure RegisterVectorFileFormat(const aExtension, aDescription: string; AClass: TgxVectorFileClass);
procedure UnregisterVectorFileClass(AClass: TgxVectorFileClass);

Types

PgxVertexBoneWeightArray = ˆTgxVertexBoneWeightArray;
PgxVerticesBoneWeights = ˆTgxVerticesBoneWeights;
TgxActorAnimationMode = (...);
TgxActorAnimationName = string;
TgxActorAnimationReference = (...);
TgxActorFrameInterpolation = (...);
TgxActorOption = (...);
TgxActorOptions = set of TgxActorOption;
TgxFaceGroupMeshMode = (...);
TgxMeshAutoCentering = (...);
TgxMeshAutoCenterings = set of TgxMeshAutoCentering;
TgxMeshNormalsOrientation = (...);
TgxMeshObjectListClass = class of TgxMeshObjectList;
TgxMeshObjectMode = (...);
TgxMeshObjectRenderingOption = (...);
TgxMeshObjectRenderingOptions = set of TgxMeshObjectRenderingOption;
TgxSkeletonFrameTransform = (...);
TgxVectorFileClass = class of TgxVectorFile;
TgxVertexBoneWeightArray = array [0 .. MaxInt div (2 * SizeOf(TgxVertexBoneWeight))] of TgxVertexBoneWeight;
TgxVertexBoneWeightDynArray = array of TgxVertexBoneWeight;
TgxVerticesBoneWeights = array [0 .. MaxInt div (2 * SizeOf(PgxVertexBoneWeightArray))] of PgxVertexBoneWeightArray;
TVBOBuffer = (...);
TVBOBuffers = set of TVBOBuffer;

Constants

cDefaultActorOptions = [aoSkeletonNormalizeNormals];

Variables

vVectorFileObjectsAllocateMaterials: Boolean = True;
vVectorFileObjectsEnableVBOByDefault: Boolean = True;

Description

Functions and Procedures

function GetVectorFileFormats: TgxVectorFileFormatsList;

Read access to the list of registered vector file formats

function VectorFileFormatsFilter: string;

A file extension filter suitable for dialog's 'Filter' property

function VectorFileFormatsSaveFilter: string;

A file extension filter suitable for a savedialog's 'Filter' property

function VectorFileFormatExtensionByIndex(Index: Integer): string;

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.

procedure RegisterVectorFileFormat(const aExtension, aDescription: string; AClass: TgxVectorFileClass);

This item has no description.

procedure UnregisterVectorFileClass(AClass: TgxVectorFileClass);

This item has no description.

Types

PgxVertexBoneWeightArray = ˆTgxVertexBoneWeightArray;

This item has no description.

PgxVerticesBoneWeights = ˆTgxVerticesBoneWeights;

This item has no description.

TgxActorAnimationMode = (...);

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control

Values
  • aamNone
  • aamPlayOnce
  • aamLoop
  • aamBounceForward
  • aamBounceBackward
  • aamLoopBackward
  • aamExternal
TgxActorAnimationName = string;

This item has no description.

TgxActorAnimationReference = (...);

This item has no description.

Values
  • aarMorph
  • aarSkeleton
  • aarNone
TgxActorFrameInterpolation = (...);

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame

Values
  • afpNone
  • afpLinear
TgxActorOption = (...);

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.

Values
  • aoSkeletonNormalizeNormals
TgxActorOptions = set of TgxActorOption;

This item has no description.

TgxFaceGroupMeshMode = (...);

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.

Values
  • fgmmTriangles
  • fgmmTriangleStrip
  • fgmmFlatTriangles
  • fgmmTriangleFan
  • fgmmQuads
TgxMeshAutoCentering = (...);

This item has no description.

Values
  • macCenterX
  • macCenterY
  • macCenterZ
  • macUseBarycenter
  • macRestorePosition
TgxMeshAutoCenterings = set of TgxMeshAutoCentering;

This item has no description.

TgxMeshNormalsOrientation = (...);

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow

Values
  • mnoDefault
  • mnoInvert
TgxMeshObjectListClass = class of TgxMeshObjectList;

This item has no description.

TgxMeshObjectMode = (...);

This item has no description.

Values
  • momTriangles
  • momTriangleStrip
  • momFaceGroups
TgxMeshObjectRenderingOption = (...);

Rendering options per TgxMeshObject. moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list.

Values
  • moroGroupByMaterial
TgxMeshObjectRenderingOptions = set of TgxMeshObjectRenderingOption;

This item has no description.

TgxSkeletonFrameTransform = (...);

This item has no description.

Values
  • sftRotation
  • sftQuaternion
TgxVectorFileClass = class of TgxVectorFile;

This item has no description.

TgxVertexBoneWeightArray = array [0 .. MaxInt div (2 * SizeOf(TgxVertexBoneWeight))] of TgxVertexBoneWeight;

This item has no description.

TgxVertexBoneWeightDynArray = array of TgxVertexBoneWeight;

This item has no description.

TgxVerticesBoneWeights = array [0 .. MaxInt div (2 * SizeOf(PgxVertexBoneWeightArray))] of PgxVertexBoneWeightArray;

This item has no description.

TVBOBuffer = (...);

This item has no description.

Values
  • vbVertices
  • vbNormals
  • vbColors
  • vbTexCoords
  • vbLightMapTexCoords
  • vbTexCoordsEx
TVBOBuffers = set of TVBOBuffer;

This item has no description.

Constants

cDefaultActorOptions = [aoSkeletonNormalizeNormals];

This item has no description.

Variables

vVectorFileObjectsAllocateMaterials: Boolean = True;

This item has no description.

vVectorFileObjectsEnableVBOByDefault: Boolean = True;

Flag to avoid loading materials (useful for IDE Extentions or scene editors)


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxBaseMeshObject

Class TgxBaseMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxBaseMeshObject = class(TgxPersistentObject)

Description

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject

Overview

Fields

Private | FName: string;
Private | FVertices: TgxAffineVectorList;
Private | FNormals: TgxAffineVectorList;
Private | FVisible: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildNormals(vertexIndices: TgxIntegerList; mode: TgxMeshObjectMode; normalIndices: TgxIntegerList = nil);
Public | procedure Clear; virtual;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); virtual;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Name: string read FName write FName;
Public | property normals: TgxAffineVectorList read FNormals write SetNormals;
Public | property Vertices: TgxAffineVectorList read FVertices write SetVertices;
Public | property Visible: Boolean read FVisible write FVisible;

Description

Fields

Private FName: string;

This item has no description.

Private FVertices: TgxAffineVectorList;

This item has no description.

Private FNormals: TgxAffineVectorList;

This item has no description.

Private FVisible: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; virtual;

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildNormals(vertexIndices: TgxIntegerList; mode: TgxMeshObjectMode; normalIndices: TgxIntegerList = nil);

Builds (smoothed) normals for the vertex list. If normalIndices is nil, the method assumes a bijection between vertices and normals sets, and when performed, Normals and Vertices list will have the same number of items (whatever previously was in the Normals list is ignored/removed). If normalIndices is defined, normals will be added to the list and their indices will be added to normalIndices. Already defined normals and indices are preserved. The only valid modes are currently momTriangles and momTriangleStrip (ie. momFaceGroups not supported).

Public procedure Clear; virtual;

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector); virtual;

Translates all the vertices by the given delta.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property normals: TgxAffineVectorList read FNormals write SetNormals;

This item has no description.

Public property Vertices: TgxAffineVectorList read FVertices write SetVertices;

This item has no description.

Public property Visible: Boolean read FVisible write FVisible;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonFrame

Class TgxSkeletonFrame

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonFrame = class(TgxPersistentObject)

Description

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonFrame

Overview

Fields

Private | FOwner: TgxSkeletonFrameList;
Private | FName: string;
Private | FPosition: TgxAffineVectorList;
Private | FRotation: TgxAffineVectorList;
Private | FQuaternion: TGQuaternionList;
Private | FLocalMatrixList: PMatrixArray;
Private | FTransformMode: TgxSkeletonFrameTransform;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxSkeletonFrameList);
Public | destructor Destroy; override;
Public | function LocalMatrixList: PMatrixArray;
Public | procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);
Public | procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);
Public | procedure FlushLocalMatrixList;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Name: string read FName write FName;
Public | property Owner: TgxSkeletonFrameList read FOwner;
Public | property Position: TgxAffineVectorList read FPosition write SetPosition;
Public | property Quaternion: TGQuaternionList read FQuaternion write SetQuaternion;
Public | property Rotation: TgxAffineVectorList read FRotation write SetRotation;
Public | property TransformMode: TgxSkeletonFrameTransform read FTransformMode write FTransformMode;

Description

Fields

Private FOwner: TgxSkeletonFrameList;

This item has no description.

Private FName: string;

This item has no description.

Private FPosition: TgxAffineVectorList;

This item has no description.

Private FRotation: TgxAffineVectorList;

This item has no description.

Private FQuaternion: TGQuaternionList;

This item has no description.

Private FLocalMatrixList: PMatrixArray;

This item has no description.

Private FTransformMode: TgxSkeletonFrameTransform;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxSkeletonFrameList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function LocalMatrixList: PMatrixArray;

Calculate or retrieves an array of local bone matrices. This array is calculated on the first call after creation, and the first call following a FlushLocalMatrixList. Subsequent calls return the same arrays.

Public procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);

This item has no description.

Public procedure FlushLocalMatrixList;

Flushes (frees) then LocalMatrixList data. Call this function to allow a recalculation of local matrices.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Name: string read FName write FName;

This item has no description.

Public property Owner: TgxSkeletonFrameList read FOwner;

This item has no description.

Public property Position: TgxAffineVectorList read FPosition write SetPosition;

Position values for the joints.

Public property Quaternion: TGQuaternionList read FQuaternion write SetQuaternion;

Quaternions are an alternative to Euler rotations to build the global matrices for the skeleton bones.

Public property Rotation: TgxAffineVectorList read FRotation write SetRotation;

Rotation values for the joints.

Public property TransformMode: TgxSkeletonFrameTransform read FTransformMode write FTransformMode;

TransformMode indicates whether to use Rotation or Quaternion to build the local transform matrices.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonFrameList

Class TgxSkeletonFrameList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonFrameList = class(TgxPersistentObjectList)

Description

A list of TgxSkeletonFrame objects.

Hierarchy

  • TgxPersistentObjectList
  • TgxSkeletonFrameList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(aOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TgxSkeletonFrame read GetSkeletonFrame;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True; SetTransformMode: Boolean = True);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TgxSkeletonFrame read GetSkeletonFrame;

This item has no description.

Public property Owner: TPersistent read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonBoneList

Class TgxSkeletonBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonBoneList = class(TgxPersistentObjectList)

Description

A list of skeleton bones.

Hierarchy

  • TgxPersistentObjectList
  • TgxSkeletonBoneList

Overview

Fields

Private FSkeleton: TgxSkeleton;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxSkeleton);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TgxSkeletonBone; virtual;
Public | function BoneByName(const aName: string): TgxSkeletonBone; virtual;
Public | function BoneCount: Integer;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); virtual; abstract;
Public | procedure PrepareGlobalMatrices; virtual;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Items[Index: Integer]: TgxSkeletonBone read GetSkeletonBone;
Public | property Skeleton: TgxSkeleton read FSkeleton;

Description

Fields

Private FSkeleton: TgxSkeleton;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxSkeleton);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TgxSkeletonBone; virtual;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TgxSkeletonBone; virtual;

Returns a bone by its Name, nil if not found.

Public function BoneCount: Integer;

Number of bones (including all children and self).

Public procedure BuildList(var mrci: TgxRenderContextInfo); virtual; abstract;

Render skeleton wireframe

Public procedure PrepareGlobalMatrices; virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TgxSkeletonBone read GetSkeletonBone;

This item has no description.

Public property Skeleton: TgxSkeleton read FSkeleton;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonRootBoneList

Class TgxSkeletonRootBoneList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonRootBoneList = class(TgxSkeletonBoneList)

Description

This list store skeleton root bones exclusively.

Hierarchy

  • TgxPersistentObjectList
  • TgxSkeletonBoneList
  • TgxSkeletonRootBoneList

Overview

Methods

Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property GlobalMatrix: TMatrix4f read FGlobalMatrix write FGlobalMatrix;

Description

Methods

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

Render skeleton wireframe

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property GlobalMatrix: TMatrix4f read FGlobalMatrix write FGlobalMatrix;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonBone

Class TgxSkeletonBone

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonBone = class(TgxSkeletonBoneList)

Description

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TgxSkeletonFrame, but the calculated bone matrices are stored here.

Hierarchy

  • TgxPersistentObjectList
  • TgxSkeletonBoneList
  • TgxSkeletonBone

Overview

Fields

Private | FOwner: TgxSkeletonBoneList;
Private | FBoneID: Integer;
Private | FName: string;
Private | FColor: Cardinal;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxSkeletonBoneList);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TgxSkeletonBone; override;
Public | function BoneByName(const aName: string): TgxSkeletonBone; override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure Clean; override;
Public | procedure PrepareGlobalMatrices; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure SetGlobalMatrix(Matrix: TMatrix4f);
Public | procedure SetGlobalMatrixForRagDoll(RagDollMatrix: TMatrix4f);
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property BoneID: Integer read FBoneID write FBoneID;
Public | property Color: Cardinal read FColor write SetColor;
Public | property GlobalMatrix: TMatrix4f read FGlobalMatrix;
Public | property Items[Index: Integer]: TgxSkeletonBone read GetSkeletonBone;
Public | property Name: string read FName write FName;
Public | property Owner: TgxSkeletonBoneList read FOwner;

Description

Fields

Private FOwner: TgxSkeletonBoneList;

This item has no description.

Private FBoneID: Integer;

indirectly persistent

Private FName: string;

This item has no description.

Private FColor: Cardinal;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxSkeletonBoneList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TgxSkeletonBone; override;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TgxSkeletonBone; override;

This item has no description. Showing description inherited from TgxSkeletonBoneList.BoneByName.

Returns a bone by its Name, nil if not found.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

Render skeleton wireframe

Public procedure Clean; override;

Free all sub bones and reset BoneID and Name.

Public procedure PrepareGlobalMatrices; override;

Calculates the global matrix for the bone and its sub-bone. Call this function directly only the RootBone.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure SetGlobalMatrix(Matrix: TMatrix4f);

Set the bone's matrix. Becareful using this.

Public procedure SetGlobalMatrixForRagDoll(RagDollMatrix: TMatrix4f);

Ragdoll Set the bone's GlobalMatrix. Used for Ragdoll.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property BoneID: Integer read FBoneID write FBoneID;

This item has no description.

Public property Color: Cardinal read FColor write SetColor;

This item has no description.

Public property GlobalMatrix: TMatrix4f read FGlobalMatrix;

Global Matrix for the bone in the current frame. Global matrices must be prepared by invoking PrepareGlobalMatrices on the root bone.

Public property Items[Index: Integer]: TgxSkeletonBone read GetSkeletonBone;

This item has no description.

Public property Name: string read FName write FName;

This item has no description.

Public property Owner: TgxSkeletonBoneList read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonCollider

Class TgxSkeletonCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonCollider = class(TgxPersistentObject)

Description

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider

Overview

Fields

Private | FOwner: TgxSkeletonColliderList;
Private | FBone: TgxSkeletonBone;
Private | FBoneID: Integer;
Private | FLocalMatrix: TMatrix4f;
Private | FGlobalMatrix: TMatrix4f;
Private | FAutoUpdate: Boolean;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxSkeletonColliderList);
Public | procedure AlignCollider; virtual;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;
Public | property Bone: TgxSkeletonBone read FBone write SetBone;
Public | property GlobalMatrix: TMatrix4f read FGlobalMatrix;
Public | property LocalMatrix: TMatrix4f read FLocalMatrix write SetLocalMatrix;
Public | property Owner: TgxSkeletonColliderList read FOwner;

Description

Fields

Private FOwner: TgxSkeletonColliderList;

This item has no description.

Private FBone: TgxSkeletonBone;

This item has no description.

Private FBoneID: Integer;

This item has no description.

Private FLocalMatrix: TMatrix4f;

This item has no description.

Private FGlobalMatrix: TMatrix4f;

This item has no description.

Private FAutoUpdate: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxSkeletonColliderList);

This item has no description.

Public procedure AlignCollider; virtual;

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;

This item has no description.

Public property Bone: TgxSkeletonBone read FBone write SetBone;

The bone that this collider associates with.

Public property GlobalMatrix: TMatrix4f read FGlobalMatrix;

Global offset and orientation of the collider. This gets set in the AlignCollider method.

Public property LocalMatrix: TMatrix4f read FLocalMatrix write SetLocalMatrix;

Offset and orientation of the collider in the associated bone's space.

Public property Owner: TgxSkeletonColliderList read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonColliderList

Class TgxSkeletonColliderList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonColliderList = class(TgxPersistentObjectList)

Description

List class for storing TgxSkeletonCollider objects.

Hierarchy

  • TgxPersistentObjectList
  • TgxSkeletonColliderList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(aOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure AlignColliders;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TgxSkeletonCollider read GetSkeletonCollider;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AlignColliders;

Calls AlignCollider for each collider in the list.

Public procedure Clear; override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Properties

Public property Items[Index: Integer]: TgxSkeletonCollider read GetSkeletonCollider;

This item has no description.

Public property Owner: TPersistent read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Record TGXBlendedLerpInfo

Record TGXBlendedLerpInfo

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TGXBlendedLerpInfo = record

Description

Small structure to store a weighted lerp for use in blending.

Overview

Fields

Public | frameIndex1: Integer;
Public | frameIndex2: Integer;
Public | lerpFactor: Single;
Public | weight: Single;
Public | externalPositions: TgxAffineVectorList;
Public | externalRotations: TgxAffineVectorList;
Public | externalQuaternions: TGQuaternionList;

Description

Fields

Public frameIndex1: Integer;

This item has no description.

Public frameIndex2: Integer;

This item has no description.

Public lerpFactor: Single;

This item has no description.

Public weight: Single;

This item has no description.

Public externalPositions: TgxAffineVectorList;

This item has no description.

Public externalRotations: TgxAffineVectorList;

This item has no description.

Public externalQuaternions: TGQuaternionList;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeleton

Class TgxSkeleton

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeleton = class(TgxPersistentObject)

Description

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

Hierarchy

  • TgxPersistentObject
  • TgxSkeleton

Overview

Fields

Private | FOwner: TgxBaseMesh;
Private | FRootBones: TgxSkeletonRootBoneList;
Private | FFrames: TgxSkeletonFrameList;
Private | FCurrentFrame: TgxSkeletonFrame;
Private | FBonesByIDCache: TList;
Private | FColliders: TgxSkeletonColliderList;
Private | FRagDollEnabled: Boolean;
Private | FMorphInvisibleParts: Boolean;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxBaseMesh);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TgxSkeletonBone;
Public | function BoneByName(const aName: string): TgxSkeletonBone;
Public | function BoneCount: Integer;
Public | procedure BlendedLerps(const lerpInfos: array of TGXBlendedLerpInfo);
Public | procedure Clear;
Public | procedure FlushBoneByIDCache;
Public | procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);
Public | procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);
Public | procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);
Public | procedure MorphMesh(normalize: Boolean);
Public | procedure MorphTo(frameIndex: Integer); overload;
Public | procedure MorphTo(frame: TgxSkeletonFrame); overload;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure StartRagdoll;
Public | procedure StopRagdoll;
Public | procedure Synchronize(reference: TgxSkeleton);
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property Colliders: TgxSkeletonColliderList read FColliders write SetColliders;
Public | property CurrentFrame: TgxSkeletonFrame read GetCurrentFrame write SetCurrentFrame;
Public | property Frames: TgxSkeletonFrameList read FFrames write SetFrames;
Public | property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;
Public | property Owner: TgxBaseMesh read FOwner;
Public | property RootBones: TgxSkeletonRootBoneList read FRootBones write SetRootBones;

Description

Fields

Private FOwner: TgxBaseMesh;

This item has no description.

Private FRootBones: TgxSkeletonRootBoneList;

This item has no description.

Private FFrames: TgxSkeletonFrameList;

This item has no description.

Private FCurrentFrame: TgxSkeletonFrame;

This item has no description.

Private FBonesByIDCache: TList;

not persistent

Private FColliders: TgxSkeletonColliderList;

This item has no description.

Private FRagDollEnabled: Boolean;

This item has no description.

Private FMorphInvisibleParts: Boolean;

ragdoll

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function BoneByID(anID: Integer): TgxSkeletonBone;

This item has no description.

Public function BoneByName(const aName: string): TgxSkeletonBone;

This item has no description.

Public function BoneCount: Integer;

This item has no description.

Public procedure BlendedLerps(const lerpInfos: array of TGXBlendedLerpInfo);

This item has no description.

Public procedure Clear;

Release bones and frames info.

Public procedure FlushBoneByIDCache;

This item has no description.

Public procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);

This item has no description.

Public procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);

Removes the absolute rotation component of the skeletal frames. Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation. This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);

Linearly removes the translation component between skeletal frames. This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Public procedure MorphMesh(normalize: Boolean);

Applies current frame to morph all mesh objects.

Public procedure MorphTo(frameIndex: Integer); overload;

This item has no description.

Public procedure MorphTo(frame: TgxSkeletonFrame); overload;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure StartRagdoll;

Backup and prepare the BoneMatrixInvertedMeshes to use with ragdolls

Public procedure StopRagdoll;

ragdoll Restore the BoneMatrixInvertedMeshes to stop the ragdoll

Public procedure Synchronize(reference: TgxSkeleton);

Copy bone rotations from reference skeleton.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Colliders: TgxSkeletonColliderList read FColliders write SetColliders;

This item has no description.

Public property CurrentFrame: TgxSkeletonFrame read GetCurrentFrame write SetCurrentFrame;

This item has no description.

Public property Frames: TgxSkeletonFrameList read FFrames write SetFrames;

This item has no description.

Public property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;

Turning this option off (by default) alows to increase FPS, but may break backwards-compatibility, because some may choose to attach other objects to invisible parts.

Public property Owner: TgxBaseMesh read FOwner;

This item has no description.

Public property RootBones: TgxSkeletonRootBoneList read FRootBones write SetRootBones;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxMeshObject

Class TgxMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxMeshObject = class(TgxBaseMeshObject)

Description

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TMOxxx".

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject

Overview

Fields

Private | FOwner: TgxMeshObjectList;
Private | FExtentCacheRevision: Cardinal;
Private | FTexCoords: TgxAffineVectorList;
Private | FLightMapTexCoords: TgxAffineVectorList;
Private | FColors: TgxVectorList;
Private | FFaceGroups: TgxFaceGroups;
Private | FMode: TgxMeshObjectMode;
Private | FRenderingOptions: TgxMeshObjectRenderingOptions;
Private | FArraysDeclared: Boolean;
Private | FLightMapArrayEnabled: Boolean;
Private | FLastLightMapIndex: Integer;
Private | FTexCoordsEx: TList;
Private | FBinormalsTexCoordIndex: Integer;
Private | FTangentsTexCoordIndex: Integer;
Private | FLastXOpenGLTexMapping: Cardinal;
Private | FUseVBO: Boolean;
Private | FVerticesVBO: TgxVBOHandle;
Private | FNormalsVBO: TgxVBOHandle;
Private | FColorsVBO: TgxVBOHandle;
Private | FTexCoordsVBO: array of TgxVBOHandle;
Private | FLightmapTexCoordsVBO: TgxVBOHandle;
Private | FValidBuffers: TVBOBuffers;
Private | FExtentCache: TAABB;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TgxMeshObjectList);
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; override;
Public | function GetBarycenter: TVector4f;
Public | function PointInObject(const aPoint: TAffineVector): Boolean; virtual;
Public | function TriangleCount: Integer; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); virtual;
Public | procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out aabb: TAABB); overload; virtual;
Public | procedure GetExtents(out min, max: TAffineVector); overload; virtual;
Public | procedure GetTriangleData(tri: Integer; list: TgxVectorList; var v0, v1, v2: TVector4f); overload;
Public | procedure GetTriangleData(tri: Integer; list: TgxAffineVectorList; var v0, v1, v2: TAffineVector); overload;
Public | procedure Prepare; virtual;
Public | procedure PrepareBuildList(var mrci: TgxRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure SetTriangleData(tri: Integer; list: TgxAffineVectorList; const v0, v1, v2: TAffineVector); overload;
Public | procedure SetTriangleData(tri: Integer; list: TgxVectorList; const v0, v1, v2: TVector4f); overload;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;
Private | procedure SetUseVBO(const Value: Boolean);
Private | procedure SetValidBuffers(Value: TVBOBuffers);

Properties

Public | property Binormals: TgxVectorList read GetBinormals write SetBinormals;
Public | property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;
Public | property Colors: TgxVectorList read FColors write SetColors;
Public | property FaceGroups: TgxFaceGroups read FFaceGroups;
Public | property LightMapTexCoords: TgxAffineVectorList read FLightMapTexCoords write SetLightmapTexCoords;
Public | property mode: TgxMeshObjectMode read FMode write FMode;
Public | property Owner: TgxMeshObjectList read FOwner;
Public | property RenderingOptions: TgxMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;
Public | property Tangents: TgxVectorList read GetTangents write SetTangents;
Public | property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;
Public | property texCoords: TgxAffineVectorList read FTexCoords write SetTexCoords;
Public | property TexCoordsEx[index: Integer]: TgxVectorList read GetTexCoordsEx write SetTexCoordsEx;
Public | property UseVBO: Boolean read FUseVBO write SetUseVBO;

Description

Fields

Private FOwner: TgxMeshObjectList;

This item has no description.

Private FExtentCacheRevision: Cardinal;

This item has no description.

Private FTexCoords: TgxAffineVectorList;

This item has no description.

Private FLightMapTexCoords: TgxAffineVectorList;

provision for 3D textures

Private FColors: TgxVectorList;

reserved for 2D surface needs

Private FFaceGroups: TgxFaceGroups;

This item has no description.

Private FMode: TgxMeshObjectMode;

This item has no description.

Private FRenderingOptions: TgxMeshObjectRenderingOptions;

This item has no description.

Private FArraysDeclared: Boolean;

This item has no description.

Private FLightMapArrayEnabled: Boolean;

not persistent

Private FLastLightMapIndex: Integer;

not persistent

Private FTexCoordsEx: TList;

not persistent

Private FBinormalsTexCoordIndex: Integer;

This item has no description.

Private FTangentsTexCoordIndex: Integer;

This item has no description.

Private FLastXOpenGLTexMapping: Cardinal;

This item has no description.

Private FUseVBO: Boolean;

This item has no description.

Private FVerticesVBO: TgxVBOHandle;

This item has no description.

Private FNormalsVBO: TgxVBOHandle;

This item has no description.

Private FColorsVBO: TgxVBOHandle;

This item has no description.

Private FTexCoordsVBO: array of TgxVBOHandle;

This item has no description.

Private FLightmapTexCoordsVBO: TgxVBOHandle;

This item has no description.

Private FValidBuffers: TVBOBuffers;

This item has no description.

Private FExtentCache: TAABB;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public constructor CreateOwned(aOwner: TgxMeshObjectList);

Creates, assigns Owner and adds to list.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.ExtractTriangles.

Extracts all mesh triangles as a triangles list. The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle. The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller. If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public function GetBarycenter: TVector4f;

Barycenter from vertices data

Public function PointInObject(const aPoint: TAffineVector): Boolean; virtual;

This item has no description.

Public function TriangleCount: Integer; virtual;

Returns number of triangles in the mesh object.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var mrci: TgxRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure GetExtents(out aabb: TAABB); overload; virtual;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector); overload; virtual;

The extents of the object (min and max coordinates)

Public procedure GetTriangleData(tri: Integer; list: TgxVectorList; var v0, v1, v2: TVector4f); overload;

This item has no description.

Public procedure GetTriangleData(tri: Integer; list: TgxAffineVectorList; var v0, v1, v2: TAffineVector); overload;

Returns the triangle data for a given triangle

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TgxRenderContextInfo); virtual;

Prepare the texture and materials before rendering. Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure SetTriangleData(tri: Integer; list: TgxAffineVectorList; const v0, v1, v2: TAffineVector); overload;

Sets the triangle data of a given triangle

Public procedure SetTriangleData(tri: Integer; list: TgxVectorList; const v0, v1, v2: TVector4f); overload;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Private procedure SetUseVBO(const Value: Boolean);

This item has no description.

Private procedure SetValidBuffers(Value: TVBOBuffers);

This item has no description.

Properties

Public property Binormals: TgxVectorList read GetBinormals write SetBinormals;

A TexCoordsEx list wrapper for binormals usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;

Specify the texcoord extension index for binormals (default = 2)

Public property Colors: TgxVectorList read FColors write SetColors;

This item has no description.

Public property FaceGroups: TgxFaceGroups read FFaceGroups;

This item has no description.

Public property LightMapTexCoords: TgxAffineVectorList read FLightMapTexCoords write SetLightmapTexCoords;

This item has no description.

Public property mode: TgxMeshObjectMode read FMode write FMode;

This item has no description.

Public property Owner: TgxMeshObjectList read FOwner;

This item has no description.

Public property RenderingOptions: TgxMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;

This item has no description.

Public property Tangents: TgxVectorList read GetTangents write SetTangents;

A TexCoordsEx list wrapper for tangents usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;

Specify the texcoord extension index for tangents (default = 3)

Public property texCoords: TgxAffineVectorList read FTexCoords write SetTexCoords;

This item has no description.

Public property TexCoordsEx[index: Integer]: TgxVectorList read GetTexCoordsEx write SetTexCoordsEx;

The TexCoords Extension is a list of vector lists that are used to extend the vertex data applied during rendering. The lists are applied to the GL_TEXTURE0_ARB + index texture environment. This means that if TexCoordsEx 0 or 1 have data it will override the TexCoords or LightMapTexCoords repectively. Lists are created on demand, meaning that if you request TexCoordsEx[4] it will create the list up to and including 4. The extensions are only applied to the texture environment if they contain data.

Public property UseVBO: Boolean read FUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxMeshObjectList

Class TgxMeshObjectList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxMeshObjectList = class(TgxPersistentObjectList)

Description

A list of TgxMeshObject objects.

Hierarchy

  • TgxPersistentObjectList
  • TgxMeshObjectList

Overview

Fields

Private FOwner: TgxBaseMesh;

Methods

Public | constructor CreateOwned(aOwner: TgxBaseMesh);
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList;
Public | function FindMeshByName(MeshName: string): TgxMeshObject;
Public | function MorphTargetCount: Integer;
Public | function TriangleCount: Integer;
Private | function GetUseVBO: Boolean;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); virtual;
Public | procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);
Public | procedure MorphTo(morphTargetIndex: Integer);
Public | procedure Prepare; virtual;
Public | procedure PrepareBuildList(var mrci: TgxRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);
Private | procedure SetUseVBO(const Value: Boolean);

Properties

Public | property Items[Index: Integer]: TgxMeshObject read GetMeshObject;
Public | property Owner: TgxBaseMesh read FOwner;
Public | property UseVBO: Boolean read GetUseVBO write SetUseVBO;

Description

Fields

Private FOwner: TgxBaseMesh;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TgxBaseMesh);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ExtractTriangles(texCoords: TgxAffineVectorList = nil; normals: TgxAffineVectorList = nil): TgxAffineVectorList;

This item has no description.

Public function FindMeshByName(MeshName: string): TgxMeshObject;

This item has no description.

Public function MorphTargetCount: Integer;

This item has no description.

Public function TriangleCount: Integer;

Returns number of triangles in the meshes of the list.

Private function GetUseVBO: Boolean;

Resturns True if all its MeshObjects use VBOs.

Public procedure BuildList(var mrci: TgxRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace(buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector);

This item has no description.

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);

This item has no description.

Public procedure MorphTo(morphTargetIndex: Integer);

This item has no description.

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TgxRenderContextInfo); virtual;

Prepare the texture and materials before rendering. Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector);

This item has no description.

Private procedure SetUseVBO(const Value: Boolean);

This item has no description.

Properties

Public property Items[Index: Integer]: TgxMeshObject read GetMeshObject;

This item has no description.

Public property Owner: TgxBaseMesh read FOwner;

This item has no description.

Public property UseVBO: Boolean read GetUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays. Resturns True if all its MeshObjects use VBOs.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxMeshMorphTarget

Class TgxMeshMorphTarget

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxMeshMorphTarget = class(TgxBaseMeshObject)

Description

A morph target, stores alternate lists of vertices and normals.

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshMorphTarget

Overview

Fields

Private FOwner: TgxMeshMorphTargetList;

Methods

Public | constructor CreateOwned(aOwner: TgxMeshMorphTargetList);
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property Owner: TgxMeshMorphTargetList read FOwner;

Description

Fields

Private FOwner: TgxMeshMorphTargetList;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TgxMeshMorphTargetList);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Owner: TgxMeshMorphTargetList read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxMeshMorphTargetList

Class TgxMeshMorphTargetList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxMeshMorphTargetList = class(TgxPersistentObjectList)

Description

A list of TgxMeshMorphTarget objects.

Hierarchy

  • TgxPersistentObjectList
  • TgxMeshMorphTargetList

Overview

Fields

Private FOwner: TPersistent;

Methods

Public | constructor CreateOwned(aOwner: TPersistent);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);

Properties

Public | property Items[Index: Integer]: TgxMeshMorphTarget read GetMeshMorphTarget;
Public | property Owner: TPersistent read FOwner;

Description

Fields

Private FOwner: TPersistent;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TPersistent);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector);

This item has no description.

Properties

Public property Items[Index: Integer]: TgxMeshMorphTarget read GetMeshMorphTarget;

This item has no description.

Public property Owner: TPersistent read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxMorphableMeshObject

Class TgxMorphableMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxMorphableMeshObject = class(TgxMeshObject)

Description

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre- existing "morph targets".

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject

Overview

Fields

Private FMorphTargets: TgxMeshMorphTargetList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;
Public | procedure MorphTo(morphTargetIndex: Integer); virtual;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property MorphTargets: TgxMeshMorphTargetList read FMorphTargets;

Description

Fields

Private FMorphTargets: TgxMeshMorphTargetList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;

This item has no description.

Public procedure MorphTo(morphTargetIndex: Integer); virtual;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Translate(const delta: TAffineVector); override;

This item has no description. Showing description inherited from TgxBaseMeshObject.Translate.

Translates all the vertices by the given delta.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property MorphTargets: TgxMeshMorphTargetList read FMorphTargets;


GXSysHelp v.2.5: GXS.VectorFileObjects: Packed Record TgxVertexBoneWeight

Packed Record TgxVertexBoneWeight

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxVertexBoneWeight = packed record

Description

This item has no description.

Overview

Fields

Public | BoneID: Integer;
Public | weight: Single;

Description

Fields

Public BoneID: Integer;

This item has no description.

Public weight: Single;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxSkeletonMeshObject

Class TgxSkeletonMeshObject

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxSkeletonMeshObject = class(TgxMorphableMeshObject)

Description

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TgxVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).

Hierarchy

  • TgxPersistentObject
  • TgxBaseMeshObject
  • TgxMeshObject
  • TgxMorphableMeshObject
  • TgxSkeletonMeshObject

Overview

Fields

Private | FVerticesBonesWeights: PgxVerticesBoneWeights;
Private | FVerticeBoneWeightCount: Integer;
Private | FVerticeBoneWeightCapacity: Integer;
Private | FBonesPerVertex: Integer;
Private | FLastVerticeBoneWeightCount: Integer;
Private | FLastBonesPerVertex: Integer;
Private | FBoneMatrixInvertedMeshes: TList;
Private | FBackupInvertedMeshes: TList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function FindOrAdd(const boneIDs: TgxVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;
Public | function FindOrAdd(BoneID: Integer; const vertex, normal: TAffineVector): Integer; overload;
Public | procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);
Public | procedure AddWeightedBones(const boneIDs: TgxVertexBoneWeightDynArray);
Public | procedure ApplyCurrentSkeletonFrame(normalize: Boolean);
Public | procedure Clear; override;
Public | procedure PrepareBoneMatrixInvertedMeshes;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;
Private | procedure BackupBoneMatrixInvertedMeshes;
Private | procedure RestoreBoneMatrixInvertedMeshes;

Properties

Public | property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;
Public | property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;
Public | property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;
Public | property VerticesBonesWeights: PgxVerticesBoneWeights read FVerticesBonesWeights;

Description

Fields

Private FVerticesBonesWeights: PgxVerticesBoneWeights;

This item has no description.

Private FVerticeBoneWeightCount: Integer;

This item has no description.

Private FVerticeBoneWeightCapacity: Integer;

This item has no description.

Private FBonesPerVertex: Integer;

This item has no description.

Private FLastVerticeBoneWeightCount: Integer;

This item has no description.

Private FLastBonesPerVertex: Integer;

This item has no description.

Private FBoneMatrixInvertedMeshes: TList;

not persistent

Private FBackupInvertedMeshes: TList;

not persistent

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FindOrAdd(const boneIDs: TgxVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;

This item has no description.

Public function FindOrAdd(BoneID: Integer; const vertex, normal: TAffineVector): Integer; overload;

This item has no description.

Public procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);

This item has no description.

Public procedure AddWeightedBones(const boneIDs: TgxVertexBoneWeightDynArray);

This item has no description.

Public procedure ApplyCurrentSkeletonFrame(normalize: Boolean);

This item has no description.

Public procedure Clear; override;

This item has no description. Showing description inherited from TgxBaseMeshObject.Clear.

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure PrepareBoneMatrixInvertedMeshes;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Private procedure BackupBoneMatrixInvertedMeshes;

ragdoll

Private procedure RestoreBoneMatrixInvertedMeshes;

ragdoll

Properties

Public property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;

This item has no description.

Public property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;

This item has no description.

Public property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;

This item has no description.

Public property VerticesBonesWeights: PgxVerticesBoneWeights read FVerticesBonesWeights;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxFaceGroup

Class TgxFaceGroup

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxFaceGroup = class(TgxPersistentObject)

Description

Describes a face group of a TgxMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup

Overview

Fields

Private | FOwner: TgxFaceGroups;
Private | FMaterialName: string;
Private | FMaterialCache: TgxLibMaterial;
Private | FLightMapIndex: Integer;
Private | FRenderGroupID: Integer;

Methods

Public | constructor CreateOwned(aOwner: TgxFaceGroups); virtual;
Public | destructor Destroy; override;
Public | function TriangleCount: Integer; virtual; abstract;
Public | procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); virtual;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); virtual; abstract;
Public | procedure DropMaterialLibraryCache;
Public | procedure Prepare; virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Reverse; virtual;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;
Public | property MaterialCache: TgxLibMaterial read FMaterialCache;
Public | property MaterialName: string read FMaterialName write FMaterialName;
Public | property Owner: TgxFaceGroups read FOwner write FOwner;

Description

Fields

Private FOwner: TgxFaceGroups;

This item has no description.

Private FMaterialName: string;

This item has no description.

Private FMaterialCache: TgxLibMaterial;

This item has no description.

Private FLightMapIndex: Integer;

This item has no description.

Private FRenderGroupID: Integer;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TgxFaceGroups); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TriangleCount: Integer; virtual; abstract;

Returns number of triangles in the facegroup.

Public procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); virtual;

Add to the list the triangles corresponding to the facegroup. This function is used by TgxMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TgxRenderContextInfo); virtual; abstract;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure Prepare; virtual;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Reverse; virtual;

Reverses the rendering order of faces. Default implementation does nothing

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;

Index of lightmap in the lightmap library.

Public property MaterialCache: TgxLibMaterial read FMaterialCache;

This item has no description.

Public property MaterialName: string read FMaterialName write FMaterialName;

This item has no description.

Public property Owner: TgxFaceGroups read FOwner write FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxFGVertexIndexList

Class TgxFGVertexIndexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxFGVertexIndexList = class(TgxFaceGroup)

Description

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList

Overview

Fields

Private | FVertexIndices: TgxIntegerList;
Private | FIndexVBO: TgxVBOElementArrayHandle;
Private | FMode: TgxFaceGroupMeshMode;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function GetNormal: TAffineVector;
Public | function TriangleCount: Integer; override;
Public | procedure Add(idx: Integer);
Public | procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure ConvertToList;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure Reverse; override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;
Private | procedure InvalidateVBO;
Private | procedure SetupVBO;

Properties

Public | property mode: TgxFaceGroupMeshMode read FMode write FMode;
Public | property vertexIndices: TgxIntegerList read FVertexIndices write SetVertexIndices;

Description

Fields

Private FVertexIndices: TgxIntegerList;

This item has no description.

Private FIndexVBO: TgxVBOElementArrayHandle;

This item has no description.

Private FMode: TgxFaceGroupMeshMode;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetNormal: TAffineVector;

Return the normal from the 1st three points in the facegroup

Public function TriangleCount: Integer; override;

This item has no description. Showing description inherited from TgxFaceGroup.TriangleCount.

Returns number of triangles in the facegroup.

Public procedure Add(idx: Integer);

This item has no description.

Public procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;

This item has no description. Showing description inherited from TgxFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TgxMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description.

Public procedure ConvertToList;

If mode is strip or fan, convert the indices to triangle list indices.

Public procedure GetExtents(var min, max: TAffineVector);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure Reverse; override;

This item has no description. Showing description inherited from TgxFaceGroup.Reverse.

Reverses the rendering order of faces. Default implementation does nothing

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Private procedure InvalidateVBO;

This item has no description.

Private procedure SetupVBO;

This item has no description.

Properties

Public property mode: TgxFaceGroupMeshMode read FMode write FMode;

This item has no description.

Public property vertexIndices: TgxIntegerList read FVertexIndices write SetVertexIndices;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TFGVertexNormalTexIndexList

Class TFGVertexNormalTexIndexList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TFGVertexNormalTexIndexList = class(TgxFGVertexIndexList)

Description

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList
  • TFGVertexNormalTexIndexList

Overview

Fields

Private | FNormalIndices: TgxIntegerList;
Private | FTexCoordIndices: TgxIntegerList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);
Public | procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public | property normalIndices: TgxIntegerList read FNormalIndices write SetNormalIndices;
Public | property TexCoordIndices: TgxIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Fields

Private FNormalIndices: TgxIntegerList;

This item has no description.

Private FTexCoordIndices: TgxIntegerList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);

This item has no description.

Public procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;

This item has no description. Showing description inherited from TgxFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TgxMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property normalIndices: TgxIntegerList read FNormalIndices write SetNormalIndices;

This item has no description.

Public property TexCoordIndices: TgxIntegerList read FTexCoordIndices write SetTexCoordIndices;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxFGIndexTexCoordList

Class TgxFGIndexTexCoordList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxFGIndexTexCoordList = class(TgxFGVertexIndexList)

Description

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

Hierarchy

  • TgxPersistentObject
  • TgxFaceGroup
  • TgxFGVertexIndexList
  • TgxFGIndexTexCoordList

Overview

Fields

Private FTexCoords: TgxAffineVectorList;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(idx: Integer; const texCoord: TAffineVector); overload;
Public | procedure Add(idx: Integer; const s, t: Single); overload;
Public | procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TgxRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(writer: TgxVirtualWriter); override;

Properties

Public property texCoords: TgxAffineVectorList read FTexCoords write SetTexCoords;

Description

Fields

Private FTexCoords: TgxAffineVectorList;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Add(idx: Integer; const texCoord: TAffineVector); overload;

This item has no description.

Public procedure Add(idx: Integer; const s, t: Single); overload;

This item has no description.

Public procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil); override;

This item has no description. Showing description inherited from TgxFaceGroup.AddToTriangles.

Add to the list the triangles corresponding to the facegroup. This function is used by TgxMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TgxRenderContextInfo); override;

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property texCoords: TgxAffineVectorList read FTexCoords write SetTexCoords;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxFaceGroups

Class TgxFaceGroups

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxFaceGroups = class(TgxPersistentObjectList)

Description

A list of TgxFaceGroup objects.

Hierarchy

  • TgxPersistentObjectList
  • TgxFaceGroups

Overview

Fields

Private FOwner: TgxMeshObject;

Methods

Public | constructor CreateOwned(aOwner: TgxMeshObject);
Public | destructor Destroy; override;
Public | function MaterialLibrary: TgxMaterialLibrary;
Public | procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);
Public | procedure ReadFromFiler(reader: TgxVirtualReader); override;
Public | procedure SortByMaterial;

Properties

Public | property Items[Index: Integer]: TgxFaceGroup read GetFaceGroup;
Public | property Owner: TgxMeshObject read FOwner;

Description

Fields

Private FOwner: TgxMeshObject;

This item has no description.

Methods

Public constructor CreateOwned(aOwner: TgxMeshObject);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MaterialLibrary: TgxMaterialLibrary;

Material Library of the owner TgxBaseMesh.

Public procedure AddToTriangles(aList: TgxAffineVectorList; aTexCoords: TgxAffineVectorList = nil; aNormals: TgxAffineVectorList = nil);

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure DropMaterialLibraryCache;

This item has no description.

Public procedure PrepareMaterialLibraryCache(matLib: TgxMaterialLibrary);

This item has no description.

Public procedure ReadFromFiler(reader: TgxVirtualReader); override;

This item has no description.

Public procedure SortByMaterial;

Sort faces by material. Those without material first in list, followed by opaque materials, then transparent materials.

Properties

Public property Items[Index: Integer]: TgxFaceGroup read GetFaceGroup;

This item has no description.

Public property Owner: TgxMeshObject read FOwner;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxVectorFile

Class TgxVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxVectorFile = class(TgxDataFile)

Description

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile

Overview

Fields

Private FNormalsOrientation: TgxMeshNormalsOrientation;

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function Owner: TgxBaseMesh;

Properties

Public property NormalsOrientation: TgxMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;

Description

Fields

Private FNormalsOrientation: TgxMeshNormalsOrientation;

This item has no description.

Methods

Public constructor Create(aOwner: TPersistent); override;

This item has no description.

Public function Owner: TgxBaseMesh;

This item has no description.

Properties

Public property NormalsOrientation: TgxMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxVectorFileGLSM

Class TgxVectorFileGLSM

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxVectorFileGLSM = class(TgxVectorFile)

Description

GLSM ( GXScene Mesh) vector file. This corresponds to the 'native' Scene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GXScene features.

Hierarchy

  • TgxUpdateAbleObject
  • TgxDataFile
  • TgxVectorFile
  • TgxVectorFileGLSM

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;

This item has no description. Showing description inherited from TgxDataFile.Capabilities.

Describes what the TgxDataFile is capable of. Default value is [dfcRead].

Public procedure LoadFromStream(aStream: TStream); override;

This item has no description.

Public procedure SaveToStream(aStream: TStream); override;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxBaseMesh

Class TgxBaseMesh

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxBaseMesh = class(TgxSceneObject)

Description

Base class for mesh objects.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh

Overview

Fields

Private | FNormalsOrientation: TgxMeshNormalsOrientation;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FLightmapLibrary: TgxMaterialLibrary;
Private | FAxisAlignedDimensionsCache: TVector4f;
Private | FBaryCenterOffsetChanged: Boolean;
Private | FBaryCenterOffset: TVector4f;
Private | FUseMeshMaterials: Boolean;
Private | FOverlaySkeleton: Boolean;
Private | FIgnoreMissingTextures: Boolean;
Private | FAutoCentering: TgxMeshAutoCenterings;
Private | FAutoScaling: TgxCoordinates;
Private | FMaterialLibraryCachesPrepared: Boolean;
Private | FConnectivity: TObject;
Private | FLastLoadedFilename: string;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | function BarycenterAbsolutePosition: TVector4f; override;
Public | function BarycenterOffset: TVector4f;
Public | function BarycenterPosition: TVector4f;
Public | function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;
Public | function GetBarycenter: TAffineVector;
Public | function LastLoadedFilename: string;
Public | function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;
Public | procedure AddDataFromFile(const filename: string); virtual;
Public | procedure AddDataFromStream(const filename: string; aStream: TStream); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure BuildSilhouetteConnectivityData;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure LoadFromFile(const filename: string); virtual;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PerformAutoCentering; virtual;
Public | procedure PerformAutoScaling; virtual;
Public | procedure SaveToFile(const filename: string); virtual;
Public | procedure SaveToStream(const filename: string; aStream: TStream); virtual;
Public | procedure StructureChanged; override;
Public | procedure StructureChangedNoPrepare;

Properties

Public | property AutoCentering: TgxMeshAutoCenterings read FAutoCentering write FAutoCentering default [];
Public | property AutoScaling: TgxCoordinates read FAutoScaling write FAutoScaling;
Public | property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;
Public | property LightmapLibrary: TgxMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;
Public | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property MeshObjects: TgxMeshObjectList read FMeshObjects;
Public | property NormalsOrientation: TgxMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;
Public | property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;
Public | property Skeleton: TgxSkeleton read FSkeleton;
Public | property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Description

Fields

Private FNormalsOrientation: TgxMeshNormalsOrientation;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FLightmapLibrary: TgxMaterialLibrary;

This item has no description.

Private FAxisAlignedDimensionsCache: TVector4f;

This item has no description.

Private FBaryCenterOffsetChanged: Boolean;

This item has no description.

Private FBaryCenterOffset: TVector4f;

This item has no description.

Private FUseMeshMaterials: Boolean;

This item has no description.

Private FOverlaySkeleton: Boolean;

This item has no description.

Private FIgnoreMissingTextures: Boolean;

This item has no description.

Private FAutoCentering: TgxMeshAutoCenterings;

This item has no description.

Private FAutoScaling: TgxCoordinates;

This item has no description.

Private FMaterialLibraryCachesPrepared: Boolean;

This item has no description.

Private FConnectivity: TObject;

This item has no description.

Private FLastLoadedFilename: string;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public function BarycenterAbsolutePosition: TVector4f; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BarycenterAbsolutePosition.

Calculates the object's barycenter in absolute coordinates. Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children). SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function BarycenterOffset: TVector4f;

This item has no description.

Public function BarycenterPosition: TVector4f;

This item has no description.

Public function GenerateSilhouette(const SilhouetteParameters: TgxSilhouetteParameters): TgxSilhouette; override;

This item has no description. Showing description inherited from TgxBaseSceneObject.GenerateSilhouette.

Request to generate silhouette outlines. Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function GetBarycenter: TAffineVector;

Computes the barycenter of the mesh.

Public function LastLoadedFilename: string;

Returns the filename of the last loaded file, or a blank string if not file was loaded (or if the mesh was dinamically built). This does not take into account the data added to the mesh (through AddDataFromFile) or saved files.

Public function RayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil) : Boolean; override;

BEWARE! Utterly inefficient implementation!

Public procedure AddDataFromFile(const filename: string); virtual;

Loads additionnal data from a file. Additionnal data could be more animation frames or morph target. The VectorFile importer must be able to handle addition of data flawlessly.

Public procedure AddDataFromStream(const filename: string; aStream: TStream); virtual;

Loads additionnal data from stream. See AddDataFromFile.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure BuildSilhouetteConnectivityData;

This method allows fast shadow volumes for GLActors. If your actor/mesh doesn't change, you don't need to call this. It basically caches the connectivity data.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure GetExtents(out min, max: TAffineVector);

Computes the extents of the mesh.

Public procedure LoadFromFile(const filename: string); virtual;

Loads a vector file. A vector files (for instance a ".3DS") stores the definition of a mesh as well as materials property. Loading a file replaces the current one (if any).

Public procedure LoadFromStream(const filename: string; aStream: TStream); virtual;

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure PerformAutoCentering; virtual;

Invoked after a mesh has been loaded. Should auto-center according to the AutoCentering property.

Public procedure PerformAutoScaling; virtual;

Invoked after a mesh has been loaded. Should auto-scale the vertices of the meshobjects to AutoScaling the property.

Public procedure SaveToFile(const filename: string); virtual;

Saves to a vector file. Note that only some of the vector files formats can be written.

Public procedure SaveToStream(const filename: string; aStream: TStream); virtual;

Saves to a vector file in a stream. Note that only some of the vector files formats can be written.

Public procedure StructureChanged; override;

This item has no description.

Public procedure StructureChangedNoPrepare;

Notifies that geometry data changed, but no re-preparation is needed. Using this method will usually be faster, but may result in incorrect rendering, reduced performance and/or invalid bounding box data (ie. invalid collision detection). Use with caution.

Properties

Public property AutoCentering: TgxMeshAutoCenterings read FAutoCentering write FAutoCentering default [];

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TgxMeshObjects).

Public property AutoScaling: TgxCoordinates read FAutoScaling write FAutoScaling;

Scales vertices to a AutoScaling. AutoScaling is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TgxMeshObjects).

Public property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;

If True, exceptions about missing textures will be ignored. Implementation is up to the file loader class (ie. this property may be ignored by some loaders)

Public property LightmapLibrary: TgxMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Public property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Public property MeshObjects: TgxMeshObjectList read FMeshObjects;

This item has no description.

Public property NormalsOrientation: TgxMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;

Normals orientation for owned mesh.

Public property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;

Request rendering of skeleton bones over the mesh.

Public property Skeleton: TgxSkeleton read FSkeleton;

This item has no description.

Public property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxFreeForm

Class TgxFreeForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxFreeForm = class(TgxBaseMesh)

Description

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxFreeForm

Overview

Fields

Private FOctree: TgxOctree;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function OctreeAABBIntersect(const aabb: TAABB; objMatrix, invObjMatrix: TMatrix4f; triangles: TgxAffineVectorList = nil): Boolean;
Public | function OctreePointInMesh(const Point: TVector4f): Boolean;
Public | function OctreeRayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector4f; const velocity, radius: Single; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;
Public | function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): Boolean;
Public | procedure BuildOctree(TreeDepth: Integer = 3);

Properties

Published | property AutoCentering;
Published | property AutoScaling;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Public | property Octree: TgxOctree read GetOctree;
Published | property UseMeshMaterials;

Description

Fields

Private FOctree: TgxOctree;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OctreeAABBIntersect(const aabb: TAABB; objMatrix, invObjMatrix: TMatrix4f; triangles: TgxAffineVectorList = nil): Boolean;

This item has no description.

Public function OctreePointInMesh(const Point: TVector4f): Boolean;

Returns true if Point is inside the free form - this will only work properly on closed meshes. Requires that Octree has been prepared.

Public function OctreeRayCastIntersect(const rayStart, rayVector: TVector4f; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;

This item has no description.

Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector4f; const velocity, radius: Single; intersectPoint: PVector4f = nil; intersectNormal: PVector4f = nil): Boolean;

This item has no description.

Public function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): Boolean;

This item has no description.

Public procedure BuildOctree(TreeDepth: Integer = 3);

This item has no description.

Properties

Published property AutoCentering;

This item has no description. Showing description inherited from TgxBaseMesh.AutoCentering.

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TgxMeshObjects).

Published property AutoScaling;

This item has no description. Showing description inherited from TgxBaseMesh.AutoScaling.

Scales vertices to a AutoScaling. AutoScaling is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TgxMeshObjects).

Published property LightmapLibrary;

This item has no description. Showing description inherited from TgxBaseMesh.LightmapLibrary.

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Published property MaterialLibrary;

This item has no description. Showing description inherited from TgxBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Published property NormalsOrientation;

This item has no description. Showing description inherited from TgxBaseMesh.NormalsOrientation.

Normals orientation for owned mesh.

Public property Octree: TgxOctree read GetOctree;

Octree support *experimental*. Use only if you understand what you're doing!

Published property UseMeshMaterials;

This item has no description. Showing description inherited from TgxBaseMesh.UseMeshMaterials.

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxActorAnimation

Class TgxActorAnimation

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxActorAnimation = class(TCollectionItem)

Description

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TgxAnimationControler.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxActorAnimation

Overview

Fields

Private | FName: string;
Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FReference: TgxActorAnimationReference;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerActor: TgxActor;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MakeSkeletalRotationDelta;
Public | procedure MakeSkeletalTranslationStatic;

Properties

Public | property AsString: string read GetAsString write SetAsString;
Published | property endFrame: Integer read FEndFrame write SetEndFrame;
Published | property Name: string read FName write FName;
Published | property reference: TgxActorAnimationReference read FReference write SetReference default aarMorph;
Published | property startFrame: Integer read FStartFrame write SetStartFrame;

Description

Fields

Private FName: string;

This item has no description.

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FReference: TgxActorAnimationReference;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function OwnerActor: TgxActor;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure MakeSkeletalRotationDelta;

Removes the absolute rotation component of the skeletal frames. Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation. This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic;

Linearly removes the translation component between skeletal frames. This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Properties

Public property AsString: string read GetAsString write SetAsString;

This item has no description.

Published property endFrame: Integer read FEndFrame write SetEndFrame;

Index of the final frame of the animation.

Published property Name: string read FName write FName;

This item has no description.

Published property reference: TgxActorAnimationReference read FReference write SetReference default aarMorph;

Indicates if this is a skeletal or a morph-based animation.

Published property startFrame: Integer read FStartFrame write SetStartFrame;

Index of the initial frame of the animation.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxActorAnimations

Class TgxActorAnimations

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxActorAnimations = class(TCollection)

Description

Collection of actor animations sequences.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxActorAnimations

Overview

Fields

Private FOwner: TgxActor;

Methods

Public | constructor Create(aOwner: TgxActor);
Public | function Add: TgxActorAnimation;
Public | function FindFrame(aFrame: Integer; aReference: TgxActorAnimationReference): TgxActorAnimation;
Public | function FindItemID(ID: Integer): TgxActorAnimation;
Public | function FindName(const aName: string): TgxActorAnimation;
Public | function Last: TgxActorAnimation;
Public | procedure LoadFromFile(const filename: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure SaveToFile(const filename: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SetToStrings(aStrings: TStrings);

Properties

Public property Items[index: Integer]: TgxActorAnimation read GetItems write SetItems;

Description

Fields

Private FOwner: TgxActor;

This item has no description.

Methods

Public constructor Create(aOwner: TgxActor);

This item has no description.

Public function Add: TgxActorAnimation;

This item has no description.

Public function FindFrame(aFrame: Integer; aReference: TgxActorAnimationReference): TgxActorAnimation;

This item has no description.

Public function FindItemID(ID: Integer): TgxActorAnimation;

This item has no description.

Public function FindName(const aName: string): TgxActorAnimation;

This item has no description.

Public function Last: TgxActorAnimation;

This item has no description.

Public procedure LoadFromFile(const filename: string);

This item has no description.

Public procedure LoadFromStream(aStream: TStream);

This item has no description.

Public procedure SaveToFile(const filename: string);

This item has no description.

Public procedure SaveToStream(aStream: TStream);

This item has no description.

Public procedure SetToStrings(aStrings: TStrings);

This item has no description.

Properties

Public property Items[index: Integer]: TgxActorAnimation read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxBaseAnimationControler

Class TgxBaseAnimationControler

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxBaseAnimationControler = class(TComponent)

Description

Base class for skeletal animation control.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxBaseAnimationControler

Overview

Fields

Private | FEnabled: Boolean;
Private | FActor: TgxActor;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property Actor: TgxActor read FActor write SetActor;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;

Description

Fields

Private FEnabled: Boolean;

This item has no description.

Private FActor: TgxActor;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Properties

Published property Actor: TgxActor read FActor write SetActor;

This item has no description.

Published property Enabled: Boolean read FEnabled write SetEnabled default True;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxAnimationControler

Class TgxAnimationControler

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxAnimationControler = class(TgxBaseAnimationControler)

Description

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TgxActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxBaseAnimationControler
  • TgxAnimationControler

Overview

Fields

Private | FAnimationName: TgxActorAnimationName;
Private | FRatio: Single;

Properties

Published | property AnimationName: string read FAnimationName write SetAnimationName;
Published | property Ratio: Single read FRatio write SetRatio;

Description

Fields

Private FAnimationName: TgxActorAnimationName;

This item has no description.

Private FRatio: Single;

This item has no description.

Properties

Published property AnimationName: string read FAnimationName write SetAnimationName;

This item has no description.

Published property Ratio: Single read FRatio write SetRatio;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxActor

Class TgxActor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxActor = class(TgxBaseMesh)

Description

Mesh class specialized in animated meshes. The TgxActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TgxAnimationControler components).

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxBaseMesh
  • TgxActor

Overview

Fields

Private | FStartFrame: Integer;
Private | FEndFrame: Integer;
Private | FReference: TgxActorAnimationReference;
Private | FCurrentFrame: Integer;
Private | FCurrentFrameDelta: Single;
Private | FFrameInterpolation: TgxActorFrameInterpolation;
Private | FInterval: Integer;
Private | FAnimationMode: TgxActorAnimationMode;
Private | FOnFrameChanged: TNotifyEvent;
Private | FOnEndFrameReached: TNotifyEvent;
Private | FOnStartFrameReached: TNotifyEvent;
Private | FAnimations: TgxActorAnimations;
Private | FTargetSmoothAnimation: TgxActorAnimation;
Private | FControlers: TList;
Private | FOptions: TgxActorOptions;

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CurrentAnimation: string;
Public | function FrameCount: Integer;
Public | function isSwitchingAnimation: Boolean;
Public | function NextFrameIndex: Integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); override;
Public | procedure NextFrame(nbSteps: Integer = 1);
Public | procedure PrevFrame(nbSteps: Integer = 1);
Public | procedure SetCurrentFrameDirect(const Value: Integer);
Public | procedure SwitchToAnimation(const AnimationName: string; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(anAnimation: TgxActorAnimation; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;
Public | procedure Synchronize(referenceActor: TgxActor);

Properties

Published | property AnimationMode: TgxActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;
Published | property Animations: TgxActorAnimations read FAnimations write SetAnimations stored StoreAnimations;
Published | property AutoCentering;
Published | property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;
Published | property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;
Published | property endFrame: Integer read FEndFrame write SetEndFrame default 0;
Published | property FrameInterpolation: TgxActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;
Published | property Interval: Integer read FInterval write FInterval;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property Options: TgxActorOptions read FOptions write SetOptions default cDefaultActorOptions;
Published | property OverlaySkeleton;
Published | property reference: TgxActorAnimationReference read FReference write FReference default aarMorph;
Published | property startFrame: Integer read FStartFrame write SetStartFrame default 0;
Published | property UseMeshMaterials;

Description

Fields

Private FStartFrame: Integer;

This item has no description.

Private FEndFrame: Integer;

This item has no description.

Private FReference: TgxActorAnimationReference;

This item has no description.

Private FCurrentFrame: Integer;

This item has no description.

Private FCurrentFrameDelta: Single;

This item has no description.

Private FFrameInterpolation: TgxActorFrameInterpolation;

This item has no description.

Private FInterval: Integer;

This item has no description.

Private FAnimationMode: TgxActorAnimationMode;

This item has no description.

Private FOnFrameChanged: TNotifyEvent;

This item has no description.

Private FOnEndFrameReached: TNotifyEvent;

This item has no description.

Private FOnStartFrameReached: TNotifyEvent;

This item has no description.

Private FAnimations: TgxActorAnimations;

This item has no description.

Private FTargetSmoothAnimation: TgxActorAnimation;

This item has no description.

Private FControlers: TList;

This item has no description.

Private FOptions: TgxActorOptions;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CurrentAnimation: string;

This item has no description.

Public function FrameCount: Integer;

This item has no description.

Public function isSwitchingAnimation: Boolean;

Indicates whether the actor is currently swithing animations (with smooth interpolation).

Public function NextFrameIndex: Integer;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure LoadFromStream(const filename: string; aStream: TStream); override;

This item has no description. Showing description inherited from TgxBaseMesh.LoadFromStream.

Loads a vector file from a stream. See LoadFromFile. The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure NextFrame(nbSteps: Integer = 1);

This item has no description.

Public procedure PrevFrame(nbSteps: Integer = 1);

This item has no description.

Public procedure SetCurrentFrameDirect(const Value: Integer);

Provides a direct access to FCurrentFrame without any checks. Used in TgxActorProxy.

Public procedure SwitchToAnimation(const AnimationName: string; smooth: Boolean = False); overload;

This item has no description.

Public procedure SwitchToAnimation(anAnimation: TgxActorAnimation; smooth: Boolean = False); overload;

This item has no description.

Public procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;

This item has no description.

Public procedure Synchronize(referenceActor: TgxActor);

Synchronize self animation with an other actor. Copies Start/Current/End Frame values, CurrentFrameDelta, AnimationMode and FrameInterpolation.

Properties

Published property AnimationMode: TgxActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;

See TgxActorAnimationMode.

Published property Animations: TgxActorAnimations read FAnimations write SetAnimations stored StoreAnimations;

Collection of animations sequences.

Published property AutoCentering;

This item has no description. Showing description inherited from TgxBaseMesh.AutoCentering.

Determines if a mesh should be centered and how. AutoCentering is performed only after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream. If you want to alter mesh data, use direct manipulation methods (on the TgxMeshObjects).

Published property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;

Current animation frame.

Published property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;

Value in the [0; 1] range expressing the delta to the next frame.

Published property endFrame: Integer read FEndFrame write SetEndFrame default 0;

This item has no description.

Published property FrameInterpolation: TgxActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;

Frame interpolation mode (afpNone/afpLinear).

Published property Interval: Integer read FInterval write FInterval;

Interval between frames, in milliseconds.

Published property LightmapLibrary;

This item has no description. Showing description inherited from TgxBaseMesh.LightmapLibrary.

LightMap library where lightmaps will be stored/retrieved. If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Published property MaterialLibrary;

This item has no description. Showing description inherited from TgxBaseMesh.MaterialLibrary.

Material library where mesh materials will be stored/retrieved. If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Published property NormalsOrientation;

This item has no description. Showing description inherited from TgxBaseMesh.NormalsOrientation.

Normals orientation for owned mesh.

Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

Triggered after EndFrame has been reached by progression or "nextframe"

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

Triggered after each CurrentFrame change.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

Triggered after StartFrame has been reached by progression or "nextframe"

Published property Options: TgxActorOptions read FOptions write SetOptions default cDefaultActorOptions;

Actor and animation miscellanious options.

Published property OverlaySkeleton;

This item has no description. Showing description inherited from TgxBaseMesh.OverlaySkeleton.

Request rendering of skeleton bones over the mesh.

Published property reference: TgxActorAnimationReference read FReference write FReference default aarMorph;

Reference Frame Animation mode. Allows specifying if the model is primarily morph or skeleton based.

Published property startFrame: Integer read FStartFrame write SetStartFrame default 0;

This item has no description.

Published property UseMeshMaterials;

This item has no description. Showing description inherited from TgxBaseMesh.UseMeshMaterials.

Defines wether materials declared in the vector file mesh are used. You must also define the MaterialLibrary property.


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxVectorFileFormat

Class TgxVectorFileFormat

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxVectorFileFormat = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVectorFileFormat

Overview

Fields

Public | VectorFileClass: TgxVectorFileClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public VectorFileClass: TgxVectorFileClass;

This item has no description.

Public Extension: string;

This item has no description.

Public Description: string;

This item has no description.

Public DescResID: Integer;


GXSysHelp v.2.5: GXS.VectorFileObjects: Class TgxVectorFileFormatsList

Class TgxVectorFileFormatsList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type TgxVectorFileFormatsList = class(TgxPersistentObjectList)

Description

Stores registered vector file Formatx.

Hierarchy

  • TgxPersistentObjectList
  • TgxVectorFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TgxVectorFileClass;
Public | function FindExtByIndex(Index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const filename: string): TgxVectorFileClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxVectorFileClass);
Public | procedure BuildFilterStrings(VectorFileClass: TgxVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TgxVectorFileClass);

Description

Methods

Public destructor Destroy; override;

This item has no description.

Public function FindExt(Ext: string): TgxVectorFileClass;

This item has no description.

Public function FindExtByIndex(Index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;

This item has no description.

Public function FindFromFileName(const filename: string): TgxVectorFileClass;

This item has no description.

Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TgxVectorFileClass);

This item has no description.

Public procedure BuildFilterStrings(VectorFileClass: TgxVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);

This item has no description.

Public procedure Remove(AClass: TgxVectorFileClass);


GXSysHelp v.2.5: GXS.VectorFileObjects: Class EgxInvalidVectorFile

Class EgxInvalidVectorFile

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VectorFileObjects

Declaration

type EgxInvalidVectorFile = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EgxInvalidVectorFile


GXSysHelp v.2.5: GXS.VerletClothify

Unit GXS.VerletClothify

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GLScene.VectorGeometry
  • GXS.VectorFileObjects
  • GXS.VerletTypes
  • GXS.Texture
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFace |
Class TFaceList |
Class TFaceExtractor |
Class TEdge |
Class TEdgeList |
Class TEdgeDetector |
Class TgxMeshObjectVerletNode |


GXSysHelp v.2.5: GXS.VerletClothify: Class TFace

Class TFace

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TFace = class(TObject)

Description

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

Hierarchy

  • TObject
  • TFace

Overview

Fields

Public | Vertices: array[0..2] of integer;
Public | Normal: TAffineVector;
Public | MeshObject: TgxMeshObject;
Public | Active: boolean;

Methods

Public | constructor Create(aMeshObject : TgxMeshObject);
Public | procedure UpdateNormal;

Description

Fields

Public Vertices: array[0..2] of integer;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Public MeshObject: TgxMeshObject;

This item has no description.

Public Active: boolean;

This item has no description.

Methods

Public constructor Create(aMeshObject : TgxMeshObject);

This item has no description.

Public procedure UpdateNormal;


GXSysHelp v.2.5: GXS.VerletClothify: Class TFaceList

Class TFaceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TFaceList = class(TList)

Description

List of faces

Hierarchy

  • TObject
  • TList
  • TFaceList

Overview

Methods

Private | function GetItems(i: integer): TFace;
Private | procedure SetItems(i: integer; const Value: TFace);

Properties

Public property Items[i: integer]: TFace read GetItems write SetItems;

Description

Methods

Private function GetItems(i: integer): TFace;

This item has no description.

Private procedure SetItems(i: integer; const Value: TFace);

This item has no description.

Properties

Public property Items[i: integer]: TFace read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletClothify: Class TFaceExtractor

Class TFaceExtractor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TFaceExtractor = class(TObject)

Description

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TFaceExtractor

Overview

Fields

Private | FFaceList: TFaceList;
Private | FGLBaseMesh: TgxBaseMesh;
Private | FNodeList: TgxVerletNodeList;
Private | FWeldDistance: single;
Private | FEdgeDoublesSkipped: integer;

Methods

Public | constructor Create(const aGLBaseMesh : TgxBaseMesh); virtual;
Public | destructor Destroy; override;
Public | function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TgxMeshObject) : TFace; virtual;
Public | procedure Clear; virtual;
Public | procedure ExtractFacesFromVertexIndexList( const FaceGroup : TgxFGVertexIndexList; const MeshObject : TgxMeshObject);
Public | procedure ProcessMesh; virtual;
Private | procedure SetWeldDistance(const Value: single);

Properties

Public | property EdgeDoublesSkipped : integer read FEdgeDoublesSkipped;
Public | property FaceList : TFaceList read FFaceList;
Public | property GLBaseMesh : TgxBaseMesh read FGLBaseMesh;
Public | property NodeList : TgxVerletNodeList read FNodeList;
Public | property WeldDistance : single read FWeldDistance write SetWeldDistance;

Description

Fields

Private FFaceList: TFaceList;

This item has no description.

Private FGLBaseMesh: TgxBaseMesh;

This item has no description.

Private FNodeList: TgxVerletNodeList;

This item has no description.

Private FWeldDistance: single;

This item has no description.

Private FEdgeDoublesSkipped: integer;

This item has no description.

Methods

Public constructor Create(const aGLBaseMesh : TgxBaseMesh); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TgxMeshObject) : TFace; virtual;

This item has no description.

Public procedure Clear; virtual;

This item has no description.

Public procedure ExtractFacesFromVertexIndexList( const FaceGroup : TgxFGVertexIndexList; const MeshObject : TgxMeshObject);

This item has no description.

Public procedure ProcessMesh; virtual;

This item has no description.

Private procedure SetWeldDistance(const Value: single);

This item has no description.

Properties

Public property EdgeDoublesSkipped : integer read FEdgeDoublesSkipped;

This item has no description.

Public property FaceList : TFaceList read FFaceList;

This item has no description.

Public property GLBaseMesh : TgxBaseMesh read FGLBaseMesh;

This item has no description.

Public property NodeList : TgxVerletNodeList read FNodeList;

This item has no description.

Public property WeldDistance : single read FWeldDistance write SetWeldDistance;


GXSysHelp v.2.5: GXS.VerletClothify: Class TEdge

Class TEdge

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TEdge = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TEdge

Overview

Fields

Private | FSolid: boolean;
Private | FLength: single;
Private | FMeshObject: TgxMeshObject;
Private | FOwner: TEdgeDetector;
Public | Vertices: array[0..1] of integer;
Public | Faces: array[0..1] of TFace;

Methods

Public | constructor Create(const AOwner: TEdgeDetector; AVi0, AVi1 : integer; AFace0, AFace1 : TFace; AMeshObject : TgxMeshObject; ASolid : boolean);
Public | procedure Contract;
Public | procedure UpdateEdgeLength;

Properties

Public | property Length : single read FLength write FLength;
Public | property MeshObject : TgxMeshObject read FMeshObject write FMeshObject;
Public | property Owner : TEdgeDetector read FOwner;
Public | property Solid : boolean read FSolid write FSolid;

Description

Fields

Private FSolid: boolean;

This item has no description.

Private FLength: single;

This item has no description.

Private FMeshObject: TgxMeshObject;

This item has no description.

Private FOwner: TEdgeDetector;

This item has no description.

Public Vertices: array[0..1] of integer;

This item has no description.

Public Faces: array[0..1] of TFace;

This item has no description.

Methods

Public constructor Create(const AOwner: TEdgeDetector; AVi0, AVi1 : integer; AFace0, AFace1 : TFace; AMeshObject : TgxMeshObject; ASolid : boolean);

This item has no description.

Public procedure Contract;

This item has no description.

Public procedure UpdateEdgeLength;

This item has no description.

Properties

Public property Length : single read FLength write FLength;

This item has no description.

Public property MeshObject : TgxMeshObject read FMeshObject write FMeshObject;

This item has no description.

Public property Owner : TEdgeDetector read FOwner;

This item has no description.

Public property Solid : boolean read FSolid write FSolid;


GXSysHelp v.2.5: GXS.VerletClothify: Class TEdgeList

Class TEdgeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TEdgeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TEdgeList

Overview

Methods

Public | function InsertSorted(AEdge : TEdge) : integer;
Private | function GetItems(i: integer): TEdge;
Public | procedure SortByLength;
Private | procedure SetItems(i: integer; const Value: TEdge);

Properties

Public property Items[i: integer]: TEdge read GetItems write SetItems;

Description

Methods

Public function InsertSorted(AEdge : TEdge) : integer;

This item has no description.

Private function GetItems(i: integer): TEdge;

This item has no description.

Public procedure SortByLength;

This item has no description.

Private procedure SetItems(i: integer; const Value: TEdge);

This item has no description.

Properties

Public property Items[i: integer]: TEdge read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletClothify: Class TEdgeDetector

Class TEdgeDetector

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TEdgeDetector = class(TFaceExtractor)

Description

This item has no description. Showing description inherited from TFaceExtractor.

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TFaceExtractor
  • TEdgeDetector

Overview

Fields

Private | FEdgeList: TEdgeList;
Private | FCurrentNodeOffset: integer;
Private | FNodesAdded: boolean;

Methods

Public | constructor Create(const aGLBaseMesh : TgxBaseMesh); override;
Public | destructor Destroy; override;
Public | function AddEdge(const Vi0, Vi1 : integer; const Face : TFace; const AMeshObject : TgxMeshObject) : TEdge;
Public | function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TgxMeshObject) : TFace; override;
Public | function AddNode(const VerletWorld : TgxVerletWorld; const MeshObject : TgxMeshObject; const VertexIndex : integer) : TgxVerletNode; virtual;
Public | procedure AddEdgesAsSolidEdges(const VerletWorld : TgxVerletWorld);
Public | procedure AddEdgesAsSprings(const VerletWorld : TgxVerletWorld; const Strength, Damping, Slack : single);
Public | procedure AddEdgesAsSticks(const VerletWorld : TgxVerletWorld; const Slack : single);
Public | procedure AddNodes(const VerletWorld : TgxVerletWorld);
Public | procedure AddOuterEdgesAsSolidEdges(const VerletWorld : TgxVerletWorld);
Public | procedure Clear; override;
Public | procedure ProcessMesh; override;
Public | procedure RenderEdges(var rci : TgxRenderContextInfo);
Public | procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith : integer);
Private | procedure BuildOpposingEdges;

Properties

Public | property CurrentNodeOffset : integer read FCurrentNodeOffset;
Public | property EdgeList : TEdgeList read FEdgeList;
Public | property NodesAdded : boolean read FNodesAdded;

Description

Fields

Private FEdgeList: TEdgeList;

This item has no description.

Private FCurrentNodeOffset: integer;

This item has no description.

Private FNodesAdded: boolean;

This item has no description.

Methods

Public constructor Create(const aGLBaseMesh : TgxBaseMesh); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddEdge(const Vi0, Vi1 : integer; const Face : TFace; const AMeshObject : TgxMeshObject) : TEdge;

This item has no description.

Public function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TgxMeshObject) : TFace; override;

This item has no description.

Public function AddNode(const VerletWorld : TgxVerletWorld; const MeshObject : TgxMeshObject; const VertexIndex : integer) : TgxVerletNode; virtual;

This item has no description.

Public procedure AddEdgesAsSolidEdges(const VerletWorld : TgxVerletWorld);

This item has no description.

Public procedure AddEdgesAsSprings(const VerletWorld : TgxVerletWorld; const Strength, Damping, Slack : single);

This item has no description.

Public procedure AddEdgesAsSticks(const VerletWorld : TgxVerletWorld; const Slack : single);

This item has no description.

Public procedure AddNodes(const VerletWorld : TgxVerletWorld);

This item has no description.

Public procedure AddOuterEdgesAsSolidEdges(const VerletWorld : TgxVerletWorld);

This item has no description.

Public procedure Clear; override;

This item has no description.

Public procedure ProcessMesh; override;

This item has no description.

Public procedure RenderEdges(var rci : TgxRenderContextInfo);

This item has no description.

Public procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith : integer);

This item has no description.

Private procedure BuildOpposingEdges;

This item has no description.

Properties

Public property CurrentNodeOffset : integer read FCurrentNodeOffset;

This item has no description.

Public property EdgeList : TEdgeList read FEdgeList;

This item has no description.

Public property NodesAdded : boolean read FNodesAdded;


GXSysHelp v.2.5: GXS.VerletClothify: Class TgxMeshObjectVerletNode

Class TgxMeshObjectVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletClothify

Declaration

type TgxMeshObjectVerletNode = class(TgxVerletNode)

Description

This item has no description. Showing description inherited from TgxVerletNode.

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf
  • TgxBaseVerletNode
  • TgxVerletNode
  • TgxMeshObjectVerletNode

Overview

Fields

Private | MeshObject: TgxMeshObject;
Private | VertexIndices: TgxIntegerList;

Methods

Public | constructor CreateOwned(const aOwner : TgxVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure AfterProgress; override;

Description

Fields

Private MeshObject: TgxMeshObject;

This item has no description.

Private VertexIndices: TgxIntegerList;

This item has no description.

Methods

Public constructor CreateOwned(const aOwner : TgxVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AfterProgress; override;


GXSysHelp v.2.5: GXS.VerletTypes

Unit GXS.VerletTypes

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics rendering engine GLScene http://glscene.org

Uses

  • System.Classes
  • System.SysUtils
  • System.Types
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GXS.Objects
  • GXS.Scene
  • GXS.Coordinates
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.VectorFileObjects
  • GXS.SpacePartition
  • GLScene.GeometryBB

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBaseVerletNode |
Class TgxVerletNodeList |
Class TgxVerletConstraint |
Class TgxVerletDualConstraint |
Class TgxVerletGroupConstraint |
Class TgxVerletEdge |
Class TgxVerletEdgeList |
Class TgxVerletGlobalConstraint |
Class TgxVerletGlobalFrictionConstraint |
Class TgxVerletGlobalFrictionConstraintSP |
Class TgxVerletGlobalFrictionConstraintSphere |
Class TgxVerletGlobalFrictionConstraintBox |
Class TgxVerletConstraintList |
Class TgxVerletForce |
Class TgxVerletDualForce |
Class TgxVerletGroupForce |
Class TgxVerletGlobalForce |
Class TgxVerletForceList |
Class TgxVerletWorld |
Class TgxVerletGravity |
Class TgxVerletAirResistance |
Class TgxVerletSpring |
Class TgxVerletFloor |
Class TgxVerletHeightField |
Class TgxVerletStick |
Class TgxVerletRigidBody |
Class TgxVerletSlider |
Class TgxVerletFrictionSphere |
Class TgxVerletFrictionCylinder |
Class TgxVerletFrictionCube |
Class TgxVerletFrictionCapsule |
Class TgxVerletNode |
Class TgxVerletHair |
Class TgxVerletSkeletonCollider |
Class TgxVerletSphere |
Class TgxVerletCapsule |

Functions and Procedures

procedure AddVerletConstriantsToVerletWorld(Colliders: TgxSkeletonColliderList; World: TgxVerletWorld);
function CreateVerletPlaneFromGLPlane(Plane: TgxPlane; VerletWorld: TgxVerletWorld; Offset: Single): TgxVerletFloor;

Types

TCollisionConstraintTypes = (...);
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;
TgxStiffnessSetVH = set of TgxStiffnessVH;
TgxStiffnessVH = (...);
TgxVerletHeightFieldOnNeedHeight = function(hfConstraint: TgxVerletHeightField; node: TgxBaseVerletNode): Single of object;
TgxVerletNodeClass = class of TgxBaseVerletNode;
TUpdateSpacePartion = (...);

Constants

G_DRAG = 0.0001;
cDEFAULT_CONSTRAINT_FRICTION = 0.6;

Description

Functions and Procedures

procedure AddVerletConstriantsToVerletWorld(Colliders: TgxSkeletonColliderList; World: TgxVerletWorld);

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

function CreateVerletPlaneFromGLPlane(Plane: TgxPlane; VerletWorld: TgxVerletWorld; Offset: Single): TgxVerletFloor;

This item has no description.

Types

TCollisionConstraintTypes = (...);

This item has no description.

Values
  • cctEdge
  • cctNode
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;

This item has no description.

TgxStiffnessSetVH = set of TgxStiffnessVH;

This item has no description.

TgxStiffnessVH = (...);

This item has no description.

Values
  • vhsFull
  • vhsSkip1Node
  • vhsSkip2Node
  • vhsSkip3Node
  • vhsSkip4Node
  • vhsSkip5Node
  • vhsSkip6Node
  • vhsSkip7Node
  • vhsSkip8Node
  • vhsSkip9Node
TgxVerletHeightFieldOnNeedHeight = function(hfConstraint: TgxVerletHeightField; node: TgxBaseVerletNode): Single of object;

This item has no description.

TgxVerletNodeClass = class of TgxBaseVerletNode;

This item has no description.

TUpdateSpacePartion = (...);

This item has no description.

Values
  • uspEveryIteration
  • uspEveryFrame
  • uspNever

Constants

G_DRAG = 0.0001;

This item has no description.

cDEFAULT_CONSTRAINT_FRICTION = 0.6;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxBaseVerletNode

Class TgxBaseVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxBaseVerletNode = class(TSpacePartitionLeaf)

Description

Basic Verlet Node

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf
  • TgxBaseVerletNode

Overview

Fields

Private | FForce: TAffineVector;
Private | FOwner: TgxVerletWorld;
Private | FWeight: Single;
Private | FInvWeight: Single;
Private | FRadius: Single;
Private | FNailedDown: Boolean;
Private | FFriction: Single;
Private | FChangedOnStep: Integer;

Methods

Public | constructor CreateOwned(const aOwner: TgxVerletWorld); virtual;
Public | destructor Destroy; override;
Public | function DistanceToNode(const node: TgxBaseVerletNode): Single;
Public | function GetMovement: TAffineVector;
Private | function GetSpeed: TAffineVector;
Public | procedure ApplyFriction(const friction, penetrationDepth: Single; const surfaceNormal: TAffineVector);
Public | procedure Initialize; dynamic;
Public | procedure OldApplyFriction(const friction, penetrationDepth: Single);
Public | procedure UpdateCachedAABBAndBSphere; override;
Public | procedure Verlet(const vpt: TgxProgressTimes); virtual;

Properties

Public | property ChangedOnStep: Integer read FChangedOnStep;
Public | property Force: TAffineVector read FForce write FForce;
Public | property friction: Single read FFriction write FFriction;
Public | property InvWeight: Single read FInvWeight;
Public | property Location: TAffineVector read FLocation write SetLocation;
Public | property NailedDown: Boolean read FNailedDown write FNailedDown;
Public | property OldLocation: TAffineVector read FOldLocation write FOldLocation;
Public | property Owner: TgxVerletWorld read FOwner;
Public | property Radius: Single read FRadius write FRadius;
Public | property Speed: TAffineVector read GetSpeed;
Public | property Weight: Single read FWeight write SetWeight;

Description

Fields

Private FForce: TAffineVector;

This item has no description.

Private FOwner: TgxVerletWorld;

This item has no description.

Private FWeight: Single;

This item has no description.

Private FInvWeight: Single;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FNailedDown: Boolean;

This item has no description.

Private FFriction: Single;

This item has no description.

Private FChangedOnStep: Integer;

This item has no description.

Methods

Public constructor CreateOwned(const aOwner: TgxVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DistanceToNode(const node: TgxBaseVerletNode): Single;

Calculates the distance to another node

Public function GetMovement: TAffineVector;

Calculates the movement of the node

Private function GetSpeed: TAffineVector;

This item has no description.

Public procedure ApplyFriction(const friction, penetrationDepth: Single; const surfaceNormal: TAffineVector);

Applies friction

Public procedure Initialize; dynamic;

Initlializes the node. For the base class, it just makes sure that FOldPosition = FPosition, so that speed is zero

Public procedure OldApplyFriction(const friction, penetrationDepth: Single);

Simple and less accurate method for friction

Public procedure UpdateCachedAABBAndBSphere; override;

The TgxBaseVerletNode inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner (a TgxVerletWorld) has a spatial partitioning object

Public procedure Verlet(const vpt: TgxProgressTimes); virtual;

Perform Verlet integration

Properties

Public property ChangedOnStep: Integer read FChangedOnStep;

What phyisics step was this node last changed? Used to keep track of when the spatial partitioning needs to be updated

Public property Force: TAffineVector read FForce write FForce;

A sum of all forces that has been applied to this verlet node during a step

Public property friction: Single read FFriction write FFriction;

Each node has a friction that effects how it reacts during contacts.

Public property InvWeight: Single read FInvWeight;

InvWeight is 1/Weight, and is kept up to date automatically

Public property Location: TAffineVector read FLocation write SetLocation;

The location of the verlet

Public property NailedDown: Boolean read FNailedDown write FNailedDown;

If the node is nailed down, it can't be moved by either force, constraint or verlet integration - but you can still move it by hand

Public property OldLocation: TAffineVector read FOldLocation write FOldLocation;

The old location of the verlet. This is used for verlet integration

Public property Owner: TgxVerletWorld read FOwner;

The VerletWorld that owns this verlet

Public property Radius: Single read FRadius write FRadius;

The radius of the verlet node - this has been more or less deprecated

Public property Speed: TAffineVector read GetSpeed;

Returns the speed of the verlet node. Speed = Movement / deltatime

Public property Weight: Single read FWeight write SetWeight;

The weight of a node determines how much it's affected by a force


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletNodeList

Class TgxVerletNodeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletNodeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxVerletNodeList

Overview

Methods

Private | function GetItems(i: Integer): TgxBaseVerletNode;
Private | procedure SetItems(i: Integer; const Value: TgxBaseVerletNode);

Properties

Public property Items[i: Integer]: TgxBaseVerletNode read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TgxBaseVerletNode;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TgxBaseVerletNode);

This item has no description.

Properties

Public property Items[i: Integer]: TgxBaseVerletNode read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletConstraint

Class TgxVerletConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletConstraint = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint

Overview

Fields

Private | FOwner: TgxVerletWorld;
Private | FEnabled: Boolean;
Private | FTag: Integer;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure BeforeIterations; virtual;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); virtual; abstract;

Properties

Public | property Enabled: Boolean read FEnabled write FEnabled;
Public | property Owner: TgxVerletWorld read FOwner;
Public | property Tag: Integer read FTag write FTag;

Description

Fields

Private FOwner: TgxVerletWorld;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FTag: Integer;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeforeIterations; virtual;

Method that's fired before the physics iterations are performed

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); virtual; abstract;

Notifies removal of a node

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); virtual; abstract;

Updates the position of one or several nodes to make sure that they don't violate the constraint

Properties

Public property Enabled: Boolean read FEnabled write FEnabled;

Determines if the constraint should be enforced or not

Public property Owner: TgxVerletWorld read FOwner;

Onwer of the constraint

Public property Tag: Integer read FTag write FTag;

Tag field reserved for the user.


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletDualConstraint

Class TgxVerletDualConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletDualConstraint = class(TgxVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletDualConstraint

Overview

Fields

Private | FNodeA: TgxBaseVerletNode;
Private | FNodeB: TgxBaseVerletNode;

Methods

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

Properties

Public | property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TgxBaseVerletNode;

This item has no description.

Private FNodeB: TgxBaseVerletNode;

This item has no description.

Methods

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletConstraint.RemoveNode.

Notifies removal of a node

Properties

Public property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

Reference to NodeB.


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGroupConstraint

Class TgxVerletGroupConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGroupConstraint = class(TgxVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGroupConstraint

Overview

Fields

Private FNodes: TgxVerletNodeList;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

Properties

Public property Nodes: TgxVerletNodeList read FNodes;

Description

Fields

Private FNodes: TgxVerletNodeList;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletConstraint.RemoveNode.

Notifies removal of a node

Properties

Public property Nodes: TgxVerletNodeList read FNodes;

The list of nodes that this constraint will effect


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletEdge

Class TgxVerletEdge

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletEdge = class(TSpacePartitionLeaf)

Description

Verlet edges simulate rigid collission edges

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf
  • TgxVerletEdge

Overview

Fields

Private | FNodeA: TgxBaseVerletNode;
Private | FNodeB: TgxBaseVerletNode;

Methods

Public | constructor CreateEdgeOwned(const aNodeA, aNodeB: TgxBaseVerletNode);
Public | procedure UpdateCachedAABBAndBSphere; override;

Properties

Public | property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TgxBaseVerletNode;

This item has no description.

Private FNodeB: TgxBaseVerletNode;

This item has no description.

Methods

Public constructor CreateEdgeOwned(const aNodeA, aNodeB: TgxBaseVerletNode);

This item has no description.

Public procedure UpdateCachedAABBAndBSphere; override;

The TgxVerletEdge inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner ( a TgxVerletWorld ) has a spatial partitioning object

Properties

Public property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;

One of the nodes in the edge

Public property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

One of the nodes in the edge


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletEdgeList

Class TgxVerletEdgeList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletEdgeList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxVerletEdgeList

Overview

Methods

Private | function GetItems(i: Integer): TgxVerletEdge;
Private | procedure SetItems(i: Integer; const Value: TgxVerletEdge);

Properties

Public property Items[i: Integer]: TgxVerletEdge read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TgxVerletEdge;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TgxVerletEdge);

This item has no description.

Properties

Public property Items[i: Integer]: TgxVerletEdge read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalConstraint

Class TgxVerletGlobalConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalConstraint = class(TgxVerletConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint

Overview

Fields

Private | FKickbackForce: TAffineVector;
Private | FKickbackTorque: TAffineVector;
Private | FLocation: TAffineVector;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | destructor Destroy; override;
Public | function TranslateKickbackTorque(const TorqueCenter: TAffineVector) : TAffineVector;
Public | procedure AddKickbackForceAt(const Pos: TAffineVector; const Force: TAffineVector);
Public | procedure BeforeIterations; override;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); override;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); virtual;
Public | procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); virtual; abstract;
Private | procedure SetLocation(const Value: TAffineVector); virtual;

Properties

Public | property KickbackForce: TAffineVector read FKickbackForce write FKickbackForce;
Public | property KickbackTorque: TAffineVector read FKickbackTorque write FKickbackTorque;
Public | property Location: TAffineVector read FLocation write SetLocation;

Description

Fields

Private FKickbackForce: TAffineVector;

This item has no description.

Private FKickbackTorque: TAffineVector;

This item has no description.

Private FLocation: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function TranslateKickbackTorque(const TorqueCenter: TAffineVector) : TAffineVector;

This item has no description.

Public procedure AddKickbackForceAt(const Pos: TAffineVector; const Force: TAffineVector);

This item has no description.

Public procedure BeforeIterations; override;

This item has no description. Showing description inherited from TgxVerletConstraint.BeforeIterations.

Method that's fired before the physics iterations are performed

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletConstraint.RemoveNode.

Notifies removal of a node

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

This item has no description. Showing description inherited from TgxVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Public procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); virtual;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); virtual; abstract;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); virtual;

This item has no description.

Properties

Public property KickbackForce: TAffineVector read FKickbackForce write FKickbackForce;

The force that this collider has experienced while correcting the verlet possitions. This force can be applied to ODE bodies, for instance

Public property KickbackTorque: TAffineVector read FKickbackTorque write FKickbackTorque;

The torque that this collider has experienced while correcting the verlet possitions, in reference to the center of the collider. The torque force can be applied to ODE bodies, but it must first be translated. A torque can be trasnalted by EM(b) = EM(a) + EF x VectorSubtract(b, a). Simply adding the torque to the body will NOT work correctly. See TranslateKickbackTorque

Public property Location: TAffineVector read FLocation write SetLocation;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalFrictionConstraint

Class TgxVerletGlobalFrictionConstraint

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalFrictionConstraint = class(TgxVerletGlobalConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint

Overview

Fields

Private FFrictionRatio: Single;

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

Properties

Public property FrictionRatio: Single read FFrictionRatio write FFrictionRatio;

Description

Fields

Private FFrictionRatio: Single;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Properties

Public property FrictionRatio: Single read FFrictionRatio write FFrictionRatio;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalFrictionConstraintSP

Class TgxVerletGlobalFrictionConstraintSP

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalFrictionConstraintSP = class(TgxVerletGlobalFrictionConstraint)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP

Overview

Methods

Public | procedure PerformSpaceQuery; virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

Description

Methods

Public procedure PerformSpaceQuery; virtual; abstract;

This item has no description.

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

This item has no description. Showing description inherited from TgxVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalFrictionConstraintSphere

Class TgxVerletGlobalFrictionConstraintSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalFrictionConstraintSphere = class(TgxVerletGlobalFrictionConstraintSP)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletGlobalFrictionConstraintSphere

Overview

Fields

Private FCachedBSphere: TBSphere;

Methods

Public | function GetBSphere: TBSphere; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedBSphere;
Private | procedure SetLocation(const Value: TAffineVector); override;

Properties

Public property CachedBSphere: TBSphere read FCachedBSphere;

Description

Fields

Private FCachedBSphere: TBSphere;

This item has no description.

Methods

Public function GetBSphere: TBSphere; virtual; abstract;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure UpdateCachedBSphere;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); override;

This item has no description.

Properties

Public property CachedBSphere: TBSphere read FCachedBSphere;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalFrictionConstraintBox

Class TgxVerletGlobalFrictionConstraintBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalFrictionConstraintBox = class(TgxVerletGlobalFrictionConstraintSP)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletGlobalFrictionConstraintBox

Overview

Fields

Private FCachedAABB: TAABB;

Methods

Public | function GetAABB: TAABB; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedAABB;
Private | procedure SetLocation(const Value: TAffineVector); override;

Properties

Public property CachedAABB: TAABB read FCachedAABB;

Description

Fields

Private FCachedAABB: TAABB;

This item has no description.

Methods

Public function GetAABB: TAABB; virtual; abstract;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure UpdateCachedAABB;

This item has no description.

Private procedure SetLocation(const Value: TAffineVector); override;

This item has no description.

Properties

Public property CachedAABB: TAABB read FCachedAABB;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletConstraintList

Class TgxVerletConstraintList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletConstraintList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxVerletConstraintList

Overview

Methods

Private | function GetItems(i: Integer): TgxVerletConstraint;
Private | procedure SetItems(i: Integer; const Value: TgxVerletConstraint);

Properties

Public property Items[i: Integer]: TgxVerletConstraint read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TgxVerletConstraint;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TgxVerletConstraint);

This item has no description.

Properties

Public property Items[i: Integer]: TgxVerletConstraint read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletForce

Class TgxVerletForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletForce = class(TObject)

Description

Generic verlet force.

Hierarchy

  • TObject
  • TgxVerletForce

Overview

Fields

Private FOwner: TgxVerletWorld;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure AddForce(const vpt: TgxProgressTimes); virtual; abstract;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); virtual; abstract;

Properties

Public property Owner: TgxVerletWorld read FOwner;

Description

Fields

Private FOwner: TgxVerletWorld;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure AddForce(const vpt: TgxProgressTimes); virtual; abstract;

Implementation should add force to force resultant for all relevant nodes

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); virtual; abstract;

Notifies removal of a node

Properties

Public property Owner: TgxVerletWorld read FOwner;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletDualForce

Class TgxVerletDualForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletDualForce = class(TgxVerletForce)

Description

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletDualForce

Overview

Fields

Private | FNodeA: TgxBaseVerletNode;
Private | FNodeB: TgxBaseVerletNode;

Methods

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

Properties

Public | property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;
Public | property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

Description

Fields

Private FNodeA: TgxBaseVerletNode;

This item has no description.

Private FNodeB: TgxBaseVerletNode;

This item has no description.

Methods

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletForce.RemoveNode.

Notifies removal of a node

Properties

Public property NodeA: TgxBaseVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB: TgxBaseVerletNode read FNodeB write FNodeB;

Reference to NodeB.


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGroupForce

Class TgxVerletGroupForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGroupForce = class(TgxVerletForce)

Description

A verlet force that applies to a specified group of nodes.

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletGroupForce

Overview

Fields

Private FNodes: TgxVerletNodeList;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

Properties

Public property Nodes: TgxVerletNodeList read FNodes;

Description

Fields

Private FNodes: TgxVerletNodeList;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletForce.RemoveNode.

Notifies removal of a node

Properties

Public property Nodes: TgxVerletNodeList read FNodes;

Nodes of the force group, referred, NOT owned.


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGlobalForce

Class TgxVerletGlobalForce

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGlobalForce = class(TgxVerletForce)

Description

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletGlobalForce

Overview

Methods

Public | procedure AddForce(const vpt: TgxProgressTimes); override;
Public | procedure AddForceToNode(const aNode: TgxBaseVerletNode); virtual; abstract;
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

Description

Methods

Public procedure AddForce(const vpt: TgxProgressTimes); override;

This item has no description. Showing description inherited from TgxVerletForce.AddForce.

Implementation should add force to force resultant for all relevant nodes

Public procedure AddForceToNode(const aNode: TgxBaseVerletNode); virtual; abstract;

This item has no description.

Public procedure RemoveNode(const aNode: TgxBaseVerletNode); override;

This item has no description. Showing description inherited from TgxVerletForce.RemoveNode.

Notifies removal of a node


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletForceList

Class TgxVerletForceList

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletForceList = class(TList)

Description

This item has no description.

Hierarchy

  • TObject
  • TList
  • TgxVerletForceList

Overview

Methods

Private | function GetItems(i: Integer): TgxVerletForce;
Private | procedure SetItems(i: Integer; const Value: TgxVerletForce);

Properties

Public property Items[i: Integer]: TgxVerletForce read GetItems write SetItems;

Description

Methods

Private function GetItems(i: Integer): TgxVerletForce;

This item has no description.

Private procedure SetItems(i: Integer; const Value: TgxVerletForce);

This item has no description.

Properties

Public property Items[i: Integer]: TgxVerletForce read GetItems write SetItems;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletWorld

Class TgxVerletWorld

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletWorld = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxVerletWorld

Overview

Fields

Private | FIterations: Integer;
Private | FNodes: TgxVerletNodeList;
Private | FConstraints: TgxVerletConstraintList;
Private | FForces: TgxVerletForceList;
Private | FMaxDeltaTime: Single;
Private | FSimTime: Single;
Private | FDrag: Single;
Private | FCurrentDeltaTime: Single;
Private | FInvCurrentDeltaTime: Single;
Private | FSolidEdges: TgxVerletEdgeList;
Private | FSpacePartition: TBaseSpacePartition;
Private | FCurrentStepCount: Integer;
Private | FUpdateSpacePartion: TUpdateSpacePartion;
Private | FCollisionConstraintTypes: TCollisionConstraintTypesSet;
Private | FConstraintsWithBeforeIterations: TgxVerletConstraintList;
Private | FVerletNodeClass: TgxVerletNodeClass;
Private | FInertia: Boolean;
Private | FInertaPauseSteps: Integer;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function AddConstraint(const aConstraint: TgxVerletConstraint): Integer;
Public | function AddForce(const aForce: TgxVerletForce): Integer;
Public | function AddNode(const aNode: TgxBaseVerletNode): Integer;
Public | function CreateOwnedNode(const Location: TAffineVector; const aRadius: Single = 0; const aWeight: Single = 1): TgxBaseVerletNode;
Public | function CreateSlider(const aNodeA, aNodeB: TgxBaseVerletNode; const aSlideDirection: TAffineVector): TgxVerletSlider;
Public | function CreateSpring(const aNodeA, aNodeB: TgxBaseVerletNode; const aStrength, aDamping: Single; const aSlack: Single = 0): TgxVerletSpring;
Public | function CreateStick(const aNodeA, aNodeB: TgxBaseVerletNode; const Slack: Single = 0): TgxVerletStick;
Public | function FirstNode: TgxBaseVerletNode;
Public | function LastNode: TgxBaseVerletNode;
Public | function Progress(const deltaTime, newTime: Double): Integer; virtual;
Public | procedure AddSolidEdge(const aNodeA, aNodeB: TgxBaseVerletNode);
Public | procedure CreateOctree(const OctreeMin, OctreeMax: TAffineVector; const LeafThreshold, MaxTreeDepth: Integer);
Public | procedure Initialize; virtual;
Public | procedure PauseInertia(const IterationSteps: Integer);
Public | procedure RemoveConstraint(const aConstraint: TgxVerletConstraint);
Public | procedure RemoveForce(const aForce: TgxVerletForce);
Public | procedure RemoveNode(const aNode: TgxBaseVerletNode);

Properties

Public | property CollisionConstraintTypes: TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;
Public | property Constraints: TgxVerletConstraintList read FConstraints;
Public | property ConstraintsWithBeforeIterations: TgxVerletConstraintList read FConstraintsWithBeforeIterations;
Public | property CurrentDeltaTime: Single read FCurrentDeltaTime;
Public | property CurrentStepCount: Integer read FCurrentStepCount;
Public | property Drag: Single read FDrag write FDrag;
Public | property Inertia: Boolean read FInertia write FInertia;
Public | property Iterations: Integer read FIterations write FIterations;
Public | property MaxDeltaTime: Single read FMaxDeltaTime write FMaxDeltaTime;
Public | property Nodes: TgxVerletNodeList read FNodes;
Public | property SimTime: Single read FSimTime write FSimTime;
Public | property SolidEdges: TgxVerletEdgeList read FSolidEdges write FSolidEdges;
Public | property SpacePartition: TBaseSpacePartition read FSpacePartition;
Public | property UpdateSpacePartion: TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;
Public | property VerletNodeClass: TgxVerletNodeClass read FVerletNodeClass write FVerletNodeClass;

Description

Fields

Private FIterations: Integer;

This item has no description.

Private FNodes: TgxVerletNodeList;

This item has no description.

Private FConstraints: TgxVerletConstraintList;

This item has no description.

Private FForces: TgxVerletForceList;

This item has no description.

Private FMaxDeltaTime: Single;

This item has no description.

Private FSimTime: Single;

This item has no description.

Private FDrag: Single;

This item has no description.

Private FCurrentDeltaTime: Single;

This item has no description.

Private FInvCurrentDeltaTime: Single;

This item has no description.

Private FSolidEdges: TgxVerletEdgeList;

This item has no description.

Private FSpacePartition: TBaseSpacePartition;

This item has no description.

Private FCurrentStepCount: Integer;

This item has no description.

Private FUpdateSpacePartion: TUpdateSpacePartion;

This item has no description.

Private FCollisionConstraintTypes: TCollisionConstraintTypesSet;

This item has no description.

Private FConstraintsWithBeforeIterations: TgxVerletConstraintList;

This item has no description.

Private FVerletNodeClass: TgxVerletNodeClass;

This item has no description.

Private FInertia: Boolean;

This item has no description.

Private FInertaPauseSteps: Integer;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddConstraint(const aConstraint: TgxVerletConstraint): Integer;

This item has no description.

Public function AddForce(const aForce: TgxVerletForce): Integer;

This item has no description.

Public function AddNode(const aNode: TgxBaseVerletNode): Integer;

This item has no description.

Public function CreateOwnedNode(const Location: TAffineVector; const aRadius: Single = 0; const aWeight: Single = 1): TgxBaseVerletNode;

This item has no description.

Public function CreateSlider(const aNodeA, aNodeB: TgxBaseVerletNode; const aSlideDirection: TAffineVector): TgxVerletSlider;

This item has no description.

Public function CreateSpring(const aNodeA, aNodeB: TgxBaseVerletNode; const aStrength, aDamping: Single; const aSlack: Single = 0): TgxVerletSpring;

This item has no description.

Public function CreateStick(const aNodeA, aNodeB: TgxBaseVerletNode; const Slack: Single = 0): TgxVerletStick;

This item has no description.

Public function FirstNode: TgxBaseVerletNode;

This item has no description.

Public function LastNode: TgxBaseVerletNode;

This item has no description.

Public function Progress(const deltaTime, newTime: Double): Integer; virtual;

This item has no description.

Public procedure AddSolidEdge(const aNodeA, aNodeB: TgxBaseVerletNode);

This item has no description.

Public procedure CreateOctree(const OctreeMin, OctreeMax: TAffineVector; const LeafThreshold, MaxTreeDepth: Integer);

This item has no description.

Public procedure Initialize; virtual;

This item has no description.

Public procedure PauseInertia(const IterationSteps: Integer);

This item has no description.

Public procedure RemoveConstraint(const aConstraint: TgxVerletConstraint);

This item has no description.

Public procedure RemoveForce(const aForce: TgxVerletForce);

This item has no description.

Public procedure RemoveNode(const aNode: TgxBaseVerletNode);

This item has no description.

Properties

Public property CollisionConstraintTypes: TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;

This item has no description.

Public property Constraints: TgxVerletConstraintList read FConstraints;

This item has no description.

Public property ConstraintsWithBeforeIterations: TgxVerletConstraintList read FConstraintsWithBeforeIterations;

This item has no description.

Public property CurrentDeltaTime: Single read FCurrentDeltaTime;

This item has no description.

Public property CurrentStepCount: Integer read FCurrentStepCount;

This item has no description.

Public property Drag: Single read FDrag write FDrag;

This item has no description.

Public property Inertia: Boolean read FInertia write FInertia;

This item has no description.

Public property Iterations: Integer read FIterations write FIterations;

This item has no description.

Public property MaxDeltaTime: Single read FMaxDeltaTime write FMaxDeltaTime;

This item has no description.

Public property Nodes: TgxVerletNodeList read FNodes;

This item has no description.

Public property SimTime: Single read FSimTime write FSimTime;

This item has no description.

Public property SolidEdges: TgxVerletEdgeList read FSolidEdges write FSolidEdges;

This item has no description.

Public property SpacePartition: TBaseSpacePartition read FSpacePartition;

This item has no description.

Public property UpdateSpacePartion: TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;

This item has no description.

Public property VerletNodeClass: TgxVerletNodeClass read FVerletNodeClass write FVerletNodeClass;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletGravity

Class TgxVerletGravity

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletGravity = class(TgxVerletGlobalForce)

Description

This item has no description. Showing description inherited from TgxVerletGlobalForce.

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletGlobalForce
  • TgxVerletGravity

Overview

Fields

Private FGravity: TAffineVector;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | procedure AddForceToNode(const aNode: TgxBaseVerletNode); override;

Properties

Public property Gravity: TAffineVector read FGravity write FGravity;

Description

Fields

Private FGravity: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public procedure AddForceToNode(const aNode: TgxBaseVerletNode); override;

This item has no description.

Properties

Public property Gravity: TAffineVector read FGravity write FGravity;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletAirResistance

Class TgxVerletAirResistance

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletAirResistance = class(TgxVerletGlobalForce)

Description

This item has no description. Showing description inherited from TgxVerletGlobalForce.

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletGlobalForce
  • TgxVerletAirResistance

Overview

Fields

Private | FDragCoeff: Single;
Private | FWindDirection: TAffineVector;
Private | FWindMagnitude: Single;
Private | FWindChaos: Single;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | procedure AddForceToNode(const aNode: TgxBaseVerletNode); override;
Private | procedure SetWindDirection(const Value: TAffineVector);

Properties

Public | property DragCoeff: Single read FDragCoeff write FDragCoeff;
Public | property WindChaos: Single read FWindChaos write FWindChaos;
Public | property WindDirection: TAffineVector read FWindDirection write SetWindDirection;
Public | property WindMagnitude: Single read FWindMagnitude write FWindMagnitude;

Description

Fields

Private FDragCoeff: Single;

This item has no description.

Private FWindDirection: TAffineVector;

This item has no description.

Private FWindMagnitude: Single;

This item has no description.

Private FWindChaos: Single;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public procedure AddForceToNode(const aNode: TgxBaseVerletNode); override;

This item has no description.

Private procedure SetWindDirection(const Value: TAffineVector);

This item has no description.

Properties

Public property DragCoeff: Single read FDragCoeff write FDragCoeff;

This item has no description.

Public property WindChaos: Single read FWindChaos write FWindChaos;

Measures how chaotic the wind is, as a fraction of the wind magnitude

Public property WindDirection: TAffineVector read FWindDirection write SetWindDirection;

This item has no description.

Public property WindMagnitude: Single read FWindMagnitude write FWindMagnitude;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletSpring

Class TgxVerletSpring

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletSpring = class(TgxVerletDualForce)

Description

This item has no description. Showing description inherited from TgxVerletDualForce.

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TgxVerletForce
  • TgxVerletDualForce
  • TgxVerletSpring

Overview

Fields

Private | FRestLength: Single;
Private | FStrength: Single;
Private | FDamping: Single;
Private | FSlack: Single;
Private | FForceFactor: Single;

Methods

Public | procedure AddForce(const vpt: TgxProgressTimes); override;
Public | procedure SetRestLengthToCurrent;

Properties

Public | property Damping: Single read FDamping write FDamping;
Public | property Slack: Single read FSlack write SetSlack;
Public | property Strength: Single read FStrength write FStrength;

Description

Fields

Private FRestLength: Single;

This item has no description.

Private FStrength: Single;

This item has no description.

Private FDamping: Single;

This item has no description.

Private FSlack: Single;

This item has no description.

Private FForceFactor: Single;

This item has no description.

Methods

Public procedure AddForce(const vpt: TgxProgressTimes); override;

This item has no description. Showing description inherited from TgxVerletForce.AddForce.

Implementation should add force to force resultant for all relevant nodes

Public procedure SetRestLengthToCurrent;

Must be invoked after adjust node locations or strength

Properties

Public property Damping: Single read FDamping write FDamping;

This item has no description.

Public property Slack: Single read FSlack write SetSlack;

This item has no description.

Public property Strength: Single read FStrength write FStrength;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletFloor

Class TgxVerletFloor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletFloor = class(TgxVerletGlobalFrictionConstraintSP)

Description

Floor Collision Constraint

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletFloor

Overview

Fields

Private | FBounceRatio: Single;
Private | FFloorLevel: Single;
Private | FNormal: TAffineVector;

Methods

Public | constructor Create(const aOwner: TgxVerletWorld); override;
Public | procedure PerformSpaceQuery; override;
Public | procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property BounceRatio: Single read FBounceRatio write FBounceRatio;
Public | property FloorLevel: Single read FFloorLevel write FFloorLevel;
Public | property Normal: TAffineVector read FNormal write SetNormal;

Description

Fields

Private FBounceRatio: Single;

This item has no description.

Private FFloorLevel: Single;

This item has no description.

Private FNormal: TAffineVector;

This item has no description.

Methods

Public constructor Create(const aOwner: TgxVerletWorld); override;

This item has no description.

Public procedure PerformSpaceQuery; override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property BounceRatio: Single read FBounceRatio write FBounceRatio;

This item has no description.

Public property FloorLevel: Single read FFloorLevel write FFloorLevel;

This item has no description.

Public property Normal: TAffineVector read FNormal write SetNormal;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletHeightField

Class TgxVerletHeightField

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletHeightField = class(TgxVerletFloor)

Description

HeightField collision constraint (punctual!)

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletFloor
  • TgxVerletHeightField

Overview

Fields

Private FOnNeedHeight: TgxVerletHeightFieldOnNeedHeight;

Methods

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public property OnNeedHeight: TgxVerletHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;

Description

Fields

Private FOnNeedHeight: TgxVerletHeightFieldOnNeedHeight;

This item has no description.

Methods

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property OnNeedHeight: TgxVerletHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletStick

Class TgxVerletStick

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletStick = class(TgxVerletDualConstraint)

Description

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletDualConstraint
  • TgxVerletStick

Overview

Fields

Private | FSlack: Single;
Private | FRestLength: Single;

Methods

Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;
Public | procedure SetRestLengthToCurrent;

Properties

Public | property RestLength: Single read FRestLength write FRestLength;
Public | property Slack: Single read FSlack write FSlack;

Description

Fields

Private FSlack: Single;

This item has no description.

Private FRestLength: Single;

This item has no description.

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TgxVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Public procedure SetRestLengthToCurrent;

This item has no description.

Properties

Public property RestLength: Single read FRestLength write FRestLength;

This item has no description.

Public property Slack: Single read FSlack write FSlack;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletRigidBody

Class TgxVerletRigidBody

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletRigidBody = class(TgxVerletGroupConstraint)

Description

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGroupConstraint
  • TgxVerletRigidBody

Overview

Fields

Private | FNodeParams: array of TAffineVector;
Private | FNodeCoords: array of TAffineVector;
Private | FNatMatrix: TAffineMatrix;
Private | FInvNatMatrix: TAffineMatrix;

Methods

Public | procedure ComputeRigidityParameters;
Public | procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

Description

Fields

Private FNodeParams: array of TAffineVector;

This item has no description.

Private FNodeCoords: array of TAffineVector;

This item has no description.

Private FNatMatrix: TAffineMatrix;

This item has no description.

Private FInvNatMatrix: TAffineMatrix;

This item has no description.

Methods

Public procedure ComputeRigidityParameters;

This item has no description.

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TgxVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletSlider

Class TgxVerletSlider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletSlider = class(TgxVerletDualConstraint)

Description

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletDualConstraint
  • TgxVerletSlider

Overview

Fields

Private | FSlideDirection: TAffineVector;
Private | FConstrained: Boolean;

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

Properties

Public | property Constrained: Boolean read FConstrained write FConstrained;
Public | property SlideDirection: TAffineVector read FSlideDirection write SetSlideDirection;

Description

Fields

Private FSlideDirection: TAffineVector;

This item has no description.

Private FConstrained: Boolean;

This item has no description.

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations: Integer); override;

This item has no description. Showing description inherited from TgxVerletConstraint.SatisfyConstraint.

Updates the position of one or several nodes to make sure that they don't violate the constraint

Properties

Public property Constrained: Boolean read FConstrained write FConstrained;

Constrain NodeB to the halfplane defined by NodeA and SlideDirection.

Public property SlideDirection: TAffineVector read FSlideDirection write SetSlideDirection;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletFrictionSphere

Class TgxVerletFrictionSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletFrictionSphere = class(TgxVerletGlobalFrictionConstraintSphere)

Description

Sphere Сollision Friction Constraint

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletGlobalFrictionConstraintSphere
  • TgxVerletFrictionSphere

Overview

Fields

Private FRadius: Single;

Methods

Public | function GetBSphere: TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public property Radius: Single read FRadius write FRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Methods

Public function GetBSphere: TBSphere; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Radius: Single read FRadius write FRadius;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletFrictionCylinder

Class TgxVerletFrictionCylinder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletFrictionCylinder = class(TgxVerletGlobalFrictionConstraint)

Description

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletFrictionCylinder

Overview

Fields

Private | FAxis: TAffineVector;
Private | FRadius: Single;
Private | FRadius2: Single;

Methods

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property Axis: TAffineVector read FAxis write FAxis;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FAxis: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FRadius2: Single;

This item has no description.

Methods

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis write FAxis;

Cylinder axis vector. Must be normalized.

Public property Radius: Single read FRadius write SetRadius;

Cylinder radius.


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletFrictionCube

Class TgxVerletFrictionCube

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletFrictionCube = class(TgxVerletGlobalFrictionConstraintBox)

Description

Cube Сollision Friction Constraint.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletGlobalFrictionConstraintBox
  • TgxVerletFrictionCube

Overview

Fields

Private | FHalfSides: TAffineVector;
Private | FSides: TAffineVector;
Private | FDirection: TAffineVector;

Methods

Public | function GetAABB: TAABB; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;
Private | procedure SetSides(const Value: TAffineVector);

Properties

Public | property Direction: TAffineVector read FDirection write FDirection;
Public | property Sides: TAffineVector read FSides write SetSides;

Description

Fields

Private FHalfSides: TAffineVector;

This item has no description.

Private FSides: TAffineVector;

This item has no description.

Private FDirection: TAffineVector;

This item has no description.

Methods

Public function GetAABB: TAABB; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;

Broken and very slow!

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Private procedure SetSides(const Value: TAffineVector);

This item has no description.

Properties

Public property Direction: TAffineVector read FDirection write FDirection;

This item has no description.

Public property Sides: TAffineVector read FSides write SetSides;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletFrictionCapsule

Class TgxVerletFrictionCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletFrictionCapsule = class(TgxVerletGlobalFrictionConstraintSphere)

Description

Capsule collision Friction Constraint.

Hierarchy

  • TObject
  • TgxVerletConstraint
  • TgxVerletGlobalConstraint
  • TgxVerletGlobalFrictionConstraint
  • TgxVerletGlobalFrictionConstraintSP
  • TgxVerletGlobalFrictionConstraintSphere
  • TgxVerletFrictionCapsule

Overview

Fields

Private | FAxis: TAffineVector;
Private | FRadius: Single;
Private | FRadius2: Single;
Private | FLength: Single;
Private | FLengthDiv2: Single;

Methods

Public | function GetBSphere: TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

Properties

Public | property Axis: TAffineVector read FAxis write SetAxis;
Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FAxis: TAffineVector;

This item has no description.

Private FRadius: Single;

This item has no description.

Private FRadius2: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Private FLengthDiv2: Single;

This item has no description.

Methods

Public function GetBSphere: TBSphere; override;

This item has no description.

Public procedure SatisfyConstraintForEdge(const aEdge: TgxVerletEdge; const iteration, maxIterations: Integer); override;

This item has no description.

Public procedure SatisfyConstraintForNode(const aNode: TgxBaseVerletNode; const iteration, maxIterations: Integer); override;

This item has no description.

Properties

Public property Axis: TAffineVector read FAxis write SetAxis;

property Base : TAffineVector read FBase write FBase;

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletNode

Class TgxVerletNode

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletNode = class(TgxBaseVerletNode)

Description

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

Hierarchy

  • TgxPersistentObject
  • TSpacePartitionLeaf
  • TgxBaseVerletNode
  • TgxVerletNode

Overview

Fields

Private | FRelativePosition: TAffineVector;
Private | FGXBaseSceneObject: TgxBaseSceneObject;

Methods

Public | procedure Verlet(const vpt: TgxProgressTimes); override;
Private | procedure SetBaseSceneObject(const Value: TgxBaseSceneObject);

Properties

Public | property GXBaseSceneObject: TgxBaseSceneObject read FGXBaseSceneObject write SetBaseSceneObject;
Public | property RelativePosition: TAffineVector read FRelativePosition write FRelativePosition;

Description

Fields

Private FRelativePosition: TAffineVector;

This item has no description.

Private FGXBaseSceneObject: TgxBaseSceneObject;

This item has no description.

Methods

Public procedure Verlet(const vpt: TgxProgressTimes); override;

This item has no description. Showing description inherited from TgxBaseVerletNode.Verlet.

Perform Verlet integration

Private procedure SetBaseSceneObject(const Value: TgxBaseSceneObject);

This item has no description.

Properties

Public property GXBaseSceneObject: TgxBaseSceneObject read FGXBaseSceneObject write SetBaseSceneObject;

This item has no description.

Public property RelativePosition: TAffineVector read FRelativePosition write FRelativePosition;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletHair

Class TgxVerletHair

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletHair = class(TObject)

Description

Verlet Hair class

Hierarchy

  • TObject
  • TgxVerletHair

Overview

Fields

Private | FNodeList: TgxVerletNodeList;
Private | FLinkCount: integer;
Private | FRootDepth: single;
Private | FVerletWorld: TgxVerletWorld;
Private | FHairLength: single;
Private | FData: pointer;
Private | FStiffness: TgxStiffnessSetVH;
Private | FStiffnessList: TList;

Methods

Public | constructor Create(const AVerletWorld: TgxVerletWorld; const ARootDepth, AHairLength: single; ALinkCount: integer; const AAnchorPosition, AHairDirection: TAffineVector; const AStiffness: TgxStiffnessSetVH);
Public | destructor Destroy; override;
Private | function GetAnchor: TgxBaseVerletNode;
Private | function GetLinkLength: single;
Private | function GetRoot: TgxBaseVerletNode;
Public | procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);
Public | procedure BuildStiffness;
Public | procedure Clear;
Public | procedure ClearStiffness;
Private | procedure AddStickStiffness(const ANodeSkip: integer);
Private | procedure SetStiffness(const Value: TgxStiffnessSetVH);

Properties

Public | property Anchor: TgxBaseVerletNode read GetAnchor;
Public | property Data: pointer read FData write FData;
Public | property HairLength: single read FHairLength;
Public | property LinkCount: integer read FLinkCount;
Public | property LinkLength: single read GetLinkLength;
Public | property NodeList: TgxVerletNodeList read FNodeList;
Public | property Root: TgxBaseVerletNode read GetRoot;
Public | property RootDepth: single read FRootDepth;
Public | property Stiffness: TgxStiffnessSetVH read FStiffness write SetStiffness;
Public | property VerletWorld: TgxVerletWorld read FVerletWorld;

Description

Fields

Private FNodeList: TgxVerletNodeList;

This item has no description.

Private FLinkCount: integer;

This item has no description.

Private FRootDepth: single;

This item has no description.

Private FVerletWorld: TgxVerletWorld;

This item has no description.

Private FHairLength: single;

This item has no description.

Private FData: pointer;

This item has no description.

Private FStiffness: TgxStiffnessSetVH;

This item has no description.

Private FStiffnessList: TList;

This item has no description.

Methods

Public constructor Create(const AVerletWorld: TgxVerletWorld; const ARootDepth, AHairLength: single; ALinkCount: integer; const AAnchorPosition, AHairDirection: TAffineVector; const AStiffness: TgxStiffnessSetVH);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAnchor: TgxBaseVerletNode;

This item has no description.

Private function GetLinkLength: single;

This item has no description.

Private function GetRoot: TgxBaseVerletNode;

This item has no description.

Public procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);

This item has no description.

Public procedure BuildStiffness;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure ClearStiffness;

This item has no description.

Private procedure AddStickStiffness(const ANodeSkip: integer);

This item has no description.

Private procedure SetStiffness(const Value: TgxStiffnessSetVH);

This item has no description.

Properties

Public property Anchor: TgxBaseVerletNode read GetAnchor;

Anchor should be nailed down to give the hair stability

Public property Data: pointer read FData write FData;

This item has no description.

Public property HairLength: single read FHairLength;

This item has no description.

Public property LinkCount: integer read FLinkCount;

This item has no description.

Public property LinkLength: single read GetLinkLength;

This item has no description.

Public property NodeList: TgxVerletNodeList read FNodeList;

This item has no description.

Public property Root: TgxBaseVerletNode read GetRoot;

Root should be nailed down to give the hair stability

Public property RootDepth: single read FRootDepth;

This item has no description.

Public property Stiffness: TgxStiffnessSetVH read FStiffness write SetStiffness;

This item has no description.

Public property VerletWorld: TgxVerletWorld read FVerletWorld;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletSkeletonCollider

Class TgxVerletSkeletonCollider

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletSkeletonCollider = class(TgxSkeletonCollider)

Description

Base Verlet Skeleton Collider class.

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TgxVerletSkeletonCollider

Overview

Fields

Private FVerletConstraint: TgxVerletConstraint;

Methods

Public | procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); virtual;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Properties

Public property VerletConstraint: TgxVerletConstraint read FVerletConstraint;

Description

Fields

Private FVerletConstraint: TgxVerletConstraint;

This item has no description.

Methods

Public procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); virtual;

This item has no description.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property VerletConstraint: TgxVerletConstraint read FVerletConstraint;

The verlet constraint is created through the AddToVerletWorld procedure


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletSphere

Class TgxVerletSphere

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletSphere = class(TgxVerletSkeletonCollider)

Description

Sphere shaped verlet constraint in a skeleton collider

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TgxVerletSkeletonCollider
  • TgxVerletSphere

Overview

Fields

Private FRadius: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Properties

Public property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); override;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TgxSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Radius: Single read FRadius write SetRadius;


GXSysHelp v.2.5: GXS.VerletTypes: Class TgxVerletCapsule

Class TgxVerletCapsule

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.VerletTypes

Declaration

type TgxVerletCapsule = class(TgxVerletSkeletonCollider)

Description

Capsule shaped verlet constraint in a skeleton collider

Hierarchy

  • TgxPersistentObject
  • TgxSkeletonCollider
  • TgxVerletSkeletonCollider
  • TgxVerletCapsule

Overview

Fields

Private | FRadius: Single;
Private | FLength: Single;

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(Reader: TgxVirtualReader); override;
Public | procedure WriteToFiler(Writer: TgxVirtualWriter); override;

Properties

Public | property Length: Single read FLength write SetLength;
Public | property Radius: Single read FRadius write SetRadius;

Description

Fields

Private FRadius: Single;

This item has no description.

Private FLength: Single;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public procedure AddToVerletWorld(VerletWorld: TgxVerletWorld); override;

This item has no description.

Public procedure AlignCollider; override;

This item has no description. Showing description inherited from TgxSkeletonCollider.AlignCollider.

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(Reader: TgxVirtualReader); override;

This item has no description.

Public procedure WriteToFiler(Writer: TgxVirtualWriter); override;

This item has no description.

Properties

Public property Length: Single read FLength write SetLength;

This item has no description.

Public property Radius: Single read FRadius write SetRadius;


GXSysHelp v.2.5: GXS.ViewerOpenGL

Unit GXS.ViewerOpenGL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.Windows
  • System.Types
  • System.Classes
  • System.UITypes
  • System.SysUtils
  • FMX.Forms
  • FMX.Platform.Win
  • FMX.Types
  • FMX.Types3D
  • FMX.Controls
  • FMX.Graphics
  • GLScene.OpenGL4
  • GLScene.TextureFormat
  • GXS.Scene
  • GXS.Context
  • GXS.WinContext

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSceneViewport |


GXSysHelp v.2.5: GXS.ViewerOpenGL: Class TgxSceneViewport

Class TgxSceneViewport

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.ViewerOpenGL

Declaration

type TgxSceneViewport = class(TControl)

Description

GL_ARB_framebuffer_object or GL_EXT_framebuffer_blit

Hierarchy

  • TControl
  • TgxSceneViewport

Overview

Fields

Private | FGLSBuffer: TgxSceneBuffer;
Private | FFMXBuffer: TBitmap;
Private | FFMXContext: TContext3D;
Private | FMultisample: FMX.Types3D.TMultisample;
Private | FParentHandle: HWND;
Private | FOwnDC: HDC;
Private | FDrawing: Boolean;
Private | FPostRender: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetAfterRender: TNotifyEvent;
Private | function GetBeforeRender: TNotifyEvent;
Private | function GetSceneCamera: TgxCamera;
Public | procedure Realign;
Private | procedure CopyBuffer(Sender: TObject);
Private | procedure SetAfterRender(const Value: TNotifyEvent);
Private | procedure SetBeforeRender(const Value: TNotifyEvent);
Private | procedure SetBuffer(const Value: TgxSceneBuffer);
Private | procedure SetSceneCamera(const Value: TgxCamera);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TgxSceneBuffer read FGLSBuffer write SetBuffer;
Published | property PostRender: TNotifyEvent read FPostRender write FPostRender;
Published | property SceneCamera: TgxCamera read GetSceneCamera write SetSceneCamera;

Description

Fields

Private FGLSBuffer: TgxSceneBuffer;

This item has no description.

Private FFMXBuffer: TBitmap;

This item has no description.

Private FFMXContext: TContext3D;

This item has no description.

Private FMultisample: FMX.Types3D.TMultisample;

This item has no description.

Private FParentHandle: HWND;

This item has no description.

Private FOwnDC: HDC;

This item has no description.

Private FDrawing: Boolean;

This item has no description.

Private FPostRender: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAfterRender: TNotifyEvent;

This item has no description.

Private function GetBeforeRender: TNotifyEvent;

This item has no description.

Private function GetSceneCamera: TgxCamera;

This item has no description.

Public procedure Realign;

procedure Realign; override; - E2179, removed override;

Private procedure CopyBuffer(Sender: TObject);

This item has no description.

Private procedure SetAfterRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetBeforeRender(const Value: TNotifyEvent);

This item has no description.

Private procedure SetBuffer(const Value: TgxSceneBuffer);

This item has no description.

Private procedure SetSceneCamera(const Value: TgxCamera);

This item has no description.

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering. You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered. You may use this event to execute your own OpenGL rendering.

Published property Buffer: TgxSceneBuffer read FGLSBuffer write SetBuffer;

Access to buffer properties.

Published property PostRender: TNotifyEvent read FPostRender write FPostRender;

Triggered just after all the scene's objects have been rendered. The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.

Published property SceneCamera: TgxCamera read GetSceneCamera write SetSceneCamera;

Camera from which the scene is rendered.


GXSysHelp v.2.5: GXS.WaterPlane

Unit GXS.WaterPlane

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • GLScene.OpenGL4
  • System.Classes
  • FMX.Objects
  • FMX.Types
  • FMX.Graphics
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.Utils
  • GXS.VectorLists
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GXS.Scene
  • GXS.ImageUtils
  • GXS.Context
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxWaterPlane |

Types

TgxWaterPlaneOption = (...);
TgxWaterPlaneOptions = set of TgxWaterPlaneOption;

Constants

cDefaultWaterPlaneOptions = [wpoTextured];

Description

Types

TgxWaterPlaneOption = (...);

GL_EXT_compiled_vertex_array

Values
  • wpoTextured
TgxWaterPlaneOptions = set of TgxWaterPlaneOption;

This item has no description.

Constants

cDefaultWaterPlaneOptions = [wpoTextured];


GXSysHelp v.2.5: GXS.WaterPlane: Class TgxWaterPlane

Class TgxWaterPlane

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.WaterPlane

Declaration

type TgxWaterPlane = class(TgxSceneObject)

Description

This item has no description. Showing description inherited from TgxSceneObject.

Base class for standard scene objects. Publishes the Material property.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxWaterPlane

Overview

Fields

Private | FLocks: packed of ByteBool;
Private | FPositions: packed of Single;
Private | FVelocity: packed of Single;
Private | FPlaneQuadIndices: TgxPersistentObjectList;
Private | FPlaneQuadTexCoords: TgxTexPointList;
Private | FPlaneQuadVertices: TgxAffineVectorList;
Private | FPlaneQuadNormals: TgxAffineVectorList;
Private | FActive: Boolean;
Private | FRainTimeInterval: Integer;
Private | FRainForce: Single;
Private | FViscosity: Single;
Private | FElastic: Single;
Private | FResolution: Integer;
Private | FSimulationFrequency: Single;
Private | FTimeToNextUpdate: Single;
Private | FTimeToNextRainDrop: Single;
Private | FMaximumCatchupIterations: Integer;
Private | FLastIterationStepTime: Single;
Private | FMask: TImage;
Private | FOptions: TgxWaterPlaneOptions;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector4f; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TgxRenderContextInfo); override;
Public | procedure CreateRippleAtGridPos(X, Y: Integer);
Public | procedure CreateRippleAtWorldPos(const pos: TVector4f); overload;
Public | procedure CreateRippleAtWorldPos(const X, Y, z: Single); overload;
Public | procedure CreateRippleRandom;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure Reset;

Properties

Published | property Active: Boolean read FActive write FActive default True;
Published | property Elastic: Single read FElastic write SetElastic;
Public | property LastIterationStepTime: Single read FLastIterationStepTime;
Published | property Mask: TImage read FMask write SetMask;
Published | property MaximumCatchupIterations: Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;
Published | property Options: TgxWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;
Published | property RainForce: Single read FRainForce write SetRainForce;
Published | property RainTimeInterval: Integer read FRainTimeInterval write SetRainTimeInterval default 500;
Published | property Resolution: Integer read FResolution write SetResolution default 64;
Published | property SimulationFrequency: Single read FSimulationFrequency write SetSimulationFrequency;
Published | property Viscosity: Single read FViscosity write SetViscosity;

Description

Fields

Private FLocks: packed of ByteBool;

This item has no description.

Private FPositions: packed of Single;

This item has no description.

Private FVelocity: packed of Single;

This item has no description.

Private FPlaneQuadIndices: TgxPersistentObjectList;

This item has no description.

Private FPlaneQuadTexCoords: TgxTexPointList;

This item has no description.

Private FPlaneQuadVertices: TgxAffineVectorList;

This item has no description.

Private FPlaneQuadNormals: TgxAffineVectorList;

This item has no description.

Private FActive: Boolean;

This item has no description.

Private FRainTimeInterval: Integer;

This item has no description.

Private FRainForce: Single;

This item has no description.

Private FViscosity: Single;

This item has no description.

Private FElastic: Single;

This item has no description.

Private FResolution: Integer;

This item has no description.

Private FSimulationFrequency: Single;

This item has no description.

Private FTimeToNextUpdate: Single;

This item has no description.

Private FTimeToNextRainDrop: Single;

This item has no description.

Private FMaximumCatchupIterations: Integer;

This item has no description.

Private FLastIterationStepTime: Single;

This item has no description.

Private FMask: TImage;

This item has no description.

Private FOptions: TgxWaterPlaneOptions;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AxisAlignedDimensionsUnscaled: TVector4f; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure BuildList(var rci: TgxRenderContextInfo); override;

This item has no description. Showing description inherited from TgxBaseSceneObject.BuildList.

Make object-specific geometry description here. Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure CreateRippleAtGridPos(X, Y: Integer);

This item has no description.

Public procedure CreateRippleAtWorldPos(const pos: TVector4f); overload;

This item has no description.

Public procedure CreateRippleAtWorldPos(const X, Y, z: Single); overload;

This item has no description.

Public procedure CreateRippleRandom;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure Reset;

This item has no description.

Properties

Published property Active: Boolean read FActive write FActive default True;

This item has no description.

Published property Elastic: Single read FElastic write SetElastic;

This item has no description.

Public property LastIterationStepTime: Single read FLastIterationStepTime;

CPU time (in seconds) taken by the last iteration step.

Published property Mask: TImage read FMask write SetMask;

A picture whose pixels determine what part of the waterplane is active. Pixels with a green/gray component beyond 128 are active, the others are not (in short, white = active, black = inactive). The picture will automatically be stretched to match the resolution.

Published property MaximumCatchupIterations: Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;

Maximum number of simulation iterations during catchups. Catchups happen when for a reason or another, the DoProgress doesn't happen as fast SimulationFrequency.

Published property Options: TgxWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;

This item has no description.

Published property RainForce: Single read FRainForce write SetRainForce;

This item has no description.

Published property RainTimeInterval: Integer read FRainTimeInterval write SetRainTimeInterval default 500;

Delay between raindrops in milliseconds (0 = no rain)

Published property Resolution: Integer read FResolution write SetResolution default 64;

This item has no description.

Published property SimulationFrequency: Single read FSimulationFrequency write SetSimulationFrequency;

Maximum frequency (in Hz) at which simulation iterations happen.

Published property Viscosity: Single read FViscosity write SetViscosity;


GXSysHelp v.2.5: GXS.WinContext

Unit GXS.WinContext

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • Winapi.Messages
  • System.SysUtils
  • System.Classes
  • FMX.Forms
  • FMX.Dialogs
  • FMX.Platform.Win
  • GLScene.OpenGL4
  • GXS.Context
  • GXS.State
  • GLScene.Strings
  • GLScene.VectorGeometry

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxWinContext |

Functions and Procedures

function CreateTempWnd: HWND;

Variables

vUseWindowTrackingHook: Boolean = True;

Description

Functions and Procedures

function CreateTempWnd: HWND;

This item has no description.

Variables

vUseWindowTrackingHook: Boolean = True;

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction.


GXSysHelp v.2.5: GXS.WinContext: Class TgxWinContext

Class TgxWinContext

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.WinContext

Declaration

type TgxWinContext = class(TgxContext)

Description

A context driver for standard Windows OpenGL

Hierarchy

  • TObject
  • TgxContext
  • TgxWinContext

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Public | procedure SwapBuffers; override;

Properties

Public | property DC: HDC read FDC;
Public | property RC: HGLRC read FRC;

Description

Methods

Public constructor Create; override;

DoGetHandles must be implemented in child classes, and return the display + window

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; override;

This item has no description. Showing description inherited from TgxContext.IsValid.

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; override;

This item has no description.

Public procedure SwapBuffers; override;

This item has no description. Showing description inherited from TgxContext.SwapBuffers.

Request to swap front and back buffers if they were defined.

Properties

Public property DC: HDC read FDC;

This item has no description.

Public property RC: HGLRC read FRC;


GXSysHelp v.2.5: GXS.Windows

Unit GXS.Windows

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • System.Math
  • System.UITypes
  • FMX.Graphics
  • FMX.Types
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GLScene.Utils
  • GXS.PersistentClasses
  • GXS.BaseClasses
  • GXS.Scene
  • GXS.Coordinates
  • GXS.HUDObjects
  • GXS.Material
  • GXS.Context
  • GXS.BitmapFont
  • GXS.WindowsFont
  • GXS.Gui
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Objects
  • GXS.State
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxBaseComponent |
Class TgxBaseControl |
Class TgxBaseFontControl |
Class TgxBaseTextControl |
Class TgxFocusControl |
Class TgxCustomControl |
Class TgxPopupMenu |
Class TgxForm |
Class TgxPanel |
Class TgxCheckBox |
Class TgxButton |
Class TgxEdit |
Class TgxLabel |
Class TgxAdvancedLabel |
Class TgxScrollbar |
Class StringGrid |

Functions and Procedures

function UnpressGroup(CurrentObject: TgxBaseSceneObject; AGroupID: Integer): Boolean;

Types

TgxAcceptMouseQuery = procedure(Sender: TgxBaseControl; Shift: TShiftState; Action: TgxMouseAction; Button: TMouseButton; X, Y: Integer; var Accept: boolean) of object;
TgxCustomRenderEvent = procedure(Sender: TgxCustomControl; Bitmap: TBitmap) of object;
TgxFormCanClose = procedure(Sender: TgxForm; var CanClose: TgxFormCloseOptions) of object;
TgxFormCanRequest = procedure(Sender: TgxForm; var Can: Boolean) of object;
TgxFormCloseOptions = (...);
TgxFormMove = procedure(Sender: TgxForm; var Left, Top: Single) of object;
TgxFormNotify = procedure(Sender: TgxForm) of object;
TgxMouseAction = (...);
TgxPopupMenuClick = procedure(Sender: TgxPopupMenu; index: Integer; const MenuItemText: string) of object;

Description

Functions and Procedures

function UnpressGroup(CurrentObject: TgxBaseSceneObject; AGroupID: Integer): Boolean;

This item has no description.

Types

TgxAcceptMouseQuery = procedure(Sender: TgxBaseControl; Shift: TShiftState; Action: TgxMouseAction; Button: TMouseButton; X, Y: Integer; var Accept: boolean) of object;

This item has no description.

TgxCustomRenderEvent = procedure(Sender: TgxCustomControl; Bitmap: TBitmap) of object;

This item has no description.

TgxFormCanClose = procedure(Sender: TgxForm; var CanClose: TgxFormCloseOptions) of object;

This item has no description.

TgxFormCanRequest = procedure(Sender: TgxForm; var Can: Boolean) of object;

This item has no description.

TgxFormCloseOptions = (...);

This item has no description.

Values
  • co_Hide
  • co_Ignore
  • co_Destroy
TgxFormMove = procedure(Sender: TgxForm; var Left, Top: Single) of object;

This item has no description.

TgxFormNotify = procedure(Sender: TgxForm) of object;

This item has no description.

TgxMouseAction = (...);

This item has no description.

Values
  • ma_mouseup
  • ma_mousedown
  • ma_mousemove
TgxPopupMenuClick = procedure(Sender: TgxPopupMenu; index: Integer; const MenuItemText: string) of object;


GXSysHelp v.2.5: GXS.Windows: Class TgxBaseComponent

Class TgxBaseComponent

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxBaseComponent = class(TgxBaseGuiObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent

Overview

Fields

Private | FGUIRedraw: Boolean;
Private | FGuiLayout: TgxGuiLayout;
Private | FGuiLayoutName: TgxGuiComponentName;
Private | FGuiComponent: TgxGuiComponent;
Private | FReBuildGui: Boolean;
Private | FRedrawAtOnce: Boolean;
Private | MoveX: Single;
Private | MoveY: Single;
Private | FRenderStatus: TGUIDrawResult;
Private | FAlphaChannel: Single;
Private | FRotation: Single;
Private | FNoZWrite: Boolean;
Private | BlockRendering: Boolean;
Private | RenderingCount: Integer;
Private | BlockedCount: Integer;
Private | GuiDestroying: Boolean;
Private | FDoChangesOnProgress: Boolean;
Private | FAutosize: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BlockRender;
Public | procedure DoChanges; virtual;
Public | procedure DoProgress(const progressTime: TgxProgressTimes); override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;
Public | procedure MoveGUI(XRel, YRel: Single);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure PlaceGUI(XPos, YPos: Single);
Public | procedure UnBlockRender;
Private | procedure SetAutosize(const Value: Boolean);
Private | procedure SetDoChangesOnProgress(const Value: Boolean);
Private | procedure SetGUIRedraw(value: Boolean);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Autosize: Boolean read FAutosize write SetAutosize;
Published | property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;
Published | property GuiLayout: TgxGuiLayout read FGuiLayout write SetGuiLayout;
Published | property GuiLayoutName: TgxGuiComponentName read FGuiLayoutName write SetGuiLayoutName;
Public | property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;
Published | property Height;
Published | property Left;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property Position;
Public | property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;
Published | property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property Top;
Published | property Visible;
Published | property Width;

Description

Fields

Private FGUIRedraw: Boolean;

This item has no description.

Private FGuiLayout: TgxGuiLayout;

This item has no description.

Private FGuiLayoutName: TgxGuiComponentName;

This item has no description.

Private FGuiComponent: TgxGuiComponent;

This item has no description.

Private FReBuildGui: Boolean;

This item has no description.

Private FRedrawAtOnce: Boolean;

This item has no description.

Private MoveX: Single;

This item has no description.

Private MoveY: Single;

This item has no description.

Private FRenderStatus: TGUIDrawResult;

This item has no description.

Private FAlphaChannel: Single;

This item has no description.

Private FRotation: Single;

This item has no description.

Private FNoZWrite: Boolean;

This item has no description.

Private BlockRendering: Boolean;

This item has no description.

Private RenderingCount: Integer;

This item has no description.

Private BlockedCount: Integer;

This item has no description.

Private GuiDestroying: Boolean;

This item has no description.

Private FDoChangesOnProgress: Boolean;

This item has no description.

Private FAutosize: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BlockRender;

This item has no description.

Public procedure DoChanges; virtual;

This item has no description.

Public procedure DoProgress(const progressTime: TgxProgressTimes); override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;

This item has no description.

Public procedure MoveGUI(XRel, YRel: Single);

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure PlaceGUI(XPos, YPos: Single);

This item has no description.

Public procedure UnBlockRender;

This item has no description.

Private procedure SetAutosize(const Value: Boolean);

This item has no description.

Private procedure SetDoChangesOnProgress(const Value: Boolean);

This item has no description.

Private procedure SetGUIRedraw(value: Boolean);

This item has no description.

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;

If different from 1, this value will replace that of Diffuse.Alpha

Published property Autosize: Boolean read FAutosize write SetAutosize;

This item has no description.

Published property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;

This item has no description.

Published property GuiLayout: TgxGuiLayout read FGuiLayout write SetGuiLayout;

This item has no description.

Published property GuiLayoutName: TgxGuiComponentName read FGuiLayoutName write SetGuiLayoutName;

This item has no description.

Public property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;

This item has no description.

Published property Height;

This item has no description. Showing description inherited from TgxBaseGuiObject.Height.

GuiComponent Height in 3D world units.

Published property Left;

This item has no description. Showing description inherited from TgxBaseGuiObject.Left.

GuiComponent Left in 3D world units.

Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If True, GuiComponent will not write to Z-Buffer. GuiComponent will STILL be maskable by ZBuffer test.

Published property Position;

This item has no description.

Public property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;

This item has no description.

Published property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;

This item has no description.

Published property Rotation: Single read FRotation write SetRotation;

This the ON-SCREEN rotation of the GuiComponent. Rotatation=0 is handled faster.

Published property Top;

This item has no description. Showing description inherited from TgxBaseGuiObject.Top.

GuiComponent Top in 3D world units.

Published property Visible;

This item has no description.

Published property Width;

This item has no description. Showing description inherited from TgxBaseGuiObject.Width.

GuiComponent Width in 3D world units.


GXSysHelp v.2.5: GXS.Windows: Class TgxBaseControl

Class TgxBaseControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxBaseControl = class(TgxBaseComponent)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl

Overview

Fields

Private | FOnMouseDown: TMouseEvent;
Private | FOnMouseMove: TMouseMoveEvent;
Private | FOnMouseUp: TMouseEvent;
Private | FKeepMouseEvents: Boolean;
Private | FActiveControl: TgxBaseControl;
Private | FFocusedControl: TgxFocusControl;
Private | FOnAcceptMouseQuery: TgxAcceptMouseQuery;
Private | FOnMouseLeave: TNotifyEvent;
Private | FOnMouseEnter: TNotifyEvent;
Private | FEnteredControl: TgxBaseControl;

Methods

Public | function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Public | procedure KeyPress(Sender: TObject; var Key: Char); virtual;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

Properties

Public | property ActiveControl: TgxBaseControl read FActiveControl write SetActiveControl;
Published | property FocusedControl: TgxFocusControl read FFocusedControl write SetFocusedControl;
Public | property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;
Published | property OnAcceptMouseQuery: TgxAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;
Published | property OnMouseDown: TMouseEvent read FOnMouseDown write FOnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property OnMouseUp: TMouseEvent read FOnMouseUp write FOnMouseUp;

Description

Fields

Private FOnMouseDown: TMouseEvent;

This item has no description.

Private FOnMouseMove: TMouseMoveEvent;

This item has no description.

Private FOnMouseUp: TMouseEvent;

This item has no description.

Private FKeepMouseEvents: Boolean;

This item has no description.

Private FActiveControl: TgxBaseControl;

This item has no description.

Private FFocusedControl: TgxFocusControl;

This item has no description.

Private FOnAcceptMouseQuery: TgxAcceptMouseQuery;

This item has no description.

Private FOnMouseLeave: TNotifyEvent;

This item has no description.

Private FOnMouseEnter: TNotifyEvent;

This item has no description.

Private FEnteredControl: TgxBaseControl;

This item has no description.

Methods

Public function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;

This item has no description.

Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

This item has no description.

Public procedure KeyPress(Sender: TObject; var Key: Char); virtual;

This item has no description.

Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;

This item has no description.

Properties

Public property ActiveControl: TgxBaseControl read FActiveControl write SetActiveControl;

This item has no description.

Published property FocusedControl: TgxFocusControl read FFocusedControl write SetFocusedControl;

This item has no description.

Public property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;

This item has no description.

Published property OnAcceptMouseQuery: TgxAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;

This item has no description.

Published property OnMouseDown: TMouseEvent read FOnMouseDown write FOnMouseDown;

This item has no description.

Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;

This item has no description.

Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;

This item has no description.

Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;

This item has no description.

Published property OnMouseUp: TMouseEvent read FOnMouseUp write FOnMouseUp;


GXSysHelp v.2.5: GXS.Windows: Class TgxBaseFontControl

Class TgxBaseFontControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxBaseFontControl = class(TgxBaseControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl

Overview

Fields

Private | FBitmapFont: TgxCustomBitmapFont;
Private | FDefaultColor: TgxColorVector;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property BitmapFont: TgxCustomBitmapFont read GetBitmapFont write SetBitmapFont;
Published | property DefaultColor: TColor read GetDefaultColor write SetDefaultColor;

Description

Fields

Private FBitmapFont: TgxCustomBitmapFont;

This item has no description.

Private FDefaultColor: TgxColorVector;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Properties

Published property BitmapFont: TgxCustomBitmapFont read GetBitmapFont write SetBitmapFont;

This item has no description.

Published property DefaultColor: TColor read GetDefaultColor write SetDefaultColor;


GXSysHelp v.2.5: GXS.Windows: Class TgxBaseTextControl

Class TgxBaseTextControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxBaseTextControl = class(TgxBaseFontControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl

Overview

Fields

Private FCaption: UnicodeString;

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;

Description

Fields

Private FCaption: UnicodeString;

This item has no description.

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;


GXSysHelp v.2.5: GXS.Windows: Class TgxFocusControl

Class TgxFocusControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxFocusControl = class(TgxBaseTextControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl

Overview

Fields

Private | FRootControl: TgxBaseControl;
Private | FFocused: Boolean;
Private | FOnKeyDown: TKeyEvent;
Private | FOnKeyUp: TKeyEvent;
Private | FOnKeyPress: TKeyEvent;
Private | FShiftState: TShiftState;
Private | FFocusedColor: TgxColorVector;

Methods

Public | destructor Destroy; override;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure KeyPress(Sender: TObject; var Key: Char); override;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure MoveTo(newParent: TgxBaseSceneObject); override;
Public | procedure NextControl;
Public | procedure NotifyHide; override;
Public | procedure PrevControl;
Public | procedure ReGetRootControl;
Public | procedure SetFocus;

Properties

Published | property Focused: Boolean read FFocused write SetFocused;
Published | property FocusedColor: TColor read GetFocusedColor write SetFocusedColor;
Published | property OnKeyDown: TKeyEvent read FOnKeyDown write FOnKeyDown;
Published | property OnKeyPress: TKeyEvent read FOnKeyPress write FOnKeyPress;
Published | property OnKeyUp: TKeyEvent read FOnKeyUp write FOnKeyUp;
Published | property RootControl: TgxBaseControl read GetRootControl;

Description

Fields

Private FRootControl: TgxBaseControl;

This item has no description.

Private FFocused: Boolean;

This item has no description.

Private FOnKeyDown: TKeyEvent;

This item has no description.

Private FOnKeyUp: TKeyEvent;

This item has no description.

Private FOnKeyPress: TKeyEvent;

This item has no description.

Private FShiftState: TShiftState;

This item has no description.

Private FFocusedColor: TgxColorVector;

This item has no description.

Methods

Public destructor Destroy; override;

This item has no description.

Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;

This item has no description.

Public procedure KeyPress(Sender: TObject; var Key: Char); override;

This item has no description.

Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;

This item has no description.

Public procedure MoveTo(newParent: TgxBaseSceneObject); override;

This item has no description.

Public procedure NextControl;

This item has no description.

Public procedure NotifyHide; override;

This item has no description.

Public procedure PrevControl;

This item has no description.

Public procedure ReGetRootControl;

This item has no description.

Public procedure SetFocus;

This item has no description.

Properties

Published property Focused: Boolean read FFocused write SetFocused;

This item has no description.

Published property FocusedColor: TColor read GetFocusedColor write SetFocusedColor;

This item has no description.

Published property OnKeyDown: TKeyEvent read FOnKeyDown write FOnKeyDown;

This item has no description.

Published property OnKeyPress: TKeyEvent read FOnKeyPress write FOnKeyPress;

This item has no description.

Published property OnKeyUp: TKeyEvent read FOnKeyUp write FOnKeyUp;

This item has no description.

Published property RootControl: TgxBaseControl read GetRootControl;


GXSysHelp v.2.5: GXS.Windows: Class TgxCustomControl

Class TgxCustomControl

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxCustomControl = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxCustomControl

Overview

Fields

Private | FCustomData: Pointer;
Private | FCustomObject: TObject;
Private | FOnRender: TgxCustomRenderEvent;
Private | FMaterial: TgxMaterial;
Private | FBitmap: TBitmap;
Private | FInternalBitmap: TBitmap;
Private | FBitmapChanged: Boolean;
Private | FXTexCoord: Single;
Private | FYTexCoord: Single;
Private | FInvalidRenderCount: Integer;
Private | FMaxInvalidRenderCount: Integer;
Private | FCentered: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetMaterial(AMaterial: TgxMaterial);
Private | procedure SetCentered(const Value: Boolean);

Properties

Published | property Bitmap: TBitmap read FBitmap write SetBitmap;
Published | property Centered: Boolean read FCentered write SetCentered;
Public | property CustomData: Pointer read FCustomData write FCustomData;
Public | property CustomObject: TObject read FCustomObject write FCustomObject;
Published | property Material: TgxMaterial read FMaterial write SetMaterial;
Published | property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;
Published | property OnRender: TgxCustomRenderEvent read FOnRender write FOnRender;

Description

Fields

Private FCustomData: Pointer;

This item has no description.

Private FCustomObject: TObject;

This item has no description.

Private FOnRender: TgxCustomRenderEvent;

This item has no description.

Private FMaterial: TgxMaterial;

This item has no description.

Private FBitmap: TBitmap;

This item has no description.

Private FInternalBitmap: TBitmap;

This item has no description.

Private FBitmapChanged: Boolean;

This item has no description.

Private FXTexCoord: Single;

This item has no description.

Private FYTexCoord: Single;

This item has no description.

Private FInvalidRenderCount: Integer;

This item has no description.

Private FMaxInvalidRenderCount: Integer;

This item has no description.

Private FCentered: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure SetMaterial(AMaterial: TgxMaterial);

This item has no description.

Private procedure SetCentered(const Value: Boolean);

This item has no description.

Properties

Published property Bitmap: TBitmap read FBitmap write SetBitmap;

This item has no description.

Published property Centered: Boolean read FCentered write SetCentered;

This item has no description.

Public property CustomData: Pointer read FCustomData write FCustomData;

This item has no description.

Public property CustomObject: TObject read FCustomObject write FCustomObject;

This item has no description.

Published property Material: TgxMaterial read FMaterial write SetMaterial;

This item has no description.

Published property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;

This item has no description.

Published property OnRender: TgxCustomRenderEvent read FOnRender write FOnRender;


GXSysHelp v.2.5: GXS.Windows: Class TgxPopupMenu

Class TgxPopupMenu

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxPopupMenu = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxPopupMenu

Overview

Fields

Private | FOnClick: TgxPopupMenuClick;
Private | FMenuItems: TStrings;
Private | FSelIndex: Integer;
Private | FMarginSize: Single;
Private | NewHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PopUp(Px, Py: Integer);

Properties

Published | property MarginSize: Single read FMarginSize write SetMarginSize;
Published | property MenuItems: TStrings read FMenuItems write SetMenuItems;
Published | property OnClick: TgxPopupMenuClick read FOnClick write FOnClick;
Published | property SelIndex: Integer read FSelIndex write SetSelIndex;

Description

Fields

Private FOnClick: TgxPopupMenuClick;

This item has no description.

Private FMenuItems: TStrings;

This item has no description.

Private FSelIndex: Integer;

This item has no description.

Private FMarginSize: Single;

This item has no description.

Private NewHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure PopUp(Px, Py: Integer);

This item has no description.

Properties

Published property MarginSize: Single read FMarginSize write SetMarginSize;

This item has no description.

Published property MenuItems: TStrings read FMenuItems write SetMenuItems;

This item has no description.

Published property OnClick: TgxPopupMenuClick read FOnClick write FOnClick;

This item has no description.

Published property SelIndex: Integer read FSelIndex write SetSelIndex;


GXSysHelp v.2.5: GXS.Windows: Class TgxForm

Class TgxForm

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxForm = class(TgxBaseTextControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxForm

Overview

Fields

Private | FOnCanMove: TgxFormCanRequest;
Private | FOnCanResize: TgxFormCanRequest;
Private | FOnCanClose: TgxFormCanClose;
Private | FOnShow: TgxFormNotify;
Private | FOnHide: TgxFormNotify;
Private | FOnMoving: TgxFormMove;
Private | Moving: Boolean;
Private | OldX: Integer;
Private | OldY: Integer;
Private | FTitleColor: TgxColorVector;
Private | FTitleOffset: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure Close;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyHide; override;
Public | procedure NotifyShow; override;

Properties

Published | property OnCanClose: TgxFormCanClose read FOnCanClose write FOnCanClose;
Published | property OnCanMove: TgxFormCanRequest read FOnCanMove write FOnCanMove;
Published | property OnCanResize: TgxFormCanRequest read FOnCanResize write FOnCanResize;
Published | property OnHide: TgxFormNotify read FOnHide write FOnHide;
Published | property OnMoving: TgxFormMove read FOnMoving write FOnMoving;
Published | property OnShow: TgxFormNotify read FOnShow write FOnShow;
Published | property TitleColor: TColor read GetTitleColor write SetTitleColor;
Published | property TitleOffset: Single read FTitleOffset write FTitleOffset;

Description

Fields

Private FOnCanMove: TgxFormCanRequest;

This item has no description.

Private FOnCanResize: TgxFormCanRequest;

This item has no description.

Private FOnCanClose: TgxFormCanClose;

This item has no description.

Private FOnShow: TgxFormNotify;

This item has no description.

Private FOnHide: TgxFormNotify;

This item has no description.

Private FOnMoving: TgxFormMove;

This item has no description.

Private Moving: Boolean;

This item has no description.

Private OldX: Integer;

This item has no description.

Private OldY: Integer;

This item has no description.

Private FTitleColor: TgxColorVector;

This item has no description.

Private FTitleOffset: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure Close;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure NotifyHide; override;

This item has no description.

Public procedure NotifyShow; override;

This item has no description.

Properties

Published property OnCanClose: TgxFormCanClose read FOnCanClose write FOnCanClose;

This item has no description.

Published property OnCanMove: TgxFormCanRequest read FOnCanMove write FOnCanMove;

This item has no description.

Published property OnCanResize: TgxFormCanRequest read FOnCanResize write FOnCanResize;

This item has no description.

Published property OnHide: TgxFormNotify read FOnHide write FOnHide;

This item has no description.

Published property OnMoving: TgxFormMove read FOnMoving write FOnMoving;

This item has no description.

Published property OnShow: TgxFormNotify read FOnShow write FOnShow;

This item has no description.

Published property TitleColor: TColor read GetTitleColor write SetTitleColor;

This item has no description.

Published property TitleOffset: Single read FTitleOffset write FTitleOffset;


GXSysHelp v.2.5: GXS.Windows: Class TgxPanel

Class TgxPanel

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxPanel = class(TgxBaseControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxPanel


GXSysHelp v.2.5: GXS.Windows: Class TgxCheckBox

Class TgxCheckBox

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxCheckBox = class(TgxBaseControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxCheckBox

Overview

Fields

Private | FChecked: Boolean;
Private | FOnChange: TNotifyEvent;
Private | FGuiLayoutNameChecked: TgxGuiComponentName;
Private | FGuiCheckedComponent: TgxGuiComponent;
Private | FGroup: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Checked: Boolean read FChecked write SetChecked;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNameChecked: TgxGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Private FChecked: Boolean;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private FGuiLayoutNameChecked: TgxGuiComponentName;

This item has no description.

Private FGuiCheckedComponent: TgxGuiComponent;

This item has no description.

Private FGroup: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Properties

Published property Checked: Boolean read FChecked write SetChecked;

This item has no description.

Published property Group: Integer read FGroup write SetGroup;

This item has no description.

Published property GuiLayoutNameChecked: TgxGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;


GXSysHelp v.2.5: GXS.Windows: Class TgxButton

Class TgxButton

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxButton = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxButton

Overview

Fields

Private | FPressed: Boolean;
Private | FOnButtonClick: TNotifyEvent;
Private | FGuiLayoutNamePressed: TgxGuiComponentName;
Private | FGuiPressedComponent: TgxGuiComponent;
Private | FBitBtn: TgxMaterial;
Private | FGroup: Integer;
Private | FLogicWidth: Single;
Private | FLogicHeight: Single;
Private | FXOffSet: Single;
Private | FYOffSet: Single;
Private | FAllowUp: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property AllowUp: Boolean read FAllowUp write FAllowUp;
Published | property BitBtn: TgxMaterial read FBitBtn write SetBitBtn;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNamePressed: TgxGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;
Published | property LogicHeight: Single read FLogicHeight write SetLogicHeight;
Published | property LogicWidth: Single read FLogicWidth write SetLogicWidth;
Published | property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;
Published | property Pressed: Boolean read FPressed write SetPressed;
Published | property XOffset: Single read FXOffset write SetXOffset;
Published | property YOffset: Single read FYOffset write SetYOffset;

Description

Fields

Private FPressed: Boolean;

This item has no description.

Private FOnButtonClick: TNotifyEvent;

This item has no description.

Private FGuiLayoutNamePressed: TgxGuiComponentName;

This item has no description.

Private FGuiPressedComponent: TgxGuiComponent;

This item has no description.

Private FBitBtn: TgxMaterial;

This item has no description.

Private FGroup: Integer;

This item has no description.

Private FLogicWidth: Single;

This item has no description.

Private FLogicHeight: Single;

This item has no description.

Private FXOffSet: Single;

This item has no description.

Private FYOffSet: Single;

This item has no description.

Private FAllowUp: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property AllowUp: Boolean read FAllowUp write FAllowUp;

This item has no description.

Published property BitBtn: TgxMaterial read FBitBtn write SetBitBtn;

This item has no description.

Published property Group: Integer read FGroup write SetGroup;

This item has no description.

Published property GuiLayoutNamePressed: TgxGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;

This item has no description.

Published property LogicHeight: Single read FLogicHeight write SetLogicHeight;

This item has no description.

Published property LogicWidth: Single read FLogicWidth write SetLogicWidth;

This item has no description.

Published property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;

This item has no description.

Published property Pressed: Boolean read FPressed write SetPressed;

This item has no description.

Published property XOffset: Single read FXOffset write SetXOffset;

This item has no description.

Published property YOffset: Single read FYOffset write SetYOffset;


GXSysHelp v.2.5: GXS.Windows: Class TgxEdit

Class TgxEdit

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxEdit = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxEdit

Overview

Fields

Private | FOnChange: TNotifyEvent;
Private | FSelStart: Integer;
Private | FReadOnly: Boolean;
Private | FEditChar: string;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property EditChar: string read FEditChar write SetEditChar;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property ReadOnly: Boolean read FReadOnly write FReadOnly default False;
Published | property SelStart: Integer read FSelStart write SetSelStart;

Description

Fields

Private FOnChange: TNotifyEvent;

This item has no description.

Private FSelStart: Integer;

This item has no description.

Private FReadOnly: Boolean;

This item has no description.

Private FEditChar: string;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Properties

Published property EditChar: string read FEditChar write SetEditChar;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property ReadOnly: Boolean read FReadOnly write FReadOnly default False;

This item has no description.

Published property SelStart: Integer read FSelStart write SetSelStart;


GXSysHelp v.2.5: GXS.Windows: Class TgxLabel

Class TgxLabel

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxLabel = class(TgxBaseTextControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxLabel

Overview

Fields

Private | FAlignment: TAlignment;
Private | FTextLayout: TgxTextLayout;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Private | procedure SetAlignment(const Value: TAlignment);
Private | procedure SetTextLayout(const Value: TgxTextLayout);

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property TextLayout: TgxTextLayout read FTextLayout write SetTextLayout;

Description

Fields

Private FAlignment: TAlignment;

This item has no description.

Private FTextLayout: TgxTextLayout;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Private procedure SetAlignment(const Value: TAlignment);

This item has no description.

Private procedure SetTextLayout(const Value: TgxTextLayout);

This item has no description.

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;

This item has no description.

Published property TextLayout: TgxTextLayout read FTextLayout write SetTextLayout;


GXSysHelp v.2.5: GXS.Windows: Class TgxAdvancedLabel

Class TgxAdvancedLabel

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxAdvancedLabel = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxAdvancedLabel

Overview

Methods

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;


GXSysHelp v.2.5: GXS.Windows: Class TgxScrollbar

Class TgxScrollbar

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type TgxScrollbar = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • TgxScrollbar

Overview

Fields

Private | FMin: Single;
Private | FMax: Single;
Private | FStep: Single;
Private | FPos: Single;
Private | FPageSize: Single;
Private | FOnChange: TNotifyEvent;
Private | FGuiLayoutKnobName: TgxGuiComponentName;
Private | FGuiKnobComponent: TgxGuiComponent;
Private | FKnobRenderStatus: TGUIDrawResult;
Private | FScrollOffs: Single;
Private | FScrolling: Boolean;
Private | FHorizontal: Boolean;
Private | FLocked: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PageDown;
Public | procedure PageUp;
Public | procedure StepDown;
Public | procedure StepUp;

Properties

Published | property GuiLayoutKnobName: TgxGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;
Published | property Horizontal: Boolean read FHorizontal write SetHorizontal;
Published | property Locked: Boolean read FLocked write FLocked default False;
Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property PageSize: Single read FPageSize write SetPageSize;
Published | property Pos: Single read FPos write SetPos;
Published | property Step: Single read FStep write FStep;

Description

Fields

Private FMin: Single;

This item has no description.

Private FMax: Single;

This item has no description.

Private FStep: Single;

This item has no description.

Private FPos: Single;

This item has no description.

Private FPageSize: Single;

This item has no description.

Private FOnChange: TNotifyEvent;

This item has no description.

Private FGuiLayoutKnobName: TgxGuiComponentName;

This item has no description.

Private FGuiKnobComponent: TgxGuiComponent;

This item has no description.

Private FKnobRenderStatus: TGUIDrawResult;

This item has no description.

Private FScrollOffs: Single;

This item has no description.

Private FScrolling: Boolean;

This item has no description.

Private FHorizontal: Boolean;

This item has no description.

Private FLocked: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public function MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure PageDown;

This item has no description.

Public procedure PageUp;

This item has no description.

Public procedure StepDown;

This item has no description.

Public procedure StepUp;

This item has no description.

Properties

Published property GuiLayoutKnobName: TgxGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;

This item has no description.

Published property Horizontal: Boolean read FHorizontal write SetHorizontal;

This item has no description.

Published property Locked: Boolean read FLocked write FLocked default False;

This item has no description.

Published property Max: Single read FMax write SetMax;

This item has no description.

Published property Min: Single read FMin write SetMin;

This item has no description.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange;

This item has no description.

Published property PageSize: Single read FPageSize write SetPageSize;

This item has no description.

Published property Pos: Single read FPos write SetPos;

This item has no description.

Published property Step: Single read FStep write FStep;


GXSysHelp v.2.5: GXS.Windows: Class StringGrid

Class StringGrid

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.Windows

Declaration

type StringGrid = class(TgxFocusControl)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxBaseGuiObject
  • TgxBaseComponent
  • TgxBaseControl
  • TgxBaseFontControl
  • TgxBaseTextControl
  • TgxFocusControl
  • StringGrid

Overview

Fields

Private | FSelCol: Integer;
Private | FSelRow: Integer;
Private | FRowSelect: Boolean;
Private | FColSelect: Boolean;
Private | FColumns: TStrings;
Private | FRows: TList;
Private | FHeaderColor: TgxColorVector;
Private | FMarginSize: Integer;
Private | FColumnSize: Integer;
Private | FRowHeight: Integer;
Private | FScrollbar: TgxScrollbar;
Private | FDrawHeader: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Add(const Data: string): Integer; overload;
Public | function Add(Data: array of string): Integer; overload;
Public | procedure Clear;
Public | procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure OnStringListChange(Sender: TObject);
Public | procedure SetText(Data: string);

Properties

Published | property ColSelect: Boolean read FColSelect write SetColSelect;
Published | property Columns: TStrings read FColumns write SetColumns;
Published | property ColumnSize: Integer read FColumnSize write SetColumnSize;
Published | property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;
Published | property HeaderColor: TColor read GetHeaderColor write SetHeaderColor;
Published | property MarginSize: Integer read FMarginSize write SetMarginSize;
Public | property Row[index: Integer]: TStringList read GetRow write SetRow;
Published | property RowCount: Integer read GetRowCount write SetRowCount;
Published | property RowHeight: Integer read FRowHeight write SetRowHeight;
Published | property RowSelect: Boolean read FRowSelect write SetRowSelect;
Published | property Scrollbar: TgxScrollbar read FScrollbar write SetScrollbar;
Published | property SelCol: Integer read FSelCol write SetSelCol;
Published | property SelRow: Integer read FSelRow write SetSelRow;

Description

Fields

Private FSelCol: Integer;

This item has no description.

Private FSelRow: Integer;

This item has no description.

Private FRowSelect: Boolean;

This item has no description.

Private FColSelect: Boolean;

This item has no description.

Private FColumns: TStrings;

This item has no description.

Private FRows: TList;

This item has no description.

Private FHeaderColor: TgxColorVector;

This item has no description.

Private FMarginSize: Integer;

This item has no description.

Private FColumnSize: Integer;

This item has no description.

Private FRowHeight: Integer;

This item has no description.

Private FScrollbar: TgxScrollbar;

This item has no description.

Private FDrawHeader: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Add(const Data: string): Integer; overload;

This item has no description.

Public function Add(Data: array of string): Integer; overload;

This item has no description.

Public procedure Clear;

This item has no description.

Public procedure InternalRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Public procedure OnStringListChange(Sender: TObject);

This item has no description.

Public procedure SetText(Data: string);

This item has no description.

Properties

Published property ColSelect: Boolean read FColSelect write SetColSelect;

This item has no description.

Published property Columns: TStrings read FColumns write SetColumns;

in VCL TDelphiColor;

Published property ColumnSize: Integer read FColumnSize write SetColumnSize;

This item has no description.

Published property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;

This item has no description.

Published property HeaderColor: TColor read GetHeaderColor write SetHeaderColor;

This item has no description.

Published property MarginSize: Integer read FMarginSize write SetMarginSize;

This item has no description.

Public property Row[index: Integer]: TStringList read GetRow write SetRow;

This item has no description.

Published property RowCount: Integer read GetRowCount write SetRowCount;

This item has no description.

Published property RowHeight: Integer read FRowHeight write SetRowHeight;

This item has no description.

Published property RowSelect: Boolean read FRowSelect write SetRowSelect;

This item has no description.

Published property Scrollbar: TgxScrollbar read FScrollbar write SetScrollbar;

This item has no description.

Published property SelCol: Integer read FSelCol write SetSelCol;

This item has no description.

Published property SelRow: Integer read FSelRow write SetSelRow;


GXSysHelp v.2.5: GXS.WindowsFont

Unit GXS.WindowsFont

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • System.Classes
  • System.Math
  • System.SysUtils
  • System.Types
  • System.UITypes
  • FMX.Graphics
  • GXS.Scene
  • GXS.Texture
  • GXS.BitmapFont
  • GXS.RenderContextInfo
  • GXS.VectorLists
  • GLScene.Utils
  • GLScene.VectorGeometry
  • GXS.ApplicationFileIO
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxWindowsBitmapFont |


GXSysHelp v.2.5: GXS.WindowsFont: Class TgxWindowsBitmapFont

Class TgxWindowsBitmapFont

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.WindowsFont

Declaration

type TgxWindowsBitmapFont = class(TgxCustomBitmapFont)

Description

A bitmap font automatically built from a TFont. It works like a TgxBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders as close to that font as possible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxCustomBitmapFont
  • TgxWindowsBitmapFont

Overview

Fields

Private FFont: TFont;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FontTextureHeight: Integer;
Public | function FontTextureWidth: Integer;
Public | procedure EnsureChars(const AStart, AEnd: widechar);
Public | procedure EnsureString(const s : String); overload;
Public | procedure NotifyChange(Sender: TObject); override;
Private | procedure SetList(const AList : TgxIntegerList);

Properties

Published | property Font: TFont read FFont write SetFont;
Public | property Glyphs;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges stored StoreRanges;
Published | property VSpace;

Description

Fields

Private FFont: TFont;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function FontTextureHeight: Integer;

This item has no description.

Public function FontTextureWidth: Integer;

This item has no description.

Public procedure EnsureChars(const AStart, AEnd: widechar);

This item has no description.

Public procedure EnsureString(const s : String); overload;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description.

Private procedure SetList(const AList : TgxIntegerList);

This item has no description.

Properties

Published property Font: TFont read FFont write SetFont;

The font used to prepare the texture. Note: the font color is ignored.

Public property Glyphs;

This item has no description.

Published property HSpace;

This item has no description.

Published property MagFilter;

This item has no description.

Published property MinFilter;

This item has no description.

Published property Ranges stored StoreRanges;

This item has no description.

Published property VSpace;


GXSysHelp v.2.5: GXS.XOpenGL

Unit GXS.XOpenGL

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext

Overview

Functions and Procedures

procedure xglMapTexCoordToNull;
procedure xglMapTexCoordToMain;
procedure xglMapTexCoordToSecond;
procedure xglMapTexCoordToDual;
procedure xglMapTexCoordToArbitrary(const units: array of Cardinal); overload;
procedure xglMapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;
procedure xglMapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);
procedure xglBeginUpdate;
procedure xglEndUpdate;
procedure xglPushState;
procedure xglPopState;
procedure xglForbidSecondTextureUnit;
procedure xglAllowSecondTextureUnit;
function xglGetBitWiseMapping: Cardinal;

Types

TMapTexCoordMode = (...);

Variables

xglMapTexCoordMode: TMapTexCoordMode;
vSecondTextureUnitForbidden: Boolean;
xglTexCoord2f: procedure(s, t: Single); stdcall;
xglTexCoord2fv: procedure(v: PGLfloat); stdcall;
xglTexCoord3f: procedure(s, t, r: Single); stdcall;
xglTexCoord3fv: procedure(v: PGLfloat); stdcall;
xglTexCoord4f: procedure(s, t, r, q: Single); stdcall;
xglTexCoord4fv: procedure(v: PGLfloat); stdcall;
xglTexGenf: procedure(coord, pname: Cardinal; param: Single); stdcall;
xglTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;
xglTexGeni: procedure(coord, pname: Cardinal; param: GLint); stdcall;
xglTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;
xglTexCoordPointer: procedure(size: GLint; atype: GLEnum; stride: GLsizei; data: pointer); stdcall;
xglEnableClientState: procedure(aarray: Cardinal); stdcall;
xglDisableClientState: procedure(aarray: Cardinal); stdcall;
xglEnable: procedure(cap: Cardinal); stdcall;
xglDisable: procedure(cap: Cardinal); stdcall;

Description

Functions and Procedures

procedure xglMapTexCoordToNull;

TexCoord functions will be ignored.

procedure xglMapTexCoordToMain;

TexCoord functions will define the main texture coordinates.

procedure xglMapTexCoordToSecond;

TexCoord functions will define the second texture unit coordinates.

procedure xglMapTexCoordToDual;

TexCoord functions will define the two first texture units coordinates.

procedure xglMapTexCoordToArbitrary(const units: array of Cardinal); overload;

TexCoord functions will define the specified texture units coordinates.

procedure xglMapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;

This item has no description.

procedure xglMapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);

This item has no description.

procedure xglBeginUpdate;

Defers xglMap calls execution until xglEndUpdate is met. Calls to Begin/EndUpdate may be nested.

procedure xglEndUpdate;

Applies xglMap calls if there were any since xglBeginUpdate was invoked. Calls to Begin/EndUpdate may be nested.

procedure xglPushState;

Saves State on the stack.

procedure xglPopState;

Restores State from the stack.

procedure xglForbidSecondTextureUnit;

Whenever called, 2nd texture units changes will be forbidden to . Use this function when you're using the 2nd texture unit for your own purposes and don't want to alter it.

procedure xglAllowSecondTextureUnit;

Allow to use the second texture unit again.

function xglGetBitWiseMapping: Cardinal;

Returns the complex mapping in bitwise form.

Types

TMapTexCoordMode = (...);

This item has no description.

Values
  • mtcmUndefined
  • mtcmNull
  • mtcmMain
  • mtcmDual
  • mtcmSecond
  • mtcmArbitrary

Variables

xglMapTexCoordMode: TMapTexCoordMode;

This item has no description.

vSecondTextureUnitForbidden: Boolean;

This item has no description.

xglTexCoord2f: procedure(s, t: Single); stdcall;

Explicit texture coordinates specification

xglTexCoord2fv: procedure(v: PGLfloat); stdcall;

This item has no description.

xglTexCoord3f: procedure(s, t, r: Single); stdcall;

This item has no description.

xglTexCoord3fv: procedure(v: PGLfloat); stdcall;

This item has no description.

xglTexCoord4f: procedure(s, t, r, q: Single); stdcall;

This item has no description.

xglTexCoord4fv: procedure(v: PGLfloat); stdcall;

This item has no description.

xglTexGenf: procedure(coord, pname: Cardinal; param: Single); stdcall;

TexGen texture coordinates specification

xglTexGenfv: procedure(coord, pname: Cardinal; params: PGLfloat); stdcall;

This item has no description.

xglTexGeni: procedure(coord, pname: Cardinal; param: GLint); stdcall;

This item has no description.

xglTexGeniv: procedure(coord, pname: Cardinal; params: PGLint); stdcall;

This item has no description.

xglTexCoordPointer: procedure(size: GLint; atype: GLEnum; stride: GLsizei; data: pointer); stdcall;

Vertex Arrays texture coordinates specification

xglEnableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

xglDisableClientState: procedure(aarray: Cardinal); stdcall;

This item has no description.

xglEnable: procedure(cap: Cardinal); stdcall;

Misc

xglDisable: procedure(cap: Cardinal); stdcall;


GXSysHelp v.2.5: GXS.zBuffer

Unit GXS.zBuffer

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.Math
  • GLScene.OpenGL4
  • GLScene.VectorTypes
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Coordinates
  • GXS.Color
  • GXS.Scene
  • GXS.XOpenGL
  • GXS.Graphics
  • GXS.Objects
  • GXS.Context
  • GXS.SceneViewer
  • GXS.RenderContextInfo
  • GXS.State
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EZBufferException |
Class TgxZBuffer |
Class TgxZShadows |

Types

PAArray = ˆTAArray;
PZArray = ˆTZArray;
TAArray = array[0..MaxInt shr 3] of Byte;
TAArrayIdx = array of PAArray;
TOptimise = (...);
TZArray = array[0..MaxInt shr 3] of Single;
TZArrayIdx = array of PZArray;

Description

Types

PAArray = ˆTAArray;

This item has no description.

PZArray = ˆTZArray;

This item has no description.

TAArray = array[0..MaxInt shr 3] of Byte;

This item has no description.

TAArrayIdx = array of PAArray;

This item has no description.

TOptimise = (...);

This item has no description.

Values
  • opNone
  • op4in1
  • op9in1
  • op16in1
TZArray = array[0..MaxInt shr 3] of Single;

This item has no description.

TZArrayIdx = array of PZArray;


GXSysHelp v.2.5: GXS.zBuffer: Class EZBufferException

Class EZBufferException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.zBuffer

Declaration

type EZBufferException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EZBufferException


GXSysHelp v.2.5: GXS.zBuffer: Class TgxZBuffer

Class TgxZBuffer

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.zBuffer

Declaration

type TgxZBuffer = class(TPersistent)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TgxZBuffer

Overview

Fields

Private | FData: PZArray;
Private | FDataIdx: TZArrayIdx;
Private | FDataInvIdx: TZArrayIdx;
Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FDataSize: Integer;
Private | ang1: single;
Private | ang2: single;
Private | scal: single;
Private | c1: single;
Private | s1: single;
Private | c2: single;
Private | s2: single;
Private | vw: single;
Private | vh: single;
Private | lt: TAffineVector;
Private | rt: TAffineVector;
Private | lb: TAffineVector;
Private | rb: TAffineVector;
Private | UpVec: TAffineVector;
Private | riVec: TAffineVector;
Private | ltW: TAffineVector;
Private | rtW: TAffineVector;
Private | lbW: TAffineVector;
Private | rbW: TAffineVector;
Private | UpVecW: TAffineVector;
Private | riVecW: TAffineVector;
Private | OrthInvDov: single;
Private | OrthAddX: single;
Private | OrthMulX: single;
Private | OrthAddY: single;
Private | OrthMulY: single;
Private | dov: single;
Private | np: single;
Private | fp: single;
Private | NpFp: single;
Private | OneMinNp_Fp: single;
Private | invOneMinNp_Fp: single;
Private | cam: TgxCamera;
Public | SceneViewer: TgxSceneViewer;
Public | MemoryViewer: TgxMemoryViewer;
Public | Buffer: TgxSceneBuffer;
Public | Normal: TAffineVector;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FastScreenToVector(x, y: Integer): TAffineVector;
Public | function FastVectorToScreen(vec: TAffineVector): TAffineVector;
Public | function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;
Public | function GetPixelzDepth(x, y: integer): Single;
Public | function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;
Public | function PixelToDistance(x, y: integer): Single;
Public | function PixelToDistance_OLD(x, y: integer): Single;
Public | function PixelToWorld(const x, y: Integer): TAffineVector;
Public | function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;
Public | procedure LinkToViewer(viewer: TgxMemoryViewer); overload;
Public | procedure LinkToViewer(viewer: TgxSceneViewer); overload;
Public | procedure Refresh;
Private | procedure DoCalcVectors;

Properties

Public | property Data: PZArray read FData;
Public | property DataIdx: TZArrayIdx read FDataIdx;
Public | property DataInvIdx: TZArrayIdx read FDataIdx;
Public | property DataSize: Integer read FDataSize;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Private FData: PZArray;

This item has no description.

Private FDataIdx: TZArrayIdx;

This item has no description.

Private FDataInvIdx: TZArrayIdx;

This item has no description.

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private ang1: single;

This item has no description.

Private ang2: single;

This item has no description.

Private scal: single;

This item has no description.

Private c1: single;

This item has no description.

Private s1: single;

This item has no description.

Private c2: single;

This item has no description.

Private s2: single;

This item has no description.

Private vw: single;

This item has no description.

Private vh: single;

This item has no description.

Private lt: TAffineVector;

VectorToScreen variables;

Private rt: TAffineVector;

VectorToScreen variables;

Private lb: TAffineVector;

VectorToScreen variables;

Private rb: TAffineVector;

VectorToScreen variables;

Private UpVec: TAffineVector;

ScreenToVector corner vectors;

Private riVec: TAffineVector;

ScreenToVector corner vectors;

Private ltW: TAffineVector;

This item has no description.

Private rtW: TAffineVector;

This item has no description.

Private lbW: TAffineVector;

This item has no description.

Private rbW: TAffineVector;

This item has no description.

Private UpVecW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private riVecW: TAffineVector;

ScreenToVector corner vectors;(Warped)

Private OrthInvDov: single;

This item has no description.

Private OrthAddX: single;

This item has no description.

Private OrthMulX: single;

This item has no description.

Private OrthAddY: single;

This item has no description.

Private OrthMulY: single;

This item has no description.

Private dov: single;

This item has no description.

Private np: single;

This item has no description.

Private fp: single;

This item has no description.

Private NpFp: single;

This item has no description.

Private OneMinNp_Fp: single;

This item has no description.

Private invOneMinNp_Fp: single;

This item has no description.

Private cam: TgxCamera;

Calc Variables;

Public SceneViewer: TgxSceneViewer;

This item has no description.

Public MemoryViewer: TgxMemoryViewer;

This item has no description.

Public Buffer: TgxSceneBuffer;

This item has no description.

Public Normal: TAffineVector;

This item has no description.

Methods

Public constructor Create;

Absolute direction of camera

Public destructor Destroy; override;

This item has no description.

Public function FastScreenToVector(x, y: Integer): TAffineVector;

This item has no description.

Public function FastVectorToScreen(vec: TAffineVector): TAffineVector;

This item has no description.

Public function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;

This item has no description.

Public function GetPixelzDepth(x, y: integer): Single;

This item has no description.

Public function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;

This item has no description.

Public function PixelToDistance(x, y: integer): Single;

This item has no description.

Public function PixelToDistance_OLD(x, y: integer): Single;

This item has no description.

Public function PixelToWorld(const x, y: Integer): TAffineVector;

This item has no description.

Public function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;

This item has no description.

Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;

This item has no description.

Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;

This item has no description.

Public procedure LinkToViewer(viewer: TgxMemoryViewer); overload;

This item has no description.

Public procedure LinkToViewer(viewer: TgxSceneViewer); overload;

This item has no description.

Public procedure Refresh;

This item has no description.

Private procedure DoCalcVectors;

This item has no description.

Properties

Public property Data: PZArray read FData;

This item has no description.

Public property DataIdx: TZArrayIdx read FDataIdx;

This item has no description.

Public property DataInvIdx: TZArrayIdx read FDataIdx;

This item has no description.

Public property DataSize: Integer read FDataSize;

This item has no description.

Public property Height: Integer read FHeight write SetHeight;

This item has no description.

Public property Width: Integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXS.zBuffer: Class TgxZShadows

Class TgxZShadows

Description
Hierarchy
Fields
Methods
Properties

Unit

GXS.zBuffer

Declaration

type TgxZShadows = class(TgxBaseSceneObject)

Description

This item has no description. Showing description inherited from TgxBaseSceneObject.

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxZShadows

Overview

Fields

Private | FViewer: TgxSceneViewer;
Private | FCaster: TgxMemoryViewer;
Private | FDepthFade: Boolean;
Private | FFrustShadow: Boolean;
Private | FSkyShadow: Boolean;
Private | FOptimise: TOptimise;
Private | FData: PAArray;
Private | FDataIdx: TAArrayIdx;
Private | FDataInvIdx: TAArrayIdx;
Private | FDataSize: Integer;
Private | FWidth: integer;
Private | FHeight: integer;
Private | FXRes: integer;
Private | FYRes: integer;
Private | Fsoft: boolean;
Private | FTolerance: single;
Private | FColor: TgxColor;
Private | SCol: TgxPixel32;
Private | FTexturePrepared: Boolean;
Private | FTexHandle: TgxTextureHandle;
Public | ViewerZBuf: TgxZBuffer;
Public | CasterZBuf: TgxZBuffer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Published | function CastShadow: boolean;
Public | procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Caster: TgxMemoryViewer read GetCaster write SetCaster;
Published | property Color: TgxColor read FColor write FColor;
Published | property DepthFade: Boolean read FDepthFade write FDepthFade;
Published | property FrustShadow: Boolean read FFrustShadow write FFrustShadow;
Published | property Height: integer read FHeight write SetHeight;
Published | property ObjectsSorting;
Published | property Optimise: TOptimise read FOptimise write FOptimise;
Published | property SkyShadow: Boolean read FSkyShadow write FSkyShadow;
Published | property Soft: Boolean read Fsoft write SetSoft;
Published | property Tolerance: single read FTolerance write FTolerance;
Published | property Viewer: TgxSceneViewer read GetViewer write SetViewer;
Published | property Visible;
Published | property Width: integer read FWidth write SetWidth;

Description

Fields

Private FViewer: TgxSceneViewer;

This item has no description.

Private FCaster: TgxMemoryViewer;

This item has no description.

Private FDepthFade: Boolean;

This item has no description.

Private FFrustShadow: Boolean;

This item has no description.

Private FSkyShadow: Boolean;

This item has no description.

Private FOptimise: TOptimise;

This item has no description.

Private FData: PAArray;

This item has no description.

Private FDataIdx: TAArrayIdx;

This item has no description.

Private FDataInvIdx: TAArrayIdx;

This item has no description.

Private FDataSize: Integer;

This item has no description.

Private FWidth: integer;

This item has no description.

Private FHeight: integer;

This item has no description.

Private FXRes: integer;

This item has no description.

Private FYRes: integer;

This item has no description.

Private Fsoft: boolean;

This item has no description.

Private FTolerance: single;

This item has no description.

Private FColor: TgxColor;

This item has no description.

Private SCol: TgxPixel32;

This item has no description.

Private FTexturePrepared: Boolean;

stepX, stepY :single;

Private FTexHandle: TgxTextureHandle;

This item has no description.

Public ViewerZBuf: TgxZBuffer;

This item has no description.

Public CasterZBuf: TgxZBuffer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Published function CastShadow: boolean;

This item has no description.

Public procedure DoRender(var ARci: TgxRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

This item has no description.

Properties

Published property Caster: TgxMemoryViewer read GetCaster write SetCaster;

This item has no description.

Published property Color: TgxColor read FColor write FColor;

This item has no description.

Published property DepthFade: Boolean read FDepthFade write FDepthFade;

This item has no description.

Published property FrustShadow: Boolean read FFrustShadow write FFrustShadow;

This item has no description.

Published property Height: integer read FHeight write SetHeight;

This item has no description.

Published property ObjectsSorting;

property Material;

Published property Optimise: TOptimise read FOptimise write FOptimise;

This item has no description.

Published property SkyShadow: Boolean read FSkyShadow write FSkyShadow;

This item has no description.

Published property Soft: Boolean read Fsoft write SetSoft;

property Xres :integer read FXRes write SetXRes;// default 64; property Yres :integer read FYRes write SetYRes;// default 64;

Published property Tolerance: single read FTolerance write FTolerance;

This item has no description.

Published property Viewer: TgxSceneViewer read GetViewer write SetViewer;

This item has no description.

Published property Visible;

This item has no description.

Published property Width: integer read FWidth write SetWidth;


GXSysHelp v.2.5: GXSL.AsmShader

Unit GXSL.AsmShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GXS.Context
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.Texture
  • GXSL.CustomShader
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxAsmShaderParameter |
Class TgxCustomAsmShader |
Class TgxAsmShader |

Types

TgxAsmShaderEvent = procedure(Shader: TgxCustomAsmShader) of object;
TgxAsmShaderUnUplyEvent = procedure(Shader: TgxCustomAsmShader; var ThereAreMorePasses: Boolean) of object;

Description

Types

TgxAsmShaderEvent = procedure(Shader: TgxCustomAsmShader) of object;

This item has no description.

TgxAsmShaderUnUplyEvent = procedure(Shader: TgxCustomAsmShader; var ThereAreMorePasses: Boolean) of object;


GXSysHelp v.2.5: GXSL.AsmShader: Class TgxAsmShaderParameter

Class TgxAsmShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.AsmShader

Declaration

type TgxAsmShaderParameter = class(TgxCustomShaderParameter)

Description

This item has no description. Showing description inherited from TgxCustomShaderParameter.

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TgxCustomShaderParameter
  • TgxAsmShaderParameter


GXSysHelp v.2.5: GXSL.AsmShader: Class TgxCustomAsmShader

Class TgxCustomAsmShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.AsmShader

Declaration

type TgxCustomAsmShader = class(TgxCustomShader)

Description

This item has no description. Showing description inherited from TgxCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TgxCustomAsmShader

Overview

Fields

Private | FVPHandle: TgxVertexProgramHandle;
Private | FFPHandle: TgxFragmentProgramHandle;
Private | FGPHandle: TgxGeometryProgramHandle;
Private | FOnInitialize: TgxAsmShaderEvent;
Private | FOnApply: TgxAsmShaderEvent;
Private | FOnUnApply: TgxAsmShaderUnUplyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;

Description

Fields

Private FVPHandle: TgxVertexProgramHandle;

This item has no description.

Private FFPHandle: TgxFragmentProgramHandle;

This item has no description.

Private FGPHandle: TgxGeometryProgramHandle;

This item has no description.

Private FOnInitialize: TgxAsmShaderEvent;

This item has no description.

Private FOnApply: TgxAsmShaderEvent;

This item has no description.

Private FOnUnApply: TgxAsmShaderUnUplyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TgxShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure Assign(Source: TPersistent); override;


GXSysHelp v.2.5: GXSL.AsmShader: Class TgxAsmShader

Class TgxAsmShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.AsmShader

Declaration

type TgxAsmShader = class(TgxCustomAsmShader)

Description

This item has no description. Showing description inherited from TgxCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TgxCustomAsmShader
  • TgxAsmShader

Overview

Properties

Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnInitialize;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property FailedInitAction;

This item has no description. Showing description inherited from TgxShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property GeometryProgram;

This item has no description.

Published property OnApply;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TgxShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property VertexProgram;


GXSysHelp v.2.5: GXSL.BumpShaders

Unit GXSL.BumpShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.Context
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.VectorLists
  • GXS.Texture
  • GXS.Scene
  • GXS.Cadencer
  • GLScene.Strings
  • GXS.Color
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.Graphics
  • GXS.State
  • GXSL.CustomShader
  • GXSL.Shader
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EgxslBumpShaderException |
Class TgxslBaseCustomBumpShader |
Class TgxslBaseCustomBumpShaderMT |
Class TgxslCustomBumpShaderAM |
Class TgxslCustomBumpShaderMT |
Class TgxslCustomBumpShader |
Class TgxslCustomMLBumpShader |
Class TgxslCustomMLBumpShaderMT |
Class TgxslBumpShaderMT |
Class TgxslBumpShader |
Class TgxslBumpShaderAM |
Class TgxslMLBumpShader |
Class TgxslMLBumpShaderMT |
Class TgxBumpShader |

Types

TBumpMethod = (...);
TBumpOption = (...);
TBumpOptions = set of TBumpOption;
TBumpSpace = (...);
TSpecularMode = (...);

Description

Types

TBumpMethod = (...);

This item has no description.

Values
  • bmDot3TexCombiner
  • bmBasicARBFP
TBumpOption = (...);

This item has no description.

Values
  • boDiffuseTexture2
  • boSpecularTexture3: Use secondary texture as diffuse
  • boUseSecondaryTexCoords: Use tertiary texture as specular
  • boLightAttenuation: Pass through secondary texcoords
  • boParallaxMapping: Use light attenuation
TBumpOptions = set of TBumpOption;

Enable parallax offset mapping

TBumpSpace = (...);

This item has no description.

Values
  • bsObject
  • bsTangentExternal
  • bsTangentQuaternion
TSpecularMode = (...);

This item has no description.

Values
  • smOff
  • smBlinn
  • smPhong


GXSysHelp v.2.5: GXSL.BumpShaders: Class EgxslBumpShaderException

Class EgxslBumpShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type EgxslBumpShaderException = class(EgxslShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECustomShaderException
  • EGXSLShaderException
  • EgxslBumpShaderException


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslBaseCustomBumpShader

Class TgxslBaseCustomBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslBaseCustomBumpShader = class(TgxslCustomShader, IgxMaterialLibrarySupported)

Description

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader

Overview

Fields

Private | FBumpHeight: Single;
Private | FBumpSmoothness: Integer;
Private | FSpecularPower: Single;
Private | FSpecularSpread: Single;
Private | FLightPower: Single;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FNormalTexture: TgxTexture;
Private | FSpecularTexture: TgxTexture;
Private | FNormalTextureName: TgxLibMaterialName;
Private | FSpecularTextureName: TgxLibMaterialName;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetNormalTextureName: TgxLibMaterialName;
Private | function GetSpecularTextureName: TgxLibMaterialName;
Private | procedure SetNormalTexture(const Value: TgxTexture);
Private | procedure SetNormalTextureName(const Value: TgxLibMaterialName);
Private | procedure SetSpecularTexture(const Value: TgxTexture);
Private | procedure SetSpecularTextureName(const Value: TgxLibMaterialName);

Properties

Public | property BumpHeight: Single read FBumpHeight write FBumpHeight;
Public | property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property NormalTexture: TgxTexture read FNormalTexture write SetNormalTexture;
Public | property NormalTextureName: TgxLibMaterialName read GetNormalTextureName write SetNormalTextureName;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;
Public | property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;
Public | property SpecularTexture: TgxTexture read FSpecularTexture write SetSpecularTexture;
Public | property SpecularTextureName: TgxLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;

Description

Fields

Private FBumpHeight: Single;

This item has no description.

Private FBumpSmoothness: Integer;

This item has no description.

Private FSpecularPower: Single;

This item has no description.

Private FSpecularSpread: Single;

This item has no description.

Private FLightPower: Single;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FNormalTexture: TgxTexture;

This item has no description.

Private FSpecularTexture: TgxTexture;

This item has no description.

Private FNormalTextureName: TgxLibMaterialName;

This item has no description.

Private FSpecularTextureName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private function GetNormalTextureName: TgxLibMaterialName;

This item has no description.

Private function GetSpecularTextureName: TgxLibMaterialName;

This item has no description.

Private procedure SetNormalTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetNormalTextureName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetSpecularTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetSpecularTextureName(const Value: TgxLibMaterialName);

This item has no description.

Properties

Public property BumpHeight: Single read FBumpHeight write FBumpHeight;

This item has no description.

Public property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;

This item has no description.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NormalTexture: TgxTexture read FNormalTexture write SetNormalTexture;

This item has no description.

Public property NormalTextureName: TgxLibMaterialName read GetNormalTextureName write SetNormalTextureName;

This item has no description.

Public property SpecularPower: Single read FSpecularPower write FSpecularPower;

This item has no description.

Public property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;

This item has no description.

Public property SpecularTexture: TgxTexture read FSpecularTexture write SetSpecularTexture;

This item has no description.

Public property SpecularTextureName: TgxLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslBaseCustomBumpShaderMT

Class TgxslBaseCustomBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslBaseCustomBumpShaderMT = class(TgxslBaseCustomBumpShader)

Description

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT

Overview

Fields

Private | FMainTexture: TgxTexture;
Private | FMainTextureName: TgxLibMaterialName;

Methods

Private | function GetMainTextureName: string;
Private | procedure SetMainTextureName(const Value: string);

Properties

Public | property MainTexture: TgxTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;

Description

Fields

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTextureName: TgxLibMaterialName;

This item has no description.

Methods

Private function GetMainTextureName: string;

This item has no description.

Private procedure SetMainTextureName(const Value: string);

This item has no description.

Properties

Public property MainTexture: TgxTexture read FMainTexture write FMainTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslCustomBumpShaderAM

Class TgxslCustomBumpShaderAM

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslCustomBumpShaderAM = class(TgxslBaseCustomBumpShaderMT)

Description

One Light shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomBumpShaderAM

Overview

Fields

Private | FAmbientColor: TgxColor;
Private | FDiffuseColor: TgxColor;
Private | FSpecularColor: TgxColor;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetAlpha: Single;
Private | procedure SetAlpha(const Value: Single);

Properties

Public | property Alpha: Single read GetAlpha write SetAlpha;
Public | property AmbientColor: TgxColor read FAmbientColor;
Public | property DiffuseColor: TgxColor read FDiffuseColor;
Public | property SpecularColor: TgxColor read FSpecularColor;

Description

Fields

Private FAmbientColor: TgxColor;

This item has no description.

Private FDiffuseColor: TgxColor;

This item has no description.

Private FSpecularColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetAlpha: Single;

This item has no description.

Private procedure SetAlpha(const Value: Single);

This item has no description.

Properties

Public property Alpha: Single read GetAlpha write SetAlpha;

This item has no description.

Public property AmbientColor: TgxColor read FAmbientColor;

This item has no description.

Public property DiffuseColor: TgxColor read FDiffuseColor;

This item has no description.

Public property SpecularColor: TgxColor read FSpecularColor;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslCustomBumpShaderMT

Class TgxslCustomBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslCustomBumpShaderMT = class(TgxslBaseCustomBumpShaderMT)

Description

This item has no description. Showing description inherited from TgxslBaseCustomBumpShaderMT.

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomBumpShaderMT


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslCustomBumpShader

Class TgxslCustomBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslCustomBumpShader = class(TgxslBaseCustomBumpShader, IgxShaderDescription)

Description

This item has no description. Showing description inherited from TgxslBaseCustomBumpShader.

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslCustomBumpShader

Overview

Methods

Private | function GetShaderAlpha: Single;
Private | function GetShaderDescription: string;
Private | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);
Private | procedure GetShaderTextures(var Textures: array of TgxTexture);
Private | procedure SetShaderAlpha(const Value: Single);
Private | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);
Private | procedure SetShaderTextures(const Textures: array of TgxTexture);

Description

Methods

Private function GetShaderAlpha: Single;

This item has no description.

Private function GetShaderDescription: string;

This item has no description.

Private procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);

This item has no description.

Private procedure GetShaderTextures(var Textures: array of TgxTexture);

This item has no description.

Private procedure SetShaderAlpha(const Value: Single);

This item has no description.

Private procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);

This item has no description.

Private procedure SetShaderTextures(const Textures: array of TgxTexture);

Implementing IGLShaderDescription.


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslCustomMLBumpShader

Class TgxslCustomMLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslCustomMLBumpShader = class(TgxslBaseCustomBumpShader, IgxShaderDescription)

Description

MultiLight shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslCustomMLBumpShader

Overview

Fields

Private | FLightSources: TgxLightSourceSet;
Private | FLightCompensation: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | function GetShaderAlpha: Single;
Private | function GetShaderDescription: string;
Private | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);
Private | procedure GetShaderTextures(var Textures: array of TgxTexture);
Private | procedure SetLightCompensation(const Value: Single);
Private | procedure SetLightSources(const Value: TgxLightSourceSet);
Private | procedure SetShaderAlpha(const Value: Single);
Private | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Private | procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);
Private | procedure SetShaderTextures(const Textures: array of TgxTexture);

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TgxLightSourceSet read FLightSources write SetLightSources default [1];

Description

Fields

Private FLightSources: TgxLightSourceSet;

This item has no description.

Private FLightCompensation: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private function GetShaderAlpha: Single;

This item has no description.

Private function GetShaderDescription: string;

This item has no description.

Private procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);

This item has no description.

Private procedure GetShaderTextures(var Textures: array of TgxTexture);

This item has no description.

Private procedure SetLightCompensation(const Value: Single);

This item has no description.

Private procedure SetLightSources(const Value: TgxLightSourceSet);

This item has no description.

Private procedure SetShaderAlpha(const Value: Single);

This item has no description.

Private procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Private procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);

This item has no description.

Private procedure SetShaderTextures(const Textures: array of TgxTexture);

Implementing IGLShaderDescription.

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TgxLightSourceSet read FLightSources write SetLightSources default [1];


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslCustomMLBumpShaderMT

Class TgxslCustomMLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslCustomMLBumpShaderMT = class(TgxslBaseCustomBumpShaderMT)

Description

This item has no description. Showing description inherited from TgxslBaseCustomBumpShaderMT.

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomMLBumpShaderMT

Overview

Fields

Private | FLightSources: TgxLightSourceSet;
Private | FLightCompensation: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | procedure SetLightCompensation(const Value: Single);
Private | procedure SetLightSources(const Value: TgxLightSourceSet);

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TgxLightSourceSet read FLightSources write SetLightSources default [1];

Description

Fields

Private FLightSources: TgxLightSourceSet;

This item has no description.

Private FLightCompensation: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private procedure SetLightCompensation(const Value: Single);

This item has no description.

Private procedure SetLightSources(const Value: TgxLightSourceSet);

This item has no description.

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TgxLightSourceSet read FLightSources write SetLightSources default [1];


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslBumpShaderMT

Class TgxslBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslBumpShaderMT = class(TgxslCustomBumpShaderMT)

Description

One light shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomBumpShaderMT
  • TgxslBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslBumpShader

Class TgxslBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslBumpShader = class(TgxslCustomBumpShader)

Description

This item has no description. Showing description inherited from TgxslBaseCustomBumpShader.

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslCustomBumpShader
  • TgxslBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightPower;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslBumpShaderAM

Class TgxslBumpShaderAM

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslBumpShaderAM = class(TgxslCustomBumpShaderAM)

Description

This item has no description. Showing description inherited from TgxslCustomBumpShaderAM.

One Light shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomBumpShaderAM
  • TgxslBumpShaderAM

Overview

Properties

Published | property Alpha stored False;
Published | property AmbientColor;
Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property DiffuseColor;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularColor;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property Alpha stored False;

This item has no description.

Published property AmbientColor;

This item has no description.

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslMLBumpShader

Class TgxslMLBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslMLBumpShader = class(TgxslCustomMLBumpShader)

Description

Multi light shaders.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslCustomMLBumpShader
  • TgxslMLBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightCompensation;

This item has no description. Showing description inherited from TgxslCustomMLBumpShader.LightCompensation.

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Published property LightPower;

This item has no description.

Published property LightSources;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxslMLBumpShaderMT

Class TgxslMLBumpShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxslMLBumpShaderMT = class(TgxslCustomMLBumpShaderMT)

Description

This item has no description. Showing description inherited from TgxslBaseCustomBumpShaderMT.

An abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslBaseCustomBumpShader
  • TgxslBaseCustomBumpShaderMT
  • TgxslCustomMLBumpShaderMT
  • TgxslMLBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;

This item has no description.

Published property BumpSmoothness;

This item has no description.

Published property LightCompensation;

This item has no description. Showing description inherited from TgxslCustomMLBumpShaderMT.LightCompensation.

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Published property LightPower;

This item has no description.

Published property LightSources;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NormalTextureName;

This item has no description.

Published property SpecularPower;

This item has no description.

Published property SpecularSpread;

This item has no description.

Published property SpecularTextureName;


GXSysHelp v.2.5: GXSL.BumpShaders: Class TgxBumpShader

Class TgxBumpShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.BumpShaders

Declaration

type TgxBumpShader = class(TgxShader)

Description

A generic bump shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxBumpShader

Overview

Fields

Private | FVertexProgramHandle: TgxVertexProgramHandle;
Private | FFragmentProgramHandle: TgxFragmentProgramHandle;
Private | FLightIDs: TgxIntegerList;
Private | FLightsEnabled: Integer;
Private | FBumpMethod: TBumpMethod;
Private | FBumpSpace: TBumpSpace;
Private | FBumpOptions: TBumpOptions;
Private | FSpecularMode: TSpecularMode;
Private | FDesignTimeEnabled: Boolean;
Private | FAmbientPass: Boolean;
Private | FDiffusePass: Boolean;
Private | FVertexProgram: TStringList;
Private | FFragmentProgram: TStringList;
Private | FParallaxOffset: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;
Private | function GenerateFragmentProgram: string;
Private | function GenerateVertexProgram: string;
Public | procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;
Private | procedure DoLightPass(var rci: TgxRenderContextInfo; lightID: Cardinal);

Properties

Published | property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;
Published | property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;
Published | property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;
Published | property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;

Description

Fields

Private FVertexProgramHandle: TgxVertexProgramHandle;

This item has no description.

Private FFragmentProgramHandle: TgxFragmentProgramHandle;

This item has no description.

Private FLightIDs: TgxIntegerList;

This item has no description.

Private FLightsEnabled: Integer;

This item has no description.

Private FBumpMethod: TBumpMethod;

This item has no description.

Private FBumpSpace: TBumpSpace;

This item has no description.

Private FBumpOptions: TBumpOptions;

This item has no description.

Private FSpecularMode: TSpecularMode;

This item has no description.

Private FDesignTimeEnabled: Boolean;

This item has no description.

Private FAmbientPass: Boolean;

This item has no description.

Private FDiffusePass: Boolean;

This item has no description.

Private FVertexProgram: TStringList;

This item has no description.

Private FFragmentProgram: TStringList;

This item has no description.

Private FParallaxOffset: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;

This item has no description.

Private function GenerateFragmentProgram: string;

This item has no description.

Private function GenerateVertexProgram: string;

This item has no description.

Public procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;

This item has no description.

Private procedure DoLightPass(var rci: TgxRenderContextInfo; lightID: Cardinal);

This item has no description.

Properties

Published property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;

This item has no description.

Published property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;

This item has no description.

Published property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;

This item has no description.

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;

This item has no description.

Published property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;

This item has no description.

Published property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;


GXSysHelp v.2.5: GXSL.CustomShader

Unit GXSL.CustomShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.Texture
  • GXS.Cadencer
  • GXS.Scene
  • GLScene.Strings
  • GXS.Context
  • GXS.RenderContextInfo
  • GXS.Material
  • GXS.VectorLists
  • GLScene.TextureFormat
  • GXSL.Parameter

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class ECustomShaderException |
Interface IgxShaderDescription |
Interface IgxPostShader |
Class TgxCustomShader |
Class TgxShaderProgram |
Class TgxVertexProgram |
Class TgxFragmentProgram |
Class TgxGeometryProgram |
Class TgxCustomShaderParameter |

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TgxBlendingModeEx);
procedure UnApplyBlendingModeEx;
procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGXSize; const TextureTarget: TglTextureTarget = ttTexture2D);
procedure DrawTexturedScreenQuad;
procedure DrawTexturedScreenQuad2(const ViewPortSize: TGXSize);
procedure DrawTexturedScreenQuad3;
procedure DrawTexturedScreenQuad4(const ViewPortSize: TGXSize);
procedure DrawTexturedScreenQuad5(const ViewPortSize: TGXSize);
procedure DrawTexturedScreenQuad6(const ViewPortSize: TGXSize);
procedure CopyScreentoTexture(const ViewPortSize: TGXSize; const TextureTarget: Word = GL_TEXTURE_2D);
procedure CopyScreentoTexture2(const ViewPortSize: TGXSize; const TextureTarget: Word = GL_TEXTURE_2D);
function IsFogEnabled(const AFogSupportMode: TgxShaderFogSupport; var rci: TgxRenderContextInfo): Boolean;
procedure GetActiveLightsList(const ALightIDs: TgxIntegerList);

Types

TgxBlendingModeEx = (...);
TgxLightSourceEnum = 1..gxsShaderMaxLightSources;
TgxLightSourceSet = set of TgxLightSourceEnum;
TgxShaderEvent = procedure(Shader: TgxCustomShader) of object;
TgxShaderFogSupport = (...);
TgxShaderUnAplyEvent = procedure(Shader: TgxCustomShader; var ThereAreMorePasses: Boolean) of object;
TgxTransformFeedBackMode = (...);

Constants

gxsShaderMaxLightSources = 8;

Description

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TgxBlendingModeEx);

Exported procedures.

procedure UnApplyBlendingModeEx;

This item has no description.

procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGXSize; const TextureTarget: TglTextureTarget = ttTexture2D);

This item has no description.

procedure DrawTexturedScreenQuad;

Probably need to give them proper names, instead of numbers...

procedure DrawTexturedScreenQuad2(const ViewPortSize: TGXSize);

This item has no description.

procedure DrawTexturedScreenQuad3;

This item has no description.

procedure DrawTexturedScreenQuad4(const ViewPortSize: TGXSize);

This item has no description.

procedure DrawTexturedScreenQuad5(const ViewPortSize: TGXSize);

This item has no description.

procedure DrawTexturedScreenQuad6(const ViewPortSize: TGXSize);

This item has no description.

procedure CopyScreentoTexture(const ViewPortSize: TGXSize; const TextureTarget: Word = GL_TEXTURE_2D);

This item has no description.

procedure CopyScreentoTexture2(const ViewPortSize: TGXSize; const TextureTarget: Word = GL_TEXTURE_2D);

This item has no description.

function IsFogEnabled(const AFogSupportMode: TgxShaderFogSupport; var rci: TgxRenderContextInfo): Boolean;

This item has no description.

procedure GetActiveLightsList(const ALightIDs: TgxIntegerList);

This item has no description.

Types

TgxBlendingModeEx = (...);

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

Values
  • bmxOpaque
  • bmxTransparency
  • bmxAdditive
  • bmxAlphaTest50
  • bmxAlphaTest100
  • bmxModulate
  • bmxDestColorOne
  • bmxDestAlphaOne
TgxLightSourceEnum = 1..gxsShaderMaxLightSources;

This item has no description.

TgxLightSourceSet = set of TgxLightSourceEnum;

This item has no description.

TgxShaderEvent = procedure(Shader: TgxCustomShader) of object;

This item has no description.

TgxShaderFogSupport = (...);

This item has no description.

Values
  • sfsEnabled
  • sfsDisabled
  • sfsAuto
TgxShaderUnAplyEvent = procedure(Shader: TgxCustomShader; var ThereAreMorePasses: Boolean) of object;

This item has no description.

TgxTransformFeedBackMode = (...);

This item has no description.

Values
  • tfbmInterleaved
  • tfbmSeparate

Constants

gxsShaderMaxLightSources = 8;


GXSysHelp v.2.5: GXSL.CustomShader: Class ECustomShaderException

Class ECustomShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type ECustomShaderException = class(EShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECustomShaderException


GXSysHelp v.2.5: GXSL.CustomShader: Interface IgxShaderDescription

Interface IgxShaderDescription

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type IgxShaderDescription = interface(IInterface)

Description

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

Attributes
GUID['{04089C64-60C2-43F5-AC9C-38ED46264812}']

Hierarchy

  • IInterface
  • IgxShaderDescription

Overview

Methods

Public | function GetShaderAlpha: Single;
Public | function GetShaderDescription: string;
Public | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);
Public | procedure GetShaderTextures(var Textures: array of TgxTexture);
Public | procedure SetShaderAlpha(const Value: Single);
Public | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);
Public | procedure SetShaderTextures(const Textures: array of TgxTexture);

Description

Methods

Public function GetShaderAlpha: Single;

This item has no description.

Public function GetShaderDescription: string;

This item has no description.

Public procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Public procedure GetShaderMiscParameters(var ACadencer: TgxCadencer; var AMatLib: TgxMaterialLibrary; var ALightSources: TgxLightSourceSet);

This item has no description.

Public procedure GetShaderTextures(var Textures: array of TgxTexture);

This item has no description.

Public procedure SetShaderAlpha(const Value: Single);

This item has no description.

Public procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);

This item has no description.

Public procedure SetShaderMiscParameters(const ACadencer: TgxCadencer; const AMatLib: TgxMaterialLibrary; const ALightSources: TgxLightSourceSet);

This item has no description.

Public procedure SetShaderTextures(const Textures: array of TgxTexture);


GXSysHelp v.2.5: GXSL.CustomShader: Interface IgxPostShader

Interface IgxPostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type IgxPostShader = interface(IInterface)

Description

Used in the TgxPostShaderHolder component.

Attributes
GUID['{68A62362-AF0A-4CE8-A9E1-714FE02AFA4A}']

Hierarchy

  • IInterface
  • IgxPostShader

Overview

Methods

Public | function GetTextureTarget: TglTextureTarget;
Public | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle; TextureTarget: TglTextureTarget);

Description

Methods

Public function GetTextureTarget: TglTextureTarget;

Called to determine if it is compatible.

Public procedure DoUseTempTexture(const TempTexture: TgxTextureHandle; TextureTarget: TglTextureTarget);

Called on every pass.


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxCustomShader

Class TgxCustomShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxCustomShader = class(TgxShader)

Description

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader

Overview

Fields

Private | FFragmentProgram: TgxFragmentProgram;
Private | FVertexProgram: TgxVertexProgram;
Private | FGeometryProgram: TgxGeometryProgram;
Private | FTagObject: TObject;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function StoreFragmentProgram: Boolean;
Private | function StoreGeometryProgram: Boolean;
Private | function StoreVertexProgram: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename: string; GPFilename: string = '');
Private | procedure SetFragmentProgram(const Value: TgxFragmentProgram);
Private | procedure SetGeometryProgram(const Value: TgxGeometryProgram);
Private | procedure SetVertexProgram(const Value: TgxVertexProgram);

Description

Fields

Private FFragmentProgram: TgxFragmentProgram;

This item has no description.

Private FVertexProgram: TgxVertexProgram;

This item has no description.

Private FGeometryProgram: TgxGeometryProgram;

This item has no description.

Private FTagObject: TObject;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function StoreFragmentProgram: Boolean;

This item has no description.

Private function StoreGeometryProgram: Boolean;

This item has no description.

Private function StoreVertexProgram: Boolean;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadShaderPrograms(const VPFilename, FPFilename: string; GPFilename: string = '');

This item has no description.

Private procedure SetFragmentProgram(const Value: TgxFragmentProgram);

This item has no description.

Private procedure SetGeometryProgram(const Value: TgxGeometryProgram);

This item has no description.

Private procedure SetVertexProgram(const Value: TgxVertexProgram);


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxShaderProgram

Class TgxShaderProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxShaderProgram = class(TPersistent)

Description

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TgxShaderProgram

Overview

Fields

Private | FParent: TgxCustomShader;
Private | FEnabled: Boolean;
Private | FCode: TStrings;

Methods

Public | constructor Create(const AParent: TgxCustomShader); virtual;
Public | destructor Destroy; override;
Public | procedure Apply; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const AFileName: string);
Private | procedure OnChangeCode(Sender: TObject);
Private | procedure SetCode(const Value: TStrings);
Private | procedure SetEnabled(const Value: Boolean);

Properties

Published | property Code: TStrings read FCode write SetCode;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;

Description

Fields

Private FParent: TgxCustomShader;

This item has no description.

Private FEnabled: Boolean;

This item has no description.

Private FCode: TStrings;

This item has no description.

Methods

Public constructor Create(const AParent: TgxCustomShader); virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply; virtual;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure LoadFromFile(const AFileName: string);

This item has no description.

Private procedure OnChangeCode(Sender: TObject);

This item has no description.

Private procedure SetCode(const Value: TStrings);

This item has no description.

Private procedure SetEnabled(const Value: Boolean);

This item has no description.

Properties

Published property Code: TStrings read FCode write SetCode;

This item has no description.

Published property Enabled: Boolean read FEnabled write SetEnabled default False;


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxVertexProgram

Class TgxVertexProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxVertexProgram = class(TgxShaderProgram)

Description

This item has no description. Showing description inherited from TgxShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TgxShaderProgram
  • TgxVertexProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;

This item has no description.

Published property Enabled;


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxFragmentProgram

Class TgxFragmentProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxFragmentProgram = class(TgxShaderProgram)

Description

This item has no description. Showing description inherited from TgxShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TgxShaderProgram
  • TgxFragmentProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;

This item has no description.

Published property Enabled;


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxGeometryProgram

Class TgxGeometryProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxGeometryProgram = class(TgxShaderProgram)

Description

This item has no description. Showing description inherited from TgxShaderProgram.

A custom shader program.

Hierarchy

  • TObject
  • TPersistent
  • TgxShaderProgram
  • TgxGeometryProgram

Overview

Fields

Private | FInputPrimitiveType: TgxgsInTypes;
Private | FOutputPrimitiveType: TgxgsOutTypes;
Private | FVerticesOut: GLint;

Methods

Public | constructor Create(const AParent: TgxCustomShader); override;
Private | procedure SetInputPrimitiveType(const Value: TgxgsInTypes);
Private | procedure SetOutputPrimitiveType(const Value: TgxgsOutTypes);
Private | procedure SetVerticesOut(const Value: GLint);

Properties

Published | property Code;
Published | property Enabled;
Published | property InputPrimitiveType: TgxgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;
Published | property OutputPrimitiveType: TgxgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;
Published | property VerticesOut: GLint read FVerticesOut write SetVerticesOut default 0;

Description

Fields

Private FInputPrimitiveType: TgxgsInTypes;

This item has no description.

Private FOutputPrimitiveType: TgxgsOutTypes;

This item has no description.

Private FVerticesOut: GLint;

This item has no description.

Methods

Public constructor Create(const AParent: TgxCustomShader); override;

This item has no description.

Private procedure SetInputPrimitiveType(const Value: TgxgsInTypes);

This item has no description.

Private procedure SetOutputPrimitiveType(const Value: TgxgsOutTypes);

This item has no description.

Private procedure SetVerticesOut(const Value: GLint);

This item has no description.

Properties

Published property Code;

This item has no description.

Published property Enabled;

This item has no description.

Published property InputPrimitiveType: TgxgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;

This item has no description.

Published property OutputPrimitiveType: TgxgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;

This item has no description.

Published property VerticesOut: GLint read FVerticesOut write SetVerticesOut default 0;


GXSysHelp v.2.5: GXSL.CustomShader: Class TgxCustomShaderParameter

Class TgxCustomShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.CustomShader

Declaration

type TgxCustomShaderParameter = class(TObject)

Description

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TgxCustomShaderParameter

Overview

Methods

Public | procedure SetAsVectorF(const Values: array of Single); overload;
Public | procedure SetAsVectorI(const Values: array of Integer); overload;
Public | procedure SetToTextureOf(const Texture: TgxTexture; const TextureIndex: Integer); overload;
Public | procedure SetToTextureOf(const LibMaterial: TgxLibMaterial; const TextureIndex: Integer); overload;

Properties

Public | property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;
Public | property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TglTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;
Public | property AsFloat: Single read GetAsVector1f write SetAsVector1f;
Public | property AsInteger: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;
Public | property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;
Public | property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;
Public | property AsTexture [const TextureIndex: Integer]: TgxTexture write SetAsTexture;
Public | property AsTexture1D [const TextureIndex: Integer]: TgxTexture write SetAsTexture1D;
Public | property AsTexture2D [const TextureIndex: Integer]: TgxTexture write SetAsTexture2D;
Public | property AsTexture3D [const TextureIndex: Integer]: TgxTexture write SetAsTexture3D;
Public | property AsTextureCube[const TextureIndex: Integer]: TgxTexture write SetAsTextureCube;
Public | property AsTextureRect[const TextureIndex: Integer]: TgxTexture write SetAsTextureRect;
Public | property AsUniformBuffer: GLenum read GetAsUniformBuffer write SetAsUniformBuffer;
Public | property AsVector: TVector4f read GetAsVector4f write SetAsVector4f;
Public | property AsVector1f: Single read GetAsVector1f write SetAsVector1f;
Public | property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsVector1ui: GLuint read GetAsVector1ui write SetAsVector1ui;
Public | property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;
Public | property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;
Public | property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;
Public | property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;
Public | property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;
Public | property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;
Public | property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;
Public | property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;
Public | property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;

Description

Methods

Public procedure SetAsVectorF(const Values: array of Single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVectorF([0.1, 0.2]). Array length must between 1-4.

Public procedure SetAsVectorI(const Values: array of Integer); overload;

This item has no description.

Public procedure SetToTextureOf(const Texture: TgxTexture; const TextureIndex: Integer); overload;

This item has no description.

Public procedure SetToTextureOf(const LibMaterial: TgxLibMaterial; const TextureIndex: Integer); overload;

SetToTextureOf determines texture type on-the-fly.

Properties

Public property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;

This item has no description.

Public property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TglTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;

This item has no description.

Public property AsFloat: Single read GetAsVector1f write SetAsVector1f;

Standard types.

Public property AsInteger: Integer read GetAsVector1i write SetAsVector1i;

This item has no description.

Public property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;

Matrix Types.

Public property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;

This item has no description.

Public property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;

This item has no description.

Public property AsTexture [const TextureIndex: Integer]: TgxTexture write SetAsTexture;

Texture Types.

Public property AsTexture1D [const TextureIndex: Integer]: TgxTexture write SetAsTexture1D;

This item has no description.

Public property AsTexture2D [const TextureIndex: Integer]: TgxTexture write SetAsTexture2D;

This item has no description.

Public property AsTexture3D [const TextureIndex: Integer]: TgxTexture write SetAsTexture3D;

This item has no description.

Public property AsTextureCube[const TextureIndex: Integer]: TgxTexture write SetAsTextureCube;

This item has no description.

Public property AsTextureRect[const TextureIndex: Integer]: TgxTexture write SetAsTextureRect;

This item has no description.

Public property AsUniformBuffer: GLenum read GetAsUniformBuffer write SetAsUniformBuffer;

This item has no description.

Public property AsVector: TVector4f read GetAsVector4f write SetAsVector4f;

friendly properties.

Public property AsVector1f: Single read GetAsVector1f write SetAsVector1f;

Float vector types.

Public property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;

Integer vector types.

Public property AsVector1ui: GLuint read GetAsVector1ui write SetAsVector1ui;

Unsigned integer vector types.

Public property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;

This item has no description.

Public property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;

This item has no description.

Public property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;

This item has no description.

Public property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;

This item has no description.

Public property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;

This item has no description.

Public property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;

This item has no description.

Public property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;

This item has no description.

Public property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;

This item has no description.

Public property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader

Unit GXSL.DiffuseSpecularShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GXS.Color
  • GLScene.Strings
  • GXS.Scene
  • GXSL.CustomShader
  • GXSL.Shader
  • GXS.Texture
  • GXS.RenderContextInfo
  • GXS.Material

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EgxslDiffuseSpecularShaderException |
Class TgxBaseCustomGLSLDiffuseSpecular |
Class TgxBaseGLSLDiffuseSpecularShaderMT |
Class TgxCustomGLSLDiffuseSpecularShader |
Class TgxCustomGLSLDiffuseSpecularShaderMT |
Record TLightRecord |
Class TgxCustomGLSLMLDiffuseSpecularShader |
Class TgxCustomGLSLMLDiffuseSpecularShaderMT |
Class TgxSLDiffuseSpecularShaderMT |
Class TgxSLDiffuseSpecularShader |
Class TgxSLMLDiffuseSpecularShaderMT |
Class TgxSLMLDiffuseSpecularShader |


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class EgxslDiffuseSpecularShaderException

Class EgxslDiffuseSpecularShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type EgxslDiffuseSpecularShaderException = class(EgxslShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECustomShaderException
  • EGXSLShaderException
  • EgxslDiffuseSpecularShaderException


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxBaseCustomGLSLDiffuseSpecular

Class TgxBaseCustomGLSLDiffuseSpecular

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxBaseCustomGLSLDiffuseSpecular = class(TgxslCustomShader)

Description

Abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular

Overview

Fields

Private | FLightPower: Single;
Private | FRealisticSpecular: Boolean;
Private | FFogSupport: TgxShaderFogSupport;

Methods

Public | constructor Create(AOwner : TComponent); override;
Private | procedure SetFogSupport(const Value: TgxShaderFogSupport);
Private | procedure SetRealisticSpecular(const Value: Boolean);

Properties

Public | property FogSupport: TgxShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;

Description

Fields

Private FLightPower: Single;

This item has no description.

Private FRealisticSpecular: Boolean;

This item has no description.

Private FFogSupport: TgxShaderFogSupport;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Private procedure SetFogSupport(const Value: TgxShaderFogSupport);

This item has no description.

Private procedure SetRealisticSpecular(const Value: Boolean);

This item has no description.

Properties

Public property FogSupport: TgxShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;

User can disable fog support and save some FPS if he doesn't need it.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxBaseGLSLDiffuseSpecularShaderMT

Class TgxBaseGLSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxBaseGLSLDiffuseSpecularShaderMT = class(TgxBaseCustomGLSLDiffuseSpecular, IgxMaterialLibrarySupported)

Description

Abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxBaseGLSLDiffuseSpecularShaderMT

Overview

Fields

Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FMainTexture: TgxTexture;
Private | FMainTextureName: TgxLibMaterialName;

Methods

Private | function GetMainTextureName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | procedure SetMainTextureName(const Value: TgxLibMaterialName);

Properties

Public | property MainTexture: TgxTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTextureName: TgxLibMaterialName;

This item has no description.

Methods

Private function GetMainTextureName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

Implementing IGLMaterialLibrarySupported.

Private procedure SetMainTextureName(const Value: TgxLibMaterialName);

This item has no description.

Properties

Public property MainTexture: TgxTexture read FMainTexture write FMainTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTextureName write SetMainTextureName;

This item has no description.

Public property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxCustomGLSLDiffuseSpecularShader

Class TgxCustomGLSLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxCustomGLSLDiffuseSpecularShader = class(TgxBaseCustomGLSLDiffuseSpecular)

Description

******** Single Light ************

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxCustomGLSLDiffuseSpecularShader


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxCustomGLSLDiffuseSpecularShaderMT

Class TgxCustomGLSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxCustomGLSLDiffuseSpecularShaderMT = class(TgxBaseGLSLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TgxBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxBaseGLSLDiffuseSpecularShaderMT
  • TgxCustomGLSLDiffuseSpecularShaderMT


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Record TLightRecord

Record TLightRecord

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TLightRecord = record

Description

******* Multi Light *********

Overview

Fields

Public | Enabled: Boolean;
Public | Style: TgxLightStyle;

Description

Fields

Public Enabled: Boolean;

This item has no description.

Public Style: TgxLightStyle;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxCustomGLSLMLDiffuseSpecularShader

Class TgxCustomGLSLMLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxCustomGLSLMLDiffuseSpecularShader = class(TgxBaseCustomGLSLDiffuseSpecular)

Description

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxCustomGLSLMLDiffuseSpecularShader

Overview

Fields

Private FLightTrace: array[0..7] of TLightRecord;

Methods

Public constructor Create(AOwner : TComponent); override;

Description

Fields

Private FLightTrace: array[0..7] of TLightRecord;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxCustomGLSLMLDiffuseSpecularShaderMT

Class TgxCustomGLSLMLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxCustomGLSLMLDiffuseSpecularShaderMT = class(TgxBaseGLSLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TgxBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxBaseGLSLDiffuseSpecularShaderMT
  • TgxCustomGLSLMLDiffuseSpecularShaderMT

Overview

Fields

Private FLightTrace: array[0..7] of TLightRecord;

Methods

Public constructor Create(AOwner : TComponent); override;

Description

Fields

Private FLightTrace: array[0..7] of TLightRecord;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxSLDiffuseSpecularShaderMT

Class TgxSLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxSLDiffuseSpecularShaderMT = class(TgxCustomGLSLDiffuseSpecularShaderMT)

Description

******** Published Stuff ************

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxBaseGLSLDiffuseSpecularShaderMT
  • TgxCustomGLSLDiffuseSpecularShaderMT
  • TgxSLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property MainTextureName;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TgxBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;

This item has no description.

Published property MainTextureName;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxSLDiffuseSpecularShader

Class TgxSLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxSLDiffuseSpecularShader = class(TgxCustomGLSLDiffuseSpecularShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLDiffuseSpecularShader.

******** Single Light ************

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxCustomGLSLDiffuseSpecularShader
  • TgxSLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightPower;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TgxBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxSLMLDiffuseSpecularShaderMT

Class TgxSLMLDiffuseSpecularShaderMT

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxSLMLDiffuseSpecularShaderMT = class(TgxCustomGLSLMLDiffuseSpecularShaderMT)

Description

This item has no description. Showing description inherited from TgxBaseGLSLDiffuseSpecularShaderMT.

Abstract class.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxBaseGLSLDiffuseSpecularShaderMT
  • TgxCustomGLSLMLDiffuseSpecularShaderMT
  • TgxSLMLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property MainTextureName;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TgxBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;

This item has no description.

Published property MainTextureName;


GXSysHelp v.2.5: GXSL.DiffuseSpecularShader: Class TgxSLMLDiffuseSpecularShader

Class TgxSLMLDiffuseSpecularShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.DiffuseSpecularShader

Declaration

type TgxSLMLDiffuseSpecularShader = class(TgxCustomGLSLMLDiffuseSpecularShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLMLDiffuseSpecularShader.

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxBaseCustomGLSLDiffuseSpecular
  • TgxCustomGLSLMLDiffuseSpecularShader
  • TgxSLMLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightPower;

Description

Properties

Published property FogSupport;

This item has no description. Showing description inherited from TgxBaseCustomGLSLDiffuseSpecular.FogSupport.

User can disable fog support and save some FPS if he doesn't need it.

Published property LightPower;


GXSysHelp v.2.5: GXSL.LineShaders

Unit GXSL.LineShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GXS.Scene
  • GXS.Color
  • GXS.Material
  • GXS.BaseClasses
  • GXS.RenderContextInfo
  • GXS.State
  • GXS.Context

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxLineSettings |
Class TgxHiddenLineShader |
Class TgxOutlineShader |


GXSysHelp v.2.5: GXSL.LineShaders: Class TgxLineSettings

Class TgxLineSettings

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.LineShaders

Declaration

type TgxLineSettings = class(TgxUpdateAbleObject)

Description

This item has no description.

Hierarchy

  • TgxUpdateAbleObject
  • TgxLineSettings

Overview

Fields

Private | FColor: TgxColor;
Private | FWidth: Single;
Private | FPattern: TGLushort;
Private | FForceMaterial: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure UnApply(var rci: TgxRenderContextInfo);
Private | procedure SetColor(const v: TgxColor);
Private | procedure SetForceMaterial(v: boolean);
Private | procedure SetPattern(const value: TGLushort);
Private | procedure SetWidth(const Value: Single);

Properties

Published | property Color: TgxColor read FColor write SetColor;
Published | property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;
Published | property Pattern: TGLushort read FPattern write SetPattern default $FFFF;
Published | property Width: Single read FWidth write SetWidth;

Description

Fields

Private FColor: TgxColor;

This item has no description.

Private FWidth: Single;

This item has no description.

Private FPattern: TGLushort;

This item has no description.

Private FForceMaterial: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TPersistent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetColor(const v: TgxColor);

This item has no description.

Private procedure SetForceMaterial(v: boolean);

This item has no description.

Private procedure SetPattern(const value: TGLushort);

This item has no description.

Private procedure SetWidth(const Value: Single);

This item has no description.

Properties

Published property Color: TgxColor read FColor write SetColor;

This item has no description.

Published property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;

Set ForceMaterial to true to enforce the application of the line settings for objects that sets their own color, line width and pattern.

Published property Pattern: TGLushort read FPattern write SetPattern default $FFFF;

This item has no description.

Published property Width: Single read FWidth write SetWidth;


GXSysHelp v.2.5: GXSL.LineShaders: Class TgxHiddenLineShader

Class TgxHiddenLineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.LineShaders

Declaration

type TgxHiddenLineShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxHiddenLineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineSmooth: Boolean;
Private | FSolid: Boolean;
Private | FBackGroundColor: TgxColor;
Private | FFrontLine: TgxLineSettings;
Private | FBackLine: TgxLineSettings;
Private | FLighting: Boolean;
Private | FShadeModel: TgxShadeModel;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetBackgroundColor(AColor: TgxColor);
Private | procedure SetLighting(v: boolean);
Private | procedure SetlineSmooth(v: boolean);
Private | procedure SetShadeModel(const val: TgxShadeModel);
Private | procedure SetSolid(v: boolean);

Properties

Published | property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;
Published | property BackLine: TgxLineSettings read FBackLine write FBackLine;
Published | property FrontLine: TgxLineSettings read FFrontLine write FFrontLine;
Published | property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;
Published | property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;
Published | property Solid: Boolean read FSolid write SetSolid default false;
Published | property SurfaceLit: Boolean read FLighting write SetLighting default true;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineSmooth: Boolean;

This item has no description.

Private FSolid: Boolean;

This item has no description.

Private FBackGroundColor: TgxColor;

This item has no description.

Private FFrontLine: TgxLineSettings;

This item has no description.

Private FBackLine: TgxLineSettings;

This item has no description.

Private FLighting: Boolean;

This item has no description.

Private FShadeModel: TgxShadeModel;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetBackgroundColor(AColor: TgxColor);

This item has no description.

Private procedure SetLighting(v: boolean);

This item has no description.

Private procedure SetlineSmooth(v: boolean);

This item has no description.

Private procedure SetShadeModel(const val: TgxShadeModel);

This item has no description.

Private procedure SetSolid(v: boolean);

This item has no description.

Properties

Published property BackgroundColor: TgxColor read FBackgroundColor write SetBackgroundColor;

Color used for solid fill.

Published property BackLine: TgxLineSettings read FBackLine write FBackLine;

This item has no description.

Published property FrontLine: TgxLineSettings read FFrontLine write FFrontLine;

This item has no description.

Published property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;

Line smoothing control

Published property ShadeModel: TgxShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model. Default is "Smooth".

Published property Solid: Boolean read FSolid write SetSolid default false;

Solid controls if you can see through the front-line wireframe.

Published property SurfaceLit: Boolean read FLighting write SetLighting default true;

When Solid is True, determines if lighting or background color is used.


GXSysHelp v.2.5: GXSL.LineShaders: Class TgxOutlineShader

Class TgxOutlineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.LineShaders

Declaration

type TgxOutlineShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxOutlineShader

Overview

Fields

Private | FPassCount: integer;
Private | FLineColor: TgxColor;
Private | FOutlineSmooth: Boolean;
Private | FOutlineWidth: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetOutlineSmooth(v: boolean);
Private | procedure SetOutlineWidth(v: single);

Properties

Published | property LineColor: TgxColor read FLineColor write FLineColor;
Published | property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;
Published | property LineWidth: Single read FOutlineWidth write SetOutlineWidth;

Description

Fields

Private FPassCount: integer;

This item has no description.

Private FLineColor: TgxColor;

This item has no description.

Private FOutlineSmooth: Boolean;

This item has no description.

Private FOutlineWidth: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetOutlineSmooth(v: boolean);

This item has no description.

Private procedure SetOutlineWidth(v: single);

This item has no description.

Properties

Published property LineColor: TgxColor read FLineColor write FLineColor;

This item has no description.

Published property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;

Line smoothing control

Published property LineWidth: Single read FOutlineWidth write SetOutlineWidth;


GXSysHelp v.2.5: GXSL.MultiMaterialShader

Unit GXSL.MultiMaterialShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Material
  • GXS.Context
  • GXS.RenderContextInfo
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxMultiMaterialShader |


GXSysHelp v.2.5: GXSL.MultiMaterialShader: Class TgxMultiMaterialShader

Class TgxMultiMaterialShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.MultiMaterialShader

Declaration

type TgxMultiMaterialShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxMultiMaterialShader

Overview

Fields

Private | FPass: Integer;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FVisibleAtDesignTime: boolean;
Private | FShaderActiveAtDesignTime: boolean;
Private | FShaderStyle: TgxShaderStyle;

Methods

Public | constructor Create(aOwner: TComponent); override;
Private | procedure SetShaderStyle(const Value: TgxShaderStyle);
Private | procedure SetVisibleAtDesignTime(const Value: boolean);

Properties

Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ShaderStyle: TgxShaderStyle read FShaderStyle write SetShaderStyle;
Published | property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;

Description

Fields

Private FPass: Integer;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FVisibleAtDesignTime: boolean;

This item has no description.

Private FShaderActiveAtDesignTime: boolean;

This item has no description.

Private FShaderStyle: TgxShaderStyle;

This item has no description.

Methods

Public constructor Create(aOwner: TComponent); override;

This item has no description.

Private procedure SetShaderStyle(const Value: TgxShaderStyle);

This item has no description.

Private procedure SetVisibleAtDesignTime(const Value: boolean);

This item has no description.

Properties

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property ShaderStyle: TgxShaderStyle read FShaderStyle write SetShaderStyle;

This item has no description.

Published property VisibleAtDesignTime: boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;


GXSysHelp v.2.5: GXSL.Parameter

Unit GXSL.Parameter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IgxShaderParameter |

Functions and Procedures

function GLXLTypeEnum(AType: TgxSLDataType): GLEnum;
function GLXLTypeComponentCount(AType: TgxSLDataType): Integer;
procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TgxSLDataType; AMethod: TUniformAutoSetMethod);
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TgxSLDataType); overload;
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TgxSLSamplerType); overload;
function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;
function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

Types

TgxgsInTypes = (...);
TgxgsOutTypes = (...);
TgxSLDataType = (...);
TgxSLSamplerType = (...);
TUniformAutoSetMethod = procedure(Sender: IgxShaderParameter; var ARci: TgxRenderContextInfo) of object;

Constants

cGLXLTypeString: array[TgxSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');
cGLXLSamplerString: array[TgxSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');
cGXgsInTypes : array[TgxgsInTypes] of GLenum = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);
cGXgsOutTypes: array[TgxgsOutTypes] of GLenum = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);

Description

Functions and Procedures

function GLXLTypeEnum(AType: TgxSLDataType): GLEnum;

This item has no description.

function GLXLTypeComponentCount(AType: TgxSLDataType): Integer;

This item has no description.

procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TgxSLDataType; AMethod: TUniformAutoSetMethod);

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TgxSLDataType); overload;

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TgxSLSamplerType); overload;

This item has no description.

function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;

This item has no description.

function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

This item has no description.

Types

TgxgsInTypes = (...);

This item has no description.

Values
  • gsInPoints
  • gsInLines
  • gsInAdjLines
  • gsInTriangles
  • gsInAdjTriangles
TgxgsOutTypes = (...);

This item has no description.

Values
  • gsOutPoints
  • gsOutLineStrip
  • sOutTriangleStrip
TgxSLDataType = (...);

This item has no description.

Values
  • GLSLTypeUndefined
  • GLSLType1F
  • GLSLType2F
  • GLSLType3F
  • GLSLType4F
  • GLSLType1I
  • GLSLType2I
  • GLSLType3I
  • GLSLType4I
  • GLSLType1UI
  • GLSLType2UI
  • GLSLType3UI
  • GLSLType4UI
  • GLSLTypeMat2F
  • GLSLTypeMat3F
  • GLSLTypeMat4F
  • GLSLTypeVoid
TgxSLSamplerType = (...);

This item has no description.

Values
  • GLSLSamplerUndefined
  • GLSLSampler1D
  • GLSLSampler2D
  • GLSLSampler3D
  • GLSLSamplerCube
  • GLSLSampler1DShadow
  • GLSLSampler2DShadow
  • GLSLSampler1DArray
  • GLSLSampler2DArray
  • GLSLSampler1DArrayShadow
  • GLSLSampler2DArrayShadow
  • GLSLSamplerCubeShadow
  • GLSLIntSampler1D
  • GLSLIntSampler2D
  • GLSLIntSampler3D
  • GLSLIntSamplerCube
  • GLSLIntSampler1DArray
  • GLSLIntSampler2DArray
  • GLSLUIntSampler1D
  • GLSLUIntSampler2D
  • GLSLUIntSampler3D
  • GLSLUIntSamplerCube
  • GLSLUIntSampler1DArray
  • GLSLUIntSampler2DArray
  • GLSLSamplerRect
  • GLSLSamplerRectShadow
  • GLSLSamplerBuffer
  • GLSLIntSamplerRect
  • GLSLIntSamplerBuffer
  • GLSLUIntSamplerRect
  • GLSLUIntSamplerBuffer
  • GLSLSamplerMS
  • GLSLIntSamplerMS
  • GLSLUIntSamplerMS
  • GLSLSamplerMSArray
  • GLSLIntSamplerMSArray
  • GLSLUIntSamplerMSArray
TUniformAutoSetMethod = procedure(Sender: IgxShaderParameter; var ARci: TgxRenderContextInfo) of object;

This item has no description.

Constants

cGLXLTypeString: array[TgxSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');

This item has no description.

cGLXLSamplerString: array[TgxSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');

This item has no description.

cGXgsInTypes : array[TgxgsInTypes] of GLenum = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);

This item has no description.

cGXgsOutTypes: array[TgxgsOutTypes] of GLenum = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);


GXSysHelp v.2.5: GXSL.Parameter: Interface IgxShaderParameter

Interface IgxShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Parameter

Declaration

type IgxShaderParameter = interface(IInterface)

Description

This item has no description.

Hierarchy

  • IInterface
  • IgxShaderParameter

Overview

Methods

Public | function GetAutoSetMethod: string;
Public | function GetFloat: Single;
Public | function GetGLSLSamplerType: TgxSLSamplerType;
Public | function GetGLSLType: TgxSLDataType;
Public | function GetInt: Integer;
Public | function GetIVec2: TVector2i;
Public | function GetIVec3: TVector3i;
Public | function GetIVec4: TVector4i;
Public | function GetMat2: TMatrix2f;
Public | function GetMat3: TMatrix3f;
Public | function GetMat4: TMatrix4f;
Public | function GetName: string;
Public | function GetSamplerName: string;
Public | function GetTextureName: string;
Public | function GetTextureSwizzle: TglSwizzleVector;
Public | function GetUInt: Cardinal;
Public | function GetUVec2: TVector2ui;
Public | function GetUVec3: TVector3ui;
Public | function GetUVec4: TVector4ui;
Public | function GetVec2: TVector2f;
Public | function GetVec3: TVector3f;
Public | function GetVec4: TVector4f;
Public | procedure SetAutoSetMethod(const AValue: string);
Public | procedure SetFloat(const Value: Single);
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer);
Public | procedure SetInt(const Value: Integer);
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer);
Public | procedure SetIVec2(const Value: TVector2i);
Public | procedure SetIVec3(const Value: TVector3i);
Public | procedure SetIVec4(const Value: TVector4i);
Public | procedure SetMat2(const Value: TMatrix2f);
Public | procedure SetMat3(const Value: TMatrix3f);
Public | procedure SetMat4(const Value: TMatrix4f);
Public | procedure SetSamplerName(const AValue: string);
Public | procedure SetTextureName(const AValue: string);
Public | procedure SetTextureSwizzle(const AValue: TglSwizzleVector);
Public | procedure SetUInt(const Value: Cardinal);
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer);
Public | procedure SetUVec2(const Value: TVector2ui);
Public | procedure SetUVec3(const Value: TVector3ui);
Public | procedure SetUVec4(const Value: TVector4ui);
Public | procedure SetVec2(const Value: TVector2f);
Public | procedure SetVec3(const Value: TVector3f);
Public | procedure SetVec4(const Value: TVector4f);

Properties

Public | property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;
Public | property float: Single read GetFloat write SetFloat;
Public | property GLSLSamplerType: TgxSLSamplerType read GetGLSLSamplerType;
Public | property GLSLType: TgxSLDataType read GetGLSLType;
Public | property int: GLint read GetInt write SetInt;
Public | property ivec2: TVector2i read GetIVec2 write SetIVec2;
Public | property ivec3: TVector3i read GetIVec3 write SetIVec3;
Public | property ivec4: TVector4i read GetIVec4 write SetIVec4;
Public | property mat2: TMatrix2f read GetMat2 write SetMat2;
Public | property mat3: TMatrix3f read GetMat3 write SetMat3;
Public | property mat4: TMatrix4f read GetMat4 write SetMat4;
Public | property Name: string read GetName;
Public | property SamplerName: string read GetSamplerName write SetSamplerName;
Public | property TextureName: string read GetTextureName write SetTextureName;
Public | property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Public | property uint: GLuint read GetUInt write SetUInt;
Public | property uvec2: TVector2ui read GetUVec2 write SetUVec2;
Public | property uvec3: TVector3ui read GetUVec3 write SetUVec3;
Public | property uvec4: TVector4ui read GetUVec4 write SetUVec4;
Public | property vec2: TVector2f read GetVec2 write SetVec2;
Public | property vec3: TVector3f read GetVec3 write SetVec3;
Public | property vec4: TVector4f read GetVec4 write SetVec4;

Description

Methods

Public function GetAutoSetMethod: string;

This item has no description.

Public function GetFloat: Single;

This item has no description.

Public function GetGLSLSamplerType: TgxSLSamplerType;

This item has no description.

Public function GetGLSLType: TgxSLDataType;

This item has no description.

Public function GetInt: Integer;

This item has no description.

Public function GetIVec2: TVector2i;

This item has no description.

Public function GetIVec3: TVector3i;

This item has no description.

Public function GetIVec4: TVector4i;

This item has no description.

Public function GetMat2: TMatrix2f;

This item has no description.

Public function GetMat3: TMatrix3f;

This item has no description.

Public function GetMat4: TMatrix4f;

This item has no description.

Public function GetName: string;

This item has no description.

Public function GetSamplerName: string;

This item has no description.

Public function GetTextureName: string;

This item has no description.

Public function GetTextureSwizzle: TglSwizzleVector;

This item has no description.

Public function GetUInt: Cardinal;

This item has no description.

Public function GetUVec2: TVector2ui;

This item has no description.

Public function GetUVec3: TVector3ui;

This item has no description.

Public function GetUVec4: TVector4ui;

This item has no description.

Public function GetVec2: TVector2f;

This item has no description.

Public function GetVec3: TVector3f;

This item has no description.

Public function GetVec4: TVector4f;

This item has no description.

Public procedure SetAutoSetMethod(const AValue: string);

This item has no description.

Public procedure SetFloat(const Value: Single);

This item has no description.

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer);

This item has no description.

Public procedure SetInt(const Value: Integer);

This item has no description.

Public procedure SetIntArray(const Values: PGLInt; Count: Integer);

This item has no description.

Public procedure SetIVec2(const Value: TVector2i);

This item has no description.

Public procedure SetIVec3(const Value: TVector3i);

This item has no description.

Public procedure SetIVec4(const Value: TVector4i);

This item has no description.

Public procedure SetMat2(const Value: TMatrix2f);

This item has no description.

Public procedure SetMat3(const Value: TMatrix3f);

This item has no description.

Public procedure SetMat4(const Value: TMatrix4f);

This item has no description.

Public procedure SetSamplerName(const AValue: string);

This item has no description.

Public procedure SetTextureName(const AValue: string);

This item has no description.

Public procedure SetTextureSwizzle(const AValue: TglSwizzleVector);

This item has no description.

Public procedure SetUInt(const Value: Cardinal);

This item has no description.

Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer);

This item has no description.

Public procedure SetUVec2(const Value: TVector2ui);

This item has no description.

Public procedure SetUVec3(const Value: TVector3ui);

This item has no description.

Public procedure SetUVec4(const Value: TVector4ui);

This item has no description.

Public procedure SetVec2(const Value: TVector2f);

This item has no description.

Public procedure SetVec3(const Value: TVector3f);

This item has no description.

Public procedure SetVec4(const Value: TVector4f);

This item has no description.

Properties

Public property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;

Bindings.

Public property float: Single read GetFloat write SetFloat;

Scalar types.

Public property GLSLSamplerType: TgxSLSamplerType read GetGLSLSamplerType;

This item has no description.

Public property GLSLType: TgxSLDataType read GetGLSLType;

This item has no description.

Public property int: GLint read GetInt write SetInt;

This item has no description.

Public property ivec2: TVector2i read GetIVec2 write SetIVec2;

Integer vector types.

Public property ivec3: TVector3i read GetIVec3 write SetIVec3;

This item has no description.

Public property ivec4: TVector4i read GetIVec4 write SetIVec4;

This item has no description.

Public property mat2: TMatrix2f read GetMat2 write SetMat2;

Matrix Types.

Public property mat3: TMatrix3f read GetMat3 write SetMat3;

This item has no description.

Public property mat4: TMatrix4f read GetMat4 write SetMat4;

This item has no description.

Public property Name: string read GetName;

This item has no description.

Public property SamplerName: string read GetSamplerName write SetSamplerName;

This item has no description.

Public property TextureName: string read GetTextureName write SetTextureName;

This item has no description.

Public property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;

This item has no description.

Public property uint: GLuint read GetUInt write SetUInt;

This item has no description.

Public property uvec2: TVector2ui read GetUVec2 write SetUVec2;

Unsigned integer vector types.

Public property uvec3: TVector3ui read GetUVec3 write SetUVec3;

This item has no description.

Public property uvec4: TVector4ui read GetUVec4 write SetUVec4;

This item has no description.

Public property vec2: TVector2f read GetVec2 write SetVec2;

Float vector types.

Public property vec3: TVector3f read GetVec3 write SetVec3;

This item has no description.

Public property vec4: TVector4f read GetVec4 write SetVec4;


GXSysHelp v.2.5: GXSL.PhongShader

Unit GXSL.PhongShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorTypes
  • GXS.Texture
  • GLScene.VectorGeometry
  • GXS.VectorLists
  • GXS.Context
  • GXS.RenderContextInfo
  • GXSL.AsmShader
  • GXSL.CustomShader
  • GXS.State

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxPhongShader |


GXSysHelp v.2.5: GXSL.PhongShader: Class TgxPhongShader

Class TgxPhongShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PhongShader

Declaration

type TgxPhongShader = class(TgxCustomAsmShader)

Description

This item has no description. Showing description inherited from TgxCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TgxCustomAsmShader
  • TgxPhongShader

Overview

Fields

Private | FLightIDs: TgxIntegerList;
Private | FDesignTimeEnabled: Boolean;
Private | FAmbientPass: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Private | procedure SetDesignTimeEnabled(const Value: Boolean);

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;

Description

Fields

Private FLightIDs: TgxIntegerList;

This item has no description.

Private FDesignTimeEnabled: Boolean;

This item has no description.

Private FAmbientPass: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TgxShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Private procedure SetDesignTimeEnabled(const Value: Boolean);

This item has no description.

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;


GXSysHelp v.2.5: GXSL.PostEffects

Unit GXSL.PostEffects

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.Scene
  • GXS.Texture
  • GXS.Graphics
  • GXSL.CustomShader
  • GXS.Context
  • GXS.RenderContextInfo
  • GXS.Material
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLPostShaderHolderException |
Class TgxPostShaderCollectionItem |
Class TgxPostShaderCollection |
Class TgxPostShaderHolder |
Record TgxPostEffectColor |
Class TgxPostEffect |

Types

TgxOnCustomPostEffectEvent = procedure(Sender: TObject; var rci : TgxRenderContextInfo; var Buffer: TgxPostEffectBuffer) of object;
TgxPostEffectBuffer = array of TgxPostEffectColor;
TgxPostEffectPreset = (...);

Description

Types

TgxOnCustomPostEffectEvent = procedure(Sender: TObject; var rci : TgxRenderContextInfo; var Buffer: TgxPostEffectBuffer) of object;

This item has no description.

TgxPostEffectBuffer = array of TgxPostEffectColor;

This item has no description.

TgxPostEffectPreset = (...);

Some presets for TgxPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

Values
  • pepNone
  • pepGray
  • pepNegative
  • pepDistort
  • pepNoise
  • pepNightVision
  • pepBlur
  • pepCustom


GXSysHelp v.2.5: GXSL.PostEffects: Class EGLPostShaderHolderException

Class EGLPostShaderHolderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type EGLPostShaderHolderException = class(Exception)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EGLPostShaderHolderException


GXSysHelp v.2.5: GXSL.PostEffects: Class TgxPostShaderCollectionItem

Class TgxPostShaderCollectionItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type TgxPostShaderCollectionItem = class(TCollectionItem)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxPostShaderCollectionItem

Overview

Fields

Private | FShader: TgxShader;
Private | FPostShaderInterface: IgxPostShader;

Methods

Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetShader(const Value: TgxShader);

Properties

Published property Shader: TgxShader read FShader write SetShader;

Description

Fields

Private FShader: TgxShader;

This item has no description.

Private FPostShaderInterface: IgxPostShader;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetShader(const Value: TgxShader);

This item has no description.

Properties

Published property Shader: TgxShader read FShader write SetShader;


GXSysHelp v.2.5: GXSL.PostEffects: Class TgxPostShaderCollection

Class TgxPostShaderCollection

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type TgxPostShaderCollection = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxPostShaderCollection

Overview

Methods

Public | function Add: TgxPostShaderCollectionItem;
Private | function GetItems(const Index: Integer): TgxPostShaderCollectionItem;
Public | procedure Remove(const Item: TgxShader);
Private | procedure SetItems(const Index: Integer; const Value: TgxPostShaderCollectionItem);

Properties

Public property Items[const Index: Integer]: TgxPostShaderCollectionItem read GetItems write SetItems;

Description

Methods

Public function Add: TgxPostShaderCollectionItem;

This item has no description.

Private function GetItems(const Index: Integer): TgxPostShaderCollectionItem;

This item has no description.

Public procedure Remove(const Item: TgxShader);

This item has no description.

Private procedure SetItems(const Index: Integer; const Value: TgxPostShaderCollectionItem);

This item has no description.

Properties

Public property Items[const Index: Integer]: TgxPostShaderCollectionItem read GetItems write SetItems;


GXSysHelp v.2.5: GXSL.PostEffects: Class TgxPostShaderHolder

Class TgxPostShaderHolder

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type TgxPostShaderHolder = class(TgxBaseSCeneObject)

Description

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxPostShaderHolder

Overview

Fields

Private | FShaders: TgxPostShaderCollection;
Private | FTempTexture: TgxTextureHandle;
Private | FPreviousViewportSize: TGXSize;
Private | FTempTextureTarget: TglTextureTarget;

Methods

Public | constructor Create(Owner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Private | procedure SetShaders(const Value: TgxPostShaderCollection);

Properties

Published | property OnProgress;
Published | property Shaders: TgxPostShaderCollection read FShaders write SetShaders;
Published | property TempTextureTarget: TglTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;
Published | property Visible;

Description

Fields

Private FShaders: TgxPostShaderCollection;

This item has no description.

Private FTempTexture: TgxTextureHandle;

This item has no description.

Private FPreviousViewportSize: TGXSize;

This item has no description.

Private FTempTextureTarget: TglTextureTarget;

This item has no description.

Methods

Public constructor Create(Owner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;

This item has no description.

Private procedure SetShaders(const Value: TgxPostShaderCollection);

This item has no description.

Properties

Published property OnProgress;

This item has no description.

Published property Shaders: TgxPostShaderCollection read FShaders write SetShaders;

This item has no description.

Published property TempTextureTarget: TglTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;

This item has no description.

Published property Visible;

Publish some stuff from TgxBaseSceneObject.


GXSysHelp v.2.5: GXSL.PostEffects: Record TgxPostEffectColor

Record TgxPostEffectColor

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type TgxPostEffectColor = record

Description

This item has no description.

Overview

Fields

Public | R: GLubyte;
Public | G: GLubyte;
Public | B: GLubyte;
Public | A: GLubyte;

Description

Fields

Public R: GLubyte;

This item has no description.

Public G: GLubyte;

This item has no description.

Public B: GLubyte;

This item has no description.

Public A: GLubyte;


GXSysHelp v.2.5: GXSL.PostEffects: Class TgxPostEffect

Class TgxPostEffect

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostEffects

Declaration

type TgxPostEffect = class(TgxBaseSCeneObject)

Description

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxPostEffect

Overview

Fields

Private | FOnCustomEffect: TgxOnCustomPostEffectEvent;
Private | FPreset: TgxPostEffectPreset;
Private | FRenderBuffer: TgxPostEffectBuffer;

Methods

Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;

Properties

Published | property OnCustomEffect: TgxOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;
Published | property OnProgress;
Published | property Preset: TgxPostEffectPreset read FPreset write FPreset default pepNone;
Published | property Visible;

Description

Fields

Private FOnCustomEffect: TgxOnCustomPostEffectEvent;

This item has no description.

Private FPreset: TgxPostEffectPreset;

This item has no description.

Private FRenderBuffer: TgxPostEffectBuffer;

This item has no description.

Methods

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Public procedure DoRender(var rci : TgxRenderContextInfo; renderSelf, renderChildren : Boolean); override;

This item has no description.

Properties

Published property OnCustomEffect: TgxOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;

User creates this effect.

Published property OnProgress;

This item has no description.

Published property Preset: TgxPostEffectPreset read FPreset write FPreset default pepNone;

This item has no description.

Published property Visible;

Publish some stuff from TgxBaseSCeneObject.


GXSysHelp v.2.5: GXSL.PostShaders

Unit GXSL.PostShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Texture
  • GXS.Scene
  • GLScene.VectorTypes
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Material
  • GXSL.Shader
  • GXSL.CustomShader
  • GXS.RenderContextInfo
  • GLScene.TextureFormat

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxslCustomPostBlurShader |
Class TgxslPostBlurShader |
Class TgxslCustomPostThermalVisionShader |
Class TgxslPostThermalVisionShader |
Class TgxslCustomPostDreamVisionShader |
Class TgxSLPostDreamVisionShader |
Class TgxslCustomPostNightVisionShader |
Class TgxslPostNightVisionShader |
Class TgxslCustomPostPixelateShader |
Class TgxslPostPixelateShader |
Class TgxslCustomPostPosterizeShader |
Class TgxslPostPosterizeShader |
Class TgxslCustomPostFrostShader |
Class TgxslPostFrostShader |
Class TgxslCustomPostTroubleShader |
Class TgxslPostTroubleShader |


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostBlurShader

Class TgxslCustomPostBlurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostBlurShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom class for GLSLxPostBlurShader. A shader that blurs the entire scene }

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostBlurShader

Overview

Fields

Private FThreshold: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle; TextureTarget: TglTextureTarget);

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle; TextureTarget: TglTextureTarget);

Implementing IPostShader.

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostBlurShader

Class TgxslPostBlurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostBlurShader = class(TgxslCustomPostBlurShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostBlurShader.

Custom class for GLSLxPostBlurShader. A shader that blurs the entire scene }

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostBlurShader
  • TgxslPostBlurShader

Overview

Properties

Published property Threshold;

Description

Properties

Published property Threshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostThermalVisionShader

Class TgxslCustomPostThermalVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostThermalVisionShader = class(TgxslCustomShader, IgxPostShader)

Description

A shader that simulate a Thermal Vision of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostThermalVisionShader

Overview

Fields

Private | FThreshold: Single;
Private | Fintensity: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreIntensity: Boolean;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Properties

Public | property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;
Public | property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Private Fintensity: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreIntensity: Boolean;

This item has no description.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Implementing IPostShader.

Properties

Public property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;

This item has no description.

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostThermalVisionShader

Class TgxslPostThermalVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostThermalVisionShader = class(TgxslCustomPostThermalVisionShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostThermalVisionShader.

A shader that simulate a Thermal Vision of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostThermalVisionShader
  • TgxslPostThermalVisionShader

Overview

Properties

Published | property Intensity;
Published | property Threshold;

Description

Properties

Published property Intensity;

This item has no description.

Published property Threshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostDreamVisionShader

Class TgxslCustomPostDreamVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostDreamVisionShader = class(TgxslCustomShader, IgxPostShader)

Description

A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostDreamVisionShader

Overview

Fields

Private FThreshold: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Fields

Private FThreshold: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

In percent 0..100; Implementing IPostShader.

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxSLPostDreamVisionShader

Class TgxSLPostDreamVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxSLPostDreamVisionShader = class(TgxslCustomPostDreamVisionShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostDreamVisionShader.

A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostDreamVisionShader
  • TgxSLPostDreamVisionShader

Overview

Properties

Published property Threshold;

Description

Properties

Published property Threshold;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostNightVisionShader

Class TgxslCustomPostNightVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostNightVisionShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostNightVisionShader

Overview

Fields

Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FLuminanceThreshold: Single;
Private | FColorAmplification:Single;
Private | FElapsedTime: Single;
Private | FUseMask: Integer;
Private | FNoiseTex: TgxTexture;
Private | FMaskTex: TgxTexture;
Private | FNoiseTexName: TgxLibMaterialName;
Private | FMaskTexName: TgxLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetMaskTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetNoiseTexName: TgxLibMaterialName;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreColorAmplification: Boolean;
Private | function StoreLuminanceThreshold: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);
Private | procedure SetMaskTexName(const Value: TgxLibMaterialName);
Private | procedure SetMaskTexTexture(const Value: TgxTexture);
Private | procedure SetNoiseTexName(const Value: TgxLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TgxTexture);

Properties

Public | property ColorAmplification: Single read FColorAmplification write FColorAmplification stored StoreColorAmplification;
Public | property ElapsedTime: Single read FElapsedTime write FElapsedTime stored false;
Public | property LuminanceThreshold: Single read FLuminanceThreshold write FLuminanceThreshold stored StoreLuminanceThreshold;
Public | property MaskTex: TgxTexture read FMaskTex write SetMaskTexTexture;
Public | property MaskTexName: TgxLibMaterialName read GetMaskTexName write SetMaskTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTex: TgxTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTexName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property UseMask : Integer read FUseMask write FUseMask;

Description

Fields

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FLuminanceThreshold: Single;

This item has no description.

Private FColorAmplification:Single;

This item has no description.

Private FElapsedTime: Single;

This item has no description.

Private FUseMask: Integer;

This item has no description.

Private FNoiseTex: TgxTexture;

This item has no description.

Private FMaskTex: TgxTexture;

This item has no description.

Private FNoiseTexName: TgxLibMaterialName;

This item has no description.

Private FMaskTexName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetMaskTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TgxLibMaterialName;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreColorAmplification: Boolean;

This item has no description.

Private function StoreLuminanceThreshold: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

This item has no description. Showing description inherited from IgxPostShader.DoUseTempTexture.

Called on every pass.

Private procedure SetMaskTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMaskTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TgxTexture);

This item has no description.

Properties

Public property ColorAmplification: Single read FColorAmplification write FColorAmplification stored StoreColorAmplification;

This item has no description.

Public property ElapsedTime: Single read FElapsedTime write FElapsedTime stored false;

This item has no description.

Public property LuminanceThreshold: Single read FLuminanceThreshold write FLuminanceThreshold stored StoreLuminanceThreshold;

This item has no description.

Public property MaskTex: TgxTexture read FMaskTex write SetMaskTexTexture;

This item has no description.

Public property MaskTexName: TgxLibMaterialName read GetMaskTexName write SetMaskTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseTex: TgxTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTexName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property UseMask : Integer read FUseMask write FUseMask;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostNightVisionShader

Class TgxslPostNightVisionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostNightVisionShader = class(TgxslCustomPostNightVisionShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostNightVisionShader.

Custom shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostNightVisionShader
  • TgxslPostNightVisionShader

Overview

Properties

Published | property ColorAmplification;
Published | property ElapsedTime;
Published | property LuminanceThreshold;
Published | property MaskTexName;
Published | property MaterialLibrary;
Published | property NoiseTexName;
Published | property UseMask;

Description

Properties

Published property ColorAmplification;

This item has no description.

Published property ElapsedTime;

This item has no description.

Published property LuminanceThreshold;

This item has no description.

Published property MaskTexName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseTexName;

This item has no description.

Published property UseMask;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostPixelateShader

Class TgxslCustomPostPixelateShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostPixelateShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom shader that pixelate of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostPixelateShader

Overview

Fields

Private | FPixelWidth: Single;
Private | FPixelHeight: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StorePixelHeight: Boolean;
Private | function StorePixelWidth: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Properties

Public | property PixelHeight: Single read FPixelHeight write FPixelHeight stored StorePixelHeight;
Public | property PixelWidth: Single read FPixelWidth write FPixelWidth stored StorePixelWidth;

Description

Fields

Private FPixelWidth: Single;

This item has no description.

Private FPixelHeight: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StorePixelHeight: Boolean;

This item has no description.

Private function StorePixelWidth: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

This item has no description. Showing description inherited from IgxPostShader.DoUseTempTexture.

Called on every pass.

Properties

Public property PixelHeight: Single read FPixelHeight write FPixelHeight stored StorePixelHeight;

This item has no description.

Public property PixelWidth: Single read FPixelWidth write FPixelWidth stored StorePixelWidth;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostPixelateShader

Class TgxslPostPixelateShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostPixelateShader = class(TgxslCustomPostPixelateShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostPixelateShader.

Custom shader that pixelate of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostPixelateShader
  • TgxslPostPixelateShader

Overview

Properties

Published | property PixelHeight;
Published | property PixelWidth;

Description

Properties

Published property PixelHeight;

This item has no description.

Published property PixelWidth;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostPosterizeShader

Class TgxslCustomPostPosterizeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostPosterizeShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom shader that posterize of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostPosterizeShader

Overview

Fields

Private | FGamma: Single;
Private | FNumColors: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreGamma: Boolean;
Private | function StoreNumColors: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Properties

Public | property Gamma: Single read FGamma write FGamma stored StoreGamma;
Public | property NumColors: Single read FNumColors write FNumColors stored StoreNumColors;

Description

Fields

Private FGamma: Single;

This item has no description.

Private FNumColors: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreGamma: Boolean;

This item has no description.

Private function StoreNumColors: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

This item has no description. Showing description inherited from IgxPostShader.DoUseTempTexture.

Called on every pass.

Properties

Public property Gamma: Single read FGamma write FGamma stored StoreGamma;

This item has no description.

Public property NumColors: Single read FNumColors write FNumColors stored StoreNumColors;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostPosterizeShader

Class TgxslPostPosterizeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostPosterizeShader = class(TgxslCustomPostPosterizeShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostPosterizeShader.

Custom shader that posterize of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostPosterizeShader
  • TgxslPostPosterizeShader

Overview

Properties

Published | property Gamma;
Published | property NumColors;

Description

Properties

Published property Gamma;

This item has no description.

Published property NumColors;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostFrostShader

Class TgxslCustomPostFrostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostFrostShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom class for shader that frost of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostFrostShader

Overview

Fields

Private | FRandScale: Single;
Private | FRandFactor: Single;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreRandFactor: Boolean;
Private | function StoreRandScale: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

Properties

Public | property RandFactor: Single read FRandFactor write FRandFactor stored StoreRandFactor;
Public | property RandScale: Single read FRandScale write FRandScale stored StoreRandScale;

Description

Fields

Private FRandScale: Single;

This item has no description.

Private FRandFactor: Single;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreRandFactor: Boolean;

This item has no description.

Private function StoreRandScale: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

This item has no description. Showing description inherited from IgxPostShader.DoUseTempTexture.

Called on every pass.

Properties

Public property RandFactor: Single read FRandFactor write FRandFactor stored StoreRandFactor;

This item has no description.

Public property RandScale: Single read FRandScale write FRandScale stored StoreRandScale;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostFrostShader

Class TgxslPostFrostShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostFrostShader = class(TgxslCustomPostFrostShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostFrostShader.

Custom class for shader that frost of the entire scene

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostFrostShader
  • TgxslPostFrostShader

Overview

Properties

Published | property RandFactor;
Published | property RandScale;

Description

Properties

Published property RandFactor;

This item has no description.

Published property RandScale;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslCustomPostTroubleShader

Class TgxslCustomPostTroubleShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslCustomPostTroubleShader = class(TgxslCustomShader, IgxPostShader)

Description

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostTroubleShader

Overview

Fields

Private | FPixelX: Single;
Private | FPixelY: Single;
Private | FFreq: Single;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FNoiseTex: TgxTexture;
Private | FNoiseTexName: TgxLibMaterialName;

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetNoiseTexName: TgxLibMaterialName;
Private | function GetTextureTarget: TglTextureTarget;
Private | function StoreFreq: Boolean;
Private | function StorePixelX: Boolean;
Private | function StorePixelY: Boolean;
Private | procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);
Private | procedure SetNoiseTexName(const Value: TgxLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TgxTexture);

Properties

Public | property Freq: Single read FFreq write FFreq stored StoreFreq;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTex: TgxTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTexName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property PixelX: Single read FPixelX write FPixelX stored StorePixelX;
Public | property PixelY: Single read FPixelY write FPixelY stored StorePixelY;

Description

Fields

Private FPixelX: Single;

This item has no description.

Private FPixelY: Single;

This item has no description.

Private FFreq: Single;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FNoiseTex: TgxTexture;

This item has no description.

Private FNoiseTexName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TgxLibMaterialName;

This item has no description.

Private function GetTextureTarget: TglTextureTarget;

This item has no description. Showing description inherited from IgxPostShader.GetTextureTarget.

Called to determine if it is compatible.

Private function StoreFreq: Boolean;

This item has no description.

Private function StorePixelX: Boolean;

This item has no description.

Private function StorePixelY: Boolean;

This item has no description.

Private procedure DoUseTempTexture(const TempTexture: TgxTextureHandle;TextureTarget: TglTextureTarget);

This item has no description. Showing description inherited from IgxPostShader.DoUseTempTexture.

Called on every pass.

Private procedure SetNoiseTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TgxTexture);

This item has no description.

Properties

Public property Freq: Single read FFreq write FFreq stored StoreFreq;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseTex: TgxTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTexName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property PixelX: Single read FPixelX write FPixelX stored StorePixelX;

This item has no description.

Public property PixelY: Single read FPixelY write FPixelY stored StorePixelY;


GXSysHelp v.2.5: GXSL.PostShaders: Class TgxslPostTroubleShader

Class TgxslPostTroubleShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.PostShaders

Declaration

type TgxslPostTroubleShader = class(TgxslCustomPostTroubleShader)

Description

This item has no description. Showing description inherited from TgxslCustomPostTroubleShader.

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxslCustomPostTroubleShader
  • TgxslPostTroubleShader

Overview

Properties

Published | property Freq;
Published | property MaterialLibrary;
Published | property NoiseTexName;
Published | property PixelX;
Published | property PixelY;

Description

Properties

Published property Freq;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseTexName;

This item has no description.

Published property PixelX;

This item has no description.

Published property PixelY;


GXSysHelp v.2.5: GXSL.ProjectedTextures

Unit GXSL.ProjectedTextures

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • GXS.PersistentClasses
  • GXS.Scene
  • GXS.Texture
  • GLScene.VectorGeometry
  • GXS.Context
  • GXS.Color
  • GXS.RenderContextInfo
  • GLScene.TextureFormat
  • GLScene.PipelineTransform
  • GLScene.VectorTypes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxslTextureEmitter |
Class TgxslTextureEmitterItem |
Class TgxslTextureEmitters |
Class TgxslProjectedTextures |

Types

TgxslProjectedTexturesStyle = (...);

Description

Types

TgxslProjectedTexturesStyle = (...);

This item has no description.

Values
  • ptsLight
  • ptsShadow


GXSysHelp v.2.5: GXSL.ProjectedTextures: Class TgxslTextureEmitter

Class TgxslTextureEmitter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ProjectedTextures

Declaration

type TgxslTextureEmitter = class(TgxBaseSceneObject)

Description

A projected texture emitter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxslTextureEmitter

Overview

Fields

Private | FFOV: single;
Private | FAspect: single;
Private | FBrightness: single;
Private | FAttenuation: single;
Private | FStyle: TgxslProjectedTexturesStyle;
Private | FColor: TgxColor;
Private | FUseAttenuation: boolean;
Private | FAllowReverseProjection: boolean;
Private | FUseQuadraticAttenuation: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: boolean); override;

Properties

Published | property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;
Published | property Aspect: single read FAspect write FAspect;
Published | property Attenuation: single read FAttenuation write FAttenuation;
Published | property Behaviours;
Published | property Brightness: single read FBrightness write FBrightness;
Published | property Color: TgxColor read FColor write FColor;
Published | property Direction;
Published | property Effects;
Published | property FOV: single read FFOV write FFOV;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property Style: TgxslProjectedTexturesStyle read FStyle write SetStyle;
Published | property TurnAngle;
Published | property Up;
Published | property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;
Published | property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;
Published | property VisibilityCulling;
Published | property Visible;

Description

Fields

Private FFOV: single;

This item has no description.

Private FAspect: single;

This item has no description.

Private FBrightness: single;

This item has no description.

Private FAttenuation: single;

This item has no description.

Private FStyle: TgxslProjectedTexturesStyle;

This item has no description.

Private FColor: TgxColor;

This item has no description.

Private FUseAttenuation: boolean;

This item has no description.

Private FAllowReverseProjection: boolean;

This item has no description.

Private FUseQuadraticAttenuation: boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: boolean); override;

This item has no description.

Properties

Published property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;

This item has no description.

Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property Attenuation: single read FAttenuation write FAttenuation;

Fall off/ attenuation of the projected texture

Published property Behaviours;

This item has no description.

Published property Brightness: single read FBrightness write FBrightness;

This item has no description.

Published property Color: TgxColor read FColor write FColor;

This item has no description.

Published property Direction;

This item has no description.

Published property Effects;

This item has no description.

Published property FOV: single read FFOV write FFOV;

Indicates the field-of-view of the projection frustum.

Published property ObjectsSorting;

This item has no description.

Published property OnProgress;

This item has no description.

Published property PitchAngle;

This item has no description.

Published property Position;

This item has no description.

Published property RollAngle;

This item has no description.

Published property Scale;

This item has no description.

Published property ShowAxes;

This item has no description.

Published property Style: TgxslProjectedTexturesStyle read FStyle write SetStyle;

Indicates the style of the projected textures.

Published property TurnAngle;

This item has no description.

Published property Up;

This item has no description.

Published property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;

This item has no description.

Published property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;

This item has no description.

Published property VisibilityCulling;

This item has no description.

Published property Visible;


GXSysHelp v.2.5: GXSL.ProjectedTextures: Class TgxslTextureEmitterItem

Class TgxslTextureEmitterItem

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ProjectedTextures

Declaration

type TgxslTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TgxslTextureEmitters collection.

Hierarchy

  • TObject
  • TPersistent
  • TCollectionItem
  • TgxslTextureEmitterItem

Overview

Fields

Private FEmitter: TgxslTextureEmitter;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Emitter: TgxslTextureEmitter read FEmitter write SetEmitter;

Description

Fields

Private FEmitter: TgxslTextureEmitter;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Properties

Published property Emitter: TgxslTextureEmitter read FEmitter write SetEmitter;


GXSysHelp v.2.5: GXSL.ProjectedTextures: Class TgxslTextureEmitters

Class TgxslTextureEmitters

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ProjectedTextures

Declaration

type TgxslTextureEmitters = class(TCollection)

Description

Collection of TgxslTextureEmitter.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TgxslTextureEmitters

Overview

Fields

Private FOwner: TgxslProjectedTextures;

Methods

Public procedure AddEmitter(texEmitter: TgxslTextureEmitter);

Properties

Public property Items[index: Integer]: TgxslTextureEmitterItem read GetItems;

Description

Fields

Private FOwner: TgxslProjectedTextures;

This item has no description.

Methods

Public procedure AddEmitter(texEmitter: TgxslTextureEmitter);

This item has no description.

Properties

Public property Items[index: Integer]: TgxslTextureEmitterItem read GetItems;


GXSysHelp v.2.5: GXSL.ProjectedTextures: Class TgxslProjectedTextures

Class TgxslProjectedTextures

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ProjectedTextures

Declaration

type TgxslProjectedTextures = class(TgxSceneObject)

Description

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

Hierarchy

  • TgxCoordinatesUpdateAbleComponent
  • TgxBaseSceneObject
  • TgxCustomSceneObject
  • TgxSceneObject
  • TgxslProjectedTextures

Overview

Fields

Private | FEmitters: TgxslTextureEmitters;
Private | FUseLightmaps: boolean;
Private | Shader: TgxProgramHandle;
Private | FAmbient: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;
Private | procedure SetupShader;

Properties

Published | property Ambient: TgxColor read fAmbient write fAmbient;
Published | property Emitters: TgxslTextureEmitters read FEmitters write FEmitters;
Published | property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;

Description

Fields

Private FEmitters: TgxslTextureEmitters;

This item has no description.

Private FUseLightmaps: boolean;

This item has no description.

Private Shader: TgxProgramHandle;

This item has no description.

Private FAmbient: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure DoRender(var rci: TgxRenderContextInfo; renderSelf, renderChildren: Boolean); override;

This item has no description.

Public procedure StructureChanged; override;

This item has no description.

Private procedure SetupShader;

This item has no description.

Properties

Published property Ambient: TgxColor read fAmbient write fAmbient;

Ambient is use if no lightmap..

Published property Emitters: TgxslTextureEmitters read FEmitters write FEmitters;

List of emitters.

Published property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;


GXSysHelp v.2.5: GXSL.Shader

Unit GXSL.Shader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GXS.Texture
  • GXS.Context
  • GXS.RenderContextInfo
  • GLScene.TextureFormat
  • GXSL.CustomShader
  • GXSL.Parameter

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGXSLShaderException |
Record TgxActiveAttrib |
Class TGXSLCustomShader |
Class TGXSLShaderParameter |
Class TGXSLShader |

Types

TgxActiveAttribArray = array of TgxActiveAttrib;
TGXSLShaderEvent = procedure(Shader: TGXSLCustomShader) of object;
TGXSLShaderEventEx = procedure(Shader: TGXSLCustomShader; Sender: TObject) of object;
TGXSLShaderUnApplyEvent = procedure(Shader: TGXSLCustomShader; var ThereAreMorePasses: Boolean) of object;

Description

Types

TgxActiveAttribArray = array of TgxActiveAttrib;

This item has no description.

TGXSLShaderEvent = procedure(Shader: TGXSLCustomShader) of object;

This item has no description.

TGXSLShaderEventEx = procedure(Shader: TGXSLCustomShader; Sender: TObject) of object;

This item has no description.

TGXSLShaderUnApplyEvent = procedure(Shader: TGXSLCustomShader; var ThereAreMorePasses: Boolean) of object;


GXSysHelp v.2.5: GXSL.Shader: Class EGXSLShaderException

Class EGXSLShaderException

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Shader

Declaration

type EGXSLShaderException = class(ECustomShaderException)

Description

This item has no description.

Hierarchy

  • TObject
  • Exception
  • EShaderException
  • ECustomShaderException
  • EGXSLShaderException


GXSysHelp v.2.5: GXSL.Shader: Record TgxActiveAttrib

Record TgxActiveAttrib

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Shader

Declaration

type TgxActiveAttrib = record

Description

This item has no description.

Overview

Fields

Public | Name: string;
Public | Size: Integer;
Public | AType: TgxSLDataType;
Public | Location: Integer;

Description

Fields

Public Name: string;

This item has no description.

Public Size: Integer;

This item has no description.

Public AType: TgxSLDataType;

This item has no description.

Public Location: Integer;


GXSysHelp v.2.5: GXSL.Shader: Class TGXSLCustomShader

Class TGXSLCustomShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Shader

Declaration

type TGXSLCustomShader = class(TgxCustomShader)

Description

This item has no description. Showing description inherited from TgxCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader

Overview

Fields

Private | FGXSLProg: TgxProgramHandle;
Private | FParam: TGXSLShaderParameter;
Private | FActiveVarying: TStrings;
Private | FTransformFeedBackMode: TgxTransformFeedBackMode;
Private | FOnInitialize: TGXSLShaderEvent;
Private | FOnApply: TGXSLShaderEvent;
Private | FOnUnApply: TGXSLShaderUnApplyEvent;
Private | FOnInitializeEx: TGXSLShaderEventEx;
Private | FOnApplyEx: TGXSLShaderEventEx;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetActiveAttribs: TgxActiveAttribArray;
Public | function ShaderSupported: Boolean; override;
Private | function GetDirectParam(const Index: Cardinal): TGXSLShaderParameter;
Private | function GetParam(const Index: string): TGXSLShaderParameter;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure OnChangeActiveVarying(Sender: TObject);

Properties

Public | property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;
Public | property DirectParam[const Index: Cardinal]: TGXSLShaderParameter read GetDirectParam;
Public | property Param[const Index: string]: TGXSLShaderParameter read GetParam;
Public | property TransformFeedBackMode: TgxTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;

Description

Fields

Private FGXSLProg: TgxProgramHandle;

This item has no description.

Private FParam: TGXSLShaderParameter;

This item has no description.

Private FActiveVarying: TStrings;

This item has no description.

Private FTransformFeedBackMode: TgxTransformFeedBackMode;

This item has no description.

Private FOnInitialize: TGXSLShaderEvent;

This item has no description.

Private FOnApply: TGXSLShaderEvent;

This item has no description.

Private FOnUnApply: TGXSLShaderUnApplyEvent;

This item has no description.

Private FOnInitializeEx: TGXSLShaderEventEx;

This item has no description.

Private FOnApplyEx: TGXSLShaderEventEx;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function GetActiveAttribs: TgxActiveAttribArray;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TgxShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Private function GetDirectParam(const Index: Cardinal): TGXSLShaderParameter;

This item has no description.

Private function GetParam(const Index: string): TGXSLShaderParameter;

This item has no description.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure OnChangeActiveVarying(Sender: TObject);

This item has no description.

Properties

Public property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;

This item has no description.

Public property DirectParam[const Index: Cardinal]: TGXSLShaderParameter read GetDirectParam;

This item has no description.

Public property Param[const Index: string]: TGXSLShaderParameter read GetParam;

This item has no description.

Public property TransformFeedBackMode: TgxTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;


GXSysHelp v.2.5: GXSL.Shader: Class TGXSLShaderParameter

Class TGXSLShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Shader

Declaration

type TGXSLShaderParameter = class(TgxCustomShaderParameter)

Description

Wrapper around a parameter of a GLSL program.

Hierarchy

  • TObject
  • TgxCustomShaderParameter
  • TGXSLShaderParameter

Overview

Fields

Private | FGXSLProg: TgxProgramHandle;
Private | FParameterID: Integer;

Description

Fields

Private FGXSLProg: TgxProgramHandle;

This item has no description.

Private FParameterID: Integer;


GXSysHelp v.2.5: GXSL.Shader: Class TGXSLShader

Class TGXSLShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.Shader

Declaration

type TGXSLShader = class(TGXSLCustomShader)

Description

This item has no description. Showing description inherited from TgxCustomShader.

A pure abstract class, must be overriden.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TGXSLShader

Overview

Properties

Published | property ActiveVarying;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnApplyEx;
Published | property OnInitialize;
Published | property OnInitializeEx;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property TransformFeedBackMode;
Published | property VertexProgram;

Description

Properties

Published property ActiveVarying;

This item has no description.

Published property FailedInitAction;

This item has no description. Showing description inherited from TgxShader.FailedInitAction.

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Published property FragmentProgram;

This item has no description.

Published property GeometryProgram;

This item has no description.

Published property OnApply;

This item has no description.

Published property OnApplyEx;

This item has no description.

Published property OnInitialize;

This item has no description.

Published property OnInitializeEx;

This item has no description.

Published property OnUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TgxShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property TransformFeedBackMode;

This item has no description.

Published property VertexProgram;


GXSysHelp v.2.5: GXSL.ShaderCombiner

Unit GXSL.ShaderCombiner

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • GXS.Material
  • GXS.Scene
  • GLScene.VectorGeometry
  • GLScene.Strings
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCustomShaderCombiner |
Class TgxShaderCombiner |

Types

TgxShaderCombinerType = (...);

Description

Types

TgxShaderCombinerType = (...);

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.

sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.

Values
  • sctOneSPTwoAP
  • sctTwoSPOneAP
  • sctOneMPTwoSP
  • sctTwoMPOneSP


GXSysHelp v.2.5: GXSL.ShaderCombiner: Class TgxCustomShaderCombiner

Class TgxCustomShaderCombiner

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShaderCombiner

Declaration

type TgxCustomShaderCombiner = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShaderCombiner

Overview

Fields

Private | FCurrentPass: Integer;
Private | FCombinerType: TgxShaderCombinerType;
Private | FShaderOne: TgxShader;
Private | FShaderTwo: TgxShader;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function ShaderSupported: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Private | procedure SetShaderOne(const Value: TgxShader);
Private | procedure SetShaderTwo(const Value: TgxShader);

Description

Fields

Private FCurrentPass: Integer;

This item has no description.

Private FCombinerType: TgxShaderCombinerType;

This item has no description.

Private FShaderOne: TgxShader;

This item has no description.

Private FShaderTwo: TgxShader;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public function ShaderSupported: Boolean; override;

This item has no description. Showing description inherited from TgxShader.ShaderSupported.

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public procedure Assign(Source: TPersistent); override;

This item has no description.

Private procedure SetShaderOne(const Value: TgxShader);

This item has no description.

Private procedure SetShaderTwo(const Value: TgxShader);


GXSysHelp v.2.5: GXSL.ShaderCombiner: Class TgxShaderCombiner

Class TgxShaderCombiner

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShaderCombiner

Declaration

type TgxShaderCombiner = class(TgxCustomShaderCombiner)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShaderCombiner
  • TgxShaderCombiner

Overview

Properties

Published | property CombinerType;
Published | property ShaderOne;
Published | property ShaderStyle;
Published | property ShaderTwo;

Description

Properties

Published property CombinerType;

This item has no description.

Published property ShaderOne;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TgxShader.ShaderStyle.

Shader application style (default is ssLowLevel).

Published property ShaderTwo;


GXSysHelp v.2.5: GXSL.ShaderParameter

Unit GXSL.ShaderParameter

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • GLScene.Strings
  • GLScene.OpenGLTokens
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IShaderParameter |

Functions and Procedures

function GLSLTypeEnum(AType: TGXSLDataType): Cardinal;
function GLSLTypeComponentCount(AType: TGXSLDataType): Integer;
procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGXSLDataType; AMethod: TUniformAutoSetMethod);
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGXSLDataType); overload;
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGXSLSamplerType); overload;
function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;
function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

Types

TGXSLDataType = (...);
TGXSLInTypes = (...);
TGXSLOutTypes = (...);
TGXSLSamplerType = (...);
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TgxRenderContextInfo) of object;

Constants

cGXSLTypeString: array[TGXSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');
cGXSLSamplerString: array[TGXSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');
cGLgsInTypes : array[TGXSLInTypes] of Cardinal = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);
cGLgsOutTypes: array[TGXSLOutTypes] of Cardinal = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);

Description

Functions and Procedures

function GLSLTypeEnum(AType: TGXSLDataType): Cardinal;

This item has no description.

function GLSLTypeComponentCount(AType: TGXSLDataType): Integer;

This item has no description.

procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGXSLDataType; AMethod: TUniformAutoSetMethod);

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGXSLDataType); overload;

This item has no description.

procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGXSLSamplerType); overload;

This item has no description.

function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;

This item has no description.

function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

This item has no description.

Types

TGXSLDataType = (...);

This item has no description.

Values
  • GLSLTypeUndefined
  • GLSLType1F
  • GLSLType2F
  • GLSLType3F
  • GLSLType4F
  • GLSLType1I
  • GLSLType2I
  • GLSLType3I
  • GLSLType4I
  • GLSLType1UI
  • GLSLType2UI
  • GLSLType3UI
  • GLSLType4UI
  • GLSLTypeMat2F
  • GLSLTypeMat3F
  • GLSLTypeMat4F
  • GLSLTypeVoid
TGXSLInTypes = (...);

This item has no description.

Values
  • gsInPoints
  • gsInLines
  • gsInAdjLines
  • gsInTriangles
  • gsInAdjTriangles
TGXSLOutTypes = (...);

This item has no description.

Values
  • gsOutPoints
  • gsOutLineStrip
  • sOutTriangleStrip
TGXSLSamplerType = (...);

This item has no description.

Values
  • GLSLSamplerUndefined
  • GLSLSampler1D
  • GLSLSampler2D
  • GLSLSampler3D
  • GLSLSamplerCube
  • GLSLSampler1DShadow
  • GLSLSampler2DShadow
  • GLSLSampler1DArray
  • GLSLSampler2DArray
  • GLSLSampler1DArrayShadow
  • GLSLSampler2DArrayShadow
  • GLSLSamplerCubeShadow
  • GLSLIntSampler1D
  • GLSLIntSampler2D
  • GLSLIntSampler3D
  • GLSLIntSamplerCube
  • GLSLIntSampler1DArray
  • GLSLIntSampler2DArray
  • GLSLUIntSampler1D
  • GLSLUIntSampler2D
  • GLSLUIntSampler3D
  • GLSLUIntSamplerCube
  • GLSLUIntSampler1DArray
  • GLSLUIntSampler2DArray
  • GLSLSamplerRect
  • GLSLSamplerRectShadow
  • GLSLSamplerBuffer
  • GLSLIntSamplerRect
  • GLSLIntSamplerBuffer
  • GLSLUIntSamplerRect
  • GLSLUIntSamplerBuffer
  • GLSLSamplerMS
  • GLSLIntSamplerMS
  • GLSLUIntSamplerMS
  • GLSLSamplerMSArray
  • GLSLIntSamplerMSArray
  • GLSLUIntSamplerMSArray
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TgxRenderContextInfo) of object;

This item has no description.

Constants

cGXSLTypeString: array[TGXSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');

This item has no description.

cGXSLSamplerString: array[TGXSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');

This item has no description.

cGLgsInTypes : array[TGXSLInTypes] of Cardinal = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);

This item has no description.

cGLgsOutTypes: array[TGXSLOutTypes] of Cardinal = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);


GXSysHelp v.2.5: GXSL.ShaderParameter: Interface IShaderParameter

Interface IShaderParameter

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShaderParameter

Declaration

type IShaderParameter = interface(IInterface)

Description

This item has no description.

Hierarchy

  • IInterface
  • IShaderParameter

Overview

Methods

Public | function GetAutoSetMethod: string;
Public | function GetFloat: Single;
Public | function GetGLSLSamplerType: TGXSLSamplerType;
Public | function GetGLSLType: TGXSLDataType;
Public | function GetInt: Integer;
Public | function GetIVec2: TVector2i;
Public | function GetIVec3: TVector3i;
Public | function GetIVec4: TVector4i;
Public | function GetMat2: TMatrix2f;
Public | function GetMat3: TMatrix3f;
Public | function GetMat4: TMatrix4f;
Public | function GetName: string;
Public | function GetSamplerName: string;
Public | function GetTextureName: string;
Public | function GetTextureSwizzle: TglSwizzleVector;
Public | function GetUInt: Cardinal;
Public | function GetUVec2: TVector2ui;
Public | function GetUVec3: TVector3ui;
Public | function GetUVec4: TVector4ui;
Public | function GetVec2: TVector2f;
Public | function GetVec3: TVector3f;
Public | function GetVec4: TVector4f;
Public | procedure SetAutoSetMethod(const AValue: string);
Public | procedure SetFloat(const Value: Single);
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer);
Public | procedure SetInt(const Value: Integer);
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer);
Public | procedure SetIVec2(const Value: TVector2i);
Public | procedure SetIVec3(const Value: TVector3i);
Public | procedure SetIVec4(const Value: TVector4i);
Public | procedure SetMat2(const Value: TMatrix2f);
Public | procedure SetMat3(const Value: TMatrix3f);
Public | procedure SetMat4(const Value: TMatrix4f);
Public | procedure SetSamplerName(const AValue: string);
Public | procedure SetTextureName(const AValue: string);
Public | procedure SetTextureSwizzle(const AValue: TglSwizzleVector);
Public | procedure SetUInt(const Value: Cardinal);
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer);
Public | procedure SetUVec2(const Value: TVector2ui);
Public | procedure SetUVec3(const Value: TVector3ui);
Public | procedure SetUVec4(const Value: TVector4ui);
Public | procedure SetVec2(const Value: TVector2f);
Public | procedure SetVec3(const Value: TVector3f);
Public | procedure SetVec4(const Value: TVector4f);

Properties

Public | property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;
Public | property float: Single read GetFloat write SetFloat;
Public | property GLSLSamplerType: TGXSLSamplerType read GetGLSLSamplerType;
Public | property GLSLType: TGXSLDataType read GetGLSLType;
Public | property int: Integer read GetInt write SetInt;
Public | property ivec2: TVector2i read GetIVec2 write SetIVec2;
Public | property ivec3: TVector3i read GetIVec3 write SetIVec3;
Public | property ivec4: TVector4i read GetIVec4 write SetIVec4;
Public | property mat2: TMatrix2f read GetMat2 write SetMat2;
Public | property mat3: TMatrix3f read GetMat3 write SetMat3;
Public | property mat4: TMatrix4f read GetMat4 write SetMat4;
Public | property Name: string read GetName;
Public | property SamplerName: string read GetSamplerName write SetSamplerName;
Public | property TextureName: string read GetTextureName write SetTextureName;
Public | property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Public | property uint: Cardinal read GetUInt write SetUInt;
Public | property uvec2: TVector2ui read GetUVec2 write SetUVec2;
Public | property uvec3: TVector3ui read GetUVec3 write SetUVec3;
Public | property uvec4: TVector4ui read GetUVec4 write SetUVec4;
Public | property vec2: TVector2f read GetVec2 write SetVec2;
Public | property vec3: TVector3f read GetVec3 write SetVec3;
Public | property vec4: TVector4f read GetVec4 write SetVec4;

Description

Methods

Public function GetAutoSetMethod: string;

This item has no description.

Public function GetFloat: Single;

This item has no description.

Public function GetGLSLSamplerType: TGXSLSamplerType;

This item has no description.

Public function GetGLSLType: TGXSLDataType;

This item has no description.

Public function GetInt: Integer;

This item has no description.

Public function GetIVec2: TVector2i;

This item has no description.

Public function GetIVec3: TVector3i;

This item has no description.

Public function GetIVec4: TVector4i;

This item has no description.

Public function GetMat2: TMatrix2f;

This item has no description.

Public function GetMat3: TMatrix3f;

This item has no description.

Public function GetMat4: TMatrix4f;

This item has no description.

Public function GetName: string;

This item has no description.

Public function GetSamplerName: string;

This item has no description.

Public function GetTextureName: string;

This item has no description.

Public function GetTextureSwizzle: TglSwizzleVector;

This item has no description.

Public function GetUInt: Cardinal;

This item has no description.

Public function GetUVec2: TVector2ui;

This item has no description.

Public function GetUVec3: TVector3ui;

This item has no description.

Public function GetUVec4: TVector4ui;

This item has no description.

Public function GetVec2: TVector2f;

This item has no description.

Public function GetVec3: TVector3f;

This item has no description.

Public function GetVec4: TVector4f;

This item has no description.

Public procedure SetAutoSetMethod(const AValue: string);

This item has no description.

Public procedure SetFloat(const Value: Single);

This item has no description.

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer);

This item has no description.

Public procedure SetInt(const Value: Integer);

This item has no description.

Public procedure SetIntArray(const Values: PGLInt; Count: Integer);

This item has no description.

Public procedure SetIVec2(const Value: TVector2i);

This item has no description.

Public procedure SetIVec3(const Value: TVector3i);

This item has no description.

Public procedure SetIVec4(const Value: TVector4i);

This item has no description.

Public procedure SetMat2(const Value: TMatrix2f);

This item has no description.

Public procedure SetMat3(const Value: TMatrix3f);

This item has no description.

Public procedure SetMat4(const Value: TMatrix4f);

This item has no description.

Public procedure SetSamplerName(const AValue: string);

This item has no description.

Public procedure SetTextureName(const AValue: string);

This item has no description.

Public procedure SetTextureSwizzle(const AValue: TglSwizzleVector);

This item has no description.

Public procedure SetUInt(const Value: Cardinal);

This item has no description.

Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer);

This item has no description.

Public procedure SetUVec2(const Value: TVector2ui);

This item has no description.

Public procedure SetUVec3(const Value: TVector3ui);

This item has no description.

Public procedure SetUVec4(const Value: TVector4ui);

This item has no description.

Public procedure SetVec2(const Value: TVector2f);

This item has no description.

Public procedure SetVec3(const Value: TVector3f);

This item has no description.

Public procedure SetVec4(const Value: TVector4f);

This item has no description.

Properties

Public property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;

Bindings.

Public property float: Single read GetFloat write SetFloat;

Scalar types.

Public property GLSLSamplerType: TGXSLSamplerType read GetGLSLSamplerType;

This item has no description.

Public property GLSLType: TGXSLDataType read GetGLSLType;

This item has no description.

Public property int: Integer read GetInt write SetInt;

This item has no description.

Public property ivec2: TVector2i read GetIVec2 write SetIVec2;

Integer vector types.

Public property ivec3: TVector3i read GetIVec3 write SetIVec3;

This item has no description.

Public property ivec4: TVector4i read GetIVec4 write SetIVec4;

This item has no description.

Public property mat2: TMatrix2f read GetMat2 write SetMat2;

Matrix Types.

Public property mat3: TMatrix3f read GetMat3 write SetMat3;

This item has no description.

Public property mat4: TMatrix4f read GetMat4 write SetMat4;

This item has no description.

Public property Name: string read GetName;

This item has no description.

Public property SamplerName: string read GetSamplerName write SetSamplerName;

This item has no description.

Public property TextureName: string read GetTextureName write SetTextureName;

This item has no description.

Public property TextureSwizzle: TglSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;

This item has no description.

Public property uint: Cardinal read GetUInt write SetUInt;

This item has no description.

Public property uvec2: TVector2ui read GetUVec2 write SetUVec2;

Unsigned integer vector types.

Public property uvec3: TVector3ui read GetUVec3 write SetUVec3;

This item has no description.

Public property uvec4: TVector4ui read GetUVec4 write SetUVec4;

This item has no description.

Public property vec2: TVector2f read GetVec2 write SetVec2;

Float vector types.

Public property vec3: TVector3f read GetVec3 write SetVec3;

This item has no description.

Public property vec4: TVector4f read GetVec4 write SetVec4;


GXSysHelp v.2.5: GXSL.ShapeShaders

Unit GXSL.ShapeShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GLScene.OpenGLTokens
  • GXS.Scene
  • GXS.BaseClasses
  • GXS.State
  • GXS.Context
  • GXS.Graphics
  • GXS.RenderContextInfo
  • GXS.Coordinates
  • GLScene.VectorGeometry
  • GLScene.VectorTypes
  • GLScene.TextureFormat
  • GXS.Color
  • GXS.Texture
  • GXS.Material
  • GXSL.Shader
  • GXSL.CustomShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxCelShader |
Class TgxCustomGLSLSimpleErosionShader |
Class TgxSLSimpleErosionShader |
Class TgxCustomGLSLGlassShader |
Class TgxSLGlassShader |
Class TgxCustomGLSLSimpleGoochShader |
Class TgxSLSimpleGoochShader |
Class TgxCustomGLSLFurShader |
Class TgxSLFurShader |
Class TgxCustomGLSLIvoryShader |
Class TgxSLIvoryShader |
Class TgxCustomGLSLSimpleLatticeShader |
Class TgxCustomGLSLLatticeShader |
Class TgxSLSimpleLatticeShader |
Class TgxSLLatticeShader |
Class TgxCustomGLSLSemShader |
Class TgxSLSemShader |
Class TgxCustomGLSLToonShader |
Class TgxSLToonShader |
Class TgxCustomGLSLVertexDisplacementShader |
Class TgxSLVertexDisplacementShader |

Types

TgxCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;
TgxCelShaderOption = (...);
TgxCelShaderOptions = set of TgxCelShaderOption;

Description

Types

TgxCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;

An event for user defined cel intensity.

TgxCelShaderOption = (...);

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

Values
  • csoOutlines
  • csoTextured
  • csoNoBuildShadeTexture
TgxCelShaderOptions = set of TgxCelShaderOption;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCelShader

Class TgxCelShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCelShader = class(TgxShader)

Description

A generic cel shader.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCelShader

Overview

Fields

Private | FOutlineWidth: Single;
Private | FCelShaderOptions: TgxCelShaderOptions;
Private | FVPHandle: TgxVertexProgramHandle;
Private | FShadeTexture: TgxTexture;
Private | FOnGetIntensity: TgxCelShaderGetIntensity;
Private | FOutlinePass: Boolean;
Private | FUnApplyShadeTexture: Boolean;
Private | FOutlineColor: TgxColor;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;
Public | procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;

Properties

Published | property CelShaderOptions: TgxCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;
Published | property OnGetIntensity: TgxCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;
Published | property OutlineColor: TgxColor read FOutlineColor write SetOutlineColor;
Published | property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;
Public | property ShadeTexture: TgxTexture read FShadeTexture;

Description

Fields

Private FOutlineWidth: Single;

This item has no description.

Private FCelShaderOptions: TgxCelShaderOptions;

This item has no description.

Private FVPHandle: TgxVertexProgramHandle;

This item has no description.

Private FShadeTexture: TgxTexture;

This item has no description.

Private FOnGetIntensity: TgxCelShaderGetIntensity;

This item has no description.

Private FOutlinePass: Boolean;

This item has no description.

Private FUnApplyShadeTexture: Boolean;

This item has no description.

Private FOutlineColor: TgxColor;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function DoUnApply(var rci: TgxRenderContextInfo): Boolean; override;

This item has no description.

Public procedure DoApply(var rci: TgxRenderContextInfo; Sender: TObject); override;

This item has no description.

Properties

Published property CelShaderOptions: TgxCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;

This item has no description.

Published property OnGetIntensity: TgxCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;

This item has no description.

Published property OutlineColor: TgxColor read FOutlineColor write SetOutlineColor;

This item has no description.

Published property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;

This item has no description.

Public property ShadeTexture: TgxTexture read FShadeTexture;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLSimpleErosionShader

Class TgxCustomGLSLSimpleErosionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLSimpleErosionShader = class(TGXSLCustomShader)

Description

Custom class for a shader that Erode surface object

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleErosionShader

Overview

Fields

Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FMainTex: TgxTexture;
Private | FNoiseTex: TgxTexture;
Private | FErosionTex: TgxTexture;
Private | FMainTexName: TgxLibMaterialName;
Private | FNoiseTexName: TgxLibMaterialName;
Private | FErosionTexName: TgxLibMaterialName;
Private | FErosionScale: Single;
Private | FErosionFactor: Single;
Private | FIntensityFactor1: Single;
Private | FIntensityFactor2: Single;
Private | FSpecularColor: TgxColor;
Private | FAmbientColor: TgxColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FSpecularRoughness: Single;
Private | FAnisotropicRoughness: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetErosionTexName: TgxLibMaterialName;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetNoiseTexName: TgxLibMaterialName;
Private | procedure SetAmbientColor(AValue: TgxColor);
Private | procedure SetErosionTexName(const Value: TgxLibMaterialName);
Private | procedure SetErosionTexTexture(const Value: TgxTexture);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetNoiseTexName(const Value: TgxLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TgxTexture);
Private | procedure SetSpecularColor(AValue: TgxColor);

Properties

Public | property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property AnisotropicRoughness : Single Read FAnisotropicRoughness Write FAnisotropicRoughness;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property ErosionFactor: Single read FErosionFactor write FErosionFactor;
Public | property ErosionScale: Single read FErosionFactor write FErosionFactor;
Public | property ErosionTexture: TgxTexture read FErosionTex write SetErosionTexTexture;
Public | property ErosionTextureName: TgxLibMaterialName read GetErosionTexName write SetErosionTexName;
Public | property IntensityFactor1: Single read FIntensityFactor1 write FIntensityFactor1;
Public | property IntensityFactor2: Single read FIntensityFactor2 write FIntensityFactor2;
Public | property MainTexture: TgxTexture read FMainTex write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseTexture: TgxTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTextureName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property SpecularRoughness : Single Read FSpecularRoughness Write FSpecularRoughness;

Description

Fields

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FMainTex: TgxTexture;

This item has no description.

Private FNoiseTex: TgxTexture;

This item has no description.

Private FErosionTex: TgxTexture;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

This item has no description.

Private FNoiseTexName: TgxLibMaterialName;

This item has no description.

Private FErosionTexName: TgxLibMaterialName;

This item has no description.

Private FErosionScale: Single;

This item has no description.

Private FErosionFactor: Single;

This item has no description.

Private FIntensityFactor1: Single;

This item has no description.

Private FIntensityFactor2: Single;

This item has no description.

Private FSpecularColor: TgxColor;

This item has no description.

Private FAmbientColor: TgxColor;

This item has no description.

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FSpecularRoughness: Single;

This item has no description.

Private FAnisotropicRoughness: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetErosionTexName: TgxLibMaterialName;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private function GetNoiseTexName: TgxLibMaterialName;

This item has no description.

Private procedure SetAmbientColor(AValue: TgxColor);

This item has no description.

Private procedure SetErosionTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetErosionTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TgxColor);

This item has no description.

Properties

Public property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property AnisotropicRoughness : Single Read FAnisotropicRoughness Write FAnisotropicRoughness;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property ErosionFactor: Single read FErosionFactor write FErosionFactor;

This item has no description.

Public property ErosionScale: Single read FErosionFactor write FErosionFactor;

This item has no description.

Public property ErosionTexture: TgxTexture read FErosionTex write SetErosionTexTexture;

This item has no description.

Public property ErosionTextureName: TgxLibMaterialName read GetErosionTexName write SetErosionTexName;

This item has no description.

Public property IntensityFactor1: Single read FIntensityFactor1 write FIntensityFactor1;

This item has no description.

Public property IntensityFactor2: Single read FIntensityFactor2 write FIntensityFactor2;

This item has no description.

Public property MainTexture: TgxTexture read FMainTex write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

property Color1: TgxColor read FColor1; property Color2: TgxColor read FColor2;

Public property NoiseTexture: TgxTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTextureName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property SpecularRoughness : Single Read FSpecularRoughness Write FSpecularRoughness;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLSimpleErosionShader

Class TgxSLSimpleErosionShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLSimpleErosionShader = class(TgxCustomGLSLSimpleErosionShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLSimpleErosionShader.

Custom class for a shader that Erode surface object

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleErosionShader
  • TgxSLSimpleErosionShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property AnisotropicRoughness;
Published | property DiffuseFactor;
Published | property ErosionFactor;
Published | property ErosionScale;
Published | property ErosionTexture;
Published | property ErosionTextureName;
Published | property IntensityFactor1;
Published | property IntensityFactor2;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NoiseTexture;
Published | property NoiseTextureName;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property SpecularRoughness;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property AnisotropicRoughness;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property ErosionFactor;

This item has no description.

Published property ErosionScale;

This item has no description.

Published property ErosionTexture;

This item has no description.

Published property ErosionTextureName;

This item has no description.

Published property IntensityFactor1;

This item has no description.

Published property IntensityFactor2;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

property Color1; property Color2;

Published property NoiseTexture;

This item has no description.

Published property NoiseTextureName;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularFactor;

This item has no description.

Published property SpecularRoughness;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLGlassShader

Class TgxCustomGLSLGlassShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLGlassShader = class(TGXSLCustomShader)

Description

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLGlassShader

Overview

Fields

Private | FDiffuseColor: TgxColor;
Private | FDepth: Single;
Private | FMix: Single;
Private | FAlpha: Single;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FMainTexture: TgxTexture;
Private | FMainTexName: TgxLibMaterialName;
Private | FRefractionTexture: TgxTexture;
Private | FRefractionTexName: TgxLibMaterialName;
Private | FOwnerObject: TgxBaseSceneObject;
Private | FBlendSrc: TgxBlendFunction;
Private | FBlendDst: TgxBlendFunction;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetRefractionTexName: TgxLibMaterialName;
Private | procedure SetDiffuseColor(AValue: TgxColor);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetRefractionTexName(const Value: TgxLibMaterialName);
Private | procedure SetRefractionTexTexture(const Value: TgxTexture);

Properties

Public | property Alpha: Single read FAlpha write FAlpha;
Public | property BlendDst: TgxBlendFunction read FBlendDst write FBlendDst default bfDstAlpha;
Public | property BlendSrc: TgxBlendFunction read FBlendSrc write FBlendSrc default bfSrcAlpha;
Public | property Depth: Single read FDepth write FDepth;
Public | property DiffuseColor: TgxColor read FDiffuseColor Write SetDiffuseColor;
Public | property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Public | property Mix: Single read FMix write FMix;
Public | property OwnerObject: TgxBaseSceneObject read FOwnerObject write FOwnerObject;
Public | property RefractionTexture: TgxTexture read FRefractionTexture write SetRefractionTexTexture;
Public | property RefractionTextureName: TgxLibMaterialName read GetRefractionTexName write SetRefractionTexName;

Description

Fields

Private FDiffuseColor: TgxColor;

This item has no description.

Private FDepth: Single;

This item has no description.

Private FMix: Single;

This item has no description.

Private FAlpha: Single;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

EnvMap

Private FRefractionTexture: TgxTexture;

This item has no description.

Private FRefractionTexName: TgxLibMaterialName;

This item has no description.

Private FOwnerObject: TgxBaseSceneObject;

This item has no description.

Private FBlendSrc: TgxBlendFunction;

This item has no description.

Private FBlendDst: TgxBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private function GetRefractionTexName: TgxLibMaterialName;

This item has no description.

Private procedure SetDiffuseColor(AValue: TgxColor);

This item has no description.

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetRefractionTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetRefractionTexTexture(const Value: TgxTexture);

This item has no description.

Properties

Public property Alpha: Single read FAlpha write FAlpha;

This item has no description.

Public property BlendDst: TgxBlendFunction read FBlendDst write FBlendDst default bfDstAlpha;

This item has no description.

Public property BlendSrc: TgxBlendFunction read FBlendSrc write FBlendSrc default bfSrcAlpha;

This item has no description.

Public property Depth: Single read FDepth write FDepth;

This item has no description.

Public property DiffuseColor: TgxColor read FDiffuseColor Write SetDiffuseColor;

This item has no description.

Public property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property Mix: Single read FMix write FMix;

This item has no description.

Public property OwnerObject: TgxBaseSceneObject read FOwnerObject write FOwnerObject;

This item has no description.

Public property RefractionTexture: TgxTexture read FRefractionTexture write SetRefractionTexTexture;

This item has no description.

Public property RefractionTextureName: TgxLibMaterialName read GetRefractionTexName write SetRefractionTexName;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLGlassShader

Class TgxSLGlassShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLGlassShader = class(TgxCustomGLSLGlassShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLGlassShader.

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLGlassShader
  • TgxSLGlassShader

Overview

Properties

Published | property Alpha;
Published | property BlendDst;
Published | property BlendSrc;
Published | property Depth;
Published | property DiffuseColor;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property Mix;
Published | property OwnerObject;
Published | property RefractionTexture;
Published | property RefractionTextureName;

Description

Properties

Published property Alpha;

This item has no description.

Published property BlendDst;

This item has no description.

Published property BlendSrc;

This item has no description.

Published property Depth;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property Mix;

This item has no description.

Published property OwnerObject;

This item has no description.

Published property RefractionTexture;

This item has no description.

Published property RefractionTextureName;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLSimpleGoochShader

Class TgxCustomGLSLSimpleGoochShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLSimpleGoochShader = class(TGXSLCustomShader)

Description

Custom class for Gooch Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleGoochShader

Overview

Fields

Private | FDiffuseColor: TgxColor;
Private | FWarmColor: TgxColor;
Private | FCoolColor: TgxColor;
Private | FSpecularColor: TgxColor;
Private | FAmbientColor: TgxColor;
Private | FDiffuseWarm: Single;
Private | FDiffuseCool: Single;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FBlendingMode: TgxBlendingModeEx;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetAmbientColor(AValue: TgxColor);
Private | procedure SetCoolColor(AValue: TgxColor);
Private | procedure SetDiffuseColor(AValue: TgxColor);
Private | procedure SetSpecularColor(AValue: TgxColor);
Private | procedure SetWarmColor(AValue: TgxColor);

Properties

Public | property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property BlendingMode: TgxBlendingModeEx read FBlendingMode write FBlendingMode default bmxOpaque;
Public | property CoolColor : TgxColor Read FCoolColor Write setCoolColor;
Public | property CoolFactor : Single Read FDiffuseCool Write FDiffuseCool;
Public | property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property WarmColor : TgxColor read FWarmColor Write setWarmColor;
Public | property WarmFactor : Single Read FDiffuseWarm Write FDiffuseWarm;

Description

Fields

Private FDiffuseColor: TgxColor;

This item has no description.

Private FWarmColor: TgxColor;

This item has no description.

Private FCoolColor: TgxColor;

This item has no description.

Private FSpecularColor: TgxColor;

This item has no description.

Private FAmbientColor: TgxColor;

This item has no description.

Private FDiffuseWarm: Single;

This item has no description.

Private FDiffuseCool: Single;

This item has no description.

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FBlendingMode: TgxBlendingModeEx;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetAmbientColor(AValue: TgxColor);

This item has no description.

Private procedure SetCoolColor(AValue: TgxColor);

This item has no description.

Private procedure SetDiffuseColor(AValue: TgxColor);

This item has no description.

Private procedure SetSpecularColor(AValue: TgxColor);

This item has no description.

Private procedure SetWarmColor(AValue: TgxColor);

This item has no description.

Properties

Public property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property BlendingMode: TgxBlendingModeEx read FBlendingMode write FBlendingMode default bmxOpaque;

This item has no description.

Public property CoolColor : TgxColor Read FCoolColor Write setCoolColor;

This item has no description.

Public property CoolFactor : Single Read FDiffuseCool Write FDiffuseCool;

This item has no description.

Public property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property WarmColor : TgxColor read FWarmColor Write setWarmColor;

This item has no description.

Public property WarmFactor : Single Read FDiffuseWarm Write FDiffuseWarm;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLSimpleGoochShader

Class TgxSLSimpleGoochShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLSimpleGoochShader = class(TgxCustomGLSLSimpleGoochShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLSimpleGoochShader.

Custom class for Gooch Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleGoochShader
  • TgxSLSimpleGoochShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property CoolColor;
Published | property CoolFactor;
Published | property DiffuseColor;
Published | property DiffuseFactor;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property WarmColor;
Published | property WarmFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property CoolColor;

This item has no description.

Published property CoolFactor;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularFactor;

This item has no description.

Published property WarmColor;

This item has no description.

Published property WarmFactor;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLFurShader

Class TgxCustomGLSLFurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLFurShader = class(TGXSLCustomShader)

Description

Custom class for Fur Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLFurShader

Overview

Fields

Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FCurrentPass: Integer;
Private | FPassCount: Single;
Private | FFurLength: Single;
Private | FMaxFurLength: Single;
Private | FFurScale: Single;
Private | FRandomFurLength: Boolean;
Private | FColorScale: TgxColor;
Private | FAmbient: TgxColor;
Private | FGravity: TgxCoordinates;
Private | FLightIntensity: Single;
Private | FMainTex: TgxTexture;
Private | FNoiseTex: TgxTexture;
Private | FNoiseTexName: TgxLibMaterialName;
Private | FMainTexName: TgxLibMaterialName;
Private | FBlendSrc: TgxBlendFunction;
Private | FBlendDst: TgxBlendFunction;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | function GetNoiseTexName: TgxLibMaterialName;
Private | procedure SetAmbient(AValue: TgxColor);
Private | procedure SetColorScale(AValue: TgxColor);
Private | procedure SetGravity(APosition:TgxCoordinates);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetNoiseTexName(const Value: TgxLibMaterialName);
Private | procedure SetNoiseTexTexture(const Value: TgxTexture);

Properties

Public | property Ambient: TgxColor read FAmbient write setAmbient;
Public | property BlendDst : TgxBlendFunction read FBlendDst write FBlendDst default bfOneMinusDstColor;
Public | property BlendSrc : TgxBlendFunction read FBlendSrc write FBlendSrc default bfSrcColor;
Public | property ColorScale: TgxColor read FColorScale Write setColorScale;
Public | property FurDensity: Single read FFurScale write FFurScale;
Public | property FurLength: Single read FFurLength write FFurLength;
Public | property Gravity : TgxCoordinates Read FGravity write setGravity;
Public | property LightIntensity : Single read FLightIntensity Write FLightIntensity;
Public | property MainTexture: TgxTexture read FMainTex write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property MaxFurLength: Single read FMaxFurLength write FMaxFurLength;
Public | property NoiseTexture: TgxTexture read FNoiseTex write SetNoiseTexTexture;
Public | property NoiseTextureName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;
Public | property PassCount: Single read FPassCount write FPassCount;
Public | property RandomFurLength : Boolean read FRandomFurLength Write FRandomFurLength;

Description

Fields

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FCurrentPass: Integer;

This item has no description.

Private FPassCount: Single;

This item has no description.

Private FFurLength: Single;

This item has no description.

Private FMaxFurLength: Single;

This item has no description.

Private FFurScale: Single;

This item has no description.

Private FRandomFurLength: Boolean;

This item has no description.

Private FColorScale: TgxColor;

This item has no description.

Private FAmbient: TgxColor;

This item has no description.

Private FGravity: TgxCoordinates;

This item has no description.

Private FLightIntensity: Single;

This item has no description.

Private FMainTex: TgxTexture;

This item has no description.

Private FNoiseTex: TgxTexture;

This item has no description.

Private FNoiseTexName: TgxLibMaterialName;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

This item has no description.

Private FBlendSrc: TgxBlendFunction;

This item has no description.

Private FBlendDst: TgxBlendFunction;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

Common stuff

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

FBlendEquation : TgxBlendEquation;

Private function GetNoiseTexName: TgxLibMaterialName;

This item has no description.

Private procedure SetAmbient(AValue: TgxColor);

This item has no description.

Private procedure SetColorScale(AValue: TgxColor);

This item has no description.

Private procedure SetGravity(APosition:TgxCoordinates);

This item has no description.

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetNoiseTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetNoiseTexTexture(const Value: TgxTexture);

This item has no description.

Properties

Public property Ambient: TgxColor read FAmbient write setAmbient;

This item has no description.

Public property BlendDst : TgxBlendFunction read FBlendDst write FBlendDst default bfOneMinusDstColor;

This item has no description.

Public property BlendSrc : TgxBlendFunction read FBlendSrc write FBlendSrc default bfSrcColor;

property BlendEquation : TBlendEquation read FBlendEquation write FBlendEquation default beMin;

Public property ColorScale: TgxColor read FColorScale Write setColorScale;

This item has no description.

Public property FurDensity: Single read FFurScale write FFurScale;

This item has no description.

Public property FurLength: Single read FFurLength write FFurLength;

This item has no description.

Public property Gravity : TgxCoordinates Read FGravity write setGravity;

This item has no description.

Public property LightIntensity : Single read FLightIntensity Write FLightIntensity;

This item has no description.

Public property MainTexture: TgxTexture read FMainTex write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property MaxFurLength: Single read FMaxFurLength write FMaxFurLength;

This item has no description.

Public property NoiseTexture: TgxTexture read FNoiseTex write SetNoiseTexTexture;

This item has no description.

Public property NoiseTextureName: TgxLibMaterialName read GetNoiseTexName write SetNoiseTexName;

This item has no description.

Public property PassCount: Single read FPassCount write FPassCount;

This item has no description.

Public property RandomFurLength : Boolean read FRandomFurLength Write FRandomFurLength;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLFurShader

Class TgxSLFurShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLFurShader = class(TgxCustomGLSLFurShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLFurShader.

Custom class for Fur Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLFurShader
  • TgxSLFurShader

Overview

Properties

Published | property Ambient;
Published | property BlendDst;
Published | property BlendSrc;
Published | property ColorScale;
Published | property FurDensity;
Published | property FurLength;
Published | property Gravity;
Published | property LightIntensity;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaxFurLength;
Published | property NoiseTexture;
Published | property NoiseTextureName;
Published | property PassCount;
Published | property RandomFurLength;

Description

Properties

Published property Ambient;

This item has no description.

Published property BlendDst;

This item has no description.

Published property BlendSrc;

This item has no description. Showing description inherited from TgxCustomGLSLFurShader.BlendSrc.

property BlendEquation : TBlendEquation read FBlendEquation write FBlendEquation default beMin;

Published property ColorScale;

This item has no description.

Published property FurDensity;

This item has no description.

Published property FurLength;

This item has no description.

Published property Gravity;

This item has no description.

Published property LightIntensity;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaxFurLength;

This item has no description.

Published property NoiseTexture;

This item has no description.

Published property NoiseTextureName;

This item has no description.

Published property PassCount;

This item has no description.

Published property RandomFurLength;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLIvoryShader

Class TgxCustomGLSLIvoryShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLIvoryShader = class(TGXSLCustomShader)

Description

Custom class for a shader that simulate Ivory Material

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLIvoryShader

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLIvoryShader

Class TgxSLIvoryShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLIvoryShader = class(TgxCustomGLSLIvoryShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLIvoryShader.

Custom class for a shader that simulate Ivory Material

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLIvoryShader
  • TgxSLIvoryShader


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLSimpleLatticeShader

Class TgxCustomGLSLSimpleLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLSimpleLatticeShader = class(TGXSLCustomShader)

Description

Custom class for a shader that simulate Lattice

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleLatticeShader

Overview

Fields

Private | FLatticeScale: TgxCoordinates2;
Private | FLatticeThreshold: TgxCoordinates2;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetLatticeScale(const Value: TgxCoordinates2);
Private | procedure SetLatticeThreshold(const Value: TgxCoordinates2);

Properties

Public | property LatticeScale: TgxCoordinates2 read FLatticeScale write SetLatticeScale;
Public | property LatticeThreshold: TgxCoordinates2 read FLatticeThreshold write SetLatticeThreshold;

Description

Fields

Private FLatticeScale: TgxCoordinates2;

This item has no description.

Private FLatticeThreshold: TgxCoordinates2;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetLatticeScale(const Value: TgxCoordinates2);

This item has no description.

Private procedure SetLatticeThreshold(const Value: TgxCoordinates2);

This item has no description.

Properties

Public property LatticeScale: TgxCoordinates2 read FLatticeScale write SetLatticeScale;

This item has no description.

Public property LatticeThreshold: TgxCoordinates2 read FLatticeThreshold write SetLatticeThreshold;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLLatticeShader

Class TgxCustomGLSLLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLLatticeShader = class(TgxCustomGLSLSimpleLatticeShader)

Description

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleLatticeShader
  • TgxCustomGLSLLatticeShader

Overview

Fields

Private | FAmbientColor: TgxColor;
Private | FDiffuseColor: TgxColor;
Private | FSpecularColor: TgxColor;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FMainTexture: TgxTexture;
Private | FMainTexName: TgxLibMaterialName;
Private | FSpecularPower: Single;
Private | FLightPower: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TgxColor);
Private | procedure SetDiffuseColor(AValue: TgxColor);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetSpecularColor(AValue: TgxColor);

Properties

Public | property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;
Public | property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;

Description

Fields

Private FAmbientColor: TgxColor;

This item has no description.

Private FDiffuseColor: TgxColor;

This item has no description.

Private FSpecularColor: TgxColor;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

This item has no description.

Private FSpecularPower: Single;

This item has no description.

Private FLightPower: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private procedure SetAmbientColor(AValue: TgxColor);

This item has no description.

Private procedure SetDiffuseColor(AValue: TgxColor);

This item has no description.

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TgxColor);

This item has no description.

Properties

Public property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;

This item has no description.

Public property LightPower: Single read FLightPower write FLightPower;

This item has no description.

Public property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;

This item has no description.

Public property SpecularPower: Single read FSpecularPower write FSpecularPower;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLSimpleLatticeShader

Class TgxSLSimpleLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLSimpleLatticeShader = class(TgxCustomGLSLSimpleLatticeShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLSimpleLatticeShader.

Custom class for a shader that simulate Lattice

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleLatticeShader
  • TgxSLSimpleLatticeShader

Overview

Properties

Published | property LatticeScale;
Published | property LatticeThreshold;

Description

Properties

Published property LatticeScale;

This item has no description.

Published property LatticeThreshold;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLLatticeShader

Class TgxSLLatticeShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLLatticeShader = class(TgxCustomGLSLLatticeShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLLatticeShader.

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSimpleLatticeShader
  • TgxCustomGLSLLatticeShader
  • TgxSLLatticeShader

Overview

Properties

Published | property AmbientColor;
Published | property DiffuseColor;
Published | property LatticeScale;
Published | property LatticeThreshold;
Published | property LightPower;
Published | property MainTexture;
Published | property SpecularColor;
Published | property SpecularPower;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property DiffuseColor;

This item has no description.

Published property LatticeScale;

This item has no description.

Published property LatticeThreshold;

This item has no description.

Published property LightPower;

This item has no description.

Published property MainTexture;

This item has no description.

Published property SpecularColor;

This item has no description.

Published property SpecularPower;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLSemShader

Class TgxCustomGLSLSemShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLSemShader = class(TGXSLCustomShader)

Description

Custom class for SEM Shader : Spherical Environment Mapping

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSemShader

Overview

Fields

Private | FAmbientColor: TgxColor;
Private | FSpecularColor: TgxColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FMainTexture: TgxTexture;
Private | FMainTexName: TgxLibMaterialName;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TgxColor);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetSpecularColor(AValue: TgxColor);

Properties

Public | property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

Description

Fields

Private FAmbientColor: TgxColor;

This item has no description.

Private FSpecularColor: TgxColor;

FDiffuseColor: TgxColor;

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

FSpecularPower: Single; FLightPower: Single;

Private procedure SetAmbientColor(AValue: TgxColor);

procedure SetDiffuseColor(AValue: TgxColor);

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TgxColor);

This item has no description.

Properties

Public property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;

property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLSemShader

Class TgxSLSemShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLSemShader = class(TgxCustomGLSLSemShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLSemShader.

Custom class for SEM Shader : Spherical Environment Mapping

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLSemShader
  • TgxSLSemShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property DiffuseFactor;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property SpecularColor;
Published | property SpecularFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property SpecularColor;

property DiffuseColor;

Published property SpecularFactor;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLToonShader

Class TgxCustomGLSLToonShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLToonShader = class(TGXSLCustomShader)

Description

Custom class for Toon Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLToonShader

Overview

Fields

Private | FHighlightColor: TgxColor;
Private | FMidColor: TgxColor;
Private | FLightenShadowColor: TgxColor;
Private | FDarkenShadowColor: TgxColor;
Private | FOutlineColor: TgxColor;
Private | FHighlightSize: Single;
Private | FMidSize: Single;
Private | FShadowSize: Single;
Private | FOutlineWidth: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | procedure SetDarkenShadowColor(AValue: TgxColor);
Private | procedure SetHighLightColor(AValue: TgxColor);
Private | procedure SetLightenShadowColor(AValue: TgxColor);
Private | procedure SetMidColor(AValue: TgxColor);
Private | procedure SetOutlineColor(AValue: TgxColor);

Properties

Public | property DarkenShadowrColor : TgxColor Read FDarkenShadowColor Write setDarkenShadowColor;
Public | property HighlightColor : TgxColor read FHighlightColor Write setHighlightColor;
Public | property HighlightSize : Single read FHighlightSize write FHighlightSize;
Public | property LightenShadowColor : TgxColor Read FLightenShadowColor Write setLightenShadowColor;
Public | property MidColor : TgxColor read FMidColor Write setMidColor;
Public | property MidSize : Single read FMidSize write FMidSize;
Public | property OutlinetColor : TgxColor Read FOutlineColor Write setOutlineColor;
Public | property OutlineWidth : Single read FOutlineWidth write FOutlineWidth;
Public | property ShadowSize : Single read FShadowSize write FShadowSize;

Description

Fields

Private FHighlightColor: TgxColor;

This item has no description.

Private FMidColor: TgxColor;

This item has no description.

Private FLightenShadowColor: TgxColor;

This item has no description.

Private FDarkenShadowColor: TgxColor;

This item has no description.

Private FOutlineColor: TgxColor;

This item has no description.

Private FHighlightSize: Single;

This item has no description.

Private FMidSize: Single;

This item has no description.

Private FShadowSize: Single;

This item has no description.

Private FOutlineWidth: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private procedure SetDarkenShadowColor(AValue: TgxColor);

This item has no description.

Private procedure SetHighLightColor(AValue: TgxColor);

This item has no description.

Private procedure SetLightenShadowColor(AValue: TgxColor);

This item has no description.

Private procedure SetMidColor(AValue: TgxColor);

This item has no description.

Private procedure SetOutlineColor(AValue: TgxColor);

This item has no description.

Properties

Public property DarkenShadowrColor : TgxColor Read FDarkenShadowColor Write setDarkenShadowColor;

This item has no description.

Public property HighlightColor : TgxColor read FHighlightColor Write setHighlightColor;

This item has no description.

Public property HighlightSize : Single read FHighlightSize write FHighlightSize;

This item has no description.

Public property LightenShadowColor : TgxColor Read FLightenShadowColor Write setLightenShadowColor;

This item has no description.

Public property MidColor : TgxColor read FMidColor Write setMidColor;

This item has no description.

Public property MidSize : Single read FMidSize write FMidSize;

This item has no description.

Public property OutlinetColor : TgxColor Read FOutlineColor Write setOutlineColor;

This item has no description.

Public property OutlineWidth : Single read FOutlineWidth write FOutlineWidth;

This item has no description.

Public property ShadowSize : Single read FShadowSize write FShadowSize;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLToonShader

Class TgxSLToonShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLToonShader = class(TgxCustomGLSLToonShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLToonShader.

Custom class for Toon Shader

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLToonShader
  • TgxSLToonShader

Overview

Properties

Published | property DarkenShadowrColor;
Published | property HighlightColor;
Published | property HighlightSize;
Published | property LightenShadowColor;
Published | property MidColor;
Published | property MidSize;
Published | property OutlinetColor;
Published | property OutlineWidth;
Published | property ShadowSize;

Description

Properties

Published property DarkenShadowrColor;

This item has no description.

Published property HighlightColor;

This item has no description.

Published property HighlightSize;

This item has no description.

Published property LightenShadowColor;

This item has no description.

Published property MidColor;

This item has no description.

Published property MidSize;

This item has no description.

Published property OutlinetColor;

This item has no description.

Published property OutlineWidth;

This item has no description.

Published property ShadowSize;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxCustomGLSLVertexDisplacementShader

Class TgxCustomGLSLVertexDisplacementShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxCustomGLSLVertexDisplacementShader = class(TGXSLCustomShader)

Description

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLVertexDisplacementShader

Overview

Fields

Private | FAmbientColor: TgxColor;
Private | FSpecularColor: TgxColor;
Private | FAmbientFactor: Single;
Private | FDiffuseFactor: Single;
Private | FSpecularFactor: Single;
Private | FMaterialLibrary: TgxAbstractMaterialLibrary;
Private | FMainTexture: TgxTexture;
Private | FMainTexName: TgxLibMaterialName;
Private | FElapsedTime: Single;
Private | FNoise: Single;
Private | FDisplacementScale: Single;
Private | FNoiseScale: Single;
Private | FTurbulenceFactor: Single;
Private | FNoisePeriod: Single;
Private | FTimeFactor: Single;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Private | function GetMainTexName: TgxLibMaterialName;
Private | function GetMaterialLibrary: TgxAbstractMaterialLibrary;
Private | procedure SetAmbientColor(AValue: TgxColor);
Private | procedure SetMainTexName(const Value: TgxLibMaterialName);
Private | procedure SetMainTexTexture(const Value: TgxTexture);
Private | procedure SetSpecularColor(AValue: TgxColor);

Properties

Public | property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;
Public | property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;
Public | property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;
Public | property DisplacementScale : Single read FDisplacementScale write FDisplacementScale;
Public | property ElapsedTime: Single read FElapsedTime write FElapsedTime;
Public | property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;
Public | property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;
Public | property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;
Public | property NoiseFactor : Single read FNoise write FNoise;
Public | property NoisePeriod : Single read FNoisePeriod write FNoisePeriod;
Public | property NoiseScale : Single read FNoiseScale write FNoiseScale;
Public | property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;
Public | property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;
Public | property TimeFactor : Single read FTimeFactor write FTimeFactor;
Public | property TurbulenceFactor : Single read FTurbulenceFactor write FTurbulenceFactor;

Description

Fields

Private FAmbientColor: TgxColor;

This item has no description.

Private FSpecularColor: TgxColor;

FDiffuseColor: TgxColor;

Private FAmbientFactor: Single;

This item has no description.

Private FDiffuseFactor: Single;

This item has no description.

Private FSpecularFactor: Single;

This item has no description.

Private FMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private FMainTexture: TgxTexture;

This item has no description.

Private FMainTexName: TgxLibMaterialName;

This item has no description.

Private FElapsedTime: Single;

This item has no description.

Private FNoise: Single;

This item has no description.

Private FDisplacementScale: Single;

This item has no description.

Private FNoiseScale: Single;

This item has no description.

Private FTurbulenceFactor: Single;

This item has no description.

Private FNoisePeriod: Single;

This item has no description.

Private FTimeFactor: Single;

This item has no description.

Methods

Public constructor Create(AOwner : TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetMainTexName: TgxLibMaterialName;

This item has no description.

Private function GetMaterialLibrary: TgxAbstractMaterialLibrary;

This item has no description.

Private procedure SetAmbientColor(AValue: TgxColor);

procedure SetDiffuseColor(AValue: TgxColor);

Private procedure SetMainTexName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMainTexTexture(const Value: TgxTexture);

This item has no description.

Private procedure SetSpecularColor(AValue: TgxColor);

This item has no description.

Properties

Public property AmbientColor : TgxColor Read FAmbientColor Write setAmbientColor;

This item has no description.

Public property AmbientFactor : Single Read FAmbientFactor Write FAmbientFactor;

This item has no description.

Public property DiffuseFactor : Single Read FDiffuseFactor Write FDiffuseFactor;

This item has no description.

Public property DisplacementScale : Single read FDisplacementScale write FDisplacementScale;

This item has no description.

Public property ElapsedTime: Single read FElapsedTime write FElapsedTime;

This item has no description.

Public property MainTexture: TgxTexture read FMainTexture write SetMainTexTexture;

This item has no description.

Public property MainTextureName: TgxLibMaterialName read GetMainTexName write SetMainTexName;

This item has no description.

Public property MaterialLibrary: TgxAbstractMaterialLibrary read getMaterialLibrary write SetMaterialLibrary;

This item has no description.

Public property NoiseFactor : Single read FNoise write FNoise;

This item has no description.

Public property NoisePeriod : Single read FNoisePeriod write FNoisePeriod;

This item has no description.

Public property NoiseScale : Single read FNoiseScale write FNoiseScale;

This item has no description.

Public property SpecularColor : TgxColor Read FSpecularColor Write setSpecularColor;

property DiffuseColor : TgxColor read FDiffuseColor Write setDiffuseColor;

Public property SpecularFactor : Single Read FSpecularFactor Write FSpecularFactor;

This item has no description.

Public property TimeFactor : Single read FTimeFactor write FTimeFactor;

This item has no description.

Public property TurbulenceFactor : Single read FTurbulenceFactor write FTurbulenceFactor;


GXSysHelp v.2.5: GXSL.ShapeShaders: Class TgxSLVertexDisplacementShader

Class TgxSLVertexDisplacementShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.ShapeShaders

Declaration

type TgxSLVertexDisplacementShader = class(TgxCustomGLSLVertexDisplacementShader)

Description

This item has no description. Showing description inherited from TgxCustomGLSLVertexDisplacementShader.

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxCustomShader
  • TGXSLCustomShader
  • TgxCustomGLSLVertexDisplacementShader
  • TgxSLVertexDisplacementShader

Overview

Properties

Published | property AmbientColor;
Published | property AmbientFactor;
Published | property DiffuseFactor;
Published | property DisplacementScale;
Published | property ElapsedTime;
Published | property MainTexture;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NoiseFactor;
Published | property NoisePeriod;
Published | property NoiseScale;
Published | property SpecularColor;
Published | property SpecularFactor;
Published | property TimeFactor;
Published | property TurbulenceFactor;

Description

Properties

Published property AmbientColor;

This item has no description.

Published property AmbientFactor;

This item has no description.

Published property DiffuseFactor;

This item has no description.

Published property DisplacementScale;

This item has no description.

Published property ElapsedTime;

This item has no description.

Published property MainTexture;

This item has no description.

Published property MainTextureName;

This item has no description.

Published property MaterialLibrary;

This item has no description.

Published property NoiseFactor;

This item has no description.

Published property NoisePeriod;

This item has no description.

Published property NoiseScale;

This item has no description.

Published property SpecularColor;

property DiffuseColor;

Published property SpecularFactor;

This item has no description.

Published property TimeFactor;

This item has no description.

Published property TurbulenceFactor;


GXSysHelp v.2.5: GXSL.TextureShaders

Unit GXSL.TextureShaders

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • System.Classes
  • System.SysUtils
  • GXS.Scene
  • GXS.Context
  • GXS.Texture
  • GLScene.VectorTypes
  • GXS.XOpenGL
  • GLScene.VectorGeometry
  • GXS.Color
  • GXS.Material
  • GLScene.Strings
  • GXS.VectorFileObjects
  • GXS.State
  • GXS.PersistentClasses
  • GXS.Coordinates
  • GXS.TextureCombiners
  • GXS.RenderContextInfo
  • GXS.ImageUtils

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxShaderTextureSharingMaterial |
Class TgxShaderTextureSharingMaterials |
Class TgxShaderTextureSharing |
Class TgxTexCombineShader |


GXSysHelp v.2.5: GXSL.TextureShaders: Class TgxShaderTextureSharingMaterial

Class TgxShaderTextureSharingMaterial

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.TextureShaders

Declaration

type TgxShaderTextureSharingMaterial = class(TgxInterfacedCollectionItem, IgxMaterialLibrarySupported)

Description

This item has no description.

Hierarchy

  • TgxInterfacedCollectionItem
  • TgxShaderTextureSharingMaterial

Overview

Fields

Private | FTextureMatrix: TMatrix4f;
Private | FNeedToUpdateTextureMatrix: Boolean;
Private | FTextureMatrixIsUnitary: Boolean;
Private | FLibMaterial: TgxLibMaterial;
Private | FTexOffset: TgxCoordinates2;
Private | FTexScale: TgxCoordinates2;
Private | FBlendingMode: TgxBlendingMode;
Private | FSpecular: TgxColor;
Private | FAmbient: TgxColor;
Private | FDiffuse: TgxColor;
Private | FEmission: TgxColor;
Private | FShininess: TgxShininess;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FLibMaterialName: TgxLibMaterialName;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Private | function GetTextureMatrix: TMatrix4f;
Private | function GetTextureMatrixIsUnitary: Boolean;
Public | procedure Apply(var rci: TgxRenderContextInfo);
Public | procedure UnApply(var rci: TgxRenderContextInfo);
Private | procedure SetAmbient(const Value: TgxColor);
Private | procedure SetBlendingMode(const Value: TgxBlendingMode);
Private | procedure SetDiffuse(const Value: TgxColor);
Private | procedure SetEmission(const Value: TgxColor);
Private | procedure SetLibMaterial(const Value: TgxLibMaterial);
Private | procedure SetLibMaterialName(const Value: TgxLibMaterialName);
Private | procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);
Private | procedure SetShininess(const Value: TgxShininess);
Private | procedure SetSpecular(const Value: TgxColor);
Private | procedure SetTexOffset(const Value: TgxCoordinates2);
Private | procedure SetTexScale(const Value: TgxCoordinates2);

Properties

Published | property Ambient: TgxColor read FAmbient write SetAmbient;
Published | property BlendingMode: TgxBlendingMode read FBlendingMode write SetBlendingMode;
Published | property Diffuse: TgxColor read FDiffuse write SetDiffuse;
Published | property Emission: TgxColor read FEmission write SetEmission;
Public | property LibMaterial: TgxLibMaterial read FLibMaterial write SetLibMaterial;
Published | property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Shininess: TgxShininess read FShininess write SetShininess;
Published | property Specular: TgxColor read FSpecular write SetSpecular;
Published | property TexOffset: TgxCoordinates2 read FTexOffset write SetTexOffset;
Published | property TexScale: TgxCoordinates2 read FTexScale write SetTexScale;
Public | property TextureMatrix: TMatrix4f read GetTextureMatrix;
Public | property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;

Description

Fields

Private FTextureMatrix: TMatrix4f;

This item has no description.

Private FNeedToUpdateTextureMatrix: Boolean;

This item has no description.

Private FTextureMatrixIsUnitary: Boolean;

This item has no description.

Private FLibMaterial: TgxLibMaterial;

This item has no description.

Private FTexOffset: TgxCoordinates2;

This item has no description.

Private FTexScale: TgxCoordinates2;

This item has no description.

Private FBlendingMode: TgxBlendingMode;

This item has no description.

Private FSpecular: TgxColor;

This item has no description.

Private FAmbient: TgxColor;

This item has no description.

Private FDiffuse: TgxColor;

This item has no description.

Private FEmission: TgxColor;

This item has no description.

Private FShininess: TgxShininess;

This item has no description.

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FLibMaterialName: TgxLibMaterialName;

This item has no description.

Methods

Public constructor Create(Collection: TCollection); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Private function GetTextureMatrix: TMatrix4f;

This item has no description.

Private function GetTextureMatrixIsUnitary: Boolean;

This item has no description.

Public procedure Apply(var rci: TgxRenderContextInfo);

This item has no description.

Public procedure UnApply(var rci: TgxRenderContextInfo);

This item has no description.

Private procedure SetAmbient(const Value: TgxColor);

This item has no description.

Private procedure SetBlendingMode(const Value: TgxBlendingMode);

This item has no description.

Private procedure SetDiffuse(const Value: TgxColor);

This item has no description.

Private procedure SetEmission(const Value: TgxColor);

This item has no description.

Private procedure SetLibMaterial(const Value: TgxLibMaterial);

This item has no description.

Private procedure SetLibMaterialName(const Value: TgxLibMaterialName);

This item has no description.

Private procedure SetMaterialLibrary(const Value: TgxMaterialLibrary);

This item has no description.

Private procedure SetShininess(const Value: TgxShininess);

This item has no description.

Private procedure SetSpecular(const Value: TgxColor);

This item has no description.

Private procedure SetTexOffset(const Value: TgxCoordinates2);

This item has no description.

Private procedure SetTexScale(const Value: TgxCoordinates2);

This item has no description.

Properties

Published property Ambient: TgxColor read FAmbient write SetAmbient;

This item has no description.

Published property BlendingMode: TgxBlendingMode read FBlendingMode write SetBlendingMode;

This item has no description.

Published property Diffuse: TgxColor read FDiffuse write SetDiffuse;

This item has no description.

Published property Emission: TgxColor read FEmission write SetEmission;

This item has no description.

Public property LibMaterial: TgxLibMaterial read FLibMaterial write SetLibMaterial;

This item has no description.

Published property LibMaterialName: TgxLibMaterialName read FLibMaterialName write SetLibMaterialName;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

This item has no description.

Published property Shininess: TgxShininess read FShininess write SetShininess;

This item has no description.

Published property Specular: TgxColor read FSpecular write SetSpecular;

This item has no description.

Published property TexOffset: TgxCoordinates2 read FTexOffset write SetTexOffset;

This item has no description.

Published property TexScale: TgxCoordinates2 read FTexScale write SetTexScale;

This item has no description.

Public property TextureMatrix: TMatrix4f read GetTextureMatrix;

This item has no description.

Public property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;


GXSysHelp v.2.5: GXSL.TextureShaders: Class TgxShaderTextureSharingMaterials

Class TgxShaderTextureSharingMaterials

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.TextureShaders

Declaration

type TgxShaderTextureSharingMaterials = class(TOwnedCollection)

Description

This item has no description.

Hierarchy

  • TObject
  • TPersistent
  • TCollection
  • TOwnedCollection
  • TgxShaderTextureSharingMaterials

Overview

Methods

Public | constructor Create(AOwner: TgxShaderTextureSharing);
Public | function Add: TgxShaderTextureSharingMaterial;

Properties

Public property Items[const AIndex: Integer]: TgxShaderTextureSharingMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TgxShaderTextureSharing);

This item has no description.

Public function Add: TgxShaderTextureSharingMaterial;

This item has no description.

Properties

Public property Items[const AIndex: Integer]: TgxShaderTextureSharingMaterial read GetItems write SetItems;


GXSysHelp v.2.5: GXSL.TextureShaders: Class TgxShaderTextureSharing

Class TgxShaderTextureSharing

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.TextureShaders

Declaration

type TgxShaderTextureSharing = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxShaderTextureSharing

Overview

Fields

Private | FMaterials: TgxShaderTextureSharingMaterials;
Private | FCurrentPass: Integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddLibMaterial(const ALibMaterial: TgxLibMaterial): TgxShaderTextureSharingMaterial;
Public | function FindLibMaterial(const ALibMaterial: TgxLibMaterial): TgxShaderTextureSharingMaterial;
Private | procedure SetMaterials(const Value: TgxShaderTextureSharingMaterials);

Properties

Published property Materials: TgxShaderTextureSharingMaterials read FMaterials write SetMaterials;

Description

Fields

Private FMaterials: TgxShaderTextureSharingMaterials;

This item has no description.

Private FCurrentPass: Integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function AddLibMaterial(const ALibMaterial: TgxLibMaterial): TgxShaderTextureSharingMaterial;

This item has no description.

Public function FindLibMaterial(const ALibMaterial: TgxLibMaterial): TgxShaderTextureSharingMaterial;

This item has no description.

Private procedure SetMaterials(const Value: TgxShaderTextureSharingMaterials);

This item has no description.

Properties

Published property Materials: TgxShaderTextureSharingMaterials read FMaterials write SetMaterials;


GXSysHelp v.2.5: GXSL.TextureShaders: Class TgxTexCombineShader

Class TgxTexCombineShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.TextureShaders

Declaration

type TgxTexCombineShader = class(TgxShader)

Description

A shader that can setup the texture combiner.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxTexCombineShader

Overview

Fields

Private | FCombiners: TStringList;
Private | FCommandCache: TgxCombinerCache;
Private | FCombinerIsValid: Boolean;
Private | FDesignTimeEnabled: Boolean;
Private | FMaterialLibrary: TgxMaterialLibrary;
Private | FLibMaterial3Name: TgxLibMaterialName;
Private | CurrentLibMaterial3: TgxLibMaterial;
Private | FLibMaterial4Name: TgxLibMaterialName;
Private | CurrentLibMaterial4: TgxLibMaterial;
Private | FApplied3: Boolean;
Private | FApplied4: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;

Properties

Published | property Combiners: TStringList read FCombiners write SetCombiners;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property LibMaterial3Name: TgxLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;
Published | property LibMaterial4Name: TgxLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;
Published | property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Fields

Private FCombiners: TStringList;

This item has no description.

Private FCommandCache: TgxCombinerCache;

This item has no description.

Private FCombinerIsValid: Boolean;

This item has no description.

Private FDesignTimeEnabled: Boolean;

to avoid reparsing invalid stuff

Private FMaterialLibrary: TgxMaterialLibrary;

This item has no description.

Private FLibMaterial3Name: TgxLibMaterialName;

This item has no description.

Private CurrentLibMaterial3: TgxLibMaterial;

This item has no description.

Private FLibMaterial4Name: TgxLibMaterialName;

This item has no description.

Private CurrentLibMaterial4: TgxLibMaterial;

This item has no description.

Private FApplied3: Boolean;

This item has no description.

Private FApplied4: Boolean;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

This item has no description.

Public procedure NotifyChange(Sender: TObject); override;

This item has no description. Showing description inherited from TgxShader.NotifyChange.

Subclasses should invoke this function when shader properties are altered. This procedure can also be used to reset/recompile the shader.

Properties

Published property Combiners: TStringList read FCombiners write SetCombiners;

This item has no description.

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;

This item has no description.

Published property LibMaterial3Name: TgxLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;

This item has no description.

Published property LibMaterial4Name: TgxLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;

This item has no description.

Published property MaterialLibrary: TgxMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;


GXSysHelp v.2.5: GXSL.UserShader

Unit GXSL.UserShader

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

A shader that passes control of the DoApply and DoUnApply methods through published events. This component is designed to make it a little easier to implement a customized shader. Be sure to keep the shader balanced by returning the OpenGL state to how you found it.

Uses

  • System.Classes
  • GXS.Material
  • GXS.RenderContextInfo

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxUserShader |

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TgxRenderContextInfo) of Object;
TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TgxRenderContextInfo; var Continue : Boolean) of Object;

Description

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TgxRenderContextInfo) of Object;

This item has no description.

TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TgxRenderContextInfo; var Continue : Boolean) of Object;


GXSysHelp v.2.5: GXSL.UserShader: Class TgxUserShader

Class TgxUserShader

Description
Hierarchy
Fields
Methods
Properties

Unit

GXSL.UserShader

Declaration

type TgxUserShader = class(TgxShader)

Description

This item has no description. Showing description inherited from TgxShader.

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TgxUpdateAbleComponent
  • TgxShader
  • TgxUserShader

Overview

Fields

Private | FPass: Integer;
Private | FOnDoApply: TOnDoApplyEvent;
Private | FOnDoUnApply: TOnDoUnApplyEvent;

Properties

Published | property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;
Published | property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;
Published | property ShaderStyle;

Description

Fields

Private FPass: Integer;

This item has no description.

Private FOnDoApply: TOnDoApplyEvent;

This item has no description.

Private FOnDoUnApply: TOnDoUnApplyEvent;

This item has no description.

Properties

Published property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;

This item has no description.

Published property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;

This item has no description.

Published property ShaderStyle;

This item has no description. Showing description inherited from TgxShader.ShaderStyle.

Shader application style (default is ssLowLevel).


GXSysHelp v.2.5: omSailSurface

Unit omSailSurface

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Classes
  • System.Math.Vectors
  • System.Threading
  • System.Types
  • System.Generics.Collections
  • FMX.Types3D
  • FMX.Types
  • FMX.Controls3D
  • FMX.Objects3D
  • FMX.MaterialSources

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TSailParams |
Class TomSailSurface |

Functions and Procedures

function CalcQuadraticInterpolation(const x0, y0, x1, y1, x2, y2: Single; const x: Single; var y: Single): boolean;
procedure Register;

Types

TPointF_Array = array of System.Types.TPointF;
TSailShape = (...);

Description

Functions and Procedures

function CalcQuadraticInterpolation(const x0, y0, x1, y1, x2, y2: Single; const x: Single; var y: Single): boolean;

Quadratic interpolation with 3 points

procedure Register;

This item has no description.

Types

TPointF_Array = array of System.Types.TPointF;

————————————————————————– Sail construction params

ˆ h ˆ h ˆ h | Main | Simetric | Jib Ht +—-+ Ht +—+ Lt Ht +—+ | Lt \ / | \ |Lt \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ +———–+ +—————–+ +———-+ | Lm \ / | Lm \ | Lm \ | | | | | | \ | \ | | | | Lx \ | | \ | / Hx +————–+ <– h of max chord | \ | | | | ____/ 0 | Lb | | 0 | Lb | 0 | ____/ —-+————–+–> L -+——–+——–+–> L —-+___/————-> L Lb nh subdivisions in height nl subdivisions in chord —————————————————————————

TSailShape = (...);

This item has no description.

Values
  • ShapeMain
  • ShapeSimetric
  • ShapeJib


GXSysHelp v.2.5: omSailSurface: Record TSailParams

Record TSailParams

Description
Hierarchy
Fields
Methods
Properties

Unit

omSailSurface

Declaration

type TSailParams = record

Description

This item has no description.

Overview

Fields

Public | Lb: Single;
Public | Lt: Single;
Public | Lm: Single;
Public | Ht: Single;
Public | Hx: Single;
Public | Lx: Single;

Methods

Public function GetSailChord(aType: TSailShape; const H: Single): Single;

Description

Fields

Public Lb: Single;

Sail w/ quadratic leech

Public Lt: Single;

sail chord at the bottom

Public Lm: Single;

chord at the top

Public Ht: Single;

chord at the middle ( for a quadratic leech )

Public Hx: Single;

sail height for Jib Shape only

Public Lx: Single;

height of Jib max chord

Methods

Public function GetSailChord(aType: TSailShape; const H: Single): Single;

Jib max chord NsubH:integer; // subdivisions in height default = 16hx8w NsubL:integer; // subdivisions in chord chord at a certain height ( H between 0 and Ht )


GXSysHelp v.2.5: omSailSurface: Class TomSailSurface

Class TomSailSurface

Description
Hierarchy
Fields
Methods
Properties

Unit

omSailSurface

Declaration

type TomSailSurface = class(TPlane)

Description

TomSailSurface morphs a TPlane grid into a triangular sail with camber ( or any other polygonal Shape)

Hierarchy

  • TPlane
  • TomSailSurface

Overview

Fields

Private | fSailShape: TSailShape;
Private | fVersion: integer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Altura(P: TPoint3D): Single;
Private | function GetChordBottom: Single;
Private | function GetChordMid: Single;
Private | function GetChordTop: Single;
Private | function GetChordX: Single;
Private | function GetHeightX: Single;
Private | function GetSailHeight: Single;
Public | procedure Render; override;
Public | procedure SetMeshWith2Dline(aPtArray: TPointF_Array);
Public | procedure SetSailParams(aSailParams: TSailParams);
Private | procedure CalcSailSurfaceMesh;
Private | procedure SetChordBottom(const Value: Single);
Private | procedure SetChordMid(const Value: Single);
Private | procedure SetChordTop(const Value: Single);
Private | procedure SetChordX(const Value: Single);
Private | procedure SetHeightX(const Value: Single);
Private | procedure SetSailHeight(const Value: Single);
Private | procedure SetSailShape(const Value: TSailShape);
Private | procedure setVersion(const Value: integer);

Properties

Published | property CamberRight: boolean read fCamberRight write fCamberRight;
Published | property ChordBottom: Single read GetChordBottom write SetChordBottom;
Published | property ChordMid: Single read GetChordMid write SetChordMid;
Published | property ChordTop: Single read GetChordTop write SetChordTop;
Published | property ChordX: Single read GetChordX write SetChordX;
Published | property HeightX: Single read GetHeightX write SetHeightX;
Published | property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;
Published | property SailHeight: Single read GetSailHeight write SetSailHeight;
Published | property SailShape: TSailShape read fSailShape write SetSailShape default ShapeMain;
Published | property ShowLines: boolean read fShowlines write fShowlines;
Published | property UseTasks: boolean read fUseTasks write fUseTasks;
Published | property version: integer read fVersion write setVersion;

Description

Fields

Private fSailShape: TSailShape;

This item has no description.

Private fVersion: integer;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Altura(P: TPoint3D): Single;

Property Data; //om: publica

Private function GetChordBottom: Single;

This item has no description.

Private function GetChordMid: Single;

This item has no description.

Private function GetChordTop: Single;

This item has no description.

Private function GetChordX: Single;

This item has no description.

Private function GetHeightX: Single;

This item has no description.

Private function GetSailHeight: Single;

This item has no description.

Public procedure Render; override;

This item has no description.

Public procedure SetMeshWith2Dline(aPtArray: TPointF_Array);

This item has no description.

Public procedure SetSailParams(aSailParams: TSailParams);

Om: calc wave amplitude on a point

Private procedure CalcSailSurfaceMesh;

This item has no description.

Private procedure SetChordBottom(const Value: Single);

This item has no description.

Private procedure SetChordMid(const Value: Single);

This item has no description.

Private procedure SetChordTop(const Value: Single);

This item has no description.

Private procedure SetChordX(const Value: Single);

This item has no description.

Private procedure SetHeightX(const Value: Single);

This item has no description.

Private procedure SetSailHeight(const Value: Single);

This item has no description.

Private procedure SetSailShape(const Value: TSailShape);

This item has no description.

Private procedure setVersion(const Value: integer);

This item has no description.

Properties

Published property CamberRight: boolean read fCamberRight write fCamberRight;

main sail, jib or simetric shape

Published property ChordBottom: Single read GetChordBottom write SetChordBottom;

This item has no description.

Published property ChordMid: Single read GetChordMid write SetChordMid;

This item has no description.

Published property ChordTop: Single read GetChordTop write SetChordTop;

This item has no description.

Published property ChordX: Single read GetChordX write SetChordX;

This item has no description.

Published property HeightX: Single read GetHeightX write SetHeightX;

Jib style only

Published property MaterialLines: TColorMaterialSource read fMaterialLignes write fMaterialLignes;

This item has no description.

Published property SailHeight: Single read GetSailHeight write SetSailHeight;

This item has no description.

Published property SailShape: TSailShape read fSailShape write SetSailShape default ShapeMain;

This item has no description.

Published property ShowLines: boolean read fShowlines write fShowlines;

This item has no description.

Published property UseTasks: boolean read fUseTasks write fUseTasks;

This item has no description.

Published property version: integer read fVersion write setVersion;


GXSysHelp v.2.5: OpenGXS.InitFMX

Unit OpenGXS.InitFMX

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.OpenGL
  • Winapi.OpenGLext
  • Winapi.Windows
  • FMX.Forms

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxOpenGL |
Class TgxShader |
Class TgxShaderV |
Class TgxShaderG |
Class TgxShaderF |
Class TgxProgram |
Class TgxBuffer |
Class TgxBufferV |
Class TgxBufferI |
Class TgxBufferU |
Class TgxArray |

Variables

GXOpenGL: TgxOpenGL;

Description

Variables

GXOpenGL: TgxOpenGL;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxOpenGL

Class TgxOpenGL

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxOpenGL = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TgxOpenGL

Overview

Fields

Private | CommonCustomForm: TCommonCustomForm;
Private | _WND: HWND;
Private | _DC: HDC;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | class function DefaultPFD: TPixelFormatDescriptor;
Public | procedure ApplyPixelFormat(const DC_: HDC);
Public | procedure BeginGL;
Public | procedure EndGL;
Public | procedure InitOpenGL;

Properties

Public | property PFD: TPixelFormatDescriptor read _PFD write SetPFD;
Public | property PFI: Integer read _PFI write SetPFI;
Public | property RC: HGLRC read _RC;

Description

Fields

Private CommonCustomForm: TCommonCustomForm;

This item has no description.

Private _WND: HWND;

This item has no description.

Private _DC: HDC;

This item has no description.

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public class function DefaultPFD: TPixelFormatDescriptor;

This item has no description.

Public procedure ApplyPixelFormat(const DC_: HDC);

This item has no description.

Public procedure BeginGL;

This item has no description.

Public procedure EndGL;

This item has no description.

Public procedure InitOpenGL;

This item has no description.

Properties

Public property PFD: TPixelFormatDescriptor read _PFD write SetPFD;

This item has no description.

Public property PFI: Integer read _PFI write SetPFI;

This item has no description.

Public property RC: HGLRC read _RC;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxShader

Class TgxShader

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxShader = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader

Overview

Methods

Public | constructor Create(const Kind_: GLenum);
Public | destructor Destroy; override;
Public | procedure SetSource(const Source_: String);

Properties

Public property ID: GLuint read _ID;

Description

Methods

Public constructor Create(const Kind_: GLenum);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure SetSource(const Source_: String);

This item has no description.

Properties

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxShaderV

Class TgxShaderV

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxShaderV = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxShaderG

Class TgxShaderG

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxShaderG = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderG

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxShaderF

Class TgxShaderF

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxShaderF = class(TgxShader)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxShader
  • TgxShaderF

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxProgram

Class TgxProgram

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxProgram = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxProgram

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure Attach(const Shader_: TgxShader);
Public | procedure Detach(const Shader_: TgxShader);
Public | procedure Link;
Public | procedure Use;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Attach(const Shader_: TgxShader);

This item has no description.

Public procedure Detach(const Shader_: TgxShader);

This item has no description.

Public procedure Link;

This item has no description.

Public procedure Use;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxBuffer

Class TgxBuffer

Description
Hierarchy
Nested Types
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxBuffer<_TYPE_:record> = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer

Overview

Nested Types

Public _PValue_ = ˆ_TYPE_;

Methods

Public | constructor Create(const Kind_: GLenum);
Public | destructor Destroy; override;
Public | procedure Bind;
Public | procedure Map;
Public | procedure Unbind;
Public | procedure Unmap;

Properties

Public | property Count: Integer read _Count write SetCount;
Public | property ID: GLuint read _ID;

Description

Nested Types

Public _PValue_ = ˆ_TYPE_;

This item has no description.

Methods

Public constructor Create(const Kind_: GLenum);

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Bind;

This item has no description.

Public procedure Map;

This item has no description.

Public procedure Unbind;

This item has no description.

Public procedure Unmap;

This item has no description.

Properties

Public property Count: Integer read _Count write SetCount;

This item has no description.

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxBufferV

Class TgxBufferV

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxBufferV<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferV

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxBufferI

Class TgxBufferI

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxBufferI<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferI

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxBufferU

Class TgxBufferU

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxBufferU<_TYPE_:record> = class(TgxBuffer<_TYPE_>)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxBuffer
  • TgxBufferU

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;


GXSysHelp v.2.5: OpenGXS.InitFMX: Class TgxArray

Class TgxArray

Description
Hierarchy
Fields
Methods
Properties

Unit

OpenGXS.InitFMX

Declaration

type TgxArray = class(TObject)

Description

———————————————————————–

Hierarchy

  • TObject
  • TgxArray

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure BeginBind;
Public | procedure EndBind;

Properties

Public property ID: GLuint read _ID;

Description

Methods

Public constructor Create;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure BeginBind;

This item has no description.

Public procedure EndBind;

This item has no description.

Properties

Public property ID: GLuint read _ID;


GXSysHelp v.2.5: SDLx.Context

Unit SDLx.Context

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • Winapi.Windows
  • System.Classes
  • System.SysUtils
  • SDL.Import
  • GXS.OpenGL
  • GXS.XOpenGL
  • GXS.Scene
  • GXS.Context
  • SDLx.Window

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSDLViewer |
Class TgxSDLContext |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: SDLx.Context: Class TgxSDLViewer

Class TgxSDLViewer

Description
Hierarchy
Fields
Methods
Properties

Unit

SDLx.Context

Declaration

type TgxSDLViewer = class(TgxNonVisualViewer)

Description

A viewer using SDL.

Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxNonVisualViewer
  • TgxSDLViewer

Overview

Fields

Private | FCaption: string;
Private | FOnSDLEvent: TgxSDLEvent;
Private | FOnEventPollDone: TNotifyEvent;
Private | FOnResize: TNotifyEvent;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Active: Boolean;
Public | procedure Render(baseObject: TgxBaseSceneObject = nil); override;

Properties

Published | property Caption: string read FCaption write SetCaption;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TgxSDLEvent read FOnSDLEvent write FOnSDLEvent;

Description

Fields

Private FCaption: string;

This item has no description.

Private FOnSDLEvent: TgxSDLEvent;

This item has no description.

Private FOnEventPollDone: TNotifyEvent;

This item has no description.

Private FOnResize: TNotifyEvent;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function Active: Boolean;

This item has no description.

Public procedure Render(baseObject: TgxBaseSceneObject = nil); override;

This item has no description.

Properties

Published property Caption: string read FCaption write SetCaption;

This item has no description.

Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;

Fired whenever an event polling completes with no events left to poll.

Published property OnResize: TNotifyEvent read FOnResize write FOnResize;

This item has no description.

Published property OnSDLEvent: TgxSDLEvent read FOnSDLEvent write FOnSDLEvent;

Fired whenever an SDL Event is polled. SDL_QUITEV and SDL_VIDEORESIZE are not passed to this event handler, they are passed via OnClose and OnResize respectively.


GXSysHelp v.2.5: SDLx.Context: Class TgxSDLContext

Class TgxSDLContext

Description
Hierarchy
Fields
Methods
Properties

Unit

SDLx.Context

Declaration

type TgxSDLContext = class(TgxScreenControlingContext)

Description

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application

Hierarchy

  • TObject
  • TgxContext
  • TgxScreenControlingContext
  • TgxSDLContext

Overview

Fields

Private | FSDLWin: TgxSDLWindow;
Private | FSimulatedValidity: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Public | procedure SwapBuffers; override;

Properties

Public property SDLWindow: TgxSDLWindow read FSDLWin;

Description

Fields

Private FSDLWin: TgxSDLWindow;

This item has no description.

Private FSimulatedValidity: Boolean;

This item has no description.

Methods

Public constructor Create; override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function IsValid: Boolean; override;

This item has no description. Showing description inherited from TgxContext.IsValid.

Returns true if the context is valid. A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; override;

This item has no description.

Public procedure SwapBuffers; override;

This item has no description. Showing description inherited from TgxContext.SwapBuffers.

Request to swap front and back buffers if they were defined.

Properties

Public property SDLWindow: TgxSDLWindow read FSDLWin;


GXSysHelp v.2.5: SDLx.Window

Unit SDLx.Window

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

The graphics engine GXScene https://github.com/glscene

Uses

  • System.Classes
  • System.SysUtils
  • System.SyncObjs
  • GXS.OpenGL
  • GLScene.VectorTypes
  • GXS.Context
  • GLScene.VectorGeometry
  • SDL.Import

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TgxSDLWindow |
Class ESDLError |

Functions and Procedures

function SDL_putenv(const variable: PAnsiChar): integer;
function SDL_getenv(const name: PAnsiChar): PAnsiChar;
procedure Register;

Types

TgxSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;
TgxSDLWindowOption = (...);
TgxSDLWindowOptions = set of TgxSDLWindowOption;
TgxSDLWindowPixelDepth = (...);

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voOpenGL, voResizable];

Description

Functions and Procedures

function SDL_putenv(const variable: PAnsiChar): integer;

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;

function SDL_getenv(const name: PAnsiChar): PAnsiChar;

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;

procedure Register;

The following function has been commented out to encourage developers to use SDL_getenv as it it more portable function getenv(const name: PAnsiChar): PAnsiChar; ———————————————————————

Types

TgxSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;

This item has no description.

TgxSDLWindowOption = (...);

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)

Values
  • voDoubleBuffer
  • voOpenGL
  • voResizable
  • voFullScreen
  • voStencilBuffer
TgxSDLWindowOptions = set of TgxSDLWindowOption;

This item has no description.

TgxSDLWindowPixelDepth = (...);

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)

Values
  • vpd16bits
  • vpd24bits

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voOpenGL, voResizable];


GXSysHelp v.2.5: SDLx.Window: Class TgxSDLWindow

Class TgxSDLWindow

Description
Hierarchy
Fields
Methods
Properties

Unit

SDLx.Window

Declaration

type TgxSDLWindow = class(TComponent)

Description

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used.

Hierarchy

  • TObject
  • TPersistent
  • TComponent
  • TgxSDLWindow

Overview

Fields

Private | FWidth: Integer;
Private | FHeight: Integer;
Private | FPixelDepth: TgxSDLWindowPixelDepth;
Private | FOptions: TgxSDLWindowOptions;
Private | FActive: Boolean;
Private | FOnOpen: TNotifyEvent;
Private | FOnClose: TNotifyEvent;
Private | FOnResize: TNotifyEvent;
Private | FOnSDLEvent: TgxSDLEvent;
Private | FOnEventPollDone: TNotifyEvent;
Private | FCaption: String;
Private | FThreadSleepLength: Integer;
Private | FThreadPriority: TThreadPriority;
Private | FThreadedEventPolling: Boolean;
Private | FThread: TThread;
Private | FSDLSurface: PSDL_Surface;
Private | FWindowHandle: Longword;
Private | FSDLWindow: PSDL_Window;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Close;
Public | procedure Open;
Public | procedure PollEvents;
Public | procedure SwapBuffers;
Public | procedure UpdateWindow;

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Caption: String read FCaption write SetCaption;
Published | property Height: Integer read FHeight write SetHeight default 480;
Published | property OnClose: TNotifyEvent read FOnClose write FOnClose;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TgxSDLEvent read FOnSDLEvent write FOnSDLEvent;
Published | property Options: TgxSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;
Published | property PixelDepth: TgxSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;
Public | property SDLSurface: PSDL_Surface read FSDLSurface;
Public | property SDLWindow: PSDL_Window read FSDLWindow;
Published | property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;
Published | property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;
Published | property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;
Published | property Width: Integer read FWidth write SetWidth default 640;
Public | property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;

Description

Fields

Private FWidth: Integer;

This item has no description.

Private FHeight: Integer;

This item has no description.

Private FPixelDepth: TgxSDLWindowPixelDepth;

This item has no description.

Private FOptions: TgxSDLWindowOptions;

This item has no description.

Private FActive: Boolean;

This item has no description.

Private FOnOpen: TNotifyEvent;

This item has no description.

Private FOnClose: TNotifyEvent;

This item has no description.

Private FOnResize: TNotifyEvent;

This item has no description.

Private FOnSDLEvent: TgxSDLEvent;

This item has no description.

Private FOnEventPollDone: TNotifyEvent;

This item has no description.

Private FCaption: String;

This item has no description.

Private FThreadSleepLength: Integer;

This item has no description.

Private FThreadPriority: TThreadPriority;

This item has no description.

Private FThreadedEventPolling: Boolean;

This item has no description.

Private FThread: TThread;

This item has no description.

Private FSDLSurface: PSDL_Surface;

This item has no description.

Private FWindowHandle: Longword;

This item has no description.

Private FSDLWindow: PSDL_Window;

This item has no description.

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public procedure Close;

Closes an already opened SDL Window. NOTE: will also kill the app due to an SDL limitation...

Public procedure Open;

Initializes and Opens an SDL window

Public procedure PollEvents;

Polls SDL events. SDL events can be either polled "manually", through a call to this method, or automatically via ThreadEventPolling.

Public procedure SwapBuffers;

Swap front and back buffer.

Public procedure UpdateWindow;

Applies changes (size, pixeldepth...) to the opened window.

Properties

Public property Active: Boolean read FActive write SetActive;

Is the SDL window active (opened)? Adjusting this value as the same effect as invoking Open/Close.

Published property Caption: String read FCaption write SetCaption;

Caption of the SDL window

Published property Height: Integer read FHeight write SetHeight default 480;

Height of the SDL window. To apply changes to an active window, call UpdateWindow.

Published property OnClose: TNotifyEvent read FOnClose write FOnClose;

Fired whenever closing the window. The SDL surface is still defined and usable when the event happens.

Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;

Fired whenever an event polling completes with no events left to poll.

Published property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;

Fired whenever Open succeeds. The SDL surface is defined and usable when the event happens.

Published property OnResize: TNotifyEvent read FOnResize write FOnResize;

Fired whenever the window is resized. Note: glViewPort call is handled automatically for OpenGL windows

Published property OnSDLEvent: TgxSDLEvent read FOnSDLEvent write FOnSDLEvent;

Fired whenever an SDL Event is polled. SDL_QUITEV and SDL_VIDEORESIZE are not passed to this event handler, they are passed via OnClose and OnResize respectively.

Published property Options: TgxSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;

Options for the SDL window. To apply changes to an active window, call UpdateWindow.

Published property PixelDepth: TgxSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;

PixelDepth of the SDL window. To apply changes to an active window, call UpdateWindow.

Public property SDLSurface: PSDL_Surface read FSDLSurface;

Presents the SDL surface of the window. If Active is False, this value is undefined.

Public property SDLWindow: PSDL_Window read FSDLWindow;

Presents the SDL window. If Active is False, this value is undefined.

Published property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;

Controls automatic threaded event polling.

Published property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;

Priority of the event polling thread.

Published property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;

Sleep length between pollings in the polling thread.

Published property Width: Integer read FWidth write SetWidth default 640;

Width of the SDL window.To apply changes to an active window, call UpdateWindow

Public property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;

Experimental: ask SDL to reuse and existing WindowHandle


GXSysHelp v.2.5: SDLx.Window: Class ESDLError

Class ESDLError

Description
Hierarchy
Fields
Methods
Properties

Unit

SDLx.Window

Declaration

type ESDLError = class(Exception)

Description

Generic SDL or SDLWindow exception.

Hierarchy

  • TObject
  • Exception
  • ESDLError


GXSysHelp v.2.5: uGBEImageUtils

Unit uGBEImageUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.UITypes
  • System.SysUtils
  • System.UIConsts
  • System.Types
  • FMX.Effects
  • FMX.Graphics

Overview

Functions and Procedures

function GenerateDiamondSquare(size, blurLevel: integer; color: TAlphaColor = TAlphaColorRec.White; bordure: boolean = false; colorBordure: TAlphaColor = TAlphaColorRec.Black): TBitmap;
function TileImage(imageOrigine: TBitmap; nbX, nbY: integer): TBitmap;
function CropImage(originBitmap: TBitmap; Xpos, Ypos, width, height: integer): TBitmap;
function MultiTexturing(imgCarte, imgFond, imgCanalRouge, imgCanalVert, imgCanalBleu: TBitmap; tailleCrop: integer): TBitmap;
function MultiTexturingZone(img: TBitmap): TBitmap;
function MixerCouleurPixel(cCarte: TAlphaColor; x, y: integer): TAlphaColor;

Variables

TextureCanalNoir: TBitmap;
TextureCanalRouge: TBitmap;
TextureCanalVert: TBitmap;
TextureCanalBleu: TBitmap;
BitmapDataCanalNoir: TBitmapData;
BitmapDataCanalRouge: TBitmapData;
BitmapDataCanalVert: TBitmapData;
BitmapDataCanalBleu: TBitmapData;

Description

Functions and Procedures

function GenerateDiamondSquare(size, blurLevel: integer; color: TAlphaColor = TAlphaColorRec.White; bordure: boolean = false; colorBordure: TAlphaColor = TAlphaColorRec.Black): TBitmap;

https://fr.wikipedia.org/wiki/Algorithme_Diamant-Carr%C3%A9

function TileImage(imageOrigine: TBitmap; nbX, nbY: integer): TBitmap;

This item has no description.

function CropImage(originBitmap: TBitmap; Xpos, Ypos, width, height: integer): TBitmap;

This item has no description.

function MultiTexturing(imgCarte, imgFond, imgCanalRouge, imgCanalVert, imgCanalBleu: TBitmap; tailleCrop: integer): TBitmap;

This item has no description.

function MultiTexturingZone(img: TBitmap): TBitmap;

This item has no description.

function MixerCouleurPixel(cCarte: TAlphaColor; x, y: integer): TAlphaColor;

This item has no description.

Variables

TextureCanalNoir: TBitmap;

This item has no description.

TextureCanalRouge: TBitmap;

This item has no description.

TextureCanalVert: TBitmap;

This item has no description.

TextureCanalBleu: TBitmap;

This item has no description.

BitmapDataCanalNoir: TBitmapData;

This item has no description.

BitmapDataCanalRouge: TBitmapData;

This item has no description.

BitmapDataCanalVert: TBitmapData;

This item has no description.

BitmapDataCanalBleu: TBitmapData;


GXSysHelp v.2.5: uGBEOptionsUtils

Unit uGBEOptionsUtils

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • FMX.Types3D
  • System.IniFiles
  • System.SysUtils
  • System.Classes

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGBEOptions |

Types

TKeyboardType = (...);

Description

Types

TKeyboardType = (...);

This item has no description.

Values
  • QWERTY
  • AZERTY


GXSysHelp v.2.5: uGBEOptionsUtils: Record TGBEOptions

Record TGBEOptions

Description
Hierarchy
Fields
Methods
Properties

Unit

uGBEOptionsUtils

Declaration

type TGBEOptions = record

Description

This item has no description.

Overview

Fields

Public | afficherLignes: boolean;
Public | activerMusiques: boolean;
Public | activerSons: boolean;
Public | activerVagues: boolean;
Public | activerHerbe: boolean;
Public | activerHerbeVent: boolean;
Public | activerNuages: boolean;
Public | afficherFPS: boolean;
Public | utilisationTasks: boolean;
Public | pleinEcran: boolean;
Public | volumeSons: single;
Public | volumeMusiques: single;
Public | detailsHeightmap: integer;
Public | nbNuages: integer;
Public | nbHerbe: integer;
Public | detailsVagues: integer;
Public | Filter: TMultisample;
Public | Keyboard: TKeyboardType;

Methods

Public | function ReadOption(configFile, section, option: string): string;
Public | procedure ReadConfig(configFile: string);
Public | procedure SaveOption(configFile, section, option, value: string);
Public | procedure WriteConfig(configFile: string);

Description

Fields

Public afficherLignes: boolean;

This item has no description.

Public activerMusiques: boolean;

This item has no description.

Public activerSons: boolean;

This item has no description.

Public activerVagues: boolean;

This item has no description.

Public activerHerbe: boolean;

This item has no description.

Public activerHerbeVent: boolean;

This item has no description.

Public activerNuages: boolean;

This item has no description.

Public afficherFPS: boolean;

This item has no description.

Public utilisationTasks: boolean;

This item has no description.

Public pleinEcran: boolean;

This item has no description.

Public volumeSons: single;

This item has no description.

Public volumeMusiques: single;

This item has no description.

Public detailsHeightmap: integer;

This item has no description.

Public nbNuages: integer;

This item has no description.

Public nbHerbe: integer;

This item has no description.

Public detailsVagues: integer;

This item has no description.

Public Filter: TMultisample;

This item has no description.

Public Keyboard: TKeyboardType;

This item has no description.

Methods

Public function ReadOption(configFile, section, option: string): string;

This item has no description.

Public procedure ReadConfig(configFile: string);

This item has no description.

Public procedure SaveOption(configFile, section, option, value: string);

This item has no description.

Public procedure WriteConfig(configFile: string);


GXSysHelp v.2.5: uGBEPathFinder

Unit uGBEPathFinder

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.SysUtils
  • System.Types
  • System.UITypes
  • System.Classes
  • System.Generics.Collections

Overview

Classes, Interfaces, Objects and Records

Name | Description
Record TGBENoeud |
Class TGBEPathFinder |

Types

TGBEPathFinderMode = (...);

Description

Types

TGBEPathFinderMode = (...);

This item has no description.

Values
  • DeplacementsMinimum
  • CoutMinimum


GXSysHelp v.2.5: uGBEPathFinder: Record TGBENoeud

Record TGBENoeud

Description
Hierarchy
Fields
Methods
Properties

Unit

uGBEPathFinder

Declaration

type TGBENoeud = record

Description

This item has no description.

Overview

Fields

Public | CoutDeplacement: integer;
Public | Heuristique: integer;
Public | EstimationCout: integer;
Public | Position: TPoint;
Public | Parent: TPoint;

Description

Fields

Public CoutDeplacement: integer;

This item has no description.

Public Heuristique: integer;

This item has no description.

Public EstimationCout: integer;

This item has no description.

Public Position: TPoint;

This item has no description.

Public Parent: TPoint;


GXSysHelp v.2.5: uGBEPathFinder: Class TGBEPathFinder

Class TGBEPathFinder

Description
Hierarchy
Fields
Methods
Properties

Unit

uGBEPathFinder

Declaration

type TGBEPathFinder = class(TObject)

Description

This item has no description.

Hierarchy

  • TObject
  • TGBEPathFinder

Overview

Fields

Public | fNoeudDepart: TGBENoeud;
Public | fNoeudArrivee: TGBENoeud;
Public | ListeNoeudsPossibles: TDictionary<TPoint, TGBENoeud>;
Public | ListeNoeudsVoisins: TDictionary<TPoint, TGBENoeud>;
Public | flGrille: integer;
Public | fhGrille: integer;
Public | fCoutDeplacementCote: integer;
Public | fCoutDeplacementDiagonal: integer;
Public | fAutoriserDeplacementDiagonal: boolean;
Public | fQuePremiereEtape: boolean;
Public | fMode: TGBEPathFinderMode;
Public | ListeChemin: TDictionary<TPoint, TGBENoeud>;
Public | ListeNoeudsObstacles: TDictionary<TPoint, TGBENoeud>;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function CalculerCoutArrivee(Point: TPoint): integer;
Public | function RechercheCoutTotalMin(Liste: TDictionary<TPoint, TGBENoeud>) : TGBENoeud;
Public | function RechercherChemin: boolean;
Public | procedure ListerVoisins(UnNoeud: TGBENoeud);
Public | procedure OptimiserChemin;

Properties

Public | property AutoriserDeplacementDiagonal: boolean read fAutoriserDeplacementDiagonal write fAutoriserDeplacementDiagonal;
Public | property CoutDeplacementCote: integer read fCoutDeplacementCote write fCoutDeplacementCote;
Public | property CoutDeplacementDiagonal: integer read fCoutDeplacementDiagonal write fCoutDeplacementDiagonal;
Public | property HauteurGrille: integer read fhGrille write fhGrille;
Public | property LargeurGrille: integer read flGrille write flGrille;
Public | property Mode: TGBEPathFinderMode read fMode write fMode;
Public | property NoeudArrivee: TGBENoeud read fNoeudArrivee write fNoeudArrivee;
Public | property NoeudDepart: TGBENoeud read fNoeudDepart write fNoeudDepart;
Public | property QuePremiereEtape: boolean read fQuePremiereEtape write fQuePremiereEtape;

Description

Fields

Public fNoeudDepart: TGBENoeud;

This item has no description.

Public fNoeudArrivee: TGBENoeud;

This item has no description.

Public ListeNoeudsPossibles: TDictionary<TPoint, TGBENoeud>;

This item has no description.

Public ListeNoeudsVoisins: TDictionary<TPoint, TGBENoeud>;

This item has no description.

Public flGrille: integer;

This item has no description.

Public fhGrille: integer;

This item has no description.

Public fCoutDeplacementCote: integer;

This item has no description.

Public fCoutDeplacementDiagonal: integer;

This item has no description.

Public fAutoriserDeplacementDiagonal: boolean;

This item has no description.

Public fQuePremiereEtape: boolean;

This item has no description.

Public fMode: TGBEPathFinderMode;

This item has no description.

Public ListeChemin: TDictionary<TPoint, TGBENoeud>;

This item has no description.

Public ListeNoeudsObstacles: TDictionary<TPoint, TGBENoeud>;

This item has no description.

Methods

Public constructor Create; virtual;

This item has no description.

Public destructor Destroy; override;

This item has no description.

Public function CalculerCoutArrivee(Point: TPoint): integer;

Allows you to calculate the cost from a given point to the arrival

Public function RechercheCoutTotalMin(Liste: TDictionary<TPoint, TGBENoeud>) : TGBENoeud;

Retrieves the least expensive node in a list

Public function RechercherChemin: boolean;

Algorithm A*: 1st step We explore all the tracks until we find the arrival node

Public procedure ListerVoisins(UnNoeud: TGBENoeud);

Allows you to list the neighbors of a given node

Public procedure OptimiserChemin;

2nd part: allows to trace only the path from the tracks explored in step 1 We will go through the list of nodes explored in step 1 starting from the arrival node and going back to the departure node in order to list only the nodes necessary for the constitution of the path

Properties

Public property AutoriserDeplacementDiagonal: boolean read fAutoriserDeplacementDiagonal write fAutoriserDeplacementDiagonal;

This item has no description.

Public property CoutDeplacementCote: integer read fCoutDeplacementCote write fCoutDeplacementCote;

This item has no description.

Public property CoutDeplacementDiagonal: integer read fCoutDeplacementDiagonal write fCoutDeplacementDiagonal;

This item has no description.

Public property HauteurGrille: integer read fhGrille write fhGrille;

This item has no description.

Public property LargeurGrille: integer read flGrille write flGrille;

This item has no description.

Public property Mode: TGBEPathFinderMode read fMode write fMode;

This item has no description.

Public property NoeudArrivee: TGBENoeud read fNoeudArrivee write fNoeudArrivee;

This item has no description.

Public property NoeudDepart: TGBENoeud read fNoeudDepart write fNoeudDepart;

This item has no description.

Public property QuePremiereEtape: boolean read fQuePremiereEtape write fQuePremiereEtape;


GXSysHelp v.2.5: uGBESound

Unit uGBESound

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • FMX.Media

Overview

Functions and Procedures

procedure PlaySound(MediaPlayer: TMediaPlayer; Son: string; Volume: single = 1);
procedure RePlaySound(MediaPlayer: TMediaPlayer; Son: string; Volume: single = 1);

Description

Functions and Procedures

procedure PlaySound(MediaPlayer: TMediaPlayer; Son: string; Volume: single = 1);

This item has no description.

procedure RePlaySound(MediaPlayer: TMediaPlayer; Son: string; Volume: single = 1);


GXSysHelp v.2.5: uGBEUtils3D

Unit uGBEUtils3D

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

This item has no description.

Uses

  • System.Math.Vectors
  • System.Types
  • System.Classes
  • FMX.Objects3D
  • Math
  • FMX.Controls3D
  • FMX.Graphics
  • FMX.Types3D
  • System.UITypes
  • FMX.Effects
  • System.UIConsts
  • System.SysUtils
  • System.RTLConsts
  • FMX.Types
  • FMX.Ani
  • FMX.Viewport3D

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCustomMeshHelper |
Record TGBECollisionRetour |

Functions and Procedures

function Barycentre(p1, p2, p3: TPoint3D; p4: TPointF): single;
function CalculateHeight(Mesh: TMesh; P: TPoint3D; miseAEchelle: single; subDivX, subDivZ: integer): single;
function SizeOf3D(const unObjet3D: TControl3D): TPoint3D;
function DetectionCollisionObstacle(Mesh: TMesh; objet: TControl3D) : TGBECollisionRetour;
procedure InteractionIHM(viewport: TViewport3D);
function CollisionDummyChilds(aDummy: TDummy; objet3D: TControl3D) : TGBECollisionRetour;
function CollisionEntre2Objets(objet1, objet2: TControl3D): TGBECollisionRetour;

Description

Functions and Procedures

function Barycentre(p1, p2, p3: TPoint3D; p4: TPointF): single;

This item has no description.

function CalculateHeight(Mesh: TMesh; P: TPoint3D; miseAEchelle: single; subDivX, subDivZ: integer): single;

This item has no description.

function SizeOf3D(const unObjet3D: TControl3D): TPoint3D;

This item has no description.

function DetectionCollisionObstacle(Mesh: TMesh; objet: TControl3D) : TGBECollisionRetour;

This item has no description.

procedure InteractionIHM(viewport: TViewport3D);

This item has no description.

function CollisionDummyChilds(aDummy: TDummy; objet3D: TControl3D) : TGBECollisionRetour;

This item has no description.

function CollisionEntre2Objets(objet1, objet2: TControl3D): TGBECollisionRetour;


GXSysHelp v.2.5: uGBEUtils3D: Class TCustomMeshHelper

Class TCustomMeshHelper

Description
Hierarchy
Fields
Methods
Properties

Unit

uGBEUtils3D

Declaration

type TCustomMeshHelper = class(TCustomMesh)

Description

This item has no description.

Hierarchy

  • TCustomMesh
  • TCustomMeshHelper


GXSysHelp v.2.5: uGBEUtils3D: Record TGBECollisionRetour

Record TGBECollisionRetour

Description
Hierarchy
Fields
Methods
Properties

Unit

uGBEUtils3D

Declaration

type TGBECollisionRetour = record

Description

This item has no description.

Overview

Fields

Public | bool: boolean;
Public | objet: TControl3D;

Description

Fields

Public bool: boolean;

This item has no description.

Public objet: TControl3D;


GXSysHelp v.2.5: VXS.DWSScene

Unit VXS.DWSScene

Description
Uses
Classes, Interfaces, Objects and Records
Functions and Procedures
Types
Constants
Variables

Description

DelphiWebScript symbol creation for base GLScene classes.

This unit is dependent on DwsClasses and DwsVectorGeometry. These components must be associated with the same compiler for the GLScene classes to inherit from.

Uses

  • System.Classes
  • System.SysUtils
  • DwsExprs
  • DwsSymbols
  • DwsComp
  • DwsCompStrings
  • DwsStack
  • DwsFunctions
  • DwsHelperFunc
  • GXS.Scene
  • GLScene.VectorGeometry
  • GXS.Coordinates

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDwsGLXceneUnit |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;


GXSysHelp v.2.5: VXS.DWSScene: Class TDwsGLXceneUnit

Class TDwsGLXceneUnit

Description
Hierarchy
Fields
Methods
Properties

Unit

VXS.DWSScene

Declaration

type TDwsGLXceneUnit = class(TDwsUnitComponent)

Description

This item has no description.

Hierarchy

  • TDwsUnitComponent
  • TDwsGLXceneUnit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Private | procedure AddClassTgxBaseSceneObject(SymbolTable : TSymbolTable);
Private | procedure AddClassTgxCoordinates(SymbolTable : TSymbolTable);

Description

Methods

Public constructor Create(AOwner: TComponent); override;

This item has no description.

Private procedure AddClassTgxBaseSceneObject(SymbolTable : TSymbolTable);

This item has no description.

Private procedure AddClassTgxCoordinates(SymbolTable : TSymbolTable);


GXSysHelp v.2.5: Class Hierarchy

Class Hierarchy

  • IgxNotifyable
    • IgxTextureNotifyAble
  • IInterface
    • IDesigner
    • IgxInitializable
    • IgxMaterialLibrarySupported
    • IgxPostShader
    • IgxShaderDescription
    • IgxShaderParameter
    • IShaderParameter
  • TBitmap
    • TDDSImage
    • THDRImage
    • TTGAImage
  • TComponentEditor
    • TCUDACompilerEditor
    • TCUDAEditor
    • TgxGUILayoutEditor
    • TgxReuseableDefaultEditor
      • TgxMaterialLibraryEditor
      • TgxSArchiveManagerEditor
    • TgxSceneEditor
    • TgxSceneViewerEditor
  • TCone
    • TGBEConeExtend
  • TControl
    • TgxSceneViewport
  • TControl3D
    • THelpOpenControl3D
  • TCustomAttribute
    • TDim
  • TCustomMesh
    • TCustomMeshHelper
  • TCylinder
    • TGBECylinderExtend
  • TDummy
    • TGBEClouds
    • TGBECubeExtend
    • TGBEPlayerPosition
  • TDwsUnitComponent
    • TDwsGLXceneUnit
  • TEvent
    • TgxFinishTaskEvent
  • TFloatAnimation
    • TGBETimeline
  • TForm
    • TCUDAEditorForm
    • TGUILayoutForm
    • TInfoForm
    • TLibMaterialPicker
    • TMaterialEditorForm
    • TSceneEditorForm
    • TShaderMemoForm
    • TShaderUniformEditorForm
    • TSkinEditorForm
    • TXCollectionEditorForm
  • TFrame
    • TColorEditorFrame
    • TFaceEditorFrame
    • TMaterialPreviewFrame
    • TTextureEditFrame
  • TGLInterfacedPersistent
    • TXCollectionItem
      • TgxBaseBehaviour
        • TgxBehaviour
          • TgxBAcceleration
          • TgxBaseForceFieldEmitter
            • TGLRadialGravityEmitter
            • TGLUniformGravityEmitter
            • TgxDampingFieldEmitter
          • TgxBaseInertia
            • TgxParticleInertia
              • TgxRigidBodyInertia
          • TgxBCollision
          • TgxBFPSMovement
          • TgxBInertia
          • TgxBSoundEmitter
          • TgxDCEDynamic
          • TgxDCEStatic
          • TgxDwsActiveBehaviour
          • TgxMovement
          • TgxNGDBehaviour
            • TgxNGDDynamic
            • TgxNGDStatic
          • TgxODEBehaviour
            • TgxODECustomCollider
              • TgxODEHeightField
            • TgxODEDynamic
            • TgxODEStatic
        • TgxEffect
          • TgxObjectAfterEffect
          • TgxObjectPostEffect
            • TgxBFireFX
            • TgxBThorFX
            • TgxParticleFXEffect
              • TgxSourcePFXEffect
          • TgxObjectPreEffect
            • TgxBExplosionFX
      • TgxForce
        • TgxHookesSpring
          • TgxHookesString
      • TgxMapCollectionItem
      • TgxNavigatorSmoothChangeItem
        • TgxNavigatorSmoothChangeSingle
        • TgxNavigatorSmoothChangeVector
      • TgxODEElementBase
        • TgxODEElementBox
        • TgxODEElementCapsule
        • TgxODEElementCylinder
        • TgxODEElementPlane
        • TgxODEElementSphere
        • TgxODEElementTriMesh
      • TgxODEJointBase
        • TgxODEJointBall
        • TgxODEJointFixed
        • TgxODEJointHinge
        • TgxODEJointHinge2
        • TgxODEJointSlider
        • TgxODEJointUniversal
      • TgxScriptBase
        • TgxScriptPython
      • TgxSpriteAnimation
      • TgxSpriteAnimFrame
  • TGLSceneViewport
  • TGNotifyCollection
    • TgxContours
  • TgxCadenceAbleComponent
    • TgxAbstractMaterialLibrary
      • TgxMaterialLibrary
    • TgxFireFXManager
    • TgxSoundManager
      • TgxSMBASS
      • TgxSMOpenAL
      • TgxSMWaveOut
    • TgxThorFXManager
  • TgxCoordinatesUpdateAbleComponent
    • TgxBaseSceneObject
      • TgxAnimatedSprite
      • TgxBaseGuiObject
        • TgxBaseComponent
          • TgxBaseControl
            • TgxBaseFontControl
              • TgxBaseTextControl
                • TgxFocusControl
                  • StringGrid
                  • TgxAdvancedLabel
                  • TgxButton
                  • TgxCustomControl
                  • TgxEdit
                  • TgxPopupMenu
                  • TgxScrollbar
                • TgxForm
                • TgxLabel
            • TgxCheckBox
            • TgxPanel
      • TgxCamera
        • TgxFile3DSCamera
      • TgxCustomAtmosphere
        • TgxAtmosphere
      • TgxCustomConsole
        • TgxConsole
      • TgxCustomFeedBackMesh
        • TgxFeedBackMesh
      • TgxCustomSceneObject
        • TgxImmaterialSceneObject
          • TgxCameraInvariantObject
            • TgxDummyCube
            • TgxSkyBox
            • TgxSkyDome
              • TgxEarthSkyDome
          • TgxDirectOpenGL
          • TgxFlatText
            • TgxGizmoExUIFlatText
          • TgxHUDText
            • TgxAbsoluteHUDText
            • TgxResolutionIndependantHUDText
          • TgxImposter
          • TgxLineBase
            • TgxNodedLines
              • TgxLines
                • TgxGizmoExUILines
                • TgxIsolines
            • TgxXYZGrid
          • TgxParticles
          • TgxPoints
            • TgxSwartSwarm
          • TgxProjectedTextures
          • TgxRenderPoint
          • TgxShadowVolume
          • TgxTilePlane
          • TgxTree
        • TgxMotionBlur
        • TgxSceneObject
          • TgxBaseMesh
            • TgxActor
              • TgxCyborg
              • TgxFile3DSActor
            • TgxDodecahedron
            • TgxFreeForm
              • TgxFile3DSFreeForm
              • TgxMeshLines
            • TgxHexahedron
            • TgxIcosahedron
            • TgxOctahedron
            • TgxPortal
            • TgxTetrahedron
          • TgxCapsule
          • TgxCube
            • TgxGizmoPickCube
            • TgxODERagdollCube
          • TgxFrustrum
            • TgxGizmoExUIFrustrum
          • TgxGameMenu
          • TgxHeightField
          • TgxMesh
            • TgxTrail
          • TgxMirror
          • TgxMultiPolygonBase
            • TgxExtrusionSolid
            • TgxMultiPolygon
          • TgxMultiProxy
          • TgxPlane
            • TgxShadowPlane
          • TgxPolygonBase
            • TgxPipe
            • TgxPolygon
              • TgxGizmoExUIPolygon
            • TgxRevolutionSolid
          • TgxQuadricObject
            • TgxCylinderBase
              • TgxAnnulus
              • TgxArrowArc
              • TgxArrowLine
                • TgxGizmoExUIArrowLine
              • TgxCone
              • TgxCylinder
            • TgxDisk
              • TgxGizmoExUIDisk
            • TgxSphere
              • TgxGizmoExUISphere
            • TgxSuperellipsoid
          • TgxslProjectedTextures
          • TgxSpaceText
          • TgxSprite
            • TgxHUDSprite
              • TgxBlur
          • TgxTeapot
          • TgxTerrainRenderer
          • TgxTextureEmitter
          • TgxTorus
            • TgxGizmoExUITorus
            • TgxGizmoPickTorus
          • TgxWaterPlane
      • TgxFBORenderer
      • TgxFeedback
      • TgxLensFlare
      • TgxLightSource
        • TgxFile3DSLight
      • TgxMaterialMultiProxy
      • TgxParticleFXRenderer
      • TgxPostEffect
      • TgxPostShaderHolder
      • TgxProxyObject
        • TgxActorProxy
        • TgxColorProxy
        • TgxFreeFormProxy
        • TgxMaterialProxy
      • TgxSceneRootObject
      • TgxslTextureEmitter
      • TgxTextureLensFlare
      • TgxZShadows
  • TgxCustomCoordinates
    • TLightmapBounds
  • TgxInterfacedCollectionItem
    • TgxMaterialMultiProxyMaster
    • TgxShaderTextureSharingMaterial
  • TgxPersistentObject
    • TBaseSpacePartition
      • TLeavedSpacePartition
        • TSectoredSpacePartition
          • TOctreeSpacePartition
          • TQuadtreeSpacePartition
    • TgxBaseMeshObject
      • TgxMeshMorphTarget
      • TgxMeshObject
        • TBSPMeshObject
        • TgxMorphableMeshObject
          • TgxFile3DSDummyObject
            • TgxFile3DSCameraObject
            • TgxFile3DSMeshObject
            • TgxFile3DSOmniLightObject
              • TgxFile3DSSpotLightObject
          • TgxSectorMeshObject
          • TgxSkeletonMeshObject
        • TMOParametricSurface
    • TgxFaceGroup
      • TFGBezierSurface
      • TgxFGVertexIndexList
        • TFGBSPNode
        • TFGVertexNormalTexIndexList
          • TFGPolygon
            • TFGPortalPolygon
        • TgxFGIndexTexCoordList
    • TgxFile3DSAnimationKeyList
    • TgxFile3DSAnimationKeys
      • TgxFile3DSColorAnimationKeys
      • TgxFile3DSLightHotSpotAnimationKeys
      • TgxFile3DSPositionAnimationKeys
      • TgxFile3DSRollAnimationKeys
      • TgxFile3DSRotationAnimationKeys
      • TgxFile3DSScaleAnimationKeys
      • TgxFile3DSSpotLightCutOffAnimationKeys
      • TTgxFile3DSPositionAnimationKeys
    • TgxParticle
      • TgxLineParticle
    • TgxParticleList
    • TgxRagdoll
      • TgxODERagdoll
    • TgxSkeleton
    • TgxSkeletonCollider
      • TgxVerletSkeletonCollider
        • TgxVerletCapsule
        • TgxVerletSphere
      • TSCODEBase
        • TSCODEBox
        • TSCODECCylinder
        • TSCODESphere
    • TgxSkeletonFrame
    • TgxTiledArea
    • TgxTiledAreaRow
    • TSpacePartitionLeaf
      • TgxBaseVerletNode
        • TgxVerletNode
          • TgxMeshObjectVerletNode
      • TgxSceneObj
      • TgxVerletEdge
  • TgxPersistentObjectList
    • TgxArchiveFileFormatsList
    • TgxCyborgThinksList
    • TgxFaceGroups
    • TgxMeshMorphTargetList
    • TgxMeshObjectList
      • TgxPortalMeshObjectList
    • TgxPickList
    • TgxPolygonList
    • TgxRagdolBoneList
      • TgxRagdolBone
        • TgxODERagdollBone
    • TgxSkeletonBoneList
      • TgxSkeletonBone
      • TgxSkeletonRootBoneList
    • TgxSkeletonColliderList
    • TgxSkeletonFrameList
    • TgxVectorFileFormatsList
    • TRasterFileFormatsList
    • TSpacePartitionLeafList
  • TgxUpdateAbleComponent
    • TgxCustomBitmapFont
      • TgxBitmapFont
      • TgxWindowsBitmapFont
    • TgxCustomCadencedComponent
      • TgxCadencedComponent
        • TgxParticleFXManager
          • TgxDynamicPFXManager
            • TgxLifeColoredPFXManager
              • TgxBaseSpritePFXManager
                • TgxCustomSpritePFXManager
                • TgxPerlinPFXManager
                • TgxPointLightPFXManager
              • TgxCustomPFXManager
              • TgxLinePFXManager
              • TgxPolygonPFXManager
    • TgxGuiLayout
    • TgxImposterBuilder
      • TgxDynamicImposterBuilder
      • TgxStaticImposterBuilder
    • TgxScene
    • TgxTimeEventsMGR
  • TgxUpdateAbleObject
    • TCGxProgram
      • TCGxFragmentProgram
      • TCGxVertexProgram
    • TCUDADimensions
    • TgxBlendingParameters
    • TgxDamping
    • TgxDataFile
      • TgxBaseArchive
        • TPAKArchive
        • TZLibArchive
      • TgxBaseImage
        • TgxBMPImage
        • TgxDDSImage
        • TgxHDRImage
        • TgxImage
        • TgxJPEGImage
        • TgxPGMImage
        • TgxPNGImage
        • TgxTGAImage
      • TgxSoundFile
        • TgxMP3File
        • TgxWAVFile
      • TgxVectorFile
        • TglTFVectorFile
        • Tgx3DSVectorFile
        • TgxASEVectorFile
        • TgxB3DVectorFile
        • TgxDXFVectorFile
        • TgxFileDAE
        • TgxGLAVectorFile
        • TgxGLMVectorFile
        • TgxGRDVectorFile
        • TgxGTSVectorFile
        • TgxLMTSVectorFile
        • TgxLWOVectorFile
        • TgxMD2VectorFile
        • TgxMD3VectorFile
        • TgxMD5VectorFile
        • TgxMDCVectorFile
        • TgxMS3DVectorFile
        • TgxNMFVectorFile
        • TgxNurbsVectorFile
        • TgxOBJVectorFile
        • TgxOCTgxVectorFile
        • TgxPLYVectorFile
        • TgxQ3BSPVectorFile
        • TGXSMDVectorFile
        • TGXSTLVectorFile
        • TgxTINVectorFile
        • TgxVectorFileGLSM
        • TgxVRMLVectorFile
        • TgxXVectorFile
    • TgxDepthProperties
    • TgxFaceProperties
    • TgxFlareGradient
    • TgxFogEnvironment
    • TgxHeightData
    • TgxInertiaTensor
    • TgxLineSettings
    • TgxMaterial
    • TgxPointParameters
    • TgxSamplingScale
    • TgxSceneBuffer
    • TgxTexture
    • TgxTextureImage
      • TgxBlankImage
        • TgxDynamicTextureImage
      • TgxCompositeImage
      • TgxCubeMapImage
      • TgxMultisampleImage
      • TgxPictureImage
        • TgxPersistentImage
        • TgxPicFileImage
      • TgxProcTextureNoise
    • TgxVertexList
  • TLayout
    • TGBEJoystick
  • TMesh
    • TGBECubemap
    • TGBEGrass
    • TGBEHeightmap
    • TGBESphereExtend
    • TGBETerrain
  • TObject
    • CUDAContextManager
    • Exception
      • EDDSException
      • EFilerException
      • EGLAtmosphereException
      • EGLCameraController
      • EGLConsoleException
      • EGLFile3DS
      • EGLImageUtils
      • EGLMotionBlurException
      • EGLOBJFileError
      • EGLPostShaderHolderException
      • EGLROAMException
      • EGLUtilsException
      • EgxInvalidVectorFile
      • EInvalidArchiveFile
      • EInvalidRasterFile
      • EOpenGLError
      • EPBuffer
      • EProxyException
      • ESDLError
      • EShaderException
        • ECGxShaderException
          • ECGxBombShaderException
        • ECustomShaderException
          • EGXSLShaderException
            • EgxslBumpShaderException
            • EgxslDiffuseSpecularShaderException
      • ETexture
      • ETGAException
      • EVXContext
        • EVXShader
      • EVXTextureCombinerError
      • EZBufferException
    • GRedBlackTree
    • TArchiveFileFormat
    • TBaseConnectivity
      • TConnectivity
        • TgxFaceGroupConnectivity
      • TgxBaseMeshConnectivity
    • TBoneMatrixObj
    • TBSPClusterVisibility
    • TCGxParameter
    • TClassProperty
      • TgxColorProperty
      • TgxCoordinatesProperty
      • TgxImageClassProperty
      • TgxMaterialProperty
      • TgxShaderEditorProperty
      • TgxSoundFileProperty
      • TgxTextureImageProperty
      • TgxTextureProperty
      • TXCollectionProperty
    • TCollisionState
    • TCubicSpline
    • TCUDAContext
    • TDESolver
      • TDESolverExplicit
        • TDESolverEuler
        • TDESolverRungeKutta4
      • TDESolverImplicit
        • TDESolverVerlet
    • TECPlane
    • TEdge
    • TFace
    • TFaceExtractor
      • TEdgeDetector
    • TFileNMF
    • TGBEPathFinder
    • TGDelaunay2D
    • TGLBaseJoint
      • TGLJoint
        • TGLBallAndSocketJoint
        • TGLPrismaticJoint
        • TGLRevoluteJoint
    • TGLBaseLink
      • TGLLink
        • TGLType1Link
        • TGLType2Link
        • TGLType3Link
        • TGLType4Link
        • TGLType5Link
        • TGLType6Link
        • TGLType7Link
        • TGLType8Link
    • TGLExtensionsAndEntryPoints
    • TgTransformation
    • TgxAbstractMultitextureCoordinator
    • TgxArray
    • TgxASEFace
    • TgxASEFaceList
    • TgxASEMaterial
    • TgxASEMaterialList
    • TgxASEMeshObject
    • TgxBasePerlinOctav
      • Tgx2DPerlinOctav
    • TgxBaseSelectTechnique
      • TgxSelectRenderModeTechnique
    • TgxBuffer
      • TgxBufferI
      • TgxBufferU
      • TgxBufferV
    • TgxCameraJob
      • TgxMoveToPosJob
      • TgxOrbitToPosAdvJob
        • TgxSmoothOrbitToPosAdvJob
      • TgxOrbitToPosJob
        • TgxSmoothOrbitToPos
      • TgxZoomToDistanceJob
    • TgxCanvas
    • TgxContext
      • TgxScreenControlingContext
        • TgxSDLContext
      • TgxWinContext
    • TgxContextHandle
      • TgxBufferObjectHandle
        • TgxPackPBOHandle
        • TgxTextureBufferHandle
        • TgxTransformFeedbackBufferHandle
        • TgxUniformBufferHandle
        • TgxUnpackPBOHandle
        • TgxVBOHandle
          • TgxVBOArrayBufferHandle
          • TgxVBOElementArrayHandle
      • TgxFramebufferHandle
      • TgxListHandle
      • TgxProgramHandleEXT
        • TgxFragmentProgramHandle
        • TgxGeometryProgramHandle
        • TgxVertexProgramHandle
      • TgxQueryHandle
        • TgxBooleanOcclusionQueryHandle
        • TgxOcclusionQueryHandle
        • TgxPrimitiveQueryHandle
        • TgxTimerQueryHandle
      • TgxRenderbufferHandle
      • TgxSamplerHandle
      • TgxSLHandle
        • TgxProgramHandle
        • TgxShaderHandle
          • TgxFragmentShaderHandle
          • TgxGeometryShaderHandle
          • TgxTessControlShaderHandle
          • TgxTessEvaluationShaderHandle
          • TgxVertexShaderHandle
      • TgxTextureHandle
      • TgxVertexArrayHandle
      • TgxVirtualHandle
        • TgxVirtualHandleTransf
    • TgxContextManager
    • TgxCustomShaderParameter
      • TgxAsmShaderParameter
      • TGXSLShaderParameter
    • TgxCyborgManager
    • TgxFrameBuffer
    • TgxHeightTileFile
    • TgxIsoline
    • TgxMarchingCube
    • TgxOctree
    • TgxODEContactPoint
    • TgxODERagdollWorld
    • TgxOpenGL
    • TgxPerlin3DNoise
    • TgxProgram
    • TgxRagdolJoint
      • TgxODERagdollDummyJoint
      • TgxODERagdollHingeJoint
        • TgxODERagdollUniversalJoint
    • TgxRenderbuffer
      • TgxDepthRBO
      • TgxStencilRBO
    • TgxROAMPatch
    • TgxShader
      • TCGxCustomShader
        • TCGxCadencableCustomShader
          • TCGxCustomBombShader
            • TCGxBombShader
        • TCGxCustomPostTransformationShader
          • TCGxPostTransformationShader
        • TCGxShader
      • TgxBumpShader
      • TgxCelShader
      • TgxCustomShader
        • TgxCustomAsmShader
          • TgxAsmShader
          • TgxPhongShader
        • TGXSLCustomShader
          • TgxBaseCustomGLSLDiffuseSpecular
            • TgxBaseGLSLDiffuseSpecularShaderMT
              • TgxCustomGLSLDiffuseSpecularShaderMT
                • TgxSLDiffuseSpecularShaderMT
              • TgxCustomGLSLMLDiffuseSpecularShaderMT
                • TgxSLMLDiffuseSpecularShaderMT
            • TgxCustomGLSLDiffuseSpecularShader
              • TgxSLDiffuseSpecularShader
            • TgxCustomGLSLMLDiffuseSpecularShader
              • TgxSLMLDiffuseSpecularShader
          • TgxCustomGLSLFurShader
            • TgxSLFurShader
          • TgxCustomGLSLGlassShader
            • TgxSLGlassShader
          • TgxCustomGLSLIvoryShader
            • TgxSLIvoryShader
          • TgxCustomGLSLSemShader
            • TgxSLSemShader
          • TgxCustomGLSLSimpleErosionShader
            • TgxSLSimpleErosionShader
          • TgxCustomGLSLSimpleGoochShader
            • TgxSLSimpleGoochShader
          • TgxCustomGLSLSimpleLatticeShader
            • TgxCustomGLSLLatticeShader
              • TgxSLLatticeShader
            • TgxSLSimpleLatticeShader
          • TgxCustomGLSLToonShader
            • TgxSLToonShader
          • TgxCustomGLSLVertexDisplacementShader
            • TgxSLVertexDisplacementShader
          • TgxslBaseCustomBumpShader
            • TgxslBaseCustomBumpShaderMT
              • TgxslCustomBumpShaderAM
                • TgxslBumpShaderAM
              • TgxslCustomBumpShaderMT
                • TgxslBumpShaderMT
              • TgxslCustomMLBumpShaderMT
                • TgxslMLBumpShaderMT
            • TgxslCustomBumpShader
              • TgxslBumpShader
            • TgxslCustomMLBumpShader
              • TgxslMLBumpShader
          • TgxslCustomPostBlurShader
            • TgxslPostBlurShader
          • TgxslCustomPostDreamVisionShader
            • TgxSLPostDreamVisionShader
          • TgxslCustomPostFrostShader
            • TgxslPostFrostShader
          • TgxslCustomPostNightVisionShader
            • TgxslPostNightVisionShader
          • TgxslCustomPostPixelateShader
            • TgxslPostPixelateShader
          • TgxslCustomPostPosterizeShader
            • TgxslPostPosterizeShader
          • TgxslCustomPostThermalVisionShader
            • TgxslPostThermalVisionShader
          • TgxslCustomPostTroubleShader
            • TgxslPostTroubleShader
          • TGXSLShader
      • TgxCustomShaderCombiner
        • TgxShaderCombiner
      • TgxHiddenLineShader
      • TgxMultiMaterialShader
      • TgxOutlineShader
      • TgxShaderF
      • TgxShaderG
      • TgxShaderTextureSharing
      • TgxShaderV
      • TgxTexCombineShader
      • TgxUserShader
    • TgxSilhouette
    • TgxStateCache
    • TgxTextureImageEditor
      • TgxBlankTIE
      • TgxPersistentTIE
      • TgxPicFileTIE
      • TgxProcTextureNoiseTIE
    • TgxTreeBranch
    • TgxTreeBranches
    • TgxTreeBranchNoise
    • TgxTreeLeaves
    • TgxVectorFileFormat
    • TgxVerletConstraint
      • TgxVerletDualConstraint
        • TgxVerletSlider
        • TgxVerletStick
      • TgxVerletGlobalConstraint
        • TgxVerletGlobalFrictionConstraint
          • TgxVerletFrictionCylinder
          • TgxVerletGlobalFrictionConstraintSP
            • TgxVerletFloor
              • TgxVerletHeightField
            • TgxVerletGlobalFrictionConstraintBox
              • TgxVerletFrictionCube
            • TgxVerletGlobalFrictionConstraintSphere
              • TgxVerletFrictionCapsule
              • TgxVerletFrictionSphere
      • TgxVerletGroupConstraint
        • TgxVerletRigidBody
    • TgxVerletForce
      • TgxVerletDualForce
        • TgxVerletSpring
      • TgxVerletGlobalForce
        • TgxVerletAirResistance
        • TgxVerletGravity
      • TgxVerletGroupForce
    • TgxVerletHair
    • TgxVerletWorld
    • TImposter
      • TStaticImposter
    • TIsoSurfaceExtractor
    • TList
      • TCollisionStates
      • TEdgeList
      • TFaceList
      • TFontManager
      • TgxInitializableObjectList
      • TgxNGDBehaviourList
      • TgxSoundFileFormatsList
      • TgxVerletConstraintList
      • TgxVerletEdgeList
      • TgxVerletForceList
      • TgxVerletNodeList
      • TMS3DCommentList
      • TObjectList
        • TgxCameraJobList
      • TVertexWeightList
    • TMD3TagList
    • TMS3DGroup
    • TNewtonRagdoll
    • TPersistent
      • TCollection
        • TgxActorAnimations
        • TgxBitmapFontRanges
        • TgxConsoleCommandList
        • TgxCyborgThinks
        • TgxEParticleMasks
        • TgxSkyDomeBands
        • TgxSkyDomeStars
        • TgxslTextureEmitters
        • TgxSoundSamples
        • TgxSoundSources
        • TgxTextureEmitters
        • TgxTextureEx
        • TgxTimeEvents
        • TOwnedCollection
          • TCUDAVertexAttributes
          • TgxAbstractLibMaterials
            • TgxLibMaterials
          • TgxGizmoExActionHistoryCollection
          • TgxGizmoExObjectCollection
          • TgxGizmoUndoCollection
          • TgxGuiComponentList
          • TgxGuiElementList
          • TgxMaterialLibraryItems
          • TgxMaterialMultiProxyMasters
          • TgxMovementPaths
          • TgxMultiProxyMasters
          • TgxNodes
            • TgxContourNodes
            • TgxLinesNodes
              • TgxPipeNodes
            • TLineNodes
          • TgxPathNodes
          • TgxPostShaderCollection
          • TgxShaderItems
          • TgxShaderTextureSharingMaterials
          • TgxShadowVolumeCasters
          • TgxSimpleNavigationKeyCombinations
          • TgxStaticImposterBuilderCoronas
          • TLibArchives
          • TLineCollection
          • TPFXLifeColors
      • TCollectionItem
        • TCUDAVertexAttribute
        • TgxAbstractLibMaterial
          • TgxLibMaterial
        • TgxActorAnimation
        • TgxBaseSoundSource
          • TgxSoundSource
        • TgxBitmapFontRange
        • TgxConsoleCommand
        • TgxContour
        • TgxEParticleMask
        • TgxGizmoExActionHistoryItem
        • TgxGizmoExObjectItem
        • TgxGizmoUndoItem
        • TgxGuiComponent
        • TgxGuiElement
        • TgxMaterialLibraryItem
        • TgxMovementPath
        • TgxMultiProxyMaster
        • TgxNGDJoint
        • TgxNGDSurfaceItem
        • TgxNGDSurfacePair
        • TgxNode
          • TgxLinesNode
          • TgxPipeNode
          • TLineNode
        • TgxPathNode
        • TgxPostShaderCollectionItem
        • TgxShaderItem
        • TgxShadowVolumeCaster
          • TgxShadowVolumeLight
          • TgxShadowVolumeOccluder
        • TgxSimpleNavigationKeyCombination
        • TgxSkyDomeBand
        • TgxSkyDomeStar
        • TgxslTextureEmitterItem
        • TgxSoundSample
        • TgxStaticImposterBuilderCorona
        • TgxTextureEmitterItem
        • TgxTextureExItem
        • TgxTimeEvent
        • TLibArchive
        • TLineItem
        • TPFXLifeColor
      • TComponent
        • TCUDAHandlesMaster
          • TCUDAComponent
            • TCUDAFFTPlan
            • TCUDAFunction
            • TCUDAGraphicResource
              • TCUDAGeometryResource
              • TCUDAImageResource
            • TCUDAMemData
            • TCUDAModule
            • TCUDATexture
            • TCUDAUniform
              • TCUDAConstant
              • TCUDAFuncParam
            • TgxSCUDA
        • TGLSLogger
        • TgxApplicationFileIO
        • TgxAsyncTimer
        • TgxAVIRecorder
        • TgxBaseAnimationControler
          • TgxAnimationControler
        • TgxBasePerlin
          • Tgx1DPerlin
          • Tgx2DPerlin
        • TgxCadencer
        • TgxCameraController
        • TgxCollisionManager
        • TgxDCEManager
        • TgxEParticleMasksManager
        • TgxFPSMovementManager
        • TgxGizmo
        • TgxGizmoEx
        • TgxHeightDataSource
          • TgxBaseRandomHDS
            • TgxCustomRandomHDS
              • TgxFractalHDS
            • TgxTiledRndLandscape
              • TgxFractalArchipelago
          • TgxBitmapHDS
          • TgxCustomHDS
          • TgxHeightDataSourceFilter
            • TgxAsyncHDS
            • TgxBumpmapHDS
            • TgxShadowHDS
          • TgxHeightTileFileHDS
          • TgxPerlinHDS
          • TgxTerrainBaseHDS
          • TgxTexturedHDS
        • TgxJoystick
        • TgxMaterialScripter
        • TgxNavigator
          • TgxSmoothNavigator
        • TgxNGDManager
        • TgxNonVisualViewer
          • TgxFullScreenViewer
          • TgxMemoryViewer
          • TgxSDLViewer
        • TgxObjectManager
        • TgxODEJointList
        • TgxODEManager
        • TgxPhysManager
        • TgxSArchiveManager
        • TgxScreenSaver
        • TgxScriptLibrary
        • TgxSCUDACompiler
        • TgxSCUDADevice
        • TgxSDLWindow
        • TgxSimpleNavigation
        • TgxSmoothUserInterface
        • TgxSoundLibrary
        • TgxUserInterface
        • TWaveSystem
      • TCUDADevice
      • TgxConsoleControls
      • TgxDisplayOptions
      • TgxGizmoRayCastHitData
      • TgxNavigatorAbstractParameters
        • TgxNavigatorAdjustDistanceParameters
        • TgxNavigatorAdjustDistanceParametersEx
      • TgxNavigatorGeneralParameters
      • TgxNavigatorInertiaParameters
      • TgxNavigatorMoveAroundParameters
      • TgxNGDDebugOption
      • TgxNGDJointKinematicController
      • TgxNGDJointPivot
        • TgxNGDJointBallAndSocket
        • TgxNGDJointPin
          • TgxNGDJointHinge
          • TgxNGDJointPin2
          • TgxNGDJointSlider
      • TgxODECollisionSurface
      • TgxODEJointParams
      • TgxShaderProgram
        • TgxFragmentProgram
        • TgxGeometryProgram
        • TgxVertexProgram
      • TgxSoundSampling
      • TgxSpriteAnimMargins
      • TgxTextAdjust
      • TgxZBuffer
      • TLogSession
      • TStrings
        • TStringList
          • TgxConsoleStringList
          • TgxMTLFile
      • TXCollection
        • TgxBehaviours
        • TgxEffects
        • TgxForces
        • TgxMapCollection
        • TgxNavigatorSmoothChangeItems
        • TgxODEElements
        • TgxODEJoints
        • TgxScripts
        • TgxSpriteAnimationList
        • TgxSpriteAnimFrameList
    • TPickRecord
    • TRasterFileFormat
    • GRedBlackTree.TRBNode
    • TSectorNode
      • TSPOctreeNode
        • TSPQuadtreeNode
    • TThread
      • TgxHeightDataThread
        • TgxAsyncHDThread
        • TgxPerlinHDSThread
      • TLogBufferFlushThread
      • TLogCheckSizeThread
  • TPlane
    • TGBEPlaneExtend
    • TOceanSurface
      • TTwoWavesOceanSurface
    • TomSailSurface
    • TWindArrowSurface
  • TPropertyEditor
    • TgxResolutionProperty
    • TUniformAutoSetProperty
  • TPythonEngine
    • TgxPythonEngine
  • TSelectionEditor
    • TgxBaseSceneObjectSelectionEditor
    • TgxSoundLibrarySelectionEditor
  • TStringProperty
    • TAsmProgFileProperty
    • TCUDACompilerSourceProperty
    • TCUDADeviceProperty
    • TgxAnimationNameProperty
    • TgxLibMaterialNameProperty
    • TgxMaterialComponentNameProperty
      • TgxLibAsmProgNameProperty
      • TgxLibAttachmentNameProperty
      • TgxLibCombinerNameProperty
      • TgxLibSamplerNameProperty
      • TgxLibShaderNameProperty
      • TgxLibTextureNameProperty
    • TgxSoundNameProperty
    • TPictureFileProperty
    • TShaderFileProperty
  • TViewport3D
    • TGBEViewport3D
    • TgxSceneViewer


GXSysHelp v.2.5: All Classes, Interfaces, Objects and Records

All Classes, Interfaces, Objects and Records

Name Unit Description
CUDAContextManager GXS.CUDA.Context

Static class of CUDA contexts manager.
DTriangle GLScene.Triangulation

Created Triangles, vv# are the vertex pointers
DVertex GLScene.Triangulation

Points (Vertices)
ECGxBombShaderException GXS.CgBombShader

ECGxShaderException GXS.CgShader

Define OutputCompilerWarnings to output CG compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.
ECustomShaderException GXSL.CustomShader

EDDSException Formatx.DDSImage

EFilerException GLScene.XCollection

EGLAtmosphereException GXS.Atmosphere

EGLCameraController GXS.CameraController

EGLConsoleException GXS.Console

EGLFile3DS GXS.File3DS

EGLImageUtils GXS.ImageUtils

EGLMotionBlurException GXS.Blur

EGLOBJFileError GXS.FileOBJ

EGLPostShaderHolderException GXSL.PostEffects

EGLROAMException GXS.ROAMPatch

GL_ARB_vertex_buffer_object Exception use by splitter for SafeTesselation
EGLUtilsException GLScene.Utils

EgxInvalidVectorFile GXS.VectorFileObjects

EgxslBumpShaderException GXSL.BumpShaders

EgxslDiffuseSpecularShaderException GXSL.DiffuseSpecularShader

EGXSLShaderException GXSL.Shader

EInvalidArchiveFile GXS.ArchiveManager

EInvalidRasterFile GXS.Graphics

EOpenGLError GLScene.OpenGL4

EOpenGLError GXS.OpenGLAdapter

EPBuffer GXS.Context

EProxyException GXS.ProxyObjects

ESDLError SDLx.Window

Generic SDL or SDLWindow exception.
EShaderException GXS.Texture

ETexture GXS.Texture

ETGAException GXS.FileTGA

EVXContext GXS.Context

EVXShader GXS.Context

EVXTextureCombinerError GXS.TextureCombiners

EZBufferException GXS.zBuffer

GRedBlackTree GLScene.RedBlackTree

GRedBlackTree.TRBNode GLScene.RedBlackTree

IDesigner FMxXCollectionEditor

IgxInitializable GXS.Scene

Interface to objects that need initialization
IgxMaterialLibrarySupported GXS.Material

an interface for proper TgxLibMaterialNameProperty support
IgxPostShader GXSL.CustomShader

Used in the TgxPostShaderHolder component.
IgxShaderDescription GXSL.CustomShader

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.
IgxShaderParameter GXSL.Parameter

IgxTextureNotifyAble GXS.Texture

IShaderParameter GXSL.ShaderParameter

StringGrid GXS.Windows

TAABB GLScene.GeometryBB

Structure for storing Axis Aligned Bounding Boxes
TArchiveFileFormat GXS.ArchiveManager

Registered archives for using extentions, e.g.: GLFilePak,GLFileZLib
TAsmProgFileProperty GXS.SceneRegister

TBaseConnectivity GXS.Silhouette

TBaseSpacePartition GXS.SpacePartition

Basic space partition, does not implement any actual space partitioning
TBoneMatrixObj GXS.ProxyObjects

An object containing the bone matrix for TgxActorProxy.
TBoxRec GLScene.VectorTypesExt

TBSPClusterVisibility GXS.BSP

TBSPCullingSphere GXS.BSP

TBSphere GLScene.GeometryBB

Structure for storing BoundingSpheres. Similar to TAABB
TBSPMeshObject GXS.BSP

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.
TBSPRenderContextInfo GXS.BSP

TCGxBombShader GXS.CgBombShader

TCGxCadencableCustomShader GXS.CgShader

Allows to use a Cadencer, which is used for noise generation in many shaders.
TCGxCustomBombShader GXS.CgBombShader

Just a good-looking shader.
TCGxCustomPostTransformationShader GXS.CgPostTransformationShader

TCGxCustomShader GXS.CgShader

TCGxFragmentProgram GXS.CgShader

TCGxParameter GXS.CgShader

Wrapper around a Cg parameter of the main program.
TCGxPostTransformationShader GXS.CgPostTransformationShader

TCGxProgram GXS.CgShader

Wrapper around a Cg program.
TCGxShader GXS.CgShader

TCGxVertexProgram GXS.CgShader

TChannelTypeAndNum GXS.CUDA.API

TCharInfo GXS.BitmapFont

TClassProperty GXS.RegisterXCollection

TCollisionState GXS.FPSMovement

TCollisionStates GXS.FPSMovement

TColorEditorFrame FRxColorEditor

TConnectivity GXS.Silhouette

TContactPoint GXS.FPSMovement

TCoronaTangentLookup GXS.Imposter

TCubicSpline GLScene.Spline

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.
TCUDACompilerEditor GXS.GPURegister

TCUDACompilerEditor GXS.ParallelRegister

TCUDACompilerSourceProperty GXS.GPURegister

TCUDACompilerSourceProperty GXS.ParallelRegister

TCUDAComponent GXS.CUDA.API

TCUDAConstant GXS.CUDA.API

TCUDAContext GXS.CUDA.Context

TCUDADevice GXS.CUDA.Context

TCUDADeviceProperty GXS.GPURegister

TCUDADeviceProperty GXS.ParallelRegister

TCUDADimensions GXS.CUDA.Context

TCUDAEditor GXS.GPURegister

TCUDAEditor GXS.ParallelRegister

TCUDAEditorForm FMxCUDAEditor

TCUDAFFTPlan GXS.CUDA.FFTPlan

TCUDAFuncParam GXS.CUDA.API

TCUDAFunction GXS.CUDA.API

TCUDAGeometryResource GXS.CUDA.Graphics

TCUDAGraphicResource GXS.CUDA.API

Abstract class of graphic resources.
TCUDAHandlesMaster GXS.CUDA.Context

TCUDAImageResource GXS.CUDA.Graphics

TCUDAMemData GXS.CUDA.API

TCUDAModule GXS.CUDA.API

TCUDATexture GXS.CUDA.API

TCUDAUniform GXS.CUDA.API

TCUDAVertexAttribute GXS.CUDA.Graphics

TCUDAVertexAttributes GXS.CUDA.Graphics

TCustomMeshHelper GBE.ConeExtend

TCustomMeshHelper GBE.CylinderExtend

TCustomMeshHelper GBE.SphereExtend

TCustomMeshHelper uGBEUtils3D

TD3DMatrix GLScene.VectorTypes

TD3DVector GLScene.VectorTypes

TDDSImage Formatx.DDSImage

TDESolver GXS.PhysManager

need to have state array(s) seperate from inertias to allow for implicit & explicit methods
TDESolverEuler GXS.PhysManager

TDESolverExplicit GXS.PhysManager

explicit e.g. Euler, Mid-point, Runge-Kutta integration
TDESolverImplicit GXS.PhysManager

implicit e.g. Verlet Integration
TDESolverRungeKutta4 GXS.PhysManager

TDESolverVerlet GXS.PhysManager

TDim GLScene.VectorTypesExt

TDwsGLXceneUnit VXS.DWSScene

TECCollider GXS.EllipseCollision

TECCollisionPacket GXS.EllipseCollision

TECContact GXS.EllipseCollision

TECFreeForm GXS.EllipseCollision

TECMovePack GXS.EllipseCollision

TECObjectInfo GXS.EllipseCollision

Object collision properties
TECPlane GXS.EllipseCollision

TECTriangle GXS.EllipseCollision

TECTriMesh GXS.EllipseCollision

TEdge GXS.VerletClothify

TEdgeDetector GXS.VerletClothify

TEdgeList GXS.VerletClothify

TExtendedFrustum GXS.SpacePartition

Extended frustum, used for fast intersection testing
TFace GXS.VerletClothify

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes
TFaceEditorFrame FRxFaceEditor

TFaceExtractor GXS.VerletClothify

Class that extracts faces from a GLBaseMesh
TFaceList GXS.VerletClothify

List of faces
TFaceRec GLScene.VectorTypesExt

TFGBezierSurface GXS.ParametricSurfaces

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.
TFGBSPNode GXS.BSP

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.
TFGPolygon GXS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGPortalPolygon GXS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGVertexNormalTexIndexList GXS.VectorFileObjects

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.
TFileNMF GXS.FileNMF

TFileSection GXS.FileZLIB

TFileSection GXS.PAKArchive

TFireParticle GXS.FireFX

TFontEntry GXS.SpaceText

TFontManager GXS.SpaceText

Manages a list of fonts for which display lists were created.
TFractionErosion GXS.RandomHDS

TFrustum GLScene.VectorGeometry

TGBEClouds GBE.Clouds

TGBECollisionRetour uGBEUtils3D

TGBEConeExtend GBE.ConeExtend

TGBECubeExtend GBE.CubeExtend

TGBECubemap GBE.Cubemap

TGBECylinderExtend GBE.CylinderExtend

TGBEGrass GBE.Grass

TGBEHeightmap GBE.Heightmap

TGBEJoystick GBE.Joystick

TGBENoeud uGBEPathFinder

TGBEOptions uGBEOptionsUtils

TGBEPathFinder uGBEPathFinder

TGBEPlaneExtend GBE.PlaneExtend

TGBEPlayerPosition GBE.PlayerPosition

TGBESphereExtend GBE.SphereExtend

TGBEStep GBE.TimeLine

TGBETerrain GBE.Terrain

TGBETimeline GBE.TimeLine

TGBEViewport3D GBE.Viewport3D

TGClipRect GLScene.GeometryBB

TGDelaunay2D GLScene.Triangulation

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact
TGLBallAndSocketJoint GXS.PhysJoints

TGLBaseJoint GXS.PhysJoints

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)
TGLBaseLink GXS.PhysJoints

TGLExtensionsAndEntryPoints GXS.OpenGLAdapter

TGLJoint GXS.PhysJoints

TGLLink GXS.PhysJoints

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned
TGLPrismaticJoint GXS.PhysJoints

TGLRadialGravityEmitter GXS.PhysFields

TGLRevoluteJoint GXS.PhysJoints

TGLSceneViewport GXS.FMX.Viewer

TGLSLogger GLScene.Logger

Abstract class for control logging.
TglTFVectorFile GXS.FileGLTF

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.
TGLType1Link GXS.PhysJoints

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //
TGLType2Link GXS.PhysJoints

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //
TGLType3Link GXS.PhysJoints

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|
TGLType4Link GXS.PhysJoints

TGLType5Link GXS.PhysJoints

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //
TGLType6Link GXS.PhysJoints

TGLType7Link GXS.PhysJoints

TGLType8Link GXS.PhysJoints

TGLUniformGravityEmitter GXS.PhysFields

GXS.RigidBodyInertia
TGLUNurbs GLScene.OpenGL4

TGLUNurbs GLScene.OpenGLTokens

——————- OpenGL Utility (GLU) types —————- GLU types
TGLUQuadric GLScene.OpenGL4

TGLUQuadric GLScene.OpenGLTokens

TGLUTesselator GLScene.OpenGL4

TGLUTesselator GLScene.OpenGLTokens

TGPUDEVICE GLScene.OpenGL4

TGPUDEVICE GLScene.OpenGLTokens

TgTransformation GLScene.PipelineTransform

TgTransformationRec GLScene.PipelineTransform

TGUILayoutForm FMxGuiLayoutEditor

TGUIRect GXS.Gui

Tgx1DPerlin GXS.Perlin

Tgx2DPerlin GXS.Perlin

Tgx2DPerlinOctav GXS.Perlin

Tgx3DSVectorFile GXS.File3DS

The 3DStudio vector file. A 3DS file may contain material information and require textures when loading.
TgxAbsoluteHUDText GXS.HUDObjects

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.
TgxAbstractLibMaterial GXS.Material

TgxAbstractLibMaterials GXS.Material

TgxAbstractMaterialLibrary GXS.Material

TgxAbstractMultitextureCoordinator GXS.Context

TgxActiveAttrib GXSL.Shader

TgxActor GXS.VectorFileObjects

Mesh class specialized in animated meshes. The TgxActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TgxAnimationControler components).
TgxActorAnimation GXS.VectorFileObjects

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TgxAnimationControler.
TgxActorAnimations GXS.VectorFileObjects

Collection of actor animations sequences.
TgxActorProxy GXS.ProxyObjects

A proxy object specialized for Actors.
TgxAdvancedLabel GXS.Windows

TgxAnimatedSprite GXS.AnimatedSprite

An animated version for using offset texture coordinate animation.
TgxAnimationControler GXS.VectorFileObjects

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TgxActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.
TgxAnimationNameProperty GXS.SceneRegister

TgxAnnulus GXS.GeomObjects

An annulus is a cylinder that can be made hollow (pipe-like).
TgxApplicationFileIO GXS.ApplicationFileIO

Allows specifying a custom behaviour for TFileStream.Create. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.
TgxArchiveFileFormatsList GXS.ArchiveManager

List of registered classes
TgxArray GXS.InitOpenGL

———————————————————————–
TgxArray OpenGXS.InitFMX

———————————————————————–
TgxArrowArc GXS.GeomObjects

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off
TgxArrowLine GXS.GeomObjects

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off
TgxASEFace GXS.FileASE

ASE mesh face
TgxASEFaceList GXS.FileASE

ASE mesh faces list
TgxASEFaceTexure GXS.FileASE

maximum texture maps face texture channel indices
TgxASEFaceTexureChannels GXS.FileASE

face texture channels
TgxASEMaterial GXS.FileASE

TgxASEMaterialList GXS.FileASE

TgxASEMaterialTextureMap GXS.FileASE

TgxASEMaterialTextureMaps GXS.FileASE

TgxASEMeshObject GXS.FileASE

ASE geom object, represents single mesh object; contains: vertices, faces, vertex indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into TgxMeshObject
TgxASESmoothingGroups GXS.FileASE

TgxASESubMaterial GXS.FileASE

TgxASESubMaterialList GXS.FileASE

TgxASEVectorFile GXS.FileASE

ASE vector file parser
TgxAsmShader GXSL.AsmShader

TgxAsmShaderParameter GXSL.AsmShader

TgxAsyncHDS GXS.AsyncHDS

TgxAsyncHDThread GXS.AsyncHDS

TgxAsyncTimer GXS.AsyncTimer

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.
TgxAtmosphere GXS.Atmosphere

TgxAVIRecorder GXS.AVIRecorder

Component to make it easy to record GLScene frames into an AVI file.
TgxB3DVectorFile GXS.FileB3D

TgxBAcceleration GXS.Behaviours

Applies a constant acceleration to a TgxBInertia.
TgxBaseAnimationControler GXS.VectorFileObjects

Base class for skeletal animation control.
TgxBaseArchive GXS.ArchiveManager

Base classes for archivers
TgxBaseBehaviour GXS.Scene

Base class for implementing behaviours in TgxScene. Behaviours are regrouped in a collection attached to a TgxBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)

Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function
TgxBaseComponent GXS.Windows

TgxBaseControl GXS.Windows

TgxBaseCustomGLSLDiffuseSpecular GXSL.DiffuseSpecularShader

Abstract class.
TgxBaseFontControl GXS.Windows

TgxBaseForceFieldEmitter GXS.PhysManager

A base for different types of force-field behaviours
TgxBaseGLSLDiffuseSpecularShaderMT GXSL.DiffuseSpecularShader

Abstract class.
TgxBaseGuiObject GXS.Gui

TgxBaseImage GXS.Graphics

TgxBaseInertia GXS.PhysManager

purpose of TgxBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TgxParticleInertia (for a 3D particle) TgxRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. Tgx1DParticleInertia, this will allow for faster speed
TgxBaseMesh GXS.VectorFileObjects

Base class for mesh objects.
TgxBaseMeshConnectivity GXS.BaseMeshSilhouette

TgxBaseMeshObject GXS.VectorFileObjects

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own.
TgxBasePerlin GXS.Perlin

TgxBasePerlinOctav GXS.Perlin

TgxBaseRandomHDS GXS.RandomHDS

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TgxCustomRandomLandscape: one tile landscape (cyclic or not) - TgxTiledRndLandscape: "infinite" landscapes (grids of TgxCustomRandomLandscape)
TgxBaseSceneObject GXS.Scene

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.
TgxBaseSceneObjectSelectionEditor GXS.SceneRegister

Selection editor for TgxBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TgxBaseSceneObject at design-time.
TgxBaseSelectTechnique GXS.Selection

TgxBaseSoundSource GXS.SoundManager

Base class for origin of sound playback.
TgxBaseSpritePFXManager GXS.ParticleFX

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.
TgxBaseTextControl GXS.Windows

TgxBaseVerletNode GXS.VerletTypes

Basic Verlet Node
TgxBCollision GXS.Collision

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TgxBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.
TgxBehaviour GXS.Scene

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".
TgxBehaviours GXS.Scene

Holds a list of TgxBehaviour objects. This object expects itself to be owned by a TgxBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TgxBehaviour subclasses.
TgxBExplosionFX GXS.ExplosionFx

TgxBFireFX GXS.FireFX

Fire special effect. This effect works as a client of TFireFXManager
TgxBFPSMovement GXS.FPSMovement

TgxBInertia GXS.Behaviours

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).
TgxBitmapFont GXS.BitmapFont

See TgxCustomBitmapFont. This class only publuishes some of the properties.
TgxBitmapFontRange GXS.BitmapFont

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).
TgxBitmapFontRanges GXS.BitmapFont

TgxBitmapHDS GXS.HeightData

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.
TgxBlankImage GXS.Texture

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TgxMemoryViewer for instance).
TgxBlankTIE GXS.TextureImageEditors

TGXBlendedLerpInfo GXS.VectorFileObjects

Small structure to store a weighted lerp for use in blending.
TgxBlendingParameters GXS.Material

TgxBlur GXS.Blur

TgxBMPImage GXS.FileBMP

TgxBooleanOcclusionQueryHandle GXS.Context

TgxBSoundEmitter GXS.SoundManager

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TgxSoundSource, for editing convenience.
TgxBThorFX GXS.ThorFX

Thor special effect
TgxBuffer GXS.InitOpenGL

———————————————————————–
TgxBuffer OpenGXS.InitFMX

———————————————————————–
TgxBufferI GXS.InitOpenGL

———————————————————————–
TgxBufferI OpenGXS.InitFMX

———————————————————————–
TgxBufferObjectHandle GXS.Context

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TgxBufferU GXS.InitOpenGL

———————————————————————–
TgxBufferU OpenGXS.InitFMX

———————————————————————–
TgxBufferV GXS.InitOpenGL

———————————————————————–
TgxBufferV OpenGXS.InitFMX

———————————————————————–
TgxBumpmapHDS GXS.BumpmapHDS

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.
TgxBumpShader GXSL.BumpShaders

A generic bump shader
TgxButton GXS.Windows

TgxCadencedComponent GXS.Cadencer

TgxCadencer GXS.Cadencer

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TgxScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).
TgxCamera GXS.Scene

Camera object. This object is commonly referred by TgxSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.
TgxCameraController GXS.CameraController

TgxCameraInvariantObject GXS.Scene

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).
TgxCameraJob GXS.CameraController

TgxCameraJobList GXS.CameraController

TgxCanvas GXS.Canvas

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).
TgxCapsule GXS.GeomObjects

Capsule object, can also be used to make truncated cones
TgxCelShader GXS.CelShader

A generic cel shader.
TgxCelShader GXSL.ShapeShaders

A generic cel shader.
TgxCheckBox GXS.Windows

TgxCollisionManager GXS.Collision

TgxColorProperty GXS.SceneRegister

TgxColorProxy GXS.ProxyObjects

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.
TgxCombinerCommand GXS.TextureCombiners

TgxCompositeImage GXS.CompositeImage

TgxCone GXS.GeomObjects

A cone object
TgxConsole GXS.Console

TgxConsoleCommand GXS.Console

A wrapper for a console command.
TgxConsoleCommandList GXS.Console

TgxConsoleControls GXS.Console

TgxConsoleStringList GXS.Console

A class that checks for duplicates.
TgxContext GXS.Context

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists.
TgxContextHandle GXS.Context

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.
TgxContextManager GXS.Context

Stores and manages all the TgxContext objects.
TgxContextNotification GXS.Context

TgxContour GXS.MultiPolygon

TgxContourNodes GXS.MultiPolygon

TgxContours GXS.MultiPolygon

TgxCoordinatesProperty GXS.SceneRegister

TgxCreateParams GXS.SceneViewer

WGL_EXT_swap_control
TgxCube GXS.Objects

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TgxFreeForm and a material library.
TgxCubeMapImage GXS.Texture

A texture image used for specifying and stroing a cube map. Not unlike TgxPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.
TgxCustomAsmShader GXSL.AsmShader

TgxCustomAtmosphere GXS.Atmosphere

This class imitates an atmosphere around a planet.
TgxCustomBitmapFont GXS.BitmapFont

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.
TgxCustomCadencedComponent GXS.Cadencer

Adds a property to connect/subscribe to a cadencer.
TgxCustomConsole GXS.Console

TgxCustomConsole
TgxCustomControl GXS.Windows

TgxCustomFeedBackMesh GXS.CUDA.Graphics

TgxCustomGLSLDiffuseSpecularShader GXSL.DiffuseSpecularShader

******** Single Light ************
TgxCustomGLSLDiffuseSpecularShaderMT GXSL.DiffuseSpecularShader

TgxCustomGLSLFurShader GXSL.ShapeShaders

Custom class for Fur Shader
TgxCustomGLSLGlassShader GXSL.ShapeShaders

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms
TgxCustomGLSLIvoryShader GXSL.ShapeShaders

Custom class for a shader that simulate Ivory Material
TgxCustomGLSLLatticeShader GXSL.ShapeShaders

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture
TgxCustomGLSLMLDiffuseSpecularShader GXSL.DiffuseSpecularShader

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas
TgxCustomGLSLMLDiffuseSpecularShaderMT GXSL.DiffuseSpecularShader

TgxCustomGLSLSemShader GXSL.ShapeShaders

Custom class for SEM Shader : Spherical Environment Mapping
TgxCustomGLSLSimpleErosionShader GXSL.ShapeShaders

Custom class for a shader that Erode surface object
TgxCustomGLSLSimpleGoochShader GXSL.ShapeShaders

Custom class for Gooch Shader
TgxCustomGLSLSimpleLatticeShader GXSL.ShapeShaders

Custom class for a shader that simulate Lattice
TgxCustomGLSLToonShader GXSL.ShapeShaders

Custom class for Toon Shader
TgxCustomGLSLVertexDisplacementShader GXSL.ShapeShaders

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported
TgxCustomHDS GXS.HeightData

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).
TgxCustomPFXManager GXS.ParticleFX

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.
TgxCustomRandomHDS GXS.RandomHDS

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.
TgxCustomSceneObject GXS.Scene

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TgxMaterial.
TgxCustomShader GXSL.CustomShader

A pure abstract class, must be overriden.
TgxCustomShaderCombiner GXSL.ShaderCombiner

TgxCustomShaderParameter GXSL.CustomShader

Wrapper around a parameter of the main program.
TgxCustomSpritePFXManager GXS.ParticleFX

A sprite-based particles FX managers using user-specified code to prepare the texture .
TgxCyborg GXS.SmartObjects

The Cyborg class specialized as a smart actor with AI. The TgxCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).
TgxCyborgManager GXS.CyborgManager

TgxCyborgThinks GXS.SmartObjects

TgxCyborgThinksList GXS.SmartObjects

A list of thinking periods for TgxCyborgThinkMode
TgxCylinder GXS.GeomObjects

Cylinder object, can also be used to make truncated cones
TgxCylinderBase GXS.GeomObjects

Base class to cylinder-like objects. Introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.
TgxDamping GXS.Behaviours

Holds parameters for TgxScene basic damping model. Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas : damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics :). A note on the components : constant : use it for solid friction (will stop abruptly an object after decreasing its speed. linear : linear friction damping. quadratic : expresses viscosity.
TgxDampingFieldEmitter GXS.PhysFields

TgxDataFile GXS.ApplicationFileIO

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.
TgxDCECollision GXS.DCE

TgxDCEDynamic GXS.DCE

TgxDCEManager GXS.DCE

TgxDCEStatic GXS.DCE

TgxDDSImage GXS.FileDDS

TgxDepthProperties GXS.Material

TgxDepthRBO GXS.FBO

TgxDirectOpenGL GXS.Scene

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.
TgxDisk GXS.GeomObjects

A Disk object. The disk may not be complete, it can have a hole (controled by the InnerRadius property) and can only be a slice (controled by the StartAngle and SweepAngle properties).
TgxDisplayOptions GXS.Screen

TgxDodecahedron GXS.GeomObjects

The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TgxDummyCube GXS.Objects

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).
TgxDwsActiveBehaviour GXS.DwsObjects

A DelphiWebScript enabled behaviour. This behaviour also calls on the OnProgress and OnBeginProgram procedures in the script if they are found. Once compiled and executed the program remains active until killed, deactivated or the script is invalidated.
TgxDXFVectorFile GXS.FileDXF

TgxDynamicImposterBuilder GXS.Imposter

TgxDynamicPFXManager GXS.ParticleFX

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).
TgxDynamicTextureImage GXS.DynamicTexture

Allows for fast updating of the texture at runtime.
TgxEarthSkyDome GXS.Skydome

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TgxEarthSkyDome.
TgxEdit GXS.Windows

TgxEffect GXS.Scene

TgxEffectClass = class of TgxEffect;
TgxEffects GXS.Scene

Holds a list of object effects. This object expects itself to be owned by a TgxBaseSceneObject.
TgxEParticleMask GXS.EParticleMasksManager

TgxEParticleMasks GXS.EParticleMasksManager

TgxEParticleMasksManager GXS.EParticleMasksManager

TgxExtrusionSolid GXS.Extrusion

Extrudes a complex Polygon into Z direction. For contour description see TgxMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TgxRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.
TgxFaceGroup GXS.VectorFileObjects

Describes a face group of a TgxMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.
TgxFaceGroupConnectivity GXS.BaseMeshSilhouette

TgxFaceGroups GXS.VectorFileObjects

A list of TgxFaceGroup objects.
TgxFaceProperties GXS.Material

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).
TgxFBORenderer GXS.FBORenderer

TgxFeedback GXS.Feedback

An object encapsulating the feedback rendering mode.
TgxFeedBackMesh GXS.CUDA.Graphics

TgxFGIndexTexCoordList GXS.VectorFileObjects

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.
TgxFGVertexIndexList GXS.VectorFileObjects

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.
TgxFile3DSActor GXS.File3DSSceneObjects

TgxFile3DSAnimationData GXS.File3DS

A record that holds all the information that is used during 3ds animation.
TgxFile3DSAnimationKeyList GXS.File3DS

TgxFile3DSAnimationKeys GXS.File3DS

An abstract class that describes how to interpolate animation keys.
TgxFile3DSCamera GXS.File3DSSceneObjects

TgxFile3DSCameraObject GXS.File3DS

A 3ds-specific camera.
TgxFile3DSColorAnimationKeys GXS.File3DS

TgxFile3DSDummyObject GXS.File3DS

A 3ds-specific TgxMorphableMeshObject.
TgxFile3DSFreeForm GXS.File3DSSceneObjects

TgxFile3DSLight GXS.File3DSSceneObjects

TgxFile3DSLightHotSpotAnimationKeys GXS.File3DS

TgxFile3DSMeshObject GXS.File3DS

A 3ds-specific mesh object.
TgxFile3DSOmniLightObject GXS.File3DS

A 3ds-specific omni light.
TgxFile3DSPositionAnimationKeys GXS.File3DS

TgxFile3DSRollAnimationKeys GXS.File3DS

TgxFile3DSRotationAnimationKeys GXS.File3DS

TgxFile3DSScaleAnimationKeys GXS.File3DS

TgxFile3DSSpotLightCutOffAnimationKeys GXS.File3DS

TgxFile3DSSpotLightObject GXS.File3DS

A 3ds-specific spot light.
TgxFileDAE GXS.FileDAE

The DAE vector file (COLLADA actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).
TgxFinishTaskEvent GXS.Context

TgxFireFXManager GXS.FireFX

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.
TgxFlareGradient GXS.LensFlare

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.
TgxFlatText GXS.BitmapFont

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TgxBitmapFont component. Default character scale is 1 font pixel = 1 space unit.
TgxFocusControl GXS.Windows

TgxFogEnvironment GXS.Scene

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.
TgxForce GXS.PhysForces

TgxForces GXS.PhysManager

TgxForm GXS.Windows

TgxFPSMovementManager GXS.FPSMovement

TgxFractalArchipelago GXS.RandomHDS

TgxFractalHDS GXS.RandomHDS

Random landscape based on the middle-point displacement algorithm
TgxFragmentProgram GXSL.CustomShader

TgxFragmentProgramHandle GXS.Context

TgxFragmentShaderHandle GXS.Context

Manages a handle to a Fragment Shader Object.
TgxFrameBuffer GXS.FBO

TgxFramebufferHandle GXS.Context

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.
TgxFreeForm GXS.VectorFileObjects

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.
TgxFreeFormProxy GXS.ProxyObjects

A proxy object specialized for FreeForms.
TgxFrustrum GXS.GeomObjects

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.
TgxFullScreenViewer GXS.FullScreenViewer

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.
TgxGameMenu GXS.GameMenu

Classic game menu interface made of several lines.
TgxGeometryProgram GXSL.CustomShader

TgxGeometryProgramHandle GXS.Context

TgxGeometryShaderHandle GXS.Context

Manages a handle to a Geometry Shader Object.
TgxGizmo GXS.Gizmo

TgxGizmoEx GXS.GizmoEx

TgxGizmoExActionHistoryCollection GXS.GizmoEx

TgxGizmoExActionHistoryItem GXS.GizmoEx

TgxGizmoExObjectCollection GXS.GizmoEx

TgxGizmoExObjectItem GXS.GizmoEx

TgxGizmoExUIArrowLine GXS.GizmoEx

TgxGizmoExUIDisk GXS.GizmoEx

TgxGizmoExUIFlatText GXS.GizmoEx

TgxGizmoExUIFrustrum GXS.GizmoEx

Gizmo objects
TgxGizmoExUILines GXS.GizmoEx

TgxGizmoExUIPolygon GXS.GizmoEx

TgxGizmoExUISphere GXS.GizmoEx

TgxGizmoExUITorus GXS.GizmoEx

TgxGizmoPickCube GXS.Gizmo

TgxGizmoPickTorus GXS.Gizmo

TgxGizmoRayCastHitData GXS.Gizmo

TgxGizmoUndoCollection GXS.Gizmo

TgxGizmoUndoItem GXS.Gizmo

TgxGLAVectorFile GXS.FileGL2

TgxGLMVectorFile GXS.FileGL2

TgxGRDVectorFile GXS.FileGRD

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats
TgxGTSVectorFile GXS.FileGTS

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/
TgxGuiComponent GXS.Gui

TgxGuiComponentList GXS.Gui

TgxGuiElement GXS.Gui

TgxGuiElementList GXS.Gui

TgxGuiLayout GXS.Gui

TgxGUILayoutEditor GXS.SceneRegister

TgxHDRImage GXS.FileHDR

TgxHeightData GXS.HeightData

TgxHeightData = class (TObject)
TgxHeightDataSource GXS.HeightData

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TgxHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TgxHeightData with its "Release" method) Pre-loading : specify a list of TgxHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task
TgxHeightDataSourceFilter GXS.HeightData

Height Data Source Filter. This component sits between the TgxTerrainRenderer, and a real TgxHeightDataSource. i.e. TgxTerrainRenderer links to this. This links to the real TgxHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TgxHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TgxHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TgxHeightData object from the Source HDS's cache, before linking your texture. See the new version of TgxBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.
TgxHeightDataThread GXS.HeightData

A thread specialized for processing TgxHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly
TgxHeightDataUser GXS.HeightData

TgxHeightField GXS.Graph

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.
TgxHeightTile GXS.HeightTileFile

TgxHeightTileFile GXS.HeightTileFile

Interfaces a Tiled file
TgxHeightTileFileHDS GXS.HeightTileFileHDS

An Height Data Source for the HTF format.
TgxHeightTileInfo GXS.HeightTileFile

TgxHexahedron GXS.GeomObjects

The hexahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TgxHiddenLineShader GXS.HiddenLineShader

TgxHiddenLineShader GXSL.LineShaders

TgxHookesSpring GXS.PhysForces

TgxHookesString GXS.PhysForces

TgxHUDSprite GXS.HUDObjects

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TgxHUDSprite in 2D only scenes : The most convenient way to use a TgxHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TgxHUDSprite works in absolute coordinates, TgxProxyObject can't be used to duplicate an hud sprite.
TgxHUDText GXS.HUDObjects

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TgxBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.
TgxIcosahedron GXS.GeomObjects

The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TgxImage GXS.Graphics

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GXS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.
TgxImageClassProperty GXS.SceneRegister

TgxImageLevelDesc GXS.Graphics

TgxImmaterialSceneObject GXS.Scene

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.
TgxImposter GXS.Imposter

TgxImposterBuilder GXS.Imposter

Abstract ImposterBuilder class.
TgxInertiaTensor GXS.PhysInertias

Stores Inertia Tensor for TgxRigidBodyInertia model
TgxInitializableObjectList GXS.Scene

Just a list of objects that support IGLInitializable.
TgxIsoline GXS.Isolines

TgxIsolines GXS.Isolines

TgxJoystick GXS.Joystick

A component interfacing the Joystick via the (regular) windows API.
TgxJPEGImage GXS.FileJPEG

TgxLabel GXS.Windows

TgxLensFlare GXS.LensFlare

TgxLibAsmProgNameProperty GXS.SceneRegister

TgxLibAttachmentNameProperty GXS.SceneRegister

TgxLibCombinerNameProperty GXS.SceneRegister

TgxLibMaterial GXS.Material

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).
TgxLibMaterialNameProperty GXS.SceneRegister

DesignIntf, DesignEditors, DesignMenus,
TgxLibMaterials GXS.Material

A collection of materials, mainly used in material libraries.
TgxLibSamplerNameProperty GXS.SceneRegister

TgxLibShaderNameProperty GXS.SceneRegister

TgxLibTextureNameProperty GXS.SceneRegister

TgxLifeColoredPFXManager GXS.ParticleFX

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.
TgxLightSource GXS.Scene

Standard light source. The standard light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TgxScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.
TgxLightSourceState GXS.State

TgxLineBase GXS.Objects

Base class for line objects. Introduces line style properties (width, color...)
TgxLineParticle GXS.LinePFX

Linear particle.
TgxLinePFXManager GXS.LinePFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.
TgxLines GXS.Objects

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.
TgxLineSettings GXS.HiddenLineShader

TgxLineSettings GXSL.LineShaders

TgxLinesNode GXS.Objects

Specialized Node for use in a TgxLines objects. Adds a Color property (TgxColor).
TgxLinesNodes GXS.Objects

Specialized collection for Nodes in a TgxLines objects. Stores TgxLinesNode items.
TgxListHandle GXS.Context

Manages a handle to a display list.
TgxLMTSVectorFile GXS.FileLMTS

TgxLWOVectorFile GXS.FileLWO

TgxMapCollection GXS.FPSMovement

TgxMapCollectionItem GXS.FPSMovement

TgxMarchingCube GXS.Isosurface

TgxMaterial GXS.Material

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TgxLibMaterial (taken for a material library). The TgxLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps
TgxMaterialComponentNameProperty GXS.SceneRegister

TgxMaterialLibrary GXS.Material

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.
TgxMaterialLibraryEditor GXS.SceneRegister

Editor for material library.
TgxMaterialLibraryItem GXS.MaterialScript

TgxMaterialLibraryItems GXS.MaterialScript

TgxMaterialMultiProxy GXS.MaterialMultiProxy

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).
TgxMaterialMultiProxyMaster GXS.MaterialMultiProxy

MasterObject description for a MultiProxy object.
TgxMaterialMultiProxyMasters GXS.MaterialMultiProxy

Collection of TgxMaterialMultiProxyMaster.
TgxMaterialProperty GXS.SceneRegister

TgxMaterialProxy GXS.ProxyObjects

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.
TgxMaterialScripter GXS.MaterialScript

TgxMD2VectorFile GXS.FileMD2

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.
TgxMD3VectorFile GXS.FileMD3

TgxMD5VectorFile GXS.FileMD5

TgxMDCVectorFile GXS.FileMDC

TgxMemoryViewer GXS.Scene

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).
TgxMesh GXS.Mesh

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)
TgxMeshLines GXS.MeshLines

TgxMeshMorphTarget GXS.VectorFileObjects

A morph target, stores alternate lists of vertices and normals.
TgxMeshMorphTargetList GXS.VectorFileObjects

A list of TgxMeshMorphTarget objects.
TgxMeshObject GXS.VectorFileObjects

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TMOxxx".
TgxMeshObjectList GXS.VectorFileObjects

A list of TgxMeshObject objects.
TgxMeshObjectVerletNode GXS.VerletClothify

TgxMirror GXS.Mirror

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.
TgxMorphableMeshObject GXS.VectorFileObjects

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre- existing "morph targets".
TgxMotionBlur GXS.Blur

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup
TgxMovement GXS.Movement

TgxMovementPath GXS.Movement

TgxMovementPaths GXS.Movement

TgxMoveToPosJob GXS.CameraController

TgxMP3File GXS.FileMP3

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.
TgxMS3DVectorFile GXS.FileMS3D

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!
TgxMTLFile GXS.FileOBJ

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)
TgxMultiMaterialShader GXS.MultiMaterialShader

TgxMultiMaterialShader GXSL.MultiMaterialShader

TgxMultiPolygon GXS.MultiPolygon

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).
TgxMultiPolygonBase GXS.MultiPolygon

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TgxMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GXS.VectorLists.
TgxMultiProxy GXS.MultiProxy

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).
TgxMultiProxyMaster GXS.MultiProxy

MasterObject description for a MultiProxy object.
TgxMultiProxyMasters GXS.MultiProxy

Collection of TgxMultiProxyMaster.
TgxMultisampleImage GXS.MultisampleImage

TgxNavigator GXS.Navigator

TgxNavigator is the component for moving a TgxBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction

The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal.
TgxNavigatorAbstractParameters GXS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.
TgxNavigatorAdjustDistanceParameters GXS.SmoothNavigator

This is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work
TgxNavigatorAdjustDistanceParametersEx GXS.SmoothNavigator

This is a wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.
TgxNavigatorGeneralParameters GXS.SmoothNavigator

This is a wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.
TgxNavigatorInertiaParameters GXS.SmoothNavigator

This is a wrapper for all parameters that affect the smoothness of movement
TgxNavigatorMoveAroundParameters GXS.SmoothNavigator

This is a wrapper for all parameters that effect how the TgxBaseSceneObject.MoveObjectAround() procedure works
TgxNavigatorSmoothChangeItem GXS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement
TgxNavigatorSmoothChangeItems GXS.SmoothNavigator

XCollection of TgxNavigatorSmoothChangeItem.
TgxNavigatorSmoothChangeSingle GXS.SmoothNavigator

Smoothly change any Single value, so it will become TargetValue in the end.
TgxNavigatorSmoothChangeVector GXS.SmoothNavigator

Smoothly change any Vector4f value, so it will become TargetValue in the end.
TgxNGDBehaviour GXS.NGDManager

Basis structures for behaviour style implementations.
TgxNGDBehaviourList GXS.NGDManager

TgxNGDDebugOption GXS.NGDManager

TgxNGDDynamic GXS.NGDManager

TgxNGDHeightField GXS.NGDManager

TgxNGDJoint GXS.NGDManager

TgxNGDJointBallAndSocket GXS.NGDManager

TgxNGDJointHinge GXS.NGDManager

TgxNGDJointKinematicController GXS.NGDManager

TgxNGDJointPin GXS.NGDManager

TgxNGDJointPin2 GXS.NGDManager

TgxNGDJointPivot GXS.NGDManager

TgxNGDJointSlider GXS.NGDManager

TgxNGDManager GXS.NGDManager

TgxNGDStatic GXS.NGDManager

TgxNGDSurfaceItem GXS.NGDManager

TgxNGDSurfacePair GXS.NGDManager

TgxNMFVectorFile GXS.FileNMF

TgxNode GXS.Nodes

TgxNodedLines GXS.Objects

Class that defines lines via a series of nodes. Base class, does not render anything.
TgxNodes GXS.Nodes

TgxNonVisualViewer GXS.Scene

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.
TgxNurbsVectorFile GXS.FileNurbs

TgxObjectAfterEffect GXS.Scene

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.
TgxObjectManager GXS.ObjectManager

TgxObjectPostEffect GXS.Scene

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.
TgxObjectPreEffect GXS.Scene

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.
TgxOBJVectorFile GXS.FileOBJ

Allocate memory for the current line in chunks of LineLen Bytes
TgxOcclusionQueryHandle GXS.Context

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TgxOctahedron GXS.GeomObjects

The octahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TgxOCTgxVectorFile GXS.FileOCT

The OCT vector file (FSRad output).
TgxOctree GXS.Octree

Manages an Octree containing references to triangles.
TgxOctreeNode GXS.Octree

TgxOctreeTriangleInfo GXS.Octree

Stores information about an intersected triangle.
TgxODEBehaviour GXS.ODEManager

Basis structures for behaviour style implementations.
TgxODECollisionSurface GXS.ODEManager

TgxODEContactPoint GXS.ODEManager

TgxODECustomCollider GXS.ODEManager

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE
TgxODEDynamic GXS.ODEManager

TgxODEElementBase GXS.ODEManager

TgxODEElementBox GXS.ODEManager

ODE box implementation.
TgxODEElementCapsule GXS.ODEManager

ODE capped cylinder implementation.
TgxODEElementCylinder GXS.ODEManager

ODE cylinder implementation.
TgxODEElementPlane GXS.ODEManager

ODE plane implementation.
TgxODEElements GXS.ODEManager

TgxODEElementSphere GXS.ODEManager

ODE sphere implementation.
TgxODEElementTriMesh GXS.ODEManager

ODE tri-mesh implementation.
TgxODEHeightField GXS.ODEManager

Add this behaviour to a TgxHeightField or TgxTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.
TgxODEJointBall GXS.ODEManager

ODE ball joint implementation
TgxODEJointBase GXS.ODEManager

Base structures for ODE Joints.
TgxODEJointFixed GXS.ODEManager

ODE fixed joint implementation.
TgxODEJointHinge GXS.ODEManager

ODE hinge joint implementation.
TgxODEJointHinge2 GXS.ODEManager

ODE hinge2 joint implementation.
TgxODEJointList GXS.ODEManager

Component front-end for storing ODE Joints.
TgxODEJointParams GXS.ODEManager

TgxODEJoints GXS.ODEManager

An XCollection decendant for ODE Joints.
TgxODEJointSlider GXS.ODEManager

ODE slider joint implementation
TgxODEJointUniversal GXS.ODEManager

ODE universal joint implementation
TgxODEManager GXS.ODEManager

TgxODERagdoll GXS.ODERagdoll

TgxODERagdollBone GXS.ODERagdoll

TgxODERagdollCube GXS.ODERagdoll

TgxODERagdollDummyJoint GXS.ODERagdoll

TgxODERagdollHingeJoint GXS.ODERagdoll

TgxODERagdollUniversalJoint GXS.ODERagdoll

TgxODERagdollWorld GXS.ODERagdoll

TgxODEStatic GXS.ODEManager

TgxOpenGL GXS.InitOpenGL

TgxOpenGL OpenGXS.InitFMX

TgxOrbitToPosAdvJob GXS.CameraController

TgxOrbitToPosJob GXS.CameraController

TgxOutlineShader GXS.OutlineShader

TgxOutlineShader GXSL.LineShaders

TgxPackPBOHandle GXS.Context

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.
TgxPanel GXS.Windows

TgxParticle GXS.ParticleFX

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).
TgxParticleFXEffect GXS.ParticleFX

Base class for linking scene objects to a particle FX manager.
TgxParticleFXManager GXS.ParticleFX

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).
TgxParticleFXRenderer GXS.ParticleFX

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.
TgxParticleInertia GXS.PhysInertias

TgxParticleList GXS.ParticleFX

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.
TgxParticles GXS.Particles

Manager object of a particle system. Particles in a TgxParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TgxParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TgxParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GXS.ParticleFX instead, TgxParticles being rather focused on complex particles.
TgxPathNode GXS.Movement

TgxPathNodes GXS.Movement

TgxPerlin3DNoise GXS.PerlinPFX

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice
TgxPerlinHDS GXS.Perlin

TgxPerlinHDSThread GXS.Perlin

TgxPerlinPFXManager GXS.PerlinPFX

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.
TgxPersistentImage GXS.Texture

Stores any image compatible with Delphi's TgxPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)
TgxPersistentTIE GXS.TextureImageEditors

TgxPGMImage GXS.FilePGM

TgxPhongShader GXSL.PhongShader

TgxPhysManager GXS.PhysManager

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene
TgxPicFileImage GXS.Texture

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.
TgxPicFileTIE GXS.TextureImageEditors

TgxPickList GXS.Selection

List class for object picking. This list is used to store the results of a PickObjects call.
TgxPictureImage GXS.Texture

Base class for image data classes internally based on a TgxPicture.
TgxPipe GXS.Extrusion

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.
TgxPipeNode GXS.Extrusion

TgxPipeNodes GXS.Extrusion

TgxPixel24 GXS.Graphics

TgxPixel32 GXS.Graphics

TgxPlane GXS.Objects

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.
TgxPLYVectorFile GXS.FilePLY

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.
TgxPNGImage GXS.FilePNG

TgxPointLightPFXManager GXS.ParticleFX

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TgxPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.
TgxPointParameters GXS.Objects

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.
TgxPoints GXS.Objects

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties.
TgxPolygon GXS.GeomObjects

A basic polygon object. The curve is described by the Nodes and SplineMode properties, should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single curve, if you need "complex polygons" with holes, patches and cutouts, see GLMultiPolygon.
TgxPolygonBase GXS.Objects

Base class for objects based on a polygon.
TgxPolygonList GXS.MultiPolygon

TgxPolygonPFXManager GXS.ParticleFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.
TgxPopupMenu GXS.Windows

TgxPortal GXS.Portal

Portal Renderer class.
TgxPortalMeshObjectList GXS.Portal

A mesh object list that handles portal rendering. The items are treated as being sectors.
TgxPostEffect GXSL.PostEffects

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.
TgxPostEffectColor GXSL.PostEffects

TgxPostShaderCollection GXSL.PostEffects

TgxPostShaderCollectionItem GXSL.PostEffects

TgxPostShaderHolder GXSL.PostEffects

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.
TgxPrimitiveQueryHandle GXS.Context

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TgxProcTextureNoise GXS.ProcTextures

TgxProcTextureNoiseTIE GXS.TextureImageEditors

TgxProgram GXS.InitOpenGL

———————————————————————–
TgxProgram OpenGXS.InitFMX

———————————————————————–
TgxProgramHandle GXS.Context

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TgxProgramHandleEXT GXS.Context

TgxProjectedTextures GXS.ProjectedTextures

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).
TgxProxyObject GXS.Scene

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.
TgxPythonEngine GXS.Python.Script

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TgxScriptPython) retain it's assigned compiler from design to run -time.
TgxQ3BSPVectorFile GXS.FileQ3BSP

The Q3BSP vector file (Quake III BSP).
TgxQuadricObject GXS.Objects

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).
TgxQueryHandle GXS.Context

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.
TgxRagdolBone GXS.Ragdoll

TgxRagdolBoneList GXS.Ragdoll

TgxRagdolJoint GXS.Ragdoll

TgxRagdoll GXS.Ragdoll

TgxRCHandle GXS.Context

TgxRenderbuffer GXS.FBO

TgxRenderbufferHandle GXS.Context

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).
TGXRenderContextClippingInfo GXS.RenderContextInfo

TgxRenderContextInfo GXS.RenderContextInfo

Stores contextual info useful during rendering methods.
TgxRenderPoint GXS.Scene

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.
TgxResolutionIndependantHUDText GXS.HUDObjects

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.
TgxResolutionProperty GXS.SceneRegister

TgxReuseableDefaultEditor GXS.SceneRegister

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TgxSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! Grrr...
TgxRevolutionSolid GXS.Extrusion

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TgxRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.
TgxRigidBodyInertia GXS.PhysInertias

A more complex model than TgxBInertia for Inertia
TgxROAMPatch GXS.ROAMPatch

TgxROAMRenderPoint GXS.ROAMPatch

TgxROAMTriangleNode GXS.ROAMPatch

TgxSamplerHandle GXS.Context

Manages a handle to a sampler.
TgxSamplingScale GXS.Graph

TgxSArchiveManager GXS.ArchiveManager

TgxSArchiveManagerEditor GXS.SceneRegister

Editor for Archive Manager.
TgxScene GXS.Scene

Scene object. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TgxBaseSceneObject. It will usually contain one or more TgxCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TgxScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TgxBaseSceneObject.
TgxSceneBuffer GXS.Scene

Encapsulates an OpenGL frame/rendering buffer.
TgxSceneEditor GXS.SceneRegister

TgxSceneObj GXS.SpatialPartitioning

Object for holding scene objects in a spatial partitioning
TgxSceneObject GXS.Scene

Base class for standard scene objects. Publishes the Material property.
TgxSceneObjectEntry GXS.ObjectManager

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference
TgxSceneRootObject GXS.Scene

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.
TgxSceneViewer GXS.SceneViewer

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.
TgxSceneViewerEditor GXS.SceneRegister

TgxSceneViewport GXS.ViewerOpenGL

GL_ARB_framebuffer_object or GL_EXT_framebuffer_blit
TgxScreenControlingContext GXS.Context

Context with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TgxSceneViewer won't use them, TgxMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.
TgxScreenSaver GXS.ScreenSaver

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible)

There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).
TgxScriptBase GXS.ScriptBase

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.
TgxScriptLibrary GXS.ScriptBase

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.
TgxScriptPython GXS.Python.Script

Implements Python scripting functionality through the abstracted GLS.ScriptBase
TgxScripts GXS.ScriptBase

XCollection descendant for storing and handling scripts.
TgxScrollbar GXS.Windows

TgxSCUDA GXS.CUDA.API

TgxSCUDACompiler GXS.CUDA.Compiler

TgxSCUDADevice GXS.CUDA.Context

TgxSDLContext SDLx.Context

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application
TgxSDLViewer SDLx.Context

A viewer using SDL.

Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!
TgxSDLWindow SDLx.Window

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used.
TgxSectorMeshObject GXS.Portal

A portal renderer sector.
TgxSelectRenderModeTechnique GXS.Selection

TgxServiceContextTask GXS.Context

TgxShader GXS.InitOpenGL

———————————————————————–
TgxShader GXS.Material

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.
TgxShader OpenGXS.InitFMX

———————————————————————–
TgxShaderCombiner GXSL.ShaderCombiner

TgxShaderEditorProperty GXS.SceneRegister

TgxShaderF GXS.InitOpenGL

———————————————————————–
TgxShaderF OpenGXS.InitFMX

———————————————————————–
TgxShaderG GXS.InitOpenGL

———————————————————————–
TgxShaderG OpenGXS.InitFMX

———————————————————————–
TgxShaderHandle GXS.Context

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.
TgxShaderItem GXS.MaterialScript

TgxShaderItems GXS.MaterialScript

TgxShaderLightSourceState GXS.State

TgxShaderProgram GXSL.CustomShader

A custom shader program.
TgxShaderTextureSharing GXSL.TextureShaders

TgxShaderTextureSharingMaterial GXSL.TextureShaders

TgxShaderTextureSharingMaterials GXSL.TextureShaders

TgxShaderV GXS.InitOpenGL

———————————————————————–
TgxShaderV OpenGXS.InitFMX

———————————————————————–
TgxShadowHDS GXS.ShadowHDS

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.
TgxShadowPlane GXS.ShadowPlane

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones
TgxShadowVolume GXS.ShadowVolume

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLXceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.
TgxShadowVolumeCaster GXS.ShadowVolume

Specifies an individual shadow caster. Can be a light or an opaque object.
TgxShadowVolumeCasters GXS.ShadowVolume

Collection of TgxShadowVolumeCaster.
TgxShadowVolumeLight GXS.ShadowVolume

Specifies an individual shadow casting light.
TgxShadowVolumeOccluder GXS.ShadowVolume

Specifies an individual shadow casting occluder.
TgxSilhouette GXS.Silhouette

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TgxSilhouette subclass if you need some helper methods for generating the indexed sets.
TgxSilhouetteParameters GXS.Silhouette

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.
TgxSimpleNavigation GXS.SimpleNavigation

TgxSimpleNavigationKeyCombination GXS.SimpleNavigation

TgxSimpleNavigationKeyCombinations GXS.SimpleNavigation

TGXSize GXS.RenderContextInfo

TgxSkeleton GXS.VectorFileObjects

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.
TgxSkeletonBone GXS.VectorFileObjects

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TgxSkeletonFrame, but the calculated bone matrices are stored here.
TgxSkeletonBoneList GXS.VectorFileObjects

A list of skeleton bones.
TgxSkeletonCollider GXS.VectorFileObjects

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.
TgxSkeletonColliderList GXS.VectorFileObjects

List class for storing TgxSkeletonCollider objects.
TgxSkeletonFrame GXS.VectorFileObjects

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).
TgxSkeletonFrameList GXS.VectorFileObjects

A list of TgxSkeletonFrame objects.
TgxSkeletonMeshObject GXS.VectorFileObjects

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TgxVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).
TgxSkeletonRootBoneList GXS.VectorFileObjects

This list store skeleton root bones exclusively.
TgxSkyBox GXS.Skydome

TgxSkyDome GXS.Skydome

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.
TgxSkyDomeBand GXS.Skydome

——————— SkyDome classes —————————–
TgxSkyDomeBands GXS.Skydome

TgxSkyDomeStar GXS.Skydome

TgxSkyDomeStars GXS.Skydome

TgxslBaseCustomBumpShader GXSL.BumpShaders

An abstract class.
TgxslBaseCustomBumpShaderMT GXSL.BumpShaders

An abstract class.
TgxslBumpShader GXSL.BumpShaders

TgxslBumpShaderAM GXSL.BumpShaders

TgxslBumpShaderMT GXSL.BumpShaders

One light shaders.
TgxslCustomBumpShader GXSL.BumpShaders

TgxslCustomBumpShaderAM GXSL.BumpShaders

One Light shaders.
TgxslCustomBumpShaderMT GXSL.BumpShaders

TgxslCustomMLBumpShader GXSL.BumpShaders

MultiLight shaders.
TgxslCustomMLBumpShaderMT GXSL.BumpShaders

TgxslCustomPostBlurShader GXSL.PostShaders

Custom class for GLSLxPostBlurShader. A shader that blurs the entire scene }
TgxslCustomPostDreamVisionShader GXSL.PostShaders

A shader that simulate a grayscale threshold vision (aka dream) of the entire scene
TgxslCustomPostFrostShader GXSL.PostShaders

Custom class for shader that frost of the entire scene
TgxslCustomPostNightVisionShader GXSL.PostShaders

Custom shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene
TgxslCustomPostPixelateShader GXSL.PostShaders

Custom shader that pixelate of the entire scene
TgxslCustomPostPosterizeShader GXSL.PostShaders

Custom shader that posterize of the entire scene
TgxslCustomPostThermalVisionShader GXSL.PostShaders

A shader that simulate a Thermal Vision of the entire scene
TgxslCustomPostTroubleShader GXSL.PostShaders

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different
TGXSLCustomShader GXSL.Shader

TgxSLDiffuseSpecularShader GXSL.DiffuseSpecularShader

TgxSLDiffuseSpecularShaderMT GXSL.DiffuseSpecularShader

******** Published Stuff ************
TgxSLFurShader GXSL.ShapeShaders

TgxSLGlassShader GXSL.ShapeShaders

TgxSLHandle GXS.Context

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead.
TgxSLIvoryShader GXSL.ShapeShaders

TgxSLLatticeShader GXSL.ShapeShaders

TgxslMLBumpShader GXSL.BumpShaders

Multi light shaders.
TgxslMLBumpShaderMT GXSL.BumpShaders

TgxSLMLDiffuseSpecularShader GXSL.DiffuseSpecularShader

TgxSLMLDiffuseSpecularShaderMT GXSL.DiffuseSpecularShader

TgxslPostBlurShader GXSL.PostShaders

TgxSLPostDreamVisionShader GXSL.PostShaders

TgxslPostFrostShader GXSL.PostShaders

TgxslPostNightVisionShader GXSL.PostShaders

TgxslPostPixelateShader GXSL.PostShaders

TgxslPostPosterizeShader GXSL.PostShaders

TgxslPostThermalVisionShader GXSL.PostShaders

TgxslPostTroubleShader GXSL.PostShaders

TgxslProjectedTextures GXSL.ProjectedTextures

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.
TgxSLSemShader GXSL.ShapeShaders

TGXSLShader GXSL.Shader

TGXSLShaderParameter GXSL.Shader

Wrapper around a parameter of a GLSL program.
TgxSLSimpleErosionShader GXSL.ShapeShaders

TgxSLSimpleGoochShader GXSL.ShapeShaders

TgxSLSimpleLatticeShader GXSL.ShapeShaders

TgxslTextureEmitter GXSL.ProjectedTextures

A projected texture emitter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader
TgxslTextureEmitterItem GXSL.ProjectedTextures

Specifies an item on the TgxslTextureEmitters collection.
TgxslTextureEmitters GXSL.ProjectedTextures

Collection of TgxslTextureEmitter.
TgxSLToonShader GXSL.ShapeShaders

TgxSLVertexDisplacementShader GXSL.ShapeShaders

TgxSMBASS GXS.Sounds.BASS

TGXSMDVectorFile GXS.FileSMD

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.
TgxSmoothNavigator GXS.SmoothNavigator

This is the component for moving a TgxBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.
TgxSmoothOrbitToPos GXS.CameraController

TgxSmoothOrbitToPosAdvJob GXS.CameraController

TgxSmoothUserInterface GXS.SmoothNavigator

This is the component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....
TgxSMOpenAL GXS.Sounds.OpenAL

al, alut, alTypes
TgxSMWaveOut GXS.Sounds.WaveOut

Basic sound manager based on WinMM WaveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).
TgxSoundFile GXS.SoundFileObjects

Abstract base class for different Sound file Formatx. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TgxSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.
TgxSoundFileFormat GXS.SoundFileObjects

TgxSoundFileFormatsList GXS.SoundFileObjects

TgxSoundFileProperty GXS.SceneRegister

TgxSoundLibrary GXS.SoundManager

TgxSoundLibrarySelectionEditor GXS.SceneRegister

Selection editor for TgxSoundLibrary. Allows units to be added to the uses clause automatically when sound files are loaded into a TgxSoundLibrary at design-time.
TgxSoundManager GXS.SoundManager

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.
TgxSoundNameProperty GXS.SceneRegister

TgxSoundSample GXS.SoundManager

Stores a single PCM coded sound sample.
TgxSoundSamples GXS.SoundManager

TgxSoundSampling GXS.SoundFileObjects

Defines a sound sampling quality.
TgxSoundSource GXS.SoundManager

Origin of sound playback. Just publishes the 'Origin' property. Note: "orientation" is the the source's Direction, ie. the "Z" vector.
TgxSoundSources GXS.SoundManager

TgxSourcePFXEffect GXS.ParticleFX

Simple Particles Source.
TgxSpaceText GXS.SpaceText

Renders a text in 3D.
TgxSphere GXS.Objects

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere.
TgxSprite GXS.Objects

A rectangular area, perspective projected, but always facing the camera. A TgxSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TgxHUDSprite.
TgxSpriteAnimation GXS.AnimatedSprite

Animations define how the texture coordinates for each offset are to be determined.
TgxSpriteAnimationList GXS.AnimatedSprite

A collection for storing SpriteAnimation objects.
TgxSpriteAnimFrame GXS.AnimatedSprite

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.
TgxSpriteAnimFrameList GXS.AnimatedSprite

TgxSpriteAnimMargins GXS.AnimatedSprite

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.
TgxStarRecord GXS.Skydome

TgxStateCache GXS.State

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.
TgxStateRecord GXS.State

TgxStaticImposterBuilder GXS.Imposter

Builds imposters whose texture is a catalog of prerendered views
TgxStaticImposterBuilderCorona GXS.Imposter

Describes a set of orientation in a corona fashion
TgxStaticImposterBuilderCoronas GXS.Imposter

TgxStencilRBO GXS.FBO

TGXSTLVectorFile GXS.FileSTL

The STL vector file (stereolithography format). It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines. There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version. Original Binary importer code by Paul M. Bearne, Text importer by Adem.
TgxSuperellipsoid GXS.Objects

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid.
TgxSwartSwarm GXS.SmartObjects

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);
TgxTeapot GXS.GeomObjects

The classic teapot. The only use of this object is as placeholder for testing...
TgxTerrainBaseHDS GXS.HeightData

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).
TgxTerrainRenderer GXS.TerrainRenderer

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TgxHeightDataSource, and expressed as z=f(x, y) data.
TgxTessControlShaderHandle GXS.Context

Manages a handle to a Tessellation Control Shader Object.
TgxTessEvaluationShaderHandle GXS.Context

Manages a handle to a Tessellation Evaluation Shader Object.
TgxTetrahedron GXS.GeomObjects

The tetrahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TgxTexCombineShader GXSL.TextureShaders

A shader that can setup the texture combiner.
TgxTextAdjust GXS.SpaceText

TgxTexture GXS.Texture

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TgxTextureImageAlpha).
TgxTextureBufferHandle GXS.Context

Manages a handle to a Buffer Texture. (TBO)
TgxTexturedHDS GXS.TexturedHDS

TgxTextureEmitter GXS.ProjectedTextures

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.
TgxTextureEmitterItem GXS.ProjectedTextures

Specifies an item on the TgxTextureEmitters collection.
TgxTextureEmitters GXS.ProjectedTextures

Collection of TgxTextureEmitter.
TgxTextureEx GXS.Texture

TgxTextureExItem GXS.Texture

TgxTextureHandle GXS.Context

Manages a handle to a texture.
TgxTextureImage GXS.Texture

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.
TgxTextureImageEditor GXS.TextureImageEditors

TgxTextureImageProperty GXS.SceneRegister

TgxTextureLensFlare GXS.TexLensFlare

TgxTextureProperty GXS.SceneRegister

TgxTGAImage Formatx.TGA

TgxThorFXManager GXS.ThorFX

Thor special effect manager.
TgxTiledArea GXS.TilePlane

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".
TgxTiledAreaRow GXS.TilePlane

Stores row information for a tiled area.
TgxTiledRndLandscape GXS.RandomHDS

Random Lansdscape with tiles
TgxTilePlane GXS.TilePlane

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.
TgxTimeEvent GXS.TimeEventsMgr

TgxTimeEvents GXS.TimeEventsMgr

TgxTimeEventsMGR GXS.TimeEventsMgr

TgxTimerQueryHandle GXS.Context

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TgxTINVectorFile GXS.FileTIN

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.
TgxTorus GXS.GeomObjects

A Torus object
TgxTrail GXS.Trail

TgxTransformFeedbackBufferHandle GXS.Context

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.
TgxTree GXS.Tree

TgxTreeBranch GXS.Tree

TgxTreeBranches GXS.Tree

TgxTreeBranchNoise GXS.Tree

TgxTreeLeaves GXS.Tree

TgxUniformBufferHandle GXS.Context

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.
TgxUnpackPBOHandle GXS.Context

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object
TgxUserInputCommand GXS.Console

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...
TgxUserInterface GXS.Navigator

TgxUserInterface is the component which reads the userinput and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GXNavigator : The Navigator which receives the user movement. GXVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....
TgxUserShader GXSL.UserShader

TgxVBOArrayBufferHandle GXS.Context

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.
TgxVBOElementArrayHandle GXS.Context

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.
TgxVBOHandle GXS.Context

Manages a handle to an Vertex Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.
TgxVectorFile GXS.VectorFileObjects

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).
TgxVectorFileFormat GXS.VectorFileObjects

TgxVectorFileFormatsList GXS.VectorFileObjects

Stores registered vector file Formatx.
TgxVectorFileGLSM GXS.VectorFileObjects

GLSM ( GXScene Mesh) vector file. This corresponds to the 'native' Scene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GXScene features.
TgxVerletAirResistance GXS.VerletTypes

TgxVerletCapsule GXS.VerletTypes

Capsule shaped verlet constraint in a skeleton collider
TgxVerletConstraint GXS.VerletTypes

TgxVerletConstraintList GXS.VerletTypes

TgxVerletDualConstraint GXS.VerletTypes

TgxVerletDualForce GXS.VerletTypes

A verlet force that applies to two specified nodes.
TgxVerletEdge GXS.VerletTypes

Verlet edges simulate rigid collission edges
TgxVerletEdgeList GXS.VerletTypes

TgxVerletFloor GXS.VerletTypes

Floor Collision Constraint
TgxVerletForce GXS.VerletTypes

Generic verlet force.
TgxVerletForceList GXS.VerletTypes

TgxVerletFrictionCapsule GXS.VerletTypes

Capsule collision Friction Constraint.
TgxVerletFrictionCube GXS.VerletTypes

Cube Сollision Friction Constraint.
TgxVerletFrictionCylinder GXS.VerletTypes

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.
TgxVerletFrictionSphere GXS.VerletTypes

Sphere Сollision Friction Constraint
TgxVerletGlobalConstraint GXS.VerletTypes

TgxVerletGlobalForce GXS.VerletTypes

A global force (applied to all verlet nodes).
TgxVerletGlobalFrictionConstraint GXS.VerletTypes

TgxVerletGlobalFrictionConstraintBox GXS.VerletTypes

TgxVerletGlobalFrictionConstraintSP GXS.VerletTypes

TgxVerletGlobalFrictionConstraintSphere GXS.VerletTypes

TgxVerletGravity GXS.VerletTypes

TgxVerletGroupConstraint GXS.VerletTypes

TgxVerletGroupForce GXS.VerletTypes

A verlet force that applies to a specified group of nodes.
TgxVerletHair GXS.VerletTypes

Verlet Hair class
TgxVerletHeightField GXS.VerletTypes

HeightField collision constraint (punctual!)
TgxVerletNode GXS.VerletTypes

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.
TgxVerletNodeList GXS.VerletTypes

TgxVerletRigidBody GXS.VerletTypes

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!
TgxVerletSkeletonCollider GXS.VerletTypes

Base Verlet Skeleton Collider class.
TgxVerletSlider GXS.VerletTypes

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.
TgxVerletSphere GXS.VerletTypes

Sphere shaped verlet constraint in a skeleton collider
TgxVerletSpring GXS.VerletTypes

TgxVerletStick GXS.VerletTypes

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes
TgxVerletWorld GXS.VerletTypes

TgxVertexArrayHandle GXS.Context

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.
TgxVertexBoneWeight GXS.VectorFileObjects

TgxVertexData GXS.Mesh

TgxVertexList GXS.Mesh

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.
TgxVertexProgram GXSL.CustomShader

TgxVertexProgramHandle GXS.Context

TgxVertexShaderHandle GXS.Context

Manages a handle to a Vertex Shader Object.
TgxVideoMode GXS.Screen

TgxVirtualHandle GXS.Context

A context handle with event-based handle allocation and destruction.
TgxVirtualHandleTransf GXS.Context

Transferable virtual handle.
TgxVRMLVectorFile GXS.FileVRML

TgxWaterPlane GXS.WaterPlane

TgxWAVFile GXS.FileWAV

Support for Windows WAV format.
TgxWinContext GXS.WinContext

A context driver for standard Windows OpenGL
TgxWindowsBitmapFont GXS.WindowsFont

A bitmap font automatically built from a TFont. It works like a TgxBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders as close to that font as possible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.
TgxXVectorFile GXS.FileX

TgxXYZGrid GXS.Graph

An XYZ Grid object. Renders an XYZ grid using lines.
TgxZBuffer GXS.zBuffer

TgxZoomToDistanceJob GXS.CameraController

TgxZShadows GXS.zBuffer

THDRImage Formatx.HDRImage

THelpOpenControl3D GBE.Viewport3D

THmgBoundingBox GLScene.GeometryBB

THTFHeader GXS.HeightTileFile

TImposter GXS.Imposter

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.
TInfoForm FMxInfo

TInstProp FMxXCollectionEditor

TIntermediateFormat GXS.ImageUtils

Relative sample radius for filtering
TIsoSurfaceExtractor GXS.Isosurface

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue
TLandTileInfo GXS.RandomHDS

TLeavedSpacePartition GXS.SpacePartition

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods
TLibArchive GXS.ArchiveManager

To work with several archives simultaniously collections implemented Item to work with one archive
TLibArchives GXS.ArchiveManager

TLibMaterialPicker FMXLibMaterialPicker

TLifeErosion GXS.RandomHDS

TLightmapBounds GXS.MeshLines

TLightRecord GXSL.DiffuseSpecularShader

******* Multi Light *********
TLineCollection GXS.MeshLines

TLineItem GXS.MeshLines

TLineNode GXS.MeshLines

Specialized Node for use in a TgxLines objects. Adds a Width property
TLineNodes GXS.MeshLines

Specialized collection for Nodes in TgxMeshLines objects. Stores TLineNode items.
TLMTS GXS.FileLMTS

TLMTS_Header GXS.FileLMTS

TLMTS_Subset GXS.FileLMTS

TLMTS_TexData GXS.FileLMTS

TLMTS_Vertex GXS.FileLMTS

TLogBufferFlushThread GLScene.Logger

Thread that periodically flushes the buffer to disk.
TLogCheckSizeThread GLScene.Logger

Thread that checks file size and splits the file if nessesary.
TLogSession GLScene.Logger

Abstract Logger class
TMaterialEditorForm FMxMaterialEditor

TMaterialInfo GXS.FileLMTS

TMaterialPreviewFrame FRxMaterialPreview

GXS.SceneViewer,
TMatrix2b GLScene.VectorTypes

TMatrix2d GLScene.VectorTypes

=========== Matrices ============
TMatrix2DRec GLScene.VectorTypesExt

TMatrix2e GLScene.VectorTypes

TMatrix2f GLScene.VectorTypes

TMatrix2i GLScene.VectorTypes

TMatrix2p GLScene.VectorTypes

TMatrix2s GLScene.VectorTypes

TMatrix2w GLScene.VectorTypes

TMatrix3b GLScene.VectorTypes

TMatrix3d GLScene.VectorTypes

TMatrix3DRec GLScene.VectorTypesExt

TMatrix3e GLScene.VectorTypes

TMatrix3f GLScene.VectorTypes

TMatrix3i GLScene.VectorTypes

TMatrix3p GLScene.VectorTypes

TMatrix3s GLScene.VectorTypes

TMatrix3w GLScene.VectorTypes

TMatrix4b GLScene.VectorTypes

TMatrix4d GLScene.VectorTypes

TMatrix4e GLScene.VectorTypes

TMatrix4f GLScene.VectorTypes

TMatrix4i GLScene.VectorTypes

TMatrix4p GLScene.VectorTypes

TMatrix4s GLScene.VectorTypes

TMatrix4w GLScene.VectorTypes

TMatrixRec GLScene.VectorTypesExt

TMD3TagList Formatx.Q3MD3

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.
TMDCBaseFrame GXS.FileMDC

TMDCBorderFrame GXS.FileMDC

TMDCCompFrame GXS.FileMDC

TMDCFileHeader GXS.FileMDC

TMDCSkin GXS.FileMDC

TMDCSurfaceHeader GXS.FileMDC

TMDCTag GXS.FileMDC

TMDCTagFrame GXS.FileMDC

TMDCTagName GXS.FileMDC

TMesh2DVert GLScene.VectorTypesExt

————————– Mesh simple record types ————————–
TMesh3DVert GLScene.VectorTypesExt

TMOParametricSurface GXS.ParametricSurfaces

TMS3DComment GXS.FileMS3D

TMS3DCommentList GXS.FileMS3D

TMS3DGroup GXS.FileMS3D

typedef struct { byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material } ms3d_group_t;
TMS3DHeader GXS.FileMS3D

typdef struct { char id[10]; // always "MS3D000000" int version; // 4 } ms3d_header_t;
TMS3DJoint GXS.FileMS3D

TMS3DJointBase GXS.FileMS3D

typedef struct { byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];

word numKeyFramesRot; // word numKeyFramesTrans; //

ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices } ms3d_joint_t;
TMS3DKeyframePosition GXS.FileMS3D

typedef struct { float time; // time in seconds float position[3]; // local position } ms3d_keyframe_pos_t;
TMS3DKeyframeRotation GXS.FileMS3D

typedef struct { float time; // time in seconds float rotation[3]; // x, y, z angles } ms3d_keyframe_rot_t;
TMS3DMaterial GXS.FileMS3D

typedef struct { char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp } ms3d_material_t;
TMS3DTriangle GXS.FileMS3D

typedef struct { word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // } ms3d_triangle_t;
TMS3DVertex GXS.FileMS3D

typedef struct { byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; } ms3d_vertex_t;
TMS3D_vertex_ex_t GXS.FileMS3D

TNewtonRagdoll GXS.NGDRagdoll

TNmHeader GXS.FileNMF

TNmRawTriangle GXS.FileNMF

TOceanSurface GBE.omOceanWaves

TOctreeSpacePartition GXS.SpacePartition

Implements octrees
TomSailSurface omSailSurface

TomSailSurface morphs a TPlane grid into a triangular sail with camber ( or any other polygonal Shape)
TPAKArchive GXS.PAKArchive

TPakHeader GXS.PAKArchive

TParticleReference GXS.ParticleFX

PFX region rendering structures
TPFXLifeColor GXS.ParticleFX

TPFXLifeColors GXS.ParticleFX

TPFXRegion GXS.ParticleFX

TPickRecord GXS.Selection

TPictureFileProperty GXS.SceneRegister

TPoint2DRec GLScene.VectorTypesExt

TPoint3DRec GLScene.VectorTypesExt

TQuadtreeSpacePartition GXS.SpacePartition

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting).
TQuat3DRec GLScene.VectorTypesExt

————————– Quaternion simple record types ————————–
TQuaternion GLScene.VectorGeometry

TQuaternionHelper GLScene.VectorTypesExt

TQuaternionRec GLScene.VectorTypesExt

TRainErosion GXS.RandomHDS

TRasterFileFormat GXS.Graphics

TRasterFileFormatsList GXS.Graphics

Stores registered raster file Formatx.
TRectangle GLScene.VectorGeometry

TRelativeCoordinate GXS.RandomHDS

TRGBPixel GXS.Blur

TSailParams omSailSurface

TSceneEditorForm FMxSceneEditor

TSCODEBase GXS.ODESkeletonColliders

Base ODE skeleton collider class.
TSCODEBox GXS.ODESkeletonColliders

Box shaped ODE geom in a skeleton collider.
TSCODECCylinder GXS.ODESkeletonColliders

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.
TSCODESphere GXS.ODESkeletonColliders

Sphere shaped ODE geom in a skeleton collider.
TSeaErosion GXS.RandomHDS

Fmx.Imaging.jpeg,
TSectoredSpacePartition GXS.SpacePartition

TSectorNode GXS.SpacePartition

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8
TShaderFileProperty GXS.SceneRegister

TShaderMemoForm FMxShaderMemo

TShaderUniformEditorForm FMxShaderUniformEditor

TSkinEditorForm FMxSkinEditor

TSpacePartitionLeaf GXS.SpacePartition

Used to store the actual objects in the SpacePartition
TSpacePartitionLeafList GXS.SpacePartition

List for storing space partition leaves
TSPCone GXS.SpacePartition

Describes a cone, and is used for cone collision
TSPOctreeNode GXS.SpacePartition

Implements sector node that handles octrees
TSPQuadtreeNode GXS.SpacePartition

Implements sector node that handles quadtrees.
TStaticImposter GXS.Imposter

Imposter class whose texture contains several views from different angles
TSteps GXS.RandomHDS

TSTLFace GXS.FileSTL

Original specs : = packed record x : single; y : single; z : single; end;
TSTLHeader GXS.FileSTL

TTexPoint GLScene.VectorGeometry

TTextureEditFrame FRxTextureEdit

TTGAImage GXS.FileTGA

TGA image load/save capable class for Delphi. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.
TTgxFile3DSPositionAnimationKeys GXS.File3DS

TThorpoint GXS.ThorFX

TTriangleRec GLScene.VectorTypesExt

TTwoWavesOceanSurface GBE.omOceanWaves

TUBOStates GXS.State

TUniformAutoSetProperty GXS.SceneRegister

TVector2b GLScene.VectorTypes

TVector2d GLScene.VectorTypes

=========== Vectors ============ 2
TVector2DRec GLScene.VectorTypesExt

TVector2e GLScene.VectorTypes

TVector2f GLScene.VectorTypes

TVector2h GLScene.VectorTypes

TVector2i GLScene.VectorTypes

TVector2p GLScene.VectorTypes

TVector2s GLScene.VectorTypes

TVector2sb GLScene.VectorTypes

TVector2ui GLScene.VectorTypes

TVector2w GLScene.VectorTypes

TVector3b GLScene.VectorTypes

TVector3d GLScene.VectorTypes

3
TVector3DRec GLScene.VectorTypesExt

TVector3e GLScene.VectorTypes

TVector3f GLScene.VectorTypes

TVector3h GLScene.VectorTypes

TVector3i GLScene.VectorTypes

TVector3p GLScene.VectorTypes

TVector3s GLScene.VectorTypes

TVector3sb GLScene.VectorTypes

TVector3ui GLScene.VectorTypes

TVector3w GLScene.VectorTypes

TVector4b GLScene.VectorTypes

TVector4d GLScene.VectorTypes

4
TVector4e GLScene.VectorTypes

TVector4f GLScene.VectorTypes

TVector4h GLScene.VectorTypes

TVector4i GLScene.VectorTypes

TVector4p GLScene.VectorTypes

TVector4s GLScene.VectorTypes

TVector4sb GLScene.VectorTypes

TVector4ui GLScene.VectorTypes

TVector4w GLScene.VectorTypes

TVectorHelper GLScene.VectorTypesExt

TVectorRec GLScene.VectorTypesExt

TVertexRec GLScene.VectorTypesExt

TVertexRec GXS.Objects

TVertexWeightList GXS.FileMS3D

TVoxelRec GLScene.VectorTypesExt

TWaveRec GBE.PlaneExtend

TWaveSystem GBE.omOceanWaves

TGBEPlaneExtend and WaveRec
TWindArrowSurface GBE.omOceanWaves

TXCollection GLScene.XCollection

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility
TXCollectionEditorForm FMxXCollectionEditor

TXCollectionItem GLScene.XCollection

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation
TXCollectionProperty GLScene.XCollectionRegister

ToDo DesignEditors, DesignIntf,
TXCollectionProperty GXS.RegisterXCollection

TZLibArchive GXS.FileZLIB

TZLibArchive
TZLibHeader GXS.FileZLIB

Signature for compressed zlib.
_WGLSWAP GLScene.OpenGL4

_WGLSWAP GLScene.OpenGLTokens


GXSysHelp v.2.5: All Types

All Types

Name Unit Description
CLogSession GLScene.Logger

Class reference to log session class
EGLOSError GLScene.Utils

EOpenALError GXS.Sounds.OpenAL

GLbitfield GLScene.OpenGL4

GLboolean GLScene.OpenGL4

GLbyte GLScene.OpenGL4

GLclampd GLScene.OpenGL4

GLclampf GLScene.OpenGL4

GLdouble GLScene.OpenGL4

GLenum GLScene.OpenGL4

GLfloat GLScene.OpenGL4

GLhandleARB GLScene.OpenGL4

GLint GLScene.OpenGL4

GLint64 GLScene.OpenGL4

GLint64EXT GLScene.OpenGL4

GLshort GLScene.OpenGL4

GLsizei GLScene.OpenGL4

GLubyte GLScene.OpenGL4

GLuint GLScene.OpenGL4

GLuint64 GLScene.OpenGL4

GLuint64EXT GLScene.OpenGL4

GLushort GLScene.OpenGL4

HGPUNV GLScene.OpenGL4

HGPUNV GLScene.OpenGLTokens

HPBUFFERARB GLScene.OpenGL4

HPBUFFERARB GLScene.OpenGLTokens

HVIDEOINPUTDEVICENV GLScene.OpenGL4

HVIDEOINPUTDEVICENV GLScene.OpenGLTokens

PAABB GLScene.GeometryBB

PAArray GXS.zBuffer

PAffineByteVector GLScene.VectorGeometry

PAffineDblVector GLScene.VectorGeometry

PAffineExtVector GLScene.VectorGeometry

PAffineFltVector GLScene.VectorGeometry

PAffineIntVector GLScene.VectorGeometry

PAffineMatrix GLScene.VectorGeometry

PAffinePtrVector GLScene.VectorGeometry

PAffineVector GLScene.VectorGeometry

PAffineVectorArray GLScene.VectorGeometry

Arrays of vectors
PAffineWordVector GLScene.VectorGeometry

PAVIStream GXS.AVIRecorder

PByteArray GLScene.VectorGeometry

PByteRaster GXS.HeightData

PByteVector GLScene.VectorGeometry

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits
PCardinalArray GLScene.VectorGeometry

PCardinalVector GLScene.VectorGeometry

PCharInfo GXS.BitmapFont

PdFloat GXS.NGDManager

TComponent Tlist TWriter TReader TPersistent System utilities Samevalue isZero to compare single PVector4f TVector4f TMatrix4f PMatrix4f NullHmgVector... TgxAffineVectorList for Tree TXCollection file function cube cone freeform... For show debug
PDoubleArray GLScene.VectorGeometry

PDoubleVector GLScene.VectorGeometry

PExtendedArray GLScene.VectorGeometry

PExtendedVector GLScene.VectorGeometry

PFastCollisionChecker GXS.Collision

PFireParticle GXS.FireFX

PFireParticleArray GXS.FireFX

PFloat GLScene.VectorGeometry

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)
PFloatArray GLScene.VectorGeometry

PFloatVector GLScene.VectorGeometry

PFNGLACTIVESHADERPROGRAMPROC GLScene.OpenGLTokens

PFNGLACTIVESTENCILFACEEXTPROC GLScene.OpenGLTokens

GL_EXT_stencil_two_side (EXT #268)
PFNGLACTIVETEXTUREARBPROC GLScene.OpenGLTokens

GL_ARB_multitexture (ARB #1)
PFNGLACTIVETEXTUREPROC GLScene.OpenGLTokens

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)
PFNGLACTIVEVARYINGNVPROC GLScene.OpenGLTokens

PFNGLADDSWAPHINTRECTWINPROC GLScene.OpenGLTokens

GL_WIN_swap_hint (extension # not found)
PFNGLAREPROGRAMSRESIDENTNVPROC GLScene.OpenGLTokens

GL_NV_vertex_program (EXT #233)
PFNGLARETEXTURESRESIDENTEXTPROC GLScene.OpenGLTokens

PFNGLARRAYELEMENTARRAYEXTPROC GLScene.OpenGLTokens

EXT/Vendor extensions Unknown Vendor/EXT functions
PFNGLATTACHOBJECTARBPROC GLScene.OpenGLTokens

PFNGLATTACHSHADERPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)
PFNGLBEGINCONDITIONALRENDERNVPROC GLScene.OpenGLTokens

GL_NV_conditional_render (EXT #346)
PFNGLBEGINCONDITIONALRENDERPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_NV_conditional_render
PFNGLBEGINOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYARBPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYINDEXEDPROC GLScene.OpenGLTokens

PFNGLBEGINQUERYPROC GLScene.OpenGLTokens

PFNGLBEGINSCENEEXTPROC GLScene.OpenGLTokens

GL_EXT_scene_marker (EXT #120)
PFNGLBEGINTRANSFORMFEEDBACKEXTPROC GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKNVPROC GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLBINDATTRIBLOCATIONARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_shader (ARB #31)
PFNGLBINDATTRIBLOCATIONPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_buffer_object (ARB #28)
PFNGLBINDBUFFERBASEEXTPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERBASENVPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERBASEPROC GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETEXTPROC GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETNVPROC GLScene.OpenGLTokens

PFNGLBINDBUFFERPROC GLScene.OpenGLTokens

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)
PFNGLBINDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

GL_EXT_transform_feedback (EXT #352)
PFNGLBINDBUFFERRANGENVPROC GLScene.OpenGLTokens

GL_NV_transform_feedback (EXT #341)
PFNGLBINDBUFFERRANGEPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_transform_feedback
PFNGLBindBuffersBase GLScene.OpenGLTokens

PFNGLBindBuffersRange GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONEXTPROC GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC GLScene.OpenGLTokens

GL_ARB_blend_func_extended (ARB #78)
PFNGLBINDFRAGDATALOCATIONPROC GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLBindImageTextures GLScene.OpenGLTokens

PFNGLBINDMULTITEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLBINDPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFERPROC GLScene.OpenGLTokens

PFNGLBINDSAMPLERPROC GLScene.OpenGLTokens

PFNGLBindSamplers GLScene.OpenGLTokens

PFNGLBINDTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLBindTextures GLScene.OpenGLTokens

PFNGLBINDTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

GL_ARB_transform_feedback2 (ARB #93)
PFNGLBINDVERTEXARRAYPROC GLScene.OpenGLTokens

GL_ARB_vertex_array_object (ARB #54)
PFNGLBindVertexBuffer GLScene.OpenGLTokens

GL_ARB_vertex_attrib_binding (ARB #125)
PFNGLBindVertexBuffers GLScene.OpenGLTokens

PFNGLBLENDCOLOREXTPROC GLScene.OpenGLTokens

GL_EXT_blend_color (EXT #2)
PFNGLBLENDCOLORPROC GLScene.OpenGLTokens

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)
PFNGLBLENDEQUATIONEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_minmax (EXT #37)
PFNGLBLENDEQUATIONIARBPROC GLScene.OpenGLTokens

GL_ARB_draw_buffers_blend (ARB #69)
PFNGLBLENDEQUATIONIPROC GLScene.OpenGLTokens

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)
PFNGLBLENDEQUATIONPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_blend_minmax (#37)
PFNGLBLENDEQUATIONSEPARATEEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_equation_separate (EXT #299)
PFNGLBLENDEQUATIONSEPARATEIARBPROC GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIPROC GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEPROC GLScene.OpenGLTokens

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)
PFNGLBLENDFUNCIARBPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCIPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEEXTPROC GLScene.OpenGLTokens

GL_EXT_blend_func_separate (EXT #173)
PFNGLBLENDFUNCSEPARATEIARBPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEIPROC GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEPROC GLScene.OpenGLTokens

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)
PFNGLBLITFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_blit (EXT #316)
PFNGLBLITFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLBUFFERADDRESSRANGENVPROC GLScene.OpenGLTokens

GL_NV_vertex_buffer_unified_memory (EXT #380)
PFNGLBUFFERDATAARBPROC GLScene.OpenGLTokens

PFNGLBUFFERDATAPROC GLScene.OpenGLTokens

PFNGLBufferStorage GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAARBPROC GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAPROC GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSPROC GLScene.OpenGLTokens

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC GLScene.OpenGLTokens

PFNGLCLAMPCOLORARBPROC GLScene.OpenGLTokens

GL_ARB_color_buffer_float (ARB #39)
PFNGLCLAMPCOLORPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_ARB_color_buffer_float
PFNGLClearBufferData GLScene.OpenGLTokens

GL_ARB_clear_buffer_object (ARB #121)
PFNGLCLEARBUFFERFIPROC GLScene.OpenGLTokens

PFNGLCLEARBUFFERFVPROC GLScene.OpenGLTokens

PFNGLCLEARBUFFERIVPROC GLScene.OpenGLTokens

New commands in OpenGL 3.0
PFNGLClearBufferSubData GLScene.OpenGLTokens

PFNGLCLEARBUFFERUIVPROC GLScene.OpenGLTokens

PFNGLCLEARCOLORIIEXTPROC GLScene.OpenGLTokens

GL_EXT_texture_integer (EXT #343)
PFNGLCLEARCOLORIUIEXTPROC GLScene.OpenGLTokens

PFNGLCLEARDEPTHFPROC GLScene.OpenGLTokens

PFNGLClearNamedBufferData GLScene.OpenGLTokens

PFNGLClearNamedBufferSubData GLScene.OpenGLTokens

PFNGLClearTexImage GLScene.OpenGLTokens

PFNGLClearTexSubImage GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREARBPROC GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREPROC GLScene.OpenGLTokens

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)
PFNGLCLIENTATTRIBDEFAULTEXTPROC GLScene.OpenGLTokens

GL_EXT_direct_state_access
PFNGLCLIENTWAITSYNCPROC GLScene.OpenGLTokens

PFNGLCOLORFORMATNVPROC GLScene.OpenGLTokens

PFNGLCOLORMASKINDEXEDEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_buffers2 (EXT #340)
PFNGLCOLORMASKIPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_draw_buffers2
PFNGLCOLORP3UIPROC GLScene.OpenGLTokens

PFNGLCOLORP3UIVPROC GLScene.OpenGLTokens

PFNGLCOLORP4UIPROC GLScene.OpenGLTokens

PFNGLCOLORP4UIVPROC GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEEXTPROC GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)
PFNGLCOLORTABLEEXTPROC GLScene.OpenGLTokens

GL_EXT_paletted_texture (EXT #78)
PFNGLCOLORTABLEPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOLORTABLEPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOLORTABLEPROC GLScene.OpenGLTokens

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)
PFNGLCOMBINERINPUTNVPROC GLScene.OpenGLTokens

PFNGLCOMBINEROUTPUTNVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFNVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFVNVPROC GLScene.OpenGLTokens

GL_NV_register_combiners (EXT #191)
PFNGLCOMBINERPARAMETERINVPROC GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLCOMPILESHADERARBPROC GLScene.OpenGLTokens

PFNGLCOMPILESHADERPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC GLScene.OpenGLTokens

GL_ARB_texture_compression (ARB #12)
PFNGLCOMPRESSEDTEXIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_texture_compression (#12)
PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCONVOLUTIONFILTER1DPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)
PFNGLCONVOLUTIONFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERFPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERIPROC GLScene.OpenGLTokens

deprecated;
PFNGLCONVOLUTIONPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYBUFFERSUBDATAPROC GLScene.OpenGLTokens

GL_ARB_copy_buffer (ARB #59)
PFNGLCOPYCOLORSUBTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCOLORTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCONVOLUTIONFILTER1DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCOPYCONVOLUTIONFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLCopyImageSubData GLScene.OpenGLTokens

GL_ARB_copy_image (ARB #123)
PFNGLCOPYIMAGESUBDATANVPROC GLScene.OpenGLTokens

GL_NV_copy_image (EXT #376)
PFNGLCOPYMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYPATHNVPROC GLScene.OpenGLTokens

PFNGLCOPYTEXIMAGE1DEXTPROC GLScene.OpenGLTokens

GL_EXT_copy_texture (EXT #10)
PFNGLCOPYTEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_copy_texture
PFNGLCOPYTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLCOVERFILLPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLCOVERFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLCREATEPROGRAMOBJECTARBPROC GLScene.OpenGLTokens

PFNGLCREATEPROGRAMPROC GLScene.OpenGLTokens

PFNGLCREATESHADEROBJECTARBPROC GLScene.OpenGLTokens

PFNGLCREATESHADERPROC GLScene.OpenGLTokens

PFNGLCREATESHADERPROGRAMVPROC GLScene.OpenGLTokens

PFNGLCreateSyncFromCLevent GLScene.OpenGLTokens

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)
PFNGLCURRENTPALETTEMATRIXARBPROC GLScene.OpenGLTokens

GL_ARB_matrix_palette (ARB #16) {deprecated?}
PFNGLDEBUGMESSAGECALLBACKARBPROC GLScene.OpenGLTokens

PFNGLDEBUGMESSAGECONTROLARBPROC GLScene.OpenGLTokens

GL_ARB_debug_output (ARB #104)
PFNGLDEBUGMESSAGEINSERTARBPROC GLScene.OpenGLTokens

PFNGLDELETEBUFFERSARBPROC GLScene.OpenGLTokens

PFNGLDELETEBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETEFENCESNVPROC GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETEOBJECTARBPROC GLScene.OpenGLTokens

GL_ARB_shader_objects (ARB #30)
PFNGLDELETEOCCLUSIONQUERIESNVPROC GLScene.OpenGLTokens

PFNGLDELETEPATHSNVPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPIPELINESPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSARBPROC GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLDELETEQUERIESARBPROC GLScene.OpenGLTokens

PFNGLDELETEQUERIESPROC GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSPROC GLScene.OpenGLTokens

PFNGLDELETESAMPLERSPROC GLScene.OpenGLTokens

PFNGLDELETESHADERPROC GLScene.OpenGLTokens

PFNGLDELETESYNCPROC GLScene.OpenGLTokens

PFNGLDELETETEXTURESEXTPROC GLScene.OpenGLTokens

PFNGLDELETETRANSFORMFEEDBACKSPROC GLScene.OpenGLTokens

PFNGLDELETEVERTEXARRAYSPROC GLScene.OpenGLTokens

PFNGLDEPTHBOUNDSEXTPROC GLScene.OpenGLTokens

GL_EXT_depth_bounds_test (EXT #297)
PFNGLDEPTHRANGEARRAYVPROC GLScene.OpenGLTokens

PFNGLDEPTHRANGEFPROC GLScene.OpenGLTokens

PFNGLDEPTHRANGEINDEXEDPROC GLScene.OpenGLTokens

PFNGLDETACHOBJECTARBPROC GLScene.OpenGLTokens

PFNGLDETACHSHADERPROC GLScene.OpenGLTokens

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLDISABLEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLDISABLEIPROC GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYPROC GLScene.OpenGLTokens

PFNGLDispatchCompute GLScene.OpenGLTokens

GL_ARB_compute_shader (ARB #122)
PFNGLDispatchComputeIndirect GLScene.OpenGLTokens

PFNGLDRAWARRAYSINDIRECTPROC GLScene.OpenGLTokens

GL_ARB_draw_indirect (ARB #87)
PFNGLDRAWARRAYSINSTANCEDARBPROC GLScene.OpenGLTokens

GL_ARB_draw_instanced (ARB #44)
PFNGLDRAWARRAYSINSTANCEDEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_instanced (EXT #327)
PFNGLDRAWARRAYSINSTANCEDPROC GLScene.OpenGLTokens

Core 3.1 New commands in OpenGL 3.1
PFNGLDRAWBUFFERSARBPROC GLScene.OpenGLTokens

GL_ARB_DrawBuffers (ARB #37)
PFNGLDRAWBUFFERSATIPROC GLScene.OpenGLTokens

GL_ATI_draw_buffers (EXT #277)
PFNGLDRAWBUFFERSPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_draw_buffers (#37)
PFNGLDRAWELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

GL_ARB_draw_elements_base_vertex (ARB #62)
PFNGLDRAWELEMENTSINDIRECTPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDARBPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDEXTPROC GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDPROC GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSEXTPROC GLScene.OpenGLTokens

GL_EXT_draw_range_elements (EXT #112)
PFNGLDRAWRANGEELEMENTSPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)
PFNGLDRAWTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC GLScene.OpenGLTokens

GL_ARB_transform_feedback3 (ARB #94)
PFNGLEDGEFLAGFORMATNVPROC GLScene.OpenGLTokens

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLENABLEINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLENABLEIPROC GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYARBPROC GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYPROC GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERNVPROC GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERPROC GLScene.OpenGLTokens

PFNGLENDOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLENDQUERYARBPROC GLScene.OpenGLTokens

PFNGLENDQUERYINDEXEDPROC GLScene.OpenGLTokens

PFNGLENDQUERYPROC GLScene.OpenGLTokens

PFNGLENDSCENEEXTPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKEXTPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKNVPROC GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLEXECUTEPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLFENCESYNCPROC GLScene.OpenGLTokens

GL_ARB_sync (ARB #66)
PFNGLFINALCOMBINERINPUTNVPROC GLScene.OpenGLTokens

PFNGLFINISHFENCENVPROC GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDBUFFERRANGEPROC GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

PFNGLFLUSHVERTEXARRAYRANGENVPROC GLScene.OpenGLTokens

GL_NV_vertex_array_range (EXT #190)
PFNGLFOGCOORDDEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDDPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDDVEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDDVPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDFEXTPROC GLScene.OpenGLTokens

GL_EXT_fog_coord (EXT #149)
PFNGLFOGCOORDFORMATNVPROC GLScene.OpenGLTokens

PFNGLFOGCOORDFPROC GLScene.OpenGLTokens

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)
PFNGLFOGCOORDFVEXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLFOGCOORDPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLFOGCOORDPOINTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLFramebufferParameteri GLScene.OpenGLTokens

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)
PFNGLFRAMEBUFFERREADBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFERPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERPROC GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREPROC GLScene.OpenGLTokens

PFNGLFRAMETERMINATORGREMEDYPROC GLScene.OpenGLTokens

GL_GREMEDY_frame_terminator (EXT #345)
PFNGLGENBUFFERSARBPROC GLScene.OpenGLTokens

PFNGLGENBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPPROC GLScene.OpenGLTokens

PFNGLGENERATEMULTITEXMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENERATETEXTUREMIPMAPEXTPROC GLScene.OpenGLTokens

PFNGLGENFENCESNVPROC GLScene.OpenGLTokens

GL_NV_fence (EXT #222)
PFNGLGENFRAMEBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLGENFRAMEBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENOCCLUSIONQUERIESNVPROC GLScene.OpenGLTokens

GL_NV_occlusion_query (EXT #261)
PFNGLGENPATHSNVPROC GLScene.OpenGLTokens

GL_NV_path_rendering
PFNGLGENPROGRAMPIPELINESPROC GLScene.OpenGLTokens

PFNGLGENPROGRAMSARBPROC GLScene.OpenGLTokens

PFNGLGENPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLGENQUERIESARBPROC GLScene.OpenGLTokens

GL_ARB_occlusion_query (ARB #29)
PFNGLGENQUERIESPROC GLScene.OpenGLTokens

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)
PFNGLGENRENDERBUFFERSEXTPROC GLScene.OpenGLTokens

PFNGLGENRENDERBUFFERSPROC GLScene.OpenGLTokens

PFNGLGENSAMPLERSPROC GLScene.OpenGLTokens

GL_ARB_sampler_objects (ARB #81)
PFNGLGENTEXTURESEXTPROC GLScene.OpenGLTokens

GL_EXT_texture_object (EXT #20)
PFNGLGENTRANSFORMFEEDBACKSPROC GLScene.OpenGLTokens

PFNGLGENVERTEXARRAYSPROC GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBARBPROC GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINENAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMARBPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMNAMEPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMPROC GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMSIVPROC GLScene.OpenGLTokens

PFNGLGETACTIVEVARYINGNVPROC GLScene.OpenGLTokens

PFNGLGETATTACHEDOBJECTSARBPROC GLScene.OpenGLTokens

PFNGLGETATTACHEDSHADERSPROC GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONARBPROC GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONPROC GLScene.OpenGLTokens

PFNGLGETBOOLEANINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETBOOLEANI_VPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERI64VPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVPROC GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAARBPROC GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOLORTABLEPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOLORTABLEPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEPROC GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETCONVOLUTIONFILTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCONVOLUTIONPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETCONVOLUTIONPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETDEBUGMESSAGELOGARBPROC GLScene.OpenGLTokens

PFNGLGETDOUBLEINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETDOUBLEI_VPROC GLScene.OpenGLTokens

PFNGLGETFENCEIVNVPROC GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETFLOATINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETFLOATI_VPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATAINDEXPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONEXTPROC GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONPROC GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGetFramebufferParameteriv GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETGRAPHICSRESETSTATUSARBPROC GLScene.OpenGLTokens

GL_ARB_robustness (ARB #105)
PFNGLGETHANDLEARBPROC GLScene.OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETHISTOGRAMPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETHISTOGRAMPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)
PFNGLGETINFOLOGARBPROC GLScene.OpenGLTokens

PFNGLGETINTEGER64I_VPROC GLScene.OpenGLTokens

Core 3.2
PFNGLGETINTEGER64VPROC GLScene.OpenGLTokens

PFNGLGETINTEGERINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETINTEGERI_VPROC GLScene.OpenGLTokens

PFNGLGETINTEGERUI64I_VNVPROC GLScene.OpenGLTokens

PFNGLGETINTEGERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGetInternalformati64v GLScene.OpenGLTokens

GL_ARB_internalformat_query2 (ARB #131)
PFNGLGETMINMAXPARAMETERFVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMINMAXPARAMETERIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETMULTISAMPLEFVPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXENVFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXENVIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENDVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXGENIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGetNamedFramebufferParameteriv GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC GLScene.OpenGLTokens

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETNCOLORTABLEARBPROC GLScene.OpenGLTokens

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETNCONVOLUTIONFILTERARBPROC GLScene.OpenGLTokens

PFNGLGETNHISTOGRAMARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPDVARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPFVARBPROC GLScene.OpenGLTokens

PFNGLGETNMAPIVARBPROC GLScene.OpenGLTokens

PFNGLGETNMINMAXARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPFVARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUIVARBPROC GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUSVARBPROC GLScene.OpenGLTokens

PFNGLGETNPOLYGONSTIPPLEARBPROC GLScene.OpenGLTokens

PFNGLGETNSEPARABLEFILTERARBPROC GLScene.OpenGLTokens

PFNGLGETNTEXIMAGEARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMDVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMFVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMIVARBPROC GLScene.OpenGLTokens

PFNGLGETNUNIFORMUIVARBPROC GLScene.OpenGLTokens

PFNGLGetObjectLabel GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERIVARBPROC GLScene.OpenGLTokens

PFNGLGetObjectPtrLabel GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYIVNVPROC GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYUIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHCOORDSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHDASHARRAYNVPROC GLScene.OpenGLTokens

PFNGLGETPATHLENGTHNVPROC GLScene.OpenGLTokens

PFNGLGETPATHMETRICRANGENVPROC GLScene.OpenGLTokens

PFNGLGETPATHMETRICSNVPROC GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHSPACINGNVPROC GLScene.OpenGLTokens

PFNGLGETPATHTEXGENFVNVPROC GLScene.OpenGLTokens

PFNGLGETPATHTEXGENIVNVPROC GLScene.OpenGLTokens

PFNGLGETPOINTERINDEXEDVEXTPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMBINARYPROC GLScene.OpenGLTokens

GL_ARB_get_program_binary (ARB #96)
PFNGLGETPROGRAMENVPARAMETERDVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMINFOLOGPROC GLScene.OpenGLTokens

PFNGLGetProgramInterfaceiv GLScene.OpenGLTokens

GL_ARB_program_interface_query (ARB #134)
PFNGLGETPROGRAMIVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMIVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMIVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERDVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEINFOLOGPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEIVPROC GLScene.OpenGLTokens

PFNGLGetProgramResourceIndex GLScene.OpenGLTokens

PFNGLGetProgramResourceiv GLScene.OpenGLTokens

PFNGLGetProgramResourceLocation GLScene.OpenGLTokens

PFNGLGetProgramResourceLocationIndex GLScene.OpenGLTokens

PFNGLGetProgramResourceName GLScene.OpenGLTokens

PFNGLGETPROGRAMSTAGEIVPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGARBPROC GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGNVPROC GLScene.OpenGLTokens

PFNGLGETQUERYINDEXEDIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTI64VEXTPROC GLScene.OpenGLTokens

GL_EXT_timer_query (EXT #319)
PFNGLGETQUERYOBJECTI64VPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VEXTPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVARBPROC GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVPROC GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIFVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLGETSEPARABLEFILTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLGETSHADERINFOLOGPROC GLScene.OpenGLTokens

PFNGLGETSHADERIVPROC GLScene.OpenGLTokens

PFNGLGETSHADERPRECISIONFORMATPROC GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEARBPROC GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEPROC GLScene.OpenGLTokens

PFNGLGETSTRINGIPROC GLScene.OpenGLTokens

PFNGLGETSUBROUTINEINDEXPROC GLScene.OpenGLTokens

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC GLScene.OpenGLTokens

GL_ARB_shader_subroutine (ARB #90)
PFNGLGETSYNCIVPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREIMAGEEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLGETTRACKMATRIXIVNVPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMBLOCKINDEXPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMBUFFERSIZEEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMDVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMFVARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMFVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMINDICESPROC GLScene.OpenGLTokens

GL_ARB_uniform_buffer_object (ARB #57)
PFNGLGETUNIFORMIVARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMIVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONARBPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMOFFSETEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMSUBROUTINEUIVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVPROC GLScene.OpenGLTokens

PFNGLGETVARYINGLOCATIONNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVEXTPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVEXTPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBLDVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVARBPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVNVPROC GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVPROC GLScene.OpenGLTokens

PFNGLHISTOGRAMPROC GLScene.OpenGLTokens

deprecated;
PFNGLINDEXFORMATNVPROC GLScene.OpenGLTokens

PFNGLINDEXFUNCEXTPROC GLScene.OpenGLTokens

GL_EXT_index_func (EXT #95)
PFNGLINDEXMATERIALEXTPROC GLScene.OpenGLTokens

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)
PFNGLINTERPOLATEPATHSNVPROC GLScene.OpenGLTokens

PFNGLInvalidateBufferData GLScene.OpenGLTokens

PFNGLInvalidateBufferSubData GLScene.OpenGLTokens

PFNGLInvalidateFramebuffer GLScene.OpenGLTokens

PFNGLInvalidateSubFramebuffer GLScene.OpenGLTokens

PFNGLInvalidateTexImage GLScene.OpenGLTokens

PFNGLInvalidateTexSubImage GLScene.OpenGLTokens

GL_ARB_invalidate_subdata (ARB #132)
PFNGLISBUFFERARBPROC GLScene.OpenGLTokens

PFNGLISBUFFERPROC GLScene.OpenGLTokens

PFNGLISBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLISENABLEDINDEXEDEXTPROC GLScene.OpenGLTokens

PFNGLISENABLEDIPROC GLScene.OpenGLTokens

PFNGLISFENCENVPROC GLScene.OpenGLTokens

PFNGLISFRAMEBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLISFRAMEBUFFERPROC GLScene.OpenGLTokens

PFNGLISNAMEDBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLISOCCLUSIONQUERYNVPROC GLScene.OpenGLTokens

PFNGLISPATHNVPROC GLScene.OpenGLTokens

PFNGLISPOINTINFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLISPOINTINSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLISPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLISPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLISPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLISPROGRAMPROC GLScene.OpenGLTokens

PFNGLISQUERYARBPROC GLScene.OpenGLTokens

PFNGLISQUERYPROC GLScene.OpenGLTokens

PFNGLISRENDERBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_object (EXT #310)
PFNGLISRENDERBUFFERPROC GLScene.OpenGLTokens

GL_ARB_framebuffer_object (ARB #45)
PFNGLISSAMPLERPROC GLScene.OpenGLTokens

PFNGLISSHADERPROC GLScene.OpenGLTokens

PFNGLISSYNCPROC GLScene.OpenGLTokens

PFNGLISTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLISTRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLISVERTEXARRAYPROC GLScene.OpenGLTokens

PFNGLLINKPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLLINKPROGRAMPROC GLScene.OpenGLTokens

PFNGLLOADPROGRAMNVPROC GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDARBPROC GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDPROC GLScene.OpenGLTokens

deprecated;
PFNGLLOADTRANSPOSEMATRIXFARBPROC GLScene.OpenGLTokens

GL_ARB_transpose_matrix (ARB #3)
PFNGLLOADTRANSPOSEMATRIXFPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix
PFNGLLOCKARRAYSEXTPROC GLScene.OpenGLTokens

GL_EXT_compiled_vertex_array (EXT #97)
PFNGLMAKEBUFFERNONRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAKEBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

GL_NV_shader_buffer_load (EXT #379)
PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERARBPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERPROC GLScene.OpenGLTokens

PFNGLMAPBUFFERRANGEPROC GLScene.OpenGLTokens

GL_ARB_map_buffer_range (ARB #50)
PFNGLMAPNAMEDBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMAPNAMEDBUFFERRANGEEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXFRUSTUMEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXPOINTERARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUBVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUIVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXINDEXUSVARBPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADIDENTITYEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXORTHOEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXPOPEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXPUSHEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXROTATEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXROTATEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXSCALEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXSCALEFEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEDEXTPROC GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEFEXTPROC GLScene.OpenGLTokens

PFNGLMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLMINSAMPLESHADINGARBPROC GLScene.OpenGLTokens

GL_ARB_sample_shading (ARB #70)
PFNGLMINSAMPLESHADINGPROC GLScene.OpenGLTokens

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)
PFNGLMULTIDRAWARRAYSEXTPROC GLScene.OpenGLTokens

GL_EXT_multi_draw_arrays (EXT #148)
PFNGLMultiDrawArraysIndirect GLScene.OpenGLTokens

GL_ARB_multi_draw_indirect (ARB #133)
PFNGLMULTIDRAWARRAYSPROC GLScene.OpenGLTokens

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)
PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSEXTPROC GLScene.OpenGLTokens

PFNGLMultiDrawElementsIndirect GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSPROC GLScene.OpenGLTokens

PFNGLMULTITEXBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD1SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD2SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD3SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4DARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4DVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4FARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4FVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4IARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4IVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4SARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORD4SVARBPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTITEXCOORDP1UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP1UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIVPROC GLScene.OpenGLTokens

PFNGLMULTITEXCOORDPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXENVIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENDEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENDVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXGENIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDARBPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDPROC GLScene.OpenGLTokens

deprecated;
PFNGLMULTTRANSPOSEMATRIXFARBPROC GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFPROC GLScene.OpenGLTokens

deprecated;
PFNGLNAMEDBUFFERDATAEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC GLScene.OpenGLTokens

PFNGLNamedFramebufferParameteri GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMSTRINGEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC GLScene.OpenGLTokens

PFNGLNORMALFORMATNVPROC GLScene.OpenGLTokens

PFNGLNORMALP3UIPROC GLScene.OpenGLTokens

PFNGLNORMALP3UIVPROC GLScene.OpenGLTokens

PFNGLObjectLabel GLScene.OpenGLTokens

PFNGLObjectPtrLabel GLScene.OpenGLTokens

PFNGLPATCHPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLPATCHPARAMETERIPROC GLScene.OpenGLTokens

GL_ARB_tessellation_shader (ARB #91)
PFNGLPATHCOLORGENNVPROC GLScene.OpenGLTokens

PFNGLPATHCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLPATHCOORDSNVPROC GLScene.OpenGLTokens

PFNGLPATHCOVERDEPTHFUNCNVPROC GLScene.OpenGLTokens

PFNGLPATHDASHARRAYNVPROC GLScene.OpenGLTokens

PFNGLPATHFOGGENNVPROC GLScene.OpenGLTokens

PFNGLPATHGLYPHRANGENVPROC GLScene.OpenGLTokens

PFNGLPATHGLYPHSNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERFNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERFVNVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERINVPROC GLScene.OpenGLTokens

PFNGLPATHPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLPATHSTENCILDEPTHOFFSETNVPROC GLScene.OpenGLTokens

PFNGLPATHSTENCILFUNCNVPROC GLScene.OpenGLTokens

PFNGLPATHSTRINGNVPROC GLScene.OpenGLTokens

PFNGLPATHSUBCOMMANDSNVPROC GLScene.OpenGLTokens

PFNGLPATHSUBCOORDSNVPROC GLScene.OpenGLTokens

PFNGLPATHTEXGENNVPROC GLScene.OpenGLTokens

PFNGLPAUSETRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLPOINTALONGPATHNVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFARBPROC GLScene.OpenGLTokens

GL_ARB_point_parameter (ARB #14)
PFNGLPOINTPARAMETERFPROC GLScene.OpenGLTokens

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)
PFNGLPOINTPARAMETERFVARBPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERINVPROC GLScene.OpenGLTokens

GL_NV_point_sprite (EXT #262)
PFNGLPOINTPARAMETERIPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVNVPROC GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLPOLYGONOFFSETEXTPROC GLScene.OpenGLTokens

GL_EXT_polygon_offset (EXT #3)
PFNGLPopDebugGroup GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXNVPROC GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXPROC GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTNVPROC GLScene.OpenGLTokens

GL_NV_primitive_restart (EXT #285)
PFNGLPRIORITIZETEXTURESEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMBINARYPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

GL_EXT_gpu_program_parameters (EXT #320)
PFNGLPROGRAMLOCALPARAMETER4DARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERIARBPROC GLScene.OpenGLTokens

GL_ARB_geometry_shader4 (ARB #47)
PFNGLPROGRAMPARAMETERIEXTPROC GLScene.OpenGLTokens

GL_EXT_geometry_shader4 (EXT #324)
PFNGLPROGRAMPARAMETERIPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4DVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4FVNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMSTRINGARBPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64NVPROC GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLPROGRAMVERTEXLIMITNVPROC GLScene.OpenGLTokens

GL_NV_geometry_program4 (EXT #323)
PFNGLPROVOKINGVERTEXPROC GLScene.OpenGLTokens

GL_ARB_provoking_vertex (ARB #64)
PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC GLScene.OpenGLTokens

PFNGLPushDebugGroup GLScene.OpenGLTokens

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)
PFNGLQUERYCOUNTERPROC GLScene.OpenGLTokens

GL_ARB_timer_query (ARB #85)
PFNGLREADNPIXELSARBPROC GLScene.OpenGLTokens

PFNGLRELEASESHADERCOMPILERPROC GLScene.OpenGLTokens

GL_ARB_ES2_compatibility (ARB #95)
PFNGLRENDERBUFFERSTORAGEEXTPROC GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC GLScene.OpenGLTokens

GL_EXT_framebuffer_multisample (EXT #317)
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEPROC GLScene.OpenGLTokens

PFNGLREQUESTRESIDENTPROGRAMSNVPROC GLScene.OpenGLTokens

PFNGLRESETHISTOGRAMPROC GLScene.OpenGLTokens

deprecated;
PFNGLRESETMINMAXPROC GLScene.OpenGLTokens

deprecated;
PFNGLRESIZEBUFFERSMESAPROC GLScene.OpenGLTokens

GL_MESA_resize_buffers (EXT #196)
PFNGLRESUMETRANSFORMFEEDBACKPROC GLScene.OpenGLTokens

PFNGLSAMPLECOVERAGEARBPROC GLScene.OpenGLTokens

GL_ARB_multisample (ARB #5)
PFNGLSAMPLECOVERAGEPROC GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_multisample (#5)
PFNGLSAMPLEMASKEXTPROC GLScene.OpenGLTokens

GL_EXT_multisample (EXT #209)
PFNGLSAMPLEMASKIPROC GLScene.OpenGLTokens

PFNGLSAMPLEMASKSGISPROC GLScene.OpenGLTokens

GL_SGIS_multisample (EXT #25)
PFNGLSAMPLEPASSARBPROC GLScene.OpenGLTokens

ARB Extensions unknown ARB extension
PFNGLSAMPLEPATTERNEXTPROC GLScene.OpenGLTokens

PFNGLSAMPLEPATTERNSGISPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIIVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIVPROC GLScene.OpenGLTokens

PFNGLSCISSORARRAYVPROC GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDPROC GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BEXTPROC GLScene.OpenGLTokens

GL_EXT_secondary_color (EXT #145)
PFNGLSECONDARYCOLOR3BPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)
PFNGLSECONDARYCOLOR3BVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3DEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3DVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3FEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3FVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3IEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3IVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3SEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3SVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UBEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UBVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UIEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3UIVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3USEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLOR3USVEXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USVPROC GLScene.OpenGLTokens

deprecated;
PFNGLSECONDARYCOLORFORMATNVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIVPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTERPROC GLScene.OpenGLTokens

deprecated;
PFNGLSEPARABLEFILTER2DPROC GLScene.OpenGLTokens

deprecated;
PFNGLSETFENCENVPROC GLScene.OpenGLTokens

PFNGLSHADERBINARYPROC GLScene.OpenGLTokens

PFNGLSHADERSOURCEARBPROC GLScene.OpenGLTokens

PFNGLSHADERSOURCEPROC GLScene.OpenGLTokens

PFNGLShaderStorageBlockBinding GLScene.OpenGLTokens

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)
PFNGLSTENCILCLEARTAGEXTPROC GLScene.OpenGLTokens

GL_EXT_stencil_clear_tag (EXT #314)
PFNGLSTENCILFILLPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLSTENCILFILLPATHNVPROC GLScene.OpenGLTokens

PFNGLSTENCILFUNCSEPARATEPROC GLScene.OpenGLTokens

PFNGLSTENCILMASKSEPARATEPROC GLScene.OpenGLTokens

PFNGLSTENCILOPSEPARATEPROC GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)
PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC GLScene.OpenGLTokens

PFNGLSTENCILSTROKEPATHNVPROC GLScene.OpenGLTokens

PFNGLSTRINGMARKERGREMEDYPROC GLScene.OpenGLTokens

GL_GREMEDY_string_marker (EXT #311)
PFNGLTBUFFERMASK3DFXPROC GLScene.OpenGLTokens

GL_3DFX_tbuffer (EXT #208)
PFNGLTESSELLATIONFACTORAMDPROC GLScene.OpenGLTokens

GL_AMD_vertex_shader_tessellator (EXT #363)
PFNGLTESSELLATIONMODEAMDPROC GLScene.OpenGLTokens

PFNGLTESTFENCENVPROC GLScene.OpenGLTokens

PFNGLTEXBUFFERARBPROC GLScene.OpenGLTokens

GL_ARB_texture_buffer_object (ARB #51)
PFNGLTEXBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)
PFNGLTEXBUFFERPROC GLScene.OpenGLTokens

PFNGLTexBufferRange GLScene.OpenGLTokens

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)
PFNGLTEXCOORDFORMATNVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIVPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIPROC GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIVPROC GLScene.OpenGLTokens

PFNGLTEXIMAGE2DMULTISAMPLEPROC GLScene.OpenGLTokens

GL_ARB_texture_multisample (ARB #67)
PFNGLTEXIMAGE3DEXTPROC GLScene.OpenGLTokens

GL_EXT_texture3D (EXT #6)
PFNGLTEXIMAGE3DMULTISAMPLEPROC GLScene.OpenGLTokens

PFNGLTEXIMAGE3DPROC GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_texture3D (#6)
PFNGLTEXPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXPARAMETERIIVPROC GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_texture_integer
PFNGLTEXPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXPARAMETERIUIVPROC GLScene.OpenGLTokens

PFNGLTexStorage2DMultisample GLScene.OpenGLTokens

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)
PFNGLTexStorage3DMultisample GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE1DEXTPROC GLScene.OpenGLTokens

GL_EXT_subtexture (EXT #9)
PFNGLTEXSUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DPROC GLScene.OpenGLTokens

PFNGLTEXTUREBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLTextureBufferRange GLScene.OpenGLTokens

PFNGLTEXTURECOLORMASKSGISPROC GLScene.OpenGLTokens

GL_SGIS_texture_color_mask (EXT #214)
PFNGLTEXTUREIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERFVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIUIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIVEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURERENDERBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLTextureStorage2DMultisample GLScene.OpenGLTokens

PFNGLTextureStorage3DMultisample GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE1DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE2DEXTPROC GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE3DEXTPROC GLScene.OpenGLTokens

PFNGLTextureView GLScene.OpenGLTokens

GL_ARB_texture_view (ARB #124)
PFNGLTRACKMATRIXNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSPROC GLScene.OpenGLTokens

PFNGLTRANSFORMPATHNVPROC GLScene.OpenGLTokens

PFNGLUDELETENURBSTESSELLATOREXTPROC GLScene.OpenGLTokens

PFNGLUNEWNURBSTESSELLATOREXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1DPROC GLScene.OpenGLTokens

GL_ARB_gpu_shader_fp64 (ARB #89)
PFNGLUNIFORM1DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM1IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM1UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2DPROC GLScene.OpenGLTokens

PFNGLUNIFORM2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM2IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM2UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3DPROC GLScene.OpenGLTokens

PFNGLUNIFORM3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM3IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM3UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4DPROC GLScene.OpenGLTokens

PFNGLUNIFORM4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORM4IVPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIVEXTPROC GLScene.OpenGLTokens

PFNGLUNIFORM4UIVPROC GLScene.OpenGLTokens

PFNGLUNIFORMBLOCKBINDINGPROC GLScene.OpenGLTokens

PFNGLUNIFORMBUFFEREXTPROC GLScene.OpenGLTokens

GL_EXT_bindable_uniform (EXT #342)
PFNGLUNIFORMMATRIX2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3FVPROC GLScene.OpenGLTokens

core 2.1 new commands in OpenGL 2.1
PFNGLUNIFORMMATRIX2X4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVARBPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3DVPROC GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3FVPROC GLScene.OpenGLTokens

PFNGLUNIFORMSUBROUTINESUIVPROC GLScene.OpenGLTokens

PFNGLUNIFORMUI64NVPROC GLScene.OpenGLTokens

PFNGLUNIFORMUI64VNVPROC GLScene.OpenGLTokens

PFNGLUNLOCKARRAYSEXTPROC GLScene.OpenGLTokens

PFNGLUNMAPBUFFERARBPROC GLScene.OpenGLTokens

PFNGLUNMAPBUFFERPROC GLScene.OpenGLTokens

PFNGLUNMAPNAMEDBUFFEREXTPROC GLScene.OpenGLTokens

PFNGLUNURBSCALLBACKDATAEXTPROC GLScene.OpenGLTokens

GLU extensions (might not be same naming as c versions?)
PFNGLUSEPROGRAMOBJECTARBPROC GLScene.OpenGLTokens

PFNGLUSEPROGRAMPROC GLScene.OpenGLTokens

PFNGLUSEPROGRAMSTAGESPROC GLScene.OpenGLTokens

GL_ARB_separate_shader_objects (ARB #97)
PFNGLVALIDATEPROGRAMARBPROC GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPIPELINEPROC GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPROC GLScene.OpenGLTokens

PFNGLVertexArrayBindVertexBuffer GLScene.OpenGLTokens

PFNGLVERTEXARRAYRANGENVPROC GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribBinding GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribFormat GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribIFormat GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribLFormat GLScene.OpenGLTokens

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC GLScene.OpenGLTokens

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available
PFNGLVertexArrayVertexBindingDivisor GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_program (ARB #26)
PFNGLVERTEXATTRIB1DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVPROC GLScene.OpenGLTokens

PFNGLVertexAttribBinding GLScene.OpenGLTokens

PFNGLVERTEXATTRIBDIVISORARBPROC GLScene.OpenGLTokens

GL_ARB_instanced_arrays (ARB #49)
PFNGLVERTEXATTRIBDIVISORPROC GLScene.OpenGLTokens

Core 3.3
PFNGLVertexAttribFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IEXTPROC GLScene.OpenGLTokens

GL_EXT_gpu_shader4 (EXT #326)
PFNGLVERTEXATTRIBI1IPROC GLScene.OpenGLTokens

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4
PFNGLVERTEXATTRIBI1IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVEXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVPROC GLScene.OpenGLTokens

PFNGLVertexAttribIFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTEREXTPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL1DPROC GLScene.OpenGLTokens

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)
PFNGLVERTEXATTRIBL1DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DVPROC GLScene.OpenGLTokens

PFNGLVertexAttribLFormat GLScene.OpenGLTokens

PFNGLVERTEXATTRIBLPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERARBPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4DVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4FVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4SVNVPROC GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4UBVNVPROC GLScene.OpenGLTokens

PFNGLVertexBindingDivisor GLScene.OpenGLTokens

PFNGLVERTEXBLENDARBPROC GLScene.OpenGLTokens

PFNGLVERTEXFORMATNVPROC GLScene.OpenGLTokens

PFNGLVERTEXP2UIPROC GLScene.OpenGLTokens

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)
PFNGLVERTEXP2UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXP3UIPROC GLScene.OpenGLTokens

PFNGLVERTEXP3UIVPROC GLScene.OpenGLTokens

PFNGLVERTEXP4UIPROC GLScene.OpenGLTokens

PFNGLVERTEXP4UIVPROC GLScene.OpenGLTokens

PFNGLVIEWPORTARRAYVPROC GLScene.OpenGLTokens

GL_ARB_viewport_array (ARB #100)
PFNGLVIEWPORTINDEXEDFPROC GLScene.OpenGLTokens

PFNGLVIEWPORTINDEXEDFVPROC GLScene.OpenGLTokens

PFNGLWAITSYNCPROC GLScene.OpenGLTokens

PFNGLWEIGHTBVARBPROC GLScene.OpenGLTokens

GL_ARB_vertex_blend (ARB #15) {deprecated?}
PFNGLWEIGHTDVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTFVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTIVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTPATHSNVPROC GLScene.OpenGLTokens

PFNGLWEIGHTPOINTERARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTSVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUBVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUIVARBPROC GLScene.OpenGLTokens

PFNGLWEIGHTUSVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2DARBPROC GLScene.OpenGLTokens

GL_ARB_window_pos (ARB #25)
PFNGLWINDOWPOS2DPROC GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)
PFNGLWINDOWPOS2DVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2FARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2FPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2FVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2IARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2IPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2IVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2SARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2SPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS2SVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS2SVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3DARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3DPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3DVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3DVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3FARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3FPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3FVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3FVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3IARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3IPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3IVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3IVPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3SARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3SPROC GLScene.OpenGLTokens

deprecated;
PFNGLWINDOWPOS3SVARBPROC GLScene.OpenGLTokens

PFNGLWINDOWPOS3SVPROC GLScene.OpenGLTokens

deprecated;
PFNWGLALLOCATEMEMORYNVPROC GLScene.OpenGLTokens

PFNWGLBINDTEXIMAGEARBPROC GLScene.OpenGLTokens

WGL_ARB_render_texture (ARB #20)
PFNWGLCHOOSEPIXELFORMATARBPROC GLScene.OpenGLTokens

PFNWGLCREATEAFFINITYDCNVPROC GLScene.OpenGLTokens

PFNWGLCREATEBUFFERREGIONARBPROC GLScene.OpenGLTokens

WGL WGL - ARB WGL_buffer_region (ARB #4)
PFNWGLCREATECONTEXTATTRIBSARBPROC GLScene.OpenGLTokens

WGL_ARB_create_context (ARB #55)
PFNWGLCREATEPBUFFERARBPROC GLScene.OpenGLTokens

WGL_ARB_pbuffer (ARB #11)
PFNWGLDELETEBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLDELETEDCNVPROC GLScene.OpenGLTokens

PFNWGLDESTROYPBUFFERARBPROC GLScene.OpenGLTokens

PFNWGLDXCLOSEDEVICEPROC GLScene.OpenGLTokens

PFNWGLDXLOCKOBJECTSPROC GLScene.OpenGLTokens

PFNWGLDXOBJECTACCESSPROC GLScene.OpenGLTokens

PFNWGLDXOPENDEVICEPROC GLScene.OpenGLTokens

PFNWGLDXREGISTEROBJECTPROC GLScene.OpenGLTokens

PFNWGLDXSETRESOURCESHAREHANDLEPROC GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)
PFNWGLDXUNLOCKOBJECTSNVPROC GLScene.OpenGLTokens

PFNWGLDXUNREGISTEROBJECTPROC GLScene.OpenGLTokens

PFNWGLENUMGPUDEVICESNVPROC GLScene.OpenGLTokens

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC GLScene.OpenGLTokens

PFNWGLENUMGPUSNVPROC GLScene.OpenGLTokens

WGL_NV_gpu_affinity (EXT #355)
PFNWGLFREEMEMORYNVPROC GLScene.OpenGLTokens

PFNWGLGETCURRENTREADDCARBPROC GLScene.OpenGLTokens

PFNWGLGETEXTENSIONSSTRINGARBPROC GLScene.OpenGLTokens

WGL_ARB_extensions_string (ARB #8)
PFNWGLGETPBUFFERDCARBPROC GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBFVARBPROC GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBIVARBPROC GLScene.OpenGLTokens

WGL_ARB_pixel_format (ARB #9)
PFNWGLGETSWAPINTERVALEXTPROC GLScene.OpenGLTokens

PFNWGLMAKECONTEXTCURRENTARBPROC GLScene.OpenGLTokens

WGL_make_current_read (ARB #10)
PFNWGLQUERYPBUFFERARBPROC GLScene.OpenGLTokens

PFNWGLRELEASEPBUFFERDCARBPROC GLScene.OpenGLTokens

PFNWGLRELEASETEXIMAGEARBPROC GLScene.OpenGLTokens

PFNWGLRESTOREBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLSAVEBUFFERREGIONARBPROC GLScene.OpenGLTokens

PFNWGLSETPBUFFERATTRIBARBPROC GLScene.OpenGLTokens

PFNWGLSWAPINTERVALEXTPROC GLScene.OpenGLTokens

WGL - EXT WGL_EXT_swap_control (EXT #172)
PFontEntry GXS.SpaceText

Holds an entry in the font manager list (used in TgxSpaceText)
PFrustum GLScene.VectorGeometry

PFXPointerList GXS.ParticleFX

PGLbitfield GLScene.OpenGL4

PGLbitfield GLScene.OpenGLTokens

UINT
PGLboolean GLScene.OpenGL4

PGLboolean GLScene.OpenGLTokens

PGLbyte GLScene.OpenGL4

PGLbyte GLScene.OpenGLTokens

PGLChar GLScene.OpenGL4

PGLchar GLScene.OpenGLTokens

PGLclampd GLScene.OpenGL4

PGLclampd GLScene.OpenGLTokens

PGLclampf GLScene.OpenGL4

PGLclampf GLScene.OpenGLTokens

PGLdouble GLScene.OpenGL4

PGLdouble GLScene.OpenGLTokens

PGLenum GLScene.OpenGL4

PGLenum GLScene.OpenGLTokens

PGLfloat GLScene.OpenGL4

PGLfloat GLScene.OpenGLTokens

PGLhalf GLScene.OpenGLTokens

PGLhandleARB GLScene.OpenGL4

PGLhandleARB GLScene.OpenGLTokens

PGLint GLScene.OpenGL4

PGLint GLScene.OpenGLTokens

PGLint64 GLScene.OpenGL4

PGLint64 GLScene.OpenGLTokens

PGLint64EXT GLScene.OpenGL4

PGLint64EXT GLScene.OpenGLTokens

PGLintptr GLScene.OpenGL4

PGLintptr GLScene.OpenGLTokens

PGLMatrix GLScene.VectorTypes

The matrix by default
PGLParticleArray GXS.ParticleFX

PGLPCharArray GLScene.OpenGL4

PGLPCharArray GLScene.OpenGLTokens

PGLPointer GLScene.OpenGL4

PGLPointer GLScene.OpenGLTokens

PGLshort GLScene.OpenGL4

PGLshort GLScene.OpenGLTokens

PGLsizei GLScene.OpenGL4

PGLsizei GLScene.OpenGLTokens

PGLsizeiptr GLScene.OpenGLTokens

PGLsync GLScene.OpenGLTokens

PGLubyte GLScene.OpenGL4

PGLubyte GLScene.OpenGLTokens

PGLuint GLScene.OpenGL4

PGLuint GLScene.OpenGLTokens

PGLuint64 GLScene.OpenGL4

PGLuint64 GLScene.OpenGLTokens

PGLuint64EXT GLScene.OpenGL4

PGLuint64EXT GLScene.OpenGLTokens

PGLUNurbs GLScene.OpenGL4

PGLUNurbs GLScene.OpenGLTokens

PGLUNurbsObj GLScene.OpenGL4

PGLUNurbsObj GLScene.OpenGLTokens

PGLUQuadric GLScene.OpenGL4

PGLUQuadric GLScene.OpenGLTokens

PGLUQuadricObj GLScene.OpenGL4

PGLUQuadricObj GLScene.OpenGLTokens

PGLushort GLScene.OpenGL4

PGLushort GLScene.OpenGLTokens

PGLUTesselator GLScene.OpenGL4

PGLUTesselator GLScene.OpenGLTokens

PGLUTesselatorObj GLScene.OpenGL4

PGLUTesselatorObj GLScene.OpenGLTokens

PGLUTriangulatorObj GLScene.OpenGL4

PGLUTriangulatorObj GLScene.OpenGLTokens

PGLvdpauSurfaceNV GLScene.OpenGLTokens

PGLVector GLScene.VectorTypes

The vector by default
PGLvoid GLScene.OpenGL4

PGLvoid GLScene.OpenGLTokens

PGNGLGETBUFFERPARAMETERUI64VNV GLScene.OpenGLTokens

PGPUDEVICE GLScene.OpenGL4

PGPUDEVICE GLScene.OpenGLTokens

PgTransformationRec GLScene.PipelineTransform

PgxHeightTileInfo GXS.HeightTileFile

PgxOctreeNode GXS.Octree

PgxOctreeTriangleInfo GXS.Octree

PgxPixel24 GXS.Graphics

PgxPixel32 GXS.Graphics

PgxPixel32Array GXS.Graphics

PgxRCHandle GXS.Context

PGXRenderContextInfo GXS.RenderContextInfo

PgxStarRecord GXS.Skydome

PgxVertexBoneWeightArray GXS.VectorFileObjects

PgxVertexData GXS.Mesh

PgxVerticesBoneWeights GXS.VectorFileObjects

PgxVideoMode GXS.Screen

PHalfFloat GLScene.Utils

PHeightTile GXS.HeightTileFile

PHGPUNV GLScene.OpenGL4

—————————- OpenGL Utility (GLU) types ——————–
PHGPUNV GLScene.OpenGLTokens

PHmgBoundingBox GLScene.GeometryBB

Structure for storing Bounding Boxes
PHomogeneousByteVector GLScene.VectorGeometry

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3
PHomogeneousDblVector GLScene.VectorGeometry

PHomogeneousExtVector GLScene.VectorGeometry

PHomogeneousFltVector GLScene.VectorGeometry

PHomogeneousIntVector GLScene.VectorGeometry

PHomogeneousMatrix GLScene.VectorGeometry

PHomogeneousPtrVector GLScene.VectorGeometry

PHomogeneousVector GLScene.VectorGeometry

some simplified names
PHomogeneousWordVector GLScene.VectorGeometry

PHVIDEOINPUTDEVICENV GLScene.OpenGL4

PHVIDEOINPUTDEVICENV GLScene.OpenGLTokens

PInstPropList FMxXCollectionEditor

PIntegerArray GLScene.VectorGeometry

PIntegerArray GXS.HeightTileFile

PIntegerVector GLScene.VectorGeometry

PIntermediateFormatArray GXS.ImageUtils

PLMTS GXS.FileLMTS

PLMTS_Header GXS.FileLMTS

max texture filename length
PLMTS_Subset GXS.FileLMTS

PLMTS_TexData GXS.FileLMTS

PLMTS_Vertex GXS.FileLMTS

PLongWordArray GLScene.VectorGeometry

PLongWordVector GLScene.VectorGeometry

PMatrix4f GLScene.VectorTypes

the matrix by default
PMatrixArray GLScene.VectorGeometry

PMatrixRec GLScene.VectorTypesExt

PMDCTagFrame GXS.FileMDC

PMDCTagName GXS.FileMDC

pMS3DComment GXS.FileMS3D

PMS3DJointArray GXS.FileMS3D

PMS3DKeyframePositionArray GXS.FileMS3D

PMS3DKeyframeRotationArray GXS.FileMS3D

PMS3DTriangleArray GXS.FileMS3D

PMS3DVertexArray GXS.FileMS3D

pMS3D_vertex_ex_t GXS.FileMS3D

PParticleReference GXS.ParticleFX

PParticleReferenceArray GXS.ParticleFX

PPFXRegion GXS.ParticleFX

PPHeightTileInfo GXS.HeightTileFile

PPoint2DRec GLScene.VectorTypesExt

PPoint3DRec GLScene.VectorTypesExt

PPointerArray GLScene.VectorGeometry

PPointerVector GLScene.VectorGeometry

PQuaternion GLScene.VectorGeometry

q = ([x, y, z], w)
PQuaternionArray GLScene.VectorGeometry

PRGBA32F GXS.ImageUtils

PROAMTriangleNode GXS.ROAMPatch

PSceneObjectEntry GXS.ObjectManager

PShortIntArray GXS.HeightTileFile

PSingleArray GLScene.VectorGeometry

PSingleRaster GXS.HeightData

PSmallIntArray GXS.HeightData

PSmallIntArray GXS.HeightTileFile

PSmallIntRaster GXS.HeightData

PSoundFileFormat GXS.SoundFileObjects

PSqrt255Array GLScene.Utils

PTexPoint GLScene.VectorGeometry

PTexPointArray GLScene.VectorGeometry

PThorpoint GXS.ThorFX

PThorpointArray GXS.ThorFX

PTriangleRecArray GLScene.VectorTypesExt

PVector2f GLScene.VectorGeometry

PVector4f GLScene.VectorTypes

PVectorArray GLScene.VectorGeometry

PVectorRec GLScene.VectorTypesExt

PVertArray GLScene.VectorTypesExt

PVertex GLScene.VectorGeometry

PVertex2DArr GXS.Isolines

PVertexRec GXS.Objects

PVKVertexDataArray GXS.Mesh

PVoxelData GLScene.VectorTypesExt

PVoxelRec GLScene.VectorTypesExt

PVXIsoline GXS.Isolines

PWGLSwap GLScene.OpenGL4

PWGLswap GLScene.OpenGLTokens

========= Windows types ==============
PWordVector GLScene.VectorGeometry

PZArray GXS.zBuffer

T1DPerlinArray GXS.Perlin

T2DPerlinArray GXS.Perlin

T48BitBlock GXS.ImageUtils

TAABBCorners GLScene.GeometryBB

Structure for storing the corners of an AABB, used with ExtractAABBCorners
TAABBOverlapEvent GXS.NGDManager

TAArray GXS.zBuffer

TAArrayIdx GXS.zBuffer

TAffineByteMatrix GLScene.VectorGeometry

TAffineByteVector GLScene.VectorGeometry

TAffineDblMatrix GLScene.VectorGeometry

TAffineDblVector GLScene.VectorGeometry

TAffineExtMatrix GLScene.VectorGeometry

TAffineExtVector GLScene.VectorGeometry

TAffineFltMatrix GLScene.VectorGeometry

TAffineFltVector GLScene.VectorGeometry

TAffineIntMatrix GLScene.VectorGeometry

TAffineIntVector GLScene.VectorGeometry

TAffineMatrix GLScene.VectorGeometry

TAffinePtrVector GLScene.VectorGeometry

TAffineVector GLScene.VectorGeometry

TAffineVectorArray GLScene.VectorGeometry

TAffineWordMatrix GLScene.VectorGeometry

TAffineWordVector GLScene.VectorGeometry

TAMFloatVector GLScene.RandomLib

Used as a Dynamic Vector
TAngleLimit1 GXS.Objects

TAngleLimit2 GXS.Objects

TApplyForceAndTorqueEvent GXS.NGDManager

TArray3DExt GLScene.VectorTypesExt

TASETextureMap GXS.FileASE

TAVICompressor GXS.AVIRecorder

TAVIImageRetrievalMode GXS.AVIRecorder

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution
TAVIRecorderPostProcessEvent GXS.AVIRecorder

TAVIRecorderState GXS.AVIRecorder

TAVISizeRestriction GXS.AVIRecorder

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.
TBASS3DAlgorithm GXS.Sounds.BASS

TBSPRenderSort GXS.BSP

TBumpMethod GXSL.BumpShaders

TBumpOption GXSL.BumpShaders

TBumpOptions GXSL.BumpShaders

Enable parallax offset mapping
TBumpSpace GXSL.BumpShaders

TByteArray GXS.HeightData

for CreateMonochromeBitmap
TByteMatrixArr GXS.Isolines

TByteRaster GXS.HeightData

TByteVector GLScene.VectorGeometry

TByteVectorArr GXS.Isolines

TCalcPointEvent GXS.ThorFX

TCardinalVector GLScene.VectorGeometry

TCastArray GXS.Isolines

TCgFPProfile GXS.CgShader

Available fragment program profile
TCgUnApplyEvent GXS.CgShader

TCgVPProfile GXS.CgShader

Available vertex program profile
TCGxApplyEvent GXS.CgShader

TCGxBombShaderTextureSource GXS.CgBombShader

TCGxProgramType GXS.CgShader

TCGxShaderEvent GXS.CgShader

TCollisionBoundingMode GXS.Collision

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code)
TCollisionConstraintTypes GXS.VerletTypes

TCollisionConstraintTypesSet GXS.VerletTypes

TCollisionIteratorEvent GXS.NGDManager

Events for Newton Callback
TCompressionLevel GXS.ArchiveManager

TConeForme GBE.ConeExtend

TContactProcessEvent GXS.NGDManager

TCSGOperation GXS.MeshCSG

TCuAddresMode GXS.CUDA.API

TCubicSplineMatrix GLScene.Spline

TCUDAChange GXS.CUDA.API

TCUDAChanges GXS.CUDA.API

TCUDAChannelNum GXS.CUDA.API

TCUDAChannelType GXS.CUDA.API

TCUDAComponentClass GXS.CUDA.API

TCUDAContextList GXS.CUDA.Context

TCUDADeviceList GXS.CUDA.Context

TCUDAFFTdir GXS.CUDA.FFTPlan

TCUDAFFTransform GXS.CUDA.FFTPlan

TCUDAHandleList GXS.CUDA.Context

TCUDAMapping GXS.CUDA.API

TCUDAMemMapFlag GXS.CUDA.API

TCUDAMemMapFlags GXS.CUDA.API

Fast write, slow read
TCUDAMemType GXS.CUDA.API

TCuFilterMode GXS.CUDA.API

TCullingMode GXS.SpacePartition

TDataFileCapabilities GXS.ApplicationFileIO

TDComplete GLScene.Triangulation

TDebugProc GLScene.OpenGLTokens

TDebugProcAMD GLScene.OpenGLTokens

TDEdges GLScene.Triangulation

TDeSerializeEvent GXS.NGDManager

TDESolverType GXS.PhysManager

only ssEuler is usable at the moment
TDirectRenderEvent GXS.Scene

Event for user-specific rendering in a TgxDirectOpenVX object.
TDirPlan GLScene.GeometryBB

TDoubleArray GLScene.Polynomials

TDoubleArray GLScene.VectorTypesExt

TDoubleHmgPlane GLScene.VectorGeometry

TDoubleVector GLScene.VectorGeometry

TDProgressEvent GLScene.Triangulation

TDTriangle GLScene.Triangulation

TDVertex GLScene.Triangulation

TEarthSkydomeOption GXS.Skydome

TEarthSkydomeOptions GXS.Skydome

TEaseType GLScene.AnimationUtils

TECColliderList GXS.EllipseCollision

TECColliderShape GXS.EllipseCollision

TECContactList GXS.EllipseCollision

TECFreeFormList GXS.EllipseCollision

TECTriMeshList GXS.EllipseCollision

TEulerOrder GLScene.VectorGeometry

—————————————————————————- Quaternion functions —————————————————————————-
TExtendedVector GLScene.VectorGeometry

TFastCollisionChecker GXS.Collision

TFeedBackMeshLaunching GXS.CUDA.Graphics

TFeedBackMeshPrimitive GXS.CUDA.Graphics

TFeedbackMode GXS.Feedback

TFindCuFileFunc GXS.CUDA.Compiler

TFireParticleArray GXS.FireFX

TFlareElement GXS.LensFlare

TFlareElements GXS.LensFlare

TFloatVector GLScene.VectorGeometry

TFrustrumPart GXS.GeomObjects

TFrustrumParts GXS.GeomObjects

TFXPointerList GXS.ParticleFX

TGBEJoystickType GBE.Joystick

TGBEPathFinderMode uGBEPathFinder

TGBETypePosition GBE.PlayerPosition

TGetTerrainBoundsEvent GXS.TerrainRenderer

TGLbitfield GLScene.OpenGL4

TGLbitfield GLScene.OpenGLTokens

TGLboolean GLScene.OpenGL4

TGLboolean GLScene.OpenGLTokens

=========== OpenGL types ============
TGLbyte GLScene.OpenGL4

TGLbyte GLScene.OpenGLTokens

TGLchar GLScene.OpenGLTokens

TGLclampd GLScene.OpenGL4

TGLclampd GLScene.OpenGLTokens

TGLclampf GLScene.OpenGL4

TGLDEBUGPROCARB GLScene.OpenGLTokens

TGLdouble GLScene.OpenGL4

TGLdouble GLScene.OpenGLTokens

TGLEnum GLScene.OpenGL4

TGLenum GLScene.OpenGLTokens

TGLfloat GLScene.OpenGL4

TGLfloat GLScene.OpenGLTokens

TGLhalf GLScene.OpenGLTokens

TGLhandleARB GLScene.OpenGLTokens

TGLint GLScene.OpenGL4

TGLint GLScene.OpenGLTokens

TGLint64 GLScene.OpenGL4

TGLint64 GLScene.OpenGLTokens

TGLint64EXT GLScene.OpenGL4

TGLint64EXT GLScene.OpenGLTokens

TglInternalCompression GLScene.TextureFormat

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression
TglInternalFormat GLScene.TextureFormat

TGLInterpolationType GLScene.VectorGeometry

TGLintptr GLScene.OpenGL4

the size of these depend on platform (32bit or 64bit)
TGLintptr GLScene.OpenGLTokens

the size of these depend on platform (32bit or 64bit)
TGLMatrix GLScene.VectorTypes

TglSeparateTextureWrap GLScene.TextureFormat

Texture addressing rules
TGLshort GLScene.OpenGL4

TGLshort GLScene.OpenGLTokens

TGLsizei GLScene.OpenGL4

TGLsizei GLScene.OpenGLTokens

TGLsizeiptr GLScene.OpenGL4

TGLsizeiptr GLScene.OpenGLTokens

TGLString GLScene.OpenGL4

TglSwizzleVector GLScene.TextureFormat

TGLsync GLScene.OpenGL4

TGLsync GLScene.OpenGLTokens

TglTextureCompareMode GLScene.TextureFormat

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*
TglTextureFilteringQuality GLScene.TextureFormat

Filtering quality
TglTextureSwizzle GLScene.TextureFormat

TglTextureTarget GLScene.TextureFormat

TGLubyte GLScene.OpenGL4

TGLubyte GLScene.OpenGLTokens

TGLuint GLScene.OpenGL4

TGLuint GLScene.OpenGLTokens

TGLuint64 GLScene.OpenGL4

TGLuint64 GLScene.OpenGLTokens

TGLuint64EXT GLScene.OpenGL4

TGLuint64EXT GLScene.OpenGLTokens

TGLUNurbsErrorProc GLScene.OpenGL4

GLUNurbsCallback
TGLUNurbsErrorProc GLScene.OpenGLTokens

TGLUNurbsObj GLScene.OpenGL4

backwards compatibility
TGLUNurbsObj GLScene.OpenGLTokens

backwards compatibility
TGLUQuadricErrorProc GLScene.OpenGL4

GLUQuadricCallback
TGLUQuadricErrorProc GLScene.OpenGLTokens

Callback function prototypes
TGLUQuadricObj GLScene.OpenGL4

TGLUQuadricObj GLScene.OpenGLTokens

TGLushort GLScene.OpenGL4

TGLushort GLScene.OpenGLTokens

TGLUTessBeginDataProc GLScene.OpenGL4

TGLUTessBeginDataProc GLScene.OpenGLTokens

TGLUTessBeginProc GLScene.OpenGL4

GLUTessCallback
TGLUTessBeginProc GLScene.OpenGLTokens

TGLUTessCombineDataProc GLScene.OpenGL4

TGLUTessCombineDataProc GLScene.OpenGLTokens

TGLUTessCombineProc GLScene.OpenGL4

TGLUTessCombineProc GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc GLScene.OpenGL4

TGLUTessEdgeFlagDataProc GLScene.OpenGLTokens

TGLUTessEdgeFlagProc GLScene.OpenGL4

TGLUTessEdgeFlagProc GLScene.OpenGLTokens

TGLUTesselatorObj GLScene.OpenGL4

TGLUTesselatorObj GLScene.OpenGLTokens

TGLUTessEndDataProc GLScene.OpenGL4

TGLUTessEndDataProc GLScene.OpenGLTokens

TGLUTessEndProc GLScene.OpenGL4

TGLUTessEndProc GLScene.OpenGLTokens

TGLUTessErrorDataProc GLScene.OpenGL4

TGLUTessErrorDataProc GLScene.OpenGLTokens

TGLUTessErrorProc GLScene.OpenGL4

TGLUTessErrorProc GLScene.OpenGLTokens

TGLUTessVertexDataProc GLScene.OpenGL4

TGLUTessVertexDataProc GLScene.OpenGLTokens

TGLUTessVertexProc GLScene.OpenGL4

TGLUTessVertexProc GLScene.OpenGLTokens

TGLUTriangulatorObj GLScene.OpenGL4

TGLUTriangulatorObj GLScene.OpenGLTokens

TGLvdpauSurfaceNV GLScene.OpenGLTokens

TGLVector GLScene.VectorTypes

TgOnMatricesPush GLScene.PipelineTransform

TgPipelineTransformationState GLScene.PipelineTransform

TgPipelineTransformationStates GLScene.PipelineTransform

TGraphicClass GXS.ImageUtils

TGrowMethod GXS.SpacePartition

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees
TGUIAlignments GXS.Gui

TGUIDrawResult GXS.Gui

TgxAbstractMultitextureCoordinatorClass GXS.Context

TgxAcceptMouseQuery GXS.Windows

TgxActiveAttribArray GXSL.Shader

TgxActorAnimationMode GXS.VectorFileObjects

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control
TgxActorAnimationName GXS.VectorFileObjects

TgxActorAnimationReference GXS.VectorFileObjects

TgxActorFrameInterpolation GXS.VectorFileObjects

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame
TgxActorOption GXS.VectorFileObjects

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.
TgxActorOptions GXS.VectorFileObjects

TgxActorProxyAnimationMode GXS.ProxyObjects

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.
TgxAdvancedBlurImagePrepareEvent GXS.Blur

TgxAFIOCreateFileStream GXS.ApplicationFileIO

TgxAFIOFileStreamEvent GXS.ApplicationFileIO

TgxAFIOFileStreamExists GXS.ApplicationFileIO

TgxAFIOFileStreamExistsEvent GXS.ApplicationFileIO

TgxAlphaFunc GXS.Material

To show up in design-time editor vTGlAlphaFuncValues and vTgxBlendFuncFactorValues arrays if you type smth like af_GL_NEVER = GL_NEVER in the definition.
TgxAnnulusPart GXS.GeomObjects

TgxAnnulusParts GXS.GeomObjects

TgxAntiAliasing GXS.Context

TgxApplicationResource GXS.ApplicationFileIO

TgxArcDirection GXS.Canvas

TgxArrowArcPart GXS.GeomObjects

TgxArrowArcParts GXS.GeomObjects

TgxArrowHeadStyle GXS.GeomObjects

Arrow Head Stacking Style
TgxArrowLinePart GXS.GeomObjects

TgxArrowLineParts GXS.GeomObjects

TgxAsmShaderEvent GXSL.AsmShader

TgxAsmShaderUnUplyEvent GXSL.AsmShader

TgxAtmosphereBlendingMode GXS.Atmosphere

With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big. With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).
TgxBaseArchiveClass GXS.ArchiveManager

TgxBaseImageClass GXS.Graphics

TgxBaseSelectTechniqueClass GXS.Selection

TgxBehaviourClass GXS.Scene

TgxBitmap32 GXS.Graphics

TgxBlendEquation GXS.State

TgxBlendFunction GXS.State

TgxBlendingMode GXS.Material

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TgxBlendingParameters options
TgxBlendingModeEx GXSL.CustomShader

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.
TgxBlurkind GXS.Blur

TgxBlurPreset GXS.Blur

TgxBufferBindingTarget GXS.State

TgxCadencerMode GXS.Cadencer

Determines how the TgxCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.
TgxCadencerTimeReference GXS.Cadencer

Determines which time reference the TgxCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used
TgxCameraInvarianceMode GXS.Scene

TgxCameraJobEvent GXS.CameraController

TgxCameraKeepFOVMode GXS.Scene

TgxCameraStyle GXS.Scene

TgxCapType GXS.Objects

TgxCelShaderGetIntensity GXS.CelShader

An event for user defined cel intensity.
TgxCelShaderGetIntensity GXSL.ShapeShaders

An event for user defined cel intensity.
TgxCelShaderOption GXS.CelShader

Cel shading options. csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.
TgxCelShaderOption GXSL.ShapeShaders

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.
TgxCelShaderOptions GXS.CelShader

TgxCelShaderOptions GXSL.ShapeShaders

TgxColorComponent GXS.State

TSingleCullFaceMode = cmFront..cmBack;
TgxColorDepth GXS.Scene

TgxColorMask GXS.State

TgxCombinerCache GXS.TextureCombiners

TgxComparisonFunction GXS.State

TgxConePart GXS.GeomObjects

TgxConeParts GXS.GeomObjects

TgxConsoleMatchList GXS.Console

TgxConsoleOption GXS.Console

TgxConsoleOptions GXS.Console

remove quotes when a command line is parsed
TgxContextAcceleration GXS.Context

TgxContextClass GXS.Context

TgxContextLayer GXS.Context

TgxContextOption GXS.Scene

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (it needs a stereo device to test...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context
TgxContextOptions GXS.Scene

TgxContourClass GXS.MultiPolygon

TgxCubeMapTarget GXS.Texture

TgxCubePart GXS.Objects

TgxCubeParts GXS.Objects

TgxCullFaceMode GXS.State

TgxCustomRenderEvent GXS.Windows

TgxCyborgOption GXS.SmartObjects

TgxCyborgOptions GXS.SmartObjects

TgxCyborgReference GXS.SmartObjects

TgxCyborgSenceOrgans GXS.SmartObjects

TgxCyborgThinkMode GXS.SmartObjects

TgxCylinderAlignment GXS.GeomObjects

TgxCylinderPart GXS.GeomObjects

TgxCylinderParts GXS.GeomObjects

TgxDataFileCapability GXS.ApplicationFileIO

TgxDataFileClass GXS.ApplicationFileIO

TgxDCECollisionEvent GXS.DCE

TgxDCECollisionSelection GXS.DCE

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)
TgxDCEObjectCollisionEvent GXS.DCE

TgxDCEShape GXS.DCE

Only csEllipsoid can have dynamic behaviour
TgxDCESlideOrBounce GXS.DCE

TgxDDSDetailLevels GXS.FileDDS

TgxDepthCompareFunc GXS.Texture

Specifies the depth comparison function.
TgxDepthFunction GXS.State

TgxDepthPrecision GXS.Scene

TgxDepthTextureMode GXS.Texture

Specifies how depth values should be treated during filtering and texture application
TGXDrawState GXS.RenderContextInfo

TgxDstBlendFunction GXS.State

TgxEffectClass GXS.Scene

TgxEnabledRenderBuffer GXS.FBORenderer

TgxEnabledRenderBuffers GXS.FBORenderer

TgxEProjectedParticleMask GXS.EParticleMasksManager

TgxExtrusionSolidPart GXS.Extrusion

TgxExtrusionSolidParts GXS.Extrusion

TgxFaceCulling GXS.Material

TgxFaceGroupMeshMode GXS.VectorFileObjects

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.
TgxFaceWinding GXS.State

Describe what kind of winding has a front face
TgxFBOClearOption GXS.FBORenderer

TgxFBOClearOptions GXS.FBORenderer

TgxFBOTargetVisibility GXS.FBORenderer

TgxFile3DSAnimKeysClassType GXS.File3DS

Used only for serialization. There probably is a more efficient way to do it.
TgxFlatTextOption GXS.BitmapFont

TgxFlatTextOptions GXS.BitmapFont

TgxFogDistance GXS.Scene

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.
TgxFogMode GXS.Scene

TgxForceType GXS.PhysForces

TgxFormCanClose GXS.Windows

TgxFormCanRequest GXS.Windows

TgxFormCloseOptions GXS.Windows

TgxFormMove GXS.Windows

TgxFormNotify GXS.Windows

TgxFramebufferStatus GXS.Context

TgxGameMenuScale GXS.GameMenu

TgxGizmoAcceptEvent GXS.Gizmo

TgxGizmoAxis GXS.Gizmo

TgxGizmoElement GXS.Gizmo

TgxGizmoElements GXS.Gizmo

TgxGizmoExAcceptEvent GXS.GizmoEx

TgxGizmoExAxis GXS.GizmoEx

TgxGizmoExAxisSelected GXS.GizmoEx

TgxGizmoExOperation GXS.GizmoEx

TgxGizmoExOperationMode GXS.GizmoEx

TgxGizmoExPickMode GXS.GizmoEx

TgxGizmoExReferenceCoordinateSystem GXS.GizmoEx

TgxGizmoExSelectionRegion GXS.GizmoEx

TgxGizmoExSelRec GXS.GizmoEx

TgxGizmoExVisibleInfoLabel GXS.GizmoEx

TgxGizmoExVisibleInfoLabels GXS.GizmoEx

TgxGizmoOperation GXS.Gizmo

TgxGizmoPickMode GXS.Gizmo

TgxGizmoUpdateEvent GXS.Gizmo

TgxGizmoVisibleInfoLabel GXS.Gizmo

TgxGizmoVisibleInfoLabels GXS.Gizmo

TgxgsInTypes GXSL.Parameter

TgxgsOutTypes GXSL.Parameter

TgxGuiComponentName GXS.Gui

TgxGuiElementName GXS.Gui

TgxHeightDataClass GXS.HeightData

TgxHeightDataPostRenderEvent GXS.TerrainRenderer

TgxHeightDataState GXS.HeightData

Possible states for a TgxHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile
TgxHeightDataType GXS.HeightData

Determines the type of data stored in a TgxHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.
TgxHeightFieldColorMode GXS.Graph

TgxHeightFieldGetHeight2Event GXS.Graph

TgxHeightFieldGetHeightEvent GXS.Graph

TgxHeightFieldOption GXS.Graph

TgxHeightFieldOptions GXS.Graph

TgxHintType GXS.State

TgxImageLODRange GXS.Graphics

TgxImagePiramid GXS.Graphics

TgxIsolineState GXS.Isolines

TgxlConsoleEvent GXS.Console

Event called when used presses the "Enter"
TgxLibMaterialName GXS.Material

TgxLightSourceEnum GXSL.CustomShader

TgxLightSourceSet GXSL.CustomShader

TgxLightStyle GXS.Scene

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)
TgxLimitType GXS.Scene

IDs for limit determination
TgxLinesOptions GXS.Objects

TgxLineSplineMode GXS.Objects

Available spline modes for a TLine.
TgxLODStreamingState GXS.Graphics

TgxLogicOp GXS.State

TgxMagFilter GXS.Texture

TgxMapCollectionItemClass GXS.FPSMovement

TgxMaterialLevel GXS.State

TgxMaterialOption GXS.Material

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered
TgxMaterialOptions GXS.Material

TgxMeshAutoCentering GXS.VectorFileObjects

TgxMeshAutoCenterings GXS.VectorFileObjects

TgxMeshNormalsOrientation GXS.VectorFileObjects

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow
TgxMeshObjectListClass GXS.VectorFileObjects

TgxMeshObjectMode GXS.VectorFileObjects

TgxMeshObjectRenderingOption GXS.VectorFileObjects

Rendering options per TgxMeshObject. moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list.
TgxMeshObjectRenderingOptions GXS.VectorFileObjects

TgxMeshPrimitive GXS.State

TgxMeshPrimitives GXS.State

TgxMinFilter GXS.Texture

TgxMouseAction GXS.Windows

TgxMovementRotationMode GXS.Movement

TgxNavigatorSmoothChangeItemClass GXS.SmoothNavigator

TgxNavigatorSmoothChangeSingleGetEvent GXS.SmoothNavigator

TgxNavigatorSmoothChangeSingleSetEvent GXS.SmoothNavigator

TgxNavigatorSmoothChangeVectorGetEvent GXS.SmoothNavigator

TgxNavigatorSmoothChangeVectorSetEvent GXS.SmoothNavigator

TgxNGDCollisions GXS.NGDManager

TgxNGDFrictionModels GXS.NGDManager

TgxNGDJoints GXS.NGDManager

TgxNGDManagerDebug GXS.NGDManager

TgxNGDManagerDebugs GXS.NGDManager

TgxNGDPickedActions GXS.NGDManager

TgxNGDSolverModels GXS.NGDManager

TgxNodesClass GXS.Nodes

TgxNormalDirection GXS.Scene

TgxNormalSmoothing GXS.Objects

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing
TgxObjectBBChange GXS.Scene

TgxObjectBBChanges GXS.Scene

TgxObjectChange GXS.Scene

Used to describe only the changes in an object, which have to be reflected in the scene
TgxObjectChanges GXS.Scene

TgxObjectsSorting GXS.RenderContextInfo

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.
TgxObjectStyle GXS.Scene

Possible styles/options for objects. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered
TgxObjectStyles GXS.Scene

TgxODECollisionEvent GXS.ODEManager

TgxODECollisionSurfaceMode GXS.ODEManager

TgxODECustomCollisionEvent GXS.ODEManager

TgxODEElementClass GXS.ODEManager

TgxODEGetParamCallback GXS.ODEManager

TgxODEObjectCollisionEvent GXS.ODEManager

TgxODESetParamCallback GXS.ODEManager

TgxODESolverMethod GXS.ODEManager

TgxOnCustomPerspective GXS.Scene

TgxOnCustomPostEffectEvent GXSL.PostEffects

TgxOnLightsChanged GXS.State

TgxParticleArray GXS.ParticleFX

TgxParticleClass GXS.ParticleFX

TgxParticleEvent GXS.Particles

TgxPerlinInterpolation GXS.Perlin

TgxPerlinOctav GXS.Perlin

TgxPixel32Array GXS.Graphics

TgxPlaneStyle GXS.Objects

TgxPlaneStyles GXS.Objects

TgxPointStyle GXS.Objects

TgxPolygonMode GXS.State

TgxPolygonPart GXS.GeomObjects

TgxPolygonParts GXS.GeomObjects

TgxPopupMenuClick GXS.Windows

TgxPostEffectBuffer GXSL.PostEffects

TgxPostEffectPreset GXSL.PostEffects

Some presets for TgxPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.
TgxProjectedTexturesStyle GXS.ProjectedTextures

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).
TgxProxyObjectClass GXS.Scene

TgxProxyObjectOption GXS.Scene

Defines which features are taken from the master object.
TgxProxyObjectOptions GXS.Scene

TgxQueryType GXS.State

TgxRCOption GXS.Context

TgxRCOptions GXS.Context

TgxResourceStream GXS.ApplicationFileIO

TgxResourceType GXS.CUDA.API

TgxRevolutionSolidPart GXS.Extrusion

TgxRevolutionSolidParts GXS.Extrusion

TgxSceneObjectClass GXS.Scene

TgxSceneOperation GXS.Scene

Flags for design notification
TgxSceneViewerMode GXS.Scene

TgxScreenDepth GXS.FullScreenViewer

TgxScriptState GXS.ScriptBase

TgxSCUDACompilerOutput GXS.CUDA.Compiler

TgxSCUDARealArch GXS.CUDA.Compiler

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown
TgxSCUDARealArchs GXS.CUDA.Compiler

TgxSCUDAVirtArch GXS.CUDA.Compiler

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support
TgxSDLEvent SDLx.Window

TgxSDLWindowOption SDLx.Window

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)
TgxSDLWindowOptions SDLx.Window

TgxSDLWindowPixelDepth SDLx.Window

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)
TgxShadeModel GXS.Scene

float_type
TgxShaderClass GXS.Material

TgxShaderCombinerType GXSL.ShaderCombiner

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.

sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.
TgxShaderEvent GXSL.CustomShader

TgxShaderFailedInitAction GXS.Material

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)
TgxShaderFogSupport GXSL.CustomShader

TgxShaderHandleClass GXS.Context

TgxShaderStyle GXS.Material

Define VXShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)
TgxShaderUnAplyEvent GXSL.CustomShader

TgxShadowCastingMode GXS.ShadowVolume

Determines when a caster should actually produce a shadow;

scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)
TgxShadowVolumeCapping GXS.ShadowVolume

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.

svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps
TgxShadowVolumeMode GXS.ShadowVolume

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place
TgxShadowVolumeOption GXS.ShadowVolume

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface
TgxShadowVolumeOptions GXS.ShadowVolume

TgxShininess GXS.Material

TgxSilhouetteStyle GXS.Silhouette

TgxSimpleNavigationAction GXS.SimpleNavigation

TgxSimpleNavigationOption GXS.SimpleNavigation

TgxSimpleNavigationOptions GXS.SimpleNavigation

Show FPS
TgxSkeletonFrameTransform GXS.VectorFileObjects

TgxSkyBoxStyle GXS.Skydome

————————- SkyBox class ————————-
TgxSkyDomeOption GXS.Skydome

TgxSkyDomeOptions GXS.Skydome

TgxSLDataType GXSL.Parameter

TGXSLDataType GXSL.ShaderParameter

TGXSLInTypes GXSL.ShaderParameter

TGXSLOutTypes GXSL.ShaderParameter

TgxslProjectedTexturesStyle GXSL.ProjectedTextures

TgxSLSamplerType GXSL.Parameter

TGXSLSamplerType GXSL.ShaderParameter

TGXSLShaderEvent GXSL.Shader

TGXSLShaderEventEx GXSL.Shader

TGXSLShaderUnApplyEvent GXSL.Shader

TgxSmartSwarmMode GXS.SmartObjects

TgxSoundEnvironment GXS.SoundManager

EAX standard sound environments
TgxSoundFileClass GXS.SoundFileObjects

TgxSoundSourceChange GXS.SoundManager

TgxSoundSourceChanges GXS.SoundManager

TgxSourcePFXDispersionMode GXS.ParticleFX

TgxSourcePFXPositionMode GXS.ParticleFX

TgxSourcePFXVelocityMode GXS.ParticleFX

TgxSpaceTextCharRange GXS.SpaceText

TgxSpriteAnimationMode GXS.AnimatedSprite

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.
TgxSpriteFrameDimensions GXS.AnimatedSprite

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.
TgxState GXS.State

Reflects all relevant (binary) states of OpenGL subsystem
TgxStates GXS.State

TgxStateType GXS.State

TgxStateTypes GXS.State

TgxStencilFunction GXS.State

TgxStencilOp GXS.State

TgxStencilPrecision GXS.FBO

TgxStiffnessSetVH GXS.VerletTypes

TgxStiffnessVH GXS.VerletTypes

TgxSurfaceModes GXS.ODEManager

TgxSyncMode GXS.Context

TgxTaskProcedure GXS.Context

TgxTerrainHighResStyle GXS.TerrainRenderer

TgxTerrainOcclusionTesselate GXS.TerrainRenderer

TgxTextHorzAdjust GXS.SpaceText

Note: haAligned, haCentrically, haFitIn have not been implemented!
TgxTextLayout GXS.ImageUtils

in vcl class of TGraphic
TgxTextureArray GXS.FBORenderer

TgxTextureChange GXS.Texture

TgxTextureChanges GXS.Texture

TgxTextureCompression GXS.Texture

TgxTextureFormat GXS.Texture

Texture format for OpenGL (rendering) use. Internally, GLXScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:
TgxTextureImageAlpha GXS.Texture

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.
TgxTextureImageClass GXS.Texture

TgxTextureImageEditorClass GXS.TextureImageEditors

TgxTextureMappingMode GXS.Texture

TgxTextureMode GXS.Texture

TgxTextureNeededEvent GXS.Texture

TgxTextureWrap GXS.Texture

TgxTextVertAdjust GXS.SpaceText

TgxTileManagementFlag GXS.TerrainRenderer

TgxTileManagementFlags GXS.TerrainRenderer

TgxTimeEventProc GXS.TimeEventsMgr

TgxTimeEventType GXS.TimeEventsMgr

TgxTorusPart GXS.GeomObjects

TgxTorusParts GXS.GeomObjects

TgxTouchEvent GXS.SceneViewer

TgxTransformFeedBackMode GXSL.CustomShader

TgxVectorFileClass GXS.VectorFileObjects

TgxVerletHeightFieldOnNeedHeight GXS.VerletTypes

TgxVerletNodeClass GXS.VerletTypes

TgxVertexBoneWeightArray GXS.VectorFileObjects

TgxVertexBoneWeightDynArray GXS.VectorFileObjects

TgxVertexDataArray GXS.Mesh

TgxVerticesBoneWeights GXS.VectorFileObjects

TgxVirtualHandleEvent GXS.Context

TgxVisibilityCulling GXS.RenderContextInfo

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).
TgxVisibilityDeterminationEvent GXS.Objects

TgxWaterPlaneOption GXS.WaterPlane

GL_EXT_compiled_vertex_array
TgxWaterPlaneOptions GXS.WaterPlane

TgxWindowAttribute GXS.Screen

window attributes
TgxWindowAttributes GXS.Screen

TgxWindowFitting GXS.Screen

window-to-screen fitting
THalfFloat GLScene.Utils

THDTextureCoordinatesMode GXS.HeightData

THmgPlane GLScene.VectorGeometry

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation
THomogeneousByteMatrix GLScene.VectorGeometry

Matrices
THomogeneousByteVector GLScene.VectorGeometry

THomogeneousDblMatrix GLScene.VectorGeometry

THomogeneousDblVector GLScene.VectorGeometry

THomogeneousExtMatrix GLScene.VectorGeometry

THomogeneousExtVector GLScene.VectorGeometry

THomogeneousFltMatrix GLScene.VectorGeometry

THomogeneousFltVector GLScene.VectorGeometry

THomogeneousIntMatrix GLScene.VectorGeometry

THomogeneousIntVector GLScene.VectorGeometry

THomogeneousMatrix GLScene.VectorGeometry

THomogeneousPtrVector GLScene.VectorGeometry

THomogeneousVector GLScene.VectorGeometry

THomogeneousWordMatrix GLScene.VectorGeometry

THomogeneousWordVector GLScene.VectorGeometry

TIDELogProc GLScene.Logger

TIdleEvent GXS.AsyncHDS

TImageAlphaProc GXS.ImageUtils

TImageFilterFunction GXS.ImageUtils

TImposterLoadedEvent GXS.Imposter

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter; var result : TgxBitmap32) of object;
TImposterOption GXS.Imposter

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing
TImposterOptions GXS.Imposter

TImposterReference GXS.Imposter

TInfoLabelCoordType GXS.GizmoEx

TInstPropList FMxXCollectionEditor

TIntegerArray GLScene.VectorTypesExt

Extended may be replaced with BigDecimals
TIntegerArray GXS.HeightTileFile

TIntegerClamp GXS.RandomHDS

TIntegerVector GLScene.VectorGeometry

TIntermediateFormatArray GXS.ImageUtils

TInvokeInfoForm GXS.Scene

TIsDefaultTile GXS.RandomHDS

TJointOption GXS.ODEManager

TJointOptions GXS.ODEManager

TJoyAxis GXS.Joystick

TJoyPos GXS.Joystick

TJoystickButton GXS.Joystick

TJoystickButtons GXS.Joystick

TJoystickDesignMode GXS.Joystick

TJoystickEvent GXS.Joystick

TJoystickID GXS.Joystick

TKeyboardType uGBEOptionsUtils

TLandTile GXS.RandomHDS

TMapOfLandscapes :array of array of TgxBaseRandomHDS;
TLineNodesAspect GXS.Objects

Possible aspects for the nodes of a TLine.
TLinesOption GXS.Objects

TLoadingImposterEvent GXS.Imposter

Imposter loading events
TLogBufferingMode GLScene.Logger

How log is buffered.
TLogLevel GLScene.Logger

Levels of importance of log messages
TLogLevels GLScene.Logger

Log level setting type
TLogMessageLimitAction GLScene.Logger

What to do when number of messages exceeds message limit.
TLogTimeFormat GLScene.Logger

Log date and time setting type
TLongWordVector GLScene.VectorGeometry

TMapOfSingle GXS.RandomHDS

TMapOfVector GXS.RandomHDS

TMapTexCoordMode GXS.XOpenGL

TMarkDirtyEvent GXS.HeightData

TMarkStyle GXS.Trail

TMatrix2DArray GLScene.VectorTypesExt

Matrix Arrays
TMatrix2DType GLScene.VectorTypesExt

———————– Matrix types ———————–
TMatrix3DArray GLScene.VectorTypesExt

TMatrix3DType GLScene.VectorTypesExt

TMatrixArr GXS.Isolines

TMatrixArray GLScene.VectorGeometry

Some simplified names
TMatrixExt GLScene.VectorTypesExt

TMaxCLODTrianglesReachedEvent GXS.TerrainRenderer

TMDCAngle GXS.FileMDC

TMDCBaseVertex GXS.FileMDC

TMDCCompVertex GXS.FileMDC

TMDCPoint GXS.FileMDC

3/64;
TMDCTexCoord GXS.FileMDC

TMDCTriangle GXS.FileMDC

TMesh2DArray GLScene.VectorTypesExt

TMesh3DArray GLScene.VectorTypesExt

TMeshMode GXS.Mesh

wglAllocateMemoryNV
TMeshOptimizerOption GXS.MeshOptimizer

TMeshOptimizerOptions GXS.MeshOptimizer

TMirrorOption GXS.Mirror

TMirrorOptions GXS.Mirror

TMirrorShapes GXS.Mirror

TMS3DJointArray GXS.FileMS3D

TMS3DKeyframePositionArray GXS.FileMS3D

TMS3DKeyframeRotationArray GXS.FileMS3D

TMS3DTriangleArray GXS.FileMS3D

TMS3DVertexArray GXS.FileMS3D

TNewTilePreparedEvent GXS.AsyncHDS

TNewTilePreparedEvent GXS.BumpmapHDS

TNewTilePreparedEvent GXS.ShadowHDS

TNormalMapSpace GXS.BumpMapping

TObjectCollisionEvent GXS.Collision

TOnBeforeKernelLaunch GXS.CUDA.Graphics

TOnCreateLandTile GXS.RandomHDS

TOnCustomForce GXS.PhysForces

TOnDoApplyEvent GXSL.UserShader

TOnDoUnApplyEvent GXSL.UserShader

TOnDrawTexture GXS.RandomHDS

Function type to use for topography-based texture
TOnHeightDataDirtyEvent GXS.HeightData

TOnOpenGLInteropInit GXS.CUDA.Context

TOnPrepareHandleData GXS.Context

TOptimise GXS.zBuffer

TPackedRotationMatrix GLScene.VectorGeometry

TParametricSurfaceBasis GXS.ParametricSurfaces

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.
TParametricSurfaceRenderer GXS.ParametricSurfaces

psrGLXcene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenVX uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.
TParticleReferenceArray GXS.ParticleFX

TPatchPostRenderEvent GXS.TerrainRenderer

TPathTravelStartEvent GXS.Movement

Event for path related event
TPathTravelStopEvent GXS.Movement

TPFXCreateParticleEvent GXS.ParticleFX

TPFXDirectRenderEvent GXS.ParticleFX

TPFXGetParticleCountEvent GXS.ParticleFX

TPFXParticleProgress GXS.ParticleFX

TPFXPrepareTextureImageEvent GXS.ParticleFX

TPFXProgressEvent GXS.ParticleFX

TPFXSortAccuracy GXS.ParticleFX

TPickSortType GXS.Selection

TPickSubObjects GXS.Selection

TPipeNodesColorMode GXS.Extrusion

TPipeNormalMode GXS.Extrusion

TPipePart GXS.Extrusion

TPipeParts GXS.Extrusion

TPipeTexCoordMode GXS.Extrusion

TPlanBB GLScene.GeometryBB

TPlanIndices GLScene.GeometryBB

TPoint2DArray GLScene.VectorTypesExt

TPoint3DArray GLScene.VectorTypesExt

TPointerArray GXS.ImageUtils

TPointerVector GLScene.VectorGeometry

TPointF_Array omSailSurface

————————————————————————– Sail construction params

ˆ h ˆ h ˆ h | Main | Simetric | Jib Ht +—-+ Ht +—+ Lt Ht +—+ | Lt \ / | \ |Lt \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ +———–+ +—————–+ +———-+ | Lm \ / | Lm \ | Lm \ | | | | | | \ | \ | | | | Lx \ | | \ | / Hx +————–+ <– h of max chord | \ | | | | ____/ 0 | Lb | | 0 | Lb | 0 | ____/ —-+————–+–> L -+——–+——–+–> L —-+___/————-> L Lb nh subdivisions in height nl subdivisions in chord —————————————————————————
TPolygon2D GLScene.VectorTypesExt

———————– Polygon types ———————–
TPolygon3D GLScene.VectorTypesExt

TPolyhedronArray GLScene.VectorTypesExt

———————– Polyhedron types ———————–
TPrecisionSetting GXS.CgShader

TProcAffineAffineAffine GXS.Octree

TProcInt GXS.Octree

TProjectTargetNameFunc GLScene.Utils

TPropertyAttribute GXS.RegisterXCollection

DesignIntf, DesignEditors,
TPropertyAttributes GXS.RegisterXCollection

TQuatArray GLScene.VectorTypesExt

TQuaternionArray GLScene.VectorGeometry

TRandomGenFunction GLScene.RandomLib

Used for passing Random Number Generators
TRBColor GLScene.RedBlackTree

TRCOptions GLScene.OpenGL4

TResolution GXS.Screen

TRGBPixelBuffer GXS.Blur

TSailShape omSailSurface

TScalarField GLScene.VectorTypesExt

TScalarFieldInt GLScene.VectorTypesExt

if data are made on integer XYZ index may be replaced with BigIntegers
TScalarValue GLScene.VectorTypesExt

———————– Point types ———————–
TScreenSaverOption GXS.ScreenSaver

Options of screen-saver.

ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). - ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) - ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) - ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)
TScreenSaverOptions GXS.ScreenSaver

TScreenSaverPreviewEvent GXS.ScreenSaver

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).
TSectorNodeArray GXS.SpacePartition

TSerializeEvent GXS.NGDManager

TSetTextureTargetsEvent GXS.FBORenderer

TSetTransformEvent GXS.NGDManager

TShadowPlaneOption GXS.ShadowPlane

TShadowPlaneOptions GXS.ShadowPlane

TShortIntArray GXS.HeightTileFile

TSIBLigthing GXS.Imposter

TSimpleNavigationCustomActionEvent GXS.SimpleNavigation

TSingleArray GLScene.VectorGeometry

TSingleClamp GXS.RandomHDS

TSingleRaster GXS.HeightData

TSmallintArray GXS.HeightData

TSmallIntArray GXS.HeightTileFile

TSmallIntRaster GXS.HeightData

TSourceDataFetchedEvent GXS.HeightData

TSpaceContains GLScene.GeometryBB

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB
TSpecularMode GXSL.BumpShaders

TSpheroid GBE.SphereExtend

TSpriteColorMode GXS.ParticleFX

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored).
TSpritesPerTexture GXS.ParticleFX

Sprites per sprite texture for the SpritePFX.
TSqrt255Array GLScene.Utils

TStartPreparingDataEvent GXS.HeightData

TStateArray GXS.PhysManager

TDESolver = procedure((*RigidBody:TgxRigidBody;*)DeltaTime:Real) of object;
TSTLVertex GXS.FileSTL

TSubdivideEdgeEvent GXS.MeshUtils

TTexPointArray GLScene.VectorGeometry

TThorpointArray GXS.ThorFX

TThreadBmp32 GXS.ShadowHDS

TTransformations GLScene.VectorGeometry

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)
TTransType GLScene.VectorGeometry

TTriangleRecArray GLScene.VectorTypesExt

TU48BitBlock GXS.ImageUtils

TUniformAutoSetMethod GXSL.Parameter

TUniformAutoSetMethod GXSL.ShaderParameter

TUpdateSpacePartion GXS.VerletTypes

TUseDirtyTiles GXS.AsyncHDS

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)
TVBOBuffer GXS.VectorFileObjects

TVBOBuffers GXS.VectorFileObjects

TVector2DArray GLScene.VectorTypesExt

Vector Arrays
TVector2DType GLScene.VectorTypesExt

———————– Vector types ———————–
TVector3DArray GLScene.VectorTypesExt

TVector3DType GLScene.VectorTypesExt

TVector4p GLScene.OpenGL4

TVectorArr GXS.Isolines

TVectorArray GLScene.VectorGeometry

TVectorExt GLScene.VectorTypesExt

TVectorL4D GXS.Isolines

TVectorL4I GXS.Isolines

TVertArray GLScene.VectorTypesExt

TVertex GLScene.VectorGeometry

TVertex2DArr GXS.Isolines

TVertexArray GLScene.VectorTypesExt

TVertexMode GXS.Mesh

TVirtualKeyCode GLScene.Keyboard

TVoxelData GLScene.VectorTypesExt

TVoxelStatus GLScene.VectorTypesExt

Voxel types
TWGLSwap GLScene.OpenGL4

TWGLswap GLScene.OpenGLTokens

TWordVector GLScene.VectorGeometry

TXCollectionItemClass GLScene.XCollection

TXYZGridLinesStyle GXS.Graph

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.
TXYZGridPart GXS.Graph

TXYZGridParts GXS.Graph

TZArray GXS.zBuffer

TZArrayIdx GXS.zBuffer

WGLSWAP GLScene.OpenGL4

WGLSWAP GLScene.OpenGLTokens


GXSysHelp v.2.5: All Variables

All Variables

Name Unit Description
BinormalAttributeName GXS.Objects

BitmapDataCanalBleu uGBEImageUtils

BitmapDataCanalNoir uGBEImageUtils

BitmapDataCanalRouge uGBEImageUtils

BitmapDataCanalVert uGBEImageUtils

CUDAEditorForm FMxCUDAEditor

Debug_tri GXS.EllipseCollision

.$DEFINE DEBUG
FMUSIC_FreeSong GXS.Sounds.FMOD

FMUSIC_GetBPM GXS.Sounds.FMOD

FMUSIC_GetGlobalVolume GXS.Sounds.FMOD

FMUSIC_GetMasterVolume GXS.Sounds.FMOD

FMUSIC_GetName GXS.Sounds.FMOD

Static song information functions.
FMUSIC_GetNumChannels GXS.Sounds.FMOD

FMUSIC_GetNumInstruments GXS.Sounds.FMOD

FMUSIC_GetNumOrders GXS.Sounds.FMOD

FMUSIC_GetNumPatterns GXS.Sounds.FMOD

FMUSIC_GetNumSamples GXS.Sounds.FMOD

FMUSIC_GetOpenState GXS.Sounds.FMOD

FMUSIC_GetOrder GXS.Sounds.FMOD

FMUSIC_GetPattern GXS.Sounds.FMOD

FMUSIC_GetPatternLength GXS.Sounds.FMOD

FMUSIC_GetPaused GXS.Sounds.FMOD

FMUSIC_GetRealChannel GXS.Sounds.FMOD

FMUSIC_GetRow GXS.Sounds.FMOD

FMUSIC_GetSample GXS.Sounds.FMOD

FMUSIC_GetSpeed GXS.Sounds.FMOD

FMUSIC_GetTime GXS.Sounds.FMOD

FMUSIC_GetType GXS.Sounds.FMOD

FMUSIC_GetUserData GXS.Sounds.FMOD

FMUSIC_IsFinished GXS.Sounds.FMOD

Runtime song information.
FMUSIC_IsPlaying GXS.Sounds.FMOD

FMUSIC_LoadSong GXS.Sounds.FMOD

Song management / playback functions.
FMUSIC_LoadSongEx GXS.Sounds.FMOD

FMUSIC_OptimizeChannels GXS.Sounds.FMOD

FMUSIC_PlaySong GXS.Sounds.FMOD

FMUSIC_SetInstCallback GXS.Sounds.FMOD

FMUSIC_SetLooping GXS.Sounds.FMOD

FMUSIC_SetMasterSpeed GXS.Sounds.FMOD

FMUSIC_SetMasterVolume GXS.Sounds.FMOD

FMUSIC_SetOrder GXS.Sounds.FMOD

FMUSIC_SetOrderCallback GXS.Sounds.FMOD

FMUSIC_SetPanSeperation GXS.Sounds.FMOD

FMUSIC_SetPaused GXS.Sounds.FMOD

FMUSIC_SetReverb GXS.Sounds.FMOD

Runtime song functions.
FMUSIC_SetRowCallback GXS.Sounds.FMOD

FMUSIC_SetSample GXS.Sounds.FMOD

FMUSIC_SetUserData GXS.Sounds.FMOD

FMUSIC_SetZxxCallback GXS.Sounds.FMOD

FMUSIC_StopAllSongs GXS.Sounds.FMOD

FMUSIC_StopSong GXS.Sounds.FMOD

FSOUND_3D_GetAttributes GXS.Sounds.FMOD

FSOUND_3D_GetMinMaxDistance GXS.Sounds.FMOD

FSOUND_3D_Listener_GetAttributes GXS.Sounds.FMOD

FSOUND_3D_Listener_SetAttributes GXS.Sounds.FMOD

FSOUND_3D_Listener_SetCurrent GXS.Sounds.FMOD

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.
FSOUND_3D_SetAttributes GXS.Sounds.FMOD

FSOUND_3D_SetDistanceFactor GXS.Sounds.FMOD

FSOUND_3D_SetDopplerFactor GXS.Sounds.FMOD

FSOUND_3D_SetMinMaxDistance GXS.Sounds.FMOD

FSOUND_3D_SetRolloffFactor GXS.Sounds.FMOD

FSOUND_CD_GetNumTracks GXS.Sounds.FMOD

FSOUND_CD_GetPaused GXS.Sounds.FMOD

FSOUND_CD_GetTrack GXS.Sounds.FMOD

FSOUND_CD_GetTrackLength GXS.Sounds.FMOD

FSOUND_CD_GetTrackTime GXS.Sounds.FMOD

FSOUND_CD_GetVolume GXS.Sounds.FMOD

FSOUND_CD_OpenTray GXS.Sounds.FMOD

FSOUND_CD_Play GXS.Sounds.FMOD

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.
FSOUND_CD_SetPaused GXS.Sounds.FMOD

FSOUND_CD_SetPlayMode GXS.Sounds.FMOD

FSOUND_CD_SetTrackTime GXS.Sounds.FMOD

FSOUND_CD_SetVolume GXS.Sounds.FMOD

FSOUND_CD_Stop GXS.Sounds.FMOD

FSOUND_Close GXS.Sounds.FMOD

FSOUND_DSP_ClearMixBuffer GXS.Sounds.FMOD

FSOUND_DSP_Create GXS.Sounds.FMOD

DSP Unit control and information functions.
FSOUND_DSP_Free GXS.Sounds.FMOD

FSOUND_DSP_GetActive GXS.Sounds.FMOD

FSOUND_DSP_GetBufferLength GXS.Sounds.FMOD

FSOUND_DSP_GetBufferLengthTotal GXS.Sounds.FMOD

Length of each DSP update
FSOUND_DSP_GetClearUnit GXS.Sounds.FMOD

Functions to get hold of FSOUND 'system DSP unit' handles.
FSOUND_DSP_GetClipAndCopyUnit GXS.Sounds.FMOD

FSOUND_DSP_GetFFTUnit GXS.Sounds.FMOD

FSOUND_DSP_GetMusicUnit GXS.Sounds.FMOD

FSOUND_DSP_GetPriority GXS.Sounds.FMOD

FSOUND_DSP_GetSFXUnit GXS.Sounds.FMOD

FSOUND_DSP_GetSpectrum GXS.Sounds.FMOD

Total buffer length due to FSOUND_SetBufferSize
FSOUND_DSP_MixBuffers GXS.Sounds.FMOD

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.
FSOUND_DSP_SetActive GXS.Sounds.FMOD

FSOUND_DSP_SetPriority GXS.Sounds.FMOD

FSOUND_File_SetCallbacks GXS.Sounds.FMOD

FSOUND_FX_Disable GXS.Sounds.FMOD

Set bits to enable following fx
FSOUND_FX_Enable GXS.Sounds.FMOD

Functions to control DX8 only effects processing.

- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - Stopping or starting a sound resets all FX and they must be re-enabled each time if this happens.
FSOUND_FX_SetChorus GXS.Sounds.FMOD

FSOUND_FX_SetCompressor GXS.Sounds.FMOD

FSOUND_FX_SetDistortion GXS.Sounds.FMOD

FSOUND_FX_SetEcho GXS.Sounds.FMOD

FSOUND_FX_SetFlanger GXS.Sounds.FMOD

FSOUND_FX_SetGargle GXS.Sounds.FMOD

FSOUND_FX_SetI3DL2Reverb GXS.Sounds.FMOD

FSOUND_FX_SetParamEQ GXS.Sounds.FMOD

FSOUND_FX_SetWavesReverb GXS.Sounds.FMOD

FSOUND_GetAmplitude GXS.Sounds.FMOD

FSOUND_GetChannelsPlaying GXS.Sounds.FMOD

FSOUND_GetCPUUsage GXS.Sounds.FMOD

FSOUND_GetCurrentLevels GXS.Sounds.FMOD

FSOUND_GetCurrentPosition GXS.Sounds.FMOD

FSOUND_GetCurrentSample GXS.Sounds.FMOD

FSOUND_GetDriver GXS.Sounds.FMOD

FSOUND_GetDriverCaps GXS.Sounds.FMOD

FSOUND_GetDriverName GXS.Sounds.FMOD

FSOUND_GetError GXS.Sounds.FMOD

System information functions
FSOUND_GetFrequency GXS.Sounds.FMOD

FSOUND_GetLoopMode GXS.Sounds.FMOD

FSOUND_GetMaxChannels GXS.Sounds.FMOD

FSOUND_GetMaxSamples GXS.Sounds.FMOD

FSOUND_GetMemoryStats GXS.Sounds.FMOD

FSOUND_GetMixer GXS.Sounds.FMOD

FSOUND_GetMute GXS.Sounds.FMOD

FSOUND_GetNumDrivers GXS.Sounds.FMOD

FSOUND_GetNumHWChannels GXS.Sounds.FMOD

FSOUND_GetNumSubChannels GXS.Sounds.FMOD

FSOUND_GetOutput GXS.Sounds.FMOD

FSOUND_GetOutputHandle GXS.Sounds.FMOD

FSOUND_GetOutputRate GXS.Sounds.FMOD

FSOUND_GetPan GXS.Sounds.FMOD

FSOUND_GetPaused GXS.Sounds.FMOD

FSOUND_GetPriority GXS.Sounds.FMOD

FSOUND_GetReserved GXS.Sounds.FMOD

FSOUND_GetSFXMasterVolume GXS.Sounds.FMOD

FSOUND_GetSpeakerMode GXS.Sounds.FMOD

FSOUND_GetSubChannel GXS.Sounds.FMOD

FSOUND_GetSurround GXS.Sounds.FMOD

FSOUND_GetVersion GXS.Sounds.FMOD

FSOUND_GetVolume GXS.Sounds.FMOD

FSOUND_Init GXS.Sounds.FMOD

Main initialization / closedown functions Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)
FSOUND_IsPlaying GXS.Sounds.FMOD

Channel information functions
FSOUND_PlaySound GXS.Sounds.FMOD

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!
FSOUND_PlaySoundEx GXS.Sounds.FMOD

FSOUND_Record_GetDriver GXS.Sounds.FMOD

FSOUND_Record_GetDriverName GXS.Sounds.FMOD

FSOUND_Record_GetNumDrivers GXS.Sounds.FMOD

FSOUND_Record_GetPosition GXS.Sounds.FMOD

FSOUND_Record_SetDriver GXS.Sounds.FMOD

Recording initialization functions
FSOUND_Record_StartSample GXS.Sounds.FMOD

Recording functionality. Only one recording session will work at a time.
FSOUND_Record_Stop GXS.Sounds.FMOD

FSOUND_Reverb_GetChannelProperties GXS.Sounds.FMOD

FSOUND_Reverb_GetProperties GXS.Sounds.FMOD

FSOUND_Reverb_SetChannelProperties GXS.Sounds.FMOD

FSOUND_Reverb_SetProperties GXS.Sounds.FMOD

See structures above for definitions and information on the reverb parameters.
FSOUND_Sample_Alloc GXS.Sounds.FMOD

FSOUND_Sample_Free GXS.Sounds.FMOD

FSOUND_Sample_Get GXS.Sounds.FMOD

Sample information functions
FSOUND_Sample_GetDefaults GXS.Sounds.FMOD

FSOUND_Sample_GetDefaultsEx GXS.Sounds.FMOD

FSOUND_Sample_GetLength GXS.Sounds.FMOD

FSOUND_Sample_GetLoopPoints GXS.Sounds.FMOD

FSOUND_Sample_GetMinMaxDistance GXS.Sounds.FMOD

FSOUND_Sample_GetMode GXS.Sounds.FMOD

FSOUND_Sample_GetName GXS.Sounds.FMOD

FSOUND_Sample_Load GXS.Sounds.FMOD

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.
FSOUND_Sample_Lock GXS.Sounds.FMOD

FSOUND_Sample_SetDefaults GXS.Sounds.FMOD

FSOUND_Sample_SetDefaultsEx GXS.Sounds.FMOD

FSOUND_Sample_SetLoopPoints GXS.Sounds.FMOD

FSOUND_Sample_SetMaxPlaybacks GXS.Sounds.FMOD

FSOUND_Sample_SetMinMaxDistance GXS.Sounds.FMOD

FSOUND_Sample_SetMode GXS.Sounds.FMOD

Sample control functions
FSOUND_Sample_Unlock GXS.Sounds.FMOD

FSOUND_Sample_Upload GXS.Sounds.FMOD

FSOUND_SetBufferSize GXS.Sounds.FMOD

FSOUND_SetCurrentPosition GXS.Sounds.FMOD

FSOUND_SetDriver GXS.Sounds.FMOD

FSOUND_SetFrequency GXS.Sounds.FMOD

Functions to control playback of a channel.
FSOUND_SetHWND GXS.Sounds.FMOD

FSOUND_SetLoopMode GXS.Sounds.FMOD

FSOUND_SetMaxHardwareChannels GXS.Sounds.FMOD

FSOUND_SetMemorySystem GXS.Sounds.FMOD

FSOUND_SetMinHardwareChannels GXS.Sounds.FMOD

FSOUND_SetMixer GXS.Sounds.FMOD

FSOUND_SetMute GXS.Sounds.FMOD

FSOUND_SetOutput GXS.Sounds.FMOD

Pre FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.
FSOUND_SetPan GXS.Sounds.FMOD

FSOUND_SetPanSeperation GXS.Sounds.FMOD

FSOUND_SetPaused GXS.Sounds.FMOD

FSOUND_SetPriority GXS.Sounds.FMOD

FSOUND_SetReserved GXS.Sounds.FMOD

FSOUND_SetSFXMasterVolume GXS.Sounds.FMOD

FSOUND_SetSpeakerMode GXS.Sounds.FMOD

This is called to update 3d sound / non-realtime output
FSOUND_SetSurround GXS.Sounds.FMOD

FSOUND_SetVolume GXS.Sounds.FMOD

FSOUND_SetVolumeAbsolute GXS.Sounds.FMOD

FSOUND_StopSound GXS.Sounds.FMOD

FSOUND_Stream_AddSyncPoint GXS.Sounds.FMOD

FSOUND_Stream_Close GXS.Sounds.FMOD

FSOUND_Stream_Create GXS.Sounds.FMOD

FSOUND_Stream_CreateDSP GXS.Sounds.FMOD

Every stream contains a sample to play back on
FSOUND_Stream_DeleteSyncPoint GXS.Sounds.FMOD

FSOUND_Stream_FindTagField GXS.Sounds.FMOD

FSOUND_Stream_GetLength GXS.Sounds.FMOD

FSOUND_Stream_GetLengthMs GXS.Sounds.FMOD

FSOUND_Stream_GetMode GXS.Sounds.FMOD

FSOUND_Stream_GetNumSubStreams GXS.Sounds.FMOD

FSOUND_Stream_GetNumSyncPoints GXS.Sounds.FMOD

FSOUND_Stream_GetNumTagFields GXS.Sounds.FMOD

FSOUND_Stream_GetOpenState GXS.Sounds.FMOD

FSOUND_Stream_GetPosition GXS.Sounds.FMOD

FSOUND_Stream_GetSample GXS.Sounds.FMOD

FSOUND_Stream_GetSyncPoint GXS.Sounds.FMOD

FSOUND_Stream_GetSyncPointInfo GXS.Sounds.FMOD

FSOUND_Stream_GetTagField GXS.Sounds.FMOD

FSOUND_Stream_GetTime GXS.Sounds.FMOD

FSOUND_Stream_Net_GetBufferProperties GXS.Sounds.FMOD

FSOUND_Stream_Net_GetLastServerStatus GXS.Sounds.FMOD

FSOUND_Stream_Net_GetStatus GXS.Sounds.FMOD

FSOUND_Stream_Net_SetBufferProperties GXS.Sounds.FMOD

FSOUND_Stream_Net_SetMetadataCallback GXS.Sounds.FMOD

FSOUND_Stream_Net_SetProxy GXS.Sounds.FMOD

FSOUND_Stream_Open GXS.Sounds.FMOD

FSOUND_Stream_Play GXS.Sounds.FMOD

FSOUND_Stream_PlayEx GXS.Sounds.FMOD

FSOUND_Stream_SetBufferSize GXS.Sounds.FMOD

call this before opening streams, not after
FSOUND_Stream_SetEndCallback GXS.Sounds.FMOD

FSOUND_Stream_SetLoopCount GXS.Sounds.FMOD

FSOUND_Stream_SetLoopPoints GXS.Sounds.FMOD

FSOUND_Stream_SetMode GXS.Sounds.FMOD

FSOUND_Stream_SetPosition GXS.Sounds.FMOD

FSOUND_Stream_SetSubStream GXS.Sounds.FMOD

FSOUND_Stream_SetSubStreamSentence GXS.Sounds.FMOD

FSOUND_Stream_SetSyncCallback GXS.Sounds.FMOD

FSOUND_Stream_SetTime GXS.Sounds.FMOD

FSOUND_Stream_Stop GXS.Sounds.FMOD

FSOUND_Update GXS.Sounds.FMOD

Runtime system level functions
glActiveStencilFaceEXT GLScene.OpenGL4

GL_EXT_stencil_two_side (EXT #268)
glActiveTexture GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)
glActiveTextureARB GLScene.OpenGL4

GL_ARB_multitexture (ARB #1)
glActiveVaryingNV GLScene.OpenGL4

glAddSwapHintRectWIN GLScene.OpenGL4

GL_WIN_swap_hint (extension # not found)
glAreProgramsResidentNV GLScene.OpenGL4

GL_NV_vertex_program (EXT #233)
glAreTexturesResidentEXT GLScene.OpenGL4

glArrayElementArrayEXT GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions
glAttachObjectARB GLScene.OpenGL4

glAttachShader GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)
glBeginConditionalRender GLScene.OpenGL4

glBeginConditionalRenderNV GLScene.OpenGL4

GL_NV_conditional_render (#346)
glBeginOcclusionQueryNV GLScene.OpenGL4

glBeginQuery GLScene.OpenGL4

glBeginQueryARB GLScene.OpenGL4

glBeginQueryIndexed GLScene.OpenGL4

glBeginSceneEXT GLScene.OpenGL4

GL_EXT_scene_marker (EXT #120)
glBeginTransformFeedback GLScene.OpenGL4

glBeginTransformFeedbackEXT GLScene.OpenGL4

glBeginTransformFeedbackNV GLScene.OpenGL4

glBindAttribLocation GLScene.OpenGL4

glBindAttribLocationARB GLScene.OpenGL4

GL_ARB_vertex_shader (ARB #31)
glBindBuffer GLScene.OpenGL4

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)
glBindBufferARB GLScene.OpenGL4

GL_ARB_vertex_buffer_object (ARB #28)
glBindBufferBase GLScene.OpenGL4

glBindBufferBaseEXT GLScene.OpenGL4

glBindBufferBaseNV GLScene.OpenGL4

glBindBufferOffsetEXT GLScene.OpenGL4

glBindBufferOffsetNV GLScene.OpenGL4

glBindBufferRange GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_transform_feedback
glBindBufferRangeEXT GLScene.OpenGL4

GL_EXT_transform_feedback (#352)
glBindBufferRangeNV GLScene.OpenGL4

GL_NV_transform_feedback (#341)
glBindFragDataLocation GLScene.OpenGL4

glBindFragDataLocationEXT GLScene.OpenGL4

glBindFragDataLocationIndexed GLScene.OpenGL4

GL_ARB_blend_func_extended (ARB #78)
glBindFramebuffer GLScene.OpenGL4

glBindFramebufferEXT GLScene.OpenGL4

glBindProgramARB GLScene.OpenGL4

glBindProgramNV GLScene.OpenGL4

glBindRenderbuffer GLScene.OpenGL4

glBindRenderbufferEXT GLScene.OpenGL4

glBindSampler GLScene.OpenGL4

glBindTextureEXT GLScene.OpenGL4

glBindTransformFeedback GLScene.OpenGL4

GL_ARB_transform_feedback2 (ARB #93)
glBindVertexArray GLScene.OpenGL4

GL_ARB_vertex_array_object (ARB #54)
glBlendColor GLScene.OpenGL4

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)
glBlendColorEXT GLScene.OpenGL4

GL_EXT_blend_color (EXT #2)
glBlendEquation GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_blend_minmax (#37)
glBlendEquationEXT GLScene.OpenGL4

GL_EXT_blend_minmax (EXT #37)
glBlendEquationi GLScene.OpenGL4

GL_ARB_draw_buffers_blend (ARB #69)
glBlendEquationSeparate GLScene.OpenGL4

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)
glBlendEquationSeparateEXT GLScene.OpenGL4

GL_EXT_blend_equation_separate (EXT #299)
glBlendEquationSeparatei GLScene.OpenGL4

glBlendFunci GLScene.OpenGL4

glBlendFuncSeparate GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)
glBlendFuncSeparateEXT GLScene.OpenGL4

GL_EXT_blend_func_separate (EXT #173)
glBlendFuncSeparatei GLScene.OpenGL4

glBlitFramebuffer GLScene.OpenGL4

glBlitFramebufferEXT GLScene.OpenGL4

GL_EXT_framebuffer_blit (#316)
glBufferAddressRangeNV GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory (#380)
glBufferData GLScene.OpenGL4

glBufferDataARB GLScene.OpenGL4

glBufferSubData GLScene.OpenGL4

glBufferSubDataARB GLScene.OpenGL4

glCheckFramebufferStatus GLScene.OpenGL4

glCheckFramebufferStatusEXT GLScene.OpenGL4

glClampColor GLScene.OpenGL4

glClampColorARB GLScene.OpenGL4

GL_ARB_color_buffer_float (ARB #39)
glClearBufferfi GLScene.OpenGL4

glClearBufferfv GLScene.OpenGL4

glClearBufferiv GLScene.OpenGL4

New commands in OpenGL 3.0
glClearBufferuiv GLScene.OpenGL4

glClearColorIiEXT GLScene.OpenGL4

GL_EXT_texture_integer (#343)
glClearColorIuiEXT GLScene.OpenGL4

glClientActiveTexture GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multitexture (#1)
glClientActiveTextureARB GLScene.OpenGL4

glClientWaitSync GLScene.OpenGL4

glColorFormatNV GLScene.OpenGL4

glColorMaski GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_draw_buffers2
glColorMaskIndexedEXT GLScene.OpenGL4

GL_EXT_draw_buffers2 (#340)
glColorP3ui GLScene.OpenGL4

glColorP3uiv GLScene.OpenGL4

glColorP4ui GLScene.OpenGL4

glColorP4uiv GLScene.OpenGL4

glColorSubTable GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)
glColorSubTableExt GLScene.OpenGL4

glColorTable GLScene.OpenGL4

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)
glColorTableEXT GLScene.OpenGL4

GL_EXT_paletted_texture (EXT #78)
glColorTableParameterfv GLScene.OpenGL4

deprecated;
glColorTableParameteriv GLScene.OpenGL4

deprecated;
glCombinerInputNV GLScene.OpenGL4

glCombinerOutputNV GLScene.OpenGL4

glCombinerParameterfNV GLScene.OpenGL4

glCombinerParameterfvNV GLScene.OpenGL4

GL_NV_register_combiners (EXT #191)
glCombinerParameteriNV GLScene.OpenGL4

glCombinerParameterivNV GLScene.OpenGL4

glCompileShader GLScene.OpenGL4

glCompileShaderARB GLScene.OpenGL4

glCompressedTexImage1D GLScene.OpenGL4

glCompressedTexImage1DARB GLScene.OpenGL4

glCompressedTexImage2D GLScene.OpenGL4

glCompressedTexImage2DARB GLScene.OpenGL4

glCompressedTexImage3D GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_texture_compression (#12)
glCompressedTexImage3DARB GLScene.OpenGL4

GL_ARB_texture_compression (ARB #12)
glCompressedTexSubImage1D GLScene.OpenGL4

glCompressedTexSubImage1DARB GLScene.OpenGL4

glCompressedTexSubImage2D GLScene.OpenGL4

glCompressedTexSubImage2DARB GLScene.OpenGL4

glCompressedTexSubImage3D GLScene.OpenGL4

glCompressedTexSubImage3DARB GLScene.OpenGL4

glConvolutionFilter1D GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)
glConvolutionFilter2D GLScene.OpenGL4

deprecated;
glConvolutionParameterf GLScene.OpenGL4

deprecated;
glConvolutionParameterfv GLScene.OpenGL4

deprecated;
glConvolutionParameteri GLScene.OpenGL4

deprecated;
glConvolutionParameteriv GLScene.OpenGL4

deprecated;
glCopyBufferSubData GLScene.OpenGL4

GL_ARB_copy_buffer (ARB #59)
glCopyColorSubTable GLScene.OpenGL4

deprecated;
glCopyColorTable GLScene.OpenGL4

deprecated;
glCopyConvolutionFilter1D GLScene.OpenGL4

deprecated;
glCopyConvolutionFilter2D GLScene.OpenGL4

deprecated;
glCopyImageSubDataNV GLScene.OpenGL4

GL_NV_copy_image (#376)
glCopyTexImage1DEXT GLScene.OpenGL4

GL_EXT_copy_texture (EXT #10)
glCopyTexImage2DEXT GLScene.OpenGL4

glCopyTexSubImage1DEXT GLScene.OpenGL4

glCopyTexSubImage2DEXT GLScene.OpenGL4

glCopyTexSubImage3D GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_copy_texture
glCopyTexSubImage3DEXT GLScene.OpenGL4

glCreateProgram GLScene.OpenGL4

glCreateProgramObjectARB GLScene.OpenGL4

glCreateShader GLScene.OpenGL4

glCreateShaderObjectARB GLScene.OpenGL4

glCurrentPaletteMatrixARB GLScene.OpenGL4

GL_ARB_matrix_palette (ARB #16) {deprecated?}
glDeleteBuffers GLScene.OpenGL4

glDeleteBuffersARB GLScene.OpenGL4

glDeleteFencesNV GLScene.OpenGL4

glDeleteFramebuffers GLScene.OpenGL4

glDeleteFramebuffersEXT GLScene.OpenGL4

glDeleteObjectARB GLScene.OpenGL4

GL_ARB_shader_objects (ARB #30)
glDeleteOcclusionQueriesNV GLScene.OpenGL4

glDeleteProgram GLScene.OpenGL4

glDeleteProgramsARB GLScene.OpenGL4

glDeleteProgramsNV GLScene.OpenGL4

glDeleteQueries GLScene.OpenGL4

glDeleteQueriesARB GLScene.OpenGL4

glDeleteRenderbuffers GLScene.OpenGL4

glDeleteRenderbuffersEXT GLScene.OpenGL4

glDeleteSamplers GLScene.OpenGL4

glDeleteShader GLScene.OpenGL4

glDeleteSync GLScene.OpenGL4

glDeleteTexturesEXT GLScene.OpenGL4

glDeleteTransformFeedbacks GLScene.OpenGL4

glDeleteVertexArrays GLScene.OpenGL4

glDepthBoundsEXT GLScene.OpenGL4

GL_EXT_depth_bounds_test (EXT #297)
glDetachObjectARB GLScene.OpenGL4

glDetachShader GLScene.OpenGL4

glDisablei GLScene.OpenGL4

glDisableIndexedEXT GLScene.OpenGL4

glDisableVertexAttribArray GLScene.OpenGL4

glDisableVertexAttribArrayARB GLScene.OpenGL4

glDrawArraysIndirect GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87)
glDrawArraysInstanced GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################
glDrawArraysInstancedARB GLScene.OpenGL4

GL_ARB_draw_instanced (ARB #44)
glDrawArraysInstancedEXT GLScene.OpenGL4

GL_EXT_draw_instanced (#327)
glDrawBuffers GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_draw_buffers (#37)
glDrawBuffersARB GLScene.OpenGL4

GL_ARB_DrawBuffers (ARB #37)
glDrawBuffersATI GLScene.OpenGL4

GL_ATI_draw_buffers (EXT #277)
glDrawElementsBaseVertex GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex (ARB #62)
glDrawElementsIndirect GLScene.OpenGL4

glDrawElementsInstanced GLScene.OpenGL4

glDrawElementsInstancedARB GLScene.OpenGL4

glDrawElementsInstancedBaseVertex GLScene.OpenGL4

glDrawElementsInstancedEXT GLScene.OpenGL4

glDrawRangeElements GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)
glDrawRangeElementsBaseVertex GLScene.OpenGL4

glDrawRangeElementsEXT GLScene.OpenGL4

GL_EXT_draw_range_elements (EXT #112)
glDrawTransformFeedback GLScene.OpenGL4

glDrawTransformFeedbackStream GLScene.OpenGL4

GL_ARB_transform_feedback3 (ARB #94)
glEdgeFlagFormatNV GLScene.OpenGL4

glEnablei GLScene.OpenGL4

glEnableIndexedEXT GLScene.OpenGL4

glEnableVertexAttribArray GLScene.OpenGL4

glEnableVertexAttribArrayARB GLScene.OpenGL4

glEndConditionalRender GLScene.OpenGL4

glEndConditionalRenderNV GLScene.OpenGL4

glEndOcclusionQueryNV GLScene.OpenGL4

glEndQuery GLScene.OpenGL4

glEndQueryARB GLScene.OpenGL4

glEndQueryIndexed GLScene.OpenGL4

glEndSceneEXT GLScene.OpenGL4

glEndTransformFeedback GLScene.OpenGL4

glEndTransformFeedbackEXT GLScene.OpenGL4

glEndTransformFeedbackNV GLScene.OpenGL4

glExecuteProgramNV GLScene.OpenGL4

glFenceSync GLScene.OpenGL4

GL_ARB_sync (ARB #66)
glFinalCombinerInputNV GLScene.OpenGL4

glFinishFenceNV GLScene.OpenGL4

glFlushMappedBufferRange GLScene.OpenGL4

glFlushVertexArrayRangeNV GLScene.OpenGL4

GL_NV_vertex_array_range (EXT #190)
glFogCoordd GLScene.OpenGL4

deprecated;
glFogCoorddEXT GLScene.OpenGL4

glFogCoorddv GLScene.OpenGL4

deprecated;
glFogCoorddvEXT GLScene.OpenGL4

glFogCoordf GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_fog_coord (#149)
glFogCoordfEXT GLScene.OpenGL4

GL_EXT_fog_coord (EXT #149)
glFogCoordFormatNV GLScene.OpenGL4

glFogCoordfv GLScene.OpenGL4

deprecated;
glFogCoordfvEXT GLScene.OpenGL4

glFogCoordPointer GLScene.OpenGL4

deprecated;
glFogCoordPointerEXT GLScene.OpenGL4

glFramebufferRenderbuffer GLScene.OpenGL4

glFramebufferRenderbufferEXT GLScene.OpenGL4

glFramebufferTexture GLScene.OpenGL4

glFramebufferTexture1D GLScene.OpenGL4

glFramebufferTexture1DEXT GLScene.OpenGL4

glFramebufferTexture2D GLScene.OpenGL4

glFramebufferTexture2DEXT GLScene.OpenGL4

glFramebufferTexture3D GLScene.OpenGL4

glFramebufferTexture3DEXT GLScene.OpenGL4

glFramebufferTextureARB GLScene.OpenGL4

glFramebufferTextureEXT GLScene.OpenGL4

glFramebufferTextureFaceARB GLScene.OpenGL4

glFramebufferTextureFaceEXT GLScene.OpenGL4

glFramebufferTextureLayer GLScene.OpenGL4

glFramebufferTextureLayerARB GLScene.OpenGL4

glFramebufferTextureLayerEXT GLScene.OpenGL4

glFrameTerminatorGREMEDY GLScene.OpenGL4

Special Gremedy debugger extension
glGenBuffers GLScene.OpenGL4

glGenBuffersARB GLScene.OpenGL4

glGenerateMipmap GLScene.OpenGL4

glGenerateMipmapEXT GLScene.OpenGL4

glGenFencesNV GLScene.OpenGL4

GL_NV_fence (EXT #222)
glGenFramebuffers GLScene.OpenGL4

glGenFramebuffersEXT GLScene.OpenGL4

glGenOcclusionQueriesNV GLScene.OpenGL4

GL_NV_occlusion_query (EXT #261)
glGenProgramsARB GLScene.OpenGL4

glGenProgramsNV GLScene.OpenGL4

glGenQueries GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)
glGenQueriesARB GLScene.OpenGL4

GL_ARB_occlusion_query (ARB #29)
glGenRenderbuffers GLScene.OpenGL4

glGenRenderbuffersEXT GLScene.OpenGL4

glGenSamplers GLScene.OpenGL4

GL_ARB_sampler_objects (ARB #81)
glGenTexturesEXT GLScene.OpenGL4

GL_EXT_texture_object (EXT #20)
glGenTransformFeedbacks GLScene.OpenGL4

glGenVertexArrays GLScene.OpenGL4

glGetActiveAttrib GLScene.OpenGL4

glGetActiveAttribARB GLScene.OpenGL4

glGetActiveSubroutineName GLScene.OpenGL4

glGetActiveSubroutineUniformiv GLScene.OpenGL4

glGetActiveSubroutineUniformName GLScene.OpenGL4

glGetActiveUniform GLScene.OpenGL4

glGetActiveUniformARB GLScene.OpenGL4

glGetActiveUniformBlockiv GLScene.OpenGL4

glGetActiveUniformBlockName GLScene.OpenGL4

glGetActiveUniformName GLScene.OpenGL4

glGetActiveUniformsiv GLScene.OpenGL4

glGetActiveVaryingNV GLScene.OpenGL4

glGetAttachedObjectsARB GLScene.OpenGL4

glGetAttachedShaders GLScene.OpenGL4

glGetAttribLocation GLScene.OpenGL4

glGetAttribLocationARB GLScene.OpenGL4

glGetBooleanIndexedvEXT GLScene.OpenGL4

glGetBooleani_v GLScene.OpenGL4

glGetBufferParameteri64v GLScene.OpenGL4

glGetBufferParameteriv GLScene.OpenGL4

glGetBufferParameterivARB GLScene.OpenGL4

glGetBufferParameterui64vNV GLScene.OpenGL4

glGetBufferPointerv GLScene.OpenGL4

glGetBufferPointervARB GLScene.OpenGL4

glGetBufferSubData GLScene.OpenGL4

glGetBufferSubDataARB GLScene.OpenGL4

glGetColorTable GLScene.OpenGL4

deprecated;
glGetColorTableEXT GLScene.OpenGL4

glGetColorTableParameterfv GLScene.OpenGL4

deprecated;
glGetColorTableParameterfvEXT GLScene.OpenGL4

glGetColorTableParameteriv GLScene.OpenGL4

deprecated;
glGetColorTableParameterivEXT GLScene.OpenGL4

glGetCombinerInputParameterfvNV GLScene.OpenGL4

glGetCombinerInputParameterivNV GLScene.OpenGL4

glGetCombinerOutputParameterfvNV GLScene.OpenGL4

glGetCombinerOutputParameterivNV GLScene.OpenGL4

glGetCompressedTexImage GLScene.OpenGL4

glGetCompressedTexImageARB GLScene.OpenGL4

glGetConvolutionFilter GLScene.OpenGL4

deprecated;
glGetConvolutionParameterfv GLScene.OpenGL4

deprecated;
glGetConvolutionParameteriv GLScene.OpenGL4

deprecated;
glGetFenceivNV GLScene.OpenGL4

glGetFinalCombinerInputParameterfvNV GLScene.OpenGL4

glGetFinalCombinerInputParameterivNV GLScene.OpenGL4

glGetFragDataIndex GLScene.OpenGL4

glGetFragDataLocation GLScene.OpenGL4

glGetFragDataLocationEXT GLScene.OpenGL4

glGetFramebufferAttachmentParameteriv GLScene.OpenGL4

glGetFramebufferAttachmentParameterivEXT GLScene.OpenGL4

glGetHandleARB GLScene.OpenGL4

glGetHistogram GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)
glGetHistogramParameterfv GLScene.OpenGL4

deprecated;
glGetHistogramParameteriv GLScene.OpenGL4

deprecated;
glGetInfoLogARB GLScene.OpenGL4

glGetInteger64i_v GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################
glGetInteger64v GLScene.OpenGL4

glGetIntegerIndexedvEXT GLScene.OpenGL4

glGetIntegeri_v GLScene.OpenGL4

glGetIntegerui64i_vNV GLScene.OpenGL4

glGetIntegerui64vNV GLScene.OpenGL4

glGetMinmax GLScene.OpenGL4

deprecated;
glGetMinmaxParameterfv GLScene.OpenGL4

deprecated;
glGetMinmaxParameteriv GLScene.OpenGL4

deprecated;
glGetMultisamplefv GLScene.OpenGL4

glGetNamedBufferParameterui64vNV GLScene.OpenGL4

glGetObjectParameterfvARB GLScene.OpenGL4

glGetObjectParameterivARB GLScene.OpenGL4

glGetOcclusionQueryivNV GLScene.OpenGL4

glGetOcclusionQueryuivNV GLScene.OpenGL4

glGetProgramEnvParameterdvARB GLScene.OpenGL4

glGetProgramEnvParameterfvARB GLScene.OpenGL4

glGetProgramInfoLog GLScene.OpenGL4

glGetProgramiv GLScene.OpenGL4

glGetProgramivARB GLScene.OpenGL4

glGetProgramivNV GLScene.OpenGL4

glGetProgramLocalParameterdvARB GLScene.OpenGL4

glGetProgramLocalParameterfvARB GLScene.OpenGL4

glGetProgramParameterdvNV GLScene.OpenGL4

glGetProgramParameterfvNV GLScene.OpenGL4

glGetProgramStageiv GLScene.OpenGL4

glGetProgramStringARB GLScene.OpenGL4

glGetProgramStringNV GLScene.OpenGL4

glGetQueryIndexediv GLScene.OpenGL4

glGetQueryiv GLScene.OpenGL4

glGetQueryivARB GLScene.OpenGL4

glGetQueryObjecti64v GLScene.OpenGL4

glGetQueryObjecti64vEXT GLScene.OpenGL4

GL_EXT_timer_query (#319)
glGetQueryObjectiv GLScene.OpenGL4

glGetQueryObjectivARB GLScene.OpenGL4

glGetQueryObjectui64v GLScene.OpenGL4

glGetQueryObjectui64vEXT GLScene.OpenGL4

glGetQueryObjectuiv GLScene.OpenGL4

glGetQueryObjectuivARB GLScene.OpenGL4

glGetRenderbufferParameteriv GLScene.OpenGL4

glGetRenderbufferParameterivEXT GLScene.OpenGL4

glGetSamplerParameterfv GLScene.OpenGL4

glGetSamplerParameterIfv GLScene.OpenGL4

glGetSamplerParameterIiv GLScene.OpenGL4

glGetSamplerParameteriv GLScene.OpenGL4

glGetSeparableFilter GLScene.OpenGL4

deprecated;
glGetShaderInfoLog GLScene.OpenGL4

glGetShaderiv GLScene.OpenGL4

glGetShaderSource GLScene.OpenGL4

glGetShaderSourceARB GLScene.OpenGL4

glGetStringi GLScene.OpenGL4

glGetSubroutineIndex GLScene.OpenGL4

glGetSubroutineUniformLocation GLScene.OpenGL4

GL_ARB_shader_subroutine (ARB #90)
glGetSynciv GLScene.OpenGL4

glGetTexParameterIiv GLScene.OpenGL4

glGetTexParameterIivEXT GLScene.OpenGL4

glGetTexParameterIuiv GLScene.OpenGL4

glGetTexParameterIuivEXT GLScene.OpenGL4

glGetTrackMatrixivNV GLScene.OpenGL4

glGetTransformFeedbackVarying GLScene.OpenGL4

glGetTransformFeedbackVaryingEXT GLScene.OpenGL4

glGetTransformFeedbackVaryingNV GLScene.OpenGL4

glGetUniformBlockIndex GLScene.OpenGL4

glGetUniformBufferSizeEXT GLScene.OpenGL4

glGetUniformdv GLScene.OpenGL4

glGetUniformfv GLScene.OpenGL4

glGetUniformfvARB GLScene.OpenGL4

glGetUniformIndices GLScene.OpenGL4

GL_ARB_uniform_buffer_object (ARB #57)
glGetUniformiv GLScene.OpenGL4

glGetUniformivARB GLScene.OpenGL4

glGetUniformLocation GLScene.OpenGL4

glGetUniformLocationARB GLScene.OpenGL4

glGetUniformOffsetEXT GLScene.OpenGL4

glGetUniformSubroutineuiv GLScene.OpenGL4

glGetUniformui64vNV GLScene.OpenGL4

glGetUniformuiv GLScene.OpenGL4

glGetUniformuivEXT GLScene.OpenGL4

glGetVaryingLocationNV GLScene.OpenGL4

glGetVertexAttribdv GLScene.OpenGL4

glGetVertexAttribdvARB GLScene.OpenGL4

glGetVertexAttribdvNV GLScene.OpenGL4

glGetVertexAttribfv GLScene.OpenGL4

glGetVertexAttribfvARB GLScene.OpenGL4

glGetVertexAttribfvNV GLScene.OpenGL4

glGetVertexAttribIiv GLScene.OpenGL4

glGetVertexAttribIivEXT GLScene.OpenGL4

glGetVertexAttribIuiv GLScene.OpenGL4

glGetVertexAttribIuivEXT GLScene.OpenGL4

glGetVertexAttribiv GLScene.OpenGL4

glGetVertexAttribivARB GLScene.OpenGL4

glGetVertexAttribivNV GLScene.OpenGL4

glGetVertexAttribPointerv GLScene.OpenGL4

glGetVertexAttribPointervARB GLScene.OpenGL4

glGetVertexAttribPointervNV GLScene.OpenGL4

glHistogram GLScene.OpenGL4

deprecated;
glIndexFormatNV GLScene.OpenGL4

glIndexFuncEXT GLScene.OpenGL4

GL_EXT_index_func (EXT #95)
glIndexMaterialEXT GLScene.OpenGL4

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)
glIsBuffer GLScene.OpenGL4

glIsBufferARB GLScene.OpenGL4

glIsBufferResidentNV GLScene.OpenGL4

glIsEnabledi GLScene.OpenGL4

glIsEnabledIndexedEXT GLScene.OpenGL4

glIsFenceNV GLScene.OpenGL4

glIsFramebuffer GLScene.OpenGL4

glIsFramebufferEXT GLScene.OpenGL4

glIsNamedBufferResidentNV GLScene.OpenGL4

glIsOcclusionQueryNV GLScene.OpenGL4

glIsProgram GLScene.OpenGL4

glIsProgramARB GLScene.OpenGL4

glIsProgramNV GLScene.OpenGL4

glIsQuery GLScene.OpenGL4

glIsQueryARB GLScene.OpenGL4

glIsRenderbuffer GLScene.OpenGL4

GL_ARB_framebuffer_object (ARB #45)
glIsRenderbufferEXT GLScene.OpenGL4

GL_EXT_framebuffer_object (EXT #310)
glIsSampler GLScene.OpenGL4

glIsShader GLScene.OpenGL4

glIsSync GLScene.OpenGL4

glIsTextureEXT GLScene.OpenGL4

glIsTransformFeedback GLScene.OpenGL4

glIsVertexArray GLScene.OpenGL4

glLinkProgram GLScene.OpenGL4

glLinkProgramARB GLScene.OpenGL4

glLoadProgramNV GLScene.OpenGL4

glLoadTransposeMatrixd GLScene.OpenGL4

deprecated;
glLoadTransposeMatrixdARB GLScene.OpenGL4

glLoadTransposeMatrixf GLScene.OpenGL4

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix
glLoadTransposeMatrixfARB GLScene.OpenGL4

GL_ARB_transpose_matrix (ARB #3)
glLockArraysEXT GLScene.OpenGL4

GL_EXT_compiled_vertex_array (EXT #97)
glMakeBufferNonResidentNV GLScene.OpenGL4

glMakeBufferResidentNV GLScene.OpenGL4

GL_NV_shader_buffer_load (#379)
glMakeNamedBufferNonResidentNV GLScene.OpenGL4

glMakeNamedBufferResidentNV GLScene.OpenGL4

glMapBuffer GLScene.OpenGL4

glMapBufferARB GLScene.OpenGL4

glMapBufferRange GLScene.OpenGL4

GL_ARB_map_buffer_range (ARB #50)
glMatrixIndexPointerARB GLScene.OpenGL4

glMatrixIndexubvARB GLScene.OpenGL4

glMatrixIndexuivARB GLScene.OpenGL4

glMatrixIndexusvARB GLScene.OpenGL4

glMinmax GLScene.OpenGL4

deprecated;
glMinSampleShading GLScene.OpenGL4

GL_ARB_sample_shading (ARB #70)
glMultiDrawArrays GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)
glMultiDrawArraysEXT GLScene.OpenGL4

GL_EXT_multi_draw_arrays (EXT #148)
glMultiDrawElements GLScene.OpenGL4

glMultiDrawElementsBaseVertex GLScene.OpenGL4

glMultiDrawElementsEXT GLScene.OpenGL4

glMultiTexCoord1d GLScene.OpenGL4

deprecated;
glMultiTexCoord1dARB GLScene.OpenGL4

glMultiTexCoord1dV GLScene.OpenGL4

deprecated;
glMultiTexCoord1dVARB GLScene.OpenGL4

glMultiTexCoord1f GLScene.OpenGL4

deprecated;
glMultiTexCoord1fARB GLScene.OpenGL4

glMultiTexCoord1fV GLScene.OpenGL4

deprecated;
glMultiTexCoord1fVARB GLScene.OpenGL4

glMultiTexCoord1i GLScene.OpenGL4

deprecated;
glMultiTexCoord1iARB GLScene.OpenGL4

glMultiTexCoord1iV GLScene.OpenGL4

deprecated;
glMultiTexCoord1iVARB GLScene.OpenGL4

glMultiTexCoord1s GLScene.OpenGL4

deprecated;
glMultiTexCoord1sARB GLScene.OpenGL4

glMultiTexCoord1sV GLScene.OpenGL4

deprecated;
glMultiTexCoord1sVARB GLScene.OpenGL4

glMultiTexCoord2d GLScene.OpenGL4

deprecated;
glMultiTexCoord2dARB GLScene.OpenGL4

glMultiTexCoord2dv GLScene.OpenGL4

deprecated;
glMultiTexCoord2dvARB GLScene.OpenGL4

glMultiTexCoord2f GLScene.OpenGL4

deprecated;
glMultiTexCoord2fARB GLScene.OpenGL4

glMultiTexCoord2fv GLScene.OpenGL4

deprecated;
glMultiTexCoord2fvARB GLScene.OpenGL4

glMultiTexCoord2i GLScene.OpenGL4

deprecated;
glMultiTexCoord2iARB GLScene.OpenGL4

glMultiTexCoord2iv GLScene.OpenGL4

deprecated;
glMultiTexCoord2ivARB GLScene.OpenGL4

glMultiTexCoord2s GLScene.OpenGL4

deprecated;
glMultiTexCoord2sARB GLScene.OpenGL4

glMultiTexCoord2sv GLScene.OpenGL4

deprecated;
glMultiTexCoord2svARB GLScene.OpenGL4

glMultiTexCoord3d GLScene.OpenGL4

deprecated;
glMultiTexCoord3dARB GLScene.OpenGL4

glMultiTexCoord3dv GLScene.OpenGL4

deprecated;
glMultiTexCoord3dvARB GLScene.OpenGL4

glMultiTexCoord3f GLScene.OpenGL4

deprecated;
glMultiTexCoord3fARB GLScene.OpenGL4

glMultiTexCoord3fv GLScene.OpenGL4

deprecated;
glMultiTexCoord3fvARB GLScene.OpenGL4

glMultiTexCoord3i GLScene.OpenGL4

deprecated;
glMultiTexCoord3iARB GLScene.OpenGL4

glMultiTexCoord3iv GLScene.OpenGL4

deprecated;
glMultiTexCoord3ivARB GLScene.OpenGL4

glMultiTexCoord3s GLScene.OpenGL4

deprecated;
glMultiTexCoord3sARB GLScene.OpenGL4

glMultiTexCoord3sv GLScene.OpenGL4

deprecated;
glMultiTexCoord3svARB GLScene.OpenGL4

glMultiTexCoord4d GLScene.OpenGL4

deprecated;
glMultiTexCoord4dARB GLScene.OpenGL4

glMultiTexCoord4dv GLScene.OpenGL4

deprecated;
glMultiTexCoord4dvARB GLScene.OpenGL4

glMultiTexCoord4f GLScene.OpenGL4

deprecated;
glMultiTexCoord4fARB GLScene.OpenGL4

glMultiTexCoord4fv GLScene.OpenGL4

deprecated;
glMultiTexCoord4fvARB GLScene.OpenGL4

glMultiTexCoord4i GLScene.OpenGL4

deprecated;
glMultiTexCoord4iARB GLScene.OpenGL4

glMultiTexCoord4iv GLScene.OpenGL4

deprecated;
glMultiTexCoord4ivARB GLScene.OpenGL4

glMultiTexCoord4s GLScene.OpenGL4

deprecated;
glMultiTexCoord4sARB GLScene.OpenGL4

glMultiTexCoord4sv GLScene.OpenGL4

deprecated;
glMultiTexCoord4svARB GLScene.OpenGL4

glMultiTexCoordP1ui GLScene.OpenGL4

glMultiTexCoordP1uiv GLScene.OpenGL4

glMultiTexCoordP2ui GLScene.OpenGL4

glMultiTexCoordP2uiv GLScene.OpenGL4

glMultiTexCoordP3ui GLScene.OpenGL4

glMultiTexCoordP3uiv GLScene.OpenGL4

glMultiTexCoordP4ui GLScene.OpenGL4

glMultiTexCoordP4uiv GLScene.OpenGL4

glMultTransposeMatrixd GLScene.OpenGL4

deprecated;
glMultTransposeMatrixdARB GLScene.OpenGL4

glMultTransposeMatrixf GLScene.OpenGL4

deprecated;
glMultTransposeMatrixfARB GLScene.OpenGL4

glNormalFormatNV GLScene.OpenGL4

glNormalP3ui GLScene.OpenGL4

glNormalP3uiv GLScene.OpenGL4

glPatchParameterfv GLScene.OpenGL4

glPatchParameteri GLScene.OpenGL4

GL_ARB_tessellation_shader (ARB #91)
glPauseTransformFeedback GLScene.OpenGL4

glPointParameterf GLScene.OpenGL4

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)
glPointParameterfARB GLScene.OpenGL4

GL_ARB_point_parameter (ARB #14)
glPointParameterfv GLScene.OpenGL4

glPointParameterfvARB GLScene.OpenGL4

glPointParameteri GLScene.OpenGL4

glPointParameteriNV GLScene.OpenGL4

GL_NV_point_sprite (EXT #262)
glPointParameteriv GLScene.OpenGL4

glPointParameterivNV GLScene.OpenGL4

glPolygonOffsetEXT GLScene.OpenGL4

GL_EXT_polygon_offset (EXT #3)
glPrimitiveRestartIndex GLScene.OpenGL4

glPrimitiveRestartIndexNV GLScene.OpenGL4

glPrimitiveRestartNV GLScene.OpenGL4

GL_NV_primitive_restart (EXT #285)
glPrioritizeTexturesEXT GLScene.OpenGL4

glProgramEnvParameter4dARB GLScene.OpenGL4

glProgramEnvParameter4dvARB GLScene.OpenGL4

glProgramEnvParameter4fARB GLScene.OpenGL4

glProgramEnvParameter4fvARB GLScene.OpenGL4

glProgramEnvParameters4fvEXT GLScene.OpenGL4

GL_EXT_gpu_program_parameters (EXT #320)
glProgramLocalParameter4dARB GLScene.OpenGL4

glProgramLocalParameter4dvARB GLScene.OpenGL4

glProgramLocalParameter4fARB GLScene.OpenGL4

glProgramLocalParameter4fvARB GLScene.OpenGL4

glProgramLocalParameters4fvEXT GLScene.OpenGL4

glProgramParameter4dNV GLScene.OpenGL4

glProgramParameter4dvNV GLScene.OpenGL4

glProgramParameter4fNV GLScene.OpenGL4

glProgramParameter4fvNV GLScene.OpenGL4

glProgramParameteri GLScene.OpenGL4

glProgramParameteriARB GLScene.OpenGL4

GL_ARB_geometry_shader4 (ARB #47)
glProgramParameteriEXT GLScene.OpenGL4

GL_EXT_geometry_shader4 (EXT #324)
glProgramParameters4dvNV GLScene.OpenGL4

glProgramParameters4fvNV GLScene.OpenGL4

glProgramStringARB GLScene.OpenGL4

glProgramUniform1dEXT GLScene.OpenGL4

glProgramUniformXXX only valid if EXT_direct_state_access is available
glProgramUniform1dvEXT GLScene.OpenGL4

glProgramUniform2dEXT GLScene.OpenGL4

glProgramUniform2dvEXT GLScene.OpenGL4

glProgramUniform3dEXT GLScene.OpenGL4

glProgramUniform3dvEXT GLScene.OpenGL4

glProgramUniform4dEXT GLScene.OpenGL4

glProgramUniform4dvEXT GLScene.OpenGL4

glProgramUniformMatrix2dvEXT GLScene.OpenGL4

glProgramUniformMatrix2x3dvEXT GLScene.OpenGL4

glProgramUniformMatrix2x4dvEXT GLScene.OpenGL4

glProgramUniformMatrix3dvEXT GLScene.OpenGL4

glProgramUniformMatrix3x2dvEXT GLScene.OpenGL4

glProgramUniformMatrix3x4dvEXT GLScene.OpenGL4

glProgramUniformMatrix4dvEXT GLScene.OpenGL4

glProgramUniformMatrix4x2dvEXT GLScene.OpenGL4

glProgramUniformMatrix4x3dvEXT GLScene.OpenGL4

glProgramUniformui64NV GLScene.OpenGL4

glProgramUniformui64vNV GLScene.OpenGL4

glProgramVertexLimitNV GLScene.OpenGL4

GL_NV_geometry_program4 (EXT #323)
glProvokingVertex GLScene.OpenGL4

GL_ARB_provoking_vertex (ARB #64)
glQueryCounter GLScene.OpenGL4

GL_ARB_timer_query (ARB #85)
glRenderbufferStorage GLScene.OpenGL4

glRenderbufferStorageEXT GLScene.OpenGL4

glRenderbufferStorageMultisample GLScene.OpenGL4

glRenderbufferStorageMultisampleEXT GLScene.OpenGL4

GL_EXT_framebuffer_multisample (#317)
glRequestResidentProgramsNV GLScene.OpenGL4

glResetHistogram GLScene.OpenGL4

deprecated;
glResetMinmax GLScene.OpenGL4

deprecated;
glResizeBuffersMESA GLScene.OpenGL4

GL_MESA_resize_buffers (EXT #196)
glResumeTransformFeedback GLScene.OpenGL4

glSampleCoverage GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multisample (#5)
glSampleCoverageARB GLScene.OpenGL4

GL_ARB_multisample (ARB #5)
glSampleMaskEXT GLScene.OpenGL4

GL_EXT_multisample (EXT #209)
glSampleMaski GLScene.OpenGL4

glSampleMaskSGIS GLScene.OpenGL4

GL_SGIS_multisample (EXT #25)
glSamplePassARB GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension
glSamplePatternEXT GLScene.OpenGL4

glSamplePatternSGIS GLScene.OpenGL4

glSamplerParameterf GLScene.OpenGL4

glSamplerParameterfv GLScene.OpenGL4

glSamplerParameteri GLScene.OpenGL4

glSamplerParameterIiv GLScene.OpenGL4

glSamplerParameterIuiv GLScene.OpenGL4

glSamplerParameteriv GLScene.OpenGL4

glSecondaryColor3b GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)
glSecondaryColor3bEXT GLScene.OpenGL4

GL_EXT_secondary_color (EXT #145)
glSecondaryColor3bv GLScene.OpenGL4

deprecated;
glSecondaryColor3bvEXT GLScene.OpenGL4

glSecondaryColor3d GLScene.OpenGL4

deprecated;
glSecondaryColor3dEXT GLScene.OpenGL4

glSecondaryColor3dv GLScene.OpenGL4

deprecated;
glSecondaryColor3dvEXT GLScene.OpenGL4

glSecondaryColor3f GLScene.OpenGL4

deprecated;
glSecondaryColor3fEXT GLScene.OpenGL4

glSecondaryColor3fv GLScene.OpenGL4

deprecated;
glSecondaryColor3fvEXT GLScene.OpenGL4

glSecondaryColor3i GLScene.OpenGL4

deprecated;
glSecondaryColor3iEXT GLScene.OpenGL4

glSecondaryColor3iv GLScene.OpenGL4

deprecated;
glSecondaryColor3ivEXT GLScene.OpenGL4

glSecondaryColor3s GLScene.OpenGL4

deprecated;
glSecondaryColor3sEXT GLScene.OpenGL4

glSecondaryColor3sv GLScene.OpenGL4

deprecated;
glSecondaryColor3svEXT GLScene.OpenGL4

glSecondaryColor3ub GLScene.OpenGL4

deprecated;
glSecondaryColor3ubEXT GLScene.OpenGL4

glSecondaryColor3ubv GLScene.OpenGL4

deprecated;
glSecondaryColor3ubvEXT GLScene.OpenGL4

glSecondaryColor3ui GLScene.OpenGL4

deprecated;
glSecondaryColor3uiEXT GLScene.OpenGL4

glSecondaryColor3uiv GLScene.OpenGL4

deprecated;
glSecondaryColor3uivEXT GLScene.OpenGL4

glSecondaryColor3us GLScene.OpenGL4

deprecated;
glSecondaryColor3usEXT GLScene.OpenGL4

glSecondaryColor3usv GLScene.OpenGL4

deprecated;
glSecondaryColor3usvEXT GLScene.OpenGL4

glSecondaryColorFormatNV GLScene.OpenGL4

glSecondaryColorP3ui GLScene.OpenGL4

glSecondaryColorP3uiv GLScene.OpenGL4

glSecondaryColorPointer GLScene.OpenGL4

deprecated;
glSecondaryColorPointerEXT GLScene.OpenGL4

glSeparableFilter2D GLScene.OpenGL4

deprecated;
glSetFenceNV GLScene.OpenGL4

glShaderSource GLScene.OpenGL4

glShaderSourceARB GLScene.OpenGL4

glStencilClearTagEXT GLScene.OpenGL4

GL_EXT_stencil_clear_tag (EXT #314)
glStencilFuncSeparate GLScene.OpenGL4

glStencilMaskSeparate GLScene.OpenGL4

glStencilOpSeparate GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)
glStringMarkerGREMEDY GLScene.OpenGL4

glTbufferMask3DFX GLScene.OpenGL4

GL_3DFX_tbuffer (EXT #208)
glTessellationFactorAMD GLScene.OpenGL4

GL_AMD_vertex_shader_tessellator (#363)
glTessellationModeAMD GLScene.OpenGL4

glTestFenceNV GLScene.OpenGL4

glTexBuffer GLScene.OpenGL4

glTexBufferARB GLScene.OpenGL4

GL_ARB_texture_buffer_object (ARB #51)
glTexBufferEXT GLScene.OpenGL4

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)
glTexCoordFormatNV GLScene.OpenGL4

glTexCoordP1ui GLScene.OpenGL4

glTexCoordP1uiv GLScene.OpenGL4

glTexCoordP2ui GLScene.OpenGL4

glTexCoordP2uiv GLScene.OpenGL4

glTexCoordP3ui GLScene.OpenGL4

glTexCoordP3uiv GLScene.OpenGL4

glTexCoordP4ui GLScene.OpenGL4

glTexCoordP4uiv GLScene.OpenGL4

glTexImage2DMultisample GLScene.OpenGL4

GL_ARB_texture_multisample (ARB #67)
glTexImage3D GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_texture3D (#6)
glTexImage3DEXT GLScene.OpenGL4

GL_EXT_texture3D (EXT #6)
glTexImage3DMultisample GLScene.OpenGL4

glTexParameterIiv GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}
glTexParameterIivEXT GLScene.OpenGL4

glTexParameterIuiv GLScene.OpenGL4

glTexParameterIuivEXT GLScene.OpenGL4

glTexSubImage1DEXT GLScene.OpenGL4

GL_EXT_subtexture (EXT #9)
glTexSubImage2DEXT GLScene.OpenGL4

glTexSubImage3D GLScene.OpenGL4

glTexSubImage3DEXT GLScene.OpenGL4

glTextureColorMaskSGIS GLScene.OpenGL4

GL_SGIS_texture_color_mask (EXT #214)
glTrackMatrixNV GLScene.OpenGL4

glTransformFeedbackAttribsNV GLScene.OpenGL4

glTransformFeedbackVaryings GLScene.OpenGL4

glTransformFeedbackVaryingsEXT GLScene.OpenGL4

glTransformFeedbackVaryingsNV GLScene.OpenGL4

gluDeleteNurbsTessellatorEXT GLScene.OpenGL4

gluNewNurbsTessellatorEXT GLScene.OpenGL4

glUniform1d GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 (ARB #89)
glUniform1dv GLScene.OpenGL4

glUniform1f GLScene.OpenGL4

glUniform1fARB GLScene.OpenGL4

glUniform1fv GLScene.OpenGL4

glUniform1fvARB GLScene.OpenGL4

glUniform1i GLScene.OpenGL4

glUniform1iARB GLScene.OpenGL4

glUniform1iv GLScene.OpenGL4

glUniform1ivARB GLScene.OpenGL4

glUniform1ui GLScene.OpenGL4

glUniform1uiEXT GLScene.OpenGL4

glUniform1uiv GLScene.OpenGL4

glUniform1uivEXT GLScene.OpenGL4

glUniform2d GLScene.OpenGL4

glUniform2dv GLScene.OpenGL4

glUniform2f GLScene.OpenGL4

glUniform2fARB GLScene.OpenGL4

glUniform2fv GLScene.OpenGL4

glUniform2fvARB GLScene.OpenGL4

glUniform2i GLScene.OpenGL4

glUniform2iARB GLScene.OpenGL4

glUniform2iv GLScene.OpenGL4

glUniform2ivARB GLScene.OpenGL4

glUniform2ui GLScene.OpenGL4

glUniform2uiEXT GLScene.OpenGL4

glUniform2uiv GLScene.OpenGL4

glUniform2uivEXT GLScene.OpenGL4

glUniform3d GLScene.OpenGL4

glUniform3dv GLScene.OpenGL4

glUniform3f GLScene.OpenGL4

glUniform3fARB GLScene.OpenGL4

glUniform3fv GLScene.OpenGL4

glUniform3fvARB GLScene.OpenGL4

glUniform3i GLScene.OpenGL4

glUniform3iARB GLScene.OpenGL4

glUniform3iv GLScene.OpenGL4

glUniform3ivARB GLScene.OpenGL4

glUniform3ui GLScene.OpenGL4

glUniform3uiEXT GLScene.OpenGL4

glUniform3uiv GLScene.OpenGL4

glUniform3uivEXT GLScene.OpenGL4

glUniform4d GLScene.OpenGL4

glUniform4dv GLScene.OpenGL4

glUniform4f GLScene.OpenGL4

glUniform4fARB GLScene.OpenGL4

glUniform4fv GLScene.OpenGL4

glUniform4fvARB GLScene.OpenGL4

glUniform4i GLScene.OpenGL4

glUniform4iARB GLScene.OpenGL4

glUniform4iv GLScene.OpenGL4

glUniform4ivARB GLScene.OpenGL4

glUniform4ui GLScene.OpenGL4

glUniform4uiEXT GLScene.OpenGL4

glUniform4uiv GLScene.OpenGL4

glUniform4uivEXT GLScene.OpenGL4

glUniformBlockBinding GLScene.OpenGL4

glUniformBufferEXT GLScene.OpenGL4

GL_EXT_bindable_uniform (#342)
glUniformMatrix2dv GLScene.OpenGL4

glUniformMatrix2fv GLScene.OpenGL4

glUniformMatrix2fvARB GLScene.OpenGL4

glUniformMatrix2x3dv GLScene.OpenGL4

glUniformMatrix2x3fv GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################
glUniformMatrix2x4dv GLScene.OpenGL4

glUniformMatrix2x4fv GLScene.OpenGL4

glUniformMatrix3dv GLScene.OpenGL4

glUniformMatrix3fv GLScene.OpenGL4

glUniformMatrix3fvARB GLScene.OpenGL4

glUniformMatrix3x2dv GLScene.OpenGL4

glUniformMatrix3x2fv GLScene.OpenGL4

glUniformMatrix3x4dv GLScene.OpenGL4

glUniformMatrix3x4fv GLScene.OpenGL4

glUniformMatrix4dv GLScene.OpenGL4

glUniformMatrix4fv GLScene.OpenGL4

glUniformMatrix4fvARB GLScene.OpenGL4

glUniformMatrix4x2dv GLScene.OpenGL4

glUniformMatrix4x2fv GLScene.OpenGL4

glUniformMatrix4x3dv GLScene.OpenGL4

glUniformMatrix4x3fv GLScene.OpenGL4

glUniformSubroutinesuiv GLScene.OpenGL4

glUniformui64NV GLScene.OpenGL4

glUniformui64vNV GLScene.OpenGL4

glUnlockArraysEXT GLScene.OpenGL4

glUnmapBuffer GLScene.OpenGL4

glUnmapBufferARB GLScene.OpenGL4

gluNurbsCallbackDataEXT GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions
glUseProgram GLScene.OpenGL4

glUseProgramObjectARB GLScene.OpenGL4

GLU_VERSION_1_3 GLScene.OpenGL4

glValidateProgram GLScene.OpenGL4

glValidateProgramARB GLScene.OpenGL4

glVertexArrayRangeNV GLScene.OpenGL4

glVertexAttrib1d GLScene.OpenGL4

glVertexAttrib1dARB GLScene.OpenGL4

GL_ARB_vertex_program (ARB #26)
glVertexAttrib1dNV GLScene.OpenGL4

glVertexAttrib1dv GLScene.OpenGL4

glVertexAttrib1dvARB GLScene.OpenGL4

glVertexAttrib1dvNV GLScene.OpenGL4

glVertexAttrib1f GLScene.OpenGL4

glVertexAttrib1fARB GLScene.OpenGL4

glVertexAttrib1fNV GLScene.OpenGL4

glVertexAttrib1fv GLScene.OpenGL4

glVertexAttrib1fvARB GLScene.OpenGL4

glVertexAttrib1fvNV GLScene.OpenGL4

glVertexAttrib1s GLScene.OpenGL4

glVertexAttrib1sARB GLScene.OpenGL4

glVertexAttrib1sNV GLScene.OpenGL4

glVertexAttrib1sv GLScene.OpenGL4

glVertexAttrib1svARB GLScene.OpenGL4

glVertexAttrib1svNV GLScene.OpenGL4

glVertexAttrib2d GLScene.OpenGL4

glVertexAttrib2dARB GLScene.OpenGL4

glVertexAttrib2dNV GLScene.OpenGL4

glVertexAttrib2dv GLScene.OpenGL4

glVertexAttrib2dvARB GLScene.OpenGL4

glVertexAttrib2dvNV GLScene.OpenGL4

glVertexAttrib2f GLScene.OpenGL4

glVertexAttrib2fARB GLScene.OpenGL4

glVertexAttrib2fNV GLScene.OpenGL4

glVertexAttrib2fv GLScene.OpenGL4

glVertexAttrib2fvARB GLScene.OpenGL4

glVertexAttrib2fvNV GLScene.OpenGL4

glVertexAttrib2s GLScene.OpenGL4

glVertexAttrib2sARB GLScene.OpenGL4

glVertexAttrib2sNV GLScene.OpenGL4

glVertexAttrib2sv GLScene.OpenGL4

glVertexAttrib2svARB GLScene.OpenGL4

glVertexAttrib2svNV GLScene.OpenGL4

glVertexAttrib3d GLScene.OpenGL4

glVertexAttrib3dARB GLScene.OpenGL4

glVertexAttrib3dNV GLScene.OpenGL4

glVertexAttrib3dv GLScene.OpenGL4

glVertexAttrib3dvARB GLScene.OpenGL4

glVertexAttrib3dvNV GLScene.OpenGL4

glVertexAttrib3f GLScene.OpenGL4

glVertexAttrib3fARB GLScene.OpenGL4

glVertexAttrib3fNV GLScene.OpenGL4

glVertexAttrib3fv GLScene.OpenGL4

glVertexAttrib3fvARB GLScene.OpenGL4

glVertexAttrib3fvNV GLScene.OpenGL4

glVertexAttrib3s GLScene.OpenGL4

glVertexAttrib3sARB GLScene.OpenGL4

glVertexAttrib3sNV GLScene.OpenGL4

glVertexAttrib3sv GLScene.OpenGL4

glVertexAttrib3svARB GLScene.OpenGL4

glVertexAttrib3svNV GLScene.OpenGL4

glVertexAttrib4bv GLScene.OpenGL4

glVertexAttrib4bvARB GLScene.OpenGL4

glVertexAttrib4d GLScene.OpenGL4

glVertexAttrib4dARB GLScene.OpenGL4

glVertexAttrib4dNV GLScene.OpenGL4

glVertexAttrib4dv GLScene.OpenGL4

glVertexAttrib4dvARB GLScene.OpenGL4

glVertexAttrib4dvNV GLScene.OpenGL4

glVertexAttrib4f GLScene.OpenGL4

glVertexAttrib4fARB GLScene.OpenGL4

glVertexAttrib4fNV GLScene.OpenGL4

glVertexAttrib4fv GLScene.OpenGL4

glVertexAttrib4fvARB GLScene.OpenGL4

glVertexAttrib4fvNV GLScene.OpenGL4

glVertexAttrib4iv GLScene.OpenGL4

glVertexAttrib4ivARB GLScene.OpenGL4

glVertexAttrib4Nbv GLScene.OpenGL4

glVertexAttrib4NbvARB GLScene.OpenGL4

glVertexAttrib4Niv GLScene.OpenGL4

glVertexAttrib4NivARB GLScene.OpenGL4

glVertexAttrib4Nsv GLScene.OpenGL4

glVertexAttrib4NsvARB GLScene.OpenGL4

glVertexAttrib4Nub GLScene.OpenGL4

glVertexAttrib4NubARB GLScene.OpenGL4

glVertexAttrib4Nubv GLScene.OpenGL4

glVertexAttrib4NubvARB GLScene.OpenGL4

glVertexAttrib4Nuiv GLScene.OpenGL4

glVertexAttrib4NuivARB GLScene.OpenGL4

glVertexAttrib4Nusv GLScene.OpenGL4

glVertexAttrib4NusvARB GLScene.OpenGL4

glVertexAttrib4s GLScene.OpenGL4

glVertexAttrib4sARB GLScene.OpenGL4

glVertexAttrib4sNV GLScene.OpenGL4

glVertexAttrib4sv GLScene.OpenGL4

glVertexAttrib4svARB GLScene.OpenGL4

glVertexAttrib4svNV GLScene.OpenGL4

glVertexAttrib4ubv GLScene.OpenGL4

glVertexAttrib4ubvARB GLScene.OpenGL4

glVertexAttrib4ubvNV GLScene.OpenGL4

glVertexAttrib4uiv GLScene.OpenGL4

glVertexAttrib4uivARB GLScene.OpenGL4

glVertexAttrib4usv GLScene.OpenGL4

glVertexAttrib4usvARB GLScene.OpenGL4

glVertexAttribDivisorARB GLScene.OpenGL4

GL_ARB_instanced_arrays (ARB #49)
glVertexAttribFormatNV GLScene.OpenGL4

glVertexAttribI1i GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################
glVertexAttribI1iEXT GLScene.OpenGL4

GL_EXT_gpu_shader4 (EXT #326)
glVertexAttribI1iv GLScene.OpenGL4

glVertexAttribI1ivEXT GLScene.OpenGL4

glVertexAttribI1ui GLScene.OpenGL4

glVertexAttribI1uiEXT GLScene.OpenGL4

glVertexAttribI1uiv GLScene.OpenGL4

glVertexAttribI1uivEXT GLScene.OpenGL4

glVertexAttribI2i GLScene.OpenGL4

glVertexAttribI2iEXT GLScene.OpenGL4

glVertexAttribI2iv GLScene.OpenGL4

glVertexAttribI2ivEXT GLScene.OpenGL4

glVertexAttribI2ui GLScene.OpenGL4

glVertexAttribI2uiEXT GLScene.OpenGL4

glVertexAttribI2uiv GLScene.OpenGL4

glVertexAttribI2uivEXT GLScene.OpenGL4

glVertexAttribI3i GLScene.OpenGL4

glVertexAttribI3iEXT GLScene.OpenGL4

glVertexAttribI3iv GLScene.OpenGL4

glVertexAttribI3ivEXT GLScene.OpenGL4

glVertexAttribI3ui GLScene.OpenGL4

glVertexAttribI3uiEXT GLScene.OpenGL4

glVertexAttribI3uiv GLScene.OpenGL4

glVertexAttribI3uivEXT GLScene.OpenGL4

glVertexAttribI4bv GLScene.OpenGL4

glVertexAttribI4bvEXT GLScene.OpenGL4

glVertexAttribI4i GLScene.OpenGL4

glVertexAttribI4iEXT GLScene.OpenGL4

glVertexAttribI4iv GLScene.OpenGL4

glVertexAttribI4ivEXT GLScene.OpenGL4

glVertexAttribI4sv GLScene.OpenGL4

glVertexAttribI4svEXT GLScene.OpenGL4

glVertexAttribI4ubv GLScene.OpenGL4

glVertexAttribI4ubvEXT GLScene.OpenGL4

glVertexAttribI4ui GLScene.OpenGL4

glVertexAttribI4uiEXT GLScene.OpenGL4

glVertexAttribI4uiv GLScene.OpenGL4

glVertexAttribI4uivEXT GLScene.OpenGL4

glVertexAttribI4usv GLScene.OpenGL4

glVertexAttribI4usvEXT GLScene.OpenGL4

glVertexAttribIFormatNV GLScene.OpenGL4

glVertexAttribIPointer GLScene.OpenGL4

glVertexAttribIPointerEXT GLScene.OpenGL4

glVertexAttribP1ui GLScene.OpenGL4

glVertexAttribP1uiv GLScene.OpenGL4

glVertexAttribP2ui GLScene.OpenGL4

glVertexAttribP2uiv GLScene.OpenGL4

glVertexAttribP3ui GLScene.OpenGL4

glVertexAttribP3uiv GLScene.OpenGL4

glVertexAttribP4ui GLScene.OpenGL4

glVertexAttribP4uiv GLScene.OpenGL4

glVertexAttribPointer GLScene.OpenGL4

glVertexAttribPointerARB GLScene.OpenGL4

glVertexAttribPointerNV GLScene.OpenGL4

glVertexAttribs1dvNV GLScene.OpenGL4

glVertexAttribs1fvNV GLScene.OpenGL4

glVertexAttribs1svNV GLScene.OpenGL4

glVertexAttribs2dvNV GLScene.OpenGL4

glVertexAttribs2fvNV GLScene.OpenGL4

glVertexAttribs2svNV GLScene.OpenGL4

glVertexAttribs3dvNV GLScene.OpenGL4

glVertexAttribs3fvNV GLScene.OpenGL4

glVertexAttribs3svNV GLScene.OpenGL4

glVertexAttribs4dvNV GLScene.OpenGL4

glVertexAttribs4fvNV GLScene.OpenGL4

glVertexAttribs4svNV GLScene.OpenGL4

glVertexAttribs4ubvNV GLScene.OpenGL4

glVertexBlendARB GLScene.OpenGL4

glVertexFormatNV GLScene.OpenGL4

glVertexP2ui GLScene.OpenGL4

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)
glVertexP2uiv GLScene.OpenGL4

glVertexP3ui GLScene.OpenGL4

glVertexP3uiv GLScene.OpenGL4

glVertexP4ui GLScene.OpenGL4

glVertexP4uiv GLScene.OpenGL4

glWaitSync GLScene.OpenGL4

glWeightbvARB GLScene.OpenGL4

GL_ARB_vertex_blend (ARB #15) {deprecated?}
glWeightdvARB GLScene.OpenGL4

glWeightfvARB GLScene.OpenGL4

glWeightivARB GLScene.OpenGL4

glWeightPointerARB GLScene.OpenGL4

glWeightsvARB GLScene.OpenGL4

glWeightubvARB GLScene.OpenGL4

glWeightuivARB GLScene.OpenGL4

glWeightusvARB GLScene.OpenGL4

glWindowPos2d GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)
glWindowPos2dARB GLScene.OpenGL4

GL_ARB_window_pos (ARB #25)
glWindowPos2dv GLScene.OpenGL4

deprecated;
glWindowPos2dvARB GLScene.OpenGL4

glWindowPos2f GLScene.OpenGL4

deprecated;
glWindowPos2fARB GLScene.OpenGL4

glWindowPos2fv GLScene.OpenGL4

deprecated;
glWindowPos2fvARB GLScene.OpenGL4

glWindowPos2i GLScene.OpenGL4

deprecated;
glWindowPos2iARB GLScene.OpenGL4

glWindowPos2iv GLScene.OpenGL4

deprecated;
glWindowPos2ivARB GLScene.OpenGL4

glWindowPos2s GLScene.OpenGL4

deprecated;
glWindowPos2sARB GLScene.OpenGL4

glWindowPos2sv GLScene.OpenGL4

deprecated;
glWindowPos2svARB GLScene.OpenGL4

glWindowPos3d GLScene.OpenGL4

deprecated;
glWindowPos3dARB GLScene.OpenGL4

glWindowPos3dv GLScene.OpenGL4

deprecated;
glWindowPos3dvARB GLScene.OpenGL4

glWindowPos3f GLScene.OpenGL4

deprecated;
glWindowPos3fARB GLScene.OpenGL4

glWindowPos3fv GLScene.OpenGL4

deprecated;
glWindowPos3fvARB GLScene.OpenGL4

glWindowPos3i GLScene.OpenGL4

deprecated;
glWindowPos3iARB GLScene.OpenGL4

glWindowPos3iv GLScene.OpenGL4

deprecated;
glWindowPos3ivARB GLScene.OpenGL4

glWindowPos3s GLScene.OpenGL4

deprecated;
glWindowPos3sARB GLScene.OpenGL4

glWindowPos3sv GLScene.OpenGL4

deprecated;
glWindowPos3svARB GLScene.OpenGL4

GLX_ARB_context_flush_control GLScene.OpenGL4

GLX
GLX_ARB_create_context GLScene.OpenGL4

GLX
GLX_ARB_create_context_profile GLScene.OpenGL4

GLX
GLX_ARB_create_context_robustness GLScene.OpenGL4

GLX
GLX_ARB_fbconfig_float GLScene.OpenGL4

GLX
GLX_ARB_framebuffer_sRGB GLScene.OpenGL4

GLX
GLX_ARB_get_proc_address GLScene.OpenGL4

GLX
GLX_ARB_multisample GLScene.OpenGL4

GLX
GLX_ARB_vertex_buffer_object GLScene.OpenGL4

GLX
GLX_EXT_create_context_es2_profile GLScene.OpenGL4

GLX
GLX_EXT_fbconfig_packed_float GLScene.OpenGL4

GLX
GLX_EXT_framebuffer_sRGB GLScene.OpenGL4

GLX
GLX_EXT_import_context GLScene.OpenGL4

GLX
GLX_EXT_swap_control GLScene.OpenGL4

GLX
GLX_EXT_texture_from_pixmap GLScene.OpenGL4

GLX
GLX_EXT_visual_info GLScene.OpenGL4

GLX
GLX_EXT_visual_rating GLScene.OpenGL4

GLX
GLX_VERSION_1_4 GLScene.OpenGL4

GLX
GL_3DFX_multisample GLScene.OpenGL4

GL_3DFX_tbuffer GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1 GLScene.OpenGL4

GL_AMD_conservative_depth GLScene.OpenGL4

GL 4.6
GL_AMD_debug_output GLScene.OpenGL4

GL 4.6
GL_AMD_depth_clamp_separate GLScene.OpenGL4

GL 4.6
GL_AMD_draw_buffers_blend GLScene.OpenGL4

GL 4.6
GL_AMD_name_gen_delete GLScene.OpenGL4

GL 4.6
GL_AMD_performance_monitor GLScene.OpenGL4

GL 4.6
GL_AMD_pinned_memory GLScene.OpenGL4

GL 4.3
GL_AMD_query_buffer_object GLScene.OpenGL4

GL 4.3
GL_AMD_seamless_cubemap_per_texture GLScene.OpenGL4

GL 4.6
GL_AMD_shader_stencil_export GLScene.OpenGL4

GL 4.6
GL_AMD_stencil_operation_extended GLScene.OpenGL4

GL 4.3
GL_AMD_texture_texture4 GLScene.OpenGL4

GL 4.6
GL_AMD_transform_feedback3_lines_triangles GLScene.OpenGL4

GL 4.6
GL_AMD_vertex_shader_layer GLScene.OpenGL4

GL 4.3
GL_AMD_vertex_shader_tesselator GLScene.OpenGL4

GL 4.6
GL_AMD_vertex_shader_viewport_index GLScene.OpenGL4

GL 4.3
GL_APPLE_aux_depth_stencil GLScene.OpenGL4

GL_APPLE_client_storage GLScene.OpenGL4

GL_APPLE_element_array GLScene.OpenGL4

GL_APPLE_fence GLScene.OpenGL4

GL_APPLE_float_pixels GLScene.OpenGL4

GL_APPLE_object_purgeable GLScene.OpenGL4

GL_APPLE_rgb_422 GLScene.OpenGL4

GL_APPLE_row_bytes GLScene.OpenGL4

GL_APPLE_specular_vector GLScene.OpenGL4

GL_APPLE_texture_range GLScene.OpenGL4

GL_APPLE_transform_hint GLScene.OpenGL4

GL_APPLE_vertex_array_object GLScene.OpenGL4

GL_APPLE_vertex_array_range GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators GLScene.OpenGL4

GL_APPLE_ycbcr_422 GLScene.OpenGL4

GL_ARB_arrays_of_arrays GLScene.OpenGL4

GL 4.3
GL_ARB_base_instance GLScene.OpenGL4

GL 4.2
GL_ARB_bindless_texture GLScene.OpenGL4

GL 4.4
GL_ARB_blend_func_extended GLScene.OpenGL4

GL_ARB_buffer_storage GLScene.OpenGL4

GL 4.4
GL_ARB_clear_buffer_object GLScene.OpenGL4

GL 4.3
GL_ARB_clear_texture GLScene.OpenGL4

GL 4.4
GL_ARB_clip_control GLScene.OpenGL4

GL 4.5
GL_ARB_cl_event GLScene.OpenGL4

GL 4.6
GL_ARB_color_buffer_float GLScene.OpenGL4

GL_ARB_compatibility GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage GLScene.OpenGL4

GL 4.2
GL_ARB_compute_shader GLScene.OpenGL4

GL 4.3
GL_ARB_compute_variable_group_size GLScene.OpenGL4

GL 4.6
GL_ARB_conditional_render_inverted GLScene.OpenGL4

GL 4.5
GL_ARB_conservative_depth GLScene.OpenGL4

GL 4.2
GL_ARB_copy_buffer GLScene.OpenGL4

GL_ARB_copy_image GLScene.OpenGL4

GL 4.3
GL_ARB_cull_distance GLScene.OpenGL4

GL 4.5
GL_ARB_debug_output GLScene.OpenGL4

GL 4.6
GL_ARB_depth_buffer_float GLScene.OpenGL4

GL_ARB_depth_clamp GLScene.OpenGL4

GL_ARB_depth_texture GLScene.OpenGL4

GL_ARB_derivative_control GLScene.OpenGL4

GL 4.5
GL_ARB_direct_state_access GLScene.OpenGL4

GL 4.5
GL_ARB_draw_buffers GLScene.OpenGL4

GL_ARB_draw_buffers_blend GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex GLScene.OpenGL4

GL_ARB_draw_indirect GLScene.OpenGL4

GL_ARB_draw_instanced GLScene.OpenGL4

GL_ARB_enhanced_layouts GLScene.OpenGL4

GL 4.4
GL_ARB_ES2_compatibility GLScene.OpenGL4

GL_ARB_ES3_1_compatibility GLScene.OpenGL4

GL 4.5
GL_ARB_ES3_2_compatibility GLScene.OpenGL4

GL_ARB_ES3_compatibility GLScene.OpenGL4

GL 4.3
GL_ARB_explicit_attrib_location GLScene.OpenGL4

GL_ARB_explicit_uniform_location GLScene.OpenGL4

GL 4.3
GL_ARB_fragment_coord_conventions GLScene.OpenGL4

GL_ARB_fragment_layer_viewport GLScene.OpenGL4

GL 4.3
GL_ARB_fragment_program GLScene.OpenGL4

GL_ARB_fragment_program_shadow GLScene.OpenGL4

GL_ARB_fragment_shader GLScene.OpenGL4

GL_ARB_fragment_shader_interlock GLScene.OpenGL4

GL_ARB_framebuffer_no_attachments GLScene.OpenGL4

GL 4.3
GL_ARB_framebuffer_object GLScene.OpenGL4

GL_ARB_framebuffer_sRGB GLScene.OpenGL4

GL_ARB_geometry_shader4 GLScene.OpenGL4

GL_ARB_get_program_binary GLScene.OpenGL4

GL_ARB_get_texture_sub_image GLScene.OpenGL4

GL 4.5
GL_ARB_gl_spirv GLScene.OpenGL4

GL 4.6
GL_ARB_gpu_shader5 GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 GLScene.OpenGL4

GL_ARB_gpu_shader_int64 GLScene.OpenGL4

GL_ARB_half_float_pixel GLScene.OpenGL4

GL_ARB_half_float_vertex GLScene.OpenGL4

GL_ARB_imaging GLScene.OpenGL4

GL_ARB_indirect_parameters GLScene.OpenGL4

GL 4.6
GL_ARB_instanced_arrays GLScene.OpenGL4

GL_ARB_internalformat_query GLScene.OpenGL4

GL 4.2
GL_ARB_internalformat_query2 GLScene.OpenGL4

GL 4.3
GL_ARB_invalidate_subdata GLScene.OpenGL4

GL 4.3
GL_ARB_map_buffer_alignment GLScene.OpenGL4

GL 4.2
GL_ARB_map_buffer_range GLScene.OpenGL4

GL_ARB_matrix_palette GLScene.OpenGL4

GL_ARB_multisample GLScene.OpenGL4

GL_ARB_multitexture GLScene.OpenGL4

GL_ARB_multi_bind GLScene.OpenGL4

GL 4.4
GL_ARB_multi_draw_indirect GLScene.OpenGL4

GL 4.3
GL_ARB_occlusion_query GLScene.OpenGL4

GL_ARB_occlusion_query2 GLScene.OpenGL4

GL_ARB_parallel_shader_compile GLScene.OpenGL4

GL_ARB_pipeline_statistics_query GLScene.OpenGL4

GL 4.6
GL_ARB_pixel_buffer_object GLScene.OpenGL4

GL_ARB_point_parameters GLScene.OpenGL4

GL_ARB_point_sprite GLScene.OpenGL4

GL_ARB_polygon_offset_clamp GLScene.OpenGL4

GL 4.6
GL_ARB_post_depth_coverage GLScene.OpenGL4

GL_ARB_program_interface_query GLScene.OpenGL4

GL 4.3
GL_ARB_provoking_vertex GLScene.OpenGL4

GL_ARB_query_buffer_object GLScene.OpenGL4

GL 4.4
GL_ARB_robustness GLScene.OpenGL4

GL 4.6
GL_ARB_robust_buffer_access_behavior GLScene.OpenGL4

GL 4.3
GL_ARB_sampler_objects GLScene.OpenGL4

GL_ARB_sample_locations GLScene.OpenGL4

GL_ARB_sample_shading GLScene.OpenGL4

GL_ARB_seamless_cube_map GLScene.OpenGL4

GL_ARB_separate_shader_objects GLScene.OpenGL4

GL_ARB_shader_atomic_counters GLScene.OpenGL4

GL 4.2
GL_ARB_shader_atomic_counter_ops GLScene.OpenGL4

GL 4.6
GL_ARB_shader_ballot GLScene.OpenGL4

GL_ARB_shader_bit_encoding GLScene.OpenGL4

GL_ARB_shader_clock GLScene.OpenGL4

GL_ARB_shader_draw_parameters GLScene.OpenGL4

GL 4.6
GL_ARB_shader_group_vote GLScene.OpenGL4

GL 4.6
GL_ARB_shader_image_load_store GLScene.OpenGL4

GL 4.2
GL_ARB_shader_image_size GLScene.OpenGL4

GL 4.3
GL_ARB_shader_objects GLScene.OpenGL4

GL_ARB_shader_precision GLScene.OpenGL4

GL_ARB_shader_stencil_export GLScene.OpenGL4

GL 4.6
GL_ARB_shader_storage_buffer_object GLScene.OpenGL4

GL 4.3
GL_ARB_shader_subroutine GLScene.OpenGL4

GL_ARB_shader_texture_image_samples GLScene.OpenGL4

GL 4.5
GL_ARB_shader_texture_lod GLScene.OpenGL4

GL_ARB_shader_viewport_layer_array GLScene.OpenGL4

GL_ARB_shading_language_100 GLScene.OpenGL4

GL_ARB_shading_language_420pack GLScene.OpenGL4

GL 4.2
GL_ARB_shading_language_include GLScene.OpenGL4

GL_ARB_shading_language_packing GLScene.OpenGL4

GL 4.2
GL_ARB_shadow GLScene.OpenGL4

GL_ARB_shadow_ambient GLScene.OpenGL4

GL_ARB_sparse_texture GLScene.OpenGL4

GL 4.4
GL_ARB_sparse_texture2 GLScene.OpenGL4

GL_ARB_sparse_texture_clamp GLScene.OpenGL4

GL_ARB_spirv_extensions GLScene.OpenGL4

GL 4.6
GL_ARB_stencil_texturing GLScene.OpenGL4

GL 4.3
GL_ARB_sync GLScene.OpenGL4

GL_ARB_tessellation_shader GLScene.OpenGL4

GL_ARB_texture_barrier GLScene.OpenGL4

GL 4.5
GL_ARB_texture_border_clamp GLScene.OpenGL4

GL_ARB_texture_buffer_object GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32 GLScene.OpenGL4

GL_ARB_texture_buffer_range GLScene.OpenGL4

GL 4.3
GL_ARB_texture_compression GLScene.OpenGL4

GL_ARB_texture_compression_bptc GLScene.OpenGL4

GL_ARB_texture_compression_rgtc GLScene.OpenGL4

GL_ARB_texture_cube_map GLScene.OpenGL4

GL_ARB_texture_cube_map_array GLScene.OpenGL4

GL_ARB_texture_env_add GLScene.OpenGL4

GL_ARB_texture_env_combine GLScene.OpenGL4

GL_ARB_texture_env_crossbar GLScene.OpenGL4

GL_ARB_texture_env_dot3 GLScene.OpenGL4

GL_ARB_texture_filter_anisotropic GLScene.OpenGL4

GL 4.6
GL_ARB_texture_filter_minmax GLScene.OpenGL4

GL_ARB_texture_float GLScene.OpenGL4

GL_ARB_texture_gather GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat GLScene.OpenGL4

GL_ARB_texture_mirror_clamp_to_edge GLScene.OpenGL4

GL 4.4
GL_ARB_texture_multisample GLScene.OpenGL4

GL_ARB_texture_non_power_of_two GLScene.OpenGL4

GL_ARB_texture_query_levels GLScene.OpenGL4

GL 4.3
GL_ARB_texture_query_lod GLScene.OpenGL4

GL_ARB_texture_rectangle GLScene.OpenGL4

GL_ARB_texture_rg GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui GLScene.OpenGL4

GL_ARB_texture_stencil8 GLScene.OpenGL4

GL 4.4
GL_ARB_texture_storage GLScene.OpenGL4

GL 4.2
GL_ARB_texture_storage_multisample GLScene.OpenGL4

GL 4.3
GL_ARB_texture_swizzle GLScene.OpenGL4

GL_ARB_texture_view GLScene.OpenGL4

GL 4.3
GL_ARB_timer_query GLScene.OpenGL4

GL_ARB_transform_feedback2 GLScene.OpenGL4

GL_ARB_transform_feedback3 GLScene.OpenGL4

GL_ARB_transform_feedback_instanced GLScene.OpenGL4

GL 4.2
GL_ARB_transform_feedback_overflow_query GLScene.OpenGL4

GL 4.6
GL_ARB_transpose_matrix GLScene.OpenGL4

GL_ARB_uniform_buffer_object GLScene.OpenGL4

GL_ARB_vertex_array_bgra GLScene.OpenGL4

GL_ARB_vertex_array_object GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit GLScene.OpenGL4

GL_ARB_vertex_attrib_binding GLScene.OpenGL4

GL 4.3
GL_ARB_vertex_blend GLScene.OpenGL4

GL_ARB_vertex_buffer_object GLScene.OpenGL4

GL_ARB_vertex_program GLScene.OpenGL4

GL_ARB_vertex_shader GLScene.OpenGL4

GL_ARB_vertex_type_10f_11f_11f_rev GLScene.OpenGL4

GL 4.4
GL_ARB_vertex_type_2_10_10_10_rev GLScene.OpenGL4

GL_ARB_viewport_array GLScene.OpenGL4

GL_ARB_window_pos GLScene.OpenGL4

GL_ATI_draw_buffers GLScene.OpenGL4

GL 4.6
GL_ATI_element_array GLScene.OpenGL4

GL 4.6
GL_ATI_envmap_bumpmap GLScene.OpenGL4

GL 4.6
GL_ATI_fragment_shader GLScene.OpenGL4

GL 4.6
GL_ATI_map_object_buffer GLScene.OpenGL4

GL 4.6
GL_ATI_meminfo GLScene.OpenGL4

GL 4.6
GL_ATI_pn_triangles GLScene.OpenGL4

GL 4.6
GL_ATI_separate_stencil GLScene.OpenGL4

GL 4.6
GL_ATI_texture_env_combine3 GLScene.OpenGL4

GL 4.6
GL_ATI_texture_float GLScene.OpenGL4

GL 4.6
GL_ATI_texture_mirror_once GLScene.OpenGL4

GL 4.6
GL_ATI_text_fragment_shader GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_array_object GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_attrib_array_object GLScene.OpenGL4

GL 4.6
GL_ATI_vertex_streams GLScene.OpenGL4

GL 4.6
GL_EXT_422_pixels GLScene.OpenGL4

GL 4.6
GL_EXT_abgr GLScene.OpenGL4

GL 4.6
GL_EXT_bgra GLScene.OpenGL4

GL 4.6
GL_EXT_bindable_uniform GLScene.OpenGL4

GL 4.6
GL_EXT_blend_color GLScene.OpenGL4

GL 4.6
GL_EXT_blend_equation_separate GLScene.OpenGL4

GL 4.6
GL_EXT_blend_func_separate GLScene.OpenGL4

GL 4.6
GL_EXT_blend_logic_op GLScene.OpenGL4

GL 4.6
GL_EXT_blend_minmax GLScene.OpenGL4

GL 4.6
GL_EXT_blend_subtract GLScene.OpenGL4

GL 4.6
GL_EXT_clip_volume_hint GLScene.OpenGL4

GL 4.6
GL_EXT_cmyka GLScene.OpenGL4

GL 4.6
GL_EXT_color_matrix GLScene.OpenGL4

GL 4.6
GL_EXT_color_subtable GLScene.OpenGL4

GL 4.6
GL_EXT_compiled_vertex_array GLScene.OpenGL4

GL 4.6
GL_EXT_convolution GLScene.OpenGL4

GL 4.6
GL_EXT_coordinate_frame GLScene.OpenGL4

GL 4.6
GL_EXT_copy_texture GLScene.OpenGL4

GL 4.6
GL_EXT_cull_vertex GLScene.OpenGL4

GL 4.6
GL_EXT_depth_bounds_test GLScene.OpenGL4

GL 4.6
GL_EXT_direct_state_access GLScene.OpenGL4

GL 4.6
GL_EXT_draw_buffers2 GLScene.OpenGL4

GL 4.6
GL_EXT_draw_instanced GLScene.OpenGL4

GL 4.6
GL_EXT_draw_range_elements GLScene.OpenGL4

GL 4.6
GL_EXT_fog_coord GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_blit GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_multisample GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_framebuffer_sRGB GLScene.OpenGL4

GL 4.6
GL_EXT_geometry_shader4 GLScene.OpenGL4

GL 4.6
GL_EXT_gpu_program_parameters GLScene.OpenGL4

GL 4.6
GL_EXT_gpu_shader4 GLScene.OpenGL4

GL 4.6
GL_EXT_histogram GLScene.OpenGL4

GL 4.6
GL_EXT_index_array_formats GLScene.OpenGL4

GL 4.6
GL_EXT_index_func GLScene.OpenGL4

GL 4.6
GL_EXT_index_material GLScene.OpenGL4

GL 4.6
GL_EXT_index_texture GLScene.OpenGL4

GL 4.6
GL_EXT_light_texture GLScene.OpenGL4

GL 4.6
GL_EXT_misc_attribute GLScene.OpenGL4

GL 4.6
GL_EXT_multisample GLScene.OpenGL4

GL 4.6
GL_EXT_multi_draw_arrays GLScene.OpenGL4

GL 4.6
GL_EXT_packed_depth_stencil GLScene.OpenGL4

GL 4.6
GL_EXT_packed_float GLScene.OpenGL4

GL 4.6
GL_EXT_packed_pixels GLScene.OpenGL4

GL 4.6
GL_EXT_paletted_texture GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_buffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_transform GLScene.OpenGL4

GL 4.6
GL_EXT_pixel_transform_color_table GLScene.OpenGL4

GL 4.6
GL_EXT_point_parameters GLScene.OpenGL4

GL 4.6
GL_EXT_polygon_offset GLScene.OpenGL4

GL 4.6
GL_EXT_provoking_vertex GLScene.OpenGL4

GL 4.6
GL_EXT_rescale_normal GLScene.OpenGL4

GL 4.6
GL_EXT_secondary_color GLScene.OpenGL4

GL 4.6
GL_EXT_separate_shader_objects GLScene.OpenGL4

GL 4.6
GL_EXT_separate_specular_color GLScene.OpenGL4

GL 4.6
GL_EXT_shader_image_load_store GLScene.OpenGL4

GL 4.6
GL_EXT_shadow_funcs GLScene.OpenGL4

GL 4.6
GL_EXT_shared_texture_palette GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_clear_tag GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_two_side GLScene.OpenGL4

GL 4.6
GL_EXT_stencil_wrap GLScene.OpenGL4

GL 4.6
GL_EXT_subtexture GLScene.OpenGL4

GL 4.6
GL_EXT_texture GLScene.OpenGL4

GL 4.6
GL_EXT_texture3D GLScene.OpenGL4

GL 4.6
GL_EXT_texture_array GLScene.OpenGL4

GL 4.6
GL_EXT_texture_buffer_object GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_dxt1 GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_latc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_rgtc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_compression_s3tc GLScene.OpenGL4

GL 4.6
GL_EXT_texture_cube_map GLScene.OpenGL4

GL 4.6
GL_EXT_texture_edge_clamp GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_add GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_combine GLScene.OpenGL4

GL 4.6
GL_EXT_texture_env_dot3 GLScene.OpenGL4

GL 4.6
GL_EXT_texture_filter_anisotropic GLScene.OpenGL4

GL 4.6
GL_EXT_texture_integer GLScene.OpenGL4

GL 4.6
GL_EXT_texture_lod_bias GLScene.OpenGL4

GL 4.6
GL_EXT_texture_mirror_clamp GLScene.OpenGL4

GL 4.6
GL_EXT_texture_object GLScene.OpenGL4

GL 4.6
GL_EXT_texture_perturb_normal GLScene.OpenGL4

GL 4.6
GL_EXT_texture_rectangle GLScene.OpenGL4

GL 4.6
GL_EXT_texture_shared_exponent GLScene.OpenGL4

GL 4.6
GL_EXT_texture_snorm GLScene.OpenGL4

GL 4.6
GL_EXT_texture_sRGB GLScene.OpenGL4

GL 4.6
GL_EXT_texture_sRGB_decode GLScene.OpenGL4

GL 4.6
GL_EXT_texture_swizzle GLScene.OpenGL4

GL 4.6
GL_EXT_timer_query GLScene.OpenGL4

GL 4.6
GL_EXT_transform_feedback GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_array GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_array_bgra GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_attrib_64bit GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_shader GLScene.OpenGL4

GL 4.6
GL_EXT_vertex_weighting GLScene.OpenGL4

GL 4.6
GL_FfdMaskSGIX GLScene.OpenGL4

GL 4.6
GL_HP_convolution_border_modes GLScene.OpenGL4

GL 4.6
GL_HP_image_transform GLScene.OpenGL4

GL 4.6
GL_HP_occlusion_test GLScene.OpenGL4

GL 4.6
GL_HP_texture_lighting GLScene.OpenGL4

GL 4.6
GL_IBM_cull_vertex GLScene.OpenGL4

GL 4.6
GL_IBM_multimode_draw_arrays GLScene.OpenGL4

GL 4.6
GL_IBM_rasterpos_clip GLScene.OpenGL4

GL 4.6
GL_IBM_texture_mirrored_repeat GLScene.OpenGL4

GL 4.6
GL_IBM_vertex_array_lists GLScene.OpenGL4

GL 4.6
GL_INGR_blend_func_separate GLScene.OpenGL4

GL 4.6
GL_INGR_color_clamp GLScene.OpenGL4

GL 4.6
GL_INGR_interlace_read GLScene.OpenGL4

GL 4.6
GL_INGR_palette_buffer GLScene.OpenGL4

GL 4.6
GL_INTEL_framebuffer_CMAA GLScene.OpenGL4

GL 4.6
GL_INTEL_parallel_arrays GLScene.OpenGL4

GL 4.6
GL_INTEL_texture_scissor GLScene.OpenGL4

GL 4.6
GL_KHR_blend_equation_advanced GLScene.OpenGL4

GL 4.5
GL_KHR_blend_equation_advanced_coherent GLScene.OpenGL4

GL 4.5
GL_KHR_context_flush_control GLScene.OpenGL4

GL 4.5
GL_KHR_debug GLScene.OpenGL4

GL 4.3
GL_KHR_no_error GLScene.OpenGL4

GL 4.6
GL_KHR_robustness GLScene.OpenGL4

GL 4.5
GL_KHR_robust_buffer_access_behavior GLScene.OpenGL4

GL 4.5
GL_MESA_resize_buffers GLScene.OpenGL4

GL 4.6
GL_MESA_window_pos GLScene.OpenGL4

GL 4.6
GL_NV_bindless_texture GLScene.OpenGL4

GL 4.3
GL_NV_blend_square GLScene.OpenGL4

GL 4.6
GL_NV_conditional_render GLScene.OpenGL4

GL 4.6
GL_NV_conservative_raster GLScene.OpenGL4

GL 4.6
GL_NV_conservative_raster_dilate GLScene.OpenGL4

GL 4.6
GL_NV_copy_depth_to_color GLScene.OpenGL4

GL 4.6
GL_NV_copy_image GLScene.OpenGL4

GL 4.6
GL_NV_depth_buffer_float GLScene.OpenGL4

GL 4.6
GL_NV_depth_clamp GLScene.OpenGL4

GL 4.6
GL_NV_evaluators GLScene.OpenGL4

GL 4.6
GL_NV_explicit_multisample GLScene.OpenGL4

GL 4.6
GL_NV_fence GLScene.OpenGL4

GL 4.6
GL_NV_float_buffer GLScene.OpenGL4

GL 4.6
GL_NV_fog_distance GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program2 GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program4 GLScene.OpenGL4

GL 4.6
GL_NV_fragment_program_option GLScene.OpenGL4

GL 4.6
GL_NV_framebuffer_multisample_coverage GLScene.OpenGL4

GL 4.6
GL_NV_geometry_program4 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_program4 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_program5 GLScene.OpenGL4

GL 4.6
GL_NV_gpu_shader5 GLScene.OpenGL4

GL 4.6
GL_NV_half_float GLScene.OpenGL4

GL 4.6
GL_NV_light_max_exponent GLScene.OpenGL4

GL 4.6
GL_NV_multisample_coverage GLScene.OpenGL4

GL 4.6
GL_NV_multisample_filter_hint GLScene.OpenGL4

GL 4.6
GL_NV_occlusion_query GLScene.OpenGL4

GL 4.6
GL_NV_packed_depth_stencil GLScene.OpenGL4

GL 4.6
GL_NV_parameter_buffer_object GLScene.OpenGL4

GL 4.6
GL_NV_parameter_buffer_object2 GLScene.OpenGL4

GL 4.6
GL_NV_path_rendering GLScene.OpenGL4

GL 4.3
GL_NV_pixel_data_range GLScene.OpenGL4

GL 4.6
GL_NV_point_sprite GLScene.OpenGL4

GL 4.6
GL_NV_present_video GLScene.OpenGL4

GL 4.6
GL_NV_primitive_restart GLScene.OpenGL4

GL 4.6
GL_NV_register_combiners GLScene.OpenGL4

GL 4.6
GL_NV_register_combiners2 GLScene.OpenGL4

GL 4.6
GL_NV_shader_atomic_float GLScene.OpenGL4

GL 4.3
GL_NV_shader_buffer_load GLScene.OpenGL4

GL 4.6
GL_NV_shader_buffer_store GLScene.OpenGL4

GL 4.6
GL_NV_tessellation_program5 GLScene.OpenGL4

GL 4.6
GL_NV_texgen_emboss GLScene.OpenGL4

GL 4.6
GL_NV_texgen_reflection GLScene.OpenGL4

GL 4.6
GL_NV_texture_barrier GLScene.OpenGL4

GL 4.6
GL_NV_texture_compression_vtc GLScene.OpenGL4

GL 4.6
GL_NV_texture_env_combine4 GLScene.OpenGL4

GL 4.6
GL_NV_texture_expand_normal GLScene.OpenGL4

GL 4.6
GL_NV_texture_rectangle GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader2 GLScene.OpenGL4

GL 4.6
GL_NV_texture_shader3 GLScene.OpenGL4

GL 4.6
GL_NV_transform_feedback GLScene.OpenGL4

GL 4.6
GL_NV_transform_feedback2 GLScene.OpenGL4

GL 4.6
GL_NV_vdpau_interop GLScene.OpenGL4

GL 4.6
GL_NV_vertex_array_range GLScene.OpenGL4

GL 4.6
GL_NV_vertex_array_range2 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_attrib_integer_64bit GLScene.OpenGL4

GL 4.6
GL_NV_vertex_buffer_unified_memory GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program1_1 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program2 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program2_option GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program3 GLScene.OpenGL4

GL 4.6
GL_NV_vertex_program4 GLScene.OpenGL4

GL 4.6
GL_NV_video_capture GLScene.OpenGL4

GL 4.6
GL_OML_interlace GLScene.OpenGL4

GL 4.6
GL_OML_resample GLScene.OpenGL4

GL 4.6
GL_OML_subsample GLScene.OpenGL4

GL 4.6
GL_OVR_multiview GLScene.OpenGL4

GL 4.6
GL_OVR_multiview2 GLScene.OpenGL4

GL 4.6
GL_PGI_misc_hints GLScene.OpenGL4

GL 4.6
GL_PGI_vertex_hints GLScene.OpenGL4

GL 4.6
GL_REND_screen_coordinates GLScene.OpenGL4

GL 4.6
GL_S3_s3tc GLScene.OpenGL4

GL 4.6
GL_SGIS_detail_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_fog_function GLScene.OpenGL4

GL 4.6
GL_SGIS_generate_mipmap GLScene.OpenGL4

GL 4.6
GL_SGIS_multisample GLScene.OpenGL4

GL 4.6
GL_SGIS_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_point_line_texgen GLScene.OpenGL4

GL 4.6
GL_SGIS_point_parameters GLScene.OpenGL4

GL 4.6
GL_SGIS_sharpen_texture GLScene.OpenGL4

GL 4.6
GL_SGIS_texture4D GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_border_clamp GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_color_mask GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_edge_clamp GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_filter4 GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_lod GLScene.OpenGL4

GL 4.6
GL_SGIS_texture_select GLScene.OpenGL4

GL 4.6
GL_SGIX_async GLScene.OpenGL4

GL 4.6
GL_SGIX_async_histogram GLScene.OpenGL4

GL 4.6
GL_SGIX_async_pixel GLScene.OpenGL4

GL 4.6
GL_SGIX_blend_alpha_minmax GLScene.OpenGL4

GL 4.6
GL_SGIX_calligraphic_fragment GLScene.OpenGL4

GL 4.6
GL_SGIX_clipmap GLScene.OpenGL4

GL 4.6
GL_SGIX_convolution_accuracy GLScene.OpenGL4

GL 4.6
GL_SGIX_depth_pass_instrument GLScene.OpenGL4

GL 4.6
GL_SGIX_depth_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_flush_raster GLScene.OpenGL4

GL 4.6
GL_SGIX_fog_offset GLScene.OpenGL4

GL 4.6
GL_SGIX_fog_scale GLScene.OpenGL4

GL 4.6
GL_SGIX_fragment_lighting GLScene.OpenGL4

GL 4.6
GL_SGIX_framezoom GLScene.OpenGL4

GL 4.6
GL_SGIX_igloo_interface GLScene.OpenGL4

GL 4.6
GL_SGIX_impact_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_instruments GLScene.OpenGL4

GL 4.6
GL_SGIX_interlace GLScene.OpenGL4

GL 4.6
GL_SGIX_ir_instrument1 GLScene.OpenGL4

GL 4.6
GL_SGIX_list_priority GLScene.OpenGL4

GL 4.6
GL_SGIX_pixel_texture GLScene.OpenGL4

GL 4.6
GL_SGIX_pixel_tiles GLScene.OpenGL4

GL 4.6
GL_SGIX_polynomial_ffd GLScene.OpenGL4

GL 4.6
GL_SGIX_reference_plane GLScene.OpenGL4

GL 4.6
GL_SGIX_resample GLScene.OpenGL4

GL 4.6
GL_SGIX_scalebias_hint GLScene.OpenGL4

GL 4.6
GL_SGIX_shadow GLScene.OpenGL4

GL 4.6
GL_SGIX_shadow_ambient GLScene.OpenGL4

GL 4.6
GL_SGIX_sprite GLScene.OpenGL4

GL 4.6
GL_SGIX_subsample GLScene.OpenGL4

GL 4.6
GL_SGIX_tag_sample_buffer GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_add_env GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_coordinate_clamp GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_lod_bias GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_multi_buffer GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_scale_bias GLScene.OpenGL4

GL 4.6
GL_SGIX_texture_select GLScene.OpenGL4

GL 4.6
GL_SGIX_vertex_preclip GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcb GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcba GLScene.OpenGL4

GL 4.6
GL_SGIX_ycrcb_subsample GLScene.OpenGL4

GL 4.6
GL_SGI_color_matrix GLScene.OpenGL4

GL 4.6
GL_SGI_color_table GLScene.OpenGL4

GL 4.6
GL_SGI_depth_pass_instrument GLScene.OpenGL4

GL 4.6
GL_SGI_texture_color_table GLScene.OpenGL4

GL 4.6
GL_SUNX_constant_data GLScene.OpenGL4

GL 4.6
GL_SUN_convolution_border_modes GLScene.OpenGL4

GL 4.6
GL_SUN_global_alpha GLScene.OpenGL4

GL 4.6
GL_SUN_mesh_array GLScene.OpenGL4

GL 4.6
GL_SUN_slice_accum GLScene.OpenGL4

GL 4.6
GL_SUN_triangle_list GLScene.OpenGL4

GL 4.6
GL_SUN_vertex GLScene.OpenGL4

GL 4.6
GL_VERSION_4_0 GLScene.OpenGL4

GL_VERSION_4_1 GLScene.OpenGL4

GL_VERSION_4_2 GLScene.OpenGL4

GL_VERSION_4_3 GLScene.OpenGL4

GL_VERSION_4_4 GLScene.OpenGL4

GL_VERSION_4_5 GLScene.OpenGL4

GL_VERSION_4_6 GLScene.OpenGL4

GL_WIN_phong_shading GLScene.OpenGL4

WGL
GL_WIN_specular_fog GLScene.OpenGL4

WGL
GUILayoutForm FMxGuiLayoutEditor

GXContextManager GXS.Context

GXOpenGL GXS.InitOpenGL

GXOpenGL OpenGXS.InitFMX

Handle GXS.SceneViewer

IncludeFilePath GXS.CgShader

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.
InfoForm FMxInfo

IsDesignTime GLScene.Utils

Language GLScene.Strings

String constants that are used for internationalization

To build your project with a single language's translations in the executable itself, define one of the next languages

Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es
lkPrefix GLScene.Logger

llMessageLimit GLScene.Logger

SkinEditorForm FMxSkinEditor

TangentAttributeName GXS.Objects

TextureCanalBleu uGBEImageUtils

TextureCanalNoir uGBEImageUtils

TextureCanalRouge uGBEImageUtils

TextureCanalVert uGBEImageUtils

vContextActivationFailureOccurred GXS.Context

vCounterFrequency GXS.Scene

vCurrentContext GXS.Context

vCurrentRenderingObject GXS.Scene

vCurrentVideoMode GXS.Screen

vCustomColliderClass GXS.ODEManager

vCustomColliderClassNum GXS.ODEManager

vDDSDetailLevel GXS.FileDDS

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.
vDefaultMeshOptimizerOptions GXS.MeshOptimizer

vDefaultTextureCompression GLScene.TextureFormat

vDefaultTextureFormat GLScene.TextureFormat

vEdgeInfoReserveSize GXS.MeshUtils

vFile3DSSceneObjects_RenderCameraAndLights GXS.File3DSSceneObjects

vFile3DS_EnableAnimation GXS.File3DS

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TgxFreeForm.AutoCentering does now work correctly. - TgxMeshObject.vertices return values different from TgxMeshObject.ExtractTriangles()
vFile3DS_FixDefaultUpAxisY GXS.File3DS

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vFile3DS_EnableAnimation = true)
vFile3DS_LoadedStaticFrame GXS.File3DS

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.
vFile3DS_UseTextureEx GXS.File3DS

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.
vFileOBJ_SplitMesh GXS.FileOBJ

If enabled, main mesh will be splitted into multiple mesh from facegroup data.
vFileOCTAllocateMaterials GXS.FileOCT

Flag to avoid loading materials (useful for IDE Extensions or scene editors)
vFileOCTLightmapBrightness GXS.FileOCT

Scaling factor, 1.0 = unchanged
vFileOCTLightmapGammaCorrection GXS.FileOCT

Scaling factor, 1.0 = unchanged
vFileQ3BSPLoadMaterials GXS.FileQ3BSP

scaling factor, 1.0 = unchanged
vFindCuFileFunc GXS.CUDA.Compiler

vFontManagerMsgID GXS.SpaceText

vGhoul2LevelOfDetail GXS.FileGL2

vGhoul2MaxBonesPerVertex GXS.FileGL2

Highest detail level by default
vGLSmartObjectsAllocate GXS.SmartObjects

vGLSmartObjectsEnableByDefault GXS.SmartObjects

vGXAFIOCreateFileStream GXS.ApplicationFileIO

vGXAFIOFileStreamExists GXS.ApplicationFileIO

vIDELogProc GLScene.Logger

vIgnoreOpenGLErrors GLScene.OpenGL4

Raises an EOpenGLError with 'msg' error string
vIgnoreOpenGXErrors GXS.Context

vImageScaleFilterWidth GXS.ImageUtils

vImprovedFixingOpenTriangleEdge GXS.MeshUtils

vLastWheelDelta GLScene.Keyboard

vMD5TextureExtensions GXS.FileMD5

vMultitextureCoordinatorClass GXS.Context

vNumberVideoModes GXS.Screen

vODEObjectRegister GXS.ODEManager

vODERagdoll_cDensity GXS.ODERagdoll

vODERagdoll_cMass GXS.ODERagdoll

vProjectTargetName GLScene.Utils

vQ3BSPLightmapBrightness GXS.FileQ3BSP

vQ3BSPLightmapGammaCorrection GXS.FileQ3BSP

Q3 lightmaps are quite dark, we brighten them a lot by default
vSecondTextureUnitForbidden GXS.XOpenGL

vSIMD GLScene.VectorGeometry

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)
vUseWindowTrackingHook GXS.WinContext

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction.
vVectorFileObjectsAllocateMaterials GXS.VectorFileObjects

vVectorFileObjectsEnableVBOByDefault GXS.VectorFileObjects

Flag to avoid loading materials (useful for IDE Extentions or scene editors)
vVerboseGLSMErrors GXS.SoundManager

If this variable is true, errors in GLSM may be displayed to the user
vVerticalFlipDDS GXS.Graphics

vVideoModes GXS.Screen

wglAllocateMemoryNV GLScene.OpenGL4

wglBindTexImageARB GLScene.OpenGL4

WGL_ARB_render_texture (ARB #20)
wglChoosePixelFormatARB GLScene.OpenGL4

wglCreateAffinityDCNV GLScene.OpenGL4

wglCreateBufferRegionARB GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)
wglCreateContextAttribsARB GLScene.OpenGL4

WGL_ARB_create_context (ARB #55)
wglCreatePbufferARB GLScene.OpenGL4

WGL_ARB_pbuffer (ARB #11)
wglDeleteBufferRegionARB GLScene.OpenGL4

wglDeleteDCNV GLScene.OpenGL4

wglDestroyPbufferARB GLScene.OpenGL4

wglEnumGpuDevicesNV GLScene.OpenGL4

wglEnumGpusFromAffinityDCNV GLScene.OpenGL4

wglEnumGpusNV GLScene.OpenGL4

WGL_NV_gpu_affinity
wglFreeMemoryNV GLScene.OpenGL4

wglGetCurrentReadDCARB GLScene.OpenGL4

wglGetExtensionsStringARB GLScene.OpenGL4

WGL_ARB_extensions_string (ARB #8)
wglGetPbufferDCARB GLScene.OpenGL4

wglGetPixelFormatAttribfvARB GLScene.OpenGL4

wglGetPixelFormatAttribivARB GLScene.OpenGL4

WGL_ARB_pixel_format (ARB #9)
wglGetSwapIntervalEXT GLScene.OpenGL4

wglMakeContextCurrentARB GLScene.OpenGL4

WGL_make_current_read (ARB #10)
wglQueryPbufferARB GLScene.OpenGL4

wglReleasePbufferDCARB GLScene.OpenGL4

wglReleaseTexImageARB GLScene.OpenGL4

wglRestoreBufferRegionARB GLScene.OpenGL4

wglSaveBufferRegionARB GLScene.OpenGL4

wglSetPbufferAttribARB GLScene.OpenGL4

wglSwapIntervalEXT GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)
WGL_3DFX_multisample GLScene.OpenGL4

WGL
WGL_3DL_stereo_control GLScene.OpenGL4

WGL
WGL_AMD_gpu_association GLScene.OpenGL4

WGL
WGL_ARB_buffer_region GLScene.OpenGL4

WGL
WGL_ARB_context_flush_control GLScene.OpenGL4

WGL
WGL_ARB_create_context GLScene.OpenGL4

WGL
WGL_ARB_create_context_profile GLScene.OpenGL4

WGL
WGL_ARB_create_context_robustness GLScene.OpenGL4

WGL
WGL_ARB_extensions_string GLScene.OpenGL4

WGL
WGL_ARB_framebuffer_sRGB GLScene.OpenGL4

WGL
WGL_ARB_make_current_read GLScene.OpenGL4

WGL
WGL_ARB_multisample GLScene.OpenGL4

WGL
WGL_ARB_pbuffer GLScene.OpenGL4

WGL
WGL_ARB_pixel_format GLScene.OpenGL4

WGL
WGL_ARB_pixel_format_float GLScene.OpenGL4

WGL
WGL_ARB_render_texture GLScene.OpenGL4

WGL
WGL_ATI_pixel_format_float GLScene.OpenGL4

WGL
WGL_EXT_create_context_es2_profile GLScene.OpenGL4

WGL
WGL_EXT_depth_float GLScene.OpenGL4

WGL
WGL_EXT_display_color_table GLScene.OpenGL4

WGL
WGL_EXT_extensions_string GLScene.OpenGL4

WGL
WGL_EXT_make_current_read GLScene.OpenGL4

WGL
WGL_EXT_multisample GLScene.OpenGL4

WGL
WGL_EXT_pbuffer GLScene.OpenGL4

WGL
WGL_EXT_pixel_format GLScene.OpenGL4

WGL
WGL_EXT_swap_control GLScene.OpenGL4

WGL
WGL_I3D_digital_video_control GLScene.OpenGL4

WGL
WGL_I3D_gamma GLScene.OpenGL4

WGL
WGL_I3D_genlock GLScene.OpenGL4

WGL
WGL_I3D_image_buffer GLScene.OpenGL4

WGL
WGL_I3D_swap_frame_lock GLScene.OpenGL4

WGL
WGL_I3D_swap_frame_usage GLScene.OpenGL4

WGL
WGL_NV_copy_image GLScene.OpenGL4

WGL
WGL_NV_DX_interop GLScene.OpenGL4

WGL
WGL_NV_float_buffer GLScene.OpenGL4

WGL
WGL_NV_gpu_affinity GLScene.OpenGL4

WGL
WGL_NV_multisample_coverage GLScene.OpenGL4

WGL
WGL_NV_present_video GLScene.OpenGL4

WGL
WGL_NV_render_depth_texture GLScene.OpenGL4

WGL
WGL_NV_render_texture_rectangle GLScene.OpenGL4

WGL
WGL_NV_swap_group GLScene.OpenGL4

WGL
WGL_NV_vertex_array_range GLScene.OpenGL4

WGL
WGL_NV_video_capture GLScene.OpenGL4

WGL
WGL_NV_video_output GLScene.OpenGL4

WGL
WGL_OML_sync_control GLScene.OpenGL4

WGL
WIN_draw_range_elements GLScene.OpenGL4

WGL
WIN_swap_hint GLScene.OpenGL4

WGL
xglDisable GXS.XOpenGL

xglDisableClientState GXS.XOpenGL

xglEnable GXS.XOpenGL

Misc
xglEnableClientState GXS.XOpenGL

xglMapTexCoordMode GXS.XOpenGL

xglTexCoord2f GXS.XOpenGL

Explicit texture coordinates specification
xglTexCoord2fv GXS.XOpenGL

xglTexCoord3f GXS.XOpenGL

xglTexCoord3fv GXS.XOpenGL

xglTexCoord4f GXS.XOpenGL

xglTexCoord4fv GXS.XOpenGL

xglTexCoordPointer GXS.XOpenGL

Vertex Arrays texture coordinates specification
xglTexGenf GXS.XOpenGL

TexGen texture coordinates specification
xglTexGenfv GXS.XOpenGL

xglTexGeni GXS.XOpenGL

xglTexGeniv GXS.XOpenGL


GXSysHelp v.2.5: All Constants

All Constants

Name | Unit | Description
ALLOC_SIZE | GXS.Isosurface |
BufSize | GXS.FileOBJ |
c180 | GLScene.VectorGeometry |
c180divPI | GLScene.VectorGeometry |
c2PI | GLScene.VectorGeometry |
c360 | GLScene.VectorGeometry |
c3PIdiv2 | GLScene.VectorGeometry |
c3PIdiv4 | GLScene.VectorGeometry |
cAllAttribBits | GXS.State |
cAllColorComponents | GXS.State |
cAllFrustrumParts | GXS.GeomObjects |
cAllMeshPrimitive | GXS.State |
cAllStatesChanged | GLScene.PipelineTransform |
CBBBack | GLScene.GeometryBB |
CBBBottom | GLScene.GeometryBB |
CBBFront | GLScene.GeometryBB |
CBBLeft | GLScene.GeometryBB |
CBBPlans | GLScene.GeometryBB |
CBBRight | GLScene.GeometryBB |
CBBTop | GLScene.GeometryBB |
cColinearBias | GLScene.VectorGeometry |
cDefaultActorOptions | GXS.VectorFileObjects |
cDefaultCyborgOptions | GXS.SmartObjects |
cDefaultFlareElements | GXS.LensFlare |
cDefaultImposterOptions | GXS.Imposter |
cDefaultMirrorOptions | GXS.Mirror |
cDefaultNormalMapScale | GXS.Texture |
cDefaultPointSize | GXS.Objects |
cDefaultProxyOptions | GXS.Scene |
cDefaultScreenSaverOptions | GXS.ScreenSaver |
cDefaultSDLWindowOptions | SDLx.Window |
cDefaultShadowPlaneOptions | GXS.ShadowPlane |
cDefaultSwizzleVector | GLScene.TextureFormat |
cDefaultWaterPlaneOptions | GXS.WaterPlane |
cDEFAULT_CONSTRAINT_FRICTION | GXS.VerletTypes |
cDEFAULT_TIMER_INTERVAL | GXS.AsyncTimer |
CDirPlan | GLScene.GeometryBB |
cECCloseDistance | GXS.EllipseCollision |
cGLBlendEquationToGLEnum | GXS.State | valid for src only
cGLBlendFunctionToGLEnum | GXS.State |
cGLBufferBindingTarget | GXS.State |
cGLComparisonFunctionToGLEnum | GXS.State |
cGLCullFaceModeToGLEnum | GXS.State |
cGLFaceWindingToGLEnum | GXS.State |
cGLgsInTypes | GXSL.ShaderParameter |
cGLgsOutTypes | GXSL.ShaderParameter |
cGLHintToGLEnum | GXS.State |
cGLLogicOpToGLEnum | GXS.State |
cGLPolygonModeToGLEnum | GXS.State |
cGLQueryTypeToGLEnum | GXS.State |
cGLStateToGLEnum | GXS.State |
cGLStateTypeToGLEnum | GXS.State |
cGLStencilOpToGLEnum | GXS.State |
cGLTexTypeToGLEnum | GXS.State |
cGLXLSamplerString | GXSL.Parameter |
cGLXLTypeString | GXSL.Parameter |
cGXgsInTypes | GXSL.Parameter |
cGXgsOutTypes | GXSL.Parameter |
cGXSLSamplerString | GXSL.ShaderParameter |
cGXSLTypeString | GXSL.ShaderParameter |
cHTFHashTableSize | GXS.HeightTileFile |
cHTFQuadTableSize | GXS.HeightTileFile |
cInv2PI | GLScene.VectorGeometry |
cInv360 | GLScene.VectorGeometry |
cLn10 | GLScene.VectorGeometry |
ClosedPolygon2D | GLScene.VectorTypesExt | TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;
ClosedPolygon3D | GLScene.VectorTypesExt |
cMaxArray | GLScene.VectorGeometry |
cMaxContacts | GXS.ODERagdoll |
cMaxVerts | GXS.Trail |
cMeshModeToGLEnum | GXS.Mesh |
CmtNX | GXS.Texture |
CmtNY | GXS.Texture |
CmtNZ | GXS.Texture |
CmtPX | GXS.Texture |
CmtPY | GXS.Texture |
CmtPZ | GXS.Texture |
COctree_GROW_GRAVY | GXS.SpacePartition |
COctree_LEAF_TRHESHOLD | GXS.SpacePartition |
COctree_MAX_TREE_DEPTH | GXS.SpacePartition |
cOneHalf | GLScene.VectorGeometry |
CONSOLE_MAX_COMMANDS | GXS.Console |
cPERLIN_TABLE_SIZE | GXS.PerlinPFX |
cPFXGranularity | GXS.ParticleFX | number of distance regions
cPFXNbRegions | GXS.ParticleFX |
cPI | GLScene.VectorGeometry |
cPIdiv180 | GLScene.VectorGeometry |
cPIdiv2 | GLScene.VectorGeometry |
cPIdiv4 | GLScene.VectorGeometry |
cTilesHashSize | GXS.TerrainRenderer |
cVertexModeToGLEnum | GXS.Mesh |
C_LMTS_ID | GXS.FileLMTS |
C_LMTS_SUBS | GXS.FileLMTS |
C_LMTS_TEXFNLEN | GXS.FileLMTS |
C_LMTS_TEXT | GXS.FileLMTS |
C_LMTS_TRIS | GXS.FileLMTS |
C_LMTS_VER | GXS.FileLMTS |
DAMP_SHIFT | GXS.ProcTextures |
DCEBox | GXS.DCEMisc |
DebugMode | GXS.PhysInertias |
DLL | GXS.PhysX |
EmptyHmgMatrix | GLScene.VectorGeometry |
EmptyMatrix | GLScene.VectorGeometry |
EPSILON | GLScene.VectorGeometry | Some very small numbers
EPSILON2 | GLScene.VectorGeometry |
ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB | GLScene.OpenGL4 |
ERROR_INVALID_PIXEL_TYPE_ARB | GLScene.OpenGL4 | WGL_ARB_make_current_read
ERROR_INVALID_PIXEL_TYPE_EXT | GLScene.OpenGL4 | WGL_EXT_make_current_read
ERROR_INVALID_PROFILE_ARB | GLScene.OpenGL4 |
ERROR_INVALID_PROFILE_ARB | GLScene.OpenGLTokens |
ERROR_INVALID_VERSION_ARB | GLScene.OpenGL4 |
ERROR_INVALID_VERSION_ARB | GLScene.OpenGLTokens |
ExPtTolerance | GLScene.Triangulation |
FONT_CHARS_COUNT | GLScene.Utils |
glu32 | GLScene.OpenGL4 |
glu32 | GXS.OpenGLAdapter |
GLU_AUTO_LOAD_MATRIX | GLScene.OpenGL4 |
GLU_AUTO_LOAD_MATRIX | GLScene.OpenGLTokens | NURBS constants NurbsProperty
GLU_BEGIN | GLScene.OpenGL4 |
GLU_BEGIN | GLScene.OpenGLTokens | Names without "TESS_" prefix
GLU_CCW | GLScene.OpenGL4 |
GLU_CCW | GLScene.OpenGLTokens |
GLU_CULLING | GLScene.OpenGL4 |
GLU_CULLING | GLScene.OpenGLTokens |
GLU_CW | GLScene.OpenGL4 |
GLU_CW | GLScene.OpenGLTokens | Contours types – obsolete!
GLU_DISPLAY_MODE | GLScene.OpenGL4 |
GLU_DISPLAY_MODE | GLScene.OpenGLTokens |
GLU_DOMAIN_DISTANCE | GLScene.OpenGL4 |
GLU_DOMAIN_DISTANCE | GLScene.OpenGLTokens |
GLU_EDGE_FLAG | GLScene.OpenGL4 |
GLU_EDGE_FLAG | GLScene.OpenGLTokens |
GLU_END | GLScene.OpenGL4 |
GLU_END | GLScene.OpenGLTokens |
GLU_ERROR | GLScene.OpenGL4 |
GLU_ERROR | GLScene.OpenGLTokens |
GLU_EXTENSIONS | GLScene.OpenGL4 |
GLU_EXTERIOR | GLScene.OpenGL4 |
GLU_EXTERIOR | GLScene.OpenGLTokens |
GLU_FALSE | GLScene.OpenGL4 |
GLU_FILL | GLScene.OpenGL4 |
GLU_FLAT | GLScene.OpenGL4 |
GLU_INCOMPATIBLE_GL_VERSION | GLScene.OpenGL4 |
GLU_INSIDE | GLScene.OpenGL4 |
GLU_INTERIOR | GLScene.OpenGL4 |
GLU_INTERIOR | GLScene.OpenGLTokens |
GLU_INVALID_ENUM | GLScene.OpenGL4 | GLU
GLU_INVALID_VALUE | GLScene.OpenGL4 |
GLU_LINE | GLScene.OpenGL4 |
GLU_MAP1_TRIM_2 | GLScene.OpenGL4 |
GLU_MAP1_TRIM_2 | GLScene.OpenGLTokens | NurbsTrim
GLU_MAP1_TRIM_3 | GLScene.OpenGL4 |
GLU_MAP1_TRIM_3 | GLScene.OpenGLTokens |
GLU_NONE | GLScene.OpenGL4 |
GLU_NURBS_ERROR1 | GLScene.OpenGL4 |
GLU_NURBS_ERROR1 | GLScene.OpenGLTokens | NurbsErrors
GLU_NURBS_ERROR10 | GLScene.OpenGL4 |
GLU_NURBS_ERROR10 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR11 | GLScene.OpenGL4 |
GLU_NURBS_ERROR11 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR12 | GLScene.OpenGL4 |
GLU_NURBS_ERROR12 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR13 | GLScene.OpenGL4 |
GLU_NURBS_ERROR13 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR14 | GLScene.OpenGL4 |
GLU_NURBS_ERROR14 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR15 | GLScene.OpenGL4 |
GLU_NURBS_ERROR15 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR16 | GLScene.OpenGL4 |
GLU_NURBS_ERROR16 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR17 | GLScene.OpenGL4 |
GLU_NURBS_ERROR17 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR18 | GLScene.OpenGL4 |
GLU_NURBS_ERROR18 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR19 | GLScene.OpenGL4 |
GLU_NURBS_ERROR19 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR2 | GLScene.OpenGL4 |
GLU_NURBS_ERROR2 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR20 | GLScene.OpenGL4 |
GLU_NURBS_ERROR20 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR21 | GLScene.OpenGL4 |
GLU_NURBS_ERROR21 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR22 | GLScene.OpenGL4 |
GLU_NURBS_ERROR22 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR23 | GLScene.OpenGL4 |
GLU_NURBS_ERROR23 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR24 | GLScene.OpenGL4 |
GLU_NURBS_ERROR24 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR25 | GLScene.OpenGL4 |
GLU_NURBS_ERROR25 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR26 | GLScene.OpenGL4 |
GLU_NURBS_ERROR26 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR27 | GLScene.OpenGL4 |
GLU_NURBS_ERROR27 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR28 | GLScene.OpenGL4 |
GLU_NURBS_ERROR28 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR29 | GLScene.OpenGL4 |
GLU_NURBS_ERROR29 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR3 | GLScene.OpenGL4 |
GLU_NURBS_ERROR3 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR30 | GLScene.OpenGL4 |
GLU_NURBS_ERROR30 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR31 | GLScene.OpenGL4 |
GLU_NURBS_ERROR31 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR32 | GLScene.OpenGL4 |
GLU_NURBS_ERROR32 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR33 | GLScene.OpenGL4 |
GLU_NURBS_ERROR33 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR34 | GLScene.OpenGL4 |
GLU_NURBS_ERROR34 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR35 | GLScene.OpenGL4 |
GLU_NURBS_ERROR35 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR36 | GLScene.OpenGL4 |
GLU_NURBS_ERROR36 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR37 | GLScene.OpenGL4 |
GLU_NURBS_ERROR37 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR4 | GLScene.OpenGL4 |
GLU_NURBS_ERROR4 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR5 | GLScene.OpenGL4 |
GLU_NURBS_ERROR5 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR6 | GLScene.OpenGL4 |
GLU_NURBS_ERROR6 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR7 | GLScene.OpenGL4 |
GLU_NURBS_ERROR7 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR8 | GLScene.OpenGL4 |
GLU_NURBS_ERROR8 | GLScene.OpenGLTokens |
GLU_NURBS_ERROR9 | GLScene.OpenGL4 |
GLU_NURBS_ERROR9 | GLScene.OpenGLTokens |
GLU_OUTLINE_PATCH | GLScene.OpenGL4 |
GLU_OUTLINE_PATCH | GLScene.OpenGLTokens |
GLU_OUTLINE_POLYGON | GLScene.OpenGL4 |
GLU_OUTLINE_POLYGON | GLScene.OpenGLTokens | NurbsDisplay
GLU_OUTSIDE | GLScene.OpenGL4 |
GLU_OUT_OF_MEMORY | GLScene.OpenGL4 |
GLU_PARAMETRIC_ERROR | GLScene.OpenGL4 |
GLU_PARAMETRIC_ERROR | GLScene.OpenGLTokens |
GLU_PARAMETRIC_TOLERANCE | GLScene.OpenGL4 |
GLU_PARAMETRIC_TOLERANCE | GLScene.OpenGLTokens |
GLU_PATH_LENGTH | GLScene.OpenGL4 |
GLU_PATH_LENGTH | GLScene.OpenGLTokens | NurbsSampling
GLU_POINT | GLScene.OpenGL4 |
GLU_SAMPLING_METHOD | GLScene.OpenGL4 |
GLU_SAMPLING_METHOD | GLScene.OpenGLTokens |
GLU_SAMPLING_TOLERANCE | GLScene.OpenGL4 |
GLU_SAMPLING_TOLERANCE | GLScene.OpenGLTokens |
GLU_SILHOUETTE | GLScene.OpenGL4 |
GLU_SMOOTH | GLScene.OpenGL4 |
GLU_TESS_BEGIN | GLScene.OpenGL4 |
GLU_TESS_BEGIN | GLScene.OpenGLTokens | ********** GLU generic constants ********** TessCallback
GLU_TESS_BEGIN_DATA | GLScene.OpenGL4 |
GLU_TESS_BEGIN_DATA | GLScene.OpenGLTokens | TGLUTessCombineProc
GLU_TESS_BOUNDARY_ONLY | GLScene.OpenGL4 |
GLU_TESS_COMBINE | GLScene.OpenGL4 |
GLU_TESS_COMBINE | GLScene.OpenGLTokens | TGLUTessEdgeFlagProc
GLU_TESS_COMBINE_DATA | GLScene.OpenGL4 |
GLU_TESS_COMBINE_DATA | GLScene.OpenGLTokens | TGLUTessEdgeFlagDataProc
GLU_TESS_COORD_TOO_LARGE | GLScene.OpenGL4 |
GLU_TESS_COORD_TOO_LARGE | GLScene.OpenGLTokens |
GLU_TESS_EDGE_FLAG | GLScene.OpenGL4 |
GLU_TESS_EDGE_FLAG | GLScene.OpenGLTokens | TGLUTessErrorProc
GLU_TESS_EDGE_FLAG_DATA | GLScene.OpenGL4 |
GLU_TESS_EDGE_FLAG_DATA | GLScene.OpenGLTokens | TGLUTessErrorDataProc
GLU_TESS_END | GLScene.OpenGL4 |
GLU_TESS_END | GLScene.OpenGLTokens | TGLUTessVertexProc
GLU_TESS_END_DATA | GLScene.OpenGL4 |
GLU_TESS_END_DATA | GLScene.OpenGLTokens | TGLUTessVertexDataProc
GLU_TESS_ERROR | GLScene.OpenGL4 |
GLU_TESS_ERROR | GLScene.OpenGLTokens | TGLUTessEndProc
GLU_TESS_ERROR1 | GLScene.OpenGL4 |
GLU_TESS_ERROR1 | GLScene.OpenGLTokens | TGLUTessCombineDataProc TessError
GLU_TESS_ERROR2 | GLScene.OpenGL4 |
GLU_TESS_ERROR2 | GLScene.OpenGLTokens |
GLU_TESS_ERROR3 | GLScene.OpenGL4 |
GLU_TESS_ERROR3 | GLScene.OpenGLTokens |
GLU_TESS_ERROR4 | GLScene.OpenGL4 |
GLU_TESS_ERROR4 | GLScene.OpenGLTokens |
GLU_TESS_ERROR5 | GLScene.OpenGL4 |
GLU_TESS_ERROR5 | GLScene.OpenGLTokens |
GLU_TESS_ERROR6 | GLScene.OpenGL4 |
GLU_TESS_ERROR6 | GLScene.OpenGLTokens |
GLU_TESS_ERROR7 | GLScene.OpenGL4 |
GLU_TESS_ERROR7 | GLScene.OpenGLTokens |
GLU_TESS_ERROR8 | GLScene.OpenGL4 |
GLU_TESS_ERROR8 | GLScene.OpenGLTokens |
GLU_TESS_ERROR_DATA | GLScene.OpenGL4 |
GLU_TESS_ERROR_DATA | GLScene.OpenGLTokens | TGLUTessEndDataProc
GLU_TESS_MAX_COORD | GLScene.OpenGL4 |
GLU_TESS_MISSING_BEGIN_CONTOUR | GLScene.OpenGL4 |
GLU_TESS_MISSING_BEGIN_CONTOUR | GLScene.OpenGLTokens |
GLU_TESS_MISSING_BEGIN_POLYGON | GLScene.OpenGL4 |
GLU_TESS_MISSING_BEGIN_POLYGON | GLScene.OpenGLTokens |
GLU_TESS_MISSING_END_CONTOUR | GLScene.OpenGL4 |
GLU_TESS_MISSING_END_CONTOUR | GLScene.OpenGLTokens |
GLU_TESS_MISSING_END_POLYGON | GLScene.OpenGL4 |
GLU_TESS_MISSING_END_POLYGON | GLScene.OpenGLTokens |
GLU_TESS_NEED_COMBINE_CALLBACK | GLScene.OpenGL4 |
GLU_TESS_NEED_COMBINE_CALLBACK | GLScene.OpenGLTokens |
GLU_TESS_TOLERANCE | GLScene.OpenGL4 |
GLU_TESS_VERTEX | GLScene.OpenGL4 |
GLU_TESS_VERTEX | GLScene.OpenGLTokens | TGLUTessBeginProc
GLU_TESS_VERTEX_DATA | GLScene.OpenGL4 |
GLU_TESS_VERTEX_DATA | GLScene.OpenGLTokens | TGLUTessBeginDataProc
GLU_TESS_WINDING_ABS_GEQ_TWO | GLScene.OpenGL4 |
GLU_TESS_WINDING_NEGATIVE | GLScene.OpenGL4 |
GLU_TESS_WINDING_NONZERO | GLScene.OpenGL4 |
GLU_TESS_WINDING_ODD | GLScene.OpenGL4 |
GLU_TESS_WINDING_POSITIVE | GLScene.OpenGL4 |
GLU_TESS_WINDING_RULE | GLScene.OpenGL4 |
GLU_TRUE | GLScene.OpenGL4 |
GLU_UNKNOWN | GLScene.OpenGL4 |
GLU_UNKNOWN | GLScene.OpenGLTokens |
GLU_U_STEP | GLScene.OpenGL4 |
GLU_U_STEP | GLScene.OpenGLTokens |
GLU_VERSION | GLScene.OpenGL4 |
GLU_VERTEX | GLScene.OpenGL4 |
GLU_VERTEX | GLScene.OpenGLTokens |
GLU_V_STEP | GLScene.OpenGL4 |
GLU_V_STEP | GLScene.OpenGLTokens |
GLX_ACCUM_ALPHA_SIZE | GLScene.OpenGL4 |
GLX_ACCUM_BLUE_SIZE | GLScene.OpenGL4 |
GLX_ACCUM_BUFFER_BIT | GLScene.OpenGL4 |
GLX_ACCUM_GREEN_SIZE | GLScene.OpenGL4 |
GLX_ACCUM_RED_SIZE | GLScene.OpenGL4 |
GLX_ALPHA_SIZE | GLScene.OpenGL4 |
GLX_AUX0_EXT | GLScene.OpenGL4 |
GLX_AUX1_EXT | GLScene.OpenGL4 |
GLX_AUX2_EXT | GLScene.OpenGL4 |
GLX_AUX3_EXT | GLScene.OpenGL4 |
GLX_AUX4_EXT | GLScene.OpenGL4 |
GLX_AUX5_EXT | GLScene.OpenGL4 |
GLX_AUX6_EXT | GLScene.OpenGL4 |
GLX_AUX7_EXT | GLScene.OpenGL4 |
GLX_AUX8_EXT | GLScene.OpenGL4 |
GLX_AUX9_EXT | GLScene.OpenGL4 |
GLX_AUX_BUFFERS | GLScene.OpenGL4 |
GLX_AUX_BUFFERS_BIT | GLScene.OpenGL4 |
GLX_BACK_EXT | GLScene.OpenGL4 |
GLX_BACK_LEFT_BUFFER_BIT | GLScene.OpenGL4 |
GLX_BACK_LEFT_EXT | GLScene.OpenGL4 |
GLX_BACK_RIGHT_BUFFER_BIT | GLScene.OpenGL4 |
GLX_BACK_RIGHT_EXT | GLScene.OpenGL4 |
GLX_BIND_TO_MIPMAP_TEXTURE_EXT | GLScene.OpenGL4 |
GLX_BIND_TO_TEXTURE_RGBA_EXT | GLScene.OpenGL4 |
GLX_BIND_TO_TEXTURE_RGB_EXT | GLScene.OpenGL4 |
GLX_BIND_TO_TEXTURE_TARGETS_EXT | GLScene.OpenGL4 |
GLX_BLUE_SIZE | GLScene.OpenGL4 |
GLX_BUFFER_SIZE | GLScene.OpenGL4 |
GLX_COLOR_INDEX_BIT | GLScene.OpenGL4 |
GLX_COLOR_INDEX_TYPE | GLScene.OpenGL4 |
GLX_CONFIG_CAVEAT | GLScene.OpenGL4 |
GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB | GLScene.OpenGL4 | GLX_ARB_vertex_buffer_object
GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_CORE_PROFILE_BIT_ARB | GLScene.OpenGL4 | GLX_ARB_create_context_profile
GLX_CONTEXT_DEBUG_BIT_ARB | GLScene.OpenGL4 | GLX_ARB_create_context
GLX_CONTEXT_ES2_PROFILE_BIT_EXT | GLScene.OpenGL4 | GLX_EXT_create_context_es2_profile
GLX_CONTEXT_FLAGS_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_MAJOR_VERSION_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_MINOR_VERSION_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_PROFILE_MASK_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_RELEASE_BEHAVIOR_ARB | GLScene.OpenGL4 | GLX_ARB_context_flush_control
GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_RESET_ISOLATION_BIT_ARB | GLScene.OpenGL4 | GLX_ARB_robustness_application_isolation
GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB | GLScene.OpenGL4 |
GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB | GLScene.OpenGL4 | GLX_ARB_create_context_robustness
GLX_DAMAGED | GLScene.OpenGL4 |
GLX_DEPTH_BUFFER_BIT | GLScene.OpenGL4 |
GLX_DEPTH_SIZE | GLScene.OpenGL4 |
GLX_DIRECT_COLOR | GLScene.OpenGL4 |
GLX_DIRECT_COLOR_EXT | GLScene.OpenGL4 |
GLX_DONT_CARE | GLScene.OpenGL4 |
GLX_DOUBLEBUFFER | GLScene.OpenGL4 |
GLX_DRAWABLE_TYPE | GLScene.OpenGL4 |
GLX_EVENT_MASK | GLScene.OpenGL4 |
GLX_EXTENSIONS | GLScene.OpenGL4 |
GLX_FBCONFIG_ID | GLScene.OpenGL4 |
GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB | GLScene.OpenGL4 | GLX_ARB_framebuffer_sRGB
GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT | GLScene.OpenGL4 | GL_EXT_framebuffer_sRGB
GLX_FRONT_EXT | GLScene.OpenGL4 |
GLX_FRONT_LEFT_BUFFER_BIT | GLScene.OpenGL4 |
GLX_FRONT_LEFT_EXT | GLScene.OpenGL4 |
GLX_FRONT_RIGHT_BUFFER_BIT | GLScene.OpenGL4 |
GLX_FRONT_RIGHT_EXT | GLScene.OpenGL4 |
GLX_GRAY_SCALE | GLScene.OpenGL4 |
GLX_GRAY_SCALE_EXT | GLScene.OpenGL4 |
GLX_GREEN_SIZE | GLScene.OpenGL4 |
GLX_HEIGHT | GLScene.OpenGL4 |
GLX_LARGEST_PBUFFER | GLScene.OpenGL4 |
GLX_LATE_SWAPS_TEAR_EXT | GLScene.OpenGL4 | GL_EXT_Late_Swaps
GLX_LEVEL | GLScene.OpenGL4 |
GLX_LOSE_CONTEXT_ON_RESET_ARB | GLScene.OpenGL4 |
GLX_MAX_PBUFFER_HEIGHT | GLScene.OpenGL4 |
GLX_MAX_PBUFFER_PIXELS | GLScene.OpenGL4 |
GLX_MAX_PBUFFER_WIDTH | GLScene.OpenGL4 |
GLX_MAX_SWAP_INTERVAL_EXT | GLScene.OpenGL4 |
GLX_MIPMAP_TEXTURE_EXT | GLScene.OpenGL4 |
GLX_NONE | GLScene.OpenGL4 |
GLX_NONE_EXT | GLScene.OpenGL4 |
GLX_NON_CONFORMANT_CONFIG | GLScene.OpenGL4 |
GLX_NON_CONFORMANT_VISUAL_EXT | GLScene.OpenGL4 |
GLX_NO_RESET_NOTIFICATION_ARB | GLScene.OpenGL4 |
GLX_PBUFFER | GLScene.OpenGL4 |
GLX_PBUFFER_BIT | GLScene.OpenGL4 |
GLX_PBUFFER_CLOBBER_MASK | GLScene.OpenGL4 |
GLX_PBUFFER_HEIGHT | GLScene.OpenGL4 |
GLX_PBUFFER_WIDTH | GLScene.OpenGL4 |
GLX_PIXMAP_BIT | GLScene.OpenGL4 |
GLX_PRESERVED_CONTENTS | GLScene.OpenGL4 |
GLX_PSEUDO_COLOR | GLScene.OpenGL4 |
GLX_PSEUDO_COLOR_EXT | GLScene.OpenGL4 |
GLX_RED_SIZE | GLScene.OpenGL4 |
GLX_RENDER_TYPE | GLScene.OpenGL4 |
GLX_RGBA | GLScene.OpenGL4 |
GLX_RGBA_BIT | GLScene.OpenGL4 |
GLX_RGBA_FLOAT_BIT | GLScene.OpenGL4 |
GLX_RGBA_FLOAT_BIT_ARB | GLScene.OpenGL4 |
GLX_RGBA_FLOAT_TYPE | GLScene.OpenGL4 |
GLX_RGBA_FLOAT_TYPE_ARB | GLScene.OpenGL4 | GLX_ARB_fbconfig_float
GLX_RGBA_TYPE | GLScene.OpenGL4 |
GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT | GLScene.OpenGL4 |
GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT | GLScene.OpenGL4 |
GLX_SAMPLES | GLScene.OpenGL4 |
GLX_SAMPLES_ARB | GLScene.OpenGL4 |
GLX_SAMPLE_BUFFERS | GLScene.OpenGL4 | GLX_VERSION_1_4
GLX_SAMPLE_BUFFERS_ARB | GLScene.OpenGL4 | GLX_ARB_multisample
GLX_SAVED | GLScene.OpenGL4 |
GLX_SCREEN | GLScene.OpenGL4 |
GLX_SCREEN_EXT | GLScene.OpenGL4 |
GLX_SHARE_CONTEXT_EXT | GLScene.OpenGL4 | GLX_EXT_import_context
GLX_SLOW_CONFIG | GLScene.OpenGL4 |
GLX_SLOW_VISUAL_EXT | GLScene.OpenGL4 |
GLX_STATIC_COLOR | GLScene.OpenGL4 |
GLX_STATIC_COLOR_EXT | GLScene.OpenGL4 |
GLX_STATIC_GRAY | GLScene.OpenGL4 |
GLX_STATIC_GRAY_EXT | GLScene.OpenGL4 |
GLX_STENCIL_BUFFER_BIT | GLScene.OpenGL4 |
GLX_STENCIL_SIZE | GLScene.OpenGL4 |
GLX_STEREO | GLScene.OpenGL4 |
GLX_SWAP_INTERVAL_EXT | GLScene.OpenGL4 | GLX_EXT_swap_control
GLX_TEXTURE_1D_BIT_EXT | GLScene.OpenGL4 | GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap
GLX_TEXTURE_1D_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_2D_BIT_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_2D_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_FORMAT_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_FORMAT_NONE_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_FORMAT_RGBA_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_FORMAT_RGB_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_RECTANGLE_BIT_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_RECTANGLE_EXT | GLScene.OpenGL4 |
GLX_TEXTURE_TARGET_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_ALPHA_VALUE | GLScene.OpenGL4 |
GLX_TRANSPARENT_ALPHA_VALUE_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_BLUE_VALUE | GLScene.OpenGL4 |
GLX_TRANSPARENT_BLUE_VALUE_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_GREEN_VALUE | GLScene.OpenGL4 |
GLX_TRANSPARENT_GREEN_VALUE_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_INDEX | GLScene.OpenGL4 |
GLX_TRANSPARENT_INDEX_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_INDEX_VALUE | GLScene.OpenGL4 |
GLX_TRANSPARENT_INDEX_VALUE_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_RED_VALUE | GLScene.OpenGL4 |
GLX_TRANSPARENT_RED_VALUE_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_RGB | GLScene.OpenGL4 |
GLX_TRANSPARENT_RGB_EXT | GLScene.OpenGL4 |
GLX_TRANSPARENT_TYPE | GLScene.OpenGL4 |
GLX_TRANSPARENT_TYPE_EXT | GLScene.OpenGL4 |
GLX_TRUE_COLOR | GLScene.OpenGL4 |
GLX_TRUE_COLOR_EXT | GLScene.OpenGL4 |
GLX_USE_GL | GLScene.OpenGL4 |
GLX_VENDOR | GLScene.OpenGL4 | GLX 1.1 and later:
GLX_VERSION | GLScene.OpenGL4 |
GLX_VISUAL_CAVEAT_EXT | GLScene.OpenGL4 | GLX_EXT_visual_rating
GLX_VISUAL_ID | GLScene.OpenGL4 |
GLX_VISUAL_ID_EXT | GLScene.OpenGL4 |
GLX_WIDTH | GLScene.OpenGL4 |
GLX_WINDOW | GLScene.OpenGL4 |
GLX_WINDOW_BIT | GLScene.OpenGL4 | GLX_VERSION_1_3
GLX_X_RENDERABLE | GLScene.OpenGL4 |
GLX_X_VISUAL_TYPE | GLScene.OpenGL4 |
GLX_X_VISUAL_TYPE_EXT | GLScene.OpenGL4 | GLX_EXT_visual_info
GLX_Y_INVERTED_EXT | GLScene.OpenGL4 |
GL_1PASS_EXT | GLScene.OpenGL4 |
GL_1PASS_SGIS | GLScene.OpenGL4 |
GL_2D | GLScene.OpenGL4 |
GL_2PASS_0_EXT | GLScene.OpenGL4 |
GL_2PASS_0_SGIS | GLScene.OpenGL4 |
GL_2PASS_1_EXT | GLScene.OpenGL4 |
GL_2PASS_1_SGIS | GLScene.OpenGL4 |
GL_2X_BIT_ATI | GLScene.OpenGL4 |
GL_2_BYTES | GLScene.OpenGL4 |
GL_3D | GLScene.OpenGL4 |
GL_3D_COLOR | GLScene.OpenGL4 |
GL_3D_COLOR_TEXTURE | GLScene.OpenGL4 |
GL_3_BYTES | GLScene.OpenGL4 |
GL_422_AVERAGE_EXT | GLScene.OpenGL4 |
GL_422_EXT | GLScene.OpenGL4 | GL_EXT_422_pixels
GL_422_REV_AVERAGE_EXT | GLScene.OpenGL4 |
GL_422_REV_EXT | GLScene.OpenGL4 |
GL_4D_COLOR_TEXTURE | GLScene.OpenGL4 |
GL_4PASS_0_EXT | GLScene.OpenGL4 |
GL_4PASS_0_SGIS | GLScene.OpenGL4 |
GL_4PASS_1_EXT | GLScene.OpenGL4 |
GL_4PASS_1_SGIS | GLScene.OpenGL4 |
GL_4PASS_2_EXT | GLScene.OpenGL4 |
GL_4PASS_2_SGIS | GLScene.OpenGL4 |
GL_4PASS_3_EXT | GLScene.OpenGL4 |
GL_4PASS_3_SGIS | GLScene.OpenGL4 |
GL_4X_BIT_ATI | GLScene.OpenGL4 |
GL_4_BYTES | GLScene.OpenGL4 |
GL_8X_BIT_ATI | GLScene.OpenGL4 |
GL_ABGR_EXT | GLScene.OpenGL4 | GL_EXT_abgr
GL_ACCUM | GLScene.OpenGL4 |
GL_ACCUM_ADJACENT_PAIRS_NV | GLScene.OpenGL4 |
GL_ACCUM_ALPHA_BITS | GLScene.OpenGL4 |
GL_ACCUM_BLUE_BITS | GLScene.OpenGL4 |
GL_ACCUM_BUFFER_BIT | GLScene.OpenGL4 |
GL_ACCUM_CLEAR_VALUE | GLScene.OpenGL4 |
GL_ACCUM_GREEN_BITS | GLScene.OpenGL4 |
GL_ACCUM_RED_BITS | GLScene.OpenGL4 |
GL_ACTIVE_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_ACTIVE_ATTRIBUTES | GLScene.OpenGL4 |
GL_ACTIVE_ATTRIBUTE_MAX_LENGTH | GLScene.OpenGL4 |
GL_ACTIVE_PROGRAM | GLScene.OpenGL4 |
GL_ACTIVE_PROGRAM_EXT | GLScene.OpenGL4 | GL_EXT_separate_shader_objects
GL_ACTIVE_RESOURCES | GLScene.OpenGL4 |
GL_ACTIVE_STENCIL_FACE_EXT | GLScene.OpenGL4 |
GL_ACTIVE_SUBROUTINES | GLScene.OpenGL4 | GL_ARB_shader_subroutine
GL_ACTIVE_SUBROUTINE_MAX_LENGTH | GLScene.OpenGL4 |
GL_ACTIVE_SUBROUTINE_UNIFORMS | GLScene.OpenGL4 |
GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS | GLScene.OpenGL4 |
GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH | GLScene.OpenGL4 |
GL_ACTIVE_TEXTURE | GLScene.OpenGL4 |
GL_ACTIVE_TEXTURE_ARB | GLScene.OpenGL4 |
GL_ACTIVE_UNIFORMS | GLScene.OpenGL4 |
GL_ACTIVE_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH | GLScene.OpenGL4 |
GL_ACTIVE_UNIFORM_MAX_LENGTH | GLScene.OpenGL4 |
GL_ACTIVE_VARIABLES | GLScene.OpenGL4 |
GL_ACTIVE_VARYINGS_NV | GLScene.OpenGL4 |
GL_ACTIVE_VARYING_MAX_LENGTH_NV | GLScene.OpenGL4 |
GL_ACTIVE_VERTEX_UNITS_ARB | GLScene.OpenGL4 |
GL_ADD | GLScene.OpenGL4 |
GL_ADD_ATI | GLScene.OpenGL4 |
GL_ADD_SIGNED | GLScene.OpenGL4 |
GL_ADD_SIGNED_ARB | GLScene.OpenGL4 |
GL_ADD_SIGNED_EXT | GLScene.OpenGL4 |
GL_ADJACENT_PAIRS_NV | GLScene.OpenGL4 |
GL_AFFINE_2D_NV | GLScene.OpenGL4 |
GL_AFFINE_3D_NV | GLScene.OpenGL4 |
GL_ALIASED_LINE_WIDTH_RANGE | GLScene.OpenGL4 |
GL_ALIASED_POINT_SIZE_RANGE | GLScene.OpenGL4 |
GL_ALLOW_DRAW_FRG_HINT_PGI | GLScene.OpenGL4 |
GL_ALLOW_DRAW_MEM_HINT_PGI | GLScene.OpenGL4 |
GL_ALLOW_DRAW_OBJ_HINT_PGI | GLScene.OpenGL4 |
GL_ALLOW_DRAW_WIN_HINT_PGI | GLScene.OpenGL4 |
GL_ALL_ATTRIB_BITS | GLScene.OpenGL4 |
GL_ALL_BARRIER_BITS | GLScene.OpenGL4 |
GL_ALL_BARRIER_BITS_EXT | GLScene.OpenGL4 |
GL_ALL_COMPLETED_NV | GLScene.OpenGL4 | GL_NV_fence
GL_ALL_SHADER_BITS | GLScene.OpenGL4 |
GL_ALPHA | GLScene.OpenGL4 |
GL_ALPHA12 | GLScene.OpenGL4 |
GL_ALPHA12_EXT | GLScene.OpenGL4 |
GL_ALPHA16 | GLScene.OpenGL4 |
GL_ALPHA16F_ARB | GLScene.OpenGL4 |
GL_ALPHA16I_EXT | GLScene.OpenGL4 |
GL_ALPHA16UI_EXT | GLScene.OpenGL4 |
GL_ALPHA16_EXT | GLScene.OpenGL4 |
GL_ALPHA16_SNORM | GLScene.OpenGL4 |
GL_ALPHA32F_ARB | GLScene.OpenGL4 |
GL_ALPHA32I_EXT | GLScene.OpenGL4 |
GL_ALPHA32UI_EXT | GLScene.OpenGL4 |
GL_ALPHA4 | GLScene.OpenGL4 |
GL_ALPHA4_EXT | GLScene.OpenGL4 | GL_EXT_texture
GL_ALPHA8 | GLScene.OpenGL4 |
GL_ALPHA8I_EXT | GLScene.OpenGL4 |
GL_ALPHA8UI_EXT | GLScene.OpenGL4 |
GL_ALPHA8_EXT | GLScene.OpenGL4 |
GL_ALPHA8_SNORM | GLScene.OpenGL4 |
GL_ALPHA_BIAS | GLScene.OpenGL4 |
GL_ALPHA_BITS | GLScene.OpenGL4 |
GL_ALPHA_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_ALPHA_FLOAT16_ATI | GLScene.OpenGL4 |
GL_ALPHA_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_ALPHA_FLOAT32_ATI | GLScene.OpenGL4 |
GL_ALPHA_INTEGER | GLScene.OpenGL4 |
GL_ALPHA_INTEGER_EXT | GLScene.OpenGL4 |
GL_ALPHA_MAX_CLAMP_INGR | GLScene.OpenGL4 |
GL_ALPHA_MAX_SGIX | GLScene.OpenGL4 |
GL_ALPHA_MIN_CLAMP_INGR | GLScene.OpenGL4 |
GL_ALPHA_MIN_SGIX | GLScene.OpenGL4 | GL_SGIX_blend_alpha_minmax
GL_ALPHA_SCALE | GLScene.OpenGL4 |
GL_ALPHA_SNORM | GLScene.OpenGL4 | GL_EXT_texture_snorm
GL_ALPHA_TEST | GLScene.OpenGL4 |
GL_ALPHA_TEST_FUNC | GLScene.OpenGL4 |
GL_ALPHA_TEST_REF | GLScene.OpenGL4 |
GL_ALREADY_SIGNALED | GLScene.OpenGL4 |
GL_ALWAYS | GLScene.OpenGL4 |
GL_ALWAYS_FAST_HINT_PGI | GLScene.OpenGL4 |
GL_ALWAYS_SOFT_HINT_PGI | GLScene.OpenGL4 |
GL_AMBIENT | GLScene.OpenGL4 |
GL_AMBIENT_AND_DIFFUSE | GLScene.OpenGL4 |
GL_AND | GLScene.OpenGL4 |
GL_AND_INVERTED | GLScene.OpenGL4 |
GL_AND_REVERSE | GLScene.OpenGL4 |
GL_ANY_SAMPLES_PASSED | GLScene.OpenGL4 | GL_ARB_occlusion_query2
GL_ANY_SAMPLES_PASSED_CONSERVATIVE | GLScene.OpenGL4 |
GL_ARC_TO_NV | GLScene.OpenGL4 |
GL_ARRAY_BUFFER | GLScene.OpenGL4 |
GL_ARRAY_BUFFER_ARB | GLScene.OpenGL4 |
GL_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_ARRAY_ELEMENT_LOCK_COUNT_EXT | GLScene.OpenGL4 |
GL_ARRAY_ELEMENT_LOCK_FIRST_EXT | GLScene.OpenGL4 | GL_EXT_compiled_vertex_array
GL_ARRAY_OBJECT_BUFFER_ATI | GLScene.OpenGL4 |
GL_ARRAY_OBJECT_OFFSET_ATI | GLScene.OpenGL4 |
GL_ARRAY_SIZE | GLScene.OpenGL4 |
GL_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_ASE_MAX_SMOOTH_GROUPS | GXS.FileASE | maximum material submaterials
GL_ASE_MAX_SUBMATERIALS | GXS.FileASE | maximum texture channels
GL_ASE_MAX_TEXTURE_MAPS | GXS.FileASE | maximum smoothing groups
GL_ASE_MAX_TEXURE_CHANNELS | GXS.FileASE |
GL_ASYNC_DRAW_PIXELS_SGIX | GLScene.OpenGL4 |
GL_ASYNC_HISTOGRAM_SGIX | GLScene.OpenGL4 | GL_SGIX_async_histogram
GL_ASYNC_MARKER_SGIX | GLScene.OpenGL4 | GL_SGIX_async
GL_ASYNC_READ_PIXELS_SGIX | GLScene.OpenGL4 |
GL_ASYNC_TEX_IMAGE_SGIX | GLScene.OpenGL4 | GL_SGIX_async_pixel
GL_ATOMIC_COUNTER_BARRIER_BIT | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER | GLScene.OpenGL4 | GL_ARB_shader_atomic_counters
GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_BINDING | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_INDEX | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_SIZE | GLScene.OpenGL4 |
GL_ATOMIC_COUNTER_BUFFER_START | GLScene.OpenGL4 |
GL_ATTACHED_SHADERS | GLScene.OpenGL4 |
GL_ATTENUATION_EXT | GLScene.OpenGL4 |
GL_ATTRIB_ARRAY_POINTER_NV | GLScene.OpenGL4 |
GL_ATTRIB_ARRAY_SIZE_NV | GLScene.OpenGL4 |
GL_ATTRIB_ARRAY_STRIDE_NV | GLScene.OpenGL4 |
GL_ATTRIB_ARRAY_TYPE_NV | GLScene.OpenGL4 |
GL_ATTRIB_STACK_DEPTH | GLScene.OpenGL4 |
GL_AUTO_GENERATE_MIPMAP | GLScene.OpenGL4 |
GL_AUTO_NORMAL | GLScene.OpenGL4 |
GL_AUX0 | GLScene.OpenGL4 |
GL_AUX1 | GLScene.OpenGL4 |
GL_AUX2 | GLScene.OpenGL4 |
GL_AUX3 | GLScene.OpenGL4 |
GL_AUX_BUFFERS | GLScene.OpenGL4 |
GL_AUX_DEPTH_STENCIL_APPLE | GLScene.OpenGL4 | GL_APPLE_aux_depth_stencil
GL_AVERAGE_EXT | GLScene.OpenGL4 |
GL_AVERAGE_HP | GLScene.OpenGL4 |
GL_BACK | GLScene.OpenGL4 |
GL_BACK_LEFT | GLScene.OpenGL4 |
GL_BACK_NORMALS_HINT_PGI | GLScene.OpenGL4 |
GL_BACK_PRIMARY_COLOR_NV | GLScene.OpenGL4 |
GL_BACK_RIGHT | GLScene.OpenGL4 |
GL_BACK_SECONDARY_COLOR_NV | GLScene.OpenGL4 |
GL_BEVEL_NV | GLScene.OpenGL4 |
GL_BGR | GLScene.OpenGL4 |
GL_BGRA | GLScene.OpenGL4 |
GL_BGRA_EXT | GLScene.OpenGL4 |
GL_BGRA_INTEGER | GLScene.OpenGL4 |
GL_BGRA_INTEGER_EXT | GLScene.OpenGL4 |
GL_BGR_EXT | GLScene.OpenGL4 | GL_EXT_bgra
GL_BGR_INTEGER | GLScene.OpenGL4 |
GL_BGR_INTEGER_EXT | GLScene.OpenGL4 |
GL_BIAS_BIT_ATI | GLScene.OpenGL4 |
GL_BIAS_BY_NEGATIVE_ONE_HALF_NV | GLScene.OpenGL4 |
GL_BINORMAL_ARRAY_EXT | GLScene.OpenGL4 |
GL_BINORMAL_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_BINORMAL_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_BINORMAL_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_BITMAP | GLScene.OpenGL4 |
GL_BITMAP_TOKEN | GLScene.OpenGL4 |
GL_BLEND | GLScene.OpenGL4 |
GL_BLEND_ADVANCED_COHERENT_KHR | GLScene.OpenGL4 | GL_KHR_blend_equation_advanced_coherent
GL_BLEND_COLOR | GLScene.OpenGL4 |
GL_BLEND_COLOR_EXT | GLScene.OpenGL4 |
GL_BLEND_DST | GLScene.OpenGL4 |
GL_BLEND_DST_ALPHA | GLScene.OpenGL4 |
GL_BLEND_DST_ALPHA_EXT | GLScene.OpenGL4 |
GL_BLEND_DST_RGB | GLScene.OpenGL4 | GL_VERSION_1_4
GL_BLEND_DST_RGB_EXT | GLScene.OpenGL4 | GL_EXT_blend_func_separate
GL_BLEND_EQUATION | GLScene.OpenGL4 |
GL_BLEND_EQUATION_ALPHA | GLScene.OpenGL4 |
GL_BLEND_EQUATION_ALPHA_EXT | GLScene.OpenGL4 |
GL_BLEND_EQUATION_EXT | GLScene.OpenGL4 |
GL_BLEND_EQUATION_RGB | GLScene.OpenGL4 | GL_VERSION_2_0
GL_BLEND_EQUATION_RGB_EXT | GLScene.OpenGL4 | GL_EXT_blend_equation_separate
GL_BLEND_SRC | GLScene.OpenGL4 |
GL_BLEND_SRC_ALPHA | GLScene.OpenGL4 |
GL_BLEND_SRC_ALPHA_EXT | GLScene.OpenGL4 |
GL_BLEND_SRC_RGB | GLScene.OpenGL4 |
GL_BLEND_SRC_RGB_EXT | GLScene.OpenGL4 |
GL_BLOCK_INDEX | GLScene.OpenGL4 |
GL_BLUE | GLScene.OpenGL4 |
GL_BLUE_BIAS | GLScene.OpenGL4 |
GL_BLUE_BITS | GLScene.OpenGL4 |
GL_BLUE_BIT_ATI | GLScene.OpenGL4 |
GL_BLUE_INTEGER | GLScene.OpenGL4 |
GL_BLUE_INTEGER_EXT | GLScene.OpenGL4 |
GL_BLUE_MAX_CLAMP_INGR | GLScene.OpenGL4 |
GL_BLUE_MIN_CLAMP_INGR | GLScene.OpenGL4 |
GL_BLUE_SCALE | GLScene.OpenGL4 |
GL_BOLD_BIT_NV | GLScene.OpenGL4 |
GL_BOOL | GLScene.OpenGL4 |
GL_BOOL_ARB | GLScene.OpenGL4 |
GL_BOOL_VEC2 | GLScene.OpenGL4 |
GL_BOOL_VEC2_ARB | GLScene.OpenGL4 |
GL_BOOL_VEC3 | GLScene.OpenGL4 |
GL_BOOL_VEC3_ARB | GLScene.OpenGL4 |
GL_BOOL_VEC4 | GLScene.OpenGL4 |
GL_BOOL_VEC4_ARB | GLScene.OpenGL4 |
GL_BOUNDING_BOX_NV | GLScene.OpenGL4 |
GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV | GLScene.OpenGL4 |
GL_BUFFER | GLScene.OpenGL4 |
GL_BUFFER_ACCESS | GLScene.OpenGL4 |
GL_BUFFER_ACCESS_ARB | GLScene.OpenGL4 |
GL_BUFFER_ACCESS_FLAGS | GLScene.OpenGL4 |
GL_BUFFER_BINDING | GLScene.OpenGL4 |
GL_BUFFER_DATA_SIZE | GLScene.OpenGL4 |
GL_BUFFER_GPU_ADDRESS_NV | GLScene.OpenGL4 | GL_NV_shader_buffer_load
GL_BUFFER_IMMUTABLE_STORAGE | GLScene.OpenGL4 |
GL_BUFFER_MAPPED | GLScene.OpenGL4 |
GL_BUFFER_MAPPED_ARB | GLScene.OpenGL4 |
GL_BUFFER_MAP_LENGTH | GLScene.OpenGL4 |
GL_BUFFER_MAP_OFFSET | GLScene.OpenGL4 |
GL_BUFFER_MAP_POINTER | GLScene.OpenGL4 |
GL_BUFFER_MAP_POINTER_ARB | GLScene.OpenGL4 |
GL_BUFFER_OBJECT_APPLE | GLScene.OpenGL4 | GL_APPLE_object_purgeable
GL_BUFFER_SIZE | GLScene.OpenGL4 | GL_VERSION_1_5
GL_BUFFER_SIZE_ARB | GLScene.OpenGL4 | GL_ARB_vertex_buffer_object
GL_BUFFER_STORAGE_FLAGS | GLScene.OpenGL4 |
GL_BUFFER_UPDATE_BARRIER_BIT | GLScene.OpenGL4 |
GL_BUFFER_UPDATE_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_BUFFER_USAGE | GLScene.OpenGL4 |
GL_BUFFER_USAGE_ARB | GLScene.OpenGL4 |
GL_BUFFER_VARIABLE | GLScene.OpenGL4 |
GL_BUMP_ENVMAP_ATI | GLScene.OpenGL4 |
GL_BUMP_NUM_TEX_UNITS_ATI | GLScene.OpenGL4 |
GL_BUMP_ROT_MATRIX_ATI | GLScene.OpenGL4 | GL_ATI_envmap_bumpmap
GL_BUMP_ROT_MATRIX_SIZE_ATI | GLScene.OpenGL4 |
GL_BUMP_TARGET_ATI | GLScene.OpenGL4 |
GL_BUMP_TEX_UNITS_ATI | GLScene.OpenGL4 |
GL_BYTE | GLScene.OpenGL4 | DataType
GL_C3F_V3F | GLScene.OpenGL4 |
GL_C4F_N3F_V3F | GLScene.OpenGL4 |
GL_C4UB_V2F | GLScene.OpenGL4 |
GL_C4UB_V3F | GLScene.OpenGL4 |
GL_CALLIGRAPHIC_FRAGMENT_SGIX | GLScene.OpenGL4 | GL_SGIX_calligraphic_fragment
GL_CAVEAT_SUPPORT | GLScene.OpenGL4 |
GL_CCW | GLScene.OpenGL4 |
GL_CIRCULAR_CCW_ARC_TO_NV | GLScene.OpenGL4 |
GL_CIRCULAR_CW_ARC_TO_NV | GLScene.OpenGL4 |
GL_CIRCULAR_TANGENT_ARC_TO_NV | GLScene.OpenGL4 |
GL_CLAMP | GLScene.OpenGL4 |
GL_CLAMP_FRAGMENT_COLOR | GLScene.OpenGL4 |
GL_CLAMP_FRAGMENT_COLOR_ARB | GLScene.OpenGL4 |
GL_CLAMP_READ_COLOR | GLScene.OpenGL4 |
GL_CLAMP_READ_COLOR_ARB | GLScene.OpenGL4 |
GL_CLAMP_TO_BORDER | GLScene.OpenGL4 |
GL_CLAMP_TO_BORDER_ARB | GLScene.OpenGL4 | GL_ARB_texture_border_clamp
GL_CLAMP_TO_EDGE | GLScene.OpenGL4 |
GL_CLAMP_TO_EDGE_EXT | GLScene.OpenGL4 | GL_EXT_texture_edge_clamp
GL_CLAMP_TO_EDGE_SGIS | GLScene.OpenGL4 | GL_SGIS_texture_edge_clamp
GL_CLAMP_VERTEX_COLOR | GLScene.OpenGL4 |
GL_CLAMP_VERTEX_COLOR_ARB | GLScene.OpenGL4 |
GL_CLEAR | GLScene.OpenGL4 | LogicOp
GL_CLEAR_BUFFER | GLScene.OpenGL4 |
GL_CLEAR_TEXTURE | GLScene.OpenGL4 |
GL_CLIENT_ACTIVE_TEXTURE | GLScene.OpenGL4 |
GL_CLIENT_ACTIVE_TEXTURE_ARB | GLScene.OpenGL4 |
GL_CLIENT_ALL_ATTRIB_BITS | GLScene.OpenGL4 |
GL_CLIENT_ATTRIB_STACK_DEPTH | GLScene.OpenGL4 |
GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT | GLScene.OpenGL4 |
GL_CLIENT_PIXEL_STORE_BIT | GLScene.OpenGL4 |
GL_CLIENT_STORAGE_BIT | GLScene.OpenGL4 |
GL_CLIENT_VERTEX_ARRAY_BIT | GLScene.OpenGL4 |
GL_CLIPPING_INPUT_PRIMITIVES | GLScene.OpenGL4 |
GL_CLIPPING_INPUT_PRIMITIVES_ARB | GLScene.OpenGL4 |
GL_CLIPPING_OUTPUT_PRIMITIVES | GLScene.OpenGL4 |
GL_CLIPPING_OUTPUT_PRIMITIVES_ARB | GLScene.OpenGL4 |
GL_CLIP_DEPTH_MODE | GLScene.OpenGL4 |
GL_CLIP_DISTANCE0 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE1 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE2 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE3 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE4 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE5 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE6 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE7 | GLScene.OpenGL4 |
GL_CLIP_DISTANCE_NV | GLScene.OpenGL4 |
GL_CLIP_FAR_HINT_PGI | GLScene.OpenGL4 |
GL_CLIP_NEAR_HINT_PGI | GLScene.OpenGL4 |
GL_CLIP_ORIGIN | GLScene.OpenGL4 |
GL_CLIP_PLANE0 | GLScene.OpenGL4 |
GL_CLIP_PLANE1 | GLScene.OpenGL4 |
GL_CLIP_PLANE2 | GLScene.OpenGL4 |
GL_CLIP_PLANE3 | GLScene.OpenGL4 |
GL_CLIP_PLANE4 | GLScene.OpenGL4 |
GL_CLIP_PLANE5 | GLScene.OpenGL4 |
GL_CLIP_VOLUME_CLIPPING_HINT_EXT | GLScene.OpenGL4 | GL_EXT_clip_volume_hint
GL_CLOSE_PATH_NV | GLScene.OpenGL4 |
GL_CMYKA_EXT | GLScene.OpenGL4 |
GL_CMYK_EXT | GLScene.OpenGL4 | GL_EXT_cmyka
GL_CND0_ATI | GLScene.OpenGL4 |
GL_CND_ATI | GLScene.OpenGL4 |
GL_COEFF | GLScene.OpenGL4 |
GL_COLOR | GLScene.OpenGL4 | PixelCopyType
GL_COLOR3_BIT_PGI | GLScene.OpenGL4 |
GL_COLOR4_BIT_PGI | GLScene.OpenGL4 |
GL_COLORBURN_KHR | GLScene.OpenGL4 |
GL_COLORDODGE_KHR | GLScene.OpenGL4 |
GL_COLOR_ALPHA_PAIRING_ATI | GLScene.OpenGL4 |
GL_COLOR_ARRAY | GLScene.OpenGL4 |
GL_COLOR_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_COLOR_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_COLOR_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_COLOR_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_COLOR_ARRAY_EXT | GLScene.OpenGL4 |
GL_COLOR_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_COLOR_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_COLOR_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL | GLScene.OpenGL4 |
GL_COLOR_ARRAY_POINTER | GLScene.OpenGL4 |
GL_COLOR_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_COLOR_ARRAY_SIZE | GLScene.OpenGL4 |
GL_COLOR_ARRAY_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_COLOR_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_COLOR_ARRAY_TYPE | GLScene.OpenGL4 |
GL_COLOR_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT0 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT0_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT1 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT10 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT10_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT11 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT11_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT12 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT12_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT13 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT13_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT14 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT14_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT15 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT15_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT1_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT2 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT2_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT3 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT3_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT4 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT4_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT5 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT5_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT6 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT6_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT7 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT7_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT8 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT8_EXT | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT9 | GLScene.OpenGL4 |
GL_COLOR_ATTACHMENT9_EXT | GLScene.OpenGL4 |
GL_COLOR_BUFFER_BIT | GLScene.OpenGL4 |
GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI | GLScene.OpenGL4 |
GL_COLOR_CLEAR_VALUE | GLScene.OpenGL4 |
GL_COLOR_COMPONENTS | GLScene.OpenGL4 |
GL_COLOR_ENCODING | GLScene.OpenGL4 |
GL_COLOR_FLOAT_APPLE | GLScene.OpenGL4 |
GL_COLOR_INDEX | GLScene.OpenGL4 |
GL_COLOR_INDEX12_EXT | GLScene.OpenGL4 |
GL_COLOR_INDEX16_EXT | GLScene.OpenGL4 |
GL_COLOR_INDEX1_EXT | GLScene.OpenGL4 | GL_EXT_paletted_texture
GL_COLOR_INDEX2_EXT | GLScene.OpenGL4 |
GL_COLOR_INDEX4_EXT | GLScene.OpenGL4 |
GL_COLOR_INDEX8_EXT | GLScene.OpenGL4 |
GL_COLOR_INDEXES | GLScene.OpenGL4 |
GL_COLOR_LOGIC_OP | GLScene.OpenGL4 |
GL_COLOR_MATERIAL | GLScene.OpenGL4 |
GL_COLOR_MATERIAL_FACE | GLScene.OpenGL4 |
GL_COLOR_MATERIAL_PARAMETER | GLScene.OpenGL4 |
GL_COLOR_MATRIX | GLScene.OpenGL4 |
GL_COLOR_MATRIX_SGI | GLScene.OpenGL4 | GL_SGI_color_matrix
GL_COLOR_MATRIX_STACK_DEPTH | GLScene.OpenGL4 |
GL_COLOR_MATRIX_STACK_DEPTH_SGI | GLScene.OpenGL4 |
GL_COLOR_RENDERABLE | GLScene.OpenGL4 |
GL_COLOR_SAMPLES_NV | GLScene.OpenGL4 |
GL_COLOR_SUM | GLScene.OpenGL4 |
GL_COLOR_SUM_ARB | GLScene.OpenGL4 | GL_ARB_vertex_program
GL_COLOR_SUM_CLAMP_NV | GLScene.OpenGL4 |
GL_COLOR_SUM_EXT | GLScene.OpenGL4 | GL_EXT_secondary_color
GL_COLOR_TABLE | GLScene.OpenGL4 |
GL_COLOR_TABLE_ALPHA_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_ALPHA_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_ALPHA_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_BIAS | GLScene.OpenGL4 |
GL_COLOR_TABLE_BIAS_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_BLUE_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_BLUE_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_BLUE_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_FORMAT | GLScene.OpenGL4 |
GL_COLOR_TABLE_FORMAT_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_FORMAT_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_GREEN_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_GREEN_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_GREEN_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_INTENSITY_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_INTENSITY_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_INTENSITY_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_LUMINANCE_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_LUMINANCE_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_LUMINANCE_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_RED_SIZE | GLScene.OpenGL4 |
GL_COLOR_TABLE_RED_SIZE_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_RED_SIZE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_SCALE | GLScene.OpenGL4 |
GL_COLOR_TABLE_SCALE_SGI | GLScene.OpenGL4 |
GL_COLOR_TABLE_SGI | GLScene.OpenGL4 | GL_SGI_color_table
GL_COLOR_TABLE_WIDTH | GLScene.OpenGL4 |
GL_COLOR_TABLE_WIDTH_EXT | GLScene.OpenGL4 |
GL_COLOR_TABLE_WIDTH_SGI | GLScene.OpenGL4 |
GL_COLOR_WRITEMASK | GLScene.OpenGL4 |
GL_COMBINE | GLScene.OpenGL4 |
GL_COMBINE4_NV | GLScene.OpenGL4 | GL_NV_texture_env_combine4
GL_COMBINER0_NV | GLScene.OpenGL4 |
GL_COMBINER1_NV | GLScene.OpenGL4 |
GL_COMBINER2_NV | GLScene.OpenGL4 |
GL_COMBINER3_NV | GLScene.OpenGL4 |
GL_COMBINER4_NV | GLScene.OpenGL4 |
GL_COMBINER5_NV | GLScene.OpenGL4 |
GL_COMBINER6_NV | GLScene.OpenGL4 |
GL_COMBINER7_NV | GLScene.OpenGL4 |
GL_COMBINER_AB_DOT_PRODUCT_NV | GLScene.OpenGL4 |
GL_COMBINER_AB_OUTPUT_NV | GLScene.OpenGL4 |
GL_COMBINER_BIAS_NV | GLScene.OpenGL4 |
GL_COMBINER_CD_DOT_PRODUCT_NV | GLScene.OpenGL4 |
GL_COMBINER_CD_OUTPUT_NV | GLScene.OpenGL4 |
GL_COMBINER_COMPONENT_USAGE_NV | GLScene.OpenGL4 |
GL_COMBINER_INPUT_NV | GLScene.OpenGL4 |
GL_COMBINER_MAPPING_NV | GLScene.OpenGL4 |
GL_COMBINER_MUX_SUM_NV | GLScene.OpenGL4 |
GL_COMBINER_SCALE_NV | GLScene.OpenGL4 |
GL_COMBINER_SUM_OUTPUT_NV | GLScene.OpenGL4 |
GL_COMBINE_ALPHA | GLScene.OpenGL4 |
GL_COMBINE_ALPHA_ARB | GLScene.OpenGL4 |
GL_COMBINE_ALPHA_EXT | GLScene.OpenGL4 |
GL_COMBINE_ARB | GLScene.OpenGL4 | GL_ARB_texture_env_combine
GL_COMBINE_EXT | GLScene.OpenGL4 | GL_EXT_texture_env_combine
GL_COMBINE_RGB | GLScene.OpenGL4 |
GL_COMBINE_RGB_ARB | GLScene.OpenGL4 |
GL_COMBINE_RGB_EXT | GLScene.OpenGL4 |
GL_COMMAND_BARRIER_BIT | GLScene.OpenGL4 |
GL_COMMAND_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT | GLScene.OpenGL4 |
GL_COMPARE_REF_TO_TEXTURE | GLScene.OpenGL4 | GL_VERSION_3_0
GL_COMPARE_R_TO_TEXTURE | GLScene.OpenGL4 |
GL_COMPARE_R_TO_TEXTURE_ARB | GLScene.OpenGL4 |
GL_COMPATIBLE_SUBROUTINES | GLScene.OpenGL4 |
GL_COMPILE | GLScene.OpenGL4 |
GL_COMPILE_AND_EXECUTE | GLScene.OpenGL4 |
GL_COMPILE_STATUS | GLScene.OpenGL4 |
GL_COMPLETION_STATUS_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_ALPHA | GLScene.OpenGL4 |
GL_COMPRESSED_ALPHA_ARB | GLScene.OpenGL4 | GL_ARB_texture_compression
GL_COMPRESSED_INTENSITY | GLScene.OpenGL4 |
GL_COMPRESSED_INTENSITY_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE_ALPHA | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI | GLScene.OpenGLTokens | GL_ATI_texture_compression_3dc
GL_COMPRESSED_LUMINANCE_ALPHA_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_LUMINANCE_LATC1_EXT | GLScene.OpenGL4 | GL_EXT_texture_compression_latc
GL_COMPRESSED_R11_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_RED | GLScene.OpenGL4 |
GL_COMPRESSED_RED_GREEN_RGTC2_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_RED_RGTC1 | GLScene.OpenGL4 | GL_ARB_texture_compression_rgtc
GL_COMPRESSED_RED_RGTC1_EXT | GLScene.OpenGL4 | GL_EXT_texture_compression_rgtc
GL_COMPRESSED_RG | GLScene.OpenGL4 |
GL_COMPRESSED_RG11_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_RGB | GLScene.OpenGL4 |
GL_COMPRESSED_RGB8_ETC2 | GLScene.OpenGL4 |
GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2 | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA8_ETC2_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_105_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_106_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_108_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_110_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_12x10_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_12x12_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_4x4_KHR | GLScene.OpenGL4 | 4.3 GL_KHR_texture_compression_astc_hdr
GL_COMPRESSED_RGBA_ASTC_5x4_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_5x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_6x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_6x6_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_8x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_8x6_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_ASTC_8x8_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_BPTC_UNORM_ARB | GLScene.OpenGL4 | GL_ARB_texture_compression_bptc
GL_COMPRESSED_RGBA_FXT1_3DFX | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_S3TC_DXT1_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_S3TC_DXT3_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_RGBA_S3TC_DXT5_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_RGB_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_RGB_FXT1_3DFX | GLScene.OpenGL4 | GL_3DFX_texture_compression_FXT1
GL_COMPRESSED_RGB_S3TC_DXT1_EXT | GLScene.OpenGL4 | GL_EXT_texture_compression_s3tc
GL_COMPRESSED_RG_RGTC2 | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_R11_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_RED_RGTC1 | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_RED_RGTC1_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_RG11_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_SIGNED_RG_RGTC2 | GLScene.OpenGL4 |
GL_COMPRESSED_SLUMINANCE | GLScene.OpenGL4 |
GL_COMPRESSED_SLUMINANCE_ALPHA | GLScene.OpenGL4 |
GL_COMPRESSED_SLUMINANCE_ALPHA_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SLUMINANCE_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_ETC2 | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2 | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_SRGB_S3TC_DXT1_EXT | GLScene.OpenGL4 |
GL_COMPRESSED_TEXTURE_FORMATS | GLScene.OpenGL4 |
GL_COMPRESSED_TEXTURE_FORMATS_ARB | GLScene.OpenGL4 |
GL_COMPUTE_LOCAL_WORK_SIZE | GLScene.OpenGL4 |
GL_COMPUTE_SHADER | GLScene.OpenGL4 |
GL_COMPUTE_SHADER_BIT | GLScene.OpenGL4 |
GL_COMPUTE_SHADER_INVOCATIONS | GLScene.OpenGL4 |
GL_COMPUTE_SHADER_INVOCATIONS_ARB | GLScene.OpenGL4 |
GL_COMPUTE_SUBROUTINE | GLScene.OpenGL4 |
GL_COMPUTE_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_COMPUTE_TEXTURE | GLScene.OpenGL4 |
GL_COMP_BIT_ATI | GLScene.OpenGL4 |
GL_CONDITION_SATISFIED | GLScene.OpenGL4 |
GL_CONSERVATIVE_RASTERIZATION_NV | GLScene.OpenGL4 | GL_NV_conservative_raster
GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV | GLScene.OpenGL4 |
GL_CONSERVATIVE_RASTER_DILATE_NV | GLScene.OpenGL4 | GL_NV_conservative_raster_dilate
GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV | GLScene.OpenGL4 |
GL_CONSERVE_MEMORY_HINT_PGI | GLScene.OpenGL4 |
GL_CONSTANT | GLScene.OpenGL4 |
GL_CONSTANT_ALPHA | GLScene.OpenGL4 |
GL_CONSTANT_ALPHA_EXT | GLScene.OpenGL4 |
GL_CONSTANT_ARB | GLScene.OpenGL4 |
GL_CONSTANT_ATTENUATION | GLScene.OpenGL4 |
GL_CONSTANT_BORDER | GLScene.OpenGL4 |
GL_CONSTANT_BORDER_HP | GLScene.OpenGL4 |
GL_CONSTANT_COLOR0_NV | GLScene.OpenGL4 |
GL_CONSTANT_COLOR1_NV | GLScene.OpenGL4 |
GL_CONSTANT_COLOR_ARB | GLScene.OpenGL4 | GL_ARB_imaging
GL_CONSTANT_COLOR_EXT | GLScene.OpenGL4 | GL_EXT_blend_color
GL_CONSTANT_EXT | GLScene.OpenGL4 |
GL_CONST_EYE_NV | GLScene.OpenGL4 |
GL_CONTEXT_COMPATIBILITY_PROFILE_BIT | GLScene.OpenGL4 |
GL_CONTEXT_CORE_PROFILE_BIT | GLScene.OpenGL4 | GL_VERSION_3_2
GL_CONTEXT_FLAGS | GLScene.OpenGL4 |
GL_CONTEXT_FLAG_DEBUG_BIT | GLScene.OpenGL4 |
GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT | GLScene.OpenGL4 |
GL_CONTEXT_FLAG_NO_ERROR_BIT | GLScene.OpenGL4 |
GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR | GLScene.OpenGL4 | GL_KHR_no_error
GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT | GLScene.OpenGL4 |
GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB | GLScene.OpenGL4 | GL_ARB_robustness
GL_CONTEXT_LOST | GLScene.OpenGL4 | GL 4.5
GL_CONTEXT_PROFILE_MASK | GLScene.OpenGL4 |
GL_CONTEXT_RELEASE_BEHAVIOR | GLScene.OpenGL4 |
GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH | GLScene.OpenGL4 |
GL_CONTEXT_ROBUST_ACCESS | GLScene.OpenGL4 | GL_KHR_robustness
GL_CONTINUOUS_AMD | GLScene.OpenGL4 |
GL_CONVEX_HULL_NV | GLScene.OpenGL4 |
GL_CONVOLUTION_1D | GLScene.OpenGL4 |
GL_CONVOLUTION_1D_EXT | GLScene.OpenGL4 | GL_EXT_convolution
GL_CONVOLUTION_2D | GLScene.OpenGL4 |
GL_CONVOLUTION_2D_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_BORDER_COLOR | GLScene.OpenGL4 |
GL_CONVOLUTION_BORDER_COLOR_HP | GLScene.OpenGL4 |
GL_CONVOLUTION_BORDER_MODE | GLScene.OpenGL4 |
GL_CONVOLUTION_BORDER_MODE_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_FILTER_BIAS | GLScene.OpenGL4 |
GL_CONVOLUTION_FILTER_BIAS_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_FILTER_SCALE | GLScene.OpenGL4 |
GL_CONVOLUTION_FILTER_SCALE_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_FORMAT | GLScene.OpenGL4 |
GL_CONVOLUTION_FORMAT_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_HEIGHT | GLScene.OpenGL4 |
GL_CONVOLUTION_HEIGHT_EXT | GLScene.OpenGL4 |
GL_CONVOLUTION_HINT_SGIX | GLScene.OpenGL4 | GL_SGIX_convolution_accuracy
GL_CONVOLUTION_WIDTH | GLScene.OpenGL4 |
GL_CONVOLUTION_WIDTH_EXT | GLScene.OpenGL4 |
GL_CON_0_ATI | GLScene.OpenGL4 |
GL_CON_10_ATI | GLScene.OpenGL4 |
GL_CON_11_ATI | GLScene.OpenGL4 |
GL_CON_12_ATI | GLScene.OpenGL4 |
GL_CON_13_ATI | GLScene.OpenGL4 |
GL_CON_14_ATI | GLScene.OpenGL4 |
GL_CON_15_ATI | GLScene.OpenGL4 |
GL_CON_16_ATI | GLScene.OpenGL4 |
GL_CON_17_ATI | GLScene.OpenGL4 |
GL_CON_18_ATI | GLScene.OpenGL4 |
GL_CON_19_ATI | GLScene.OpenGL4 |
GL_CON_1_ATI | GLScene.OpenGL4 |
GL_CON_20_ATI | GLScene.OpenGL4 |
GL_CON_21_ATI | GLScene.OpenGL4 |
GL_CON_22_ATI | GLScene.OpenGL4 |
GL_CON_23_ATI | GLScene.OpenGL4 |
GL_CON_24_ATI | GLScene.OpenGL4 |
GL_CON_25_ATI | GLScene.OpenGL4 |
GL_CON_26_ATI | GLScene.OpenGL4 |
GL_CON_27_ATI | GLScene.OpenGL4 |
GL_CON_28_ATI | GLScene.OpenGL4 |
GL_CON_29_ATI | GLScene.OpenGL4 |
GL_CON_2_ATI | GLScene.OpenGL4 |
GL_CON_30_ATI | GLScene.OpenGL4 |
GL_CON_31_ATI | GLScene.OpenGL4 |
GL_CON_3_ATI | GLScene.OpenGL4 |
GL_CON_4_ATI | GLScene.OpenGL4 |
GL_CON_5_ATI | GLScene.OpenGL4 |
GL_CON_6_ATI | GLScene.OpenGL4 |
GL_CON_7_ATI | GLScene.OpenGL4 |
GL_CON_8_ATI | GLScene.OpenGL4 |
GL_CON_9_ATI | GLScene.OpenGL4 |
GL_COORD_REPLACE | GLScene.OpenGL4 |
GL_COORD_REPLACE_ARB | GLScene.OpenGL4 |
GL_COORD_REPLACE_NV | GLScene.OpenGL4 |
GL_COPY | GLScene.OpenGL4 |
GL_COPY_INVERTED | GLScene.OpenGL4 |
GL_COPY_PIXEL_TOKEN | GLScene.OpenGL4 |
GL_COPY_READ_BUFFER | GLScene.OpenGL4 |
GL_COPY_READ_BUFFER_BINDING | GLScene.OpenGL4 | GL_ARB_copy_buffer
GL_COPY_WRITE_BUFFER | GLScene.OpenGL4 |
GL_COPY_WRITE_BUFFER_BINDING | GLScene.OpenGL4 |
GL_COUNTER_RANGE_AMD | GLScene.OpenGL4 |
GL_COUNTER_TYPE_AMD | GLScene.OpenGL4 | GL_AMD_performance_monitor
GL_COUNT_DOWN_NV | GLScene.OpenGL4 |
GL_COUNT_UP_NV | GLScene.OpenGL4 |
GL_COVERAGE_SAMPLES_NV | GLScene.OpenGL4 | GL_NV_multisample_coverage
GL_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_CUBIC_EXT | GLScene.OpenGL4 |
GL_CUBIC_HP | GLScene.OpenGL4 |
GL_CULL_FACE | GLScene.OpenGL4 |
GL_CULL_FACE_MODE | GLScene.OpenGL4 |
GL_CULL_FRAGMENT_NV | GLScene.OpenGL4 |
GL_CULL_MODES_NV | GLScene.OpenGL4 |
GL_CULL_VERTEX_EXT | GLScene.OpenGL4 | GL_EXT_cull_vertex
GL_CULL_VERTEX_EYE_POSITION_EXT | GLScene.OpenGL4 |
GL_CULL_VERTEX_IBM | GLScene.OpenGL4 | GL_IBM_cull_vertex
GL_CULL_VERTEX_OBJECT_POSITION_EXT | GLScene.OpenGL4 |
GL_CURRENT_ATTRIB_NV | GLScene.OpenGL4 |
GL_CURRENT_BINORMAL_EXT | GLScene.OpenGL4 |
GL_CURRENT_BIT | GLScene.OpenGL4 |
GL_CURRENT_COLOR | GLScene.OpenGL4 |
GL_CURRENT_FOG_COORD | GLScene.OpenGL4 |
GL_CURRENT_FOG_COORDINATE | GLScene.OpenGL4 |
GL_CURRENT_FOG_COORDINATE_EXT | GLScene.OpenGL4 |
GL_CURRENT_INDEX | GLScene.OpenGL4 |
GL_CURRENT_MATRIX_ARB | GLScene.OpenGL4 |
GL_CURRENT_MATRIX_INDEX_ARB | GLScene.OpenGL4 |
GL_CURRENT_MATRIX_NV | GLScene.OpenGL4 |
GL_CURRENT_MATRIX_STACK_DEPTH_ARB | GLScene.OpenGL4 |
GL_CURRENT_MATRIX_STACK_DEPTH_NV | GLScene.OpenGL4 |
GL_CURRENT_NORMAL | GLScene.OpenGL4 |
GL_CURRENT_OCCLUSION_QUERY_ID_NV | GLScene.OpenGL4 |
GL_CURRENT_PALETTE_MATRIX_ARB | GLScene.OpenGL4 |
GL_CURRENT_PROGRAM | GLScene.OpenGL4 |
GL_CURRENT_QUERY | GLScene.OpenGL4 |
GL_CURRENT_QUERY_ARB | GLScene.OpenGL4 |
GL_CURRENT_RASTER_COLOR | GLScene.OpenGL4 |
GL_CURRENT_RASTER_DISTANCE | GLScene.OpenGL4 |
GL_CURRENT_RASTER_INDEX | GLScene.OpenGL4 |
GL_CURRENT_RASTER_NORMAL_SGIX | GLScene.OpenGL4 |
GL_CURRENT_RASTER_POSITION | GLScene.OpenGL4 |
GL_CURRENT_RASTER_POSITION_VALID | GLScene.OpenGL4 |
GL_CURRENT_RASTER_SECONDARY_COLOR | GLScene.OpenGL4 |
GL_CURRENT_RASTER_TEXTURE_COORDS | GLScene.OpenGL4 |
GL_CURRENT_SECONDARY_COLOR | GLScene.OpenGL4 |
GL_CURRENT_SECONDARY_COLOR_EXT | GLScene.OpenGL4 |
GL_CURRENT_TANGENT_EXT | GLScene.OpenGL4 |
GL_CURRENT_TEXTURE_COORDS | GLScene.OpenGL4 |
GL_CURRENT_TIME_NV | GLScene.OpenGL4 |
GL_CURRENT_VERTEX_ATTRIB | GLScene.OpenGL4 |
GL_CURRENT_VERTEX_ATTRIB_ARB | GLScene.OpenGL4 |
GL_CURRENT_VERTEX_EXT | GLScene.OpenGL4 |
GL_CURRENT_VERTEX_WEIGHT_EXT | GLScene.OpenGL4 |
GL_CURRENT_WEIGHT_ARB | GLScene.OpenGL4 |
GL_CW | GLScene.OpenGL4 | FrontFaceDirection
GL_DARKEN_KHR | GLScene.OpenGL4 |
GL_DATA_BUFFER_AMD | GLScene.OpenGL4 | GL_AMD_name_gen_delete
GL_DEBUG_CALLBACK_FUNCTION | GLScene.OpenGL4 |
GL_DEBUG_CALLBACK_FUNCTION_ARB | GLScene.OpenGL4 |
GL_DEBUG_CALLBACK_USER_PARAM | GLScene.OpenGL4 |
GL_DEBUG_CALLBACK_USER_PARAM_ARB | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_API_ERROR_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_APPLICATION_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_DEPRECATION_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_OTHER_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_PERFORMANCE_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD | GLScene.OpenGL4 |
GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD | GLScene.OpenGL4 |
GL_DEBUG_GROUP_STACK_DEPTH | GLScene.OpenGL4 |
GL_DEBUG_LOGGED_MESSAGES | GLScene.OpenGL4 |
GL_DEBUG_LOGGED_MESSAGES_AMD | GLScene.OpenGL4 |
GL_DEBUG_LOGGED_MESSAGES_ARB | GLScene.OpenGL4 |
GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH | GLScene.OpenGL4 |
GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB | GLScene.OpenGL4 |
GL_DEBUG_OUTPUT | GLScene.OpenGL4 |
GL_DEBUG_OUTPUT_SYNCHRONOUS | GLScene.OpenGL4 | (4.3) GL_KHR_debug
GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB | GLScene.OpenGL4 | GL_ARB_debug_output
GL_DEBUG_SEVERITY_HIGH | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_HIGH_AMD | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_HIGH_ARB | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_LOW | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_LOW_AMD | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_LOW_ARB | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_MEDIUM | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_MEDIUM_AMD | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_MEDIUM_ARB | GLScene.OpenGL4 |
GL_DEBUG_SEVERITY_NOTIFICATION | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_API | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_API_ARB | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_APPLICATION | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_APPLICATION_ARB | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_OTHER | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_OTHER_ARB | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_SHADER_COMPILER | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_SHADER_COMPILER_ARB | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_THIRD_PARTY | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_THIRD_PARTY_ARB | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_WINDOW_SYSTEM | GLScene.OpenGL4 |
GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR | GLScene.OpenGL4 |
GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_ERROR | GLScene.OpenGL4 |
GL_DEBUG_TYPE_ERROR_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_MARKER | GLScene.OpenGL4 |
GL_DEBUG_TYPE_OTHER | GLScene.OpenGL4 |
GL_DEBUG_TYPE_OTHER_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_PERFORMANCE | GLScene.OpenGL4 |
GL_DEBUG_TYPE_PERFORMANCE_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_POP_GROUP | GLScene.OpenGL4 |
GL_DEBUG_TYPE_PORTABILITY | GLScene.OpenGL4 |
GL_DEBUG_TYPE_PORTABILITY_ARB | GLScene.OpenGL4 |
GL_DEBUG_TYPE_PUSH_GROUP | GLScene.OpenGL4 |
GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR | GLScene.OpenGL4 |
GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB | GLScene.OpenGL4 |
GL_DECAL | GLScene.OpenGL4 |
GL_DECODE_EXT | GLScene.OpenGL4 |
GL_DECR | GLScene.OpenGL4 |
GL_DECR_WRAP | GLScene.OpenGL4 |
GL_DECR_WRAP_EXT | GLScene.OpenGL4 |
GL_DEFORMATIONS_MASK_SGIX | GLScene.OpenGL4 |
GL_DELETE_STATUS | GLScene.OpenGL4 |
GL_DEPENDENT_AR_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_DEPENDENT_GB_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_DEPENDENT_HILO_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_DEPENDENT_RGB_TEXTURE_3D_NV | GLScene.OpenGL4 |
GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV | GLScene.OpenGL4 |
GL_DEPTH | GLScene.OpenGL4 |
GL_DEPTH24_STENCIL8 | GLScene.OpenGL4 |
GL_DEPTH24_STENCIL8_EXT | GLScene.OpenGL4 |
GL_DEPTH32F_STENCIL8 | GLScene.OpenGL4 |
GL_DEPTH_ATTACHMENT | GLScene.OpenGL4 |
GL_DEPTH_ATTACHMENT_EXT | GLScene.OpenGL4 |
GL_DEPTH_BIAS | GLScene.OpenGL4 |
GL_DEPTH_BITS | GLScene.OpenGL4 |
GL_DEPTH_BOUNDS_EXT | GLScene.OpenGL4 |
GL_DEPTH_BOUNDS_TEST_EXT | GLScene.OpenGL4 | GL_EXT_depth_bounds_test
GL_DEPTH_BUFFER | GLScene.OpenGL4 |
GL_DEPTH_BUFFER_BIT | GLScene.OpenGL4 | AttribMask
GL_DEPTH_BUFFER_FLOAT_MODE_NV | GLScene.OpenGL4 |
GL_DEPTH_CLAMP | GLScene.OpenGL4 | GL_ARB_depth_clamp
GL_DEPTH_CLAMP_FAR_AMD | GLScene.OpenGL4 |
GL_DEPTH_CLAMP_NEAR_AMD | GLScene.OpenGL4 | GL_AMD_depth_clamp_separate
GL_DEPTH_CLAMP_NV | GLScene.OpenGL4 | GL_NV_depth_clamp
GL_DEPTH_CLEAR_VALUE | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT16 | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT16_ARB | GLScene.OpenGL4 | GL_ARB_depth_texture
GL_DEPTH_COMPONENT16_SGIX | GLScene.OpenGL4 | GL_SGIX_depth_texture
GL_DEPTH_COMPONENT24 | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT24_ARB | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT24_SGIX | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT32 | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT32F | GLScene.OpenGL4 | GL_ARB_depth_buffer_float
GL_DEPTH_COMPONENT32_ARB | GLScene.OpenGL4 |
GL_DEPTH_COMPONENT32_SGIX | GLScene.OpenGL4 |
GL_DEPTH_COMPONENTS | GLScene.OpenGL4 |
GL_DEPTH_FUNC | GLScene.OpenGL4 |
GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX | GLScene.OpenGL4 |
GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX | GLScene.OpenGL4 |
GL_DEPTH_PASS_INSTRUMENT_SGIX | GLScene.OpenGL4 | GL_SGI_depth_pass_instrument
GL_DEPTH_RANGE | GLScene.OpenGL4 |
GL_DEPTH_RENDERABLE | GLScene.OpenGL4 |
GL_DEPTH_SCALE | GLScene.OpenGL4 |
GL_DEPTH_STENCIL | GLScene.OpenGL4 |
GL_DEPTH_STENCIL_ATTACHMENT | GLScene.OpenGL4 |
GL_DEPTH_STENCIL_EXT | GLScene.OpenGL4 | GL_EXT_packed_depth_stencil
GL_DEPTH_STENCIL_NV | GLScene.OpenGL4 | GL_NV_packed_depth_stencil
GL_DEPTH_STENCIL_TEXTURE_MODE | GLScene.OpenGL4 |
GL_DEPTH_STENCIL_TO_BGRA_NV | GLScene.OpenGL4 |
GL_DEPTH_STENCIL_TO_RGBA_NV | GLScene.OpenGL4 | GL_NV_copy_depth_to_color
GL_DEPTH_TEST | GLScene.OpenGL4 |
GL_DEPTH_TEXTURE_MODE | GLScene.OpenGL4 |
GL_DEPTH_TEXTURE_MODE_ARB | GLScene.OpenGL4 |
GL_DEPTH_WRITEMASK | GLScene.OpenGL4 |
GL_DETAIL_TEXTURE_2D_BINDING_SGIS | GLScene.OpenGL4 |
GL_DETAIL_TEXTURE_2D_SGIS | GLScene.OpenGL4 | GL_SGIS_detail_texture
GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS | GLScene.OpenGL4 |
GL_DETAIL_TEXTURE_LEVEL_SGIS | GLScene.OpenGL4 |
GL_DETAIL_TEXTURE_MODE_SGIS | GLScene.OpenGL4 |
GL_DIFFERENCE_KHR | GLScene.OpenGL4 |
GL_DIFFUSE | GLScene.OpenGL4 |
GL_DISCARD_ATI | GLScene.OpenGL4 |
GL_DISCARD_NV | GLScene.OpenGL4 |
GL_DISCRETE_AMD | GLScene.OpenGL4 |
GL_DISPATCH_INDIRECT_BUFFER | GLScene.OpenGL4 |
GL_DISPATCH_INDIRECT_BUFFER_BINDING | GLScene.OpenGL4 |
GL_DISPLAY_LIST | GLScene.OpenGL4 |
GL_DISTANCE_ATTENUATION_EXT | GLScene.OpenGL4 |
GL_DISTANCE_ATTENUATION_SGIS | GLScene.OpenGL4 |
GL_DITHER | GLScene.OpenGL4 |
GL_DOMAIN | GLScene.OpenGL4 |
GL_DONT_CARE | GLScene.OpenGL4 | HintMode
GL_DOT2_ADD_ATI | GLScene.OpenGL4 |
GL_DOT3_ATI | GLScene.OpenGL4 |
GL_DOT3_RGB | GLScene.OpenGL4 |
GL_DOT3_RGBA | GLScene.OpenGL4 |
GL_DOT3_RGBA_ARB | GLScene.OpenGL4 |
GL_DOT3_RGBA_EXT | GLScene.OpenGL4 |
GL_DOT3_RGB_ARB | GLScene.OpenGL4 | GL_ARB_texture_env_dot3
GL_DOT3_RGB_EXT | GLScene.OpenGL4 | GL_EXT_texture_env_dot3
GL_DOT4_ATI | GLScene.OpenGL4 |
GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_DEPTH_REPLACE_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_PASS_THROUGH_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_TEXTURE_1D_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_TEXTURE_3D_NV | GLScene.OpenGL4 | GL_NV_texture_shader2
GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV | GLScene.OpenGL4 |
GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
GL_DOUBLE | GLScene.OpenGL4 |
GL_DOUBLEBUFFER | GLScene.OpenGL4 |
GL_DOUBLE_MAT2 | GLScene.OpenGL4 |
GL_DOUBLE_MAT2x3 | GLScene.OpenGL4 |
GL_DOUBLE_MAT2x3_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT2x4 | GLScene.OpenGL4 |
GL_DOUBLE_MAT2x4_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT2_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT3 | GLScene.OpenGL4 |
GL_DOUBLE_MAT3x2 | GLScene.OpenGL4 |
GL_DOUBLE_MAT3x2_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT3x4 | GLScene.OpenGL4 |
GL_DOUBLE_MAT3x4_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT3_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT4 | GLScene.OpenGL4 |
GL_DOUBLE_MAT4x2 | GLScene.OpenGL4 |
GL_DOUBLE_MAT4x2_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT4x3 | GLScene.OpenGL4 |
GL_DOUBLE_MAT4x3_EXT | GLScene.OpenGL4 |
GL_DOUBLE_MAT4_EXT | GLScene.OpenGL4 |
GL_DOUBLE_VEC2 | GLScene.OpenGL4 | GL_ARB_gpu_shader_fp64
GL_DOUBLE_VEC2_EXT | GLScene.OpenGL4 | reuse GL_DOUBLE
GL_DOUBLE_VEC3 | GLScene.OpenGL4 |
GL_DOUBLE_VEC3_EXT | GLScene.OpenGL4 |
GL_DOUBLE_VEC4 | GLScene.OpenGL4 |
GL_DOUBLE_VEC4_EXT | GLScene.OpenGL4 |
GL_DRAW_BUFFER | GLScene.OpenGL4 |
GL_DRAW_BUFFER0 | GLScene.OpenGL4 |
GL_DRAW_BUFFER0_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER0_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER1 | GLScene.OpenGL4 |
GL_DRAW_BUFFER10 | GLScene.OpenGL4 |
GL_DRAW_BUFFER10_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER10_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER11 | GLScene.OpenGL4 |
GL_DRAW_BUFFER11_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER11_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER12 | GLScene.OpenGL4 |
GL_DRAW_BUFFER12_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER12_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER13 | GLScene.OpenGL4 |
GL_DRAW_BUFFER13_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER13_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER14 | GLScene.OpenGL4 |
GL_DRAW_BUFFER14_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER14_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER15 | GLScene.OpenGL4 |
GL_DRAW_BUFFER15_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER15_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER1_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER1_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER2 | GLScene.OpenGL4 |
GL_DRAW_BUFFER2_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER2_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER3 | GLScene.OpenGL4 |
GL_DRAW_BUFFER3_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER3_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER4 | GLScene.OpenGL4 |
GL_DRAW_BUFFER4_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER4_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER5 | GLScene.OpenGL4 |
GL_DRAW_BUFFER5_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER5_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER6 | GLScene.OpenGL4 |
GL_DRAW_BUFFER6_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER6_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER7 | GLScene.OpenGL4 |
GL_DRAW_BUFFER7_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER7_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER8 | GLScene.OpenGL4 |
GL_DRAW_BUFFER8_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER8_ATI | GLScene.OpenGL4 |
GL_DRAW_BUFFER9 | GLScene.OpenGL4 |
GL_DRAW_BUFFER9_ARB | GLScene.OpenGL4 |
GL_DRAW_BUFFER9_ATI | GLScene.OpenGL4 |
GL_DRAW_FRAMEBUFFER | GLScene.OpenGL4 |
GL_DRAW_FRAMEBUFFER_BINDING | GLScene.OpenGL4 |
GL_DRAW_FRAMEBUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_DRAW_FRAMEBUFFER_EXT | GLScene.OpenGL4 |
GL_DRAW_INDIRECT_ADDRESS_NV | GLScene.OpenGL4 |
GL_DRAW_INDIRECT_BUFFER | GLScene.OpenGL4 | GL_ARB_draw_indirect
GL_DRAW_INDIRECT_BUFFER_BINDING | GLScene.OpenGL4 |
GL_DRAW_INDIRECT_LENGTH_NV | GLScene.OpenGL4 |
GL_DRAW_INDIRECT_UNIFIED_NV | GLScene.OpenGL4 |
GL_DRAW_PIXELS_APPLE | GLScene.OpenGL4 | GL_APPLE_fence
GL_DRAW_PIXEL_TOKEN | GLScene.OpenGL4 |
GL_DSDT8_MAG8_INTENSITY8_NV | GLScene.OpenGL4 |
GL_DSDT8_MAG8_NV | GLScene.OpenGL4 |
GL_DSDT8_NV | GLScene.OpenGL4 |
GL_DSDT_MAG_INTENSITY_NV | GLScene.OpenGL4 |
GL_DSDT_MAG_NV | GLScene.OpenGL4 |
GL_DSDT_MAG_VIB_NV | GLScene.OpenGL4 |
GL_DSDT_NV | GLScene.OpenGL4 |
GL_DST_ALPHA | GLScene.OpenGL4 |
GL_DST_COLOR | GLScene.OpenGL4 | BlendingFactorSrc
GL_DS_BIAS_NV | GLScene.OpenGL4 |
GL_DS_SCALE_NV | GLScene.OpenGL4 |
GL_DT_BIAS_NV | GLScene.OpenGL4 |
GL_DT_SCALE_NV | GLScene.OpenGL4 |
GL_DU8DV8_ATI | GLScene.OpenGL4 |
GL_DUAL_ALPHA12_SGIS | GLScene.OpenGL4 |
GL_DUAL_ALPHA16_SGIS | GLScene.OpenGL4 |
GL_DUAL_ALPHA4_SGIS | GLScene.OpenGL4 | GL_SGIS_texture_select
GL_DUAL_ALPHA8_SGIS | GLScene.OpenGL4 |
GL_DUAL_INTENSITY12_SGIS | GLScene.OpenGL4 |
GL_DUAL_INTENSITY16_SGIS | GLScene.OpenGL4 |
GL_DUAL_INTENSITY4_SGIS | GLScene.OpenGL4 |
GL_DUAL_INTENSITY8_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE12_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE16_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE4_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE8_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE_ALPHA4_SGIS | GLScene.OpenGL4 |
GL_DUAL_LUMINANCE_ALPHA8_SGIS | GLScene.OpenGL4 |
GL_DUAL_TEXTURE_SELECT_SGIS | GLScene.OpenGL4 |
GL_DUDV_ATI | GLScene.OpenGL4 |
GL_DUP_FIRST_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_DUP_LAST_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_DYNAMIC_ATI | GLScene.OpenGL4 |
GL_DYNAMIC_COPY | GLScene.OpenGL4 |
GL_DYNAMIC_COPY_ARB | GLScene.OpenGL4 |
GL_DYNAMIC_DRAW | GLScene.OpenGL4 |
GL_DYNAMIC_DRAW_ARB | GLScene.OpenGL4 |
GL_DYNAMIC_READ | GLScene.OpenGL4 |
GL_DYNAMIC_READ_ARB | GLScene.OpenGL4 |
GL_DYNAMIC_STORAGE_BIT | GLScene.OpenGL4 |
GL_EDGEFLAG_BIT_PGI | GLScene.OpenGL4 |
GL_EDGE_FLAG | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_EXT | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_POINTER | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_EDGE_FLAG_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_EIGHTH_BIT_ATI | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_APPLE | GLScene.OpenGL4 | GL_APPLE_element_array
GL_ELEMENT_ARRAY_ATI | GLScene.OpenGL4 | GL_ATI_element_array
GL_ELEMENT_ARRAY_BARRIER_BIT | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_BUFFER | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_BUFFER_ARB | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_POINTER_APPLE | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_POINTER_ATI | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_TYPE_APPLE | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_TYPE_ATI | GLScene.OpenGL4 |
GL_ELEMENT_ARRAY_UNIFIED_NV | GLScene.OpenGL4 |
GL_EMBOSS_CONSTANT_NV | GLScene.OpenGL4 |
GL_EMBOSS_LIGHT_NV | GLScene.OpenGL4 | GL_NV_texgen_emboss
GL_EMBOSS_MAP_NV | GLScene.OpenGL4 |
GL_EMISSION | GLScene.OpenGL4 |
GL_ENABLE_BIT | GLScene.OpenGL4 |
GL_EQUAL | GLScene.OpenGL4 |
GL_EQUIV | GLScene.OpenGL4 |
GL_EVAL_2D_NV | GLScene.OpenGL4 | GL_NV_evaluators
GL_EVAL_BIT | GLScene.OpenGL4 |
GL_EVAL_FRACTIONAL_TESSELLATION_NV | GLScene.OpenGL4 |
GL_EVAL_TRIANGULAR_2D_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB0_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB10_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB11_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB12_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB13_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB14_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB15_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB1_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB2_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB3_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB4_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB5_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB6_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB7_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB8_NV | GLScene.OpenGL4 |
GL_EVAL_VERTEX_ATTRIB9_NV | GLScene.OpenGL4 |
GL_EXCLUSION_KHR | GLScene.OpenGL4 |
GL_EXP | GLScene.OpenGL4 |
GL_EXP2 | GLScene.OpenGL4 |
GL_EXPAND_NEGATE_NV | GLScene.OpenGL4 |
GL_EXPAND_NORMAL_NV | GLScene.OpenGL4 |
GL_EXTENSIONS | GLScene.OpenGL4 |
GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD | GLScene.OpenGL4 | (4.3) GL_AMD_pinned_memory
GL_EYE_DISTANCE_TO_LINE_SGIS | GLScene.OpenGL4 |
GL_EYE_DISTANCE_TO_POINT_SGIS | GLScene.OpenGL4 | GL_SGIS_point_line_texgen
GL_EYE_LINEAR | GLScene.OpenGL4 |
GL_EYE_LINE_SGIS | GLScene.OpenGL4 |
GL_EYE_PLANE | GLScene.OpenGL4 |
GL_EYE_PLANE_ABSOLUTE_NV | GLScene.OpenGL4 |
GL_EYE_POINT_SGIS | GLScene.OpenGL4 |
GL_EYE_RADIAL_NV | GLScene.OpenGL4 |
GL_E_TIMES_F_NV | GLScene.OpenGL4 |
GL_FACTOR_MAX_AMD | GLScene.OpenGL4 |
GL_FACTOR_MIN_AMD | GLScene.OpenGL4 | GL_AMD_blend_minmax_factor
GL_FAILURE_NV | GLScene.OpenGL4 |
GL_FALSE | GLScene.OpenGL4 |
GL_FASTEST | GLScene.OpenGL4 |
GL_FEEDBACK | GLScene.OpenGL4 |
GL_FEEDBACK_BUFFER_POINTER | GLScene.OpenGL4 |
GL_FEEDBACK_BUFFER_SIZE | GLScene.OpenGL4 |
GL_FEEDBACK_BUFFER_TYPE | GLScene.OpenGL4 |
GL_FENCE_APPLE | GLScene.OpenGL4 |
GL_FENCE_CONDITION_NV | GLScene.OpenGL4 |
GL_FENCE_STATUS_NV | GLScene.OpenGL4 |
GL_FIELDS_NV | GLScene.OpenGL4 |
GL_FIELD_LOWER_NV | GLScene.OpenGL4 |
GL_FIELD_UPPER_NV | GLScene.OpenGL4 |
GL_FILE_NAME_NV | GLScene.OpenGL4 |
GL_FILL | GLScene.OpenGL4 |
GL_FILTER | GLScene.OpenGL4 |
GL_FILTER4_SGIS | GLScene.OpenGL4 | GL_SGIS_texture_filter4
GL_FIRST_TO_REST_NV | GLScene.OpenGL4 |
GL_FIRST_VERTEX_CONVENTION | GLScene.OpenGL4 |
GL_FIRST_VERTEX_CONVENTION_EXT | GLScene.OpenGL4 |
GL_FIXED | GLScene.OpenGL4 | GL_ARB_ES2_compatibility
GL_FIXED_ONLY | GLScene.OpenGL4 |
GL_FIXED_ONLY_ARB | GLScene.OpenGL4 |
GL_FLAT | GLScene.OpenGL4 |
GL_FLOAT | GLScene.OpenGL4 |
GL_FLOAT16_NV | GLScene.OpenGL4 |
GL_FLOAT16_VEC2_NV | GLScene.OpenGL4 |
GL_FLOAT16_VEC3_NV | GLScene.OpenGL4 |
GL_FLOAT16_VEC4_NV | GLScene.OpenGL4 |
GL_FLOAT_32_UNSIGNED_INT_24_8_REV | GLScene.OpenGL4 |
GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV | GLScene.OpenGL4 | GL_NV_depth_buffer_float
GL_FLOAT_CLEAR_COLOR_VALUE_NV | GLScene.OpenGL4 |
GL_FLOAT_MAT2 | GLScene.OpenGL4 |
GL_FLOAT_MAT2x3 | GLScene.OpenGL4 |
GL_FLOAT_MAT2x4 | GLScene.OpenGL4 |
GL_FLOAT_MAT2_ARB | GLScene.OpenGL4 |
GL_FLOAT_MAT3 | GLScene.OpenGL4 |
GL_FLOAT_MAT3x2 | GLScene.OpenGL4 |
GL_FLOAT_MAT3x4 | GLScene.OpenGL4 |
GL_FLOAT_MAT3_ARB | GLScene.OpenGL4 |
GL_FLOAT_MAT4 | GLScene.OpenGL4 |
GL_FLOAT_MAT4x2 | GLScene.OpenGL4 |
GL_FLOAT_MAT4x3 | GLScene.OpenGL4 |
GL_FLOAT_MAT4_ARB | GLScene.OpenGL4 |
GL_FLOAT_R16_NV | GLScene.OpenGL4 |
GL_FLOAT_R32_NV | GLScene.OpenGL4 |
GL_FLOAT_RG16_NV | GLScene.OpenGL4 |
GL_FLOAT_RG32_NV | GLScene.OpenGL4 |
GL_FLOAT_RGB16_NV | GLScene.OpenGL4 |
GL_FLOAT_RGB32_NV | GLScene.OpenGL4 |
GL_FLOAT_RGBA16_NV | GLScene.OpenGL4 |
GL_FLOAT_RGBA32_NV | GLScene.OpenGL4 |
GL_FLOAT_RGBA_MODE_NV | GLScene.OpenGL4 |
GL_FLOAT_RGBA_NV | GLScene.OpenGL4 |
GL_FLOAT_RGB_NV | GLScene.OpenGL4 |
GL_FLOAT_RG_NV | GLScene.OpenGL4 |
GL_FLOAT_R_NV | GLScene.OpenGL4 | GL_NV_float_buffer
GL_FLOAT_VEC2 | GLScene.OpenGL4 |
GL_FLOAT_VEC2_ARB | GLScene.OpenGL4 |
GL_FLOAT_VEC3 | GLScene.OpenGL4 |
GL_FLOAT_VEC3_ARB | GLScene.OpenGL4 |
GL_FLOAT_VEC4 | GLScene.OpenGL4 |
GL_FLOAT_VEC4_ARB | GLScene.OpenGL4 |
GL_FOG | GLScene.OpenGL4 |
GL_FOG_BIT | GLScene.OpenGL4 |
GL_FOG_COLOR | GLScene.OpenGL4 |
GL_FOG_COORD | GLScene.OpenGL4 |
GL_FOG_COORDINATE | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_EXT | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_POINTER | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_TYPE | GLScene.OpenGL4 |
GL_FOG_COORDINATE_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_FOG_COORDINATE_EXT | GLScene.OpenGL4 |
GL_FOG_COORDINATE_SOURCE | GLScene.OpenGL4 |
GL_FOG_COORDINATE_SOURCE_EXT | GLScene.OpenGL4 | GL_EXT_fog_coord
GL_FOG_COORD_ARRAY | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_POINTER | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_FOG_COORD_ARRAY_TYPE | GLScene.OpenGL4 |
GL_FOG_COORD_SRC | GLScene.OpenGL4 |
GL_FOG_DENSITY | GLScene.OpenGL4 |
GL_FOG_DISTANCE_MODE_NV | GLScene.OpenGL4 | GL_NV_fog_distance
GL_FOG_END | GLScene.OpenGL4 |
GL_FOG_FUNC_POINTS_SGIS | GLScene.OpenGL4 |
GL_FOG_FUNC_SGIS | GLScene.OpenGL4 | GL_SGIS_fog_function
GL_FOG_HINT | GLScene.OpenGL4 |
GL_FOG_INDEX | GLScene.OpenGL4 |
GL_FOG_MODE | GLScene.OpenGL4 |
GL_FOG_OFFSET_SGIX | GLScene.OpenGL4 | GL_SGIX_fog_offset
GL_FOG_OFFSET_VALUE_SGIX | GLScene.OpenGL4 |
GL_FOG_SCALE_SGIX | GLScene.OpenGL4 | GL_SGIX_fog_scale
GL_FOG_SCALE_VALUE_SGIX | GLScene.OpenGL4 |
GL_FOG_SPECULAR_TEXTURE_WIN | GLScene.OpenGL4 | GL_WIN_specular_fog
GL_FOG_START | GLScene.OpenGL4 |
GL_FONT_ASCENDER_NV | GLScene.OpenGL4 |
GL_FONT_DESCENDER_NV | GLScene.OpenGL4 |
GL_FONT_HAS_KERNING_NV | GLScene.OpenGL4 |
GL_FONT_HEIGHT_NV | GLScene.OpenGL4 |
GL_FONT_MAX_ADVANCE_HEIGHT_NV | GLScene.OpenGL4 |
GL_FONT_MAX_ADVANCE_WIDTH_NV | GLScene.OpenGL4 |
GL_FONT_UNDERLINE_POSITION_NV | GLScene.OpenGL4 |
GL_FONT_UNDERLINE_THICKNESS_NV | GLScene.OpenGL4 |
GL_FONT_UNITS_PER_EM_NV | GLScene.OpenGL4 |
GL_FONT_X_MAX_BOUNDS_NV | GLScene.OpenGL4 |
GL_FONT_X_MIN_BOUNDS_NV | GLScene.OpenGL4 |
GL_FONT_Y_MAX_BOUNDS_NV | GLScene.OpenGL4 |
GL_FONT_Y_MIN_BOUNDS_NV | GLScene.OpenGL4 |
GL_FORCE_BLUE_TO_ONE_NV | GLScene.OpenGL4 |
GL_FORMAT_SUBSAMPLE_244_244_OML | GLScene.OpenGL4 |
GL_FORMAT_SUBSAMPLE_24_24_OML | GLScene.OpenGL4 | GL_OML_subsample
GL_FRACTIONAL_EVEN | GLScene.OpenGL4 |
GL_FRACTIONAL_ODD | GLScene.OpenGL4 |
GL_FRAGMENT_COLOR_EXT | GLScene.OpenGL4 |
GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_COLOR_MATERIAL_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_DEPTH | GLScene.OpenGL4 |
GL_FRAGMENT_DEPTH_EXT | GLScene.OpenGL4 |
GL_FRAGMENT_INTERPOLATION_OFFSET_BITS | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT0_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT1_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT2_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT3_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT4_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT5_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT6_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT7_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHTING_SGIX | GLScene.OpenGL4 | GL_SGIX_fragment_lighting
GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX | GLScene.OpenGL4 |
GL_FRAGMENT_MATERIAL_EXT | GLScene.OpenGL4 | GL_EXT_light_texture
GL_FRAGMENT_NORMAL_EXT | GLScene.OpenGL4 |
GL_FRAGMENT_PROGRAM_ARB | GLScene.OpenGL4 | GL_ARB_fragment_program
GL_FRAGMENT_PROGRAM_BINDING_NV | GLScene.OpenGL4 |
GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV | GLScene.OpenGL4 |
GL_FRAGMENT_PROGRAM_NV | GLScene.OpenGL4 |
GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV | GLScene.OpenGL4 |
GL_FRAGMENT_SHADER | GLScene.OpenGL4 |
GL_FRAGMENT_SHADER_ARB | GLScene.OpenGL4 | GL_ARB_fragment_shader
GL_FRAGMENT_SHADER_ATI | GLScene.OpenGL4 | GL_ATI_fragment_shader
GL_FRAGMENT_SHADER_BIT | GLScene.OpenGL4 |
GL_FRAGMENT_SHADER_DERIVATIVE_HINT | GLScene.OpenGL4 |
GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB | GLScene.OpenGL4 | 1.4
GL_FRAGMENT_SHADER_INVOCATIONS | GLScene.OpenGL4 |
GL_FRAGMENT_SHADER_INVOCATIONS_ARB | GLScene.OpenGL4 |
GL_FRAGMENT_SUBROUTINE | GLScene.OpenGL4 |
GL_FRAGMENT_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_FRAGMENT_TEXTURE | GLScene.OpenGL4 |
GL_FRAMEBUFFER | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_LAYERED | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR | GLScene.OpenGL4 | GL_OVR_multiview
GL_FRAMEBUFFER_BARRIER_BIT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_BINDING | GLScene.OpenGL4 |
GL_FRAMEBUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_BLEND | GLScene.OpenGL4 |
GL_FRAMEBUFFER_COMPLETE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_COMPLETE_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT_HEIGHT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT_LAYERS | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT_SAMPLES | GLScene.OpenGL4 |
GL_FRAMEBUFFER_DEFAULT_WIDTH | GLScene.OpenGL4 |
GL_FRAMEBUFFER_EXT | GLScene.OpenGL4 | GL_EXT_framebuffer_object
GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT | GLScene.OpenGLTokens | Vendor/EXT extensions constants, in extension number order
GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR | GLScene.OpenGL4 |
GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB | GLScene.OpenGL4 |
GL_FRAMEBUFFER_RENDERABLE | GLScene.OpenGL4 |
GL_FRAMEBUFFER_RENDERABLE_LAYERED | GLScene.OpenGL4 |
GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB | GLScene.OpenGL4 |
GL_FRAMEBUFFER_SRGB | GLScene.OpenGL4 | GL_ARB_framebuffer_sRGB
GL_FRAMEBUFFER_SRGB_CAPABLE_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_SRGB_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_STATUS_ERROR_EXT | GLScene.OpenGL4 |
GL_FRAMEBUFFER_UNDEFINED | GLScene.OpenGL4 |
GL_FRAMEBUFFER_UNSUPPORTED | GLScene.OpenGL4 |
GL_FRAMEBUFFER_UNSUPPORTED_EXT | GLScene.OpenGL4 |
GL_FRAMEZOOM_FACTOR_SGIX | GLScene.OpenGL4 |
GL_FRAMEZOOM_SGIX | GLScene.OpenGL4 | GL_SGIX_framezoom
GL_FRAME_NV | GLScene.OpenGL4 | GL_NV_present_video
GL_FRONT | GLScene.OpenGL4 |
GL_FRONT_AND_BACK | GLScene.OpenGL4 |
GL_FRONT_FACE | GLScene.OpenGL4 |
GL_FRONT_LEFT | GLScene.OpenGL4 |
GL_FRONT_RIGHT | GLScene.OpenGL4 |
GL_FULL_RANGE_EXT | GLScene.OpenGL4 |
GL_FULL_STIPPLE_HINT_PGI | GLScene.OpenGL4 |
GL_FULL_SUPPORT | GLScene.OpenGL4 |
GL_FUNC_ADD | GLScene.OpenGL4 |
GL_FUNC_ADD_EXT | GLScene.OpenGL4 | GL_EXT_blend_minmax
GL_FUNC_REVERSE_SUBTRACT | GLScene.OpenGL4 |
GL_FUNC_REVERSE_SUBTRACT_EXT | GLScene.OpenGL4 |
GL_FUNC_SUBTRACT | GLScene.OpenGL4 |
GL_FUNC_SUBTRACT_EXT | GLScene.OpenGL4 | GL_EXT_blend_subtract
GL_GENERATE_MIPMAP | GLScene.OpenGL4 |
GL_GENERATE_MIPMAP_HINT | GLScene.OpenGL4 |
GL_GENERATE_MIPMAP_HINT_SGIS | GLScene.OpenGL4 |
GL_GENERATE_MIPMAP_SGIS | GLScene.OpenGL4 | GL_SGIS_generate_mipmap
GL_GENERIC_ATTRIB_NV | GLScene.OpenGL4 |
GL_GEOMETRY_DEFORMATION_BIT_SGIX | GLScene.OpenGL4 |
GL_GEOMETRY_DEFORMATION_SGIX | GLScene.OpenGL4 | GL_SGIX_polynomial_ffd
GL_GEOMETRY_INPUT_TYPE | GLScene.OpenGL4 |
GL_GEOMETRY_INPUT_TYPE_ARB | GLScene.OpenGL4 |
GL_GEOMETRY_INPUT_TYPE_EXT | GLScene.OpenGL4 |
GL_GEOMETRY_OUTPUT_TYPE | GLScene.OpenGL4 |
GL_GEOMETRY_OUTPUT_TYPE_ARB | GLScene.OpenGL4 |
GL_GEOMETRY_OUTPUT_TYPE_EXT | GLScene.OpenGL4 |
GL_GEOMETRY_PROGRAM_NV | GLScene.OpenGL4 | GL_NV_geometry_program4
GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV | GLScene.OpenGL4 |
GL_GEOMETRY_SHADER | GLScene.OpenGL4 |
GL_GEOMETRY_SHADER_ARB | GLScene.OpenGL4 |
GL_GEOMETRY_SHADER_BIT | GLScene.OpenGL4 |
GL_GEOMETRY_SHADER_EXT | GLScene.OpenGL4 | GL_EXT_geometry_shader4
GL_GEOMETRY_SHADER_INVOCATIONS | GLScene.OpenGL4 | GL_ARB_gpu_shader5
GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED | GLScene.OpenGL4 |
GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB | GLScene.OpenGL4 |
GL_GEOMETRY_SUBROUTINE | GLScene.OpenGL4 |
GL_GEOMETRY_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_GEOMETRY_TEXTURE | GLScene.OpenGL4 |
GL_GEOMETRY_VERTICES_OUT | GLScene.OpenGL4 |
GL_GEOMETRY_VERTICES_OUT_ARB | GLScene.OpenGL4 |
GL_GEOMETRY_VERTICES_OUT_EXT | GLScene.OpenGL4 |
GL_GEQUAL | GLScene.OpenGL4 |
GL_GET_TEXTURE_IMAGE_FORMAT | GLScene.OpenGL4 |
GL_GET_TEXTURE_IMAGE_TYPE | GLScene.OpenGL4 |
GL_GLOBAL_ALPHA_FACTOR_SUN | GLScene.OpenGL4 |
GL_GLOBAL_ALPHA_SUN | GLScene.OpenGL4 | GL_SUN_global_alpha
GL_GLYPH_HAS_KERNING_NV | GLScene.OpenGL4 |
GL_GLYPH_HEIGHT_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_VERTICAL_BEARING_X_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV | GLScene.OpenGL4 |
GL_GLYPH_WIDTH_BIT_NV | GLScene.OpenGL4 |
GL_GPU_ADDRESS_NV | GLScene.OpenGL4 |
GL_GREATER | GLScene.OpenGL4 |
GL_GREEN | GLScene.OpenGL4 |
GL_GREEN_BIAS | GLScene.OpenGL4 |
GL_GREEN_BITS | GLScene.OpenGL4 |
GL_GREEN_BIT_ATI | GLScene.OpenGL4 |
GL_GREEN_INTEGER | GLScene.OpenGL4 |
GL_GREEN_INTEGER_EXT | GLScene.OpenGL4 |
GL_GREEN_MAX_CLAMP_INGR | GLScene.OpenGL4 |
GL_GREEN_MIN_CLAMP_INGR | GLScene.OpenGL4 |
GL_GREEN_SCALE | GLScene.OpenGL4 |
GL_GUILTY_CONTEXT_RESET | GLScene.OpenGL4 |
GL_GUILTY_CONTEXT_RESET_ARB | GLScene.OpenGL4 |
GL_HALF_APPLE | GLScene.OpenGL4 | GL_APPLE_float_pixels
GL_HALF_BIAS_NEGATE_NV | GLScene.OpenGL4 |
GL_HALF_BIAS_NORMAL_NV | GLScene.OpenGL4 |
GL_HALF_BIT_ATI | GLScene.OpenGL4 |
GL_HALF_FLOAT | GLScene.OpenGL4 | GL_ARB_half_float_vertex
GL_HALF_FLOAT_ARB | GLScene.OpenGL4 | GL_ARB_half_float_pixel
GL_HALF_FLOAT_NV | GLScene.OpenGL4 | GL_NV_half_float
GL_HARDLIGHT_KHR | GLScene.OpenGL4 |
GL_HIGH_FLOAT | GLScene.OpenGL4 |
GL_HIGH_INT | GLScene.OpenGL4 |
GL_HILO16_NV | GLScene.OpenGL4 |
GL_HILO8_NV | GLScene.OpenGL4 |
GL_HILO_NV | GLScene.OpenGL4 |
GL_HINT_BIT | GLScene.OpenGL4 |
GL_HISTOGRAM | GLScene.OpenGL4 |
GL_HISTOGRAM_ALPHA_SIZE | GLScene.OpenGL4 |
GL_HISTOGRAM_ALPHA_SIZE_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_BLUE_SIZE | GLScene.OpenGL4 |
GL_HISTOGRAM_BLUE_SIZE_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_EXT | GLScene.OpenGL4 | GL_EXT_histogram
GL_HISTOGRAM_FORMAT | GLScene.OpenGL4 |
GL_HISTOGRAM_FORMAT_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_GREEN_SIZE | GLScene.OpenGL4 |
GL_HISTOGRAM_GREEN_SIZE_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_LUMINANCE_SIZE | GLScene.OpenGL4 |
GL_HISTOGRAM_LUMINANCE_SIZE_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_RED_SIZE | GLScene.OpenGL4 |
GL_HISTOGRAM_RED_SIZE_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_SINK | GLScene.OpenGL4 |
GL_HISTOGRAM_SINK_EXT | GLScene.OpenGL4 |
GL_HISTOGRAM_WIDTH | GLScene.OpenGL4 |
GL_HISTOGRAM_WIDTH_EXT | GLScene.OpenGL4 |
GL_HI_BIAS_NV | GLScene.OpenGL4 |
GL_HI_SCALE_NV | GLScene.OpenGL4 |
GL_HORIZONTAL_LINE_TO_NV | GLScene.OpenGL4 |
GL_HSL_COLOR_KHR | GLScene.OpenGL4 |
GL_HSL_HUE_KHR | GLScene.OpenGL4 |
GL_HSL_LUMINOSITY_KHR | GLScene.OpenGL4 |
GL_HSL_SATURATION_KHR | GLScene.OpenGL4 |
GL_IDENTITY_NV | GLScene.OpenGL4 |
GL_IGNORE_BORDER_HP | GLScene.OpenGL4 | GL_HP_convolution_border_modes
GL_IMAGE_1D | GLScene.OpenGL4 |
GL_IMAGE_1D_ARRAY | GLScene.OpenGL4 |
GL_IMAGE_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_IMAGE_1D_EXT | GLScene.OpenGL4 |
GL_IMAGE_2D | GLScene.OpenGL4 |
GL_IMAGE_2D_ARRAY | GLScene.OpenGL4 |
GL_IMAGE_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_IMAGE_2D_EXT | GLScene.OpenGL4 |
GL_IMAGE_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_IMAGE_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT | GLScene.OpenGL4 |
GL_IMAGE_2D_MULTISAMPLE_EXT | GLScene.OpenGL4 |
GL_IMAGE_2D_RECT | GLScene.OpenGL4 |
GL_IMAGE_2D_RECT_EXT | GLScene.OpenGL4 |
GL_IMAGE_3D | GLScene.OpenGL4 |
GL_IMAGE_3D_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_ACCESS | GLScene.OpenGL4 |
GL_IMAGE_BINDING_ACCESS_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_FORMAT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_FORMAT_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LAYER | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LAYERED | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LAYERED_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LAYER_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LEVEL | GLScene.OpenGL4 |
GL_IMAGE_BINDING_LEVEL_EXT | GLScene.OpenGL4 |
GL_IMAGE_BINDING_NAME | GLScene.OpenGL4 |
GL_IMAGE_BINDING_NAME_EXT | GLScene.OpenGL4 |
GL_IMAGE_BUFFER | GLScene.OpenGL4 |
GL_IMAGE_BUFFER_EXT | GLScene.OpenGL4 |
GL_IMAGE_CLASS_10_10_10_2 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_11_11_10 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_1_X_16 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_1_X_32 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_1_X_8 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_2_X_16 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_2_X_32 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_2_X_8 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_4_X_16 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_4_X_32 | GLScene.OpenGL4 |
GL_IMAGE_CLASS_4_X_8 | GLScene.OpenGL4 |
GL_IMAGE_COMPATIBILITY_CLASS | GLScene.OpenGL4 |
GL_IMAGE_CUBE | GLScene.OpenGL4 |
GL_IMAGE_CUBE_EXT | GLScene.OpenGL4 |
GL_IMAGE_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_IMAGE_CUBE_MAP_ARRAY_EXT | GLScene.OpenGL4 |
GL_IMAGE_CUBIC_WEIGHT_HP | GLScene.OpenGL4 |
GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS | GLScene.OpenGL4 |
GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE | GLScene.OpenGL4 |
GL_IMAGE_FORMAT_COMPATIBILITY_TYPE | GLScene.OpenGL4 |
GL_IMAGE_MAG_FILTER_HP | GLScene.OpenGL4 |
GL_IMAGE_MIN_FILTER_HP | GLScene.OpenGL4 |
GL_IMAGE_PIXEL_FORMAT | GLScene.OpenGL4 |
GL_IMAGE_PIXEL_TYPE | GLScene.OpenGL4 |
GL_IMAGE_ROTATE_ANGLE_HP | GLScene.OpenGL4 |
GL_IMAGE_ROTATE_ORIGIN_X_HP | GLScene.OpenGL4 |
GL_IMAGE_ROTATE_ORIGIN_Y_HP | GLScene.OpenGL4 |
GL_IMAGE_SCALE_X_HP | GLScene.OpenGL4 | GL_HP_image_transform
GL_IMAGE_SCALE_Y_HP | GLScene.OpenGL4 |
GL_IMAGE_TEXEL_SIZE | GLScene.OpenGL4 |
GL_IMAGE_TRANSFORM_2D_HP | GLScene.OpenGL4 |
GL_IMAGE_TRANSLATE_X_HP | GLScene.OpenGL4 |
GL_IMAGE_TRANSLATE_Y_HP | GLScene.OpenGL4 |
GL_IMPLEMENTATION_COLOR_READ_FORMAT | GLScene.OpenGL4 |
GL_IMPLEMENTATION_COLOR_READ_TYPE | GLScene.OpenGL4 |
GL_INCR | GLScene.OpenGL4 |
GL_INCR_WRAP | GLScene.OpenGL4 |
GL_INCR_WRAP_EXT | GLScene.OpenGL4 | GL_EXT_stencil_wrap
GL_INDEX | GLScene.OpenGL4 |
GL_INDEX_ARRAY | GLScene.OpenGL4 |
GL_INDEX_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_INDEX_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_INDEX_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_INDEX_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_INDEX_ARRAY_EXT | GLScene.OpenGL4 |
GL_INDEX_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_INDEX_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_INDEX_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_INDEX_ARRAY_POINTER | GLScene.OpenGL4 |
GL_INDEX_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_INDEX_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_INDEX_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_INDEX_ARRAY_TYPE | GLScene.OpenGL4 |
GL_INDEX_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_INDEX_BITS | GLScene.OpenGL4 |
GL_INDEX_BIT_PGI | GLScene.OpenGL4 |
GL_INDEX_CLEAR_VALUE | GLScene.OpenGL4 |
GL_INDEX_LOGIC_OP | GLScene.OpenGL4 |
GL_INDEX_MATERIAL_EXT | GLScene.OpenGL4 | GL_EXT_index_material
GL_INDEX_MATERIAL_FACE_EXT | GLScene.OpenGL4 |
GL_INDEX_MATERIAL_PARAMETER_EXT | GLScene.OpenGL4 |
GL_INDEX_MODE | GLScene.OpenGL4 |
GL_INDEX_OFFSET | GLScene.OpenGL4 |
GL_INDEX_SHIFT | GLScene.OpenGL4 |
GL_INDEX_TEST_EXT | GLScene.OpenGL4 | GL_EXT_index_func
GL_INDEX_TEST_FUNC_EXT | GLScene.OpenGL4 |
GL_INDEX_TEST_REF_EXT | GLScene.OpenGL4 |
GL_INDEX_WRITEMASK | GLScene.OpenGL4 |
GL_INFO_LOG_LENGTH | GLScene.OpenGL4 |
GL_INNOCENT_CONTEXT_RESET | GLScene.OpenGL4 |
GL_INNOCENT_CONTEXT_RESET_ARB | GLScene.OpenGL4 |
GL_INSTRUMENT_BUFFER_POINTER_SGIX | GLScene.OpenGL4 | GL_SGIX_instruments
GL_INSTRUMENT_MEASUREMENTS_SGIX | GLScene.OpenGL4 |
GL_INT | GLScene.OpenGL4 |
GL_INT16_NV | GLScene.OpenGL4 |
GL_INT16_VEC2_NV | GLScene.OpenGL4 |
GL_INT16_VEC3_NV | GLScene.OpenGL4 |
GL_INT16_VEC4_NV | GLScene.OpenGL4 |
GL_INT64_ARB | GLScene.OpenGL4 | GL_ARB_gpu_shader_int64
GL_INT64_NV | GLScene.OpenGL4 | GL_NV_gpu_shader5
GL_INT64_VEC2_ARB | GLScene.OpenGL4 |
GL_INT64_VEC2_NV | GLScene.OpenGL4 |
GL_INT64_VEC3_ARB | GLScene.OpenGL4 |
GL_INT64_VEC3_NV | GLScene.OpenGL4 |
GL_INT64_VEC4_ARB | GLScene.OpenGL4 |
GL_INT64_VEC4_NV | GLScene.OpenGL4 |
GL_INT8_NV | GLScene.OpenGL4 |
GL_INT8_VEC2_NV | GLScene.OpenGL4 |
GL_INT8_VEC3_NV | GLScene.OpenGL4 |
GL_INT8_VEC4_NV | GLScene.OpenGL4 |
GL_INTENSITY | GLScene.OpenGL4 |
GL_INTENSITY12 | GLScene.OpenGL4 |
GL_INTENSITY12_EXT | GLScene.OpenGL4 |
GL_INTENSITY16 | GLScene.OpenGL4 |
GL_INTENSITY16F_ARB | GLScene.OpenGL4 |
GL_INTENSITY16I_EXT | GLScene.OpenGL4 |
GL_INTENSITY16UI_EXT | GLScene.OpenGL4 |
GL_INTENSITY16_EXT | GLScene.OpenGL4 |
GL_INTENSITY16_SNORM | GLScene.OpenGL4 |
GL_INTENSITY32F_ARB | GLScene.OpenGL4 |
GL_INTENSITY32I_EXT | GLScene.OpenGL4 |
GL_INTENSITY32UI_EXT | GLScene.OpenGL4 |
GL_INTENSITY4 | GLScene.OpenGL4 |
GL_INTENSITY4_EXT | GLScene.OpenGL4 |
GL_INTENSITY8 | GLScene.OpenGL4 |
GL_INTENSITY8I_EXT | GLScene.OpenGL4 |
GL_INTENSITY8UI_EXT | GLScene.OpenGL4 |
GL_INTENSITY8_EXT | GLScene.OpenGL4 |
GL_INTENSITY8_SNORM | GLScene.OpenGL4 |
GL_INTENSITY_EXT | GLScene.OpenGL4 |
GL_INTENSITY_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_INTENSITY_FLOAT16_ATI | GLScene.OpenGL4 |
GL_INTENSITY_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_INTENSITY_FLOAT32_ATI | GLScene.OpenGL4 |
GL_INTENSITY_SNORM | GLScene.OpenGL4 |
GL_INTERLACE_OML | GLScene.OpenGL4 | GL_OML_interlace
GL_INTERLACE_READ_INGR | GLScene.OpenGL4 | GL_INGR_interlace_read
GL_INTERLACE_READ_OML | GLScene.OpenGL4 |
GL_INTERLACE_SGIX | GLScene.OpenGL4 | GL_SGIX_interlace
GL_INTERLEAVED_ATTRIBS | GLScene.OpenGL4 |
GL_INTERLEAVED_ATTRIBS_EXT | GLScene.OpenGL4 |
GL_INTERLEAVED_ATTRIBS_NV | GLScene.OpenGL4 |
GL_INTERNALFORMAT_ALPHA_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_ALPHA_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_BLUE_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_BLUE_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_DEPTH_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_DEPTH_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_GREEN_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_GREEN_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_PREFERRED | GLScene.OpenGL4 |
GL_INTERNALFORMAT_RED_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_RED_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_SHARED_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_STENCIL_SIZE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_STENCIL_TYPE | GLScene.OpenGL4 |
GL_INTERNALFORMAT_SUPPORTED | GLScene.OpenGL4 |
GL_INTERPOLATE | GLScene.OpenGL4 |
GL_INTERPOLATE_ARB | GLScene.OpenGL4 |
GL_INTERPOLATE_EXT | GLScene.OpenGL4 |
GL_INT_2_10_10_10_REV | GLScene.OpenGL4 | reuse GL_UNSIGNED_INT_2_10_10_10_REV
GL_INT_IMAGE_1D | GLScene.OpenGL4 |
GL_INT_IMAGE_1D_ARRAY | GLScene.OpenGL4 |
GL_INT_IMAGE_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_1D_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_ARRAY | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_MULTISAMPLE_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_RECT | GLScene.OpenGL4 |
GL_INT_IMAGE_2D_RECT_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_3D | GLScene.OpenGL4 |
GL_INT_IMAGE_3D_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_BUFFER | GLScene.OpenGL4 |
GL_INT_IMAGE_BUFFER_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_CUBE | GLScene.OpenGL4 |
GL_INT_IMAGE_CUBE_EXT | GLScene.OpenGL4 |
GL_INT_IMAGE_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_1D | GLScene.OpenGL4 |
GL_INT_SAMPLER_1D_ARRAY | GLScene.OpenGL4 |
GL_INT_SAMPLER_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_1D_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_ARRAY | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_RECT | GLScene.OpenGL4 |
GL_INT_SAMPLER_2D_RECT_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_3D | GLScene.OpenGL4 |
GL_INT_SAMPLER_3D_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_BUFFER | GLScene.OpenGL4 |
GL_INT_SAMPLER_BUFFER_AMD | GLScene.OpenGL4 |
GL_INT_SAMPLER_BUFFER_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_CUBE | GLScene.OpenGL4 |
GL_INT_SAMPLER_CUBE_EXT | GLScene.OpenGL4 |
GL_INT_SAMPLER_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 |
GL_INT_SAMPLER_RENDERBUFFER_NV | GLScene.OpenGL4 |
GL_INT_VEC2 | GLScene.OpenGL4 |
GL_INT_VEC2_ARB | GLScene.OpenGL4 |
GL_INT_VEC3 | GLScene.OpenGL4 |
GL_INT_VEC3_ARB | GLScene.OpenGL4 |
GL_INT_VEC4 | GLScene.OpenGL4 |
GL_INT_VEC4_ARB | GLScene.OpenGL4 |
GL_INVALID_ENUM | GLScene.OpenGL4 |
GL_INVALID_FRAMEBUFFER_OPERATION | GLScene.OpenGL4 | GL_ARB_framebuffer_object
GL_INVALID_FRAMEBUFFER_OPERATION_EXT | GLScene.OpenGL4 |
GL_INVALID_INDEX | GLScene.OpenGL4 |
GL_INVALID_OPERATION | GLScene.OpenGL4 |
GL_INVALID_VALUE | GLScene.OpenGL4 |
GL_INVARIANT_DATATYPE_EXT | GLScene.OpenGL4 |
GL_INVARIANT_EXT | GLScene.OpenGL4 |
GL_INVARIANT_VALUE_EXT | GLScene.OpenGL4 |
GL_INVERSE_NV | GLScene.OpenGL4 |
GL_INVERSE_TRANSPOSE_NV | GLScene.OpenGL4 |
GL_INVERT | GLScene.OpenGL4 |
GL_INVERTED_SCREEN_W_REND | GLScene.OpenGL4 |
GL_IR_INSTRUMENT1_SGIX | GLScene.OpenGL4 | GL_SGIX_ir_instrument1
GL_ISOLINES | GLScene.OpenGL4 |
GL_IS_PER_PATCH | GLScene.OpenGL4 |
GL_IS_ROW_MAJOR | GLScene.OpenGL4 |
GL_ITALIC_BIT_NV | GLScene.OpenGL4 |
GL_IUI_N3F_V2F_EXT | GLScene.OpenGL4 |
GL_IUI_N3F_V3F_EXT | GLScene.OpenGL4 |
GL_IUI_V2F_EXT | GLScene.OpenGL4 | GL_EXT_index_array_formats
GL_IUI_V3F_EXT | GLScene.OpenGL4 |
GL_KEEP | GLScene.OpenGL4 | StencilOp
GL_LARGE_CCW_ARC_TO_NV | GLScene.OpenGL4 |
GL_LARGE_CW_ARC_TO_NV | GLScene.OpenGL4 |
GL_LAST_VERTEX_CONVENTION | GLScene.OpenGL4 |
GL_LAST_VERTEX_CONVENTION_EXT | GLScene.OpenGL4 |
GL_LAST_VIDEO_CAPTURE_STATUS_NV | GLScene.OpenGL4 |
GL_LAYER_NV | GLScene.OpenGL4 |
GL_LAYER_PROVOKING_VERTEX | GLScene.OpenGL4 |
GL_LEFT | GLScene.OpenGL4 |
GL_LEQUAL | GLScene.OpenGL4 |
GL_LERP_ATI | GLScene.OpenGL4 |
GL_LESS | GLScene.OpenGL4 |
GL_LIGHT0 | GLScene.OpenGL4 |
GL_LIGHT1 | GLScene.OpenGL4 |
GL_LIGHT2 | GLScene.OpenGL4 |
GL_LIGHT3 | GLScene.OpenGL4 |
GL_LIGHT4 | GLScene.OpenGL4 |
GL_LIGHT5 | GLScene.OpenGL4 |
GL_LIGHT6 | GLScene.OpenGL4 |
GL_LIGHT7 | GLScene.OpenGL4 |
GL_LIGHTEN_KHR | GLScene.OpenGL4 |
GL_LIGHTING | GLScene.OpenGL4 |
GL_LIGHTING_BIT | GLScene.OpenGL4 |
GL_LIGHT_ENV_MODE_SGIX | GLScene.OpenGL4 |
GL_LIGHT_MODEL_AMBIENT | GLScene.OpenGL4 |
GL_LIGHT_MODEL_COLOR_CONTROL | GLScene.OpenGL4 |
GL_LIGHT_MODEL_COLOR_CONTROL_EXT | GLScene.OpenGL4 | GL_EXT_separate_specular_color
GL_LIGHT_MODEL_LOCAL_VIEWER | GLScene.OpenGL4 |
GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE | GLScene.OpenGL4 | GL_APPLE_specular_vector
GL_LIGHT_MODEL_TWO_SIDE | GLScene.OpenGL4 |
GL_LINE | GLScene.OpenGL4 |
GL_LINEAR | GLScene.OpenGL4 |
GL_LINEAR_ATTENUATION | GLScene.OpenGL4 |
GL_LINEAR_CLIPMAP_LINEAR_SGIX | GLScene.OpenGL4 | GL_SGIX_clipmap
GL_LINEAR_CLIPMAP_NEAREST_SGIX | GLScene.OpenGL4 |
GL_LINEAR_DETAIL_ALPHA_SGIS | GLScene.OpenGL4 |
GL_LINEAR_DETAIL_COLOR_SGIS | GLScene.OpenGL4 |
GL_LINEAR_DETAIL_SGIS | GLScene.OpenGL4 |
GL_LINEAR_MIPMAP_LINEAR | GLScene.OpenGL4 |
GL_LINEAR_MIPMAP_NEAREST | GLScene.OpenGL4 |
GL_LINEAR_SHARPEN_ALPHA_SGIS | GLScene.OpenGL4 |
GL_LINEAR_SHARPEN_COLOR_SGIS | GLScene.OpenGL4 |
GL_LINEAR_SHARPEN_SGIS | GLScene.OpenGL4 | GL_SGIS_sharpen_texture
GL_LINES | GLScene.OpenGL4 |
GL_LINES_ADJACENCY | GLScene.OpenGL4 |
GL_LINES_ADJACENCY_ARB | GLScene.OpenGL4 | GL_ARB_geometry_shader4
GL_LINES_ADJACENCY_EXT | GLScene.OpenGL4 |
GL_LINE_BIT | GLScene.OpenGL4 |
GL_LINE_LOOP | GLScene.OpenGL4 |
GL_LINE_RESET_TOKEN | GLScene.OpenGL4 |
GL_LINE_SMOOTH | GLScene.OpenGL4 |
GL_LINE_SMOOTH_HINT | GLScene.OpenGL4 |
GL_LINE_STIPPLE | GLScene.OpenGL4 |
GL_LINE_STIPPLE_PATTERN | GLScene.OpenGL4 |
GL_LINE_STIPPLE_REPEAT | GLScene.OpenGL4 |
GL_LINE_STRIP | GLScene.OpenGL4 |
GL_LINE_STRIP_ADJACENCY | GLScene.OpenGL4 |
GL_LINE_STRIP_ADJACENCY_ARB | GLScene.OpenGL4 |
GL_LINE_STRIP_ADJACENCY_EXT | GLScene.OpenGL4 |
GL_LINE_TOKEN | GLScene.OpenGL4 |
GL_LINE_TO_NV | GLScene.OpenGL4 |
GL_LINE_WIDTH | GLScene.OpenGL4 |
GL_LINE_WIDTH_GRANULARITY | GLScene.OpenGL4 |
GL_LINE_WIDTH_RANGE | GLScene.OpenGL4 |
GL_LINK_STATUS | GLScene.OpenGL4 |
GL_LIST_BASE | GLScene.OpenGL4 |
GL_LIST_BIT | GLScene.OpenGL4 |
GL_LIST_INDEX | GLScene.OpenGL4 |
GL_LIST_MODE | GLScene.OpenGL4 |
GL_LIST_PRIORITY_SGIX | GLScene.OpenGL4 | GL_SGIX_list_priority
GL_LOAD | GLScene.OpenGL4 |
GL_LOCAL_CONSTANT_DATATYPE_EXT | GLScene.OpenGL4 |
GL_LOCAL_CONSTANT_EXT | GLScene.OpenGL4 |
GL_LOCAL_CONSTANT_VALUE_EXT | GLScene.OpenGL4 |
GL_LOCAL_EXT | GLScene.OpenGL4 |
GL_LOCATION | GLScene.OpenGL4 |
GL_LOCATION_COMPONENT | GLScene.OpenGL4 |
GL_LOCATION_INDEX | GLScene.OpenGL4 |
GL_LOGIC_OP | GLScene.OpenGL4 |
GL_LOGIC_OP_MODE | GLScene.OpenGL4 |
GL_LOSE_CONTEXT_ON_RESET | GLScene.OpenGL4 |
GL_LOSE_CONTEXT_ON_RESET_ARB | GLScene.OpenGL4 |
GL_LOWER_LEFT | GLScene.OpenGL4 |
GL_LOW_FLOAT | GLScene.OpenGL4 |
GL_LOW_INT | GLScene.OpenGL4 |
GL_LO_BIAS_NV | GLScene.OpenGL4 |
GL_LO_SCALE_NV | GLScene.OpenGL4 |
GL_LUMINANCE | GLScene.OpenGL4 |
GL_LUMINANCE12 | GLScene.OpenGL4 |
GL_LUMINANCE12_ALPHA12 | GLScene.OpenGL4 |
GL_LUMINANCE12_ALPHA12_EXT | GLScene.OpenGL4 |
GL_LUMINANCE12_ALPHA4 | GLScene.OpenGL4 |
GL_LUMINANCE12_ALPHA4_EXT | GLScene.OpenGL4 |
GL_LUMINANCE12_EXT | GLScene.OpenGL4 |
GL_LUMINANCE16 | GLScene.OpenGL4 |
GL_LUMINANCE16F_ARB | GLScene.OpenGL4 |
GL_LUMINANCE16I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE16UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE16_ALPHA16 | GLScene.OpenGL4 |
GL_LUMINANCE16_ALPHA16_EXT | GLScene.OpenGL4 |
GL_LUMINANCE16_ALPHA16_SNORM | GLScene.OpenGL4 |
GL_LUMINANCE16_EXT | GLScene.OpenGL4 |
GL_LUMINANCE16_SNORM | GLScene.OpenGL4 |
GL_LUMINANCE32F_ARB | GLScene.OpenGL4 |
GL_LUMINANCE32I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE32UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE4 | GLScene.OpenGL4 |
GL_LUMINANCE4_ALPHA4 | GLScene.OpenGL4 |
GL_LUMINANCE4_ALPHA4_EXT | GLScene.OpenGL4 |
GL_LUMINANCE4_EXT | GLScene.OpenGL4 |
GL_LUMINANCE6_ALPHA2 | GLScene.OpenGL4 |
GL_LUMINANCE6_ALPHA2_EXT | GLScene.OpenGL4 |
GL_LUMINANCE8 | GLScene.OpenGL4 |
GL_LUMINANCE8I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE8UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE8_ALPHA8 | GLScene.OpenGL4 |
GL_LUMINANCE8_ALPHA8_EXT | GLScene.OpenGL4 |
GL_LUMINANCE8_ALPHA8_SNORM | GLScene.OpenGL4 |
GL_LUMINANCE8_EXT | GLScene.OpenGL4 |
GL_LUMINANCE8_SNORM | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA16F_ARB | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA16I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA16UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA32F_ARB | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA32I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA32UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA8I_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA8UI_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_FLOAT16_ATI | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_FLOAT32_ATI | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_INTEGER_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_ALPHA_SNORM | GLScene.OpenGL4 |
GL_LUMINANCE_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_LUMINANCE_FLOAT16_ATI | GLScene.OpenGL4 |
GL_LUMINANCE_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_LUMINANCE_FLOAT32_ATI | GLScene.OpenGL4 |
GL_LUMINANCE_INTEGER_EXT | GLScene.OpenGL4 |
GL_LUMINANCE_SNORM | GLScene.OpenGL4 |
GL_MAD_ATI | GLScene.OpenGL4 |
GL_MAGNITUDE_BIAS_NV | GLScene.OpenGL4 |
GL_MAGNITUDE_SCALE_NV | GLScene.OpenGL4 |
GL_MAJOR_VERSION | GLScene.OpenGL4 |
GL_MANUAL_GENERATE_MIPMAP | GLScene.OpenGL4 |
GL_MAP1_BINORMAL_EXT | GLScene.OpenGL4 |
GL_MAP1_COLOR_4 | GLScene.OpenGL4 |
GL_MAP1_GRID_DOMAIN | GLScene.OpenGL4 |
GL_MAP1_GRID_SEGMENTS | GLScene.OpenGL4 |
GL_MAP1_INDEX | GLScene.OpenGL4 |
GL_MAP1_NORMAL | GLScene.OpenGL4 |
GL_MAP1_TANGENT_EXT | GLScene.OpenGL4 |
GL_MAP1_TEXTURE_COORD_1 | GLScene.OpenGL4 |
GL_MAP1_TEXTURE_COORD_2 | GLScene.OpenGL4 |
GL_MAP1_TEXTURE_COORD_3 | GLScene.OpenGL4 |
GL_MAP1_TEXTURE_COORD_4 | GLScene.OpenGL4 |
GL_MAP1_VERTEX_3 | GLScene.OpenGL4 |
GL_MAP1_VERTEX_4 | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB0_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB10_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB11_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB12_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB13_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB14_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB15_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB1_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB2_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB3_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB4_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB5_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB6_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB7_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB8_4_NV | GLScene.OpenGL4 |
GL_MAP1_VERTEX_ATTRIB9_4_NV | GLScene.OpenGL4 |
GL_MAP2_BINORMAL_EXT | GLScene.OpenGL4 |
GL_MAP2_COLOR_4 | GLScene.OpenGL4 |
GL_MAP2_GRID_DOMAIN | GLScene.OpenGL4 |
GL_MAP2_GRID_SEGMENTS | GLScene.OpenGL4 |
GL_MAP2_INDEX | GLScene.OpenGL4 |
GL_MAP2_NORMAL | GLScene.OpenGL4 |
GL_MAP2_TANGENT_EXT | GLScene.OpenGL4 |
GL_MAP2_TEXTURE_COORD_1 | GLScene.OpenGL4 |
GL_MAP2_TEXTURE_COORD_2 | GLScene.OpenGL4 |
GL_MAP2_TEXTURE_COORD_3 | GLScene.OpenGL4 |
GL_MAP2_TEXTURE_COORD_4 | GLScene.OpenGL4 |
GL_MAP2_VERTEX_3 | GLScene.OpenGL4 |
GL_MAP2_VERTEX_4 | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB0_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB10_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB11_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB12_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB13_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB14_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB15_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB1_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB2_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB3_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB4_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB5_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB6_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB7_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB8_4_NV | GLScene.OpenGL4 |
GL_MAP2_VERTEX_ATTRIB9_4_NV | GLScene.OpenGL4 |
GL_MAP_ATTRIB_U_ORDER_NV | GLScene.OpenGL4 |
GL_MAP_ATTRIB_V_ORDER_NV | GLScene.OpenGL4 |
GL_MAP_COHERENT_BIT | GLScene.OpenGL4 |
GL_MAP_COLOR | GLScene.OpenGL4 |
GL_MAP_FLUSH_EXPLICIT_BIT | GLScene.OpenGL4 |
GL_MAP_INVALIDATE_BUFFER_BIT | GLScene.OpenGL4 |
GL_MAP_INVALIDATE_RANGE_BIT | GLScene.OpenGL4 |
GL_MAP_PERSISTENT_BIT | GLScene.OpenGL4 |
GL_MAP_READ_BIT | GLScene.OpenGL4 | GL_ARB_map_buffer_range
GL_MAP_STENCIL | GLScene.OpenGL4 |
GL_MAP_TESSELLATION_NV | GLScene.OpenGL4 |
GL_MAP_UNSYNCHRONIZED_BIT | GLScene.OpenGL4 |
GL_MAP_WRITE_BIT | GLScene.OpenGL4 |
GL_MATERIAL_SIDE_HINT_PGI | GLScene.OpenGL4 |
GL_MATRIX0_ARB | GLScene.OpenGL4 |
GL_MATRIX0_NV | GLScene.OpenGL4 |
GL_MATRIX10_ARB | GLScene.OpenGL4 |
GL_MATRIX11_ARB | GLScene.OpenGL4 |
GL_MATRIX12_ARB | GLScene.OpenGL4 |
GL_MATRIX13_ARB | GLScene.OpenGL4 |
GL_MATRIX14_ARB | GLScene.OpenGL4 |
GL_MATRIX15_ARB | GLScene.OpenGL4 |
GL_MATRIX16_ARB | GLScene.OpenGL4 |
GL_MATRIX17_ARB | GLScene.OpenGL4 |
GL_MATRIX18_ARB | GLScene.OpenGL4 |
GL_MATRIX19_ARB | GLScene.OpenGL4 |
GL_MATRIX1_ARB | GLScene.OpenGL4 |
GL_MATRIX1_NV | GLScene.OpenGL4 |
GL_MATRIX20_ARB | GLScene.OpenGL4 |
GL_MATRIX21_ARB | GLScene.OpenGL4 |
GL_MATRIX22_ARB | GLScene.OpenGL4 |
GL_MATRIX23_ARB | GLScene.OpenGL4 |
GL_MATRIX24_ARB | GLScene.OpenGL4 |
GL_MATRIX25_ARB | GLScene.OpenGL4 |
GL_MATRIX26_ARB | GLScene.OpenGL4 |
GL_MATRIX27_ARB | GLScene.OpenGL4 |
GL_MATRIX28_ARB | GLScene.OpenGL4 |
GL_MATRIX29_ARB | GLScene.OpenGL4 |
GL_MATRIX2_ARB | GLScene.OpenGL4 |
GL_MATRIX2_NV | GLScene.OpenGL4 |
GL_MATRIX30_ARB | GLScene.OpenGL4 |
GL_MATRIX31_ARB | GLScene.OpenGL4 |
GL_MATRIX3_ARB | GLScene.OpenGL4 |
GL_MATRIX3_NV | GLScene.OpenGL4 |
GL_MATRIX4_ARB | GLScene.OpenGL4 |
GL_MATRIX4_NV | GLScene.OpenGL4 |
GL_MATRIX5_ARB | GLScene.OpenGL4 |
GL_MATRIX5_NV | GLScene.OpenGL4 |
GL_MATRIX6_ARB | GLScene.OpenGL4 |
GL_MATRIX6_NV | GLScene.OpenGL4 |
GL_MATRIX7_ARB | GLScene.OpenGL4 |
GL_MATRIX7_NV | GLScene.OpenGL4 |
GL_MATRIX8_ARB | GLScene.OpenGL4 |
GL_MATRIX9_ARB | GLScene.OpenGL4 |
GL_MATRIX_EXT | GLScene.OpenGL4 |
GL_MATRIX_INDEX_ARRAY_ARB | GLScene.OpenGL4 |
GL_MATRIX_INDEX_ARRAY_POINTER_ARB | GLScene.OpenGL4 |
GL_MATRIX_INDEX_ARRAY_SIZE_ARB | GLScene.OpenGL4 |
GL_MATRIX_INDEX_ARRAY_STRIDE_ARB | GLScene.OpenGL4 |
GL_MATRIX_INDEX_ARRAY_TYPE_ARB | GLScene.OpenGL4 |
GL_MATRIX_MODE | GLScene.OpenGL4 |
GL_MATRIX_PALETTE_ARB | GLScene.OpenGL4 | GL_ARB_matrix_palette
GL_MATRIX_STRIDE | GLScene.OpenGL4 |
GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_AMBIENT_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_COLOR_INDEXES_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_DIFFUSE_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_EMISSION_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_SHININESS_BIT_PGI | GLScene.OpenGL4 |
GL_MAT_SPECULAR_BIT_PGI | GLScene.OpenGL4 |
GL_MAX | GLScene.OpenGL4 |
GL_MAX_3D_TEXTURE_SIZE | GLScene.OpenGL4 |
GL_MAX_3D_TEXTURE_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_4D_TEXTURE_SIZE_SGIS | GLScene.OpenGL4 |
GL_MAX_ACTIVE_LIGHTS_SGIX | GLScene.OpenGL4 |
GL_MAX_ARRAY_TEXTURE_LAYERS | GLScene.OpenGL4 |
GL_MAX_ARRAY_TEXTURE_LAYERS_EXT | GLScene.OpenGL4 |
GL_MAX_ASYNC_DRAW_PIXELS_SGIX | GLScene.OpenGL4 |
GL_MAX_ASYNC_HISTOGRAM_SGIX | GLScene.OpenGL4 |
GL_MAX_ASYNC_READ_PIXELS_SGIX | GLScene.OpenGL4 |
GL_MAX_ASYNC_TEX_IMAGE_SGIX | GLScene.OpenGL4 |
GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS | GLScene.OpenGL4 |
GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE | GLScene.OpenGL4 |
GL_MAX_ATTRIB_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_BINDABLE_UNIFORM_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_CLIENT_ATTRIB_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_CLIPMAP_DEPTH_SGIX | GLScene.OpenGL4 |
GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX | GLScene.OpenGL4 |
GL_MAX_CLIP_DISTANCES | GLScene.OpenGL4 |
GL_MAX_CLIP_PLANES | GLScene.OpenGL4 |
GL_MAX_COLOR_ATTACHMENTS | GLScene.OpenGL4 |
GL_MAX_COLOR_ATTACHMENTS_EXT | GLScene.OpenGL4 |
GL_MAX_COLOR_MATRIX_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI | GLScene.OpenGL4 |
GL_MAX_COLOR_TEXTURE_SAMPLES | GLScene.OpenGL4 |
GL_MAX_COMBINED_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES | GLScene.OpenGL4 |
GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_DIMENSIONS | GLScene.OpenGL4 |
GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT | GLScene.OpenGL4 |
GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES | GLScene.OpenGL4 |
GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB | GLScene.OpenGL4 |
GL_MAX_COMBINED_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB | GLScene.OpenGL4 |
GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_COMPUTE_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_LOCAL_INVOCATIONS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_SHARED_MEMORY_SIZE | GLScene.OpenGL4 |
GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB | GLScene.OpenGL4 | GL_ARB_compute_variable_group_size
GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_COMPUTE_WORK_GROUP_COUNT | GLScene.OpenGL4 |
GL_MAX_COMPUTE_WORK_GROUP_SIZE | GLScene.OpenGL4 |
GL_MAX_CONVOLUTION_HEIGHT | GLScene.OpenGL4 |
GL_MAX_CONVOLUTION_HEIGHT_EXT | GLScene.OpenGL4 |
GL_MAX_CONVOLUTION_WIDTH | GLScene.OpenGL4 |
GL_MAX_CONVOLUTION_WIDTH_EXT | GLScene.OpenGL4 |
GL_MAX_CUBE_MAP_TEXTURE_SIZE | GLScene.OpenGL4 |
GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_CULL_DISTANCES | GLScene.OpenGL4 |
GL_MAX_DEBUG_GROUP_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_DEBUG_LOGGED_MESSAGES | GLScene.OpenGL4 |
GL_MAX_DEBUG_LOGGED_MESSAGES_AMD | GLScene.OpenGL4 | GL_AMD_debug_output
GL_MAX_DEBUG_LOGGED_MESSAGES_ARB | GLScene.OpenGL4 |
GL_MAX_DEBUG_MESSAGE_LENGTH | GLScene.OpenGL4 |
GL_MAX_DEBUG_MESSAGE_LENGTH_ARB | GLScene.OpenGL4 |
GL_MAX_DEFORMATION_ORDER_SGIX | GLScene.OpenGL4 |
GL_MAX_DEPTH | GLScene.OpenGL4 |
GL_MAX_DEPTH_TEXTURE_SAMPLES | GLScene.OpenGL4 |
GL_MAX_DRAW_BUFFERS | GLScene.OpenGL4 |
GL_MAX_DRAW_BUFFERS_ARB | GLScene.OpenGL4 | GL_ARB_draw_buffers
GL_MAX_DRAW_BUFFERS_ATI | GLScene.OpenGL4 | GL_ATI_draw_buffers
GL_MAX_DUAL_SOURCE_DRAW_BUFFERS | GLScene.OpenGL4 |
GL_MAX_ELEMENTS_INDICES | GLScene.OpenGL4 |
GL_MAX_ELEMENTS_INDICES_EXT | GLScene.OpenGL4 |
GL_MAX_ELEMENTS_INDICES_WIN | GLScene.OpenGL4 |
GL_MAX_ELEMENTS_VERTICES | GLScene.OpenGL4 |
GL_MAX_ELEMENTS_VERTICES_EXT | GLScene.OpenGL4 | GL_EXT_draw_range_elements
GL_MAX_ELEMENTS_VERTICES_WIN | GLScene.OpenGL4 | WIN_draw_range_elements
GL_MAX_ELEMENT_INDEX | GLScene.OpenGL4 |
GL_MAX_EVAL_ORDER | GLScene.OpenGL4 |
GL_MAX_EXT | GLScene.OpenGL4 |
GL_MAX_FOG_FUNC_POINTS_SGIS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_INPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_INTERPOLATION_OFFSET | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_LIGHTS_SGIX | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV | GLScene.OpenGL4 | GL_NV_fragment_program
GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_FRAGMENT_UNIFORM_VECTORS | GLScene.OpenGL4 |
GL_MAX_FRAMEBUFFER_HEIGHT | GLScene.OpenGL4 |
GL_MAX_FRAMEBUFFER_LAYERS | GLScene.OpenGL4 |
GL_MAX_FRAMEBUFFER_SAMPLES | GLScene.OpenGL4 |
GL_MAX_FRAMEBUFFER_WIDTH | GLScene.OpenGL4 |
GL_MAX_FRAMEZOOM_FACTOR_SGIX | GLScene.OpenGL4 |
GL_MAX_GENERAL_COMBINERS_NV | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_INPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_OUTPUT_VERTICES | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV | GLScene.OpenGL4 | GL_NV_gpu_program5
GL_MAX_GEOMETRY_SHADER_INVOCATIONS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_HEIGHT | GLScene.OpenGL4 |
GL_MAX_IMAGE_SAMPLES | GLScene.OpenGL4 |
GL_MAX_IMAGE_SAMPLES_EXT | GLScene.OpenGL4 |
GL_MAX_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_IMAGE_UNITS_EXT | GLScene.OpenGL4 | GL_EXT_shader_image_load_store
GL_MAX_INTEGER_SAMPLES | GLScene.OpenGL4 |
GL_MAX_LABEL_LENGTH | GLScene.OpenGL4 |
GL_MAX_LAYERS | GLScene.OpenGL4 |
GL_MAX_LIGHTS | GLScene.OpenGL4 |
GL_MAX_LIST_NESTING | GLScene.OpenGL4 |
GL_MAX_MAP_TESSELLATION_NV | GLScene.OpenGL4 |
GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB | GLScene.OpenGL4 |
GL_MAX_MODELVIEW_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_NAME_LENGTH | GLScene.OpenGL4 |
GL_MAX_NAME_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_NUM_ACTIVE_VARIABLES | GLScene.OpenGL4 |
GL_MAX_NUM_COMPATIBLE_SUBROUTINES | GLScene.OpenGL4 |
GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT | GLScene.OpenGL4 |
GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT | GLScene.OpenGL4 |
GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT | GLScene.OpenGL4 |
GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT | GLScene.OpenGL4 |
GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT | GLScene.OpenGL4 |
GL_MAX_PALETTE_MATRICES_ARB | GLScene.OpenGL4 |
GL_MAX_PATCH_VERTICES | GLScene.OpenGL4 |
GL_MAX_PIXEL_MAP_TABLE | GLScene.OpenGL4 |
GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT | GLScene.OpenGL4 |
GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI | GLScene.OpenGL4 |
GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_ATTRIBS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_CALL_DEPTH_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_ENV_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV | GLScene.OpenGL4 | GL_NV_fragment_program2 and GL_NV_vertex_program2_option
GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_GENERIC_RESULTS_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_IF_DEPTH_NV | GLScene.OpenGL4 | GL_NV_fragment_program2
GL_MAX_PROGRAM_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_LOOP_COUNT_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_LOOP_DEPTH_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_MATRICES_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_OUTPUT_VERTICES_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV | GLScene.OpenGL4 | GL_NV_parameter_buffer_object
GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_PATCH_ATTRIBS_NV | GLScene.OpenGL4 | GL_NV_tessellation_program5
GL_MAX_PROGRAM_RESULT_COMPONENTS_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_SUBROUTINE_NUM_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEMPORARIES_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEXEL_OFFSET | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEXEL_OFFSET_EXT | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV | GLScene.OpenGL4 |
GL_MAX_PROJECTION_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_RATIONAL_EVAL_ORDER_NV | GLScene.OpenGL4 |
GL_MAX_RECTANGLE_TEXTURE_SIZE | GLScene.OpenGL4 |
GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_RECTANGLE_TEXTURE_SIZE_NV | GLScene.OpenGL4 |
GL_MAX_RENDERBUFFER_SIZE | GLScene.OpenGL4 |
GL_MAX_RENDERBUFFER_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_SAMPLES | GLScene.OpenGL4 |
GL_MAX_SAMPLES_EXT | GLScene.OpenGL4 |
GL_MAX_SAMPLE_MASK_WORDS | GLScene.OpenGL4 |
GL_MAX_SAMPLE_MASK_WORDS_NV | GLScene.OpenGL4 |
GL_MAX_SERVER_WAIT_TIMEOUT | GLScene.OpenGL4 | GL_ARB_sync
GL_MAX_SHADER_BUFFER_ADDRESS_NV | GLScene.OpenGL4 |
GL_MAX_SHADER_COMPILER_THREADS_ARB | GLScene.OpenGL4 | GL_ARB_parallel_shader_compile
GL_MAX_SHADER_STORAGE_BLOCK_SIZE | GLScene.OpenGL4 |
GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS | GLScene.OpenGL4 |
GL_MAX_SHININESS_NV | GLScene.OpenGL4 | GL_NV_light_max_exponent
GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB | GLScene.OpenGL4 |
GL_MAX_SPARSE_TEXTURE_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_SPOT_EXPONENT_NV | GLScene.OpenGL4 |
GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV | GLScene.OpenGL4 |
GL_MAX_SUBROUTINES | GLScene.OpenGL4 |
GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_INPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TESS_GEN_LEVEL | GLScene.OpenGL4 |
GL_MAX_TESS_PATCH_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TEXTURE_BUFFER_SIZE | GLScene.OpenGL4 |
GL_MAX_TEXTURE_BUFFER_SIZE_ARB | GLScene.OpenGL4 |
GL_MAX_TEXTURE_BUFFER_SIZE_EXT | GLScene.OpenGL4 |
GL_MAX_TEXTURE_COORDS | GLScene.OpenGL4 |
GL_MAX_TEXTURE_COORDS_ARB | GLScene.OpenGL4 |
GL_MAX_TEXTURE_COORDS_NV | GLScene.OpenGL4 |
GL_MAX_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_TEXTURE_IMAGE_UNITS_ARB | GLScene.OpenGL4 |
GL_MAX_TEXTURE_IMAGE_UNITS_NV | GLScene.OpenGL4 |
GL_MAX_TEXTURE_LOD_BIAS | GLScene.OpenGL4 |
GL_MAX_TEXTURE_LOD_BIAS_EXT | GLScene.OpenGL4 | GL_EXT_texture_lod_bias
GL_MAX_TEXTURE_MAX_ANISOTROPY | GLScene.OpenGL4 |
GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT | GLScene.OpenGL4 |
GL_MAX_TEXTURE_SIZE | GLScene.OpenGL4 |
GL_MAX_TEXTURE_STACK_DEPTH | GLScene.OpenGL4 |
GL_MAX_TEXTURE_UNITS | GLScene.OpenGL4 |
GL_MAX_TEXTURE_UNITS_ARB | GLScene.OpenGL4 |
GL_MAX_TRACK_MATRICES_NV | GLScene.OpenGL4 |
GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_BUFFERS | GLScene.OpenGL4 | GL_ARB_transform_feedback3
GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV | GLScene.OpenGL4 |
GL_MAX_UNIFORM_BLOCK_SIZE | GLScene.OpenGL4 |
GL_MAX_UNIFORM_BUFFER_BINDINGS | GLScene.OpenGL4 |
GL_MAX_UNIFORM_LOCATIONS | GLScene.OpenGL4 |
GL_MAX_VARYING_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_VARYING_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_VARYING_FLOATS | GLScene.OpenGL4 |
GL_MAX_VARYING_FLOATS_ARB | GLScene.OpenGL4 |
GL_MAX_VARYING_VECTORS | GLScene.OpenGL4 |
GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATOMIC_COUNTERS | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATTRIBS | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATTRIBS_ARB | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATTRIB_BINDINGS | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET | GLScene.OpenGL4 |
GL_MAX_VERTEX_ATTRIB_STRIDE | GLScene.OpenGL4 | GL 4.4
GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT | GLScene.OpenGL4 | GL_EXT_bindable_uniform
GL_MAX_VERTEX_HINT_PGI | GLScene.OpenGL4 |
GL_MAX_VERTEX_IMAGE_UNIFORMS | GLScene.OpenGL4 |
GL_MAX_VERTEX_OUTPUT_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_INVARIANTS_EXT | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_LOCALS_EXT | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS | GLScene.OpenGL4 |
GL_MAX_VERTEX_SHADER_VARIANTS_EXT | GLScene.OpenGL4 |
GL_MAX_VERTEX_STREAMS | GLScene.OpenGL4 |
GL_MAX_VERTEX_STREAMS_ATI | GLScene.OpenGL4 | GL_ATI_vertex_streams
GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS | GLScene.OpenGL4 |
GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB | GLScene.OpenGL4 |
GL_MAX_VERTEX_UNIFORM_BLOCKS | GLScene.OpenGL4 |
GL_MAX_VERTEX_UNIFORM_COMPONENTS | GLScene.OpenGL4 |
GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_VERTEX_UNIFORM_VECTORS | GLScene.OpenGL4 |
GL_MAX_VERTEX_UNITS_ARB | GLScene.OpenGL4 | GL_ARB_vertex_blend
GL_MAX_VERTEX_VARYING_COMPONENTS_ARB | GLScene.OpenGL4 |
GL_MAX_VERTEX_VARYING_COMPONENTS_EXT | GLScene.OpenGL4 |
GL_MAX_VIEWPORTS | GLScene.OpenGL4 | GL_ARB_vertex_attrib_64bit
GL_MAX_VIEWPORT_DIMS | GLScene.OpenGL4 |
GL_MAX_VIEWS_OVR | GLScene.OpenGL4 |
GL_MAX_WIDTH | GLScene.OpenGL4 |
GL_MEDIUM_FLOAT | GLScene.OpenGL4 |
GL_MEDIUM_INT | GLScene.OpenGL4 |
GL_MIN | GLScene.OpenGL4 |
GL_MINMAX | GLScene.OpenGL4 |
GL_MINMAX_EXT | GLScene.OpenGL4 |
GL_MINMAX_FORMAT | GLScene.OpenGL4 |
GL_MINMAX_FORMAT_EXT | GLScene.OpenGL4 |
GL_MINMAX_SINK | GLScene.OpenGL4 |
GL_MINMAX_SINK_EXT | GLScene.OpenGL4 |
GL_MINOR_VERSION | GLScene.OpenGL4 |
GL_MIN_EXT | GLScene.OpenGL4 |
GL_MIN_FRAGMENT_INTERPOLATION_OFFSET | GLScene.OpenGL4 |
GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV | GLScene.OpenGL4 |
GL_MIN_MAP_BUFFER_ALIGNMENT | GLScene.OpenGL4 | GL_ARB_map_buffer_alignment
GL_MIN_PROGRAM_TEXEL_OFFSET | GLScene.OpenGL4 |
GL_MIN_PROGRAM_TEXEL_OFFSET_EXT | GLScene.OpenGL4 |
GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET | GLScene.OpenGL4 |
GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB | GLScene.OpenGL4 | GL_ARB_texture_gather
GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV | GLScene.OpenGL4 |
GL_MIN_SAMPLE_SHADING_VALUE | GLScene.OpenGL4 |
GL_MIN_SAMPLE_SHADING_VALUE_ARB | GLScene.OpenGL4 |
GL_MIN_SPARSE_LEVEL_ARB | GLScene.OpenGL4 |
GL_MIPMAP | GLScene.OpenGL4 |
GL_MIRRORED_REPEAT | GLScene.OpenGL4 |
GL_MIRRORED_REPEAT_ARB | GLScene.OpenGL4 | GL_ARB_texture_mirrored_repeat
GL_MIRRORED_REPEAT_IBM | GLScene.OpenGL4 | GL_IBM_texture_mirrored_repeat
GL_MIRROR_CLAMP_ATI | GLScene.OpenGL4 | GL_ATI_texture_mirror_once
GL_MIRROR_CLAMP_EXT | GLScene.OpenGL4 | GL_EXT_texture_mirror_clamp
GL_MIRROR_CLAMP_TO_BORDER_EXT | GLScene.OpenGL4 |
GL_MIRROR_CLAMP_TO_EDGE | GLScene.OpenGL4 |
GL_MIRROR_CLAMP_TO_EDGE_ATI | GLScene.OpenGL4 |
GL_MIRROR_CLAMP_TO_EDGE_EXT | GLScene.OpenGL4 |
GL_MITER_REVERT_NV | GLScene.OpenGL4 |
GL_MITER_TRUNCATE_NV | GLScene.OpenGL4 |
GL_MODELVIEW | GLScene.OpenGL4 |
GL_MODELVIEW0_ARB | GLScene.OpenGL4 |
GL_MODELVIEW0_EXT | GLScene.OpenGL4 |
GL_MODELVIEW0_MATRIX_EXT | GLScene.OpenGL4 |
GL_MODELVIEW0_STACK_DEPTH_EXT | GLScene.OpenGL4 | GL_EXT_vertex_weighting
GL_MODELVIEW10_ARB | GLScene.OpenGL4 |
GL_MODELVIEW11_ARB | GLScene.OpenGL4 |
GL_MODELVIEW12_ARB | GLScene.OpenGL4 |
GL_MODELVIEW13_ARB | GLScene.OpenGL4 |
GL_MODELVIEW14_ARB | GLScene.OpenGL4 |
GL_MODELVIEW15_ARB | GLScene.OpenGL4 |
GL_MODELVIEW16_ARB | GLScene.OpenGL4 |
GL_MODELVIEW17_ARB | GLScene.OpenGL4 |
GL_MODELVIEW18_ARB | GLScene.OpenGL4 |
GL_MODELVIEW19_ARB | GLScene.OpenGL4 |
GL_MODELVIEW1_ARB | GLScene.OpenGL4 |
GL_MODELVIEW1_EXT | GLScene.OpenGL4 |
GL_MODELVIEW1_MATRIX_EXT | GLScene.OpenGL4 |
GL_MODELVIEW1_STACK_DEPTH_EXT | GLScene.OpenGL4 |
GL_MODELVIEW20_ARB | GLScene.OpenGL4 |
GL_MODELVIEW21_ARB | GLScene.OpenGL4 |
GL_MODELVIEW22_ARB | GLScene.OpenGL4 |
GL_MODELVIEW23_ARB | GLScene.OpenGL4 |
GL_MODELVIEW24_ARB | GLScene.OpenGL4 |
GL_MODELVIEW25_ARB | GLScene.OpenGL4 |
GL_MODELVIEW26_ARB | GLScene.OpenGL4 |
GL_MODELVIEW27_ARB | GLScene.OpenGL4 |
GL_MODELVIEW28_ARB | GLScene.OpenGL4 |
GL_MODELVIEW29_ARB | GLScene.OpenGL4 |
GL_MODELVIEW2_ARB | GLScene.OpenGL4 |
GL_MODELVIEW30_ARB | GLScene.OpenGL4 |
GL_MODELVIEW31_ARB | GLScene.OpenGL4 |
GL_MODELVIEW3_ARB | GLScene.OpenGL4 |
GL_MODELVIEW4_ARB | GLScene.OpenGL4 |
GL_MODELVIEW5_ARB | GLScene.OpenGL4 |
GL_MODELVIEW6_ARB | GLScene.OpenGL4 |
GL_MODELVIEW7_ARB | GLScene.OpenGL4 |
GL_MODELVIEW8_ARB | GLScene.OpenGL4 |
GL_MODELVIEW9_ARB | GLScene.OpenGL4 |
GL_MODELVIEW_MATRIX | GLScene.OpenGL4 |
GL_MODELVIEW_PROJECTION_NV | GLScene.OpenGL4 |
GL_MODELVIEW_STACK_DEPTH | GLScene.OpenGL4 |
GL_MODULATE | GLScene.OpenGL4 |
GL_MODULATE_ADD_ATI | GLScene.OpenGL4 | GL_ATI_texture_env_combine3
GL_MODULATE_SIGNED_ADD_ATI | GLScene.OpenGL4 |
GL_MODULATE_SUBTRACT_ATI | GLScene.OpenGL4 |
GL_MOVE_TO_CONTINUES_NV | GLScene.OpenGL4 |
GL_MOVE_TO_NV | GLScene.OpenGL4 |
GL_MOVE_TO_RESETS_NV | GLScene.OpenGL4 |
GL_MOV_ATI | GLScene.OpenGL4 |
GL_MULT | GLScene.OpenGL4 |
GL_MULTIPLY_KHR | GLScene.OpenGL4 | GL_KHR_blend_equation_advanced
GL_MULTISAMPLE | GLScene.OpenGL4 |
GL_MULTISAMPLE_3DFX | GLScene.OpenGL4 | GL_3DFX_multisample
GL_MULTISAMPLE_ARB | GLScene.OpenGL4 | GL_ARB_multisample
GL_MULTISAMPLE_BIT | GLScene.OpenGL4 |
GL_MULTISAMPLE_BIT_3DFX | GLScene.OpenGL4 |
GL_MULTISAMPLE_BIT_ARB | GLScene.OpenGL4 |
GL_MULTISAMPLE_BIT_EXT | GLScene.OpenGL4 |
GL_MULTISAMPLE_EXT | GLScene.OpenGL4 | GL_EXT_multisample
GL_MULTISAMPLE_FILTER_HINT_NV | GLScene.OpenGL4 | GL_NV_multisample_filter_hint
GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB | GLScene.OpenGL4 |
GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB | GLScene.OpenGL4 |
GL_MULTISAMPLE_SGIS | GLScene.OpenGL4 | GL_SGIS_multisample
GL_MULTI_HULLS_NV | GLScene.OpenGL4 |
GL_MUL_ATI | GLScene.OpenGL4 |
GL_MVP_MATRIX_EXT | GLScene.OpenGL4 |
GL_N3F_V3F | GLScene.OpenGL4 |
GL_NAMED_STRING_LENGTH_ARB | GLScene.OpenGL4 |
GL_NAMED_STRING_TYPE_ARB | GLScene.OpenGL4 |
GL_NAME_LENGTH | GLScene.OpenGL4 |
GL_NAME_STACK_DEPTH | GLScene.OpenGL4 |
GL_NAND | GLScene.OpenGL4 |
GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI | GLScene.OpenGL4 |
GL_NATIVE_GRAPHICS_END_HINT_PGI | GLScene.OpenGL4 |
GL_NATIVE_GRAPHICS_HANDLE_PGI | GLScene.OpenGL4 |
GL_NEAREST | GLScene.OpenGL4 | TextureMagFilter
GL_NEAREST_CLIPMAP_LINEAR_SGIX | GLScene.OpenGL4 |
GL_NEAREST_CLIPMAP_NEAREST_SGIX | GLScene.OpenGL4 |
GL_NEAREST_MIPMAP_LINEAR | GLScene.OpenGL4 |
GL_NEAREST_MIPMAP_NEAREST | GLScene.OpenGL4 | TextureMinFilter
GL_NEGATE_BIT_ATI | GLScene.OpenGL4 |
GL_NEGATIVE_ONE_EXT | GLScene.OpenGL4 |
GL_NEGATIVE_ONE_TO_ONE | GLScene.OpenGL4 |
GL_NEGATIVE_W_EXT | GLScene.OpenGL4 |
GL_NEGATIVE_X_EXT | GLScene.OpenGL4 |
GL_NEGATIVE_Y_EXT | GLScene.OpenGL4 |
GL_NEGATIVE_Z_EXT | GLScene.OpenGL4 |
GL_NEVER | GLScene.OpenGL4 | AlphaFunction
GL_NEXT_BUFFER_NV | GLScene.OpenGL4 |
GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV | GLScene.OpenGL4 |
GL_NICEST | GLScene.OpenGL4 |
GL_NONE | GLScene.OpenGL4 | DrawBufferMode
GL_NOOP | GLScene.OpenGL4 |
GL_NOR | GLScene.OpenGL4 |
GL_NORMALIZE | GLScene.OpenGL4 |
GL_NORMALIZED_RANGE_EXT | GLScene.OpenGL4 |
GL_NORMAL_ARRAY | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_EXT | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_POINTER | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_TYPE | GLScene.OpenGL4 |
GL_NORMAL_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_NORMAL_BIT_PGI | GLScene.OpenGL4 |
GL_NORMAL_MAP | GLScene.OpenGL4 |
GL_NORMAL_MAP_ARB | GLScene.OpenGL4 | GL_ARB_texture_cube_map
GL_NORMAL_MAP_EXT | GLScene.OpenGL4 | GL_EXT_texture_cube_map
GL_NORMAL_MAP_NV | GLScene.OpenGL4 | GL_NV_texgen_reflection
GL_NOTEQUAL | GLScene.OpenGL4 |
GL_NO_ERROR | GLScene.OpenGL4 | ErrorCode
GL_NO_RESET_NOTIFICATION | GLScene.OpenGL4 |
GL_NO_RESET_NOTIFICATION_ARB | GLScene.OpenGL4 |
GL_NUM_ACTIVE_VARIABLES | GLScene.OpenGL4 |
GL_NUM_COMPATIBLE_SUBROUTINES | GLScene.OpenGL4 |
GL_NUM_COMPRESSED_TEXTURE_FORMATS | GLScene.OpenGL4 |
GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB | GLScene.OpenGL4 |
GL_NUM_EXTENSIONS | GLScene.OpenGL4 |
GL_NUM_FILL_STREAMS_NV | GLScene.OpenGL4 |
GL_NUM_FRAGMENT_CONSTANTS_ATI | GLScene.OpenGL4 |
GL_NUM_FRAGMENT_REGISTERS_ATI | GLScene.OpenGL4 |
GL_NUM_GENERAL_COMBINERS_NV | GLScene.OpenGL4 |
GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI | GLScene.OpenGL4 |
GL_NUM_INSTRUCTIONS_PER_PASS_ATI | GLScene.OpenGL4 |
GL_NUM_INSTRUCTIONS_TOTAL_ATI | GLScene.OpenGL4 |
GL_NUM_LOOPBACK_COMPONENTS_ATI | GLScene.OpenGL4 |
GL_NUM_PASSES_ATI | GLScene.OpenGL4 |
GL_NUM_PROGRAM_BINARY_FORMATS | GLScene.OpenGL4 |
GL_NUM_SAMPLE_COUNTS | GLScene.OpenGL4 | GL_ARB_internalformat_query
GL_NUM_SHADER_BINARY_FORMATS | GLScene.OpenGL4 |
GL_NUM_SHADING_LANGUAGE_VERSIONS | GLScene.OpenGL4 | GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3
GL_NUM_SPARSE_LEVELS_ARB | GLScene.OpenGL4 |
GL_NUM_SPIR_V_EXTENSIONS | GLScene.OpenGL4 |
GL_NUM_VIDEO_CAPTURE_STREAMS_NV | GLScene.OpenGL4 |
GL_NUM_VIRTUAL_PAGE_SIZES_ARB | GLScene.OpenGL4 |
GL_OBJECT_ACTIVE_ATTRIBUTES_ARB | GLScene.OpenGL4 |
GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB | GLScene.OpenGL4 |
GL_OBJECT_ACTIVE_UNIFORMS_ARB | GLScene.OpenGL4 |
GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB | GLScene.OpenGL4 |
GL_OBJECT_ATTACHED_OBJECTS_ARB | GLScene.OpenGL4 |
GL_OBJECT_BUFFER_SIZE_ATI | GLScene.OpenGL4 |
GL_OBJECT_BUFFER_USAGE_ATI | GLScene.OpenGL4 |
GL_OBJECT_COMPILE_STATUS_ARB | GLScene.OpenGL4 |
GL_OBJECT_DELETE_STATUS_ARB | GLScene.OpenGL4 |
GL_OBJECT_DISTANCE_TO_LINE_SGIS | GLScene.OpenGL4 |
GL_OBJECT_DISTANCE_TO_POINT_SGIS | GLScene.OpenGL4 |
GL_OBJECT_INFO_LOG_LENGTH_ARB | GLScene.OpenGL4 |
GL_OBJECT_LINEAR | GLScene.OpenGL4 |
GL_OBJECT_LINE_SGIS | GLScene.OpenGL4 |
GL_OBJECT_LINK_STATUS_ARB | GLScene.OpenGL4 |
GL_OBJECT_PLANE | GLScene.OpenGL4 |
GL_OBJECT_POINT_SGIS | GLScene.OpenGL4 |
GL_OBJECT_SHADER_SOURCE_LENGTH_ARB | GLScene.OpenGL4 |
GL_OBJECT_SUBTYPE_ARB | GLScene.OpenGL4 |
GL_OBJECT_TYPE | GLScene.OpenGL4 |
GL_OBJECT_TYPE_ARB | GLScene.OpenGL4 |
GL_OBJECT_VALIDATE_STATUS_ARB | GLScene.OpenGL4 |
GL_OCCLUSION_TEST_HP | GLScene.OpenGL4 | GL_HP_occlusion_test
GL_OCCLUSION_TEST_RESULT_HP | GLScene.OpenGL4 |
GL_OFFSET | GLScene.OpenGL4 |
GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
GL_OFFSET_HILO_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV | GLScene.OpenGL4 | GL_NV_texture_shader3
GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV | GLScene.OpenGL4 |
GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_2D_BIAS_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_2D_MATRIX_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_2D_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_2D_SCALE_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_BIAS_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_MATRIX_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 | GL_NV_texture_shader
GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV | GLScene.OpenGL4 |
GL_OFFSET_TEXTURE_SCALE_NV | GLScene.OpenGL4 |
GL_ONE | GLScene.OpenGL4 |
GL_ONE_EXT | GLScene.OpenGL4 |
GL_ONE_MINUS_CONSTANT_ALPHA | GLScene.OpenGL4 |
GL_ONE_MINUS_CONSTANT_ALPHA_EXT | GLScene.OpenGL4 |
GL_ONE_MINUS_CONSTANT_COLOR | GLScene.OpenGL4 |
GL_ONE_MINUS_CONSTANT_COLOR_EXT | GLScene.OpenGL4 |
GL_ONE_MINUS_DST_ALPHA | GLScene.OpenGL4 |
GL_ONE_MINUS_DST_COLOR | GLScene.OpenGL4 |
GL_ONE_MINUS_SRC1_ALPHA | GLScene.OpenGL4 |
GL_ONE_MINUS_SRC1_COLOR | GLScene.OpenGL4 |
GL_ONE_MINUS_SRC_ALPHA | GLScene.OpenGL4 |
GL_ONE_MINUS_SRC_COLOR | GLScene.OpenGL4 |
GL_OPERAND0_ALPHA | GLScene.OpenGL4 |
GL_OPERAND0_ALPHA_ARB | GLScene.OpenGL4 |
GL_OPERAND0_ALPHA_EXT | GLScene.OpenGL4 |
GL_OPERAND0_RGB | GLScene.OpenGL4 |
GL_OPERAND0_RGB_ARB | GLScene.OpenGL4 |
GL_OPERAND0_RGB_EXT | GLScene.OpenGL4 |
GL_OPERAND1_ALPHA | GLScene.OpenGL4 |
GL_OPERAND1_ALPHA_ARB | GLScene.OpenGL4 |
GL_OPERAND1_ALPHA_EXT | GLScene.OpenGL4 |
GL_OPERAND1_RGB | GLScene.OpenGL4 |
GL_OPERAND1_RGB_ARB | GLScene.OpenGL4 |
GL_OPERAND1_RGB_EXT | GLScene.OpenGL4 |
GL_OPERAND2_ALPHA | GLScene.OpenGL4 |
GL_OPERAND2_ALPHA_ARB | GLScene.OpenGL4 |
GL_OPERAND2_ALPHA_EXT | GLScene.OpenGL4 |
GL_OPERAND2_RGB | GLScene.OpenGL4 |
GL_OPERAND2_RGB_ARB | GLScene.OpenGL4 |
GL_OPERAND2_RGB_EXT | GLScene.OpenGL4 |
GL_OPERAND3_ALPHA_NV | GLScene.OpenGL4 |
GL_OPERAND3_RGB_NV | GLScene.OpenGL4 |
GL_OP_ADD_EXT | GLScene.OpenGL4 |
GL_OP_CLAMP_EXT | GLScene.OpenGL4 |
GL_OP_CROSS_PRODUCT_EXT | GLScene.OpenGL4 |
GL_OP_DOT3_EXT | GLScene.OpenGL4 |
GL_OP_DOT4_EXT | GLScene.OpenGL4 |
GL_OP_EXP_BASE_2_EXT | GLScene.OpenGL4 |
GL_OP_FLOOR_EXT | GLScene.OpenGL4 |
GL_OP_FRAC_EXT | GLScene.OpenGL4 |
GL_OP_INDEX_EXT | GLScene.OpenGL4 |
GL_OP_LOG_BASE_2_EXT | GLScene.OpenGL4 |
GL_OP_MADD_EXT | GLScene.OpenGL4 |
GL_OP_MAX_EXT | GLScene.OpenGL4 |
GL_OP_MIN_EXT | GLScene.OpenGL4 |
GL_OP_MOV_EXT | GLScene.OpenGL4 |
GL_OP_MULTIPLY_MATRIX_EXT | GLScene.OpenGL4 |
GL_OP_MUL_EXT | GLScene.OpenGL4 |
GL_OP_NEGATE_EXT | GLScene.OpenGL4 |
GL_OP_POWER_EXT | GLScene.OpenGL4 |
GL_OP_RECIP_EXT | GLScene.OpenGL4 |
GL_OP_RECIP_SQRT_EXT | GLScene.OpenGL4 |
GL_OP_ROUND_EXT | GLScene.OpenGL4 |
GL_OP_SET_GE_EXT | GLScene.OpenGL4 |
GL_OP_SET_LT_EXT | GLScene.OpenGL4 |
GL_OP_SUB_EXT | GLScene.OpenGL4 |
GL_OR | GLScene.OpenGL4 |
GL_ORDER | GLScene.OpenGL4 |
GL_OR_INVERTED | GLScene.OpenGL4 |
GL_OR_REVERSE | GLScene.OpenGL4 |
GL_OUTPUT_COLOR0_EXT | GLScene.OpenGL4 |
GL_OUTPUT_COLOR1_EXT | GLScene.OpenGL4 |
GL_OUTPUT_FOG_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD0_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD10_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD11_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD12_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD13_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD14_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD15_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD16_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD17_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD18_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD19_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD1_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD20_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD21_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD22_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD23_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD24_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD25_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD26_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD27_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD28_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD29_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD2_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD30_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD31_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD3_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD4_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD5_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD6_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD7_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD8_EXT | GLScene.OpenGL4 |
GL_OUTPUT_TEXTURE_COORD9_EXT | GLScene.OpenGL4 |
GL_OUTPUT_VERTEX_EXT | GLScene.OpenGL4 |
GL_OUT_OF_MEMORY | GLScene.OpenGL4 |
GL_OVERLAY_KHR | GLScene.OpenGL4 |
GL_PACK_ALIGNMENT | GLScene.OpenGL4 |
GL_PACK_CMYK_HINT_EXT | GLScene.OpenGL4 |
GL_PACK_COMPRESSED_BLOCK_DEPTH | GLScene.OpenGL4 |
GL_PACK_COMPRESSED_BLOCK_HEIGHT | GLScene.OpenGL4 |
GL_PACK_COMPRESSED_BLOCK_SIZE | GLScene.OpenGL4 |
GL_PACK_COMPRESSED_BLOCK_WIDTH | GLScene.OpenGL4 |
GL_PACK_IMAGE_DEPTH_SGIS | GLScene.OpenGL4 |
GL_PACK_IMAGE_HEIGHT | GLScene.OpenGL4 |
GL_PACK_IMAGE_HEIGHT_EXT | GLScene.OpenGL4 |
GL_PACK_LSB_FIRST | GLScene.OpenGL4 |
GL_PACK_RESAMPLE_OML | GLScene.OpenGL4 | GL_OML_resample
GL_PACK_RESAMPLE_SGIX | GLScene.OpenGL4 | GL_SGIX_resample
GL_PACK_ROW_BYTES_APPLE | GLScene.OpenGL4 | GL_APPLE_row_bytes
GL_PACK_ROW_LENGTH | GLScene.OpenGL4 |
GL_PACK_SKIP_IMAGES | GLScene.OpenGL4 |
GL_PACK_SKIP_IMAGES_EXT | GLScene.OpenGL4 | GL_EXT_texture3D
GL_PACK_SKIP_PIXELS | GLScene.OpenGL4 |
GL_PACK_SKIP_ROWS | GLScene.OpenGL4 |
GL_PACK_SKIP_VOLUMES_SGIS | GLScene.OpenGL4 | GL_SGIS_texture4D
GL_PACK_SUBSAMPLE_RATE_SGIX | GLScene.OpenGL4 | GL_SGIX_subsample
GL_PACK_SWAP_BYTES | GLScene.OpenGL4 |
GL_PARALLEL_ARRAYS_INTEL | GLScene.OpenGL4 | GL_INTEL_parallel_arrays
GL_PARAMETER_BUFFER | GLScene.OpenGL4 |
GL_PARAMETER_BUFFER_BINDING | GLScene.OpenGL4 |
GL_PARTIAL_SUCCESS_NV | GLScene.OpenGL4 |
GL_PASS_THROUGH_NV | GLScene.OpenGL4 |
GL_PASS_THROUGH_TOKEN | GLScene.OpenGL4 |
GL_PATCHES | GLScene.OpenGL4 | GL_ARB_tessellation_shader
GL_PATCH_DEFAULT_INNER_LEVEL | GLScene.OpenGL4 |
GL_PATCH_DEFAULT_OUTER_LEVEL | GLScene.OpenGL4 |
GL_PATCH_VERTICES | GLScene.OpenGL4 |
GL_PATH_CLIENT_LENGTH_NV | GLScene.OpenGL4 |
GL_PATH_COMMAND_COUNT_NV | GLScene.OpenGL4 |
GL_PATH_COMPUTED_LENGTH_NV | GLScene.OpenGL4 |
GL_PATH_COORD_COUNT_NV | GLScene.OpenGL4 |
GL_PATH_COVER_DEPTH_FUNC_NV | GLScene.OpenGL4 |
GL_PATH_DASH_ARRAY_COUNT_NV | GLScene.OpenGL4 |
GL_PATH_DASH_CAPS_NV | GLScene.OpenGL4 |
GL_PATH_DASH_OFFSET_NV | GLScene.OpenGL4 |
GL_PATH_DASH_OFFSET_RESET_NV | GLScene.OpenGL4 |
GL_PATH_END_CAPS_NV | GLScene.OpenGL4 |
GL_PATH_ERROR_POSITION_NV | GLScene.OpenGL4 |
GL_PATH_FILL_BOUNDING_BOX_NV | GLScene.OpenGL4 |
GL_PATH_FILL_COVER_MODE_NV | GLScene.OpenGL4 |
GL_PATH_FILL_MASK_NV | GLScene.OpenGL4 |
GL_PATH_FILL_MODE_NV | GLScene.OpenGL4 |
GL_PATH_FOG_GEN_MODE_NV | GLScene.OpenGL4 |
GL_PATH_FORMAT_PS_NV | GLScene.OpenGL4 |
GL_PATH_FORMAT_SVG_NV | GLScene.OpenGL4 | (4.3) GL_NV_path_rendering
GL_PATH_GEN_COEFF_NV | GLScene.OpenGL4 |
GL_PATH_GEN_COLOR_FORMAT_NV | GLScene.OpenGL4 |
GL_PATH_GEN_COMPONENTS_NV | GLScene.OpenGL4 |
GL_PATH_GEN_MODE_NV | GLScene.OpenGL4 |
GL_PATH_INITIAL_DASH_CAP_NV | GLScene.OpenGL4 |
GL_PATH_INITIAL_END_CAP_NV | GLScene.OpenGL4 |
GL_PATH_JOIN_STYLE_NV | GLScene.OpenGL4 |
GL_PATH_MITER_LIMIT_NV | GLScene.OpenGL4 |
GL_PATH_OBJECT_BOUNDING_BOX_NV | GLScene.OpenGL4 |
GL_PATH_SAMPLE_QUALITY_NV | GLScene.OpenGL4 |
GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV | GLScene.OpenGL4 |
GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV | GLScene.OpenGL4 |
GL_PATH_STENCIL_FUNC_NV | GLScene.OpenGL4 |
GL_PATH_STENCIL_REF_NV | GLScene.OpenGL4 |
GL_PATH_STENCIL_VALUE_MASK_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_BOUNDING_BOX_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_BOUND_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_COVER_MODE_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_MASK_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_OVERSAMPLE_COUNT_NV | GLScene.OpenGL4 |
GL_PATH_STROKE_WIDTH_NV | GLScene.OpenGL4 |
GL_PATH_TERMINAL_DASH_CAP_NV | GLScene.OpenGL4 |
GL_PATH_TERMINAL_END_CAP_NV | GLScene.OpenGL4 |
GL_PERCENTAGE_AMD | GLScene.OpenGL4 |
GL_PERFMON_RESULT_AMD | GLScene.OpenGL4 |
GL_PERFMON_RESULT_AVAILABLE_AMD | GLScene.OpenGL4 |
GL_PERFMON_RESULT_SIZE_AMD | GLScene.OpenGL4 |
GL_PERFORMANCE_MONITOR_AMD | GLScene.OpenGL4 |
GL_PERSPECTIVE_CORRECTION_HINT | GLScene.OpenGL4 |
GL_PERTURB_EXT | GLScene.OpenGL4 | GL_EXT_texture_perturb_normal
GL_PER_STAGE_CONSTANTS_NV | GLScene.OpenGL4 | GL_NV_register_combiners2
GL_PHONG_HINT_WIN | GLScene.OpenGL4 |
GL_PHONG_WIN | GLScene.OpenGL4 | GL_WIN_phong_shading
GL_PIXEL_BUFFER_BARRIER_BIT | GLScene.OpenGL4 |
GL_PIXEL_BUFFER_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_PIXEL_COUNTER_BITS_NV | GLScene.OpenGL4 | GL_NV_occlusion_query
GL_PIXEL_COUNT_AVAILABLE_NV | GLScene.OpenGL4 |
GL_PIXEL_COUNT_NV | GLScene.OpenGL4 |
GL_PIXEL_CUBIC_WEIGHT_EXT | GLScene.OpenGL4 |
GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS | GLScene.OpenGL4 |
GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS | GLScene.OpenGL4 |
GL_PIXEL_GROUP_COLOR_SGIS | GLScene.OpenGL4 |
GL_PIXEL_MAG_FILTER_EXT | GLScene.OpenGL4 |
GL_PIXEL_MAP_A_TO_A | GLScene.OpenGL4 |
GL_PIXEL_MAP_A_TO_A_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_B_TO_B | GLScene.OpenGL4 |
GL_PIXEL_MAP_B_TO_B_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_G_TO_G | GLScene.OpenGL4 |
GL_PIXEL_MAP_G_TO_G_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_A | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_A_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_B | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_B_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_G | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_G_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_I | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_I_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_R | GLScene.OpenGL4 |
GL_PIXEL_MAP_I_TO_R_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_R_TO_R | GLScene.OpenGL4 |
GL_PIXEL_MAP_R_TO_R_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MAP_S_TO_S | GLScene.OpenGL4 |
GL_PIXEL_MAP_S_TO_S_SIZE | GLScene.OpenGL4 |
GL_PIXEL_MIN_FILTER_EXT | GLScene.OpenGL4 |
GL_PIXEL_MODE_BIT | GLScene.OpenGL4 |
GL_PIXEL_PACK_BUFFER | GLScene.OpenGL4 | GL_VERSION_2_1
GL_PIXEL_PACK_BUFFER_ARB | GLScene.OpenGL4 | GL_ARB_pixel_buffer_object
GL_PIXEL_PACK_BUFFER_BINDING | GLScene.OpenGL4 |
GL_PIXEL_PACK_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_PIXEL_PACK_BUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_PIXEL_PACK_BUFFER_EXT | GLScene.OpenGL4 | GL_EXT_pixel_buffer_object
GL_PIXEL_SUBSAMPLE_2424_SGIX | GLScene.OpenGL4 |
GL_PIXEL_SUBSAMPLE_4242_SGIX | GLScene.OpenGL4 |
GL_PIXEL_SUBSAMPLE_4444_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEXTURE_SGIS | GLScene.OpenGL4 | GL_SGIS_pixel_texture
GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_MODE_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_Q_CEILING_SGIX | GLScene.OpenGL4 | GL_SGIX_impact_pixel_texture
GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_Q_ROUND_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TEX_GEN_SGIX | GLScene.OpenGL4 | GL_SGIX_pixel_texture
GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX | GLScene.OpenGL4 | GL_SGIX_pixel_tiles
GL_PIXEL_TILE_CACHE_INCREMENT_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_CACHE_SIZE_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_GRID_DEPTH_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_GRID_HEIGHT_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_GRID_WIDTH_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_HEIGHT_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TILE_WIDTH_SGIX | GLScene.OpenGL4 |
GL_PIXEL_TRANSFORM_2D_EXT | GLScene.OpenGL4 | GL_EXT_pixel_transform
GL_PIXEL_TRANSFORM_2D_MATRIX_EXT | GLScene.OpenGL4 |
GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER_ARB | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER_BINDING | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_PIXEL_UNPACK_BUFFER_EXT | GLScene.OpenGL4 |
GL_PN_TRIANGLES_ATI | GLScene.OpenGL4 | GL_ATI_pn_triangles
GL_PN_TRIANGLES_NORMAL_MODE_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_POINT_MODE_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI | GLScene.OpenGL4 |
GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI | GLScene.OpenGL4 |
GL_POINT | GLScene.OpenGL4 | PolygonMode
GL_POINTS | GLScene.OpenGL4 | BeginMode
GL_POINT_BIT | GLScene.OpenGL4 |
GL_POINT_DISTANCE_ATTENUATION | GLScene.OpenGL4 |
GL_POINT_DISTANCE_ATTENUATION_ARB | GLScene.OpenGL4 |
GL_POINT_FADE_THRESHOLD_SIZE | GLScene.OpenGL4 |
GL_POINT_FADE_THRESHOLD_SIZE_ARB | GLScene.OpenGL4 |
GL_POINT_FADE_THRESHOLD_SIZE_EXT | GLScene.OpenGL4 |
GL_POINT_FADE_THRESHOLD_SIZE_SGIS | GLScene.OpenGL4 |
GL_POINT_SIZE | GLScene.OpenGL4 | GetPName
GL_POINT_SIZE_GRANULARITY | GLScene.OpenGL4 |
GL_POINT_SIZE_MAX | GLScene.OpenGL4 |
GL_POINT_SIZE_MAX_ARB | GLScene.OpenGL4 |
GL_POINT_SIZE_MAX_EXT | GLScene.OpenGL4 |
GL_POINT_SIZE_MAX_SGIS | GLScene.OpenGL4 |
GL_POINT_SIZE_MIN | GLScene.OpenGL4 |
GL_POINT_SIZE_MIN_ARB | GLScene.OpenGL4 | GL_ARB_point_parameters
GL_POINT_SIZE_MIN_EXT | GLScene.OpenGL4 | GL_EXT_point_parameters
GL_POINT_SIZE_MIN_SGIS | GLScene.OpenGL4 | GL_SGIS_point_parameters
GL_POINT_SIZE_RANGE | GLScene.OpenGL4 |
GL_POINT_SMOOTH | GLScene.OpenGL4 |
GL_POINT_SMOOTH_HINT | GLScene.OpenGL4 |
GL_POINT_SPRITE | GLScene.OpenGL4 |
GL_POINT_SPRITE_ARB | GLScene.OpenGL4 | GL_ARB_point_sprite
GL_POINT_SPRITE_COORD_ORIGIN | GLScene.OpenGL4 |
GL_POINT_SPRITE_NV | GLScene.OpenGL4 | GL_NV_point_sprite
GL_POINT_SPRITE_R_MODE_NV | GLScene.OpenGL4 |
GL_POINT_TOKEN | GLScene.OpenGL4 |
GL_POLYGON | GLScene.OpenGL4 |
GL_POLYGON_BIT | GLScene.OpenGL4 |
GL_POLYGON_MODE | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_BIAS_EXT | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_CLAMP | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_EXT | GLScene.OpenGL4 | GL_EXT_polygon_offset
GL_POLYGON_OFFSET_FACTOR | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_FACTOR_EXT | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_FILL | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_LINE | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_POINT | GLScene.OpenGL4 |
GL_POLYGON_OFFSET_UNITS | GLScene.OpenGL4 |
GL_POLYGON_SMOOTH | GLScene.OpenGL4 |
GL_POLYGON_SMOOTH_HINT | GLScene.OpenGL4 |
GL_POLYGON_STIPPLE | GLScene.OpenGL4 |
GL_POLYGON_STIPPLE_BIT | GLScene.OpenGL4 |
GL_POLYGON_TOKEN | GLScene.OpenGL4 |
GL_POSITION | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_ALPHA_BIAS | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_ALPHA_SCALE | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_BLUE_BIAS | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_BLUE_SCALE | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_COLOR_TABLE | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_GREEN_BIAS | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_GREEN_SCALE | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_RED_BIAS | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_RED_BIAS_SGI | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_RED_SCALE | GLScene.OpenGL4 |
GL_POST_COLOR_MATRIX_RED_SCALE_SGI | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_ALPHA_BIAS | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_ALPHA_BIAS_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_ALPHA_SCALE | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_ALPHA_SCALE_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_BLUE_BIAS | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_BLUE_BIAS_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_BLUE_SCALE | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_BLUE_SCALE_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_COLOR_TABLE | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_GREEN_BIAS | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_GREEN_BIAS_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_GREEN_SCALE | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_GREEN_SCALE_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_RED_BIAS | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_RED_BIAS_EXT | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_RED_SCALE | GLScene.OpenGL4 |
GL_POST_CONVOLUTION_RED_SCALE_EXT | GLScene.OpenGL4 |
GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP | GLScene.OpenGL4 |
GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX | GLScene.OpenGL4 |
GL_POST_TEXTURE_FILTER_BIAS_SGIX | GLScene.OpenGL4 | GL_SGIX_texture_scale_bias
GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX | GLScene.OpenGL4 |
GL_POST_TEXTURE_FILTER_SCALE_SGIX | GLScene.OpenGL4 |
GL_PREFER_DOUBLEBUFFER_HINT_PGI | GLScene.OpenGL4 | GL_PGI_misc_hints
GL_PRESENT_DURATION_NV | GLScene.OpenGL4 |
GL_PRESENT_TIME_NV | GLScene.OpenGL4 |
GL_PRESERVE_ATI | GLScene.OpenGL4 |
GL_PREVIOUS | GLScene.OpenGL4 |
GL_PREVIOUS_ARB | GLScene.OpenGL4 |
GL_PREVIOUS_EXT | GLScene.OpenGL4 |
GL_PREVIOUS_TEXTURE_INPUT_NV | GLScene.OpenGL4 |
GL_PRIMARY_COLOR | GLScene.OpenGL4 |
GL_PRIMARY_COLOR_ARB | GLScene.OpenGL4 |
GL_PRIMARY_COLOR_EXT | GLScene.OpenGL4 |
GL_PRIMARY_COLOR_NV | GLScene.OpenGL4 |
GL_PRIMITIVES_GENERATED | GLScene.OpenGL4 |
GL_PRIMITIVES_GENERATED_EXT | GLScene.OpenGL4 |
GL_PRIMITIVES_GENERATED_NV | GLScene.OpenGL4 |
GL_PRIMITIVES_SUBMITTED | GLScene.OpenGL4 |
GL_PRIMITIVES_SUBMITTED_ARB | GLScene.OpenGL4 |
GL_PRIMITIVE_BOUNDING_BOX_ARB | GLScene.OpenGL4 | GL_ARB_ES3_2_compatibility
GL_PRIMITIVE_ID_NV | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART_FIXED_INDEX | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART_INDEX | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART_INDEX_NV | GLScene.OpenGL4 |
GL_PRIMITIVE_RESTART_NV | GLScene.OpenGL4 | GL_NV_primitive_restart
GL_PROGRAM | GLScene.OpenGL4 |
GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB | GLScene.OpenGL4 |
GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ADDRESS_REGISTERS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ALU_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ATTRIBS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ATTRIB_COMPONENTS_NV | GLScene.OpenGL4 | GL_NV_gpu_program4
GL_PROGRAM_BINARY_FORMATS | GLScene.OpenGL4 |
GL_PROGRAM_BINARY_LENGTH | GLScene.OpenGL4 |
GL_PROGRAM_BINARY_RETRIEVABLE_HINT | GLScene.OpenGL4 | GL_ARB_get_program_binary
GL_PROGRAM_BINDING_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ERROR_POSITION_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ERROR_POSITION_NV | GLScene.OpenGL4 |
GL_PROGRAM_ERROR_STRING_ARB | GLScene.OpenGL4 |
GL_PROGRAM_ERROR_STRING_NV | GLScene.OpenGL4 |
GL_PROGRAM_FORMAT_ARB | GLScene.OpenGL4 |
GL_PROGRAM_FORMAT_ASCII_ARB | GLScene.OpenGL4 |
GL_PROGRAM_INPUT | GLScene.OpenGL4 |
GL_PROGRAM_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_LENGTH_ARB | GLScene.OpenGL4 |
GL_PROGRAM_LENGTH_NV | GLScene.OpenGL4 |
GL_PROGRAM_MATRIX_EXT | GLScene.OpenGL4 | GL_EXT_direct_state_access
GL_PROGRAM_MATRIX_STACK_DEPTH_EXT | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_ATTRIBS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_TEMPORARIES_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_OBJECT_ARB | GLScene.OpenGL4 | 1.4 GL_ARB_shader_objects
GL_PROGRAM_OUTPUT | GLScene.OpenGL4 |
GL_PROGRAM_PARAMETERS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_PARAMETER_NV | GLScene.OpenGL4 |
GL_PROGRAM_PIPELINE | GLScene.OpenGL4 |
GL_PROGRAM_PIPELINE_BINDING | GLScene.OpenGL4 |
GL_PROGRAM_POINT_SIZE | GLScene.OpenGL4 |
GL_PROGRAM_POINT_SIZE_ARB | GLScene.OpenGL4 |
GL_PROGRAM_POINT_SIZE_EXT | GLScene.OpenGL4 |
GL_PROGRAM_RESIDENT_NV | GLScene.OpenGL4 |
GL_PROGRAM_RESULT_COMPONENTS_NV | GLScene.OpenGL4 |
GL_PROGRAM_SEPARABLE | GLScene.OpenGL4 |
GL_PROGRAM_STRING_ARB | GLScene.OpenGL4 |
GL_PROGRAM_STRING_NV | GLScene.OpenGL4 |
GL_PROGRAM_TARGET_NV | GLScene.OpenGL4 |
GL_PROGRAM_TEMPORARIES_ARB | GLScene.OpenGL4 |
GL_PROGRAM_TEX_INDIRECTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_TEX_INSTRUCTIONS_ARB | GLScene.OpenGL4 |
GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB | GLScene.OpenGL4 |
GL_PROJECTION | GLScene.OpenGL4 |
GL_PROJECTION_MATRIX | GLScene.OpenGL4 |
GL_PROJECTION_STACK_DEPTH | GLScene.OpenGL4 |
GL_PROJECTIVE_2D_NV | GLScene.OpenGL4 |
GL_PROJECTIVE_3D_NV | GLScene.OpenGL4 |
GL_PROVOKING_VERTEX | GLScene.OpenGL4 |
GL_PROVOKING_VERTEX_EXT | GLScene.OpenGL4 |
GL_PROXY_COLOR_TABLE | GLScene.OpenGL4 |
GL_PROXY_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_PROXY_HISTOGRAM | GLScene.OpenGL4 |
GL_PROXY_HISTOGRAM_EXT | GLScene.OpenGL4 |
GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE | GLScene.OpenGL4 |
GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_PROXY_POST_CONVOLUTION_COLOR_TABLE | GLScene.OpenGL4 |
GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_1D | GLScene.OpenGL4 | TextureTarget
GL_PROXY_TEXTURE_1D_ARRAY | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_1D_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D_ARRAY | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_3D | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_3D_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_4D_SGIS | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_COLOR_TABLE_SGI | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_CUBE_MAP | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_CUBE_MAP_ARB | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_CUBE_MAP_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_RECTANGLE | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_RECTANGLE_ARB | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_RECTANGLE_EXT | GLScene.OpenGL4 |
GL_PROXY_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
GL_PURGEABLE_APPLE | GLScene.OpenGL4 |
GL_Q | GLScene.OpenGL4 |
GL_QUADRATIC_ATTENUATION | GLScene.OpenGL4 |
GL_QUADRATIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_QUADS | GLScene.OpenGL4 |
GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION | GLScene.OpenGL4 | GL_ARB_provoking_vertex
GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT | GLScene.OpenGL4 | GL_EXT_provoking_vertex
GL_QUAD_ALPHA4_SGIS | GLScene.OpenGL4 |
GL_QUAD_ALPHA8_SGIS | GLScene.OpenGL4 |
GL_QUAD_INTENSITY4_SGIS | GLScene.OpenGL4 |
GL_QUAD_INTENSITY8_SGIS | GLScene.OpenGL4 |
GL_QUAD_LUMINANCE4_SGIS | GLScene.OpenGL4 |
GL_QUAD_LUMINANCE8_SGIS | GLScene.OpenGL4 |
GL_QUAD_MESH_SUN | GLScene.OpenGL4 | GL_SUN_mesh_array
GL_QUAD_STRIP | GLScene.OpenGL4 |
GL_QUAD_TEXTURE_SELECT_SGIS | GLScene.OpenGL4 |
GL_QUARTER_BIT_ATI | GLScene.OpenGL4 |
GL_QUERY | GLScene.OpenGL4 |
GL_QUERY_BUFFER | GLScene.OpenGL4 |
GL_QUERY_BUFFER_AMD | GLScene.OpenGL4 | (4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object
GL_QUERY_BUFFER_BARRIER_BIT | GLScene.OpenGL4 |
GL_QUERY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_QUERY_BUFFER_BINDING_AMD | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_NO_WAIT | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_NO_WAIT_INVERTED | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_NO_WAIT_NV | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_WAIT | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_WAIT_INVERTED | GLScene.OpenGL4 |
GL_QUERY_BY_REGION_WAIT_NV | GLScene.OpenGL4 |
GL_QUERY_COUNTER_BITS | GLScene.OpenGL4 |
GL_QUERY_COUNTER_BITS_ARB | GLScene.OpenGL4 |
GL_QUERY_NO_WAIT | GLScene.OpenGL4 |
GL_QUERY_NO_WAIT_INVERTED | GLScene.OpenGL4 |
GL_QUERY_NO_WAIT_NV | GLScene.OpenGL4 |
GL_QUERY_OBJECT_AMD | GLScene.OpenGL4 |
GL_QUERY_RESULT | GLScene.OpenGL4 |
GL_QUERY_RESULT_ARB | GLScene.OpenGL4 |
GL_QUERY_RESULT_AVAILABLE | GLScene.OpenGL4 |
GL_QUERY_RESULT_AVAILABLE_ARB | GLScene.OpenGL4 |
GL_QUERY_RESULT_NO_WAIT | GLScene.OpenGL4 |
GL_QUERY_RESULT_NO_WAIT_AMD | GLScene.OpenGL4 |
GL_QUERY_TARGET | GLScene.OpenGL4 |
GL_QUERY_WAIT | GLScene.OpenGL4 |
GL_QUERY_WAIT_INVERTED | GLScene.OpenGL4 |
GL_QUERY_WAIT_NV | GLScene.OpenGL4 | GL_NV_conditional_render
GL_R | GLScene.OpenGL4 |
GL_R11F_G11F_B10F | GLScene.OpenGL4 |
GL_R11F_G11F_B10F_EXT | GLScene.OpenGL4 | GL_EXT_packed_float
GL_R16 | GLScene.OpenGL4 |
GL_R16F | GLScene.OpenGL4 |
GL_R16I | GLScene.OpenGL4 |
GL_R16UI | GLScene.OpenGL4 |
GL_R16_SNORM | GLScene.OpenGL4 |
GL_R1UI_C3F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_C4F_N3F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_C4UB_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_N3F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_T2F_C4F_N3F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_T2F_N3F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_T2F_V3F_SUN | GLScene.OpenGL4 |
GL_R1UI_V3F_SUN | GLScene.OpenGL4 |
GL_R32F | GLScene.OpenGL4 |
GL_R32I | GLScene.OpenGL4 |
GL_R32UI | GLScene.OpenGL4 |
GL_R3_G3_B2 | GLScene.OpenGL4 | PixelInternalFormat
GL_R8 | GLScene.OpenGL4 |
GL_R8I | GLScene.OpenGL4 |
GL_R8UI | GLScene.OpenGL4 |
GL_R8_SNORM | GLScene.OpenGL4 |
GL_RASTERIZER_DISCARD | GLScene.OpenGL4 |
GL_RASTERIZER_DISCARD_EXT | GLScene.OpenGL4 |
GL_RASTERIZER_DISCARD_NV | GLScene.OpenGL4 |
GL_RASTER_POSITION_UNCLIPPED_IBM | GLScene.OpenGL4 | GL_IBM_rasterpos_clip
GL_READ_BUFFER | GLScene.OpenGL4 |
GL_READ_FRAMEBUFFER | GLScene.OpenGL4 |
GL_READ_FRAMEBUFFER_BINDING | GLScene.OpenGL4 |
GL_READ_FRAMEBUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_READ_FRAMEBUFFER_EXT | GLScene.OpenGL4 | GL_EXT_framebuffer_blit
GL_READ_ONLY | GLScene.OpenGL4 |
GL_READ_ONLY_ARB | GLScene.OpenGL4 |
GL_READ_PIXELS | GLScene.OpenGL4 |
GL_READ_PIXELS_FORMAT | GLScene.OpenGL4 |
GL_READ_PIXELS_TYPE | GLScene.OpenGL4 |
GL_READ_PIXEL_DATA_RANGE_LENGTH_NV | GLScene.OpenGL4 |
GL_READ_PIXEL_DATA_RANGE_NV | GLScene.OpenGL4 |
GL_READ_PIXEL_DATA_RANGE_POINTER_NV | GLScene.OpenGL4 |
GL_READ_WRITE | GLScene.OpenGL4 |
GL_READ_WRITE_ARB | GLScene.OpenGL4 |
GL_RECLAIM_MEMORY_HINT_PGI | GLScene.OpenGL4 |
GL_RECT_NV | GLScene.OpenGL4 |
GL_RED | GLScene.OpenGL4 |
GL_REDUCE | GLScene.OpenGL4 |
GL_REDUCE_EXT | GLScene.OpenGL4 |
GL_RED_BIAS | GLScene.OpenGL4 |
GL_RED_BITS | GLScene.OpenGL4 |
GL_RED_BIT_ATI | GLScene.OpenGL4 |
GL_RED_INTEGER | GLScene.OpenGL4 |
GL_RED_INTEGER_EXT | GLScene.OpenGL4 |
GL_RED_MAX_CLAMP_INGR | GLScene.OpenGL4 |
GL_RED_MIN_CLAMP_INGR | GLScene.OpenGL4 | GL_INGR_color_clamp
GL_RED_SCALE | GLScene.OpenGL4 |
GL_RED_SNORM | GLScene.OpenGL4 |
GL_REFERENCED_BY_COMPUTE_SHADER | GLScene.OpenGL4 |
GL_REFERENCED_BY_FRAGMENT_SHADER | GLScene.OpenGL4 |
GL_REFERENCED_BY_GEOMETRY_SHADER | GLScene.OpenGL4 |
GL_REFERENCED_BY_TESS_CONTROL_SHADER | GLScene.OpenGL4 |
GL_REFERENCED_BY_TESS_EVALUATION_SHADER | GLScene.OpenGL4 |
GL_REFERENCED_BY_VERTEX_SHADER | GLScene.OpenGL4 |
GL_REFERENCE_PLANE_EQUATION_SGIX | GLScene.OpenGL4 |
GL_REFERENCE_PLANE_SGIX | GLScene.OpenGL4 | GL_SGIX_reference_plane
GL_REFLECTION_MAP | GLScene.OpenGL4 |
GL_REFLECTION_MAP_ARB | GLScene.OpenGL4 |
GL_REFLECTION_MAP_EXT | GLScene.OpenGL4 |
GL_REFLECTION_MAP_NV | GLScene.OpenGL4 |
GL_REGISTER_COMBINERS_NV | GLScene.OpenGL4 | GL_NV_register_combiners
GL_REG_0_ATI | GLScene.OpenGL4 |
GL_REG_10_ATI | GLScene.OpenGL4 |
GL_REG_11_ATI | GLScene.OpenGL4 |
GL_REG_12_ATI | GLScene.OpenGL4 |
GL_REG_13_ATI | GLScene.OpenGL4 |
GL_REG_14_ATI | GLScene.OpenGL4 |
GL_REG_15_ATI | GLScene.OpenGL4 |
GL_REG_16_ATI | GLScene.OpenGL4 |
GL_REG_17_ATI | GLScene.OpenGL4 |
GL_REG_18_ATI | GLScene.OpenGL4 |
GL_REG_19_ATI | GLScene.OpenGL4 |
GL_REG_1_ATI | GLScene.OpenGL4 |
GL_REG_20_ATI | GLScene.OpenGL4 |
GL_REG_21_ATI | GLScene.OpenGL4 |
GL_REG_22_ATI | GLScene.OpenGL4 |
GL_REG_23_ATI | GLScene.OpenGL4 |
GL_REG_24_ATI | GLScene.OpenGL4 |
GL_REG_25_ATI | GLScene.OpenGL4 |
GL_REG_26_ATI | GLScene.OpenGL4 |
GL_REG_27_ATI | GLScene.OpenGL4 |
GL_REG_28_ATI | GLScene.OpenGL4 |
GL_REG_29_ATI | GLScene.OpenGL4 |
GL_REG_2_ATI | GLScene.OpenGL4 |
GL_REG_30_ATI | GLScene.OpenGL4 |
GL_REG_31_ATI | GLScene.OpenGL4 |
GL_REG_3_ATI | GLScene.OpenGL4 |
GL_REG_4_ATI | GLScene.OpenGL4 |
GL_REG_5_ATI | GLScene.OpenGL4 |
GL_REG_6_ATI | GLScene.OpenGL4 |
GL_REG_7_ATI | GLScene.OpenGL4 |
GL_REG_8_ATI | GLScene.OpenGL4 |
GL_REG_9_ATI | GLScene.OpenGL4 |
GL_RELATIVE_ARC_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_HORIZONTAL_LINE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_LARGE_CCW_ARC_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_LARGE_CW_ARC_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_LINE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_MOVE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_QUADRATIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_SMALL_CCW_ARC_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_SMALL_CW_ARC_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_RELATIVE_VERTICAL_LINE_TO_NV | GLScene.OpenGL4 |
GL_RELEASED_APPLE | GLScene.OpenGL4 |
GL_RENDER | GLScene.OpenGL4 |
GL_RENDERBUFFER | GLScene.OpenGL4 |
GL_RENDERBUFFER_ALPHA_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_BINDING | GLScene.OpenGL4 |
GL_RENDERBUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_RENDERBUFFER_BLUE_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_COLOR_SAMPLES_NV | GLScene.OpenGL4 |
GL_RENDERBUFFER_COVERAGE_SAMPLES_NV | GLScene.OpenGL4 | GL_NV_framebuffer_multisample_coverage
GL_RENDERBUFFER_DEPTH_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_EXT | GLScene.OpenGL4 |
GL_RENDERBUFFER_FREE_MEMORY_ATI | GLScene.OpenGL4 |
GL_RENDERBUFFER_GREEN_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_HEIGHT | GLScene.OpenGL4 |
GL_RENDERBUFFER_HEIGHT_EXT | GLScene.OpenGL4 |
GL_RENDERBUFFER_INTERNAL_FORMAT | GLScene.OpenGL4 |
GL_RENDERBUFFER_INTERNAL_FORMAT_EXT | GLScene.OpenGL4 |
GL_RENDERBUFFER_RED_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_SAMPLES | GLScene.OpenGL4 |
GL_RENDERBUFFER_SAMPLES_EXT | GLScene.OpenGL4 | GL_EXT_framebuffer_multisample
GL_RENDERBUFFER_STENCIL_SIZE | GLScene.OpenGL4 |
GL_RENDERBUFFER_WIDTH | GLScene.OpenGL4 |
GL_RENDERBUFFER_WIDTH_EXT | GLScene.OpenGL4 |
GL_RENDERER | GLScene.OpenGL4 |
GL_RENDER_MODE | GLScene.OpenGL4 |
GL_REPEAT | GLScene.OpenGL4 | TextureWrapMode
GL_REPLACE | GLScene.OpenGL4 |
GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN | GLScene.OpenGL4 |
GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN | GLScene.OpenGL4 |
GL_REPLACEMENT_CODE_ARRAY_SUN | GLScene.OpenGL4 |
GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN | GLScene.OpenGL4 |
GL_REPLACEMENT_CODE_SUN | GLScene.OpenGL4 |
GL_REPLACE_EXT | GLScene.OpenGL4 |
GL_REPLACE_MIDDLE_SUN | GLScene.OpenGL4 |
GL_REPLACE_OLDEST_SUN | GLScene.OpenGL4 |
GL_REPLACE_VALUE_AMD | GLScene.OpenGL4 |
GL_REPLICATE_BORDER | GLScene.OpenGL4 |
GL_REPLICATE_BORDER_HP | GLScene.OpenGL4 |
GL_RESAMPLE_AVERAGE_OML | GLScene.OpenGL4 |
GL_RESAMPLE_DECIMATE_OML | GLScene.OpenGL4 |
GL_RESAMPLE_DECIMATE_SGIX | GLScene.OpenGL4 |
GL_RESAMPLE_REPLICATE_OML | GLScene.OpenGL4 |
GL_RESAMPLE_REPLICATE_SGIX | GLScene.OpenGL4 |
GL_RESAMPLE_ZERO_FILL_OML | GLScene.OpenGL4 |
GL_RESAMPLE_ZERO_FILL_SGIX | GLScene.OpenGL4 |
GL_RESCALE_NORMAL | GLScene.OpenGL4 |
GL_RESCALE_NORMAL_EXT | GLScene.OpenGL4 | GL_EXT_rescale_normal
GL_RESET_NOTIFICATION_STRATEGY | GLScene.OpenGL4 |
GL_RESET_NOTIFICATION_STRATEGY_ARB | GLScene.OpenGL4 |
GL_RESTART_PATH_NV | GLScene.OpenGL4 |
GL_RESTART_SUN | GLScene.OpenGL4 | GL_SUN_triangle_list
GL_RETAINED_APPLE | GLScene.OpenGL4 |
GL_RETURN | GLScene.OpenGL4 |
GL_RG | GLScene.OpenGL4 | GL_ARB_texture_rg
GL_RG16 | GLScene.OpenGL4 |
GL_RG16F | GLScene.OpenGL4 |
GL_RG16I | GLScene.OpenGL4 |
GL_RG16UI | GLScene.OpenGL4 |
GL_RG16_SNORM | GLScene.OpenGL4 |
GL_RG32F | GLScene.OpenGL4 |
GL_RG32I | GLScene.OpenGL4 |
GL_RG32UI | GLScene.OpenGL4 |
GL_RG8 | GLScene.OpenGL4 |
GL_RG8I | GLScene.OpenGL4 |
GL_RG8UI | GLScene.OpenGL4 |
GL_RG8_SNORM | GLScene.OpenGL4 |
GL_RGB | GLScene.OpenGL4 |
GL_RGB10 | GLScene.OpenGL4 |
GL_RGB10_A2 | GLScene.OpenGL4 |
GL_RGB10_A2UI | GLScene.OpenGL4 | GL_ARB_texture_rgb10_a2ui
GL_RGB10_A2_EXT | GLScene.OpenGL4 |
GL_RGB10_EXT | GLScene.OpenGL4 |
GL_RGB12 | GLScene.OpenGL4 |
GL_RGB12_EXT | GLScene.OpenGL4 |
GL_RGB16 | GLScene.OpenGL4 |
GL_RGB16F | GLScene.OpenGL4 |
GL_RGB16F_ARB | GLScene.OpenGL4 |
GL_RGB16I | GLScene.OpenGL4 |
GL_RGB16I_EXT | GLScene.OpenGL4 |
GL_RGB16UI | GLScene.OpenGL4 |
GL_RGB16UI_EXT | GLScene.OpenGL4 |
GL_RGB16_EXT | GLScene.OpenGL4 |
GL_RGB16_SNORM | GLScene.OpenGL4 |
GL_RGB2_EXT | GLScene.OpenGL4 |
GL_RGB32F | GLScene.OpenGL4 |
GL_RGB32F_ARB | GLScene.OpenGL4 |
GL_RGB32I | GLScene.OpenGL4 |
GL_RGB32I_EXT | GLScene.OpenGL4 |
GL_RGB32UI | GLScene.OpenGL4 |
GL_RGB32UI_EXT | GLScene.OpenGL4 |
GL_RGB4 | GLScene.OpenGL4 |
GL_RGB4_EXT | GLScene.OpenGL4 |
GL_RGB4_S3TC | GLScene.OpenGL4 |
GL_RGB5 | GLScene.OpenGL4 |
GL_RGB565 | GLScene.OpenGL4 |
GL_RGB5_A1 | GLScene.OpenGL4 |
GL_RGB5_A1_EXT | GLScene.OpenGL4 |
GL_RGB5_EXT | GLScene.OpenGL4 |
GL_RGB8 | GLScene.OpenGL4 |
GL_RGB8I | GLScene.OpenGL4 |
GL_RGB8I_EXT | GLScene.OpenGL4 |
GL_RGB8UI | GLScene.OpenGL4 |
GL_RGB8UI_EXT | GLScene.OpenGL4 |
GL_RGB8_EXT | GLScene.OpenGL4 |
GL_RGB8_SNORM | GLScene.OpenGL4 |
GL_RGB9_E5 | GLScene.OpenGL4 |
GL_RGB9_E5_EXT | GLScene.OpenGL4 | GL_EXT_texture_shared_exponent
GL_RGBA | GLScene.OpenGL4 |
GL_RGBA12 | GLScene.OpenGL4 |
GL_RGBA12_EXT | GLScene.OpenGL4 |
GL_RGBA16 | GLScene.OpenGL4 |
GL_RGBA16F | GLScene.OpenGL4 |
GL_RGBA16F_ARB | GLScene.OpenGL4 |
GL_RGBA16I | GLScene.OpenGL4 |
GL_RGBA16I_EXT | GLScene.OpenGL4 |
GL_RGBA16UI | GLScene.OpenGL4 |
GL_RGBA16UI_EXT | GLScene.OpenGL4 |
GL_RGBA16_EXT | GLScene.OpenGL4 |
GL_RGBA16_SNORM | GLScene.OpenGL4 |
GL_RGBA2 | GLScene.OpenGL4 |
GL_RGBA2_EXT | GLScene.OpenGL4 |
GL_RGBA32F | GLScene.OpenGL4 |
GL_RGBA32F_ARB | GLScene.OpenGL4 |
GL_RGBA32I | GLScene.OpenGL4 |
GL_RGBA32I_EXT | GLScene.OpenGL4 |
GL_RGBA32UI | GLScene.OpenGL4 |
GL_RGBA32UI_EXT | GLScene.OpenGL4 |
GL_RGBA4 | GLScene.OpenGL4 |
GL_RGBA4_EXT | GLScene.OpenGL4 |
GL_RGBA4_S3TC | GLScene.OpenGL4 |
GL_RGBA8 | GLScene.OpenGL4 |
GL_RGBA8I | GLScene.OpenGL4 |
GL_RGBA8I_EXT | GLScene.OpenGL4 |
GL_RGBA8UI | GLScene.OpenGL4 |
GL_RGBA8UI_EXT | GLScene.OpenGL4 |
GL_RGBA8_EXT | GLScene.OpenGL4 |
GL_RGBA8_SNORM | GLScene.OpenGL4 |
GL_RGBA_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_RGBA_FLOAT16_ATI | GLScene.OpenGL4 |
GL_RGBA_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_RGBA_FLOAT32_ATI | GLScene.OpenGL4 | GL_ATI_texture_float
GL_RGBA_FLOAT_MODE_ARB | GLScene.OpenGL4 | GL_ARB_color_buffer_float
GL_RGBA_INTEGER | GLScene.OpenGL4 |
GL_RGBA_INTEGER_EXT | GLScene.OpenGL4 |
GL_RGBA_INTEGER_MODE_EXT | GLScene.OpenGL4 | GL_EXT_texture_integer
GL_RGBA_MODE | GLScene.OpenGL4 |
GL_RGBA_S3TC | GLScene.OpenGL4 |
GL_RGBA_SNORM | GLScene.OpenGL4 |
GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV | GLScene.OpenGL4 |
GL_RGB_FLOAT16_APPLE | GLScene.OpenGL4 |
GL_RGB_FLOAT16_ATI | GLScene.OpenGL4 |
GL_RGB_FLOAT32_APPLE | GLScene.OpenGL4 |
GL_RGB_FLOAT32_ATI | GLScene.OpenGL4 |
GL_RGB_INTEGER | GLScene.OpenGL4 |
GL_RGB_INTEGER_EXT | GLScene.OpenGL4 |
GL_RGB_RAW_422_APPLE | GLScene.OpenGL4 |
GL_RGB_S3TC | GLScene.OpenGL4 | GL_S3_s3tc
GL_RGB_SCALE | GLScene.OpenGL4 |
GL_RGB_SCALE_ARB | GLScene.OpenGL4 |
GL_RGB_SCALE_EXT | GLScene.OpenGL4 |
GL_RGB_SNORM | GLScene.OpenGL4 |
GL_RG_INTEGER | GLScene.OpenGL4 |
GL_RG_SNORM | GLScene.OpenGL4 |
GL_RIGHT | GLScene.OpenGL4 |
GL_ROUND_NV | GLScene.OpenGL4 |
GL_S | GLScene.OpenGL4 |
GL_SAMPLER | GLScene.OpenGL4 |
GL_SAMPLER_1D | GLScene.OpenGL4 |
GL_SAMPLER_1D_ARB | GLScene.OpenGL4 |
GL_SAMPLER_1D_ARRAY | GLScene.OpenGL4 |
GL_SAMPLER_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_SAMPLER_1D_ARRAY_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_1D_ARRAY_SHADOW_EXT | GLScene.OpenGL4 |
GL_SAMPLER_1D_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_1D_SHADOW_ARB | GLScene.OpenGL4 |
GL_SAMPLER_2D | GLScene.OpenGL4 |
GL_SAMPLER_2D_ARB | GLScene.OpenGL4 |
GL_SAMPLER_2D_ARRAY | GLScene.OpenGL4 |
GL_SAMPLER_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_SAMPLER_2D_ARRAY_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_2D_ARRAY_SHADOW_EXT | GLScene.OpenGL4 |
GL_SAMPLER_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_SAMPLER_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_SAMPLER_2D_RECT | GLScene.OpenGL4 | GL_VERSION_3_1
GL_SAMPLER_2D_RECT_ARB | GLScene.OpenGL4 |
GL_SAMPLER_2D_RECT_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_2D_RECT_SHADOW_ARB | GLScene.OpenGL4 |
GL_SAMPLER_2D_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_2D_SHADOW_ARB | GLScene.OpenGL4 |
GL_SAMPLER_3D | GLScene.OpenGL4 |
GL_SAMPLER_3D_ARB | GLScene.OpenGL4 |
GL_SAMPLER_BINDING | GLScene.OpenGL4 | GL_ARB_sampler_objects
GL_SAMPLER_BUFFER | GLScene.OpenGL4 |
GL_SAMPLER_BUFFER_AMD | GLScene.OpenGL4 | GL_AMD_vertex_shader_tesselator
GL_SAMPLER_BUFFER_EXT | GLScene.OpenGL4 |
GL_SAMPLER_CUBE | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_ARB | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_SHADOW | GLScene.OpenGL4 |
GL_SAMPLER_CUBE_SHADOW_EXT | GLScene.OpenGL4 |
GL_SAMPLER_OBJECT_AMD | GLScene.OpenGL4 |
GL_SAMPLER_RENDERBUFFER_NV | GLScene.OpenGL4 |
GL_SAMPLES | GLScene.OpenGL4 |
GL_SAMPLES_3DFX | GLScene.OpenGL4 |
GL_SAMPLES_ARB | GLScene.OpenGL4 |
GL_SAMPLES_EXT | GLScene.OpenGL4 |
GL_SAMPLES_PASSED | GLScene.OpenGL4 |
GL_SAMPLES_PASSED_ARB | GLScene.OpenGL4 | 1.4 GL_ARB_occlusion_query
GL_SAMPLES_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_COVERAGE | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_COVERAGE_ARB | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_MASK_EXT | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_MASK_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_ONE | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_ONE_ARB | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_ONE_EXT | GLScene.OpenGL4 |
GL_SAMPLE_ALPHA_TO_ONE_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_BUFFERS | GLScene.OpenGL4 |
GL_SAMPLE_BUFFERS_3DFX | GLScene.OpenGL4 |
GL_SAMPLE_BUFFERS_ARB | GLScene.OpenGL4 |
GL_SAMPLE_BUFFERS_EXT | GLScene.OpenGL4 |
GL_SAMPLE_BUFFERS_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE_ARB | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE_INVERT | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE_INVERT_ARB | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE_VALUE | GLScene.OpenGL4 |
GL_SAMPLE_COVERAGE_VALUE_ARB | GLScene.OpenGL4 |
GL_SAMPLE_LOCATION_ARB | GLScene.OpenGL4 |
GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB | GLScene.OpenGL4 |
GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB | GLScene.OpenGL4 |
GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB | GLScene.OpenGL4 | GL_ARB_sample_locations
GL_SAMPLE_MASK | GLScene.OpenGL4 |
GL_SAMPLE_MASK_EXT | GLScene.OpenGL4 |
GL_SAMPLE_MASK_INVERT_EXT | GLScene.OpenGL4 |
GL_SAMPLE_MASK_INVERT_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_MASK_NV | GLScene.OpenGL4 |
GL_SAMPLE_MASK_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_MASK_VALUE | GLScene.OpenGL4 |
GL_SAMPLE_MASK_VALUE_EXT | GLScene.OpenGL4 |
GL_SAMPLE_MASK_VALUE_NV | GLScene.OpenGL4 |
GL_SAMPLE_MASK_VALUE_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_PATTERN_EXT | GLScene.OpenGL4 |
GL_SAMPLE_PATTERN_SGIS | GLScene.OpenGL4 |
GL_SAMPLE_POSITION | GLScene.OpenGL4 | GL_ARB_texture_multisample
GL_SAMPLE_POSITION_NV | GLScene.OpenGL4 | GL_NV_explicit_multisample
GL_SAMPLE_SHADING | GLScene.OpenGL4 | GL_VERSION_4_0
GL_SAMPLE_SHADING_ARB | GLScene.OpenGL4 | GL_ARB_sample_shading
GL_SATURATE_BIT_ATI | GLScene.OpenGL4 |
GL_SCALAR_EXT | GLScene.OpenGL4 |
GL_SCALEBIAS_HINT_SGIX | GLScene.OpenGL4 | GL_SGIX_scalebias_hint
GL_SCALED_RESOLVE_FASTEST_EXT | GLScene.OpenGL4 | GL_EXT_framebuffer_multisample_blit_scaled
GL_SCALED_RESOLVE_NICEST_EXT | GLScene.OpenGL4 |
GL_SCALE_BY_FOUR_NV | GLScene.OpenGL4 |
GL_SCALE_BY_ONE_HALF_NV | GLScene.OpenGL4 |
GL_SCALE_BY_TWO_NV | GLScene.OpenGL4 |
GL_SCISSOR_BIT | GLScene.OpenGL4 |
GL_SCISSOR_BOX | GLScene.OpenGL4 |
GL_SCISSOR_TEST | GLScene.OpenGL4 |
GL_SCREEN_COORDINATES_REND | GLScene.OpenGL4 | GL_REND_screen_coordinates
GL_SCREEN_KHR | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_EXT | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_POINTER | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_SIZE | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_SIZE_EXT | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_TYPE | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_SECONDARY_COLOR_NV | GLScene.OpenGL4 |
GL_SECONDARY_INTERPOLATOR_ATI | GLScene.OpenGL4 |
GL_SELECT | GLScene.OpenGL4 |
GL_SELECTION_BUFFER_POINTER | GLScene.OpenGL4 |
GL_SELECTION_BUFFER_SIZE | GLScene.OpenGL4 |
GL_SEPARABLE_2D | GLScene.OpenGL4 |
GL_SEPARABLE_2D_EXT | GLScene.OpenGL4 |
GL_SEPARATE_ATTRIBS | GLScene.OpenGL4 |
GL_SEPARATE_ATTRIBS_EXT | GLScene.OpenGL4 |
GL_SEPARATE_ATTRIBS_NV | GLScene.OpenGL4 |
GL_SEPARATE_SPECULAR_COLOR | GLScene.OpenGL4 |
GL_SEPARATE_SPECULAR_COLOR_EXT | GLScene.OpenGL4 |
GL_SET | GLScene.OpenGL4 |
GL_SET_AMD | GLScene.OpenGL4 | (4.3) GL_AMD_stencil_operation_extended
GL_SHADER | GLScene.OpenGL4 |
GL_SHADER_BINARY_FORMAT_SPIR_V | GLScene.OpenGL4 | 4.6
GL_SHADER_BINARY_FORMAT_SPIR_V_ARB | GLScene.OpenGL4 | GL_ARB_gl_spirv
GL_SHADER_COMPILER | GLScene.OpenGL4 |
GL_SHADER_CONSISTENT_NV | GLScene.OpenGL4 |
GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV | GLScene.OpenGL4 | GL_NV_shader_buffer_store
GL_SHADER_IMAGE_ACCESS_BARRIER_BIT | GLScene.OpenGL4 |
GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_SHADER_IMAGE_ATOMIC | GLScene.OpenGL4 |
GL_SHADER_IMAGE_LOAD | GLScene.OpenGL4 |
GL_SHADER_IMAGE_STORE | GLScene.OpenGL4 |
GL_SHADER_INCLUDE_ARB | GLScene.OpenGL4 | GL_ARB_shading_language_include
GL_SHADER_OBJECT_ARB | GLScene.OpenGL4 |
GL_SHADER_OPERATION_NV | GLScene.OpenGL4 |
GL_SHADER_SOURCE_LENGTH | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BARRIER_BIT | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BLOCK | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BUFFER | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BUFFER_BINDING | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BUFFER_SIZE | GLScene.OpenGL4 |
GL_SHADER_STORAGE_BUFFER_START | GLScene.OpenGL4 |
GL_SHADER_TYPE | GLScene.OpenGL4 |
GL_SHADE_MODEL | GLScene.OpenGL4 |
GL_SHADING_LANGUAGE_VERSION | GLScene.OpenGL4 |
GL_SHADING_LANGUAGE_VERSION_ARB | GLScene.OpenGL4 | GL_ARB_shading_language_100
GL_SHADOW_AMBIENT_SGIX | GLScene.OpenGL4 | GL_SGIX_shadow_ambient
GL_SHADOW_ATTENUATION_EXT | GLScene.OpenGL4 |
GL_SHARED_TEXTURE_PALETTE_EXT | GLScene.OpenGL4 | GL_EXT_shared_texture_palette
GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS | GLScene.OpenGL4 |
GL_SHININESS | GLScene.OpenGL4 |
GL_SHORT | GLScene.OpenGL4 |
GL_SIGNALED | GLScene.OpenGL4 |
GL_SIGNED_ALPHA8_NV | GLScene.OpenGL4 |
GL_SIGNED_ALPHA_NV | GLScene.OpenGL4 |
GL_SIGNED_HILO16_NV | GLScene.OpenGL4 |
GL_SIGNED_HILO8_NV | GLScene.OpenGL4 |
GL_SIGNED_HILO_NV | GLScene.OpenGL4 |
GL_SIGNED_IDENTITY_NV | GLScene.OpenGL4 |
GL_SIGNED_INTENSITY8_NV | GLScene.OpenGL4 |
GL_SIGNED_INTENSITY_NV | GLScene.OpenGL4 |
GL_SIGNED_LUMINANCE8_ALPHA8_NV | GLScene.OpenGL4 |
GL_SIGNED_LUMINANCE8_NV | GLScene.OpenGL4 |
GL_SIGNED_LUMINANCE_ALPHA_NV | GLScene.OpenGL4 |
GL_SIGNED_LUMINANCE_NV | GLScene.OpenGL4 |
GL_SIGNED_NEGATE_NV | GLScene.OpenGL4 |
GL_SIGNED_NORMALIZED | GLScene.OpenGL4 |
GL_SIGNED_RGB8_NV | GLScene.OpenGL4 |
GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV | GLScene.OpenGL4 |
GL_SIGNED_RGBA8_NV | GLScene.OpenGL4 |
GL_SIGNED_RGBA_NV | GLScene.OpenGL4 |
GL_SIGNED_RGB_NV | GLScene.OpenGL4 |
GL_SIGNED_RGB_UNSIGNED_ALPHA_NV | GLScene.OpenGL4 |
GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST | GLScene.OpenGL4 |
GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE | GLScene.OpenGL4 |
GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST | GLScene.OpenGL4 |
GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE | GLScene.OpenGL4 |
GL_SINGLE_COLOR | GLScene.OpenGL4 |
GL_SINGLE_COLOR_EXT | GLScene.OpenGL4 |
GL_SKIP_COMPONENTS1_NV | GLScene.OpenGL4 |
GL_SKIP_COMPONENTS2_NV | GLScene.OpenGL4 |
GL_SKIP_COMPONENTS3_NV | GLScene.OpenGL4 |
GL_SKIP_COMPONENTS4_NV | GLScene.OpenGL4 |
GL_SKIP_DECODE_EXT | GLScene.OpenGL4 |
GL_SKIP_MISSING_GLYPH_NV | GLScene.OpenGL4 |
GL_SLICE_ACCUM_SUN | GLScene.OpenGL4 | GL_SUN_slice_accum
GL_SLUMINANCE | GLScene.OpenGL4 |
GL_SLUMINANCE8 | GLScene.OpenGL4 |
GL_SLUMINANCE8_ALPHA8 | GLScene.OpenGL4 |
GL_SLUMINANCE8_ALPHA8_EXT | GLScene.OpenGL4 |
GL_SLUMINANCE8_EXT | GLScene.OpenGL4 |
GL_SLUMINANCE_ALPHA | GLScene.OpenGL4 |
GL_SLUMINANCE_ALPHA_EXT | GLScene.OpenGL4 |
GL_SLUMINANCE_EXT | GLScene.OpenGL4 |
GL_SMALL_CCW_ARC_TO_NV | GLScene.OpenGL4 |
GL_SMALL_CW_ARC_TO_NV | GLScene.OpenGL4 |
GL_SMOOTH | GLScene.OpenGL4 |
GL_SMOOTH_CUBIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_SMOOTH_LINE_WIDTH_GRANULARITY | GLScene.OpenGL4 |
GL_SMOOTH_LINE_WIDTH_RANGE | GLScene.OpenGL4 |
GL_SMOOTH_POINT_SIZE_GRANULARITY | GLScene.OpenGL4 |
GL_SMOOTH_POINT_SIZE_RANGE | GLScene.OpenGL4 |
GL_SMOOTH_QUADRATIC_CURVE_TO_NV | GLScene.OpenGL4 |
GL_SOFTLIGHT_KHR | GLScene.OpenGL4 |
GL_SOURCE0_ALPHA | GLScene.OpenGL4 |
GL_SOURCE0_ALPHA_ARB | GLScene.OpenGL4 |
GL_SOURCE0_ALPHA_EXT | GLScene.OpenGL4 |
GL_SOURCE0_RGB | GLScene.OpenGL4 |
GL_SOURCE0_RGB_ARB | GLScene.OpenGL4 |
GL_SOURCE0_RGB_EXT | GLScene.OpenGL4 |
GL_SOURCE1_ALPHA | GLScene.OpenGL4 |
GL_SOURCE1_ALPHA_ARB | GLScene.OpenGL4 |
GL_SOURCE1_ALPHA_EXT | GLScene.OpenGL4 |
GL_SOURCE1_RGB | GLScene.OpenGL4 |
GL_SOURCE1_RGB_ARB | GLScene.OpenGL4 |
GL_SOURCE1_RGB_EXT | GLScene.OpenGL4 |
GL_SOURCE2_ALPHA | GLScene.OpenGL4 |
GL_SOURCE2_ALPHA_ARB | GLScene.OpenGL4 |
GL_SOURCE2_ALPHA_EXT | GLScene.OpenGL4 |
GL_SOURCE2_RGB | GLScene.OpenGL4 |
GL_SOURCE2_RGB_ARB | GLScene.OpenGL4 |
GL_SOURCE2_RGB_EXT | GLScene.OpenGL4 |
GL_SOURCE3_ALPHA_NV | GLScene.OpenGL4 |
GL_SOURCE3_RGB_NV | GLScene.OpenGL4 |
GL_SPARE0_NV | GLScene.OpenGL4 |
GL_SPARE0_PLUS_SECONDARY_COLOR_NV | GLScene.OpenGL4 |
GL_SPARE1_NV | GLScene.OpenGL4 |
GL_SPARSE_BUFFER_PAGE_SIZE_ARB | GLScene.OpenGL4 |
GL_SPARSE_STORAGE_BIT_ARB | GLScene.OpenGL4 | GL_ARB_sparse_buffer
GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB | GLScene.OpenGL4 |
GL_SPECULAR | GLScene.OpenGL4 |
GL_SPHERE_MAP | GLScene.OpenGL4 |
GL_SPIR_V_BINARY | GLScene.OpenGL4 |
GL_SPIR_V_BINARY_ARB | GLScene.OpenGL4 |
GL_SPIR_V_EXTENSIONS | GLScene.OpenGL4 |
GL_SPOT_CUTOFF | GLScene.OpenGL4 |
GL_SPOT_DIRECTION | GLScene.OpenGL4 |
GL_SPOT_EXPONENT | GLScene.OpenGL4 |
GL_SPRITE_AXIAL_SGIX | GLScene.OpenGL4 |
GL_SPRITE_AXIS_SGIX | GLScene.OpenGL4 |
GL_SPRITE_EYE_ALIGNED_SGIX | GLScene.OpenGL4 |
GL_SPRITE_MODE_SGIX | GLScene.OpenGL4 |
GL_SPRITE_OBJECT_ALIGNED_SGIX | GLScene.OpenGL4 |
GL_SPRITE_SGIX | GLScene.OpenGL4 | GL_SGIX_sprite
GL_SPRITE_TRANSLATION_SGIX | GLScene.OpenGL4 |
GL_SQUARE_NV | GLScene.OpenGL4 |
GL_SRC0_ALPHA | GLScene.OpenGL4 |
GL_SRC0_RGB | GLScene.OpenGL4 |
GL_SRC1_ALPHA | GLScene.OpenGL4 |
GL_SRC1_COLOR | GLScene.OpenGL4 | GL_ARB_blend_func_extended
GL_SRC1_RGB | GLScene.OpenGL4 |
GL_SRC2_ALPHA | GLScene.OpenGL4 |
GL_SRC2_RGB | GLScene.OpenGL4 |
GL_SRC_ALPHA | GLScene.OpenGL4 |
GL_SRC_ALPHA_SATURATE | GLScene.OpenGL4 |
GL_SRC_COLOR | GLScene.OpenGL4 |
GL_SRGB | GLScene.OpenGL4 |
GL_SRGB8 | GLScene.OpenGL4 |
GL_SRGB8_ALPHA8 | GLScene.OpenGL4 |
GL_SRGB8_ALPHA8_EXT | GLScene.OpenGL4 |
GL_SRGB8_EXT | GLScene.OpenGL4 |
GL_SRGB_ALPHA | GLScene.OpenGL4 |
GL_SRGB_ALPHA_EXT | GLScene.OpenGL4 |
GL_SRGB_DECODE_ARB | GLScene.OpenGL4 |
GL_SRGB_EXT | GLScene.OpenGL4 | GL_EXT_texture_sRGB
GL_SRGB_READ | GLScene.OpenGL4 |
GL_SRGB_WRITE | GLScene.OpenGL4 |
GL_STACK_OVERFLOW | GLScene.OpenGL4 |
GL_STACK_UNDERFLOW | GLScene.OpenGL4 |
GL_STANDARD_FONT_NAME_NV | GLScene.OpenGL4 |
GL_STATIC_ATI | GLScene.OpenGL4 | GL_ATI_vertex_array_object
GL_STATIC_COPY | GLScene.OpenGL4 |
GL_STATIC_COPY_ARB | GLScene.OpenGL4 |
GL_STATIC_DRAW | GLScene.OpenGL4 |
GL_STATIC_DRAW_ARB | GLScene.OpenGL4 |
GL_STATIC_READ | GLScene.OpenGL4 |
GL_STATIC_READ_ARB | GLScene.OpenGL4 |
GL_STENCIL | GLScene.OpenGL4 |
GL_STENCIL_ATTACHMENT | GLScene.OpenGL4 |
GL_STENCIL_ATTACHMENT_EXT | GLScene.OpenGL4 |
GL_STENCIL_BACK_FAIL | GLScene.OpenGL4 |
GL_STENCIL_BACK_FAIL_ATI | GLScene.OpenGL4 |
GL_STENCIL_BACK_FUNC | GLScene.OpenGL4 |
GL_STENCIL_BACK_FUNC_ATI | GLScene.OpenGL4 | GL_ATI_separate_stencil
GL_STENCIL_BACK_OP_VALUE_AMD | GLScene.OpenGL4 |
GL_STENCIL_BACK_PASS_DEPTH_FAIL | GLScene.OpenGL4 |
GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI | GLScene.OpenGL4 |
GL_STENCIL_BACK_PASS_DEPTH_PASS | GLScene.OpenGL4 |
GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI | GLScene.OpenGL4 |
GL_STENCIL_BACK_REF | GLScene.OpenGL4 |
GL_STENCIL_BACK_VALUE_MASK | GLScene.OpenGL4 |
GL_STENCIL_BACK_WRITEMASK | GLScene.OpenGL4 |
GL_STENCIL_BITS | GLScene.OpenGL4 |
GL_STENCIL_BUFFER | GLScene.OpenGL4 |
GL_STENCIL_BUFFER_BIT | GLScene.OpenGL4 |
GL_STENCIL_CLEAR_TAG_VALUE_EXT | GLScene.OpenGL4 |
GL_STENCIL_CLEAR_VALUE | GLScene.OpenGL4 |
GL_STENCIL_COMPONENTS | GLScene.OpenGL4 |
GL_STENCIL_FAIL | GLScene.OpenGL4 |
GL_STENCIL_FUNC | GLScene.OpenGL4 |
GL_STENCIL_INDEX | GLScene.OpenGL4 | PixelFormat
GL_STENCIL_INDEX1 | GLScene.OpenGL4 |
GL_STENCIL_INDEX16 | GLScene.OpenGL4 |
GL_STENCIL_INDEX16_EXT | GLScene.OpenGL4 |
GL_STENCIL_INDEX1_EXT | GLScene.OpenGL4 |
GL_STENCIL_INDEX4 | GLScene.OpenGL4 |
GL_STENCIL_INDEX4_EXT | GLScene.OpenGL4 |
GL_STENCIL_INDEX8 | GLScene.OpenGL4 |
GL_STENCIL_INDEX8_EXT | GLScene.OpenGL4 |
GL_STENCIL_INDEX_EXT | GLScene.OpenGL4 |
GL_STENCIL_OP_VALUE_AMD | GLScene.OpenGL4 |
GL_STENCIL_PASS_DEPTH_FAIL | GLScene.OpenGL4 |
GL_STENCIL_PASS_DEPTH_PASS | GLScene.OpenGL4 |
GL_STENCIL_REF | GLScene.OpenGL4 |
GL_STENCIL_RENDERABLE | GLScene.OpenGL4 |
GL_STENCIL_TAG_BITS_EXT | GLScene.OpenGL4 | GL_EXT_stencil_clear_tag
GL_STENCIL_TEST | GLScene.OpenGL4 |
GL_STENCIL_TEST_TWO_SIDE_EXT | GLScene.OpenGL4 | GL_EXT_stencil_two_side
GL_STENCIL_VALUE_MASK | GLScene.OpenGL4 |
GL_STENCIL_WRITEMASK | GLScene.OpenGL4 |
GL_STEREO | GLScene.OpenGL4 |
GL_STORAGE_CACHED_APPLE | GLScene.OpenGL4 |
GL_STORAGE_CLIENT_APPLE | GLScene.OpenGL4 |
GL_STORAGE_PRIVATE_APPLE | GLScene.OpenGL4 |
GL_STORAGE_SHARED_APPLE | GLScene.OpenGL4 |
GL_STREAM_COPY | GLScene.OpenGL4 |
GL_STREAM_COPY_ARB | GLScene.OpenGL4 |
GL_STREAM_DRAW | GLScene.OpenGL4 |
GL_STREAM_DRAW_ARB | GLScene.OpenGL4 |
GL_STREAM_READ | GLScene.OpenGL4 |
GL_STREAM_READ_ARB | GLScene.OpenGL4 |
GL_STRICT_DEPTHFUNC_HINT_PGI | GLScene.OpenGL4 |
GL_STRICT_LIGHTING_HINT_PGI | GLScene.OpenGL4 |
GL_STRICT_SCISSOR_HINT_PGI | GLScene.OpenGL4 |
GL_SUBPIXEL_BITS | GLScene.OpenGL4 |
GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV | GLScene.OpenGL4 |
GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV | GLScene.OpenGL4 |
GL_SUBSAMPLE_DISTANCE_AMD | GLScene.OpenGL4 | GL_AMD_sample_positions
GL_SUBTRACT | GLScene.OpenGL4 |
GL_SUBTRACT_ARB | GLScene.OpenGL4 |
GL_SUB_ATI | GLScene.OpenGL4 |
GL_SUCCESS_NV | GLScene.OpenGL4 |
GL_SURFACE_MAPPED_NV | GLScene.OpenGL4 |
GL_SURFACE_REGISTERED_NV | GLScene.OpenGL4 |
GL_SURFACE_STATE_NV | GLScene.OpenGL4 | GL_NV_vdpau_interop
GL_SWIZZLE_STQ_ATI | GLScene.OpenGL4 |
GL_SWIZZLE_STQ_DQ_ATI | GLScene.OpenGL4 |
GL_SWIZZLE_STRQ_ATI | GLScene.OpenGL4 |
GL_SWIZZLE_STRQ_DQ_ATI | GLScene.OpenGL4 |
GL_SWIZZLE_STR_ATI | GLScene.OpenGL4 |
GL_SWIZZLE_STR_DR_ATI | GLScene.OpenGL4 |
GL_SYNC_CL_EVENT_ARB | GLScene.OpenGL4 | GL_ARB_cl_event
GL_SYNC_CL_EVENT_COMPLETE_ARB | GLScene.OpenGL4 |
GL_SYNC_CONDITION | GLScene.OpenGL4 |
GL_SYNC_FENCE | GLScene.OpenGL4 |
GL_SYNC_FLAGS | GLScene.OpenGL4 |
GL_SYNC_FLUSH_COMMANDS_BIT | GLScene.OpenGL4 |
GL_SYNC_GPU_COMMANDS_COMPLETE | GLScene.OpenGL4 |
GL_SYNC_STATUS | GLScene.OpenGL4 |
GL_SYNC_X11_FENCE_EXT | GLScene.OpenGL4 | GL_EXT_x11_sync_object
GL_SYSTEM_FONT_NAME_NV | GLScene.OpenGL4 |
GL_T | GLScene.OpenGL4 |
GL_T2F_C3F_V3F | GLScene.OpenGL4 |
GL_T2F_C4F_N3F_V3F | GLScene.OpenGL4 |
GL_T2F_C4UB_V3F | GLScene.OpenGL4 |
GL_T2F_IUI_N3F_V2F_EXT | GLScene.OpenGL4 |
GL_T2F_IUI_N3F_V3F_EXT | GLScene.OpenGL4 |
GL_T2F_IUI_V2F_EXT | GLScene.OpenGL4 |
GL_T2F_IUI_V3F_EXT | GLScene.OpenGL4 |
GL_T2F_N3F_V3F | GLScene.OpenGL4 |
GL_T2F_V3F | GLScene.OpenGL4 |
GL_T4F_C4F_N3F_V4F | GLScene.OpenGL4 |
GL_T4F_V4F | GLScene.OpenGL4 |
GL_TABLE_TOO_LARGE | GLScene.OpenGL4 |
GL_TABLE_TOO_LARGE_EXT | GLScene.OpenGL4 |
GL_TANGENT_ARRAY_EXT | GLScene.OpenGL4 | GL_EXT_coordinate_frame
GL_TANGENT_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_TANGENT_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_TANGENT_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_TESSELLATION_FACTOR_AMD | GLScene.OpenGL4 |
GL_TESSELLATION_MODE_AMD | GLScene.OpenGL4 |
GL_TESS_CONTROL_OUTPUT_VERTICES | GLScene.OpenGL4 |
GL_TESS_CONTROL_PROGRAM_NV | GLScene.OpenGL4 |
GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV | GLScene.OpenGL4 |
GL_TESS_CONTROL_SHADER | GLScene.OpenGL4 |
GL_TESS_CONTROL_SHADER_BIT | GLScene.OpenGL4 |
GL_TESS_CONTROL_SHADER_PATCHES | GLScene.OpenGL4 |
GL_TESS_CONTROL_SHADER_PATCHES_ARB | GLScene.OpenGL4 |
GL_TESS_CONTROL_SUBROUTINE | GLScene.OpenGL4 |
GL_TESS_CONTROL_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_TESS_CONTROL_TEXTURE | GLScene.OpenGL4 |
GL_TESS_EVALUATION_PROGRAM_NV | GLScene.OpenGL4 |
GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SHADER | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SHADER_BIT | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SHADER_INVOCATIONS | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SUBROUTINE | GLScene.OpenGL4 |
GL_TESS_EVALUATION_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_TESS_EVALUATION_TEXTURE | GLScene.OpenGL4 |
GL_TESS_GEN_MODE | GLScene.OpenGL4 |
GL_TESS_GEN_POINT_MODE | GLScene.OpenGL4 |
GL_TESS_GEN_SPACING | GLScene.OpenGL4 |
GL_TESS_GEN_VERTEX_ORDER | GLScene.OpenGL4 |
GL_TEXCOORD1_BIT_PGI | GLScene.OpenGL4 |
GL_TEXCOORD2_BIT_PGI | GLScene.OpenGL4 |
GL_TEXCOORD3_BIT_PGI | GLScene.OpenGL4 |
GL_TEXCOORD4_BIT_PGI | GLScene.OpenGL4 |
GL_TEXTURE | GLScene.OpenGL4 | MatrixMode (for gl3.h, FBO attachment type)
GL_TEXTURE0 | GLScene.OpenGL4 | GL_VERSION_1_3
GL_TEXTURE0_ARB | GLScene.OpenGL4 | GL_ARB_multitexture
GL_TEXTURE1 | GLScene.OpenGL4 |
GL_TEXTURE10 | GLScene.OpenGL4 |
GL_TEXTURE10_ARB | GLScene.OpenGL4 |
GL_TEXTURE11 | GLScene.OpenGL4 |
GL_TEXTURE11_ARB | GLScene.OpenGL4 |
GL_TEXTURE12 | GLScene.OpenGL4 |
GL_TEXTURE12_ARB | GLScene.OpenGL4 |
GL_TEXTURE13 | GLScene.OpenGL4 |
GL_TEXTURE13_ARB | GLScene.OpenGL4 |
GL_TEXTURE14 | GLScene.OpenGL4 |
GL_TEXTURE14_ARB | GLScene.OpenGL4 |
GL_TEXTURE15 | GLScene.OpenGL4 |
GL_TEXTURE15_ARB | GLScene.OpenGL4 |
GL_TEXTURE16 | GLScene.OpenGL4 |
GL_TEXTURE16_ARB | GLScene.OpenGL4 |
GL_TEXTURE17 | GLScene.OpenGL4 |
GL_TEXTURE17_ARB | GLScene.OpenGL4 |
GL_TEXTURE18 | GLScene.OpenGL4 |
GL_TEXTURE18_ARB | GLScene.OpenGL4 |
GL_TEXTURE19 | GLScene.OpenGL4 |
GL_TEXTURE19_ARB | GLScene.OpenGL4 |
GL_TEXTURE1_ARB | GLScene.OpenGL4 |
GL_TEXTURE2 | GLScene.OpenGL4 |
GL_TEXTURE20 | GLScene.OpenGL4 |
GL_TEXTURE20_ARB | GLScene.OpenGL4 |
GL_TEXTURE21 | GLScene.OpenGL4 |
GL_TEXTURE21_ARB | GLScene.OpenGL4 |
GL_TEXTURE22 | GLScene.OpenGL4 |
GL_TEXTURE22_ARB | GLScene.OpenGL4 |
GL_TEXTURE23 | GLScene.OpenGL4 |
GL_TEXTURE23_ARB | GLScene.OpenGL4 |
GL_TEXTURE24 | GLScene.OpenGL4 |
GL_TEXTURE24_ARB | GLScene.OpenGL4 |
GL_TEXTURE25 | GLScene.OpenGL4 |
GL_TEXTURE25_ARB | GLScene.OpenGL4 |
GL_TEXTURE26 | GLScene.OpenGL4 |
GL_TEXTURE26_ARB | GLScene.OpenGL4 |
GL_TEXTURE27 | GLScene.OpenGL4 |
GL_TEXTURE27_ARB | GLScene.OpenGL4 |
GL_TEXTURE28 | GLScene.OpenGL4 |
GL_TEXTURE28_ARB | GLScene.OpenGL4 |
GL_TEXTURE29 | GLScene.OpenGL4 |
GL_TEXTURE29_ARB | GLScene.OpenGL4 |
GL_TEXTURE2_ARB | GLScene.OpenGL4 |
GL_TEXTURE3 | GLScene.OpenGL4 |
GL_TEXTURE30 | GLScene.OpenGL4 |
GL_TEXTURE30_ARB | GLScene.OpenGL4 |
GL_TEXTURE31 | GLScene.OpenGL4 |
GL_TEXTURE31_ARB | GLScene.OpenGL4 |
GL_TEXTURE3_ARB | GLScene.OpenGL4 |
GL_TEXTURE4 | GLScene.OpenGL4 |
GL_TEXTURE4_ARB | GLScene.OpenGL4 |
GL_TEXTURE5 | GLScene.OpenGL4 |
GL_TEXTURE5_ARB | GLScene.OpenGL4 |
GL_TEXTURE6 | GLScene.OpenGL4 |
GL_TEXTURE6_ARB | GLScene.OpenGL4 |
GL_TEXTURE7 | GLScene.OpenGL4 |
GL_TEXTURE7_ARB | GLScene.OpenGL4 |
GL_TEXTURE8 | GLScene.OpenGL4 |
GL_TEXTURE8_ARB | GLScene.OpenGL4 |
GL_TEXTURE9 | GLScene.OpenGL4 |
GL_TEXTURE9_ARB | GLScene.OpenGL4 |
GL_TEXTURE_1D | GLScene.OpenGL4 |
GL_TEXTURE_1D_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_1D_ARRAY_EXT | GLScene.OpenGL4 | GL_EXT_texture_array
GL_TEXTURE_1D_BINDING_EXT | GLScene.OpenGL4 |
GL_TEXTURE_2D | GLScene.OpenGL4 |
GL_TEXTURE_2D_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_TEXTURE_2D_BINDING_EXT | GLScene.OpenGL4 |
GL_TEXTURE_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_TEXTURE_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_3D | GLScene.OpenGL4 |
GL_TEXTURE_3D_BINDING_EXT | GLScene.OpenGL4 |
GL_TEXTURE_3D_EXT | GLScene.OpenGL4 |
GL_TEXTURE_4DSIZE_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_4D_BINDING_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_4D_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_ALPHA_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_ALPHA_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_ALPHA_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_ALPHA_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_APPLICATION_MODE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BASE_LEVEL | GLScene.OpenGL4 |
GL_TEXTURE_BASE_LEVEL_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_BINDING | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_1D | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_1D_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_2D | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_2D_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_3D | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_BUFFER | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_BUFFER_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_BUFFER_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_CUBE_MAP | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_CUBE_MAP_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_CUBE_MAP_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_RECTANGLE | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_RECTANGLE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_RECTANGLE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_RECTANGLE_NV | GLScene.OpenGL4 |
GL_TEXTURE_BINDING_RENDERBUFFER_NV | GLScene.OpenGL4 |
GL_TEXTURE_BIT | GLScene.OpenGL4 |
GL_TEXTURE_BLUE_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_BLUE_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BLUE_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_BLUE_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BORDER | GLScene.OpenGL4 |
GL_TEXTURE_BORDER_COLOR | GLScene.OpenGL4 |
GL_TEXTURE_BORDER_VALUES_NV | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_ARB | GLScene.OpenGL4 | GL_ARB_texture_buffer_object
GL_TEXTURE_BUFFER_BINDING | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_DATA_STORE_BINDING | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_EXT | GLScene.OpenGL4 | GL_EXT_texture_buffer_object
GL_TEXTURE_BUFFER_FORMAT | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_FORMAT_ARB | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_FORMAT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_OFFSET | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT | GLScene.OpenGL4 |
GL_TEXTURE_BUFFER_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_CENTER_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_DEPTH_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_FRAME_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_OFFSET_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_COLOR_SAMPLES_NV | GLScene.OpenGL4 |
GL_TEXTURE_COLOR_TABLE_SGI | GLScene.OpenGL4 | GL_SGI_texture_color_table
GL_TEXTURE_COLOR_WRITEMASK_SGIS | GLScene.OpenGL4 | GL_SGIS_texture_color_mask
GL_TEXTURE_COMPARE_FAIL_VALUE_ARB | GLScene.OpenGL4 | GL_ARB_shadow_ambient
GL_TEXTURE_COMPARE_FUNC | GLScene.OpenGL4 |
GL_TEXTURE_COMPARE_FUNC_ARB | GLScene.OpenGL4 |
GL_TEXTURE_COMPARE_MODE | GLScene.OpenGL4 |
GL_TEXTURE_COMPARE_MODE_ARB | GLScene.OpenGL4 | GL_ARB_shadow
GL_TEXTURE_COMPARE_OPERATOR_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_COMPARE_SGIX | GLScene.OpenGL4 | GL_SGIX_shadow
GL_TEXTURE_COMPONENTS | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_ARB | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_BLOCK_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_BLOCK_WIDTH | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_IMAGE_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSION_HINT | GLScene.OpenGL4 |
GL_TEXTURE_COMPRESSION_HINT_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CONSTANT_DATA_SUNX | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_LIST_IBM | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_POINTER | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_COORD_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_COORD_NV | GLScene.OpenGL4 |
GL_TEXTURE_COVERAGE_SAMPLES_NV | GLScene.OpenGL4 | GL_NV_texture_multisample
GL_TEXTURE_CUBE_MAP | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 | GL_ARB_texture_cube_map_array
GL_TEXTURE_CUBE_MAP_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_X | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Y | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Z | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_X | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Y | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Z | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT | GLScene.OpenGL4 |
GL_TEXTURE_CUBE_MAP_SEAMLESS | GLScene.OpenGL4 | GL_ARB_seamless_cube_map
GL_TEXTURE_DEFORMATION_BIT_SGIX | GLScene.OpenGL4 | GL_FfdMaskSGIX
GL_TEXTURE_DEFORMATION_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH_EXT | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH_SIZE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_DEPTH_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_DS_SIZE_NV | GLScene.OpenGL4 |
GL_TEXTURE_DT_SIZE_NV | GLScene.OpenGL4 |
GL_TEXTURE_ENV | GLScene.OpenGL4 |
GL_TEXTURE_ENV_BIAS_SGIX | GLScene.OpenGL4 | GL_SGIX_texture_add_env
GL_TEXTURE_ENV_COLOR | GLScene.OpenGL4 |
GL_TEXTURE_ENV_MODE | GLScene.OpenGL4 |
GL_TEXTURE_FETCH_BARRIER_BIT | GLScene.OpenGL4 |
GL_TEXTURE_FETCH_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_FILTER4_SIZE_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_FILTER_CONTROL | GLScene.OpenGL4 |
GL_TEXTURE_FILTER_CONTROL_EXT | GLScene.OpenGL4 |
GL_TEXTURE_FIXED_SAMPLE_LOCATIONS | GLScene.OpenGL4 |
GL_TEXTURE_FLOAT_COMPONENTS_NV | GLScene.OpenGL4 |
GL_TEXTURE_FREE_MEMORY_ATI | GLScene.OpenGL4 |
GL_TEXTURE_GATHER | GLScene.OpenGL4 |
GL_TEXTURE_GATHER_SHADOW | GLScene.OpenGL4 |
GL_TEXTURE_GEN_MODE | GLScene.OpenGL4 |
GL_TEXTURE_GEN_Q | GLScene.OpenGL4 |
GL_TEXTURE_GEN_R | GLScene.OpenGL4 |
GL_TEXTURE_GEN_S | GLScene.OpenGL4 |
GL_TEXTURE_GEN_T | GLScene.OpenGL4 |
GL_TEXTURE_GEQUAL_R_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_GREEN_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_GREEN_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_GREEN_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_GREEN_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_HEIGHT | GLScene.OpenGL4 |
GL_TEXTURE_HI_SIZE_NV | GLScene.OpenGL4 |
GL_TEXTURE_IMAGE_FORMAT | GLScene.OpenGL4 |
GL_TEXTURE_IMAGE_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_IMMUTABLE_FORMAT | GLScene.OpenGL4 | GL_ARB_texture_storage
GL_TEXTURE_IMMUTABLE_LEVELS | GLScene.OpenGL4 |
GL_TEXTURE_INDEX_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_INTENSITY_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_INTENSITY_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_INTENSITY_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_INTENSITY_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_INTERNAL_FORMAT | GLScene.OpenGL4 |
GL_TEXTURE_LEQUAL_R_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_LIGHTING_MODE_HP | GLScene.OpenGL4 | GL_HP_texture_lighting
GL_TEXTURE_LIGHT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_LOD_BIAS | GLScene.OpenGL4 |
GL_TEXTURE_LOD_BIAS_EXT | GLScene.OpenGL4 |
GL_TEXTURE_LOD_BIAS_R_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_LOD_BIAS_S_SGIX | GLScene.OpenGL4 | GL_SGIX_texture_lod_bias
GL_TEXTURE_LOD_BIAS_T_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_LO_SIZE_NV | GLScene.OpenGL4 |
GL_TEXTURE_LUMINANCE_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_LUMINANCE_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_LUMINANCE_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_LUMINANCE_TYPE_ARB | GLScene.OpenGL4 |
GL_TEXTURE_MAG_FILTER | GLScene.OpenGL4 | TextureParameterName
GL_TEXTURE_MAG_SIZE_NV | GLScene.OpenGL4 |
GL_TEXTURE_MATERIAL_FACE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_MATERIAL_PARAMETER_EXT | GLScene.OpenGL4 |
GL_TEXTURE_MATRIX | GLScene.OpenGL4 |
GL_TEXTURE_MAX_ANISOTROPY | GLScene.OpenGL4 |
GL_TEXTURE_MAX_ANISOTROPY_EXT | GLScene.OpenGL4 | GL_EXT_texture_filter_anisotropic
GL_TEXTURE_MAX_CLAMP_R_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_MAX_CLAMP_S_SGIX | GLScene.OpenGL4 | GL_SGIX_texture_coordinate_clamp
GL_TEXTURE_MAX_CLAMP_T_SGIX | GLScene.OpenGL4 |
GL_TEXTURE_MAX_LEVEL | GLScene.OpenGL4 |
GL_TEXTURE_MAX_LEVEL_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_MAX_LOD | GLScene.OpenGL4 |
GL_TEXTURE_MAX_LOD_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_MIN_FILTER | GLScene.OpenGL4 |
GL_TEXTURE_MIN_LOD | GLScene.OpenGL4 |
GL_TEXTURE_MIN_LOD_SGIS | GLScene.OpenGL4 | GL_SGIS_texture_lod
GL_TEXTURE_MULTI_BUFFER_HINT_SGIX | GLScene.OpenGL4 | GL_SGIX_texture_multi_buffer
GL_TEXTURE_NORMAL_EXT | GLScene.OpenGL4 |
GL_TEXTURE_POST_SPECULAR_HP | GLScene.OpenGL4 |
GL_TEXTURE_PRE_SPECULAR_HP | GLScene.OpenGL4 |
GL_TEXTURE_PRIORITY | GLScene.OpenGL4 |
GL_TEXTURE_PRIORITY_EXT | GLScene.OpenGL4 | GL_EXT_texture_object
GL_TEXTURE_RANGE_LENGTH_APPLE | GLScene.OpenGL4 | GL_APPLE_texture_range
GL_TEXTURE_RANGE_POINTER_APPLE | GLScene.OpenGL4 |
GL_TEXTURE_RECTANGLE | GLScene.OpenGL4 |
GL_TEXTURE_RECTANGLE_ARB | GLScene.OpenGL4 | GL_ARB_texture_rectangle
GL_TEXTURE_RECTANGLE_EXT | GLScene.OpenGL4 | GL_EXT_texture_rectangle
GL_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 | GL_NV_texture_rectangle
GL_TEXTURE_REDUCTION_MODE_ARB | GLScene.OpenGL4 | GL_ARB_texture_filter_minmax
GL_TEXTURE_RED_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_RED_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_RED_TYPE | GLScene.OpenGL4 |
GL_TEXTURE_RED_TYPE_ARB | GLScene.OpenGL4 | GL_ARB_texture_float
GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV | GLScene.OpenGL4 |
GL_TEXTURE_RENDERBUFFER_NV | GLScene.OpenGL4 |
GL_TEXTURE_RESIDENT | GLScene.OpenGL4 |
GL_TEXTURE_RESIDENT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SAMPLES | GLScene.OpenGL4 |
GL_TEXTURE_SHADER_NV | GLScene.OpenGL4 |
GL_TEXTURE_SHADOW | GLScene.OpenGL4 |
GL_TEXTURE_SHARED_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_SHARED_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SPARSE_ARB | GLScene.OpenGL4 | GL_ARB_SPARSE_TEXTURE
GL_TEXTURE_SRGB_DECODE_EXT | GLScene.OpenGL4 | GL_EXT_texture_sRGB_decode
GL_TEXTURE_STACK_DEPTH | GLScene.OpenGL4 |
GL_TEXTURE_STENCIL_SIZE | GLScene.OpenGL4 |
GL_TEXTURE_STENCIL_SIZE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_STORAGE_HINT_APPLE | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_A | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_A_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_B | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_B_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_G | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_G_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_R | GLScene.OpenGL4 | GL_ARB_texture_swizzle
GL_TEXTURE_SWIZZLE_RGBA | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_RGBA_EXT | GLScene.OpenGL4 |
GL_TEXTURE_SWIZZLE_R_EXT | GLScene.OpenGL4 | GL_EXT_texture_swizzle
GL_TEXTURE_TARGET | GLScene.OpenGL4 |
GL_TEXTURE_TOO_LARGE_EXT | GLScene.OpenGL4 |
GL_TEXTURE_UNSIGNED_REMAP_MODE_NV | GLScene.OpenGL4 | GL_NV_texture_expand_normal
GL_TEXTURE_UPDATE_BARRIER_BIT | GLScene.OpenGL4 |
GL_TEXTURE_UPDATE_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_TEXTURE_VIEW | GLScene.OpenGL4 |
GL_TEXTURE_VIEW_MIN_LAYER | GLScene.OpenGL4 |
GL_TEXTURE_VIEW_MIN_LEVEL | GLScene.OpenGL4 |
GL_TEXTURE_VIEW_NUM_LAYERS | GLScene.OpenGL4 |
GL_TEXTURE_VIEW_NUM_LEVELS | GLScene.OpenGL4 |
GL_TEXTURE_WIDTH | GLScene.OpenGL4 | GetTextureParameter
GL_TEXTURE_WRAP_Q_SGIS | GLScene.OpenGL4 |
GL_TEXTURE_WRAP_R | GLScene.OpenGL4 |
GL_TEXTURE_WRAP_R_EXT | GLScene.OpenGL4 |
GL_TEXTURE_WRAP_S | GLScene.OpenGL4 |
GL_TEXTURE_WRAP_T | GLScene.OpenGL4 |
GL_TEXT_FRAGMENT_SHADER_ATI | GLScene.OpenGL4 | GL_ATI_text_fragment_shader
GL_TIMEOUT_EXPIRED | GLScene.OpenGL4 |
GL_TIMEOUT_IGNORED | GLScene.OpenGL4 |
GL_TIMESTAMP | GLScene.OpenGL4 |
GL_TIME_ELAPSED | GLScene.OpenGL4 | GL_ARB_timer_query
GL_TIME_ELAPSED_EXT | GLScene.OpenGL4 | GL_EXT_timer_query
GL_TOP_LEVEL_ARRAY_SIZE | GLScene.OpenGL4 |
GL_TOP_LEVEL_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_TRACK_MATRIX_NV | GLScene.OpenGL4 |
GL_TRACK_MATRIX_TRANSFORM_NV | GLScene.OpenGL4 |
GL_TRANSFORM_BIT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK | GLScene.OpenGL4 | GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2
GL_TRANSFORM_FEEDBACK_ACTIVE | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_ATTRIBS_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BARRIER_BIT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BINDING | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BINDING_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_BINDING | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_EXT | GLScene.OpenGL4 | GL_EXT_transform_feedback
GL_TRANSFORM_FEEDBACK_BUFFER_INDEX | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_MODE | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_NV | GLScene.OpenGL4 | GL_NV_transform_feedback
GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_SIZE | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_START | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_START_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_NV | GLScene.OpenGL4 | GL_NV_transform_feedback2
GL_TRANSFORM_FEEDBACK_OVERFLOW | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB | GLScene.OpenGL4 | GL_ARB_transform_feedback_overflow_query
GL_TRANSFORM_FEEDBACK_PAUSED | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_RECORD_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYING | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYINGS | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYINGS_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYINGS_NV | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH | GLScene.OpenGL4 |
GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT | GLScene.OpenGL4 |
GL_TRANSFORM_HINT_APPLE | GLScene.OpenGL4 | GL_APPLE_transform_hint
GL_TRANSLATE_2D_NV | GLScene.OpenGL4 |
GL_TRANSLATE_3D_NV | GLScene.OpenGL4 |
GL_TRANSLATE_X_NV | GLScene.OpenGL4 |
GL_TRANSLATE_Y_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_AFFINE_2D_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_AFFINE_3D_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_COLOR_MATRIX | GLScene.OpenGL4 |
GL_TRANSPOSE_COLOR_MATRIX_ARB | GLScene.OpenGL4 |
GL_TRANSPOSE_CURRENT_MATRIX_ARB | GLScene.OpenGL4 |
GL_TRANSPOSE_MODELVIEW_MATRIX | GLScene.OpenGL4 |
GL_TRANSPOSE_MODELVIEW_MATRIX_ARB | GLScene.OpenGL4 | GL_ARB_transpose_matrix
GL_TRANSPOSE_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_PROGRAM_MATRIX_EXT | GLScene.OpenGL4 |
GL_TRANSPOSE_PROJECTION_MATRIX | GLScene.OpenGL4 |
GL_TRANSPOSE_PROJECTION_MATRIX_ARB | GLScene.OpenGL4 |
GL_TRANSPOSE_PROJECTIVE_2D_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_PROJECTIVE_3D_NV | GLScene.OpenGL4 |
GL_TRANSPOSE_TEXTURE_MATRIX | GLScene.OpenGL4 |
GL_TRANSPOSE_TEXTURE_MATRIX_ARB | GLScene.OpenGL4 |
GL_TRIANGLES | GLScene.OpenGL4 |
GL_TRIANGLES_ADJACENCY | GLScene.OpenGL4 |
GL_TRIANGLES_ADJACENCY_ARB | GLScene.OpenGL4 |
GL_TRIANGLES_ADJACENCY_EXT | GLScene.OpenGL4 |
GL_TRIANGLE_FAN | GLScene.OpenGL4 |
GL_TRIANGLE_LIST_SUN | GLScene.OpenGL4 |
GL_TRIANGLE_MESH_SUN | GLScene.OpenGL4 |
GL_TRIANGLE_STRIP | GLScene.OpenGL4 |
GL_TRIANGLE_STRIP_ADJACENCY | GLScene.OpenGL4 |
GL_TRIANGLE_STRIP_ADJACENCY_ARB | GLScene.OpenGL4 |
GL_TRIANGLE_STRIP_ADJACENCY_EXT | GLScene.OpenGL4 |
GL_TRIANGULAR_NV | GLScene.OpenGL4 |
GL_TRUE | GLScene.OpenGL4 |
GL_TYPE | GLScene.OpenGL4 |
GL_TYPE_RGBA_FLOAT_ATI | GLScene.OpenGL4 |
GL_UNDEFINED_APPLE | GLScene.OpenGL4 |
GL_UNDEFINED_VERTEX | GLScene.OpenGL4 |
GL_UNIFORM | GLScene.OpenGL4 |
GL_UNIFORM_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX | GLScene.OpenGL4 |
GL_UNIFORM_BARRIER_BIT | GLScene.OpenGL4 |
GL_UNIFORM_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_BINDING | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_DATA_SIZE | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_INDEX | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_NAME_LENGTH | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER | GLScene.OpenGL4 | GL_ARB_uniform_buffer_object
GL_UNIFORM_BUFFER_BINDING | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER_BINDING_EXT | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER_EXT | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER_SIZE | GLScene.OpenGL4 |
GL_UNIFORM_BUFFER_START | GLScene.OpenGL4 |
GL_UNIFORM_IS_ROW_MAJOR | GLScene.OpenGL4 |
GL_UNIFORM_MATRIX_STRIDE | GLScene.OpenGL4 |
GL_UNIFORM_NAME_LENGTH | GLScene.OpenGL4 |
GL_UNIFORM_OFFSET | GLScene.OpenGL4 |
GL_UNIFORM_SIZE | GLScene.OpenGL4 |
GL_UNIFORM_TYPE | GLScene.OpenGL4 |
GL_UNKNOWN_CONTEXT_RESET | GLScene.OpenGL4 |
GL_UNKNOWN_CONTEXT_RESET_ARB | GLScene.OpenGL4 |
GL_UNPACK_ALIGNMENT | GLScene.OpenGL4 |
GL_UNPACK_CLIENT_STORAGE_APPLE | GLScene.OpenGL4 | GL_APPLE_client_storage
GL_UNPACK_CMYK_HINT_EXT | GLScene.OpenGL4 |
GL_UNPACK_COMPRESSED_BLOCK_DEPTH | GLScene.OpenGL4 |
GL_UNPACK_COMPRESSED_BLOCK_HEIGHT | GLScene.OpenGL4 |
GL_UNPACK_COMPRESSED_BLOCK_SIZE | GLScene.OpenGL4 |
GL_UNPACK_COMPRESSED_BLOCK_WIDTH | GLScene.OpenGL4 | GL_ARB_compressed_texture_pixel_storage
GL_UNPACK_CONSTANT_DATA_SUNX | GLScene.OpenGL4 | GL_SUNX_constant_data
GL_UNPACK_IMAGE_DEPTH_SGIS | GLScene.OpenGL4 |
GL_UNPACK_IMAGE_HEIGHT | GLScene.OpenGL4 |
GL_UNPACK_IMAGE_HEIGHT_EXT | GLScene.OpenGL4 |
GL_UNPACK_LSB_FIRST | GLScene.OpenGL4 |
GL_UNPACK_RESAMPLE_OML | GLScene.OpenGL4 |
GL_UNPACK_RESAMPLE_SGIX | GLScene.OpenGL4 |
GL_UNPACK_ROW_BYTES_APPLE | GLScene.OpenGL4 |
GL_UNPACK_ROW_LENGTH | GLScene.OpenGL4 |
GL_UNPACK_SKIP_IMAGES | GLScene.OpenGL4 |
GL_UNPACK_SKIP_IMAGES_EXT | GLScene.OpenGL4 |
GL_UNPACK_SKIP_PIXELS | GLScene.OpenGL4 |
GL_UNPACK_SKIP_ROWS | GLScene.OpenGL4 |
GL_UNPACK_SKIP_VOLUMES_SGIS | GLScene.OpenGL4 |
GL_UNPACK_SUBSAMPLE_RATE_SGIX | GLScene.OpenGL4 |
GL_UNPACK_SWAP_BYTES | GLScene.OpenGL4 |
GL_UNSIGNALED | GLScene.OpenGL4 |
GL_UNSIGNED_BYTE | GLScene.OpenGL4 |
GL_UNSIGNED_BYTE_2_3_3_REV | GLScene.OpenGL4 |
GL_UNSIGNED_BYTE_3_3_2 | GLScene.OpenGL4 | GL_VERSION_1_2
GL_UNSIGNED_BYTE_3_3_2_EXT | GLScene.OpenGL4 | GL_EXT_packed_pixels
GL_UNSIGNED_IDENTITY_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT | GLScene.OpenGL4 |
GL_UNSIGNED_INT16_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT16_VEC2_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT16_VEC3_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT16_VEC4_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_AMD | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC2_ARB | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC2_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC3_ARB | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC3_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC4_ARB | GLScene.OpenGL4 |
GL_UNSIGNED_INT64_VEC4_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT8_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT8_VEC2_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT8_VEC3_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT8_VEC4_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_10F_11F_11F_REV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_10F_11F_11F_REV_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_10_10_10_2 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_10_10_10_2_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_24_8 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_24_8_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_24_8_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_2_10_10_10_REV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_5_9_9_9_REV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_5_9_9_9_REV_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_8_8_8_8 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_8_8_8_8_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_8_8_8_8_REV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_8_8_S8_S8_REV_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_ATOMIC_COUNTER | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_1D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_1D_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_1D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_RECT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_3D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_3D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_BUFFER | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_BUFFER_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_CUBE | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_CUBE_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_S8_S8_8_8_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_1D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_1D_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_1D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_RECT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_3D | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_3D_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_BUFFER | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_CUBE | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_CUBE_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB | GLScene.OpenGL4 |
GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC2 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC2_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC3 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC3_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC4 | GLScene.OpenGL4 |
GL_UNSIGNED_INT_VEC4_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_INVERT_NV | GLScene.OpenGL4 |
GL_UNSIGNED_NORMALIZED | GLScene.OpenGL4 |
GL_UNSIGNED_NORMALIZED_ARB | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_1_5_5_5_REV | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_4_4_4_4 | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_4_4_4_4_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_4_4_4_4_REV | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_5_5_5_1 | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_5_5_5_1_EXT | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_5_6_5 | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_5_6_5_REV | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_8_8_APPLE | GLScene.OpenGL4 |
GL_UNSIGNED_SHORT_8_8_REV_APPLE | GLScene.OpenGL4 |
GL_UPPER_LEFT | GLScene.OpenGL4 |
GL_USE_MISSING_GLYPH_NV | GLScene.OpenGL4 |
GL_UTF16_NV | GLScene.OpenGL4 |
GL_UTF8_NV | GLScene.OpenGL4 |
GL_V2F | GLScene.OpenGL4 |
GL_V3F | GLScene.OpenGL4 |
GL_VALIDATE_STATUS | GLScene.OpenGL4 |
GL_VARIABLE_A_NV | GLScene.OpenGL4 |
GL_VARIABLE_B_NV | GLScene.OpenGL4 |
GL_VARIABLE_C_NV | GLScene.OpenGL4 |
GL_VARIABLE_D_NV | GLScene.OpenGL4 |
GL_VARIABLE_E_NV | GLScene.OpenGL4 |
GL_VARIABLE_F_NV | GLScene.OpenGL4 |
GL_VARIABLE_G_NV | GLScene.OpenGL4 |
GL_VARIANT_ARRAY_EXT | GLScene.OpenGL4 |
GL_VARIANT_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_VARIANT_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_VARIANT_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_VARIANT_DATATYPE_EXT | GLScene.OpenGL4 |
GL_VARIANT_EXT | GLScene.OpenGL4 |
GL_VARIANT_VALUE_EXT | GLScene.OpenGL4 |
GL_VBO_FREE_MEMORY_ATI | GLScene.OpenGL4 | GL_ATI_meminfo
GL_VECTOR_EXT | GLScene.OpenGL4 |
GL_VENDOR | GLScene.OpenGL4 | StringName
GL_VERSION | GLScene.OpenGL4 |
GL_VERTEX23_BIT_PGI | GLScene.OpenGL4 |
GL_VERTEX4_BIT_PGI | GLScene.OpenGL4 |
GL_VERTEX_ARRAY | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_BINDING | GLScene.OpenGL4 | GL_ARB_vertex_array_object
GL_VERTEX_ARRAY_BINDING_APPLE | GLScene.OpenGL4 | GL_APPLE_vertex_array_object
GL_VERTEX_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_COUNT_EXT | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_EXT | GLScene.OpenGL4 | GL_EXT_vertex_array
GL_VERTEX_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_LIST_IBM | GLScene.OpenGL4 | GL_IBM_vertex_array_lists
GL_VERTEX_ARRAY_LIST_STRIDE_IBM | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_OBJECT_AMD | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_POINTER | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_APPLE | GLScene.OpenGL4 | GL_APPLE_vertex_array_range
GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_LENGTH_NV | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_NV | GLScene.OpenGL4 | GL_NV_vertex_array_range
GL_VERTEX_ARRAY_RANGE_POINTER_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_POINTER_NV | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_VALID_NV | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV | GLScene.OpenGL4 | GL_NV_vertex_array_range2
GL_VERTEX_ARRAY_SIZE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_SIZE_EXT | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_STORAGE_HINT_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_TYPE | GLScene.OpenGL4 |
GL_VERTEX_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY0_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY10_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY11_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY12_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY13_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY14_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY15_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY1_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY2_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY3_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY4_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY5_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY6_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY7_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY8_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY9_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT | GLScene.OpenGL4 | GL_ARB_shader_image_load_store
GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_DIVISOR | GLScene.OpenGL4 | GL_VERSION_3_3
GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB | GLScene.OpenGL4 | GL_ARB_instanced_arrays
GL_VERTEX_ATTRIB_ARRAY_ENABLED | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_INTEGER | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT | GLScene.OpenGL4 | GL_EXT_gpu_shader4
GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_LONG | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_NORMALIZED | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_POINTER | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_SIZE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_STRIDE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_TYPE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV | GLScene.OpenGL4 | GL_NV_vertex_buffer_unified_memory
GL_VERTEX_ATTRIB_BINDING | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP1_APPLE | GLScene.OpenGL4 | GL_APPLE_vertex_program_evaluators
GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP2_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE | GLScene.OpenGL4 |
GL_VERTEX_ATTRIB_RELATIVE_OFFSET | GLScene.OpenGL4 |
GL_VERTEX_BINDING_DIVISOR | GLScene.OpenGL4 |
GL_VERTEX_BINDING_OFFSET | GLScene.OpenGL4 |
GL_VERTEX_BINDING_STRIDE | GLScene.OpenGL4 |
GL_VERTEX_BLEND_ARB | GLScene.OpenGL4 |
GL_VERTEX_CONSISTENT_HINT_PGI | GLScene.OpenGL4 |
GL_VERTEX_DATA_HINT_PGI | GLScene.OpenGL4 | GL_PGI_vertex_hints
GL_VERTEX_ID_NV | GLScene.OpenGL4 |
GL_VERTEX_PRECLIP_HINT_SGIX | GLScene.OpenGL4 |
GL_VERTEX_PRECLIP_SGIX | GLScene.OpenGL4 | GL_SGIX_vertex_preclip
GL_VERTEX_PROGRAM_ARB | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_BINDING_NV | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_NV | GLScene.OpenGL4 | GL_NV_vertex_program
GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_POINT_SIZE | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_POINT_SIZE_ARB | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_POINT_SIZE_NV | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_TWO_SIDE | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_TWO_SIDE_ARB | GLScene.OpenGL4 |
GL_VERTEX_PROGRAM_TWO_SIDE_NV | GLScene.OpenGL4 |
GL_VERTEX_SHADER | GLScene.OpenGL4 |
GL_VERTEX_SHADER_ARB | GLScene.OpenGL4 | GL_ARB_vertex_shader
GL_VERTEX_SHADER_BINDING_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_BIT | GLScene.OpenGL4 | GL_ARB_separate_shader_objects
GL_VERTEX_SHADER_EXT | GLScene.OpenGL4 | GL_EXT_vertex_shader
GL_VERTEX_SHADER_INSTRUCTIONS_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_INVARIANTS_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_INVOCATIONS | GLScene.OpenGL4 |
GL_VERTEX_SHADER_INVOCATIONS_ARB | GLScene.OpenGL4 |
GL_VERTEX_SHADER_LOCALS_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_OPTIMIZED_EXT | GLScene.OpenGL4 |
GL_VERTEX_SHADER_VARIANTS_EXT | GLScene.OpenGL4 |
GL_VERTEX_SOURCE_ATI | GLScene.OpenGL4 |
GL_VERTEX_STATE_PROGRAM_NV | GLScene.OpenGL4 |
GL_VERTEX_STREAM0_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM1_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM2_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM3_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM4_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM5_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM6_ATI | GLScene.OpenGL4 |
GL_VERTEX_STREAM7_ATI | GLScene.OpenGL4 |
GL_VERTEX_SUBROUTINE | GLScene.OpenGL4 |
GL_VERTEX_SUBROUTINE_UNIFORM | GLScene.OpenGL4 |
GL_VERTEX_TEXTURE | GLScene.OpenGL4 |
GL_VERTEX_WEIGHTING_EXT | GLScene.OpenGL4 |
GL_VERTEX_WEIGHT_ARRAY_EXT | GLScene.OpenGL4 |
GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT | GLScene.OpenGL4 |
GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT | GLScene.OpenGL4 |
GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT | GLScene.OpenGL4 |
GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT | GLScene.OpenGL4 |
GL_VERTICAL_LINE_TO_NV | GLScene.OpenGL4 |
GL_VERTICES_SUBMITTED | GLScene.OpenGL4 |
GL_VERTICES_SUBMITTED_ARB | GLScene.OpenGL4 | GL_ARB_pipeline_statistics_query
GL_VIBRANCE_BIAS_NV | GLScene.OpenGL4 |
GL_VIBRANCE_SCALE_NV | GLScene.OpenGL4 |
GL_VIDEO_BUFFER_BINDING_NV | GLScene.OpenGL4 |
GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV | GLScene.OpenGL4 |
GL_VIDEO_BUFFER_NV | GLScene.OpenGL4 | GL_NV_video_capture
GL_VIDEO_BUFFER_PITCH_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_FRAME_WIDTH_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV | GLScene.OpenGL4 |
GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV | GLScene.OpenGL4 |
GL_VIDEO_COLOR_CONVERSION_MATRIX_NV | GLScene.OpenGL4 |
GL_VIDEO_COLOR_CONVERSION_MAX_NV | GLScene.OpenGL4 |
GL_VIDEO_COLOR_CONVERSION_MIN_NV | GLScene.OpenGL4 |
GL_VIDEO_COLOR_CONVERSION_OFFSET_NV | GLScene.OpenGL4 |
GL_VIEWPORT | GLScene.OpenGL4 |
GL_VIEWPORT_BIT | GLScene.OpenGL4 |
GL_VIEWPORT_BOUNDS_RANGE | GLScene.OpenGL4 |
GL_VIEWPORT_INDEX_PROVOKING_VERTEX | GLScene.OpenGL4 |
GL_VIEWPORT_SUBPIXEL_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_128_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_16_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_24_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_32_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_48_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_64_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_8_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_96_BITS | GLScene.OpenGL4 |
GL_VIEW_CLASS_BPTC_FLOAT | GLScene.OpenGL4 |
GL_VIEW_CLASS_BPTC_UNORM | GLScene.OpenGL4 |
GL_VIEW_CLASS_RGTC1_RED | GLScene.OpenGL4 |
GL_VIEW_CLASS_RGTC2_RG | GLScene.OpenGL4 |
GL_VIEW_CLASS_S3TC_DXT1_RGB | GLScene.OpenGL4 |
GL_VIEW_CLASS_S3TC_DXT1_RGBA | GLScene.OpenGL4 |
GL_VIEW_CLASS_S3TC_DXT3_RGBA | GLScene.OpenGL4 |
GL_VIEW_CLASS_S3TC_DXT5_RGBA | GLScene.OpenGL4 |
GL_VIEW_COMPATIBILITY_CLASS | GLScene.OpenGL4 |
GL_VIRTUAL_PAGE_SIZE_INDEX_ARB | GLScene.OpenGL4 |
GL_VIRTUAL_PAGE_SIZE_X_ARB | GLScene.OpenGL4 |
GL_VIRTUAL_PAGE_SIZE_Y_ARB | GLScene.OpenGL4 |
GL_VIRTUAL_PAGE_SIZE_Z_ARB | GLScene.OpenGL4 |
GL_VOLATILE_APPLE | GLScene.OpenGL4 |
GL_WAIT_FAILED | GLScene.OpenGL4 |
GL_WEIGHTED_AVERAGE_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_BUFFER_BINDING | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_POINTER_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_SIZE_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_STRIDE_ARB | GLScene.OpenGL4 |
GL_WEIGHT_ARRAY_TYPE_ARB | GLScene.OpenGL4 |
GL_WEIGHT_SUM_UNITY_ARB | GLScene.OpenGL4 |
GL_WIDE_LINE_HINT_PGI | GLScene.OpenGL4 |
GL_WRAP_BORDER_SUN | GLScene.OpenGL4 | GL_SUN_convolution_border_modes
GL_WRITE_DISCARD_NV | GLScene.OpenGL4 |
GL_WRITE_ONLY | GLScene.OpenGL4 |
GL_WRITE_ONLY_ARB | GLScene.OpenGL4 |
GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV | GLScene.OpenGL4 |
GL_WRITE_PIXEL_DATA_RANGE_NV | GLScene.OpenGL4 | GL_NV_pixel_data_range
GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV | GLScene.OpenGL4 |
GL_W_EXT | GLScene.OpenGL4 |
GL_XOR | GLScene.OpenGL4 |
GL_X_EXT | GLScene.OpenGL4 |
GL_YCBAYCR8A_4224_NV | GLScene.OpenGL4 |
GL_YCBCR_422_APPLE | GLScene.OpenGL4 | GL_APPLE_ycbcr_422
GL_YCBYCR8_422_NV | GLScene.OpenGL4 |
GL_YCRCBA_SGIX | GLScene.OpenGL4 |
GL_YCRCB_422_SGIX | GLScene.OpenGL4 | GL_SGIX_ycrcb
GL_YCRCB_444_SGIX | GLScene.OpenGL4 |
GL_YCRCB_SGIX | GLScene.OpenGL4 | GL_SGIX_ycrcba
GL_Y_EXT | GLScene.OpenGL4 |
GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV | GLScene.OpenGL4 |
GL_Z4Y12Z4CB12Z4CR12_444_NV | GLScene.OpenGL4 |
GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV | GLScene.OpenGL4 |
GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV | GLScene.OpenGL4 |
GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV | GLScene.OpenGL4 |
GL_ZERO | GLScene.OpenGL4 | BlendingFactorDest
GL_ZERO_EXT | GLScene.OpenGL4 |
GL_ZERO_TO_ONE | GLScene.OpenGL4 |
GL_ZOOM_X | GLScene.OpenGL4 |
GL_ZOOM_Y | GLScene.OpenGL4 |
GL_Z_EXT | GLScene.OpenGL4 |
GRADIENT_TABLE_SIZE | GXS.ProcTextures |
GravitationalConstant | GXS.PhysFields |
GuiNullRect | GXS.Gui |
gxsShaderMaxLightSources | GXSL.CustomShader |
G_DRAG | GXS.VerletTypes |
IdentityHmgDblMatrix | GLScene.VectorGeometry |
IdentityHmgMatrix | GLScene.VectorGeometry |
IdentityMatrix | GLScene.VectorGeometry |
IdentityQuaternion | GLScene.VectorGeometry | Quaternions
lcl_release | GXS.Screen |
libEGL | GLScene.OpenGL4 |
libGLES2 | GLScene.OpenGL4 |
LineLen | GXS.FileOBJ | Load input data in chunks of BufSize Bytes.
llMax | GLScene.Logger |
llMedium | GLScene.Logger |
llMin | GLScene.Logger |
MaxColorAttachments | GXS.FBO |
MaxComp | GLScene.VectorGeometry |
MaxDouble | GLScene.VectorGeometry |
MaxExtended | GLScene.VectorGeometry |
MaxSingle | GLScene.VectorGeometry |
MaxTriangles | GLScene.Triangulation |
MaxVertices | GLScene.Triangulation | Set these as applicable
MaxVideoModes | GXS.Screen |
MAX_HARDWARE_LIGHT | GXS.State |
MAX_HARDWARE_TEXTURE_UNIT | GXS.State |
MAX_HARDWARE_UNIFORM_BUFFER_BINDING | GXS.State |
MAX_MATRIX_STACK_DEPTH | GLScene.PipelineTransform |
MAX_MS3D_GROUPS | GXS.FileMS3D |
MAX_MS3D_JOINTS | GXS.FileMS3D |
MAX_MS3D_KEYFRAMES | GXS.FileMS3D |
MAX_MS3D_MATERIALS | GXS.FileMS3D |
MAX_MS3D_TRIANGLES | GXS.FileMS3D |
MAX_MS3D_VERTICES | GXS.FileMS3D |
MAX_OBJECT_STACK_DEPTH | GXS.Selection |
MAX_SHADER_LIGHT | GXS.State |
MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB | GLScene.OpenGL4 | GL_NV_vertex_program3
MDCFILE_IDENTITY | GXS.FileMDC |
MDCFILE_VERSION | GXS.FileMDC |
MDC_BASEVERTEX_FACTOR | GXS.FileMDC |
MDC_COMPVERTEX_FACTOR | GXS.FileMDC | 1/64;
MidTexPoint | GLScene.VectorGeometry |
MinComp | GLScene.VectorGeometry | 1.1E+4932 <-Overflowing in c++;
MinDouble | GLScene.VectorGeometry |
MinExtended | GLScene.VectorGeometry |
MinSingle | GLScene.VectorGeometry | Ranges of the IEEE floating point types, including denormals with Math.pas compatible name
MinusXVector | GLScene.VectorGeometry |
MinusYVector | GLScene.VectorGeometry |
MinusZVector | GLScene.VectorGeometry |
MRT_BUFFERS | GXS.Context | GXS.OpenGLx, Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)
NMF_HEADER_TAG | GXS.FileNMF |
NMF_TRIANGLE_TAG | GXS.FileNMF |
NullBoundingBox | GLScene.GeometryBB |
NullHmgPoint | GLScene.VectorGeometry |
NullHmgVector | GLScene.VectorGeometry |
NullTexPoint | GLScene.VectorGeometry |
NullVector | GLScene.VectorGeometry |
opengl32 | GLScene.OpenGL4 |
opengl32 | GXS.OpenGLAdapter |
RC_DDS_Type | GXS.ApplicationFileIO |
RC_JPG_Type | GXS.ApplicationFileIO |
RC_String_Type | GXS.ApplicationFileIO |
RC_XML_Type | GXS.ApplicationFileIO |
RGBA_SIGNED_COMPONENTS_EXT | GLScene.OpenGL4 |
sAllFilter | GXS.ImageUtils | TglTextLayout
SCENE_REVISION | GXS.Scene |
SCENE_VERSION | GXS.Scene |
SIGN | GXS.FileZLIB |
SIGN | GXS.PAKArchive |
sNOT_QUAD | GLScene.VectorTypesExt |
sSINGULAR | GLScene.VectorTypesExt |
str3DSMapNotFound | GLScene.Strings | File3DS
strAlreadyRendering | GLScene.Strings |
strBackwardContextFailed | GLScene.Strings |
strBadPlanSize | GLScene.Strings |
strBrokenObjectListArchive | GLScene.Strings |
strCadencerNotDefined | GLScene.Strings | Cadencer
strCadencerNotDefinedEx | GLScene.Strings |
strCamera | GLScene.Strings |
strCameraRoot | GLScene.Strings |
strCannotAlterAnActiveContext | GLScene.Strings | Context
strCantConvertImg | GLScene.Strings | Graphics
strConnectJoystick | GLScene.Strings |
strContextActivationFailed | GLScene.Strings |
strContextAlreadyCreated | GLScene.Strings |
strContextDeactivationFailed | GLScene.Strings |
strContextNotCreated | GLScene.Strings |
strContextNotInit | GLScene.Strings |
strCUDAEditor | GLScene.Strings |
strCUTILFailed | GLScene.Strings | FilePGM
strCyclicRefMat | GLScene.Strings | Material
strDeleteContextFailed | GLScene.Strings |
strDisplayList | GLScene.Strings |
strDot | GLScene.Strings | General
strDriverNotSupportDebugRC | GLScene.Strings |
strDriverNotSupportFRC | GLScene.Strings |
strDriverNotSupportOESRC | GLScene.Strings |
strError | GLScene.Strings |
strError3DS_CLOSING_FILE | GLScene.Strings |
strError3DS_CREATING_DATABASE | GLScene.Strings |
strError3DS_GET_FAIL | GLScene.Strings |
strError3DS_INIT_FAILED | GLScene.Strings |
strError3DS_INVALID_ARG | GLScene.Strings |
strError3DS_INVALID_CHUNK | GLScene.Strings |
strError3DS_INVALID_DATA | GLScene.Strings |
strError3DS_INVALID_DATABASE | GLScene.Strings |
strError3DS_INVALID_INDEX | GLScene.Strings |
strError3DS_NO_MEM | GLScene.Strings |
strError3DS_NO_SUCH_FILE | GLScene.Strings |
strError3DS_OPENING_FILE | GLScene.Strings |
strError3DS_PUT_FAIL | GLScene.Strings |
strError3DS_READING_DATABASE | GLScene.Strings |
strError3DS_READING_FILE | GLScene.Strings |
strError3DS_STRING_TOO_LONG | GLScene.Strings |
strError3DS_UNFOUND_CHUNK | GLScene.Strings |
strError3DS_WRITING_DATABASE | GLScene.Strings |
strError3DS_WRITING_FILE | GLScene.Strings |
strError3DS_WRONG_DATABASE | GLScene.Strings |
strError3DS_WRONG_OBJECT | GLScene.Strings |
strErrorEx | GLScene.Strings |
strErrorLIB | GLScene.Strings |
strFailCompilation | GLScene.Strings |
strFailCreatePipe | GLScene.Strings |
strFailedOpenFile | GLScene.Strings |
strFailedOpenFileFromCurrentDir | GLScene.Strings |
strFailedToShare | GLScene.Strings |
strFailHWRC | GLScene.Strings |
strFailMap | GLScene.Strings |
strFailRunNVCC | GLScene.Strings |
strFailToBindArrayToTex | GLScene.Strings |
strFailUnmap | GLScene.Strings |
strFFTFuncRetErr | GLScene.Strings |
strFileNotFound | GLScene.Strings |
strForwardContextFailed | GLScene.Strings | SceneContext
strFRC_created | GLScene.Strings |
strFuncNotConnected | GLScene.Strings |
strFuncRetErr | GLScene.Strings |
strGLSceneEditor | GLScene.Strings | SceneEdit
strImageInvalid | GLScene.Strings | Textures
strIncompatibleContexts | GLScene.Strings |
strIncompatibleTypes | GLScene.Strings |
strInterleaveNotSupported | GLScene.Strings |
strInvalidColor | GLScene.Strings | Utils
strInvalidContextReg | GLScene.Strings |
strInvalidContextRegistration | GLScene.Strings |
strInvalidFileSignature | GLScene.Strings | PersistentClasses
strInvalidGLContext | GLScene.Strings |
strInvalidNotificationRemoval | GLScene.Strings |
strInvalidParamType | GLScene.Strings |
strInvalidType | GLScene.Strings |
strInvalidValue | GLScene.Strings |
strJoystickError | GLScene.Strings |
strLaunchFailed | GLScene.Strings |
strLayoutCategoryName | GLScene.Strings |
strListIndexError | GLScene.Strings |
strLocalizableCategoryName | GLScene.Strings |
strMakeFloatingFail | GLScene.Strings |
strMaterialNotFound | GLScene.Strings |
strMaterialNotFoundInMatlib | GLScene.Strings |
strMaterialNotFoundInMatlibEx | GLScene.Strings |
strMatLibNotDefined | GLScene.Strings | Materials
strMissingResource | GLScene.Strings |
strModuleAbsent | GLScene.Strings | CUDA strings
strNoActiveRC | GLScene.Strings |
strNoDescriptionAvailable | GLScene.Strings |
strNoDeviceToCreate | GLScene.Strings |
strNoJoystickDriver | GLScene.Strings | Joystick
strNoNewTexture | GLScene.Strings |
strNoRenderingContext | GLScene.Strings | SceneViewer
strNothing | GLScene.Strings |
strObjectRoot | GLScene.Strings |
strObjectsNotSupported | GLScene.Strings |
strOCAdvancedGeometry | GLScene.Strings |
strOCBasicGeometry | GLScene.Strings | Object categories in GLScene Registry
strOCDoodad | GLScene.Strings |
strOCEnvironmentObjects | GLScene.Strings |
strOCExperimental | GLScene.Strings |
strOCGraphPlottingObjects | GLScene.Strings |
strOCGuiObjects | GLScene.Strings |
strOCHUDObjects | GLScene.Strings |
strOCMeshObjects | GLScene.Strings |
strOCParticleSystems | GLScene.Strings |
strOCProxyObjects | GLScene.Strings |
strOCSpecialObjects | GLScene.Strings |
strOctreeMustBePreparedBeforeUse | GLScene.Strings | Octree
strOESRC_created | GLScene.Strings |
strOESvsForwardRC | GLScene.Strings |
strOnlyHostData | GLScene.Strings |
strOpenGLCategoryName | GLScene.Strings | SceneRegister, strings additional to Designintf
strOpenGLError | GLScene.Strings | InitOpenGL
strOutOfAttribSize | GLScene.Strings |
strOutOfElementSize | GLScene.Strings |
strOutOfMemory | GLScene.Strings |
strOutOfRange | GLScene.Strings |
strPBufferRC_created | GLScene.Strings |
strRequireFreeThread | GLScene.Strings |
strSceneRoot | GLScene.Strings | Tree
strSceneViewerNotDefined | GLScene.Strings |
strShaderNeedsAtLeastOneLightSource | GLScene.Strings | Shaders
strShaderNeedsAtLeastOneLightSourceEx | GLScene.Strings |
strSizeMismatch | GLScene.Strings |
strSourceFileNotFound | GLScene.Strings |
strSphereStartStop | GLScene.Strings |
strSphereTopBottom | GLScene.Strings | Objects
strStateCashMissing | GLScene.Strings |
strSuccessCompilation | GLScene.Strings |
strThreadBusy | GLScene.Strings |
strTmpRC_Created | GLScene.Strings |
strTooManyLights | GLScene.Strings |
strUnableToCreateLegacyContext | GLScene.Strings |
strUnBalancedBeginEndUpdate | GLScene.Strings |
strUnbalancedContexActivations | GLScene.Strings |
strUnbalansedUsage | GLScene.Strings |
strUnknownArchive | GLScene.Strings | Common messages
strUnknownArchiveVersion | GLScene.Strings |
strUnknownExtension | GLScene.Strings |
strUnknownParam | GLScene.Strings |
strUnknownType | GLScene.Strings |
strUnsupportedType | GLScene.Strings |
strVisualCategoryName | GLScene.Strings |
strWrongBitmapCanvas | GLScene.Strings |
strWrongParamSetup | GLScene.Strings |
strWrongPrinter | GLScene.Strings |
strWrongVersion | GLScene.Strings |
strXCollectionEditor | GLScene.Strings | FXCollectionEditor
sWRONG_ELEMENT | GLScene.VectorTypesExt |
sWRONG_SIZE | GLScene.VectorTypesExt |
VERTEX_ATTR_NUM | GXS.State |
VerticalScalingFactor | GXS.RandomHDS |
VK_MOUSEWHEELDOWN | GLScene.Keyboard |
VK_MOUSEWHEELUP | GLScene.Keyboard | pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved
WGL_ACCELERATION_ARB | GLScene.OpenGL4 |
WGL_ACCELERATION_ARB | GLScene.OpenGLTokens |
WGL_ACCELERATION_EXT | GLScene.OpenGL4 |
WGL_ACCESS_READ_ONLY_NV | GLScene.OpenGL4 | WGL_NV_DX_interop
WGL_ACCESS_READ_ONLY_NV | GLScene.OpenGLTokens | WGL_NV_DX_interop (EXT #407)
WGL_ACCESS_READ_WRITE_NV | GLScene.OpenGL4 |
WGL_ACCESS_READ_WRITE_NV | GLScene.OpenGLTokens |
WGL_ACCESS_WRITE_DISCARD_NV | GLScene.OpenGL4 |
WGL_ACCESS_WRITE_DISCARD_NV | GLScene.OpenGLTokens |
WGL_ACCUM_ALPHA_BITS_ARB | GLScene.OpenGL4 |
WGL_ACCUM_ALPHA_BITS_ARB | GLScene.OpenGLTokens |
WGL_ACCUM_ALPHA_BITS_EXT | GLScene.OpenGL4 |
WGL_ACCUM_BITS_ARB | GLScene.OpenGL4 |
WGL_ACCUM_BITS_ARB | GLScene.OpenGLTokens |
WGL_ACCUM_BITS_EXT | GLScene.OpenGL4 |
WGL_ACCUM_BLUE_BITS_ARB | GLScene.OpenGL4 |
WGL_ACCUM_BLUE_BITS_ARB | GLScene.OpenGLTokens |
WGL_ACCUM_BLUE_BITS_EXT | GLScene.OpenGL4 |
WGL_ACCUM_GREEN_BITS_ARB | GLScene.OpenGL4 |
WGL_ACCUM_GREEN_BITS_ARB | GLScene.OpenGLTokens |
WGL_ACCUM_GREEN_BITS_EXT | GLScene.OpenGL4 |
WGL_ACCUM_RED_BITS_ARB | GLScene.OpenGL4 |
WGL_ACCUM_RED_BITS_ARB | GLScene.OpenGLTokens |
WGL_ACCUM_RED_BITS_EXT | GLScene.OpenGL4 |
WGL_ALPHA_BITS_ARB | GLScene.OpenGL4 |
WGL_ALPHA_BITS_ARB | GLScene.OpenGLTokens |
WGL_ALPHA_BITS_EXT | GLScene.OpenGL4 |
WGL_ALPHA_SHIFT_ARB | GLScene.OpenGL4 |
WGL_ALPHA_SHIFT_ARB | GLScene.OpenGLTokens |
WGL_ALPHA_SHIFT_EXT | GLScene.OpenGL4 |
WGL_AUX0_ARB | GLScene.OpenGL4 |
WGL_AUX0_ARB | GLScene.OpenGLTokens |
WGL_AUX1_ARB | GLScene.OpenGL4 |
WGL_AUX1_ARB | GLScene.OpenGLTokens |
WGL_AUX2_ARB | GLScene.OpenGL4 |
WGL_AUX2_ARB | GLScene.OpenGLTokens |
WGL_AUX3_ARB | GLScene.OpenGL4 |
WGL_AUX3_ARB | GLScene.OpenGLTokens |
WGL_AUX4_ARB | GLScene.OpenGL4 |
WGL_AUX4_ARB | GLScene.OpenGLTokens |
WGL_AUX5_ARB | GLScene.OpenGL4 |
WGL_AUX5_ARB | GLScene.OpenGLTokens |
WGL_AUX6_ARB | GLScene.OpenGL4 |
WGL_AUX6_ARB | GLScene.OpenGLTokens |
WGL_AUX7_ARB | GLScene.OpenGL4 |
WGL_AUX7_ARB | GLScene.OpenGLTokens |
WGL_AUX8_ARB | GLScene.OpenGL4 |
WGL_AUX8_ARB | GLScene.OpenGLTokens |
WGL_AUX9_ARB | GLScene.OpenGL4 |
WGL_AUX9_ARB | GLScene.OpenGLTokens |
WGL_AUX_BUFFERS_ARB | GLScene.OpenGL4 |
WGL_AUX_BUFFERS_ARB | GLScene.OpenGLTokens |
WGL_AUX_BUFFERS_EXT | GLScene.OpenGL4 |
WGL_BACK_COLOR_BUFFER_BIT_ARB | GLScene.OpenGL4 |
WGL_BACK_COLOR_BUFFER_BIT_ARB | GLScene.OpenGLTokens |
WGL_BACK_LEFT_ARB | GLScene.OpenGL4 |
WGL_BACK_LEFT_ARB | GLScene.OpenGLTokens |
WGL_BACK_RIGHT_ARB | GLScene.OpenGL4 |
WGL_BACK_RIGHT_ARB | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_DEPTH_NV | GLScene.OpenGL4 | WGL_NV_render_depth_texture
WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV | GLScene.OpenGL4 | WGL_NV_render_texture_rectangle
WGL_BIND_TO_TEXTURE_RGBA_ARB | GLScene.OpenGL4 |
WGL_BIND_TO_TEXTURE_RGBA_ARB | GLScene.OpenGLTokens |
WGL_BIND_TO_TEXTURE_RGB_ARB | GLScene.OpenGL4 | WGL_ARB_render_texture
WGL_BIND_TO_TEXTURE_RGB_ARB | GLScene.OpenGLTokens | ARB Extension #20 - WGL_ARB_render_texture
WGL_BIND_TO_VIDEO_RGBA_NV | GLScene.OpenGL4 |
WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV | GLScene.OpenGL4 |
WGL_BIND_TO_VIDEO_RGB_NV | GLScene.OpenGL4 | WGL_NV_video_output
WGL_BLUE_BITS_ARB | GLScene.OpenGL4 |
WGL_BLUE_BITS_ARB | GLScene.OpenGLTokens |
WGL_BLUE_BITS_EXT | GLScene.OpenGL4 |
WGL_BLUE_SHIFT_ARB | GLScene.OpenGL4 |
WGL_BLUE_SHIFT_ARB | GLScene.OpenGLTokens |
WGL_BLUE_SHIFT_EXT | GLScene.OpenGL4 |
WGL_CLAMP_FRAGMENT_COLOR_ARB | GLScene.OpenGL4 |
WGL_CLAMP_READ_COLOR_ARB | GLScene.OpenGL4 |
WGL_CLAMP_VERTEX_COLOR_ARB | GLScene.OpenGL4 |
WGL_COLOR_BITS_ARB | GLScene.OpenGL4 |
WGL_COLOR_BITS_ARB | GLScene.OpenGLTokens |
WGL_COLOR_BITS_EXT | GLScene.OpenGL4 |
WGL_COLOR_SAMPLES_NV | GLScene.OpenGL4 |
WGL_COLOR_SAMPLES_NV | GLScene.OpenGLTokens | unknown extension, where does it come from?
WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_CORE_PROFILE_BIT_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_CORE_PROFILE_BIT_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_DEBUG_BIT_ARB | GLScene.OpenGL4 | WGL_ARB_create_context
WGL_CONTEXT_DEBUG_BIT_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_ES2_PROFILE_BIT_EXT | GLScene.OpenGL4 | WGL_EXT_create_context_es2_profile
WGL_CONTEXT_ES2_PROFILE_BIT_EXT | GLScene.OpenGLTokens | EXT #400 WGL_EXT_create_context_es2_profile
WGL_CONTEXT_FLAGS_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_FLAGS_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_LAYER_PLANE_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_LAYER_PLANE_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_MAJOR_VERSION_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_MAJOR_VERSION_ARB | GLScene.OpenGLTokens | ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)
WGL_CONTEXT_MINOR_VERSION_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_MINOR_VERSION_ARB | GLScene.OpenGLTokens |
WGL_CONTEXT_PROFILE_MASK_ARB | GLScene.OpenGL4 | WGL_ARB_create_context_profile
WGL_CONTEXT_PROFILE_MASK_ARB | GLScene.OpenGLTokens | ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)
WGL_CONTEXT_RELEASE_BEHAVIOR_ARB | GLScene.OpenGL4 | WGL_ARB_context_flush_control
WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_RESET_ISOLATION_BIT_ARB | GLScene.OpenGL4 | WGL_ARB_robustness_application_isolation
WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB | GLScene.OpenGL4 |
WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB | GLScene.OpenGL4 | WGL_ARB_create_context_robustness
WGL_COVERAGE_SAMPLES_NV | GLScene.OpenGL4 | WGL_NV_multisample_coverage
WGL_CUBE_MAP_FACE_ARB | GLScene.OpenGL4 |
WGL_CUBE_MAP_FACE_ARB | GLScene.OpenGLTokens |
WGL_DEPTH_BITS_ARB | GLScene.OpenGL4 |
WGL_DEPTH_BITS_ARB | GLScene.OpenGLTokens |
WGL_DEPTH_BITS_EXT | GLScene.OpenGL4 |
WGL_DEPTH_BUFFER_BIT_ARB | GLScene.OpenGL4 |
WGL_DEPTH_BUFFER_BIT_ARB | GLScene.OpenGLTokens |
WGL_DEPTH_COMPONENT_NV | GLScene.OpenGL4 |
WGL_DEPTH_FLOAT_EXT | GLScene.OpenGL4 | WGL_EXT_depth_float
WGL_DEPTH_TEXTURE_FORMAT_NV | GLScene.OpenGL4 |
WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D | GLScene.OpenGL4 | WGL_I3D_digital_video_control
WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D | GLScene.OpenGL4 |
WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D | GLScene.OpenGL4 |
WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D | GLScene.OpenGL4 |
WGL_DOUBLE_BUFFER_ARB | GLScene.OpenGL4 |
WGL_DOUBLE_BUFFER_ARB | GLScene.OpenGLTokens |
WGL_DOUBLE_BUFFER_EXT | GLScene.OpenGL4 |
WGL_DRAW_TO_BITMAP_ARB | GLScene.OpenGL4 |
WGL_DRAW_TO_BITMAP_ARB | GLScene.OpenGLTokens |
WGL_DRAW_TO_BITMAP_EXT | GLScene.OpenGL4 |
WGL_DRAW_TO_PBUFFER_ARB | GLScene.OpenGL4 | WGL_ARB_pbuffer
WGL_DRAW_TO_PBUFFER_ARB | GLScene.OpenGLTokens | ARB Extension #11 - WGL_ARB_pbuffer
WGL_DRAW_TO_PBUFFER_EXT | GLScene.OpenGL4 | WGL_EXT_pbuffer
WGL_DRAW_TO_WINDOW_ARB | GLScene.OpenGL4 |
WGL_DRAW_TO_WINDOW_ARB | GLScene.OpenGLTokens |
WGL_DRAW_TO_WINDOW_EXT | GLScene.OpenGL4 |
WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV | GLScene.OpenGL4 | WGL_NV_gpu_affinity
WGL_ERROR_MISSING_AFFINITY_MASK_NV | GLScene.OpenGL4 |
WGL_FIXED_ONLY_ARB | GLScene.OpenGL4 |
WGL_FLOAT_COMPONENTS_NV | GLScene.OpenGL4 | WGL_NV_float_buffer
WGL_FLOAT_COMPONENTS_NV | GLScene.OpenGLTokens |
WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB | GLScene.OpenGL4 | WGL_ARB_framebuffer_sRGB
WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB | GLScene.OpenGLTokens | ARB Extension #46 - GL_ARB_framebuffer_sRGB
WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT | GLScene.OpenGL4 |
WGL_FRONT_COLOR_BUFFER_BIT_ARB | GLScene.OpenGL4 | WGL_ARB_buffer_region
WGL_FRONT_COLOR_BUFFER_BIT_ARB | GLScene.OpenGLTokens | —————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region
WGL_FRONT_LEFT_ARB | GLScene.OpenGL4 |
WGL_FRONT_LEFT_ARB | GLScene.OpenGLTokens |
WGL_FRONT_RIGHT_ARB | GLScene.OpenGL4 |
WGL_FRONT_RIGHT_ARB | GLScene.OpenGLTokens |
WGL_FULL_ACCELERATION_ARB | GLScene.OpenGL4 |
WGL_FULL_ACCELERATION_ARB | GLScene.OpenGLTokens |
WGL_FULL_ACCELERATION_EXT | GLScene.OpenGL4 |
WGL_GAMMA_EXCLUDE_DESKTOP_I3D | GLScene.OpenGL4 |
WGL_GAMMA_TABLE_SIZE_I3D | GLScene.OpenGL4 | WGL_I3D_gamma
WGL_GENERIC_ACCELERATION_ARB | GLScene.OpenGL4 |
WGL_GENERIC_ACCELERATION_ARB | GLScene.OpenGLTokens |
WGL_GENERIC_ACCELERATION_EXT | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EDGE_RISING_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D | GLScene.OpenGL4 |
WGL_GENLOCK_SOURCE_MULTIVIEW_I3D | GLScene.OpenGL4 | WGL_I3D_genlock
WGL_GPU_CLOCK_AMD | GLScene.OpenGL4 |
WGL_GPU_FASTEST_TARGET_GPUS_AMD | GLScene.OpenGL4 |
WGL_GPU_NUM_PIPES_AMD | GLScene.OpenGL4 |
WGL_GPU_NUM_RB_AMD | GLScene.OpenGL4 |
WGL_GPU_NUM_SIMD_AMD | GLScene.OpenGL4 |
WGL_GPU_NUM_SPI_AMD | GLScene.OpenGL4 |
WGL_GPU_OPENGL_VERSION_STRING_AMD | GLScene.OpenGL4 |
WGL_GPU_RAM_AMD | GLScene.OpenGL4 |
WGL_GPU_RENDERER_STRING_AMD | GLScene.OpenGL4 |
WGL_GPU_VENDOR_AMD | GLScene.OpenGL4 | WGL_AMD_gpu_association
WGL_GREEN_BITS_ARB | GLScene.OpenGL4 |
WGL_GREEN_BITS_ARB | GLScene.OpenGLTokens |
WGL_GREEN_BITS_EXT | GLScene.OpenGL4 |
WGL_GREEN_SHIFT_ARB | GLScene.OpenGL4 |
WGL_GREEN_SHIFT_ARB | GLScene.OpenGLTokens |
WGL_GREEN_SHIFT_EXT | GLScene.OpenGL4 |
WGL_IMAGE_BUFFER_LOCK_I3D | GLScene.OpenGL4 |
WGL_IMAGE_BUFFER_MIN_ACCESS_I3D | GLScene.OpenGL4 | WGL_I3D_image_buffer
WGL_LOSE_CONTEXT_ON_RESET_ARB | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_HEIGHT_ARB | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_HEIGHT_ARB | GLScene.OpenGLTokens |
WGL_MAX_PBUFFER_HEIGHT_EXT | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_PIXELS_ARB | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_PIXELS_ARB | GLScene.OpenGLTokens |
WGL_MAX_PBUFFER_PIXELS_EXT | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_WIDTH_ARB | GLScene.OpenGL4 |
WGL_MAX_PBUFFER_WIDTH_ARB | GLScene.OpenGLTokens |
WGL_MAX_PBUFFER_WIDTH_EXT | GLScene.OpenGL4 |
WGL_MIPMAP_LEVEL_ARB | GLScene.OpenGL4 |
WGL_MIPMAP_LEVEL_ARB | GLScene.OpenGLTokens |
WGL_MIPMAP_TEXTURE_ARB | GLScene.OpenGL4 |
WGL_MIPMAP_TEXTURE_ARB | GLScene.OpenGLTokens |
WGL_NEED_PALETTE_ARB | GLScene.OpenGL4 |
WGL_NEED_PALETTE_ARB | GLScene.OpenGLTokens |
WGL_NEED_PALETTE_EXT | GLScene.OpenGL4 |
WGL_NEED_SYSTEM_PALETTE_ARB | GLScene.OpenGL4 |
WGL_NEED_SYSTEM_PALETTE_ARB | GLScene.OpenGLTokens |
WGL_NEED_SYSTEM_PALETTE_EXT | GLScene.OpenGL4 |
WGL_NO_ACCELERATION_ARB | GLScene.OpenGL4 |
WGL_NO_ACCELERATION_ARB | GLScene.OpenGLTokens |
WGL_NO_ACCELERATION_EXT | GLScene.OpenGL4 |
WGL_NO_RESET_NOTIFICATION_ARB | GLScene.OpenGL4 |
WGL_NO_TEXTURE_ARB | GLScene.OpenGL4 |
WGL_NO_TEXTURE_ARB | GLScene.OpenGLTokens |
WGL_NUMBER_OVERLAYS_ARB | GLScene.OpenGL4 |
WGL_NUMBER_OVERLAYS_ARB | GLScene.OpenGLTokens |
WGL_NUMBER_OVERLAYS_EXT | GLScene.OpenGL4 |
WGL_NUMBER_PIXEL_FORMATS_ARB | GLScene.OpenGL4 | WGL_ARB_pixel_format
WGL_NUMBER_PIXEL_FORMATS_ARB | GLScene.OpenGLTokens | ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)
WGL_NUMBER_PIXEL_FORMATS_EXT | GLScene.OpenGL4 | WGL_EXT_pixel_format
WGL_NUMBER_UNDERLAYS_ARB | GLScene.OpenGL4 |
WGL_NUMBER_UNDERLAYS_ARB | GLScene.OpenGLTokens |
WGL_NUMBER_UNDERLAYS_EXT | GLScene.OpenGL4 |
WGL_NUM_VIDEO_CAPTURE_SLOTS_NV | GLScene.OpenGL4 |
WGL_NUM_VIDEO_SLOTS_NV | GLScene.OpenGL4 | WGL_NV_present_video
WGL_OPTIMAL_PBUFFER_HEIGHT_EXT | GLScene.OpenGL4 |
WGL_OPTIMAL_PBUFFER_WIDTH_EXT | GLScene.OpenGL4 |
WGL_PBUFFER_HEIGHT_ARB | GLScene.OpenGL4 |
WGL_PBUFFER_HEIGHT_ARB | GLScene.OpenGLTokens |
WGL_PBUFFER_HEIGHT_EXT | GLScene.OpenGL4 |
WGL_PBUFFER_LARGEST_ARB | GLScene.OpenGL4 |
WGL_PBUFFER_LARGEST_ARB | GLScene.OpenGLTokens |
WGL_PBUFFER_LARGEST_EXT | GLScene.OpenGL4 |
WGL_PBUFFER_LOST_ARB | GLScene.OpenGL4 |
WGL_PBUFFER_LOST_ARB | GLScene.OpenGLTokens |
WGL_PBUFFER_WIDTH_ARB | GLScene.OpenGL4 |
WGL_PBUFFER_WIDTH_ARB | GLScene.OpenGLTokens |
WGL_PBUFFER_WIDTH_EXT | GLScene.OpenGL4 |
WGL_PIXEL_TYPE_ARB | GLScene.OpenGL4 |
WGL_PIXEL_TYPE_ARB | GLScene.OpenGLTokens |
WGL_PIXEL_TYPE_EXT | GLScene.OpenGL4 |
WGL_RED_BITS_ARB | GLScene.OpenGL4 |
WGL_RED_BITS_ARB | GLScene.OpenGLTokens |
WGL_RED_BITS_EXT | GLScene.OpenGL4 |
WGL_RED_SHIFT_ARB | GLScene.OpenGL4 |
WGL_RED_SHIFT_ARB | GLScene.OpenGLTokens |
WGL_RED_SHIFT_EXT | GLScene.OpenGL4 |
WGL_RGBA_FLOAT_MODE_ARB | GLScene.OpenGL4 | WGL_ARB_pixel_format_float
WGL_SAMPLES_3DFX | GLScene.OpenGL4 |
WGL_SAMPLES_ARB | GLScene.OpenGL4 |
WGL_SAMPLES_ARB | GLScene.OpenGLTokens |
WGL_SAMPLES_EXT | GLScene.OpenGL4 |
WGL_SAMPLE_BUFFERS_3DFX | GLScene.OpenGL4 | WGL_3DFX_multisample
WGL_SAMPLE_BUFFERS_ARB | GLScene.OpenGL4 | WGL_ARB_multisample
WGL_SAMPLE_BUFFERS_ARB | GLScene.OpenGLTokens |
WGL_SAMPLE_BUFFERS_EXT | GLScene.OpenGL4 | WGL_EXT_multisample
WGL_SHARE_ACCUM_ARB | GLScene.OpenGL4 |
WGL_SHARE_ACCUM_ARB | GLScene.OpenGLTokens |
WGL_SHARE_ACCUM_EXT | GLScene.OpenGL4 |
WGL_SHARE_DEPTH_ARB | GLScene.OpenGL4 |
WGL_SHARE_DEPTH_ARB | GLScene.OpenGLTokens |
WGL_SHARE_DEPTH_EXT | GLScene.OpenGL4 |
WGL_SHARE_STENCIL_ARB | GLScene.OpenGL4 |
WGL_SHARE_STENCIL_ARB | GLScene.OpenGLTokens |
WGL_SHARE_STENCIL_EXT | GLScene.OpenGL4 |
WGL_STENCIL_BITS_ARB | GLScene.OpenGL4 |
WGL_STENCIL_BITS_ARB | GLScene.OpenGLTokens |
WGL_STENCIL_BITS_EXT | GLScene.OpenGL4 |
WGL_STENCIL_BUFFER_BIT_ARB | GLScene.OpenGL4 |
WGL_STENCIL_BUFFER_BIT_ARB | GLScene.OpenGLTokens |
WGL_STEREO_ARB | GLScene.OpenGL4 |
WGL_STEREO_ARB | GLScene.OpenGLTokens |
WGL_STEREO_EXT | GLScene.OpenGL4 |
WGL_SUPPORT_GDI_ARB | GLScene.OpenGL4 |
WGL_SUPPORT_GDI_ARB | GLScene.OpenGLTokens |
WGL_SUPPORT_GDI_EXT | GLScene.OpenGL4 |
WGL_SUPPORT_OPENGL_ARB | GLScene.OpenGL4 |
WGL_SUPPORT_OPENGL_ARB | GLScene.OpenGLTokens |
WGL_SUPPORT_OPENGL_EXT | GLScene.OpenGL4 |
WGL_SWAP_COPY_ARB | GLScene.OpenGL4 |
WGL_SWAP_COPY_ARB | GLScene.OpenGLTokens |
WGL_SWAP_COPY_EXT | GLScene.OpenGL4 |
WGL_SWAP_EXCHANGE_ARB | GLScene.OpenGL4 |
WGL_SWAP_EXCHANGE_ARB | GLScene.OpenGLTokens |
WGL_SWAP_EXCHANGE_EXT | GLScene.OpenGL4 |
WGL_SWAP_LAYER_BUFFERS_ARB | GLScene.OpenGL4 |
WGL_SWAP_LAYER_BUFFERS_ARB | GLScene.OpenGLTokens |
WGL_SWAP_LAYER_BUFFERS_EXT | GLScene.OpenGL4 |
WGL_SWAP_METHOD_ARB | GLScene.OpenGL4 |
WGL_SWAP_METHOD_ARB | GLScene.OpenGLTokens |
WGL_SWAP_METHOD_EXT | GLScene.OpenGL4 |
WGL_SWAP_UNDEFINED_ARB | GLScene.OpenGL4 |
WGL_SWAP_UNDEFINED_ARB | GLScene.OpenGLTokens |
WGL_SWAP_UNDEFINED_EXT | GLScene.OpenGL4 |
WGL_TEXTURE_1D_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_1D_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_2D_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_2D_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_DEPTH_COMPONENT_NV | GLScene.OpenGL4 |
WGL_TEXTURE_FLOAT_RGBA_NV | GLScene.OpenGL4 |
WGL_TEXTURE_FLOAT_RGBA_NV | GLScene.OpenGLTokens |
WGL_TEXTURE_FLOAT_RGB_NV | GLScene.OpenGL4 |
WGL_TEXTURE_FLOAT_RGB_NV | GLScene.OpenGLTokens |
WGL_TEXTURE_FLOAT_RG_NV | GLScene.OpenGL4 |
WGL_TEXTURE_FLOAT_RG_NV | GLScene.OpenGLTokens |
WGL_TEXTURE_FLOAT_R_NV | GLScene.OpenGL4 |
WGL_TEXTURE_FLOAT_R_NV | GLScene.OpenGLTokens |
WGL_TEXTURE_FORMAT_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_FORMAT_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_RECTANGLE_NV | GLScene.OpenGL4 |
WGL_TEXTURE_RGBA_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_RGBA_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_RGB_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_RGB_ARB | GLScene.OpenGLTokens |
WGL_TEXTURE_TARGET_ARB | GLScene.OpenGL4 |
WGL_TEXTURE_TARGET_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_ALPHA_VALUE_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_ALPHA_VALUE_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_BLUE_VALUE_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_BLUE_VALUE_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_EXT | GLScene.OpenGL4 |
WGL_TRANSPARENT_GREEN_VALUE_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_GREEN_VALUE_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_INDEX_VALUE_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_INDEX_VALUE_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_RED_VALUE_ARB | GLScene.OpenGL4 |
WGL_TRANSPARENT_RED_VALUE_ARB | GLScene.OpenGLTokens |
WGL_TRANSPARENT_VALUE_EXT | GLScene.OpenGL4 |
WGL_TYPE_COLORINDEX_ARB | GLScene.OpenGL4 |
WGL_TYPE_COLORINDEX_ARB | GLScene.OpenGLTokens |
WGL_TYPE_COLORINDEX_EXT | GLScene.OpenGL4 |
WGL_TYPE_RGBA_ARB | GLScene.OpenGL4 |
WGL_TYPE_RGBA_ARB | GLScene.OpenGLTokens |
WGL_TYPE_RGBA_EXT | GLScene.OpenGL4 |
WGL_TYPE_RGBA_FLOAT_ARB | GLScene.OpenGL4 |
WGL_TYPE_RGBA_FLOAT_ATI | GLScene.OpenGL4 | WGL_ATI_pixel_format_float
WGL_TYPE_RGBA_FLOAT_ATI | GLScene.OpenGLTokens | WGL_ATI_pixel_format_float (#278)
WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT | GLScene.OpenGL4 |
WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT | GLScene.OpenGLTokens |
WGL_UNIQUE_ID_NV | GLScene.OpenGL4 | WGL_NV_video_capture
WGL_VIDEO_OUT_ALPHA_NV | GLScene.OpenGL4 |
WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV | GLScene.OpenGL4 |
WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV | GLScene.OpenGL4 |
WGL_VIDEO_OUT_COLOR_NV | GLScene.OpenGL4 |
WGL_VIDEO_OUT_DEPTH_NV | GLScene.OpenGL4 |
WGL_VIDEO_OUT_FIELD_1 | GLScene.OpenGL4 |
WGL_VIDEO_OUT_FIELD_2 | GLScene.OpenGL4 |
WGL_VIDEO_OUT_FRAME | GLScene.OpenGL4 |
WGL_VIDEO_OUT_STACKED_FIELDS_1_2 | GLScene.OpenGL4 |
WGL_VIDEO_OUT_STACKED_FIELDS_2_1 | GLScene.OpenGL4 |
WHmgPoint | GLScene.VectorGeometry |
WHmgVector | GLScene.VectorGeometry |
XHmgPoint | GLScene.VectorGeometry | Standard homogeneous points
XHmgVector | GLScene.VectorGeometry | Standard homogeneous vectors
XTexPoint | GLScene.VectorGeometry | TexPoints (2D space)
XVector | GLScene.VectorGeometry | standard vectors
XYHmgVector | GLScene.VectorGeometry |
XYTexPoint | GLScene.VectorGeometry |
XYVector | GLScene.VectorGeometry |
XYZHmgVector | GLScene.VectorGeometry |
XYZVector | GLScene.VectorGeometry |
XYZWHmgVector | GLScene.VectorGeometry |
XZHmgVector | GLScene.VectorGeometry |
XZVector | GLScene.VectorGeometry |
YHmgPoint | GLScene.VectorGeometry |
YHmgVector | GLScene.VectorGeometry |
YTexPoint | GLScene.VectorGeometry |
YVector | GLScene.VectorGeometry |
YZHmgVector | GLScene.VectorGeometry |
YZVector | GLScene.VectorGeometry |
ZHmgPoint | GLScene.VectorGeometry |
ZHmgVector | GLScene.VectorGeometry |
ZVector | GLScene.VectorGeometry |


GXSysHelp v.2.5: All Functions and Procedures

All Functions and Procedures

Name Unit Description
AABBContainsAABB GLScene.GeometryBB

Determines to which extent one AABB contains another AABB
AABBContainsBSphere GLScene.GeometryBB

Determines to which extent an AABB contains a BSpher
AABBFitsInAABBAbsolute GLScene.GeometryBB

Checks whether one Bounding box aligned with the world axes fits within another Bounding box
AABBFromSweep GLScene.GeometryBB

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest
AABBInclude GLScene.GeometryBB

Resize the AABB if necessary to include p.
AABBIntersection GLScene.GeometryBB

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).
AABBScale GLScene.GeometryBB

AABBToBB GLScene.GeometryBB

Converts an AABB to its canonical BB.
AABBToBB GLScene.GeometryBB

Transforms an AABB to a BB.
AABBToBSphere GLScene.GeometryBB

Convert an AABB to a BSphere
AABBToClipRect GLScene.GeometryBB

Projects an AABB and determines the extent of its projection as a clip rect.
AABBTransform GLScene.GeometryBB

AbsVector GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }
AbsVector GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }
ActiveSoundManager GXS.SoundManager

ActorAddForce GXS.PhysX

ActorCount GXS.PhysX

AddAABB GLScene.GeometryBB

AddBB GLScene.GeometryBB

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.
AddPoint GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1. W coordinate is always 1.
AddSCODEGeomsToODESpace GXS.ODESkeletonColliders

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1
AddVector GLScene.VectorGeometry

Sums up f to each component of the vector
AddVector GLScene.VectorGeometry

Sums up f to each component of the vector
AddVerletConstriantsToVerletWorld GXS.VerletTypes

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.
AdjointMatrix GLScene.VectorGeometry

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix
AdjointMatrix GLScene.VectorGeometry

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix
AffineVectorEquals GLScene.VectorGeometry

True if X, Y and Z components are equal.
AffineVectorMake GLScene.VectorGeometry

AffineVectorMake GLScene.VectorGeometry

AlphaGammaBrightCorrection GXS.ImageUtils

AngleBetweenVectors GLScene.VectorGeometry

AngleBetweenVectors GLScene.VectorGeometry

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians
AngleLerp GLScene.VectorGeometry

Calculates angular interpolation between start and stop at point t
AnglePreservingMatrixInvert GLScene.VectorGeometry

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.
AnsiStartsText GLScene.Utils

StrUtils.pas
ApplicationFileIODefined GXS.ApplicationFileIO

Returns true if an ApplicationFileIO has been defined
ApplyBlendingModeEx GXSL.CustomShader

Exported procedures.
AppTime GLScene.Utils

Returns time in milisecond from application start.
ArcCosine GLScene.VectorGeometry

ArcCreateFileStream GXS.ArchiveManager

Users getting results after LoadFromFile with this functions
ArcFileStreamExists GXS.ArchiveManager

ASESetPreferredLightmap GXS.FileASE

ASESetPreferredTexture GXS.FileASE

Use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map
AxesBuildList GXS.Scene

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.
Barycentre uGBEUtils3D

BBMaxX GLScene.GeometryBB

BBMaxY GLScene.GeometryBB

BBMaxZ GLScene.GeometryBB

BBMinX GLScene.GeometryBB

BBMinY GLScene.GeometryBB

BBMinZ GLScene.GeometryBB

BBToAABB GLScene.GeometryBB

Extract AABB information from a BB.
BBTransform GLScene.GeometryBB

BeginFPUOnlySection GLScene.VectorGeometry

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).
BGR24ToRGB24 GXS.Graphics

BGR24ToRGBA32 GXS.Graphics

BGRA32ToRGBA32 GXS.Graphics

BitmapScanLine GXS.ImageUtils

Returns the bitmap's scanline for the specified row.
BoundingBoxesAreEqual GLScene.GeometryBB

BoundingBoxesAreEqual GLScene.GeometryBB

—————————————————————————— Bounding Box functions ——————————————————————————
BrightenRGBArray GXS.Graphics

BSphereContainsAABB GLScene.GeometryBB

Determines to which extent a BSphere contains an AABB
BSphereContainsBSphere GLScene.GeometryBB

Determines to which extent one BSphere contains another BSphere
BSphereIntersectsBSphere GLScene.GeometryBB

Determines if one BSphere intersects another BSphere
BSphereToAABB GLScene.GeometryBB

BSphereToAABB GLScene.GeometryBB

BSphereToAABB GLScene.GeometryBB

Convert a BSphere to an AABB
Build2DMipmap GXS.ImageUtils

BuildCube GXS.MeshBuilder

BuildCylinder GXS.MeshBuilder

BuildCylinder2 GXS.MeshBuilder

BuildNonOrientedEdgesList GXS.MeshUtils

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.
BuildNormals GXS.MeshUtils

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.
BuildVectorCountOptimizedIndices GXS.MeshUtils

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.
CalcObjectSpaceLightVectors GXS.BumpMapping

CalcPlaneNormal GLScene.VectorGeometry

CalcPlaneNormal GLScene.VectorGeometry

CalcPlaneNormal GLScene.VectorGeometry

Calculate the normal of a plane defined by three points.
CalcQuadraticInterpolation omSailSurface

Quadratic interpolation with 3 points
CalcTangentSpaceLightVectors GXS.BumpMapping

CalculateHeight uGBEUtils3D

cbrt GLScene.Polynomials

Calculates the cube root of its parameter.
CharToVirtualKeyCode GLScene.Keyboard

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.
CharToWideChar GLScene.Utils

CheckOpenGLError GLScene.OpenGL4

ClampInteger GLScene.VectorGeometry

ClampInteger GLScene.VectorGeometry

ClampValue GLScene.VectorGeometry

Clamps aValue in the aMin-aMax interval
ClampValue GLScene.VectorGeometry

Clamps aValue in the aMin-INF interval
ClearGLError GLScene.OpenGL4

Gets the oldest error and tries to clear the error queue
ClipToAABB GLScene.GeometryBB

Clips a position to an AABB
CloseOpenGL GLScene.OpenGL4

CloseOpenGL GXS.OpenGLAdapter

CollideAndSlide GXS.EllipseCollision

CollideWithWorld GXS.EllipseCollision

CollisionDummyChilds uGBEUtils3D

CollisionEntre2Objets uGBEUtils3D

CombineVector GLScene.VectorGeometry

CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CombineVector GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f
CompareInteger GLScene.RedBlackTree

CompressedInternalFormatToOpenGL GLScene.TextureFormat

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format
ConeContainsBSphere GXS.SpacePartition

Determines to which extent one Cone contains an BSphere
ConstArrayToString GLScene.Logger

ConvertdVector3ToAffineVector GXS.ODEUtils

ConvertdVector3ToAffineVector GXS.ODEUtils

ConvertdVector3ToVector3f GXS.ODEUtils

ConvertdVector3ToVector3f GXS.ODEUtils

Converting between ODE and Scene formats
ConvertdVector3ToVector4f GXS.ODEUtils

ConvertdVector3ToVector4f GXS.ODEUtils

ConvertFansToList GXS.MeshUtils

ConvertImage GXS.ImageUtils

ConvertIndexedListToList GXS.MeshUtils

Expands an indexed structure into a non-indexed structure.
ConvertRotation GLScene.VectorGeometry

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)
ConvertStripToList GXS.MeshUtils

ConvertStripToList GXS.MeshUtils

ConvertStripToList GXS.MeshUtils

ConvertStripToList GXS.MeshUtils

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.
ConvertVector3fTodVector3 GXS.ODEUtils

Converting between Scene and ODE formats
ConvertVector3fToPdVector3 GXS.ODEUtils

ConvertVector4fTodVector3 GXS.ODEUtils

ConvertVector4fToPdVector3 GXS.ODEUtils

CopyBodyFromCube GXS.ODEUtils

CopyCubeSizeFromBox GXS.ODEUtils

CopyPosFromGeomToGX GXS.ODEUtils

CopyScreentoTexture GXSL.CustomShader

CopyScreentoTexture2 GXSL.CustomShader

Cosine_Interpolate GXS.Perlin

does a cosine interpolation
CreateAffineRotationMatrix GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateBodyFromCube GXS.ODEUtils

CreateBox GXS.PhysX

CreateCylinder GXS.PhysX

CreateGeomFromCube GXS.ODEUtils

CreateGraphicFromFile GXS.Texture

CreateGroundPlane GXS.PhysX

CreateLookAtMatrix GLScene.VectorGeometry

CreateMatrixFromFrustum GLScene.VectorGeometry

CreateObjectSpaceNormalMap GXS.BumpMapping

CreateODEPlaneFromScenePlane GXS.ODEUtils

CreateOrthoMatrix GLScene.VectorGeometry

CreatePerspectiveMatrix GLScene.VectorGeometry

CreatePickMatrix GLScene.VectorGeometry

CreateResourceStream GXS.ApplicationFileIO

CreateRotationMatrix GLScene.VectorGeometry

CreateRotationMatrix GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateRotationMatrixX GLScene.VectorGeometry

CreateRotationMatrixX GLScene.VectorGeometry

Creates matrix for rotation about x-axis (angle in rad)
CreateRotationMatrixY GLScene.VectorGeometry

CreateRotationMatrixY GLScene.VectorGeometry

Creates matrix for rotation about y-axis (angle in rad)
CreateRotationMatrixZ GLScene.VectorGeometry

CreateRotationMatrixZ GLScene.VectorGeometry

Creates matrix for rotation about z-axis (angle in rad)
CreateScaleAndTranslationMatrix GLScene.VectorGeometry

Creates a scale+translation matrix. Scale is applied BEFORE applying offset
CreateScaleMatrix GLScene.VectorGeometry

Creates scale matrix
CreateScaleMatrix GLScene.VectorGeometry

Creates scale matrix
CreateSphere GXS.PhysX

CreateTangentSpaceNormalMap GXS.BumpMapping

CreateTempWnd GXS.WinContext

CreateTranslationMatrix GLScene.VectorGeometry

Creates translation matrix
CreateTranslationMatrix GLScene.VectorGeometry

Creates translation matrix
CreateTriMeshFromBaseMesh GXS.ODEUtils

This method requires you to manually deallocate vertices and indices when you're done with the trimesh
CreateVerletPlaneFromGLPlane GXS.VerletTypes

CropImage uGBEImageUtils

CSG_Operation GXS.MeshCSG

CubeWireframeBuildList GXS.Objects

Issues for a unit-size cube stippled wireframe.
Cubic_Interpolate GXS.Perlin

does a cubic interpolation
Cubic_Interpolate_Strip GXS.Perlin

cubic interpolate 4 strips into one...
CurrentContext GXS.Context

The TgxContext that is the currently active context, if any. Returns nil if no context is active.
dBodyToBodyDistance GXS.ODEUtils

DecodeTextureTarget GLScene.TextureFormat

DegToRadian GLScene.VectorGeometry

DegToRadian GLScene.VectorGeometry

—————————————————————————- Trigonometric functions —————————————————————————-
DeRegisterBaseSceneObjectNameChangeEvent GXS.Scene

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.
DeRegisterBehaviourNameChangeEvent GXS.Scene

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.
DeRegisterCUDAComponentNameChangeEvent GXS.CUDA.API

DeRegisterManager GLScene.Manager

DeRegisterXCollectionDestroyEvent GLScene.XCollection

DeRegisters event
DerivatedPolynom GLScene.Polynomials

Calculates the polynom's derivative
DetectionCollisionObstacle uGBEUtils3D

DistanceBetweenAngles GLScene.VectorGeometry

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.
Div2 GXS.Graphics

DivideVector GLScene.VectorGeometry

DivideVector GLScene.VectorGeometry

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.
DivMod GLScene.VectorGeometry

DoTesselate GXS.PolygonTesselation

Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.
DrawBox GXS.ODEUtils

DrawContours GXS.ROAMPatch

Draw contours on rendering terrain patches
DrawTexturedScreenQuad GXSL.CustomShader

Probably need to give them proper names, instead of numbers...
DrawTexturedScreenQuad2 GXSL.CustomShader

DrawTexturedScreenQuad3 GXSL.CustomShader

DrawTexturedScreenQuad4 GXSL.CustomShader

DrawTexturedScreenQuad5 GXSL.CustomShader

DrawTexturedScreenQuad6 GXSL.CustomShader

dsDrawBox GXS.ODEUtils

dsDrawBox GXS.ODEUtils

dVector3Length GXS.ODEUtils

dVector3Length GXS.ODEUtils

ECAddBox GXS.DCEMisc

Add a TriMesh box
ECAddEllipsoid GXS.DCEMisc

Add a static ellipsoid
ECAddFreeForm GXS.DCEMisc

Add freeform's octree data
ECAddTerrain GXS.DCEMisc

Add the terrain as a TriMesh
ECResetColliders GXS.DCEMisc

Set the collider lists to null
ECSetCollisionRange GXS.DCEMisc

Calculate and set the collision range
EditTextureImage GXS.TextureImageEditors

Invokes the editor for the given TgxTextureImage
EncodeGLTextureTarget GLScene.TextureFormat

EndFPUOnlySection GLScene.VectorGeometry

Ends a FPU-only section. See BeginFPUOnlySection
EvalPolynom GLScene.Polynomials

Computes polynom's value for given x
ExponateCrap GXS.Perlin

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.
ExtendedFrustumIntersectsBSphere GXS.SpacePartition

Determines if a extended frustum intersects an BSphere
ExtendedFrustumMake GXS.SpacePartition

Create an extended frustum from a number of values
ExtendedFrustumMakeFromSceneViewer GXS.SpatialPartitioning

ExtendedFrustumMakeFromSceneViewer GXS.SpatialPartitioning

Create an extended frustum from a SceneViewer - this makes the unit specific to the windows platform!
ExtractAABBCorners GLScene.GeometryBB

Extract the corners from an AABB
ExtractFrustumFromModelViewProjection GLScene.VectorGeometry

Extracts a TFrustum for combined modelview and projection matrices
FacesSmooth GXS.MeshOptimizer

FastArcTangent2 GLScene.VectorGeometry

Fast ArcTangent2 approximation, about 0.07 rads accuracy
FastCheckCubeVsCube GXS.Collision

FastCheckCubeVsEllipsoid GXS.Collision

FastCheckCubeVsFace GXS.Collision

FastCheckCubeVsPoint GXS.Collision

FastCheckCubeVsSphere GXS.Collision

FastCheckEllipsoidVsCube GXS.Collision

FastCheckEllipsoidVsEllipsoid GXS.Collision

FastCheckEllipsoidVsPoint GXS.Collision

FastCheckEllipsoidVsSphere GXS.Collision

FastCheckFaceVsCube GXS.Collision

experimental
FastCheckFaceVsFace GXS.Collision

experimental
FastCheckPointVsCube GXS.Collision

FastCheckPointVsEllipsoid GXS.Collision

FastCheckPointVsPoint GXS.Collision

Fast Collision detection routines that are heavily specialized and just return a boolean
FastCheckPointVsSphere GXS.Collision

FastCheckSphereVsCube GXS.Collision

FastCheckSphereVsEllipsoid GXS.Collision

FastCheckSphereVsPoint GXS.Collision

FastCheckSphereVsSphere GXS.Collision

FileStreamExists GXS.ApplicationFileIO

Queries is a file stream corresponding to the fileName exists.
FillUniformAutoSetMethodList GXSL.Parameter

FillUniformAutoSetMethodList GXSL.Parameter

FillUniformAutoSetMethodList GXSL.ShaderParameter

FillUniformAutoSetMethodList GXSL.ShaderParameter

FindCompatibleDataFormat GLScene.TextureFormat

Give compatible openGL image format and data type
FindManager GLScene.Manager

FindRoot GLScene.Polynomials

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign
FindTextureImageClass GXS.Texture

Finds a registerer TgxTextureImageClass using its classname
FindTextureImageClassByFriendlyName GXS.Texture

Finds a registerer TgxTextureImageClass using its FriendlyName
FindUnitName GLScene.Utils

FindUnitName GLScene.Utils

FindXCollectionItemClass GLScene.XCollection

Retrieves a registered TXCollectionItemClass from its classname
FixPathDelimiter GLScene.Utils

Replace path delimiter to delimiter of the current platform.
Float2rgbe GLScene.RGBE

FloatToHalf GLScene.Utils

FMOD_Load GXS.Sounds.FMOD

If no library name is passed to FMOD_Load, then the default library name used.
FMOD_Unload GXS.Sounds.FMOD

FontManager GXS.SpaceText

FractalMiddlePointHDS GXS.RandomHDS

Random HDS functions
FrustumContainsAABB GLScene.GeometryBB

Determines to which extent a frustum contains an AABB
FrustumContainsBSphere GLScene.GeometryBB

Determines to which extent a frustum contains a BSphere
GammaCorrectRGBArray GXS.Graphics

GenerateDiamondSquare uGBEImageUtils

https://fr.wikipedia.org/wiki/Algorithme_Diamant-Carr%C3%A9
GenRandom GLScene.RandomLib

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.
GeometryOptimizationMode GLScene.VectorGeometry

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'
GetActiveLightsList GXSL.CustomShader

GetActor GXS.PhysX

GetActorCMassGlobalPosition GXS.PhysX

GetActorGlobalOrientation GXS.PhysX

GetActorGlobalPosition GXS.PhysX

GetActorMass GXS.PhysX

GetArchiveFileFormats GXS.ArchiveManager

GetArchiveManager GXS.ArchiveManager

Note! It's working only with one manager
GetBestSelectorClass GXS.Selection

GetBodyFromGLXceneObject GXS.NGDManager

GetBodyFromGLXceneObject GXS.ODEManager

GetBodyFromObject GXS.ODEManager

Helper functions for extracting data from objects with different inheritance.
GetBodyPositionAsAffineVector GXS.ODEUtils

GetBoneParent GXS.NGDRagdoll

GetChannelTypeAndNum GXS.CUDA.API

GetCUDAEditorForm FMxCUDAEditor

GetCurrentAssetPath GLScene.Utils

Get current path to assets from dir examples
GetCurrentColorDepth GXS.ImageUtils

Number of bits per pixel for the current desktop resolution.
GetCurrentRenderingObject GXS.Scene

GetDeviceLogicalPixelsX GXS.ImageUtils

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.
GetFPSMovement GXS.FPSMovement

GetFPSMovement GXS.FPSMovement

GetGenericCompressedFormat GLScene.TextureFormat

Give generic compressed OpenGL texture format
GetGLRect GLScene.Utils

Rectangle as function
GetGLSoundFileFormats GXS.SoundFileObjects

GetGLXceneObject GXS.ODEManager

GetImageLodNumber GXS.Graphics

Return an optimal number of texture pyramid
GetIndexFromResolution GXS.Screen

GetInertia GXS.Behaviours

Returns or creates the TgxBInertia within the given behaviours. This helper function is convenient way to access a TgxBInertia.
GetMatrixRec GLScene.VectorTypesExt

GetMovement GXS.Movement

GetMovement GXS.Movement

GetNextIsoline GXS.Isolines

GetNGDDynamic GXS.NGDManager

GetNGDStatic GXS.NGDManager

Global function
GetOdeDynamic GXS.ODEManager

GetODEHeightField GXS.ODEManager

Get and GetOrCreate functions for ODE HeightField
GetOdeStatic GXS.ODEManager

Get and GetOrCreate functions for ode behaviours
GetOrCreateAcceleration GXS.Behaviours

GetOrCreateAcceleration GXS.Behaviours

Returns or creates the TgxBAcceleration within the given behaviours. This helper function is convenient way to access a TgxBAcceleration.
GetOrCreateCollision GXS.Collision

Returns or creates the TgxBCollision within the given behaviours. This helper function is convenient way to access a TgxBCollision.
GetOrCreateCollision GXS.Collision

Returns or creates the TgxBCollision within the given object's behaviours. This helper function is convenient way to access a TgxBCollision.
GetOrCreateDCEDynamic GXS.DCE

GetOrCreateDCEDynamic GXS.DCE

GetOrCreateDCEStatic GXS.DCE

GetOrCreateDCEStatic GXS.DCE

GetOrCreateFireFX GXS.FireFX

Returns or creates the TgxBFireFX within the given behaviours. This helper function is convenient way to access a TgxBFireFX.
GetOrCreateFireFX GXS.FireFX

Returns or creates the TgxBFireFX within the given object's behaviours. This helper function is convenient way to access a TgxBFireFX.
GetOrCreateFPSMovement GXS.FPSMovement

GetOrCreateFPSMovement GXS.FPSMovement

GetOrCreateInertia GXS.Behaviours

GetOrCreateInertia GXS.Behaviours

GetOrCreateMovement GXS.Movement

GetOrCreateMovement GXS.Movement

GetOrCreateNGDDynamic GXS.NGDManager

GetOrCreateNGDStatic GXS.NGDManager

GetOrCreateOdeDynamic GXS.ODEManager

GetOrCreateODEHeightField GXS.ODEManager

GetOrCreateOdeStatic GXS.ODEManager

GetOrCreateParticleInertia GXS.PhysInertias

Returns or creates the TgxParticleInertia within the given behaviours. This helper function is convenient way to access a TgxParticleInertia.
GetOrCreateParticleInertia GXS.PhysInertias

Returns or creates the TgxParticleInertia within the given object's behaviours. This helper function is convenient way to access a TgxParticleInertia.
GetOrCreateRigidBodyInertia GXS.PhysInertias

Returns or creates the TgxRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.
GetOrCreateRigidBodyInertia GXS.PhysInertias

Returns or creates the TgxRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.
GetOrCreateSoundEmitter GXS.SoundManager

GetOrCreateSoundEmitter GXS.SoundManager

GetOrCreateSourcePFX GXS.ParticleFX

Returns or creates the TgxBInertia within the given object's behaviours.
GetOrCreateThorFX GXS.ThorFX

Returns or creates the TgxBThorFX within the given object's effects.
GetOrdValue GXS.RegisterXCollection

GetOrdValueAt GXS.RegisterXCollection

GetProcAddressGLLib GXS.OpenGLAdapter

GetProcAddressGLS GXS.OpenGLAdapter

GetQuaternionRec GLScene.VectorTypesExt

GetRasterFileFormats GXS.Graphics

Read access to the list of registered vector file formats
GetResultsNx GXS.PhysX

GetROAMTrianglesCapacity GXS.ROAMPatch

GetSafeTurnAngle GLScene.VectorGeometry

GetSafeTurnAngle GLScene.VectorGeometry

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles
GetServiceWindow GXS.Context

GetSoundLibraryByName GXS.SoundManager

GetSqrt255Array GLScene.Utils

Returns a pointer to an array containing the results of "255*sqrt(i/255)".
GetSurfaceFromObject GXS.ODEManager

GetTextureCombiners GXS.TextureCombiners

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment. Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color

Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.
GetTextureElementSize GLScene.TextureFormat

GetTextureElementSize GLScene.TextureFormat

Give a pixel size in bytes from texture format or data format
GetTextureImageClassesAsStrings GXS.Texture

Creates a TStrings with the list of registered TgxTextureImageClass. To be freed by caller.
GetUncompressedFormat GLScene.TextureFormat

Give uncompressed texture format and OpenGL color format
GetUniformAutoSetMethod GXSL.Parameter

GetUniformAutoSetMethod GXSL.ShaderParameter

GetUniformAutoSetMethodName GXSL.Parameter

GetUniformAutoSetMethodName GXSL.ShaderParameter

GetValueFromStringsIndex GLScene.Utils

GetVectorFileFormats GXS.VectorFileObjects

Read access to the list of registered vector file formats
GetVectorRec GLScene.VectorTypesExt

GetXCollectionClassesList GLScene.XCollection

GetXCollectionItemClassesList GLScene.XCollection

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.
glAccum GLScene.OpenGL4

GL functions and procedures
glAlphaFunc GLScene.OpenGL4

deprecated;
glAreTexturesResident GLScene.OpenGL4

deprecated;
glArrayElement GLScene.OpenGL4

deprecated;
glBegin GLScene.OpenGL4

deprecated;
glBindTexture GLScene.OpenGL4

deprecated;
glBitmap GLScene.OpenGL4

glBlendFunc GLScene.OpenGL4

deprecated;
glCallList GLScene.OpenGL4

glCallLists GLScene.OpenGL4

deprecated;
glClear GLScene.OpenGL4

deprecated;
glClearAccum GLScene.OpenGL4

glClearColor GLScene.OpenGL4

deprecated;
glClearDepth GLScene.OpenGL4

glClearIndex GLScene.OpenGL4

glClearStencil GLScene.OpenGL4

deprecated;
glClipPlane GLScene.OpenGL4

glColor3b GLScene.OpenGL4

deprecated;
glColor3bv GLScene.OpenGL4

deprecated;
glColor3d GLScene.OpenGL4

deprecated;
glColor3dv GLScene.OpenGL4

deprecated;
glColor3f GLScene.OpenGL4

deprecated;
glColor3fv GLScene.OpenGL4

deprecated;
glColor3i GLScene.OpenGL4

deprecated;
glColor3iv GLScene.OpenGL4

deprecated;
glColor3s GLScene.OpenGL4

deprecated;
glColor3sv GLScene.OpenGL4

deprecated;
glColor3ub GLScene.OpenGL4

deprecated;
glColor3ubv GLScene.OpenGL4

deprecated;
glColor3ui GLScene.OpenGL4

deprecated;
glColor3uiv GLScene.OpenGL4

deprecated;
glColor3us GLScene.OpenGL4

deprecated;
glColor3usv GLScene.OpenGL4

deprecated;
glColor4b GLScene.OpenGL4

deprecated;
glColor4bv GLScene.OpenGL4

deprecated;
glColor4d GLScene.OpenGL4

deprecated;
glColor4dv GLScene.OpenGL4

deprecated;
glColor4f GLScene.OpenGL4

deprecated;
glColor4fv GLScene.OpenGL4

deprecated;
glColor4i GLScene.OpenGL4

deprecated;
glColor4iv GLScene.OpenGL4

deprecated;
glColor4s GLScene.OpenGL4

deprecated;
glColor4sv GLScene.OpenGL4

deprecated;
glColor4ub GLScene.OpenGL4

deprecated;
glColor4ubv GLScene.OpenGL4

deprecated;
glColor4ui GLScene.OpenGL4

deprecated;
glColor4uiv GLScene.OpenGL4

deprecated;
glColor4us GLScene.OpenGL4

deprecated;
glColor4usv GLScene.OpenGL4

deprecated;
glColorMask GLScene.OpenGL4

deprecated;
glColorMaterial GLScene.OpenGL4

glColorPointer GLScene.OpenGL4

deprecated;
glCopyPixels GLScene.OpenGL4

deprecated;
glCopyTexImage1D GLScene.OpenGL4

deprecated;
glCopyTexImage2D GLScene.OpenGL4

glCopyTexSubImage1D GLScene.OpenGL4

glCopyTexSubImage2D GLScene.OpenGL4

glCullFace GLScene.OpenGL4

glDeleteLists GLScene.OpenGL4

glDeleteTextures GLScene.OpenGL4

deprecated;
glDepthFunc GLScene.OpenGL4

glDepthMask GLScene.OpenGL4

glDepthRange GLScene.OpenGL4

glDisable GLScene.OpenGL4

glDisableClientState GLScene.OpenGL4

glDrawArrays GLScene.OpenGL4

deprecated;
glDrawBuffer GLScene.OpenGL4

glDrawElements GLScene.OpenGL4

glDrawPixels GLScene.OpenGL4

glEdgeFlag GLScene.OpenGL4

deprecated;
glEdgeFlagPointer GLScene.OpenGL4

deprecated;
glEdgeFlagv GLScene.OpenGL4

deprecated;
glEnable GLScene.OpenGL4

deprecated;
glEnableClientState GLScene.OpenGL4

glEnd GLScene.OpenGL4

deprecated;
glEndList GLScene.OpenGL4

deprecated;
glEvalCoord1d GLScene.OpenGL4

deprecated;
glEvalCoord1dv GLScene.OpenGL4

deprecated;
glEvalCoord1f GLScene.OpenGL4

deprecated;
glEvalCoord1fv GLScene.OpenGL4

deprecated;
glEvalCoord2d GLScene.OpenGL4

deprecated;
glEvalCoord2dv GLScene.OpenGL4

deprecated;
glEvalCoord2f GLScene.OpenGL4

deprecated;
glEvalCoord2fv GLScene.OpenGL4

deprecated;
glEvalMesh1 GLScene.OpenGL4

deprecated;
glEvalMesh2 GLScene.OpenGL4

deprecated;
glEvalPoint1 GLScene.OpenGL4

deprecated;
glEvalPoint2 GLScene.OpenGL4

deprecated;
glFeedbackBuffer GLScene.OpenGL4

deprecated;
glFinish GLScene.OpenGL4

deprecated;
glFlush GLScene.OpenGL4

glFogf GLScene.OpenGL4

glFogfv GLScene.OpenGL4

deprecated;
glFogi GLScene.OpenGL4

deprecated;
glFogiv GLScene.OpenGL4

deprecated;
glFrontFace GLScene.OpenGL4

deprecated;
glFrustum GLScene.OpenGL4

glGenLists GLScene.OpenGL4

deprecated;
glGenTextures GLScene.OpenGL4

deprecated;
glGetBooleanv GLScene.OpenGL4

glGetClipPlane GLScene.OpenGL4

GLGetCursorPos GXS.Screen

glGetDoublev GLScene.OpenGL4

deprecated;
glGetError GLScene.OpenGL4

glGetFloatv GLScene.OpenGL4

glGetIntegerv GLScene.OpenGL4

glGetLightfv GLScene.OpenGL4

glGetLightiv GLScene.OpenGL4

deprecated;
glGetMapdv GLScene.OpenGL4

deprecated;
glGetMapfv GLScene.OpenGL4

deprecated;
glGetMapiv GLScene.OpenGL4

deprecated;
glGetMaterialfv GLScene.OpenGL4

deprecated;
glGetMaterialiv GLScene.OpenGL4

deprecated;
glGetPixelMapfv GLScene.OpenGL4

deprecated;
glGetPixelMapuiv GLScene.OpenGL4

deprecated;
glGetPixelMapusv GLScene.OpenGL4

deprecated;
glGetPointerv GLScene.OpenGL4

deprecated;
glGetPolygonStipple GLScene.OpenGL4

GLGetProcAddress GLScene.OpenGL4

——————————————————————————
GLGetScreenHeight GXS.Screen

GLGetScreenWidth GXS.Screen

glGetString GLScene.OpenGL4

deprecated;
glGetTexEnvfv GLScene.OpenGL4

glGetTexEnviv GLScene.OpenGL4

deprecated;
glGetTexGendv GLScene.OpenGL4

deprecated;
glGetTexGenfv GLScene.OpenGL4

deprecated;
glGetTexGeniv GLScene.OpenGL4

deprecated;
glGetTexImage GLScene.OpenGL4

deprecated;
glGetTexLevelParameterfv GLScene.OpenGL4

glGetTexLevelParameteriv GLScene.OpenGL4

glGetTexParameterfv GLScene.OpenGL4

glGetTexParameteriv GLScene.OpenGL4

glHint GLScene.OpenGL4

glIndexd GLScene.OpenGL4

deprecated;
glIndexdv GLScene.OpenGL4

deprecated;
glIndexf GLScene.OpenGL4

deprecated;
glIndexfv GLScene.OpenGL4

deprecated;
glIndexi GLScene.OpenGL4

deprecated;
glIndexiv GLScene.OpenGL4

deprecated;
glIndexMask GLScene.OpenGL4

glIndexPointer GLScene.OpenGL4

deprecated;
glIndexs GLScene.OpenGL4

deprecated;
glIndexsv GLScene.OpenGL4

deprecated;
glIndexub GLScene.OpenGL4

deprecated;
glIndexubv GLScene.OpenGL4

deprecated;
glInitNames GLScene.OpenGL4

deprecated;
glInterleavedArrays GLScene.OpenGL4

deprecated;
glIsEnabled GLScene.OpenGL4

deprecated;
glIsList GLScene.OpenGL4

glIsTexture GLScene.OpenGL4

GLLibMaterialPicker FMXLibMaterialPicker

glLightf GLScene.OpenGL4

deprecated;
glLightfv GLScene.OpenGL4

deprecated;
glLighti GLScene.OpenGL4

deprecated;
glLightiv GLScene.OpenGL4

deprecated;
glLightModelf GLScene.OpenGL4

glLightModelfv GLScene.OpenGL4

deprecated;
glLightModeli GLScene.OpenGL4

deprecated;
glLightModeliv GLScene.OpenGL4

deprecated;
glLineStipple GLScene.OpenGL4

deprecated;
glLineWidth GLScene.OpenGL4

deprecated;
glListBase GLScene.OpenGL4

GLLoadBitmapFromInstance GXS.ImageUtils

glLoadIdentity GLScene.OpenGL4

deprecated;
glLoadMatrixd GLScene.OpenGL4

deprecated;
glLoadMatrixf GLScene.OpenGL4

deprecated;
glLoadName GLScene.OpenGL4

deprecated;
glLogicOp GLScene.OpenGL4

deprecated;
glMap1d GLScene.OpenGL4

glMap1f GLScene.OpenGL4

deprecated;
glMap2d GLScene.OpenGL4

deprecated;
glMap2f GLScene.OpenGL4

deprecated;
glMapGrid1d GLScene.OpenGL4

deprecated;
glMapGrid1f GLScene.OpenGL4

deprecated;
glMapGrid2d GLScene.OpenGL4

deprecated;
glMapGrid2f GLScene.OpenGL4

deprecated;
glMaterialf GLScene.OpenGL4

deprecated;
glMaterialfv GLScene.OpenGL4

deprecated;
glMateriali GLScene.OpenGL4

deprecated;
glMaterialiv GLScene.OpenGL4

deprecated;
glMatrixMode GLScene.OpenGL4

deprecated;
glMultMatrixd GLScene.OpenGL4

deprecated;
glMultMatrixf GLScene.OpenGL4

deprecated;
glNewList GLScene.OpenGL4

deprecated;
glNormal3b GLScene.OpenGL4

deprecated;
glNormal3bv GLScene.OpenGL4

deprecated;
glNormal3d GLScene.OpenGL4

deprecated;
glNormal3dv GLScene.OpenGL4

deprecated;
glNormal3f GLScene.OpenGL4

deprecated;
glNormal3fv GLScene.OpenGL4

deprecated;
glNormal3i GLScene.OpenGL4

deprecated;
glNormal3iv GLScene.OpenGL4

deprecated;
glNormal3s GLScene.OpenGL4

deprecated;
glNormal3sv GLScene.OpenGL4

deprecated;
glNormalPointer GLScene.OpenGL4

deprecated;
GLOKMessageBox GXS.ImageUtils

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.
glOrtho GLScene.OpenGL4

deprecated;
glPassThrough GLScene.OpenGL4

deprecated;
glPixelMapfv GLScene.OpenGL4

deprecated;
glPixelMapuiv GLScene.OpenGL4

deprecated;
glPixelMapusv GLScene.OpenGL4

deprecated;
glPixelStoref GLScene.OpenGL4

deprecated;
glPixelStorei GLScene.OpenGL4

glPixelTransferf GLScene.OpenGL4

glPixelTransferi GLScene.OpenGL4

deprecated;
glPixelZoom GLScene.OpenGL4

deprecated;
glPointSize GLScene.OpenGL4

deprecated;
glPolygonMode GLScene.OpenGL4

glPolygonOffset GLScene.OpenGL4

glPolygonStipple GLScene.OpenGL4

glPopAttrib GLScene.OpenGL4

deprecated;
glPopClientAttrib GLScene.OpenGL4

deprecated;
glPopMatrix GLScene.OpenGL4

deprecated;
glPopName GLScene.OpenGL4

deprecated;
glPrioritizeTextures GLScene.OpenGL4

deprecated;
glPushAttrib GLScene.OpenGL4

deprecated;
glPushClientAttrib GLScene.OpenGL4

deprecated;
glPushMatrix GLScene.OpenGL4

deprecated;
glPushName GLScene.OpenGL4

deprecated;
glRasterPos2d GLScene.OpenGL4

deprecated;
glRasterPos2dv GLScene.OpenGL4

deprecated;
glRasterPos2f GLScene.OpenGL4

deprecated;
glRasterPos2fv GLScene.OpenGL4

deprecated;
glRasterPos2i GLScene.OpenGL4

deprecated;
glRasterPos2iv GLScene.OpenGL4

deprecated;
glRasterPos2s GLScene.OpenGL4

deprecated;
glRasterPos2sv GLScene.OpenGL4

deprecated;
glRasterPos3d GLScene.OpenGL4

deprecated;
glRasterPos3dv GLScene.OpenGL4

deprecated;
glRasterPos3f GLScene.OpenGL4

deprecated;
glRasterPos3fv GLScene.OpenGL4

deprecated;
glRasterPos3i GLScene.OpenGL4

deprecated;
glRasterPos3iv GLScene.OpenGL4

deprecated;
glRasterPos3s GLScene.OpenGL4

deprecated;
glRasterPos3sv GLScene.OpenGL4

deprecated;
glRasterPos4d GLScene.OpenGL4

deprecated;
glRasterPos4dv GLScene.OpenGL4

deprecated;
glRasterPos4f GLScene.OpenGL4

deprecated;
glRasterPos4fv GLScene.OpenGL4

deprecated;
glRasterPos4i GLScene.OpenGL4

deprecated;
glRasterPos4iv GLScene.OpenGL4

deprecated;
glRasterPos4s GLScene.OpenGL4

deprecated;
glRasterPos4sv GLScene.OpenGL4

deprecated;
glReadBuffer GLScene.OpenGL4

deprecated;
glReadPixels GLScene.OpenGL4

glRectd GLScene.OpenGL4

glRectdv GLScene.OpenGL4

deprecated;
glRectf GLScene.OpenGL4

deprecated;
glRectfv GLScene.OpenGL4

deprecated;
glRecti GLScene.OpenGL4

deprecated;
glRectiv GLScene.OpenGL4

deprecated;
glRects GLScene.OpenGL4

deprecated;
glRectsv GLScene.OpenGL4

deprecated;
glRenderMode GLScene.OpenGL4

deprecated;
glRotated GLScene.OpenGL4

glRotatef GLScene.OpenGL4

deprecated;
glScaled GLScene.OpenGL4

deprecated;
glScalef GLScene.OpenGL4

deprecated;
glScissor GLScene.OpenGL4

deprecated;
glSelectBuffer GLScene.OpenGL4

GLSetCursorPos GXS.Screen

glShadeModel GLScene.OpenGL4

deprecated;
GLShowCursor GXS.Screen

GLSLogger GLScene.Logger

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).
GLSLTypeComponentCount GXSL.ShaderParameter

GLSLTypeEnum GXSL.ShaderParameter

glStencilFunc GLScene.OpenGL4

deprecated;
glStencilMask GLScene.OpenGL4

glStencilOp GLScene.OpenGL4

GLStrToFloatDef GLScene.Utils

GLStrToFloatDef GLScene.Utils

GLStrToFloatDef GLScene.Utils

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...
glTexCoord1d GLScene.OpenGL4

glTexCoord1dv GLScene.OpenGL4

deprecated;
glTexCoord1f GLScene.OpenGL4

deprecated;
glTexCoord1fv GLScene.OpenGL4

deprecated;
glTexCoord1i GLScene.OpenGL4

deprecated;
glTexCoord1iv GLScene.OpenGL4

deprecated;
glTexCoord1s GLScene.OpenGL4

deprecated;
glTexCoord1sv GLScene.OpenGL4

deprecated;
glTexCoord2d GLScene.OpenGL4

deprecated;
glTexCoord2dv GLScene.OpenGL4

deprecated;
glTexCoord2f GLScene.OpenGL4

deprecated;
glTexCoord2fv GLScene.OpenGL4

deprecated;
glTexCoord2i GLScene.OpenGL4

deprecated;
glTexCoord2iv GLScene.OpenGL4

deprecated;
glTexCoord2s GLScene.OpenGL4

deprecated;
glTexCoord2sv GLScene.OpenGL4

deprecated;
glTexCoord3d GLScene.OpenGL4

deprecated;
glTexCoord3dv GLScene.OpenGL4

deprecated;
glTexCoord3f GLScene.OpenGL4

deprecated;
glTexCoord3fv GLScene.OpenGL4

deprecated;
glTexCoord3i GLScene.OpenGL4

deprecated;
glTexCoord3iv GLScene.OpenGL4

deprecated;
glTexCoord3s GLScene.OpenGL4

deprecated;
glTexCoord3sv GLScene.OpenGL4

deprecated;
glTexCoord4d GLScene.OpenGL4

deprecated;
glTexCoord4dv GLScene.OpenGL4

deprecated;
glTexCoord4f GLScene.OpenGL4

deprecated;
glTexCoord4fv GLScene.OpenGL4

deprecated;
glTexCoord4i GLScene.OpenGL4

deprecated;
glTexCoord4iv GLScene.OpenGL4

deprecated;
glTexCoord4s GLScene.OpenGL4

deprecated;
glTexCoord4sv GLScene.OpenGL4

deprecated;
glTexCoordPointer GLScene.OpenGL4

deprecated;
glTexEnvf GLScene.OpenGL4

deprecated;
glTexEnvfv GLScene.OpenGL4

deprecated;
glTexEnvi GLScene.OpenGL4

deprecated;
glTexEnviv GLScene.OpenGL4

deprecated;
glTexGend GLScene.OpenGL4

deprecated;
glTexGendv GLScene.OpenGL4

deprecated;
glTexGenf GLScene.OpenGL4

deprecated;
glTexGenfv GLScene.OpenGL4

deprecated;
glTexGeni GLScene.OpenGL4

deprecated;
glTexGeniv GLScene.OpenGL4

deprecated;
glTexImage1D GLScene.OpenGL4

deprecated;
glTexImage2D GLScene.OpenGL4

glTexParameterf GLScene.OpenGL4

glTexParameterfv GLScene.OpenGL4

glTexParameteri GLScene.OpenGL4

glTexParameteriv GLScene.OpenGL4

glTexSubImage1D GLScene.OpenGL4

glTexSubImage2D GLScene.OpenGL4

glTranslated GLScene.OpenGL4

glTranslatef GLScene.OpenGL4

deprecated;
gluBeginCurve GLScene.OpenGL4

gluBeginCurve GXS.OpenGLAdapter

gluBeginPolygon GLScene.OpenGL4

gluBeginPolygon GXS.OpenGLAdapter

gluBeginSurface GLScene.OpenGL4

gluBeginSurface GXS.OpenGLAdapter

gluBeginTrim GLScene.OpenGL4

gluBeginTrim GXS.OpenGLAdapter

gluBuild1DMipmaps GLScene.OpenGL4

gluBuild1DMipmaps GXS.OpenGLAdapter

gluBuild2DMipmaps GLScene.OpenGL4

gluBuild2DMipmaps GXS.OpenGLAdapter

gluCylinder GLScene.OpenGL4

gluCylinder GXS.OpenGLAdapter

gluDeleteNurbsRenderer GLScene.OpenGL4

gluDeleteNurbsRenderer GXS.OpenGLAdapter

gluDeleteQuadric GLScene.OpenGL4

gluDeleteQuadric GXS.OpenGLAdapter

gluDeleteTess GLScene.OpenGL4

gluDeleteTess GXS.OpenGLAdapter

gluDisk GLScene.OpenGL4

gluDisk GXS.OpenGLAdapter

gluEndCurve GLScene.OpenGL4

gluEndCurve GXS.OpenGLAdapter

gluEndPolygon GLScene.OpenGL4

gluEndPolygon GXS.OpenGLAdapter

gluEndSurface GLScene.OpenGL4

gluEndSurface GXS.OpenGLAdapter

gluEndTrim GLScene.OpenGL4

gluEndTrim GXS.OpenGLAdapter

gluErrorString GLScene.OpenGL4

GLU utility functions and procedures
gluErrorString GXS.OpenGLAdapter

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';
gluGetNurbsProperty GLScene.OpenGL4

gluGetNurbsProperty GXS.OpenGLAdapter

gluGetString GLScene.OpenGL4

gluGetString GXS.OpenGLAdapter

gluGetTessProperty GLScene.OpenGL4

gluGetTessProperty GXS.OpenGLAdapter

gluLoadSamplingMatrices GLScene.OpenGL4

gluLoadSamplingMatrices GXS.OpenGLAdapter

gluLookAt GLScene.OpenGL4

gluLookAt GXS.OpenGLAdapter

gluNewNurbsRenderer GLScene.OpenGL4

gluNewNurbsRenderer GXS.OpenGLAdapter

gluNewQuadric GLScene.OpenGL4

gluNewQuadric GXS.OpenGLAdapter

gluNewTess GLScene.OpenGL4

gluNewTess GXS.OpenGLAdapter

gluNextContour GLScene.OpenGL4

gluNextContour GXS.OpenGLAdapter

gluNurbsCallback GLScene.OpenGL4

gluNurbsCallback GXS.OpenGLAdapter

gluNurbsCurve GLScene.OpenGL4

gluNurbsCurve GXS.OpenGLAdapter

gluNurbsProperty GLScene.OpenGL4

gluNurbsProperty GXS.OpenGLAdapter

gluNurbsSurface GLScene.OpenGL4

gluNurbsSurface GXS.OpenGLAdapter

gluOrtho2D GLScene.OpenGL4

gluOrtho2D GXS.OpenGLAdapter

gluPartialDisk GLScene.OpenGL4

gluPartialDisk GXS.OpenGLAdapter

gluPerspective GLScene.OpenGL4

gluPerspective GXS.OpenGLAdapter

gluPickMatrix GLScene.OpenGL4

gluPickMatrix GXS.OpenGLAdapter

gluProject GLScene.OpenGL4

gluProject GXS.OpenGLAdapter

gluPwlCurve GLScene.OpenGL4

gluPwlCurve GXS.OpenGLAdapter

gluQuadricCallback GLScene.OpenGL4

gluQuadricCallback GXS.OpenGLAdapter

gluQuadricDrawStyle GLScene.OpenGL4

gluQuadricDrawStyle GXS.OpenGLAdapter

gluQuadricNormals GLScene.OpenGL4

gluQuadricNormals GXS.OpenGLAdapter

gluQuadricOrientation GLScene.OpenGL4

gluQuadricOrientation GXS.OpenGLAdapter

gluQuadricTexture GLScene.OpenGL4

gluQuadricTexture GXS.OpenGLAdapter

gluScaleImage GLScene.OpenGL4

gluScaleImage GXS.OpenGLAdapter

gluSphere GLScene.OpenGL4

gluSphere GXS.OpenGLAdapter

gluTessBeginContour GLScene.OpenGL4

gluTessBeginContour GXS.OpenGLAdapter

gluTessBeginPolygon GLScene.OpenGL4

gluTessBeginPolygon GXS.OpenGLAdapter

gluTessCallback GLScene.OpenGL4

gluTessCallback GXS.OpenGLAdapter

gluTessEndContour GLScene.OpenGL4

gluTessEndContour GXS.OpenGLAdapter

gluTessEndPolygon GLScene.OpenGL4

gluTessEndPolygon GXS.OpenGLAdapter

gluTessNormal GLScene.OpenGL4

gluTessNormal GXS.OpenGLAdapter

gluTessProperty GLScene.OpenGL4

gluTessProperty GXS.OpenGLAdapter

gluTessVertex GLScene.OpenGL4

gluTessVertex GXS.OpenGLAdapter

gluUnProject GLScene.OpenGL4

gluUnProject GXS.OpenGLAdapter

glVertex2d GLScene.OpenGL4

deprecated;
glVertex2dv GLScene.OpenGL4

deprecated;
glVertex2f GLScene.OpenGL4

deprecated;
glVertex2fv GLScene.OpenGL4

deprecated;
glVertex2i GLScene.OpenGL4

deprecated;
glVertex2iv GLScene.OpenGL4

deprecated;
glVertex2s GLScene.OpenGL4

deprecated;
glVertex2sv GLScene.OpenGL4

deprecated;
glVertex3d GLScene.OpenGL4

deprecated;
glVertex3dv GLScene.OpenGL4

deprecated;
glVertex3f GLScene.OpenGL4

deprecated;
glVertex3fv GLScene.OpenGL4

deprecated;
glVertex3i GLScene.OpenGL4

deprecated;
glVertex3iv GLScene.OpenGL4

deprecated;
glVertex3s GLScene.OpenGL4

deprecated;
glVertex3sv GLScene.OpenGL4

deprecated;
glVertex4d GLScene.OpenGL4

deprecated;
glVertex4dv GLScene.OpenGL4

deprecated;
glVertex4f GLScene.OpenGL4

deprecated;
glVertex4fv GLScene.OpenGL4

deprecated;
glVertex4i GLScene.OpenGL4

deprecated;
glVertex4iv GLScene.OpenGL4

deprecated;
glVertex4s GLScene.OpenGL4

deprecated;
glVertex4sv GLScene.OpenGL4

deprecated;
glVertexPointer GLScene.OpenGL4

deprecated;
glViewport GLScene.OpenGL4

deprecated;
GLXLTypeComponentCount GXSL.Parameter

GLXLTypeEnum GXSL.Parameter

GraphicClassForExtension GXS.PictureRegisteredFormats

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'
GUIComponentDialog FMxSkinEditor

HackTPictureRegisteredFormats GXS.PictureRegisteredFormats

Adds to the passed TStrings the list of registered Formatx. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').
HalfToFloat GLScene.Utils

ILength GLScene.VectorGeometry

ILength GLScene.VectorGeometry

Computes an integer length Result:=Sqrt(x*x+y*y)
ImageAlphaBottomRightPointColorTransparent GXS.ImageUtils

ImageAlphaFromIntensity GXS.ImageUtils

ImageAlphaInverseLuminance GXS.ImageUtils

ImageAlphaInverseLuminanceSqrt GXS.ImageUtils

ImageAlphaLuminance GXS.ImageUtils

ImageAlphaLuminanceSqrt GXS.ImageUtils

ImageAlphaOpaque GXS.ImageUtils

ImageAlphaSuperBlackTransparent GXS.ImageUtils

ImageAlphaTopLeftPointColorTransparent GXS.ImageUtils

ImageBellFilter GXS.ImageUtils

ImageBoxFilter GXS.ImageUtils

in VCL -> sAllFilter;
ImageHermiteFilter GXS.ImageUtils

ImageLanczos3Filter GXS.ImageUtils

ImageMitchellFilter GXS.ImageUtils

ImageSplineFilter GXS.ImageUtils

ImageTriangleFilter GXS.ImageUtils

IncludeInClipRect GLScene.GeometryBB

Extend the clip rect to include given coordinate.
IncreaseCoherency GXS.MeshUtils

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).
InflateGLRect GLScene.Utils

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.
InformationDlg GXS.ImageUtils

Pops up a simple dialog with msg and an Ok button.
Init GLScene.VectorTypesExt

InitializeRandomGenerator GXS.RandomHDS

Initialize_Contouring GXS.Isolines

InitNx GXS.PhysX

InitOpenGL GLScene.OpenGL4

InitOpenGL GXS.OpenGLAdapter

InitOpenGLFromLibrary GLScene.OpenGL4

InitOpenGLFromLibrary GXS.OpenGLAdapter

InitTexture GXSL.CustomShader

InputDlg GXS.ImageUtils

Posp a simple dialog with a string input.
InteractionIHM uGBEUtils3D

InternalFormatToOpenGLFormat GLScene.TextureFormat

Give a openGL texture format from GLScene texture format
InterpolateCombined GLScene.VectorGeometry

InterpolateCombinedFast GLScene.VectorGeometry

InterpolateCombinedFastPower GLScene.VectorGeometry

InterpolateCombinedSafe GLScene.VectorGeometry

InterpolateExp GLScene.VectorGeometry

InterpolateLn GLScene.VectorGeometry

InterpolatePower GLScene.VectorGeometry

There functions that do the same as "Lerp", but add some distortions
InterpolateSin GLScene.VectorGeometry

Only valid where Delta belongs to [0..1]
InterpolateSinAlt GLScene.VectorGeometry

"Alt" functions are valid everywhere
InterpolateTan GLScene.VectorGeometry

IntersectAABBs GLScene.GeometryBB

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system
IntersectAABBsAbsolute GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide.
IntersectAABBsAbsoluteXY GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.
IntersectAABBsAbsoluteXZ GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.
IntersectCubes GXS.Collision

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.
IntersectGLRect GLScene.Utils

IntersectLinePlane GLScene.VectorGeometry

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988
IntersectSphereBox GLScene.VectorGeometry

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube
IntersectTriangleBox GLScene.VectorGeometry

Compute intersection between a triangle and a box. Returns True if an intersection was found
InvertMatrix GLScene.VectorGeometry

Finds the inverse of a 3x3 matrix;
InvertMatrix GLScene.VectorGeometry

Finds the inverse of a 4x4 matrix
InvertTrianglesWinding GXS.MeshUtils

Inverts the triangles winding (vertex order).
InvokeInfoForm GXS.Scene

IsCgProfileSupported GXS.CgShader

Misc. global functions
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsColinear GLScene.VectorGeometry

Returns true if both vector are colinear
IsCompressedFormat GLScene.TextureFormat

IsCompressedFormat GLScene.TextureFormat

True if texture compressed
IsDepthFormat GLScene.TextureFormat

IsDepthFormat GLScene.TextureFormat

True if depth texture
IsDirectoryWriteable GLScene.Utils

Determine if the directory is writable.
IsFloatFormat GLScene.TextureFormat

IsFloatFormat GLScene.TextureFormat

True if texture format is float
IsFogEnabled GXSL.CustomShader

IsFormatSupported GLScene.TextureFormat

True if texture format is supported by hardware or software
IsInCube GLScene.VectorGeometry

IsInCube GLScene.VectorGeometry

Returns True if p is in the cube defined by d.
IsInRange GLScene.VectorGeometry

IsInRange GLScene.VectorGeometry

Returns True if x is in [a; b]
IsInRect GXS.Gui

IsKeyDown GLScene.Keyboard

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.
IsKeyDown GLScene.Keyboard

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).
IsLineIntersectQuad GLScene.VectorGeometry

Returns true if line intersect ABCD quad. Quad have to be flat and convex
IsLineIntersectTriangle GLScene.VectorGeometry

Returns true if line intersect ABC triangle
IsMainThread GXS.Context

IsMesaGL GLScene.OpenGL4

IsMesaGL GXS.OpenGLAdapter

IsOpenGLInitialized GLScene.OpenGL4

IsOpenGLInitialized GXS.OpenGLAdapter

IsOpenGLLoaded GLScene.OpenGL4

IsOpenGLLoaded GXS.OpenGLAdapter

IsOpenGLVersionMet GLScene.OpenGL4

IsPointInPolygon GLScene.VectorGeometry

PtInRegion
IsPowerOf2 GLScene.Utils

Returns True if value is a true power of two
ISqrt GLScene.VectorGeometry

Computes an integer sqrt approximation
IsServiceContextAvaible GXS.Context

IsSubComponent GLScene.Utils

Classes.pas
IsTargetSupported GLScene.TextureFormat

IsTargetSupported GLScene.TextureFormat

True if texture target supported
IsTargetSupportMipmap GLScene.TextureFormat

IsTargetSupportMipmap GLScene.TextureFormat

IsVersionMet GLScene.OpenGL4

IsVersionMet GXS.OpenGLAdapter

IsVolumeClipped GLScene.VectorGeometry

IsVolumeClipped GLScene.VectorGeometry

IsVolumeClipped GLScene.VectorGeometry

Determines if volume is clipped or not
KeyboardNotifyWheelMoved GLScene.Keyboard

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed
KeyNameToVirtualKeyCode GLScene.Keyboard

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.
KeyPressed GLScene.Keyboard

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.
Lerp GLScene.VectorGeometry

Calculates linear interpolation between start and stop at point t
Linear_Interpolate GXS.Perlin

Useless for final output! Usefull for after interpolation, as its FAST!
LineLineDistance GLScene.VectorGeometry

Computes the closest distance between two lines
LnGamma GLScene.RandomLib

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988
LoadAnsiStringFromFile GLScene.Utils

Returns the ansistring content of "filename".
LoadComponentFromFile GLScene.Utils

Loads component from a file.
LoadOpenGL GLScene.OpenGL4

LoadOpenGL GXS.OpenGLAdapter

LoadOpenGLFromLibrary GLScene.OpenGL4

LoadOpenGLFromLibrary GXS.OpenGLAdapter

LoadQ3Anims Formatx.Q3MD3

LoadQ3Anims Formatx.Q3MD3

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'
LoadQ3Skin Formatx.Q3MD3

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.
LoadRGBEpixels GLScene.RGBE

LoadRLEpixels GLScene.RGBE

LoadStringFromFile GLScene.Utils

Returns the string content of "filename".
Logarithm2 GLScene.VectorGeometry

—————————————————————————- Exponential functions —————————————————————————–
MakeAffineDblVector GLScene.VectorGeometry

Miscellaneous functions
MakeDblVector GLScene.VectorGeometry

MakeParallelProjectionMatrix GLScene.VectorGeometry

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction
MakePoint GLScene.VectorGeometry

MakePoint GLScene.VectorGeometry

MakePoint GLScene.VectorGeometry

MakeReflectionMatrix GLScene.VectorGeometry

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)
MakeShadowMatrix GLScene.VectorGeometry

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos
MakeSubComponent GLScene.Utils

MakeTriangleAdjacencyList GXS.MeshUtils

Create list of indices of triangles with adjacency from triangle list
MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MakeVector GLScene.VectorGeometry

MaterialEditorForm FMxMaterialEditor

MatrixDecompose GLScene.VectorGeometry

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.
MatrixDeterminant GLScene.VectorGeometry

Determinant of a 3x3 matrix
MatrixDeterminant GLScene.VectorGeometry

Determinant of a 4x4 matrix
MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

MatrixEquals GLScene.VectorGeometry

3x3
MatrixEquals GLScene.VectorGeometry

4x4
MatrixInvert GLScene.VectorGeometry

MatrixInvert GLScene.VectorGeometry

MatrixLerp GLScene.VectorGeometry

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.
MatrixMultiply GLScene.VectorGeometry

Multiplies M1 by M2 and places result in MResult
MatrixMultiply GLScene.VectorGeometry

Multiplies two 3x3 matrices
MatrixMultiply GLScene.VectorGeometry

Multiplies two 4x4 matrices
MaxAbsXYZComponent GLScene.VectorGeometry

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)
MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

MaxFloat GLScene.VectorGeometry

Returns the maximum of given values.
MaxFloat GLScene.VectorGeometry

Returns the maximum value of the array.
MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxInteger GLScene.VectorGeometry

MaxVector GLScene.VectorGeometry

MaxVector GLScene.VectorGeometry

Replace components of v with the max of v or v1 component. Maximum is computed per component
MaxXYZComponent GLScene.VectorGeometry

MaxXYZComponent GLScene.VectorGeometry

Returns the max of the X, Y and Z components of a vector (W is ignored)
MinAbsXYZComponent GLScene.VectorGeometry

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)
MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

MinFloat GLScene.VectorGeometry

Returns the minimum of given values.
MinFloat GLScene.VectorGeometry

Returns the minimum value of the array.
MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinInteger GLScene.VectorGeometry

MinPositiveCoef GLScene.Polynomials

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.
MinVector GLScene.VectorGeometry

MinVector GLScene.VectorGeometry

Replace components of v with the min of v or v1 component. Minimum is computed per component
MinXYZComponent GLScene.VectorGeometry

MinXYZComponent GLScene.VectorGeometry

Returns the min of the X, Y and Z components of a vector (W is ignored)
MixerCouleurPixel uGBEImageUtils

MoveObjectAround GLScene.VectorGeometry

Extracted from Camera.MoveAroundTarget(pitch, turn)
MultiTexturing uGBEImageUtils

MultiTexturingZone uGBEImageUtils

nearCallBack GXS.ODEManager

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer
NegateVector GLScene.VectorGeometry

Negates the vector
NegateVector GLScene.VectorGeometry

Negates the vector
NegateVector GLScene.VectorGeometry

Negates the vector
NoisyColor GXS.RandomHDS

function LoadJPGtexture(const JpgName: string): tBitmap;
NormalizeAngle GLScene.VectorGeometry

Normalize to an angle in the [-PI; +PI] range
NormalizeDegAngle GLScene.VectorGeometry

Normalize to an angle in the [-180; 180] range
NormalizeMatrix GLScene.VectorGeometry

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)
NormalizePlane GLScene.VectorGeometry

Normalize a plane so that point evaluation = plane distance. }
NormalizeQuaternion GLScene.VectorGeometry

Normalizes the given quaternion
NormalizeVector GLScene.VectorGeometry

Returns the vector transformed to unit length Transforms a vector to unit length
NormalizeVector GLScene.VectorGeometry

Transforms a vector to unit length
NormalizeVector GLScene.VectorGeometry

Transforms a vector to unit length
NormalizeVectorArray GLScene.VectorGeometry

Transforms vectors to unit length
ObjectManager GXS.SceneRegister

Auto-create for object manager
ODERToSceneMatrix GXS.ODEUtils

ODERToSceneMatrix GXS.ODEUtils

ODERToSceneMatrix GXS.ODEUtils

OffsetAABB GLScene.GeometryBB

OffsetAABB GLScene.GeometryBB

Adds delta to min and max of the AABB.
OffsetBB GLScene.GeometryBB

OffsetBB GLScene.GeometryBB

Adds delta to min and max of the BB.
OffsetBBPoint GLScene.GeometryBB

The same as above but uses AddPoint() instead of AddVector().
OffsetFloatArray GLScene.VectorGeometry

OffsetFloatArray GLScene.VectorGeometry

OffsetFloatArray GLScene.VectorGeometry

Adds delta to values in the array. Array size must be a multiple of four
OpenGLFormatToInternalFormat GLScene.TextureFormat

Give a GLScene texture format from openGL texture format
OpenPictureDialog GXS.ImageUtils

Pops up a simple open picture dialog.
OptimizeMesh GXS.MeshOptimizer

OptimizeMesh GXS.MeshOptimizer

OptimizeMesh GXS.MeshOptimizer

OptimizeMesh GXS.MeshOptimizer

PackRotationMatrix GLScene.VectorGeometry

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition
ParseFloat GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.
ParseInteger GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.
Perlin_Random1 GXS.Perlin

just a random controlled by X
Perlin_Random1DStrip GXS.Perlin

generates a random strip
Perlin_Random2 GXS.Perlin

just a random controlled by X,Y
Pitch GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its X-axis
Pitch GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterRight
PixelFormatToColorBits GXS.ImageUtils

Returns the number of color bits associated to the given pixel format.
PlaneAABBIntersection GLScene.GeometryBB

Compute the intersection between a plane and the AABB
PlaneContainsBSphere GLScene.GeometryBB

Determines to which extent a plane contains a BSphere
PlaneEvaluatePoint GLScene.VectorGeometry

PlaneEvaluatePoint GLScene.VectorGeometry

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.
PlaneIntersectAABB GLScene.GeometryBB

Checks if a plane (given by the normal+d) intersects the AABB
PlaneMake GLScene.VectorGeometry

PlaneMake GLScene.VectorGeometry

PlaneMake GLScene.VectorGeometry

Computes the parameters of a plane defined by a point and a normal.
PlaneMake GLScene.VectorGeometry

Computes the parameters of a plane defined by three points.
PlayOnWaveOut GXS.Sounds.WaveOut

PlayOnWaveOut GXS.Sounds.WaveOut

PlaySound uGBESound

PointAdd GLScene.VectorGeometry

Returns the sum of two homogeneous vectors. W coordinate is always 1.
PointDiskOrthoProjection GLScene.VectorGeometry

Computes point to disk projection. Direction has to be normalized
PointDiskProjection GLScene.VectorGeometry

PointInAABB GLScene.GeometryBB

PointInAABB GLScene.GeometryBB

Checks if a point "p" is inside an AABB
PointInPolygon GLScene.VectorGeometry

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary
PointIsInHalfSpace GLScene.VectorGeometry

PointIsInHalfSpace GLScene.VectorGeometry

PointIsInHalfSpace GLScene.VectorGeometry

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.
PointLineClosestPoint GLScene.VectorGeometry

Computes closest point on a line
PointLineDistance GLScene.VectorGeometry

Computes algebraic distance between point and line
PointMake GLScene.VectorGeometry

PointMake GLScene.VectorGeometry

PointMake GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

PointPlaneDistance GLScene.VectorGeometry

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.
PointPlaneOrthoProjection GLScene.VectorGeometry

Computes point to plane projection. Plane and direction have to be normalized
PointPlaneProjection GLScene.VectorGeometry

PointProject GLScene.VectorGeometry

PointProject GLScene.VectorGeometry

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line
PointQuadOrthoProjection GLScene.VectorGeometry

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex
PointQuadProjection GLScene.VectorGeometry

PointSegmentClosestPoint GLScene.VectorGeometry

PointSegmentClosestPoint GLScene.VectorGeometry

Computes closest point on a segment (a segment is a limited line)
PointSegmentDistance GLScene.VectorGeometry

Computes algebraic distance between segment and line (a segment is a limited line)
PointTriangleOrthoProjection GLScene.VectorGeometry

Computes point to triangle projection. Direction has to be normalized
PointTriangleProjection GLScene.VectorGeometry

PolygonArea GLScene.VectorGeometry

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex
PolygonSignedArea GLScene.VectorGeometry

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex
PositionSceneObject GXS.ODEUtils

PositionSceneObjectForGeom GXS.ODEUtils

PowerInt64 GLScene.VectorGeometry

PowerInteger GLScene.VectorGeometry

Raise base to an integer
PowerSingle GLScene.VectorGeometry

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0
PrecisionTimerLap GLScene.Utils

Computes time elapsed since timer start. Return time lap in seconds.
PrepareSinCosCache GLScene.VectorGeometry

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.
PrimerIsland GXS.RandomHDS

PrimerNull GXS.RandomHDS

Landscape primers
Project GLScene.VectorGeometry

QuaternionConjugate GLScene.VectorGeometry

Returns the conjugate of a quaternion
QuaternionFromAngleAxis GLScene.VectorGeometry

Constructs quaternion from angle (in deg) and axis
QuaternionFromEuler GLScene.VectorGeometry

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)
QuaternionFromMatrix GLScene.VectorGeometry

Constructs a unit quaternion from a rotation matrix
QuaternionFromPoints GLScene.VectorGeometry

Constructs a unit quaternion from two points on unit sphere
QuaternionFromRollPitchYaw GLScene.VectorGeometry

Constructs quaternion from Euler angles
QuaternionMagnitude GLScene.VectorGeometry

Returns the magnitude of the quaternion
QuaternionMake GLScene.VectorGeometry

QuaternionMake GLScene.VectorGeometry

QuaternionMake GLScene.VectorGeometry

Creates a quaternion from the given values
QuaternionMultiply GLScene.VectorGeometry

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond
QuaternionSlerp GLScene.VectorGeometry

QuaternionSlerp GLScene.VectorGeometry

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve
QuaternionToAffineMatrix GLScene.VectorGeometry

Constructs an affine rotation matrix from (possibly non-unit) quaternion
QuaternionToMatrix GLScene.VectorGeometry

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations
QuaternionToPoints GLScene.VectorGeometry

Converts a unit quaternion into two points on a unit sphere
QueryPerformanceCounter GLScene.Utils

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.
QueryPerformanceFrequency GLScene.Utils

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.
QuestionDlg GXS.ImageUtils

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".
RadianToDeg GLScene.VectorGeometry

RadianToDeg GLScene.VectorGeometry

RaiseLastOSError GLScene.Utils

RaiseOpenGLError GLScene.OpenGL4

Clears all pending OpenGL errors
RandEmpiric GLScene.RandomLib

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]
RandExponent GLScene.RandomLib

RandGauss GLScene.RandomLib

Marsaglia-Bray algorithm
RandLogNorm GLScene.RandomLib

RandNorm GLScene.RandomLib

RandomColorVector GXS.ODEUtils

RandomPointOnSphere GLScene.VectorGeometry

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction
Random_Beta GLScene.RandomLib

Random_Beta GLScene.RandomLib

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)
Random_Binomial1 GLScene.RandomLib

Random_Binomial1 GLScene.RandomLib

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.
Random_Binomial2 GLScene.RandomLib

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.
Random_Binomial2 GLScene.RandomLib

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.

Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P
Random_Cauchy GLScene.RandomLib

Random_Cauchy GLScene.RandomLib

Generate a random deviate from the standard Cauchy distribution
Random_ChiSq GLScene.RandomLib

Random_ChiSq GLScene.RandomLib

Generates a random variate from the chi-squared distribution with dff degrees of freedom.
Random_Exponential GLScene.RandomLib

Random_Exponential GLScene.RandomLib

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.
Random_Gamma GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)
Random_Gamma GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).
Random_Gamma1 GLScene.RandomLib

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.
Random_Inv_Gauss GLScene.RandomLib

Random_Inv_Gauss GLScene.RandomLib

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.

h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)
Random_LogNormal GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.
Random_LogNormal GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.
Random_MVNorm GLScene.RandomLib

Random_MVNorm GLScene.RandomLib

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.

ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)

D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise
Random_Neg_Binomial GLScene.RandomLib

Random_Neg_Binomial GLScene.RandomLib

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.
Random_Normal GLScene.RandomLib

Random_Normal GLScene.RandomLib

Random_Normal GLScene.RandomLib

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves
Random_Normal GLScene.RandomLib

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance
Random_Poisson GLScene.RandomLib

Random_Poisson GLScene.RandomLib

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179

TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL
Random_T GLScene.RandomLib

Random_T GLScene.RandomLib

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)
Random_von_Mises GLScene.RandomLib

Random_von_Mises GLScene.RandomLib

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.
Random_Weibull GLScene.RandomLib

Random_Weibull GLScene.RandomLib

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e
RandUniform GLScene.RandomLib

RandUniform GLScene.RandomLib

Uniform Random single numbers in RLow..RHigh range
RasterFileFormatExtensionByIndex GXS.Graphics

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.
RayCastAABBIntersect GLScene.GeometryBB

RayCastAABBIntersect GLScene.GeometryBB

Finds the intersection between a ray and an axis aligned bounding box.
RayCastBoxIntersect GLScene.VectorGeometry

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil
RayCastIntersectsSphere GLScene.VectorGeometry

Determines if a ray will intersect with a given sphere
RayCastMinDistToPoint GLScene.VectorGeometry

Compute the min distance a ray will pass to a point
RayCastPlaneIntersect GLScene.VectorGeometry

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil
RayCastPlaneXZIntersect GLScene.VectorGeometry

RayCastSphereIntersect GLScene.VectorGeometry

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)
RayCastTriangleIntersect GLScene.VectorGeometry

Compute intersection between a ray and a triangle
ReadCRLFString GLScene.Utils

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.
ReadExtensions GLScene.OpenGL4

ReadImplementationProperties GLScene.OpenGL4

ReadLine GLScene.Logger

ReadScreenImage GXS.Screen

ReadVideoModes GXS.Screen

ReadWGLExtensions GLScene.OpenGL4

ReadWGLImplementationProperties GLScene.OpenGL4

RectangleContains GLScene.VectorGeometry

Determine if BigRect completely contains SmallRect
RectanglesIntersect GLScene.VectorGeometry

Determine if 2 rectanges intersect
RectEquals GLScene.VectorGeometry

True if all components are equal.
Register GBE.Clouds

Register GBE.ConeExtend

Register GBE.CubeExtend

Register GBE.Cubemap

Register GBE.CylinderExtend

Register GBE.Grass

Register GBE.Heightmap

Register GBE.Joystick

Register GBE.omOceanWaves

compatibility w/ old forms
Register GBE.PlaneExtend

Register GBE.PlayerPosition

Register GBE.SphereExtend

Register GBE.Terrain

Register GBE.TimeLine

Register GBE.Viewport3D

Register GLScene.XCollectionRegister

Register GXS.CgRegister

ToDo DesignIntf, not implemented DesignEditors, FMXEditors, for TgxLibMaterialNameProperty
Register GXS.DwsObjects

Register GXS.FullScreenViewer

Register GXS.GPURegister

ToolsAPI, STREDIT,
Register GXS.ParallelRegister

ToolsAPI, STREDIT,
Register GXS.Physics.Register

GXS.PhysManager todo
Register GXS.Python.Script

Register GXS.RegisterXCollection

Register GXS.SceneRegister

Register GXS.Sounds.Register

Register omSailSurface

Register SDLx.Context

Register SDLx.Window

The following function has been commented out to encourage developers to use SDL_getenv as it it more portable function getenv(const name: PAnsiChar): PAnsiChar; ———————————————————————
Register VXS.DWSScene

RegisterArchiveFormat GXS.ArchiveManager

RegisterBaseSceneObjectNameChangeEvent GXS.Scene

Register an event handler triggered by any TgxBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FSceneEdit in the IDE.
RegisterBehaviourNameChangeEvent GXS.Scene

Register an event handler triggered by any TgxBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.
RegisterContextClass GXS.Context

Drivers should register themselves via this function.
RegisterCUDAComponentNameChangeEvent GXS.CUDA.API

RegisterGLXceneObject GXS.ODEManager

GLODEObject register methods (used for joint object persistence)
RegisterInfoForm GXS.Scene

Registers the procedure call used to invoke the info form.
RegisterManager GLScene.Manager

RegisterRasterFormat GXS.Graphics

RegisterSoundFileFormat GXS.SoundFileObjects

RegisterTextureImageClass GXS.Texture

Register a TgxTextureImageClass (used for persistence and IDE purposes)
RegisterTextureImageEditor GXS.TextureImageEditors

RegisterTGraphicClassFileExtension GXS.Texture

RegisterUniformAutoSetMethod GXSL.Parameter

RegisterUniformAutoSetMethod GXSL.ShaderParameter

RegisterVectorFileFormat GXS.VectorFileObjects

RegisterXCollectionDestroyEvent GLScene.XCollection

Registers an event to be called when an XCollection is destroyed
RegisterXCollectionItemClass GLScene.XCollection

Registers a TXCollectionItem subclass for persistence requirements
RelativePath GLScene.Utils

Remove if possible part of path witch leads to project executable.
ReleaseCUDAEditorForm FMxCUDAEditor

ReleaseFontManager GXS.SpaceText

ReleaseLibMaterialPicker FMXLibMaterialPicker

ReleaseMaterialEditorForm FMxMaterialEditor

ReleaseNx GXS.PhysX

ReleaseSceneEditorForm FMxSceneEditor

ReleaseShaderEditor FMxShaderMemo

ReleaseShaderUniformEditor FMxShaderUniformEditor

ReleaseXCollectionEditor FMxXCollectionEditor

Release_Memory_Isoline GXS.Isolines

RemapAndCleanupReferences GXS.MeshUtils

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.
remapIndices GXS.MeshUtils

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RemapIndicesToIndicesMap GXS.MeshUtils

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)
RemapReferences GXS.MeshUtils

RemapReferences GXS.MeshUtils

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.
RemapTrianglesIndices GXS.MeshUtils

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RenderAABB GXS.SpatialPartitioning

RenderAABB GXS.SpatialPartitioning

Renders an AABB as a line
RenderGeomList GXS.ODEUtils

RenderSpatialPartitioning GXS.SpatialPartitioning

Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation
RePlaySound uGBESound

RescaleImage GXS.ImageUtils

RestoreDefaultMode GXS.Screen

RGB24ToRGBA32 GXS.Graphics

Rgbe2float GLScene.RGBE

RLength GLScene.VectorGeometry

Computes 1/Sqrt(Sqr(x)+Sqr(y)).
Roll GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Z-axis
Roll GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterDirection
RotateVector GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians
RotateVector GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians
RotateVectorAroundY GLScene.VectorGeometry

Rotate given vector around the Y axis (alpha is in rad)
RoundDownToPowerOf2 GLScene.Utils

Round down to the nearest power of two, value must be strictly positive
RoundInt GLScene.VectorGeometry

RoundInt GLScene.VectorGeometry

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.
RoundUpToPowerOf2 GLScene.Utils

Round ups to the nearest power of two, value must be positive
RSqrt GLScene.VectorGeometry

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)
RstVector GLScene.VectorGeometry

RstVector GLScene.VectorGeometry

SafeCurrentContext GXS.Context

SaveAnsiStringToFile GLScene.Utils

Saves ansistring "data" to "filename".
SaveComponentToFile GLScene.Utils

Saves component to a file.
SavePictureDialog GXS.ImageUtils

Pops up a simple save picture dialog.
SaveStringToFile GLScene.Utils

Saves string "data" to "filename".
ScaleAndRound GLScene.VectorGeometry

Multiples i by s and returns the rounded result.
ScaleFloatArray GLScene.VectorGeometry

ScaleFloatArray GLScene.VectorGeometry

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available
ScaleMatrix GLScene.VectorGeometry

Multiplies all elements of a 3x3 matrix with a factor
ScaleMatrix GLScene.VectorGeometry

Multiplies all elements of a 4x4 matrix with a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by a factor
ScaleVector GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
ScaleVector GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
SceneDirectionFromGeom GXS.ODEUtils

SceneEditorForm FMxSceneEditor

SceneMatrixFromGeom GXS.ODEUtils

SceneMatrixToODER GXS.ODEUtils

SDK_Version GXS.PhysX

SDL_getenv SDLx.Window

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;
SDL_putenv SDLx.Window

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;
SegmentPlaneIntersection GLScene.VectorGeometry

Computes segment / plane intersection return false if there isn't an intersection
SegmentSegmentClosestPoint GLScene.VectorGeometry

Computes the closest points (2) given two segments
SegmentSegmentDistance GLScene.VectorGeometry

Computes the closest distance between two segments
SetAABB GLScene.GeometryBB

SetActorCMassGlobalPosition GXS.PhysX

SetActorGlobalOrientation GXS.PhysX

SetActorGlobalPosition GXS.PhysX

SetActorMass GXS.PhysX

SetAffineVector GLScene.VectorGeometry

SetBB GLScene.GeometryBB

SetExeDirectory GLScene.Utils

SetFullscreenMode GXS.Screen

Changes to the video mode given by 'Index'
SetMatrix GLScene.VectorGeometry

SetMatrix GLScene.VectorGeometry

SetMatrix GLScene.VectorGeometry

—————————————————————————- Matrix functions —————————————————————————-
SetMatrixRow GLScene.VectorGeometry

SetPlane GLScene.VectorGeometry

Converts from single to double representation
SetROAMTrianglesCapacity GXS.ROAMPatch

Specifies the maximum number of ROAM triangles that may be allocated.
SetScreenSaverPassword GXS.ScreenSaver

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.
SetTextureImageClassesToStrings GXS.Texture

Defines a TStrings with the list of registered TgxTextureImageClass.
setTransform GXS.ODEUtils

SetupTangentSpace GXS.BumpMapping

SetupVSync GXS.SceneViewer

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SetVector GLScene.VectorGeometry

SFChmutov1 GXS.Isosurface

Chmutov-surface-1 (http://mathworld.wolfram.com)
SFChmutov2 GXS.Isosurface

Chmutov-surface-2 (http://mathworld.wolfram.com)
SFDoubleTorus GXS.Isosurface

Double torus Surface (phantasy!)
SFKleinBottle GXS.Isosurface

Klein Bottle (http://mathworld.wolfram.com)
SFMinkowski GXS.Isosurface

Minkowski space (http://mathworld.wolfram.com)
SFSphere GXS.Isosurface

Sphere surface
SFToroidal GXS.Isosurface

Toroidal surface (phantasy!)
ShaderEditorForm FMxShaderMemo

ShaderUniformEditorForm FMxShaderUniformEditor

ShiftObjectFromCenter GLScene.VectorGeometry

ShiftObjectFromCenter GLScene.VectorGeometry

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center
ShowHTMLUrl GLScene.Utils

SignStrict GLScene.VectorGeometry

Returns the sign of the x value using the (-1, 0, +1) convention
SimulateNx GXS.PhysX

SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius
SinCosine GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius
SizeOf3D uGBEUtils3D

SizeOfFile GLScene.Utils

Returns the size of "filename". Returns 0 (zero) is file does not exists.
Smooth_Interpolate_Strip GXS.Perlin

smooth interpolate 3 strips into one...
SolveCubic GLScene.Polynomials

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3
SolveQuadric GLScene.Polynomials

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2
SolveQuartic GLScene.Polynomials

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4
SortArrayAscending GLScene.VectorGeometry

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...
SphereVisibleRadius GLScene.VectorGeometry

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.
StarRecordColor GXS.Skydome

Computes star color from BV index (RGB) and magnitude (alpha).
StarRecordPositionYUp GXS.Skydome

Computes position on the unit sphere of a star record (Y=up).
StarRecordPositionZUp GXS.Skydome

Computes position on the unit sphere of a star record (Z=up).
StartAllMovements GXS.Movement

StartPrecisionTimer GLScene.Utils

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.
StopAllMovements GXS.Movement

StopPrecisionTimer GLScene.Utils

Computes time elapsed since timer start and stop timer. Return time lap in seconds.
Str2Float GLScene.Utils

Trying to read string otherwise using '.' as Decimal Separator
StringToColorAdvanced GXS.ImageUtils

Converts a string into color
StringToColorAdvancedSafe GXS.ImageUtils

Converts a string into color
StripifyMesh GXS.MeshUtils

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TgxIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.
StrToFloatDef GLScene.Utils

Similar to SysUtils.StrToFloatDef, but ignores user's locale
StrToResType GXS.ApplicationFileIO

SubdivideTriangles GXS.MeshUtils

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
SubtractVector GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1
TexPointArrayAdd GLScene.VectorGeometry

Adds delta to nb texpoints in src and places result in dest
TexPointArrayScaleAndAdd GLScene.VectorGeometry

TexPointCombine GLScene.VectorGeometry

Makes a linear combination of two texpoints
TexpointEquals GLScene.VectorGeometry

True if all components are equal.
TexPointLerp GLScene.VectorGeometry

Calculates linear interpolation between texpoint1 and texpoint2 at point t
TexPointMake GLScene.VectorGeometry

————————————————————————– Vector functions ————————————————————————–
TextureBlue GXS.RandomHDS

TextureBrownSoil GXS.RandomHDS

TextureDarkGray GXS.RandomHDS

TextureDarkGreen GXS.RandomHDS

TextureGreen GXS.RandomHDS

TextureSand GXS.RandomHDS

TextureWhite GXS.RandomHDS

TileImage uGBEImageUtils

TranslateMatrix GLScene.VectorGeometry

TranslateMatrix GLScene.VectorGeometry

Adds the translation vector into the matrix
TransposeMatrix GLScene.VectorGeometry

Computes transpose of 3x3 matrix
TransposeMatrix GLScene.VectorGeometry

Computes transpose of 4x4 matrix
TriangleArea GLScene.VectorGeometry

Computes the triangle's area
TriangleElevationSegments GXS.Isolines

Defines contouring segments inside a triangle using elevations
TriangleIntersectAABB GLScene.GeometryBB

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB
TriangleSignedArea GLScene.VectorGeometry

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored
TrimAndSplitVersionString GLScene.OpenGL4

TrimAndSplitVersionString GXS.OpenGLAdapter

TryStringToColorAdvanced GXS.ImageUtils

Converts a string into color
Turn GLScene.VectorGeometry

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis
Turn GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterUp
Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

Tweener GLScene.AnimationUtils

UnApplyBlendingModeEx GXSL.CustomShader

UnifyTrianglesWinding GXS.MeshUtils

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)
UnloadOpenGL GLScene.OpenGL4

compatibility routines
UnloadOpenGL GXS.OpenGLAdapter

compatibility routines
UnPackRotationMatrix GLScene.VectorGeometry

Restores a packed rotation matrix. See PackRotationMatrix
UnpressGroup GXS.Windows

UnProject GLScene.VectorGeometry

UnregisterArchiveFormat GXS.ArchiveManager

UnregisterGLXceneObject GXS.ODEManager

UnregisterRasterFormat GXS.Graphics

UnregisterSoundFileClass GXS.SoundFileObjects

UnRegisterTextureImageEditor GXS.TextureImageEditors

UnregisterVectorFileClass GXS.VectorFileObjects

UnregisterXCollectionItemClass GLScene.XCollection

Removes a TXCollectionItem subclass from the list
UseCustomGLSLogger GLScene.Logger

UserLog GLScene.Logger

Return logger wich created by TGLSLogger component
Vector2bMake GLScene.VectorGeometry

Vector2bMake GLScene.VectorGeometry

Vector2bMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2dMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

Vector2fMake GLScene.VectorGeometry

2x
Vector2iMake GLScene.VectorGeometry

Vector2iMake GLScene.VectorGeometry

Vector2iMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector2sMake GLScene.VectorGeometry

Vector3bMake GLScene.VectorGeometry

Vector3bMake GLScene.VectorGeometry

Vector3bMake GLScene.VectorGeometry

Vector3dMake GLScene.VectorGeometry

Vector3dMake GLScene.VectorGeometry

Vector3dMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

Vector3fMake GLScene.VectorGeometry

3x
Vector3iMake GLScene.VectorGeometry

Vector3iMake GLScene.VectorGeometry

Vector3iMake GLScene.VectorGeometry

Vector3sMake GLScene.VectorGeometry

Vector3sMake GLScene.VectorGeometry

Vector3sMake GLScene.VectorGeometry

Vector4bMake GLScene.VectorGeometry

Vector4bMake GLScene.VectorGeometry

Vector4bMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4dMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

Vector4fMake GLScene.VectorGeometry

4x
Vector4iMake GLScene.VectorGeometry

Vector4iMake GLScene.VectorGeometry

Vector4iMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

Vector4sMake GLScene.VectorGeometry

VectorAbs GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }
VectorAbs GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }
VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

VectorAdd GLScene.VectorGeometry

Adds two vectors and places result in vr
VectorAdd GLScene.VectorGeometry

Returns the sum of two affine vectors
VectorAdd GLScene.VectorGeometry

Returns the sum of two homogeneous vectors
VectorAdd GLScene.VectorGeometry

Sums up f to each component of the vector
VectorAdd GLScene.VectorGeometry

Sums up f to each component of the vector
VectorAffineDblToFlt GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values
VectorAffineFltToDbl GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values
VectorAngleCombine GLScene.VectorGeometry

VectorAngleCosine GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleCosine GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleLerp GLScene.VectorGeometry

VectorArrayAdd GLScene.VectorGeometry

Adds delta to nb vectors in src and places result in dest
VectorArrayLerp GLScene.VectorGeometry

VectorArrayLerp GLScene.VectorGeometry

VectorArrayLerp GLScene.VectorGeometry

Calculates linear interpolation between vector arrays
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr, F1=1.0
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result
VectorCombine3 GLScene.VectorGeometry

VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCombine3 GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr
VectorDblToFlt GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values
VectorDistance GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)
VectorDistance GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)
VectorDistance2 GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...
VectorDistance2 GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)
VectorDivide GLScene.VectorGeometry

VectorDivide GLScene.VectorGeometry

VectorDivide GXS.EllipseCollision

VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

VectorEquals GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further
VectorEquals GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further
VectorEquals GLScene.VectorGeometry

True if all components are equal.
VectorEquals GLScene.VectorGeometry

True if all components are equal.
VectorFileFormatExtensionByIndex GXS.VectorFileObjects

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.
VectorFileFormatsFilter GXS.VectorFileObjects

A file extension filter suitable for dialog's 'Filter' property
VectorFileFormatsSaveFilter GXS.VectorFileObjects

A file extension filter suitable for a savedialog's 'Filter' property
VectorFltToDbl GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values
VectorIsNull GLScene.VectorGeometry

True if x=y=z=0, w ignored
VectorIsNull GLScene.VectorGeometry

True if x=y=z=0, w ignored
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).
VectorLength GLScene.VectorGeometry

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLerp GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessEqualThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorLessThen GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMake GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreEqualThen GLScene.VectorGeometry

VectorMoreThen GLScene.VectorGeometry

3i
VectorMoreThen GLScene.VectorGeometry

3i
VectorMoreThen GLScene.VectorGeometry

3s
VectorMoreThen GLScene.VectorGeometry

3s
VectorMoreThen GLScene.VectorGeometry

4f
VectorMoreThen GLScene.VectorGeometry

4f
VectorMoreThen GLScene.VectorGeometry

4i
VectorMoreThen GLScene.VectorGeometry

4i
VectorMoreThen GLScene.VectorGeometry

4s
VectorMoreThen GLScene.VectorGeometry

4s
VectorMoreThen GLScene.VectorGeometry

ComparedNumber 3f
VectorMoreThen GLScene.VectorGeometry

Vector comparison functions: 3f
VectorNegate GLScene.VectorGeometry

VectorNegate GLScene.VectorGeometry

Negates the vector
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length
VectorNormalize GLScene.VectorGeometry

Returns the vector transformed to unit length (w component dropped)
VectorPerpendicular GLScene.VectorGeometry

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N
VectorReflect GLScene.VectorGeometry

Reflects vector V against N (assumes N is normalized)
VectorRotateAroundX GLScene.VectorGeometry

Returns given vector rotated around the X axis (alpha is in rad)
VectorRotateAroundY GLScene.VectorGeometry

Returns given vector rotated around the Y axis (alpha is in rad)
VectorRotateAroundY GLScene.VectorGeometry

Returns given vector rotated around the Y axis in vr (alpha is in rad)
VectorRotateAroundZ GLScene.VectorGeometry

Returns given vector rotated around the Z axis (alpha is in rad)
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

Returns a vector scaled by a factor
VectorScale GLScene.VectorGeometry

RScales given vector by another vector
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales a vector by a factor and places result in vr
VectorScale GLScene.VectorGeometry

Scales given vector by another vector
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".
VectorSpacing GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".
VectorSubtract GLScene.VectorGeometry

VectorSubtract GLScene.VectorGeometry

VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Returns V1-V2
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorSubtract GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result
VectorTransform GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix
VectorTransform GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix
VirtualKeyCodeToKeyName GLScene.Keyboard

Converts a virtual key code to its name. The name is expressed using the locale windows options.
WeldVertices GXS.MeshUtils

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)
wglCopyContext GLScene.OpenGL4

wglCopyContext GXS.OpenGLAdapter

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;
wglCreateContext GLScene.OpenGL4

wglCreateContext GXS.OpenGLAdapter

wglCreateLayerContext GLScene.OpenGL4

wglCreateLayerContext GXS.OpenGLAdapter

wglDeleteContext GLScene.OpenGL4

wglDeleteContext GXS.OpenGLAdapter

wglDescribeLayerPlane GLScene.OpenGL4

wglGetCurrentContext GLScene.OpenGL4

wglGetCurrentContext GXS.OpenGLAdapter

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
wglGetCurrentDC GLScene.OpenGL4

wglGetCurrentDC GXS.OpenGLAdapter

wglGetLayerPaletteEntries GLScene.OpenGL4

wglGetProcAddress GLScene.OpenGL4

wglMakeCurrent GLScene.OpenGL4

wglMakeCurrent GXS.OpenGLAdapter

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
wglRealizeLayerPalette GLScene.OpenGL4

wglRealizeLayerPalette GXS.OpenGLAdapter

wglSetLayerPaletteEntries GLScene.OpenGL4

wglShareLists GLScene.OpenGL4

wglShareLists GXS.OpenGLAdapter

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
wglSwapLayerBuffers GLScene.OpenGL4

wglSwapLayerBuffers GXS.OpenGLAdapter

wglSwapMultipleBuffers GLScene.OpenGL4

wglUseFontBitmaps GLScene.OpenGL4

wglUseFontBitmapsA GLScene.OpenGL4

wglUseFontBitmapsW GLScene.OpenGL4

wglUseFontOutlines GLScene.OpenGL4

wglUseFontOutlinesA GLScene.OpenGL4

wglUseFontOutlinesW GLScene.OpenGL4

WordToIntegerArray GLScene.Utils

Copies the values of Source to Dest (converting word values to integer values)
WriteCRLFString GLScene.Utils

Write the string and a CRLF in the stream
XCollectionEditorForm FMxXCollectionEditor

xglAllowSecondTextureUnit GXS.XOpenGL

Allow to use the second texture unit again.
xglBeginUpdate GXS.XOpenGL

Defers xglMap calls execution until xglEndUpdate is met. Calls to Begin/EndUpdate may be nested.
xglEndUpdate GXS.XOpenGL

Applies xglMap calls if there were any since xglBeginUpdate was invoked. Calls to Begin/EndUpdate may be nested.
xglForbidSecondTextureUnit GXS.XOpenGL

Whenever called, 2nd texture units changes will be forbidden to . Use this function when you're using the 2nd texture unit for your own purposes and don't want to alter it.
xglGetBitWiseMapping GXS.XOpenGL

Returns the complex mapping in bitwise form.
xglMapTexCoordToArbitrary GXS.XOpenGL

xglMapTexCoordToArbitrary GXS.XOpenGL

TexCoord functions will define the specified texture units coordinates.
xglMapTexCoordToArbitraryAdd GXS.XOpenGL

xglMapTexCoordToDual GXS.XOpenGL

TexCoord functions will define the two first texture units coordinates.
xglMapTexCoordToMain GXS.XOpenGL

TexCoord functions will define the main texture coordinates.
xglMapTexCoordToNull GXS.XOpenGL

TexCoord functions will be ignored.
xglMapTexCoordToSecond GXS.XOpenGL

TexCoord functions will define the second texture unit coordinates.
xglPopState GXS.XOpenGL

Restores State from the stack.
xglPushState GXS.XOpenGL

Saves State on the stack.


GXSysHelp v.2.5: All Identifiers

All Identifiers

Name

Unit

Description

AABBContainsAABB

GLScene.GeometryBB

Determines to which extent one AABB contains another AABB

AABBContainsBSphere

GLScene.GeometryBB

Determines to which extent an AABB contains a BSpher

AABBFitsInAABBAbsolute

GLScene.GeometryBB

Checks whether one Bounding box aligned with the world axes fits within another Bounding box

AABBFromSweep

GLScene.GeometryBB

Make an AABB that is formed by sweeping a sphere (or AABB) from Start to Dest

AABBInclude

GLScene.GeometryBB

Resize the AABB if necessary to include p.

AABBIntersection

GLScene.GeometryBB

Returns the intersection AABB of two AABBs. If the AABBs don't intersect, will return a degenerated AABB (plane, line or point).

AABBScale

GLScene.GeometryBB

AABBToBB

GLScene.GeometryBB

Converts an AABB to its canonical BB.

AABBToBB

GLScene.GeometryBB

Transforms an AABB to a BB.

AABBToBSphere

GLScene.GeometryBB

Convert an AABB to a BSphere

AABBToClipRect

GLScene.GeometryBB

Projects an AABB and determines the extent of its projection as a clip rect.

AABBTransform

GLScene.GeometryBB

AbsVector

GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }

AbsVector

GLScene.VectorGeometry

Vector components are replaced by their Abs() value. }

ActiveSoundManager

GXS.SoundManager

ActorAddForce

GXS.PhysX

ActorCount

GXS.PhysX

AddAABB

GLScene.GeometryBB

AddBB

GLScene.GeometryBB

Adds a BB into another BB. The original BB (c1) is extended if necessary to contain c2.

AddPoint

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

AddSCODEGeomsToODESpace

GXS.ODESkeletonColliders

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

GLScene.VectorGeometry

Sums up f to each component of the vector

AddVector

GLScene.VectorGeometry

Sums up f to each component of the vector

AddVerletConstriantsToVerletWorld

GXS.VerletTypes

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

AdjointMatrix

GLScene.VectorGeometry

Adjoint of a 3x3 matrix, used in the computation of the inverse of a 3x3 matrix

AdjointMatrix

GLScene.VectorGeometry

Adjoint of a 4x4 matrix, used in the computation of the inverse of a 4x4 matrix

AffineVectorEquals

GLScene.VectorGeometry

True if X, Y and Z components are equal.

AffineVectorMake

GLScene.VectorGeometry

AffineVectorMake

GLScene.VectorGeometry

ALLOC_SIZE

GXS.Isosurface

AlphaGammaBrightCorrection

GXS.ImageUtils

AngleBetweenVectors

GLScene.VectorGeometry

AngleBetweenVectors

GLScene.VectorGeometry

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians

AngleLerp

GLScene.VectorGeometry

Calculates angular interpolation between start and stop at point t

AnglePreservingMatrixInvert

GLScene.VectorGeometry

Finds the inverse of an angle preserving matrix. Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

AnsiStartsText

GLScene.Utils

StrUtils.pas

ApplicationFileIODefined

GXS.ApplicationFileIO

Returns true if an ApplicationFileIO has been defined

ApplyBlendingModeEx

GXSL.CustomShader

Exported procedures.

AppTime

GLScene.Utils

Returns time in milisecond from application start.

ArcCosine

GLScene.VectorGeometry

ArcCreateFileStream

GXS.ArchiveManager

Users getting results after LoadFromFile with this functions

ArcFileStreamExists

GXS.ArchiveManager

ASESetPreferredLightmap

GXS.FileASE

ASESetPreferredTexture

GXS.FileASE

Use this functions to select texture and lightmap from ASE file aSubMaterialIndex = -1 - means main material maps Default are: Texture - main material Diffuse map Lightmap - main material Ambient map

AxesBuildList

GXS.Scene

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

Barycentre

uGBEUtils3D

BBMaxX

GLScene.GeometryBB

BBMaxY

GLScene.GeometryBB

BBMaxZ

GLScene.GeometryBB

BBMinX

GLScene.GeometryBB

BBMinY

GLScene.GeometryBB

BBMinZ

GLScene.GeometryBB

BBToAABB

GLScene.GeometryBB

Extract AABB information from a BB.

BBTransform

GLScene.GeometryBB

BeginFPUOnlySection

GLScene.VectorGeometry

Begins a FPU-only section. You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases. Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

BGR24ToRGB24

GXS.Graphics

BGR24ToRGBA32

GXS.Graphics

BGRA32ToRGBA32

GXS.Graphics

BinormalAttributeName

GXS.Objects

BitmapDataCanalBleu

uGBEImageUtils

BitmapDataCanalNoir

uGBEImageUtils

BitmapDataCanalRouge

uGBEImageUtils

BitmapDataCanalVert

uGBEImageUtils

BitmapScanLine

GXS.ImageUtils

Returns the bitmap's scanline for the specified row.

BoundingBoxesAreEqual

GLScene.GeometryBB

BoundingBoxesAreEqual

GLScene.GeometryBB

—————————————————————————— Bounding Box functions ——————————————————————————

BrightenRGBArray

GXS.Graphics

BSphereContainsAABB

GLScene.GeometryBB

Determines to which extent a BSphere contains an AABB

BSphereContainsBSphere

GLScene.GeometryBB

Determines to which extent one BSphere contains another BSphere

BSphereIntersectsBSphere

GLScene.GeometryBB

Determines if one BSphere intersects another BSphere

BSphereToAABB

GLScene.GeometryBB

BSphereToAABB

GLScene.GeometryBB

BSphereToAABB

GLScene.GeometryBB

Convert a BSphere to an AABB

BufSize

GXS.FileOBJ

Build2DMipmap

GXS.ImageUtils

BuildCube

GXS.MeshBuilder

BuildCylinder

GXS.MeshBuilder

BuildCylinder2

GXS.MeshBuilder

BuildNonOrientedEdgesList

GXS.MeshUtils

Builds a list of non-oriented (non duplicated) edges list. Each edge is represented by the two integers of its vertices, sorted in ascending order. If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.

BuildNormals

GXS.MeshUtils

Builds normals for a triangles list. Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles. Returned list must be freed by caller.

BuildVectorCountOptimizedIndices

GXS.MeshUtils

Builds a vector-count optimized indices list. The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used). The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

c180

GLScene.VectorGeometry

c180divPI

GLScene.VectorGeometry

c2PI

GLScene.VectorGeometry

c360

GLScene.VectorGeometry

c3PIdiv2

GLScene.VectorGeometry

c3PIdiv4

GLScene.VectorGeometry

CalcObjectSpaceLightVectors

GXS.BumpMapping

CalcPlaneNormal

GLScene.VectorGeometry

CalcPlaneNormal

GLScene.VectorGeometry

CalcPlaneNormal

GLScene.VectorGeometry

Calculate the normal of a plane defined by three points.

CalcQuadraticInterpolation

omSailSurface

Quadratic interpolation with 3 points

CalcTangentSpaceLightVectors

GXS.BumpMapping

CalculateHeight

uGBEUtils3D

cAllAttribBits

GXS.State

cAllColorComponents

GXS.State

cAllFrustrumParts

GXS.GeomObjects

cAllMeshPrimitive

GXS.State

cAllStatesChanged

GLScene.PipelineTransform

CBBBack

GLScene.GeometryBB

CBBBottom

GLScene.GeometryBB

CBBFront

GLScene.GeometryBB

CBBLeft

GLScene.GeometryBB

CBBPlans

GLScene.GeometryBB

CBBRight

GLScene.GeometryBB

CBBTop

GLScene.GeometryBB

cbrt

GLScene.Polynomials

Calculates the cube root of its parameter.

cColinearBias

GLScene.VectorGeometry

cDefaultActorOptions

GXS.VectorFileObjects

cDefaultCyborgOptions

GXS.SmartObjects

cDefaultFlareElements

GXS.LensFlare

cDefaultImposterOptions

GXS.Imposter

cDefaultMirrorOptions

GXS.Mirror

cDefaultNormalMapScale

GXS.Texture

cDefaultPointSize

GXS.Objects

cDefaultProxyOptions

GXS.Scene

cDefaultScreenSaverOptions

GXS.ScreenSaver

cDefaultSDLWindowOptions

SDLx.Window

cDefaultShadowPlaneOptions

GXS.ShadowPlane

cDefaultSwizzleVector

GLScene.TextureFormat

cDefaultWaterPlaneOptions

GXS.WaterPlane

cDEFAULT_CONSTRAINT_FRICTION

GXS.VerletTypes

cDEFAULT_TIMER_INTERVAL

GXS.AsyncTimer

CDirPlan

GLScene.GeometryBB

cECCloseDistance

GXS.EllipseCollision

cGLBlendEquationToGLEnum

GXS.State

valid for src only

cGLBlendFunctionToGLEnum

GXS.State

cGLBufferBindingTarget

GXS.State

cGLComparisonFunctionToGLEnum

GXS.State

cGLCullFaceModeToGLEnum

GXS.State

cGLFaceWindingToGLEnum

GXS.State

cGLgsInTypes

GXSL.ShaderParameter

cGLgsOutTypes

GXSL.ShaderParameter

cGLHintToGLEnum

GXS.State

cGLLogicOpToGLEnum

GXS.State

cGLPolygonModeToGLEnum

GXS.State

cGLQueryTypeToGLEnum

GXS.State

cGLStateToGLEnum

GXS.State

cGLStateTypeToGLEnum

GXS.State

cGLStencilOpToGLEnum

GXS.State

cGLTexTypeToGLEnum

GXS.State

cGLXLSamplerString

GXSL.Parameter

cGLXLTypeString

GXSL.Parameter

cGXgsInTypes

GXSL.Parameter

cGXgsOutTypes

GXSL.Parameter

cGXSLSamplerString

GXSL.ShaderParameter

cGXSLTypeString

GXSL.ShaderParameter

CharToVirtualKeyCode

GLScene.Keyboard

Returns the virtual keycode corresponding to the given char. The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

CharToWideChar

GLScene.Utils

CheckOpenGLError

GLScene.OpenGL4

cHTFHashTableSize

GXS.HeightTileFile

cHTFQuadTableSize

GXS.HeightTileFile

cInv2PI

GLScene.VectorGeometry

cInv360

GLScene.VectorGeometry

ClampInteger

GLScene.VectorGeometry

ClampInteger

GLScene.VectorGeometry

ClampValue

GLScene.VectorGeometry

Clamps aValue in the aMin-aMax interval

ClampValue

GLScene.VectorGeometry

Clamps aValue in the aMin-INF interval

ClearGLError

GLScene.OpenGL4

Gets the oldest error and tries to clear the error queue

ClipToAABB

GLScene.GeometryBB

Clips a position to an AABB

cLn10

GLScene.VectorGeometry

CLogSession

GLScene.Logger

Class reference to log session class

ClosedPolygon2D

GLScene.VectorTypesExt

TPolygon3D = record Vertices: array of TPoint3DRec; function Length; end;

ClosedPolygon3D

GLScene.VectorTypesExt

CloseOpenGL

GLScene.OpenGL4

CloseOpenGL

GXS.OpenGLAdapter

cMaxArray

GLScene.VectorGeometry

cMaxContacts

GXS.ODERagdoll

cMaxVerts

GXS.Trail

cMeshModeToGLEnum

GXS.Mesh

CmtNX

GXS.Texture

CmtNY

GXS.Texture

CmtNZ

GXS.Texture

CmtPX

GXS.Texture

CmtPY

GXS.Texture

CmtPZ

GXS.Texture

COctree_GROW_GRAVY

GXS.SpacePartition

COctree_LEAF_TRHESHOLD

GXS.SpacePartition

COctree_MAX_TREE_DEPTH

GXS.SpacePartition

CollideAndSlide

GXS.EllipseCollision

CollideWithWorld

GXS.EllipseCollision

CollisionDummyChilds

uGBEUtils3D

CollisionEntre2Objets

uGBEUtils3D

CombineVector

GLScene.VectorGeometry

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

GLScene.VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CompareInteger

GLScene.RedBlackTree

CompressedInternalFormatToOpenGL

GLScene.TextureFormat

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format

ConeContainsBSphere

GXS.SpacePartition

Determines to which extent one Cone contains an BSphere

cOneHalf

GLScene.VectorGeometry

CONSOLE_MAX_COMMANDS

GXS.Console

ConstArrayToString

GLScene.Logger

ConvertdVector3ToAffineVector

GXS.ODEUtils

ConvertdVector3ToAffineVector

GXS.ODEUtils

ConvertdVector3ToVector3f

GXS.ODEUtils

ConvertdVector3ToVector3f

GXS.ODEUtils

Converting between ODE and Scene formats

ConvertdVector3ToVector4f

GXS.ODEUtils

ConvertdVector3ToVector4f

GXS.ODEUtils

ConvertFansToList

GXS.MeshUtils

ConvertImage

GXS.ImageUtils

ConvertIndexedListToList

GXS.MeshUtils

Expands an indexed structure into a non-indexed structure.

ConvertRotation

GLScene.VectorGeometry

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians)

ConvertStripToList

GXS.MeshUtils

ConvertStripToList

GXS.MeshUtils

ConvertStripToList

GXS.MeshUtils

ConvertStripToList

GXS.MeshUtils

Converts a triangle strips into a triangle list. Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

ConvertVector3fTodVector3

GXS.ODEUtils

Converting between Scene and ODE formats

ConvertVector3fToPdVector3

GXS.ODEUtils

ConvertVector4fTodVector3

GXS.ODEUtils

ConvertVector4fToPdVector3

GXS.ODEUtils

CopyBodyFromCube

GXS.ODEUtils

CopyCubeSizeFromBox

GXS.ODEUtils

CopyPosFromGeomToGX

GXS.ODEUtils

CopyScreentoTexture

GXSL.CustomShader

CopyScreentoTexture2

GXSL.CustomShader

Cosine_Interpolate

GXS.Perlin

does a cosine interpolation

cPERLIN_TABLE_SIZE

GXS.PerlinPFX

cPFXGranularity

GXS.ParticleFX

number of distance regions

cPFXNbRegions

GXS.ParticleFX

cPI

GLScene.VectorGeometry

cPIdiv180

GLScene.VectorGeometry

cPIdiv2

GLScene.VectorGeometry

cPIdiv4

GLScene.VectorGeometry

CreateAffineRotationMatrix

GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateBodyFromCube

GXS.ODEUtils

CreateBox

GXS.PhysX

CreateCylinder

GXS.PhysX

CreateGeomFromCube

GXS.ODEUtils

CreateGraphicFromFile

GXS.Texture

CreateGroundPlane

GXS.PhysX

CreateLookAtMatrix

GLScene.VectorGeometry

CreateMatrixFromFrustum

GLScene.VectorGeometry

CreateObjectSpaceNormalMap

GXS.BumpMapping

CreateODEPlaneFromScenePlane

GXS.ODEUtils

CreateOrthoMatrix

GLScene.VectorGeometry

CreatePerspectiveMatrix

GLScene.VectorGeometry

CreatePickMatrix

GLScene.VectorGeometry

CreateResourceStream

GXS.ApplicationFileIO

CreateRotationMatrix

GLScene.VectorGeometry

CreateRotationMatrix

GLScene.VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateRotationMatrixX

GLScene.VectorGeometry

CreateRotationMatrixX

GLScene.VectorGeometry

Creates matrix for rotation about x-axis (angle in rad)

CreateRotationMatrixY

GLScene.VectorGeometry

CreateRotationMatrixY

GLScene.VectorGeometry

Creates matrix for rotation about y-axis (angle in rad)

CreateRotationMatrixZ

GLScene.VectorGeometry

CreateRotationMatrixZ

GLScene.VectorGeometry

Creates matrix for rotation about z-axis (angle in rad)

CreateScaleAndTranslationMatrix

GLScene.VectorGeometry

Creates a scale+translation matrix. Scale is applied BEFORE applying offset

CreateScaleMatrix

GLScene.VectorGeometry

Creates scale matrix

CreateScaleMatrix

GLScene.VectorGeometry

Creates scale matrix

CreateSphere

GXS.PhysX

CreateTangentSpaceNormalMap

GXS.BumpMapping

CreateTempWnd

GXS.WinContext

CreateTranslationMatrix

GLScene.VectorGeometry

Creates translation matrix

CreateTranslationMatrix

GLScene.VectorGeometry

Creates translation matrix

CreateTriMeshFromBaseMesh

GXS.ODEUtils

This method requires you to manually deallocate vertices and indices when you're done with the trimesh

CreateVerletPlaneFromGLPlane

GXS.VerletTypes

CropImage

uGBEImageUtils

CSG_Operation

GXS.MeshCSG

cTilesHashSize

GXS.TerrainRenderer

CubeWireframeBuildList

GXS.Objects

Issues for a unit-size cube stippled wireframe.

Cubic_Interpolate

GXS.Perlin

does a cubic interpolation

Cubic_Interpolate_Strip

GXS.Perlin

cubic interpolate 4 strips into one...

CUDAContextManager

GXS.CUDA.Context

Static class of CUDA contexts manager.

CUDAEditorForm

FMxCUDAEditor

CurrentContext

GXS.Context

The TgxContext that is the currently active context, if any. Returns nil if no context is active.

cVertexModeToGLEnum

GXS.Mesh

C_LMTS_ID

GXS.FileLMTS

C_LMTS_SUBS

GXS.FileLMTS

C_LMTS_TEXFNLEN

GXS.FileLMTS

C_LMTS_TEXT

GXS.FileLMTS

C_LMTS_TRIS

GXS.FileLMTS

C_LMTS_VER

GXS.FileLMTS

DAMP_SHIFT

GXS.ProcTextures

dBodyToBodyDistance

GXS.ODEUtils

DCEBox

GXS.DCEMisc

DebugMode

GXS.PhysInertias

Debug_tri

GXS.EllipseCollision

.$DEFINE DEBUG

DecodeTextureTarget

GLScene.TextureFormat

DegToRadian

GLScene.VectorGeometry

DegToRadian

GLScene.VectorGeometry

—————————————————————————- Trigonometric functions —————————————————————————-

DeRegisterBaseSceneObjectNameChangeEvent

GXS.Scene

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.

DeRegisterBehaviourNameChangeEvent

GXS.Scene

Deregister an event handler triggered by any TgxBaseSceneObject Name change. See RegisterVKBaseSceneObjectNameChangeEvent.

DeRegisterCUDAComponentNameChangeEvent

GXS.CUDA.API

DeRegisterManager

GLScene.Manager

DeRegisterXCollectionDestroyEvent

GLScene.XCollection

DeRegisters event

DerivatedPolynom

GLScene.Polynomials

Calculates the polynom's derivative

DetectionCollisionObstacle

uGBEUtils3D

DistanceBetweenAngles

GLScene.VectorGeometry

Calculates the angular distance between two angles in radians. Result is in the [0; PI] range.

Div2

GXS.Graphics

DivideVector

GLScene.VectorGeometry

DivideVector

GLScene.VectorGeometry

Divides given vector by another vector. v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

DivMod

GLScene.VectorGeometry

DLL

GXS.PhysX

DoTesselate

GXS.PolygonTesselation

Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.

DrawBox

GXS.ODEUtils

DrawContours

GXS.ROAMPatch

Draw contours on rendering terrain patches

DrawTexturedScreenQuad

GXSL.CustomShader

Probably need to give them proper names, instead of numbers...

DrawTexturedScreenQuad2

GXSL.CustomShader

DrawTexturedScreenQuad3

GXSL.CustomShader

DrawTexturedScreenQuad4

GXSL.CustomShader

DrawTexturedScreenQuad5

GXSL.CustomShader

DrawTexturedScreenQuad6

GXSL.CustomShader

dsDrawBox

GXS.ODEUtils

dsDrawBox

GXS.ODEUtils

DTriangle

GLScene.Triangulation

Created Triangles, vv# are the vertex pointers

dVector3Length

GXS.ODEUtils

dVector3Length

GXS.ODEUtils

DVertex

GLScene.Triangulation

Points (Vertices)

ECAddBox

GXS.DCEMisc

Add a TriMesh box

ECAddEllipsoid

GXS.DCEMisc

Add a static ellipsoid

ECAddFreeForm

GXS.DCEMisc

Add freeform's octree data

ECAddTerrain

GXS.DCEMisc

Add the terrain as a TriMesh

ECGxBombShaderException

GXS.CgBombShader

ECGxShaderException

GXS.CgShader

Define OutputCompilerWarnings to output CG compiler warnings to a file. Useful for detecting bugs caused by using uninitialized value, implicit type cast, etc.

ECResetColliders

GXS.DCEMisc

Set the collider lists to null

ECSetCollisionRange

GXS.DCEMisc

Calculate and set the collision range

ECustomShaderException

GXSL.CustomShader

EDDSException

Formatx.DDSImage

EditTextureImage

GXS.TextureImageEditors

Invokes the editor for the given TgxTextureImage

EFilerException

GLScene.XCollection

EGLAtmosphereException

GXS.Atmosphere

EGLCameraController

GXS.CameraController

EGLConsoleException

GXS.Console

EGLFile3DS

GXS.File3DS

EGLImageUtils

GXS.ImageUtils

EGLMotionBlurException

GXS.Blur

EGLOBJFileError

GXS.FileOBJ

EGLOSError

GLScene.Utils

EGLPostShaderHolderException

GXSL.PostEffects

EGLROAMException

GXS.ROAMPatch

GL_ARB_vertex_buffer_object Exception use by splitter for SafeTesselation

EGLUtilsException

GLScene.Utils

EgxInvalidVectorFile

GXS.VectorFileObjects

EgxslBumpShaderException

GXSL.BumpShaders

EgxslDiffuseSpecularShaderException

GXSL.DiffuseSpecularShader

EGXSLShaderException

GXSL.Shader

EInvalidArchiveFile

GXS.ArchiveManager

EInvalidRasterFile

GXS.Graphics

EmptyHmgMatrix

GLScene.VectorGeometry

EmptyMatrix

GLScene.VectorGeometry

EncodeGLTextureTarget

GLScene.TextureFormat

EndFPUOnlySection

GLScene.VectorGeometry

Ends a FPU-only section. See BeginFPUOnlySection

EOpenALError

GXS.Sounds.OpenAL

EOpenGLError

GLScene.OpenGL4

EOpenGLError

GXS.OpenGLAdapter

EPBuffer

GXS.Context

EProxyException

GXS.ProxyObjects

EPSILON

GLScene.VectorGeometry

Some very small numbers

EPSILON2

GLScene.VectorGeometry

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB

GLScene.OpenGL4

ERROR_INVALID_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_ARB_make_current_read

ERROR_INVALID_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_EXT_make_current_read

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGL4

ERROR_INVALID_PROFILE_ARB

GLScene.OpenGLTokens

ERROR_INVALID_VERSION_ARB

GLScene.OpenGL4

ERROR_INVALID_VERSION_ARB

GLScene.OpenGLTokens

ESDLError

SDLx.Window

Generic SDL or SDLWindow exception.

EShaderException

GXS.Texture

ETexture

GXS.Texture

ETGAException

GXS.FileTGA

EvalPolynom

GLScene.Polynomials

Computes polynom's value for given x

EVXContext

GXS.Context

EVXShader

GXS.Context

EVXTextureCombinerError

GXS.TextureCombiners

ExponateCrap

GXS.Perlin

The function returning some integer based on the rootˆexponant concept, result is crap and is only for "random" usage... eg perlin.

ExPtTolerance

GLScene.Triangulation

ExtendedFrustumIntersectsBSphere

GXS.SpacePartition

Determines if a extended frustum intersects an BSphere

ExtendedFrustumMake

GXS.SpacePartition

Create an extended frustum from a number of values

ExtendedFrustumMakeFromSceneViewer

GXS.SpatialPartitioning

ExtendedFrustumMakeFromSceneViewer

GXS.SpatialPartitioning

Create an extended frustum from a SceneViewer - this makes the unit specific to the windows platform!

ExtractAABBCorners

GLScene.GeometryBB

Extract the corners from an AABB

ExtractFrustumFromModelViewProjection

GLScene.VectorGeometry

Extracts a TFrustum for combined modelview and projection matrices

EZBufferException

GXS.zBuffer

FacesSmooth

GXS.MeshOptimizer

FastArcTangent2

GLScene.VectorGeometry

Fast ArcTangent2 approximation, about 0.07 rads accuracy

FastCheckCubeVsCube

GXS.Collision

FastCheckCubeVsEllipsoid

GXS.Collision

FastCheckCubeVsFace

GXS.Collision

FastCheckCubeVsPoint

GXS.Collision

FastCheckCubeVsSphere

GXS.Collision

FastCheckEllipsoidVsCube

GXS.Collision

FastCheckEllipsoidVsEllipsoid

GXS.Collision

FastCheckEllipsoidVsPoint

GXS.Collision

FastCheckEllipsoidVsSphere

GXS.Collision

FastCheckFaceVsCube

GXS.Collision

experimental

FastCheckFaceVsFace

GXS.Collision

experimental

FastCheckPointVsCube

GXS.Collision

FastCheckPointVsEllipsoid

GXS.Collision

FastCheckPointVsPoint

GXS.Collision

Fast Collision detection routines that are heavily specialized and just return a boolean

FastCheckPointVsSphere

GXS.Collision

FastCheckSphereVsCube

GXS.Collision

FastCheckSphereVsEllipsoid

GXS.Collision

FastCheckSphereVsPoint

GXS.Collision

FastCheckSphereVsSphere

GXS.Collision

FileStreamExists

GXS.ApplicationFileIO

Queries is a file stream corresponding to the fileName exists.

FillUniformAutoSetMethodList

GXSL.Parameter

FillUniformAutoSetMethodList

GXSL.Parameter

FillUniformAutoSetMethodList

GXSL.ShaderParameter

FillUniformAutoSetMethodList

GXSL.ShaderParameter

FindCompatibleDataFormat

GLScene.TextureFormat

Give compatible openGL image format and data type

FindManager

GLScene.Manager

FindRoot

GLScene.Polynomials

Finds a root between min and max with a precision of epsilon. The evaluation of min/max must be of opposit sign

FindTextureImageClass

GXS.Texture

Finds a registerer TgxTextureImageClass using its classname

FindTextureImageClassByFriendlyName

GXS.Texture

Finds a registerer TgxTextureImageClass using its FriendlyName

FindUnitName

GLScene.Utils

FindUnitName

GLScene.Utils

FindXCollectionItemClass

GLScene.XCollection

Retrieves a registered TXCollectionItemClass from its classname

FixPathDelimiter

GLScene.Utils

Replace path delimiter to delimiter of the current platform.

Float2rgbe

GLScene.RGBE

FloatToHalf

GLScene.Utils

FMOD_Load

GXS.Sounds.FMOD

If no library name is passed to FMOD_Load, then the default library name used.

FMOD_Unload

GXS.Sounds.FMOD

FMUSIC_FreeSong

GXS.Sounds.FMOD

FMUSIC_GetBPM

GXS.Sounds.FMOD

FMUSIC_GetGlobalVolume

GXS.Sounds.FMOD

FMUSIC_GetMasterVolume

GXS.Sounds.FMOD

FMUSIC_GetName

GXS.Sounds.FMOD

Static song information functions.

FMUSIC_GetNumChannels

GXS.Sounds.FMOD

FMUSIC_GetNumInstruments

GXS.Sounds.FMOD

FMUSIC_GetNumOrders

GXS.Sounds.FMOD

FMUSIC_GetNumPatterns

GXS.Sounds.FMOD

FMUSIC_GetNumSamples

GXS.Sounds.FMOD

FMUSIC_GetOpenState

GXS.Sounds.FMOD

FMUSIC_GetOrder

GXS.Sounds.FMOD

FMUSIC_GetPattern

GXS.Sounds.FMOD

FMUSIC_GetPatternLength

GXS.Sounds.FMOD

FMUSIC_GetPaused

GXS.Sounds.FMOD

FMUSIC_GetRealChannel

GXS.Sounds.FMOD

FMUSIC_GetRow

GXS.Sounds.FMOD

FMUSIC_GetSample

GXS.Sounds.FMOD

FMUSIC_GetSpeed

GXS.Sounds.FMOD

FMUSIC_GetTime

GXS.Sounds.FMOD

FMUSIC_GetType

GXS.Sounds.FMOD

FMUSIC_GetUserData

GXS.Sounds.FMOD

FMUSIC_IsFinished

GXS.Sounds.FMOD

Runtime song information.

FMUSIC_IsPlaying

GXS.Sounds.FMOD

FMUSIC_LoadSong

GXS.Sounds.FMOD

Song management / playback functions.

FMUSIC_LoadSongEx

GXS.Sounds.FMOD

FMUSIC_OptimizeChannels

GXS.Sounds.FMOD

FMUSIC_PlaySong

GXS.Sounds.FMOD

FMUSIC_SetInstCallback

GXS.Sounds.FMOD

FMUSIC_SetLooping

GXS.Sounds.FMOD

FMUSIC_SetMasterSpeed

GXS.Sounds.FMOD

FMUSIC_SetMasterVolume

GXS.Sounds.FMOD

FMUSIC_SetOrder

GXS.Sounds.FMOD

FMUSIC_SetOrderCallback

GXS.Sounds.FMOD

FMUSIC_SetPanSeperation

GXS.Sounds.FMOD

FMUSIC_SetPaused

GXS.Sounds.FMOD

FMUSIC_SetReverb

GXS.Sounds.FMOD

Runtime song functions.

FMUSIC_SetRowCallback

GXS.Sounds.FMOD

FMUSIC_SetSample

GXS.Sounds.FMOD

FMUSIC_SetUserData

GXS.Sounds.FMOD

FMUSIC_SetZxxCallback

GXS.Sounds.FMOD

FMUSIC_StopAllSongs

GXS.Sounds.FMOD

FMUSIC_StopSong

GXS.Sounds.FMOD

FontManager

GXS.SpaceText

FONT_CHARS_COUNT

GLScene.Utils

FractalMiddlePointHDS

GXS.RandomHDS

Random HDS functions

FrustumContainsAABB

GLScene.GeometryBB

Determines to which extent a frustum contains an AABB

FrustumContainsBSphere

GLScene.GeometryBB

Determines to which extent a frustum contains a BSphere

FSOUND_3D_GetAttributes

GXS.Sounds.FMOD

FSOUND_3D_GetMinMaxDistance

GXS.Sounds.FMOD

FSOUND_3D_Listener_GetAttributes

GXS.Sounds.FMOD

FSOUND_3D_Listener_SetAttributes

GXS.Sounds.FMOD

FSOUND_3D_Listener_SetCurrent

GXS.Sounds.FMOD

See also 3d sample and channel based functions above. Call FSOUND_Update once a frame to process 3d information.

FSOUND_3D_SetAttributes

GXS.Sounds.FMOD

FSOUND_3D_SetDistanceFactor

GXS.Sounds.FMOD

FSOUND_3D_SetDopplerFactor

GXS.Sounds.FMOD

FSOUND_3D_SetMinMaxDistance

GXS.Sounds.FMOD

FSOUND_3D_SetRolloffFactor

GXS.Sounds.FMOD

FSOUND_CD_GetNumTracks

GXS.Sounds.FMOD

FSOUND_CD_GetPaused

GXS.Sounds.FMOD

FSOUND_CD_GetTrack

GXS.Sounds.FMOD

FSOUND_CD_GetTrackLength

GXS.Sounds.FMOD

FSOUND_CD_GetTrackTime

GXS.Sounds.FMOD

FSOUND_CD_GetVolume

GXS.Sounds.FMOD

FSOUND_CD_OpenTray

GXS.Sounds.FMOD

FSOUND_CD_Play

GXS.Sounds.FMOD

Note : 0 = default cdrom. Otherwise specify the drive letter, for example. 'D'.

FSOUND_CD_SetPaused

GXS.Sounds.FMOD

FSOUND_CD_SetPlayMode

GXS.Sounds.FMOD

FSOUND_CD_SetTrackTime

GXS.Sounds.FMOD

FSOUND_CD_SetVolume

GXS.Sounds.FMOD

FSOUND_CD_Stop

GXS.Sounds.FMOD

FSOUND_Close

GXS.Sounds.FMOD

FSOUND_DSP_ClearMixBuffer

GXS.Sounds.FMOD

FSOUND_DSP_Create

GXS.Sounds.FMOD

DSP Unit control and information functions.

FSOUND_DSP_Free

GXS.Sounds.FMOD

FSOUND_DSP_GetActive

GXS.Sounds.FMOD

FSOUND_DSP_GetBufferLength

GXS.Sounds.FMOD

FSOUND_DSP_GetBufferLengthTotal

GXS.Sounds.FMOD

Length of each DSP update

FSOUND_DSP_GetClearUnit

GXS.Sounds.FMOD

Functions to get hold of FSOUND 'system DSP unit' handles.

FSOUND_DSP_GetClipAndCopyUnit

GXS.Sounds.FMOD

FSOUND_DSP_GetFFTUnit

GXS.Sounds.FMOD

FSOUND_DSP_GetMusicUnit

GXS.Sounds.FMOD

FSOUND_DSP_GetPriority

GXS.Sounds.FMOD

FSOUND_DSP_GetSFXUnit

GXS.Sounds.FMOD

FSOUND_DSP_GetSpectrum

GXS.Sounds.FMOD

Total buffer length due to FSOUND_SetBufferSize

FSOUND_DSP_MixBuffers

GXS.Sounds.FMOD

Miscellaneous DSP functions Note for the spectrum analysis function to work, you have to enable the FFT DSP unit with the following code FSOUND_DSP_SetActive(FSOUND_DSP_GetFFTUnit(), TRUE); It is off by default to save cpu usage.

FSOUND_DSP_SetActive

GXS.Sounds.FMOD

FSOUND_DSP_SetPriority

GXS.Sounds.FMOD

FSOUND_File_SetCallbacks

GXS.Sounds.FMOD

FSOUND_FX_Disable

GXS.Sounds.FMOD

Set bits to enable following fx

FSOUND_FX_Enable

GXS.Sounds.FMOD

Functions to control DX8 only effects processing.
- FX enabled samples can only be played once at a time, not multiple times at once. - Sounds have to be created with FSOUND_HW2D or FSOUND_HW3D for this to work. - FSOUND_INIT_ENABLESYSTEMCHANNELFX can be used to apply hardware effect processing to the global mixed output of FMOD's software channels. - FSOUND_FX_Enable returns an FX handle that you can use to alter fx parameters. - FSOUND_FX_Enable can be called multiple times in a row, even on the same FX type, it will return a unique handle for each FX. - FSOUND_FX_Enable cannot be called if the sound is playing or locked. - Stopping or starting a sound resets all FX and they must be re-enabled each time if this happens.

FSOUND_FX_SetChorus

GXS.Sounds.FMOD

FSOUND_FX_SetCompressor

GXS.Sounds.FMOD

FSOUND_FX_SetDistortion

GXS.Sounds.FMOD

FSOUND_FX_SetEcho

GXS.Sounds.FMOD

FSOUND_FX_SetFlanger

GXS.Sounds.FMOD

FSOUND_FX_SetGargle

GXS.Sounds.FMOD

FSOUND_FX_SetI3DL2Reverb

GXS.Sounds.FMOD

FSOUND_FX_SetParamEQ

GXS.Sounds.FMOD

FSOUND_FX_SetWavesReverb

GXS.Sounds.FMOD

FSOUND_GetAmplitude

GXS.Sounds.FMOD

FSOUND_GetChannelsPlaying

GXS.Sounds.FMOD

FSOUND_GetCPUUsage

GXS.Sounds.FMOD

FSOUND_GetCurrentLevels

GXS.Sounds.FMOD

FSOUND_GetCurrentPosition

GXS.Sounds.FMOD

FSOUND_GetCurrentSample

GXS.Sounds.FMOD

FSOUND_GetDriver

GXS.Sounds.FMOD

FSOUND_GetDriverCaps

GXS.Sounds.FMOD

FSOUND_GetDriverName

GXS.Sounds.FMOD

FSOUND_GetError

GXS.Sounds.FMOD

System information functions

FSOUND_GetFrequency

GXS.Sounds.FMOD

FSOUND_GetLoopMode

GXS.Sounds.FMOD

FSOUND_GetMaxChannels

GXS.Sounds.FMOD

FSOUND_GetMaxSamples

GXS.Sounds.FMOD

FSOUND_GetMemoryStats

GXS.Sounds.FMOD

FSOUND_GetMixer

GXS.Sounds.FMOD

FSOUND_GetMute

GXS.Sounds.FMOD

FSOUND_GetNumDrivers

GXS.Sounds.FMOD

FSOUND_GetNumHWChannels

GXS.Sounds.FMOD

FSOUND_GetNumSubChannels

GXS.Sounds.FMOD

FSOUND_GetOutput

GXS.Sounds.FMOD

FSOUND_GetOutputHandle

GXS.Sounds.FMOD

FSOUND_GetOutputRate

GXS.Sounds.FMOD

FSOUND_GetPan

GXS.Sounds.FMOD

FSOUND_GetPaused

GXS.Sounds.FMOD

FSOUND_GetPriority

GXS.Sounds.FMOD

FSOUND_GetReserved

GXS.Sounds.FMOD

FSOUND_GetSFXMasterVolume

GXS.Sounds.FMOD

FSOUND_GetSpeakerMode

GXS.Sounds.FMOD

FSOUND_GetSubChannel

GXS.Sounds.FMOD

FSOUND_GetSurround

GXS.Sounds.FMOD

FSOUND_GetVersion

GXS.Sounds.FMOD

FSOUND_GetVolume

GXS.Sounds.FMOD

FSOUND_Init

GXS.Sounds.FMOD

Main initialization / closedown functions Note : Use FSOUND_INIT_USEDEFAULTMIDISYNTH with FSOUND_Init for software override with MIDI playback. : Use FSOUND_INIT_GLOBALFOCUS with FSOUND_Init to make sound audible no matter which window is in focus. (FSOUND_OUTPUT_DSOUND only)

FSOUND_IsPlaying

GXS.Sounds.FMOD

Channel information functions

FSOUND_PlaySound

GXS.Sounds.FMOD

Playing and stopping sounds. Note : Use FSOUND_FREE as the 'channel' variable, to let FMOD pick a free channel for you. Use FSOUND_ALL as the 'channel' variable to control ALL channels with one function call!

FSOUND_PlaySoundEx

GXS.Sounds.FMOD

FSOUND_Record_GetDriver

GXS.Sounds.FMOD

FSOUND_Record_GetDriverName

GXS.Sounds.FMOD

FSOUND_Record_GetNumDrivers

GXS.Sounds.FMOD

FSOUND_Record_GetPosition

GXS.Sounds.FMOD

FSOUND_Record_SetDriver

GXS.Sounds.FMOD

Recording initialization functions

FSOUND_Record_StartSample

GXS.Sounds.FMOD

Recording functionality. Only one recording session will work at a time.

FSOUND_Record_Stop

GXS.Sounds.FMOD

FSOUND_Reverb_GetChannelProperties

GXS.Sounds.FMOD

FSOUND_Reverb_GetProperties

GXS.Sounds.FMOD

FSOUND_Reverb_SetChannelProperties

GXS.Sounds.FMOD

FSOUND_Reverb_SetProperties

GXS.Sounds.FMOD

See structures above for definitions and information on the reverb parameters.

FSOUND_Sample_Alloc

GXS.Sounds.FMOD

FSOUND_Sample_Free

GXS.Sounds.FMOD

FSOUND_Sample_Get

GXS.Sounds.FMOD

Sample information functions

FSOUND_Sample_GetDefaults

GXS.Sounds.FMOD

FSOUND_Sample_GetDefaultsEx

GXS.Sounds.FMOD

FSOUND_Sample_GetLength

GXS.Sounds.FMOD

FSOUND_Sample_GetLoopPoints

GXS.Sounds.FMOD

FSOUND_Sample_GetMinMaxDistance

GXS.Sounds.FMOD

FSOUND_Sample_GetMode

GXS.Sounds.FMOD

FSOUND_Sample_GetName

GXS.Sounds.FMOD

FSOUND_Sample_Load

GXS.Sounds.FMOD

Sample creation and management functions Note : Use FSOUND_LOADMEMORY flag with FSOUND_Sample_Load to load from memory. Use FSOUND_LOADRAW flag with FSOUND_Sample_Load to treat as as raw pcm data.

FSOUND_Sample_Lock

GXS.Sounds.FMOD

FSOUND_Sample_SetDefaults

GXS.Sounds.FMOD

FSOUND_Sample_SetDefaultsEx

GXS.Sounds.FMOD

FSOUND_Sample_SetLoopPoints

GXS.Sounds.FMOD

FSOUND_Sample_SetMaxPlaybacks

GXS.Sounds.FMOD

FSOUND_Sample_SetMinMaxDistance

GXS.Sounds.FMOD

FSOUND_Sample_SetMode

GXS.Sounds.FMOD

Sample control functions

FSOUND_Sample_Unlock

GXS.Sounds.FMOD

FSOUND_Sample_Upload

GXS.Sounds.FMOD

FSOUND_SetBufferSize

GXS.Sounds.FMOD

FSOUND_SetCurrentPosition

GXS.Sounds.FMOD

FSOUND_SetDriver

GXS.Sounds.FMOD

FSOUND_SetFrequency

GXS.Sounds.FMOD

Functions to control playback of a channel.

FSOUND_SetHWND

GXS.Sounds.FMOD

FSOUND_SetLoopMode

GXS.Sounds.FMOD

FSOUND_SetMaxHardwareChannels

GXS.Sounds.FMOD

FSOUND_SetMemorySystem

GXS.Sounds.FMOD

FSOUND_SetMinHardwareChannels

GXS.Sounds.FMOD

FSOUND_SetMixer

GXS.Sounds.FMOD

FSOUND_SetMute

GXS.Sounds.FMOD

FSOUND_SetOutput

GXS.Sounds.FMOD

Pre FSOUND_Init functions. These can't be called after FSOUND_Init is called (they will fail). They set up FMOD system functionality.

FSOUND_SetPan

GXS.Sounds.FMOD

FSOUND_SetPanSeperation

GXS.Sounds.FMOD

FSOUND_SetPaused

GXS.Sounds.FMOD

FSOUND_SetPriority

GXS.Sounds.FMOD

FSOUND_SetReserved

GXS.Sounds.FMOD

FSOUND_SetSFXMasterVolume

GXS.Sounds.FMOD

FSOUND_SetSpeakerMode

GXS.Sounds.FMOD

This is called to update 3d sound / non-realtime output

FSOUND_SetSurround

GXS.Sounds.FMOD

FSOUND_SetVolume

GXS.Sounds.FMOD

FSOUND_SetVolumeAbsolute

GXS.Sounds.FMOD

FSOUND_StopSound

GXS.Sounds.FMOD

FSOUND_Stream_AddSyncPoint

GXS.Sounds.FMOD

FSOUND_Stream_Close

GXS.Sounds.FMOD

FSOUND_Stream_Create

GXS.Sounds.FMOD

FSOUND_Stream_CreateDSP

GXS.Sounds.FMOD

Every stream contains a sample to play back on

FSOUND_Stream_DeleteSyncPoint

GXS.Sounds.FMOD

FSOUND_Stream_FindTagField

GXS.Sounds.FMOD

FSOUND_Stream_GetLength

GXS.Sounds.FMOD

FSOUND_Stream_GetLengthMs

GXS.Sounds.FMOD

FSOUND_Stream_GetMode

GXS.Sounds.FMOD

FSOUND_Stream_GetNumSubStreams

GXS.Sounds.FMOD

FSOUND_Stream_GetNumSyncPoints

GXS.Sounds.FMOD

FSOUND_Stream_GetNumTagFields

GXS.Sounds.FMOD

FSOUND_Stream_GetOpenState

GXS.Sounds.FMOD

FSOUND_Stream_GetPosition

GXS.Sounds.FMOD

FSOUND_Stream_GetSample

GXS.Sounds.FMOD

FSOUND_Stream_GetSyncPoint

GXS.Sounds.FMOD

FSOUND_Stream_GetSyncPointInfo

GXS.Sounds.FMOD

FSOUND_Stream_GetTagField

GXS.Sounds.FMOD

FSOUND_Stream_GetTime

GXS.Sounds.FMOD

FSOUND_Stream_Net_GetBufferProperties

GXS.Sounds.FMOD

FSOUND_Stream_Net_GetLastServerStatus

GXS.Sounds.FMOD

FSOUND_Stream_Net_GetStatus

GXS.Sounds.FMOD

FSOUND_Stream_Net_SetBufferProperties

GXS.Sounds.FMOD

FSOUND_Stream_Net_SetMetadataCallback

GXS.Sounds.FMOD

FSOUND_Stream_Net_SetProxy

GXS.Sounds.FMOD

FSOUND_Stream_Open

GXS.Sounds.FMOD

FSOUND_Stream_Play

GXS.Sounds.FMOD

FSOUND_Stream_PlayEx

GXS.Sounds.FMOD

FSOUND_Stream_SetBufferSize

GXS.Sounds.FMOD

call this before opening streams, not after

FSOUND_Stream_SetEndCallback

GXS.Sounds.FMOD

FSOUND_Stream_SetLoopCount

GXS.Sounds.FMOD

FSOUND_Stream_SetLoopPoints

GXS.Sounds.FMOD

FSOUND_Stream_SetMode

GXS.Sounds.FMOD

FSOUND_Stream_SetPosition

GXS.Sounds.FMOD

FSOUND_Stream_SetSubStream

GXS.Sounds.FMOD

FSOUND_Stream_SetSubStreamSentence

GXS.Sounds.FMOD

FSOUND_Stream_SetSyncCallback

GXS.Sounds.FMOD

FSOUND_Stream_SetTime

GXS.Sounds.FMOD

FSOUND_Stream_Stop

GXS.Sounds.FMOD

FSOUND_Update

GXS.Sounds.FMOD

Runtime system level functions

GammaCorrectRGBArray

GXS.Graphics

GenerateDiamondSquare

uGBEImageUtils

https://fr.wikipedia.org/wiki/Algorithme_Diamant-Carr%C3%A9

GenRandom

GLScene.RandomLib

Used to call Random Number Generator. Remember to use Randomize if you don't want repeatable sequences.

GeometryOptimizationMode

GLScene.VectorGeometry

Returns the detected optimization mode. Returned values is either 'FPU', '3DNow!' or 'SSE'

GetActiveLightsList

GXSL.CustomShader

GetActor

GXS.PhysX

GetActorCMassGlobalPosition

GXS.PhysX

GetActorGlobalOrientation

GXS.PhysX

GetActorGlobalPosition

GXS.PhysX

GetActorMass

GXS.PhysX

GetArchiveFileFormats

GXS.ArchiveManager

GetArchiveManager

GXS.ArchiveManager

Note! It's working only with one manager

GetBestSelectorClass

GXS.Selection

GetBodyFromGLXceneObject

GXS.NGDManager

GetBodyFromGLXceneObject

GXS.ODEManager

GetBodyFromObject

GXS.ODEManager

Helper functions for extracting data from objects with different inheritance.

GetBodyPositionAsAffineVector

GXS.ODEUtils

GetBoneParent

GXS.NGDRagdoll

GetChannelTypeAndNum

GXS.CUDA.API

GetCUDAEditorForm

FMxCUDAEditor

GetCurrentAssetPath

GLScene.Utils

Get current path to assets from dir examples

GetCurrentColorDepth

GXS.ImageUtils

Number of bits per pixel for the current desktop resolution.

GetCurrentRenderingObject

GXS.Scene

GetDeviceLogicalPixelsX

GXS.ImageUtils

Number of pixels per logical inch along the screen width for the device. Under Win32 awaits a HDC and returns its LOGPIXELSX.

GetFPSMovement

GXS.FPSMovement

GetFPSMovement

GXS.FPSMovement

GetGenericCompressedFormat

GLScene.TextureFormat

Give generic compressed OpenGL texture format

GetGLRect

GLScene.Utils

Rectangle as function

GetGLSoundFileFormats

GXS.SoundFileObjects

GetGLXceneObject

GXS.ODEManager

GetImageLodNumber

GXS.Graphics

Return an optimal number of texture pyramid

GetIndexFromResolution

GXS.Screen

GetInertia

GXS.Behaviours

Returns or creates the TgxBInertia within the given behaviours. This helper function is convenient way to access a TgxBInertia.

GetMatrixRec

GLScene.VectorTypesExt

GetMovement

GXS.Movement

GetMovement

GXS.Movement

GetNextIsoline

GXS.Isolines

GetNGDDynamic

GXS.NGDManager

GetNGDStatic

GXS.NGDManager

Global function

GetOdeDynamic

GXS.ODEManager

GetODEHeightField

GXS.ODEManager

Get and GetOrCreate functions for ODE HeightField

GetOdeStatic

GXS.ODEManager

Get and GetOrCreate functions for ode behaviours

GetOrCreateAcceleration

GXS.Behaviours

GetOrCreateAcceleration

GXS.Behaviours

Returns or creates the TgxBAcceleration within the given behaviours. This helper function is convenient way to access a TgxBAcceleration.

GetOrCreateCollision

GXS.Collision

Returns or creates the TgxBCollision within the given behaviours. This helper function is convenient way to access a TgxBCollision.

GetOrCreateCollision

GXS.Collision

Returns or creates the TgxBCollision within the given object's behaviours. This helper function is convenient way to access a TgxBCollision.

GetOrCreateDCEDynamic

GXS.DCE

GetOrCreateDCEDynamic

GXS.DCE

GetOrCreateDCEStatic

GXS.DCE

GetOrCreateDCEStatic

GXS.DCE

GetOrCreateFireFX

GXS.FireFX

Returns or creates the TgxBFireFX within the given behaviours. This helper function is convenient way to access a TgxBFireFX.

GetOrCreateFireFX

GXS.FireFX

Returns or creates the TgxBFireFX within the given object's behaviours. This helper function is convenient way to access a TgxBFireFX.

GetOrCreateFPSMovement

GXS.FPSMovement

GetOrCreateFPSMovement

GXS.FPSMovement

GetOrCreateInertia

GXS.Behaviours

GetOrCreateInertia

GXS.Behaviours

GetOrCreateMovement

GXS.Movement

GetOrCreateMovement

GXS.Movement

GetOrCreateNGDDynamic

GXS.NGDManager

GetOrCreateNGDStatic

GXS.NGDManager

GetOrCreateOdeDynamic

GXS.ODEManager

GetOrCreateODEHeightField

GXS.ODEManager

GetOrCreateOdeStatic

GXS.ODEManager

GetOrCreateParticleInertia

GXS.PhysInertias

Returns or creates the TgxParticleInertia within the given behaviours. This helper function is convenient way to access a TgxParticleInertia.

GetOrCreateParticleInertia

GXS.PhysInertias

Returns or creates the TgxParticleInertia within the given object's behaviours. This helper function is convenient way to access a TgxParticleInertia.

GetOrCreateRigidBodyInertia

GXS.PhysInertias

Returns or creates the TgxRigidBodyInertia within the given behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.

GetOrCreateRigidBodyInertia

GXS.PhysInertias

Returns or creates the TgxRigidBodyInertia within the given object's behaviours. This helper function is convenient way to access a TgxRigidBodyInertia.

GetOrCreateSoundEmitter

GXS.SoundManager

GetOrCreateSoundEmitter

GXS.SoundManager

GetOrCreateSourcePFX

GXS.ParticleFX

Returns or creates the TgxBInertia within the given object's behaviours.

GetOrCreateThorFX

GXS.ThorFX

Returns or creates the TgxBThorFX within the given object's effects.

GetOrdValue

GXS.RegisterXCollection

GetOrdValueAt

GXS.RegisterXCollection

GetProcAddressGLLib

GXS.OpenGLAdapter

GetProcAddressGLS

GXS.OpenGLAdapter

GetQuaternionRec

GLScene.VectorTypesExt

GetRasterFileFormats

GXS.Graphics

Read access to the list of registered vector file formats

GetResultsNx

GXS.PhysX

GetROAMTrianglesCapacity

GXS.ROAMPatch

GetSafeTurnAngle

GLScene.VectorGeometry

GetSafeTurnAngle

GLScene.VectorGeometry

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles

GetServiceWindow

GXS.Context

GetSoundLibraryByName

GXS.SoundManager

GetSqrt255Array

GLScene.Utils

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

GetSurfaceFromObject

GXS.ODEManager

GetTextureCombiners

GXS.TextureCombiners

Parses a TC text description and setups combiners accordingly. *experimental* Knowledge of texture combiners is a requirement Syntax: pascal-like, one instruction per line, use '//' for comment. Examples: Tex1:=Tex0; // replace texture 1 with texture 0 Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 Accepted tokens: Tex0, Tex1, etc. : texture unit PrimaryColor, Col : the primary color ConstantColor, EnvCol : texture environment constant color
Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

GetTextureElementSize

GLScene.TextureFormat

GetTextureElementSize

GLScene.TextureFormat

Give a pixel size in bytes from texture format or data format

GetTextureImageClassesAsStrings

GXS.Texture

Creates a TStrings with the list of registered TgxTextureImageClass. To be freed by caller.

GetUncompressedFormat

GLScene.TextureFormat

Give uncompressed texture format and OpenGL color format

GetUniformAutoSetMethod

GXSL.Parameter

GetUniformAutoSetMethod

GXSL.ShaderParameter

GetUniformAutoSetMethodName

GXSL.Parameter

GetUniformAutoSetMethodName

GXSL.ShaderParameter

GetValueFromStringsIndex

GLScene.Utils

GetVectorFileFormats

GXS.VectorFileObjects

Read access to the list of registered vector file formats

GetVectorRec

GLScene.VectorTypesExt

GetXCollectionClassesList

GLScene.XCollection

GetXCollectionItemClassesList

GLScene.XCollection

Creates and returns a copy of internal list of TXCollectionItem classes. Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

glAccum

GLScene.OpenGL4

GL functions and procedures

glActiveStencilFaceEXT

GLScene.OpenGL4

GL_EXT_stencil_two_side (EXT #268)

glActiveTexture

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.3 Core ########################################################### promoted to core v1.3 from GL_ARB_multitexture (#1)

glActiveTextureARB

GLScene.OpenGL4

GL_ARB_multitexture (ARB #1)

glActiveVaryingNV

GLScene.OpenGL4

glAddSwapHintRectWIN

GLScene.OpenGL4

GL_WIN_swap_hint (extension # not found)

glAlphaFunc

GLScene.OpenGL4

deprecated;

glAreProgramsResidentNV

GLScene.OpenGL4

GL_NV_vertex_program (EXT #233)

glAreTexturesResident

GLScene.OpenGL4

deprecated;

glAreTexturesResidentEXT

GLScene.OpenGL4

glArrayElement

GLScene.OpenGL4

deprecated;

glArrayElementArrayEXT

GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT extensions ########################################################### Unknown Vendor/EXT functions

glAttachObjectARB

GLScene.OpenGL4

glAttachShader

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

glBegin

GLScene.OpenGL4

deprecated;

glBeginConditionalRender

GLScene.OpenGL4

glBeginConditionalRenderNV

GLScene.OpenGL4

GL_NV_conditional_render (#346)

glBeginOcclusionQueryNV

GLScene.OpenGL4

glBeginQuery

GLScene.OpenGL4

glBeginQueryARB

GLScene.OpenGL4

glBeginQueryIndexed

GLScene.OpenGL4

glBeginSceneEXT

GLScene.OpenGL4

GL_EXT_scene_marker (EXT #120)

glBeginTransformFeedback

GLScene.OpenGL4

glBeginTransformFeedbackEXT

GLScene.OpenGL4

glBeginTransformFeedbackNV

GLScene.OpenGL4

glBindAttribLocation

GLScene.OpenGL4

glBindAttribLocationARB

GLScene.OpenGL4

GL_ARB_vertex_shader (ARB #31)

glBindBuffer

GLScene.OpenGL4

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

glBindBufferARB

GLScene.OpenGL4

GL_ARB_vertex_buffer_object (ARB #28)

glBindBufferBase

GLScene.OpenGL4

glBindBufferBaseEXT

GLScene.OpenGL4

glBindBufferBaseNV

GLScene.OpenGL4

glBindBufferOffsetEXT

GLScene.OpenGL4

glBindBufferOffsetNV

GLScene.OpenGL4

glBindBufferRange

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_transform_feedback

glBindBufferRangeEXT

GLScene.OpenGL4

GL_EXT_transform_feedback (#352)

glBindBufferRangeNV

GLScene.OpenGL4

GL_NV_transform_feedback (#341)

glBindFragDataLocation

GLScene.OpenGL4

glBindFragDataLocationEXT

GLScene.OpenGL4

glBindFragDataLocationIndexed

GLScene.OpenGL4

GL_ARB_blend_func_extended (ARB #78)

glBindFramebuffer

GLScene.OpenGL4

glBindFramebufferEXT

GLScene.OpenGL4

glBindProgramARB

GLScene.OpenGL4

glBindProgramNV

GLScene.OpenGL4

glBindRenderbuffer

GLScene.OpenGL4

glBindRenderbufferEXT

GLScene.OpenGL4

glBindSampler

GLScene.OpenGL4

glBindTexture

GLScene.OpenGL4

deprecated;

glBindTextureEXT

GLScene.OpenGL4

glBindTransformFeedback

GLScene.OpenGL4

GL_ARB_transform_feedback2 (ARB #93)

glBindVertexArray

GLScene.OpenGL4

GL_ARB_vertex_array_object (ARB #54)

GLbitfield

GLScene.OpenGL4

glBitmap

GLScene.OpenGL4

glBlendColor

GLScene.OpenGL4

——————- OpenGL extension function/procedure definitions —————— ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.2 Core ########################################################### promoted to core v1.2 from GL_EXT_blend_color (#2)

glBlendColorEXT

GLScene.OpenGL4

GL_EXT_blend_color (EXT #2)

glBlendEquation

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

glBlendEquationEXT

GLScene.OpenGL4

GL_EXT_blend_minmax (EXT #37)

glBlendEquationi

GLScene.OpenGL4

GL_ARB_draw_buffers_blend (ARB #69)

glBlendEquationSeparate

GLScene.OpenGL4

promoted to core v1.5 from GL_EXT_shadow_funcs (#267) (no functions or procedures) ########################################################### function and procedure definitions for extensions integrated into OpenGL 2.0 Core ########################################################### promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

glBlendEquationSeparateEXT

GLScene.OpenGL4

GL_EXT_blend_equation_separate (EXT #299)

glBlendEquationSeparatei

GLScene.OpenGL4

glBlendFunc

GLScene.OpenGL4

deprecated;

glBlendFunci

GLScene.OpenGL4

glBlendFuncSeparate

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.4 Core ########################################################### promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

glBlendFuncSeparateEXT

GLScene.OpenGL4

GL_EXT_blend_func_separate (EXT #173)

glBlendFuncSeparatei

GLScene.OpenGL4

glBlitFramebuffer

GLScene.OpenGL4

glBlitFramebufferEXT

GLScene.OpenGL4

GL_EXT_framebuffer_blit (#316)

GLboolean

GLScene.OpenGL4

glBufferAddressRangeNV

GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory (#380)

glBufferData

GLScene.OpenGL4

glBufferDataARB

GLScene.OpenGL4

glBufferSubData

GLScene.OpenGL4

glBufferSubDataARB

GLScene.OpenGL4

GLbyte

GLScene.OpenGL4

glCallList

GLScene.OpenGL4

glCallLists

GLScene.OpenGL4

deprecated;

glCheckFramebufferStatus

GLScene.OpenGL4

glCheckFramebufferStatusEXT

GLScene.OpenGL4

glClampColor

GLScene.OpenGL4

glClampColorARB

GLScene.OpenGL4

GL_ARB_color_buffer_float (ARB #39)

GLclampd

GLScene.OpenGL4

GLclampf

GLScene.OpenGL4

glClear

GLScene.OpenGL4

deprecated;

glClearAccum

GLScene.OpenGL4

glClearBufferfi

GLScene.OpenGL4

glClearBufferfv

GLScene.OpenGL4

glClearBufferiv

GLScene.OpenGL4

New commands in OpenGL 3.0

glClearBufferuiv

GLScene.OpenGL4

glClearColor

GLScene.OpenGL4

deprecated;

glClearColorIiEXT

GLScene.OpenGL4

GL_EXT_texture_integer (#343)

glClearColorIuiEXT

GLScene.OpenGL4

glClearDepth

GLScene.OpenGL4

glClearIndex

GLScene.OpenGL4

glClearStencil

GLScene.OpenGL4

deprecated;

glClientActiveTexture

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multitexture (#1)

glClientActiveTextureARB

GLScene.OpenGL4

glClientWaitSync

GLScene.OpenGL4

glClipPlane

GLScene.OpenGL4

glColor3b

GLScene.OpenGL4

deprecated;

glColor3bv

GLScene.OpenGL4

deprecated;

glColor3d

GLScene.OpenGL4

deprecated;

glColor3dv

GLScene.OpenGL4

deprecated;

glColor3f

GLScene.OpenGL4

deprecated;

glColor3fv

GLScene.OpenGL4

deprecated;

glColor3i

GLScene.OpenGL4

deprecated;

glColor3iv

GLScene.OpenGL4

deprecated;

glColor3s

GLScene.OpenGL4

deprecated;

glColor3sv

GLScene.OpenGL4

deprecated;

glColor3ub

GLScene.OpenGL4

deprecated;

glColor3ubv

GLScene.OpenGL4

deprecated;

glColor3ui

GLScene.OpenGL4

deprecated;

glColor3uiv

GLScene.OpenGL4

deprecated;

glColor3us

GLScene.OpenGL4

deprecated;

glColor3usv

GLScene.OpenGL4

deprecated;

glColor4b

GLScene.OpenGL4

deprecated;

glColor4bv

GLScene.OpenGL4

deprecated;

glColor4d

GLScene.OpenGL4

deprecated;

glColor4dv

GLScene.OpenGL4

deprecated;

glColor4f

GLScene.OpenGL4

deprecated;

glColor4fv

GLScene.OpenGL4

deprecated;

glColor4i

GLScene.OpenGL4

deprecated;

glColor4iv

GLScene.OpenGL4

deprecated;

glColor4s

GLScene.OpenGL4

deprecated;

glColor4sv

GLScene.OpenGL4

deprecated;

glColor4ub

GLScene.OpenGL4

deprecated;

glColor4ubv

GLScene.OpenGL4

deprecated;

glColor4ui

GLScene.OpenGL4

deprecated;

glColor4uiv

GLScene.OpenGL4

deprecated;

glColor4us

GLScene.OpenGL4

deprecated;

glColor4usv

GLScene.OpenGL4

deprecated;

glColorFormatNV

GLScene.OpenGL4

glColorMask

GLScene.OpenGL4

deprecated;

glColorMaski

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_draw_buffers2

glColorMaskIndexedEXT

GLScene.OpenGL4

GL_EXT_draw_buffers2 (#340)

glColorMaterial

GLScene.OpenGL4

glColorP3ui

GLScene.OpenGL4

glColorP3uiv

GLScene.OpenGL4

glColorP4ui

GLScene.OpenGL4

glColorP4uiv

GLScene.OpenGL4

glColorPointer

GLScene.OpenGL4

deprecated;

glColorSubTable

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

glColorSubTableExt

GLScene.OpenGL4

glColorTable

GLScene.OpenGL4

OpenGL 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

glColorTableEXT

GLScene.OpenGL4

GL_EXT_paletted_texture (EXT #78)

glColorTableParameterfv

GLScene.OpenGL4

deprecated;

glColorTableParameteriv

GLScene.OpenGL4

deprecated;

glCombinerInputNV

GLScene.OpenGL4

glCombinerOutputNV

GLScene.OpenGL4

glCombinerParameterfNV

GLScene.OpenGL4

glCombinerParameterfvNV

GLScene.OpenGL4

GL_NV_register_combiners (EXT #191)

glCombinerParameteriNV

GLScene.OpenGL4

glCombinerParameterivNV

GLScene.OpenGL4

glCompileShader

GLScene.OpenGL4

glCompileShaderARB

GLScene.OpenGL4

glCompressedTexImage1D

GLScene.OpenGL4

glCompressedTexImage1DARB

GLScene.OpenGL4

glCompressedTexImage2D

GLScene.OpenGL4

glCompressedTexImage2DARB

GLScene.OpenGL4

glCompressedTexImage3D

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_texture_compression (#12)

glCompressedTexImage3DARB

GLScene.OpenGL4

GL_ARB_texture_compression (ARB #12)

glCompressedTexSubImage1D

GLScene.OpenGL4

glCompressedTexSubImage1DARB

GLScene.OpenGL4

glCompressedTexSubImage2D

GLScene.OpenGL4

glCompressedTexSubImage2DARB

GLScene.OpenGL4

glCompressedTexSubImage3D

GLScene.OpenGL4

glCompressedTexSubImage3DARB

GLScene.OpenGL4

glConvolutionFilter1D

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

glConvolutionFilter2D

GLScene.OpenGL4

deprecated;

glConvolutionParameterf

GLScene.OpenGL4

deprecated;

glConvolutionParameterfv

GLScene.OpenGL4

deprecated;

glConvolutionParameteri

GLScene.OpenGL4

deprecated;

glConvolutionParameteriv

GLScene.OpenGL4

deprecated;

glCopyBufferSubData

GLScene.OpenGL4

GL_ARB_copy_buffer (ARB #59)

glCopyColorSubTable

GLScene.OpenGL4

deprecated;

glCopyColorTable

GLScene.OpenGL4

deprecated;

glCopyConvolutionFilter1D

GLScene.OpenGL4

deprecated;

glCopyConvolutionFilter2D

GLScene.OpenGL4

deprecated;

glCopyImageSubDataNV

GLScene.OpenGL4

GL_NV_copy_image (#376)

glCopyPixels

GLScene.OpenGL4

deprecated;

glCopyTexImage1D

GLScene.OpenGL4

deprecated;

glCopyTexImage1DEXT

GLScene.OpenGL4

GL_EXT_copy_texture (EXT #10)

glCopyTexImage2D

GLScene.OpenGL4

glCopyTexImage2DEXT

GLScene.OpenGL4

glCopyTexSubImage1D

GLScene.OpenGL4

glCopyTexSubImage1DEXT

GLScene.OpenGL4

glCopyTexSubImage2D

GLScene.OpenGL4

glCopyTexSubImage2DEXT

GLScene.OpenGL4

glCopyTexSubImage3D

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_copy_texture

glCopyTexSubImage3DEXT

GLScene.OpenGL4

glCreateProgram

GLScene.OpenGL4

glCreateProgramObjectARB

GLScene.OpenGL4

glCreateShader

GLScene.OpenGL4

glCreateShaderObjectARB

GLScene.OpenGL4

glCullFace

GLScene.OpenGL4

glCurrentPaletteMatrixARB

GLScene.OpenGL4

GL_ARB_matrix_palette (ARB #16) {deprecated?}

glDeleteBuffers

GLScene.OpenGL4

glDeleteBuffersARB

GLScene.OpenGL4

glDeleteFencesNV

GLScene.OpenGL4

glDeleteFramebuffers

GLScene.OpenGL4

glDeleteFramebuffersEXT

GLScene.OpenGL4

glDeleteLists

GLScene.OpenGL4

glDeleteObjectARB

GLScene.OpenGL4

GL_ARB_shader_objects (ARB #30)

glDeleteOcclusionQueriesNV

GLScene.OpenGL4

glDeleteProgram

GLScene.OpenGL4

glDeleteProgramsARB

GLScene.OpenGL4

glDeleteProgramsNV

GLScene.OpenGL4

glDeleteQueries

GLScene.OpenGL4

glDeleteQueriesARB

GLScene.OpenGL4

glDeleteRenderbuffers

GLScene.OpenGL4

glDeleteRenderbuffersEXT

GLScene.OpenGL4

glDeleteSamplers

GLScene.OpenGL4

glDeleteShader

GLScene.OpenGL4

glDeleteSync

GLScene.OpenGL4

glDeleteTextures

GLScene.OpenGL4

deprecated;

glDeleteTexturesEXT

GLScene.OpenGL4

glDeleteTransformFeedbacks

GLScene.OpenGL4

glDeleteVertexArrays

GLScene.OpenGL4

glDepthBoundsEXT

GLScene.OpenGL4

GL_EXT_depth_bounds_test (EXT #297)

glDepthFunc

GLScene.OpenGL4

glDepthMask

GLScene.OpenGL4

glDepthRange

GLScene.OpenGL4

glDetachObjectARB

GLScene.OpenGL4

glDetachShader

GLScene.OpenGL4

glDisable

GLScene.OpenGL4

glDisableClientState

GLScene.OpenGL4

glDisablei

GLScene.OpenGL4

glDisableIndexedEXT

GLScene.OpenGL4

glDisableVertexAttribArray

GLScene.OpenGL4

glDisableVertexAttribArrayARB

GLScene.OpenGL4

GLdouble

GLScene.OpenGL4

glDrawArrays

GLScene.OpenGL4

deprecated;

glDrawArraysIndirect

GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87)

glDrawArraysInstanced

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.1 Core ###########################################################

glDrawArraysInstancedARB

GLScene.OpenGL4

GL_ARB_draw_instanced (ARB #44)

glDrawArraysInstancedEXT

GLScene.OpenGL4

GL_EXT_draw_instanced (#327)

glDrawBuffer

GLScene.OpenGL4

glDrawBuffers

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

glDrawBuffersARB

GLScene.OpenGL4

GL_ARB_DrawBuffers (ARB #37)

glDrawBuffersATI

GLScene.OpenGL4

GL_ATI_draw_buffers (EXT #277)

glDrawElements

GLScene.OpenGL4

glDrawElementsBaseVertex

GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex (ARB #62)

glDrawElementsIndirect

GLScene.OpenGL4

glDrawElementsInstanced

GLScene.OpenGL4

glDrawElementsInstancedARB

GLScene.OpenGL4

glDrawElementsInstancedBaseVertex

GLScene.OpenGL4

glDrawElementsInstancedEXT

GLScene.OpenGL4

glDrawPixels

GLScene.OpenGL4

glDrawRangeElements

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

glDrawRangeElementsBaseVertex

GLScene.OpenGL4

glDrawRangeElementsEXT

GLScene.OpenGL4

GL_EXT_draw_range_elements (EXT #112)

glDrawTransformFeedback

GLScene.OpenGL4

glDrawTransformFeedbackStream

GLScene.OpenGL4

GL_ARB_transform_feedback3 (ARB #94)

glEdgeFlag

GLScene.OpenGL4

deprecated;

glEdgeFlagFormatNV

GLScene.OpenGL4

glEdgeFlagPointer

GLScene.OpenGL4

deprecated;

glEdgeFlagv

GLScene.OpenGL4

deprecated;

glEnable

GLScene.OpenGL4

deprecated;

glEnableClientState

GLScene.OpenGL4

glEnablei

GLScene.OpenGL4

glEnableIndexedEXT

GLScene.OpenGL4

glEnableVertexAttribArray

GLScene.OpenGL4

glEnableVertexAttribArrayARB

GLScene.OpenGL4

glEnd

GLScene.OpenGL4

deprecated;

glEndConditionalRender

GLScene.OpenGL4

glEndConditionalRenderNV

GLScene.OpenGL4

glEndList

GLScene.OpenGL4

deprecated;

glEndOcclusionQueryNV

GLScene.OpenGL4

glEndQuery

GLScene.OpenGL4

glEndQueryARB

GLScene.OpenGL4

glEndQueryIndexed

GLScene.OpenGL4

glEndSceneEXT

GLScene.OpenGL4

glEndTransformFeedback

GLScene.OpenGL4

glEndTransformFeedbackEXT

GLScene.OpenGL4

glEndTransformFeedbackNV

GLScene.OpenGL4

GLenum

GLScene.OpenGL4

glEvalCoord1d

GLScene.OpenGL4

deprecated;

glEvalCoord1dv

GLScene.OpenGL4

deprecated;

glEvalCoord1f

GLScene.OpenGL4

deprecated;

glEvalCoord1fv

GLScene.OpenGL4

deprecated;

glEvalCoord2d

GLScene.OpenGL4

deprecated;

glEvalCoord2dv

GLScene.OpenGL4

deprecated;

glEvalCoord2f

GLScene.OpenGL4

deprecated;

glEvalCoord2fv

GLScene.OpenGL4

deprecated;

glEvalMesh1

GLScene.OpenGL4

deprecated;

glEvalMesh2

GLScene.OpenGL4

deprecated;

glEvalPoint1

GLScene.OpenGL4

deprecated;

glEvalPoint2

GLScene.OpenGL4

deprecated;

glExecuteProgramNV

GLScene.OpenGL4

glFeedbackBuffer

GLScene.OpenGL4

deprecated;

glFenceSync

GLScene.OpenGL4

GL_ARB_sync (ARB #66)

glFinalCombinerInputNV

GLScene.OpenGL4

glFinish

GLScene.OpenGL4

deprecated;

glFinishFenceNV

GLScene.OpenGL4

GLfloat

GLScene.OpenGL4

glFlush

GLScene.OpenGL4

glFlushMappedBufferRange

GLScene.OpenGL4

glFlushVertexArrayRangeNV

GLScene.OpenGL4

GL_NV_vertex_array_range (EXT #190)

glFogCoordd

GLScene.OpenGL4

deprecated;

glFogCoorddEXT

GLScene.OpenGL4

glFogCoorddv

GLScene.OpenGL4

deprecated;

glFogCoorddvEXT

GLScene.OpenGL4

glFogCoordf

GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_fog_coord (#149)

glFogCoordfEXT

GLScene.OpenGL4

GL_EXT_fog_coord (EXT #149)

glFogCoordFormatNV

GLScene.OpenGL4

glFogCoordfv

GLScene.OpenGL4

deprecated;

glFogCoordfvEXT

GLScene.OpenGL4

glFogCoordPointer

GLScene.OpenGL4

deprecated;

glFogCoordPointerEXT

GLScene.OpenGL4

glFogf

GLScene.OpenGL4

glFogfv

GLScene.OpenGL4

deprecated;

glFogi

GLScene.OpenGL4

deprecated;

glFogiv

GLScene.OpenGL4

deprecated;

glFramebufferRenderbuffer

GLScene.OpenGL4

glFramebufferRenderbufferEXT

GLScene.OpenGL4

glFramebufferTexture

GLScene.OpenGL4

glFramebufferTexture1D

GLScene.OpenGL4

glFramebufferTexture1DEXT

GLScene.OpenGL4

glFramebufferTexture2D

GLScene.OpenGL4

glFramebufferTexture2DEXT

GLScene.OpenGL4

glFramebufferTexture3D

GLScene.OpenGL4

glFramebufferTexture3DEXT

GLScene.OpenGL4

glFramebufferTextureARB

GLScene.OpenGL4

glFramebufferTextureEXT

GLScene.OpenGL4

glFramebufferTextureFaceARB

GLScene.OpenGL4

glFramebufferTextureFaceEXT

GLScene.OpenGL4

glFramebufferTextureLayer

GLScene.OpenGL4

glFramebufferTextureLayerARB

GLScene.OpenGL4

glFramebufferTextureLayerEXT

GLScene.OpenGL4

glFrameTerminatorGREMEDY

GLScene.OpenGL4

Special Gremedy debugger extension

glFrontFace

GLScene.OpenGL4

deprecated;

glFrustum

GLScene.OpenGL4

glGenBuffers

GLScene.OpenGL4

glGenBuffersARB

GLScene.OpenGL4

glGenerateMipmap

GLScene.OpenGL4

glGenerateMipmapEXT

GLScene.OpenGL4

glGenFencesNV

GLScene.OpenGL4

GL_NV_fence (EXT #222)

glGenFramebuffers

GLScene.OpenGL4

glGenFramebuffersEXT

GLScene.OpenGL4

glGenLists

GLScene.OpenGL4

deprecated;

glGenOcclusionQueriesNV

GLScene.OpenGL4

GL_NV_occlusion_query (EXT #261)

glGenProgramsARB

GLScene.OpenGL4

glGenProgramsNV

GLScene.OpenGL4

glGenQueries

GLScene.OpenGL4

deprecated; ########################################################### function and procedure definitions for extensions integrated into OpenGL 1.5 Core ########################################################### promoted to core v1.5 from GL_ARB_occlusion_query (#29)

glGenQueriesARB

GLScene.OpenGL4

GL_ARB_occlusion_query (ARB #29)

glGenRenderbuffers

GLScene.OpenGL4

glGenRenderbuffersEXT

GLScene.OpenGL4

glGenSamplers

GLScene.OpenGL4

GL_ARB_sampler_objects (ARB #81)

glGenTextures

GLScene.OpenGL4

deprecated;

glGenTexturesEXT

GLScene.OpenGL4

GL_EXT_texture_object (EXT #20)

glGenTransformFeedbacks

GLScene.OpenGL4

glGenVertexArrays

GLScene.OpenGL4

glGetActiveAttrib

GLScene.OpenGL4

glGetActiveAttribARB

GLScene.OpenGL4

glGetActiveSubroutineName

GLScene.OpenGL4

glGetActiveSubroutineUniformiv

GLScene.OpenGL4

glGetActiveSubroutineUniformName

GLScene.OpenGL4

glGetActiveUniform

GLScene.OpenGL4

glGetActiveUniformARB

GLScene.OpenGL4

glGetActiveUniformBlockiv

GLScene.OpenGL4

glGetActiveUniformBlockName

GLScene.OpenGL4

glGetActiveUniformName

GLScene.OpenGL4

glGetActiveUniformsiv

GLScene.OpenGL4

glGetActiveVaryingNV

GLScene.OpenGL4

glGetAttachedObjectsARB

GLScene.OpenGL4

glGetAttachedShaders

GLScene.OpenGL4

glGetAttribLocation

GLScene.OpenGL4

glGetAttribLocationARB

GLScene.OpenGL4

glGetBooleanIndexedvEXT

GLScene.OpenGL4

glGetBooleani_v

GLScene.OpenGL4

glGetBooleanv

GLScene.OpenGL4

glGetBufferParameteri64v

GLScene.OpenGL4

glGetBufferParameteriv

GLScene.OpenGL4

glGetBufferParameterivARB

GLScene.OpenGL4

glGetBufferParameterui64vNV

GLScene.OpenGL4

glGetBufferPointerv

GLScene.OpenGL4

glGetBufferPointervARB

GLScene.OpenGL4

glGetBufferSubData

GLScene.OpenGL4

glGetBufferSubDataARB

GLScene.OpenGL4

glGetClipPlane

GLScene.OpenGL4

glGetColorTable

GLScene.OpenGL4

deprecated;

glGetColorTableEXT

GLScene.OpenGL4

glGetColorTableParameterfv

GLScene.OpenGL4

deprecated;

glGetColorTableParameterfvEXT

GLScene.OpenGL4

glGetColorTableParameteriv

GLScene.OpenGL4

deprecated;

glGetColorTableParameterivEXT

GLScene.OpenGL4

glGetCombinerInputParameterfvNV

GLScene.OpenGL4

glGetCombinerInputParameterivNV

GLScene.OpenGL4

glGetCombinerOutputParameterfvNV

GLScene.OpenGL4

glGetCombinerOutputParameterivNV

GLScene.OpenGL4

glGetCompressedTexImage

GLScene.OpenGL4

glGetCompressedTexImageARB

GLScene.OpenGL4

glGetConvolutionFilter

GLScene.OpenGL4

deprecated;

glGetConvolutionParameterfv

GLScene.OpenGL4

deprecated;

glGetConvolutionParameteriv

GLScene.OpenGL4

deprecated;

GLGetCursorPos

GXS.Screen

glGetDoublev

GLScene.OpenGL4

deprecated;

glGetError

GLScene.OpenGL4

glGetFenceivNV

GLScene.OpenGL4

glGetFinalCombinerInputParameterfvNV

GLScene.OpenGL4

glGetFinalCombinerInputParameterivNV

GLScene.OpenGL4

glGetFloatv

GLScene.OpenGL4

glGetFragDataIndex

GLScene.OpenGL4

glGetFragDataLocation

GLScene.OpenGL4

glGetFragDataLocationEXT

GLScene.OpenGL4

glGetFramebufferAttachmentParameteriv

GLScene.OpenGL4

glGetFramebufferAttachmentParameterivEXT

GLScene.OpenGL4

glGetHandleARB

GLScene.OpenGL4

glGetHistogram

GLScene.OpenGL4

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

glGetHistogramParameterfv

GLScene.OpenGL4

deprecated;

glGetHistogramParameteriv

GLScene.OpenGL4

deprecated;

glGetInfoLogARB

GLScene.OpenGL4

glGetInteger64i_v

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.2 Core ###########################################################

glGetInteger64v

GLScene.OpenGL4

glGetIntegerIndexedvEXT

GLScene.OpenGL4

glGetIntegeri_v

GLScene.OpenGL4

glGetIntegerui64i_vNV

GLScene.OpenGL4

glGetIntegerui64vNV

GLScene.OpenGL4

glGetIntegerv

GLScene.OpenGL4

glGetLightfv

GLScene.OpenGL4

glGetLightiv

GLScene.OpenGL4

deprecated;

glGetMapdv

GLScene.OpenGL4

deprecated;

glGetMapfv

GLScene.OpenGL4

deprecated;

glGetMapiv

GLScene.OpenGL4

deprecated;

glGetMaterialfv

GLScene.OpenGL4

deprecated;

glGetMaterialiv

GLScene.OpenGL4

deprecated;

glGetMinmax

GLScene.OpenGL4

deprecated;

glGetMinmaxParameterfv

GLScene.OpenGL4

deprecated;

glGetMinmaxParameteriv

GLScene.OpenGL4

deprecated;

glGetMultisamplefv

GLScene.OpenGL4

glGetNamedBufferParameterui64vNV

GLScene.OpenGL4

glGetObjectParameterfvARB

GLScene.OpenGL4

glGetObjectParameterivARB

GLScene.OpenGL4

glGetOcclusionQueryivNV

GLScene.OpenGL4

glGetOcclusionQueryuivNV

GLScene.OpenGL4

glGetPixelMapfv

GLScene.OpenGL4

deprecated;

glGetPixelMapuiv

GLScene.OpenGL4

deprecated;

glGetPixelMapusv

GLScene.OpenGL4

deprecated;

glGetPointerv

GLScene.OpenGL4

deprecated;

glGetPolygonStipple

GLScene.OpenGL4

GLGetProcAddress

GLScene.OpenGL4

——————————————————————————

glGetProgramEnvParameterdvARB

GLScene.OpenGL4

glGetProgramEnvParameterfvARB

GLScene.OpenGL4

glGetProgramInfoLog

GLScene.OpenGL4

glGetProgramiv

GLScene.OpenGL4

glGetProgramivARB

GLScene.OpenGL4

glGetProgramivNV

GLScene.OpenGL4

glGetProgramLocalParameterdvARB

GLScene.OpenGL4

glGetProgramLocalParameterfvARB

GLScene.OpenGL4

glGetProgramParameterdvNV

GLScene.OpenGL4

glGetProgramParameterfvNV

GLScene.OpenGL4

glGetProgramStageiv

GLScene.OpenGL4

glGetProgramStringARB

GLScene.OpenGL4

glGetProgramStringNV

GLScene.OpenGL4

glGetQueryIndexediv

GLScene.OpenGL4

glGetQueryiv

GLScene.OpenGL4

glGetQueryivARB

GLScene.OpenGL4

glGetQueryObjecti64v

GLScene.OpenGL4

glGetQueryObjecti64vEXT

GLScene.OpenGL4

GL_EXT_timer_query (#319)

glGetQueryObjectiv

GLScene.OpenGL4

glGetQueryObjectivARB

GLScene.OpenGL4

glGetQueryObjectui64v

GLScene.OpenGL4

glGetQueryObjectui64vEXT

GLScene.OpenGL4

glGetQueryObjectuiv

GLScene.OpenGL4

glGetQueryObjectuivARB

GLScene.OpenGL4

glGetRenderbufferParameteriv

GLScene.OpenGL4

glGetRenderbufferParameterivEXT

GLScene.OpenGL4

glGetSamplerParameterfv

GLScene.OpenGL4

glGetSamplerParameterIfv

GLScene.OpenGL4

glGetSamplerParameterIiv

GLScene.OpenGL4

glGetSamplerParameteriv

GLScene.OpenGL4

GLGetScreenHeight

GXS.Screen

GLGetScreenWidth

GXS.Screen

glGetSeparableFilter

GLScene.OpenGL4

deprecated;

glGetShaderInfoLog

GLScene.OpenGL4

glGetShaderiv

GLScene.OpenGL4

glGetShaderSource

GLScene.OpenGL4

glGetShaderSourceARB

GLScene.OpenGL4

glGetString

GLScene.OpenGL4

deprecated;

glGetStringi

GLScene.OpenGL4

glGetSubroutineIndex

GLScene.OpenGL4

glGetSubroutineUniformLocation

GLScene.OpenGL4

GL_ARB_shader_subroutine (ARB #90)

glGetSynciv

GLScene.OpenGL4

glGetTexEnvfv

GLScene.OpenGL4

glGetTexEnviv

GLScene.OpenGL4

deprecated;

glGetTexGendv

GLScene.OpenGL4

deprecated;

glGetTexGenfv

GLScene.OpenGL4

deprecated;

glGetTexGeniv

GLScene.OpenGL4

deprecated;

glGetTexImage

GLScene.OpenGL4

deprecated;

glGetTexLevelParameterfv

GLScene.OpenGL4

glGetTexLevelParameteriv

GLScene.OpenGL4

glGetTexParameterfv

GLScene.OpenGL4

glGetTexParameterIiv

GLScene.OpenGL4

glGetTexParameterIivEXT

GLScene.OpenGL4

glGetTexParameterIuiv

GLScene.OpenGL4

glGetTexParameterIuivEXT

GLScene.OpenGL4

glGetTexParameteriv

GLScene.OpenGL4

glGetTrackMatrixivNV

GLScene.OpenGL4

glGetTransformFeedbackVarying

GLScene.OpenGL4

glGetTransformFeedbackVaryingEXT

GLScene.OpenGL4

glGetTransformFeedbackVaryingNV

GLScene.OpenGL4

glGetUniformBlockIndex

GLScene.OpenGL4

glGetUniformBufferSizeEXT

GLScene.OpenGL4

glGetUniformdv

GLScene.OpenGL4

glGetUniformfv

GLScene.OpenGL4

glGetUniformfvARB

GLScene.OpenGL4

glGetUniformIndices

GLScene.OpenGL4

GL_ARB_uniform_buffer_object (ARB #57)

glGetUniformiv

GLScene.OpenGL4

glGetUniformivARB

GLScene.OpenGL4

glGetUniformLocation

GLScene.OpenGL4

glGetUniformLocationARB

GLScene.OpenGL4

glGetUniformOffsetEXT

GLScene.OpenGL4

glGetUniformSubroutineuiv

GLScene.OpenGL4

glGetUniformui64vNV

GLScene.OpenGL4

glGetUniformuiv

GLScene.OpenGL4

glGetUniformuivEXT

GLScene.OpenGL4

glGetVaryingLocationNV

GLScene.OpenGL4

glGetVertexAttribdv

GLScene.OpenGL4

glGetVertexAttribdvARB

GLScene.OpenGL4

glGetVertexAttribdvNV

GLScene.OpenGL4

glGetVertexAttribfv

GLScene.OpenGL4

glGetVertexAttribfvARB

GLScene.OpenGL4

glGetVertexAttribfvNV

GLScene.OpenGL4

glGetVertexAttribIiv

GLScene.OpenGL4

glGetVertexAttribIivEXT

GLScene.OpenGL4

glGetVertexAttribIuiv

GLScene.OpenGL4

glGetVertexAttribIuivEXT

GLScene.OpenGL4

glGetVertexAttribiv

GLScene.OpenGL4

glGetVertexAttribivARB

GLScene.OpenGL4

glGetVertexAttribivNV

GLScene.OpenGL4

glGetVertexAttribPointerv

GLScene.OpenGL4

glGetVertexAttribPointervARB

GLScene.OpenGL4

glGetVertexAttribPointervNV

GLScene.OpenGL4

GLhandleARB

GLScene.OpenGL4

glHint

GLScene.OpenGL4

glHistogram

GLScene.OpenGL4

deprecated;

glIndexd

GLScene.OpenGL4

deprecated;

glIndexdv

GLScene.OpenGL4

deprecated;

glIndexf

GLScene.OpenGL4

deprecated;

glIndexFormatNV

GLScene.OpenGL4

glIndexFuncEXT

GLScene.OpenGL4

GL_EXT_index_func (EXT #95)

glIndexfv

GLScene.OpenGL4

deprecated;

glIndexi

GLScene.OpenGL4

deprecated;

glIndexiv

GLScene.OpenGL4

deprecated;

glIndexMask

GLScene.OpenGL4

glIndexMaterialEXT

GLScene.OpenGL4

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); {$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} GL_EXT_index_material (EXT #94)

glIndexPointer

GLScene.OpenGL4

deprecated;

glIndexs

GLScene.OpenGL4

deprecated;

glIndexsv

GLScene.OpenGL4

deprecated;

glIndexub

GLScene.OpenGL4

deprecated;

glIndexubv

GLScene.OpenGL4

deprecated;

glInitNames

GLScene.OpenGL4

deprecated;

GLint

GLScene.OpenGL4

GLint64

GLScene.OpenGL4

GLint64EXT

GLScene.OpenGL4

glInterleavedArrays

GLScene.OpenGL4

deprecated;

glIsBuffer

GLScene.OpenGL4

glIsBufferARB

GLScene.OpenGL4

glIsBufferResidentNV

GLScene.OpenGL4

glIsEnabled

GLScene.OpenGL4

deprecated;

glIsEnabledi

GLScene.OpenGL4

glIsEnabledIndexedEXT

GLScene.OpenGL4

glIsFenceNV

GLScene.OpenGL4

glIsFramebuffer

GLScene.OpenGL4

glIsFramebufferEXT

GLScene.OpenGL4

glIsList

GLScene.OpenGL4

glIsNamedBufferResidentNV

GLScene.OpenGL4

glIsOcclusionQueryNV

GLScene.OpenGL4

glIsProgram

GLScene.OpenGL4

glIsProgramARB

GLScene.OpenGL4

glIsProgramNV

GLScene.OpenGL4

glIsQuery

GLScene.OpenGL4

glIsQueryARB

GLScene.OpenGL4

glIsRenderbuffer

GLScene.OpenGL4

GL_ARB_framebuffer_object (ARB #45)

glIsRenderbufferEXT

GLScene.OpenGL4

GL_EXT_framebuffer_object (EXT #310)

glIsSampler

GLScene.OpenGL4

glIsShader

GLScene.OpenGL4

glIsSync

GLScene.OpenGL4

glIsTexture

GLScene.OpenGL4

glIsTextureEXT

GLScene.OpenGL4

glIsTransformFeedback

GLScene.OpenGL4

glIsVertexArray

GLScene.OpenGL4

GLLibMaterialPicker

FMXLibMaterialPicker

glLightf

GLScene.OpenGL4

deprecated;

glLightfv

GLScene.OpenGL4

deprecated;

glLighti

GLScene.OpenGL4

deprecated;

glLightiv

GLScene.OpenGL4

deprecated;

glLightModelf

GLScene.OpenGL4

glLightModelfv

GLScene.OpenGL4

deprecated;

glLightModeli

GLScene.OpenGL4

deprecated;

glLightModeliv

GLScene.OpenGL4

deprecated;

glLineStipple

GLScene.OpenGL4

deprecated;

glLineWidth

GLScene.OpenGL4

deprecated;

glLinkProgram

GLScene.OpenGL4

glLinkProgramARB

GLScene.OpenGL4

glListBase

GLScene.OpenGL4

GLLoadBitmapFromInstance

GXS.ImageUtils

glLoadIdentity

GLScene.OpenGL4

deprecated;

glLoadMatrixd

GLScene.OpenGL4

deprecated;

glLoadMatrixf

GLScene.OpenGL4

deprecated;

glLoadName

GLScene.OpenGL4

deprecated;

glLoadProgramNV

GLScene.OpenGL4

glLoadTransposeMatrixd

GLScene.OpenGL4

deprecated;

glLoadTransposeMatrixdARB

GLScene.OpenGL4

glLoadTransposeMatrixf

GLScene.OpenGL4

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

glLoadTransposeMatrixfARB

GLScene.OpenGL4

GL_ARB_transpose_matrix (ARB #3)

glLockArraysEXT

GLScene.OpenGL4

GL_EXT_compiled_vertex_array (EXT #97)

glLogicOp

GLScene.OpenGL4

deprecated;

glMakeBufferNonResidentNV

GLScene.OpenGL4

glMakeBufferResidentNV

GLScene.OpenGL4

GL_NV_shader_buffer_load (#379)

glMakeNamedBufferNonResidentNV

GLScene.OpenGL4

glMakeNamedBufferResidentNV

GLScene.OpenGL4

glMap1d

GLScene.OpenGL4

glMap1f

GLScene.OpenGL4

deprecated;

glMap2d

GLScene.OpenGL4

deprecated;

glMap2f

GLScene.OpenGL4

deprecated;

glMapBuffer

GLScene.OpenGL4

glMapBufferARB

GLScene.OpenGL4

glMapBufferRange

GLScene.OpenGL4

GL_ARB_map_buffer_range (ARB #50)

glMapGrid1d

GLScene.OpenGL4

deprecated;

glMapGrid1f

GLScene.OpenGL4

deprecated;

glMapGrid2d

GLScene.OpenGL4

deprecated;

glMapGrid2f

GLScene.OpenGL4

deprecated;

glMaterialf

GLScene.OpenGL4

deprecated;

glMaterialfv

GLScene.OpenGL4

deprecated;

glMateriali

GLScene.OpenGL4

deprecated;

glMaterialiv

GLScene.OpenGL4

deprecated;

glMatrixIndexPointerARB

GLScene.OpenGL4

glMatrixIndexubvARB

GLScene.OpenGL4

glMatrixIndexuivARB

GLScene.OpenGL4

glMatrixIndexusvARB

GLScene.OpenGL4

glMatrixMode

GLScene.OpenGL4

deprecated;

glMinmax

GLScene.OpenGL4

deprecated;

glMinSampleShading

GLScene.OpenGL4

GL_ARB_sample_shading (ARB #70)

glMultiDrawArrays

GLScene.OpenGL4

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

glMultiDrawArraysEXT

GLScene.OpenGL4

GL_EXT_multi_draw_arrays (EXT #148)

glMultiDrawElements

GLScene.OpenGL4

glMultiDrawElementsBaseVertex

GLScene.OpenGL4

glMultiDrawElementsEXT

GLScene.OpenGL4

glMultiTexCoord1d

GLScene.OpenGL4

deprecated;

glMultiTexCoord1dARB

GLScene.OpenGL4

glMultiTexCoord1dV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1dVARB

GLScene.OpenGL4

glMultiTexCoord1f

GLScene.OpenGL4

deprecated;

glMultiTexCoord1fARB

GLScene.OpenGL4

glMultiTexCoord1fV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1fVARB

GLScene.OpenGL4

glMultiTexCoord1i

GLScene.OpenGL4

deprecated;

glMultiTexCoord1iARB

GLScene.OpenGL4

glMultiTexCoord1iV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1iVARB

GLScene.OpenGL4

glMultiTexCoord1s

GLScene.OpenGL4

deprecated;

glMultiTexCoord1sARB

GLScene.OpenGL4

glMultiTexCoord1sV

GLScene.OpenGL4

deprecated;

glMultiTexCoord1sVARB

GLScene.OpenGL4

glMultiTexCoord2d

GLScene.OpenGL4

deprecated;

glMultiTexCoord2dARB

GLScene.OpenGL4

glMultiTexCoord2dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2dvARB

GLScene.OpenGL4

glMultiTexCoord2f

GLScene.OpenGL4

deprecated;

glMultiTexCoord2fARB

GLScene.OpenGL4

glMultiTexCoord2fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2fvARB

GLScene.OpenGL4

glMultiTexCoord2i

GLScene.OpenGL4

deprecated;

glMultiTexCoord2iARB

GLScene.OpenGL4

glMultiTexCoord2iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2ivARB

GLScene.OpenGL4

glMultiTexCoord2s

GLScene.OpenGL4

deprecated;

glMultiTexCoord2sARB

GLScene.OpenGL4

glMultiTexCoord2sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord2svARB

GLScene.OpenGL4

glMultiTexCoord3d

GLScene.OpenGL4

deprecated;

glMultiTexCoord3dARB

GLScene.OpenGL4

glMultiTexCoord3dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3dvARB

GLScene.OpenGL4

glMultiTexCoord3f

GLScene.OpenGL4

deprecated;

glMultiTexCoord3fARB

GLScene.OpenGL4

glMultiTexCoord3fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3fvARB

GLScene.OpenGL4

glMultiTexCoord3i

GLScene.OpenGL4

deprecated;

glMultiTexCoord3iARB

GLScene.OpenGL4

glMultiTexCoord3iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3ivARB

GLScene.OpenGL4

glMultiTexCoord3s

GLScene.OpenGL4

deprecated;

glMultiTexCoord3sARB

GLScene.OpenGL4

glMultiTexCoord3sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord3svARB

GLScene.OpenGL4

glMultiTexCoord4d

GLScene.OpenGL4

deprecated;

glMultiTexCoord4dARB

GLScene.OpenGL4

glMultiTexCoord4dv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4dvARB

GLScene.OpenGL4

glMultiTexCoord4f

GLScene.OpenGL4

deprecated;

glMultiTexCoord4fARB

GLScene.OpenGL4

glMultiTexCoord4fv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4fvARB

GLScene.OpenGL4

glMultiTexCoord4i

GLScene.OpenGL4

deprecated;

glMultiTexCoord4iARB

GLScene.OpenGL4

glMultiTexCoord4iv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4ivARB

GLScene.OpenGL4

glMultiTexCoord4s

GLScene.OpenGL4

deprecated;

glMultiTexCoord4sARB

GLScene.OpenGL4

glMultiTexCoord4sv

GLScene.OpenGL4

deprecated;

glMultiTexCoord4svARB

GLScene.OpenGL4

glMultiTexCoordP1ui

GLScene.OpenGL4

glMultiTexCoordP1uiv

GLScene.OpenGL4

glMultiTexCoordP2ui

GLScene.OpenGL4

glMultiTexCoordP2uiv

GLScene.OpenGL4

glMultiTexCoordP3ui

GLScene.OpenGL4

glMultiTexCoordP3uiv

GLScene.OpenGL4

glMultiTexCoordP4ui

GLScene.OpenGL4

glMultiTexCoordP4uiv

GLScene.OpenGL4

glMultMatrixd

GLScene.OpenGL4

deprecated;

glMultMatrixf

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixd

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixdARB

GLScene.OpenGL4

glMultTransposeMatrixf

GLScene.OpenGL4

deprecated;

glMultTransposeMatrixfARB

GLScene.OpenGL4

glNewList

GLScene.OpenGL4

deprecated;

glNormal3b

GLScene.OpenGL4

deprecated;

glNormal3bv

GLScene.OpenGL4

deprecated;

glNormal3d

GLScene.OpenGL4

deprecated;

glNormal3dv

GLScene.OpenGL4

deprecated;

glNormal3f

GLScene.OpenGL4

deprecated;

glNormal3fv

GLScene.OpenGL4

deprecated;

glNormal3i

GLScene.OpenGL4

deprecated;

glNormal3iv

GLScene.OpenGL4

deprecated;

glNormal3s

GLScene.OpenGL4

deprecated;

glNormal3sv

GLScene.OpenGL4

deprecated;

glNormalFormatNV

GLScene.OpenGL4

glNormalP3ui

GLScene.OpenGL4

glNormalP3uiv

GLScene.OpenGL4

glNormalPointer

GLScene.OpenGL4

deprecated;

GLOKMessageBox

GXS.ImageUtils

Returns the number of CPU cycles since startup. Use the similarly named CPU instruction.

glOrtho

GLScene.OpenGL4

deprecated;

glPassThrough

GLScene.OpenGL4

deprecated;

glPatchParameterfv

GLScene.OpenGL4

glPatchParameteri

GLScene.OpenGL4

GL_ARB_tessellation_shader (ARB #91)

glPauseTransformFeedback

GLScene.OpenGL4

glPixelMapfv

GLScene.OpenGL4

deprecated;

glPixelMapuiv

GLScene.OpenGL4

deprecated;

glPixelMapusv

GLScene.OpenGL4

deprecated;

glPixelStoref

GLScene.OpenGL4

deprecated;

glPixelStorei

GLScene.OpenGL4

glPixelTransferf

GLScene.OpenGL4

glPixelTransferi

GLScene.OpenGL4

deprecated;

glPixelZoom

GLScene.OpenGL4

deprecated;

glPointParameterf

GLScene.OpenGL4

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

glPointParameterfARB

GLScene.OpenGL4

GL_ARB_point_parameter (ARB #14)

glPointParameterfv

GLScene.OpenGL4

glPointParameterfvARB

GLScene.OpenGL4

glPointParameteri

GLScene.OpenGL4

glPointParameteriNV

GLScene.OpenGL4

GL_NV_point_sprite (EXT #262)

glPointParameteriv

GLScene.OpenGL4

glPointParameterivNV

GLScene.OpenGL4

glPointSize

GLScene.OpenGL4

deprecated;

glPolygonMode

GLScene.OpenGL4

glPolygonOffset

GLScene.OpenGL4

glPolygonOffsetEXT

GLScene.OpenGL4

GL_EXT_polygon_offset (EXT #3)

glPolygonStipple

GLScene.OpenGL4

glPopAttrib

GLScene.OpenGL4

deprecated;

glPopClientAttrib

GLScene.OpenGL4

deprecated;

glPopMatrix

GLScene.OpenGL4

deprecated;

glPopName

GLScene.OpenGL4

deprecated;

glPrimitiveRestartIndex

GLScene.OpenGL4

glPrimitiveRestartIndexNV

GLScene.OpenGL4

glPrimitiveRestartNV

GLScene.OpenGL4

GL_NV_primitive_restart (EXT #285)

glPrioritizeTextures

GLScene.OpenGL4

deprecated;

glPrioritizeTexturesEXT

GLScene.OpenGL4

glProgramEnvParameter4dARB

GLScene.OpenGL4

glProgramEnvParameter4dvARB

GLScene.OpenGL4

glProgramEnvParameter4fARB

GLScene.OpenGL4

glProgramEnvParameter4fvARB

GLScene.OpenGL4

glProgramEnvParameters4fvEXT

GLScene.OpenGL4

GL_EXT_gpu_program_parameters (EXT #320)

glProgramLocalParameter4dARB

GLScene.OpenGL4

glProgramLocalParameter4dvARB

GLScene.OpenGL4

glProgramLocalParameter4fARB

GLScene.OpenGL4

glProgramLocalParameter4fvARB

GLScene.OpenGL4

glProgramLocalParameters4fvEXT

GLScene.OpenGL4

glProgramParameter4dNV

GLScene.OpenGL4

glProgramParameter4dvNV

GLScene.OpenGL4

glProgramParameter4fNV

GLScene.OpenGL4

glProgramParameter4fvNV

GLScene.OpenGL4

glProgramParameteri

GLScene.OpenGL4

glProgramParameteriARB

GLScene.OpenGL4

GL_ARB_geometry_shader4 (ARB #47)

glProgramParameteriEXT

GLScene.OpenGL4

GL_EXT_geometry_shader4 (EXT #324)

glProgramParameters4dvNV

GLScene.OpenGL4

glProgramParameters4fvNV

GLScene.OpenGL4

glProgramStringARB

GLScene.OpenGL4

glProgramUniform1dEXT

GLScene.OpenGL4

glProgramUniformXXX only valid if EXT_direct_state_access is available

glProgramUniform1dvEXT

GLScene.OpenGL4

glProgramUniform2dEXT

GLScene.OpenGL4

glProgramUniform2dvEXT

GLScene.OpenGL4

glProgramUniform3dEXT

GLScene.OpenGL4

glProgramUniform3dvEXT

GLScene.OpenGL4

glProgramUniform4dEXT

GLScene.OpenGL4

glProgramUniform4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2x3dvEXT

GLScene.OpenGL4

glProgramUniformMatrix2x4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3x2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix3x4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4x2dvEXT

GLScene.OpenGL4

glProgramUniformMatrix4x3dvEXT

GLScene.OpenGL4

glProgramUniformui64NV

GLScene.OpenGL4

glProgramUniformui64vNV

GLScene.OpenGL4

glProgramVertexLimitNV

GLScene.OpenGL4

GL_NV_geometry_program4 (EXT #323)

glProvokingVertex

GLScene.OpenGL4

GL_ARB_provoking_vertex (ARB #64)

glPushAttrib

GLScene.OpenGL4

deprecated;

glPushClientAttrib

GLScene.OpenGL4

deprecated;

glPushMatrix

GLScene.OpenGL4

deprecated;

glPushName

GLScene.OpenGL4

deprecated;

glQueryCounter

GLScene.OpenGL4

GL_ARB_timer_query (ARB #85)

glRasterPos2d

GLScene.OpenGL4

deprecated;

glRasterPos2dv

GLScene.OpenGL4

deprecated;

glRasterPos2f

GLScene.OpenGL4

deprecated;

glRasterPos2fv

GLScene.OpenGL4

deprecated;

glRasterPos2i

GLScene.OpenGL4

deprecated;

glRasterPos2iv

GLScene.OpenGL4

deprecated;

glRasterPos2s

GLScene.OpenGL4

deprecated;

glRasterPos2sv

GLScene.OpenGL4

deprecated;

glRasterPos3d

GLScene.OpenGL4

deprecated;

glRasterPos3dv

GLScene.OpenGL4

deprecated;

glRasterPos3f

GLScene.OpenGL4

deprecated;

glRasterPos3fv

GLScene.OpenGL4

deprecated;

glRasterPos3i

GLScene.OpenGL4

deprecated;

glRasterPos3iv

GLScene.OpenGL4

deprecated;

glRasterPos3s

GLScene.OpenGL4

deprecated;

glRasterPos3sv

GLScene.OpenGL4

deprecated;

glRasterPos4d

GLScene.OpenGL4

deprecated;

glRasterPos4dv

GLScene.OpenGL4

deprecated;

glRasterPos4f

GLScene.OpenGL4

deprecated;

glRasterPos4fv

GLScene.OpenGL4

deprecated;

glRasterPos4i

GLScene.OpenGL4

deprecated;

glRasterPos4iv

GLScene.OpenGL4

deprecated;

glRasterPos4s

GLScene.OpenGL4

deprecated;

glRasterPos4sv

GLScene.OpenGL4

deprecated;

glReadBuffer

GLScene.OpenGL4

deprecated;

glReadPixels

GLScene.OpenGL4

glRectd

GLScene.OpenGL4

glRectdv

GLScene.OpenGL4

deprecated;

glRectf

GLScene.OpenGL4

deprecated;

glRectfv

GLScene.OpenGL4

deprecated;

glRecti

GLScene.OpenGL4

deprecated;

glRectiv

GLScene.OpenGL4

deprecated;

glRects

GLScene.OpenGL4

deprecated;

glRectsv

GLScene.OpenGL4

deprecated;

glRenderbufferStorage

GLScene.OpenGL4

glRenderbufferStorageEXT

GLScene.OpenGL4

glRenderbufferStorageMultisample

GLScene.OpenGL4

glRenderbufferStorageMultisampleEXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample (#317)

glRenderMode

GLScene.OpenGL4

deprecated;

glRequestResidentProgramsNV

GLScene.OpenGL4

glResetHistogram

GLScene.OpenGL4

deprecated;

glResetMinmax

GLScene.OpenGL4

deprecated;

glResizeBuffersMESA

GLScene.OpenGL4

GL_MESA_resize_buffers (EXT #196)

glResumeTransformFeedback

GLScene.OpenGL4

glRotated

GLScene.OpenGL4

glRotatef

GLScene.OpenGL4

deprecated;

glSampleCoverage

GLScene.OpenGL4

promoted to core v1.3 from GL_ARB_multisample (#5)

glSampleCoverageARB

GLScene.OpenGL4

GL_ARB_multisample (ARB #5)

glSampleMaskEXT

GLScene.OpenGL4

GL_EXT_multisample (EXT #209)

glSampleMaski

GLScene.OpenGL4

glSampleMaskSGIS

GLScene.OpenGL4

GL_SGIS_multisample (EXT #25)

glSamplePassARB

GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved extensions ########################################################### unknown ARB extension

glSamplePatternEXT

GLScene.OpenGL4

glSamplePatternSGIS

GLScene.OpenGL4

glSamplerParameterf

GLScene.OpenGL4

glSamplerParameterfv

GLScene.OpenGL4

glSamplerParameteri

GLScene.OpenGL4

glSamplerParameterIiv

GLScene.OpenGL4

glSamplerParameterIuiv

GLScene.OpenGL4

glSamplerParameteriv

GLScene.OpenGL4

glScaled

GLScene.OpenGL4

deprecated;

glScalef

GLScene.OpenGL4

deprecated;

glScissor

GLScene.OpenGL4

deprecated;

glSecondaryColor3b

GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

glSecondaryColor3bEXT

GLScene.OpenGL4

GL_EXT_secondary_color (EXT #145)

glSecondaryColor3bv

GLScene.OpenGL4

deprecated;

glSecondaryColor3bvEXT

GLScene.OpenGL4

glSecondaryColor3d

GLScene.OpenGL4

deprecated;

glSecondaryColor3dEXT

GLScene.OpenGL4

glSecondaryColor3dv

GLScene.OpenGL4

deprecated;

glSecondaryColor3dvEXT

GLScene.OpenGL4

glSecondaryColor3f

GLScene.OpenGL4

deprecated;

glSecondaryColor3fEXT

GLScene.OpenGL4

glSecondaryColor3fv

GLScene.OpenGL4

deprecated;

glSecondaryColor3fvEXT

GLScene.OpenGL4

glSecondaryColor3i

GLScene.OpenGL4

deprecated;

glSecondaryColor3iEXT

GLScene.OpenGL4

glSecondaryColor3iv

GLScene.OpenGL4

deprecated;

glSecondaryColor3ivEXT

GLScene.OpenGL4

glSecondaryColor3s

GLScene.OpenGL4

deprecated;

glSecondaryColor3sEXT

GLScene.OpenGL4

glSecondaryColor3sv

GLScene.OpenGL4

deprecated;

glSecondaryColor3svEXT

GLScene.OpenGL4

glSecondaryColor3ub

GLScene.OpenGL4

deprecated;

glSecondaryColor3ubEXT

GLScene.OpenGL4

glSecondaryColor3ubv

GLScene.OpenGL4

deprecated;

glSecondaryColor3ubvEXT

GLScene.OpenGL4

glSecondaryColor3ui

GLScene.OpenGL4

deprecated;

glSecondaryColor3uiEXT

GLScene.OpenGL4

glSecondaryColor3uiv

GLScene.OpenGL4

deprecated;

glSecondaryColor3uivEXT

GLScene.OpenGL4

glSecondaryColor3us

GLScene.OpenGL4

deprecated;

glSecondaryColor3usEXT

GLScene.OpenGL4

glSecondaryColor3usv

GLScene.OpenGL4

deprecated;

glSecondaryColor3usvEXT

GLScene.OpenGL4

glSecondaryColorFormatNV

GLScene.OpenGL4

glSecondaryColorP3ui

GLScene.OpenGL4

glSecondaryColorP3uiv

GLScene.OpenGL4

glSecondaryColorPointer

GLScene.OpenGL4

deprecated;

glSecondaryColorPointerEXT

GLScene.OpenGL4

glSelectBuffer

GLScene.OpenGL4

glSeparableFilter2D

GLScene.OpenGL4

deprecated;

GLSetCursorPos

GXS.Screen

glSetFenceNV

GLScene.OpenGL4

glShadeModel

GLScene.OpenGL4

deprecated;

glShaderSource

GLScene.OpenGL4

glShaderSourceARB

GLScene.OpenGL4

GLshort

GLScene.OpenGL4

GLShowCursor

GXS.Screen

GLsizei

GLScene.OpenGL4

GLSLogger

GLScene.Logger

Inner logger. Converted to a function, because in case of a DLL and main app using this module, log is written to the same file on initialization and finalization, which is not what one might want. This also allows to create a GLSLogger with custom parameters for user's application, for example a different log path (Often the EXE application directory is read-only).

GLSLTypeComponentCount

GXSL.ShaderParameter

GLSLTypeEnum

GXSL.ShaderParameter

glStencilClearTagEXT

GLScene.OpenGL4

GL_EXT_stencil_clear_tag (EXT #314)

glStencilFunc

GLScene.OpenGL4

deprecated;

glStencilFuncSeparate

GLScene.OpenGL4

glStencilMask

GLScene.OpenGL4

glStencilMaskSeparate

GLScene.OpenGL4

glStencilOp

GLScene.OpenGL4

glStencilOpSeparate

GLScene.OpenGL4

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

glStringMarkerGREMEDY

GLScene.OpenGL4

GLStrToFloatDef

GLScene.Utils

GLStrToFloatDef

GLScene.Utils

GLStrToFloatDef

GLScene.Utils

Added by PAL to fix problem with decimal separator in not En-US configurations Decimal separator in text descriptions of meshes for import/export is always '.' char But in System.SysUtils.TextToFloat is Windows char, maybe ',' or others...

glTbufferMask3DFX

GLScene.OpenGL4

GL_3DFX_tbuffer (EXT #208)

glTessellationFactorAMD

GLScene.OpenGL4

GL_AMD_vertex_shader_tessellator (#363)

glTessellationModeAMD

GLScene.OpenGL4

glTestFenceNV

GLScene.OpenGL4

glTexBuffer

GLScene.OpenGL4

glTexBufferARB

GLScene.OpenGL4

GL_ARB_texture_buffer_object (ARB #51)

glTexBufferEXT

GLScene.OpenGL4

GL_EXT_packed_float (#328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (#329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: TGLuint; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (#330)

glTexCoord1d

GLScene.OpenGL4

glTexCoord1dv

GLScene.OpenGL4

deprecated;

glTexCoord1f

GLScene.OpenGL4

deprecated;

glTexCoord1fv

GLScene.OpenGL4

deprecated;

glTexCoord1i

GLScene.OpenGL4

deprecated;

glTexCoord1iv

GLScene.OpenGL4

deprecated;

glTexCoord1s

GLScene.OpenGL4

deprecated;

glTexCoord1sv

GLScene.OpenGL4

deprecated;

glTexCoord2d

GLScene.OpenGL4

deprecated;

glTexCoord2dv

GLScene.OpenGL4

deprecated;

glTexCoord2f

GLScene.OpenGL4

deprecated;

glTexCoord2fv

GLScene.OpenGL4

deprecated;

glTexCoord2i

GLScene.OpenGL4

deprecated;

glTexCoord2iv

GLScene.OpenGL4

deprecated;

glTexCoord2s

GLScene.OpenGL4

deprecated;

glTexCoord2sv

GLScene.OpenGL4

deprecated;

glTexCoord3d

GLScene.OpenGL4

deprecated;

glTexCoord3dv

GLScene.OpenGL4

deprecated;

glTexCoord3f

GLScene.OpenGL4

deprecated;

glTexCoord3fv

GLScene.OpenGL4

deprecated;

glTexCoord3i

GLScene.OpenGL4

deprecated;

glTexCoord3iv

GLScene.OpenGL4

deprecated;

glTexCoord3s

GLScene.OpenGL4

deprecated;

glTexCoord3sv

GLScene.OpenGL4

deprecated;

glTexCoord4d

GLScene.OpenGL4

deprecated;

glTexCoord4dv

GLScene.OpenGL4

deprecated;

glTexCoord4f

GLScene.OpenGL4

deprecated;

glTexCoord4fv

GLScene.OpenGL4

deprecated;

glTexCoord4i

GLScene.OpenGL4

deprecated;

glTexCoord4iv

GLScene.OpenGL4

deprecated;

glTexCoord4s

GLScene.OpenGL4

deprecated;

glTexCoord4sv

GLScene.OpenGL4

deprecated;

glTexCoordFormatNV

GLScene.OpenGL4

glTexCoordP1ui

GLScene.OpenGL4

glTexCoordP1uiv

GLScene.OpenGL4

glTexCoordP2ui

GLScene.OpenGL4

glTexCoordP2uiv

GLScene.OpenGL4

glTexCoordP3ui

GLScene.OpenGL4

glTexCoordP3uiv

GLScene.OpenGL4

glTexCoordP4ui

GLScene.OpenGL4

glTexCoordP4uiv

GLScene.OpenGL4

glTexCoordPointer

GLScene.OpenGL4

deprecated;

glTexEnvf

GLScene.OpenGL4

deprecated;

glTexEnvfv

GLScene.OpenGL4

deprecated;

glTexEnvi

GLScene.OpenGL4

deprecated;

glTexEnviv

GLScene.OpenGL4

deprecated;

glTexGend

GLScene.OpenGL4

deprecated;

glTexGendv

GLScene.OpenGL4

deprecated;

glTexGenf

GLScene.OpenGL4

deprecated;

glTexGenfv

GLScene.OpenGL4

deprecated;

glTexGeni

GLScene.OpenGL4

deprecated;

glTexGeniv

GLScene.OpenGL4

deprecated;

glTexImage1D

GLScene.OpenGL4

deprecated;

glTexImage2D

GLScene.OpenGL4

glTexImage2DMultisample

GLScene.OpenGL4

GL_ARB_texture_multisample (ARB #67)

glTexImage3D

GLScene.OpenGL4

promoted to core v1.2 from GL_EXT_texture3D (#6)

glTexImage3DEXT

GLScene.OpenGL4

GL_EXT_texture3D (EXT #6)

glTexImage3DMultisample

GLScene.OpenGL4

glTexParameterf

GLScene.OpenGL4

glTexParameterfv

GLScene.OpenGL4

glTexParameteri

GLScene.OpenGL4

glTexParameterIiv

GLScene.OpenGL4

promoted to core v3.0 from GL_EXT_texture_integer glClearColorIi: procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF} glClearColorIui: procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint);{$IFDEF MSWINDOWS} stdcall; {$ELSE} cdecl; {$ENDIF}

glTexParameterIivEXT

GLScene.OpenGL4

glTexParameterIuiv

GLScene.OpenGL4

glTexParameterIuivEXT

GLScene.OpenGL4

glTexParameteriv

GLScene.OpenGL4

glTexSubImage1D

GLScene.OpenGL4

glTexSubImage1DEXT

GLScene.OpenGL4

GL_EXT_subtexture (EXT #9)

glTexSubImage2D

GLScene.OpenGL4

glTexSubImage2DEXT

GLScene.OpenGL4

glTexSubImage3D

GLScene.OpenGL4

glTexSubImage3DEXT

GLScene.OpenGL4

glTextureColorMaskSGIS

GLScene.OpenGL4

GL_SGIS_texture_color_mask (EXT #214)

glTrackMatrixNV

GLScene.OpenGL4

glTransformFeedbackAttribsNV

GLScene.OpenGL4

glTransformFeedbackVaryings

GLScene.OpenGL4

glTransformFeedbackVaryingsEXT

GLScene.OpenGL4

glTransformFeedbackVaryingsNV

GLScene.OpenGL4

glTranslated

GLScene.OpenGL4

glTranslatef

GLScene.OpenGL4

deprecated;

glu32

GLScene.OpenGL4

glu32

GXS.OpenGLAdapter

gluBeginCurve

GLScene.OpenGL4

gluBeginCurve

GXS.OpenGLAdapter

gluBeginPolygon

GLScene.OpenGL4

gluBeginPolygon

GXS.OpenGLAdapter

gluBeginSurface

GLScene.OpenGL4

gluBeginSurface

GXS.OpenGLAdapter

gluBeginTrim

GLScene.OpenGL4

gluBeginTrim

GXS.OpenGLAdapter

gluBuild1DMipmaps

GLScene.OpenGL4

gluBuild1DMipmaps

GXS.OpenGLAdapter

gluBuild2DMipmaps

GLScene.OpenGL4

gluBuild2DMipmaps

GXS.OpenGLAdapter

GLubyte

GLScene.OpenGL4

gluCylinder

GLScene.OpenGL4

gluCylinder

GXS.OpenGLAdapter

gluDeleteNurbsRenderer

GLScene.OpenGL4

gluDeleteNurbsRenderer

GXS.OpenGLAdapter

gluDeleteNurbsTessellatorEXT

GLScene.OpenGL4

gluDeleteQuadric

GLScene.OpenGL4

gluDeleteQuadric

GXS.OpenGLAdapter

gluDeleteTess

GLScene.OpenGL4

gluDeleteTess

GXS.OpenGLAdapter

gluDisk

GLScene.OpenGL4

gluDisk

GXS.OpenGLAdapter

gluEndCurve

GLScene.OpenGL4

gluEndCurve

GXS.OpenGLAdapter

gluEndPolygon

GLScene.OpenGL4

gluEndPolygon

GXS.OpenGLAdapter

gluEndSurface

GLScene.OpenGL4

gluEndSurface

GXS.OpenGLAdapter

gluEndTrim

GLScene.OpenGL4

gluEndTrim

GXS.OpenGLAdapter

gluErrorString

GLScene.OpenGL4

GLU utility functions and procedures

gluErrorString

GXS.OpenGLAdapter

function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32; function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32; function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32; function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA'; function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';

gluGetNurbsProperty

GLScene.OpenGL4

gluGetNurbsProperty

GXS.OpenGLAdapter

gluGetString

GLScene.OpenGL4

gluGetString

GXS.OpenGLAdapter

gluGetTessProperty

GLScene.OpenGL4

gluGetTessProperty

GXS.OpenGLAdapter

GLuint

GLScene.OpenGL4

GLuint64

GLScene.OpenGL4

GLuint64EXT

GLScene.OpenGL4

gluLoadSamplingMatrices

GLScene.OpenGL4

gluLoadSamplingMatrices

GXS.OpenGLAdapter

gluLookAt

GLScene.OpenGL4

gluLookAt

GXS.OpenGLAdapter

gluNewNurbsRenderer

GLScene.OpenGL4

gluNewNurbsRenderer

GXS.OpenGLAdapter

gluNewNurbsTessellatorEXT

GLScene.OpenGL4

gluNewQuadric

GLScene.OpenGL4

gluNewQuadric

GXS.OpenGLAdapter

gluNewTess

GLScene.OpenGL4

gluNewTess

GXS.OpenGLAdapter

gluNextContour

GLScene.OpenGL4

gluNextContour

GXS.OpenGLAdapter

glUniform1d

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64 (ARB #89)

glUniform1dv

GLScene.OpenGL4

glUniform1f

GLScene.OpenGL4

glUniform1fARB

GLScene.OpenGL4

glUniform1fv

GLScene.OpenGL4

glUniform1fvARB

GLScene.OpenGL4

glUniform1i

GLScene.OpenGL4

glUniform1iARB

GLScene.OpenGL4

glUniform1iv

GLScene.OpenGL4

glUniform1ivARB

GLScene.OpenGL4

glUniform1ui

GLScene.OpenGL4

glUniform1uiEXT

GLScene.OpenGL4

glUniform1uiv

GLScene.OpenGL4

glUniform1uivEXT

GLScene.OpenGL4

glUniform2d

GLScene.OpenGL4

glUniform2dv

GLScene.OpenGL4

glUniform2f

GLScene.OpenGL4

glUniform2fARB

GLScene.OpenGL4

glUniform2fv

GLScene.OpenGL4

glUniform2fvARB

GLScene.OpenGL4

glUniform2i

GLScene.OpenGL4

glUniform2iARB

GLScene.OpenGL4

glUniform2iv

GLScene.OpenGL4

glUniform2ivARB

GLScene.OpenGL4

glUniform2ui

GLScene.OpenGL4

glUniform2uiEXT

GLScene.OpenGL4

glUniform2uiv

GLScene.OpenGL4

glUniform2uivEXT

GLScene.OpenGL4

glUniform3d

GLScene.OpenGL4

glUniform3dv

GLScene.OpenGL4

glUniform3f

GLScene.OpenGL4

glUniform3fARB

GLScene.OpenGL4

glUniform3fv

GLScene.OpenGL4

glUniform3fvARB

GLScene.OpenGL4

glUniform3i

GLScene.OpenGL4

glUniform3iARB

GLScene.OpenGL4

glUniform3iv

GLScene.OpenGL4

glUniform3ivARB

GLScene.OpenGL4

glUniform3ui

GLScene.OpenGL4

glUniform3uiEXT

GLScene.OpenGL4

glUniform3uiv

GLScene.OpenGL4

glUniform3uivEXT

GLScene.OpenGL4

glUniform4d

GLScene.OpenGL4

glUniform4dv

GLScene.OpenGL4

glUniform4f

GLScene.OpenGL4

glUniform4fARB

GLScene.OpenGL4

glUniform4fv

GLScene.OpenGL4

glUniform4fvARB

GLScene.OpenGL4

glUniform4i

GLScene.OpenGL4

glUniform4iARB

GLScene.OpenGL4

glUniform4iv

GLScene.OpenGL4

glUniform4ivARB

GLScene.OpenGL4

glUniform4ui

GLScene.OpenGL4

glUniform4uiEXT

GLScene.OpenGL4

glUniform4uiv

GLScene.OpenGL4

glUniform4uivEXT

GLScene.OpenGL4

glUniformBlockBinding

GLScene.OpenGL4

glUniformBufferEXT

GLScene.OpenGL4

GL_EXT_bindable_uniform (#342)

glUniformMatrix2dv

GLScene.OpenGL4

glUniformMatrix2fv

GLScene.OpenGL4

glUniformMatrix2fvARB

GLScene.OpenGL4

glUniformMatrix2x3dv

GLScene.OpenGL4

glUniformMatrix2x3fv

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 2.1 Core ###########################################################

glUniformMatrix2x4dv

GLScene.OpenGL4

glUniformMatrix2x4fv

GLScene.OpenGL4

glUniformMatrix3dv

GLScene.OpenGL4

glUniformMatrix3fv

GLScene.OpenGL4

glUniformMatrix3fvARB

GLScene.OpenGL4

glUniformMatrix3x2dv

GLScene.OpenGL4

glUniformMatrix3x2fv

GLScene.OpenGL4

glUniformMatrix3x4dv

GLScene.OpenGL4

glUniformMatrix3x4fv

GLScene.OpenGL4

glUniformMatrix4dv

GLScene.OpenGL4

glUniformMatrix4fv

GLScene.OpenGL4

glUniformMatrix4fvARB

GLScene.OpenGL4

glUniformMatrix4x2dv

GLScene.OpenGL4

glUniformMatrix4x2fv

GLScene.OpenGL4

glUniformMatrix4x3dv

GLScene.OpenGL4

glUniformMatrix4x3fv

GLScene.OpenGL4

glUniformSubroutinesuiv

GLScene.OpenGL4

glUniformui64NV

GLScene.OpenGL4

glUniformui64vNV

GLScene.OpenGL4

glUnlockArraysEXT

GLScene.OpenGL4

glUnmapBuffer

GLScene.OpenGL4

glUnmapBufferARB

GLScene.OpenGL4

gluNurbsCallback

GLScene.OpenGL4

gluNurbsCallback

GXS.OpenGLAdapter

gluNurbsCallbackDataEXT

GLScene.OpenGL4

GL_ARB_draw_indirect (ARB #87) GL_ARB_gpu_shader5 (ARB #88) (none) GL_ARB_gpu_shader_fp64 (ARB #89) GL_ARB_shader_subroutine (ARB #90) GL_ARB_tessellation_shader (ARB #91) GL_ARB_texture_buffer_object_rgb32 (ARB #92) (none) GL_ARB_transform_feedback2 (ARB #93) GL_ARB_transform_feedback3 (ARB #94) GL_VERSION_4_1 ########################################################### function and procedure definitions for GLU extensions ########################################################### GLU extensions

gluNurbsCurve

GLScene.OpenGL4

gluNurbsCurve

GXS.OpenGLAdapter

gluNurbsProperty

GLScene.OpenGL4

gluNurbsProperty

GXS.OpenGLAdapter

gluNurbsSurface

GLScene.OpenGL4

gluNurbsSurface

GXS.OpenGLAdapter

gluOrtho2D

GLScene.OpenGL4

gluOrtho2D

GXS.OpenGLAdapter

gluPartialDisk

GLScene.OpenGL4

gluPartialDisk

GXS.OpenGLAdapter

gluPerspective

GLScene.OpenGL4

gluPerspective

GXS.OpenGLAdapter

gluPickMatrix

GLScene.OpenGL4

gluPickMatrix

GXS.OpenGLAdapter

gluProject

GLScene.OpenGL4

gluProject

GXS.OpenGLAdapter

gluPwlCurve

GLScene.OpenGL4

gluPwlCurve

GXS.OpenGLAdapter

gluQuadricCallback

GLScene.OpenGL4

gluQuadricCallback

GXS.OpenGLAdapter

gluQuadricDrawStyle

GLScene.OpenGL4

gluQuadricDrawStyle

GXS.OpenGLAdapter

gluQuadricNormals

GLScene.OpenGL4

gluQuadricNormals

GXS.OpenGLAdapter

gluQuadricOrientation

GLScene.OpenGL4

gluQuadricOrientation

GXS.OpenGLAdapter

gluQuadricTexture

GLScene.OpenGL4

gluQuadricTexture

GXS.OpenGLAdapter

gluScaleImage

GLScene.OpenGL4

gluScaleImage

GXS.OpenGLAdapter

glUseProgram

GLScene.OpenGL4

glUseProgramObjectARB

GLScene.OpenGL4

GLushort

GLScene.OpenGL4

gluSphere

GLScene.OpenGL4

gluSphere

GXS.OpenGLAdapter

gluTessBeginContour

GLScene.OpenGL4

gluTessBeginContour

GXS.OpenGLAdapter

gluTessBeginPolygon

GLScene.OpenGL4

gluTessBeginPolygon

GXS.OpenGLAdapter

gluTessCallback

GLScene.OpenGL4

gluTessCallback

GXS.OpenGLAdapter

gluTessEndContour

GLScene.OpenGL4

gluTessEndContour

GXS.OpenGLAdapter

gluTessEndPolygon

GLScene.OpenGL4

gluTessEndPolygon

GXS.OpenGLAdapter

gluTessNormal

GLScene.OpenGL4

gluTessNormal

GXS.OpenGLAdapter

gluTessProperty

GLScene.OpenGL4

gluTessProperty

GXS.OpenGLAdapter

gluTessVertex

GLScene.OpenGL4

gluTessVertex

GXS.OpenGLAdapter

gluUnProject

GLScene.OpenGL4

gluUnProject

GXS.OpenGLAdapter

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGL4

GLU_AUTO_LOAD_MATRIX

GLScene.OpenGLTokens

NURBS constants NurbsProperty

GLU_BEGIN

GLScene.OpenGL4

GLU_BEGIN

GLScene.OpenGLTokens

Names without "TESS_" prefix

GLU_CCW

GLScene.OpenGL4

GLU_CCW

GLScene.OpenGLTokens

GLU_CULLING

GLScene.OpenGL4

GLU_CULLING

GLScene.OpenGLTokens

GLU_CW

GLScene.OpenGL4

GLU_CW

GLScene.OpenGLTokens

Contours types – obsolete!

GLU_DISPLAY_MODE

GLScene.OpenGL4

GLU_DISPLAY_MODE

GLScene.OpenGLTokens

GLU_DOMAIN_DISTANCE

GLScene.OpenGL4

GLU_DOMAIN_DISTANCE

GLScene.OpenGLTokens

GLU_EDGE_FLAG

GLScene.OpenGL4

GLU_EDGE_FLAG

GLScene.OpenGLTokens

GLU_END

GLScene.OpenGL4

GLU_END

GLScene.OpenGLTokens

GLU_ERROR

GLScene.OpenGL4

GLU_ERROR

GLScene.OpenGLTokens

GLU_EXTENSIONS

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGL4

GLU_EXTERIOR

GLScene.OpenGLTokens

GLU_FALSE

GLScene.OpenGL4

GLU_FILL

GLScene.OpenGL4

GLU_FLAT

GLScene.OpenGL4

GLU_INCOMPATIBLE_GL_VERSION

GLScene.OpenGL4

GLU_INSIDE

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGL4

GLU_INTERIOR

GLScene.OpenGLTokens

GLU_INVALID_ENUM

GLScene.OpenGL4

GLU

GLU_INVALID_VALUE

GLScene.OpenGL4

GLU_LINE

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGL4

GLU_MAP1_TRIM_2

GLScene.OpenGLTokens

NurbsTrim

GLU_MAP1_TRIM_3

GLScene.OpenGL4

GLU_MAP1_TRIM_3

GLScene.OpenGLTokens

GLU_NONE

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGL4

GLU_NURBS_ERROR1

GLScene.OpenGLTokens

NurbsErrors

GLU_NURBS_ERROR10

GLScene.OpenGL4

GLU_NURBS_ERROR10

GLScene.OpenGLTokens

GLU_NURBS_ERROR11

GLScene.OpenGL4

GLU_NURBS_ERROR11

GLScene.OpenGLTokens

GLU_NURBS_ERROR12

GLScene.OpenGL4

GLU_NURBS_ERROR12

GLScene.OpenGLTokens

GLU_NURBS_ERROR13

GLScene.OpenGL4

GLU_NURBS_ERROR13

GLScene.OpenGLTokens

GLU_NURBS_ERROR14

GLScene.OpenGL4

GLU_NURBS_ERROR14

GLScene.OpenGLTokens

GLU_NURBS_ERROR15

GLScene.OpenGL4

GLU_NURBS_ERROR15

GLScene.OpenGLTokens

GLU_NURBS_ERROR16

GLScene.OpenGL4

GLU_NURBS_ERROR16

GLScene.OpenGLTokens

GLU_NURBS_ERROR17

GLScene.OpenGL4

GLU_NURBS_ERROR17

GLScene.OpenGLTokens

GLU_NURBS_ERROR18

GLScene.OpenGL4

GLU_NURBS_ERROR18

GLScene.OpenGLTokens

GLU_NURBS_ERROR19

GLScene.OpenGL4

GLU_NURBS_ERROR19

GLScene.OpenGLTokens

GLU_NURBS_ERROR2

GLScene.OpenGL4

GLU_NURBS_ERROR2

GLScene.OpenGLTokens

GLU_NURBS_ERROR20

GLScene.OpenGL4

GLU_NURBS_ERROR20

GLScene.OpenGLTokens

GLU_NURBS_ERROR21

GLScene.OpenGL4

GLU_NURBS_ERROR21

GLScene.OpenGLTokens

GLU_NURBS_ERROR22

GLScene.OpenGL4

GLU_NURBS_ERROR22

GLScene.OpenGLTokens

GLU_NURBS_ERROR23

GLScene.OpenGL4

GLU_NURBS_ERROR23

GLScene.OpenGLTokens

GLU_NURBS_ERROR24

GLScene.OpenGL4

GLU_NURBS_ERROR24

GLScene.OpenGLTokens

GLU_NURBS_ERROR25

GLScene.OpenGL4

GLU_NURBS_ERROR25

GLScene.OpenGLTokens

GLU_NURBS_ERROR26

GLScene.OpenGL4

GLU_NURBS_ERROR26

GLScene.OpenGLTokens

GLU_NURBS_ERROR27

GLScene.OpenGL4

GLU_NURBS_ERROR27

GLScene.OpenGLTokens

GLU_NURBS_ERROR28

GLScene.OpenGL4

GLU_NURBS_ERROR28

GLScene.OpenGLTokens

GLU_NURBS_ERROR29

GLScene.OpenGL4

GLU_NURBS_ERROR29

GLScene.OpenGLTokens

GLU_NURBS_ERROR3

GLScene.OpenGL4

GLU_NURBS_ERROR3

GLScene.OpenGLTokens

GLU_NURBS_ERROR30

GLScene.OpenGL4

GLU_NURBS_ERROR30

GLScene.OpenGLTokens

GLU_NURBS_ERROR31

GLScene.OpenGL4

GLU_NURBS_ERROR31

GLScene.OpenGLTokens

GLU_NURBS_ERROR32

GLScene.OpenGL4

GLU_NURBS_ERROR32

GLScene.OpenGLTokens

GLU_NURBS_ERROR33

GLScene.OpenGL4

GLU_NURBS_ERROR33

GLScene.OpenGLTokens

GLU_NURBS_ERROR34

GLScene.OpenGL4

GLU_NURBS_ERROR34

GLScene.OpenGLTokens

GLU_NURBS_ERROR35

GLScene.OpenGL4

GLU_NURBS_ERROR35

GLScene.OpenGLTokens

GLU_NURBS_ERROR36

GLScene.OpenGL4

GLU_NURBS_ERROR36

GLScene.OpenGLTokens

GLU_NURBS_ERROR37

GLScene.OpenGL4

GLU_NURBS_ERROR37

GLScene.OpenGLTokens

GLU_NURBS_ERROR4

GLScene.OpenGL4

GLU_NURBS_ERROR4

GLScene.OpenGLTokens

GLU_NURBS_ERROR5

GLScene.OpenGL4

GLU_NURBS_ERROR5

GLScene.OpenGLTokens

GLU_NURBS_ERROR6

GLScene.OpenGL4

GLU_NURBS_ERROR6

GLScene.OpenGLTokens

GLU_NURBS_ERROR7

GLScene.OpenGL4

GLU_NURBS_ERROR7

GLScene.OpenGLTokens

GLU_NURBS_ERROR8

GLScene.OpenGL4

GLU_NURBS_ERROR8

GLScene.OpenGLTokens

GLU_NURBS_ERROR9

GLScene.OpenGL4

GLU_NURBS_ERROR9

GLScene.OpenGLTokens

GLU_OUTLINE_PATCH

GLScene.OpenGL4

GLU_OUTLINE_PATCH

GLScene.OpenGLTokens

GLU_OUTLINE_POLYGON

GLScene.OpenGL4

GLU_OUTLINE_POLYGON

GLScene.OpenGLTokens

NurbsDisplay

GLU_OUTSIDE

GLScene.OpenGL4

GLU_OUT_OF_MEMORY

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGL4

GLU_PARAMETRIC_ERROR

GLScene.OpenGLTokens

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGL4

GLU_PARAMETRIC_TOLERANCE

GLScene.OpenGLTokens

GLU_PATH_LENGTH

GLScene.OpenGL4

GLU_PATH_LENGTH

GLScene.OpenGLTokens

NurbsSampling

GLU_POINT

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGL4

GLU_SAMPLING_METHOD

GLScene.OpenGLTokens

GLU_SAMPLING_TOLERANCE

GLScene.OpenGL4

GLU_SAMPLING_TOLERANCE

GLScene.OpenGLTokens

GLU_SILHOUETTE

GLScene.OpenGL4

GLU_SMOOTH

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGL4

GLU_TESS_BEGIN

GLScene.OpenGLTokens

********** GLU generic constants ********** TessCallback

GLU_TESS_BEGIN_DATA

GLScene.OpenGL4

GLU_TESS_BEGIN_DATA

GLScene.OpenGLTokens

TGLUTessCombineProc

GLU_TESS_BOUNDARY_ONLY

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGL4

GLU_TESS_COMBINE

GLScene.OpenGLTokens

TGLUTessEdgeFlagProc

GLU_TESS_COMBINE_DATA

GLScene.OpenGL4

GLU_TESS_COMBINE_DATA

GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGL4

GLU_TESS_COORD_TOO_LARGE

GLScene.OpenGLTokens

GLU_TESS_EDGE_FLAG

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG

GLScene.OpenGLTokens

TGLUTessErrorProc

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGL4

GLU_TESS_EDGE_FLAG_DATA

GLScene.OpenGLTokens

TGLUTessErrorDataProc

GLU_TESS_END

GLScene.OpenGL4

GLU_TESS_END

GLScene.OpenGLTokens

TGLUTessVertexProc

GLU_TESS_END_DATA

GLScene.OpenGL4

GLU_TESS_END_DATA

GLScene.OpenGLTokens

TGLUTessVertexDataProc

GLU_TESS_ERROR

GLScene.OpenGL4

GLU_TESS_ERROR

GLScene.OpenGLTokens

TGLUTessEndProc

GLU_TESS_ERROR1

GLScene.OpenGL4

GLU_TESS_ERROR1

GLScene.OpenGLTokens

TGLUTessCombineDataProc TessError

GLU_TESS_ERROR2

GLScene.OpenGL4

GLU_TESS_ERROR2

GLScene.OpenGLTokens

GLU_TESS_ERROR3

GLScene.OpenGL4

GLU_TESS_ERROR3

GLScene.OpenGLTokens

GLU_TESS_ERROR4

GLScene.OpenGL4

GLU_TESS_ERROR4

GLScene.OpenGLTokens

GLU_TESS_ERROR5

GLScene.OpenGL4

GLU_TESS_ERROR5

GLScene.OpenGLTokens

GLU_TESS_ERROR6

GLScene.OpenGL4

GLU_TESS_ERROR6

GLScene.OpenGLTokens

GLU_TESS_ERROR7

GLScene.OpenGL4

GLU_TESS_ERROR7

GLScene.OpenGLTokens

GLU_TESS_ERROR8

GLScene.OpenGL4

GLU_TESS_ERROR8

GLScene.OpenGLTokens

GLU_TESS_ERROR_DATA

GLScene.OpenGL4

GLU_TESS_ERROR_DATA

GLScene.OpenGLTokens

TGLUTessEndDataProc

GLU_TESS_MAX_COORD

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_BEGIN_POLYGON

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGL4

GLU_TESS_MISSING_END_CONTOUR

GLScene.OpenGLTokens

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGL4

GLU_TESS_MISSING_END_POLYGON

GLScene.OpenGLTokens

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGL4

GLU_TESS_NEED_COMBINE_CALLBACK

GLScene.OpenGLTokens

GLU_TESS_TOLERANCE

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGL4

GLU_TESS_VERTEX

GLScene.OpenGLTokens

TGLUTessBeginProc

GLU_TESS_VERTEX_DATA

GLScene.OpenGL4

GLU_TESS_VERTEX_DATA

GLScene.OpenGLTokens

TGLUTessBeginDataProc

GLU_TESS_WINDING_ABS_GEQ_TWO

GLScene.OpenGL4

GLU_TESS_WINDING_NEGATIVE

GLScene.OpenGL4

GLU_TESS_WINDING_NONZERO

GLScene.OpenGL4

GLU_TESS_WINDING_ODD

GLScene.OpenGL4

GLU_TESS_WINDING_POSITIVE

GLScene.OpenGL4

GLU_TESS_WINDING_RULE

GLScene.OpenGL4

GLU_TRUE

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGL4

GLU_UNKNOWN

GLScene.OpenGLTokens

GLU_U_STEP

GLScene.OpenGL4

GLU_U_STEP

GLScene.OpenGLTokens

GLU_VERSION

GLScene.OpenGL4

GLU_VERSION_1_3

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGL4

GLU_VERTEX

GLScene.OpenGLTokens

GLU_V_STEP

GLScene.OpenGL4

GLU_V_STEP

GLScene.OpenGLTokens

glValidateProgram

GLScene.OpenGL4

glValidateProgramARB

GLScene.OpenGL4

glVertex2d

GLScene.OpenGL4

deprecated;

glVertex2dv

GLScene.OpenGL4

deprecated;

glVertex2f

GLScene.OpenGL4

deprecated;

glVertex2fv

GLScene.OpenGL4

deprecated;

glVertex2i

GLScene.OpenGL4

deprecated;

glVertex2iv

GLScene.OpenGL4

deprecated;

glVertex2s

GLScene.OpenGL4

deprecated;

glVertex2sv

GLScene.OpenGL4

deprecated;

glVertex3d

GLScene.OpenGL4

deprecated;

glVertex3dv

GLScene.OpenGL4

deprecated;

glVertex3f

GLScene.OpenGL4

deprecated;

glVertex3fv

GLScene.OpenGL4

deprecated;

glVertex3i

GLScene.OpenGL4

deprecated;

glVertex3iv

GLScene.OpenGL4

deprecated;

glVertex3s

GLScene.OpenGL4

deprecated;

glVertex3sv

GLScene.OpenGL4

deprecated;

glVertex4d

GLScene.OpenGL4

deprecated;

glVertex4dv

GLScene.OpenGL4

deprecated;

glVertex4f

GLScene.OpenGL4

deprecated;

glVertex4fv

GLScene.OpenGL4

deprecated;

glVertex4i

GLScene.OpenGL4

deprecated;

glVertex4iv

GLScene.OpenGL4

deprecated;

glVertex4s

GLScene.OpenGL4

deprecated;

glVertex4sv

GLScene.OpenGL4

deprecated;

glVertexArrayRangeNV

GLScene.OpenGL4

glVertexAttrib1d

GLScene.OpenGL4

glVertexAttrib1dARB

GLScene.OpenGL4

GL_ARB_vertex_program (ARB #26)

glVertexAttrib1dNV

GLScene.OpenGL4

glVertexAttrib1dv

GLScene.OpenGL4

glVertexAttrib1dvARB

GLScene.OpenGL4

glVertexAttrib1dvNV

GLScene.OpenGL4

glVertexAttrib1f

GLScene.OpenGL4

glVertexAttrib1fARB

GLScene.OpenGL4

glVertexAttrib1fNV

GLScene.OpenGL4

glVertexAttrib1fv

GLScene.OpenGL4

glVertexAttrib1fvARB

GLScene.OpenGL4

glVertexAttrib1fvNV

GLScene.OpenGL4

glVertexAttrib1s

GLScene.OpenGL4

glVertexAttrib1sARB

GLScene.OpenGL4

glVertexAttrib1sNV

GLScene.OpenGL4

glVertexAttrib1sv

GLScene.OpenGL4

glVertexAttrib1svARB

GLScene.OpenGL4

glVertexAttrib1svNV

GLScene.OpenGL4

glVertexAttrib2d

GLScene.OpenGL4

glVertexAttrib2dARB

GLScene.OpenGL4

glVertexAttrib2dNV

GLScene.OpenGL4

glVertexAttrib2dv

GLScene.OpenGL4

glVertexAttrib2dvARB

GLScene.OpenGL4

glVertexAttrib2dvNV

GLScene.OpenGL4

glVertexAttrib2f

GLScene.OpenGL4

glVertexAttrib2fARB

GLScene.OpenGL4

glVertexAttrib2fNV

GLScene.OpenGL4

glVertexAttrib2fv

GLScene.OpenGL4

glVertexAttrib2fvARB

GLScene.OpenGL4

glVertexAttrib2fvNV

GLScene.OpenGL4

glVertexAttrib2s

GLScene.OpenGL4

glVertexAttrib2sARB

GLScene.OpenGL4

glVertexAttrib2sNV

GLScene.OpenGL4

glVertexAttrib2sv

GLScene.OpenGL4

glVertexAttrib2svARB

GLScene.OpenGL4

glVertexAttrib2svNV

GLScene.OpenGL4

glVertexAttrib3d

GLScene.OpenGL4

glVertexAttrib3dARB

GLScene.OpenGL4

glVertexAttrib3dNV

GLScene.OpenGL4

glVertexAttrib3dv

GLScene.OpenGL4

glVertexAttrib3dvARB

GLScene.OpenGL4

glVertexAttrib3dvNV

GLScene.OpenGL4

glVertexAttrib3f

GLScene.OpenGL4

glVertexAttrib3fARB

GLScene.OpenGL4

glVertexAttrib3fNV

GLScene.OpenGL4

glVertexAttrib3fv

GLScene.OpenGL4

glVertexAttrib3fvARB

GLScene.OpenGL4

glVertexAttrib3fvNV

GLScene.OpenGL4

glVertexAttrib3s

GLScene.OpenGL4

glVertexAttrib3sARB

GLScene.OpenGL4

glVertexAttrib3sNV

GLScene.OpenGL4

glVertexAttrib3sv

GLScene.OpenGL4

glVertexAttrib3svARB

GLScene.OpenGL4

glVertexAttrib3svNV

GLScene.OpenGL4

glVertexAttrib4bv

GLScene.OpenGL4

glVertexAttrib4bvARB

GLScene.OpenGL4

glVertexAttrib4d

GLScene.OpenGL4

glVertexAttrib4dARB

GLScene.OpenGL4

glVertexAttrib4dNV

GLScene.OpenGL4

glVertexAttrib4dv

GLScene.OpenGL4

glVertexAttrib4dvARB

GLScene.OpenGL4

glVertexAttrib4dvNV

GLScene.OpenGL4

glVertexAttrib4f

GLScene.OpenGL4

glVertexAttrib4fARB

GLScene.OpenGL4

glVertexAttrib4fNV

GLScene.OpenGL4

glVertexAttrib4fv

GLScene.OpenGL4

glVertexAttrib4fvARB

GLScene.OpenGL4

glVertexAttrib4fvNV

GLScene.OpenGL4

glVertexAttrib4iv

GLScene.OpenGL4

glVertexAttrib4ivARB

GLScene.OpenGL4

glVertexAttrib4Nbv

GLScene.OpenGL4

glVertexAttrib4NbvARB

GLScene.OpenGL4

glVertexAttrib4Niv

GLScene.OpenGL4

glVertexAttrib4NivARB

GLScene.OpenGL4

glVertexAttrib4Nsv

GLScene.OpenGL4

glVertexAttrib4NsvARB

GLScene.OpenGL4

glVertexAttrib4Nub

GLScene.OpenGL4

glVertexAttrib4NubARB

GLScene.OpenGL4

glVertexAttrib4Nubv

GLScene.OpenGL4

glVertexAttrib4NubvARB

GLScene.OpenGL4

glVertexAttrib4Nuiv

GLScene.OpenGL4

glVertexAttrib4NuivARB

GLScene.OpenGL4

glVertexAttrib4Nusv

GLScene.OpenGL4

glVertexAttrib4NusvARB

GLScene.OpenGL4

glVertexAttrib4s

GLScene.OpenGL4

glVertexAttrib4sARB

GLScene.OpenGL4

glVertexAttrib4sNV

GLScene.OpenGL4

glVertexAttrib4sv

GLScene.OpenGL4

glVertexAttrib4svARB

GLScene.OpenGL4

glVertexAttrib4svNV

GLScene.OpenGL4

glVertexAttrib4ubv

GLScene.OpenGL4

glVertexAttrib4ubvARB

GLScene.OpenGL4

glVertexAttrib4ubvNV

GLScene.OpenGL4

glVertexAttrib4uiv

GLScene.OpenGL4

glVertexAttrib4uivARB

GLScene.OpenGL4

glVertexAttrib4usv

GLScene.OpenGL4

glVertexAttrib4usvARB

GLScene.OpenGL4

glVertexAttribDivisorARB

GLScene.OpenGL4

GL_ARB_instanced_arrays (ARB #49)

glVertexAttribFormatNV

GLScene.OpenGL4

glVertexAttribI1i

GLScene.OpenGL4

########################################################### function and procedure definitions for extensions integrated into OpenGL 3.0 Core ###########################################################

glVertexAttribI1iEXT

GLScene.OpenGL4

GL_EXT_gpu_shader4 (EXT #326)

glVertexAttribI1iv

GLScene.OpenGL4

glVertexAttribI1ivEXT

GLScene.OpenGL4

glVertexAttribI1ui

GLScene.OpenGL4

glVertexAttribI1uiEXT

GLScene.OpenGL4

glVertexAttribI1uiv

GLScene.OpenGL4

glVertexAttribI1uivEXT

GLScene.OpenGL4

glVertexAttribI2i

GLScene.OpenGL4

glVertexAttribI2iEXT

GLScene.OpenGL4

glVertexAttribI2iv

GLScene.OpenGL4

glVertexAttribI2ivEXT

GLScene.OpenGL4

glVertexAttribI2ui

GLScene.OpenGL4

glVertexAttribI2uiEXT

GLScene.OpenGL4

glVertexAttribI2uiv

GLScene.OpenGL4

glVertexAttribI2uivEXT

GLScene.OpenGL4

glVertexAttribI3i

GLScene.OpenGL4

glVertexAttribI3iEXT

GLScene.OpenGL4

glVertexAttribI3iv

GLScene.OpenGL4

glVertexAttribI3ivEXT

GLScene.OpenGL4

glVertexAttribI3ui

GLScene.OpenGL4

glVertexAttribI3uiEXT

GLScene.OpenGL4

glVertexAttribI3uiv

GLScene.OpenGL4

glVertexAttribI3uivEXT

GLScene.OpenGL4

glVertexAttribI4bv

GLScene.OpenGL4

glVertexAttribI4bvEXT

GLScene.OpenGL4

glVertexAttribI4i

GLScene.OpenGL4

glVertexAttribI4iEXT

GLScene.OpenGL4

glVertexAttribI4iv

GLScene.OpenGL4

glVertexAttribI4ivEXT

GLScene.OpenGL4

glVertexAttribI4sv

GLScene.OpenGL4

glVertexAttribI4svEXT

GLScene.OpenGL4

glVertexAttribI4ubv

GLScene.OpenGL4

glVertexAttribI4ubvEXT

GLScene.OpenGL4

glVertexAttribI4ui

GLScene.OpenGL4

glVertexAttribI4uiEXT

GLScene.OpenGL4

glVertexAttribI4uiv

GLScene.OpenGL4

glVertexAttribI4uivEXT

GLScene.OpenGL4

glVertexAttribI4usv

GLScene.OpenGL4

glVertexAttribI4usvEXT

GLScene.OpenGL4

glVertexAttribIFormatNV

GLScene.OpenGL4

glVertexAttribIPointer

GLScene.OpenGL4

glVertexAttribIPointerEXT

GLScene.OpenGL4

glVertexAttribP1ui

GLScene.OpenGL4

glVertexAttribP1uiv

GLScene.OpenGL4

glVertexAttribP2ui

GLScene.OpenGL4

glVertexAttribP2uiv

GLScene.OpenGL4

glVertexAttribP3ui

GLScene.OpenGL4

glVertexAttribP3uiv

GLScene.OpenGL4

glVertexAttribP4ui

GLScene.OpenGL4

glVertexAttribP4uiv

GLScene.OpenGL4

glVertexAttribPointer

GLScene.OpenGL4

glVertexAttribPointerARB

GLScene.OpenGL4

glVertexAttribPointerNV

GLScene.OpenGL4

glVertexAttribs1dvNV

GLScene.OpenGL4

glVertexAttribs1fvNV

GLScene.OpenGL4

glVertexAttribs1svNV

GLScene.OpenGL4

glVertexAttribs2dvNV

GLScene.OpenGL4

glVertexAttribs2fvNV

GLScene.OpenGL4

glVertexAttribs2svNV

GLScene.OpenGL4

glVertexAttribs3dvNV

GLScene.OpenGL4

glVertexAttribs3fvNV

GLScene.OpenGL4

glVertexAttribs3svNV

GLScene.OpenGL4

glVertexAttribs4dvNV

GLScene.OpenGL4

glVertexAttribs4fvNV

GLScene.OpenGL4

glVertexAttribs4svNV

GLScene.OpenGL4

glVertexAttribs4ubvNV

GLScene.OpenGL4

glVertexBlendARB

GLScene.OpenGL4

glVertexFormatNV

GLScene.OpenGL4

glVertexP2ui

GLScene.OpenGL4

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

glVertexP2uiv

GLScene.OpenGL4

glVertexP3ui

GLScene.OpenGL4

glVertexP3uiv

GLScene.OpenGL4

glVertexP4ui

GLScene.OpenGL4

glVertexP4uiv

GLScene.OpenGL4

glVertexPointer

GLScene.OpenGL4

deprecated;

glViewport

GLScene.OpenGL4

deprecated;

glWaitSync

GLScene.OpenGL4

glWeightbvARB

GLScene.OpenGL4

GL_ARB_vertex_blend (ARB #15) {deprecated?}

glWeightdvARB

GLScene.OpenGL4

glWeightfvARB

GLScene.OpenGL4

glWeightivARB

GLScene.OpenGL4

glWeightPointerARB

GLScene.OpenGL4

glWeightsvARB

GLScene.OpenGL4

glWeightubvARB

GLScene.OpenGL4

glWeightuivARB

GLScene.OpenGL4

glWeightusvARB

GLScene.OpenGL4

glWindowPos2d

GLScene.OpenGL4

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

glWindowPos2dARB

GLScene.OpenGL4

GL_ARB_window_pos (ARB #25)

glWindowPos2dv

GLScene.OpenGL4

deprecated;

glWindowPos2dvARB

GLScene.OpenGL4

glWindowPos2f

GLScene.OpenGL4

deprecated;

glWindowPos2fARB

GLScene.OpenGL4

glWindowPos2fv

GLScene.OpenGL4

deprecated;

glWindowPos2fvARB

GLScene.OpenGL4

glWindowPos2i

GLScene.OpenGL4

deprecated;

glWindowPos2iARB

GLScene.OpenGL4

glWindowPos2iv

GLScene.OpenGL4

deprecated;

glWindowPos2ivARB

GLScene.OpenGL4

glWindowPos2s

GLScene.OpenGL4

deprecated;

glWindowPos2sARB

GLScene.OpenGL4

glWindowPos2sv

GLScene.OpenGL4

deprecated;

glWindowPos2svARB

GLScene.OpenGL4

glWindowPos3d

GLScene.OpenGL4

deprecated;

glWindowPos3dARB

GLScene.OpenGL4

glWindowPos3dv

GLScene.OpenGL4

deprecated;

glWindowPos3dvARB

GLScene.OpenGL4

glWindowPos3f

GLScene.OpenGL4

deprecated;

glWindowPos3fARB

GLScene.OpenGL4

glWindowPos3fv

GLScene.OpenGL4

deprecated;

glWindowPos3fvARB

GLScene.OpenGL4

glWindowPos3i

GLScene.OpenGL4

deprecated;

glWindowPos3iARB

GLScene.OpenGL4

glWindowPos3iv

GLScene.OpenGL4

deprecated;

glWindowPos3ivARB

GLScene.OpenGL4

glWindowPos3s

GLScene.OpenGL4

deprecated;

glWindowPos3sARB

GLScene.OpenGL4

glWindowPos3sv

GLScene.OpenGL4

deprecated;

glWindowPos3svARB

GLScene.OpenGL4

GLXLTypeComponentCount

GXSL.Parameter

GLXLTypeEnum

GXSL.Parameter

GLX_ACCUM_ALPHA_SIZE

GLScene.OpenGL4

GLX_ACCUM_BLUE_SIZE

GLScene.OpenGL4

GLX_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GLX_ACCUM_GREEN_SIZE

GLScene.OpenGL4

GLX_ACCUM_RED_SIZE

GLScene.OpenGL4

GLX_ALPHA_SIZE

GLScene.OpenGL4

GLX_ARB_context_flush_control

GLScene.OpenGL4

GLX

GLX_ARB_create_context

GLScene.OpenGL4

GLX

GLX_ARB_create_context_profile

GLScene.OpenGL4

GLX

GLX_ARB_create_context_robustness

GLScene.OpenGL4

GLX

GLX_ARB_fbconfig_float

GLScene.OpenGL4

GLX

GLX_ARB_framebuffer_sRGB

GLScene.OpenGL4

GLX

GLX_ARB_get_proc_address

GLScene.OpenGL4

GLX

GLX_ARB_multisample

GLScene.OpenGL4

GLX

GLX_ARB_vertex_buffer_object

GLScene.OpenGL4

GLX

GLX_AUX0_EXT

GLScene.OpenGL4

GLX_AUX1_EXT

GLScene.OpenGL4

GLX_AUX2_EXT

GLScene.OpenGL4

GLX_AUX3_EXT

GLScene.OpenGL4

GLX_AUX4_EXT

GLScene.OpenGL4

GLX_AUX5_EXT

GLScene.OpenGL4

GLX_AUX6_EXT

GLScene.OpenGL4

GLX_AUX7_EXT

GLScene.OpenGL4

GLX_AUX8_EXT

GLScene.OpenGL4

GLX_AUX9_EXT

GLScene.OpenGL4

GLX_AUX_BUFFERS

GLScene.OpenGL4

GLX_AUX_BUFFERS_BIT

GLScene.OpenGL4

GLX_BACK_EXT

GLScene.OpenGL4

GLX_BACK_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_LEFT_EXT

GLScene.OpenGL4

GLX_BACK_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_BACK_RIGHT_EXT

GLScene.OpenGL4

GLX_BIND_TO_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGBA_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_RGB_EXT

GLScene.OpenGL4

GLX_BIND_TO_TEXTURE_TARGETS_EXT

GLScene.OpenGL4

GLX_BLUE_SIZE

GLScene.OpenGL4

GLX_BUFFER_SIZE

GLScene.OpenGL4

GLX_COLOR_INDEX_BIT

GLScene.OpenGL4

GLX_COLOR_INDEX_TYPE

GLScene.OpenGL4

GLX_CONFIG_CAVEAT

GLScene.OpenGL4

GLX_CONTEXT_ALLOW_BUFFER_BYTE_ORDER_MISMATCH_ARB

GLScene.OpenGL4

GLX_ARB_vertex_buffer_object

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_profile

GLX_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context

GLX_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

GLX_EXT_create_context_es2_profile

GLX_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

GLX_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

GLX_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

GLX_ARB_context_flush_control

GLX_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

GLX_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

GLX_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

GLX_ARB_robustness_application_isolation

GLX_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GLX_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GLX_ARB_create_context_robustness

GLX_DAMAGED

GLScene.OpenGL4

GLX_DEPTH_BUFFER_BIT

GLScene.OpenGL4

GLX_DEPTH_SIZE

GLScene.OpenGL4

GLX_DIRECT_COLOR

GLScene.OpenGL4

GLX_DIRECT_COLOR_EXT

GLScene.OpenGL4

GLX_DONT_CARE

GLScene.OpenGL4

GLX_DOUBLEBUFFER

GLScene.OpenGL4

GLX_DRAWABLE_TYPE

GLScene.OpenGL4

GLX_EVENT_MASK

GLScene.OpenGL4

GLX_EXTENSIONS

GLScene.OpenGL4

GLX_EXT_create_context_es2_profile

GLScene.OpenGL4

GLX

GLX_EXT_fbconfig_packed_float

GLScene.OpenGL4

GLX

GLX_EXT_framebuffer_sRGB

GLScene.OpenGL4

GLX

GLX_EXT_import_context

GLScene.OpenGL4

GLX

GLX_EXT_swap_control

GLScene.OpenGL4

GLX

GLX_EXT_texture_from_pixmap

GLScene.OpenGL4

GLX

GLX_EXT_visual_info

GLScene.OpenGL4

GLX

GLX_EXT_visual_rating

GLScene.OpenGL4

GLX

GLX_FBCONFIG_ID

GLScene.OpenGL4

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

GLX_ARB_framebuffer_sRGB

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_sRGB

GLX_FRONT_EXT

GLScene.OpenGL4

GLX_FRONT_LEFT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_LEFT_EXT

GLScene.OpenGL4

GLX_FRONT_RIGHT_BUFFER_BIT

GLScene.OpenGL4

GLX_FRONT_RIGHT_EXT

GLScene.OpenGL4

GLX_GRAY_SCALE

GLScene.OpenGL4

GLX_GRAY_SCALE_EXT

GLScene.OpenGL4

GLX_GREEN_SIZE

GLScene.OpenGL4

GLX_HEIGHT

GLScene.OpenGL4

GLX_LARGEST_PBUFFER

GLScene.OpenGL4

GLX_LATE_SWAPS_TEAR_EXT

GLScene.OpenGL4

GL_EXT_Late_Swaps

GLX_LEVEL

GLScene.OpenGL4

GLX_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GLX_MAX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_MAX_PBUFFER_PIXELS

GLScene.OpenGL4

GLX_MAX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_MAX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_MIPMAP_TEXTURE_EXT

GLScene.OpenGL4

GLX_NONE

GLScene.OpenGL4

GLX_NONE_EXT

GLScene.OpenGL4

GLX_NON_CONFORMANT_CONFIG

GLScene.OpenGL4

GLX_NON_CONFORMANT_VISUAL_EXT

GLScene.OpenGL4

GLX_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GLX_PBUFFER

GLScene.OpenGL4

GLX_PBUFFER_BIT

GLScene.OpenGL4

GLX_PBUFFER_CLOBBER_MASK

GLScene.OpenGL4

GLX_PBUFFER_HEIGHT

GLScene.OpenGL4

GLX_PBUFFER_WIDTH

GLScene.OpenGL4

GLX_PIXMAP_BIT

GLScene.OpenGL4

GLX_PRESERVED_CONTENTS

GLScene.OpenGL4

GLX_PSEUDO_COLOR

GLScene.OpenGL4

GLX_PSEUDO_COLOR_EXT

GLScene.OpenGL4

GLX_RED_SIZE

GLScene.OpenGL4

GLX_RENDER_TYPE

GLScene.OpenGL4

GLX_RGBA

GLScene.OpenGL4

GLX_RGBA_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT

GLScene.OpenGL4

GLX_RGBA_FLOAT_BIT_ARB

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE

GLScene.OpenGL4

GLX_RGBA_FLOAT_TYPE_ARB

GLScene.OpenGL4

GLX_ARB_fbconfig_float

GLX_RGBA_TYPE

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT

GLScene.OpenGL4

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT

GLScene.OpenGL4

GLX_SAMPLES

GLScene.OpenGL4

GLX_SAMPLES_ARB

GLScene.OpenGL4

GLX_SAMPLE_BUFFERS

GLScene.OpenGL4

GLX_VERSION_1_4

GLX_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GLX_ARB_multisample

GLX_SAVED

GLScene.OpenGL4

GLX_SCREEN

GLScene.OpenGL4

GLX_SCREEN_EXT

GLScene.OpenGL4

GLX_SHARE_CONTEXT_EXT

GLScene.OpenGL4

GLX_EXT_import_context

GLX_SLOW_CONFIG

GLScene.OpenGL4

GLX_SLOW_VISUAL_EXT

GLScene.OpenGL4

GLX_STATIC_COLOR

GLScene.OpenGL4

GLX_STATIC_COLOR_EXT

GLScene.OpenGL4

GLX_STATIC_GRAY

GLScene.OpenGL4

GLX_STATIC_GRAY_EXT

GLScene.OpenGL4

GLX_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GLX_STENCIL_SIZE

GLScene.OpenGL4

GLX_STEREO

GLScene.OpenGL4

GLX_SWAP_INTERVAL_EXT

GLScene.OpenGL4

GLX_EXT_swap_control

GLX_TEXTURE_1D_BIT_EXT

GLScene.OpenGL4

GLX_EXT_fbconfig_packed_float GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1; GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008; GLX_EXT_framebuffer_sRGB GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2; GLX_EXT_texture_from_pixmap

GLX_TEXTURE_1D_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_2D_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_NONE_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGBA_EXT

GLScene.OpenGL4

GLX_TEXTURE_FORMAT_RGB_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_BIT_EXT

GLScene.OpenGL4

GLX_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GLX_TEXTURE_TARGET_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_ALPHA_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_BLUE_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_GREEN_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_INDEX_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE

GLScene.OpenGL4

GLX_TRANSPARENT_RED_VALUE_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_RGB

GLScene.OpenGL4

GLX_TRANSPARENT_RGB_EXT

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE

GLScene.OpenGL4

GLX_TRANSPARENT_TYPE_EXT

GLScene.OpenGL4

GLX_TRUE_COLOR

GLScene.OpenGL4

GLX_TRUE_COLOR_EXT

GLScene.OpenGL4

GLX_USE_GL

GLScene.OpenGL4

GLX_VENDOR

GLScene.OpenGL4

GLX 1.1 and later:

GLX_VERSION

GLScene.OpenGL4

GLX_VERSION_1_4

GLScene.OpenGL4

GLX

GLX_VISUAL_CAVEAT_EXT

GLScene.OpenGL4

GLX_EXT_visual_rating

GLX_VISUAL_ID

GLScene.OpenGL4

GLX_VISUAL_ID_EXT

GLScene.OpenGL4

GLX_WIDTH

GLScene.OpenGL4

GLX_WINDOW

GLScene.OpenGL4

GLX_WINDOW_BIT

GLScene.OpenGL4

GLX_VERSION_1_3

GLX_X_RENDERABLE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE

GLScene.OpenGL4

GLX_X_VISUAL_TYPE_EXT

GLScene.OpenGL4

GLX_EXT_visual_info

GLX_Y_INVERTED_EXT

GLScene.OpenGL4

GL_1PASS_EXT

GLScene.OpenGL4

GL_1PASS_SGIS

GLScene.OpenGL4

GL_2D

GLScene.OpenGL4

GL_2PASS_0_EXT

GLScene.OpenGL4

GL_2PASS_0_SGIS

GLScene.OpenGL4

GL_2PASS_1_EXT

GLScene.OpenGL4

GL_2PASS_1_SGIS

GLScene.OpenGL4

GL_2X_BIT_ATI

GLScene.OpenGL4

GL_2_BYTES

GLScene.OpenGL4

GL_3D

GLScene.OpenGL4

GL_3DFX_multisample

GLScene.OpenGL4

GL_3DFX_tbuffer

GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1

GLScene.OpenGL4

GL_3D_COLOR

GLScene.OpenGL4

GL_3D_COLOR_TEXTURE

GLScene.OpenGL4

GL_3_BYTES

GLScene.OpenGL4

GL_422_AVERAGE_EXT

GLScene.OpenGL4

GL_422_EXT

GLScene.OpenGL4

GL_EXT_422_pixels

GL_422_REV_AVERAGE_EXT

GLScene.OpenGL4

GL_422_REV_EXT

GLScene.OpenGL4

GL_4D_COLOR_TEXTURE

GLScene.OpenGL4

GL_4PASS_0_EXT

GLScene.OpenGL4

GL_4PASS_0_SGIS

GLScene.OpenGL4

GL_4PASS_1_EXT

GLScene.OpenGL4

GL_4PASS_1_SGIS

GLScene.OpenGL4

GL_4PASS_2_EXT

GLScene.OpenGL4

GL_4PASS_2_SGIS

GLScene.OpenGL4

GL_4PASS_3_EXT

GLScene.OpenGL4

GL_4PASS_3_SGIS

GLScene.OpenGL4

GL_4X_BIT_ATI

GLScene.OpenGL4

GL_4_BYTES

GLScene.OpenGL4

GL_8X_BIT_ATI

GLScene.OpenGL4

GL_ABGR_EXT

GLScene.OpenGL4

GL_EXT_abgr

GL_ACCUM

GLScene.OpenGL4

GL_ACCUM_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_ACCUM_ALPHA_BITS

GLScene.OpenGL4

GL_ACCUM_BLUE_BITS

GLScene.OpenGL4

GL_ACCUM_BUFFER_BIT

GLScene.OpenGL4

GL_ACCUM_CLEAR_VALUE

GLScene.OpenGL4

GL_ACCUM_GREEN_BITS

GLScene.OpenGL4

GL_ACCUM_RED_BITS

GLScene.OpenGL4

GL_ACTIVE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTES

GLScene.OpenGL4

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_PROGRAM

GLScene.OpenGL4

GL_ACTIVE_PROGRAM_EXT

GLScene.OpenGL4

GL_EXT_separate_shader_objects

GL_ACTIVE_RESOURCES

GLScene.OpenGL4

GL_ACTIVE_STENCIL_FACE_EXT

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINES

GLScene.OpenGL4

GL_ARB_shader_subroutine

GL_ACTIVE_SUBROUTINE_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_ACTIVE_UNIFORM_MAX_LENGTH

GLScene.OpenGL4

GL_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_ACTIVE_VARYINGS_NV

GLScene.OpenGL4

GL_ACTIVE_VARYING_MAX_LENGTH_NV

GLScene.OpenGL4

GL_ACTIVE_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ADD

GLScene.OpenGL4

GL_ADD_ATI

GLScene.OpenGL4

GL_ADD_SIGNED

GLScene.OpenGL4

GL_ADD_SIGNED_ARB

GLScene.OpenGL4

GL_ADD_SIGNED_EXT

GLScene.OpenGL4

GL_ADJACENT_PAIRS_NV

GLScene.OpenGL4

GL_AFFINE_2D_NV

GLScene.OpenGL4

GL_AFFINE_3D_NV

GLScene.OpenGL4

GL_ALIASED_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_ALIASED_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_ALLOW_DRAW_FRG_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_MEM_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_OBJ_HINT_PGI

GLScene.OpenGL4

GL_ALLOW_DRAW_WIN_HINT_PGI

GLScene.OpenGL4

GL_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS

GLScene.OpenGL4

GL_ALL_BARRIER_BITS_EXT

GLScene.OpenGL4

GL_ALL_COMPLETED_NV

GLScene.OpenGL4

GL_NV_fence

GL_ALL_SHADER_BITS

GLScene.OpenGL4

GL_ALPHA

GLScene.OpenGL4

GL_ALPHA12

GLScene.OpenGL4

GL_ALPHA12_EXT

GLScene.OpenGL4

GL_ALPHA16

GLScene.OpenGL4

GL_ALPHA16F_ARB

GLScene.OpenGL4

GL_ALPHA16I_EXT

GLScene.OpenGL4

GL_ALPHA16UI_EXT

GLScene.OpenGL4

GL_ALPHA16_EXT

GLScene.OpenGL4

GL_ALPHA16_SNORM

GLScene.OpenGL4

GL_ALPHA32F_ARB

GLScene.OpenGL4

GL_ALPHA32I_EXT

GLScene.OpenGL4

GL_ALPHA32UI_EXT

GLScene.OpenGL4

GL_ALPHA4

GLScene.OpenGL4

GL_ALPHA4_EXT

GLScene.OpenGL4

GL_EXT_texture

GL_ALPHA8

GLScene.OpenGL4

GL_ALPHA8I_EXT

GLScene.OpenGL4

GL_ALPHA8UI_EXT

GLScene.OpenGL4

GL_ALPHA8_EXT

GLScene.OpenGL4

GL_ALPHA8_SNORM

GLScene.OpenGL4

GL_ALPHA_BIAS

GLScene.OpenGL4

GL_ALPHA_BITS

GLScene.OpenGL4

GL_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_ALPHA_INTEGER

GLScene.OpenGL4

GL_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_ALPHA_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MAX_SGIX

GLScene.OpenGL4

GL_ALPHA_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_ALPHA_MIN_SGIX

GLScene.OpenGL4

GL_SGIX_blend_alpha_minmax

GL_ALPHA_SCALE

GLScene.OpenGL4

GL_ALPHA_SNORM

GLScene.OpenGL4

GL_EXT_texture_snorm

GL_ALPHA_TEST

GLScene.OpenGL4

GL_ALPHA_TEST_FUNC

GLScene.OpenGL4

GL_ALPHA_TEST_REF

GLScene.OpenGL4

GL_ALREADY_SIGNALED

GLScene.OpenGL4

GL_ALWAYS

GLScene.OpenGL4

GL_ALWAYS_FAST_HINT_PGI

GLScene.OpenGL4

GL_ALWAYS_SOFT_HINT_PGI

GLScene.OpenGL4

GL_AMBIENT

GLScene.OpenGL4

GL_AMBIENT_AND_DIFFUSE

GLScene.OpenGL4

GL_AMD_conservative_depth

GLScene.OpenGL4

GL 4.6

GL_AMD_debug_output

GLScene.OpenGL4

GL 4.6

GL_AMD_depth_clamp_separate

GLScene.OpenGL4

GL 4.6

GL_AMD_draw_buffers_blend

GLScene.OpenGL4

GL 4.6

GL_AMD_name_gen_delete

GLScene.OpenGL4

GL 4.6

GL_AMD_performance_monitor

GLScene.OpenGL4

GL 4.6

GL_AMD_pinned_memory

GLScene.OpenGL4

GL 4.3

GL_AMD_query_buffer_object

GLScene.OpenGL4

GL 4.3

GL_AMD_seamless_cubemap_per_texture

GLScene.OpenGL4

GL 4.6

GL_AMD_shader_stencil_export

GLScene.OpenGL4

GL 4.6

GL_AMD_stencil_operation_extended

GLScene.OpenGL4

GL 4.3

GL_AMD_texture_texture4

GLScene.OpenGL4

GL 4.6

GL_AMD_transform_feedback3_lines_triangles

GLScene.OpenGL4

GL 4.6

GL_AMD_vertex_shader_layer

GLScene.OpenGL4

GL 4.3

GL_AMD_vertex_shader_tesselator

GLScene.OpenGL4

GL 4.6

GL_AMD_vertex_shader_viewport_index

GLScene.OpenGL4

GL 4.3

GL_AND

GLScene.OpenGL4

GL_AND_INVERTED

GLScene.OpenGL4

GL_AND_REVERSE

GLScene.OpenGL4

GL_ANY_SAMPLES_PASSED

GLScene.OpenGL4

GL_ARB_occlusion_query2

GL_ANY_SAMPLES_PASSED_CONSERVATIVE

GLScene.OpenGL4

GL_APPLE_aux_depth_stencil

GLScene.OpenGL4

GL_APPLE_client_storage

GLScene.OpenGL4

GL_APPLE_element_array

GLScene.OpenGL4

GL_APPLE_fence

GLScene.OpenGL4

GL_APPLE_float_pixels

GLScene.OpenGL4

GL_APPLE_object_purgeable

GLScene.OpenGL4

GL_APPLE_rgb_422

GLScene.OpenGL4

GL_APPLE_row_bytes

GLScene.OpenGL4

GL_APPLE_specular_vector

GLScene.OpenGL4

GL_APPLE_texture_range

GLScene.OpenGL4

GL_APPLE_transform_hint

GLScene.OpenGL4

GL_APPLE_vertex_array_object

GLScene.OpenGL4

GL_APPLE_vertex_array_range

GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators

GLScene.OpenGL4

GL_APPLE_ycbcr_422

GLScene.OpenGL4

GL_ARB_arrays_of_arrays

GLScene.OpenGL4

GL 4.3

GL_ARB_base_instance

GLScene.OpenGL4

GL 4.2

GL_ARB_bindless_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_blend_func_extended

GLScene.OpenGL4

GL_ARB_buffer_storage

GLScene.OpenGL4

GL 4.4

GL_ARB_clear_buffer_object

GLScene.OpenGL4

GL 4.3

GL_ARB_clear_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_clip_control

GLScene.OpenGL4

GL 4.5

GL_ARB_cl_event

GLScene.OpenGL4

GL 4.6

GL_ARB_color_buffer_float

GLScene.OpenGL4

GL_ARB_compatibility

GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage

GLScene.OpenGL4

GL 4.2

GL_ARB_compute_shader

GLScene.OpenGL4

GL 4.3

GL_ARB_compute_variable_group_size

GLScene.OpenGL4

GL 4.6

GL_ARB_conditional_render_inverted

GLScene.OpenGL4

GL 4.5

GL_ARB_conservative_depth

GLScene.OpenGL4

GL 4.2

GL_ARB_copy_buffer

GLScene.OpenGL4

GL_ARB_copy_image

GLScene.OpenGL4

GL 4.3

GL_ARB_cull_distance

GLScene.OpenGL4

GL 4.5

GL_ARB_debug_output

GLScene.OpenGL4

GL 4.6

GL_ARB_depth_buffer_float

GLScene.OpenGL4

GL_ARB_depth_clamp

GLScene.OpenGL4

GL_ARB_depth_texture

GLScene.OpenGL4

GL_ARB_derivative_control

GLScene.OpenGL4

GL 4.5

GL_ARB_direct_state_access

GLScene.OpenGL4

GL 4.5

GL_ARB_draw_buffers

GLScene.OpenGL4

GL_ARB_draw_buffers_blend

GLScene.OpenGL4

GL_ARB_draw_elements_base_vertex

GLScene.OpenGL4

GL_ARB_draw_indirect

GLScene.OpenGL4

GL_ARB_draw_instanced

GLScene.OpenGL4

GL_ARB_enhanced_layouts

GLScene.OpenGL4

GL 4.4

GL_ARB_ES2_compatibility

GLScene.OpenGL4

GL_ARB_ES3_1_compatibility

GLScene.OpenGL4

GL 4.5

GL_ARB_ES3_2_compatibility

GLScene.OpenGL4

GL_ARB_ES3_compatibility

GLScene.OpenGL4

GL 4.3

GL_ARB_explicit_attrib_location

GLScene.OpenGL4

GL_ARB_explicit_uniform_location

GLScene.OpenGL4

GL 4.3

GL_ARB_fragment_coord_conventions

GLScene.OpenGL4

GL_ARB_fragment_layer_viewport

GLScene.OpenGL4

GL 4.3

GL_ARB_fragment_program

GLScene.OpenGL4

GL_ARB_fragment_program_shadow

GLScene.OpenGL4

GL_ARB_fragment_shader

GLScene.OpenGL4

GL_ARB_fragment_shader_interlock

GLScene.OpenGL4

GL_ARB_framebuffer_no_attachments

GLScene.OpenGL4

GL 4.3

GL_ARB_framebuffer_object

GLScene.OpenGL4

GL_ARB_framebuffer_sRGB

GLScene.OpenGL4

GL_ARB_geometry_shader4

GLScene.OpenGL4

GL_ARB_get_program_binary

GLScene.OpenGL4

GL_ARB_get_texture_sub_image

GLScene.OpenGL4

GL 4.5

GL_ARB_gl_spirv

GLScene.OpenGL4

GL 4.6

GL_ARB_gpu_shader5

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64

GLScene.OpenGL4

GL_ARB_gpu_shader_int64

GLScene.OpenGL4

GL_ARB_half_float_pixel

GLScene.OpenGL4

GL_ARB_half_float_vertex

GLScene.OpenGL4

GL_ARB_imaging

GLScene.OpenGL4

GL_ARB_indirect_parameters

GLScene.OpenGL4

GL 4.6

GL_ARB_instanced_arrays

GLScene.OpenGL4

GL_ARB_internalformat_query

GLScene.OpenGL4

GL 4.2

GL_ARB_internalformat_query2

GLScene.OpenGL4

GL 4.3

GL_ARB_invalidate_subdata

GLScene.OpenGL4

GL 4.3

GL_ARB_map_buffer_alignment

GLScene.OpenGL4

GL 4.2

GL_ARB_map_buffer_range

GLScene.OpenGL4

GL_ARB_matrix_palette

GLScene.OpenGL4

GL_ARB_multisample

GLScene.OpenGL4

GL_ARB_multitexture

GLScene.OpenGL4

GL_ARB_multi_bind

GLScene.OpenGL4

GL 4.4

GL_ARB_multi_draw_indirect

GLScene.OpenGL4

GL 4.3

GL_ARB_occlusion_query

GLScene.OpenGL4

GL_ARB_occlusion_query2

GLScene.OpenGL4

GL_ARB_parallel_shader_compile

GLScene.OpenGL4

GL_ARB_pipeline_statistics_query

GLScene.OpenGL4

GL 4.6

GL_ARB_pixel_buffer_object

GLScene.OpenGL4

GL_ARB_point_parameters

GLScene.OpenGL4

GL_ARB_point_sprite

GLScene.OpenGL4

GL_ARB_polygon_offset_clamp

GLScene.OpenGL4

GL 4.6

GL_ARB_post_depth_coverage

GLScene.OpenGL4

GL_ARB_program_interface_query

GLScene.OpenGL4

GL 4.3

GL_ARB_provoking_vertex

GLScene.OpenGL4

GL_ARB_query_buffer_object

GLScene.OpenGL4

GL 4.4

GL_ARB_robustness

GLScene.OpenGL4

GL 4.6

GL_ARB_robust_buffer_access_behavior

GLScene.OpenGL4

GL 4.3

GL_ARB_sampler_objects

GLScene.OpenGL4

GL_ARB_sample_locations

GLScene.OpenGL4

GL_ARB_sample_shading

GLScene.OpenGL4

GL_ARB_seamless_cube_map

GLScene.OpenGL4

GL_ARB_separate_shader_objects

GLScene.OpenGL4

GL_ARB_shader_atomic_counters

GLScene.OpenGL4

GL 4.2

GL_ARB_shader_atomic_counter_ops

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_ballot

GLScene.OpenGL4

GL_ARB_shader_bit_encoding

GLScene.OpenGL4

GL_ARB_shader_clock

GLScene.OpenGL4

GL_ARB_shader_draw_parameters

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_group_vote

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_image_load_store

GLScene.OpenGL4

GL 4.2

GL_ARB_shader_image_size

GLScene.OpenGL4

GL 4.3

GL_ARB_shader_objects

GLScene.OpenGL4

GL_ARB_shader_precision

GLScene.OpenGL4

GL_ARB_shader_stencil_export

GLScene.OpenGL4

GL 4.6

GL_ARB_shader_storage_buffer_object

GLScene.OpenGL4

GL 4.3

GL_ARB_shader_subroutine

GLScene.OpenGL4

GL_ARB_shader_texture_image_samples

GLScene.OpenGL4

GL 4.5

GL_ARB_shader_texture_lod

GLScene.OpenGL4

GL_ARB_shader_viewport_layer_array

GLScene.OpenGL4

GL_ARB_shading_language_100

GLScene.OpenGL4

GL_ARB_shading_language_420pack

GLScene.OpenGL4

GL 4.2

GL_ARB_shading_language_include

GLScene.OpenGL4

GL_ARB_shading_language_packing

GLScene.OpenGL4

GL 4.2

GL_ARB_shadow

GLScene.OpenGL4

GL_ARB_shadow_ambient

GLScene.OpenGL4

GL_ARB_sparse_texture

GLScene.OpenGL4

GL 4.4

GL_ARB_sparse_texture2

GLScene.OpenGL4

GL_ARB_sparse_texture_clamp

GLScene.OpenGL4

GL_ARB_spirv_extensions

GLScene.OpenGL4

GL 4.6

GL_ARB_stencil_texturing

GLScene.OpenGL4

GL 4.3

GL_ARB_sync

GLScene.OpenGL4

GL_ARB_tessellation_shader

GLScene.OpenGL4

GL_ARB_texture_barrier

GLScene.OpenGL4

GL 4.5

GL_ARB_texture_border_clamp

GLScene.OpenGL4

GL_ARB_texture_buffer_object

GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32

GLScene.OpenGL4

GL_ARB_texture_buffer_range

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_compression

GLScene.OpenGL4

GL_ARB_texture_compression_bptc

GLScene.OpenGL4

GL_ARB_texture_compression_rgtc

GLScene.OpenGL4

GL_ARB_texture_cube_map

GLScene.OpenGL4

GL_ARB_texture_cube_map_array

GLScene.OpenGL4

GL_ARB_texture_env_add

GLScene.OpenGL4

GL_ARB_texture_env_combine

GLScene.OpenGL4

GL_ARB_texture_env_crossbar

GLScene.OpenGL4

GL_ARB_texture_env_dot3

GLScene.OpenGL4

GL_ARB_texture_filter_anisotropic

GLScene.OpenGL4

GL 4.6

GL_ARB_texture_filter_minmax

GLScene.OpenGL4

GL_ARB_texture_float

GLScene.OpenGL4

GL_ARB_texture_gather

GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat

GLScene.OpenGL4

GL_ARB_texture_mirror_clamp_to_edge

GLScene.OpenGL4

GL 4.4

GL_ARB_texture_multisample

GLScene.OpenGL4

GL_ARB_texture_non_power_of_two

GLScene.OpenGL4

GL_ARB_texture_query_levels

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_query_lod

GLScene.OpenGL4

GL_ARB_texture_rectangle

GLScene.OpenGL4

GL_ARB_texture_rg

GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui

GLScene.OpenGL4

GL_ARB_texture_stencil8

GLScene.OpenGL4

GL 4.4

GL_ARB_texture_storage

GLScene.OpenGL4

GL 4.2

GL_ARB_texture_storage_multisample

GLScene.OpenGL4

GL 4.3

GL_ARB_texture_swizzle

GLScene.OpenGL4

GL_ARB_texture_view

GLScene.OpenGL4

GL 4.3

GL_ARB_timer_query

GLScene.OpenGL4

GL_ARB_transform_feedback2

GLScene.OpenGL4

GL_ARB_transform_feedback3

GLScene.OpenGL4

GL_ARB_transform_feedback_instanced

GLScene.OpenGL4

GL 4.2

GL_ARB_transform_feedback_overflow_query

GLScene.OpenGL4

GL 4.6

GL_ARB_transpose_matrix

GLScene.OpenGL4

GL_ARB_uniform_buffer_object

GLScene.OpenGL4

GL_ARB_vertex_array_bgra

GLScene.OpenGL4

GL_ARB_vertex_array_object

GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit

GLScene.OpenGL4

GL_ARB_vertex_attrib_binding

GLScene.OpenGL4

GL 4.3

GL_ARB_vertex_blend

GLScene.OpenGL4

GL_ARB_vertex_buffer_object

GLScene.OpenGL4

GL_ARB_vertex_program

GLScene.OpenGL4

GL_ARB_vertex_shader

GLScene.OpenGL4

GL_ARB_vertex_type_10f_11f_11f_rev

GLScene.OpenGL4

GL 4.4

GL_ARB_vertex_type_2_10_10_10_rev

GLScene.OpenGL4

GL_ARB_viewport_array

GLScene.OpenGL4

GL_ARB_window_pos

GLScene.OpenGL4

GL_ARC_TO_NV

GLScene.OpenGL4

GL_ARRAY_BUFFER

GLScene.OpenGL4

GL_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT

GLScene.OpenGL4

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT

GLScene.OpenGL4

GL_EXT_compiled_vertex_array

GL_ARRAY_OBJECT_BUFFER_ATI

GLScene.OpenGL4

GL_ARRAY_OBJECT_OFFSET_ATI

GLScene.OpenGL4

GL_ARRAY_SIZE

GLScene.OpenGL4

GL_ARRAY_STRIDE

GLScene.OpenGL4

GL_ASE_MAX_SMOOTH_GROUPS

GXS.FileASE

maximum material submaterials

GL_ASE_MAX_SUBMATERIALS

GXS.FileASE

maximum texture channels

GL_ASE_MAX_TEXTURE_MAPS

GXS.FileASE

maximum smoothing groups

GL_ASE_MAX_TEXURE_CHANNELS

GXS.FileASE

GL_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_SGIX_async_histogram

GL_ASYNC_MARKER_SGIX

GLScene.OpenGL4

GL_SGIX_async

GL_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_SGIX_async_pixel

GL_ATI_draw_buffers

GLScene.OpenGL4

GL 4.6

GL_ATI_element_array

GLScene.OpenGL4

GL 4.6

GL_ATI_envmap_bumpmap

GLScene.OpenGL4

GL 4.6

GL_ATI_fragment_shader

GLScene.OpenGL4

GL 4.6

GL_ATI_map_object_buffer

GLScene.OpenGL4

GL 4.6

GL_ATI_meminfo

GLScene.OpenGL4

GL 4.6

GL_ATI_pn_triangles

GLScene.OpenGL4

GL 4.6

GL_ATI_separate_stencil

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_env_combine3

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_float

GLScene.OpenGL4

GL 4.6

GL_ATI_texture_mirror_once

GLScene.OpenGL4

GL 4.6

GL_ATI_text_fragment_shader

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_array_object

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_attrib_array_object

GLScene.OpenGL4

GL 4.6

GL_ATI_vertex_streams

GLScene.OpenGL4

GL 4.6

GL_ATOMIC_COUNTER_BARRIER_BIT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER

GLScene.OpenGL4

GL_ARB_shader_atomic_counters

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_ACTIVE_ATOMIC_COUNTER_INDICES

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_BINDING

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_ATOMIC_COUNTER_BUFFER_START

GLScene.OpenGL4

GL_ATTACHED_SHADERS

GLScene.OpenGL4

GL_ATTENUATION_EXT

GLScene.OpenGL4

GL_ATTRIB_ARRAY_POINTER_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_SIZE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_STRIDE_NV

GLScene.OpenGL4

GL_ATTRIB_ARRAY_TYPE_NV

GLScene.OpenGL4

GL_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_AUTO_GENERATE_MIPMAP

GLScene.OpenGL4

GL_AUTO_NORMAL

GLScene.OpenGL4

GL_AUX0

GLScene.OpenGL4

GL_AUX1

GLScene.OpenGL4

GL_AUX2

GLScene.OpenGL4

GL_AUX3

GLScene.OpenGL4

GL_AUX_BUFFERS

GLScene.OpenGL4

GL_AUX_DEPTH_STENCIL_APPLE

GLScene.OpenGL4

GL_APPLE_aux_depth_stencil

GL_AVERAGE_EXT

GLScene.OpenGL4

GL_AVERAGE_HP

GLScene.OpenGL4

GL_BACK

GLScene.OpenGL4

GL_BACK_LEFT

GLScene.OpenGL4

GL_BACK_NORMALS_HINT_PGI

GLScene.OpenGL4

GL_BACK_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_BACK_RIGHT

GLScene.OpenGL4

GL_BACK_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_BEVEL_NV

GLScene.OpenGL4

GL_BGR

GLScene.OpenGL4

GL_BGRA

GLScene.OpenGL4

GL_BGRA_EXT

GLScene.OpenGL4

GL_BGRA_INTEGER

GLScene.OpenGL4

GL_BGRA_INTEGER_EXT

GLScene.OpenGL4

GL_BGR_EXT

GLScene.OpenGL4

GL_EXT_bgra

GL_BGR_INTEGER

GLScene.OpenGL4

GL_BGR_INTEGER_EXT

GLScene.OpenGL4

GL_BIAS_BIT_ATI

GLScene.OpenGL4

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV

GLScene.OpenGL4

GL_BINORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_BINORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_BITMAP

GLScene.OpenGL4

GL_BITMAP_TOKEN

GLScene.OpenGL4

GL_BLEND

GLScene.OpenGL4

GL_BLEND_ADVANCED_COHERENT_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced_coherent

GL_BLEND_COLOR

GLScene.OpenGL4

GL_BLEND_COLOR_EXT

GLScene.OpenGL4

GL_BLEND_DST

GLScene.OpenGL4

GL_BLEND_DST_ALPHA

GLScene.OpenGL4

GL_BLEND_DST_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_DST_RGB

GLScene.OpenGL4

GL_VERSION_1_4

GL_BLEND_DST_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_func_separate

GL_BLEND_EQUATION

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA

GLScene.OpenGL4

GL_BLEND_EQUATION_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_EXT

GLScene.OpenGL4

GL_BLEND_EQUATION_RGB

GLScene.OpenGL4

GL_VERSION_2_0

GL_BLEND_EQUATION_RGB_EXT

GLScene.OpenGL4

GL_EXT_blend_equation_separate

GL_BLEND_SRC

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA

GLScene.OpenGL4

GL_BLEND_SRC_ALPHA_EXT

GLScene.OpenGL4

GL_BLEND_SRC_RGB

GLScene.OpenGL4

GL_BLEND_SRC_RGB_EXT

GLScene.OpenGL4

GL_BLOCK_INDEX

GLScene.OpenGL4

GL_BLUE

GLScene.OpenGL4

GL_BLUE_BIAS

GLScene.OpenGL4

GL_BLUE_BITS

GLScene.OpenGL4

GL_BLUE_BIT_ATI

GLScene.OpenGL4

GL_BLUE_INTEGER

GLScene.OpenGL4

GL_BLUE_INTEGER_EXT

GLScene.OpenGL4

GL_BLUE_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_BLUE_SCALE

GLScene.OpenGL4

GL_BOLD_BIT_NV

GLScene.OpenGL4

GL_BOOL

GLScene.OpenGL4

GL_BOOL_ARB

GLScene.OpenGL4

GL_BOOL_VEC2

GLScene.OpenGL4

GL_BOOL_VEC2_ARB

GLScene.OpenGL4

GL_BOOL_VEC3

GLScene.OpenGL4

GL_BOOL_VEC3_ARB

GLScene.OpenGL4

GL_BOOL_VEC4

GLScene.OpenGL4

GL_BOOL_VEC4_ARB

GLScene.OpenGL4

GL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV

GLScene.OpenGL4

GL_BUFFER

GLScene.OpenGL4

GL_BUFFER_ACCESS

GLScene.OpenGL4

GL_BUFFER_ACCESS_ARB

GLScene.OpenGL4

GL_BUFFER_ACCESS_FLAGS

GLScene.OpenGL4

GL_BUFFER_BINDING

GLScene.OpenGL4

GL_BUFFER_DATA_SIZE

GLScene.OpenGL4

GL_BUFFER_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_NV_shader_buffer_load

GL_BUFFER_IMMUTABLE_STORAGE

GLScene.OpenGL4

GL_BUFFER_MAPPED

GLScene.OpenGL4

GL_BUFFER_MAPPED_ARB

GLScene.OpenGL4

GL_BUFFER_MAP_LENGTH

GLScene.OpenGL4

GL_BUFFER_MAP_OFFSET

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER

GLScene.OpenGL4

GL_BUFFER_MAP_POINTER_ARB

GLScene.OpenGL4

GL_BUFFER_OBJECT_APPLE

GLScene.OpenGL4

GL_APPLE_object_purgeable

GL_BUFFER_SIZE

GLScene.OpenGL4

GL_VERSION_1_5

GL_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_ARB_vertex_buffer_object

GL_BUFFER_STORAGE_FLAGS

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_BUFFER_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_BUFFER_USAGE

GLScene.OpenGL4

GL_BUFFER_USAGE_ARB

GLScene.OpenGL4

GL_BUFFER_VARIABLE

GLScene.OpenGL4

GL_BUMP_ENVMAP_ATI

GLScene.OpenGL4

GL_BUMP_NUM_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BUMP_ROT_MATRIX_ATI

GLScene.OpenGL4

GL_ATI_envmap_bumpmap

GL_BUMP_ROT_MATRIX_SIZE_ATI

GLScene.OpenGL4

GL_BUMP_TARGET_ATI

GLScene.OpenGL4

GL_BUMP_TEX_UNITS_ATI

GLScene.OpenGL4

GL_BYTE

GLScene.OpenGL4

DataType

GL_C3F_V3F

GLScene.OpenGL4

GL_C4F_N3F_V3F

GLScene.OpenGL4

GL_C4UB_V2F

GLScene.OpenGL4

GL_C4UB_V3F

GLScene.OpenGL4

GL_CALLIGRAPHIC_FRAGMENT_SGIX

GLScene.OpenGL4

GL_SGIX_calligraphic_fragment

GL_CAVEAT_SUPPORT

GLScene.OpenGL4

GL_CCW

GLScene.OpenGL4

GL_CIRCULAR_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_CW_ARC_TO_NV

GLScene.OpenGL4

GL_CIRCULAR_TANGENT_ARC_TO_NV

GLScene.OpenGL4

GL_CLAMP

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR

GLScene.OpenGL4

GL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_READ_COLOR

GLScene.OpenGL4

GL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

GL_CLAMP_TO_BORDER

GLScene.OpenGL4

GL_CLAMP_TO_BORDER_ARB

GLScene.OpenGL4

GL_ARB_texture_border_clamp

GL_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_EXT_texture_edge_clamp

GL_CLAMP_TO_EDGE_SGIS

GLScene.OpenGL4

GL_SGIS_texture_edge_clamp

GL_CLAMP_VERTEX_COLOR

GLScene.OpenGL4

GL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

GL_CLEAR

GLScene.OpenGL4

LogicOp

GL_CLEAR_BUFFER

GLScene.OpenGL4

GL_CLEAR_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE

GLScene.OpenGL4

GL_CLIENT_ACTIVE_TEXTURE_ARB

GLScene.OpenGL4

GL_CLIENT_ALL_ATTRIB_BITS

GLScene.OpenGL4

GL_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_CLIENT_MAPPED_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_CLIENT_PIXEL_STORE_BIT

GLScene.OpenGL4

GL_CLIENT_STORAGE_BIT

GLScene.OpenGL4

GL_CLIENT_VERTEX_ARRAY_BIT

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_INPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES

GLScene.OpenGL4

GL_CLIPPING_OUTPUT_PRIMITIVES_ARB

GLScene.OpenGL4

GL_CLIP_DEPTH_MODE

GLScene.OpenGL4

GL_CLIP_DISTANCE0

GLScene.OpenGL4

GL_CLIP_DISTANCE1

GLScene.OpenGL4

GL_CLIP_DISTANCE2

GLScene.OpenGL4

GL_CLIP_DISTANCE3

GLScene.OpenGL4

GL_CLIP_DISTANCE4

GLScene.OpenGL4

GL_CLIP_DISTANCE5

GLScene.OpenGL4

GL_CLIP_DISTANCE6

GLScene.OpenGL4

GL_CLIP_DISTANCE7

GLScene.OpenGL4

GL_CLIP_DISTANCE_NV

GLScene.OpenGL4

GL_CLIP_FAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_NEAR_HINT_PGI

GLScene.OpenGL4

GL_CLIP_ORIGIN

GLScene.OpenGL4

GL_CLIP_PLANE0

GLScene.OpenGL4

GL_CLIP_PLANE1

GLScene.OpenGL4

GL_CLIP_PLANE2

GLScene.OpenGL4

GL_CLIP_PLANE3

GLScene.OpenGL4

GL_CLIP_PLANE4

GLScene.OpenGL4

GL_CLIP_PLANE5

GLScene.OpenGL4

GL_CLIP_VOLUME_CLIPPING_HINT_EXT

GLScene.OpenGL4

GL_EXT_clip_volume_hint

GL_CLOSE_PATH_NV

GLScene.OpenGL4

GL_CMYKA_EXT

GLScene.OpenGL4

GL_CMYK_EXT

GLScene.OpenGL4

GL_EXT_cmyka

GL_CND0_ATI

GLScene.OpenGL4

GL_CND_ATI

GLScene.OpenGL4

GL_COEFF

GLScene.OpenGL4

GL_COLOR

GLScene.OpenGL4

PixelCopyType

GL_COLOR3_BIT_PGI

GLScene.OpenGL4

GL_COLOR4_BIT_PGI

GLScene.OpenGL4

GL_COLORBURN_KHR

GLScene.OpenGL4

GL_COLORDODGE_KHR

GLScene.OpenGL4

GL_COLOR_ALPHA_PAIRING_ATI

GLScene.OpenGL4

GL_COLOR_ARRAY

GLScene.OpenGL4

GL_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_COLOR_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_COLOR_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0

GLScene.OpenGL4

GL_COLOR_ATTACHMENT0_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10

GLScene.OpenGL4

GL_COLOR_ATTACHMENT10_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11

GLScene.OpenGL4

GL_COLOR_ATTACHMENT11_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12

GLScene.OpenGL4

GL_COLOR_ATTACHMENT12_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13

GLScene.OpenGL4

GL_COLOR_ATTACHMENT13_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14

GLScene.OpenGL4

GL_COLOR_ATTACHMENT14_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15

GLScene.OpenGL4

GL_COLOR_ATTACHMENT15_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT1_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2

GLScene.OpenGL4

GL_COLOR_ATTACHMENT2_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3

GLScene.OpenGL4

GL_COLOR_ATTACHMENT3_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4

GLScene.OpenGL4

GL_COLOR_ATTACHMENT4_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5

GLScene.OpenGL4

GL_COLOR_ATTACHMENT5_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6

GLScene.OpenGL4

GL_COLOR_ATTACHMENT6_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7

GLScene.OpenGL4

GL_COLOR_ATTACHMENT7_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8

GLScene.OpenGL4

GL_COLOR_ATTACHMENT8_EXT

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9

GLScene.OpenGL4

GL_COLOR_ATTACHMENT9_EXT

GLScene.OpenGL4

GL_COLOR_BUFFER_BIT

GLScene.OpenGL4

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI

GLScene.OpenGL4

GL_COLOR_CLEAR_VALUE

GLScene.OpenGL4

GL_COLOR_COMPONENTS

GLScene.OpenGL4

GL_COLOR_ENCODING

GLScene.OpenGL4

GL_COLOR_FLOAT_APPLE

GLScene.OpenGL4

GL_COLOR_INDEX

GLScene.OpenGL4

GL_COLOR_INDEX12_EXT

GLScene.OpenGL4

GL_COLOR_INDEX16_EXT

GLScene.OpenGL4

GL_COLOR_INDEX1_EXT

GLScene.OpenGL4

GL_EXT_paletted_texture

GL_COLOR_INDEX2_EXT

GLScene.OpenGL4

GL_COLOR_INDEX4_EXT

GLScene.OpenGL4

GL_COLOR_INDEX8_EXT

GLScene.OpenGL4

GL_COLOR_INDEXES

GLScene.OpenGL4

GL_COLOR_LOGIC_OP

GLScene.OpenGL4

GL_COLOR_MATERIAL

GLScene.OpenGL4

GL_COLOR_MATERIAL_FACE

GLScene.OpenGL4

GL_COLOR_MATERIAL_PARAMETER

GLScene.OpenGL4

GL_COLOR_MATRIX

GLScene.OpenGL4

GL_COLOR_MATRIX_SGI

GLScene.OpenGL4

GL_SGI_color_matrix

GL_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_COLOR_RENDERABLE

GLScene.OpenGL4

GL_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_COLOR_SUM

GLScene.OpenGL4

GL_COLOR_SUM_ARB

GLScene.OpenGL4

GL_ARB_vertex_program

GL_COLOR_SUM_CLAMP_NV

GLScene.OpenGL4

GL_COLOR_SUM_EXT

GLScene.OpenGL4

GL_EXT_secondary_color

GL_COLOR_TABLE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_ALPHA_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS

GLScene.OpenGL4

GL_COLOR_TABLE_BIAS_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_BLUE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_FORMAT_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_GREEN_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_INTENSITY_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_LUMINANCE_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_RED_SIZE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE

GLScene.OpenGL4

GL_COLOR_TABLE_SCALE_SGI

GLScene.OpenGL4

GL_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_color_table

GL_COLOR_TABLE_WIDTH

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_EXT

GLScene.OpenGL4

GL_COLOR_TABLE_WIDTH_SGI

GLScene.OpenGL4

GL_COLOR_WRITEMASK

GLScene.OpenGL4

GL_COMBINE

GLScene.OpenGL4

GL_COMBINE4_NV

GLScene.OpenGL4

GL_NV_texture_env_combine4

GL_COMBINER0_NV

GLScene.OpenGL4

GL_COMBINER1_NV

GLScene.OpenGL4

GL_COMBINER2_NV

GLScene.OpenGL4

GL_COMBINER3_NV

GLScene.OpenGL4

GL_COMBINER4_NV

GLScene.OpenGL4

GL_COMBINER5_NV

GLScene.OpenGL4

GL_COMBINER6_NV

GLScene.OpenGL4

GL_COMBINER7_NV

GLScene.OpenGL4

GL_COMBINER_AB_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_AB_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_BIAS_NV

GLScene.OpenGL4

GL_COMBINER_CD_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_COMBINER_CD_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINER_COMPONENT_USAGE_NV

GLScene.OpenGL4

GL_COMBINER_INPUT_NV

GLScene.OpenGL4

GL_COMBINER_MAPPING_NV

GLScene.OpenGL4

GL_COMBINER_MUX_SUM_NV

GLScene.OpenGL4

GL_COMBINER_SCALE_NV

GLScene.OpenGL4

GL_COMBINER_SUM_OUTPUT_NV

GLScene.OpenGL4

GL_COMBINE_ALPHA

GLScene.OpenGL4

GL_COMBINE_ALPHA_ARB

GLScene.OpenGL4

GL_COMBINE_ALPHA_EXT

GLScene.OpenGL4

GL_COMBINE_ARB

GLScene.OpenGL4

GL_ARB_texture_env_combine

GL_COMBINE_EXT

GLScene.OpenGL4

GL_EXT_texture_env_combine

GL_COMBINE_RGB

GLScene.OpenGL4

GL_COMBINE_RGB_ARB

GLScene.OpenGL4

GL_COMBINE_RGB_EXT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT

GLScene.OpenGL4

GL_COMMAND_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT

GLScene.OpenGL4

GL_COMPARE_REF_TO_TEXTURE

GLScene.OpenGL4

GL_VERSION_3_0

GL_COMPARE_R_TO_TEXTURE

GLScene.OpenGL4

GL_COMPARE_R_TO_TEXTURE_ARB

GLScene.OpenGL4

GL_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_COMPILE

GLScene.OpenGL4

GL_COMPILE_AND_EXECUTE

GLScene.OpenGL4

GL_COMPILE_STATUS

GLScene.OpenGL4

GL_COMPLETION_STATUS_ARB

GLScene.OpenGL4

GL_COMPRESSED_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_ALPHA_ARB

GLScene.OpenGL4

GL_ARB_texture_compression

GL_COMPRESSED_INTENSITY

GLScene.OpenGL4

GL_COMPRESSED_INTENSITY_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI

GLScene.OpenGLTokens

GL_ATI_texture_compression_3dc

GL_COMPRESSED_LUMINANCE_ALPHA_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_ARB

GLScene.OpenGL4

GL_COMPRESSED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_latc

GL_COMPRESSED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RED

GLScene.OpenGL4

GL_COMPRESSED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_RED_RGTC1

GLScene.OpenGL4

GL_ARB_texture_compression_rgtc

GL_COMPRESSED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_rgtc

GL_COMPRESSED_RG

GLScene.OpenGL4

GL_COMPRESSED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGB

GLScene.OpenGL4

GL_COMPRESSED_RGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_RGBA

GLScene.OpenGL4

GL_COMPRESSED_RGBA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_105_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_106_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_108_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_110_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_4x4_KHR

GLScene.OpenGL4

4.3 GL_KHR_texture_compression_astc_hdr

GL_COMPRESSED_RGBA_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_ARB_texture_compression_bptc

GL_COMPRESSED_RGBA_FXT1_3DFX

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_RGB_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB

GLScene.OpenGL4

GL_COMPRESSED_RGB_FXT1_3DFX

GLScene.OpenGL4

GL_3DFX_texture_compression_FXT1

GL_COMPRESSED_RGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_EXT_texture_compression_s3tc

GL_COMPRESSED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_R11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG11_EAC

GLScene.OpenGL4

GL_COMPRESSED_SIGNED_RG_RGTC2

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SLUMINANCE_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_10x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x10_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_12x12_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_4x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x4_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_5x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_6x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x5_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x6_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ASTC_8x8_KHR

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ALPHA8_ETC2_EAC

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB8_PUNCHTHROUGH_ALPHA1_ETC2

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_EXT

GLScene.OpenGL4

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_COMPUTE_LOCAL_WORK_SIZE

GLScene.OpenGL4

GL_COMPUTE_SHADER

GLScene.OpenGL4

GL_COMPUTE_SHADER_BIT

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_COMPUTE_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE

GLScene.OpenGL4

GL_COMPUTE_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_COMPUTE_TEXTURE

GLScene.OpenGL4

GL_COMP_BIT_ATI

GLScene.OpenGL4

GL_CONDITION_SATISFIED

GLScene.OpenGL4

GL_CONSERVATIVE_RASTERIZATION_NV

GLScene.OpenGL4

GL_NV_conservative_raster

GL_CONSERVATIVE_RASTER_DILATE_GRANULARITY_NV

GLScene.OpenGL4

GL_CONSERVATIVE_RASTER_DILATE_NV

GLScene.OpenGL4

GL_NV_conservative_raster_dilate

GL_CONSERVATIVE_RASTER_DILATE_RANGE_NV

GLScene.OpenGL4

GL_CONSERVE_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_CONSTANT

GLScene.OpenGL4

GL_CONSTANT_ALPHA

GLScene.OpenGL4

GL_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_CONSTANT_ARB

GLScene.OpenGL4

GL_CONSTANT_ATTENUATION

GLScene.OpenGL4

GL_CONSTANT_BORDER

GLScene.OpenGL4

GL_CONSTANT_BORDER_HP

GLScene.OpenGL4

GL_CONSTANT_COLOR0_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR1_NV

GLScene.OpenGL4

GL_CONSTANT_COLOR_ARB

GLScene.OpenGL4

GL_ARB_imaging

GL_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_EXT_blend_color

GL_CONSTANT_EXT

GLScene.OpenGL4

GL_CONST_EYE_NV

GLScene.OpenGL4

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT

GLScene.OpenGL4

GL_CONTEXT_CORE_PROFILE_BIT

GLScene.OpenGL4

GL_VERSION_3_2

GL_CONTEXT_FLAGS

GLScene.OpenGL4

GL_CONTEXT_FLAG_DEBUG_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_NO_ERROR_BIT_KHR

GLScene.OpenGL4

GL_KHR_no_error

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT

GLScene.OpenGL4

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

GL_ARB_robustness

GL_CONTEXT_LOST

GLScene.OpenGL4

GL 4.5

GL_CONTEXT_PROFILE_MASK

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR

GLScene.OpenGL4

GL_CONTEXT_RELEASE_BEHAVIOR_FLUSH

GLScene.OpenGL4

GL_CONTEXT_ROBUST_ACCESS

GLScene.OpenGL4

GL_KHR_robustness

GL_CONTINUOUS_AMD

GLScene.OpenGL4

GL_CONVEX_HULL_NV

GLScene.OpenGL4

GL_CONVOLUTION_1D

GLScene.OpenGL4

GL_CONVOLUTION_1D_EXT

GLScene.OpenGL4

GL_EXT_convolution

GL_CONVOLUTION_2D

GLScene.OpenGL4

GL_CONVOLUTION_2D_EXT

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_COLOR_HP

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE

GLScene.OpenGL4

GL_CONVOLUTION_BORDER_MODE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_BIAS_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE

GLScene.OpenGL4

GL_CONVOLUTION_FILTER_SCALE_EXT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT

GLScene.OpenGL4

GL_CONVOLUTION_FORMAT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_CONVOLUTION_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_convolution_accuracy

GL_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_CON_0_ATI

GLScene.OpenGL4

GL_CON_10_ATI

GLScene.OpenGL4

GL_CON_11_ATI

GLScene.OpenGL4

GL_CON_12_ATI

GLScene.OpenGL4

GL_CON_13_ATI

GLScene.OpenGL4

GL_CON_14_ATI

GLScene.OpenGL4

GL_CON_15_ATI

GLScene.OpenGL4

GL_CON_16_ATI

GLScene.OpenGL4

GL_CON_17_ATI

GLScene.OpenGL4

GL_CON_18_ATI

GLScene.OpenGL4

GL_CON_19_ATI

GLScene.OpenGL4

GL_CON_1_ATI

GLScene.OpenGL4

GL_CON_20_ATI

GLScene.OpenGL4

GL_CON_21_ATI

GLScene.OpenGL4

GL_CON_22_ATI

GLScene.OpenGL4

GL_CON_23_ATI

GLScene.OpenGL4

GL_CON_24_ATI

GLScene.OpenGL4

GL_CON_25_ATI

GLScene.OpenGL4

GL_CON_26_ATI

GLScene.OpenGL4

GL_CON_27_ATI

GLScene.OpenGL4

GL_CON_28_ATI

GLScene.OpenGL4

GL_CON_29_ATI

GLScene.OpenGL4

GL_CON_2_ATI

GLScene.OpenGL4

GL_CON_30_ATI

GLScene.OpenGL4

GL_CON_31_ATI

GLScene.OpenGL4

GL_CON_3_ATI

GLScene.OpenGL4

GL_CON_4_ATI

GLScene.OpenGL4

GL_CON_5_ATI

GLScene.OpenGL4

GL_CON_6_ATI

GLScene.OpenGL4

GL_CON_7_ATI

GLScene.OpenGL4

GL_CON_8_ATI

GLScene.OpenGL4

GL_CON_9_ATI

GLScene.OpenGL4

GL_COORD_REPLACE

GLScene.OpenGL4

GL_COORD_REPLACE_ARB

GLScene.OpenGL4

GL_COORD_REPLACE_NV

GLScene.OpenGL4

GL_COPY

GLScene.OpenGL4

GL_COPY_INVERTED

GLScene.OpenGL4

GL_COPY_PIXEL_TOKEN

GLScene.OpenGL4

GL_COPY_READ_BUFFER

GLScene.OpenGL4

GL_COPY_READ_BUFFER_BINDING

GLScene.OpenGL4

GL_ARB_copy_buffer

GL_COPY_WRITE_BUFFER

GLScene.OpenGL4

GL_COPY_WRITE_BUFFER_BINDING

GLScene.OpenGL4

GL_COUNTER_RANGE_AMD

GLScene.OpenGL4

GL_COUNTER_TYPE_AMD

GLScene.OpenGL4

GL_AMD_performance_monitor

GL_COUNT_DOWN_NV

GLScene.OpenGL4

GL_COUNT_UP_NV

GLScene.OpenGL4

GL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_multisample_coverage

GL_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_CUBIC_EXT

GLScene.OpenGL4

GL_CUBIC_HP

GLScene.OpenGL4

GL_CULL_FACE

GLScene.OpenGL4

GL_CULL_FACE_MODE

GLScene.OpenGL4

GL_CULL_FRAGMENT_NV

GLScene.OpenGL4

GL_CULL_MODES_NV

GLScene.OpenGL4

GL_CULL_VERTEX_EXT

GLScene.OpenGL4

GL_EXT_cull_vertex

GL_CULL_VERTEX_EYE_POSITION_EXT

GLScene.OpenGL4

GL_CULL_VERTEX_IBM

GLScene.OpenGL4

GL_IBM_cull_vertex

GL_CULL_VERTEX_OBJECT_POSITION_EXT

GLScene.OpenGL4

GL_CURRENT_ATTRIB_NV

GLScene.OpenGL4

GL_CURRENT_BINORMAL_EXT

GLScene.OpenGL4

GL_CURRENT_BIT

GLScene.OpenGL4

GL_CURRENT_COLOR

GLScene.OpenGL4

GL_CURRENT_FOG_COORD

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE

GLScene.OpenGL4

GL_CURRENT_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_CURRENT_INDEX

GLScene.OpenGL4

GL_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_INDEX_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_NV

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_CURRENT_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_CURRENT_NORMAL

GLScene.OpenGL4

GL_CURRENT_OCCLUSION_QUERY_ID_NV

GLScene.OpenGL4

GL_CURRENT_PALETTE_MATRIX_ARB

GLScene.OpenGL4

GL_CURRENT_PROGRAM

GLScene.OpenGL4

GL_CURRENT_QUERY

GLScene.OpenGL4

GL_CURRENT_QUERY_ARB

GLScene.OpenGL4

GL_CURRENT_RASTER_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_DISTANCE

GLScene.OpenGL4

GL_CURRENT_RASTER_INDEX

GLScene.OpenGL4

GL_CURRENT_RASTER_NORMAL_SGIX

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION

GLScene.OpenGL4

GL_CURRENT_RASTER_POSITION_VALID

GLScene.OpenGL4

GL_CURRENT_RASTER_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_RASTER_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR

GLScene.OpenGL4

GL_CURRENT_SECONDARY_COLOR_EXT

GLScene.OpenGL4

GL_CURRENT_TANGENT_EXT

GLScene.OpenGL4

GL_CURRENT_TEXTURE_COORDS

GLScene.OpenGL4

GL_CURRENT_TIME_NV

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB

GLScene.OpenGL4

GL_CURRENT_VERTEX_ATTRIB_ARB

GLScene.OpenGL4

GL_CURRENT_VERTEX_EXT

GLScene.OpenGL4

GL_CURRENT_VERTEX_WEIGHT_EXT

GLScene.OpenGL4

GL_CURRENT_WEIGHT_ARB

GLScene.OpenGL4

GL_CW

GLScene.OpenGL4

FrontFaceDirection

GL_DARKEN_KHR

GLScene.OpenGL4

GL_DATA_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_name_gen_delete

GL_DEBUG_CALLBACK_FUNCTION

GLScene.OpenGL4

GL_DEBUG_CALLBACK_FUNCTION_ARB

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM

GLScene.OpenGL4

GL_DEBUG_CALLBACK_USER_PARAM_ARB

GLScene.OpenGL4

GL_DEBUG_CATEGORY_API_ERROR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_APPLICATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_DEPRECATION_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_OTHER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_PERFORMANCE_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_SHADER_COMPILER_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_UNDEFINED_BEHAVIOR_AMD

GLScene.OpenGL4

GL_DEBUG_CATEGORY_WINDOW_SYSTEM_AMD

GLScene.OpenGL4

GL_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH

GLScene.OpenGL4

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_DEBUG_OUTPUT

GLScene.OpenGL4

GL_DEBUG_OUTPUT_SYNCHRONOUS

GLScene.OpenGL4

(4.3) GL_KHR_debug

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB

GLScene.OpenGL4

GL_ARB_debug_output

GL_DEBUG_SEVERITY_HIGH

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_HIGH_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_LOW_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_AMD

GLScene.OpenGL4

GL_DEBUG_SEVERITY_MEDIUM_ARB

GLScene.OpenGL4

GL_DEBUG_SEVERITY_NOTIFICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_API

GLScene.OpenGL4

GL_DEBUG_SOURCE_API_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION

GLScene.OpenGL4

GL_DEBUG_SOURCE_APPLICATION_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER

GLScene.OpenGL4

GL_DEBUG_SOURCE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER

GLScene.OpenGL4

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY

GLScene.OpenGL4

GL_DEBUG_SOURCE_THIRD_PARTY_ARB

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM

GLScene.OpenGL4

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR

GLScene.OpenGL4

GL_DEBUG_TYPE_ERROR_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_MARKER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER

GLScene.OpenGL4

GL_DEBUG_TYPE_OTHER_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE

GLScene.OpenGL4

GL_DEBUG_TYPE_PERFORMANCE_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_POP_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY

GLScene.OpenGL4

GL_DEBUG_TYPE_PORTABILITY_ARB

GLScene.OpenGL4

GL_DEBUG_TYPE_PUSH_GROUP

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR

GLScene.OpenGL4

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB

GLScene.OpenGL4

GL_DECAL

GLScene.OpenGL4

GL_DECODE_EXT

GLScene.OpenGL4

GL_DECR

GLScene.OpenGL4

GL_DECR_WRAP

GLScene.OpenGL4

GL_DECR_WRAP_EXT

GLScene.OpenGL4

GL_DEFORMATIONS_MASK_SGIX

GLScene.OpenGL4

GL_DELETE_STATUS

GLScene.OpenGL4

GL_DEPENDENT_AR_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_GB_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_3D_NV

GLScene.OpenGL4

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DEPTH

GLScene.OpenGL4

GL_DEPTH24_STENCIL8

GLScene.OpenGL4

GL_DEPTH24_STENCIL8_EXT

GLScene.OpenGL4

GL_DEPTH32F_STENCIL8

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_ATTACHMENT_EXT

GLScene.OpenGL4

GL_DEPTH_BIAS

GLScene.OpenGL4

GL_DEPTH_BITS

GLScene.OpenGL4

GL_DEPTH_BOUNDS_EXT

GLScene.OpenGL4

GL_DEPTH_BOUNDS_TEST_EXT

GLScene.OpenGL4

GL_EXT_depth_bounds_test

GL_DEPTH_BUFFER

GLScene.OpenGL4

GL_DEPTH_BUFFER_BIT

GLScene.OpenGL4

AttribMask

GL_DEPTH_BUFFER_FLOAT_MODE_NV

GLScene.OpenGL4

GL_DEPTH_CLAMP

GLScene.OpenGL4

GL_ARB_depth_clamp

GL_DEPTH_CLAMP_FAR_AMD

GLScene.OpenGL4

GL_DEPTH_CLAMP_NEAR_AMD

GLScene.OpenGL4

GL_AMD_depth_clamp_separate

GL_DEPTH_CLAMP_NV

GLScene.OpenGL4

GL_NV_depth_clamp

GL_DEPTH_CLEAR_VALUE

GLScene.OpenGL4

GL_DEPTH_COMPONENT

GLScene.OpenGL4

GL_DEPTH_COMPONENT16

GLScene.OpenGL4

GL_DEPTH_COMPONENT16_ARB

GLScene.OpenGL4

GL_ARB_depth_texture

GL_DEPTH_COMPONENT16_SGIX

GLScene.OpenGL4

GL_SGIX_depth_texture

GL_DEPTH_COMPONENT24

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT24_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENT32

GLScene.OpenGL4

GL_DEPTH_COMPONENT32F

GLScene.OpenGL4

GL_ARB_depth_buffer_float

GL_DEPTH_COMPONENT32_ARB

GLScene.OpenGL4

GL_DEPTH_COMPONENT32_SGIX

GLScene.OpenGL4

GL_DEPTH_COMPONENTS

GLScene.OpenGL4

GL_DEPTH_FUNC

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_COUNTERS_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_MAX_SGIX

GLScene.OpenGL4

GL_DEPTH_PASS_INSTRUMENT_SGIX

GLScene.OpenGL4

GL_SGI_depth_pass_instrument

GL_DEPTH_RANGE

GLScene.OpenGL4

GL_DEPTH_RENDERABLE

GLScene.OpenGL4

GL_DEPTH_SCALE

GLScene.OpenGL4

GL_DEPTH_STENCIL

GLScene.OpenGL4

GL_DEPTH_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_DEPTH_STENCIL_EXT

GLScene.OpenGL4

GL_EXT_packed_depth_stencil

GL_DEPTH_STENCIL_NV

GLScene.OpenGL4

GL_NV_packed_depth_stencil

GL_DEPTH_STENCIL_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_BGRA_NV

GLScene.OpenGL4

GL_DEPTH_STENCIL_TO_RGBA_NV

GLScene.OpenGL4

GL_NV_copy_depth_to_color

GL_DEPTH_TEST

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE

GLScene.OpenGL4

GL_DEPTH_TEXTURE_MODE_ARB

GLScene.OpenGL4

GL_DEPTH_WRITEMASK

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_BINDING_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_2D_SGIS

GLScene.OpenGL4

GL_SGIS_detail_texture

GL_DETAIL_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_LEVEL_SGIS

GLScene.OpenGL4

GL_DETAIL_TEXTURE_MODE_SGIS

GLScene.OpenGL4

GL_DIFFERENCE_KHR

GLScene.OpenGL4

GL_DIFFUSE

GLScene.OpenGL4

GL_DISCARD_ATI

GLScene.OpenGL4

GL_DISCARD_NV

GLScene.OpenGL4

GL_DISCRETE_AMD

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER

GLScene.OpenGL4

GL_DISPATCH_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DISPLAY_LIST

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_EXT

GLScene.OpenGL4

GL_DISTANCE_ATTENUATION_SGIS

GLScene.OpenGL4

GL_DITHER

GLScene.OpenGL4

GL_DOMAIN

GLScene.OpenGL4

GL_DONT_CARE

GLScene.OpenGL4

HintMode

GL_DOT2_ADD_ATI

GLScene.OpenGL4

GL_DOT3_ATI

GLScene.OpenGL4

GL_DOT3_RGB

GLScene.OpenGL4

GL_DOT3_RGBA

GLScene.OpenGL4

GL_DOT3_RGBA_ARB

GLScene.OpenGL4

GL_DOT3_RGBA_EXT

GLScene.OpenGL4

GL_DOT3_RGB_ARB

GLScene.OpenGL4

GL_ARB_texture_env_dot3

GL_DOT3_RGB_EXT

GLScene.OpenGL4

GL_EXT_texture_env_dot3

GL_DOT4_ATI

GLScene.OpenGL4

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DEPTH_REPLACE_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_PASS_THROUGH_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_1D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_2D_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_3D_NV

GLScene.OpenGL4

GL_NV_texture_shader2

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV

GLScene.OpenGL4

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_DOUBLE

GLScene.OpenGL4

GL_DOUBLEBUFFER

GLScene.OpenGL4

GL_DOUBLE_MAT2

GLScene.OpenGL4

GL_DOUBLE_MAT2x3

GLScene.OpenGL4

GL_DOUBLE_MAT2x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2x4

GLScene.OpenGL4

GL_DOUBLE_MAT2x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3

GLScene.OpenGL4

GL_DOUBLE_MAT3x2

GLScene.OpenGL4

GL_DOUBLE_MAT3x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3x4

GLScene.OpenGL4

GL_DOUBLE_MAT3x4_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4

GLScene.OpenGL4

GL_DOUBLE_MAT4x2

GLScene.OpenGL4

GL_DOUBLE_MAT4x2_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4x3

GLScene.OpenGL4

GL_DOUBLE_MAT4x3_EXT

GLScene.OpenGL4

GL_DOUBLE_MAT4_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC2

GLScene.OpenGL4

GL_ARB_gpu_shader_fp64

GL_DOUBLE_VEC2_EXT

GLScene.OpenGL4

reuse GL_DOUBLE

GL_DOUBLE_VEC3

GLScene.OpenGL4

GL_DOUBLE_VEC3_EXT

GLScene.OpenGL4

GL_DOUBLE_VEC4

GLScene.OpenGL4

GL_DOUBLE_VEC4_EXT

GLScene.OpenGL4

GL_DRAW_BUFFER

GLScene.OpenGL4

GL_DRAW_BUFFER0

GLScene.OpenGL4

GL_DRAW_BUFFER0_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER0_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1

GLScene.OpenGL4

GL_DRAW_BUFFER10

GLScene.OpenGL4

GL_DRAW_BUFFER10_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER10_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER11

GLScene.OpenGL4

GL_DRAW_BUFFER11_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER11_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER12

GLScene.OpenGL4

GL_DRAW_BUFFER12_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER12_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER13

GLScene.OpenGL4

GL_DRAW_BUFFER13_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER13_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER14

GLScene.OpenGL4

GL_DRAW_BUFFER14_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER14_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER15

GLScene.OpenGL4

GL_DRAW_BUFFER15_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER15_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER1_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER1_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER2

GLScene.OpenGL4

GL_DRAW_BUFFER2_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER2_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER3

GLScene.OpenGL4

GL_DRAW_BUFFER3_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER3_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER4

GLScene.OpenGL4

GL_DRAW_BUFFER4_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER4_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER5

GLScene.OpenGL4

GL_DRAW_BUFFER5_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER5_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER6

GLScene.OpenGL4

GL_DRAW_BUFFER6_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER6_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER7

GLScene.OpenGL4

GL_DRAW_BUFFER7_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER7_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER8

GLScene.OpenGL4

GL_DRAW_BUFFER8_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER8_ATI

GLScene.OpenGL4

GL_DRAW_BUFFER9

GLScene.OpenGL4

GL_DRAW_BUFFER9_ARB

GLScene.OpenGL4

GL_DRAW_BUFFER9_ATI

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_DRAW_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_DRAW_INDIRECT_ADDRESS_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_BUFFER

GLScene.OpenGL4

GL_ARB_draw_indirect

GL_DRAW_INDIRECT_BUFFER_BINDING

GLScene.OpenGL4

GL_DRAW_INDIRECT_LENGTH_NV

GLScene.OpenGL4

GL_DRAW_INDIRECT_UNIFIED_NV

GLScene.OpenGL4

GL_DRAW_PIXELS_APPLE

GLScene.OpenGL4

GL_APPLE_fence

GL_DRAW_PIXEL_TOKEN

GLScene.OpenGL4

GL_DSDT8_MAG8_INTENSITY8_NV

GLScene.OpenGL4

GL_DSDT8_MAG8_NV

GLScene.OpenGL4

GL_DSDT8_NV

GLScene.OpenGL4

GL_DSDT_MAG_INTENSITY_NV

GLScene.OpenGL4

GL_DSDT_MAG_NV

GLScene.OpenGL4

GL_DSDT_MAG_VIB_NV

GLScene.OpenGL4

GL_DSDT_NV

GLScene.OpenGL4

GL_DST_ALPHA

GLScene.OpenGL4

GL_DST_COLOR

GLScene.OpenGL4

BlendingFactorSrc

GL_DS_BIAS_NV

GLScene.OpenGL4

GL_DS_SCALE_NV

GLScene.OpenGL4

GL_DT_BIAS_NV

GLScene.OpenGL4

GL_DT_SCALE_NV

GLScene.OpenGL4

GL_DU8DV8_ATI

GLScene.OpenGL4

GL_DUAL_ALPHA12_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA16_SGIS

GLScene.OpenGL4

GL_DUAL_ALPHA4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_select

GL_DUAL_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY12_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY16_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY4_SGIS

GLScene.OpenGL4

GL_DUAL_INTENSITY8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE12_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE16_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA4_SGIS

GLScene.OpenGL4

GL_DUAL_LUMINANCE_ALPHA8_SGIS

GLScene.OpenGL4

GL_DUAL_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_DUDV_ATI

GLScene.OpenGL4

GL_DUP_FIRST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DUP_LAST_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_DYNAMIC_ATI

GLScene.OpenGL4

GL_DYNAMIC_COPY

GLScene.OpenGL4

GL_DYNAMIC_COPY_ARB

GLScene.OpenGL4

GL_DYNAMIC_DRAW

GLScene.OpenGL4

GL_DYNAMIC_DRAW_ARB

GLScene.OpenGL4

GL_DYNAMIC_READ

GLScene.OpenGL4

GL_DYNAMIC_READ_ARB

GLScene.OpenGL4

GL_DYNAMIC_STORAGE_BIT

GLScene.OpenGL4

GL_EDGEFLAG_BIT_PGI

GLScene.OpenGL4

GL_EDGE_FLAG

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE

GLScene.OpenGL4

GL_EDGE_FLAG_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_EIGHTH_BIT_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_APPLE

GLScene.OpenGL4

GL_APPLE_element_array

GL_ELEMENT_ARRAY_ATI

GLScene.OpenGL4

GL_ATI_element_array

GL_ELEMENT_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_ELEMENT_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_POINTER_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_APPLE

GLScene.OpenGL4

GL_ELEMENT_ARRAY_TYPE_ATI

GLScene.OpenGL4

GL_ELEMENT_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_EMBOSS_CONSTANT_NV

GLScene.OpenGL4

GL_EMBOSS_LIGHT_NV

GLScene.OpenGL4

GL_NV_texgen_emboss

GL_EMBOSS_MAP_NV

GLScene.OpenGL4

GL_EMISSION

GLScene.OpenGL4

GL_ENABLE_BIT

GLScene.OpenGL4

GL_EQUAL

GLScene.OpenGL4

GL_EQUIV

GLScene.OpenGL4

GL_EVAL_2D_NV

GLScene.OpenGL4

GL_NV_evaluators

GL_EVAL_BIT

GLScene.OpenGL4

GL_EVAL_FRACTIONAL_TESSELLATION_NV

GLScene.OpenGL4

GL_EVAL_TRIANGULAR_2D_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB0_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB10_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB11_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB12_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB13_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB14_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB15_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB1_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB2_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB3_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB4_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB5_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB6_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB7_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB8_NV

GLScene.OpenGL4

GL_EVAL_VERTEX_ATTRIB9_NV

GLScene.OpenGL4

GL_EXCLUSION_KHR

GLScene.OpenGL4

GL_EXP

GLScene.OpenGL4

GL_EXP2

GLScene.OpenGL4

GL_EXPAND_NEGATE_NV

GLScene.OpenGL4

GL_EXPAND_NORMAL_NV

GLScene.OpenGL4

GL_EXTENSIONS

GLScene.OpenGL4

GL_EXTERNAL_VIRTUAL_MEMORY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_pinned_memory

GL_EXT_422_pixels

GLScene.OpenGL4

GL 4.6

GL_EXT_abgr

GLScene.OpenGL4

GL 4.6

GL_EXT_bgra

GLScene.OpenGL4

GL 4.6

GL_EXT_bindable_uniform

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_color

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_equation_separate

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_func_separate

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_logic_op

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_minmax

GLScene.OpenGL4

GL 4.6

GL_EXT_blend_subtract

GLScene.OpenGL4

GL 4.6

GL_EXT_clip_volume_hint

GLScene.OpenGL4

GL 4.6

GL_EXT_cmyka

GLScene.OpenGL4

GL 4.6

GL_EXT_color_matrix

GLScene.OpenGL4

GL 4.6

GL_EXT_color_subtable

GLScene.OpenGL4

GL 4.6

GL_EXT_compiled_vertex_array

GLScene.OpenGL4

GL 4.6

GL_EXT_convolution

GLScene.OpenGL4

GL 4.6

GL_EXT_coordinate_frame

GLScene.OpenGL4

GL 4.6

GL_EXT_copy_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_cull_vertex

GLScene.OpenGL4

GL 4.6

GL_EXT_depth_bounds_test

GLScene.OpenGL4

GL 4.6

GL_EXT_direct_state_access

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_buffers2

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_instanced

GLScene.OpenGL4

GL 4.6

GL_EXT_draw_range_elements

GLScene.OpenGL4

GL 4.6

GL_EXT_fog_coord

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_blit

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_multisample

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_framebuffer_sRGB

GLScene.OpenGL4

GL 4.6

GL_EXT_geometry_shader4

GLScene.OpenGL4

GL 4.6

GL_EXT_gpu_program_parameters

GLScene.OpenGL4

GL 4.6

GL_EXT_gpu_shader4

GLScene.OpenGL4

GL 4.6

GL_EXT_histogram

GLScene.OpenGL4

GL 4.6

GL_EXT_index_array_formats

GLScene.OpenGL4

GL 4.6

GL_EXT_index_func

GLScene.OpenGL4

GL 4.6

GL_EXT_index_material

GLScene.OpenGL4

GL 4.6

GL_EXT_index_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_light_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_misc_attribute

GLScene.OpenGL4

GL 4.6

GL_EXT_multisample

GLScene.OpenGL4

GL 4.6

GL_EXT_multi_draw_arrays

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_depth_stencil

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_float

GLScene.OpenGL4

GL 4.6

GL_EXT_packed_pixels

GLScene.OpenGL4

GL 4.6

GL_EXT_paletted_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_buffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_transform

GLScene.OpenGL4

GL 4.6

GL_EXT_pixel_transform_color_table

GLScene.OpenGL4

GL 4.6

GL_EXT_point_parameters

GLScene.OpenGL4

GL 4.6

GL_EXT_polygon_offset

GLScene.OpenGL4

GL 4.6

GL_EXT_provoking_vertex

GLScene.OpenGL4

GL 4.6

GL_EXT_rescale_normal

GLScene.OpenGL4

GL 4.6

GL_EXT_secondary_color

GLScene.OpenGL4

GL 4.6

GL_EXT_separate_shader_objects

GLScene.OpenGL4

GL 4.6

GL_EXT_separate_specular_color

GLScene.OpenGL4

GL 4.6

GL_EXT_shader_image_load_store

GLScene.OpenGL4

GL 4.6

GL_EXT_shadow_funcs

GLScene.OpenGL4

GL 4.6

GL_EXT_shared_texture_palette

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_clear_tag

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_two_side

GLScene.OpenGL4

GL 4.6

GL_EXT_stencil_wrap

GLScene.OpenGL4

GL 4.6

GL_EXT_subtexture

GLScene.OpenGL4

GL 4.6

GL_EXT_texture

GLScene.OpenGL4

GL 4.6

GL_EXT_texture3D

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_array

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_buffer_object

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_dxt1

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_latc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_rgtc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_compression_s3tc

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_cube_map

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_edge_clamp

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_add

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_combine

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_env_dot3

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_filter_anisotropic

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_integer

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_lod_bias

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_mirror_clamp

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_object

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_perturb_normal

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_rectangle

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_shared_exponent

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_snorm

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_sRGB

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_sRGB_decode

GLScene.OpenGL4

GL 4.6

GL_EXT_texture_swizzle

GLScene.OpenGL4

GL 4.6

GL_EXT_timer_query

GLScene.OpenGL4

GL 4.6

GL_EXT_transform_feedback

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_array

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_array_bgra

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_attrib_64bit

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_shader

GLScene.OpenGL4

GL 4.6

GL_EXT_vertex_weighting

GLScene.OpenGL4

GL 4.6

GL_EYE_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_EYE_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_SGIS_point_line_texgen

GL_EYE_LINEAR

GLScene.OpenGL4

GL_EYE_LINE_SGIS

GLScene.OpenGL4

GL_EYE_PLANE

GLScene.OpenGL4

GL_EYE_PLANE_ABSOLUTE_NV

GLScene.OpenGL4

GL_EYE_POINT_SGIS

GLScene.OpenGL4

GL_EYE_RADIAL_NV

GLScene.OpenGL4

GL_E_TIMES_F_NV

GLScene.OpenGL4

GL_FACTOR_MAX_AMD

GLScene.OpenGL4

GL_FACTOR_MIN_AMD

GLScene.OpenGL4

GL_AMD_blend_minmax_factor

GL_FAILURE_NV

GLScene.OpenGL4

GL_FALSE

GLScene.OpenGL4

GL_FASTEST

GLScene.OpenGL4

GL_FEEDBACK

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_POINTER

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_FEEDBACK_BUFFER_TYPE

GLScene.OpenGL4

GL_FENCE_APPLE

GLScene.OpenGL4

GL_FENCE_CONDITION_NV

GLScene.OpenGL4

GL_FENCE_STATUS_NV

GLScene.OpenGL4

GL_FfdMaskSGIX

GLScene.OpenGL4

GL 4.6

GL_FIELDS_NV

GLScene.OpenGL4

GL_FIELD_LOWER_NV

GLScene.OpenGL4

GL_FIELD_UPPER_NV

GLScene.OpenGL4

GL_FILE_NAME_NV

GLScene.OpenGL4

GL_FILL

GLScene.OpenGL4

GL_FILTER

GLScene.OpenGL4

GL_FILTER4_SGIS

GLScene.OpenGL4

GL_SGIS_texture_filter4

GL_FIRST_TO_REST_NV

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_FIRST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_FIXED

GLScene.OpenGL4

GL_ARB_ES2_compatibility

GL_FIXED_ONLY

GLScene.OpenGL4

GL_FIXED_ONLY_ARB

GLScene.OpenGL4

GL_FLAT

GLScene.OpenGL4

GL_FLOAT

GLScene.OpenGL4

GL_FLOAT16_NV

GLScene.OpenGL4

GL_FLOAT16_VEC2_NV

GLScene.OpenGL4

GL_FLOAT16_VEC3_NV

GLScene.OpenGL4

GL_FLOAT16_VEC4_NV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV

GLScene.OpenGL4

GL_FLOAT_32_UNSIGNED_INT_24_8_REV_NV

GLScene.OpenGL4

GL_NV_depth_buffer_float

GL_FLOAT_CLEAR_COLOR_VALUE_NV

GLScene.OpenGL4

GL_FLOAT_MAT2

GLScene.OpenGL4

GL_FLOAT_MAT2x3

GLScene.OpenGL4

GL_FLOAT_MAT2x4

GLScene.OpenGL4

GL_FLOAT_MAT2_ARB

GLScene.OpenGL4

GL_FLOAT_MAT3

GLScene.OpenGL4

GL_FLOAT_MAT3x2

GLScene.OpenGL4

GL_FLOAT_MAT3x4

GLScene.OpenGL4

GL_FLOAT_MAT3_ARB

GLScene.OpenGL4

GL_FLOAT_MAT4

GLScene.OpenGL4

GL_FLOAT_MAT4x2

GLScene.OpenGL4

GL_FLOAT_MAT4x3

GLScene.OpenGL4

GL_FLOAT_MAT4_ARB

GLScene.OpenGL4

GL_FLOAT_R16_NV

GLScene.OpenGL4

GL_FLOAT_R32_NV

GLScene.OpenGL4

GL_FLOAT_RG16_NV

GLScene.OpenGL4

GL_FLOAT_RG32_NV

GLScene.OpenGL4

GL_FLOAT_RGB16_NV

GLScene.OpenGL4

GL_FLOAT_RGB32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA16_NV

GLScene.OpenGL4

GL_FLOAT_RGBA32_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_MODE_NV

GLScene.OpenGL4

GL_FLOAT_RGBA_NV

GLScene.OpenGL4

GL_FLOAT_RGB_NV

GLScene.OpenGL4

GL_FLOAT_RG_NV

GLScene.OpenGL4

GL_FLOAT_R_NV

GLScene.OpenGL4

GL_NV_float_buffer

GL_FLOAT_VEC2

GLScene.OpenGL4

GL_FLOAT_VEC2_ARB

GLScene.OpenGL4

GL_FLOAT_VEC3

GLScene.OpenGL4

GL_FLOAT_VEC3_ARB

GLScene.OpenGL4

GL_FLOAT_VEC4

GLScene.OpenGL4

GL_FLOAT_VEC4_ARB

GLScene.OpenGL4

GL_FOG

GLScene.OpenGL4

GL_FOG_BIT

GLScene.OpenGL4

GL_FOG_COLOR

GLScene.OpenGL4

GL_FOG_COORD

GLScene.OpenGL4

GL_FOG_COORDINATE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORDINATE_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_EXT

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE

GLScene.OpenGL4

GL_FOG_COORDINATE_SOURCE_EXT

GLScene.OpenGL4

GL_EXT_fog_coord

GL_FOG_COORD_ARRAY

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_FOG_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_FOG_COORD_SRC

GLScene.OpenGL4

GL_FOG_DENSITY

GLScene.OpenGL4

GL_FOG_DISTANCE_MODE_NV

GLScene.OpenGL4

GL_NV_fog_distance

GL_FOG_END

GLScene.OpenGL4

GL_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_FOG_FUNC_SGIS

GLScene.OpenGL4

GL_SGIS_fog_function

GL_FOG_HINT

GLScene.OpenGL4

GL_FOG_INDEX

GLScene.OpenGL4

GL_FOG_MODE

GLScene.OpenGL4

GL_FOG_OFFSET_SGIX

GLScene.OpenGL4

GL_SGIX_fog_offset

GL_FOG_OFFSET_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SCALE_SGIX

GLScene.OpenGL4

GL_SGIX_fog_scale

GL_FOG_SCALE_VALUE_SGIX

GLScene.OpenGL4

GL_FOG_SPECULAR_TEXTURE_WIN

GLScene.OpenGL4

GL_WIN_specular_fog

GL_FOG_START

GLScene.OpenGL4

GL_FONT_ASCENDER_NV

GLScene.OpenGL4

GL_FONT_DESCENDER_NV

GLScene.OpenGL4

GL_FONT_HAS_KERNING_NV

GLScene.OpenGL4

GL_FONT_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_HEIGHT_NV

GLScene.OpenGL4

GL_FONT_MAX_ADVANCE_WIDTH_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_POSITION_NV

GLScene.OpenGL4

GL_FONT_UNDERLINE_THICKNESS_NV

GLScene.OpenGL4

GL_FONT_UNITS_PER_EM_NV

GLScene.OpenGL4

GL_FONT_X_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_X_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MAX_BOUNDS_NV

GLScene.OpenGL4

GL_FONT_Y_MIN_BOUNDS_NV

GLScene.OpenGL4

GL_FORCE_BLUE_TO_ONE_NV

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_244_244_OML

GLScene.OpenGL4

GL_FORMAT_SUBSAMPLE_24_24_OML

GLScene.OpenGL4

GL_OML_subsample

GL_FRACTIONAL_EVEN

GLScene.OpenGL4

GL_FRACTIONAL_ODD

GLScene.OpenGL4

GL_FRAGMENT_COLOR_EXT

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_FACE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_PARAMETER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_COLOR_MATERIAL_SGIX

GLScene.OpenGL4

GL_FRAGMENT_DEPTH

GLScene.OpenGL4

GL_FRAGMENT_DEPTH_EXT

GLScene.OpenGL4

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS

GLScene.OpenGL4

GL_FRAGMENT_LIGHT0_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT1_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT2_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT3_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT4_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT5_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT6_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT7_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHTING_SGIX

GLScene.OpenGL4

GL_SGIX_fragment_lighting

GL_FRAGMENT_LIGHT_MODEL_AMBIENT_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_LOCAL_VIEWER_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_NORMAL_INTERPOLATION_SGIX

GLScene.OpenGL4

GL_FRAGMENT_LIGHT_MODEL_TWO_SIDE_SGIX

GLScene.OpenGL4

GL_FRAGMENT_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_light_texture

GL_FRAGMENT_NORMAL_EXT

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_ARB

GLScene.OpenGL4

GL_ARB_fragment_program

GL_FRAGMENT_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_INTERPOLATION_OFFSET_BITS_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_NV

GLScene.OpenGL4

GL_FRAGMENT_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_FRAGMENT_SHADER

GLScene.OpenGL4

GL_FRAGMENT_SHADER_ARB

GLScene.OpenGL4

GL_ARB_fragment_shader

GL_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_fragment_shader

GL_FRAGMENT_SHADER_BIT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT

GLScene.OpenGL4

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB

GLScene.OpenGL4

1.4

GL_FRAGMENT_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_FRAGMENT_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE

GLScene.OpenGL4

GL_FRAGMENT_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_FRAGMENT_TEXTURE

GLScene.OpenGL4

GL_FRAMEBUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_BASE_VIEW_INDEX_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_NUM_VIEWS_OVR

GLScene.OpenGL4

GL_OVR_multiview

GL_FRAMEBUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_FRAMEBUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_BLEND

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE

GLScene.OpenGL4

GL_FRAMEBUFFER_COMPLETE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_HEIGHT

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_LAYERS

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_SAMPLES

GLScene.OpenGL4

GL_FRAMEBUFFER_DEFAULT_WIDTH

GLScene.OpenGL4

GL_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_object

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

GLScene.OpenGLTokens

Vendor/EXT extensions constants, in extension number order

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_INCOMPLETE_VIEW_TARGETS_OVR

GLScene.OpenGL4

GL_FRAMEBUFFER_PROGRAMMABLE_SAMPLE_LOCATIONS_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE

GLScene.OpenGL4

GL_FRAMEBUFFER_RENDERABLE_LAYERED

GLScene.OpenGL4

GL_FRAMEBUFFER_SAMPLE_LOCATION_PIXEL_GRID_ARB

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB

GLScene.OpenGL4

GL_ARB_framebuffer_sRGB

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_SRGB_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_STATUS_ERROR_EXT

GLScene.OpenGL4

GL_FRAMEBUFFER_UNDEFINED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED

GLScene.OpenGL4

GL_FRAMEBUFFER_UNSUPPORTED_EXT

GLScene.OpenGL4

GL_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_FRAMEZOOM_SGIX

GLScene.OpenGL4

GL_SGIX_framezoom

GL_FRAME_NV

GLScene.OpenGL4

GL_NV_present_video

GL_FRONT

GLScene.OpenGL4

GL_FRONT_AND_BACK

GLScene.OpenGL4

GL_FRONT_FACE

GLScene.OpenGL4

GL_FRONT_LEFT

GLScene.OpenGL4

GL_FRONT_RIGHT

GLScene.OpenGL4

GL_FULL_RANGE_EXT

GLScene.OpenGL4

GL_FULL_STIPPLE_HINT_PGI

GLScene.OpenGL4

GL_FULL_SUPPORT

GLScene.OpenGL4

GL_FUNC_ADD

GLScene.OpenGL4

GL_FUNC_ADD_EXT

GLScene.OpenGL4

GL_EXT_blend_minmax

GL_FUNC_REVERSE_SUBTRACT

GLScene.OpenGL4

GL_FUNC_REVERSE_SUBTRACT_EXT

GLScene.OpenGL4

GL_FUNC_SUBTRACT

GLScene.OpenGL4

GL_FUNC_SUBTRACT_EXT

GLScene.OpenGL4

GL_EXT_blend_subtract

GL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT

GLScene.OpenGL4

GL_GENERATE_MIPMAP_HINT_SGIS

GLScene.OpenGL4

GL_GENERATE_MIPMAP_SGIS

GLScene.OpenGL4

GL_SGIS_generate_mipmap

GL_GENERIC_ATTRIB_NV

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_GEOMETRY_DEFORMATION_SGIX

GLScene.OpenGL4

GL_SGIX_polynomial_ffd

GL_GEOMETRY_INPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_INPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_ARB

GLScene.OpenGL4

GL_GEOMETRY_OUTPUT_TYPE_EXT

GLScene.OpenGL4

GL_GEOMETRY_PROGRAM_NV

GLScene.OpenGL4

GL_NV_geometry_program4

GL_GEOMETRY_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_GEOMETRY_SHADER

GLScene.OpenGL4

GL_GEOMETRY_SHADER_ARB

GLScene.OpenGL4

GL_GEOMETRY_SHADER_BIT

GLScene.OpenGL4

GL_GEOMETRY_SHADER_EXT

GLScene.OpenGL4

GL_EXT_geometry_shader4

GL_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_ARB_gpu_shader5

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED

GLScene.OpenGL4

GL_GEOMETRY_SHADER_PRIMITIVES_EMITTED_ARB

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE

GLScene.OpenGL4

GL_GEOMETRY_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_GEOMETRY_TEXTURE

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_ARB

GLScene.OpenGL4

GL_GEOMETRY_VERTICES_OUT_EXT

GLScene.OpenGL4

GL_GEQUAL

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_GET_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_GLOBAL_ALPHA_FACTOR_SUN

GLScene.OpenGL4

GL_GLOBAL_ALPHA_SUN

GLScene.OpenGL4

GL_SUN_global_alpha

GL_GLYPH_HAS_KERNING_NV

GLScene.OpenGL4

GL_GLYPH_HEIGHT_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV

GLScene.OpenGL4

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV

GLScene.OpenGL4

GL_GLYPH_WIDTH_BIT_NV

GLScene.OpenGL4

GL_GPU_ADDRESS_NV

GLScene.OpenGL4

GL_GREATER

GLScene.OpenGL4

GL_GREEN

GLScene.OpenGL4

GL_GREEN_BIAS

GLScene.OpenGL4

GL_GREEN_BITS

GLScene.OpenGL4

GL_GREEN_BIT_ATI

GLScene.OpenGL4

GL_GREEN_INTEGER

GLScene.OpenGL4

GL_GREEN_INTEGER_EXT

GLScene.OpenGL4

GL_GREEN_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_GREEN_SCALE

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET

GLScene.OpenGL4

GL_GUILTY_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_HALF_APPLE

GLScene.OpenGL4

GL_APPLE_float_pixels

GL_HALF_BIAS_NEGATE_NV

GLScene.OpenGL4

GL_HALF_BIAS_NORMAL_NV

GLScene.OpenGL4

GL_HALF_BIT_ATI

GLScene.OpenGL4

GL_HALF_FLOAT

GLScene.OpenGL4

GL_ARB_half_float_vertex

GL_HALF_FLOAT_ARB

GLScene.OpenGL4

GL_ARB_half_float_pixel

GL_HALF_FLOAT_NV

GLScene.OpenGL4

GL_NV_half_float

GL_HARDLIGHT_KHR

GLScene.OpenGL4

GL_HIGH_FLOAT

GLScene.OpenGL4

GL_HIGH_INT

GLScene.OpenGL4

GL_HILO16_NV

GLScene.OpenGL4

GL_HILO8_NV

GLScene.OpenGL4

GL_HILO_NV

GLScene.OpenGL4

GL_HINT_BIT

GLScene.OpenGL4

GL_HISTOGRAM

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_EXT

GLScene.OpenGL4

GL_EXT_histogram

GL_HISTOGRAM_FORMAT

GLScene.OpenGL4

GL_HISTOGRAM_FORMAT_EXT

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE

GLScene.OpenGL4

GL_HISTOGRAM_RED_SIZE_EXT

GLScene.OpenGL4

GL_HISTOGRAM_SINK

GLScene.OpenGL4

GL_HISTOGRAM_SINK_EXT

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH

GLScene.OpenGL4

GL_HISTOGRAM_WIDTH_EXT

GLScene.OpenGL4

GL_HI_BIAS_NV

GLScene.OpenGL4

GL_HI_SCALE_NV

GLScene.OpenGL4

GL_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_HP_convolution_border_modes

GLScene.OpenGL4

GL 4.6

GL_HP_image_transform

GLScene.OpenGL4

GL 4.6

GL_HP_occlusion_test

GLScene.OpenGL4

GL 4.6

GL_HP_texture_lighting

GLScene.OpenGL4

GL 4.6

GL_HSL_COLOR_KHR

GLScene.OpenGL4

GL_HSL_HUE_KHR

GLScene.OpenGL4

GL_HSL_LUMINOSITY_KHR

GLScene.OpenGL4

GL_HSL_SATURATION_KHR

GLScene.OpenGL4

GL_IBM_cull_vertex

GLScene.OpenGL4

GL 4.6

GL_IBM_multimode_draw_arrays

GLScene.OpenGL4

GL 4.6

GL_IBM_rasterpos_clip

GLScene.OpenGL4

GL 4.6

GL_IBM_texture_mirrored_repeat

GLScene.OpenGL4

GL 4.6

GL_IBM_vertex_array_lists

GLScene.OpenGL4

GL 4.6

GL_IDENTITY_NV

GLScene.OpenGL4

GL_IGNORE_BORDER_HP

GLScene.OpenGL4

GL_HP_convolution_border_modes

GL_IMAGE_1D

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_1D_EXT

GLScene.OpenGL4

GL_IMAGE_2D

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_IMAGE_2D_RECT

GLScene.OpenGL4

GL_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_IMAGE_3D

GLScene.OpenGL4

GL_IMAGE_3D_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS

GLScene.OpenGL4

GL_IMAGE_BINDING_ACCESS_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT

GLScene.OpenGL4

GL_IMAGE_BINDING_FORMAT_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYERED_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LAYER_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL

GLScene.OpenGL4

GL_IMAGE_BINDING_LEVEL_EXT

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME

GLScene.OpenGL4

GL_IMAGE_BINDING_NAME_EXT

GLScene.OpenGL4

GL_IMAGE_BUFFER

GLScene.OpenGL4

GL_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_IMAGE_CLASS_10_10_10_2

GLScene.OpenGL4

GL_IMAGE_CLASS_11_11_10

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_1_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_2_X_8

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_16

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_32

GLScene.OpenGL4

GL_IMAGE_CLASS_4_X_8

GLScene.OpenGL4

GL_IMAGE_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_IMAGE_CUBE

GLScene.OpenGL4

GL_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_IMAGE_CUBIC_WEIGHT_HP

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_CLASS

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_BY_SIZE

GLScene.OpenGL4

GL_IMAGE_FORMAT_COMPATIBILITY_TYPE

GLScene.OpenGL4

GL_IMAGE_MAG_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_MIN_FILTER_HP

GLScene.OpenGL4

GL_IMAGE_PIXEL_FORMAT

GLScene.OpenGL4

GL_IMAGE_PIXEL_TYPE

GLScene.OpenGL4

GL_IMAGE_ROTATE_ANGLE_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_X_HP

GLScene.OpenGL4

GL_IMAGE_ROTATE_ORIGIN_Y_HP

GLScene.OpenGL4

GL_IMAGE_SCALE_X_HP

GLScene.OpenGL4

GL_HP_image_transform

GL_IMAGE_SCALE_Y_HP

GLScene.OpenGL4

GL_IMAGE_TEXEL_SIZE

GLScene.OpenGL4

GL_IMAGE_TRANSFORM_2D_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_X_HP

GLScene.OpenGL4

GL_IMAGE_TRANSLATE_Y_HP

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_FORMAT

GLScene.OpenGL4

GL_IMPLEMENTATION_COLOR_READ_TYPE

GLScene.OpenGL4

GL_INCR

GLScene.OpenGL4

GL_INCR_WRAP

GLScene.OpenGL4

GL_INCR_WRAP_EXT

GLScene.OpenGL4

GL_EXT_stencil_wrap

GL_INDEX

GLScene.OpenGL4

GL_INDEX_ARRAY

GLScene.OpenGL4

GL_INDEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_INDEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_INDEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER

GLScene.OpenGL4

GL_INDEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_INDEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE

GLScene.OpenGL4

GL_INDEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_INDEX_BITS

GLScene.OpenGL4

GL_INDEX_BIT_PGI

GLScene.OpenGL4

GL_INDEX_CLEAR_VALUE

GLScene.OpenGL4

GL_INDEX_LOGIC_OP

GLScene.OpenGL4

GL_INDEX_MATERIAL_EXT

GLScene.OpenGL4

GL_EXT_index_material

GL_INDEX_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_INDEX_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_INDEX_MODE

GLScene.OpenGL4

GL_INDEX_OFFSET

GLScene.OpenGL4

GL_INDEX_SHIFT

GLScene.OpenGL4

GL_INDEX_TEST_EXT

GLScene.OpenGL4

GL_EXT_index_func

GL_INDEX_TEST_FUNC_EXT

GLScene.OpenGL4

GL_INDEX_TEST_REF_EXT

GLScene.OpenGL4

GL_INDEX_WRITEMASK

GLScene.OpenGL4

GL_INFO_LOG_LENGTH

GLScene.OpenGL4

GL_INGR_blend_func_separate

GLScene.OpenGL4

GL 4.6

GL_INGR_color_clamp

GLScene.OpenGL4

GL 4.6

GL_INGR_interlace_read

GLScene.OpenGL4

GL 4.6

GL_INGR_palette_buffer

GLScene.OpenGL4

GL 4.6

GL_INNOCENT_CONTEXT_RESET

GLScene.OpenGL4

GL_INNOCENT_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_INSTRUMENT_BUFFER_POINTER_SGIX

GLScene.OpenGL4

GL_SGIX_instruments

GL_INSTRUMENT_MEASUREMENTS_SGIX

GLScene.OpenGL4

GL_INT

GLScene.OpenGL4

GL_INT16_NV

GLScene.OpenGL4

GL_INT16_VEC2_NV

GLScene.OpenGL4

GL_INT16_VEC3_NV

GLScene.OpenGL4

GL_INT16_VEC4_NV

GLScene.OpenGL4

GL_INT64_ARB

GLScene.OpenGL4

GL_ARB_gpu_shader_int64

GL_INT64_NV

GLScene.OpenGL4

GL_NV_gpu_shader5

GL_INT64_VEC2_ARB

GLScene.OpenGL4

GL_INT64_VEC2_NV

GLScene.OpenGL4

GL_INT64_VEC3_ARB

GLScene.OpenGL4

GL_INT64_VEC3_NV

GLScene.OpenGL4

GL_INT64_VEC4_ARB

GLScene.OpenGL4

GL_INT64_VEC4_NV

GLScene.OpenGL4

GL_INT8_NV

GLScene.OpenGL4

GL_INT8_VEC2_NV

GLScene.OpenGL4

GL_INT8_VEC3_NV

GLScene.OpenGL4

GL_INT8_VEC4_NV

GLScene.OpenGL4

GL_INTEL_framebuffer_CMAA

GLScene.OpenGL4

GL 4.6

GL_INTEL_parallel_arrays

GLScene.OpenGL4

GL 4.6

GL_INTEL_texture_scissor

GLScene.OpenGL4

GL 4.6

GL_INTENSITY

GLScene.OpenGL4

GL_INTENSITY12

GLScene.OpenGL4

GL_INTENSITY12_EXT

GLScene.OpenGL4

GL_INTENSITY16

GLScene.OpenGL4

GL_INTENSITY16F_ARB

GLScene.OpenGL4

GL_INTENSITY16I_EXT

GLScene.OpenGL4

GL_INTENSITY16UI_EXT

GLScene.OpenGL4

GL_INTENSITY16_EXT

GLScene.OpenGL4

GL_INTENSITY16_SNORM

GLScene.OpenGL4

GL_INTENSITY32F_ARB

GLScene.OpenGL4

GL_INTENSITY32I_EXT

GLScene.OpenGL4

GL_INTENSITY32UI_EXT

GLScene.OpenGL4

GL_INTENSITY4

GLScene.OpenGL4

GL_INTENSITY4_EXT

GLScene.OpenGL4

GL_INTENSITY8

GLScene.OpenGL4

GL_INTENSITY8I_EXT

GLScene.OpenGL4

GL_INTENSITY8UI_EXT

GLScene.OpenGL4

GL_INTENSITY8_EXT

GLScene.OpenGL4

GL_INTENSITY8_SNORM

GLScene.OpenGL4

GL_INTENSITY_EXT

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT16_ATI

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_APPLE

GLScene.OpenGL4

GL_INTENSITY_FLOAT32_ATI

GLScene.OpenGL4

GL_INTENSITY_SNORM

GLScene.OpenGL4

GL_INTERLACE_OML

GLScene.OpenGL4

GL_OML_interlace

GL_INTERLACE_READ_INGR

GLScene.OpenGL4

GL_INGR_interlace_read

GL_INTERLACE_READ_OML

GLScene.OpenGL4

GL_INTERLACE_SGIX

GLScene.OpenGL4

GL_SGIX_interlace

GL_INTERLEAVED_ATTRIBS

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_EXT

GLScene.OpenGL4

GL_INTERLEAVED_ATTRIBS_NV

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_ALPHA_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_BLUE_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_DEPTH_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_GREEN_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_PREFERRED

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_RED_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SHARED_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_SIZE

GLScene.OpenGL4

GL_INTERNALFORMAT_STENCIL_TYPE

GLScene.OpenGL4

GL_INTERNALFORMAT_SUPPORTED

GLScene.OpenGL4

GL_INTERPOLATE

GLScene.OpenGL4

GL_INTERPOLATE_ARB

GLScene.OpenGL4

GL_INTERPOLATE_EXT

GLScene.OpenGL4

GL_INT_2_10_10_10_REV

GLScene.OpenGL4

reuse GL_UNSIGNED_INT_2_10_10_10_REV

GL_INT_IMAGE_1D

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_IMAGE_3D

GLScene.OpenGL4

GL_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_3D

GLScene.OpenGL4

GL_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_INT_VEC2

GLScene.OpenGL4

GL_INT_VEC2_ARB

GLScene.OpenGL4

GL_INT_VEC3

GLScene.OpenGL4

GL_INT_VEC3_ARB

GLScene.OpenGL4

GL_INT_VEC4

GLScene.OpenGL4

GL_INT_VEC4_ARB

GLScene.OpenGL4

GL_INVALID_ENUM

GLScene.OpenGL4

GL_INVALID_FRAMEBUFFER_OPERATION

GLScene.OpenGL4

GL_ARB_framebuffer_object

GL_INVALID_FRAMEBUFFER_OPERATION_EXT

GLScene.OpenGL4

GL_INVALID_INDEX

GLScene.OpenGL4

GL_INVALID_OPERATION

GLScene.OpenGL4

GL_INVALID_VALUE

GLScene.OpenGL4

GL_INVARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_INVARIANT_EXT

GLScene.OpenGL4

GL_INVARIANT_VALUE_EXT

GLScene.OpenGL4

GL_INVERSE_NV

GLScene.OpenGL4

GL_INVERSE_TRANSPOSE_NV

GLScene.OpenGL4

GL_INVERT

GLScene.OpenGL4

GL_INVERTED_SCREEN_W_REND

GLScene.OpenGL4

GL_IR_INSTRUMENT1_SGIX

GLScene.OpenGL4

GL_SGIX_ir_instrument1

GL_ISOLINES

GLScene.OpenGL4

GL_IS_PER_PATCH

GLScene.OpenGL4

GL_IS_ROW_MAJOR

GLScene.OpenGL4

GL_ITALIC_BIT_NV

GLScene.OpenGL4

GL_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_IUI_V2F_EXT

GLScene.OpenGL4

GL_EXT_index_array_formats

GL_IUI_V3F_EXT

GLScene.OpenGL4

GL_KEEP

GLScene.OpenGL4

StencilOp

GL_KHR_blend_equation_advanced

GLScene.OpenGL4

GL 4.5

GL_KHR_blend_equation_advanced_coherent

GLScene.OpenGL4

GL 4.5

GL_KHR_context_flush_control

GLScene.OpenGL4

GL 4.5

GL_KHR_debug

GLScene.OpenGL4

GL 4.3

GL_KHR_no_error

GLScene.OpenGL4

GL 4.6

GL_KHR_robustness

GLScene.OpenGL4

GL 4.5

GL_KHR_robust_buffer_access_behavior

GLScene.OpenGL4

GL 4.5

GL_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION

GLScene.OpenGL4

GL_LAST_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_LAST_VIDEO_CAPTURE_STATUS_NV

GLScene.OpenGL4

GL_LAYER_NV

GLScene.OpenGL4

GL_LAYER_PROVOKING_VERTEX

GLScene.OpenGL4

GL_LEFT

GLScene.OpenGL4

GL_LEQUAL

GLScene.OpenGL4

GL_LERP_ATI

GLScene.OpenGL4

GL_LESS

GLScene.OpenGL4

GL_LIGHT0

GLScene.OpenGL4

GL_LIGHT1

GLScene.OpenGL4

GL_LIGHT2

GLScene.OpenGL4

GL_LIGHT3

GLScene.OpenGL4

GL_LIGHT4

GLScene.OpenGL4

GL_LIGHT5

GLScene.OpenGL4

GL_LIGHT6

GLScene.OpenGL4

GL_LIGHT7

GLScene.OpenGL4

GL_LIGHTEN_KHR

GLScene.OpenGL4

GL_LIGHTING

GLScene.OpenGL4

GL_LIGHTING_BIT

GLScene.OpenGL4

GL_LIGHT_ENV_MODE_SGIX

GLScene.OpenGL4

GL_LIGHT_MODEL_AMBIENT

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL

GLScene.OpenGL4

GL_LIGHT_MODEL_COLOR_CONTROL_EXT

GLScene.OpenGL4

GL_EXT_separate_specular_color

GL_LIGHT_MODEL_LOCAL_VIEWER

GLScene.OpenGL4

GL_LIGHT_MODEL_SPECULAR_VECTOR_APPLE

GLScene.OpenGL4

GL_APPLE_specular_vector

GL_LIGHT_MODEL_TWO_SIDE

GLScene.OpenGL4

GL_LINE

GLScene.OpenGL4

GL_LINEAR

GLScene.OpenGL4

GL_LINEAR_ATTENUATION

GLScene.OpenGL4

GL_LINEAR_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_SGIX_clipmap

GL_LINEAR_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_LINEAR_DETAIL_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_DETAIL_SGIS

GLScene.OpenGL4

GL_LINEAR_MIPMAP_LINEAR

GLScene.OpenGL4

GL_LINEAR_MIPMAP_NEAREST

GLScene.OpenGL4

GL_LINEAR_SHARPEN_ALPHA_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_COLOR_SGIS

GLScene.OpenGL4

GL_LINEAR_SHARPEN_SGIS

GLScene.OpenGL4

GL_SGIS_sharpen_texture

GL_LINES

GLScene.OpenGL4

GL_LINES_ADJACENCY

GLScene.OpenGL4

GL_LINES_ADJACENCY_ARB

GLScene.OpenGL4

GL_ARB_geometry_shader4

GL_LINES_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_BIT

GLScene.OpenGL4

GL_LINE_LOOP

GLScene.OpenGL4

GL_LINE_RESET_TOKEN

GLScene.OpenGL4

GL_LINE_SMOOTH

GLScene.OpenGL4

GL_LINE_SMOOTH_HINT

GLScene.OpenGL4

GL_LINE_STIPPLE

GLScene.OpenGL4

GL_LINE_STIPPLE_PATTERN

GLScene.OpenGL4

GL_LINE_STIPPLE_REPEAT

GLScene.OpenGL4

GL_LINE_STRIP

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_LINE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_LINE_TOKEN

GLScene.OpenGL4

GL_LINE_TO_NV

GLScene.OpenGL4

GL_LINE_WIDTH

GLScene.OpenGL4

GL_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_LINK_STATUS

GLScene.OpenGL4

GL_LIST_BASE

GLScene.OpenGL4

GL_LIST_BIT

GLScene.OpenGL4

GL_LIST_INDEX

GLScene.OpenGL4

GL_LIST_MODE

GLScene.OpenGL4

GL_LIST_PRIORITY_SGIX

GLScene.OpenGL4

GL_SGIX_list_priority

GL_LOAD

GLScene.OpenGL4

GL_LOCAL_CONSTANT_DATATYPE_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_EXT

GLScene.OpenGL4

GL_LOCAL_CONSTANT_VALUE_EXT

GLScene.OpenGL4

GL_LOCAL_EXT

GLScene.OpenGL4

GL_LOCATION

GLScene.OpenGL4

GL_LOCATION_COMPONENT

GLScene.OpenGL4

GL_LOCATION_INDEX

GLScene.OpenGL4

GL_LOGIC_OP

GLScene.OpenGL4

GL_LOGIC_OP_MODE

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET

GLScene.OpenGL4

GL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

GL_LOWER_LEFT

GLScene.OpenGL4

GL_LOW_FLOAT

GLScene.OpenGL4

GL_LOW_INT

GLScene.OpenGL4

GL_LO_BIAS_NV

GLScene.OpenGL4

GL_LO_SCALE_NV

GLScene.OpenGL4

GL_LUMINANCE

GLScene.OpenGL4

GL_LUMINANCE12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA12_EXT

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE12_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE12_EXT

GLScene.OpenGL4

GL_LUMINANCE16

GLScene.OpenGL4

GL_LUMINANCE16F_ARB

GLScene.OpenGL4

GL_LUMINANCE16I_EXT

GLScene.OpenGL4

GL_LUMINANCE16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_ALPHA16_SNORM

GLScene.OpenGL4

GL_LUMINANCE16_EXT

GLScene.OpenGL4

GL_LUMINANCE16_SNORM

GLScene.OpenGL4

GL_LUMINANCE32F_ARB

GLScene.OpenGL4

GL_LUMINANCE32I_EXT

GLScene.OpenGL4

GL_LUMINANCE32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4

GLScene.OpenGL4

GL_LUMINANCE4_ALPHA4_EXT

GLScene.OpenGL4

GL_LUMINANCE4_EXT

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2

GLScene.OpenGL4

GL_LUMINANCE6_ALPHA2_EXT

GLScene.OpenGL4

GL_LUMINANCE8

GLScene.OpenGL4

GL_LUMINANCE8I_EXT

GLScene.OpenGL4

GL_LUMINANCE8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_ALPHA8_SNORM

GLScene.OpenGL4

GL_LUMINANCE8_EXT

GLScene.OpenGL4

GL_LUMINANCE8_SNORM

GLScene.OpenGL4

GL_LUMINANCE_ALPHA

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA16UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32F_ARB

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA32UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8I_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA8UI_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_ALPHA_SNORM

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT16_ATI

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_APPLE

GLScene.OpenGL4

GL_LUMINANCE_FLOAT32_ATI

GLScene.OpenGL4

GL_LUMINANCE_INTEGER_EXT

GLScene.OpenGL4

GL_LUMINANCE_SNORM

GLScene.OpenGL4

GL_MAD_ATI

GLScene.OpenGL4

GL_MAGNITUDE_BIAS_NV

GLScene.OpenGL4

GL_MAGNITUDE_SCALE_NV

GLScene.OpenGL4

GL_MAJOR_VERSION

GLScene.OpenGL4

GL_MANUAL_GENERATE_MIPMAP

GLScene.OpenGL4

GL_MAP1_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP1_COLOR_4

GLScene.OpenGL4

GL_MAP1_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP1_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP1_INDEX

GLScene.OpenGL4

GL_MAP1_NORMAL

GLScene.OpenGL4

GL_MAP1_TANGENT_EXT

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP1_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP1_VERTEX_3

GLScene.OpenGL4

GL_MAP1_VERTEX_4

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP1_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP2_BINORMAL_EXT

GLScene.OpenGL4

GL_MAP2_COLOR_4

GLScene.OpenGL4

GL_MAP2_GRID_DOMAIN

GLScene.OpenGL4

GL_MAP2_GRID_SEGMENTS

GLScene.OpenGL4

GL_MAP2_INDEX

GLScene.OpenGL4

GL_MAP2_NORMAL

GLScene.OpenGL4

GL_MAP2_TANGENT_EXT

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_1

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_2

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_3

GLScene.OpenGL4

GL_MAP2_TEXTURE_COORD_4

GLScene.OpenGL4

GL_MAP2_VERTEX_3

GLScene.OpenGL4

GL_MAP2_VERTEX_4

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB0_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB10_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB11_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB12_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB13_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB14_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB15_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB1_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB2_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB3_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB4_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB5_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB6_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB7_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB8_4_NV

GLScene.OpenGL4

GL_MAP2_VERTEX_ATTRIB9_4_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_U_ORDER_NV

GLScene.OpenGL4

GL_MAP_ATTRIB_V_ORDER_NV

GLScene.OpenGL4

GL_MAP_COHERENT_BIT

GLScene.OpenGL4

GL_MAP_COLOR

GLScene.OpenGL4

GL_MAP_FLUSH_EXPLICIT_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_BUFFER_BIT

GLScene.OpenGL4

GL_MAP_INVALIDATE_RANGE_BIT

GLScene.OpenGL4

GL_MAP_PERSISTENT_BIT

GLScene.OpenGL4

GL_MAP_READ_BIT

GLScene.OpenGL4

GL_ARB_map_buffer_range

GL_MAP_STENCIL

GLScene.OpenGL4

GL_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAP_UNSYNCHRONIZED_BIT

GLScene.OpenGL4

GL_MAP_WRITE_BIT

GLScene.OpenGL4

GL_MATERIAL_SIDE_HINT_PGI

GLScene.OpenGL4

GL_MATRIX0_ARB

GLScene.OpenGL4

GL_MATRIX0_NV

GLScene.OpenGL4

GL_MATRIX10_ARB

GLScene.OpenGL4

GL_MATRIX11_ARB

GLScene.OpenGL4

GL_MATRIX12_ARB

GLScene.OpenGL4

GL_MATRIX13_ARB

GLScene.OpenGL4

GL_MATRIX14_ARB

GLScene.OpenGL4

GL_MATRIX15_ARB

GLScene.OpenGL4

GL_MATRIX16_ARB

GLScene.OpenGL4

GL_MATRIX17_ARB

GLScene.OpenGL4

GL_MATRIX18_ARB

GLScene.OpenGL4

GL_MATRIX19_ARB

GLScene.OpenGL4

GL_MATRIX1_ARB

GLScene.OpenGL4

GL_MATRIX1_NV

GLScene.OpenGL4

GL_MATRIX20_ARB

GLScene.OpenGL4

GL_MATRIX21_ARB

GLScene.OpenGL4

GL_MATRIX22_ARB

GLScene.OpenGL4

GL_MATRIX23_ARB

GLScene.OpenGL4

GL_MATRIX24_ARB

GLScene.OpenGL4

GL_MATRIX25_ARB

GLScene.OpenGL4

GL_MATRIX26_ARB

GLScene.OpenGL4

GL_MATRIX27_ARB

GLScene.OpenGL4

GL_MATRIX28_ARB

GLScene.OpenGL4

GL_MATRIX29_ARB

GLScene.OpenGL4

GL_MATRIX2_ARB

GLScene.OpenGL4

GL_MATRIX2_NV

GLScene.OpenGL4

GL_MATRIX30_ARB

GLScene.OpenGL4

GL_MATRIX31_ARB

GLScene.OpenGL4

GL_MATRIX3_ARB

GLScene.OpenGL4

GL_MATRIX3_NV

GLScene.OpenGL4

GL_MATRIX4_ARB

GLScene.OpenGL4

GL_MATRIX4_NV

GLScene.OpenGL4

GL_MATRIX5_ARB

GLScene.OpenGL4

GL_MATRIX5_NV

GLScene.OpenGL4

GL_MATRIX6_ARB

GLScene.OpenGL4

GL_MATRIX6_NV

GLScene.OpenGL4

GL_MATRIX7_ARB

GLScene.OpenGL4

GL_MATRIX7_NV

GLScene.OpenGL4

GL_MATRIX8_ARB

GLScene.OpenGL4

GL_MATRIX9_ARB

GLScene.OpenGL4

GL_MATRIX_EXT

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_MATRIX_INDEX_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_MATRIX_MODE

GLScene.OpenGL4

GL_MATRIX_PALETTE_ARB

GLScene.OpenGL4

GL_ARB_matrix_palette

GL_MATRIX_STRIDE

GLScene.OpenGL4

GL_MAT_AMBIENT_AND_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_AMBIENT_BIT_PGI

GLScene.OpenGL4

GL_MAT_COLOR_INDEXES_BIT_PGI

GLScene.OpenGL4

GL_MAT_DIFFUSE_BIT_PGI

GLScene.OpenGL4

GL_MAT_EMISSION_BIT_PGI

GLScene.OpenGL4

GL_MAT_SHININESS_BIT_PGI

GLScene.OpenGL4

GL_MAT_SPECULAR_BIT_PGI

GLScene.OpenGL4

GL_MAX

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_3D_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_4D_TEXTURE_SIZE_SGIS

GLScene.OpenGL4

GL_MAX_ACTIVE_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS

GLScene.OpenGL4

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT

GLScene.OpenGL4

GL_MAX_ASYNC_DRAW_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_HISTOGRAM_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_READ_PIXELS_SGIX

GLScene.OpenGL4

GL_MAX_ASYNC_TEX_IMAGE_SGIX

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_ATOMIC_COUNTER_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_MAX_CLIP_DISTANCES

GLScene.OpenGL4

GL_MAX_CLIP_PLANES

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS

GLScene.OpenGL4

GL_MAX_COLOR_ATTACHMENTS_EXT

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI

GLScene.OpenGL4

GL_MAX_COLOR_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMBINED_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMBINED_CLIP_AND_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_COMBINED_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_DIMENSIONS

GLScene.OpenGL4

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS

GLScene.OpenGL4

GL_MAX_COMBINED_IMAGE_UNITS_AND_FRAGMENT_OUTPUTS_EXT

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_OUTPUT_RESOURCES

GLScene.OpenGL4

GL_MAX_COMBINED_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_COMBINED_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_COMPUTE_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_FIXED_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_COMPUTE_LOCAL_INVOCATIONS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_SHARED_MEMORY_SIZE

GLScene.OpenGL4

GL_MAX_COMPUTE_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_COMPUTE_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_COMPUTE_VARIABLE_GROUP_INVOCATIONS_ARB

GLScene.OpenGL4

GL_ARB_compute_variable_group_size

GL_MAX_COMPUTE_VARIABLE_GROUP_SIZE_ARB

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_COUNT

GLScene.OpenGL4

GL_MAX_COMPUTE_WORK_GROUP_SIZE

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_HEIGHT_EXT

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH

GLScene.OpenGL4

GL_MAX_CONVOLUTION_WIDTH_EXT

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_CULL_DISTANCES

GLScene.OpenGL4

GL_MAX_DEBUG_GROUP_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES

GLScene.OpenGL4

GL_MAX_DEBUG_LOGGED_MESSAGES_AMD

GLScene.OpenGL4

GL_AMD_debug_output

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH

GLScene.OpenGL4

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB

GLScene.OpenGL4

GL_MAX_DEFORMATION_ORDER_SGIX

GLScene.OpenGL4

GL_MAX_DEPTH

GLScene.OpenGL4

GL_MAX_DEPTH_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_DRAW_BUFFERS_ARB

GLScene.OpenGL4

GL_ARB_draw_buffers

GL_MAX_DRAW_BUFFERS_ATI

GLScene.OpenGL4

GL_ATI_draw_buffers

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_EXT

GLScene.OpenGL4

GL_MAX_ELEMENTS_INDICES_WIN

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES

GLScene.OpenGL4

GL_MAX_ELEMENTS_VERTICES_EXT

GLScene.OpenGL4

GL_EXT_draw_range_elements

GL_MAX_ELEMENTS_VERTICES_WIN

GLScene.OpenGL4

WIN_draw_range_elements

GL_MAX_ELEMENT_INDEX

GLScene.OpenGL4

GL_MAX_EVAL_ORDER

GLScene.OpenGL4

GL_MAX_EXT

GLScene.OpenGL4

GL_MAX_FOG_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_FRAGMENT_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MAX_FRAGMENT_LIGHTS_SGIX

GLScene.OpenGL4

GL_MAX_FRAGMENT_PROGRAM_LOCAL_PARAMETERS_NV

GLScene.OpenGL4

GL_NV_fragment_program

GL_MAX_FRAGMENT_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_FRAGMENT_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_HEIGHT

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_LAYERS

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_SAMPLES

GLScene.OpenGL4

GL_MAX_FRAMEBUFFER_WIDTH

GLScene.OpenGL4

GL_MAX_FRAMEZOOM_FACTOR_SGIX

GLScene.OpenGL4

GL_MAX_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_GEOMETRY_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_PROGRAM_INVOCATIONS_NV

GLScene.OpenGL4

GL_NV_gpu_program5

GL_MAX_GEOMETRY_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_MAX_GEOMETRY_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_HEIGHT

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES

GLScene.OpenGL4

GL_MAX_IMAGE_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_IMAGE_UNITS_EXT

GLScene.OpenGL4

GL_EXT_shader_image_load_store

GL_MAX_INTEGER_SAMPLES

GLScene.OpenGL4

GL_MAX_LABEL_LENGTH

GLScene.OpenGL4

GL_MAX_LAYERS

GLScene.OpenGL4

GL_MAX_LIGHTS

GLScene.OpenGL4

GL_MAX_LIST_NESTING

GLScene.OpenGL4

GL_MAX_MAP_TESSELLATION_NV

GLScene.OpenGL4

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NAME_LENGTH

GLScene.OpenGL4

GL_MAX_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_MAX_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_OPTIMIZED_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_PALETTE_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PATCH_VERTICES

GLScene.OpenGL4

GL_MAX_PIXEL_MAP_TABLE

GLScene.OpenGL4

GL_MAX_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MAX_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_CALL_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_EXEC_INSTRUCTIONS_NV

GLScene.OpenGL4

GL_NV_fragment_program2 and GL_NV_vertex_program2_option

GL_MAX_PROGRAM_GENERIC_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_GENERIC_RESULTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_IF_DEPTH_NV

GLScene.OpenGL4

GL_NV_fragment_program2

GL_MAX_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_COUNT_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_LOOP_DEPTH_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRICES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_PARAMETER_BUFFER_BINDINGS_NV

GLScene.OpenGL4

GL_NV_parameter_buffer_object

GL_MAX_PROGRAM_PARAMETER_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_PATCH_ATTRIBS_NV

GLScene.OpenGL4

GL_NV_tessellation_program5

GL_MAX_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_NUM_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_SUBROUTINE_PARAMETERS_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_RATIONAL_EVAL_ORDER_NV

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT

GLScene.OpenGL4

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE

GLScene.OpenGL4

GL_MAX_RENDERBUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_SAMPLES

GLScene.OpenGL4

GL_MAX_SAMPLES_EXT

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS

GLScene.OpenGL4

GL_MAX_SAMPLE_MASK_WORDS_NV

GLScene.OpenGL4

GL_MAX_SERVER_WAIT_TIMEOUT

GLScene.OpenGL4

GL_ARB_sync

GL_MAX_SHADER_BUFFER_ADDRESS_NV

GLScene.OpenGL4

GL_MAX_SHADER_COMPILER_THREADS_ARB

GLScene.OpenGL4

GL_ARB_parallel_shader_compile

GL_MAX_SHADER_STORAGE_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_SHADER_STORAGE_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_SHININESS_NV

GLScene.OpenGL4

GL_NV_light_max_exponent

GL_MAX_SPARSE_3D_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_ARRAY_TEXTURE_LAYERS_ARB

GLScene.OpenGL4

GL_MAX_SPARSE_TEXTURE_SIZE_ARB

GLScene.OpenGL4

GL_MAX_SPOT_EXPONENT_NV

GLScene.OpenGL4

GL_MAX_SUBPIXEL_PRECISION_BIAS_BITS_NV

GLScene.OpenGL4

GL_MAX_SUBROUTINES

GLScene.OpenGL4

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_TESS_GEN_LEVEL

GLScene.OpenGL4

GL_MAX_TESS_PATCH_COMPONENTS

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_COORDS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TEXTURE_IMAGE_UNITS_NV

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_MAX_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_EXT_texture_lod_bias

GL_MAX_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_MAX_TEXTURE_SIZE

GLScene.OpenGL4

GL_MAX_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS

GLScene.OpenGL4

GL_MAX_TEXTURE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_TRACK_MATRICES_NV

GLScene.OpenGL4

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS

GLScene.OpenGL4

GL_ARB_transform_feedback3

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV

GLScene.OpenGL4

GL_MAX_UNIFORM_BLOCK_SIZE

GLScene.OpenGL4

GL_MAX_UNIFORM_BUFFER_BINDINGS

GLScene.OpenGL4

GL_MAX_UNIFORM_LOCATIONS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS

GLScene.OpenGL4

GL_MAX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS

GLScene.OpenGL4

GL_MAX_VARYING_FLOATS_ARB

GLScene.OpenGL4

GL_MAX_VARYING_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATOMIC_COUNTER_BUFFERS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIBS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_BINDINGS

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_MAX_VERTEX_ATTRIB_STRIDE

GLScene.OpenGL4

GL 4.4

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT

GLScene.OpenGL4

GL_EXT_bindable_uniform

GL_MAX_VERTEX_HINT_PGI

GLScene.OpenGL4

GL_MAX_VERTEX_IMAGE_UNIFORMS

GLScene.OpenGL4

GL_MAX_VERTEX_OUTPUT_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_STORAGE_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS

GLScene.OpenGL4

GL_MAX_VERTEX_STREAMS_ATI

GLScene.OpenGL4

GL_ATI_vertex_streams

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

GLScene.OpenGL4

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_BLOCKS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_UNIFORM_VECTORS

GLScene.OpenGL4

GL_MAX_VERTEX_UNITS_ARB

GLScene.OpenGL4

GL_ARB_vertex_blend

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB

GLScene.OpenGL4

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT

GLScene.OpenGL4

GL_MAX_VIEWPORTS

GLScene.OpenGL4

GL_ARB_vertex_attrib_64bit

GL_MAX_VIEWPORT_DIMS

GLScene.OpenGL4

GL_MAX_VIEWS_OVR

GLScene.OpenGL4

GL_MAX_WIDTH

GLScene.OpenGL4

GL_MEDIUM_FLOAT

GLScene.OpenGL4

GL_MEDIUM_INT

GLScene.OpenGL4

GL_MESA_resize_buffers

GLScene.OpenGL4

GL 4.6

GL_MESA_window_pos

GLScene.OpenGL4

GL 4.6

GL_MIN

GLScene.OpenGL4

GL_MINMAX

GLScene.OpenGL4

GL_MINMAX_EXT

GLScene.OpenGL4

GL_MINMAX_FORMAT

GLScene.OpenGL4

GL_MINMAX_FORMAT_EXT

GLScene.OpenGL4

GL_MINMAX_SINK

GLScene.OpenGL4

GL_MINMAX_SINK_EXT

GLScene.OpenGL4

GL_MINOR_VERSION

GLScene.OpenGL4

GL_MIN_EXT

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET

GLScene.OpenGL4

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET_NV

GLScene.OpenGL4

GL_MIN_MAP_BUFFER_ALIGNMENT

GLScene.OpenGL4

GL_ARB_map_buffer_alignment

GL_MIN_PROGRAM_TEXEL_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET

GLScene.OpenGL4

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

GLScene.OpenGL4

GL_ARB_texture_gather

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_NV

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE

GLScene.OpenGL4

GL_MIN_SAMPLE_SHADING_VALUE_ARB

GLScene.OpenGL4

GL_MIN_SPARSE_LEVEL_ARB

GLScene.OpenGL4

GL_MIPMAP

GLScene.OpenGL4

GL_MIRRORED_REPEAT

GLScene.OpenGL4

GL_MIRRORED_REPEAT_ARB

GLScene.OpenGL4

GL_ARB_texture_mirrored_repeat

GL_MIRRORED_REPEAT_IBM

GLScene.OpenGL4

GL_IBM_texture_mirrored_repeat

GL_MIRROR_CLAMP_ATI

GLScene.OpenGL4

GL_ATI_texture_mirror_once

GL_MIRROR_CLAMP_EXT

GLScene.OpenGL4

GL_EXT_texture_mirror_clamp

GL_MIRROR_CLAMP_TO_BORDER_EXT

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_ATI

GLScene.OpenGL4

GL_MIRROR_CLAMP_TO_EDGE_EXT

GLScene.OpenGL4

GL_MITER_REVERT_NV

GLScene.OpenGL4

GL_MITER_TRUNCATE_NV

GLScene.OpenGL4

GL_MODELVIEW

GLScene.OpenGL4

GL_MODELVIEW0_ARB

GLScene.OpenGL4

GL_MODELVIEW0_EXT

GLScene.OpenGL4

GL_MODELVIEW0_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW0_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_EXT_vertex_weighting

GL_MODELVIEW10_ARB

GLScene.OpenGL4

GL_MODELVIEW11_ARB

GLScene.OpenGL4

GL_MODELVIEW12_ARB

GLScene.OpenGL4

GL_MODELVIEW13_ARB

GLScene.OpenGL4

GL_MODELVIEW14_ARB

GLScene.OpenGL4

GL_MODELVIEW15_ARB

GLScene.OpenGL4

GL_MODELVIEW16_ARB

GLScene.OpenGL4

GL_MODELVIEW17_ARB

GLScene.OpenGL4

GL_MODELVIEW18_ARB

GLScene.OpenGL4

GL_MODELVIEW19_ARB

GLScene.OpenGL4

GL_MODELVIEW1_ARB

GLScene.OpenGL4

GL_MODELVIEW1_EXT

GLScene.OpenGL4

GL_MODELVIEW1_MATRIX_EXT

GLScene.OpenGL4

GL_MODELVIEW1_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_MODELVIEW20_ARB

GLScene.OpenGL4

GL_MODELVIEW21_ARB

GLScene.OpenGL4

GL_MODELVIEW22_ARB

GLScene.OpenGL4

GL_MODELVIEW23_ARB

GLScene.OpenGL4

GL_MODELVIEW24_ARB

GLScene.OpenGL4

GL_MODELVIEW25_ARB

GLScene.OpenGL4

GL_MODELVIEW26_ARB

GLScene.OpenGL4

GL_MODELVIEW27_ARB

GLScene.OpenGL4

GL_MODELVIEW28_ARB

GLScene.OpenGL4

GL_MODELVIEW29_ARB

GLScene.OpenGL4

GL_MODELVIEW2_ARB

GLScene.OpenGL4

GL_MODELVIEW30_ARB

GLScene.OpenGL4

GL_MODELVIEW31_ARB

GLScene.OpenGL4

GL_MODELVIEW3_ARB

GLScene.OpenGL4

GL_MODELVIEW4_ARB

GLScene.OpenGL4

GL_MODELVIEW5_ARB

GLScene.OpenGL4

GL_MODELVIEW6_ARB

GLScene.OpenGL4

GL_MODELVIEW7_ARB

GLScene.OpenGL4

GL_MODELVIEW8_ARB

GLScene.OpenGL4

GL_MODELVIEW9_ARB

GLScene.OpenGL4

GL_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_MODELVIEW_PROJECTION_NV

GLScene.OpenGL4

GL_MODELVIEW_STACK_DEPTH

GLScene.OpenGL4

GL_MODULATE

GLScene.OpenGL4

GL_MODULATE_ADD_ATI

GLScene.OpenGL4

GL_ATI_texture_env_combine3

GL_MODULATE_SIGNED_ADD_ATI

GLScene.OpenGL4

GL_MODULATE_SUBTRACT_ATI

GLScene.OpenGL4

GL_MOVE_TO_CONTINUES_NV

GLScene.OpenGL4

GL_MOVE_TO_NV

GLScene.OpenGL4

GL_MOVE_TO_RESETS_NV

GLScene.OpenGL4

GL_MOV_ATI

GLScene.OpenGL4

GL_MULT

GLScene.OpenGL4

GL_MULTIPLY_KHR

GLScene.OpenGL4

GL_KHR_blend_equation_advanced

GL_MULTISAMPLE

GLScene.OpenGL4

GL_MULTISAMPLE_3DFX

GLScene.OpenGL4

GL_3DFX_multisample

GL_MULTISAMPLE_ARB

GLScene.OpenGL4

GL_ARB_multisample

GL_MULTISAMPLE_BIT

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_3DFX

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_BIT_EXT

GLScene.OpenGL4

GL_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_EXT_multisample

GL_MULTISAMPLE_FILTER_HINT_NV

GLScene.OpenGL4

GL_NV_multisample_filter_hint

GL_MULTISAMPLE_LINE_WIDTH_GRANULARITY_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_LINE_WIDTH_RANGE_ARB

GLScene.OpenGL4

GL_MULTISAMPLE_SGIS

GLScene.OpenGL4

GL_SGIS_multisample

GL_MULTI_HULLS_NV

GLScene.OpenGL4

GL_MUL_ATI

GLScene.OpenGL4

GL_MVP_MATRIX_EXT

GLScene.OpenGL4

GL_N3F_V3F

GLScene.OpenGL4

GL_NAMED_STRING_LENGTH_ARB

GLScene.OpenGL4

GL_NAMED_STRING_TYPE_ARB

GLScene.OpenGL4

GL_NAME_LENGTH

GLScene.OpenGL4

GL_NAME_STACK_DEPTH

GLScene.OpenGL4

GL_NAND

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_BEGIN_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_END_HINT_PGI

GLScene.OpenGL4

GL_NATIVE_GRAPHICS_HANDLE_PGI

GLScene.OpenGL4

GL_NEAREST

GLScene.OpenGL4

TextureMagFilter

GL_NEAREST_CLIPMAP_LINEAR_SGIX

GLScene.OpenGL4

GL_NEAREST_CLIPMAP_NEAREST_SGIX

GLScene.OpenGL4

GL_NEAREST_MIPMAP_LINEAR

GLScene.OpenGL4

GL_NEAREST_MIPMAP_NEAREST

GLScene.OpenGL4

TextureMinFilter

GL_NEGATE_BIT_ATI

GLScene.OpenGL4

GL_NEGATIVE_ONE_EXT

GLScene.OpenGL4

GL_NEGATIVE_ONE_TO_ONE

GLScene.OpenGL4

GL_NEGATIVE_W_EXT

GLScene.OpenGL4

GL_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_NEVER

GLScene.OpenGL4

AlphaFunction

GL_NEXT_BUFFER_NV

GLScene.OpenGL4

GL_NEXT_VIDEO_CAPTURE_BUFFER_STATUS_NV

GLScene.OpenGL4

GL_NICEST

GLScene.OpenGL4

GL_NONE

GLScene.OpenGL4

DrawBufferMode

GL_NOOP

GLScene.OpenGL4

GL_NOR

GLScene.OpenGL4

GL_NORMALIZE

GLScene.OpenGL4

GL_NORMALIZED_RANGE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY

GLScene.OpenGL4

GL_NORMAL_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_NORMAL_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_NORMAL_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER

GLScene.OpenGL4

GL_NORMAL_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE

GLScene.OpenGL4

GL_NORMAL_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE

GLScene.OpenGL4

GL_NORMAL_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_NORMAL_BIT_PGI

GLScene.OpenGL4

GL_NORMAL_MAP

GLScene.OpenGL4

GL_NORMAL_MAP_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map

GL_NORMAL_MAP_EXT

GLScene.OpenGL4

GL_EXT_texture_cube_map

GL_NORMAL_MAP_NV

GLScene.OpenGL4

GL_NV_texgen_reflection

GL_NOTEQUAL

GLScene.OpenGL4

GL_NO_ERROR

GLScene.OpenGL4

ErrorCode

GL_NO_RESET_NOTIFICATION

GLScene.OpenGL4

GL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

GL_NUM_ACTIVE_VARIABLES

GLScene.OpenGL4

GL_NUM_COMPATIBLE_SUBROUTINES

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS

GLScene.OpenGL4

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB

GLScene.OpenGL4

GL_NUM_EXTENSIONS

GLScene.OpenGL4

GL_NUM_FILL_STREAMS_NV

GLScene.OpenGL4

GL_NUM_FRAGMENT_CONSTANTS_ATI

GLScene.OpenGL4

GL_NUM_FRAGMENT_REGISTERS_ATI

GLScene.OpenGL4

GL_NUM_GENERAL_COMBINERS_NV

GLScene.OpenGL4

GL_NUM_INPUT_INTERPOLATOR_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_PER_PASS_ATI

GLScene.OpenGL4

GL_NUM_INSTRUCTIONS_TOTAL_ATI

GLScene.OpenGL4

GL_NUM_LOOPBACK_COMPONENTS_ATI

GLScene.OpenGL4

GL_NUM_PASSES_ATI

GLScene.OpenGL4

GL_NUM_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SAMPLE_COUNTS

GLScene.OpenGL4

GL_ARB_internalformat_query

GL_NUM_SHADER_BINARY_FORMATS

GLScene.OpenGL4

GL_NUM_SHADING_LANGUAGE_VERSIONS

GLScene.OpenGL4

GL_VERSION_4_1 GL_VERSION_4_2 GL_VERSION_4_3

GL_NUM_SPARSE_LEVELS_ARB

GLScene.OpenGL4

GL_NUM_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_NUM_VIDEO_CAPTURE_STREAMS_NV

GLScene.OpenGL4

GL_NUM_VIRTUAL_PAGE_SIZES_ARB

GLScene.OpenGL4

GL_NV_bindless_texture

GLScene.OpenGL4

GL 4.3

GL_NV_blend_square

GLScene.OpenGL4

GL 4.6

GL_NV_conditional_render

GLScene.OpenGL4

GL 4.6

GL_NV_conservative_raster

GLScene.OpenGL4

GL 4.6

GL_NV_conservative_raster_dilate

GLScene.OpenGL4

GL 4.6

GL_NV_copy_depth_to_color

GLScene.OpenGL4

GL 4.6

GL_NV_copy_image

GLScene.OpenGL4

GL 4.6

GL_NV_depth_buffer_float

GLScene.OpenGL4

GL 4.6

GL_NV_depth_clamp

GLScene.OpenGL4

GL 4.6

GL_NV_evaluators

GLScene.OpenGL4

GL 4.6

GL_NV_explicit_multisample

GLScene.OpenGL4

GL 4.6

GL_NV_fence

GLScene.OpenGL4

GL 4.6

GL_NV_float_buffer

GLScene.OpenGL4

GL 4.6

GL_NV_fog_distance

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program2

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program4

GLScene.OpenGL4

GL 4.6

GL_NV_fragment_program_option

GLScene.OpenGL4

GL 4.6

GL_NV_framebuffer_multisample_coverage

GLScene.OpenGL4

GL 4.6

GL_NV_geometry_program4

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_program4

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_program5

GLScene.OpenGL4

GL 4.6

GL_NV_gpu_shader5

GLScene.OpenGL4

GL 4.6

GL_NV_half_float

GLScene.OpenGL4

GL 4.6

GL_NV_light_max_exponent

GLScene.OpenGL4

GL 4.6

GL_NV_multisample_coverage

GLScene.OpenGL4

GL 4.6

GL_NV_multisample_filter_hint

GLScene.OpenGL4

GL 4.6

GL_NV_occlusion_query

GLScene.OpenGL4

GL 4.6

GL_NV_packed_depth_stencil

GLScene.OpenGL4

GL 4.6

GL_NV_parameter_buffer_object

GLScene.OpenGL4

GL 4.6

GL_NV_parameter_buffer_object2

GLScene.OpenGL4

GL 4.6

GL_NV_path_rendering

GLScene.OpenGL4

GL 4.3

GL_NV_pixel_data_range

GLScene.OpenGL4

GL 4.6

GL_NV_point_sprite

GLScene.OpenGL4

GL 4.6

GL_NV_present_video

GLScene.OpenGL4

GL 4.6

GL_NV_primitive_restart

GLScene.OpenGL4

GL 4.6

GL_NV_register_combiners

GLScene.OpenGL4

GL 4.6

GL_NV_register_combiners2

GLScene.OpenGL4

GL 4.6

GL_NV_shader_atomic_float

GLScene.OpenGL4

GL 4.3

GL_NV_shader_buffer_load

GLScene.OpenGL4

GL 4.6

GL_NV_shader_buffer_store

GLScene.OpenGL4

GL 4.6

GL_NV_tessellation_program5

GLScene.OpenGL4

GL 4.6

GL_NV_texgen_emboss

GLScene.OpenGL4

GL 4.6

GL_NV_texgen_reflection

GLScene.OpenGL4

GL 4.6

GL_NV_texture_barrier

GLScene.OpenGL4

GL 4.6

GL_NV_texture_compression_vtc

GLScene.OpenGL4

GL 4.6

GL_NV_texture_env_combine4

GLScene.OpenGL4

GL 4.6

GL_NV_texture_expand_normal

GLScene.OpenGL4

GL 4.6

GL_NV_texture_rectangle

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader2

GLScene.OpenGL4

GL 4.6

GL_NV_texture_shader3

GLScene.OpenGL4

GL 4.6

GL_NV_transform_feedback

GLScene.OpenGL4

GL 4.6

GL_NV_transform_feedback2

GLScene.OpenGL4

GL 4.6

GL_NV_vdpau_interop

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_array_range

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_array_range2

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_attrib_integer_64bit

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_buffer_unified_memory

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program1_1

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program2

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program2_option

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program3

GLScene.OpenGL4

GL 4.6

GL_NV_vertex_program4

GLScene.OpenGL4

GL 4.6

GL_NV_video_capture

GLScene.OpenGL4

GL 4.6

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORMS_ARB

GLScene.OpenGL4

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_ATTACHED_OBJECTS_ARB

GLScene.OpenGL4

GL_OBJECT_BUFFER_SIZE_ATI

GLScene.OpenGL4

GL_OBJECT_BUFFER_USAGE_ATI

GLScene.OpenGL4

GL_OBJECT_COMPILE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DELETE_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_DISTANCE_TO_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_INFO_LOG_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_LINEAR

GLScene.OpenGL4

GL_OBJECT_LINE_SGIS

GLScene.OpenGL4

GL_OBJECT_LINK_STATUS_ARB

GLScene.OpenGL4

GL_OBJECT_PLANE

GLScene.OpenGL4

GL_OBJECT_POINT_SGIS

GLScene.OpenGL4

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB

GLScene.OpenGL4

GL_OBJECT_SUBTYPE_ARB

GLScene.OpenGL4

GL_OBJECT_TYPE

GLScene.OpenGL4

GL_OBJECT_TYPE_ARB

GLScene.OpenGL4

GL_OBJECT_VALIDATE_STATUS_ARB

GLScene.OpenGL4

GL_OCCLUSION_TEST_HP

GLScene.OpenGL4

GL_HP_occlusion_test

GL_OCCLUSION_TEST_RESULT_HP

GLScene.OpenGL4

GL_OFFSET

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV

GLScene.OpenGL4

GL_NV_texture_shader3

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_2D_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_BIAS_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_MATRIX_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_shader

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV

GLScene.OpenGL4

GL_OFFSET_TEXTURE_SCALE_NV

GLScene.OpenGL4

GL_OML_interlace

GLScene.OpenGL4

GL 4.6

GL_OML_resample

GLScene.OpenGL4

GL 4.6

GL_OML_subsample

GLScene.OpenGL4

GL 4.6

GL_ONE

GLScene.OpenGL4

GL_ONE_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_ALPHA_EXT

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_CONSTANT_COLOR_EXT

GLScene.OpenGL4

GL_ONE_MINUS_DST_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_DST_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC1_COLOR

GLScene.OpenGL4

GL_ONE_MINUS_SRC_ALPHA

GLScene.OpenGL4

GL_ONE_MINUS_SRC_COLOR

GLScene.OpenGL4

GL_OPERAND0_ALPHA

GLScene.OpenGL4

GL_OPERAND0_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND0_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND0_RGB

GLScene.OpenGL4

GL_OPERAND0_RGB_ARB

GLScene.OpenGL4

GL_OPERAND0_RGB_EXT

GLScene.OpenGL4

GL_OPERAND1_ALPHA

GLScene.OpenGL4

GL_OPERAND1_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND1_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND1_RGB

GLScene.OpenGL4

GL_OPERAND1_RGB_ARB

GLScene.OpenGL4

GL_OPERAND1_RGB_EXT

GLScene.OpenGL4

GL_OPERAND2_ALPHA

GLScene.OpenGL4

GL_OPERAND2_ALPHA_ARB

GLScene.OpenGL4

GL_OPERAND2_ALPHA_EXT

GLScene.OpenGL4

GL_OPERAND2_RGB

GLScene.OpenGL4

GL_OPERAND2_RGB_ARB

GLScene.OpenGL4

GL_OPERAND2_RGB_EXT

GLScene.OpenGL4

GL_OPERAND3_ALPHA_NV

GLScene.OpenGL4

GL_OPERAND3_RGB_NV

GLScene.OpenGL4

GL_OP_ADD_EXT

GLScene.OpenGL4

GL_OP_CLAMP_EXT

GLScene.OpenGL4

GL_OP_CROSS_PRODUCT_EXT

GLScene.OpenGL4

GL_OP_DOT3_EXT

GLScene.OpenGL4

GL_OP_DOT4_EXT

GLScene.OpenGL4

GL_OP_EXP_BASE_2_EXT

GLScene.OpenGL4

GL_OP_FLOOR_EXT

GLScene.OpenGL4

GL_OP_FRAC_EXT

GLScene.OpenGL4

GL_OP_INDEX_EXT

GLScene.OpenGL4

GL_OP_LOG_BASE_2_EXT

GLScene.OpenGL4

GL_OP_MADD_EXT

GLScene.OpenGL4

GL_OP_MAX_EXT

GLScene.OpenGL4

GL_OP_MIN_EXT

GLScene.OpenGL4

GL_OP_MOV_EXT

GLScene.OpenGL4

GL_OP_MULTIPLY_MATRIX_EXT

GLScene.OpenGL4

GL_OP_MUL_EXT

GLScene.OpenGL4

GL_OP_NEGATE_EXT

GLScene.OpenGL4

GL_OP_POWER_EXT

GLScene.OpenGL4

GL_OP_RECIP_EXT

GLScene.OpenGL4

GL_OP_RECIP_SQRT_EXT

GLScene.OpenGL4

GL_OP_ROUND_EXT

GLScene.OpenGL4

GL_OP_SET_GE_EXT

GLScene.OpenGL4

GL_OP_SET_LT_EXT

GLScene.OpenGL4

GL_OP_SUB_EXT

GLScene.OpenGL4

GL_OR

GLScene.OpenGL4

GL_ORDER

GLScene.OpenGL4

GL_OR_INVERTED

GLScene.OpenGL4

GL_OR_REVERSE

GLScene.OpenGL4

GL_OUTPUT_COLOR0_EXT

GLScene.OpenGL4

GL_OUTPUT_COLOR1_EXT

GLScene.OpenGL4

GL_OUTPUT_FOG_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD0_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD10_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD11_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD12_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD13_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD14_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD15_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD16_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD17_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD18_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD19_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD1_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD20_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD21_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD22_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD23_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD24_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD25_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD26_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD27_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD28_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD29_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD2_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD30_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD31_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD3_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD4_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD5_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD6_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD7_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD8_EXT

GLScene.OpenGL4

GL_OUTPUT_TEXTURE_COORD9_EXT

GLScene.OpenGL4

GL_OUTPUT_VERTEX_EXT

GLScene.OpenGL4

GL_OUT_OF_MEMORY

GLScene.OpenGL4

GL_OVERLAY_KHR

GLScene.OpenGL4

GL_OVR_multiview

GLScene.OpenGL4

GL 4.6

GL_OVR_multiview2

GLScene.OpenGL4

GL 4.6

GL_PACK_ALIGNMENT

GLScene.OpenGL4

GL_PACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_PACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_PACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_PACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_PACK_LSB_FIRST

GLScene.OpenGL4

GL_PACK_RESAMPLE_OML

GLScene.OpenGL4

GL_OML_resample

GL_PACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_SGIX_resample

GL_PACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_APPLE_row_bytes

GL_PACK_ROW_LENGTH

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES

GLScene.OpenGL4

GL_PACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_EXT_texture3D

GL_PACK_SKIP_PIXELS

GLScene.OpenGL4

GL_PACK_SKIP_ROWS

GLScene.OpenGL4

GL_PACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_SGIS_texture4D

GL_PACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_SGIX_subsample

GL_PACK_SWAP_BYTES

GLScene.OpenGL4

GL_PARALLEL_ARRAYS_INTEL

GLScene.OpenGL4

GL_INTEL_parallel_arrays

GL_PARAMETER_BUFFER

GLScene.OpenGL4

GL_PARAMETER_BUFFER_BINDING

GLScene.OpenGL4

GL_PARTIAL_SUCCESS_NV

GLScene.OpenGL4

GL_PASS_THROUGH_NV

GLScene.OpenGL4

GL_PASS_THROUGH_TOKEN

GLScene.OpenGL4

GL_PATCHES

GLScene.OpenGL4

GL_ARB_tessellation_shader

GL_PATCH_DEFAULT_INNER_LEVEL

GLScene.OpenGL4

GL_PATCH_DEFAULT_OUTER_LEVEL

GLScene.OpenGL4

GL_PATCH_VERTICES

GLScene.OpenGL4

GL_PATH_CLIENT_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COMMAND_COUNT_NV

GLScene.OpenGL4

GL_PATH_COMPUTED_LENGTH_NV

GLScene.OpenGL4

GL_PATH_COORD_COUNT_NV

GLScene.OpenGL4

GL_PATH_COVER_DEPTH_FUNC_NV

GLScene.OpenGL4

GL_PATH_DASH_ARRAY_COUNT_NV

GLScene.OpenGL4

GL_PATH_DASH_CAPS_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_NV

GLScene.OpenGL4

GL_PATH_DASH_OFFSET_RESET_NV

GLScene.OpenGL4

GL_PATH_END_CAPS_NV

GLScene.OpenGL4

GL_PATH_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PATH_FILL_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_FILL_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_FILL_MASK_NV

GLScene.OpenGL4

GL_PATH_FILL_MODE_NV

GLScene.OpenGL4

GL_PATH_FOG_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_FORMAT_PS_NV

GLScene.OpenGL4

GL_PATH_FORMAT_SVG_NV

GLScene.OpenGL4

(4.3) GL_NV_path_rendering

GL_PATH_GEN_COEFF_NV

GLScene.OpenGL4

GL_PATH_GEN_COLOR_FORMAT_NV

GLScene.OpenGL4

GL_PATH_GEN_COMPONENTS_NV

GLScene.OpenGL4

GL_PATH_GEN_MODE_NV

GLScene.OpenGL4

GL_PATH_INITIAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_INITIAL_END_CAP_NV

GLScene.OpenGL4

GL_PATH_JOIN_STYLE_NV

GLScene.OpenGL4

GL_PATH_MITER_LIMIT_NV

GLScene.OpenGL4

GL_PATH_OBJECT_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_SAMPLE_QUALITY_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV

GLScene.OpenGL4

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV

GLScene.OpenGL4

GL_PATH_STENCIL_FUNC_NV

GLScene.OpenGL4

GL_PATH_STENCIL_REF_NV

GLScene.OpenGL4

GL_PATH_STENCIL_VALUE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUNDING_BOX_NV

GLScene.OpenGL4

GL_PATH_STROKE_BOUND_NV

GLScene.OpenGL4

GL_PATH_STROKE_COVER_MODE_NV

GLScene.OpenGL4

GL_PATH_STROKE_MASK_NV

GLScene.OpenGL4

GL_PATH_STROKE_OVERSAMPLE_COUNT_NV

GLScene.OpenGL4

GL_PATH_STROKE_WIDTH_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_DASH_CAP_NV

GLScene.OpenGL4

GL_PATH_TERMINAL_END_CAP_NV

GLScene.OpenGL4

GL_PERCENTAGE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_AVAILABLE_AMD

GLScene.OpenGL4

GL_PERFMON_RESULT_SIZE_AMD

GLScene.OpenGL4

GL_PERFORMANCE_MONITOR_AMD

GLScene.OpenGL4

GL_PERSPECTIVE_CORRECTION_HINT

GLScene.OpenGL4

GL_PERTURB_EXT

GLScene.OpenGL4

GL_EXT_texture_perturb_normal

GL_PER_STAGE_CONSTANTS_NV

GLScene.OpenGL4

GL_NV_register_combiners2

GL_PGI_misc_hints

GLScene.OpenGL4

GL 4.6

GL_PGI_vertex_hints

GLScene.OpenGL4

GL 4.6

GL_PHONG_HINT_WIN

GLScene.OpenGL4

GL_PHONG_WIN

GLScene.OpenGL4

GL_WIN_phong_shading

GL_PIXEL_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_PIXEL_BUFFER_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_PIXEL_COUNTER_BITS_NV

GLScene.OpenGL4

GL_NV_occlusion_query

GL_PIXEL_COUNT_AVAILABLE_NV

GLScene.OpenGL4

GL_PIXEL_COUNT_NV

GLScene.OpenGL4

GL_PIXEL_CUBIC_WEIGHT_EXT

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_ALPHA_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_FRAGMENT_RGB_SOURCE_SGIS

GLScene.OpenGL4

GL_PIXEL_GROUP_COLOR_SGIS

GLScene.OpenGL4

GL_PIXEL_MAG_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_A_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_B_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_G_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_A_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_B_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_G_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_I_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_I_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R

GLScene.OpenGL4

GL_PIXEL_MAP_R_TO_R_SIZE

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S

GLScene.OpenGL4

GL_PIXEL_MAP_S_TO_S_SIZE

GLScene.OpenGL4

GL_PIXEL_MIN_FILTER_EXT

GLScene.OpenGL4

GL_PIXEL_MODE_BIT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER

GLScene.OpenGL4

GL_VERSION_2_1

GL_PIXEL_PACK_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_pixel_buffer_object

GL_PIXEL_PACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_PACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_pixel_buffer_object

GL_PIXEL_SUBSAMPLE_2424_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4242_SGIX

GLScene.OpenGL4

GL_PIXEL_SUBSAMPLE_4444_SGIX

GLScene.OpenGL4

GL_PIXEL_TEXTURE_SGIS

GLScene.OpenGL4

GL_SGIS_pixel_texture

GL_PIXEL_TEX_GEN_ALPHA_LS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_MS_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_NO_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_ALPHA_REPLACE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_MODE_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_CEILING_SGIX

GLScene.OpenGL4

GL_SGIX_impact_pixel_texture

GL_PIXEL_TEX_GEN_Q_FLOOR_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_Q_ROUND_SGIX

GLScene.OpenGL4

GL_PIXEL_TEX_GEN_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_texture

GL_PIXEL_TILE_BEST_ALIGNMENT_SGIX

GLScene.OpenGL4

GL_SGIX_pixel_tiles

GL_PIXEL_TILE_CACHE_INCREMENT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_CACHE_SIZE_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_DEPTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_GRID_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_HEIGHT_SGIX

GLScene.OpenGL4

GL_PIXEL_TILE_WIDTH_SGIX

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_EXT

GLScene.OpenGL4

GL_EXT_pixel_transform

GL_PIXEL_TRANSFORM_2D_MATRIX_EXT

GLScene.OpenGL4

GL_PIXEL_TRANSFORM_2D_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_PIXEL_UNPACK_BUFFER_EXT

GLScene.OpenGL4

GL_PN_TRIANGLES_ATI

GLScene.OpenGL4

GL_ATI_pn_triangles

GL_PN_TRIANGLES_NORMAL_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_NORMAL_MODE_QUADRATIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_CUBIC_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_POINT_MODE_LINEAR_ATI

GLScene.OpenGL4

GL_PN_TRIANGLES_TESSELATION_LEVEL_ATI

GLScene.OpenGL4

GL_POINT

GLScene.OpenGL4

PolygonMode

GL_POINTS

GLScene.OpenGL4

BeginMode

GL_POINT_BIT

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION

GLScene.OpenGL4

GL_POINT_DISTANCE_ATTENUATION_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_ARB

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_EXT

GLScene.OpenGL4

GL_POINT_FADE_THRESHOLD_SIZE_SGIS

GLScene.OpenGL4

GL_POINT_SIZE

GLScene.OpenGL4

GetPName

GL_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_POINT_SIZE_MAX

GLScene.OpenGL4

GL_POINT_SIZE_MAX_ARB

GLScene.OpenGL4

GL_POINT_SIZE_MAX_EXT

GLScene.OpenGL4

GL_POINT_SIZE_MAX_SGIS

GLScene.OpenGL4

GL_POINT_SIZE_MIN

GLScene.OpenGL4

GL_POINT_SIZE_MIN_ARB

GLScene.OpenGL4

GL_ARB_point_parameters

GL_POINT_SIZE_MIN_EXT

GLScene.OpenGL4

GL_EXT_point_parameters

GL_POINT_SIZE_MIN_SGIS

GLScene.OpenGL4

GL_SGIS_point_parameters

GL_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_POINT_SMOOTH

GLScene.OpenGL4

GL_POINT_SMOOTH_HINT

GLScene.OpenGL4

GL_POINT_SPRITE

GLScene.OpenGL4

GL_POINT_SPRITE_ARB

GLScene.OpenGL4

GL_ARB_point_sprite

GL_POINT_SPRITE_COORD_ORIGIN

GLScene.OpenGL4

GL_POINT_SPRITE_NV

GLScene.OpenGL4

GL_NV_point_sprite

GL_POINT_SPRITE_R_MODE_NV

GLScene.OpenGL4

GL_POINT_TOKEN

GLScene.OpenGL4

GL_POLYGON

GLScene.OpenGL4

GL_POLYGON_BIT

GLScene.OpenGL4

GL_POLYGON_MODE

GLScene.OpenGL4

GL_POLYGON_OFFSET_BIAS_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_CLAMP

GLScene.OpenGL4

GL_POLYGON_OFFSET_EXT

GLScene.OpenGL4

GL_EXT_polygon_offset

GL_POLYGON_OFFSET_FACTOR

GLScene.OpenGL4

GL_POLYGON_OFFSET_FACTOR_EXT

GLScene.OpenGL4

GL_POLYGON_OFFSET_FILL

GLScene.OpenGL4

GL_POLYGON_OFFSET_LINE

GLScene.OpenGL4

GL_POLYGON_OFFSET_POINT

GLScene.OpenGL4

GL_POLYGON_OFFSET_UNITS

GLScene.OpenGL4

GL_POLYGON_SMOOTH

GLScene.OpenGL4

GL_POLYGON_SMOOTH_HINT

GLScene.OpenGL4

GL_POLYGON_STIPPLE

GLScene.OpenGL4

GL_POLYGON_STIPPLE_BIT

GLScene.OpenGL4

GL_POLYGON_TOKEN

GLScene.OpenGL4

GL_POSITION

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_BIAS_SGI

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE

GLScene.OpenGL4

GL_POST_COLOR_MATRIX_RED_SCALE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_BLUE_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_GREEN_SCALE_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_BIAS_EXT

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE

GLScene.OpenGL4

GL_POST_CONVOLUTION_RED_SCALE_EXT

GLScene.OpenGL4

GL_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_scale_bias

GL_POST_TEXTURE_FILTER_SCALE_RANGE_SGIX

GLScene.OpenGL4

GL_POST_TEXTURE_FILTER_SCALE_SGIX

GLScene.OpenGL4

GL_PREFER_DOUBLEBUFFER_HINT_PGI

GLScene.OpenGL4

GL_PGI_misc_hints

GL_PRESENT_DURATION_NV

GLScene.OpenGL4

GL_PRESENT_TIME_NV

GLScene.OpenGL4

GL_PRESERVE_ATI

GLScene.OpenGL4

GL_PREVIOUS

GLScene.OpenGL4

GL_PREVIOUS_ARB

GLScene.OpenGL4

GL_PREVIOUS_EXT

GLScene.OpenGL4

GL_PREVIOUS_TEXTURE_INPUT_NV

GLScene.OpenGL4

GL_PRIMARY_COLOR

GLScene.OpenGL4

GL_PRIMARY_COLOR_ARB

GLScene.OpenGL4

GL_PRIMARY_COLOR_EXT

GLScene.OpenGL4

GL_PRIMARY_COLOR_NV

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_EXT

GLScene.OpenGL4

GL_PRIMITIVES_GENERATED_NV

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED

GLScene.OpenGL4

GL_PRIMITIVES_SUBMITTED_ARB

GLScene.OpenGL4

GL_PRIMITIVE_BOUNDING_BOX_ARB

GLScene.OpenGL4

GL_ARB_ES3_2_compatibility

GL_PRIMITIVE_ID_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FIXED_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_FOR_PATCHES_SUPPORTED

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_INDEX_NV

GLScene.OpenGL4

GL_PRIMITIVE_RESTART_NV

GLScene.OpenGL4

GL_NV_primitive_restart

GL_PROGRAM

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_PROGRAMMABLE_SAMPLE_LOCATION_TABLE_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_ATTRIB_COMPONENTS_NV

GLScene.OpenGL4

GL_NV_gpu_program4

GL_PROGRAM_BINARY_FORMATS

GLScene.OpenGL4

GL_PROGRAM_BINARY_LENGTH

GLScene.OpenGL4

GL_PROGRAM_BINARY_RETRIEVABLE_HINT

GLScene.OpenGL4

GL_ARB_get_program_binary

GL_PROGRAM_BINDING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_POSITION_NV

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_ERROR_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ARB

GLScene.OpenGL4

GL_PROGRAM_FORMAT_ASCII_ARB

GLScene.OpenGL4

GL_PROGRAM_INPUT

GLScene.OpenGL4

GL_PROGRAM_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_ARB

GLScene.OpenGL4

GL_PROGRAM_LENGTH_NV

GLScene.OpenGL4

GL_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_EXT_direct_state_access

GL_PROGRAM_MATRIX_STACK_DEPTH_EXT

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_ATTRIBS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_OBJECT_ARB

GLScene.OpenGL4

1.4 GL_ARB_shader_objects

GL_PROGRAM_OUTPUT

GLScene.OpenGL4

GL_PROGRAM_PARAMETERS_ARB

GLScene.OpenGL4

GL_PROGRAM_PARAMETER_NV

GLScene.OpenGL4

GL_PROGRAM_PIPELINE

GLScene.OpenGL4

GL_PROGRAM_PIPELINE_BINDING

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_PROGRAM_POINT_SIZE_EXT

GLScene.OpenGL4

GL_PROGRAM_RESIDENT_NV

GLScene.OpenGL4

GL_PROGRAM_RESULT_COMPONENTS_NV

GLScene.OpenGL4

GL_PROGRAM_SEPARABLE

GLScene.OpenGL4

GL_PROGRAM_STRING_ARB

GLScene.OpenGL4

GL_PROGRAM_STRING_NV

GLScene.OpenGL4

GL_PROGRAM_TARGET_NV

GLScene.OpenGL4

GL_PROGRAM_TEMPORARIES_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INDIRECTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_TEX_INSTRUCTIONS_ARB

GLScene.OpenGL4

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB

GLScene.OpenGL4

GL_PROJECTION

GLScene.OpenGL4

GL_PROJECTION_MATRIX

GLScene.OpenGL4

GL_PROJECTION_STACK_DEPTH

GLScene.OpenGL4

GL_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_PROVOKING_VERTEX

GLScene.OpenGL4

GL_PROVOKING_VERTEX_EXT

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_HISTOGRAM

GLScene.OpenGL4

GL_PROXY_HISTOGRAM_EXT

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE

GLScene.OpenGL4

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_POST_IMAGE_TRANSFORM_COLOR_TABLE_HP

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D

GLScene.OpenGL4

TextureTarget

GL_PROXY_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_1D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D

GLScene.OpenGL4

GL_PROXY_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_PROXY_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_PROXY_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_PURGEABLE_APPLE

GLScene.OpenGL4

GL_Q

GLScene.OpenGL4

GL_QUADRATIC_ATTENUATION

GLScene.OpenGL4

GL_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_QUADS

GLScene.OpenGL4

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

GLScene.OpenGL4

GL_ARB_provoking_vertex

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION_EXT

GLScene.OpenGL4

GL_EXT_provoking_vertex

GL_QUAD_ALPHA4_SGIS

GLScene.OpenGL4

GL_QUAD_ALPHA8_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY4_SGIS

GLScene.OpenGL4

GL_QUAD_INTENSITY8_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE4_SGIS

GLScene.OpenGL4

GL_QUAD_LUMINANCE8_SGIS

GLScene.OpenGL4

GL_QUAD_MESH_SUN

GLScene.OpenGL4

GL_SUN_mesh_array

GL_QUAD_STRIP

GLScene.OpenGL4

GL_QUAD_TEXTURE_SELECT_SGIS

GLScene.OpenGL4

GL_QUARTER_BIT_ATI

GLScene.OpenGL4

GL_QUERY

GLScene.OpenGL4

GL_QUERY_BUFFER

GLScene.OpenGL4

GL_QUERY_BUFFER_AMD

GLScene.OpenGL4

(4.3) GL_AMD_vertex_shader_viewport_index (4.3) GL_AMD_vertex_shader_layer (4.3) GL_NV_bindless_texture (4.3) GL_NV_shader_atomic_float (4.3) GL_AMD_query_buffer_object

GL_QUERY_BUFFER_BARRIER_BIT

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING

GLScene.OpenGL4

GL_QUERY_BUFFER_BINDING_AMD

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_BY_REGION_WAIT_NV

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS

GLScene.OpenGL4

GL_QUERY_COUNTER_BITS_ARB

GLScene.OpenGL4

GL_QUERY_NO_WAIT

GLScene.OpenGL4

GL_QUERY_NO_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_NO_WAIT_NV

GLScene.OpenGL4

GL_QUERY_OBJECT_AMD

GLScene.OpenGL4

GL_QUERY_RESULT

GLScene.OpenGL4

GL_QUERY_RESULT_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE

GLScene.OpenGL4

GL_QUERY_RESULT_AVAILABLE_ARB

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT

GLScene.OpenGL4

GL_QUERY_RESULT_NO_WAIT_AMD

GLScene.OpenGL4

GL_QUERY_TARGET

GLScene.OpenGL4

GL_QUERY_WAIT

GLScene.OpenGL4

GL_QUERY_WAIT_INVERTED

GLScene.OpenGL4

GL_QUERY_WAIT_NV

GLScene.OpenGL4

GL_NV_conditional_render

GL_R

GLScene.OpenGL4

GL_R11F_G11F_B10F

GLScene.OpenGL4

GL_R11F_G11F_B10F_EXT

GLScene.OpenGL4

GL_EXT_packed_float

GL_R16

GLScene.OpenGL4

GL_R16F

GLScene.OpenGL4

GL_R16I

GLScene.OpenGL4

GL_R16UI

GLScene.OpenGL4

GL_R16_SNORM

GLScene.OpenGL4

GL_R1UI_C3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_C4UB_V3F_SUN

GLScene.OpenGL4

GL_R1UI_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_C4F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_N3F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_T2F_V3F_SUN

GLScene.OpenGL4

GL_R1UI_V3F_SUN

GLScene.OpenGL4

GL_R32F

GLScene.OpenGL4

GL_R32I

GLScene.OpenGL4

GL_R32UI

GLScene.OpenGL4

GL_R3_G3_B2

GLScene.OpenGL4

PixelInternalFormat

GL_R8

GLScene.OpenGL4

GL_R8I

GLScene.OpenGL4

GL_R8UI

GLScene.OpenGL4

GL_R8_SNORM

GLScene.OpenGL4

GL_RASTERIZER_DISCARD

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_EXT

GLScene.OpenGL4

GL_RASTERIZER_DISCARD_NV

GLScene.OpenGL4

GL_RASTER_POSITION_UNCLIPPED_IBM

GLScene.OpenGL4

GL_IBM_rasterpos_clip

GL_READ_BUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_READ_FRAMEBUFFER_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_blit

GL_READ_ONLY

GLScene.OpenGL4

GL_READ_ONLY_ARB

GLScene.OpenGL4

GL_READ_PIXELS

GLScene.OpenGL4

GL_READ_PIXELS_FORMAT

GLScene.OpenGL4

GL_READ_PIXELS_TYPE

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_READ_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_READ_WRITE

GLScene.OpenGL4

GL_READ_WRITE_ARB

GLScene.OpenGL4

GL_RECLAIM_MEMORY_HINT_PGI

GLScene.OpenGL4

GL_RECT_NV

GLScene.OpenGL4

GL_RED

GLScene.OpenGL4

GL_REDUCE

GLScene.OpenGL4

GL_REDUCE_EXT

GLScene.OpenGL4

GL_RED_BIAS

GLScene.OpenGL4

GL_RED_BITS

GLScene.OpenGL4

GL_RED_BIT_ATI

GLScene.OpenGL4

GL_RED_INTEGER

GLScene.OpenGL4

GL_RED_INTEGER_EXT

GLScene.OpenGL4

GL_RED_MAX_CLAMP_INGR

GLScene.OpenGL4

GL_RED_MIN_CLAMP_INGR

GLScene.OpenGL4

GL_INGR_color_clamp

GL_RED_SCALE

GLScene.OpenGL4

GL_RED_SNORM

GLScene.OpenGL4

GL_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_REFERENCE_PLANE_EQUATION_SGIX

GLScene.OpenGL4

GL_REFERENCE_PLANE_SGIX

GLScene.OpenGL4

GL_SGIX_reference_plane

GL_REFLECTION_MAP

GLScene.OpenGL4

GL_REFLECTION_MAP_ARB

GLScene.OpenGL4

GL_REFLECTION_MAP_EXT

GLScene.OpenGL4

GL_REFLECTION_MAP_NV

GLScene.OpenGL4

GL_REGISTER_COMBINERS_NV

GLScene.OpenGL4

GL_NV_register_combiners

GL_REG_0_ATI

GLScene.OpenGL4

GL_REG_10_ATI

GLScene.OpenGL4

GL_REG_11_ATI

GLScene.OpenGL4

GL_REG_12_ATI

GLScene.OpenGL4

GL_REG_13_ATI

GLScene.OpenGL4

GL_REG_14_ATI

GLScene.OpenGL4

GL_REG_15_ATI

GLScene.OpenGL4

GL_REG_16_ATI

GLScene.OpenGL4

GL_REG_17_ATI

GLScene.OpenGL4

GL_REG_18_ATI

GLScene.OpenGL4

GL_REG_19_ATI

GLScene.OpenGL4

GL_REG_1_ATI

GLScene.OpenGL4

GL_REG_20_ATI

GLScene.OpenGL4

GL_REG_21_ATI

GLScene.OpenGL4

GL_REG_22_ATI

GLScene.OpenGL4

GL_REG_23_ATI

GLScene.OpenGL4

GL_REG_24_ATI

GLScene.OpenGL4

GL_REG_25_ATI

GLScene.OpenGL4

GL_REG_26_ATI

GLScene.OpenGL4

GL_REG_27_ATI

GLScene.OpenGL4

GL_REG_28_ATI

GLScene.OpenGL4

GL_REG_29_ATI

GLScene.OpenGL4

GL_REG_2_ATI

GLScene.OpenGL4

GL_REG_30_ATI

GLScene.OpenGL4

GL_REG_31_ATI

GLScene.OpenGL4

GL_REG_3_ATI

GLScene.OpenGL4

GL_REG_4_ATI

GLScene.OpenGL4

GL_REG_5_ATI

GLScene.OpenGL4

GL_REG_6_ATI

GLScene.OpenGL4

GL_REG_7_ATI

GLScene.OpenGL4

GL_REG_8_ATI

GLScene.OpenGL4

GL_REG_9_ATI

GLScene.OpenGL4

GL_RELATIVE_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_HORIZONTAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LARGE_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_LINE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_MOVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_RELATIVE_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_RELEASED_APPLE

GLScene.OpenGL4

GL_RENDER

GLScene.OpenGL4

GL_RENDERBUFFER

GLScene.OpenGL4

GL_RENDERBUFFER_ALPHA_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING

GLScene.OpenGL4

GL_RENDERBUFFER_BINDING_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_BLUE_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_RENDERBUFFER_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_framebuffer_multisample_coverage

GL_RENDERBUFFER_DEPTH_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_RENDERBUFFER_GREEN_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT

GLScene.OpenGL4

GL_RENDERBUFFER_HEIGHT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT

GLScene.OpenGL4

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT

GLScene.OpenGL4

GL_RENDERBUFFER_RED_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES

GLScene.OpenGL4

GL_RENDERBUFFER_SAMPLES_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample

GL_RENDERBUFFER_STENCIL_SIZE

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH

GLScene.OpenGL4

GL_RENDERBUFFER_WIDTH_EXT

GLScene.OpenGL4

GL_RENDERER

GLScene.OpenGL4

GL_RENDER_MODE

GLScene.OpenGL4

GL_REND_screen_coordinates

GLScene.OpenGL4

GL 4.6

GL_REPEAT

GLScene.OpenGL4

TextureWrapMode

GL_REPLACE

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_POINTER_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_STRIDE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_ARRAY_TYPE_SUN

GLScene.OpenGL4

GL_REPLACEMENT_CODE_SUN

GLScene.OpenGL4

GL_REPLACE_EXT

GLScene.OpenGL4

GL_REPLACE_MIDDLE_SUN

GLScene.OpenGL4

GL_REPLACE_OLDEST_SUN

GLScene.OpenGL4

GL_REPLACE_VALUE_AMD

GLScene.OpenGL4

GL_REPLICATE_BORDER

GLScene.OpenGL4

GL_REPLICATE_BORDER_HP

GLScene.OpenGL4

GL_RESAMPLE_AVERAGE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_OML

GLScene.OpenGL4

GL_RESAMPLE_DECIMATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_OML

GLScene.OpenGL4

GL_RESAMPLE_REPLICATE_SGIX

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_OML

GLScene.OpenGL4

GL_RESAMPLE_ZERO_FILL_SGIX

GLScene.OpenGL4

GL_RESCALE_NORMAL

GLScene.OpenGL4

GL_RESCALE_NORMAL_EXT

GLScene.OpenGL4

GL_EXT_rescale_normal

GL_RESET_NOTIFICATION_STRATEGY

GLScene.OpenGL4

GL_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

GL_RESTART_PATH_NV

GLScene.OpenGL4

GL_RESTART_SUN

GLScene.OpenGL4

GL_SUN_triangle_list

GL_RETAINED_APPLE

GLScene.OpenGL4

GL_RETURN

GLScene.OpenGL4

GL_RG

GLScene.OpenGL4

GL_ARB_texture_rg

GL_RG16

GLScene.OpenGL4

GL_RG16F

GLScene.OpenGL4

GL_RG16I

GLScene.OpenGL4

GL_RG16UI

GLScene.OpenGL4

GL_RG16_SNORM

GLScene.OpenGL4

GL_RG32F

GLScene.OpenGL4

GL_RG32I

GLScene.OpenGL4

GL_RG32UI

GLScene.OpenGL4

GL_RG8

GLScene.OpenGL4

GL_RG8I

GLScene.OpenGL4

GL_RG8UI

GLScene.OpenGL4

GL_RG8_SNORM

GLScene.OpenGL4

GL_RGB

GLScene.OpenGL4

GL_RGB10

GLScene.OpenGL4

GL_RGB10_A2

GLScene.OpenGL4

GL_RGB10_A2UI

GLScene.OpenGL4

GL_ARB_texture_rgb10_a2ui

GL_RGB10_A2_EXT

GLScene.OpenGL4

GL_RGB10_EXT

GLScene.OpenGL4

GL_RGB12

GLScene.OpenGL4

GL_RGB12_EXT

GLScene.OpenGL4

GL_RGB16

GLScene.OpenGL4

GL_RGB16F

GLScene.OpenGL4

GL_RGB16F_ARB

GLScene.OpenGL4

GL_RGB16I

GLScene.OpenGL4

GL_RGB16I_EXT

GLScene.OpenGL4

GL_RGB16UI

GLScene.OpenGL4

GL_RGB16UI_EXT

GLScene.OpenGL4

GL_RGB16_EXT

GLScene.OpenGL4

GL_RGB16_SNORM

GLScene.OpenGL4

GL_RGB2_EXT

GLScene.OpenGL4

GL_RGB32F

GLScene.OpenGL4

GL_RGB32F_ARB

GLScene.OpenGL4

GL_RGB32I

GLScene.OpenGL4

GL_RGB32I_EXT

GLScene.OpenGL4

GL_RGB32UI

GLScene.OpenGL4

GL_RGB32UI_EXT

GLScene.OpenGL4

GL_RGB4

GLScene.OpenGL4

GL_RGB4_EXT

GLScene.OpenGL4

GL_RGB4_S3TC

GLScene.OpenGL4

GL_RGB5

GLScene.OpenGL4

GL_RGB565

GLScene.OpenGL4

GL_RGB5_A1

GLScene.OpenGL4

GL_RGB5_A1_EXT

GLScene.OpenGL4

GL_RGB5_EXT

GLScene.OpenGL4

GL_RGB8

GLScene.OpenGL4

GL_RGB8I

GLScene.OpenGL4

GL_RGB8I_EXT

GLScene.OpenGL4

GL_RGB8UI

GLScene.OpenGL4

GL_RGB8UI_EXT

GLScene.OpenGL4

GL_RGB8_EXT

GLScene.OpenGL4

GL_RGB8_SNORM

GLScene.OpenGL4

GL_RGB9_E5

GLScene.OpenGL4

GL_RGB9_E5_EXT

GLScene.OpenGL4

GL_EXT_texture_shared_exponent

GL_RGBA

GLScene.OpenGL4

GL_RGBA12

GLScene.OpenGL4

GL_RGBA12_EXT

GLScene.OpenGL4

GL_RGBA16

GLScene.OpenGL4

GL_RGBA16F

GLScene.OpenGL4

GL_RGBA16F_ARB

GLScene.OpenGL4

GL_RGBA16I

GLScene.OpenGL4

GL_RGBA16I_EXT

GLScene.OpenGL4

GL_RGBA16UI

GLScene.OpenGL4

GL_RGBA16UI_EXT

GLScene.OpenGL4

GL_RGBA16_EXT

GLScene.OpenGL4

GL_RGBA16_SNORM

GLScene.OpenGL4

GL_RGBA2

GLScene.OpenGL4

GL_RGBA2_EXT

GLScene.OpenGL4

GL_RGBA32F

GLScene.OpenGL4

GL_RGBA32F_ARB

GLScene.OpenGL4

GL_RGBA32I

GLScene.OpenGL4

GL_RGBA32I_EXT

GLScene.OpenGL4

GL_RGBA32UI

GLScene.OpenGL4

GL_RGBA32UI_EXT

GLScene.OpenGL4

GL_RGBA4

GLScene.OpenGL4

GL_RGBA4_EXT

GLScene.OpenGL4

GL_RGBA4_S3TC

GLScene.OpenGL4

GL_RGBA8

GLScene.OpenGL4

GL_RGBA8I

GLScene.OpenGL4

GL_RGBA8I_EXT

GLScene.OpenGL4

GL_RGBA8UI

GLScene.OpenGL4

GL_RGBA8UI_EXT

GLScene.OpenGL4

GL_RGBA8_EXT

GLScene.OpenGL4

GL_RGBA8_SNORM

GLScene.OpenGL4

GL_RGBA_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT16_ATI

GLScene.OpenGL4

GL_RGBA_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGBA_FLOAT32_ATI

GLScene.OpenGL4

GL_ATI_texture_float

GL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

GL_ARB_color_buffer_float

GL_RGBA_INTEGER

GLScene.OpenGL4

GL_RGBA_INTEGER_EXT

GLScene.OpenGL4

GL_RGBA_INTEGER_MODE_EXT

GLScene.OpenGL4

GL_EXT_texture_integer

GL_RGBA_MODE

GLScene.OpenGL4

GL_RGBA_S3TC

GLScene.OpenGL4

GL_RGBA_SNORM

GLScene.OpenGL4

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV

GLScene.OpenGL4

GL_RGB_FLOAT16_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT16_ATI

GLScene.OpenGL4

GL_RGB_FLOAT32_APPLE

GLScene.OpenGL4

GL_RGB_FLOAT32_ATI

GLScene.OpenGL4

GL_RGB_INTEGER

GLScene.OpenGL4

GL_RGB_INTEGER_EXT

GLScene.OpenGL4

GL_RGB_RAW_422_APPLE

GLScene.OpenGL4

GL_RGB_S3TC

GLScene.OpenGL4

GL_S3_s3tc

GL_RGB_SCALE

GLScene.OpenGL4

GL_RGB_SCALE_ARB

GLScene.OpenGL4

GL_RGB_SCALE_EXT

GLScene.OpenGL4

GL_RGB_SNORM

GLScene.OpenGL4

GL_RG_INTEGER

GLScene.OpenGL4

GL_RG_SNORM

GLScene.OpenGL4

GL_RIGHT

GLScene.OpenGL4

GL_ROUND_NV

GLScene.OpenGL4

GL_S

GLScene.OpenGL4

GL_S3_s3tc

GLScene.OpenGL4

GL 4.6

GL_SAMPLER

GLScene.OpenGL4

GL_SAMPLER_1D

GLScene.OpenGL4

GL_SAMPLER_1D_ARB

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_1D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D

GLScene.OpenGL4

GL_SAMPLER_2D_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_ARRAY_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_VERSION_3_1

GL_SAMPLER_2D_RECT_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_RECT_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW

GLScene.OpenGL4

GL_SAMPLER_2D_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_3D

GLScene.OpenGL4

GL_SAMPLER_3D_ARB

GLScene.OpenGL4

GL_SAMPLER_BINDING

GLScene.OpenGL4

GL_ARB_sampler_objects

GL_SAMPLER_BUFFER

GLScene.OpenGL4

GL_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_AMD_vertex_shader_tesselator

GL_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_SAMPLER_CUBE

GLScene.OpenGL4

GL_SAMPLER_CUBE_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW

GLScene.OpenGL4

GL_SAMPLER_CUBE_SHADOW_EXT

GLScene.OpenGL4

GL_SAMPLER_OBJECT_AMD

GLScene.OpenGL4

GL_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_SAMPLES

GLScene.OpenGL4

GL_SAMPLES_3DFX

GLScene.OpenGL4

GL_SAMPLES_ARB

GLScene.OpenGL4

GL_SAMPLES_EXT

GLScene.OpenGL4

GL_SAMPLES_PASSED

GLScene.OpenGL4

GL_SAMPLES_PASSED_ARB

GLScene.OpenGL4

1.4 GL_ARB_occlusion_query

GL_SAMPLES_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_ARB

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_EXT

GLScene.OpenGL4

GL_SAMPLE_ALPHA_TO_ONE_SGIS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

GL_SAMPLE_BUFFERS_SGIS

GLScene.OpenGL4

GL_SAMPLE_COVERAGE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_INVERT_ARB

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE

GLScene.OpenGL4

GL_SAMPLE_COVERAGE_VALUE_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_HEIGHT_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_PIXEL_GRID_WIDTH_ARB

GLScene.OpenGL4

GL_SAMPLE_LOCATION_SUBPIXEL_BITS_ARB

GLScene.OpenGL4

GL_ARB_sample_locations

GL_SAMPLE_MASK

GLScene.OpenGL4

GL_SAMPLE_MASK_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_INVERT_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_SGIS

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_EXT

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_NV

GLScene.OpenGL4

GL_SAMPLE_MASK_VALUE_SGIS

GLScene.OpenGL4

GL_SAMPLE_PATTERN_EXT

GLScene.OpenGL4

GL_SAMPLE_PATTERN_SGIS

GLScene.OpenGL4

GL_SAMPLE_POSITION

GLScene.OpenGL4

GL_ARB_texture_multisample

GL_SAMPLE_POSITION_NV

GLScene.OpenGL4

GL_NV_explicit_multisample

GL_SAMPLE_SHADING

GLScene.OpenGL4

GL_VERSION_4_0

GL_SAMPLE_SHADING_ARB

GLScene.OpenGL4

GL_ARB_sample_shading

GL_SATURATE_BIT_ATI

GLScene.OpenGL4

GL_SCALAR_EXT

GLScene.OpenGL4

GL_SCALEBIAS_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_scalebias_hint

GL_SCALED_RESOLVE_FASTEST_EXT

GLScene.OpenGL4

GL_EXT_framebuffer_multisample_blit_scaled

GL_SCALED_RESOLVE_NICEST_EXT

GLScene.OpenGL4

GL_SCALE_BY_FOUR_NV

GLScene.OpenGL4

GL_SCALE_BY_ONE_HALF_NV

GLScene.OpenGL4

GL_SCALE_BY_TWO_NV

GLScene.OpenGL4

GL_SCISSOR_BIT

GLScene.OpenGL4

GL_SCISSOR_BOX

GLScene.OpenGL4

GL_SCISSOR_TEST

GLScene.OpenGL4

GL_SCREEN_COORDINATES_REND

GLScene.OpenGL4

GL_REND_screen_coordinates

GL_SCREEN_KHR

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE

GLScene.OpenGL4

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SECONDARY_INTERPOLATOR_ATI

GLScene.OpenGL4

GL_SELECT

GLScene.OpenGL4

GL_SELECTION_BUFFER_POINTER

GLScene.OpenGL4

GL_SELECTION_BUFFER_SIZE

GLScene.OpenGL4

GL_SEPARABLE_2D

GLScene.OpenGL4

GL_SEPARABLE_2D_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_EXT

GLScene.OpenGL4

GL_SEPARATE_ATTRIBS_NV

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR

GLScene.OpenGL4

GL_SEPARATE_SPECULAR_COLOR_EXT

GLScene.OpenGL4

GL_SET

GLScene.OpenGL4

GL_SET_AMD

GLScene.OpenGL4

(4.3) GL_AMD_stencil_operation_extended

GL_SGIS_detail_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_fog_function

GLScene.OpenGL4

GL 4.6

GL_SGIS_generate_mipmap

GLScene.OpenGL4

GL 4.6

GL_SGIS_multisample

GLScene.OpenGL4

GL 4.6

GL_SGIS_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_point_line_texgen

GLScene.OpenGL4

GL 4.6

GL_SGIS_point_parameters

GLScene.OpenGL4

GL 4.6

GL_SGIS_sharpen_texture

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture4D

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_border_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_color_mask

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_edge_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_filter4

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_lod

GLScene.OpenGL4

GL 4.6

GL_SGIS_texture_select

GLScene.OpenGL4

GL 4.6

GL_SGIX_async

GLScene.OpenGL4

GL 4.6

GL_SGIX_async_histogram

GLScene.OpenGL4

GL 4.6

GL_SGIX_async_pixel

GLScene.OpenGL4

GL 4.6

GL_SGIX_blend_alpha_minmax

GLScene.OpenGL4

GL 4.6

GL_SGIX_calligraphic_fragment

GLScene.OpenGL4

GL 4.6

GL_SGIX_clipmap

GLScene.OpenGL4

GL 4.6

GL_SGIX_convolution_accuracy

GLScene.OpenGL4

GL 4.6

GL_SGIX_depth_pass_instrument

GLScene.OpenGL4

GL 4.6

GL_SGIX_depth_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_flush_raster

GLScene.OpenGL4

GL 4.6

GL_SGIX_fog_offset

GLScene.OpenGL4

GL 4.6

GL_SGIX_fog_scale

GLScene.OpenGL4

GL 4.6

GL_SGIX_fragment_lighting

GLScene.OpenGL4

GL 4.6

GL_SGIX_framezoom

GLScene.OpenGL4

GL 4.6

GL_SGIX_igloo_interface

GLScene.OpenGL4

GL 4.6

GL_SGIX_impact_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_instruments

GLScene.OpenGL4

GL 4.6

GL_SGIX_interlace

GLScene.OpenGL4

GL 4.6

GL_SGIX_ir_instrument1

GLScene.OpenGL4

GL 4.6

GL_SGIX_list_priority

GLScene.OpenGL4

GL 4.6

GL_SGIX_pixel_texture

GLScene.OpenGL4

GL 4.6

GL_SGIX_pixel_tiles

GLScene.OpenGL4

GL 4.6

GL_SGIX_polynomial_ffd

GLScene.OpenGL4

GL 4.6

GL_SGIX_reference_plane

GLScene.OpenGL4

GL 4.6

GL_SGIX_resample

GLScene.OpenGL4

GL 4.6

GL_SGIX_scalebias_hint

GLScene.OpenGL4

GL 4.6

GL_SGIX_shadow

GLScene.OpenGL4

GL 4.6

GL_SGIX_shadow_ambient

GLScene.OpenGL4

GL 4.6

GL_SGIX_sprite

GLScene.OpenGL4

GL 4.6

GL_SGIX_subsample

GLScene.OpenGL4

GL 4.6

GL_SGIX_tag_sample_buffer

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_add_env

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_coordinate_clamp

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_lod_bias

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_multi_buffer

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_scale_bias

GLScene.OpenGL4

GL 4.6

GL_SGIX_texture_select

GLScene.OpenGL4

GL 4.6

GL_SGIX_vertex_preclip

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcb

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcba

GLScene.OpenGL4

GL 4.6

GL_SGIX_ycrcb_subsample

GLScene.OpenGL4

GL 4.6

GL_SGI_color_matrix

GLScene.OpenGL4

GL 4.6

GL_SGI_color_table

GLScene.OpenGL4

GL 4.6

GL_SGI_depth_pass_instrument

GLScene.OpenGL4

GL 4.6

GL_SGI_texture_color_table

GLScene.OpenGL4

GL 4.6

GL_SHADER

GLScene.OpenGL4

GL_SHADER_BINARY_FORMAT_SPIR_V

GLScene.OpenGL4

4.6

GL_SHADER_BINARY_FORMAT_SPIR_V_ARB

GLScene.OpenGL4

GL_ARB_gl_spirv

GL_SHADER_COMPILER

GLScene.OpenGL4

GL_SHADER_CONSISTENT_NV

GLScene.OpenGL4

GL_SHADER_GLOBAL_ACCESS_BARRIER_BIT_NV

GLScene.OpenGL4

GL_NV_shader_buffer_store

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_IMAGE_ACCESS_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_SHADER_IMAGE_ATOMIC

GLScene.OpenGL4

GL_SHADER_IMAGE_LOAD

GLScene.OpenGL4

GL_SHADER_IMAGE_STORE

GLScene.OpenGL4

GL_SHADER_INCLUDE_ARB

GLScene.OpenGL4

GL_ARB_shading_language_include

GL_SHADER_OBJECT_ARB

GLScene.OpenGL4

GL_SHADER_OPERATION_NV

GLScene.OpenGL4

GL_SHADER_SOURCE_LENGTH

GLScene.OpenGL4

GL_SHADER_STORAGE_BARRIER_BIT

GLScene.OpenGL4

GL_SHADER_STORAGE_BLOCK

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_BINDING

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_SIZE

GLScene.OpenGL4

GL_SHADER_STORAGE_BUFFER_START

GLScene.OpenGL4

GL_SHADER_TYPE

GLScene.OpenGL4

GL_SHADE_MODEL

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION

GLScene.OpenGL4

GL_SHADING_LANGUAGE_VERSION_ARB

GLScene.OpenGL4

GL_ARB_shading_language_100

GL_SHADOW_AMBIENT_SGIX

GLScene.OpenGL4

GL_SGIX_shadow_ambient

GL_SHADOW_ATTENUATION_EXT

GLScene.OpenGL4

GL_SHARED_TEXTURE_PALETTE_EXT

GLScene.OpenGL4

GL_EXT_shared_texture_palette

GL_SHARPEN_TEXTURE_FUNC_POINTS_SGIS

GLScene.OpenGL4

GL_SHININESS

GLScene.OpenGL4

GL_SHORT

GLScene.OpenGL4

GL_SIGNALED

GLScene.OpenGL4

GL_SIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_HILO16_NV

GLScene.OpenGL4

GL_SIGNED_HILO8_NV

GLScene.OpenGL4

GL_SIGNED_HILO_NV

GLScene.OpenGL4

GL_SIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY8_NV

GLScene.OpenGL4

GL_SIGNED_INTENSITY_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE8_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_ALPHA_NV

GLScene.OpenGL4

GL_SIGNED_LUMINANCE_NV

GLScene.OpenGL4

GL_SIGNED_NEGATE_NV

GLScene.OpenGL4

GL_SIGNED_NORMALIZED

GLScene.OpenGL4

GL_SIGNED_RGB8_NV

GLScene.OpenGL4

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA8_NV

GLScene.OpenGL4

GL_SIGNED_RGBA_NV

GLScene.OpenGL4

GL_SIGNED_RGB_NV

GLScene.OpenGL4

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_DEPTH_WRITE

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_TEST

GLScene.OpenGL4

GL_SIMULTANEOUS_TEXTURE_AND_STENCIL_WRITE

GLScene.OpenGL4

GL_SINGLE_COLOR

GLScene.OpenGL4

GL_SINGLE_COLOR_EXT

GLScene.OpenGL4

GL_SKIP_COMPONENTS1_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS2_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS3_NV

GLScene.OpenGL4

GL_SKIP_COMPONENTS4_NV

GLScene.OpenGL4

GL_SKIP_DECODE_EXT

GLScene.OpenGL4

GL_SKIP_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_SLICE_ACCUM_SUN

GLScene.OpenGL4

GL_SUN_slice_accum

GL_SLUMINANCE

GLScene.OpenGL4

GL_SLUMINANCE8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8

GLScene.OpenGL4

GL_SLUMINANCE8_ALPHA8_EXT

GLScene.OpenGL4

GL_SLUMINANCE8_EXT

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA

GLScene.OpenGL4

GL_SLUMINANCE_ALPHA_EXT

GLScene.OpenGL4

GL_SLUMINANCE_EXT

GLScene.OpenGL4

GL_SMALL_CCW_ARC_TO_NV

GLScene.OpenGL4

GL_SMALL_CW_ARC_TO_NV

GLScene.OpenGL4

GL_SMOOTH

GLScene.OpenGL4

GL_SMOOTH_CUBIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_LINE_WIDTH_RANGE

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_GRANULARITY

GLScene.OpenGL4

GL_SMOOTH_POINT_SIZE_RANGE

GLScene.OpenGL4

GL_SMOOTH_QUADRATIC_CURVE_TO_NV

GLScene.OpenGL4

GL_SOFTLIGHT_KHR

GLScene.OpenGL4

GL_SOURCE0_ALPHA

GLScene.OpenGL4

GL_SOURCE0_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE0_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE0_RGB

GLScene.OpenGL4

GL_SOURCE0_RGB_ARB

GLScene.OpenGL4

GL_SOURCE0_RGB_EXT

GLScene.OpenGL4

GL_SOURCE1_ALPHA

GLScene.OpenGL4

GL_SOURCE1_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE1_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE1_RGB

GLScene.OpenGL4

GL_SOURCE1_RGB_ARB

GLScene.OpenGL4

GL_SOURCE1_RGB_EXT

GLScene.OpenGL4

GL_SOURCE2_ALPHA

GLScene.OpenGL4

GL_SOURCE2_ALPHA_ARB

GLScene.OpenGL4

GL_SOURCE2_ALPHA_EXT

GLScene.OpenGL4

GL_SOURCE2_RGB

GLScene.OpenGL4

GL_SOURCE2_RGB_ARB

GLScene.OpenGL4

GL_SOURCE2_RGB_EXT

GLScene.OpenGL4

GL_SOURCE3_ALPHA_NV

GLScene.OpenGL4

GL_SOURCE3_RGB_NV

GLScene.OpenGL4

GL_SPARE0_NV

GLScene.OpenGL4

GL_SPARE0_PLUS_SECONDARY_COLOR_NV

GLScene.OpenGL4

GL_SPARE1_NV

GLScene.OpenGL4

GL_SPARSE_BUFFER_PAGE_SIZE_ARB

GLScene.OpenGL4

GL_SPARSE_STORAGE_BIT_ARB

GLScene.OpenGL4

GL_ARB_sparse_buffer

GL_SPARSE_TEXTURE_FULL_ARRAY_CUBE_MIPMAPS_ARB

GLScene.OpenGL4

GL_SPECULAR

GLScene.OpenGL4

GL_SPHERE_MAP

GLScene.OpenGL4

GL_SPIR_V_BINARY

GLScene.OpenGL4

GL_SPIR_V_BINARY_ARB

GLScene.OpenGL4

GL_SPIR_V_EXTENSIONS

GLScene.OpenGL4

GL_SPOT_CUTOFF

GLScene.OpenGL4

GL_SPOT_DIRECTION

GLScene.OpenGL4

GL_SPOT_EXPONENT

GLScene.OpenGL4

GL_SPRITE_AXIAL_SGIX

GLScene.OpenGL4

GL_SPRITE_AXIS_SGIX

GLScene.OpenGL4

GL_SPRITE_EYE_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_MODE_SGIX

GLScene.OpenGL4

GL_SPRITE_OBJECT_ALIGNED_SGIX

GLScene.OpenGL4

GL_SPRITE_SGIX

GLScene.OpenGL4

GL_SGIX_sprite

GL_SPRITE_TRANSLATION_SGIX

GLScene.OpenGL4

GL_SQUARE_NV

GLScene.OpenGL4

GL_SRC0_ALPHA

GLScene.OpenGL4

GL_SRC0_RGB

GLScene.OpenGL4

GL_SRC1_ALPHA

GLScene.OpenGL4

GL_SRC1_COLOR

GLScene.OpenGL4

GL_ARB_blend_func_extended

GL_SRC1_RGB

GLScene.OpenGL4

GL_SRC2_ALPHA

GLScene.OpenGL4

GL_SRC2_RGB

GLScene.OpenGL4

GL_SRC_ALPHA

GLScene.OpenGL4

GL_SRC_ALPHA_SATURATE

GLScene.OpenGL4

GL_SRC_COLOR

GLScene.OpenGL4

GL_SRGB

GLScene.OpenGL4

GL_SRGB8

GLScene.OpenGL4

GL_SRGB8_ALPHA8

GLScene.OpenGL4

GL_SRGB8_ALPHA8_EXT

GLScene.OpenGL4

GL_SRGB8_EXT

GLScene.OpenGL4

GL_SRGB_ALPHA

GLScene.OpenGL4

GL_SRGB_ALPHA_EXT

GLScene.OpenGL4

GL_SRGB_DECODE_ARB

GLScene.OpenGL4

GL_SRGB_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB

GL_SRGB_READ

GLScene.OpenGL4

GL_SRGB_WRITE

GLScene.OpenGL4

GL_STACK_OVERFLOW

GLScene.OpenGL4

GL_STACK_UNDERFLOW

GLScene.OpenGL4

GL_STANDARD_FONT_NAME_NV

GLScene.OpenGL4

GL_STATIC_ATI

GLScene.OpenGL4

GL_ATI_vertex_array_object

GL_STATIC_COPY

GLScene.OpenGL4

GL_STATIC_COPY_ARB

GLScene.OpenGL4

GL_STATIC_DRAW

GLScene.OpenGL4

GL_STATIC_DRAW_ARB

GLScene.OpenGL4

GL_STATIC_READ

GLScene.OpenGL4

GL_STATIC_READ_ARB

GLScene.OpenGL4

GL_STENCIL

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT

GLScene.OpenGL4

GL_STENCIL_ATTACHMENT_EXT

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC

GLScene.OpenGL4

GL_STENCIL_BACK_FUNC_ATI

GLScene.OpenGL4

GL_ATI_separate_stencil

GL_STENCIL_BACK_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_FAIL_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_BACK_PASS_DEPTH_PASS_ATI

GLScene.OpenGL4

GL_STENCIL_BACK_REF

GLScene.OpenGL4

GL_STENCIL_BACK_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_BACK_WRITEMASK

GLScene.OpenGL4

GL_STENCIL_BITS

GLScene.OpenGL4

GL_STENCIL_BUFFER

GLScene.OpenGL4

GL_STENCIL_BUFFER_BIT

GLScene.OpenGL4

GL_STENCIL_CLEAR_TAG_VALUE_EXT

GLScene.OpenGL4

GL_STENCIL_CLEAR_VALUE

GLScene.OpenGL4

GL_STENCIL_COMPONENTS

GLScene.OpenGL4

GL_STENCIL_FAIL

GLScene.OpenGL4

GL_STENCIL_FUNC

GLScene.OpenGL4

GL_STENCIL_INDEX

GLScene.OpenGL4

PixelFormat

GL_STENCIL_INDEX1

GLScene.OpenGL4

GL_STENCIL_INDEX16

GLScene.OpenGL4

GL_STENCIL_INDEX16_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX1_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX4

GLScene.OpenGL4

GL_STENCIL_INDEX4_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX8

GLScene.OpenGL4

GL_STENCIL_INDEX8_EXT

GLScene.OpenGL4

GL_STENCIL_INDEX_EXT

GLScene.OpenGL4

GL_STENCIL_OP_VALUE_AMD

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_FAIL

GLScene.OpenGL4

GL_STENCIL_PASS_DEPTH_PASS

GLScene.OpenGL4

GL_STENCIL_REF

GLScene.OpenGL4

GL_STENCIL_RENDERABLE

GLScene.OpenGL4

GL_STENCIL_TAG_BITS_EXT

GLScene.OpenGL4

GL_EXT_stencil_clear_tag

GL_STENCIL_TEST

GLScene.OpenGL4

GL_STENCIL_TEST_TWO_SIDE_EXT

GLScene.OpenGL4

GL_EXT_stencil_two_side

GL_STENCIL_VALUE_MASK

GLScene.OpenGL4

GL_STENCIL_WRITEMASK

GLScene.OpenGL4

GL_STEREO

GLScene.OpenGL4

GL_STORAGE_CACHED_APPLE

GLScene.OpenGL4

GL_STORAGE_CLIENT_APPLE

GLScene.OpenGL4

GL_STORAGE_PRIVATE_APPLE

GLScene.OpenGL4

GL_STORAGE_SHARED_APPLE

GLScene.OpenGL4

GL_STREAM_COPY

GLScene.OpenGL4

GL_STREAM_COPY_ARB

GLScene.OpenGL4

GL_STREAM_DRAW

GLScene.OpenGL4

GL_STREAM_DRAW_ARB

GLScene.OpenGL4

GL_STREAM_READ

GLScene.OpenGL4

GL_STREAM_READ_ARB

GLScene.OpenGL4

GL_STRICT_DEPTHFUNC_HINT_PGI

GLScene.OpenGL4

GL_STRICT_LIGHTING_HINT_PGI

GLScene.OpenGL4

GL_STRICT_SCISSOR_HINT_PGI

GLScene.OpenGL4

GL_SUBPIXEL_BITS

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_X_BITS_NV

GLScene.OpenGL4

GL_SUBPIXEL_PRECISION_BIAS_Y_BITS_NV

GLScene.OpenGL4

GL_SUBSAMPLE_DISTANCE_AMD

GLScene.OpenGL4

GL_AMD_sample_positions

GL_SUBTRACT

GLScene.OpenGL4

GL_SUBTRACT_ARB

GLScene.OpenGL4

GL_SUB_ATI

GLScene.OpenGL4

GL_SUCCESS_NV

GLScene.OpenGL4

GL_SUNX_constant_data

GLScene.OpenGL4

GL 4.6

GL_SUN_convolution_border_modes

GLScene.OpenGL4

GL 4.6

GL_SUN_global_alpha

GLScene.OpenGL4

GL 4.6

GL_SUN_mesh_array

GLScene.OpenGL4

GL 4.6

GL_SUN_slice_accum

GLScene.OpenGL4

GL 4.6

GL_SUN_triangle_list

GLScene.OpenGL4

GL 4.6

GL_SUN_vertex

GLScene.OpenGL4

GL 4.6

GL_SURFACE_MAPPED_NV

GLScene.OpenGL4

GL_SURFACE_REGISTERED_NV

GLScene.OpenGL4

GL_SURFACE_STATE_NV

GLScene.OpenGL4

GL_NV_vdpau_interop

GL_SWIZZLE_STQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STRQ_DQ_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_ATI

GLScene.OpenGL4

GL_SWIZZLE_STR_DR_ATI

GLScene.OpenGL4

GL_SYNC_CL_EVENT_ARB

GLScene.OpenGL4

GL_ARB_cl_event

GL_SYNC_CL_EVENT_COMPLETE_ARB

GLScene.OpenGL4

GL_SYNC_CONDITION

GLScene.OpenGL4

GL_SYNC_FENCE

GLScene.OpenGL4

GL_SYNC_FLAGS

GLScene.OpenGL4

GL_SYNC_FLUSH_COMMANDS_BIT

GLScene.OpenGL4

GL_SYNC_GPU_COMMANDS_COMPLETE

GLScene.OpenGL4

GL_SYNC_STATUS

GLScene.OpenGL4

GL_SYNC_X11_FENCE_EXT

GLScene.OpenGL4

GL_EXT_x11_sync_object

GL_SYSTEM_FONT_NAME_NV

GLScene.OpenGL4

GL_T

GLScene.OpenGL4

GL_T2F_C3F_V3F

GLScene.OpenGL4

GL_T2F_C4F_N3F_V3F

GLScene.OpenGL4

GL_T2F_C4UB_V3F

GLScene.OpenGL4

GL_T2F_IUI_N3F_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_N3F_V3F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V2F_EXT

GLScene.OpenGL4

GL_T2F_IUI_V3F_EXT

GLScene.OpenGL4

GL_T2F_N3F_V3F

GLScene.OpenGL4

GL_T2F_V3F

GLScene.OpenGL4

GL_T4F_C4F_N3F_V4F

GLScene.OpenGL4

GL_T4F_V4F

GLScene.OpenGL4

GL_TABLE_TOO_LARGE

GLScene.OpenGL4

GL_TABLE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_coordinate_frame

GL_TANGENT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TANGENT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TESSELLATION_FACTOR_AMD

GLScene.OpenGL4

GL_TESSELLATION_MODE_AMD

GLScene.OpenGL4

GL_TESS_CONTROL_OUTPUT_VERTICES

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_CONTROL_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_BIT

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES

GLScene.OpenGL4

GL_TESS_CONTROL_SHADER_PATCHES_ARB

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE

GLScene.OpenGL4

GL_TESS_CONTROL_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_CONTROL_TEXTURE

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_BIT

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_TESS_EVALUATION_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE

GLScene.OpenGL4

GL_TESS_EVALUATION_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_TESS_EVALUATION_TEXTURE

GLScene.OpenGL4

GL_TESS_GEN_MODE

GLScene.OpenGL4

GL_TESS_GEN_POINT_MODE

GLScene.OpenGL4

GL_TESS_GEN_SPACING

GLScene.OpenGL4

GL_TESS_GEN_VERTEX_ORDER

GLScene.OpenGL4

GL_TEXCOORD1_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD2_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD3_BIT_PGI

GLScene.OpenGL4

GL_TEXCOORD4_BIT_PGI

GLScene.OpenGL4

GL_TEXTURE

GLScene.OpenGL4

MatrixMode (for gl3.h, FBO attachment type)

GL_TEXTURE0

GLScene.OpenGL4

GL_VERSION_1_3

GL_TEXTURE0_ARB

GLScene.OpenGL4

GL_ARB_multitexture

GL_TEXTURE1

GLScene.OpenGL4

GL_TEXTURE10

GLScene.OpenGL4

GL_TEXTURE10_ARB

GLScene.OpenGL4

GL_TEXTURE11

GLScene.OpenGL4

GL_TEXTURE11_ARB

GLScene.OpenGL4

GL_TEXTURE12

GLScene.OpenGL4

GL_TEXTURE12_ARB

GLScene.OpenGL4

GL_TEXTURE13

GLScene.OpenGL4

GL_TEXTURE13_ARB

GLScene.OpenGL4

GL_TEXTURE14

GLScene.OpenGL4

GL_TEXTURE14_ARB

GLScene.OpenGL4

GL_TEXTURE15

GLScene.OpenGL4

GL_TEXTURE15_ARB

GLScene.OpenGL4

GL_TEXTURE16

GLScene.OpenGL4

GL_TEXTURE16_ARB

GLScene.OpenGL4

GL_TEXTURE17

GLScene.OpenGL4

GL_TEXTURE17_ARB

GLScene.OpenGL4

GL_TEXTURE18

GLScene.OpenGL4

GL_TEXTURE18_ARB

GLScene.OpenGL4

GL_TEXTURE19

GLScene.OpenGL4

GL_TEXTURE19_ARB

GLScene.OpenGL4

GL_TEXTURE1_ARB

GLScene.OpenGL4

GL_TEXTURE2

GLScene.OpenGL4

GL_TEXTURE20

GLScene.OpenGL4

GL_TEXTURE20_ARB

GLScene.OpenGL4

GL_TEXTURE21

GLScene.OpenGL4

GL_TEXTURE21_ARB

GLScene.OpenGL4

GL_TEXTURE22

GLScene.OpenGL4

GL_TEXTURE22_ARB

GLScene.OpenGL4

GL_TEXTURE23

GLScene.OpenGL4

GL_TEXTURE23_ARB

GLScene.OpenGL4

GL_TEXTURE24

GLScene.OpenGL4

GL_TEXTURE24_ARB

GLScene.OpenGL4

GL_TEXTURE25

GLScene.OpenGL4

GL_TEXTURE25_ARB

GLScene.OpenGL4

GL_TEXTURE26

GLScene.OpenGL4

GL_TEXTURE26_ARB

GLScene.OpenGL4

GL_TEXTURE27

GLScene.OpenGL4

GL_TEXTURE27_ARB

GLScene.OpenGL4

GL_TEXTURE28

GLScene.OpenGL4

GL_TEXTURE28_ARB

GLScene.OpenGL4

GL_TEXTURE29

GLScene.OpenGL4

GL_TEXTURE29_ARB

GLScene.OpenGL4

GL_TEXTURE2_ARB

GLScene.OpenGL4

GL_TEXTURE3

GLScene.OpenGL4

GL_TEXTURE30

GLScene.OpenGL4

GL_TEXTURE30_ARB

GLScene.OpenGL4

GL_TEXTURE31

GLScene.OpenGL4

GL_TEXTURE31_ARB

GLScene.OpenGL4

GL_TEXTURE3_ARB

GLScene.OpenGL4

GL_TEXTURE4

GLScene.OpenGL4

GL_TEXTURE4_ARB

GLScene.OpenGL4

GL_TEXTURE5

GLScene.OpenGL4

GL_TEXTURE5_ARB

GLScene.OpenGL4

GL_TEXTURE6

GLScene.OpenGL4

GL_TEXTURE6_ARB

GLScene.OpenGL4

GL_TEXTURE7

GLScene.OpenGL4

GL_TEXTURE7_ARB

GLScene.OpenGL4

GL_TEXTURE8

GLScene.OpenGL4

GL_TEXTURE8_ARB

GLScene.OpenGL4

GL_TEXTURE9

GLScene.OpenGL4

GL_TEXTURE9_ARB

GLScene.OpenGL4

GL_TEXTURE_1D

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_texture_array

GL_TEXTURE_1D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_3D

GLScene.OpenGL4

GL_TEXTURE_3D_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_3D_EXT

GLScene.OpenGL4

GL_TEXTURE_4DSIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_BINDING_SGIS

GLScene.OpenGL4

GL_TEXTURE_4D_SGIS

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE

GLScene.OpenGL4

GL_TEXTURE_ALPHA_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_APPLICATION_MODE_EXT

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL

GLScene.OpenGL4

GL_TEXTURE_BASE_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_1D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_3D

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_BUFFER_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_ARB

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_EXT

GLScene.OpenGL4

GL_TEXTURE_BINDING_RECTANGLE_NV

GLScene.OpenGL4

GL_TEXTURE_BINDING_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_BIT

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE

GLScene.OpenGL4

GL_TEXTURE_BLUE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE

GLScene.OpenGL4

GL_TEXTURE_BLUE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_BORDER

GLScene.OpenGL4

GL_TEXTURE_BORDER_COLOR

GLScene.OpenGL4

GL_TEXTURE_BORDER_VALUES_NV

GLScene.OpenGL4

GL_TEXTURE_BUFFER

GLScene.OpenGL4

GL_TEXTURE_BUFFER_ARB

GLScene.OpenGL4

GL_ARB_texture_buffer_object

GL_TEXTURE_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_texture_buffer_object

GL_TEXTURE_BUFFER_FORMAT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_ARB

GLScene.OpenGL4

GL_TEXTURE_BUFFER_FORMAT_EXT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET

GLScene.OpenGL4

GL_TEXTURE_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_TEXTURE_BUFFER_SIZE

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_CENTER_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_FRAME_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_LOD_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_OFFSET_SGIX

GLScene.OpenGL4

GL_TEXTURE_CLIPMAP_VIRTUAL_DEPTH_SGIX

GLScene.OpenGL4

GL_TEXTURE_COLOR_SAMPLES_NV

GLScene.OpenGL4

GL_TEXTURE_COLOR_TABLE_SGI

GLScene.OpenGL4

GL_SGI_texture_color_table

GL_TEXTURE_COLOR_WRITEMASK_SGIS

GLScene.OpenGL4

GL_SGIS_texture_color_mask

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB

GLScene.OpenGL4

GL_ARB_shadow_ambient

GL_TEXTURE_COMPARE_FUNC

GLScene.OpenGL4

GL_TEXTURE_COMPARE_FUNC_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE

GLScene.OpenGL4

GL_TEXTURE_COMPARE_MODE_ARB

GLScene.OpenGL4

GL_ARB_shadow

GL_TEXTURE_COMPARE_OPERATOR_SGIX

GLScene.OpenGL4

GL_TEXTURE_COMPARE_SGIX

GLScene.OpenGL4

GL_SGIX_shadow

GL_TEXTURE_COMPONENTS

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE

GLScene.OpenGL4

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT

GLScene.OpenGL4

GL_TEXTURE_COMPRESSION_HINT_ARB

GLScene.OpenGL4

GL_TEXTURE_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE

GLScene.OpenGL4

GL_TEXTURE_COORD_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_TEXTURE_COORD_NV

GLScene.OpenGL4

GL_TEXTURE_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

GL_NV_texture_multisample

GL_TEXTURE_CUBE_MAP

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_ARB_texture_cube_map_array

GL_TEXTURE_CUBE_MAP_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT

GLScene.OpenGL4

GL_TEXTURE_CUBE_MAP_SEAMLESS

GLScene.OpenGL4

GL_ARB_seamless_cube_map

GL_TEXTURE_DEFORMATION_BIT_SGIX

GLScene.OpenGL4

GL_FfdMaskSGIX

GL_TEXTURE_DEFORMATION_SGIX

GLScene.OpenGL4

GL_TEXTURE_DEPTH

GLScene.OpenGL4

GL_TEXTURE_DEPTH_EXT

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_SIZE_ARB

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE

GLScene.OpenGL4

GL_TEXTURE_DEPTH_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_DS_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_DT_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_ENV

GLScene.OpenGL4

GL_TEXTURE_ENV_BIAS_SGIX

GLScene.OpenGL4

GL_SGIX_texture_add_env

GL_TEXTURE_ENV_COLOR

GLScene.OpenGL4

GL_TEXTURE_ENV_MODE

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_FETCH_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_FILTER4_SIZE_SGIS

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL

GLScene.OpenGL4

GL_TEXTURE_FILTER_CONTROL_EXT

GLScene.OpenGL4

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS

GLScene.OpenGL4

GL_TEXTURE_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

GL_TEXTURE_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_TEXTURE_GATHER

GLScene.OpenGL4

GL_TEXTURE_GATHER_SHADOW

GLScene.OpenGL4

GL_TEXTURE_GEN_MODE

GLScene.OpenGL4

GL_TEXTURE_GEN_Q

GLScene.OpenGL4

GL_TEXTURE_GEN_R

GLScene.OpenGL4

GL_TEXTURE_GEN_S

GLScene.OpenGL4

GL_TEXTURE_GEN_T

GLScene.OpenGL4

GL_TEXTURE_GEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE

GLScene.OpenGL4

GL_TEXTURE_GREEN_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE

GLScene.OpenGL4

GL_TEXTURE_GREEN_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_HEIGHT

GLScene.OpenGL4

GL_TEXTURE_HI_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_IMAGE_FORMAT

GLScene.OpenGL4

GL_TEXTURE_IMAGE_TYPE

GLScene.OpenGL4

GL_TEXTURE_IMMUTABLE_FORMAT

GLScene.OpenGL4

GL_ARB_texture_storage

GL_TEXTURE_IMMUTABLE_LEVELS

GLScene.OpenGL4

GL_TEXTURE_INDEX_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE

GLScene.OpenGL4

GL_TEXTURE_INTENSITY_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_INTERNAL_FORMAT

GLScene.OpenGL4

GL_TEXTURE_LEQUAL_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LIGHTING_MODE_HP

GLScene.OpenGL4

GL_HP_texture_lighting

GL_TEXTURE_LIGHT_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_EXT

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_LOD_BIAS_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_lod_bias

GL_TEXTURE_LOD_BIAS_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_LO_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE

GLScene.OpenGL4

GL_TEXTURE_LUMINANCE_TYPE_ARB

GLScene.OpenGL4

GL_TEXTURE_MAG_FILTER

GLScene.OpenGL4

TextureParameterName

GL_TEXTURE_MAG_SIZE_NV

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_FACE_EXT

GLScene.OpenGL4

GL_TEXTURE_MATERIAL_PARAMETER_EXT

GLScene.OpenGL4

GL_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY

GLScene.OpenGL4

GL_TEXTURE_MAX_ANISOTROPY_EXT

GLScene.OpenGL4

GL_EXT_texture_filter_anisotropic

GL_TEXTURE_MAX_CLAMP_R_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_CLAMP_S_SGIX

GLScene.OpenGL4

GL_SGIX_texture_coordinate_clamp

GL_TEXTURE_MAX_CLAMP_T_SGIX

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL

GLScene.OpenGL4

GL_TEXTURE_MAX_LEVEL_SGIS

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD

GLScene.OpenGL4

GL_TEXTURE_MAX_LOD_SGIS

GLScene.OpenGL4

GL_TEXTURE_MIN_FILTER

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD

GLScene.OpenGL4

GL_TEXTURE_MIN_LOD_SGIS

GLScene.OpenGL4

GL_SGIS_texture_lod

GL_TEXTURE_MULTI_BUFFER_HINT_SGIX

GLScene.OpenGL4

GL_SGIX_texture_multi_buffer

GL_TEXTURE_NORMAL_EXT

GLScene.OpenGL4

GL_TEXTURE_POST_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRE_SPECULAR_HP

GLScene.OpenGL4

GL_TEXTURE_PRIORITY

GLScene.OpenGL4

GL_TEXTURE_PRIORITY_EXT

GLScene.OpenGL4

GL_EXT_texture_object

GL_TEXTURE_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_APPLE_texture_range

GL_TEXTURE_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE

GLScene.OpenGL4

GL_TEXTURE_RECTANGLE_ARB

GLScene.OpenGL4

GL_ARB_texture_rectangle

GL_TEXTURE_RECTANGLE_EXT

GLScene.OpenGL4

GL_EXT_texture_rectangle

GL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

GL_NV_texture_rectangle

GL_TEXTURE_REDUCTION_MODE_ARB

GLScene.OpenGL4

GL_ARB_texture_filter_minmax

GL_TEXTURE_RED_SIZE

GLScene.OpenGL4

GL_TEXTURE_RED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE

GLScene.OpenGL4

GL_TEXTURE_RED_TYPE_ARB

GLScene.OpenGL4

GL_ARB_texture_float

GL_TEXTURE_RENDERBUFFER_DATA_STORE_BINDING_NV

GLScene.OpenGL4

GL_TEXTURE_RENDERBUFFER_NV

GLScene.OpenGL4

GL_TEXTURE_RESIDENT

GLScene.OpenGL4

GL_TEXTURE_RESIDENT_EXT

GLScene.OpenGL4

GL_TEXTURE_SAMPLES

GLScene.OpenGL4

GL_TEXTURE_SHADER_NV

GLScene.OpenGL4

GL_TEXTURE_SHADOW

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE

GLScene.OpenGL4

GL_TEXTURE_SHARED_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_SPARSE_ARB

GLScene.OpenGL4

GL_ARB_SPARSE_TEXTURE

GL_TEXTURE_SRGB_DECODE_EXT

GLScene.OpenGL4

GL_EXT_texture_sRGB_decode

GL_TEXTURE_STACK_DEPTH

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE

GLScene.OpenGL4

GL_TEXTURE_STENCIL_SIZE_EXT

GLScene.OpenGL4

GL_TEXTURE_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_A_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_B_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_G_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R

GLScene.OpenGL4

GL_ARB_texture_swizzle

GL_TEXTURE_SWIZZLE_RGBA

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_RGBA_EXT

GLScene.OpenGL4

GL_TEXTURE_SWIZZLE_R_EXT

GLScene.OpenGL4

GL_EXT_texture_swizzle

GL_TEXTURE_TARGET

GLScene.OpenGL4

GL_TEXTURE_TOO_LARGE_EXT

GLScene.OpenGL4

GL_TEXTURE_UNSIGNED_REMAP_MODE_NV

GLScene.OpenGL4

GL_NV_texture_expand_normal

GL_TEXTURE_UPDATE_BARRIER_BIT

GLScene.OpenGL4

GL_TEXTURE_UPDATE_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TEXTURE_VIEW

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LAYER

GLScene.OpenGL4

GL_TEXTURE_VIEW_MIN_LEVEL

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LAYERS

GLScene.OpenGL4

GL_TEXTURE_VIEW_NUM_LEVELS

GLScene.OpenGL4

GL_TEXTURE_WIDTH

GLScene.OpenGL4

GetTextureParameter

GL_TEXTURE_WRAP_Q_SGIS

GLScene.OpenGL4

GL_TEXTURE_WRAP_R

GLScene.OpenGL4

GL_TEXTURE_WRAP_R_EXT

GLScene.OpenGL4

GL_TEXTURE_WRAP_S

GLScene.OpenGL4

GL_TEXTURE_WRAP_T

GLScene.OpenGL4

GL_TEXT_FRAGMENT_SHADER_ATI

GLScene.OpenGL4

GL_ATI_text_fragment_shader

GL_TIMEOUT_EXPIRED

GLScene.OpenGL4

GL_TIMEOUT_IGNORED

GLScene.OpenGL4

GL_TIMESTAMP

GLScene.OpenGL4

GL_TIME_ELAPSED

GLScene.OpenGL4

GL_ARB_timer_query

GL_TIME_ELAPSED_EXT

GLScene.OpenGL4

GL_EXT_timer_query

GL_TOP_LEVEL_ARRAY_SIZE

GLScene.OpenGL4

GL_TOP_LEVEL_ARRAY_STRIDE

GLScene.OpenGL4

GL_TRACK_MATRIX_NV

GLScene.OpenGL4

GL_TRACK_MATRIX_TRANSFORM_NV

GLScene.OpenGL4

GL_TRANSFORM_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK

GLScene.OpenGL4

GL_ARB_texture_buffer_object_rgb32 GL_ARB_transform_feedback2

GL_TRANSFORM_FEEDBACK_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_EXT

GLScene.OpenGL4

GL_EXT_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_INDEX

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_NV

GLScene.OpenGL4

GL_NV_transform_feedback

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_BUFFER_STRIDE

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_NV

GLScene.OpenGL4

GL_NV_transform_feedback2

GL_TRANSFORM_FEEDBACK_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_OVERFLOW_ARB

GLScene.OpenGL4

GL_ARB_transform_feedback_overflow_query

GL_TRANSFORM_FEEDBACK_PAUSED

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_RECORD_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_STREAM_OVERFLOW_ARB

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYINGS_NV

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH

GLScene.OpenGL4

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT

GLScene.OpenGL4

GL_TRANSFORM_HINT_APPLE

GLScene.OpenGL4

GL_APPLE_transform_hint

GL_TRANSLATE_2D_NV

GLScene.OpenGL4

GL_TRANSLATE_3D_NV

GLScene.OpenGL4

GL_TRANSLATE_X_NV

GLScene.OpenGL4

GL_TRANSLATE_Y_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_AFFINE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_COLOR_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_CURRENT_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB

GLScene.OpenGL4

GL_ARB_transpose_matrix

GL_TRANSPOSE_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROGRAM_MATRIX_EXT

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTION_MATRIX_ARB

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_2D_NV

GLScene.OpenGL4

GL_TRANSPOSE_PROJECTIVE_3D_NV

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX

GLScene.OpenGL4

GL_TRANSPOSE_TEXTURE_MATRIX_ARB

GLScene.OpenGL4

GL_TRIANGLES

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLES_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGLE_FAN

GLScene.OpenGL4

GL_TRIANGLE_LIST_SUN

GLScene.OpenGL4

GL_TRIANGLE_MESH_SUN

GLScene.OpenGL4

GL_TRIANGLE_STRIP

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_ARB

GLScene.OpenGL4

GL_TRIANGLE_STRIP_ADJACENCY_EXT

GLScene.OpenGL4

GL_TRIANGULAR_NV

GLScene.OpenGL4

GL_TRUE

GLScene.OpenGL4

GL_TYPE

GLScene.OpenGL4

GL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

GL_UNDEFINED_APPLE

GLScene.OpenGL4

GL_UNDEFINED_VERTEX

GLScene.OpenGL4

GL_UNIFORM

GLScene.OpenGL4

GL_UNIFORM_ARRAY_STRIDE

GLScene.OpenGL4

GL_UNIFORM_ATOMIC_COUNTER_BUFFER_INDEX

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT

GLScene.OpenGL4

GL_UNIFORM_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_UNIFORM_BLOCK

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS

GLScene.OpenGL4

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES

GLScene.OpenGL4

GL_UNIFORM_BLOCK_BINDING

GLScene.OpenGL4

GL_UNIFORM_BLOCK_DATA_SIZE

GLScene.OpenGL4

GL_UNIFORM_BLOCK_INDEX

GLScene.OpenGL4

GL_UNIFORM_BLOCK_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_COMPUTE_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER

GLScene.OpenGL4

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER

GLScene.OpenGL4

GL_UNIFORM_BUFFER

GLScene.OpenGL4

GL_ARB_uniform_buffer_object

GL_UNIFORM_BUFFER_BINDING

GLScene.OpenGL4

GL_UNIFORM_BUFFER_BINDING_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_EXT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT

GLScene.OpenGL4

GL_UNIFORM_BUFFER_SIZE

GLScene.OpenGL4

GL_UNIFORM_BUFFER_START

GLScene.OpenGL4

GL_UNIFORM_IS_ROW_MAJOR

GLScene.OpenGL4

GL_UNIFORM_MATRIX_STRIDE

GLScene.OpenGL4

GL_UNIFORM_NAME_LENGTH

GLScene.OpenGL4

GL_UNIFORM_OFFSET

GLScene.OpenGL4

GL_UNIFORM_SIZE

GLScene.OpenGL4

GL_UNIFORM_TYPE

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET

GLScene.OpenGL4

GL_UNKNOWN_CONTEXT_RESET_ARB

GLScene.OpenGL4

GL_UNPACK_ALIGNMENT

GLScene.OpenGL4

GL_UNPACK_CLIENT_STORAGE_APPLE

GLScene.OpenGL4

GL_APPLE_client_storage

GL_UNPACK_CMYK_HINT_EXT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_DEPTH

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_HEIGHT

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_SIZE

GLScene.OpenGL4

GL_UNPACK_COMPRESSED_BLOCK_WIDTH

GLScene.OpenGL4

GL_ARB_compressed_texture_pixel_storage

GL_UNPACK_CONSTANT_DATA_SUNX

GLScene.OpenGL4

GL_SUNX_constant_data

GL_UNPACK_IMAGE_DEPTH_SGIS

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT

GLScene.OpenGL4

GL_UNPACK_IMAGE_HEIGHT_EXT

GLScene.OpenGL4

GL_UNPACK_LSB_FIRST

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_OML

GLScene.OpenGL4

GL_UNPACK_RESAMPLE_SGIX

GLScene.OpenGL4

GL_UNPACK_ROW_BYTES_APPLE

GLScene.OpenGL4

GL_UNPACK_ROW_LENGTH

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES

GLScene.OpenGL4

GL_UNPACK_SKIP_IMAGES_EXT

GLScene.OpenGL4

GL_UNPACK_SKIP_PIXELS

GLScene.OpenGL4

GL_UNPACK_SKIP_ROWS

GLScene.OpenGL4

GL_UNPACK_SKIP_VOLUMES_SGIS

GLScene.OpenGL4

GL_UNPACK_SUBSAMPLE_RATE_SGIX

GLScene.OpenGL4

GL_UNPACK_SWAP_BYTES

GLScene.OpenGL4

GL_UNSIGNALED

GLScene.OpenGL4

GL_UNSIGNED_BYTE

GLScene.OpenGL4

GL_UNSIGNED_BYTE_2_3_3_REV

GLScene.OpenGL4

GL_UNSIGNED_BYTE_3_3_2

GLScene.OpenGL4

GL_VERSION_1_2

GL_UNSIGNED_BYTE_3_3_2_EXT

GLScene.OpenGL4

GL_EXT_packed_pixels

GL_UNSIGNED_IDENTITY_NV

GLScene.OpenGL4

GL_UNSIGNED_INT

GLScene.OpenGL4

GL_UNSIGNED_INT16_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT16_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT64_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT64_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC2_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC3_NV

GLScene.OpenGL4

GL_UNSIGNED_INT8_VEC4_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2

GLScene.OpenGL4

GL_UNSIGNED_INT_10_10_10_2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_24_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_2_10_10_10_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_5_9_9_9_REV_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_8_8_REV

GLScene.OpenGL4

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_ATOMIC_COUNTER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_MULTISAMPLE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_IMAGE_CUBE_MAP_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_S8_S8_8_8_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_1D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_3D_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

GLScene.OpenGL4

GL_UNSIGNED_INT_SAMPLER_RENDERBUFFER_NV

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC2_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC3_EXT

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4

GLScene.OpenGL4

GL_UNSIGNED_INT_VEC4_EXT

GLScene.OpenGL4

GL_UNSIGNED_INVERT_NV

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED

GLScene.OpenGL4

GL_UNSIGNED_NORMALIZED_ARB

GLScene.OpenGL4

GL_UNSIGNED_SHORT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_1_5_5_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_4_4_4_4_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_5_5_1_EXT

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5

GLScene.OpenGL4

GL_UNSIGNED_SHORT_5_6_5_REV

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_APPLE

GLScene.OpenGL4

GL_UNSIGNED_SHORT_8_8_REV_APPLE

GLScene.OpenGL4

GL_UPPER_LEFT

GLScene.OpenGL4

GL_USE_MISSING_GLYPH_NV

GLScene.OpenGL4

GL_UTF16_NV

GLScene.OpenGL4

GL_UTF8_NV

GLScene.OpenGL4

GL_V2F

GLScene.OpenGL4

GL_V3F

GLScene.OpenGL4

GL_VALIDATE_STATUS

GLScene.OpenGL4

GL_VARIABLE_A_NV

GLScene.OpenGL4

GL_VARIABLE_B_NV

GLScene.OpenGL4

GL_VARIABLE_C_NV

GLScene.OpenGL4

GL_VARIABLE_D_NV

GLScene.OpenGL4

GL_VARIABLE_E_NV

GLScene.OpenGL4

GL_VARIABLE_F_NV

GLScene.OpenGL4

GL_VARIABLE_G_NV

GLScene.OpenGL4

GL_VARIANT_ARRAY_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VARIANT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VARIANT_DATATYPE_EXT

GLScene.OpenGL4

GL_VARIANT_EXT

GLScene.OpenGL4

GL_VARIANT_VALUE_EXT

GLScene.OpenGL4

GL_VBO_FREE_MEMORY_ATI

GLScene.OpenGL4

GL_ATI_meminfo

GL_VECTOR_EXT

GLScene.OpenGL4

GL_VENDOR

GLScene.OpenGL4

StringName

GL_VERSION

GLScene.OpenGL4

GL_VERSION_4_0

GLScene.OpenGL4

GL_VERSION_4_1

GLScene.OpenGL4

GL_VERSION_4_2

GLScene.OpenGL4

GL_VERSION_4_3

GLScene.OpenGL4

GL_VERSION_4_4

GLScene.OpenGL4

GL_VERSION_4_5

GLScene.OpenGL4

GL_VERSION_4_6

GLScene.OpenGL4

GL_VERTEX23_BIT_PGI

GLScene.OpenGL4

GL_VERTEX4_BIT_PGI

GLScene.OpenGL4

GL_VERTEX_ARRAY

GLScene.OpenGL4

GL_VERTEX_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_BINDING

GLScene.OpenGL4

GL_ARB_vertex_array_object

GL_VERTEX_ARRAY_BINDING_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_object

GL_VERTEX_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ARRAY_COUNT_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_EXT

GLScene.OpenGL4

GL_EXT_vertex_array

GL_VERTEX_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_LIST_IBM

GLScene.OpenGL4

GL_IBM_vertex_array_lists

GL_VERTEX_ARRAY_LIST_STRIDE_IBM

GLScene.OpenGL4

GL_VERTEX_ARRAY_OBJECT_AMD

GLScene.OpenGL4

GL_VERTEX_ARRAY_PARALLEL_POINTERS_INTEL

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_array_range

GL_VERTEX_ARRAY_RANGE_LENGTH_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_NV

GLScene.OpenGL4

GL_NV_vertex_array_range

GL_VERTEX_ARRAY_RANGE_POINTER_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_POINTER_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_VALID_NV

GLScene.OpenGL4

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV

GLScene.OpenGL4

GL_NV_vertex_array_range2

GL_VERTEX_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_STORAGE_HINT_APPLE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY0_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY10_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY11_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY12_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY13_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY14_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY15_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY1_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY2_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY3_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY4_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY5_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY6_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY7_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY8_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY9_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT

GLScene.OpenGL4

GL_ARB_shader_image_load_store

GL_VERTEX_ATTRIB_ARRAY_BARRIER_BIT_EXT

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_DIVISOR

GLScene.OpenGL4

GL_VERSION_3_3

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB

GLScene.OpenGL4

GL_ARB_instanced_arrays

GL_VERTEX_ATTRIB_ARRAY_ENABLED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT

GLScene.OpenGL4

GL_EXT_gpu_shader4

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_LONG

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV

GLScene.OpenGL4

GL_NV_vertex_buffer_unified_memory

GL_VERTEX_ATTRIB_BINDING

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_APPLE

GLScene.OpenGL4

GL_APPLE_vertex_program_evaluators

GL_VERTEX_ATTRIB_MAP1_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP1_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_COEFF_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_DOMAIN_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_ORDER_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_MAP2_SIZE_APPLE

GLScene.OpenGL4

GL_VERTEX_ATTRIB_RELATIVE_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_DIVISOR

GLScene.OpenGL4

GL_VERTEX_BINDING_OFFSET

GLScene.OpenGL4

GL_VERTEX_BINDING_STRIDE

GLScene.OpenGL4

GL_VERTEX_BLEND_ARB

GLScene.OpenGL4

GL_VERTEX_CONSISTENT_HINT_PGI

GLScene.OpenGL4

GL_VERTEX_DATA_HINT_PGI

GLScene.OpenGL4

GL_PGI_vertex_hints

GL_VERTEX_ID_NV

GLScene.OpenGL4

GL_VERTEX_PRECLIP_HINT_SGIX

GLScene.OpenGL4

GL_VERTEX_PRECLIP_SGIX

GLScene.OpenGL4

GL_SGIX_vertex_preclip

GL_VERTEX_PROGRAM_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_BINDING_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_NV

GLScene.OpenGL4

GL_NV_vertex_program

GL_VERTEX_PROGRAM_PARAMETER_BUFFER_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_POINT_SIZE_NV

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_ARB

GLScene.OpenGL4

GL_VERTEX_PROGRAM_TWO_SIDE_NV

GLScene.OpenGL4

GL_VERTEX_SHADER

GLScene.OpenGL4

GL_VERTEX_SHADER_ARB

GLScene.OpenGL4

GL_ARB_vertex_shader

GL_VERTEX_SHADER_BINDING_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_BIT

GLScene.OpenGL4

GL_ARB_separate_shader_objects

GL_VERTEX_SHADER_EXT

GLScene.OpenGL4

GL_EXT_vertex_shader

GL_VERTEX_SHADER_INSTRUCTIONS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS

GLScene.OpenGL4

GL_VERTEX_SHADER_INVOCATIONS_ARB

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCALS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_LOCAL_CONSTANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_OPTIMIZED_EXT

GLScene.OpenGL4

GL_VERTEX_SHADER_VARIANTS_EXT

GLScene.OpenGL4

GL_VERTEX_SOURCE_ATI

GLScene.OpenGL4

GL_VERTEX_STATE_PROGRAM_NV

GLScene.OpenGL4

GL_VERTEX_STREAM0_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM1_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM2_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM3_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM4_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM5_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM6_ATI

GLScene.OpenGL4

GL_VERTEX_STREAM7_ATI

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE

GLScene.OpenGL4

GL_VERTEX_SUBROUTINE_UNIFORM

GLScene.OpenGL4

GL_VERTEX_TEXTURE

GLScene.OpenGL4

GL_VERTEX_WEIGHTING_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_POINTER_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_SIZE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_STRIDE_EXT

GLScene.OpenGL4

GL_VERTEX_WEIGHT_ARRAY_TYPE_EXT

GLScene.OpenGL4

GL_VERTICAL_LINE_TO_NV

GLScene.OpenGL4

GL_VERTICES_SUBMITTED

GLScene.OpenGL4

GL_VERTICES_SUBMITTED_ARB

GLScene.OpenGL4

GL_ARB_pipeline_statistics_query

GL_VIBRANCE_BIAS_NV

GLScene.OpenGL4

GL_VIBRANCE_SCALE_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_BINDING_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_INTERNAL_FORMAT_NV

GLScene.OpenGL4

GL_VIDEO_BUFFER_NV

GLScene.OpenGL4

GL_NV_video_capture

GL_VIDEO_BUFFER_PITCH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_LOWER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FIELD_UPPER_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_HEIGHT_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_FRAME_WIDTH_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_SURFACE_ORIGIN_NV

GLScene.OpenGL4

GL_VIDEO_CAPTURE_TO_422_SUPPORTED_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MATRIX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MAX_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_MIN_NV

GLScene.OpenGL4

GL_VIDEO_COLOR_CONVERSION_OFFSET_NV

GLScene.OpenGL4

GL_VIEWPORT

GLScene.OpenGL4

GL_VIEWPORT_BIT

GLScene.OpenGL4

GL_VIEWPORT_BOUNDS_RANGE

GLScene.OpenGL4

GL_VIEWPORT_INDEX_PROVOKING_VERTEX

GLScene.OpenGL4

GL_VIEWPORT_SUBPIXEL_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_128_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_16_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_24_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_32_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_48_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_64_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_8_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_96_BITS

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_FLOAT

GLScene.OpenGL4

GL_VIEW_CLASS_BPTC_UNORM

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC1_RED

GLScene.OpenGL4

GL_VIEW_CLASS_RGTC2_RG

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGB

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT1_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT3_RGBA

GLScene.OpenGL4

GL_VIEW_CLASS_S3TC_DXT5_RGBA

GLScene.OpenGL4

GL_VIEW_COMPATIBILITY_CLASS

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_INDEX_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_X_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Y_ARB

GLScene.OpenGL4

GL_VIRTUAL_PAGE_SIZE_Z_ARB

GLScene.OpenGL4

GL_VOLATILE_APPLE

GLScene.OpenGL4

GL_WAIT_FAILED

GLScene.OpenGL4

GL_WEIGHTED_AVERAGE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING

GLScene.OpenGL4

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_POINTER_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_SIZE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_STRIDE_ARB

GLScene.OpenGL4

GL_WEIGHT_ARRAY_TYPE_ARB

GLScene.OpenGL4

GL_WEIGHT_SUM_UNITY_ARB

GLScene.OpenGL4

GL_WIDE_LINE_HINT_PGI

GLScene.OpenGL4

GL_WIN_phong_shading

GLScene.OpenGL4

WGL

GL_WIN_specular_fog

GLScene.OpenGL4

WGL

GL_WRAP_BORDER_SUN

GLScene.OpenGL4

GL_SUN_convolution_border_modes

GL_WRITE_DISCARD_NV

GLScene.OpenGL4

GL_WRITE_ONLY

GLScene.OpenGL4

GL_WRITE_ONLY_ARB

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_LENGTH_NV

GLScene.OpenGL4

GL_WRITE_PIXEL_DATA_RANGE_NV

GLScene.OpenGL4

GL_NV_pixel_data_range

GL_WRITE_PIXEL_DATA_RANGE_POINTER_NV

GLScene.OpenGL4

GL_W_EXT

GLScene.OpenGL4

GL_XOR

GLScene.OpenGL4

GL_X_EXT

GLScene.OpenGL4

GL_YCBAYCR8A_4224_NV

GLScene.OpenGL4

GL_YCBCR_422_APPLE

GLScene.OpenGL4

GL_APPLE_ycbcr_422

GL_YCBYCR8_422_NV

GLScene.OpenGL4

GL_YCRCBA_SGIX

GLScene.OpenGL4

GL_YCRCB_422_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcb

GL_YCRCB_444_SGIX

GLScene.OpenGL4

GL_YCRCB_SGIX

GLScene.OpenGL4

GL_SGIX_ycrcba

GL_Y_EXT

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4A12Z4Y12Z4CR12Z4A12_4224_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4CR12_444_NV

GLScene.OpenGL4

GL_Z4Y12Z4CB12Z4Y12Z4CR12_422_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6A10Z6Y10Z6CR10Z6A10_4224_NV

GLScene.OpenGL4

GL_Z6Y10Z6CB10Z6Y10Z6CR10_422_NV

GLScene.OpenGL4

GL_ZERO

GLScene.OpenGL4

BlendingFactorDest

GL_ZERO_EXT

GLScene.OpenGL4

GL_ZERO_TO_ONE

GLScene.OpenGL4

GL_ZOOM_X

GLScene.OpenGL4

GL_ZOOM_Y

GLScene.OpenGL4

GL_Z_EXT

GLScene.OpenGL4

GRADIENT_TABLE_SIZE

GXS.ProcTextures

GraphicClassForExtension

GXS.PictureRegisteredFormats

Returns the TGraphicClass associated to the extension, if any. Accepts anExtension with or without the '.'

GravitationalConstant

GXS.PhysFields

GRedBlackTree

GLScene.RedBlackTree

GRedBlackTree.TRBNode

GLScene.RedBlackTree

GUIComponentDialog

FMxSkinEditor

GUILayoutForm

FMxGuiLayoutEditor

GuiNullRect

GXS.Gui

GXContextManager

GXS.Context

GXOpenGL

GXS.InitOpenGL

GXOpenGL

OpenGXS.InitFMX

gxsShaderMaxLightSources

GXSL.CustomShader

G_DRAG

GXS.VerletTypes

HackTPictureRegisteredFormats

GXS.PictureRegisteredFormats

Adds to the passed TStrings the list of registered Formatx. Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').

HalfToFloat

GLScene.Utils

Handle

GXS.SceneViewer

HGPUNV

GLScene.OpenGL4

HGPUNV

GLScene.OpenGLTokens

HPBUFFERARB

GLScene.OpenGL4

HPBUFFERARB

GLScene.OpenGLTokens

HVIDEOINPUTDEVICENV

GLScene.OpenGL4

HVIDEOINPUTDEVICENV

GLScene.OpenGLTokens

IdentityHmgDblMatrix

GLScene.VectorGeometry

IdentityHmgMatrix

GLScene.VectorGeometry

IdentityMatrix

GLScene.VectorGeometry

IdentityQuaternion

GLScene.VectorGeometry

Quaternions

IDesigner

FMxXCollectionEditor

IgxInitializable

GXS.Scene

Interface to objects that need initialization

IgxMaterialLibrarySupported

GXS.Material

an interface for proper TgxLibMaterialNameProperty support

IgxPostShader

GXSL.CustomShader

Used in the TgxPostShaderHolder component.

IgxShaderDescription

GXSL.CustomShader

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

IgxShaderParameter

GXSL.Parameter

IgxTextureNotifyAble

GXS.Texture

ILength

GLScene.VectorGeometry

ILength

GLScene.VectorGeometry

Computes an integer length Result:=Sqrt(x*x+y*y)

ImageAlphaBottomRightPointColorTransparent

GXS.ImageUtils

ImageAlphaFromIntensity

GXS.ImageUtils

ImageAlphaInverseLuminance

GXS.ImageUtils

ImageAlphaInverseLuminanceSqrt

GXS.ImageUtils

ImageAlphaLuminance

GXS.ImageUtils

ImageAlphaLuminanceSqrt

GXS.ImageUtils

ImageAlphaOpaque

GXS.ImageUtils

ImageAlphaSuperBlackTransparent

GXS.ImageUtils

ImageAlphaTopLeftPointColorTransparent

GXS.ImageUtils

ImageBellFilter

GXS.ImageUtils

ImageBoxFilter

GXS.ImageUtils

in VCL -> sAllFilter;

ImageHermiteFilter

GXS.ImageUtils

ImageLanczos3Filter

GXS.ImageUtils

ImageMitchellFilter

GXS.ImageUtils

ImageSplineFilter

GXS.ImageUtils

ImageTriangleFilter

GXS.ImageUtils

IncludeFilePath

GXS.CgShader

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.

IncludeInClipRect

GLScene.GeometryBB

Extend the clip rect to include given coordinate.

IncreaseCoherency

GXS.MeshUtils

Increases indices coherency wrt vertex caches. The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips). This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

InflateGLRect

GLScene.Utils

Increases or decreases the width and height of the specified rectangle. Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

InfoForm

FMxInfo

InformationDlg

GXS.ImageUtils

Pops up a simple dialog with msg and an Ok button.

Init

GLScene.VectorTypesExt

InitializeRandomGenerator

GXS.RandomHDS

Initialize_Contouring

GXS.Isolines

InitNx

GXS.PhysX

InitOpenGL

GLScene.OpenGL4

InitOpenGL

GXS.OpenGLAdapter

InitOpenGLFromLibrary

GLScene.OpenGL4

InitOpenGLFromLibrary

GXS.OpenGLAdapter

InitTexture

GXSL.CustomShader

InputDlg

GXS.ImageUtils

Posp a simple dialog with a string input.

InteractionIHM

uGBEUtils3D

InternalFormatToOpenGLFormat

GLScene.TextureFormat

Give a openGL texture format from GLScene texture format

InterpolateCombined

GLScene.VectorGeometry

InterpolateCombinedFast

GLScene.VectorGeometry

InterpolateCombinedFastPower

GLScene.VectorGeometry

InterpolateCombinedSafe

GLScene.VectorGeometry

InterpolateExp

GLScene.VectorGeometry

InterpolateLn

GLScene.VectorGeometry

InterpolatePower

GLScene.VectorGeometry

There functions that do the same as "Lerp", but add some distortions

InterpolateSin

GLScene.VectorGeometry

Only valid where Delta belongs to [0..1]

InterpolateSinAlt

GLScene.VectorGeometry

"Alt" functions are valid everywhere

InterpolateTan

GLScene.VectorGeometry

IntersectAABBs

GLScene.GeometryBB

Determines if two AxisAlignedBoundingBoxes intersect. The matrices are the ones that convert one point to the other's AABB system

IntersectAABBsAbsolute

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide.

IntersectAABBsAbsoluteXY

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XY plane.

IntersectAABBsAbsoluteXZ

GLScene.GeometryBB

Checks whether two Bounding boxes aligned with the world axes collide in the XZ plane.

IntersectCubes

GXS.Collision

Returns true when the bounding box cubes does intersect the other. Also true when the one cube does contain the other completely.

IntersectGLRect

GLScene.Utils

IntersectLinePlane

GLScene.VectorGeometry

Compute the intersection point "res" of a line with a plane. Return value: 0 : no intersection, line parallel to plane 1 : res is valid -1 : line is inside plane Adapted from: E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

IntersectSphereBox

GLScene.VectorGeometry

Compute intersection between a Sphere and a box. Up, Direction and Right must be normalized! Use CubDepth, CubeHeight and CubeWidth to scale TGLCube

IntersectTriangleBox

GLScene.VectorGeometry

Compute intersection between a triangle and a box. Returns True if an intersection was found

InvertMatrix

GLScene.VectorGeometry

Finds the inverse of a 3x3 matrix;

InvertMatrix

GLScene.VectorGeometry

Finds the inverse of a 4x4 matrix

InvertTrianglesWinding

GXS.MeshUtils

Inverts the triangles winding (vertex order).

InvokeInfoForm

GXS.Scene

IsCgProfileSupported

GXS.CgShader

Misc. global functions

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsColinear

GLScene.VectorGeometry

Returns true if both vector are colinear

IsCompressedFormat

GLScene.TextureFormat

IsCompressedFormat

GLScene.TextureFormat

True if texture compressed

IsDepthFormat

GLScene.TextureFormat

IsDepthFormat

GLScene.TextureFormat

True if depth texture

IsDesignTime

GLScene.Utils

IsDirectoryWriteable

GLScene.Utils

Determine if the directory is writable.

IsFloatFormat

GLScene.TextureFormat

IsFloatFormat

GLScene.TextureFormat

True if texture format is float

IsFogEnabled

GXSL.CustomShader

IsFormatSupported

GLScene.TextureFormat

True if texture format is supported by hardware or software

IShaderParameter

GXSL.ShaderParameter

IsInCube

GLScene.VectorGeometry

IsInCube

GLScene.VectorGeometry

Returns True if p is in the cube defined by d.

IsInRange

GLScene.VectorGeometry

IsInRange

GLScene.VectorGeometry

Returns True if x is in [a; b]

IsInRect

GXS.Gui

IsKeyDown

GLScene.Keyboard

Check if the given virtual key is down. This function is just a wrapper for GetAsyncKeyState.

IsKeyDown

GLScene.Keyboard

Check if the key corresponding to the given Char is down. The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad. The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

IsLineIntersectQuad

GLScene.VectorGeometry

Returns true if line intersect ABCD quad. Quad have to be flat and convex

IsLineIntersectTriangle

GLScene.VectorGeometry

Returns true if line intersect ABC triangle

IsMainThread

GXS.Context

IsMesaGL

GLScene.OpenGL4

IsMesaGL

GXS.OpenGLAdapter

IsOpenGLInitialized

GLScene.OpenGL4

IsOpenGLInitialized

GXS.OpenGLAdapter

IsOpenGLLoaded

GLScene.OpenGL4

IsOpenGLLoaded

GXS.OpenGLAdapter

IsOpenGLVersionMet

GLScene.OpenGL4

IsPointInPolygon

GLScene.VectorGeometry

PtInRegion

IsPowerOf2

GLScene.Utils

Returns True if value is a true power of two

ISqrt

GLScene.VectorGeometry

Computes an integer sqrt approximation

IsServiceContextAvaible

GXS.Context

IsSubComponent

GLScene.Utils

Classes.pas

IsTargetSupported

GLScene.TextureFormat

IsTargetSupported

GLScene.TextureFormat

True if texture target supported

IsTargetSupportMipmap

GLScene.TextureFormat

IsTargetSupportMipmap

GLScene.TextureFormat

IsVersionMet

GLScene.OpenGL4

IsVersionMet

GXS.OpenGLAdapter

IsVolumeClipped

GLScene.VectorGeometry

IsVolumeClipped

GLScene.VectorGeometry

IsVolumeClipped

GLScene.VectorGeometry

Determines if volume is clipped or not

KeyboardNotifyWheelMoved

GLScene.Keyboard

Use this procedure to notify a wheel movement and have it resurfaced as key stroke. Honoured by IsKeyDown and KeyPressed

KeyNameToVirtualKeyCode

GLScene.Keyboard

Converts a key name to its virtual key code. The comparison is **NOT** case-sensitive, if no match is found, returns -1. The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

KeyPressed

GLScene.Keyboard

Returns the first pressed key whose virtual key code is >= to minVkCode. If no key is pressed, the return value is -1, this function does NOT wait for user input. If you don't care about multiple key presses, just don't use the parameter.

Language

GLScene.Strings

String constants that are used for internationalization
To build your project with a single language's translations in the executable itself, define one of the next languages
Language $DEFINE 2-character locale id ——————- ———- ——————— English LANG_EN en French LANG_FR fr German LANG_DE de Italian LANG_IT it Japanese LANG_JP jp Russian LANG_RU ru Spanish LANG_ES es

lcl_release

GXS.Screen

Lerp

GLScene.VectorGeometry

Calculates linear interpolation between start and stop at point t

libEGL

GLScene.OpenGL4

libGLES2

GLScene.OpenGL4

Linear_Interpolate

GXS.Perlin

Useless for final output! Usefull for after interpolation, as its FAST!

LineLen

GXS.FileOBJ

Load input data in chunks of BufSize Bytes.

LineLineDistance

GLScene.VectorGeometry

Computes the closest distance between two lines

lkPrefix

GLScene.Logger

llMax

GLScene.Logger

llMedium

GLScene.Logger

llMessageLimit

GLScene.Logger

llMin

GLScene.Logger

LnGamma

GLScene.RandomLib

Logarithm to base e of the gamma function. Accurate to about 1.e-14. Programmer: Alan Miller Latest revision of Fortran 77 version - 28 February 1988

LoadAnsiStringFromFile

GLScene.Utils

Returns the ansistring content of "filename".

LoadComponentFromFile

GLScene.Utils

Loads component from a file.

LoadOpenGL

GLScene.OpenGL4

LoadOpenGL

GXS.OpenGLAdapter

LoadOpenGLFromLibrary

GLScene.OpenGL4

LoadOpenGLFromLibrary

GXS.OpenGLAdapter

LoadQ3Anims

Formatx.Q3MD3

LoadQ3Anims

Formatx.Q3MD3

These procedures are helpers to load the Quake3 animation file data into an animation list. The NamePrefix parameter is used to determine which class of animation is extracted. eg NamePrefix='TORSO' will load all animations starting with 'TORSO_' like 'TORSO_STAND'

LoadQ3Skin

Formatx.Q3MD3

Quake3 Skin loading procedure. Use this procedure to apply textures to a GLActor. This doens't use the actors original preloaded materials so it may be a good idea to clear the actors material library before running this to keep everything nice and clean.

LoadRGBEpixels

GLScene.RGBE

LoadRLEpixels

GLScene.RGBE

LoadStringFromFile

GLScene.Utils

Returns the string content of "filename".

Logarithm2

GLScene.VectorGeometry

—————————————————————————- Exponential functions —————————————————————————–

MakeAffineDblVector

GLScene.VectorGeometry

Miscellaneous functions

MakeDblVector

GLScene.VectorGeometry

MakeParallelProjectionMatrix

GLScene.VectorGeometry

Creates a parallel projection matrix. Transformed points will projected on the plane along the specified direction

MakePoint

GLScene.VectorGeometry

MakePoint

GLScene.VectorGeometry

MakePoint

GLScene.VectorGeometry

MakeReflectionMatrix

GLScene.VectorGeometry

Builds a reflection matrix for the given plane. Reflection matrix allow implementing planar reflectors (mirrors)

MakeShadowMatrix

GLScene.VectorGeometry

Creates a shadow projection matrix. Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos

MakeSubComponent

GLScene.Utils

MakeTriangleAdjacencyList

GXS.MeshUtils

Create list of indices of triangles with adjacency from triangle list

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MakeVector

GLScene.VectorGeometry

MaterialEditorForm

FMxMaterialEditor

MatrixDecompose

GLScene.VectorGeometry

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it. Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan The coefficient of each transformation is returned in the corresponding element of the vector Tran. Returns true upon success, false if the matrix is singular.

MatrixDeterminant

GLScene.VectorGeometry

Determinant of a 3x3 matrix

MatrixDeterminant

GLScene.VectorGeometry

Determinant of a 4x4 matrix

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

MatrixEquals

GLScene.VectorGeometry

3x3

MatrixEquals

GLScene.VectorGeometry

4x4

MatrixInvert

GLScene.VectorGeometry

MatrixInvert

GLScene.VectorGeometry

MatrixLerp

GLScene.VectorGeometry

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

MatrixMultiply

GLScene.VectorGeometry

Multiplies M1 by M2 and places result in MResult

MatrixMultiply

GLScene.VectorGeometry

Multiplies two 3x3 matrices

MatrixMultiply

GLScene.VectorGeometry

Multiplies two 4x4 matrices

MaxAbsXYZComponent

GLScene.VectorGeometry

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

MaxColorAttachments

GXS.FBO

MaxComp

GLScene.VectorGeometry

MaxDouble

GLScene.VectorGeometry

MaxExtended

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

MaxFloat

GLScene.VectorGeometry

Returns the maximum of given values.

MaxFloat

GLScene.VectorGeometry

Returns the maximum value of the array.

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxInteger

GLScene.VectorGeometry

MaxSingle

GLScene.VectorGeometry

MaxTriangles

GLScene.Triangulation

MaxVector

GLScene.VectorGeometry

MaxVector

GLScene.VectorGeometry

Replace components of v with the max of v or v1 component. Maximum is computed per component

MaxVertices

GLScene.Triangulation

Set these as applicable

MaxVideoModes

GXS.Screen

MaxXYZComponent

GLScene.VectorGeometry

MaxXYZComponent

GLScene.VectorGeometry

Returns the max of the X, Y and Z components of a vector (W is ignored)

MAX_HARDWARE_LIGHT

GXS.State

MAX_HARDWARE_TEXTURE_UNIT

GXS.State

MAX_HARDWARE_UNIFORM_BUFFER_BINDING

GXS.State

MAX_MATRIX_STACK_DEPTH

GLScene.PipelineTransform

MAX_MS3D_GROUPS

GXS.FileMS3D

MAX_MS3D_JOINTS

GXS.FileMS3D

MAX_MS3D_KEYFRAMES

GXS.FileMS3D

MAX_MS3D_MATERIALS

GXS.FileMS3D

MAX_MS3D_TRIANGLES

GXS.FileMS3D

MAX_MS3D_VERTICES

GXS.FileMS3D

MAX_OBJECT_STACK_DEPTH

GXS.Selection

MAX_SHADER_LIGHT

GXS.State

MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

GLScene.OpenGL4

GL_NV_vertex_program3

MDCFILE_IDENTITY

GXS.FileMDC

MDCFILE_VERSION

GXS.FileMDC

MDC_BASEVERTEX_FACTOR

GXS.FileMDC

MDC_COMPVERTEX_FACTOR

GXS.FileMDC

1/64;

MidTexPoint

GLScene.VectorGeometry

MinAbsXYZComponent

GLScene.VectorGeometry

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored)

MinComp

GLScene.VectorGeometry

1.1E+4932 <-Overflowing in c++;

MinDouble

GLScene.VectorGeometry

MinExtended

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

MinFloat

GLScene.VectorGeometry

Returns the minimum of given values.

MinFloat

GLScene.VectorGeometry

Returns the minimum value of the array.

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinInteger

GLScene.VectorGeometry

MinPositiveCoef

GLScene.Polynomials

Finds the minimum positive coef in the array in aMin. Returns true if such an item was found.

MinSingle

GLScene.VectorGeometry

Ranges of the IEEE floating point types, including denormals with Math.pas compatible name

MinusXVector

GLScene.VectorGeometry

MinusYVector

GLScene.VectorGeometry

MinusZVector

GLScene.VectorGeometry

MinVector

GLScene.VectorGeometry

MinVector

GLScene.VectorGeometry

Replace components of v with the min of v or v1 component. Minimum is computed per component

MinXYZComponent

GLScene.VectorGeometry

MinXYZComponent

GLScene.VectorGeometry

Returns the min of the X, Y and Z components of a vector (W is ignored)

MixerCouleurPixel

uGBEImageUtils

MoveObjectAround

GLScene.VectorGeometry

Extracted from Camera.MoveAroundTarget(pitch, turn)

MRT_BUFFERS

GXS.Context

GXS.OpenGLx, Buffer ID's for Multiple-Render-Targets (using GL_ATI_draw_buffers)

MultiTexturing

uGBEImageUtils

MultiTexturingZone

uGBEImageUtils

nearCallBack

GXS.ODEManager

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer

NegateVector

GLScene.VectorGeometry

Negates the vector

NegateVector

GLScene.VectorGeometry

Negates the vector

NegateVector

GLScene.VectorGeometry

Negates the vector

NMF_HEADER_TAG

GXS.FileNMF

NMF_TRIANGLE_TAG

GXS.FileNMF

NoisyColor

GXS.RandomHDS

function LoadJPGtexture(const JpgName: string): tBitmap;

NormalizeAngle

GLScene.VectorGeometry

Normalize to an angle in the [-PI; +PI] range

NormalizeDegAngle

GLScene.VectorGeometry

Normalize to an angle in the [-180; 180] range

NormalizeMatrix

GLScene.VectorGeometry

Normalize the matrix and remove the translation component. The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

NormalizePlane

GLScene.VectorGeometry

Normalize a plane so that point evaluation = plane distance. }

NormalizeQuaternion

GLScene.VectorGeometry

Normalizes the given quaternion

NormalizeVector

GLScene.VectorGeometry

Returns the vector transformed to unit length Transforms a vector to unit length

NormalizeVector

GLScene.VectorGeometry

Transforms a vector to unit length

NormalizeVector

GLScene.VectorGeometry

Transforms a vector to unit length

NormalizeVectorArray

GLScene.VectorGeometry

Transforms vectors to unit length

NullBoundingBox

GLScene.GeometryBB

NullHmgPoint

GLScene.VectorGeometry

NullHmgVector

GLScene.VectorGeometry

NullTexPoint

GLScene.VectorGeometry

NullVector

GLScene.VectorGeometry

ObjectManager

GXS.SceneRegister

Auto-create for object manager

ODERToSceneMatrix

GXS.ODEUtils

ODERToSceneMatrix

GXS.ODEUtils

ODERToSceneMatrix

GXS.ODEUtils

OffsetAABB

GLScene.GeometryBB

OffsetAABB

GLScene.GeometryBB

Adds delta to min and max of the AABB.

OffsetBB

GLScene.GeometryBB

OffsetBB

GLScene.GeometryBB

Adds delta to min and max of the BB.

OffsetBBPoint

GLScene.GeometryBB

The same as above but uses AddPoint() instead of AddVector().

OffsetFloatArray

GLScene.VectorGeometry

OffsetFloatArray

GLScene.VectorGeometry

OffsetFloatArray

GLScene.VectorGeometry

Adds delta to values in the array. Array size must be a multiple of four

opengl32

GLScene.OpenGL4

opengl32

GXS.OpenGLAdapter

OpenGLFormatToInternalFormat

GLScene.TextureFormat

Give a GLScene texture format from openGL texture format

OpenPictureDialog

GXS.ImageUtils

Pops up a simple open picture dialog.

OptimizeMesh

GXS.MeshOptimizer

OptimizeMesh

GXS.MeshOptimizer

OptimizeMesh

GXS.MeshOptimizer

OptimizeMesh

GXS.MeshOptimizer

PAABB

GLScene.GeometryBB

PAArray

GXS.zBuffer

PackRotationMatrix

GLScene.VectorGeometry

Packs an homogeneous rotation matrix to 6 bytes. The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each. Deviation is typically below 0.01% and around 0.1% in worst case situations. Note: quaternion conversion is faster and more robust than an angle decomposition

PAffineByteVector

GLScene.VectorGeometry

PAffineDblVector

GLScene.VectorGeometry

PAffineExtVector

GLScene.VectorGeometry

PAffineFltVector

GLScene.VectorGeometry

PAffineIntVector

GLScene.VectorGeometry

PAffineMatrix

GLScene.VectorGeometry

PAffinePtrVector

GLScene.VectorGeometry

PAffineVector

GLScene.VectorGeometry

PAffineVectorArray

GLScene.VectorGeometry

Arrays of vectors

PAffineWordVector

GLScene.VectorGeometry

ParseFloat

GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

ParseInteger

GLScene.Utils

Parses the next integer in the string. Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

PAVIStream

GXS.AVIRecorder

PByteArray

GLScene.VectorGeometry

PByteRaster

GXS.HeightData

PByteVector

GLScene.VectorGeometry

Types to specify continous streams of a specific type switch off range checking to access values beyond the limits

PCardinalArray

GLScene.VectorGeometry

PCardinalVector

GLScene.VectorGeometry

PCharInfo

GXS.BitmapFont

PdFloat

GXS.NGDManager

TComponent Tlist TWriter TReader TPersistent System utilities Samevalue isZero to compare single PVector4f TVector4f TMatrix4f PMatrix4f NullHmgVector... TgxAffineVectorList for Tree TXCollection file function cube cone freeform... For show debug

PDoubleArray

GLScene.VectorGeometry

PDoubleVector

GLScene.VectorGeometry

Perlin_Random1

GXS.Perlin

just a random controlled by X

Perlin_Random1DStrip

GXS.Perlin

generates a random strip

Perlin_Random2

GXS.Perlin

just a random controlled by X,Y

PExtendedArray

GLScene.VectorGeometry

PExtendedVector

GLScene.VectorGeometry

PFastCollisionChecker

GXS.Collision

PFireParticle

GXS.FireFX

PFireParticleArray

GXS.FireFX

PFloat

GLScene.VectorGeometry

Data types needed for 3D graphics calculation, included are 'C like' aliases for each type (to be conformal with OpenGL types)

PFloatArray

GLScene.VectorGeometry

PFloatVector

GLScene.VectorGeometry

PFNGLACTIVESHADERPROGRAMPROC

GLScene.OpenGLTokens

PFNGLACTIVESTENCILFACEEXTPROC

GLScene.OpenGLTokens

GL_EXT_stencil_two_side (EXT #268)

PFNGLACTIVETEXTUREARBPROC

GLScene.OpenGLTokens

GL_ARB_multitexture (ARB #1)

PFNGLACTIVETEXTUREPROC

GLScene.OpenGLTokens

deprecated; core 1.3 promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLACTIVEVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLADDSWAPHINTRECTWINPROC

GLScene.OpenGLTokens

GL_WIN_swap_hint (extension # not found)

PFNGLAREPROGRAMSRESIDENTNVPROC

GLScene.OpenGLTokens

GL_NV_vertex_program (EXT #233)

PFNGLARETEXTURESRESIDENTEXTPROC

GLScene.OpenGLTokens

PFNGLARRAYELEMENTARRAYEXTPROC

GLScene.OpenGLTokens

EXT/Vendor extensions Unknown Vendor/EXT functions

PFNGLATTACHOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLATTACHSHADERPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_shader_objects (#30) / GL_ARB_vertex_shader (#31) / GL_ARB_fragment_shader (#32)

PFNGLBEGINCONDITIONALRENDERNVPROC

GLScene.OpenGLTokens

GL_NV_conditional_render (EXT #346)

PFNGLBEGINCONDITIONALRENDERPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_NV_conditional_render

PFNGLBEGINOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYARBPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYINDEXEDPROC

GLScene.OpenGLTokens

PFNGLBEGINQUERYPROC

GLScene.OpenGLTokens

PFNGLBEGINSCENEEXTPROC

GLScene.OpenGLTokens

GL_EXT_scene_marker (EXT #120)

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC

GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKNVPROC

GLScene.OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLBINDATTRIBLOCATIONARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_shader (ARB #31)

PFNGLBINDATTRIBLOCATIONPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_buffer_object (ARB #28)

PFNGLBINDBUFFERBASEEXTPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERBASENVPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERBASEPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETEXTPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFEROFFSETNVPROC

GLScene.OpenGLTokens

PFNGLBINDBUFFERPROC

GLScene.OpenGLTokens

promoted to core v1.5 from GL_ARB_vertex_buffer_object (#28)

PFNGLBINDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

GL_EXT_transform_feedback (EXT #352)

PFNGLBINDBUFFERRANGENVPROC

GLScene.OpenGLTokens

GL_NV_transform_feedback (EXT #341)

PFNGLBINDBUFFERRANGEPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_transform_feedback

PFNGLBindBuffersBase

GLScene.OpenGLTokens

PFNGLBindBuffersRange

GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONEXTPROC

GLScene.OpenGLTokens

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC

GLScene.OpenGLTokens

GL_ARB_blend_func_extended (ARB #78)

PFNGLBINDFRAGDATALOCATIONPROC

GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLBINDFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLBindImageTextures

GLScene.OpenGLTokens

PFNGLBINDMULTITEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLBINDPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLBINDRENDERBUFFERPROC

GLScene.OpenGLTokens

PFNGLBINDSAMPLERPROC

GLScene.OpenGLTokens

PFNGLBindSamplers

GLScene.OpenGLTokens

PFNGLBINDTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLBindTextures

GLScene.OpenGLTokens

PFNGLBINDTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

GL_ARB_transform_feedback2 (ARB #93)

PFNGLBINDVERTEXARRAYPROC

GLScene.OpenGLTokens

GL_ARB_vertex_array_object (ARB #54)

PFNGLBindVertexBuffer

GLScene.OpenGLTokens

GL_ARB_vertex_attrib_binding (ARB #125)

PFNGLBindVertexBuffers

GLScene.OpenGLTokens

PFNGLBLENDCOLOREXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_color (EXT #2)

PFNGLBLENDCOLORPROC

GLScene.OpenGLTokens

====================================================================== core 1.2 promoted to core v1.2 from GL_EXT_blend_color (#2)

PFNGLBLENDEQUATIONEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_minmax (EXT #37)

PFNGLBLENDEQUATIONIARBPROC

GLScene.OpenGLTokens

GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONIPROC

GLScene.OpenGLTokens

Core 4.0 promoted to core v4.0 from GL_ARB_draw_buffers_blend (ARB #69)

PFNGLBLENDEQUATIONPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_blend_minmax (#37)

PFNGLBLENDEQUATIONSEPARATEEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_equation_separate (EXT #299)

PFNGLBLENDEQUATIONSEPARATEIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIPROC

GLScene.OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEPROC

GLScene.OpenGLTokens

core 2.0 promoted to core v2.0 from GL_EXT_blend_equation_separate (#299)

PFNGLBLENDFUNCIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCIPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEEXTPROC

GLScene.OpenGLTokens

GL_EXT_blend_func_separate (EXT #173)

PFNGLBLENDFUNCSEPARATEIARBPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEIPROC

GLScene.OpenGLTokens

PFNGLBLENDFUNCSEPARATEPROC

GLScene.OpenGLTokens

deprecated; core 1.4 promoted to core v1.4 from GL_EXT_blend_func_separate (#173)

PFNGLBLITFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_blit (EXT #316)

PFNGLBLITFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLBUFFERADDRESSRANGENVPROC

GLScene.OpenGLTokens

GL_NV_vertex_buffer_unified_memory (EXT #380)

PFNGLBUFFERDATAARBPROC

GLScene.OpenGLTokens

PFNGLBUFFERDATAPROC

GLScene.OpenGLTokens

PFNGLBufferStorage

GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAARBPROC

GLScene.OpenGLTokens

PFNGLBUFFERSUBDATAPROC

GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC

GLScene.OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSPROC

GLScene.OpenGLTokens

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC

GLScene.OpenGLTokens

PFNGLCLAMPCOLORARBPROC

GLScene.OpenGLTokens

GL_ARB_color_buffer_float (ARB #39)

PFNGLCLAMPCOLORPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_ARB_color_buffer_float

PFNGLClearBufferData

GLScene.OpenGLTokens

GL_ARB_clear_buffer_object (ARB #121)

PFNGLCLEARBUFFERFIPROC

GLScene.OpenGLTokens

PFNGLCLEARBUFFERFVPROC

GLScene.OpenGLTokens

PFNGLCLEARBUFFERIVPROC

GLScene.OpenGLTokens

New commands in OpenGL 3.0

PFNGLClearBufferSubData

GLScene.OpenGLTokens

PFNGLCLEARBUFFERUIVPROC

GLScene.OpenGLTokens

PFNGLCLEARCOLORIIEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture_integer (EXT #343)

PFNGLCLEARCOLORIUIEXTPROC

GLScene.OpenGLTokens

PFNGLCLEARDEPTHFPROC

GLScene.OpenGLTokens

PFNGLClearNamedBufferData

GLScene.OpenGLTokens

PFNGLClearNamedBufferSubData

GLScene.OpenGLTokens

PFNGLClearTexImage

GLScene.OpenGLTokens

PFNGLClearTexSubImage

GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREARBPROC

GLScene.OpenGLTokens

PFNGLCLIENTACTIVETEXTUREPROC

GLScene.OpenGLTokens

core 1.3 deprecated promoted to core v1.3 from GL_ARB_multitexture (#1)

PFNGLCLIENTATTRIBDEFAULTEXTPROC

GLScene.OpenGLTokens

GL_EXT_direct_state_access

PFNGLCLIENTWAITSYNCPROC

GLScene.OpenGLTokens

PFNGLCOLORFORMATNVPROC

GLScene.OpenGLTokens

PFNGLCOLORMASKINDEXEDEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_buffers2 (EXT #340)

PFNGLCOLORMASKIPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_draw_buffers2

PFNGLCOLORP3UIPROC

GLScene.OpenGLTokens

PFNGLCOLORP3UIVPROC

GLScene.OpenGLTokens

PFNGLCOLORP4UIPROC

GLScene.OpenGLTokens

PFNGLCOLORP4UIVPROC

GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEEXTPROC

GLScene.OpenGLTokens

PFNGLCOLORSUBTABLEPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_color_subtable (#74)

PFNGLCOLORTABLEEXTPROC

GLScene.OpenGLTokens

GL_EXT_paletted_texture (EXT #78)

PFNGLCOLORTABLEPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOLORTABLEPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOLORTABLEPROC

GLScene.OpenGLTokens

core 1.2 deprecated promoted to core v1.2 from GL_SGI_color_table (#14)

PFNGLCOMBINERINPUTNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINEROUTPUTNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFNVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERFVNVPROC

GLScene.OpenGLTokens

GL_NV_register_combiners (EXT #191)

PFNGLCOMBINERPARAMETERINVPROC

GLScene.OpenGLTokens

PFNGLCOMBINERPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLCOMPILESHADERARBPROC

GLScene.OpenGLTokens

PFNGLCOMPILESHADERPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC

GLScene.OpenGLTokens

GL_ARB_texture_compression (ARB #12)

PFNGLCOMPRESSEDTEXIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_texture_compression (#12)

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCONVOLUTIONFILTER1DPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_convolution (#12)

PFNGLCONVOLUTIONFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERFPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERIPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCONVOLUTIONPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYBUFFERSUBDATAPROC

GLScene.OpenGLTokens

GL_ARB_copy_buffer (ARB #59)

PFNGLCOPYCOLORSUBTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCOLORTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCONVOLUTIONFILTER1DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCOPYCONVOLUTIONFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLCopyImageSubData

GLScene.OpenGLTokens

GL_ARB_copy_image (ARB #123)

PFNGLCOPYIMAGESUBDATANVPROC

GLScene.OpenGLTokens

GL_NV_copy_image (EXT #376)

PFNGLCOPYMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYPATHNVPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

GL_EXT_copy_texture (EXT #10)

PFNGLCOPYTEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_copy_texture

PFNGLCOPYTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLCOVERFILLPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLCOVERFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLCOVERSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLCREATEPROGRAMOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLCREATEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLCREATESHADEROBJECTARBPROC

GLScene.OpenGLTokens

PFNGLCREATESHADERPROC

GLScene.OpenGLTokens

PFNGLCREATESHADERPROGRAMVPROC

GLScene.OpenGLTokens

PFNGLCreateSyncFromCLevent

GLScene.OpenGLTokens

GL_ARB_robustness_isolation (ARB #126) (no entry points) GL_ARB_cl_event (ARB #103)

PFNGLCURRENTPALETTEMATRIXARBPROC

GLScene.OpenGLTokens

GL_ARB_matrix_palette (ARB #16) {deprecated?}

PFNGLDEBUGMESSAGECALLBACKARBPROC

GLScene.OpenGLTokens

PFNGLDEBUGMESSAGECONTROLARBPROC

GLScene.OpenGLTokens

GL_ARB_debug_output (ARB #104)

PFNGLDEBUGMESSAGEINSERTARBPROC

GLScene.OpenGLTokens

PFNGLDELETEBUFFERSARBPROC

GLScene.OpenGLTokens

PFNGLDELETEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETEFENCESNVPROC

GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLDELETEFRAMEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETEOBJECTARBPROC

GLScene.OpenGLTokens

GL_ARB_shader_objects (ARB #30)

PFNGLDELETEOCCLUSIONQUERIESNVPROC

GLScene.OpenGLTokens

PFNGLDELETEPATHSNVPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPIPELINESPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSARBPROC

GLScene.OpenGLTokens

PFNGLDELETEPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLDELETEQUERIESARBPROC

GLScene.OpenGLTokens

PFNGLDELETEQUERIESPROC

GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLDELETERENDERBUFFERSPROC

GLScene.OpenGLTokens

PFNGLDELETESAMPLERSPROC

GLScene.OpenGLTokens

PFNGLDELETESHADERPROC

GLScene.OpenGLTokens

PFNGLDELETESYNCPROC

GLScene.OpenGLTokens

PFNGLDELETETEXTURESEXTPROC

GLScene.OpenGLTokens

PFNGLDELETETRANSFORMFEEDBACKSPROC

GLScene.OpenGLTokens

PFNGLDELETEVERTEXARRAYSPROC

GLScene.OpenGLTokens

PFNGLDEPTHBOUNDSEXTPROC

GLScene.OpenGLTokens

GL_EXT_depth_bounds_test (EXT #297)

PFNGLDEPTHRANGEARRAYVPROC

GLScene.OpenGLTokens

PFNGLDEPTHRANGEFPROC

GLScene.OpenGLTokens

PFNGLDEPTHRANGEINDEXEDPROC

GLScene.OpenGLTokens

PFNGLDETACHOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLDETACHSHADERPROC

GLScene.OpenGLTokens

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLDISABLEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLDISABLEIPROC

GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC

GLScene.OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYPROC

GLScene.OpenGLTokens

PFNGLDispatchCompute

GLScene.OpenGLTokens

GL_ARB_compute_shader (ARB #122)

PFNGLDispatchComputeIndirect

GLScene.OpenGLTokens

PFNGLDRAWARRAYSINDIRECTPROC

GLScene.OpenGLTokens

GL_ARB_draw_indirect (ARB #87)

PFNGLDRAWARRAYSINSTANCEDARBPROC

GLScene.OpenGLTokens

GL_ARB_draw_instanced (ARB #44)

PFNGLDRAWARRAYSINSTANCEDEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_instanced (EXT #327)

PFNGLDRAWARRAYSINSTANCEDPROC

GLScene.OpenGLTokens

Core 3.1 New commands in OpenGL 3.1

PFNGLDRAWBUFFERSARBPROC

GLScene.OpenGLTokens

GL_ARB_DrawBuffers (ARB #37)

PFNGLDRAWBUFFERSATIPROC

GLScene.OpenGLTokens

GL_ATI_draw_buffers (EXT #277)

PFNGLDRAWBUFFERSPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_draw_buffers (#37)

PFNGLDRAWELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

GL_ARB_draw_elements_base_vertex (ARB #62)

PFNGLDRAWELEMENTSINDIRECTPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDARBPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDEXTPROC

GLScene.OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDPROC

GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLDRAWRANGEELEMENTSEXTPROC

GLScene.OpenGLTokens

GL_EXT_draw_range_elements (EXT #112)

PFNGLDRAWRANGEELEMENTSPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_draw_range_elements (#112)

PFNGLDRAWTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC

GLScene.OpenGLTokens

GL_ARB_transform_feedback3 (ARB #94)

PFNGLEDGEFLAGFORMATNVPROC

GLScene.OpenGLTokens

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLENABLEINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLENABLEIPROC

GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYARBPROC

GLScene.OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYPROC

GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERNVPROC

GLScene.OpenGLTokens

PFNGLENDCONDITIONALRENDERPROC

GLScene.OpenGLTokens

PFNGLENDOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLENDQUERYARBPROC

GLScene.OpenGLTokens

PFNGLENDQUERYINDEXEDPROC

GLScene.OpenGLTokens

PFNGLENDQUERYPROC

GLScene.OpenGLTokens

PFNGLENDSCENEEXTPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKEXTPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKNVPROC

GLScene.OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLEXECUTEPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLFENCESYNCPROC

GLScene.OpenGLTokens

GL_ARB_sync (ARB #66)

PFNGLFINALCOMBINERINPUTNVPROC

GLScene.OpenGLTokens

PFNGLFINISHFENCENVPROC

GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDBUFFERRANGEPROC

GLScene.OpenGLTokens

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

PFNGLFLUSHVERTEXARRAYRANGENVPROC

GLScene.OpenGLTokens

GL_NV_vertex_array_range (EXT #190)

PFNGLFOGCOORDDEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDDVEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDDVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDFEXTPROC

GLScene.OpenGLTokens

GL_EXT_fog_coord (EXT #149)

PFNGLFOGCOORDFORMATNVPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDFPROC

GLScene.OpenGLTokens

core 1.4 deprecated promoted to core v1.4 from GL_EXT_fog_coord (#149)

PFNGLFOGCOORDFVEXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFOGCOORDPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLFOGCOORDPOINTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLFramebufferParameteri

GLScene.OpenGLTokens

GL_ARB_debug_group ARB_debug_group reuses entry points from KHR_debug GL_ARB_debug_label ARB_debug_label reuses entry points from KHR_debug GL_ARB_debug_output2 GL_ARB_ES3_compatibility GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_framebuffer_no_attachments (ARB #130)

PFNGLFRAMEBUFFERREADBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFERPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERPROC

GLScene.OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREPROC

GLScene.OpenGLTokens

PFNGLFRAMETERMINATORGREMEDYPROC

GLScene.OpenGLTokens

GL_GREMEDY_frame_terminator (EXT #345)

PFNGLGENBUFFERSARBPROC

GLScene.OpenGLTokens

PFNGLGENBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENERATEMIPMAPPROC

GLScene.OpenGLTokens

PFNGLGENERATEMULTITEXMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENERATETEXTUREMIPMAPEXTPROC

GLScene.OpenGLTokens

PFNGLGENFENCESNVPROC

GLScene.OpenGLTokens

GL_NV_fence (EXT #222)

PFNGLGENFRAMEBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLGENFRAMEBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENOCCLUSIONQUERIESNVPROC

GLScene.OpenGLTokens

GL_NV_occlusion_query (EXT #261)

PFNGLGENPATHSNVPROC

GLScene.OpenGLTokens

GL_NV_path_rendering

PFNGLGENPROGRAMPIPELINESPROC

GLScene.OpenGLTokens

PFNGLGENPROGRAMSARBPROC

GLScene.OpenGLTokens

PFNGLGENPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLGENQUERIESARBPROC

GLScene.OpenGLTokens

GL_ARB_occlusion_query (ARB #29)

PFNGLGENQUERIESPROC

GLScene.OpenGLTokens

deprecated; core 1.5 promoted to core v1.5 from GL_ARB_occlusion_query (#29)

PFNGLGENRENDERBUFFERSEXTPROC

GLScene.OpenGLTokens

PFNGLGENRENDERBUFFERSPROC

GLScene.OpenGLTokens

PFNGLGENSAMPLERSPROC

GLScene.OpenGLTokens

GL_ARB_sampler_objects (ARB #81)

PFNGLGENTEXTURESEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture_object (EXT #20)

PFNGLGENTRANSFORMFEEDBACKSPROC

GLScene.OpenGLTokens

PFNGLGENVERTEXARRAYSPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBARBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEATTRIBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINENAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMARBPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMNAMEPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEUNIFORMSIVPROC

GLScene.OpenGLTokens

PFNGLGETACTIVEVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLGETATTACHEDOBJECTSARBPROC

GLScene.OpenGLTokens

PFNGLGETATTACHEDSHADERSPROC

GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONARBPROC

GLScene.OpenGLTokens

PFNGLGETATTRIBLOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETBOOLEANINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETBOOLEANI_VPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERI64VPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPARAMETERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERPOINTERVPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAARBPROC

GLScene.OpenGLTokens

PFNGLGETBUFFERSUBDATAPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOLORTABLEPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEPROC

GLScene.OpenGLTokens

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETCONVOLUTIONFILTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCONVOLUTIONPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETCONVOLUTIONPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETDEBUGMESSAGELOGARBPROC

GLScene.OpenGLTokens

PFNGLGETDOUBLEINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETDOUBLEI_VPROC

GLScene.OpenGLTokens

PFNGLGETFENCEIVNVPROC

GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETFLOATINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETFLOATI_VPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATAINDEXPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONEXTPROC

GLScene.OpenGLTokens

PFNGLGETFRAGDATALOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGetFramebufferParameteriv

GLScene.OpenGLTokens

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETGRAPHICSRESETSTATUSARBPROC

GLScene.OpenGLTokens

GL_ARB_robustness (ARB #105)

PFNGLGETHANDLEARBPROC

GLScene.OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETHISTOGRAMPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.2 from GL_EXT_histogram (#11)

PFNGLGETINFOLOGARBPROC

GLScene.OpenGLTokens

PFNGLGETINTEGER64I_VPROC

GLScene.OpenGLTokens

Core 3.2

PFNGLGETINTEGER64VPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERI_VPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERUI64I_VNVPROC

GLScene.OpenGLTokens

PFNGLGETINTEGERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGetInternalformati64v

GLScene.OpenGLTokens

GL_ARB_internalformat_query2 (ARB #131)

PFNGLGETMINMAXPARAMETERFVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMINMAXPARAMETERIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETMULTISAMPLEFVPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXENVFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXENVIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXGENIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETMULTITEXPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGetNamedFramebufferParameteriv

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC

GLScene.OpenGLTokens

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETNCOLORTABLEARBPROC

GLScene.OpenGLTokens

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETNCONVOLUTIONFILTERARBPROC

GLScene.OpenGLTokens

PFNGLGETNHISTOGRAMARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPDVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMAPIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNMINMAXARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPIXELMAPUSVARBPROC

GLScene.OpenGLTokens

PFNGLGETNPOLYGONSTIPPLEARBPROC

GLScene.OpenGLTokens

PFNGLGETNSEPARABLEFILTERARBPROC

GLScene.OpenGLTokens

PFNGLGETNTEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMDVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMFVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETNUNIFORMUIVARBPROC

GLScene.OpenGLTokens

PFNGLGetObjectLabel

GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETOBJECTPARAMETERIVARBPROC

GLScene.OpenGLTokens

PFNGLGetObjectPtrLabel

GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYIVNVPROC

GLScene.OpenGLTokens

PFNGLGETOCCLUSIONQUERYUIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOLORGENIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHDASHARRAYNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHLENGTHNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHMETRICRANGENVPROC

GLScene.OpenGLTokens

PFNGLGETPATHMETRICSNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHSPACINGNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHTEXGENFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPATHTEXGENIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPOINTERINDEXEDVEXTPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMBINARYPROC

GLScene.OpenGLTokens

GL_ARB_get_program_binary (ARB #96)

PFNGLGETPROGRAMENVPARAMETERDVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGetProgramInterfaceiv

GLScene.OpenGLTokens

GL_ARB_program_interface_query (ARB #134)

PFNGLGETPROGRAMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMIVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMIVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERDVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMPIPELINEIVPROC

GLScene.OpenGLTokens

PFNGLGetProgramResourceIndex

GLScene.OpenGLTokens

PFNGLGetProgramResourceiv

GLScene.OpenGLTokens

PFNGLGetProgramResourceLocation

GLScene.OpenGLTokens

PFNGLGetProgramResourceLocationIndex

GLScene.OpenGLTokens

PFNGLGetProgramResourceName

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTAGEIVPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGARBPROC

GLScene.OpenGLTokens

PFNGLGETPROGRAMSTRINGNVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYINDEXEDIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTI64VEXTPROC

GLScene.OpenGLTokens

GL_EXT_timer_query (EXT #319)

PFNGLGETQUERYOBJECTI64VPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTIVPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VEXTPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUI64VPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVARBPROC

GLScene.OpenGLTokens

PFNGLGETQUERYOBJECTUIVPROC

GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIFVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLGETSAMPLERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLGETSEPARABLEFILTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLGETSHADERINFOLOGPROC

GLScene.OpenGLTokens

PFNGLGETSHADERIVPROC

GLScene.OpenGLTokens

PFNGLGETSHADERPRECISIONFORMATPROC

GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEARBPROC

GLScene.OpenGLTokens

PFNGLGETSHADERSOURCEPROC

GLScene.OpenGLTokens

PFNGLGETSTRINGIPROC

GLScene.OpenGLTokens

PFNGLGETSUBROUTINEINDEXPROC

GLScene.OpenGLTokens

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC

GLScene.OpenGLTokens

GL_ARB_shader_subroutine (ARB #90)

PFNGLGETSYNCIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREIMAGEEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTEXTUREPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETTRACKMATRIXIVNVPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC

GLScene.OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMBLOCKINDEXPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMBUFFERSIZEEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMDVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMFVARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMFVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMINDICESPROC

GLScene.OpenGLTokens

GL_ARB_uniform_buffer_object (ARB #57)

PFNGLGETUNIFORMIVARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMIVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONARBPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMLOCATIONPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMOFFSETEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMSUBROUTINEUIVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETUNIFORMUIVPROC

GLScene.OpenGLTokens

PFNGLGETVARYINGLOCATIONNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBDVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBFVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBIVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBLDVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVARBPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVNVPROC

GLScene.OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVPROC

GLScene.OpenGLTokens

PFNGLHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated;

PFNGLINDEXFORMATNVPROC

GLScene.OpenGLTokens

PFNGLINDEXFUNCEXTPROC

GLScene.OpenGLTokens

GL_EXT_index_func (EXT #95)

PFNGLINDEXMATERIALEXTPROC

GLScene.OpenGLTokens

glGetColorTableParameterfvEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; glGetColorTableParameterivEXT: procedure(target, pname: Cardinal; params: Pointer); stdcall; GL_EXT_index_material (EXT #94)

PFNGLINTERPOLATEPATHSNVPROC

GLScene.OpenGLTokens

PFNGLInvalidateBufferData

GLScene.OpenGLTokens

PFNGLInvalidateBufferSubData

GLScene.OpenGLTokens

PFNGLInvalidateFramebuffer

GLScene.OpenGLTokens

PFNGLInvalidateSubFramebuffer

GLScene.OpenGLTokens

PFNGLInvalidateTexImage

GLScene.OpenGLTokens

PFNGLInvalidateTexSubImage

GLScene.OpenGLTokens

GL_ARB_invalidate_subdata (ARB #132)

PFNGLISBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLISBUFFERPROC

GLScene.OpenGLTokens

PFNGLISBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLISENABLEDINDEXEDEXTPROC

GLScene.OpenGLTokens

PFNGLISENABLEDIPROC

GLScene.OpenGLTokens

PFNGLISFENCENVPROC

GLScene.OpenGLTokens

PFNGLISFRAMEBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLISFRAMEBUFFERPROC

GLScene.OpenGLTokens

PFNGLISNAMEDBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLISOCCLUSIONQUERYNVPROC

GLScene.OpenGLTokens

PFNGLISPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPOINTINFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPOINTINSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLISPROGRAMPROC

GLScene.OpenGLTokens

PFNGLISQUERYARBPROC

GLScene.OpenGLTokens

PFNGLISQUERYPROC

GLScene.OpenGLTokens

PFNGLISRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_object (EXT #310)

PFNGLISRENDERBUFFERPROC

GLScene.OpenGLTokens

GL_ARB_framebuffer_object (ARB #45)

PFNGLISSAMPLERPROC

GLScene.OpenGLTokens

PFNGLISSHADERPROC

GLScene.OpenGLTokens

PFNGLISSYNCPROC

GLScene.OpenGLTokens

PFNGLISTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLISTRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLISVERTEXARRAYPROC

GLScene.OpenGLTokens

PFNGLLINKPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLLINKPROGRAMPROC

GLScene.OpenGLTokens

PFNGLLOADPROGRAMNVPROC

GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDARBPROC

GLScene.OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLLOADTRANSPOSEMATRIXFARBPROC

GLScene.OpenGLTokens

GL_ARB_transpose_matrix (ARB #3)

PFNGLLOADTRANSPOSEMATRIXFPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.3 from GL_ARB_transpose_matrix

PFNGLLOCKARRAYSEXTPROC

GLScene.OpenGLTokens

GL_EXT_compiled_vertex_array (EXT #97)

PFNGLMAKEBUFFERNONRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAKEBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

GL_NV_shader_buffer_load (EXT #379)

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERPROC

GLScene.OpenGLTokens

PFNGLMAPBUFFERRANGEPROC

GLScene.OpenGLTokens

GL_ARB_map_buffer_range (ARB #50)

PFNGLMAPNAMEDBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMAPNAMEDBUFFERRANGEEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXFRUSTUMEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUBVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUIVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXINDEXUSVARBPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADIDENTITYEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXORTHOEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXPOPEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXPUSHEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXROTATEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXROTATEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXSCALEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXSCALEFEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEDEXTPROC

GLScene.OpenGLTokens

PFNGLMATRIXTRANSLATEFEXTPROC

GLScene.OpenGLTokens

PFNGLMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMINSAMPLESHADINGARBPROC

GLScene.OpenGLTokens

GL_ARB_sample_shading (ARB #70)

PFNGLMINSAMPLESHADINGPROC

GLScene.OpenGLTokens

promoted to core v4.0 from GL_ARB_sample_shading (ARB #70)

PFNGLMULTIDRAWARRAYSEXTPROC

GLScene.OpenGLTokens

GL_EXT_multi_draw_arrays (EXT #148)

PFNGLMultiDrawArraysIndirect

GLScene.OpenGLTokens

GL_ARB_multi_draw_indirect (ARB #133)

PFNGLMULTIDRAWARRAYSPROC

GLScene.OpenGLTokens

promoted to core v1.4 from GL_EXT_multi_draw_arrays (#148)

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC

GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSEXTPROC

GLScene.OpenGLTokens

PFNGLMultiDrawElementsIndirect

GLScene.OpenGLTokens

PFNGLMULTIDRAWELEMENTSPROC

GLScene.OpenGLTokens

PFNGLMULTITEXBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD1SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD1SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD2SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD2SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD3SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4DARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4DVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4FARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4FVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4IARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4IVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4SARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORD4SVARBPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORD4SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTITEXCOORDP1UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP1UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP2UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP3UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDP4UIVPROC

GLScene.OpenGLTokens

PFNGLMULTITEXCOORDPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXENVIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENDEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENDVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXGENIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTITEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDARBPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDPROC

GLScene.OpenGLTokens

deprecated;

PFNGLMULTTRANSPOSEMATRIXFARBPROC

GLScene.OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFPROC

GLScene.OpenGLTokens

deprecated;

PFNGLNAMEDBUFFERDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC

GLScene.OpenGLTokens

PFNGLNamedFramebufferParameteri

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDPROGRAMSTRINGEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC

GLScene.OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

GLScene.OpenGLTokens

PFNGLNORMALFORMATNVPROC

GLScene.OpenGLTokens

PFNGLNORMALP3UIPROC

GLScene.OpenGLTokens

PFNGLNORMALP3UIVPROC

GLScene.OpenGLTokens

PFNGLObjectLabel

GLScene.OpenGLTokens

PFNGLObjectPtrLabel

GLScene.OpenGLTokens

PFNGLPATCHPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLPATCHPARAMETERIPROC

GLScene.OpenGLTokens

GL_ARB_tessellation_shader (ARB #91)

PFNGLPATHCOLORGENNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHCOVERDEPTHFUNCNVPROC

GLScene.OpenGLTokens

PFNGLPATHDASHARRAYNVPROC

GLScene.OpenGLTokens

PFNGLPATHFOGGENNVPROC

GLScene.OpenGLTokens

PFNGLPATHGLYPHRANGENVPROC

GLScene.OpenGLTokens

PFNGLPATHGLYPHSNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERFNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERFVNVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERINVPROC

GLScene.OpenGLTokens

PFNGLPATHPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTENCILDEPTHOFFSETNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTENCILFUNCNVPROC

GLScene.OpenGLTokens

PFNGLPATHSTRINGNVPROC

GLScene.OpenGLTokens

PFNGLPATHSUBCOMMANDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHSUBCOORDSNVPROC

GLScene.OpenGLTokens

PFNGLPATHTEXGENNVPROC

GLScene.OpenGLTokens

PFNGLPAUSETRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLPOINTALONGPATHNVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFARBPROC

GLScene.OpenGLTokens

GL_ARB_point_parameter (ARB #14)

PFNGLPOINTPARAMETERFPROC

GLScene.OpenGLTokens

promoted to core v1.4 from GL_ARB_point_parameters (#14), GL_NV_point_sprite (#262)

PFNGLPOINTPARAMETERFVARBPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERINVPROC

GLScene.OpenGLTokens

GL_NV_point_sprite (EXT #262)

PFNGLPOINTPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVNVPROC

GLScene.OpenGLTokens

PFNGLPOINTPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLPOLYGONOFFSETEXTPROC

GLScene.OpenGLTokens

GL_EXT_polygon_offset (EXT #3)

PFNGLPopDebugGroup

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXNVPROC

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXPROC

GLScene.OpenGLTokens

PFNGLPRIMITIVERESTARTNVPROC

GLScene.OpenGLTokens

GL_NV_primitive_restart (EXT #285)

PFNGLPRIORITIZETEXTURESEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMBINARYPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

GL_EXT_gpu_program_parameters (EXT #320)

PFNGLPROGRAMLOCALPARAMETER4DARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4DVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETER4FVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERIARBPROC

GLScene.OpenGLTokens

GL_ARB_geometry_shader4 (ARB #47)

PFNGLPROGRAMPARAMETERIEXTPROC

GLScene.OpenGLTokens

GL_EXT_geometry_shader4 (EXT #324)

PFNGLPROGRAMPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4DVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMPARAMETERS4FVNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMSTRINGARBPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM1UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM2UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM3UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4IVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORM4UIVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64NVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLPROGRAMVERTEXLIMITNVPROC

GLScene.OpenGLTokens

GL_NV_geometry_program4 (EXT #323)

PFNGLPROVOKINGVERTEXPROC

GLScene.OpenGLTokens

GL_ARB_provoking_vertex (ARB #64)

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC

GLScene.OpenGLTokens

PFNGLPushDebugGroup

GLScene.OpenGLTokens

GL_ARB_shader_stencil_export (ARB #106) (no entry points) GL_KHR_debug (ARB #119)

PFNGLQUERYCOUNTERPROC

GLScene.OpenGLTokens

GL_ARB_timer_query (ARB #85)

PFNGLREADNPIXELSARBPROC

GLScene.OpenGLTokens

PFNGLRELEASESHADERCOMPILERPROC

GLScene.OpenGLTokens

GL_ARB_ES2_compatibility (ARB #95)

PFNGLRENDERBUFFERSTORAGEEXTPROC

GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

GLScene.OpenGLTokens

GL_EXT_framebuffer_multisample (EXT #317)

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC

GLScene.OpenGLTokens

PFNGLRENDERBUFFERSTORAGEPROC

GLScene.OpenGLTokens

PFNGLREQUESTRESIDENTPROGRAMSNVPROC

GLScene.OpenGLTokens

PFNGLRESETHISTOGRAMPROC

GLScene.OpenGLTokens

deprecated;

PFNGLRESETMINMAXPROC

GLScene.OpenGLTokens

deprecated;

PFNGLRESIZEBUFFERSMESAPROC

GLScene.OpenGLTokens

GL_MESA_resize_buffers (EXT #196)

PFNGLRESUMETRANSFORMFEEDBACKPROC

GLScene.OpenGLTokens

PFNGLSAMPLECOVERAGEARBPROC

GLScene.OpenGLTokens

GL_ARB_multisample (ARB #5)

PFNGLSAMPLECOVERAGEPROC

GLScene.OpenGLTokens

promoted to core v1.3 from GL_ARB_multisample (#5)

PFNGLSAMPLEMASKEXTPROC

GLScene.OpenGLTokens

GL_EXT_multisample (EXT #209)

PFNGLSAMPLEMASKIPROC

GLScene.OpenGLTokens

PFNGLSAMPLEMASKSGISPROC

GLScene.OpenGLTokens

GL_SGIS_multisample (EXT #25)

PFNGLSAMPLEPASSARBPROC

GLScene.OpenGLTokens

ARB Extensions unknown ARB extension

PFNGLSAMPLEPATTERNEXTPROC

GLScene.OpenGLTokens

PFNGLSAMPLEPATTERNSGISPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERFVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIIVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLSAMPLERPARAMETERIVPROC

GLScene.OpenGLTokens

PFNGLSCISSORARRAYVPROC

GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDPROC

GLScene.OpenGLTokens

PFNGLSCISSORINDEXEDVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BEXTPROC

GLScene.OpenGLTokens

GL_EXT_secondary_color (EXT #145)

PFNGLSECONDARYCOLOR3BPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_EXT_secondary_color (#145)

PFNGLSECONDARYCOLOR3BVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3BVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3DEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3DVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3FEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3FVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3IEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3IVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3SEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3SVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UBEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UBVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UBVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UIEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3UIVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3USEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLOR3USVEXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLOR3USVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSECONDARYCOLORFORMATNVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORP3UIVPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLSECONDARYCOLORPOINTERPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSEPARABLEFILTER2DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLSETFENCENVPROC

GLScene.OpenGLTokens

PFNGLSHADERBINARYPROC

GLScene.OpenGLTokens

PFNGLSHADERSOURCEARBPROC

GLScene.OpenGLTokens

PFNGLSHADERSOURCEPROC

GLScene.OpenGLTokens

PFNGLShaderStorageBlockBinding

GLScene.OpenGLTokens

GL_ARB_robust_buffer_access_behavior (ARB #135) (no entry points) GL_ARB_shader_image_size (ARB #136) (no entry points) GL_ARB_shader_storage_buffer_object (ARB #137)

PFNGLSTENCILCLEARTAGEXTPROC

GLScene.OpenGLTokens

GL_EXT_stencil_clear_tag (EXT #314)

PFNGLSTENCILFILLPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILFILLPATHNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILFUNCSEPARATEPROC

GLScene.OpenGLTokens

PFNGLSTENCILMASKSEPARATEPROC

GLScene.OpenGLTokens

PFNGLSTENCILOPSEPARATEPROC

GLScene.OpenGLTokens

promoted to core v2.0 from GL_ARB_stencil_two_side (no # found)

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC

GLScene.OpenGLTokens

PFNGLSTENCILSTROKEPATHNVPROC

GLScene.OpenGLTokens

PFNGLSTRINGMARKERGREMEDYPROC

GLScene.OpenGLTokens

GL_GREMEDY_string_marker (EXT #311)

PFNGLTBUFFERMASK3DFXPROC

GLScene.OpenGLTokens

GL_3DFX_tbuffer (EXT #208)

PFNGLTESSELLATIONFACTORAMDPROC

GLScene.OpenGLTokens

GL_AMD_vertex_shader_tessellator (EXT #363)

PFNGLTESSELLATIONMODEAMDPROC

GLScene.OpenGLTokens

PFNGLTESTFENCENVPROC

GLScene.OpenGLTokens

PFNGLTEXBUFFERARBPROC

GLScene.OpenGLTokens

GL_ARB_texture_buffer_object (ARB #51)

PFNGLTEXBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_packed_float (EXT #328) WGL_EXT_pixel_format_packed_float GLX_EXT_fbconfig_packed_float GL_EXT_texture_array (EXT #329) glFramebufferTextureLayerEXT: procedure(target: Cardinal; attachment: Cardinal; texture: Cardinal; level: TGLint; layer: TGLint); GL_EXT_texture_buffer_object (EXT #330)

PFNGLTEXBUFFERPROC

GLScene.OpenGLTokens

PFNGLTexBufferRange

GLScene.OpenGLTokens

GL_ARB_stencil_texturing (ARB #138) (no entry points) GL_ARB_texture_buffer_range (ARB #139)

PFNGLTEXCOORDFORMATNVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP1UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP2UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP3UIVPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIPROC

GLScene.OpenGLTokens

PFNGLTEXCOORDP4UIVPROC

GLScene.OpenGLTokens

PFNGLTEXIMAGE2DMULTISAMPLEPROC

GLScene.OpenGLTokens

GL_ARB_texture_multisample (ARB #67)

PFNGLTEXIMAGE3DEXTPROC

GLScene.OpenGLTokens

GL_EXT_texture3D (EXT #6)

PFNGLTEXIMAGE3DMULTISAMPLEPROC

GLScene.OpenGLTokens

PFNGLTEXIMAGE3DPROC

GLScene.OpenGLTokens

promoted to core v1.2 from GL_EXT_texture3D (#6)

PFNGLTEXPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXPARAMETERIIVPROC

GLScene.OpenGLTokens

promoted to core v3.0 from GL_EXT_texture_integer

PFNGLTEXPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXPARAMETERIUIVPROC

GLScene.OpenGLTokens

PFNGLTexStorage2DMultisample

GLScene.OpenGLTokens

GL_ARB_texture_query_levels (ARB #140) (no entry points) GL_ARB_texture_storage_multisample (ARB #141)

PFNGLTexStorage3DMultisample

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

GL_EXT_subtexture (EXT #9)

PFNGLTEXSUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXSUBIMAGE3DPROC

GLScene.OpenGLTokens

PFNGLTEXTUREBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLTextureBufferRange

GLScene.OpenGLTokens

PFNGLTEXTURECOLORMASKSGISPROC

GLScene.OpenGLTokens

GL_SGIS_texture_color_mask (EXT #214)

PFNGLTEXTUREIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERFVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIUIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTUREPARAMETERIVEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURERENDERBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLTextureStorage2DMultisample

GLScene.OpenGLTokens

PFNGLTextureStorage3DMultisample

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE1DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE2DEXTPROC

GLScene.OpenGLTokens

PFNGLTEXTURESUBIMAGE3DEXTPROC

GLScene.OpenGLTokens

PFNGLTextureView

GLScene.OpenGLTokens

GL_ARB_texture_view (ARB #124)

PFNGLTRACKMATRIXNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSPROC

GLScene.OpenGLTokens

PFNGLTRANSFORMPATHNVPROC

GLScene.OpenGLTokens

PFNGLUDELETENURBSTESSELLATOREXTPROC

GLScene.OpenGLTokens

PFNGLUNEWNURBSTESSELLATOREXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1DPROC

GLScene.OpenGLTokens

GL_ARB_gpu_shader_fp64 (ARB #89)

PFNGLUNIFORM1DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM1UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM2UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM3UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4DPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4IVPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLUNIFORM4UIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMBLOCKBINDINGPROC

GLScene.OpenGLTokens

PFNGLUNIFORMBUFFEREXTPROC

GLScene.OpenGLTokens

GL_EXT_bindable_uniform (EXT #342)

PFNGLUNIFORMMATRIX2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X3FVPROC

GLScene.OpenGLTokens

core 2.1 new commands in OpenGL 2.1

PFNGLUNIFORMMATRIX2X4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX2X4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX3X4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVARBPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X2FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3DVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMMATRIX4X3FVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMSUBROUTINESUIVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMUI64NVPROC

GLScene.OpenGLTokens

PFNGLUNIFORMUI64VNVPROC

GLScene.OpenGLTokens

PFNGLUNLOCKARRAYSEXTPROC

GLScene.OpenGLTokens

PFNGLUNMAPBUFFERARBPROC

GLScene.OpenGLTokens

PFNGLUNMAPBUFFERPROC

GLScene.OpenGLTokens

PFNGLUNMAPNAMEDBUFFEREXTPROC

GLScene.OpenGLTokens

PFNGLUNURBSCALLBACKDATAEXTPROC

GLScene.OpenGLTokens

GLU extensions (might not be same naming as c versions?)

PFNGLUSEPROGRAMOBJECTARBPROC

GLScene.OpenGLTokens

PFNGLUSEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLUSEPROGRAMSTAGESPROC

GLScene.OpenGLTokens

GL_ARB_separate_shader_objects (ARB #97)

PFNGLVALIDATEPROGRAMARBPROC

GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPIPELINEPROC

GLScene.OpenGLTokens

PFNGLVALIDATEPROGRAMPROC

GLScene.OpenGLTokens

PFNGLVertexArrayBindVertexBuffer

GLScene.OpenGLTokens

PFNGLVERTEXARRAYRANGENVPROC

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribBinding

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribFormat

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribIFormat

GLScene.OpenGLTokens

PFNGLVertexArrayVertexAttribLFormat

GLScene.OpenGLTokens

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC

GLScene.OpenGLTokens

VertexArrayVertexAttribLOffsetEXT only valid if EXT_direct_state_access is available

PFNGLVertexArrayVertexBindingDivisor

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_program (ARB #26)

PFNGLVERTEXATTRIB1DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB1SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB2SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB3SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4BVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4FVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NSVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4NUSVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIB4USVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribBinding

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBDIVISORARBPROC

GLScene.OpenGLTokens

GL_ARB_instanced_arrays (ARB #49)

PFNGLVERTEXATTRIBDIVISORPROC

GLScene.OpenGLTokens

Core 3.3

PFNGLVertexAttribFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IEXTPROC

GLScene.OpenGLTokens

GL_EXT_gpu_shader4 (EXT #326)

PFNGLVERTEXATTRIBI1IPROC

GLScene.OpenGLTokens

Core 3.0 promoted to core v3.0 from GL_EXT_gpu_shader4

PFNGLVERTEXATTRIBI1IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI1UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4BVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4IVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4SVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UBVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVEXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBI4USVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribIFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTEREXTPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBIPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL1DPROC

GLScene.OpenGLTokens

GL_ARB_shader_precision (ARB #98) (no entry points) GL_ARB_vertex_attrib_64bit (ARB #99)

PFNGLVERTEXATTRIBL1DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL2DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL3DVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBL4DVPROC

GLScene.OpenGLTokens

PFNGLVertexAttribLFormat

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBLPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP1UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBP4UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBPOINTERPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS1SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS2SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS3SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4DVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4FVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4SVNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXATTRIBS4UBVNVPROC

GLScene.OpenGLTokens

PFNGLVertexBindingDivisor

GLScene.OpenGLTokens

PFNGLVERTEXBLENDARBPROC

GLScene.OpenGLTokens

PFNGLVERTEXFORMATNVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP2UIPROC

GLScene.OpenGLTokens

GL_ARB_vertex_type_2_10_10_10_rev (ARB #86)

PFNGLVERTEXP2UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP3UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXP3UIVPROC

GLScene.OpenGLTokens

PFNGLVERTEXP4UIPROC

GLScene.OpenGLTokens

PFNGLVERTEXP4UIVPROC

GLScene.OpenGLTokens

PFNGLVIEWPORTARRAYVPROC

GLScene.OpenGLTokens

GL_ARB_viewport_array (ARB #100)

PFNGLVIEWPORTINDEXEDFPROC

GLScene.OpenGLTokens

PFNGLVIEWPORTINDEXEDFVPROC

GLScene.OpenGLTokens

PFNGLWAITSYNCPROC

GLScene.OpenGLTokens

PFNGLWEIGHTBVARBPROC

GLScene.OpenGLTokens

GL_ARB_vertex_blend (ARB #15) {deprecated?}

PFNGLWEIGHTDVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTFVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTIVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTPATHSNVPROC

GLScene.OpenGLTokens

PFNGLWEIGHTPOINTERARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTSVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUBVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUIVARBPROC

GLScene.OpenGLTokens

PFNGLWEIGHTUSVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2DARBPROC

GLScene.OpenGLTokens

GL_ARB_window_pos (ARB #25)

PFNGLWINDOWPOS2DPROC

GLScene.OpenGLTokens

deprecated; promoted to core v1.4 from GL_ARB_window_pos (#25)

PFNGLWINDOWPOS2DVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2FARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2FVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2IARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2IVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2SARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS2SVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS2SVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3DARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3DPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3DVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3DVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3FARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3FPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3FVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3FVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3IARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3IPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3IVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3IVPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3SARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3SPROC

GLScene.OpenGLTokens

deprecated;

PFNGLWINDOWPOS3SVARBPROC

GLScene.OpenGLTokens

PFNGLWINDOWPOS3SVPROC

GLScene.OpenGLTokens

deprecated;

PFNWGLALLOCATEMEMORYNVPROC

GLScene.OpenGLTokens

PFNWGLBINDTEXIMAGEARBPROC

GLScene.OpenGLTokens

WGL_ARB_render_texture (ARB #20)

PFNWGLCHOOSEPIXELFORMATARBPROC

GLScene.OpenGLTokens

PFNWGLCREATEAFFINITYDCNVPROC

GLScene.OpenGLTokens

PFNWGLCREATEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

WGL WGL - ARB WGL_buffer_region (ARB #4)

PFNWGLCREATECONTEXTATTRIBSARBPROC

GLScene.OpenGLTokens

WGL_ARB_create_context (ARB #55)

PFNWGLCREATEPBUFFERARBPROC

GLScene.OpenGLTokens

WGL_ARB_pbuffer (ARB #11)

PFNWGLDELETEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLDELETEDCNVPROC

GLScene.OpenGLTokens

PFNWGLDESTROYPBUFFERARBPROC

GLScene.OpenGLTokens

PFNWGLDXCLOSEDEVICEPROC

GLScene.OpenGLTokens

PFNWGLDXLOCKOBJECTSPROC

GLScene.OpenGLTokens

PFNWGLDXOBJECTACCESSPROC

GLScene.OpenGLTokens

PFNWGLDXOPENDEVICEPROC

GLScene.OpenGLTokens

PFNWGLDXREGISTEROBJECTPROC

GLScene.OpenGLTokens

PFNWGLDXSETRESOURCESHAREHANDLEPROC

GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)

PFNWGLDXUNLOCKOBJECTSNVPROC

GLScene.OpenGLTokens

PFNWGLDXUNREGISTEROBJECTPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUDEVICESNVPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC

GLScene.OpenGLTokens

PFNWGLENUMGPUSNVPROC

GLScene.OpenGLTokens

WGL_NV_gpu_affinity (EXT #355)

PFNWGLFREEMEMORYNVPROC

GLScene.OpenGLTokens

PFNWGLGETCURRENTREADDCARBPROC

GLScene.OpenGLTokens

PFNWGLGETEXTENSIONSSTRINGARBPROC

GLScene.OpenGLTokens

WGL_ARB_extensions_string (ARB #8)

PFNWGLGETPBUFFERDCARBPROC

GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBFVARBPROC

GLScene.OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBIVARBPROC

GLScene.OpenGLTokens

WGL_ARB_pixel_format (ARB #9)

PFNWGLGETSWAPINTERVALEXTPROC

GLScene.OpenGLTokens

PFNWGLMAKECONTEXTCURRENTARBPROC

GLScene.OpenGLTokens

WGL_make_current_read (ARB #10)

PFNWGLQUERYPBUFFERARBPROC

GLScene.OpenGLTokens

PFNWGLRELEASEPBUFFERDCARBPROC

GLScene.OpenGLTokens

PFNWGLRELEASETEXIMAGEARBPROC

GLScene.OpenGLTokens

PFNWGLRESTOREBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLSAVEBUFFERREGIONARBPROC

GLScene.OpenGLTokens

PFNWGLSETPBUFFERATTRIBARBPROC

GLScene.OpenGLTokens

PFNWGLSWAPINTERVALEXTPROC

GLScene.OpenGLTokens

WGL - EXT WGL_EXT_swap_control (EXT #172)

PFontEntry

GXS.SpaceText

Holds an entry in the font manager list (used in TgxSpaceText)

PFrustum

GLScene.VectorGeometry

PFXPointerList

GXS.ParticleFX

PGLbitfield

GLScene.OpenGL4

PGLbitfield

GLScene.OpenGLTokens

UINT

PGLboolean

GLScene.OpenGL4

PGLboolean

GLScene.OpenGLTokens

PGLbyte

GLScene.OpenGL4

PGLbyte

GLScene.OpenGLTokens

PGLChar

GLScene.OpenGL4

PGLchar

GLScene.OpenGLTokens

PGLclampd

GLScene.OpenGL4

PGLclampd

GLScene.OpenGLTokens

PGLclampf

GLScene.OpenGL4

PGLclampf

GLScene.OpenGLTokens

PGLdouble

GLScene.OpenGL4

PGLdouble

GLScene.OpenGLTokens

PGLenum

GLScene.OpenGL4

PGLenum

GLScene.OpenGLTokens

PGLfloat

GLScene.OpenGL4

PGLfloat

GLScene.OpenGLTokens

PGLhalf

GLScene.OpenGLTokens

PGLhandleARB

GLScene.OpenGL4

PGLhandleARB

GLScene.OpenGLTokens

PGLint

GLScene.OpenGL4

PGLint

GLScene.OpenGLTokens

PGLint64

GLScene.OpenGL4

PGLint64

GLScene.OpenGLTokens

PGLint64EXT

GLScene.OpenGL4

PGLint64EXT

GLScene.OpenGLTokens

PGLintptr

GLScene.OpenGL4

PGLintptr

GLScene.OpenGLTokens

PGLMatrix

GLScene.VectorTypes

The matrix by default

PGLParticleArray

GXS.ParticleFX

PGLPCharArray

GLScene.OpenGL4

PGLPCharArray

GLScene.OpenGLTokens

PGLPointer

GLScene.OpenGL4

PGLPointer

GLScene.OpenGLTokens

PGLshort

GLScene.OpenGL4

PGLshort

GLScene.OpenGLTokens

PGLsizei

GLScene.OpenGL4

PGLsizei

GLScene.OpenGLTokens

PGLsizeiptr

GLScene.OpenGLTokens

PGLsync

GLScene.OpenGLTokens

PGLubyte

GLScene.OpenGL4

PGLubyte

GLScene.OpenGLTokens

PGLuint

GLScene.OpenGL4

PGLuint

GLScene.OpenGLTokens

PGLuint64

GLScene.OpenGL4

PGLuint64

GLScene.OpenGLTokens

PGLuint64EXT

GLScene.OpenGL4

PGLuint64EXT

GLScene.OpenGLTokens

PGLUNurbs

GLScene.OpenGL4

PGLUNurbs

GLScene.OpenGLTokens

PGLUNurbsObj

GLScene.OpenGL4

PGLUNurbsObj

GLScene.OpenGLTokens

PGLUQuadric

GLScene.OpenGL4

PGLUQuadric

GLScene.OpenGLTokens

PGLUQuadricObj

GLScene.OpenGL4

PGLUQuadricObj

GLScene.OpenGLTokens

PGLushort

GLScene.OpenGL4

PGLushort

GLScene.OpenGLTokens

PGLUTesselator

GLScene.OpenGL4

PGLUTesselator

GLScene.OpenGLTokens

PGLUTesselatorObj

GLScene.OpenGL4

PGLUTesselatorObj

GLScene.OpenGLTokens

PGLUTriangulatorObj

GLScene.OpenGL4

PGLUTriangulatorObj

GLScene.OpenGLTokens

PGLvdpauSurfaceNV

GLScene.OpenGLTokens

PGLVector

GLScene.VectorTypes

The vector by default

PGLvoid

GLScene.OpenGL4

PGLvoid

GLScene.OpenGLTokens

PGNGLGETBUFFERPARAMETERUI64VNV

GLScene.OpenGLTokens

PGPUDEVICE

GLScene.OpenGL4

PGPUDEVICE

GLScene.OpenGLTokens

PgTransformationRec

GLScene.PipelineTransform

PgxHeightTileInfo

GXS.HeightTileFile

PgxOctreeNode

GXS.Octree

PgxOctreeTriangleInfo

GXS.Octree

PgxPixel24

GXS.Graphics

PgxPixel32

GXS.Graphics

PgxPixel32Array

GXS.Graphics

PgxRCHandle

GXS.Context

PGXRenderContextInfo

GXS.RenderContextInfo

PgxStarRecord

GXS.Skydome

PgxVertexBoneWeightArray

GXS.VectorFileObjects

PgxVertexData

GXS.Mesh

PgxVerticesBoneWeights

GXS.VectorFileObjects

PgxVideoMode

GXS.Screen

PHalfFloat

GLScene.Utils

PHeightTile

GXS.HeightTileFile

PHGPUNV

GLScene.OpenGL4

—————————- OpenGL Utility (GLU) types ——————–

PHGPUNV

GLScene.OpenGLTokens

PHmgBoundingBox

GLScene.GeometryBB

Structure for storing Bounding Boxes

PHomogeneousByteVector

GLScene.VectorGeometry

Common vector and matrix types with predefined limits indices correspond like: x -> 0 y -> 1 z -> 2 w -> 3

PHomogeneousDblVector

GLScene.VectorGeometry

PHomogeneousExtVector

GLScene.VectorGeometry

PHomogeneousFltVector

GLScene.VectorGeometry

PHomogeneousIntVector

GLScene.VectorGeometry

PHomogeneousMatrix

GLScene.VectorGeometry

PHomogeneousPtrVector

GLScene.VectorGeometry

PHomogeneousVector

GLScene.VectorGeometry

some simplified names

PHomogeneousWordVector

GLScene.VectorGeometry

PHVIDEOINPUTDEVICENV

GLScene.OpenGL4

PHVIDEOINPUTDEVICENV

GLScene.OpenGLTokens

PInstPropList

FMxXCollectionEditor

PIntegerArray

GLScene.VectorGeometry

PIntegerArray

GXS.HeightTileFile

PIntegerVector

GLScene.VectorGeometry

PIntermediateFormatArray

GXS.ImageUtils

Pitch

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its X-axis

Pitch

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterRight

PixelFormatToColorBits

GXS.ImageUtils

Returns the number of color bits associated to the given pixel format.

PlaneAABBIntersection

GLScene.GeometryBB

Compute the intersection between a plane and the AABB

PlaneContainsBSphere

GLScene.GeometryBB

Determines to which extent a plane contains a BSphere

PlaneEvaluatePoint

GLScene.VectorGeometry

PlaneEvaluatePoint

GLScene.VectorGeometry

Calculates the cross-product between the plane normal and plane to point vector. This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive. This function performs an homogeneous space dot-product.

PlaneIntersectAABB

GLScene.GeometryBB

Checks if a plane (given by the normal+d) intersects the AABB

PlaneMake

GLScene.VectorGeometry

PlaneMake

GLScene.VectorGeometry

PlaneMake

GLScene.VectorGeometry

Computes the parameters of a plane defined by a point and a normal.

PlaneMake

GLScene.VectorGeometry

Computes the parameters of a plane defined by three points.

PlayOnWaveOut

GXS.Sounds.WaveOut

PlayOnWaveOut

GXS.Sounds.WaveOut

PlaySound

uGBESound

PLMTS

GXS.FileLMTS

PLMTS_Header

GXS.FileLMTS

max texture filename length

PLMTS_Subset

GXS.FileLMTS

PLMTS_TexData

GXS.FileLMTS

PLMTS_Vertex

GXS.FileLMTS

PLongWordArray

GLScene.VectorGeometry

PLongWordVector

GLScene.VectorGeometry

PMatrix4f

GLScene.VectorTypes

the matrix by default

PMatrixArray

GLScene.VectorGeometry

PMatrixRec

GLScene.VectorTypesExt

PMDCTagFrame

GXS.FileMDC

PMDCTagName

GXS.FileMDC

pMS3DComment

GXS.FileMS3D

PMS3DJointArray

GXS.FileMS3D

PMS3DKeyframePositionArray

GXS.FileMS3D

PMS3DKeyframeRotationArray

GXS.FileMS3D

PMS3DTriangleArray

GXS.FileMS3D

PMS3DVertexArray

GXS.FileMS3D

pMS3D_vertex_ex_t

GXS.FileMS3D

PointAdd

GLScene.VectorGeometry

Returns the sum of two homogeneous vectors. W coordinate is always 1.

PointDiskOrthoProjection

GLScene.VectorGeometry

Computes point to disk projection. Direction has to be normalized

PointDiskProjection

GLScene.VectorGeometry

PointInAABB

GLScene.GeometryBB

PointInAABB

GLScene.GeometryBB

Checks if a point "p" is inside an AABB

PointInPolygon

GLScene.VectorGeometry

The code below is from Wm. Randolph Franklin <wrf@ecse.rpi.edu> with some minor modifications for speed. It returns 1 for strictly interior points, 0 for strictly exterior, and 0 or 1 for points on the boundary

PointIsInHalfSpace

GLScene.VectorGeometry

PointIsInHalfSpace

GLScene.VectorGeometry

PointIsInHalfSpace

GLScene.VectorGeometry

Returns true if point is in the half-space defined by a plane with normal. The plane itself is not considered to be in the tested halfspace.

PointLineClosestPoint

GLScene.VectorGeometry

Computes closest point on a line

PointLineDistance

GLScene.VectorGeometry

Computes algebraic distance between point and line

PointMake

GLScene.VectorGeometry

PointMake

GLScene.VectorGeometry

PointMake

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

PointPlaneDistance

GLScene.VectorGeometry

Computes algebraic distance between point and plane. Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

PointPlaneOrthoProjection

GLScene.VectorGeometry

Computes point to plane projection. Plane and direction have to be normalized

PointPlaneProjection

GLScene.VectorGeometry

PointProject

GLScene.VectorGeometry

PointProject

GLScene.VectorGeometry

Projects p on the line defined by o and direction. Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line

PointQuadOrthoProjection

GLScene.VectorGeometry

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

PointQuadProjection

GLScene.VectorGeometry

PointSegmentClosestPoint

GLScene.VectorGeometry

PointSegmentClosestPoint

GLScene.VectorGeometry

Computes closest point on a segment (a segment is a limited line)

PointSegmentDistance

GLScene.VectorGeometry

Computes algebraic distance between segment and line (a segment is a limited line)

PointTriangleOrthoProjection

GLScene.VectorGeometry

Computes point to triangle projection. Direction has to be normalized

PointTriangleProjection

GLScene.VectorGeometry

PolygonArea

GLScene.VectorGeometry

Computes the polygons's area. Points must be coplanar. Polygon needs not be convex

PolygonSignedArea

GLScene.VectorGeometry

Computes a 2D polygon's signed area. Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex

PositionSceneObject

GXS.ODEUtils

PositionSceneObjectForGeom

GXS.ODEUtils

PowerInt64

GLScene.VectorGeometry

PowerInteger

GLScene.VectorGeometry

Raise base to an integer

PowerSingle

GLScene.VectorGeometry

Raise base to any power. For fractional exponents, or |exponents| > MaxInt, base must be > 0

PParticleReference

GXS.ParticleFX

PParticleReferenceArray

GXS.ParticleFX

PPFXRegion

GXS.ParticleFX

PPHeightTileInfo

GXS.HeightTileFile

PPoint2DRec

GLScene.VectorTypesExt

PPoint3DRec

GLScene.VectorTypesExt

PPointerArray

GLScene.VectorGeometry

PPointerVector

GLScene.VectorGeometry

PQuaternion

GLScene.VectorGeometry

q = ([x, y, z], w)

PQuaternionArray

GLScene.VectorGeometry

PrecisionTimerLap

GLScene.Utils

Computes time elapsed since timer start. Return time lap in seconds.

PrepareSinCosCache

GLScene.VectorGeometry

Fills up the two given dynamic arrays with sin cos values. start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

PRGBA32F

GXS.ImageUtils

PrimerIsland

GXS.RandomHDS

PrimerNull

GXS.RandomHDS

Landscape primers

PROAMTriangleNode

GXS.ROAMPatch

Project

GLScene.VectorGeometry

PSceneObjectEntry

GXS.ObjectManager

PShortIntArray

GXS.HeightTileFile

PSingleArray

GLScene.VectorGeometry

PSingleRaster

GXS.HeightData

PSmallIntArray

GXS.HeightData

PSmallIntArray

GXS.HeightTileFile

PSmallIntRaster

GXS.HeightData

PSoundFileFormat

GXS.SoundFileObjects

PSqrt255Array

GLScene.Utils

PTexPoint

GLScene.VectorGeometry

PTexPointArray

GLScene.VectorGeometry

PThorpoint

GXS.ThorFX

PThorpointArray

GXS.ThorFX

PTriangleRecArray

GLScene.VectorTypesExt

PVector2f

GLScene.VectorGeometry

PVector4f

GLScene.VectorTypes

PVectorArray

GLScene.VectorGeometry

PVectorRec

GLScene.VectorTypesExt

PVertArray

GLScene.VectorTypesExt

PVertex

GLScene.VectorGeometry

PVertex2DArr

GXS.Isolines

PVertexRec

GXS.Objects

PVKVertexDataArray

GXS.Mesh

PVoxelData

GLScene.VectorTypesExt

PVoxelRec

GLScene.VectorTypesExt

PVXIsoline

GXS.Isolines

PWGLSwap

GLScene.OpenGL4

PWGLswap

GLScene.OpenGLTokens

========= Windows types ==============

PWordVector

GLScene.VectorGeometry

PZArray

GXS.zBuffer

QuaternionConjugate

GLScene.VectorGeometry

Returns the conjugate of a quaternion

QuaternionFromAngleAxis

GLScene.VectorGeometry

Constructs quaternion from angle (in deg) and axis

QuaternionFromEuler

GLScene.VectorGeometry

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

QuaternionFromMatrix

GLScene.VectorGeometry

Constructs a unit quaternion from a rotation matrix

QuaternionFromPoints

GLScene.VectorGeometry

Constructs a unit quaternion from two points on unit sphere

QuaternionFromRollPitchYaw

GLScene.VectorGeometry

Constructs quaternion from Euler angles

QuaternionMagnitude

GLScene.VectorGeometry

Returns the magnitude of the quaternion

QuaternionMake

GLScene.VectorGeometry

QuaternionMake

GLScene.VectorGeometry

QuaternionMake

GLScene.VectorGeometry

Creates a quaternion from the given values

QuaternionMultiply

GLScene.VectorGeometry

Returns quaternion product qL * qR. Note: order is important! To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond

QuaternionSlerp

GLScene.VectorGeometry

QuaternionSlerp

GLScene.VectorGeometry

Spherical linear interpolation of unit quaternions with spins. QStart, QEnd - start and end unit quaternions t - interpolation parameter (0 to 1) Spin - number of extra spin rotations to involve

QuaternionToAffineMatrix

GLScene.VectorGeometry

Constructs an affine rotation matrix from (possibly non-unit) quaternion

QuaternionToMatrix

GLScene.VectorGeometry

Constructs a rotation matrix from (possibly non-unit) quaternion. Assumes matrix is used to multiply column vector on the left: vnew = mat vold. Works correctly for right-handed coordinate system and right-handed rotations

QuaternionToPoints

GLScene.VectorGeometry

Converts a unit quaternion into two points on a unit sphere

QueryPerformanceCounter

GLScene.Utils

Returns the current value of the highest-resolution counter. If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

QueryPerformanceFrequency

GLScene.Utils

Returns the frequency of the counter used by QueryPerformanceCounter. Return value is in ticks per second (Hz), returns False if no precision counter is available.

QuestionDlg

GXS.ImageUtils

Pops up a simple question dialog with msg and yes/no buttons. Returns True if answer was "yes".

RadianToDeg

GLScene.VectorGeometry

RadianToDeg

GLScene.VectorGeometry

RaiseLastOSError

GLScene.Utils

RaiseOpenGLError

GLScene.OpenGL4

Clears all pending OpenGL errors

RandEmpiric

GLScene.RandomLib

Random Number for Empiricle Distribution X[I] - middle of I-interval Fx[I] - cummulative empiricle distribution with values in [0..1]

RandExponent

GLScene.RandomLib

RandGauss

GLScene.RandomLib

Marsaglia-Bray algorithm

RandLogNorm

GLScene.RandomLib

RandNorm

GLScene.RandomLib

RandomColorVector

GXS.ODEUtils

RandomPointOnSphere

GLScene.VectorGeometry

Generates a random point on the unit sphere. Point repartition is correctly isotropic with no privilegied direction

Random_Beta

GLScene.RandomLib

Random_Beta

GLScene.RandomLib

Generates a random variate in [0,1] FROM A BETA DISTRIBUTION WITH DENSITY PROPORTIONAL TO BETA**(AA-1) * (1-BETA)**(BB-1). USING CHENG'S LOG LOGISTIC METHOD. AA = Shape PARAMETER FROM DISTRIBUTION (0 < REAL) BB = Shape PARAMETER FROM DISTRIBUTION (0 < REAL)

Random_Binomial1

GLScene.RandomLib

Random_Binomial1

GLScene.RandomLib

GENERATES A RANDOM BINOMIAL VARIATE USING C.D.Kemp's method. This algorithm is suitable when many random variates are required with the SAME parameter values for n & p. P = Bernoulli SUCCESS PROBABILITY (0 <= REAL <= 1) N = Number of Bernoulli trials (1 <= INTEGER) Reference: Kemp, C.D. (1986). `A modal method for generating binomial variables', Commun. Statist. - Theor. Meth. 15(3), 805-813.

Random_Binomial2

GLScene.RandomLib

FIRST –> Set FIRST = .TRUE. for the first call to perform initialization the set FIRST = .FALSE. for further calls using the same pair of parameter values (N, P). LOGICAL FIRST random_binomial2 <– A random deviate yielding the number of events from N independent trials, each of which has a probability of event P. INTEGER –> random_binomial Method: This is algorithm BTPE from: Kachitvichyanukul, V. and Schmeiser, B. W. Binomial Random Variate Generation. Communications of the ACM, 31, 2 (February, 1988) 216.

Random_Binomial2

GLScene.RandomLib

Generates a single random deviate from a binomial distribution whose number of trials is N and whose probability of an event in each trial is P.
Arguments N –> The number of trials in the binomial distribution from which a random deviate is to be generated. INTEGER N P –> The probability of an event in each trial of the binomial distribution from which a random deviate is to be generated. REAL P

Random_Cauchy

GLScene.RandomLib

Random_Cauchy

GLScene.RandomLib

Generate a random deviate from the standard Cauchy distribution

Random_ChiSq

GLScene.RandomLib

Random_ChiSq

GLScene.RandomLib

Generates a random variate from the chi-squared distribution with dff degrees of freedom.

Random_Exponential

GLScene.RandomLib

Random_Exponential

GLScene.RandomLib

Generates a random variate in [0,INFINITY) FROM A NEGATIVE EXPONENTIAL DlSTRIBUTION WlTH DENSITY PROPORTIONAL TO EXP(-random_exponential), USING INVERSION.

Random_Gamma

GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL)

Random_Gamma

GLScene.RandomLib

GENERATES A RANDOM GAMMA VARIATE. CALLS EITHER random_gamma1 (Shape > 1.0) OR random_exponential (Shape = 1.0) OR random_gamma2 (Shape < 1.0). Shape = Shape PARAMETER OF DISTRIBUTION (0 < REAL).

Random_Gamma1

GLScene.RandomLib

Uses the algorithm in Marsaglia, G. and Tsang, W.W. (2000) 'A simple method for generating gamma variables', Trans. om Math. Software (TOMS), vol.26(3), pp.363-372. Generates a random gamma deviate for shape parameter Shape >= 1.

Random_Inv_Gauss

GLScene.RandomLib

Random_Inv_Gauss

GLScene.RandomLib

Generates a random variate in [0,INFINITY] FROM A REPARAMETERISED GENERALISED INVERSE GAUSSIAN (GIG) DISTRIBUTION WITH DENSITY PROPORTIONAL TO GIG**(H-1) * EXP(-0.5*B*(GIG+1/GIG)) USING A RATIO METHOD.
h = PARAMETER OF DISTRIBUTION (0 <= REAL) b = PARAMETER OF DISTRIBUTION (0 < REAL)

Random_LogNormal

GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.

Random_LogNormal

GLScene.RandomLib

Adapted from approach suggested by Greg Hood, used with Permission.

Random_MVNorm

GLScene.RandomLib

Random_MVNorm

GLScene.RandomLib

GENERATES AN N VARIATE RANDOM NORMAL Vector USING A CHOLESKY DECOMPOSITION.
ARGUMENTS: N = NUMBER OF VARIATES IN Vector (INPUT,INTEGER >= 1) H(J) = J'TH ELEMENT OF Vector OF MEANS (INPUT,REAL) X(J) = J'TH ELEMENT OF DELIVERED Vector (OUTPUT,REAL)
D(J*(J-1)/2+I) = (I,J)'TH ELEMENT OF VARIANCE MATRIX (J> = I) (INPUT,REAL) F((J-1)*(2*N-J)/2+I) = (I,J)'TH ELEMENT OF LOWER TRIANGULAR DECOMPOSITION OF VARIANCE MATRIX (J <= I) (OUTPUT,REAL) ier = 1 if the input covariance matrix is not +ve definite = 0 otherwise

Random_Neg_Binomial

GLScene.RandomLib

Random_Neg_Binomial

GLScene.RandomLib

GENERATES A RANDOM NEGATIVE BINOMIAL VARIATE USING UNSTORED INVERSION AND/OR THE REPRODUCTIVE PROPERTY. SK = NUMBER OF FAILURES REQUIRED (Dagpunar's words!) = the `power' parameter of the negative binomial (0 < REAL) P = BERNOULLI SUCCESS PROBABILITY (0 < REAL < 1) THE PARAMETER H IS SET SO THAT UNSTORED INVERSION ONLY IS USED WHEN P <= H, OTHERWISE A COMBINATION OF UNSTORED INVERSION AND THE REPRODUCTIVE PROPERTY IS USED.

Random_Normal

GLScene.RandomLib

Random_Normal

GLScene.RandomLib

Random_Normal

GLScene.RandomLib

Adapted from COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. Returns a normally distributed pseudo-random number with zero mean and unit variance. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves

Random_Normal

GLScene.RandomLib

Adapted from the following Fortran 77 code ALGORITHM 712, COLLECTED ALGORITHMS FROM ACM. THIS WORK PUBLISHED IN TRANSACTIONS ON MATHEMATICAL SOFTWARE, VOL. 18, NO. 4, DECEMBER, 1992, PP. 434-435. The algorithm uses the ratio of uniforms method of A.J. Kinderman and J.F. Monahan augmented with quadratic bounding curves Returns a normally distributed pseudo-random number with zero mean and unit variance

Random_Poisson

GLScene.RandomLib

Random_Poisson

GLScene.RandomLib

Generates a single random deviate from a Poisson distribution with mean mu. Arguments: mu –> The mean of the Poisson distribution from which a random deviate is to be generated. REAL mu Method: For details see Ahrens, J.H. and Dieter, U. Computer Generation of Poisson Deviates From Modified Normal Distributions. ACM Trans. Math. Software, 8, 2 (June 1982),163-179
TABLES: COEFFICIENTS A0-A7 FOR STEP F. FACTORIALS FACT COEFFICIENTS A(K) - FOR PX = FK*V*V*SUM(A(K)*V**K)-DEL

Random_T

GLScene.RandomLib

Random_T

GLScene.RandomLib

Generates a random variate FROM A T DISTRIBUTION USING KINDERMAN AND MONAHAN'S RATIO METHOD. DF = DEGREES OF FREEDOM OF DISTRIBUTION (DF >= 1)

Random_von_Mises

GLScene.RandomLib

Random_von_Mises

GLScene.RandomLib

Algorithm VMD Arguments: k (real) - parameter of the von Mises distribution.

Random_Weibull

GLScene.RandomLib

Random_Weibull

GLScene.RandomLib

Generates a random variate from the Weibull distribution with probability density: a a-1 -x f(x) = a.x e

RandUniform

GLScene.RandomLib

RandUniform

GLScene.RandomLib

Uniform Random single numbers in RLow..RHigh range

RasterFileFormatExtensionByIndex

GXS.Graphics

Returns an extension by its index in the internal image files dialogs filter. Use InternalImageFileFormatsFilter to obtain the filter.

RayCastAABBIntersect

GLScene.GeometryBB

RayCastAABBIntersect

GLScene.GeometryBB

Finds the intersection between a ray and an axis aligned bounding box.

RayCastBoxIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a box. Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil

RayCastIntersectsSphere

GLScene.VectorGeometry

Determines if a ray will intersect with a given sphere

RayCastMinDistToPoint

GLScene.VectorGeometry

Compute the min distance a ray will pass to a point

RayCastPlaneIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a plane. Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil

RayCastPlaneXZIntersect

GLScene.VectorGeometry

RayCastSphereIntersect

GLScene.VectorGeometry

Calculates the intersections between a sphere and a ray. Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined)

RayCastTriangleIntersect

GLScene.VectorGeometry

Compute intersection between a ray and a triangle

RC_DDS_Type

GXS.ApplicationFileIO

RC_JPG_Type

GXS.ApplicationFileIO

RC_String_Type

GXS.ApplicationFileIO

RC_XML_Type

GXS.ApplicationFileIO

ReadCRLFString

GLScene.Utils

Read a CRLF terminated string from a stream. The CRLF is NOT in the returned string.

ReadExtensions

GLScene.OpenGL4

ReadImplementationProperties

GLScene.OpenGL4

ReadLine

GLScene.Logger

ReadScreenImage

GXS.Screen

ReadVideoModes

GXS.Screen

ReadWGLExtensions

GLScene.OpenGL4

ReadWGLImplementationProperties

GLScene.OpenGL4

RectangleContains

GLScene.VectorGeometry

Determine if BigRect completely contains SmallRect

RectanglesIntersect

GLScene.VectorGeometry

Determine if 2 rectanges intersect

RectEquals

GLScene.VectorGeometry

True if all components are equal.

Register

GBE.Clouds

Register

GBE.ConeExtend

Register

GBE.CubeExtend

Register

GBE.Cubemap

Register

GBE.CylinderExtend

Register

GBE.Grass

Register

GBE.Heightmap

Register

GBE.Joystick

Register

GBE.omOceanWaves

compatibility w/ old forms

Register

GBE.PlaneExtend

Register

GBE.PlayerPosition

Register

GBE.SphereExtend

Register

GBE.Terrain

Register

GBE.TimeLine

Register

GBE.Viewport3D

Register

GLScene.XCollectionRegister

Register

GXS.CgRegister

ToDo DesignIntf, not implemented DesignEditors, FMXEditors, for TgxLibMaterialNameProperty

Register

GXS.DwsObjects

Register

GXS.FullScreenViewer

Register

GXS.GPURegister

ToolsAPI, STREDIT,

Register

GXS.ParallelRegister

ToolsAPI, STREDIT,

Register

GXS.Physics.Register

GXS.PhysManager todo

Register

GXS.Python.Script

Register

GXS.RegisterXCollection

Register

GXS.SceneRegister

Register

GXS.Sounds.Register

Register

omSailSurface

Register

SDLx.Context

Register

SDLx.Window

The following function has been commented out to encourage developers to use SDL_getenv as it it more portable function getenv(const name: PAnsiChar): PAnsiChar; ———————————————————————

Register

VXS.DWSScene

RegisterArchiveFormat

GXS.ArchiveManager

RegisterBaseSceneObjectNameChangeEvent

GXS.Scene

Register an event handler triggered by any TgxBaseSceneObject Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FSceneEdit in the IDE.

RegisterBehaviourNameChangeEvent

GXS.Scene

Register an event handler triggered by any TgxBehaviour Name change. *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

RegisterContextClass

GXS.Context

Drivers should register themselves via this function.

RegisterCUDAComponentNameChangeEvent

GXS.CUDA.API

RegisterGLXceneObject

GXS.ODEManager

GLODEObject register methods (used for joint object persistence)

RegisterInfoForm

GXS.Scene

Registers the procedure call used to invoke the info form.

RegisterManager

GLScene.Manager

RegisterRasterFormat

GXS.Graphics

RegisterSoundFileFormat

GXS.SoundFileObjects

RegisterTextureImageClass

GXS.Texture

Register a TgxTextureImageClass (used for persistence and IDE purposes)

RegisterTextureImageEditor

GXS.TextureImageEditors

RegisterTGraphicClassFileExtension

GXS.Texture

RegisterUniformAutoSetMethod

GXSL.Parameter

RegisterUniformAutoSetMethod

GXSL.ShaderParameter

RegisterVectorFileFormat

GXS.VectorFileObjects

RegisterXCollectionDestroyEvent

GLScene.XCollection

Registers an event to be called when an XCollection is destroyed

RegisterXCollectionItemClass

GLScene.XCollection

Registers a TXCollectionItem subclass for persistence requirements

RelativePath

GLScene.Utils

Remove if possible part of path witch leads to project executable.

ReleaseCUDAEditorForm

FMxCUDAEditor

ReleaseFontManager

GXS.SpaceText

ReleaseLibMaterialPicker

FMXLibMaterialPicker

ReleaseMaterialEditorForm

FMxMaterialEditor

ReleaseNx

GXS.PhysX

ReleaseSceneEditorForm

FMxSceneEditor

ReleaseShaderEditor

FMxShaderMemo

ReleaseShaderUniformEditor

FMxShaderUniformEditor

ReleaseXCollectionEditor

FMxXCollectionEditor

Release_Memory_Isoline

GXS.Isolines

RemapAndCleanupReferences

GXS.MeshUtils

Alters a reference/indice pair and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

remapIndices

GXS.MeshUtils

Remaps a list of indices. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RemapIndicesToIndicesMap

GXS.MeshUtils

Creates an indices map from a remap list. The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear? In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices. Any simpler documentation of this function welcome ;)

RemapReferences

GXS.MeshUtils

RemapReferences

GXS.MeshUtils

Alters a reference array and removes unused reference values. This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

RemapTrianglesIndices

GXS.MeshUtils

Remaps a list of triangles vertex indices and remove degenerate triangles. The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RenderAABB

GXS.SpatialPartitioning

RenderAABB

GXS.SpatialPartitioning

Renders an AABB as a line

RenderGeomList

GXS.ODEUtils

RenderSpatialPartitioning

GXS.SpatialPartitioning

Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

RePlaySound

uGBESound

RescaleImage

GXS.ImageUtils

RestoreDefaultMode

GXS.Screen

RGB24ToRGBA32

GXS.Graphics

RGBA_SIGNED_COMPONENTS_EXT

GLScene.OpenGL4

Rgbe2float

GLScene.RGBE

RLength

GLScene.VectorGeometry

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

Roll

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Z-axis

Roll

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterDirection

RotateVector

GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVector

GLScene.VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVectorAroundY

GLScene.VectorGeometry

Rotate given vector around the Y axis (alpha is in rad)

RoundDownToPowerOf2

GLScene.Utils

Round down to the nearest power of two, value must be strictly positive

RoundInt

GLScene.VectorGeometry

RoundInt

GLScene.VectorGeometry

Rounds the floating point value to the closest integer. Behaves like Round but returns a floating point value like Int.

RoundUpToPowerOf2

GLScene.Utils

Round ups to the nearest power of two, value must be positive

RSqrt

GLScene.VectorGeometry

—————————————————————————— Miscellanious math functions —————————————————————————— Computes 1/Sqrt(v)

RstVector

GLScene.VectorGeometry

RstVector

GLScene.VectorGeometry

SafeCurrentContext

GXS.Context

sAllFilter

GXS.ImageUtils

TglTextLayout

SaveAnsiStringToFile

GLScene.Utils

Saves ansistring "data" to "filename".

SaveComponentToFile

GLScene.Utils

Saves component to a file.

SavePictureDialog

GXS.ImageUtils

Pops up a simple save picture dialog.

SaveStringToFile

GLScene.Utils

Saves string "data" to "filename".

ScaleAndRound

GLScene.VectorGeometry

Multiples i by s and returns the rounded result.

ScaleFloatArray

GLScene.VectorGeometry

ScaleFloatArray

GLScene.VectorGeometry

Multiplies values in the array by factor. This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items. Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available

ScaleMatrix

GLScene.VectorGeometry

Multiplies all elements of a 3x3 matrix with a factor

ScaleMatrix

GLScene.VectorGeometry

Multiplies all elements of a 4x4 matrix with a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by a factor

ScaleVector

GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

ScaleVector

GLScene.VectorGeometry

Scales given vector by another vector. v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

SceneDirectionFromGeom

GXS.ODEUtils

SceneEditorForm

FMxSceneEditor

SceneMatrixFromGeom

GXS.ODEUtils

SceneMatrixToODER

GXS.ODEUtils

SCENE_REVISION

GXS.Scene

SCENE_VERSION

GXS.Scene

SDK_Version

GXS.PhysX

SDL_getenv

SDLx.Window

function SDL_getenv(const name: PAnsiChar): PAnsiChar; cdecl; external LibName;

SDL_putenv

SDLx.Window

function SDL_putenv(const variable: PAnsiChar): integer; cdecl; external LibName;

SegmentPlaneIntersection

GLScene.VectorGeometry

Computes segment / plane intersection return false if there isn't an intersection

SegmentSegmentClosestPoint

GLScene.VectorGeometry

Computes the closest points (2) given two segments

SegmentSegmentDistance

GLScene.VectorGeometry

Computes the closest distance between two segments

SetAABB

GLScene.GeometryBB

SetActorCMassGlobalPosition

GXS.PhysX

SetActorGlobalOrientation

GXS.PhysX

SetActorGlobalPosition

GXS.PhysX

SetActorMass

GXS.PhysX

SetAffineVector

GLScene.VectorGeometry

SetBB

GLScene.GeometryBB

SetExeDirectory

GLScene.Utils

SetFullscreenMode

GXS.Screen

Changes to the video mode given by 'Index'

SetMatrix

GLScene.VectorGeometry

SetMatrix

GLScene.VectorGeometry

SetMatrix

GLScene.VectorGeometry

—————————————————————————- Matrix functions —————————————————————————-

SetMatrixRow

GLScene.VectorGeometry

SetPlane

GLScene.VectorGeometry

Converts from single to double representation

SetROAMTrianglesCapacity

GXS.ROAMPatch

Specifies the maximum number of ROAM triangles that may be allocated.

SetScreenSaverPassword

GXS.ScreenSaver

Invokes the standard Windows dialog to set the password. May be invoked from your Properties/Configuration dialog.

SetTextureImageClassesToStrings

GXS.Texture

Defines a TStrings with the list of registered TgxTextureImageClass.

setTransform

GXS.ODEUtils

SetupTangentSpace

GXS.BumpMapping

SetupVSync

GXS.SceneViewer

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SetVector

GLScene.VectorGeometry

SFChmutov1

GXS.Isosurface

Chmutov-surface-1 (http://mathworld.wolfram.com)

SFChmutov2

GXS.Isosurface

Chmutov-surface-2 (http://mathworld.wolfram.com)

SFDoubleTorus

GXS.Isosurface

Double torus Surface (phantasy!)

SFKleinBottle

GXS.Isosurface

Klein Bottle (http://mathworld.wolfram.com)

SFMinkowski

GXS.Isosurface

Minkowski space (http://mathworld.wolfram.com)

SFSphere

GXS.Isosurface

Sphere surface

SFToroidal

GXS.Isosurface

Toroidal surface (phantasy!)

ShaderEditorForm

FMxShaderMemo

ShaderUniformEditorForm

FMxShaderUniformEditor

ShiftObjectFromCenter

GLScene.VectorGeometry

ShiftObjectFromCenter

GLScene.VectorGeometry

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced. ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center

ShowHTMLUrl

GLScene.Utils

SIGN

GXS.FileZLIB

SIGN

GXS.PAKArchive

SignStrict

GLScene.VectorGeometry

Returns the sign of the x value using the (-1, 0, +1) convention

SimulateNx

GXS.PhysX

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

SinCosine

GLScene.VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius. sin and cos values calculated from theta are multiplicated by radius

SizeOf3D

uGBEUtils3D

SizeOfFile

GLScene.Utils

Returns the size of "filename". Returns 0 (zero) is file does not exists.

SkinEditorForm

FMxSkinEditor

Smooth_Interpolate_Strip

GXS.Perlin

smooth interpolate 3 strips into one...

sNOT_QUAD

GLScene.VectorTypesExt

SolveCubic

GLScene.Polynomials

Computes the real roots of a real polynomial of the 3rd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

SolveQuadric

GLScene.Polynomials

Computes the real roots of a real polynomial of the 2nd degree. The polynomial is of the form: A(0) + A(1)*Z + A(2)*Z**2

SolveQuartic

GLScene.Polynomials

Computes the real roots of a real polynomial of the 4th degree. The polynomial is of the form: A(0) + A(1)*Z + ... + A(4)*Z**4

SortArrayAscending

GLScene.VectorGeometry

Sorts given array in ascending order. NOTE : current implementation is a slow bubble sort...

SphereVisibleRadius

GLScene.VectorGeometry

Computes the visible radius of a sphere in a perspective projection. This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

sSINGULAR

GLScene.VectorTypesExt

StarRecordColor

GXS.Skydome

Computes star color from BV index (RGB) and magnitude (alpha).

StarRecordPositionYUp

GXS.Skydome

Computes position on the unit sphere of a star record (Y=up).

StarRecordPositionZUp

GXS.Skydome

Computes position on the unit sphere of a star record (Z=up).

StartAllMovements

GXS.Movement

StartPrecisionTimer

GLScene.Utils

Starts a precision timer. Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

StopAllMovements

GXS.Movement

StopPrecisionTimer

GLScene.Utils

Computes time elapsed since timer start and stop timer. Return time lap in seconds.

Str2Float

GLScene.Utils

Trying to read string otherwise using '.' as Decimal Separator

str3DSMapNotFound

GLScene.Strings

File3DS

strAlreadyRendering

GLScene.Strings

strBackwardContextFailed

GLScene.Strings

strBadPlanSize

GLScene.Strings

strBrokenObjectListArchive

GLScene.Strings

strCadencerNotDefined

GLScene.Strings

Cadencer

strCadencerNotDefinedEx

GLScene.Strings

strCamera

GLScene.Strings

strCameraRoot

GLScene.Strings

strCannotAlterAnActiveContext

GLScene.Strings

Context

strCantConvertImg

GLScene.Strings

Graphics

strConnectJoystick

GLScene.Strings

strContextActivationFailed

GLScene.Strings

strContextAlreadyCreated

GLScene.Strings

strContextDeactivationFailed

GLScene.Strings

strContextNotCreated

GLScene.Strings

strContextNotInit

GLScene.Strings

strCUDAEditor

GLScene.Strings

strCUTILFailed

GLScene.Strings

FilePGM

strCyclicRefMat

GLScene.Strings

Material

strDeleteContextFailed

GLScene.Strings

strDisplayList

GLScene.Strings

strDot

GLScene.Strings

General

strDriverNotSupportDebugRC

GLScene.Strings

strDriverNotSupportFRC

GLScene.Strings

strDriverNotSupportOESRC

GLScene.Strings

strError

GLScene.Strings

strError3DS_CLOSING_FILE

GLScene.Strings

strError3DS_CREATING_DATABASE

GLScene.Strings

strError3DS_GET_FAIL

GLScene.Strings

strError3DS_INIT_FAILED

GLScene.Strings

strError3DS_INVALID_ARG

GLScene.Strings

strError3DS_INVALID_CHUNK

GLScene.Strings

strError3DS_INVALID_DATA

GLScene.Strings

strError3DS_INVALID_DATABASE

GLScene.Strings

strError3DS_INVALID_INDEX

GLScene.Strings

strError3DS_NO_MEM

GLScene.Strings

strError3DS_NO_SUCH_FILE

GLScene.Strings

strError3DS_OPENING_FILE

GLScene.Strings

strError3DS_PUT_FAIL

GLScene.Strings

strError3DS_READING_DATABASE

GLScene.Strings

strError3DS_READING_FILE

GLScene.Strings

strError3DS_STRING_TOO_LONG

GLScene.Strings

strError3DS_UNFOUND_CHUNK

GLScene.Strings

strError3DS_WRITING_DATABASE

GLScene.Strings

strError3DS_WRITING_FILE

GLScene.Strings

strError3DS_WRONG_DATABASE

GLScene.Strings

strError3DS_WRONG_OBJECT

GLScene.Strings

strErrorEx

GLScene.Strings

strErrorLIB

GLScene.Strings

strFailCompilation

GLScene.Strings

strFailCreatePipe

GLScene.Strings

strFailedOpenFile

GLScene.Strings

strFailedOpenFileFromCurrentDir

GLScene.Strings

strFailedToShare

GLScene.Strings

strFailHWRC

GLScene.Strings

strFailMap

GLScene.Strings

strFailRunNVCC

GLScene.Strings

strFailToBindArrayToTex

GLScene.Strings

strFailUnmap

GLScene.Strings

strFFTFuncRetErr

GLScene.Strings

strFileNotFound

GLScene.Strings

strForwardContextFailed

GLScene.Strings

SceneContext

strFRC_created

GLScene.Strings

strFuncNotConnected

GLScene.Strings

strFuncRetErr

GLScene.Strings

strGLSceneEditor

GLScene.Strings

SceneEdit

strImageInvalid

GLScene.Strings

Textures

strIncompatibleContexts

GLScene.Strings

strIncompatibleTypes

GLScene.Strings

StringGrid

GXS.Windows

StringToColorAdvanced

GXS.ImageUtils

Converts a string into color

StringToColorAdvancedSafe

GXS.ImageUtils

Converts a string into color

strInterleaveNotSupported

GLScene.Strings

strInvalidColor

GLScene.Strings

Utils

strInvalidContextReg

GLScene.Strings

strInvalidContextRegistration

GLScene.Strings

strInvalidFileSignature

GLScene.Strings

PersistentClasses

strInvalidGLContext

GLScene.Strings

strInvalidNotificationRemoval

GLScene.Strings

strInvalidParamType

GLScene.Strings

strInvalidType

GLScene.Strings

strInvalidValue

GLScene.Strings

StripifyMesh

GXS.MeshUtils

Attempts to create as few as possible triangle strips to cover the mesh. The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality). The function returns a list of TgxIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller. If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

strJoystickError

GLScene.Strings

strLaunchFailed

GLScene.Strings

strLayoutCategoryName

GLScene.Strings

strListIndexError

GLScene.Strings

strLocalizableCategoryName

GLScene.Strings

strMakeFloatingFail

GLScene.Strings

strMaterialNotFound

GLScene.Strings

strMaterialNotFoundInMatlib

GLScene.Strings

strMaterialNotFoundInMatlibEx

GLScene.Strings

strMatLibNotDefined

GLScene.Strings

Materials

strMissingResource

GLScene.Strings

strModuleAbsent

GLScene.Strings

CUDA strings

strNoActiveRC

GLScene.Strings

strNoDescriptionAvailable

GLScene.Strings

strNoDeviceToCreate

GLScene.Strings

strNoJoystickDriver

GLScene.Strings

Joystick

strNoNewTexture

GLScene.Strings

strNoRenderingContext

GLScene.Strings

SceneViewer

strNothing

GLScene.Strings

strObjectRoot

GLScene.Strings

strObjectsNotSupported

GLScene.Strings

strOCAdvancedGeometry

GLScene.Strings

strOCBasicGeometry

GLScene.Strings

Object categories in GLScene Registry

strOCDoodad

GLScene.Strings

strOCEnvironmentObjects

GLScene.Strings

strOCExperimental

GLScene.Strings

strOCGraphPlottingObjects

GLScene.Strings

strOCGuiObjects

GLScene.Strings

strOCHUDObjects

GLScene.Strings

strOCMeshObjects

GLScene.Strings

strOCParticleSystems

GLScene.Strings

strOCProxyObjects

GLScene.Strings

strOCSpecialObjects

GLScene.Strings

strOctreeMustBePreparedBeforeUse

GLScene.Strings

Octree

strOESRC_created

GLScene.Strings

strOESvsForwardRC

GLScene.Strings

strOnlyHostData

GLScene.Strings

strOpenGLCategoryName

GLScene.Strings

SceneRegister, strings additional to Designintf

strOpenGLError

GLScene.Strings

InitOpenGL

strOutOfAttribSize

GLScene.Strings

strOutOfElementSize

GLScene.Strings

strOutOfMemory

GLScene.Strings

strOutOfRange

GLScene.Strings

strPBufferRC_created

GLScene.Strings

strRequireFreeThread

GLScene.Strings

strSceneRoot

GLScene.Strings

Tree

strSceneViewerNotDefined

GLScene.Strings

strShaderNeedsAtLeastOneLightSource

GLScene.Strings

Shaders

strShaderNeedsAtLeastOneLightSourceEx

GLScene.Strings

strSizeMismatch

GLScene.Strings

strSourceFileNotFound

GLScene.Strings

strSphereStartStop

GLScene.Strings

strSphereTopBottom

GLScene.Strings

Objects

strStateCashMissing

GLScene.Strings

strSuccessCompilation

GLScene.Strings

strThreadBusy

GLScene.Strings

strTmpRC_Created

GLScene.Strings

StrToFloatDef

GLScene.Utils

Similar to SysUtils.StrToFloatDef, but ignores user's locale

strTooManyLights

GLScene.Strings

StrToResType

GXS.ApplicationFileIO

strUnableToCreateLegacyContext

GLScene.Strings

strUnBalancedBeginEndUpdate

GLScene.Strings

strUnbalancedContexActivations

GLScene.Strings

strUnbalansedUsage

GLScene.Strings

strUnknownArchive

GLScene.Strings

Common messages

strUnknownArchiveVersion

GLScene.Strings

strUnknownExtension

GLScene.Strings

strUnknownParam

GLScene.Strings

strUnknownType

GLScene.Strings

strUnsupportedType

GLScene.Strings

strVisualCategoryName

GLScene.Strings

strWrongBitmapCanvas

GLScene.Strings

strWrongParamSetup

GLScene.Strings

strWrongPrinter

GLScene.Strings

strWrongVersion

GLScene.Strings

strXCollectionEditor

GLScene.Strings

FXCollectionEditor

SubdivideTriangles

GXS.MeshUtils

Subdivides mesh triangles. Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes. The procedure is not intended for real-time use.

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

GLScene.VectorGeometry

Subtracts V2 from V1, result is placed in V1

sWRONG_ELEMENT

GLScene.VectorTypesExt

sWRONG_SIZE

GLScene.VectorTypesExt

T1DPerlinArray

GXS.Perlin

T2DPerlinArray

GXS.Perlin

T48BitBlock

GXS.ImageUtils

TAABB

GLScene.GeometryBB

Structure for storing Axis Aligned Bounding Boxes

TAABBCorners

GLScene.GeometryBB

Structure for storing the corners of an AABB, used with ExtractAABBCorners

TAABBOverlapEvent

GXS.NGDManager

TAArray

GXS.zBuffer

TAArrayIdx

GXS.zBuffer

TAffineByteMatrix

GLScene.VectorGeometry

TAffineByteVector

GLScene.VectorGeometry

TAffineDblMatrix

GLScene.VectorGeometry

TAffineDblVector

GLScene.VectorGeometry

TAffineExtMatrix

GLScene.VectorGeometry

TAffineExtVector

GLScene.VectorGeometry

TAffineFltMatrix

GLScene.VectorGeometry

TAffineFltVector

GLScene.VectorGeometry

TAffineIntMatrix

GLScene.VectorGeometry

TAffineIntVector

GLScene.VectorGeometry

TAffineMatrix

GLScene.VectorGeometry

TAffinePtrVector

GLScene.VectorGeometry

TAffineVector

GLScene.VectorGeometry

TAffineVectorArray

GLScene.VectorGeometry

TAffineWordMatrix

GLScene.VectorGeometry

TAffineWordVector

GLScene.VectorGeometry

TAMFloatVector

GLScene.RandomLib

Used as a Dynamic Vector

TangentAttributeName

GXS.Objects

TAngleLimit1

GXS.Objects

TAngleLimit2

GXS.Objects

TApplyForceAndTorqueEvent

GXS.NGDManager

TArchiveFileFormat

GXS.ArchiveManager

Registered archives for using extentions, e.g.: GLFilePak,GLFileZLib

TArray3DExt

GLScene.VectorTypesExt

TASETextureMap

GXS.FileASE

TAsmProgFileProperty

GXS.SceneRegister

TAVICompressor

GXS.AVIRecorder

TAVIImageRetrievalMode

GXS.AVIRecorder

Image retrieval mode for frame capture. Following modes are supported: irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution

TAVIRecorderPostProcessEvent

GXS.AVIRecorder

TAVIRecorderState

GXS.AVIRecorder

TAVISizeRestriction

GXS.AVIRecorder

Frame size restriction. Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

TBaseConnectivity

GXS.Silhouette

TBaseSpacePartition

GXS.SpacePartition

Basic space partition, does not implement any actual space partitioning

TBASS3DAlgorithm

GXS.Sounds.BASS

TBoneMatrixObj

GXS.ProxyObjects

An object containing the bone matrix for TgxActorProxy.

TBoxRec

GLScene.VectorTypesExt

TBSPClusterVisibility

GXS.BSP

TBSPCullingSphere

GXS.BSP

TBSphere

GLScene.GeometryBB

Structure for storing BoundingSpheres. Similar to TAABB

TBSPMeshObject

GXS.BSP

A BSP mesh object. Stores the geometry information, BSP rendering options and offers some basic BSP utility methods. Geometry information is indexed in the facegroups, the 1st facegroup (of index 0) being the root node of the BSP tree.

TBSPRenderContextInfo

GXS.BSP

TBSPRenderSort

GXS.BSP

TBumpMethod

GXSL.BumpShaders

TBumpOption

GXSL.BumpShaders

TBumpOptions

GXSL.BumpShaders

Enable parallax offset mapping

TBumpSpace

GXSL.BumpShaders

TByteArray

GXS.HeightData

for CreateMonochromeBitmap

TByteMatrixArr

GXS.Isolines

TByteRaster

GXS.HeightData

TByteVector

GLScene.VectorGeometry

TByteVectorArr

GXS.Isolines

TCalcPointEvent

GXS.ThorFX

TCardinalVector

GLScene.VectorGeometry

TCastArray

GXS.Isolines

TCgFPProfile

GXS.CgShader

Available fragment program profile

TCgUnApplyEvent

GXS.CgShader

TCgVPProfile

GXS.CgShader

Available vertex program profile

TCGxApplyEvent

GXS.CgShader

TCGxBombShader

GXS.CgBombShader

TCGxBombShaderTextureSource

GXS.CgBombShader

TCGxCadencableCustomShader

GXS.CgShader

Allows to use a Cadencer, which is used for noise generation in many shaders.

TCGxCustomBombShader

GXS.CgBombShader

Just a good-looking shader.

TCGxCustomPostTransformationShader

GXS.CgPostTransformationShader

TCGxCustomShader

GXS.CgShader

TCGxFragmentProgram

GXS.CgShader

TCGxParameter

GXS.CgShader

Wrapper around a Cg parameter of the main program.

TCGxPostTransformationShader

GXS.CgPostTransformationShader

TCGxProgram

GXS.CgShader

Wrapper around a Cg program.

TCGxProgramType

GXS.CgShader

TCGxShader

GXS.CgShader

TCGxShaderEvent

GXS.CgShader

TCGxVertexProgram

GXS.CgShader

TChannelTypeAndNum

GXS.CUDA.API

TCharInfo

GXS.BitmapFont

TClassProperty

GXS.RegisterXCollection

TCollisionBoundingMode

GXS.Collision

Defines how fine collision bounding is for a particular object. Possible values are : cbmPoint : the object is punctual and may only collide with volumes cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid cbmCube : the object is defined by a bounding axis-aligned "cube" cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code)

TCollisionConstraintTypes

GXS.VerletTypes

TCollisionConstraintTypesSet

GXS.VerletTypes

TCollisionIteratorEvent

GXS.NGDManager

Events for Newton Callback

TCollisionState

GXS.FPSMovement

TCollisionStates

GXS.FPSMovement

TColorEditorFrame

FRxColorEditor

TCompressionLevel

GXS.ArchiveManager

TConeForme

GBE.ConeExtend

TConnectivity

GXS.Silhouette

TContactPoint

GXS.FPSMovement

TContactProcessEvent

GXS.NGDManager

TCoronaTangentLookup

GXS.Imposter

TCSGOperation

GXS.MeshCSG

TCuAddresMode

GXS.CUDA.API

TCubicSpline

GLScene.Spline

3D cubic spline handler class. This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline. Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector. Note : X, Y & Z are actually interpolated independently.

TCubicSplineMatrix

GLScene.Spline

TCUDAChange

GXS.CUDA.API

TCUDAChanges

GXS.CUDA.API

TCUDAChannelNum

GXS.CUDA.API

TCUDAChannelType

GXS.CUDA.API

TCUDACompilerEditor

GXS.GPURegister

TCUDACompilerEditor

GXS.ParallelRegister

TCUDACompilerSourceProperty

GXS.GPURegister

TCUDACompilerSourceProperty

GXS.ParallelRegister

TCUDAComponent

GXS.CUDA.API

TCUDAComponentClass

GXS.CUDA.API

TCUDAConstant

GXS.CUDA.API

TCUDAContext

GXS.CUDA.Context

TCUDAContextList

GXS.CUDA.Context

TCUDADevice

GXS.CUDA.Context

TCUDADeviceList

GXS.CUDA.Context

TCUDADeviceProperty

GXS.GPURegister

TCUDADeviceProperty

GXS.ParallelRegister

TCUDADimensions

GXS.CUDA.Context

TCUDAEditor

GXS.GPURegister

TCUDAEditor

GXS.ParallelRegister

TCUDAEditorForm

FMxCUDAEditor

TCUDAFFTdir

GXS.CUDA.FFTPlan

TCUDAFFTPlan

GXS.CUDA.FFTPlan

TCUDAFFTransform

GXS.CUDA.FFTPlan

TCUDAFuncParam

GXS.CUDA.API

TCUDAFunction

GXS.CUDA.API

TCUDAGeometryResource

GXS.CUDA.Graphics

TCUDAGraphicResource

GXS.CUDA.API

Abstract class of graphic resources.

TCUDAHandleList

GXS.CUDA.Context

TCUDAHandlesMaster

GXS.CUDA.Context

TCUDAImageResource

GXS.CUDA.Graphics

TCUDAMapping

GXS.CUDA.API

TCUDAMemData

GXS.CUDA.API

TCUDAMemMapFlag

GXS.CUDA.API

TCUDAMemMapFlags

GXS.CUDA.API

Fast write, slow read

TCUDAMemType

GXS.CUDA.API

TCUDAModule

GXS.CUDA.API

TCUDATexture

GXS.CUDA.API

TCUDAUniform

GXS.CUDA.API

TCUDAVertexAttribute

GXS.CUDA.Graphics

TCUDAVertexAttributes

GXS.CUDA.Graphics

TCuFilterMode

GXS.CUDA.API

TCullingMode

GXS.SpacePartition

TCustomMeshHelper

GBE.ConeExtend

TCustomMeshHelper

GBE.CylinderExtend

TCustomMeshHelper

GBE.SphereExtend

TCustomMeshHelper

uGBEUtils3D

TD3DMatrix

GLScene.VectorTypes

TD3DVector

GLScene.VectorTypes

TDataFileCapabilities

GXS.ApplicationFileIO

TDComplete

GLScene.Triangulation

TDDSImage

Formatx.DDSImage

TDebugProc

GLScene.OpenGLTokens

TDebugProcAMD

GLScene.OpenGLTokens

TDEdges

GLScene.Triangulation

TDeSerializeEvent

GXS.NGDManager

TDESolver

GXS.PhysManager

need to have state array(s) seperate from inertias to allow for implicit & explicit methods

TDESolverEuler

GXS.PhysManager

TDESolverExplicit

GXS.PhysManager

explicit e.g. Euler, Mid-point, Runge-Kutta integration

TDESolverImplicit

GXS.PhysManager

implicit e.g. Verlet Integration

TDESolverRungeKutta4

GXS.PhysManager

TDESolverType

GXS.PhysManager

only ssEuler is usable at the moment

TDESolverVerlet

GXS.PhysManager

TDim

GLScene.VectorTypesExt

TDirectRenderEvent

GXS.Scene

Event for user-specific rendering in a TgxDirectOpenVX object.

TDirPlan

GLScene.GeometryBB

TDoubleArray

GLScene.Polynomials

TDoubleArray

GLScene.VectorTypesExt

TDoubleHmgPlane

GLScene.VectorGeometry

TDoubleVector

GLScene.VectorGeometry

TDProgressEvent

GLScene.Triangulation

TDTriangle

GLScene.Triangulation

TDVertex

GLScene.Triangulation

TDwsGLXceneUnit

VXS.DWSScene

TEarthSkydomeOption

GXS.Skydome

TEarthSkydomeOptions

GXS.Skydome

TEaseType

GLScene.AnimationUtils

TECCollider

GXS.EllipseCollision

TECColliderList

GXS.EllipseCollision

TECColliderShape

GXS.EllipseCollision

TECCollisionPacket

GXS.EllipseCollision

TECContact

GXS.EllipseCollision

TECContactList

GXS.EllipseCollision

TECFreeForm

GXS.EllipseCollision

TECFreeFormList

GXS.EllipseCollision

TECMovePack

GXS.EllipseCollision

TECObjectInfo

GXS.EllipseCollision

Object collision properties

TECPlane

GXS.EllipseCollision

TECTriangle

GXS.EllipseCollision

TECTriMesh

GXS.EllipseCollision

TECTriMeshList

GXS.EllipseCollision

TEdge

GXS.VerletClothify

TEdgeDetector

GXS.VerletClothify

TEdgeList

GXS.VerletClothify

TEulerOrder

GLScene.VectorGeometry

—————————————————————————- Quaternion functions —————————————————————————-

TexPointArrayAdd

GLScene.VectorGeometry

Adds delta to nb texpoints in src and places result in dest

TexPointArrayScaleAndAdd

GLScene.VectorGeometry

TexPointCombine

GLScene.VectorGeometry

Makes a linear combination of two texpoints

TexpointEquals

GLScene.VectorGeometry

True if all components are equal.

TexPointLerp

GLScene.VectorGeometry

Calculates linear interpolation between texpoint1 and texpoint2 at point t

TexPointMake

GLScene.VectorGeometry

————————————————————————– Vector functions ————————————————————————–

TExtendedFrustum

GXS.SpacePartition

Extended frustum, used for fast intersection testing

TExtendedVector

GLScene.VectorGeometry

TextureBlue

GXS.RandomHDS

TextureBrownSoil

GXS.RandomHDS

TextureCanalBleu

uGBEImageUtils

TextureCanalNoir

uGBEImageUtils

TextureCanalRouge

uGBEImageUtils

TextureCanalVert

uGBEImageUtils

TextureDarkGray

GXS.RandomHDS

TextureDarkGreen

GXS.RandomHDS

TextureGreen

GXS.RandomHDS

TextureSand

GXS.RandomHDS

TextureWhite

GXS.RandomHDS

TFace

GXS.VerletClothify

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

TFaceEditorFrame

FRxFaceEditor

TFaceExtractor

GXS.VerletClothify

Class that extracts faces from a GLBaseMesh

TFaceList

GXS.VerletClothify

List of faces

TFaceRec

GLScene.VectorTypesExt

TFastCollisionChecker

GXS.Collision

TFeedBackMeshLaunching

GXS.CUDA.Graphics

TFeedBackMeshPrimitive

GXS.CUDA.Graphics

TFeedbackMode

GXS.Feedback

TFGBezierSurface

GXS.ParametricSurfaces

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

TFGBSPNode

GXS.BSP

A node in the BSP tree. The description does not explicitly differentiates nodes and leafs, nodes are referred by their index.

TFGPolygon

GXS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGPortalPolygon

GXS.Portal

A portal polygon. This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGVertexNormalTexIndexList

GXS.VectorFileObjects

Adds normals and texcoords indices. Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

TFileNMF

GXS.FileNMF

TFileSection

GXS.FileZLIB

TFileSection

GXS.PAKArchive

TFindCuFileFunc

GXS.CUDA.Compiler

TFireParticle

GXS.FireFX

TFireParticleArray

GXS.FireFX

TFlareElement

GXS.LensFlare

TFlareElements

GXS.LensFlare

TFloatVector

GLScene.VectorGeometry

TFontEntry

GXS.SpaceText

TFontManager

GXS.SpaceText

Manages a list of fonts for which display lists were created.

TFractionErosion

GXS.RandomHDS

TFrustrumPart

GXS.GeomObjects

TFrustrumParts

GXS.GeomObjects

TFrustum

GLScene.VectorGeometry

TFXPointerList

GXS.ParticleFX

TGBEClouds

GBE.Clouds

TGBECollisionRetour

uGBEUtils3D

TGBEConeExtend

GBE.ConeExtend

TGBECubeExtend

GBE.CubeExtend

TGBECubemap

GBE.Cubemap

TGBECylinderExtend

GBE.CylinderExtend

TGBEGrass

GBE.Grass

TGBEHeightmap

GBE.Heightmap

TGBEJoystick

GBE.Joystick

TGBEJoystickType

GBE.Joystick

TGBENoeud

uGBEPathFinder

TGBEOptions

uGBEOptionsUtils

TGBEPathFinder

uGBEPathFinder

TGBEPathFinderMode

uGBEPathFinder

TGBEPlaneExtend

GBE.PlaneExtend

TGBEPlayerPosition

GBE.PlayerPosition

TGBESphereExtend

GBE.SphereExtend

TGBEStep

GBE.TimeLine

TGBETerrain

GBE.Terrain

TGBETimeline

GBE.TimeLine

TGBETypePosition

GBE.PlayerPosition

TGBEViewport3D

GBE.Viewport3D

TGClipRect

GLScene.GeometryBB

TGDelaunay2D

GLScene.Triangulation

TGDelaunay2D is a class for Delaunay triangulation of arbitrary points Credit to Paul Bourke (http://paulbourke.net/) for the original Fortran 77 Program :)) Conversion to Visual Basic by EluZioN (EluZioN@casesladder.com) Conversion from VB to Delphi6 by Dr Steve Evans (steve@lociuk.com) June 2002 Update by Dr Steve Evans: Heap memory allocation added to prevent stack overflow when MaxVertices and MaxTriangles are very large. Additional Updates in June 2002: Bug in InCircle function fixed. Radius r := Sqrt(rsqr). Check for duplicate points added when inserting new point. For speed, all points pre-sorted in x direction using quicksort algorithm and triangles flagged when no longer needed. The circumcircle centre and radius of the triangles are now stored to improve calculation time. You can use this code however you like providing the above credits remain in tact

TGetTerrainBoundsEvent

GXS.TerrainRenderer

TGLBallAndSocketJoint

GXS.PhysJoints

TGLBaseJoint

GXS.PhysJoints

// // Joint(Z1) Joint(Z3) // / \ |_| (Wrist) // / \/\ // // / / \ \ // // / / \ \(1) //(2) // Link(0) / / \ \ // // / / \ \ // // / / \ \ // // / / \/\/ // Joint(Z0)/ / \/ // |——| Joint(Z2) // | Base | // ——————————————– // X(n) = Common normal between joint axis Z(n-1) & Z(n)

TGLBaseLink

GXS.PhysJoints

TGLbitfield

GLScene.OpenGL4

TGLbitfield

GLScene.OpenGLTokens

TGLboolean

GLScene.OpenGL4

TGLboolean

GLScene.OpenGLTokens

=========== OpenGL types ============

TGLbyte

GLScene.OpenGL4

TGLbyte

GLScene.OpenGLTokens

TGLchar

GLScene.OpenGLTokens

TGLclampd

GLScene.OpenGL4

TGLclampd

GLScene.OpenGLTokens

TGLclampf

GLScene.OpenGL4

TGLDEBUGPROCARB

GLScene.OpenGLTokens

TGLdouble

GLScene.OpenGL4

TGLdouble

GLScene.OpenGLTokens

TGLEnum

GLScene.OpenGL4

TGLenum

GLScene.OpenGLTokens

TGLExtensionsAndEntryPoints

GXS.OpenGLAdapter

TGLfloat

GLScene.OpenGL4

TGLfloat

GLScene.OpenGLTokens

TGLhalf

GLScene.OpenGLTokens

TGLhandleARB

GLScene.OpenGLTokens

TGLint

GLScene.OpenGL4

TGLint

GLScene.OpenGLTokens

TGLint64

GLScene.OpenGL4

TGLint64

GLScene.OpenGLTokens

TGLint64EXT

GLScene.OpenGL4

TGLint64EXT

GLScene.OpenGLTokens

TglInternalCompression

GLScene.TextureFormat

Texture compression option. If OpenGL supports it, this will activate a compressed texture format: tcDefault : uses global default compression option tcNone : do not use compression tcStandard : use standard compression, average quality, average rate tcHighQuality : choose a high-quality, low-speed compression tcHighSpeed : choose a high-speed, low-quality compression

TglInternalFormat

GLScene.TextureFormat

TGLInterpolationType

GLScene.VectorGeometry

TGLintptr

GLScene.OpenGL4

the size of these depend on platform (32bit or 64bit)

TGLintptr

GLScene.OpenGLTokens

the size of these depend on platform (32bit or 64bit)

TGLJoint

GXS.PhysJoints

TGLLink

GXS.PhysJoints

Links are mainly for used for Serial-Link manipulators Direct & Inverse Kinematics algorithms are planned

TGLMatrix

GLScene.VectorTypes

TGLPrismaticJoint

GXS.PhysJoints

TGLRadialGravityEmitter

GXS.PhysFields

TGLRevoluteJoint

GXS.PhysJoints

TGLSceneViewport

GXS.FMX.Viewer

TglSeparateTextureWrap

GLScene.TextureFormat

Texture addressing rules

TGLshort

GLScene.OpenGL4

TGLshort

GLScene.OpenGLTokens

TGLsizei

GLScene.OpenGL4

TGLsizei

GLScene.OpenGLTokens

TGLsizeiptr

GLScene.OpenGL4

TGLsizeiptr

GLScene.OpenGLTokens

TGLSLogger

GLScene.Logger

Abstract class for control logging.

TGLString

GLScene.OpenGL4

TglSwizzleVector

GLScene.TextureFormat

TGLsync

GLScene.OpenGL4

TGLsync

GLScene.OpenGLTokens

TglTextureCompareMode

GLScene.TextureFormat

Specifies the texture comparison mode for currently bound depth textures. That is, a texture whose internal format is tfDEPTH_COMPONENT*

TglTextureFilteringQuality

GLScene.TextureFormat

Filtering quality

TglTextureSwizzle

GLScene.TextureFormat

TglTextureTarget

GLScene.TextureFormat

TglTFVectorFile

GXS.FileGLTF

The glTF format is a runtime asset delivery format for GL APIs: WebGL, OpenGL ES OpenGL and Vulkan.

TGLType1Link

GXS.PhysJoints

// Type 1 Two-Link Manipulator // // _ ________ // / \ \ // / \/________/ // / / // / / // / / // / / // / / // \_/ //

TGLType2Link

GXS.PhysJoints

// Type 2 Two-Link Manipulator // ___ // / \___________________ // | + |___________________| // \ / // | | // | | // | | // | | // | | // | | // __|_|__ // |___.___| //

TGLType3Link

GXS.PhysJoints

// Type 3 Two-Link Manipulator // _______ // _________| |__ // <-|_________| |__|-> // |__ __| // | | // | | // | | // | | // | | // _|_|_ // |__.__|

TGLType4Link

GXS.PhysJoints

TGLType5Link

GXS.PhysJoints

// Type 5 Two-Link Manipulator // // _ // ________|_|__ // <-|_____________|-> // | | // | | // | | // | | // | | // __| |__ // |__| |__| // |_| // | // V //

TGLType6Link

GXS.PhysJoints

TGLType7Link

GXS.PhysJoints

TGLType8Link

GXS.PhysJoints

TGLubyte

GLScene.OpenGL4

TGLubyte

GLScene.OpenGLTokens

TGLuint

GLScene.OpenGL4

TGLuint

GLScene.OpenGLTokens

TGLuint64

GLScene.OpenGL4

TGLuint64

GLScene.OpenGLTokens

TGLuint64EXT

GLScene.OpenGL4

TGLuint64EXT

GLScene.OpenGLTokens

TGLUniformGravityEmitter

GXS.PhysFields

GXS.RigidBodyInertia

TGLUNurbs

GLScene.OpenGL4

TGLUNurbs

GLScene.OpenGLTokens

——————- OpenGL Utility (GLU) types —————- GLU types

TGLUNurbsErrorProc

GLScene.OpenGL4

GLUNurbsCallback

TGLUNurbsErrorProc

GLScene.OpenGLTokens

TGLUNurbsObj

GLScene.OpenGL4

backwards compatibility

TGLUNurbsObj

GLScene.OpenGLTokens

backwards compatibility

TGLUQuadric

GLScene.OpenGL4

TGLUQuadric

GLScene.OpenGLTokens

TGLUQuadricErrorProc

GLScene.OpenGL4

GLUQuadricCallback

TGLUQuadricErrorProc

GLScene.OpenGLTokens

Callback function prototypes

TGLUQuadricObj

GLScene.OpenGL4

TGLUQuadricObj

GLScene.OpenGLTokens

TGLushort

GLScene.OpenGL4

TGLushort

GLScene.OpenGLTokens

TGLUTessBeginDataProc

GLScene.OpenGL4

TGLUTessBeginDataProc

GLScene.OpenGLTokens

TGLUTessBeginProc

GLScene.OpenGL4

GLUTessCallback

TGLUTessBeginProc

GLScene.OpenGLTokens

TGLUTessCombineDataProc

GLScene.OpenGL4

TGLUTessCombineDataProc

GLScene.OpenGLTokens

TGLUTessCombineProc

GLScene.OpenGL4

TGLUTessCombineProc

GLScene.OpenGLTokens

TGLUTessEdgeFlagDataProc

GLScene.OpenGL4

TGLUTessEdgeFlagDataProc

GLScene.OpenGLTokens

TGLUTessEdgeFlagProc

GLScene.OpenGL4

TGLUTessEdgeFlagProc

GLScene.OpenGLTokens

TGLUTesselator

GLScene.OpenGL4

TGLUTesselator

GLScene.OpenGLTokens

TGLUTesselatorObj

GLScene.OpenGL4

TGLUTesselatorObj

GLScene.OpenGLTokens

TGLUTessEndDataProc

GLScene.OpenGL4

TGLUTessEndDataProc

GLScene.OpenGLTokens

TGLUTessEndProc

GLScene.OpenGL4

TGLUTessEndProc

GLScene.OpenGLTokens

TGLUTessErrorDataProc

GLScene.OpenGL4

TGLUTessErrorDataProc

GLScene.OpenGLTokens

TGLUTessErrorProc

GLScene.OpenGL4

TGLUTessErrorProc

GLScene.OpenGLTokens

TGLUTessVertexDataProc

GLScene.OpenGL4

TGLUTessVertexDataProc

GLScene.OpenGLTokens

TGLUTessVertexProc

GLScene.OpenGL4

TGLUTessVertexProc

GLScene.OpenGLTokens

TGLUTriangulatorObj

GLScene.OpenGL4

TGLUTriangulatorObj

GLScene.OpenGLTokens

TGLvdpauSurfaceNV

GLScene.OpenGLTokens

TGLVector

GLScene.VectorTypes

TgOnMatricesPush

GLScene.PipelineTransform

TgPipelineTransformationState

GLScene.PipelineTransform

TgPipelineTransformationStates

GLScene.PipelineTransform

TGPUDEVICE

GLScene.OpenGL4

TGPUDEVICE

GLScene.OpenGLTokens

TGraphicClass

GXS.ImageUtils

TGrowMethod

GXS.SpacePartition

Implements sectored space partitioning, sectored space partitions include Octrees, Quadtrees and BSP-trees

TgTransformation

GLScene.PipelineTransform

TgTransformationRec

GLScene.PipelineTransform

TGUIAlignments

GXS.Gui

TGUIDrawResult

GXS.Gui

TGUILayoutForm

FMxGuiLayoutEditor

TGUIRect

GXS.Gui

Tgx1DPerlin

GXS.Perlin

Tgx2DPerlin

GXS.Perlin

Tgx2DPerlinOctav

GXS.Perlin

Tgx3DSVectorFile

GXS.File3DS

The 3DStudio vector file. A 3DS file may contain material information and require textures when loading.

TgxAbsoluteHUDText

GXS.HUDObjects

Position (X, Y and X) is in absolute coordinates. This component converts them to screen coordinates and renderes text there.

TgxAbstractLibMaterial

GXS.Material

TgxAbstractLibMaterials

GXS.Material

TgxAbstractMaterialLibrary

GXS.Material

TgxAbstractMultitextureCoordinator

GXS.Context

TgxAbstractMultitextureCoordinatorClass

GXS.Context

TgxAcceptMouseQuery

GXS.Windows

TgxActiveAttrib

GXSL.Shader

TgxActiveAttribArray

GXSL.Shader

TgxActor

GXS.VectorFileObjects

Mesh class specialized in animated meshes. The TgxActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TgxAnimationControler components).

TgxActorAnimation

GXS.VectorFileObjects

An actor animation sequence. An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property). An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TgxAnimationControler.

TgxActorAnimationMode

GXS.VectorFileObjects

Defines how an actor plays between its StartFrame and EndFrame. aamNone : no animation is performed aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward aamExternal : Allows for external animation control

TgxActorAnimationName

GXS.VectorFileObjects

TgxActorAnimationReference

GXS.VectorFileObjects

TgxActorAnimations

GXS.VectorFileObjects

Collection of actor animations sequences.

TgxActorFrameInterpolation

GXS.VectorFileObjects

Actor frame-interpolation mode. - afpNone : no interpolation, display CurrentFrame only - afpLinear : perform linear interpolation between current and next frame

TgxActorOption

GXS.VectorFileObjects

Miscellanious actor options. aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance.

TgxActorOptions

GXS.VectorFileObjects

TgxActorProxy

GXS.ProxyObjects

A proxy object specialized for Actors.

TgxActorProxyAnimationMode

GXS.ProxyObjects

pamLoop mode was too difficalt to implement, so it was discarded ...for now. pamPlayOnce only works if Actor.AnimationMode <> aamNone.

TgxAdvancedBlurImagePrepareEvent

GXS.Blur

TgxAdvancedLabel

GXS.Windows

TgxAFIOCreateFileStream

GXS.ApplicationFileIO

TgxAFIOFileStreamEvent

GXS.ApplicationFileIO

TgxAFIOFileStreamExists

GXS.ApplicationFileIO

TgxAFIOFileStreamExistsEvent

GXS.ApplicationFileIO

TgxAlphaFunc

GXS.Material

To show up in design-time editor vTGlAlphaFuncValues and vTgxBlendFuncFactorValues arrays if you type smth like af_GL_NEVER = GL_NEVER in the definition.

TgxAnimatedSprite

GXS.AnimatedSprite

An animated version for using offset texture coordinate animation.

TgxAnimationControler

GXS.VectorFileObjects

Controls the blending of an additionnal skeletal animation into an actor. The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TgxActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

TgxAnimationNameProperty

GXS.SceneRegister

TgxAnnulus

GXS.GeomObjects

An annulus is a cylinder that can be made hollow (pipe-like).

TgxAnnulusPart

GXS.GeomObjects

TgxAnnulusParts

GXS.GeomObjects

TgxAntiAliasing

GXS.Context

TgxApplicationFileIO

GXS.ApplicationFileIO

Allows specifying a custom behaviour for TFileStream.Create. The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable. If multiple ApplicationFileIO components exist in the application, the last one created will be the active one.

TgxApplicationResource

GXS.ApplicationFileIO

TgxArcDirection

GXS.Canvas

TgxArchiveFileFormatsList

GXS.ArchiveManager

List of registered classes

TgxArray

GXS.InitOpenGL

———————————————————————–

TgxArray

OpenGXS.InitFMX

———————————————————————–

TgxArrowArc

GXS.GeomObjects

Draws an arrowhead (Sliced Torus + cone). The arrow head is a cone that shares the attributes of the Torus (ie stacks/slices, materials etc). This is useful for displaying a movement (eg twist) or other arc arrows that might be required. By default the bottom arrow is off

TgxArrowArcPart

GXS.GeomObjects

TgxArrowArcParts

GXS.GeomObjects

TgxArrowHeadStyle

GXS.GeomObjects

Arrow Head Stacking Style

TgxArrowLine

GXS.GeomObjects

Draws an arrowhead (cylinder + cone). The arrow head is a cone that shares the attributes of the cylinder (ie stacks/slices, materials etc). Seems to work ok. This is useful for displaying a vector based field (eg velocity) or other arrows that might be required. By default the bottom arrow is off

TgxArrowLinePart

GXS.GeomObjects

TgxArrowLineParts

GXS.GeomObjects

TgxASEFace

GXS.FileASE

ASE mesh face

TgxASEFaceList

GXS.FileASE

ASE mesh faces list

TgxASEFaceTexure

GXS.FileASE

maximum texture maps face texture channel indices

TgxASEFaceTexureChannels

GXS.FileASE

face texture channels

TgxASEMaterial

GXS.FileASE

TgxASEMaterialList

GXS.FileASE

TgxASEMaterialTextureMap

GXS.FileASE

TgxASEMaterialTextureMaps

GXS.FileASE

TgxASEMeshObject

GXS.FileASE

ASE geom object, represents single mesh object; contains: vertices, faces, vertex indices, faces and vertices normals, channels of texture coordinates and indices, scaling and location info; this object used only to store ASE data temporary to copy supported piece of it into TgxMeshObject

TgxASESmoothingGroups

GXS.FileASE

TgxASESubMaterial

GXS.FileASE

TgxASESubMaterialList

GXS.FileASE

TgxASEVectorFile

GXS.FileASE

ASE vector file parser

TgxAsmShader

GXSL.AsmShader

TgxAsmShaderEvent

GXSL.AsmShader

TgxAsmShaderParameter

GXSL.AsmShader

TgxAsmShaderUnUplyEvent

GXSL.AsmShader

TgxAsyncHDS

GXS.AsyncHDS

TgxAsyncHDThread

GXS.AsyncHDS

TgxAsyncTimer

GXS.AsyncTimer

Asynchronous timer component (actual 1 ms resolution, if CPU fast enough). Keep in mind timer resolution is obtained in-between events, but events are not triggered every x ms. For instance if you set the interval to 5 ms, and your Timer event takes 1 ms to complete, Timer events will actually be triggered every 5+1=6 ms (that's why it's "asynchronous"). This component is based on ThreadedTimer by Carlos Barbosa.

TgxAtmosphere

GXS.Atmosphere

TgxAtmosphereBlendingMode

GXS.Atmosphere

With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big. With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

TgxAVIRecorder

GXS.AVIRecorder

Component to make it easy to record GLScene frames into an AVI file.

TgxB3DVectorFile

GXS.FileB3D

TgxBAcceleration

GXS.Behaviours

Applies a constant acceleration to a TgxBInertia.

TgxBaseAnimationControler

GXS.VectorFileObjects

Base class for skeletal animation control.

TgxBaseArchive

GXS.ArchiveManager

Base classes for archivers

TgxBaseArchiveClass

GXS.ArchiveManager

TgxBaseBehaviour

GXS.Scene

Base class for implementing behaviours in TgxScene. Behaviours are regrouped in a collection attached to a TgxBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...). Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses : stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.)
Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object). NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function

TgxBaseComponent

GXS.Windows

TgxBaseControl

GXS.Windows

TgxBaseCustomGLSLDiffuseSpecular

GXSL.DiffuseSpecularShader

Abstract class.

TgxBaseFontControl

GXS.Windows

TgxBaseForceFieldEmitter

GXS.PhysManager

A base for different types of force-field behaviours

TgxBaseGLSLDiffuseSpecularShaderMT

GXSL.DiffuseSpecularShader

Abstract class.

TgxBaseGuiObject

GXS.Gui

TgxBaseImage

GXS.Graphics

TgxBaseImageClass

GXS.Graphics

TgxBaseInertia

GXS.PhysManager

purpose of TgxBaseInertia is to allow for inertias that may be constrained to 1 or 2 dimensions Shouldn't be used directly, instead use TgxParticleInertia (for a 3D particle) TgxRigidBodyInertia (for a 3D rigid-body) or define a new sub-class e.g. Tgx1DParticleInertia, this will allow for faster speed

TgxBaseMesh

GXS.VectorFileObjects

Base class for mesh objects.

TgxBaseMeshConnectivity

GXS.BaseMeshSilhouette

TgxBaseMeshObject

GXS.VectorFileObjects

A base class for mesh objects. The class introduces a set of vertices and normals for the object but does no rendering of its own.

TgxBasePerlin

GXS.Perlin

TgxBasePerlinOctav

GXS.Perlin

TgxBaseRandomHDS

GXS.RandomHDS

This class introduces all the basic properties of random landscape. No method implemented though. It is used as a descendant for - TgxCustomRandomLandscape: one tile landscape (cyclic or not) - TgxTiledRndLandscape: "infinite" landscapes (grids of TgxCustomRandomLandscape)

TgxBaseSceneObject

GXS.Scene

Base class for all scene objects. A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes. Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject). To add children at runtime, use the AddNewChild method of TgxBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

TgxBaseSceneObjectSelectionEditor

GXS.SceneRegister

Selection editor for TgxBaseSceneObject. Allows units to be added to the uses clause automatically when behaviours/effects are added to a TgxBaseSceneObject at design-time.

TgxBaseSelectTechnique

GXS.Selection

TgxBaseSelectTechniqueClass

GXS.Selection

TgxBaseSoundSource

GXS.SoundManager

Base class for origin of sound playback.

TgxBaseSpritePFXManager

GXS.ParticleFX

Base class for sprite-based particles FX managers. The particles are made of optionally centered single-textured quads.

TgxBaseTextControl

GXS.Windows

TgxBaseVerletNode

GXS.VerletTypes

Basic Verlet Node

TgxBCollision

GXS.Collision

Collision detection behaviour. Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms. An object may have multiple TgxBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

TgxBehaviour

GXS.Scene

Ancestor for non-rendering behaviours. This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TgxEffect", non-rendering effects (like inertia) are simply named "TgxBehaviour".

TgxBehaviourClass

GXS.Scene

TgxBehaviours

GXS.Scene

Holds a list of TgxBehaviour objects. This object expects itself to be owned by a TgxBaseSceneObject. As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TgxBehaviour subclasses.

TgxBExplosionFX

GXS.ExplosionFx

TgxBFireFX

GXS.FireFX

Fire special effect. This effect works as a client of TFireFXManager

TgxBFPSMovement

GXS.FPSMovement

TgxBInertia

GXS.Behaviours

Simple translation and rotation Inertia behaviour. Stores translation and rotation speeds, to which you can apply accelerations. Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

TgxBitmap32

GXS.Graphics

TgxBitmapFont

GXS.BitmapFont

See TgxCustomBitmapFont. This class only publuishes some of the properties.

TgxBitmapFontRange

GXS.BitmapFont

An individual character range in a bitmap font. A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

TgxBitmapFontRanges

GXS.BitmapFont

TgxBitmapHDS

GXS.HeightData

Bitmap-based Height Data Source. The image is automatically wrapped if requested data is out of picture Size, or if requested data is larger than the picture. The internal format is an 8 bit bitmap whose dimensions are a power of two, if the original image does not comply, it is StretchDraw'ed on a monochrome (gray) bitmap.

TgxBlankImage

GXS.Texture

A texture image with no specified content, only a size. This texture image type is of use if the context of your texture is calculated at run-time (with a TgxMemoryViewer for instance).

TgxBlankTIE

GXS.TextureImageEditors

TGXBlendedLerpInfo

GXS.VectorFileObjects

Small structure to store a weighted lerp for use in blending.

TgxBlendEquation

GXS.State

TgxBlendFunction

GXS.State

TgxBlendingMode

GXS.Material

Simplified blending options. bmOpaque : disable blending bmTransparency : uses standard alpha blending bmAdditive : activates additive blending (with saturation) bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise) bmAlphaTest100 : uses opaque blending, with alpha-testing at 100% bmModulate : uses modulation blending bmCustom : uses TgxBlendingParameters options

TgxBlendingModeEx

GXSL.CustomShader

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

TgxBlendingParameters

GXS.Material

TgxBlur

GXS.Blur

TgxBlurkind

GXS.Blur

TgxBlurPreset

GXS.Blur

TgxBMPImage

GXS.FileBMP

TgxBooleanOcclusionQueryHandle

GXS.Context

TgxBSoundEmitter

GXS.SoundManager

A sound emitter behaviour, plug it on any object to make it noisy. This behaviour is just an interface to a TgxSoundSource, for editing convenience.

TgxBThorFX

GXS.ThorFX

Thor special effect

TgxBuffer

GXS.InitOpenGL

———————————————————————–

TgxBuffer

OpenGXS.InitFMX

———————————————————————–

TgxBufferBindingTarget

GXS.State

TgxBufferI

GXS.InitOpenGL

———————————————————————–

TgxBufferI

OpenGXS.InitFMX

———————————————————————–

TgxBufferObjectHandle

GXS.Context

Manages a handle to a Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TgxBufferU

GXS.InitOpenGL

———————————————————————–

TgxBufferU

OpenGXS.InitFMX

———————————————————————–

TgxBufferV

GXS.InitOpenGL

———————————————————————–

TgxBufferV

OpenGXS.InitFMX

———————————————————————–

TgxBumpmapHDS

GXS.BumpmapHDS

An Height Data Source that generates elevation bumpmaps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

TgxBumpShader

GXSL.BumpShaders

A generic bump shader

TgxButton

GXS.Windows

TgxCadencedComponent

GXS.Cadencer

TgxCadencer

GXS.Cadencer

This component allows auto-progression of animation. Basicly dropping this component and linking it to your TgxScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene). The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

TgxCadencerMode

GXS.Cadencer

Determines how the TgxCadencer operates. - cmManual : you must trigger progress manually (in your code) - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

TgxCadencerTimeReference

GXS.Cadencer

Determines which time reference the TgxCadencer should use. - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems) - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems) - cmExternal : the CurrentTime property is used

TgxCamera

GXS.Scene

Camera object. This object is commonly referred by TgxSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

TgxCameraController

GXS.CameraController

TgxCameraInvarianceMode

GXS.Scene

TgxCameraInvariantObject

GXS.Scene

Base class for camera invariant objects. Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

TgxCameraJob

GXS.CameraController

TgxCameraJobEvent

GXS.CameraController

TgxCameraJobList

GXS.CameraController

TgxCameraKeepFOVMode

GXS.Scene

TgxCameraStyle

GXS.Scene

TgxCanvas

GXS.Canvas

A simple Canvas-like interface for OpenGL. This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points. This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner. All coordinates are internally maintained with floating point precision. Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

TgxCapsule

GXS.GeomObjects

Capsule object, can also be used to make truncated cones

TgxCapType

GXS.Objects

TgxCelShader

GXS.CelShader

A generic cel shader.

TgxCelShader

GXSL.ShapeShaders

A generic cel shader.

TgxCelShaderGetIntensity

GXS.CelShader

An event for user defined cel intensity.

TgxCelShaderGetIntensity

GXSL.ShapeShaders

An event for user defined cel intensity.

TgxCelShaderOption

GXS.CelShader

Cel shading options. csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

TgxCelShaderOption

GXSL.ShapeShaders

A shader that applies cel shading through a vertex program and shade definition texture. Cel shading options: csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

TgxCelShaderOptions

GXS.CelShader

TgxCelShaderOptions

GXSL.ShapeShaders

TgxCheckBox

GXS.Windows

TgxCollisionManager

GXS.Collision

TgxColorComponent

GXS.State

TSingleCullFaceMode = cmFront..cmBack;

TgxColorDepth

GXS.Scene

TgxColorMask

GXS.State

TgxColorProperty

GXS.SceneRegister

TgxColorProxy

GXS.ProxyObjects

A proxy object with its own color. This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

TgxCombinerCache

GXS.TextureCombiners

TgxCombinerCommand

GXS.TextureCombiners

TgxComparisonFunction

GXS.State

TgxCompositeImage

GXS.CompositeImage

TgxCone

GXS.GeomObjects

A cone object

TgxConePart

GXS.GeomObjects

TgxConeParts

GXS.GeomObjects

TgxConsole

GXS.Console

TgxConsoleCommand

GXS.Console

A wrapper for a console command.

TgxConsoleCommandList

GXS.Console

TgxConsoleControls

GXS.Console

TgxConsoleMatchList

GXS.Console

TgxConsoleOption

GXS.Console

TgxConsoleOptions

GXS.Console

remove quotes when a command line is parsed

TgxConsoleStringList

GXS.Console

A class that checks for duplicates.

TgxContext

GXS.Context

Wrapper around an OpenGL rendering context. The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection. This is a virtual abstract a class, and platform-specific subclasses must be used. All rendering context share the same lists.

TgxContextAcceleration

GXS.Context

TgxContextClass

GXS.Context

TgxContextHandle

GXS.Context

Wrapper around an OpenGL context handle. This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TgxListHandle and TgxTextureHandle subclasses.

TgxContextLayer

GXS.Context

TgxContextManager

GXS.Context

Stores and manages all the TgxContext objects.

TgxContextNotification

GXS.Context

TgxContextOption

GXS.Scene

Options for the rendering context. roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering. roRenderToWindows: ignored (legacy). roTwoSideLighting: enables two-side lighting model. roStereo: enables stereo support in the driver (it needs a stereo device to test...) roDestinationAlpha: request an Alpha channel for the rendered output roNoColorBuffer: don't request a color buffer (color depth setting ignored) roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling. roForwardContext: force OpenGL forward context

TgxContextOptions

GXS.Scene

TgxContour

GXS.MultiPolygon

TgxContourClass

GXS.MultiPolygon

TgxContourNodes

GXS.MultiPolygon

TgxContours

GXS.MultiPolygon

TgxCoordinatesProperty

GXS.SceneRegister

TgxCreateParams

GXS.SceneViewer

WGL_EXT_swap_control

TgxCube

GXS.Objects

A simple cube object. This cube use the same material for each of its faces, ie. all faces look the same. If you want a multi-material cube, use a mesh in conjunction with a TgxFreeForm and a material library.

TgxCubeMapImage

GXS.Texture

A texture image used for specifying and stroing a cube map. Not unlike TgxPictureImage, but storing 6 of them instead of just one. Saving & loading as a whole currently not supported.

TgxCubeMapTarget

GXS.Texture

TgxCubePart

GXS.Objects

TgxCubeParts

GXS.Objects

TgxCullFaceMode

GXS.State

TgxCustomAsmShader

GXSL.AsmShader

TgxCustomAtmosphere

GXS.Atmosphere

This class imitates an atmosphere around a planet.

TgxCustomBitmapFont

GXS.BitmapFont

Provides access to individual characters in a BitmapFont. Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column). Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap. Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

TgxCustomCadencedComponent

GXS.Cadencer

Adds a property to connect/subscribe to a cadencer.

TgxCustomConsole

GXS.Console

TgxCustomConsole

TgxCustomControl

GXS.Windows

TgxCustomFeedBackMesh

GXS.CUDA.Graphics

TgxCustomGLSLDiffuseSpecularShader

GXSL.DiffuseSpecularShader

******** Single Light ************

TgxCustomGLSLDiffuseSpecularShaderMT

GXSL.DiffuseSpecularShader

TgxCustomGLSLFurShader

GXSL.ShapeShaders

Custom class for Fur Shader

TgxCustomGLSLGlassShader

GXSL.ShapeShaders

Custom class for Glass shader: Environment mapping and refraction mapping using the fresnel terms

TgxCustomGLSLIvoryShader

GXSL.ShapeShaders

Custom class for a shader that simulate Ivory Material

TgxCustomGLSLLatticeShader

GXSL.ShapeShaders

Custom class for GLSLLatticeShader. A shader that simulate Lattice with Diffuse/Specular and support Texture

TgxCustomGLSLMLDiffuseSpecularShader

GXSL.DiffuseSpecularShader

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

TgxCustomGLSLMLDiffuseSpecularShaderMT

GXSL.DiffuseSpecularShader

TgxCustomGLSLSemShader

GXSL.ShapeShaders

Custom class for SEM Shader : Spherical Environment Mapping

TgxCustomGLSLSimpleErosionShader

GXSL.ShapeShaders

Custom class for a shader that Erode surface object

TgxCustomGLSLSimpleGoochShader

GXSL.ShapeShaders

Custom class for Gooch Shader

TgxCustomGLSLSimpleLatticeShader

GXSL.ShapeShaders

Custom class for a shader that simulate Lattice

TgxCustomGLSLToonShader

GXSL.ShapeShaders

Custom class for Toon Shader

TgxCustomGLSLVertexDisplacementShader

GXSL.ShapeShaders

VertexDisplacement shader: Basic Vertex Displacement with Perlin Noise You can Improved it: The vertex displacement can be done by reading a 2D or 3D texture. It can be done along the normal or the tangent. It can be scaled, twisted, modulated, inverted... Converted from : https://www.clicktorelease.com/blog/vertex-displacement-noise-3d-webgl-glsl-three-js At this time only one light source is supported

TgxCustomHDS

GXS.HeightData

An Height Data Source for custom use. Provides event handlers for the various requests to be implemented application-side (for application-specific needs).

TgxCustomPFXManager

GXS.ParticleFX

A particles FX manager offering events for customization/experimentation. This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager. If the events aren't handled, nothing will be rendered.

TgxCustomRandomHDS

GXS.RandomHDS

Base structure for all random landscape objects. It can't be used directly since its BuildHeightField procedure is abstract. Use one of its descendants instead.

TgxCustomRenderEvent

GXS.Windows

TgxCustomSceneObject

GXS.Scene

Extended base scene object class with a material property. The material allows defining a color and texture for the object, see TgxMaterial.

TgxCustomShader

GXSL.CustomShader

A pure abstract class, must be overriden.

TgxCustomShaderCombiner

GXSL.ShaderCombiner

TgxCustomShaderParameter

GXSL.CustomShader

Wrapper around a parameter of the main program.

TgxCustomSpritePFXManager

GXS.ParticleFX

A sprite-based particles FX managers using user-specified code to prepare the texture .

TgxCyborg

GXS.SmartObjects

The Cyborg class specialized as a smart actor with AI. The TgxCyborg provides a quick interface to animated actors based on morph or skeleton frames, it is capable of performing frame interpolation and thinking blending (via TGLThinkingController components).

TgxCyborgManager

GXS.CyborgManager

TgxCyborgOption

GXS.SmartObjects

TgxCyborgOptions

GXS.SmartObjects

TgxCyborgReference

GXS.SmartObjects

TgxCyborgSenceOrgans

GXS.SmartObjects

TgxCyborgThinkMode

GXS.SmartObjects

TgxCyborgThinks

GXS.SmartObjects

TgxCyborgThinksList

GXS.SmartObjects

A list of thinking periods for TgxCyborgThinkMode

TgxCylinder

GXS.GeomObjects

Cylinder object, can also be used to make truncated cones

TgxCylinderAlignment

GXS.GeomObjects

TgxCylinderBase

GXS.GeomObjects

Base class to cylinder-like objects. Introduces the basic cylinder description properties. Be aware teh default slices and stacks make up for a high-poly cylinder, unless you're after high-quality lighting it is recommended to reduce the Stacks property to 1.

TgxCylinderPart

GXS.GeomObjects

TgxCylinderParts

GXS.GeomObjects

TgxDamping

GXS.Behaviours

Holds parameters for TgxScene basic damping model. Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass. Formulas : damping = constant + linear * Speed + quadratic * Speedˆ2 accel = damping / Mass That's just basic physics :). A note on the components : constant : use it for solid friction (will stop abruptly an object after decreasing its speed. linear : linear friction damping. quadratic : expresses viscosity.

TgxDampingFieldEmitter

GXS.PhysFields

TgxDataFile

GXS.ApplicationFileIO

Abstract base class for data file formats interfaces. This class declares base file-related behaviours, ie. ability to load/save from a file or a stream. It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

TgxDataFileCapability

GXS.ApplicationFileIO

TgxDataFileClass

GXS.ApplicationFileIO

TgxDCECollision

GXS.DCE

TgxDCECollisionEvent

GXS.DCE

TgxDCECollisionSelection

GXS.DCE

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: ccsDCEStandard: Collides bodies if A.layer <= B.layer ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0)

TgxDCEDynamic

GXS.DCE

TgxDCEManager

GXS.DCE

TgxDCEObjectCollisionEvent

GXS.DCE

TgxDCEShape

GXS.DCE

Only csEllipsoid can have dynamic behaviour

TgxDCESlideOrBounce

GXS.DCE

TgxDCEStatic

GXS.DCE

TgxDDSDetailLevels

GXS.FileDDS

TgxDDSImage

GXS.FileDDS

TgxDepthCompareFunc

GXS.Texture

Specifies the depth comparison function.

TgxDepthFunction

GXS.State

TgxDepthPrecision

GXS.Scene

TgxDepthProperties

GXS.Material

TgxDepthRBO

GXS.FBO

TgxDepthTextureMode

GXS.Texture

Specifies how depth values should be treated during filtering and texture application

TgxDirectOpenGL

GXS.Scene

Provides a way to issue direct OpenGL calls during the rendering. You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.

TgxDisk

GXS.GeomObjects

A Disk object. The disk may not be complete, it can have a hole (controled by the InnerRadius property) and can only be a slice (controled by the StartAngle and SweepAngle properties).

TgxDisplayOptions

GXS.Screen

TgxDodecahedron

GXS.GeomObjects

The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TGXDrawState

GXS.RenderContextInfo

TgxDstBlendFunction

GXS.State

TgxDummyCube

GXS.Objects

A simple cube, invisible at run-time. This is a usually non-visible object -except at design-time- used for building hierarchies or groups, when some kind of joint or movement mechanism needs be described, you can use DummyCubes. DummyCube's barycenter is its children's barycenter. The DummyCube can optionnally amalgamate all its children into a single display list (see Amalgamate property).

TgxDwsActiveBehaviour

GXS.DwsObjects

A DelphiWebScript enabled behaviour. This behaviour also calls on the OnProgress and OnBeginProgram procedures in the script if they are found. Once compiled and executed the program remains active until killed, deactivated or the script is invalidated.

TgxDXFVectorFile

GXS.FileDXF

TgxDynamicImposterBuilder

GXS.Imposter

TgxDynamicPFXManager

GXS.ParticleFX

An abstract PFX manager for simple dynamic particles. Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

TgxDynamicTextureImage

GXS.DynamicTexture

Allows for fast updating of the texture at runtime.

TgxEarthSkyDome

GXS.Skydome

Render a skydome like what can be seen on earth. Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render exoplanet atmospheres too. The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TgxEarthSkyDome.

TgxEdit

GXS.Windows

TgxEffect

GXS.Scene

TgxEffectClass = class of TgxEffect;

TgxEffectClass

GXS.Scene

TgxEffects

GXS.Scene

Holds a list of object effects. This object expects itself to be owned by a TgxBaseSceneObject.

TgxEnabledRenderBuffer

GXS.FBORenderer

TgxEnabledRenderBuffers

GXS.FBORenderer

TgxEParticleMask

GXS.EParticleMasksManager

TgxEParticleMasks

GXS.EParticleMasksManager

TgxEParticleMasksManager

GXS.EParticleMasksManager

TgxEProjectedParticleMask

GXS.EParticleMasksManager

TgxExtrusionSolid

GXS.Extrusion

Extrudes a complex Polygon into Z direction. For contour description see TgxMultiPolygonBase. properties Parts, Height (or should we better cal it Depth, because its in Z?), Stacks, Normals and NormalDirection are equivalent to TgxRevolutionSolid. If Normals=nsSmooth and the angle between two consecutive normals along the contour is less than MinSmoothAngle, smoothing is done, otherweise flat normals are used. This makes it possible to have smooth normals on sharp edged contours.

TgxExtrusionSolidPart

GXS.Extrusion

TgxExtrusionSolidParts

GXS.Extrusion

TgxFaceCulling

GXS.Material

TgxFaceGroup

GXS.VectorFileObjects

Describes a face group of a TgxMeshObject. Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object". Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

TgxFaceGroupConnectivity

GXS.BaseMeshSilhouette

TgxFaceGroupMeshMode

GXS.VectorFileObjects

Known descriptions for face group mesh modes. - fgmmTriangles : issue all vertices with GL_TRIANGLES. - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP. - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle. - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN. - fgmmQuads : issue all vertices with GL_QUADS.

TgxFaceGroups

GXS.VectorFileObjects

A list of TgxFaceGroup objects.

TgxFaceProperties

GXS.Material

Stores basic face lighting properties. The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools. You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

TgxFaceWinding

GXS.State

Describe what kind of winding has a front face

TgxFBOClearOption

GXS.FBORenderer

TgxFBOClearOptions

GXS.FBORenderer

TgxFBORenderer

GXS.FBORenderer

TgxFBOTargetVisibility

GXS.FBORenderer

TgxFeedback

GXS.Feedback

An object encapsulating the feedback rendering mode.

TgxFeedBackMesh

GXS.CUDA.Graphics

TgxFGIndexTexCoordList

GXS.VectorFileObjects

Adds per index texture coordinates to its ancestor. Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

TgxFGVertexIndexList

GXS.VectorFileObjects

A face group based on an indexlist. The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.

TgxFile3DSActor

GXS.File3DSSceneObjects

TgxFile3DSAnimationData

GXS.File3DS

A record that holds all the information that is used during 3ds animation.

TgxFile3DSAnimationKeyList

GXS.File3DS

TgxFile3DSAnimationKeys

GXS.File3DS

An abstract class that describes how to interpolate animation keys.

TgxFile3DSAnimKeysClassType

GXS.File3DS

Used only for serialization. There probably is a more efficient way to do it.

TgxFile3DSCamera

GXS.File3DSSceneObjects

TgxFile3DSCameraObject

GXS.File3DS

A 3ds-specific camera.

TgxFile3DSColorAnimationKeys

GXS.File3DS

TgxFile3DSDummyObject

GXS.File3DS

A 3ds-specific TgxMorphableMeshObject.

TgxFile3DSFreeForm

GXS.File3DSSceneObjects

TgxFile3DSLight

GXS.File3DSSceneObjects

TgxFile3DSLightHotSpotAnimationKeys

GXS.File3DS

TgxFile3DSMeshObject

GXS.File3DS

A 3ds-specific mesh object.

TgxFile3DSOmniLightObject

GXS.File3DS

A 3ds-specific omni light.

TgxFile3DSPositionAnimationKeys

GXS.File3DS

TgxFile3DSRollAnimationKeys

GXS.File3DS

TgxFile3DSRotationAnimationKeys

GXS.File3DS

TgxFile3DSScaleAnimationKeys

GXS.File3DS

TgxFile3DSSpotLightCutOffAnimationKeys

GXS.File3DS

TgxFile3DSSpotLightObject

GXS.File3DS

A 3ds-specific spot light.

TgxFileDAE

GXS.FileDAE

The DAE vector file (COLLADA actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).

TgxFinishTaskEvent

GXS.Context

TgxFireFXManager

GXS.FireFX

Fire special effect manager. Defines the looks and behaviour of a particle system that can be made to look fire-like.

TgxFlareGradient

GXS.LensFlare

The actual gradients between two colors are, of course, calculated by OpenGL. The start and end colors of a gradient are stored to represent the color of lens flare elements.

TgxFlatText

GXS.BitmapFont

A 2D text displayed and positionned in 3D coordinates. The FlatText uses a character font defined and stored by a TgxBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

TgxFlatTextOption

GXS.BitmapFont

TgxFlatTextOptions

GXS.BitmapFont

TgxFocusControl

GXS.Windows

TgxFogDistance

GXS.Scene

Fog distance calculation mode. fdDefault: let OpenGL use its default formula fdEyeRadial: uses radial "true" distance (best quality) fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

TgxFogEnvironment

GXS.Scene

Parameters for fog environment in a scene. The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

TgxFogMode

GXS.Scene

TgxForce

GXS.PhysForces

TgxForces

GXS.PhysManager

TgxForceType

GXS.PhysForces

TgxForm

GXS.Windows

TgxFormCanClose

GXS.Windows

TgxFormCanRequest

GXS.Windows

TgxFormCloseOptions

GXS.Windows

TgxFormMove

GXS.Windows

TgxFormNotify

GXS.Windows

TgxFPSMovementManager

GXS.FPSMovement

TgxFractalArchipelago

GXS.RandomHDS

TgxFractalHDS

GXS.RandomHDS

Random landscape based on the middle-point displacement algorithm

TgxFragmentProgram

GXSL.CustomShader

TgxFragmentProgramHandle

GXS.Context

TgxFragmentShaderHandle

GXS.Context

Manages a handle to a Fragment Shader Object.

TgxFrameBuffer

GXS.FBO

TgxFramebufferHandle

GXS.Context

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.

TgxFramebufferStatus

GXS.Context

TgxFreeForm

GXS.VectorFileObjects

Container objects for a vector file mesh. FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method. A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

TgxFreeFormProxy

GXS.ProxyObjects

A proxy object specialized for FreeForms.

TgxFrustrum

GXS.GeomObjects

A frustrum is a pyramid with the top chopped off. The height of the imaginary pyramid is ApexHeight, the height of the frustrum is Height. If ApexHeight and Height are the same, the frustrum degenerates into a pyramid. Height cannot be greater than ApexHeight.

TgxFullScreenViewer

GXS.FullScreenViewer

A FullScreen viewer. This non visual viewer will, when activated, use the full screen as rendering surface. It will also switch/restore videomode depending on the required width/height. This is performed by creating an underlying TForm and using its surface for rendering OpenGL, "decent" ICDs will automatically use PageFlipping instead of BlockTransfer (slower buffer flipping mode used for windowed OpenGL). Note: if you terminate the application either via a kill or in the IDE, the original resolution isn't restored.

TgxGameMenu

GXS.GameMenu

Classic game menu interface made of several lines.

TgxGameMenuScale

GXS.GameMenu

TgxGeometryProgram

GXSL.CustomShader

TgxGeometryProgramHandle

GXS.Context

TgxGeometryShaderHandle

GXS.Context

Manages a handle to a Geometry Shader Object.

TgxGizmo

GXS.Gizmo

TgxGizmoAcceptEvent

GXS.Gizmo

TgxGizmoAxis

GXS.Gizmo

TgxGizmoElement

GXS.Gizmo

TgxGizmoElements

GXS.Gizmo

TgxGizmoEx

GXS.GizmoEx

TgxGizmoExAcceptEvent

GXS.GizmoEx

TgxGizmoExActionHistoryCollection

GXS.GizmoEx

TgxGizmoExActionHistoryItem

GXS.GizmoEx

TgxGizmoExAxis

GXS.GizmoEx

TgxGizmoExAxisSelected

GXS.GizmoEx

TgxGizmoExObjectCollection

GXS.GizmoEx

TgxGizmoExObjectItem

GXS.GizmoEx

TgxGizmoExOperation

GXS.GizmoEx

TgxGizmoExOperationMode

GXS.GizmoEx

TgxGizmoExPickMode

GXS.GizmoEx

TgxGizmoExReferenceCoordinateSystem

GXS.GizmoEx

TgxGizmoExSelectionRegion

GXS.GizmoEx

TgxGizmoExSelRec

GXS.GizmoEx

TgxGizmoExUIArrowLine

GXS.GizmoEx

TgxGizmoExUIDisk

GXS.GizmoEx

TgxGizmoExUIFlatText

GXS.GizmoEx

TgxGizmoExUIFrustrum

GXS.GizmoEx

Gizmo objects

TgxGizmoExUILines

GXS.GizmoEx

TgxGizmoExUIPolygon

GXS.GizmoEx

TgxGizmoExUISphere

GXS.GizmoEx

TgxGizmoExUITorus

GXS.GizmoEx

TgxGizmoExVisibleInfoLabel

GXS.GizmoEx

TgxGizmoExVisibleInfoLabels

GXS.GizmoEx

TgxGizmoOperation

GXS.Gizmo

TgxGizmoPickCube

GXS.Gizmo

TgxGizmoPickMode

GXS.Gizmo

TgxGizmoPickTorus

GXS.Gizmo

TgxGizmoRayCastHitData

GXS.Gizmo

TgxGizmoUndoCollection

GXS.Gizmo

TgxGizmoUndoItem

GXS.Gizmo

TgxGizmoUpdateEvent

GXS.Gizmo

TgxGizmoVisibleInfoLabel

GXS.Gizmo

TgxGizmoVisibleInfoLabels

GXS.Gizmo

TgxGLAVectorFile

GXS.FileGL2

TgxGLMVectorFile

GXS.FileGL2

TgxGRDVectorFile

GXS.FileGRD

The GRD file represents ascii grid formats in 2D/3D. This is a format for storing regular grid values as a matrices of cell centers. The format supports variations and subformats. This importer works for Sutfer, ArcInfo and GMS formats

TgxgsInTypes

GXSL.Parameter

TgxgsOutTypes

GXSL.Parameter

TgxGTSVectorFile

GXS.FileGTS

The GTS vector file (GNU Triangulated Surface library). It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces. Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices). http://gts.sourceforge.net/

TgxGuiComponent

GXS.Gui

TgxGuiComponentList

GXS.Gui

TgxGuiComponentName

GXS.Gui

TgxGuiElement

GXS.Gui

TgxGuiElementList

GXS.Gui

TgxGuiElementName

GXS.Gui

TgxGuiLayout

GXS.Gui

TgxGUILayoutEditor

GXS.SceneRegister

TgxHDRImage

GXS.FileHDR

TgxHeightData

GXS.HeightData

TgxHeightData = class (TObject)

TgxHeightDataClass

GXS.HeightData

TgxHeightDataPostRenderEvent

GXS.TerrainRenderer

TgxHeightDataSource

GXS.HeightData

Base class for height datasources. This class is abstract and presents the standard interfaces for height data retrieval (TgxHeightData objects). The class offers the following features (that a subclass may decide to implement or not, what follow is the complete feature set, check subclass doc to see what is actually supported): Pooling / Cacheing (return a TgxHeightData with its "Release" method) Pre-loading : specify a list of TgxHeightData you want to preload Multi-threaded preload/queueing : specified list can be loaded in a background task

TgxHeightDataSourceFilter

GXS.HeightData

Height Data Source Filter. This component sits between the TgxTerrainRenderer, and a real TgxHeightDataSource. i.e. TgxTerrainRenderer links to this. This links to the real TgxHeightDataSource. Use the 'HeightDataSource' property, to link to a source HDS. The 'OnSourceDataFetched' event then gives you the opportunity to make any changes, or link in a texture to the TgxHeightData object, BEFORE it is cached. It bypasses the cache of the source HDS, by calling the source's StartPreparingData procedure directly. The TgxHeightData objects are then cached by THIS component, AFTER you have made your changes. This eliminates the need to copy and release the TgxHeightData object from the Source HDS's cache, before linking your texture. See the new version of TgxBumpmapHDS for an example. (LIN) To create your own HDSFilters, Derive from this component, and override the PreparingData procedure.

TgxHeightDataState

GXS.HeightData

Possible states for a TgxHeightData. hdsQueued : the data has been queued for loading hdsPreparing : the data is currently loading or being prepared for use hdsReady : the data is fully loaded and ready for use hdsNone : the height data does not exist for this tile

TgxHeightDataThread

GXS.HeightData

A thread specialized for processing TgxHeightData in background. Requirements: must have FreeOnTerminate set to true, must check and honour Terminated swiftly

TgxHeightDataType

GXS.HeightData

Determines the type of data stored in a TgxHeightData. There are 3 data types (8 bits unsigned, signed 16 bits and 32 bits). Conversions: (128*(ByteValue-128)) = SmallIntValue = Round(SingleValue). The 'hdtDefault' type is used for request only, and specifies that the default type for the source should be used.

TgxHeightDataUser

GXS.HeightData

TgxHeightField

GXS.Graph

Renders a sampled height-field. HeightFields are used to materialize z=f(x, y) surfaces, you can use it to render anything from math formulas to statistics. Most important properties of an height field are its sampling scales (X & Y) that determine the extents and the resolution of the base grid. The component will then invoke it OnGetHeight event to retrieve Z values for all of the grid points (values are retrieved only once for each point). Each point may have an additionnal color and texture coordinate.

TgxHeightFieldColorMode

GXS.Graph

TgxHeightFieldGetHeight2Event

GXS.Graph

TgxHeightFieldGetHeightEvent

GXS.Graph

TgxHeightFieldOption

GXS.Graph

TgxHeightFieldOptions

GXS.Graph

TgxHeightTile

GXS.HeightTileFile

TgxHeightTileFile

GXS.HeightTileFile

Interfaces a Tiled file

TgxHeightTileFileHDS

GXS.HeightTileFileHDS

An Height Data Source for the HTF format.

TgxHeightTileInfo

GXS.HeightTileFile

TgxHexahedron

GXS.GeomObjects

The hexahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TgxHiddenLineShader

GXS.HiddenLineShader

TgxHiddenLineShader

GXSL.LineShaders

TgxHintType

GXS.State

TgxHookesSpring

GXS.PhysForces

TgxHookesString

GXS.PhysForces

TgxHUDSprite

GXS.HUDObjects

A rectangular area, NOT perspective projected. (x, y) coordinates map directly to the viewport (in pixels) and refer the center of the area. The coordinate system is that of an equivalent TCanvas, ie. top-left point is the origin (0, 0). The z component is ignored and Z-Buffer is disabled when rendering. Using TgxHUDSprite in 2D only scenes : The most convenient way to use a TgxHUDSprite as a simple 2D sprite with blending capabilities (transparency or additive), is to set the texture mode to tmModulate, in FrontProperties, to use the Emission color to control coloring/intensity, and finally use the Diffuse color's alpha to control transparency (while setting the other RGB components to 0). You can also control aplha-blending by defining a <1 value in the sprite's AlphaChannel field. This provides you with hardware accelerated, alpha-blended blitting. Note : since TgxHUDSprite works in absolute coordinates, TgxProxyObject can't be used to duplicate an hud sprite.

TgxHUDText

GXS.HUDObjects

A 2D text displayed and positionned in 2D coordinates. The HUDText uses a character font defined and stored by a TgxBitmapFont component. The text can be scaled and rotated (2D), the layout and alignment can also be controled.

TgxIcosahedron

GXS.GeomObjects

The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TgxImage

GXS.Graphics

Contains and manipulates a 32 bits (24+8) bitmap. This is the base class for preparing and manipulating textures in GXS.Scene, this function does not rely on a windows handle and should be used for in-memory manipulations only. 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL. The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

TgxImageClassProperty

GXS.SceneRegister

TgxImageLevelDesc

GXS.Graphics

TgxImageLODRange

GXS.Graphics

TgxImagePiramid

GXS.Graphics

TgxImmaterialSceneObject

GXS.Scene

Base class for objects that do not have a published "material". Note that the material is available in public properties, but isn't applied automatically before invoking BuildList. Subclassing should be reserved to structural objects and objects that have no material of their own.

TgxImposter

GXS.Imposter

TgxImposterBuilder

GXS.Imposter

Abstract ImposterBuilder class.

TgxInertiaTensor

GXS.PhysInertias

Stores Inertia Tensor for TgxRigidBodyInertia model

TgxInitializableObjectList

GXS.Scene

Just a list of objects that support IGLInitializable.

TgxIsoline

GXS.Isolines

TgxIsolines

GXS.Isolines

TgxIsolineState

GXS.Isolines

TgxJoystick

GXS.Joystick

A component interfacing the Joystick via the (regular) windows API.

TgxJPEGImage

GXS.FileJPEG

TgxLabel

GXS.Windows

TgxlConsoleEvent

GXS.Console

Event called when used presses the "Enter"

TgxLensFlare

GXS.LensFlare

TgxLibAsmProgNameProperty

GXS.SceneRegister

TgxLibAttachmentNameProperty

GXS.SceneRegister

TgxLibCombinerNameProperty

GXS.SceneRegister

TgxLibMaterial

GXS.Material

Material in a material library. Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

TgxLibMaterialName

GXS.Material

TgxLibMaterialNameProperty

GXS.SceneRegister

DesignIntf, DesignEditors, DesignMenus,

TgxLibMaterials

GXS.Material

A collection of materials, mainly used in material libraries.

TgxLibSamplerNameProperty

GXS.SceneRegister

TgxLibShaderNameProperty

GXS.SceneRegister

TgxLibTextureNameProperty

GXS.SceneRegister

TgxLifeColoredPFXManager

GXS.ParticleFX

Base PFX manager for particles with life colors. Particles have a core and edge color, for subclassing.

TgxLightSource

GXS.Scene

Standard light source. The standard light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle). Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property. Lightsources are managed in a specific object by the TgxScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

TgxLightSourceEnum

GXSL.CustomShader

TgxLightSourceSet

GXSL.CustomShader

TgxLightSourceState

GXS.State

TgxLightStyle

GXS.Scene

Defines the various styles for lightsources. lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering)

TgxLimitType

GXS.Scene

IDs for limit determination

TgxLineBase

GXS.Objects

Base class for line objects. Introduces line style properties (width, color...)

TgxLineParticle

GXS.LinePFX

Linear particle.

TgxLinePFXManager

GXS.LinePFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.

TgxLines

GXS.Objects

Set of 3D line segments. You define a 3D Line by adding its nodes in the "Nodes" property. The line may be rendered as a set of segment or as a curve (nodes then act as spline control points). Alternatively, you can also use it to render a set of spacial nodes (points in space), just make the lines transparent and the nodes visible by picking the node aspect that suits you.

TgxLineSettings

GXS.HiddenLineShader

TgxLineSettings

GXSL.LineShaders

TgxLinesNode

GXS.Objects

Specialized Node for use in a TgxLines objects. Adds a Color property (TgxColor).

TgxLinesNodes

GXS.Objects

Specialized collection for Nodes in a TgxLines objects. Stores TgxLinesNode items.

TgxLinesOptions

GXS.Objects

TgxLineSplineMode

GXS.Objects

Available spline modes for a TLine.

TgxListHandle

GXS.Context

Manages a handle to a display list.

TgxLMTSVectorFile

GXS.FileLMTS

TgxLODStreamingState

GXS.Graphics

TgxLogicOp

GXS.State

TgxLWOVectorFile

GXS.FileLWO

TgxMagFilter

GXS.Texture

TgxMapCollection

GXS.FPSMovement

TgxMapCollectionItem

GXS.FPSMovement

TgxMapCollectionItemClass

GXS.FPSMovement

TgxMarchingCube

GXS.Isosurface

TgxMaterial

GXS.Material

Describes a rendering material. A material is basically a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping. An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TgxLibMaterial (taken for a material library). The TgxLibMaterial has more advanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps

TgxMaterialComponentNameProperty

GXS.SceneRegister

TgxMaterialLevel

GXS.State

TgxMaterialLibrary

GXS.Material

Stores a set of materials, to be used and shared by scene objects. Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time. Materials in a material library also feature advanced control properties like texture coordinates transforms.

TgxMaterialLibraryEditor

GXS.SceneRegister

Editor for material library.

TgxMaterialLibraryItem

GXS.MaterialScript

TgxMaterialLibraryItems

GXS.MaterialScript

TgxMaterialMultiProxy

GXS.MaterialMultiProxy

Multiple Proxy object. This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

TgxMaterialMultiProxyMaster

GXS.MaterialMultiProxy

MasterObject description for a MultiProxy object.

TgxMaterialMultiProxyMasters

GXS.MaterialMultiProxy

Collection of TgxMaterialMultiProxyMaster.

TgxMaterialOption

GXS.Material

Control special rendering options for a material. moIgnoreFog : fog is deactivated when the material is rendered

TgxMaterialOptions

GXS.Material

TgxMaterialProperty

GXS.SceneRegister

TgxMaterialProxy

GXS.ProxyObjects

A proxy object with its own material. This proxy object can take a mesh from one master and a materia from a material library.

TgxMaterialScripter

GXS.MaterialScript

TgxMD2VectorFile

GXS.FileMD2

The MD2 vector file (Quake2 actor file). Stores a set of "frames" describing the different postures of the actor, it may be animated by TgxActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap). Based on code by Roger Cao.

TgxMD3VectorFile

GXS.FileMD3

TgxMD5VectorFile

GXS.FileMD5

TgxMDCVectorFile

GXS.FileMDC

TgxMemoryViewer

GXS.Scene

Component to render a scene to memory only. This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

TgxMesh

GXS.Mesh

Basic mesh object. Each mesh holds a set of vertices and a Mode value defines how they make up the mesh (triangles, strips...)

TgxMeshAutoCentering

GXS.VectorFileObjects

TgxMeshAutoCenterings

GXS.VectorFileObjects

TgxMeshLines

GXS.MeshLines

TgxMeshMorphTarget

GXS.VectorFileObjects

A morph target, stores alternate lists of vertices and normals.

TgxMeshMorphTargetList

GXS.VectorFileObjects

A list of TgxMeshMorphTarget objects.

TgxMeshNormalsOrientation

GXS.VectorFileObjects

Determines how normals orientation is defined in a mesh. - mnoDefault : uses default orientation - mnoInvert : inverse of default orientation - mnoAutoSolid : autocalculate to make the mesh globally solid - mnoAutoHollow : autocalculate to make the mesh globally hollow

TgxMeshObject

GXS.VectorFileObjects

Base mesh class. Introduces base methods and properties for mesh objects. Subclasses are named "TMOxxx".

TgxMeshObjectList

GXS.VectorFileObjects

A list of TgxMeshObject objects.

TgxMeshObjectListClass

GXS.VectorFileObjects

TgxMeshObjectMode

GXS.VectorFileObjects

TgxMeshObjectRenderingOption

GXS.VectorFileObjects

Rendering options per TgxMeshObject. moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list.

TgxMeshObjectRenderingOptions

GXS.VectorFileObjects

TgxMeshObjectVerletNode

GXS.VerletClothify

TgxMeshPrimitive

GXS.State

TgxMeshPrimitives

GXS.State

TgxMinFilter

GXS.Texture

TgxMirror

GXS.Mirror

A simple plane mirror. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered). It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

TgxMorphableMeshObject

GXS.VectorFileObjects

Mesh object with support for morph targets. The morph targets allow to change vertices and normals according to pre- existing "morph targets".

TgxMotionBlur

GXS.Blur

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders. Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;) I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup

TgxMouseAction

GXS.Windows

TgxMovement

GXS.Movement

TgxMovementPath

GXS.Movement

TgxMovementPaths

GXS.Movement

TgxMovementRotationMode

GXS.Movement

TgxMoveToPosJob

GXS.CameraController

TgxMP3File

GXS.FileMP3

Support for MP3 format. *Partial* support only, access to PCMData is NOT supported.

TgxMS3DVectorFile

GXS.FileMS3D

The MilkShape vector file. By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

TgxMTLFile

GXS.FileOBJ

A simple class that know how to extract infos from a mtl file. mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more): materials begin with a 'newmtl' command followed by material name *Kd command defines the diffuse color *map_Kd command defines the diffuse texture image *Ka/map_Ka define the ambient color and texmap *Ks/map_Ks define the specular color and texmap *Ke/map_Ke define the self-illumination/lightmap texmap map_Bump specifies the bump map *d specifies transparency (alpha-channel, range [0; 1]) map_d specifies the opcaity texture map Ns defines the specular exponent or shininess or phong specular (?) Ni is the refraction index (greater than 1) *illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting)

TgxMultiMaterialShader

GXS.MultiMaterialShader

TgxMultiMaterialShader

GXSL.MultiMaterialShader

TgxMultiPolygon

GXS.MultiPolygon

A polygon that can have holes and multiple contours. Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

TgxMultiPolygonBase

GXS.MultiPolygon

Multipolygon is defined with multiple contours. The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator). The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one. Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended. TgxMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of GXS.VectorLists.

TgxMultiProxy

GXS.MultiProxy

Multiple Proxy object. This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation. For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

TgxMultiProxyMaster

GXS.MultiProxy

MasterObject description for a MultiProxy object.

TgxMultiProxyMasters

GXS.MultiProxy

Collection of TgxMultiProxyMaster.

TgxMultisampleImage

GXS.MultisampleImage

TgxNavigator

GXS.Navigator

TgxNavigator is the component for moving a TgxBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor. The four calls to get you started is TurnHorisontal : it turns left and right. TurnVertical : it turns up and down. MoveForward : moves back and forth. FlyForward : moves back and forth in the movingobject's direction
The three properties to get you started is MovingObject : The Object that you are moving. UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal.

TgxNavigatorAbstractParameters

GXS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement.

TgxNavigatorAdjustDistanceParameters

GXS.SmoothNavigator

This is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work

TgxNavigatorAdjustDistanceParametersEx

GXS.SmoothNavigator

This is a wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

TgxNavigatorGeneralParameters

GXS.SmoothNavigator

This is a wrapper for all general inertia parameters. These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

TgxNavigatorInertiaParameters

GXS.SmoothNavigator

This is a wrapper for all parameters that affect the smoothness of movement

TgxNavigatorMoveAroundParameters

GXS.SmoothNavigator

This is a wrapper for all parameters that effect how the TgxBaseSceneObject.MoveObjectAround() procedure works

TgxNavigatorSmoothChangeItem

GXS.SmoothNavigator

Includes a basic set of parameters that control the smoothness of movement

TgxNavigatorSmoothChangeItemClass

GXS.SmoothNavigator

TgxNavigatorSmoothChangeItems

GXS.SmoothNavigator

XCollection of TgxNavigatorSmoothChangeItem.

TgxNavigatorSmoothChangeSingle

GXS.SmoothNavigator

Smoothly change any Single value, so it will become TargetValue in the end.

TgxNavigatorSmoothChangeSingleGetEvent

GXS.SmoothNavigator

TgxNavigatorSmoothChangeSingleSetEvent

GXS.SmoothNavigator

TgxNavigatorSmoothChangeVector

GXS.SmoothNavigator

Smoothly change any Vector4f value, so it will become TargetValue in the end.

TgxNavigatorSmoothChangeVectorGetEvent

GXS.SmoothNavigator

TgxNavigatorSmoothChangeVectorSetEvent

GXS.SmoothNavigator

TgxNGDBehaviour

GXS.NGDManager

Basis structures for behaviour style implementations.

TgxNGDBehaviourList

GXS.NGDManager

TgxNGDCollisions

GXS.NGDManager

TgxNGDDebugOption

GXS.NGDManager

TgxNGDDynamic

GXS.NGDManager

TgxNGDFrictionModels

GXS.NGDManager

TgxNGDHeightField

GXS.NGDManager

TgxNGDJoint

GXS.NGDManager

TgxNGDJointBallAndSocket

GXS.NGDManager

TgxNGDJointHinge

GXS.NGDManager

TgxNGDJointKinematicController

GXS.NGDManager

TgxNGDJointPin

GXS.NGDManager

TgxNGDJointPin2

GXS.NGDManager

TgxNGDJointPivot

GXS.NGDManager

TgxNGDJoints

GXS.NGDManager

TgxNGDJointSlider

GXS.NGDManager

TgxNGDManager

GXS.NGDManager

TgxNGDManagerDebug

GXS.NGDManager

TgxNGDManagerDebugs

GXS.NGDManager

TgxNGDPickedActions

GXS.NGDManager

TgxNGDSolverModels

GXS.NGDManager

TgxNGDStatic

GXS.NGDManager

TgxNGDSurfaceItem

GXS.NGDManager

TgxNGDSurfacePair

GXS.NGDManager

TgxNMFVectorFile

GXS.FileNMF

TgxNode

GXS.Nodes

TgxNodedLines

GXS.Objects

Class that defines lines via a series of nodes. Base class, does not render anything.

TgxNodes

GXS.Nodes

TgxNodesClass

GXS.Nodes

TgxNonVisualViewer

GXS.Scene

Base class for non-visual viewer. Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

TgxNormalDirection

GXS.Scene

TgxNormalSmoothing

GXS.Objects

Determines how and if normals are smoothed. - nsFlat : facetted look - nsSmooth : smooth look - nsNone : unlighted rendering, usefull for decla texturing

TgxNurbsVectorFile

GXS.FileNurbs

TgxObjectAfterEffect

GXS.Scene

An object effect that gets rendered at scene's end. No particular OpenGL matrices or material should be assumed.

TgxObjectBBChange

GXS.Scene

TgxObjectBBChanges

GXS.Scene

TgxObjectChange

GXS.Scene

Used to describe only the changes in an object, which have to be reflected in the scene

TgxObjectChanges

GXS.Scene

TgxObjectManager

GXS.ObjectManager

TgxObjectPostEffect

GXS.Scene

An object effect that gets rendered after owner object's render. The current OpenGL matrices and material are that of the owner object.

TgxObjectPreEffect

GXS.Scene

An object effect that gets rendered before owner object's render. The current OpenGL matrices and material are that of the owner object.

TgxObjectsSorting

GXS.RenderContextInfo

Determines if objects are sorted, and how. Sorting is done level by level (and not for all entities), values are : osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst osNone : do not sort objects. osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. osRenderNearestFirst : render objects whose Position is the nearest to the camera first.

TgxObjectStyle

GXS.Scene

Possible styles/options for objects. Allowed styles are: osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered

TgxObjectStyles

GXS.Scene

TgxOBJVectorFile

GXS.FileOBJ

Allocate memory for the current line in chunks of LineLen Bytes

TgxOcclusionQueryHandle

GXS.Context

Manages a handle to an occlusion query. Requires OpenGL 1.5+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TgxOctahedron

GXS.GeomObjects

The octahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TgxOCTgxVectorFile

GXS.FileOCT

The OCT vector file (FSRad output).

TgxOctree

GXS.Octree

Manages an Octree containing references to triangles.

TgxOctreeNode

GXS.Octree

TgxOctreeTriangleInfo

GXS.Octree

Stores information about an intersected triangle.

TgxODEBehaviour

GXS.ODEManager

Basis structures for behaviour style implementations.

TgxODECollisionEvent

GXS.ODEManager

TgxODECollisionSurface

GXS.ODEManager

TgxODECollisionSurfaceMode

GXS.ODEManager

TgxODEContactPoint

GXS.ODEManager

TgxODECustomCollider

GXS.ODEManager

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms. Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE

TgxODECustomCollisionEvent

GXS.ODEManager

TgxODEDynamic

GXS.ODEManager

TgxODEElementBase

GXS.ODEManager

TgxODEElementBox

GXS.ODEManager

ODE box implementation.

TgxODEElementCapsule

GXS.ODEManager

ODE capped cylinder implementation.

TgxODEElementClass

GXS.ODEManager

TgxODEElementCylinder

GXS.ODEManager

ODE cylinder implementation.

TgxODEElementPlane

GXS.ODEManager

ODE plane implementation.

TgxODEElements

GXS.ODEManager

TgxODEElementSphere

GXS.ODEManager

ODE sphere implementation.

TgxODEElementTriMesh

GXS.ODEManager

ODE tri-mesh implementation.

TgxODEGetParamCallback

GXS.ODEManager

TgxODEHeightField

GXS.ODEManager

Add this behaviour to a TgxHeightField or TgxTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

TgxODEJointBall

GXS.ODEManager

ODE ball joint implementation

TgxODEJointBase

GXS.ODEManager

Base structures for ODE Joints.

TgxODEJointFixed

GXS.ODEManager

ODE fixed joint implementation.

TgxODEJointHinge

GXS.ODEManager

ODE hinge joint implementation.

TgxODEJointHinge2

GXS.ODEManager

ODE hinge2 joint implementation.

TgxODEJointList

GXS.ODEManager

Component front-end for storing ODE Joints.

TgxODEJointParams

GXS.ODEManager

TgxODEJoints

GXS.ODEManager

An XCollection decendant for ODE Joints.

TgxODEJointSlider

GXS.ODEManager

ODE slider joint implementation

TgxODEJointUniversal

GXS.ODEManager

ODE universal joint implementation

TgxODEManager

GXS.ODEManager

TgxODEObjectCollisionEvent

GXS.ODEManager

TgxODERagdoll

GXS.ODERagdoll

TgxODERagdollBone

GXS.ODERagdoll

TgxODERagdollCube

GXS.ODERagdoll

TgxODERagdollDummyJoint

GXS.ODERagdoll

TgxODERagdollHingeJoint

GXS.ODERagdoll

TgxODERagdollUniversalJoint

GXS.ODERagdoll

TgxODERagdollWorld

GXS.ODERagdoll

TgxODESetParamCallback

GXS.ODEManager

TgxODESolverMethod

GXS.ODEManager

TgxODEStatic

GXS.ODEManager

TgxOnCustomPerspective

GXS.Scene

TgxOnCustomPostEffectEvent

GXSL.PostEffects

TgxOnLightsChanged

GXS.State

TgxOpenGL

GXS.InitOpenGL

TgxOpenGL

OpenGXS.InitFMX

TgxOrbitToPosAdvJob

GXS.CameraController

TgxOrbitToPosJob

GXS.CameraController

TgxOutlineShader

GXS.OutlineShader

TgxOutlineShader

GXSL.LineShaders

TgxPackPBOHandle

GXS.Context

Manages a handle to PBO Pixel Pack Buffer. When bound, commands such as ReadPixels write their data into a buffer object.

TgxPanel

GXS.Windows

TgxParticle

GXS.ParticleFX

Base class for particles. The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

TgxParticleArray

GXS.ParticleFX

TgxParticleClass

GXS.ParticleFX

TgxParticleEvent

GXS.Particles

TgxParticleFXEffect

GXS.ParticleFX

Base class for linking scene objects to a particle FX manager.

TgxParticleFXManager

GXS.ParticleFX

Base class for particle FX managers. Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer. Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

TgxParticleFXRenderer

GXS.ParticleFX

Rendering interface for scene-wide particle FX. A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately. This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

TgxParticleInertia

GXS.PhysInertias

TgxParticleList

GXS.ParticleFX

List of particles. This list is managed with particles and performance in mind, make sure to check methods doc.

TgxParticles

GXS.Particles

Manager object of a particle system. Particles in a TgxParticles system are described as normal scene objects, however their children are to be : "particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. "live particle" : the other objects (index>0), this ones are rendered and receive progression events. TgxParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle. All direct access to a TgxParticles children should be avoided. For high-performance particle systems of basic particles, you should look into GXS.ParticleFX instead, TgxParticles being rather focused on complex particles.

TgxPathNode

GXS.Movement

TgxPathNodes

GXS.Movement

TgxPerlin3DNoise

GXS.PerlinPFX

Generates Perlin Noise in the [-1; 1] range. 2D noise requests are taken in the Z=0 slice

TgxPerlinHDS

GXS.Perlin

TgxPerlinHDSThread

GXS.Perlin

TgxPerlinInterpolation

GXS.Perlin

TgxPerlinOctav

GXS.Perlin

TgxPerlinPFXManager

GXS.PerlinPFX

A sprite-based particles FX manager using perlin-based sprites. This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles. The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

TgxPersistentImage

GXS.Texture

Stores any image compatible with Delphi's TgxPicture mechanism. The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage. Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

TgxPersistentTIE

GXS.TextureImageEditors

TgxPGMImage

GXS.FilePGM

TgxPhongShader

GXSL.PhongShader

TgxPhysManager

GXS.PhysManager

The Simple Physics Interaction (SPI) manager can only deal with objects from one scene More than one physics manager can be assigned to a scene

TgxPicFileImage

GXS.Texture

Uses a picture whose data is found in a file (only filename is stored). The image is unloaded after upload to OpenGL.

TgxPicFileTIE

GXS.TextureImageEditors

TgxPickList

GXS.Selection

List class for object picking. This list is used to store the results of a PickObjects call.

TgxPictureImage

GXS.Texture

Base class for image data classes internally based on a TgxPicture.

TgxPipe

GXS.Extrusion

A solid object generated by extruding a circle along a trajectory. Texture coordinates NOT supported yet.

TgxPipeNode

GXS.Extrusion

TgxPipeNodes

GXS.Extrusion

TgxPixel24

GXS.Graphics

TgxPixel32

GXS.Graphics

TgxPixel32Array

GXS.Graphics

TgxPlane

GXS.Objects

A simple plane object. Note that a plane is always made of a single quad (two triangles) and the tiling is only applied to texture coordinates.

TgxPlaneStyle

GXS.Objects

TgxPlaneStyles

GXS.Objects

TgxPLYVectorFile

GXS.FilePLY

The PLY vector file aka Stanford Triangle Format. This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

TgxPNGImage

GXS.FilePNG

TgxPointLightPFXManager

GXS.ParticleFX

A sprite-based particles FX managers using point light maps. The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property. This PFX manager renders particles similar to what you can get with TgxPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

TgxPointParameters

GXS.Objects

Point parameters as in ARB_point_parameters. Make sure to read the ARB_point_parameters spec if you want to understand what each parameter does.

TgxPoints

GXS.Objects

Renders a set of non-transparent colored points. The points positions and their color are defined through the Positions and Colors properties.

TgxPointStyle

GXS.Objects

TgxPolygon

GXS.GeomObjects

A basic polygon object. The curve is described by the Nodes and SplineMode properties, should be planar and is automatically tessellated. Texture coordinates are deduced from X and Y coordinates only. This object allows only for polygons described by a single curve, if you need "complex polygons" with holes, patches and cutouts, see GLMultiPolygon.

TgxPolygonBase

GXS.Objects

Base class for objects based on a polygon.

TgxPolygonList

GXS.MultiPolygon

TgxPolygonMode

GXS.State

TgxPolygonPart

GXS.GeomObjects

TgxPolygonParts

GXS.GeomObjects

TgxPolygonPFXManager

GXS.ParticleFX

Polygonal particles FX manager. The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available. If you render large particles and don't have T&L acceleration, consider using TgxPointLightPFXManager.

TgxPopupMenu

GXS.Windows

TgxPopupMenuClick

GXS.Windows

TgxPortal

GXS.Portal

Portal Renderer class.

TgxPortalMeshObjectList

GXS.Portal

A mesh object list that handles portal rendering. The items are treated as being sectors.

TgxPostEffect

GXSL.PostEffects

Provides a simple way to producing post-effects without shaders. It is slow as hell, but it's worth it in some cases.

TgxPostEffectBuffer

GXSL.PostEffects

TgxPostEffectColor

GXSL.PostEffects

TgxPostEffectPreset

GXSL.PostEffects

Some presets for TgxPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

TgxPostShaderCollection

GXSL.PostEffects

TgxPostShaderCollectionItem

GXSL.PostEffects

TgxPostShaderHolder

GXSL.PostEffects

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

TgxPrimitiveQueryHandle

GXS.Context

Manages a handle to a primitive query. Requires OpenGL 3.0+ Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TgxProcTextureNoise

GXS.ProcTextures

TgxProcTextureNoiseTIE

GXS.TextureImageEditors

TgxProgram

GXS.InitOpenGL

———————————————————————–

TgxProgram

OpenGXS.InitFMX

———————————————————————–

TgxProgramHandle

GXS.Context

Manages a GLSL Program Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TgxProgramHandleEXT

GXS.Context

TgxProjectedTextures

GXS.ProjectedTextures

Projected Textures Manager. Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

TgxProjectedTexturesStyle

GXS.ProjectedTextures

Possible styles of texture projection. Possible values: ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures).

TgxProxyObject

GXS.Scene

A full proxy object. This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own. Use it for duplicates of an object.

TgxProxyObjectClass

GXS.Scene

TgxProxyObjectOption

GXS.Scene

Defines which features are taken from the master object.

TgxProxyObjectOptions

GXS.Scene

TgxPythonEngine

GXS.Python.Script

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TgxScriptPython) retain it's assigned compiler from design to run -time.

TgxQ3BSPVectorFile

GXS.FileQ3BSP

The Q3BSP vector file (Quake III BSP).

TgxQuadricObject

GXS.Objects

Base class for quadric objects. Introduces some basic Quadric interaction functions (the actual quadric math is part of the GLU library).

TgxQueryHandle

GXS.Context

Manages a handle to a query. Do not use this class directly, use one of its subclasses instead.

TgxQueryType

GXS.State

TgxRagdolBone

GXS.Ragdoll

TgxRagdolBoneList

GXS.Ragdoll

TgxRagdolJoint

GXS.Ragdoll

TgxRagdoll

GXS.Ragdoll

TgxRCHandle

GXS.Context

TgxRCOption

GXS.Context

TgxRCOptions

GXS.Context

TgxRenderbuffer

GXS.FBO

TgxRenderbufferHandle

GXS.Context

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

TGXRenderContextClippingInfo

GXS.RenderContextInfo

TgxRenderContextInfo

GXS.RenderContextInfo

Stores contextual info useful during rendering methods.

TgxRenderPoint

GXS.Scene

Scene object that allows other objects to issue rendering at some point. This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase. Callbacks must be explicitly unregistered.

TgxResolutionIndependantHUDText

GXS.HUDObjects

Position (X and Y) is expected in a [0..1] range (from Screen size) This component converts this position to the actual screen position and renders the text there. This way a HUD text always appears to be in the the same place, regardless of the currect screen resolution. Note: this still does not solve the font scaling problem.

TgxResolutionProperty

GXS.SceneRegister

TgxResourceStream

GXS.ApplicationFileIO

TgxResourceType

GXS.CUDA.API

TgxReuseableDefaultEditor

GXS.SceneRegister

Editor copied from DsgnIntf. Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TgxSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! Grrr...

TgxRevolutionSolid

GXS.Extrusion

A solid object generated by rotating a curve along the Y axis. The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF). The TgxRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution. If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

TgxRevolutionSolidPart

GXS.Extrusion

TgxRevolutionSolidParts

GXS.Extrusion

TgxRigidBodyInertia

GXS.PhysInertias

A more complex model than TgxBInertia for Inertia

TgxROAMPatch

GXS.ROAMPatch

TgxROAMRenderPoint

GXS.ROAMPatch

TgxROAMTriangleNode

GXS.ROAMPatch

TgxSamplerHandle

GXS.Context

Manages a handle to a sampler.

TgxSamplingScale

GXS.Graph

TgxSArchiveManager

GXS.ArchiveManager

TgxSArchiveManagerEditor

GXS.SceneRegister

Editor for Archive Manager.

TgxScene

GXS.Scene

Scene object. The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TgxBaseSceneObject. It will usually contain one or more TgxCamera object, which can be referred by a Viewer component for rendering purposes. The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TgxScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TgxBaseSceneObject.

TgxSceneBuffer

GXS.Scene

Encapsulates an OpenGL frame/rendering buffer.

TgxSceneEditor

GXS.SceneRegister

TgxSceneObj

GXS.SpatialPartitioning

Object for holding scene objects in a spatial partitioning

TgxSceneObject

GXS.Scene

Base class for standard scene objects. Publishes the Material property.

TgxSceneObjectClass

GXS.Scene

TgxSceneObjectEntry

GXS.ObjectManager

holds a relation between an scene object class, its global identification, its location in the object stock and its icon reference

TgxSceneOperation

GXS.Scene

Flags for design notification

TgxSceneRootObject

GXS.Scene

This class shall be used only as a hierarchy root. It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations. Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

TgxSceneViewer

GXS.SceneViewer

Component where the GLScene objects get rendered. This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap. It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form). This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.

TgxSceneViewerEditor

GXS.SceneRegister

TgxSceneViewerMode

GXS.Scene

TgxSceneViewport

GXS.ViewerOpenGL

GL_ARB_framebuffer_object or GL_EXT_framebuffer_blit

TgxScreenControlingContext

GXS.Context

Context with screen control property and methods. This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API. TgxSceneViewer won't use them, TgxMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.

TgxScreenDepth

GXS.FullScreenViewer

TgxScreenSaver

GXS.ScreenSaver

Drop this component on your main form to make it a screensaver. You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab). How this component works : At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) At run-time, once its props are loaded, this component will parse the command line and trigger relevant events Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible)
There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

TgxScriptBase

GXS.ScriptBase

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

TgxScriptLibrary

GXS.ScriptBase

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

TgxScriptPython

GXS.Python.Script

Implements Python scripting functionality through the abstracted GLS.ScriptBase

TgxScripts

GXS.ScriptBase

XCollection descendant for storing and handling scripts.

TgxScriptState

GXS.ScriptBase

TgxScrollbar

GXS.Windows

TgxSCUDA

GXS.CUDA.API

TgxSCUDACompiler

GXS.CUDA.Compiler

TgxSCUDACompilerOutput

GXS.CUDA.Compiler

TgxSCUDADevice

GXS.CUDA.Context

TgxSCUDARealArch

GXS.CUDA.Compiler

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

TgxSCUDARealArchs

GXS.CUDA.Compiler

TgxSCUDAVirtArch

GXS.CUDA.Compiler

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

TgxSDLContext

SDLx.Context

A context driver for OpenGL via SDL (libsdl.org). Due to limitations of SDL: you may have only one SDL window opened at any time (you cannot have memory viewers) closing the SDL window will terminate the application

TgxSDLEvent

SDLx.Window

TgxSDLViewer

SDLx.Context

A viewer using SDL.
Beware: only one at a time, no other viewers allowed! Will also close the application when the window is closed!

TgxSDLWindow

SDLx.Window

A basic SDL-based window (non-visual component). Only a limited subset of SDL's features are available, and this window is heavily oriented toward using it for OpenGL rendering. Be aware SDL is currently limited to a single window at any time... so you may have multiple components, but only one can be used.

TgxSDLWindowOption

SDLx.Window

Specifies optional settings for the SDL window. Those options are a simplified subset of the SDL options: voDoubleBuffer: create a double-buffered window voOpenGL: requires OpenGL capability for the window voResizable: window should be resizable voFullScreen: requires a full screen "window" (screen resolution may be changed) voStencilBuffer: requires a stencil buffer (8bits, use along voOpenGL)

TgxSDLWindowOptions

SDLx.Window

TgxSDLWindowPixelDepth

SDLx.Window

Pixel Depth options. vpd16bits: 16bpp graphics (565) (and 16 bits depth buffer for OpenGL) vpd24bits: 24bpp graphics (565) (and 24 bits depth buffer for OpenGL)

TgxSectorMeshObject

GXS.Portal

A portal renderer sector.

TgxSelectRenderModeTechnique

GXS.Selection

TgxServiceContextTask

GXS.Context

TgxShadeModel

GXS.Scene

float_type

TgxShader

GXS.InitOpenGL

———————————————————————–

TgxShader

GXS.Material

Generic, abstract shader class. Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities. Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

TgxShader

OpenGXS.InitFMX

———————————————————————–

TgxShaderClass

GXS.Material

TgxShaderCombiner

GXSL.ShaderCombiner

TgxShaderCombinerType

GXSL.ShaderCombiner

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.
sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself
TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.
By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.

TgxShaderEditorProperty

GXS.SceneRegister

TgxShaderEvent

GXSL.CustomShader

TgxShaderF

GXS.InitOpenGL

———————————————————————–

TgxShaderF

OpenGXS.InitFMX

———————————————————————–

TgxShaderFailedInitAction

GXS.Material

Defines what to do if for some reason shader failed to initialize. fiaSilentdisable: just disable it fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage fiaReRaiseException: Re-raises the exception fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;)

TgxShaderFogSupport

GXSL.CustomShader

TgxShaderG

GXS.InitOpenGL

———————————————————————–

TgxShaderG

OpenGXS.InitFMX

———————————————————————–

TgxShaderHandle

GXS.Context

Manages a handle to a Shader Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

TgxShaderHandleClass

GXS.Context

TgxShaderItem

GXS.MaterialScript

TgxShaderItems

GXS.MaterialScript

TgxShaderLightSourceState

GXS.State

TgxShaderProgram

GXSL.CustomShader

A custom shader program.

TgxShaderStyle

GXS.Material

Define VXShader style application relatively to a material. ssHighLevel: shader is applied before material application, and unapplied after material unapplication ssLowLevel: shader is applied after material application, and unapplied before material unapplication ssReplace: shader is applied in place of the material (and material is completely ignored)

TgxShaderTextureSharing

GXSL.TextureShaders

TgxShaderTextureSharingMaterial

GXSL.TextureShaders

TgxShaderTextureSharingMaterials

GXSL.TextureShaders

TgxShaderUnAplyEvent

GXSL.CustomShader

TgxShaderV

GXS.InitOpenGL

———————————————————————–

TgxShaderV

OpenGXS.InitFMX

———————————————————————–

TgxShadowCastingMode

GXS.ShadowVolume

Determines when a caster should actually produce a shadow;
scmAlways : Caster always produces a shadow, ignoring visibility scmVisible : Caster casts shadow if the object has visible=true scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true scmParentVisible : Caster produces shadow if parent has visible=true scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting)

TgxShadowHDS

GXS.ShadowHDS

An Height Data Source that generates terrain shadow maps automatically. The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

TgxShadowPlane

GXS.ShadowPlane

A simple shadow plane. This mirror requires a stencil buffer for optimal rendering! The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered). If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently. You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones

TgxShadowVolume

GXS.ShadowVolume

Simple shadow volumes. Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection. Shadow volumes require that the buffer allows stencil buffers, GLXceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly. Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

TgxShadowVolumeCapping

GXS.ShadowVolume

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option. Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera.
svcDefault : Default behaviour svcAlways : Always generates caps svcNever : Never generates caps

TgxShadowVolumeCaster

GXS.ShadowVolume

Specifies an individual shadow caster. Can be a light or an opaque object.

TgxShadowVolumeCasters

GXS.ShadowVolume

Collection of TgxShadowVolumeCaster.

TgxShadowVolumeLight

GXS.ShadowVolume

Specifies an individual shadow casting light.

TgxShadowVolumeMode

GXS.ShadowVolume

Shadow rendering modes. svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) svmOff : no shadowing will take place

TgxShadowVolumeOccluder

GXS.ShadowVolume

Specifies an individual shadow casting occluder.

TgxShadowVolumeOption

GXS.ShadowVolume

Shadow volume rendering options/optimizations. svoShowVolumes : make the shadow volumes visible svoDesignVisible : the shadow are visible at design-time svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface

TgxShadowVolumeOptions

GXS.ShadowVolume

TgxShininess

GXS.Material

TgxSilhouette

GXS.Silhouette

Base class storing a volume silhouette. Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system. This is the base class, you can use the TgxSilhouette subclass if you need some helper methods for generating the indexed sets.

TgxSilhouetteParameters

GXS.Silhouette

Silouhette generation parameters. SeenFrom and LightDirection are expected in local coordinates.

TgxSilhouetteStyle

GXS.Silhouette

TgxSimpleNavigation

GXS.SimpleNavigation

TgxSimpleNavigationAction

GXS.SimpleNavigation

TgxSimpleNavigationKeyCombination

GXS.SimpleNavigation

TgxSimpleNavigationKeyCombinations

GXS.SimpleNavigation

TgxSimpleNavigationOption

GXS.SimpleNavigation

TgxSimpleNavigationOptions

GXS.SimpleNavigation

Show FPS

TGXSize

GXS.RenderContextInfo

TgxSkeleton

GXS.VectorFileObjects

Main skeleton object. This class stores the bones hierarchy and animation frames. It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

TgxSkeletonBone

GXS.VectorFileObjects

A skeleton bone or node and its children. This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TgxSkeletonFrame, but the calculated bone matrices are stored here.

TgxSkeletonBoneList

GXS.VectorFileObjects

A list of skeleton bones.

TgxSkeletonCollider

GXS.VectorFileObjects

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

TgxSkeletonColliderList

GXS.VectorFileObjects

List class for storing TgxSkeletonCollider objects.

TgxSkeletonFrame

GXS.VectorFileObjects

Stores position and rotation for skeleton joints. If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).

TgxSkeletonFrameList

GXS.VectorFileObjects

A list of TgxSkeletonFrame objects.

TgxSkeletonFrameTransform

GXS.VectorFileObjects

TgxSkeletonMeshObject

GXS.VectorFileObjects

A mesh object with vertice bone attachments. The class adds per vertex bone weights to the standard morphable mesh. The TgxVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method. When BonesPerVertex is 1, the weight is ignored (set to 1.0).

TgxSkeletonRootBoneList

GXS.VectorFileObjects

This list store skeleton root bones exclusively.

TgxSkyBox

GXS.Skydome

TgxSkyBoxStyle

GXS.Skydome

————————- SkyBox class ————————-

TgxSkyDome

GXS.Skydome

Renders a sky dome always centered on the camera. If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system. The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.

TgxSkyDomeBand

GXS.Skydome

——————— SkyDome classes —————————–

TgxSkyDomeBands

GXS.Skydome

TgxSkyDomeOption

GXS.Skydome

TgxSkyDomeOptions

GXS.Skydome

TgxSkyDomeStar

GXS.Skydome

TgxSkyDomeStars

GXS.Skydome

TgxslBaseCustomBumpShader

GXSL.BumpShaders

An abstract class.

TgxslBaseCustomBumpShaderMT

GXSL.BumpShaders

An abstract class.

TgxslBumpShader

GXSL.BumpShaders

TgxslBumpShaderAM

GXSL.BumpShaders

TgxslBumpShaderMT

GXSL.BumpShaders

One light shaders.

TgxslCustomBumpShader

GXSL.BumpShaders

TgxslCustomBumpShaderAM

GXSL.BumpShaders

One Light shaders.

TgxslCustomBumpShaderMT

GXSL.BumpShaders

TgxslCustomMLBumpShader

GXSL.BumpShaders

MultiLight shaders.

TgxslCustomMLBumpShaderMT

GXSL.BumpShaders

TgxslCustomPostBlurShader

GXSL.PostShaders

Custom class for GLSLxPostBlurShader. A shader that blurs the entire scene }

TgxslCustomPostDreamVisionShader

GXSL.PostShaders

A shader that simulate a grayscale threshold vision (aka dream) of the entire scene

TgxslCustomPostFrostShader

GXSL.PostShaders

Custom class for shader that frost of the entire scene

TgxslCustomPostNightVisionShader

GXSL.PostShaders

Custom shader that simulate a Night Vision of the scene throw a mask if enabled, or of the entire scene

TgxslCustomPostPixelateShader

GXSL.PostShaders

Custom shader that pixelate of the entire scene

TgxslCustomPostPosterizeShader

GXSL.PostShaders

Custom shader that posterize of the entire scene

TgxslCustomPostThermalVisionShader

GXSL.PostShaders

A shader that simulate a Thermal Vision of the entire scene

TgxslCustomPostTroubleShader

GXSL.PostShaders

Custom class for GLSLPostTroubleShader. A shader that trouble of the entire scene. v2 This Shader is experimental it can do smooth the scene or double the scene and it's depends of PixelX, PixelY and Freq values if they are less than 1 or greater the effects will be very different

TGXSLCustomShader

GXSL.Shader

TgxSLDataType

GXSL.Parameter

TGXSLDataType

GXSL.ShaderParameter

TgxSLDiffuseSpecularShader

GXSL.DiffuseSpecularShader

TgxSLDiffuseSpecularShaderMT

GXSL.DiffuseSpecularShader

******** Published Stuff ************

TgxSLFurShader

GXSL.ShapeShaders

TgxSLGlassShader

GXSL.ShapeShaders

TgxSLHandle

GXS.Context

Base class for GLSL handles (programs and shaders). Do not use this class directly, use one of its subclasses instead.

TGXSLInTypes

GXSL.ShaderParameter

TgxSLIvoryShader

GXSL.ShapeShaders

TgxSLLatticeShader

GXSL.ShapeShaders

TgxslMLBumpShader

GXSL.BumpShaders

Multi light shaders.

TgxslMLBumpShaderMT

GXSL.BumpShaders

TgxSLMLDiffuseSpecularShader

GXSL.DiffuseSpecularShader

TgxSLMLDiffuseSpecularShaderMT

GXSL.DiffuseSpecularShader

TGXSLOutTypes

GXSL.ShaderParameter

TgxslPostBlurShader

GXSL.PostShaders

TgxSLPostDreamVisionShader

GXSL.PostShaders

TgxslPostFrostShader

GXSL.PostShaders

TgxslPostNightVisionShader

GXSL.PostShaders

TgxslPostPixelateShader

GXSL.PostShaders

TgxslPostPosterizeShader

GXSL.PostShaders

TgxslPostThermalVisionShader

GXSL.PostShaders

TgxslPostTroubleShader

GXSL.PostShaders

TgxslProjectedTextures

GXSL.ProjectedTextures

Projected Texture Manager. Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

TgxslProjectedTexturesStyle

GXSL.ProjectedTextures

TgxSLSamplerType

GXSL.Parameter

TGXSLSamplerType

GXSL.ShaderParameter

TgxSLSemShader

GXSL.ShapeShaders

TGXSLShader

GXSL.Shader

TGXSLShaderEvent

GXSL.Shader

TGXSLShaderEventEx

GXSL.Shader

TGXSLShaderParameter

GXSL.Shader

Wrapper around a parameter of a GLSL program.

TGXSLShaderUnApplyEvent

GXSL.Shader

TgxSLSimpleErosionShader

GXSL.ShapeShaders

TgxSLSimpleGoochShader

GXSL.ShapeShaders

TgxSLSimpleLatticeShader

GXSL.ShapeShaders

TgxslTextureEmitter

GXSL.ProjectedTextures

A projected texture emitter. Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

TgxslTextureEmitterItem

GXSL.ProjectedTextures

Specifies an item on the TgxslTextureEmitters collection.

TgxslTextureEmitters

GXSL.ProjectedTextures

Collection of TgxslTextureEmitter.

TgxSLToonShader

GXSL.ShapeShaders

TgxSLVertexDisplacementShader

GXSL.ShapeShaders

TgxSmartSwarmMode

GXS.SmartObjects

TgxSMBASS

GXS.Sounds.BASS

TGXSMDVectorFile

GXS.FileSMD

The SMD vector file is Half-life's skeleton format. The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames. This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

TgxSmoothNavigator

GXS.SmoothNavigator

This is the component for moving a TgxBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor. It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

TgxSmoothOrbitToPos

GXS.CameraController

TgxSmoothOrbitToPosAdvJob

GXS.CameraController

TgxSmoothUserInterface

GXS.SmoothNavigator

This is the component which reads the userinput and transform it into action. Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. GLNavigator : The Navigator which receives the user movement. GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

TgxSMOpenAL

GXS.Sounds.OpenAL

al, alut, alTypes

TgxSMWaveOut

GXS.Sounds.WaveOut

Basic sound manager based on WinMM WaveOut function. This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality. Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

TgxSoundEnvironment

GXS.SoundManager

EAX standard sound environments

TgxSoundFile

GXS.SoundFileObjects

Abstract base class for different Sound file Formatx. The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TgxSoundFile is very similar to TGraphic (see Delphi Help). Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

TgxSoundFileClass

GXS.SoundFileObjects

TgxSoundFileFormat

GXS.SoundFileObjects

TgxSoundFileFormatsList

GXS.SoundFileObjects

TgxSoundFileProperty

GXS.SceneRegister

TgxSoundLibrary

GXS.SoundManager

TgxSoundLibrarySelectionEditor

GXS.SceneRegister

Selection editor for TgxSoundLibrary. Allows units to be added to the uses clause automatically when sound files are loaded into a TgxSoundLibrary at design-time.

TgxSoundManager

GXS.SoundManager

Base class for sound manager components. The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this). Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

TgxSoundNameProperty

GXS.SceneRegister

TgxSoundSample

GXS.SoundManager

Stores a single PCM coded sound sample.

TgxSoundSamples

GXS.SoundManager

TgxSoundSampling

GXS.SoundFileObjects

Defines a sound sampling quality.

TgxSoundSource

GXS.SoundManager

Origin of sound playback. Just publishes the 'Origin' property. Note: "orientation" is the the source's Direction, ie. the "Z" vector.

TgxSoundSourceChange

GXS.SoundManager

TgxSoundSourceChanges

GXS.SoundManager

TgxSoundSources

GXS.SoundManager

TgxSourcePFXDispersionMode

GXS.ParticleFX

TgxSourcePFXEffect

GXS.ParticleFX

Simple Particles Source.

TgxSourcePFXPositionMode

GXS.ParticleFX

TgxSourcePFXVelocityMode

GXS.ParticleFX

TgxSpaceText

GXS.SpaceText

Renders a text in 3D.

TgxSpaceTextCharRange

GXS.SpaceText

TgxSphere

GXS.Objects

A sphere object. The sphere can have to and bottom caps, as well as being just a slice of sphere.

TgxSprite

GXS.Objects

A rectangular area, perspective projected, but always facing the camera. A TgxSprite is perspective projected and as such is scaled with distance, if you want a 2D sprite that does not get scaled, see TgxHUDSprite.

TgxSpriteAnimation

GXS.AnimatedSprite

Animations define how the texture coordinates for each offset are to be determined.

TgxSpriteAnimationList

GXS.AnimatedSprite

A collection for storing SpriteAnimation objects.

TgxSpriteAnimationMode

GXS.AnimatedSprite

Sets the current animation playback mode: samNone - No playback, the animation does not progress. samPlayOnce - Plays the animation once then switches to samNone. samLoop - Play the animation forward in a continuous loop. samLoopBackward - Same as samLoop but reversed direction. samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached.

TgxSpriteAnimFrame

GXS.AnimatedSprite

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

TgxSpriteAnimFrameList

GXS.AnimatedSprite

TgxSpriteAnimMargins

GXS.AnimatedSprite

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

TgxSpriteFrameDimensions

GXS.AnimatedSprite

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

TgxStarRecord

GXS.Skydome

TgxState

GXS.State

Reflects all relevant (binary) states of OpenGL subsystem

TgxStateCache

GXS.State

Manages an application-side cache of OpenGL states and parameters. Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.

TgxStateRecord

GXS.State

TgxStates

GXS.State

TgxStateType

GXS.State

TgxStateTypes

GXS.State

TgxStaticImposterBuilder

GXS.Imposter

Builds imposters whose texture is a catalog of prerendered views

TgxStaticImposterBuilderCorona

GXS.Imposter

Describes a set of orientation in a corona fashion

TgxStaticImposterBuilderCoronas

GXS.Imposter

TgxStencilFunction

GXS.State

TgxStencilOp

GXS.State

TgxStencilPrecision

GXS.FBO

TgxStencilRBO

GXS.FBO

TgxStiffnessSetVH

GXS.VerletTypes

TgxStiffnessVH

GXS.VerletTypes

TGXSTLVectorFile

GXS.FileSTL

The STL vector file (stereolithography format). It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines. There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version. Original Binary importer code by Paul M. Bearne, Text importer by Adem.

TgxSuperellipsoid

GXS.Objects

A Superellipsoid object. The Superellipsoid can have top and bottom caps, as well as being just a slice of Superellipsoid.

TgxSurfaceModes

GXS.ODEManager

TgxSwartSwarm

GXS.SmartObjects

Synchronize self thinking with an other thinkers in the swarm Copies Ai/Current/End values,ThinkingMode and GridInterpolation. procedure Synchronize(IntelSwarm: TGLIntelSwarm);

TgxSyncMode

GXS.Context

TgxTaskProcedure

GXS.Context

TgxTeapot

GXS.GeomObjects

The classic teapot. The only use of this object is as placeholder for testing...

TgxTerrainBaseHDS

GXS.HeightData

TerrainBase-based Height Data Source. This component takes its data from the TerrainBase Gobal Terrain Model. Though it can be used directly, the resolution of the TerrainBase dataset isn't high enough for accurate short-range representation and the data should rather be used as basis for further (fractal) refinement. TerrainBase is freely available from the National Geophysical Data Center and World Data Center web site (http://ngdc.noaa.com). (this component expects to find "tbase.bin" in the current directory).

TgxTerrainHighResStyle

GXS.TerrainRenderer

TgxTerrainOcclusionTesselate

GXS.TerrainRenderer

TgxTerrainRenderer

GXS.TerrainRenderer

Basic terrain renderer. This renderer uses no sophisticated meshing, it just builds and maintains a set of terrain tiles, performs basic visibility culling and renders its stuff. You can use it has a base class/sample for more specialized terrain renderers. The Terrain heightdata is retrieved directly from a TgxHeightDataSource, and expressed as z=f(x, y) data.

TgxTessControlShaderHandle

GXS.Context

Manages a handle to a Tessellation Control Shader Object.

TgxTessEvaluationShaderHandle

GXS.Context

Manages a handle to a Tessellation Evaluation Shader Object.

TgxTetrahedron

GXS.GeomObjects

The tetrahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TgxTexCombineShader

GXSL.TextureShaders

A shader that can setup the texture combiner.

TgxTextAdjust

GXS.SpaceText

TgxTextHorzAdjust

GXS.SpaceText

Note: haAligned, haCentrically, haFitIn have not been implemented!

TgxTextLayout

GXS.ImageUtils

in vcl class of TGraphic

TgxTexture

GXS.Texture

Defines basic texturing properties. You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default). A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TgxTextureImageAlpha).

TgxTextureArray

GXS.FBORenderer

TgxTextureBufferHandle

GXS.Context

Manages a handle to a Buffer Texture. (TBO)

TgxTextureChange

GXS.Texture

TgxTextureChanges

GXS.Texture

TgxTextureCompression

GXS.Texture

TgxTexturedHDS

GXS.TexturedHDS

TgxTextureEmitter

GXS.ProjectedTextures

A projected texture emmiter. It's material property will be used as the projected texture. Can be places anywhere in the scene.

TgxTextureEmitterItem

GXS.ProjectedTextures

Specifies an item on the TgxTextureEmitters collection.

TgxTextureEmitters

GXS.ProjectedTextures

Collection of TgxTextureEmitter.

TgxTextureEx

GXS.Texture

TgxTextureExItem

GXS.Texture

TgxTextureFormat

GXS.Texture

Texture format for OpenGL (rendering) use. Internally, GLXScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:

TgxTextureHandle

GXS.Context

Manages a handle to a texture.

TgxTextureImage

GXS.Texture

Base class for texture image data. Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source). SubClasses should be registered using RegisterTextureImageClass to allow proper persistence and editability in the IDE experts.

TgxTextureImageAlpha

GXS.Texture

Defines how and if Alpha channel is defined for a texture image. tiaDefault : uses the alpha channel in the image if any tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) tiaOpaque : alpha channel is uniformously set to 1.0 tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque.

TgxTextureImageClass

GXS.Texture

TgxTextureImageEditor

GXS.TextureImageEditors

TgxTextureImageEditorClass

GXS.TextureImageEditors

TgxTextureImageProperty

GXS.SceneRegister

TgxTextureLensFlare

GXS.TexLensFlare

TgxTextureMappingMode

GXS.Texture

TgxTextureMode

GXS.Texture

TgxTextureNeededEvent

GXS.Texture

TgxTextureProperty

GXS.SceneRegister

TgxTextureWrap

GXS.Texture

TgxTextVertAdjust

GXS.SpaceText

TgxTGAImage

Formatx.TGA

TgxThorFXManager

GXS.ThorFX

Thor special effect manager.

TgxTiledArea

GXS.TilePlane

Stores tile information in a tiled area. Each tile stores an integer value with zero the default value, assumed as "empty".

TgxTiledAreaRow

GXS.TilePlane

Stores row information for a tiled area.

TgxTiledRndLandscape

GXS.RandomHDS

Random Lansdscape with tiles

TgxTileManagementFlag

GXS.TerrainRenderer

TgxTileManagementFlags

GXS.TerrainRenderer

TgxTilePlane

GXS.TilePlane

A tiled textured plane. This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering. Its bounding dimensions are determined by its painted tile.

TgxTimeEvent

GXS.TimeEventsMgr

TgxTimeEventProc

GXS.TimeEventsMgr

TgxTimeEvents

GXS.TimeEventsMgr

TgxTimeEventsMGR

GXS.TimeEventsMgr

TgxTimeEventType

GXS.TimeEventsMgr

TgxTimerQueryHandle

GXS.Context

Manages a handle to a timer query. Requires GL_EXT_timer_query extension. Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TgxTINVectorFile

GXS.FileTIN

The TIN vector file (triangle irregular network). It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files). This format is encountered in the DEM/DTED world and used in place of grids.

TgxTorus

GXS.GeomObjects

A Torus object

TgxTorusPart

GXS.GeomObjects

TgxTorusParts

GXS.GeomObjects

TgxTouchEvent

GXS.SceneViewer

TgxTrail

GXS.Trail

TgxTransformFeedbackBufferHandle

GXS.Context

Manages a handle to a Transform Feedback Buffer Object. Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

TgxTransformFeedBackMode

GXSL.CustomShader

TgxTree

GXS.Tree

TgxTreeBranch

GXS.Tree

TgxTreeBranches

GXS.Tree

TgxTreeBranchNoise

GXS.Tree

TgxTreeLeaves

GXS.Tree

TgxUniformBufferHandle

GXS.Context

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.

TgxUnpackPBOHandle

GXS.Context

Manages a handle to PBO Pixel Unpack Buffer. When bound, commands such as DrawPixels read their data from a buffer object

TgxUserInputCommand

GXS.Console

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

TgxUserInterface

GXS.Navigator

TgxUserInterface is the component which reads the userinput and transform it into action. The four calls to get you started is MouseLookActivate : set us up the bomb. MouseLookDeActivate : defuses it. Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. The four properties to get you started are: InvertMouse : Inverts the mouse Y axis. MouseSpeed : Also known as mouse sensitivity. GXNavigator : The Navigator which receives the user movement. GXVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras....

TgxUserShader

GXSL.UserShader

TgxVBOArrayBufferHandle

GXS.Context

Manages a handle to VBO Array Buffer. Typically used to store vertices, normals, texcoords, etc.

TgxVBOElementArrayHandle

GXS.Context

Manages a handle to VBO Element Array Buffer. Typically used to store vertex indices.

TgxVBOHandle

GXS.Context

Manages a handle to an Vertex Buffer Object. Does *NOT* check for extension availability, this is assumed to have been checked by the user. Do not use this class directly, use one of its subclasses instead.

TgxVectorFile

GXS.VectorFileObjects

Abstract base class for different vector file Formatx. The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TgxVectorFile is very similar to TGraphic (see Delphi Help).

TgxVectorFileClass

GXS.VectorFileObjects

TgxVectorFileFormat

GXS.VectorFileObjects

TgxVectorFileFormatsList

GXS.VectorFileObjects

Stores registered vector file Formatx.

TgxVectorFileGLSM

GXS.VectorFileObjects

GLSM ( GXScene Mesh) vector file. This corresponds to the 'native' Scene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GXScene features.

TgxVerletAirResistance

GXS.VerletTypes

TgxVerletCapsule

GXS.VerletTypes

Capsule shaped verlet constraint in a skeleton collider

TgxVerletConstraint

GXS.VerletTypes

TgxVerletConstraintList

GXS.VerletTypes

TgxVerletDualConstraint

GXS.VerletTypes

TgxVerletDualForce

GXS.VerletTypes

A verlet force that applies to two specified nodes.

TgxVerletEdge

GXS.VerletTypes

Verlet edges simulate rigid collission edges

TgxVerletEdgeList

GXS.VerletTypes

TgxVerletFloor

GXS.VerletTypes

Floor Collision Constraint

TgxVerletForce

GXS.VerletTypes

Generic verlet force.

TgxVerletForceList

GXS.VerletTypes

TgxVerletFrictionCapsule

GXS.VerletTypes

Capsule collision Friction Constraint.

TgxVerletFrictionCube

GXS.VerletTypes

Cube Сollision Friction Constraint.

TgxVerletFrictionCylinder

GXS.VerletTypes

Cylinder collision Friction Constraint. The cylinder is considered infinite by this constraint.

TgxVerletFrictionSphere

GXS.VerletTypes

Sphere Сollision Friction Constraint

TgxVerletGlobalConstraint

GXS.VerletTypes

TgxVerletGlobalForce

GXS.VerletTypes

A global force (applied to all verlet nodes).

TgxVerletGlobalFrictionConstraint

GXS.VerletTypes

TgxVerletGlobalFrictionConstraintBox

GXS.VerletTypes

TgxVerletGlobalFrictionConstraintSP

GXS.VerletTypes

TgxVerletGlobalFrictionConstraintSphere

GXS.VerletTypes

TgxVerletGravity

GXS.VerletTypes

TgxVerletGroupConstraint

GXS.VerletTypes

TgxVerletGroupForce

GXS.VerletTypes

A verlet force that applies to a specified group of nodes.

TgxVerletHair

GXS.VerletTypes

Verlet Hair class

TgxVerletHeightField

GXS.VerletTypes

HeightField collision constraint (punctual!)

TgxVerletHeightFieldOnNeedHeight

GXS.VerletTypes

TgxVerletNode

GXS.VerletTypes

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

TgxVerletNodeClass

GXS.VerletTypes

TgxVerletNodeList

GXS.VerletTypes

TgxVerletRigidBody

GXS.VerletTypes

Rigid body verlet Collision constraint. Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. EXPERIMENTAL, STILL DOES NOT WORK!

TgxVerletSkeletonCollider

GXS.VerletTypes

Base Verlet Skeleton Collider class.

TgxVerletSlider

GXS.VerletTypes

Slider constraint. Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

TgxVerletSphere

GXS.VerletTypes

Sphere shaped verlet constraint in a skeleton collider

TgxVerletSpring

GXS.VerletTypes

TgxVerletStick

GXS.VerletTypes

Stick Verlet Collision Constraint. Imposes a fixed distance between two nodes

TgxVerletWorld

GXS.VerletTypes

TgxVertexArrayHandle

GXS.Context

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.

TgxVertexBoneWeight

GXS.VectorFileObjects

TgxVertexBoneWeightArray

GXS.VectorFileObjects

TgxVertexBoneWeightDynArray

GXS.VectorFileObjects

TgxVertexData

GXS.Mesh

TgxVertexDataArray

GXS.Mesh

TgxVertexList

GXS.Mesh

Stores an interlaced vertex list for direct use in OpenGL. Locking (hardware passthrough) is supported, see "Locked" property for details.

TgxVertexProgram

GXSL.CustomShader

TgxVertexProgramHandle

GXS.Context

TgxVertexShaderHandle

GXS.Context

Manages a handle to a Vertex Shader Object.

TgxVerticesBoneWeights

GXS.VectorFileObjects

TgxVideoMode

GXS.Screen

TgxVirtualHandle

GXS.Context

A context handle with event-based handle allocation and destruction.

TgxVirtualHandleEvent

GXS.Context

TgxVirtualHandleTransf

GXS.Context

Transferable virtual handle.

TgxVisibilityCulling

GXS.RenderContextInfo

Determines the visibility culling mode. Culling is done level by level, allowed values are: vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone vcNone : no visibility culling is performed vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

TgxVisibilityDeterminationEvent

GXS.Objects

TgxVRMLVectorFile

GXS.FileVRML

TgxWaterPlane

GXS.WaterPlane

TgxWaterPlaneOption

GXS.WaterPlane

GL_EXT_compiled_vertex_array

TgxWaterPlaneOptions

GXS.WaterPlane

TgxWAVFile

GXS.FileWAV

Support for Windows WAV format.

TgxWinContext

GXS.WinContext

A context driver for standard Windows OpenGL

TgxWindowAttribute

GXS.Screen

window attributes

TgxWindowAttributes

GXS.Screen

TgxWindowFitting

GXS.Screen

window-to-screen fitting

TgxWindowsBitmapFont

GXS.WindowsFont

A bitmap font automatically built from a TFont. It works like a TgxBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders as close to that font as possible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations. Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

TgxXVectorFile

GXS.FileX

TgxXYZGrid

GXS.Graph

An XYZ Grid object. Renders an XYZ grid using lines.

TgxZBuffer

GXS.zBuffer

TgxZoomToDistanceJob

GXS.CameraController

TgxZShadows

GXS.zBuffer

THalfFloat

GLScene.Utils

THDRImage

Formatx.HDRImage

THDTextureCoordinatesMode

GXS.HeightData

THelpOpenControl3D

GBE.Viewport3D

THmgBoundingBox

GLScene.GeometryBB

THmgPlane

GLScene.VectorGeometry

A plane equation. Defined by its equation A.x+B.y+C.z+D , a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here. The typename is just here for easing up data manipulation

THomogeneousByteMatrix

GLScene.VectorGeometry

Matrices

THomogeneousByteVector

GLScene.VectorGeometry

THomogeneousDblMatrix

GLScene.VectorGeometry

THomogeneousDblVector

GLScene.VectorGeometry

THomogeneousExtMatrix

GLScene.VectorGeometry

THomogeneousExtVector

GLScene.VectorGeometry

THomogeneousFltMatrix

GLScene.VectorGeometry

THomogeneousFltVector

GLScene.VectorGeometry

THomogeneousIntMatrix

GLScene.VectorGeometry

THomogeneousIntVector

GLScene.VectorGeometry

THomogeneousMatrix

GLScene.VectorGeometry

THomogeneousPtrVector

GLScene.VectorGeometry

THomogeneousVector

GLScene.VectorGeometry

THomogeneousWordMatrix

GLScene.VectorGeometry

THomogeneousWordVector

GLScene.VectorGeometry

THTFHeader

GXS.HeightTileFile

TIDELogProc

GLScene.Logger

TIdleEvent

GXS.AsyncHDS

TileImage

uGBEImageUtils

TImageAlphaProc

GXS.ImageUtils

TImageFilterFunction

GXS.ImageUtils

TImposter

GXS.Imposter

Base class for imposters manipulation and handling. Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.
Note: Remeber to enable Destination Alpha on your viewer.

TImposterLoadedEvent

GXS.Imposter

Used CPPB procedure instead of Delphi function TLoadingImposterEvent = procedure (Sender : TObject; impostoredObject : TgxBaseSceneObject; destImposter : TImposter; var result : TgxBitmap32) of object;

TImposterOption

GXS.Imposter

Imposter rendering options. Following options are supported: impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing

TImposterOptions

GXS.Imposter

TImposterReference

GXS.Imposter

TInfoForm

FMxInfo

TInfoLabelCoordType

GXS.GizmoEx

TInstProp

FMxXCollectionEditor

TInstPropList

FMxXCollectionEditor

TIntegerArray

GLScene.VectorTypesExt

Extended may be replaced with BigDecimals

TIntegerArray

GXS.HeightTileFile

TIntegerClamp

GXS.RandomHDS

TIntegerVector

GLScene.VectorGeometry

TIntermediateFormat

GXS.ImageUtils

Relative sample radius for filtering

TIntermediateFormatArray

GXS.ImageUtils

TInvokeInfoForm

GXS.Scene

TIsDefaultTile

GXS.RandomHDS

TIsoSurfaceExtractor

GXS.Isosurface

3D isosurface extractor class. This class allows to calculate and exctract isosurfaces from scalar field voxel models using a given isovalue

TJointOption

GXS.ODEManager

TJointOptions

GXS.ODEManager

TJoyAxis

GXS.Joystick

TJoyPos

GXS.Joystick

TJoystickButton

GXS.Joystick

TJoystickButtons

GXS.Joystick

TJoystickDesignMode

GXS.Joystick

TJoystickEvent

GXS.Joystick

TJoystickID

GXS.Joystick

TKeyboardType

uGBEOptionsUtils

TLandTile

GXS.RandomHDS

TMapOfLandscapes :array of array of TgxBaseRandomHDS;

TLandTileInfo

GXS.RandomHDS

TLeavedSpacePartition

GXS.SpacePartition

Implements a list of all leaves added to the space partition, _not_ a good solution, but it can be used as a benchmark against more complex methods

TLibArchive

GXS.ArchiveManager

To work with several archives simultaniously collections implemented Item to work with one archive

TLibArchives

GXS.ArchiveManager

TLibMaterialPicker

FMXLibMaterialPicker

TLifeErosion

GXS.RandomHDS

TLightmapBounds

GXS.MeshLines

TLightRecord

GXSL.DiffuseSpecularShader

******* Multi Light *********

TLineCollection

GXS.MeshLines

TLineItem

GXS.MeshLines

TLineNode

GXS.MeshLines

Specialized Node for use in a TgxLines objects. Adds a Width property

TLineNodes

GXS.MeshLines

Specialized collection for Nodes in TgxMeshLines objects. Stores TLineNode items.

TLineNodesAspect

GXS.Objects

Possible aspects for the nodes of a TLine.

TLinesOption

GXS.Objects

TLMTS

GXS.FileLMTS

TLMTS_Header

GXS.FileLMTS

TLMTS_Subset

GXS.FileLMTS

TLMTS_TexData

GXS.FileLMTS

TLMTS_Vertex

GXS.FileLMTS

TLoadingImposterEvent

GXS.Imposter

Imposter loading events

TLogBufferFlushThread

GLScene.Logger

Thread that periodically flushes the buffer to disk.

TLogBufferingMode

GLScene.Logger

How log is buffered.

TLogCheckSizeThread

GLScene.Logger

Thread that checks file size and splits the file if nessesary.

TLogLevel

GLScene.Logger

Levels of importance of log messages

TLogLevels

GLScene.Logger

Log level setting type

TLogMessageLimitAction

GLScene.Logger

What to do when number of messages exceeds message limit.

TLogSession

GLScene.Logger

Abstract Logger class

TLogTimeFormat

GLScene.Logger

Log date and time setting type

TLongWordVector

GLScene.VectorGeometry

TMapOfSingle

GXS.RandomHDS

TMapOfVector

GXS.RandomHDS

TMapTexCoordMode

GXS.XOpenGL

TMarkDirtyEvent

GXS.HeightData

TMarkStyle

GXS.Trail

TMaterialEditorForm

FMxMaterialEditor

TMaterialInfo

GXS.FileLMTS

TMaterialPreviewFrame

FRxMaterialPreview

GXS.SceneViewer,

TMatrix2b

GLScene.VectorTypes

TMatrix2d

GLScene.VectorTypes

=========== Matrices ============

TMatrix2DArray

GLScene.VectorTypesExt

Matrix Arrays

TMatrix2DRec

GLScene.VectorTypesExt

TMatrix2DType

GLScene.VectorTypesExt

———————– Matrix types ———————–

TMatrix2e

GLScene.VectorTypes

TMatrix2f

GLScene.VectorTypes

TMatrix2i

GLScene.VectorTypes

TMatrix2p

GLScene.VectorTypes

TMatrix2s

GLScene.VectorTypes

TMatrix2w

GLScene.VectorTypes

TMatrix3b

GLScene.VectorTypes

TMatrix3d

GLScene.VectorTypes

TMatrix3DArray

GLScene.VectorTypesExt

TMatrix3DRec

GLScene.VectorTypesExt

TMatrix3DType

GLScene.VectorTypesExt

TMatrix3e

GLScene.VectorTypes

TMatrix3f

GLScene.VectorTypes

TMatrix3i

GLScene.VectorTypes

TMatrix3p

GLScene.VectorTypes

TMatrix3s

GLScene.VectorTypes

TMatrix3w

GLScene.VectorTypes

TMatrix4b

GLScene.VectorTypes

TMatrix4d

GLScene.VectorTypes

TMatrix4e

GLScene.VectorTypes

TMatrix4f

GLScene.VectorTypes

TMatrix4i

GLScene.VectorTypes

TMatrix4p

GLScene.VectorTypes

TMatrix4s

GLScene.VectorTypes

TMatrix4w

GLScene.VectorTypes

TMatrixArr

GXS.Isolines

TMatrixArray

GLScene.VectorGeometry

Some simplified names

TMatrixExt

GLScene.VectorTypesExt

TMatrixRec

GLScene.VectorTypesExt

TMaxCLODTrianglesReachedEvent

GXS.TerrainRenderer

TMD3TagList

Formatx.Q3MD3

This class is used to extract the tag transform information stored in the MD3 files. The data is used to offset each part of the model based on the parent parts animation state.

TMDCAngle

GXS.FileMDC

TMDCBaseFrame

GXS.FileMDC

TMDCBaseVertex

GXS.FileMDC

TMDCBorderFrame

GXS.FileMDC

TMDCCompFrame

GXS.FileMDC

TMDCCompVertex

GXS.FileMDC

TMDCFileHeader

GXS.FileMDC

TMDCPoint

GXS.FileMDC

3/64;

TMDCSkin

GXS.FileMDC

TMDCSurfaceHeader

GXS.FileMDC

TMDCTag

GXS.FileMDC

TMDCTagFrame

GXS.FileMDC

TMDCTagName

GXS.FileMDC

TMDCTexCoord

GXS.FileMDC

TMDCTriangle

GXS.FileMDC

TMesh2DArray

GLScene.VectorTypesExt

TMesh2DVert

GLScene.VectorTypesExt

————————– Mesh simple record types ————————–

TMesh3DArray

GLScene.VectorTypesExt

TMesh3DVert

GLScene.VectorTypesExt

TMeshMode

GXS.Mesh

wglAllocateMemoryNV

TMeshOptimizerOption

GXS.MeshOptimizer

TMeshOptimizerOptions

GXS.MeshOptimizer

TMirrorOption

GXS.Mirror

TMirrorOptions

GXS.Mirror

TMirrorShapes

GXS.Mirror

TMOParametricSurface

GXS.ParametricSurfaces

TMS3DComment

GXS.FileMS3D

TMS3DCommentList

GXS.FileMS3D

TMS3DGroup

GXS.FileMS3D

typedef struct { byte flags; // SELECTED | HIDDEN char name[32]; // word numtriangles; // word triangleIndices[numtriangles]; // the groups group the triangles char materialIndex; // -1 = no material } ms3d_group_t;

TMS3DHeader

GXS.FileMS3D

typdef struct { char id[10]; // always "MS3D000000" int version; // 4 } ms3d_header_t;

TMS3DJoint

GXS.FileMS3D

TMS3DJointArray

GXS.FileMS3D

TMS3DJointBase

GXS.FileMS3D

typedef struct { byte flags; // SELECTED | DIRTY char name[32]; // char parentName[32]; // float rotation[3]; // local reference matrix float position[3];
word numKeyFramesRot; // word numKeyFramesTrans; //
ms3d_keyframe_rot_t keyFramesRot[numKeyFramesRot]; // local animation matrices ms3d_keyframe_pos_t keyFramesTrans[numKeyFramesTrans]; // local animation matrices } ms3d_joint_t;

TMS3DKeyframePosition

GXS.FileMS3D

typedef struct { float time; // time in seconds float position[3]; // local position } ms3d_keyframe_pos_t;

TMS3DKeyframePositionArray

GXS.FileMS3D

TMS3DKeyframeRotation

GXS.FileMS3D

typedef struct { float time; // time in seconds float rotation[3]; // x, y, z angles } ms3d_keyframe_rot_t;

TMS3DKeyframeRotationArray

GXS.FileMS3D

TMS3DMaterial

GXS.FileMS3D

typedef struct { char name[32]; // float ambient[4]; // float diffuse[4]; // float specular[4]; // float emissive[4]; // float shininess; // 0.0f - 128.0f float transparency; // 0.0f - 1.0f char mode; // 0, 1, 2 is unused now char texture[128]; // texture.bmp char alphamap[128]; // alpha.bmp } ms3d_material_t;

TMS3DTriangle

GXS.FileMS3D

typedef struct { word flags; // SELECTED | SELECTED2 | HIDDEN word vertexIndices[3]; // float vertexNormals[3][3]; // float s[3]; // float t[3]; // byte smoothingGroup; // 1 - 32 byte groupIndex; // } ms3d_triangle_t;

TMS3DTriangleArray

GXS.FileMS3D

TMS3DVertex

GXS.FileMS3D

typedef struct { byte flags; // SELECTED | SELECTED2 | HIDDEN float vertex[3]; // char boneId; // -1 = no bone byte referenceCount; } ms3d_vertex_t;

TMS3DVertexArray

GXS.FileMS3D

TMS3D_vertex_ex_t

GXS.FileMS3D

TNewTilePreparedEvent

GXS.AsyncHDS

TNewTilePreparedEvent

GXS.BumpmapHDS

TNewTilePreparedEvent

GXS.ShadowHDS

TNewtonRagdoll

GXS.NGDRagdoll

TNmHeader

GXS.FileNMF

TNmRawTriangle

GXS.FileNMF

TNormalMapSpace

GXS.BumpMapping

TObjectCollisionEvent

GXS.Collision

TOceanSurface

GBE.omOceanWaves

TOctreeSpacePartition

GXS.SpacePartition

Implements octrees

TomSailSurface

omSailSurface

TomSailSurface morphs a TPlane grid into a triangular sail with camber ( or any other polygonal Shape)

TOnBeforeKernelLaunch

GXS.CUDA.Graphics

TOnCreateLandTile

GXS.RandomHDS

TOnCustomForce

GXS.PhysForces

TOnDoApplyEvent

GXSL.UserShader

TOnDoUnApplyEvent

GXSL.UserShader

TOnDrawTexture

GXS.RandomHDS

Function type to use for topography-based texture

TOnHeightDataDirtyEvent

GXS.HeightData

TOnOpenGLInteropInit

GXS.CUDA.Context

TOnPrepareHandleData

GXS.Context

TOptimise

GXS.zBuffer

TPackedRotationMatrix

GLScene.VectorGeometry

TPAKArchive

GXS.PAKArchive

TPakHeader

GXS.PAKArchive

TParametricSurfaceBasis

GXS.ParametricSurfaces

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

TParametricSurfaceRenderer

GXS.ParametricSurfaces

psrGLXcene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenVX uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

TParticleReference

GXS.ParticleFX

PFX region rendering structures

TParticleReferenceArray

GXS.ParticleFX

TPatchPostRenderEvent

GXS.TerrainRenderer

TPathTravelStartEvent

GXS.Movement

Event for path related event

TPathTravelStopEvent

GXS.Movement

TPFXCreateParticleEvent

GXS.ParticleFX

TPFXDirectRenderEvent

GXS.ParticleFX

TPFXGetParticleCountEvent

GXS.ParticleFX

TPFXLifeColor

GXS.ParticleFX

TPFXLifeColors

GXS.ParticleFX

TPFXParticleProgress

GXS.ParticleFX

TPFXPrepareTextureImageEvent

GXS.ParticleFX

TPFXProgressEvent

GXS.ParticleFX

TPFXRegion

GXS.ParticleFX

TPFXSortAccuracy

GXS.ParticleFX

TPickRecord

GXS.Selection

TPickSortType

GXS.Selection

TPickSubObjects

GXS.Selection

TPictureFileProperty

GXS.SceneRegister

TPipeNodesColorMode

GXS.Extrusion

TPipeNormalMode

GXS.Extrusion

TPipePart

GXS.Extrusion

TPipeParts

GXS.Extrusion

TPipeTexCoordMode

GXS.Extrusion

TPlanBB

GLScene.GeometryBB

TPlanIndices

GLScene.GeometryBB

TPoint2DArray

GLScene.VectorTypesExt

TPoint2DRec

GLScene.VectorTypesExt

TPoint3DArray

GLScene.VectorTypesExt

TPoint3DRec

GLScene.VectorTypesExt

TPointerArray

GXS.ImageUtils

TPointerVector

GLScene.VectorGeometry

TPointF_Array

omSailSurface

————————————————————————– Sail construction params
ˆ h ˆ h ˆ h | Main | Simetric | Jib Ht +—-+ Ht +—+ Lt Ht +—+ | Lt \ / | \ |Lt \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ | \ / | \ | \ +———–+ +—————–+ +———-+ | Lm \ / | Lm \ | Lm \ | | | | | | \ | \ | | | | Lx \ | | \ | / Hx +————–+ <– h of max chord | \ | | | | ____/ 0 | Lb | | 0 | Lb | 0 | ____/ —-+————–+–> L -+——–+——–+–> L —-+___/————-> L Lb nh subdivisions in height nl subdivisions in chord —————————————————————————

TPolygon2D

GLScene.VectorTypesExt

———————– Polygon types ———————–

TPolygon3D

GLScene.VectorTypesExt

TPolyhedronArray

GLScene.VectorTypesExt

———————– Polyhedron types ———————–

TPrecisionSetting

GXS.CgShader

TProcAffineAffineAffine

GXS.Octree

TProcInt

GXS.Octree

TProjectTargetNameFunc

GLScene.Utils

TPropertyAttribute

GXS.RegisterXCollection

DesignIntf, DesignEditors,

TPropertyAttributes

GXS.RegisterXCollection

TQuadtreeSpacePartition

GXS.SpacePartition

Implements quadtrees. Quadtrees are hardcoded to completely ignore the Y axis, only using X and Z to determine positioning. This means that they're well suited for 2d-ish situations (landscapes with trees for instance) but not for fully 3d situations (space fighting).

TQuat3DRec

GLScene.VectorTypesExt

————————– Quaternion simple record types ————————–

TQuatArray

GLScene.VectorTypesExt

TQuaternion

GLScene.VectorGeometry

TQuaternionArray

GLScene.VectorGeometry

TQuaternionHelper

GLScene.VectorTypesExt

TQuaternionRec

GLScene.VectorTypesExt

TRainErosion

GXS.RandomHDS

TRandomGenFunction

GLScene.RandomLib

Used for passing Random Number Generators

TranslateMatrix

GLScene.VectorGeometry

TranslateMatrix

GLScene.VectorGeometry

Adds the translation vector into the matrix

TransposeMatrix

GLScene.VectorGeometry

Computes transpose of 3x3 matrix

TransposeMatrix

GLScene.VectorGeometry

Computes transpose of 4x4 matrix

TRasterFileFormat

GXS.Graphics

TRasterFileFormatsList

GXS.Graphics

Stores registered raster file Formatx.

TRBColor

GLScene.RedBlackTree

TRCOptions

GLScene.OpenGL4

TRectangle

GLScene.VectorGeometry

TRelativeCoordinate

GXS.RandomHDS

TResolution

GXS.Screen

TRGBPixel

GXS.Blur

TRGBPixelBuffer

GXS.Blur

TriangleArea

GLScene.VectorGeometry

Computes the triangle's area

TriangleElevationSegments

GXS.Isolines

Defines contouring segments inside a triangle using elevations

TriangleIntersectAABB

GLScene.GeometryBB

Original source code by Tomas Akenine-Mцller Based on the paper "Fast 3D Triangle-Box Overlap Testing" http://www.cs.lth.se/home/Tomas_Akenine_Moller/pubs/tribox.pdf http://jgt.akpeters.com/papers/AkenineMoller01/ (code) Use separating axis theorem to test overlap between triangle and box need to test for overlap in these directions: 1) the (x,y,z)-directions (actually, since we use the AABB of the triangle we do not even need to test these) 2) normal of the triangle 3) crossproduct(edge from tri, {x,y,z}-directin) this gives 3x3=9 more tests Checks if a triangle (given by vertices v1, v2 and v3) intersects an AABB

TriangleSignedArea

GLScene.VectorGeometry

Computes a 2D triangle's signed area. Only X and Y coordinates are used, Z is ignored

TrimAndSplitVersionString

GLScene.OpenGL4

TrimAndSplitVersionString

GXS.OpenGLAdapter

TryStringToColorAdvanced

GXS.ImageUtils

Converts a string into color

TSailParams

omSailSurface

TSailShape

omSailSurface

TScalarField

GLScene.VectorTypesExt

TScalarFieldInt

GLScene.VectorTypesExt

if data are made on integer XYZ index may be replaced with BigIntegers

TScalarValue

GLScene.VectorTypesExt

———————– Point types ———————–

TSceneEditorForm

FMxSceneEditor

TSCODEBase

GXS.ODESkeletonColliders

Base ODE skeleton collider class.

TSCODEBox

GXS.ODESkeletonColliders

Box shaped ODE geom in a skeleton collider.

TSCODECCylinder

GXS.ODESkeletonColliders

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.

TSCODESphere

GXS.ODESkeletonColliders

Sphere shaped ODE geom in a skeleton collider.

TScreenSaverOption

GXS.ScreenSaver

Options of screen-saver.
ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). - ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) - ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) - ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer)

TScreenSaverOptions

GXS.ScreenSaver

TScreenSaverPreviewEvent

GXS.ScreenSaver

This event is fired when screen saver should start in preview mode. The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

TSeaErosion

GXS.RandomHDS

Fmx.Imaging.jpeg,

TSectoredSpacePartition

GXS.SpacePartition

TSectorNode

GXS.SpacePartition

Implements a SectorNode node. Each node can have 0 or 8 children, each child being a portion of the size of the parent. For quadtrees, that's 1/4, for octrees, it's 1/8

TSectorNodeArray

GXS.SpacePartition

TSerializeEvent

GXS.NGDManager

TSetTextureTargetsEvent

GXS.FBORenderer

TSetTransformEvent

GXS.NGDManager

TShaderFileProperty

GXS.SceneRegister

TShaderMemoForm

FMxShaderMemo

TShaderUniformEditorForm

FMxShaderUniformEditor

TShadowPlaneOption

GXS.ShadowPlane

TShadowPlaneOptions

GXS.ShadowPlane

TShortIntArray

GXS.HeightTileFile

TSIBLigthing

GXS.Imposter

TSimpleNavigationCustomActionEvent

GXS.SimpleNavigation

TSingleArray

GLScene.VectorGeometry

TSingleClamp

GXS.RandomHDS

TSingleRaster

GXS.HeightData

TSkinEditorForm

FMxSkinEditor

TSmallintArray

GXS.HeightData

TSmallIntArray

GXS.HeightTileFile

TSmallIntRaster

GXS.HeightData

TSourceDataFetchedEvent

GXS.HeightData

TSpaceContains

GLScene.GeometryBB

Result type for space intersection tests, like AABBContainsAABB or BSphereContainsAABB

TSpacePartitionLeaf

GXS.SpacePartition

Used to store the actual objects in the SpacePartition

TSpacePartitionLeafList

GXS.SpacePartition

List for storing space partition leaves

TSPCone

GXS.SpacePartition

Describes a cone, and is used for cone collision

TSpecularMode

GXSL.BumpShaders

TSpheroid

GBE.SphereExtend

TSPOctreeNode

GXS.SpacePartition

Implements sector node that handles octrees

TSPQuadtreeNode

GXS.SpacePartition

Implements sector node that handles quadtrees.

TSpriteColorMode

GXS.ParticleFX

Sprite color modes. scmFade: vertex coloring is used to fade inner-outer scmInner: vertex coloring uses inner color only scmOuter: vertex coloring uses outer color only scmNone: vertex coloring is NOT used (colors are ignored).

TSpritesPerTexture

GXS.ParticleFX

Sprites per sprite texture for the SpritePFX.

TSqrt255Array

GLScene.Utils

TStartPreparingDataEvent

GXS.HeightData

TStateArray

GXS.PhysManager

TDESolver = procedure((*RigidBody:TgxRigidBody;*)DeltaTime:Real) of object;

TStaticImposter

GXS.Imposter

Imposter class whose texture contains several views from different angles

TSteps

GXS.RandomHDS

TSTLFace

GXS.FileSTL

Original specs : = packed record x : single; y : single; z : single; end;

TSTLHeader

GXS.FileSTL

TSTLVertex

GXS.FileSTL

TSubdivideEdgeEvent

GXS.MeshUtils

TTexPoint

GLScene.VectorGeometry

TTexPointArray

GLScene.VectorGeometry

TTextureEditFrame

FRxTextureEdit

TTGAImage

GXS.FileTGA

TGA image load/save capable class for Delphi. TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

TTgxFile3DSPositionAnimationKeys

GXS.File3DS

TThorpoint

GXS.ThorFX

TThorpointArray

GXS.ThorFX

TThreadBmp32

GXS.ShadowHDS

TTransformations

GLScene.VectorGeometry

Used to describe a sequence of transformations in following order: [Sx][Sy][Sz][ShearXY][ShearXZ][ShearZY][Rx][Ry][Rz][Tx][Ty][Tz][P(x,y,z,w)] constants are declared for easier access (see MatrixDecompose below)

TTransType

GLScene.VectorGeometry

TTriangleRec

GLScene.VectorTypesExt

TTriangleRecArray

GLScene.VectorTypesExt

TTwoWavesOceanSurface

GBE.omOceanWaves

TU48BitBlock

GXS.ImageUtils

TUBOStates

GXS.State

TUniformAutoSetMethod

GXSL.Parameter

TUniformAutoSetMethod

GXSL.ShaderParameter

TUniformAutoSetProperty

GXS.SceneRegister

TUpdateSpacePartion

GXS.VerletTypes

Turn

GLScene.VectorGeometry

Coordinate system manipulation functions Rotates the given coordinate system (represented by the matrix) around its Y-axis

Turn

GLScene.VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterUp

TUseDirtyTiles

GXS.AsyncHDS

Determines if/how dirty tiles are displayed and when they are released. When a tile is maked as dirty, a replacement is queued immediately. However, the replacement cant be used until the HDThread has finished preparing it. Dirty tiles can be deleted as soon as they are no longer used/displayed. Possible states for a TUseDirtyTiles. hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, before allowing the renderer to switch over to the new set of tiles. (This prevents a fading checkerbox effect.)

TVBOBuffer

GXS.VectorFileObjects

TVBOBuffers

GXS.VectorFileObjects

TVector2b

GLScene.VectorTypes

TVector2d

GLScene.VectorTypes

=========== Vectors ============ 2

TVector2DArray

GLScene.VectorTypesExt

Vector Arrays

TVector2DRec

GLScene.VectorTypesExt

TVector2DType

GLScene.VectorTypesExt

———————– Vector types ———————–

TVector2e

GLScene.VectorTypes

TVector2f

GLScene.VectorTypes

TVector2h

GLScene.VectorTypes

TVector2i

GLScene.VectorTypes

TVector2p

GLScene.VectorTypes

TVector2s

GLScene.VectorTypes

TVector2sb

GLScene.VectorTypes

TVector2ui

GLScene.VectorTypes

TVector2w

GLScene.VectorTypes

TVector3b

GLScene.VectorTypes

TVector3d

GLScene.VectorTypes

3

TVector3DArray

GLScene.VectorTypesExt

TVector3DRec

GLScene.VectorTypesExt

TVector3DType

GLScene.VectorTypesExt

TVector3e

GLScene.VectorTypes

TVector3f

GLScene.VectorTypes

TVector3h

GLScene.VectorTypes

TVector3i

GLScene.VectorTypes

TVector3p

GLScene.VectorTypes

TVector3s

GLScene.VectorTypes

TVector3sb

GLScene.VectorTypes

TVector3ui

GLScene.VectorTypes

TVector3w

GLScene.VectorTypes

TVector4b

GLScene.VectorTypes

TVector4d

GLScene.VectorTypes

4

TVector4e

GLScene.VectorTypes

TVector4f

GLScene.VectorTypes

TVector4h

GLScene.VectorTypes

TVector4i

GLScene.VectorTypes

TVector4p

GLScene.OpenGL4

TVector4p

GLScene.VectorTypes

TVector4s

GLScene.VectorTypes

TVector4sb

GLScene.VectorTypes

TVector4ui

GLScene.VectorTypes

TVector4w

GLScene.VectorTypes

TVectorArr

GXS.Isolines

TVectorArray

GLScene.VectorGeometry

TVectorExt

GLScene.VectorTypesExt

TVectorHelper

GLScene.VectorTypesExt

TVectorL4D

GXS.Isolines

TVectorL4I

GXS.Isolines

TVectorRec

GLScene.VectorTypesExt

TVertArray

GLScene.VectorTypesExt

TVertex

GLScene.VectorGeometry

TVertex2DArr

GXS.Isolines

TVertexArray

GLScene.VectorTypesExt

TVertexMode

GXS.Mesh

TVertexRec

GLScene.VectorTypesExt

TVertexRec

GXS.Objects

TVertexWeightList

GXS.FileMS3D

TVirtualKeyCode

GLScene.Keyboard

TVoxelData

GLScene.VectorTypesExt

TVoxelRec

GLScene.VectorTypesExt

TVoxelStatus

GLScene.VectorTypesExt

Voxel types

TWaveRec

GBE.PlaneExtend

TWaveSystem

GBE.omOceanWaves

TGBEPlaneExtend and WaveRec

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

Tweener

GLScene.AnimationUtils

TWGLSwap

GLScene.OpenGL4

TWGLswap

GLScene.OpenGLTokens

TWindArrowSurface

GBE.omOceanWaves

TWordVector

GLScene.VectorGeometry

TXCollection

GLScene.XCollection

Holds a list of TXCollectionItem objects. This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList, if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than VCL's lists and persistence mechanisms with polymorphism-support and full backward compatibility

TXCollectionEditorForm

FMxXCollectionEditor

TXCollectionItem

GLScene.XCollection

Base class for implementing a XCollection item. NOTES : Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation

TXCollectionItemClass

GLScene.XCollection

TXCollectionProperty

GLScene.XCollectionRegister

ToDo DesignEditors, DesignIntf,

TXCollectionProperty

GXS.RegisterXCollection

TXYZGridLinesStyle

GXS.Graph

Rendering Style for grid lines. - glsLine : a single line is used for each grid line (from Min to Max), this provides the fastest rendering - glsSegments : line segments are used between each node of the grid, this enhances perspective and quality, at the expense of computing power.

TXYZGridPart

GXS.Graph

TXYZGridParts

GXS.Graph

TZArray

GXS.zBuffer

TZArrayIdx

GXS.zBuffer

TZLibArchive

GXS.FileZLIB

TZLibArchive

TZLibHeader

GXS.FileZLIB

Signature for compressed zlib.

UnApplyBlendingModeEx

GXSL.CustomShader

UnifyTrianglesWinding

GXS.MeshUtils

Attempts to unify triangle winding. Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

UnloadOpenGL

GLScene.OpenGL4

compatibility routines

UnloadOpenGL

GXS.OpenGLAdapter

compatibility routines

UnPackRotationMatrix

GLScene.VectorGeometry

Restores a packed rotation matrix. See PackRotationMatrix

UnpressGroup

GXS.Windows

UnProject

GLScene.VectorGeometry

UnregisterArchiveFormat

GXS.ArchiveManager

UnregisterGLXceneObject

GXS.ODEManager

UnregisterRasterFormat

GXS.Graphics

UnregisterSoundFileClass

GXS.SoundFileObjects

UnRegisterTextureImageEditor

GXS.TextureImageEditors

UnregisterVectorFileClass

GXS.VectorFileObjects

UnregisterXCollectionItemClass

GLScene.XCollection

Removes a TXCollectionItem subclass from the list

UseCustomGLSLogger

GLScene.Logger

UserLog

GLScene.Logger

Return logger wich created by TGLSLogger component

vContextActivationFailureOccurred

GXS.Context

vCounterFrequency

GXS.Scene

vCurrentContext

GXS.Context

vCurrentRenderingObject

GXS.Scene

vCurrentVideoMode

GXS.Screen

vCustomColliderClass

GXS.ODEManager

vCustomColliderClassNum

GXS.ODEManager

vDDSDetailLevel

GXS.FileDDS

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.

vDefaultMeshOptimizerOptions

GXS.MeshOptimizer

vDefaultTextureCompression

GLScene.TextureFormat

vDefaultTextureFormat

GLScene.TextureFormat

Vector2bMake

GLScene.VectorGeometry

Vector2bMake

GLScene.VectorGeometry

Vector2bMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2dMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

Vector2fMake

GLScene.VectorGeometry

2x

Vector2iMake

GLScene.VectorGeometry

Vector2iMake

GLScene.VectorGeometry

Vector2iMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector2sMake

GLScene.VectorGeometry

Vector3bMake

GLScene.VectorGeometry

Vector3bMake

GLScene.VectorGeometry

Vector3bMake

GLScene.VectorGeometry

Vector3dMake

GLScene.VectorGeometry

Vector3dMake

GLScene.VectorGeometry

Vector3dMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

Vector3fMake

GLScene.VectorGeometry

3x

Vector3iMake

GLScene.VectorGeometry

Vector3iMake

GLScene.VectorGeometry

Vector3iMake

GLScene.VectorGeometry

Vector3sMake

GLScene.VectorGeometry

Vector3sMake

GLScene.VectorGeometry

Vector3sMake

GLScene.VectorGeometry

Vector4bMake

GLScene.VectorGeometry

Vector4bMake

GLScene.VectorGeometry

Vector4bMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4dMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

Vector4fMake

GLScene.VectorGeometry

4x

Vector4iMake

GLScene.VectorGeometry

Vector4iMake

GLScene.VectorGeometry

Vector4iMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

Vector4sMake

GLScene.VectorGeometry

VectorAbs

GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAbs

GLScene.VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

VectorAdd

GLScene.VectorGeometry

Adds two vectors and places result in vr

VectorAdd

GLScene.VectorGeometry

Returns the sum of two affine vectors

VectorAdd

GLScene.VectorGeometry

Returns the sum of two homogeneous vectors

VectorAdd

GLScene.VectorGeometry

Sums up f to each component of the vector

VectorAdd

GLScene.VectorGeometry

Sums up f to each component of the vector

VectorAffineDblToFlt

GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values

VectorAffineFltToDbl

GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values

VectorAngleCombine

GLScene.VectorGeometry

VectorAngleCosine

GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleCosine

GLScene.VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2. Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleLerp

GLScene.VectorGeometry

VectorArrayAdd

GLScene.VectorGeometry

Adds delta to nb vectors in src and places result in dest

VectorArrayLerp

GLScene.VectorGeometry

VectorArrayLerp

GLScene.VectorGeometry

VectorArrayLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector arrays

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and place result in vr, F1=1.0

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

GLScene.VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine3

GLScene.VectorGeometry

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

GLScene.VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

GLScene.VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorDblToFlt

GLScene.VectorGeometry

Converts a vector containing double sized values into a vector with single sized values

VectorDistance

GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...)

VectorDistance

GLScene.VectorGeometry

Calculates distance between two vectors. ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

VectorDistance2

GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...

VectorDistance2

GLScene.VectorGeometry

Calculates the "Norm 2" between two vectors. ie. sqr(v1[x]-v2[x])+...(w component ignored)

VectorDivide

GLScene.VectorGeometry

VectorDivide

GLScene.VectorGeometry

VectorDivide

GXS.EllipseCollision

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

GLScene.VectorGeometry

Calculates the dot product between V1 and V2. Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

VectorEquals

GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector3f): Boolean; overload; //declared further

VectorEquals

GLScene.VectorGeometry

function VectorEquals(const V1, V2: TVector4f): Boolean; overload; //declared further

VectorEquals

GLScene.VectorGeometry

True if all components are equal.

VectorEquals

GLScene.VectorGeometry

True if all components are equal.

VectorFileFormatExtensionByIndex

GXS.VectorFileObjects

Returns an extension by its index in the vector files dialogs filter. Use VectorFileFormatsFilter to obtain the filter.

VectorFileFormatsFilter

GXS.VectorFileObjects

A file extension filter suitable for dialog's 'Filter' property

VectorFileFormatsSaveFilter

GXS.VectorFileObjects

A file extension filter suitable for a savedialog's 'Filter' property

VectorFltToDbl

GLScene.VectorGeometry

Converts a vector containing single sized values into a vector with double sized values

VectorIsNull

GLScene.VectorGeometry

True if x=y=z=0, w ignored

VectorIsNull

GLScene.VectorGeometry

True if x=y=z=0, w ignored

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

VectorLength

GLScene.VectorGeometry

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...). Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLerp

GLScene.VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessEqualThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorLessThen

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMake

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreEqualThen

GLScene.VectorGeometry

VectorMoreThen

GLScene.VectorGeometry

3i

VectorMoreThen

GLScene.VectorGeometry

3i

VectorMoreThen

GLScene.VectorGeometry

3s

VectorMoreThen

GLScene.VectorGeometry

3s

VectorMoreThen

GLScene.VectorGeometry

4f

VectorMoreThen

GLScene.VectorGeometry

4f

VectorMoreThen

GLScene.VectorGeometry

4i

VectorMoreThen

GLScene.VectorGeometry

4i

VectorMoreThen

GLScene.VectorGeometry

4s

VectorMoreThen

GLScene.VectorGeometry

4s

VectorMoreThen

GLScene.VectorGeometry

ComparedNumber 3f

VectorMoreThen

GLScene.VectorGeometry

Vector comparison functions: 3f

VectorNegate

GLScene.VectorGeometry

VectorNegate

GLScene.VectorGeometry

Negates the vector

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = v.X*v.X + ... Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x * x + y * y Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

GLScene.VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length

VectorNormalize

GLScene.VectorGeometry

Returns the vector transformed to unit length (w component dropped)

VectorPerpendicular

GLScene.VectorGeometry

Calculates a vector perpendicular to N. N is assumed to be of unit length, subtract out any component parallel to N

VectorReflect

GLScene.VectorGeometry

Reflects vector V against N (assumes N is normalized)

VectorRotateAroundX

GLScene.VectorGeometry

Returns given vector rotated around the X axis (alpha is in rad)

VectorRotateAroundY

GLScene.VectorGeometry

Returns given vector rotated around the Y axis (alpha is in rad)

VectorRotateAroundY

GLScene.VectorGeometry

Returns given vector rotated around the Y axis in vr (alpha is in rad)

VectorRotateAroundZ

GLScene.VectorGeometry

Returns given vector rotated around the Z axis (alpha is in rad)

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

Returns a vector scaled by a factor

VectorScale

GLScene.VectorGeometry

RScales given vector by another vector

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

GLScene.VectorGeometry

Scales given vector by another vector

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".

VectorSpacing

GLScene.VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".

VectorSubtract

GLScene.VectorGeometry

VectorSubtract

GLScene.VectorGeometry

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Returns V1-V2

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

GLScene.VectorGeometry

Subtracts V2 from V1 and return value in result

VectorTransform

GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix

VectorTransform

GLScene.VectorGeometry

Transforms an affine vector by multiplying it with a matrix

vEdgeInfoReserveSize

GXS.MeshUtils

VERTEX_ATTR_NUM

GXS.State

VerticalScalingFactor

GXS.RandomHDS

vFile3DSSceneObjects_RenderCameraAndLights

GXS.File3DSSceneObjects

vFile3DS_EnableAnimation

GXS.File3DS

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TgxFreeForm.AutoCentering does now work correctly. - TgxMeshObject.vertices return values different from TgxMeshObject.ExtractTriangles()

vFile3DS_FixDefaultUpAxisY

GXS.File3DS

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vFile3DS_EnableAnimation = true)

vFile3DS_LoadedStaticFrame

GXS.File3DS

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.

vFile3DS_UseTextureEx

GXS.File3DS

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vFileOBJ_SplitMesh

GXS.FileOBJ

If enabled, main mesh will be splitted into multiple mesh from facegroup data.

vFileOCTAllocateMaterials

GXS.FileOCT

Flag to avoid loading materials (useful for IDE Extensions or scene editors)

vFileOCTLightmapBrightness

GXS.FileOCT

Scaling factor, 1.0 = unchanged

vFileOCTLightmapGammaCorrection

GXS.FileOCT

Scaling factor, 1.0 = unchanged

vFileQ3BSPLoadMaterials

GXS.FileQ3BSP

scaling factor, 1.0 = unchanged

vFindCuFileFunc

GXS.CUDA.Compiler

vFontManagerMsgID

GXS.SpaceText

vGhoul2LevelOfDetail

GXS.FileGL2

vGhoul2MaxBonesPerVertex

GXS.FileGL2

Highest detail level by default

vGLSmartObjectsAllocate

GXS.SmartObjects

vGLSmartObjectsEnableByDefault

GXS.SmartObjects

vGXAFIOCreateFileStream

GXS.ApplicationFileIO

vGXAFIOFileStreamExists

GXS.ApplicationFileIO

vIDELogProc

GLScene.Logger

vIgnoreOpenGLErrors

GLScene.OpenGL4

Raises an EOpenGLError with 'msg' error string

vIgnoreOpenGXErrors

GXS.Context

vImageScaleFilterWidth

GXS.ImageUtils

vImprovedFixingOpenTriangleEdge

GXS.MeshUtils

VirtualKeyCodeToKeyName

GLScene.Keyboard

Converts a virtual key code to its name. The name is expressed using the locale windows options.

VK_MOUSEWHEELDOWN

GLScene.Keyboard

VK_MOUSEWHEELUP

GLScene.Keyboard

pseudo wheel keys (we squat F23/F24), see KeyboardNotifyWheelMoved

vLastWheelDelta

GLScene.Keyboard

vMD5TextureExtensions

GXS.FileMD5

vMultitextureCoordinatorClass

GXS.Context

vNumberVideoModes

GXS.Screen

vODEObjectRegister

GXS.ODEManager

vODERagdoll_cDensity

GXS.ODERagdoll

vODERagdoll_cMass

GXS.ODERagdoll

vProjectTargetName

GLScene.Utils

vQ3BSPLightmapBrightness

GXS.FileQ3BSP

vQ3BSPLightmapGammaCorrection

GXS.FileQ3BSP

Q3 lightmaps are quite dark, we brighten them a lot by default

vSecondTextureUnitForbidden

GXS.XOpenGL

vSIMD

GLScene.VectorGeometry

This var is adjusted during "initialization", current values are + 0 : use standard optimized FPU code + 1 : use 3DNow! optimized code (requires K6-2/3 CPU) + 2 : use Intel SSE code (Pentium III, NOT IMPLEMENTED YET !)

vUseWindowTrackingHook

GXS.WinContext

This boolean controls a hook-based tracking of top-level forms destruction, with the purpose of being able to properly release OpenGL contexts before they are (improperly) released by some drivers upon top-level form destruction.

vVectorFileObjectsAllocateMaterials

GXS.VectorFileObjects

vVectorFileObjectsEnableVBOByDefault

GXS.VectorFileObjects

Flag to avoid loading materials (useful for IDE Extentions or scene editors)

vVerboseGLSMErrors

GXS.SoundManager

If this variable is true, errors in GLSM may be displayed to the user

vVerticalFlipDDS

GXS.Graphics

vVideoModes

GXS.Screen

WeldVertices

GXS.MeshUtils

Welds all vertices separated by a distance inferior to weldRadius. Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter). The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex]. The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex. This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

wglAllocateMemoryNV

GLScene.OpenGL4

wglBindTexImageARB

GLScene.OpenGL4

WGL_ARB_render_texture (ARB #20)

wglChoosePixelFormatARB

GLScene.OpenGL4

wglCopyContext

GLScene.OpenGL4

wglCopyContext

GXS.OpenGLAdapter

TGLExtensionsAndEntryPoints —————————— Windows OpenGL (WGL) support functions {$IFDEF SUPPORT_WGL} function wglGetProcAddress(ProcName: PAnsiChar): Pointer; stdcall; external opengl32;

wglCreateAffinityDCNV

GLScene.OpenGL4

wglCreateBufferRegionARB

GLScene.OpenGL4

########################################################### function and procedure definitions for ARB approved WGL extensions ########################################################### WGL_buffer_region (ARB #4)

wglCreateContext

GLScene.OpenGL4

wglCreateContext

GXS.OpenGLAdapter

wglCreateContextAttribsARB

GLScene.OpenGL4

WGL_ARB_create_context (ARB #55)

wglCreateLayerContext

GLScene.OpenGL4

wglCreateLayerContext

GXS.OpenGLAdapter

wglCreatePbufferARB

GLScene.OpenGL4

WGL_ARB_pbuffer (ARB #11)

wglDeleteBufferRegionARB

GLScene.OpenGL4

wglDeleteContext

GLScene.OpenGL4

wglDeleteContext

GXS.OpenGLAdapter

wglDeleteDCNV

GLScene.OpenGL4

wglDescribeLayerPlane

GLScene.OpenGL4

wglDestroyPbufferARB

GLScene.OpenGL4

wglEnumGpuDevicesNV

GLScene.OpenGL4

wglEnumGpusFromAffinityDCNV

GLScene.OpenGL4

wglEnumGpusNV

GLScene.OpenGL4

WGL_NV_gpu_affinity

wglFreeMemoryNV

GLScene.OpenGL4

wglGetCurrentContext

GLScene.OpenGL4

wglGetCurrentContext

GXS.OpenGLAdapter

function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;

wglGetCurrentDC

GLScene.OpenGL4

wglGetCurrentDC

GXS.OpenGLAdapter

wglGetCurrentReadDCARB

GLScene.OpenGL4

wglGetExtensionsStringARB

GLScene.OpenGL4

WGL_ARB_extensions_string (ARB #8)

wglGetLayerPaletteEntries

GLScene.OpenGL4

wglGetPbufferDCARB

GLScene.OpenGL4

wglGetPixelFormatAttribfvARB

GLScene.OpenGL4

wglGetPixelFormatAttribivARB

GLScene.OpenGL4

WGL_ARB_pixel_format (ARB #9)

wglGetProcAddress

GLScene.OpenGL4

wglGetSwapIntervalEXT

GLScene.OpenGL4

wglMakeContextCurrentARB

GLScene.OpenGL4

WGL_make_current_read (ARB #10)

wglMakeCurrent

GLScene.OpenGL4

wglMakeCurrent

GXS.OpenGLAdapter

function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

wglQueryPbufferARB

GLScene.OpenGL4

wglRealizeLayerPalette

GLScene.OpenGL4

wglRealizeLayerPalette

GXS.OpenGLAdapter

wglReleasePbufferDCARB

GLScene.OpenGL4

wglReleaseTexImageARB

GLScene.OpenGL4

wglRestoreBufferRegionARB

GLScene.OpenGL4

wglSaveBufferRegionARB

GLScene.OpenGL4

wglSetLayerPaletteEntries

GLScene.OpenGL4

wglSetPbufferAttribARB

GLScene.OpenGL4

wglShareLists

GLScene.OpenGL4

wglShareLists

GXS.OpenGLAdapter

function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;

WGLSWAP

GLScene.OpenGL4

WGLSWAP

GLScene.OpenGLTokens

wglSwapIntervalEXT

GLScene.OpenGL4

########################################################### function and procedure definitions for Vendor/EXT WGL extensions ########################################################### WGL_EXT_swap_control (EXT #172)

wglSwapLayerBuffers

GLScene.OpenGL4

wglSwapLayerBuffers

GXS.OpenGLAdapter

wglSwapMultipleBuffers

GLScene.OpenGL4

wglUseFontBitmaps

GLScene.OpenGL4

wglUseFontBitmapsA

GLScene.OpenGL4

wglUseFontBitmapsW

GLScene.OpenGL4

wglUseFontOutlines

GLScene.OpenGL4

wglUseFontOutlinesA

GLScene.OpenGL4

wglUseFontOutlinesW

GLScene.OpenGL4

WGL_3DFX_multisample

GLScene.OpenGL4

WGL

WGL_3DL_stereo_control

GLScene.OpenGL4

WGL

WGL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGL4

WGL_NV_DX_interop

WGL_ACCESS_READ_ONLY_NV

GLScene.OpenGLTokens

WGL_NV_DX_interop (EXT #407)

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGL4

WGL_ACCESS_READ_WRITE_NV

GLScene.OpenGLTokens

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGL4

WGL_ACCESS_WRITE_DISCARD_NV

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGL4

WGL_ACCUM_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_ACCUM_RED_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGL4

WGL_ALPHA_BITS_ARB

GLScene.OpenGLTokens

WGL_ALPHA_BITS_EXT

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGL4

WGL_ALPHA_SHIFT_ARB

GLScene.OpenGLTokens

WGL_ALPHA_SHIFT_EXT

GLScene.OpenGL4

WGL_AMD_gpu_association

GLScene.OpenGL4

WGL

WGL_ARB_buffer_region

GLScene.OpenGL4

WGL

WGL_ARB_context_flush_control

GLScene.OpenGL4

WGL

WGL_ARB_create_context

GLScene.OpenGL4

WGL

WGL_ARB_create_context_profile

GLScene.OpenGL4

WGL

WGL_ARB_create_context_robustness

GLScene.OpenGL4

WGL

WGL_ARB_extensions_string

GLScene.OpenGL4

WGL

WGL_ARB_framebuffer_sRGB

GLScene.OpenGL4

WGL

WGL_ARB_make_current_read

GLScene.OpenGL4

WGL

WGL_ARB_multisample

GLScene.OpenGL4

WGL

WGL_ARB_pbuffer

GLScene.OpenGL4

WGL

WGL_ARB_pixel_format

GLScene.OpenGL4

WGL

WGL_ARB_pixel_format_float

GLScene.OpenGL4

WGL

WGL_ARB_render_texture

GLScene.OpenGL4

WGL

WGL_ATI_pixel_format_float

GLScene.OpenGL4

WGL

WGL_AUX0_ARB

GLScene.OpenGL4

WGL_AUX0_ARB

GLScene.OpenGLTokens

WGL_AUX1_ARB

GLScene.OpenGL4

WGL_AUX1_ARB

GLScene.OpenGLTokens

WGL_AUX2_ARB

GLScene.OpenGL4

WGL_AUX2_ARB

GLScene.OpenGLTokens

WGL_AUX3_ARB

GLScene.OpenGL4

WGL_AUX3_ARB

GLScene.OpenGLTokens

WGL_AUX4_ARB

GLScene.OpenGL4

WGL_AUX4_ARB

GLScene.OpenGLTokens

WGL_AUX5_ARB

GLScene.OpenGL4

WGL_AUX5_ARB

GLScene.OpenGLTokens

WGL_AUX6_ARB

GLScene.OpenGL4

WGL_AUX6_ARB

GLScene.OpenGLTokens

WGL_AUX7_ARB

GLScene.OpenGL4

WGL_AUX7_ARB

GLScene.OpenGLTokens

WGL_AUX8_ARB

GLScene.OpenGL4

WGL_AUX8_ARB

GLScene.OpenGLTokens

WGL_AUX9_ARB

GLScene.OpenGL4

WGL_AUX9_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_ARB

GLScene.OpenGL4

WGL_AUX_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_AUX_BUFFERS_EXT

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_BACK_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_BACK_LEFT_ARB

GLScene.OpenGL4

WGL_BACK_LEFT_ARB

GLScene.OpenGLTokens

WGL_BACK_RIGHT_ARB

GLScene.OpenGL4

WGL_BACK_RIGHT_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_DEPTH_NV

GLScene.OpenGL4

WGL_NV_render_depth_texture

WGL_BIND_TO_TEXTURE_RECTANGLE_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RECTANGLE_RGB_NV

GLScene.OpenGL4

WGL_NV_render_texture_rectangle

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_BIND_TO_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_ARB_render_texture

WGL_BIND_TO_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

ARB Extension #20 - WGL_ARB_render_texture

WGL_BIND_TO_VIDEO_RGBA_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_AND_DEPTH_NV

GLScene.OpenGL4

WGL_BIND_TO_VIDEO_RGB_NV

GLScene.OpenGL4

WGL_NV_video_output

WGL_BLUE_BITS_ARB

GLScene.OpenGL4

WGL_BLUE_BITS_ARB

GLScene.OpenGLTokens

WGL_BLUE_BITS_EXT

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGL4

WGL_BLUE_SHIFT_ARB

GLScene.OpenGLTokens

WGL_BLUE_SHIFT_EXT

GLScene.OpenGL4

WGL_CLAMP_FRAGMENT_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_READ_COLOR_ARB

GLScene.OpenGL4

WGL_CLAMP_VERTEX_COLOR_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGL4

WGL_COLOR_BITS_ARB

GLScene.OpenGLTokens

WGL_COLOR_BITS_EXT

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGL4

WGL_COLOR_SAMPLES_NV

GLScene.OpenGLTokens

unknown extension, where does it come from?

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context

WGL_CONTEXT_DEBUG_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGL4

WGL_EXT_create_context_es2_profile

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

GLScene.OpenGLTokens

EXT #400 WGL_EXT_create_context_es2_profile

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGL4

WGL_CONTEXT_FLAGS_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGL4

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGL4

WGL_CONTEXT_LAYER_PLANE_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MAJOR_VERSION_ARB

GLScene.OpenGLTokens

ARB Extension #55 - WGL_ARB_create_context see also WGL_ARB_create_context_profile (ARB #74)

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGL4

WGL_CONTEXT_MINOR_VERSION_ARB

GLScene.OpenGLTokens

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGL4

WGL_ARB_create_context_profile

WGL_CONTEXT_PROFILE_MASK_ARB

GLScene.OpenGLTokens

ARB Extension #74 - WGL_ARB_create_context_profile see also WGL_ARB_create_context (ARB #55)

WGL_CONTEXT_RELEASE_BEHAVIOR_ARB

GLScene.OpenGL4

WGL_ARB_context_flush_control

WGL_CONTEXT_RELEASE_BEHAVIOR_FLUSH_ARB

GLScene.OpenGL4

WGL_CONTEXT_RELEASE_BEHAVIOR_NONE_ARB

GLScene.OpenGL4

WGL_CONTEXT_RESET_ISOLATION_BIT_ARB

GLScene.OpenGL4

WGL_ARB_robustness_application_isolation

WGL_CONTEXT_RESET_NOTIFICATION_STRATEGY_ARB

GLScene.OpenGL4

WGL_CONTEXT_ROBUST_ACCESS_BIT_ARB

GLScene.OpenGL4

WGL_ARB_create_context_robustness

WGL_COVERAGE_SAMPLES_NV

GLScene.OpenGL4

WGL_NV_multisample_coverage

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGL4

WGL_CUBE_MAP_FACE_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_ARB

GLScene.OpenGL4

WGL_DEPTH_BITS_ARB

GLScene.OpenGLTokens

WGL_DEPTH_BITS_EXT

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_DEPTH_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_DEPTH_FLOAT_EXT

GLScene.OpenGL4

WGL_EXT_depth_float

WGL_DEPTH_TEXTURE_FORMAT_NV

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_FRAMEBUFFER_I3D

GLScene.OpenGL4

WGL_I3D_digital_video_control

WGL_DIGITAL_VIDEO_CURSOR_ALPHA_VALUE_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_CURSOR_INCLUDED_I3D

GLScene.OpenGL4

WGL_DIGITAL_VIDEO_GAMMA_CORRECTED_I3D

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGL4

WGL_DOUBLE_BUFFER_ARB

GLScene.OpenGLTokens

WGL_DOUBLE_BUFFER_EXT

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGL4

WGL_DRAW_TO_BITMAP_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_BITMAP_EXT

GLScene.OpenGL4

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGL4

WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_ARB

GLScene.OpenGLTokens

ARB Extension #11 - WGL_ARB_pbuffer

WGL_DRAW_TO_PBUFFER_EXT

GLScene.OpenGL4

WGL_EXT_pbuffer

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGL4

WGL_DRAW_TO_WINDOW_ARB

GLScene.OpenGLTokens

WGL_DRAW_TO_WINDOW_EXT

GLScene.OpenGL4

WGL_ERROR_INCOMPATIBLE_AFFINITY_MASKS_NV

GLScene.OpenGL4

WGL_NV_gpu_affinity

WGL_ERROR_MISSING_AFFINITY_MASK_NV

GLScene.OpenGL4

WGL_EXT_create_context_es2_profile

GLScene.OpenGL4

WGL

WGL_EXT_depth_float

GLScene.OpenGL4

WGL

WGL_EXT_display_color_table

GLScene.OpenGL4

WGL

WGL_EXT_extensions_string

GLScene.OpenGL4

WGL

WGL_EXT_make_current_read

GLScene.OpenGL4

WGL

WGL_EXT_multisample

GLScene.OpenGL4

WGL

WGL_EXT_pbuffer

GLScene.OpenGL4

WGL

WGL_EXT_pixel_format

GLScene.OpenGL4

WGL

WGL_EXT_swap_control

GLScene.OpenGL4

WGL

WGL_FIXED_ONLY_ARB

GLScene.OpenGL4

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGL4

WGL_NV_float_buffer

WGL_FLOAT_COMPONENTS_NV

GLScene.OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGL4

WGL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

GLScene.OpenGLTokens

ARB Extension #46 - GL_ARB_framebuffer_sRGB

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT

GLScene.OpenGL4

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_ARB_buffer_region

WGL_FRONT_COLOR_BUFFER_BIT_ARB

GLScene.OpenGLTokens

—————— OpenGL v1.1 generic constants ——————– ARB Extension #4 - WGL_ARB_buffer_region

WGL_FRONT_LEFT_ARB

GLScene.OpenGL4

WGL_FRONT_LEFT_ARB

GLScene.OpenGLTokens

WGL_FRONT_RIGHT_ARB

GLScene.OpenGL4

WGL_FRONT_RIGHT_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGL4

WGL_FULL_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_FULL_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GAMMA_EXCLUDE_DESKTOP_I3D

GLScene.OpenGL4

WGL_GAMMA_TABLE_SIZE_I3D

GLScene.OpenGL4

WGL_I3D_gamma

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGL4

WGL_GENERIC_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_GENERIC_ACCELERATION_EXT

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_DIGITAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_BOTH_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_FALLING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EDGE_RISING_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_FIELD_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_SYNC_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_EXTENAL_TTL_I3D

GLScene.OpenGL4

WGL_GENLOCK_SOURCE_MULTIVIEW_I3D

GLScene.OpenGL4

WGL_I3D_genlock

WGL_GPU_CLOCK_AMD

GLScene.OpenGL4

WGL_GPU_FASTEST_TARGET_GPUS_AMD

GLScene.OpenGL4

WGL_GPU_NUM_PIPES_AMD

GLScene.OpenGL4

WGL_GPU_NUM_RB_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SIMD_AMD

GLScene.OpenGL4

WGL_GPU_NUM_SPI_AMD

GLScene.OpenGL4

WGL_GPU_OPENGL_VERSION_STRING_AMD

GLScene.OpenGL4

WGL_GPU_RAM_AMD

GLScene.OpenGL4

WGL_GPU_RENDERER_STRING_AMD

GLScene.OpenGL4

WGL_GPU_VENDOR_AMD

GLScene.OpenGL4

WGL_AMD_gpu_association

WGL_GREEN_BITS_ARB

GLScene.OpenGL4

WGL_GREEN_BITS_ARB

GLScene.OpenGLTokens

WGL_GREEN_BITS_EXT

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGL4

WGL_GREEN_SHIFT_ARB

GLScene.OpenGLTokens

WGL_GREEN_SHIFT_EXT

GLScene.OpenGL4

WGL_I3D_digital_video_control

GLScene.OpenGL4

WGL

WGL_I3D_gamma

GLScene.OpenGL4

WGL

WGL_I3D_genlock

GLScene.OpenGL4

WGL

WGL_I3D_image_buffer

GLScene.OpenGL4

WGL

WGL_I3D_swap_frame_lock

GLScene.OpenGL4

WGL

WGL_I3D_swap_frame_usage

GLScene.OpenGL4

WGL

WGL_IMAGE_BUFFER_LOCK_I3D

GLScene.OpenGL4

WGL_IMAGE_BUFFER_MIN_ACCESS_I3D

GLScene.OpenGL4

WGL_I3D_image_buffer

WGL_LOSE_CONTEXT_ON_RESET_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_PIXELS_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_PIXELS_EXT

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_MAX_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_MAX_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGL4

WGL_MIPMAP_LEVEL_ARB

GLScene.OpenGLTokens

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGL4

WGL_MIPMAP_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_PALETTE_EXT

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGL4

WGL_NEED_SYSTEM_PALETTE_ARB

GLScene.OpenGLTokens

WGL_NEED_SYSTEM_PALETTE_EXT

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGL4

WGL_NO_ACCELERATION_ARB

GLScene.OpenGLTokens

WGL_NO_ACCELERATION_EXT

GLScene.OpenGL4

WGL_NO_RESET_NOTIFICATION_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGL4

WGL_NO_TEXTURE_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_OVERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_OVERLAYS_EXT

GLScene.OpenGL4

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format

WGL_NUMBER_PIXEL_FORMATS_ARB

GLScene.OpenGLTokens

ARB Extension #9 - WGL_ARB_pixel_format (no new tokens)

WGL_NUMBER_PIXEL_FORMATS_EXT

GLScene.OpenGL4

WGL_EXT_pixel_format

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGL4

WGL_NUMBER_UNDERLAYS_ARB

GLScene.OpenGLTokens

WGL_NUMBER_UNDERLAYS_EXT

GLScene.OpenGL4

WGL_NUM_VIDEO_CAPTURE_SLOTS_NV

GLScene.OpenGL4

WGL_NUM_VIDEO_SLOTS_NV

GLScene.OpenGL4

WGL_NV_present_video

WGL_NV_copy_image

GLScene.OpenGL4

WGL

WGL_NV_DX_interop

GLScene.OpenGL4

WGL

WGL_NV_float_buffer

GLScene.OpenGL4

WGL

WGL_NV_gpu_affinity

GLScene.OpenGL4

WGL

WGL_NV_multisample_coverage

GLScene.OpenGL4

WGL

WGL_NV_present_video

GLScene.OpenGL4

WGL

WGL_NV_render_depth_texture

GLScene.OpenGL4

WGL

WGL_NV_render_texture_rectangle

GLScene.OpenGL4

WGL

WGL_NV_swap_group

GLScene.OpenGL4

WGL

WGL_NV_vertex_array_range

GLScene.OpenGL4

WGL

WGL_NV_video_capture

GLScene.OpenGL4

WGL

WGL_NV_video_output

GLScene.OpenGL4

WGL

WGL_OML_sync_control

GLScene.OpenGL4

WGL

WGL_OPTIMAL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_OPTIMAL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGL4

WGL_PBUFFER_HEIGHT_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_HEIGHT_EXT

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LARGEST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_LARGEST_EXT

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGL4

WGL_PBUFFER_LOST_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGL4

WGL_PBUFFER_WIDTH_ARB

GLScene.OpenGLTokens

WGL_PBUFFER_WIDTH_EXT

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGL4

WGL_PIXEL_TYPE_ARB

GLScene.OpenGLTokens

WGL_PIXEL_TYPE_EXT

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGL4

WGL_RED_BITS_ARB

GLScene.OpenGLTokens

WGL_RED_BITS_EXT

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGL4

WGL_RED_SHIFT_ARB

GLScene.OpenGLTokens

WGL_RED_SHIFT_EXT

GLScene.OpenGL4

WGL_RGBA_FLOAT_MODE_ARB

GLScene.OpenGL4

WGL_ARB_pixel_format_float

WGL_SAMPLES_3DFX

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGL4

WGL_SAMPLES_ARB

GLScene.OpenGLTokens

WGL_SAMPLES_EXT

GLScene.OpenGL4

WGL_SAMPLE_BUFFERS_3DFX

GLScene.OpenGL4

WGL_3DFX_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGL4

WGL_ARB_multisample

WGL_SAMPLE_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SAMPLE_BUFFERS_EXT

GLScene.OpenGL4

WGL_EXT_multisample

WGL_SHARE_ACCUM_ARB

GLScene.OpenGL4

WGL_SHARE_ACCUM_ARB

GLScene.OpenGLTokens

WGL_SHARE_ACCUM_EXT

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGL4

WGL_SHARE_DEPTH_ARB

GLScene.OpenGLTokens

WGL_SHARE_DEPTH_EXT

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGL4

WGL_SHARE_STENCIL_ARB

GLScene.OpenGLTokens

WGL_SHARE_STENCIL_EXT

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGL4

WGL_STENCIL_BITS_ARB

GLScene.OpenGLTokens

WGL_STENCIL_BITS_EXT

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGL4

WGL_STENCIL_BUFFER_BIT_ARB

GLScene.OpenGLTokens

WGL_STEREO_ARB

GLScene.OpenGL4

WGL_STEREO_ARB

GLScene.OpenGLTokens

WGL_STEREO_EXT

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGL4

WGL_SUPPORT_GDI_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_GDI_EXT

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGL4

WGL_SUPPORT_OPENGL_ARB

GLScene.OpenGLTokens

WGL_SUPPORT_OPENGL_EXT

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGL4

WGL_SWAP_COPY_ARB

GLScene.OpenGLTokens

WGL_SWAP_COPY_EXT

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGL4

WGL_SWAP_EXCHANGE_ARB

GLScene.OpenGLTokens

WGL_SWAP_EXCHANGE_EXT

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGL4

WGL_SWAP_LAYER_BUFFERS_ARB

GLScene.OpenGLTokens

WGL_SWAP_LAYER_BUFFERS_EXT

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGL4

WGL_SWAP_METHOD_ARB

GLScene.OpenGLTokens

WGL_SWAP_METHOD_EXT

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGL4

WGL_SWAP_UNDEFINED_ARB

GLScene.OpenGLTokens

WGL_SWAP_UNDEFINED_EXT

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGL4

WGL_TEXTURE_1D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_2D_ARB

GLScene.OpenGL4

WGL_TEXTURE_2D_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGL4

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_DEPTH_COMPONENT_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGBA_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RGB_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_RG_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGL4

WGL_TEXTURE_FLOAT_R_NV

GLScene.OpenGLTokens

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGL4

WGL_TEXTURE_FORMAT_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RECTANGLE_NV

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_RGB_ARB

GLScene.OpenGL4

WGL_TEXTURE_RGB_ARB

GLScene.OpenGLTokens

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGL4

WGL_TEXTURE_TARGET_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ALPHA_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_BLUE_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_EXT

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_GREEN_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_INDEX_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGL4

WGL_TRANSPARENT_RED_VALUE_ARB

GLScene.OpenGLTokens

WGL_TRANSPARENT_VALUE_EXT

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGL4

WGL_TYPE_COLORINDEX_ARB

GLScene.OpenGLTokens

WGL_TYPE_COLORINDEX_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_ARB

GLScene.OpenGLTokens

WGL_TYPE_RGBA_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ARB

GLScene.OpenGL4

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGL4

WGL_ATI_pixel_format_float

WGL_TYPE_RGBA_FLOAT_ATI

GLScene.OpenGLTokens

WGL_ATI_pixel_format_float (#278)

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGL4

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

GLScene.OpenGLTokens

WGL_UNIQUE_ID_NV

GLScene.OpenGL4

WGL_NV_video_capture

WGL_VIDEO_OUT_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_ALPHA_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_AND_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_COLOR_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_DEPTH_NV

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_1

GLScene.OpenGL4

WGL_VIDEO_OUT_FIELD_2

GLScene.OpenGL4

WGL_VIDEO_OUT_FRAME

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_1_2

GLScene.OpenGL4

WGL_VIDEO_OUT_STACKED_FIELDS_2_1

GLScene.OpenGL4

WHmgPoint

GLScene.VectorGeometry

WHmgVector

GLScene.VectorGeometry

WIN_draw_range_elements

GLScene.OpenGL4

WGL

WIN_swap_hint

GLScene.OpenGL4

WGL

WordToIntegerArray

GLScene.Utils

Copies the values of Source to Dest (converting word values to integer values)

WriteCRLFString

GLScene.Utils

Write the string and a CRLF in the stream

XCollectionEditorForm

FMxXCollectionEditor

xglAllowSecondTextureUnit

GXS.XOpenGL

Allow to use the second texture unit again.

xglBeginUpdate

GXS.XOpenGL

Defers xglMap calls execution until xglEndUpdate is met. Calls to Begin/EndUpdate may be nested.

xglDisable

GXS.XOpenGL

xglDisableClientState

GXS.XOpenGL

xglEnable

GXS.XOpenGL

Misc

xglEnableClientState

GXS.XOpenGL

xglEndUpdate

GXS.XOpenGL

Applies xglMap calls if there were any since xglBeginUpdate was invoked. Calls to Begin/EndUpdate may be nested.

xglForbidSecondTextureUnit

GXS.XOpenGL

Whenever called, 2nd texture units changes will be forbidden to . Use this function when you're using the 2nd texture unit for your own purposes and don't want to alter it.

xglGetBitWiseMapping

GXS.XOpenGL

Returns the complex mapping in bitwise form.

xglMapTexCoordMode

GXS.XOpenGL

xglMapTexCoordToArbitrary

GXS.XOpenGL

xglMapTexCoordToArbitrary

GXS.XOpenGL

TexCoord functions will define the specified texture units coordinates.

xglMapTexCoordToArbitraryAdd

GXS.XOpenGL

xglMapTexCoordToDual

GXS.XOpenGL

TexCoord functions will define the two first texture units coordinates.

xglMapTexCoordToMain

GXS.XOpenGL

TexCoord functions will define the main texture coordinates.

xglMapTexCoordToNull

GXS.XOpenGL

TexCoord functions will be ignored.

xglMapTexCoordToSecond

GXS.XOpenGL

TexCoord functions will define the second texture unit coordinates.

xglPopState

GXS.XOpenGL

Restores State from the stack.

xglPushState

GXS.XOpenGL

Saves State on the stack.

xglTexCoord2f

GXS.XOpenGL

Explicit texture coordinates specification

xglTexCoord2fv

GXS.XOpenGL

xglTexCoord3f

GXS.XOpenGL

xglTexCoord3fv

GXS.XOpenGL

xglTexCoord4f

GXS.XOpenGL

xglTexCoord4fv

GXS.XOpenGL

xglTexCoordPointer

GXS.XOpenGL

Vertex Arrays texture coordinates specification

xglTexGenf

GXS.XOpenGL

TexGen texture coordinates specification

xglTexGenfv

GXS.XOpenGL

xglTexGeni

GXS.XOpenGL

xglTexGeniv

GXS.XOpenGL

XHmgPoint

GLScene.VectorGeometry

Standard homogeneous points

XHmgVector

GLScene.VectorGeometry

Standard homogeneous vectors

XTexPoint

GLScene.VectorGeometry

TexPoints (2D space)

XVector

GLScene.VectorGeometry

standard vectors

XYHmgVector

GLScene.VectorGeometry

XYTexPoint

GLScene.VectorGeometry

XYVector

GLScene.VectorGeometry

XYZHmgVector

GLScene.VectorGeometry

XYZVector

GLScene.VectorGeometry

XYZWHmgVector

GLScene.VectorGeometry

XZHmgVector

GLScene.VectorGeometry

XZVector

GLScene.VectorGeometry

YHmgPoint

GLScene.VectorGeometry

YHmgVector

GLScene.VectorGeometry

YTexPoint

GLScene.VectorGeometry

YVector

GLScene.VectorGeometry

YZHmgVector

GLScene.VectorGeometry

YZVector

GLScene.VectorGeometry

ZHmgPoint

GLScene.VectorGeometry

ZHmgVector

GLScene.VectorGeometry

ZVector

GLScene.VectorGeometry

_WGLSWAP

GLScene.OpenGL4

_WGLSWAP

GLScene.OpenGLTokens


GXSysHelp v.2.5: Legend

Legend

Marker | Visibility
Strict Private | Strict Private
Private | Private
Strict Protected | Strict Protected
Protected | Protected
Public | Public
Published | Published
Automated | Automated
Implicit | Implicit