Fat-Free Framework: Class List

Fat-Free Framework 3.1.0 API Reference
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
o N DB |
| o N Jig |
| | o C Mapper | Flat-file DB mapper
| | \ C Session | Jig-managed session handler
| o N Mongo |
| | o C Mapper | MongoDB mapper
| | \ C Session | MongoDB-managed session handler
| o N SQL |
| | o C Mapper | SQL data mapper
| | \ C Session | SQL-managed session handler
| o C Cursor | Simple cursor implementation
| o C Jig | Flat-file DB wrapper
| o C Mongo | MongoDB wrapper
| \ C SQL | PDO wrapper
o N Web |
| o C Geo | Geo plug-in
| o C OpenID | OpenID consumer
| \ C Pingback | Pingback 1.0 protocol (client and server) implementation
o C Audit | Data validator
o C Auth | Authorization/authentication plug-in
o C Base | Base structure
o C Basket | Session-based pseudo-mapper
o C Bcrypt | Lightweight password hashing library
o C Cache | Cache engine
o C F3 | Legacy mode enabler
o C Image | Image manipulation tools
o C ISO | ISO language/country codes
o C Log | Custom logger
o C Magic | PHP magic wrapper
o C Markdown | Markdown-to-HTML converter
o C Matrix | Generic array utilities
o C Prefab | Prefab for classes with constructors and static factory methods
o C Registry | Container for singular object instances
o C Session | Cache-based session handler
o C SMTP | SMTP plug-in
o C Template | Template engine
o C Test | Unit test kit
o C UTF | Unicode string manager
o C View | View handler
\ C Web | Wrapper for various HTTP utilities
Generated on Fri Jul 5 2013 15:09:18 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: DB\Jig\Mapper Class Reference

  • DB
  • Jig
  • Mapper
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
DB\Jig\Mapper Class Reference

Flat-file DB mapper. More...

Inheritance diagram for DB\Jig\Mapper:
DB\Cursor Magic DB\Jig\Session

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
cast ($obj=NULL)
token ($str)
find ($filter=NULL, array $options=NULL, $ttl=0, $log=TRUE)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
__construct (\DB\Jig $db, $file)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$file
Data file.
$id
Document identifier.
$document =array()
Document contents.
- Public Attributes inherited from DB\Cursor
$ptr =0
Current position.
const E_Field ='Undefined field %s'

Protected Member Functions

factory ($id, $row)

Protected Attributes

$db
Flat-file DB wrapper.
- Protected Attributes inherited from DB\Cursor
$query =array()
Query results.

Detailed Description

Flat-file DB mapper.

Constructor & Destructor Documentation

DB\Jig\Mapper::__construct | ( | \DB\Jig | $db,
 |  |  | $file
 | ) |  |

Instantiate class

Returns
void
Parameters
$db | object
$file | string

Member Function Documentation

DB\Jig\Mapper::cast ( $obj = NULL)

Return fields of mapper object as an associative array

Returns
array
Parameters
$obj object
DB\Jig\Mapper::clear ( $key)

Delete field

Returns
NULL
Parameters
$key string
DB\Jig\Mapper::copyfrom ( $key)

Hydrate mapper object using hive array variable

Returns
NULL
Parameters
$key string
DB\Jig\Mapper::copyto ( $key)

Populate hive array variable with mapper fields

Returns
NULL
Parameters
$key string
DB\Jig\Mapper::count ( $filter = NULL)

Count records that match criteria

Returns
int
Parameters
$filter array
DB\Jig\Mapper::erase ( $filter = NULL)

Delete current record

Returns
bool
Parameters
$filter array
DB\Jig\Mapper::exists ( $key)

Return TRUE if field is defined

Returns
bool
Parameters
$key string
DB\Jig\Mapper::factory | ( | $id,
 |  | $row
 | ) |
protected

Convert array to mapper object

Returns
object
Parameters
$id | string
$row | array
DB\Jig\Mapper::find | ( |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0,
 |  |  | $log = TRUE
 | ) |  |

Return records that match criteria

Returns
array|FALSE
Parameters
$filter | array
$options | array
$ttl | int
$log | bool
DB\Jig\Mapper::get ( $key)

Retrieve value of field

Returns
scalar|FALSE
Parameters
$key string
DB\Jig\Mapper::insert ( )

Insert new record

Returns
array
DB\Jig\Mapper::reset ( )

Reset cursor

Returns
NULL
DB\Jig\Mapper::set | ( | $key,
 |  | $val
 | ) |

Assign value to field

Returns
scalar|FALSE
Parameters
$key | string
$val | scalar
DB\Jig\Mapper::skip ( $ofs = 1)

Return record at specified offset using criteria of previous load() call and make it active

Returns
array
Parameters
$ofs int
DB\Jig\Mapper::token ( $str)

Convert tokens in string expression to variable names

Returns
string
Parameters
$str string
DB\Jig\Mapper::update ( )

Update current record

Returns
array
The documentation for this class was generated from the following file:
  • db/jig/mapper.php


Fat-Free Framework: DB\Jig\Session Class Reference

  • DB
  • Jig
  • Session
Public Member Functions | List of all members
DB\Jig\Session Class Reference

Jig-managed session handler. More...

Inheritance diagram for DB\Jig\Session:
DB\Jig\Mapper DB\Cursor Magic

Public Member Functions

open ($path, $name)
close ()
read ($id)
write ($id, $data)
destroy ($id)
cleanup ($max)
ip ($id=NULL)
stamp ($id=NULL)
agent ($id=NULL)
__construct (\DB\Jig $db, $table='sessions')
- Public Member Functions inherited from DB\Jig\Mapper
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
cast ($obj=NULL)
token ($str)
find ($filter=NULL, array $options=NULL, $ttl=0, $log=TRUE)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
__construct (\DB\Jig $db, $file)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Additional Inherited Members

- Public Attributes inherited from DB\Jig\Mapper
$file
Data file.
$id
Document identifier.
$document =array()
Document contents.
- Protected Member Functions inherited from DB\Jig\Mapper
factory ($id, $row)
- Protected Attributes inherited from DB\Jig\Mapper
$db
Flat-file DB wrapper.

Detailed Description

Jig-managed session handler.

Constructor & Destructor Documentation

DB\Jig\Session::__construct | ( | \DB\Jig | $db,
 |  |  | $table = 'sessions'
 | ) |  |

Instantiate class

Parameters
$db | object
$table | string

Member Function Documentation

DB\Jig\Session::agent ( $id = NULL)

Return HTTP user agent associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Jig\Session::cleanup ( $max)

Garbage collector

Returns
TRUE
Parameters
$max int
DB\Jig\Session::close ( )

Close session

Returns
TRUE
DB\Jig\Session::destroy ( $id)

Destroy session

Returns
TRUE
Parameters
$id string
DB\Jig\Session::ip ( $id = NULL)

Return IP address associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Jig\Session::open | ( | $path,
 |  | $name
 | ) |

Open session

Returns
TRUE
Parameters
$path | string
$name | string
DB\Jig\Session::read ( $id)

Return session data in serialized format

Returns
string|FALSE
Parameters
$id string
DB\Jig\Session::stamp ( $id = NULL)

Return Unix timestamp associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Jig\Session::write | ( | $id,
 |  | $data
 | ) |

Write session data

Returns
TRUE
Parameters
$id | string
$data | string
The documentation for this class was generated from the following file:
  • db/jig/session.php


Fat-Free Framework: DB\Mongo\Mapper Class Reference

  • DB
  • Mongo
  • Mapper
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
DB\Mongo\Mapper Class Reference

MongoDB mapper. More...

Inheritance diagram for DB\Mongo\Mapper:
DB\Cursor Magic DB\Mongo\Session

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
cast ($obj=NULL)
select ($fields=NULL, $filter=NULL, array $options=NULL, $ttl=0)
find ($filter=NULL, array $options=NULL, $ttl=0)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
__construct (\DB\Mongo $db, $collection)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$collection
Mongo collection.
$document =array()
Mongo document.
- Public Attributes inherited from DB\Cursor
$ptr =0
Current position.
const E_Field ='Undefined field %s'

Protected Member Functions

factory ($row)

Protected Attributes

$db
MongoDB wrapper.
- Protected Attributes inherited from DB\Cursor
$query =array()
Query results.

Detailed Description

MongoDB mapper.

Constructor & Destructor Documentation

DB\Mongo\Mapper::__construct | ( | \DB\Mongo | $db,
 |  |  | $collection
 | ) |  |

Instantiate class

Returns
void
Parameters
$db | object
$collection | string

Member Function Documentation

DB\Mongo\Mapper::cast ( $obj = NULL)

Return fields of mapper object as an associative array

Returns
array
Parameters
$obj object
DB\Mongo\Mapper::clear ( $key)

Delete field

Returns
NULL
Parameters
$key string
DB\Mongo\Mapper::copyfrom ( $key)

Hydrate mapper object using hive array variable

Returns
NULL
Parameters
$key string
DB\Mongo\Mapper::copyto ( $key)

Populate hive array variable with mapper fields

Returns
NULL
Parameters
$key string
DB\Mongo\Mapper::count ( $filter = NULL)

Count records that match criteria

Returns
int
Parameters
$filter array
DB\Mongo\Mapper::erase ( $filter = NULL)

Delete current record

Returns
bool
Parameters
$filter array
DB\Mongo\Mapper::exists ( $key)

Return TRUE if field is defined

Returns
bool
Parameters
$key string
DB\Mongo\Mapper::factory ( $row)
protected

Convert array to mapper object

Returns
object
Parameters
$row array
DB\Mongo\Mapper::find | ( |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0
 | ) |  |

Return records that match criteria

Returns
array
Parameters
$filter | array
$options | array
$ttl | int
DB\Mongo\Mapper::get ( $key)

Retrieve value of field

Returns
scalar|FALSE
Parameters
$key string
DB\Mongo\Mapper::insert ( )

Insert new record

Returns
array
DB\Mongo\Mapper::reset ( )

Reset cursor

Returns
NULL
DB\Mongo\Mapper::select | ( |  | $fields = NULL,
 |  |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0
 | ) |  |

Build query and execute

Returns
array
Parameters
$fields | string
$filter | array
$options | array
$ttl | int
DB\Mongo\Mapper::set | ( | $key,
 |  | $val
 | ) |

Assign value to field

Returns
scalar|FALSE
Parameters
$key | string
$val | scalar
DB\Mongo\Mapper::skip ( $ofs = 1)

Return record at specified offset using criteria of previous load() call and make it active

Returns
array
Parameters
$ofs int
DB\Mongo\Mapper::update ( )

Update current record

Returns
array
The documentation for this class was generated from the following file:
  • db/mongo/mapper.php


Fat-Free Framework: DB\Mongo\Session Class Reference

  • DB
  • Mongo
  • Session
Public Member Functions | List of all members
DB\Mongo\Session Class Reference

MongoDB-managed session handler. More...

Inheritance diagram for DB\Mongo\Session:
DB\Mongo\Mapper DB\Cursor Magic

Public Member Functions

open ($path, $name)
close ()
read ($id)
write ($id, $data)
destroy ($id)
cleanup ($max)
ip ($id=NULL)
stamp ($id=NULL)
agent ($id=NULL)
__construct (\DB\Mongo $db, $table='sessions')
- Public Member Functions inherited from DB\Mongo\Mapper
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
cast ($obj=NULL)
select ($fields=NULL, $filter=NULL, array $options=NULL, $ttl=0)
find ($filter=NULL, array $options=NULL, $ttl=0)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
__construct (\DB\Mongo $db, $collection)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Additional Inherited Members

- Public Attributes inherited from DB\Mongo\Mapper
$collection
Mongo collection.
$document =array()
Mongo document.
- Protected Member Functions inherited from DB\Mongo\Mapper
factory ($row)
- Protected Attributes inherited from DB\Mongo\Mapper
$db
MongoDB wrapper.

Detailed Description

MongoDB-managed session handler.

Constructor & Destructor Documentation

DB\Mongo\Session::__construct | ( | \DB\Mongo | $db,
 |  |  | $table = 'sessions'
 | ) |  |

Instantiate class

Parameters
$db | object
$table | string

Member Function Documentation

DB\Mongo\Session::agent ( $id = NULL)

Return HTTP user agent associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Mongo\Session::cleanup ( $max)

Garbage collector

Returns
TRUE
Parameters
$max int
DB\Mongo\Session::close ( )

Close session

Returns
TRUE
DB\Mongo\Session::destroy ( $id)

Destroy session

Returns
TRUE
Parameters
$id string
DB\Mongo\Session::ip ( $id = NULL)

Return IP address associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Mongo\Session::open | ( | $path,
 |  | $name
 | ) |

Open session

Returns
TRUE
Parameters
$path | string
$name | string
DB\Mongo\Session::read ( $id)

Return session data in serialized format

Returns
string|FALSE
Parameters
$id string
DB\Mongo\Session::stamp ( $id = NULL)

Return Unix timestamp associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\Mongo\Session::write | ( | $id,
 |  | $data
 | ) |

Write session data

Returns
TRUE
Parameters
$id | string
$data | string
The documentation for this class was generated from the following file:
  • db/mongo/session.php


Fat-Free Framework: DB\SQL\Mapper Class Reference

  • DB
  • SQL
  • Mapper
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
DB\SQL\Mapper Class Reference

SQL data mapper. More...

Inheritance diagram for DB\SQL\Mapper:
DB\Cursor Magic DB\SQL\Session

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
type ($pdo)
value ($type, $val)
cast ($obj=NULL)
select ($fields, $filter=NULL, array $options=NULL, $ttl=0)
find ($filter=NULL, array $options=NULL, $ttl=0)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
schema ()
__construct (\DB\SQL $db, $table, $ttl=60)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$engine
Database engine.
$table
SQL table.
$_id
Last insert ID.
$fields
Defined fields.
$adhoc =array()
Adhoc fields.
const | E_Adhoc ='Unable to process ad hoc field %s'
- Public Attributes inherited from DB\Cursor
$ptr =0
Current position.
const | E_Field ='Undefined field %s'

Protected Member Functions

factory ($row)

Protected Attributes

$db
PDO wrapper.
- Protected Attributes inherited from DB\Cursor
$query =array()
Query results.

Detailed Description

SQL data mapper.

Constructor & Destructor Documentation

DB\SQL\Mapper::__construct | ( | \DB\SQL | $db,
 |  |  | $table,
 |  |  | $ttl = 60
 | ) |  |

Instantiate class

Parameters
$db | object
$table | string
$ttl | int

Member Function Documentation

DB\SQL\Mapper::cast ( $obj = NULL)

Return fields of mapper object as an associative array

Returns
array
Parameters
$obj object
DB\SQL\Mapper::clear ( $key)

Clear value of field

Returns
NULL
Parameters
$key string
DB\SQL\Mapper::copyfrom ( $key)

Hydrate mapper object using hive array variable

Returns
NULL
Parameters
$key string
DB\SQL\Mapper::copyto ( $key)

Populate hive array variable with mapper fields

Returns
NULL
Parameters
$key string
DB\SQL\Mapper::count ( $filter = NULL)

Count records that match criteria

Returns
int
Parameters
$filter string|array
DB\SQL\Mapper::erase ( $filter = NULL)

Delete current record

Returns
int
Parameters
$filter string|array
DB\SQL\Mapper::exists ( $key)

Return TRUE if field is defined

Returns
bool
Parameters
$key string
DB\SQL\Mapper::factory ( $row)
protected

Convert array to mapper object

Returns
object
Parameters
$row array
DB\SQL\Mapper::find | ( |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0
 | ) |  |

Return records that match criteria

Returns
array
Parameters
$filter | string|array
$options | array
$ttl | int
DB\SQL\Mapper::get ( $key)

Retrieve value of field

Returns
scalar
Parameters
$key string
DB\SQL\Mapper::insert ( )

Insert new record

Returns
array
DB\SQL\Mapper::reset ( )

Reset cursor

Returns
NULL
DB\SQL\Mapper::schema ( )

Return schema

Returns
array
DB\SQL\Mapper::select | ( |  | $fields,
 |  |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0
 | ) |  |

Build query string and execute

Returns
array
Parameters
$fields | string
$filter | string|array
$options | array
$ttl | int
DB\SQL\Mapper::set | ( | $key,
 |  | $val
 | ) |

Assign value to field

Returns
scalar
Parameters
$key | string
$val | scalar
DB\SQL\Mapper::skip ( $ofs = 1)

Return record at specified offset using same criteria as previous load() call and make it active

Returns
array
Parameters
$ofs int
DB\SQL\Mapper::type ( $pdo)

Get PHP type equivalent of PDO constant

Returns
string
Parameters
$pdo string
DB\SQL\Mapper::update ( )

Update current record

Returns
array
DB\SQL\Mapper::value | ( | $type,
 |  | $val
 | ) |

Cast value to PHP type

Returns
scalar
Parameters
$type | string
$val | scalar
The documentation for this class was generated from the following file:
  • db/sql/mapper.php


Fat-Free Framework: DB\SQL\Session Class Reference

  • DB
  • SQL
  • Session
Public Member Functions | List of all members
DB\SQL\Session Class Reference

SQL-managed session handler. More...

Inheritance diagram for DB\SQL\Session:
DB\SQL\Mapper DB\Cursor Magic

Public Member Functions

open ($path, $name)
close ()
read ($id)
write ($id, $data)
destroy ($id)
cleanup ($max)
ip ($id=NULL)
stamp ($id=NULL)
agent ($id=NULL)
__construct (\DB\SQL $db, $table='sessions')
- Public Member Functions inherited from DB\SQL\Mapper
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
type ($pdo)
value ($type, $val)
cast ($obj=NULL)
select ($fields, $filter=NULL, array $options=NULL, $ttl=0)
find ($filter=NULL, array $options=NULL, $ttl=0)
count ($filter=NULL)
skip ($ofs=1)
insert ()
update ()
erase ($filter=NULL)
reset ()
copyfrom ($key)
copyto ($key)
schema ()
__construct (\DB\SQL $db, $table, $ttl=60)
- Public Member Functions inherited from DB\Cursor
find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Additional Inherited Members

- Public Attributes inherited from DB\SQL\Mapper
$engine
Database engine.
$table
SQL table.
$_id
Last insert ID.
$fields
Defined fields.
$adhoc =array()
Adhoc fields.
const E_Adhoc ='Unable to process ad hoc field %s'
- Protected Member Functions inherited from DB\SQL\Mapper
factory ($row)
- Protected Attributes inherited from DB\SQL\Mapper
$db
PDO wrapper.

Detailed Description

SQL-managed session handler.

Constructor & Destructor Documentation

DB\SQL\Session::__construct | ( | \DB\SQL | $db,
 |  |  | $table = 'sessions'
 | ) |  |

Instantiate class

Parameters
$db | object
$table | string

Member Function Documentation

DB\SQL\Session::agent ( $id = NULL)

Return HTTP user agent associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\SQL\Session::cleanup ( $max)

Garbage collector

Returns
TRUE
Parameters
$max int
DB\SQL\Session::close ( )

Close session

Returns
TRUE
DB\SQL\Session::destroy ( $id)

Destroy session

Returns
TRUE
Parameters
$id string
DB\SQL\Session::ip ( $id = NULL)

Return IP address associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\SQL\Session::open | ( | $path,
 |  | $name
 | ) |

Open session

Returns
TRUE
Parameters
$path | string
$name | string
DB\SQL\Session::read ( $id)

Return session data in serialized format

Returns
string|FALSE
Parameters
$id string
DB\SQL\Session::stamp ( $id = NULL)

Return Unix timestamp associated with specified session ID

Returns
string|FALSE
Parameters
$id string
DB\SQL\Session::write | ( | $id,
 |  | $data
 | ) |

Write session data

Returns
TRUE
Parameters
$id | string
$data | string
The documentation for this class was generated from the following file:
  • db/sql/session.php


Fat-Free Framework: DB\Cursor Class Reference

  • DB
  • Cursor
Public Member Functions | Public Attributes | Protected Attributes | List of all members
DB\Cursor Class Reference

Simple cursor implementation. More...

Inheritance diagram for DB\Cursor:
Magic DB\Jig\Mapper DB\Mongo\Mapper DB\SQL\Mapper DB\Jig\Session DB\Mongo\Session DB\SQL\Session

Public Member Functions

find ($filter=NULL, array $options=NULL)
insert ()
update ()
dry ()
findone ($filter=NULL, array $options=NULL, $ttl=0)
paginate ($pos=0, $size=10, $filter=NULL, array $options=NULL)
load ($filter=NULL, array $options=NULL)
first ()
last ()
skip ($ofs=1)
next ()
prev ()
save ()
erase ()
reset ()
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$ptr =0
Current position.
const E_Field ='Undefined field %s'

Protected Attributes

$query =array()
Query results.

Detailed Description

Simple cursor implementation.

Member Function Documentation

DB\Cursor::dry ( )

Return TRUE if current cursor position is not mapped to any record

Returns
bool
DB\Cursor::erase ( )

Delete current record

Returns
int|bool
DB\Cursor::find | ( |  | $filter = NULL,
 |  | array | $options = NULL
 | ) |  |
abstract

Return records (array of mapper objects) that match criteria

Returns
array
Parameters
$filter | string|array
$options | array
DB\Cursor::findone | ( |  | $filter = NULL,
 |  | array | $options = NULL,
 |  |  | $ttl = 0
 | ) |  |

Return first record (mapper object) that matches criteria

Returns
object|FALSE
Parameters
$filter | string|array
$options | array
$ttl | int
DB\Cursor::first ( )

Map to first record in cursor

Returns
mixed
DB\Cursor::insert ( )
abstract

Insert new record

Returns
array
DB\Cursor::last ( )

Map to last record in cursor

Returns
mixed
DB\Cursor::load | ( |  | $filter = NULL,
 |  | array | $options = NULL
 | ) |  |

Map to first record that matches criteria

Returns
array|FALSE
Parameters
$filter | string|array
$options | array
DB\Cursor::next ( )

Map next record

Returns
mixed
DB\Cursor::paginate | ( |  | $pos = 0,
 |  |  | $size = 10,
 |  |  | $filter = NULL,
 |  | array | $options = NULL
 | ) |  |

Return array containing subset of records matching criteria, total number of records in superset, number of subsets available, and actual subset position

Returns
array
Parameters
$pos | int
$size | int
$filter | string|array
$options | array
DB\Cursor::prev ( )

Map previous record

Returns
mixed
DB\Cursor::reset ( )

Reset cursor

Returns
NULL
DB\Cursor::save ( )

Save mapped record

Returns
mixed
DB\Cursor::skip ( $ofs = 1)

Map to nth record relative to current cursor position

Returns
mixed
Parameters
$ofs int
DB\Cursor::update ( )
abstract

Update current record

Returns
array
The documentation for this class was generated from the following file:
  • db/cursor.php


Fat-Free Framework: DB\Jig Class Reference

  • DB
  • Jig
Public Member Functions | Public Attributes | Protected Attributes | List of all members
DB\Jig Class Reference

Flat-file DB wrapper. More...

Public Member Functions

read ($file)
write ($file, array $data=NULL)
log ()
jot ($frame)
drop ()
__construct ($dir, $format=self::FORMAT_JSON)

Public Attributes

$format
Current storage format.
$log
Jig log.
const | FORMAT_JSON =0
const | FORMAT_Serialized =1

Protected Attributes

$dir
Storage location.

Detailed Description

Flat-file DB wrapper.

Constructor & Destructor Documentation

DB\Jig::__construct | ( | $dir,
 |  | $format = self::FORMAT_JSON
 | ) |

Instantiate class

Parameters
$dir | string
$format | int

Member Function Documentation

DB\Jig::drop ( )

Clean storage

Returns
NULL
DB\Jig::jot ( $frame)

Jot down log entry

Returns
NULL
Parameters
$frame string
DB\Jig::log ( )

Return SQL profiler results

Returns
string
DB\Jig::read ( $file)

Read data from file

Returns
array
Parameters
$file string
DB\Jig::write | ( |  | $file,
 |  | array | $data = NULL
 | ) |  |

Write data to file

Returns
int
Parameters
$file | string
$data | array
The documentation for this class was generated from the following file:
  • db/jig.php


Fat-Free Framework: DB\Mongo Class Reference

  • DB
  • Mongo
Public Member Functions | List of all members
DB\Mongo Class Reference

MongoDB wrapper. More...

Inheritance diagram for DB\Mongo:

Public Member Functions

log ()
drop ()
__construct ($dsn, $dbname, array $options=NULL)

Public Attributes

const E_Profiler ='MongoDB profiler is disabled'

Detailed Description

MongoDB wrapper.

Constructor & Destructor Documentation

DB\Mongo::__construct | ( |  | $dsn,
 |  |  | $dbname,
 |  | array | $options = NULL
 | ) |  |

Instantiate class

Parameters
$dsn | string
$dbname | string
$options | array

Member Function Documentation

DB\Mongo::drop ( )

Intercept native call to re-enable profiler

Returns
int
DB\Mongo::log ( )

Return MongoDB profiler results

Returns
string
The documentation for this class was generated from the following file:
  • db/mongo.php


Fat-Free Framework: DB\SQL Class Reference

  • DB
  • SQL
Public Member Functions | Public Attributes | List of all members
DB\SQL Class Reference

PDO wrapper. More...

Inheritance diagram for DB\SQL:

Public Member Functions

begin ()
rollback ()
commit ()
type ($val)
exec ($cmds, $args=NULL, $ttl=0, $log=TRUE)
count ()
log ()
schema ($table, $ttl=0)
quote ($val, $type=\PDO::PARAM_STR)
driver ()
version ()
name ()
quotekey ($key)
__construct ($dsn, $user=NULL, $pw=NULL, array $options=NULL)

Public Attributes

$dbname
Database name.
$trans =FALSE
Transaction flag.
$rows =0
Number of rows affected by query.
$log
SQL log.

Detailed Description

PDO wrapper.

Constructor & Destructor Documentation

DB\SQL::__construct | ( |  | $dsn,
 |  |  | $user = NULL,
 |  |  | $pw = NULL,
 |  | array | $options = NULL
 | ) |  |

Instantiate class

Parameters
$dsn | string
$user | string
$pw | string
$options | array

Member Function Documentation

DB\SQL::begin ( )

Begin SQL transaction

Returns
NULL
DB\SQL::commit ( )

Commit SQL transaction

Returns
NULL
DB\SQL::count ( )

Return number of rows affected by last query

Returns
int
DB\SQL::driver ( )

Return database engine

Returns
string
DB\SQL::exec | ( | $cmds,
 |  | $args = NULL,
 |  | $ttl = 0,
 |  | $log = TRUE
 | ) |

Execute SQL statement(s)

Returns
array|int|FALSE
Parameters
$cmds | string|array
$args | string|array
$ttl | int
$log | bool
DB\SQL::log ( )

Return SQL profiler results

Returns
string
DB\SQL::name ( )

Return database name

Returns
string
DB\SQL::quote | ( | $val,
 |  | $type = \PDO::PARAM_STR
 | ) |

Quote string

Returns
string
Parameters
$val | mixed
$type | int
DB\SQL::quotekey ( $key)

Return quoted identifier name

Returns
string
Parameters
$key
DB\SQL::rollback ( )

Rollback SQL transaction

Returns
NULL
DB\SQL::schema | ( | $table,
 |  | $ttl = 0
 | ) |

Retrieve schema of SQL table

Returns
array|FALSE
Parameters
$table | string
$ttl | int
DB\SQL::type ( $val)

Map data type of argument to a PDO constant

Returns
int
Parameters
$val scalar
DB\SQL::version ( )

Return server version

Returns
string
The documentation for this class was generated from the following file:
  • db/sql.php


Fat-Free Framework: Web\Geo Class Reference

  • Web
  • Geo
Public Member Functions | List of all members
Web\Geo Class Reference

Geo plug-in. More...

Inheritance diagram for Web\Geo:
Prefab

Public Member Functions

tzinfo ($zone)
location ($ip=NULL)
weather ($latitude, $longitude)

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Geo plug-in.

Member Function Documentation

Web\Geo::location ( $ip = NULL)

Return geolocation data based on specified/auto-detected IP address

Returns
array|FALSE
Parameters
$ip string
Web\Geo::tzinfo ( $zone)

Return information about specified Unix time zone

Returns
array
Parameters
$zone string
Web\Geo::weather | ( | $latitude,
 |  | $longitude
 | ) |

Return weather data based on specified latitude/longitude

Returns
array|FALSE
Parameters
$latitude | float
$longitude | float
The documentation for this class was generated from the following file:
  • web/geo.php


Fat-Free Framework: Web\OpenID Class Reference

  • Web
  • OpenID
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Web\OpenID Class Reference

OpenID consumer. More...

Inheritance diagram for Web\OpenID:
Magic

Public Member Functions

auth ($proxy=NULL)
verified ($proxy=NULL)
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$args =array()
HTTP request parameters.
const E_EndPoint ='Unable to find OpenID provider'

Protected Member Functions

discover ($proxy)

Detailed Description

OpenID consumer.

Member Function Documentation

Web\OpenID::auth ( $proxy = NULL)

Initiate OpenID authentication sequence; Return FALSE on failure or redirect to OpenID provider URL

Returns
bool
Parameters
$proxy string
Web\OpenID::clear ( $key)

Remove OpenID request parameter

Returns
NULL
Parameters
$key
Web\OpenID::discover ( $proxy)
protected

Determine OpenID provider

Returns
string|FALSE
Parameters
$proxy string
Web\OpenID::exists ( $key)

Return TRUE if OpenID request parameter exists

Returns
bool
Parameters
$key string
Web\OpenID::get ( $key)

Return value of OpenID request parameter

Returns
mixed
Parameters
$key string
Web\OpenID::set | ( | $key,
 |  | $val
 | ) |

Bind value to OpenID request parameter

Returns
string
Parameters
$key | string
$val | string
Web\OpenID::verified ( $proxy = NULL)

Return TRUE if OpenID verification was successful

Returns
bool
Parameters
$proxy string
The documentation for this class was generated from the following file:
  • web/openid.php


Fat-Free Framework: Web\Pingback Class Reference

  • Web
  • Pingback
Public Member Functions | Protected Member Functions | List of all members
Web\Pingback Class Reference

Pingback 1.0 protocol (client and server) implementation. More...

Inheritance diagram for Web\Pingback:
Prefab

Public Member Functions

inspect ($source)
listen ($func, $path=NULL)
log ()
__construct ()

Protected Member Functions

enabled ($url)

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Pingback 1.0 protocol (client and server) implementation.

Constructor & Destructor Documentation

Web\Pingback::__construct ( )

Instantiate class

Returns
object

Member Function Documentation

Web\Pingback::enabled ( $url)
protected

Return TRUE if URL points to a pingback-enabled resource

Returns
bool
Parameters
$url
Web\Pingback::inspect ( $source)

Load local page contents, parse HTML anchor tags, find permalinks, and send XML-RPC calls to corresponding pingback servers

Returns
NULL
Parameters
$source string
Web\Pingback::listen | ( | $func,
 |  | $path = NULL
 | ) |

Receive ping, check if local page is pingback-enabled, verify source contents, and return XML-RPC response

Returns
string
Parameters
$func | callback
$path | string
Web\Pingback::log ( )

Return transaction history

Returns
string
The documentation for this class was generated from the following file:
  • web/pingback.php


Fat-Free Framework: Audit Class Reference

Public Member Functions | List of all members
Audit Class Reference

Data validator. More...

Inheritance diagram for Audit:
Prefab

Public Member Functions

url ($str)
email ($str, $mx=TRUE)
ipv4 ($addr)
ipv6 ($addr)
isprivate ($addr)
isreserved ($addr)
ispublic ($addr)
isdesktop ()
ismobile ()
isbot ()
mod10 ($id)
card ($id)
entropy ($str)

Public Attributes

const | UA_Mobile ='android|blackberry|iphone|ipod|palm|windows\s+ce'
const | UA_Desktop ='bsd|linux|os\s+[x9]|solaris|windows'
const | UA_Bot ='bot|crawl|slurp|spider'

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Data validator.

Member Function Documentation

Audit::card ( $id)

Return credit card type if number is valid

Returns
string|FALSE
Parameters
$id string
Audit::email | ( | $str,
 |  | $mx = TRUE
 | ) |

Return TRUE if string is a valid e-mail address; Check DNS MX records if specified

Returns
bool
Parameters
$str | string
$mx | boolean
Audit::entropy ( $str)

Return entropy estimate of a password (NIST 800-63)

Returns
int
Parameters
$str string
Audit::ipv4 ( $addr)

Return TRUE if string is a valid IPV4 address

Returns
bool
Parameters
$addr string
Audit::ipv6 ( $addr)

Return TRUE if string is a valid IPV6 address

Returns
bool
Parameters
$addr string
Audit::isbot ( )

Return TRUE if user agent is a Web bot

Returns
bool
Audit::isdesktop ( )

Return TRUE if user agent is a desktop browser

Returns
bool
Audit::ismobile ( )

Return TRUE if user agent is a mobile device

Returns
bool
Audit::isprivate ( $addr)

Return TRUE if IP address is within private range

Returns
bool
Parameters
$addr string
Audit::ispublic ( $addr)

Return TRUE if IP address is neither private nor reserved

Returns
bool
Parameters
$addr string
Audit::isreserved ( $addr)

Return TRUE if IP address is within reserved range

Returns
bool
Parameters
$addr string
Audit::mod10 ( $id)

Return TRUE if specified ID has a valid (Luhn) Mod-10 check digit

Returns
bool
Parameters
$id string
Audit::url ( $str)

Return TRUE if string is a valid URL

Returns
bool
Parameters
$str string
The documentation for this class was generated from the following file:
  • audit.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Auth Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Auth Class Reference

Authorization/authentication plug-in. More...

Public Member Functions

login ($id, $pw, $realm=NULL)
basic ($func=NULL, $halt=TRUE)
__construct ($storage, array $args=NULL)

Public Attributes

$mapper
Mapper object.
$args
Storage options.
const | E_LDAP ='LDAP connection failure'
const | E_SMTP ='SMTP connection failure'

Protected Member Functions

_jig ($id, $pw, $realm)
_mongo ($id, $pw, $realm)
_sql ($id, $pw, $realm)
_ldap ($id, $pw)
_smtp ($id, $pw)

Detailed Description

Authorization/authentication plug-in.

Constructor & Destructor Documentation

Auth::__construct | ( |  | $storage,
 |  | array | $args = NULL
 | ) |  |

Instantiate class

Returns
object
Parameters
$storage | string|object
$args | array

Member Function Documentation

Auth::_jig | ( | $id,
 |  | $pw,
 |  | $realm
 | ) |
protected

Jig storage handler

Returns
bool
Parameters
$id | string
$pw | string
$realm | string
Auth::_ldap | ( | $id,
 |  | $pw
 | ) |
protected

LDAP storage handler

Returns
bool
Parameters
$id | string
$pw | string
Auth::_mongo | ( | $id,
 |  | $pw,
 |  | $realm
 | ) |
protected

MongoDB storage handler

Returns
bool
Parameters
$id | string
$pw | string
$realm | string
Auth::_smtp | ( | $id,
 |  | $pw
 | ) |
protected

SMTP storage handler

Returns
bool
Parameters
$id | string
$pw | string
Auth::_sql | ( | $id,
 |  | $pw,
 |  | $realm
 | ) |
protected

SQL storage handler

Returns
bool
Parameters
$id | string
$pw | string
$realm | string
Auth::basic | ( | $func = NULL,
 |  | $halt = TRUE
 | ) |

HTTP basic auth mechanism

Returns
bool
Parameters
$func | callback
$halt | bool
Auth::login | ( | $id,
 |  | $pw,
 |  | $realm = NULL
 | ) |

Login auth mechanism

Returns
bool
Parameters
$id | string
$pw | string
$realm | string
The documentation for this class was generated from the following file:
  • auth.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Base Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Base Class Reference

Base structure. More...

Public Member Functions

sync ($key)
& ref ($key, $add=TRUE)
exists ($key)
set ($key, $val, $ttl=0)
get ($key, $args=NULL)
clear ($key)
mset (array $vars, $prefix='', $ttl=0)
hive ()
copy ($src, $dst)
concat ($key, $val)
flip ($key)
push ($key, $val)
pop ($key)
unshift ($key, $val)
shift ($key)
fixslashes ($str)
split ($str)
stringify ($arg)
csv (array $args)
camelcase ($str)
snakecase ($str)
sign ($num)
hash ($str)
base64 ($data, $mime)
encode ($str)
decode ($str)
scrub (&$var, $tags=NULL)
esc ($arg)
raw ($arg)
format ()
language ($code)
lexicon ($path)
serialize ($arg)
unserialize ($arg)
status ($code)
expire ($secs=0)
error ($code, $text='', array $trace=NULL)
mock ($pattern, array $args=NULL, array $headers=NULL, $body=NULL)
route ($pattern, $handler, $ttl=0, $kbps=0)
reroute ($uri, $permanent=FALSE)
map ($url, $class, $ttl=0, $kbps=0)
blacklisted ($ip)
run ()
call ($func, $args=NULL, $hooks='')
chain ($funcs, $args=NULL)
relay ($funcs, $args=NULL)
config ($file)
mutex ($id, $func, $args=NULL)
read ($file, $lf=FALSE)
write ($file, $data, $append=FALSE)
highlight ($text)
dump ($expr)
unload ()

Static Public Member Functions

static instance ()

Public Attributes

const | GLOBALS ='GET|POST|COOKIE|REQUEST|SESSION|FILES|SERVER|ENV'
Mapped PHP globals.
const | VERBS ='GET|HEAD|POST|PUT|PATCH|DELETE|CONNECT'
HTTP verbs.
const | MODE =0755
Default directory permissions.
const | CSS ='code.css'
Syntax highlighting stylesheet.
$init
Initial settings.
$languages
Language lookup sequence.
$locales
Equivalent Locales.
$fallback ='en'
Default fallback language.
$null =NULL
NULL reference.
const | PACKAGE ='Fat-Free Framework'
const | VERSION ='3.1.0-Dev'
const | HTTP_100 ='Continue'
const | HTTP_101 ='Switching Protocols'
const | HTTP_200 ='OK'
const | HTTP_201 ='Created'
const | HTTP_202 ='Accepted'
const | HTTP_203 ='Non-Authorative Information'
const | HTTP_204 ='No Content'
const | HTTP_205 ='Reset Content'
const | HTTP_206 ='Partial Content'
const | HTTP_300 ='Multiple Choices'
const | HTTP_301 ='Moved Permanently'
const | HTTP_302 ='Found'
const | HTTP_303 ='See Other'
const | HTTP_304 ='Not Modified'
const | HTTP_305 ='Use Proxy'
const | HTTP_307 ='Temporary Redirect'
const | HTTP_400 ='Bad Request'
const | HTTP_401 ='Unauthorized'
const | HTTP_402 ='Payment Required'
const | HTTP_403 ='Forbidden'
const | HTTP_404 ='Not Found'
const | HTTP_405 ='Method Not Allowed'
const | HTTP_406 ='Not Acceptable'
const | HTTP_407 ='Proxy Authentication Required'
const | HTTP_408 ='Request Timeout'
const | HTTP_409 ='Conflict'
const | HTTP_410 ='Gone'
const | HTTP_411 ='Length Required'
const | HTTP_412 ='Precondition Failed'
const | HTTP_413 ='Request Entity Too Large'
const | HTTP_414 ='Request-URI Too Long'
const | HTTP_415 ='Unsupported Media Type'
const | HTTP_416 ='Requested Range Not Satisfiable'
const | HTTP_417 ='Expectation Failed'
const | HTTP_500 ='Internal Server Error'
const | HTTP_501 ='Not Implemented'
const | HTTP_502 ='Bad Gateway'
const | HTTP_503 ='Service Unavailable'
const | HTTP_504 ='Gateway Timeout'
const | HTTP_505 ='HTTP Version Not Supported'
const | REQ_SYNC =1
const | REQ_AJAX =2
const | E_Pattern ='Invalid routing pattern: %s'
const | E_Fatal ='Fatal error: %s'
const | E_Open ='Unable to open %s'
const | E_Routes ='No routes specified'
const | E_Method ='Invalid method %s'
const | E_Hive ='Invalid hive key %s'

Protected Member Functions

autoload ($class)

Detailed Description

Base structure.

Member Function Documentation

Base::autoload ( $class)
protected

Namespace-aware class autoloader

Returns
mixed
Parameters
$class string
Base::base64 | ( | $data,
 |  | $mime
 | ) |

Return Base64-encoded equivalent

Returns
string
Parameters
$data | string
$mime | string
Base::blacklisted ( $ip)

Return TRUE if IPv4 address exists in DNSBL

Returns
bool
Parameters
$ip string
Base::call | ( | $func,
 |  | $args = NULL,
 |  | $hooks = ''
 | ) |

Execute callback/hooks (supports 'class->method' format)

Returns
mixed|FALSE
Parameters
$func | callback
$args | mixed
$hooks | string
Base::camelcase ( $str)

Convert snakecase string to camelcase

Returns
string
Parameters
$str string
Base::chain | ( | $funcs,
 |  | $args = NULL
 | ) |

Execute specified callbacks in succession; Apply same arguments to all callbacks

Returns
array
Parameters
$funcs | array|string
$args | mixed
Base::clear ( $key)

Unset hive key

Returns
NULL
Parameters
$key string
Base::concat | ( | $key,
 |  | $val
 | ) |

Concatenate string to hive string variable

Returns
string
Parameters
$key | string
$val | string
Base::config ( $file)

Configure framework according to .ini-style file settings

Returns
NULL
Parameters
$file string
Base::copy | ( | $src,
 |  | $dst
 | ) |

Copy contents of hive variable to another

Returns
mixed
Parameters
$src | string
$dst | string
Base::csv ( array $args)

Flatten array values and return as CSV string

Returns
string
Parameters
$args array
Base::decode ( $str)

Convert HTML entities back to characters

Returns
string
Parameters
$str string
Base::dump ( $expr)

Dump expression with syntax highlighting

Returns
NULL
Parameters
$expr mixed
Base::encode ( $str)

Convert special characters to HTML entities

Returns
string
Parameters
$str string
Base::error | ( |  | $code,
 |  |  | $text = '',
 |  | array | $trace = NULL
 | ) |  |

Log error; Execute ONERROR handler if defined, else display default error page (HTML for synchronous requests, JSON string for AJAX requests)

Returns
NULL
Parameters
$code | int
$text | string
$trace | array
Base::esc ( $arg)

Encode characters to equivalent HTML entities

Returns
string
Parameters
$arg mixed
Base::exists ( $key)

Return TRUE if hive key is not empty (or timestamp and TTL if cached)

Returns
bool
Parameters
$key string
Base::expire ( $secs = 0)

Send cache metadata to HTTP client

Returns
NULL
Parameters
$secs int
Base::fixslashes ( $str)

Convert backslashes to slashes

Returns
string
Parameters
$str string
Base::flip ( $key)

Swap keys and values of hive array variable

Returns
array
Parameters
$key string
Base::format ( )

Return locale-aware formatted string

Returns
string
Base::get | ( | $key,
 |  | $args = NULL
 | ) |

Retrieve contents of hive key

Returns
mixed
Parameters
$key | string
$args | string|array
Base::hash ( $str)

Generate 64bit/base36 hash

Returns
string
Parameters
$str
Base::highlight ( $text)

Apply syntax highlighting

Returns
string
Parameters
$text string
Base::hive ( )

Publish hive contents

Returns
array
static Base::instance ( )
static

Return class instance

Returns
object
Base::language ( $code)

Assign/auto-detect language

Returns
string
Parameters
$code string
Base::lexicon ( $path)

Transfer lexicon entries to hive

Returns
NULL
Parameters
$path string
Base::map | ( | $url,
 |  | $class,
 |  | $ttl = 0,
 |  | $kbps = 0
 | ) |

Provide ReST interface by mapping HTTP verb to class method

Returns
NULL
Parameters
$url | string
$class | string
$ttl | int
$kbps | int
Base::mock | ( |  | $pattern,
 |  | array | $args = NULL,
 |  | array | $headers = NULL,
 |  |  | $body = NULL
 | ) |  |

Mock HTTP request

Returns
NULL
Parameters
$pattern | string
$args | array
$headers | array
$body | string
Base::mset | ( | array | $vars,
 |  |  | $prefix = '',
 |  |  | $ttl = 0
 | ) |  |

Multi-variable assignment using associative array

Returns
NULL
Parameters
$vars | array
$prefix | string
$ttl | int
Base::mutex | ( | $id,
 |  | $func,
 |  | $args = NULL
 | ) |

Create mutex, invoke callback then drop ownership when done

Returns
mixed
Parameters
$id | string
$func | callback
$args | mixed
Base::pop ( $key)

Remove last element of hive array variable

Returns
mixed
Parameters
$key string
Base::push | ( | $key,
 |  | $val
 | ) |

Add element to the end of hive array variable

Returns
mixed
Parameters
$key | string
$val | mixed
Base::raw ( $arg)

Decode HTML entities to equivalent characters

Returns
string
Parameters
$arg mixed
Base::read | ( | $file,
 |  | $lf = FALSE
 | ) |

Read file (with option to apply Unix LF as standard line ending)

Returns
string
Parameters
$file | string
$lf | bool
& Base::ref | ( | $key,
 |  | $add = TRUE
 | ) |

Get hive key reference/contents; Add non-existent hive keys, array elements, and object properties by default

Returns
mixed
Parameters
$key | string
$add | bool
Base::relay | ( | $funcs,
 |  | $args = NULL
 | ) |

Execute specified callbacks in succession; Relay result of previous callback as argument to the next callback

Returns
array
Parameters
$funcs | array|string
$args | mixed
Base::reroute | ( | $uri,
 |  | $permanent = FALSE
 | ) |

Reroute to specified URI

Returns
NULL
Parameters
$uri | string
$permanent | bool
Base::route | ( | $pattern,
 |  | $handler,
 |  | $ttl = 0,
 |  | $kbps = 0
 | ) |

Bind handler to route pattern

Returns
NULL
Parameters
$pattern | string|array
$handler | callback
$ttl | int
$kbps | int
Base::run ( )

Match routes against incoming URI

Returns
NULL
Base::scrub | ( | & | $var,
 |  |  | $tags = NULL
 | ) |  |

Remove HTML tags (except those enumerated) and non-printable characters to mitigate XSS/code injection attacks

Returns
mixed
Parameters
$var | mixed
$tags | string
Base::serialize ( $arg)

Return string representation of PHP value

Returns
string
Parameters
$arg mixed
Base::set | ( | $key,
 |  | $val,
 |  | $ttl = 0
 | ) |

Bind value to hive key

Returns
mixed
Parameters
$key | string
$val | mixed
$ttl | int
Base::shift ( $key)

Remove first element of hive array variable

Returns
mixed
Parameters
$key string
Base::sign ( $num)

Return -1 if specified number is negative, 0 if zero, or 1 if the number is positive

Returns
int
Parameters
$num mixed
Base::snakecase ( $str)

Convert camelcase string to snakecase

Returns
string
Parameters
$str string
Base::split ( $str)

Split comma-, semi-colon, or pipe-separated string

Returns
array
Parameters
$str string
Base::status ( $code)

Send HTTP/1.1 status header; Return text equivalent of status code

Returns
string
Parameters
$code int
Base::stringify ( $arg)

Convert PHP expression/value to compressed exportable string

Returns
string
Parameters
$arg mixed
Base::sync ( $key)

Sync PHP global with corresponding hive key

Returns
array
Parameters
$key string
Base::unload ( )

Execute framework/application shutdown sequence

Returns
NULL
Base::unserialize ( $arg)

Return PHP value derived from string

Returns
string
Parameters
$arg mixed
Base::unshift | ( | $key,
 |  | $val
 | ) |

Add element to the beginning of hive array variable

Returns
mixed
Parameters
$key | string
$val | mixed
Base::write | ( | $file,
 |  | $data,
 |  | $append = FALSE
 | ) |

Exclusive file write

Returns
int|FALSE
Parameters
$file | string
$data | mixed
$append | bool
The documentation for this class was generated from the following file:
  • base.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Basket Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
Basket Class Reference

Session-based pseudo-mapper. More...

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
find ($key, $val)
load ($key, $val)
dry ()
count ()
save ()
erase ($key, $val)
reset ()
drop ()
copyfrom ($key)
copyto ($key)
checkout ()
__construct ($key='basket')

Public Attributes

$id
Current item identifier.
$item =array()
Current item contents.
const E_Field ='Undefined field %s'

Protected Attributes

$key
Session key.

Detailed Description

Session-based pseudo-mapper.

Constructor & Destructor Documentation

Basket::__construct ( $key = 'basket')

Instantiate class

Returns
void
Parameters
$key string

Member Function Documentation

Basket::checkout ( )

Check out basket contents

Returns
array
Basket::clear ( $key)

Delete field

Returns
NULL
Parameters
$key string
Basket::copyfrom ( $key)

Hydrate item using hive array variable

Returns
NULL
Parameters
$key string
Basket::copyto ( $key)

Populate hive array variable with item contents

Returns
NULL
Parameters
$key string
Basket::count ( )

Return number of items in basket

Returns
int
Basket::drop ( )

Empty basket

Returns
NULL
Basket::dry ( )

Return TRUE if current item is empty/undefined

Returns
bool
Basket::erase | ( | $key,
 |  | $val
 | ) |

Erase item matching key/value pair

Returns
bool
Parameters
$key | string
$val | mixed
Basket::exists ( $key)

Return TRUE if field is defined

Returns
bool
Parameters
$key string
Basket::find | ( | $key,
 |  | $val
 | ) |

Return item that matches key/value pair

Returns
object|FALSE
Parameters
$key | string
$val | mixed
Basket::get ( $key)

Retrieve value of field

Returns
scalar|FALSE
Parameters
$key string
Basket::load | ( | $key,
 |  | $val
 | ) |

Map current item to matching key/value pair

Returns
array
Parameters
$key | string
$val | mixed
Basket::reset ( )

Reset cursor

Returns
NULL
Basket::save ( )

Save current item

Returns
array
Basket::set | ( | $key,
 |  | $val
 | ) |

Assign value to field

Returns
scalar|FALSE
Parameters
$key | string
$val | scalar
The documentation for this class was generated from the following file:
  • basket.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Bcrypt Class Reference

Public Member Functions | List of all members
Bcrypt Class Reference

Lightweight password hashing library. More...

Inheritance diagram for Bcrypt:
Prefab

Public Member Functions

hash ($pw, $salt=NULL, $cost=10)
verify ($pw, $hash)

Public Attributes

const | E_Cost ='Invalid cost parameter'
const | E_Salt ='Invalid salt (must be at least 22 alphanumeric characters)'

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Lightweight password hashing library.

Member Function Documentation

Bcrypt::hash | ( | $pw,
 |  | $salt = NULL,
 |  | $cost = 10
 | ) |

Generate bcrypt hash of string

Returns
string|FALSE
Parameters
$pw | string
$salt | string
$cost | int
Bcrypt::verify | ( | $pw,
 |  | $hash
 | ) |

Verify password against hash using timing attack resistant approach

Returns
bool
Parameters
$pw | string
$hash | string
The documentation for this class was generated from the following file:
  • bcrypt.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Cache Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
Cache Class Reference

Cache engine. More...

Inheritance diagram for Cache:
Prefab

Public Member Functions

exists ($key, &$val=NULL)
set ($key, $val, $ttl=0)
get ($key)
clear ($key)
reset ($suffix=NULL, $lifetime=0)
load ($dsn)
__construct ($dsn=FALSE)

Public Attributes

$prefix
Prefix for cache entries.
$ref
MemCache object.

Protected Attributes

$dsn
Cache DSN.

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Cache engine.

Constructor & Destructor Documentation

Cache::__construct ( $dsn = FALSE)

Class constructor

Returns
object
Parameters
$dsn bool|string

Member Function Documentation

Cache::clear ( $key)

Delete cache entry

Returns
bool
Parameters
$key string
Cache::exists | ( |  | $key,
 |  | & | $val = NULL
 | ) |  |

Return timestamp and TTL of cache entry or FALSE if not found

Returns
float|FALSE
Parameters
$key | string
$val | mixed
Cache::get ( $key)

Retrieve value of cache entry

Returns
mixed|FALSE
Parameters
$key string
Cache::load ( $dsn)

Load/auto-detect cache backend

Returns
string
Parameters
$dsn bool|string
Cache::reset | ( | $suffix = NULL,
 |  | $lifetime = 0
 | ) |

Clear contents of cache backend

Returns
bool
Parameters
$suffix | string
$lifetime | int
Cache::set | ( | $key,
 |  | $val,
 |  | $ttl = 0
 | ) |

Store value in cache

Returns
mixed|FALSE
Parameters
$key | string
$val | mixed
$ttl | int
The documentation for this class was generated from the following file:
  • base.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: F3 Class Reference

Static Public Member Functions | Static Public Attributes | List of all members
F3 Class Reference

Legacy mode enabler. More...

Static Public Member Functions

static __callstatic ($func, array $args)

Static Public Attributes

static $fw
Framework instance.

Detailed Description

Legacy mode enabler.

Member Function Documentation

static F3::__callstatic | ( |  | $func,
 |  | array | $args
 | ) |  |
static

Forward function calls to framework

Returns
mixed
Parameters
$func | callback
$args | array
The documentation for this class was generated from the following file:
  • f3.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Image Class Reference

Public Member Functions | Public Attributes | List of all members
Image Class Reference

Image manipulation tools. More...

Public Member Functions

rgb ($color)
invert ()
brightness ($level)
contrast ($level)
grayscale ()
smooth ($level)
emboss ()
sepia ()
pixelate ($size)
blur ($selective=FALSE)
sketch ()
hflip ()
vflip ()
crop ($x1, $y1, $x2, $y2)
resize ($width, $height, $crop=TRUE, $enlarge=TRUE)
rotate ($angle)
overlay (Image $img, $align=NULL)
identicon ($str, $size=64, $blocks=4)
captcha ($font, $size=24, $len=5, $key=NULL, $path='')
width ()
height ()
render ()
dump ()
save ()
restore ($state=1)
undo ()
__construct ($file=NULL, $flag=FALSE, $path='')
__destruct ()

Public Attributes

$data
Image resource.
$flag =FALSE
Enable/disable history.
$count =0
Filter count.
const | E_Color ='Invalid color specified: %s'
const | E_Font ='CAPTCHA font not found'
const | POS_Left =1
const | POS_Center =2
const | POS_Right =4
const | POS_Top =8
const | POS_Middle =16
const | POS_Bottom =32

Detailed Description

Image manipulation tools.

Constructor & Destructor Documentation

Image::__construct | ( | $file = NULL,
 |  | $flag = FALSE,
 |  | $path = ''
 | ) |

Instantiate image

Parameters
$file | string
$flag | bool
$path | string
Image::__destruct ( )

Wrap-up

Returns
NULL

Member Function Documentation

Image::blur ( $selective = FALSE)

Blur the image using Gaussian filter

Returns
object
Parameters
$selective bool
Image::brightness ( $level)

Adjust brightness (range:-255 to 255)

Returns
object
Parameters
$level int
Image::captcha | ( | $font,
 |  | $size = 24,
 |  | $len = 5,
 |  | $key = NULL,
 |  | $path = ''
 | ) |

Generate CAPTCHA image

Returns
object|FALSE
Parameters
$font | string
$size | int
$len | int
$key | string
$path | string
Image::contrast ( $level)

Adjust contrast (range:-100 to 100)

Returns
object
Parameters
$level int
Image::crop | ( | $x1,
 |  | $y1,
 |  | $x2,
 |  | $y2
 | ) |

Crop the image

Returns
object
Parameters
$x1 | int
$y1 | int
$x2 | int
$y2 | int
Image::dump ( )

Return image as a string

Returns
string
Image::emboss ( )

Emboss the image

Returns
object
Image::grayscale ( )

Convert to grayscale

Returns
object
Image::height ( )

Return image height

Returns
int
Image::hflip ( )

Flip on horizontal axis

Returns
object
Image::identicon | ( | $str,
 |  | $size = 64,
 |  | $blocks = 4
 | ) |

Generate identicon

Returns
object
Parameters
$str | string
$size | int
$blocks | int
Image::invert ( )

Invert image

Returns
object
Image::overlay | ( | Image | $img,
 |  |  | $align = NULL
 | ) |  |

Apply an image overlay

Returns
object
Parameters
$img | object
$align | int
Image::pixelate ( $size)

Pixelate the image

Returns
object
Parameters
$size int
Image::render ( )

Send image to HTTP client

Returns
NULL
Image::resize | ( | $width,
 |  | $height,
 |  | $crop = TRUE,
 |  | $enlarge = TRUE
 | ) |

Resize image (Maintain aspect ratio); Crop relative to center if flag is enabled; Enlargement allowed if flag is enabled

Returns
object
Parameters
$width | int
$height | int
$crop | bool
$enlarge | bool
Image::restore ( $state = 1)

Revert to specified state

Returns
object
Parameters
$state int
Image::rgb ( $color)

Convert RGB hex triad to array

Returns
array|FALSE
Parameters
$color int
Image::rotate ( $angle)

Rotate image

Returns
object
Parameters
$angle int
Image::save ( )

Save current state

Returns
object
Image::sepia ( )

Apply sepia effect

Returns
object
Image::sketch ( )

Apply sketch effect

Returns
object
Image::smooth ( $level)

Adjust smoothness

Returns
object
Parameters
$level int
Image::undo ( )

Undo most recently applied filter

Returns
object
Image::vflip ( )

Flip on vertical axis

Returns
object
Image::width ( )

Return image width

Returns
int
The documentation for this class was generated from the following file:
  • image.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: ISO Class Reference

Public Member Functions | Protected Member Functions | List of all members
ISO Class Reference

ISO language/country codes. More...

Inheritance diagram for ISO:
Prefab

Public Member Functions

languages ()
countries ()

Public Attributes

const | CC_af ='Afghanistan'
const | CC_ax ='Åland Islands'
const | CC_al ='Albania'
const | CC_dz ='Algeria'
const | CC_as ='American Samoa'
const | CC_ad ='Andorra'
const | CC_ao ='Angola'
const | CC_ai ='Anguilla'
const | CC_aq ='Antarctica'
const | CC_ag ='Antigua and Barbuda'
const | CC_ar ='Argentina'
const | CC_am ='Armenia'
const | CC_aw ='Aruba'
const | CC_au ='Australia'
const | CC_at ='Austria'
const | CC_az ='Azerbaijan'
const | CC_bs ='Bahamas'
const | CC_bh ='Bahrain'
const | CC_bd ='Bangladesh'
const | CC_bb ='Barbados'
const | CC_by ='Belarus'
const | CC_be ='Belgium'
const | CC_bz ='Belize'
const | CC_bj ='Benin'
const | CC_bm ='Bermuda'
const | CC_bt ='Bhutan'
const | CC_bo ='Bolivia'
const | CC_bq ='Bonaire, Sint Eustatius and Saba'
const | CC_ba ='Bosnia and Herzegovina'
const | CC_bw ='Botswana'
const | CC_bv ='Bouvet Island'
const | CC_br ='Brazil'
const | CC_io ='British Indian Ocean Territory'
const | CC_bn ='Brunei Darussalam'
const | CC_bg ='Bulgaria'
const | CC_bf ='Burkina Faso'
const | CC_bi ='Burundi'
const | CC_kh ='Cambodia'
const | CC_cm ='Cameroon'
const | CC_ca ='Canada'
const | CC_cv ='Cape Verde'
const | CC_ky ='Cayman Islands'
const | CC_cf ='Central African Republic'
const | CC_td ='Chad'
const | CC_cl ='Chile'
const | CC_cn ='China'
const | CC_cx ='Christmas Island'
const | CC_cc ='Cocos (Keeling) Islands'
const | CC_co ='Colombia'
const | CC_km ='Comoros'
const | CC_cg ='Congo'
const | CC_cd ='Congo, The Democratic Republic of'
const | CC_ck ='Cook Islands'
const | CC_cr ='Costa Rica'
const | CC_ci ='Côte d\'ivoire'
const | CC_hr ='Croatia'
const | CC_cu ='Cuba'
const | CC_cw ='Curaçao'
const | CC_cy ='Cyprus'
const | CC_cz ='Czech Republic'
const | CC_dk ='Denmark'
const | CC_dj ='Djibouti'
const | CC_dm ='Dominica'
const | CC_do ='Dominican Republic'
const | CC_ec ='Ecuador'
const | CC_eg ='Egypt'
const | CC_sv ='El Salvador'
const | CC_gq ='Equatorial Guinea'
const | CC_er ='Eritrea'
const | CC_ee ='Estonia'
const | CC_et ='Ethiopia'
const | CC_fk ='Falkland Islands (Malvinas)'
const | CC_fo ='Faroe Islands'
const | CC_fj ='Fiji'
const | CC_fi ='Finland'
const | CC_fr ='France'
const | CC_gf ='French Guiana'
const | CC_pf ='French Polynesia'
const | CC_tf ='French Southern Territories'
const | CC_ga ='Gabon'
const | CC_gm ='Gambia'
const | CC_ge ='Georgia'
const | CC_de ='Germany'
const | CC_gh ='Ghana'
const | CC_gi ='Gibraltar'
const | CC_gr ='Greece'
const | CC_gl ='Greenland'
const | CC_gd ='Grenada'
const | CC_gp ='Guadeloupe'
const | CC_gu ='Guam'
const | CC_gt ='Guatemala'
const | CC_gg ='Guernsey'
const | CC_gn ='Guinea'
const | CC_gw ='Guinea-Bissau'
const | CC_gy ='Guyana'
const | CC_ht ='Haiti'
const | CC_hm ='Heard Island and McDonald Islands'
const | CC_va ='Holy See (Vatican City State)'
const | CC_hn ='Honduras'
const | CC_hk ='Hong Kong'
const | CC_hu ='Hungary'
const | CC_is ='Iceland'
const | CC_in ='India'
const | CC_id ='Indonesia'
const | CC_ir ='Iran, Islamic Republic of'
const | CC_iq ='Iraq'
const | CC_ie ='Ireland'
const | CC_im ='Isle of Man'
const | CC_il ='Israel'
const | CC_it ='Italy'
const | CC_jm ='Jamaica'
const | CC_jp ='Japan'
const | CC_je ='Jersey'
const | CC_jo ='Jordan'
const | CC_kz ='Kazakhstan'
const | CC_ke ='Kenya'
const | CC_ki ='Kiribati'
const | CC_kp ='Korea, Democratic People\'s Republic of'
const | CC_kr ='Korea, Republic of'
const | CC_kw ='Kuwait'
const | CC_kg ='Kyrgyzstan'
const | CC_la ='Lao People\'s Democratic Republic'
const | CC_lv ='Latvia'
const | CC_lb ='Lebanon'
const | CC_ls ='Lesotho'
const | CC_lr ='Liberia'
const | CC_ly ='Libya'
const | CC_li ='Liechtenstein'
const | CC_lt ='Lithuania'
const | CC_lu ='Luxembourg'
const | CC_mo ='Macao'
const | CC_mk ='Macedonia, The Former Yugoslav Republic of'
const | CC_mg ='Madagascar'
const | CC_mw ='Malawi'
const | CC_my ='Malaysia'
const | CC_mv ='Maldives'
const | CC_ml ='Mali'
const | CC_mt ='Malta'
const | CC_mh ='Marshall Islands'
const | CC_mq ='Martinique'
const | CC_mr ='Mauritania'
const | CC_mu ='Mauritius'
const | CC_yt ='Mayotte'
const | CC_mx ='Mexico'
const | CC_fm ='Micronesia, Federated States of'
const | CC_md ='Moldova, Republic of'
const | CC_mc ='Monaco'
const | CC_mn ='Mongolia'
const | CC_me ='Montenegro'
const | CC_ms ='Montserrat'
const | CC_ma ='Morocco'
const | CC_mz ='Mozambique'
const | CC_mm ='Myanmar'
const | CC_na ='Namibia'
const | CC_nr ='Nauru'
const | CC_np ='Nepal'
const | CC_nl ='Netherlands'
const | CC_nc ='New Caledonia'
const | CC_nz ='New Zealand'
const | CC_ni ='Nicaragua'
const | CC_ne ='Niger'
const | CC_ng ='Nigeria'
const | CC_nu ='Niue'
const | CC_nf ='Norfolk Island'
const | CC_mp ='Northern Mariana Islands'
const | CC_no ='Norway'
const | CC_om ='Oman'
const | CC_pk ='Pakistan'
const | CC_pw ='Palau'
const | CC_ps ='Palestinian Territory, Occupied'
const | CC_pa ='Panama'
const | CC_pg ='Papua New Guinea'
const | CC_py ='Paraguay'
const | CC_pe ='Peru'
const | CC_ph ='Philippines'
const | CC_pn ='Pitcairn'
const | CC_pl ='Poland'
const | CC_pt ='Portugal'
const | CC_pr ='Puerto Rico'
const | CC_qa ='Qatar'
const | CC_re ='Réunion'
const | CC_ro ='Romania'
const | CC_ru ='Russian Federation'
const | CC_rw ='Rwanda'
const | CC_bl ='Saint Barthélemy'
const | CC_sh ='Saint Helena, Ascension and Tristan da Cunha'
const | CC_kn ='Saint Kitts and Nevis'
const | CC_lc ='Saint Lucia'
const | CC_mf ='Saint Martin (French Part)'
const | CC_pm ='Saint Pierre and Miquelon'
const | CC_vc ='Saint Vincent and The Grenadines'
const | CC_ws ='Samoa'
const | CC_sm ='San Marino'
const | CC_st ='Sao Tome and Principe'
const | CC_sa ='Saudi Arabia'
const | CC_sn ='Senegal'
const | CC_rs ='Serbia'
const | CC_sc ='Seychelles'
const | CC_sl ='Sierra Leone'
const | CC_sg ='Singapore'
const | CC_sk ='Slovakia'
const | CC_sx ='Sint Maarten (Dutch Part)'
const | CC_si ='Slovenia'
const | CC_sb ='Solomon Islands'
const | CC_so ='Somalia'
const | CC_za ='South Africa'
const | CC_gs ='South Georgia and The South Sandwich Islands'
const | CC_ss ='South Sudan'
const | CC_es ='Spain'
const | CC_lk ='Sri Lanka'
const | CC_sd ='Sudan'
const | CC_sr ='Suriname'
const | CC_sj ='Svalbard and Jan Mayen'
const | CC_sz ='Swaziland'
const | CC_se ='Sweden'
const | CC_ch ='Switzerland'
const | CC_sy ='Syrian Arab Republic'
const | CC_tw ='Taiwan, Province of China'
const | CC_tj ='Tajikistan'
const | CC_tz ='Tanzania, United Republic of'
const | CC_th ='Thailand'
const | CC_tl ='Timor-Leste'
const | CC_tg ='Togo'
const | CC_tk ='Tokelau'
const | CC_to ='Tonga'
const | CC_tt ='Trinidad and Tobago'
const | CC_tn ='Tunisia'
const | CC_tr ='Turkey'
const | CC_tm ='Turkmenistan'
const | CC_tc ='Turks and Caicos Islands'
const | CC_tv ='Tuvalu'
const | CC_ug ='Uganda'
const | CC_ua ='Ukraine'
const | CC_ae ='United Arab Emirates'
const | CC_gb ='United Kingdom'
const | CC_us ='United States'
const | CC_um ='United States Minor Outlying Islands'
const | CC_uy ='Uruguay'
const | CC_uz ='Uzbekistan'
const | CC_vu ='Vanuatu'
const | CC_ve ='Venezuela'
const | CC_vn ='Viet Nam'
const | CC_vg ='Virgin Islands, British'
const | CC_vi ='Virgin Islands, U.S.'
const | CC_wf ='Wallis and Futuna'
const | CC_eh ='Western Sahara'
const | CC_ye ='Yemen'
const | CC_zm ='Zambia'
const | CC_zw ='Zimbabwe'
const | LC_af ='Afrikaans'
const | LC_am ='Amharic'
const | LC_ar ='Arabic'
const | LC_as ='Assamese'
const | LC_ba ='Bashkir'
const | LC_be ='Belarusian'
const | LC_bg ='Bulgarian'
const | LC_bn ='Bengali'
const | LC_bo ='Tibetan'
const | LC_br ='Breton'
const | LC_ca ='Catalan'
const | LC_co ='Corsican'
const | LC_cs ='Czech'
const | LC_cy ='Welsh'
const | LC_da ='Danish'
const | LC_de ='German'
const | LC_dv ='Divehi'
const | LC_el ='Greek'
const | LC_en ='English'
const | LC_es ='Spanish'
const | LC_et ='Estonian'
const | LC_eu ='Basque'
const | LC_fa ='Persian'
const | LC_fi ='Finnish'
const | LC_fo ='Faroese'
const | LC_fr ='French'
const | LC_gd ='Scottish Gaelic'
const | LC_gl ='Galician'
const | LC_gu ='Gujarati'
const | LC_he ='Hebrew'
const | LC_hi ='Hindi'
const | LC_hr ='Croatian'
const | LC_hu ='Hungarian'
const | LC_hy ='Armenian'
const | LC_id ='Indonesian'
const | LC_ig ='Igbo'
const | LC_is ='Icelandic'
const | LC_it ='Italian'
const | LC_ja ='Japanese'
const | LC_ka ='Georgian'
const | LC_kk ='Kazakh'
const | LC_km ='Khmer'
const | LC_kn ='Kannada'
const | LC_ko ='Korean'
const | LC_lb ='Luxembourgish'
const | LC_lo ='Lao'
const | LC_lt ='Lithuanian'
const | LC_lv ='Latvian'
const | LC_mi ='Maori'
const | LC_ml ='Malayalam'
const | LC_mr ='Marathi'
const | LC_ms ='Malay'
const | LC_mt ='Maltese'
const | LC_ne ='Nepali'
const | LC_nl ='Dutch'
const | LC_no ='Norwegian'
const | LC_oc ='Occitan'
const | LC_or ='Oriya'
const | LC_pl ='Polish'
const | LC_ps ='Pashto'
const | LC_pt ='Portuguese'
const | LC_qu ='Quechua'
const | LC_ro ='Romanian'
const | LC_ru ='Russian'
const | LC_rw ='Kinyarwanda'
const | LC_sa ='Sanskrit'
const | LC_si ='Sinhala'
const | LC_sk ='Slovak'
const | LC_sl ='Slovenian'
const | LC_sq ='Albanian'
const | LC_sv ='Swedish'
const | LC_ta ='Tamil'
const | LC_te ='Telugu'
const | LC_th ='Thai'
const | LC_tk ='Turkmen'
const | LC_tr ='Turkish'
const | LC_tt ='Tatar'
const | LC_uk ='Ukrainian'
const | LC_ur ='Urdu'
const | LC_vi ='Vietnamese'
const | LC_wo ='Wolof'
const | LC_yo ='Yoruba'
const | LC_zh ='Chinese'

Protected Member Functions

constants ($prefix)

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

ISO language/country codes.

Member Function Documentation

ISO::constants ( $prefix)
protected

Convert class constants to array

Returns
array
Parameters
$prefix string
ISO::countries ( )

Return list of countries indexed by ISO 3166-1 country code

Returns
array
ISO::languages ( )

Return list of languages indexed by ISO 639-1 language code

Returns
array
The documentation for this class was generated from the following file:
  • base.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Log Class Reference

Public Member Functions | Protected Attributes | List of all members
Log Class Reference

Custom logger. More...

Public Member Functions

write ($text, $format='r')
erase ()
__construct ($file)

Protected Attributes

$file
File name.

Detailed Description

Custom logger.

Constructor & Destructor Documentation

Log::__construct ( $file)

Instantiate class

Parameters
$file string

Member Function Documentation

Log::erase ( )

Erase log

Returns
NULL
Log::write | ( | $text,
 |  | $format = 'r'
 | ) |

Write specified text to log file

Returns
string
Parameters
$text | string
$format | string
The documentation for this class was generated from the following file:
  • log.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Magic Class Reference

Public Member Functions | List of all members
Magic Class Reference

PHP magic wrapper. More...

Inheritance diagram for Magic:
DB\Cursor SMTP Web\OpenID DB\Jig\Mapper DB\Mongo\Mapper DB\SQL\Mapper DB\Jig\Session DB\Mongo\Session DB\SQL\Session

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Detailed Description

PHP magic wrapper.

Member Function Documentation

Magic::__get ( $key)

Alias for offsetget()

Returns
mixed
Parameters
$key string
Magic::__isset ( $key)

Alias for offsetexists()

Returns
mixed
Parameters
$key string
Magic::__set | ( | $key,
 |  | $val
 | ) |

Alias for offsetset()

Returns
mixed
Parameters
$key | string
$val | scalar
Magic::__unset ( $key)

Alias for offsetunset()

Returns
NULL
Parameters
$key string
Magic::clear ( $key)
abstract

Unset key

Returns
NULL
Parameters
$key string
Magic::exists ( $key)
abstract

Return TRUE if key is not empty

Returns
bool
Parameters
$key string
Magic::get ( $key)
abstract

Retrieve contents of key

Returns
mixed
Parameters
$key string
Magic::offsetexists ( $key)

Convenience method for checking property value

Returns
mixed
Parameters
$key string
Magic::offsetget ( $key)

Convenience method for retrieving property value

Returns
mixed
Parameters
$key string
Magic::offsetset | ( | $key,
 |  | $val
 | ) |

Convenience method for assigning property value

Returns
mixed
Parameters
$key | string
$val | scalar
Magic::offsetunset ( $key)

Convenience method for checking property value

Returns
NULL
Parameters
$key string
Magic::set | ( | $key,
 |  | $val
 | ) |
abstract

Bind value to key

Returns
mixed
Parameters
$key | string
$val | mixed
The documentation for this class was generated from the following file:
  • magic.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Markdown Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
Markdown Class Reference

Markdown-to-HTML converter. More...

Inheritance diagram for Markdown:
Prefab

Public Member Functions

esc ($str)
scan ($str)
convert ($txt)

Public Attributes

$special
Special characters.

Protected Member Functions

_blockquote ($str)
_pre ($str)
_fence ($hint, $str)
_hr ()
_atx ($type, $str)
_setext ($str, $type)
_li ($str)
_raw ($str)
_p ($str)
_text ($str)
_img ($str)
_a ($str)
_auto ($str)
_code ($str)
snip ($str)
build ($str)

Protected Attributes

$blocks
Parsing rules.

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Markdown-to-HTML converter.

Member Function Documentation

Markdown::_a ( $str)
protected

Process anchor span

Returns
string
Parameters
$str string
Markdown::_atx | ( | $type,
 |  | $str
 | ) |
protected

Process atx-style heading

Returns
string
Parameters
$type | string
$str | string
Markdown::_auto ( $str)
protected

Auto-convert links

Returns
string
Parameters
$str string
Markdown::_blockquote ( $str)
protected

Process blockquote

Returns
string
Parameters
$str string
Markdown::_code ( $str)
protected

Process code span

Returns
string
Parameters
$str string
Markdown::_fence | ( | $hint,
 |  | $str
 | ) |
protected

Process fenced code block

Returns
string
Parameters
$hint | string
$str | string
Markdown::_hr ( )
protected

Process horizontal rule

Returns
string
Markdown::_img ( $str)
protected

Process image span

Returns
string
Parameters
$str string
Markdown::_li ( $str)
protected

Process ordered/unordered list

Returns
string
Parameters
$str string
Markdown::_p ( $str)
protected

Process paragraph

Returns
string
Parameters
$str string
Markdown::_pre ( $str)
protected

Process whitespace-prefixed code block

Returns
string
Parameters
$str string
Markdown::_raw ( $str)
protected

Ignore raw HTML

Returns
string
Parameters
$str string
Markdown::_setext | ( | $str,
 |  | $type
 | ) |
protected

Process setext-style heading

Returns
string
Parameters
$str | string
$type | string
Markdown::_text ( $str)
protected

Process strong/em/strikethrough spans

Returns
string
Parameters
$str string
Markdown::build ( $str)
protected

Assemble blocks

Returns
string
Parameters
$str string
Markdown::convert ( $txt)

Render HTML equivalent of markdown

Returns
string
Parameters
$txt string
Markdown::esc ( $str)

Convert characters to HTML entities

Returns
string
Parameters
$str string
Markdown::scan ( $str)

Scan line for convertible spans

Returns
string
Parameters
$str string
Markdown::snip ( $str)
protected

Reduce multiple line feeds

Returns
string
Parameters
$str string
The documentation for this class was generated from the following file:
  • markdown.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Matrix Class Reference

Public Member Functions | List of all members
Matrix Class Reference

Generic array utilities. More...

Inheritance diagram for Matrix:
Prefab

Public Member Functions

pick (array $var, $col)
transpose (array &$var)
sort (array &$var, $col, $order=SORT_ASC)
changekey (array &$var, $old, $new)
calendar ($date='now', $first=0)

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Generic array utilities.

Member Function Documentation

Matrix::calendar | ( | $date = 'now',
 |  | $first = 0
 | ) |

Return month calendar of specified date, with optional setting for first day of week (0 for Sunday)

Returns
array
Parameters
$date | string
$first | int
Matrix::changekey | ( | array & | $var,
 |  |  | $old,
 |  |  | $new
 | ) |  |

Change the key of a two-dimensional array element

Returns
NULL
Parameters
$var | array
$old | string
$new | string
Matrix::pick | ( | array | $var,
 |  |  | $col
 | ) |  |

Retrieve values from a specified column of a multi-dimensional array variable

Returns
array
Parameters
$var | array
$col | mixed
Matrix::sort | ( | array & | $var,
 |  |  | $col,
 |  |  | $order = SORT_ASC
 | ) |  |

Sort a multi-dimensional array variable on a specified column

Returns
bool
Parameters
$var | array
$col | mixed
$order | int
Matrix::transpose ( array & $var)

Rotate a two-dimensional array variable

Returns
NULL
Parameters
$var array
The documentation for this class was generated from the following file:
  • matrix.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Prefab Class Reference

Static Public Member Functions | List of all members
Prefab Class Reference

Prefab for classes with constructors and static factory methods. More...

Inheritance diagram for Prefab:
Audit Bcrypt Cache ISO Markdown Matrix UTF View Web Web\Geo Web\Pingback

Static Public Member Functions

static instance ()

Detailed Description

Prefab for classes with constructors and static factory methods.

Member Function Documentation

static Prefab::instance ( )
static

Return class instance

Returns
object
The documentation for this class was generated from the following file:
  • base.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Registry Class Reference

Static Public Member Functions | List of all members
Registry Class Reference

Container for singular object instances. More...

Static Public Member Functions

static | exists ($key)
static | set ($key, $obj)
static | get ($key)
static | clear ($key)

Detailed Description

Container for singular object instances.

Member Function Documentation

static Registry::clear ( $key)
static

Delete object from catalog

Returns
NULL
Parameters
$key string
static Registry::exists ( $key)
static

Return TRUE if object exists in catalog

Returns
bool
Parameters
$key string
static Registry::get ( $key)
static

Retrieve object from catalog

Returns
object
Parameters
$key string
static Registry::set | ( | $key,
 |  | $obj
 | ) |
static

Add object to catalog

Returns
object
Parameters
$key | string
$obj | object
The documentation for this class was generated from the following file:
  • base.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Session Class Reference

Public Member Functions | List of all members
Session Class Reference

Cache-based session handler. More...

Public Member Functions

open ($path, $name)
close ()
read ($id)
write ($id, $data)
destroy ($id)
cleanup ($max)
ip ($id=NULL)
stamp ($id=NULL)
agent ($id=NULL)
__construct ()

Detailed Description

Cache-based session handler.

Constructor & Destructor Documentation

Session::__construct ( )

Instantiate class

Returns
object

Member Function Documentation

Session::agent ( $id = NULL)

Return HTTP user agent associated with specified session ID

Returns
string|FALSE
Parameters
$id string
Session::cleanup ( $max)

Garbage collector

Returns
TRUE
Parameters
$max int
Session::close ( )

Close session

Returns
TRUE
Session::destroy ( $id)

Destroy session

Returns
TRUE
Parameters
$id string
Session::ip ( $id = NULL)

Return IP address associated with specified session ID

Returns
string|FALSE
Parameters
$id string
Session::open | ( | $path,
 |  | $name
 | ) |

Open session

Returns
TRUE
Parameters
$path | string
$name | string
Session::read ( $id)

Return session data in serialized format

Returns
string|FALSE
Parameters
$id string
Session::stamp ( $id = NULL)

Return Unix timestamp associated with specified session ID

Returns
string|FALSE
Parameters
$id string
Session::write | ( | $id,
 |  | $data
 | ) |

Write session data

Returns
TRUE
Parameters
$id | string
$data | string
The documentation for this class was generated from the following file:
  • session.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: SMTP Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
SMTP Class Reference

SMTP plug-in. More...

Inheritance diagram for SMTP:
Magic

Public Member Functions

exists ($key)
set ($key, $val)
get ($key)
clear ($key)
log ()
attach ($file)
send ($message)
__construct ($host, $port, $scheme, $user, $pw)
- Public Member Functions inherited from Magic
exists ($key)
set ($key, $val)
get ($key)
clear ($key)
offsetexists ($key)
__isset ($key)
offsetset ($key, $val)
__set ($key, $val)
offsetget ($key)
__get ($key)
offsetunset ($key)
__unset ($key)

Public Attributes

$attachments
E-mail attachments.
$host
SMTP host.
$port
SMTP port.
$scheme
TLS/SSL.
$user
User ID.
$pw
Password.
$socket
TCP/IP socket.
$log
Server-client conversation.
const | E_Header ='%s: header is required'
const | E_Blank ='Message must not be blank'
const | E_Attach ='Attachment %s not found'

Protected Member Functions

fixheader ($key)
dialog ($cmd=NULL, $log=FALSE)

Detailed Description

SMTP plug-in.

Constructor & Destructor Documentation

SMTP::__construct | ( | $host,
 |  | $port,
 |  | $scheme,
 |  | $user,
 |  | $pw
 | ) |

Instantiate class

Parameters
$host | string
$port | int
$scheme | string
$user | string
$pw | string

Member Function Documentation

SMTP::attach ( $file)

Add e-mail attachment

Returns
NULL
Parameters
$file
SMTP::clear ( $key)

Remove header

Returns
NULL
Parameters
$key string
SMTP::dialog | ( | $cmd = NULL,
 |  | $log = FALSE
 | ) |
protected

Send SMTP command and record server response

Returns
NULL
Parameters
$cmd | string
$log | bool
SMTP::exists ( $key)

Return TRUE if header exists

Returns
bool
Parameters
$key
SMTP::fixheader ( $key)
protected

Fix header

Returns
string
Parameters
$key string
SMTP::get ( $key)

Return value of e-mail header

Returns
string|NULL
Parameters
$key string
SMTP::log ( )

Return client-server conversation history

Returns
string
SMTP::send ( $message)

Transmit message

Returns
bool
Parameters
$message string
SMTP::set | ( | $key,
 |  | $val
 | ) |

Bind value to e-mail header

Returns
string
Parameters
$key | string
$val | string
The documentation for this class was generated from the following file:
  • smtp.php
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Template Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
Template Class Reference

Template engine. More...

Inheritance diagram for Template:
View Prefab

Public Member Functions

token ($str)
extend ($tag, $func)
__call ($func, array $args)
render ($file, $mime='text/html', array $hive=NULL)
- Public Member Functions inherited from View
render ($file, $mime='text/html', array $hive=NULL)

Public Attributes

$tags
Template tags.
$custom =array()
Custom tag handlers.
const E_Method ='Call to undefined method %s()'
- Public Attributes inherited from View
$hive
Local hive.

Protected Member Functions

_set (array $node)
_include (array $node)
_exclude ()
_ignore (array $node)
_loop (array $node)
_repeat (array $node)
_check (array $node)
_true (array $node)
_false (array $node)
_switch (array $node)
_case (array $node)
_default (array $node)
build ($node)
- Protected Member Functions inherited from View
sandbox ()

Protected Attributes

$mime
MIME type.
- Protected Attributes inherited from View
$view
Template file.

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Template engine.

Member Function Documentation

Template::__call | ( |  | $func,
 |  | array | $args
 | ) |  |

Call custom tag handler

Returns
string|FALSE
Parameters
$func | callback
$args | array
Template::_case ( array $node)
protected

Template -case- tag handler

Returns
string
Parameters
$node array
Template::_check ( array $node)
protected

Template -check- tag handler

Returns
string
Parameters
$node array
Template::_default ( array $node)
protected

Template -default- tag handler

Returns
string
Parameters
$node array
Template::_exclude ( )
protected

Template -exclude- tag handler

Returns
string
Template::_false ( array $node)
protected

Template -false- tag handler

Returns
string
Parameters
$node array
Template::_ignore ( array $node)
protected

Template -ignore- tag handler

Returns
string
Parameters
$node array
Template::_include ( array $node)
protected

Template -include- tag handler

Returns
string
Parameters
$node array
Template::_loop ( array $node)
protected

Template -loop- tag handler

Returns
string
Parameters
$node array
Template::_repeat ( array $node)
protected

Template -repeat- tag handler

Returns
string
Parameters
$node array
Template::_set ( array $node)
protected

Template -set- tag handler

Returns
string
Parameters
$node array
Template::_switch ( array $node)
protected

Template -switch- tag handler

Returns
string
Parameters
$node array
Template::_true ( array $node)
protected

Template -true- tag handler

Returns
string
Parameters
$node array
Template::build ( $node)
protected

Assemble markup

Returns
string
Parameters
$node array|string
Template::extend | ( | $tag,
 |  | $func
 | ) |

Extend template with custom tag

Returns
NULL
Parameters
$tag | string
$func | callback
Template::render | ( |  | $file,
 |  |  | $mime = 'text/html',
 |  | array | $hive = NULL
 | ) |  |

Render template

Returns
string
Parameters
$file | string
$mime | string
$hive | array
Template::token ( $str)

Convert token to variable

Returns
string
Parameters
$str string
The documentation for this class was generated from the following file:
  • template.php


Fat-Free Framework: Test Class Reference

Public Member Functions | List of all members
Test Class Reference

Unit test kit. More...

Public Member Functions

results ()
expect ($cond, $text=NULL)
message ($text)
__construct ($level=self::FLAG_Both)

Public Attributes

const | FLAG_False =0
const | FLAG_True =1
const | FLAG_Both =2

Detailed Description

Unit test kit.

Constructor & Destructor Documentation

Test::__construct ( $level = self::FLAG_Both)

Class constructor

Returns
NULL
Parameters
$level int

Member Function Documentation

Test::expect | ( | $cond,
 |  | $text = NULL
 | ) |

Evaluate condition and save test result

Returns
NULL
Parameters
$cond | bool
$text | string
Test::message ( $text)

Append message to test results

Returns
NULL
Parameters
$text string
Test::results ( )

Return test results

Returns
array
The documentation for this class was generated from the following file:
  • test.php


Fat-Free Framework: UTF Class Reference

Public Member Functions | List of all members
UTF Class Reference

Unicode string manager. More...

Inheritance diagram for UTF:
Prefab

Public Member Functions

stripos ($stack, $needle, $ofs=0)
strlen ($str)
strpos ($stack, $needle, $ofs=0, $case=FALSE)
strripos ($stack, $needle, $ofs=0)
strrpos ($stack, $needle, $ofs=0, $case=FALSE)
stristr ($stack, $needle, $before=FALSE)
strstr ($stack, $needle, $before=FALSE, $case=FALSE)
substr ($str, $start, $len=0)
substr_count ($stack, $needle)
ltrim ($str)
rtrim ($str)
trim ($str)
bom ()

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Unicode string manager.

Member Function Documentation

UTF::bom ( )

Return UTF-8 byte order mark

Returns
string
UTF::ltrim ( $str)

Strip whitespaces from the beginning of a string

Returns
string
Parameters
$str string
UTF::rtrim ( $str)

Strip whitespaces from the end of a string

Returns
string
Parameters
$str string
UTF::stripos | ( | $stack,
 |  | $needle,
 |  | $ofs = 0
 | ) |

Find position of first occurrence of a string (case-insensitive)

Returns
int|FALSE
Parameters
$stack | string
$needle | string
$ofs | int
UTF::stristr | ( | $stack,
 |  | $needle,
 |  | $before = FALSE
 | ) |

Returns part of haystack string from the first occurrence of needle to the end of haystack (case-insensitive)

Returns
string|FALSE
Parameters
$stack | string
$needle | string
$before | bool
UTF::strlen ( $str)

Get string length

Returns
int
Parameters
$str string
UTF::strpos | ( | $stack,
 |  | $needle,
 |  | $ofs = 0,
 |  | $case = FALSE
 | ) |

Find position of first occurrence of a string

Returns
int|FALSE
Parameters
$stack | string
$needle | string
$ofs | int
$case | bool
UTF::strripos | ( | $stack,
 |  | $needle,
 |  | $ofs = 0
 | ) |

Finds position of last occurrence of a string (case-insensitive)

Returns
int|FALSE
Parameters
$stack | string
$needle | string
$ofs | int
UTF::strrpos | ( | $stack,
 |  | $needle,
 |  | $ofs = 0,
 |  | $case = FALSE
 | ) |

Find position of last occurrence of a string

Returns
int|FALSE
Parameters
$stack | string
$needle | string
$ofs | int
$case | bool
UTF::strstr | ( | $stack,
 |  | $needle,
 |  | $before = FALSE,
 |  | $case = FALSE
 | ) |

Returns part of haystack string from the first occurrence of needle to the end of haystack

Returns
string|FALSE
Parameters
$stack | string
$needle | string
$before | bool
$case | bool
UTF::substr | ( | $str,
 |  | $start,
 |  | $len = 0
 | ) |

Return part of a string

Returns
string|FALSE
Parameters
$str | string
$start | int
$len | int
UTF::substr_count | ( | $stack,
 |  | $needle
 | ) |

Count the number of substring occurrences

Returns
int
Parameters
$stack | string
$needle | string
UTF::trim ( $str)

Strip whitespaces from the beginning and end of a string

Returns
string
Parameters
$str string
The documentation for this class was generated from the following file:
  • utf.php


Fat-Free Framework: View Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
View Class Reference

View handler. More...

Inheritance diagram for View:
Prefab Template

Public Member Functions

render ($file, $mime='text/html', array $hive=NULL)

Public Attributes

$hive
Local hive.

Protected Member Functions

sandbox ()

Protected Attributes

$view
Template file.

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

View handler.

Member Function Documentation

View::render | ( |  | $file,
 |  |  | $mime = 'text/html',
 |  | array | $hive = NULL
 | ) |  |

Render template

Returns
string
Parameters
$file | string
$mime | string
$hive | array
View::sandbox ( )
protected

Create sandbox for template execution

Returns
string
The documentation for this class was generated from the following file:
  • base.php


Fat-Free Framework: Web Class Reference

Public Member Functions | Protected Member Functions | List of all members
Web Class Reference

Wrapper for various HTTP utilities. More...

Inheritance diagram for Web:
Prefab

Public Member Functions

mime ($file)
acceptable ($list=NULL)
send ($file, $mime=NULL, $kbps=0, $force=TRUE)
receive ($func=NULL, $overwrite=FALSE, $slug=TRUE)
progress ($id)
engine ($arg='socket')
subst (array &$old, $new)
request ($url, array $options=NULL)
minify ($files, $mime=NULL, $header=TRUE, $path='')
rss ($url, $max=10, $tags=NULL)
whois ($addr, $server='whois.internic.net')
slug ($text)
filler ($count=1, $max=20, $std=TRUE)

Public Attributes

const E_Request ='No suitable HTTP request engine found'

Protected Member Functions

_curl ($url, $options)
_stream ($url, $options)
_socket ($url, $options)

Additional Inherited Members

- Static Public Member Functions inherited from Prefab
static instance ()

Detailed Description

Wrapper for various HTTP utilities.

Member Function Documentation

Web::_curl | ( | $url,
 |  | $options
 | ) |
protected

HTTP request via cURL

Returns
array
Parameters
$url | string
$options | array
Web::_socket | ( | $url,
 |  | $options
 | ) |
protected

HTTP request via low-level TCP/IP socket

Returns
array
Parameters
$url | string
$options | array
Web::_stream | ( | $url,
 |  | $options
 | ) |
protected

HTTP request via PHP stream wrapper

Returns
array
Parameters
$url | string
$options | array
Web::acceptable ( $list = NULL)

Return the MIME types stated in the HTTP Accept header as an array; If a list of MIME types is specified, return the best match; or FALSE if none found

Returns
array|string|FALSE
Parameters
$list string|array
Web::engine ( $arg = 'socket')

Specify the HTTP request engine to use; If not available, fall back to an applicable substitute

Returns
string
Parameters
$arg string
Web::filler | ( | $count = 1,
 |  | $max = 20,
 |  | $std = TRUE
 | ) |

Return chunk of text from standard Lorem Ipsum passage

Returns
string
Parameters
$count | int
$max | int
$std | bool
Web::mime ( $file)

Detect MIME type using file extension

Returns
string
Parameters
$file string
Web::minify | ( | $files,
 |  | $mime = NULL,
 |  | $header = TRUE,
 |  | $path = ''
 | ) |

Strip Javascript/CSS files of extraneous whitespaces and comments; Return combined output as a minified string

Returns
string
Parameters
$files | string|array
$mime | string
$header | bool
$path | string
Web::progress ( $id)

Return upload progress in bytes, FALSE on failure

Returns
int|FALSE
Parameters
$id string
Web::receive | ( | $func = NULL,
 |  | $overwrite = FALSE,
 |  | $slug = TRUE
 | ) |

Receive file(s) from HTTP client

Returns
array|bool
Parameters
$func | callback
$overwrite | bool
$slug | bool
Web::request | ( |  | $url,
 |  | array | $options = NULL
 | ) |  |

Submit HTTP request; Use HTTP context options (described in http://www.php.net/manual/en/context.http.php) if specified; Cache the page as instructed by remote server

Returns
array|FALSE
Parameters
$url | string
$options | array
Web::rss | ( | $url,
 |  | $max = 10,
 |  | $tags = NULL
 | ) |

Retrieve RSS feed and return as an array

Returns
array|FALSE
Parameters
$url | string
$max | int
$tags | string
Web::send | ( | $file,
 |  | $mime = NULL,
 |  | $kbps = 0,
 |  | $force = TRUE
 | ) |

Transmit file to HTTP client; Return file size if successful, FALSE otherwise

Returns
int|FALSE
Parameters
$file | string
$mime | string
$kbps | int
$force | bool
Web::slug ( $text)

Return a URL/filesystem-friendly version of string

Returns
string
Parameters
$text string
Web::subst | ( | array & | $old,
 |  |  | $new
 | ) |  |

Replace old headers with new elements

Returns
NULL
Parameters
$old | array
$new | string|array
Web::whois | ( | $addr,
 |  | $server = 'whois.internic.net'
 | ) |

Retrieve information from whois server

Returns
string|FALSE
Parameters
$addr | string
$server | string
The documentation for this class was generated from the following file:
  • web.php


Fat-Free Framework: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12345]
o C ArrayAccess |
| \ C Magic | PHP magic wrapper
| o C DB\Cursor | Simple cursor implementation
| | o C DB\Jig\Mapper | Flat-file DB mapper
| | | \ C DB\Jig\Session | Jig-managed session handler
| | o C DB\Mongo\Mapper | MongoDB mapper
| | | \ C DB\Mongo\Session | MongoDB-managed session handler
| | \ C DB\SQL\Mapper | SQL data mapper
| | \ C DB\SQL\Session | SQL-managed session handler
| o C SMTP | SMTP plug-in
| \ C Web\OpenID | OpenID consumer
o C Auth | Authorization/authentication plug-in
o C Base | Base structure
o C Basket | Session-based pseudo-mapper
o C F3 | Legacy mode enabler
o C Image | Image manipulation tools
o C DB\Jig | Flat-file DB wrapper
o C Log | Custom logger
o C MongoDB |
| \ C DB\Mongo | MongoDB wrapper
o C PDO |
| \ C DB\SQL | PDO wrapper
o C Prefab | Prefab for classes with constructors and static factory methods
| o C Audit | Data validator
| o C Bcrypt | Lightweight password hashing library
| o C Cache | Cache engine
| o C ISO | ISO language/country codes
| o C Markdown | Markdown-to-HTML converter
| o C Matrix | Generic array utilities
| o C UTF | Unicode string manager
| o C View | View handler
| | \ C Template | Template engine
| o C Web | Wrapper for various HTTP utilities
| o C Web\Geo | Geo plug-in
| \ C Web\Pingback | Pingback 1.0 protocol (client and server) implementation
o C Registry | Container for singular object instances
o C Session | Cache-based session handler
\ C Test | Unit test kit


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- $ -

  • $_id : DB\SQL\Mapper
  • $adhoc : DB\SQL\Mapper
  • $args : Web\OpenID , Auth
  • $attachments : SMTP
  • $blocks : Markdown
  • $collection : DB\Mongo\Mapper
  • $count : Image
  • $custom : Template
  • $data : Image
  • $db : DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper
  • $dbname : DB\SQL
  • $dir : DB\Jig
  • $document : DB\Jig\Mapper , DB\Mongo\Mapper
  • $dsn : Cache
  • $engine : DB\SQL\Mapper
  • $fallback : Base
  • $fields : DB\SQL\Mapper
  • $file : DB\Jig\Mapper , Log
  • $flag : Image
  • $format : DB\Jig
  • $fw : F3
  • $hive : View
  • $host : SMTP
  • $id : Basket , DB\Jig\Mapper
  • $init : Base
  • $item : Basket
  • $key : Basket
  • $languages : Base
  • $locales : Base
  • $log : DB\Jig , DB\SQL , SMTP
  • $mapper : Auth
  • $mime : Template
  • $null : Base
  • $port : SMTP
  • $prefix : Cache
  • $ptr : DB\Cursor
  • $pw : SMTP
  • $query : DB\Cursor
  • $ref : Cache
  • $rows : DB\SQL
  • $scheme : SMTP
  • $socket : SMTP
  • $special : Markdown
  • $table : DB\SQL\Mapper
  • $tags : Template
  • $trans : DB\SQL
  • $user : SMTP
  • $view : View


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • __call() : Template
  • __callstatic() : F3
  • __construct() : Cache , DB\Jig , Log , Session , DB\Mongo\Mapper , SMTP , Test , Basket , DB\Mongo\Session , Web\Pingback , DB\Mongo , Auth , DB\Jig\Mapper , DB\SQL\Mapper , DB\SQL\Session , DB\Jig\Session , DB\SQL , Image
  • __destruct() : Image
  • __get() : Magic
  • __isset() : Magic
  • __set() : Magic
  • __unset() : Magic
  • _a() : Markdown
  • _atx() : Markdown
  • _auto() : Markdown
  • _blockquote() : Markdown
  • _case() : Template
  • _check() : Template
  • _code() : Markdown
  • _curl() : Web
  • _default() : Template
  • _exclude() : Template
  • _false() : Template
  • _fence() : Markdown
  • _hr() : Markdown
  • _ignore() : Template
  • _img() : Markdown
  • _include() : Template
  • _jig() : Auth
  • _ldap() : Auth
  • _li() : Markdown
  • _loop() : Template
  • _mongo() : Auth
  • _p() : Markdown
  • _pre() : Markdown
  • _raw() : Markdown
  • _repeat() : Template
  • _set() : Template
  • _setext() : Markdown
  • _smtp() : Auth
  • _socket() : Web
  • _sql() : Auth
  • _stream() : Web
  • _switch() : Template
  • _text() : Markdown
  • _true() : Template


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • acceptable() : Web
  • agent() : DB\Jig\Session , DB\SQL\Session , Session , DB\Mongo\Session
  • attach() : SMTP
  • auth() : Web\OpenID
  • autoload() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • base64() : Base
  • basic() : Auth
  • begin() : DB\SQL
  • blacklisted() : Base
  • blur() : Image
  • bom() : UTF
  • brightness() : Image
  • build() : Markdown , Template


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • calendar() : Matrix
  • call() : Base
  • camelcase() : Base
  • captcha() : Image
  • card() : Audit
  • cast() : DB\SQL\Mapper , DB\Jig\Mapper , DB\Mongo\Mapper
  • chain() : Base
  • changekey() : Matrix
  • checkout() : Basket
  • cleanup() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • clear() : Base , Cache , Registry , Basket , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Magic , SMTP , Web\OpenID
  • close() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • commit() : DB\SQL
  • concat() : Base
  • config() : Base
  • constants() : ISO
  • contrast() : Image
  • convert() : Markdown
  • copy() : Base
  • copyfrom() : DB\Mongo\Mapper , Basket , DB\Jig\Mapper , DB\SQL\Mapper
  • copyto() : DB\Jig\Mapper , DB\SQL\Mapper , DB\Mongo\Mapper , Basket
  • count() : DB\SQL , DB\Jig\Mapper , Basket , DB\Mongo\Mapper , DB\SQL\Mapper
  • countries() : ISO
  • crop() : Image
  • CSS : Base
  • csv() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • decode() : Base
  • destroy() : DB\Jig\Session , DB\SQL\Session , Session , DB\Mongo\Session
  • dialog() : SMTP
  • discover() : Web\OpenID
  • driver() : DB\SQL
  • drop() : Basket , DB\Jig , DB\Mongo
  • dry() : DB\Cursor , Basket
  • dump() : Base , Image


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • email() : Audit
  • emboss() : Image
  • enabled() : Web\Pingback
  • encode() : Base
  • engine() : Web
  • entropy() : Audit
  • erase() : DB\Cursor , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Log , Basket
  • error() : Base
  • esc() : Base , Markdown
  • exec() : DB\SQL
  • exists() : DB\Jig\Mapper , SMTP , Base , DB\SQL\Mapper , Basket , Web\OpenID , DB\Mongo\Mapper , Cache , Magic , Registry
  • expect() : Test
  • expire() : Base
  • extend() : Template


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • factory() : DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper
  • filler() : Web
  • find() : DB\Mongo\Mapper , DB\SQL\Mapper , Basket , DB\Cursor , DB\Jig\Mapper
  • findone() : DB\Cursor
  • first() : DB\Cursor
  • fixheader() : SMTP
  • fixslashes() : Base
  • flip() : Base
  • format() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • get() : Base , Cache , Basket , Web\OpenID , Magic , SMTP , DB\SQL\Mapper , DB\Mongo\Mapper , DB\Jig\Mapper , Registry
  • GLOBALS : Base
  • grayscale() : Image


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hash() : Base , Bcrypt
  • height() : Image
  • hflip() : Image
  • highlight() : Base
  • hive() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • identicon() : Image
  • insert() : DB\Cursor , DB\Mongo\Mapper , DB\SQL\Mapper , DB\Jig\Mapper
  • inspect() : Web\Pingback
  • instance() : Prefab , Base
  • invert() : Image
  • ip() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • ipv4() : Audit
  • ipv6() : Audit
  • isbot() : Audit
  • isdesktop() : Audit
  • ismobile() : Audit
  • isprivate() : Audit
  • ispublic() : Audit
  • isreserved() : Audit


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • jot() : DB\Jig


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • language() : Base
  • languages() : ISO
  • last() : DB\Cursor
  • lexicon() : Base
  • listen() : Web\Pingback
  • load() : DB\Cursor , Cache , Basket
  • location() : Web\Geo
  • log() : SMTP , DB\Mongo , DB\SQL , Web\Pingback , DB\Jig
  • login() : Auth
  • ltrim() : UTF


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • map() : Base
  • message() : Test
  • mime() : Web
  • minify() : Web
  • mock() : Base
  • mod10() : Audit
  • MODE : Base
  • mset() : Base
  • mutex() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name() : DB\SQL
  • next() : DB\Cursor


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • offsetexists() : Magic
  • offsetget() : Magic
  • offsetset() : Magic
  • offsetunset() : Magic
  • open() : DB\SQL\Session , DB\Jig\Session , Session , DB\Mongo\Session
  • overlay() : Image


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • paginate() : DB\Cursor
  • pick() : Matrix
  • pixelate() : Image
  • pop() : Base
  • prev() : DB\Cursor
  • progress() : Web
  • push() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • quote() : DB\SQL
  • quotekey() : DB\SQL


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • raw() : Base
  • read() : Base , DB\Jig , DB\Mongo\Session , DB\Jig\Session , DB\SQL\Session , Session
  • receive() : Web
  • ref() : Base
  • relay() : Base
  • render() : View , Image , Template
  • request() : Web
  • reroute() : Base
  • reset() : Cache , Basket , DB\Cursor , DB\Mongo\Mapper , DB\SQL\Mapper , DB\Jig\Mapper
  • resize() : Image
  • restore() : Image
  • results() : Test
  • rgb() : Image
  • rollback() : DB\SQL
  • rotate() : Image
  • route() : Base
  • rss() : Web
  • rtrim() : UTF
  • run() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • sandbox() : View
  • save() : Basket , Image , DB\Cursor
  • scan() : Markdown
  • schema() : DB\SQL\Mapper , DB\SQL
  • scrub() : Base
  • select() : DB\Mongo\Mapper , DB\SQL\Mapper
  • send() : SMTP , Web
  • sepia() : Image
  • serialize() : Base
  • set() : Cache , Registry , Basket , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Magic , SMTP , Web\OpenID , Base
  • shift() : Base
  • sign() : Base
  • sketch() : Image
  • skip() : DB\SQL\Mapper , DB\Cursor , DB\Jig\Mapper , DB\Mongo\Mapper
  • slug() : Web
  • smooth() : Image
  • snakecase() : Base
  • snip() : Markdown
  • sort() : Matrix
  • split() : Base
  • stamp() : DB\Mongo\Session , Session , DB\Jig\Session , DB\SQL\Session
  • status() : Base
  • stringify() : Base
  • stripos() : UTF
  • stristr() : UTF
  • strlen() : UTF
  • strpos() : UTF
  • strripos() : UTF
  • strrpos() : UTF
  • strstr() : UTF
  • subst() : Web
  • substr() : UTF
  • substr_count() : UTF
  • sync() : Base


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • token() : DB\Jig\Mapper , Template
  • transpose() : Matrix
  • trim() : UTF
  • type() : DB\SQL\Mapper , DB\SQL
  • tzinfo() : Web\Geo


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • undo() : Image
  • unload() : Base
  • unserialize() : Base
  • unshift() : Base
  • update() : DB\Mongo\Mapper , DB\Cursor , DB\SQL\Mapper , DB\Jig\Mapper
  • url() : Audit


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • value() : DB\SQL\Mapper
  • VERBS : Base
  • verified() : Web\OpenID
  • verify() : Bcrypt
  • version() : DB\SQL
  • vflip() : Image


Fat-Free Framework: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • weather() : Web\Geo
  • whois() : Web
  • width() : Image
  • write() : DB\SQL\Session , DB\Mongo\Session , DB\Jig , DB\Jig\Session , Base , Log , Session


Fat-Free Framework: Class Members - Functions

- _ -

  • __call() : Template
  • __callstatic() : F3
  • __construct() : Cache , DB\Jig , Log , Session , DB\Mongo\Mapper , SMTP , Test , Basket , DB\Mongo\Session , Web\Pingback , DB\Mongo , Auth , DB\Jig\Mapper , DB\SQL\Mapper , DB\SQL\Session , DB\Jig\Session , DB\SQL , Image
  • __destruct() : Image
  • __get() : Magic
  • __isset() : Magic
  • __set() : Magic
  • __unset() : Magic
  • _a() : Markdown
  • _atx() : Markdown
  • _auto() : Markdown
  • _blockquote() : Markdown
  • _case() : Template
  • _check() : Template
  • _code() : Markdown
  • _curl() : Web
  • _default() : Template
  • _exclude() : Template
  • _false() : Template
  • _fence() : Markdown
  • _hr() : Markdown
  • _ignore() : Template
  • _img() : Markdown
  • _include() : Template
  • _jig() : Auth
  • _ldap() : Auth
  • _li() : Markdown
  • _loop() : Template
  • _mongo() : Auth
  • _p() : Markdown
  • _pre() : Markdown
  • _raw() : Markdown
  • _repeat() : Template
  • _set() : Template
  • _setext() : Markdown
  • _smtp() : Auth
  • _socket() : Web
  • _sql() : Auth
  • _stream() : Web
  • _switch() : Template
  • _text() : Markdown
  • _true() : Template


Fat-Free Framework: Class Members - Functions

- a -

  • acceptable() : Web
  • agent() : DB\Jig\Session , DB\SQL\Session , Session , DB\Mongo\Session
  • attach() : SMTP
  • auth() : Web\OpenID
  • autoload() : Base


Fat-Free Framework: Class Members - Functions

- b -

  • base64() : Base
  • basic() : Auth
  • begin() : DB\SQL
  • blacklisted() : Base
  • blur() : Image
  • bom() : UTF
  • brightness() : Image
  • build() : Markdown , Template


Fat-Free Framework: Class Members - Functions

- c -

  • calendar() : Matrix
  • call() : Base
  • camelcase() : Base
  • captcha() : Image
  • card() : Audit
  • cast() : DB\SQL\Mapper , DB\Jig\Mapper , DB\Mongo\Mapper
  • chain() : Base
  • changekey() : Matrix
  • checkout() : Basket
  • cleanup() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • clear() : Base , Cache , Registry , Basket , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Magic , SMTP , Web\OpenID
  • close() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • commit() : DB\SQL
  • concat() : Base
  • config() : Base
  • constants() : ISO
  • contrast() : Image
  • convert() : Markdown
  • copy() : Base
  • copyfrom() : DB\Jig\Mapper , Basket , DB\SQL\Mapper , DB\Mongo\Mapper
  • copyto() : DB\Mongo\Mapper , DB\Jig\Mapper , DB\SQL\Mapper , Basket
  • count() : DB\Jig\Mapper , DB\SQL\Mapper , Basket , DB\SQL , DB\Mongo\Mapper
  • countries() : ISO
  • crop() : Image
  • csv() : Base


Fat-Free Framework: Class Members - Functions

- d -

  • decode() : Base
  • destroy() : DB\Jig\Session , DB\SQL\Session , Session , DB\Mongo\Session
  • dialog() : SMTP
  • discover() : Web\OpenID
  • driver() : DB\SQL
  • drop() : Basket , DB\Jig , DB\Mongo
  • dry() : DB\Cursor , Basket
  • dump() : Base , Image


Fat-Free Framework: Class Members - Functions

- e -

  • email() : Audit
  • emboss() : Image
  • enabled() : Web\Pingback
  • encode() : Base
  • engine() : Web
  • entropy() : Audit
  • erase() : DB\Cursor , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Log , Basket
  • error() : Base
  • esc() : Base , Markdown
  • exec() : DB\SQL
  • exists() : DB\Jig\Mapper , SMTP , Base , DB\SQL\Mapper , Basket , Web\OpenID , DB\Mongo\Mapper , Cache , Magic , Registry
  • expect() : Test
  • expire() : Base
  • extend() : Template


Fat-Free Framework: Class Members - Functions

- f -

  • factory() : DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper
  • filler() : Web
  • find() : DB\Mongo\Mapper , DB\SQL\Mapper , Basket , DB\Cursor , DB\Jig\Mapper
  • findone() : DB\Cursor
  • first() : DB\Cursor
  • fixheader() : SMTP
  • fixslashes() : Base
  • flip() : Base
  • format() : Base


Fat-Free Framework: Class Members - Functions

- g -

  • get() : Base , Cache , Web\OpenID , SMTP , Basket , DB\SQL\Mapper , DB\Mongo\Mapper , DB\Jig\Mapper , Magic , Registry
  • grayscale() : Image


Fat-Free Framework: Class Members - Functions

- h -

  • hash() : Base , Bcrypt
  • height() : Image
  • hflip() : Image
  • highlight() : Base
  • hive() : Base


Fat-Free Framework: Class Members - Functions

- i -

  • identicon() : Image
  • insert() : DB\Cursor , DB\Mongo\Mapper , DB\SQL\Mapper , DB\Jig\Mapper
  • inspect() : Web\Pingback
  • instance() : Prefab , Base
  • invert() : Image
  • ip() : DB\Jig\Session , DB\Mongo\Session , DB\SQL\Session , Session
  • ipv4() : Audit
  • ipv6() : Audit
  • isbot() : Audit
  • isdesktop() : Audit
  • ismobile() : Audit
  • isprivate() : Audit
  • ispublic() : Audit
  • isreserved() : Audit


Fat-Free Framework: Class Members - Functions

- j -

  • jot() : DB\Jig


Fat-Free Framework: Class Members - Functions

- l -

  • language() : Base
  • languages() : ISO
  • last() : DB\Cursor
  • lexicon() : Base
  • listen() : Web\Pingback
  • load() : DB\Cursor , Cache , Basket
  • location() : Web\Geo
  • log() : SMTP , DB\Mongo , DB\SQL , Web\Pingback , DB\Jig
  • login() : Auth
  • ltrim() : UTF


Fat-Free Framework: Class Members - Functions

- m -

  • map() : Base
  • message() : Test
  • mime() : Web
  • minify() : Web
  • mock() : Base
  • mod10() : Audit
  • mset() : Base
  • mutex() : Base


Fat-Free Framework: Class Members - Functions

- n -

  • name() : DB\SQL
  • next() : DB\Cursor


Fat-Free Framework: Class Members - Functions

- o -

  • offsetexists() : Magic
  • offsetget() : Magic
  • offsetset() : Magic
  • offsetunset() : Magic
  • open() : DB\SQL\Session , DB\Jig\Session , Session , DB\Mongo\Session
  • overlay() : Image


Fat-Free Framework: Class Members - Functions

- p -

  • paginate() : DB\Cursor
  • pick() : Matrix
  • pixelate() : Image
  • pop() : Base
  • prev() : DB\Cursor
  • progress() : Web
  • push() : Base


Fat-Free Framework: Class Members - Functions

- q -

  • quote() : DB\SQL
  • quotekey() : DB\SQL


Fat-Free Framework: Class Members - Functions

- r -

  • raw() : Base
  • read() : Base , DB\Jig , DB\Mongo\Session , DB\Jig\Session , DB\SQL\Session , Session
  • receive() : Web
  • ref() : Base
  • relay() : Base
  • render() : View , Image , Template
  • request() : Web
  • reroute() : Base
  • reset() : Cache , Basket , DB\Cursor , DB\Mongo\Mapper , DB\SQL\Mapper , DB\Jig\Mapper
  • resize() : Image
  • restore() : Image
  • results() : Test
  • rgb() : Image
  • rollback() : DB\SQL
  • rotate() : Image
  • route() : Base
  • rss() : Web
  • rtrim() : UTF
  • run() : Base


Fat-Free Framework: Class Members - Functions

- s -

  • sandbox() : View
  • save() : Basket , Image , DB\Cursor
  • scan() : Markdown
  • schema() : DB\SQL\Mapper , DB\SQL
  • scrub() : Base
  • select() : DB\Mongo\Mapper , DB\SQL\Mapper
  • send() : SMTP , Web
  • sepia() : Image
  • serialize() : Base
  • set() : Cache , Registry , Basket , DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper , Magic , SMTP , Web\OpenID , Base
  • shift() : Base
  • sign() : Base
  • sketch() : Image
  • skip() : DB\SQL\Mapper , DB\Cursor , DB\Jig\Mapper , DB\Mongo\Mapper
  • slug() : Web
  • smooth() : Image
  • snakecase() : Base
  • snip() : Markdown
  • sort() : Matrix
  • split() : Base
  • stamp() : DB\Mongo\Session , Session , DB\Jig\Session , DB\SQL\Session
  • status() : Base
  • stringify() : Base
  • stripos() : UTF
  • stristr() : UTF
  • strlen() : UTF
  • strpos() : UTF
  • strripos() : UTF
  • strrpos() : UTF
  • strstr() : UTF
  • subst() : Web
  • substr() : UTF
  • substr_count() : UTF
  • sync() : Base


Fat-Free Framework: Class Members - Functions

- t -

  • token() : DB\Jig\Mapper , Template
  • transpose() : Matrix
  • trim() : UTF
  • type() : DB\SQL\Mapper , DB\SQL
  • tzinfo() : Web\Geo


Fat-Free Framework: Class Members - Functions

- u -

  • undo() : Image
  • unload() : Base
  • unserialize() : Base
  • unshift() : Base
  • update() : DB\Mongo\Mapper , DB\Cursor , DB\SQL\Mapper , DB\Jig\Mapper
  • url() : Audit


Fat-Free Framework: Class Members - Functions

- v -

  • value() : DB\SQL\Mapper
  • verified() : Web\OpenID
  • verify() : Bcrypt
  • version() : DB\SQL
  • vflip() : Image


Fat-Free Framework: Class Members - Functions

- w -

  • weather() : Web\Geo
  • whois() : Web
  • width() : Image
  • write() : DB\SQL\Session , DB\Mongo\Session , DB\Jig , DB\Jig\Session , Base , Log , Session


Fat-Free Framework: Class Members - Variables

- $ -

  • $_id : DB\SQL\Mapper
  • $adhoc : DB\SQL\Mapper
  • $args : Web\OpenID , Auth
  • $attachments : SMTP
  • $blocks : Markdown
  • $collection : DB\Mongo\Mapper
  • $count : Image
  • $custom : Template
  • $data : Image
  • $db : DB\Jig\Mapper , DB\Mongo\Mapper , DB\SQL\Mapper
  • $dbname : DB\SQL
  • $dir : DB\Jig
  • $document : DB\Jig\Mapper , DB\Mongo\Mapper
  • $dsn : Cache
  • $engine : DB\SQL\Mapper
  • $fallback : Base
  • $fields : DB\SQL\Mapper
  • $file : DB\Jig\Mapper , Log
  • $flag : Image
  • $format : DB\Jig
  • $fw : F3
  • $hive : View
  • $host : SMTP
  • $id : Basket , DB\Jig\Mapper
  • $init : Base
  • $item : Basket
  • $key : Basket
  • $languages : Base
  • $locales : Base
  • $log : DB\Jig , DB\SQL , SMTP
  • $mapper : Auth
  • $mime : Template
  • $null : Base
  • $port : SMTP
  • $prefix : Cache
  • $ptr : DB\Cursor
  • $pw : SMTP
  • $query : DB\Cursor
  • $ref : Cache
  • $rows : DB\SQL
  • $scheme : SMTP
  • $socket : SMTP
  • $special : Markdown
  • $table : DB\SQL\Mapper
  • $tags : Template
  • $trans : DB\SQL
  • $user : SMTP
  • $view : View

- c -

  • CSS : Base

- g -

  • GLOBALS : Base

- m -

  • MODE : Base

- v -

  • VERBS : Base


Fat-Free Framework: Member List

Audit Member List

This is the complete list of members for Audit, including all inherited members.

card($id) | Audit |
email($str, $mx=TRUE) | Audit |
entropy($str) | Audit |
instance() | Prefab | static
ipv4($addr) | Audit |
ipv6($addr) | Audit |
isbot() | Audit |
isdesktop() | Audit |
ismobile() | Audit |
isprivate($addr) | Audit |
ispublic($addr) | Audit |
isreserved($addr) | Audit |
mod10($id) | Audit |
UA_Bot (defined in Audit) | Audit |
UA_Desktop (defined in Audit) | Audit |
UA_Mobile (defined in Audit) | Audit |
url($str) | Audit |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Auth Member List

This is the complete list of members for Auth, including all inherited members.

$args | Auth |
$mapper | Auth |
__construct($storage, array $args=NULL) | Auth |
_jig($id, $pw, $realm) | Auth | protected
_ldap($id, $pw) | Auth | protected
_mongo($id, $pw, $realm) | Auth | protected
_smtp($id, $pw) | Auth | protected
_sql($id, $pw, $realm) | Auth | protected
basic($func=NULL, $halt=TRUE) | Auth |
E_LDAP (defined in Auth) | Auth |
E_SMTP (defined in Auth) | Auth |
login($id, $pw, $realm=NULL) | Auth |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Base Member List

This is the complete list of members for Base, including all inherited members.

$fallback | Base |
$init | Base |
$languages | Base |
$locales | Base |
$null | Base |
autoload($class) | Base | protected
base64($data, $mime) | Base |
blacklisted($ip) | Base |
call($func, $args=NULL, $hooks='') | Base |
camelcase($str) | Base |
chain($funcs, $args=NULL) | Base |
clear($key) | Base |
concat($key, $val) | Base |
config($file) | Base |
copy($src, $dst) | Base |
CSS | Base |
csv(array $args) | Base |
decode($str) | Base |
dump($expr) | Base |
E_Fatal (defined in Base) | Base |
E_Hive (defined in Base) | Base |
E_Method (defined in Base) | Base |
E_Open (defined in Base) | Base |
E_Pattern (defined in Base) | Base |
E_Routes (defined in Base) | Base |
encode($str) | Base |
error($code, $text='', array $trace=NULL) | Base |
esc($arg) | Base |
exists($key) | Base |
expire($secs=0) | Base |
fixslashes($str) | Base |
flip($key) | Base |
format() | Base |
get($key, $args=NULL) | Base |
GLOBALS | Base |
hash($str) | Base |
highlight($text) | Base |
hive() | Base |
HTTP_100 (defined in Base) | Base |
HTTP_101 (defined in Base) | Base |
HTTP_200 (defined in Base) | Base |
HTTP_201 (defined in Base) | Base |
HTTP_202 (defined in Base) | Base |
HTTP_203 (defined in Base) | Base |
HTTP_204 (defined in Base) | Base |
HTTP_205 (defined in Base) | Base |
HTTP_206 (defined in Base) | Base |
HTTP_300 (defined in Base) | Base |
HTTP_301 (defined in Base) | Base |
HTTP_302 (defined in Base) | Base |
HTTP_303 (defined in Base) | Base |
HTTP_304 (defined in Base) | Base |
HTTP_305 (defined in Base) | Base |
HTTP_307 (defined in Base) | Base |
HTTP_400 (defined in Base) | Base |
HTTP_401 (defined in Base) | Base |
HTTP_402 (defined in Base) | Base |
HTTP_403 (defined in Base) | Base |
HTTP_404 (defined in Base) | Base |
HTTP_405 (defined in Base) | Base |
HTTP_406 (defined in Base) | Base |
HTTP_407 (defined in Base) | Base |
HTTP_408 (defined in Base) | Base |
HTTP_409 (defined in Base) | Base |
HTTP_410 (defined in Base) | Base |
HTTP_411 (defined in Base) | Base |
HTTP_412 (defined in Base) | Base |
HTTP_413 (defined in Base) | Base |
HTTP_414 (defined in Base) | Base |
HTTP_415 (defined in Base) | Base |
HTTP_416 (defined in Base) | Base |
HTTP_417 (defined in Base) | Base |
HTTP_500 (defined in Base) | Base |
HTTP_501 (defined in Base) | Base |
HTTP_502 (defined in Base) | Base |
HTTP_503 (defined in Base) | Base |
HTTP_504 (defined in Base) | Base |
HTTP_505 (defined in Base) | Base |
instance() | Base | static
language($code) | Base |
lexicon($path) | Base |
map($url, $class, $ttl=0, $kbps=0) | Base |
mock($pattern, array $args=NULL, array $headers=NULL, $body=NULL) | Base |
MODE | Base |
mset(array $vars, $prefix='', $ttl=0) | Base |
mutex($id, $func, $args=NULL) | Base |
PACKAGE (defined in Base) | Base |
pop($key) | Base |
push($key, $val) | Base |
raw($arg) | Base |
read($file, $lf=FALSE) | Base |
ref($key, $add=TRUE) | Base |
relay($funcs, $args=NULL) | Base |
REQ_AJAX (defined in Base) | Base |
REQ_SYNC (defined in Base) | Base |
reroute($uri, $permanent=FALSE) | Base |
route($pattern, $handler, $ttl=0, $kbps=0) | Base |
run() | Base |
scrub(&$var, $tags=NULL) | Base |
serialize($arg) | Base |
set($key, $val, $ttl=0) | Base |
shift($key) | Base |
sign($num) | Base |
snakecase($str) | Base |
split($str) | Base |
status($code) | Base |
stringify($arg) | Base |
sync($key) | Base |
unload() | Base |
unserialize($arg) | Base |
unshift($key, $val) | Base |
VERBS | Base |
VERSION (defined in Base) | Base |
write($file, $data, $append=FALSE) | Base |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Basket Member List

This is the complete list of members for Basket, including all inherited members.

$id | Basket |
$item | Basket |
$key | Basket | protected
__construct($key='basket') | Basket |
checkout() | Basket |
clear($key) | Basket |
copyfrom($key) | Basket |
copyto($key) | Basket |
count() | Basket |
drop() | Basket |
dry() | Basket |
E_Field (defined in Basket) | Basket |
erase($key, $val) | Basket |
exists($key) | Basket |
find($key, $val) | Basket |
get($key) | Basket |
load($key, $val) | Basket |
reset() | Basket |
save() | Basket |
set($key, $val) | Basket |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Bcrypt Member List

This is the complete list of members for Bcrypt, including all inherited members.

E_Cost (defined in Bcrypt) | Bcrypt |
E_Salt (defined in Bcrypt) | Bcrypt |
hash($pw, $salt=NULL, $cost=10) | Bcrypt |
instance() | Prefab | static
verify($pw, $hash) | Bcrypt |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Cache Member List

This is the complete list of members for Cache, including all inherited members.

$dsn | Cache | protected
$prefix | Cache |
$ref | Cache |
__construct($dsn=FALSE) | Cache |
clear($key) | Cache |
exists($key, &$val=NULL) | Cache |
get($key) | Cache |
instance() | Prefab | static
load($dsn) | Cache |
reset($suffix=NULL, $lifetime=0) | Cache |
set($key, $val, $ttl=0) | Cache |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

  • DB
  • Cursor
DB\Cursor Member List

This is the complete list of members for DB\Cursor, including all inherited members.

$ptr | DB\Cursor |
$query | DB\Cursor | protected
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
clear($key) | Magic |
dry() | DB\Cursor |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase() | DB\Cursor |
exists($key) | Magic |
find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | Magic |
insert() | DB\Cursor |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
reset() | DB\Cursor |
save() | DB\Cursor |
set($key, $val) | Magic |
skip($ofs=1) | DB\Cursor |
update() | DB\Cursor |


Fat-Free Framework: Member List

  • DB
  • Jig
DB\Jig Member List

This is the complete list of members for DB\Jig, including all inherited members.

$dir | DB\Jig | protected
$format | DB\Jig |
$log | DB\Jig |
__construct($dir, $format=self::FORMAT_JSON) | DB\Jig |
drop() | DB\Jig |
FORMAT_JSON (defined in DB\Jig) | DB\Jig |
FORMAT_Serialized (defined in DB\Jig) | DB\Jig |
jot($frame) | DB\Jig |
log() | DB\Jig |
read($file) | DB\Jig |
write($file, array $data=NULL) | DB\Jig |


Fat-Free Framework: Member List

  • DB
  • Jig
  • Mapper
DB\Jig\Mapper Member List

This is the complete list of members for DB\Jig\Mapper, including all inherited members.

$db | DB\Jig\Mapper | protected
$document | DB\Jig\Mapper |
$file | DB\Jig\Mapper |
$id | DB\Jig\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
__construct(\DB\Jig $db, $file) | DB\Jig\Mapper |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
cast($obj=NULL) | DB\Jig\Mapper |
clear($key) | DB\Jig\Mapper |
copyfrom($key) | DB\Jig\Mapper |
copyto($key) | DB\Jig\Mapper |
count($filter=NULL) | DB\Jig\Mapper |
dry() | DB\Cursor |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\Jig\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\Jig\Mapper |
factory($id, $row) | DB\Jig\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0, $log=TRUE) | DB\Jig\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\Jig\Mapper |
insert() | DB\Jig\Mapper |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
reset() | DB\Jig\Mapper |
save() | DB\Cursor |
set($key, $val) | DB\Jig\Mapper |
skip($ofs=1) | DB\Jig\Mapper |
token($str) | DB\Jig\Mapper |
update() | DB\Jig\Mapper |


Fat-Free Framework: Member List

  • DB
  • Jig
  • Session
DB\Jig\Session Member List

This is the complete list of members for DB\Jig\Session, including all inherited members.

$db | DB\Jig\Mapper | protected
$document | DB\Jig\Mapper |
$file | DB\Jig\Mapper |
$id | DB\Jig\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
__construct(\DB\Jig $db, $table='sessions') | DB\Jig\Session |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
agent($id=NULL) | DB\Jig\Session |
cast($obj=NULL) | DB\Jig\Mapper |
cleanup($max) | DB\Jig\Session |
clear($key) | DB\Jig\Mapper |
close() | DB\Jig\Session |
copyfrom($key) | DB\Jig\Mapper |
copyto($key) | DB\Jig\Mapper |
count($filter=NULL) | DB\Jig\Mapper |
destroy($id) | DB\Jig\Session |
dry() | DB\Cursor |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\Jig\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\Jig\Mapper |
factory($id, $row) | DB\Jig\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0, $log=TRUE) | DB\Jig\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\Jig\Mapper |
insert() | DB\Jig\Mapper |
ip($id=NULL) | DB\Jig\Session |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
open($path, $name) | DB\Jig\Session |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
read($id) | DB\Jig\Session |
reset() | DB\Jig\Mapper |
save() | DB\Cursor |
set($key, $val) | DB\Jig\Mapper |
skip($ofs=1) | DB\Jig\Mapper |
stamp($id=NULL) | DB\Jig\Session |
token($str) | DB\Jig\Mapper |
update() | DB\Jig\Mapper |
write($id, $data) | DB\Jig\Session |


Fat-Free Framework: Member List

  • DB
  • Mongo
DB\Mongo Member List

This is the complete list of members for DB\Mongo, including all inherited members.

__construct($dsn, $dbname, array $options=NULL) | DB\Mongo
drop() | DB\Mongo
E_Profiler (defined in DB\Mongo) | DB\Mongo
log() | DB\Mongo


Fat-Free Framework: Member List

  • DB
  • Mongo
  • Mapper
DB\Mongo\Mapper Member List

This is the complete list of members for DB\Mongo\Mapper, including all inherited members.

$collection | DB\Mongo\Mapper |
$db | DB\Mongo\Mapper | protected
$document | DB\Mongo\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
__construct(\DB\Mongo $db, $collection) | DB\Mongo\Mapper |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
cast($obj=NULL) | DB\Mongo\Mapper |
clear($key) | DB\Mongo\Mapper |
copyfrom($key) | DB\Mongo\Mapper |
copyto($key) | DB\Mongo\Mapper |
count($filter=NULL) | DB\Mongo\Mapper |
dry() | DB\Cursor |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\Mongo\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\Mongo\Mapper |
factory($row) | DB\Mongo\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0) | DB\Mongo\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\Mongo\Mapper |
insert() | DB\Mongo\Mapper |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
reset() | DB\Mongo\Mapper |
save() | DB\Cursor |
select($fields=NULL, $filter=NULL, array $options=NULL, $ttl=0) | DB\Mongo\Mapper |
set($key, $val) | DB\Mongo\Mapper |
skip($ofs=1) | DB\Mongo\Mapper |
update() | DB\Mongo\Mapper |


Fat-Free Framework: Member List

  • DB
  • Mongo
  • Session
DB\Mongo\Session Member List

This is the complete list of members for DB\Mongo\Session, including all inherited members.

$collection | DB\Mongo\Mapper |
$db | DB\Mongo\Mapper | protected
$document | DB\Mongo\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
__construct(\DB\Mongo $db, $table='sessions') | DB\Mongo\Session |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
agent($id=NULL) | DB\Mongo\Session |
cast($obj=NULL) | DB\Mongo\Mapper |
cleanup($max) | DB\Mongo\Session |
clear($key) | DB\Mongo\Mapper |
close() | DB\Mongo\Session |
copyfrom($key) | DB\Mongo\Mapper |
copyto($key) | DB\Mongo\Mapper |
count($filter=NULL) | DB\Mongo\Mapper |
destroy($id) | DB\Mongo\Session |
dry() | DB\Cursor |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\Mongo\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\Mongo\Mapper |
factory($row) | DB\Mongo\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0) | DB\Mongo\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\Mongo\Mapper |
insert() | DB\Mongo\Mapper |
ip($id=NULL) | DB\Mongo\Session |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
open($path, $name) | DB\Mongo\Session |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
read($id) | DB\Mongo\Session |
reset() | DB\Mongo\Mapper |
save() | DB\Cursor |
select($fields=NULL, $filter=NULL, array $options=NULL, $ttl=0) | DB\Mongo\Mapper |
set($key, $val) | DB\Mongo\Mapper |
skip($ofs=1) | DB\Mongo\Mapper |
stamp($id=NULL) | DB\Mongo\Session |
update() | DB\Mongo\Mapper |
write($id, $data) | DB\Mongo\Session |


Fat-Free Framework: Member List

  • DB
  • SQL
DB\SQL Member List

This is the complete list of members for DB\SQL, including all inherited members.

$dbname | DB\SQL
$log | DB\SQL
$rows | DB\SQL
$trans | DB\SQL
__construct($dsn, $user=NULL, $pw=NULL, array $options=NULL) | DB\SQL
begin() | DB\SQL
commit() | DB\SQL
count() | DB\SQL
driver() | DB\SQL
exec($cmds, $args=NULL, $ttl=0, $log=TRUE) | DB\SQL
log() | DB\SQL
name() | DB\SQL
quote($val, $type=\PDO::PARAM_STR) | DB\SQL
quotekey($key) | DB\SQL
rollback() | DB\SQL
schema($table, $ttl=0) | DB\SQL
type($val) | DB\SQL
version() | DB\SQL


Fat-Free Framework: Member List

  • DB
  • SQL
  • Mapper
DB\SQL\Mapper Member List

This is the complete list of members for DB\SQL\Mapper, including all inherited members.

$_id | DB\SQL\Mapper |
$adhoc | DB\SQL\Mapper |
$db | DB\SQL\Mapper | protected
$engine | DB\SQL\Mapper |
$fields | DB\SQL\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
$table | DB\SQL\Mapper |
__construct(\DB\SQL $db, $table, $ttl=60) | DB\SQL\Mapper |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
cast($obj=NULL) | DB\SQL\Mapper |
clear($key) | DB\SQL\Mapper |
copyfrom($key) | DB\SQL\Mapper |
copyto($key) | DB\SQL\Mapper |
count($filter=NULL) | DB\SQL\Mapper |
dry() | DB\Cursor |
E_Adhoc (defined in DB\SQL\Mapper) | DB\SQL\Mapper |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\SQL\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\SQL\Mapper |
factory($row) | DB\SQL\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0) | DB\SQL\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\SQL\Mapper |
insert() | DB\SQL\Mapper |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
reset() | DB\SQL\Mapper |
save() | DB\Cursor |
schema() | DB\SQL\Mapper |
select($fields, $filter=NULL, array $options=NULL, $ttl=0) | DB\SQL\Mapper |
set($key, $val) | DB\SQL\Mapper |
skip($ofs=1) | DB\SQL\Mapper |
type($pdo) | DB\SQL\Mapper |
update() | DB\SQL\Mapper |
value($type, $val) | DB\SQL\Mapper |


Fat-Free Framework: Member List

  • DB
  • SQL
  • Session
DB\SQL\Session Member List

This is the complete list of members for DB\SQL\Session, including all inherited members.

$_id | DB\SQL\Mapper |
$adhoc | DB\SQL\Mapper |
$db | DB\SQL\Mapper | protected
$engine | DB\SQL\Mapper |
$fields | DB\SQL\Mapper |
$ptr | DB\Cursor |
$query | DB\Cursor | protected
$table | DB\SQL\Mapper |
__construct(\DB\SQL $db, $table='sessions') | DB\SQL\Session |
DB::SQL::Mapper::__construct(\DB\SQL $db, $table, $ttl=60) | DB\SQL\Mapper |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
agent($id=NULL) | DB\SQL\Session |
cast($obj=NULL) | DB\SQL\Mapper |
cleanup($max) | DB\SQL\Session |
clear($key) | DB\SQL\Mapper |
close() | DB\SQL\Session |
copyfrom($key) | DB\SQL\Mapper |
copyto($key) | DB\SQL\Mapper |
count($filter=NULL) | DB\SQL\Mapper |
destroy($id) | DB\SQL\Session |
dry() | DB\Cursor |
E_Adhoc (defined in DB\SQL\Mapper) | DB\SQL\Mapper |
E_Field (defined in DB\Cursor) | DB\Cursor |
erase($filter=NULL) | DB\SQL\Mapper |
DB::Cursor::erase() | DB\Cursor |
exists($key) | DB\SQL\Mapper |
factory($row) | DB\SQL\Mapper | protected
find($filter=NULL, array $options=NULL, $ttl=0) | DB\SQL\Mapper |
DB::Cursor::find($filter=NULL, array $options=NULL) | DB\Cursor |
findone($filter=NULL, array $options=NULL, $ttl=0) | DB\Cursor |
first() | DB\Cursor |
get($key) | DB\SQL\Mapper |
insert() | DB\SQL\Mapper |
ip($id=NULL) | DB\SQL\Session |
last() | DB\Cursor |
load($filter=NULL, array $options=NULL) | DB\Cursor |
next() | DB\Cursor |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
open($path, $name) | DB\SQL\Session |
paginate($pos=0, $size=10, $filter=NULL, array $options=NULL) | DB\Cursor |
prev() | DB\Cursor |
read($id) | DB\SQL\Session |
reset() | DB\SQL\Mapper |
save() | DB\Cursor |
schema() | DB\SQL\Mapper |
select($fields, $filter=NULL, array $options=NULL, $ttl=0) | DB\SQL\Mapper |
set($key, $val) | DB\SQL\Mapper |
skip($ofs=1) | DB\SQL\Mapper |
stamp($id=NULL) | DB\SQL\Session |
type($pdo) | DB\SQL\Mapper |
update() | DB\SQL\Mapper |
value($type, $val) | DB\SQL\Mapper |
write($id, $data) | DB\SQL\Session |


Fat-Free Framework: Member List

F3 Member List

This is the complete list of members for F3, including all inherited members.

$fw | F3 | static
__callstatic($func, array $args) | F3 | static
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

ISO Member List

This is the complete list of members for ISO, including all inherited members.

CC_ad (defined in ISO) | ISO |
CC_ae (defined in ISO) | ISO |
CC_af (defined in ISO) | ISO |
CC_ag (defined in ISO) | ISO |
CC_ai (defined in ISO) | ISO |
CC_al (defined in ISO) | ISO |
CC_am (defined in ISO) | ISO |
CC_ao (defined in ISO) | ISO |
CC_aq (defined in ISO) | ISO |
CC_ar (defined in ISO) | ISO |
CC_as (defined in ISO) | ISO |
CC_at (defined in ISO) | ISO |
CC_au (defined in ISO) | ISO |
CC_aw (defined in ISO) | ISO |
CC_ax (defined in ISO) | ISO |
CC_az (defined in ISO) | ISO |
CC_ba (defined in ISO) | ISO |
CC_bb (defined in ISO) | ISO |
CC_bd (defined in ISO) | ISO |
CC_be (defined in ISO) | ISO |
CC_bf (defined in ISO) | ISO |
CC_bg (defined in ISO) | ISO |
CC_bh (defined in ISO) | ISO |
CC_bi (defined in ISO) | ISO |
CC_bj (defined in ISO) | ISO |
CC_bl (defined in ISO) | ISO |
CC_bm (defined in ISO) | ISO |
CC_bn (defined in ISO) | ISO |
CC_bo (defined in ISO) | ISO |
CC_bq (defined in ISO) | ISO |
CC_br (defined in ISO) | ISO |
CC_bs (defined in ISO) | ISO |
CC_bt (defined in ISO) | ISO |
CC_bv (defined in ISO) | ISO |
CC_bw (defined in ISO) | ISO |
CC_by (defined in ISO) | ISO |
CC_bz (defined in ISO) | ISO |
CC_ca (defined in ISO) | ISO |
CC_cc (defined in ISO) | ISO |
CC_cd (defined in ISO) | ISO |
CC_cf (defined in ISO) | ISO |
CC_cg (defined in ISO) | ISO |
CC_ch (defined in ISO) | ISO |
CC_ci (defined in ISO) | ISO |
CC_ck (defined in ISO) | ISO |
CC_cl (defined in ISO) | ISO |
CC_cm (defined in ISO) | ISO |
CC_cn (defined in ISO) | ISO |
CC_co (defined in ISO) | ISO |
CC_cr (defined in ISO) | ISO |
CC_cu (defined in ISO) | ISO |
CC_cv (defined in ISO) | ISO |
CC_cw (defined in ISO) | ISO |
CC_cx (defined in ISO) | ISO |
CC_cy (defined in ISO) | ISO |
CC_cz (defined in ISO) | ISO |
CC_de (defined in ISO) | ISO |
CC_dj (defined in ISO) | ISO |
CC_dk (defined in ISO) | ISO |
CC_dm (defined in ISO) | ISO |
CC_do (defined in ISO) | ISO |
CC_dz (defined in ISO) | ISO |
CC_ec (defined in ISO) | ISO |
CC_ee (defined in ISO) | ISO |
CC_eg (defined in ISO) | ISO |
CC_eh (defined in ISO) | ISO |
CC_er (defined in ISO) | ISO |
CC_es (defined in ISO) | ISO |
CC_et (defined in ISO) | ISO |
CC_fi (defined in ISO) | ISO |
CC_fj (defined in ISO) | ISO |
CC_fk (defined in ISO) | ISO |
CC_fm (defined in ISO) | ISO |
CC_fo (defined in ISO) | ISO |
CC_fr (defined in ISO) | ISO |
CC_ga (defined in ISO) | ISO |
CC_gb (defined in ISO) | ISO |
CC_gd (defined in ISO) | ISO |
CC_ge (defined in ISO) | ISO |
CC_gf (defined in ISO) | ISO |
CC_gg (defined in ISO) | ISO |
CC_gh (defined in ISO) | ISO |
CC_gi (defined in ISO) | ISO |
CC_gl (defined in ISO) | ISO |
CC_gm (defined in ISO) | ISO |
CC_gn (defined in ISO) | ISO |
CC_gp (defined in ISO) | ISO |
CC_gq (defined in ISO) | ISO |
CC_gr (defined in ISO) | ISO |
CC_gs (defined in ISO) | ISO |
CC_gt (defined in ISO) | ISO |
CC_gu (defined in ISO) | ISO |
CC_gw (defined in ISO) | ISO |
CC_gy (defined in ISO) | ISO |
CC_hk (defined in ISO) | ISO |
CC_hm (defined in ISO) | ISO |
CC_hn (defined in ISO) | ISO |
CC_hr (defined in ISO) | ISO |
CC_ht (defined in ISO) | ISO |
CC_hu (defined in ISO) | ISO |
CC_id (defined in ISO) | ISO |
CC_ie (defined in ISO) | ISO |
CC_il (defined in ISO) | ISO |
CC_im (defined in ISO) | ISO |
CC_in (defined in ISO) | ISO |
CC_io (defined in ISO) | ISO |
CC_iq (defined in ISO) | ISO |
CC_ir (defined in ISO) | ISO |
CC_is (defined in ISO) | ISO |
CC_it (defined in ISO) | ISO |
CC_je (defined in ISO) | ISO |
CC_jm (defined in ISO) | ISO |
CC_jo (defined in ISO) | ISO |
CC_jp (defined in ISO) | ISO |
CC_ke (defined in ISO) | ISO |
CC_kg (defined in ISO) | ISO |
CC_kh (defined in ISO) | ISO |
CC_ki (defined in ISO) | ISO |
CC_km (defined in ISO) | ISO |
CC_kn (defined in ISO) | ISO |
CC_kp (defined in ISO) | ISO |
CC_kr (defined in ISO) | ISO |
CC_kw (defined in ISO) | ISO |
CC_ky (defined in ISO) | ISO |
CC_kz (defined in ISO) | ISO |
CC_la (defined in ISO) | ISO |
CC_lb (defined in ISO) | ISO |
CC_lc (defined in ISO) | ISO |
CC_li (defined in ISO) | ISO |
CC_lk (defined in ISO) | ISO |
CC_lr (defined in ISO) | ISO |
CC_ls (defined in ISO) | ISO |
CC_lt (defined in ISO) | ISO |
CC_lu (defined in ISO) | ISO |
CC_lv (defined in ISO) | ISO |
CC_ly (defined in ISO) | ISO |
CC_ma (defined in ISO) | ISO |
CC_mc (defined in ISO) | ISO |
CC_md (defined in ISO) | ISO |
CC_me (defined in ISO) | ISO |
CC_mf (defined in ISO) | ISO |
CC_mg (defined in ISO) | ISO |
CC_mh (defined in ISO) | ISO |
CC_mk (defined in ISO) | ISO |
CC_ml (defined in ISO) | ISO |
CC_mm (defined in ISO) | ISO |
CC_mn (defined in ISO) | ISO |
CC_mo (defined in ISO) | ISO |
CC_mp (defined in ISO) | ISO |
CC_mq (defined in ISO) | ISO |
CC_mr (defined in ISO) | ISO |
CC_ms (defined in ISO) | ISO |
CC_mt (defined in ISO) | ISO |
CC_mu (defined in ISO) | ISO |
CC_mv (defined in ISO) | ISO |
CC_mw (defined in ISO) | ISO |
CC_mx (defined in ISO) | ISO |
CC_my (defined in ISO) | ISO |
CC_mz (defined in ISO) | ISO |
CC_na (defined in ISO) | ISO |
CC_nc (defined in ISO) | ISO |
CC_ne (defined in ISO) | ISO |
CC_nf (defined in ISO) | ISO |
CC_ng (defined in ISO) | ISO |
CC_ni (defined in ISO) | ISO |
CC_nl (defined in ISO) | ISO |
CC_no (defined in ISO) | ISO |
CC_np (defined in ISO) | ISO |
CC_nr (defined in ISO) | ISO |
CC_nu (defined in ISO) | ISO |
CC_nz (defined in ISO) | ISO |
CC_om (defined in ISO) | ISO |
CC_pa (defined in ISO) | ISO |
CC_pe (defined in ISO) | ISO |
CC_pf (defined in ISO) | ISO |
CC_pg (defined in ISO) | ISO |
CC_ph (defined in ISO) | ISO |
CC_pk (defined in ISO) | ISO |
CC_pl (defined in ISO) | ISO |
CC_pm (defined in ISO) | ISO |
CC_pn (defined in ISO) | ISO |
CC_pr (defined in ISO) | ISO |
CC_ps (defined in ISO) | ISO |
CC_pt (defined in ISO) | ISO |
CC_pw (defined in ISO) | ISO |
CC_py (defined in ISO) | ISO |
CC_qa (defined in ISO) | ISO |
CC_re (defined in ISO) | ISO |
CC_ro (defined in ISO) | ISO |
CC_rs (defined in ISO) | ISO |
CC_ru (defined in ISO) | ISO |
CC_rw (defined in ISO) | ISO |
CC_sa (defined in ISO) | ISO |
CC_sb (defined in ISO) | ISO |
CC_sc (defined in ISO) | ISO |
CC_sd (defined in ISO) | ISO |
CC_se (defined in ISO) | ISO |
CC_sg (defined in ISO) | ISO |
CC_sh (defined in ISO) | ISO |
CC_si (defined in ISO) | ISO |
CC_sj (defined in ISO) | ISO |
CC_sk (defined in ISO) | ISO |
CC_sl (defined in ISO) | ISO |
CC_sm (defined in ISO) | ISO |
CC_sn (defined in ISO) | ISO |
CC_so (defined in ISO) | ISO |
CC_sr (defined in ISO) | ISO |
CC_ss (defined in ISO) | ISO |
CC_st (defined in ISO) | ISO |
CC_sv (defined in ISO) | ISO |
CC_sx (defined in ISO) | ISO |
CC_sy (defined in ISO) | ISO |
CC_sz (defined in ISO) | ISO |
CC_tc (defined in ISO) | ISO |
CC_td (defined in ISO) | ISO |
CC_tf (defined in ISO) | ISO |
CC_tg (defined in ISO) | ISO |
CC_th (defined in ISO) | ISO |
CC_tj (defined in ISO) | ISO |
CC_tk (defined in ISO) | ISO |
CC_tl (defined in ISO) | ISO |
CC_tm (defined in ISO) | ISO |
CC_tn (defined in ISO) | ISO |
CC_to (defined in ISO) | ISO |
CC_tr (defined in ISO) | ISO |
CC_tt (defined in ISO) | ISO |
CC_tv (defined in ISO) | ISO |
CC_tw (defined in ISO) | ISO |
CC_tz (defined in ISO) | ISO |
CC_ua (defined in ISO) | ISO |
CC_ug (defined in ISO) | ISO |
CC_um (defined in ISO) | ISO |
CC_us (defined in ISO) | ISO |
CC_uy (defined in ISO) | ISO |
CC_uz (defined in ISO) | ISO |
CC_va (defined in ISO) | ISO |
CC_vc (defined in ISO) | ISO |
CC_ve (defined in ISO) | ISO |
CC_vg (defined in ISO) | ISO |
CC_vi (defined in ISO) | ISO |
CC_vn (defined in ISO) | ISO |
CC_vu (defined in ISO) | ISO |
CC_wf (defined in ISO) | ISO |
CC_ws (defined in ISO) | ISO |
CC_ye (defined in ISO) | ISO |
CC_yt (defined in ISO) | ISO |
CC_za (defined in ISO) | ISO |
CC_zm (defined in ISO) | ISO |
CC_zw (defined in ISO) | ISO |
constants($prefix) | ISO | protected
countries() | ISO |
instance() | Prefab | static
languages() | ISO |
LC_af (defined in ISO) | ISO |
LC_am (defined in ISO) | ISO |
LC_ar (defined in ISO) | ISO |
LC_as (defined in ISO) | ISO |
LC_ba (defined in ISO) | ISO |
LC_be (defined in ISO) | ISO |
LC_bg (defined in ISO) | ISO |
LC_bn (defined in ISO) | ISO |
LC_bo (defined in ISO) | ISO |
LC_br (defined in ISO) | ISO |
LC_ca (defined in ISO) | ISO |
LC_co (defined in ISO) | ISO |
LC_cs (defined in ISO) | ISO |
LC_cy (defined in ISO) | ISO |
LC_da (defined in ISO) | ISO |
LC_de (defined in ISO) | ISO |
LC_dv (defined in ISO) | ISO |
LC_el (defined in ISO) | ISO |
LC_en (defined in ISO) | ISO |
LC_es (defined in ISO) | ISO |
LC_et (defined in ISO) | ISO |
LC_eu (defined in ISO) | ISO |
LC_fa (defined in ISO) | ISO |
LC_fi (defined in ISO) | ISO |
LC_fo (defined in ISO) | ISO |
LC_fr (defined in ISO) | ISO |
LC_gd (defined in ISO) | ISO |
LC_gl (defined in ISO) | ISO |
LC_gu (defined in ISO) | ISO |
LC_he (defined in ISO) | ISO |
LC_hi (defined in ISO) | ISO |
LC_hr (defined in ISO) | ISO |
LC_hu (defined in ISO) | ISO |
LC_hy (defined in ISO) | ISO |
LC_id (defined in ISO) | ISO |
LC_ig (defined in ISO) | ISO |
LC_is (defined in ISO) | ISO |
LC_it (defined in ISO) | ISO |
LC_ja (defined in ISO) | ISO |
LC_ka (defined in ISO) | ISO |
LC_kk (defined in ISO) | ISO |
LC_km (defined in ISO) | ISO |
LC_kn (defined in ISO) | ISO |
LC_ko (defined in ISO) | ISO |
LC_lb (defined in ISO) | ISO |
LC_lo (defined in ISO) | ISO |
LC_lt (defined in ISO) | ISO |
LC_lv (defined in ISO) | ISO |
LC_mi (defined in ISO) | ISO |
LC_ml (defined in ISO) | ISO |
LC_mr (defined in ISO) | ISO |
LC_ms (defined in ISO) | ISO |
LC_mt (defined in ISO) | ISO |
LC_ne (defined in ISO) | ISO |
LC_nl (defined in ISO) | ISO |
LC_no (defined in ISO) | ISO |
LC_oc (defined in ISO) | ISO |
LC_or (defined in ISO) | ISO |
LC_pl (defined in ISO) | ISO |
LC_ps (defined in ISO) | ISO |
LC_pt (defined in ISO) | ISO |
LC_qu (defined in ISO) | ISO |
LC_ro (defined in ISO) | ISO |
LC_ru (defined in ISO) | ISO |
LC_rw (defined in ISO) | ISO |
LC_sa (defined in ISO) | ISO |
LC_si (defined in ISO) | ISO |
LC_sk (defined in ISO) | ISO |
LC_sl (defined in ISO) | ISO |
LC_sq (defined in ISO) | ISO |
LC_sv (defined in ISO) | ISO |
LC_ta (defined in ISO) | ISO |
LC_te (defined in ISO) | ISO |
LC_th (defined in ISO) | ISO |
LC_tk (defined in ISO) | ISO |
LC_tr (defined in ISO) | ISO |
LC_tt (defined in ISO) | ISO |
LC_uk (defined in ISO) | ISO |
LC_ur (defined in ISO) | ISO |
LC_vi (defined in ISO) | ISO |
LC_wo (defined in ISO) | ISO |
LC_yo (defined in ISO) | ISO |
LC_zh (defined in ISO) | ISO |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Image Member List

This is the complete list of members for Image, including all inherited members.

$count | Image
$data | Image
$flag | Image
__construct($file=NULL, $flag=FALSE, $path='') | Image
__destruct() | Image
blur($selective=FALSE) | Image
brightness($level) | Image
captcha($font, $size=24, $len=5, $key=NULL, $path='') | Image
contrast($level) | Image
crop($x1, $y1, $x2, $y2) | Image
dump() | Image
E_Color (defined in Image) | Image
E_Font (defined in Image) | Image
emboss() | Image
grayscale() | Image
height() | Image
hflip() | Image
identicon($str, $size=64, $blocks=4) | Image
invert() | Image
overlay(Image $img, $align=NULL) | Image
pixelate($size) | Image
POS_Bottom (defined in Image) | Image
POS_Center (defined in Image) | Image
POS_Left (defined in Image) | Image
POS_Middle (defined in Image) | Image
POS_Right (defined in Image) | Image
POS_Top (defined in Image) | Image
render() | Image
resize($width, $height, $crop=TRUE, $enlarge=TRUE) | Image
restore($state=1) | Image
rgb($color) | Image
rotate($angle) | Image
save() | Image
sepia() | Image
sketch() | Image
smooth($level) | Image
undo() | Image
vflip() | Image
width() | Image
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Log Member List

This is the complete list of members for Log, including all inherited members.

$file | Log | protected
__construct($file) | Log |
erase() | Log |
write($text, $format='r') | Log |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Magic Member List

This is the complete list of members for Magic, including all inherited members.

__get($key) | Magic
__isset($key) | Magic
__set($key, $val) | Magic
__unset($key) | Magic
clear($key) | Magic
exists($key) | Magic
get($key) | Magic
offsetexists($key) | Magic
offsetget($key) | Magic
offsetset($key, $val) | Magic
offsetunset($key) | Magic
set($key, $val) | Magic
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Markdown Member List

This is the complete list of members for Markdown, including all inherited members.

$blocks | Markdown | protected
$special | Markdown |
_a($str) | Markdown | protected
_atx($type, $str) | Markdown | protected
_auto($str) | Markdown | protected
_blockquote($str) | Markdown | protected
_code($str) | Markdown | protected
_fence($hint, $str) | Markdown | protected
_hr() | Markdown | protected
_img($str) | Markdown | protected
_li($str) | Markdown | protected
_p($str) | Markdown | protected
_pre($str) | Markdown | protected
_raw($str) | Markdown | protected
_setext($str, $type) | Markdown | protected
_text($str) | Markdown | protected
build($str) | Markdown | protected
convert($txt) | Markdown |
esc($str) | Markdown |
instance() | Prefab | static
scan($str) | Markdown |
snip($str) | Markdown | protected
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Matrix Member List

This is the complete list of members for Matrix, including all inherited members.

calendar($date='now', $first=0) | Matrix |
changekey(array &$var, $old, $new) | Matrix |
instance() | Prefab | static
pick(array $var, $col) | Matrix |
sort(array &$var, $col, $order=SORT_ASC) | Matrix |
transpose(array &$var) | Matrix |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Prefab Member List

This is the complete list of members for Prefab, including all inherited members.

instance() Prefab static
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Registry Member List

This is the complete list of members for Registry, including all inherited members.

clear($key) | Registry | static
exists($key) | Registry | static
get($key) | Registry | static
set($key, $obj) | Registry | static
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

SMTP Member List

This is the complete list of members for SMTP, including all inherited members.

$attachments | SMTP |
$host | SMTP |
$log | SMTP |
$port | SMTP |
$pw | SMTP |
$scheme | SMTP |
$socket | SMTP |
$user | SMTP |
__construct($host, $port, $scheme, $user, $pw) | SMTP |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
attach($file) | SMTP |
clear($key) | SMTP |
dialog($cmd=NULL, $log=FALSE) | SMTP | protected
E_Attach (defined in SMTP) | SMTP |
E_Blank (defined in SMTP) | SMTP |
E_Header (defined in SMTP) | SMTP |
exists($key) | SMTP |
fixheader($key) | SMTP | protected
get($key) | SMTP |
log() | SMTP |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
send($message) | SMTP |
set($key, $val) | SMTP |
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Session Member List

This is the complete list of members for Session, including all inherited members.

__construct() | Session
agent($id=NULL) | Session
cleanup($max) | Session
close() | Session
destroy($id) | Session
ip($id=NULL) | Session
open($path, $name) | Session
read($id) | Session
stamp($id=NULL) | Session
write($id, $data) | Session
Generated on Fri Jul 5 2013 15:09:17 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Member List

Template Member List

This is the complete list of members for Template, including all inherited members.

$custom | Template |
$hive | View |
$mime | Template | protected
$tags | Template |
$view | View | protected
__call($func, array $args) | Template |
__construct() (defined in Template) | Template |
_case(array $node) | Template | protected
_check(array $node) | Template | protected
_default(array $node) | Template | protected
_exclude() | Template | protected
_false(array $node) | Template | protected
_ignore(array $node) | Template | protected
_include(array $node) | Template | protected
_loop(array $node) | Template | protected
_repeat(array $node) | Template | protected
_set(array $node) | Template | protected
_switch(array $node) | Template | protected
_true(array $node) | Template | protected
build($node) | Template | protected
E_Method (defined in Template) | Template |
extend($tag, $func) | Template |
instance() | Prefab | static
render($file, $mime='text/html', array $hive=NULL) | Template |
sandbox() | View | protected
token($str) | Template |


Fat-Free Framework: Member List

Test Member List

This is the complete list of members for Test, including all inherited members.

__construct($level=self::FLAG_Both) | Test
expect($cond, $text=NULL) | Test
FLAG_Both (defined in Test) | Test
FLAG_False (defined in Test) | Test
FLAG_True (defined in Test) | Test
message($text) | Test
results() | Test


Fat-Free Framework: Member List

UTF Member List

This is the complete list of members for UTF, including all inherited members.

bom() | UTF |
instance() | Prefab | static
ltrim($str) | UTF |
rtrim($str) | UTF |
stripos($stack, $needle, $ofs=0) | UTF |
stristr($stack, $needle, $before=FALSE) | UTF |
strlen($str) | UTF |
strpos($stack, $needle, $ofs=0, $case=FALSE) | UTF |
strripos($stack, $needle, $ofs=0) | UTF |
strrpos($stack, $needle, $ofs=0, $case=FALSE) | UTF |
strstr($stack, $needle, $before=FALSE, $case=FALSE) | UTF |
substr($str, $start, $len=0) | UTF |
substr_count($stack, $needle) | UTF |
trim($str) | UTF |


Fat-Free Framework: Member List

View Member List

This is the complete list of members for View, including all inherited members.

$hive | View |
$view | View | protected
instance() | Prefab | static
render($file, $mime='text/html', array $hive=NULL) | View |
sandbox() | View | protected


Fat-Free Framework: Member List

Web Member List

This is the complete list of members for Web, including all inherited members.

_curl($url, $options) | Web | protected
_socket($url, $options) | Web | protected
_stream($url, $options) | Web | protected
acceptable($list=NULL) | Web |
E_Request (defined in Web) | Web |
engine($arg='socket') | Web |
filler($count=1, $max=20, $std=TRUE) | Web |
instance() | Prefab | static
mime($file) | Web |
minify($files, $mime=NULL, $header=TRUE, $path='') | Web |
progress($id) | Web |
receive($func=NULL, $overwrite=FALSE, $slug=TRUE) | Web |
request($url, array $options=NULL) | Web |
rss($url, $max=10, $tags=NULL) | Web |
send($file, $mime=NULL, $kbps=0, $force=TRUE) | Web |
slug($text) | Web |
subst(array &$old, $new) | Web |
whois($addr, $server='whois.internic.net') | Web |


Fat-Free Framework: Member List

  • Web
  • Geo
Web\Geo Member List

This is the complete list of members for Web\Geo, including all inherited members.

instance() | Prefab | static
location($ip=NULL) | Web\Geo |
tzinfo($zone) | Web\Geo |
weather($latitude, $longitude) | Web\Geo |


Fat-Free Framework: Member List

  • Web
  • OpenID
Web\OpenID Member List

This is the complete list of members for Web\OpenID, including all inherited members.

$args | Web\OpenID |
__get($key) | Magic |
__isset($key) | Magic |
__set($key, $val) | Magic |
__unset($key) | Magic |
auth($proxy=NULL) | Web\OpenID |
clear($key) | Web\OpenID |
discover($proxy) | Web\OpenID | protected
E_EndPoint (defined in Web\OpenID) | Web\OpenID |
exists($key) | Web\OpenID |
get($key) | Web\OpenID |
offsetexists($key) | Magic |
offsetget($key) | Magic |
offsetset($key, $val) | Magic |
offsetunset($key) | Magic |
set($key, $val) | Web\OpenID |
verified($proxy=NULL) | Web\OpenID |


Fat-Free Framework: Member List

  • Web
  • Pingback
Web\Pingback Member List

This is the complete list of members for Web\Pingback, including all inherited members.

__construct() | Web\Pingback |
enabled($url) | Web\Pingback | protected
inspect($source) | Web\Pingback |
instance() | Prefab | static
listen($func, $path=NULL) | Web\Pingback |
log() | Web\Pingback |


Fat-Free Framework: Class Index

Class Index
A | B | C | F | G | I | J | L | M | O | P | R | S | T | U | V | W
A
G
Mongo\Mapper (DB)
S
V
Jig\Mapper (DB)
Audit | Web\Geo | SQL\Mapper (DB) | Session | View
Auth
I
Markdown Mongo\Session (DB)
W
B
Matrix SQL\Session (DB)
Image | Mongo (DB) | Jig\Session (DB) | Web
Base ISO
O
SMTP
Basket
J
SQL (DB)
Bcrypt Web\OpenID
T
C
Jig (DB)
P
L
Template
Cache Web\Pingback Test
Cursor (DB) Log Prefab
U
F
M
R
UTF
F3 Magic Registry
A | B | C | F | G | I | J | L | M | O | P | R | S | T | U | V | W


Fat-Free Framework: db/mongo Directory Reference

  • db
  • mongo
mongo Directory Reference

Files

file | mapper.php
file | session.php


Fat-Free Framework: web Directory Reference

  • web
web Directory Reference

Files

file | geo.php
file | openid.php
file | pingback.php


Fat-Free Framework: db/jig Directory Reference

  • db
  • jig
jig Directory Reference

Files

file | mapper.php
file | session.php


Fat-Free Framework: db/sql Directory Reference

  • db
  • sql
sql Directory Reference

Files

file | mapper.php
file | session.php


Fat-Free Framework: db Directory Reference

  • db
db Directory Reference

Directories

directory | jig
directory | mongo
directory | sql

Files

file | cursor.php
file | jig.php
file | mongo.php
file | sql.php


Fat-Free Framework: doxygen.h Source File

doxygen.h
1
Generated on Fri Jul 5 2013 15:09:16 for Fat-Free Framework by doxygen 1.8.4


Fat-Free Framework: Main Page

A powerful yet easy-to-use PHP micro-framework designed to help you build dynamic and robust Web applications - fast!

Condensed in a single ~50KB file, F3 (as we fondly call it) gives you solid foundation, a mature code base, and a no-nonsense approach to writing Web applications. Under the hood is an easy-to-use Web development tool kit, a high-performance URL routing and cache engine, and support for multilingual applications. It's lightweight, easy-to-use, and fast. Most of all, it doesn't get in your way.

Whether you're a novice or an expert PHP programmer, F3 will get you up and running in no time. No unnecessary and painstaking installation procedures. No complex configuration required. No convoluted directory structures. There's no better time to start developing Web applications the easy way than right now!

Unlike other frameworks, F3 aims to be usable - not usual.

The philosophy behind the framework and its approach to software architecture is towards minimalism in structural components, avoiding application complexity and striking a balance between code elegance, application performance and programmer productivity.

Copyright (c) 2009-2013 F3::Factory Bong Cosca bong..nosp@m.cosc.nosp@m.a@yah.nosp@m.oo.c.nosp@m.om All rights reserved.

This file is part of the Fat-Free Framework (http://fatfree.sf.net).

Fat-Free Framework is free and released as open source software covered by the terms of the GNU Public License (GPL v3). You may not use the software, documentation, and samples except in compliance with the license. If the terms and conditions of this license are too restrictive for your use, alternative licensing is available for a very reasonable fee.

If you feel that this software is one great weapon to have in your programming arsenal, it saves you a lot of time and money, use it for commercial gain or in your business organization, please consider making a donation to the project. A significant amount of time, effort, and money has been spent on this project. Your donations help keep this project alive and the development team motivated. Donors and sponsors get priority support (24-hour response time on business days).

THIS CODE AND INFORMATION ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR PURPOSE.

Please see the license.txt file for more information.